Toon Boom Storyboard Pro 6.0.1 Release Notes

Here is the list of changes in Storyboard Pro 6.0.1, build 14.20.1.13760:

Features & Enhancements

Video Clips

Feature Description
Split clip The Split Clip at Current Frame command can now be used with both video clips and sound clips—see Splitting a Video Clip.
Copy and paste keyframes It is now possible to copy and paste animation keyframes in video clips—see Copying and Pasting Video Clip Animation Keyframes.

Drawing

Feature Description
Auto-Matte on source layer When generating a matte for your artwork using the Generate Auto-Matte dialog, you now have the option to generate the matte directly on the same layer as the artwork instead of in a new separate layer—see Automatically Filling Drawings with a Matte and Generate Auto-Matte Dialog BoxGenerate Auto-Matte Dialog Box
Modifier keys for Stamp and Bitmap Brush tools

The following modifier keys, which could be used when drawing with the Brush tool on a vector layer as well as with the Pencil tool, can now be used when drawing with the Stamp tool and with the Brush tool on a bitmap layer:

  • If you press and hold the Shift key before you start drawing, your stroke will be a straight line.
  • If you press and hold the Shift key while you're drawing, the part of your stroke from that point on will be a straight line until you release the Shift key.
  • If you press and hold the Shift and the Alt keys before drawing, your stroke will be a straight line in an angle that is a multiple of 15 degrees.
  • If you press and hold the Ctrl (Windows) or ⌘ (macOS) key while drawing, your stroke will be a closed shape.
  • If you press and hold the Alt key, your tool will snap in a straight line to the nearest existing shape.

Staging

Feature Description
Enable Action Safe Area and Title Safe Area separately

In the Stage and Camera views, the Safe Area option would display the Action Safe Area and the Title Safe Area inside the camera frame. This option has been split into two options: One to display the Action Safe Area and one to display the Title Safe Area—see Stage View, Camera View and View Menu.

Export

Feature Description
Disable optimization when exporting to Harmony

The Optimize Still Images option was added to the Export to Harmony dialog.

Since Storyboard Pro 6.0.0, when exporting Harmony scenes with a rendered animatic, spans with no layer animation or camera movement would be rendered as a single drawing with its exposure extended. This is now optional. By unchecking this option, you can render your animatic with one drawing per frame.

For more information, see Exporting Harmony Scenes, Export to Harmony Dialog Box.

Use variables in Scene Options when exporting to Harmony

When exporting Harmony scenes, if you use the options in the Scene Options tab to set the path and prefixes to use for rendering the scene's frames, you can now use variables to make the path and the prefix include the project name as well as the act, sequence and scene number. This allows you to make each exported scene have a different image render path and image prefix.

For more information, see Exporting Harmony Scenes, Export to Harmony Dialog Box and About File Naming Patterns.

Burn in Action Safe Area and Title Safe Area separately

When exporting movies, Harmony scenes, PDF documents, EDL/XML/AAF sequences or conformation projects, the Safe Area option would burn in both the Action Safe Area and the Title Safe Area into the exported images and movies. This option has been split into two options: One to display the Action Safe Area and one to display the Title Safe Area

For more information, see Export to Movie Dialog Box, Export to Harmony Dialog Box, Export to EDL/AAF/XML Dialog Box and Export Project / Selected Scenes / Tracked Scenes Dialog Box (Conformation).

Project Structure

Feature Description
Rename Panel script

A new script is packaged, TB_RenamePanelProject, which contains two useful functions:

  • TB_RenamePanelByScene will rename all panels in the selected scene. The panels in each selected scene will be numbered sequentially starting from 1 for the first panel in each scene.
  • TB_RenamePanelProject will rename all panels in the project. The panels in the project will be numbered sequentially starting from 1 for the first panel in the project. The number sequence will continue across scenes, meaning each panel will have a unique number in the entire project.

Because scripts are stored in your preferences and preferences are stored by major version, this script will not be automatically copied to your preferences if you used Storyboard Pro 6.0.0 before. You can copy it manually to your preferences.

Scripting

Feature Description

Documentation

Enhancements were made to the scripting documentation packaged with Storyboard Pro:

  • The style and layout has been updated.
  • A tree view navigation pane was added to the left of the documentation to make navigation easier.
  • Most of the information that is not useful to users, such as private classes and members, hierarchy graphs and file references was removed.

The scripting documentation can be viewed by opening the view menu in the Script Editor view and selecting Help > Scripting Interface Documentation. It can also be viewed online by clicking on the following link:  Storyboard Pro Scripting Reference.

Enhancements

Description

When updating the position of a rendered 3D model, the rotation sphere used to rotate the model will preserve its previous angle. This sphere appears when holding Ctrl + Shift (Windows) or Shift + ⌘ (macOS), then clicking and dragging the model.

The logic for the Random Size parameter of the Brush and Stamp tools has been enhanced so that you no longer need to reduce the minimum size of the brush for the random size parameter to work.

The following enhancements were made to the install wizard on Windows:

  • The installation wizard for Windows is now able to upgrade from a previous version of Storyboard Pro without requiring the user to manually uninstall it first.

  • Installation on Windows is now faster. The installer no longer registers the fonts packaged with Storyboard Pro in Windows. This routine significantly increased installation time and is not required to use these fonts in Storyboard Pro.

Bug Fixes

  • Fixed issue causing Storyboard Pro to initialize the machine’s printer on launch. If the printer’s drivers had issues, they would be triggered when launching Storyboard Pro.
  • Fixed issue where panels with a vertical camera movement would appear cropped in an exported PDF with the Full Page and Expand Panel options enabled.
  • Fixed issue where selecting an audio clip then selecting a video track would add the video clip at the current frame to the selection.
  • Fixed issue causing selected clips to get deselected when moving a selection of video clips on multiple video tracks.
  • Fixed issue causing the selected clip to be deselected where moving a video clip while the timeline cursor is over it.
  • Fixed issue preventing from selecting video and audio clips simultaneously when selecting a video clip first.
  • Fixed issue causing the dialog prompting to import preferences from previous version of Storyboard Pro to appear in English when launching the application in a different language.
  • Fixed issue where, when exporting a movie as a sequence of image files, a directory would automatically be created in the target directory and image files would be exported in it. Exported image files are now saved directly in the target directory.
  • Fixed the differences between the available image formats in the Scene Options tab of the Export to Harmony dialog and the image formats supported by Harmony

    • Added Digital Picture Exchange (.dpx), OpenEXR (.exr), Portable Document File (.pdf) and Deep Texture (.dtex) to the list.
    • Removed Toon Boom Vector Graphics Optimized (.tvgo) from the list.
  • Fixed issue where creating a brush preset with the same name as a previously deleted brush preset would reload the preview of the deleted brush preset.
  • Fixed issue where the tool properties of the Brush tool would not update when selecting a vector or bitmap layer, then adding a layer of a different type.

  • Fixed issue where, when using the Shift or Alt key to draw a straight line with a drawing tool and releasing it while drawing the stroke, a short zig-zag would be drawn near the straight line.
  • Fixed issue where the brush size cursor, which can be enabled in the Tools tab of the Preferences, would appear when using the Stamp tool and would indicate the wrong brush size.
  • Fixed issue causing video clips to be hidden when drawing with the Realistic Preview option enabled.
  • Fixed issue where, when drawing with the Realistic Preview option enabled, new strokes would not display while they were being drawn.
  • Fixed a rare crash when importing certain Alembic (.abc) 3D models.
  • Fixed a potential crash when exporting Harmony scenes with burn-in options enabled.
  • Fixed issue causing rendered 3D models to not appear in exported Storyboard Pro scenes when exporting with the Nest Panels in Symbols option is unchecked.
  • Fixed issue causing application to be invisible on launch if it was exited in a maximized state the last time it was running on macOS.
  • Fixed issue that occurred when exporting a multi-layer Photoshop Document (.psd) file from a project with video tracks. The layers in the PSD file that corresponded to the video tracks would always be underneath all other layers.
  • Fixed issue where, when updating the position of a rendered 3D model, undoing it then attempting to update its position again, the model would appear in the position that was undone in the Update Model Position dialog.
  • Fixed issue where clicking on the artwork of a different layer with the Select tool while holding down the Ctrl (Windows/Linux) or ⌘ (macOS) key would not select that layer.
  • Fixed issue causing groups to be converted to layers when creating a template made from a selection of multiple layers and groups.
  • Fixed issue causing video clips to get clipped when pasting a sound clip in the same time span.
  • Fixed issue causing the project to be shortened by a single frame when adding a transition between scenes while the Preserve project length when adding transitions is enabled.
  • Fixed issue causing colour pots to be temporarily missing from the Colour view when copying panels from an existing project and pasting them to a new project.
  • Fixed issue causing layers in imported Photoshop Document (.psd) files to be ignored if their opacity is below 9%.
  • Fixed issue where movie files exported with a frame rate of 23.976 FPS would have an extra frame.
  • Fixed issue where burn-in would sometimes not appear in exported Harmony scenes.
  • Fixed issue causing the LayerManager.isEmpty method to return the opposite value.
  • Fixed issue causing the LayerrManager.generateMatteLayer method to return true when using a radius of 0, which fails to generate a matte.