Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 19: Effects > Using Effects > Quadmap
Download Toon Boom DocumentationDownload Documentation

Quadmap

Use the Quadmap transformation layer to deform the shape of an element. For example, you can use it to create a drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.

To edit the Quadmap the Camera view:

1. In the Timeline view, click on the Add Layer button and select Quadmap from the drop-down menu.
2. Connect the Quadmap layer to the drawing layer that you want to deform, or in the Network view, drag in the Quadmap module from the Module Library and connect it above the drawing element module that you want the effect to act on.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire duration of the element.
4. In the Timeline view, click on the Quadmap layer to select it.
5. Select View > Show > Control or press [Shift] + [F11].

The quadmap handles appear around the element in the window. There is also a pivot point at the centre of the quadmap frame that can be repositioned.

6. In the Camera View window, use the Transform tool to move the points on the quadmap. [Shift] + click to select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap module Layer Properties to attach the points to function curves.

Only the X and Y values of each point in the quadmap can be changed.

2D Path: change the X and Y values simultaneously and control the velocity of the change.
Separate: change the X and Y values separately. Each of these can be attached to separate function curves.

Related Topics 

Using Effects