Release Notes > Storyboard Pro 4.0

Chapter 9: Storyboard Pro 4.0


Here are the new features and improvements in Storyboard Pro 4.0.

Bitmap Drawing Tools and Bitmap Layers
Brush Presets
Tool Presets
Colour View Enhancements
Picking Composite Colours
Playback Enhancements
Collaboration Tools
Integrated 3D Technology
Paste and Spread Camera
Export to Toon Boom
Timeline View Interface Enhancements
Pitch Mode
Clock Wipe Transition
Edge Transition
General Improvements
Moved, Removed and Renamed Features


Storyboard Pro technology is now supercharged on a 64-bit core. This gives you the freedom to use more of the computer’s resources, and allows the use of the new bitmap technology. You’ll also see improvements on the number and size of images that can be imported into a project.

Bitmap Drawing Tools and Bitmap Layers

Adding Bitmap Layers
Converting Layers
Drawing Tools Available
Blurring Bitmap Layers

In Storyboard Pro, you now have the ability to draw directly in the software using bitmap drawing tools. In addition to the time-proven vector tools, you can draw with different styles and textures for full artistic freedom.

Create brushes with imported textures, and adjust a variety of parameters like flow, hardness, spacing, and many others to get a custom look.

When you create a bitmap drawing layer and use the bitmap tools on this layer, you are drawing with the raw pixels instead of drawing with vector strokes. This behaves more like when you draw with a pencil on paper. If you want to erase part of the drawing, just use the eraser tool.

Bitmap layers allow you to create 2D graphics. The bitmap lines you create are composed of pixels on a grid that resemble tiny dots, which altogether make up the drawing you are creating or artwork you are importing. Bitmap graphics impart a more natural and soft look to your work. The colour is defined on a pixel-by-pixel basis.

Drawing on a bitmap layer is similar to drawing with a bitmap tool in Photoshop or Painter. You can select and move bitmap strokes. However, layering strokes on top of each other will merge (flatten) them. Instead of drawing lines, you are laying down the individual pixels. This gives you finer control over the brush itself, as well as the shading and colour of the drawing. However, the strokes cannot be edited with the Contour Editor or Perspective tool. It is more efficient for storing texture information than a textured brush on a vector layer, so if you are creating drawings with a lot of texture, this may be a better option.

Advantage: File sizes are not as heavy as when you use textured brushes on a vector layer, since each stroke does not have to be remembered individually. Also, you have full artistic control over the style of the drawing.
Disadvantage: You cannot modify the lines after you draw them. Simply draw and erase, like you would on paper. Also, it can be difficult to reuse the drawing at multiple distances.
Recommended Use: When creating drawings with a lot of texture, for a natural media feel. Particularly when you want a wide variety in colour and shading, this is where you will see the real advantage.
NOTE: Images are now imported in bitmap layers.

Adding Bitmap Layers

You can add an unlimited number of layers to a panel.

Converting Layers

If you started with one type of layer, such as vector, you can always switch it to use a bitmap layer and vice versa.

NOTE: When you convert from vector to bitmap, the vector data is lost, so if you convert back to vector, what you get is a vector region with a bitmap inside of it

Drawing Tools Available

Depending on the type of layer you select, here are the tools available:


Vector Layer

Bitmap Layer

Select By Colour  
Contour Editor  
Edit Gradient/Texture  
Paint Unpainted  
Close Gap  

Blurring Bitmap Layers

If the layer you want to blur is on a vector layer, you must first convert it to a bitmap layer—see Converting Layers.

Brush Presets

The brush properties available depend on whether you are drawing on a vector or bitmap layer. On both layers, you can set the minimum and maximum sizes of your tool, which produces the thick and thin effect on your line. This works with the pressure sensitivity of a pen tablet.

On vector layers, you can modify the central line smoothness of your line, as well as smooth the initial movement of your line. Increasing the value will result in a smoother line with fewer control points.

On bitmap layers, you can optimize the flow of lines and set the rate at which colour is applied as you draw. As you draw over an area, the amount of colour builds up based on the flow rate, up to the maximum flow rate you set.

Spacing: Controls the spacing between the brush marks of a stroke.
Hardness: Controls the size of the brush's hard centre.
Texture Scale: Determines the size of the texture used in strokes.

Brush presets are created by saving the properties of the current brush to a new preset, which you can reuse for repeated tasks. You can create as many brush presets as you need.

To access the brush presets:

From the Panel view, click the View menu and select Tool Properties.

Brush Display

Tool Presets

Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often. That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line.

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the option of saving the colour and assigning a shortcut, which you cannot do with brush presets.

The Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them. There are four default brush presets to get you started—Rough, Clean, Shading, and Revision. By default, this toolbar is not displayed.

Colour View Enhancements

To paint drawings and select colours, you will be using the Colour view located at the bottom of the Tool Properties view. The Current Colour swatch at the top-left corner indicates the current colour. You can modify the current colour and opacity using the sliders beneath, or double-click the Current Colour swatch to open the Colour Picker for more possibilities.

If you are going to frequently use a colour, you can save this colour for reuse by creating a colour swatch out of it.

NOTE: Once added, a colour swatch can no longer be modified. You must delete the swatch and add a new one.

Default Colour Palette

Once you have established the colours to be used throughout your storyboard, you can save it as your default colour palette for the project. You can also import and export colour palettes so that everyone on your team is using the same colours.

NOTE: Toon Boom colour palettes are appended with a .plt extension.

Picking Composite Colours


Storyboard Pro now allows you to organize your project into four divisions: Acts, Sequences, Scenes, and Panels. The addition of the Sequence level allows you to gather scenes that take place at the same location. For Live Action terminology, this breaks down into Acts, Scenes, Shots, and Panels. Storyboard Pro allows you to define whether you prefer to use Animation terminology or Live Action terminology. This information is included when you export to PDF or CSV.

  1. A panel represents an action. You can use multiple panels whenever you need more than one drawing to clearly express the acting within a scene. It is the white rectangle representing the camera view. By default the current panel will be highlighted in red in the Thumbnails view.
  1. A scene is composed of one or several panels. In animation, whenever the camera angle changes, you should create a new scene. In live action, this is called a shot.In other words, if your action goes from a mid shot to a close shot, each of these shot should be a different scene. By default, a grey rectangle connects the different panels of a scene together.
  1. A sequence is a series of scenes that should be grouped together. Usually, scenes are grouped together by location. For example, all the scenes that are taking place in one location, should be in the same sequence and as soon as there is a change of location, it should be a new sequence. by default, a blue line connects the different scenes of a sequence together.
  1. An act is composed of one or several scenes and sequences. An act usually represents a story arc. It can be a certain time lapse in the story. For example, all the scenes in the first half of a TV series are one act, and the second act is after the commercial break. As for movies, live action, or even video games, there could have several different story arcs. In Storyboard Pro, a purple flag shows the beginning of a new act.

Playback Enhancements

Storyboard Pro has made significant improvements in playback in this newer, faster version. New playback preferences allow you to play back smoothly and without hitching when a complex panel is encountered. This means when you play back, you hear the sound at the right timing, and the panels play back at the correct speed.

Collaboration Tools

Storyboard Pro has integrated new collaboration tools which allow multiple users working on a project to collaborate. A master project can be split into separate smaller projects, worked on individually, and then merged back together again. A new Advanced Merge feature replaces the existing scenes in the master project with the new, merged scenes. Storyboard Pro allows you to:

Split a Storyboard
Extract a Storyboard
Merge a Storyboard
Inserte a Storyboard
Merge and Replace Scenes

Integrated 3D Technology

Storyboard Pro gives you the ability to work in a 3D space, directly integrated. Enable this feature to work in a 3D space, import 3D models, and export to FBX. You can always keep working in Storyboard Pro as before or turn on the 3D tools when you’re ready to experiment with the 3D technology.

When you export a 3D element in FBX format, any textures you applied to it are included and will appear in the Shaded view. You can see it when you import the 3D element in Storyboard Pro and drag it into a scene. Also, if the 3D elements have pivot points, you can manipulate the objects using pivot points

Paste and Spread Camera

When the Camera > Camera by Panel Compatibility Mode preference is enabled, alternative commands become available in the Camera menu:

Paste and Repeat Camera on Selected Panels: Pastes the copied keyframes and fits them into the selected panel. If multiple panels are selected, the keyframes repeated in each of them.
Paste and Spread Camera on Selected Panels: Pastes the copied keyframes and spread them across all the panels of the selected scene.

Export to Toon Boom

Storyboard Pro allows to export to Toon Boom Harmony, Animate 2 and Animate Pro 2.

  1. In the Export Type section, select the Toon Boom animation software in which you want to export.
NOTE: To determine if your export will be created for Harmony Server or Harmony Stand Alone, in the Format menu, select the Offline option for a stand alone export or To Database for a server format. Depending on the Harmony version you have, select either 7.8 or 9.2 or higher.
Select Original Scene to export your storyboard in a project where the vector drawings, layers and camera settings are kept as is. For each shot or scene in your storyboard, a Harmony/Animate scene is created.

Timeline View Interface Enhancements

Pitch Mode

When pitching your storyboard, it is helpful to use Storyboard Pro to visually present your story or concepts. Storyboard Pro provides a workspace designed specifically for this called the Pitch Mode workspace.

Clock Wipe Transition

By default, the Clock wipe will pass from one scene to the other with a circular clockwise wiping motion. It is possible to customize the direction of the wipe as well as the starting angle.

Edge Transition

By default, the Edge Wipe will pass from one scene to the other with a wiping motion from left to right. It is possible to customize the effect to change the direction of the wiping motion.


Storyboard Pro 5.1 can open files created with previous versions of Storyboard Pro. However, once the files are saved in Storyboard Pro 5.1, they can no longer be opened in Storyboard Pro 1.5, 2, and Storyboard Pro 3D.

General Improvements

Select tool now remembers the selection when switching between layer or panel and coming back
New keyboard shortcut to increase [ ] ] and decrease [ [ ] the Brush and Pencil size
General Tool Properties view behaviour has been reviewed for the following tools: Brush, Pencil, Eraser, Ellipse, Rectangle and Line
Cutter tool now has an option to turn aliasing on or off while cutting drawing strokes on bitmap layers
Stage scenes can be imported via the File menu to create Storyboard Pro projects
New Camera menu
New Camera toolbar
While moving the camera frame, its direction can be constrained when holding Shift down
Panels can now have more than four snapshots
Sound tracks can now have an unlimited amount of volume keyframes
Volume keyframes can be deleted by holding down the Alt key and clicking
Volume can now be increase using the volumne keys
New tab in Preferences dialog box called Naming
New option to set the DPI when rendering panels in the PDF export
Mouse scroll wheel can now be used to zoom in the Stage view
Contextual menu when right-clicking in the Thumbnails view
New Bitmap Resolution tab in the Project Properties dialog box
New submenu in the View menu called Extras

Moved, Removed and Renamed Features

Brush Preset toolbar has been renamed Tool Preset
Brush Preset view has been removed
Pencil Editor tool has been removed
Overlay tab in Export dialog boxes has been renamed Burn-in
Storyboard menu has been rearranged
Storyboard toolbar has been rearranged
Import commands have been moved to the File menu