Chapter 8: Toon Boom Storyboard Pro 4.1 (10.2.1.8451)

 

Here are the new features and improvements in Storyboard Pro 4.1.

Improvements
Editing in Storyboard Pro
3D Workflow Improvements
Other Features and Changes

Improvements

Touch Gestures
Changing the Brush Tool Cursor Display
Reframe Tool
Vectorization Options
Merging and Replacing Scenes
Importing and Exporting
Export to EDL/AAF/XML

General

The Go to Scene command has this shortcut assigned: Ctrl+F (Windows) or ⌘+F (Mac OS X).
Changed full screen mode shortcut from [CTRL]+[F] to Ctrl+Alt+Shift+F (Windows) or ⌘+Alt+Shift+F (Mac OS X).
Changing a 3D layer display option is now undoable.
The layer name is now highlighted in the Rename Layer dialog to allow for quicker edits.
Added the following commands to the layer menu, layer toolbar and layer category in shortcut list:

Layer > Pivot > Center Pivot to Selection

Layer > Pivot > Reset Pivot

Touch Gestures

Toon Boom Storyboard Pro supports touch gestures. Once touch gesture is enabled in your project, you can use these main gestures to navigate in the interface using a supported touch device:

Use a two-finger pinch to zoom.
Use two fingers to rotate and pan.
Touch Gesture Preferences

The preferences for touch gestures is on the General tab of the Preferences dialog box.

This preference is disabled by default. When enabled,you can use the main gestures to navigate in the interface using a supported touch device.

Support Gesture: Enables touch gesture.
Invert Scroll Direction: Inverts the touch motion used to scroll up and down.
Gesture Sensitivity: Defines the level of sensitivity recognized.

Changing the Brush Tool Cursor Display

By default, the Brush tool cursor is displayed as a crosshair. You can change it to display the shape of the current brush size.

Reframe Tool

The Reframe tool allows you to set the position of the content of the panels for the entire scene so it fits the camera frame you define.

NOTE: When setting the camera frame using the Reframe tool, it is not possible to reset it to its former position.

Vectorization Options

By default, when you import an image into your project using either the Import Image as Layers or Import Images as Scenes commands, the imported images will be vectorized in colour and fit the camera frame. The image resulting from a colour vectorization will appear exactly as the original picture.

With the Storyboard Pro, more options are available which give you better control over the vectorization of imported images. To access these options, you must first select the Display Vectorize Options Dialog option in the Preferences dialog box.

Merging and Replacing Scenes

NOTE: When merging projects, the sounds in the master project will now move in order to sync with the panels.The sounds will follow panels based on their name, therefore, it is important to lock scenes and panels names prior to distributing the different scene's extracts, in order to preserve them.

There are two new options in the Advanced Merge Storyboard dialog box:

The Respect locked audio track option ensuresthat the locked audio tracks will not be synced during the merge and replace. When deselected, audio tracks will be synched regardless if they were locked or not.
The Import audio changes from source project option allowsthe modifications done in the audio to be applied to the scenes that are replaced.

 

Tools

Options were added to the Transform tool properties to turn the translation, scale and rotation controls on or off.
Added gesture support in the Cutter tool for deleting stubs.

Timeline and Animatic

While changing the duration of a sound clip or panel, you can see the difference between the original length and what is to be set. This is displayed as a positive (or negative) value in brackets while the clip is being resized. You can see this value in timecode or in frames by modifying your preferences.
Multiple sound clips on multiple sound tracks can now be selected at the same time by drawing a selection marquee around the clips in the Timeline. Using the Shift key while selecting in this way to add your selection to the current selection.

Library

Sounds can be played from the library in the same way that templates and swf files can be played. Double-click the sound, then click the Play button in the preview section.

Importing and Exporting

Change default encoding for text caption when export to PDF to prevent having special characters replaced with question marks.
Improved multithreading support to reduce time required to render movies. Depending on the hardware, movies are now two to six times faster to render.
Export Volume Keyframes to XML for Final Cut Pro.
Added file name pattern field when exporting to FCP conformation.

File name pattern field was added to the XML conformation export. This pattern is used for the name of the images exported. The following variables can be used:

%t : Project Title.

%a : Act name. When acts are enabled.

%q : Sequence name. When project contains sequences.

%s : Scene name.

%p : Panel name.

%l : Layer name. When exporting one image per layer.

A number can be typed between the % and the letter to define the minimum number of characters used.

Added option to export camera frame when exporting an XML for Final Cut Pro conform. (File > Conformation > Export Project).
Added scene name pattern field to define scene names when exporting to Harmony.

A field has been added in the Export to Toon Boom dialog that can be used to define the pattern used to name the Harmony scenes created. When left blank, the default pattern is used. The default pattern is different base on the selected export type (One scene per scene, sequence, act). Default patterns are as before.

The following variables can be used to define the scene name pattern:

%t : Project Title

%a : Act name. When acts are enabled.

%q : Sequence name. When project contains sequences.

%s : Scene name.

A number can be typed between the % and the letter to define the minimum number of characters used. For example, for a scene named 16:

MYPROJECT_SC%4s : This will create a scene using the MYPROJECT_SC prefix + scene name using 4 characters, padding with zeros = MYPROJECT_SC0016.

Export to EDL/AAF/XML

  1. In the Export Range tab:

Decide whether you want to export the entire project (All), a selected frame range, a selected scene, a selected panel, or tracked panels. If you decide on the latter, be sure to enter the frame range in the fields provided. In the Scene Picker dialog box, you can select scenes by sequence if your project contains sequences.

  1. In the Burn-in tab:

Print Time Code: Prints the project timecode on the video as an overlay on your video.
Print Scene Names and Panel Numbers: Prints the scene names and panel numbers as an overlay on your video.
Print Additional Duration: Prints an additional duration on your video, defined by the Units and Repeat menu.
Units: Displays additional duration information using Time Code or Frames units.
Repeat: Displays additional duration information per panel, scene or sequence.
  1. In the Camera Grids tab, do the following:

Project Safety: Prints the safe area on your video.
4:3 Safety: Prints the 4:3 safe area on each panel of your storyboard that has a camera movement.
4:3 Reference: Prints the 4:3 area on each panel of your storyboard that has a camera movement.
  1. Select the Open document/folder after export option to view the file when it is ready.

Editing in Storyboard Pro

Setting the Panel's In or Out to the Current Frame
Locking the Scene Duration
Selecting Panels and Sound Clips Forward
Marking Sound Clips with Custom Colours
Setting the Panel's In or Out to the Current Frame
Recording a Sound Guide
Displaying and Adjusting the Volume Envelope
Slide Transition
Other Features and Changes

Setting the Panel's In or Out to the Current Frame

You can adjust the duration and position of a panel by moving its in and out points to a specific frame determined by the current position of the playhead.

NOTE: Note that the frame you specify must be contained within the current position of the panel you want to change the in or out point of.

Locking the Scene Duration

You can lock the duration of all scenes in your project with the Lock Scene Duration command. This ensures that the length of every scene is preserved when adding, duplicating, or deleting panels.

Selecting Panels and Sound Clips Forward

By using a series of keyboard shortcuts, you can:

Select all panels forward.
Select all panels and all sound clips forward.
Select all sound clips on a single sound track forward.
Select all sound clips and all sound tracks forward.

Marking Sound Clips with Custom Colours

Marking sound clips with a custom colour allows you manage them and quickly identify them. This option is also available for marking panels

Setting the Soundtrack Size

By default the size of the soundtracks is set to small, but you can modify the size of the different soundtracks of your project individually to increase or decrease their heights.

Recording a Sound Guide

You can record sound directly from Storyboard Pro and insert it in the timeline.

Displaying and Adjusting the Volume Envelope

Volume keyframes are no longer added automatically while clicking on a sound clip. To add or remove a volume keyframe, hold [Alt] and click. The pointer changes to indicate if a keyframe will be added or removed. This prevents you from the accidentally adding or removing volume keyframes while dragging sound clips.

Slide Transition

By default, the Slide transition will pass from one scene to the other by translating the next scene panel from the right side of the camera frame. It is possible to customize the angle and direction.

Other Features and Changes

In the Timeline view, the total duration of the project is now displayed under the current timecode.
The Timeline playhead no longer changes frames when clicking on sound tracks.
Fixed problem with sound clips on new tracks not syncing after merging.

3D Workflow Improvements

Replacing a 3D Model in the Library
Align Camera Key with Stage View Position
Coordinate Toolbar
Exporting to FBX
Additional 3D Improvements

Replacing a 3D Model in the Library

Once you have imported a 3D model in the Library, you can easily replace it with a new one using the Replace 3D Model command. This will update all instances of the model used in the project.

 

Align Camera Key with Stage View Position

Fits the camera frame to the current space available in the Stage view while retaining its original ratio, which is very useful in 3D scenes. You can also select Camera > Align Camera Key with Stage View Position.

Coordinate Toolbar

You can also use the Coordinate Toolbar, which displays the current translation, scale and rotation values of a selected layer, as well as allowing you to type specific values for each of these parameters. This toolbar is available from the top menu by selecting: Windows > Toolbars > Coordinate.

Translation

The translation field displays the X, Y and Z translation values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame position of a layer. By default the Z value field is disabled, it will automatically become active when the 3D option is enabled.

Scale

The scale field displays the X, Y and Z scaling values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame size of a layer. By default the Z value field is disabled, it will automatically become active when the 3D option is enabled.

Rotation

The rotation field displays the X, Y and Z rotation values of the selected layer. You can use these fields to type in precise values to set the first frame and last frame rotation of a layer. By default the X and Y value fields are disabled, it will automatically become active when the 3D option is enabled.

Exporting to FBX

When exporting your storyboard to FBX:

You can now export one clip per scene, export one clip for the entire project, or export one clip per sequence (this option is only available in there sequences in your project).
You can include only the scenes from the sequence you selected when you opened this dialog box. This option will only be visible if your project contains sequences.

Additional 3D Improvements

When animating a 3D element in the 3D space, you can also make a multiple selection to move multiple 3D layers at once.
When deleting a 3D model from the 3D Models folder of the Library, every instance of the model used in the project will be deleted at once. A warning message will prompt you to confirm or cancel the action.

Other Features and Changes

Interface
Layers
Drawing
Exporting Your Storyboard

Interface

The Pivot tool has been removed. The pivot can now be moved using the First Transform and Last Frame Transform tools.

Layers

There are two new options for displaying objects on 3D layers:

Wireframe on Shaded: The 3D objects displays the textures with its wireframe on top.
Wireframe on Flat: The 3D objects displays the surface with its wireframe on top.

Drawing

When the light table is activated, all layers apart from the currently selected one are shown in washed-out colours in the Stage and Camera views and when using the layer tools.

Exporting Your Storyboard

When exporting your storyboard to PDF, there are two new layouts in the Export to PDF dialog box:

This layout consists of a total of 5 panels per page, aligned on the left side of the page. Captions are organized on the right size of each panel. This export also includes a cut and a duration column, and displays the duration of each scene at the beginning of every new one.
This layout consists of a total of 80 panels per page, organized in ten rows of four. No caption is included.

When exporting your entire storyboard project to Final Cut Pro:

You can now export the camera frame's black border.
You can include additional burn-in information including:
Print Additional Duration: Prints an additional duration on your video, defined by the Units and Repeat drop-down menu.
Units: Choose either you want the additional duration information to be displayed using Time Code or Frames units.
Repeat: Choose either you want the additional duration information to be the duration per Panel, per Scene or per Sequence.

Bug Fixes

Fixed the Select tool that was not allowing you to select drawings on layers from multiple panels.
Fixed double-click on project file that was opening the Welcome screen and not the actual project.
Fixed crash when converting a vector layer to bitmap when there is a perspective selection.
Fixed case that was causing the undo queue to stop working after right-clicking in the Timeline view.
Fixed undo that was selecting the first panel in the project.
Properly remember when "Per Act" is selected in the Export to Toon Boom window.
Fixed Paste Layer Special that was pasting layers in the reverse order.
Fixed Timeline view that was scrolling too fast when moving the playhead to the left edge.
Fixed crash when using Cutter tool on flattened brush strokes.
Fixed ALT+SHIFT modifier using the Brush tool that was not drawing a straight line in increments of 15 degrees.
Fixed potential freeze when exporting to FBX.
Fixed AFF export on Windows that was not working.
Fixed a problem that caused sound layer to not synch with panels when moving them in the Timeline.
Fixed image preview that was distorted in the Import Images window.
Fixed XML export (File > Export > EDL/AAF/XML) that was causing problems connecting movies in Final Cut Pro.