Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 19: Effects > Particle Effects > Particle Effect Modules > Visualizer

Visualizer

This module renders and flattens the particle system down to a single plane. You can plug a peg module into the left-hand port here to animate the position of the whole particle system. Plugging a peg into the right-hand port will move the depth where the flat plane is generated, so you could adjust to move it behind or in front of various other drawing layers in your scene. You could even have two visualizers with pegs in the right in-ports that are at different depths, to display some particles in front of and some particles behind a character or drawing in the scene.

Layer Properties

Use the Visualizer's Properties panel to adjust the effect's parameters.

Force Render as Dots: You may want to temporarily render your system as Dots when previewing a simulation, so you can check this checkbox to ignore all drawings and force the whole system to render as dots.
You may also use the option View > Particle > Show Particles as Dots in OpenGL. If this option is enabled, the particles will always be displayed as dots in the OpenGL preview mode. This will make the playback speed faster when running a heavy scene.
Rendering Order: This is where you can set the order that you want the particles to appear in the render.
Back to Front: Added particles will appear behind existing particles.
Front to Back: Added particles will appear in front of existing particles.
Oldest to Youngest: Older particles will appear behind younger particles.
Youngest to Oldest: Older particles will appear in front of younger particles.
Ascending Types: Lower types will appear behind higher types.
Descending Types: Lower types will appear in front of higher types.
Fix Output Alpha: This is an important checkbox to check when using some filters like Screen or Multiply in the Blend Mode that can be specified in the Rendering tab of the Emitter. When working with pre-multiplied images, if the alpha is not fixed in the visualizer, you can get some strange artifacts.

Related Topics 

Particle Effect Modules