Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 12: Scene Setup > Setting Up the Network > Network Navigation and Basic Rules

Network Navigation and Basic Rules

The basic rules of the Network view are quite simple. Once you understand them, a lot can be accomplished.

Related Topics 

About Modules
Input and Output Ports
Adding Modules
Composite Module
Organizing Modules
Connecting and Disconnecting Modules
Cable Styles
Navigator Display

About Modules

About Modules

Each element in the Network view is called a module. There are several different types of modules:

Module

Description

Drawing Transfers drawing information.
Effect Processes effects on drawings and transfers drawing information.
Input/Output Act as the interface between each module and network.
Move Controls the camera and element transformations over time.
Compositing Combines multiple source images.

Input and Output Ports

Each module has an input port at the top and an output port at the bottom. Some are blue and others are light-green or bright green.

Blue denotes drawing information.

Light Green denotes position and movement.

Bright green shows the element on top of the composition and outputs that element’s Z position to the Composite module. When many elements have different Z positions (multiplane, different distances from the camera) and are placed through a Composite module that flattens them together (producing one image with one Z value), the system needs to give a Z position to this new image. It uses the bright green port information.

Finally, some modules contain more than one Input port. These are usually Effects modules needing different drawing or position information in order to perform their calculation. When the two ports are blue, the Drawing is on the right and the Matte is on the left. If it is light green, the drawing needs extra position information.

Adding Modules

Each module used to build a network is available in the Module Library view. In addition, each time you create a layer from the Timeline or Xsheet views, the corresponding module is created in the Network view.

To import modules from the Module Library:

In the Module Library, select a module and drag it to the Network view.

Composite Module

The Composite module is used to take several images and output a single image. You can compare that to doing pre-compositions in some editing software. You connect several drawing modules in your Composite module and one bitmap comes out of it.

By default, the image coming out of the Composite module is a bitmap. The layers are composited together depending on their position on the Z-axis (forward-backward) first, then their order in the Composite module. If two images are at the same position on the Z-axis, their order in the Composite will determine which one is displayed in front and which one is displayed behind.

 

Organizing Modules

When you are working in the Network view and adding many modules, your scene may look a bit messy and be difficult to follow. To fix this, Harmony provides the Order Network script which organizes and displays the modules in a more orderly fashion.

To organize your network:

1. In the Network view, select some or all of your modules.

2. Display the Scripting toolbar by selecting Window > Toolbars > Scripting.
3. Click the Order Network Up or Order Network Down button.

The Order Network Settings dialog box opens.

4. Set an X Overlap% value.
5. Set a Layer Spacing value.
6. Set a Vertical Spacing value.

Connecting and Disconnecting Modules

Making or removing connections between modules is as easy as a click and drag.

To connect modules:

1. In the Network view, extend a cable from the first module’s output port and connect it in the second module’s input port. You can also select the module to connect, hold down the [Alt] key and drag the module on an existing cable.

To disconnect modules:

1. In the Network view, pull a cable away from the module’s input port. You can also select the module to disconnect, hold down the [Alt] key and drag the module away.

Cable Styles

You can customize the look of the cables in the Network view to fit your style of working.

Bezier

The Bezier cable style displays the cables as curved lines.

To switch to Bezier cable style:

In the Network View menu, select View > Cable Style > Bezier.

Line

The Line cable style will display the cables as straight lines.

To switch to Line cable style:

In the Network View menu, select View > Cable Style > Line.
Refer to the Scene Setup Preferences topic to learn how to set the cable style in the Preferences panel.

Navigator Display

The Navigator is a small square window inside the Network view that displays a thumbnail of your current network. The current view displayed in the Network window is shown framed in the Navigator display. You can drag this frame to pan your current Network view display.

Showing and Hiding the Navigator

You can show or hide the Navigator from the Network view.

To show and hide the navigator:

In the Network View menu, select View > Navigator > Hide Navigator or Show Navigator. Or press [Ctrl] + [Shift] + [W] (Windows/Linux) or [⌘] + [Shift] + [W] (Mac OS X).

Positioning the Navigator

The Navigator display can be placed in any corner of the Network view.

To position the navigator:

In the Network View menu, select View > Navigator > and choose from Top Left, Top Right, Bottom Left, Bottom Right.
Refer to the Scene Setup Preferences topic to learn how to set the Navigator display options in the Preferences panel.

Related Topics 

Composite Layer Properties
Grouping Modules
Enabling and Disabling Modules
Module Thumbnails