Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 9: Import > Exporting and Re-Importing a PSD Layout > Exporting a Layout

Exporting a Layout

It is necessary to have all of your elements well positioned before you export your layout. If you plan to have a camera movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear and complete layout.

You could also create all of the layouts for your production in the same Toon Boom Harmony project. These layouts can be imported later on when you start each scene’s project, this will help setup this will help to setup the scene and begin it’s creation. These layout PSD files can also be used to create the background art of each scene and make sure everything is correctly framed and at the right size. Finally, you can also have a layer containing a drawing of the rough poses of the character or action and generate your layout posing from there.

Note that only the first frame of your drawing layers will be exported, as the layout image is one static PSD file.

Refer to the following chapters to learn more about scene setup, camera moves and drawing:

Drawing
Scene Setup
Animation Paths

To export your scene as a Layout:

Before you do this you should position your background elements, and everything you need as a reference in your scene, including a camera movement.

1. Select File > Export > Layout Image to export all the elements of your scene in the layout PSD file
or if you want only the selected elements to be exported then select File > Export > Layout Image from Selection.

The Export Layout Image dialog box opens.

2. In the Export Layout Image dialog box setup the export parameters:

Output: In the output section, use the Browse button to select a location where to save your layout and name the resulting PSD file.

Image Size: This section displays the size of the PSD image file that will be exported. The resulting image will be 72 dpi as the standard television resolution and its size in pixel will fit your scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note that if you have a camera movement going over the normal camera frame limit, for example a pan, the image will be bigger.

Options:

Export Camera Frame: This option is disabled by default. You can enable it to export an additional layer to your PSD file displaying the camera frame on it.

Add a Camera Frame for each Key Frame:


This option is disabled by default, meaning that if you have a camera movement with more than a starting and an ending point, only these positions of the camera frame will appear on the camera layer of the exported layout PSD file. You must enable this option if you need to the in-between keyframes to also be displayed.

Label Camera Frame:


Enable this option to add the camera position label in the top corner of the camera frames. The camera label is a single alphabet letter determining the order of the camera frame position.

Add Border to Layout:


This option is disabled by default, meaning the layout image will take the complete PSD area, cropped at the very edge of the canvas. You can enable this option to add a transparent area all around the layout. You must setup the size of this area by using the Scale field lower. The resulting image will be larger.

Scale: Use the Scale field to set the size of the transparent border around the layout image. By default the value is set to 100%, meaning that the image will be exported as is with no transparent area around it. When you increase the percentage value the extra space will be added around the image to create the border.
Adjust Scaling Factor: This option is enabled by default, meaning that when you have a camera zoom movement, the size of the layout image will be adjusted accordingly. The resulting percentage will be calculated following the maximal camera zoom value appearing in the layout. This allows the image to be exported at an appropriate resolution, preventing the layout image from appearing pixelated or blurry when the camera zoom occurs. You can disable this option to export the image layout at the normal size.
Scale: When the Adjust Scaling Factor option is enabled, the Scale value is automatically calculated according to the maximum camera zoom in your layout. You can modify this value.

Vector Options: If you export one or more vector-based drawing layers in your layout image, you have the option to export only the drawing layers you want. Enable or disable the following options to export or prevent the export of the corresponding art layers.

Overlay: Enable this option to export the art contained in the Overlay layer of the drawings to be exported to the layout image. Disable this option to prevent this art layer from being exported.
Line Art: Enable this option to export the art contained in the Line layer of the drawings to be exported to the layout image. Disable this option to prevent this art layer from being exported.
Colour Art: Enable this option to export the art contained in the Colour layer of the drawings to be exported to the layout image. Disable this option to prevent this art layer from being exported.
Underlay: Enable this option to export the art contained in the Underlay layer of the drawings to be exported to the layout image. Disable this option to prevent this art layer from being exported.
3. Click OK to validate the settings and export a PSD file of your layout.

The resulting image will be a PSD file containing either one or two layers, each of which is contained in a corresponding group. These groups make the layout PSD file ready for a multi-layer PSD import.

Camera_Set: This group contains the camera drawing layer. This group and layer will only appear in your layout image if you enabled the Export Camera option during the export.
Layout_Set: This group contains a merged drawing layer of all the content of your scene’s first frame when you exported the layout image.
Along with your PSD file will be exported an XLI file. Do not delete this file and always keep it at the same location as the layout PSD file. These two files should not be renamed. This XLI file contains all the necessary information to be able to correctly import and automatically position your layout image in an Toon Boom Harmony project.

Refer to the next topic Importing a Layout to learn how to import a layout image in Toon Boom Harmony.

Related Topics 

Importing a Layout
Exporting and Re-Importing a PSD Layout