Paint Guide > Toon Boom Harmony 10 Paint User Guide > Chapter 4: Clean Up and Drawing Tools > More Drawing Tools

More Drawing Tools

Harmony offers a wide variety of useful tools to optimze your drawings and work more efficiently; tools such as Group, Arrange, and the animation disk to rotate your workspace.

Related Topics 

Arrange
Convert Brush Strokes to Pencil Lines
Pencil Lines to Brush Strokes
Strokes to Pencil Lines
Optimize
Remove Extra Strokes
Reduce Drawing Texture Resolution
Crop Brush Textures
Create Contour Stroke
Remove Contour Stroke
Grid
Group/Ungroup
Hand
Rotate View

Arrange

Use the different Arrange options to reorder drawing objects inside a single layer in the Drawing or Camera view.

Bring to Front button or select Drawing > Arrange > Bring to Front or press [Ctrl] + [Shift] + [PgUp] (Windows/Linux) or [⌘] + [Shift] + [PgUp] (Mac OS X).
The selected art is moved to the top.
Bring Forward button or select Drawing > Arrange > Bring Forward or press [Ctrl] + [PgUp] (Windows/Linux) or [⌘] + [PgUp] (Mac OS X).
The selected art is moved one level higher.
Send Backward button or select Drawing > Arrange > Send Backward or press [Ctrl] + [PgDown] (Windows/Linux) or [⌘] + [PgDown] (Mac OS X).
The selected art is moved one level lower.
Send to Back button or select Drawing > Arrange > Send to Back or press [Ctrl] + [Shift] + [PgDown] (Windows/Linux) or [⌘] + [Shift] + [PgDown] (Mac OS X).
The selected art is moved to the bottom.

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts the selected contour strokes into centreline pencil strokes. This command is only available from the top menu.

To convert brush strokes to pencil lines:

Select Drawing > Convert > Brush Strokes to Pencil Lines or press [^].

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour strokes brush lines.

To convert pencil lines to brush strokes:

From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press [&].

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

To convert strokes to pencil lines:

Select Drawing > Convert > Strokes to Pencil Lines. or press [Shift] + [F12] (Windows/Linux only).

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected drawing objects. Drawing objects will only be flattened and optimized if the selected objects will not change the appearance of the final image when they are merged.

For example, if you have selected a number of partially transparent objects, which you layered to create an additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the transparent drawing objects will cause them to lose the effect of the layered transparent colours.

Use the Select tool to select the drawing objects you want to optimize.
Select Drawing > Optimize > Optimize.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Remove Extra Strokes

The Remove Extra Strokes option is used to remove the invisible lines in your selection.

Use the Select tool to select the drawing objects you want to remove invisible lines from.
Select Drawing > Optimize > Remove Extra Strokes.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Reduce Drawing Texture Resolution

If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy. This option is used to reduce the size and resolution of the textures in your drawing. When you import and vectorize drawings using the grey or colour preset styles, you don't have control on the size of the bitmap texture. This tool allows you to reduce that bitmap texture.

To reduce the drawing texture resolution:

In the Timeline or Xsheet view, Select tool to select the drawing objects you want to reduce the texture resolution for.remove invisible lines from.
Select Drawing > Optimize > Reduce Drawing Texture Resolution.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

1. In the dialog box, drag the slider toward the left to reduce the texture resolution.
2. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your layer.
3. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies, unseen, beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing into another. If you cut a portion from a textured line and paste it into a different drawing, Toon Boom Harmony pastes the entire unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of the source drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not touch the vector area. If there are many textured lines in your scene, this will greatly reduce the file size.

In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first glance, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However, using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command the bitmap texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image where the vector envelope has been pulled out to reveal empty space).

To crop the brush texture:

1. In the Timeline or Xsheet view, select the drawing you want to crop the texture for.
2. Select Drawing > Optimize > Crop Brush Textures.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Create Contour Stroke

The Create Contour Stroke option is used to add a permanent invisible line around a shape that was drawn directly in the application. This allows you to unpaint your lines with the Paint tool but to maintain the shape of the lines should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer option.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Remove Contour Stroke

The Remove Contour Stroke option is used to remove any permanently invisible lines that were either created while scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the intersection triangles created during vectorization.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.

Select View > Grid > Show Grid. The [Ctrl] + ['] (Windows/Linux) or [⌘] + ['] (Mac OS X).
Select View > Grid > Square to display a standard square grid.
Select View > Grid > 12 Field Grid to display a 12 field size grid.
Select View > Grid > 16 Field Grid to display a 16 field size grid.
Select View > Grid > Underlay to display the grid behind the drawing elements.
Select View > Grid > Overlay to display the grid over the drawing elements.

Group/Ungroup

Use the Group option to group the selected drawing objects. This can help in the selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Select Edit > Group > Group or Edit > Group > Ungroup.
Press [Ctrl] + [G] and [Ctrl] + [Shift] + [G] (Windows/Linux) or [⌘] + [G] and [⌘] + [Shift] + [G] (Mac OS X).

Hand

Use the Hand tool to pan through the Drawing and Camera view.

In the Tools toolbar, select the Hand tool, click in the Drawing or Camera view and drag your cursor.
You can also Hold down the keyboard shortcut [Spacebar], click in the Drawing or Camera view and move your mouse in the direction you want to pan the view.

Rotate View

Use the Rotate View tool to rotate the Drawing or Camera view, the same way as you would do with a real animation disc.

Select Drawing > Tools > Rotate View.

In Harmony Paint, this option is found in the Selected menu rather than the Drawing menu.

Press [Ctrl] + [Alt] (Windows/Linux) or [⌘] + [Alt] (Mac OS X).

 

This tool can also be used in the Perspective view.

Related Topics 

How to Draw