Paint Guide > Toon Boom Harmony 10 Paint User Guide > Chapter 4: Clean Up and Drawing Tools > Selecting Drawing Objects

Selecting Drawing Objects

The Select tool is used to select drawing strokes in both the Drawing and Camera views, and apply basic transformations, such as repositioning, rotating, scaling or skewing, using the different handles of the bounding box.

To select with the Select tool:

1. In the Timeline view, select the cell on which you want to select drawing objects.
In Harmony Paint, select a drawing in the Drawing panel.
2. In the Tools toolbar, select the Select tool or press [Alt] + [S].
3. In the Camera or Drawing view, select the drawing objects.
You can select all the drawing objects in a drawing by using the Select All command or press [Ctrl] + [A] (Windows/Linux) or [⌘] + [A] (Mac OS X).
4. To deform or reposition a selection:
To reposition, click on the selected drawing object and drag the selection to a new area.

To rotate, grab the selection box handle and rotate it.

To scale, pull or push either on the top, side, bottom or corner control point. Hold down [Shift] to lock the selection’s ratio.

To skew, drag sideways or up and down the sides or top and bottom segments, between the control points.

Not available in Harmony Paint.

Sometimes, when you want to select multiple objects, while leaving one unselected, it can be handy to select only the stroke, or line, that you do not want included in your selection. Then, you can invert that selection so that everything else becomes selected. This can be quite a time saver.

To invert a selection:

1. From the top menu, select Edit > Invert Selection or press [Ctrl] + [Shift] + [I] (Windows/Linux) or [⌘] + [Shift] + [I] (Mac OS X).
You can also find the Invert Selection option in the Camera View or Drawing View menu by selecting Edit > Invert Selection.

Related Topics 

Repositioning a Pivot Point
Selection on Single or Multiple Layers
Select Tool Properties