Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 3: Interface > User Interface > Camera View

Camera View

The Camera view is the centre of operations in Toon Boom Harmony. It is in this view that you will draw, paint, animate, create animation paths and see your results. You can also move through your symbol’s hierarchy.

The Camera view has a top and bottom toolbar that you can use to either navigate in the view, change the display mode or go back up your symbols hierarchy.

 

1. Update Preview
2. OpenGL View Mode
3. Render View Mode and Matte View Mode
4. Camera View Options Menu
5. Zoom Drop-down Menu and Toggle Quick Close-up
6. Overlay, Line Art, Colour Art, Underlay and Preview Mode
7. Drawing Name
8. Tool Name
9. Frame Number
10. Editing Stack Menu

Update Preview

The Update Preview button lets you check the final look of your effects and fully antialiased image. When you click the button, Toon Boom Harmony calculates the current frame final image. It displays the result in the Render View Mode of the Camera view, it does not output an image.

OpenGL View Mode

The OpenGL View Mode button switches the Camera view to fast display, letting you see your animation play in real time. The OpenGL display requires less memory. The final look of your effects is not shown in the OpenGL View Mode. Switch to the Render View Mode to see your effects.

Render View Mode

The Render View Mode button switches the Camera view to a fully rendered display showing the final image of the current frame. If a modification is done to your current frame or if you move to a different frame, click on the Update Preview button to update the display.

Use the Render View Mode display to see the final look of your frames including effects and antialiasing. You cannot play back your scene in Render View Mode. To see your scene fully rendered and play it back, you must select File > Export > Render Network and enable the Preview option in the Render Network dialog box.

Matte View Mode

The Matte View Mode button switches the Camera view to a matte display showing the alpha channel of the elements in your scene. The transparency level ranges from 0 to 100 percent. Zero percent is completely transparent and represented by black and 100 percent is completely opaque and represented by white. Everything in between these extremes has a transparency level somewhere between 1 and 99 percent and is represented in various shades of grey.

To access the Matte View mode, click on the Render View Mode button and select Matte View from the drop-down menu.

Camera View Options Menu

The Camera View Option menu contains several options related to the camera view display modes. Here are the options contained in the menu:

Safe Area
Camera Mask
BBox Selection Style
Outline Locked Drawings
Current Drawing On Top
Show Strokes
Show Strokes with Colour Wash
Light Table
Reset View
Reset Rotation
Safe Area

The Safe Area button shows or hides the TV safety zone and the centre of the camera frame. The Safe Area will adapt to the scene resolution as well as the safety zone and frame’s centre.

You can also access this feature from the top menu by selecting View > Show > Safe Area.

Camera Mask

The Camera Mask button shows or hides a black mask around the scene’s frame to avoid seeing the unnecessary artwork. This option is handy when you are animating and setting up the scene. It allows you to see your scene’s composition better.

You can also access this feature from the top menu by selecting View > Show > Camera Mask.

BBox Selection Style

Selecting an object in the Camera view with the Transform tool will make a bounding box appear around the object rather than causing the selected object to be tinted in fuchsia, red or yellow along with the bounding box.

Outline Locked Drawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be displayed as wire frames.

Current Drawing On Top

If this option is enabled, the drawing that is being currently edited with a drawing tool will be temporarily displayed in front of all the other elements. The actual scene is not modified by this option.

Show Strokes

When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which helps indicating where the strokes end and where there are gaps in the outline.

Show Strokes with Colour Wash

When drawing with invisible lines such as with the Pencil tool and a line thickness with a value of “0”, the invisible strokes will be displayed as thin blue lines and the tips of the strokes will be displayed as yellow squares which helps indicating where there are gaps in the outline. The drawing colours will also be washed out to make the invisible lines stick out better.

Light Table

By default, while using a drawing tool in the Camera view, the layers that are not being edited are washed out. If the Light Table option is disabled, the drawings will all be displayed in normal colours even though they are not being edited.

Reset View

The Reset View button will reset any panning, zooming or rotation done in the Camera view and return the display to the initial settings or press [Shift] + [M].

Reset Rotation

The Reset Rotation button will reset any rotation done in the Camera view and return the display to the initial rotation settings or press [Shift] + [X]].

Zoom Drop-down Menu

The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option. Click the drop-down arrow and select a zoom level or press [1] and [2].

Toggle Quick Close-up

Use the Magnifier tool to quickly center on the mouse position and zoom in to a pre-defined value such as 4X. Then you can zoom out again. Hold the shift key and press [Z] to zoom in and back out again. Replacing the Reset Zoom by pressing [Shift] + [Z].

The area where you zoom in or out is dependent on the cursor location in the Camera view. If you zoom in and them move the cursor to a different location when you zoom out the mouse will be centered on that location.

Overlay, Line Art, Colour Art, Underlay and Preview Mode

Overlay: Switches to the drawing’s Overlay layer. This layer is located above the Line Art layer. The default keyboard shortcut is [:].
Line Art: Switches to the Line Art layer of the drawing. The default keyboard shortcut is [L].
Colour Art: Switches to the Colour Art layer of the drawing. The default keyboard shortcut is [L].
Underlay: Switches to the drawing’s Underlay layer. This layer is located under the Colour Art layer. The default keyboard shortcut is[:].
Preview mode: Switches to Preview mode, so you can see both Line Art and Colour Art layers simultaneously. The default keyboard shortcut is [Shift] + [P].

You can display the Preview mode drop-down menu and select the Underlay and Overlay layers if you want to show all four of them at the same time.

Drawing Name

The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name

The Tool Name field displays the name of the selected tool. If you override a tool using an overriding keyboard shortcut, the tool’s name will be highlighted in red letters—see Override Tool to learn how to temporarily override a tool.

Frame Number

The Frame Number field displays the number of the current frame.

Editing Stack Menu

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a symbol. You can click on the different names to go back up to the different parent symbols or the top/current project.

Related Topics 

Interface Highlights