Scripting Guide > Toon Boom Harmony 10.0.1 Scripting Guide > Chapter 2: Scripting Overview > Harmony Server Network Environment > Creating a Qt Script

Creating a Qt Script

Use the Script Editor to create Qt scripts forHarmony.

To create a script:

1. Open the Script Editor by going to the top menu and selecting Windows > Script Editor.

The Script Editor view opens.

2. From the View menu , select File > New Script ,or from the Script Editor toolbar, click on the New Script button. (If you do not see the Script Editor toolbar, go to the top menu and select Windows > Toolbars > Script Editor).

The New Script dialog box appears.

3. Enter a name in the Enter name of new script field, along with the file extension *.js and click on OK.

The Save Script window opens.

4. To save the script:
Click on the User button to store the script into the user profile so the user can always access the script (/usa_db/users/user_name).
Click on the Global button to make the script available to all users from any scene, job and environment (/usa_db/scripts).
Click on the Environment button to make the script available to all users from a particular environment (/usa_db/environments/environments_name).
Click on the Job button to make the script available to all users from a particular job (/usa_db/jobs/job_name).

The name of your script appears in the File column of the Script Editor view.

5. Click in the right side area of the Script Editor and start writing your script. Try the following script:

function add3dPathCol()

{

column.add(“ColumnName”, “3DPATH”);

}

6. To test your script, select the function your would like to run from the File column, then from the Script Editor toolbar, click on the Run button, or from the View menu select Play/Debug > Run.
You may receive the message: Only functions that have been saved or are explicitly called will be executed. This usually occurs if you did not select the function you wished to run from the File column before running the script. In this case, click on the Save Changes button, then try running your script again.
You may also see this message on the right side of the Script Editor:

This is because the software jumped to the <<Sandbox>> item in the Function column. The <<Sandbox>> is provided to test scripts without saving them. Simply click on your newly created script and then try running it again.

A new 3Dpath column (or 3 separate x, y and z path columns and a velocity column) will appear in your Xsheet view with the name ColumnName.

To delete a script:

1. In the Script Editor, in the File column, select the script that you would like to delete.
2. From the Script Editor toolbar, click on the Delete Script button, or from the View menu , select File > Delete Script.

To trouble shoot errors in your script:

Debug: Select the script from the function column, then from the Script Editor toolbar, click on the Debug button, or from the View menu , select Play/Debug > Debug.

The Qt Script Debugger opens.

Syntax Check: Click on the Syntax Check button.

An window will pop-up containing syntax information.

Related Topics 

Harmony Server Network Environment
Using Qt Script to Automate Toon Boom Harmony Functions - server functions
Importing Scripts
Linking a Script to a Toolbar Button