Reference > Menus > View Menus > Xsheet

Xsheet View Menu

The Xsheet View menu lets you modify columns, keyframe and timing.

Parameter Description

File

Import

Images: Imports bitmap images which you can choose to vectorize—see About Bitmap Images.

From Scanner: Imports drawings from a TWAIN scanner.

Sounds: Lets you import sound files into your project.

Print

Prints the exposure sheet so you can take it to your animation table, provide a copy to the animator, or create your Xsheet skeleton directly in Harmony.

Edit

Cut cells from Xsheet

Removes selected objects. You can then paste the object or its properties to another object.

Copy cells from Xsheet

Copies selected objects and properties.

Paste

Places an object you cut or copied into the location you select in a view.

Paste Special

Lets you copy and paste selected drawings into a different layer or paste the selection in the same layer to duplicate the drawings.

Paste Special Again

Pastes new drawings with the previous Paste Special settings.

Paste Cycle

Cycles a portion of an animation. You can increase or decrease the number of cycles to paste and select a type of cycle: Normal, Reverse, Forward-Reverse and Reverse-Forward.

Paste Reverse

Reverses the timing of drawings or keyframes in range of selection after copying.

Delete

Removes selected objects.

Select All

Selects all drawing objects in the current drawing window in the Drawing, Timeline and Camera views. This helps you manage multiple objects as one when moving them.

Deselect All

Deselects all selected objects in the Drawing and Camera views.

Insert Mode

Adds a new value or a new value sequence over existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the column. The Insert mode opposite of the Overwrite mode, which is the Xsheet default mode.

Gestural Drag Mode

Lets you drag a cell to any other frame in the same column or into another column.

This feature does not apply to Annotation columns.

Send to Function View

Sends selected objects to the Function view where you can edit and adjust its function curve and parameters.

View

Zoom In Xsheet

Zooms in the view.

Zoom Out Xsheet

Zooms out the view.

Reset Zoom

Resets the view’s zoom to its default position.

Reset Pan

Resets the view’s pan to its default position.

Reset View

Resets the view to its default position.

Set Tempo Marker

 

Expand/Collapse

Collapse Selection:

Expand Selection:

Collapse All:

Expand All:

Column Properties

Lets you rename a column, and enable or disable a column. To view additional properties, select Edit > Preferences from the top menu. In the Preferences dialog box, select the Advanced tab, then select the Advanced Element Mode option.

Show Column List

 

Column Types Manager

Lets you add advanced column types to create particular animation paths. When you create these columns, they are not linked automatically to any particular drawing layer. You can create a motion path using these columns and then link or unlink several drawing or peg layers to it.

Show Thumbnails

Displays column thumbnails making it easier to identify a particular column. This option displays a small thumbnail picture of the current frame below the column header.

Show Selection

 

Set Columns Width

Lets you change the column width (in pixels) and set it as the default.

All Columns to Default Width

Returns all columns to their default width of 100 pixels.

Change Columns Colour

Lets you customize the colour of the column by selecting one from the Select Colour dialog box. The colour you select is also reflected in the correspondng layer in the Timeline view.

Default Column Colour

Removes the colour you assigned to a column (if any).

Hide Selected Columns

Hides selected columns.

Unhide All Columns

Displays all columns.

Show Hidden Columns

Displays columns that were previously hidden.

Enable Playback

Plays back your animation in the Perspective view.

Columns

Add Columns

Lets you add a column. You can specify the column name, type, and set drawing layer options in the Add Column dialog box that opens.

Delete Columns

Removes the selected column. You have the option to delete the associated drawing files and element folders.

Clone Selected Columns: Drawings Only

Creates a copy of the selected column that is linked to the original. If a drawing is modified in the original or cloned column, both will be updated. However, cloned columns can have different timings.

You can clone the drawings only or both the drawings and timing—see Cloning Layers and Columns.

Clone Selected Columns: Drawings and Timing

Duplicate Selected Columns

Creates an independent copy of the selected column. This useful when you need to modify the element independently, including the timing (exposure). Changes to the original element do not propagate to the duplicate.

Merge Selected Columns

There are two methods of merging drawings.

  • You can merge selected drawings in adjacent elements. The columns and layers will be left intact, and each new merged drawing will reside in the frames of the left-most column or lower layer.
  • You can merge elements. All drawings will be merged. Unused columns and layers will be deleted, but the original drawing files are still accessible.

See Merging Drawings.

Frames

 

Add Frames At Start

Adds the number of frames you specify to the end of the scene.

Add Frames At End

Add Frames Before Selection

Adds the number of frames you specify before or after your selection.

Add Frames After Selection

Remove Selected Frames

Deletes the selected frames from your scene.

Drawings

Create Empty Drawing

Creates Creates a drawing in the selected cell, replacing any drawing that may already be exposed in that cell and the following ones until it meets another drawing, key exposure or a blank cell.

Duplicate Drawings

Lets you duplicate the drawing and work on a copy of it. This lets you modify an existing drawing but retain the original. When duplicating a drawing, the selected cell is replaced with the new drawing. The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted from the project folder or other cells in which it is exposed.

When duplicating a drawing, the selected cell is replaced with the new drawing. The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted from the project folder or other cells in which it is exposed.

Rename Drawing

Lets you give a selected drawing a new name.

Mark Drawing As

Marks selected drawings as one of the following: Key, Breakdown, In-between, RetakeKey, RetakeBD or RetakeIB.  

This helps to keep the Xsheet well organized while animating.

When working with several animators, directors or even other studios, the necessity for retakes will often arise. Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or Retake In-betweens.

See About Marked Drawings.

Substitute Drawing Previous

Replaces the drawing or cell's symbol on the current frame by the next drawing.

Substitute Drawing Next

Exposure

Increase

Adds Adds one more exposure to a selected cell; repeating this action adds an extra cell each time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an exposure pushes the existing exposure forward.

Decrease

Decreases exposure of a selected cell by one; repeating this action decreases one exposure adds an extra cell each time. This is an efficient way to shorten a drawing's exposure. Decreasing an exposure pulls in the existing exposure.

Set Exposure to

Lets you set the exposure to 1, 2, 3 or a custom exposure.

Extend Exposure

Lets you extend the length of a selected cell.

Add Key Exposure

Adds a key exposure to the selected cell.

Remove Key Exposure

Removes only the key exposure (key frames) not all the exposures. The existing key exposure is replaced by the preceding exposure.

Remove Duplicate Key Exposure

When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of specific key exposures, unnecessary key exposures will be created. You can delete these duplicates without affecting the rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

Fill Empty Cells

Lets you Lets you fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after each one.When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer fills automatically. You must select the frame range where you want your drawings to hold their exposure up to the next drawing and use the Fill Empty Cells command.

Insert Blank Cell

Adds Adds an empty cell between other cells.

Clear Exposure

Removes the exposure from the selected cell.

Clear Exposure and Pull

Replaces the exposure from the selected cell with exposures that follow it.

Fill Selection

Lets you Lets you fill the same value over an entire selection. The selection can be over one cell, a cell range in one column, a cell range over many columns, an entire column, or many columns. You can use numbers, words, letters, or any alphanumeric value.

Sequence Fill

Lets you Lets you create a numbered sequence over a selection. The sequence can be forward, backward, single, double or higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column or more or an entire column or many entire columns.

Fill Cells Randomly

Lets you Lets you fill in random values over a selection. You can give a maximum and a minimum value and create a range for Harmony to choose the random values from. The selection can be over one cell or a cell range in one column or more or an entire column or many entire columns.

Hold Exposure

Lets you expose a drawing for three, four, or five cells and so on.

Motion

Insert Keyframe

Insert Keyframe and Duplicate Drawing

 

Delete Keyframes

Deletes the selected keyframes.

Go to Previous Keyframe

 

Go to Next Keyframe

 

Set Stop-Motion Keyframe

Sets a stop-motion keyframe which there is no computer-generated motion between two keyframes. The segment is constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to its new location.

Set Motion Keyframe

Sets a motion keyframe. With motion keyframes, Harmony generates the interpolation between the keyframes. This means that a value for each frame between the keyframes is calculated by Harmony to progress from the value of the previous keyframe to the value of the next keyframe.

Morphing

Create Morphing

Lets you control a morphing sequence by placing different types of hints to help Harmony morph the animation the way you want it.

Delete Morphing

Once a cell is selected in a morphing sequence, deletes the entire sequence between the two keyframes.

Insert Morphing Key Drawing

Creates a morphing keyframe from a selected morphing frame.

Convert Morphing to Drawing

Lets Lets you convert your morphing inbetweens to real drawings you can edit. This is useful when manually editing a morphing sequence or if you prefer to have animation timing in double frame (on twos) instead of single frame (on ones).

Lip-Sync

Change Mouth Shape to

Lets you change the mouth shape to one of the following: A, B, C, D, E, F, G, X.

Auto Lip-Sync Detection

Generates a sound detection for lip-sync.

Map Lip-Sync

Automatically maps Automatically maps drawings in an element to the mouth chart you have generated for a sound. This can save time when you are lip-synching a voice track.

Sound Display

Sound Name

Shows the name of the sound file, as well as the file format. The line running vertically through the column frames between the same file name indicates a continuity of the same sound file in these frames.

Mouth Shapes

Shows the letter (or name depending on the way you named your character's different mouth positions) in the column's frames. There is only one mouth position allotted per frame and this position should correspond to the sound file after performing a lip-sync.

Waveform

Shows a vertical display of the sound file's actual waveform. In the column header, in the field under the column name, you can type in a percentage to zoom in or zoom out on the waveform, or pass the scroll cursor over the Zoom Waveform icon.

Sound Edit

Insert Blank Cell

Places an empty cell between other cells.

Clear Exposure and Pull

Replaces the exposure from the selected cell with exposures that follow it.

Annotation

Import File

Lets you import an image file in an Annotation column.

Change Pen Colour

Lets you change the pen colour by selecting one from the Select Colour dialog box.

Pen Width

Lets you select a pen preset or change the pen width (in pixels).

Eraser Width

Lets you modify the width of the Eraser tool.

Erase All

Removes all text and drawn annotations. Annotations that you type in cannot be erased using this method.

Erase Selected Images

Removes images you select in the Annotation column.

Erase Selected Texts

Removes text you select in the Annotation column.

Enable Drawing

Lets you draw in the Annotation column using your mouse or pen tablet.