Start Project > Basic Commands

Basic Commands

This table lists the most common commands used in Harmony.



Access Methods


Creates a new scene while closing any scene already open. The New Scene dialog box opens, asking for directory, name, and resolution information.

File > New

Press Ctrl + N (Windows/Linux) or ⌘ + N (Mac OS X).


Displays the Open Scene dialog box. Browse your file system for a scene file.

The Open command is not disabled when a scene is opened. You can open a new scene from the current one and the previous scene will be closed.

File > Open

Press Ctrl + O (Windows/Linux) or ⌘ + O (Mac OS X).

Open Recent

Displays a quick access list to view and open recently used Harmony files.

File > Open Recent

Open Recent > Clear

Clears the recently opened Harmony files list.

File > Open Recent > Clear


Closes the currently opened scene, but does not close the Harmony application.

File > Close


Saves all changes made to the opened scene, drawings, palettes, and palette lists.

File > Save

Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

Save As

Saves the current state of a scene as another scene. The Save As window prompts you to give a new name and choose a different location to this scene before saving it. This will create a complete scene directory for the new scene.

The scene name cannot exceed 23 characters.

File > Save As

Save As New Version Saves the current scene as another version. The Save Version dialog box prompts you to give a name for this new version. This will create a new .xstage file in your current project directory. File > Save As New Version


Closes the application.

Windows/Linux: File > Quit

Mac OS X: Stage Advanced> Quit


Show Scan Information

Displays a status bar showing the scanning information at the bottom of the Drawing and Camera view.

Drawing View Menu > View > Show > Show Scan Information


Removes selected objects. You can then paste the object or its properties to another object.

Edit > Cut

Press Ctrl + X (Windows/Linux) or ⌘ + X (Mac OS X).


Copies selected objects and properties.

Edit > Copy

Press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).


Places an object you cut or copied into the location you select in the Camera, Drawing and Timeline views.

Edit > Paste

Press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).


Removes selected objects.

Edit > Delete


Select All

Selects all drawing objects in the current drawing window in the Drawing, Timeline and Camera views. This helps you manage multiple objects as one when moving them.

Edit > Select All

Press Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X).

Deselect All

Deselects all selected objects in the Drawing and Camera views.

Edit > Deselect All



Removes the last change made to your project. Harmony supports multiple undo, so you can undo changes you made in the order you made them.

Edit > Undo

Press Ctrl + Z (Windows/Linux) or ⌘ + Z (Mac OS X).


Redoes an operation you have undone. This command is active only after you use the Undo command.

Edit > Redo

Press Ctrl + Shift + Z.

Select Children

Lets you select all elements parented to the selected peg element in the Timeline view.

Animation > Select Children

Select Child

Lets you select the first element parented to the selected peg element in the Timeline view..

Animation > Select Child

Press Shift + B.

Select Parent

Lets you select the parent of the selected element in the Timeline view.

Animation > Select Parent

Press B.

Select Previous Sibling

Lets you select the previous element (above current element) in the Timeline view.

Animation > Select Previous Sibling

Press /.

Select Next Sibling

Lets you select the next element (below current element) in the Timeline view.

Animation > Select Next Sibling

Press ?.

Debug Mode

Enables the Debug mode for gathering and displaying precise information about each rendering frame, such as the nodes encountered and action taken.

Help > Debug Mode


Launches the Toon Boom Harmony Online Help system, complete with instructions on how to use the system. This requires an internet connection.

Help > Help

Toon Boom Harmony on the Web

Launches the Toon Boom Harmony website, which features a Support and Community > Forum section.

Help > Toon Boom Harmony on the Web


Use the About command to access general information about the software.

Windows/Linux: Help > About

Mac OS X: Stage Advanced > About

Show Welcome Screen

Brings back the Welcome screen

Help > Show Welcome Screen

Customer Experience Improvement Program Harmony includes an optional customer experience feature whereby usage information is collected and sent to Toon Boom. The data does not contain any personally identifiable information and cannot be used to identify you. The data will consist of a basic hardware description, a project summary and usage information. This information will only be used for software improvement purposes, as well as sharing the information with third parties for the same reason.

The customer experience feature is enabled by default but is voluntary. If you prefer not to participate, you can opt out when you first launch the software, by using a global preference, or by a command line argument.

Help > Customer Experience Improvement Program