Stage Guide > Toon Boom Harmony 10 Stage User Guide > Chapter 9: Import > Exporting and Re-Importing a PSD Layout > Importing a Layout
Download Toon Boom DocumentationDownload Documentation

Importing a Layout

It is very easy to re-import into Toon Boom Harmony any layout PSD image which was already exported from a Toon Boom Harmony project.

This layout image should be imported at the beginning of the project to allow accurate scene planning.

Refer to the previous topic Exporting a Layout to learn how to create an Toon Boom Harmony layout.

To import a PSD layout file:

1. In your Toon Boom Harmony project, select File > Import > Images.

The Import Images dialog box opens.

2. In the Files section, use the Browse button to find your PSD layout file. Note that this layout image file must have its corresponding XLI file in the same folder.

3. Once you selected the layout image, you will notice a new option appearing in the Layer section.

Use Position Information Contained in XLI file: This option is enabled by default, meaning that when you import the layout image in your scene, it will be automatically positioned to fit the original layout scene. Creating an accurate layout guide. You can disabled this option if you want the imported layout image to be imported according to the normal behavior of the import process. The layout image will be incorrectly aligned as it was when it was first created.
4. Select Layer > Create Layer(s) > Create Single Layer Named or Create Layer(s) Based on Filenames.
5. Decide whether to check or uncheck the Vectorize Imported Items option.
6. Enable or disable the Create Symbol for Imported Items if you want your layers to be contained in symbols or not.
7. Click on the OK button.

The Multilayer Image Import Settings dialog box opens.

8. In the Image to Load field, select
Composite Image: To import the Camera and Layout layers merged together.
All Layers Image: To keep your Camera and Layout layers separated.
9. Select the Transparency Type. Refer to the Importing a Bitmap Image without Vectorization section to learn more the different Transparency Type options.
10. Click on the OK button.

Your image should appear as separate layers in the Timeline view, corresponding to the PSD layer group folders Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.

Refer to Scene Setup chapter to learn more about the scene setup task.

Related Topics 

Exporting a Layout
Exporting and Re-Importing a PSD Layout