Control Center and Server Guide > Control Center and Server User Guide > Chapter 2: Control Center Module > Exporting and Importing Data > Exporting Data
Download Toon Boom DocumentationDownload Documentation

Exporting Data

You can use the Control Center module's export utility to copy scene data. After Harmony copies the exported data to a temporary directory, you can move the archived data to your storage device (for example, a CD or tape drive).

To select the components you want to export:

1. Launch Control Center.
To learn more about the different launch methods, refer to the Launching Control Center section.
2. In the top menu, select Admin > Export.

The Export Scene(s) dialog box appears.

3. Enter the path where you want to export the files. You can also use the Browse button to select this path and create a folder. The destination must be an existing empty folder or a new folder that will be created during the export process.
4. Click Add to select the scenes that you want to export from the Harmony database. You can select a Job to select all scenes in a job. The scenes you select will appear in the list.
5. Select one or more scenes and click Remove to remove scenes from the export list.
6. In the Data Options tab, select what you want to export:
Audio: Exports the Audio directory.
Database: Selected by default, this option exports the elements in the scene. If you select this option and de-select the Elements option, you will be able to access the elements from the Element Manager in the Control Center, but their drawing and bitmap files will not be included. Also exports the list of available versions in the scene. It will not be possible to open a scene if this is not selected for export.
Final Frames: Exports the directory that contains final, rendered frames.
Other Directories: Exports all other directories and files in the scene's data structure.
Elements: selected by default, this option exports the contents (drawing and bitmap files) of the Element directories.
Timing Drawings: Selected by default, this option exports the contents of the Timing directories.
Annotation: This option allows you to export the different drawings created while drawing in annotation columns and imported images.
Stage (xsheet and network): Selected by default, this option exports the Stage directory, which contains the STAGE files for each scene you export. These files are necessary if you want to be able to re-use the exposure sheet (timing) and the effects network from the original scene.

If this option is selected, you can select the Get Outside Drawings option to copy drawings into the scene folder that are referred to by Timing columns and their Element (Drawing) modules.

Palettes: Exports the palette-library directories. When you select this option, you must decide if you want to export the palette-library from the Environment, Job or scene level. When you select a level, the palette-library in lower-level directories will also be exported.
Macros: Exports the Macros (customized effect and module connections) that were created and stored in the environment, jobs or scenes to be exported.
Libraries: Exports Templates created at the selected levels.
7. In the Advanced Options tab (Mac OS X and Linux), select how you want to package the exported scene. The choices you make here are related to the size of the export package as well as the speed of the export process.

Due to constraints in the Windows operating system, you do not have any choices on the Advanced Options tab. In Linux, you can make the following selections.

Select one of the following options in the Exporting Files section:
As hard links if possible, otherwise copy: Speed up the export process by making hard links to the original files on the file system. Hard links keep disk space usage to a minimum and ensure a quick export process.

If it is not possible to create hard links (because the links cross file systems, for example), the entire contents will be copied to the destination directory, which will be a slower process that will take up more space on your file system.

As hard links when possible, otherwise symbolic links: Ensures a quicker export process. However, if symbolic links are used and the original file is deleted, the symbolic link will be broken.
As symbolic links: Export the scene using symbolic links to the original scene files (when importing, imports the scene using symbolic links to the export directory). While this process will reduce the size of the export directory, if the original file is deleted, the symbolic link will be broken.
Copy: Copy all scene data to the export location. This produces the largest export package and therefore takes the longest to complete. However, it is the simplest method.
Select one of the following options in the Valid Links Options panel:
Keep them: Maintain symbolic links.
Resolve them: Remove symbolic links, replacing them with the actual files. When you use this option, the export package will contain real files, rather than symbolic links.
Ignore them: Do not include valid symbolic links in the export package.
Select one of the following options in the Broken Links Options panel:
Keep them: Keep symbolic links to missing files. When the missing files are placed in the path searched by the symbolic link, broken links will be valid again.
Ignore them: Do not include broken symbolic links in the export package.
8. Click on the Calculate button to get a preview of the size of your export package.
9. Click Export. The system exports the selected files and components. Use the Message Log tab to view messages generated during the export process.

Unlike Windows, where the database information and the scene data have been copied to a different directory, Linux creates a set of links to the data.

You must use additional Linux commands to retrieve the animation data pointed to by the links.

 

Harmony creates two files during the export process:

README.txt file (includes export statistics, such as creation date and user ID)
IEContents.dat file (includes export parameters)

Related Topics 

Exporting the Data in Linux
Exporting and Importing Data