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About Producer
With increasing global demand for original animated content, and productions being produced from different 
sites worldwide with more and more work from home, there is a growing need for tools that ensure efficient 
production development. Studios everywhere have relied on spreadsheets and DIY solutions to help keep 
teams aligned, and move productions forward along timelines and within budgets.

Producer 21 provides real-time access to the progress of your animated features and series, making it easier to 
manage global production processes. Track tasks, assets, scenes, production progress, team management, 
efficiencies across departments, reporting and more. Plus, Producer seamlessly integrates with the software 
your team needs to get the job done including Storyboard Pro and Harmony.

Our all-in-one production management and tracking tool provides global visibility of your studio’s activities, 
giving you access to up-to-date information and enabling you to make the best decisions at the right time.
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Benefits
 l Measurable increases in studio production efficiency

 l On-time and on-budget feature and series delivery, enabling massive savings

 l Real-time visibility of full production pipeline for quick and efficient decision making

 l Reporting for all levels of studio management 

 l User-friendly interface makes learning easy

 l Backed by the industry’s leading 2D animation software company who understands the needs of global 
studios

 l We are accessible, with support and our community being our focus — a leader in 2D animation for over 
25 years

 l Seamless integration with industry-leading 2D animation production (Harmony) and storyboard 
software (Storyboard Pro)

 l Multi-production environment in one global platform

 l Advanced potential for team collaboration, effective communications and task delegation 
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Features
 l Customizable workflows, user profiles and roles

 l User-friendly interface

 l Dashboards and detailed reporting

 l Job task reports

 l Progress report

 l Team productivity reports

 l Access to in-app analytics and graphs

 l Graphical scene status dashboard

 l Customizable & Automated triggers

 l Advanced filtering of projects, tasks, scenes, searches and more

 l Versioning

 l Potential for multi-production tracking

 l Scheduling & gantt charts

 l Central Hub for connectivity of every team member

 l Notes and annotations

 l Task, scene and asset assignment

 l Asset categorization, labeling and tags for simplified search

 l Thumbnails and preview videos for easy access

 l Assets assembly and scene set up in Harmony

 l Third-party software integration

 l Batch import and export to CVS

 l Advanced reporting: task reports, progress reports, team productivity, and more

 l Multi-language interface (English, French, Spanish, Japanese, Standard Chinese)

 l Available for deployment on premises or on the cloud
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User Guide
The following guide explains how to use all the core functionalities of Producer. It is addressed to all kinds of 
project contributors, depending on the task they wish to accomplish.
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Chapter 1: About the Interface

Chapter 1: About the Interface
Producer has many pages, tabs, views and buttons that allow you to organize and manage your production 
workflows.

You can navigate the main sections and features available in Producer through the top menu.

Page Description

Goes back to the Project list home page.

Production
Allows supervisors and directors to track the progress of episodes, scenes, tasks and manage 
workloads.

Open 
Tasks

Allows a user to see the work assigned to them and update their tasks as well as logging work 
hours.

Assets Allows supervisors and directors to track asset tasks and manage assets.

Review
Allows supervisors and directors to review submitted scenes and assets, approve tasks, add notes, 
and send work for retake.
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Page Description

Reports
Allows supervisors, directors, and producers to analyze data and progress through a variety of 
customizable reports.

Views Allows users to create and share custom views with custom columns.

Settings
Allows administrators to configure Producer by creating users, setting permissions and groups, 
creating workflows, and managing projects.

NOTE 

Users will have access to different pages and menu items based on their level of permissions—see 
Creating Users.
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Production Toolbar
A lot of the operations in the Production and Asset pages are perform through the Production toolbar.
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Search and Filtering Tools
You can use the Search field and filtering tools to only display scenes and assets matching specific criteria.
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View Tools 
You can change the display style of the Production and Asset tables to include more or less information such as 
opening the detail side panel or changing the view style to thumbnails.
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List button
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Tiles button
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Column Selector 
With the Column Selector you can choose how many columns are displayed in your main list. Uncheck the 
boxes on the ones you wish to hide.
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Toggle Bottom and Side Panels
You can display additional information for each selected job, scene or asset using the side and bottom panel.
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Additional Options for Selected Items
When you enable the checkbox on a Job, more options are available to edit your selection.
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Adding and Removing Columns
Depending on your workflow needs, you can add and remove columns from the production or asset list.

How to add and remove columns

 1. In the top menu, click Production or Assets > Manage.

The assets list opens.

 2. In the toolbar in the top-right corner above the assets list, click on the  Manage Columns  icon.

A menu appears with all the available column options for the asset list. Columns that are currently 
displayed in the list are checked, and those that are hidden are unchecked.

 3. Check each column box that you wish to add, and uncheck each column box that you wish to 
remove.

When adding columns, the newest column added will by default appear on the right.

NOTE 

You should always keep the Selector column enabled. This column contains a checkbox for 
each asset, allowing you to perform certain actions and select several assets simultaneously.
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Creating Views 
You can create custom views and share them with users to display the Production or Asset list using a specific 
set of columns and filtering options. You can create as many views as needed.

How to save a custom view

 1. Select Production or Assets > Manage. 

 2. From the page toolbar, click on the Column Selector  icon. 

 3. Check or uncheck any boxes of columns you wish to display or hide.

NOTE 

The order of the tabs will be displayed from left to right as you check the boxes 
in that order. You can edit this later by grabbing the name in the column header 
and sliding it left or right to switch the order.

More custom fields can be entered using the Toggle Search Panel.

 4. When finished, in the page toolbar, go to More > Save New View. 

The Save New View window opens.

 5. In the Name field, type in a name for the new view. 

 6. Check or uncheck the following options:

 l Save Current View Settings Only: saves the columns and ordering of columns in the 
view.

 l Save Current Environment or Job: save the current location of the view.

 l Save Search Data: saves the search data.

 7. In the drop-down menu, select one of the following:  

 l Add Link to Views: adds the link to views that you can only see.
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 l Add Link to Shared Views: adds a link that everyone in the production can see and 
use.

 8. Click Save View.

Under Shared Views in the Views tab you will see the shared views from the current production. 

Under My Views from the Views tab you will see your personal saved views from the current 
production. 
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Managing Views
Once you have created custom views, you can manage them to remove them or manage the sharing settings.

How to manage views

 1. Select Views > Manage Views.

My Saved Views and Shared Views appears. 

 2. In the Saved Views section, right-click on a saved view. 

The option menu opens.  If you click directly on a saved view, it will open immediately. 

 3. You can drag and drop saved views into the Shared Views section for everyone in the production to 
see and use.
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Chapter 2: About Users and Permissions
Anyone using Producer on a regular basis should have their own login credentials. This allows permissions 
control as well as task assignment and effective communication within Producer. Note that the permissions are 
handled through groups, for better efficiency. A user can be part of many groups and has all the rights 
permitted to these groups.

A group has two primary functions. First, it serves to assign permissions to its members, within the context of a 
project. Second, groups can be used to facilitate task assignments. For example, if you specify that the 
Animators group are the usual assignees for the task “animation” then the animation supervisor will only have 
to chose among users that are part of the Animators group when assigning an animation task.

NOTE 

Only users with Administration permissions will be able to create users, manage groups, and set 
permissions.

Users, groups, and permissions can be access via the Settings page.

The Security section allows the Admin user to set permissions for groups, page access, project access, task 
access, and menu item access such as creating, deleting, or archiving.
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The Users section allows the Admin user to create new users and assign them to groups.
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Creating Users
You can assign certain users permission to access part of Producer, while restricting the use of certain features 
for others.

How to add a user

 1. In the main menu, click on Settings. 

 2. In the Settings tab, select Users.

The Users tab opens.

 3. In the second User tab, click on the Add button.

The Create New User window opens.

 4. Enter all the information for the new user. 
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 5. When finished, click the Add button.
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Editing and Adding Users to Groups
Once a new user is created, they can have their preferences created or changed. They can be found on the 
same user page. Within that you can change or view preferences/groups as well as view metadata. 
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Groups
Add the user to specific groups within the production. Each group has a different set of restrictions.
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Edit User
Allows you to edit the user profile and login credentials.
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Chapter 3: About Workflows
In Producer, production tracking is based on workflows. It is a multi-stage process usually involving several 
different software. While there are commonalities, most animation studios will develop their own pipelines. 
Producer’s ability to reproduce or create complex non-linear pipelines with its node based editor makes it most 
adaptable to an already established studio environment.

The term workflow can be used almost interchangeably with pipeline in Producer. The term workflow is also 
used for the actual node structures. A workflow applies to one type of production. For example, you may have a 
workflow to produce jobs, a different workflow to produce scenes, and another to produce a specific kind of 
asset such as bitmap backgrounds. These different workflows are made up of nodes that each represent a 
process. There can be as many workflows as needed. Producer comes with some ready-made workflows, 
however it is recommended that you use these as templates to create your own. Workflows are specific to 
projects, however they can be exported and imported from one project to another.

   

Workflows are blueprints to eventually create actual tasks that can then be assigned and tracked.
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About Task Status Workflows
A task status workflow has a particular property. It's a workflow that can be applied to the task of another 
workflow. It provides different statuses for that task, letting users know the progress of that task.

NOTE 

To find out how to link a task status workflow to a task—see Task Setup Options.

In the Basic Task Status workflow (a workflow that comes with Producer) there are seven possible options 
(Standby, Pending, Need Assistance, In Progress, To Validate, Revise, Approved).

In the Production or Assets > Manage tab, when a user clicks on a task status, a drop-down menu lets them 
choose or update the status of that task from an option in the list.

36

Producer 21 User Guide                          



Chapter 3: About Workflows

About Included Workflows
Here is the list of workflows that are included with Producer, along with a brief description for each.
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Episodes
Workflow to track jobs as episodes of a TV series.
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Basic
Workflow to track scenes in a simple manner.
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Complete
Workflow to track 2D paperless scenes, where the animation is hand-drawn digitally.
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Double Approval
Workflow to track scenes, where the two approval stages are required for each necessary step in the process.
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Single Approval
Workflow to track scenes, where a single approval stage is required for each step in the process.
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BG
Workflow to track the creation of bitmap backgrounds.

43



Character 
Workflow to track the building of digital puppets (also known as character rigs).
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Prop
Workflow to track the building of digital props.
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Basic Task Workflow
Basic Workflow providing statuses for the tasks of the other workflows.
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Simple Task Workflow
Simple Workflow providing statuses for the tasks of the other workflows. It is meant to track something that is 
completed without any type of revision or approval (ie: task done).
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Duplicating Workflows
The workflows that are provided with Producer are useful templates to create your own. It is NOT 
recommended to use them directly as they may be updated and modified in future versions. Instead, duplicate 
and modify them to match your own pipeline.

How to duplicate workflows

 1. In the main menu, select Settings.

The Project Settings are displayed.

 2. Select the Workflows option.

The Workflow tab opens.

 3. In the Project Workflows list, right-click on the desired workflow and select Duplicate.

The new workflow appears in the list.
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 4. Right-click on the new workflow and select Edit.

The Edit Workflow Details dialog box opens.

 5. In the Name field, enter the name of the new workflow.

 6. In the Description field, type the workflow description

 7. In the Search Type drop-down menu, select the type of item to which this workflow applies. For a 
scene, select Scene (tba/scene). For an asset, select Asset (vfx/asset).

 8. In the Colour field, use the colour picker widget to select an identification colour. 

Then click Select to confirm the colour selection. 

 9. Leave the Autocreate Tasks option enabled (recommended). This means that when items are 
created using this workflow, the tasks will be created automatically.

 10. Click Save.
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Creating Workflows
Creating a new workflow includes a series of subtasks. To simplify the process, it may be a good idea to start 
from an existing workflow—see Duplicating Workflows. 

To create a completely new workflow, follow this procedure.

NOTE 

To add nodes to your workflow and connect them, see Adding Nodes to Workflows and 
Connecting Nodes.

How to create a workflow

 1. In the main menu, select Settings.

The Project Settings tab opens.

 2. Select the Workflows option.

The Workflows tab opens.

 3. Click Add.

The Add New Workflow dialog box opens.
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 4. In the Name field, enter the name of the new workflow.

 5. In the Description field, type the workflow description.

 6. In the Search Type drop-down menu, select the type of item to which this workflow applies. For a 
scene, select Scene (tba/scene). For an asset, select Asset (vfx/asset).

 7. In the Colour field, use the colour picker widget to select an identification colour.

 8. Click Select to confirm the colour selection.

NOTE 

We recommend that you leave the Autocreate Tasks option enabled. This means 
that when items are created using this workflow, the tasks will be created 
automatically.

 9. Click Add to create the workflow.

 10. In the Workflows list, select the new workflow.

The workflow appears in the editor.

 11. Click on the Create First Node icon to create the first node.

 

 12. Right-click on the node and select Rename Node.

 13. Type the new name. DO NOT USE SPACES. USE UNDERSCORES.

 14. Press Enter to validate the name.

 15. Click on the Save   icon to save the changes. The Save icon has an orange glow    whenever a 
change has been made to a workflow.
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About Nodes
Each node in a workflow represents a process. When creating an asset or scene using a specific workflow, the 
nodes of this workflow are represented as tasks that can be assigned to users in the Production and Asset 
tabs. Nodes can be connected from one to another in a non-linear fashion. There are 5 types of nodes: Manual, 
Progress, Action, Condition, and Approval.
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Manual
The Manual node is used for a process where the work is done by a person. This process can have different 
statuses. These statuses are linked by creating a Task Status workflow and assigning it to the node. The node 
status is manually changed by the user executing the work.

You can use the Details field to annotate this node with additional information on the purpose of this step or 
any other requirements.

You can attach triggers and notifications to a Manual node so that when a specific action is performed, such as 
assigning a task or status change, another action can be performed, such as sending a notification to a user.
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Progress
The Progress node is used to follow the progress of various items like environments, scenes, jobs or  assets. For 
example, It can be used in a Scene workflow to track the completion of an asset, such as a background. 

You can set the Progress node to track (also known as listen) to a type of event (environment, scene, job or 
asset), a given workflow of that event, and a specific step in that workflow.
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Action
The Action node is used to execute a script, either Python or Server Javascript. Once the previous process in the 
workflow is completed and its status set to either Complete or Approved, the script attached to the Action 
node will execute.

You can either create the script directly in the node properties or place your scripts in a common location on 
your server and add the path to the node.
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Condition
The Condition node is similar to the Action process. It will execute a script, Python or Server Javascript, that 
will return either True or False. This value can then be used by an Action process to run another script.

You can either create the script directly in the node properties or place your scripts in a common location on 
your server and add the path to the node.

56

Producer 21 User Guide                          



Chapter 3: About Workflows

Approval
The Approval node is used when work created during a manual process needs to be reviewed by a supervisor. 
The supervisor will then update the status to Approved or Retake.

NOTE 

If you want to attach a trigger to the Approval process, first set the process to Manual, create the 
trigger, and then set the type to Approval. The node will preserve the triggers.
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Adding Nodes to Workflows
Workflows are made up of nodes, representing processes, which will eventually turn into tasks. 

NOTE 

When renaming nodes, DO NOT USE SPACES. USE UNDERSCORES. Spaces in process names 
will cause issues when pushing assets to Toon Boom Harmony.

NOTE 

Since nodes can be connected in a non-linear manner, the order of the tasks in the dashboard will 
be based on the X-axis value of the node. Leftmost nodes will be shown first, and rightmost nodes 
will be shown last. Even if nodes are connected in different flows, it is the X-axis value that will 
determine the ordering.

How to add nodes to workflows

 1. In the main menu, select Settings.

The Project Settings are displayed.

 2. Select the Workflows option.

The Workflow tab opens.

 3. In the Workflow list, select the desired workflow.

The workflow appears in the editor.
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 4. There are 3 ways that you can add a node to your workflow:

 l Click on the Add  icon add a new Manual node to the workflow.

 l Click and hold the down arrow next to the Add  icon to select the node type 
you would like to add.

The node type can be changed at any time from the node's properties panel—see 
About Nodes.

 l Click and drag the outport of an existing node.

When you release the wire a newly connected Manual node appears.
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 5. Right-click on the node and select Rename Node.

An editable field appears directly on the node.

 6. Type the new name.  DO NOT USE SPACES. USE UNDERSCORES.

 7. Press Enter to validate the name. 

 8. Click on the Save   icon to save changes. The Save icon has an orange glow    whenever a 
change has been made to a workflow. 
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Connecting Nodes
You can easily connect nodes in Producer by following this procedure. 

If there are no nodes in your current workflow, you should start by Adding Nodes to Workflows.

How to connect nodes

 1. Click and drag the processes around to put them up in the right order. Workflows travel from left to 
right.

 2. Click and drag from the output of the first node to the input of the second node.

 3. Click on the Save   icon to save changes. The Save icon has an orange glow    whenever a 
change has been made to a workflow.
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Deleting Nodes
You can easily delete nodes from a workflow by following this procedure.

How to delete nodes

 1. In the main menu, select Settings. 

The Project Settings are displayed.

 2. Select the Workflows option.

The Workflow tab opens.

 3. In the Workflow list, select the desired workflow you would like to remove the node from.

The workflow appears in the editor.

 4. Click on the cable wire preceding the node you would like to remove.

 5. Then click on the Trash button in the Workflow Editor menu bar.
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 6. Click on the node you would like to remove, then click on the Trash button again.

OR 

Right-click on the node you would like to remove and select Delete Node.

The node is deleted from the workflow.
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Creating Triggers
Creating triggers allows the status of tasks in a workflow to be updated automatically. This eliminates the 
need for manual updating.

Before creating a trigger, you must first create a custom workflow—see Creating Workflows or Duplicating 
Workflows.

NOTE 

The following triggers do NOT need to be set, as they already built in:

 l If the status of a task is set to Approved, the status of the next task in the workflow will 
automatically be updated to Pending.

 l If the status of a task set to Approved is changed to Retake, the status of the preceding task in 
the workflow is automatically updated to Revise.  

NOTE 

Task status updates follow a logical progression, therefore be sure that tasks further down the 
pipeline are not set to a higher status than Pending (eg. Approved). If this occurs, the status of the 
high status task will remain unchanged and not be triggered to update correctly.

How to create a trigger

 1. In your new Workflow, select the node for which you would like to incorporate a Trigger.

The options for the selected node appear in the right panel.
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 2. Click Triggers View button.

The Triggers dialog box appears.

 3. Click on the plus button to add a new trigger.
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The Add a new trigger for process panel appears.

 4. In the Name field, enter a name for the trigger.

 5. In the Description field, type in a description of the trigger's action.

 6. In the Scope section, select either:

Local to Pipeline. This option will only activate in the current workflow. This is the default often.

OR

All “NODE NAME” Processes. Any node of this name in any workflow  will be affected by this 
trigger. In this example it’s the “Anim” node.

 7. In the Event section, from the When drop-down list, select when the event should be triggered.

 8. In the Event section, from the To drop-down list, select the status that will activate the trigger.

In the example here, when a task status is changed from any other status (Standby, Pending, Need 
Assistance, In Progress, etc.) to To Validate, the trigger is activated.
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 9. In the Action section, from the Do the following drop-down menu, select the action that the trigger 
will activate.

Depending on which action is selected, a corresponding set of additional options will appear.
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 10. After completing the additional options, click on the Save  button. 

In the Production tab, changing the status of the given task/node now triggers the set action.

In this case, changing the status of the Anim task from Pending to To Validate automatically 
updates the status of Comp (the next task in the workflow) from Standby to Pending.

 11. Click on the Save  icon to globally save the changes.
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Task Setup Options
In any Workflow, you can further modify the task options of a node by going into its Task Setup. 

By selecting the node you wish to modify, its properties appear in the options panel. Click on the Task Setup 
button to bring up the Task Setup options.

 

Option Description

Completion
Set a number from 0 to 100 as the percentage that this task represents in 
the complete workflow. When added together, the Completion value for all 
the nodes in a workflow should = 100.

Task Status 
Workflow

Select a task status workflow from the drop-down menu to link it to your 
task. The status options become available as a drop-down menu in the 
task. 

Assigned 
Login Group

Set an Assigned Login Group so that for any of these processes a specific 
group of users will appear under the tasks. This is especially useful if there 
are many users.
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Option Description

Supervisor 
Login Group

In this drop-dwon menu, you can select a supervisor login group from the 
list. 

Default 
Duration

Use this field to enter the how many days a task should take. This value is 
tied into the GANTT chart.

Bid Effort

Use this field to enter the how many hours a task should take. This is tied 
into the GANTT: 

Color

Click on the hex code in this field to bring up the colour picker window. 
Use the colour picker window to select a colour. Click on the Select 
button to confirm the colour selection. The new hex code and colour 
appears in the Color field. If you know the hex code of a desired colour, you 
can copy and paste it into the field or type it in manually. Click the Save 
button to confirm the  change. The task (which you can view in Production 
and Asset > Manage tabs) associated with the node takes on the same 
colour.
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Option Description

Label
Set a Label. Can be useful if you would like the name in a different 
language. 

Take/Retake

This field will determine whether to keep a track of “Takes" or "Retakes”. 
For example, a task process will track a take number whereas an approval 
process will typically track a retake number. You can also set the initial 
Take or Retake value.

71



Creating Overview Job Workflows
It is possible to create a Overview Job workflow in which you can quickly view the percentage of status’ that 
are complete for a particular task.

Asset Check

Task Completion Overview

How to create an Overview Job workflow

 1. In the main menu, select Settings.

The Project Settings appear.

 2. Select the Workflows Option.
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The Workflow tab opens.

 3. In the Workflow list, select the desired workflow you would like to add the Overview to and right-
click on it. 

 4. From the pop-up menu, select Duplicate.

The duplicated workflow appears in the Project Workflows list.

 5. Right-click on the new workflow and select Edit.

The Edit Workflow Details window appears. 

 6. In the Name field, rename the Workflow and change the Search Type to Job (if it is not already).

 7. Click Save.

 8. Select a node, then in the side panel, from the Node Type drop-down menu, select Overview.

Repeat this step for each node in your Workflow.

How to incorporate an Overview Job workflow into your production

 1. In the main menu, select Production.
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.

 2. In the Production page, from the environments drop-down (All Environments), select the 
environment you are looking for.

 3. In the jobs drop-down, be sure to have All Jobs selected. 

 4. In the list of environments, select the jobs you would like to add the Job Overview workflow to.

 5. In the Production tab toolbar, click on the More button and select Edit Tasks.
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The Edit Tasks window appears.

 6. In the Task Operation drop-down menu, select Replace.

 7. In the Selected drop-down menu, select the job overiew workflow that you createdd.

 8. Click Submit.

The selected jobs are updated to Job Overview workflows 
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Chapter 4: Production
The Producer structure is divided as follows:

 l Project

 l Environments

 l Jobs

 l Scenes

Environments are a collection of jobs. Typically, environments are used to separate the seasons of an animated 
series, or to separate animation series themselves.

Jobs are a collection of scenes. Typically, jobs are used to separate the episodes of an animated series.
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Creating Projects
Creating a project is the first step to creating and housing environments, jobs and scenes.

How to create a project

 1. In the main menu, select Settings.

The Project Settings are displayed.

 2. In the Project Settings tab, select Project.

The Projects tab opens.

 3. In the Projects tab, click on the New Project button.

The Create a new project window appears.
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 4. In the Title field, enter the title of the project.

 5. In the Project Code field, enter the project code.

IMPORTANT 

The project code is a very important key that will tie many components of the 
project together. The project code must contain only alphanumeric characters 
[A-Z]/[0-9] and only an '_' as a separator.

 6. Click on the Create button.

A status bar appears. When it reaches 100% the Go to New Project and Close buttons appear.

 7. Click on the Go to New Project button.

The project appears.
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Creating Environments
Environments are a collection of jobs, each of which is a collection of scenes. Typically, environments are used 
to separate the seasons of an animated series, or to separate animation series themselves. Special 
environments can also be created to store scenes containing character models and assets for a series.

A new project does not have any environments. To start creating the structure of a project, environments must 
be manually created by a user with administrative privileges. A project can have as many environments as 
needed.

Users with the appropriate privileges can add, edit, retire, and delete environments.

How to create an environment

 1. In new project, click on the Add Environment  button.

The Create Environment window appears.

 2. In the Name field, enter a name for the Environment. 

 3. In the Description field, you can choose to add an optional description for the environment.

 4. If you choose, you can check the Create in Harmony checkbox to create the environment directly in 
Harmony in you are connected to the Harmony server.

If you do choose this option, you now have the option to create a different environment name than 
the one that will appear in Producer, as well as the version of Harmony used in the environment.

 5. If you choose, you can drag and drop an image or movie clip file onto the Add a default thumbnail 
box, to create a preview image for the environment—see Adding a Preview Image for an Asset.

 6. Click on the Create Environment button.

The environment appears in your project.
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Creating Jobs
Jobs are a collection of scenes. Typically, jobs are used to separate the episodes or other segments of an 
animated series. Special jobs can also be created to store scenes containing character models and assets for a 
series.

A new job does not have any scenes by default. To start creating the structure of a job, scenes must be 
manually created by a user with administrative privileges. A job can have as many scenes as needed.

Users with the appropriate privileges can add, edit, retire, and delete jobs, and all users may search, open, and 
view jobs.

How to create a job

 1. In the main menu, select Production.

The Production tab opens.

 2. In the All Environments drop-down menu, select the environment you are looking for.

 3. Once in the environment, click on the Add Jobs  button.

The Create Job window appears.
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 4. In the Number of jobs field, enter the desired number of jobs you would like to populate the 
environment. You can always add more jobs later.

 5. Click in the Start Date field to bring up the calendar and choose the start date for the first job.

 6. If you entered a value greater than one in the Number of jobs field, in the Days between jobs field, 
you have the option to set the number of days between jobs.

 7. In the Name field, enter the name of the job. This is the only mandatory field. If you use a number at 
the end of the job name, Producer will automatically create a sequence for the subsequent jobs 
using the same numbering convention (ie: 101; 102; 103; etc.). 

 8. In the Job Workflow drop-down menu, select an existing workflow. This could be either one of the 
workflows that comes with Producer or a workflow from another environment in your account. You 
can always change it later in Settings.

 9. In the Scene Workflow drop-down menu, select an existing workflow. This could be either one of 
the workflows that comes with Producer or a workflow from another environment in your account. 
You can always change it later in Settings.

 10. Check the Create in Harmony option box if you want to create Harmony files directly to the 
Harmony Server (if connected). Do NOT check this option if your scenes will be created in Harmony 
Standalone.

If you checked this option, you now have the option to add the Job name and Version of Harmony.

 11. Click on the Create Job  button.

82

Producer 21 User Guide                          



Chapter 4: Production

Your job page will look something like this:
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Creating Scenes
Once you've created an environment and jobs for your project, you can start to populate your job with scenes.

How to create a scene

 1. In the Production page, from the list of jobs, double-click on the job you would like to create scenes 
for. Alternatively, go to the Jobs drop-down menu, click on the down arrow and select a job from 
the list.

 2. Once inside the job, click on the Add Scenes  button.

The Create Scene window appears.

 3. In the Number of scenes field, enter the number of scenes you would like to create. You can always 
create more later.
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 4. In the Name field, enter the name of the scene. This is a mandatory field.

 5. In the Workflow drop-down menu, select an existing workflow. This could be either one of the 
workflows that comes with Producer or a workflow from another environment in your account. You 
can always change it later in Settings. 

 6. In the Number of frames field, set a number of frames to start out each scene.

 7. In the Priority drop-down menu, select the priority level for the scenes. This can be No priority or 
anywhere between 1 - Critical and 5 - Low.

 8. Check the Create in Harmony Server option if you are connected to the Harmony Server and if the 
corresponding environment and job were already created there.

Additionally, you have the option to enter the scene name, as it will appear in Harmony, as well as 
the version of Harmony being used.

 9. Check the Harmony Standalone scenes if you would like to create scenes for Harmony Standalone.

Additionally, you have the option to enter a Workspace ID and a Relative Path (often the scene 
name).

 10. Click the Create Scene button.

The scene(s) are added to your job.
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Editing Tasks
Once a task is created for a given scene or asset, it can easily be modified.

How to edit a task

 1. In the main menu, select either Production or Asset > Manage.

 2. In the Environment, Jobs or Scene drop-downs, select an environment, scene or job or a 
combination.

The tab is populated.

 3. From the list, select the assets  to edit by checking their checkboxes.

 4. In the tab toolbar, select More  > Edit Tasks.

The Edit Tasks window appears.
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 5. In the Task Operation drop-down menu, select one of the following:

 l Add - To add missing tasks to selection

 l Delete - To delete existing tasks from selection

 l Replace - To replace some or all tasks for the selection

 l Shift

 6. In the Selected drop-down menu, change the Workflow type.

 7. In Processes list, check the tasks you wish to include in the Workflow.

 8. Click the Submit button.
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Writing Notes
The Write Notes  feature allows you to create notes on one or multiple scenes that have been selected. 

How to create a note

 1. In the top menu, select either Production or Assets > Manage.

 2. From the drop-down menus, located under the main menu, bring up a list of environments, jobs or 
scenes.

 3. From this list, select which you would like to add notes to by checking their corresponding check 
box.

 4. In the tab toolbar, click on the Write Notes  button.

The Create New Note dialog box appears.
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 5. Check the Link notes option if you want changes in one note to automatically update in the other 
notes for all the assets you selected.

 6. In the Process drop-down menu, select the task/process in the worklfow that you would like to add 
the note to.

 7. Select the retake type (ie: artistic, technical, or both).

 8. In the Note Content field, type in your note.

 9. Click on the Add attachments button if you would like to add an attachment.

 10. Click the Create button.

The note is added to the selected assets.
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About Gantt Charts
A Gantt chart is available from the Production page under All jobs of any environment. It can be displayed by 
switching layout type along List and Tiles views.

The Gantt chart lists all current jobs and their tasks for the selected environment. It can be collapsed to have 
an overview of when jobs should start and end over time or it can be fully expanded to display all tasks for 
every job. Every row displays the name, duration (in days), start and end dates for the environment, it’s jobs 
and all tasks from their workflow.

On the right side, there is a timeline and progress bar for each row, it will turn from grey to green when tasks 
start getting approved or completed. There is also a completion % that indicates the progress for each task, 
every job and the environment itself.

If a job needs to be shifted over in time, simply highlight the desired job and click on More in the menu above 
the table, then select Shift Jobs. In the Shift Jobs window, simply select the number of days it will be shifted 
over (jobs can be shifted in the future or in the past, using positive or negative values).
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Scene Focus View
This section provides the details related to a scene (Status, Assignee, Notes, Associated Assets) so that one 
can focus on that given scene  without being distracted by the information of other scenes, as may be the case 
when viewing multiple scenes in the production page.

How to access Scene Focus View

Do one of the following:

 l Double click on a scene row on the Production Page.

 l Select a Scene from the drop-down list in the navigation section.

In order to exit the scene focus view, select "All Scenes from Current Job" from the drop-down list.

 

The Scene Focus view is divided in multiple sections:

Option Description

Navigation
It allows you to select a specific scene to focus. You can also exit the focus 
view, by selecting a Job/Episode in the second drop-down list.
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Option Description

Summary

This section displays the name of the scene and provides information on 
the current process, its Status and Assignee. It also displays useful 
information such as the overall progress of the scene, the completion of the 
Assets associated with this scene, the current priority and the description.

You can perform the following two actions here:

 l Upload Files

 l Submit for Review

Preview
The Preview of the latest snapshot is prominently displayed and can be 
played back.

Tasks
Below the Preview section, the Tasks section shows all the tasks related to 
the selected scene. It is possible, if you have the rights, to edit the status 
and assignee directly from here.

Related Items
This section is located at the bottom left. It will list any assets associated 
with the current scene.

Notes
This section is similar to the one you would find in the side panel of any 
Production Page. It will list all the Notes related to the current scene and 
allows you to enter new Notes.

Details
This section is similar to the one you would find in the side panel of any 
Production Page. It will list all the Details of the current scene and allows 
you to edit them.
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Chapter 5: About Assets 
Assets are typically any component of a production use to produce scenes and track in Producer. This can 
include character sheets, model references, character rigs, backgrounds, music, and more.

Producer can be used as a file server under some circumstances.

Assets can be sorted one of two ways:

 l Categories: Asset categories  are a way of classifying assets based on the purpose of an asset within a 
production, such as characters, backgrounds, props, and more. 

 l Types: Types can be used to categorize the type of file, such as a PNG, JPEG, MOV, MP4, GIF, PSD, or 
PDF.

The following image types are supported for assets: PNG, JPEG, GIF, BMP, TGA, TIFF, PSD, AI, PDF, MP4, MOV.
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About Asset Details
An asset has many properties and attributes. By default, the Asset page only displays some information about 
each asset in the asset list.

To display more information on an asset, depending on the type of information you want to see, you may have 
to:

 l Add a column containing this information to the asset list.

 l Select a specific asset, then open either the side panel or the bottom panel to view more information 
about it.

Columns in the asset list can display the following information:

 l Selector

 l Preview

 l Tasks

 l Asset Name

 l Description

 l Type

 l Category

 l Notes

 l Priority

 l Completion
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 l Workflow Code

 l Asset Code

 l Harmony Status

The side panel displays the following information:

 l Preview thumbnail

 l Name

 l Description

 l Priority 

 l Asset Code

 l Notes

 l Harmony Settings: environment/job/scene/harmony version

The bottom panel displays the following information:

 l Tasks

 l Environments

 l Jobs

 l Scenes

The following table lists each type of information about an asset, and which method will display it: 

Information Description Asset List
Side 
Panel

Bottom 
Panel

Preview The preview thumbnail for the asset.
Preview 
column

Side 
panel

N/A

Tasks A step in a workflow.
Tasks 
column

N/A
Tasks 
tab

Asset Name The display name of the asset.
Name 
column

Details 
tab

N/A

Description The description of the asset.
Description 
column

Details 
tab

N/A

Asset Type
Categories can be used to identify the purpose of an 
asset.

Asset type 
column

N/A N/A
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Asset 
Category

Types can be used to categorize the file type.
Category 
column

N/A N/A

Notes All the notes that were added to the asset.
Notes 
column

Notes 
tab

N/A

Priority A rank indicating the importance of a given asset.
Priority 
column

N/A N/A

Open 
Harmony

If Producer has been configured to synchronize with 
Harmony, you can click this button to open the asset 
directly in Harmony.

Open 
Harmony 
column

N/A N/A

Completion
A progress wheel tracking the percentage of the asset 
that has been completed.

Completion 
column

N/A N/A

Workflow 
Code

The type of workflow being used for the asset.
Workflow 
Code 
column

N/A N/A

Asset Code  
Asset Code 
column

N/A N/A

Scene Asset 
Code

If a scene has been converted to an asset, this is the 
code of the asset it is linked to.

Scene 
Asset Code 
column

Side 
panel

N/A
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Creating Assets
Upload scripts, characters, backgrounds and 3D models to help visually assist your task workflow.

Users with administrative privileges can create one or more assets at a time.

How to create assets

 1. In the top menu, click Assets > Manage.

 

The assets list opens.

 2. In the toolbar above the asset list, select Create Asset.

The Create Asset dialog box appears.

 3. Upload a thumbnail for your asset by clicking and dragging your file into the Drop Files Here box.
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 4. In the Name field, type in a name for your new asset. It must be unique or else an error will occur. 

NOTE 

It is possible to create multiple assets at once. Press enter after typing an asset 
name and continue entering assets name for all the assets you wish to create 
with the same parameters.

 5. OPTIONAL: Link a Harmony Scene asset by checking the box. 

New fields appear. Fill in the Environment name, Job name, Scene name and Version of Harmony 
fields to link the asset from an existing Harmony scene.

NOTE 

This does not create a scene on the Harmony Server, it only links to an existing 
scene.

OR 

Check the Harmony Standalone box to link to an asset from a standalone version of Harmony or 
even to an asset from a third-party software.

New fields appear where you can enter in the Workspace ID and Relative Path.

 6. In the Description field, type in a description for the asset.

 7. In the Type drop-down menu, select what type (3D Model, Image, etc.) of asset you intend to 
upload.

 8. In the Category drop-down menu, select a category (Bg, Main Character, etc.) for the asset type .

 9. In  the Workflow drop-down menu, select your workflow (background, character or prop).

NOTE 

This field is mandatory.
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 10. In the Tags field, type any words you would like to associate with the asset that can later be used in 
searches. Hit Enter after typing each tag to validate it.

 11. In the Assembly section, from the Environment drop-down menu, select an environment.

The Jobs drop-down menu is enabled.

 12. In the Assembly section, from the Jobs drop-down menu, select a job.

 13. To save your new assets, click the Add Asset  button.

Your assets are now available in the asset list.
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Searching for Assets
If you have a lot of assets and you need to find a specific asset, you can filter the assets in the list using 
keywords from their descriptions. You can also choose to only view assets associated with specific 
environments, jobs or based on the specific process, status or user they are assigned to. 

How to search for assets using keywords

 1. In the top menu, select Assets > Manage. 

The asset list opens.

TIP 

To include retired items in your search results, in the toolbar above the asset list, 

click  More and, in the pop-up menu, select Show Retired Items.

 2. In the toolbar above the asset list, click in the Quick Search field and type in all or part of the name 
of the asset you would like to find. Hit the Enter key to initiate the search.

TIP 

When an asset is created, the creator had the option to associate certain words 
with the asset (tags)—see Creating Assets. These tags are usually descriptive of 
the asset and can now come in handy when doing a search.

Assets containing your search term appear.

 3. You can repeat this step to add several search terms. Only assets containing all of your search 
terms in their name will appear in the list.
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TIP 

You can restrict your search to assets associated with specific environments or 
jobs by selecting such restrictions from the navigation drop-downs.

How to filter assets by their tasks, statuses and assignees

 1. In the top menu, click Assets > Manage.

The assets list opens.

 2. In the toolbar above the asset list, click on  Toggle Search Panel. 

The search panel appears. 
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 3. From the All Environments drop-down list, select an environment as an asset search filter.

The Jobs drop-down menu is enabled.

 4. Use the Jobs drop-down menu and Custom Fields fields to continue refining your search. If you need 
more filters or a different set, click on the Add button to bring up the Add Processes, Add Statuses 
and Add Assignees drop-down menus. You can use this second set of filters to exclude, rather than 
include, additional information by clicking on the Exclude button.

Use some or all of these filters at your discretion.

You can add several items from any of these categories by clicking on the Add button to create 
another row of the same filters. An example of where this might be useful is when you need to 
search for 2 different processes assigned to the same person. 

 5. Click Apply Search Criteria at the bottom of the search panel.

The assets that match your search appear in the asset list.

How to clear search terms and filters

Do one of the following:

 l Click the  on all search terms in the Quick Search text box.

 l Hit the Backspace key to remove the last search term until all the search terms have been erased.

 l In the toolbar at the top of the assets list, use the Clear All Filters button 

 l At the bottom of the Search Panel, click on the Clear button.

All of the assets within the job are displayed in the asset list again.
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Navigating Assets
The navigating drop downs (top left of the Asset Manage page)  will let you focus on the assets associated with 
a specific environment or job. These associations are done  either at creation time or through the Asset 
Assembly page. Select the desired environment and job to restrict the display to these assets. 

NOTE 

If you leave the environment to the default “All Environments”, no restriction will apply.
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Editing an Asset
Once an asset has been created, you can edit its description, workflow, and other information at any time.

How to edit the name and description of an asset

 1. In the top menu, click Assets > Manage.

The assets list opens.

 2. In the asset list, click on the check box of the asset you wish to edit. 

 3. If the side panel is not visible, in the toolbar at the top-right corner of the asset list, click the  
Toggle Side Panel button to display it.

 4. In the side panel, select the Details tab.
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 5. To rename the selected asset, in the Name field, type in a new name.

 6. To update the description of the asset, in the Description field, type in a new description. 

 7. To change the priority of the selected asset, from the Priority drop-down menu, select a new 
priority.

 8. To save your changes, click anywhere outside the side panel.

A toaster notification (pop-up) appears in the bottom-right corner of the page, indicating that the 
asset is being updated. When the toaster notification disappears, the asset changes are saved.
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Deleting an Asset
Assets can be permanently deleted. 

NOTE 

Deleting an asset will delete all of its tasks, previews(uploads) and assembly data. Deleted items 
will be permanently lost, and cannot be restored. 

How to delete assets

 1. In the top menu, select Assets > Manage. 

The Asset list opens.

 2. In the Asset list, enable the checkbox on the far left column of the item you wish to delete. 

 3. In the toolbar above the asset list, select More > Delete Assets.
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The Delete Assets dialog box opens. 

 4. In the confirmation prompt, click Delete.

The asset has now been deleted.
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Adding a Preview Image for an Asset
You can add or change a preview image of any asset that appears in the Preview column in the asset list. This 
can be done from either the Assest > Manage tab or the Production tab.

The following image types are supported for preview images: PNG, JPEG, GIF, BMP, TGA, TIFF, PSD, AI and 
PDF.

If you upload a movie clip (MP4 or MOV) as a preview, the first frame of the movie will automatically be set as 
the image. You will be able to play the clip from the Preview column.

For an animated GIF or video file, the first frame will automatically be set as the preview image. You will NOT 
be able to play these files. 

How to add or change a preview image

 1. In the top menu, click Assets > Manage.

The assets list opens.

OR

In the top menu, click on the Production tab.

 2. Use the All Enviroments and/or All Jobs drop-down menu filters to bring up the desired asset(s).

 3. Click the check box of the asset whose thumbnail you wish to change. 

 4. In the toolbar above the asset list, click on the Upload File button.

The Upload File dialog box appears.

 5. Select one of the following options:
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 l This is a default thumbnail to upload an image or movie clip (MP4 or MOV) that will 
be a visual reference for all the tasks in the selected row.

 l This is a preview for the following process to associate an image or movie clip (MP4 
or MOV) with a specific task in the selected row.

When selecting this option, the Process drop-down menu is enabled. Select the task 
you want to associate with the preview image from this list. After the file is uploaded, 
the name of the task will appear near the corner of the thumbnail.

 6. To upload an image, either click on the Click to browse  button or drag and drop the file over it. 

 7. Click the Upload File button.

The selected image/movie clip appears in the Preview column.

TIP 

To view the full-size image/movie clip, click on the Open the image in a new tab 
 icon that appears when you hover over the bottom of the preview image.
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Downloading an Asset Movie Clip
Scene preview movie clips can be downloaded for viewing outside of Producer web interface.

How to download an asset movie clip

 1. In the top menu, click Assets > Manage.

The assets list opens.

 2. If the Preview column is not displayed, in the toolbar above the assets list, enable it from the 
Column selector  button.

 3. Hover your mouse cursor over the Preview thumbnail and click on the gear icon.

A black dialog box appears.

 4. Click on the Download option.

The movie file is downloaded to your computer.
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Viewing Preview Image Versions 
Producer gives you the ability to view  different Preview images and movie clips associated with a certain 
Environment/Job/Scene/Task. 

How to view different versions of Preview images and movie clips

 1. Hover your mouse over a Preview image.

 

A menu bar appears.

 2. Click on the gear icon.

An information and dialog box appears. 

 3. In Process Version, click on the down arrow.

If different image or movie clip options exist, they appear in the drop-down list. Select the one you 
wish to view.

If a Preview images or movie clip was uploaded for the global environment, it has the naming 
convention <default> + version number. If an image or movie clip was associated with a specific task 
during the upload process, it has the naming convention "task name" + version number—see 
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Adding a Preview Image for an Asset. In this example, the movie clip is associated with the Anim 
task and has 3 versions available.

 4. If the image is a still frame from a movie clip, click on the play button to preview the movie clip.

 5. If you would like to see a full-size version of the image or movie clip, click on the Open the image in a 
new tab  icon.
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Replacing Asset Tasks
If your Producer database has several asset workflows, you can change an asset’s workflow by replacing all of 
the asset tasks with the tasks of a different workflow.

How to replace asset tasks

 1. In the top menu, select Assets > Manage. 

The asset list opens.

 2. Ensure the Tasks are visible by doing one of the following:

 l In the toolbar in the top-right corner, click on the Manage Columns  icon, and 
ensure the checkbox next to the Tasks column option is checked.

 l Select the asset in the asset list and, in the toolbar in the top-right corner, ensure the 
Toggle Bottom Panel  button is clicked and the bottom panel is visible. Then, in the 
bottom panel, select the Tasks tab.

 3. Click the checkbox of each asset whose workflow you wish to change.

 4. In the toolbar above the asset list, click on the More  button. 

 5. From the More drop-down menu, select Edit Tasks. 
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The Edit Tasks dialog box appears.

 6. In the Task Operation drop-down menu, select Replace.

NOTE 

All replaced tasks will lose their current assignees and statuses. If you select 
Add instead, missing tasks are added and existing ones are untouched—see 
Adding Tasks .

 7. In the drop-down just below, select the workflow you wish to use.
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 8. By default, all the tasks in the selected workflow will be checked. If you want the selected asset(s) 
to only take some of the tasks in the selected workflow, uncheck the tasks that you wish to exclude.

 9. Click the Confirm  button.

A toaster (pop-up) notification appears, indicating that the tasks for the selected items are being 
replaced. When the toaster notification disappears, tasks from old workflows have been removed 
from all the selected assets, and tasks from new workflow have been added.
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Adding Tasks 
When an asset is created with a workflow, all of that workflow’s tasks are added to it by default. It is possible 
to remove specific tasks from an asset’s workflow, as well as to add back tasks that were previously removed.

How to add asset tasks

 1. In the top menu, select Assets > Manage. 

The asset list opens.

 2. Click the checkbox of each asset whose workflow you wish to change.

 3. In the toolbar above the asset list, click on the More  button. 

 4. From the More drop-down menu, select Edit Tasks. 
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The Edit Tasks dialog box appears.

 5. In the Task Operation drop-down menu, select Add.

 6. In the Selected drop-down menu, select the workflow you wish to use.

NOTE 

An asset can only have one workflow, and can only have tasks from its assigned 
workflow. If you select a different workflow than the one that is currently 
assigned to the asset, tasks from the asset’s old workflow will be removed, 
unless a task with the same name exists in the new workflow.

 7. Check the checkbox for each task you wish to add. If you want to add all of the selected workflow’s 
tasks, check Select All.
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 8. Click the Confirm  button.

A toaster (pop-up) notification appears, indicating that the tasks for the selected items are being 
replaced. When the toaster notification disappears, tasks from old workflows have been removed 
from all the selected assets, and tasks from new workflow have been added.
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Removing Tasks
When an asset is created with a workflow, all of that workflow’s tasks are added to it by default. It is possible 
to remove specific tasks from an asset’s workflow, as well as to add back tasks that were previously removed.

How to remove asset tasks

 1. In the top menu, select Assets > Manage. 

The asset list opens.

 2. Click the checkbox of each asset whose workflow you wish to change.

 3. In the toolbar above the asset list, click on the More  button. 

 4. From the More drop-down menu, select Edit Tasks. 
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The Edit Tasks dialog box appears.

 5. In the Task Operation drop-down menu, select Delete.

 6. By default, all the tasks in the asset’s workflow will be checked and marked for deletion. If you only 
want to delete some of the selected asset’s tasks, uncheck all the tasks that you want to keep.

 7. Click the Confirm  button.

A toaster (pop-up) notification appears, indicating that the tasks for the selected items are being 
replaced. When the toaster notification disappears, tasks from old workflows have been removed 
from all the selected assets, and tasks from new workflow have been added.

NOTE 

You can add back the tasks that were removed from an assets workflow—see 
Adding Tasks .
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Retiring Assets
When an asset is no longer needed, retiring it will hide it from view without deleting it. Retired assets can still 
be viewed and reactivated if needed—see Activating Retired Assets.

How to retire assets

 1. In the top menu, select Assets > Manage. 

The Asset list opens.

 2. Click on the asset whose information you would like to view.

 3. Enable the checkbox on the far left column of each asset for which you want to retire.

 4. In the toolbar above the asset list, select More > Retire Assets.

The Confirm dialog box opens.

 5. Select Confirm.

The retired assets is now hidden from view. 
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Viewing Retired Assets 
Assets that have been retired are hidden from the Production page, but can be viewed if needed. 

NOTE 

To retire assets, see Retiring Assets.

How to view retired assets

 1. In the top menu, select Assets > Manage. 

The Asset list opens.

 2. In the toolbar above the asset list, select More > Show Retired Items. 

Retired items appear.
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NOTE 

To hide retired assets, in the toolbar above the asset list, select More. A 
checkmark will be visible beside Show Retired Items. Select Show Retired Items 
to disable it. 

The retired elements are now hidden from view.
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Activating Retired Assets
Assets that have been retired and hidden from view can be restored so they will appear in the asset list. This is 
referred to as activating assets.

NOTE 

To retire assets, see Retiring Assets.

How to restore retired assets

 1. In the top menu, select Assets > Manage. 

The Asset list opens.

 2. In the toolbar above the asset list, select More > Show Retired Items. 

Retired items appear.
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 3. Select the Assets you wish to Activate by using the check box to the far left of the screen. 

 4. Select More > Activate Assets.

 5. In the confirmation prompt, click Confirm.

The retired assets are now visible in the asset list.
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Chapter 6: About Monitoring the Workload
Tasks are at the heart of tracking your production with Producer. They can can be automatically created when 
new scenes are added or they can be created manually. Tasks are the practical form of the processes that 
make up workflows.

Tasks have different possible statuses and can be assigned to different users.

Tasks are usually created automatically because workflows have a default setting to automatically create 
tasks. When you create an item, such as a scene or an asset, and you select a workflow using the auto-create 
setting, all the processes of this workflow will be converted into actual tasks for this item.
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Assigning Tasks
Each Task in any Workflow can be assigned to a specific user.

To assign multiple tasks to a particular user you can select one scene at a time and change to the required user 
or use the check boxes on the side of the screen and select the box of  the designated scenes to be assigned. 
and in the Task in the Unassigned drop down menu select the appropriate user. 

How to assign a task

 1. In the top menu, select Production or Assets > Manage.

 2. Select the environment and job containing the scenes to assign.

 3. In the column corresponding to the task, in the Assigned drop-down menu (bottom), set the 
asset/task owner.

 l To assign multiple tasks at the same time, in the left-most column, enable the check box for 
all the scenes to assign and then assign the task owner.
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Checking Open Tasks for Work and Notes
In Producer, every user receives their own unique login credentials. The individual users will have a 
predetermined limit of access to Producer depending on their duties within the animation pipeline. Every user 
will have the ability to check for Tasks and Notes that have been specifically assigned to them in the Open 
Tasks page. 

How to check Open Tasks for work and notes

 1. In the top menu, select Open Tasks.

 2. In the Open Tasks view, use the search toolbar to filter work and update tasks.
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Updating Status Manually
In the Production, Open Tasks, and Assets views, you can set the status for various tasks.

How to update a status

 1. In the top menu, select Production, Open Tasks or Assets > Manage.

 2. Select the environment and job containing the status to update.

 3. In the column corresponding to the task, in the Status drop-down menu (top), set the asset/task 
status.

 l To set multiple statuses at the same time, in the left-most column, enable the check box for 
all the scenes to update and then set the new status.

NOTE 

You can change it depending on the workflow of the production 
and your need within that workflow. Depending on how the 
workflow is set up there could be some triggers involved with other 
statuses. 
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Logging Work Hours
Producer allows users to track work by hours. In the Open Tasks view, a user can log the hours worked on each 
task on specific dates.

How to log work hours

 1. In Open Tasks, click on the Work Hours tab at the top of the task window. 

The Work Hours window opens.

 2. Here you can select a number of options. 

 l In the Date Range field, select the date range.

 l Use the Search toolbar to search for a particular task.

 l Enable or disable the Hide Approved option to hide all approved work.

 l For each task, enter the number of hours worked in the corresponding day field.

 3. When finished, select Done.
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Uploading and Updating Snapshots 
If Producer is not integrated with Harmony or any other option updating the task snapshot automatically, a 
user can manually upload a snapshot.

If Producer is integrated with Harmony, you can push the asset snapshot automatically from Harmony using a 
script.

How to upload a snapshot manually

 1. In Open Tasks, check the box on the far left for the scene(s) you wish to upload a image or video.

 2. Select Upload File. 

The Upload Preview window opens.

 3. In the Upload Preview window, you can either drag and drop your new preview or click and upload 
it. 

 4. Select Upload.

 5. In the Image area, select the Gear icon that appears when you hover your mouse over the window. 

A new window opens. 
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 6. Here you can view the old preview and the new one. Producer automatically makes the latest 
upload the default preview. 

How to upload an Asset snapshot from a Harmony scene

 1. In Harmony, select the Asset Snapshot script within the asset scene you wish to upload. 

A new window opens. 

 2. The window may display an error at first because it associates the scene name as an asset. Enter in 
proper asset name. 

Harmony then communicates with Producer to recognize the Process you have in place. 

 3. Set your Process and set your Status (keep the box to the left checked). 

 4. Click OK.
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A new window will open showing the progress in Rendering Preview.

 

The Preview Confirmation dialog box opens. 

 5. Select Upload.  

A confirmation window opens.

 

NOTE 

If you view your asset in Producer, they will have a Harmony icon in the preview 
window linking directly to the original Harmony file. 
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Verifying a User's Workload
You can filter the Production and Asset lists to see tasks assigned to a user.

How to filter the production table

 1. In the top menu, select Production or Assets > Manage.

The Production page opens. 

 2. Select the Environment for which you want to see the workload and assignments. 

 3. Click on the Toggle Search Panel  button at the top. 

The Custom Fields window opens.

 4. Click the Add + option to add more custom fields as well as use the existing fields to Exclude any of 
the selections.

 l In the Add Processes menu, depending on the workflow you selected you get a drop 
down window similar to this:

 l In the Add Statues, depending on the workflow you selected you get a drop down 
window similar to this:
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 l And in the final drop-down, Add Assignees, it is limited to the users assigned for  this 
particular production.

 5. When ready, select Apply Search Criteria in the bottom right corner of the window.

NOTE 

There is no limit to the amount of filters you can Add or Exclude from your search 
criteria.
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This search is not limited to just one episode. You can put your search criteria to include across all 
episodes within this production.
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Creating Custom Fields
Custom Fields are fields or columns that can be added by user profile to match something they want to track 
that Producer isn’t tracking by default, ie: Difficulty of a scene.

How to create custom fields

 1. To add a custom field click on the More tab and select Add Custom Fields.

The Add a Custom Field window opens. 

 2. In the Name field, enter the name of the new custom field.

 3. In the Description field, you can add an optional Description. 

 4. Click Create.

 5. Open the Field Selector, and check the new custom field.
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 6. To modify the new custom field, select the scene or asset for which you wish to edit the custom field 
value.

 7. Open a side panel and select Details > your custom field.

Your entry now appears in the custom field. 

NOTE 

Everyone in the production will be able to view the custom field. Only certain 
users will have the ability to add them.
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Searching in Producer
In Producer there is a Quick Search located in the Production, Open Task, Assets and Review views. This can be 
used to quickly find a environment, scene, asset, or numerous other items. 

How to search in Producer

 1. In the Quick Search field, type a keyword to filter the production table.

 2. When done, beside the search field, click the Clear Filter  button.
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Chapter 7: About CSV Import and Export
Import CSV files in Toon Boom Producer to automatically create empty assets, scenes, jobs, and environments 
and populate additional fields such as Description, Name, and, Note.

Export CSV files from Toon Boom Producer to gather information such as asset lists and details.
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About Creating a CSV File
Before creating your CSV file, review the notes below:

 l When creating the data in the spreadsheet application, set numbers with padding as Text format to 
preserve the preceding zeros.

 l You are responsible to avoid doubling the asset and scene names in your spreadsheet. Producer will not 
accept duplicate names and will suggest skipping the problematic entries.

 l 2-bit characters and special characters can be imported via CSV file upload only. It will not work by 
copying and pasting data directly in the Producer Import CSV dialog box.

 l Create your CSV file as a UTF-8 format (8-bit Unicode Transformation Format) to support special 
characters.

 l When creating a sample header row for your columns, use the exact Producer column name to 
automatically match the data. You will be able to reassign the columns directly in Producer before 
completing the import process. Use name in lowercase for the scene or job name to be assigned to the 
Name column.

 l To create scenes, you need to add a column containing the matching Job code. For more information, see 
Displaying the Environment and Job Codes.

 l To create jobs, you need to add a column containing the matching Environment code. For more 
information, see Displaying the Environment and Job Codes.
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Chapter 8: Exporting CSV File
Producer allows you to export/import data through CSV files.

How to export a csv file

 1. In the main menu, select Production. 

 2. From the Environment and Job drop-down menus, select an environment and job. 

 3. In the list of scenes, select  one or several  scenes from which you would like to export notes by 
checking their respective checkbox.

 4. In the Production tab toolbar, select More > Export CSV.

The Export CSV window appears.
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 5. Check or uncheck the column checkboxes to select which categories you would like to appear in 
your exported CSV file.

 6. Click Export CSV.

A CSV file automatically downloads.
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Displaying the Environment and Job Codes
When creating a CSV file to create scenes or jobs, you need to include the job code, in which these scenes will 
be created or the environment code, in which the new jobs will be.

How to display the Environment code:

 1. In the main menu, select Production.

 

 2. Use the Environments drop-down menu, under the main menu, to navigate to an environment list.

 3. In the Production toolbar, click on the Column Manager  icon.

 4. In the Column Manager, enable the Environment Code column. 

The Environment Code column appears in the list of environments.

How to display the Job code:

 1. In the main menu, select Production.
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 2. Use the Job drop-down menu, under the main menu, to navigate to a job list.

 3. In the Production toolbar, click on the Column Manager  icon.

 4. In the Column Manager, enable the Job Code column. 

The Job Code column appears in the list of jobs.
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Uploading a CSV File and Copy/Pasting Data
When your data is ready, you can import it in Producer. You can also copy and paste your data directly from 
your spreadsheet to the Producer Import CSV dialog box without creating a CSV.

How to upload a CSV file or copy data from a CSV file:

 1. Go either to Assets > Manage.

  

Or navigate to the Environment, then to the Job where you want to create items from your CSV 
data. 

 2. Click on the More tab and select Import CSV.

 

The Import CSV dialog box opens.
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 3. In the Import CSV dialog box (if a CSV is already created), click on the Select a CSV file to parse  
button and browse for your CSV file. Alternatively, you can paste it into the Copy and Paste from a 
Spreadsheet area.

 4. Set up your String Delimiter to Auto detect. 

 5. Click on the Next: Data Mapping button.

 6. Click on the Next: Verify button.
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NOTE 

If the CSV file format doesn’t match the default value, Producer will display a 
warning.
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Chapter 9: About Assembly 
Assembly is the process of associating assets with environments, jobs and scenes that require those assets so 
as to track which assets must be completed before work on these environments, jobs and scenes can begin. An 
asset can be assembled with as many environments, scenes and jobs as needed, and environments, jobs and 
scenes can be assembled to as many assets as needed.

Whether you associate an asset with a scene, job or environment can depend on how much it is used. For 
example:

 l If an asset will only be used in one or a couple scenes in an episode, it makes sense to assemble it with 
each scene in which it is used.

 l If an asset is to be used throughout one or a few episodes, it makes sense to assemble it with each job 
representing each episode in which it is used.

 l If an asset will be used throughout an entire season or an entire series, it makes sense to assemble it 
with each environment in which it is used. 

Assets that have been assigned to scenes can be viewed from the Production page. In the Job Tasks column for 
a given scene, the progress process wheel will display the number of assets assigned to it in the centre, and 
the completion percentage in the wheel. 

The Assembly page also allows you to search and filter assets.
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Navigating and Searching the Production List
The left area of the Assembly page is where you can navigate your production to locate the right environment, 
job or scene, and the right area of the page is where you can browse through and search for assets.

The first step to assembling is browsing through the Production List panel to find the item you want to 
associate assets with.

How to search the production list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens and the Production List panel appears to the left. 

 2. In the Production List panel, navigate to the production item with which you want to assemble 
assets:

 3. To assemble assets to an environment, in the environments drop-down in the Production List 
panel, select All Environments.

 4. To assemble assets to a job, in the environments drop-down menu, select the environment 
containing the job you want to assemble assets with. 
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 5. To assemble assets to a scene:

 l in the environments drop-down menu, select the environment containing the scene you 
want to assemble assets with.

 l In the Job drop-down menu, select the job containing the scene you want to assemble 
assets with.
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 6. To filter the listed items based on keywords, in the Quick Search text box, type in all or part of the 
name of the environment, job or scene you want to find. Then hit the Enter key to add what you 
typed to your search terms.

Only items containing your search term appear in the list.

NOTE 

You can repeat this step to add several search terms. Only items containing all of 
your search terms in their name will appear in the list.

You can remove a search term by clicking on the Close  icon in the search 
terms box. You can also press Backspace to delete the last search term.

 7. To list all items again, do one of the following:

 l Click the Remove  icon on all search terms in the text box or hit the Clear all filters  
button.

 l Press the Backspace key to remove the last search term until all the search terms have been 
erased.
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Browsing and Finding Assets
The second step to assembling assets with environments, jobs or scenes in your production is to find the assets 
you want to associate to the items in the Production List. 

When you open the Assembly page, the list of all the assets for your project is displayed in the right area, in a 
panel labelled Assets List. If you don’t have a lot of assets, you can simply scroll through your assets and find 
the assets you want to assemble. Otherwise, you can use the extensive set of search and display options to find 
the right assets. 

It is also possible to have several lists of assets in the Assembly page, each one taking a part of the space 
reserved to the assets list. Each list can have its own unique search filters and display settings. 
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How to change the size of thumbnails in the assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. Ensure the Asset List is in tile mode by clicking the Tiles icon.

 3. To change the size of the assets:

 4. Click and hold the icon in the middle of the slider, then drag it to the left to make the icons smaller, 
or right to make the icons larger.
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How to change the display mode of the assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. Do one of the following:

 l To view the Asset List in tile mode, click Tiles.

 l To view the Asset List in list mode, click List.

How to filter assets in the assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. In the top-right corner of the Assets List panel click the Toggle Search Panel  icon.

The search panel appears below the toolbar.
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 3. Do one or several of the following to filter the list of assets to the assets you want to assemble:

 l In the Name field, type in the name, or part of the name, of the asset you are searching for.

 l In the Workflow drop-down menu, select the workflow associated with the asset you are 
searching for. 

 l If the asset you are searching for was already assembled with an environment, in the 
Environments drop-down menu, select the environment the asset you are searching for is 
associated with. 

 l If the asset you are searching for was already assembled with a job, in the Jobs drop-down 
menu, select the job for the asset you want to search for. 

 l If the asset you are searching for was assigned a specific process, in the Process field, select 
the process assigned to the asset you are searching for. 

 l In the Statuses field, select the status for the asset you want to search for. 

 l In the Categories field, select the category for the asset you are searching for. 

 l In the Types field, select the type for the asset you want to search for. 

 4. Click Apply Search Criteria at the bottom of the search toolbar.

The assets that match your criteria appear in the list of jobs. 

 5. To display all assets again, click the Clear button at the bottom of the search panel.

All of the assets are now displayed in the asset list.

How to add an assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. At the top of the Asset List, select Add Assets List. 

An additional asset list appears on the right. 
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 3. To rename an asset list, click anywhere at the top of the list around the current name.

The text box can now be edited.

 4. Type in a new name for the asset list in the text box, then click anywhere outside of the text box.

The asset list has now been renamed. 

How to remove an assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. If there is more than one asset list, click on the Remove  icon to the top left of the asset list you 
wish to remove.

The asset list has now been removed.

How to remove all extra assets list and reset the first assets list

 1. In the top menu, select Assets > Assembly.

The Assembly page opens. The Asset List panel appears to the right.

 2. If there is more than one asset list, select Clear Assets Lists  at the top of the Asset List page.

All but the original asset list are removed.
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Assembling
You can assemble assets by associating assets with the environments, jobs, and scenes in which they are used. 
If an asset is only used in a few scenes, it can be assembled to those scenes; if it is only used in a few episodes, it 
can be assembled to said jobs; if it will be used throughout an entire series season, it can be assembled to an 
environment.

How to assemble one asset at a time

 1. In the top menu, select Assets > Assembly.

The Asset List opens.

 2. Locate the environment/s, job/s, or scene/s you want to associate the asset to from the production 
List—see Searching Production List.

 3. Locate the asset you want to associate to an environment, scene or job from the Assets List. 

 4. Click the asset you wish to assign, and drag it over to the Asset Drop column to the item you wish to 
assign it to.

The asset is now listed in the Asset Drop column.

How to assemble multiple assets at once

 1. In the top menu, select Assets > Assembly.

The Asset List opens.
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 2. Locate the environment/s, job/s, or scene/s you want to associate the asset to from the production 
List—see Searching Production List.

 3. Select the item by checking the checkbox on the far left column of each item you wish to associate 
the asset to. 

 4. Locate the asset you want to associate to an environment, scene or job from the Assets List. 

 5. Select the asset by enabling the checkbox on the far left column of each asset you want to associate 
to an item. 
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 6. Click the Move button to associate the assets to the items.

The assets are now listed in the Asset Drop column.
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Disassembling
Assets that have been associated with environments, jobs and scenes can be disassociated at any time by 
disassembling them. 

How to disassemble assets

 1. In the top menu, select Assets > Assembly.

The Asset list opens.

 2. In the Assets list, locate the environment, scene or job you want to disassemble.

 3. In the Asset Drop column, click the Remove  icon on the asset you want to disassemble.

The asset is removed from the Asset Drop column.
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Checking the Asset Progress in a Scene Workflow
From a scene workflow, you can check the asset creation progress by adding a Progress process. This node will 
track the percentage of completion of the assets assigned to the scene.

How to add a Progress node to a workflow

 1. In the top menu, select Settings. 

The Project Settings are displayed.

 2. Select Workflows.

The Workflow tab opens.

 3. In the Workflow list, select the desired workflow you would like to add the Progress node to. 

The workflow appears in the editor. 

 4. Click on the drop-down arrow BESIDE the Add Process button.

 5. Select Add Progress.
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The new node is added to the workspace. 

NOTE 

Producer reads everything linearly, so the new node must be placed to the left of 
the Workflow.

 6. Rename your node to reflect the purpose, In this case, Asset Check. 

 7. 
NOTE 

To rename any node, either right-click and select Rename or press Ctrl/Cmd Click on 
the node. 

 8. Select the Asset Check progress node.

 9. In the Properties view's Listen to events from field, select the Asset or any type of element you 
would like this to track in your workflow. You can track multiple items. 
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 10. To save the changes to the process, click the Save button.

 11. To save the Workflow, click the Save Workflow  button.
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Chapter 10: About Harmony Synchronization
You can import and synchronize scenes between Producer and Harmony as long as the Environment and Job 
structure is the same.

How to create environments in Producer and Harmony Server

To create a new environment in Producer and add it to the Harmony server you must follow these steps:

 1. In the main menu, select Production.

 2. In the Environments drop-down menu, select All Environments.

 3. In the Production tab toolbar, click on the Add Environment button.

 

The Create Environment window opens.

 4. In the Name field, type in the name of the new environment.

 5. In the Description field, optionally add a description of the new environment.

 6. Check the  Create in Harmony  checkbox.

 7. Click in the Environment field. The environment name is automatically regenerated. If there are 
spaces in the name, they will automatically be replaced by underscores. Harmony doesn’t allow 
spaces in names. 

 8. In the Version of Harmony field, you can optionally enter the version of Harmony being used.
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 9. In the Add a default thumbnail box, you can optionally drag and drop a file that will be used at the 
environment's Preview image. This can also be done at a later time.

 10. Click on the Create Environment button. 

The new environment will be sent to the render queue. 

 11. Go back to the Production > All Environments. 

 12. Go to the Column Selector  and check the Harmony Status box. 

The Harmony Status indicates Create in Progress.

 13. Hit the Refresh button.

The Harmony Status is updated to Vaild. The new environment now appears in the Harmony 
Server or will remain in the queue until there is a proper connection to the Harmony Server.

How to add jobs from Producer into Harmony Server

 1. In the main menu, select Production.

 2. From the Environment drop-down menu, select the environment in which you’d like to add the 
jobs.

 3. In the Production tab toolbar, click on the Add Jobs button.
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The Create Job window opens.

 4. In the Number of jobs field, enter the number of jobs you wish to create.

 5. In the Start Date field, click on the calendar icon to select a start date for the first job.

 6. If you entered a value greater than one for the Number of jobs, in the Days between jobs field, enter 
the number of days you would like in the production schedule between jobs. This will affect the 
production schedule Gantt chart.

 7. In the Name field, type in the name of the first job.

NOTE 

If you create more than one job, it is important to add a number to the end of the 
name, as the other jobs will use the same name plus subsequent number.

 8. In the Description field, optionally enter a description of the job.

 9. In the Job Workflow and Scene Workflow drop-down menus, find the job and scene workflows 
that you would like to associate with the new jobs.

 10. Check the Create in Harmony checkbox. 

 11. Click in the Job field. The job name is automatically generated from the one entered into the Name 
field. Spaces will be replaced by underscores.

 12. Optionally, in the Version of Harmony field, enter the version number of Harmony being used.
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 13. Click Create Job.

The new Job is sent to the render queue. 

 14. Go back to the Production page, selected environment, then to All Jobs.

 15. Go to the Column Selector  and check the Harmony Status box.

The status indicates Create in Progress. All the jobs have a sequential numerical order. 

 16. Hit the Refresh button.

The Harmony Status is updated to Valid. The jobs appear in the Harmony Server or will remain in 
the queue until there is a proper connection to the Harmony Server. 

 How to add Scenes from Producer into Harmony Server

 1. In the main menu, select Production.
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 2. From the Environment drop-down menu, select the environment in which you’d like to add the 
jobs.

 3. From the Job drop-down menu, select the job in which you’d like to add the scenes.

 4. In the Production tab toolbar, click on the Add Scenes button.

The Create Scene window opens.

 5. In the Number of scenes field, enter the number of scenes you wish to create.

 6. In the Name field, type in the name of the first scene.

NOTE 

If you create more than one scene, it is important to add a number to the end of 
the name, as the other scenes will use the same name plus subsequent number.

 7. In the Workflow drop-down menu, select the workflow you would like to associate with the new 
scenes.

 8. In the Number of frames field, enter a numerical value for the number of frames that you would like 
automatically created for each scene.

 9. In the Priority drop-down menu, select the priority (No priority, 1 - Critical to 5 - Low) for the new 
scenes.

 10. Check the Create in Harmony Server checkbox. 

 11. Click in the Scene field. The scene name is automatically generated from the one entered into the 
Name field. Spaces will be replaced by underscores.

 12. Optionally, in the Version of Harmony field, enter the version number of Harmony being used.

 13. Optionally, in the Description field, enter a description of the scene.
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 14. Click Create Scene.

The new Scene is sent to the render queue. 

 15. Go back to the Production page, selected environment and job.

 16. If the Harmony Status column is not displayed, go to the Column Selector  and check the 
Harmony Status box.

The status indicates Create in Progress. All the scene names have a sequential numerical order. 

 17. Hit the Refresh button.

The Harmony Status is updated to Valid. The scenes appear in the Harmony Server or will remain in 
the queue until there is a proper connection to the Harmony Server. 

How to create scenes/jobs in Harmony and synchronize with Producer

NOTE 

Environment and job names must match in both Harmony and Producer for this process to 
work.

 1. In your Harmony Server, create your scenes. 
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 2. Once the scenes are created in Harmony, go back to Producer and in the main menu, select 
Production. 

 3. In the Environment and Job drop-down menus, select the environment and job you would like to 
populate with scenes created in Harmony.

 

No scenes will be visible yet.

 4. In the Jobs drop-down menu, select All Jobs.

 5. From the list of jobs that appear, select the jobs for which created scenes in Harmony by checking 
their checkboxes. 

 6. In the Production tab toolbar, select More > Synchronize with Harmony. 
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The Synchronize with Harmony dialog box opens.

 

 7. Click on the Synchronize button.

The scenes appear in Producer.

NOTE 

Syncing with Harmony will also update the frame counts to those set in 
Harmony. 
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How to sync Harmony with scenes deleted in Producer

 1. In your Environment/Jobs where you would like to delete a scene(s), check the box on the left 
column. Then go to the More tab and select Delete Scenes.

  

The Delete scenes dialog box opens. 

 2. Select Delete. 

The Delete scenes WARNING window opens. It tells you that the Producer scene and the external 
scene in Harmony will be deleted.  

 3. Select Delete. 

The selected scenes are deleted from both Harmony and Producer.
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Updating Snapshot Scripts in Harmony
In Harmony you must install the snapshots scripts provided by Toon Boom. There will be two types of scripts 
to install. One is the Scene Snapshot scripts, they other is the Asset Snapshot scripts. The scripts allow 
Harmony to be connected to Producer. 

How to upload a scene snapshot from your scene:

 1. Select the Scene Snapshot script within the scene you wish to upload a snapshot. 

The TB_Producer_SceneSnapshot window opens.

 2. Enter in the information for this scene. The first 4 fields are mapped  to the Project > Environment > 
Job > Scene.  

 3. In the Process drop-down menu, select the process.

 4. Set the process/task status that you wish to be updated in Producer. 

 5. Click OK.

The Create Preview progress bar appears.

Once finished, the Preview Confirmation window opens. 

 6. Click Upload to send the snapshot (preview) to Producer.
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Harmony lets you know that your preview has been successfully created. 
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About Sending Assets to Harmony (Baking)
In Producer, “baking’ refers to the pushing of assets directly into Harmony scenes. This can be simply 
accomplished in the Asset Assembly page, by selecting the scenes for which you wish the baking to be done 
and pressing the baking button (with the Harmony logo). However, several operations have to be completed 
first to insure a successful bake.
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Requirements for Baking

Producer_Link
Producer Link is an application that can help you create workspaces and upload assets to 
Producer. It can be downloaded from the about page of Producer.

cli_workspaces 
Setup through Producer link, the file /Users/user_name/.producer/cli_workspaces has to 
reflect the local access path to folders storing assets. 

workspaces.json
Setup manually, the file /USA_DB/workspaces.json specify which folders can be used to 
store templates and must also specify the folders containing assets (the same as specified in 
cli_workspaces) so that Harmony can find these assets and paste them to the scenes.

TB_Producer_
AssetSnapshot.js

That Harmony script allows the user to push an asset from a Harmony scenes as a preview in 
Producer and as a template, in a library folder (specified in workspaces.json). That script can 
be downloaded from the About page of Producer. (Note that all 4 scripts should be installed 
as they are referring each others)

WebCC
WebCC is a Harmony application that is able to communicate with Producer. For the baking 
to work, you have to use WebCC version 17.0.3 or more higher.
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Sending a PSD file into a Harmony scene
You can send a PSD file  directly to Harmony using Producer.

How to send a PSD file to Harmony

 1. In top menu bar, go to Asset > Manage.

 2. In the secondary toolbar, click on the Create Asset button.

The Create Asset dialog box opens.

 3. In the Create Asset dialog box, specify the name of the asset (in this case the name of he PSD file). 

 4. Check the Harmony Standalone option box. 

 5. In the Workspace ID field, specify the workspace ID—see About Sending Assets to Harmony 
(Baking). 

 6. In the Relative Path field, enter the end of the path extenxsion. The relative path relates to where 
the asset is located within the workspace.

 7. In the Workflow drop-down menu, specify the workflow by choosing one from the list.
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 8. Click on the Add Asset button.

The PSD file is now available in Harmony.

How to create a snapshot and add a preview image of the PSD

 1. From your desktop top menu bar, click on the Producer icon and select Login.

The Login to Producer dialog box appears.

 2. Enter the web address of your Producer, as well as your username and password.

 3. From your desktop top menu bar, click on the Producer icon and select Upload External Asset. 

The External Asset Upload dialog box opens.

 4. In the Project drop-down menu, select the project where your asset is located. 
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 5. In the Asset Name field, click on the magnifying glass icon to search for the asset and identify it.

 6. In the Process drop-down menu, select a workflow task to specify which task/process the snapshot 
is being uploaded for.

 7. In the Source section, click on the the Select File button to browse and locate your asset file.

 8. In the Preview section, click on the Select File button to upload a preview file, if one is available. 

 9. Click on the Create Snapshot button to upload the preview and inform Producer of the location of 
the actual asset.

How to bake the PSD into a Harmony

 1. Complete the asset assembly (associating assets from the asset list to the scenes in the Production 
List)—see Assembling. 

 2. In the Production list, select one or multiple scenes to bake. 

 3. Press the Bake button (the one with the Harmony logo).

The Bake Assets in Harmony dialog box appears.
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 4. Click on the drop-down menu to select how you want the asset to be baked.

 l Copy assets to their associated scene’s local library only

Default option. This option makes the asset available within the scene without 
adding it to the timeline and Node view.

 l Always paste assets into the scene itself

This option puts a copy of the asset in the local library of the scene and will add the 
asset directly to the timeline and the Node view. To protect the work that was done 
and to avoid confusion, this option creates a new version of the scene that will be 
called “producer paste” and this version will become the current version.

 5. Click on the Bake button.

The PSD is baked into the selected Harmony scenes.
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Baking a Scene Template into a Harmony
You can create a template file of a scene for Harmony using Producer.

How to bake a template file into a Harmony scene

 1. Create a Harmony scene asset—see Creating Assets. 

This creates a new asset in Producer and a new scene in Harmony that will be used to build this 
asset.

 2. In Harmony, make sure your Harmony snapshot scripts are installed and launch the TB_
Producer_AssetSnapshot script by clicking on its icon.

The TB_Producer_AssetSnapshot dialog box appears and you may be prompted to login to 
Producer if you are not already.

 3. Complete the login to Producer if necessary.

 4. In the TB_Producer_AssetSnapshot dialog box, from the Project drop-down menu, select the 
project in which you would like to create the template file.

 5. In the Asset Name field, type in the name of the asset.

 6. In the Process drop-down, select the task/process for which you want to upload this preview of the 
template. 
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 7. Click on the Set Status checkbox if you would like to set the status of the task/process. If you check 
this box, from the Set Status drop-down menu, select the status that you would like to update the 
status of the task/ process to.

 8. In the Workspace field, type in the name of the workspace. In this case, the workspace name refers 
to a reference folder where a .tpl of the current scene will be generated and stored. The workspace 
is defined in /USA_DB/workspace.json.

If no Workspace is specified, the template will be placed in /USA_DB/library/assets/env_
name/job_name/asset_name.

 1. Click OK.

A template of the whole scene is generated in Harmony AND preview of the asset is pushed to 
Producer.
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Chapter 11: About Reviewing
Reviewing is the process of watching, reviewing, approving, and providing retakes to preview movies for 
scenes submitted by project collaborators after they have completed a task. 

Project collaborators are able upload movie previews of the scenes they have worked on in Producer. By 
loading these movie previews into Producer’s review tool, directors, supervisors, and other project 
administrators are able to do the following:

 l Stitch the movie previews of several consecutive scenes into a sequence.

 l Play these movie previews

 l Stop at, or seek specific frames to examine them

 l Add notes to the scene

 l Draw annotations over frames in the scene, and add them as attachments to a note

 l Approve a scene’s task

 l Send a scene’s task for revisions (retakes)

To use the Review tool, you must create a review session. A session is essentially a container in which you can 
store a sequence of scenes. Opening the session will load the scenes into the Review tool and allow you to 
review and annotate them. 

There are two types of session:

 l Temporary: A review session that is created on the go as you send scenes to the review tool from the 
Production page. Each user can only have one temporary review session. If you already have a 
temporary review session, creating a new one will overwrite the old one.

 l Permanent: A review session that is created in the Review tool before sending scenes to it from the 
Production page. These sessions typically have a specific purpose, such as reviewing the same segment 
of an episode as its completion progresses. You can create as many permanent review sessions as 
needed. 

NOTE 

Reviewing allows you to preview one or several scenes together and is typically used to approve 
the work of project collaborators on tasks or to send them for revisions. If you only wish to watch 
the preview movie for a single scene without actually reviewing it, you can play the preview movies 
for scenes from within the Production page. 
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Creating a Temporary Review Session
Temporary review sessions can be created directly from the Production page. Each user can have only one 
temporary review session at a time, and creating a new one will overwrite the previous one. 

How to create a temporary session

 1. Open the job in which you want to review one or more scenes.

The Scene list opens.

 2. In the far-left column, enable the checkbox for each scene that you want to review.

NOTE 

You can only review scenes that have a playable movie preview. Scenes with a 
movie preview will have a thumbnail and a  Play button underneath their 
thumbnail. 

 3. In the toolbar above the scene list, select Review. 

The Review dialog box opens. 
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 4. In the Select Review Process drop-down menu, select the process (task) that you wish to review. 
This list will change according to the type of workflow that was created. 

 5. Select the Use Temporary Review Session option.

 6. Click Review Now.

A notification will appear in the bottom-right corner of the interface indicating that the session is 
ready. 

 7. Click on Open Review.
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Creating a Permanent Review Session
You can create a review session from the Review page, then populate it with scenes from the Production page. 
You can create as many permanent review sessions as needed.

How to create a session

 1. In the top menu, select Review.

 

 2. In the toolbar at the top of the Review page, select Create a Review.

 

The Create a Review dialog box opens.

 3. In the Name field, name the review session.

 4. In the Date field, select the pop-up calendar and the date at which you want the review session to 
take place.

 5. In Assignee field, you can assign the review to a particular user.

 6. In the Restriction field, select the type of restriction needed to limits the elements that can be 
added to this review. 
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There are three options:

 l Unrestricted: Anything can be added to the session. 

 l Scenes of a Specific Job: It can be limited to scenes of a specific job which opens more 
options (Job and Process).

 l  Assets: It can be limited to assets  which opens one additional option (Process).

 7. To allow external review, enable the External Review option.  This is added as flag as there is no 
limitations while using it. It is useful for a client to easily search for reviews meant for them 
externally. 

 8. Click Add. 

The session has now been created. 

NOTE 

Once your session is created, you must add scenes to it.
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Sharing Review Session 
After a review session has been created, you may want someone else to access it specifically. To do this, you 
will need to make sure the recipient has access to Producer. Please see section on Creating Users.

How to share a review session

 1. In the Review List, under the   of the Actions column, click  icon to generate a Review URL for the 
corresponding review session.

 2. Click on the blue Copy icon to copy the displayed URL to the clipboard.

 3. Send that URL to the remote user whom you would like to review this session.
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Sending Scenes for Review 
Once you have created a session, you can add scenes to be reviewed in it from the Production page. You can 
add scenes to new, empty sessions, or to sessions that already have scenes in them.

How to add scenes to a session

 1. Open the job in which you want to review one or more scenes.

The Scene list opens.

 2. Enable the checkboxes on the far left column of the scenes you wish to review.

 3. In the toolbar above the scene list, click Review.

The Review dialogue box opens.

 4. In the Select Review Process drop-down menu, select the process (task) that you want to review. 
For example, if you want to review the work of a project collaborator on a scene’s animation, select 
the process for Animation.

 5. Select the Use Review Session option.

 6. In the Use Review Session drop-down menu, select the review session to which you want to add 
the selected scenes.

 7. Click Submit.

A notification appears in the bottom-right corner of the page indicating that the session is being 
updated. When the notification disappears, the session is ready for review.
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Filtering a Review Session
If you have a lot of review sessions and you need to find a specific one, you can filter the sessions in the list 
using keywords from their descriptions. You can also choose to only view sessions of a certain type, or sessions 
within a specific range of dates.

How to filter sessions

 1. In the top menu, click Review.

 2. In the Review page, click the Toggle Search Panel  button at the top right of the page.

The Search Criteria panel opens.

 3. Select one or many of the search criteria listed. The reviews will automatically populate at the 
bottom as you enter your criteria. 

 4. To remove all of your search filters, click Clear Search Criteria  at the bottom of the search panel.

All of the sessions are be displayed in the session list.
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Editing a Review Session
Once a session is created, you can edit its name, assignee, restriction, date and if the review is external.

How to edit a review session

 1. In the top menu, click Review. 

 2. In the Review page, check the box on the far left for the review you wish to edit. 

 3. Select More > Edit. 

The Edit Review window opens. You can change the name of the review, set or change an assignee, 
create a restriction, set a date as well as label External/Locked/Closed reviews. 

NOTE 

The External Review is  a simple flag and is only used to help with search results. 
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 4. Click the Edit button at the bottom to save your changes.

A notification appears in the center of the page indicating that the changes are  saved.
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Opening a Review Session
Once a session has been created and filled with scenes, you can open it and play the preview movies for each 
scene in the session in a single video player. From the Review interface, you can add notes to scenes, draw 
annotations, approve scenes or send them for revision. 

You can open multiple review sessions at once. Each session you open will appear in the Open reviews panel at 
the far left of the page.

How to open and play a review session

 1. In the top menu, click Review.

 2. In the Review page, select a review session to open.

Once in a review session,  a list of one or more reviews opens in the far left column. From here you 
can return to the All Reviews page.

 

NOTE 

If the column is not visible, click on the Reviews tab in the window to the right.
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 3. Click on the video player to the right to start playing the movie. The movie will include all the 
scenes in the review session, stitched together in a single sequence. 

NOTE 

Movies can only be stitched together if their options/parameters all match (see 
Delivery section below). 

 4. While reviewing scenes, you can do the following:

 l To pause, resume, mute or adjust the volume of the video, or to skip to a specific part of 
the video, use the controls inside the video player. Space bar will also work to pause 
or resume your video. 

 l If you want to instantly skip to the beginning of a specific scene, select that scene in 
the Scenes panel to the left. 

 l To skip to the previous scene, click  Show Previous Scene  or press the Up key.

 l To skip to the next scene, click   Show Next Scene  or press the Down key.

 l To go to a specific frame, pause the movie near the frame you want to see, then click  
Show Previous Frame  or press the Left key to go back one frame, or click  Show 
Next Frame  or press the Right key to go forward one frame.

 l To hide or display the controls in the video player, click   Video  controls. 

 l Click  Maximize  to hide the Scenes and the Notes panel and expand the video 
player. 

 l To enable or disable looping, click the  Looping  button. When looping is enabled, 
the player  will play the first scene from the beginning after reaching the end of the 
last scene.

200

Producer 21 User Guide                          



Chapter 11: About Reviewing

Returning to the Session List and Switching Sessions
Once you have already opened a session, you can return to the session list using a number of ways.

How to return to the session list

 1. Do one of the following:

 l From any page, in the top menu, click Review.

 l From the Review Session page, select any open review or any review that was 
created 

 

 l Once in a review session, you can easily switch from one open review to another. On 
the far left of the page there should be a list of Open Reviews.
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 l If the list isn't visible, select the Reviews tab in the window to the right. 

 

 2. From here you can easily switch reviews by selecting the next open review in the column. 
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Removing Scenes from a Review Session
If you accidentally added extra scenes to a review session, you have the ability to remove them.

How to remove scenes from a review session

 1. Make sure you are in the review session list to edit. 

 2. Select Go To All Reviews.

 3. In the Column Selector on the far right, make sure that the Submission column is checked. 

In the column, the number of Scenes/Snapshots that have been submitted appears. 

 4. Click on the Submission number.

The Submission window opens. 

In the Submission window, all the snapshots/scenes for the current review are displayed. 

 5. Select one or more you wish to delete and then click Delete Submissions. 
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NOTE 

This will not delete the scene from Producer. 
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Deleting a Review Session
Deleting a session will permanently erase it and it will not be accessible again. 

NOTE 

Deleting a review  session will not delete any of its scenes, nor will it delete any of the 
attachments or notes created within the session or undo any of the task status changes done 
within the session.

How to delete review sessions

 1. In the top menu, click Review.

 2. In the Review page, check the box on the far left for the review you wish to edit. 

 3. Select More > Delete. 

A confirmation prompt opens.

 4. In the confirmation prompt, click Delete.
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A notification appears indicating that the item is being removed from the session.
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Playing Preview Movies
You can view the preview movie for any environment, job, scene, or asset in the preview column for that item.

How to play a preview movie

 1. Open the job containing the scene you want to preview.

 2. Do one of the following:

 l To play the scene’s preview movie within its thumbnail in the Production page, click 
on the  Play  button below its thumbnail. 

 l To pause the movie within the thumbnail, click on the  Stop  button.  

 l To watch the preview for an item, click on the  Play  button, or click in the video 
player to play the movie. 

 l Press the Stop button or the spacebar to start the movie from the beginning. 

 l To open the preview movie for a scene in high resolution, click on the  Expand  
button below its thumbnail. The preview movie will open in a new tab. 
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Adding a Note to a Scene in a Review Session
Notes can be added to scenes in a  review session to make comments and suggestions, request corrections, 
point out details or  otherwise communicate important information about a scene to project collaborators.

NOTE 

 l Scene notes can also be added and viewed in both the Production page and in the My Tasks 
page.

 l It is also possible to draw annotations over a frame in a scene and attach it to a note.

How to add notes to a scene in a review session

 1. Open the review session containing the scene you wish to review. There can be 4 different columns  
open. 

 2. In the Scenes column, select the scene to which you want to add a note or scroll horizontally in the 
Timeline below the preview area, select the exact frame where you want to add a comment.
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 3. If you want to leave a note for a different process than the pre-selected process of this review, 
select a new process by clicking on the coloured pill, above the comment box, on the left.

NOTE 

This step is OPTIONAL.
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 4. On the top right of the comment box, you may want to edit the “Note Tag”. This tag allows you to 
later arrange notes per review session. For example, all of today’s review sessions notes can be 
tagged with “Retake 1”.

 5. Type your note in the comment box.

There are 4 options to register your comment: 

 l  Approve Scene: Sets the scene review process to Approved in Producer and 
logs your comment with the approval.

 l  Save Note as a Comment: Your note will appear as a comment in the context 
of the current process.

 l  Revise Note: This will set the scene review process to Retake (or Revise) and 
will save your note as the explanation.

 l Optional: You can check the brush to mark an “Artistic Retake” or the wrench 
to mark a “Technical Retake” (or both).
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 l  Set a Custom Status: Select a custom status using the down arrow. 
Once the desired status is displayed, click on it to set the review process of the scene 
to this status and save your comment along.
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Drawing Annotations While Reviewing Scenes
The Review tool allows you to freeze on a specific frame in the preview movie, draw annotations over it using a 
variety of drawing tools, then add this annotation to the scene, as a note.

An annotation is added to a scene as an attachment to a note. They can be viewed from the Review page as 
well as Production and My Task pages by opening the note attachment.

How to draw annotations

 1. Open the review session containing the scene you wish to review.

 2. In the Scenes column, select the scene to which you want to add a note.

 3. Go to the exact frame to which you want to add an annotation by doing one or several of the 
following:

 l Play the video up until it is at the right frame, then pause it.

 l To fast forward to the frame you want to annotate, click and drag on the play head and 
release it when it is at the right frame.

 l To go back one frame, click the   Show Previous Frame  button under the video player or 
press the Left key.

 l To go forward one frame or click the   Show Next Frame  button under the video player or 
press the Right key.

NOTE 

For the keyboard shortcuts to work with the video player, you must click inside 
the Review tool, but outside of the video player.

 4. In the top right, click the Display drawing toolbar  button.

The drawing toolbar appears.

 5. You can use the following tools in the drawing toolbar to draw over the frame:

 l Use the Pen  tool to draw on the frame.

 l Use the Arrow  tool to draw arrows.

 l Use the Box  tool to draw rectangles and boxes.

 l Use the Straight Line  tool to draw straight lines.

 l Use the Erase  tool to erase any drawings..

 l Set the Set Drawing Colour  tool to change the colour of your drawing tool.
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 l Use the Undo Last Drawing  tool to undo the last drawing stroke.

 l Use the Redo Last Drawing  tool to redo the last stroke you undid.

 l Use the  Clear All Strokes  tool to clear all drawings

 6. In the Review process drop-down below the preview area, ensure the process for which you want 
to add an annotation to is selected.

 7. Do one of the following:

 l To only add your annotation to the scene without approving it or sending it for 
revision, click the  Save Note  button.

 l To add the annotation to the scene and send it for revision, click the Revise Scene 
 button.

 l To add the annotation to the scene and approve it, click the  Approve Scene  
button.

The note and its annotation will appear in the Notes column in the middle, near the top. 

If you approved the scene or sent it for revisions, an extra note will appear in the Notes column 
indicating so. The icon next to the scene in the Scenes list will also change to represent its current 
status. 
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Sending a Scene in a Session for Revision
When reviewing a scene in a review session, you can send it back to the project collaborator who worked on it 
to request revisions. You can add a note to specify which revisions are requested, draw annotations over a 
specific frame in the scene to visually indicate what kind of revisions are needed, or both. You can also indicate 
whether the requested revisions are technical or artistic.

NOTE 

NOTE: Adding a note or an annotation is required to send a scene for revisions.

How to send a scene for revisions with a text note

 1. Open the review session containing the scene you wish to review.

 2. In the Scenes column, select the scene that you want to send back for revisions.

 3. In the Enter your comments here text box, type in the content of your note.

NOTE 

You must include a note or annotation drawing when sending sessions for 
revision.

 4. Click  Revise scene  to send the scene for revisions.

 5. In the Select the type of revision dialog, choose whether the note is Regular, Artistic, Technical, or 
Both. 

The status of the scene’s current process is set to Retake. The note appears in the Notes column. In 
the Scenes column, two curved red arrows appear on the left of the scene.
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Approving a Scene in a Session
Once a scene has been reviewed and any notes have been implemented, it can be approved. 

How to approve scenes

 1. Open the review session containing the scene you wish to review.

 2. In the Scenes column, select the scene that you want to approve.

 3. If you want to add a note while approving the scene, type in the content of your note in the Enter 
your comments here text box.

 4. Click  Approve Scene  to approve the scene.

The approval note appears in the Notes column. In the Scenes column, a green checkmark appears 
on the left of the scene.
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Viewing Notes in a Review Session
In the Review page, you can choose whether to view all notes for the items in a session at once, or to only see 
the  notes for the scene currently highlighted in the Scenes list. Notes are listed from newest to oldest.

How to view notes for all the scenes in a review session

 1. View the session whose notes you wish to view

 2. Do one of the following:

 l In the Notes column, click the Filter  button. In the drop-down menu, click For all 
scenes.

 l Click the title of the Notes list.

Only notes for all session items will be visible.

How to view only notes for the current scene in a review session

 1. To return to only viewing notes for one item at a time, do one of the following:

 l In the Notes column, click the Filter  button. In the drop-down menu, click For 
current scene.

 l Click the title of the Notes list. 

Only the notes for the current item will be visible again. 
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Moderating Notes
For this to work, a user must be tagged as a Moderator and another as a Moderated Person by the 
administrator.  As a Moderated Person, their notes will not reach the general public in the production 
immediately. They will have to go through a Moderator(s) in order for their notes to get to the rest of the 
production. This is a safeguard for all involved.

Once the Moderators and the Moderated are in place, notes from the moderated will have to be screened by 
the moderators of the production.

How to moderate directors notes

 1. To add a user as a Moderator or Moderated Person, in the main menu, select Settings. 

 2.  In the Settings tab, select Security.

 3. Find the group in the production you wish to be the Moderator or the Moderated. 

 4. If you need to add or subtract names from those groups, in the User Assign tab, select the User  
icon .

The Assign Users to Group dialog box opens.

 5. Use the check box to add or remove users from the associated group, the click Save.  

 6. In the Global Rules column, select the Edit icon.

The Permissions Manager dialog box opens.
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 7. In the Data Manipulation Permissions section, check the Moderator and Moderated checkboxes.

 8. Click Save.

Now whenever a Moderated person writes a note—see Writing Notes, the status To Moderate is 
added within the note. The Moderated has the ability to edit their notes.

The To Moderate Status also appears in the Notes column of the Open Tasks tab for any user 
designated as a Moderator.
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How to view and moderate notes

 1. In the main menu, select Review.

 2. In the Review tab, in the Open Reviews section, select a review.

In the Notes for [scene name] section, the notes to moderate are displayed. The notes are marked in 
Orange. 

By default you will be able to see one scene at a time. To see all scenes to moderate in this review 
session, click on the green Filter notes displayed icon and select For all scenes.

 

 3. Select one of 3 options: 

 l Contest, if a note is contested, it will NOT appear in Open Tasks of the Moderated 
person, but will appear in the Notes in the review session.

 l Edit, if a note is contested, click on Edit to place a note as to why.

 l Confirm, if a note is approved it will appear in full view of the production.

Alternatively, if you as the Moderator agree with all notes, click on the Confirm Suggestions 

 button to confirm all. 
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If there is a contested note, the Confirm Uncontested Suggestions  button 
appears. 

NOTE 

Anyone who is not a moderator will not see any notes from the Moderated UNTIL they are 
approved by the Moderators. 
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Closing and Reopening Notes in the Review Session
When a note is created, its status is set to Open. Notes can be closed to indicate that they have been 
acknowledged or tended to, and they can be reopened to indicate that they need further attention.

To avoid cluttering the Notes column, notes that have been closed are hidden by default. It is possible to 
display them so that they can be viewed reopened if needed.

How to close a note

 1. Open the review session containing the scenes for which you want to close or reopen notes.

 2. Do one of the following to display the note you want to close:

 3. In the Scenes column, select the scene containing the note you want to close.

 4. Make the Notes column display the notes for all the scenes in the review session.

 5. In the Notes column, find the note you wish to close.

NOTE 

All new notes are  Open by default.

 6. To close an open note, check the checkbox in its bottom-right corner. 

The status of the note is be set to  Closed. Unless you enabled displaying closed notes in the 
Notes column, it will disappear from the Notes column.

How to reopen a note

 1. Open the review session containing the scene for which you want to reopen a note.

 2. In the Notes column, click the Search button. 
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 3. In the drop-down menu, make sure Closed is checked.

Closed notes appear in the notes list. 

 4. Do one of the following to display the note you want to reopen:

 l In the Scenes column, select the scene containing the note you want to close.

 l Make the Notes column display the notes for all the scenes in the review session.

 5. Find the note you wish to reopen.

 6. To open a closed note, check the checkbox in its bottom-right corner. 

The note will now be  Open.

 7. To hide the other closed notes, click the  Filter  button again. 

 8. In the drop-down menu, uncheck the checkbox next to Closed.

All closed notes will now be hidden from view. 
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Downloading Reviews
Producer gives you the ability to download the reviews on your local machine.

How to download reviews

 1. In the top menu, select Review.

You will then see Open Reviews, Names of the Reviews and Open Submissions.

 2. To view a submission, click on the number in the submission column. 

The Submission window opens.

 3. You can now download individual reviews by clicking on the check box on the far left and then on 
the blue button in the Actions column. You may select as many check boxes as you like but you must 
select each download button to download individually. 
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 4. You can also download multiple scenes at the same time into a Zip folder. Select all the scenes you 
wish to download and then click on the Download button above the entries. 

 5. If you wish to download a full review with all the videos stitched together, select the review you 
wish to open from either the Open Reviews area or by selecting the Open Review  button from 
the Actions column. 

A new window opens. 

 6. In the Scenes area, check the select all boxes  or select the individual videos you wish to have 
stitched together.

 

 7. In the Play window, select the more options button  to the bottom right of the screen. 

A new window opens. 

 8. Select Download. 
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NOTE 

If there are red lines separating the videos, there was a problem stitching the 
videos together. It could have be cause by a number problems, ie:  video codec, 
audio codec, fps, timebase, aspect ratio.
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Chapter 11: About Importing from Storyboard Pro
This procedure will allow you to create all the scenes in Producer and import the animatic and meta-data 
directly from Storyboard Pro.
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Chapter 11: Importing from Storyboard Pro
This section explains how to  export data from Storyboard Pro and import it in Producer.

How to export data from Storyboard Pro

There are 3 steps to export your data:

 l Add leading Zeros

 l Export CSV from Storyboard Pro

 l Export Movie files from Storyboard Pro

Add leading Zeros

 1. Go to Preferences > Naming tab, select Automatically Add leading Zeros. 

 l In Storyboard Pro, make sure your scenes are named with leading zeros (for example: 01, 02, 
03 or 001, 002, 003 and not simply 1, 2, 3) 

 l Enter the Minimum Number of Characters. 

 l In the Top menu, click Storyboard and select Rename Scene. 
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 l Save your SBP project.

Export CSV from  Storyboard Pro

 1. From Storyboard Pro, choose File / Export / CSV

 2. Uncheck the “Transitions” option

 3. Click Export
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Export Movie files from Storyboard Pro

 1. From Storyboard Pro, choose File / Export / Movie

 2. Fill in the Destination Path

 3. Leave the File Pattern field blank

 4. In One Clip field, select per Scene from the drop-down list

 5. Click Export
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How to import Storyboard Pro data in Producer

 1. Determine which workflow process will be used. 

We recommend that you create a process "Animatic" in your scene workflow.

 2. Use “Import from Storyboard Pro” in Producer Link. 
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NOTE 

Please see How to download Producer Link for more information on downloading the Producer 
Link.

 3. Open the Producer Link application. 

TIP 

If your Producer Link is not already connected to Producer, make sure to use the login function.

 4. From the menu, select Import from Storyboard Pro.

 5. Fill all the fields.

NOTE 

If you have created an animatic process, select “Animatic” from the drop-down list.

 6. Click “Import CSV”.
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You can monitor the import process by scrolling down. In Producer, refresh your Production page to see the 
new scenes.

How to download Producer Link

To download the Producer Link, you can follow the steps below.

 1. Select “Downloads & Resources” from the menu.
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 2. Click the Producer Link file for your platform.
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Chapter 11: About Reports 
Reports can be used to keep a track of multiple aspects of the production.
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Chapter 11: Sharing Reports
This procedure will allow you to share the report to a user or group of users.

How to share reports

 1. In the main menu, select Reports.

 2. In the left panel, select a report from the section “My Reports”

 3. In the main section, select the option “Share this Report”

The report can be shared globally, to a specific user or group of users.

Shared reports will be displayed in the left panel under the section “Shared with me”
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Chapter 11: Exporting Reports
This procedure will allow you to export the data so that you may use it in another software, such as a 
spreadsheet.

How to export reports

 1. In the main menu, select Reports.

 2. In the Reports tab, select the type of report you would like to create (Job Tasks, Productivity, 
Progress or Summary).

 3. Select a specification of the report from the drop-down list.

The report options/types appear.

 4. In the Name field, enter the name of the report.
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 5. Click Save.

The report  is saved in the Saved Reports column on the left.

You can  hover your mouse over different areas of the graph to see additional information.
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 6. In the Search Criteria section, use the drop-down menu to select specifics that you would like to find 
in the generated report.

 7. Click the Search button to initiate the search.

The search results from the generated report are displayed.

NOTE 

You can continue to generate reports and access them later in the Saved Reports 
column. You can use the Search feature at any time to search for specific data from any 
generated report.

 8. In the Report Data section, click Export >To CSV to export a CSV file of a particular report.
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A .csv document downloads.
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