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Introduction

Introduction

The Harmony core functionality are explained in this User guide. All the steps required to create and complete 
a project are covered in the following chapters with concept descriptions and detailed step-by-step 
procedures focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide 
and Preference guide. Some of them are explained here where necessary to the understanding of a given 
concept or procedure.  

43



44

Harmony 21 Premium User Guide                          



Chapter 1: Project Creation

Chapter 1: Project Creation
Once Harmony Premium is installed, you are ready to start the application and animate! In this chapter, you 
will learn about starting the application, as well as creating, opening and saving scenes
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About Harmony Stand Alone
Harmony Stand Alone allows you to create, open, save and manage scenes on your computer's file system. 
Unlike Harmony Server, Harmony Stand Alone does not have a database system. Each scene you create is an 
independent project, and you must organize your scenes yourself. 

If you have a Harmony Server license, you can still choose to run Harmony in Stand Alone mode if you like. 
However, if you have a Harmony Stand Alone license, you can only run Harmony in Stand Alone mode. 
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Starting Harmony in Stand Alone Mode
T-HFND-001-002

You can run Harmony Premium from your operating system's desktop. 

WARNING 

On macOS, Harmony and its other applications will not run on the first time unless you right-click 
on the application, then select Open. You will be prompted to confirm a security exception, which 
will require administrative privileges. 

How to start  Harmony Stand Alone

 1. Depending on your operating system, do one of the following:

 l Windows: Do one of the following:

 l On the desktop, double-click  Harmony Premium

 l Open the Start menu and, in the list of programs, select Harmony 21 Premium >  
Harmony Premium.

 l macOS: In Finder, proceed to Applications >  Toon Boom Harmony 21 Premium and 
double-click  Harmony Premium.

 l GNU/Linux: In the GNOME top menu, select Applications > Harmony 21 Premium >  
Harmony Premium.

The Harmony Premium application launches and displays a splash screen. After the splash screen:

 l If you have a Harmony Stand Alone license, the Welcome Screen will appear

 l If you have a Harmony Server license, the Log-In Screen will appear. You can proceed from 
the Log-In Screen to the Welcome Screen by selecting Work Offline and clicking on the OK 
button.

Once you are at the Welcome Screen, see About the Welcome Screen on page 48. 
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About the Welcome Screen
T-HFND-001-003

As soon as you launch Harmony, you are greeted with the Welcome screen, from which you can:

 l Create scenes

 l Choose your new scene's resolution

 l Manage your scene resolution presets

 l Quickly open recently opened scenes

 l Browse for and open a scene you already created.

 l Watch Harmony video tutorials on the web.

 l Access the support web page.
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NOTES 

 l If you are using Harmony Server, you must use the  Control Center application to create your 
scenes before you can open them in Harmony. Harmony Server scenes cannot be created 
directly in Harmony.

 l You can disable the Welcome screen and make Harmony launch right to the main application 
window by unchecking the Do not show this window at startup option at the bottom.

 l You can return to the Welcome screen from the main application window by selecting Help > 
Show Welcome Screen in the top menu. If you disabled the Welcome screen, you can re-
enable it again by returning to the Welcome screen and unchecking the Do not show this 
window at startup option.
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About Harmony Stand Alone Scenes
When working in production, it is important to keep your work organized. It is important to create a naming 
convention chart and establish a file storage structure before starting the project. It is not only extremely 
important that everyone follows the criteria laid out in the naming convention chart and the file storage 
structure, but also that they understand the organization and where to find the files.

A well thought-out and logical naming convention will help keep your production structured and allow it to 
run smoothly by preventing the loss of files due to chaotic organization.

In this section, you will learn how to create, open, organize,  and name the different components in your 
animation project.
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Creating Scenes in Harmony Stand Alone

T-HFND-001-005

All scenes created via  Harmony Stand Alone are independent and local to the computer. You can create or 
open a scene using the Welcome screen or the File menu.

If you are using Harmony Server, you must use the  Control Center application to create your scenes before 
you can open them in Harmony. Harmony Server scenes cannot be created directly in Harmony.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.

NOTE 

The scene name should not exceed 23 characters and cannot contain special 
characters, such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location 
field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created. The main application window will appear with your new scene opened in it.
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How to create a new scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > New. 

 l In the File toolbar, click the New  button. 

 l Press Ctrl + N (Windows/Linux) or ⌘  + N (macOS).

The New Scene dialog box opens.

 2. In the Project Name field, type the scene's name.

 3. Select a scene directory by clicking the Browse button.

NOTE 

The scene name cannot exceed 23 characters and cannot contain special characters, such as 
*&^%!.

 4. In the Resolution window, select the scene’s resolution and click Create.

A new scene is created.
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Creating Custom Resolutions in Harmony Stand Alone

T-HFND-001-006

You can create your own custom resolution presets for your projects.

How to create a custom resolution

 1. Create a new scene from the Welcome screen or from the File menu in Harmony.

 2. Set the scene resolution by doing one of the following:

 l Select a scene resolution from the Camera sizes drop-down menu.

 l Set a custom resolution by changing the values in the Width and Height fields. This 
preset will not be saved.

NOTE 

The different editions of Harmony support the following maximum render 
resolutions:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited

 l Add a new resolution to the list by clicking the Add   button. You can delete a 
custom resolution from the Resolution list by selecting it, and clicking the Delete 
button.

 3. In the New Resolution dialog box, fill in the following fields and click Create.

 l Resolution Name: Name your new resolution.

 l Resolution: Set the width and height of the scene, in pixels. 
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 l Field of View: Select how the angle of the field of view  should be determined. 

 l Horizontal Fit: The angle of the field of view is adjusted to the width of the 
scene.

 l Vertical Fit: The angle of the field of view is adjusted to the height of the scene. 

 l Custom Fov: Set the angle of the field of view to a custom value. 

 l Frame Rate: The amount of frames to play each second. You can select one of the 
preset frame rates in the Preset drop-down, or type in a custom frame rate in the 
Frames per second field. 
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Opening Scenes in Harmony Stand Alone

T-HFND-001-007

You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen

 1. In the Recent Scenes section, click Open.

The Open Scene browser opens.

 2. Browse and select an .xstage file.

 3. Click Open.

How to open a scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > Open. 

 l In the File toolbar, click the Browse  button. 

 l Press Ctrl + O (Windows/Linux) or ⌘  + O (macOS).

The Open Scene browser opens.

 2. Browse and select the desired .xstagefile.

 3. Click Open.

How to open a recent scene from the Welcome screen

 1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu

 1. From the top menu, select File > Open Recent.
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 2. Select a scene from the displayed list.
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Setting the Scene Length in Harmony Stand Alone

T-HFND-001-009

Once you have opened your scene, you can set its length. 

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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About Scene Settings in Harmony Stand Alone

T-HFND-001-010

When you created your  scene, you set up the resolution and the alignment. However, if you want to change 
these settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options are 
separated into four tabs.

NOTE 

Refer to the Scene Setting dialog box  in the Reference guide to learn more about the individual 
parameters of the Scene Settings dialog box.

How to access the Scene Settings dialog box

 1. In the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
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About Saving in Harmony Stand Alone

It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title 
bar beside the scene name to indicate that the scene contains unsaved changes.

To save the current state of a scene as another scene, you can use the Save As command. The Save As window 
prompts you to give a new name and choose a different location to this scene before saving it. This will create a 
complete scene directory for the new scene. The Save As command is not available in Harmony Server.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or 
parameters to see which one will work best. Harmony allows you to save several versions of the same scene.

You can also automatically save your work by enabling Auto-Save.

IMPORTANT 

When a scene has several versions, the drawings and palettes are the same between all the 
different scene versions. You can modify the timing, effects, parameters and camera motions in a 
specific scene version, but if you make change to a drawing or a palette, the change will affect all 
scene versions.
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Saving Scenes in Harmony Stand Alone

T-HFND-001-011

You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses 
the same drawings in all versions. 

How to save a scene

 1. Do one of the following

 l In the top menu, select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).
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Saving Scenes as Copies in Harmony Stand Alone

Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene 
a new name. The name cannot exceed 23 characters.

 3. Click Save.
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Saving Scenes as New Versions in Harmony Stand Alone

Saving a new version of your scene allows you to save your scene at it's current location, under a new file name. 

How to save a new version of a scene

 1. Select File > Save As New Version.

The Save Version dialog box opens.

 2. In the Save Version dialog box, type the new version name.

 3. Click OK.
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Enabling Auto-Save in Harmony Stand Alone

T-ANIMPA-001-001

You can allow the software to automatically save your scene, as well as decide on the interval of time between 
auto-saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l macOS: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): The frequency at which auto-save happens.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you 
are drawing or doing anything in the application. Auto-save will not happen until you 
have stopped using the application for this amount of seconds. 

 l Ask Before Saving: Before performing an auto-save, you are prompted with a 
message to confirm if you want to save or not. 

 l Enabled: This enables the Auto-save feature. If you do not want the system to 
automatically save your work, uncheck this option. Auto-save is off by default.
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About the File Structure in Harmony Stand Alone

T-HFND-001-008

A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the 
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the 
files contained in the folder structure.

Here is an example of the file structure contained in a scene. As you work and use more features, different 
folders may appear in your structure.

The Harmony scene folder contains the following folders:

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation 
column in the Xsheet view.

audio Contains all imported audio files.

elements
Contains all the drawing files. The drawings are organized by folders named like 
the layers they are associated with.

environments
If the scene was exported from a Harmony Server database, this directory will 
contain the palettes and templates that were stored in the scene's environment. 
Otherwise, it is empty.

frames
Contains the final frames after a render if you are using the default settings of the 
Write node in the Node view.
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jobs
If the scene was exported from a Harmony Server database, this directory will 
contain the palettes and templates that were stored in the scene's job. Otherwise, 
it is empty.

palette-library Contains scene palettes and scene palette list files.

timings
This folder is used when a user links external images to a scene and wants to 
store a backup copy in case the link breaks.
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About Harmony Server

Harmony can be used in database mode (online) via the server connection (Harmony Server) or as a standalone 
application (offline).

Several animators can work simultaneously on the same project while the asset library provides users with 
easy access to up-to-date media assets. Harmony is scalable; more than 100 staging clients can share 
animation just as easily as a few can. 

Harmony Server is the link between the client machines and the server. It lets you work on the different 
projects stored in the central Harmony database. 

At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository. 
The server is compatible with Windows, GNU/Linux or macOS. To learn more, refer to the Control Center 
Guide.

If you have a Harmony Server license, when you start Harmony, you can opt to either work offline in the 
application as a standalone software, or connect to the database to work on projects via the database.

When working with Harmony Server, the scenes and their data are stored directly on the server. No data is 
saved or stored on the client machine. The client machines access the database and load the scenes and 
drawings directly from the server. Each time the user saves his scene, the data is updated directly on the 
server. There are no upload or download operations (check-in, check-out) done between the server and the 
clients.

NOTE 

If you have a standalone license, you will not have access to the database. You will automatically 
start the application in standalone mode.
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About the Database Structure in Harmony Server
Harmony Server has a client-server configuration linked through a network. Although the user is working on a 
client machine, all of the data is saved on the server.

You can compare the Harmony Server structure to a filing cabinet. Every element is structured and follows a 
strictly organized hierarchy.

The following production structure hierarchy is used:

 l Environment: Production, project, feature film, series—see Environment Structure on page 67

 l Job: Episode and sequence from each environment

 l Scene: Scene from each job

 l Element: Layers and columns from each scene

 l Drawing: Drawings from each element

If you imagine the environment as a filing cabinet containing all the folders and information, then the following 
structure is used:

 l The job is a drawer in the filing cabinet containing all the folders related to the drawer’s topic.

 l The scenes are the folders contained in that drawer

 l The elements are the papers contained in the folder

 l The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so 
nothing is lost. By adhering to this structure, every user working in the database always knows where to find 
the scenes to work on.

Environment Structure

Before you create or save any elements in your production, you should decide upon a project name. This should 
reflect the content or title. Use the name to create the project’s environment, where you will store all of your 
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production elements.

For example, the environment could be called adventure_movie. An environment can be used for movies, 
series, commercials, student work database, etc.

For a series, you can create an environment with the same name as the series, such as smith_family. Then 
you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers 
represent:

 l sm: The first two letters of the name smith

 l ep: Episode

 l 001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can 
create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require 
splitting into episodes or sequences, you can group them all in the same environment.

For a database of student’s work, you can create an environment and name it with the class or group name, 
such as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store 
the different student exercises in separate scenes under their job name.
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About the Database File Structure in Harmony Server
ForHarmony Server, the scene files as well as user and configuration files are contained within the database 
structure. If you want to share or archive a project, you will need to use Control Center to export your data from 
the database. If you receive a package from another user or studio, you will also need to use Control Center to 
import it in your database. Refer to the Control Center User Guide to learn how.

All Harmony Server directories are located at the root of your file system by default. On Windows, this is at the 
root of the C:\ drive. On macOS and GNU/Linux, this is simply referred to as the root directory, or /.

/usa_db

The usa_db directory contains the file structure of the database server. This is 
where all the information about the database structure is stored, including 
the hierarchy of environment, jobs and scenes, their various settings, user 
profiles and the location of the scene data on the network. 

/usadata

The usadata directory is where all the scene data is actually stored. It is 
stored in a different directory than the database structure to allow using 
different machines to store the database and to store the scene data. There 
may be several usadata folders, each followed by a number. This occurs 
when the server is configured to store scene data on more than one data 
server, to expand its storage space.

Although the hierarchy of a database starts with environments, inside which are jobs and inside which are 
scenes, the environments and jobs in a Harmony Server database are stored in separate folders in /usa_db. 
Hence, while browsing /usa_db, you cannot navigate from an environment to one of its jobs. You must go 
directly to the jobs directory to find its content.

Inside a job directory, you will find one folder for each scene contained in the job. This is actually a shortcut that 
points to the actual scene data folder of the scene, which is located to one of the /usadata folder for the 
database. 
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About Scene Creation in Harmony Server
When working in Harmony Server, you can only open and edit scenes that were already created. To create 
scenes, you must use the Control Center module. 

For documentation on how to use Control Center to create scenes, refer to the Control Center User Guide.
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Starting Harmony in Server Mode
T-HFND-001-002

You can run Harmony Premium from your operating system's desktop. 

WARNING 

On macOS, Harmony and its other applications will not run on the first time unless you right-click 
on the application, then select Open. You will be prompted to confirm a security exception, which 
will require administrative privileges. 

How to start Harmony 

 1. Depending on your operating system, do one of the following:

 l Windows: Do one of the following:

 l On the desktop, double-click  Harmony Premium

 l Open the Start menu and, in the list of programs, select Harmony 21 Premium >  
Harmony Premium.

 l macOS: In Finder, proceed to Applications >  Toon Boom Harmony 21 Premium and 
double-click  Harmony Premium.

 l GNU/Linux: In the GNOME top menu, select Applications > Harmony 21 Premium >  
Harmony Premium.

The Harmony Premium application launches and displays a splash screen. After the splash screen, 
the log-in dialog box appears—see Connecting to the Database in Harmony Server on page 72.
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Connecting to the Database in Harmony Server
Before you can work in Harmony via Harmony Server, you must be connected to the Harmony database. 

How to connect to the Harmony database

 1. Start  Harmony —see Starting Harmony in Server Mode.

 2. In the log-in dialog, select the Connect to Database option. 

 3. In the User Name field, type in your Harmony username. 

NOTE 

This username should be provided to you by your project lead or system administrator. 

 4. Click on OK. 

The Database Selector dialog box opens, displaying the environments available in Harmony 
database.

You can now navigate to a scene and open it—see Opening a Scene in Harmony Server.
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About Scenes in Harmony Server
In Harmony Server, you must use Control Center to create scenes. Then, you can open your scenes in Harmony 
and configure them, set them up, create several versions and manage those versions. 
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Opening a Scene in Harmony Server

Once you are connected to the database in Harmony, you can open a scene in the database.

How to open a scene in Harmony Server

 1. Connect to the database—see Connecting to the Database in Harmony Server on page 72.

The Database Selector appears when you log-in.

 2. In the Environments column, select the scene's environment (project, movie, season). 

 3. In the Jobs column, select the scene's job (episode, sequence). 
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 4. In the Scenes column, select the scene. 

 5. Get the permissions needed for this session by selecting one or several of the following options:

 l Get rights to modify the scene: Allows you to modify the selected version of the scene as 
well as to manage and overwrite other versions. Other users will not be able to open a 
different version of the scene until you close the scene..

 l Get rights to modify the scene version: Allows you to modify the currently selected scene 
version only. Unless the Get rights to modify the scene option is also checked, you will not 
be able to change other versions of the scene. This allows other users to modify different 
versions of the scene while you are working on the selected version.

 l Get rights to modify the scene assets: Automatically gets the rights to modify all of the 
scene's assets, locking other users from making changes to them until you close the scene. 
This means that you will have the rights to modify all the scene's versions, drawings, 
palettes, its palette list, but not its library folder. If this option is unchecked, drawings and 
palettes will be locked unless you unlock them manually. This can allow another user to 
work on the scene's drawings and palettes in Paint while you are working on the scene's 
timing or staging in Harmony.

 6. If this is a heavy scene, check the Cache scene assets locally option. If this option is checked 
Harmony will download drawings to your computer before opening the scene and load the 
drawings from your computer instead of from the network. Harmony will upload the updated 
drawings back to the network when you save, so you do not have to worry about uploading them 
manually.  
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NOTE 

If this option is checked, it may take a while to download all of the scene's assets when 
opening a particularly heavy scene.

 7. Choose the version you want to open from the Version menu.

NOTE 

The Saved By and Saved Date fields display the user who last saved the selected scene 
and the date of the last save.

 8. Click on Open.
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About Scene Settings in Harmony Server

When you create a scene in Harmony Server, its settings such as the scene resolution and framerate are set to 
default values. You can change your scene's resolution, framerate, alignment and other settings using the 
Scene Settings dialog. 

NOTE 

Refer to the Scene Setting dialog box  in the Reference guide to learn more about the individual 
parameters of the Scene Settings dialog box.

How to access the Scene Settings dialog box

 1. In the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
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Setting the Scene Length in Harmony Server

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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About Saving and Scene Versions in Harmony Server

When you use Harmony Server and work in a scene on the database, there are many choices and options 
available when you save your work. Specifically, the Advanced Save dialog lets you do the following:

 l Save the scene as the current version.

 l Save different versions representing different stages of the production of your scene.

 l Save different versions representing different scene setups.

 l Choose specific assets that you want to save, such as drawings or palettes. 

When you open the scene from the database and select the version you want to edit, you can save the 
changes you made in the current version or create a new version. The simplest way to save your work is to 
update the current version. 

You can delete any unnecessary versions using the Versions window.

When working with multiple versions, you may want to merge some of the changes from one version into 
another. You may have created a version with some suggestions that you submitted to the director while 
continuing to work on the official version. If the director has approved some of the changes, you can go ahead 
and import them into the official version.

You might want to save some specific aspects of your scene or save a new version. The Advance Save feature 
allows you to do this. Once you have chosen the components to save, you will conclude the procedure by 
following the instructions in the  section. All the specific components that are selected throughout the different 
tabs of the Advanced Save dialog box will be saved. 

You can also automatically save your work by enabling Auto-Save.

IMPORTANT 

When a scene has several versions, the drawings and palettes are the same between all the 
different scene versions. You can modify the timing, effects, parameters and camera motions in a 
specific scene version, but if you make change to a drawing or a palette, the change will affect all 
scene versions.
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Saving a Scene in Harmony Server

The first time you save a scene in Harmony Server, you will be prompted to create a first scene version. Once 
the scene has at least one scene version, you can instantly save to that version every time you make changes to 
your scene. 

How to save the first version of a scene in Harmony Server

 1. Make sure you have the necessary rights to save the current scene version. If you do not, you can 
acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene in 
the top menu. 

 2. Do one of the following: 

 l In the top menu, select File > Save.

 l In the File toolbar, click on the  Save button.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS). 

When saving the scene for the first time, the Save dialog box opens, prompting you to name the 
version.
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 3. In the This Version field, enter a relevant name for the current version.

 4. In the Description field, if you want, you can enter a short description of the current version.

 5. Click on Save. 
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Saving a New Scene Version in Harmony Server

You can save different versions of your scene and add descriptions to each version to keep track of the changes 
made to a scene over time

How to save a new version of the scene in Harmony Server

 1. Make sure that you have the necessary rights to save the current scene version. If you do not, you 
can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify 
Scene from the top menu.  

 2. From the top menu, select File > Advanced Save. 

The Advanced Save dialog appears.

 3. Make sure the Save option is checked. 

 4. Select the New Version option.

 5. In the New Version field, enter a relevant name for the new version of your scene.
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 6. In the Description field, if you want, you can enter a short description of the current version.

 7. If you want the new version to be marked as the current scene version, make sure the Mark as 
Current option is checked. This will make the version you are creating the default version of the 
scene, when opening it. 

 8. Click on Save. 
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Deleting Scene Versions in Harmony Server

View a list of the different versions of your scene, along with their corresponding description. Use this 
information to delete various versions.

How to delete versions

 1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene. 

 2. Select File > Manage Versions. 

The Versions window opens. 

 3. In the Existing Versions list, select the scene version you want to delete. When a version is 
selected, information about it appears in the Description area.

 4. Click Delete. 

The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone. 

 5. Click one of the following:

 l Yes:  Only if you are absolutely certain that the version can be deleted.
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 l No: To cancel the operation and keep the version. 
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Merging Scene Versions in Harmony Server

If you have two different versions of a scene that need to be brought together, you can merge them.

How to merge scene versions

 1. From the top menu, select Edit > Open Merge Editor.

The Choose Scene Versions for Merge window opens.

 2. In the Select Version to Merge Changes From list, select the scene version from which you want to 
merge the changes from in your current open version.

In the Use Another Version for Reference section, you can select a different scene version to merge 
the changes into, rather than your current version.

 3. Click Load.

The Merge Editor opens.
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 4. From the right column, select the layers you want to merge the changes from into the reference 
version.

 5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate from 
what frame to what frame you want to take the changes from.

 6. Click Merge Selected to complete the operation.
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Advanced Saving in Harmony Server

Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your 
scene. 

How to use the Advanced Save dialog box

 1. Make sure that you have the necessary rights to save the current scene version. If you do not, you 
can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify 
Scene from the top menu.  

 2. From the top menu, select File > Advanced Save. 

The Advanced Save dialog appears.

For information on the parameters in the Advanced Save Dialog Box, refer to the Advanced Save 
Dialog Box topic of the Reference guide.
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Enabling Auto-Save

You can allow the software to automatically save your scene, as well as decide on the interval of time between 
auto-saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l macOS: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): The frequency at which auto-save happens.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you 
are drawing or doing anything in the application. Auto-save will not happen until you 
have stopped using the application for this amount of seconds. 

 l Ask Before Saving: Before performing an auto-save, you are prompted with a 
message to confirm if you want to save or not. 

 l Enabled: This enables the Auto-save feature. If you do not want the system to 
automatically save your work, uncheck this option. Auto-save is off by default.
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About the Scene File Structure in Harmony Server

A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the 
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the 
files contained in the folder structure.

Here is an example of the file structure contained in a scene. As you work and use more features, different 
folders may appear in your structure.

The Harmony scene folder contains the following folders:

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation 
column in the Xsheet view.

audio Contains all imported audio files.

database
This is no longer used for new projects. It remains for projects created with older 
versions of the software.

elements
Contains all the drawing files. The drawings are organized by folders named like 
the layers they are associated with.

frames
Contains the final frames after a render if you are using the default settings of the 
Write node in the Node view.

palette-library Contains scene palettes and scene palette list files.

stage Contains one .stage file for each version of the scene.

timings
This folder is used when a user links external images to a scene and wants to 
store a backup copy in case the link breaks.
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About Global Lock in Harmony Server
Harmony Server has a lock system, referred to as Global Lock, for the different scenes and scene assets. 
Because all the data on the server can be accessed directly and modified from any client machine by default, 
the scenes are locked. You must obtain the rights to modify scenes in order to save your work on the server.

Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users can only 
open the scene in read-only mode. They will not be able to save any modifications.

If you work in standalone mode, you automatically have the rights to modify all drawings and palettes.

Global Lock offers three levels which are available from the Database Selector when you log in to Harmony. 
From there, you can select a scene and obtain the rights to modify it by selecting the desired lock option.

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked. 
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked items. 
If someone tries to open a locked scene, it will be displayed as read-only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, nodes but not the drawing, palettes, palette-
lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.
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Library Folder lock Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a 
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is 
created using the Control Center module.
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Acquiring Rights to Loaded Scenes in Harmony Server

If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire the 
necessary rights without closing and reloading the scene. 

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This 
process is done during the initial loading of the scene. To learn more about enabling the rights to modify while 
creating environments, jobs and scenes, refer to the  Control Center Guide.

How to set the scene's rights after the scene is loaded

 1. In the top menu, select File and one of the following:

 l Rights to Modify Scene: Allows you to modify the selected version of the scene as 
well as to manage and overwrite other versions. Other users will not be able to open 
a different version of the scene until you close the scene.

 l Rights to Modify Scene Version: Allows you to modify the currently selected scene 
version only. Unless the Get rights to modify the scene option is also checked, you 
will not be able to change other versions of the scene. This allows other users to 
modify different versions of the scene while you are working on the selected 
version.
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About Drawing Lock in Harmony Server
The drawings are stored on the server database providing access to them from every client machine. They are 
locked to avoid different users from modifying the same drawings simultaneously. Only one person at a time 
can get the rights to modify them. The drawing rights are independent from the scene rights because in a 
production rush, two users may need to work on the same scene to finish painting the drawings faster. One 
user will get the rights for one set of drawings, and the second user the rights to another set of drawings. This 
prevents work from being duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new 
drawings by drawing directly on an empty cell. This mode is enabled by default when you open a scene 
version with the rights enabled.

NOTE 

If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing 
mode is not available.

When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a 
selection of specific drawings. This is useful when, for example, many users are working on the same scene 
during the ink and paint process and they want to split the drawings to paint between them.

Also, once you got the rights to modify drawings, you can release these rights if necessary.

If your system crashes and the drawings remain locked, you can force the release of the rights. You must use 
this option carefully as data loss may occur if the scene is currently open and being edited by another person. 
Verify that no one else is using the scene prior to forcing the release of the drawing rights.

Since the drawings are stored on the server,  you might at times need to refresh the drawings that are 
displayed in your scene. 
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Locking & Unlocking Drawings in Harmony Server

You can acquire and release the rights to modify drawings when working with Harmony Server.

How to enable the Edit Drawing Mode

 l From the top menu, select Edit > Edit Drawing Mode.

How to get the rights on a selection of drawings

 1. Make sure that the Edit Drawing Mode is disabled.

 2. In the Xsheet view, select the drawings you want to edit.

 3. Select Edit > Get Rights to Modify Drawings or press Alt + L.

How to release the rights on a selection of drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Release Rights to Modify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Force Release Rights to Modify Drawings.

A Warning dialog box opens.

 l Click Yes if you want to continue to force the release.

 l Click No if you want to cancel the force release.

How to read changed drawings

 l Select File > Read Changed Drawings.
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Verifying a Scene's Integrity
The Check Files commandVerifies the integrity of the drawing and palette files in your project.  Use the Check 
Files dialog box to verify that the data is consistent, correct, and accessible.

How to open the Check Files dialog box

 1. From the top menu, select Scene > Check Files.

 2. Click Check Colours to open the Check Colours dialog box.

The Check Colours dialog box checks the palette integrity and displays the colour recovery 
data.
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Chapter 2: User Interface
T-HFND-003-001

Knowing how to manage the Toon Boom Harmony Premium interface helps you to work efficiently and 
organize your workspace conveniently. There are a series of views and toolbars you can use as you perform 
different operations. Usually, each person has a specific way of working in the interface and prefer particular 
views and toolbars. In this chapter, you will learn about the main elements of the interface and how to manage 
them.

NOTE 

To learn more about each view's properties, see the Reference guide.
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

 1. In the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(macOS) .

The Preferences dialog box opens.

 2. In the General tab, in the Options section, uncheck the Use Dark StyleSheet (Requires Relaunch) 
check box.

 3. Click OK.

 4. Close and relaunch Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. 

By default, Harmony will automatically launch in your operating system language if it is one of the supported 
languages. Otherwise, it will launch in English. 

There are two ways of controlling the language in which Harmony launches:

 l By changing the Language preference in the Preferences dialog.

 l By launching Harmony from a command line, with the -lang parameter followed by a two-letters 
language code.

How to change the user interface language for Harmony

 1. In the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(macOS) .

The Preferences dialog box opens.

 1. In the General tab, in the Language section, open the Language (Requires Relaunch) drop-down 
and select the desired user interface language.

 2. Click OK. 

 3. Close and relaunch Harmony.
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How to start Harmony in a specific user interface language from the command line

 1. Open a Command Prompt or Terminal window.

 2. Type in the following command, including the quotation marks, but don't press Enter/Return yet. 

 l Windows: "C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony 21 Premium\win64\bin\HarmonyPremium.exe"

 l macOS: "/Applications/Toon Boom Harmony 21 Premium/Harmony 
Premium.app/Contents/MacOS/Harmony Premium"

 l GNU/Linux: /usr/local/ToonBoomAnimation/harmonyPremium_21/lnx86_
64/bin/HarmonyPremium

 3. Type a space, then type the following parameter depending on which language you want to launch 
Harmony in:

 l English:  -lang en

 l Chinese: -lang zh

 l Japanese: -lang ja

 l Spanish: -lang es

 4. Press Enter/Return.

Harmony will launch in the specified language.
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About Menus
T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, 
some commands are available and others are not. The top menu is always located at the very top of the 
interface.

The top menu contains the following categories:

 l File

 l Edit

 l View

 l Play

 l Insert

 l Scene

 l Drawing

 l Animation

 l Windows

 l Help

On macOS, there is also a Harmony Premium category that contains the following commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.

To access a  view menu, click the Menu  button in the top-left corner of a view.
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A view menu is available in the following views:

 l Camera

 l Colour

 l Drawing

 l Function

 l Library

 l Model

 l Node Library

 l Node

 l Perspective

 l Script Editor

 l Side

 l Timeline

 l Top

 l Xsheet

Quick Access Menu

A quick access menu lets you open a list of the commands you will use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003

The Harmony user interface contains various toolbars, such as the Tools toolbar and the Edit toolbar, to give 
you quick access to various menu commands. 

Toolbars are separated in two main categories:

 l Workspace  toolbars are toolbars that have a general purpose. For example, the File, Edit, Workspace, 
Advanced Animation and Deformation toolbars at the top, as well as the Tools toolbar on the left, are 
workspace toolbars. Those toolbars can be placed at the top, bottom, left or right edge of the 
application window. They can also be placed at the edge of specific views if preferred. 

 l View toolbars are toolbars that are useful for a specific view. For example, the Camera view has a 
Camera toolbar at its top. View toolbars can only be displayed inside their respective view. They can be 
placed at the top, bottom, left or right edge of their view. 

You can display or hide toolbars using the Windows > Toolbars menu. This menu contains all the workspace 
toolbars, as well as the view toolbar for all the views that are currently displayed in your workspace. 

For example, in the default workspace, you have the Camera and the Drawing views in the same area, and you 
can switch between either view by clicking on the Camera or Drawing tab. If the Camera view is the one being 
displayed, then the Camera toolbar will be in the list. If the Drawing view is displayed, then the Drawing 
toolbar will be in the list instead.

Workspace toolbars can be added to either the general workspace or the inside of a view.  For example, you 
can add the Edit toolbar to the top of the area occupied by the Camera view instead of the top of the 
application window, where it is by default. In the default workspace, the Tool Presets and Art Layer toolbars 
are placed in the area where the Camera and Drawing views are, even though they’re actually workspace 
toolbars. 

When a workspace toolbar is added to a view, and several views are placed where this view is, then all those 
views will have this toolbar inside of them. For example, if you add the Edit toolbar to the Camera view, it will 
also be available in the Drawing view, as both these views share the same space. However, the Camera 
toolbar will not be available in the Drawing view as it is specific to the Camera view. 

Some toolbars have buttons that are hidden by default to avoid cluttering. You can customize which buttons 
are displayed in these toolbars, and in which order they’re displayed—see Customizing Toolbars.

TIP 

Many toolbar buttons have a keyboard shortcut associated to them. You can check which keyboard 
shortcut is associated to a button by leaving your mouse cursor over the button for a second. If the 
button has a keyboard shortcut, it will be indicated in the tooltip that appears. 
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Adding and Removing Toolbars
T-HFND-003-004

You can add toolbars to certain areas of your workspace. The way it works is as follows:

 l A workspace toolbar can be added to any edge of the application window, or to the edge of a view in 
your workspace.

 l A view-specific toolbar can be added to the edge of its respective view only. 

NOTE 

When a workspace toolbar is added inside a view, and this view shares its area with other views—
like the Camera and Drawing views do by default—the toolbar will remain visible even if you 
switch to a different view in this area. For example, if you added the Alignment Guides toolbar to 
the Camera view, this toolbar would also be visible in the Drawing view. 

How to add or remove a workspace toolbar to the general workspace

 1. Do one of the following:

 l In the top menu, select Windows > Toolbars and in the sub-menu, select the toolbar you 
want to add. 

 l Right-click on any toolbar that is at the top or side of the workspace, or in the empty space 
next to these toolbars, and select the toolbar you want to add in the contextual menu.
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NOTE 

In the list of toolbars in the top menu and in the contextual menu of the workspace, the 
toolbars listed above the separator are workspace toolbars, and the ones below the 
separator are view toolbars.

How to add a view toolbar to a view

 1. Do one of the following:

 l Click on the tab of the view for which you want to add a toolbar to set the focus on it. Then, 
in the top menu, select Windows > Toolbars and select the toolbar you want to add.
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NOTE 

In the list of toolbars in the top menu and in the contextual menu of the 
workspace, the toolbars listed above the separator are workspace toolbars, and 
the ones below the separator are view toolbars.

 l In the top area of the view to which you want to add a toolbar, to the left of its tab, right-click 
and  select the toolbar you want to add in the contextual menu.
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NOTE 

In the list of toolbars in the contextual menu of a view, the toolbars listed above 
the separator are workspace toolbars, and the ones below the separator are 
view toolbars.
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How to add or remove a workspace toolbar to a view

 1. In the top area of the view to which you want to add a toolbar, left of its tab, right-click and  select 
the toolbar you want to add in the contextual menu. You can also-right-click on a toolbar inside this 
view, if there is any.
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NOTES 

 l If the workspace toolbar was present somewhere else in your workspace, it will be 
removed from its previous position and moved to the view where you just added it.

 l In the list of toolbars in the contextual menu of a view, the toolbars listed above the 
separator are workspace toolbars, and the ones below the separator are view 
toolbars.
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Moving Toolbars
T-HFND-003-005, T-HFND-003-006

You can move toolbars around using drag & drop. This can be used to:

 l Reorder toolbars within the same toolbar area.

 l Move a toolbar from one edge of the application window or view in which it is located to another edge.

 l Hide part of a toolbar with another toolbar. 

Which you do depends on the gesture with which you drag the toolbar:

 l If you drag the toolbar horizontally you are “sliding” the toolbar. This allows you to move the toolbar 
over another toolbar in the same row. When two toolbars share the same space, the toolbar on the 
right appears over the toolbar on the left, and the left toolbar’s rightmost buttons are hidden in a pop-
up menu. 

Likewise, you can do this with a vertical toolbar by sliding it vertically, in which case the toolbar at the 
bottom appears over the toolbar at the top. 

 l If you drag the toolbar vertically, you “pop” it out of its row. When a toolbar is popped out, you can 
reorder toolbars and move the toolbar to another row or to a different edge of the user interface.

Likewise, you can do this with a vertical toolbar, such as the Tools toolbar at the left of the workspace, 
by moving it horizontally. 

NOTE 

You cannot move a toolbar from the edge of the application window to the inside of a view, or vice 
versa. If you want to do that, you must add the toolbar where you want it to be located, and it will 
automatically be removed from the area where it is currently located. For example, if you want to 
move the Edit toolbar from the top of the workspace to the Camera view, all you have to do is add 
it to the Camera view—see Adding and Removing Toolbars.

How to move a toolbar around

 1. Click and hold the handle at the left of the toolbar you want to move.
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 2. Do one of the following:

 l If the toolbar is horizontal, move it up or down to make it pop out of its row.

 l If the toolbar is vertical, move it left or right to make it pop out of its column.

 3. Do one of the following:

 l To reorder toolbars, drag the toolbar where you want it to be located and drop it.

The toolbar will move to its new position. Toolbars to the right (or to the bottom, if the 
toolbar is vertical) will be offset to make space for it.

 l To move the toolbar to a new row or to a new column, simply move the toolbar where the 
new row or column should be created. For example, to create a new row of toolbars at the 
top of the user interface, move it just below the existing toolbars at the top of the user 
interface. A new row or column will appear, highlighted in cyan.

When you drop the toolbar, the new row will be created and the toolbar will be placed at 
the left end of the row.

Likewise, to create a new column at the left of the user interface, move the toolbar just right 
of the existing toolbars at the left of the user interface.

 l To move the toolbar to another edge of the user interface, drag it all the way to that edge of 
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the user interface.

How to move a toolbar over another toolbar

 1. Make sure both toolbars are in the same row or column. If they are not, move both toolbars to the 
same row or column using the method previously described. 

 l If the toolbars are horizontal, click and hold the handle at the left of the rightmost toolbar. 
Then, without going outside of the toolbar’s row, slide the toolbar towards the left.

 l If the toolbars are vertical, click and hold the handle at the top of the bottom toolbar. Then, 
without going outside of the toolbar’s column, slide the toolbar up. 

As you slide the toolbar over the other toolbar, the other toolbar’s buttons become hidden and a 
pop-up menu button appear.

 2. To separate the toolbars again, simply slide the same toolbar in the opposite direction.

 3. To expand a toolbar that is overlapped by another toolbar, click on the expand button at the right 
of the overlapped toolbar.
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Customizing Toolbars
T-HFND-003-007

Some toolbars have buttons that are hidden by default to prevent clutter. You can customize which buttons are 
displayed in these toolbars, as well as the order in which the buttons are displayed. 

How to customize a toolbar

 1. Right-click on the toolbar that you want to customize.

 2. In the context menu, select Customize.

The Toolbar Manager dialog appears.

NOTES 

 l If the Customize option is greyed out, this toolbar cannot be customized.

 l The Tools toolbar can only be customized in Flat Tools Toolbar mode—see Enabling 
the Flat Toolbar.

 3. To add a new toolbar button, select the button you want to add from the Available Tools list, then 
click on the  Add the selected tool into the toolbar button. 
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The button will be removed from the Available Tools list and added to the Toolbar list. 

 4. To remove a button from the toolbar, select it in the Toolbar list, then click on the Remove the 
selected tool from the toolbar button. 

The button will be removed from the Toolbar list and added to the Available Tools list. 

 5. To reorder the buttons in the toolbar, select a button in the Toolbar list, then use the Move the tool 
up and Move the tool down buttons to change the button’s order. The order of the tools in the 
toolbar from left to right is the same as the order of the buttons in the Toolbar list from top to 
bottom.
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 6. Click OK when you are done customizing the toolbar.
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Enabling the Flat Toolbar
By default, the Tools toolbar hides some of its tools inside pop-up menus. For example, to select the  Cutter 
tool, you must double-click or long-click the  Select tool button, and select  Cutter in the pop-up menu.

However, it is possible to make the Tools toolbar display each tool as a separate button by enabling the Flat 
Tools Toolbar preference. This makes the selection of tools quicker. 

How to make every tool in the Tools toolbar display in buttons rather than pop-up 
menus

 1. Do one of the following to open the Preferences dialog:

 l Windows or GNU/Linux:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Premium > Preferences.

 l Press ⌘  + U.

 2. Select the General tab.

 3. In the Options section, check the Flat Tool Toolbar option.

 4. Click OK.

 5. Close and relaunch Harmony.

NOTE 

In Flat Tools Toolbar mode, some tools are hidden from the Tools toolbar by default. To 
customize which tools are displayed in the Tools toolbar, and the order in which they are 
displayed, right-click on the Tools toolbar and select Customize.
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About Views
T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a 
view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing 
or other type of selection or the option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application, unless you disable the 
Automatically Save Workspace option in the Preferences dialog box.
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Adding Views
T-HFND-003-009

You can easily add views through the top menu or each view.

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the  Add View  button 

 2. Select the desired view from the list.

The view appears as a new tab, in the section of your workspace where you added it.
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NOTE 

Some views, such as the Camera, Perspective, Library, Model and Node views, can be opened 
in multiple instances. For example, this can be useful if you want to have two instances of the 
Camera views open, each focused on different areas of your scene, to quickly switch between 
working on these two areas. 

How to add a view to your workspace                                    as a window                 

 1. Open the Windows menu.                     

 2. In the Windows menu, select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

 1. Click and drag the floating view by its tab and do one of the following:

 l Drop the window over another tab to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the 
edge of a view, a cyan rectangle appears, indicating where the view will be docked.
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NOTE 

The view in which you are currently working will have a red square surrounding it, marking is as 
your active view.
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Closing Views
T-HFND-003-010

You can close one or multiple views by using their closing button.

How to close a view

 1. Click the Close View  button.

If there are several tabs in the same view, press Shift and click the Close View  button to close all 
tabs at the same time.
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Showing and Hiding Views
T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the window you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011

You can move views by dragging their name tab to a new location.

How to move views

 1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s 
tab.

 2. When a blue rectangle outline appears showing an available location for the view, release the tab 
to drop the view into position. One of three things will happen:

 l The view becomes a tabbed view.

 l The view becomes a floating window.

 l The view becomes a new docked view.
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Resizing Views
T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. When you see the Resizing  icon, drag the side of the view to the desired size.
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About Preferences
An important feature of Toon Boom Harmony Premium is the Preferences dialog box. From here you can 
customize the behaviour of various user interface elements, as well as drawing and animation tools, and enable 
or disable advanced features.

NOTE 

For a list of all the preferences as well as their functionality, refer to the Preferences guide.

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows or GNU/Linux:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Premium > Preferences.

 l Press ⌘  + U.

127



About Keyboard Shortcuts 
Harmony uses keyboard shortcuts to allow you to quickly use commands you are familiar with without having 
to browse through menus and toolbars. Learning the keyboard shortcuts for the commands you use the most 
often can be a great way to increase your productivity with Harmony. 

Using the Keyboard Shortcuts dialog, you can: check which keyboard shortcuts are assigned to which 
commands, you can customize existing keyboard shortcuts, and you can assign keyboard shortcuts to 
commands that don't have any.

NOTE 

For more information on how to configure keyboard shortcuts as well as a list of commands and 
their default keyboard shortcuts, refer to the Keyboard Shortcuts guide.

How to open the Keyboard Shortcuts dialog box

 1. Do one of the following:

 l Windows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Premium > Keyboard Shortcuts.
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About Workspaces
T-HFND-003-014

The Harmony interface is composed of several views. You can customize your workspace to suit your working 
style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the 
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can 
access these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your 
workspaces as they are and only save the modifications when you really want to, you must disable the 
Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can 
save your workspace as a new version to avoid over-writing the current one. If you do not want to modify the 
current workspace, use the Workspace Manager to create another one and then modify that one.

Your customized preferences are stored in the following location and you can save them to either share with 
someone else, copy to a second computer or simply back them up.

When working with Harmony Stand Alone, your custom workspaces are stored in:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon Boom 
Harmony Premium\2000-layouts-xml

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon Boom 
Harmony Premium/2000-layouts-xml

 l GNU/Linux: /home/[username]/Toon Boom Animation/Toon Boom Harmony 
Premium/2000-layouts-xml

When working with Harmony Server, you workspaces are stored in:

/USA_DB/users/Harmony Premium/2000-layouts-xml
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Loading Workspaces
T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the following:

 l Select Windows > Workspace > Workspace.

 l Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016

You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.
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 5. Select the new workspace and click the Right Arrow  button to move it to the Workspace 
toolbar.

 6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit 
the name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving Workspaces
T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save Workspace preference

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > 
Preferences (macOS) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save Workspace option.

 4. Click OK. 

The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

 1. Do one of the following:

 l In the Workspace toolbar, click the Save Workspace   button. 

 l You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   button 
to move it to the Available Workspaces list.

 3. Select the workspace from the Available Workspaces list, then click the Delete  button to delete 
the workspace.

 4. Click OK.
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Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow  
 button to move it to the Workspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button 
to move it to the Available Workspaces list.

 3. Click OK. 
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  
buttons to move it up or down.

 3. Click OK. 
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Restoring the Default Workspace
T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select Windows > Restore Default Workspace.
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About Interface Navigation
With the help of menu commands and keyboard shortcuts, some views let you navigate their content by 
zooming in, zooming out, panning and rotating them. You can also reset the zoom level, pan and rotation angle 
of these views as needed.

The navigation commands in the table below can be used in the following views, with some exceptions:

 l Camera

 l Drawing

 l Perspective

 l Timeline

 l Xsheet

 l Node View

 l Function

 l Side and Top

 l Model

TIP 

Keyboard shortcuts can be customized. You can view, search for and change keyboard shortcuts for 
Harmony in the Keyboard Shortcuts dialog. To access the Keyboard shortcuts dialog:

 l Windows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Premium > Keyboard Shortcuts.

Command Action Access Methods

Zoom In
Zooms in the 
view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the Timeline and Xsheet views)

Zoom Out
Zooms out the 
view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except in the Timeline and Xsheet 
views)

Zoom In or Out
Zooms in or out of 
the view.

Roll the middle mouse button up or down.
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Command Action Access Methods

Hold down the Spacebar and the middle mouse button while 
dragging the mouse up or down.

Pan
Moves the view 
horizontally or 
vertically.

Hold down the Spacebar and drag in the direction you want to pan 
the view.

Reset Pan
Resets the view’s 
pan to its default 
position.

View > Reset Pan

Press Shift + N

Reset View
Resets the view to 
its default 
position.

View > Reset View

Press Shift + M

The  Reset View button at the bottom of the Camera view.

Reset Rotation
Resets the view’s 
rotation to its 
default position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s 
zoom to its 
default position.

View > Reset Zoom

Rotate View
Rotates the view 
left or right.

While holding Ctrl + Alt (Windows/Linux) or Ctrl + ⌘  (macOS), 
click and drag the rotating disc to rotate it clockwise or 
counterclockwise.

3D Rotate View

Rotates the view 
in any direction. 
This is only 
available in the 
Perspective view. 

While holding Ctrl + Shift (Windows/Linux) or ⌘  + Shift (macOS), 
click and drag the stage to rotate it in any direction.

Rotate 30 CW

Rotates the 
Camera view 30 
degrees 
clockwise, like an 
animation table.

View > Rotate View CW
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Command Action Access Methods

Rotate 30 CCW

Rotates the 
Camera view 30 
degrees counter-
clockwise, like an 
animation table.

View > Rotate View CCW

Mirror View

Temporarily flips 
the Camera or 
Drawing view 
horizontally, 
allowing you to 
view and edit your 
artwork as if it 
was being 
mirrored.

View > Mirror View

In the Camera or Drawing toolbar, click on the  Mirror View 
button.

Toggle Quick 
Close-up

Instantly 
multiplies the 
view's Zoom 
Factor by 4. For 
example, if the 
Camera View's 
Zoom Factor is at 
100%, this will 
make it toggle 
between 400% 
and 100%. 

Shift + Z

Toggle Full 
Screen

Cycles through 
the following 
display modes:

 l Normal 
Full-
Screen: 
The main 
application 
window 
becomes 
full screen.

 l View Full-
Screen: 
The 

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  + F (macOS)
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Command Action Access Methods

selected 
view 
becomes 
full screen 
and all 
other 
views are 
collapsed.

 l Normal: 
The main 
application 
window is 
restored to 
its original 
size and 
collapsed 
views are 
expanded.

Using the Play Menu to Navigate

From the top menu, you can select any of the following commands from the Play menu to navigate around the 
interface.

Command Description

Start Frame Lets you set the frame on which playback will start.

End Frame Lets you set the frame on which playback will end.

First Frame Jump to the first frame. You can also press <.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline view.  You 
can also press the comma (,) key.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. You 
can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.
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Go to Frame

Opens the Go to Frame window in which you can enter the number of the frame 
you want to display. 

You can also use the Go button, which you can add to the Timeline toolbar 
through the Toolbar Manager. Open the Go to Frame dialog box and enter the 
frame number to jump to.

Enable Playback Plays back your animation from the Top, Side, or Perspective views.
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony. 
The documentation of features and procedures exists online, but you can access it through the software.

A simple, but fast way to find a description of certain menu items and preferences is through the Integrated 
Help.
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Accessing the Documentation
T-HFND-001-004

The Harmony documentation can be accessed from the Help menu.

How to access the Harmony Premium documentation

 1. From the top menu, select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in 
the Preferences panel, use the Integrated Help.

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through a history of the help information that you called up during your 
session.

How to use the Integrated Help with Menu Items

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on macOS.

The Integrated Help window appears.

 2. In the top menu, click on a menu heading to display its contents.

 3. Use your mouse to hover over a menu item.

 4. Press  F1 on Windows/Linux or ⌘  + / on macOS.

In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on macOS.

The Integrated Help window appears.

 2. In the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (macOS).

The Preferences window appears.

 3. In the Preferences window, use your mouse to hover over a preference.

 4. Press  F1 on Windows/Linux or ⌘  + / on macOS.

In the Integrated Help window, a description of the preference appears.
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How to scroll through the bank of searched items

 l In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE 

The moment you close the Integrated Help window all searched items will be erased from the 
memory bank. In order to keep an on-going record of all the search requests made, you must keep 
the window open.
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Chapter 3: Layers and Columns
T-RIG-009-003

Before filling in any values or setting any timing or exposure, you need to create drawing elements. Each 
drawing element is represented as a vertical column in the Xsheet view and a horizontal layer in the Timeline 
view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will be 
applied to both.You can also see your layers displayed in the Node view as nodes.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named 
the same way as the drawing element and is in fact, linked to the drawing element. Its purpose is to contain all 
the drawings related to this element (layer, column). For example, in cut-out animation, a character can have 
many heads available. All of the head drawings will be contained in this folder, even if they are not exposed in 
the Timeline or the Xsheet view.

Drawings are exposed in cells/frames and linked to the drawings saved in the layer's directory. When you 
remove a drawing from a cell/frame, it is not displayed, but still exists in the directory.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all exposures of drawing “1” are updated 
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the 
drawing.

NOTE 

There are different element types available, such as sound and expression. A sound element 
contains sound files. Expressions, Beziers, eases, 3D path, Quadmaps and Pegs are for motion 
purposes during the compositing step. It's not necessary to create these types to create your 
exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu. 
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Layer and Column Types
A column is also known as a layer. There are several types of layers you can add in the Timeline and Xsheet 
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently 
in the Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. 

 

Any time you need to create a vector drawing or import a symbol or image, you can use a drawing layer. You 
can also create bitmap artwork on a drawing layer.

NOTE 

Bitmap images are contained in bitmap layers.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you 
choose to vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a 
bitmap into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when 
you create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.
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NOTE 

If you want to have several cameras with different settings, you can keep adding Camera layers in 
your Timeline view (however, only one will ever be visible at a time as you can only have one 
camera at a time in your timeline). To switch to a different camera, select Scene > Camera and 
select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.

In Harmony, there is a series of effect nodes in the Node Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the 
Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no 
background colour and if you render it as a QuickTime movie or image sequence, it will have a black 
background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize both the Timeline and Node views. 

You can drag and drop other layers onto a Group layer and then collapse the Group layer to hide these other 
layers from view. 

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any 
drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  Functions 
section of the Xsheet view.
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Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This 
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the 
deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in 
the Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to 
your Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When 
you create these columns, they are not linked automatically to any particular drawing layer. You can create a 
motion path using these columns and then link or unlink several drawing or peg layers to it. 

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression 

• Annotation
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Adding Layers and Columns
T-HFND-005-002

There are different ways to add a drawing elements (layers and columns) to your project. By default, when you 
create a new scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in 
the Timeline view.

When you add an element, it will appear as a column in the Xsheet view or as,  a layer in the Timeline view, 
and a node in the Node view. 
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Adding Layers in the Timeline View
T-LAY-001-007

Drawing elements are more commonly known as layers in the Timeline view. Create them using the following 
procedure:

How to add a drawing element from the Timeline view

 1. Do one of the following:

 l In the Timeline view, click the  Add Drawing Layer  button.

 l In the top menu, select Insert > Drawing.

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (macOS).

The Add Drawing Layer dialog appears.

 2. In the Name field, type in the name for your new layer. 

 2. Select whether you want the Line Art layer should be Vector or Bitmap. 

 3. Select whether you want the Colour Art layer should be Vector or Bitmap. 

 4. Select Extend Exposure for Scene Duration checkbox to automatically create and empty drawing 
exposure on each layer and expose them for the duration of the scene.

 2. Do one of the following:

 l Click Add to create this layer, but leave the dialog open so you can create more layers.

 l Click Add and Close to create this layer and close the dialog. 

A new drawing layer is added to the Timeline view.

154

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

Adding Columns from the Xsheet View
Drawing elements in the Xsheet view are more commonly known as columns. You can add columns using the 
following procedure:

How to add a drawing element from the Xsheet view

 1. Do one of the following:

 l In the Xsheet menu, select Columns > Add Columns. 

 l Click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a relevant element name.

 3. In the Type field, select Drawing. 

 4. To complete the operation:

 l Click Add and Close to add your new layers and close the dialog box.

 l Click Add to add your new layers and keep the dialog box open to add column.

 l Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and 
Column Types on page 150.
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Using the Advanced Add Column Dialog Box

How to create a column using the advanced Add Column dialog box

You can use the advanced Add Column dialog box to make more file format and field size options available 
when you insert a column.

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > 
Preferences (macOS) and select the Advanced tab.

 2. In the Advanced Options section, select the Advanced Element Mode option to access the 
advanced Add Column dialog box.

 3. Click OK.

 4. In the Xsheet menu, select Columns > Add Column or press Shift + C.

The Add Column dialog box opens.
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 5. In the Name field, type the new column’s name.

 6. In the Type menu, select the Drawing type.

 7. In the Element section, select one of the following:

 l Create New Element: Creates an independent column with its own drawing folder.

 l Reuse Existing Folder: Links your column to an existing folder within the Element 
folder of your scene. If you select this option, in the Folder menu, select the folder to 
which you want to link your new column.

 l Use Existing Element: Uses drawings from an existing column in the new column. 
Both columns will be attached to the same set of drawings, but their timing will 
remain  independent  from one another. If you modify one of the drawings, it will be 
modified in both columns. This is the same principle as the Clone column.

In the Name menu, select the column to which you want to link your new column.

 8. If you selected the Create New Element option:

 l Deselect the Vector option if you want your layer to contain bitmap images or enable 
it if you want the layer to contain vector drawings. Most of the time, the Vector option 
will be enabled.

 l If you deselected the Vector option, from the Bitmap Format  list, select which type of 
bitmap image you want to insert in the column. Select the SCAN type if you are 
planning to scan drawings using the Toon Boom Harmony Premium Scan module.

 l If you deselected the Vector option and you chose the SCAN type, from the Scan Type 
menu, select what kind of scanning you want to achieve.

 l In the Field Chart field, when importing traditional animation, indicate the size of 
paper on which the animation or background was drawn. If you are not using 
perforated animation paper, leave the 12 field default value as is.

 9. Do one of the following: 

 l Click OK to create the new column and close the dialog box. 

 l Click Apply to create the new column but keep the dialog box opened to create other 
new columns.
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Deleting Layers and Columns
T-HFND-005-004

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

NOTE 

You can select several contiguous layers by holding down the Shift key, clicking on the 
first layer you want to select, then on the last layer you want to select. You can also 
select several layers by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key and 
clicking on each layer you want to select. 

 2. Do one of the following:

 l In the Timeline’s Layer toolbar, click the Delete Layers button. 

 l Right-click on the selection and select Delete.

The selected layers are removed from the Timeline view.

How to delete columns in the Xsheet view

 1. In the Xsheet view, select the columns to be deleted by clicking on their header.
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 2. Do one of the following

 l Right-click on the selection and select Delete Columns. 

 l In the Xsheet toolbar, click the Delete Columns  button.

 l Press Del.

The Confirm Delete dialog box opens.

 l Select the Delete Drawing Files and Element Folder option if you want to delete the 
drawings and folders linked to the selected column.

 3. To complete the operation:

 l Click OK to delete the selected layers.

 l Click Cancel to cancel the operation.

The Warning dialog box may open.

 4. Do one of the following:

 l Click Yes to delete all the frames from your scene.

 l Click No to keep the frames in your scene.

 l Select the Don’t Show This Message Again option if you do not want the dialog box 
to display again in the future.
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Renaming Layers and Columns
T-LAY-001-008

Once you add layers and columns to your project, you can modify their names.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

A text-input field appears over the name.

 2. Type in the new name for your layer and press Enter/Return.

The layer now has the new name.

How to rename a layer in the Layer Properties editor

 1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

 2. In the Name field, rename the layer.

 3. Click Close.

How to rename a column

 1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that 
the column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.
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 2. In the Name field, rename the column.

 3. Click OK.
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Reordering  Layers and Columns
You can change the order of your elements in the Timeline view and Xsheet view. When you change the order 
of your elements in one view, the other one is updated.

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.

 2. Click and drag the selection, then do one of the following:

 l Drop the selection between two layers to move it between those layers. A cyan line will 
appear between the layers where the selection will be moved.

 l Drop the selection onto a layer to rig the selected layers as children over that layer. 

How to reorder columns in the Xsheet view

 1. In the Xsheet view, click on the column’s header with the middle mouse button.

 2. Drag the column to its new position.
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Enabling and Disabling Layers
T-HFND-005-010

You can disable layers so that they do not appear in the rendered image or in the Camera view. This can have 
many purposes:

 l If you used a layer to sketch rough animation or drawings, ideas or designs, you can disable the layer 
permanently once you're done using it as a reference, without deleting the layer.

 l If a specific layer, such as an overlay, character or prop, is in the way of the layer you're working on, you 
can disable it temporarily to de-clutter the Camera view. 

Disabling a layer also hides it from the rendered image. Hence, if you want to hide a layer temporarily, you 
must re-enable it before rendering your scene. 

Likewise, it is also possible to disable peg layers, which makes the peg's child layers unaffected by the peg's 
transformations. You can also disable effect layers to disable their effect. 

How to show or hide all layers

 1. In the layers toolbar, click on the  Enable/Disable All button to enable or disable all layers.

How to show or hide individual layers

 1. Do one of the following:

 l Click the layer's  Enable/Disable button to show or hide that layer. 

 l Press A to show selected layers or D to hide selected layers.

 l Right-click on the selected layer and select Enable > Enable/Disable. 

How to enable the selected layer and disable all others

 1. Right click on the selected layer and select Enable > Disable All Others.
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Enabling or Disabling Solo Mode on a Layer
Solo Mode allows you to instantly and temporarily hide all layers except for the layer or layers you're currently 
working on. Solo Mode can be enabled on one or several layers, and works with the following logic:

 l If Solo Mode is not enabled on any layer, then all enabled layers are visible.

 l If Solo Mode is enabled on a single layer, then only this layer is visible and all others are hidden.

 l If Solo Mode is enabled on several layers, then only these layers are visible and all others are hidden.

While disabling a layer makes it invisible in the rendered image, enabling Solo Mode only affects the preview 
image in the Camera view. 

NOTES 

 l If Solo Mode is enabled on a disabled layer, this layer will not be visible in the Camera view. 

 l If a drawing layer is connected to an inverted Cutter effect, you must enable Solo Mode on both 
the drawing layer and the Cutter effect for them to be visible. 

How to enable or disable Solo Mode on a layer

 1. In the Timeline view, click on the  Solo Mode button left of each layer that you want to make 
visible in the Camera view.

 2. To disable Solo Mode on a layer, click on its  Solo Mode button again.

If you have Solo Mode enabled on many layers and you want to quickly go back to only seeing one layer, you 
can quickly disable Solo Mode on all but one layers, and enable Solo Mode on that layer.

How to enable Solo Mode on a layer and disable it on all other layers

 1. While holding the Alt key, click on the  Solo Mode button of the only layer that you want to 
make visible in the Camera view.

If you want to quickly turn off Solo Mode for all layers it has been enabled on, you can do so by clicking on the 
Toggle solo mode on or off button in the Layers toolbar of the Timeline View.

How to toggle Solo Mode off for all layers

 1. In the Layers toolbar of the Timeline view, click on the  Toggle solo mode on or off button to 
disable Solo Mode on all layers.

 2. When you want to enable Solo Mode again, you can do one of the following:
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 l To instantly enable Solo Mode again on all the layers on which it was previously enabled, 
click on the  Toggle solo mode on or off button again.

 l To only enable Solo Mode again on a single specific layer, click on the  Solo Mode button 
for that layer.
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Locking and Unlocking Layers
You can prevent modifications to a layer by locking in it. While a layer is locked, you cannot select it, 
manipulate it, draw in it, or change its timing in the Timeline view. 

You can Lock/Unlock an audio layer by using the Lock/Unlock button lets you prevent the editing of a layer.

Locking a layer is especially useful if you want to avoid selecting it in the Camera view. Clicking on a locked 
drawing with the Transform tool in the Camera view will select whichever drawing is behind it, if there is any. 
This can help ensure that backgrounds and, more importantly, foreground elements, remain in place once they 
have been properly positioned.

NOTE 

When a layer is locked, you can still make changes to its timing in the Xsheet view.

How to lock a layer or a selection of layers

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock. 

 l Click one of the selected layer’s Lock  icon. 

 l Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (macOS).

All selected layers are locked. 
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How to unlock a locked layer or a selection of locked layers

 1. In the Timeline view, select one or more locked layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Unlock. 

 l Click a selected layer’s Lock  icon. 

 l Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (macOS). 

All selected layers are unlocked.

How to lock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Lock All. 

 l In the Timeline view, select all layers and click Lock  icon of a selected layer. 

 l Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (macOS).

All layers are locked.
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How to unlock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Unlock All. 

 l In the Timeline view, select all layers (locked) and click Lock icon of a selected layer. 

 l Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (macOS). 

All layers are unlocked.

How to lock all other layers

 1. In the Timeline view, select the layers you do not want to lock.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock All Others. 
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 l Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (macOS). 

All layers are locked except the selected ones.

How to lock/unlock an audio layer

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock. 

 l Click one of the selected layer’s Lock  icon.

 l Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (macOS)

All selected layers are locked. 

When a layer is locked, its name is displayed in red. Click the  Lock  icon again to unlock the layer.

How to display locked drawings as outline

 1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings  option.

 2. You can also set this option as a permanent preference. From the top menu, select Edit > 
Preferences (Windows/Linux) or Harmony Premium > Preferences (macOS).

 3. In the Preferences dialog box, select the Camera tab.

 4. In the Tools section, select the Show Locked Drawings As Outlines option.
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Navigating Layers and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and 
layers. Displays the previous drawing, next drawing, previous layer or next layer. using keyboard shortcuts 
that work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames

• Columns

How to navigate through drawings, frames and columns

 1. In the Timeline or Xsheet view, select a cell.

 2. Once the cell is selected, you can navigate between:

 l Previous and next layers: From the top menu, select Drawing > Previous Layer and 
Next Layer or press H and J.

 l Previous and next drawings: From the top menu, select Drawing > Previous Drawing 

170

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

and Next Drawing or press F and G..

 l Previous and next frames: From the top menu, select Play > Previous Frame and 
Next Frame or press comma (,) and period (.).
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About Clone and Duplicate Layers 
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You 
can do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone 
uses the same drawings for all layers. A duplicated layer is simply an independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, you 
should clone your layer. If you simply want to copy your layers and be able to modify your drawings without 
affecting the original layer, use the duplicate option.
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About Clone Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, 
both will be updated. However, cloned layers can have different timings.

In the Timeline view, the left part of the layer is a node, same as in the Node view. These nodes are linked to 
columns. The right part of the Timeline view corresponds to the Xsheet column. These columns can contain 
drawing exposures or value keyframes. One node can be linked to several columns; one drawing column and 
several parameter columns (rotation, position, scale, pivot, etc.).

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or 
only the drawings. If you choose to clone the drawings and timing, your node will be linked to the same 
element folder, as well as the same drawing and function columns. Therefore, if you change the drawing 
exposure or keyframe on one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the 
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a 
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing 
exposures to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it 
will create a heavier scene. It is better to clone the 50 layers with only their drawings without linking to the 
same timing (function and exposure columns). 
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Cloning Layers

You can clone layers in several ways. Cloned layers use the same drawings.

How to clone a layer

 1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

 l From the Xsheet menu, select Columns > Clone Selected Columns: Drawings Only 
or Columns > Clone Selected Columns: Drawings and Timing.

 l From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and 
Timing.

 l From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only or 
Layers > Clone Selected Layers: Drawings and Timing.

 l In the Timeline view, right-click on the layers and select Clone Selected Layers: 
Drawings Only or Clone Selected Layers: Drawings and Timing.

 l In the Node menu, select Nodes > Clone Selected Layers: Drawings Only or Nodes > 
Clone Selected Layers: Drawings and Timing. When you clone a node, it does not 
automatically connect itself to the Composite node of your scene.

The cloned layer appears. 

NOTE 

By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C 
and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (macOS), this creates a CLONE not a 
duplicate.  Nodes will be linked to the same drawings.  Pegs will be linked to the same function 
columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C 
(Windows/Linux) or ⌘  + C (macOS) and Ctrl + B (Windows/Linux) or ⌘  + B (macOS) for Paste 
Special, and in the Advanced tab, select Nodes: Create New Columns.

174

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

About Duplicate Layers
T-HFND-006-013

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well 
as an independent timing (exposure). When you need the drawings to be modified independently, you will 
want to duplicate the layer instead of cloning it.
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Duplicating Layers

T-HFND-006-014

You can easily duplicate layers. Once duplicated, the layers are completely independent. Drawings are also 
duplicated.

How to duplicate a layer

 1. In the Timeline, Xsheet or Node view, select one or more layers.

 2. Do one of the following:

 l In the Timeline menu, select Layers > Duplicate Selected Layers.

 l In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

 l In the Node menu, select Nodes > Duplicate Selected Nodes. When you duplicate a 
node, it does not automatically connect itself to the Composite node of your scene.

 l From the Xsheet menu, select Columns > Duplicate Selected Layers.

 l From the top menu, select Edit > Duplicate.

The duplicated layer appears.

NOTE 

By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C 
and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (macOS), this creates a CLONE not a 
duplicate.  Nodes will be linked to the same drawings.  Pegs will be linked to the same function 
columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C 
(Windows/Linux) or ⌘  + C (macOS) and Ctrl + B (Windows/Linux) or ⌘  + B (macOS) for Paste 
Special, and in the Advanced tab, select Nodes: Create New Columns.
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About Sync Layers
Use the Sync Layer feature when you need drawings to be separated on different layers, but to have the same 
timing,  such as with the front and back of a shirt collar. The drawing exposures of synced layers not only 
update automatically, but their drawing substitutions correspond as well, as long as the drawings are labeled 
properly.

When using certain drawing tools, such at the Select, Cutter and Reposition All Drawings tools, you can 
enable the Apply to Synced Drawings option while you work. To learn more about this option—see the 
Reference .
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Syncing Two Layers
The Sync Layer feature allows for drawings to be separated on different layers, but to have the same timing.

How to sync two layers

 1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

 2. From the right-click menu, select Sync Layer With.

The Convert to Synced Drawing Layer dialog box opens.

 3. From the drop-down list, select a parent drawing layer to sync with the currently selected layer.

 4. Click OK.

In the Timeline view, when you click on either of the two synced layers, the other will display the 
link icon.

In the Node view, when you click on either of the two synced nodes, the other will display the link 
icon.
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In the right side of the Timeline view, the child layer will update to the parent layer's timing.

 5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in either of the 
two layers.

The other synced layer immediately updates to the same timing.
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Syncing Multiple Layers
You may want to sync more than two layers. However, once a layer is synced,  the Sync Layers menu option 
becomes disabled for that layer. In order to sync a layer to a layer that has already been synced, you need to 
use the Sync Layers command on the yet unsynced layer.

How to sync multiple layers

 1. In the Timeline view, right-click on the drawing layer you would like to sync with an already synced 
pair.

 2. From the right-click menu, select Sync Layers With.

The Convert to Synced Drawing Layer dialog box opens.

 3. From the drop-down list, select the parent drawing layer you would like to sync with the currently 
selected layer. This should be a drawing layer already synced with another drawing layer. You can 
select either the parent or the child from that linked pair; they both appear in the drop-down list.

 4. Click OK.

In the Timeline view, when you click on any of the synced layers, the others will display the link 
icon.

180

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

In the Node view, when you click on any of the synced nodes, the others will display the link icon.

In the right side of the Timeline view, the child layer will update to the parent layer's timing.

 5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in any of the 
synced layers.

The other synced layers immediately update to the same timing.
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Creating Synced Layers
Create a new drawing layer to be synced immediately with an existing drawing layer.

How to create a new synced layer

 1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

 2. From the right-click menu, select Add Synced Drawing Layer.

The Add Synced Drawing Layer dialog box opens.

 3. In the Add Synced Drawing Layer dialog box, add a single or multiple drawing layers.

 4. When you are finished, click Close.

In the Timeline view, when you click on any of the synced layers, the others will display the link 
icon.

In the Node view, when you click on any of the synced nodes, the others will display the link icon.
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In the right side of the Timeline view, the child layer will update to the parent layer's timing.
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Selecting All Synced Layers
You can select all  the drawing layers that are linked to the selected drawing layer, in the Timeline or Node 
view.

How to select all synced layers

 1. In the Timeline view, select a layer that is synced to at least one or more layer or in the Node view, 
select a node that is synced to one or more node.

 2. In the view menu , select Edit > Select Synced Layers.

In the Timeline view, all the layers synced to the selected layer become highlighted.

In the Node view, all the nodes synced to the selected layer become highlighted.
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Unsyncing Layers
Once layers have been synced, they can just as easily be unsynced.

How to unsync layers

 1. In the Timeline view, right-click on the child layer of a synced pairing.

 2. From the right-click menu, select Unsync Layer.

The parent layer is unsynced and the link icons disappears.

NOTE 

If this menu item is disabled, then the selected layer is either the parent layer or a layer that is 
already unsynced.
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Editing Synced Layers
Since synced layers are often used to sync together two smaller parts of the same part of a rig, the artwork in 
layers that are synced together is often intertwined. Hence, it can be useful to edit the artwork in two or more 
layers that are synced together simultaneously. 

Several of the drawing tools in the Tools toolbar have a mode specifically made for that purpose, the Apply to 
Synced Drawing Layers mode, which can be enabled in the Tool Properties view. When this mode is enabled, 
your drawing tool will have affect the currently selected layer as well as any layer that is synced to it.

This mode is available for the following tools: The  Select tool, the  Cutter tool, the  Reposition All 
Drawings tool, the  Pencil Editor tool, the  Edit Gradient/Texture tool, the  Eraser tool and the  
Paint tool. 

How to edit synced layers

 1. Make sure you are using the Camera view and not the Drawing view.

 2. In the tools toolbar, select either the  Select tool, the  Cutter tool, the  Reposition All 
Drawings tool, the  Pencil Editor tool, the  Edit Gradient/Texture tool, the  Eraser tool or 
the  Paint tool. 

 3. In the Tool Properties view, there will either be an  Apply to Visible Drawing Layers button or an 
Apply to Synced Drawing Layers button:

 l If there is an  Apply to Visible Drawing Layers button, click and hold on it and, in the pop-
up menu, select Apply to Synced Drawing Layers.

 l If there is an Apply to Synced Drawing Layers button, click on it to toggle it on.

 4. In the Camera view, your can start using your drawing tool. It will affect both the current layer and 
its synced layers. 
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About Groups in the Timeline View
When working with complex rigs, you may want to group layers together to avoid cluttering the Timeline view 
and keep your layers organized.

When grouping layers, you can choose to create a simple group, or a group with a composite. A simple group 
will simply help you organize your Timeline view, whereas a group with a composite will connect all the nodes 
in your group to the same composite, allowing you to apply the same effect to all of its layers at once.  For 
example, if transparency is applied to each individual layer making a character rig, the seams between its body 
parts will become visible. Instead, if you put all of the rig's layers together into a group with composite, then 
add a Transparency effect to the group, Harmony will compose the layers inside the group into a single image 
before applying the effect.

NOTE 

You can also group nodes in the Node view—see About Groups in the Node View on page 1259
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Grouping Layers
You can group layers to keep your Timeline view organized.

NOTE 

For grouping layers in the Node view, see Grouping Nodes on page 1261

How to group layers in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

NOTE 

Any layer between the selected layers will be grouped with the selected layers. 

 2. Do one of the following: 

 l Right-click on the highlighted layers and select Group Selection.

 l Right-click on the highlighted layers and select Group Selection With Composite. 

 l Press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS) to instantly group the 
selection with a Composite. 

A new Group layer is added to the Timeline view.

If you click on the  Expand Group button, you will find the grouped layers rigged as children of 
the group layer. 
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Ungrouping Layers
If needed you can ungroup layers you have previously grouped together.

NOTE 

For ungrouping layers in the Node view, see Ungrouping Nodes on page 1262

How to ungroup layers in the Timeline view

 1. In the Timeline view, select the group you want to ungroup.

 2. Right-click on the group and select Ungroup. 

All the group's layers will be placed outside of the group, and the group will be removed. 

189



About  Annotation Columns
T-ANIMPA-005-001

The annotation columns are useful for marking actions, corrections or other information related to your 
animation that you want to draw or write. This way, you can print your Xsheet, take it back to your animation 
table and work with the annotations.

Before you can draw in the Annotation column, you must first activate the Enable Drawing option to activate 
the Drawing mode. Pen tablet pressure sensitivity is not supported in the annotation column.

190

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

Adding Annotation Columns
T-ANIMPA-005-002

Add annotation columns to mark actions, corrections or other information related to your animation.

How to add an annotation column

 1. Do one of the following: 

 l In the Xsheet menu, select Columns > Add Columns. 

 l In the Xsheet toolbar, click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type in an appropriate name.

 3. From the Type list, select Annotation and click OK.

The new column appears.
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Drawing in Annotation Columns
T-ANIMPA-005-003

In the annotation column, you can draw sketches and ideas that will be useful in producing your animation.

How to draw in the annotation column

 1. Do one of the following:

‣ In the Xsheet menu, select Annotation > Enable Drawing.

‣ In the Annotation column header, click the icon in the upper-right corner to cycle through the 
icons until the Brush  icon is displayed.

The Drawing mode is enabled.

 2. To draw in an Annotation column, simply use your mouse or pen tablet.
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Typing in Annotation Columns
T-ANIMPA-005-004

In the annotation column, you can type in your notes and relevant information that will be useful in producing 
your animation.

Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the 
typing will work. To learn about typing values in the Xsheet view, see Typing Exposures on page 233.

How to type in an annotation column

 1. Do one of the following:

 l In the selected cell, press Ctrl (Windows/Linux) or ⌘  (macOS).

 l In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + 
click (macOS).

 2. In the selected cell, type the desired text.
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Erasing in Annotation Columns
T-ANIMPA-005-005

You can erase part or all of the annotation column’s text and drawn annotations. Annotations that you type in 
cannot be erased using this method.

How to erase part of a drawn annotation using Erasing mode

 1. In the annotation column header, click the icon in the upper-right corner to cycle through the icons 
until the Eraser  icon is displayed.

 2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

NOTE 

When using a pen on a tablet, you MUST flip your pen to the eraser side for the 
eraser to work.
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Modifying Annotation Column Pen Options
T-ANIMPA-005-006

You can change the pen size and colour when you draw in the annotation column.

How to modify the pen width

 1. In the Xsheet menu, select Annotation > Pen Width and do one of the following:

 l Select a pen width preset.

 l Select  Change Current to display the Pen Width dialog box. In the Pen Width field, 
type the number of pixels for the pen size and click OK.

How to modify the pen colour

 1. In the Xsheet menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.

 2. Choose a new colour.

 3. Click OK.
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Showing and Hiding Annotation Column Tick Marks
T-ANIMPA-005-007

When working with the annotation columns, it is useful to display tick marks on odd-numbered frames.

To display the tick marks, you must run a short script.

How to display tick marks

 1. From the top menu, select Windows > Script Editor.

 2. From the Script Editor menu, select File > New Script.

 3. Type in a name for your script and click OK.

 4. In the File list, select the script you created. 

 5. On the right side of the view, type the following script:

function display_tick_marks()

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

 6. Click Verify.

The script is verified. 

 7. From the Script Editor menu, select Play/Debug > Run.
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A dialog box opens with your script selected in the Files column.

 8. In the Functions column, select display_tick_marks and click OK.

Tick marks appear on odd frames in the Annotation column. If you do not see tick marks, close and 
restart Harmony.

How to turn off the display of tick marks

 1. Follow steps 1 to 5 of How to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

 2. Follow steps 6 to 8. 

All tick marks are removed from the Annotation column.
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Importing Annotation Files
T-ANIMPA-005-008

If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in the 
Annotation columns, you can easily import them.

How to import annotation files

 1. In the Xsheet view, select the first cell in the Annotation column where you want the imported 
image to start.

 2. Do one of the following:

 l Right-click on the cell and select Annotation > Import File.

 l From the Xsheet menu, select Annotation > Import File. 

 3. Browse for the bitmap image to import.

 4. Click Open.

The image appears in the Annotation column.
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Using Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to bring 
images into the project. For example, you may have background scenes created in a third party software that 
you might need to update in the future. By using Timing columns, you can dynamically link your backgrounds, 
expose different backgrounds at different times, and have live, automatic updating capabilities.

IMPORTANT 

If the project file is moved, or if the folder that the column is linked to is moved, then dynamic 
linking is broken and the images that were in that folder will disappear in Toon Boom Harmony 
Premium.

How to use a Timing column

 1. In the Xsheet view, click the Add Columns  button.

 2. In the Add Column dialog box, type in the name of the new column, then from the Type menu, 
select Timing.

 3. Do one of the following:

 l Click OK if you are finished.

 l Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header, 
<unused>.

 4. In the Node view, add a new node.

 5. Open the Layer Properties editor by clicking the yellow square of the node.

 6. In the Drawing tab, select the Timing Columns option.

 7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to 
locate a folder, you must select a file in the folder you want and then delete the dash and the suffix 
(for example, background-01 should be renamed to background) from the file name in the field. 
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If you leave the full file name selected, Harmony will display that file for the entire duration of the 
scene, regardless of the contents of the Timing Column field.

NOTE 

This means that all the images in the folder that you are linking to are named using the 
naming convention described above. If for some reason you are unable to access a certain 
directory, type the directory extension directly in the path extension field at the top of the 
browser window.

 8. In the Timing Column field, click the Arrow button to create a new timing column, or select the 
name of the column from the  list. If you have an element directory selected in the Name field, the 
Timing Column will indicate which files are called from that element directory. Remember that the 
file displayed at each frame is based on the element name, cell label, and extension. If the element 
is toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display 
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames. 

In the Xsheet, the <unused> header  changes to the name of the node in the Node view.

 9. From the Extension  list, select the file format of the files you want to display.

 10. Click OK.

 11. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the 
drawing file that you want to expose to make it appear in the Camera view.
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Setting Properties for Many Nodes or Layers
When working with several nodes/layers, you may need to change certain properties for a lot of nodes at once. 
For example, you may want to:

 l Make all your Drawing nodes to use 3D Path type position functions.

 l Make all your Peg nodes to use Separate type position functions.

 l Make all your Drawing nodes to apply their embedded pivot on their parent pegs.

 l Disable animation on all your Drawing nodes.

 l Set the mode of all your Composite nodes to Pass Through.

 l Disable specific art layers on several Drawing nodes.

This is common for cut-out productions that need a lot of layers in their character rigs to have a specific 
configuration. 

The Set Properties for Many Layers dialog allows you to select several nodes and to change the following 
properties for all the nodes in your selection:

 l 3D Path or Separate mode

 l Use Embedded Pivot

 l Overlay On/Off

 l Line Art On/Off

 l Colour Art On/Off

 l Underlay On/Off

 l Animate Using Animation Tools

 l Composite Mode

How to change properties for several nodes

 1. In the Timeline or Node view, select all the layers/nodes for which you want to change properties.
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 2. In the Node View toolbar, click on  Set Properties on Many Layers  button.

The Set Properties on Many Layers dialog appears.
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 3. Select the value of each property you want to change for all the selected nodes:

 l 3D path or Separate Mode: Whether you want the Position parameter of the selected Peg 
and Drawing nodes to use a 3D Path type function or a Separate function for their position 
on the x, y and z axes.

 l Use Embedded Pivot: Whether you want the selected Drawing nodes to apply their 
embedded pivot on themselves (Drawing), on their parent peg (Parent Peg) or not at all (Do 
Not Use)

 l Overlay: Whether to enable the Overlay layer for the selected Drawing nodes.

 l Line Art: Whether to enable the Line Art layer for the selected Drawing nodes.

 l Color Art: Whether to enable the Color Art layer for the selected Drawing nodes.

 l Underlay: Whether to enable the Underlay layer for the selected Drawing nodes.

 l Animate Using Animation Tools: Whether to allow users to manipulate and animate the 
selected Drawing nodes with the animation tools. Setting this to off will make animation 
tools work on the Drawing node's parent peg instead.

NOTE 

This option only affects Drawing nodes, and not Peg nodes.

 l Composite Mode: Whether the selected Composite nodes should have their mode set to As 
Bitmap or to Pass Through.

NOTE 

Composite nodes are only available in Harmony Premium.

For each property that you do not want to change for the selected nodes, leave As Is selected.

 4. Click on the OK button.
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Displaying Layer and Column Properties
Each element has its own set of properties that you can modify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline 
view or selected node in the Node view. If you're working with the Xsheet, you can display its properties as 
well. You can display a layer's properties as a window or as a view of its own.

The Layer Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

 l Lock the layer

 l Change the track colour

 l Activate the onion skin preview

 l Adjust the positioning and animation parameters

 l Adjust many other advanced parameters

The Column Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

How to display a layer's properties

 1. Do one of the following:

 l In the Layer Properties view is not part of your workspace, from the top menu, select 
Windows > Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

 l In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .

204

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

How to display a column's properties in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Double-click on a column header.

 l Right-click on a column header and select Column Editor.

The properties for the column are displayed.

 2. (Optional) To view additional properties, select Edit > Preferences from the top menu. 
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 3. In the Preferences dialog box, select the Advanced tab, then select the Advanced Element Mode 
option.

 4. In the Xsheet view, double-click on a column header.

Additional properties for the column are displayed.
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About Layer and Column Display
You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline 
view or a column in the Xsheet view displays. You can stay organized without changing the content of 
elements or your animation output.
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Expanding and Collapsing Layers and Columns
To simplify the look of the Timeline or Xsheet view, you can expand and collapse some of the layers and 
columns. If layers are parented to other ones, you can collapse the parent layer to hide its children.   

How to collapse or expand selected layers in the Timeline view

 1. In the Timeline view, select the layer(s) to collapse or expand.

 2. Do one of the following:

 l Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

 l Click the Expand Children  button on the parent layer.

 l Click the Collapse/Expand  button  (you may have to customize the toolbar to 
display it).

 l Press  Ctrl + I (Windows/Linux) or ⌘  + I (macOS).

How to collapse or expand all layers in the Timeline view

 1. Do one of the following:

 l Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

 l In the Timeline toolbar, click the Collapse All  or Expand All  buttons (you may 
have to customize the toolbar to display them).

 l Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button to display the Functions list.

 2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or 
expand.

 3. Do one of the following:

 l Right-click on the column’s header and select Expand/Collapse > Collapse Selection 
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or Expand Selection.

 l In the Xsheet toolbar, click the Collapse Selection  or Expand Selection  buttons 
(you may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

 l Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

 l Press 0 and 9.

 l In the Xsheet toolbar, click the Collapse All  or Expand All  buttons  (you may have to 
customize the toolbar to display it).
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Showing and Hiding Layers and Columns
As you work in the Drawing, Camera or Xsheet view, some layers or columns may be in the way, such as those 
that were used as references. You can hide these layers to make your work area less cluttered and easier to 
navigate.
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Showing and Hiding Columns

The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can 
be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without 
using the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is 
disabled in the Timeline view.

How to show and hide columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button.

 2. On the right side of the Functions section, click the Expand  button to display the Column List 
section.

 3. Do one of the following:

 l In the Column List section, select the columns to display and deselect the columns to 
hide. 

 l In the Xsheet toolbar, click the Hide Selected Column  button (you may have to 
customize the toolbar to display it).
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Showing Hidden Columns

In order to save visual space in the Xsheet view, columns can be hidden from view. The hidden layer's presence 
is indicated by a thicker grey line between columns.

How to show hidden columns in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Click the thick grey line that represents a hidden column. 

 l Right-click on the column header and select Show Hidden Columns.

 l Press Alt + Shift + H.

The Show Hidden Columns dialog box opens.

 2. In the Show column, select the hidden columns you want to display in the Xsheet view.

 l Click Check to select all the selected columns.

 l Click Uncheck to deselect all selected columns.

212

Harmony 21 Premium User Guide                          



Chapter 3: Layers and Columns

Showing All Columns

In order to save visual space in the Xsheet view, columns can be hidden from view. You can bring all the hidden 
columns back into view all at once.

How to show all columns

 l In the Xsheet menu, select View > Unhide All Columns.
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Showing and Hiding Column Types

You can hide specific column types from view, in order to work more easily with one aspect of your project. For 
example, you could hide all the Drawing columns in the Xsheet, so that you could work more easily with your 
3D Path Columns. 

How to show and hide column types using the Column List

 1. In the Column List section, click the button corresponding to the column type you want to show or 
hide.

Column Type Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns

How to show and hide column types using the Column Types Manager

 1. In the Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.
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 2. Select the types of columns you want to display and disable the ones you want to hide.

Click Set As Default if you want to make these new settings the default ones used each time you start 
Harmony.

Click Restore Default if you want to return the settings to their defaults.
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Showing and Hiding Function Columns

Function columns (columns that house translation, rotation, scale, etc. information) that are associated with 
another column type, for example a Drawing column, are often hidden from view. You can bring these columns 
into the forefront, in order to work with them or view their information. 

How to show or hide function columns on the left side of the Xsheet view

 1. Right-click on a column and select Tag > Function Columns Visible or Function Columns Invisible.
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Customizing the Column Appearance
In Harmony, you can customize the way the column displays drawings, empty cells and the column width.

You can modify the following elements:

 l Empty cells

 l Row units

 l Held exposure

 l Column width

How to change the appearance of an empty cell

 1. From the Xsheet menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units

 1. From the Xsheet menu, select View > Row Units > Frames or Feet.

How to modify the look of a held exposure

 1. In the Xsheet menu, select View > Held Exposures > Line or Value.
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How to modify column width

 1. In the Xsheet view, select a column.

 2. From the Xsheet menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.

 3. In the Column Width field, enter the desired width in pixels.

 4. Do one of the following:

 l Click OK to validate and close the dialog box.

 l Click  Apply to validate the operation and keep the dialog box opened to adjust the 
next column’s width.

 l Click  Set As Default to create all the new columns to this width.

 l Click  Close to cancel the operation.

 5. To restore all columns to the default value, in the Xsheet menu, select  View > All Columns to 
Default Width.
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Displaying Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular 
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of 
the current frame below the column header.

NOTE 

To display thumbnails in the Timeline view, see Displaying Drawing Thumbnails in the Timeline 
View.

How to display the thumbnails

 1. Do one of the following:

 l In the Xsheet toolbar, click the Show Thumbnails  button.

 l In the Xsheet menu, select View > Show Thumbnails. 

The thumbnails row appear appear underneath the column names.
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Changing Layer and Column Colours
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. 
The colours you choose will be reflected in the Node view.

How to change the layer’s colour in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

 2. In the Select Colour dialog box, select a new colour for your layer.

 3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, 
selected colour for easy identification. The corresponding column colour is also updated in the 
Xsheet.

How to reset a layer’s colour in the Timeline view

 1. In the Timeline view, select the layers to reset.

 2. In the Timeline toolbar, click the Default Track Colour  button (you may have to customize the 
toolbar to display it).
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How to change a column’s colour in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

 3. In the Select Colour dialog box, select a new colour for your columns.

 4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

 1. In the Xsheet view, select the columns to reset.

 2. Right-click on the column’s header and select Colour > Default Columns Colour.
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Using the Element Manager
The Element Manager window lets you Opens the Element Manager window where you can add, delete or 
modify elements (drawing folders) in your scene. If you have drawing folders that are not linked to a column in 
your scene, use the Element Manager to delete them if needed. See xref Reference > Windows > Element 
Manager.

How to use the Element Manager

 l From the top menu, select Scene > Element Manager.—see the Reference guide .
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Chapter 4: Timing
When you create hand-drawn animation traditionally or in a paperless environment, it's important to know 
how to set and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure 
sheet created by the animator. In a paperless workflow, the animator creates and manages their own exposure 
sheet directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital 
animator, you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn 
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using. 
Depending on your working style, some actions may seem preferable to do in one view instead of another. 
Many of the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often 
show both techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and 
animation paths for symbols are covered in separate chapters.

NOTE 

The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters 
and parts, but is not really needed for animation and timing. If you plan to work with cut-out 
animation, you can still learn useful tips by reviewing the section on exposure sheets.
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About Scene Length
In Harmony, the length of each scene is determined by the amount of frames it contains. You can calculate the 
amount of frames your scene requires based on the amount of time it should span over with the formula, in 
which l is the scene's length, s is the amount of seconds your scene requires, and fps is the scene's frame rate. 

l = s × fps

Likewise, a scene's length in seconds can be calculated with the reverse formula:

s = l ÷ fps

By default, scenes created in Harmony are 60 frames in length. At 24 frames per second, this makes a scene of 
2½ seconds in length. You should set your scene's length based on how much time you plan for it to require 
after creating your scene so you can plan your animation based on the scene's length. However, it is possible to 
adjust your scene's length at any time. You can also insert or remove frames at any point in your scene.
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Setting the Scene Length
T-HFND-007-007

You can set the scene length by entering its exact amount of frames or by adjusting its length using the scene 
length bracket in the Timeline view. 

How to set the scene's length in frames

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.

How to modify the scene length in the Timeline view

 1. In the ruler of the Timeline view, click and drag the red scene length bracket  and move it to the 
left to shorten the scene or to the right to extend the scene.
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Inserting Frames in a Scene
You can add frames to your scene before or after the currently selected frame(s). All of your scene's animation 
before or after the selection will be offset by the amount of frames you added.

How to add frames at the start of a scene

 1. Do one of the following:

 l In the top menu, select Scene > Frames > Add Frames at Start.

 l Right-click in the Xsheet view and, in the context menu, select Frames > Add Frames at 
Start.

The Add Frames dialog box appears.

 2. In the Number of frames to add field, enter the number of frames you want to add at the beginning 
of the scene.

 3. If your scene contains scene markers, check Ripple Scene Markers if you want them to be offset 
along with the keyframes and drawings. If you want them to remain in place, uncheck this option.

 4. Click OK.

How to add frames to the middle of a scene

 1. In the Timeline or Xsheet view, select the frame where you want to insert frames. 
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 2. Do one of the following:

 l From the top menu, select Scene > Frames > Add Frames Before Selection or Add Frames 
After Selection. 

 l In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.

 l In the Xsheet view toolbar, click the  Add Frames  button to add frames after your 
selection. 

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (macOS) to add frames before the selection, or Ctrl 
+ H to add frames after the selection.

The Add Frames dialog box appears.

 3. In the Number of Frames to Add field, enter the amount of frames to add to the scene.

 4. If your scene contains scene markers, check Ripple Scene Markers if you want the scene markers 
after the insertion point to be offset along with the keyframes and drawings. If you want them to 
remain in place, uncheck this option.

 5. If you want the drawings exposed just before the insertion point to be exposed throughout the new 
frames, check Extend Drawing Exposure. If you want the new frames to be empty, uncheck this 
option.

 6. Click OK.

New frames are inserted before or after the selected frames, depending on which command you 
selected.

How to add frames at the  end of a scene

 1. Do one of the following:
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 l In the top menu, select Scene > Frames > Add Frames at End.

 l Right-click in the Xsheet view and, in the context menu, select Frames > Add Frames at 
End.

The Add Frames dialog box appears.

 2. In the Number of Frames to Add field, enter the number of frames to add at the end of the scene.

 3. If you want the drawings exposed at the end of the scene to be exposed throughout the new 
frames, check Extend Drawing Exposure. If you want the new frames to be empty, uncheck this 
option.

 4. Click OK.
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Removing Frames from a Scene
It is possible to remove frames from your scene. Your scene will be shortened by the amount of selected frames, 
and all the animation after the removed frames will move back to close the gap. 

How to remove a frame or a range of frames from your scene

 1. In the Timeline or Xsheet view, select a frame or a range of frames to remove. 

 2. Do one of the following: 

 l In the top menu, select Scene > Frame > Remove Selected Frames.

 l Right-click in the Xsheet view and, in the context menu, select Frame > Remove Selected 
Frames.
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TIP 

If you selected frames in the Xsheet view by clicking and dragging on the frame 
numbers like in the screenshot above, or if you selected frames in all the columns in the 
Xsheet view, you can also press the Del key. You will be prompted to confirm whether 
you want to delete the frames, or just clear the exposure in the selection. To delete the 
frames, click Yes. 

The Remove Frames dialog box appears.

 3. If your scene contains scene markers, check Ripple Scene Markers if you want the scene markers 
after the selected frames to be offset backwards along with the keyframes and drawings. If you 
want them to remain in place, uncheck this option.
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About Exposure
T-HFND-006-006

In Harmony, exposure is the term used for the link between a cell, which is a single frame in a drawing layer, 
and a drawing. 

This concept comes from traditional animation. When drawings were finished and ready to be added to the 
animation, they would be placed under a camera, and taking one snapshot of the drawing would equate to one 
exposure. Hence, exposure is an important concept for planning out the drawings required for your action, as 
well as the timing in which they will be displayed as your scene plays out. It is especially important when 
drawings are used several times in a scene, which is a common practice to save on production time and costs, 
as you can re-use a drawing by exposing it over multiple frames. 

In traditional animation, it is typical to plan a scene by filling the exposure sheet with the exposure before 
creating the animation. An exposure sheet is made of cells, which represent frames, spread across columns, 
representing drawing layers, and the exposure is planned by filling each cell with the identification numbers 
for the drawings you plan your scene's action to require. This allows animators to figure out the timing of their 
scene's actions and to allocate the amount of drawings each action will require before they start drawing, 
removing decision making from the animation process. 

In Harmony, you can achieve this process by using the Xsheet view, which is very similar to a traditional 
animation exposure sheet. You can fill each cell in your scene's drawing layers with the number of the 
drawings you plan to create, at the frames at which you intend to expose them, and set the exposure of each 
drawing to the amount of frames you intend them to take. 

Filling a cell with a drawing identifier allows Harmony to keep track of which frames should display which 
drawings. For example, if you fill cell 1 and 2 of the drawing layer A with the number 5, then start drawing in 
cell 1 or 2, Harmony will create the drawing A-5, which will display in layer A when at frame 1 or 2 of your 
scene. Otherwise, if you start drawing inside an empty cell, Harmony will automatically create a drawing and 
assign it an available drawing number.
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About Creating Exposure
In traditional and paperless animation, it is useful to plan your scene by creating its exposure before creating 
the drawings. The most basic method of creating a scene's exposure is by manually entering the name 
(typically a number) of each drawing in each cell of each column in your scene using the Xsheet view. However, 
Harmony has many tools allowing you to streamline the exposure filling process. If you plan to animate on 
twos or threes, Harmony can automatically expose each drawing added to your exposure sheet over the 
preferred amount of frames. You can also fill a range of cells with the same drawing, a number sequence, a 
cycle, or even random drawing numbers. 
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Typing Exposures

T-HFND-006-007

To fill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section 
of the Timeline.

NOTE 

You can only use alphanumeric values (0 to 9, a to z) and the underscore (_) and dash (-).

How to type a value in the Timeline view

 1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing 
you want to create.

 2. Press Enter/Return to validate the value.

How to type a value in the Xsheet view

 1. In an Xsheet column, double-click on a cell.

 2. Type a value or drawing name in the cell.
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 3. Press Enter/Return to move to the next cell.

 4. Press Esc to exit the typing mode.
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Setting the Exposure Hold

Drawings in an animation project are often exposed for more than one frame to save on production costs. In 
western animation, each drawing is usually exposed on two frames, and in Japanese animation, each drawing 
is usually exposed on three frames. In both cases, exceptions can be made for quick or detailed actions that 
require precise timing. 

In the industry, this type of exposure is known as animation in double or triple frames, or animation on twos or 
on threes. 

To save time when creating your scene's exposure, you can configure the Xsheet to hold the exposure. This will 
make every new exposure you type into the Xsheet exposed for the preferred amount of frames. After you 
enter the exposure for a cell, the selected cell will be after this exposure's hold, allowing you to quickly fill a 
column with exposure while respecting the selected hold. 

How to hold an exposure

 1. Do one of the following:

 l In the Xsheet menu, select Exposure > Hold Exposure > Hold the desired amount of cells.

 l From the top menu, select Animation > Cell > Hold Exposure > Hold the desired amount of 
cells.

 l Right-click on the Xsheet and select Exposure > Hold Exposure > Hold the desired amount 
of cells.

 2. Type a value or drawing name in the cell.

 3. Type a value or drawing name in the cell.

 l Press Enter/Return to move on to the next cell.

 l Press Esc to quit the typing mode.
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Toggling Between Inserting and Overwriting Exposure        

T-HFND-006-007

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes 
control the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites 
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence 
over existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed 
down the column.

How to switch between the Overwrite and Insert modes

 1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.
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Filling a Selection with a Specific Exposure

You can fill a selection with the same drawing using the Fill Selection dialog box. You can fill a selection of a 
single drawing, several drawings or even several columns. 

How to fill a selection with a specific exposure

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Fill Selection. 

 l In the Xsheet toolbar, click the Fill Selection  button. Note that you may have to add this 
button to your toolbar by right-clicking on it and selecting Customize.

 l Press Ctrl + T (Windows/Linux) or ⌘  + T (macOS)).

The Fill Selection dialog box opens.

 3. In the Value field, type the desired value.

 4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

 5. Click OK.
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Creating an Exposure Sequence

You can quickly create a sequence with a gesture by holding the Shift key while extending an exposure, or use 
the Sequence Fill dialog box to create a custom sequence within your selection. While the former is faster, the 
latter allows you to determine your sequence's hold and increment, to create a backward sequence or to 
configure it in multiple other ways. 

How to extend an exposure to create a sequence

 1. In the Xsheet view, select a cell containing a number.

 2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

 3. Hold down the Shift key. Make sure a plus sign (+) appears.

 4. Pull down the selection box to the desired frame.

NOTE 

The red selection box must be visible when releasing the cursor. If not, the action is 
considered cancelled.

 5. First release the Shift key, then release the mouse button.
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How to fill a selection with a sequence

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l From the top menu, select Animation > Cell > Sequence Fill. 

 l In the Timeline view, right-click and select Exposure > Sequence Fill.

 l In the Xsheet toolbar, click the Sequence Fill  button (you may have to customize 
the toolbar to display it).

 l Press Ctrl + M (Windows/Linux) or ⌘  + M (macOS)).

The Sequence Fill dialog box opens.

 3. In the Starting Value field, type the first number in the sequence.

 4. In the Increment field, type the number by which the drawing number will increase from frame to 
frame. For example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; 
and -2 gives you this: 8-6-4-2.
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Creating an Exposure Cycle 

T-HFND-006-008

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways. 
This can be useful for example if you want to make or use a looping character's walking animation, referred to 
as a walk cycle.

When you create cycle, each instance of each cycled drawing is linked to the same drawing file. This means 
that if you change a drawing for the first instance of the cycle, it will update for every other instance of the 
cycle. 

NOTE 

You can also copy and paste drawings and keyframes into cycles—see Pasting Cycles on page 281.

How to  create a cycle

 1. In the Timeline view, select the cell range to loop.

 2. In the Timeline toolbar, click the Create Cycle  button (you may have to customize the toolbar to 
display it).

The Create Cycle dialog box opens.

 3. Enter the number of cycles you want, including the current selection.
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Filling a Selection with Random Exposure

You can Lets you fill in random values over a selection. You can give a maximum and a minimum value and 
create a range for Harmony to choose the random values from. The selection can be over one cell or a cell 
range in one column or more or an entire column or many entire columns.

How to fill cells randomly

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Select Animation > Cell > Fill Cells Randomly.

 l Right-click on the selection and select Exposure > Fill Cells Randomly.

 l In the Xsheet view, click the Fill Cells Randomly  button. Note that you may have to add 
this button to your toolbar by right-clicking on it and selecting Customize.

The Fill Cells Randomly dialog box opens.

 3. In the Minimum Value field, enter the lowest acceptable value.

 4. In the Maximum Value field, enter the highest acceptable value.

 5. In the Hold field, choose an exposure holding value.

 6. If you are applying this option to a drawing column, select the Whole Numbers option to avoid 
decimal points.

243



 7. Click OK.
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Inserting Blank Cells

You can place an empty cell between other cells. 

NOTE 

Inserting a blank cell never overwrites existing cells, even if the Xsheet view is set to Overwrite 
mode. This is because overwriting existing cells with blank cells would replicate the behavior of 
deleting exposure.

How to insert a blank cell

 1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

 2. Do one of the following:

 l In the top menu, select Animation > Cell > Insert Blank Cell. 

 l Right-click and select Exposure > Insert Blank Cell.

 l In the Timeline or Xsheet toolbar, click the Insert Blank Cell  button. Note that you may 
have to add this button to your toolbar by right-clicking on it and selecting Customize.

 l Press Shift + J.

A blank cell is inserted.
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Filling Empty Cells

T-LAY-002-005

You can automatically fill gaps between exposures using the Fill Empty Cells command. This will extend the 
exposure of cell exposed right before the gap until the end of the gap. 

How to fill empty cells

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Right-click and select Exposure > Fill Empty Cells.

 l From the top menu, select Animation > Cell > Fill Empty Cells.

 l In the Timeline toolbar, click the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.
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Toggling Extending Previous Drawing Exposure

T-HFND-006-005

With the Extend Exposure of Previous Drawing preference enabled, you can configure Harmony to 
automatically extend a previous drawing's exposure when creating a new drawing, automatically filling the 
gaps as you create drawings.

This preference is enabled by default. If you disable it, gaps between previous drawings and new drawing will 
not be automatically filled:

How to enable or disable the Extend Exposure of Previous Drawing preference

 1. Open the Preferences dialog box by doing one of the following:

 l Select Edit > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.

 2. Select the Exposure Sheet tab.
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 3. In the Drawing Creation section, check or uncheck the Extend Exposure of Previous Drawing 
option.

 4. Click OK.
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About Adjusting Exposure
The exposure of drawings in a scene often needs to be adjusted as you flesh out your animation and your 
scene's action starts taking form. Your scene's action may require more or less drawings than initially planned, 
or some drawings may need to be exposed for longer or shorter times than expected. There are many ways to 
adjust your scene's exposure, giving you the flexibility to quickly make changes and test them so you can fine-
tune your animation.
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Increasing Exposures

T-ANIMPA-006-005

Increasing the exposure Adds one more exposure to a selected cell; repeating this action adds an extra cell 
each time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing 
an exposure pushes the existing exposure forward. 

How to increase exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l Press +.

 l At the bottom-right corner of the Xsheet view, set the number of cells over which the 
drawing will be exposed. 

 l In the Xsheet  toolbar, click the Increase Exposure  button.

 l Right-click and select Exposure > Increase Exposure.

 l From the top menu, select Animation > Cell > Increase Exposure. 

251



Decreasing Exposures

T-ANIMPA-006-006

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the 
beginning of selection. You can do this for one cell or a range.

How to decrease a single exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l Press -.

 l At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will 
be exposed. 

 l In the Xsheet toolbar, click the Decrease Exposure  button.

 l Right-click and select Exposure > Decrease Exposure. 

 l From the top menu, select Animation > Cell > Decrease Exposure. 

How to decrease a range of exposures

 1. In the Timeline or Xsheet view,  select a range of cells.
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 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure and Pull. 

 l Right-click and select Exposure > Clear Exposure and Pull.

 l In the Xsheet toolbar, click the Clear Exposure and Pull  button.

The exposure is reduced by the selected number of cells.
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Extending Single Exposures

T-HFND-007-008

Extending the exposure lets you select a cell and extend it to the desired frame. 

How to extend an exposure in the Timeline view

 1. In the Timeline view, select the cell you want to extend.

 2. Do one of the following:

 l Right-click and select Extend Exposure.

 l In the Timeline View menu, select Exposure > Extend Exposure.

 l Select Animation > Cell > Extend Exposure.

 l Press F5.

 3. In the Extend Exposure dialog box, enter the frame number to extend your cell to.

 4. Indicate if you want to insert the new frames before the following exposure or overwrite it. If you 
select insert, any following exposure will be moved down. If you select Overwrite, the following 
exposure will be erased and replaced by the drawing being extended.

NOTE 

You can also select the last cell where you want to extend your drawing to (such 
as the last cell of the layer), right-click and select Extend Exposure. You will not 
be prompted the dialog box.

How to extend an exposure gesturally

 1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down 
 cursor.
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 2. Pull down the selected cell to the desired frame. 

NOTE 

The red selection box must be visible when releasing the cursor. If not, the action 
is considered cancelled.

How to extend an exposure from the top menu

 1. Select a cell and do one of the following:

 l From the top menu, select Animation > Cell > Extend Exposure.

 l Press F5.

The Extend Exposure dialog box opens.

 2. Enter the frame number you want to extend the cell to.
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Setting the Exposure

T-HFND-006-009

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

 1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

 2. Do one of the following:

 l Select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set Exposure.

 l In the Timeline toolbar, click one of the Set Exposure     buttons. Note that 
you may have to add this button to your toolbar by right-clicking on it and selecting 
Customize.

 l In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure 
to 1, 2, or 3, or Set Exposure.

 3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of 
frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Deleting Exposures

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the 
Timeline or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its 
name again in a cell.

You can delete the exposure in a selected cell range  or delete the entire exposure of a drawing exposed over 
several cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

 1. In the Timeline or Xsheet view, select the exposure you want to delete.

 2. Do one of the following:

 l Press Del.

 l Right-click and select Delete.

How to clear the entire exposure of a drawing

 1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure.

 l In the Timeline view, right-click and select Exposure > Clear Exposure.

 l In the Xsheet toolbar, click the Clear Exposure  button (you may have to customize the 
toolbar to display it).

258

Harmony 21 Premium User Guide                          



Chapter 4: Timing

Moving Cells

T-ANIMPA-006-007

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame 
in the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from 
one location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

 1. In the Timeline view, select one or more cells to move.

 2. Drag the cells to the new location.

 3. Drop the selection by doing one of the following:

 l Drop by simply releasing the mouse or pen.

 l Hold Ctrl (Windows/Linux) or ⌘  (macOS) while dropping the selection to copy the 
cells. The original cells will not be moved.

 l Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

 1. In the Xsheet view, select one or more cells.

 2. In the Xsheet view, position the pointer over the small dotted area  on the left side of the selected 
cells.

 3. Drag the selection to any other cell in the same column or in another column.

 4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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 l Hold down Ctrl (Windows/Linux) or ⌘  (macOS) while dropping the selection to copy 
the cells. The original selection will not be moved.

 l Press Shift while dropping the selection to insert it between existing frames.

How to turn off the Gestural Drag mode

 1. Do one of the following:

‣ In the Xsheet view, right-click and deselect Gestural Drag Mode. 

‣ From the Xsheet menu, select Edit > Gestural Drag Mode
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‣ In the Xsheet toolbar, click the Toggle Gestural Drag Mode button (you may have to 
customize the  toolbar to display it).

 

The dragging pad disappears on selected cells when the Gestural Drag mode is off.
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Enabling or Disabling Overwriting Exposures and Keyframes During 
Drag and Drop

You can change the way the Timeline behaves when you drag and drop a selection of keyframes or drawings 
with the Overwrite Exposure and Keyframes during Drag and Drop preference.  When this preference is 
enabled, dragging and dropping drawings and keyframes in the Timeline view will overwrite the drawings 
and keyframes between the selection and the destination, as if the selection "wiped" everything on the way to 
the destination. This behavior is more similar to the one observed when manipulating keyframes in Adobe 
Animate. If disabled, dragging and dropping a selection in the timeline will simply remove the keyframes and 
drawings from the source, and overwrite the destination with them, leaving anything else unaffected.

You can set this mode in two places: the Timeline toolbar and the Preferences dialog box.

How to enable or disable overwriting exposure and keyframes in the Preferences 
dialog

 1. From the top menu, open the Edit (Windows/Linux) or Harmony Premium (macOS) menu and 
select  Preferences. In the Timeline tab, check or uncheck the Overwrite Exposures and Keyframes 
During Drag and Drop option, then click OK.

 2. Open the Timeline tab.

 3. In the Paste / Drag & Drop panel, check or uncheck the Overwrite Exposures and Keyframes 
During Drag and Drop option.

 4. Click OK.

How to enable or disable overwriting exposure and keyframes in the Timeline view

 1. In the Timeline toolbar, click the Toggle Override Exposure and Keyframe During Drag and Drop  
button. Note that you may have to add this button to your toolbar by right-clicking on it and 
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selecting Customize.
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About Rippling and Overwriting the Exposure in the Timeline View
T-ANIMPA-006-004

By default, you can only use your mouse to drag and drop frames in the Timeline view. However, if you zoom in 
sufficiently, you are able to tweak the exposure of each drawing by clicking and dragging the junction between 
two drawings. 

Just like in some video editing software, when tweaking the duration of a drawing by dragging its side, you can 
decide whether to ripple or overwrite subsequent frames. This is determined by whether you grab the edge of 
the drawing by the left or the right side of said edge. 

Although not required, this functionality is especially useful when displaying thumbnails in the Timeline view, 
as you can preview the exposed drawings as you modify their exposure. As a reference, tweaking exposure in 
the timeline is only possible when you zoom in on the timeline at least close enough to fully view the 
thumbnails of drawings exposed on two frames. For more information, see Displaying Drawing Thumbnails in 
the Timeline View on page 811. 
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Changing Exposure and Rippling Drawings in the Timeline View

If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their 
right edge with the mouse cursor. If your mouse cursor is just left of the drawing's right edge, a yellow highlight 
will appear. This means dragging the drawing's edge will adjust its exposure and ripple the ensuing drawings. 

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline 
view

 1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the 
following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

NOTE 

Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it 
is very useful.

 2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed 
on twos, by doing one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the 
exposure. 
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 4. Click and drag the right edge of the drawing to change its exposure.

If you move the edge to the right, the drawing's exposure is extended, and all the drawings 
exposed after this drawing are moved forward.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawings exposed 
after this drawing are moved backward.

NOTE 

You can drag the edge further left and completely remove the drawing, making subsequent 
drawings overwrite it.     
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Changing Exposure and Overwriting Drawings in the Timeline View

If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their 
right edge with the mouse cursor. If your mouse cursor is just right of the drawing's right edge, a red highlight 
will appear. This means dragging the drawing's edge will adjust its exposure and overwrite ensuing drawings. 

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline 
view

 1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the 
following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

NOTE 

Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it 
is very useful.

 2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed 
on twos, by doing one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the 
exposure. 
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 4. Click and drag the right edge of the drawing to change its exposure.

If you move the edge to the right, the drawing's exposure is extended, and all the drawing right 
after is overwritten.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawing right after 
is exposed over it.

NOTE 

You can drag the edge further left and completely remove the drawing, making the drawing 
right after overwrite it.
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About Drawings
Drawings that are created in Toon Boom Harmony Premium are not stored in their cells. They are actual files 
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need 
to edit the file and not the cells.
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Creating Empty Drawings
T-LAY-003-003

The Create Empty Drawing  command automatically Creates a drawing in the selected cell, replacing any 
drawing that may already be exposed in that cell and the following ones until it meets another drawing, key 
exposure or a blank cell. 

How to create an empty drawing

 1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

 2. Do one of the following:

 l In the top menu, select Drawing > Create Empty Drawing.

 l In the Xsheet view menu, select Drawings > Create Empty Drawing.

 l In the Xsheet view toolbar, click the Create Empty Drawing  button. 

 l In the  Timeline view toolbar, click the Create Empty Drawing  button. 

 l Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline view.
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Renaming Drawings
T-HFND-005-003

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

You can also rename a series of drawings relative to their frame position, which is useful in hand-drawn 
animation.

How to rename a drawing

 1. In the Timeline or Xsheet view, select the drawing to rename.

 2. Do one of the following:

 l Right-click and select Drawings > Rename Drawing.

 l In the Timeline toolbar, click the Rename Drawing  button (you may have to 
customize the toolbar to display it).

 l Press Ctrl + D (Windows/Linux) or ⌘  + D (macOS).

The Rename Drawing dialog box opens.

 3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet 
breakdown and deformation animation.

 1. In the Timeline or Xsheet view, select a drawing sequence. Note that you can only select a drawing 
range in one column or layer at a time.

 2. Right-click and select Drawings > Rename Drawing with Prefix.
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The Rename Drawing with Prefix dialog box opens.

 3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

 1. In the Timeline or Xsheet view, select the drawing sequence to rename.

 2. Select Drawing > Rename by Frame.
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Deleting Drawings
You can permanently delete a drawing file from a project's folder.

NOTE 

Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

 1. In the Timeline or Xsheet view, select the drawings to delete.

 2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing
T-LAY-003-004

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the 
drawing and work on the copy. When duplicating a drawing, the exposure at the selected cell is replaced with 
the new drawing, up until the next key exposure.

With Toon Boom Harmony Premium, you can create a keyframe at the same time as you duplicate your 
drawing. This way, you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

 1. In the Timeline or Xsheet view, select the drawing to duplicate.

 2. Do one of the following:

 l From the top menu, select Drawing > Duplicate Drawings.

 l Right-click  and select Drawings > Duplicate Drawings.

 l In the Xsheet toolbar, click the Duplicate Drawing  button.

 l Press Alt + Shift + D.
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the 
actual drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is 
visible over a series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not 
linked to drawings. Keyframes can be moved independently from the drawing exposure. 

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer 
to duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, 
new drawings will be created only when drawings with the same name do not already exist in 
the destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with 
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template,  such 
as when placing new drawings after the animation, then delete the template's 
animation.  It will still have updated the drawings but not override the existing 
animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will 
always be created. If drawing files with the same name already exist, Harmony will create a new 
name for the drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can 
use the Paste Special Again command instead. You can paste your selection using the same settings as in the 
most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

 1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS). 
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 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

 3. Do one of the following:

 l Right-click and select Paste Special.

 l From the top menu, select Edit > Paste Special.

 l In the Xsheet  or Timeline toolbar, click the Paste Special  button (you may need to 
customize the toolbar to display it).

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (macOS). 

The Paste Special dialog box opens.

 4. Select the Basic tab.

 5. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They 
Do Not Exist option.
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How to paste new drawings with the previous Paste Special settings

 1. Do one of the following:

 l From the top menu, select Edit > Paste Special Again.

 l Right-click and select Paste Special Again

 l In the Timeline or Xsheet  toolbar, click the Paste Special Again  button (you may 
have to customize the toolbar to display it).

 l Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (macOS).
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Pasting Reversed

Once you've copied an animated sequence, you can paste back its drawings in the reverse order.

NOTE 

You can perform the same operation using the Paste Special dialog box. To open the Paste Special 
dialog box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (macOS).   

How to paste a reversed cycle

 1. In the Timeline or Xsheet view, select the cell range to paste in reverse order.

 2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C 
(Windows/Linux) or ⌘  + C (macOS).

 3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

 4. Do one of the following:

 l From the top menu, select Edit > Paste Reverse. 

 l Right-click and select Paste Reverse. 
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 l Press Ctrl + . (Windows/Linux) or ⌘  + . (macOS).
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Pasting Cycles

Once you have created a cycle from an animated sequence, you can paste it anywhere, for as many times as you 
like and in any direction that you choose.

How to paste a cycle

 1. In the Timeline or Xsheet view, select the cell range to loop.

 2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C 
(Windows/Linux) or ⌘  + C (macOS).

 3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

 4. Do one of the following:

 l From the top menu, select Edit > Paste Cycle. 

 l Right-click and select Paste Cycle. 

 l Press Ctrl + / (Windows/Linux) or ⌘  + / (macOS).

The Paste Cycle dialog box opens.
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 5. Do one of the following:

 l In the Number of Cycles field, enter the number of cycles you want to paste.

 l Increase or decrease the number of cycles you want to paste.

 6. In the Cycle Type menu, select the type of cycle you want to paste.

 l Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your 
selection and ending with the last.

 l Reverse: Pastes cycles in the reverse order of the original selection, starting with the 
last cell of your selection and ending with the first one.

 l Forward > Reverse: Pastes the first cycle in your selection as is, then the following 
one in reverse order. This repeated until all cycles are pasted.

 l Reverse > Forward:  Pastes the first cycle in your selectionin reverse order, then the 
following one as is. This repeated until all cycles are pasted.

 7. Click OK.

NOTE 

You can also paste cycles using the Paste Special dialog instead of the Paste Cycle dialog. The 
Paste Special dialog gives you access to the same options along with many other options. To access 
the Paste Special dialog, do one of the following:   

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (macOS).

 l Right-click on the destination and select Paste Special.

 l From the top menu, select Edit > Paste Special.
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Modifying Paste Presets

When pasting key frames and exposures, you can modify the existing presets to your liking. There are three 
presets you can modify: the default presets for both key frames and exposures, key frames only and exposures 
only.

How to modify paste presets

 1. From the Timeline view menu, select Edit > Modify Paste Presets and one of the following options:

 l All to edit the default paste preset settings.

 l Key Frame to edit the preset settings for pasting key frames.

 l Exposure to edit the preset settings for pasting exposures.

The Edit Paste Presets dialog box opens.

 2. Refer to the following table and edit the presets as desired.

Parameter Description

Drawings

Add/Remove 
Exposure

 

Never create drawing files: When adding exposures to a drawing layer, 
drawing files will not be created.

Only create drawing files when they do not exist: When adding 
exposures to a drawing layer, new drawings will be created only when 
drawings with the same name do not already exist in the destination.
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Always create drawing files: When adding exposures to a drawing layer, 
new drawings will always be created. If drawing files with the same name 
already exist, Harmony will create a new name for the drawing.

Enforce Key Exposure
If there are key exposures that exist on copied drawings, they are preserved 
when pasting. No key exposures are added. This is the default behavior 
when pasting.

Fill Gap with 
Previous Drawing

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fill to Next Key 
Exposure

Fills selected area till the next key exposure.

Keyframes

Add/Remove 
Keyframes

Motion: Copies the properties of the selected motion keyframe to the new 
frame.

Velocity: Copies the properties of the selected velocity keyframe to the new 
frame.

Rotation: Copies the properties of the selected rotation keyframe to the new 
frame.

Scale: Copies the properties of the selected scale keyframe to the new 
frame.

Skew: Copies the properties of the selected skew keyframe to the new 
frame.

Force Keyframes at Function's Beginning and End: Adds a keyframe to the 
beginning and end of the pasted function, reproducing the source function.
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Merging Drawings
There are two methods of merging drawings. 

 l You can merge selected drawings in adjacent elements. The columns and layers will be left intact, and 
each new merged drawing will reside in the frames of the left-most column or lower layer.

 l You can merge elements. All drawings will be merged. Unused columns and layers will be deleted, but 
the original drawing files are still accessible.
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Merging Selected Drawings

You can merge drawings from adjacent layers or columns. The merged drawings will appear in the lower layer 
or left-most column of the two layers or columns selected.

How to merge selected drawings

 1. In the Xsheet view, select the drawings to merge.

 2. Do one of the following:

‣ In the Xsheet menu, select Columns> Merge Selected Drawings.

‣ In the Timeline menu, select Layers > Merge Selected Drawings.
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 3. Do one of the following:

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timeline menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining columns 
will be left blank at the corresponding frames. In the Timeline view, the bottom timeline layer will contain 
the merged drawings from all layers and the other layers will be left blank at the corresponding frames. 
Drawings are not deleted and are still accessible.
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Merging All Drawings

You can merge all the drawings in two layers or columns.

How to merge all the drawings in two layers or columns

 1. Do one of the following:

‣ In the Timeline view, select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

‣ In the top menu, select Edit > Merge.

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timeline menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns 
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings 
from all layers and the other layers will be deleted. Drawings are not deleted and are still 
accessible.
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About Frame Markers
Frame markers are simple colour markers that you can add in the Timeline view. They can be added to any 
frame, regardless of whether or not it contains a drawing. They can help you organize your scene by marking 
important frames in your scene.

Contrary to scene markers, frame markers are placed on a specific frame in a specific layer. They can only be 
added to a single frame, and not to a span of frames. 

Frame markers also distinguish themselves from drawing markers in that they do not mark drawings, but 
frames. They can even be added to frames that do not contain any drawing. They are also only visible in the 
Timeline view.
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Adding Frame Markers
You can add frame markers to any frame in your scene, either by right-clicking on a frame in the Timeline view, 
or by using the Timeline view menu. 

How to add a frame marker

 1. In the Timeline view, select the frame you want to mark.

 2. Do one of the following:

 l Right-click on the frame and, in the context menu, select Mark Frame, then the colour you 
want to mark the frame with.

 l In the top-left corner of the Timeline view, open the  View menu, and select Motion > 
Mark Frame, then the colour you want to mark the frame with. 

A little square will appear over the marked frame, in the colour your selected.
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Moving Frame Markers
You can move frame markers by dragging and dropping them, just like you would with drawings and 
keyframes.

NOTE 

If you drag and drop frames containing frame markers, they will be moved along with the frames 
regardless of which paste preset is currently selected.

How to move frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to move. 

TIP 

If you want to move several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to move.

 2. Click and drag on the selection, and drop it where you want the frame marker to be moved.
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Copying, Cutting and Pasting Frame Markers
You can copy and paste, or cut and paste frame markers just like you would with drawings and keyframes.

NOTE 

If you copy and paste or cut and paste frames containing frame markers, the frame markers will be 
affected regardless of which paste preset is currently selected.

How to copy and paste frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to copy.

TIP 

If you want to copy several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to copy.

 2. Do one of the following:

 l Right-click on the selection and select Copy cells from Timeline.

 l In the top menu, select Edit > Copy cells from Timeline.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 l In the top-left corner of the Timeline view, open the  View menu and select Edit > Copy 
cells from Timeline.

 3. In the Timeline view, select the frame where you want to paste the copied frame marker.

 4. Do one of the following: 

 l Right-click on the selection and select Paste cells in Timeline.

 l In the top menu, select Edit > Paste cells in Timeline.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

 l In the top-left corner of the Timeline view, open the  View menu and select Edit > Paste 
cells in Timeline.

How to cut and paste frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to cut and paste.
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TIP 

If you want to cut several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to cut.

 2. Do one of the following:

 l Right-click on the selection and select Cut cells from Timeline.

 l In the top menu, select Edit > Cut cells from Timeline.

 l Press Ctrl + X (Windows/Linux) or ⌘  + X (macOS).

 l In the top-left corner of the Timeline view, open the  View menu and select Edit > Cut 
cells from Timeline.

 3. In the Timeline view, select the frame where you want to paste the copied frame marker.

 4. Do one of the following: 

 l Right-click on the selection and select Paste cells in Timeline.

 l In the top menu, select Edit > Paste cells in Timeline.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

 l In the top-left corner of the Timeline view, open the  View menu and select Edit > Paste 
cells in Timeline.
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Removing Frame Markers
You can remove frame markers from the same menu from which you can add frame markers.

How to add a frame marker

 1. In the Timeline view, select the frame containing the frame marker you want to remove. 

TIP 

If you want to remove several frame markers, select all the frames containing the frame 
markers you want to remove.

 2. Do one of the following:

 l Right-click on the frame and, in the context menu, select Mark Frame > Remove Frame 
Marker.

 l In the top-left corner of the Timeline view, open the  View menu, and select Motion > 
Mark Frame > Remove Frame Marker.

The frame marker will be removed.
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About Scene Markers
T-ANIMPA-005-010

Scene markers are visual indicators displayed in the frame ruler at the top of the Timeline view.

You can use scene markers to highlight, sort and label parts of your scene. For example, you can indicate the 
frames you want to clean up, a change in action, an impact, or where you intend to apply an effect. 

Scene markers have a colour, a name, a start frame, a length and a description. Then can mark a single frame or 
span over any amount of frames. If you hold the mouse cursor over a scene marker, its name, starting frame, 
duration and note will be displayed in the tool tip box.
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Quickly Creating Scene Markers at the Current Frame
You can quickly mark a single frame using the Mark Current Frame command. This creates a scene marker at 
the current frame, with no name, description and which does not span over several frames. 

When you mark the current frame, the scene marker is created in the same color as the last scene marker you 
created or edited, or in black if you haven’t created any scene marker yet. Hence, to select in which colour you 
mark the current frame, you can start by creating a scene marker with a specific colour or editing an existing 
scene marker with a specific colour—see Creating a Scene Marker and Editing Scene Markers.

How to mark the current frame

 1. In the Timeline view, make sure the playhead is set on the frame you want to mark.

NOTE 

Even if you right-click on a different frame, the scene marker will be created at the 
frame on which the playhead is positioned.

 2. Right-click in the timeline ruler and select Scene Markers > Mark Current Frame.

A scene marker is created at the current frame.

 

TIP 

The colour of the new scene marker is the last colour you selected for a scene marker. If this is 
the first scene marker you create, then it will be black. Hence, to quickly mark several frames 
with a specific colour, simply edit your new scene marker to the colour you want, and all other 
scene markers you create afterwards will have that colour by default—see Editing Scene 
Markers on page 301.
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Creating a Scene Marker
T-ANIMPA-005-011

Using the Marker dialog, you can create a scene marker on a single frame or a range of frames, and give it a 
name, a description and a specific colour if you want.

How to create a scene marker on a frame range

 1. In the timeline view, do one of the following:

 l To create a marker on a single frame, either move the timeline playhad to that frame, or 
select that frame on any layer.

 l To create a marker on a range of frames, select that range of frames on any layer.

 2. Right-click on the timeline ruler and select Scene Markers > Create Scene Marker.

The Marker dialog appears. 

 3. If you want the scene marker to have a name, type it in the Name field.

 4. To create the scene marker at a different frame than the one you selected, edit the starting frame 
number in the Time field.
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 5. To change the length in frames for this scene marker, edit the length in the Duration field.

 6. Open the Colour drop-down and select a colour for the new scene marker.

 7. To add a description or note to the scene marker, type it in the Note field.

 8. Click OK.

In the Timeline view, the scene marker is displayed over the selected frame counters. 

TIP 

Move the mouse cursor over the scene marker and wait 1 second to display the scene marker’s 
name, time, duration and note in a tool tip box.
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Moving Scene Markers
You can quickly offset a scene marker by clicking and dragging it. You can also select several scene markers 
and offset them together.

How to move scene markerss

 1. In the timeline ruler, click and drag on the scene marker you want to move.

How to move several scene markers

 1. In the timeline ruler, click on the first scene marker you want to move.

 2. While holding the Shift key, click on every other scene marker you want to move to add them to the 
selection.

NOTE 

When a scene marker is selected, its outline will turn cyan, and other scene markers 
will become slightly darker.

 3. Click and drag on one of the selected scene markers.
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Editing Scene Markers
You can modify the colour of a scene marker or edit the note attached to it.

How to edit a scene marker

 1. In the timeline ruler, click on the scene marker to select it. 

NOTE 

When a scene marker is selected, its outline will turn cyan, and other scene markers 
will become slightly darker.

 2. Do one of the following:

 l Double-click on the scene marker.

 l Right-click on the timeline ruler and, in the context menu, select Scene Markers > Edit Scene 
Marker.

The Marker dialog box appears.

 1. To edit the scene marker’s name, type it in the Name field.

 2. To change the starting frame of the scene marker, edit the value in the Time field.

 3. To change the length in frames for this scene marker, edit the value in the Duration field.
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 4. To change the colour of the scene marker, open the Colour drop-down and select a new colour. 

 5. To edit the note for the scene marker, type it in the Note field.

 3. Click OK.

TIP 

Move the mouse cursor over the scene marker and wait 1 second to display the scene marker’s 
name, time, duration and note in a tool tip box.
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Deleting Scene Markers
You can delete unused scene markers.

How to delete scene markers

 1. In the timeline ruler, click on the scene marker you want to delete.

NOTE 

When a scene marker is selected, its outline will turn cyan, and other scene markers 
will become slightly darker.

 2. If you want to delete several scene markers, hold the Shift key and click on every other scene 
marker you want to delete to add them to the selection.

 3. Right-click on the timeline ruler and, in the context menu, select Scene Markers > Delete Scene 
Marker.

NOTE 

Do not attempt to delete scene markers by pressing the Del key, as that will delete the 
currently selected element in your scene instead.

303



Scene Marker View & Marker List
The Scene Marker view allows you to manage all your scene markers easily inside a View. It lets you select, 
modify, create and delete a marker. 

You can also search for the markers from the list of markers you have created. You can move the specific 
markers from the Timeline to the desired marker location.

The exporter uses scene markers to separate each animation in gaming.

How to access scene marker in Timeline

 1. In the Timeline, click  and select Scene Markers to enable.

Parameter Description

Change Colour

Allows you to modify the scene marker colour on several markers at the same 
time.

NOTE 

This option is only available when a marker is selected.
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Prefix & Suffix

Allows to add or remove Prefix or Suffix to the name of the marker. 

NOTE 

This option is only available when a marker is selected.

Add Frame to Marker Add frames to the selected marker in the Timeline.

Remove Frame to Marker Remove frames to the selected marker in the Timeline.

Add Scene Marker Create a new scene marker.

Delete Scene Marker

Delete selected scene markers.

NOTE 

This option is only available when a marker is selected.

Search in Notes Allows you to search a marker inside Notes, when this option is selected.

How to select markers from the list

Inside the list you can select one or several markers

 1. Select a marker from the list.

 2. Once the marker is selected, Timeline will move on to that marker automatically.

 3. It will mark the start and end frames to the playback.

NOTE 

It will start with the lowest frame in your selection and ends with the farthest frame selected.

How to modify markers

You can modify different columns of the markers as per your need such as Colour, Name, Note, Start, End, 
Duration.

 1. Double click on any column and it will open the entire cell for you to modify.
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NOTE 

To modify Colour, click only once on the colour column, and a colour selector will appear.

How to search markers

You can search any marker by using the search bar at the bottom.

 1. Type in the name of the marker you want to search inside Name section.

 2. Select "Search in Notes" option at the bottom in order to search for the marker inside Notes section.
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Setting Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce the FPB 
(Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view lets you pace your 
animation according to the tempo or beat of the soundtrack music or to any rhythmic sound, such as the ticking 
of a clock or water leaking from a spout.

How to set the tempo markers

 1. In the Xsheet menu, select View > Set Tempo Marker.

The Tempo Marker dialog box opens.

 2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the frame where you want the tempo markers to begin.

‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in 
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) in 
which a tempo marker will appear in the Xsheet view.

 3. Click OK.
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Printing the Xsheet
Once you have marked all the information, corrections, and timing you want in the Xsheet view, you can print 
your exposure sheet. Printing the Xsheet allows you to take it with you to your animation table or give a copy 
to the animator. You can also use it to create your Xsheet skeleton directly in Harmony.

How to print your exposure sheet

 1. Select File > Print > Xsheet.

The Print dialog box opens.

 2. To set up your print:

 l Windows: In the Select Printer section, select your printer and adjust the rest of the 
printing settings. 

 l GNU/Linux: In the Print Destination section, select your printer and adjust the rest of 
the printing settings. 

 l macOS: In the Printer section, select your printer and adjust the rest of the settings by 
clicking on the Parameters  button. You can also click  PDF and select an option 
from the menu if you want to save a PDF version of your exposure sheet. 

NOTE 

Refer to your printer user guide to learn more about its options.
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 3. Do one of the following:

 l Windows and macOS: Click Print. 

 l GNU/Linux: Click OK.
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Skinning View
The Skinning view allows you to create skins on your assets. It allows you to  change or modify your Timeline 
interactively based on which skin you are working on. For example, to change different costumes on a 
character while still keeping the animations.

To create a skin, you first need to define Skin Nodes and then change their exposure based on which Skin you 
expose. 

You can also create groups " Group Skin and Global Skin" to gather and change specific skin nodes.

How to access skinning in Timeline

 1. In the Timeline, click  and select Skinning to enable.

Parameter Description

Skin Nodes
This column shows you which drawing layers are defined as Skin Nodes and 
which group they are assigned to.

Path This column refers to the node path in the Node View and Timeline.
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Skin This column shows which skin is applied to the group.

Types of Manipulators

The Skinning view gives you access to the following manipulators.

 l Global Manipulators: Changes/Actions will be applied globally.

Parameter Description

Toggle Skin Nodes Toggle if a selected drawing layer is defined as a Skin Node.

Save Skin Save the skins on the Skin Nodes.

Drop-down List Use the list to change the Global Skin to a different skin or to an empty one.

Add Global Skin Create a new Global Skin that will be applied to every Skin Node.

Rename Global Skin Rename the selected Global Skin.

Delete Global Skin Delete a Global Skin.

 l Group Manipulators: Changes/Actions will only be applied inside a specific group.

Group Manipulators available when at least one group is selected in the Skin Node List.

Parameter Description
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Add Group Skin
Create a new Group Skin that will be applied to the Skin Nodes of the 
selected groups.

Remove Group Skin

Remove a Skin from the Skin Nodes of the selected group 

NOTE 

This will delete the whole skin if there are no Skin Nodes applied to 
that skin in the scene.

Drop-down List
Use the list to change the selected Group’s Skin to a different skin or to an 
empty one.

Rename Group Rename the selected groups.

Delete Group

Delete the groups.

NOTE 

The Skin Nodes associated to the groups will be ungrouped.

 l Skin Nodes Manipulators: Changes/Actions will only be applied to selected nodes.

Group Manipulators available when a Skin Node is selected in the List.

Parameter Description

Move Skin Nodes Group/Ungroup Skin Nodes to an existing group.

Create New Group
Create a new group and group the selected Skin Nodes to the newly created 
group.
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Chapter 5: Drawing
Harmony has many powerful tools, views, and features for sketching, drawing and animating with ease. This 
chapter describes the main assets needed when drawing , as well as tips on how to start and use these tools 
efficiently. 
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About Drawing Tools
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and 
styles.

Here are the drawing tools available in Harmony, followed by the types of layer on which they are supported.  
If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap layer, 
some tools are not available. When tools are not available, they are grayed out in the Tools toolbar. 

Icon Tool Name
Vector 
Layer

Bitmap 
Layer

Select ✓ ✓

Cutter ✓ ✓

Reposition All Drawings ✓  

Contour Editor ✓  

Centerline Editor ✓  

Pencil Editor ✓  

Smooth Editor ✓  

Perspective ✓  

Envelope    

Edit Gradient/Texture ✓  

Brush ✓ ✓
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Icon Tool Name
Vector 
Layer

Bitmap 
Layer

Pencil ✓  

Eraser ✓ ✓

Text ✓ ✓

Line ✓ ✓

Rectangle ✓ ✓

Ellipse ✓ ✓

Polyline ✓  

Paint ✓ ✓

Ink ✓  

Paint Unpainted ✓ ✓

Repaint ✓  

Unpaint ✓ ✓

Stroke ✓  
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Icon Tool Name
Vector 
Layer

Bitmap 
Layer

Close Gap ✓  

Colour Eyedropper ✓ ✓

Pencil Texture Eyedropper ✓  

Each drawing tool has a series of options to customize its behaviour and drawing style. When you select a tool, 
the Tool Properties view displays the properties of the currently selected tool, where you can configure your 
drawing tool's behavior and style, if applicable. 
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About the Brush Tool
T-HFND-004-003

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it 
was created with a paint brush.

With the Brush tool, you can draw solid vector strokes or textured bitmap strokes, depending on your brush 
properties.  Solid vector brush strokes are made of a vector shape filled with a solid colour, making them limited 
in terms of art style, but lightweight and easy to manage. Textured brush strokes can have a bitmap brush tip, 
a bitmap paper texture, and various settings such as hardness, randomness, antialiasing and transparency. 
Hence, they can be used to draw in various art styles, add natural-looking details to your drawing and 
reproduce the feel of a real brush stroke. 

When drawing on vector layers, you can use the Select Tool, Contour Editor, Smooth Editor, Perspective and 
Envelope tool to scale your brush strokes or to tweak their shape. If your strokes contain a bitmap texture, 
Harmony will scale or deform the texture to fit the new shape of your brush. If your brush is scaled up or 
deformed in a way that takes more volume, Harmony will automatically generate new pixels for the textures, 
which might cause them to lose quality.

On vector layers, textured vector brush strokes are composed of a greyscale bitmap mask applied to their 
colour. Hence, their colour can be repainted or updated as easily as with solid vector brush strokes. Changing 
the colour used to paint a textured vector brush stroke  from the colour palette will update the colour in  
textured vector brush stroke, as it would with solid vector brush strokes, all the while preserving its texture.

You can also create dynamic brushes, which allow you to use artwork created in Harmony as if it was a brush 
tip or a stamp. 

NOTE 

To learn more about the options of the Brush tool, see the Reference Guide.
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Drawing with the Brush Tool

T-HFND-004-003A 

In the Camera or Drawing view, you can draw on any drawing layer type with the Brush tool. 

How to draw with the Brush tool                                       on a vector layer                 

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Tool Properties view, set the Maximum Size to the desired brush size. 

NOTE 

If you are drawing with a mouse, your strokes will always be at their maximum size. If you are 
using a pressure-sensitive tablet, your strokes will vary in size depending on the pressure of 
your pen, ranging between 25% to 100% of the maximum size. 

 4. In the Colour view, click a colour swatch to select a colour.

 5. In the Drawing or Camera view, start drawing.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 
the start of your drawing stroke will connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near 
existing artwork, the end of that drawing stroke will connect to that artwork.

How to draw with the Brush tool on a bitmap layer

 1. In the Timeline view, add a bitmap drawing layer.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Tool Properties view, set the Maximum Size to the desired brush size. If you are drawing with 
a mouse, your strokes will always be at their maximum size. If you are using a pressure-sensitive 
tablet, your strokes will vary in size depending on the pressure of your pen, ranging between 25% 
to 100% of the maximum size by default.

 4. In the Colour view, select a colour.
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 5. If you would prefer using Red/Green/Blue sliders, you can switch between HSV and RGB sliders by 
doing one of the following:

 l Select Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. 

 l Right-click on the colour sliders and select RGB Sliders or HSV Sliders.

NOTE 

Although you can use colours from your colour palette to paint on a bitmap layer, 
colours used in a bitmap drawing layer are not linked to their colour swatch in the 
palette. This means that, contrary to vector drawing, updating the colours in your colour 
palette will not update your bitmap drawings with the new colours. 

 6. In the Camera or Drawing view, start drawing.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.
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Creating a Solid  Brush

T-ANIMPA-002-001A

When drawing with the Brush tool on a vector layer, you can use either solid vector brushes or textured vector 
brushes. By default, your brush will be a solid vector brush. A solid vector brush creates a vector shape and 
simply fills it with the selected colour, making lightweight, simple crisp strokes. 

A solid vector brush's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 
specific size, aspect ratio and angle. Also, solid vector brushes can be automatically smoothed by Harmony as 
you draw.

If you are drawing on a bitmap layer, you can only use textured brushes. You can create a textured brush that 
makes solid looking strokes, but they can not be automatically smoothed by Harmony, nor can they tweaked 
with vector tools such as the Contour Editor. For more information, see About Vector and Bitmap Layers on 
page 643.

 

You can now control the Size properties with input options such as Pressure, Tilt and Speed. You can use a 
combination of multiple inputs to control a single property. Also, you can control the Angle Function by 
selecting any one option from the drop down list.

How to create a                                       solid vector                                  brush

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

The Brush Properties dialog opens.
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 1. In the Brush Type dropdown list, select Solid Vector.

 2. In the brush tip list, select either Circle, Diamond or Square. 

 3. Use the Maximum Size slider to set the maximum size of your brush tip.

 4. 
NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 5. You can control the size properties by clicking on the arrow button on right and the Size Properties 
dialog box will appear.
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 6. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 
Brush Tool Properties. 

 7. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 8. If you want your brush to keep the same size relative to the camera frame when the camera zooms 
in on or zooms out of the scene, check the Proportional to Camera option.

 9. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 
window. 

 10. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 11. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 12. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.
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 13. If you want your brush tip to rotate with the angle of your pen tip use the Angle Function. You can 
select one of the following options:

 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 
is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: When the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the twist angle of the stylus and is only available with 
Wacom Art Pen.

 14. Click on the Smoothing tab.

 15. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  stroke's direction, curves and corners. A higher setting will prevent your line from being shaky, 
but is liable to reduce your drawing precision and to round sharp corners into curves.

 16. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 17. Either close or set aside the Brush Properties dialog.

 18. In the Camera or Drawing view, start drawing to test your brush settings.
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Creating a Textured Brush

T-LAY-001-004

Using textured brushes, you can create an infinite range of fuzzy, textured and watercolour lines. You can use 
bitmap brush tips, adjust your line's hardness and opacity, combine two tips and apply a paper texture to your 
brush strokes so as to adapt the Brush tool to a variety of art styles and create natural-looking brush strokes.

When drawing on a vector layer, brushes are solid vector brushes by default. You can however create a 
textured vector brush which combines both Harmony's vector and bitmap drawing capabilities. You can tweak 
textured vector brush strokes using various vector editing tools such as the Contour Editor, the Smooth Editor, 
the Perspective tool and the Envelope tool, and Harmony will resample the textures inside your brush strokes 
with each modification.

If you are drawing on a bitmap layer, your brush is always textured. You can configure a textured brush to look 
crisp and solid if desired, but brush strokes on bitmap layers cannot be tweaked or smoothed.
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Configuring a Textured Brush Tip

T-ANIMPA-002-002

The Brush tool supports two types of brush tips: Solid and Textured. Solid brush tips are plain shapes that can 
be used to draw vector shapes filled with a solid color, whereas textured brush tips are bitmap images with 
various shapes and opacity levels that can be used to create natural-looking brush strokes.

Solid brush tips are not customizable. The selection is limited to either a circle, diamond or square-shaped 
brush tip, the proportions and angle of which can be adjusted. While Harmony also comes bundled with 
preset textured brush tips, it is also possible to create and use your own textured brush tips. 

How to configure a textured brush tip

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
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 4. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see 
Adding a Brush Tip on page 331.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

 6. 
NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 7. You can control the size properties by clicking on the arrow button on right and the Size Properties 
dialog box will appear.
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 8. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 
Brush Tool Properties. 

 9. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 10. If you want your brush to keep the same size relative to the camera frame when the camera zooms 
in on or zooms out of the scene, check the Proportional to Camera option.

 11. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 
window. 

 12. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 13. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 14. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 15. If you want your brush tip to rotate with the angle of your pen tip use the Angle Function. You can 
select one of the following options:
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 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 
is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: When the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the twist angle of the stylus and is only available with 
Wacom Art Pen.

 16. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush 
will only be opaque in its center, and will gradually become transparent towards its edges. 

 17. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints 
the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip 
has been stamped repeatedly over your canvas instead of dragged on it.

 18. If you want the size of your brush tip to vary each time it's printed on your canvas, set the Random 
Size setting to any value above 0 %.

 19. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 
the Random Angle setting to any value above 0 °.

 20. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 21. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 22. In the Camera or Drawing view, start drawing to test your brush settings.

NOTE 

It is also possible to use textures when drawing with the Pencil tool. Those textures follow the 
angle of your pencil lines, which may create more interesting results depending on your desired 
drawing style. For more information, see About Pencil Line Textures on page 383.

330

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Adding a Brush Tip

In the Brush or Eraser Properties dialog, you will find a set of default brush tips which are bundled with 
Harmony, but you can also create your own brush tips, then export your collection or import an existing set. 

To make your own brush tip, you must first create an image file containing the brush tip, either in Harmony or in 
a third party software, like Adobe Photoshop, then import it into Harmony. A brush tip must be a greyscale 
image. Colors in brush tips are not acknowledged by Harmony, as brush tips only use the colour you are 
painting with in Harmony. Your brush tip should also not contain transparency, as Harmony determines the 
brush tip's transparency based on its black, white and grey levels. Its black parts will appear 100% opaque, its 
white parts will appear 100% transparent, and its grey parts will appear semitransparent. 

You can import brush tips in any image format supported by Harmony. It is recommended to create brush tips 
in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Brush tips are shared between the brush tool and the eraser tool. Like paper textures and brush presets, paper 
textures are saved in your preferences. You can also export your brush tips into an .xml file, and import them 
on a different workstation, allowing you to share your brush tips between the different people collaborating on 
your project.

How to add a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Do one of the following:

 l Click on the Paper Texture menu icon  and select Add.

 l Click the Add Paper Texture button.
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 5. In the file browser window, navigate to the location of your texture image file and select it.

 6. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming Brush Tips

You can rename your bitmap brush tips to keep your list organized. 

How to rename a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Select the brush tip you wish to rename. 

 5. Click on the Paper Texture menu icon  and select Rename.

 6. In the Rename  dialog box that appears, type in the new name of the brush tip. 

 7. Click OK.
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Deleting Brush Tips 

You can delete unnecessary brush tips to keep your list organized. 

How to delete a brush tip

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Select the brush tip you wish to delete.

 5. Do one of the following:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.

NOTE 

You can delete any brush tip in the Paper Texture library, including the default paper textures, 
except for the three solid brush tips: Circle, Diamond and Square. Also, brush tips will not get 
deleted if they are used in a brush preset. 
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Exporting Brush Tips

You can export brush tips to share, backup or install on a new computer. 

How to export brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 
brush tips and your paper textures.

 5. By default, both your brush tips and your paper textures are selected for export. If you only wish to 
export your brush tips, uncheck the Select Paper Textures option.

 6. Click Export.
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 7. In the Export Textures window that appears, browse to a location where you want save the .xml 
file and give it a name.

 8. Click Save.
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Importing Brush Tips

You can import Harmony brush tips you previously exported.

How to import brush tips

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 4. Click on the Paper Texture menu icon  and select Import.

 5. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush tips.

 6. Click Open.

In the Import Tips and Textures dialog box appears.
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 7. If the selected .xml file also contains paper textures, they will be selected for import along with 
the brush tips by default. If you wish to only import the paper textures, uncheck the Select Paper 
Textures option.

 8. Click Import.

The imported brush  tips appear in the Brush Tips Library. 
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Changing the Brush Tip Display

You can display your preset list as thumbnails or a list.

How to change the Brush Tips thumbnail display

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the 
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the 
eraser tool. 

 1. Click on the Brush Tips menu icon .

 2. Select one of the following options:

 l Small Thumbnail: Displays brush tips in a grid of small thumbnails.

 l Large Thumbnail: Displays brush tips in a grid of large thumbnails with their name. 
The default view setting.

 l List View: Displays brush tips in a list, with their name on the left and their texture on 
the right of each row. 
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Configuring Smoothing for a Textured Brush

T-ANIMPA-002-003

If you are drawing on a vector layer, the Brush Properties dialog will have a Smoothing tab, which allows to 
configure how Harmony automatically smooths your brush strokes. If you are drawing on a bitmap layer, this 
topic is not applicable, as bitmap layers do not support automatic smoothing. 

How to configure a textured brush's smoothing

 1. In the Brush Properties dialog, open the Smoothing tab.

 2. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  stroke's direction, curves and corners. A higher setting will prevent your line from being shaky, 
but is liable to reduce your drawing precision and to round sharp corners into curves.

 3. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 4. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring Antialiasing and Transparency for a Textured Brush

A textured brush can be either antialiased or not antialiased. Without antialiasing, your brush strokes will only 
create fully opaque artwork. With antialiasing enabled, you also have the option to set the flow and opacity of 
your brush, allowing you to simulate the effect of inks and paints with various consistencies. 

You can now control the Flow/Opacity properties with input options such as Pressure, Tilt and Speed. You can 
use a combination of multiple inputs to control a single property.

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set to 
Textured Vector Brush to enable the textured brush options.

How to configure a brush's antialiasing and transparency settings

 1. In the Brush Properties dialog, open the Transparency tab.

 2. If you want your brush to have antialiasing or transparency, enable the Antialiasing option. 

NOTE 

If the Antialiasing option is disabled, all Transparency settings will be disabled, and 
your brush will only create fully opaque artwork.

 3. Use the Maximum Flow slider to set the consistency of your brush strokes. A lower flow will make 
your stroke more transparent towards the extremities and more opaque in its center, whereas a 
higher flow will make your stroke consistently opaque.
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 4. If you are using a pressure-sensitive pen tablet, use the Minimum Flow slider to set the percentage 
of the maximum flow that you want your brush to use when using your pen with very little pressure. 
If you don't want the pressure on your pen to affect the flow, set this parameter to 100%.

 5. Use the Maximum Opacity slider to set the maximum opacity of your brush strokes. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Opacity slider to set the 
percentage of the maximum opacity that you want your brush to use when using your pen with very 
little pressure. If you don't want the pressure on your pen to affect the opacity, set this parameter to 
100%.

NOTE 

You can control the Flow/Opacity properties by clicking on the arrow button on the 
right and Flow/Opacity Properties Dialog box will appear.

NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool option, see 
Brush Tool Properties.

 7. If you want the Flow of your brush to be randomized, set the Random Flow setting to any value over 
0 %.

 8. If you want the Opacity of your brush to be randomized, set the Random Opacity setting to any 
value over 0 %.

 9. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring a Textured Brush with a Dual Tip

Textured brushes can also have a dual tip. A dual tip is a secondary tip that can be blended into your primary 
tip in various blend modes, with its own full set of tip settings. 

NOTE 

If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set to 
Textured Vector Brush to enable the textured brush options.

How to configure a brush with a dual tip

 1. In the Brush Properties dialog, click on the Dual Tip tab.

 2. Check the check box in the Dual Tip tab to enable the Dual Tip functionality.
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 3. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see 
Adding a Brush Tip on page 331.

 4. In the Blend Mode drop-down list, select the algorithm with which you want your secondary tip to 
blend into your primary tip:

 l Multiply will draw the least opaque pixel of either brush tip, making more spaced out, 
inconsistent strokes. 

 l Color Dodge will add the opacity of the pixels in both brush tips, making more 
opaque strokes. 

 l Combine will draw the most opaque pixel of either brush tip, combining the tip 
shapes without increasing their opacity.

 5. Use the Maximum Size slider to set the maximum size of your brush tip.

 6. 
NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 7. You can control the size properties by clicking on the arrow button on right and the Size Properties 
dialog box will appear.

 8. 
NOTE 

Please see Brush Properties Dialog and to learn more about Brush Tool options, see 
Brush Tool Properties. 

 9. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 10. If you want your brush to keep the same size relative to the camera frame when the camera zooms 
in on or zooms out of the scene, check the Proportional to Camera option.
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 11. 
NOTE 

The "Size Proportional to Camera" option has been moved to the new Size Properties 
window. 

 12. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 13. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 14. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 15. If you want your brush tip to rotate with the angle of your pen tip use the Angle Function. You can 
select one of the following options:

 l Constant: The static orientation of the brush tip expressed in degrees.

 l Heading: The orientation of the brush tip is determined by the direction in which the stroke 
is drawn. It changes dynamically as the stroke is drawn.

 l Azimuth: When the pen is tilted, it uses the direction in which the pen eraser is facing.

 l Twist (if supported by pen): It uses the twist angle of the stylus and is only available with 
Wacom Art Pen.

 16. Use the Hardness slider to set how much of the outer part of your brush tip should fade to 
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush 
will only be opaque in its center, and will gradually become transparent towards its edges. 
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 17. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints 
the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which 
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes 
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip 
has been stamped repeatedly over your canvas instead of dragged on it.

 18. If you want the size of your brush tip to vary each time it's printed on your canvas, set the Random 
Size setting to any value above 0 %.

 19. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set 
the Random Angle setting to any value above 0 °.

 20. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 21. If you want the spacing between each instance of the brush tip to be random, set the Random 
Spacing setting to any value above 0 %.

 22. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring a Brush with a Paper Texture

T-ANIMPA-002-004

Paper textures are bitmap textures that you can apply to your brush strokes as you draw. They act as 
transparency filters that are tiled over your brush strokes to make them look grainy, as if you were drawing on 
a rough paper surface. While Harmony comes bundled with preset paper textures, it is also possible to create 
and use your own paper textures. 

How to configure a brush with a paper texture

 1. In the Brush Properties dialog, click on the Paper Texture tab.

 2. Check the check box in the Paper Texture tab to enable paper textures.
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 3. In the paper texture list, select the desired paper texture. If you wish to create your own paper 
texture, see Adding a Paper Texture on page 350.

 4. Using the Texture Scale slider, select the scaling factor at which to scale the paper texture when 
applying it to your brush strokes.

 5. If you want your brush strokes to get more opaque as you drag your brush or when you draw over 
them, enable the Additive option.

 6. If you want the paper texture to always be aligned to the same grid regardless of where you draw 
your strokes, enable the Aligned option. Otherwise, your paper textures will be positioned relative 
to where you start your drawing stroke, and if you draw two strokes one over the other, their paper 
textures will clash with each other.

 7. In the Camera or Drawing view, start drawing to test your brush settings.
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NOTE 

It is also possible to use textures when drawing with the Pencil tool. However, those textures 
follow the shape of the line instead of tiling over your strokes. For more information, see About 
Pencil Line Textures on page 383.
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Adding a Paper Texture

In the Brush Properties dialog, you will find a set of default paper textures which are bundled with Harmony, 
but you can also create your own paper textures, then export your collection or import an existing set. 

To make your own paper texture, you must first create an image file containing the texture, either in Harmony 
or in a third party software, like Adobe Photoshop, then import it into Harmony. A paper texture must be a 
greyscale image. Colors in paper textures are not acknowledged by Harmony, as paper textures are applied 
onto the colour you are painting with in Harmony. Your texture should also not contain transparency, as 
Harmony determines the texture's transparency based on its black, white and grey levels. When drawing 
with a paper texture, its black parts will appear 100% opaque, its white parts will appear 100% transparents, 
and its grey parts will appear semitransparent. 

You can import brush tips in any image format supported by Harmony. It is recommended to create paper 
textures in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.

Like brush tips and brush presets, paper textures are saved in your preferences. You can also export your paper 
textures into an .xml file, and import them on a different workstation, allowing you to share your textures 
between the different people collaborating on your project.

How to add a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.
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 1. In the Brush Properties dialog, do one of the following:

 l From the Paper Texture menu, select Add.

 l Click the Add Paper Texture button.

 2. In the browser window that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming a Paper Texture

You can rename your paper textures to keep your list organized. 

How to rename a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Select the texture you want to rename.

 7. Click on the Paper Texture menu icon  and select Rename.
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 8. In the Rename Texture dialog box that appears, type in the new name for the texture. 

 9. Click OK.
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Deleting Paper Textures

You can delete unnecessary paper textures from your preset list. 

How to delete a paper texture

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 1. Select the texture you want to delete.

 2. Do one of the following:

 l Click on the Paper Texture menu icon  and select Delete.

 l Click the Delete  button.
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NOTE 

You can delete any paper texture in the Paper Texture library, including the 
default paper textures, as long as no brush preset is using that paper texture. 
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Exporting Paper Textures

You can export paper textures into an .xml file which will contain their name and bitmap texture. This can be 
useful if you wish to back up or share your paper textures. 

How to export paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured 
brush tips and your paper textures.
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 7. By default, both your brush tips and your paper textures are selected for export. If you only wish to 
export your paper textures, uncheck the Select Brush Tips option.

 8. Click on the Export button.

 9. In the Export Textures dialog that appears, browse to a location where you would like to save the 
.xml file, then type in the desired file name.

 10. Click Save.
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Importing Paper Textures

You can import paper texture presets you previously exported from Harmony. 

How to import paper textures

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 6. Click on the Paper Texture menu icon  and select Import.

 7. In the browser window that appears, navigate to and select  the .xml file in which you exported 
your paper textures. 

 8. Click Open.

In the Import Tips and Textures dialog box appears.
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 9. If the selected .xml file also contains brush tips, they will be selected for import along with the 
paper textures by default. If you only wish to import the paper textures, uncheck the Select Brush 
Tips option.

 10. Click Import.

The imported paper textures will appear in the Paper Texture Library. 
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Changing the Paper Texture Display

You can change the way the paper textures are displayed in the paper textures list of the Brush Properties 
dialog.

How to change the Paper Texture thumbnail display

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. In the Tool Properties view,  click the Arrow button to open the Brush Properties view.

 3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured 
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.

 4. Click on the Paper Texture tab.

 5. Check the check box in the Paper Texture tab to enable paper textures.

 1. Click on the Paper Texture menu icon .

 2. Select one of the following options:

 l Small Thumbnail: Displays paper textures in a grid of small thumbnails.

 l Large Thumbnail: Displays paper textures in a grid of large thumbnails with their 
names. The default view setting. 

 l List View: Displays paper textures in a list, with their name on the left and their 
texture on the right of each row. 
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Setting the Textured Brush Resolution

An important thing to take in consideration when drawing with textured brushes is that, contrary to solid 
vector brushes, textured brushes store their texture in bitmap data, which is stored in individual pixels. This 
implies that, where solid vector artwork can be scaled and zoomed in without issue, textured brush strokes are 
resolution dependent, and are liable to lose quality and appear pixelated if they are enlarged or zoomed in. 

By default, textured brush strokes have a pixel density of 100%. At this density, when your scene is not 
zoomed in and your artwork is not scaled up, each pixel in the textured brush strokes corresponds to one pixel 
in the rendered image. Scaling it up or zooming in will require Harmony to render several pixels using the same 
pixel from the brush stroke's texture, making the artwork lose quality.

Hence, before you start drawing using textured brushes, it is important to consider if you will need to zoom 
onto or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your 
bitmap artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure the pixel 
density for your textured brush strokes is of at least 300% before you start drawing. 

You can specify the pixel density for textured brushes at the scene level or at the drawing level:

 l Setting the pixel density at the scene level will make newly created drawings have the specified pixel 
density, but it will not change the pixel density of existing textured artwork.

 l Setting the pixel density  at the drawing level will allow you to change the pixel density of existing 
drawings, but will not affect the pixel density of drawings created afterward.

NOTE 

If you are drawing on a bitmap layer, you must set the pixel density and canvas size for bitmap 
artwork instead—see Setting the Bitmap Resolution on page 646.

How to set the pixel density for textured brush strokes for a scene

 1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

 2. Select the Bitmap Resolution tab.
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 3. In the Pixel Density field of the Default Texture Pixel Density for Vector Drawings section, enter 
the desired percentage of pixel density. If you intend to scale or zoom in on your artwork, make sure 
your pixel density is set to be at least the factor by which your artwork will scaled or zoomed on. For 
example, if you intend to scale your artwork by 300%, you need to set the pixel density to at least 
300%. If you intend to zoom in on your artwork from 12 fields to 6 fields, you need to set the pixel 
density to at least 200%. If you intend to do both, you need to set the pixel density to at least 
600%, as the camera zoom and scaling factor will have a multiplying effect on the apparent scaling 
of your artwork.

 4. Click OK.

From now on, new drawings created in your scene will have the selected pixel density for textured 
brush strokes.

Since changing the bitmap resolution settings for your scene will only affect newly created drawings, you may 
also want to change the pixel density for existing drawings. This is possible. However, if you choose to change 
the pixel density of textures in existing artwork, it will be resampled. If you increase the pixel density of 
existing artwork, Harmony will have to generate extra pixels for the texture, which will cause the artwork to 
lose quality. Hence, it is important to calculate and set the proper pixel density for your textured artwork 
before you start drawing.

How to change the pixel density for textured brushes strokes in existing drawings

 1. In the Timeline, Node or Camera view, select the drawing for which you want to change the 
textured brush stroke resolution. 

 2. From the top menu, select Drawing > Change Vector Drawing Brush Resolution.

The Change Vector Drawing Brush Textures Resolution dialog opens.

 3. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or 
zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your 
artwork will scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you 
need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12 
fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you 
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need to set the pixel density to at least 600%, as the camera zoom and scaling factor will have a 
multiplying effect on the apparent scaling of your artwork.

 4. If you want the specified pixel density to be applied on the existing textured brush strokes in the 
drawing, check the Apply to Existing Strokes option.

 5. If you want the specified pixel density to be applied to all the drawing's art layers (ie: Line Art, 
Colour Art and, if enabled, Overlay Art and Underlay Art), check the Apply to All Art Layers 
option. Otherwise, only the currently active art layer will be affected.

 6. If you want the specified pixel density to be applied to all drawings in the active layer, check the 
Apply to All Drawings option. Otherwise, only the current drawing will be affected. 

 7. Click OK.

From now on, new brush strokes will be in the selected drawing will be in the specified pixel 
density.

NOTE 

This does not change the default pixel density for the scene. New drawings will still be 
created with the scene's default  pixel density.
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About Brush Presets

Setting up your brush to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 
and error. Once you have found the correct settings for your brush, you will want to reuse it throughout your 
project for consistency. You can do that by creating and using brush presets.

Harmony comes preloaded with many brush presets which you can select from the Tool Properties view. It is 
also possible to create your own brush presets by configuring your brush, then saving it as a preset. 

Like brush tips and paper textures, brush presets are saved in your preferences. You can also export your brush 
presets into an .xml file, and import them on a different workstation, allowing you to share your brush presets 
between the different people collaborating on your project.

NOTES 

 l Brush presets are not to be confused with brush tips and paper textures. A brush tip is one of 
the properties of a brush. A brush preset contains all of the properties for a given brush. 
However, both can be exported, imported and managed similarly. 

 l Brush presets for vector layers and for bitmap layers are separate. A brush preset created while 
working on a vector layer cannot be used when working on a bitmap layer, and vice versa. 
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Creating a Brush Preset

You can create your own custom brush presets by configuring your brush, then adding it as a preset.

How to create a brush preset

 1. Make sure the current drawing layer is vector if you wish to create a vector brush preset, or bitmap if 
you wish to create a bitmap brush preset—see About Vector and Bitmap Layers.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. Click on the Arrow button to open the Brush Properties dialog.

 4. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 5. Do one of the following:

 l From the Brush Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 6. In the New Preset window, type a name for your new brush preset.

Your new brush preset is added to the end of the list of brush presets.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Timeline or Xsheet view, select an empty cell in a vector drawing layer. 

 2. In the Camera or Drawing view, draw the artwork with which you want to create a stamp.

 3. Do one of the following:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 
Timeline or Xsheet view. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  
tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—
see—Selecting, Repositioning and Transforming Artwork on page 478.

 4. In the Tools toolbar, select the  Stamp  tool.

 5. In the Tool Properties view, click on the New Preset  button.
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 6. In the New Preset dialog, type the desired name for your new stamp.

 7. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Selecting a Brush Preset

Harmony provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming a Brush Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select the brush preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Brush Presets

You can export brush presets into an .xml file which will contain all of your brush's settings. This can be useful 
if you wish to back up or share your brush presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export 
presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 
export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Brush Presets

You can import brush presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish 
to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 
want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of 
their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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Adjusting Texture Opacity

An advantage of using textured vector brushes on vector layers is that you can adjust their opacity afterward. 
Using the Adjust Line Texture Opacity dialog, you can adjust the opacity levels between the most opaque and 
the most transparent pixels in your textures. 

How to adjust the line texture opacity

 1. If you are in Camera view, select the Current Drawing on Top option—see Displaying the Current 
Drawing on Top on page 558.

 2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

 3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

 4. Do one of the following:

 l Drag the upper slider towards the right to increase the transparency of the more 
transparent pixels.

 l Drag the lower slider towards the left to increase the opacity of the more opaque 
pixels. 

 5. If you want to apply the changes to all drawings exposed on the layer, enable the Apply to All 
Drawings option.

 6. Click OK.
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About the Pencil Tool
T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. 
The pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

The Brush  and Pencil  tools are used for drawing and sketching. Both  tools support pressure sensitivity, 
allowing you to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil 
and shape tools produce central vector lines. This means that a pencil line’s control points (used to deform its 
shape) are located along the length of the central spine, while the Brush line’s control points are located along 
the contour.

 l If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor  tool. 

 l If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor  tool. 

 l You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line   option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool, 
as it produces a more realistic and natural feel. Transparent pencil lines may not display the way you want 
when they overlap:
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The pencil line is more appropriate for the final line of your clean drawings. Also, if you're drawing for digital 
animation and intend to use the Auto-Patch effect to connect the parts of your character model, you should use 
pencil lines for the Auto-Patch effect to work as expected.

NOTE 

To learn more about the Pencil tool options, see the Reference Guide.
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Drawing with the Pencil Tool

T-HFND-004-004A

Using the Pencil tool, you can draw vector pencil lines which can be easily tweaked and reshaped as needed.

How to draw with the Pencil tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 
the start of your drawing stroke will connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near 
existing artwork, the end of that drawing stroke will connect to that artwork.
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Creating a Pencil

T-LAY-001-001

You can configure a pencil's size, how much Harmony should automatically smooth your pencil lines when 
drawing, the shape of the tips and corners of your pencil line as well as its texture.

How to modify the pencil settings

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

The Pencil Properties dialog opens.

 3. Use the Maximum Size slider to set the maximum size of your pencil line.

 4. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
pencil when using your pen with very little pressure. The minimum size is set to a percentage of 
your pencil's maximum size, which is 20% by default. If you don't want the pressure on your pen to 
affect the pencil size, set this parameter to 100%.

 5. If you want your pencil to keep the same size relative to the camera frame when the camera zooms 
in on or zooms out of the scene, check the Proportional to Camera option.

 6. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  pencil stroke's centreline. A higher setting will prevent your line from being shaky, but is liable 
to reduce your drawing precision and to round sharp corners into curves.
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 7. If you are using a pressure-sensitive tablet, use the Contour Smoothing slider to set the amount of 
smoothing Harmony should perform on your pencil stroke's contour. A higher setting will smoothen 
the variations in your pencil line's thickness and reduce its amount of control points, but may affect 
the precision of the variations in line thickness.

NOTE 

This parameter is only useful if you are drawing with a pressure-sensitive tablet, as it 
only affects the control points for the thickness of your pencil line. When drawing with 
a mouse, the pencil line has a uniform thickness, and hence its contour only has control 
points at its extremiities. 

 8. Click on the Shape pop-up buttons to select whether you want the Start and End of your pencil 
lines to be Round or Flat, and whether you want the points and corners where pencil lines Join to 
be Round, Mitre-shaped or Beveled.

 9. Click on the Texture tab.

 10. If you want your pencil line to have a texture, select the desired pencil line texture from the pencil 
line texture library. Otherwise, select None. For more information on pencil line textures, see About 
Pencil Line Textures on page 383.
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 11. Either close or set aside the Pencil Properties dialog.

 12. In the Camera or Drawing view, start drawing to test your pencil settings.
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About Pencil Line Textures

Just like the Brush tool, the Pencil tool also supports textures. However, there are important differences 
between the way brush textures and pencil textures work.

For one thing, a pencil line texture is applied with regard to the width and direction of the pencil lines. For 
example, if you draw a spiral with a dash texture, the dashes will follow the curves of the spiral, and if you 
draw a thicker line with the same texture, the dashes will be both longer and thicker.

Like colours, pencil textures are stored in special palettes in your scene. While brush textures are stored in your 
artwork as bitmap data, pencil textures are stored in your artwork by linking the pencil line with its pencil 
texture in the palette. This means that if you scale or tweak your pencil line, the pencil texture will be updated 
based on the new line's shape and the original texture. This also means that you are able to change the pencil 
texture of an existing pencil line or to apply a texture to a pencil line that does not already have one.

Pencil line textures can also be used with the Line, Rectangle, Ellipse and Polyline tools, as those tools also 
draw pencil lines. 
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Drawing with Pencil Textures

You can draw a textured pencil line by selecting the pencil texture, then drawing. 

There are two ways to select a pencil texture. In the Colour view, you can select a pencil texture palette, then 
one of its pencil texture swatches, as you would do to select a colour, or you can select a pencil texture from the 
current pencil texture palette in the Pencil Properties dialog.

Your pencil texture will be combined with the selected colour to make a textured colour line.

NOTE 

You can also draw with textured pencil lines with the Line, Rectangle and Ellipse tools. 

How to draw with a textured pencil line using the Colour view

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Colour view, select the colour with which you wish to draw. 

 3. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 4. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 5. In the swatch list, select the pencil texture you want to use. 

 6. In the Camera or Drawing view, draw a pencil line.
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How to draw with a textured pencil line using the Pencil Properties dialog

 1. In the Colour view, select the colour with which you wish to draw. 

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 5. In the Texture library, select a texture for the pencil.

 6. In the Camera or Drawing view, draw a pencil line.

385



386

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Applying Texture to a Pencil Line

You can apply a pencil texture to an existing pencil line. You can also change a textured pencil line's texture by 
following the same steps.

NOTE 

You can also apply pencil line textures on artwork created with the Line, Rectangle, Ellipse and 
Polyline tools. 

How to apply a pencil line texture to an existing pencil line using the Colour view

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select a pencil line.

 3. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 4. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 5. In the swatch list, select the pencil texture you want to apply to your pencil line.
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 6. The selected pencil line now uses the selected pencil line texture.

How to apply a pencil line texture to an existing pencil line using the Tool Properties 
view

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select a pencil line.

 3. In the Tool Properties view, scroll down to the pencil texture library panel.

NOTE 

The texture library in the Tool Properties view lists the same pencil textures as the ones 
in the currently selected pencil texture palette in the Colour view.

 4. Select the pencil texture you wish to apply.
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 5. The selected pencil line now uses the selected pencil line texture.
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Editing a Pencil Line's Texture

There are two kinds of modification you can make to a pencil line's texture. Using the Edit Gradient/Texture 
tool, you can scale the texture by its length and thickness, as well as offset its starting position. Using the 
Pencil Editor tool, you can change the texture's symmetry relative to the line's center.

How to scale the length or thickness of a pencil line texture.

 1. In the Tools toolbar, select the Edit Gradient/Texture  tool or press Shift + F3.

 2. Click on the pencil line you want to edit. 

 3. Drag one of the square-shaped handles to scale the texture's length, thickness, or both 
simultaneously.

How to offset a pencil line's texture.

 1. In the Tools toolbar, select the Edit Gradient/Texture tool or press Shift + F3.

 2. Click on the pencil line you want to edit. 

 3. Drag the triangle-shaped handle to offset the texture. 
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How to change a pencil line's symmetry

 1. In the Tools toolbar, select the Pencil Editor  tool or press 8.

 2. Click on the pencil line you want to edit. 

 3. Drag one of the line's control points closer or further away from the center line to change the size of 
its half of the texture.
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Picking a Pencil Texture from Artwork

Just like you can pick a colour from your artwork using the  Colour Eyedropper tool, you can pick a pencil 
texture from your artwork and make it the current pencil texture using the  Pencil Texture Eyedropper tool. 

How to pick a pencil texture from your artwork

 1. In the Tools toolbar, double-click or long-click on the  Colour Eyedropper button. Then, in the 
pop-up menu, select  Pencil Texture Eyedropper.

 2. In the Camera or Drawing view, click on a pencil line that uses the pencil texture you want to select.

The pencil texture used by that line will become the active pencil texture, and pencil lines you draw 
from that point will use that texture.
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Disabling Pencil Line Textures

After you selected a pencil line texture, if you wish to resume drawing solid pencil lines again, you can do so 
using either the Colour view or the Pencil Properties dialog. 

How to resume drawing with a solid pencil line using the Colour view

 1. Click on the Show Pencil Texture Palettes  button to display your pencil texture palettes.

 2. Over the swatch list, click on the No Texture button.

From now on, the pencil lines you draw will not have a texture.

How to resume drawing with a solid pencil line Pencil Properties dialog

 1. In the Colour view, select the colour with which you wish to draw. 

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

 5. In the pencil textures library, select None.
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From now on, the pencil lines you draw will not have a texture.
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Pencil Texture Palettes

Just like colours used by your drawings, pencil textures are stored in pencil texture swatches, which are stored 
in pencil texture palettes. Because pencil lines drawn with pencil textures are linked to the pencil texture in 
their pencil texture palette, pencil textures can be shared and updated just as easily as colours in your 
Harmony project.

For example, you can create the texture palette for your character in your character model's scene, then make 
scenes that include this character link to that character's pencil texture palette, as you can with their colour 
palette, to make sure both their colour and line textures are the same throughout your project. For more 
information, see About Advanced Palette Management on page 682.

Just as with colour palettes, you can update a swatch in a pencil texture palette with a different texture, and 
the pencil lines that are drawn with this texture will update with the new texture. This means your pencil 
textures can always be subjected to revisions. It is also possible to override a pencil texture with another one 
using the Colour-Override effect, and to clone a pencil texture palette, change the textures in its swatches, 
and decide if the drawings in a scene will use the original or cloned texture palette—see Overriding a Texture 
on a Pencil Line on page 294 and Cloning a Palette  on page 714.

When you create a new scene, your palette list will be preloaded with a default colour palette and a default 
texture palette, the latter which is contains some sample pencil textures. If you wish, you can use these 
textures for your project, you can build on this palette and add new textures as needed, or you can create your 
own texture palette, loaded with only your custom textures, to use across your project. You can configure 
Harmony to create new scenes with your own custom pencil texture palette.

NOTE 

The following topics will introduce you to the basics of creating and using pencil texture palettes. 
For more information on creating and managing swatches and palettes, see About Colour 
Swatches on page 661 and About Palettes on page 680.
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Creating a Pencil Texture Palette

Creating a pencil texture palette allows you to manage your own pencil textures as you wish. You can create 
separate pencil texture palettes for different characters, props and backgrounds as needed, and share them 
among the people collaborating on your project like you would with colour palettes.

Creating a pencil texture palette is as simple as creating a colour palette. When creating a palette, you have 
the option to create it as a colour or a pencil texture palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

      How to create a pencil texture palette (Basic palette list mode)

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. Do one of the following:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Create Palette dialog box opens.

 3. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains 
information to be easy to identify, such as the name of the character and information about the type 
of setting for this palette, if any.

 4. In the Palette Type drop-down, select Pencil Texture.

 5. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a pencil texture palette (Advanced palette list mode)

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. If you want to add the palette to an element's palette list, select a drawing from the element for 
which you want to create a palette in the Timeline, Xsheet or Camera view. 

 3. Do one of the following:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Palette Browser dialog box opens. 

 4. In the Palette Location panel, select the location where you want to store the palette file. If you are 
using Harmony Server, you can store the palette in any environment, job, scene or element on your 
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 
or inside its provisional job or environment. For more information, see About Palette Storage 
Locations on page 685.

 5. In the New Palette Name field, enter the name for the new palette. The palette list above this field 
lists the palettes that already exist in the selected location. Make sure you enter a name that is not 
already used by another palette. 

 6. In the Palette Type drop-down, select Pencil Texture.
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 7. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 8. Click OK. 

The new palette appears in the palette list.
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Adding a Pencil Line Texture

You can create your own pencil textures by first creating an image file containing the texture, either in 
Harmony or in a third party software, then importing it to your pencil texture palette. 

A pencil texture must be created with transparency, as Harmony will only use the image's transparency 
channel to determine how to apply the texture to your pencil lines. Hence, pencil textures can be in image 
format that are supported by Harmony and which supports transparency: .png, .tga, .tif, .psd, .psb and
 .sgi.

A pencil texture can be of any size, but the bigger the image resolution, the thicker the lines you can draw with 
it without seeing pixels. The pencil texture will follow your pencil lines on their horizontal axis, like so:

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to add a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 
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 3. Do one of the following:

 l Click on the Add Texture  button.

 l Right-click on the swatch list and select New Texture.

 l Open the Colour view menu  and select Colours > New Texture.

 4. In the file browser dialog, navigate to the location of your texture image file and select it.

 5. Click Open.

The texture is added to your pencil texture palette.

You can start drawing with your new pencil texture.

How to add a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.
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NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 4. Do one of the following:

 l Click on the New Texture  button over the pencil textures list.

 l Open the Brush menu  and select New Texture.

 5. In the file browser dialog, navigate to the location of your texture image file and select it.

 6. Click Open.

The texture is added to your pencil texture palette.

 7. In the pencil texture library, select the new pencil texture.
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You can start drawing with your new pencil texture.
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Renaming Pencil Line Textures

You can rename pencil textures from the Colour view or from the Pencil Properties dialog box. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to rename a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, double-click on the name of the texture you wish to rename.

 4. Enter the texture's name, then click outside of the text input field to confirm the new name.
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How to rename a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 4. In the pencil texture library, select the texture you wish to rename.

 5. Open the Brush menu  and select Rename Texture.

The Rename Texture dialog box opens.
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 6. In the Name field, type in the desired name for your texture

 7. Click OK.

You can start drawing with your new pencil texture.
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Deleting Pencil Line Textures

You can delete pencil texture palettes that you do not need. 

NOTE 

You should not delete any pencil texture that is used in your project, as pencil lines using a deleted 
pencil texture will become solid pencil lines.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to rename a pencil line texture using the Colour view

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, select the pencil texture you wish to delete.

406

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

 4. Do one of the following:

 l Click on the Remove Colour button.

 l Right-click on the pencil texture and select Delete.

 l Open the Colour view menu and select Colours > Delete.

 l Press Del (Windows/Linux) or Backspace (macOS).

The selected pencil texture is removed from the pencil texture palette.

How to rename a pencil line texture using the Pencil Properties dialog

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 3. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 4. In the pencil texture library, select the texture you wish to delete.
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 5. Do one of the following:

 l Click on the Delete Texture  button.

 l Open the Brush menu  and select Delete Texture.

The selected pencil texture is removed from the pencil texture palette.
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Replacing a Pencil Texture

Just like you can edit a colour swatch and simultaneously update all the drawings using the colour swatch with 
this new colour, you can replace an existing pencil texture with a different texture, and update all pencil lines 
that use this texture with the new texture.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to replace an existing pencil line texture

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the swatch list, select the pencil texture that you want to replace.
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 4. Do one of the following:

 l Right-click on the pencil texture and select Edit Texture.

 l Open the Colour view menu and select Colours > Edit Texture.

 5. In the file browser dialog, navigate to the location of your new texture image file and select it.

 6. Click Open.

The selected texture is replaced with the new texture file. It is also renamed based on the new 
texture's file name. 

Any pencil line that was drawn with the older pencil texture will now be drawn with the new 
pencil texture.
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Setting the Default Pencil Texture Palette

You can make a pencil texture palette into the default texture palette which is added to every new scene you 
create. This will be saved in your user preferences. 

How to add a texture to your preferences

 1. In the Colour view, click on the Show Pencil Texture Palettes  button to display your pencil 
texture palettes.

 2. In the palette list, select the pencil texture palette containing the desired pencil texture. 

 3. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 4. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 5. In the Pencil Properties dialog, click on the Texture tab.
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NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 6. Do one of the following:

 l Click on the Use as Default Texture Palette  button.

 l Open the Brush menu  and select Use as Default Texture Palette.

From now on, new scenes created in Harmony will have the selected pencil texture palette as their 
default pencil texture palette.
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Recovering the Default Pencil Texture Palette

If you have made modifications on the default pencil texture palette in your scene that you wish to undo, you 
can easily re-import the default pencil texture palette back into your scene as a new pencil texture palette.

How to recover the default pencil texture palette into your scene

 1. Click on the Show Pencil Texture Palettes  button to display your pencil texture palettes.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

NOTE 

The texture library in the Texture tab lists the same pencil textures as the ones in the 
currently selected pencil texture palette in the Colour view.

 5. Click on the Reload Default Texture Palette  button.

A copy of the default pencil texture palette is added to the scene's pencil texture palette list.
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Converting a Colour Palette to a Pencil Texture Palette

As of Harmony 15, each palette is set to either be a colour palette, or a texture palette, and both palette types 
are kept in separate lists. However, in Harmony 14 and prior versions, pencil texture palettes were just regular 
palettes, which you had to temporarily set at your pencil texture palette in order to use it for pencil line 
textures. 

Because of this, if you open a scene created in Harmony 14 or prior, and which contains pencil texture palettes, 
Harmony 15 will not be able to tell which palettes are colour palettes and which ones are pencil texture 
palettes. Hence, you must manually move your pencil texture palettes to the pencil texture palette list before 
you can use them for pencil line textures. 

The only exception to this is if a scene created in a prior version of Harmony has a pencil texture palette named 
penstyle_opacity. Because this was the default name for pencil texture palettes in older versions of 
Harmony, Harmony 15 will automatically convert those palettes to pencil texture palettes.

NOTE 

Converting a colour palette to a pencil texture palette is permanent. You cannot convert a pencil 
texture palette to a colour palette. However, you will be prompted to confirm before making the 
conversion, and the conversion can be undone with the Undo command. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to convert a colour palette to a pencil texture palette

 1. In the palette list of the Colour view, select the palette you want to convert to a pencil texture 
palette.

 2. Do one of the following:

 l Right-click on the palette and select Change to Pencil Texture.

 l Open the Colour view menu  and select Palettes > Change to Pencil Texture.
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The palette will be moved from the colour palette list to the pencil texture palette list. To see 
it, click on the Show Pencil Texture Palettes  button or the Show All Palettes  button.
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About Pencil Presets

Setting up your pencil to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 
and error. Once you have found the correct settings for your pencil, you will want to reuse it throughout your 
project for consistency. You can do that by creating and using pencil presets.

Harmony comes preloaded with a few pencil presets which you can select from the Tool Properties view. It is 
also possible to create your own pencil presets by configuring your pencil, then saving it as a preset. 

Pencil presets are saved in your preferences. You can also export your brush presets into an .xml file, and 
import them on a different workstation, allowing you to share your brush presets between the different people 
collaborating on your project.
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Creating Pencil Presets

T-LAY-002-002

You can create your own custom pencil presets.  

Regular pencil presets allow you to set the size and smoothing of the line or shape.  As you draw, the thickness 
of the line varies according the amount of pressure you apply with a pen and tablet.

NOTE 

To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Pencil on 
page 380.

 4. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 5. Type in a name for your new pencil thickness stencil and click OK.

 6. Start drawing in the Drawing or  Camera view. 
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Creating Pencil Thickness Presets

T-LAY-002-003

Thickness stencils that are indicated with this  icon  are also set with specific properties, but disregards 
the pressure of your pen and tablet. The line thickness varies. You can access thickness stencils from the list of 
presets on the Tool Properties view or create your own. 

How to create a pencil thickness stencil

 1. In the Tools toolbar, select the Select  tool.

 2. In the Camera view, select the pencil line or shape from which you want to take the style.

 3. In the Tool Properties view, click the New Thickness Stencil  button.

A new thickness stencil is added to the end of the list in the Presets menu.

 4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or 
Camera view to apply the thickness stencil you created.
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Selecting a Pencil Preset

T-ANIMPA-010-001

A pencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness 
stencils.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing or Camera view, draw your pencil line or shape.
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Applying a Pencil Preset

T-ANIMPA-010-004

You can apply a pencil preset on already drawn pencil lines using the Select tool.

How to apply a thickness stencil to a pencil line or shape

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

 3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.
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Renaming Pencil Presets

You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the thickness stencil or preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets

You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Exporting Pencil Presets

T-ANIMPA-010-005

You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export 
presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 
export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Pencil Presets 

T-ANIMPA-010-006

You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish 
to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 
want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Pencil Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of 
their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About Shape Tools
T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a 
square or circle into a much more complex drawing—see About the Contour Editor Tool on page 508  and 
About the Pencil Editor Tool on page 519. 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

NOTES 

 l The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, 
rename, import and export presets, see About the Pencil Tool on page 376.  

 l To learn more about the shape tool parameters, see the Reference guide . 
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Creating Lines, Rectangles and Ellipses  with the Shape Drawing 
Tools

T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also use 
these tools to draw perfect circles and squares. 

How to draw with the Line tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Line  tool.

 3. In the Camera view, click and hold where you want the line to start, then move the mouse cursor 
where you want the line to end. 

 l If you want to snap the angle of your line to the nearest 15° angle, hold the Shift key.

 l If you want to snap the end of your line to the nearest shape, hold the Alt key.

 l If you want to draw a curved line, hold Ctrl (Windows/Linux) or ⌘  (macOS). The line will end 
where your mouse cursor currently is, and moving the mouse cursor will pull the line's curve 
towards it. 

TIP 

You can use the Contour Editor  tool to tweak the shape of your line—see About the 
Contour Editor Tool on page 508.                 

How to draw with the Rectangle or Ellipse tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Rectangle  or Ellipse  tool.

 3. To automatically fill the shape, in the Tool Properties view, enable the Auto Fill  option.
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 4. In the Camera view, click and hold where you want one of the corners of your shape to be, then 
move the mouse cursor where you want the opposing corner of the shape to be.

TIPS 

 l To draw a perfect square or circle (with equal width and height), hold the Shift key. 
You can also enable the  Draw Square or  Draw Circle option in the Tool 
Properties view.

 l To draw the rectangle or ellipse from its centre instead of its corner, hold the Alt 
key.
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Drawing Curved Lines with the Line Tool

The Line tool allows you to draw curved lines very quickly by drawing a straight line, then defining its curve 
right after.

There are three ways to do this:

 l In Straight Line Mode, the default mode of the Line tool, you can press and hold the Ctrl 
(Windows/Linux) or ⌘  (macOS) key while drawing a line to define a simple curve for it.

 l In Curved Line Mode, after drawing a line, you are prompted to move the mouse cursor or tablet pen 
and click once to define the line’s curve.

 l In S Curve Line Mode, after drawing a line, you are prompted to click once to position the line’s first 
Bezier handle, and then once more to position its second Bezier handle.

NOTE 

You can also define the curve of an existing line using the Contour Editor tool—see About the 
Contour Editor Tool on page 508.

How to draw a curved line in Straight Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Straight Line Mode.

 3. In the Camera or Drawing view, click and drag to draw a line, but don’t release the mouse button or 
tablet pen.

 4. While holding the mouse button or tablet pen down, press and hold the Ctrl (Windows/Linux) or 
⌘  (macOS) key.

 5. Move the mouse or pen in the general direction of the desired curve.

 6. When the curve looks as intended, release the mouse button or pen to preserve it.
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How to draw a curved line in Curve Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Curve Line Mode.

 3. In the Camera or Drawing view, click and drag to draw a line, then release the mouse button or 
tablet pen.

 4. Move the mouse or pen in the general direction of the desired curve.

 5. When the curve looks as intended, click to preserve it.

How to draw a curved line in S Curve Line Mode

 1. In the Tools toolbar, select the  Line tool.

 2. In the Tool Properties view, click  Curve Line Mode.

 3. In the Camera or Drawing view, click and drag to draw a line, then release the mouse button or 
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tablet pen.

 4. Move the mouse cursor or pen where you want the curve’s first Bezier handle (from the start of the 
line) to be positioned, then click.

 5. Move the mouse cursor or pen where you want the curve’s second Bezier handle (from the end of 
the line) to be positioned, then click.
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Creating Vector Shapes with the Polyline Tool

You can use the Polyline tool to draw complex segmented lines or curved lines by creating each point 
constituting the line. 

How to draw with the Polyline tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Camera or Drawing view, do one of the following:

 l Click to create a point with no Bezier handles.

 l Click and drag to create a point and its Bezier handles in the same stroke.

TIP 

While dragging to create a Bezier handle, you can:

 l Hold the Alt key to only change the angle of the outer handle, and leave the inner 
handle at its current angle.

 l Hold the Shift key to lock the angle of the handle at every 15 degrees. 

 4. Click or click and drag somewhere else to create the second point in your line. A line will be drawn 
between the first point and the second point. 

 5. Repeat the previous step until your line is complete. 

 6. While holding Ctrl (Windows/Linux) or ⌘  (macOS), click anywhere in the drawing space to release 
the Polyline tool from the line you've been building. You can then start building a new line. 

 7. If you want to make adjustments to the line you created, you can use the Contour Editor  tool—
see Reshaping a Shape, Pencil Line or Stroke with the Contour Editor Tool on page 509.
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About the Stamp Tool
The Stamp tool allows you to create stamps out of drawings in your projects, then stamp those drawings over 
your artwork. You can click on your artwork to apply your stamp once, or draw a stroke with the Stamp tool, as 
you would with the Brush or Pencil tool, to apply the stamp repeatedly along the stroke.

A stamp can contain one or several drawings. When a stamp is made of multiple drawings, it will cycle 
through each one of its drawings each time it is stamped onto your artwork. Hence, when you draw a stroke 
with a multi-drawing stamp, you will see the stamp tool cycle through the sequence of drawings as you draw 
the stroke. The way the drawings in a multi-drawing stamp are cycled through can even be customized. 
Among other settings, you can make it cycle backward, stamp random drawings or even stamp only a specific 
drawing in the sequence. 

Other than being able to easily re-use drawings, The Stamp tool can be used to streamline drawing if you 
need to draw something that requires a lot of repetitive detail, such as starry skies, grass, weather conditions 
or particle-type effects. For example, a stamp made of a few different drawings of a blade of grass can be used 
to draw a grass line by drawing a few strokes of that stamp over the same horizontal line. The ability to 
randomize the size, angle and distance of the stamping can give the result of using this procedure a more 
natural look. 
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NOTES 

 l To learn more about the Stamp tool properties, see the Reference Guide

 l The Stamp tool replaces the Dynamic Brush option of the Brush tool in Harmony 15.0 and 
earlier.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Timeline or Xsheet view, select an empty cell in a vector drawing layer. 

 2. In the Camera or Drawing view, draw the artwork with which you want to create a stamp.

 3. Do one of the following:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 
Timeline or Xsheet view. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  
tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—
see—Selecting, Repositioning and Transforming Artwork on page 478.

 4. In the Tools toolbar, select the  Stamp  tool.

 5. In the Tool Properties view, click on the New Preset  button.
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 6. In the New Preset dialog, type the desired name for your new stamp.

 7. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Creating a Multi-Drawing Stamp

You can create a stamp containing a series of drawings. All you need to do is create each drawing you want to 
add to your stamp in a separate drawing cell, then create a stamp with those drawings selected. The resulting 
stamp will cycle through each one of those drawings as you use it. 

In order to create a stamp using multiple drawings, your drawings must either be in a single contiguous 
horizontal or vertical sequence.

How to create a multi-drawing stamp 

 1. In the Timeline view, select an empty cell. 

 2. In the Camera or Drawing view, create the first drawing you want to have in the drawing sequence 
of your stamp.

 3. In the Timeline view, select the cell right after the current cell.

437



 4. In the Camera or Drawing view, create the second drawing you want to have in the drawing 
sequence of your stamp.

 5. Repeat these previous steps until you have all the drawings you want to have in your stamp, in one 
continuous sequence of drawings, in the same layer.

NOTE 

You can also create a stamp using drawings in a sequence of layers, provided that those 
drawings are all in the same frame and that those layers are adjacent to each other. 
The drawings in the stamp will be ordered from top to bottom.

 6. In the Timeline view, select all the cells containing the drawings you want to add to your stamp. 

TIPS 

 l You can click and drag over a sequence of drawing cells to select them.

 l You can also select multiple cells by clicking on the first cell you want to select, 
holding shift, then clicking on the last cell you want to select. 

 7. In the Tools toolbar, select the   Stamp  tool.
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 8. In the Tool Properties view, click on  New Preset.

The New Preset dialog appears.

 9. In the New Preset dialog, type the desired name for your new stamp.

 10. Click OK.

A multi-drawing stamp containing the artwork in all the selected layers is added to the Presets list. 

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Configuring a Stamp

When drawing a stroke with the stamp tool, the way the stamp is applied in terms of size, angle, spacing can 
be customized.

How to configure the size, pressure sensitivity, roundness, angle and spacing of a 
stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want to adjust the size of the stamp, change the Maximum Scale setting until you obtain the 
desired size.
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NOTE 

The Scale of a stamp is relative to the original size of the drawing used to create the 
stamp. At 100% scale, the stamp added to your artwork will be the same size as its 
original drawing. 

 4. If you're using a pressure-sensitive pen tablet and want the size of the stamp to depend on the 
amount of pressure you put on your pen, reduce the Minimum Scale setting. 

 5. If you would like to flip the stamp horizontally, click on the two-ended horizontal arrow  over the 
stamp thumbnail. If you would like to flip the stamp vertically, click on the two-ended vertical arrow 
left of the stamp thumbnails. 

 6. If your stamp is round or square, and you would like it to appear flat or squished, reduce the 
Roundness parameter. This will scale down the stamp vertically.

 7. If you want your stamp to be added to your artwork at an angle, change the Angle parameter. This 
setting rotates the stamp counterclockwise, on a 360 degrees scale.

 8. If you want to change the amount of space between each stamp when you draw a stroke with the 
Stamp tool, adjust the Spacing parameter. 

 9. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.
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NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can randomize the size, angle and spacing of the stamp. This will make the Stamp tool apply a randomly 
picked value to these parameters every time it applies a stamp to your artwork.

How to randomize the size, angle and spacing of a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want the size of the stamp to be randomized every time the stamp is added to your artwork, 
decrease the Minimum Scale setting, then increase the Random Size setting.
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NOTE 

The Random Size setting makes the size of each stamp vary randomly between its 
Minimum Scale and Maximum Scale. The higher the Random Size is, the closer to its 
Minimum Scale the random size can be.

 4. If you want the angle of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Angle setting.

 5. If you want the spacing of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Spacing setting.

 6. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can make a multi-drawing stamp cycle through its sequence of drawings in several different ways. You can 
also randomize the cycle, or disable it so that it only stamps the drawing of your choice. 

How to change the way a multi-drawing stamp cycles through its drawings

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.
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The Stamp Properties dialog opens.

 1. In the Cycle drop-down, select the desired cycling method:

 l Forward: Starts by applying the first drawing in the sequence, then the next one, and so on 
until it reaches the last drawing in the sequence, then cycles back to the first one.

 l Reverse: Starts by applying the last drawing in the sequence, then the previous one, and so 
on until it reaches the first drawing in the sequence, then cycles back to the last one.

 l Forward->Reverse: Starts by cycling forward through the sequence until it reaches the last 
drawing, then cycles backward to the first drawing, and so on.

 l Reverse->Forward: Starts by cycling backward through the sequence until it reaches the 
first drawing, then cycles back to the last drawing, and so on.
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 l Random: Applies a random drawing in the sequence each time the stamp is applied. 

 l Hold: Applies a single one of the drawings in the sequence over and over again. 

 2. If you selected the Hold option, select which one of the stamps in the sequence you wish to stamp 
onto your artwork by changing the Stamp setting in the Tool Properties view. For example, if you 
only want to stamp the second drawing in the sequence, set the Stamp setting to 2.

 3. If you want the cycle to restart at the beginning of each one of your drawing strokes, enable the 
Reset Cycle for Each Stroke option.

 4. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 
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Updating a Stamp

A stamp in your Presets list does not only contain its drawings, but also its properties. If you have made any 
changes to the properties of your stamp, and wish for those properties to be set automatically whenever you 
use that stamp, you can update the stamp. This will save the current properties of the stamp into its preset. 

Once that is done, the current properties of the stamp will be loaded the next time you select it from the 
Presets list, even after you close and reopen the project. 

NOTE 

You cannot update the drawings in a stamp. You can only update its parameters. If you need to use 
different drawings for your stamp, you must create a new stamp—see Creating a Stamp on page 
435 and Creating a Multi-Drawing Stamp on page 437.

How to update a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.
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The Stamp Properties dialog opens.

 3. In the Stamp Properties dialog, adjust the settings of your stamp as desired—see Configuring a 
Stamp on page 440.

 4. In the top-right corner of the Stamp Properties dialog, click on the Update Preset  button.

The selected stamp properties will be loaded whenever you select this stamp, even after you close 
and reopen your project. 
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Drawing with the Stamp Tool

Once you have created a stamp, you can start drawing with it. You can either stamp it into your artwork once at 
a time, or draw strokes with the tool, making it apply the stamp repeatedly onto your artwork along your 
strokes.

How to draw with the Stamp tool

 1. In the Layer panel of the Stage or Camera view or the Layers view, select the layer on which you 
want to apply the stamp.                     

 2. In the Tools toolbar, select the  Stamp  tool.

 3. In the Tool Properties view, select a stamp from the Presets list—see Creating a Stamp on page 435 
and Creating a Multi-Drawing Stamp on page 437.

 4. Move the mouse cursor over the Stage or Camera view. You will see the stamp under your mouse 
cursor as it will be applied into your artwork. If you want to adjust the size in which it will be 
applied, adjust the Maximum Scale setting in the Tool Properties view.

 5. By default, your stamp will be applied at an even size, angle and distance. Also, if your stamp is a 
multi-drawing stamp, it will cycle through its drawings in their original order. If you want your 
stamp to be applied with different parameters, see Configuring a Stamp.

 6. In the Camera or Drawing view, do one of the following:

 l To apply the stamp once, simply click where you want to apply it.

 l To draw a stroke along which the stamp is applied multiple times, simply draw a stroke with 

448

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

the tool as you would with the Brush or Pencil tool. 

TIPS 

 l If your stamp has multiple drawings in it, you can select which drawings to stamp by using 
the Stamp slider in the Tool Properties view. You can also cycle through the stamp's 
drawings by pressing the Left Arrow and Right Arrow keys. 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.
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Renaming Stamps

You can rename stamps you have created to make them easier to identify in the Presets list. 

How to rename a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to rename.

 3. Open the Brush Presets  menu, then select Rename Brush.

 4. In the Rename Brush dialog, enter the new name for your stamp.

 5. Click OK.

The stamp's new name updates in the Presets list. 
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Deleting Stamps

You can delete stamps you no longer need from the Presets list. 

How to delete a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to delete.

 3. Click on the Delete Brush  button just above the Presets list.

The stamp is removed from the Presets list. 
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Exporting Stamps

You can export stamps you have created to keep a backup of them, or to import them for use in another project.

How to export stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset   menu and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil, Eraser and Stamp tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export your 
stamps, uncheck Select/Deselect All, then check Stamp.

 4. Click on Export.

A save dialog appears.

 5. Browse to the location where you want to save the .xml file that will contain your presets.

 6. Enter the desired file name for your presets file. 

 7. Click on Save.
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Importing Stamps

You can import stamps you have exported from another project into your current project, allowing you to reuse 
them between projects or to restore backups of your stamps. 

How to import stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

An Open File dialog appears.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your stamps

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish 
to import the stamps from this file, uncheck Select/Deselect All and check Stamps.

 6. Click on Import.

The imported stamps will be added to the Presets list in the Tool Properties view. 
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Changing The Way Stamps Are Displayed

By default, your stamps are listed in the Tool Properties dialog as strokes. You can also preview them as big 
thumbnails if you want to be able to pick them without scrolling, or as small thumbnails if you have a lot. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of 
their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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Stamp Tool Modes

When you select the Stamp tool, its properties are displayed in the Tool Properties view.

 Draw Behind Mode

When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen. 
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About the Stroke Tool
T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful 
for drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool 
can be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE 

To learn more about the Stroke tool parameters, see the Reference guide .
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Creating Invisible Lines with the Stroke Tool 

T-HFND-004-013A

You can draw invisible lines with the Stroke tool. These lines can be used to delimit or close off colour areas 
when you colour drawing with the Paint tool.

How to draw invisible lines with the Stroke tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. Make sure strokes are visible in your drawing space by doing one of the following:

 l In the top menu, select View >  Show > Show Strokes

 l Press K. 

 3. Select the Stroke tool by doing one of the following:

 l In the Tools toolbar, double-click on Paint. In its drop-down menu, select the  Stroke tool

 l Press Alt + V.

 4. In the Camera or Drawing view, start drawing.

TIPS 

 l If you press and hold the Shift key before or while you are drawing, your stroke will 
be a straight line until you stop drawing or release the Shift key.

 l If you press and hold the Shift and the Alt keys before drawing, your stroke will be a 
straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, 
your stroke will be a closed shape.

 l If you press and hold Alt before drawing a stroke, and you start your stroke near 
another stroke, the start of your stroke will connect to the other stroke. Likewise, if 
you press and hold the Alt key and end your stroke near another stroke, the end of 
the stroke will connect to that stroke.
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NOTE 

If the Show Strokes option is not enabled, the following message will appear after you 
draw a stroke. To remedy this, refer to step 2. 

Authors

Marie-Eve Chartrand
        Christopher Diaz

chrisdiazart.com
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About the Eraser Tool
T-HFND-004-010

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it. 

Just like the Brush tool, the Eraser tool is pressure-sensitive, allowing you to erase with more precision if you 
are using a pen tablet.

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when 
drawing and designing. Harmony provides you with a variety of default eraser styles and allows you to create 
and save your own eraser presets. 

Just like the Brush tool, you can use the Eraser tool on both vector and bitmap layers, and you can configure an 
eraser to have a solid or textured tip, to have automatic smoothing, a dual tip and a paper texture.

NOTE 

To learn more about each individual parameter of the Eraser tool, see the Reference Guide.
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Erasing 

T-HFND-004-010A

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it.

How to erase with the Eraser tool

 1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Presets list of the Tool Properties view, select a brush preset to use. 

NOTE 

To learn how to create an Eraser preset, see Creating a Solid  Eraser on page 461 and 
Creating a Textured Eraser on page 465.

 4. Set the Maximum Size to the desired Eraser size. 

NOTE 

If you are drawing with a mouse, your strokes will always be at their maximum size. If 
you are using a pressure-sensitive tablet, your strokes will vary in size depending on 
the pressure of your pen, ranging between 25% to 100% of the maximum size. 

 5. In the Camera or Drawinga view, start erasing.

TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.
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Creating a Solid  Eraser

When using the Eraser tool on a vector layer, you can use either solid vector erasers or textured vector erasers. 
By default, your eraser will be a solid vector eraser. A solid vector eraser cuts out the shape of its stroke from 
your vector artwork.

A solid vector eraser's tip can be shaped like a circle, a diamond or a square, and can be configured to have a 
specific size, aspect ratio and angle. Also, solid vector erasers can be automatically smoothed by Harmony as 
you draw.

If you are erasing on a bitmap layer, you can only use textured erasers, although you can configured a textured 
eraser to appear solid.

How to create                                      a solid vector eraser                 

 1. In the Tools toolbar, select the Eraser tool or press  Alt + B. 

 2. In the Tool Properties view,  click the arrow button to open the Eraser Properties view.

The Eraser Properties dialog opens.
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 3. In the Eraser Type dropdown list, select Solid Vector.

 4. In the brush tip list, select either Circle, Diamond or Square. 

 5. Use the Maximum Size slider to set the maximum size of your eraser tip, in pixels. 

NOTE 

When drawing with a mouse, your eraser is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your eraser's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the percentage 
of your eraser tip's maximum size your eraser should be when you use your pen with very little 
pressure. If you don't want the pressure on your pen to affect the eraser size, set this parameter to 
100%.
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 7. If you want your eraser tip to have uneven dimensions, use the Roundness slider to shrink the 
eraser tip vertically all the while preserving its horizontal size.

 8. If you want your eraser tip to be at an angle, use the Angle slider to rotate your brush tip.

 9. If you want your eraser tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 10. If you want your eraser ip to rotate when you rotate your pen, check the Use Pen Rotation check 
box. 

NOTE 

This option only works if your tablet and your pen support pen rotation. 

 11. Click on the Smoothing tab.

 12. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  stroke's direction, curves and corners. A higher setting will prevent your line from being shaky, 
but is liable to reduce your drawing precision and to round sharp corners into curves.

463



 13. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 14. Either close or set aside the Eraser Properties dialog.

 15. In the Camera or Drawing view, start erasing to test your eraser settings.
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Creating a Textured Eraser

A textured eraser can have the same settings as a textured brush: It can have a bitmap tip of any shape, can be 
hard or soft, semi-transparent, combine two tips and be applied with a paper texture effect.

When working on a bitmap layer, the eraser tool is always textured, whereas when working on vector layers, 
erasers are solid vector by default. A solid vector eraser merely cuts out the shape of the eraser stroke from the 
vector artwork, whereas a textured vector eraser makes the artwork's bitmap texture more opaque or fully 
invisible, depending on its intensity, then cuts out some of the vector artwork that the eraser made fully 
invisible. 

A textured eraser works like a reverse textured brush: It makes the pixels in a brush stroke's texture more—or 
completely—transparent, depending on the eraser's intensity. This effect can only be obtained by using a 
textured eraser on a textured brush stroke. If you use a textured eraser on solid vector shapes or on pencil lines, 
the eraser will act like a solid vector eraser, that is, it will merely cut out the shape of the stroke from the 
artwork. This is because solid vector shapes and pencil lines don't have a bitmap texture, and therefore the 
textured eraser cannot work on the opacity of their individual pixels. Hence, when working on vector layers, it 
is better to use a textured eraser only if all your artwork is composed of textured brush strokes, or it might 
wield strange-looking results. 

This outlines one of the advantages of working with bitmap layers. On bitmap layers, your brushes and erasers 
always work as textured brushes and erasers. 

Another issue you might encounter when erasing textured vector artwork is that textured vector brush strokes 
are not flattened together, whereas on bitmap layers, your artwork is always flattened. This implies that if you 
use a semi-transparent eraser on textured vector artwork, and the artwork has overlapping strokes, all the 
strokes you erase will become semi-transparent, the resulting image will be a composite of the overlapping 
strokes. On a bitmap layer, this would simply result in a single layer of semi-transparent artwork.
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There are two different types of textured vector erasers: Textured and Textured, Preserve Vector. A simple 
textured eraser will do two things: First, it will make textured brush strokes more or completely transparent 
where you erased, and second, it will cut out from the brush stroke's vector shape where it made its texture 
completely transparent. In contrast, a Textured, Preserve Vector-type eraser will only make the texture brush 
strokes more or fully transparent, but will leave its vector shape intact. 

Creating a textured eraser works exactly like creating a textured brush. Therefore, you can follow the steps in 
the Creating a Textured Brush section to learn how to create a textured eraser.
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About Eraser Presets

Once you have found the correct settings for your eraser, you might want to reuse it throughout your project for 
consistency. You can do that by creating and using eraser presets.

Harmony comes preloaded with a few eraser presets which you can select from the Tool Properties view. It is 
also possible to create your own eraser presets by configuring your eraser then saving it as a preset. 

Like eraser tips and paper textures, eraser presets are saved in your preferences. You can also export your 
eraser presets into an .xml file, and import them on a different workstation, allowing you to share your eraser 
presets between the different people collaborating on your project.

NOTES 

 l Eraser presets are not to be confused with eraser tips and paper textures. Eraser tips and paper 
textures are one of the many properties of an eraser, whereas an eraser preset contains all the 
properties of a brush.

 l Eraser presets for vector layers and for bitmap layers are separate. An eraser preset created 
while working on a vector layer cannot be used when working on a bitmap layer, and vice 
versa. 
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Creating an Eraser Preset

You can create your own custom eraser preset by configuring your eraser, then adding it as a preset.

How to create an eraser preset

 1. Make sure the current drawing layer is vector if you wish to create a vector eraser preset, or bitmap 
if you wish to create a bitmap eraser preset—see About Vector and Bitmap Layers .

 2. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 3. Click on the Arrow button to open the Eraser Properties dialog.

 4. In the Eraser Properties dialog, configure your eraser—see Creating a Solid  Eraser  and Creating a 
Textured Eraser.

 5. Do one of the following:

 l From the Eraser Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 6. In the New Preset window, type a name for your new eraser preset.

Your new eraser preset is added to the end of the list of eraser presets.
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Selecting an Eraser Preset

Harmony provides you with default eraser presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid  Brush 
or Creating a Textured Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming an Eraser Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select the eraser preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Eraser Presets

You can export eraser presets into an .xml file which will contain all of your eraser's settings. This can be 
useful if you wish to back up or share your eraser presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export 
presets for specific tools, uncheck Select/Deselect All and select the tools for which you want to 
export the presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Eraser Presets

You can import eraser presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish 
to import presets for specific tools, uncheck Select/Deselect All and select the tools for which you 
want to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of 
their tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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Erasing Synced Drawings

Normally in the Camera view, the only drawings and lines that can be erased are those on the selected layer. 
The Apply to Synced Drawing Layers  option allows for the inclusion of drawings on layers synced to the 
selected drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to erase synced drawings

 1. In the Tools toolbar, select the Erase  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other 
layers that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the  Apply to Synced Drawing Layers option.

 4. In the Camera view, start to erase. 

Notice that only the selected drawing and its corresponding synced drawings have been erased.
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About the Select Tool
T-HFND-004-005

The Select tool allows you to select drawing strokes and drawing objects. When selected, you  can use the 
Select tool to scale, translate, rotate, resize, flip and delete them.

NOTES 

 l The Select tool can only be used to select, reposition and transform whole drawing strokes. If 
you need to cut out part of your artwork to reposition or transform it, you must use the Cutter 
tool—see About the Cutter Tool.

 l To learn more about the Select tool options, see the Reference Guide .
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Selecting, Repositioning and Transforming Artwork

T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups, then reposition, rotate, scale and skew them.
 

NOTE 

The select tool can only select whole drawing strokes. If you need to cut out part of your artwork, 
use the Cutter tool instead—see About the Cutter Tool on page 497.

How to select artwork

 1. In the Timeline view, select the cell on which you want to select drawing objects.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera or Drawing view, select the artwork you want to edit by doing one of the following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 
also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 
+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 
select artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  
(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 
from the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).
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 4. Do one of the following to edit your selection:

 l To reposition the selected artwork, click on it and drag where you want to position it.

NOTE 

You can also nudge your selection using the arrow keys, and fast-nudge your 
selection by holding Shift and pressing the arrow keys.

 l To rotate the selected artwork, click and grab just outside one of the handles at the corners 
of the control box and rotate it.

 l To scale the selected artwork, click and drag on one of the control points at the corners or 
the middle of the edges of the control box. 
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TIP 

While scaling artwork, you can preserve its proportions by pressing and holding 
the Shift key.

 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.

 l To delete, press Del (Windows/Linux) or Backspace (macOS).
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Selecting Artwork in Several Drawings

You can use the Select tool to select and manipulate artwork in several drawings in the same layer at the same 
time. There are two approaches to doing this, both of which are options available in the Tool Properties view:

 l  Apply to All Frames: When you draw a lasso or marquee in the Camera or Drawing views, it will 
select strokes in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: When you draw a lasso or marquee in the Camera or Drawing views, it 
will select strokes in that area in all of the drawings currently displayed in the Onion Skin. This method 
allows you to select and manipulate artwork in a specific range of drawings, and allows you to see the 
artwork you selected in the Camera or Drawing view. 

How to select artwork in a specific range of drawings

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to edit.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to edit:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Select tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 
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NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select. 

Strokes in the current drawing and in the drawings displayed in the Onion Skin that fit inside the 
lasso or marquee you drew will be selected.

How to select artwork in all exposed drawings in a layer

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to edit. 

 2. In the Tools toolbar, select the  Select tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select.

Strokes in the current drawing as well as in all other drawings exposed in the current layer that fit 
inside the lasso or marquee you drew will be selected.
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Selecting Artwork in Several Layers

You can use the Select tool to select artwork in several layers simultaneously. There are three ways to do this:

 l By selection: If you select several layers in the Timeline, Node or Xsheet view, you will be able to select 
and manipulate artwork in all of the selected layers.

 l  Apply to All Visible Layers mode: By enabling this mode, you will be able to select artwork in all of 
the layers that are visible in the Camera view simultaneously. 

 l  Apply to Synced Drawing Layers mode: By enabling this mode, you will be able to select artwork in 
the current layer as well as in any layer that is synced to that layer simultaneously.

NOTE 

You can only select artwork in several layers simultaneously in the Camera view. 

How to select artwork in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Select tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers or  Apply to Synced 
Drawing Layers button is toggled off. 

 4. In the Timeline, Node or Xsheet view, select all the layers you want to edit simultaneously. 

TIPS 

 l To select multiple layers or nodes, press and hold the Ctrl (Windows/Linux) or ⌘  
(macOS) key, then click on each layer or node you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by 
clicking on the first layer you want to select, then, while holding Shift, clicking on 
the last layer you want to select. Every layer in-between will also be selected. 

NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 
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At this point, you can select artwork in all of the selected layers. 

 5. In the Camera view, do one of the following:

 l Draw a lasso or marquee around all the drawing strokes that you want to select. 

 l While holding Shift, click on each drawing stroke that you want to select.

How to select artwork in all visible layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Select tool.

 3. In the Tool Properties view, click on the  Apply to All Visible Layers button to toggle it on. 

NOTES 

 l If this button is currently set to  Apply to Synced Drawing Layers mode, click and 
hold on the button to open its pop-up menu and select  Apply to All Visible 
Layers.

 l If  Light Table is enabled, all the visible layers will appear fully opaque. This 
indicates that the currently selected tool can work on all visible layers 
simultaneously. 

TIP 

You can also select artwork from all visible layers by holding the Ctrl (Windows/Linux) 
or ⌘  (macOS) key while using the Select tool. 

 4. In the Camera view, do one of the following:

 l Draw a lasso or marquee around all the drawing strokes that you want to select. 

 l While holding Shift, click on each drawing stroke that you want to select.

How to select artwork in a layer and all of its synced layers simultaneously

 1. In the Timeline view, select a drawing in one of the synced layers that you want to edit. 
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NOTE 

When you select a synced layer, that layer and the other layers that are synced with it 
display a  Link icon. 

 2. In the Tools toolbar, select the  Select tool.

 3. In the Tool Properties view, click and hold on the  Apply to All Visible Layers button to open its 
pop-up menu, then select  Apply to Synced Drawing Layers.

NOTES 

 l If this button is already set to  Apply to Synced Drawing Layers mode, simply 
click on it to toggle it on. 

 l If  Light Table is enabled, the currently selected layer and all of its synced layers 
will appear fully opaque. This indicates that the currently selected tool can work on 
all of these layers simultaneously. 

At this point, you can select artwork in the selected layer and all of its synced layers. 

 4. In the Camera view, do one of the following:

 l Draw a lasso or marquee around all the drawing strokes that you want to select. 

 l While holding Shift, click on each drawing stroke that you want to select.
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Inverting a Selection

You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or Shift + 
⌘  + I (macOS).

You can also find the Invert Selection option in the Camera or Drawing View menu by selecting Edit 
> Invert Selection.
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Repositioning the Selection Pivot

You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Camera or Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain 
there until you make a new selection.
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Arranging and Reordering Drawing Strokes

The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing 
or Camera view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the following: 

 l From the top menu, select Drawing > Arrange > Bring to Front—Moves the selected 
art to the front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘  + Shift + 
PgUp (macOS). 

 l From the top menu, select Drawing > Arrange > Bring Forward—Moves the selected 
art one level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘  + 
PgUp (macOS).

 l From the top menu, select Drawing > Arrange > Send Backward—Moves the selected 
art one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘  + PgDown 
(macOS).

 l From the top menu, select Drawing > Arrange > Send to Back—Moves the selected 
art behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux) 
or ⌘  + Shift + PgDown (macOS).

 4. In the Drawing View and Camera View toolbars, you can also add the following buttons—see 
Customizing Toolbars on page 115.

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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Grouping Drawing Strokes

Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the 
selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. 
Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Group.

 l From the Camera or Drawing view menu,  select Edit > Group > Group.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (macOS). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Ungroup.

 l From the Camera or Drawing view menu,  select Edit > Group > Ungroup.

 l Press Ctrl + Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS). 
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Selecting Artwork by Colour or Texture

You can select all the shapes in your artwork that are painted with a specific colour or texture. You can also 
select all the pencil lines that use a specific pencil texture.

How to select all the artwork painted with the same colour as your selection

 1. In the Tools toolbar, select the  Select tool.

 2. In the Tools toolbar or Tool Properties view, toggle on  Select by Colour.

 3. In the Camera or Drawing view, click on a shape filled with the colour you want to select. 

All the shapes in the drawing that are painted with the same colour as the shape you clicked on 
will be selected.

How to select all the artwork filled with a specific colour or texture

 1. In the Colour view, click  Show Colour Palettes.

 2. In the upper list, select the palette containing the colour or texture you want to select

 3. In the lower list, select the colour or texture you want to select. 

 4. In the top-left corner of the Camera or Drawing view, open the  view menu and select Edit > 
Select Strokes with Current Colour. 

How to select all the pencil lines using a specific pencil texture

 1. In the Colour view, select  Show Pencil Texture Palettes.

 2. In the upper list, select the palette containing the pencil texture you want to select.

 3. In the lower list, select the pencil texture you want to select.

 4. In the top-left corner of the Camera or Drawing view, open the  view menu and select Edit > 
Select Strokes with Current Pencil Texture. 
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About the Repositioning All Drawings Tool
T-ANIMPA-010-008

The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every 
drawing included in a layer. 

If your hand-drawn animation requires to be repositioned in the grid, as soon as your select the Reposition All 
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the 
controls the same was as the Select tool—see About the Select Tool on page 477. 

You can use the Drawing Desk feature to select specific drawings and avoid repositioning all the drawings—
see About the Drawing Desk on page 853. 

NOTE 

To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning All Drawings in a Layer

T-ANIMPA-010-009

Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the 
current layer. 

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects 
every stroke in your drawing in the Drawing and Camera view.

 2. Do any of the following:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.

 l To scale, pull or push on the top, side, bottom or corner control points. Hold down 
Shift to maintain the selection’s ratio.
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 l To skew, drag the sides or top and bottom segments, between the control points.

 3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated 
or skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the 
Tool Properties view.
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Repositioning All Drawings in Synced Layers

Normally in the Camera view, the only drawings that can be repositioned are those from the selected layer. 
The Apply to Synced Drawing Layers  option allows for the inclusion of drawings on layers synced to the 
selected drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to reposition all synced drawings

 1. In the Tools toolbar, select the Reposition All Drawings  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other 
layers that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the  Apply to Synced Drawing Layers  option—see the 
Reference guide .

 4. In the Camera view, click and drag the drawings highlighted by a bounding box to a new location. 

Notice that only drawings from the selected layer and its corresponding synced drawings have 
been selected.
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 5. Delete, move, scale, skew or rotate the cut selection.

496

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

About the Cutter Tool
T-HFND-004-007

The Cutter tool lets you cut out part of a drawing so that you can transform it, copy it or delete it.  You can use it 
to scale or reposition the portion of a flattened or bitmap drawing. You can also use it to trim strokes using a 
single gesture.

NOTE 

To learn more about the Cutter tool options, see the Reference guide .
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Cutting Artwork 

T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

You can also use the Cutter tool to trim the ends of overshot lines. Line ends can be trimmed up to the point 
where they intersect with another line. This technique can be used to clean sketches much faster. Enable the 
Single Line Cutting Gesture mode for precision or the Multiple Line Cutting Gesture mode for speed.

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Camera or Drawing view, draw a lasso around the artwork you want to cut away.

The artwork inside the lasso you drew will be cut from the rest of the artwork and will be selected. 

TIPS 

 l You can add another part of your artwork to the selection by holding Shift and 
drawing another lasso. 

 l By default, the Cutter tool will only work on the current layer. You can cut artwork 
from all visible layers by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key.

 3. Once you've cut out artwork, you can manipulate it like with the Select tool. For example:

 l To move the selected artwork, click and drag it.

 l To delete the selected area, press Del.

 l To scale, rotate or skew the selection, use the controls around the selection's bounding box.
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How to trim a single line

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Tool Properties view, under the Cutter Tool Options, select the Lasso .

The Line Cutter Gesture modes are enabled.

 3. Select the Single Line Cutting Gesture Mode .

 4. In the Stage or Camera view, sweep the Cutter tool across the end of a line you wish to trim.

The line end disappears.

Before

After
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NOTE 

Even if your mouse gesture touches other lines, only the first line that the Cutter tool makes 
contact with disappears.

How to trim multiple lines

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Tool Properties view, under the Cutter Tool Options, select the Lasso .

The Line Cutter Gesture modes are enabled.

 3. In the Tool Properties view, select the Multiple Lines Cutting Gesture Mode .

 4. In the Stage or Camera view, sweep the Cutter tool across the end of a lines you wish to trim.

The line ends disappear.

Before
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After
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Cutting Artwork in Several Drawings

You can use the Cutter tool to cut out and manipulate artwork in several drawings in the same layer at the 
same time. There are two approaches to doing this, both of which are options available in the Tool Properties 
view:

 l  Apply to All Frames: When you draw a lasso or marquee in the Camera or Drawing views, it will cut 
out artwork in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: When you draw a lasso or marquee in the Camera or Drawing views, it 
will cut out artwork in that area in all of the drawings currently displayed in the Onion Skin. This 
method allows you to cut out and manipulate artwork in a specific range of drawings, and allows you to 
see the artwork you cut out in the Camera or Drawing view. 

How to select artwork in a specific range of drawings

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to edit.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to edit:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Cutter tool. 
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 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select. 

The artwork in the current drawing and in the drawings displayed in the Onion Skin will be cut out 
by the lasso or marquee you drew and will become selected. 

How to select artwork in all exposed drawings in a layer

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select.

The artwork in all the drawings in the current layer will be cut out by the lasso or marquee you 
drew and will become selected.
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Cutting Artwork in Multiple Layers

You can use the Cutter tool to cut out artwork in several layers simultaneously. There are three ways to do this:

 l By selection: If you select several layers in the Timeline, Node or Xsheet view, you will be able to cut out 
and manipulate artwork in all of the selected layers.

 l  Apply to All Visible Layers mode: By enabling this mode, you will be able to cut out artwork in all of 
the layers that are visible in the Camera view simultaneously. 

 l  Apply to Synced Drawing Layers mode: By enabling this mode, you will be able to cut out artwork 
in the current layer as well as in any layer that is synced to that layer simultaneously.

NOTE 

You can only cut artwork in several layers simultaneously in the Camera view. 

How to cut out artwork in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers or  Apply to Synced 
Drawing Layers button is toggled off. 

 4. In the Timeline, Node or Xsheet view, select all the layers you want to edit simultaneously. 

TIPS 

 l To select multiple layers or nodes, press and hold the Ctrl (Windows/Linux) or ⌘  
(macOS) key, then click on each layer or node you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by 
clicking on the first layer you want to select, then, while holding Shift, clicking on 
the last layer you want to select. Every layer in-between will also be selected. 

NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 
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At this point, you can cut artwork in all of the selected layers. 

 5. In the Camera view, draw a lasso or marquee around the artwork that you want to cut out. Note 
that only artwork in the selected layers will be cut out and selected.

How to select artwork in all visible layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool.

 3. In the Tool Properties view, click on the  Apply to All Visible Layers button to toggle it on. 

NOTES 

 l If this button is currently set to  Apply to Synced Drawing Layers mode, click and 
hold on the button to open its pop-up menu and select  Apply to All Visible 
Layers.

 l If  Light Table is enabled, all the visible layers will appear fully opaque. This 
indicates that the currently selected tool can work on all visible layers 
simultaneously. 

TIP 

You can also cut artwork from all visible layers by holding the Ctrl (Windows/Linux) or 
⌘  (macOS) key while using the Cutter tool. 

 4. In the Camera view, draw a lasso or marquee around the artwork that you want to cut out.

How to select artwork in a layer and all of its synced layers simultaneously

 1. In the Timeline view, select a drawing in one of the synced layers that you want to edit. 
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NOTE 

When you select a synced layer, that layer and the other layers that are synced with it 
display a  Link icon. 

 2. In the Tools toolbar, select the  Cutter tool.

 3. In the Tool Properties view, click and hold on the  Apply to All Visible Layers button to open its 
pop-up menu, then select  Apply to Synced Drawing Layers.

NOTES 

 l If this button is already set to  Apply to Synced Drawing Layers mode, simply 
click on it to toggle it on. 

 l If  Light Table is enabled, the currently selected layer and all of its synced layers 
will appear fully opaque. This indicates that the currently selected tool can work on 
all of these layers simultaneously. 

At this point, you can cut artwork in the selected layer and all of its synced layers. 

 4. In the Camera view, draw a lasso or marquee around the artwork that you want to cut out. Note 
that only the artwork in the synced layers will be cut out and selected.
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About the Contour Editor Tool
T-HFND-004-008

The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings. 

Artwork in Harmony is made of vector shapes. Vector shapes are defined by points, the lines joining the points 
together (contours) and the curve vectors, represented by Bezier handles, which make the curve of said lines.

The Contour Editor tool allows you to select a contour or point, and change the position of points, add and 
remove points from the shape, rotate, lengthen and shorten curve handles to influence the curve of contours 
between those points, or drag contours between points to change their curve directly. 

Since pencil lines are defined by a single line with a line width, you can use the Contour Editor to easily modify 
the shape of pencil lines. In contrast, brush strokes are full vector shapes, so the Contour Editor can be used to 
modify their shape. 

The Contour Editor can be used to tweak vector artwork in all sorts of ways. It can be used to perfect a pencil 
line, correct shapes, or create complex shapes out of a basic ellipse or rectangle.

NOTE 

To learn more about the Contour Editor tool options, see the Reference Guide.

508

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Reshaping a Shape, Pencil Line or Stroke with the Contour Editor 
Tool

T-HFND-004-008A

You can use the Contour Editor tool to tweak the contours of vector shapes and brush strokes in your drawings, 
as well as reshape pencil lines and strokes. 

How to reshape drawings

 1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

 2. In the Drawing or Camera view, click the shape, contour or pencil line you want to edit near the 
area you wish to change.

The shape or line's control points appear.

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 

TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 
while clicking on points to add them to your selection. You can use the Contour Editor to 
scale and rotate a selection of multiple points by enabling the  Show Contour Editor 
Control  option in the Tool Properties view.
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 4. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.
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 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.

 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 
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 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.

 l To remove a control point, select the control point and press Del (Windows/Linux) or 
Backspace (macOS).
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About the Centerline Editor
T-HFND-004-009B

The Centerline Editor allows you to tweak and reshape a brush stroke by manipulating its centre line rather 
than its contour (you can manipulate its contour using the Contour Editor tool). This gives a flexibility similar to 
manipulating a pencil line  with the Contour Editor tool.

Keep in mind that brush strokes are vector shapes with a fill. As such, the Centerline Editor must do guess 
work to figure out the centreline of your brush strokes, and apply deformations on its shape as you tweak its 
control points. The Centerline Editor will not be able to make a accurate centreline out of brush strokes that 
merge together, that look scrambled or that otherwise do not have a clear direction.    
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NOTE 

If you use the Centerline Editor on a textured brush stroke, it will deform the texture to make it fit 
the new shape of the stroke.

NOTE 

If you use the Centerline Editor to deform a closed brush stroke with a fill inside it, the fill will not 
be reshaped to fit the new shape of the brush stroke.

NOTE 

To learn more about the Centerline Editor tool options, see the Reference Guide.
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Reshaping Brush Strokes Using the Centerline Editor

T-HFND-004-009C

You can use the Centerline Editor tool to reshape brush strokes from their centreline rather than their contour, 
like you would reshape pencil lines using the Contour Editor.

How to reshape brush strokes

 1. In the Tools toolbar, double-click on the Contour Editor  button and select the Centerline Editor 
 tool, or press Alt + W.

 2. In the  Drawing or Camera view, click the contour or pencil line you want to edit near the area you 
wish to change.

The Centerline Editor creates a centreline manipulator based on the outline's shape, with control 
points. 

 3. In the Tool Properties view, use the Centerline Smoothness slider to adjust the amount of control 
points on the centreline as needed:

 l If you find that the generated centreline has too many control points to be easily 
manipulated, reduce the Centerline Smoothness parameter.

 l If you need more control points to make precise manipulations, increase the Centerline 
Smoothness parameter.

 4. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 
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TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 
while clicking on points to add them to your selection. You can use the Contour Editor to 
scale and rotate a selection of multiple points by enabling the Show Centerline Editor 
Control  option in the Tool Properties view.

 5. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.
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 l To deform the contour, drag a part of the contour between two points.

 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.
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 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 

 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.

 l To delete the control point, select it and press Del. 
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About the Pencil Editor Tool
T-HFND-004-009

A pencil line is a central vector shape. Control    points are located along the central spine allowing you to adjust 
the    stroke curve and position. Using the Pencil Editor tool, you can adjust the thick and thin areas of pencil 
lines. Using the Contour Editor tool, you can reposition the spine of the stroke.

NOTE 

To learn more about the Pencil Editor tool options, see the Reference guide .
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Tweaking the Thickness of Pencil Lines with the Pencil Editor Tool 

T-HFND-004-009A

You can use the Pencil Editor tool to reshape the pencil line thickness.

How to reshape pencil lines

 1. In the Tools toolbar, select the Pencil Editor  tool.

 2. In the Camera or Drawing view, select a pencil line and click to reshape it.

 3. Select one or several points by clicking them or circling around.

 4. Press Del to delete a selected point.

 5. Press Ctrl (Windows/Linux) or ⌘  (macOS) and click the central spine to add a set of points to adjust 
the contour.

 6. To modify the shape, you can:

 l Move the selected points to a new area. If you select matching points on each side of 
the line, holding the Shift key will move them both.  This way you can thicken or thin a 

520

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

line from both sides at the same time.

 l Pull on the Bezier handle to move both points’ handles as one.

 l Hold down Alt and pull on one of the Bezier handles. It moves the handle 
independently from the other one.

 l Pull directly on the line between two points. No selection is necessary. Holding down 
the Shift key will limit the contour modification to the curve between the two first 
points.
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 l If an anchor point has no visible Bezier handle, hold down Alt to display them.
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Editing a Pencil Line Texture with the Pencil Editor Tool

When working with textured pencil lines, the Pencil Editor will deform the textures starting from the centre 
lines. 

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

 l In the Tools toolbar, select the Pencil Editor  tool. 

 l From the top menu, select Drawing > Drawing Tools > Pencil Editor.

 2. Click on the pencil line to be modified to bring up its contour envelope.

 3. Select one of the contour points around the envelope and move its position to change the size of the 
tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play with 
the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled 
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to 
look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the 
number of tiles, while expanding it will increase the number of tiled images. 
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About the Smooth Editor Tool 
T-ANIMPA-010-010

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw 
may look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of 
your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the 
lines, the Smooth Editor  tool. 

NOTE 

To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Artwork Using the Smooth Editor

T-ANIMPA-010-011

You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select Drawing > Tools > Smooth Editor.

 2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass 
over the same line several times to remove more points and make the line smoother. Note that by 
default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—
see the Reference guide  to learn about the various settings available.

TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of 
which drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust 
its thickness. 
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About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and 
edge anchor points to warp the shape.

NOTE 

If you use the Perspective tool on a textured brush stroke, it is will deform its texture to fit the new 
shape of the brush stroke. Keep in mind that this will resample the texture, which is liable to make 
it lose quality. 

NOTES 

To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool

Use the Perspective tool to distort a drawing's bounding box and simulate a perspective effect. 

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or 
press Alt + 0.

 2. In the Camera or Drawing view, select the artwork you want to deform by doing one of the 
following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 
also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 
+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 
select artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  
(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 
from the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You 
can warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE 

If you use the Envelope tool on a textured brush stroke, it is will deform its texture to fit the new 
shape of the brush stroke. Keep in mind that this will resample the texture, which is liable to make 
it lose quality. 

NOTE 

You can also apply an animatable Envelope-like deformation on drawings or other elements in 
your scene using the Mesh Warp node. For more information on the Mesh Warp Node, see the 
Reference Guide.

NOTE 

To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool

You can warp your drawings using the Envelope tool. 

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 2. In the Timeline view, select a drawing to deform.

 3. In the Camera or Drawing view, select the artwork you want to deform by doing one of the 
following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l Press SHIFT+ALT to unselect all the strokes you have selected previously. You can 
also unselect strokes on multiple layers in the Timeline by pressing SHIFT+ALT 
+CTRL.

 l By default, you can only select artwork in the currently selected layer. You can 
select artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  
(macOS) key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All 
from the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).

A rectangle appears around the selected artwork. Bezier handles stem from each corner of the 
rectangle, which can be manipulated to make the sides of the rectangle into curves.
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 4. Click and drag the different anchor points and handles to deform the image.
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TIPS 

 l In the Tool Properties view, you can enable the  Show Advanced Controls  option to 
control the warp points inside the control box.

 l You can also divide the control box into several sections by increasing the value in the 
Width and Height fields of the Tool Properties view. 
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About the Text Tool
With the Text tool, you can add text in your project using various fonts and texts attributes. 

Text objects are drawing objects in the same was as brush strokes and drawing groups are, so they can be 
manipulated with the select tool. After you have written and formatted your text, you can break the string 
apart to convert the letters into drawing objects that can than be individually modified with tools such as 
Select, Perspective, Contour Editor, Smooth Editor. 

NOTE 

To learn more about the Text tool options, see the Reference guide .
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Adding Text to Drawings

You can use the Text tool to add text to your drawings. 

How to add text to drawings 

 1. Do one of the following: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Drawing > Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing or Camera view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you will 
type—see the Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always 
return to edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box with the Text   tool and moving the anchor 
point right or left. Using the Select tool will distort and scale your text itself rather than changing 
the width and height of your text box.
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Breaking Text Into Letters or Vector Shapes

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break 
ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that 
you can edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use 
the Select tool to select the letters to convert.

 5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into 
a regular drawing object, with no more text attributes.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break Apart 
Text Layers to break the selection into a regular drawing object, with no more text 
attributes.
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About Tool Presets
T-ANIMPA-002-008

Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often. 
That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable 
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, 
Pencil, Eraser, Rectangle, Ellipse, and Line. 

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the 
option of saving the colour and assigning a shortcut, which you cannot do with brush presets.

The Tool Presets toolbar lets you create new tool presets and manage them. 
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Displaying the Tool Preset Toolbar

Use the Tool Preset toolbar to create, manage and select your custom tool presets. You can display the toolbar 
in the Drawing and Camera views as well as the top area. 

How to display the Tool Presets toolbar

 1. Do one of the following:

 l From the top menu, select Windows > Toolbars > Tool Presets.

 l Right-click an empty area below the top menu and select Tool Presets.
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Creating Tool Presets

T-ANIMPA-002-009

You can create your custom tool presets to quickly access brushes and pencils settings and colours you use 
frequently. 

How to create a tool preset

 1. In the Tools toolbar, select a tool, for example the Brush tool.

 2. Use the Tool Properties view to customize the tool. 

 3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the 
tool. 

NOTE 

When using a tool preset in a scene that is not using the assigned colour swatch,  
a colour recovery dialog box appears prompting you to add the colour to the 
scene.

 4. In the Tool Presets toolbar, click the New Tool Preset   button.

 5. In the New Preset dialog box, in the Name field, type a name for your new preset.

 6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the 
File  button.
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 7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By 
default, the shortcuts are unassigned. To assign a keyboard shortcut, select Edit > Preferences > 
Shortcuts > Tool Presets (Windows/Linux) or Harmony Premium > Preferences > Shortcuts > 
Tool Presets (macOS).

 8. When you select an option, it will take effect when you use the tool preset. If an option is 
deselected, then using a tool preset will not override your current settings. 

 l Colour: Saves the current colour into the tool preset.

 9. Click OK.
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Selecting Tool Presets

You can select tool presets in the Tool Presets toolbar. 

How to select a tool preset

 l In the Tool Presets toolbar, click the tool preset  icon you assigned when creating the preset.  
Note that when using this preset in a new scene not using the assigned colour swatch,  a colour 
recovery dialog box appears prompting you to add the colour to the scene.
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Deleting Tool Presets

You can delete unnecessary tool presets to keep your list organized. 

How to delete a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.
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Updating Tool Presets

T-ANIMPA-002-010

You can update existing tool presets through the Manage Tool Presets dialog box. 

How to update a tool preset

 1. In the Tool Properties view, update the tool settings.

 2. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 3. In the Manage Tool Presets dialog box, select the tool preset from the list. 

 4. Update the additional parameters such as the icon, Colour, Layer and Draw Behind options.

 5. Click Update.

 6. Click OK.
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Exporting Tool Presets

You can export tool presets for backup, sharing, or installing on a different computer. 

How to export a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Export.

 3. In the Export Brush Presets window that opens, click  Export.

 4. Select a folder and click Select Folder.
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Importing Tool Presets

You can import Harmony tool presets you previously exported. 

How to import a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Import.

 3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select 
Folder.
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About the Tool Colour Swatches
T-ANIMPA-010-018

While drawing and painting, you can let Harmony retain the last colour you selected for each one of the 
following tool types:

 l Brush

 l Paint 

 l Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint,   and Pencil   tools.

You can also link or unlink the colour swatch used between vector and bitmap layers.
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Unlinking the Tool Colour Swatches 

T-ANIMPA-010-019

You can unlink the tool colour swatches and use separated colours for the Brush, Paint, and pencil line tools. 

If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link the 
three swatches together.

How to unlink the tool colour swatches

 1. In the Colour view, if the storage swatches are linked, click the Link   button to unlink them.

 2. Click on the Brush  storage swatch.

 3. In the Colour list, select the desired colour.

 4. Click the Pencil   storage swatch.

 5. In the Colour list, select a colour.

 6. Click the Paint   storage swatch.

 7. In the Colour list, select a colour.
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Linking the Tool Colour Swatches

You can link the tool colour swatches so all the tools use the same colour swatch.

How to link the storage swatches

 1. In the Tools toolbar, select one of the following tools:

 l  Brush

 l  Paint

 l  Pencil

 l  Polyline

 l  Line

 l  Ellipse

 l  Rectangle

 2. In the Colour view, if the storage swatches are unlinked, click the Link   button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Using Independent Bitmap Colour Swatches

When working in the Colour view, by default the current colour is active for both vector and bitmap layers. You 
can however, use different reference colours for each layer. 

Although you can use colours from your colour palette to paint on a bitmap layer, colours used in a bitmap 
drawing layer are not linked to their colour swatch in the palette. This means that, contrary to vector drawing, 
updating the colours in your colour palette will not update your bitmap drawings with the new colours. 

How to use independent colours

 l From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.
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About Drawing Space Management
When you are drawing in the Camera or Drawing view, you can zoom, pan and rotate the view to make it 
easier to determine where to place objects, determine the scale of objects, and when zooming out, get an 
overall view of the panel and its contents. You can also use the grid to help you determine the size and 
placement of objects as you draw. 

If you like drawing in the Camera view, but don't want overlays to cover the drawing you're working on, you 
can enable the Current Drawing on Top option.
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About the Zoom Tool
The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

NOTE 

To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Camera or Drawing view. 

 3. In the Tools Properties view, do the following:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Camera or 
Drawing view. When you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Camera or Drawing 
view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing or Camera view. When you are zoomed in your 
workspace, you may need to pan to a different area of your image. You can do so with the Hand tool or the 
Spacebar keyboard shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the following:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing or Camera view and 
drag. 

 l You can also Hold down the Spacebar, click in the Drawing or Camera view and move 
your mouse in the direction you want to pan the view.
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About the Rotate View Tool
T-LAY-001-005

The Rotate View  tool lets you rotate the Drawing or Camera view, the same way as you would do with a real 
animation disc  for increased flexibility. This tool can also be used in the Perspective view.

The Rotate View tool has no options in the Tool Properties view.

How to use the Rotate View tool

 1. Do one of the following:

 l From the top menu, select Drawing > Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool in the Hand tool menu.

 l In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (Windows/Linux) or ⌘  + Alt (macOS).

The rotation disc appears.

 2. In the Drawing or Camera view, click and drag to rotate the space. 
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 3. Release the keyboard shortcut or switch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About Mirror View
T-H16NEW-001-001

A recurring challenge for artists is to draw characters and objects with their elements properly aligned and 
with respect to their proportions and shapes. While drawing, the eye tends to get used to the imperfections in 
the shapes and proportions in your artwork, making it hard  to spot and correct them. A common trick to avoid 
this pitfall is to flip your artwork horizontally. This allows you to look at your artwork as if you were looking at it 
for the first time, making all the mistakes in shapes, positioning and proportion obvious to your eye.

Using the Mirror View command, you can temporarily flip the drawing space horizontally, whether in the 
Camera or Drawing view. This will allow you to see your artwork and your animation as if your whole stage 
was flipped, and you can even use the drawing and animation tools on the flipped artwork. Once you are done, 
you can disable Mirror View to instantly undo it and resume working with your artwork in its original 
orientation. 

NOTE 

Just like panning, rotating and zooming in or out of the Camera and Drawing views, Mirror view is 
strictly a temporary visual effect. It does not affect the rendered image nor does it have any 
permanent effect on your artwork, your layers or your scene's layout.

How to temporarily flip the Camera or Drawing view horizontally

 1. Click anywhere on the Camera or Drawing view to set the focus on the view you're drawing in.

TIP 

You can click on a view's tab to set the focus on it without clicking on anything inside it. 

 2. Do one of the following:

 l In the Camera or Drawing toolbar, click on the  Mirror View button.

 l In the top menu, open the View menu and select Mirror View. 

Everything in the Camera or Drawing view will now appear flipped horizontally. A small overlay 
with the text Mirror View appears in the top-left corner of the drawing space to help you remember 
that you are working in Mirror View. 

556

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

TIP 

You can add a button to enable and disable Mirror View to your Camera or Drawing view 
toolbar. To customize a toolbar's buttons, right-click on the toolbar and select Customize. 

How to unflip the Camera or Drawing view

 1. Click anywhere on the Camera or Drawing view to set the focus on the view you're using to draw. 

TIP 

You can click on a view's tab to set the focus on it without clicking on anything inside it. 

 2. In the top menu, open the View menu and select Mirror View. 

Everything in the Camera or Drawing view will be unflipped. The "Mirror View" overlay will 
disappear.
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Displaying the Current Drawing on Top
T-ANIMPA-010-020

In the Camera view, when you draw on a layer, the artwork is displayed in the correct order. For example, if the 
layer on which you are drawing is located behind an object on another layer, the lines you draw will be hidden 
behind that object.

You can display a selected drawing on top of everything while you draw. Then, each time you  select a drawing 
tool, the drawing is displayed in front of everything in the Camera view. The Timeline and Node view ordering 
remain unchanged. 

How to display the drawing on top

 1. Do one of the following:

 l From the top menu, select View > Show > Current Drawing on Top. 

 l In the Camera bottom toolbar, click the Current Drawing on Top button.

NOTE 

The Current Drawing on Top status is retained when you exit Harmony. When 
you restart the application, the last status will be used.

 2. In the Tools toolbar, select a drawing tool. You only need to enable this option once, it is not 
necessary to do it each time you select a drawing tool.  

 3. In the Camera view, start drawing.
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About the Grid 
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a 
given layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the 
grid boundaries as it is only a visual reference.  

In the Camera view, the Grid is visible when you select a drawing tool.
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Displaying the Grid

You can display the grid and it will be visible in the Drawing view. It will be visible in the Camera view when 
you select a drawing tool. 

Use the Show Grid option to display a grid in the Drawing or Camera views. 

How to display the grid 

 1. Do one of the following: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (Windows/Linux) or ⌘  + ' (macOS).
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Modifying the Grid

You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the following: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid.

 l View > Grid > 12 Field Grid—Displays a 12-field size grid.

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements.

 l View > Grid > Overlay—Displays the grid over the drawing elements.

 3. In the Drawing View and Camera View toolbars, you can also add the following buttons—see 
Customizing Toolbars on page 115.

 l Grid Outline Only  button 

 l Square  button 

 l 12 Field Grid  button 

 l 16 Field Grid  button 

 l Underlay  button 

 l Overlay  button
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Changing Pencil Line Opacity Display
The pencil, ellipsis, rectangle and line tools create pencil lines. Pencil lines are defined by a central vector line 
to which Harmony adds thickness. 

Pencil lines tend to obscure the actual edges of the shape they are around. Sometimes, knowing the actual 
edge of shapes surrounded by pencil lines can be useful. To work around this problem, it is possible to 
temporarily adjust the opacity of pencil lines in the Camera view.

NOTES 

 l This will only affect the way your pencil lines are displayed in the OpenGL preview of the 
Camera view. The rendered image will not be affected.

 l Outlines created with the Brush tool are not pencil lines. They are fully defined vector shapes. 
Hence, this feature will not work on brush strokes. 

How to adjust the opacity of pencil lines in the preview image

 1. In either the Drawing view or Camera view toolbar, click on the Top Light icon. The Pencil Lines 
Opacity feature can also be accessed through the Preferences panel.

The Onion Skin and Light Table Transparency dialog opens.
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 2. In the Onion Skin and Light Table Transparency dialog box, use the Pencil Lines Opacity slider to 
globally increase or decrease the opacity of central vector lines. Sliding the slider all the way to the 
right equals 100% opacity. Sliding the slider all the way to the left equals 0% opacity.

 3. Click OK.
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About OpenGL Antialiasing
T-ANIMPA-010-016

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you 
draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast real-
time display called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing 
preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias 
your drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on 
or off; by default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE 

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference

T-ANIMPA-010-017

You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE 

You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(macOS). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. 
The number of samples is basically equivalent to the amount of times a pixel will be enlarged to 
calculate the antialiasing. This technique is called supersampling. The higher the number of 
samples, the better the antialiasing quality will be, but the heavier it will be on performance.

 4. Restart Harmony.
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About Pen Stabilization
By default, when drawing with freehand drawing tools such as the brush, pencil or eraser tools, Harmony 
smoothens each drawing stroke you create right after creating it. It does this by generating the vector shape of 
your drawing stroke, then simplifying its structure of points and curves, to remove what appears to be jittering. 
However, this can cause your precisely executed strokes to lose in precision and quality.

When drawing with minutia and precision, you can use Harmony's pen stabilizer instead. The pen stabilizer 
allows you to easily draw curved lines with precision without having to apply smoothing to them after you 
have drawn them.

Harmony's pen stabilizer works by letting you draw a stroke of a certain length without generating artwork 
right away. Once your stroke reaches this length, Harmony starts generating an actual drawing stroke that 
trails behind your mouse cursor or tablet pen. It determines the direction the drawing stroke takes using one of 
the two following methods, depending on which one you select:

 l Average: Harmony calculates the average direction of all of your mouse or pen gestures between the 
end of the actual drawing stroke and the current position of your mouse cursor or pen tip, and extends 
the stroke in this average direction, effectively evening out jitter and rounding sharp turns. 

 l Pulled String: When you start drawing a stroke, Harmony positions the drawing tool where your stroke 
starts. As you move the mouse or tablet pen, the drawing tool remains in that position, but a "string" 
appears, linking your drawing tool to your mouse cursor or pen tip.

This string has a certain maximum length. Once that length is reached, the string pulls the drawing tool 
in the direction of your mouse cursor or tablet pen.

NOTE 

The distance between your mouse cursor or tablet pen and the stroke can be adjusted. For 
the purpose of demonstration, these images were done using the largest supported 
distance.

Both methods allow you to cancel out the jittering and the small mistakes in your drawing strokes as you make 
them, rather than afterwards. But the two methods feel different:
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 l The Average method takes into account all your drawing gestures. Therefore, if you jitter a lot while 
drawing, your strokes may jitter a little. It is also tricky to create sharp corners with this method. 
However, this method tends to create very consistently smooth drawing curves. Also, since it actually 
follows the gesture of your mouse or tablet pen, you might find that this method feels more natural than 
the Pulled String method. 

 l The Pulled String method gives you more precise control, and can be used to make sharp corners with 
the right technique, but may be harder to learn and to master. Your drawing tool does not follow your 
drawing strokes, it just gets pulled in the direction of your mouse cursor or tablet pen, which means the 
way your drawing gestures translate into drawing strokes is different than what you're used to. 

You may need to do some trial and error to determine which method fits your drawing style the best. You can 
also customize the distance by which your drawing stroke trails behind your mouse cursor or tablet pen. A 
shorter distance will feel more natural, but a longer distance will stabilize your drawing strokes more. 

The Pen Stabilizer works with the  Brush,  Pencil,  Stamp and  Stroke tools. Optionally, it can also 
work with the  Eraser tool.
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Using Drawing Tool Stabilization
You can enable and configure pen stabilization using the Pen Settings toolbar. You may have to do some trial 
and error to find the settings that work for you and to get used to drawing with the stabilizer.

NOTE 

For more information on the Pen Settings toolbar,refer to the Reference Guide.

How to configure drawing tool stabilization

 1. Add the Pen Settings toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Pen Settings.

 l Right-click on any existing toolbar and, in the context menu, select Pen Settings.

 2. In the drop-down to the left of the toolbar, select one of the following Pen Stabilizer modes:

 l Average: Harmony calculates the average direction of all of your mouse or pen gestures 
between the end of the actual drawing stroke and the current position of your mouse cursor 
or pen tip, and extends the stroke in this average direction, effectively evening out jitter and 
rounding sharp turns. 

 l Pulled String: When you start drawing a stroke, Harmony positions the drawing tool where 
your stroke starts. As you move the mouse or tablet pen, the drawing tool remains in that 
position, but a "string" appears, linking your drawing tool to your mouse cursor or pen tip.

This string has a certain maximum length. Once that length is reached, the string pulls the 
drawing tool in the direction of your mouse cursor or tablet pen.

 3. In the field just right of the drop-down, select the stabilizer distance you want to use. You can enter 
a number between 0 and 100. You can also click and drag on the  left-right button right of the 
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text field to adjust its value.

NOTES 

 l This sets the distance by which your drawing tool trails behind your mouse cursor or 
tablet pen. The higher the distance, the more stabilized your drawing motions will 
be, but the harder it will be to draw sharp corners and precise shapes. 

 l For casual drawing, it is recommended to try values ranging between 5 and 20 at 
first. Higher values are more useful for drawing with a lot of minutia.

 4. Click on the  Stabilizer Settings button and:

 l If you selected the Average method and you want your drawing strokes to catch up with 
your tablet pen when you hold the pen tip against your tablet without moving it, make sure 
the Catch Up option is checked. Otherwise, uncheck it.

NOTE 

Stabilization makes your drawing stroke trail behind as you move your mouse 
cursor or tablet pen tip. This option makes your stroke catch up to your tablet 
pen when you hold it against the tablet without moving. This option only works 
when drawing with a tablet pen.

 l If you selected the Pulled String method and you want  the virtual string between your 
mouse cursor or pen tip and your drawing tool to display, make sure the Show String option 
is checked. Otherwise, uncheck it. 

 l If you want to use the pen stabilizer with the Eraser tool, make sure the Eraser option is 
checked. Otherwise, uncheck it.

 5. Try to draw in the Camera or Drawing view to test how your settings work out, and make 
adjustments as needed until you have the configuration that works best for you.

 6. When you want to disable pen stabilization, open the stabilization drop-down in the Pen Settings 
toolbar and select Stabilizer Off.
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About Pen Pressure Curve Customization
When you use a pressure-sensitive tablet with the Brush, Eraser, Pencil and Stamp tools, Harmony takes the 
amount of pressure you put on your tablet pen in account as you draw. It uses this information to determine the 
thickness of your drawing stroke. For example, while using the Brush tool, the harder you press on you tablet 
pen, the bigger your brush strokes will be, and vice versa.

To determine the thickness of your drawing strokes, it uses your drawing tool's Minimum Size and Maximum 
Size parameters, which can be set in the Tool Properties view. The thickness of your drawing stroke is always 
going to vary between those two parameters, based on how much pressure you put on your tablet pen.

By default, the size of your drawing strokes is directly proportional to the amount of pressure you put on your 
pen. It is calculated using this simple formula:

This means that if you apply 25% of the pressure your tablet pen can detect, the thickness of your drawing 
strokes will be 25% of the way between your tool's minimum size and its maximum size. Likewise, if you apply 
75% of the pressure your tablet pen can detect, the thickness of your drawing stroke will be 75% of the way 
between your tool's minimum size and its maximum size. 

Harmony allows you to customize the way it processes the pressure you put on your tablet pen into the 
thickness of your drawing strokes.  You can do this by tweaking the pressure curve in the Pen Pressure Feel 
dialog.

Depending on how you hold and use your tablet pen, this may allow you to have better control over the 
thickness of your drawing strokes. For example, if you tend to put a lot of pressure on your pen, you may want 
Harmony to let you draw thinner lines unless you apply even more pressure than you usually do. Likewise, if 
you tend to put very little pressure on your pen, you may want Harmony to generate thicker lines unless you 
apply even less pressure than you usually do.
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Customizing the Pen Pressure Curve
You can make adjustments to the curve used by Harmony to process the pressure from your tablet pen via the 
Pen Pressure Feel dialog, which can be accessed from the Pen Settings toolbar.

NOTE 

For more information on the Pen Pressure Feel dialog,refer to the Reference Guide.

How to customize the curve by which tablet pen pressure is applied to the size of your 
drawing tool

 1. Add the Pen Settings toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Pen Settings.

 l Right-click on any existing toolbar and, in the context menu, select Pen Settings.

 2. In the Pen Settings toolbar, click on the  Pen Pressure Feel button.

The Pen Pressure Feel dialog appears.

 3. In the Tools toolbar, select either the  Brush or the  Pencil tool.

NOTE 

The pressure curve affects all tools that supports pressure-sensitivity, such as the  
Brush tool, the Pencil tool, the  Eraser tool and the  Stamp tool. However, you 
should use the  Brush or  Pencil tool to test out your pressure settings. 

 4. Make sure that the minimum size of your drawing tool is low enough and that its maximum size is 
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high enough that you can clearly see how the pen pressure affects the thickness of your lines.

TIP 

To do this, in the Tool Properties view, click on the  Show Extended Properties button 
to open the Brush or Pencil Properties dialog. Then, adjust the value of the Minimum 
Size and the Maximum Size sliders. 

 5. If you want to be able to lightly brush the tip of your tablet pen against your tablet without actually 
drawing, increase the value in the Min Pressure field. 

 6. If you don't want to have to press your tablet pen all the way down to draw in your drawing tool's 
maximum size, decrease the value in the Max Pressure field.

 7. To try a curve preset select one in the Curve Preset field. This will instantly change the shape of 
your pressure curve. 

 8. To adjust the shape of the curve manually:

 l Click and drag on the  leftmost   Bezier handle to change the shape of the curve from the 
leftmost point.

 l Click and drag on the  rightmost Bezier handle to change the shape of the curve from the 
rightmost point.

The following is a list of examples of how you can adjust the curve, depending on the way you use 
your tablet pen:

 l If you make an ease-in curve like the one below, the size of your drawing strokes will tend to 
be closer to the minimum size of your drawing tool, unless you apply a lot of pressure on your 
tablet pen.

 l If you make an ease-out curve like the one below, the size of your drawing strokes will tend 
to be closer to the maximum size of your drawing tool, unless you apply very little pressure 
on your tablet pen.
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 l If you make an ease-in-ease-out curve like the one below, the size of your drawing strokes 
will tend to be closer to the minimum size of your drawing tool when applying light pressure, 
and to be closer to the maximum size of your drawing tool when applying more pressure, but 
it will rarely be the median between the minimum and the maximum size.

 l If you make an ease-out-ease-in curve like the one below, the size of your drawing strokes 
will tend to be closer to median between the minimum and maximum size of your drawing 
tool, unless you apply very little or a lot of pressure on your tablet pen.

 9. Test out how your new settings feel by drawing strokes in the Camera or Drawing view, and make 
adjustments as needed until you have the configuration that works best for you.
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About Drawing Guides
T-LAY-001A-001

Drawing guides are drawing aids that you can add to your scene to help you draw backgrounds and objects 
with straight lines, square angles and graphic projection effects such as isometric projection, straight 
perspective or curvilinear perspective. In traditional art, this is often done with tools such as rulers, T-squares, 
set squares and vanishing points. Guides allow you to simulate the use of such tools in combination with the 
drawing tools in Harmony.

Harmony supports different types of drawing guides, each designed for a different kind of drawing task. Most 
of Harmony's drawing guides work by adding a horizon line and vanishing points to your drawing space. 
While using a drawing guide, dotted guide lines appear through your mouse cursor. These guide lines are 
either parallel or perpendicular to the horizon line, or are going from one of the guide's vanishing points to your 
mouse cursor. When you start drawing a stroke, your drawing tool instantly becomes locked to one of the 
guide's axes, as if you were drawing against a ruler. Optionally, you can use drawing guides as mere visual 
references, without locking your drawing tool against their axes.

Harmony supports the following types of drawing guides:

 l The Ruler allows you to position and rotate a simple axis, then draw a line along that axis, like a regular 
ruler.

 l The Square Grid helps you draw lines that are either parallel or perpendicular to a horizon line.

 l The Isometric Perspective guide helps you draw lines that are parallel to one of three axes: The x-axis, 
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the y-axis and the z-axis. The angle of each axis can be customized as needed.

This type of pseudo-perspective, also referred to as parallel projection, is often used in 2D games, 
computer graphics and schematics to depict 3D objects and environments without using any actual 
perspective, foreshortening or 3D rendering. In 2D animation, it is often used to draw long panning 
backgrounds from a low or high angle. 

 

 l The 1-Point Perspective guide helps you draw lines coming from a single vanishing point in the middle 
of the horizon. It also helps you draw lines that are either parallel or perpendicular to the horizon line. 

This is useful for drawing cuboid structures that are facing the camera. 

 l The 2-Point Perspective guide helps you draw lines coming from one of two vanishing points, which are 
placed on the horizon line outside the camera field. It also helps you draw lines that are perpendicular to 
the horizon line. 

This is useful for drawing cuboid structures from a specific horizontal angle. 
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 l The 3-Point Perspective (Bird's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed below the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from an elevated point of view.

 l The 3-Point Perspective (Worm's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed above the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from a low point of view. 
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 l The 3-Point Perspective (Horizontal Pan) guide helps you draw horizontally panoramic backgrounds, 
with curvilinear horizontal lines. A vanishing point is placed in the middle of the horizon line, to help 
draw lines on the z-axis, and two vanishing points are placed on the horizon line outside of the camera 
field, to define the curve of the horizontal lines. Vertical lines are made perpendicular to the horizon line. 

This is useful for drawing backgrounds meant to be panned over horizontally. Panning the camera 
horizontally over a background drawn with a 3-Point Perspective (Horizontal Pan) guide will simulate a 
rotation of the camera on the y-axis.

 l The 3-Point Perspective (Vertical Pan) guide helps you draw vertically panoramic backgrounds, with 
curvilinear vertical lines. A vanishing point is placed in the middle of the horizon line, to help draw lines 
on the z-axis, and two vanishing points are placed above and below the horizon line, outside of the 
camera field, to define the curve of the vertical lines. Horizontal lines are made parallel to the horizon 
line. 

This is useful for drawing background meant to be panned over vertically. Panning the camera vertically 
over a background drawn with a 3-Point Perspective (Vertical Pan) guide will simulate a vertical 
rotation of the camera on the x-axis. 
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 l The 4-Point Continuous Perspective guide is very similar to the 3 Point Perspective (Horizontal Pan) 
guide, except that it is designed to help draw full 360° panoramic backgrounds. 

This guide uses 5 vanishing points. When drawing a horizontal line, it is curved by arching over one of 
the vanishing points and reaching down to the two surrounding vanishing points. This creates a 
perspective effect where each vanishing point represents one of the cardinal points, except that the 
leftmost and the rightmost points represent the same cardinal point, effectively creating a looping 
background. Backgrounds made with the 4-Point Continuous Perspective guide can be looped 
horizontally to simulate a full rotation of the camera on the y-axis. 

 l The 4-Point Perspective (Vertical Pan) is a lot like the 2-Point Perspective guide, except that its 
vertical lines are curvilinear, so it can be used to make vertically panning backgrounds. Two vanishing 
points are on the horizon line, outside of the camera field, to help draw lines on the x-axis and the z-
axis, and two vanishing points are placed above and below the camera field to define the curve of the 
vertical lines.
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This is useful for drawing backgrounds meant to be panned over vertically, in which cuboid objects are 
seen from an angle.

 l The 5-Point Perspective (Fish Eye) guide helps you draw backgrounds that are curvilinear on both the 
x-axis and the y-axis. It has one central vanishing point on the horizon line, from which lines on the z-
axis are drawn, two vanishing points at the extremities of its horizon line, to define the curve of the 
horizontal lines, and two vanishing points above and below the horizon line, to define the curve of the 
vertical lines. 

This guide can be used to draw backgrounds with a fisheye-style wide angle lens effect. It can also be 
used to draw backgrounds that are meant to be panned in various directions.

Guides are made to work with the following tools. To avoid cluttering your drawing space, they are only visible 
when one of these tools is selected:
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 l  Brush  

 l  Pencil  

 l  Stroke 

 l  Line 

To use a guide, you must add the Guides view to your workspace. Then, you can add the guide you wish to use 
to your scene's guides list. A newly added guide will have its horizon line and vanishing points in preset 
positions. You can rotate and reposition the horizon line as well as reposition the vanishing points to fit your 
scene's needs. When using curvilinear perspective guides, you can also adjust the Beziers of the curves to make 
them narrower or wider.

The Guides view allows you to have as many guides as you want, and each one will preserve the adjustments 
you make to it. In the Guides view, you can also select which guide you wish to use, rename, delete and reorder 
guides as needed, as well as cut, copy, paste, export and import guides between different scenes. 

NOTES 

 l The guide list, its guides and their individual parameters are saved with your scene. Hence, you 
can create a configure a guide specifically for the backgrounds and objects in your scene in one 
Harmony session, then reuse them exactly as you configured them in a later Harmony session.

 l Changes made to a guide or to the guide list can be undone with the Undo command. 
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Adding  Drawing Guides
T-LAY-001A-002

The first step in using drawing guides is to add a guide to the scene's guides list.

How to add a drawing guide to                                      your scene                 

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. Add the Guide view to your workspace by doing one of the following:

 l In the top-right corner of any view in your workspace, click on the  Add View button and 
select Guides.

 l In the top menu, select Windows > Guides. 

 3. In the Guides view, click on the  New Guide  button and choose one of the following types of 
guides:

 l  Ruler

 l  Square Grid

 l  Isometric Perspective

 l  1-Point Perspective

 l  2-Point Perspective
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 l  3-Point Perspective (Bird’s-Eye View)

 l  3-Point Perspective (Worm’s-Eye View)

 l  3-Point Perspective (Horizontal Pan)

 l  3-Point Perspective (Vertical Pan)

 l  4-Point Continuous Perspective

 l  4-Point Perspective (Vertical Pan)

 l  5-Point Perspective (Fisheye)

NOTE 

For information on each kind of guide in the list, see About Drawing Guides on page 
574

The new guide appears in the guides list. 

NOTES 

 l Adding a guide automatically toggles the  Enable Guides option on, and automatically 
toggles the  Lock Guides option off, so that you can immediately view and adjust your 
new guide. 

 l Your new guide will come in a preset position with preset parameters. To make 
adjustments to your guide, see Editing Drawing Guides on page 587.
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Selecting the Active Drawing Guide
A Harmony scene can have several guides in its guides list, but you can only see, edit and use one guide at a 
time. You can decide which guide you're working with by selecting it from the guides list. The selected guide 
will display in your drawing space. 

When a guide is active, its horizon line, vanishing points and other visual elements will display in your drawing 
space. Also, dotted lines will follow your mouse cursor when you move it inside your drawing space. Each of 
these lines represents one of the axes of your drawing guide.

NOTE 

Although you can select the active guide at any time, a guide will only be visible, editable and 
usable if either the  Brush,  Pencil,  Stroke or  Line tool is selected.

How to select the active guide from the guides list

 1. In the Guides view, click on the desired guide in the guides list

The selected guide will become active in the Camera and Drawing views.
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NOTE 

If guides are disabled, clicking on a guide in the guides list will enable them.

How to quickly switch between guides using keyboard shortcuts

 1. Click on the tab for the Camera or Drawing view to set the focus on that view.

 2. Press the Up Arrow or Down Arrow key to select the previous or next guide in the list. 

NOTE 

Using the Up Arrow or Down Arrow to select a guide will only work if guides are already 
enabled.
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Renaming Drawing Guides
When adding a guide, it is automatically named after its guide type. Since you can have several guides of the 
same type in the same guides list, you might need to rename your guides to be able to easily differentiate them.

NOTE 

It is not required to give a unique name to each guide in the guides list.

How to rename a guide using the Guide Menu

 1. In the Guides view, select a guide from the list.

 2. Click on the  Menu button and select Rename Guide.

The Rename Guide dialog box appears.

 3. In the Rename Guide: field, type in a new name for the selected guide.

 4. Click on OK.

How to rename a guide using the Guide List

 1. In the Guides view, double-click on a guide displayed in the list.

The guide's name turns into a text input field.
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 2. In the text field, type in the new name for the guide.

 3. Press Enter/Return.
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Editing Drawing Guides
T-LAY-001A-005

After a guide is added, it is configured with a preset position and angle for its horizon line, a preset position for 
its vanishing points, a preset size and, if applicable, preset Bezier curves. In many cases, you have to make 
adjustments to your guide so that you can use it to draw backgrounds and objects from the right point of view.

Different guides can be customized in different ways. This sections provides steps on how to customize each 
type of guide. 

NOTES 

 l You can view a guide and make changes to it directly in the Camera or Drawing view when the 
 Brush,  Pencil,  Stroke or  Line tool is selected. 

 l When you make a change to a guide, you can undo that change with the Undo command.

 l Changes made to guides are saved to your scene.
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Adjusting a Ruler Drawing Guide

The Ruler guide is simply a ruler. It has a single axis that you can position and rotate. You can draw along this 
axis as if you were drawing against a ruler. 

NOTE 

To add a Ruler guide to your scene, see Adding  Drawing Guides.

How to adjust a Ruler guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Ruler guide that you wish to make adjustments to.

The guide appears in the Camera or Drawing view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its offset handle .

TIP 

You can press and hold the Shift key to only move the guide horizontally or 
vertically relative to the camera angle. 

 l To rotate the guide, click and drag on one of its rotation handles . It will rotate around the 
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opposite rotation handle.

TIPS 

 l You can press and hold the Shift key to make the angle of the ruler snap to 
the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around its 
centre.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a Square Grid Drawing Guide

The Square Grid guide helps you draw lines that are either parallel or perpendicular to the horizon line. You 
can customize it by repositioning and rotating its horizon line.

NOTE 

To add a Square Grid guide to your scene, see Adding  Drawing Guides.

How to adjust a Square Grid guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Square Grid guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view. 

TIP 

To see the parallel and perpendicular reference lines, click on the  Show Reference 
Lines option button in the Guides view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its offset handle .

 l To rotate the guide, click and drag on its horizon line.
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TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting an Isometric Perspective Drawing Guide

The Isometric Perspective guide helps you draw lines that are parallel to one of three axes: the x-axis, the y-
axis and the z-axis. By default, the z-axis is at 26.565° from the horizon, the x-axis is at 153.435° from the 
horizon, and the y-axis is at 90° from the horizon. 

These specific angles are commonly used in video games and computer generated graphics, as lines in these 
angles do not require antialiasing to be properly rendered in pixels. The angle of all three of these axes can be 
adjusted independently as needed. For example:

 l You can achieve "true" isometric perspective, where the angle between each axis is equal, by setting the 
angle of the x-axis to -150° and the angle of the z-axis to -30°.

 l You can achieve cabinet-type oblique projection by setting the angle of the x-axis to -180°.

 l You can achieve military-type oblique projection by setting the angle of the x-axis to -135° and the 
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angle of the z-axis to -45°.

NOTE 

To add a Isometric Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust an Isometric Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Isometric Perspective guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view.
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TIP 

To display the reference lines for the guide, click on the  Show Reference Lines 
option button on in the Guides view. 

 4. Do one of the following:

 l To reposition the guide, click and drag on the offset handle .

 l To adjust the angle of one of the axes, click and drag on the rotation handle  for that axis.

TIPS 

 l The angle of the axis you are adjusting will appear in the top-left corner of 
the Camera or Drawing view as you adjust it. 

 l You can hold the Shift key while rotating one of the axes to make it snap to 
the nearest angle that is a multiple of 5°. The x-axis and z-axis will also snap 
to 26.565° and 153.435°, which are their default angles.

 l To adjust the angle of both horizontal axes, press and hold the Alt key, then click and drag 
on the rotation handle of either the x-axis or the z-axis. 

TIP 

This will set the angle of both the x-axis and the z-axis to the same value, 
making your guide symmetrical.

 l To rotate the entire guide, press and hold the Alt key, then click and drag on the rotation 
handle of the y-axis. 

594

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Adjusting a 1-Point Perspective Drawing Guide

The 1-Point Perspective guide can help you draw backgrounds and objects with front-facing perspective. It 
provides a horizon line and a single vanishing point. The height and angle of the horizon line as well as the 
position of the vanishing point on the horizon line can be adjusted as needed. 

NOTE 

To add a 1-Point Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a 1-Point Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  1-Point Perspective guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its vanishing point .

 l To rotate the guide, click and drag on its horizon line.
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TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 2-Points Perspective Drawing Guide

The 2-Points Perspective guide can help you draw backgrounds and objects seen from the ground, but at an 
angle. It provides a horizon line and two vanishing points, which are located outside of the camera field by 
default. The height and angle of the horizon line as well as the position of both vanishing points can be 
adjusted as needed.

NOTE 

To add a 2-Points Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a 2-Points Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  2-Points Perspective guide that you wish to make adjustments to. 

The selected guide appears in the Camera or Drawing view. 

NOTE 

The vanishing points for this guide are far outside of the camera field by default. You 
may need to zoom out in order to be able to see them.
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 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   and move it up 
or down. This will rotate the horizon line around the opposite vanishing point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that 
vanishing point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.
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Adjusting a 3-Points Perspective (Bird's-Eye View) Drawing Guide

The 3-Points Perspective (Bird's-Eye View) guide can help you draw backgrounds and objects with 
perspective from an elevated point of view. It provides a horizon line, which is located just underneath the 
camera field, and on which there are two vanishing points: one for drawing lines on the x-axis and one for 
drawing lines on the z-axis. Another vanishing point, used to draw lines on the y-axis, is located far above the 
camera field. 

The height and angle of the horizon line, the position of its two vanishing points as well as the position of the 
upper vanishing point can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Bird's-Eye View) guide to your scene, see Adding  Drawing Guides.

How to adjust a 3-Points Perspective (Bird's-Eye View) guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  3-Points Perspective (Bird's-Eye View) guide that you wish to 
make adjustments to. 

The selected guide appears in the Camera or Drawing view. 
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NOTE 

The horizon line and vanishing points for this guide are far outside of the camera field 
by default. You may need to zoom out in order to be able to see them.

 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   on the horizon 
line and move it up or down. This will rotate the horizon line around the opposite vanishing 
point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that 
vanishing point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.

 l To reposition the bottom vanishing point, click and drag on that vanishing point .

TIPS 

 l You can press and hold the Alt key to position the point on the axis that is 
perpendicular to the horizon line and in the middle of its two vanishing 
points. 

 l You can press and hold the Shift key to make the point only move 
horizontally or vertically relative to the camera angle. 
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Adjusting a 3-Points Perspective (Worm's Eye View) Drawing Guide

The 3-Points Perspective (Worm's-Eye View) guide can help you draw backgrounds and objects with 
perspective from an low point of view. It provides a horizon line, which is located just below the camera field, 
and on which there are two vanishing points: one for drawing lines on the x-axis and one for drawing lines on 
the z-axis. Another vanishing point, used to draw lines on the y-axis, is located far above the camera field. 

The height and angle of the horizon line, the position of its two vanishing points as well as the position of the 
lower vanishing point can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Worm's-Eye View) guide to your scene, see Adding  Drawing 
Guides.

How to adjust a 3-Points Perspective (Worm's-Eye View) guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  3-Points Perspective (Worm's-Eye View) guide that you wish to 
make adjustments to. 

The selected guide appears in the Camera or Drawing view. 
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NOTE 

The horizon line and vanishing points for this guide are far outside of the camera field 
by default. You may need to zoom out in order to be able to see them.

 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   on the horizon 
line and move it up or down. This will rotate the horizon line around the opposite vanishing 
point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that 
vanishing point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.

 l To reposition the top vanishing point, click and drag on that vanishing point .

TIPS 

 l You can press and hold the Alt key to position the point on the axis that is 
perpendicular to the horizon line and in the middle of its two vanishing 
points. 

 l You can press and hold the Shift key to make the point only move 
horizontally or vertically relative to the camera angle. 
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Adjusting a 3-Points Perspective (Horizontal Pan) Drawing Guide

The 3-Points Perspective (Horizontal Guide) helps you draw backgrounds and objects with front-facing 
perspective and curvilinear horizontal lines. It provides a horizon line, a central vanishing point, used to draw 
lines on the z-axis, and two vanishing points at the extremities of the horizon line, used to draw curvilinear 
horizontal lines. 

The position and size of the guide, the height and angle of the horizon line, the distance of the outer vanishing 
points from the central vanishing point as well as the shape of the curves can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Horizontal Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a            3-Points Perspective (Horizontal Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the       3-Point Perspective (Horizontal Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 

603



 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the left and right vanishing points, click and drag on either 
one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide horizontally and make its curves wider 
or narrower.

 l To scale up the guide, press and hold Shift, then click and drag on either the left or right 
vanishing points .

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the green dots  in the top-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost top-right curve, and affect 
all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting the 3-Points Perspective (Vertical Pan) Drawing Guide

The 3-Points Perspective (Vertical Pan) Guide helps you draw backgrounds and objects with front facing 
perspective and curvilinear vertical lines. It provides a horizon line, a central vanishing point, used to draw 
lines on the z-axis, and two vanishing points above and below the horizon line, used to draw curvilinear 
vertical lines.

The position and size of the guide, the height and angle of the horizon line, the distance of the outer vanishing 
points from the horizon line as well as the shape the curves can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Vertical Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a             3-Points Perspective (Vertical Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        3-Point Perspective (Vertical Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the top and bottom vanishing points, click and drag on 
either one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide vertically and make its curves wider or 
narrower.

 l To scale up the guide, press and hold Shift, then click and drag on either the top or bottom 
vanishing points .

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the red dots  in the bottom-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost bottom-right curve, and 
affect all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.

606

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Adjusting a 4-Points Continuous Perspective Drawing Guide

The 4-Points Continuous Perspective helps you draw backgrounds with perspective and curvilinear horizontal 
lines that span over up to four cardinal points, so as to make backgrounds that can be panned in a loop to 
simulate a 360° camera rotation. It provides a horizon line with five vanishing points spread evenly along it. 
Each vanishing point represents one cardinal point, except for the two vanishing points at the extremities, 
which represent the same cardinal point, adding up to four cardinal points.

The size and position of the guide, the height and angle of the horizon line, the distance between the 
vanishing points as well as the shape of the curves can be adjusted as needed.

NOTE 

To add a 4-Points Continuous Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a             4-Points Continuous Perspective                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        4-Point Continuous Perspective       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the  vanishing points, click and drag on one of the two points 
 located left and right of the central vanishing point. 

NOTES 

 l All of the vanishing points on the horizon line will move so that they are at 
the same distance from each other.

 l This will stretch or squash the guide horizontally and make its curves wider 
or narrower.

 l To scale up the guide, press and hold Shift, then click and drag on one of the two points  
located left and right of the central vanishing point.

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the green dots  in the top-right 
corner of the central part of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost top-right curve, and affect 
all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 4-Points Perspective (Vertical Pan) Drawing Guide

The 4-Points Perspective (Vertical Pan) guide helps you draw backgrounds and objects with perspective from 
an angle with curvilinear vertical lines. It provides a horizon line on which there are two vanishing points, one 
for drawing lines on the x-axis and the other for drawing lines on the z-axis. There are two more vanishing 
points above and below the horizon line, used to draw curvilinear vertical lines.

The position and size of the guide, the height and angle of the horizon line,  the position of the two vanishing 
points on the horizon line, the distance of the top and bottom vanishing points from the horizon line as well as 
the shape of the curves can be adjusted as needed.

NOTE 

To add a 4-Points Perspective (Vertical Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a             4-Points Perspective (Vertical Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        4-Point Perspective (Vertical Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 

609



NOTE 

The vanishing points for this guide are far outside of the camera field by default. You 
may need to zoom out in order to be able to see them.

 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between either one of the left and right vanishing points and the 
central vanishing point, click and drag on one of these points .

TIP 

You can press and hold the Alt key while dragging one of the outer vanishing 
points  to make both vanishing points move and keep both points at the same 
distance from the central vanishing point.

 l To adjust the distance between the top and bottom vanishing points, click and drag on 
either one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide  and make its curves wider or narrower.

 l To scale up the guide, press and hold Shift, then click and drag on one of the four outer 
vanishing points .
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NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the red dots  in the bottom-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost bottom-right curve, and 
affect all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 5-Points Perspective (Fisheye) Drawing Guide

The 5-Points Perspective (Fisheye) guide helps you draw backgrounds and objects with both horizontal and 
vertical curvilinear perspective. It provides a horizon line, a central vanishing point, used to draw lines on the z-
axis, two vanishing points at the horizontal extremities, used to draw curvilinear horizontal lines, and two 
vanishing points at the vertical extremities, used to draw vertical lines.

The position, angle and size of the guide can be adjusted as needed.

NOTE 

To add a 5-Points Perspective (Fisheye) guide to your scene, see Adding  Drawing Guides.

How to adjust a             5-Points Perspective (Fisheye)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        5-Point Perspective (Fisheye)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 

 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

612

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To scale up the guide, click and drag on one of the four outer vanishing points .

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Locking Guides to Prevent Editing Them
T-LAY-001A-008

When using a drawing tool with a guide, you are also able to edit the guide's horizon line, vanishing points and 
other parameters by manipulating them in the Camera or Drawing view. Hence, it is possible to make changes 
to your guide by accident when drawing too close to one of its visual elements. Once you are done making 
adjustments to a guide, it is recommended to lock guides to be able to draw freely without having to worry 
about making accidental changes to your guides.

How to prevent editing of  Drawing Guides while drawing

 1. In the Guides view, click on the  Lock Guide  button. 

NOTES 

 l The Lock Guide option prevents editing all guides, not just the selected one. 

 l When adding a new guide, the Lock Guide option is automatically toggled off to allow the 
new guide to be edited immediately.
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Drawing with Drawing Guides
T-LAY-001A-006

When guides are enabled and a guide is selected, you can use this guide to assist you in drawing with precision 
or perspective. The guide will display dotted lines going through your mouse cursor as you move it inside the 
drawing space. Each of these lines represents one of the axes of the selected guide. 

When you start drawing a stroke, your drawing tool will automatically lock against the axis that most closely 
matches the angle of your stroke, forcing you to draw a straight line along that axis, as if you were using a ruler 
or a set square. 

NOTES 

 l Guides can only be used with the  Brush,  Pencil,  Stroke or  Line tool.

 l If the  Align with Guide option in the Guides view is toggled off, your mouse cursor will not 
lock against the axes in your guide. 

How to draw using guides

 1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing 
by doing one of the following:

 l Right-click on the cell and select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R

 2. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.
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 3. In the Guides view, select the guide you wish to use.

 4. To avoid editing your guide by accident while drawing, make sure the  Lock Guides option is 
toggled on—see Locking Guides to Prevent Editing Them on page 614. 

 5. If you want your drawing strokes to be locked against the axes of your guide, make sure the  
Align with Guide option of the Guides view if toggled on. Otherwise, toggle it off to be able to draw 
freely and only use the guides as references—see Drawing Freehand Perspective with Drawing 
Guides on page 619.

 6. Move the mouse cursor around the drawing space. Observe that guide lines are going through your 
mouse cursor, one for each of the axes of the drawing guide.

 7. Start drawing a stroke roughly at the same angle as one of the axes.

If the  Align with Guide option is enabled, the drawing stroke aligns to the axis that is the 
closest to its angle, as if you were drawing against a ruler.
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TIPS 

 l You can also manually select which axis to lock onto—see Locking Drawing Strokes to a 
Specific Axis.

 l Whether you're drawing or not, you can lock the position and angle of the guide lines by 
pressing and holding the Alt key. The guide lines will stop following the mouse cursor, 
allowing you to keep them at a specific angle and position. This can be used to draw over 
the same line several times over so as to adjust its length and thickness. 
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Locking Drawing Strokes to a Specific Axis
T-LAY-001A-010

When using a drawing guide with the  Align with Guide option enabled, your drawing tool will 
automatically lock against one of the axes of your guide. Which axis it locks onto is the one that is the closest to 
the angle of your stroke as you start drawing.

If you want, you can manually select which axis to lock your drawing tool against, so as to avoid accidentally 
locking against the wrong axis. 

How to lock your drawing tool to a specific axis

 1. Set the focus to the Camera or Drawing view, for example, by clicking on the view's tab.

 2. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes. The 
selected axis will be displayed in bold across your mouse cursor.

All your drawing strokes will lock onto the selected axis. 

How to re-enable using all axes

 1. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes, until none 
of them are displayed in bold across your mouse cursor. 
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Drawing Freehand Perspective with Drawing Guides
By default, when drawing with a drawing guide active, your mouse cursor will lock against one of your guide's 
axes, forcing it to draw along the axis as if you were drawing against a ruler. 

If you want, you can disable this behaviour by turning off the  Align with Guide option, and only use your 
drawing guide as a visual reference. This can be useful if you want to draw with less rigid drawing style. 

When the Align with Guide option is disabled:

 l Your drawing tool will allow you to draw in any direction. 

 l The guide will still be visible, but will only serve as a visual aid. 

 l While drawing, the dotted line representing the axis you are drawing along will lock into place instead 
of following your mouse cursor, so that you can follow it as you draw.

How to draw freehand perspective

 1. In the Guides view, click on the Align with Guide  button to toggle it off

 2. Start drawing.
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Viewing Drawing Guide Reference Lines
T-LAY-001A-007

By default, a guide will only display its horizon line and its vanishing points, as well as dotted lines going 
through your mouse cursor to represent its axes. 

To help you lay out objects in your drawing, you can also enable reference lines. Reference lines are semi-
transparent lines displaying all over your drawing space, representing your guide's axes at different angles or 
distances.

When using reference lines, you can decide the amount of lines that display in your drawing space. If you have 
too many reference lines, they will be very close to each other and your drawing space might feel cluttered, 
but if you have too few, you might not always have a reference line close enough to the stroke you wish to 
draw to help serve as a reference.

How to view Drawing Guide Reference lines

 1. In the Guides view, click on the  Show Reference Lines  button to toggle it on.

The reference lines appear as a semi-transparent overlay all over your drawing space.

 2. In the Guides view, click and drag on the Number of Lines slider to adjust the amount of reference 
lines displayed in your drawing space.
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Minimizing Guide Cursor Axes Display
By default, the guide axes that are drawn across your mouse cursor extend throughout your entire drawing 
space. You may want those axes to only extend to a short distance around your cursor, so that they can still 
serve as guides without obstructing your drawing space or drawing your eye away from your mouse cursor. You 
can do this by disabling the  Full Cursor Display option, which is enabled by default.

When the Full Cursor Display option is disabled:

 l The axis lines displaying across your mouse cursor only span on a short distance from your mouse cursor.

 l When drawing a stroke, all axis lines disappear until you finish drawing the stroke. By default, only the 
axis you are drawing on disappears.

 l The actual axes used to lock your drawing tool still extend across the entire drawing space. This is 
strictly a visual option. 

How to minimize the Drawing Guide's cursor axes display

 1. In the Guides view, toggle the Full Cursor Display  button off. 

The guide axes now only span over a short distance from your mouse cursor.
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Erasing Using Drawing Guides
By default, drawing guides have no effect when using the  Eraser tool. If you want, you can enable using the 
Eraser tool with guides.

How to erase using a Drawing Guide

 1. In the Guides view, click on the  Enable Guide with Eraser button to toggle it on.

The  Eraser  tool will now  work with the currently selected guide, just like the  Brush,  
Pencil,  Stroke and  Line tools. 

 2. Start erasing.

NOTE 

When this option is enabled, it is also possible to make adjustments to your guide while the  
Eraser too is selected.
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Enabling and Disabling Drawing Guides
T-LAY-001A-009

Once you are done working with guides, you can disable them. When drawing guides are disabled, they are 
not displayed in your drawing space and do not affect the behaviour of your drawing tools. 

How to enable and disable drawing guides

 1. To enable or disable Drawing Guides, do one of the following: 

 l In the Guides view, click on the Enable Guide  button.

 l Press Shift + G.

NOTES 

 l Guides are automatically enabled when you add a new guide or when you select a guide in 
the guides list.

 l The guide that was selected when you disabled guides will be selected again when you re-
enable guides.

 l Drawing guides only work with the  Brush,  Pencil,  Stroke and  Line tools 
tools. If any other tool is selected, drawing guides will behave as if they are disabled. 
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Reordering Drawing Guide Lists
The drawing guides in your guides list can be reordered. 

How to reorder a Drawing Guide list

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key and clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide 
in-between will also be selected.

 2. Drag and drop the selected guides to their desired position in the list.
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Cutting and Pasting Drawing Guides
You can cut a drawing guide from your guides list and paste it into the guides list of another scene.

How to cut and paste drawing guides

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key and clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide 
in-between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Menu button and select Cut.

 l Press Ctrl + X (Windows/Linux) or ⌘  + X (macOS).

The selected guides are deleted from the list and stored in the clipboard.

 3. In the top menu, select File > Open and open a different Harmony scene.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guides, select the guide that will act as an insertion point.

 5. Do one of the folliowing:

 l In the Guides view, click on the  Menu button and select Paste.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Drawing Guides that were cut from the previous guides list are pasted in the current guides list.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.
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Copying & Pasting Drawing Guides
T-LAY-001A-004

You can copy drawing guides from your guides list and paste them into the guides list of another scene.

How to copy and paste drawing guides

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key and clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide 
in-between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Menu button and select Copy.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 3. In the top menu, select File > Open and open a different Harmony scene.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guide, select a guide that will act as an insertion point.

 5. Do one of the folliowing:

 l In the Guides view, click on the  Menu button and select Paste.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Drawing Guides that were copied from the previous guides list are pasted in the current guides list.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.
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Exporting and Importing Drawing Guides
You can export drawing guides from the current scene into a file, then and import them into another scene.

How to export drawing guides to a file

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key and clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide 
in-between will also be selected.

 2. In the Guides view, click on the  Menu button and select Export Selected Guides.

 3. In the Export Guides dialog box that appears, choose a destination folder, type in the name of the 
file you want to export, then click on Save.

The selected guides are exported to the destination file. A confirmation dialog box displays the 
amount of guides that were exported.

How to import drawing guides

 1. In the Timeline or Thumbnail view, select the destination panel. 

 2. In the Guides view, click on the  Menu button and select Import Guides.

 3. In the Import Guides dialog box that appears, browse to the folder in which you exported your 
guides, select the file in which you exported your guides and click on Open.

The guides that were stored in the file are inserted at the bottom of the guides list. A confirmation 
dialog box displays the amount of guides that were imported.

NOTE 

When importing a list of guides, duplicate guides are filtered out to avoid cluttering the list. 
The confirmation dialog box will specify if duplicates were detected and filtered out.
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Deleting Drawing Guides
T-LAY-001A-003

You can delete drawing guides from the guides list.

How to delete a Drawing Guide

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key and clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide 
in-between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Delete Guide  button

 l Press Del (Windows/Linux) or Backspace (macOS).

The selected guided are deleted from the list.
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About Drawing Optimization 
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those 
drawings to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to 
flatten your artwork or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected 
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change 
the appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an 
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging 
the transparent drawing objects will cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to 
be repainted later.

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath 
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing 
into another. If you cut a portion from a textured line and paste it into a different drawing, Harmony pastes the 
entire unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of 
the source drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not 
touch the vector area. If there are many textured lines in your scene, this will greatly reduce the file size.
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In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first, it 
appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However, 
using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more 
texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command, the bitmap 
texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image where 
the vector envelope has been pulled out to reveal empty space). 
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Flattening Drawings
T-ANIMPA-002-006

The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By 
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will 
be easier if they are flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  
button in the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a 
pencil line. It also smooths out the shape.  

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  
button in the Tool Properties view.
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Creating Contour Strokes
The Create Contour Stroke  option is used to add a permanent invisible line around a shape that was drawn 
directly in Harmony. This allows you to unpaint your lines with the Paint  tool but maintain the shape of the 
lines, should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer  option.

How to create contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to create 
contour strokes for.

 3. From the top menu, select Drawing> Optimize > Create Contour Strokes.
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Removing Contour Strokes
The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while 
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the 
intersection triangles created during vectorization.

How to remove contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to 
remove contour strokes for.

 3. From the top menu, select Drawing> Optimize > Remove Contour Strokes.

634

Harmony 21 Premium User Guide                          



Chapter 5: Drawing

Removing Extra Strokes
The Remove Extra Strokes command allows you to  instantly remove invisible lines that are adjacent to the 
artwork in your selection.

NOTE 

This will only remove invisible lines that are adjacent to visible artwork. Invisible lines that are not 
connected to any visible shape or line will not be removed. 

How to                              remove extra strokes

 1. In the Tools toolbar, select the Select  tool.

 2. In the Camera or Drawing view, use the Select tool to select the artwork from which you want to 
remove extra strokes. 

 3. Do one of the following:

 l In the top menu, select Drawing > Optimize > Remove Extra Strokes.

 l In the Camera or Drawing view, open the View Menu  and select Drawing > Optimize > 
Remove Extra Strokes.
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Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your 
drawings. This mainly means that transparencies will not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to optimize. 

 3. Do one of the following:

 l From the top menu, select Drawing > Optimize > Optimize.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Optimize. 
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Cropping Brush Textures 
The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath 
the vector contour of a textured line

How to crop the brush texture

 1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop. 

 2. Do one of the following:

 l From the top menu, select Drawing > Optimize > Crop Brush Textures.

 l From the Camera View or Drawing View menu, select Drawing > Optimize > Crop 
Brush Textures.
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Reducing the Drawing Texture Resolution
When you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be 
heavy. You can reduce the size and resolution of the textures in a drawing. 

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects whose texture 
resolution you wan to reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Reduce 
Drawing Texture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the 
drawings in your layer.

 6. Click OK.
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About Strokes Conversion 
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For 
many reasons, you may want to switch your stroke types to another type to use the various advantage set they 
offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes 
(strokes) to pencil lines. 

You can also break text objects apart—see Breaking Text Into Letters or Vector Shapes on page 536.
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Converting Brush Strokes to Pencil Lines 
The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. 
The brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or 
press ^.

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ^
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Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour 
strokes brush lines. This feature works for both solid and textured pencil lines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select  tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert.

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes .

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes.

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l Select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + 
F12 (Windows/Linux only)
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About Vector and Bitmap Layers
T-LAY-001-002

With Harmony, you have the choice to use vector or bitmap drawing tools. Vector drawing tools allow you to 
make drawings that can be scaled without losing quality, to easily tweak and fine tune your drawings and to 
use the whole suite of drawing tools available in Harmony, whereas bitmap drawing tools allow you to lay on 
brush strokes to make more traditional-looking artwork, and to tweak your drawing by the pixel rather than 
by their strokes and contours. 

When drawing, whether you can use vector or bitmap drawing tools is determined by whether the art layer 
you are drawing on is a vector or a bitmap layer. By default, each drawing layer has two art layers: Line Art 
and Colour Art, and each of these art layers can be a vector or a bitmap layer. This can be useful if, for example, 
you wish your line art to be done using bitmap drawing tools, and then to paint your drawings using vector 
drawing tools, or vice versa.

NOTE 

Optionally, drawing layers can have two extra art layers, the Overlay Art layer, which appears 
over the other art layers, and the Underlay Art layers, which appears underneath. For more 
information, see Enabling Overlay and Underlay Art Layers on page 891.

Using bitmap layers may be preferable if you find that vector drawings are too limiting for the desired art style, 
or if your vector drawings are so complex that they affect software performance. However, bitmap layers have 
the following limitations which you should carefully consider before using them:

 l In vector drawings, each stroke  is a separate drawing object by default, and each of these drawing 
objects, as well as each of their points, curves and outlines, can be manipulated independently. It is not 
possible to do that with bitmap layers, as they are always a single drawing object. They can be drawn, 
filled or erased over, and manipulated as a whole, but its individual elements cannot be manipulated 
independently. 

 l By default, bitmap layers are created at the same pixel density as your scene's camera when it is in its 
default position. This means that your artwork will lose picture quality if you zoom in on it or scale it up. If 

643



you need bitmap drawings to be scaled up or zoomed on, you must set your bitmap artwork's pixel 
density higher before you start drawing. 

 l Bitmap drawings may require more storage space than vector drawings. Note that this depends a lot on 
the amount of space in your drawing that is covered by artwork. Harmony does not store bitmap data 
for empty areas of your drawings.

When drawing on a bitmap layer, the following tools are unavailable, as they exploit the vector drawing 
capabilities of Harmony:

 l Pencil

 l Contour Editor

 l Pencil Editor

 l Smooth Editor 

 l Perspective

 l Envelope

 l Ink

 l Stroke

 l Close Gap 

 l Polyline
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Adding Bitmap Layers
T-ANIMPA-002-013

By default, new scenes created in Harmony will have a single vector layer. You can choose whether a drawing 
layer will be a vector or a bitmap layer at its creation. Therefore, if you want to use a bitmap layer, you can 
simply create one.

Each drawing layer in your scene has two sub-layers, referred to as Line Art and Colour Art, each which can be 
either Vector or Bitmap. When creating a new layer, you can choose whether each of these art layers will be 
vector or bitmap art layers.

How to add a bitmap layer

 1. In the Timeline view, click the Add Drawing Layer button,

The Add Drawing Layer window opens.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and 
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, 
Line Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay 
Art Layers on page 891.

 2. If you want a fully bitmap layer, select Bitmap for all the art layers. If you want parts of your 
drawing to use bitmap drawing tools and other parts of your drawings to use vector drawing tools, 
set the corresponding art layers to Bitmap or Vector, depending on your needs.

 3. Click OK.
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Setting the Bitmap Resolution
When drawing in bitmap, it is important to understand that, contrary to vector artwork, bitmap artwork is 
stored in pixels. This implies that, where vector artwork can be scaled and zoomed in without issue, bitmap 
artwork is resolution dependent, and is liable to drop in picture quality and appear pixelated if it is enlarged or 
zoomed in. 

By default, bitmap layers created in Harmony have a pixel density of 100%. At this density, when your scene is 
not zoomed in and your artwork is not scaled up, each pixel in your artwork corresponds to one pixel in the 
rendered image. Scaling it up or zooming in will require Harmony to render several pixels using the same 
bitmap pixel, making the artwork lose quality.

Hence, before you start drawing on your bitmap layer, it is important to consider if you will need to zoom onto 
or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your bitmap 
artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure your bitmap 
artwork's pixel density is of at least 300% before you start drawing. 

The pixel density of a bitmap layer affects the amount of pixels it contains, but not its apparent size in the 
scene. For example, if your scene resolution is set to 1920 x 1080 and your bitmap artwork's pixel density is 
300%, its resolution will be 5760 x 3240. However, it will be scaled down to 1920 x 1080, and the extra 
pixels will be used to preserve the image quality if the artwork is zoomed on or scaled up.

Bitmap layers are also limited by a canvas. By default, this canvas is set to be 200% of the scene's width and 
height. This means that your artwork can bleed outside any edge of the camera frame by 50% of its size. If you 
need your bitmap artwork to have a larger canvas, it is possible to change its canvas size. This can be useful for 
example if you want to create a panning background in a bitmap layer. If you want a background to pan 
horizontally over three times the width of the camera frame, you would need to set its canvas width to at least 
300%, but it is recommended to make your canvas bigger than what you plan to use so as to avoid accidentally 
including the edges of your artwork in the picture. 
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You can specify the pixel density and canvas size at the scene level or at the drawing level:

 l Setting the pixel density and canvas size at the scene level will make it newly created bitmap drawings 
have the specified settings, but it will not change the pixel density and canvas size of existing bitmap 
drawings.

 l Setting the pixel density and canvas size at the drawing level will allow you to change the pixel density 
and canvas size of existing drawings in a bitmap layer, but will not affect the pixel density and canvas 
size of drawings created afterward.

NOTE 

If you are using textured brushes on a vector drawing layer, you must set the pixel density for 
vector drawing brush textures instead—see Setting the Textured Brush Resolution on page 361.

How to set the canvas size and pixel density of bitmap layers for a scene

 1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

 2. Select the Bitmap Resolution tab.
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 1. In the Default Canvas Size & Pixel Density for Bitmap Drawings section, do the following:

 a. In the Width and Height fields, enter the percentage of your scene's resolution that you 
want the canvas of your bitmap layer to occupy. By default, both values will be set to 200%, 
which means the width and height of your bitmap canvas will be twice the width and height 
of your scene's resolution. When the camera is in its default position, this leaves  extra space 
around the camera frame to draw on your bitmap layer. 

 b. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale 
or zoom in on your artwork, make sure your pixel density is set to be at least the factor by 
which your artwork will scaled or zoomed on. For example, if you intend to scale your artwork 
by 300%, you need to set the pixel density to at least 300%. If you intend to zoom in on your 
artwork from 12 fields to 6 fields, you need to set the pixel density to at least 200%. If you 
intend to do both, you need to set the pixel density to at least 600%, as the camera zoom 
and scaling factor will have a multiplying effect on the apparent scaling of your artwork.

 2. Click OK.

From now on, new bitmap drawings created in your scene will have the selected canvas size and 
pixel density.

Since changing the bitmap resolution settings for your scene will only affect newly created bitmap drawings, 
you may also want to change the bitmap resolution settings for existing bitmap drawings. This is possible. 
However, if your bitmap layer already contains artwork, it will be resampled. 

This is not necessarily a problem if you want to lower your bitmap layer's pixel density, which you might want 
to do to save on disk space and help Harmony's performance. However, if you want to increase your bitmap 
layer's pixel density, Harmony will have to generate extra pixels for your bitmap drawing, which will cause the 
image to lose quality. Hence, it is important to calculate and set the proper pixel density for your bitmap 
drawings before you start drawing. 

How to change the canvas size and pixel density of existing bitmap drawings

 1. In the Timeline, Node or Camera view, select the bitmap drawing for which you want to change the 
canvas size or pixel density.
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 2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.

The Change Bitmap Drawing Resolution dialog opens.

 3. In the Width and Height fields, enter the percentage of your scene's resolution that you want the 
canvas of your bitmap layer to occupy. By default, both values will be set to 200%, which means the 
width and height of your bitmap canvas will be twice the width and height of your scene's 
resolution. When the camera is in its default position, this leaves  extra space around the camera 
frame to draw on your bitmap layer. 

 4. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or 
zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your 
artwork will scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you 
need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12 
fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you 
need to set the pixel density to at least 600%, as the camera zoom and scaling factor will have a 
multiplying effect on the apparent scaling of your artwork.

 5. Enable the  Resample Bitmap option if you want your drawings to preserve their apparent size in 
the scene. 

 6. If you want the specified settings to be applied to all of the drawing's art layers, i.e., Line Art, Colour 
Art and, if enabled, Overlay Art and Underlay Art, check the Apply to All Art Layers option. 
Otherwise, only the currently active art layer will be affected.

 7. If you want the specified settings to be applied to all drawings in the active layer, check the Apply 
to All Drawings option. Otherwise, only the current drawing will be affected. 

 8. Click OK.

The selected drawing's canvas size and pixel density is set to the specified settings.
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NOTE 

This does not change the default canvas size and pixel density for the scene. New drawings 
will still be created with the scene's default canvas size and pixel density.
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Using Colours with Bitmap Layers
Contrary to vector layers, colours used in bitmap layers are not linked to their swatch in your scene's palette. 
Therefore, if you update a colour in your palette, this new colour will be updated in the drawings in your vector 
layers, but your bitmap layers will remain intact. Hence, it is important to know exactly the colours you wish to 
use before your start painting on a bitmap layer.

Because bitmap layers are not linked to your colour palettes, this adds extra flexibility when painting on a 
bitmap layer. Although you are still able to use the colour swatches from your colour palette, you can also pick 
any other colour and paint right away with it, without having to create a colour swatch for it in your palette. 
Hence, when a bitmap layer is selected, the Colour view lists your palettes and their swatches, but it also 
features an extra panel, Bitmap Colour, which allows you to create a colour on the go.

NOTE 

The Bitmap Colour panel only allows you to create solid or semi-transparent colours. If you wish to 
use a gradient or bitmap texture in a bitmap drawing, you must still create a colour swatch for it in 
one of your scene's palettes.

By default, the bitmap colour sliders allow you to pick a colour by choosing its Hue, Saturation and Value. 
These sliders are referred to as the HSV Sliders. If you prefer, you can also pick your bitmap colour by choosing 
its Red, Green and Blue values, by switching to the RGB sliders .

How to change between HSV and RGB sliders

 1. Do one of the following:

 l Right click on the Bitmap Colour panel and select either HSV Sliders or RGB Sliders.

 l Open the Colour View menu  and select Colour > Bitmap Colour Sliders > HSV 
Sliders or RGB Sliders.
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Painting with Gradients or Textures on Bitmap Layers
When drawing on a vector layer, each stroke is its own vector drawing object, and can be manipulated 
independently at any time unless you flatten or group your strokes together. When drawing on a bitmap layer, 
most modifications  are immediately merged into the artwork, making it a single bitmap drawing that can only 
be drawn on, painted on or erased. One exception to this rule is when you paint a zone with a gradient or 
texture. 

When using the Paint tool to fill a zone in a bitmap layer with a gradient or texture, a temporary vector object 
in the shape of the fill is created, and contains the fill. This allows you to use the Edit Gradient/Texture tool on 
this vector shape to tweak your gradient or texture so that it has the intended position, angle and scale. Then, 
the next modification you make to your bitmap layer—be it with a drawing tool, or by pasting artwork—will 
cause the gradient/texture to merge with your artwork, making it no longer possible to tweak it with the Edit 
Gradient/Texture tool from that point on. Hence, it is important to make sure your gradients or textures look 
exactly as you intend them to before continuing to work on your drawing. 

NOTE 

Certain tools, such as the Text or Cutter tool, will not cause your gradient/texture to merge with 
your artwork.
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Manipulating Bitmap Artwork
T-ANIMPA-002-014

Since bitmap artwork is stored as colour information for each pixel, scaling your artwork requires Harmony to 
resample it. This means that if you scale up your artwork, it is liable to lose picture quality. Furthermore, since 
Toon Boom bitmaps are embedded in a rectangular canvas, you cannot select a part of your bitmap with the 
Select tool to transform it. With Toon Boom bitmaps, the Select tool is only able to select the entire canvas. If 
you want to transform a part of your bitmap drawing, you must use the Cutter tool to cut out the part you wish 
to manipulate. 

However, artwork that you manipulate is not immediately resampled. This is to make sure you can manipulate 
your artwork in multiple steps before it is merged into your artwork again, allowing to preserve as much of its 
quality as possible. While manipulating your artwork, it temporarily becomes an object that is separate from 
your bitmap canvas. Then, it is merged back into your canvas and resampled to match its pixel density when 
you perform your next drawing operation on it. 

In the following example, a circle is scaled down. Then, when zooming in on it, it appears to have preserved all 
its precision. Right after drawing a short stroke on the drawing, it is sampled down to match the layer's pixel 
density:

Likewise, if bitmap artwork is scaled up, it will be resampled after a drawing operation is performed on it. In 
this example, the artwork is scaled up and looks pixelated. Once a stroke is drawn on it, Harmony resamples it, 
and creates the missing pixels so that it does not look pixelated:
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Changing Art Modes
Whether a layer is a bitmap or a vector layer is decided when creating it. However, it is also possible to change 
the art mode for an existing layer. 

If you convert a vector layer to a bitmap layer, the artwork will not be immediately converted, but it will be 
automatically flattened and rasterized into a single bitmap image if you make any modifications to your artwork 
using drawing tools. 

If you convert a bitmap layer into a vector layer, the existing bitmap artwork will become a single drawing 
object, which you will be able to manipulate with the select tool or cutter tool, but which you won't be able to 
draw over, erase or repaint. However, you can convert it to a vector rectangle with its artwork as its texture 
using the Convert Drawings to Match Layer Type command. It will still not be possible to edit the actual 
artwork, but you will be able to draw or erase over it, as well as tweak the contour of its canvas. 

If you want to actually vectorize a bitmap layer's artwork into vector outlines, see Vectorizing Bitmap Artwork.

How to change the art mode

 1. Open the Layer Properties view.

 2. In the Timeline view, select the layer you want to edit.

 3. In the Layer Properties view, select the Drawing tab.

 4. In the Art Layers section, select the whether the art mode should be Vector or Bitmap for each art 
layer.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and 
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, 
Line Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay 
Art Layers on page 891.

 5. In the Timeline view, right-click on the layer and select Convert Drawings to Match Layer Type.
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A message box appears informing you of how many drawings were converted. 
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Vectorizing Bitmap Artwork
It is possible to convert artwork in a bitmap layer into vector outlines, which you can then edit and paint using 
Harmony's vector drawing tools. This procedure takes the bitmap drawing in the layer's line art layer, then 
converts it to vector outlines and inserts them into a vector drawing layer, which you must create as your 
destination layer for the vectorization. 

NOTE 

To do this, your bitmap drawing you should be line art only, and it should be in your drawing 
layer's line art layer. 

How to vectorize a bitmap drawing

 1. In the Timeline view, create a new vector drawing layer, and make sure it is listed right below your 
bitmap drawing layer. If it is not, drag and drop the vector drawing layer below the bitmap drawing 
layer to reorder it. 

 2. On the right side of the Timeline view, select all the bitmap drawings you vectorize, along with the 
frames in the vector layer which should serve as a destination for the vectorized images.

 3. Right-click on the selected frames, then select Drawings > Vectorize Line Art in Selected Drawing.

The Convert to Vector Drawing dialog box opens.

 4. In the Vectorization section, select a vectorization preset. Among the default presets, you can select 
Black and White if you wish to make crisp, vector only outlines, or Grey if you wish to preserve your 
line art's texture. You can customize your own preset using the Add or Edit buttons.

 5. Click OK.

Your bitmap drawing layer's line art is vectorized and inserted into your vector drawing layer. 
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 6. Click on the Enable/Disable Layer  icon next to your bitmap drawing layer to hide your bitmap 
line art and see your vectorized line art. 

NOTE 

For this functionality to work, your selection must absolutely have frames from a bitmap 
drawing layer on top, and frames from a vector drawing layer                   in the bottom, and nothing else. 
Otherwise, an error message indicating how to use this feature will appear. 
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Setting the Default Art Mode for New Layers
You can configure Harmony to create drawing layers with specific art modes for each art layer using the 
Preferences dialog. 

How to adjust the art mode settings in the Preferences dialog box

 1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Harmony Premium > 
Preferences ( macOS ).

 2. Select the Node View tab.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and 
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, 
Line Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay 
Art Layers on page 891.

 3. In the Layer Drawing Options section, set the art layers to the desired art mode. Once this option is 
enabled, all new layers will follow these settings. It will not affect any existing layers.

 4. Click OK.
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Chapter 6: Painting and Colours
T-ANIMFX-003-001

Toon Boom Harmony Premium has some very powerful painting features to add colour to your drawings. 
Whereas some other software only allow users to work with one colour swatch at a time, painting in Harmony 
is done by using palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You 
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
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using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit 
the mood and atmosphere of the scene without having to repaint each element.

It is also possible to use colour swatches from palettes in bitmap drawings, although changing the colours in 
the palettes will not automatically update colours used in bitmap layers. Likewise, it is possible to create 
drawing layers with bitmap line art and vector colour art, all with the same palettes —see About Art Layers on 
page 887 and Creating Colour Art from Line Art  on page 893.
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About Colour Swatches
T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap 
texture swatches.

A colour palette is an actual file on the hard drive. 

In Harmony Server, these palette files can be stored in a different location on the server. They can be stored in 
the Environment, Job, Scene, or Element folder and linked to any palette list. This means that if the original 
palette file is modified, it will update in every drawing element the palette is linked to. 

In Harmony Server, to avoid accidentally modifying the palette, the palette files can be locked. If a palette must 
be modified, you must get the rights to modify them before doing so.

In Toon Boom Harmony Premium, when you add a swatch, it is created using the colour of the currently 
selected swatch from your palette. However, you can set a default colour to be used every time you create a 
new colour in your colour palette. This is useful for creating different shades of the same basic colour.

The default colour is also the colour used when you choose to vectorize images you're scanning into your scene, 
however you add the Default colour swatch to your palette in a different way, so it's unique. It has a unique ID 
number that makes it easily recognizable from all the other colours in your colour palettes. Being able to 
change this colour allows you to change the basic colour of all scanned drawings. This can be useful on more 
than just an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can 
create problems.
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Locking and Unlocking the Colour List
In Harmony Server, you can lock and unlock the colour list to avoid modifying or modify the colour swatches.

How to lock and unlock the colour list 

 1. In the Colour view, click the Edit Palette Mode  button. 

A grey pencil icon appears in the top-right corner of the Palette list.
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Adding a Colour Swatch 
T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. Do one of the following to edit the colour swatch:

 l From the Colour view menu, select Colours  > Edit.

 l Double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's 
spectrum, then click on the desired colour in the colour wheel.
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 l Enter the hue, saturation, value, red, green and blue values manually into their 
corresponding fields. All values range from 0 to 255. 

 l Click the Dropper  button to select any colour on your screen. It can be from the 
Harmony interface, your operating system or any other open application. 

You can also click Multi Wheel Mode to open the Multiwheel Colour window. This displays all the 
picking area styles together and also contains a picking undo list. To return to the regular Colour 
Picker window, click Single Wheel Mode.
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 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.

 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

 7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-
clicking on its name.

By default, when you create a new colour swatch, its colour will be the same as the currently selected colour 
swatch, or black if no colour swatch is selected. You can make Harmony create new colour swatches with a 
specific default colour instead. 
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How to change the default swatch colour for all your colour palettes

 1. Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences (macOS).

 2. In the Preferences dialog box, select the Drawing tab.

 3. In the New Colour Pots section, select the Create New Colour Pots Using the Default Colour 
option. You can also click the colour swatch beside the option to change the default colour.
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Adding a Gradient Colour Swatch 
T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker window opens.
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 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. In the Gradient slider, create your gradient:

 l To change one of the colours of your gradient, select a key colour from the gradient slider, 
then pick its colour in the colour picker.

 l To add a key colours to your gradient, click anywhere on the colour slider, between the 
existing key colour.

 l To delete a key colour, use the mouse to pull down on it.

 l To move a key colour's position in the gradient, use the mouse to drag it left or right.

NOTE 

To learn how to reposition the gradient zones in your drawings, see About the Edit Gradient 
and Texture Tool on page 769.
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Adding a Texture Colour Swatch 
T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. This allows you to fill zones in your artwork with 
custom patterns and textures. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool 
instead of plaid, just update the texture file in the swatch and the entire project updates. Any 
transformation previously applied to the texture’s position in your drawings will be kept.
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NOTE 

To learn how to reposition the textured zones in your drawings, see About the Edit Gradient 
and Texture Tool on page 769.

670

Harmony 21 Premium User Guide                          



Chapter 6: Painting and Colours

Copying and Pasting Colours 
There are three ways to copy and paste colour swatches:

 l Paste as New Colours: This create a new colour swatch with the same colour value, but with a different 
colour ID as the original swatch.

 l Paste as Clones: This creates a new colour swatch with the same colour value and the same colour ID as 
the original swatch.

 l Paste Colour Values: This replaces the colour values in the selected colour swatch with the colour values 
from the copied swatch.

Pasting a colour as a clone is useful if you’ve created a clone of a palette, then added a new swatch in the 
original palette, and need to add a swatch with the same colour ID in the clone palette.

NOTE 

A palette cannot have two swatches with the same colour ID. Hence, you can only paste colours as 
clones in a different palette than the ones the colours were copied from.

If, for any reason, you need to obtain the colour ID of your colour swatches, whether to make a reference table 
of them, or to compare the colour IDs of two swatches, you can copy the colour ID of a colour swatch to the 
clipboard. You cannot paste a colour ID anywhere on a colour swatch, but you can paste it in a text editor or a 
spreadsheet application for your own purposes. 

A colour ID is a string of 16 hexadecimal digits, i.e.: 075cf5b552401130.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

671



 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V 
(Windows/Linux) or ⌘  + V (macOS).

 l To paste the colour values of the copied swatch over an existing colour swatch, select 
Colours > Paste Colour Values.

How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new 
palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch from which you want to copy the ID.

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS).

 3. Paste the copied colour ID in a document.

672

Harmony 21 Premium User Guide                          



Chapter 6: Painting and Colours

Deleting a Colour Swatch
T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will 
be displayed in red and the system will try to recover them the next time you load the scene. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Del.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

673



If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.
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Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Replacing Colours and Textures in Drawings
T-H15NEW-004-001

Although it is always possible to change colours and textures in existing drawings by updating the swatch in 
the palette, there may be situations where you want to replace a colour or texture in your drawings with a 
different colour or texture swatch, without updating the existing swatch. For example, you may want to only 
replace a colour with a different colour in specific drawings, but not in all the drawings that use the original 
colour, or you may want to replace a colour with a colour from a different palette without changing your 
palettes. 

Using the Recolour Drawing dialog, you can replace all instances of a colour or texture used in your drawings 
with a different colour or texture swatch. This will actually change the colours or textures from within the 
drawings, without making any changes to your palette. You can perform this operation on the currently 
selected drawing, on all drawings in the current layer or in all drawings in your scene.

How to recolour drawings

 1. First, make sure one of the palettes in your scene already has a swatch containing the colour or 
texture you want to replace the original colour with—see About Colour Swatches on page 661, 
About the Edit Gradient and Texture Tool,  Adding a Texture Colour Swatch  on page 669 and 
Adding a Pencil Line Texture on page 399.

 2. In the Timeline, Xsheet or Node view, select the drawing or drawing layers you wish to recolour. 

NOTE 

You can select multiple layers if needed. 

NOTE 

You can skip this step if you intend to recolour all the drawings in your scene.

 3. In the Colour view, click on Show Colour Palettes  if you want to replace a colour, gradient or 
texture, or on Show Pencil Texture Palettes  if you want to replace a pencil texture. You can also 
click on Show All Palettes . 

 4. In the Colour view, select the colour or texture swatch you want to replace by doing one of the 
following:

 l Select the palette in which the colour or texture swatch is located, then select the swatch 
you wish to replace. 

 l If the drawing in the Camera or Drawing view contains the colour or texture you want to 
replace, select the Colour Eyedropper  tool in the Tools toolbar, then click on that colour 
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or texture in the drawing. The Colour view will automatically select that colour or texture's 
palette as well as that colour or texture's swatch.

 5. Do one of the following:

 l Right-click on the swatches list, then select Recolour Drawings.

 l Open the Colour view menu , then select Colours > Recolour Drawings.

The Recolour Drawings dialog appears.

 6. In the Replace Colour In panel, select whether you want to replace the selected colour in the 
Current Drawing, in All drawings in the selected layers or in All drawings in the scene.

 7. In the palette list in the Replacement Colour panel, select the palette that contains the colour or 
texture swatch you want to replace the original colour or texture with.

 8. In the swatches list, select the colour or texture swatch you want to replace the original colour or 
texture with.

 9. Click OK.

A dialog displays showing the progress of the recolour operation. When finished, the original 
colour or texture is replaced with the replacement colour or texture in your drawing.
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Protecting Colours
T-ANIMPA-011-006

When you are finished inking one colour, you can lock it so if you ever paint over it accidentally, the work 
already done will not be affected. You can also use the Protect Colour feature to block the filling colours if you 
painted all of the animation in Line Art and you plan to repaint the lines.

When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you can protect 
In the Colour view, you can protect a colour swatch to avoid repainting or unpainting the zones linked to that 
swatch. If you using the Paint tool and this option is deselected, you will repaint or unpaint the protected 
colours on your drawings until you enable the option again.

How to protect colours

 1. In the Colour view, select the colour to be protected.

 2. Do one of the following:

 l Right-click and select Protect Colour.

 l From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

How to enable the Respect Protected Colours option

 1. Do one of the following:

 l In the Paint tool properties, click the Respect Protected Colour button.

 l From the top menu, select Drawing> Colour Protection > Respect Colour Protection.

 l Press Shift + S.
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Changing the Colour Display Mode 
The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The 
gradient colour swatches will be identified as (gradient). 
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About Palettes
T-ANIMPA-003-001

In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a base colour palette should be created for each character, prop and effect in the production. This 
is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of 
red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production.

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit 
the mood and atmosphere of the scene without having to repaint each element.
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About Advanced Palette Management
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is 
created in Harmony,it is stored in your scene's palette-library subfolder by default, and linked to your 
scene's palette list. However, Harmony has advanced palette management features that allow you to store 
and manage your palettes in manners that may better serve your production's needs. This is called Advanced 
Palette Lists mode. To enable these features, you must enable the Advanced Palette Lists preference.

The Advanced Palette Lists mode unlocks two features that can be very useful, especially for a big production:

 l Palette location: While palette files are stored in a scene's palette library directory by default, you can 
choose to store palettes in different locations, allowing you to easily share palettes between different 
scenes in a Harmony Server database. 

 l Palette list type: Whereas palettes are usually added to a scene's palette list, making them available to 
all the elements in your scene, you can also choose to add palettes to the palette list of individual 
elements (layers) in your scene. 

When the Advanced Palette Lists mode is enabled, Harmony open a dialog called the Palette Browser 
whenever you want to create, import, clone, duplicate or link to a palette, which allows you to decide your 
palette's location and palette list type. 

To use advanced palette lists, it is important to understand the difference between a palette's location and a 
palette list's level. For example, it is possible to add a palette file stored in a scene's palette library folder to an 
element's palette list. This can be useful if you wish to have the same palette file used by several specific 
elements in your scene, without copying it in the palette library folder of each element that uses it. The reverse 
is possible: You can add a palette file stored in an element's palette library folder to a scene's palette list, 
making the palette usable for all the elements in the scene, even if it is stored inside a single element's folder. 
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Enabling the Advanced Palette Lists Mode 

Advanced Palette Lists mode is disabled by default to avoid cluttering a basic workflow with too many options, 
but it enables palette management capabilities that are very useful for big productions. Mainly, this preference 
allows you to:

 l Create palettes inside a scene's environment, job or element palette-library directory, instead of the 
scene's palette-library directory. Storing a palette at the environment or job level can be especially 
useful if you want to use the same palette in several scenes without creating dependencies between 
animation scenes and colour model scenes. 

 l Create palettes for specific elements instead of the entire scene. You can do this by adding, importing or 
linking to a palette in an element's palette list. A palette in an element's palette list can only be used by 
that element. 

You can set up the Advanced Palette Lists option in the Preferences panel.

How to set the Advanced Palette Lists mode

 1. Do one of the following:

 l From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium 
> Preferences (macOS).

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. Select the Advanced tab.

 3. In the Advanced Options section, select  the Advanced Palette Lists option.

 4. Click OK.
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About Scene and Element Palette Lists

By default, you can only add palettes to a scene's palette list. With the Advanced Palette Lists preference 
enabled, you can choose to store add palettes to the palette list of individual elements if you choose. Here is an 
explanation of the two different levels of palette lists:

 l Scene palette list: This palette list and its palettes are available for and can be used in all of the scene's 
elements. Hence, it is the most simple and least restrictive approach, and is the type of palette used by 
Harmony when Advanced Palette Lists mode is disabled. It is most recommended to add your palettes 
to your scene's palette list if you are doing digital animation, where character models can be made of 
many different elements that must use the same palette. 

 l Element palette list: A palette list associated with a single element in your scene. An element is the 
container for the drawings used by a drawing layer. Hence, when an element has a palette list with its 
own palettes, only the drawings in that element can use the colours in these palettes, and the palettes 
in this element's palette list will only be shown in the Colour view when a drawing from this element is 
selected. 

Using element palette lists as certain advantages, depending on your type of production:

 l In paperless and traditional animation projects, characters are usually drawn on single elements. Hence, 
you can use this to associate characters in a scene to their colour palette.

 l If a scene requires a lot of palettes, linking those palettes only to elements that need them rather than 
to the whole scene can help declutter your palette list. 

 l When a palette and its clone are in the scene's palette list, Harmony will only use whichever palette is 
highest in the list. If you want one element to use the original palette and another element to use the 
cloned palette, you can do so by adding the right palette to each element's palette list.
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About Palette Storage Locations

Palettes can also be stored in four different locations. The best location to store palettes depends on the type 
of production, the purpose of the palette, your pipeline and your backup plan. Here is an introduction to each 
type of palette location and their purpose:

 l Element: The palette-library folder inside an element's folder in the scene. This is the recommended 
location if you are adding palettes to the palette lists of individual elements. 

 l Scene: The palette-library folder inside the scene's folder. This is the default location when creating a 
palette in the scene's palette list, and is the location chosen by Harmony when creating a palette with 
the Advanced palette Lists preference disabled. This is a suitable location to store the palettes of 
characters, props and backgrounds used in a single scene, a small project, or any production that uses 
Harmony Stand Alone. 

 l Job:  For Harmony Server, this is the palette-library folder inside the job's folder on the database server. 
This is the recommended location if you want to share the same palette between several scenes in the 
same job, like for characters, props and backgrounds that are used in across entire episodes or smaller-
scale projects. 

 l Environment: For Harmony Server, this is the palette-library folder inside the environment's folder on 
the database server. This is the recommended location if you want to share the same palette between 
several scenes in the same environment, like for characters, props and backgrounds that are used across 
an entire series or movie. 

It is actually possible, but not recommended, to use palettes that are from a different job or environment. For 
example, if you wish to store a colour model's palette in the colour model's scene, you can make animation 
scenes that user this character link to the palette in the colour model's scene. However, this means your scene 
will depend on the colour model's scene and its palette being available at this location to render its colours. If 
the colour model's scene is moved or deleted, or if you export the animation scene and import it in another 
database, it will not be able to retrieve the palette. Hence, you would have to export the colour model along 
with the animated scene, and import it into the other database. If you were to store the colour model's palette 
in its element folder, this would have the same restriction, with the added risk of breaking links to the original 
palette if the character model's element is renamed. However, if you are sure that the structure of your 
Harmony database will remain static and available at all time and at all steps of your production, then you can 
store your palettes in whichever job or environment you see fit.

Another reason why it is better to store shared palettes in a scene's job or environment is because, when you 
export a Harmony scene, you can choose to export the palettes in the scene's job or environment palette 
libraries along with it. These palettes are then stored with the exported scene and, when importing the scene 
back into the database, you can choose to import the job and environment palettes that were exported with it 
back into the scene's job and environment. 

Even in Harmony Stand Alone, you can store palettes at the job or environment level, even though Harmony 
Stand Alone scenes do not have a job or an environment. When you do this, palettes are stored inside a 
provisional jobs or environments directory inside the scene directory. If you import your scene to a Harmony 
Server database, you can choose to import the files located in that scene's provisional job and environment into 
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the scene's job and environment. Hence, when using Harmony Stand Alone, you should only store palettes at 
the job or environment level if you intend to import your scene in a database later.

If you wish, you can also link a palette from any location on your machine or network to a palette list. This can 
be useful if you have are doing a project in Harmony Stand Alone, and want all your scenes to source their 
palettes from the same location. However, it is not recommended to do this with Harmony Server projects, as 
opening a scene linked to an external palette on a different workstation will require that palette to be in the 
same file path as on the workstation where the palette was linked.

NOTE 

In Harmony Server, even if you store palettes in a job or environment, they will not become 
immediately accessible to the scenes inside that job or environment. You must still add them to the 
scene's palette list, or to the palette list of one of its elements, before you can use the palette. 
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About Exporting Palettes

It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in 
the database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or 
Environment level. The palette files can be accessed from any scene of any project.

When you export scenes from Harmony to either archive or send them to other users or studios, you can choose 
to export it with palettes stored in the scene's own job or environment, but if your scene uses palettes stored in 
other jobs, environments, or in any other location, those palettes will not be exported. Hence, if you wish to 
use the same palette for several scenes, it is recommended to store that palette at the environment or job level 
to avoid ever facing a situation where a scene no longer has access to its palette. 

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from 
Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2. 
If Scene 2 was linked to any of these, the system will create a recovery palette the next time Scene 2 is opened 
in another Harmony system.
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About Backing Up and Recovering Palettes

Although Harmony Server opens palettes in read-only mode by default, there is always the possibility of 
palettes that are shared between scenes getting modified or their swatches getting deleted by accident. That 
is why it is a good idea to copy and back up your palette libraries, your master palette directories and your 
colour models. 

If you open a scene and a palette file happens to be missing, it will still appear in the palette list for that scene 
or element, with a strike through across its name. 

When Harmony attempts to load a drawing that uses colours from a missing palette, or colours that were 
removed from their palette, it will display the zones painted with the missing colours in red. Then, it will 
prompt you to recover the missing colours into a recovery palette. A recovery palette is based on the colour 
information which Harmony stores in each drawing as a backup mechanism. This palette is stored at the scene 
level, and is not shared or sourced externally. 

Whether you choose to perform colour recovery or not, your artwork will preserve the colour IDs which 
Harmony uses to associate brush strokes, pencil lines and filled zones with the colour swatches in your 
palettes. Hence, if you recover your original palette, you can just import or link it back to your scene—and 
remove the recovery palette, if you have one—and Harmony will automatically associate your artwork with the 
original palette again. You will not have to repaint your drawings. 

You can backup your palettes by copying them manually using your operating system's shell, or by cloning 
them using the Palette Operations dialog. In both cases, the palette preserves the colour IDs, making it easy to 
replace a missing palette with its backup. For more information on the Palette Operations, see Palette 
Operations on page 721.
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About the Palette List
T-ANIMPA-003-006

A palette list is a file containing all of the links to the palette files. Each scene created has its own palette list. 
However, it is also possible to assign palette lists to individual layers in a scene. To be able to do that, you must 
first enable Advanced Palette Lists mode—see Enabling the Advanced Palette Lists Mode  on page 683.

 l Scene Palette List 

The scene palette list is simple to understand and convenient. Every element in your scene can use 
colours from a palette in your scene's palette list. This is especially useful for digital animation, as a cut-
out character model will often be divided into dozens of different layers which will all use the same 
palette.

The scene palette list is stored inside the scene's directory in a file named PALETTE_LIST, and its 
palettes are usually located in the scene's palette-library subfolder.

 l Element Palette List
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An element palette list is a list of palettes that is associated to an individual layer (element) in your 
scene. Only the drawings inside that element are able to use the colours in the palettes of its element 
palette list. The palettes in an element palette list will only be visible in the colour view when a 
drawing from that element is selected. This can be useful if you are doing traditional animation in which 
characters are usually drawn on a single layer, so you can assign each character to their individual 
palette.

An element's palette list is stored in a file named PALETTE_LIST, inside the element's directory in the 
scene's elements subdirectory. An element's palettes can be stored in palette-library 
subdirectory of the element's directory.

If you have the Advanced Palette List preference enabled, then you can build a palette list by creating palettes 
in different locations, or linking to palettes from different locations. You might notice that the icon left of each 
palette in the list looks different depending on where the palette is sourced from. The following is a table 
explaining the meaning of each icon in the list. 

Icon Description

Indicates that the palette is stored at the same level as its palette list. For example, a palette that is 
stored in the scene's palette library and which is listed in the scene's palette list, or a palette that is 
stored in an element's palette library and which is listed in that same element's palette list. 

Indicates that the palette file is stored in an external location, such as a different scene, an element in a 
different scene, a job other than the scene's job, an environment other than the scene's environment, or a 
custom location on your file system or network. This means the palette is liable to be missing if it is 
moved from its original location, or if the scene is exported from the database into an offline scene or to 
a different database.

This indicates that the palette is stored at a higher level than its palette list, making it a shared palette. 
For example, a palette in your scene's palette list that is stored in the palette library of the scene's job or 
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environment, or a palette in an element's palette list that is stored in the palette library of the scene.

Indicates a potentially dangerous situation. For example, a palette file that is stored in one of the scene's 
element folders, but which is added to your scene's palette list. The whole scene can use the palette, 
but since it's stored inside an element, deleting that element will make your whole scene lose access to 
that palette. 
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Showing and Hiding the Palette List

By default, the palette list is enabled. If you want to only use one palette for all of your scenes, you can disable 
the palette list simply by collapsing it, which will give more vertical space to your colour swatch list:

How to show or hide the palette list

 1. In the Colour view, right over the palettes list, click on the expand/collapse arrow to expand or 
collapse the palettes list. 
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Locking and Unlocking the Palette List

In Harmony Server, palette lists are open in read only mode when loading a scene. This is to prevent users 
from accidently removing palettes. To create, link to, reorder or remove palettes, you must first unlock your 
scene's palette list. 

How to lock and unlock to the palette list

 1. Do one of the following:

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option 
is checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.

693



Displaying Colour and Pencil Texture Palettes

Besides regular colour palettes, Harmony also supports pencil texture palettes. A pencil texture can be 
combined with a colour to create pencil lines of various styles, ranging from styles reproducing traditional 
drawing tools such as chalk or felt to simple patterns like dots and circles. For more information, see About 
Pencil Line Textures on page 383.

By default, the Colour view only lists colour palettes in its palette list. You can make the Colour view list only 
pencil texture palettes, or all types of palettes.

How to change the palette list's filter to show colour palettes, pencil texture palettes, 
or both

 1. In the Colour view, do one of the following:

 l If you only want to only see colour palettes, press the Show Colour Palettes  
button.

 l If you only want to see texture palettes, press the Show Texture Palettes  button.

 l If you want to see both types of palettes, press the Show All Palettes  button.

NOTE 

If you open the Link Palette dialog, it will only list either colour palettes or pencil texture palettes, 
depending on which filter is currently applied to the palette list. If the palette list is set to display 
all palettes, the dialog will list the type of palettes of the last palette list filter that was used.
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Creating a Palette
T-ANIMPA-003-002 

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony Premium is set to the Basic mode. For simple productions, it is recommended 
to use the Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. 
When you use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element.To enable Advanced Palette Lists, see Enabling the Advanced Palette 
Lists Mode  on page 683.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

      How to create a new palette (Basic palette list mode)

 1. Do one of the following:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Create Palette dialog box opens.

 2. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains 
information to be easy to identify, such as the name of the character and information about the type 
of setting for this palette, if any.

 3. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you 
want to create a pencil texture palette—see About Pencil Line Textures.

 4. Click OK.

The palette appears in the drawing element’s palette list.
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How to create a palette (Advanced palette list mode)

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 
which you want to create a palette in the Timeline, Xsheet or Camera view. 

 2. Do one of the following:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Palette Browser dialog box opens. 

 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 
using Harmony Server, you can store the palette in any environment, job, scene or element on your 
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 
or inside its provisional job or environment. For more information, see About Palette Storage 
Locations on page 685.
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 4. In the New Palette Name field, enter the name for the new palette. The palette list above this field 
lists the palettes that already exist in the selected location. Make sure you enter a name that is not 
already used by another palette. 

 5. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you 
want to create a pencil texture palette—see About Pencil Line Textures.

 6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 7. Click OK. 

The new palette appears in the palette list.

697



Linking a Colour Palette
T-ANIMPA-003-004

Linking a palette means adding a palette to your scene's palette list, or to an element's palette list, without 
making a local copy of that palette in your scene's palette library. This means your scene will depend in this 
palette remaining in its location in order to render its colours, but it allows you to reuse the same palette files 
for several scenes, making sure that recurring characters and objects keep their original colours across a 
production and that any late change done to their colour scheme can be quickly reflected across all your 
scenes. 

In Harmony Server, environments, jobs, scenes and elements can all have their own palette library, and you 
can link to a palette from the palette library of any environment, job, scene or element in your database. 
However, to make it easier to ensure scenes do not lose access to their palettes, it is recommended to only link 
to palettes from within the scene's own environment, job, scene or elements. The most important reason for 
this is that if you export a scene that uses palettes from other jobs, environments, scenes or elements, these 
palettes will not be exported. Hence, they will be missing if you import them in a different database. However, 
you can export a scene with all of its assets along with the assets contained in its own job and environment. 

You can also link to palettes from any location on your machine or network, but this is not a recommended 
approach for Harmony Server projects, as your scene will require the palette to be in the same file path if you 
open it on a different workstation—see Linking to an External Palette on page 700.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to link a colour palette

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 
which you want to create a palette in the Timeline, Xsheet or Camera view. 

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Link. 

 l Right-click and select Link.

 l Click the Link Palette  button.

The Palette Browser: Link Palette dialog box opens.
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 3. In the Palette Location panel, browse to the location of the palette you want to link to.

 4. In the Palette list, select the palette you want to link to.

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

The palette appears in the Colour view.
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Linking to an External Palette
You can link to a palette from anywhere on your machine or network from within a palette list. This can be 
useful if you are working on a Harmony Stand Alone project on a single workstation, and wish to source 
palettes that will be used in several scenes from the same location. 

NOTE 

Linking to an external palette will cause your scene dependent on that palette being located in 
the same location it was linked from originally. This means that your scene will be missing colors if 
your palette has been renamed, moved or deleted, or if you try to open the scene on a different 
machine without first copying the palette in the same location. Hence, this is not a recommended 
workflow for large scale productions or for Harmony Server scenes. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to link to an external palette

 1. In the Colour view, click on the Create Palette  button to create a palette to be used as external.

 2. Save your scene by selecting File > Save from the top menu or by clicking the Save   button or 
press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).

 3. On your computer or server, create a master directory. Ideally, this should be created in your Root 
folder to keep it within the project directory. You could also place it inside your Colour Model’s 
subdirectory.
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 4. Name the folder appropriately, for example: Joe_master_palette.

 5. From your operating system, browse to your Toon Boom Harmony Premium scene and open the 
palette-library folder.

 6. Select and copy your palette *.plt file to copy it to the master palette directory.

 7. Create a new Toon Boom Harmony Premium scene, or open the scene in which you want to link the 
palette.

 8. If you want to add the palette to an element's palette list, select a drawing from the element for 
which you want to create a palette in the Timeline, Xsheet or Camera view. 

 9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

 10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to 
link.
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 11. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 12. Click OK.

The linked palette appears in the Colour view, with the External  icon next to it to indicate that it 
is located outside of your scene's structure. 

702

Harmony 21 Premium User Guide                          



Chapter 6: Painting and Colours

Importing a Colour Palette
T-ANIMPA-003-005

You can import an existing palette from your file system or network into your scene. This will create a copy of 
the palette file and add it to your palette list. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to import a palette into your project                                      (Basic palette list mode)                

 1. Do one of the following:

 l From the Colour menu , select Palettes > Import. 

 l Right-click on the palette list and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes 
by browsing to the palette-library sub-folder of the scene's folder.

 3. Click Open.

The Import Palette dialog box appears.

 4. In the New Palette Name field, enter the name for the imported palette.

The palette is copied to your project and added to your scene's palette list.

How to import a palette into your project (Advanced palette list mode)

 1. If you want to add the palette to an element's palette list, select a drawing from the element for 
which you want to create a palette in the Timeline, Xsheet or Camera view. 
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 2. Do one of the following:

 l From the Colour menu , select Palettes > Import. 

 l Right-click on the palette list and select Import.

The Browser window opens.

 3. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes 
by browsing to the palette-library sub-folder of the scene's folder.

 4. Click Open.

The Palette Browser dialog box appears.

 5. In the Palette Location panel, select the location where you want to store the palette file. If you are 
using Harmony Server, you can store the palette in any environment, job, scene or element on your 
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 
or inside its provisional job or environment. For more information, see About Palette Storage 
Locations on page 685.

 6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 7. In the New Palette Name field, name the imported palette.

The palette is copied to your project and added to your scene's palette list.
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Consolidating Used Colours Into a Single Palette
Using the Create Palette from Selection dialog, you can instantly generate a single palette that contains all 
the colours used in your artwork, and no other colours. This can be useful if you have used colours from several 
different palettes to design the colours for a character, background or prop, and want this asset to have its 
own dedicated palette. 

NOTE 

The Create Palette from Selection dialog uses the colours in all the drawings in the selected layers, 
even drawings that are not exposed. 

How to create a single palette with the colours used by one or several drawings

 1. In the Timeline, Camera, Xsheet or Node view, select all the layers for which you want to create a 
single colour palette.
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TIPS 

 l To select multiple layers or nodes, press and hold the Ctrl (Windows/Linux) or ⌘  
(macOS) key, then click on each layer or node you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by 
clicking on the first layer you want to select, then, while holding Shift, clicking on 
the last layer you want to select. Every layer in-between will also be selected. 

 l If your scene has a complex layer hierarchy, you can expand all the layers in the 
Timeline view by pressing 9 before selecting all the layers in your scene.

 l To select all layers in your scene, select Edit > Select All in the top menu or press 
Ctrl + A (Windows/Linux) or ⌘  + A (macOS).

 l To select all but a few specific layers, select the layers you want to exclude, then 
select Edit > Invert Selection in the top menu or press Ctrl + Shift + I 
(Windows/Linux) or Shift + ⌘  + I (macOS).

 2. In the top-left corner of the Colour view, open the  View Menu and select Palettes > New 
Palette from Selected Drawings.The Create Palette from Selection dialog appears.

NOTE 

If the Advanced Palette Lists preference is enabled, the dialog will also have a palette 
browser to allow you to select where to store the palette and whether to associate the 
palette to the scene or to an element. For information on how to create a palette in 
Advanced Palette Lists mode, see Creating a Palette.

 3. In the Name field, type in the name for the palette to create.

 4. In the Palette Type drop-down, select Colour if you want to create a palette containing all the 
colours, gradients and bitmap textures in the selected layers, or select Pencil Texture if you want to 
create a palette containing all the pencil textures in the selected layers.

 5. If you want the swatches in the new colour palette to have different colour IDs than the ones 
currently used by the selected drawings, check the Generate New Colour IDs and Recolour 
Selected Drawings option. 
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NOTES 

 l This option creates a palette with new colour IDs, and replaces the old colour IDs in 
your artwork with the new ones. This will typically not cause any visible change, 
and it will prevent your new palette from using the same colour IDs as the palettes 
that are currently in your scene. This is important because, when two colour 
swatches in two different palettes have the same colour ID, the zones filled with 
that colour ID will appear in the colour in the top-most palette. If you want to 
prevent this, it is recommended to check this option.

 l If there are any Colour-Override in the selection, they will not be updated to use the 
new colour IDs, which will cause them to no longer work with your artwork unless 
you reconfigure them manually. Using this option is not recommended in this case.

 6. Click on OK. 

A new palette is generated containing all the colours used in all the drawings in the selected layers 
and is added to the palette list.
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Renaming a Palette
T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will 
not be deleted, so you can add it back to your palette list later if you need it. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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NOTE 

If you wish to delete the palette file, you can select the Remove and Delete From Disk option from 
the same menu. You will be prompt to confirm the deletion. Note that the palette will be deleted 
from your file system, and there will be no way to recover it. 
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Duplicating a Palette 
A duplicated palette is a simple copy of the original palette. When you duplicate a palette, the duplicated 
palette will have the same colour names and values, but will have different colour IDs so that Harmony does 
not mix it up with its original palette. This is useful when you want to create different palettes for similar 
models, but want to avoid having to create the palette and its colours all over again. You can just start with 
your duplicate palette, tweak the colours and  add and remove colours as needed.

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to duplicate a palette                                      (Basic palette list mode)                 

 1. In the Colour view, select a palette to duplicate.

 2. Do one of the following: From the Colour  menu, select Palettes > Duplicateor right-click and select 
Duplicate.

 l Right-click on the palette and select Duplicate.

 l Open the Colour menu , then select  select Palettes > Duplicate.

The Duplicate palette dialog box opens

 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 
is based on the original palette name followed by "-copy". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 
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 4. Click OK.

The duplicated palette appears in the palette list.

How to duplicate a palette (Advanced palette list mode)

 1. In the Colour view, select a palette to duplicate.

 2. Do one of the following: From the Colour  menu, select Palettes > Duplicate or right-click and select 
Duplicate.

 l Right-click on the palette and select Duplicate.

 l Open the Colour menu , then select  select Palettes > Duplicate.

The Palette Browser dialog box opens. 
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 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 
using Harmony Server, you can store the palette in any environment, job, scene or element on your 
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 
or inside its provisional job or environment. For more information, see About Palette Storage 
Locations on page 685.

 4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 
is based on the original palette name followed by "-copy". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 6. Click OK.

The duplicated palette appears in the palette list.
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Cloning a Palette 
Cloning a palette creates an exact copy of the palette, where each colour swatch has the same colour ID as in 
the original palette, but which you can modify independently afterward. Since painted zones in drawings are 
associated to their colour by their colour ID, this means that any drawing colored with the original palette can 
have its colours replaced with the cloned palette's colours just by switching the palette in the scene with the 
cloned palette. 

A good example of how this can be useful is when you want to make variants of a character's palette. A 
character usually has only one master palette, although there are times when the characters are placed in 
different lighting conditions and require a different colour shading. The night palette is a popular choice when 
a scene or sequence changes from day to night. Instead of creating a different palette for the character and 
repainting all of its zones with the night palette, you can just clone the character's master palette, tweak its 
colours, and the character will have its original colours or its night colours depending on which one of the 
palettes is in the palette list, without having to repaint your drawings. 

When a palette and its clone are present in the same scene, Harmony uses the palette that is highest in the 
list. If one palette clone is present in the scene's palette list and another clone is present in the element's 
palette list, the element will use the palette in its own palette list. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to clone a palette                                       (Basic palette list mode)                 

 1. In the Colour view, select a palette to clone.
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 2. Do one of the following: From the Colour  menu, select Palettes > Clone or right-click and select 
Clone.

 l Right-click on the palette and select Clone.

 l Open the Colour menu , then select  select Palettes > Clone.

The Clone palette dialog box opens

 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 
is based on the original palette name followed by "-clone". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 

 4. Click OK.

The cloned palette appears in the palette list.

How to clone a palette (Advanced palette list mode)

 1. In the Colour view, select a palette to clone.

 2. Do one of the following: From the Colour  menu, select Palettes > Clone or right-click and select 
Clone.
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 l Right-click on the palette and select Clone.

 l Open the Colour menu , then select  select Palettes > Clone.

The Palette Browser dialog box opens. 

 3. In the Palette Location panel, select the location where you want to store the palette file. If you are 
using Harmony Server, you can store the palette in any environment, job, scene or element on your 
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element, 
or inside its provisional job or environment. For more information, see About Palette Storage 
Locations on page 685.

 4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name 
is based on the original palette name followed by "-clone". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 

 5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette 
List, or to the Element Palette List of the currently selected element. Note that in the latter case, 
the palette will only be usable by the element. For more information, see About Scene and Element 
Palette Lists on page 684.

 6. Click OK.

The cloned palette appears in the palette list.
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NOTE 

You can modify your cloned palette by changing its colour swatches individually, or you can use the 
Tint Panel to change all of the palette's colour swatches simultaneously—see Tinting a Palette's 
Colour Swatches on page 718.
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Tinting a Palette's Colour Swatches
You can use the Tint Panel dialog to offset, blend or mix all the different colour swatches in a palette 
simultaneously. This can be useful if you want to give a cloned palette a different tint, for example to make a 
night-themed version of a character's master palette. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the selected palette by 
doing one of the following:    

 l In the Colour view, make sure the Edit Palette Mode  toggle button is pressed in.

 l In the palette list of the Colour view, right-click on the selected palette and select either Get 
Rights to Modify Palette or Get Rights to Modify All Palettes.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette or Get Rights 
to Modify All Palettes.

How to tint a palette

 1. In the Palette list, select the palette you want to tint.

 2. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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 3. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

 4. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

 5. Select the Preview option to see a preview of the colours while you adjust them.
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Reordering Palettes in the Palette List
You may want your palettes to be listed in a specific order. In a lot of cases, this is strictly a matter of 
convenience. However, if your palette list contains palettes that have been cloned off each other, Harmony will 
use the palette that is located the highest in the list to determine the colours to use in the drawings. Hence, if 
you are using cloned palettes, you must mind the order of your palettes in the palette list. For more information, 
see Cloning a Palette  on page 714.

NOTE 

If a palette in the scene's palette list has been cloned into an element's palette list, Harmony will 
use the palette in the element's palette list for this element. 

NOTE 

If you are using Harmony Server, make sure you have the rights to modify the palette list by doing 
one of the following:                     

 l From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is 
checked

 l Right-click on the palette list and select Get Rights to Modify Palette List.

 l From the Colour view menu , select Palettes > Get Rights to Modify Palette List

How to reorder palettes in the palette list

 1. Select the palette you wish to reorder.

 2. Do one of the following:

 l In the Palette list toolbar, click the Up  or Down  buttos.

 l From the Colour View menu, select Palettes > Move Up or Move Down. 
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Palette Operations
When you start Toon Boom Harmony Premium connected to the database, you can access the Palette 
Operations dialog box which lets you clone, rename, or delete palettes in your database, without having to 
open a scene or browse the database's file system in your operating system's shell. 

NOTE 

The Palette Operations dialog box never makes any change to any palette list in your database. 
All it allows you to do is manipulate palettes files. You should be careful not to rename or delete 
palettes that are required by some of your existing scenes, or Harmony will be unable to locate 
those palettes when you open one of those scenes.
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Opening the Palette Operations Dialog Box

You can open the Palette Operations dialog box in Harmony Server.

How to open the Palette Operations dialog box

 1. Start Harmony and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

The Palette Operations dialog box opens. 
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Cloning a Palette in the Palette Operations Dialog Box

From the Palette Operations window, you can clone palettes in Harmony Server.  

How to clone a palette in the Palette Operations dialog box 

 1. Select the palette you want to clone at the location and level in which it was stored. 

 2. Click Clone. 

A Warning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every time 
you perform this operation.

 4. Click Yes.

The Palette Browser dialog box opens. 

 5. Select the level to store the palette file.
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 6. In the New Palette Name field, enter the name of your palette. 

 7. Click OK.
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Renaming a Palette in the Palette Operations Dialog Box

You can rename palettes in the Palette Operations dialog box in Harmony Server.

How to rename a palette in the Palette Operation dialog box

 1. Select the palette you want to rename at the location and level in which it was stored. 

 2. Click Rename.

A Warning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every time 
you perform this operation.

 4. Click Yes.

The Rename Palette dialog box opens. 

 5. Type in a name for the palette. 
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 6. Click OK. 
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Deleting a Palette in the Palette Operations Dialog Box

You can delete palette files from the Palette Operations dialog box in Harmony Server. 

How to delete a palette in the Palette Operation dialog box

 1. Select the palette you want to delete at the location and level in which it was stored. 

 2. Click Delete. 

A Warning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every time 
you perform this operation.

NOTE 

It is not recommended to disable the warning message as deleting a palette 
cannot be undone. 

 4. Click Yes.
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that 
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, 
and so on.

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and 
paint process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do 
not belong in the drawing, extra floating artwork around the drawing that must be removed), painting the 
lines and filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to 
clean, only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by 
assigning a set of colours to each character, prop or effect. The colour styling artist will create a new palette 
and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each 
colour is known as a colour swatch—see About Palettes on page 680. 
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About Colour Models
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That 
drawing can be used and loaded in any of your Harmony scenes—see Painting Drawings on page 743. 

Once a drawing is loaded in the Model view, you can use the Model view’s  Colour Eyedropper tool to select 
a colour from the model and use it to paint in your Camera or Drawing view without having to pick the colour 
from the colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the 
character directly from its colour model and paste these elements into the Drawing or Camera views.
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Loading Colour Models

T-ANIMPA-004-005

You can load any TVG drawings in your Model view. To avoid browsing for models every single time you work 
on your scene, you can store default models in your scene and load those. 

How to load a colour model from the Timeline or Xsheet view

 1. In the Timeline or Xsheet view, select a drawing (*.tvg).

 2. Bring the model into the Model view by doing one of the following:

 l In the Timeline view, drag the selected drawing and drop it directly in the Model 
view.

 l From the Model View menu, select Use Current Drawing as Model.

NOTE 

The Use Current Drawing as Model button is not part of the default Model View 
toolbar. To add the Use Current Drawing as Model button to the Model toolbar, 
right-click in the Model view toolbar and select Customize. Drag the Use 
Current Drawing as Model  button from the Available Tools column and move 
it to the right (Toolbar) column. Click OK.

 l In the Model View toolbar, click Current Drawing  button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive

 1. Do one of the following:

 l In the Model View toolbar, click the Import Model  button.

 l From the Model View menu, select Import Model. 

 l Select File > Import > Colour Model.
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 2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database for 
Harmony Server.

 3. Click Open. 

The model appears in the Model view.

How to load the default models

 1. In your scene’s folder, create a new folder and name it models.

 2. On your hard drive, copy the *.tvg drawing files you want to use as colour models in your scene.

 3. Paste the copied models in the models folder you created.

 4. Do one of the following:

 l From the Model View menu, select Load Default Models. 

 l In the Model View toolbar, click the Load Default Model  button.

NOTE 

The Load Default Model button is not part of the default Model View toolbar. To 
add the Load Default Model button to the Model toolbar, right-click in the Model 
view toolbar and select Customize. Drag the Load Default Model  button from 
the Available Tools column and move it to the right (Toolbar) column. Click OK.

How to load a single drawing from the Library view

 1. In the Library view, click the template containing the drawing to import in the Model view.

 2. Right-click on the template and select Open As Folder.

 3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders 
until *.tvg files appear on the right side.
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 4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.

How to load a template with multiple drawings from the Library view

 1. In the Library view, find the template you want to import in the Model view.

 2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.

 3. Use the Previous Model  and Next Model  buttons in the Model View toolbar to view all the 
drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.
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How to load a symbol from the Library view

 1. In the Library view’s left side, select the Symbols folder.

 2. In the Library view’s right side, select the symbol you want to use as a model, and drag and drop it 
into the Model view.

 3. Use the Previous Model  and Next Model  buttons in the Model View toolbar to view all the 
drawings contained in the template. This can often be the front, profile, and 3/4 views of a 
character.
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Clearing Colour Models

You can remove colour models from the Model view. 

How to clear a colour model

 l In the Model View menu, select Clear Model or press Del.
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Flipping Between Models

T-LAY-002-001

Once your models are loaded in the Model view, you can flip through them using a keyboard shortcut or 
toolbar buttons.

How to flip between models

 1. Do one of the following:

 l In the Model View toolbar, click the Next Model   or Previous Model  buttons.

 l From the Model View menu, select Next Model or Previous Model. 

 l Press F and G.

The previous or next model appears in the Model view.
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Copying Colour Models

You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. In the Model View toolbar, select the Select  tool.

 2. In the Model view, select your model.

 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing 
Object, or select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline 
or press Ctrl + V (Windows/Linux) or ⌘  + V (macOS). 

The model appears in the selected view.

How to copy part of the model from the Model view

 1. In the Model View toolbar, select the Cutter  tool or press Alt + T.

 2. In the Model view, use the Cutter tool to create a selection around the part of your model that you 
want to copy.
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 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the following:

 l Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

 l Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V 
(Windows/Linux) or ⌘  + V (macOS). 

The model appears in the selected view.
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About Dirt Cleanup
T-INK-002-001

When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. 
These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

If there are some marks that cannot be removed with the automated tools, you can erase them with the Eraser 
tool or select them with the Select tool and then delete them. It's always safer to select and delete them than 
to erase them, so you do not overlook anything.
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Removing Dirt

T-INK-002-002

The Remove Dirt tool selects small dots and hairs on the drawing.

Raising the Remove Dirt level will select bigger dots. When selecting larger dots, be careful not to lose small 
details like pupils and nostrils. Once you have chosen the level, you can apply it to the current drawing or the 
entire animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

How to use the Remove Dirt tool

 1. Do one of the following:

 l From the top menu, select Drawing > Clean Up > Remove Dirt.

 l From the Camera or Drawing View  menu, select Drawing > Clean Up > Remove Dirt.

 l Press Shift + D.

 2. Increase the Remove Dirt value by moving the slider to the right.

 3. Select the Apply to All Drawings option if you want to apply the operation to all drawings in the 
layer.
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Removing Dirt Outside the Selection

T-INK-002-003

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is 
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, 
it can result in large output files, especially if you work in high-definition resolutions.

How to clean dirt with Remove Art Outside Selection

 1. In the Tools toolbar, select the  Select  tool.

 2. In the Tool Properties view, click the Permanent Selection  button.

 3. Draw a selection around the animation making sure to include the entire animation sequence.

 4. In the Camera or Drawing View  menu, select Drawings > Clean Up and one of the following 
options:

 l Remove Art Outside Selection to delete artwork outside your selection on a single 
drawing.

 l Remove Art Outside Selection on All Drawings to delete artwork outside your 
selection on all the drawings.

The art outside the selection is removed.
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Removing the Art Inside the Selection

T-INK-002-004

You can delete any art inside a selection with the Remove Art Inside Selection option. We recommend that you 
clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in large 
output files, especially if you work in high definition resolutions.

You can simultaneously apply this operation to all your drawings in the layer by using the Remove Art Inside 
Selection on All Drawings command.

How to clean dirt with Remove Art Inside Selection

 1. In the Tools toolbar, click the Select tool or press Alt + S.

 2. To apply the action to your entire animation, click the Permanent Selection  button in the Tool 
Properties view.

 3. In the Camera or Drawing view, draw a selection around the animation. Make sure the area is large 
enough to include all the zones to be cleaned up on all drawings.

 4. From the top menu, select Drawing > Clean Up > Remove Art Inside Selection to delete artwork 
inside your selection on one single drawing. You can also press Delete.

 5. To apply the action on all your drawings in the layer, select Drawing > Clean Up > Remove Art 
Inside Selection on All Drawings to delete artwork inside your selection on all the drawings.
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Removing Hair

T-INK-002-005

The Remove Hair command lets you remove any small strokes created in the Colour Art layer from very thick 
lines or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the 
drawing.

How to use the Remove Hair tool

 1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Clean Up > Remove Hair.

The Remove Hair dialog box opens.

 4. Move the slider to the right to increase the number and length of hairs to be selected. 

 5. Select the Apply to All Drawings option if you want to apply the operation to all the drawings in 
the layer.

 6. Click OK.
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Painting Drawings
T-HFND-004-011

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several 
different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines 
defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap 
option.

NOTE 

To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. In the Timeline or Xsheet view, select the cell on which you want to paint.

 2. Do one of the following:

 l In the Tools toolbar, click the Paint  tool.

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and filled zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or filled zone will 
remain unchanged.
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 l The Repaint   mode paints everything it touches except empty zones. Any zone 
that is not painted will remain intact.

 l The Unpaint   mode unpaints everything it touches, including empty and filled 
zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a 
lasso or marquee selection to paint several zones or pencil lines at the same time.

NOTE 

The last colour you select while using the Paint tool will be used the next time 
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you select the Paint tool if you're using the unlocked painting tools in the Colour 
view.

Authors
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        Christopher Diaz

chrisdiazart.com
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Painting Several Drawings Simultaneously

You can use the Paint tool on several drawings in the same layer at the same time. When you set up the Paint 
tool to work on several drawings, if you click on a colour zone in the current  drawing to fill it, it will fill any 
colour zone located where you clicked in other drawings as well. This can be useful if you have several 
drawings with colour zones that mostly overlap each other, such as in a typical walk cycle, or in any animation 
where the character mostly stays in place:

There are two approaches to painting several drawings at the same time. Both are options available in the 
Tool Properties view:

 l  Apply to All Frames: When you click on a colour zone in the Camera or Drawing view, it will fill the 
area you clicked on in every exposed drawing in the current layer.

 l  Apply to Onion Skin Range: When you click on a colour zone in the Camera or Drawing view, it will 
fill the area you clicked on in every drawing that is displayed in the Onion Skin. This method allows you 
to only fill a specific range of drawings, and allows you to see those drawings in the Camera or Drawing 
view as you fill them.

How to paint a specific range of drawings simultaneously

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to paint.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to paint:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
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next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Paint tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the  Camera or Drawing view, click in an area where the colour zones for all the drawings in the 
Onion Skin overlap each other to fill them all simultaneously. 

How to paint all exposed drawings in a layer simultaneously

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to paint. 

 2. In the Tools toolbar, select the  Paint tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, click in an area where the colour zones for most or all of your 
drawings overlap each other to fill them all simultaneously. 
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Painting Several Layers Simultaneously

You can use the Paint tool to fill drawings in several layers simultaneously. When you set up the Paint tool to 
work on several layers, if you click on a colour zone in the current  drawing to fill it, it will fill any colour zone 
located where you clicked in the drawings in the other layers as well. 

There are three ways to paint several layers at the same time:

 l By selection: If you select several layers in the Timeline, Node or Xsheet view, you will be able to paint 
on all the selected layers simultaneously.

 l  Apply to All Visible Layers mode: By enabling this mode, you will be able to paint in all the layers 
that are visible in the Camera view simultaneously. 

 l  Apply to Synced Drawing Layers mode: By enabling this mode, you will be able to paint in the 
current layer as well as in any layer that is synced to that layer simultaneously. This can be very useful if 
the artwork in the synced layers must be filled with the same colours.

NOTE 

You can only paint several layers simultaneously in the Camera view. 

How to paint a drawing in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to paint are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to paint. 

 2. In the Tools toolbar, select the  Paint tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers or  Apply to Synced 
Drawing Layers button is toggled off. 

 4. In the Timeline, Node or Xsheet view, select all the layers you want to paint simultaneously. 

TIPS 

 l To select multiple layers or nodes, press and hold the Ctrl (Windows/Linux) or ⌘  
(macOS) key, then click on each layer or node you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by 
clicking on the first layer you want to select, then, while holding Shift, clicking on 
the last layer you want to select. Every layer in-between will also be selected. 
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NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 

At this point, you can paint artwork in all of the selected layers. 

 5. In the Camera view, click in an area where the colour zones for the drawings in the selected layers 
overlap each other to fill them simultaneously. 

How to paint a drawing in all visible layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to paint are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to paint. 

 2. In the Tools toolbar, select the  Paint tool.

 3. In the Tool Properties view, click on the  Apply to All Visible Layers button to toggle it on. 

NOTES 

 l If this button is currently set to  Apply to Synced Drawing Layers mode, click and 
hold on the button to open its pop-up menu and select  Apply to All Visible 
Layers.

 l If  Light Table is enabled, all the visible layers will appear fully opaque. This 
indicates that the currently selected tool can work on all visible layers 
simultaneously. 

 4. In the Camera view, click in an area where the colour zones for the drawings in most or all of the 
visible layers overlap each other to fill them simultaneously. 

How to paint a drawing in a layer and all of its synced layers simultaneously

 1. In the Timeline view, select a drawing in one of the synced layers that you want to paint. 
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NOTE 

When you select a synced layer, that layer and the other layers that are synced with it 
display a  Link icon. 

 2. In the Tools toolbar, select the  Paint tool.

 3. In the Tool Properties view, click and hold on the  Apply to All Visible Layers button to open its 
pop-up menu, then select  Apply to Synced Drawing Layers.

NOTES 

 l If this button is already set to  Apply to Synced Drawing Layers mode, simply 
click on it to toggle it on. 

 l If  Light Table is enabled, the currently selected layer and all of its synced layers 
will appear fully opaque. This indicates that the currently selected tool can work on 
all of these layers simultaneously. 

At this point, you can paint artwork in the selected layer and all of its synced layers. 

 4. In the Camera view, click in an area where the colour zones for the drawings in the synced layers 
overlap to fill them simultaneously.  
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Repainting

T-ANIMPA-011-004

You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.  

You can repaint lines, zones, and brush strokes using the Repaint tool. The repaint pencil lines more efficiently, 
see Inking Lines on page 764. The Repaint tool does not fill empty zones, even if they are closed.

If you imported and vectorized drawings, during the vectorization process on traditional scanned drawings, 
triangles are added on the lines' intersections to break the artwork in segments. This way, when you paint a 
line, it will not repaint the entire drawing, only the relevant segment—see Creating Break Triangles on page 
760.

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint 
a section by manually painting over the lines. This is useful when the vectorization triangles are not placed as 
you would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, 
where there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, 
but will only show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are 
not added one on top of each other. 

NOTE 

To avoid repainting specific colours, see Protecting Colours

How to access the Repaint Tool

 1. In the Tools toolbar, select the Repaint  tool. You can also find the option in the Tool Properties 
view when the Paint tool is selected. 

 2. In the Camera or Drawing view, click on the zones to repaint. You can also make a lasso or marquee 
selection around several zones.
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How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Camera or Drawing view, draw on the zones to repaint.
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Repainting a Selection

 The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection 
using the Select  tool in order for this command to be available. You can also click on the colour swatch in the 
colour palette to automatically repaint your selection.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the 
drawings contained within the same layer. You must enable the Permanent Selection  option in the Select tool 
Tool Properties view and then select an area of your drawing using the Select  tool in order for this command to 
be available. The Permanent Selection option lets you maintain the same selection throughout the drawings of 
a same layer.

NOTE 

To avoid repainting specific colours, see Protecting Colours
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How to repaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones to repaint. 

 3. To repaint the selection on all drawings,  enable the Permanent Selection  option in the Select 
tool Tool Properties view.

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint 
Selection or Repaint Selection on All Drawings.
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Repainting Outside a Selection

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been 
drawn using the Select   tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all 
the drawings contained within the same layer. You must enable the Permanent Selection  option in the Select 
tool Tool Properties view and then select an area of your drawing using the Select  tool in order for this 
command to be available. The Permanent Selection option lets you maintain the same selection throughout 
the drawings of a same layer.

NOTE 

To avoid repainting specific colours, see Protecting Colours

How to repaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones you do not want to repaint. 
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 3. To repaint outside the selection on all drawings,  enable the Permanent Selection  option in the 
Select tool Tool Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint 
Outside Selection or Repaint Outside Selection on All Drawings.
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Unpainting a Selection

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a 
selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all 
the drawings within the same layer. 

You must enable the Permanent Selection  option in the Select tool Tool Properties view and then select an 
area of your drawing using the Select  tool in order for this command to be available. The Permanent Selection 
option lets you maintain the same selection throughout the drawings of a same layer.

How to unpaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select 
tool Tool Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint 
Selection or Unpaint Selection on All Drawings.
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Unpainting Outside a Selection

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection 
have been drawn using the Select  tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all 
the drawings within the same layer. You must enable the Permanent Selection  option in the Select tool Tool 
Properties view and then select an area of your drawing using the Select  tool in order for this command to be 
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a 
same layer.

How to unpaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones you don't want to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select 
tool Tool Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint 
Selection or Unpaint Selection on All Drawings.
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Selecting Strokes with the Current Colour

You can select zones painted with a specific colour swatch.

How to select the zones painted with the current colour

 1. In the Colour view, select the colour from which you want to select the corresponding zones.

 2. Do one of the following:

 l Select Drawing > Select Strokes With Current Colour. 

 l Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (macOS).
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Creating Break Triangles

T-ANIMPA-011-005

The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A single 
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes 
time to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly 
become time consuming to ink. 

Toon Boom Harmony Premium lets you create triangular breaks at line intersections. These intersections are 
the probable locations where colour line breaks naturally occur, such as where a sleeve meets a hand.

How to create breaking triangles on a drawing

 1. In the  Drawing or Camera view, use the Select tool to select part or all of the drawing to be 
broken.

 2. Select Drawing > Create Breaking Triangles. If your brush strokes are not flattened, they will be 
flattened automatically before the breaking occurs.

 3. Use the Repaint tool  to paint the outline of different colour zones with different colours.
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Closing Gaps
T-HFND-004-014

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.

The Close Gap tool allows you to close small gaps in a drawing by creating small, invisible strokes between 
the two closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a 
few millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View > Show > Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be 
flattened with your artwork. They will cut overlapping drawing strokes in two pieces.

The gap automatically closes.
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Picking a Colour with the Colour Eyedropper Tool
T-ANIMPA-011-002

While working in the Camera or Drawing view, you can use the Colour Eyedropper  tool to pick a colour from 
your drawing without going to the Colour view. 

NOTE 

To learn more about the Colour Eyedropper tool options, see the Reference guide .

How to use the Colour Eyedropper tool

 1. Do one of the following:

 l In the Tools toolbar, select the  Colour Eyedropper  tool.

 l From the top menu, select Drawing > Drawing Tools > Colour Eyedropper.

 l Press Alt + D. 

 2. In the Camera or Drawing view, click on the desired colour.

TIP 

If you're using another drawing tool such as the Paint tool, you can temporarily hold down the 
D key and click in your drawing before releasing the key to pick a colour. When you release 
the key,  you will return to your previous tool. 
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Inking Lines
T-HFND-004-012

The Ink tool allows you to paint separate segments of pencil lines.

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint, 
Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you have a drawing, 
such as the one below, and you use the Paint tool to paint one of the lines, the entire line is painted.

However, if you select the Ink  tool instead and click on the same pencil line, only the segment that you clicked 
on between two intersections will be painted.

Painting and inking can be used in combination depending on what you need to paint. If you need to ink a 
character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a 
character’s neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same 
continuous outline, then the Ink tool might prove more useful.

NOTES 

 l To avoid repainting specific colours, see Protecting Colours

 l To learn more about the Ink tool options, refer to the Reference Guide.

How to use the Ink tool

 1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.  

 2. In the Drawing or Camera view, click on the pencil lines to repaint.

 l The newly inked segment is always moved on top of all other pencil strokes, even if it 
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was behind all other pencil strokes before it was inked. To reverse that behaviour, 
disable the Raise  option in the Tool Properties view.

 l Hold down Alt while clicking a segment to do the opposite option from the Raise 
mode current state.  The inked segment will be sent to the back or forward, even if it 
was in front or behind all other segments to begin with.
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Verifying Painted Zones
T-ANIMPA-011-008

When the ink and paint process is completed, it's always a good idea to verify that every zone was painted 
properly.

The first step to check your ink and paint is to go through all  your drawings and verify that there are no colour 
mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the Xsheet.

The backlight produces Produces a silhouette effect by changing the drawing’s coloured areas into a single 
dark, solid colour. Use this to verify the completeness of the ink and paint process. Any unpainted zones can be 
seen as the light shows through the unpainted areas of the silhouetted drawing.

How to preview drawings from the Xsheet

 1. First, save your scene. 

 2. Do one of the following:

 l From the top menu, select File> Save. 

 l Click the Save  button. 

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).

 3. In the Xsheet view, select the range of drawings or the whole column to preview.
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 4. In the Xsheet View  menu, select View > Preview Selected Drawings or press Alt + P.

The Play window opens.

 5. Play your drawings.
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 6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence 
while looping the playback.

How to use the backlight

NOTE 

This feature is only available in the Drawing view.

 1. Do one of the following:

 l From  the top menu, select View > Backlight.

 l Press Alt + Shift + B. 

 2. Verify the drawings in the Colour Art to make sure that all the areas are painted. From the Camera 
or Drawing View menu , select View > Switch to Colour Art or press L.

 3. In the Art Layer toolbar, click the Preview All Art Layers  button  to see the colour zones with 
lines to ensure that you did not forget any spots between the colour filling and lines.
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About the Edit Gradient and Texture Tool
T-HFND-006-019

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set 
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you 
can select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s 
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with 
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both 
elements independently at the same time.

NOTE 

For information on the Edit Gradient/Texture tool properties, see the Reference Guide
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Using the Edit Gradient and Texture Tool 

T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l From the  Camera or Drawing View  menu, select Drawing Tools > Edit 
Gradient/Texture.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Storing the Gradient and Texture Settings

You can store the position, scale, and angle of a selected gradient or texture to reuse it in other painting zones.

How to store gradient and texture settings

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Camera or Drawing view, select the gradient or texture zone to store.

 3. In the Tool Properties view, click the Store Colour Gradient  button.
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Pasting a Stored Gradient or Texture

You can apply the gradient and texture settings previously stored to paint zones with the same gradient or 
texture, in the same position, scale and angle.

How to use the stored gradient and texture settings

 1. In the Tools toolbar, select the Brush  or Paint  tool.

 2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

 3. In the Camera or Drawing view, draw and paint.
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Editing Pencil Line Textures with the Edit Gradient/Texture Tool

You can use the Edit Gradient/Texture tool to tweak the way a texture or gradient is applied onto a pencil line. 

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.

 3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on 
the top of the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is 
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or 
gradient.
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 4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central 
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it 
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s 
central vector, stretching them vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit a pencil line with both a texture and a 
gradient

 1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.

 3. Use the top editor controls edit the gradient.
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 4. Use the bottom controls edit the “brush” texture.
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About Colour Space Management

About Colour Spaces

Colour spaces are profiles defining the rules used by a display device, such as a monitor or a projector, to 
convert numerical colour values into colours. 

In computing, as a general rule, colours are defined by three numerical values: one for red, one for green and 
one for blue, which are the primaries used for additive colour mixing. Each of these values vary between 0 and 
255. Those primary values result in actual red, green and blue light, at an intensity proportional to said value.   
By mixing different primary colours, different hues such as cyan, yellow and magenta can be obtained, and 
mixing all three primaries results in white. 

Where colour spaces come into play is how each primary value is used to determine the intensity of their 
respective colour signal. For example, let’s say you have a blue value of 127, which is halfway between 0 and 
255. The resulting blue light will not be exactly halfway between black and the lightest possible blue light 
the display can generate, because monitors don’t convert colour values to colour signals on a linear scale, but 
rather, on a curvilinear scale that is a lot like an exponential function. This is because the human eye can 
perceive differences between lower light intensities better than between higher light intensities. Hence, to 
get the most nuances out of the 255 possible values of a primary, the differences between lower values must 
be smaller than the differences between higher values. The point is that, to the human eye, incrementing a 
colour value by 1 results in the same perceived intensity difference regardless of the colour value. 

The curvilinear function used to convert colour values to colour intensities is referred to as the gamma 
conversion curve, and each colour space has its own gamma conversion curve. The most commonly used colour 
space in computing, sRGB, has a gamma conversion curve that is designed to reproduce that of CRT displays. 
However, the most commonly used colour space in HD television, Rec. 709, has a gamma conversion curve that 
is considered better than that of sRGB.

Another aspect of colour spaces is the range of colours they can display. Commonly used colour spaces such as 
sRGB, Rec. 709 and Display P3 can display the same limited subset of the colours that can be perceived by the 
human eye. This subset is especially limited in the range of greens it can display. In contrast, the colour space 
Rec. 2020 is known for supporting a much wider range of colours, especially in terms of greens, than those 
colour spaces. Rec. 2020 is hence preferred for high end productions, but displays that support Rec. 2020 are 
currently very expensive, and hence producing in Rec. 2020 comes at a cost in hardware compatibility.

Because of this, productions typically use a specific colour space that is different than that of the standard 
sRGB. This also incurs common production problems such as:

 l Materials such as character models and backgrounds may have been created in a specific colour space 
that is different than the one intended for production. 

 l Project collaborators may be using displays that do not use the colour space intended for the project’s 
delivery. 

 l Compositing artists may also prefer using a specific colour space for compositing, as special effects may 
wield different results with a colour space that uses linear values than with a colour space that uses a 
curvilinear gamma curve.
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Colour Spaces in Harmony

To ensure the integrity of colours across your production, Harmony uses sRGB colour space for Toon Boom 
drawings—see Setting the Working Colour Space for a Scene on page 784. It allows you to specify the colour 
space of your inputs (bitmap images), of your outputs (rendered frames, movies) as well as the colour space 
used internally for compositing your scene. More specifically, you can specify different colour spaces for:

 l Each imported bitmap image

 l The scene

 l The preview image in the Camera view

 l The rendered images and movies

The way it works, when rendering a frame in your scene, is as follows:

 1. Harmony converts the colours of each drawing layer from sRGB colour space to the scene’s working 
colour space.

 2. Harmony converts the colours in each bitmap image from their respective colour space to the scene’s 
working colour space.

 3. All visual elements and effects in your scene are composited together into a single image, all in your 
scene’s working colour space.

 4. The image is converted to the colour space selected for the Camera view or for rendering, depending on 
whether the frame is a preview image or a final frame.

The following graph illustrates this process:
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NOTE 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the 
Working Colour Space for a Scene on page 784, in the Camera view the colour spaces of drawing 
layers are used in the Render View mode when converting their respective colour space to the 
scene’s working colour space. In OpenGL View mode, the colour spaces of drawing layers are 
ignored, and the colours of bitmap images are converted directly from their respective colour space 
to the preview colour space, skipping the scene’s colour space.

Hence, in order to properly manage the colours in your production, you must make sure that:

 l The colour space of each bitmap image layer is set to the colour space, used in the imported images—see 
Setting the Colour Space of an Element Layer on page 781. 

 l The colour space for your scene is the optimal colour space chosen for composition—see Setting the 
Working Colour Space for a Scene on page 784.

 l The colour space for your Camera view is set to the colour space supported by your monitor and, 
preferably, the one intended for delivery—see Setting the Display Colour Space on page 786.

 l The colour space used when rendering frames or when exporting a movie is the one intended for 
delivery or for post-production—see Setting the Colour Space for Rendered Movies and Frames on page 
790.

By default, Harmony supports the following colour spaces:

 l Linear: The same primaries and white point as sRGB and Rec. 709, but with no gamma transfer curve 
applied to the colour values. This colour space is useful for compositing intermediary images that are 
meant to be rendered in sRGB or Rec. 709.

 l Display P3: A colour space commonly used for digital projection. It has the same primaries as DCI-P3, 
the same white point as sRGB and the same gamma transfer curve as sRGB.

 l Display P3 Linear: The same as Display P3, except with no gamma transfer curve. This colour space is 
useful for compositing intermediary images that are meant to be rendered in Display P3.

 l Rec. 709: The colour space used for HDTV. It has the same primaries and white point as sRGB, but has a 
different gamma transfer curve.

 l Rec. 709 2.4: The same colour space as Rec. 709 or sRGB, except with a gamma transfer curve of 2.4 
(per ITU-R BT.1886). This colour space exists because some editing systems use a gamma transfer curve 
of 2.4 instead of the standard gamma curve for Rec. 709.

 l Rec. 2020: A colour space used for Ultra High Definition TV (UHDTV). It has a complex gamma transfer 
curve and primaries that cover more of the human-perceivable colour space than other colour spaces, 
especially in the area of human-perceivable greens. 
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 l Rec. 2020 2.4: The same colour space as Rec. 2020, except with a simple gamma transfer curve of 2.4 
(per ITU-R BT.1886). This colour space exists because some editing systems use a gamma transfer curve 
of 2.4 instead of the standard gamma curve for Rec. 2020.

 l Rec. 2020 Linear: The same colour space as Rec. 2020, except with no gamma transfer curve. This colour 
space is useful for compositing intermediary images that are meant to be rendered in Rec. 2020.

 l sRGB: A colour space typically used for standard computer monitors. It has the same primaries and 
white point as Rec. 709, but has a different gamma transfer curve.

Those colour spaces are defined using the OpenColourIO specification, which is a text based-technology for 
defining colour spaces and how to convert between them. Hence, it is possible to configure Harmony to 
support different colour spaces as needed. Furthermore, if other software in your pipeline use a specific 
OpenColourIO configuration file to define its colour spaces, Harmony is able to use that file as well for its colour 
space definitions. For more information, see Customizing Available Colour Spaces on page 793.

NOTE 

Any scene created in Harmony 17 or earlier has colour space management disabled by default. To 
enable colour space management on a scene created in older versions of Harmony, see Setting the 
Working Colour Space for a Scene on page 784.

NOTE 

Any scene created in Harmony 20 has “Read Toon Boom Drawings Using sRGB Colour Space” 
option disabled, see Setting the Working Colour Space for a Scene on page 784.
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Setting the Colour Space of an Element Layer
You can set the colour space of each bitmap image layer in your scene individually. For Toon Boom vector and 
bitmap drawings by default, Harmony uses sRGB colour space.

When rendering your scene, the colours of each bitmap image layer will be converted from their respective 
colour space to the scene’s colour space before they are composited together with your scene’s effects. The 
colours of the bitmap drawing layers and vector drawing layers will be converted from sRGB colour space to 
the scene’s colour space, ignoring the colour space selection of the drawing layers.

NOTE 

In OpenGL View mode, bitmap images are converted from their colour space to the colour space 
selected in the Display Colour Space preference in the Camera tab of the Preferences dialog, and 
the colour space of drawing layers is ignored. 

NOTE 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the 
Working Colour Space for a Scene on page 784.

 l In Render View mode the colours of the original bitmap images, bitmap drawing layers and 
vector drawing layers are converted from their respective colour space to the scene’s colour 
space before they are composited together.

 l In OpenGL View mode bitmap images are converted from their colour space to the colour space 
selected in the Display Colour Space preference in the Camera tab of the Preferences dialog, 
and the colour space of drawing layers is ignored.

When adding a new element layer, by default sRGB is used as the layer’s colour space.

How to set the colour space of an element layer

 1. Open the Layer Properties for the element layer for which you want to select a colour space by 
doing one of the following:

 l In the Timeline view, double-click on the element layer but outside of its name (such as on 
the  icon).

 l In the Timeline view, right-click on the element layer and select Layer Properties.

 l In the Node View, locate the element node and click on its  Layer Properties icon.

 l In the Node View, right-click on the element layer and select Layer Properties.

781



 l Add the Layer Properties view to your workspace, then select the element layer in the 
Timeline or Node view.

 2. In the element’s layer properties, select the Drawing tab.
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 3. At the bottom, in the Colour Space drop-down, select the colour space for the element layer.
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Setting the Working Colour Space for a Scene
You can select the working colour space for your scene in the scene settings dialog.

The working colour space is the colour space to which each layer in your scene is converted before all elements 
in your scene are composited together along with your scene’s effects. Then, the image is converted from your 
scene’s working colour space to the intended colour space for rendering. Hence, the scene’s working colour 
space is the intermediary colour space in which the compositing is done internally.

TIP 

For optimal compositing, it is recommended to set your scene’s working colour space to the linear 
version of the colour space used by your production. That way, the calculations done for the visual 
effects in your scene are not affected by the gamma curve of your production’s colour space. 

How to set the working colour space for a scene

 1. In the top menu, select Scene > Scene Settings.

The Scene Settings dialog appears.

 2. Select the Colour Space tab.
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 3. In the Working Colour Space list, select the desired working colour space for your scene.

 4. Click OK.

NOTE 

Any scene created in Harmony 20 has “Read Toon Boom Drawings Using sRGB Colour Space” 
option disabled. In this case the colour space information of each drawing layer will be used when 
converting to the scene’s working colour space in the Camera view > Render View mode, but 
ignored in OpenGL View mode—see Setting the Colour Space of an Element Layer on page 781. 
Moreover, display colour space in OpenGL View mode is  limited—see Setting the Display Colour 
Space on page 786
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Setting the Display Colour Space
You can set the colour space in which to display the preview image in the Camera view.

The generation of the preview image works exactly the same as when you’re rendering your scene. You can 
select the colour space in which to display the preview image using the drop-down menu at the bottom of the 
Camera view. Furthermore, if you have several monitors and want to preview your scene in the respective 
colour space of each monitor, you can do so by adding several Camera views to your workspace, moving each 
Camera view to its own monitor and setting the colour space of each Camera view to its monitor’s colour space. 
The different Camera views will display in their own colour space. 

If “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled—see Setting the Working Colour 
Space for a Scene on page 784.

In OpenGL View mode, colour management is much more limited, in the following ways:

 l The colour space used for the preview image cannot be selected individually for each Camera view. 
Hence, instead of using the drop-down at the bottom of the Camera view, it is selected in the Display 
Colour Space preference in the Camera tab of the Preferences dialog.

 l The colours in the bitmap images in your scene are converted directly from their own colour space to the 
preview colour space, without getting converted to your scene’s working colour space first, and the 
colours in the drawing layers in your scene are not processed at all. Hence, in OpenGL View mode, the 
colours in the preview image are not faithful to those of the final rendered image.

How to set the display colour space for the Render View mode of the Camera view

 1. At the bottom of the Camera view, select  Render View.

 2. In the drop-down right of the  Render View button, select the colour space in which you want 
the render preview to be.
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How to have an extra camera view displaying on a different monitor and a different 
colour space

 1. In the top menu, select Windows > Camera.

A floating Camera view appears over the Harmony user interface.

 2. Drag the floating Camera view to the monitor where you want it to display.

 3. At the bottom of the Camera view, select  Render View.

 4. In the drop-down right of the  Render View button, select the colour space in which you want 
the render preview to be.

787



How to set the display colour space for the OpenGL View mode of the Camera view 
when “Read Toon Boom Drawings Using sRGB Colour Space” option is disabled 

 1. Do one of the following to open the Preferences dialog:

 l Windows or GNU/Linux:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Premium > Preferences.

 l Press ⌘  + U.

 2. Select the Camera tab.

 3. In the Colour Space section, open the Display Colour Space drop-down and select the colour 
space in which you want the OpenGL preview to be.
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 4. Click OK.
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Setting the Colour Space for Rendered Movies and Frames
You can select the colour space in which to render your scene in the layer properties of your scene’s Write 
nodes, as well as in the Export Movie dialog if you’re exporting a movie. 

When rendering a scene, the individual layers are converted from their respective colour space to the scene’s 
working colour space, then they are composited together along with your scene’s visual effects, and the 
resulting image is converted to the rendering colour space.

About Tagging Exported Files

Some but not all files exported from Harmony can be tagged with their colour space. Tagging is when the 
information for an image or movie file’s colour space is embedded in the file itself, which allows some software 
to automatically load its colour space information instead of requiring you to provide it manually. 

Tagging images and movies with their colour space is not necessary, especially if you intend to load the files in 
a video editing or compositing software that allows you to specify their colour space manually, but it can be 
convenient if your post-production software supports reading the colour space information of your source files. 

Movies exported from Harmony are only tagged with their colour space information when exported in formats 
below:

 l QuickTime ProRes Movie (*.mov): When rendering a movie in QuickTime Prores Movie (*mov) format, the 
movie colour space ‘nclc’ tag will be only set as:

 l HD (1-1-1) if using “Rec. 709” colour space

 l BT.2020 (9-1-9) if using “Rec. 2020” colour space

 l P3 D65 (12-1-1) if using “Display P3” colour space

 l QuickTime Movie (*.mov) on macOS. The movie in this format will not be tagged with their colour space 
information if exported on Windows or GNU/Linux. When rendering a movie in QuickTime Movie (*.mov) 
format on macOS in a specific colour space, the movie buffer data will be tagged with the corresponding 
ICC colour profile.

As for exported images, colour space tagging is supported in the following formats:

 l Portable Network Graphic (.png)

 l Photoshop Document (.psd)

 l OpenEXR (.exr)

NOTE 

OpenEXR files are only tagged with the coordinates for their white point and primaries.
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How to set the colour space in your scene’s Write node 

 1. In the Node view, locate your scene’s Write node.

 2. Do one of the following:

 l Click on the  Layer Properties icon of the Write node.

 l Right-click on the Write node and select Layer Properties.

 l Add the Layer Properties view to your workspace, then select the Write node.

 3. In the Colour Space field, select the colour space in which you want the exported frames or movie 
to be rendered.

How to set the colour space when exporting your scene as a movie

 1. In the top menu, select File > Export > Movie.
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 2. In the Colour Space field, select the colour space in which you want your movie to be rendered.
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Customizing Available Colour Spaces
By default, Harmony supports a handful of commonly used colour spaces. If your production uses a colour space 
that is not supported by Harmony out of the box, it is possible to customize the colour spaces supported by 
Harmony to suit your production’s needs. 

The colour spaces supported by Harmony are stored in files in the following location:

 l Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 21 
Premium\etc\colourmanagement

 l macOS: /Applications/Toon Boom Harmony 21 Premium/Harmony 
Premium.app/Contents/tba/etc/colourmanagement

 l GNU/Linux: /usr/local/ToonBoomAnimation/harmonyPremium_21/etc/colourmanagement

In this directory, you will find the following contents:

Name Type Purpose

config.ocio
OpenColorIO 
configuration file

The configuration file that contains the colour profile definitions used 
by Harmony. 

luts Directory
A directory containing some dependency files used by the colour 
profiles defined in config.ocio.

icc Directory
A directory containing ICC profiles matching the colour spaces defined 
in config.ocio.

Just like many other software that support colour space management, Harmony uses the OpenColorIO colour 
management technology to define its supported colour spaces. If the other software used by your production 
also uses OpenColorIO, this means you can easily use the OpenColourIO configuration you use with your other 
software with Harmony so as to use the same colour space definitions across your production.

You can customize the colour space definitions used by Harmony by setting the OCIO environment variable for 
your operating system to the full path of your own, custom config.ocio file. This allows you to use the same
 .ocio file for multiple software if needed.

NOTE 

Harmony uses sRGB colour space for Toon Boom drawings—see Setting the Working Colour 
Space for a Scene on page 784). If a customized config.ocio file does not contain colour space 
definition named sRGB, a colour space of default view displayed in config.ocio file is used.

You might notice that, along with the OpenColorIO configuration files, there is a directory containing ICC colour 
profiles. The ICC colour profiles are only used to tag exported images when supported and movies when using 

793



QuickTime Movie (*.mov) format on macOS, and are not required for any other part of the colour management 
in Harmony. 

Hence, if you decide to customize the colour space definitions used by Harmony, you can include the ICC colour 
profiles for your colour space definitions if you want. If you don’t, Harmony will still render your images and 
movies in the appropriate colour spaces with the appropriate colour values, but will not be able to tag your 
exported images and movies with their colour space information.

For Harmony to be able to use an ICC colour profile to tag exported images and movies, the following 
conditions must be met:

 l The ICC colour profiles must be located in an icc sub-directory, in the same directory as config.ocio. 

 l The file name of the ICC colour profile must match the name of the colour space as defined in 
config.ocio.

For example, if your config.ocio file contains a colour space definition named sRGBf, for Harmony to be able 
to tag exported movies (on macOS) and images with this colour space, then the directory containing your 
config.ocio file should also contain a directory named icc, which would in turn contain a corresponding 
colour profile for sRGBf named sRGBf.icc. 

NOTES 

 l When rendering a movie in a specific colour space in QuickTime Movie (*.mov) format on macOS, 
the movie buffer data will be tagged with the corresponding ICC colour profile.

 l When rendering a movie in a specific colour space in QuickTime Prores Movie (*mov) format, the 
movie colour space ‘nclc’ tag will be only set as:

 l HD (1-1-1) if using “Rec. 709” colour space

 l BT.2020 (9-1-9) if using “Rec. 2020” colour space

 l P3 D65 (12-1-1) if using “Display P3” colour space

 l When rendering frames in a specific colour space,  the following file formats will be tagged with 
their colour space information:

 l Portable Network Graphic (.png)

 l Photoshop Document (.psd)

 l OpenEXR (.exr)

OpenEXR files are only tagged with the coordinates for their white point and primaries.
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Chapter 7: Paperless Animation
T-HFND-006-001

Toon Boom Harmony Premium is a powerful paperless animation software that incorporates animation and 
drawing tools to make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles of 
animation still apply. 

One of the advantages of working with paperless animation is that you do not lose time scanning elements in 
and testing them because everything is already digital. You can simply draw your animation and play back 
your line test right away. This also saves the substantial amount of paper required by traditional animation. 
Another practical advantage is the ability to undo and redo some actions that are often difficult on paper, such 
as erasing brush strokes.

NOTE 

When you draw on an empty cell, Harmony automatically creates a drawing that spans over a 
single frame in that cell. You can adjust that drawing's timing as needed afterward. However, it is 
possible to create, name and set the timing of each drawing before creating your animation, which 
can help organize your workflow. For more information, see Timing on page 223.
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Creating a Rough Animation
T-LAY-003-005

The first step to create paperless animation is the rough construction, which is the skeleton of your animation. 
You would usually start by animating the most important part of a character's action. For example, to animate a 
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and 
clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the 
details when you're satisfied with the movement. If you start animating all the details right away, you will lose 
a lot of time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. In the top row of the Timeline view, click on  Show All Thumbnails  to enable Thumbnail mode. 

 2. Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS) to open the Preferences dialog box. 

 3. Select the Exposure Sheet tab. 

 4. Select the Use Current Frame as Drawing Name option. When this preference is enabled, each 
new drawing will be named by the frame number they are created on.

 5. In the Tools toolbar, select the  Brush  tool or press Alt + B.

 6. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your 
rough animation. This will make the clean up process easier as your clean dark lines will contrast 
with your light sketch lines. 
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 7. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 8. In the Camera or Drawing view, draw the first key drawing.

As soon as you draw your first drawing stroke, a drawing is automatically created in the cell you 
selected.

 9. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of 
the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.
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 10. With your first cell still selected, do one of the following to mark your drawing as a key drawing. 
This will help you stay organized.

 l Enable the Mark Drawing toolbar by selecting Windows > Toolbar > Mark Drawing 
from the top menu, then click on the  Mark Selected Drawings as Key  button. 

 l Enable the Xsheet toolbar by focusing on the Xsheet, then selecting Windows > 
Toolbar > Xsheet from the top menu. Then, click on the Mark as Key Drawing  
button. 

 l In the Timeline view menu, select Drawings > Mark Drawing As > Key Drawing.

 

 11. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

 12. In the Tools toolbar, click the  Onion Skin  button. This will display the previous and next 
drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you 
can use them as references to draw new drawings with accuracy. This can be useful to draw 
breakdown poses between two key poses, or to add an in-between drawing between two other 
drawings.
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 13. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing 
on it. To do this, do one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include 
the previous drawings you want to display in the onion skin, then click and drag on 
the green onion skin marker to make it include the next drawings you want to display 
in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous 
and next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  
Remove Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove 
Next Drawing button in the Camera/Drawing view toolbar.

NOTE 

When in the Drawing view, you can use the Onion Skin toolbar to make onion 
skin display only specific types of drawings, such as key drawings or 
breakdowns. Keep in mind that this does not work in the Camera view.  

 14. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the  Create Empty Drawing  button.
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 l Press Alt + Shift + R.

 15. In the Camera or Drawing view, draw your second key drawing.

 16. In the Xsheet or Timeline view, identify the drawing as a key drawing.

 17. In the Timeline or Xsheet view, select a cell between the two key drawings. 

 18. Using the onion skin markers, ensure the onion skin covers both your first and last drawings.

 19. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the 
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 Create Empty Drawing  button.

 l Press Alt + Shift + R.

 20. In the Camera or Drawing view, draw your new pose.

 21. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new 
drawing.

NOTE 

When working with overlay layers in the Camera view, you can enable the  Current 
Drawing on Top  option in the status bar below the Camera view to make the layer you're 
working on appear over other layers. 
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Creating the Tie Down Animation
Once your rough animation  is correct, you can start adding extra details, such as arms, clothes or hair. You can 
add the extra details on the same layer with the same colour or you can also create a new colour so that you 
can always see your original sketch.

If your primary and secondary animation were done as a rough drawing, it is now time to put your drawing on 
model, also known as tie down. This means that you have to review your animation and ensure that every 
single detail is on model and there is no volume distortion. You can do this directly on the original sketch layer 
or on a new layer.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing element 
and use the Light Table feature to draw over the first drawing element. This technique can also be used if you 
want to reuse your rough animation for other characters. For example, if you have a rough walk-cycle, you can 
reuse it for another character and add its personal features in a new layer. This way, you only need to animate 
the secondary animation instead of the whole body again. 
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How to create secondary animation on the same layer

 1. In the Xsheet or Timeline view, select the cell in which you want to add new details.

 2. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

 3. In the Drawing Tools toolbar, select your drawing tool.

 4. In the Camera or Drawing view, draw the secondary animation.

 5. Do one of the following:

 l In the Xsheet or Timeline view, select the next cell in which you want to draw.

 l Press F and G to navigate between your drawings.

 6. Do one of the following:

 l Select View > Onion Skin > Show Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 7. Extend the onion skin.

 8. In the Camera or Drawing view, draw the secondary animation.
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 9. Use the Flip and Easy Flipping toolbars to review your animation—see the Flip and Easy Flipping 
toolbars in the Reference guide.

 10. You can also use the Playback toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

 1. Add a new drawing layer and name it secondary_animation.

 2. In the Timeline or Xsheet view, select the rough layer's timing.

 3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘  
+ B (macOS).

 4. Choose Never create drawing files from the options to paste the timing but not the drawing files.

 5. If you are working in the Drawing view, in the Drawing View toolbar, enable the Light Table.

 6. In the Xsheet or Timeline view, select the cell where you want to add the new details.
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 7. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

 8. In the Tools toolbar, select your drawing tool.

 9. In the Drawing or Camera view, draw the secondary animation on top of your rough drawing.

 10. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

 11. Do one of the following:

 l In the top, Drawing View or Camera View menu, select View > Onion Skin > Show 
Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.
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 l Press Alt + O.

 12. Extend the onion skin.

 13. In the Camera or Drawing view, draw the next secondary animation.

 14. Use the Flip and Easy Flipping toolbars to review your animation—see the Reference guide . 

 

 15. You can also use the Playback toolbar to play the animation in real time.
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Cleaning Animation
T-HFND-006-010

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It 
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless 
animation step before the ink and paint step.

You will need to add a new drawing layer to create your clean drawing. This is the equivalent of adding a 
sheet of paper and tracing the rough using the animation disk. This allows you to keep the roughs and the 
cleans intact. You only need to lock the rough layer to prevent it from appearing in the scene. 

If you plan on tracing your animation in the Drawing view, use the light table to display all the layers in your 
project.

How to trace animation in a new layer

 1. In the Layer toolbar, click the Add Drawing Layer  button and add a new layer.

 2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid 
selecting the layer in the Camera view.

 3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key 
drawing of your rough animation.

 4. In the Tools toolbar, select the drawing tool of your choice. The Pencil  tool is recommended.

 5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, 
would ensure that it contrasts well with the light colour of your rough animation.

 6. In the Camera or Drawing view, start tracing the first key drawing.
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 7. If you have some other layers in the way, you can disable them temporarily from the Timeline view 
so that only the rough animation and clean-up layer are displayed in the Camera view. 

 8. In the Tools toolbar, click the Onion Skin  button and pull on the blue onion skin handles in the 
Timeline view to extend the number of frames you can see.

 9. Use the buttons in the toolbar above the drawing space to adjust how many previous and next 
drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next Drawing 
button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next Drawing 
button in the Camera/Drawing view toolbar.

 10. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 11. In the Drawing or Camera view, trace your next drawing.
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 12. Repeat the previous steps for each drawing.
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Paperless Animation Tools
To understand paperless animation, you must first discover the tools available. There are, of course, drawing 
tools, but also practical features such as setting a drawing as a key, breakdown or in-between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work 
efficiently, as you would with an animation table, paper and pencils. 

The onion skin and light table are used to preview previous and next drawings, cells, elements and frames. 
When designing or animating, it is very useful to see your previous drawings. Just as if you were building a cut-
out puppet, you want to view other drawing elements to know where to draw the new element. 

Harmony has many useful advanced features such as the Flipping toolbar, enhanced onion skin, extra drawing 
layers, and automated matte generation.
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Displaying Drawing Thumbnails in the Timeline View
T-ANIMPA-006-003

In the Timeline view, it is possible to preview the drawings in your scene by enabling the display of thumbnails 
for your drawing layers. You can display the thumbnail for all drawing layers or for individual drawing layers. 
This allows you to preview the drawing in the current frame as well as drawings exposed in every frame of 
your scene, which can be useful for managing your drawings and for adjusting their timing.

You can enable Thumbnails for all drawing layers simultaneously or for individual drawing layers. When 
thumbnails are displayed for a layer, the Timeline view also displays the name of each drawing as well as the 
amount of frames on which each drawing is exposed for that layer. Enabling thumbnails on a layer also gives 
access to that layer's Opacity parameter in the left panel of the Timeline view. 

How to display or hide thumbnails for all drawing layers

 1. In the Layers toolbar of the Timeline view, click on the Show/Hide All Thumbnails  button

How to display or hide thumbnails for a specific drawing layer

 1. Do one of the following: 
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 l In the Timeline view, left of the layer's name, click on the Show/Hide Thumbnails  button.

 l In the Timeline view, select the layer and press T.

Even when thumbnails are displayed for a layer, it is likely that you won't be able to see the full thumbnails for 
individual drawings that are exposed over 1 or 2 frames because, by default, frames are not large enough to 
display their thumbnails. To make the frames larger so that thumbnails have enough horizontal space to be 
displayed, you must zoom in on the Timeline view.

How to zoom in on the Timeline view.

 1. Set the focus on the Timeline view, for example by clicking on the Timeline view tab.

 2. Do one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.
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TIP 

If you animate mostly on twos or threes, you can adjust the Timeline zoom to fully display the 
thumbnails of drawings exposed over two or three frames, or you can zoom in enough to 
display the thumbnails of drawings exposed over a single frame, depending on your 
preference.

TIP 

To reset the Timeline Zoom to its default zoom level, click on the Reset Zoom  icon left of the 
Timeline Zoom slider.

NOTE 

When zoomed in on the Timeline view, you can tweak the exposure of your drawing by dragging 
the edges of the drawings with your mouse cursor. This is especially useful when displaying 
thumbnails as you can visually adjust the timing of your animation. For more information, see About 
Rippling and Overwriting the Exposure in the Timeline View.

813



About Marked Drawings
T-HFND-006-004

When working with several animators, directors or even other studios, the necessity for retakes will often 
arise. Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or 
Retake In-betweens. In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. 

About the Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example, if a 
character that is sitting down falls on his back, the key poses would be the character sitting and the character 
on his back. Of course, it may vary from one animation to another.

About the Breakdown Drawing

A breakdown drawing is a pose somewhere between two key poses that better shows the movement. Most 
animation moves are arcs, such as an arm waving, somebody bending, or a leg walking. All of these 
movements are rotations. The breakdown pose is used to describe this curve better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. These 
actions can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody that is running, or 
arms moving after the main body action. These moves will generally have a different timing than the primary 
action. They will mainly start later and finish later. So, the breakdown drawings are used to complete the key 
drawings.

Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often be closer 
to one or the other depending on the timing and the action. Also, you can have more than one breakdown 
pose between two keys.
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Marking Key, Breakdown and In-Between Drawings

T-HFND-006-004A

Using the toolbar in the Xsheet view, you can mark your drawings as Key or Breakdown drawings, or In-
Between. 

If you add the Mark Drawing toolbar to your workspace, you can also mark your drawings as RetakeKey, 
RetakeBD (Retake Breakdown) and RetakeIB (Retake In-Between), which is an efficient way for someone in 
charge of verifying an animator's work to mark the drawings they want the animator to do over. You can also 
use this toolbar to mark drawings with any custom marker you created, if needed—see Creating Custom 
Drawing Markers.

NOTES 

 l Marking a drawing as an In-between actually removes its marker. All unmarked drawings are 
considered in-betweens. 

 l You cannot mark an empty cell. You can only mark an existing drawing. Hence, you must create 
your drawings before marking them.

 l A marker is assigned to a drawing, not a frame. If a drawing is exposed several times in a scene, 
marking this drawing will make every instance of it marked. 

How to mark drawings as Key, Breakdown or In-between

 1. Open the Xsheet view.
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 2. Select the drawing you want to mark.

 3. In the Xsheet toolbar, do one of the following:

 l Click on the  Mark as  Key Drawing button to mark the drawing as a key drawing.

 l Click on the  Mark as  Breakdown Drawing button to mark the drawing as a breakdown.

 l Click on the  Mark as  In-between Drawing button to remove an existing marker from the 
drawing.

 4. Repeat until all your key and breakdown drawings are properly marked. 
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How to mark drawings as Key, Breakdown or In-between

 1. Add the Mark Drawing toolbar to your workspace by doing one of the following:

 l Right-click on an existing toolbar and select Mark Drawing.

 l In the top menu, select Windows > Toolbar > Mark Drawing.

The Mark Drawing toolbar appears. It can be used to mark drawings as key, breakdowns, in-
betweens, retake keys, retake breakdowns, retake in-betweens and, if applicable, any custom 
marker created for your production.

 2. Open the Xsheet view.
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 3. Select the drawing you want to mark.

 4. In the Mark Drawing toolbar, do one of the following:

 l Click on the  Mark as  Key Drawing button to mark the drawing as a key drawing.

 l Click on the  Mark as  Breakdown Drawing button to mark the drawing as a breakdown.

 l Click on the  Mark as  In-between Drawing button to remove an existing marker from the 
drawing.

 l Click on the  Mark Drawing as: RetakeKey button to mark the drawing as a retake key 
drawing.

 l Click on the  Mark Drawing as: RetakeBD button to mark the drawing as a retake 
breakdown drawing.

 l Click on the  Mark Drawing as: RetakeIB button to mark the drawing as a retake in-
between drawing.

 5. Repeat until all your drawings are properly marked. 
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Creating Custom Drawing Markers

If your production requires you to mark drawings with markers other than the ones available by default in 
Harmony, it is possible to create custom markers. Custom markers have the same capabilities as other markers: 
You can mark drawings with it using the Mark Drawing toolbar, you can make Onion Skin only display 
drawings marked with your custom marker and you can use the Flip toolbar to only flip through drawings with 
your custom marker. 

Before you can add a custom marker to Harmony, you must first design its icons. A custom marker needs the 
following icons:

 l Mark Drawing Toolbar icon (24 x 24 pixel)

 l Onion Skin Toolbar icon (24 x 24 pixel)

 l Flip Toolbar icon (24 x 24 pixel)

 l Xsheet Column icon (16 x 16 pixel)

Once this is done, to add your marker to Harmony, you will need to add its information to an Extensible Markup 
Language (.xml) file. XML is a type of computer language often used for configuration and to store project 
data. The steps below explain in detail how to do this. Hence, although it is preferable to have scripting or 
programming background to do this, it is not required.

How to create a custom drawing marker for yourself

 1. Close Harmony.

 2. Using an image editor, create the required icons for a drawing marker. Create one file in Portable 
Network Graphics (.png) format, with the following dimensions, for each required icon type:
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 l Mark Drawing Toolbar icon (24 x 24 pixel)

 l Onion Skin Toolbar icon (24 x 24 pixel)

 l Flip Toolbar icon (24 x 24 pixel)

 l Xsheet Column icon (16 x 16 pixel)

 3. In a file browser, browse to the location of your custom markers in your user preferences:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony Premium\full-2000-pref\drawingTypes.d

NOTE 

The AppData folder is hidden by default. To see it, open the View menu in 
Explorer and check the Hidden Items option.

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon 
Boom Harmony Premium/Users/[username]/Library/Toon Boom 
Animation/full-2000-pref/drawingTypes.d

NOTE 

The Library folder is hidden by default. Access it, press and hold the Alt key 
and then, in the Finder top menu, select Go > Library.

 l GNU/Linux: /home/[username]/Toon Boom Animation/Toon Boom Harmony 
Premium/full-2000-pref/drawingTypes.d

 4. Copy and paste the icons for your marker inside this drawingTypes.d directory.

 5. Open the file drawingTypes.xml located in this directory in a text editor.

 6. Copy and paste the following line just above </DrawingTypes> near the bottom:

<DrawingType text="MarkerName" pixmapFile="XsheetIcon.png" commandIcon="MarkerIcon.png" flipIcon="FlipIcon.png" onionIcon="OnionSkinIcon.png" />

 7. Fill the line with the appropriate information for your marker:

 l Replace MarkerName with the name of your custom marker.

 l Replace XsheetIcon.png with the file name of the icon to display for your marker in the 
Xsheet view.

 l Replace MarkerIcon.png with the file name of the icon to display in the Mark Drawing 
toolbar.
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 l Replace FlipIcon.png with the file name of the icon to display in the Flip toolbar.

 l Replace OnionSkinIcon.png with the file name of the icon to display in the Onion Skin 
toolbar. 

 8. Save the file and close it.

 9. Start Harmony.

Your drawing marker will be available in the Mark Drawing, Flip and Onion Skin toolbars.

How to create a custom drawing marker for a Harmony Server database

 1. Close Harmony.

 2. Using an image editor, create the required icons for a drawing marker. Create one file in Portable 
Network Graphics (.png) format, with the following dimensions, for each required icon type:

 l Mark Drawing Toolbar icon (24 x 24 pixel)

 l Onion Skin Toolbar icon (24 x 24 pixel)

 l Flip Toolbar icon (24 x 24 pixel)

 l Xsheet Column icon (16 x 16 pixel)

 3. Using a file browser, browse to the location of the custom drawing markers configuration package 
which is a directory named drawyngTypes.d, and which is bundled with Harmony at the 
following location:

 l Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 
21 Premium\resources

 l macOS: /Applications/Toon Boom Harmony 21 Premium/Harmony 
Premium.app/Contents/tba/resources

 l GNU/Linux: /usr/local/ToonBoomAnimation/harmonyPremium_21/resources

 4. Right-click on drawingTypes.d and select Copy. 

 5. Browse to the root directory of your Harmony database: 

/USA_DB

 6. Right-click inside the directory and select Paste.

The drawingTypes.d directory will be copied to your database, along with the icons and 
configuration for the RetakeKey, RetakeBD and RetakeIK markers, which are custom drawing 
markers bundled with Harmony.

 7. Open the drawingTypes.d folder. 
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 8. Copy and paste the icons for your marker inside this drawingTypes.d directory.

 9. In the same directory, open the drawingTypes.xml file in a text editor.

 10. Copy and paste the following line just above </DrawingTypes>, at the bottom:

<DrawingTypetext="MarkerName"pixmapFile="XsheetIcon.png"commandIcon="MarkerIcon.png"flipIcon="FlipIcon.png"onionIcon="OnionSkinIcon.png"/>

 11. Fill the line with the appropriate information for your marker:

 l Replace MarkerName with the name of your custom marker.

 l Replace XsheetIcon.png with the file name of the icon to display for your marker in the 
Xsheet view.

 l Replace MarkerIcon.png with the file name of the icon to display in the Mark Drawing 
toolbar.

 l Replace FlipIcon.png with the file name of the icon to display in the Flip toolbar.

 l Replace OnionSkinIcon.png with the file name of the icon to display in the Onion Skin 
toolbar. 

 12. Save the file and close it.

 13. Start Harmony.

Your drawing marker will be available in the Mark Drawing, Flip and Onion Skin toolbars.
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About Onion Skin
One of the most basic techniques of  traditional animation is to place two drawings on a light table, put an 
animation sheet over them and draw between the outlines of the two drawings to make an in-between. In 
Harmony, this technique is streamlined with Onion Skin.

Onion Skin is a powerful feature in Harmony that allows you to display the drawings surrounding your current 
drawing in washed, semi-transparent outlines so as to help you use them as reference to make your poses, 
your breakdowns and your in-betweens. 

Onion Skin works in both the Camera and Drawing view. When using Onion Skin, you can choose to include 
one or several drawings before, after or both before and after the current drawing. By default, drawings before 
the current drawing appear in red, and drawings after the current drawing appear in green. 
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Enabling the Onion Skin

You can enable the onion skin to see your previous and next drawings as reference.  

NOTE 

You can modify the onion skin display in the Preferences panel.

How to enable the onion skin

 1. In the Timeline view, select the layer you want to draw on and the frame in which you want to 
draw.

 2. Do one of the following:

 l In the Tools toolbar, click on the   Onion Skin button.

 l In the Timeline view, click on the   Onion Skin button left of the layer name.

 l In the top menu, select View > Onion Skin > Show Onion Skin.

 l Press Alt + O.

Onion Skin will be enabled. By default, it will display two frames before and two drawings after the 
current drawing.
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Selecting Drawings to Display in Onion Skin

When you enable Onion Skin, by default, it will display two drawings before the current drawing and two 
drawings after the current drawing. You can adjust how many drawings before and after the current drawing 
to display. There are two methods to doing this:

 l Adjusting the Onion Skin handles in the Timeline view. When Onion Skin is enabled, a red handle and 
a green handle appear before and after the red playhead in the Timeline view. Those handles indicate 
and allow you to adjust the range of drawings displayed in the Onion Skin.

 l Using the     toolbar buttons or menu commands to add or remove drawings from the Onion 
Skin one at a time.

NOTE 

If you choose to include drawings to display in the Onion Skin by drawing instead of by frame, you 
cannot use the Onion Skin handles in the Timeline view—see Selecting Drawings to Include in 
Onion Skin by Frames or by Drawings.

How to select drawings to display in the Onion Skin using the Onion Skin handles in 
the Timeline view

 1. Select the layer you want to draw on, the frame in which you want to draw, and enable Onion 
Skin—see Enabling the Onion Skin.

Blue handles appear on each side of the Timeline play head.

All the drawings in the current layer over which these handles span are included in the Onion Skin.
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 2. Click on the handle left of the play head and drag it so that it includes only and all the previous 
drawings you want to display in the Onion Skin.

 3. Click on the handle right of the play head and drag it so that it includes only and all the next 
drawings you want to display in the Onion Skin.
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The Onion Skin will display only, and all the drawings that are within the span of the blue handles. 

How to increase or decrease drawings to display in the Onion Skin one at a time

 1. Select the layer you want to draw on, the frame in which you want to draw, and enable Onion 
Skin—see Enabling the Onion Skin.

The Onion Skin displays in the Camera or Drawing view, with the default amount of previous and 
next drawings included. 

 2. Do one of the following as many times as necessary to include only the drawings you want to see in 
the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.
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 l To decrease the amount of previous drawings to display, click on the  Remove Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next Drawing 
button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next Drawing 
button in the Camera/Drawing view toolbar.

The Onion Skin will update with as many or as few previous and next drawings as you add or 
remove.

TIPS 

 l You can also select those commands in the top menu, in View > Onion Skin.

 l This menu also has commands to instantly set the amount of previous and next drawings 
to include in the Onion Skin to zero, one, two or three. 

 l You can also add the commands to instantly set the amount of drawings to include to zero, 
one, two or three to the Camera/Drawing view toolbar by right-clicking on the toolbar and 
selecting Customize. 
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Selecting Drawings to Include in Onion Skin by Frames or by 
Drawings

When you select which drawings to include in the Onion Skin, you are actually just setting the amount of 
drawings to include before and after the current drawings. 

Because drawings can be exposed over multiple frames, this gives Harmony two possible approaches to 
determine which drawings to include in the Onion Skin:

Selecting Drawings by Frames

With this method, if you set the Onion Skin to include one drawing before and after the current frame, it will 
include the drawings in the frame right before and right after the current frame. This means that even if the 
same drawing is exposed throughout this span of three frames, only that drawing will be displayed in the 
Onion Skin.

This method is the default one used when using Onion Skin in the Camera view. The reason for this is that the 
Camera view is often used for cut-out animation. When doing cut-out animation, layers often have the same 
drawing exposed for long spans while the layer itself is animated with translations, rotations and scaling. By 
using Onion Skin by frames, you can display the position of the layer before and after the current frame in the 
Onion Skin, even if it's the same drawing, just in different positions. 

Selecting Drawings by Drawings

With this method, if you set the Onion Skin to include one drawing before and after the current frame, it will 
include the nearest drawing that is different from the current drawing before the current frame, and the 
nearest drawing that is different from the current drawing after the current frame. 

This method is more useful for frame-by-frame animation. Since frame-by-frame animation typically does not 
use layer animations, it is usually only relevant to have different drawings in the Onion Skin.

Changing Between Methods

In the Timeline view, you can decide whether to include drawings by frames or by drawings. In the Drawing 
view, however, drawings included in the Onion Skin are always selected by drawing, since the Drawing view 
can only be used for frame-by-frame animation, whereas the Camera view can be used for both frame-by-
frame and cut-out animation.

How to switch between selecting drawings for Onion Skin by drawing or by frame via 
the top menu

 1. In the top menu, select View > Onion Skin and select either Onion Skin by Frames or Onion Skin by 
Drawings.
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How to switch between selecting drawings for Onion Skin by drawing or by frame 
using the Onion Skin view

 1. Do one of the following:

 l In the top-right corner of a view, click on the  Add View button and select Onion Skin.

 l In the top menu, select Windows > Onion Skin.

The Onion Skin view is added to your workspace.

 2. Open the drop-drop down at the bottom and select either By Frames or By Drawings.

NOTE 

Most of the controls in the Onion Skin view are only accessible in Advanced Onion Skin 
mode—see About Advanced Onion Skin.
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Displaying Only Key Drawings, Breakdowns or In-Betweens in Onion 
Skin

If you have a lot of drawings and only want to display certain kinds of drawings in the Onion Skin, you can 
make the Onion Skin only include drawings that have been marked as keyframes or breakdowns and ignore 
all the in-betweens. Likewise, you can also make the Onion Skin only display drawings that are not marked 
(in-betweens) and ignore key drawings and breakdowns.

In order to be able to do this, you must properly mark your drawings first—see About Marked Drawings on 
page 814. 

NOTE 

If you make the Onion Skin only display specific kinds of drawings, the Onion Skin will 
automatically select the drawings to display by drawing rather than by frame, and will only take 
drawings of the selected types in account. For example, if the Onion Skin is set to include two 
drawings before and after the current frame, and is set to only display key drawings, it will display 
the two nearest key drawings before the current frame and the two nearest key drawings after the 
current frame.

For more information about selecting drawings by frame or by drawing, see Selecting Drawings to 
Include in Onion Skin by Frames or by Drawings.

How to display specific kinds of marked drawings in the Onion Skin

 1. Make sure your key drawings and breakdowns are properly marked—see About Marked Drawings 
on page 814.
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 2. Add the Onion Skin toolbar to your workspace by doing one of the following:

 l Right-click on a toolbar and select Onion Skin.

 l In the top menu, select Windows > Toolbars > Onion Skin.

The Onion Skin toolbar appears.

 3. Do one of the following to enable Onion Skin:

 l In the Tools toolbar, click on the   Onion Skin button.

 l In the Timeline view, click on the   Onion Skin button left of the layer name.

 l In the top menu, select View > Onion Skin > Show Onion Skin.

 l Press Alt + O.

 4. Using the Onion Skin toolbar, do one or several of the following:

 l To only show key drawings in the Onion Skin, click on  Show Key drawings

 l To only show breakdown drawings in the Onion Skin, click on  Show Breakdown 
drawings

 l To only show in-between drawings in the Onion Skin, click on  Show In-between 
drawings

 l To only show retake key drawings in the Onion Skin, click on  Show Retake Key drawings

 l To only show retake breakdown drawings in the Onion Skin, click on  Show Retake 
Breakdown drawings.
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 l To only show retake in-between drawings in the Onion Skin, click on  Show Retake In-
between drawings.

 l To show more than one types of drawings at the same time, click on the buttons for each 
type of drawings you want to display in the Onion Skin.

 l To go back to showing all drawings in the Onion Skin, click on all the buttons you clicked on 
to toggle them back off. 

 5. Do one of the following as many times as necessary to only include the drawings you want to see in 
the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next Drawing 
button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next Drawing 
button in the Camera/Drawing view toolbar.
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About Displaying the Onion Skin in the Other Layers 

T-LAY-003-006

When doing paperless animation, you typically only need the Onion Skin to display for the current layer. It is 
however possible to display the Onion Skin for multiple layers simultaneously. The procedure is different 
depending on whether you work in the Camera or Drawing view. 

836

Harmony 21 Premium User Guide                          



Chapter 7: Paperless Animation

Displaying the Onion Skin for Other Layers in the Camera View

In the Camera view, when Onion Skin is enabled, the Onion Skin of the currently selected layer is always 
displayed. However, it is also possible to enable persistent Onion Skin on other layers in your scene. You can 
do this by clicking the Onion Skin button just left of individual layers in the Timeline view. When Onion Skin is 
enabled on specific layers, the Onion Skin for these layers display along with the Onion Skin of the current 
layer, allowing you use both as reference. 

When you enable Onion Skin using the Onion Skin button in the Tools toolbar, persistent Onion Skin is 
automatically enabled on the currently selected layer. Hence, if you want to switch to a different layer and 
hide the Onion Skin for the layer you are no longer working on, you can also use the Onion Skin button next to 
that other layer to disable Onion Skin on it. 

NOTE 

If you are using Onion Skin with a complex scene with a lot of drawing layers, such as in Cut-Out 
animation, there are more advanced techniques for displaying and hiding Onion Skin on multiple 
layers. For more information, see About Using Onion Skin in Cut-out Animation

How to display Onion Skin on multiple layers in the Camera view

 1. Select the layer and frame on which you want to draw.

 2. In the Timeline view, click on the  Onion Skin icon just left of the selected layer to enable Onion 
Skin on it.

The icon will light up, indicating that Onion Skin is now enabled for this layer.

 3. Click on the Onion Skin icon for each layer that you want to include in the Onion Skin. 
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The Onion Skin for all layers on which it is enabled will display in the Camera view. 

NOTE 

If you want to remove a layer from the Onion Skin, you can click on its  Onion Skin icon again 
to disable Onion Skin for that layer However, keep in mind that, when Onion Skin is enabled 
on any layer, it always includes the currently selected layer as well. Therefore, if you disable 
Onion Skin on the current layer, the Onion Skin for that layer will keep displaying.
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Displaying the Onion Skin for Other Layers in the Drawing View

By default, the Drawing view only displays the drawing in the current layer. However, if you enable the Light 
Table, drawings in other layers will be displayed in the Drawing view as well. You can then enable the Enable 
Onion Skin in Other Elements option to display the Onion Skin for these other layers.

With the Enable Onion Skin in Other Elements option, for each drawing in the current layer that is displayed 
in the Onion Skin, the drawing in other layers that are aligned with this drawing is also displayed. Hence, the 
drawings in the Onion Skin for other layers are always aligned in time with the drawings in the Onion Skin for 
the current layer. 

NOTE 

To help you differentiate the different layers in the Onion Skin, while the Onion Skin for the current 
layer is displayed in red for previous drawings and green for next drawings, the Onion Skin for 
inferior layers is displayed in yellow, and the Onion Skin for superior layers is displayed in blue.

How to display Onion Skin for other layers in the Drawing view

 1. Select the layer and frame on which you want to draw.

 2. Enable Onion Skin—see Enabling the Onion Skin.

 3. Select the amount of previous and next drawings to display in the Onion Skin—see Selecting 
Drawings to Display in Onion Skin.

 4. Do one of the following to enable the Drawing view's Light Table:

 l In the Drawing toolbar, click on the  Light Table button.

 l In the top menu, select View > Light Table.
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 l Press Shift + L.

With Light Table enabled, the drawings for other layers display in the Drawing view, in washed 
colours. 

 5. Add the Onion Skin toolbar to your workspace by doing one of the following:

 l Right-click on any existing toolbar and select Onion Skin.

 l In the top menu, select Windows > Toolbars > Onion Skin.

 6. In the Onion Skin toolbar, click on the Enable Onion Skin for other elements button.

Onion Skin for other elements will display in the Drawing view. The Onion Skin for inferior layers 
will be displayed in yellow, and the Onion Skin for superior layers will be displayed in blue.
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NOTE 

This option is also availble in the View Menu of the Onion Skin view—see About Advanced 
Onion Skin.
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About Advanced Onion Skin

Advanced Onion Skin is a special mode for Harmony's Onion Skin future. It is very similar to regular Onion Skin, 
except with two main key differences:

 l You can select which drawings to display in the Onion Skin one by one, and exclude some specific 
drawings. With regular Onion Skin, you can only choose to include a span of drawings before and after 
the current frame. 

 l You can quickly adjust the opacity of the drawings in the Onion Skin, either by adjusting the opacity 
scale for all the drawings, or the opacity level of individual drawings.

Hence, Advanced Onion Skin is useful in situations where you need extra control on which drawings display in 
the Onion Skin and when you need to fine-tune how visible each drawing is. 

Advanced Onion Skin is configured using the Onion Skin view. This view contains some options that apply to 
both styles of Onion Skin. However, it has drawing visibility switches and opacity sliders that are specifically 
designed for use with Advanced Onion Skin.

This section will teach you how to use the Onion Skin view to enable and configure Advanced Onion Skin.
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Enabling Advanced Onion Skin

To use Advanced Onion Skin, you must first enable it. You also need to add the Onion Skin view to your 
workspace, as it is required to configured which drawings are displayed in the Advanced Onion Skin.

NOTE 

When Advanced Onion Skin is enabled, you cannot use the Onion Skin handles in the Timeline 
view, nor the     Onion Skin Add/Remove Previous/Next Drawing buttons to adjust 
which drawings are displayed in the Onion Skin. You can only select the drawings to display in the 
Onion Skin using the Onion Skin view. 

How to add the Onion Skin view to your workspace

 1. Do one of the following:

 l In the top-right corner of a view, click on the  Add View button and select Onion Skin.

 l In the top menu, select Windows > Onion Skin.

The Onion Skin view is added to your workspace.

How to enable Advanced Onion Skin

 1. Do one of the following:

 l In the Tools toolbar, double-click on  Onion Skin and select Advanced Onion Skin.

 l In the Onion Skin view, click on the  Advanced Onion Skin button.

 l In the top-left corner of the Onion Skin view, open the  View Menu and select Advanced 
Onion Skin.

The controls for the Advanced Onion Skin are now accessible in the Onion Skin view.
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By default, Advanced Onion Skin displays the 10 previous drawings and the 10 next drawings. To 
adjust which drawings are displayed in the Onion Skin, see Selecting Drawings to Display in 
Advanced Onion Skin
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Selecting Drawings to Display in Advanced Onion Skin

Contrary to regular Onion Skin, Advanced Onion Skin allows you to select drawings to display in the Onion 
Skin one by one, even if those drawings are not contiguous. This is done using the toggle buttons at the top of 
the Onion Skin view:

Each switch represents a drawing before or after the drawing in the current frame. For example, if you toggle 
switches 1 and 3 on in the previous drawings switches, toggle switch 2 on in the next drawing switches, and 
toggle all other switches off, it will show the first and third drawing before the current drawing as well as the 
second drawing after the current drawing in the Onion Skin.

Often, you will want to toggle whole spans of drawings on or off. For example, all 10 previous and next 
drawings switches are toggled on by default, but you may only want to use 2 or 3 drawings before and after 
the current frame as references. Toggling all of these switches off one by one would be tedious. Fortunately, 
you can quickly toggle a span of drawings on or off by clicking and holding one of the switches, then sliding 
your mouse cursor over all the other switches you want to toggle. 

How to select which drawings to display in the Onion Skin

 1. By default, both previous and next drawings from 1 to 10 are included in the Onion Skin. To reduce 
the span of previous drawings included in the Onion Skin, click and hold on switch 10 in the left 
area of the Onion Skin view, then drag your mouse cursor until the switch corresponding to the last 
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drawing you want to remove from the Onion Skin.

For example, if you want to only include the previous drawings 1 to 4 in the Onion Skin, click and 
hold on switch 10, then drag the mouse cursor over to switch 5, to remove drawings 10 to 5 from 
the Onion Skin, leaving only 1 to 4. 

TIP 

If you want to exclude all previous drawings and only display next drawings, click and 
hold on switch 10 and drag all the way to switch 1.

 2. If you want to exclude any drawing that is currently included in the Onion Skin, click on its 
corresponding toggle switch to toggle it off.

 3. If you want to include any drawing that is currently excluded in the Onion Skin, click on its 
corresponding toggle switch to toggle it on. 
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 4. To expand the span of previous drawings included in the Onion Skin, click and hold on the switch 
corresponding to the first drawing excluded from the Onion Skin, then drag your mouse cursor to 
the switch corresponding to the last drawing you want to add to the Onion Skin.

 5. Repeat steps 1 to 3, but using the switches on the right side of the Onion Skin view, to select which 
next drawings to include in the Onion Skin.
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Adjusting the Opacity of Drawings in Advanced Onion Skin

Using the sliders in the Onion Skin, you can quickly adjust the opacity of the Onion Skin as a whole, as well as 
the opacity scale of previous drawings and next drawings. 

TIP 

By default, when you change the value of one of the sliders, all of the other sliders on that side of 
the Onion Skin view will follow. To be able to adjust the opacity of a single drawing without 
affecting others, you can disable the Link Sliders option of the Onion Skin view, located in its  
View Menu in the top-left corner. 

How to adjust the opacity of all drawings displayed in the Onion Skin

 1. In the Onion Skin view, click and drag on the slider in the middle, just beneath the  Advanced 
Onion Skin button. Drag the slider up to increase the opacity, or down to decrease it. 

How to adjust the opacity scale of  drawings displayed in the Onion Skin

 1. Make sure that Advanced Onion Skin is enabled—see Enabling Advanced Onion Skin.

 2. In the left area of the Onion Skin view, click and drag on the slider underneath the 1 switch to 
adjust the opacity of the first previous drawing.
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All the switches for drawings 1 to 10 will adjust to keep the opacity scale linear.

 3. In the left area of the Onion Skin view, click and drag on the slider underneath the 10 switch to 
adjust the opacity of the last previous drawing.

All the switches for drawings 1 to 10 will adjust to keep the opacity scale linear.

 4. Optionally, click and drag on a slider underneath any switch between 2 and 9 to make the scale 
into a segmented line.

 5. In the right area of the Onion Skin view, click and drag on the slider underneath the 1 switch to 
adjust the opacity of the first next drawing.
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 6. In the right area of the Onion Skin view, click and drag on the slider underneath the 10 switch to 
adjust the opacity of the last next drawing.

 7. Optionally, click and drag on a slider underneath any switch between 2 and 9 to make the scale 
into a segmented line.

NOTE 

If you adjust the opacity slider for drawing 1 or 10 again, the opacity scale will become 
linear instead of segmented. 
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How to adjust the opacity of individual drawings displayed in the Onion Skin

 1. Make sure that Advanced Onion Skin is enabled—see Enabling Advanced Onion Skin.

 2. In the top-left corner of the Onion Skin view, open the  View Menu and uncheck the Link Sliders 
option.

 3. Click and drag on the slider corresponding to the drawing for which you want to adjust the opacity. 

 4. Repeat until every drawing displayed in the Onion Skin has the desired opacity.

 5. If you want to set the opacity of drawings in the Onion Skin on a linear scale again, open the  
View Menu and check the Link Sliders option. Then, make any adjustment on any of the sliders for 
the previous or next drawings to make all of the sliders for previous or next drawings aligned again.
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About the Drawing Desk
T-ANIMPA-008-002

You can work on a portion of an animation sequence or specific drawings from different layers. To do this, select 
the segment needed in one or more layers in the Xsheet or Timeline view and then use the drawing desk to 
allow you to work only on these drawings. 

This can be useful went you need to reposition drawings, use the Shift and Trace feature, paint multiple 
drawings at once, or apply the same transformation to drawings for different layers—see About Shift and 
Trace  on page 857.

The Drawing Desk is only available in the Drawing view.
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Adding Drawings to the Drawing Desk

T-ANIMPA-008-004

You can send drawings your selected in the Xsheet view to the drawing desk. You can also send new drawings 
to an existing set in the Drawing Desk.

How to send several drawings to the drawing desk

 1. Do one of the following:

 l In the Xsheet or Timeline view, select a consecutive cell range from one or several 
layers. 

 l In the Xsheet view, hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on any 
cell to add it to the selection, even if it is not consecutive.

 2. Do one of the following:

 l In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

 l In the Xsheet view, right-click and select Send Drawings to Desk.

 l In the Xsheet view, hold down the Alt key and click on the selection.

The drawing desk opens on the side of the Drawing view.
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NOTE 

The drawing desk is by default on the left side of the Drawing view. You can change its 
positioning in the Preferences dialog box.

 3. If the drawing desk side panel is hidden, click the Arrow button, located on the left side of the view.

How to add more drawings to the drawing desk

 1. In the Timeline or Xsheet view, select the drawings to be added.

 2. Do one of the following:

 l In the Timeline or Xsheet view menu, select Drawings > Add Drawings to Desk 

 l Alt + click the selection.
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Modifying Thumbnails in the Drawing Desk

For your convenience you can modify the way the thumbnails are displayed in the Drawing Desk.

How to clear drawings and send new ones to the drawing desk

 1. Select a new drawing in the Timeline or Xsheet view.

 2. In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

The previous drawing desk selection is removed and replaced with the current selection.

How to change the size of drawing desk thumbnails

 l Right-click the drawing desk and select No Thumbnail, Small Thumbnail, Medium Thumbnail or 
Large Thumbnail.

How to change the position of a thumbnail in the drawing desk

 1. In the drawing desk, select the thumbnail.

 2. Click the Move Drawing Up  and Moving Drawing Down  buttons as needed, to move it to the 
new position in the drawing desk.

How to clear selected or all drawings from the drawing desk

 1. In the drawing desk, select one or more drawings to remove.

 2. Do one of the following:

 l Right-click the drawing desk and select Remove Selected Drawings or Remove All 
Drawings.

 l In the Drawing view, press Esc to remove all drawings.
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About Shift and Trace 
T-ANIMPA-008-003

When hand drawing animation, it is very important to stay on model as it is easy to lose the proportions or 
features of a character. The Shift and Trace feature lets you temporarily move a drawing so you can trace it on a 
new drawing. This is similar to animators working on an animation light table and using an entire character or 
cut-out pieces of a character and moving it underneath the new drawing to trace it.

When using Shift and Trace, drawings are not permanently modified. They are temporarily moved, rotated or 
scaled to help you trace over them. Once you are done, you can turn off Shift and Trace to reset all drawings to 
their original position, angle and size. 

If you use the Shift and Trace feature frequently, you can assign keyboard shortcuts for Shift and Trace routines 
in the Shortcuts tab of the Preferences dialog box.
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About the Shift and Trace Tool

The Shift and Trace tool allows you to shift and trace drawings from within the Camera view. Using the 
controls of the Shift and Trace tool, you can offset, rotate and scale the current drawing or neighbouring 
drawings and, using Onion Skin, trace over the offset drawings in new drawings, hence helping you preserve 
the volume and details across multiple drawings. 
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Enabling the Shift and Trace Tool

You can use the Shift and Trace tool by selecting it from the Tools toolbar or from the Shift and Trace toolbar. 
When selected, Shift and Trace becomes automatically enabled. 

Likewise, when selecting the Shift and Trace tool, Onion Skin becomes automatically enabled. It is through 
Onion Skin that you will see the outlines of neighbouring drawings and hence be able to trace over them in the 
current drawing. 

Once enabled, you can choose the amount of previous and next drawings to include in the Onion Skin as well 
as the options to use the Shift and Trace tool with.

NOTE 

If you need to use the Shift and Trace tool often, you can add the Shift and Trace toolbar to your 
workspace, which will allow you to quickly select and configure it. 

How to enable and configure the Shift and Trace tool

 1. Do one of the following to select the Shift and Trace tool:

 l In the Tools toolbar, double-click on the Hand  tool to open its pop-up menu and select 
Shift and Trace  tool.

 l In the Shift and Trace toolbar, click on the Shift and Trace Tool  button. 

Shift and Trace as well as Onion Skin become enabled. 

NOTE 

You can configure some options for the Shift and Trace tool in the Tool Properties view. For 
more information, refer to the Shift and Trace Tool Properties topic of the Reference Guide. 
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Shifting Drawings with the Shift and Trace Tool

With the Shift and Trace tool, you can temporarily move, rotate and scale drawings. By default, the Shift and 
Trace tool will work on the drawing at the current frame. However, you can offset another drawing appearing 
in the Onion Skin, allowing you to shift the drawing you want to trace without having to select it, and you can 
even select multiple drawings and shift them together. 

The simplest way to shift drawings is to shift the current drawing. When you select a drawing in the Timeline 
or Xsheet view, the Shift and Trace tool is already ready to move and transform this drawing. When using this 
method, you have to select the drawing you want to shift, shift it, then select the drawing you want to draw on 
and start tracing. 

Another approach is to use the Shift and Trace tool move drawings before or after the current drawing. When 
using this method, you can start by selecting the drawing you want to draw on, shift the drawing you want to 
trace over in the right position, and start tracing right away. 

At last, if you need to shift several drawings simultaneously, you can select several drawings with the Shift 
and Trace tool and transform them together.

How to shift the current drawing

 1. Do one of the following to select the Shift and Trace tool:

 l In the Tools toolbar, double-click on the Hand  tool to open its pop-up menu and select 
Shift and Trace  tool.

 l In the Shift and Trace toolbar, click on the Shift and Trace Tool  button. 

 2. In the Xsheet or Timeline view, select the drawing you want to shift.

A manipulator box appears around the selected drawing.
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Peg holes also appear below the field of the drawing. The left and right peg holes can be used to 
rotate the drawing around the centre peg hole. 

TIPS 

 l If you do not need the peg holes, you can hide them by toggling the Show/Hide 
Pegs  button off in the Tool Properties view. 

 l If you want the peg holes to be displayed on a different side of the camera field, you 
can select the border where you want the peg holes to be by using the drop-down 
just right of the Show/Hide Pegs  button in the Tool Properties view. 

 3. Do one of the following to extend the Onion Skin so as to include the drawings you want to trace 
over:
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 l In the Timeline view, click and drag on the Onion Skin brackets so as to make them include 
all the required drawings. 

. 

 l In the Camera view toolbar, use the Onion Skid Add One Previous Drawing , Onion Skid 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion 
Skin Add One Next Drawing  buttons. 

The drawings included in the Onion Skin will appear in the Camera view, in washed down red for 
previous drawings and washed down green for next drawings.

 4. If you want to move the drawing, click and drag on it.

 5. If you intend to rotate or scale the drawing, but want to do it from a different pivot point than the 
centre of the artwork, click and drag on the pivot point to reposition it. 
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 6. If you want to rotate the drawing around the pivot point, click on the rotation handle at the right of 
the bounding box and drag it clockwise or counterclockwise.

You can also rotate the drawing by clicking just outside one of the four corners of the bounding box 
and dragging clockwise or counterclockwise.

 7. If you want to rotate the drawing around its centre peg hole, click on one of the side peg holes and 
drag it clockwise or counterclockwise. 

 8. If you want to scale the drawing, click and drag on one of the four corners of the bounding box. 
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NOTE 

You can also adjust the position, scale, rotation angle and the position of the pivot point for the 
selection in the Info section of the Tool Properties view. 

How to select and shift a previous or next drawing

 1. Do one of the following to select the Shift and Trace tool:

 l In the Tools toolbar, double-click on the Hand  tool to open its pop-up menu and select 
Shift and Trace  tool.

 l In the Shift and Trace toolbar, click on the Shift and Trace Tool  button. 

 2. In the Xsheet or Timeline view, select the drawing in which you want to draw instead of the one 
you want to shift and trace over.

. 

 3. Do one of the following to extend the Onion Skin so as to include the drawings you want to trace 
over:

 l In the Timeline view, click and drag on the Onion Skin brackets so as to make them include 
all the required drawings. 

. 

 l In the Camera view toolbar, use the Onion Skid Add One Previous Drawing , Onion Skid 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion 
Skin Add One Next Drawing  buttons. 

The drawings included in the Onion Skin will appear in the Camera view, in washed down red for 
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previous drawings and washed down green for next drawings.

 4. In the Camera view, while holding down the Ctrl (Windows/Linux) or ⌘  (macOS) key, click on the 
Onion Skin of the drawing you want to shift

The control box of the Shift and Trace tool will appear around the drawing you just clicked on. From 
now on, all transformations done with the Shift and Trace tool will be done on that drawing.

 5. Using the Shift and Trace control box, move, rotate and scale the selected drawing until it is in the 
right position, for you to trace over it. 
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TIPS 

 l If you want to select the current drawing again, hold down the Ctrl (Windows/Linux) or ⌘  
(macOS) key and click on its artwork in the Camera view.

 l You can make the selection of other drawings easier by adding cross hairs to your 
drawings. Clicking on a drawing's cross hair while holding down the Ctrl (Windows/Linux) 
or ⌘  (macOS) key will also select that drawing—see Adding Cross Hairs with the Shift 
and Trace Tool on page 870.

How to select and shift several drawings simultaneously

 1. Do one of the following to select the Shift and Trace tool:

 l In the Tools toolbar, double-click on the Hand  tool to open its pop-up menu and select 
Shift and Trace  tool.

 l In the Shift and Trace toolbar, click on the Shift and Trace Tool  button. 

 2. In the Xsheet or Timeline view, select one of the drawings in the middle of the series of drawings 
you want to shift. 

. 

 3. Do one of the following to extend the Onion Skin so as to include at least all of the drawings you 
want to shift. 

 l In the Timeline view, click and drag on the Onion Skin brackets so as to make them include 
all the required drawings. 

. 

 l In the Camera view toolbar, use the Onion Skid Add One Previous Drawing , Onion Skid 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion 
Skin Add One Next Drawing  buttons. 

The drawings included in the Onion Skin will appear in the Camera view, in washed down red for 
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previous drawings and washed down green for next drawings.

 4. In the Camera view, while holding down the Ctrl (Windows/Linux) or ⌘  (macOS) key and the Shift 
key, click on the each drawing that you want to add to your selection. 

Once your selection includes multiple drawings, a red control box appears around the whole 
selection, and a  blue control box appears around each selected drawing.

 5. Using the red control box, move, rotate and scale all the selected drawings until they are in their 
intended position, angle and size.

TIPS 

 l When multiple drawings are selected, you can still shift individual drawings by 
manipulating their own blue control box.

 l If you want to select a single drawing again, release the Shift key but hold down the 
Ctrl (Windows/Linux) or ⌘  (macOS) key, then click on its artwork in the Camera 
view.

 l You can make the selection of other drawings easier by adding cross hairs to your 
drawings. Clicking on a drawing's cross hair while holding down the Ctrl 
(Windows/Linux) or ⌘  (macOS) key will also select that drawing—see Adding 
Cross Hairs with the Shift and Trace Tool on page 870.
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Tracing Drawings with the Shift and Trace Tool

Once you have shifted your reference drawing, you can start tracing over it with your preferred drawing tool. 

How to trace over drawings that you have shifted with the Shift and Trace tool

 1. In the Timeline or Xsheet view, select the drawing on which you want to draw. 

 2. Do one of the following to extend the Onion Skin so as to include the drawings you want to trace 
over:

 l In the Timeline view, click and drag on the Onion Skin brackets so as to make them include 
all the required drawings. 

. 

 l In the Camera view toolbar, use the Onion Skid Add One Previous Drawing , Onion Skid 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion 
Skin Add One Next Drawing  buttons. 

The drawings included in the Onion Skin will appear in the Camera view, in washed down red for 
previous drawings and washed down green for next drawings.

 3. In the Tools toolbar, select the Brush  or Pencil  tool. 

 4. Using your drawing tool, trace over the washed down lines. 
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Adding Cross Hairs with the Shift and Trace Tool

Cross hairs are visual indicators that you can add on drawings when using the Shift and Trace tool. A cross hair 
added to a drawing will appear in the same position on other drawings in the layer, unless that drawing is 
shifted. When shifting a drawing with the Shift and Trace tool, the cross hair moves along with it. Hence, this 
can serve as a quick visual indicator of how much the current drawing and the other drawings in the Onion 
Skin are offset from each other. 

Another use for cross hairs is that you can use them to select drawings with the Shift and Trace tool. Without 
cross hairs, you can select one of the drawings that are visible in the Camera view by holding the Ctrl 
(Windows/Linux) or ⌘  (macOS) key and clicking on its artwork. With cross hairs, you can also change the 
selection by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key and clicking on a drawing's cross hair. 

How to add cross hairs

 1. Do one of the following:

 l In the Tool Properties view, click on the Set Add Cross Hair Mode  button.

 l In the Shift and Trace toolbar, click on the Set Add Cross Hair Mode  button.

 2. In the Timeline or Xsheet view, select the drawing on which you want to add cross hairs.

 3. In the Camera  view, click on the location where you want to add a cross hair. 

A cross hair is added where you clicked on every drawing in the current layer. On drawings that are 
offset with the Shift and Trace tool, the corresponding cross hair is also offset. 
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Removing Cross Hairs with the Shift and Trace Tool

Once you are done with the cross hairs you have added with the Shift and Trace tool, you can instantly remove 
all of them from your drawings.

How to remove all cross hairs

 1. Do one of the following:                 

 l In the Tool Properties view, click on the Remove All Cross Hair  button.

 l In the Shift and Trace toolbar, click on the Remove All Cross Hair  button.
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Disabling and Clearing Shift and Trace Transformations

All transformations made on drawings with the Shift and Trace tool are temporary, so that they do not affect 
your animation in the end. Once you are done using the Shift and Trace tool, there are two ways to reset 
drawings to their original position:

 l By disabling Shift and Trace. This will preserve the offset position of the drawings, but they will appear 
in their original position until Shift and Trace is enabled again.

 l By resetting all drawings to their original position. The Shift and Trace tool can undo all of the 
transformations done with it in a single click. 

NOTE 

Shift and Trace transformations are not saved in the scene. If you close and re-open your scene, all 
drawings will be reset to their original position.

How to temporarily disable Shift and Trace

 1. Do one of the following:

 l In the Tool Properties view, click on Disable/Enable Shift and Trace  to toggle it off.

 l In the Shift and Trace toolbar, click on Disable/Enable Shift and Trace  to toggle it off.

Drawings that were offset with the Shift and Trace tool will now appear in their original position. If 
you re-enable Shift and Trace later, they will appear offset again. 

How to reset the currently selected drawing to its original position

 1. Do one of the following:

 l In the Tool Properties view, click on the Reset Selected Drawings Shift Position  button.

 l In the Shift and Trace toolbar, click on  the Clear the shift information for all drawings     
button.

The currently selected drawing will be set back to its original position, angle and scale. 

How to reset one or several drawings to their original position

 1. In the Timeline view, click and drag on the Onion Skin brackets so as to make them include the 
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drawings you want to reset.

. 

 2. Select one or several drawings by doing one of the following:

 l If you want to reset a different drawing than the one selected with the Shift and Trace tool, 
press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key, then click on that drawing in 
the Camera view. 

 l If you want to reset several of the drawings visible in the Camera view, press and hold the 
Ctrl (Windows/Linux) or ⌘  (macOS), then click on the Onion Skin of the first drawing you 
want to select. Then, while holding both the Ctrl (Windows/Linux) or ⌘  (macOS) and Shift 
keys, click on the Onion Skin of each drawing you want to add to your selection. 

 3. Do one of the following:

 l In the Tool Properties view, click on the Reset Selected Drawings Shift Position  button.

 l In the Shift and Trace toolbar, click on  the Clear the shift information for all drawings     
button.
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The selected drawings will be set back to its original position, angle and scale. 

How to reset all drawings to their original positions

 1. Do one of the following:

 l In the Tool Properties view, click on the Reset All Drawings Shift Position  button.

 l In the Shift and Trace toolbar, click on the Clear the shift information for the current drawing  
 button.

All drawings that were offset with the Shift and Trace tool will be reset to their original position, 
angle and scale.
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About Shift and Trace with the Drawing Desk

The Drawing Desk is the legacy method of performing Shift and Trace. In the Timeline or Xsheet view, you can 
select drawings to add to the drawing desk. In the Drawing view, you can select drawings from the Drawing 
Desk, offset them to the preferred position, angle and size. Then, using Onion Skin, you can trace over the 
offset drawings in other drawings, hence helping you preserve the volume and details across multiple 
drawings. 
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Enabling Shift and Trace in the Drawing Desk

T-ANIMPA-008-005

You need to send drawings to the Drawing Desk and enable the Shift and Trace option to be able to use it—
see About the Drawing Desk on page 853. 

How to enable the Shift and Trace mode

 1. Go to the Drawing view.

 2. In the Tools toolbar, click the Show Onion Skin  button—see Paperless Animation Tools.

 3. Send the selected drawings to the drawing desk—see About the Drawing Desk on page 853.

 4. In the Drawing Desk toolbar, click the Shift and Trace Enable  button.

Registration marks appear at the bottom of your drawings. 
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Shifting Drawings with the Drawing Desk

T-ANIMPA-008-006

Once the Shift and Trace option is enabled, you can use the controls to shift the drawings. This does not modify 
your original drawings. 

How to shift

Using the shift and trace manipulator, you can move the registration marks to reposition selected 
drawings while you work.

 1. In the Drawing Desk toolbar, click the Shift and Trace Manipulator  button.

At the bottom of the Drawing view, a window displays a zoomed in view of the manipulator. You 
can move the dividing line between the manipulator and the Drawing view to resize the area.

 2. In the Drawing view, transform the drawing as needed, positioning it between your two key poses.

 l To reposition, click and drag the drawing to a new area.

 l To rotate from the centre peg, click the flat peg hole and rotate.
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 l To scale, pull or push on the triangle control.

 l To show the pivot point, hold Alt. The pivot point is in the middle of your current 
drawing view. To rotate from the pivot point, hold Alt and rotate.
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 l To scale from the pivot point, hold Shift and move your cursor.

 l Click and drag the pivot point to move it to a new position. Once the pivot point is 
moved, you can hold Alt and move your drawing to show it again.

 3. To select another drawing and reposition it, hold down Ctrl (Windows/Linux) or ⌘  (macOS).
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 4. If necessary, click the Shift and Trace Reset  button to reset the position of the modified drawing.
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Tracing Drawings with the Drawing Desk

T-ANIMPA-008-007

You can trace your new drawings once you shifted the reference artwork. 

How to trace

 1. In the drawing desk, select the drawing into which you want to trace.

 2. Select the check box next to the drawing you want to allow to be temporarily transformed. By 
default, all drawings are enabled for Shift and Trace operations.

 3. Select the drawing you want to move.

 4. If you want to trace more than one drawing at the same time, you can link them together. In the 
drawing desk, select several drawings and click the Link Drawings  button to lock their position 
together—see Tracing Drawings with the Drawing Desk.

 5. In the Tools toolbar, select a drawing tool.

 6. In the Drawing view, trace your drawing.
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Linking Drawings in the Drawing Desk

T-ANIMPA-008-008

When using the Shift and Trace feature, you can link different drawings from the drawing desk, so they move 
together when dragging or scaling. These drawings can be from different columns in the Xsheet view.

How to link your shift and trace drawings

 1. In the drawing desk, display the drawings you want to use for the Shift and Trace operation.

 2. Hold down Ctrl (Windows/Linux) or ⌘  (macOS) and select the drawings you want to link together.

 3. In the Drawing Desk toolbar, click the Link Drawings button to enable linking.

Coloured boxes appear beside drawing thumbnails to identify different linked drawing groups.

A link icon appears beside the currently selected drawing and all drawings linked to it.

 4. Shift your linked drawings.
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 5. To unlink your drawings, select one of the linked drawings and click the Link Drawing button 
again to disable it.

 6. You can shift your drawings independently.

 7. To unlink your drawings, select one of the linked drawings and click the Link Drawing button 
again to disable it.
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Enabling Onion Skin in the Drawing Desk 

You may end up with a lot of drawings in your onion skin display while working with the Shift and Trace 
feature. You can disable individual drawings from the onion skin display without deactivating them.

How to enable and disable individual onion skin drawings

 1. In the Tools toolbar, click the Onion Skin  button.

 2. In the Drawing Desk, click on the drawing’s Onion Skin  button to enable or disable it. When 
enabled, the icon's  colour changes .
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About Art Layers
T-RIG-005-000

Art layers give you the possibility to divide the artwork in your drawing on different layers. For example, you 
can separate the outline and colour fill on two art layers, similar to 1950s traditional cell animation. These art 
layers are contained within a single drawing as opposed to the layers in the Timeline view or Xsheet columns 
where individual drawings with individual timing are stacked one on top of the other—see About Art Layers 
on page 887.

Toon Boom Harmony Premium drawings include four art layers. 

 l Overlay on page 888

 l Line Art on page 888

 l Colour Art on page 889

 l Underlay on page 889

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour Art are 
displayed. You need to enable the Support Overlay and Underlay Arts option in the Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and facilitate 
creation and revision.
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Overlay

The Overlay layer can serve multiple purposes:

 l Highlights and tones

 l Annotations and corrections

 l Sketching

You can also draw in the Overlay layer as it's a regular layer.

Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The outline is 
drawn in the Line Art layer and colour is painted in the Colour Art layer.
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Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn in the 
Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are generated from Line Art 
to contain the painted area.

When you are doing rough animation, you may want to send a clip for feedback or approval before carrying on 
with your work. If you have several characters in your project that are overlapping, it may be difficult to 
understand what is going on as you can see through the characters. Toon Boom Harmony Premium can 
generate a matte automatically in the Underlay, or even in the Colour Art layer, and fill all the zones inside 
your characters to make them opaque. This process is fast and easy, and allows you to send easy-to-
understand movies.

Underlay

The Underlay layer can serve multiple purposes. It is frequently used by animators to sketch rough animation 
or generate a matte colour when doing line testing.
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Separated Lines and Colours

A  drawing is composed of line and colour filling layers. Lines and colours can be separated or kept together, 
depending on which animation process you use. The following diagram presents Line Art and Colour Art 
layers recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the Line Art 
when drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art. 

Once the drawing sequence is completed for paperless drawings, you can proceed with creating Colour Art 
strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from Line Art option to 
create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

 l After the full drawing is completed in Line Art

 l While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to patch gaps. 
Use the Auto-Create Colour Art from Brush option to create the strokes at the same time as the lines are 
drawn. This creates strokes from the lines and brush strokes created in the Line Art while you draw and is 
useful for fixing drawings. However, if you are drawing a new sketch, it is better to create the strokes afterward 
using the Create Colour Art from Line Art option.

NOTE 

Make sure to select the Advanced Art Mode in the Preferences dialog box to use this feature.
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Enabling Overlay and Underlay Art Layers

T-LAY-002-004

By default, the Overlay and Underlay art layers are disabled to simplyify the workflow. You can enable the 
support of those additional art layers in the Preferences panel.

How to enable the Support Overlay and Underlay Arts option

 1. Select Edit > Preferences ( Windows/Linux ) or Harmony Premium > Preferences ( macOS ).

 2. In the Preferences dialog box, select the Advanced tab.

 3. In the Advanced Options section, select the Support Overlay and Underlay Arts option.

 4. Click OK.
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Switching Between Art Layers 

T-RIG-005-000A

You can use the Art Layers toolbar and keyboard shortcuts to switch between art layers.

How to switch between drawing layers

 1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layers, 
you can edit the select layer without affecting the other one.

 2. Click the Preview All Enabled Art Layers   button to display all layers together. Even when the 
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only 
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
will only be able to see the selected art layer by itself if you enable the Current Drawing on Top  
option located in the Camera bottom toolbar.

NOTE 

To edit both Line Art and Colour Art at the same time, you must enable the 
Apply to Line Art and Colour Art  button in the Tool Properties of the tools 
supporting the operation.

How to switch between the drawing layers in Advanced Art mode

 1. In the  Art Layer toolbar, click the Overlay Art , Line Art , Colour Art  or Underlay Art  
buttons to display the appropriate layer—see How to enable the Support Overlay and Underlay 
Arts option on page 891. When switching art layers, you can edit the selected layer without 
affecting the other one.

 2. Click the Preview All Enabled Art Layers  button to display all the layers together. The other 
ones are only displayed as a reference. By default, the Preview mode is always enabled in the 
Camera view. You can view only the selected art layer if you select the Current Drawing on Top  
option in the Camera bottom toolbar.
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Creating Colour Art from Line Art 

T-RIG-005-000B

Lets you use the outline you traced on one of the four embedded layers (line art, colour art, overlay, underlay) 
and create invisible strokes to paint your drawings on separate layers. This provides more inking and painting 
flexibility. 

You can also configure this option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones from the Line Art layer

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Tool Properties view, click the Permanent Selection  button if you want to apply the 
operation on all drawings in the layer.

 3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection 
around the entire animation sequence if you want to apply the operation to all your drawings.

 4. In the Drawing View toolbar, click the Create Colour Art from Line Art  button or press *.

How to create strokes with the  Create Colour Art Automatically option

 1. In the Tools toolbar, select the Brush tool. 

 2. In the Tool Properties view, enable the  Create Colour Art Automatically  option.

 3. Draw the required lines. 

 4. Once you're done, deselect the  Create Colour Art Automatically  option. 

You are now ready to paint.

How to configure the Create Colour Art from Line Art option

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Tool Properties view or the Drawing View toolbar, Shift + click the Create Colour Art from 
Line Art  button.

The Configure Line Art to Colour Art dialog box opens.
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Parameter Description

Use rendered version of the 
drawing

Renders the drawing and vectorize it to calculate the position of the 
centreline that will produce the colour art stroke.

Maximum Resolution for 
rendered image

The size of the rendered image.

Threshold for rendered 
image

The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered 
Beziers

This value represents how precise the fitting of the colour art zone in 
relation to the line art will be.

Source layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you 
want the colour art to be created from.

Destination layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you 
want the colour art to be created on.

Clear Destination Art Layer 
First

Deletes the content before the colour art is added. This is useful when you 
already have artwork on the destination layer.

Perform Line Art to Colour 
Art Operation Immediately

Performs the Create Colour Art from Line Art command when you click 
OK.
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Generating a Matte

T-ANIMPA-006-013

You can quickly generate a matte to be displayed behind your rough animation so you don't see the 
background through the drawings. It can be generated in any art layer.

How to generate a matte

 1. Do one of the following:

 l In the Tools toolbar, select the Select  tool.

 l Press Alt + S.

 2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

NOTE 

You can also apply the operation to all the drawings in the layer at the same time.

 3. Do one of the following:

 l From the top menu, select Drawing > Generate Auto-Matte. 

 l In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

 4. If you want to create a matte for all the drawings included in your layer, select the Apply to All 
Drawings option.

 5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower 
value, the closer to your lines’ contours the matte will be shaped. The higher the value, the looser 
the matte will be shaped.
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 6. In the Source Art menu, select the layer from which you want the matte created: Line Art,Colour 
Art, Underlay or Overlay.

 7. In the Destination Art menu, select the layer on which you want the matte to be created: Line 
Art,Colour Art, Underlay or Overlay.

 8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

 9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case 
you ever need to keep them for later), select the Copy Stroke in Destination option.

 10. Click OK.

896

Harmony 21 Premium User Guide                          



Chapter 7: Paperless Animation

Flipping Animation
T-ANIMPA-006-010

Using the Easy Flipping toolbar, you can rapidly flip through drawings in the Drawing view, just as you would 
with paper drawings in traditional animation. 

How to use the Easy Flipping toolbar

 1. Switch to the Drawing view. 

 2. In the top menu, select Windows > Toolbars > Easy Flipping to enable the Easy Flipping toolbar.

 3. In the Easy Flipping toolbar, click the  Previous  or  Next  button to see the previous or next 
drawing of your animation.

 4. To display drawings in the first frame after you reach the last frame of your animation, select the 
Loop option.

 5. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

The further you move the slider to the left or right, the faster the drawings will flip.

 6. In the Preroll field, enter the amount of drawings to automatically flip through before and after the 
current drawing.

 7. In the FPS field, enter the speed at which you would like to automatically flip through your 
drawings, in frames per second. 

 8. Click on the Easy Flip button to automatically flip through the drawings based on the Preroll and 
FPS settings.

By default, the Flipping toolbar will flip through all drawings in the range specified in its Preroll field. 
Optionally, you can use the Flip toolbar to only flip through certain types of drawings, such as key drawings or 
breakdowns, provided that you marked these drawings as such prior—see About Marked Drawings.

How to use the Flip toolbar

 1. In the top menu, select Windows > Toolbars > Flip.

897



 2. Click on the corresponding button for each type of drawing you wish you flip through:

Icon Drawing Type

Key Drawing

Breakdown

In-between (Unmarked drawings)

Retake-Key

Retake-Breakdown

Retake-In-between

The Easy Flipping toolbar will only flip through drawings marked with the enabled drawing types.

NOTE 

If no drawing types are selected in the Flip toolbar, the Easy Flipping toolbar will flip through 
all drawing types.
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Previewing and Playing Drawings
It is a good idea to preview your drawings to check your animation's ink and paint, verify that there are no 
colour mistakes, or to play your animation in real time. You can do this by scrolling through your drawings or 
pressing F and G. You can also use the Preview option in the Xsheet view.

How to preview drawings from the Xsheet view

 1. Save your scene. 

 2. Do one of the following:

 l From the top menu, select File > Save.

 l Click the Save  button.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).

 3. In the Xsheet view, select the range of drawings or the whole column to preview.

 4. Open the Xsheet view menu  and select View > Preview Selected Drawings.

The Play application opens and loads the selected drawings.

 5. In the Play window, press the Play  button to play back your drawings.

 6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence 
while looping the playback.
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Previewing Animation with Mini Playback
You can quickly preview parts of your animation using Mini Playback. Mini Playback allows you to quickly 
preview a short span of animation starting a few frames before the current frame and ending a few frames 
after the current frame, at a customizable frame rate. 

How to use Mini Playback

 1. In the Timeline or Xsheet view, select a frame between the animation frames that you want to 
preview. 

 2. Do one of the following to add the Mini Playback toolbar to your workspace:

 l In the top menu, select Windows > Toolbars > Mini Playback.

 l Right-click on any existing toolbar and select Mini Playback. 

 3. In the Mini Playback toolbar, click on the  Mini Playback Dialog button. 

The Mini Playback dialog appears.

NOTE 

You can also open the Mini Playback dialog by selecting Play > Mini Playback from the 
top menu.

 4. In the Frame Rate drop-down, select the frame rate at which you want to preview your animation, 
in frames per second, or leave it to Same as Scene if you want to preview your animation at the 
frame rate set for your scene. 

 5. In the Before field, enter the amount of frames before the current frame to play. 

 6. In the After field, enter the amount of frames after the current frame to play. 

 7. Click on the  Play button.

Your scene starts playing at the chosen amount of frames before the current frame, and stops 
playing at the chosen amount of frames after the current frame.

 8. If you are satisfied with the Mini Playback configuration, you can close the Mini Playback dialog, and 
you can do one of the following to start Mini Playback again:
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 l In the Mini Playback toolbar, click on the  Mini Playback button.

 l In the top menu, select Play > Start Mini Playback. 
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Chapter 8: Scene Staging

Setting up your scene can be compared to building a set for a television show. This is the point when you 
position each scene element such as the camera frame, the background elements and the characters.

To learn how to position and animate your camera, see Camera Set-up and Animation on page 1333.

903



About Layer Position

Setting up the scene also involves positioning the different scene elements within the camera frame.

At this time, the elements are set to a static position. See Digital Animation on page 985 to learn how to 
animate the elements and the camera.
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Disabling Animation Keyframe Creation When Transforming 
Elements

T-HFND-008-001

By default, when you move, rotate, scale or skew elements in your scene using the  Transform tool or any of 
the  Advanced Animation tools, Harmony records the position of that element at the current 
frame into a keyframe. This means that, if you transform the same element on several frames, it will become 
animated. This is because the Animate mode of Harmony is set to  Animate Current Frame by default, to 
facilitate animation.

When staging a scene, you usually want to position, rotate, scale and skew elements throughout the length of 
the scene, not just at the current frame. It is possible to do this by setting the Animate mode to Animate Off. 
When Animate Off mode is selected, any transformations you make to layers, pegs deformations or other 
elements to your scene using the  Transform tool or the  Advanced Animation tool is applied 
across your entire scene, without creating a keyframe at the current frame.

If you set the Animate mode to Animate Off and reposition an element that is already animated, the element 
will be offset on every existing keyframe for this element, offsetting its entire animation. This can be very useful 
if you need to reposition, rotate or scale an element after having animated it.

How to set the Animate mode to Animate Off

 1. Do one of the following:

 l In the Tools toolbar, click on the Animate mode button which, depending on the currently 
selected mode, will either have the  Animate Current Frame,  Animate Onion Skin 
Range or  Animate Off icon, and select   Animate Off in the pop-up menu.

 l In the top menu, select Animation > Animate > Animate Off. 
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Selecting Layers
T-HFND-008-002

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform  tool. When using this tool, its 
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection  Mode 
option in the Tool Properties view is disabled or it will limit the selection to pegs only.

How to select a layer in the Camera view

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

 3. In the Camera view, click on the element to be repositioned. You can select more than one element 
at a time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to select from the Timeline or Xsheet view

 l In the Timeline view, click the layer corresponding to the element you want to reposition. 

 l In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.

How to select non-adjacent elements in the Timeline or Xsheet view

 l In the Timeline view,  hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on any layers that 
you would like to add to the selection.

 l In the Xsheet view,  hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on any columns that 
you would like to add to the selection.

  The non-adjacent, selected layers and columns are highlighted in the Timeline and Xsheet views.

How to select all elements within a group in the Node view

 1. In the Node view, navigate to the group whose elements you want to select.

 2. Hold down Alt and drag a marquee selection around the group node.
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All elements within that group are selected.

How to select all elements within a group in the Timeline view

 1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.
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Setting Bounding Box Styles
You can change the display style of selected elements to a bounding box style. This removes the default 
overlay highlight and leaves only the bounding box around the selected element.

How to set the bounding box selection style

 1. In the Camera view bottom toolbar, click the BBox Selection Style  button.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it 
hard to locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar 
to focus on the selected node in the Node view. You can also select elements in the Timeline or Xsheet view. 
This can be useful when there are too many objects in the scene or when an object is hard to grab. Finally, you 
can select all the elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera or Node view, select a layer.

 2. Do one of the following:

 l From the Timeline view menu, select View > Centre on Selection or press O.

 l In the Timeline view toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Node view

 1. In the Camera or Timeline view, select a layer.

 2. Do one of the following:

 l From the Node View menu, select View > Centre on Selection. 

 l In the Node View toolbar, click the Centre On Selection  button. 

 l In the Node view, press O.
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About the Transform Tool 
T-HFND-008-003

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera 
view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is 
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

NOTE 

Refer to About 3D Space Positioning on page 961 to learn about the 3D Transform tool and how to 
position elements in 3D space.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal 
and vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip 
Scale Y will perform a flip on your drawing layer following its original axis.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Repositioning Temporary Pivots with the Transform Tool

T-HFND-008-004

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can 
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is 
only moved temporarily. When animating the position, the interpolation is calculated from the permanent 
pivot position—see About Advanced Animation Tools on page 923.

How to temporarily reposition the pivot point

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously 
repositioned.

 4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this 
position as long as you do not deselect the drawing. Using the Transform tool to reposition your 
pivot will temporarily override the existing pivot point position until you complete the current 
transformation. Then it returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a 
ghost so you know where it is and also from where the animation will be interpolated when you 
create motion paths. The animation is always interpolated from the original pivot and not the 
temporary pivot.
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Panning with the Transform Tool

T-HFND-008-005

You can pan (translate) a layer using the Transform tool.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 

 2. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 3. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click 
on each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 4. Move the cursor over the artwork. When the cursor changes into , click and drag on the artwork 
to move it.
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Rotating with the Transform Tool

T-HFND-008-006

You can rotate a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to rotate 
from a different point.

How to rotate a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 

 2. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 3. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click 
on each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 4. Place  the pointer outside of a corner of the bounding box. When the cursor changes into, , then 
click and drag to rotate.

915



NOTE 

You can display a rotation handle on the bounding box when transforming a 
layer. In the Preferences dialog box, select the Camera tab and then select the 
Use Rotation Lever with Transformation Tools option. This preference is off by 
default.                         
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Scaling with the Transform Tool

T-HFND-008-007

You can scale a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to scale 
from a different point.

How to scale a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 

 2. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 1. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click 
on each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 2. Move the cursor over any of the yellow control points on the manipulator box, then click and drag 
to scale the layer. 
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NOTE 

When scaling your selection, you can hold down Shift to preserve the proportions 
between its width and height.
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Skewing with the Transform Tool

T-HFND-008-008

You can skew a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to skew 
from a different point.

How to skew a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 

 2. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 3. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click 
on each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.
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 4. Do one of the following:

 l Move the cursor over one of the vertical edges of the manipulator box, then click and drag up 
or down to skew the layer vertically. 

 l Move the cursor over one of the horizontal edges of the manipulator box, then click and drag 
left or right to skew the layer horizontally. 
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Flipping with the Transform Tool

T-HFND-008-009

You can flip a layer using the Transform tool. There are two ways to flip.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

 

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Camera view, use the Transform  tool to select a drawing layer to flip.

 4. Do one of the following:

 l From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

 l In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  
buttons.

 l Press 4 or 5. 

How to flip an element following its original axis

 

 1. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 2. In the Camera view, use the Transform  tool to select an element that has already been 
transformed.

 3. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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Manipulation with the Transform Tool

When enabled, this mode allows the transform tool to select these controls, add them to the existing 
bounding box, and modify them in the same way as a peg. This is particularly useful for modifying both pegs 
and deformation controls at the same time with the same bounding box. It also allows for controls on different 
nodes and in different deformations to be modified with the same transformation.

Certain deformations and controls can be selected and transformed with other Drawings and Pegs by 
enabling the Mixed Manipulation Mode.

How to enable the Mixed Manipulation Mode using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T

 2. In the Tool Properties view, enable the Mixed Manipulation Mode.

 3. In the Camera view, click on the Curve manipulator, Offset Manipulator, or Free Form Deformation 
you want to transform.

TIP 

Enabling the Control Selection Mode will allow lasso selections of deformation controls. 
This is helpful when multiple controls need to be selected in an area.

The selected controls will now have a bounding box around them. This bounding box can be manipulated 
in the same way as selected pegs and drawings.
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About Advanced Animation Tools
T-HFND-008-010

You can also use the advanced animation tools to position your layers. The difference between these tools and 
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as 
the Transform tool adjusts all parameters together.

You can find the advanced animation tools in the Advanced Animation Tools toolbar.
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Repositioning Permanent Pivots

Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the 
position of the drawing's pivot point. For example, rotating a layer will make it rotate around its pivot point, 
and scaling the layer will make it scale as if its centre was actually its pivot point.

While making transformations using the Transform tool, you can drag and drop your selection's pivot. 
However, this has no permanent effect. It will only temporarily change the pivot's position to help you make 
transformations at the selected frame, but the actual pivot point of your drawing layer will remain the same. 

You can reposition a layer's pivot point permanently by using one of the tools in the Advanced Animation 
toolbar.

NOTE 

When you permanently move the pivot point of a layer that is already animated, all the 
transformations done on the layer on other keyframes will be recalculated according to the new 
pivot point's position. Therefore, your existing animation will look completely different, except at 
the current frame. It is recommended to always make sure your pivot point is at its ideal position 
before you start animating.

How to permanently reposition the pivot point of a layer

 1. In the Advanced Animation toolbar, select the  Translate ,  Rotate ,  Scale , or  Skew 
tool.

 2. Do one of the following:

 l In the Timeline view, select the layer for which you want to move the pivot. 

 l In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the layer for which 
you want to move the pivot.

The  pivot point appears in the Camera view.

 3. Move the cursor over the pivot point. When the mouse cursor becomes , click and drag on the 
pivot point to reposition it.
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The layer's pivot point is now repositioned. If the layer has been animated, its position will be offset 
across the scenes relative to how much you just offset the pivot point.
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Using the Translate Tool

T-LAY-004-002

You can use the Translate tool to pan your elements on the X, Y and Z axes.

How to use the Translate tool

 

 1. Do one of the following: 

 l In the Advanced Animation toolbar, click the  Translate  tool.

 l From the top menu, select Animation > Tools > Translate. 

 l Press Alt + 2.

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 3. Drag the selection to a new area. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Rotate Tool

You can use the Rotate tool to rotate your objects on the x,y and z axis.

How to use the Rotate tool

 

 1. Do one of the following: 

 l From the top menu, select Animation > Tools > Rotate. 

 l In the Advanced Animation toolbar, click the Rotate  tool.

 l Press the Alt + 3. 

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 3. Rotate the layer. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Scale Tool

You scan use the Scale tool to squash, stretch, and resize your elements.

How to use the Scale tool

 

 1. Do one of the following: 

 l From the top menu, select Animation > Tools > Scale. 

 l In the Advanced Animation toolbar, click the Scale  tool.

 l Press Alt + 4. 

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s 
ratio when using the corner control points. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Skew Tool

You can use the Skew tool to distort your elements on the x and y axis.

How to use the Skew tool

 

 1. Do one of the following: 

 l Select Animation > Tools > Skew. 

 l In the Advanced Animation toolbar, click the Skew  tool.

 l Press Alt + 5.

 2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the element to select it 
and drag a side of the bounding box up, down or sideways. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Capture Motion Tool

The Capture Motion tool allows you to create an animation on a drawing or a peg by tracing  it in real time 
using the mouse or the pen.

How to use the Capture Motion tool

 1. Do one of the following: 

 l From the top menu, select Animation > Tools > Capture Motion. 

 l In the Advanced Animation toolbar, click the Capture Motion  tool.

 l Press Capture Motion Tool: Ctrl+Alt+Shift+M. 

 2. Select the drawing or Peg that you want to animate either in the Node or Timeline view.

 3. Set the desired capture speed, keyframe interval and smoothing.

 4. Place the play head on the start frame of your animation.

 5. Click the Capture button in the Capture Motion Tool Properties.

In the Camera view a record progress indicator will appear.

 6. Left click anywhere to start registering the motion path.  

The path is recorded in real time, and the capture time will start updating in the recording indicator

 7. Release the mouse at the end of your animation.
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TIP 

You can press down anywhere in the Camera view or in your drawing to register the motion 
path. It will help you orient the path.

NOTE 

Make sure the Capture Motion tool is enabled while performing these steps.

NOTE 

If you record an animation for a node that is already a child of a peg, the final animation will be 
affected by the animation in the parent peg and the recorded motion will be local to the node 
that you have selected.
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About the Layer Properties View
T-HFND-008-011

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these 
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in 
the Camera view. These values can also be animated over time.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters  button. 

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field 
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the 
north-south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has 
been drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have 
drawn on the page. This allows scanned drawings, imported images and paperless drawings to be properly 
registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something 
like the following:
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 l X Axis: -4 or 4W (4 West)

 l Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something 
like the following:

 l X Axis: 3 or 3E (3 East)

 l Y Axis: -2 or 2S (2 South)
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Displaying the Layer Properties View

You can display the Layer Properties view in several ways.

How to display layer parameters

 1. Do one of the following:

 l In the Layer Properties view is not part of your workspace, from the top menu, select 
Windows > Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

 l In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .
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Positioning Elements with the Layer Properties View

T-HFND-008-012

You can type values to position your elements using exact coordinates. 

How to position an element with coordinates

 1. In the Timeline view, select a layer.

 2. In the Layer Properties view, select Enable 3D option to display the 3D parameters in the Layer 
Properties.

 3. In the Position section, select one of the following options:

 l Separate to independently edit the different coordinate fields. Continue to step 3.

 l 3D Path to use a 3D path function when animating your element. Continue to step 4.

 

 4. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—
see About Multiplane on page 941.

As you type in values, the element’s position is updated in the Camera view. 

 5. Use the Function  buttons to create function curves and add keyframes to animate the 
parameter.

 6. In the Scale section, select one of the following options:

 l Locked to resizes the element uniformly in three directions.

 l Separate to resize the element in any direction without affecting the others.
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 7. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position

 8. Use the Function  buttons to create function curves and add keyframes to animate the 
parameter.

 9. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you 
can enter values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

 10. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

 11. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This 
will change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see the Reference guide .
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About Auto-Apply
When you modify a parameter in a property dialog box, Automatically applies changes you make to a property 
window or dialog box. Harmony applies the modification automatically and displays the result in the Camera 
view. When working on a heavy scene, it is useful to turn off this option.If you want to always work in Auto-
Apply mode, you can deselect the Auto-Apply option in the Preferences dialog box (General tab). Then, each 
time you start Harmony, the Auto-Apply  mode will be off. You must click the Apply button to see any 
modifications.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties view 
and any other parameter dialog boxes. 

 l Click Apply to apply the current change.

 l Click OK to apply the current change and close the Layer Properties.
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Setting the Auto-Apply Option

If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences 
dialog box (General tab). Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click 
the Apply button to see any modifications.

How to enable or disable the Auto Apply option

 l From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

 1. In the top menu, select Edit > Preferences (Windows/Linux) or
Harmony Premium > Preferences (macOS).

The Preferences dialog box opens.

 2. In the Preferences dialog box, select the General tab.

 3. In the Options section, select or deselect the Auto Apply option.
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Resetting Transformations 
You can easily reset layers to their original position. With the Reset command, you can return the value of a 
selected element to the initial value of the active tool. For example, if the Rotate  tool is active, the 
transformation angle will be reset to 0 and if the Transform  tool is active, the all transformation parameters 
values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg 
Selection Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if 
keyframes were created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformation values except Z

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.
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 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Multiplane
T-HFND-008-013

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create 
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through 
this environment to create an impressive perspective illusion.

In live action, when the camera moves around in a scene, objects near the camera will appear to move by a 
greater distance than objects far from the camera. In 2D animation, multiplanes can be used to achieve a 
similar effect without having to use 3D. 

In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and 
positioning them at different depths relative to the camera.  

Before creating a multiplane, make sure you have a proper understanding of the environment in which your 
scene happens. Picture what your scene's background would be like in 3D, then image the camera moving 
through the space, and how the objects in the picture move at different speeds depending on where they are 
in relation to the camera lens.

In the following example, the background is made of 6 different layers, each picturing an object that is at a 
different distance from the camera. On the left, you can see how each object is positioned relative to the 
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned 
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the 
camera's point of view.
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NOTE 

When creating a multiplane background, it is important to draw each layer fully. Even if some 
parts of a background layer is hidden behind a foreground layer in the camera's initial position, 
panning or zooming the camera may expose parts of background layers that are not initially 
visible.

In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You 
can do this by moving a layer using the Transform Tool  in the Side or Top views. You can also move a layer 
on Z-axis directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your 
element closer to the camera makes them appear bigger, and moving them further makes them appear 
smaller. It is also possible to move elements on the Z-axis without affecting their apparent size by using the 
Maintain Size tool in the Advanced Animation toolbar.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in 
the Top and Side views.
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Just like with other transformations, transformations on the Z-axis on a parent layer will also affect the 
apparent position on the Z-axis of its child layers. Therefore, a child layer's apparent position on the Z-axis can 
be affected by any of its parents. Once transformations on the Z-axis have been performed on several layers in 
a hierarchy, it may be difficult to keep track of which layers have been moved on the Z-axis and which ones 
have not. To help with this, it is possible to compare the selected layer's Z coordinate value with its apparent 
position on the Z-axis using the Coordinates and Control Point view or the Coordinate toolbar. Both these 
interfaces feature a field to tweak the layer's Z coordinate, which is independent from parent layers, as well as 
a field displaying the layer's cumulative Z coordinate, which is the sum of the Z coordinate of the selected layer 
with the Z coordinate of all its parents. 

To enable the Coordinate toolbar, do one of the following:

 l From the top menu, select Windows > Toolbars > Coordinate.

 l Right-click on any visible toolbar and select Coordinate.

To enable the Coord. and Control Points view, do one of the following:

 l From the top menu, select Windows > Coord. and Control Points.

 l From any view already open, click the Add View  button at the top-right corner and select Coord. 
and Control Points. 
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Setting Up Multiplanes
T-HFND-008-017

You can setup your elements as a multiplane to create a parallax effect when moving your camera. You simply 
need to spread and scale the objects on the Z-axis.

Using the Depth View mode can also be a useful tool when setting up multiplanes, see—Using the Depth 
View Mode on page 969.

How to rotate a scene in the Perspective view

 1. In the Tools toolbar, select the Rotate View   tool.

 2. Click in the view, and drag the cursor around to rotate the view or press and hold Ctrl + Alt 
(Windows/Linux) or ⌘  + Alt (macOS) and click and drag to rotate the view one axis at a time. 

How to set up a multiplane

NOTE 

Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z 
Dragging option by selecting Animation > No Z Dragging. This option is disabled by default.

 1. To maintain the visual scale in the Camera view as you move your element, do one of the following:

 l In the Advanced Animation toolbar, select the Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a 
layer from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.
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 3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain 
the same in the Camera view.

 4. For your element to scale up or down in relation to their distance to the camera, do one of the 
following:

 l In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode 
 option is disabled in the Tool Properties view.

 l In the Advanced Animation toolbar, select the Translate  tool and select a layer 
from the thumbnails section of the Top or Side view.

 l Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.
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 5. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging 
the element to make sure it only moves along the X-axis.

 6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while 
dragging the element to make sure it only moves along the Y-axis.
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Staging a 3D Space
Harmony is well known for its multiplane space where you can move your layers forward and backward on the 
Z-axis. Harmony brings you a true three-dimensional space where you can actually rotate your camera and 
layers on all axes. This lets you perform a 360 degree rotation around elements, create a floor and even build 
sets! 

NOTE 

If you are using 3D rotations in your animation, do not render your project as a SWF as these 
parameters are not supported by that format.
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Enabling the 3D Option
Before you can rotate layers in three axes instead of two, you must enable the 3D option in the layer 
properties. By default, when you create layers in Harmony, you can only move them as flat layers.    

How to enable the 3D option

 1. In the Timeline view, select the layer you want to move in 3D space.

 2. In the Layer Properties view select the Transformation tab.

 3. Select the Enable 3D option to display the 3D parameters for that layer.

948

Harmony 21 Premium User Guide                          



Chapter 8: Scene Staging

New parameters appear in the Layer Properties window.
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About 3D Parameters
When working in 3D, notice that three sets of parameters are modified: scale, rotation, pivot.
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About the 3D Scale Parameter

When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or 
separated. When the Scale is locked, the object you are scaling is uniformly resized in three directions. When 
the Scale is separated, the object you are scaling can be squashed and stretched in any direction without 
affecting the other ones.

NOTE 

You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional 
scaling is used to scale objects that were rotated on their axes or to scale a group of objects laid out 
in three dimensions.
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About the 3D  Rotation Parameter

The main parameter you will use when working in three-dimensions is rotation. Without using 3D rotation, you 
are simply working using the multiplane technique.

3D rotation can be used in two different ways:

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three 
rotation functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the 
velocity of the three rotation functions simultaneously. 

The X, Y and Z functions are linked. When you add a keyframe on one of them, it also adds it to the two others.

If you are planning to animate an element such as the camera, you should use the Quaternion rotation rather 
than Euler Angles. Quaternion creates a smooth trajectory and interpolation since the path is controlled by the 
same keyframes and a single velocity.

Euler Angles Rotation

The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is 
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are 
independent of each other; each has its own velocity.
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When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis 
independently.

Euler Angles are mainly used to position elements with exact coordinates and rotate elements on a single axis. 
The interpolation between the keyframes will not be as smooth as the Quaternion one since each function 
works individually.
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About the 3D  Pivot Parameter

When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. When you 
work in two dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the 
transformations will be performed. In 3D, the transformations are made on three axes, so the centre of rotation 
and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot  tool to 
reposition the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis 
remains at zero until you change it in the Top, Side or Perspective view using the transformation tools.
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About 3D Tools
Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are 
found in the Advanced Animation toolbar as well as the Transform  tool. Instead of letting you move 
elements only on the X and Y axes, you can also manipulate them on the Z-axis.
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About the 3D Translate Tool

Once the 3D option is enabled on a layer, the Translate  tool will work as a 3D Translate tool on that layer. 
This tool is able to move elements on all three axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer 
can move freely on two axes at once. Once the arrow is selected, it will turn pink.

NOTE 

If you move the layers in the Perspective view, it may be difficult to control the motion since you 
may not have the optimum point of view on your stage to understand the setup. In this case, it is 
best to use the direction arrows.
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About the 3D Rotate Tool

Once the 3D option is enabled on a layer, the Rotate  tool will work as a 3D Rotate tool on that layer. This 
tool is able to rotate elements on all three axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

NOTE 

If you move the layers in the Perspective view, it may be difficult to control the motion since you 
may not have the optimum point of view on your stage to understand the setup. In this case, it is 
best to use the direction ellipses.
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About the 3D Scale Tool

Once the 3D option is enabled on a layer, the Scale  tool will work as a 3D Scale tool on that layer. This tool 
is able to scale elements on three axes.

Depending on the selection, the 3D Scale tool will display one of the following:

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the 
different axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the 
object proportionally. Once the control point is selected, it will turn pink.

NOTE 

If you move the layers in the Perspective view, it may be difficult to control the motion since you 
may not have the optimum point of view on your stage to understand the setup.
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About the 3D Transform Tool

Once the 3D option is enabled on a layer, the Transform tool will work as a 3D Transform tool on that layer. 
This tool is able to translate, rotate and scale elements on all three axes.

To translate an element, grab the direction arrows in the same way that you would with the Translate tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.
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About 3D Space Positioning
To position elements in 3D space, you need to understand what you want to build and what is involved in 
building it.

Simple sets like the one above are easy to build, light to manage and probably what you will use 3D staging 
for most often.

If you have a project based on a room, it can be useful to build it in 3D. This saves you from having to redraw the 
background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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About Planning

When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map 
out the parts you need.

A complex set that is more intricate in its design will require more careful planning. Not only will you have to 
list the pieces you need, but you will also have to think about what can be reused. If you have a series of 
windows in your set, you would create a symbol from the drawing, rather than copy paste it several times all 
over your set. This way, if you need to make any correction to its design, you will only need to do it once and all 
the instances of your symbol throughout your set will be corrected. The same can be done with for each piece 
of your set.

Here is an example of all the source drawings required to build the castle. 

These are the only drawings required to build the entire castle. As you can see, there are not that many 
considering the final result. The rest is constructed by assembling symbols and through reuse. However, keep 
in mind that although you are using simple drawings and symbols to optimize your set, the more you add to 
your project, the heavier the toll it takes on your machine's RAM. While the scene's package itself is really 
light, running the scene places heavy demands on your RAM and video card.

Using the drawings shown previously, here are a couple of pieces that were put together.
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Here is the final result. A large and impressive fortress.
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About Maximizing Efficiency

When your main set is built, you will want to store it in the Library. It is important to know that when you 
import such a large structure in one of your production scenes, the set may be slow to run. To avoid long 
rendering sessions or slow manipulation, remove all faces and planes that are not visible in your scene.
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Positioning Layers in 3D Space

Once your drawings and symbols are assembled, it is time to position them. This section explains how this is 
done using the example of a simple room.

How to position layers in 3D space

 1. Next to the Camera and Drawing view tabs, click on the Add View button and select 
Perspective.

The Perspective view appears in the same section of your workspace as your Camera and Drawing 
views. This view allows you to view your scene from any angle and point of view, rather than from 
your Camera's point of view. In this view, the usual navigation keyboard shortcuts work the same, 
but you can also press Ctrl + Alt (Windows/Linux) or ⌘  + Alt (macOS) to rotate the view in any 
angle and on any axis

 2. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

 3. In the Transformation tab, select the Enable 3D option.

 4. In the Rotation section, select the Euler Angles option.
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 5. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.

 6. To position the height of the floor, type values in the Position section of the Layer Properties, use 
the Translate  tool or Transform  tool.

 7. Repeat the process for the other pieces to position.

 8. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.

 9. Do one of the following to duplicated the layer.

 l From the top menu, select Edit > Duplicate.

 l Right-click and select Edit > Duplicate.
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 10. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use 
the Translate or Transform tool. If you want to position your layer visually, consider using the 
Camera, Top or Side view so as to be able to position it with precision.

 11. If your walls are touching each other, you should make them intersect by extending one end of the 
wall through the other wall. This prevents accidentally leaving small gaps between them.

You now have a complete 3D room.
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NOTE 

The Transform tool as well as the Advanced Animation tool can be used with 3D layers as 
with 2D layers. The Transform tool allows you to reposition, rotate and scale 3D layers on any 
axis, but does not allow you to skew 3D layers. You can use these tools on 3D layers in the 
Camera, Perspective, Top and Side views. 
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Using the Depth View Mode

The Depth View mode can come in handy when positioning 3D models, creating multiplane backgrounds and  
building sets in 3D space.

How to use the Depth view

 1. In the Node view, open your Layer Properties of your composite by clicking on the yellow box.

 2. In the Layer Properties window, set the Input Ordering to 3D.

 3. In the Camera view, click on the Render View mode  button and from the menu, select Depth 
View mode.

The image of your scene changes from full colour to various shades of black, white and grey.

 4. The Depth View mode displays images in a relative white to black gradient scale. The object(s) 
closest to the camera are displayed in white and the object(s) furthest from the camera are 
displayed in black. If the position of the last object changes along the z-axis, that object will still 
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remain black, so long as it retains its position as the object the farthest back. It does not matter 
where that object is in 3D space, it just matters what its position is relative to the other object in the 
same space. The objects closest and farthest from the camera set the range of the white to black 
scale. All the other objects fall somewhere in between.

 5. In the Timeline or Node view, disable elements that you don't need, in order to work better with the 
elements that you would like to reposition. In the example below, the background elements have 
been disabled so that repositioning elements in the room can be done more precisely. 

As you can see, the same elements in the Depth View mode are now displayed differently, because 
their relative positions have changed. Without the background present, the corner of the room 
becomes the element that is the furthest back, while the right part of the right wall is the element 
that is the closest and is therefore displayed in white.

Deep blue signifies infinity. The space around elements goes on forever and therefore does not fall 
into the white to black scale.

 6. In the Camera, Top, Side or Perspective views, use the Transform tool or any of the Advanced 
Animation tools (Translate, Rotate, Scale, etc.) to reposition elements in your scene, using the 
Camera's Depth View mode to verify your adjustments as you make them.
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About 3D Input Output Options
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level 
compositing.

The Composite node's main task takes all of your image's output and converts it into a single flat image that 
you can render out. You can alter it further by manipulating a three-dimensional scene setup. You can also 
modify a Composite's behaviour as seen in the Scene Staging on page 903 chapter. 

The default options combination is:

 l As Bitmap, for the output behaviour

 l 3D flat, for the input ordering

By default, a Composite node is set to output a flat bitmap image and to correctly composite elements 
positioned in 3D space.

For example, if you have two intersecting walls, and use the default combination, you will see the following 
result:
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This image is correctly represented in the Camera view and is output from the Composite node as a flat 
drawing. The Z-axis value of your elements are not retained, it becomes an independent composition with only 
one forward-backward value.

NOTE 

When building a 3D set out of planes, it is recommended that you set the composite mode to As 
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of 
planes.

3D Input Ordering Option

The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the 
Camera view will be correct, but the elements will not be converted into a flat image. The 3D position of your 
images will be remembered until the next Composite node. This mode is quite advanced and should only be 
used in very advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option

If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D 
objects. The perspective caused by the 3D rotation will be correctly represented, but the elements will not 
intersect. The result will be similar to the following:
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About 3D Composite Nodes

If you start combining several composite nodes in your Node view, it is important to understand how they work 
if you want to get the desired result.

There is a specific order in which you should set your Composite nodes. Each time you process images through 
a 3D Flat Composite node, the images will be merged together. Images processed in later Composite nodes 
cannot be inserted between images of the previous composite since it is a flat image.

If you used Pass-Through type Composite nodes in your network, the images will not be processed together 
before the final Composite. It is important to keep your final Composite as a 3D Flat Composite in order to read 
the layer ordering correctly.

The most efficient networking system for obtaining the desired result is likely  the Pass-Through composite 
mode throughout the whole network. This way, you can create individual compositions to keep your network 
clean and organized, but process everything together at the end.
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NOTE 

When building a 3D set out of planes, it is recommended that you set the composite mode to As 
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of 
planes.
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Drawing on 3D-Rotated Layers
As you build your project in the Perspective view, you may rotate and reposition 2D drawings to lay flat against 
different planes of your 3D model. If you then want to draw on these 2D drawings, you will see that it is not 
possible. In order to draw on a 2D drawing in the Perspective view, the drawing needs to be facing the camera.

How to turn a 2D object to face the camera so you can draw on it

 1. In the Perspective view, select the 2D drawing with the Transform tool .

 2. From the Perspective view menu , select View > Face Selected to Draw.

The Perspective view is reset so that the 2D drawing is now facing the camera.
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 3. Select a drawing tool from the Drawing Tools toolbar and modify the drawing.
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About Alignment Guides
Alignment guides are horizontal and vertical rulers that you can add to a panel. You can position them 
anywhere in your stage, and use them to help you align layers and artwork as well as to draw along their axis. 

Alignment guides can be used as visual aids, but you can also make your animation and drawing tools snap to 
them.

The following tools can snap to alignment guides:

 l  Transform

 l  Select

 l  Contour Editor

 l  Perspective

 l  Brush

 l  Pencil

 l  Stamp

 l  Eraser

 l  Rectangle

 l  Ellipse

 l  Line

 l  Drawing Pivot

When you manipulate elements with the  Layer Transform tool and the  Select tool, they will snap to 
nearby alignment guides. As for drawing tools such as the  Brush or the  Pencil tool, they will snap to 
alignment guides if you draw close enough to them, allowing you to draw straight lines along the guides.
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Adding Alignment Guides
You can add horizontal or vertical alignment guides to your scene.

NOTE 

When you add a guide, it is instantly positioned in the centre of your scene. You can move it with 
the  Transform tool or the  Select tool. 

How to access the Alignment Guides toolbar 

 1. Do one of the following:

 l In the top menu, select Windows > Toolbars > Alignment Guides.

 l Right-click on any toolbar in your workspace and select Alignment Guides. 

How to add an alignment guide

 1. Do one of the following:

 l In the Alignment Guides toolbar, click  New Horizontal Alignment Guide or  New 
Vertical Alignment Guide. 

 l In the top menu, select View > Alignment Guides > New Horizontal Alignment Guide or  
New Vertical Alignment Guide.

The guide is added to the centre of the stage.
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Moving Alignment Guides
You can move alignment guides with the Transform tool or the  Select tool. 

NOTE 

Guides cannot be moved if they are locked—see Locking and Unlocking Alignment Guides.

How to move an alignment guide

 1. In the Tools toolbar, select the  Transform tool or the  Select tool.

 2. Position your mouse cursor over the guide. The cursor will change to  .

 3. Click and drag on the guide.
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Snapping to Alignment Guides
Alignment guides are not just visual aides. You can make the  Transform tool as well as various drawing 
tools snap against them. 

The following are tools that can snap against alignment guides:

 l  Transform

 l  Select

 l  Contour Editor

 l  Perspective

 l  Brush

 l  Pencil

 l  Stamp

 l  Eraser

 l  Rectangle

 l  Ellipse

 l  Line

 l  Drawing Pivot

When you're using a tool that supports snapping, you can enable snapping by clicking on the  Snapping 
button in the Tool Properties view. Some tools support several types of snapping other than snapping to 
alignment guides. 

NOTE 

When you enable or disable snapping to alignment guides, it is enabled or disabled for all tools 
that support it. 

How to enable snapping to alignment guides

 1. In the Tools toolbar, select the animation or the drawing tool you want to use.

 2. In the Tool Properties view, double-click  Snapping and, in the drop-down menu, select Snap to 
Alignment Guides.

Snapping to alignment guides is now enabled for all tools that support it. 
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Locking and Unlocking Alignment Guides
By default, it is possible to move alignment guides with the  Transform tool and the  Select tool. Once 
your guides are properly positioned, you can lock them in position so as to avoid moving them by accident 
when manipulating elements in your scene.

How to lock or unlock alignment guides

 1. Do one of the following:

 l In the Alignment Guides toolbar, click on the  Lock Alignment Guides button to toggle it 
on or off.

 l In the top menu, select View > Alignment Guides > Lock Alignment Guides to toggle the 
option on or off.
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Hiding and Displaying Alignment Guides
It is possible to temporarily hide alignment guides if you don’t need them. 

NOTES 

 l When alignment guides are hidden, animation and drawing tools do not snap to them. 

 l Adding an alignment guide automatically makes alignment guides visible.

How to hide or display alignment guides

 1. Do one of the following:

 l In the Alignment Guides toolbar, click on the  Show Alignment Guide button to toggle it 
on or off. 

 l In the top menu, select View > Alignment Guides > Show Alignment Guides to toggle the 
option on or off. 

 l In the toolbar below the Camera View, click on the  Show Alignment Guide button to 
toggle it on or off.

NOTE 

This button is available in the toolbar below the Camera View, but not in the 
toolbar below the Drawing View. 
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Clearing Alignment Guides
It is possible to instantly remove all alignment guides from your scene.

NOTE 

It is not possible to delete a single alignment guide and keep all others. 

How to clear all alignment guides

 1. Do one of the following:

 l In the Alignment Guides toolbar, click  Clear Alignment Guides.

 l In the top menu, select View > Alignment Guides > Clear Alignment Guides.
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Chapter 9: Digital Animation

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera 
moves and camera shakes, adjust the easing, shape your paths with control points and much more.

Before animating the position of your layers, you need to create motion paths which are trajectories on which 
you can attach drawing objects. Using keyframes, you can then record key positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a 
simple motion, you will learn the basics of animating a layer.

There are two ways to create motion paths: animated drawing layers and pegs. They each have different 
purposes. 
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About Pegs
T-HFND-009-004

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg 
holes at the bottom or top of the animation paper are used to keep all the sheets even and at the same 
registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right 
ones are oval shaped. The oval peg holes are located on each side of the page, four inches away from the 
centre peg hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to 
the shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and 
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create 
animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

 l Euler Angle or Quaternion Angle (when 3D option is enabled)

 l Z Scale (when 3D option is enabled)
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You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of 
birds. You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes 
trajectory modifications much easier and faster. When building a puppet, most of the time you will add a 
master peg to control your puppet as one object.

In Harmony, you can add pegs to the Node view using the Node Library view and they will instantly appear in 
the Timeline view. The nodes you add to the Node view are synchronized with the ones in the Timeline view.
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Adding Pegs
T-ANIMCO-001-001

You can add peg to your Timeline view and parent the layers to animate to it. 

How to add a peg in the Timeline view

 1. In the Timeline view, select the layer on which you want to attach a peg.

 2. Do one of the following: 

 l From the Timeline view layers toolbar, click the Add Peg  button.

 l From the Timeline view menu, select Insert > Peg.

 l From the top menu, select Insert > Peg.

 l Right-click on the selected layer, then select Insert > Peg.

 l In the Node Library, select a Peg node  and drag it to the Node view.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (macOS).

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg 
layer automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to 
the Peg layer. This relationship is called a parent-child relationship.

 3. If you intend to add multiple pegs or if the layer name that was added to the peg does not 
accurately represent the content of the Peg layer, you can rename it. Click the layer name and type 
in a new name. Or double-click the layer and type a new name into the dialog box.

 4. If you did not create your peg layer directly above the layer you intended on parenting it to, then 
drag the layer you want to attach to the peg and drop it directly below the Peg layer. The 
indentation of the layer below the Peg layer indicates whether it was correctly attached or not.
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 l You can unparent layers by holding down Shift and dragging the selected parents 
away from the child layer. Drop your selected between other layers.

How to add a peg in the Node view via the Node Library

 1. In the Node Library view, select the Move tab.

 2. Select a Peg node and drag it to the Node view. You can also press Ctrl + P (Windows/Linux) or ⌘  
+ P (macOS).

 3. In the Node view, select the Peg node's output port and connect it to a Drawing or Camera node.

The advanced connections in the Node view are shown in the Timeline view, unless they cannot be 
reproduced in a timeline layout.
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Enabling Peg Selection Mode
In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in the 
Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers 
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent 
Skipping Effects command.

How to enable the Peg Selection Mode

 1. In the Tools toolbar, select the  Transform tool or press Shift + T.

 2. In the Tool Properties view, click the Peg Selection Mode  button.

 3. In the Camera view, select an element parented to a peg.
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Connecting Nodes to  Pegs
You can connect several nodes to a single parent peg or give them each their own peg.

How to create an automatic connection to a parent peg

 1. In the Node view, select one or more drawing nodes that are not parented to any other node.

 2. Press Ctrl + P (Windows/Linux) or ⌘  + P (macOS) to add a new peg node to the Node view and 
automatically connect it to the selected nodes. Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift 
+ P (macOS) to add a peg to each node.
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About Drawing Layers
T-ANIMCO-001-002

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

3D objects and 3D-enabled layers also have these extra paramaters:

 l Euler Angle or Quaternion Angle (when 3D option is enabled)

 l Z Scale (when 3D option is enabled)

Harmony keeps track of the animation by storing each parameter of each layer in their own function curve. 
When you add a keyframe to a layer, a keyframe is created on each of these functions, and transformations 
done on a layer via the Camera view are translated into coordinates which are then stored in those functions. It 
is possible to edit these functions individually using the Function view, but that is rarely necessary, as Harmony 
provides easy-to-use tools for visually controlling trajectories and timing in the Camera and Timeline views.

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select 
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls 
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tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily  identify 
them as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools 
options.
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Disabling Layer Animation
By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do 
so by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated 
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure 
and keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for 
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose 
their offset keyframes or drawing substitution keyframes.

How to disable animation on a drawing layer

 1. In the Timeline view, double-click the layer on which you want to set the parameter.

The Layer Properties editor opens.

 2. In the Controls tab, deselect the Animate Using Animation Tools option.
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About Layer Parameters
T-HFND-009-008

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew 
and scales. Each parameter has its own function which is a mathematical formula expressing the relationship 
between position values. You can view each function on a graph as a simple curve, such as the one below.

There are several options available for setting up function parameters:

 l Locked Positions (3D Path)

 l Separate Positions

 l Locked Scales

 l Separate Scales

 l Quaternion (3D Rotation)

 l Euler Angles (3D Rotation)

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. 
When you lock or unlock parameters, this does not convert the functions from one to the other, but creates 
new ones.
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In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you 
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, 
smooth trajectories.

When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the 
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on 
its curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth 
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one 
another. This is why in cut-out animation it is recommended to use separate position settings. But if you work 
with 3D path, you can use the Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion 
keyframes and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature 
only works with 3D paths.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls 
directly on their function curve. This is useful when you want to set keyframes on one of the curves without 
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and 
horizontal scale, or two separate scales. When using a single function curve, the values are the same for the X 
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(horizontal) and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale 
functions, you can squash, stretch and skew your elements.
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Displaying Layer Parameters
T-ANIMCO-001-004

You can easily display the parameters for each layer in the Timeline view.

How to display the layer parameters in the Timeline view

 1. Do one of the following:

 l In the Timeline’s left side, click a layer's Expand  button. 

 l In the Timeline view menu, select View > Show Functions.

 l Press Alt + F. 
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Setting Layer Parameters
T-ANIMCO-001-003

You can modify the layer parameters to different types of function and linking some of them together.

How to set the layer parameters

 1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can 
also see the parameters in the Layer Properties window when you select the layer in the Timeline 
view.

The Layer Properties window opens.

 2. Select the Transformation tab.

 3. In the Position section, select the 3D Path or Separate option.

 4. In the Scale section, select the Locked or Separate option.

 5. Click Close.
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Enabling Constant Z
T-HFND-009-008A

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

 1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that 
you must select the 3D Path option for the layer.

 2. Double-click on one of the position functions to open the Function editor.

 3. In the Function editor, select the Constant Z  button.
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About Keyframes
T-HFND-009-005

Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like 
to create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no 
interpolation) and motion keyframes (computer-generated interpolation).

With stop-motion keyframes, there is no computer-generated motion between the stop-motion keyframe and 
the next keyframe. The segment of the function between those keyframes is flat, and the drawing remains still 
until the playback reaches the next keyframe, then the drawing pops to its new location.

With motion keyframes, Harmony generates the interpolation between the motion keyframe and the next 
keyframe. This means that a value for each frame between the keyframes is calculated by Harmony to progress 
from the value of the previous keyframe to the value of the next keyframe. 
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About Keyframe Creation
There are several different ways you can create keyframes. You can add a coordinate keyframe, position 
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer 
stays the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do 
not want to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be 
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and 
Skew parameters.
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Creating Keyframes in the Timeline View

T-HFND-009-006

You can add keyframes in the Timeline view to multiple layers, a single layer or a specific parameter.

How to create keyframes in the Timeline view

 1. In the Timeline view, select the cell on which you want to add a keyframe.

 2. Add a keyframe  by doing one of the following:

 l From the top menu, select Insert > Keyframe.

 l Right-click  on the selection and select Insert Keyframe.

 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the 
current frame.

 How to add a keyframe for a specific parameter

 1. On the right side of the Drawing layer, press the + to expose the different functions of that 
drawing.

 2. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

 3. Do one of the following:

 l Right-click the selected cell and select Insert Keyframe.
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 l Press F6.

 l In the Timeline View menu, select Motion > Insert Keyframe.

 l In the Timeline View toolbar, click the Add Keyframe  button.

How to create a keyframe and duplicate the drawing at the same time

 1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a 
keyframe.

 2. Do one of the following:

 l From the top menu, select Insert > Keyframe and Duplicate Drawing.

 l Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

 l Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the 
original drawing.

How to add a Position keyframe

 1. In the Timeline view, select the cell on which you want to add a position keyframe.

 2. From the top menu, select Insert > Position Keyframe.
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Creating Keyframes in the Function View

You can add keyframe directly on the graph using the Function view.

How to add or delete keyframes in the Function editor

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

 2. Double-click on the parameter layer name to open the Function editor window or click once on the 
parameter layer to display it in the Function view's left sidebar. If you are using the Function view, 
you must click on the function name from the sidebar list to view it in the graph display region.

 3. In the Function editor, do one of the following:

 l In the graph section, click on the frame  where you want to make changes.

 l In the Frame field, enter the frame number.

In the graph display area, the red playhead moves to that frame number.

 4. In the Function editor, click the Add Keyframe   button.
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 5. Click on the newly created keyframe and drag it up to increase the value of the function or down to 
decrease the value. Depending on the selected function, this could increase or decrease the width 
of the object (scale_x) or change the object's vertical position (position_y). Pull on the handles to 
create non-linear transition speeds between keyframes.

 6. If you do not like the changes you just made, select and delete the new keyframe by pressing  Del or 
clicking the and Delete keyframe  button.

You can delete an existing keyframe by using the same process.
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Creating Keyframes in the Xsheet View

If you prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view 
and then select the layer you want to modify. If you double-click on a function column's header, you will display 
the corresponding function curve in the Function editor.

How to add a keyframe in the Xsheet view

 1. In the Xsheet view, click the Expand button located on the right side of the main section to show 
the Functions section. 

 2. In the Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding 
keyframes in the Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

 3. In the Xsheet view, go to the function column on which you want to add a keyframe.

 4. Double-click on the cell on which you want to add a keyframe and type a numeric value.

 5. Press Enter/Return to continue to the next cell.
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 6. Press Esc to exit the typing mode.

How to convert a cell into a keyframe

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Select the cell to convert.

 3. Right-click on the cell and select Set Selection As Keyframe or press F6.

 4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in 
Selection or press F7.
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Automatically Creating Animation Keyframes When Transforming 
Elements

T-ANIMCO-001-007

Before you start animating, you should set the Animate mode of Harmony to  Animate Current Frame. This 
mode ensures that, whenver you use the  Transform tool or any of the  Advanced Animation 
tools to move, rotate, scale or skew an element in your scene, a keyframe is created at the current frame in 
which the new coordinates of the element are stored.

When this mode is enabled, all you need to do to animate elements in your scene is to select the frame where 
you want to create an animation keyframe, then position the element you want to animate in the position, 
angle, scale and skew you want it to be at this frame, and repeat for every animation keyframe you want to 
create. Since a keyframe is automatically created at the current frame each time you transform an element, 
making transformations on your elements on different frames in your scene will automatically create an 
animation. 

How to set the Animate mode to Animate Current Frame

 1. Do one of the following:

 l In the Tools toolbar, click on the Animate mode button which, depending on the currently 
selected mode, will either have the  Animate Current Frame,  Animate Onion Skin 
Range or  Animate Off icon, and select   Animate Current Frame in the pop-up menu.

 l In the top menu, select Animation > Animate > Animate Current Frame. 
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Deleting Keyframes
T-HFND-009-007

You can delete keyframes independently from drawing exposure.

NOTE 

If you select a keyframe in the Timeline view and press the Del key, you will also delete the 
drawing exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to delete a keyframe

 1. In the Timeline view, select a keyframe and do one of the following:

 l Right-click and select Delete Keyframes. 

 l In the Timeline view menu, select Motion > Delete Keyframes.

 l From the top menu, select Animation > Delete Keyframe.

 l Press F7.

 l In the Timeline View toolbar, click on the Delete Keyframes  button.

 l Use the Transform  tool to select a keyframe to delete from the trajectory in the 
Camera view and press Del.
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Animating with Keyframes
T-ANIMCO-001-005

You can animate a layer or a peg by creating keyframes and moving your drawings in the Camera view.

How to animate a layer                                       or a peg                 

 1. In the Tools toolbar, select the  Transform tool or press Shift + T.

 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. If your layer has a parent peg:

 l If you want to animate on the peg instead of the layer, make sure that  Peg Selection 
Mode is enabled in the Tool Properties view.

 l If you want to animate directly on the layer, make sure that  Peg Selection Mode is 
disabled in the Tool Properties view. 

 4. In the Timeline view, go to the first frame.

 5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is 
unchecked. This will make it so Harmony automatically creates the animation between the 
animation keyframes you create.

 6. Select the cell where you want to create your first keyframe

 7. To create your first keyframe, do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is created on the first frame of the Timeline view.

 8. In the Camera view, select the element to animate and move, rotate, scale or skew it so that it is in 
its proper starting position.
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 9. In the Timeline view, go to the frame on which you want to set the second position.

 10. Select the cell where you want to create your second keyframe. right-click on the selection and 
select Insert Keyframe.

The second keyframe appears in the Timeline view, along with a line going from your first keyframe 
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

 11. In the Camera view, move, rotate, scale or skew the element to that it is in its proper second 
position.
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NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 13. In the Playback toolbar, click on the  Play  button to preview your animation.

NOTE 

If your scene has 3D objects, or if you animate layers on the Z axis, you may want to preview 
your animations from the Top, Side or Perspective views  during playback. However, playback 
is disabled by default in those view. To enable them, from the top menu, select Play > Enable 
Playback > Top View, Side View or Perspective View.
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Animating, Repositioning or Transforming an Element Over Several 
Frames
By default, when you use the  Transform tool or the  Advanced Animation tool to reposition 
an element, its coordinates are changed in the current frame only. However, it is possible to move, rotate, scale 
and skew an element on several keyframes simultaneously. This is done by changing the Animate mode.

There are three different Animate modes:

 l  Animate Current Frame: When you transform an element, its position, angle, scale and skew are 
stored in a keyframe at the current frame. This means that a keyframe is created at the current frame, if 
there is not one already.

 l  Animate Onion Skin Range: When you transform an element, the transformation is applied to every 
frame in the Onion Skin. This means that it is applied to every keyframe inside the Onion Skin range, 
and, if needed, keyframes are created at the beginning and the end of the Onion Skin to preserve the 
transformations you make.

 l  Animate Off: When you transform an element, the transformation is applied throughout the entire 
scene. If the element has keyframes, the transformation is applied to all of these keyframes. No 
keyframe is automatically created when using this mode. 

How to move, rotate, scale or skew an element over a specific span of frames

 1. In the Tools toolbar, select the  Transform tool.

TIP 

You can also make transformations over several keyframes using the  Translate,  
Rotate,  Scale,  Skew or  Maintain Size tools, which can be selected in the 
Advanced Animation toolbar.

 2. In the Timeline, Node or Camera view, select the element you want to transform. 

 3. In the Tools toolbar, click on the Animate mode button which, depending on the currently selected 
mode, will either have the  Animate Current Frame,  Animate Onion Skin Range or  
Animate Off icon, and select Animate Onion Skin Range in the pop-up menu.

Animate Onion Skin Range is now enabled. At the same time, Onion Skin becomes enabled, and 
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the Onion Skin handles appear left and right of the red playhead in the Timeline view.

 4. In the Timeline view, move the timeline playhead to a frame somewhere in the middle of the span of 
frames you want to transform.

 5. Adjust the range of the Onion Skin so that it covers every frame you want to apply the 
transformation to by doing one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.
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NOTE 

If there are no keyframes at the beginning and at the end of the Onion Skin range, 
keyframes will be automatically created at those frames to store the transformation you 
will make. If you want to avoid this, make sure the Onion Skin range begins and ends on 
a keyframe.

The position of the layer in every frame in the Onion Skin range will appear in the Camera view, as 
Onion Skin. 

 6. In the Camera view, use the Transform tool to move, scale, rotate or skew the selected element.

NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.
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The transformation is applied on every keyframe within the Onion Skin range on the selected layer. 

NOTE 

Make sure to set the Animate mode back to Animate Current Frame when you want your 
transformations to only affect the current frame again.

How to move, scale, rotate or skew an element throughout the entire scene

 1. In the Tools toolbar, select the  Transform tool.

TIP 

You can also make transformations throughout the entire scene using the  Translate, 
 Rotate,  Scale,  Skew or  Maintain Size tools, which can be selected in the 

Advanced Animation toolbar.

 2. In the Timeline, Node or Camera view, select the element you want to transform. 

 3. In the Tools toolbar, click on the Animate mode button which, depending on the currently selected 
mode, will either have the  Animate Current Frame,  Animate Onion Skin Range or  
Animate Off icon, and select  Animate Off in the pop-up menu.
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 4. In the Camera view, use the Transform tool to move, scale, rotate or skew the selected element.

NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.

The transformation is applied to the element throughout the entire scene. If the element has 
animation keyframes, the transformation is applied to every keyframe as well.

NOTE 

Make sure to set the Animate mode back to Animate Current Frame when you want your 
transformations to only affect the current frame again.
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Changing Keyframe Values
Once a keyframe is added, beside moving the image in the Camera view, you can change its value by typing it 
in the Timeline and Function views.

How to change the keyframe values in the Timeline view

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

 2. Select the parameter for which you want to create a function curve.

 3. Place the cursor over the blue number value of the parameter and do one of the following:

 l Wait until the cursor changes to a white hand with a two-way arrow and then drag 
the hand left to decrease the value or right to increase the value.

 l Double-click on the blue number and enter a value in the field.

How to change a keyframe value in the Function editor

 1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg 
layer's name.

1020

Harmony 21 Premium User Guide                          



Chapter 9: Digital Animation

 2. Double-click on the parameter layer name to open the Editor window or click once on the 
parameter layer to display it in the Function view.

 3. In the graph of the Function editor, select a white keyframe. 

The keyframe turns red and displays a pointed yellow handle.

 4. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.

 5. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

 6. Keep adjusting the values until you are satisfied with the results.

 7. Click Close.
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Switching Between Motion and Stop-Motion Keyframes
T-ANIMCO-001-006

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

How to switch between motion and stop-motion in the Timeline view

 1. On the right side of the Timeline view, select one or more keyframes to modify.

 2. Switch between motion and stop-motion by doing one of the following:

 l Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (macOS) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (macOS) for stop-motion keyframes.

 l In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe 
 button.

How to switch between motion and stop-motion in the Coordinates and Control 
Points view

 1. Using the Transform  tool, in the visible path in the Camera or Timeline view, select the 
keyframe to convert.

 2. In the Coordinates and Control Point view, select/deselect the Stop-Motion Keyframe option.

How to switch between motion and stop-motion keyframes in the Function view

 1. Open the Function view.

 2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.
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 3. Do one of the following:

 l In the Transformation tab, click the Function Editor  button.

 l In the Timeline view, click the Expand Function  button or press Alt + F and 
double-click on the function to edit.

 4. On the function curve, select one or more keyframes to modify.
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 5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.
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Jumping to Keyframes
You can jump between the selected layer's keyframes in the Timeline view.

How to jump to keyframes

 1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip 
through.

 2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press 
semicolon (;) and single quote (').
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About Controls
T-HFND-009-010

Camera moves and motion paths can become quite advanced, especially with moves through 3D space. 
Harmony provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D 
perspective.

You can display the trajectory of a motion path when you select an object from any view it can be selected in.

A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both 
keyframes and control points. Both can be used to shape a path; each have their own behaviour, however only 
keyframes appear in the Timeline view. 

 l Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked 
in time.

 l Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. 
There are no velocity handles available on a control point. The velocity segments are set between 
keyframes only, making curves and trajectories much smoother. Control points can only be added on a 
3D path.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-
in-time using the Coordinates and Control Points view. 

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear 
in the Coordinates and Control Point view. You can also see the same information in the Coordinates and 
Control Points toolbar.
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You can adjust these parameters by selecting the control points and keyframes in the Camera, Top and Side 
views with the Transform  tool.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.
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Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.
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Displaying Controls
T-HFND-009-011

You can display a layer's controls to adjust a trajectory or other parameters such as a gradient's position or 
deformation settings.

How to display the layer’s controls

 1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want 
to display is selected in the Timeline view.

 2. From the top menu, select View > Show > Control or press Shift + F11 or in the Camera view 
toolbar, click on the Show Control  button.

NOTE 

If nothing appears in the Camera view, you may not have animated or selected 
the layer.
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Adding Control Points
T-HFND-009-012

You can add control points on 3D Path trajectories. You need to display the layer's controls in the Camera view.

How to add a control point on a trajectory

 1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

 2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top 
menu or press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.

 3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point 
and press P once. If you hold the key down, control points will be added continuously until you 
release the key.

A control point is added to the trajectory.
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Toggling Point Types
You can convert a control point into a keyframe and a keyframe into a control point. The position and other 
values will remain in both cases, only the frame will change. A control point is not locked in time.

How to switch between keyframe and control point

 1. In the Camera view, use the Transform  tool select a point to convert.

 2. To convert the point:

 l In the Coordinates and Control Points view, select or deselect the Locked in Time 
option.

 l From the top menu, select Animation > Lock in Time.

 l In the Function view or Function Editor, select the keyframe to convert and click the 
Lock in Time  button.

 l Press Alt + L.

1031



Adjusting Tension, Bias, and Continuity
You can adjust the shape of the curve passing through a point by modifying the bias, tension, and continuity 
settings. You can also set preferred settings as default.

How to adjust the Continuity, Tension and Bias parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline view, select the layer that contains the parameters you want to adjust.

 3. From the top menu, select View > Show > Control  or press Shift + F11 to display the trajectory.

 4. In the Camera view, select a control point or keyframe.

 5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

How to adjust the control point preferences

 1. From the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences 
(macOS).

The Preferences dialog box opens.

 2. Select the Camera tab and adjust the parameters in the Control Points section.
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Converting Angled and Curved Corners
When you select a control point on a path, you can switch between a rounded or angled corner by using the 
Linear/Curve command. 

How convert an angled or curved corner

 1. In the Timeline view, double-click the layer that contains the point you want to convert.

The Layer Properties window opens.

 2. On the Transformation tab, select the 3D Path option.

 3. In the Tools toolbar, select the Transform  tool or press Shift + T.

 4. In the Camera view, select the point to convert.

 5. From the top menu, select Animation > Linear Motion.
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Offsetting Trajectories
By offsetting a trajectory, you Lets you reposition the visual trajectory without offsetting or modifying your 
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different 
location than the centre of the drawing area, it will look like the trajectory is not aligned with your drawing. 
Also, if you have several elements attached to one trajectory, you might want your trajectory to be at a 
different location to represent the group's motion better.

How to offset a trajectory

 1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

 2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

 3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the 
trajectory, any transformation done using the Spline Offset tool will be ignored.

 4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, 
but also on the Z-axis using the Top and Side views.
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About Functions
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally 
create the ones you need to avoid being overloaded with too many functions you might not use.

When you select an element in the Camera view and move it around, it will automatically create the 
corresponding function curves. If you need to create certain functions manually, you can always do it through 
the Layer Properties view or editor.  You can then share it with other layer parameters or set keyframes directly 
on the function curve instead of doing it in the Timeline or Camera view.

You can also link a layer's parameter to an existing function curve or attach several parameters to the same 
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera 
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, 
but this may produce undesirable results and even induce a feeling of motion sickness as you watch the final 
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore 
the angle, scale and skew. 

By default, all function curves can only be used and modified using their original parameter. If you want 
another layer or parameter to use the same function curve, you must share it.

There are two ways to share a function:

 l Share Functions command

 l Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:

Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Create Ease Creates a new Ease curve

Local Disconnects the parameter from any function and changes it to shared.

3D Path Displays the list of every shared 3D Path function available

Bezier Displays the list of every shared Bezier curve available

Ease Displays the list of every shared Ease curve available

Velobased Displays the list of every shared velocity based curve available
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Expression Displays the list of every shared Expression function available

3D Rotation Displays the list of every shared 3D Rotation function available

Connected Displays the list of every shared connected function curve

Unconnected Displays the list of every shared unconnected function curve

All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have 
two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your 
needs, including: 

 l Ease function

 l Bezier function

 l Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an 
Ease or Bezier function.
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These function editors present different ways of editing the values over time. The shape of the created graph 
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is 
largely based on your working preference. 

With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls.

You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you 
do this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a 
Velobased function to control its velocity.

With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it 
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an 
element.

You can convert Ease and Bezier function so you can edit them  using the controls offered by that type of 
function. 
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Creating Functions
You can create function curves in several different ways. You cannot create function curves directly in the 
Xsheet view. You must do this in the Layer Properties window or the Timeline view.

 How to create the function curve in the Timeline view

 1. In the Timeline view, expand the layer's parameters.

 2. Click the Function button and, in the drop-down menu, select Create Bezier or Create Ease.

How to create function curves using the Layer Properties view

 1. In the Timeline view, double-click on the layer you want to create function curves for.

The Layer Properties Editor opens.
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 2. In the Transformation tab, click the Function Arrow button beside the local function information.

 3. Create a 3D Path, Bezier, Ease or Velobased curve. You can also create an Expression column—see 
About Expression Columns on page 1073.

You can click the Function  button to open the Function editor.
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Converting Functions
You can duplicate the functions in a column and send them to another column in different ways.

How to convert Ease and Bezier functions

 1. In the Xsheet view, show the function columns.

 2. In the Xsheet view, click the Expand button located on the right side of the main section to show 
the Functions section. Click on the same button to collapse it. You can also use the Show Column 
List  button in the Xsheet View toolbar.

 3. On the right side of the Functions section, click the Expand button to display the Column List 
section.

 4. In the Timeline view, click the layer that contains you function columns you want to display.

 5. In the Xsheet view, right-click on the column header, select Convert and one of the following:

 l Convert the Column: The values of multiple effects may be linked to the original 
column. When you use the Convert the Column command, all links to the original 
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column will transfer to the new converted column.

 l Create a New Column and Update Links: Creates a new function from the original. 
All links to the original column will transfer to the new column. The original function 
column will remain in the exposure sheet in case you decide you want to switch back 
to it.

 l Create a New Unused Column: Creates a new column based on the values in the 
original column and leaves all links pointing to the original column. You can use this 
command to experiment with various functions and then link effect values to the new 
function curve column.
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Sharing Functions
You can connect two or more functions to a shared function. If that shared function is modified, then the linked 
functions will vary accordingly.

How to share a function using the Layer Properties editor

 1. In the Timeline view, double-click on the layer that contains the function to share.

The Layer Properties window displays.

 2. In the Transformation tab, click the Arrow  button beside the function you want to share and select 
Local.

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.
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 3. From the same menu in which you chose the Bezier option (in our example), select the function you 
just shared and attach it to your parameter.

 4. In the Timeline view, open the Layer Properties editor of the other layer that contains the 
parameters you want to link to the shared function.

 5. In the Layer Properties editor or view, attach the parameter to the shared function the same way 
you did for the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you 
modify the curve, both parameters will update.
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How to share a function using the Share Functions command

 1. In the Timeline view, select the function layer to share.

 2. Right-click  and select Share Functions.

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.

 3. In the Timeline view, double-click on the layer that contains the parameters you want to link to the 
shared function.

The Layer Properties Editor opens.

 4. In the Transformation tab, click the Function Arrow  button beside the function you want to link 
to the function column.

 5. From the menu, select the function you just shared from the 3D Path, Bezier, Ease, Velobased, 
Expression, Connected, Unconnected, or All menu and attach it to your parameter.
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The two parameters are both linked to the same function curve and should follow the same path. If 
you modify the curve, both parameters will update.
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Linking Functions

You can give the same series of motions that you created for one layer to another. These motions may include 
moving, rotating, scaling and skewing. An example would be a car tire. You could animate the rotation of one 
tire and then link that rotation function to another tire, so that they both rotate together. The tire may also 
move up and down if it is driving along a bumpy road. This would mean that you would have to copy the x and 
y-axis position functions as well.

Linking motion works with many layer types, including drawing, peg or 3D subnode. 

In the example below, the rotation from a peg will be copied onto a drawing layer.

How to link the motion from one element to another

 1. Open the Layer Properties of the element whose motion you would like to copy. You can do this is in 
one of two ways:

 l In the Timeline view, double-click on the layer.

 l In the Node view, click on the node's yellow square.

 2. In the Layer Properties, locate the parameter you would like to copy, for example Rotation: Angle z, 
then open the function menu for that parameter, by clicking on the arrow button at the end of the 
row. 

 3. In the function menu, select Copy Function Link.

 4. Open the Layer Properties for the second element. You can have the Layer Properties for both 
elements open at the same time. If you plan to perform multiple copy-pastes, it may be a good idea 
to keep them both open.

 5. Verify that the motion types are the same for both elements. For example, if the Position type for 
your first element is set to Separate, be sure that the Position type for your second element is set to 
the same.
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 6. In the second element's Layer Properties, open the function menu for the same parameter, for 
example Rotation: Angle z.

 7. In the function menu, select Paste Function Link.

Notice in the parameter's function field that the copied motion function appears, including the name 
of element that the function was copied from.

In the Timeline view, all the keyframes relating to that motion appear in the Timeline.
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 8. In the Camera view, slide the red playhead back and forth to view the two linked objects.

 9. Repeat steps 2-8 for any other motion that you would like linked.

Simply deleting the keyframes from an element that was linked to another does not break the link between 
the two objects. You must clear the function field for all linked parameters in the Layer Properties of the linked 
element.

How to unlink the motion between two elements

 1. Open the Layer Properties of the element which contains linked functions.

 2. Open the function menu for a parameter with a linked motion function and select Local.

The property field is reset to 0.
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About Copying Motions
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them 
and even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want 
to paste the drawings or just the keys or maybe everything. There are different paste options available in the 
Timeline view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:

 l  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

 l  Paste Mode: Keyframes Only: Pastes only the keyframes.

 l   Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when 
moving your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and 
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the 
Paste Reverse command to completely reverse the flow of your animation.
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Using Timeline Paste Modes
Use can copy and paste or drag and drop keyframes and drawings in the Timeline view using various modes.

How to paste a selection using different modes

 1. In the Timeline view, select the cells you want to copy and paste.

 2. In the Timeline toolbar, click the desired Paste  mode button.

 3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) 
or ⌘  + C (macOS).

 4. In the Timeline view's right side, select the cell on which you want to paste your selection.

 5. Select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

Paste Mode: Exposures Only
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Using Paste Special
You can copy drawing exposures and keyframes and paste only a portion of your selection using Paste Special.

How to copy and paste a motion using Paste Special

 1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go 
to step 3.

 2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) 
or ⌘  + C (macOS).

 3. Edit your selection by doing the following:

 l To paste the selection, in the Timeline view, select the first cell on which you want to 
paste your keyframes and from the top menu, select Edit > Paste Special or press Ctrl 
+ B (Windows/Linux) or ⌘  + B (macOS).

 l To move the selection, in the Timeline view, drag the selection and hold down Alt. 
Drop the selection where you need it and release the hot key.

The Paste Special window opens.

 4. Set the Drawing, Pegs and Functions, and Cycles parameters. 

 5. Click OK.
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Cycling Animations
You can copy and cycle a section of your animation or your entire animation.

How to cycle an animation

 1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells from the Xsheet/Timeline.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (macOS).

The Paste Cycle dialog box opens.

 5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.

 6. In the Cycle Type, select the type of cycle to paste.

 l Normal (forward): Pastes your selection as it is, starting with the first cell and ending 
with the last.

 l Reverse: Pastes your selection reversed, starting with the last cell and ending with 
the first.

 l Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going 
to the last one and ending with the first cell.

 l Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last 
cell, going to the first one and ending with the last cell.
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Pasting Reverse Motions
You can paste your animation reversed from its original flow.

How to reverse the animation flow

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

 2. From the top menu, select Edit > Copy.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (macOS).
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About Velocity
T-ANIMCO-001-009

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters 
script and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve 
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle 
and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them 
to adjust the ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

You can also reshape the velocity function using Ease controls.
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If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for 
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected 
keyframes in the same frame.
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Displaying Velocity Curves
You can display a parameter's function curve and adjust the easing with the relevant controls.

How to display the velocity curve

 1. In the Timeline view, click the Expand  button on a layer or press Alt + F.

The layer’s functions are displayed.

 2. Double-click the desired function. Note that 3D Paths have a specific velocity curve controlling the 
X, Y, and Z axis together. You need to click on the Position:Velocity layer.

The Function Editor opens as the Ease Editor or Bezier Editor.
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The editor will not be displayed if the function does not already exist.
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Adjusting Bezier Curve Velocity
You can reshape a Bezier curve velocity using the Function view controls.

How to adjust a Bezier curve velocity

 1. In the Function view, select a keyframe.

 2. Drag the controls to modify the shape of the curve.

You can reshape the function using the Bézier controls.

 3. The Continuity options influence how you can move the handles:

 l Straight: Lets you move the handles together, maintaining the same angle to the 
point.

 l Corner: Lets you move the handles independently.

 l Smooth: Lets you move the handles together, maintaining the same distance and 
angle to the point.
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Adjusting  Ease Curve Velocity
You can reshape an Ease curve velocity using the Function view controls.

How to reshape the function using Ease controls

 1. In the Function view, select a keyframe.

You can reshape the function using the Ease controls.

 2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the 
green line. The ease in slope is indicated in blue. 

As you change the values visually, the value in the Ease In field is updated. This value represents 
the number of frames in the ease-in.

 3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the 
green line. The ease-out slope is indicated in red. 

As you change the values visually, the value in the Ease Out field is updated. This value represents 
the number of frames in the ease-out.

 4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:
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 l Straight: Lets you move the handles together, maintaining the same angle to the 
point.

 l Corner: Lets you move the handles independently.
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Creating Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when 
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those 
two frames.

How to create a step velocity

 1. Click the Hold Value Editor  button.

The Hold Value editor opens.

 2. In the Hold Value Editor, enter the following values:

 l Start: The starting frame for the effect.

 l Stop: The last frame for the effect.

 l Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) 
consistently between keyframes. That is, there is no acceleration in the effect.

How to create a step velocity for multiple parameters

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l right-click on the empty space near the top of the interface  and from the quick-access menu 
selecting Scripting.
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 l right-click on the empty space near the top of a view and from the quick-access menu 
selecting Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager 
window.

 3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_CreateStepsOn.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_CreateStepsOn script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Timeline view, select the layer whose parameter values you would like to hold. 

 9. In the Scripting toolbar, click on the TB_CreateStepsOn script  button.

The Create Function Step On dialog box appears.
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 10. In the Settings section, enter the hold value by changing the number in the Every Number of 
Frames field.

 11. In the Selection section, enter the first and last frame numbers to define the selection range.

NOTE 

The playhead location determines the lowest value you can enter for the first frame, 
when defining the selection range. You need to move the playhead to frame one if you 
would like to set frame one as the lowest possible starting value. 

 12. Click OK.

 13. In the Timeline view, expand the layer properties of the selected layer by clicking on its plus  
button.

 14. Double-click on a parameter layer to open its Bezier Editor. If that parameter was animated, the 3 
frame hold from frame 20 to 60 was applied.
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 15. In the Bezier Editor, click on any of the keyframes to bring up the bezier point handles and use them 
to reshape the velocity curve for that parameter.
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This means that multiple parameters can have the same stepped velocity, but have different ease-
in ease-out curves defining that velocity.
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Adjusting Velocity in the Timeline View
If you would rather avoid playing with graphs and function curves, you can adjust the velocity in the Timeline 
view.

How to set the ease in the Timeline view

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE 

Only the first selected keyframe will be considered when using the Set Ease For Multiple 
Parameter function. If many keyframes are selected on the same layer, the ease values will be 
applied only on the first keyframe and the rest will be ignored.

 2. In the Timeline toolbar, select an option from the Set Ease Type menu.

NOTE 

TIP: Optimize your workflow by adding the Apply Ease to Selection  button to the Timeline 
toolbar. This lets you quickly reapply the ease type without going through the Set Ease Type 
menu each time. To add the button to the toolbar, right-click on the toolbar area of the 
Timeline view and select Customize. 
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Setting Ease on Multiple Parameters
T-HFND-009-013

You can adjust the velocity on multiple parameters at a same frame for consistency.

How to set the ease on multiple parameters

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE 

Only the first selected keyframe will be considered when using the Set Ease For 
Multiple Parameter function. If many keyframes are selected on the same layer, 
the ease values will be applied only on the first keyframe and the rest will be 
ignored.

 2. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.

1070

Harmony 21 Premium User Guide                          



Chapter 9: Digital Animation

 4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as 
Rotation or Scale. Deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions.

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity 
functions. Note that it applies to the Morphing velocity function found in the Layer 
Properties window, not the basic morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other the selected functions, such as 
all functions created to animate effect parameters.

 5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are 
calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value 
corresponding to the length of time you want the easing to last. Stay between 0% 
and 100%. If you go beyond 100%, your motion will overshoot. 

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
strong you want the easing out to be. Stay between 0% and 100%. If you go beyond 
100%, your motion will overshoot. 

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 6. Once done, click one of the following:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then 
selects the previous keyframe in the timeline.

 l Apply: Applies the easing parameters to the selected keyframes.
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 l Apply/Next: Applies the easing parameters to the selected keyframes and then 
selects the next keyframe in the timeline.

 l Close: Close the dialog box. If you did not apply the modifications, they will be 
cancelled.
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About Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values in 
another function. An expression is a mathematical formula that allows you to manipulate the value in the 
source function to create new values for the destination effect.

For example, in a scene with two characters, one is walking across the stage and the other is following the 
same path two steps behind. Without expressions, you would have to manually enter the values for the 
position of the peg to be one frame behind the original element. However, you can save time by building an 
expression that does it for you. Then, if you change the position of the element in the original column, Harmony 
automatically updates the Expression columns linked to it.

When you want to create an expression for an effect, you must add an Expression column to the Xsheet view, 
build the expression and then link the Expression column to the parameter you want to control.

Writing Expressions

Expressions are based on a JavaScript (JS) program. You can access the full capability of the JS language and 
write any type of program, as long as it executes relatively quickly.

The entire JavaScript must be defined within the expression code. There is no common repository of JS 
functions and services available to the expression column scripting environment. However, with the Harmony 
C++ SDK, you can extend the API of functions available to the expression scripting environment.

If you're working with an old project that contains expressions, they are converted to a JS program. Only 
simple expressions are updated. Complex expressions and expressions using non-ported services cannot be 
converted. For these type of expressions, you must convert them manually.
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Expression Dialog Box

The Expression dialog box is where you write expressions. It's a simple text editor that can handle incomplete 
or invalid JS programs although they will not be evaluated. Harmony can save and load invalid JS programs.

The Expression editor evaluates the current script at the current global frame and reports any errors or returns 
the numerical result of the program.

Expression JavaScript Program

An expression JavaScript program can be any valid program. The only requirement is the last statement of the 
script must leave a number on the stack. The “return” statement is NOT needed as the script is not a function.

Valid Expression Column JS Program

Example 1

10

This is a simple program returning 10.

Example 2

currentFrame

This is another simple program returning the current frame. The variable “currentFrame” is one of the 
predefined variables and services available.

Example 3

value( “MyBezierFunction”, currentFrame - 1 );

A simple expression program that returns the value of the Bezier function “MyBezierFunction” at the previous 
frame. If this function does not exist in the scene, the expression column will be blank in the Xsheet. If this 
function does exist, the expression column will show the value of that function at the frame.

Example 4

This programs evaluates the Fibonacci series starting at the current frame. The value will be computed up to a 
certain frame. After that frame, the program is too complex and will be stopped by the engine before finishing.
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Errors

Programs that take too long to execute, that don't generate a numerical value, or has syntax errors will not be 
compiled and will not compute a value. The scripting editor will show the condition that triggers this, but the 
Xsheet will display a blank field.

API

To refer to the values in a column, use the column name and frame number. If you do not state the frame 
number, then Harmony uses the value of the current frame. You can refer to the frame numbers in the following 
ways:

 l currentFrame: Refers to the current frame number.

 l numFrames: Refers to the total number of frames in a scene.

Consider the expression: value ( “peg x”, currentFrame-1)

 l This expression says that the current frame value will be the same as the previous frame value of the 
element peg x.

Now consider this expression: value ( “peg_angle”, currentFrame - 2] * 3

 l In this expression, Harmony is to look two frames before the current frame in the column "peg_angle" 
and multiply the value by 3 to derive the value for the current frame of the expression column.

Predefined Functions

Most mathematic functions are obvious. They either take an angle or value, or return an angle or  value. Angles 
are always specified in degrees. If the input argument is not valid, the function will log an error (which is visible 
in the script editor) and the Xsheet does not display anything.

The two variants of the function value() are used to get the value of 2D functions at the current frame or the 
specified frame. The first argument is always a string that identifies the function. The optional second 
argument is the frame to use.

For example: value( “myFavBezier”, currentFrame-1)

Function Description

sin (angle) Returns the sinus from the angle specified in degrees.

cos (cosine) Returns the cosinus from the angle specified in  degrees.

tan (angle) Returns the tangent from the angle specified in  degrees.

asin( v ) Returns the arcs in degrees.
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acos( v ) Returns the arccos in degrees.

atan( v ) Returns arctan as an angle in degrees from the first  quadrant.

atan2( x, y ) Returns the arc tangent in degrees.

int Returns the integer value of the “v”. Undefined  behaviour for negative number.

ceil( v ) Returns the next integer greater or equal than “v”.

floor( v ) Returns the integer value of v. Remove the fractional  part.

abs( v ) Returns the absolute value.

sqrt( v ) Returns the square root for v >= 0.

exp( v ) Returns the “e” exponent v. (see c library exp( f )).

ln( v ) Returns the natural logarithmic of v for v > 0.

ln Logarithm of a value.

value( columnName) Value of the function specified by “columnName” at the current frame.

value(columnName,frame)
Value of the function specified by “columnName” at the frame specified by 
“frame”.

column( columnName )

Indentify the text wrapped by columnName to be renamed whenever the column 
named “columnName” is renamed.

column() is a keyword that does nothing at runtime, but helps Harmony track 
which references to a function needs to be renamed in the script when a function 
is renamed. For example, if you have a function named “B” and this one gets 
renamed to “C” through some scripts or by the user, all expression scripts 
referencing “B” will automatically be updated to refer to “C” if their call was 
wrapped as column( “B” ).

node( nodeName )

node( nodeName ) 

Identifies a node/node that is in the same group as another node which is using 
this expression column.

node( nodeName) and node( nodeName ) are two functions that return a proxy to 
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a node that must be in the same group as another node using that expression 
column. For this method to work, the expression must be connected to a node 
“A” and the script must refer to a node “B” in the same group as node “A”. The 
resulting object is a proxy to a node which cannot be converted to a number. This 
proxy object is only usable by an SDK plugin.

numFrames A constant that represents the number of frames in the current scene.

currentFrame A constant that represents the current frame (1 based).
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Writing Expressions
The number of expressions you can write is limitless. Find below an example of an expression for an effect.

How to build an expression for an effect

 1. In the Xsheet view menu, select Columns > Add Columns or press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a name for the column.

 3. From the Type menu, select Expression and click OK.

 4. Double-click on the column's header to open the Expression dialog box.

 5. Type an expression in the dialog box.

1078

Harmony 21 Premium User Guide                          



Chapter 9: Digital Animation

NOTE 

To address a specific component of a 3D path, the syntax is "Peg x", not "Peg_x".

 6. Click OK or Apply to activate the expression.

The cells in the Expression column are filled with values based on the expression you created.

 7. To apply the values in the Expression column to an effect, link the Expression column to the 
parameter values. In the drawing's layer properties, link the function to the new Expression column.
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About Animation Resources
As you are animating, you might find that you are constantly selecting the same elements from your scene, in 
order to progressively move and manipulate them. You can create a preset for almost any selection or group 
selection in your scene, in order to speed up the animating process.
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Creating Selection Presets
As you're animating, you might find that you are constantly selecting the same pegs, drawing layers, bezier 
points on a deformation envelope, part of a character rig, etc. You can create a preset that automatically selects 
any defined element or group of elements.

How to add the Selection Preset script to the Scripting Toolbar

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l right-click on the empty space near the top of the interface  and from the quick-access menu 
selecting Scripting.

 l right-click on the empty space near the top of a view and from the quick-access menu 
selecting Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager 
window.

 3. In the Scripts Manager, in the Files section, select the file TB_SelectionPreset.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_SelectionPreset.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_SelectionPreset script  button is added to the Scripting toolbar.
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 6. Click Apply.

 7. Click OK.

How to create a preset from a selection

 1. In the Scripting toolbar, click on the TB_SelectionPreset  button.

The Selection Presets dialog window opens.

 2. In your scene, select an individual element or group of elements. This can include, but is not limited 
to:  pegs, drawing layers, deformation controls, part of a character (such as the entire rig of the head 
from the Node view).

 3. In the Selection Presets window, click on the plus button.

The Save Selection As Preset dialog box opens.

 4. Enter a name for the new selection preset in the field provided.

 5. Click OK.

The new selection preset name appears in the Selection Presets window.
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How to use a Selection Preset

 1. In the Scripting toolbar, click on the TB_SelectionPreset  button.

The Selection Presets window opens.

 2. Double-click in the Group field next to the  Selection Preset you wish to use OR select a preset from 
the Name column and click on the Apply To Selection button.

The defined selection is selected.
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Chapter 10: Morphing Animation

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing 
feature can help speed up the process. This powerful feature automatically creates computer-generated 
drawings between your vector drawings to save time and increase productivity. You can easily modify the 
timing and velocity (ease in and ease out) of a morphing animation. 

One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can 
be time-consuming because these types of effects are usually slow moving requiring a large number of closely 
placed inbetweens.

The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by 
saving time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with 
more time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you 
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be 
producing some remarkable effects. 

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and 
which drawing lines may be more useful or problematic will enable you to design your key drawings so they 
morph efficiently. 

NOTE 

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a 
drawing than to hand-draw it, then it is better to animate it instead of morphing. However, if you 
spot an occasion when you can morph your drawings, do it! It allows you to fix your timing and 
velocity in no time without having to create any extra drawings!
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About Source and Destination Drawings
The morphing feature matches similar shapes in a source and a destination drawing. Harmony evaluates the 
source's shape properties and matches them to the most similar ones in the destination drawing.

Morphing works between similar shapes, which are drawings that have the same palette, colours and number 
of shapes. You can even change any shape into another one, as long as the source and destination keep the 
same colours, number of lines and number of shapes.
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About Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules 
before you start morphing.

NOTE 

Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap 
layers or Toon Boom bitmap drawings.

Here are a few tips about creating morphing sequences:

 l When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil 
line for simple closed shapes.

 l If you are using pencil lines, use Contour hints instead of Pencil hints. Use Pencil hint if you want the 
Pencil line to switch direction. 

 l Flatten your drawing before starting a morphing sequence.

 l If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the 
source line is closer to the dot than the destination line, the source line will morph into the dot and the 
destination line will disappear.

 l Use the same colour swatch between two drawings. You cannot morph between two different colour 
swatches even if they have the same RGB values. This can be turned to your advantage for complex 
morphing.

 l Similar shapes should have the same number of colour zones. This only applies to the number of zones 
and lines and not the number of points on a curve.

 l If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the 
morphing will fail.

 l For example, if you are morphing a face so it turns from the front to the side, the nose is located in the 
middle of the face on the source drawing. However if after morphing, the nose ends up outside or 
merged with the face profile line on the destination drawing, this will give undesirable results. You can 
avoid this by using morphing layers and splitting the nose on a separate layer.
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About the Closest Similar Shape Rule
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it 
will morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (colour ID) 
and has the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same colour swatch. 
It will morph with the red diamond shape (1) in the next drawing. The red diamond shape (2) in the source 
drawing will morph with the red heart shape (2) located in the same area in the destination drawing. The 
black spade shape (3) in the source drawing will morph with the black club shape (3) located in the same area 
in the destination drawing. Finally, the black club shape (4) in the source drawing will morph into the black 
spade shape (4) located above in the destination drawing.
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About the Pencil Line to Pencil Line Rule
If you trace a shape using a pencil line such as the Ellipse , Rectangle , Polyline , Line  or Pencil  
tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central 
vector).

A pencil line will never morph with a brush stroke.

Pencil lines with thickness are supported in morphing sequences. The thickness will morph according to the 
thickest and thinnest areas in the source and destination drawings.
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Pencil lines with textures are not supported in a morphing sequence. During the morphing, the texture will 
disappear and show without pencil line opacity texture.

If you have pencil lines in your source drawing, the same number of pencil lines must be present in the 
destination drawings. A pencil line will appear if it is not found in the destination drawing. It will pop out on 
the first or last frame depending on which one it is drawn.

When two pencil lines cross one another, they are considered to be two lines and not four lines anymore (as it 
was in version 7.8 and below of the application). In this case, you must have two pencil lines in your destination 
drawing for your morphing to work correctly.
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About the Fill Shape to Fill Shape Rule
If you have a brush stroke or a colour fill ( contour vectors), make sure that you morph it with another  brush 
stroke or fill zone. It is important to undersand that strokes drawn with the Brush tool are the same thing as 
zones painted with the Paint tool. Vector points are located along the contour. They are simply not the same 
size. Contour vectors will not morph with pencil lines (central vectors). A brush stroke can morph into a colour 
fill zone and vice versa as they are the exact same thing.
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About the Same Colour Swatch Rule
Harmony does not morph between colours. If you want to perform a colour transition, you have to create the 
effect during the compositing step of your production. A colour palette is composed of colour swatches. Each 
colour swatch has its own unique identification number, even if two swatches are the same colour value, they 
are identified independently. A colour zone or shape will morph with another one painted with the same 
colour swatch.
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About the Vanishing and Appearing Rule
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or 
disappear.
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About the Colour Art and Line Art Rule
In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically, 
an extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular 
layer on which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.

 l A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art. 

 l A shape drawn in Line Art can only be morphed with another shape existing in the Line Art. 

 l A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating Morphing
When it comes to morphing, you will need to practice and become at ease with it. Once you are familiar with 
the basic rules, you can start creating morphing sequences. To begin, start with simple elements. When you 
are confident with the morphing process, you can start to use complex and advanced morphing techniques, 
such as head rotations or full characters.

NOTE 

As you create and adjust your morphing sequences, you will often use the Tool Properties view. 
Using this view allows you to do things such as toggle between your key drawings, adjust the 
easing or select a hint type. 

How to create a basic morph

 1. In the Timeline toolbar, click the Add Drawing Layer  button to add a new layer to your project.

 2. Rename the new layer ( for example, Morphing).

 3. In the Timeline or Xsheet view, select the first cell in the layer.

 4. Do one of the following:

 l In the Tools toolbar, select the Rectangle  tool.

 l Press  Alt + 7.

 5. In the Camera or Drawing view, draw a rectangle.

NOTE 

When drawing a rectangle or an ellipsis, you can hold down the Shift key to 
draw your shape with equal dimensions, so as to make a square or a circle 
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instead. You can also hold down the Alt key to draw the shape from its center 
rather than from its corner.

 6. Paint your rectangle using the Paint tool.

 7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

 8. Do one of the following:

 l In the Tools toolbar, select the Ellipse  tool.

 l Press  Alt + =.

 9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.

 10. In the Xsheet or Timeline view, select the range of frames going from your first drawing to your 
second drawing, including the frames containing the drawings.
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 11. Do one of the following:

 l From the top menu,  select Animation > Morphing > Create Morphing.

 l In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing 

 l Press Alt + M.

Arrows going from the first key drawing to the second key drawing appear, indicating that 
computer-generated inbetweens have been created.
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Deleting Morphing
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.

How to delete a morphing sequence

 1. In the Xsheet or Timeline view, select a cell in the morphing sequence. 

 2. Do one of the following:

 l From the top menu, select Animation > Morphing > Delete Morphing.

 l From the Xsheet or Timeline view menu, select Morphing > Delete Morphing.

 l right-click on your sequence and select Morphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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About Morphing Velocity and Timing
Once you have set up a morphing sequence, you can control its velocity and timing. 

When you look at your animation you will notice that the morphing motion is constant. To produce a less 
mechanical motion, you will probably want to create some ease in or ease out.

If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one 
function curve rather than several separate ones. Having all of your velocity parameters in one place is more 
efficient and easier to modify.

Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the morphing 
sequence. The sequence will always start with the source drawing and end at the destination. You can play 
the morphing sequence backwards or forwards during the animation.
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Adjusting the Morphing Velocity
You can have two levels of easing:

 l In the Tool Properties View, you can adjust the velocity of each sequence in your layer independently

 l In the Layer Properties editor, you can adjust the morphing velocity function to control the entire layer's 
easing

How to adjust the velocity in the Tool Properties view

 1. In the Tools toolbar, select the Morphing  tool or press F3.

 2. In the Timeline view, click on a frame in the morphing sequence you want to adjust.

 3. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the 
sequence's velocity.

How to adjust the velocity in the Layer Properties editor

 1. In the Timeline view, double-click on the drawing layer to open the Layer Properties editor.

 2. In the Layer Properties editor, go to the Advanced tab and click on the Function  button to create 
a function curve.

 3. In the Layer Properties editor, click the Function  button again to open the velocity curve.

 4. Add a keyframe at the first frame of the morphing (source) and one at the end (destination) by 
clicking on the Add/Remove Keyframe  button. 

1100

Harmony 21 Premium User Guide                          



Chapter 10: Morphing Animation

 5. Move the destination keyframe upward.

NOTE 

It is important that the last keyframe remains above the first one.

 6. Make sure that the first keyframe is not a stop-motion keyframe. To do this, disable the Stop-motion 
Keyframe button. To use the Toggle Stop-Motion Segment feature, press S. 

 7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the 
curve go downward instead of upward, the animation will play backward until the curve starts to 
go upward again.
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NOTE 

If you have more than one morphing sequence in the same layer, you need to add a keyframe 
on the velocity curve for each source and destination drawing.

 8. If you want your morphing to play back on a double frame exposure rather than single frame, you 
can use the Hold Value editor and set the velocity to change every second frame, instead of every 
frame.

 9. In the Morphing Function editor, click on the Hold Value Editor  button and set the parameters to 
hold the value for two frames.
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Adjusting the Morphing Timing
If you did not place your source and destination drawings on the correct frames you may need to extend or 
shrink the sequence length.

How to extend or shrink a morphing sequence length

 1. In the Timeline view, select the source or destination drawing.

 2. Click on your selection and drag the drawing to its new frame.
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About Morphing  Hints
Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to 
place hints to ensure Harmony morphs your drawings the way you intended.

Hints are points that are placed in both the source and destination drawings to associate zones and lines 
between the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line 
that is not following the colour fill zone, or when a part of your source drawing doesn't morph into its 
corresponding part of the destination drawing. By default, Harmony will associate a corner or a point in the 
source drawing with the nearest corner or point in the destination drawing. Hence, hints quickly become 
necessary if the shape being morphed or its movement is complex. 

Hints always exist on both the source and destination drawing. When you create a hint on either drawing in a 
morph, a corresponding hint will automatically appear on the other drawing. The same principle applies if you 
delete a hint. 

The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this 
may also fix the smaller ones at the same time.
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Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to 
correctly use and place hints.

If you are morphing two sequences in a row, you will have to create a different set of hint points for each 
sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create 
two morphing sequences; one sequence between drawings 1 and 2, and a second sequence between 
drawings 2 and 3.

NOTE 

Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will 
have a set of hints for the first sequence and another set for the second sequence. The two sets of 
hints will not show at the same time. Each set of hints that appears always corresponds to the 
morphing sequence you are working on.
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About Hint Types
To correct morphing distortions, Harmony has different types of hints available for controlling different types 
of problems.

Each type of hint has a different purpose and they can all be used in the same drawing. Use the Morphing tool 
to add hints to your morphing sequences.

Hint points in the source drawing are green and red in the destination drawing.
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About Contour Hints

The Contour Hint  point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It 
allows you to control the line thickness and contour position. Also, if a contour is not animated correctly, you 
can use hints to correct the animation. For example, if a flag is not waving properly.

When adding a Contour Hint point, make sure to place it far enough away from the contour so you can see it 
snap to the contour. 

Contour Hint points are yellow.

NOTE 

Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, 
when in fact, it has not and the morphing will remain unchanged.

NOTE 

To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations 
over time.
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About Zone Hints

The Zone Hint  point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the centre 
of the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For 
example, in a splash animation there are many water droplets that are the same colour. Harmony 
automatically morphs the droplet to the nearest one. This is not always the one you may have predicted. A 
Zone Hint will force a colour zone to morph with another one.

Zone Hint points are cyan in colour.
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About Pencil Hints

A Pencil Hint  point is used to control a pencil line, also known as central vector. It can be used on drawings 
that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil 
Hint snaps to the central vector. Make sure to place it far enough away from the line so you will see it snap 
when you move it.

Pencil Hint points are magenta in colour.
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About Vanishing Point Hints

A Vanishing Point Hint  is used to control the trajectory of a vanishing shape. A shape will vanish from the 
source drawing when there is no corresponding shape in the destination drawing. If you do not place a 
Vanishing Point Hint to control the point of disappearance, the shape will vanish into its centre.

Vanishing Point Hint points are green in colour.
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About Appearing Point Hints

An Appearing Point Hint   is used to control the trajectory of an appearing shape. A shape will appear in the 
destination drawing when there is no corresponding shape in the source drawing. If you do not place an 
Appearing Point Hint to control the point of appearance, the shape will appear from its centre and expand 
outwards.

Appearing Point Hint points are violet in colour.
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Adding and Deleting Morphing Hints
Using the Morphing tool you can use hints to correct the morphing sequence.

How to add and hints

 1. In the Timeline or Xsheet view, select the source drawing of your morphing sequence.

 2. In the Tools toolbar, select the  Morphing  tool or press F3.

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a 
reference.

 3. In the Tool Properties view, select the type of hint you want to use.

 l Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil 
line. Note that you obtain better results using the Pencil Hint point on pencil line 
rather than Contour Hint points.

 l Select Pencil Hint to correct a pencil line (Central vector).

 l Select Zone Hint to correct a colour zone morphing match.

 l Select Vanishing Point Hint to correct a vanishing shape's trajectory. 

 l Select Appearing Point Hint to correct an appearing shape's trajectory. 

 4. In the Camera or Drawing view, click on the drawing near the problematic area.
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 5. Select the hint's point and move it to its correct position.

 6. In the Timeline or Xsheet view, select your destination drawing.

 7. Find and move the corresponding hint's point to the matching part of your destination drawing. 

 8. In the Playback toolbar, press the Play  button to see the result.

How to delete hints

 1. Select one or many hints.

 2. Press Del.
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NOTE 

To delete all of the hint points at once, press Shift + Del.
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Copying Hint Points
If you have two morphing sequences that use the same drawing and you would like to copy it and its hint 
points, you can do so in the Drawing view.

How to copy a drawing and its hints

 1. Do one of the following:

 l In the Tools toolbar, click the Select  tool.

 l Press  Alt + S.

 2. In the Drawing view, select the drawing to reuse in your second morphing sequence. 

 3. Do one of the following:

 l In the top menu, select Edit > Copy.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 4. In the Timeline view, select the cell where the new drawing will be.
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 5. In the Drawing view, paste your selection. 

 6. Do one of the following:

 l In the top menu, select Edit > Paste .

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

 7. In the Timeline view, select the cell where the second drawing will be.

 8. In the Drawing or Camera view, draw your second drawing.

 9. Do one of the following:

 l In the Timeline view, create the morphing sequence for the new drawings.

 l Press Alt + M.

 10. Do one of the following:

 l In the Tools toolbar, select the Morphing  tool.
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 l Press F3.

 11. In the Drawing or Camera view, position your hint points.
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About Morphing Layers
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control and may 
not work properly, by dividing the drawings into morphing layers, the task becomes much easier.

The major points used in controlling a morphing sequence are the intersections. If there are many lines 
intersecting within a drawing, the system will require more control—see About Hint Types on page 1106.

An important aspect of morphing is to identify possible problem zones in order to fix them and avoid 
potentially frustrating situations.

Simple details that look easy to morph can sometimes be more challenging than they may initially appear to 
be. For example, you may find that the nose becomes an issue when performing a head rotation. As explained 
earlier, the drawings need to be similar in their number of shapes. Generally, on a head rotation, the source 
nose is in the centre of the face, but on the destination, the nose line is part of the face outline. This means that 
on the source drawing, the nose and the face outline are two separate shapes, whereas they are combined into 
one shape on the destination drawing.

Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the 
destination nose grows from the character's cheek.
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Any shape that is contained inside another one and has to morph out of that shape will be problematic for the 
same reasons as the nose is. At some point during the morphing sequence, the shape contained inside the face 
will merge with the face outline, and then become a separate shape again.

Morphing layers are all contained in the same drawing layer. It is like having a mini Timeline within a Timeline 
layer, or a mini Xsheet within an Xsheet column.

Each morphing layer can have its own duration and velocity. Also, because you only have a single element to 
handle in your Timeline or Xsheet view, it will be treated as one element for the Compositing process, making 
the compositor's work easier.

You can separate all of your elements into different drawing elements and have many layers, but you would 
have to create a large number of morphing sequences and make sure that you modify all of their timings 
properly. 

Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene 
structure by adding more elements, which can be very important for Cut-out animation puppets. For example, 
if you morph a front head to a three-quarter head where the ear needs to be separate, you do not want to add 
a new ear layer at the same time and have to worry about connecting it inside the puppet's construction. 
Instead, simply create an ear morphing layer within the head layer. 

1119



NOTE 

Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can 
also use the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third 
one and so one. This technique is useful if you plan to do more than one morphing sequence in the 
same column. For example, front head to three-quarter head to side head. The three-quarter 
drawings will be used in both morphing sequences. 
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Creating Morphing with Morphing Layers
You can create morphing sequences on separated layers using morphing layers.

How to create a morph with morphing layers

 1. In the Timeline view, add a new drawing element and name it properly.

 2. In the first cell, draw the main source shape such as the head shape or body shape. Do not add 
details like eyes.

 3. In the Timeline view, select the destination cell.

 4. Enable and extend the Onion Skin.

 5. In the destination cell, draw the second drawing.

 6. In the Timeline view, select the in-between cells.

 7. Do one of the following:
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 l Right-click and select Morphing > Create Morphing.

 l Press Alt + M. 

 8. In the Tools toolbar, select the Morphing  tool.

 9. In the Morphing Tools Properties view, click on the Add Layer  button to add a new morphing 
layer. When you click on a morphing layer drawing, it automatically appears on top of the others. If 
you want it to stay in place, for example the wing behind the body, enable the Show Morphing in 
Place  option in the Morphing Tool Properties view. 

 10. Double-click on the new layer's name and name it appropriately.

 11. Press Enter/Return.

 12. Use the Up  and Down  arrow buttons to move the new layer above or below the Main layer. 

 l If placed above the Main layer, it will be displayed in front. If it is placed below, it will 
be displayed behind.
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 13. To create new drawings, double-click on the blank area under the From section to create the 
source drawing and the To section for the destination drawing and type a different value than the 
ones used for the main layer.

 14. Press Enter/Return.

You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

 15. Click on the new source drawing to start drawing the new part. (Make sure that you are working on 
the proper drawing by verifying the name in the Camera or Drawing view's bottom left corner.) 

 16. In the Camera or Drawing view, draw the source drawing.

 17. Once the source drawing is done, use the Morphing Tool Properties view and click on the 
destination drawing's name and draw it in the Camera or Drawing view.

 18. Repeat steps 9 to 15 for each layer needed. You can add as many layers as you want.

 19. Enable or disable the layers that you want to display or hide while drawing.
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 20. If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.
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About Morphing Key Drawings
Once you have a morphing sequence, you can add a morphing key drawing.

A morphing key  drawing allows you to insert extra details into a morphing sequence. For example, during a 
morphing sequence you may need to insert a detail such as teeth or a mouth; this is easy to do when you use a 
morphing key  drawing. Instead of creating an entirely new drawing, convert a computer generated in-
between to a morphing key  drawing and add your extra details to it and the next key drawing.
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Inserting Morphing Key Drawings
A morphing key  drawing converts a computer-generated morphing frame into a real drawing that you can 
edit. It splits the morphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing

 1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing 
keyframe.

 2. Do one of the following:

 l In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

 l Right-click and select Morphing > Insert Morphing Key Drawing.

The new morphing key  drawing appears.

 3. In the Drawing or Camera view, draw your new details on the morphing key  drawing.

 4. In the Playback toolbar, press the Play  button to see the result.
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About Transparency Morphs
To be able to morph shapes with holes or transparent colours, it is important to understand the process of 
analyzing and morphing a shape. Harmony begins the process by reading the exterior outline of the entire 
shape. So if you are morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as 
colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled 
with an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent 
colour so that you can control it and flatten the transparency to cut a hole through the main shape.

The same thing happens when you have holes painted with semi-transparent colours. To see through your 
shapes, you have to follow the same process as morphing shapes with holes.
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Morphing Transparencies
You can use invisible colours to morph holes and transparencies.

How to morph a shape with a hole

 1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

 2. Paint both holes on the source and destination drawings.

 3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

 4. Do one of the following:

 l In the Tools toolbar, select the Morphing  tool.

 l Press F3.

 5. In the Tool Properties view, enable the Flatten  button.
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A hole appears in the shape.
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About Morphing Quality
Increasing the morphing quality settings improves the line shape between vector points. It also creates a 
larger file, so only increase quality when you are zooming in closely. You can adjust the quality in the Tool 
Properties view and in the Preferences panel.

When morphing in Toon Boom Harmony Premium, there is a preference you can set to help you set the default 
quality of morphing sequences. Refer to  the Preferences Guide for complete descriptions.
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Setting the Morphing Quality Level
Increase the morphing quality to smooth out morphed lines. 

How to set a morphing sequence's quality level

 1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

 2. Do one of the following:

 l In the Tools toolbar, select the Morphing  tool.

 l Press  F3.

 3. In the Tool Properties view, adjust the Quality level.
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Converting Morphing Inbetweens to Drawings
Harmony lets Lets you convert your morphing inbetweens to real drawings you can edit. This is useful when 
manually editing a morphing sequence or if you prefer to have animation timing in double frame (on twos) 
instead of single frame (on ones). 

How to convert morphing inbetweens to drawings

 1. In the Timeline or Xsheet view, select a morphed drawing  in the morphing sequence you want to 
convert to real drawings.

 2. Do one of the following:

 l In the top menu,  select Animation > Morphing > Convert Morphing to Drawings.

 l Right-click and select Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

 3. Type the drawing basename you want to give to your new drawings. In this case, you could type 
circle.

 4. Click  OK.
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Chapter 11: Importing & Scanning
Toon Boom Harmony Premium allows you to import external content as well as being able to draw directly in 
the software. This means that characters, backgrounds and videos created in other drawing, painting and 
multimedia programs can be brought in and animated. You can import QuickTime videos, pictures, multilayered 
.psd files, as well as .ai, .swf, .pdf, and .fla files. You can also scan images and import them as bitmap or 
vectorize them.

NOTE 

For sound import, refer to Importing Sound on page 496.
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About Importing Bitmap Images
T-HFND-007-001

Images can come in many different file formats and are usually saved in a format that retains the original 
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, 
while others are not resolution dependent due to their vector nature. Toon Boom Harmony Premium supports 
the following bitmap image formats: JPEG, BMP, PNG (16 bits per channel RGB and RGBA), TGA, PSD (16 bits 
per channel), TIFF, SGI, TVG, OMF, PAL, SCAN.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Keep as Original Bitmap: This imports the image exactly as is and ensures that it cannot be modified 
when working on the scene. This is useful for using backgrounds that were created in different software 
in your project.

 l Import as Toon Boom Bitmap Drawing: This imports the image as is, but allows you to edit it using 
Harmony's bitmap drawing tools.

 l Import as Toon Boom Vector Drawing: Converts a bitmap  into Toon Boom vector art, which can easily 
be painted and edited using Harmony's vector drawing tools. This can be useful for importing line art 
scanned or created using a different software.

When importing images or 3D models, or when linking images, the settings used to import are saved in your 
user settings.
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Importing Bitmap Images As Original Bitmap
T-HFND-007-002

Importing a bitmap image in its original format ensures it is preserved exactly as is in Harmony. When 
importing a bitmap image, you have several options available such as where you want to import the file and 
how to name it. 

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.
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 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 4. In the Import Options section, select the Keep As Original Bitmap option.

 5. In the Colour Space section, it is possible to specify the colour space of the imported image. During 
the import no other colour space conversion is done, simply the specified colour space is set to the 
new created element. It is also possible to modify the colour space of the layer by using Layer 
Properties.

The colour space could be selected form one of following options:

 l  l Linear: The same primaries and white point as sRGB and Rec. 709, but with no 
gamma transfer curve applied to the colour values. This colour space is useful for 
compositing intermediary images that are meant to be rendered in sRGB or Rec. 709.

 l Display P3: A colour space commonly used for digital projection. It has the same 
primaries as DCI-P3, the same white point as sRGB and the same gamma transfer 
curve as sRGB.

 l Display P3 Linear: The same as Display P3, except with no gamma transfer curve. 
This colour space is useful for compositing intermediary images that are meant to be 
rendered in Display P3.

 l Rec. 709: The colour space used for HDTV. It has the same primaries and white point 
as sRGB, but has a different gamma transfer curve.

 l Rec. 709 2.4: The same colour space as Rec. 709 or sRGB, except with a gamma 
transfer curve of 2.4. This colour space exists because some editing systems use a 
gamma transfer curve of 2.4 instead of the standard gammae curve for Rec. 709.
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 l Rec. 2020: A colour space used for Ultra High Definition TV (UHDTV). It has a complex 
gamma transfer curve and primaries that cover more of the human-perceivable colour 
space than other colour spaces, especially in the area of human-perceivable greens. 

 l Rec. 2020 2.4: The same colour space as Rec. 2020, except with a simple gamma 
transfer curve of 2.4. This colour space exists because some editing systems use a 
gamma transfer curve of 2.4 instead of the standard gammar curve for Rec. 2020.

 l Rec. 2020 Linear: The same colour space as Rec. 2020, except with no gamma 
transfer curve. This colour space is useful for compositing intermediary images that are 
meant to be rendered in Rec. 2020.

 l sRGB: A colour space typically used for standard computer monitors. It has the same 
primaries and white point as Rec. 709, but has a different gamma transfer curve.

 6. In the Alignment section, decide on the size and placement of your image within the camera frame. 
You can choose between the following options:

Parameter Description

Fit

Adjusts the image's size to fit completely within the scene's field, both 
vertically and horizontally, making sure the entire image is visible. 

If the image's orientation is portrait, then it will adjust the image's height to fit 
the field's height, without affecting the image's aspect ratio:

If the image orientation is landscape, then it will adjust the image's width to fit 
the field's width, without affecting the image's aspect ratio:

1137



Pan

This has the opposite effect to the fit parameter. The image's smallest 
dimension will be made to fit the scene frame's matching dimension, and the 
image's largest dimension will be adjusted proportionally, making the image 
fill the entire scene field, and bleed past its boundaries it if its aspect ratio does 
not match the field's aspect ratio. This option can be used to import a panning 
background image, also referred to as a pan.

If the image's orientation is portrait, it will adjust the image's width to fit the 
field's width, without affecting its aspect ratio:

If the image's orientation is landscape, it will adjust the image's height to fit the 
field's height, without affecting its aspect ratio:

1138

Harmony 21 Premium User Guide                          



Chapter 11: Importing & Scanning

Project 
Resolution

Scales the image to fit the scene's resolution, making each pixel in the image 
take one pixel in the scene's field. For example, if the image's dimensions in 
pixels are half of the scene's resolution in pixels, then the image's dimensions 
will appear to be half of the scene field's dimensions. 

 7. If your image has transparency, in the Transparency section, select how the colour values in the 
semi-transparent pixels in the image were premultiplied with their alpha values. This allows 
Harmony to demultiply the values so that it can properly blend the image with the other elements 
in your scene. 

You can choose between the following options:

Parameter Description

Premultiplied with White 

The colour values of semi-transparent pixels in the image 
have been encoded so that the more transparent they are, the 
closer to white they are. When an image that is premultiplied 
with white is loaded in a software that does not support 
transparency, it appears blended with a white background. 
Select this to make Harmony reverse this premultiplication so 
that the image blends properly with other visual elements in 
your scene.

Premultiplied with Black 

The colour values of semi-transparent pixels in the image 
have been encoded so that the more transparent they are, the 
closer to black they are. When an image that is premultiplied 
with black is loaded in a software that does not support 
transparency, it appears blended with a black background. 
Select this to make Harmony reverse this premultiplication so 
that the image blends properly with other visual elements in 
your scene.

Straight The colour of semi-transparent pixels in the image is encoded 
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independently from their transparency. When an image that is 
not premultiplied is loaded in a software that does not 
support transparency, semi-transparent pixels simply appear 
fully opaque, making its edges appear pixelated. 

Clamp Colour to Alpha

This is the same as Premultiplied with Black, except that it 
also prevents the colour values for a given pixel from being 
higher than that pixel's alpha value. This option is only 
useful if you are working with images that are supposed to be 
premultiplied with black, but where the colour values of 
pixels have been increased without their alpha values being 
adjusted accordingly. 

TIP 

The transparency type for an image may depend on the software used to create 
it. For example, images exported by Harmony in any format but PNG are 
typically Premultiplied with Black, whereas PNG images exported by Harmony 
use Straight transparency.

The following are transparency modes typically used by other software for 
specific file types:

 l Portable Network Graphic (.png): Straight

 l Photoshop Document (.psd, .psb):

 l Imported as a single image: Premultiplied with White

 l Imported as separated layers: Straight

 l Tagged Image File Format (.tif): Premultiplied with Black

 l Truevision TARGA (.tga): Straight

 l Silicon Graphics Image (.sgi): Straight

 8. Click OK.

NOTE 

By default, bitmap images will display in low resolution in the Camera view so as to avoid 
affecting playback performance. You can also adjust the display quality of a bitmap image by 
selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View > 
Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by 
activating the Render Preview  mode in the Camera view. 

1140

Harmony 21 Premium User Guide                          



Chapter 11: Importing & Scanning

Adjusting the Bitmap Image Display Quality 

T-HFND-007-004

Your original bitmaps are imported as is in your project. In the Camera view, they may appear low quality as a 
proxy image is displayed in its place to insure fast playback.

If the bitmap images that you imported look blurry or slightly pixelated, you can increase the image proxy 
display by changing the quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

 1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is 
encapsulated or simply select the bitmap image layer in the Timeline view if it's not.

 2. Do one of the following:

 l From the top menu, select View > Bitmap File Quality.

 l From the Camera menu, select View > Bitmap File Quality.

 l Press Ctrl + Q (Windows/Linux) or ⌘  + Q (macOS).

The Bitmap Image Quality dialog box opens.

 3. Drag the slider to the right to improve the quality.

 4. Click OK.

 5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and 
return to your scene.
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Importing Bitmap Images As Toon BoomBitmap
T-HFND-007-002

Importing a bitmap images Toon Boom bitmap preserves its original detail, but allows the user to modify them 
using Harmony's bitmap drawing tools.

How to import a bitmap image as a Toon Boom bitmap drawing

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
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your computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 2. In the Import Options section, select the Import as Toon Boom Bitmap Drawing option.

 3. In the Colour Space section,  the colour space of the new created layer is selected as sRGB by 
default. If “Read Toon Boom Drawings Using sRGB Colour Space” is disabled—see Setting the 
Working Colour Space for a Scene on page 784. It is possible to specify the colour space, which will 
be used by new  layer. If add to existing layer, the colour space of the existing layer will be used, and 
the option is also disabled.

 4. Enabling the option “Convert Image Colour Space on Import” and selecting the “Source Colour 
Space” of the image allows you to convert the image colour space to the layer’s colour space, if the 
colour space of image to be imported is known.

The colour space could be selected form one of following options:

 l Linear: The same primaries and white point as sRGB and Rec. 709, but with no gamma 
transfer curve applied to the colour values. This colour space is useful for compositing 
intermediary images that are meant to be rendered in sRGB or Rec. 709.

 l Display P3: A colour space commonly used for digital projection. It has the same primaries as 
DCI-P3, the same white point as sRGB and the same gamma transfer curve as sRGB.

 l Display P3 Linear: The same as Display P3, except with no gamma transfer curve. This colour 
space is useful for compositing intermediary images that are meant to be rendered in Display 
P3.

 l Rec. 709: The colour space used for HDTV. It has the same primaries and white point as 
sRGB, but has a different gamma transfer curve.

 l Rec. 709 2.4: The same colour space as Rec. 709 or sRGB, except with a gamma transfer 
curve of 2.4. This colour space exists because some editing systems use a gamma transfer 
curve of 2.4 instead of the standard gammae curve for Rec. 709.
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 l Rec. 2020: A colour space used for Ultra High Definition TV (UHDTV). It has a complex 
gamma transfer curve and primaries that cover more of the human-perceivable colour space 
than other colour spaces, especially in the area of human-perceivable greens. 

 l Rec. 2020 2.4: The same colour space as Rec. 2020, except with a simple gamma transfer 
curve of 2.4. This colour space exists because some editing systems use a gamma transfer 
curve of 2.4 instead of the standard gammar curve for Rec. 2020.

 l Rec. 2020 Linear: The same colour space as Rec. 2020, except with no gamma transfer curve. 
This colour space is useful for compositing intermediary images that are meant to be 
rendered in Rec. 2020.

 l sRGB: A colour space typically used for standard computer monitors. It has the same 
primaries and white point as Rec. 709, but has a different gamma transfer curve.

 5. In the Alignment section, decide on the size and placement of your image within the camera frame. 
You can choose between the following options:

Parameter Description

Vertical Fit

Adjusts the image's size so that its height matches the scene's height, without 
affecting its aspect ratio.

Horizontal 
Fit

Adjusts the image's size so that its width matches the scene's width, without 
affecting its aspect ratio.
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Actual Size

Imports the image in its actual size, without adjusting its size relative to the 
scene's resolution. For example, if the image's dimensions in pixels are half of 
the scene's resolution in pixels, then the image's dimensions will appear to be 
half of the scene field's dimensions. 

 6. If your image has transparency, in the Transparency section, select how the colour values in the 
semi-transparent pixels in the image were premultiplied with their alpha values. This allows 
Harmony to demultiply the values so that it can properly blend the image with the other elements 
in your scene. 

You can choose between the following options:

Parameter Description

Premultiplied with White 

The colour values of semi-transparent pixels in the image 
have been encoded so that the more transparent they are, the 
closer to white they are. When an image that is premultiplied 
with white is loaded in a software that does not support 
transparency, it appears blended with a white background. 
Select this to make Harmony reverse this premultiplication so 
that the image blends properly with other visual elements in 
your scene.

Premultiplied with Black 

The colour values of semi-transparent pixels in the image 
have been encoded so that the more transparent they are, the 
closer to black they are. When an image that is premultiplied 
with black is loaded in a software that does not support 
transparency, it appears blended with a black background. 
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Select this to make Harmony reverse this premultiplication so 
that the image blends properly with other visual elements in 
your scene.

Straight 

The colour of semi-transparent pixels in the image is encoded 
independently from their transparency. When an image that is 
not premultiplied is loaded in a software that does not 
support transparency, semi-transparent pixels simply appear 
fully opaque, making its edges appear pixelated. 

 7. Click OK.
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Vectorizing Images on Import
You can import bitmap images as vector drawings, which allows you to edit them using Harmony's vector 
drawing tools. This is especially useful to convert bitmap line art scanned or created in a different software into 
vector line art so it can be painted in Harmony. 

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.
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 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
your computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 3. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

 4. In the Vectorization section, decide whether you want to import your image in black and white or in 
greyscale. You can also click the New Preset  button to create a custom vectorization parameter 
preset.

 l Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. The outlines of your drawings will be painted with the Vectorized Line colour 
swatch of your scene's colour palette.

 l Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines 
keep the texture from the scan, and the white of the paper becomes transparent.
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NOTE 

You can double-click on any of the presets at any time to open the Vectorization Parameters 
dialog box to customize your option. 

 5. Click OK.

Your vectorized images will appear in their selected destination.
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Linking Layers to External Images
When working on a large production, you may want to centralize the backgrounds in one directory instead of 
duplicating the background several times in different scenes. As backgrounds are generally reused in many 
scenes, some studios like to save space on the server and link the different scenes to the background directory. 
Also, if they modify one background, it is modified everywhere at the same time without having to reimport it. 
To do so, you must use the Timing columns.

Timing columns are exposure sheet columns that link to files that are outside the scene’s structure. Because of 
these external links, care must be taken not to break the links by moving the scene’s location or the 
background directory’s location. Breaking a link will result in images not appearing in your scene.

NOTE 

Refer to the  Timing chapter in the Traditional Animation, Paperless Animation or Cut-out 
Animation Guide to learn more about using Timing columns.

If you are working with Toon Boom Harmony Premium Server and all your scenes are located on a centralized 
server, you can also use the Link to Images option.

How to link a layer to an external image

 1. From the top menu, select File > Import > Link to Images.

The Link to Images dialog box opens.

 2. Click the Browse button to select the image you want to link your scene to.
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 3. Do one of the following:

 l Select the Create Timing Layer option to create a new Timing column in the Xsheet 
view. Then select one of the following:

 l Create Single Timing Named: Type the new column name in the text 
field.

 l Create Timing(s) Based on Filenames: Creates file names based on the 
selected file's name.

 l Select the Add to Existing Timing Layer option to insert the file into an existing 
Timing column.

 4. Select the Copy to Timings Directory option if you want to copy the selected file into the Timings 
folder located in the scene directory. Note that the Timing column will link to the Timings folder.

 5. Click OK.
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About Importing a Multi-Layer PSD
It is possible to import Photoshop Document (.psd) images into Harmony. This allows you to create 
backgrounds, characters and other assets in Adobe Photoshop with multiple layers and effects, then import 
them in Harmony once you're finished editing them. 

When importing a Photoshop Document (.psd) file, you have a choice of how to import the multiple layers into 
your Harmony scene:

 l Single Layer: Imports the rasterized, flattened version of the PSD into a single layer in your scene.

 l Groups as Layers: This imports every group in the PSD file as a single layer in your Harmony scene. 
Then, every layer inside a given group is imported as a single drawing inside the layer in the Harmony 
scene.

This can be useful if you want to create characters or props in Photoshop and import them in Harmony. 
You can create all the drawings for each layer in Photoshop and import them into Harmony in a single 
step.

 l Individual Layers: This imports each group in the PSD file as a group in Harmony, and each layer in the 
PSD file as a single layer in Harmony, reproducing the structure of your PSD file into your Harmony 
scene. 
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If any layer or group in your scene has a specific blending mode, this layer or group will be attached to a 
blending node. The blending node will have the same blending mode as the corresponding layer or 
group in Photoshop—provided that its blending mode is supported by Harmony—so as to reproduce 
the image in your PSD file as faithfully as possible. 
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Importing Multi-layer PSD Files
T-HFND-007-003

You can import a multi-layer PSD file into Harmony using the Import Images dialog. When you attempt to 
import a PSD into a Harmony scene, you will be prompted to choose whether to import your PSD as a single 
layer or as multiple layers. 

NOTE 

Your .psd image file must be set to RGB mode within Adobe Photoshop prior to being imported 
into Harmony.

How to import a multi-layer PSD file

 1. In Adobe Photoshop, organize your layers and groups so that they are imported as expected in 
Harmony—see About Importing a Multi-Layer PSD.

 2. In Harmony, do one of the following:

 l In the top menu, select File > Import > Images 

 l In the Files toolbar, click on the  Import Images  button.

The Import Images dialog box opens.
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 3. In the Files section, click Browse to find and select the .psd image on your computer.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 5. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

 6. In the Import Options section, select the following option to import your image as its original format.

1155



 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for 
your project), an image that you import may get scaled to the point where all its 
individual pixels become visible.

 7. Decide whether to select Vectorize Imported Items option.

 8. Click OK.

The Multilayer Image Import Settings dialog box opens.

 9. In the Create drop-down, select one of the following:

 l Single Layer: Imports the rasterized, flattened version of the PSD into a single layer in your 
scene.

 l Groups as Layers: This imports every group in the PSD file as a single layer in your Harmony 
scene. Then, every layer inside a given group is imported as a single drawing inside the layer 
in the Harmony scene.

 l Individual Layers: This imports each group in the PSD file as a group in Harmony, and each 
layer in the PSD file as a single layer in Harmony, reproducing the structure of your PSD file 
into your Harmony scene. 

1156

Harmony 21 Premium User Guide                          



Chapter 11: Importing & Scanning

If any group or layer has a special blending mode, a blending node will be added to that 
layer or group with the same blending mode.

 10. If your image has transparency, in the Transparency section, select how the colour values in the 
semi-transparent pixels in the image were premultiplied with their alpha values. This allows 
Harmony to demultiply the values so that it can properly blend the image with the other elements 
in your scene. 

You can choose between the following options:

 l Premultiplied with Black: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to black they are. When an 
image that is premultiplied with black is loaded in a software that does not support 
transparency, it appears blended with a black background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements 
in your scene.

 l Premultiplied with White: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to white they are. When an 
image that is premultiplied with white is loaded in a software that does not support 
transparency, it appears blended with a white background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements 
in your scene.

 l Straight: The colour of semi-transparent pixels in the image is encoded independently from 
their transparency. When an image that is not premultiplied is loaded in a software that 
does not support transparency, semi-transparent pixels simply appear fully opaque, making 
its edges appear pixelated. 

 l Clamp Colour to Alpha: This is the same as Premultiplied with Black, except that it also 
prevents the colour values for a given pixel from being higher than that pixel's alpha value. 
This option is only useful if you are working with images that are supposed to be 
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premultiplied with black, but where the colour values of pixels have been increased without 
their alpha values being adjusted accordingly. 

TIP 

Typically, the composite image of a PSD file, which is imported when importing a PSD 
as a single layer, is Premultiplied with White, whereas the individual layers of a PSD 
file use Straight transparency. 

 11. Click OK.

The imported PSD file is imported into your scene. In the Timeline view, one or several layers are 
added to your scene, depending on the import options your selected.

NOTE 

If you import the PSD file with the Groups as Layers or the Individual Layers 
option, all of the layers and drawings imported into your scene will be linked to 
the same PSD file in your scene folder. Hence, deleting any of the drawings or 
layers imported from the PSD file is liable to delete all of the drawings imported 
from the PSD file.
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About Importing Vector Files
T-HFND-007-005

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony Premium to convert your files to 
the Toon Boom format (TVG) and create a colour palette based on the colour settings of the original file. 

When importing AI and PDF files:

 l RGB is supported, CMYK is not.

 l Gradients and textures are not supported.

 l Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and 
Actionscript 3, cannot be imported.

 l When importing an Illustrator or PDF file in Toon Boom Harmony Premium, by default the file will be 
imported as separate layers. The import will use the Illustrator file's top level groups as separate layer 
names. However, you can change this behaviour by deselecting the PDF/Illustrator Import as Separate 
Layers option, to import your file as a single layer .

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or 
multiplaning, it can easily be imported into Harmony. 

The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.
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Importing Adobe Illustrator (.ai) files and Portable Document Files 
(.pdf)

T-HFND-007-006

You can import vector Adobe Illustrator (.ai) files as well as Portable Document Files (.pdf) through the 
Library view and File menu. Make sure to have the rights to modify your Library folder and that the colours in 
your file are encoded in RGB. 

How to import an .ai or .pdf file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type in a name for the new template or keep the name of the original AI or PDF file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.
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The message window opens.

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option if you plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under 
the imported file’s name.

1161



Importing Flash Movies (.swf)
You can import Flash (.swf) files in Harmony exported for any version of Flash Player up to version 14.

IMPORTANT 

Some effects are not supported when imported from Flash movies into Harmony. 

How to import a SWF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your.swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type a name for the new template or keep the name of the original *.swf file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.

1162

Harmony 21 Premium User Guide                          



Chapter 11: Importing & Scanning

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option. This might be useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created 
under the imported file’s name.

NOTE 

All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO 
NOT DELETE THIS PEG. To maintain the look of your movie, it's important not to delete this 
peg or detach its child layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash 
become regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within 
symbols or drawings within symbols collapse into their corresponding parent symbol.
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NOTE 

Some layers in your .swf movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate 
layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony Premium 
file are grouped together in one folder. In our example, this means that when you scroll through the 
Drawing Substitution preview in the Library view, the different hand, leg, tentacles, antennae, 
torso and facial positions are all organized together.
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Distributing SWFs to Layers

In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers 
might be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers 
again. 

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the drawing that contains elements you want to redistribute onto 
individual layers.  To select the all the elements of the selected drawing layer, press Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

 3. Do one of the following:

 l From the top menu, select Drawing > Distribute to Layers.

 l In the Tool Properties view of the Select tool, click the Distribute to Layers  button.

The number of drawing layers corresponding to the different grouped elements are created in the 
Timeline view. The selected elements in the original drawing layer are removed. Each element is 
distributed onto a new drawing layer.

 4. Repeat the process for each drawing that contains elements to redistribute.
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About FLA  Import
You can export files from Flash and import them in Harmony to  transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and macOS. It is not possible to do so on 
GNU/Linux versions.

On the Flash side, users can work with these versions:

 l Adobe Flash CS5

 l Adobe Flash CS5.5

 l Adobe Flash CS6

 l Adobe Flash CC

 l Adobe Flash CC 2014

 l Adobe Flash CC 2015

NOTE 

Exports from older versions of Flash are not possible.

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape 
lines, drawing objects, groups and bitmaps at the scene level won’t be exported. If these elements are present, 
you will be prompted to perform a clean up of the scene level. For details on importing Flash files, see Flash 
Export and Import Guidelines on page 1184.

As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe 
Extension Manager—see Installing the Export to Harmony Option on page 1168.

It is important to use the correct version of Adobe Extension Manager: 

 l If more than one version of Flash is installed on your computer, be careful where you install the 
extension. If it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in 
this version and not the other.
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 l If you have a previous version of the  extension, you must remove it first and install the latest extension—
see About FLA  Import on page 1166.

Harmony includes a script specially created to import FLA Export packages. You must add this script to your 
interface in order to use it—see Displaying the Import Flash Scene Icon on page 1179.

When you export your FLA files, a folder will be created that contains the stage.tpl and export.json 
files, as well as all the .swf and.txt  files in your scene. The export.json file is used by a Harmony script 
to organize and construct the node system from your exported files.

Once the Flash project is successfully imported into Harmony, here's how the node system was constructed:

 l Each symbol has its own peg in which all the transformation information is stored.

 l Whenever there are more than three symbols nested inside a symbol, a Composite node is 
automatically created to group them all.

 l The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came 
from the rotation point of the symbol in Flash.

 l Registration point of the symbol in Flash represents the centre of the drawing space in Harmony. 
Therefore, the position of the drawing inside a symbol will be exactly the same in Stage.

 l The imported node system is connected to the Composite of the scene, which contains the Write and 
Display nodes.

 l One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you 
have more than one zone using the same colour, they will be linked to the same colour swatch.

 l If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects. 
Harmony is now able to understand when more than one symbol share the same mask in Flash. Each 
symbol sharing the same mask will be grouped by a composite and connected to the cutter.
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Installing the Export to Harmony Option

The extension is required in order for Flash to export files to Harmony. The extension is called Export to 
Harmony.zxp and is located here: 

OS Edition Location

Windows

Premium
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Premium [version] Premium\resources\flash

Advanced
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Premium [version] Advanced\resources\flash

Essentials
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Premium [version] Essentials\resources\flash

macOS

Premium
Applications > Toon Boom Harmony Premium [version] 
Premium > tba > resources > flash

Advanced
Applications > Toon Boom Harmony Premium [version] 
Advanced > tba > resources > flash

Essentials
Applications > Toon Boom Harmony Premium [version]  
Essentials > tba > resources > flash

NOTE 

Before installing the extension, you must remove all Harmony offline and database preferences.

How to install the Export to Harmony extension

 1. Launch Adobe Extension Manager.

 2. In the top-right corner of the Adobe Extension Manager, click on Install.

An Open dialog appears.

 3. In the Open dialog, browse to and select the Export to Harmony.zxp file, then click on Open.

A message opens informing you that you're about to install the Export to Harmony extension.

 4. Click on Accept.

You may see the following message confirming that you want to install the extension. Click Install.
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 5. In order for the changes to take effect, you must close and restart Adobe Flash.

 6. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

 1. If open, close Adobe Flash.

 2. Start Adobe Extension Manager.

 3. From the Products list, select Adobe Flash. 

If you have a previous version of the Export to Harmony.zxp extension installed, it will be 
listed in the right pane.

 4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.

 5. Click Yes.

Adobe has stopped  maintaining and updating their Extension Manager CC, therefore, it has become difficult to 
install extensions. In order to link an extension from Animate CC, follow the steps below. 
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How to install an extension on Windows with Adobe Animate CC version 2015 and 
higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdWin

 3. Unzip the ExManCmd_win.zip package.

 4. Put the ExManCmd_win folder in a safe place.

NOTE 

The ExManCmd_win folder must not be deleted; this folder is necessary for 
installing or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads 
folder:

C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 21 
Premium\resources\flash\flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. In the ExManCmd_win folder, hold Shift and right-click to select Open command window here.

 10. Enter the following command: 

ExManCmd.exe /install <filename.zxp>.

 11. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by 
the Extension Manager CC.
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 12. Open Animate CC.

 13. Access Top Menu > Commands.

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.

 

NOTE 

If you have a region language  other than English (US) installed on your 
computer, or if you have more than one language installed on your computer, 
Animate CC may not be able detect in which language folder the extension has 
been installed. If this occurs, you will not be able to see the Export to Harmony 
menu option in Top Menu > Commands list. To correct this, proceed to How to 
ensure Adobe detects extension files installed on your computer on page 1171.

How to ensure Adobe detects extension files installed on your computer

 1. Browse to:

C:\Users\<UserName>\AppData\Local\Adobe\Animate <VersionNumber>

If Adobe detects more than one language on your computer, you will see multiple language folders 
in the path. For example:
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 2. Look inside each folder to detect the main language used by Adobe on your computer. To do so, 
compare the contents of both folders.

For example, inside the en_Ca\Configuration:

For example, inside the en_US\Configuration:
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The main folder is the one with more files. In this case, Adobe is using English (US) as the main 
language. The folder en_CA only contains what was installed with the extension installation: 
commands, Javascript and WindowSWF.

 3. Copy and paste the contents of the commands folder within the sub-language folder, to the 
commands folder within the main language folder .
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 4. Copy and paste the contents of the Javascript folder within the sub-language folder, to the 
Javascript folder within the main language folder.

 5. Copy and paste the contents of the WindowSWF folder within the sub-language folder, to the 
WindowSWF folder within the main language folder.
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How to install an extension on macOS with Adobe Animate CC version 2015 and 
higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdMac

 3. Unzip the ExManCmd_mac file.

 4. Put the ExManCmd_mac folder in a safe place.

NOTE 

The ExManCmd_mac folder must not be deleted; this folder is necessary for 
installing or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads 
folder:

/Applications/Toon Boom Harmony 21 Premium/Harmony 
Premium.app/Contents/tba/resources/flash/flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. Drag and drop the .zxp file directly into the ExManCmd_mac folder.

 10. In Terminal, go to the folder where the ExManCmd_mac package was extracted.

For example, if you have put the ExManCmd_mac folder into the Downloads folder:

cd Dowonloads/ExManCmd_mac/

 11. Enter the following command:

Contents/MacOS/ExManCmd --install <filename.zxp>

 12. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by 
the Extension Manager CC.
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 13. Open Animate CC.

 14. Access Top Menu > Commands. 

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.
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Exporting FLA Files

How to export FLA files for Harmony from Adobe Flash

 1. Open your.fla file in Adobe Flash. 

NOTE 

In case of a new file, it needs to be saved before continuing the exportation process. If not, the 
export won't be completed.

 2. Return to the scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

 3. Do one of the following:

 l Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony. 

 l Adobe Flash CC: Window > Extensions > Export to Harmony.

NOTE 

This window must be opened once after installing the extension in the extension manager 
because it creates a drect link to Harmony (even if the window is not used). Afterwards, you do 
not have to reopen it if there is no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will 
appear in Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution 
value of Harmony. If needed, you can change the compression: Photo (JPG) or Lossless (PNG).

 4. Do one of the following:

 l In the Export to Harmony window, click Export button. 

 l Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:
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Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all 
groups to verify if any symbols are hidden inside, breaking drawing objects to transfer them as 
shapes, drawing substitutions, and so on. Problematic situations will also be mentioned. If nothing 
appears in the Output tab, then your.fla file is clean and does not need any conversions.

The .txt files contain the drawing substitution information and at which frame they are exposed. 
A .swf file is created for each symbol in Flash and a .tpl file is created of them. The corresponding 
export.json file is also created, which you will need when importing your Flash scene in Harmony. 
These files are in a folder located at the same location as the.fla file.  The folder name is the same 
as the .fla file.

NOTE 

If  a folder with the same name as the .fla file already exists, you will be prompted to replace 
the folder. Be aware that saving Flash projects as .xfl files will automatically create a folder 
with the same name as the .fla file. In this case, the folder of the export will be created inside 
the folder of the xfl. If this not what you want, place a copy of the.fla in another path on 
your computer before the export.
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Displaying the Import Flash Scene Icon

When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash 
Scene icon. If the icon does not appear in the Scripting toolbar, add it to the toolbar. Note that you will only 
have to do this once. After that, you can import Flash files whenever needed.

How to display the Flash Import script icon

 1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony 
interface.

 2. Click the Manage Scripts  button.

The Scripts Manager opens.

 3. From the Files section, select TB_Import_Flash_Scene.js. 

On your computer, here is the location of the script file:

 l Windows:
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 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Harmony Premium\1400-scripts

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Advanced\1400-scripts

 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Essentials\1400-scripts

 l macOS: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/1400-scripts

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Advanced/1400-scripts

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Essentials/1400-scripts

On macOS, the Library folder is a hidden folder. To display the display the folder, told down the Alt 
key.

 l Global: [Server_Name] > USA_DB > scripts

 l Environment: [Server_Name] > USA_DB > environments > [environment_name]

 l Job: [Server_Name] > USA_DB > jobs > [job name]

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-scripts

 5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to 
the In Toolbar section.
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 6. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash 
scenes.
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Importing FLA Files

Once your extension is installed, your FLA file has been exported and your displayed the FLA import script in 
your toolbar, you are ready to import your FLA file in Harmony.

How to import FLA files

 1. In the Scripting toolbar, click the Import Flash  button.

 2. In the Import Files dialog box, locate the export.json file contained in the folder that was created 
when you exported your files from Flash.

 3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery. 

 4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session 
option. 

In a few moments, the .fla files are imported in Harmony. 
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 5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.
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Flash Export and Import Guidelines
The following points are guidelines for you to create optimal Flash files to export to or import in Harmony.

The following are limitations that apply when importing .swf files, whether they were exported specifically 
for Harmony or just regular Flash Movie files. 

Drawing Features

 l The line width will be preserved, whether it's constant or varied with the Width tool. 

 l Any line caps and line joins other than round will be converted to round line caps and line joins

 l The flow of gradients must be set to Extend Color, which is the default flow for gradients. Gradients 
with a Reflect or Repeat flow will cause the entire symbol in which they're located to be ignored. 

Effects

The following effects will not be imported by Harmony:

 l Filters (ie: Adjust Colour, Drop Shadow, Bevel, etc.)

 l Colour Effects (ie: Alpha, Advanced, Brightness and Tint)

 l Blending (ie: Layer, Darken, Multiply, etc.)

 l Render: Cache as Bitmap (Export as Bitmap is supported)

 l 3D Rotations

 l Component properties

Bitmap Images

Bitmap images must be either .jpg or .png format. Symbols that have their Render mode set to Cache as 
Bitmap will also be imported.

Flash Export Guidelines

The following are rules to follow when exporting assets from Flash for import in Harmony. 

Scene Root

What can be at the scene root:

 l Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:

 l Shapes: Colour shapes and line shapes

 l Bitmaps

 l Drawing objects
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 l Groups: The group works differently at the scene level. They are understood as shapes at the scene 
level—see Flash Export and Import Guidelines on page 1184.

Timeline

These features can be used in the Flash file, but will not appear when imported in Harmony.

 l Guide layers for references

 l Locked layers

 l Disabled layers

 l Folders in the Timeline view

 l Other: Several symbols on the same layer/keyframe. Harmony will spread them over several drawing 
layers, implicitly performing a Distribute to Layers operation in the process.

Not recommended:

 l Mixed layers—see Flash Export and Import Guidelines on page 1184

 l Symbols, shapes, bitmaps and groups in the same layer/keyframe

 l Symbols with drawing objects

Library View

In the Library view, the following will not be exported:

 l ActionScript Linkage

 l Embedded fonts

Mixed Layers

Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony. 
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers 
altogether.

A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be 
a mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony 
understands symbols better than groups or drawing elements, some information can be lost along the way.

Parameter Description

Drawing Objects
No matter what is inside a drawing object, it will always be understood as a 
shape. So if a drawing object shares the same layer with a shape, it won’t be a 
real mixed layer, since they are all understood as shapes.

Groups that Contain Only When there is a symbol inside a group, the group will be ungrouped 
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Symbols (MovieClip or 
graphic)

automatically during the export from Flash. The symbol inside it will be 
understood by Harmony as a Drawing node.

But if there is more than one symbol inside the group, all the symbols will be 
understand as if they were only one symbol. For example, if you have a group 
containing five MovieClips and one graphic, Harmony will create one Drawing 
node to  contain the five MovieClips and one graphic. This can be useful when 
you want to create a repetitive texture and you don’t want to have each repetition 
separated in Harmony. There is no differentiation between symbols.

Groups that Contain 
Symbols and Shapes

When there is one or more symbols with shapes inside the same group, the 
group will be ungrouped automatically during the export from Flash, but all the 
symbols and shapes will be exported as if they were one symbol. There is no 
differentiation between symbols and shapes.

Symbols and Groups on the 
Same Layer 

If there are symbols and groups sharing the same layer, each symbol will be 
separated from all the groups which will then be grouped together as one 
element. In Harmony, each symbol will have its own Drawing node, but all 
groups share one Drawing node. Since only symbols can have a name, its name 
is propagated to the Drawing node and peg. 

Groups, however, will receive the name of the MovieClip followed by an 
underscore and an appropriate number. For example, of you have a group inside a 
symbol called HEAD, the group will receive the name HEAD_1 if there is already 
a Drawing node that was created with the same name.

Symbols and Drawing 
Objects/Shapes on the Same 
Layer

If there are symbols and drawing objects/shapes sharing the same layer, the 
symbols will be separated from them and all the drawing objects/shapes will be 
kept together. Drawing objects and shapes cannot be separated. In Harmony, the 
symbols will have their own Drawing node and the drawing objects/shapes will 
share the same Drawing node. Since only symbols can have a name, its name is 
propagated to the Drawing node and peg.

Drawing objects and shapes, however, can't do this. Drawing objects and shapes 
will receive the name of the MovieClip followed by an underscore and an 
appropriate number. For example, if you have a group inside a symbol called 
HEAD, the group will be named HEAD_1 if there is already a Drawing node that 
was created with the same name.

Groups and Drawing 
Objects or Shapes on the 
Same Layer

In order to have groups and drawing objects/shapes on the same layer, these 
elements must first be inside a symbol. Groups and drawing objects/shapes 
sharing the same layer in Flash will be exported as one Drawing node. This 
Drawing node will contain both drawing objects and shapes, and receive the 
name of the symbol in which they are contained.

Mixed Instances at the 
Same Level as a Symbol

Mixed instances at the same level as a symbol can occur when, at the same level 
inside a symbol, there is more than one type of element sharing the same timeline 
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at a specific frame. Those elements may be mixed layers.

Type of problems that can occur if mixed instances are kept:

 l Order of appearance can be lost

 l Some layers can merge together

 l Transparency of shapes can cut other shapes
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Importing QuickTime Movies
T-ANIMPA-004-002

When creating an animation, it is not unusual to embed moving elements saved as videos within the 
animation. Toon Boom Harmony Premium allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

 1. From the top menu, select File > Import > Movie.

 2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE 

Do not browse for the movie file again. Leave the automatically generated field text as “many 
files selected”.

 3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see the 
Reference guide .

 4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through 
the film frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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About Scanning
Harmony can receive images from any TWAIN device, such as  scanners or digital cameras. You can load these 
images as bitmaps into your scene or convert them into vector-based images that can be edited using 
Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of 
your device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the 
digital exposure sheet.

Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import 
them in Harmony. The scanning process is the point where the traditional production becomes digital. It's the 
moment where you use Harmony to control the project.
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Scanning Images 
Toon Boom Harmony Premium can receive images from any TWAIN device such as scanners and digital 
cameras. These images can either be loaded into your scene as bitmaps or converted into vector- based images 
that can be edited using Toon Boom Harmony Premium.

If your operating system does not automatically recognize your device after it has been connected, you must 
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the 
device manufacturer’s website.

How to scan images

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens. 

 2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the 
Scanner menu. If none are available, check your device to ensure that it's properly connected to 
your computer. If your device still does not appear in the menu, you may have to shut down and 
restart the software.
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 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer—see the Reference guide .

 4. In the Import Options section, select the type of image you want to create—see the Reference guide
 .

 5. In the Alignment section, decide on the size and placement of your scanned image within the 
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for 
your project), an image that you scan may be scaled to the point where all its individual pixels 
become visible—see the Reference guide .

 6. In the Drawing Options section, set the following options if desired:

 l Drawing Name: Name of the drawing to import.

 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click Scan.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

 8. Click Scan to scan your drawing.

 9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

 10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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Vectorizing Scanned Drawings
You can turn scanned images into vector drawings, while maintaining the sketchiness of a pencil line or into 
vector images with a bitmap fill. Both options can add life to an animation, which straight vectorization with 
smoothing does not usually afford.

How to scan and vectorize drawings

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

 2. Select your scanner from the Scanner list.
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 3. Click Preview to get a test scan of your drawing.

 4. In the Layer section, select one of the following:

 l Create Layer: Imports an image into a new layer. Type a name for the layer in the 
Name field. 

 l Add to Existing Layer: Imports the image into an existing layer. Select a layer from 
the Layer list.

 5. In the Import Options section, select the Convert to Vector Drawing option.

 6. In the Vectorization section,  set the following:

 l Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-
based drawing. Set the Threshold and Smooth parameters.

 l Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. 
Lines keep the texture from the scan, and the white of the paper becomes 
transparent.

 l New Preset: Lets you create a new preset.

 l Delete Preset: Lets you delete any preset in the list.

 l Custom vectorization: Lets you set custom vectorization parameters—see About 
Custom Vectorization Parameters  on page 1195.

 7. In the Drawing Options section, set the following options if desired:
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 l Drawing Name: Name of the drawing to import.

 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click Scan.

 l Overwrite: Lets you overwrite existing drawings—see Vectorizing Scanned Drawings 
on page 1192.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 8. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the 
view.

 9. Click Scan to import your drawing.

 10. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

 11. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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About Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center 
modules when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green 
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure 
red, blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting 
in your tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker 
window and watch the indicator colour zone lines disappear.
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Creating Vectorization Styles 

With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to 
set the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

 l Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

 l Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained 
inside a vector frame. The white areas become completely transparent.

 l Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and 
turn them into 100% vector lines, preserving their original colours—see the Reference guide .

How to create or modify the vectorization parameters

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

 l In the Layer section, decide on the layer options.

 l In the Import Options section, select the Convert to Toon Boom Vector Drawing option

 l Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

 4. The Vectorization Parameters dialog box opens.

 5. Set the different options available in the Vectorization Parameters dialog box—see the Reference 
guide .

1196

Harmony 21 Premium User Guide                          



Chapter 11: Importing & Scanning

 6. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Parameters dialog box. 
These are applied during the vectorization process.

 7. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the dialog box.

 8. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan 
module vectorization style list, click  Save.

 9. In the Browser window, name and save the file.

 10. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

 11. To load a vectorization style, click Load and locate the existing *.vof file.

 12. Click OK.
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Configuring the VectOptions.conf File

Toon Boom Harmony Premium Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you will 
certainly want to create your own to fit your production style.

How to set the VectOptions.conf file 

 1. Launch Configuration Editor:

 l Windows: Open the Start menu and, in the Programs list, select  Toon BoomHarmony 21 
Premium > Tools >  Configuration Editor.

 l macOS: In Finder, go to Applications > Toon Boom Harmony 21 Premium > Tools >  
Configuration Editor.

 l GNU/Linux: In a terminal, type the following command:

$ sudo /usr/local/ToonBoomAnimation/harmonyPremium_21/lnx86_
64/bin/ConfigEditor

The Configuration Editor window opens.

 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
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Vectorization Parameters window and copy the result parameters in this file—see About Custom 
Vectorization Parameters  on page 1195

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new 
ones to the list using the parameters you got using the Vectorization Parameters window. Notice 
that some of the lines have a “#” sign at the beginning to indicate that the line is a comment and 
will not appear in the style list. The lines that have no sign at the beginning appear in the style list.

 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

 6. Under the style name line, type the following: 

options:

 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.
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 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Premium Scan on your computer, you can start the application and 
verify that the new style appears in the Vectorization Style list under Edit > Vectorization Style.  

NOTE 

If you are using the batch processing method available with Toon Boom Harmony Premium 
Server to scan and vectorize drawings, the selected style must be available on all the 
machines included in the batch processing list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch 
processing.
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Overwriting Using Scanned Drawings
At times, it might be more efficient to create a scene and fill in the exposure sheet before scanning. Then you 
can simply scan your drawings to fill in the necessary cells in the exposure sheet. Note that when you start 
scanning, the drawings are named sequentially regardless of whether there is an exposure or not in the 
Xsheet.

How to overwrite existing drawings

 1. In the Xsheet, select the first cell to overwrite.

 2. From the top menu, select File > Import > From Scanner.

 3. In the Scan Drawings window, do the following:

 l Scanner: Select your scanner from the list.

 l Layer: Select the Add to Existing Layer option.

 l Import Options: Select the Convert to Toon Boom Vector Drawing option.

 l Vectorization: Select an appropriate option: Black and White or Grey, or create a new 
preset.

 l Drawing Options: Select the Overwrite option.
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 4. Click Preview.

The scanner window opens. 

 5. Make any necessary adjustments to the image before scanning, then click Preview.

 6. In the Scan Drawings window, click Scan.

The scanned drawing replaces the selected cell in the Xsheet, filling the entire exposure. The 
Drawing Options section indicates the name of the cell the drawing overwrote and its exposure 
value.
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Importing PSD Layouts
T-LAY-006-002

If you exported a Photoshop layout image from a Harmony project using the Export Layout Image function, you 
can easily import it back into Harmony, simply be sure to import it at the beginning of the project for accurate 
scene planning.

NOTE 

For information on exporting layouts, see About PSD Layouts on page 661

How to import a layout

 1. In your Harmony project, select File > Import > Images.

The Import Images dialog box opens.

 2. In the Files section, click Browse to find and select the .psd or .psb layout file on your computer. 
Note that this layout file must have its corresponding .xli file in the same folder.
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 3. Once you have selected the layout file, the Use Position Information Contained in XLI File option 
appears in the Layer section. 

This option is enabled by default. When you import the layout image in your scene, it will be 
automatically positioned to fit the original layout scene creating an accurate layout guide. You can 
disable this option if you want the imported layout image to be imported according to the normal 
behaviour of the import process. The layout image will be incorrectly aligned as it was when it was 
first created.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 5. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

 6. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.
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 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 7. Select the Create Symbol for Imported Items option if you want the layers to be contained in 
symbols.

 8. In the Import Options section, select the following option to import your image as its original format.

 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
Depending on the Scene Settings (the height and width in pixels that you chose for 
your project), an image that you import may get scaled to the point where all its 
individual pixels become visible.

 9. Decide whether to select Vectorize Imported Items option.

 10. Click OK.

The Multilayer Image Import Settings dialog box opens.

 11. In the Create drop-down, select one of the following:

 l Single Layer: To import the Camera and Layout layers merged together.

 l Separated Layers: To keep your Camera and Layout layers separated.

NOTE 

Do not select the Individual Layers option when importing a PSD layout. Importing a 
PSD file as individual layers will ignore the position information in the XLI file, which 
was exported with your layout. 
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 12. If your image has transparency, in the Transparency section, select how the colour values in the 
semi-transparent pixels in the image were premultiplied with their alpha values. This allows 
Harmony to demultiply the values so that it can properly blend the image with the other elements 
in your scene. 

You can choose between the following options:

 l Premultiplied with Black: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to black they are. When an 
image that is premultiplied with black is loaded in a software that does not support 
transparency, it appears blended with a black background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements 
in your scene.

 l Premultiplied with White: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to white they are. When an 
image that is premultiplied with white is loaded in a software that does not support 
transparency, it appears blended with a white background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements 
in your scene.

 l Straight: The colour of semi-transparent pixels in the image is encoded independently from 
their transparency. When an image that is not premultiplied is loaded in a software that 
does not support transparency, semi-transparent pixels simply appear fully opaque, making 
its edges appear pixelated. 

 l Clamp Colour to Alpha: This is the same as Premultiplied with Black, except that it also 
prevents the colour values for a given pixel from being higher than that pixel's alpha value. 
This option is only useful if you are working with images that are supposed to be 
premultiplied with black, but where the colour values of pixels have been increased without 
their alpha values being adjusted accordingly. 

TIP 

Typically, the composite image of a PSD file, which is imported when importing a PSD 
as a single layer, is Premultiplied with White, whereas the individual layers of a PSD 
file use Straight transparency. 

 13. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the .psd layer group 
folders Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.
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Chapter 12: the Node View
The Node view is a visual representation of how every element in your scene, be it drawing layers, pegs, effects 
and others are combined together to form the final composited image. It allows you to rig the elements in your 
scene together and add a wide range of effects to your scene. Getting to know how to use the Node view is 
important especially for rigging cut-out models, adding effects to scene or managing the way your scene is 
composited, rendered and displayed in Harmony. 
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About Nodes
The node view is a visual representation of the logic in which the elements in your scene are rendered. Each 
element in the Node view is called a node. 

There are different types of nodes, each with a specific role:

Image Type of Node Description

Drawing

Reads the drawing files stored in your scene folder and displays them in the stage. 

NOTE 

Drawing nodes are actually part of a bigger category of nodes called 
Generators, which are nodes that generate an image. Other generators 
include the Colour-Card and the Gradient nodes. 

Transformation
Applies a geometric transformation (translation, scale, rotation, etc.) or other types 
of deformations onto a drawing. 

Effect
Takes an drawing or image as its input, and outputs the image with an effect 
applied over it. 

Composite
Combines multiple drawings or images by laying them on top of each other to 
make a single image. 

Camera Allows you to set the position of the camera relative to the stage. 

Write
When rendering the scene, this node takes the image that is sent to it and generates 
an image file for each frame in the scene. 
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Image Type of Node Description

TIP 

You can create several Write nodes connected to different parts of your 
scene, and generate multiple renders when rendering the scene.

Display

The Display node is what displays the image in the Camera view.

TIP 

You can create several Display nodes connected to different parts of your 
scene, and select which Display node to preview in the Camera view.

One of the first thing you'll notice when opening the Node View about it is that, for every layer or peg you add 
in the Timeline view, a node is present in the node view. 

A node representing one of the layers in the Timeline view is referred to as a Drawing or Element node. Its role 
is to display the drawing it contains.

As you can see, while layers in the Timeline view are ordered from bottom to top, in the Node view, Drawing 
nodes are ordered from right to left. This means that a node at the right of the Node View will appear 
underneath a node at its left. 

Beneath the drawing nodes are a Composite node. The Composite node is what takes the image from every 
Drawing node in your scene and bakes it into a single image. It is also what determines the orders in which the 
layers are rendered. For example, if you switch the order in which they connect to the Composite node, you 
also switch the order in which they are rendered. 

1209



Beneath the Composite node are two nodes:

 l The Write node is responsible for generating images when you render your scene's frames. 

 l The Display node is responsible for displaying your scene in the Camera view in Harmony. 

If you rig your layers under pegs, those pegs will also have a corresponding node in the node view. 

As you can see, when a layer is rigged under a peg, its Drawing node is rigged under its Peg node in the Node 
View. This is because in the Node View, information travels from top to bottom, all the way until it reaches a 
Write or Display node. 

Effect node act as filters for the image information sent by drawing nodes. This means that they take an image 
as their input, and output an image with the effect applied on it, like so:
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A Camera node acts independently from your scene's node system. It can be rigged under a peg, which allows 
you to animate the Camera by creating animations on this peg. Otherwise, it does not need to be rigged to 
anything to have an effect on the point of view from which your scene is rendered.
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About Node Connections and Ports 
T-HFND-010-005

Nodes interact with each other by being connected through their ports. Most nodes have at least one input 
port and one output port. A node's input ports are on top of the node and can only receive information. A 
node's output port are at the bottom of the node and can only transfer information. 

Port Names

Some nodes contain more than one input or output ports. To have a clue of what each port does, simply click on 
it to display the name of the port.

Port Colours

Each port has a colour which indicates the kind of information it is meant to send or receive:

 l A blue port means the port sends or receive image information. For example, a Drawing node's output 
port is blue because it outputs an image of its own drawing. A composite's input ports are all blue 
because a composite receives images and composes them together. 

 l A green port means the port sends or receive transformation information. For example, Peg, Quadmap 
and Deformation nodes all have a green output port, because they transform or deform anything 
connected underneath them. Drawing nodes have a green input port because they receive 
transformations from such pegs.

Connections between nodes are colour-coded in the same way. 

Some ports are flexible in the type of information they send. For example, you can connect a drawing node to 
another drawing node. When you do this, the cable that links the two nodes is green. This is because the top 
drawing node's image information is ignored and, instead, the transformations made on this drawing node are 
applied to the drawing underneath it. In this way, the drawing is acting as a peg.
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Some nodes, including Drawing nodes as well as several effect nodes, have what is referred to as a Matte port. 
A Matte port is used to determine the area to which an effect is applied. 

Matte Connections

For some layers, this Matte port is hidden until you attempt to connect an image port to the left extremity of 
the node. These layers do not require a Matte drawing to work, but can use one if needed. 

Other nodes, mostly effects, require a Matte drawing to work. These nodes always have a Matte port visible. 

Nodes that have a matte port can be connected to a drawing, which is then referred to as the matte drawing. 
These nodes use the shape of the matte drawing to determine which area of the image they affect. For 
example, a Tone node will only apply a tone on the drawing they are connected to in the area where that 
drawing and the matte drawing mesh. 
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When an image port is connected to a matte port, its connection is blue, like other image connections, but it is 
dashed to indicate that it is specifically a matte connection.

Output Z Port

All of the input ports of a Composite node are for laying different drawings or images together into a single 
image. However, you might notice that the leftmost input port of a Composite node is a lighter shade of blue. 
This is because this port is used to determine the position of the composited image on the z-Axis. Because each 
drawing layer has its own position on the z-Axis (which is 0 by default, unless you explicitly move them on the 
z-Axis), and the Composite node is supposed to make a single flat image out of several drawing layers, it can 
only have one position on the z-Axis. Hence, by default, it uses the drawing that is connected to its leftmost 
port, that is, the topmost drawing, as a reference for the position of the image it outputs on the z-Axis.

Pass Through Cables

Composites have several modes, one of which is named Pass Through. A Pass Through composite essentially 
passes all of the information it receives as is as its output. Hence, its output contains several layers of vector 
artwork. You can easily tell when a Composite's output contains several layers because its output connection 
will be a wide cable.
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About Multiple Connections in the Node View
The way nodes are connected together can have as important an impact on the way your elements are 
rendered as the nodes themselves. 

It is possible to connect a node's output port to several nodes making this node have the same effect on 
multiple part of this scene. For example, you can have a single Peg node control several Drawing nodes by 
connecting it to each drawing node you want it to control.

You can also connect a single Drawing node several time to a composite. This can be useful if you want a 
drawing to appear both as modified by an effect and in its original form in your scene, like in this example.

Since information in the Node View travels from top to bottom, it is not possible to make the output port of 
several nodes connect to a single input port of a single node, as that would mean merging together images 
and transformations in a way that is not defined. For example, you need to use a Composite node to combine 
different drawings together because the Composite nodes determines the order in which the drawings are 
layered. 

However, it is possible to combine the transformations of Peg nodes and other similar nodes together by 
stacking them.
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Likewise, you can combine several effects by stacking them. The order in which the effects are stacked 
determines the order in which they are applied to the image.
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Adding Nodes
T-ANIMPA-012-002

All the nodes available in Harmony can be added to your node system from the Node Library view, by using 
the Quick Insert menu or by using the Node View’s Insert sub-menu. 

How to add nodes from the Node Library

 1. In the Node Library, do either of the following to find the node you want to add:

 l In the Search bar, type in the name of the node you want to add.

 l In the list of categories to the left of the Node Library view, select the category to which the 
node you want to add belongs. 
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 2. Do one of the following to add the node to the Node View:

 l Click and drag on the node in the Node Library view, and drop it in the Node view.

 l Select the node in the Node Library view, then press Enter/Return.

How to add nodes using the Quick Insert menu

 1. Do one of the following:

 l If you want to add an unconnected node and connect it manually, click anywhere inside the 
node view.

 l If you want to add a node and automatically connect it to other nodes, click on the node the 
new node should be connected to. For example: 

 l To add an Element node under an existing Peg node, select that Peg node.

 l To add a peg node on top of an Element node, or an effect under an Element node, 
select that Element node.

 l To add an Element node to a specific Composite node, select that Composite node.
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 2. Navigate to the group in which you want to add a node.

 3. Press Enter.

The Quick Insert menu appears.

 4. Do one of the following to find the node you want to add:

 l Scroll down until you find the node you want to add.

 l Start typing the name of the node you want to add to filter the list of nodes until you see the 
node you want to add in the list.

 5. Do one of the following:
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 l Click on the node you want to add in the list.

 l Use the Up Arrowand Down Arrow keys to select the node in the list, then press 
Enter/Return.

 l Type up the entire name of the node you want to add so that it is the only node in the list, 
then press Enter/Return.

The selected node is added to the Node View, and is automatically connected to the node you had 
previously selected.

NOTE 

The last five nodes you added using the Quick Insert menu are listed at the top of the list. This 
history is preserved until you close your scene.

How to add nodes using the Insert sub-menu

 1. Do one of the following:

 l In the Node View, right-click and, in the context menu, select Insert

 l In the top-left corner of the Node View, open the  View Menu and select Insert.

A menu listing all the node categories will appear.
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 2. Select the node category to which the node you want to add belongs.

A menu listing all the nodes in this category will appear.

 3. Select the node you want to add.

The selected node is added to the Node View. 
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Search Filter in Node Library View
You can clear the search filter in the node library using the escape key or an X button, in the same manner as in 
the toolbar manager.

How to search  in Node Library View

 1. In the Search bar, type in the name of the node you want to search.

 l It will match and display the results in the Node Library.

 l For example: To add "Deformation Composite", you can type "def comp" and the result will display 
as "Deformation Composite".

You can also search for the node descriptions by clicking Search Node Descriptions.

NOTE 

If you type a word with the space at the end such as "def ", it will not list anything as the Node 
Library tries to match whole words.

How to clear search filter in Node Library View

 1. In the Search bar, type in the name of the node you want to search.

 2. X appears on the right side in search bar to clear the field.

When the search filter is empty, a magnifying glass should be displayed on the right side of the field.
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Connecting Nodes
There are several ways to connect nodes. You can create new connections from one node to another, you can 
insert a node onto an existing connection so that this node becomes an intermediary between two nodes, and 
you can instantly connect several nodes to the same nodes using a keyboard shortcut.

How to create a new connection from one node to another.

 1. In the Node view, identify which node should be at the top of the connection and which one should 
be at the bottom, and position them accordingly. 

 2. Do one of the following:

 l With the mouse, click and drag from the top node's bottom port. A cable will be drawn from 
the port to your mouse cursor. Drag it to the bottom node's top port and the cable will snap 
against it. Release the mouse button to create the connection.

 l Click on one of the ports you want to connect to select it. Then, while holding the Ctrl 
(Windows/Linux) or ⌘  (macOS) key, click on the other port to create a connection.
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How to connect a node in the middle of an existing connection

 1. Add the node you want to insert into the existing connection to the Node view.

 2. Press and hold the Alt key.

 3. While holding the Alt, click and drag the node you want to add to the connection over this 
connection, then release the node.

The node will be connected as an intermediary between the two connected nodes. 

How to instantly connect one or several nodes to the same child node

 1. Select all the nodes you want to connect to a child node. 

 2. Press and hold the Alt key.

 3. While holding the Alt key, click on the node you want the selected nodes to be connected to. 
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TIP 

This is mostly useful to connect several nodes to a composite, but can also be used to 
quickly connect any parent node to its child.

How to instantly connect one or several nodes to the same parent node

 1. Select all the nodes that you want to connect to the same parent node.

 2. Press and hold the Alt and Shift keys.

 3. While holding the Alt and Shift keys, click on the node you want the selected nodes to be 
connected to.
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Disconnecting Nodes
You can disconnect nodes by pulling the extremity of a cable and dropping it in the empty space in the Node 
view. You can also use the Cable Cutter mode of the Node view to instantly remove several connections with a 
mouse gesture. 

How to disconnect a node from another node

 1. Do one of the following:

 l Using the mouse, click and drag on the top port of the bottom node. This will tear the cable 
off the port. Drag the cable to an empty space in the Node view and drop it to delete the 
connection.

 l Click on the cable and press Del to delete it.

 l Click on the cable and drag it to delete it.

How to remove an intermediary node from its connection

 1. While holding the Alt key, click on the node and drag it away from the connection. 

How to quickly cut several connections with the mouse cursor

 1. In the Node View toolbar, click the 
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 Cable Cutter button to toggle it on.

 2. Click and drag over all the cables you want to remove.

 3. Once you are done cutting cables, click the  Cable Cutter button again to toggle it off.

TIP 

You can assign a keyboard shortcut to toggle or temporarily enable Cable Cutter mode. To do 
this, assign keyboard shortcuts to the Cable Cutter or Cable Cutter Override commands in the 
Node View section of the Keyboard Shortcuts dialog. To access the Keyboard Shortcuts dialog:

 l Windows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Premium > Keyboard Shortcuts.
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Displaying Port Tooltips
You can display a port's name by clicking on it. You can also display the information on a connection by 
hovering the mouse cursor on one of the ports in the connection.

How to display a port's name

 1. Click on the port to select it.

The port will display its name.

How to display information on a connection.

 1. Move the mouse cursor over one of the ports that the connection is linking and wait one second.

A tooltip will appear displaying the type of port the mouse is over as well, its port number, the 
name of the node it is connected to and the port number to which it is connected.
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About Peg Nodes
Peg nodes are node that are used to store geometric transformations (position, scale, skewing and angle) as 
well as animations and apply them onto drawings. Any transformation or animation made on a peg is also 
applied onto elements connected under it. 

A peg node can be connected to multiple drawings, so as to make it possible to transform and animate 
multiple elements, but still store all the transformation and animation in a single node. 

Peg nodes can also be stacked to combined their transformations and animations, and apply the combined 
transformations onto an element.
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Adding and Connecting Peg Nodes
Peg nodes are often use in great amounts in digital animation. To make rigging and staging easier, there are 
methods for quickly adding pegs to a node system.

How to add and connect a Peg node manually

 1. Do one of the following:

 l Right-click in the Node View and select Insert > Move > Peg.

 l In the top-left corner of the Node View, open the View Menu and select Insert > Peg.

 l Press Ctrl + P

 l In the Node Library view, select the Move category. Then, drag and drop the Peg node into 
the Node View. 

 2. Connect the bottom port of the Peg node to the top port of the Drawing node you want it to affect 
by doing one of the following:

 l Click and drag on the bottom port of the peg to create a cable, and drag it to the top port of 
the Drawing node.
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 l Click on the bottom port of the peg and, while holding Ctrl (Windows/Linux) or ⌘  (macOS), 
click on the top port of the drawing node to instantly create a connection.

How to add parent pegs to several layers

 1. In the Node view, select all the nodes to which you want to add a parent peg.

TIPS 

 l You can draw a rectangle around a cluster of nodes to select to select all of them 
simultaneously. 

 l You can hold the Ctrl key and click on each node you want to select to add them to 
the selection.

 2. Do one of the following:

 l In the top-left corner of the Node View, open the   View Menu and select Insert Parent 
Peg

 l Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (macOS).

A peg is created for each selected node, each rigged as the parent of their respective node.
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How to add a single parent peg to several layers

 1. In the Node view, select all the nodes to which you want to add a parent peg.

TIPS 

 l You can draw a rectangle around a cluster of nodes to select to select all of them 
simultaneously. 

 l You can hold the Ctrl key and click on each node you want to select to add them to 
the selection.

 2. Press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS).

A single peg is created and is rigged as a parent of all the selected nodes.
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About Composite Nodes
The Composite node allows you to use several images and output a single image. You can compare that to 
doing pre-compositions in editing software. You can connect several drawing, image generators and effect 
nodes in your Composite node and one bitmap (or vector in some cases) comes out of it. 

Using Composites is necessary if you wish to apply effects to several layers combined. For example, if you want 
a character rig that is composed of several layers to appear transparent, you must connect all the layers of your 
character's rig to the same composite, and connect a Transparency effect to that composite.
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Adding and Connecting Composite Nodes
Composite nodes are often used in complex node systems and must often be connected to a lot of nodes. To 
make rigging and staging easier, when you create a composite while nodes are selected, it is automatically 
connected to all of the selected nodes.

TIP 

You can assign a keyboard shortcut to 

How to add and connect a Composite node manually 

 1. Do one of the following:

 l Right-click in the Node View and select Insert > Combine > Composite. 

 l In the top-left corner of the Node VIew, open the View Menu and select Insert > Composite. 

 l Press Ctrl + H.

 l In the Node Library view, select the Combine category, then drag and drop the Composite 
node from the Node Library to the Node View. 

 2. For each node that should be connected to the composite, do one of the following:

 l Click and drag on the node's bottom port to create a connection cable, then release the 
cable just over the composite.
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 l Click on the node's bottom port to select it. Then, while holding Ctrl (Windows/Linux) or ⌘  
(macOS), click on the top edge of the Composite, where you want the connection to be 
created.

 3. Connect the bottom port of the Composite to another Composite, an effect, or a Display node.

How to add a Composite node and instantly connect several nodes to it

 1. Select all the nodes to which you want the Composite to be connected.
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 2. Do one of the following:

 l Right-click in the Node View and select Insert > Combine > Composite. 

 l In the top-left corner of the Node VIew, open the View Menu and select Insert > Composite. 

 l Press Ctrl + H.

A Composite node is created and is instantly connected to all the selected nodes.

 3. Connect the bottom port of the Composite to another Composite, an effect, or a Display node.

How to instantly connect several nodes to an existing Composite node

 1. Select all the nodes to which you want the Composite to be connected.
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 2. While holding the Alt key, click on the Composite node.

The selected nodes are instantly all connected to the Composite.
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About Composite Modes
Composite nodes have several modes, each of which can have a specific purpose in a complex node system:

 l As Bitmap: This is the default mode for composites. A bitmap composite outputs a single composited 
image. 

 l As Seamless Bitmap: mode works very similarly to bitmap mode, except it prevents seams from 
appearing between vector shapes that have matching outlines or when vector drawings are 3D-
rotated and made to mesh together. 

NOTE 

Shadow, Glow, Blending and Focus effects do not work when connected to a Seamless 
Bitmap composite.

 l As Vector: This mode outputs a flat vector drawing made of all the connected drawings. Vector 
composites should be used only when necessary, as they ignore any effect and bitmap information that 
is sent to them.

 l Pass Through: This mode simply passes all the information sent to the Composite, including artwork, 
effects and transformations, onto the next composite as is, as a multi-layered image. This means that if 
an effect is applied to the output of that composite, the effect will be applied individually to each layer 
connected to that composite. Hence, a pass through composite does not really perform any composition. 
It is essentially an organization tool. 
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NOTES 

 l The cable coming from a Pass Through composite will be thicker and have a darker 
centreline. This can be useful to identify areas of your node system that carry a lot of 
information.

 l If a Composite set to Pass Through is at the bottom of the composite chain, it will act the 
same as a Bitmap composite.
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Changing Composite Mode

By default, composite nodes have their mode set to As Bitmap. You can change the mode of a composite node 
via its layer properties. You can also change the mode of several composites between As Bitmap and Pass 
Through using the Set Properties for Many Layers dialog.

TIP 

If your project requires a lot of pass through composites, you can enable the Default Pass Through 
Composite preference. When this option is enabled, all new composite nodes you create will have 
their mode set to Pass Through by default. This option can be enabled in the Preferences dialog, in 
the General tab, in the Settings section.

How to change the mode of a single composite node

 1. Locate the composite node in the Node View.

 2. Do one of the following:

 l Click on the yellow square  inside the node to open its Layer Properties dialog. 

 l Make sure the Layer Properties view to your workspace, then select the node to display its 
properties in this view.

 3. In the node's layer properties, open the Mode drop-down and select the desired mode for this 
composite.

How to change the mode for several composite nodes

 1. In the Node View, select all the Composite nodes for which you want to change the mode. 

TIPS 

 l You can draw a rectangle around several nodes to select them simultaneously.

 l You can press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key and either click 
on nodes or draw a rectangle around them to add them to your selection.

 2. In the Node View toolbar, click on  Set Properties on Many Layers  button.

The Set Properties on Many Layers dialog appears.
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 3. Set the Composite Mode option to either Bitmap or Pass Through.

 4. Click on the OK button.
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About Effect Nodes
Effect nodes are special nodes that take an image as their input, and output a transformed image. They are 
typically connected as the intermediary between a drawing node and a composite.

Some effect nodes have several input ports. The most frequent example is matte input port. Effect nodes with 
matte input ports need a matte to know which part of the input image to affect.

There is a lot to learn about effect nodes. For more information about how to add, connect and configure effect 
nodes, see Effects on page 242.
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Enabling and Disabling Nodes
As with the Timeline layers, you can turn the Node view nodes on or off. When you turn off a node in the Node 
view, its corresponding layer in the Timeline and Xsheet views is also turned off. Nodes that are turned off are 
displayed in red.

How to disable nodes

 1. In the Node view, select the node(s) you want to disable.

 2. Do one of the following:

 l In the top-left corner of the Node View, open the  View Menu and select Nodes > Disable.

 l Press D.

How to disable all other nodes

 1. In the Node view, select the node(s) that you want to keep enabled. 

 2. In the top-left corner of the Node View, open the  View Menu and select Nodes > Disable All 
Others

All nodes are disabled except for those selected.
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NOTE 

This only affects nodes in the current group. 

How to enable nodes

 1. In the Node view, select the disabled node(s) you want to enable.

 2. Do one of the following:

 l In the top-left corner of the Node View, open the  View Menu and select Nodes > Enable.

 l Press A.

How to enable all nodes

 1. In the top-left corner of the Node View, open the  View Menu and select Nodes > Enable All.
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Moving Nodes
If you are working on a complex node system, it is important to routinely move nodes around to keep them 
organized and to keep their connections visible. 

How to move several nodes using the mouse

 1. In the Node view, click and drag on the node you want to move.

 2. Release the mouse button when the node is where you want it to be.

NOTE 

When moving a node with the mouse, its vertical position will snap to align vertically with 
other nodes and will snap to align horizontally to make its cables straight.

How to move several nodes using the mouse

 1. In the Node View, select all the nodes you want to move.

TIPS 

 l You can draw a rectangle around a cluster of nodes to select to select all of them 
simultaneously. 

 l You can hold the Ctrl key and click on each node you want to select to add them to 
the selection.

 2. Click and drag on one of the selected nodes to move them.
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 3. Release the mouse button when the nodes are where you want it to be.

How to nudge nodes using the keyboard 

 1. In the Node view, select the node or nodes you want to move. 

TIPS 

 l You can draw a rectangle around a cluster of nodes to select to select all of them 
simultaneously. 

 l You can hold the Ctrl key and click on each node you want to select to add them to 
the selection.

 2. Do one of the following:

 l To nudge the selected node(s) up, press the Up Arrowkey.

 l To nudge the selected node(s) right, press the Right Arrowkey.

 l To nudge the selected node(s) down, press the Down Arrow key.

 l To nudge the selected node(s) left, press the Left Arrow key.

TIP 

By holding the Shift key, you can nudge nodes by larger distances. 
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Aligning and Organizing a Node System
The Node View comes with three scripts allowing you to quickly organize and align nodes in a node system:

 l Order Node View Up and Order Node View Down can organize a node system made of several parent 
nodes connected to one child node—such as layers connected to a composite—into an upward arc, a 
node layout typically used for traditional or paperless animation scenes with few nodes. It should 
however not be used for complex cut-out rigs. 

 l Align Nodes Horizontally can arrange a selection of one or several rows of nodes into a grid. It can also 
organize the parent nodes if they form a simple, clean tree-like structure. It is not made to organize 
entire rigs, but it can quickly organize parts of a rig so as to make the organization of an entire rig easier.

How to organize a simple node system

 1. In the Node View, select either:
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 l The node at the root of your node system.

 l The Composite node at the bottom of your node system.

 2. In the Node View toolbar, do one of the following:

 l If you selected the root node at the top, click the  Order Node View Down button.

 l If you selected the Composite node at the bottom, click the  Order Node View Up  button.

The Order Node View Settings dialog box opens.

 3. The default values in the input fields are already optimized, but you can adjust them as needed:

 l X Overlap %: How much nodes in the same vertical tier overlap each other on the horizontal 
axis.
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 l Layer Spacing: How much space to add between each vertical tier of nodes.

 l Vertical Spacing: How much vertical space to add between nodes of the same vertical tier.

 4. Click OK.

The node system is organized in an arc.

How to align one or several rows of nodes horizontally

 1. In the Node View, select one or several rows of nodes. 
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TIPS 

This script is designed to lay out one several rows of nodes in node system into a grid, 
but is not designed to work on entire rigs at a time. If you’re using it to align several 
rows of nodes, make sure that:

 l You avoid selecting node systems that branch out into several trees.

 l If one branch in your selection has an extra child, such as an Element node with en 
effect underneath it, do not include this extra child in your selection.

 l Make sure you have created all your connections. Unconnected nodes will be put in 
the same row. 

In the following image, green rectangles represent selections that would work, and red 
rectangles represent selection that would lead to unexpected results.

 2. In the Node View toolbar, click on the  Align Nodes Horizontally button.

The selected nodes are laid out by their hierarchy and aligned. 
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About Displays
The Display node is an important node; it is used by the export and views to display your scene, primarily the 
Camera and Timeline views. By default, a scene's node system always has a Display node which can be used to 
show your entire scene, a single node or a group of nodes through a Composite or Group node. You might use it 
to see one single character as you animate it, debug your node system as you create complex effects or export 
your complete scene or a portion of it. 

You can have more than one Display node in the Node view, so you can visualize different sections of the scene 
without disabling or disconnecting elements that are in the way. This is useful in cut-out animation as it allows 
you to see one puppet without viewing all the other characters. It's also useful during compositing and helps 
you visualize and debug effects.

To use this display concept, show the Display toolbar which will let you select different Display nodes 
available in the node system. 

You can also use the Scene > Display menu to select the desired Display node to update the contents of the 
Camera, Top, Side, Perspective, and Timeline views.
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When your scene does not have a Display node, it is automatically set to Display All which uses the Timeline 
view ordering and shows floating nodes from the Node view. You can also set your scene to use Display All 
using the Display toolbar.

NOTE 

If you try to add a peg or other transformation layer in the Timeline view without having a layer 
selected, an error message will display. Make sure to change to Display All. The peg layer will be 
floating in the Node view and will not be visible in the Timeline view.  The Timeline view shows 
only layers that are connected to the Composite node.

If you switch to Display All, you run the risk of not realizing when you have floating nodes that are 
not connected to your composite.  For this reason, it is not recommended to work in Display All 
mode.

When your scene contains many nodes and you cannot see them all, you can display all nodes at that level.

Harmony has two display modes. By default, it is set to the Basic Display mode.

When creating a scene in Basic Display mode, a Display node is automatically added to the node system and 
connected to the final Composite node. All of the views are set to use this Display node. This means that only 
the elements connected in that Composite node will show in the Camera view. 

You can add and connect more Display nodes to your node system and select the one you want by using the 
Display menu. In Basic mode, every view is set to the same Display node.

In Advanced Display mode, every view using the display concept has its own Display menu and each one can 
be set to a different Display node. To switch from Basic to Advanced Display mode, you must enable the 
Advanced Display option in the Preferences dialog box (Advanced tab). These Display menus allow you to set 
the views to different displays. By default, all views are set to Default to follow the main Display toolbar 
selection. However, you may want different views set on different displays. For example, you can have one 
Camera view to display the full scene and another Camera view to only display the character being animated. 
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In this case, you can set the first Camera view on the final display and the second on the character’s Display 
node.

If you want the views to follow the main Display toolbar selection, set the display option of each display menu 
to Default.
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Adding Display Nodes
To display different portions of your scene, you need to add several Display node to your project.

How to add a Display node

 1. Do one of the followings:

 l In the Node view, press Ctrl + Y (Windows/Linux) or  ⌘  + Y (macOS).

 l In the Node menu, select Insert > Display.

 l In the Node view, right-click and select Insert > Output > Display.

 l In the Node Library view, in the Output category, select a Display node and drag it to 
the Node view.
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Changing Global Displays
Using the Display toolbar, you can change which display to view the scene from. 

How to set a different Display node as a global display

 1. Do one of the following:

 l In the Display toolbar drop-down, select a display.

 l From the top menu, select Scene > Default Display and select a display.

Each view is updated if set to the Default display option.
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Setting Advanced Display Options
You can set your views to show different display outputs simultaneously with the Advanced Display option.

How to enable the Advanced Display option

 1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > 
Preferences (macOS). 

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. In the Preferences dialog box, select the Advanced tab. 

 3. In the Advanced Options section, select the Advanced Display option.

A Display menu appears in the top-left corner of the Camera, Timeline, Perspective, Top, and Side 
views.
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About Groups in the Node View
With so many connections and nodes possible, the Timeline and Node views can quickly become cluttered. 
You can use groups to keep your scenes organized. 

When grouping nodes, you can choose to create a simple group, or a group with a composite. A simple group 
will simply help you organize your Node view, whereas a group with composite will connect all the nodes in 
your group to the same composite, and connect that composite to the outside of your group. This makes the 
group have a single outgoing connection for its composite, rather than one connection for each node that 
connected to your scene's composite.

Hence, grouping nodes with a composite is a quick way of connecting several layers that need to be 
composited together to the same composite node. However, grouping nodes without a composite allows you to 
connect the layers inside the group to different parts of the Node view outside of the group, allowing you to 
preserve and tweak the stacking order of the group's content relative to the remainder of the scene if needed. 
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Using the Move to Parent Group command allows you to move the selected node to the parent level, 
maintaining all connections.  If the operation cannot maintain the connections between the nodes, you will be 
notified and the operation will be terminated.

NOTE 

You can also group layers using the Timeline view—see About Groups in the Timeline View on 
page 187.
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Grouping Nodes
You can group your nodes to keep your Node view organized. 

NOTE 

For grouping layers in the Timeline view, see Grouping Layers on page 188.

How to group nodes in the Node view

 1. In the Node view, drag a selection around the nodes you want to group.

 2. In the Node menu, do one of the following:

 l Select Edit > Group > Group Selected Layers.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (macOS).

You can also right-click in the Node view and select one of the following:

 l Group > Group Selection With Composite or press Ctrl +Shift + G (Windows/Linux) 
or ⌘  + Shift + G (macOS).

 l Group > Group Selection or press Ctrl + G (Windows/Linux) or ⌘  + G (macOS)

The selected nodes are grouped.

NOTE 

To learn how to navigate inside the group, see Entering Groups and Exiting Groups.
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Ungrouping Nodes
If needed, you can ungroup nodes that you have previously grouped together.

NOTE 

For ungrouping layers in the Timeline view, see Ungrouping Layers.

How to ungroup a group of nodes

 1. In the Node view, select the group you want to ungroup.

 2. In the Node menu, select Edit > Group > Ungroup.

The selected group is ungrouped.
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Moving Nodes Between Groups
It is possible to move nodes from one group to another group, from the top level to a group or from a group to 
the top level. To do this, you must cut the nodes you want to move and paste them in the intended group.

How to move nodes from one group to another group

 1. In the Node view, select the node or nodes you want to move. 

TIPS 

 l You can draw a rectangle around a cluster of nodes to select to select all of them 
simultaneously. 

 l You can hold the Ctrl key and click on each node you want to select to add them to 
the selection.

 2. Do one of the following:

 l Right-click on the selection and select Cut selection.

 l In the top menu, select Edit > Cut selection.

 l Press Ctrl (Windows/Linux) or ⌘  (macOS)

 3. Navigate to the group in which you want to move the selected nodes.

 4. Do one of the following:

 l Right-click in the Node view and select Paste.

 l In the top menu, select Edit > Paste.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

The nodes are pasted in the current group. You will have to manually connect them to this group's 
node system. 
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Moving Nodes to Parent Group
Using the Move to Parent Group command, you can quickly move a selection of nodes to the parent of the 
current group and preserve their connections. However, to be able to use this command, the selected nodes 
can be connected to the bottom of the group or to the top of the group, but not both. 

How to move nodes to the parent group

 1. In the Node view, go inside the group and select the nodes you want to move up to the parent 
group level.

 2. From the Node menu, select Nodes > Move to Parent Group or press Ctrl + Shift + U 
(Windows/Linux) or ⌘  + Shift + U (macOS).

The selected nodes are moved to the parent group level.
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Adding a Node's Properties to a Group's Properties
Using Publish Attribute Mode, you can select properties in any node's Layer Properties dialog and push them 
to the layer properties of their parent group. This way, if you need to make frequent changes to specific 
properties of specific nodes inside a group, you can access those properties directly from the Layer Properties 
dialog for that group, instead of having to enter that group and locate those specific nodes every time.

How to publish a node's attributes to its parent group

 1. In the top-left corner of the Node view, open the  View Menu  and select View > Publish 
Attribute Mode.

 2. In the Node view, locate the node for which you want to publish attributes.

 3. Click on the  Layer Properties  button for this node. 

The Layer Properties dialog for this node appears. Notice that:

 l A Tab field is at the top of the layer properties dialog. The attributes you publish will be in a 
tab inside the parent group's layer properties, and the tab will have the name you put in this 
field. The parent group will have one tab for each node that has published attributes.

 l A check box and a text field is right of each group of attributes, such as Position, Scale, 
Rotation,  etc. If you check a group's check box, all of the attributes in this group will be listed 
in the parent group's properties.

 l A check box and a text field is right of each individual attribute. 

 4. In the Tab field, give a name to the tab that will appear in the parent group's properties for this 
node. 
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 5. For each attribute or attribute group that you want to add to the parent group's properties:

 a. Check the check box just right of this attribute or attribute group

 b. If you want this attribute or attribute group to have a custom name in the parent group's 
properties, type in that name in the text field just right of the check box. 
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 6. Repeat for each attribute you wish to publish.

 7. In the Node view, navigate to the parent group by doing one of the following:

 l Click on the Up  arrow near the top of the node view. 
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 l Click on the parent group's name in the hierarchy displayed at the bottom of the Node view.

 8. Click on the Layer Properties  button for that group.

The group's Layer Properties dialog opens. In the group's layer properties, each attribute you chose 
to publish are in a tab with the given tab name. You can edit those attributes from here, and the 
changes will be applied to the node's attributes.
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 9. If you don't want the attributes published to this group to also be published to this group's parent 
group (if it has one), uncheck the Publish to Parent Groups option.
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About Backdrops
T-RIG-008-001

Backdrops are a way to work with complex node systems that let you associate a selected set of nodes by 
colour. You can add as many backdrops to your node structure as needed. The idea is to visually organize the 
structure so you can quickly identify the particular set of nodes.

You can customize the backdrops with different colours. For example, the upper part of a character's body 
could be in different shades of red, while the lower body is in shades of green. When you create a backdrop to 
the Node view, the default colour is red. 

Once you have created a backdrop with nodes inside, you can move the backdrop to the desired location and 
arrange multiple backdrops neatly. You can also resize backdrops to accommodate the number of nodes in your 
rig.

You can select the nodes you want to add to the backdrop before creating it and vice versa—create an empty 
backdrop and then drag the desired nodes into the backdrop.

NOTE 

Because backdrops are not layers, its properties do not appear in a node's properties.
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For your convenience, you can add backdrops as templates to the library—see Create a Template from the 
Node view in Chapter 7: Library of the Cut-out Animation Guide.
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Adding Backdrops
T-RIG-008-002

You can add colourful backdrop to organize your nodes and group parts of your cut-out characters.

How to add a backdrop

 1. In the Node view, do one of the following:

 l Select the nodes to include in the backdrop.

 l Click anywhere in the Node view to deselect any selected items.

 2. From the Node View menu, select Insert > Backdrop.

If you selected nodes, a red backdrop displays around the nodes you selected.

If you did not select anything, a red backdrop displays in the Node view.
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Removing Backdrops
If no longer needed, you can easily remove backdrops.

How to remove a backdrop

 1. In the Node view, clear any backdrop or node selections.

 2. Alt+ click on the title bar of a backdrop to only select the backdrop, without the nodes.

 l If you want to delete the backdrop and all its nodes, simply select the backdrop 
without using the Alt key.

 3. Press Del.

 l If you had a node selection, depending on your project, the Confirm Delete window 
may display. Deselect the Delete Drawing Files and Element Folders. If you have 
multiple version of a scene, you will want to keep all the files and folders associated 
with it. If you select this option, all the drawings and folders linked to this backdrop 
will be deleted.
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Customizing Backdrops
T-RIG-008-003

Once you've created a backdrop, customizing it is a great way to organize your work. You can change the colour 
of the backdrop, give it a name which displays in the title bar of the backdrop, and add any notes or 
instructions pertaining to the nodes contained in the backdrop.

How to customize a backdrop

 1. To resize a backdrop, drag the triangle in the lower-right corner of the backdrop window.

 2. Click the yellow square properties button.

The Backdrop Properties window opens.

 3. To change the colour of the backdrop, click the Colour list and select a colour.
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 4. In the Name field, type in a name for the backdrop.

 5. In the Text field, type in any notes or instructions in the backdrop.
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Organizing Nodes in Backdrops
Once you have deselected all items in the Node view, you can organize any of the nodes by dragging and 
moving them around even if they are in a backdrop. You can move nodes from one backdrop to another.

How to organize nodes in backdrops

 1. Click anywhere in the Node view to deselect all items.

 2. Organize the nodes by dragging them from one or more backdrops.
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Moving Backdrops
T-RIG-008-004

When you want to move a backdrop, you can do so either with or without the nodes it contains. Moving a 
backdrop with its nodes lets you quickly organize entire sections of a complex rig. 

Moving the backdrop only (without its nodes) gives you a chance to reorganize a node structure. Perhaps 
nodes should be grouped differently for a better workflow or nested within another backdrop for optimal 
organization.

How to move a backdrop and its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Click the title bar of a backdrop and drag to a new location.

How to move a backdrop without its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Hold down Alt and drag the backdrop by the title bar to a new location.

 3. Click anywhere outside the backdrop to set its new position.
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Copying and Pasting Backdrops
When you copy a backdrop, its contents are copied along with the backdrop name, colour, and any notes. 
When selecting a backdrop, all backdrops underneath it are also selected.

When you select a backdrop with the Alt key, the backdrop retains its Z order.

NOTE 

A selection that contains only backdrops cannot be copied.

How to copy and paste a backdrop

 1. Select one or more backdrops to copy and press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 2. To paste the copied backdrop(s), press Ctrl + V (Windows/Linux) or ⌘  + V (macOS). Note that 
nodes will be pasted as clones. They will link to the same drawing columns and existing function 
columns.
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About Waypoints
Waypoints are a way to organize the connection cables in the Node view. 

Waypoints have two basic functionalities:

 l They allow you to modify the trajectory of a cable connecting two nodes.

 l They allow you to determine where a cable should split before branching to several nodes.

In the end, the main purpose of waypoints is to sort out connection cables in a complex node system where a 
lot of connections cross. By adding waypoints to your nose system, you can keep the different connections 
clearly separate and make your node system more legible. 
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A connection can have one or several waypoints accross it. The connection between a waypoint and a node 
will be a Bezier curve, and the connection between two waypoints will be a straight line.

In the Node view, the information travels from top to bottom. Just like it is possible to split an outgoing 
connection into several cables, it is possible to split a waypoint into several cables. However, keep in mind that 
the opposite is not possible. You cannot use a waypoint to combine several connections into one.

Just like when you create several connections from a single node, you can apply specific effects to one of the 
connections of a waypoint without applying it to all of them.
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Adding Waypoints
There are two ways to add waypoints. You can break an existing connection in two by creating a waypoint in 
the middle, or add a free waypoint, then connect its input node and its output node. 

How to quickly add a waypoint to a connection that has no waypoints

 1. Click on the connection to which you want to add a waypoint.

A circle appears in the middle of the connection. 

 

 2. Click and drag on the circle over the connection to which you want to add a waypoint,.

The circle is converted to a waypoint in the middle of the connection.

How to add a waypojnt to a connection that already has waypoints

 1. Click on the connection to which you want a waypoint.

 2. Right-click on the connection, exactly where you want the waypoint to be created.

 3. Select Create Waypoint.
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A waypoint is created over the selected connection, where you right-clicked. 

 

How to add a free waypoint

 1. Right-click anywhere in the Node view.

 2. Select Create Waypoint.

A free waypoint is created where you right-clicked. 
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Connecting and Disconnecting Waypoints
If you created a free waypoint, you need to create its incoming connection first, then its outcgoing onnections 
after. You must follow this order. Connecting a node to a waypoint is done the same way as connecting a node 
to another node. However, to connect a waypoint to a node, you must press and hold the Shift key while 
clicking and dragging on the waypoint to create an output cable. 

 

If you've created a waypoint on an existing connection, it already has one incoming and one outgoing 
connection. So, all you need to do is create its extra outgoing connections, if needed. A waypoint can only have 
one incoming connection, but can have as many outgoing connections as needed.

How to create an incoming connection from a node to a waypoint

 1. Click and hold on the bottom port of the node you want to connect to the waypoint. 

 2. While holding the mouse button, drag all the way to the waypoint. When the cable snaps to the 
waypoint, release the mouse button.
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How to create an outgoing connection from a waypoint to a node

 1. Press and hold the Shift key.

 2. Click and hold on the waypoint.

 3. Do one of the following:

 l While holding the mouse button, drag all the way to the top port of the node you want to 
connect the waypoint to. When the cable snaps to the port, release the mouse button.

 l Press and hold the Alt key and click on the node you want to connect the waypoint to, near 
the port to which you want to connect it. 
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Moving Waypoints
Like nodes, waypoints can be dragged and dropped and can be nudged using the arrow keys 

How to move a waypoint with the mouse

 1. Click and drag on the waypoint you want to move to move it. 

How to move several waypoints with the mouse

 1. In the Node View, select all the waypoints you want to move.

TIPS 

 l You can select several waypoints by pressing and holding the Ctrl (Windows/Linux) 
or ⌘  (macOS) key and clicking on each waypoint you want to select.

 l You can draw a rectangle around a cluster of waypoints to select all of them 
simultaneously.

 2. Click and drag one of the selected waypoints to move them.

How to nudge waypoints with the arrow keys

 1. In the Node View, select all the waypoints you want to move.

TIPS 

 l You can select several waypoints by pressing and holding the Ctrl (Windows/Linux) 
or ⌘  (macOS) key and clicking on each waypoint you want to select.

 l You can draw a rectangle around a cluster of waypoints to select all of them 
simultaneously.

 2. Do one of the following:

 l To nudge the selected waypoint(s) up, press the Up Arrowkey.

 l To nudge the selected waypoint(s) right, press the Right Arrowkey.

 l To nudge the selected waypoint(s) down, press the Down Arrow key.

 l To nudge the selected waypoint(s) left, press the Left Arrow key.
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TIP 

By holding the Shift key, you can nudge waypoints by larger distances. 
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Disconnecting Waypoints
It is possible to disconnect the connection going from a waypoint to a node. However, it is not possible to 
disconnect the connection from a node to a waypoint, except by replacing it with a connection coming from 
another node. 

How to break the connection from a waypoint to a node 

 1. Click and hold on the top port to which the waypoint is connected.

 2. While holding the mouse button, drag the mouse to break the connection away from the port, then 
release it to discard the connection.

How to replace the connection from a node to a waypoint 

 1. Click and hold on the bottom port of the node to which you want the waypoint to be connected.

1287



 2. While holding the mouse button, drag the mouse over the waypoint. When the cable snaps to the 
waypoint, release the mouse button.

If the waypoint had an incoming connection from another node, this connection is now discarded, as 
waypoints can only have one incoming connection.
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Removing Waypoints
You can remove a waypoints without affecting your node system. When you delete a waypoint, the connection 
that the waypoint separates remains in the node system.

How to remove a waypoint

 1. In the node view, select the waypoint you want to remove. 

TIPS 

 l You can select several waypoints by pressing and holding the Ctrl (Windows/Linux) 
or ⌘  (macOS) key and clicking on each waypoint you want to select.

 l You can draw a rectangle around a cluster of waypoints to select all of them 
simultaneously.

 2. Do one of the following:

 l Right-click on the selection and select Delete.

 l Press Del
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Navigating the Node View
The Node view is a limitless space in which you can lay out very large and complex node systems. Hence, it is 
important to know how to navigate it.
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Panning & Zooming the Node View
The basics of navigating the Node View are panning and zooming in or out until you have the nodes you want 
to work with within the view. 

How to pan the Node View

 1. Press and hold the Spacebar key.

 2. While holding the Spacebar key, click and drag the inside of the Node view.

How to zoom out the Node View

 1. Do one of the following:

 l Move the mouse inside the Node View and scroll down.

 l Click on the Node View to set the focus on it, then press 1. 

How to zoom in the Node View

 1. Do one of the following:

 l Move the mouse cursor inside the Node View and scroll up.

 l Click on the Node View to set the focus on it, then press 2.

How to reset the Node View's pan

 1. Do one of the following:

 l In the top-left corner of the Node View, open the  View Menu and select View > Reset 
Pan.

 l Press Shift + N.

How to reset the Node View's zoom

 1. In the top-left corner of the Node View, open the  View Menu and select View > Reset Node 
View Zoom.
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How to reset the Node View's pan and zoom

 1. Do one of the following:

 l In the top-left corner of the Node View, open the  View Menu and select View > Reset 
View.

 l Press Shift + period(.).
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Displaying All Nodes in the Node View 
Using the Show All Nodes command, you can quickly adjust the pan and zoom of the Node View to include all 
the nodes in your node system. 

How to display all nodes

 1. Do one of the following:

 l From the Node View menu, select View > Show All Nodes.

 l Press Shift + comma (,).
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Using the Magnifier in the Node View
Magnifier is a convenient tool that displays the entire node system and allows you to quickly zoom in on any 
section of it. 

How to magnify the Node view

 1. Click anywhere in the Node View to set the focus on it.

 2. Press and hold the Z key.

The Node View displays all the nodes in the node system and a magnifying rectangle appears near 
your mouse cursor.

 3. Move the mouse near the nodes you want to navigate to. The magnifier will display the nodes 
around your mouse cursor as you move it.

 4. When you found the nodes you want to navigate to, click in the Node View to jump to them.

 5. Release the Z key.
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Using the Navigator in the Node View
The Navigator is a small panel in the bottom-right corner of the Node View. It displays all the nodes in your 
node system within its rectangle as well as a smaller rectangle representing the area the Node View is 
displaying. You can click and drag on this rectangle to quickly pan the Node view. 

How to pan the Node View using the Navigator

 1. Click and hold inside the rectangle inside the Node View's navigator.

 2. While holding the mouse button, drag the rectangle to move it around the node system. The 
rectangle will follow your mouse cursor, making the Node View pan around the node system.
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Resizing the Node View Navigator

The Node View's Navigator is rather small by default. It is possible to scale it up or down.

How to resize the Node View Navigator

 1. Do one of the following:

 l To resize the navigator horizontally, move the mouse cursor over its left edge until the 
mouse cursor appears.

 l To resize the navigator vertically, move the cursor over its top edge until the  mouse 
cursor appears.

 l To resize the navigator both horizontally and vertically, move the cursor over its top-left 
corner until the  mouse cursor appears.

 2. Click and drag on the edge of the Navigator to resize it. 
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Moving the Node View Navigator

The Node VIew navigator is displayed in the bottom-right corner of the Node View by default. Although you 
cannot move the navigator anywhere in the Node View, you can decide which corner of the Node View it 
occupies.

How to reposition the Node View navigator

 1. In the top-left corner of the Node View, open the  View Menu and select View > Navigator

 2. Select one of the following, depending on where you want the Navigator to be:

 l Top Left

 l Top Right

 l Bottom Left

 l  Bottom Right
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Hiding and Displaying the Node View Navigator

The Node View Navigator is displayed in the bottom-right corner of the Node View by default. You can hide it 
if you prefer. 

How to hide the Node View Navigator

 1. Do one of the following:

 l In the Node view menu, select View > Navigator > Hide Navigator

 l Press Ctrl + Shift + W (Windows/Linux) or ⌘  + Shift + W (macOS).

How to display the Node View Navigator

 1. Do one of the following:

 l In the Node view menu, select View > Navigator > Show Navigator

 l Press Ctrl + Shift + W (Windows/Linux) or ⌘  + Shift + W (macOS).
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Entering Groups
You can enter groups to see their content.

How to enter a group node

 1. In the Node view, click the arrow on the right side of the group node you want to enter.

 l Inside the group node, the Multi-Port In and Multi-Port Out nodes ensure that your connections 
continue beyond the group.
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Exiting Groups
You can exit groups and return to the complete node system.

How to exit a group node

 1. In the Node view, click the destination in the Group Hierarchy menu. You can also select Nodes > 
Exit Group from the Node menu.

‣ You can click on the top blue arrow in the Node view to exit the current group.

‣ When you enter a group, the Group Hierarchy menu displays the path to where you are. In this 
example, we are inside the group named Deform_Bob. To exit this group, click Top at the 
bottom-left corner of the Node view.
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Navigating the Node View with the Keyboard
It is possible to navigate a node system using the arrow keys and the Enter/Return key. To do this, you must 
start by selecting one of the ports in a node. From there, you can navigate to any port in that node, or any node 
connected to that node.

How to navigate a node system using the keyboard

 1. In the Node view, click on any port of any node.

The port is selected.

 2. Do one of the following:

 l To navigate from a node's top port to its bottom port, press the Down Arrow key.

 l To navigate from a node's bottom port to its top port, press the Up Arrow key.
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 l To navigate between different ports on the same side of a node, press the Left Arrow and 
Right Arrow keys.

 l To navigate from one node to another node that is connected under it, navigate to the port 
through which they are connected. Then, press the Down Arrow key.

 l If a bottom port is connected to several nodes and you press the Down Arrow key, circles will 
appear to prompt you to select which node to navigate to:

Use the Left Arrow and Right Arrow keys to select the circle corresponding to the node you 
want to navigate to.

Then, press the Down Arrow key to navigate down the selected path to the port it leads to.
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 l To navigate from one node to a higher node that is connected to it, navigate to the port 
through which it is connected, then press the Up Arrow key. 

 l To navigate inside a group, do one of the following:

 l To enter the group from the top (via the Multi-Port-In), navigate to one of the group's 
top ports.

 l To enter the group from the bottom (via the Multi-Port-Out), navigate to one of the 
group's bottom ports.

Once one of the group's port is selected, do one of the following:

 l If the group's top port is selected, press the Down Arrow key.

 l If the group's bottom port is selected, press the Up Arrow key.

An Enter/Return symbol will appear over the group. 
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At this point, you can press Enter/Return to enter the group. Inside the group, the Multi-
Port-In or Multi-Port-Out port corresponding to the port you had selected will be selected, 
and you can navigate from there.

 l To navigate outside of the group, navigate to either the group's Multi-Port-In or Multi-Port-
Out. Then:

 l If the group's Multi-Port-In is selected, press the Up Arrow key.

 l If the group's Multi-Port-Out is selected, press the Down Arrow key.

An Enter/Return symbol will appear over the group. 

At this point, you can press Enter/Return to exit the group. Outside of the group, the group's 
port corresponding tho the Multi-Port-In or Multi-Port-Out port you selected will be 
selected and you can navigate from there. 
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Displaying Node Thumbnails 
In the Node view, some nodes have a thumbnail option, identified by an arrow next to the properties button 
(square yellow button). Thumbnails can be very useful when navigating the network to easily identify the 
content of each node or analyze the flow of images and effects.

How to display a node’s thumbnail

 1. In the Node view, click on the arrow in the node.

The thumbnail opens.

If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to 
generate them.

How to show thumbnails of selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to display. 

 2. In the Node View menu, select View > Show Selected Thumbnails or press T.
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If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to 
generate them.

How to hide a node’s thumbnail

 1. In the Node view, click the arrow in the node.

The thumbnail closes and the node returns to its closed state.

How to hide thumbnails for the selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to hide. 
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 2. In the Node View menu, select View > Hide Selected Thumbnails or press T. 

How to hide all nodes thumbnails

 1. In the Network View menu, select View > Hide All Thumbnails.
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Adjusting Node Thumbnails
It is possible to adjust the size, resolution and background colour of thumbnails in the Node view. 

How to adjust the size, resolution or background colour of Node thumbnails

 1. In the Node view, click on the Arrow button of a Node to display its thumbnail. For other methods to 
display Node thumbnails, see Displaying Node Thumbnails  on page 1307

 1. Click on the node to select it.

The node's thumbnail controls appear.

 1. Do one of the following:

 l To resize the thumbnail, click and drag the handle in its top-right corner.

 l To change the resolution of the thumbnail, click and hold the resolution drop-down on the 
bottom-left corner, drag the mouse cursor over the desired resolution, then release the 
mouse button.
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 l The change the background colour of the thumbnail, click on the square in the bottom-right 
corner of the thumbnail.

The background colour cycles over white, black, blue and grey.
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Changing Cable Styles
You can customize the look of the cables in the Node view to fit your style of working. You can display the cable 
lines as Bezier (curved) lines or straight lines.

How to change cable styles

 l In the Node View menu, select View > Cable Style > Bezier or Line.
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About Node and Rig Caching
Character rigs used in cut-out animation are often very complex. Depending on their complexity and on the 
general performance of your computer, some rigs can take as much as much as 50 to 150 milliseconds for 
Harmony to render in the OpenGL preview of the Camera view. 

When you manipulate an element in your scene, Harmony needs to regenerate the entire preview image for 
the Camera view. This means that if your scene has several rigs, the time required to render each of their 
preview adds up each time you manipulate something, causing delays of several hundreds of milliseconds per 
manipulation. As a result, it can be very challenging to work on scenes with several characters without using 
workarounds such as hiding all characters but the ones being worked on. 

However, it is possible to manage this situation efficiently with very little compromise by using rig caching.

Caching is a mode that can be enabled on any node that outputs an image, but more importantly, it can be 
enabled on Composite nodes, allowing you to cache entire rigs in your scenes.

When a rig is cached, Harmony generates the OpenGL preview image for that rig once, then stores it in a 
database of preview images. Whenever the preview image for the Camera view needs to be refreshed, 
Harmony will simply re-use this cached image instead of regenerating the preview image for the cached rig. 

Hence, in a scene with several rigs, you can enable caching on each rig separately, then temporarily disable 
caching on the rig you wish to work on. Harmony's performance will be comparable to that of a scene with a 
single rig in it. You can then re-enable caching on this rig, at which point Harmony will regenerate the rig's 
cache so that its preview image remains accurate while you start working on a different character rig. 

NOTE 

Node caching and rig caching do not affect the rendered image. They only affect the OpenGL 
preview of a Harmony scene in the Camera view.
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About How Node Caching Works and Its Caveats
Node caching can save a significant amount of time. However, before attempting to use node caching, it is 
important to understand how it works as well as its caveats.

Enabling Node Caching

Caching can be enabled on individual nodes. It can be enabled on any node that outputs an image. When 
caching is enabled on a node, its output image is cached, and this cache is only regenerated when needed.

More importantly, caching can be enabled on a Composite node. In this case, the Composite node will not 
cache its output image. It will cache each of its input images separately. 

This exception is meant to simplify the use of node caching. Essentially, all you need to do to create a separate 
cache for each character rig in a scene is to enable caching on the Composite node to which your character rigs 
are connected. The Composite node will take care of creating a cache for each of them, and of enabling, 
disabling and refreshing these caches when needed. 

Caching cannot be enabled on nodes that do not output an image, such as Peg, Quadmap, Deformation nodes, 
Constraint nodes as well as Write and Display nodes. Furthermore, caching cannot be enabled on a group, as 
a group does not actually output an image, it merely stores nodes and allows cables to go in and out of it. To 
cache the output image of a group, you can add a Composite node below the group and enable caching on it. 

Posing and Animating with Node Caching

Project collaborators who have to work on scenes in which nodes and rigs are cached will need to learn how to 
temporarily disable caching on a node or rig so that they can edit and manipulate it. The process is fairly 
simple. For more information, see Working with Node Caching on page 1326.

Effects on the OpenGL Preview

The most important hing to understand about node caching is that, when a node's output image is cached, 
what is cached, and what is displayed in the OpenGL preview of the Camera view, is a flat bitmap image. This 
means that a cached node has a limited display resolution, that all its layers are flattened together and that it 
does not carry any vector, colour palette or depth information.

In most cases, this will have very little visible effects. There are two exceptions to this: Layers that are offset on 
the z-axis, and effects that can be previewed in the OpenGL preview of the Camera view. Both exceptions are 
explained below. 

IMPORTANT 

Keep in mind that node caching and rig caching have no effect on the final rendered image, nor in 
the preview image in the Camera view when it is set to  Render View mode. Node caching can 
only affect the  OpenGL preview of the Camera view.
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Depth, Z-Ordering and Compositing Order

The first effect that node caching can have on the OpenGL preview occurs when layers in different rigs have 
been offset on the z-axis. It is common, in cut-out animation, to nudge specific elements of a character rig on 
the z-axis so as to allow cut-out characters to interact with each other or with objects, and have each element 
in each respective rig render in the proper order, regardless of the order in which elements are connected in 
the node system, such as in the following example:

This technique only works in Harmony when using composites in Pass Through or 3D Bitmap mode. These 
composite modes pass on the data required for composites further down in the node network to composite 
elements according to their individual position on the z-axis.

However, when the output of a Composite node is cached, its cached output is always a flat bitmap image, with 
no information about the position of individual elements on the z-axis. Hence, when characters and objects in 
your scenes are cached separately, the OpenGL preview will display each character as a single flat image. 
Individual elements that make up their rigs will not display in their specific position on the z-axis. 
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Effect Preview

Some effects in Harmony are rendered in the OpenGL preview of the Camera view. One of the most commonly 
used of those effects is the Colour-Override. 

The Colour-Override effect works by finding colours and textures by their colour ID in the vector artwork in 
their input image and processing them as configured. For example, they can replace a colour with another one 
or with a texture, hide a coulour, or hide all but a specific colour, etc. 

If a Colour-Override node is connected under a composite that is cached, since that composite will output a flat 
bitmap image to the Colour-Override node, the latter will not be able to find colour IDs in this image. The effect 
of the Colour-Override node will not be visible in the OpenGL preview of the Camera view.
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Another example of how node caching affects the preview of effects is with the Apply-Peg-Transformation 
node. Normally, the Apply-Peg-Transformation node travels up the node network to apply the transformation 
of its peg to every visual element it comes across. However, if the Apply-Peg-Transformation node reaches a 
cached node, it will not travel up this node's parents. It will simply take the cached image of the node, and 
apply its transformation to it. Since a cached image is a bitmap image, if the Apply-Peg-Transformation node is 
set up to scale-up the image, it may appear pixelated in the OpenGL preview.
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Enabling Cache on Individual Nodes
You can make any node that outputs an image cache its output image. This can be useful if an element contains 
a very complex vector drawing or 3D model.

To enable caching on a node, all you need to do is to enable the Cached parameter in its layer properties. You 
can also toggle caching for one or several nodes simultaneously using the Node Caching toolbar.

TIP 

You can find which nodes in your scene impact Harmony performance to most, and hence, which 
nodes might be more beneficial to cache, by enabling Debug mode. This will display the amount of 
times each node is traversed by Harmony, as well as the amount of milliseconds they take to 
render, next to each Node in the Node view. To enable Debug mode, simply select Help > Debug 
from the top menu.

NOTE 

If you enable cache on a Composite, it will cache each of its input images individually instead of its 
output image—see Enabling Cache on Every Rig In a Scene.

How to enable or disable                  caching on one or several nodes                 using the Node Caching 
toolbar

 1. Add the Node Caching toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Node Caching.

 l Right-click on any existing toolbar in your workspace and select Node Caching.

 2. In the Node view, select the node or nodes for which you want to enable or disable caching.
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 3. In the Node Caching toolbar, click on  Toggle Node's Cache button.

The node's image output port will have an arc over it to indicate that it is cached.

How to enable or disable caching on a single nodes by editing its layer properties

 1. In the Node view, locate the node for which you want to enable or disable caching.

 2. Do one of the following:

 l Click on the  Layer Properties button near the left edge of the node to open its layer 
properties dialog.

 l Add the Layer Properties view to your workspace, then select the node to display its 
properties in this view. 

 3. In the top-right corner the node's layer properties, check on the Cached checkbox.

The node's image output port will have an arc over it to indicate that it is cached.
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Enabling Cache on Every Rig In a Scene
When a scene contains several character rigs, Harmony has to render the OpenGL preview of all character rigs 
from scratch every time a change is made to the scene. This can be especially burdening when working on a 
scene with an usually high amount of character rigs, as Harmony may require as much as a second each time 
the preview image is updated.

In such cases, it can be very useful to cache the scene's character rigs separately. Harmony will store a cache of 
each character, and use this cache to generate the preview image in the Camera view. When the user needs to 
edit, manipulate or animate a character, they can temporarily disable caching for that character, and re-enable 
it when they're done. Harmony will only need to update the preview image for that character, and will keep 
using the cached images of the other rigs in the scene to generate the preview image in the Camera view.

Caching every rig in a scene is easy, as it can done by simply enabling caching on the composite those rigs are 
connected to. When caching is enabled on a composite, instead of caching its entire output image, it will cache 
each of the input image that is sent to it individually. Hence, when caching is enabled on a composite to which 
several character rigs are connected, the composite will cache each character rig separately.

How to enable or disable                  rig caching                 using the Node Caching toolbar

 1. Add the Node Caching toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Node Caching.

 l Right-click on any existing toolbar in your workspace and select Node Caching.

 2. In the Node view, select the composite to which the scene's character rigs are connected.
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 3. In the Node Caching toolbar, click on  Toggle Node's Cache button.

Each of the composite's input ports will have an arc over them to indicate that they are cached 
individually.

How to enable or disable rig caching by editing its layer properties

 1. In the Node view, locate the composite to which the scene's character rigs are connected.
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 2. Do one of the following:

 l Click on the  Layer Properties button near the left edge of the composite to open its layer 
properties dialog.

 l Add the Layer Properties view to your workspace, then select the composite to display its 
properties in this view. 

 3. In the top-right corner the composite's layer properties, check on the Cached checkbox.

Each of the composite's input ports will have an arc over them to indicate that they are cached 
individually.
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Managing Cache Resolution and Size
When working on a scene with cached nodes or rigs, Harmony needs to keep bitmap images for each cached 
node or rig in your scene and for each frame in your scene. This can require a lot of memory. In order to be able 
to do this, Harmony creates a database of cached images in your computer's RAM. This database uses a set 
amount of memory which can be changed in your preferences, and which is set to 2048 MB (2 GB)by default. 

Once the cache database in your computer's RAM is filled up, Harmony creates another database on your 
computer's permanent storage device so that it can store more cached images. Past this point, Harmony will 
require more time to write to, and read from the cache, as storage devices are always slower than the RAM, 
which will impact its overall performance. Hence, it is preferable to keep the amount of cache Harmony uses 
under the beneath the limit set for the cache database in your computer's RAM.

The cache database on your computer's permanent storage device also has a limited size, which can also be set 
in your preferences, and which is set to 10240 MB (10 GB) by default. If this database gets filled completely, 
Harmony will simply stop creating new cached images, meaning that some of your cached nodes and rigs will 
not be cached, or will only be cached in the beginning of the scene but not at the end. 

There are two ways to manage the amount of memory used by node and rig caching:

 l Adjust the resolution of cached images. 

 l Change the amount of memory allocated for either the RAM cache or the storage device cache. 

How to change the resolution of cached nodes and rigs

 1. In the toolbar below the Camera view, click and hold on the  OpenGL Node Caching button.

 2. In the pop-up menu, select which resolution you would like cached images to have:

How to change the amount of memory allocated for the node cache 

 1. In the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(macOS) .

The Preferences dialog box opens.
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 2. Open the OpenGL tab.

 3. In the Rendering Caching section:

 l Set the OpenGL Node Cache Size in Memory field to the amount of RAM space you want to 
allocate to node caching.

 l Set the OpenGL Cache Size on Disk field to the amount of disk space you want to allocate to 
node caching.

 4. Click OK.
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Working with Node Caching
When an element or a rig is cached, it cannot be interacted with directly without temporarily disabling its 
cache first. Hence, project collaborators who must work with cached nodes and rigs must learn how to 
temporarily disable caching on elements and rigs they are working on. 

Temporarily disabling the cache on an element or a rig is easy. When you move your mouse cursor over a 
cached element with the  Transform tool selected, your mouse cursor will change to . Then, if you click on 
this cached element, caching will be temporarily disabled for it, allowing you to manipulate and edit this 
element as you would normally be able to.

Likewise, if you move the mouse cursor over any element in a cached rig, the mouse cursor will change to . 
Clicking on any element in a cached rig will temporarily disable caching for the entire rig, allowing you edit 
and animate it freely.

When you temporarily disable caching for an element or a rig, if any other element or rig in your scene had its 
cache temporarily disabled, it will be automatically cached again. Hence, when you want to start working on a 
different rig, you do not have to worry about manually enabling caching on the rig you were working on.

You can keep track of which elements and rigs in your scene are cached by looking at the arcs displayed over 
ports connected to cached elements and rigs. The arc use a colour code to indicate the status of the caching:

 l A blue arc means that the node or rig is currently displayed using its cached image in the OpenGL 
preview of the Camera view.

 l A  white  arc means that the node or rig is temporarily uncached, and that you can manipulate and edit 
it.

 l A red arc means that the node or rig does not have a cached image. Often, this is because:

 l The memory allocated to node caching is full—see Managing Cache Resolution and Size on page 
1324. 

 l The cached image for this node or rig is being generated right now. 

 l The node outputs an image, but it cannot be cached, i.e., the Colour-Card node.
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NOTE 

Even if the OpenGL Node Caching option of the Camera view is turned off, the arcs indicating that 
nodes or rigs are cached will still display in the Node view. They will still display a colour code 
indicating whether or not the nodes or rigs would be cached if OpenGL Node Caching was 
enabled. 
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Temporarily Disabling Cache on a Single Element or Rig

When an element or rig is cached, you cannot edit it or interact with it directly. You must first temporarily 
disable caching for this element or rig. 

Harmony will automatically disable caching on a cached element when you click on it. Likewise, Harmony will 
automatically disable caching on a rig when you click on any of its elements. 

If you select an element in another rig afterwards, Harmony will re-enable caching on the previously selected 
rig and disable caching on the newly selected rig instead.

How to disable cache on a single rig 

 1. Move your mouse cursor over any element in the cached rig.

If the rig your mouse cursor is over is currently cached, your mouse cursor will change to .

 2. Click on the rig.

Cache will be temporarily disabled on the rig. It is now rendered normally in the OpenGL preview 
of the Camera view. You can now select any element inside the rig and edit or manipulate it as you 
usually would. 

NOTE 

In the Node view, the arc indicating that an element or input image is cached will turn 
from blue to white when its cache is temporarily disabled. 
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 Temporarily Disabling Cache on Multiple Elements or Rigs

When you click on an element in a cached rig, Harmony temporarily disables caching for this rig. Then, if you 
click on an element in another cached rig, Harmony will re-enable caching on the previously selected rig, and 
temporarily disable caching on the newly selected rig. This logic ensures that at least all but one rig are 
cached, so that you do not have to manage which rigs are cached or not cached while working in a heavy 
scene. 

However, there may be cases where you need to work on multiple rigs simultaneously. For example, because 
caching a rig causes it to display as a flattened bitmap image in the OpenGL preview of the Camera view, if 
you're trying to animate two characters interacting with each other, always having one of them cached while 
manipulating the other ones may prevent you from animating their interaction with precision—see About How 
Node Caching Works and Its Caveats.

To circumvent this, it is possible to temporarily disable cache on multiple rigs by holding the Shift key and 
clicking on each rig you want to manipulate.

How to disable cache on multiple rigs

 1. Move your mouse cursor over any element in the first cached rig for which you want to temporarily 
disable cache.

If the rig your mouse cursor is over is currently cached, your mouse cursor will change to .

 2. Click on the rig.

Cache will be temporarily disabled on the rig. It is now rendered normally in the OpenGL preview 
of the Camera view.

 3. Move your mouse cursor over any element in the second cached rig for which you want to 
temporarily disable cache.

 4. Press and hold the Shift key, then click on the rig.

Cache will be temporarily disabled on this other rig, and cache will not be reeanbled on the 
previous rig.

 5. Repeat steps 3 and 4 for each rig for which you want to temporarily disable cache.

NOTE 

In the Node view, the arcs around the ports connected to the rigs for which cache is 
temporarily disabled will appear white, whereas the arcs for which cache is enabled 
will appear blue.
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Re-Enabling Cache on All Cached Nodes and Rigs

If you have temporarily disabled caching on one or several elements or rigs, you can instantly re-enable 
caching for all cache-enabled nodes and rigs in the scene using the Node Caching toolbar. 

How to re-enable cache on all rigs 

 1. Make sure the Node Caching toolbar is on your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbar > Node Caching.

 l Right-click on any toolbar in your workspace and select Node Caching.

 2. In the Node Caching toolbar, click on  Show Cached Preview.

Every rig and element in your scene for which cache was temporarily disabled will become cached 
again. 
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Disabling or Enabling Cache Globally

It is possible to disable or re-enable node caching globally using the  OpenGL Node Caching button in the 
toolbar below the Camera view. 

NOTE 

This option will persist after your close Harmony.

How to disable or re-enable caching globally

 1. In the toolbar below the Camera view, click on the  OpenGL Node Caching button to toggle it on 
or off.
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Chapter 13: Camera Set-up and Animation
T-HFND-009-001

Harmony contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis 
offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera 
position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field 
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the 
north-south (up-down) direction and the Z axis is the forward-backward direction.

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust 
the camera resolution and other parameters in the Scene Settings window. If you're working in a gaming 
animation pipeline, you also have to possibility to set an orthographic camera.

By default, a scene does not have a camera layer. In order to be able to tweak the camera's angle and position, 
you must add one to your scene. Although it is possible to have several cameras in the same scene, you can 
only view your scene using one camera at a time. This can be useful if you are still working on your scene 
composition and have different camera framing to try out.

The Camera layer is static which means that if you need to animate it, you must put it under a parent peg.
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You can reposition your camera frame directly in the Camera view, using the advanced animation tools. 
Another way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing 
this positions the camera precisely where you want it to be rather than gauging it visually.

Once you have a 3D set, the exciting part is to do a camera move in it. This section teaches you the main steps 
required to perform a 3D camera move. Once you know how to do this, you can enjoy the delights of working in 
3D space and traveling through your creations!

Clipping Planes

You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that 
range is visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be 
looking inside a 3D box or room and you might want the foreground wall to not obstruct the view of the 
interior. By default, the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.
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Camera Types

In Harmony, there are two types of cameras available:

 l Perspective

 l Orthographic

The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to 
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the 
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with the 
orthographic camera, by default, you need to create a new custom scene resolution.
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Adding a Camera
T-HFND-009-002

By default, there is no camera in the scene. The frame visible in the Camera view is only a reference based on 
your project's resolution. In order to position your camera, you must add one to your scene.

How to add a camera                                       in the Timeline view

 1. Do one of the following:

 l In the Timeline view, click the  Add Layer  button and, in the pop-up menu, select 
Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to add a camera in the Node view

 1. In the Node Library view, select the Camera node from the Favorites or Move category.

 2. Drag and drop the Camera node into the Node view.
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Setting the Camera Type
You can set your camera to either Perspective or Orthographic. The orthographic is specifically used for 
gaming. It removes any depth or perspective.

How to set the camera type

 1. From the top menu, select Scene > Scene Settings.

 2. Select the Resolution tab. 

 3. In the Projection section, select Orthographic or Perspective.
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Selecting the Active Camera
T-HFND-009-003

You can add multiple cameras to your scene, but only one can be active at a time. You can select your active 
camera from the Camera list.

How to select the active camera from the Camera list

 1. From the top menu, select Scene > Camera > camera.
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Positioning the Camera Frame
You can grab the camera frame and move it around in the Camera view. You can also setup the camera position 
by entering coordinates and values in the Layer Properties view.

How to reposition the camera frame in the Camera view

 

 1. Do one of the following: 

 l In the Advanced Animation toolbar, click the  Translate  tool.

 l From the top menu, select Animation > Tools > Translate. 

 l Press Alt + 2.

 2. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the 
camera layer from the Timeline or Node view.

The selected camera frame is highlighted.

 3. Drag the camera frame to a new position. 
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 4. To tilt the camera frame, do one of the following to select the Rotate tool:

 l From the top menu, select Animation > Tools > Rotate.

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 3.

 5. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

 6. To move the camera frame closer to or further away from the scene, do one of the following to select 
the Scale tool:

 l From the top menu, select Animation > Tools > Scale.

1342

Harmony 21 Premium User Guide                          



Chapter 13: Camera Set-up and Animation

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 4.

NOTE 

The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to set up the camera frame using the Layer Properties view

 1. In the Timeline view, select the camera layer.

 2. In the Layer Properties view, adjust the camera's properties.
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 3. Type or use the numeric stepper to adjust the coordinate and angle values—see the Reference 
guide .
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Resetting the Camera Position
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of 
the selected element to the initial value of the active tool. For example, if the Rotate tool is active, the 
transformation angle will be reset to 0 and if the Transform tool is active, then all parameters values will be 
reset.

How to reset the camera position

 1. In the Tools toolbar, select the Transform  tool or press Shift + T. If you want to reset a single 
parameter, select the corresponding Advanced Animation tool, such as the  Rotate  tool.

 2. In the Timeline, Node, or Camera view, select the camera layer.

 3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Setting the Camera Clipping Planes
You can modify how far and how close the camera can see by adjusting the clipping planes.

How to modify the camera clipping plane

 1. In the Timeline or Node view, select the Camera node.

 2. In the Layer Properties view, go to the Clipping Planes section.

 3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything 
behind this plane will no longer be visible.

 4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything 
behind this plane will no longer be visible.
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Locking Drawings to the Camera Angle
When you create a 3D camera move in your scene, notice that layers are treated as flat objects. That is, 
animation layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper. 
Use the Ortholock layer when mixing flat animation layers with a set built in 3D. Ortholock forces your 
drawing layer to always follow the Camera angle. It does not follow its position or zooming level, only the 
rotation. This prevents drawings from being distorted by the camera motion.

NOTE 

Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained 
inside a symbol does not consider the position of the camera contained in the root scene. Keep your 
Ortholock layers in the root scene.

How to add an Ortholock layer

 1. In the Node Library view, select the Move category.

 2. Select the Ortholock node and drag it to the Node view.

 3. In the Node view, drag an output cable from the Ortholock node and connect it to the node you 
want to keep facing the camera.
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Animating the Camera
T-HFND-009-009

A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view 
and you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is 
static, which means it keeps the same position and angle throughout the whole scene. In order to be able to 
animate the camera, you need to connect it to a peg layer, which can be animated, and which will directly 
affect the position and angle of the camera. 

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or 
Top views, which can be especially useful when animating a camera in a multiplane scene, where each layer is 
positioned at a different distance from the camera, or if your scene contains 3D models. 

How to add a parent peg to a camera                                    in the Timeline view                 

 1. In the Timeline view, select the Camera layer

.

 2. In the Layers toolbar, click the  Add Peg  button.

A Peg layer appears directly above the Camera layer and is automatically attached to it.

How to add a parent peg to the Camera in the Node view

 1. In the Node view, select the Camera node.

 2. Press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS).
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A peg node is instantly created and attached as the parent of the Camera node.

How to animate the camera

 1. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 2. In the Tools toolbar, select the  Transform tool or press Shift + T.

 3. On the right side of the Timeline view, on the Camera peg layer, select  the frame at which you want 
the camera movement to start.

 4. Do one of the following to add a keyframe:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 5. In the Camera, Top or Side view, manipulate the camera so that it is in the right position at the 
beginning of your camera movement.
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TIP 

To make a 3D camera movement, you can manipulate the Camera in the Top or Side 
view, in which it appears as a cone.                              

 6. On the Timeline view, click on the cell where the camera movement will end.

 7. Do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.
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 8. In the Camera, Top or Side view, manipulate the camera so that it is in the right position for the end 
of your camera movement. 

 9. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 10. In the Playback toolbar, click on the  Play  button to preview your animation.
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Creating 3D Camera Movements
If you want to view your 3D camera move, you must be in the Perspective view.

How to create a 3D camera move

 1. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 1. In the Timeline view, click the Add Layers  button and select Camera to add a camera to your 
scene.

 2. In the Timeline view, select the new camera layer.

 3. In the Timeline Layer toolbar, click the Add Peg  button to add a parent peg to the camera.

 4. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.

 5. In the Layer Properties dialog box, go to the Transformation tab and select the Enable 3D option.

 6. In the Rotation section, select the Quaternion option.

 7. In the Perspective view, click the Show/Hide Camera button to see your camera cone.

 8. Setup your workspace to display the Camera view and Perspective view at the same time so you 
can compare the results.

 9. In the Tools toolbar, select the Transform  tool.

 10. In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.

 11. In the Timeline view, select the Camera-Peg layer.

 12. In the Timeline view, go to the last frame.
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 13. In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only. 
Always do one axis at a time to keep control of the positioning.

 14. Once the camera is rotated at the correct angle, grab one of the direction arrows to move the 
camera to the correct position. A keyframe is automatically created in the Timeline view.
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Enabling the 3D Playback Mode
In order to see a playback of you animation in 3D, you need to turn on the option to see playbacks in the 
Perspective view.

How to enable the playback mode in 3D

 1. From the top menu, select Play > Enable Playback > Perspective View.

 2. In the Playback toolbar, click the Play button to see the results.
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Animating a Camera Shake Using the Quake Node
One very common camera move you will do is a camera shake. You can use the Quake node to generate an 
automated quake instead of manually entering random keyframes. This way, you can simulate the shock of 
something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake node to create a camera shake

 1. From the Node Library view, drag a Quake node to the Node view.

 2. If you do not have a Camera node already, drag one from the Node Library view to the Node view.

 3. Connect the Quake node to the Camera node.

 4. Click the Quake node's yellow square properties button to open the Quake properties.

 5. In the Quake properties window, adjust the following parameters:

 l Hold Time: Enter the number of frames you want one of the quake vibrations 
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(position) to hold for. Most camera shakes are done in a single frame (1) or double 
frame (2).

 l Interpolate: An interpolation is generated between the random values. Instead of 
jumping to the next position, it will slowly progress forwards to the next position. It's 
the same principle as stop-motion keyframes and motion keyframes.

 l Move Amplitude: This is the strength of the quake. The higher the value, the stronger 
the quake. If the value is set to 0, there is no  motion. To have the motion start and stop 
at a specific frame during the scene, you can create a function curve and animate the 
amplitude over time. Simply click the Function  button to generate the function, 
then click on it again to open the Function Editor.

 l Apply on X, Y, Z: Applies the quake to the X, Y and Z-axis.

 l Rotation Amplitude: When the value is higher than 0, a rotating quake is applied. 
The higher the value, the stronger the quake.

 l Random Seed: This parameter determines the pattern of random motions it uses to 
simulate shaking. There is no wrong  value for this parameter. Entering any value will 
simply make it uses a different random pattern. If you have two or more 
SnippetVariable1 nodes in your scene and they have the same Random Seed value, 
their shaking will be similar, if not exactly the same, as it will be based on the same 
pattern of random motions. Hence, you might need to assign different Random Seed 
values to all of your SnippetVariable1 nodes to make sure their motion pattern feel 
different. You should also assign a different Random Seed value to each 
SnippetVariable1 node if they make a shaking motion that goes on throughout 
several scenes so that it doesn't look like the motion pattern is repeating itself.You 
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can also change the value of this parameter just to make the SnippetVariable1 node 
use a different shake pattern, and see if you can find a pattern that fits your 
expectations better.
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Animating the Line Thickness on Camera Move
As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements become 
thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same size or become 
thicker at a different speed, you can use the thickness feature to adjust your brush stroke and pencil line 
thickness. You can modify the size of the lines even if the camera is not animated.

How to adjust the pencil line thickness of a drawing layer in the Camera view

 1. In the Camera view, enable Render View  to see the effects of the pencil line thickness settings. 

 2. In the Timeline view, double-click on a drawing layer to display the Layer Properties window.

 3. Select the Line Thickness tab.

 4. Ajust the following parameters to have the desired pencil line thickness in the current frame and 
camera position.

Adjust Pencil Lines Thickness: Enables the options below to adjust the line thickness in the 
rendered image. 

Normal Thickness:  This setting makes the line thickness adjustments take one of two very 
different behaviors:

 l Enabled: The line thickness settings are applied to pencil lines in all art layers in the 
element. This setting should be used if you want to adjust the line thickness of pencil 
lines. 

 l Disabled: The line thickness settings are applied to all art, whether brush strokes or 
pencil lines, in the line art layer, so that it fits the desired thickness pattern around art 
in the colour art layer. This setting should be used for drawings that have their line art 
on the line art layer and their colour art on the colour art layer, which is typical of 
traditional and paperless animation productions. 

NOTE 

When this option is disabled, all artwork in the line art layer that does not 
surround artwork in the colour art layer will be cropped out.
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Zoom Independent Thickness: Makes the thickness of pencil lines remain unchanged when 
the camera zooms in or zooms out. 

Proportional: The factor by which to adjust line thickness. The original line thickness in the 
drawing will be multiplied by this value. A value between 0 and 1 can be used to make 
pencil lines thinner. 

Constant:  The offset by which to adjust line thickness. This value will be added to the 
original line thickness in the drawing. A negative number can be entered to make pencil 
lines thinner. 

Minimum: The minimum pencil line thickness allowed. Line thickness will not go below this 
value.

Maximum: The maximum pencil line thickness allowed. Line thickness will not go above this 
value. Set it to 0 to disable maximum line thickness.

 5. To start animating the pencil line, create a function on one or more of the Proportional, Constant, 
Minimum and Maximum parameters by clicking on their corresponding Bezier  button, 
depending on which setting(s) would better accommodate the desired effect. 

 6. Click again on the parameter's Bezier button to open the Function Editor for that function.

 7. Use the Function Editor to animate the value of the parameter across the scene.
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Chapter 14: Character Rigging
Harmony is a great tool for building characters. You can use different techniques and features to break down 
your puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create 
very advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with 
those concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformations on page 1545.
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About Rig Types
T-RIG-001-001

A rig is the process in which you will take apart the multiple pieces of your character and then reattach them 
together to get them to move individually. Harmony provides you with a multitude of tools to help you build 
characters. From the simplest of rigs, to a fully rotating character. There are about as many ways to rig a 
character as there are individuals who make them. The complexity of the rig is often determined by the level of 
animation to be achieved.
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About Simple Rigs
T-RIG-001-002

Simple rigging is very fast and easy to do. It is built as follows:

 l All the body parts are independent

 l All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced 
by a parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a 
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the 
hand to move along a curved path.
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About Drawing Hierarchy Rigs
T-RIG-001-003

When you want one part to follow another part, such as the forearm following the arm, you can attach the 
layers one to the other. For example, you can attach the forearm layer to the arm layer without having to 
encapsulate the forearm into the arm layer. They will still be parented, but you can access the forearm directly 
without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to 
select them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, 
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is 
often a good solution.

NOTE 

To attach one layer to another, you must drag the desired layer onto the other one in the Timeline 
view.

Harmony offers powerful techniques to create hierarchies between your layers without having to 
encapsulate layers into each other. These techniques are a great improvement over the less 
efficient and time consuming method of creating parenting between your layers by inserting 
symbols into other symbols. Therefore, rigging with symbols inside symbols is NOT recommended.
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About Peg Hierarchy Rigs
T-RIG-001-004

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that 
do not contain drawings. They are motion paths that you can use to control your entire puppet or advanced 
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can 
scale a body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child 
layers that could be attached to that part. 

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer 
follow the same trajectory.
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About Scene Setup for Rigging
Planning your rig is an essential step in avoiding missteps at later stages. Once a rig has moved on to the 
animation level, it becomes more difficult to fix potential blunders, since updating the rig scene doesn't have 
repercussions on rigs outside of that scene.  These different topics will help you avoid such mistakes.
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About Models
To begin breaking down your puppet, you must first import your character into a new project. You can also 
draw your character directly in the scene.

You can import your character in several different formats: 

 l Library template—see Library & Templates

 l Bitmap image or picture

 l External vector format

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and 
scale it to fit inside the safe area frame.

If you have several views of your character, place each view in a separate cell and center them one on top of 
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the 
same size.
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Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. 
Then, import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all 
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any 
layer that is not in a folder group, by itself or otherwise, will not be imported.
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About Size Relation
Understanding the relative size of every character and prop is important for maintaining consistency and 
structure throughout your project.

A production may contain many characters and props. It is not unusual for these to have been created by 
different people. If there is no size control implemented, the characters and elements created by different 
artists can vary greatly in size. When this occurs, the characters that are put together in a scene will be out of 
proportion. The animator or person doing the scene setup will then have to scale them to the correct size.

When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is 
scaled to its proper size, the outline may be so thin that the difference between one character's outline and 
another's will not look very good.

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling 
them so they are in proportion with each other. This line up is very important and should be handed to any 
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body 
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually 
done during the character design step. When the character builder imports the model to the break down 
scene, the size relation should be correct.

Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can 
display the field chart using the Show Grid option in the Camera and Drawing views.
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How to display the field chart

 1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or ⌘  + ' (macOS).

‣ Click the Show Grid  button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good 
idea to create and save pens with precise sizes and parameters to trace and design your models and break 
downs—see About the Brush Tool on page 317.
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Setting Preferences for Rigging
 

Before you start adding layers to your puppets, make sure the Default Separate Position  for Elements and the 
Default Separate Position for Pegs preferences are enabled.

With the Default Separate Position preferences selected, when you create new layers, their X, Y and Z axes 
are independent from each other.

By default, the Default Separate Position for Elements preference is enabled. For cut-out animation, you want 
to have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at 
the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This 
gives you more freedom when animating with motion keyframes and nudging parts forward and backward 
over time.

How to set the Default Separate Position options

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l macOS: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. In the Preferences dialog box, select the General tab.

 3. In the Settings section, select the Default Separate Position for Elements and the Default 
Separate Position for Pegs options.
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 4. Click OK.
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About Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention chart 
before starting the project. When dealing with thousands of characters, pieces and puppets, it is easy to get 
lost. Proper naming of both drawing layers and drawing substitutions is essential to keeping your workflow 
consistent throughout your project.
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Naming Drawing Layers
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient 
in later steps. 

One common practice is to add one or two letters for the character/prop name, so that we don't make it too 
long. You can then add the name of the part that you've separated. It is recommended to add an indicator of 
the position of your character's symetrical pieces to keep track of which part you are selecting. Common 
practice is to add either "F" or "B" (for front and back view) or "R" or "L" (for right or left). Avoid using spaces in 
between the words and opt for an underscore instead.

 l Character Orcus's right arm = 

  OR_arm_F 

  or 

  OR_arm_R.

Pink: Front or Right 

Blue: Back or Left

In the event that you've forgotten to add a prefix or suffix to your character's drawing layers, you can add them 
after your layers have been created.

How to add a prefix or suffix to a series of layers

 1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

1375



 2. In the Scripting toolbar, click the Add Prefix or Suffix Script  button. If the Scripting toolbar is not 
visible, you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the 
Add Prefix or Suffix Script  button is not visible in the Scripting toolbar.

The Add Prefix or Suffix dialog box opens.

 3. Select the Prefix or Suffix option depending on what you want to add to the layers' name.

 4. Type the prefix or suffix information to be added to the layer's name.

 5. Click OK.

 6. The defined prefix or suffix is added to the selected nodes and layers.

How to remove a prefix of suffix to a series of layers

 1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

 2. In the Scripting toolbar, click the Add Prefix or Suffix Script  button. If the Scripting toolbar is not 
visible, you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the 
Add Prefix or Suffix Script  button is not visible in the Scripting toolbar, see the Scripting guide.
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The Add Prefix or Suffix dialog box opens.

 3. Select the Prefix or Suffix option depending on what you want remove from the layers' name.

 4. Type the prefix or suffix information to be deleted from the layer's name.

 5. Click OK.

 6. The defined prefix or suffix is removed from the selected nodes and layers.
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Naming Drawings Substitutions
We recommend that you use a naming convention for your drawings. Especially if you combine all the angles 
of a character in the same breakdown scene, it is a good idea to identify each angle used.

Before breaking down the characters for your production, we recommend that you create a drawing name 
convention that represents the angle used. For example, use "f" for front, "s" for side, "q" for three-quarter so 
that the drawing name looks like this: f1, f2, f3, s1, s2, etc. This will be quite useful during animation and 
drawing substitution. Since drawings are displayed in alphabetical and numerical order, all the drawings for 
the front view will be together, then all the drawings for the three quarter view, and so on.

Keep in mind that in the drawing substitution library, drawings will show in alphabetical order. If you want 
them positioned in a certain order, make sure you name them accordingly.

How to add a prefix to one or more drawings

 1. In the Timeline view, select the drawing range to rename.

 2. Do one of the following:

‣ Right-click on the selection and select Drawings > Rename Drawing with Prefix.

‣ From the top menu, select Drawing > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.
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 3. Type the characters you want to add before the current drawing name.

 4. Click OK.

NOTE 

To rename a drawing, select the drawing and use the Rename Drawing option. Ctrl + D 
(Windows/Linux) or ⌘  + D (Mac OS X). or . Do not double-click on the frame and write a new 
name, as this will create a new drawing and hide your actual one. Note that the hidden 
drawing has not been deleted and is still located within the element folder. Simply retype the 
name and it will reappear.
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About Character Breakdown
T-RIG-001-006

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what 
parts will be broken apart and how they will be divided. Will the hair be separated into one, two or three 
sections? Will the hand be separated from the sleeve? To determine what is best for your character, observe 
the model in the Camera or Drawing view.

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil 
and the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of 
the eyeball. For a more advanced break down, the two eyes are separated on their own individual three-layer 
sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth 
shape, teeth, tongue and interior one from another.
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Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full 
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and 
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a 
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly overlapping 
and complete. A common mistake is to trace the part just as it appears on the model.
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Tracing the Model
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + 
R (Windows/Linux) or ⌘  + R (macOS) to add new drawing layers.

 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select the drawing tool of your choice. There are two commonly used methods 
to drawing the parts of a cut-out character model:

 l Using the  Pencil tool, then smoothing your lines with the  Smooth Editor tool

 l Using the  Polylinetool. This method allows you to draw with great precision, but 
may take more time.

These methods ensure each part is made with as few points as possible, so that they are easy to 
manipulate, modify or redraw.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see 
About Palettes on page 680.

 5. If you prefer working in the Drawing view, do one of the following to display the other layers in 
washed out colours:

 l In the Drawing view toolbar, lick the  Light Table  button.

 l Press Shift + L.

 6. In the Camera or Drawing view, draw the new part.
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 7. If you want to close an open shape without drawing a visible outline, you can draw an invisible line 
using the  Stroke  tool.

NOTE 

By default, strokes created with the Stroke tool are not visible. To see strokes in your 
drawing, select View > Show > Show Strokes from the top menu or press K.

 8. In the Tools toolbar, select the  Paint or Paint  Unpainted  tool to colour your drawing.

 9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 10. In the Camera or Drawing view, paint your drawing.
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 11. In the Tools toolbar, select the  Select tool. Select your drawing and flatten the lines by clicking 
the  Flatten  button in the Tool Properties view.

 12. If your lines are composed of several pencil strokes, you might want to combine them into one single 
smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool 
Properties view, click the  Merge Pencil Lines button.

 13. Repeat the entire process for every body part that you wish to make animatable. 
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About Cutting the Character into Pieces
If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with 
the Cutter tool, you select and send pieces of the model on a new layer.

The first step in breaking down your character is to do a rough cut down of the main parts, such as the body, 
arms, legs and head. Using the Create Drawing from Drawing Selection feature lets you automatically create 
layers and copy your selection in it.
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Breaking Down the Main Parts

To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. 

Breaks a character into its main body parts. There is no need to create any layers prior to this process. Make 
sure your model is well centered and sized in the Camera view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the 
artwork of the part you want to break down. You will clean the extra bits and pieces later.

Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines 
and colour zones.

How to break down the main parts

 1. In the Timeline view, select the cell of the model that corresponds to the first view to break down.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or 
press Alt + S.

 l In the Tool Properties view, you can switch to the Lasso  selection mode.

 3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the 
Cutter tool will select the zone. It will end the selection at the first point of intersection that it 
meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your previous 
selection.
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 4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.

 5. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

 6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

 7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

 8. Repeat the previous steps for each main body part.
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Breaking Down Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You are now 
ready to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this time you 
will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts

 1. In the Timeline view, lock your model layer by clicking its Lock  button.

 2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

 3. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press Alt 
+ S.

 4. In the Camera view, create a selection around the part to break down.
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‣ If you click on a zone, the Cutter  tool will select the zone and end the selection at the first 
point of intersection that it meets. Click on the line with the Cutter tool to select it up to the next 
intersection.

 5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.

 6. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

 7. Select the Cut Artwork From Source option to remove the selected artwork from your original 
drawing. In this case, you want to cut the artwork from the colour model.

 8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

 9. Repeat the previous steps for each body part.
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NOTE 

If you forgot to add some artwork to a layer you previously created, you can always add it later. 

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing 
from Drawing Selection dialog box by pressing F9 (Windows/Linux) or ⌘  + F9 (macOS). In the 
dialog box, select an existing layer from the list instead of typing a new name. Click OK to add the 
artwork to the existing drawing in the layer you selected.
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Breaking Down Other Views

If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

 l Breaking down the new view in a new set of layers

 l Breaking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are 
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Repeat the following steps for each extra view you need to break down.

How to break down the other views

 1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't 
forget to unlock the layer.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, in the Tools toolbar select the Select  tool or press Alt + S.

 2. In the Camera view, create a selection around the first part to break down. 

 3. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.
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 4. In the Layer Name field, select the corresponding layer from the list if you want to use the same 
layers or type a new name if you want to create a new layer.

 5. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

 6. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as 
the cell it was taken from. It is not incorporated in the other view's drawings.

 7. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views

To break down the secondary parts for your extra views, follow the exact same process as you did for the first 
view you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down Other 
Views on page 1395.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to 
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing Parts and Articulations

Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and 
complete the articulation.

Cleaning the Parts

You will need to use a series of drawing tools to clean the parts:

 l  Brush tool

 l  Eraser tool

 l  Select tool

 l  Cutter tool

 l  Contour Editor tool

 l  Paint tool

 l  Close Gap tool

How to clean your drawings

 1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

 2. In the Timeline view, select the cell containing the drawing to fix.

 3. In the Camera view, delete the extra bits using the Select  or Cutter  tool. You can also use the 
Eraser  tool.
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 4. Draw the missing lines using the Brush  tool. If you use the Brush tool, it is recommended that 
you enable the Auto-Flatten  option in the Tool Properties view.

 5. Using the Paint  tool, paint the gaps. You can close some gaps with invisible lines using the 
Close Gap  tool or press Alt + C.

 6. Reshape your lines using the Contour Editor  tool or press Alt + Q.

 7. Using the Select  tool, select the entire drawing and click the Flatten  button in the Tool 
Properties view to flatten your drawings.
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 8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be 
present in your drawing or press K.

 9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any 
unnecessary invisible lines in the drawing.

 10. Repeat this entire process for each drawing to fix.
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Distributing to Layers
When breaking down a character, you can distribute each selected art stroke to a new layer. 

Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke. 

If one part of your puppet is composed of several strokes, you must group them before distributing them onto 
new layers. 

NOTE 

You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the art strokes you want to distribute to different layers.

 3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers  
button in the Tool Properties view.

Drawing layers are created in the Timeline view, each corresponding to the different strokes or 
groups of strokes selected. Each stroke or group of strokes is distributed into each new Drawing 
layer. The selected strokes in the original drawing layer are removed.
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About Articulations
Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move 
properly and will not look good.

If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect 
will create the joint for you.
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Creating Classical Articulations

Classical articulation is the most popular technique for basic characters. It is quite simple and produces 
excellent results, but it's not the most efficient method. In many instances, it causes limitations and extra 
drawing corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design 
is usually a circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping 
the bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

 1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the 
upper arm.

 2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor  
tool.

 3. In the Colour view, select an outline colour.

 4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part 
in a half-circle shape.

If you are working in the Drawing view, click the Light Table  button in the Drawing toolbar or 
press Shift + L.

 5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines 
that may be present in your drawing.

 6. In the Drawing or Camera view, select all the strokes in your drawing.

 7. In the Tools Properties view, click the Flatten  button.

 8. In the Drawing or Camera view, select all the strokes in your drawing.
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 9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary, 
invisible lines in your drawing.

 10. Repeat the previous steps for the other articulations.

 11. In the Timeline  view, select the cell of the part that will be on top of the joint.

NOTE 

When placing rotation pivots later on, make sure they are positioned at the 
centre of the articulation.
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About Auto-Patch Articulations

Harmony has a very efficient node to automatically patch an articulation without you having to do any line 
adjustment or colour overlapping. You can draw your two pieces with their complete lines overlapping each 
other in semicircles and the Auto-patch node will create a perfect articulation from it.

In order for the Auto-patch to work on your puppet, you must draw the outline with the Pencil tool (pencil 
lines) on the Line Art layer of your drawing, and then paint the colour on the Colour Art layer.

You can use this technique in even more efficiently by adding extra lines in the Overlay layer of your drawing 
to create a fold illusion for a bent elbow.
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About the Auto Patch Node

The Auto Patch node is used mainly when creating joint patches for cut-out puppets drawn with pencil lines 
and painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a 
seamless joint, you can draw complete pieces, and with the Auto Patch node, automatically create a perfect 
articulation.

The requirements for this effect to work are:

 l Drawing outlines must be drawn in pencil lines

 l Drawing outlines must be drawn in the Line Art layer

 l Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when 
you paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.

1406

Harmony 21 Premium User Guide                          



Chapter 14: Character Rigging

When using the regular patch technique, recommended for the brush line, the result with pencil lines is very 
odd looking because the colour fill zone is bigger than the pencil line inner contour.

Instead of using the regular patch method, you can use the Auto Patch node. It will automatically extract the 
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.

The node connection for the Auto Patch is quite simple. Once your basic character rigging is done, add the 
Auto Patch node to the joints you want to cover. There is no need to set any parameters. 

Refer to the following example to connect this effect:
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About Ordering Layers
T-HFND-005-005

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level 
in the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind. 
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same 
layers (front, three-quarter, back, etc.).
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Ordering Layers in the Timeline View
T-HFND-005-006

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be 
displayed behind. If you have multiple views, you should order your layers based on the most common view, 
which is generally the three-quarter front.

How to order layers

 1. In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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Ordering Layers in the Node View
T-HFND-005-007

The Node view allows you to reorder layers without breaking any hierarchy. For example, if you want the Head 
layer to appear behind all the facial features, in the Timeline view, you cannot simply move the layer down 
because you will break the parenting between the head layers. In the Node view, since you have a set of 
flexible connections, you can change the Composite node ordering without breaking the parenting between 
the nodes.

The Composite node ordering corresponds to your timeline ordering unless the Node view's organization is too 
complex for the Timeline view to display. The element connected in the left-most port of the Composite node 
is displayed in front in the Camera view and the one connected in the right-most port is displayed behind.

How to order layers in the Node view

 1. In the Node view, select the node's output cable connected to the Composite node and drag it to its 
new position.
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About Z Nudging
T-HFND-005-008

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as 
the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break 
the hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE 

You will do the same for the layers that are not in the right order on the extra views. Do not place 
the drawing on another layer. You want to keep all your drawings of the body parts in the same 
layers like a box containing all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:

 l Up and down (Y-axis)

 l Left and right (X-axis)

 l Backwards and forwards (Z-axis)
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Nudging Layers

T-HFND-005-009

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be 
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the 
Timeline view. The forward-backward position can also be animated over time.

How to nudge layers backwards and forwards

 1. In the Tools toolbar, select the Transform  tool. 

 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is 
around the Camera view before selecting the element.

 4. To move the element forward,  press Alt + Up Arrow and to move the element backward,  press Alt 
+ Down Arrow.
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About Pivots
T-RIG-006-001

Even with a complex hierarchy, a rig is useless without positioning the proper pivot points. This will allow the 
puppet's pieces to rotate correctly. The arm needs to rotate from the shoulder and stay attached to the torso, 
so its pivot point needs to be positioned accordingly. A good way to achieve this is to position the pivot point 
exactly in the center of the articulation.

The initial position of the pivot point is always at the center of the scene. Sometimes there will not be an 
obvious place of rotation to place the pivot point, but it's a good idea to reposition the pivot to the best 
transformation point. For instance, the master peg, which generally controls the entire rig, is often best 
positioned between the character's feet.
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About Permanent Pivots
T-RIG-006-002

This is a permanent pivot, sometime referred to as peg pivot, that is applied to the entire drawing or peg layer. 
If you modify its position, it will be changed for the entire layer, modifying the animation, scale and rotation 
interpolation. The permanent pivot is set using the Rotate, Translate or Scale tool. The Transform tool will only 
move that pivot temporarily for positioning purposes, but the animation interpolation will be done from the 
original permanent pivot's position. The Transform tool is designed to move the pivot temporarily during the 
animation process. It also permits you to select multiple pegs and apply a common temporary pivot.

To permanently move a peg pivot, use the Rotate  or Scale  tool. You can also directly type the values in the 
Layer Properties window in the Pivot section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select the Don't Use Embedded Pivot option to 
use the permanent pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate  
tool.
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Setting Permanent Pivots

T-RIG-006-004

In this section, we'll take a look at one of the options we have for setting pivots. The permanent pivot allows 
you to push your rigs to great lengths without having to worry about repositioning your pivot once it is set.

How to set the pivots with the Rotate tool

 1. In the Advanced Animation toolbar, select the Rotate  tool.

 2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, 
you can also hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on the piece whose pivot you 
want to set.

 3. In the Camera view, drag the blue pivot to reposition it.

 4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as 
where to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE 

If you added other pegs to your rig, you must set their pivot using the same 
method.
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Setting Multiple Permanent Pivots

You can simultaneously set the position of pivots for several drawing layers or pegs  that you would like to 
rotate and scale from the same point of origin, 

How to set pivots on multiple pegs

 1. Select the multiple pegs or drawing layers from either the node view or timeline view.

 2. Select any Advanced Animation tool, such as the  Rotate tool. 

 3. Reposition your pivot using the Advanced Animation tool

NOTE 

Never use the Transform tool to permanently position pivots. The Transform tool only 
temporarily repositions it to accommodate your transformation, usually during the animation 
process.
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About Drawing Pivots
T-RIG-006-003

The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If you 
have many different views of a character within one layer, the pivot positions can be different and the 
animation will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not 
mixing different views within the same layers or are using pegs to animate your layers, it is recommended to 
use the permanent pivot.

You can set a different pivot for each one of your drawings. For example, if you have a series of drawings from 
different views, they are not likely to rotate from the same location. In that case, you can set a different pivot for 
these drawings by using the Drawing Pivot  tool.

In the Layer Properties window, in the Drawing Pivot section, select the Apply Embedded Pivot on Drawing 
Layer option to use the drawing pivot directly on the drawing layer. If you want to apply the drawing pivot to a 
parent peg to force the peg to follow the drawing pivot variations, enable the Apply Embedded Pivot on 
Parent Peg option.
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Setting  Multiple Drawing Pivots

If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same 
drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot 
all at once. If your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other 
drawings in the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing 
while the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range

 1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on 
hand-1.

 2. In the Timeline view, select the cell that contains the correct pivot.

 3. From the top menu, select Edit > Copy.

 4. In the Timeline view, select the cell range that requires the same pivot.
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 5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B 
(macOS).

The Paste Special dialog box opens.

 6. In the Paste Special dialog box, select the Advanced tab.

 7. In the Drawings section, select the Update Drawing Pivot option.

 8. Click  OK.

NOTE 

You can also copy and paste the pivot from one drawing to another using the 
keyboard shortcuts Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V 
(macOS) when the drawing pivot tool is active and the focus is around the 
Camera view.

1420

Harmony 21 Premium User Guide                          



Chapter 14: Character Rigging

About Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same as 
the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each drawing 
can have its own pivot. If you are not mixing different views within the same layers or are using pegs to 
animate your layers, it is recommended to use the Peg pivot.
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Setting Symbol Pivots 

If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the articulations. You can 
set the pivots using the Rotate tool which sets it for the entire layer or you can set the pivots directly on your 
symbol and have a different pivot for each symbol cell. By default, when you create symbols, the symbol pivot 
is located at the centre of your drawing. You will need to move it onto the shoulder or elbow.

You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must be at the 
top level of your character building scene and not inside the symbols.

By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different pivots 
for different cells, refer to the following procedure.

Do the following steps for each layer in the Timeline view.

How to set the pivots on a symbol

 1. In the Tools toolbar, select the Drawing Pivot  tool or select Drawing > Tools > Drawing Pivot.

 2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.

 3. If you only want to set one pivot for your symbol, in the Tool Properties view, select the Set the 
Pivot for Symbol on All Frames  button.

 l Deselect this button if you want to set a series of different pivots for your symbol's 
cells.

 4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the 
desired location.
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 5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and 
in the Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the drawings directly.

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. 
This allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the 
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to 
create a hierarchy of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 

NOTE 

It is also possible to make a drawing layer the parent of another drawing layer. Just like the way 
animating a peg animates its children layers, animating a drawing layer with children will also 
animate its children layers. Both layers will still appear in the animation as long as they are also 
connected to your scene's composite.

How to create parent pegs for your layers in the Timeline view

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Peg button to add a parent peg to all selected 
layers.
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When creating layers or pegs in the Timeline view, your Node view may look tangled up. 

 3. In the Node view, select all the nodes and, in the  Network View toolbar, click the Order Network 
Down  button.

How to create parent pegs for your layers in the Node view

 1. From the Node view, select all the drawing layers for which you want to create pegs.
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 2. Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X)

 3. Pegs are created, named and connected to their child drawing layers. They will not automatically 
connect if the top port of your drawing layer is already connected to another node.

 4. If the nodes are tangled,  select all the nodes and, in the  Network View toolbar, click the Order 
Network Down  button.
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Disabling the Animation on Drawing Layers
By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to switch 
your drawings so they can no longer be animated without a peg has certain advantages. It means that you can 
access the drawing substitution feature for this drawing layer, while being able to create keyframes on its 
parent peg. This feature is also available for backward compatibility when bringing in templates created in 
older versions of Harmony, so as not to lose their offset keyframes or drawing substitution keyframes. 

When selecting the element in the Camera view, the actual drawing layer is selected, but the motion you will 
create will automatically be transposed to the peg layer. You cannot animate (add keyframes) directly onto the 
drawing layer if the option is disabled. You will still be able to perform certain offset movements in the 
Transformation tab of the Layer Properties, but not using any of the animation tools in the Tools toolbar.

There are two ways to disable animation on drawing layers, via the Layer Properties window and the 
Preferences dialog box. When you disable animation in the Layer Properties window, it affects only the 
selected layer and not any others.

If you prefer this style of animation and want every drawing element that you create to not be animated, you 
can disable the Element Node “Animate Using Animation Tools” Default Value preference. This will  disable 
the Animate Using Animation Tools option on all the new layers you will create from that point on so you don't 
have to do this through the Layers Properties window for every layer. It is recommended to disable this 
preference before starting a new character rig.

How to disable animation on a single layer

 1. In the Timeline view, double-click on a layer.

The Layer Properties dialog opens.

 2. Open the Controls tab.

 3. Uncheck the Animate Using Animation Tools option.

Notice that the layer functions are no longer available in the Timeline view.
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How to disable animation for several drawing layers

 1. In the Timeline or Node view, select all the Drawing layers/nodes for which you want to disable 
animation.

 2. In the Node View toolbar, click on  Set Properties on Many Layers  button.

The Set Properties on Many Layers dialog appears.
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 3. Set the Animate Using Animation Tools option to Off.

 4. Click on the OK button.

How to disable animation for all new drawing layers

 1. In the top menu, select Edit (Windows/Linux) or Harmony Premium (macOS) > Preferences.

The Preferences dialog opens. 

 2. Select the Advanced tab.

 3. Uncheck the Element Node "Animate Using Animation Tools" Default Value option.

 4. Click on the OK button.
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Creating Hierarchies
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should 
influence other limbs, and how they can move independently. For example, when rigging a simple character's 
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. 
This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm 
and hand will follow. 

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can 
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig 
the legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want to make a child layer.
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 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you 
are not dropping the child layer between two layers. 

 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
your rig can serve as that parent, create a new peg and nest those layers under that peg.

NOTE 

In the Timeline view, you can unparent layers by holding down Shift, dragging the selected 
parent away from the child layer and dropping it somewhere else in the list.

How to create a hierarchy in the Node view

 1. Position your nodes as if they were in a tree representing their intended hierarchy, with the highest 
nodes on top and the lowest nodes at the bottom.
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 2. Drag a cable from the output port (bottom) of a node which you want to make into a parent node.

 3. Connect the cable to the input port (top) of the node which you want to make into its child node.

 4. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
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your rig can serve as that parent, create a new peg and nest those layers under that peg.

NOTE 

In the Node view, you can unlink nodes from their parent and child by holding down the Alt 
key and moving them anywhere in the node view. This will delete the node's connections 
instantly. If the node has both a parent and a child, this will automatically connect its former 
parent to its former child.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they 
are rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Likewise, in the 
Node view, layers that are connected to the leftmost port of a composite are rendered on top of layers 
connected to ports to the right. Should you need to change a layer's order while animating, you can nudge this 
layer's position on the Z-axis to override the layer order and force it to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.

 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the 
focus on the Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.
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Adding the Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows 
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is 
useful for positioning and scaling your character relative to the scene, as well as to animate your character's 
trajectory when it has to move between areas of the scene.

How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the  Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that your 
top layer is already a child of the peg, so don't include it in your selection.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your 
layers are added above the already parented layers, move that parented layer back on top of the 
layer stack.

1434

Harmony 21 Premium User Guide                          



Chapter 14: Character Rigging

How to add a master peg in the Node view

 1. In the Node view, hold Ctrl (Windows/Linux) or ⌘  (macOS) and select each node that you want to 
attach to your new peg.

 2. Do one of the following:

 l From the Node view menu, select Insert > Peg.

 l Press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS).

 3. Rename the new peg Master plus the character's name. 
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Fine-Tuning the Rig
Once your rig is done, you have access to a lot of tools and tricks that you can add to make your rig even more 
efficient. Colours that can help you distinguish certain layers, or parts of your node view, cutter systems and 
much more. For more great options and features on creating powerful rigs, refer to Deformations.
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Invert-Cutting
When rigging a character, there may be instances when you want to have the ability to move a particular 
piece to give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit 
of the drawing sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't 
want to be visible.

How to mask an object in the Node view

 1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece 
to cut.

 2. From the Node Library view, select the Favorites category and then select the Cutter node.

 3. Drag the Cutter node to the Node view.

 4. Connect the object you want to cut to the Cutter node's right port and connect the Cutter to the 
Composite node.

1437



 5. Pull out a cable from the masking object and connect it to the Cutter node's left port.

 6. Your masking effect is most likely inverted and what you want to cut is probably showing. Click the 
Mask node's yellow button to open the Layer Properties window. In the Layer Properties window, 
enable the Inverted option.

 7. From the Tools toolbar, select the Transform  tool and move the cut object within the masking 
zone.
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Changing Composite Modes
When you create a character with Harmony, you have to connect all your nodes in the Composite node. The 
Composite node takes all the different images coming out of your drawing nodes and flattens them into one 
single image.

This is useful when it is time to apply an effect to your entire character or group your layers for a more 
organized network.

The regular Composite node will flatten all the pieces into one image preventing interaction with props or 
characters connected to a different Composite node. That is why you have to change the Composite node's 
type to a special one that will still output one single image but will not flatten the drawings together. This will 
allow you to nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind 
other characters and objects. This Composite type is called Pass Through.

How to change your Composite node to a Pass Through

 1. In the Node view, click on the Composite node's Properties button.

The Layer Properties dialog box opens.

 2. From the Mode menu, select Pass Through.

 3. Click Close.
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Adding Displays
The Display node lets you see a section of the network in the Camera view. By renaming the Display node with 
your character's name, you can quickly identify it in the Global Display toolbar and isolate your character to see 
it better while working on it.

If you do not have a Display node in your network, you can add one by selecting one from the Node Library 
view and dragging it into the Node view.

How to add a Display node

 1. In the Node Library view, select the IO tab and select the Display node.

 2. Drag the node to the Node view.

 3. Connect the Composite node's output port into the Display node's input port.

How to rename your Display node

 1. In the Node view, click on the Display node's Properties button to open the editor.
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 2. In the Layer Properties window, rename the Display node with your character's name.

 3. Click Close.
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Grouping Rigs
Once your rigging is completed, you must group the puppet's skeleton to help organize the often large and 
complex networks. This way, once you have imported two or three characters into the scene, three Group 
nodes will be displayed instead of all the rigging connections of three puppets.

How to group nodes

 1. In the Node view, select all your nodes.

 2. In the top menu, select Edit > Group > Group Selected Layers  or press Ctrl + G (Windows/Linux) or 
⌘  + G (macOS).

Your nodes are grouped.

 3. Click on the Group node's right arrow to enter the group.

 4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select the 
Group category and select a Multi-Port Out node.
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 5. Drag the Multi-Port-Out node to the Node view.

 6. Connect the Composite node's output port into the Multi-Port Out node. 

An output port is created on your Group node.

 7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should 
now see an output port on your Group node.

 8. Click on the Group's Properties button to open the Layer Properties window.

 9. In the Layer Properties window, rename the Group node with your character's name.

 10. Click Close.
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Creating Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to 
create all of the function curves and block your pose in place.

How to create the keyframes

 1. In the Timeline view, collapse the master peg by clicking the Expand  arrow.

 2. In the Timeline view, select the first cell.

 3. Do one of the following:

 l From the top menu, select Insert > Keyframe. 

 l In the Timeline View toolbar, click the Add Keyframe  button.

 l Press F6.

NOTE 

If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates 
a keyframe but also duplicates a drawing.
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About Pose Copier
T-RIG3-007-001

The pose copier is a scrip that can be added to your Scripting toolbar. The goal of the Pose Copier is to facilitate 
the reuse of poses from a master template by taking information from it and pasting it at the desired frame. It 
does not create  new information outside of what is contained in the template.

In order for the Pose Copier to work, templates need to be set up properly to maximize the compatibility of the 
script. It is recommended to keep only the frames that will be needed. Empty or unused frames may appear 
within the sliders.

For a simple use of the script, create a template of the part that you wish to use with the pose copier. It could be 
the entire character, the head, the lip sync or any other part. It is recommended to template groups as opposed 
to scattered individual nodes. To maximize compatibility, keep the hierarchy of your template identical to the 
hierarchy of your rig.  

You can also create an advanced setup to select specific frames using guide layers—see About Guide Layers on 
page 1449. 

NOTE 

To learn more about the Pose Copier dialog box, see the Reference guide .
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Adding the Pose Copier Script to the Scripting Toolbar

T-RIG3-007-002

To use the Pose Copier, you need to add the script to the Scripting toolbar.

How to add the Pose Copier script to your Scripting toolbar

 1. Select Windows > Toolbars > Scripting to display the Scripting toolbar.

 2. In the Scripting toolbar, press the Manage Scripts  button to open the Scripts Manager.

 3. In the Files section, select the TB_Pose_Copier.js script file. 

 4. In the Functions section, select TB_Pose_Copier function. 

 5. Press the Add Script to Toolbar  button to send it to the Scripting toolbar.

 6. Press OK to close the Script Manager.
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About Guide Layers

T-RIG3-007-003

The guide layers are ordinary drawing layers named in a way that will associate them with the 3 sliders of the 
pose copier. These layers will need to be incorporated inside the template for the sliders to work when 
activating the pose copier script. 

You need to create three drawing layers for the three sliders to work. These will need to be named accordingly 
including a dash character. Suffixes may be added after the dash for additional information as seen in the 
example above.

 l slv- for the vertical layer that will be used for the tilt

 l slh- for the horizontal layer which will be used for the turn

 l slx- for the second horizontal layer that will be used for the lipsync

In those guide layers, you will need to create empty drawing cells. These frames will represent the different 
slider positions to which you will have access in the pose copier. The guide layer frames need to match the 
character's frames if they are to show an accurate view of the information that will be pasted.

In the example above, the slh (horizontal) slider contains 5 frames. The horizontal sliders are read in 
alphabetical order from left to right. You can add numbers to display them in the desired order.
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 l 1front 

 l 2quarter-front 

 l 3side 

 l 4quarter-back 

 l 5back 

The slv (vertical) slider contains 3 frames. The vertical slider works in alphabetical order from the way down 
and moving up, hence the numerical prefix.  

 l 1down 

 l 2mid 

 l 3up 

The slx (expression) slider contains 5 frames. Each of these frames holds different combinations which will be 
used for the different sliders to access the frames of the template. 

 l A 

 l B 

 l C 

 l D 

 l E

For example, setting the slh (horizontal) slider to 1front, the slv (vertical) slider to 3down and the slx 
(expression) slider to B will display a front pose, looking down, using the B mouth. 

NOTE 

To learn more about the Pose Copier dialog box, see the Reference guide .
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Creating Guide Layers

T-RIG3-007-004

For each template, three guide layers can be created to associate with the three sliders of the pose copier. 

How to create guide layers 

 1. With your rig open, go to the Timeline view, click the Add Drawing Layer  button or press Ctrl + 
R (Windows/Linux) or ⌘  + R (macOS) and create 3 new drawing layers. You may also create those 
nodes in the node view or x-sheet view.

 2. Name the prefix of each drawing layer based on the different sliders. The suffix can be anything to 
identify the sliders. The dash must be included within the name in order for the sliders to work.

‣ slv- for the vertical slider

‣ slh- for horizontal slider 1

‣ slx- for horizontal slider 2

 3. Based on the rig of your character, select each layer one at a time and click on the  button to 
create new empty drawing at the desired frame. The frame's location will be shown on the slider of 
the pose copier.

 4. Select the drawing cell and rename it with the desired information by doing one of the following.

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X) 

‣ From the timeline, right click on the cel and select Drawings > Rename Drawings...

 5. Extend exposure up to the next position on the timeline that you wish to include in the sliders.

 6. Reuse frames by selecting frames from the Drawing Substitution display in the Library view.

For more information about guide layers, see About Guide Layers on page 1449.
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Creating a Pose Copier Template 

T-RIG3-007-005

The pose copier template is a regular template of assets that will be used to copy and paste information from 
the template over to a scene. Guide layers may be used inside of the pose copier template as additional 
efficiency tools for selecting your pose.

How to create a Pose Copier template

 1. In the Node view or in the leftmost section of the Timeline view, select the nodes intended to make 
the template.      

If you have created guide layer nodes, make sure to include them in the selection as well.

 2. Copy the selection using one of the following: 

‣ Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

‣ From the top menu, select Edit > Copy.

 3. In the Library view, select a folder to store the template.

 4. If a library folder is locked, right-click and select Right to Modify.

 5. With the folder selected, paste the selection into the folder using one of the following: 

‣ Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

‣ From the top menu, select Edit > Paste.

 6. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename. 

 7. Click OK.

 8. Right-click on the template and select Generate Thumbnails.

You will see a preview of your template in the Drawing Substitution area of your Library view. The 
thumbnails are the images used inside the Pose Copier, therefore it is essential to do this before 
using the Pose Copier the script. Once this step is completed, the thumbnails are stored within the 
template. You will not need to do this again unless you recreate your template.
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Pasting Poses Using the Pose Copier 

T-RIG3-007-006

Once the templates have been created and set up properly, it is easy to paste a variety of poses from one or 
multiple templates onto a still character awaiting posing. 

Depending on how the template has been set up, a different destination has to be set up in order for the 
pasting to take place.

How to Set the Default Destination with the Pose Copier script.

 1. In the Library view, select the template you want to copy poses from.

 2. If it was not done previously, right-click on the template and select Generate Thumbnails. 

The thumbnails are generated and showing in the Drawing Substitution View.

 3. With the template still selected, run the TB_Pose_Copier script by clicking on it in the Scripting 
toolbar—see Adding the Pose Copier Script to the Scripting Toolbar on page 1448.

The Pose Copier  dialog box opens.

 4. From the timeline, select the destination of the pasted keyframes by selecting the node or topmost 
node of your hierarchy for the selected template.

 5. With the destination highlighted in the timeline, (see below table for setting the proper 
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destination) press the Set Default Destination Module button from the Pose Copier dialog box. 

Once selected, this information will remain saved within the template. 

Selecting the Destination Layer

Type of template Paste by Layer Name Option Default Destination

Grouped Nodes

Enabled

Set it on the same group as the 
templated group or any node above it 
in the hierarchy. If a node inside that 
group is selected, pasting will not 
take place.

Disabled
Select the same group as the one 
templated. 

Nodes

Enabled
Select any node in the hierarchy as 
the default position.

Disabled
Unless you've only templated a 
single node, it is preferable to turn on 
the Paste By Layer Name option.

How to Paste Poses With the Pose Copier Script

 1. Do one of the following:

 l Set Default Destination to the designated layer and enable the Use Default Destination 
Module option.

 l Manually select the layer for the destination of the pasting.

 2. Select a pose using the different sliders—see About Guide Layers on page 1449.

 3. Click Paste to apply it on your character at the currently selected frame.
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Chapter 15: Cut-out Animation
Harmony provides some great tools for rigging and animating cut-out character models. You can make simple  
rigs or give your characters flexible capabilities using peg hierarchies, groups, composites, cutters, and 
deformers, among other things. You can create basic animations with the Transform tool, or more advanced 
animation with Inverse Kinematics as well as Bone and Curve Deformers. Harmony also supports advanced 
onion skin and image swapping features to help you animate efficiently and quickly. 
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About Animating with the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has 
many useful functions: 

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece 
from their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when 
many parts are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out 
animation.

When animating with the Transform tool, make sure to select the right selection mode. In this example, make 
sure that the Peg Selection  Mode  is disabled in the  Tool Properties view or it will limit the selection in the 
Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward 
Kinematics equivalent. 

The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as the 
global selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the 
permanent pivot is displayed as a ghost. 

NOTE 

The interpolation of the animation poses is always calculated from each individual part's 
permanent pivot. If there's a parent peg on a limb, make sure to select it instead of making a 
selection of each part to avoid setting individual keyframes.
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Animating with the Transform Tool
The Transform tool allows you to move, rotate, scale and skew a selection or multi-selection. 

How to animate using the Transform tool

 1. In the Tools toolbar, click the Transform  tool or press Shift + T.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Timeline view, go to the frame on which you want to set the first position.

 4. In the Timeline toolbar, click the Add Keyframe  button or press F6. It is recommended to add a 
keyframe before moving the character. Moving a character's part without setting a keyframe will 
create keyframes only on certain parameters of the animation. You could run into issues later on 
when setting poses between existing ones. Creating a keyframe on all layers and parameters will 
ensure your pose is set and will not be modified by other poses later on.

 5. In the Camera view, select the element to animate and move it.

 6. In the Timeline view, go to the frame where you want to set the next position.

 7. In the Timeline toolbar, click the Add Keyframe  button or press F6.

 8. In the Camera view, animate the character.
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Resetting Transformations
With the Reset command, you can return a selected element to its initial position and scale values, depending 
on which tool is active. For example, if the Rotate  tool is active, the transformation angle will be reset to 0 
and if the Transform  tool is active, then all transformation  values will be reset.

The Reset All option Resets all transformations on the current frame in a selected layer. Your keyframe will 
remain, but all the values will return to the starting value. All transformations are reset regardless of the tool 
you're using.

The Reset All Except Z option resets Resets all transformations on the current frame except the Z position. 
This is useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the 
different views of a character. You might want to reset the transformation, but not necessarily the Z position. 

NOTE 

When using the Transform  tool to select elements in the Camera view, always make sure the Peg 
Selection Mode  option in the Tool Properties view is disabled or it will limit the selection to peg 
only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if 
keyframes were created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformation values except Z

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.
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 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Hierarchy Navigation
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the 
parent-child chain. You can navigate between the children of the same parent. You can also easily center on 
your selection in the Timeline or Node view.
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Navigating Layers
Navigate between the layers in the Timeline view, using keyboard shortcuts or the Animation menu. This way 
of navigating only works for unparented layers or the children of a parent layer. If you are navigating between 
unparented layers, parent layers can be selected, but their children will be skipped. If you start on a parented 
layer (child), only the other children of the same parent will be available for selection.

How move up and down the layer stack

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Camera or Timeline view, select an unparented layer or child layer of a parent with several 
children.

 3. From the top menu, select:

 l Animation > Select Previous Sibling or press / to select the previous child layer.

 l Animation Select Next Sibling or press ? to select the next child layer. 
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Selecting Parent and Children
When animating, large movements that are made at the root (parent) of a chain cause secondary movements 
throughout the rest (children) of the chain. For example, when you rotate the arm of a character from the 
shoulder, the forearm and hand will follow. However, in order to make the movement appear natural and 
graceful, the forearm and hand should not move at the same speed or angle. As a result, animators often need 
to move up and down a chain, intermittently selecting parent and children, in order to make both large and 
fine movements.

How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. Do one of the following:

 l Select Animation > Select Parent or press B to select the parent layer.

 l Select Animation > Select Child or press Shift + B to select the child layer. 

 l Select Animation > Select Children to select all child layers at the same time.
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NOTE 

When going up or down your node hierarchy, these keyboard shortcuts skip any effect node in 
the hierarchy and only select either peg or drawing nodes. This is because these shortcuts are 
optimized for cut-out animation. In the Keyboard Shortcuts dialog, under the General section, 
these shortcuts are named Select Parent Skipping Effects and Select Child Skipping Effects. 
If you want to use keyboard shortcuts to navigate the hierarchy without skipping effect nodes, 
you can assign custom keyboard shortcuts  for the Select Parent  and Select Child  commands 
instead. 
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it 
hard to locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar 
to focus on the selected node in the Node view. You can also select elements in the Timeline or Xsheet view. 
This can be useful when there are too many objects in the scene or when an object is hard to grab. Finally, you 
can select all the elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera or Node view, select a layer.

 2. Do one of the following:

 l From the Timeline view menu, select View > Centre on Selection or press O.

 l In the Timeline view toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Node view

 1. In the Camera or Timeline view, select a layer.

 2. Do one of the following:

 l From the Node View menu, select View > Centre on Selection. 

 l In the Node View toolbar, click the Centre On Selection  button. 

 l In the Node view, press O.
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About Keyframes
Keyframes are the building blocks of Cut-out animation. Unlike Traditional animation, where every pose is 
drawn, Cut-out animation uses keyframes to mark major poses (key poses) and lets the software create all the 
poses in between.

In Harmony, you can create two kinds of keyframes: Motion and Stop-Motion. Motion keyframes behave like 
the description above; they allow for the automatic creation of drawings between two keyframed poses. Stop-
Motion keyframes do not allow for interpolation between keyframes. They are often used to block poses, 
somewhat similar to what you would see in Traditional Animation.
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Creating Motion Keyframes
T-LAY-004-001

After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it 
using motion keyframes. When you use motion keyframes, the drawings gradually move to the next position 
instead of staying on the spot until the next keyframe.

How to  create motion keyframes

 1. In the top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click on the selection and select Insert Keyframe. 

 l Click the Add Keyframe  button in the Timeline toolbar.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected 
element, a keyframe will be automatically created on the current frame.

1467



How to convert a stop-motion keyframe into a motion keyframe

 1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.

 2. Do one of the following:

 l Right-click on the selection and select Set Motion Keyframe. 

 l Click the Motion Keyframe  button in the Timeline View toolbar.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (macOS).  
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Creating Stop-motion Keyframes
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing 
key poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the 
interpolation between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is 
constant. There is no animation generated by the computer between the poses. The drawing remains in 
position until the next keyframe, then moves to its new position.

How to create stop-motion keyframes

 1. In the top menu, make sure the Animation > Stop-motion Keyframe option is selected.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click and select Insert Keyframe. 

 l In the Timeline toolbar, click the Add Keyframe  button.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected 
element, a keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe

 1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

 2. Do one of the following:

 l Right-click and select Set Stop-Motion Keyframes. 

 l In the Timeline toolbar, click the Stop-Motion Keyframe  button.

 l Press Ctrl + L (Windows/Linux) or ⌘  + L (macOS). 
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About Swapping Drawings
T-RIG-004-001

Cut-out animation often requires using several different drawings on the same layers. For example, it is typical 
to have several drawings in the mouth layer so that you can animate the character's mouth by swapping its 
drawings, since it is complicated to animate a mouth with deformations and transformations alone. It is also 
typical to have several hand drawings in the hand layers, to avoid having to animate the hand's fingers 
individually and to allow for quick hand rotations. 

Hence, a cut-out animator is often required to swap drawings on some layers throughout the scene to 
complete their cut-out animation. To allow for a flexible, adaptable and optimal workflow, there are several 
ways to swap drawings. But before learning how to swap drawings, it is important to understand the 
difference between a layer's drawings and its exposure. In Harmony, each layer has its own pool of drawings, 
referred to as an element, Which drawing is displayed for a layer at any frame in the scene is called exposure. 
For example, a hand layer may contain dozens of different hand poses, but only display one or two of them 
throughout the scene, with the first one displayed for the first half of the scene and the second one displaying 
during the second half.

The exposure for a scene's layers is represented visually in the Xsheet view.
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You can also see how the exposure is separated throughout the scene in the Timeline view. Each exposure is 
represented by a gray rectangle. 

NOTE 

You can see which drawings are exposed in each rectangle by enabling Thumbnails—see 
Displaying Drawing Thumbnails in the Timeline View.
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When you swap a drawing, you change which one of the layer's drawing is exposed at the current frame up 
until the end of its exposure. For example, if you select the frame at the beginning of a drawing's exposure, and 
swap its drawing, the drawing will be swapped for the entire span of that exposure. 

Otherwise, if you select the frame in the middle of an exposure and swap its drawing, the drawing will be 
swapped from the current frame up until the end of that exposure.

This breaks the exposure into two exposures, which is visible in the Timeline view

There are three ways to swap drawings:
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 l The Drawing Picker view displays all the drawing in the selected layer's elements as thumbnails. You 
can see every drawing you can choose from and pick the drawing you want by clicking on it.

 l The Library view has a Drawing Substitution panel in its top-right corner. It allows you to swap 
drawings by selecting the drawing you want using a slider, or by typing the number or name of that 
drawing in a text field.

 l The Timeline view's Parameters column displays which drawing is exposed on drawing layers at the 
current frame. You can swap drawings by clicking and dragging on the drawing name, or by typing its 
number or name manually. 
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Swapping Drawings in the Drawing Substitutions View
The Drawing Substitutions view is the easiest way to swap drawings. When you select a layer, the Drawing 
Substitutions view will display every drawing in that layer's element as thumbnails. All you have to do is select 
the frame where you want to swap drawings, then click on the thumbnail of the drawing you want to expose.

How to swap drawings using the Drawing Substitutions view

 1. Add the Drawing Substitutions view to your workspace by doing one of the following:

 l In the top-right corner of any existing view, click on the  Add View button and select 
Drawing Substitutions.

 l In the top menu, select Windows > Drawing Substitutions.

 2. Do one of the following:

 l In the Timeline or Xsheet view, select the layer on which you want to swap drawings.

 l In the Tools toolbar, select the  Transform tool. Then, in the Camera view, select the layer 
on which you want to swap drawings.

NOTE 

Make sure the  Peg Selection mode is turned off in the Tool Properties view. 
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 3. In the Timeline or Xsheet view, select the frame at which you want to swap drawings. 

NOTE 

You can select a range of frames to substitute drawings in several frames at the same 
time—see About Swapping Multiple Drawings

 4. In the Drawing Substitutions view, click on the drawing with which you want to expose at the 
current frame.

The drawing exposed in the current frame is swapped with the drawing you just selected.
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TIP 

You can also press [ to substitute the current drawing with the previous drawing and ] to 
substitute it with the next drawing. 
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Swapping Drawings in the Library View
T-LAY-003-002

The Library view has a convenient Drawing Substitution panel in which you can quickly swap the drawing in 
the selected frame for another drawing. Under the drawing thumbnail, you can use the slider to cycle through 
the drawings in the selected layer's element, or use the text field to type in the name of the drawing you want 
to expose.

How to swap images in the Library view

 1. Do one of the following:

 l In the Timeline or Xsheet view, select the layer on which you want to swap drawings.

 l In the Tools toolbar, select the  Transform tool. Then, in the Camera view, select the layer 
on which you want to swap drawings.

NOTE 

Make sure the  Peg Selection mode is turned off in the Tool Properties view. 
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 2. In the Timeline or Xsheet view, select the frame at which you want to swap drawings. 

NOTE 

You can select a range of frames to substitute drawings in several frames at the same 
time—see About Swapping Multiple Drawings

 3. Open the Library view. The Drawing Substitution panel, in the top-left corner, will display the 
selected drawing, the name of the layer and the name of the drawing at the current frame. 

 4. Do one of the following:

 l Click and drag on the slider to cycle through the drawings in the layer's element. Leave the 
slider once you see the drawing you want to expose in the thumbnail.
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 l In the text field, type in the number or name of the drawing you want to expose. 

 l Press [ to substitute the current drawing with the previous drawing and ] to substitute it with 
the next drawing. 

The drawing exposed in the current frame is swapped with the drawing you just selected.
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Swapping Drawings in the Timeline View
T-LAY-003-001

In the Timeline view, there is a Parameters column right of the Layers column. For drawing layers, the 
Parameters column displays the name or number of the drawing exposed at the current frame. You can quickly 
swap which drawing is exposed at the current frame by clicking and dragging on the value in the Parameters 
column. This is a more technical approach, as you do not have a preview of the drawing you are selecting. 
Hence, you have to know the name or number of the drawing you have to select. If you do know it, this 
technique can save you time as it can be done on the fly while working in the Timeline view.

How to swap a drawing in the Timeline view

 1. In the Timeline view, select the cell in which you want to swap drawings. 

 2. In the fields under the Parameters column, right of the layer's name, do one of the following:

 l Click and hold on the drawing number or name, then drag left to cycle back through the 
drawings in the element, or right to cycle forward through the drawings in the element. 
When the number or name of the drawing you want to expose appears, release the mouse 
button.

 l Double-click on the drawing number or name and, in the text field that appears, type in the 
name of the drawing you want to expose and press ENTER.
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About Swapping Multiple Drawings
If you select a range of frames in the Timeline view, you can swap drawings over the entire selected range of 
frames at the same time. However, there are two approaches to doing this, with two different results.

Drawing Picker, Library View or Keyboard Shortcuts

If you select a range of frames in the Timeline view, then use the Drawing Picker view, the Library view or the [ 
and ] keyboard shortcuts to swap drawings, the drawing in every frame in the selected range will be replaced 
with the new drawing. However, subsequent drawings will not be substituted, even if they are part of the 
same exposure. This will make the selected range of frames into its own exposure, breaking it from the 
exposure before and after the selection.

Timeline View

If you select a range of frames in the Timeline view, then use the Parameters column to swap drawings, the 
every frame in the selected range will be replaced with the new drawing up and until the end of the last 
exposure in the selection.
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About Key Exposures
Key exposures are a feature that can help preserve the exposure of specific drawings at specific frames of your 
scene when you perform drawing substitution. 

Before working with key exposures, it is important to understand how exposure works with Harmony. An 
exposure basically represents the span of time (or frames) during which a specific drawing is displayed in your 
scene. You can see the exposure of each drawing for a given layer in the Xsheet view. For example, here we 
have a layer in which drawing 1 is exposed from frames 1 to 6, then drawing 2 is exposed from frames 7 to 10, 
and drawing 3 is exposed from frames 11 to 12:

As you can see, in the Xsheet view, an exposure is represented  in its first frame by the name of the drawing, 
then in every subsequent frame by a vertical line. The number represents the moment where the exposure of a 
drawing starts, which is called a key exposure, the line represents the span during which this drawing's 
exposure is repeated, which is just called exposure.

Typically, key exposures are automatically created when the exposed drawing changes. However, it is possible 
to add key exposure in the middle of a drawing's exposure without changing the exposed drawing, simply to 
break its exposure into two separate blocks of exposure. For example, here, you have drawing 1 exposed from 
frames 1 to 8, but it is split into two blocks of exposure by a Key Exposure at frame 5.

This is useful for managing what happens when you perform drawing substitution. In Harmony, when you 
swap a drawing for another drawing at a specific frame, it replaces which drawing is exposed on all the frames 
starting from the current frame up until the next key exposure. For example, here, if we switch the drawing at 
frame 3 with drawing 6, drawing 6 will be exposed from frame 3 all the way to frame 8, because there is a key 
exposure at frame 9. 
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In this other example, because there is a key exposure at frame 5, if the drawing at frame 3 is switched from 
drawing 1 to drawing 6, the substitution will only happen on frames 3 and 4. The key exposure at frame 5 will 
prevent the substitution from spanning any further:

Hence, by using Key Exposures, you can make sure the drawing exposed at a specific frame does not get 
swapped just because you swapped the drawing in earlier frames. The drawing exposed with a Key Exposure 
only gets swapped if you select the frame where that Key Exposure is and swap the drawing in it.
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Adding Key Exposures

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This 
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property 
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is 
the same drawing or not.

How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

 l In the Timeline toolbar, click the Add Key Exposure  button.

 l In the Timeline menu, select Exposure > Add Key Exposure.

 l Right-click and select Exposure > Add Key Exposure.

A new key exposure is added at the current frame. 
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Removing Key Exposures

When you no know longer need a key exposure, you can remove it. 

You can also remove key exposures of where the drawing is different than in the previous frame. When you 
remove a key exposure, the exposure of the drawing before it is extended over the exposure of the deleted key 
exposure.

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l  In the Timeline menu, select Exposure > Remove Key Exposure.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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Removing Duplicate Key Exposures

A duplicate key exposure is when a key exposure exposes the same drawing as the frame before it. You can 
quickly remove all duplicate key exposures in a span of frames and only preserve the key exposure that is 
necessary for your animation.

How to remove duplicate key exposures

 1. In the Timeline or Xsheet view, select the span of frames in which you want to remove duplicate 
exposure.

 2. Right-click on the selection and select Exposure > Remove Duplicate Key Exposure.
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Copying & Pasting Key Exposures

When you copy a key exposure and paste it over a cell that has the same drawing, by default, this creates a 
key exposure in this cell. 

You can actually choose whether or not to create key exposure when you paste in two ways

 l Using Paste Special, you can choose whether to paste key exposure on the fly.

 l Using Paste Presets, you can choose whether to paste key exposure whenever you paste. 

How ignore or enforce key exposures when copying and pasting drawings using 
Paste Special

 1. In the Timeline or Xsheet view, select the drawings you want to copy.

 2. Do one of the following:

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS). 

 l Right-click on the selection and select on Copy cells from the Timeline/Xsheet.

 l From the top menu, select Edit > Copy cells from the Timeline/Xsheet.

 3. In the Timeline or Xsheet view, select the cell where you want to paste your selection.

 4. Do one of the following:

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (macOS).

 l Right-click on the destination and select Paste Special.

 l From the top menu, select Edit > Paste Special.

The Paste Special dialog box opens.
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 5. Check or uncheck the Enforce Key Exposure optiojn, depending on whether or not you want to 
paste key exposures.

 6. Click OK.

How ignore or enforce key exposures when copying and pasting drawings using 
Paste Presets

 1. In the Timeline or Xsheet view, select the drawings you want to copy.

 2. Do one of the following:

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS). 

 l Right-click on the selection and select on Copy cells from the Timeline/Xsheet.

 l From the top menu, select Edit > Copy cells from the Timeline/Xsheet.

 3. In the Timeline or Xsheet view, select the cell where you want to paste your selection.

 4. In the Timeline view toolbar, check whether the All Drawings Attribute , Keyframes Only  or 
Exposures Only  paste preset is selected.

 5. From the Timeline menu, select Edit > Modify Paste Presets > the active paste preset.

The Edit Exposure Paste Preset dialog box opens.
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 6. Check or uncheck the Enforce Key Exposure option, depending on whether or not you want to 
paste key exposures.

 7. Click OK.

 8. Do one of the following:

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS)

 l Right-click on the destination and select Paste Cells in Timeline/Paste.

 l From the top menu, select Edit > Paste Cells in Timeline/Paste.
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About Eases
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature 
and set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve 
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle 
and left handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can 
pull on them to adjust the ease in and ease out, or type values in the fields. 

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm 
and arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in 
one frame.
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Setting the Ease for Animation Keyframes
You can set and fine-tune the ease for your animations using the Set Ease for Multiple Parameters dialog. In 
this dialog, you can edit the ease for your animation using Bezier handles, allowing you to adjust both the 
length and the angle of the Bezier curve that makes the timing of the animation. You can also select which 
types of parameters, such as position, rotation angle and scale, to which the ease should be applied. 

You can also quickly set the ease for a range of keyframes using the Set Ease on Keyframes dialog, which only 
allows you to set the length of the ease, but not the angle. 

How to set ease on animations keyframe by keyframe

 1. In the Timeline view, collapse the hierarchy of the rig (or of the part of the rig) to which you want to 
apply an ease. 

NOTE 

When you apply an ease to a layer with children, and this layer’s hierarchy is collapsed, 
the ease is applied to that layer and all of its children. 

 2. Select one of your animation keyframes.

NOTE 

You should only select one keyframe. The Set Ease for Multiple Parameters dialog can 
only edit the ease on one keyframe at a time, but it also allows you to quickly jump 
between keyframes in your timeline.

1492

Harmony 21 Premium User Guide                          



Chapter 15: Cut-out Animation

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 4. In the Bezier editor, click and drag on the Bezier handle to adjust the ease for the selected 
keyframes.

 5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields below the 
Bezier editor. The values are calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last. This will move the Beziers horizontally, 
away from their keyframe. The value must be between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
skewed you want the ease to be. This will move the Bezier vertically, towards their nearest 
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keyframe if the value is positive, or away the nearest keyframe if their value is negative. The 
value must be between 0% and 100%.

 6. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the 
Filters section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity 
functions. Note that it is applied to the Morphing Velocity function in the Layer 
Properties window, not to the basic Morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other selected functions, such as all 
functions created to animate effect parameters.

 7. Click one of the following buttons:

 l Apply/Previous: Applies the ease parameters to the selected keyframe and then 
jumps to the previous keyframe in the timeline so that you can adjust its ease next.

 l Apply: Applies the easing parameters to the selected keyframe.

 l Apply/Next: Applies the ease parameters to the selected keyframe, then jumps the 
next keyframe in the timeline so that you can adjust its ease next.

 l Close: Closes the dialog box. If you did not apply the modifications, they will be 
cancelled

How to apply a quickly set the ease on one or several keyframes

 1. In the Timeline view, collapse the hierarchy of the rig (or of the part of the rig) to which you want to 
apply an ease. 
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NOTE 

When you apply an ease to a layer with children, and this layer’s hierarchy is collapsed, 
the ease is applied to that layer and all of its children. 

 2. Select all the keyframes for which you want to adjust the ease.

 3. In the Timeline toolbar, click on the  Set Ease on Selected Keyframes button.

The Set Ease on Keyframes dialog appears.

 4. For the ease before the selected keyframes, do one of the following:

 l If you want to set the ease before the selected keyframes, check the Ease-In (left) checkbox. 
Then, in input field next to the checkbox, type in the percentage of ease you want to apply 
before the selected keyframes.

 l If you don’t want to make changes to the ease before the selected keyframes, uncheck the 
Ease-In (left) checkbox. 

 5. For the ease after the selected keyframes, do one of the following:
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 l If you want to set the ease after the selected keyframes, check the Ease-Out (right) 
checkbox. Then, in input field next to the checkbox, type in the percentage of ease you want 
to apply after the selected keyframes.

 l If you don’t want to make changes to the ease after the selected keyframes, uncheck the 
Ease-In (left) checkbox. 

 6. Click OK.

The eases on all the selected keyframe is now updated.
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Applying Ease Presets to Animations
You can quickly set the ease on an animation using the Timeline view toolbar. There are two approaches to 
this:

 l The Set Ease Type drop-down allows you to quickly select an ease preset for the animation ranging 
from the selected keyframe to the next keyframe.

 l The Quick Ease buttons allow you to apply an ease preset to the current keyframe, whether before or 
after the current keyframe.

How to select apply an ease preset to a motion

 1. In the Timeline view, collapse the hierarchy of the rig (or of the part of the rig) to which you want to 
apply an ease. 
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NOTE 

When you apply an ease to a layer with children, and this layer’s hierarchy is collapsed, 
the ease is applied to that layer and all of its children. 

 2. Select the first keyframe of the animation to which you want to apply an ease preset.

TIP 

You can select several keyframes. The ease preset will be applied to the animations 
starting from each selected keyframe up to the following keyframe.

 3. In the Timeline toolbar, open the  Set Ease Type drop-down and select the preferred ease 
preset:

 l  Linear: Removes ease-in on the selected keyframe and the ease-out on the next 
keyframe.

 l  Slow ease-in: Applies an ease-in of 25% to the selected keyframe and an ease-out of 
0% to the next keyframe.      

 l  Medium ease-in: Applies an ease-in of 50% to the selected keyframe and an ease-out of 
0% to the next keyframe.

 l  Fast ease-in: Applies an ease-in of 75% to the selected keyframe and an ease-out of 0% 
to the next keyframe.

 l  Fast ease-in / ease-out: Applies an ease-in of 75% to the selected keyframe and an 
ease-out of 75% to the next keyframe.
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 l  Medium ease-in / ease-out: Applies an ease-in of 50% to the selected keyframe and an 
ease-out of 50% to the next keyframe.

 l  Slow ease-in / ease-out: Applies an ease-in of 25% to the selected keyframe and an 
ease-out of 25% to the next keyframe.

 l  Slow ease-out: Applies an ease-in of 0% to the selected keyframe and an ease-out of 
25% to the next keyframe.

 l  Medium ease-out: Applies an ease-in of 0% to the selected keyframe and an ease-out of 
50% to the next keyframe.

 l  Fast ease-out: Applies an ease-in of 0% to the selected keyframe and an ease-out of 
75% to the next keyframe.:

The selected ease-type is applied to the animation spanning from the selected keyframe to the 
next keyframe.

How to apply a quick ease preset before or after a keyframe

 1. In the Timeline view, collapse the hierarchy of the rig (or of the part of the rig) to which you want to 
apply an ease. 

NOTE 

When you apply an ease to a layer with children, and this layer’s hierarchy is collapsed, 
the ease is applied to that layer and all of its children. 
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 2. Select all the keyframes to which you want to apply an ease preset.

 3. In the Timeline toolbar, do one of the following:

 l To apply an ease of 33% before and after the keyframe, click on the  Quick Ease button.

 l To apply an ease of 33% after the keyframe, click on the   Quick Ease Out button.

 l To apply an ease of 33% before the keyframe, click on the  Quick Ease In button.
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About Using Onion Skin in Cut-out Animation
T-HFND-006-006

Although Onion Skin is primarily designed for frame-by-frame animation, you may find Onion Skin to be useful 
when doing cut-out animation. Just like with paperless animation, you can use Onion Skin to help you use 
existing poses in your scene as references to create new key poses, breakdowns or in-betweens. Also, 
displaying the Onion Skin for the different frames of a movement can help you visualize the timing of your 
animation.

NOTE 

The following topic explains how to control which layers in a cut-out rig are displayed in the Onion 
Skin. For more information on how to use Onion Skin in general, see About Onion Skin.

When the Onion Skin is displayed, it is displayed for:

 l The currently selected layer and its children.

 l All layers for which the Onion Skin is enabled.

When you enable Onion Skin, it is automatically enabled on the selected layer and its children, and disabled 
for other layers. This way, if you select your character rig's master peg, enable Onion Skin, it will be enabled for 
all its layers. If you select one of its layers to animate it, the Onion Skin for the whole rig will persist. 

This makes managing Onion Skin while doing cut-out animation relatively seamless. However, you may still 
want to manage which layers are visible in the Onion Skin. For example, you may want to add more layers to 
the Onion Skin as their position is needed to help you pose specific layers, or you may want to remove layers 
from the Onion Skin to de-clutter it, or prevent it from hindering software performance. There are several 
techniques for managing which layers are displayed in the Onion Skin.
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NOTE 

Keep in mind that the selected layer and its children are always displayed in the Onion Skin. 
Hence, when you select a layer and try to remove it from the Onion Skin, it will remain displayed in 
the Onion Skin until you select a different layer.

The Onion Skin  Button in the Tools Toolbar

When you click on the Onion Skin button in the Tools toolbar to enable Onion Skin, it is enabled on all the 
selected layers and their children. This is persistent even if you select different layers. Hence, it is a good idea 
to select your character model, or the part of it that you want to animate, before enabling Onion Skin.

When Onion Skin is enabled, if you click on the Onion Skin button, it will disable Onion Skin for all layers.

The Onion Skin  Button in the Timeline View

In the Timeline view, there is an Onion Skin button left of each drawing layer. If you click on it, it will toggle 
whether Onion Skin is enabled on that individual layer.
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Also, and perhaps more importantly, when a peg that is the parent of one or several drawing layers is 
collapsed, it also has an Onion Skin button. Clicking on this button will toggle Onion Skin on every drawing 
layer rigged under that peg. This allows you to quickly enable Onion Skin on your whole rig or on a large part 
of your rig.

Likewise, you can quickly disable Onion Skin on part of your rig this way.
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The Onion Skin Menu

In the top menu, under View, there is an Onion Skin sub-menu. This menu contains several commands 
allowing you to add or remove layers to and from the Onion Skin:

 l Add to Onion Skin: Adds the selected layer and all of its children to the Onion Skin.

NOTE 

You can run this command instantly by pressing Shift + S.

 l Remove from Onion Skin: Removes the selected layer and all of its children from the Onion Skin.
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 l Remove Unselected from Onion Skin: Removes every layer but the selected layer and its children from 
the Onion Skin. This can be useful if you have Onion Skin enabled on your whole rig or on a big part of 
your rig, but you selected a smaller part of the rig and you only want Onion Skin to be enabled on it. 

 l Add All to Onion Skin: Adds all of the layers in your scene to the Onion Skin:

NOTE 

You can run this command instantly by pressing Alt + Shift + O

 l Remove All from Onion Skin: Disables Onion Skin on all of the layers in your scene.
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NOTE 

You can run this command instantly by pressing Ctrl + Shift + O (Windows/Linux) or ⌘  + 
Shift + O (macOS).
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Using the Outline Mode
Use the Outline mode to temporarily convert all the drawings on a layer to outlines. You can still select and 
manipulate the drawings in this mode. Select a drawing by selecting its outline. The fill is not taken into 
account when making selections in this mode.

Toggling drawings to outlines

 1. In the Timeline view, click once on the Change Track Colour button of a layer to toggle all drawings 
of that layer to outlines, in the Camera view.
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Changing the outline colour

 1. In the Timeline view, double-click on the Change Track Colour button of a layer to open the Select 
Colour dialog box.

 2. In the Select Colour window, select a new colour for your outlines.
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 3. Click Ok.

The colour swatch and frames of the selected layer take on the new colour. In the Node view, the 
layer's corresponding node also displays the colour marker.

 4. In the Timeline view, click once on the change track colour of a layer to toggle all drawings of that 
layer to outlines, in the Camera view.
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The outlines of the layer's drawings appear in the selected colour.
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Flipping Through Poses
When animating, it is useful to flip through poses to see the flow of your animation without going through each 
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses

 1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

 2. Do one of the following:

 l From the top menu, select Animation > Go to Previous Keyframe or Go to Next 
Keyframe.

 l Press semicolon (;) and single quote ('). 
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Flipping Parts
If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip 
Vertical options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select the parts to be flipped.

 4. In the  Tool Properties view, click the Flip Horizontal  or Flip Vertical  option or press 4 or 5 
respectively.
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Animating Lip-Sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE 

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound
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When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to 
work, your character's mouth layer should already contain a mouth drawing for each drawing in the mouth 
chart, and these drawings should be named by their corresponding letter. 

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 
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NOTE 

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the  Enable Sound  option.

 8. Press the  Play  button in the Playback toolbar to see and hear the results in the Camera view

You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed 
at each frame of your character's d ialogue. For this process, you will be using the Sound Scrubbing 
functionality, which plays the part of your sound track at the current frame whenever you move your Timeline 
cursor, allowing you to identify which phonemes you should match your character's mouth to. You will also be 
using drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.
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How to animate lip-sync using the Library view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.

How to swap drawings using the Drawing Substitutions view

 1. Add the Drawing Substitutions view to your workspace by doing one of the following:

 l In the top-right corner of any existing view, click on the  Add View button and select 
Drawing Substitutions.

 l In the top menu, select Windows > Drawing Substitutions.

 2. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 3. In the Timeline view, drag the red playhead along the waveform of your sound layer.
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 4. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 5. In the Drawing Substitutions view, click on the mouth pose you want to expose at the current frame.

TIP 

You can also press [ to substitute the selected drawing with the previous drawing and ] to 
substitute it with the next drawing. 
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Ordering  in Z-Depth
The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new 
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows 
you to create a multiplane and move elements closer or farther from the camera. This allows you to move the 
puppet’s pieces in front of or behind other ones without physically changing the layer position. 

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is 
created where different Z values can be entered. This allows the piece to move forward and backwards in 
space without requiring you to change the drawing’s original position or break the layer hierarchy. This also 
means that the layer ordering is maintained throughout the scene. You can combine animation assets so 
Harmony can interpolate them. 

How to nudge elements on the Z-axis

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.
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 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. In the Camera view, select the part to be repositioned and hold down the Alt key. 

 4. Using the Up Arrow or Down Arrow arrow keys, nudge the part until it moves to the desired 
position.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle 

 1. In the Xsheet or  Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells From the Timeline.

 3. In the Xsheet or  Timeline view, select the cell where you want your cycles to start.

 4. From the top menu, select one of the following:

 l Edit > Paste Cycle 

 l Press Ctrl + / (Windows/Linux) or ⌘  + / (macOS).
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The Paste Special dialog box opens.

 5. In the Cycles drop-down, select the type of cycle to paste:

 l Normal (forward): Pastes the selection as is, starting with the first cell and ending with the 
last.

 l Reverse: Pastes the selection reversed, beginning with the last cell and ending with the 
first.

 l Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the 
last cell and ending with the first cell.

 l Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.
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 1. In the Number of Cycles field, enter the number of cycles to paste.

 2. Click OK.

How to create a reverse animation cycle

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

 2. From the top menu, select Edit > Copy.

 3. In the Xsheet or  Timeline view, select the cell where you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (macOS).
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About Inverse Kinematics
The Inverse Kinematics (IK) tool  allows you to pull on a character's extremities, such as the hands and feet, and 
have the rest of the body follow. It can be used on any piece connected in a hierarchy. However, you don't have 
to use IK every time you have a hierarchy rig. This tool is useful when you want to bend a character's knees, 
make it sit and move the rest of the body, and so on. It will also assist you with posing difficult moves. 

In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony uses the 
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character. 
Inverse Kinematics in Harmony uses the connection between each of the parts' pivots.

Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present. IK 
only works on a hierarchy where the pivots are properly set.

Harmony provides different tools for animating cut-out characters and trajectories. The two main tools used to 
animate characters are the Transform and Inverse Kinematics tools.

Here, we'll compare the usage of these tools and explain the Inverse Kinematics philosophy.

 l Transform Tool

Also known as forward kinematics, the Transform tool is the main tool to use for cut-out animation. This 
tool rotates, scales, moves and skews selected elements as one global element.

Forward kinematics means that the limb is animated from the parent down to the last child as a single 
piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as a complete 
arm drawing.

 l Inverse Kinematics Tool (IK)

This tool helps you achieve complex motions, such as sitting down or knee bending. The Inverse 
Kinematics tool moves and rotates every selected element as a chain.

Inverse kinematics means that the element is animated from the child up to the parent. In other words, if 
the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly natural way in 
terms of the movement, rotation and bending.

The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and parts are 
attached to one another. In other words, it depends on the rigging type.

There are several ways to rig a puppet. These are the three main rigging techniques:
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 l The Basic Rig Technique

 l This is the simplest rig technique.

 l There are no connections between the parts. 

 l They are free to move, rotate and scale independently from each other. 

 l The Inverse Kinematics tool CANNOT be used on this type of rigging. 

 l The Hierarchy Rig Technique

 l This is a complex rig technique.

 l All the parts are connected to each other. 

 l As they move, rotate and scale, they will influence all the other parts. 

 l The Inverse Kinematics tool can be used on this type of rigging. 

 l The Mixed Rig Technique

 l This is the best of the basic and hierarchy rig.

 l Some parts are independent such as the torso. 

 l Some parts are set up in a hierarchy such as the arms and legs.

 l Independent parts are rigged in hierarchy using parent pegs.

 l The Inverse Kinematics tool can be used on this type of rigging. 

Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.

You will mainly use the Transform tool (forward kinematics) as it has all the main motions: rotate, scale, skew, 
move and select. You can also control the exact position of the parts while using the Transform tool. As well, 
the Transform tool creates a temporary global pivot on the selection that can be moved around for the 
animation purpose.

To complete complex motions, such as bending the knees while keeping the feet on the ground, you can use 
the Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible to lock the feet 
or any other part to a particular spot and move the rest of the body, which will react to the constraints.

It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You will not be using it to 
animate all the time.

Also, the Inverse Kinematics tool can be used to create the character's posing faster. Posing is a crucial part in 
the animation process. The Inverse Kinematics tool can be used to pose the character more naturally, 
depending on your own preferences.

An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as 
an arm or a portion of the arm.

Here are some tips and tricks to help you to use the Inverse Kinematics tool.

 l Inverse Kinematics on Mixed Rigs
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The Inverse Kinematics tool can be used on a full puppet's body even if it's connected as a mixed rig, 
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails on the 
puppet's feet, select the full body master peg and move the character as if it was connected in a full 
hierarchy rig. This technique works on most mix rigs.

 l Inverse Kinematics Constraints

It's important to remember that you can add and remove IK constraints (nails, hold orientation, etc.) at 
any time during the animation. They hold a certain part on the spot while you animate the rest of the 
body. Because they're not constricting one part to another object, you can add or remove them without 
affecting any of the animation you have already completed.

 l Useful Shortcuts

 l While using the Inverse Kinematics tool, you can Ctrl + click (Windows/Linux) or ⌘  + click 
(macOS) to select any part. 

 l Hold Alt to rotate the selected part without affecting the IK chain. 

 l Press Shift and click in a part's pivot to add or remove an IK Nail. 

 l Press Shift and click on a bone to add or remove and Hold Orientation constraint.
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About IK Hierarchy Chains
Before going any further, a word about IK chains. There are three types of chains:

 l Single Chains

The single chains are the most basic of chains. A single chain is a straight line with no secondary 
chain attached. It goes up to the first intersection.

 l Direct Chains

A direct chain is a single chain which goes directly to the core (root).

 l All Chains

All chains are attached and move together when one part is moved.
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About IK Setup
The first time you display the character's skeleton, notice a series of bones on the extremities which are out of 
place. There may also be some elements that you would like to exclude from the IK chain.

It is highly recommended to set up the skeleton before starting your animation.

Before fixing any bones, or excluding layers from the IK skeleton, make sure all the elements you want to be 
parented in a chain are set up.

You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms. If the 
body is not completely rigged in hierarchy, the skeleton will look a bit more messy, but the IK tool will still 
work properly.

When working with the IK tool, you will probably want to move the main parts around, but not necessarily the 
small ones such as the nose or ears. To do this, you can select some elements on your character and exclude 
them from the skeleton.

Once you remove the extra elements from the skeleton, set the bone orientation for the extremity parts. By 
default, they are oriented horizontally towards the right. This orientation often works for the feet but not 
necessarily for the hair or hands.

Harmony allows you to set a minimum and maximum angle constraint on certain joints, such as the knees or 
elbows. When using the Inverse Kinematics tool or even the Forward Kinematics (Transform tool), it is possible 
that some joints will bend in the wrong direction.

If you plan to animate a lot with the Inverse Kinematics tool, it's a good idea to try the angle constraints. The 
angle constraints can be set by the character builder or by the animator in particular scenes where it's needed.
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NOTE 

It is recommended to use the minimum and maximum angles only if the character does not change 
view within the same layers. For example, if a character is facing the camera and has some angle 
limitations enabled, it could be problematic if the character switches to side or quarter view since 
the joints won't bend the same way.

Use the minimum and maximum angle constraints if your character's views are in different 
templates or layers. If the character's views are in the same layers, then it's better not to use the 
angle constraints.
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Excluding Elements from IK Skeletons

You can easily remove elements from your IK skeleton to simply it.

How to exclude elements from the skeleton

 1. In the Tools toolbar, select the Inverse Kinematics   tool or press Shift + I.

 2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the part to exclude from 
the skeleton.

 4. In the Tool Properties view, click the Exclude from IK  button.

 5. Repeat the process for every part to be excluded from the skeleton.
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Orienting Bones

Extremity bones can be rotated to match the drawing's orientation.

How to set the bone orientation

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, enable the Bone Editing  mode.

 3. In the Camera view, click on the pivot belonging to the part whose bone you want to reposition, 
then pull the pivot in the desired direction.

 4. Repeat this process for each bone you want to position.

NOTE 

This command only works on the extremities.
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Setting Minimum and Maximum Angles

You can set minimum and maximum angles your character's limbs to avoid overbending them.

How to set the minimum and maximum angles

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode  is 
enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the piece to set the 
minimum and maximum angle.

 4. In the Tool Properties view, in the Selection section, click the Enable Min/Max Angle  option.

 5. In the Camera view, rotate the Minimum and Maximum handles to set the angle.

 6. Test the angles using the IK Manipulation  mode.

 7. For additional control over the Min/Max Angle, go to Edit > Preferences (Windows/Linux) or 
Harmony Premium > Preferences (macOS). Select the Camera tab. In the Inverse Kinematics 
section, look at the Min/Max Angle Constraint Weight. Although the maximum value goes up to 
1.0, in a production setting, the most practical value would be closer to 0.1. This value acts similar to 
the Stiffness setting in the Tool Properties view. The higher the value, the more difficult it becomes 
to approach the minimum and maximum values.
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About Nails
Often, you will want to animate only part of a character, such as the arm and not the entire body. You can do 
this using IK nails, which are IK constraints that temporarily cut or constrain the chain. With IK nails, you can 
cut an IK chain or block a part on the spot. For example, you can fix a character's feet to the ground when it 
walks.

There are different types of constraints you can place on the chain:

 l IK Nail: Blocks the X, Y and Z positions.

 l Hold Orientation: Blocks the angle.

 l Hold X: Blocks only the X position.

 l Hold Y: Blocks only the Y position.

 l Enable Maximum and Minimum Angles: Sets limitations on the angle parameter to prevent the 
puppet from bending too far.
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Setting Nails

You can place nails on your skeleton to temporarily hold it in place.

How to set an IK nail

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the part to set a nail on.

 4. In the Tool Properties view, select a type of nail:

 l Hold the Shift key and click on any part's pivot to set a regular nail on it without 
having to select it.

 l Hold the Shift key and click on the bone to set a Hold Orientation nail.

 l Select the nail type in the top menu by selecting Animation > IK Constraints > 
desired nail.

 l Remove the nail at any time using the same technique you did for placing the nail. It 
will not affect the animation.

 5. To remove all nails except the Enable Min/Max Angle ones, from the top menu, select Animation > 
IK Constraints > Remove All Constraints.
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Animating with Inverse Kinematics
Inverse Kinematics works best when you lock a part of the character on the spot, such as a foot on the floor, 
then select the entire body or another extremity and move it. It also works well in single chain mode when you 
need to simply position a limb.

To learn more about the IK tool's properties, see the Reference guide .

NOTE 

To lock a part in place, use the IK Nail option—see About Nails on page 1534.

How to animate with the Inverse Kinematics tool

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on a part of the body.

The entire IK skeleton appears.

 3. Click on a part of the body and pull on it to move the character.
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 4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You 
can Shift + click on a bone to lock the orientation of the bone.

 5. Click on another part of the character and pull on it. 
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About IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key 
poses. However, when you use motion keyframes to auto in-between the animation, you'll notice a movement 
of the feet. This motion is caused by the in-betweening of the rotations.

The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration between 
keyframes.

If you place a nail on the shoulder to move just the arm, you don't necessarily want to keep the shoulder in the 
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to 
have a slight, natural motion following the main body action. Of course, this is not the case when you fix a hand 
or a foot on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you 
placed it. That is why you can apply an IK constraint on a frame range and on selected body parts.

To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much. 
For example, to fix a foot that is moving too much, you must correct the angles on the foot, leg and thigh. To fix 
a hand, you must correct the angles on the hand, forearm and upper arm.
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Setting IK Keyframe Constraints

When setting up a hierarchy chain, the parent is usually the part that is at a logical point of rotation. For 
example, in the case of a leg, the parent would be the thigh, as it rotates from the hip and its children would be 
the shin and foot that will always follow.

However, sometimes you come across a situation where you need the movement to stem from the child, such as 
in the case of a ballerina, where the shin and thigh rotation follow the position of the foot. In order to keep the 
foot from gliding around, making the kinds of secondary movements that children do, you need to nail the foot 
in place and constrain its orientation (rotation). Sometimes this constraint needs to be held for several frames.

How to apply IK constraints on a frame range

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Camera view, click on the part on which you want to apply the constraint.

 3. In the Timeline view, select the first frame on which you want to start applying the constraint.

 4. In the Tool Properties view, enable the Apply IK Constraints  mode.

 5. In the Tool Properties view, click the IK Keyframe  button to enter the first frame number.

 6. In the Timeline view, move the playhead to the last frame on which you want to apply the 
constraint.

The IK Keyframe field should now look like this:

 7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on the 
thigh by holding down the Shift key and clicking its pivot.
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 8. In the Tool Properties view, select the type of constraint to apply to the piece. The most common 
one is a combination of the regular Nail  and Hold Orientation  options.

 9. In the Camera view, click on the bone of the part you want to apply a constraint to.

A warning message appears asking you to confirm that you want to add a constraint on that 
particular piece and for that frame duration.

 10. Click OK.

The constraint is applied.
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About Timeline View Modes
The View Modes  button lets you streamline the process of working with elements in the Timeline view. There 
are three different view modes you can choose to work in. With each mode you select, certain elements may or 
may not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding 
elements when you want to focus on specific ones. To select a view mode, use the drop-down menu in the 
bottom-left corner of the Timeline view.

 Normal View Mode

Normal View  mode is the default Timeline view mode. It shows everything connected to the chosen 
display. In this mode, anything not connected to the currently set default display will not be shown in the 
Timeline view. This also means that you cannot add certain elements to the Timeline view, as by default, 
when added they are not connected to any display or composite node. An example of such an element is a 
peg.

NOTE 

If you prefer to work as you did before, where you see everything in the Timeline whether it is 
connected to a Display or not, you can change the Always Display Unconnected Nodes 
setting in the Preferences dialog box, Timeline tab.

Selection Only Mode

When working in Selection Only  mode, only elements currently selected in the Camera or Node view 
will be visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Layers

The View Tagged Nodes   mode lets 

you see only elements which have been assigned a Tagged status. An item that has been tagged will 
appear in the Timeline view with a small asterisk beside its name.
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Once your elements are tagged and you have switched over to View Tagged Layers mode, the Timeline 
view will display only tagged elements. The red bar on the left of the layers indicates you are in this view 
mode.

While in this mode, the asterisks are not displayed beside the tagged elements.
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Tagging Layers
You can tag layers to easily visualize them in the Timeline view.

How to tag or untag elements in the Camera view

 1. In the Camera view, select one or more elements.

 2. Right-click and select Tag or Untag.

How to tag or untag elements in the Timeline or Node view

 1. In the Timeline or Node view, select one or more elements.

 2. Do one of the following:

 l Right-click and select Tag and one of the following: 

 l In the Timeline or Node view menu, select Edit > Tag and one of the following: 

 l Timeline Tag: Tags selected elements in the Timeline or Node views.

 l Timeline Untag: Untags selected layer in the Timeline view.

 l Timeline Untag All: Untags all tagged elements.

 l Timeline Untag All Others: Untags all elements except the selected one.
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Hiding and Showing Specific Layer Types in the Timeline View
By default, the Timeline view will display every layer in your scene. You can choose to hide non-drawing layer 
types such as effects, groups and sounds from the Timeline view to de-clutter the list of layers and make it 
easier to select drawing or peg layers when doing cut-out animation.

How to show and hide layer types in the Timeline view

 1. In the top-left corner of the Timeline view, click on the  Menu button and select View > Show > 
Show Manager.

The Show Manager dialog box opens.

 2. Make sure the layer types you want to display are checked, and that the ones you want to hide are 
unchecked. 

 3. If you want these settings to persist after you close and reopen Harmony, click on Set as Default.

 4. Click on OK.

The unchecked layer types will now be hidden in the Timeline view.
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Chapter 16: Deformations
T-RIG-007-001

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. 
Deformations  act as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform 
a character made out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. 
This also allows you to take an area in a single bitmap image and create animation by distortion.

A deformation skeleton is composed of deformation nodes, which are the various pieces (here represented as 
layers or nodes) required to articulate or deform your drawings, such as a series of bones, curves or game 
bones.

NOTE 

It's important to note that the deformation feature was completely rebuilt in Harmony 12 to 
simplify the process and no longer works like it was in the previous releases. If you would like to 
convert characters with deformation chains created in Harmony 11 or before, you can use the TB_
ConvertLegacyDeformation.js script to do so—see About Legacy Deformations on page 128.
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About Deformation Types
The 4 types of deformers are: Bone, Game Bone, Curve and Envelope. Each type has its own advantages and 
limitations and need to be rigged and handled in different ways.

1546

Harmony 21 Premium User Guide                          



Chapter 16: Deformations

About Bone Deformations
T-RIG-007-002

The Bone deformation allows you to create a bone-like structure in which each part is solid, but with 
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or 
other parts that can be articulated such as torsos or fingers. 

For example, a Bone deformation can be used to articulate an arm that is made of a single drawing, so that the 
upper arm and forearm can be moved independently, without having to draw the upper arm and the forearm 
on different layers. Harmony will deform the drawing to make it look articulated. The different parts of a Bone 
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as 
animating articulations on different layers, without having to worry about parts detaching, pivot points, or 
clipping outlines.
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About Game Bone Deformations
T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like 
structure in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a 
character's limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For 
example, a Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that 
the upper arm and forearm can be moved independently, without having to draw the upper arm and the 
forearm on different layers. Harmony will deform the drawing to make it look articulated. The different parts of 
a Game Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
differences between the Bone and Game Bone deformations are that Game Bone deformations do not have 
Bias and Region of Influence properties. The articulation folds also look slightly more rounded.
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About Curve Deformations
T-RIG-007-004

The Curve deformation allows you to deform parts of a character using a Bezier curve. It is different from the 
Bone deformation in that the lines connecting the points are curvilinear. Hence, Curve deformations are 
typically used to deform parts of a character that are flexible, such as hair, mouths, eyebrows, or torsos. They 
can also be useful to animate limbs in a rubber hose style, where arms and legs are animated like extensible, 
flexible tubes rather than articulated bone structures.

By manipulating the curve's points and their Bezier handles, you can change the curve's direction, shape and 
length. A drawing rigged with a curve deformation does not merely bend, it will deform along its entire length 
to match the curve deformation's shape.
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About Envelope Deformations
T-RIG-007-005

The Envelope deformation allows you to create an envelope around a drawing, then deform the entire 
drawing by manipulating the envelope's points and curves. They can be used to deform parts of a character 
with a fluid shape, such as hair, cloaks, shoulders, chins and so on. Envelope deformations can also be used to 
deform rigid parts of a characters so as to make them look like they are seen from different angles. This is 
commonly done to make character rigs rotate without swapping drawings, and using this technique makes it 
possible to animate a character rig going from one angle to another without having to swap drawings or 
character models.

Envelope deformations are very similar to Curve deformations, except that their last point connects to their 
first point to make a closed shape. Also, contrary to Curve deformations, all points move independently from 
one another, whereas the first point of a Curve deformation offsets all its other points.

NOTE 

By default, Envelope deformations do not work properly on bitmap images and textures. This can 
be fixed by using a weighted deformation—see Creating a Weighted Deformation with Envelopes.
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About Free Form Deformations
The Free Form deformation allows you to deform drawings by creating points anywhere, either on their 
contour or inside their surface, and moving them around freely. It works a bit like laying down a piece of cloth 
with a pattern on a surface, then pulling on parts of this cloth to warp its shape and its pattern.

The Free Form deformation's main purpose is to deform textured shapes and complex drawings. Contrary to 
the Envelope deformation, which merely bends the contours of a drawing without deforming the texture inside 
it, the Free Form deformation stretches and squashes all the artwork between its control points. Moreover, 
since the Free Form deformation allows you to create points anywhere on a drawing, including inside its 
contour, you can actually control precisely how the texture is deformed. 
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About Creating Deformations
Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing.  However, whenever you close your project, the 
deformation controls display is turned off. When you reopen the project, you can display all controls or only 
some of them—see Displaying Selected Deformation Controls on page 83.
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About Selecting Elements for Deformation
Deformation groups are added to your scene's hierarchy in different places, depending on whether a drawing 
or peg element is selected.

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging tool, it 
is automatically created as a parent of the selected layer, and will affect the selected layer and all its children. 
Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you could rig 
the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and the hand is the 
forearm's child. Then, if you create your deformer on the upper arm, it will be created as a parent of the upper 
arm, and will hence affect the whole arm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you 
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's 
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers that 
are under a deformer, they will exit the intended deformation zone, and may appear severely warped and 
distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under deformers 
should only be animated if the deformer is left untouched. Since the deformer will be created as a parent of all 
the peg's children, it will affect all the layers under the peg. 
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Creating Bone Deformation Chains
You can add either Bones of Game Bones to your deformation chain by using different modes.

How to create a Bone                  or                     Game Bone                  deformer

 1. Once your element is selected, select the  Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the  Bone  mode or the  Game Bone  mode, depending on 
whether you're rigging for an animation project or a game—see Deformations on page 1545.

 3. In the Tool Properties view, enable the  Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in a 
deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 4. Click where you want to create the root articulation of the bone structure. The root articulation 
should be the one that is bound to the remainder of the body. For example, for an arm, the root 
articulation would be its shoulder.

 5. Click where you want the second articulation to be created. 

A bone will be created between the first and second articulation.

 6. Click where you want the next articulation to be created.

Observe that, as you create a new point, the previous point now has a circle around it. This is the 
radius of the articulation, which allows you to determine how much of the drawing should be part of 
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius. 
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 7. Click and hold the previous articulation's radius control point and adjust the articulation's radius so 
that it properly covers the articulation.

 8. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in 
the right order going from the root to the extremity.

NOTE 

It is possible to reuse a deformation group on another drawing, for example on a symmetrical body 
part, such as with the right and left arms. To do this, you need to rig the way you would for a multi-
pose character, using a Transformation Switch—see Creating Main Deformation Chains for Multi-
pose Rigs on page 119, as well as the Associate Parent Transformation Switch for Selected 
Elements button—see Reusing Deformation Groups for Multi-pose Rigs on page 121.
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Creating Curve Deformation Chains
Depending on your character and the style of animation you want to achieve, sometimes it is better to use 
Curve Deformers, instead of Bones, to rig your character.

How to create a Curve deformer 

 1. Once your element is selected, select the  Rigging tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the  Curve  mode.

 3. In the Tool Properties view, enable the  Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in a 
deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 4. Place the cursor where you want to create the root of your deformation chain. The root of the 
deformation chain should be where the body part is bound to the remainder of the body. For 
example, if you're creating a deformer for a whole arm, you should create its root point at the 
shoulder joint.

 5. Press and hold down the mouse button to create the point, then drag to towards the direction 
where you want your curve to bend to set the position of this curve's Bezier handle, just as you 
would when drawing a curve using the Polyline tool—see Creating Vector Shapes with the Polyline 
Tool on page 432.

 6. Press and hold down the mouse button at the location where you want the curve to end, then drag 
backwards and release the mouse button to create the Bezier handle before that point.

NOTE 

The Bezier handle after the point will be symmetrical to the Bezier handle before the 
point.

1557



 7. Repeat this process until you have finished building the Curve chain.

 8. As you go, you click and drag on the Bezier handles to adjust the curves of the deformation chain.

TIP 

When manipulating a Bezier handle, by default, the opposite Bezier handle for the 
same point will rotate in the same direction, keeping the point curved. If you want to 
make the point into a corner, press and hold the Alt key, then click and drag on one of 
the Bezier handles to rotate it without affecting the opposite handle.

NOTE 

It is possible to reuse a deformation group on another drawing, for example on a symmetrical body 
part, such as with the right and left arms. To do this, you need to rig the way you would for a multi-
pose character, using a Transformation Switch—see Creating Main Deformation Chains for Multi-
pose Rigs on page 119, as well as the Associate Parent Transformation Switch for Selected 
Elements button—see Reusing Deformation Groups for Multi-pose Rigs on page 121.
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Creating Envelope Deformation Rigs
Before adding deformations, you might want to use a default type of region of influence. You can set these 
parameters in the  Rigging  tool's properties—see the Reference guide  .

NOTE 

By default, Envelope deformations do not work properly on bitmap images and textures. This can 
be fixed by using a weighted deformation—see Creating a Weighted Deformation with Envelopes.

How to create an Envelope deformation rig

 1. Once your element is selected, select the  Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the  Envelope  mode.

 3. In the Tool Properties view, enable the  Automatically create a group when creating a new 
deformation rig  option so that your deformation chains are created inside groups. Every point in a 
deformation chain is an individual layer, so creating deformers with this option disabled is liable to 
clutter your Timeline and Node view.

 4. Place the cursor where you want to start creating your envelope. 

 5. Press and hold the mouse button to create the point, then drag to towards the direction where you 
want your curve to bend to set the position of this curve's Bezier handle, just as you would when 
drawing a curve using the Polyline tool—see Creating Vector Shapes with the Polyline Tool on 
page 432.

 6. Press and hold down the mouse button to create another point, then drag backwards and release 
the mouse button to create the Bezier handle before that point.
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NOTE 

The Bezier handle after the point will be symmetrical to the Bezier handle before the 
point.

 7. Repeat to create other points. 

 8. As you go, you can click and drag on the Bezier handles to adjust the curves of the envelope.
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TIP 

When manipulating a Bezier handle, by default, the opposite Bezier handle for the 
same point will rotate in the same direction, keeping the point curved. If you want to 
make the point into a corner, press and hold the Alt key, then click and drag on one of 
the Bezier handles to rotate it without affecting the opposite handle.

 9. Create every other point needed, until you're ready to close the envelope. 

 10. When you're ready to close Envelope deformer, hold down the Alt key and click on the first point of 
your deformation chain.
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Creating a Free Form Deformation
You can easily create a Free Form deformer using the  Rigging tool's  Free Form mode. 

How to create a free form deformation rig

 1. Select the drawing which you want to deform—see About Selecting Elements for Deformation.

 2. In the Deformation toolbar, select the  Rigging tool.

 3. In the Tool Properties view, enable  Free Form Mode.

 4. In the Camera view, click where you want to create your first deformation point.

 5. Repeat for each point you want to create.

 6. If you want to reposition a point, simply click and drag on it. If you move a point while the Rigging 
tool is selected, it will change the resting position of the point without deforming the drawing.
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 7. If you want to delete a point, click on it to select it, then press Del.
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Creating a Split Deformation Chain
It is possible to create a deformation chain that splits into multiple branches, allowing to rig complex drawings 
with multiple extremities using a single deformation chain. 

When creating a split deformation chain, a Deformation Composite node is automatically added to your rig. 
This deformation composite connects all the branches of the split deformation chain to the drawing it deforms. 
You can see which deformation nodes are connected to the Deformation Composite in the Node view.

How to create a split deformation chain

 1. Select the drawing layer or the deformation chain to which you want to add a branch. 

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer controls in the Camera view. This also hides all the deformer controls that 
were displayed.

 3. Select the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 4. In the deformation chain, select the point from which you want the new deformation branch to 
start.

 5. Place the cursor where you want your new branch's first point to be and click. A new chain is 
created.

 6. Create the remainder of your chain's points as you would create a regular deformation.
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NOTE 

When using the Rigging tool, you can select which existing deformation point you want the next 
deformation point you create to branch from at any time by selecting a point in the Camera view. 
When you create a deformation point, it is always linked to the currently selected point, if any. 
Creating a point automatically selects it, which is why deformations are built in a single chain by 
default. 
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Automatically Grouping Deformation Nodes
In a deformation chain, each deformation point is its own layer in the Timeline view and its own Node in the 
Node view. This can add a lot of clutter to a character rig that uses deformers. Harmony can automatically 
create deformation chains inside groups to keep your scene structure tidy and organized.

How to automatically group deformation nodes

 1. From the Deformation toolbar, click the Rigging  tool.

 2. In the Tool Properties view, in the Rig Tool Options section, enable the Automatically Create Group 
when Creating a New Deformation Rig option.

This option automatically creates a deformation group connected to the input port of the selected 
element. This group includes all the necessary deformation nodes  you created.
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Adding Deformation Nodes
The Node Library view allows you to manually add the nodes necessary to create the deformation skeleton. 
Additional nodes such as the Kinematic Output are available to create advanced rigs.

How to add a deformation node

 1. In the Node Library view, select the Deformation category.

 2. From the Node Library view, select a deformation node and drag it to the Node view. Note that the 
Glue,  Mesh Warp, Refract, and Turbulence nodes are not directly related to deformation rigging.
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About the Envelope Creator
The traditional method of creating envelope deformations is to create it point by point. However, since 
envelopes are often used to deform drawings and shapes around their outlines, having to create envelope 
deformation chains by tracing their outline with the Rigging tool may be redundant. 

Using the Envelope Creator, you can automatically generate a deformation chain that either wraps around the 
outlines of your artwork, or goes right through its shape. This can help you quickly generate envelope or curve 
deformation chains based on your artwork. 

Before making the Envelope Creator generate an envelope, you can configure the amount of points it should 
create on the deformation chain as well as how those points will be distributed along the shape. If the results 
of the Envelope Creator are not satisfactory, you can try tweaking the parameters and make it generate a new 
envelope, and repeat the procedure until you get the best deformation chain possible.
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Automatically Generating a Deformation Envelope or Chain Based on 
Artwork

Using the Envelope Creator, you can generate an deformation chain based on the contours or the centreline of 
the artwork in a layer. You can adjust the parameters of the Envelope Creator to determine the amount of 
points in the deformation chain, as well as how the shape of the envelope is processed. 

NOTE 

Using the Envelope Creator for the first time may require some trial and error with its  parameters 
before you can obtain the expected results.

How to generate a deformation envelope or chain based on artwork

 1. Select the node or layer for which you want to create a deformation chain.

 2. In the top menu, select Animation > Envelope Creator > Create Envelope.

The Envelope Creator dialog appears.

 3. If you want to create a deformation chain that goes through the artwork, enable the Create Single 
Center Line option. If you want to create a deformation chain that wraps around the artwork, make 
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sure this option is unchecked.

 4. Do one of the following:

 l If you want the Envelope Creator to determine the amount of deformation points to create in 
the chain, check the Use All Corners option.

 l If you would rather decide the amount of points to create in the chain, set the Deformation 
Points parameter to the amount of points you want in the deformation chain. The Envelope 
Creator will distribute those points to the corners of your artwork, giving priority to the 
sharpest corners. 

 5. If you want the small details in the contour of your artwork to be taken in account, you can lower the 
Discretizer Spacing parameter. If you want these details to be ignored so as to create a smoother 
envelope,  increase this parameter instead.

NOTE 

Setting this parameter too low may cause the Envelope Creator to hang for a few 
seconds when generating an envelope. 

 6. If you don't want the shape of the deformation chain to be as concave as the outer shape of your 
artwork, increase the Concave Smoothing parameter.
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 7. If you want the shape of the deformation chain to have softer corners and smoother angles than the 
outer shape of your artwork, increase the Smooth Passes parameter.

 8. If you want the shape of the deformation chain to be expanded around the shape of your artwork, 
so that its contour wraps around the outlines instead of meshing with them, increase the Expand 
parameter.

 9. If you want to add extra points to the longer segments of the envelope so as to break them up and 
have extra control on the envelope, increase the Bisect Curves parameter. The selected amount of 
points will be added to the entire chain, with priority given to the longest curve segments. For 
example, if the generated envelope has a segment that is much longer than the other ones and this 
parameter is set to 1, this longer segment will have an extra deformation point in its middle.

4



 10. Decide whether you want Envelope Mode to be enabled:

 l If disabled, the first point in the chain will serve as an offset for the whole chain. This means 
that moving this point will move the drawing and all its other deformation points 
simultaneously.

 l If enabled, the first point on the chain will be a deformation point like all the others. Moving 
this point will simply deform the drawing and will not affect the position of other points.

 11. If you want the deformation nodes to be laid out in the Node View similarly to how their 
corresponding deformation points will be laid out in the Camera view, enable the Shape Nodes in 
Node View option. This will make it easy to visually identify which deformation point in the Camera 
view corresponds to which node in the Node view.

 

 12. If you want very wide angle corners in the envelope to be smoothed, enable the Optimize Handles 
option. This will make it so the curve handles for corners that are almost at an 180° angle are 
aligned, which makes the point straight instead of being a corner.
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NOTE 

When two Bezier handles for a point are aligned, the point does not act as a corner, but 
rather as a control point for the curve of the shape. Rotating a handle that is aligned 
with the opposite handle also rotates the opposite handle, making sure that the point 
does not become a corner. You can rotate one of the handles independently from the 
other by holding the Alt key.

 13. Click on the Create Envelope button.

A deformation chain is created and placed as a parent to the current layer. 

 14. To view the deformation chain that was created, click on the Show the Selected Deformation 
Chains and Hide All Others  button in the Deformation toolbar.

 15. If you are not satisfied with the result, Undo by doing one of the following:

 l Press Ctrl + Z.

 l In the Edit toolbar, click on the Undo  button.

 l In the top menu, select Edit > Undo.

You can then adjust the parameters and try again.
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About Editing Deformations
As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation, 
you may need to make adjustments to the deformation chain to better fit your needs.

A deformation rig has a resting position and an animated position. The resting position is the original pose the 
character is in when not animated with keyframes. You can always revert your animated character to its 
resting position to recover the initial scale, angle, and shape. You can revert the entire character or only certain 
deformation chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the 
character in production.

You can also set additional parameters in the Layer Properties window—see the Reference guide .
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Editing the Resting Positions for Bone and Game Bone Deformations
Every deformation point has a resting position. The resting position is important as it acts as the starting point 
for all the transformations that will be made to the drawing when animating. Using the Rigging tool, you can 
make adjustments to the resting positions of the point in a deformation chain.

How to make adjustments to a Bone or Game Bone deformation chain

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to edit.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 1. In the Deformation toolbar, click the  Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 2. In the Camera view, set up the deformation chain.

 l To rotate the a bone, click and drag on it. This will rotate the selected bone and all 
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subsequent bones in the chain.

 l To offset the whole chain, click and drag on its root control point.

 l To reposition an articulation, click and drag on its control point.
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 l To adjust an articulation's radius, click and drag on its radius control point. Make sure 
the radius of the articulation covers the articulation itself.

 3. Repeat until all the articulations and bones of the chain are correctly aligned to the element to 
which it is linked. 

 4. Test your modifications using the  Transform  tool.

TIP 

When manipulating the articulation of a Bone or Game Bone deformer, you can press and hold 
the Alt key to lock the bone's angle and only shorten or elongate the bone. You can also hold 
the Ctrl (Windows/Linux) or ⌘  (macOS) key to break the articulation off its chain and make it 
into a new, separate deformation chain.

How to add an articulation to a Bone or Game Bone deformation chain

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to edit.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.
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The selected deformation controls appear in the Camera view.

 3. In the Deformation toolbar, select the  Rigging  tool.

The deformation chain turns from green to red, meaning that you are editing the deformation chain 
rather than animating it.

 4. Press and hold the Alt key.

 5. While holding the Alt key, click on the bone where you want to add an articulation.

NOTE 

You can only insert new articulations between existing articulations on Bone and Game Bone 
deformation chains.
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Editing the Resting Positions for a Curve Deformation Chain
Every deformation point has a resting position. The resting position is important as it acts as the starting point 
for all the transformations that will be made to the drawing when animating. Using the Rigging tool, you can 
make adjustments to the resting positions of the point in a deformation chain.

How to make adjustments to a Curve deformation chain

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to edit.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 1. In the Deformation toolbar, click the  Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red 
chain indicates the puppet is in a resting position. Make sure your chain is red.

 2. In the Camera view, setup the deformation chain.

 l Use the Pivot rotation handle to change the angle of the chain.
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 l Use the Pivot centre control point to reposition the entire chain.

 l Use the curve handles to modify the shape of the curve.

 l Use the curve’s square control points to resize and reposition each segment of the 
curve chain.
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 3. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You 
can also set additional parameters in the Layer Properties window—see the Reference guide .

 4. With the deformation nodes or group still selected, in the Deformation toolbar, click the  Reset 
Current Keyframe  button. This will set the current resting position as the current frame one.

 5. Test your modifications using the  Transform  tool.
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Editing the Resting Positions for an Envelope Deformation Chain
Every deformation point has a resting position. The resting position is important as it acts as the starting point 
for all the transformations that will be made to the drawing when animating. Using the Rigging tool, you can 
make adjustments to the resting positions of the point in a deformation chain.

How to make adjustments to an Envelope deformation chain

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to edit.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 1. n the Deformation toolbar, click the  Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red 
chain indicates the puppet is in a resting position. Make sure your chain is red.

 2. In the Camera view, set up the deformation chain.

 l Use the envelope’s square control points to resize and reposition each segment of the 
envelope chain.
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 l Use the curve handles to modify the shape of the envelope.

 3. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You 
can also set additional parameters in the Layer Properties window—see the Reference guide .

 4. With the deformation nodes or group still selected, in the Deformation toolbar, click the  Reset 
Current Keyframe  button. This will set the current resting position as the current frame one.

 5. Test your modifications using the  Transform  tool.
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Editing the Resting Positions of a Free Form Deformation
You can change the default position of individual points in a Free Form deformation using the  Rigging tool. 
You can also add or remove points, if needed.

NOTE 

Although Free Form deformation points can be rotated, you cannot change their default angle.

How to make adjustments to a Free Form deformation

 1. Select the drawing layer or the deformation chain for which you need to make adjustments. 

 2. In the Deformation toolbar, click the  Show the Selected Deformation Chain and Hide All Others 
button to display the deformer controls in the Camera view. This also hides all the deformer 
controls that were displayed.

 3. In the Deformation toolbar, click the  Rigging  tool.

 4. In the Camera view, make adjustments to the deformation by doing one of the following:

 l To change the resting position of a point, click and drag on it to reposition it.

 l To add a point, click where you want to add the point.
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 l To delete a point, select this point and press Del.
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About Weighted Deformations
The Weighted Deform node is a deformation node that creates a blended deformation from the regions 
defined by multiple sources. The deformation blends the points in a drawing or image  based on the distance to 
a deformation source and it is used to provide a clean deformed surface. It provides a high quality deformation 
render and prioritizes quality over speed.

Weighted deformations can be used to define and deform regions. This is useful for designs with a high level of 
detail. In this case, it helps to create volume by deforming along the axis lines of the hair and blending 
between the deformation regions.

A Weighted Deform node with two bezier curve deformations -- the Weighted Deform blends between the 
two curve deformations. Pixels and drawing contours are affected based on their distance from the individual 
deformation regions attached to the Weighted Deform

.The Weighted Deforms work well on both detail-heavy Harmony drawings as well as Bitmap textures.

19

Harmony 21 Premium User Guide                          



The Weighted Deform behaves as a hybrid of the Free Form Deformation and the Envelope deformation. 
Curves, pegs and other nodes can define the target regions of the deformation and the Weighted Deform 
node blends between these transformed regions—see About Envelope Deformations on page 1550 and 
About Free Form Deformations on page 1551.

It is currently compatible with bones, curve deformations and pegs. All of which can be combined to define 
deformable regions.

The deformations regions can be mixed and matched to best define the controls of the deformation and 
provide a deformation that works best for the needs of animation.
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Using the Weighted Deform
The Weighted Deform behaves as a composite for existing nodes and creates a blended deformation map from 
the attached regions. It can be used for both simple and advanced deformations and is best used when the 
region needs to blend the deformation uniformly from multiple sources.

The way that the Weighted Deform blends the deformation makes it particularly useful for deforming textures, 
as it is less prone to tearing than other deformation options. It is heavier to process than other deformation 
options, and should be used as an advanced option when other deformation options are not viable.
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Creating a Weighted Deformation with Envelopes
On its own the Envelope Deformation is designed to deform the contours of a drawings without affecting the 
width of its outline. This works very well with flat-colored cartoon drawings, but not with bitmap textures or 
detail-heavy drawings. Merely adding a Weighted Deform node to an envelope deformation chain will cause it 
to deform its textures evenly. 

For example, here is an envelope deformation on a character’s hair, before and after adding a Weight Deform 
node to the deformation chain:

As you can see, the standard envelope deformation tends to make the borders of the drawing stick to it and to 
stretch them along its outlines, and then it deforms the inside of the drawing to fill the gaps. This is designed 
to deform cartoon drawings quickly without affecting the thickness of their outlines. In contrast, the weighted 
envelope deformation deforms the drawing evenly inside the envelope, creating better results with textured 
drawings.
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NOTE 

Although using the Weighted Deform node with Envelope deformations produces better results 
with textured and detail-heavy drawings, it should be used with discretion:

 l A weighted envelope deformation has a heavier impact on application performance than a 
regular envelope deformation.

 l If the deformed drawing has outlines with an even thickness, the effect of the weighted 
envelope deformation may cause the outlines to stretch and have slight variations in their 
thickness.

How to convert a standard envelope deformation to a weighted envelope deformation

 1. Create the Envelope deformation chain for the drawing you want to deform—see Creating 
Envelope Deformation Rigs on page 1559.

 2. In the Node Library view, in the Deformation > Weighted category, select a Weighted Deform 
node and drag it to the Node view.
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 3. Create a connection from output port of the peg above the deformation chain to the rightmost input 
of the Weighted Deform node. This port is the common transformation that will be applied to all 
input deformations.

 4. Drag a cable from the output port of the deformation chain to the left side of the Weighted Deform 
node. A new input port will be created. Release the mouse button to create this connection.
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 5. Remove the connection going from the deformation chain to the Drawing node, and create a 
connection going from the Weighted Deform node to the Drawing node instead. 

NOTE 

Depending on the complexity of the drawing and the deformation, it may take a 
moment to generate the initial cache for the deformed drawings.

 6. Manipulate the Envelope deformation’s controls with the  Transform tool. The deformation will 
be blended by the Weighted Deform node and will evenly deform the texture and details in the 
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drawing.
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Creating a Weighted Deformation with Pegs
Another use of the Weighted Deformation node is that it can be connected to Peg nodes to create free form 
deformation points, similar to the Free Form deformation. The resting position of each point is determined by 
the pivot point of its corresponding peg. You can deform the drawing by moving a peg around, but you can also 
rotate, scale and skew the peg to create interesting warp effect that surpass the capacities of the Free Form 
Deformation.

NOTE 

For more information on the Free Form Deformation, see About Free Form Deformations on page 
1551.

With only two pegs attached to a Weighted Deform, the deformation will blend between the two 
transformations based on the distance from the peg’s pivot point. This allows you to create fairly organic 
deformations with very simple transformation controls.

The Weighted Deform is controlled by two peg transformations that are interpolated as a drawing 
deformation. This also allows you to simply deform a shape organically in a rig with contextual controls. It also 
allows you to attach pegs to a rig that dynamically modifies the deformation when the peg is transformed.
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How to create a weighted deformation with free deformation points

 1. In the Node Library view, in the Deformation > Weighted category, select a Weighted Deform 
node  and drag it to the Node view.

 2. While holding the Alt key, drag the Weighted Deform node over the connection between the 
Drawing node you want to deform and its parent peg. The Weighted Deform node should be a 
child of the Peg node and a parent of the Drawing node.

 3. Create a Peg node for each free deformation point you want to add. To create Peg nodes, do the 
following:

 l In the Node Library view, in the Move category, select a Peg node and drag it to the Node 
View.

 l Press Ctrl + P.

 4. Connect the output port of each Peg node to the input of the Weighted Deform node. New input 
ports will appear on the Weighted Deform node as you drag connection cables from other nodes 
towards it. 

 5. Connect the output port of the parent peg of the weighted deformation system to the input port of 
the Peg nodes you just created.

 6. In the Advanced Animation toolbar, select the  Translate tool.

 7. In the Node view, select one of the pegs.

 8. In the Camera view, click and drag on the peg’s pivot point to position it where you the resting 
position of its free form deformation point to be.

 9. Repeat the two previous steps for each peg that is connected to the Weighted Deform node, until 
the pivot point of all the pegs are positioned where you want the resting position of the free form 
deformation points to be. 
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TIP 

You can view the position of all the pegs connected to the Weighted Deform node by 
selecting the node, then displaying its controls.

To display the Weighted Deform node’s controls, do one of the following:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

You cannot manipulate the free deformation points displayed with this method. To 
manipulate the free deformation points, you must select their corresponding Peg nodes 
and manipulate them one by one with the  Transform tool. 

The Weighted Deform is ready to be used. To manipulate the free deformation points, you must 
select the Peg node that represents the point and move them individually with the  Transform 
tool. This can be tricky, as those pegs are not technically attached to a drawing, but to an effect 
node. Hence, clicking on the drawing will select the parent peg of the deformation system, and not 
the free deformation points. 

The most reliable way to transform a peg attached to the Weighted Deform is by selecting the Peg 
node in the Node view, then manipulating its bounding box in the Camera view. For example, you 
can move the peg by clicking and dragging close to the centre point of the bounding box.

You can also rotate, scale and skew each peg by manipulating their bounding box. This can create 
interesting warp effects.
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Creating a Rigid Point Deform
The Rigid Point Deformer is a type of weighted-deformation that prioritizes rigid transformations over 
deformations and is applied by tracking the position of attached pegs. It is particularly useful for tracking and 
deforming textures on characters and animated surfaces and is used with the Weighted Deformer node.

How to create a Rigid Point Deform Node

 1. The Rigid Point Deformer is attached to the deformer inputs of the Weighted Deform node. Rigid 
Point Deform uses its attached pegs to first transform, and then deform the attached drawing.

Each Rigid Point Deform node will define a deformed region that is transformed together. The deformed 
region is defined by the peg’s pivot point in relation to the others in the system. When only one region is 
defined, and there are fewer than 4 points, the deformation will behave as a simple transformation.
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 1. Only two points are defined in a single rigid deformation, this will behave as a standard 
transformation.

NOTE 

The Rigid Point Deform only considers the translation of the peg, the transformation in the 
deformed drawing is determined by the translated position of the pegs in the system. This 
makes it useful for tracking textures since the points only have to match key features of the 
underlying drawing, and the transformation is implied based on the translated pivots.
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With two Rigid Point Deform nodes, with two pegs attached to each, the system attempts to interpolate 
the defined regions while maintaining overall integrity of the initial texture.

How to track multiple points

 l The Rigid Point Deform node is also useful for tracking more points on a single texture. This is done 
by adding more pegs to a single pivot. 

 l In this mode, the Weighted Deform considers all points in the same system, prioritizes the 
transformation common to all points, and then deforms to best make up the difference.

This mode helps to limit unwanted issues in textures, while allowing the artist to track textures by simply 
moving the nodes.

 l Setting up the Rigid Point Deform in this way will allow an artist to move the points to tracking to 
corresponding points on a drawing. The deformation will first transform to best match the position 
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of the points, and then deform the drawing to make up the difference.
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NOTE 

In simpler examples, the Weighted Deformation seems quite similar to the Rigid Point 
Deformation when comparing the same translated points. The Rigid Point Deformation still 
minimizes some deformation at the fringes.

For example- Consider a hand-drawn drawing of a shirt that has to have a tracking texture applied. A 
Rigid Point Deform can be used to define rigid regions of the texture to stick to, and the pegs only need to 
be translated to match the new drawing. The deformation system defined by the Rigid Point Deform will 
do its best to first match the overall transformation, and deform to match internal regions.
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Combining Deformation Chains and Free Deformation Points
The Weighted Deform node can act as a composite for several deformation methods. You can combine one or 
several curve deformations, with each curve deforming their area of the drawing. You can combine a curve 
deformation with free deformation point, where each point deforms their area of the drawing, and the curve 
deformation acts like one long curvilinear free deformation point. You can also combine an envelope 
deformation with free deformation point. This creates a zone, and free deformation points will only deform 
areas of the drawings on their side of the envelope. 

For example, if you create an envelope inside a drawing, then add free deformation points outside of the 
envelope, the free deformation points will deform the drawing outside of the envelope only. 

Free deformation points are created by connecting pegs to the Weighted Deform node, and defining their 
pivot point as their resting position. To combine free deformation points with a deformation chain, or several 
deformation chains together, all you need to do is connect them all to the same Weighted Deform node. The 
Weighted Deform node is a lot like Composite node for deformations. It will have as many input ports as there 
are nodes connected to it.
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The steps below explain how to reproduce this specific deformation rig, which will result in the example 
further above. They can be adapted to combine any kind of deformations in a Weighted Deform node. 

How to set up a combined weighted deformation rig

 1. In the Node Library view, in the Deformation > Weighted category, select a Weighted Deform 
node  and drag it to the Node view.
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 2. While holding the Alt key, drag the Weighted Deform node over the connection between one of 
the Drawing nodes you want to deform and its parent peg.

 3. If the parent peg was connected to several Drawing nodes, connect the output port of the 
Weighted Deform node to the other Drawing nodes that were connected to that peg.
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NOTE 

Currently, the Weighted Deform node has only one input port. As you add free 
deformation points and deformation chains to it, more ports will be created left of that 
initial input port. This is because, when the Weighted Deform node has several input 
ports, the rightmost input port is specifically reserved for the drawing’s parent pegs, 
while all the other ports are for combining deformation chains and free deformation 
points.

 4. Creating the deformation chain that you want to combine. To do this, select the Weighted Deform 
node, then create the deformation chain with the  Rigging tool. Depending on the type of 
deformation chain you want to use, see Creating Bone Deformation Chains on page 1555, Creating 
Curve Deformation Chains on page 1557 or Creating Envelope Deformation Rigs on page 1559. In 
this example, an Envelope deformation chain is created.
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NOTES 

 l The Envelope Deformation will be used to constrain the hair to the head. 
Deformation regions are useful for both deforming regions as well keeping regions 
static in the blended map.

 l Typically, the Rigging tool automatically creates deformation nodes inside a single 
Group node. In this screenshot, the deformation nodes were not created in a group 
so as to better illustrate how the combination of deformation nodes works. 

 5. Create a Peg node for each free deformation point you want to add. To create Peg nodes, do the 
following:

 l In the Node Library view, in the Move category, select a Peg node and drag it to the Node 
View.

 l Press Ctrl + P.

 6. Connect the output port of each Peg node to the input of the Weighted Deform node. New input 
ports will appear on the Weighted Deform node as you drag connection cables from other nodes 
towards it. 
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 7. Connect the output port of the parent peg of the weighted deformation system to the input port of 
the Peg nodes you just created.

 8. In the Advanced Animation toolbar, select the  Translate tool.

 9. In the Node view, select one of the pegs.

 10. In the Camera view, click and drag on the peg’s pivot point to position it where you the resting 
position of its free form deformation point to be.
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 11. Repeat the two previous steps for each peg that is connected to the Weighted Deform node, until 
the pivot point of all the pegs are positioned where you want the resting position of the free form 
deformation points to be. 
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TIP 

You can view the position of all the pegs connected to the Weighted Deform node by 
selecting the node, then displaying its controls.

To display the Weighted Deform node’s controls, do one of the following:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

You cannot manipulate the free deformation points displayed with this method. To 
manipulate the free deformation points, you must select their corresponding Peg nodes 
and manipulate them one by one with the  Transform tool. 

The Weighted Deform is ready to be used. 

To manipulate the points in the deformation chain, simply the display the chain and manipulate its 
controls with the  Transform tool, as you would with a regular deformation chain—see About 
Deformation Animation on page 85.

However, to manipulate the free deformation points, you must select the Peg node that represents 
the point and move them individually with the  Transform tool. This can be difficult, as those 
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pegs are not technically attached to a drawing, but to an effect node. Hence, clicking on the 
drawing will select the parent peg of the deformation system, and not the free deformation points. 

The most reliable way to transform a peg attached to the Weighted Deform is by selecting the Peg 
node in the Node view, then manipulating its bounding box in the Camera view. For example, you 
can move the peg by clicking and dragging close to the centre point of the bounding box: 

You can also rotate, scale and skew each peg by manipulating their bounding box. This can create 
interesting warp effects.
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Creating a Dynamic Deformation
Since the Weighted Deform can use pegs as a deformation source, it also allows you to connect other nodes 
that work with pegs. An interesting combination is to use the Weighted Deform node with a Dynamic Spring 
node. The Dynamic Spring node is able to create a spring-like movement on a peg using tension and inertia. 
By rigging pegs used as deformation points for the Weighted Deform node to Dynamic Spring nodes, you can 
add a dynamic spring effect to individual parts of a drawing. 

For example, if you rig fluffy hair with points to a Weighted Deform node, and add pegs to the Weighted 
Deform nodes so as to animate the individual points, you can rig Dynamic Spring nodes to each peg. The result 
is that, if you move the hair around in the scene, a follow through animation will be automatically generated, 
based on that movement, for the individual deformation point. The points will trail behind the rest of the hair, 
then overshoot, then settle, creating the illusion of realistic hair physics.

NOTE 

For more information on the Dynamic Spring node, refer to the Reference Guide.

How to create a dynamic deformation using Weighted Deform and Dynamic Spring 
nodes

 1. Starting with the rig previously created in Combining Deformation Chains and Free Deformation 
Points on page 35, choose which sections of the hair will be given dynamics.
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 2. In the Node Library view, in the Constraint category, select a Dynamic Spring  and drag it to the 
Node view.

 3. While holding the Alt key, click and hold the Dynamic Spring node, then drag it over the cable 
above the peg for the point to which you want to add a dynamic spring effect. The Dynamic Spring 
node should be a parent of that peg, but a child of the that peg’s former parent peg. 
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NOTE 

Placing the Dynamic Spring between the main peg and the individual pegs will offset 
the transformation applied to the individual pegs dynamically. The individual pegs 
below the Dynamic Spring can still be offset and animated manually.

 4. Repeat steps 2 and 3 to add a Dynamic Spring node to every point to which you want to add the 
dynamic psring effect.
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Now, as the character moves, the pegs controlling the tips of the hair will have a follow through 
effect applied to them, with trailing, overshoot and settling, automatically added to them. Those 
pegs can still be offset and animated manually, and the dynamic spring effect will be updated 
automatically. 

 5. In the Node View, in the Constraint category, drag a Constraint Switch node to the Node View. 
Then, connect the output port of the Constraint Switch node to the leftmost input port of each 
Dynamic Spring node.
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The Constraint Switch will allow you to change the Active parameter of every Dynamic Spring 
switch simultaneously. This parameter defines the intensity of the dynamic spring effect on the 
movement.

 6. In the Node View, click on the Layer Properties button of the Constraint Switch node to open its 
layer properties. Then, change its Active parameter to see if you can obtain the desired intensity for 
the dynamic spring effect.

NOTE 

For more information on the layer properties of the Constraint Switch node, refer to the 
Reference Guide. 

 7. If you need to make more specific tweaks to the dynamic spring effect, click on the Layer Properties 
button of one of the Dynamic Spring nodes, and change its parameters as desired. Then, apply 
similar changes to all the other Dynamic Spring nodes. 

NOTE 

For more information on the layer properties of the Dynamic Spring node, refer to the 
Reference Guide. 
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Deforming Specific Areas in Backgrounds and Large Images
Since the Weighted Deform node uses defined regions to deform the image, it can be useful for deforming 
backgrounds and other complex images. Specific regions of the deformation can be defined and left static, 
while other areas are deformed as needed. This way, the deformation can be localized, deforming the image 
smoothly, while other areas remain unaffected.

NOTE 

The Weighted Deform is optimized for making high quality deformations on textures and complex 
drawings. As such, it can be heavier on performance than regular deformations.

Animating the interactions between a detailed bitmap background and elements in the scene can be 
complicated.  A Weighted Deform allows for regions of the background to be deformed while defining other 
regions to preserve.

In the example below, the background is deformed around the special effect to improve its impact. 

How to use the Weighted Deform node to make localized deformations on an image

 1. In the Node Library view, in the Deformation > Weighted category, select a Weighted Deform 
node and drag it to the Node view.

 2. While holding the Alt key, drag the Weighted Deform node over the cable connecting the 
background layer to its parent peg.
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 3. Create an Envelope Deformation chain around the area you want to initially deform in the 
background. To do this, select the Weighted Deform node, then create envelope with the  
Rigging tool—see Creating Envelope Deformation Rigs on page 1559.
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NOTE 

Typically, the Rigging tool automatically creates deformation nodes inside a single 
Group node. In this screenshot, the deformation nodes were not created in a group so as 
to better illustrate how the combination of deformation nodes works. 

 4. In the current state, if you move any of the deformation points, the entire background will be 
deformed, as if pulling on a cloth. To make sure that only a specific area of the background gets 
deformed, create another envelope deformation chain around that area.

This new contour will prevent the area outside of it from being deformed. The first interior 
deformation will interpolate from its region to the outside contour, and will not effect anything 
outside of its range.

 5. Using the  Transform tool, move some of the points in the inner envelope deformation chain.

NOTE 

Although subtle, the rippling effect in the wall is helpful to emphasize the effect. The 
outer contour isn’t animated and prevents deforming the outside region. The inner 
curve is rippled to deform the interior bricks.
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TIPS 

 l Several layers of envelope deformations can be added to create a detailed rippling 
effect.

 l It is recommended to keep the deformation chains as simple as possible so as to 
minimize the impact of the Weighted Deform node on Harmony performance. 
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About Regions of Influence

To increase the quality of your animation and the accuracy of the deformation effect, you can modify the regions 
of influence around the deformation chains. A region of influence is the zone around the deformer within which 
art will be influenced by the deformation. The deformer has the power to shape all art contained within the 
influence area on its own element or on its children elements. 

Zones of influence are different depending on the deformer type and zone type you selected. Note that the 
Game Bone deformers do not support regions of influences. Game Bone deformers are set to Infinite and 
cannot be changed.

You can find the settings for the zones of influence in the Layer Properties of the Curve, Bone and Envelope 
nodes, as well as in the Rigging tool properties.

To understand better the various parameters available in the nodes' layer properties, you should know more 
about the following terms:

 l Radius: The radius determines the size of a zone. The radius value is the length from the central point of 
the zone to its edge. By increasing the radius value, you increase the size of the area.

 l Transversal: The transversal parameter is related to the width of the zone in relation to the bone. The 
transversal value cuts across the bone.
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 l Longitudinal: The longitudinal parameter is related to the length of the zone in relation to the bone. 
The longitudinal value is parallel to the bone's length.

NOTE 

You can also prevent a child’s element from undergoing its parent deformation by connecting it 
through a kinematic output—see About Rigging Drawings to Deformations on page 65.
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Selecting Region of Influence Types
There are four types of region of influence:

 l Zero: This creates no influence around the deformer.

 l Infinite: This is the default option. The influence goes all the way to the image boundaries or until it 
intersects with another zone of influence. When working on a cut-out puppet built on several element 
layers, the best choice is to keep the default Infinite option as the zone of influence type. In the following 
examples, the zones of influence are explained through deformation chains on a single bitmap image. 
It's also recommended to keep the regions of influence to Infinite when using Envelope deformers.

 l Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value. 
When you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and 
make sure that only the element you want to follow the deformation is included inside the zone.

 l Shaped: This creates a custom region of influence around the deformer that can be adjusted using 
control points and Bezier handles. When you set up the boundaries of your Shaped zone of influence, 
you should be as accurate as possible and make sure that only the elements that you want to follow the 
deformation are included inside the zone.

  When you have an Elliptic zone of influence selected in the Node view, you can convert it to a Shaped 
zone using the Convert Elliptic Zone of Influence to Shape option.

How to select a region of influence type

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation 
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on 
page 83.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:

 l Zero

 l Infinite

 l Elliptic

 l Shaped
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Setting Up Elliptic Regions of Influence
An elliptical region of influence is suited for regular shapes. Modify its parameters to refine the region 
boundaries.

How to set up the Elliptic region of influence

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation 
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on 
page 83.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

 4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius
This defines the size of the fade area around the actual region 
of influence's boundaries.

Transversal Influence Radius 
Left

When the Symmetric Ellipse of Influence option is enabled, 
this field controls the Left and Right transversal radius 
values. When disabled, it controls the size of the left 
transversal radius. By default, this value is set to 2.

Transversal Influence Radius 
Right

When the Symmetric Ellipse of Influence option is enabled, 
this field becomes inactive. The Left Transversal radius value 
is automatically applied to the Right Transversal. When the 
Symmetric Ellipse of Influence option is disabled, it controls 
the size of the Right Transversal radius. By default, this value 
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is set to 2.

Longitudinal Influence 
Radius Begin

When the Symmetric Ellipse of Influence option is enabled, 
this field becomes inactive. The End Longitudinal value is 
automatically applied to the Begin Longitudinal value. When 
the Symmetric Ellipse of Influence option is disabled, it 
controls the size of the Begin Longitudinal radius. By default, 
this value is set to 0.25.

Longitudinal Influence 
Radius End

When the Symmetric Ellipse of Influence option is enabled, 
this field controls both the Begin and End Longitudinal 
radius values. When this option is disabled, it controls the 
size of the End Longitudinal radius. By default, this value is 
set to 0.25.

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be 
symmetrical on both the transversal and longitudinal radii. In 
this case, use the Transversal Influence Radius Left field to 
set the transversal radius value and use the Longitudinal 
Influence Radius End field to set the longitudinal radius 
value. The two other fields will remain unused unless you 
disable the Symmetric Ellipse Influence option. In that case, 
you can set up different radius sizes for the four radii 
directions.

 5. You can also modify the elliptic shape in the Camera view using the  Rigging  tool.
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 l If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the 
Camera view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging 
it left/right will modify both longitudinal radius sizes. Dragging it up/down will modify both 
transversal radius sizes.

 l If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera 
view. Drag the top-corner point left/right to modify the end longitudinal radius size and up/down to 
modify the left transversal radius size. Drag the bottom-corner control point left/right to modify the 
beginning longitudinal radius size and up/down to modify the right transversal radius size.
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Setting Up Shaped Regions of Influence
A Shaped region of influence is suited for irregular forms. Modify the region parameters to refine the shape's 
boundaries.

How to set up the Shaped zone of influence

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation 
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on 
page 83.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties, 
the zone of influence will be square. This square has control points on all four corners and each 
control point as two control levers. If you converted an Elliptic zone to a shape, the zone will have 
more control points and handles.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—see Setting Up Shaped 
Regions of Influence on page 59.

 l In the Camera view, use the Rigging tool and drag a control point to redefine its 
position and shape.
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 l Click and drag the control lever handle to modify the corners and redefine the shape.

 l Hold Alt down while dragging the control lever handle to move one handle at a time.
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Converting Elliptic Regions of Influence into Shapes
After you have tried tweaking an elliptical region of influence, you may find that you need to convert the 
ellipse into a shape, in order to create a more precise region. Instead of losing all the tweaks you have made, 
you can use the elliptical region you have created as a base for a Shaped region of influence.

How to convert an Elliptic zone of influence to a shape

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation 
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on 
page 83.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Tools toolbar, click the  Rigging  button.

 4. In the Tool Properties view, in the Operations section, click the Convert Elliptic Zone of Influence to 
Shape  button.

The zone of influence is automatically converted to a shape. The shape is retained and control 
points appear around the zone, so you can customize the shape. 
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Modifying Influence Fade Radii
To illustrate the zone of influence Fade Radius and its effect, the bitmap picture will be swapped with a grid 
pattern.

There is an area called the deformer Fade which surrounds the region of influence; this is the link between the 
strict boundaries of the zone of influence and the surrounding region. This area gradually stretches or squashes 
following the deformation. You can change the Fade Radius value to modify the size of this area and the 
exponent of the deformation fade effect. 

If you built a custom deformation system from the Node Library view and are using a Deformation-Switch node, 
you can change the default behaviour so the fading effect is inside the zone of influence instead of outside. This 
is explained in this example.

How to modify the Influence Fade radius

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation 
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on 
page 83.
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 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Layer Properties window, under the Region of Influence section, adjust the Influence Fade 
Radius field to modify size of the fading area. The default value is 0.5.

 4. If you built a custom node structure, using deformation nodes from previous versions of Harmony 
and are using a Deformation-Switch node, you can also set the fade radius there. In the Node view, 
select the Deformation-Switch node under the Deformation-Composite node in your deformation 
chain.

 5. In the Layer Properties window, set the following options:

Parameter Description

Influence Fade Exponent
Modify the exponent value or type the exact value in the field. 

 l A value of 1 is similar to a linear curve. 

63

Harmony 21 Premium User Guide                          



 l A higher value will result in an ease-in type of curve. 

 l A lower value will result in an ease-out type of curve.

Fade Inside Zones

By default this option is disabled, meaning that the Fade 
effect will occur outside the zone of influence. You can 
enable this option so the fade effect is inside the zone of 
influence.
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About Rigging Drawings to Deformations
After you have created all the deformation chains for your character, you will need to assemble these separate 
body parts into a puppet. 

Often, you need a body part to be offset by a deformer without that body part being deformed itself. For 
example, you may rig an arm to a deformation chain, and then want the hand to follow the end of that 
deformation chain. If you rig the hand directly under the deformation chain, it will get deformed in undesirable 
ways. 

In order to work around this, you can use the Kinematic Output node. This node is designed to take the position 
and angle of a deformation point and apply it to a drawing without deforming that drawing, as if it was a peg.

If you need to rig parts of your character to a specific part of a deformation other than one of its points, such as 
somewhere between two points along a deformation curve, or somewhere inside an envelope or free form 
deformation, you can use the Point Kinematic Node instead. This node is more complicated to use as it requires 
to be configured, whereas the Point Kinematic node will track the deformation point it’s connected to without 
any configuration, but it has a lot more capabilities. 

Guidelines for Rigging with Deformers

When assembling a character rig with deformers, the following guidelines should be kept in mind:

 l Before rigging drawings to deformers, make sure all the parts of your rigs are in their proper position.

 l It is important to avoid rigging pegs directly under deformers. The offset of the peg will be affected by 
the deformation which may cause undesirable results. If you need to offset a part of drawing that is 
rigged to a deformer, rig the peg above the deformation chain instead. 
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 l You will probably want to be able to manipulate and offset the parts of a rig that are connected to a 
Kinematic Output node. In this case, you can connect a peg between the Kinematic Output node and the 
drawing. It is especially important to set the pivot point of these drawings so that the animator can 
rotate and scale them without issue. For more information, see Setting Permanent Pivots on page 1416.
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Rigging a Drawing to a Deformation Point with the Kinematic Output 
Node
In order to assemble the rigged parts of your character to a specific deformation point, you need to add a 
Kinematic Output between the deformation node and the drawing node. The Kinematic Output node will act 
as a peg that follows the position of the deformation point it is rigged under, without applying any deformation 
to the drawing connected to it. 

You can add a Kinematic Output node in the Node View or the Timeline view.

NOTE 

The Kinematic Output Node can only be used to rig a drawing to a deformation point. If you need to 
rig a drawing to a specific area in a deformation chain, see About Rigging Drawings to 
Deformations with the Point Kinematic Output Node on page 71.

How to rig a drawing to a deformation point in the Node view

 1. In the Node Library view, go to the Deformation section, select the Kinematic Output node and 
drag it to the Node view.

 2. Pull out a second output connection (bottom port) from the deformer node you want your piece or 
limb to follow and connect it to the Kinematic Output port.
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 3. Connect the Kinematic Output node to the piece you want to follow the deformer.

‣ If it a good practice to rename the Kinematic Output node to reflect which deformer it is assigned 
to as the node structure can become very large and nodes can be positioned far apart. Select the 
Kinematic Output node and in the Layer Properties view, rename the node.

‣ You can pull out multiple connections from the same Kinematic Output node if many limbs and 
pieces must follow a single deformer. For example, you can use the same Kinematic Output node 
for both arms and the neck to follow the body deformer.
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How to rig a drawing to a deformation point in the Timeline view

 1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

 2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

 3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you 
want your limb or piece to follow. For example, onto the neck deformer if you want your head to 
follow it without being deformed or onto the arm deformer if you want your hand to follow.
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 l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder 
them—see About Ordering Layers on page 1408.

 l It's good practice to rename the Kinematic Output layer to reflect which deformer it is 
assigned to as the Timeline view can become very large and layers can be positioned 
far apart. Select the Kinematic Output node and in the Layer Properties window, 
rename the node. You can also double-click on the layer's name.
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About Rigging Drawings to Deformations with the Point Kinematic 
Output Node
The Point Kinematic Output is a more advanced version of the Kinematic Output node. While the Kinematic 
Output node can rig a drawing layer to a deformation point, the Point Kinematic Output can be used to rig a 
drawing layer to any point on a deformation curve, between two deformation points, without deforming the 
drawing.

While the standard Kinematic Output simply outputs the translation and rotation angle of a deformation point, 
the Point Kinematic Output can sample up to three point anywhere on a deformation curve. Using these three 
points, it can transform the drawing in any of the following ways, depending on how you configure it:

 l Translate the drawing to make it follow the curve, without rotating it.

 l Translate the drawing to make it follow the curve and rotate it to match the angle of the curve at that 
point.

 l Translate the drawing to make it follow the curve, rotate it to match the angle of the curve at that point 
and scale it proportionally to the length of the curve.

 l Rig the drawing to all three points, and transform it as needed to keep it rigged with those three points.

This is useful for creating rigs with elements that need to track with a deformation, while retaining their overall 
shape.
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NOTE 

For information on how to use the more simple version of this node, the Kinematic Output node, 
which rigs a drawing to a deformation point without requiring any configuration, see About 
Rigging Drawings to Deformations on page 65.
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Rigging with a Point Kinematic Output Node

The Point Kinematic Output behaves very similarly to the standard Kinematic Output node, except that instead 
of simply following the end point of the deformation, it will sample up to three points along the deformation 
curve, and output a transformation that tracks all three points.

How to Rig With a Point Kinematic Output

 1. With an existing deformation rig, prepare a drawing and place it in a location that you want to 
track on the deformed drawing.

 2. In the Node Library view, in the Deformation section, select the Point Kinematic Output node and 
drag it to the Node View above the drawing node that you want to rig to the deformation.
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 3. Drag out a connection from the output port of the deformation chain and attach it to the rightmost 
input port of the Point Kinematic Output node. Then, drag a new connection from the output port of 
the Point Kinematic Output node and attach it to the input port of the Drawing node.
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 4. Select the Point Kinematic Output node and display its controls in the Camera view by doing one of 
the following:a

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The tracking point of the Point Kinematic Output will appear in the centre of the Camera view.

 5. In the Tools toolbar, select the  Transform tool.

 6. In the Camera view, click and drag the tracking point and place it where you want the drawing to 
track to on the deformation curve. This is where the drawing will adhere to as the deformation is 
changed.

 7. Make changes to the deformation curve and observe that the drawing now moves along the curve.
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About Using Sampling Points with the Point Kinematic Output Node

The Point Kinematic Output allows for up to three different tracking points. Using multiple tracking points 
results in different transformations and allows for drawings to track and transform in different ways.

One-Point Sampling

One-Point Sampling will track the deformation and apply a simple translation in order to match the 
deformation. The applied transformation will have no rotation or scale, and will simply translate the drawing 
to match the tracking points.

Two-Point Sampling

Two-Point Sampling will track the deformation with two points and will apply a constrained transformation in 
order to match the deformation. The applied transformation will rotate and translate to best match the two 
tracking points, but will not scale. This sampling method is useful for having drawings rotate with a surface to 
track the deformed position, but not squash and stretch relative to the deformation.

Two-Point Sampling with Scaling
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Two-Point Sampling with Scaling will track the deformation with two points and will apply a constrained 
transformation in order to match the deformation. The applied transformation will scale, rotate and translate 
to best match the two tracking points. The squash-and-stretch is applied similar to the 2-Point Constraint, 
and uses the Volume Modifier Property to define the ratio of the squash and stretch.

Three-Point Sampling

Three-Point Sampling will track the deformation with three points and will apply a full transformation in order 
to match the deformation. The applied transformation will scale, rotate, translate and skew to best match the 
three tracking points. 

The Three-Points Sampling mode is especially useful for rigging a drawing to an area inside a deformed 
drawing. While the other modes use a limited set of transformations meant to track along a curve, the Three-
Points Sampling mode causes the Point Kinematic Output node to make all the necessary transformations  to 
make the drawing track with the shape of the deformed drawing.
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TIP 

The Point Kinematic Output can also be used to track points in an envelope deformation.
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About Using Multiple Point Kinematic Output Nodes

The Point Kinematic Output node is particularly useful when multiple drawings need to be constrained to a 
single deformation source. Each drawing can have its own Point Kinematic Output that provides a 
transformation tailored to the context of the drawing relative to the attached deformation. This is useful when 
constraining multiple drawings to a shape, such as limbs on a torso controlled by an envelope, or a number of 
trinkets attached to a necklace controlled by a single curve.

In this example, a necklace chain is rigged with three gems. The necklace is deformed by a curve deformation 
chain, while each gem is rigged with its own Point Kinematic Output node, which is configured to track a 
different point in the curve. This allows for each gem to transform based on its position on the chain.
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Additionally, this allows to transform each drawing in different ways. In this example, the central gem is using 
a Point Kinematic Output node with Two-Point Sampling as its Sampling Type. This allows the gem to 
translate and rotate along the curve without scaling. The gems on the edges are each using a Point Kinematic 
Output with One-Point Sampling, each set to a different point on the curve. this allows the gems to translate 
and track with the curve without any rotation or scale.
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About Using Deformations as Controllers

Sometimes, several drawing in a rig need to be constrained to a specific shape, such as the links in a chain, or 
books in a tall, wobbly pile. Such rigs require all their individual parts to follow a single curve, and animating 
each part of these rigs individually can be very tedious.

With the Point Kinematic Node, you can automatically constrain several drawings to a curve or envelope, 
without having to animate each drawing individually. Even if you don’t have a drawing to deform, you can 
create a deformation chain that is rigged to several Point Kinematic Output nodes, and hence use the 
deformation chain as an animation controller for all of these drawings.

In the example below, a deformation chain is rigged to four Point Kinematic Output nodes, each of which 
control a single link in a metal chain. The deformation chain is not deforming any drawing, it’s merely used to 
control the Point Kinematic Output nodes, which apply regular transformations to the position and angle of 
each link. 
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Displaying Selected Deformation Controls
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
controls won't display automatically. Likewise, deselecting a deformation chain will not hide its deformation 
controls. 

Before you can animate or modify an existing deformation chain, you must manually display it.

How to display deformation controls

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to display.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

NOTE 

The Show the Selected Deformation Chain and Hide All Others button will display all 
deformation chains that are in the hierarchy of the selection. For example, if the master peg of 
a character model is selected, all of its deformation chains will be displayed. Likewise, if 
multiple layers linked with different deformation chains are selected, all of their deformation 
chains will be displayed.
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Hiding Deformation Controls
If you no longer want to animate or modify deformers, you can hide the deformation controls so that they no 
longer clutter the Camera view.

How to hide deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard 
the current selection, then click on  the  Show Selected Deformation Chain and 
Hide All Others  button in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the  Show the Selected 
Deformation Chain and Hide All Others  button in the deformation toolbar.

 l In the Camera toolbar, click the  Hide All Controls  button. 

 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.
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About Deformation Animation
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on 
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a 
deformer, except it requires using the  Transform  tool instead of the Rigging tool. When the Transform tool 
is selected, deformation controls in the Camera view display in green, which means they are in animation 
mode, whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.

85

Harmony 21 Premium User Guide                          



Animating Bone and Game Bone Deformers
You can add keyframes to deformers reposition their deformation controls to create animated sequences.

How to animate Bone and Game Bone deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.
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 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l To rotate the whole limb, click and drag on the first bone. This will rotate the first 
bone and all subsequent bones.

 l To bend the limb, click and drag on another bone. This will rotate the bone and all 
subsequent bones, but will leave the bones before it in their current position.
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 l To reposition an articulation, click and drag on its control point. This can be used to 
rotate, shorten or extend the bone, and will offset all subsequent bones.

 l To shorten or extend a bone without rotating it, press and hold the Alt key, then click 
and drag on its control point.

 l To offset the whole limb, click and drag on its root point.

TIP 

You can also nudge an articulation in any direction by selecting it, then 
pressing on the arrow keys.

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:
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 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 13. Transform your deformer's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 

TIP 

You can also manipulate the deformers by selecting them, then typing their coordinates 
manually in the Layer Properties view.                  
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Animating Curve Deformers
Add keyframes and reposition the curve deformers to create animated sequences.

How to animate Curve deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.
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 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l Click and drag on one of the control points to shorten or extend the body part.
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TIP 

You can also nudge a deformation point in any direction by selecting it, 
then pressing the arrow keys.

 l Click and drag on one of the Bezier curve handles to deform the curve of the body 
part.

 l By default, if you rotate a Bezier handle for a point, the opposite Bezier handle for the 
same point will rotate along with it, influencing the curve on the other side of it. To 
rotate a Bezier handle independently from its opposite handle, click on this Bezier 
handle to select it. Then, while pressing and holding the Alt key, click and drag on 
this handle to rotate it.

 l By default, transforming a point in a Curve deformation chain does not offset 
subsequent points. To offset a point and all its subsequent points, press and hold the 
Ctrl (Windows/Linux) or ⌘  (macOS) key, then click and drag on the first point you 
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want to offset.

 l To rotate a point and all subsequent points, click on the Bezier handle after the point 
around which want subsequent points to rotate to select it. Then, while pressing and 
holding the Ctrl (Windows/Linux) or ⌘  (macOS) key, click and drag on that handle to 
rotate it. All the subsequent points will rotate around this handle's point.

 l Click and drag on the root point to offset the entire limb.
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 l Click and drag on the rotation handle behind the root pivot point to rotate the entire 
limb. 

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 13. Transform your deformer's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 

TIP 

You can also manipulate the deformers by selecting them, then typing their coordinates 
manually in the Layer Properties view.                  
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Animating Envelope Deformers
Add keyframes and reposition the envelope deformers to create animated sequences.

How to animate Envelope deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.
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 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l Click and drag on any of the control points located along the envelope to deform your 
drawing.                        
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TIP 

You can also nudge a deformation point by selecting it, then pressing the 
arrow keys.

 l Use the envelope's control point handles to modify the drawing's curves

 l By default, if you rotate a Bezier handle for a point, the opposite Bezier handle for the 
same point will rotate along with it, influencing the curve on the other side of it. To 
rotate a Bezier handle independently from its opposite handle, click on this Bezier 
handle to select it. Then, while pressing and holding the Alt key, click and drag on 
this handle to rotate it.

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.
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 13. Transform your deformer's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 

TIP 

You can also manipulate the deformers by selecting them, then typing their coordinates 
manually in the Layer Properties view.                  
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Animating a Free Form Deformation
You can animate the position and angle of each individual point in a Free Form deformation. 

How to animate Free Form deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.
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 8. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l Click and drag on the centre of a control point to reposition it.

TIP 

You can also nudge a deformation point by selecting it, then pressing the arrow 
keys.
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 l Click and drag on the purple handle right of a control point to rotate it. 

 11. Repeat for all the other control points until the drawing is deformed as intended.

 12. In the Timeline view, go to the frame on which you want to set the next key pose. 

 13. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 14. Transform your deformer's points to make your new key pose. 

 15. Repeat the previous steps until your animation is complete. 
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Animating Multiple Points
When animating Curve, Envelope and Free Form deformers, the position of each point is independent from one 
another. In situations where you need to animate several deformation points simultaneously, you can select 
several deformation points, then move then together. 

By default, this only allows you to move the selected points laterally. However, if you are working with Curve 
or Envelope deformations, you can also rotate or scale a selection of deformation points by using the Show 
Manipulator option of the Deformation toolbar. This option will display a manipulator bounding box with scale 
and rotation handles, which works similarly to the one you can use to transform drawing strokes with the 
Select tool or drawing layers with the Transform tool.

You can now skew and scale a selection of deformer points on each axis when using the deformation 
manipulator. Skew and scaling controls are now available when hovering near the edges of the manipulators 
controls.

NOTES 

 l You can only select and manipulate several points with Curve, Envelope and Free Form 
deformations.

 l You can only use the deformation manipulator with Curve and Envelope deformers.

How to select multiple points in a Curve, Envelope or Free Form deformation manually

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.
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 3. Click on one of the deformation points you want to animate to select it.

 4. While holding the Ctrl (Windows/Linux) or ⌘  (macOS) or Shift key, click on each other deformation 
point that you want to animate to add them to the selection.

 5. Click and drag on any of the points to move them simultaneously.

TIP 

You can also use the arrow keys to nudge the selected points in any direction.
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How to select multiple points in a Curve, Envelope or Free Form deformation using a 
lasso

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to animate.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to animate.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 3. In the Tool Properties view, enable  Control Selection Mode mode.

 4. Draw a lasso around all the deformation points you want to select.

The points in the lasso become selected.
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TIP 

If you already have points selected, you can hold Ctrl (Windows/Linux) or ⌘  (macOS) or 
Shift to add the points in your lasso to the selection.

 5. Click and drag on any of the points to move them simultaneously.

TIP 

You can also use the arrow keys to nudge the selected points in any direction.

How to use the deformation manipulator to animate multiple Curve or Envelope 
deformation points

 1. Using one of the two methods above, select several points in your curve or envelope deformation 
chain. 

 2. In the Deformation toolbar, enable the  Show Manipulator  option.

A manipulator bounding box appears around your selection.
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 3. If you want to rotate or scale your selection from a specific pivot point, drag and drop the pivot point 
of the manipulator to the preferred position.

 4. Do one of the following:

 l If you want to scale your selection, click and drag one of the square scale handles in the 
corner of the manipulator.

 l If you want to rotate your selection, position your mouse just outside of the manipulator, near 
a corner. When your mouse cursor displays a rotation wheel , click and drag to rotate the 
manipulator. 
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 l If you want to move your selection, click and drag on one of the selected points.

TIP 

You can also use the arrow keys to nudge the selected points in any direction.
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Resetting a Deformer to its Resting Position
You can reset the positions deformation points to their original resting positions, whether for the current frame 
or for the entire scene.

How to reset the position of one or several deformation points at the current frame

 1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the 
resting position.

 2. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to reset.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to reset.

 3. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 4. In the Camera view, select the deformation point you want to reset. 

TIPS 

 l You can select several deformation points by pressing and holding Ctrl, then 
clicking on each point you want to reset to add them to the selection.

 l When working with Curve or Envelope deformations, you can also select several 
deformation points by enabling  Control Selecton Mode in the Tool Properties 
view, then drawing a lasso or marquee around all the points you want to select. 

 5. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of 
the selected chain on the current frame.

How to reset the position of all the points of a deformation at the current frame

 1. Do one of the following:

108



 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to reset.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to reset.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 3. In the Timeline or Node view, select the deformation group you want to reset.

 4. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of 
the selected chain on the current frame.

How to set the position of all the points of a deformation chain throughout the scene

 1. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the 
deformation chain you want to reset.

 l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to reset.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 3. In the Deformation toolbar, click the  Reset All Keyframes button.
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Converting Deformer Animation to Drawings
You may  want to adjust your deformation animation. Convert deformation animations to drawing sequences, so 
you can adjust the drawings using the drawing tools. You may also want to change the timing and set it on 
double frames instead of single frame. Harmony offers you the option to convert your deformation animation to 
an actual drawing sequence.

How to convert deformation animation to drawings

 1. In the Timeline view, select the deformation frame range for which you want to convert to 
drawings.

 2. From the top menu, select Animation > Deformation > Convert Deformed Drawing to Drawings.

The Baking Drawing window opens. Wait for the baking to complete.

Your selection is converted to vector drawings.
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Disabling Deformations in the Camera View Preview
When adding new drawings while animating, you may need to see the reference drawings as their original 
resting position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable 
deformations in Harmony so that all drawings appear in their resting position.

NOTE 

Disabling deformations is only a display mode. Although drawings will not appear deformed in the 
Camera view, even in Render View mode, they will still be deformed in the rendered images.

How to enable or disable deformation preview

 1. In the Deformation toolbar, click on the Enable Deformations  button to toggle deformation 
preview.
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About Multi-pose Deformation Rigs (Transformation Chains)

Creating and rigging a full character turnaround can be achieved by creating multiple deformation chains on a 
same character without having to create completely different puppets.

For a simplified process, you can keep each view of your character separate in the Timeline or Node view.  If you 
create separate rigs for each view, then you can simply turn on or off the exposure of each view in the timeline 
when needed.

However, if you want to keep the entire character, with all views, in one group/rig on the timeline, then you can 
follow the process described here by  building a multi-pose deformation rig, also known as multiple 
transformation chains.
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About Character Preparation for a Multi-pose Deformation Rig
Before building a puppet’s deformation skeleton, you must prepare your character. The best way to proceed is 
to have the limbs on separate drawing layers. This is similar to a standard cut-out puppet preparation, but uses 
fewer pieces. Since this is a more advanced type of puppet, you should keep the character’s head, hands, feet, 
and facial features on a separate layer from the body, arms, and legs. This will prevent the extremities from 
being distorted if the limbs are stretched during an action. It will also let you use drawing substitution to swap 
hands, feet, eyes and mouth poses during animation.

There are many ways to break down a cut-out puppet. The example described in this chapter uses these 
pieces:

• Body • Left Ear • Right Ear

• Head • Left Eye • Right Eye

• Mouth • Left Eyebrow • Right Eyebrow

• Nose • Left Arm • Right Arm

  • Left Hand • Right Hand

  • Left Leg • Right Leg

  • Left Foot • Right Foot

Refer to the following topic to learn how to break down a character: Character Rigging on page 1361.   

113

Harmony 21 Premium User Guide                          



About Structure for Multi-pose Deformation Rigs
Each pose (transformation chain) you rig within the same element has to be part of a separate subgroup, all of 
which are gathered together by a Transformation-Switch node. The group name is not relevant in the multi-
pose structure. These subgroups can be renamed once the rig is complete. The Transformation-Switch node 
uses the drawing name to associate a transformation chain with it. If you rename a drawing after is has been 
linked to a transformation chain, you will have to manually change the drawing name associated to the chain 
in the Transformation-Switch layer properties. You might want to rename your drawing before you start 
rigging so the names correspond to the poses. For example: front, side, quarter, etc.
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Renaming Drawings for Multi-pose Deformation Rigs
Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear node structure 
for your project. If you leave your drawing as is and do not rename it, your deformation subgroups could become 
slightly confusing. If you plan to have several drawings using the same rig within an element, for instance, 
drawing substitution, then you should rename these extra drawings before starting your rig. 

How to rename drawings

 1. In the Xsheet view, locate the column that corresponds to the element which includes several 
drawings that will use the same chain, such as a character that has several costumes which you 
plan to swap by using drawing substitution. In our example, we will use the rabbit’s feet, which will 
all use the same deformation curve.

 2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged. 

 3. From the Xsheet menu, select Drawings > Rename Drawing or press Ctrl + D (Windows/Linux) or 
⌘  + D (macOS).

 4. In the Rename Drawing dialog box, type a relevant new name for the drawing and click OK.
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 5. In the Xsheet view, select the next drawing in the column and select Drawings > Rename Drawing 
from the Xsheet menu.

 6. In the Rename Drawing dialog box, type the same name that you gave the first drawing of the 
column, exactly as it is written and add and any number. For example, if the first drawing is named 
front, the subsequent drawings are named: front_1, front_2, front_3, etc.

 7. Repeat steps 5 and 6 for each subsequent drawing that needs to be renamed.
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Creating New Deformation Chains (Transformation Chains)
The process of creating multiple deformation chains on the same character is divided in four steps: creating the 
main chain, creating additional chains, renaming the chains, and associating additional drawings to the chains.

The drawings are associated with deformation chains. For example, if you want to rig the puppet's arm, you 
will need to add a deformation chain to the arm drawing. If the arm has multiple pieces such as upper arm, 
forearm and hand, you will create the deformation chain on the upper arm and afterward link the forearm and 
hand to that same chain. When creating the additional transformation chains on the other views of your rig, 
you will create them on the upper arm. The forearm and hand will not influence which chain is used. They will 
follow the upper arm chain. If the drawing exposure is changed on the upper arm, the deformation chain will 
change to the associated one. If the forearm or hand exposure is changed, the same deformation chain will 
remain. You must create the deformation chain on the drawing that will have the most influence when 
changing the puppet's view.

After creating your deformation rig, you may want to convert an animated character's pose to a new 
deformation chain. This can be useful when you want to add a pose to a turn-around deformation rig you have 
already spent time creating and manipulating. You can take the pose at the current frame and the state of the 
deformations and create a new drawing set along with a new deformation chain using the current position.
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Creating Main Deformation Chains for Multi-pose Rigs

The first step in creating a multi-pose rig is to create the main chain for the additional poses.

How to create the main deformation chain

 1. In the Timeline view, make sure the time marker is set to the frame displaying your first drawing. 

 2. In the Node view, select the drawing layer containing the drawing you want to create the chain for. 
If you want to create the chain for an arm composed in multiple pieces, you must select only one of 
the drawing layer, such as the upper arm. The additional pieces will be added afterward.

 3. In the Deformation toolbar, click the Create New Deformation Chain  button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

 4. In the Deformation toolbar, select the Rigging   tool.

 5. Create your deformer structure—see About Creating Deformations on page 1552.

 6. If needed, in the Node view, link the new deformation group to the additional pieces, such as the 
forearm and hand.
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 7. Repeat these steps for all the deformation chains that need to be created on the current puppet's 
view.

These chains are now the default deformation chains that will be used on all drawings not using a 
custom deformation chain.
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Reusing Deformation Groups for Multi-pose Rigs

When creating a deformation rig, you may want to copy and paste the deformation group created for a 
drawing and connect it to another drawing. For example, after creating a bone or curve chain for the arm of a 
character, you may want to copy and paste the deformation group to use it on the other arm. 

The problem with copying and pasting deformation groups is that the Transformation switch in the group will 
still point to the first drawing it was connected to. You can easily correct this problem by using the Associate 
Parent Transformation Switch with Selected Element button.

How to copy bones and curves

 1. In the Node view, copy the deformation group node.

 2. Paste the deformation group node.

 3. Connect the second set of drawings to the deformation group node. If these drawings are attached 
to a peg, be sure to put the deformation group between the drawings and the peg.

 4. Enter the Deformation group by clicking on its grey arrow.
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 5. Open the Transformation Switch properties by clicking on the yellow box.                     

Notice that the drawing that the Transformation Switch points to is the original drawing that it was 
connected to.

 6. Exit the deformation group to return to the main Node view.

 7. Select the drawing node connected to the copied deformation group. If there are multiple drawing 
nodes connected to the same deformation group, select the drawing at the top of the hierarchy or 
the one that makes the most sense for your setup.

 8. From the Deformation toolbar, click on the Associate Parent Transformation Switch to Selected 
Element  button. If you do not see this button in the Deformation toolbar, you need to add it—see 
the Reference guide .

The Transformation Switch now points to the correct drawing.
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 9. Rename the deformation group to match its associated drawings.
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Creating Additional Deformation Chains for Multi-pose Rigs

The second step to creating a multi-pose rig is to create additional chains. after the creation of the main chain.

How to create additional deformation chains

 1. In the Timeline view, move the playhead (current frame) to the character's next position.

 2. In the Node or Timeline view, select the drawing you want to set a new deformation chain 
(transformation chain) for. If you had previously selected the upper arm in a multiple parts arm 
structure, select the same drawing layer (upper arm).

 3. In the Deformation toolbar, click the Create New Deformation Chain  button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

 4. In the Deformation toolbar, select the Rigging   tool.

 5. Create your new deformer structure—see About Creating Deformations on page 1552.
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Renaming Transformation Chains on Multi-pose Rigs

Rename your transformation chains in order to keep track of and better organize your rig's various poses.

How to rename a transformation chain (deformation chain)

 1. In the Timeline or Node view, select the drawing layer containing the chains you want to rename. 
Make sure your current frame contains a deformation chain.

 2. In the Deformation toolbar, click on the Rename Transformation  button,

The Rename Transformations dialog opens.

 3. Rename the different transformation chains (deformation chains) to match the view they are 
associated with.

 4. Click OK.
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Linking Drawings to Transformation Chains

Link drawings to transformation chains, so that the drawings can be animated using the chains.

How to associate a drawing to a transformation chain

 1. In the Timeline or Node view, select the drawing layer containing the drawing you want to link to 
an existing deformation chain. The deformation chain has to exist on that same layer. You cannot 
associate a drawing to a chain created on a different layer.

 2. To associate the drawing to the chain, do one of the the following:

 l In the Deformation toolbar, select the desired chain from the Transformation Chain 
drop-down list.

 l In the Node view, select the Transformation-Switch contained in the deformation 
group and in the Layer Properties view, type the drawing name in the field 
corresponding to the desired chain. The drawing names must be semi-colon 
separated.
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Converting Drawings to New Deformation Chains

Link existing drawings to new deformation chains.

How to convert a drawing to a new deformation chain

 1. In the Timeline view, go to the frame you want to transform into an new pose (deformation chain).

 2. Select the drawing you want to convert and add a new chain.

 3. Do one of the following: 

 l From the top menu, select Animation > Deformation > Convert to New Drawing and 
Add Deformation Chain.

 l In the Deformation toolbar, click the Convert to New Drawing and Add Deformation 
Chain  button.

A new transformation is created and added to the list.
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About Legacy Deformations
Releases prior to Harmony 12 used a different deformation structure. The current structure is simplified.

128



Transferring Curve Positions of Legacy Deformations
You can Lets you transfer all of the information from first curve deformer to its parent Offset node. This is useful 
for a legacy scene created using Curve deformations where the Offset's position has been placed far away from 
the drawing to make sure it doesn't affect  the drawing's deformation. You can bring back the offset and give it 
the first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The 
offset no longer needs to be placed far away.

How to transfer a curve's position to its parent offset

 1. In the Node view, select the root Offset and the first curve.

 2. From the top menu, select Animation > Deformation > Set Curves and Offsets Independent from 
Parent.

 3. In the Node view, select only the first curve node.
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 4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.

In the Node view, the first Curve node is disabled and the values are transferred to the parent 
Offset node.
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Converting Legacy Deformation Chains
You can also convert a legacy deformation rig to the new format using a script. You can select which chain you 
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original 
puppet is maintained.

How to convert legacy deformation chains to the new structure

 1. In the Node or Timeline view, select the deformation group containing the chain you want to 
convert to the new structure.

 2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the 
toolbar, you can load it.

 l In the Scripting toolbar, click on Manage Scripts

 l In the Script Manager dialog, in the File column, select the TB_
CovertLegacyDeformation.js script. If you cannot find the script in the list (most likely 
due to a software upgrade installation), you can load the script through the Script 
Editor view from the default resources folder—see Importing Scripts in the Scripting 
guide.

 l In the Functions column, select TB_ConvertLegacyDeformation.

 l Click the Right Arrow button to move the function to the Scripting toolbar.
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 l Click OK.

The legacy chain is converted.
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About the Master Controller
T-RIG3-008-001

The Master Controller is a node that is capable of generating custom on-screen manipulators, or widgets, 
which can be programmed to affect one or several elements in a scene when manipulated. They are created 
and configured entirely through the scripting interface of Harmony. This allows you to create controls that can 
manipulate any amount of elements in your scene based on specific algorithms, making their capabilities 
virtually infinite. 

The end goal of master controllers is to give studios the ability to create tools that make it easy for scene 
planners and animators to manipulate rigs and objects in the way they were designed to be manipulated. For 
example, you can create a slider widget that rotates your character's rig in 360°, or a point widget that can be 
dragged around, which determines the direction your character's head is facing. For complex characters with 
many deformations, this removes the need for the animator to create poses manually, which can be tedious 
and can lead to going off-model, or to copy and paste poses from templates.

There are two approaches to creating master controllers: 

 l Wizard: Wizards are user friendly dialogs that allow you to generate master controller widgets by 
feeding them character poses and configuring how the widget will apply the different poses to the 
character.

 l Scripting: This method allows you to create a master controller of any kind for any purpose whatsoever. 
However, since it requires using the Harmony scripting interface, it is recommended to only attempt this 
if you have solid bases in scripting. 

Several types of Master Controller widgets can be created:

 l The Slider widget creates a slider that the user can slide. When manipulated, it generates a value 
between its minimum and maximum values which can be used to manipulate elements in the scene.
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 l The 2D Point widget creates a point that the user can freely drag around the stage. When 
manipulated, it provides its position, which can be used to position elements in the scene.

 l The Button widget creates a button that can be scripted to fire an action when clicked on.

 l The Checkbox widget creates a togglable button that can be scripted to do something different 
depending on whether it's toggled on or off, like a checkbox in an application.

 l The 2D Line Display widget displays a line going between two 2D Point widgets to make a "bone" type 
manipulator. It is not manipulable by itself, but the points to which it is linked are. 

 l The 3D Rotation widget creates a 3D sphere that the user can rotate in all directions. When 
manipulated, it provides an object with a rotation angle for each axis. 
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 l The X, Y and Z Rotation widgets create a circle that can be rotated around the stage around its axis. 
When manipulated, it provides a rotation angle for its respective axis.

 l The X, Y and Z Translation widgets create an arrow that can be dragged along its axis. When 
manipulated, it provides an offset for its respective axis.

 l The Label widget creates text label. It cannot be interacted with, but it can be combined with another 
widget to identify it, or to give any kind of directions to the animator.

 l The Custom widget can be composed of one or multiple elements from other widget types, and the 
behavior of which when manipulated can be customized. 

NOTE 

Master Controller wizards can generate slider and 2D point widgets. To generate any other kind of 
Master Controller widget, you must script it manually.
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About Master Controller Wizards
T-RIG3-008-003

Creating a Master Controller widget from scratch requires appropriate scripting skills and, depending on their 
purpose, generating data files that the Master Controller reads from to pose the characters. To streamline this 
process, Master Controller Wizards are provided with Harmony. Those wizards are scripts that allow you to 
generate fully functional Master Controllers by feeding them poses from your scene.

 l The Slider Wizard allows you to create a slider widget which changes the character's pose when 
manipulated. The slider will store a range of poses you feed it and, when you move the slider, will pose 
the character based on an intermediary between two of the poses it stored. It is very simple to use, but 
only allows for uni-dimensional control.

 l The Grid Wizard allows you to create a 2D point widget which changes the character's pose when 
manipulated. The slider stores one or several series of poses you feed it into a grid. When you move the 
2D point, it will apply a pose on the character that is the intermediary of the nearest poses assigned to 
the part of the grid where the point is. The Grid Wizard is more complex to use, as it requires you to 
create several rows or columns of poses, assign each pose to a point in a grid and, optionally, determine 
where the grid's centre should be and how big its cells should be. It can however create very useful 
tools for animators, such as 2D point widget that makes the character rotate or look in any direction, 
change its facial expression to an intermediary between several facial expression or even control one of 
the character's articulations. 
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 l The Stack Wizard allows you to create a Master Controller that combines the capabilities of a Grid and a 
Slider widget. It works by combining several grids together, making a "stack" of grids. When 
manipulating either widget, only one of the grids is used at any time. Which grid is used is decided by 
manipulating Slider widget, and which pose in the current grid is used is determined by manipulating 
the 2D Point widget. This can be useful for example if you want to create a Master Controller that can 
control both the direction in which a character is looking and their mouth pose or facial expression.

In the image below, you have a basic grid of poses that can be used to create a 2D point widget, which 
will make the character look in the direction of the point.

Then, if you create variants of this grid, you can add them to your Master Controller to make a stack of 
grids. In the image below, each variant of the grid represents the same character, with a different mouth 
pose.
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The result of this is a 2D point widget that determines the direction in which the character is looking, 
and a slider that determines the character's mouth pose.

 l The Deformer on Deformer Wizard allows you to combine a Curve deformer with an Envelope 
deformer. It works by making the Curve deformer manipulate the points of the Envelope deformer 
instead of deforming the drawing directly, leaving it to the Envelope deformer to deform the drawing 
instead. This makes it possible to combine the flexibility and versatility of an envelope deformer with 
the simplicity and ease of use of a curve deformer.
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 l The Function Wizard allows you to create a basic Master Controller to toggle the visibility of elements 
or controls in your scene or to set the parameters of specific nodes relative to the position of a Slider or a 
2D Point widget. It is useful when you need to quickly create a Master Controller with a basic purpose, 
to quickly generate a barebone Master Controller to build upon, or to learn about how a Master 
Controller and its code structure work and can be customized. 
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About Rig Structure and Master Controllers
Before using a Master Controller wizard, it is important to understand how the Master Controller will connect 
to your character rig and control its nodes. You read this topic carefully if you want to make sure that your 
Master Controller will work when you import your character in an animation scene. 

Each node in a scene is identified by its unique path, which starts with Top, followed by the hierarchy of 
groups in which it is located, and ending with its name. For example, the unique path to a scene's main 
composite is typically Top/Composite, and the unique path for a composite named master_comp inside a 
group named MyCharacter would be Top/MyCharacter/master_comp.

Master Controllers need to be able to locate the nodes they control using their path and their name. When 
you create a Master Controller by using one of the wizards provided with Harmony, you will be prompted to 
select which Composite node to connect the Master Controller to. The Master Controller node will be created 
in the same group as the Composite you selected, and will refer to each node it controls by its relative path 
from this group. 

For example, if you create the Master Controller at the root of the scene, and this Master Controller is meant to 
control a character inside of a group, it will refer to each node it controls by the name of the group, followed by 
the name of the node. Hence, to control hand_front-P inside group MyCharacter, it will use the path 
MyCharacter/hand_front-P. This means that if the group MyCharacter is renamed, the Master 
Controller will not work. Likewise, if you import the character twice in the scene, both their Master Controllers 
will control the first instance of that character, as that instance will be in the group MyCharacter, and the 
second instance will be in a group named MyCharacter_1. 

However, if you create the Master Controller inside the group MyCharacter, it will refer to each node in this 
group by their name only. To control hand_front-P, it will only need to refer to the node as hand_front-P. 
By using this approach, you can rename the character's group, and you can import as many copies of the 
character as you want, and its Master Controller will still work.

Hence, you should create your Master Controller inside the group of the character it controls.  Not only this will 
make your Master Controller impervious to changes in group names or hierarchy, it will make it easier to copy 
your character and its Master Controller into templates and scenes, as it will always come bundled with the 
character.

To accomplish this, three conditions must be met:

 l Your character's rig must be inside a group.

 l This group must contain a Composite node. 

 l The keyframes for the key poses you want to use to make your Master Controller must be inside this 
group. For example, if your character's group has a parent peg, you should not create keyframes on that 
peg to make your key poses. 
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NOTE 

If you want to make a Master Controller that only controls a specific part of your character (ie: the 
head), and this part happens to be contained inside a group with a composite, you can create your 
Master Controller inside that group instead. This will make it possible to import only that part of 
your character in a scene and use its Master Controller without issue. 

141

Harmony 21 Premium User Guide                          



About the Slider Wizard
T-RIG3-008-004

The Slider Wizard is a script that allows you to create slider widgets which can be used to pose a rig or any 
part of a rig. All it needs you to do is provided it with a few keyposes, and it will generate a Master Controller 
which will allow you to apply one of these poses, or an intermediary between two of these poses, to your 
character. 

For example, you can start by creating a front, 3/4 front, side, 3/4 back and back poses for your character. Then, 
you can use the Slider Wizard to generate a slider widget based on these poses, and you will have a slider 
widget that can instantly make your character face any angle.

The Slider Wizard is very simple to use. All it needs is for you to create your keyposes, feed them to it and it will 
generate a fully functional slider widget, without any need for scripting.

NOTE 

Since the Slider uses interpolations to create the intermediary poses between the poses you 
provide it, the poses you make for your character must be interpolatable. This means that they 
must use the same layers and the same drawings, and must rely exclusively on deformations and 
geometric transformations to create the different poses. 

142



About Preparing a Character's Poses for the Slider Wizard

To use the Slider Wizard, you must select a range of frames in the Timeline view. The Slider Wizard will store 
the pose of your character at each frame in the selected range, and create a Master Controller with a Slider 
widget that, when manipulated, either applies one of these poses or an intermediary between two of these 
poses to your character, depending on where you move the handle of the slider. 

Key & Breakdown Poses

Make sure to prepare enough key and breakdown poses for it to be able to properly pose your character. A 
Master Controller generated by the Slider Wizard will generate intermediary poses between the poses you 
provide it as needed. Hence, it is not necessary to provide it with each possible pose that you want the slider 
widget to be able to apply to your character. However, the intermediary poses generated by the Master 
Controller are made with simple linear interpolation. This means that these generated poses may lack 
precision if your key poses require breakdowns between them to be properly interpolated. 

For example, if you simply provide the Slider Wizard with a pose of your character facing left, and one of your 
character facing right, there is no way the Master Controller will know how to pose your character to make it 
face the camera when the slider handle is in the middle. Hence, you would have to at least provide the Slider 
Wizard with a pose of your character facing the camera, and optimally poses of your character facing each 
direction at a 45° angle, so that the Master Controller is able to generate credible, on-model poses regardless 
of where the handle is on the slider. 

Interpolations

It is also important to not provide an unnecessarily wide range of frame to the Slider Wizard, as it will store a 
copy of your character's pose in each and every frame in the selected range of frames into a database file inside 
your scene folder. Hence, if you select a wide range of frames, your scene will be heavier because the pose 
database of your Master Controller will take multiple megabytes of disk space, and the slider widget will take 
more time to load as well as to refresh when manipulated as it will have to sort through all this data. 

For example, if you select a range of 30 frames with three animation keyframes: one at the beginning, one in 
the middle and one in the end, the Slider Wizard will store the character's pose on each of those 30 frames in 
the database. You can have the same results, and save a significant amount of disc space and computer 
resources, by sticking the three keyframes next to each other and selecting them. This will make a Master 
Controller with a database of three poses. When theSslider widget is manipulated, it will generate the 
interpolations between those poses on the fly.
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Range of Poses

At last, to launch the Slider Wizard, you must first select the range of poses you want to use in a contiguous 
selection. Hence, you should copy and paste all the poses you want to use in a specific range of frames, so that 
they make a cluster and that there are no superfluous pose between the useful poses. Your poses should be in 
the right order so that the slider can interpolate from one pose to the next smoothly. 

Summary

In summary, before using the Slider Wizard:

 l Make sure you have all the necessary key poses and breakdowns for proper interpolations.

 l Make sure you do not have any unnecessary in-betweens or interpolations between your key poses and 
breakdowns.

 l Copy and paste all the poses you want to use with the slider into one contiguous cluster of frames.
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Using the Slider Wizard

Using the Slider Wizard is very simple. All you need to do is select the range of poses you want the slider to 
interpolate between, select which layers or groups the slider widget should control and the wizard will 
generate a Master Controller for you.

How to generate a slider widget using the Slider Wizard

 1. Make sure your rig as well as your key poses are inside a group with a Composite node—see About 
Rig Structure and Master Controllers.

 2. Prepare all the poses you need to provide to the Slider Wizard in a single continuous range of 
frames—see About Preparing a Character's Poses for the Slider Wizard.

 3. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.

 4. In the Timeline view, on the group containing your character rig, select the range of frames you 
want to use for the Slider.
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NOTES 

 l If you select a group, everything inside the group will be added to the list of layers 
controlled by the Master Controller. 

 l If you select a collapsed peg in the Timeline view, its children will not be added to 
the list of layers controlled by the Master Controller. You must expand the peg and 
select its children as well. 

 5. In the Master Controller toolbar, click on the  Slider Wizard button. 

The Slider Wizard dialog appears.

 6. Check mark the Automatically Filter Attributes checkbox to remove the extra attributes that are 
not changing.

 7. In the Monitored Attributes list, expand the Top item. 

The nodes you selected will appear in the list, in a group-based hierarchy. You can expand groups 
in the list to see the nodes inside them as well. All the nodes in this list will be controlled by your 
Master Controller. 
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 l If you want to add nodes to the list of nodes that will be controlled by the Master Controller, 
select these nodes in the Timeline or Node view, then, in the Monitored Attributes section, 
click on the Add Selected Nodes button. 

 l If you want to remove nodes or attributes from the list, select them in the list, then click on 
the Remove Selected Items button.

 8. Click on the  Filter Attributes button under the Monitored Attributes list to remove any nodes or 
attributes that do not change in the selected frame range from the list of controlled attributes. This 
will optimize the performance of your Master Controller. 

 9. If you want the slider to interpolate from the first pose to the last pose by going from the top of the 
slider to the bottom, instead of from the bottom to the top, check the Invert Direction option. 

 10. If you want the slider to be horizontal rather than vertical, check the Horizontal Layout option. By 
default, the slider will interpolate from the first pose to the last pose by going from left to right, 
unless you checked the Invert Direction option, in which case it will go from right to left.

 11. In the Output section, in the Name field, type in the name you want to give to your Master 
Controller.

 12. Click on the Create button.

 13. A dialog prompting you to select a Composite will appear. In this dialog, select a Composite inside 
the group for your character rig. This will create the Master Controller inside your character rig's 
group, ensuring that it is always copied over with your character when you create templates and 
import them into scenes—see About Rig Structure and Master Controllers

 14. Click on OK.

 15. A Save dialog appears. It prompts you to select where to save the database file in which the 
character's poses will be saved. The dialog will open in the scene's scripts sub-directory by default 
and will give the database file a name based on the Master Controller's name. Hence, you can just 
click on Save right away. 

Your Master Controller has now been created and is added to your scene.
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The Master Controller's Slider widget is visible in the Camera view. 

 16. In the Timeline view, move the timeline cursor to a frame outside of the selected range of frames, so 
as to not override one of your poses. 

 17. In the Tools toolbar, select the  Transform tool. 

 18. In the Camera view, click and drag on the handle of the Slider widget to test your Master 
Controller. 
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TIP 

At any time, you can show or hide the Master Controller's widget by selecting it in the 
Timeline or Node view, then doing either of the following:

 l In the Camera view toolbar, click on the  Show Control  button.

 l In the top menu, select View > Show > Control.
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About the Grid Wizard
T-RIG3-008-005

The Grid Wizard is a script that allows you to create a 2D point Master Controller which can be used to 
position a character rig. For example, you can make a 2D point widget which can be used to rotate your 
character or their head, change their facial expression, or position one of your character's articulations. 

The way this work is by providing the Grid Wizard with a grid of key poses. For example, by providing it with a 
grid of poses such as the one below, you can generate a 2D point master controller which will make the 
character look in the point's direction as you move that point around in the Camera view. 

The Grid Wizard will generate poses for your Master Controller that interpolate between the poses you feed it. 
This way, you only have to create poses in key angles (ie: 0°, 45° and 90°) and the Grid Wizard will generate a 
Master Controller that can pose your character at any angle between those key angles.  

NOTES 

To use the Grid Wizard and the Master Controller in this way, the poses you feed it must be 
interpolatable. This means that they must use the same layers and the same drawings, and that 
their differences must rely on deformations and geometric transformations. 

Once you have fed the Grid Wizard with your poses, it will generate a Master Controller node which will 
display a 2D point widget in the Camera view. By moving this widget around, the character's pose will change 
to an intermediary of one of the poses you provided, depending on where the point is moved.

The Grid script works well with 360 rigs, but it can also be used for any purpose where part of a character rig 
can vary between four or more key poses. For example, you can also use this mechanism to make the character 
interpolate between four facial expressions.
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You can also create a 2D point widget which will control a specific articulation of your character. 

You can also use it to create a 2D point to attach a specific articulation of your character to a 2D point widget. In 
the example below, we position the character's arm based on four different wrist positions, all of which trace a 
square. Using those four poses, you can create an grid of 2 × 2 poses, allowing you to position the character's 
wrist, and its whole arm along with it, using a 2D point widget.
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About Preparing a Character's Poses for the Grid Wizard

The most important thing to do before you can use the Grid Wizard is to create a grid of poses in your scene. 
This means that you must create a series of poses in your scene's timeline, each pose on a different frame, until 
you have enough poses to associate one pose for each intersection of the grid you intend to create. 

The timeline of a scene is linear, but you will need to associate each pose you will feed to the Grid Wizard to 
one of the points in a rectangular grid. You will get to decide how many rows and columns the grid will have, 
giving you control on how many poses and which kind of poses you will have to create. However, when 
creating your poses, you must keep in mind that each row must have the same amount of poses as other rows, 
and each column must have the same amount of poses as the other columns. This is important so that you can 
have one pose to associate to each point in the grid.

You will have to associate each point in the grid with a pose in your scene manually, one by one. Hence, it is 
recommended to sort out your poses neatly. You can cluster your poses by row, then order them by column, or 
cluster them by column and order them by row. Then, if you want, you can use scene markers to separate each 
row or column in the Timeline view—see About Scene Markers on page 296.
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About the Centre Position and Cell Size of a Grid

When you launch the Grid Wizard, you are first prompted with the Grid Parameters dialog, in which you can 
set up the size of the grid, but also its centre position as well as the size of each cell in the grid.

The coordinates used for the centre position and the cell size are in fields, and are based on the field grid  used 
to position objects in your scene. This is a traditional, 12 fields, 4:3 animation grid, with its centre coordinates 
being (0, 0), and with horizontal coordinates incrementing from left to right, and vertical coordinates 
incrementing from bottom to top. You can see how a traditional animation grid, when laid out on your scene, 
corresponds to the grid displayed in the Grid wizard in the following side by side comparison:
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NOTE 

To lay out an animation grid over your scene, simply add a Grid node and connect it to your scene's 
main composite.

When you display a 2D point widget created with the Grid Wizard, it will appear somewhere inside the area 
covered by the grid it was created with. When you move it around, it will be able to move up to the edges of 
that grid. Hence, by adjusting the centre position and cell size of your grid before you create it, you can make it 
so the position of the part of your character rig you want to control closely matches the position of the 2D point 
as you move it. 

For example, if we want to create an grid of the following set of poses, we need to create a grid of 6 vertical 
poses × 3 horizontal poses:

At the default centre position (0, 0) and cell size (2 fields × 2 fields), a grid of 6 × 3 poses would occupy this 
area of the scene:
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An animator would have to move the 2D point widget in this rectangular area to control the direction in which 
the character is looking. This is not intuitive. What would be preferable is a grid like this:

To obtain such a result, you would first need to figure out the ideal centre position of the grid. In this case, it is 
the centre of the character's nose which, according to the grid, is in the middle on the horizontal axis, and 6 
fields north on the vertical axis, making its exact coordinates (0, 6). 

Then, you would need to adjust the cell size to obtain a less rectangular, more square-like grid. In this case, the 
default cell size was set to 1 horizontal field and 3 vertical fields, or 1  field ×  3 fields. Although this makes 
vertical rectangular cells, since we have 6 columns for 3 rows, the resulting grid is nearly square-shaped. 

By calculating and using precise coordinates, you can even create a 2D point master controller that appears to 
be attached to a specific articulation of your character. For example, let's say you are working with the four arm 
poses, and you want to create a 2D point widget that will be attached to the wrist:
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You could spread those four wrist poses at the corners of a rectangle, grid, like so:

A rectangle can be represented by a simple grid of 2 poses  x 2 poses, which has a single cell. The size of ts cell 
size would determine the size of the entire grid. Hence, you would simple have to figure out the size and centre 
coordinates and size of this rectangle, in fields, and create an gird of 2 x 2 poses, positioned at the centre of this 
rectangle, and with a cell size that is the size of this rectangle. In this case, the rectangle is 6 x 8 fields, and its 
centre is at (2.5, 2.5).
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Using the Grid Wizard

T-RIG3-008-006

Before using the Grid Wizard, you must create all the poses required for your Master Controller. To do this, you 
can create a scene with your character rig in it, and put each possible pose for your character on a different 
frame of the scene. The Grid Wizard will use the frame number of each frame containing a pose as an identifier 
for the pose. 

Once your character's key poses are properly laid out in your scene's timeline, the next step is to select the 
nodes which you intend to animate with the Master Controller in the Node view, then launch the Grid Wizard. 
This wizard will allow you to associate parts of your grid to frames in your scene. 

How to generate a 2D point Master Controller using the Interpolation Grip wizard

 1. Make sure your rig as well as your key poses are inside a group with a Composite node—see About 
Rig Structure and Master Controllers.

 2. Prepare all the poses you need to provide to the Grid Wizard—see About Preparing a Character's 
Poses for the Grid Wizard on page 152.

 3. Calculate the centre point and cell size of the grid you want to create—see About the Centre 
Position and Cell Size of a Grid on page 154.

 4. In the Node or Timeline view, select all the layers that you want the 2D point Master Controller to 
control. 

NOTES 

 l If you select a group, everything inside the group will be added to the list of layers 
controlled by the Master Controller. 

 l If you select a collapsed peg in the Timeline view, its children will not be added to 
the list of layers controlled by the Master Controller. You must expand the peg and 
select its children as well. 
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 5. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.

 6. In the Master Controller toolbar, click on the  Grid Wizard button.

The Grid Wizard dialog appears.

The Load Preset dialog appears just over it. This dialog can be used to load a grid preset, or to 
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create a new grid by specifying its width, height and, optionally, its centre point and cell size.

 7. If you already created a proper grid preset for your character, select it in the Preset field. Otherwise, 
skip this step. 

 8. In the Key Poses fields, type in the amount of horizontal poses per row under X, and the amount of 
vertical poses per column under Y.

 9. If you calculated the desired centre position of your grid, type in its centre coordinates in the Center 
fields. Type in its horizontal position in fields under X and its vertical position in fields under Y.

NOTES 

 l For information on how to calculate the centre point of your grid, see About the 
Centre Position and Cell Size of a Grid.

 l If you skip this step, the default position of your 2D point widget will be the centre of 
your scene. 

 10. If you calculated the optimal cell size for your grid, type it in the Cell Size fields. Type its horizontal 
cell size in fields under X and its vertical cell size in fields under Y.

NOTES 

 l For information on how to calculate the cell size of your grid, see About the Centre 
Position and Cell Size of a Grid

 l If you skip this step, the size of each cell in your grid will be 2 horizontal fields × 2 
vertical fields. 

 11. Click on OK.

The dialog will close and you can now use the Grid Wizard dialog. In the top half, the grid view 
displays the grid you just configured, with each point represented by a red dot. 

160



TIP 

If you want to return to the Load Preset dialog, click on the  Load Preset button on 
the left edge of the Grid Wizard dialog. 

IMPORTANT 

If you create a new grid or load an existing grid preset while working on a grid, any 
work you have put on the currently loaded grid will be discarded. 

 12. If needed, adjust the grid view to see the entire grid:

 l To pan the view, click and drag on it.

 l Click on the  Zoom In button right of the grid view to zoom in on the grid or on the  
Zoom Out button to zoom out from the grid.

 13. In the Monitored Attributes list, expand the Top item. 

You will see all the nodes you had selected, in a group-based hierarchy. These nodes will be 
controlled by your Master Controller. 
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 l If you want to add nodes to the list of nodes that will be controlled by the Master Controller, 
select these nodes in the Timeline or Node view, then, in the Monitored Attributes section, 
click on the Add Selected Nodes button. 

 l If you want to remove nodes or attributes from the list, select them in the list, then click on 
the Remove Selected Items button.

 14. In the Timeline view, click and drag the playhead until you find the pose you want to associate with 
the top-left point, then make note of the frame number. 

NOTE 

Even while the Grid Wizard dialog is open, you can click and drag on the playhead in 
the Timeline view to preview different frames and find the frame containing the right 
pose. 

 15. In the Visual Grid area, click on the top-left red point.

A Select Frame dialog appears.

 16. Type in the frame number of the pose that you want to associate with this point.

 17. Click on OK.

In the Grid View, the frame number appears just right of the selected point.
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TIP 

While a point is selected, you can update its Frame number and customize its identifier 
and its position in the grid in the State properties section.

 18. Repeat the last three steps for each point in the grid until every point is associated with a frame 
number. A point that is assigned to a pose will appear in green, whereas points that are not appear 
in red.
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NOTE 

You must associate every point with a pose before you can create your 2D Master 
Controller.

 19. Once you are done configuring every point in your grid, select the point where you want the 2D 
point widget to appear by default. 

 20. If you want to re-use the same grid for other characters later, click on the  Create Grid Preset 
button to save the grid as a preset. You will be prompted to type in a name for your grid preset. 
Later, you can select this preset from the Grid Parameters dialog when you launch the Grid Wizard.

 21. Under the Monitored Attributes list, click on the  Filter Attributes button to remove any nodes 
or attributes that do not change in any of the poses you added to the grid. This will optimize the 
performance of your Master Controller. 

 22. In the Output section, in the Name field, type in the name you want to give to your Master 
Controller.

 23. Click on the Create button.

 24. A dialog prompting you to select a Composite will appear. In this dialog, select a Composite inside 
the group for your character rig. This will create the Master Controller inside your character rig's 
group, ensuring that it is always copied over with your character when you create templates and 
import them into scenes—see About Rig Structure and Master Controllers.

 25. Click on OK.
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 26. A Save dialog appears. It prompts you to select where to save the database file in which the 
character's poses will be saved. The dialog will open in the scene's scripts sub-directory by default 
and will give the database file a name based on the Master Controller's name. Hence, you can just 
click on Save right away. 

Your Master Controller has now been created and is added to your scene, connected to the 
Composite you selected earlier.

The Master Controller's 2D point widget will appear in the Camera view, at the bottom-right 
corner of the area in which you can drag it. A black frame will appear around the area in which you 
can move the point. This is the same area as the one covered by the grid you created earlier.

 27. In the Timeline view, move the timeline cursor to a frame that does not contain any of the key poses 
you used, so as to not override one of your poses. 
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 28. In the Camera view, click on the 2D point widget and drag it around the black rectangle to test your 
Master Controller.

 

TIP 

At any time, you can show or hide the MasterController's widget by selecting it in the Timeline 
or Node view, then doing either of the following:

 l In the Camera view toolbar, click on the  Show Control  button.

 l In the top menu, select View > Show > Control.
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About the Deformer On Deformer Wizard
The Deformer On Deformer Wizard is a tool that allows you to rig a deformation chain over another 
deformation chain.

Because of the nature of deformers, simply rigging one deformer over another deformer does not work the way 
one would expect it to. What happens instead is that both deformers deform the drawing in their own way, 
but the deformer connected over the other one does not deform the other one’s points. The results of 
attempting this are rarely desirable. 

With the Deformer on Deformer Wizard, it is possible to create a deformer that deforms the deformer over 
which it is rigged. For example, if you use the Deformer on Deformer Wizard to create a Curve deformer over an 
Envelope deformer, manipulating the curve deformer will move the points of the envelope deformer, which 
will in turn deform the drawing. 

In the example below, the Curve Deformation handles are used to deform the Envelope Deformation, which in 
turn deform the drawing:
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The purpose of the Deformer on Deformer Wizard is to make it possible to combine the flexibility and 
versatility of an envelope deformer with the simplicity and ease of use of a curve deformer. With those two 
combined, you can animated the drawing’s centreline as easily as you can tweak its outer shape. 

How it Works

The Deformer on Deformer Wizard works by allowing you to create a Curve deformation chain over your 
Envelope deformation chain, then converting this Curve deformer into a Master Controller. This Master 
Controller will display a series of point widgets laid out and configured to resemble and behave like the curve 
deformation chain you created. The difference is that, instead of deforming the drawing, the Master Controller 
will deform the shape of the Envelope deformer it is connected to by moving and rotating its deformation 
points.

The reason why it is important to understand this technicality is that, while manipulating a regular deformer or 
a Deformer on Deformer is virtually the same, displaying a regular deformer in the Camera view is done 
differently than displaying the widgets of a Master Controller. For more information, see Using the Deformer 
On Deformer on page 173.

Other than that, creating and using Deformer on Deformer systems is virtually the same as creating and using 
regular deformers.

The Node System

When a new Deformer On Deformer is created, a new group node is created under the group node containing 
the Envelope deformer. This group node contains all the nodes making the Curve deformation system. It is 
connected to same parent peg as the Envelope deformer through its left intput port, as well as to the Envelope 
deformer itself through its right input port.

The group is also connected to a Composite node to ensure that the Master Controller’s widget can be made 
visible in the Camera view.

The image below shows the node “mcDeformation-BrowContour-G”, which contains the centerline Curve 
Deformation and the Master Controller created by the wizard.
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The Master Controller node

The group that is created by the Deformer on Deformer wizard contains a system of nodes allowing the Master 
Controller to use the Curve deformation chain you created to deform the Envelope deformation chain it is 
connected to. 

Within this group is the Master Controller node itself. This is useful information in case you want to select the 
Master Controller node from the Node View so as to display its controls in the Camera view. However, you 
should however avoid making modifications to the node system inside this group. 
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Using the Deformer On Deformer Wizard

Creating a Deformer on Deformer system is very simple, especially when compared to other types of Master 
Controllers. The method is explained in detail further below, but can be summarized as follows:

 1. Create an Envelope deformer as you usually would.

 2. Open the Deformer on Deformer Wizard.

 3. While the wizard is open, create a Curve deformer over the Envelope deformer.

 4. Click on the Done button in the Deformer on Deformer Wizard.

The Wizard will convert your Curve deformer into a Master Controller system which, instead of deforming the 
drawing it is rigged to, will deform the points of the Envelope deformer, which will in turn deform the drawing 
it is rigged to. 

How to use the Deformer on Deformer Wizard

 1. Start by creating the Envelope deformer over which you want to create the Curve deformer—see 
Creating Envelope Deformation Rigs on page 1559.

 2. Add the Master Controller toolbar to your workspace by doing one of the following:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller.

The Master Controller toolbar appears.

 3. In the Node View or the Timeline view, select the group for the Envelope deformer you just created.
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 4. In the Master Controller toolbar, click the  Deformer on Deformer button.

The Deformer on Deformer Wizard appears.

NOTES 

 l The  Rigging tool is also automatically activated in the Deformation toolbar as 
soon as you open the wizard. This is because the next step is to create the other 
deformer.

 l The Deformer on Deformer dialog needs to be open while you create the second 
deformer. You can keep working on your scene while the dialog is open.

 1. In the Tool Properties view, in the Mode section, click on the  Curve Mode button.

 2. Create your Curve deformation chain as you would normally do—see Creating Curve Deformation 
Chains on page 1557.
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 3. When you are done creating the Curve deformer, click on the Done button in the Deformer on 
Deformer Wizard.

Your Curve deformer will be converted to a Master Controller, which can be used to deform the 
Envelope deformer you created earlier. 
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Using the Deformer On Deformer

Manipulating a Deformer on Deformer system is virtually the same as manipulating a regular deformer, so it 
should be easy for an animator to use a Deformer on Deformer system if they are already familiar with 
animating with deformers. 

However, one of the nuances to understand about Deformer on Deformer systems is that the way to display 
their controls in the Camera view is different than with regular deformers. This is because a Deformer on 
Deformer system is technically not a regular deformation chain, but rather, a Master Controller made to act like 
a deformation chain. 

For example, you can display all of a rig’s deformation chains by selecting this rig’s parent peg and pressing 
the  Show Selected Deformers button in the Deformation toolbar, but if the rig contains a Deformer on 
Deformer system, it won’t be displayed using this method.

To display a rig’s Deformer on Deformer systems, you can use one of the following methods:

 l Press the  Show Master Controllers button in the Master Controller toolbar,

 l Use the Master Controller view, or

 l Locate the Master Controller in the Node or Timeline view, and then click on  Show Controls in the 
Camera view toolbar. 

How to display a Deformer on Deformer using the Show Master Controller button

 1. In the Node View or the Timeline view, locate and select the group containing the Deformer on 
Deformer system. 

This group will be connected under your drawing’s envelope deformation group, and it will be 
named mc followed by the name of the drawing’s envelope deformation group, followed by -G. For 
example, if your drawing is named Drawing, the group containing the envelope deformer will most 
likely be named Deformation-Drawing, and the group containing the Deformer on Deformer 
system will hence be named mcDeformation-Drawing-G.

173

Harmony 21 Premium User Guide                          



 2. In the Master Controller toolbar, click on the  Show Master Controller button.

A dialog appears listing the Master Controller nodes included in the selected group.

 3. Check the checkbox for the Master Controller you want to display. Its path will end with mc_
DeformerOnDeformer.

 4. Click OK.

The Deformer on Deformer’s controls will appear.

How to display a Deformer on Deformer using the Master Controller view

 1. In the top-right corner of any view in your workspace, click on the Add View button and select 
Master Controller.

The Master Controller view appears.

 2. In the Master Controllers list, locate and select the one for the Deformer on Deformer system you 
want to display. This Master Controller will be named mc_DeformerOnDeformer, and will be 
inside a group named mcDeformation-[DrawingName]-G, where [DrawingName] is the name of 
the drawing being deformed. This group will be inside the same group as the drawing you want to 
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deform. 

NOTES 

 l You can select several Master Controllers in this list. To do this, click and drag over 
the Master Controllers you want to select, press and hold the Shift key and select 
the first, then the last Master Controller in the range of Master Controllers you want 
to select, or press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key and click on 
each Master Controller you want to select. 

 l If you recently created the Deformer on Deformer system you want to display, you 
may need to refresh the list for it to appear. To do that, click on the  Refresh 
button at the bottom of the Master Controller view.

 3. In the bottom-right corner of the Master Controller view, click on the  Show Master Controllers 
button.

How to display a Deformer on Deformer using the Show Control command

 1. In the Node View or the Timeline view, locate the group containing the Deformer on Deformer 
system. 

This group will be connected under your drawing’s envelope deformation group, and it will be 
named mc followed by the name of the drawing’s envelope deformation group, followed by -G. For 
example, if your drawing is named Drawing, the group containing the envelope deformer will most 
likely be named Deformation-Drawing, and the group containing the Deformer on Deformer 
system will hence be named mcDeformation-Drawing-G.
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 2. Click on the right arrow button on the group node to enter the group.

 3. Inside the group, locate and select the node named mc_DeformerOnDeformer.

 4. Do one of the following:

 l In the Camera toolbar, click on Show Control .

 l From the top menu, select View > Show > Control. 

 l Press Shift + F11 (Windows/Linux) or ⌘  + F11 (macOS).
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How to manipulate control points

Manipulating the control points of a Deformer on Deformer system works just the same as manipulating 
the control points of a regular curve deformer. The only difference is that this deformer will “deform” the 
position of the points in the Envelope deformer it is connected to, rather than the drawing itself. The 
Envelope deformer will deform the drawing in turn.

NOTE 

The control points for a Deformer on Deformer system are slightly bigger than those of a 
regular deformer. This can help you differentiate them, as well as remember that you’re 
working with a Master Controller rather than a regular deformation chain. 
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About the Master Controller Function Wizard
The Function Wizard allows you to create Master Controllers with a specific, custom purpose. Unlike the Grid 
Wizard, the Stack Wizard and the Slider Wizard, which are designed to control many elements of a rig based 
on a set of poses, the Function Wizard is intended to create widgets that perform simple operations on a 
specific attribute of one or several nodes. 

The Function Wizard can create Master Controller widgets of the following types:

 l Checkbox

 l Slider

 l 2D point

Using the Function Wizard, you can make those widgets perform one of the following operations:

 l Control the value of one of a node’s numerical (scalar) attributes (e.g., horizontal position, vertical 
position, etc.)

 l Control the value of one of a node’s 2D (vector) attributes (e.g., position, scale, etc.)

 l Toggle whether a node is enabled or disabled

 l Show or hide the controls for a node

 l Show or hide the deformation controls for a deformation chain

TheFunction Wizard can only generate Master Controllers that perform one specific operation on one specific 
attribute, on one or several nodes that have this attribute.

The simple operations can be combined with other tools, such as other Master Controllers.

These simple operations can however be assembled with other tools such as existing Master Controllers, 
which can be activated and deactivated by a checkbox widget made by the Function Wizard, for example. 
Function Wizard widgets can also be chained  with one another, making it possible to create “control panels” 
where a main checkbox per character is used to activate all relevant Master Controllers, Deformations or 
transformation controls. Sliders and 2D Point widgets can also be linked to virtually any property of any node, 
in order to provide a convenient access to these properties directly from the Camera View.

Although scripting knowledge is not required, the code generated by the Function Wizard can also optionally 
but easily be customized by those who are comfortable with scripting.
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Lastly, a secondary important intent for the Function Wizard is to educate users about Harmony’s scripting API 
in general as well as Master Controllers. Each widget and operation type combination will generate small 
code snippets, providing a headstart for more advanced scripters who wish to create their own custom Master 
Controllers. For those users, the Function Wizard provides a basic template which is easy to modify.
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Function Wizard Example 1: Enabling and Disabling Node with the 
Checkbox Widget

The Function Wizard allows you to quickly create a Checkbox widget which will enable a specific set of nodes 
when checked and will disable that set of nodes when unchecked. 

How to create a Checkbox widget for enabling and disabling nodes using the 
Function Wizard

 1. In the Node View, Timeline view or Camera view, select the nodes you want to enable or disable 
with a Checkbox widget.

 2. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.
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 1. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.

 2. In the Controller Type drop-down, select CheckboxWidget.

 3. In the Operation drop-down, select Enable/Disable Node. 

 4. In the Target Nodes list, verify that all the nodes you want your Master Controller widget to control 
are listed. If not:

 l To add nodes to the Target Nodes list, select them in the Node View, the Timeline view or 
the Camera view, then click on Add Selected Nodes in the Function Wizard dialog box.
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 l To remove nodes from the Target Nodes list, select them in the Target Nodes list, then click 
on  Remove selected nodes.

 5. In the Label field, type in the display name for your Master Controller widget.

 6. Click OK.

 7. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
the Composite drop-down, select the main composite for your character rig. Then, click OK.

A Checkbox widget will be created and will appear in the Camera view. Toggling it off will disable 
the nodes that were in the Target Nodes list, and toggling it on will enable them. 

NOTE 

Whether the checkbox is checked or not is synchronized with whether the first node in 
the Target Nodes list is enabled or disabled. This means that disabling the first node in 
the Target Nodes list will uncheck the checkbox, and enabling it will check the 
checkbox, but disabling or enabling any of the other nodes in the Target Nodes list will 
not update the state of the Checkbox widget.
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Function Wizard Example 2: Showing and Hiding Node Controls with 
the Checkbox Widget

The Function Wizard allows you to quickly create a Checkbox widget which, when checked, will display the 
controls of a specific set of nodes, and when unchecked, will hide the controls of that set of nodes.

How to create a Checkbox widget for displaying and hiding node controls using the 
Function Wizard

 1. In the Node View, Timeline view or Camera view, select the nodes for which you want to display or 
hide the controls with a Checkbox widget.

 2. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.

 1. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.
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 2. In the Controller Type drop-down, select CheckboxWidget.

 3. In the Operation drop-down, select Show/Hide Controls.

 4. In the Target Nodes list, verify that all the nodes you want your Master Controller widget to control 
are listed. If not:

 l To add nodes to the Target Nodes list, select them in the Node View, the Timeline view or 
the Camera view, then click on Add Selected Nodes in the Function Wizard dialog box.

 l To remove nodes from the Target Nodes list, select them in the Target Nodes list, then click 
on  Remove selected nodes.

 5. In the Label field, type in the display name for your Master Controller widget.

 6. Click OK.

 7. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
the Composite drop-down, select the main composite for your character rig. Then, click OK.

A Checkbox widget will be created and will appear in the Camera view. Toggling it on will display 
the controls for the nodes that are in the Target Nodes list in the Camera view, and toggling it off 
will hide them.
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NOTE 

Whether the checkbox is checked or not is synchronized with whether the controls for 
the first node in the Target Nodes list are displayed or hidden. This means that 
displaying the controls for the first node in the Target Nodes list will check the 
checkbox, and hiding them will uncheck the checkbox, but showing or hiding the 
controls for any of the other nodes in the Target Nodes list will not update the state of 
the Checkbox widget.
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Function Wizard Example 3: Showing and Hiding Deformation 
Controls

The function wizard allows you to create a Checkbox widget which, when checked, will display the 
deformation controls for a specific set of deformation nodes, and when unchecked, will hide these deformation 
controls.

How to create a Checkbox widget for displaying and hiding deformation controls 
using the Function Wizard

 1. In the Node View or Timeline view,  select the deformation nodes or deformation groups for which 
you want to show or hide the controls with a Checkbox widget.

 2. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.
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 3. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.

 4. In the Controller Type drop-down, select CheckboxWidget.

 5. In the Operation drop-down, select Show/Hide Deformers. 

 6. In the Target Nodes list, verify that all the nodes you want your Master Controller widget to control 
are listed. If not:

 l To add nodes to the Target Nodes list, select them in the Node View, the Timeline view or 
the Camera view, then click on Add Selected Nodes in the Function Wizard dialog box.

 l To remove nodes from the Target Nodes list, select them in the Target Nodes list, then click 
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on  Remove selected nodes.

 7. In the Label field, type in the display name for your Master Controller widget.

 8. Click OK.

 9. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
the Composite drop-down, select the main composite for your character rig. Then, click OK.

A Checkbox widget will be created and will appear in the Camera view. Toggling it on will display 
the controls for the deformation chains that were in the Target Nodes list, and toggling it off will 
hide them.

NOTE 

Whether the checkbox is checked or not is synchronized with whether the deformation 
controls for the first node in the Target Nodes list are displayed or hidden. This means 
that displaying the deformation controls for the first node in the Target Nodes list will 
check the checkbox, and hiding them will uncheck the checkbox, but showing or hiding 
the deformation controls for any of the other nodes in the Target Nodes list will not 
update the state of the Checkbox widget.
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Function Wizard Example 4: Controlling Attributes with the Slider 
Widget

The Function Wizard allows you to create a Slider widget that can control any specific numerical (scalar) 
attribute for one or several nodes. 

How to create a Slider widget that controls a given parameter for one or several 
nodes

 1. In the Node View or Timeline view, select the node or nodes that the Slider widget will control.

NOTE 

If you select several nodes of different types, the Function Wizard will only allow you to 
select a parameter to control that is common to all of the selected nodes. 

For example, the Function Wizard will not allow you to manipulate the position of a 
drawing element and the position of a peg using the same widget, as the position 
parameter of a drawing element is named OFFSET, whereas the position parameter of a 
peg is named POSITION. If you are familiar with Harmony‘s scripting interface, you can 
work around this limitation by customizing the function of your Master Controller—see 
Function Wizard Example 6: Customizing the Function Code on page 195.
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 2. Do one of the following to add the Master Controller toolbar to your workspace:

 l Right-click on an existing toolbar and select Master Controller.

 l In the top menu, select Windows > Toolbars > Master Controller. 

The Master Controller toolbar appears.

 1. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.

 2. In the Controller Type drop-down, select SliderWidget.

 3. In the Operation drop-down, select Set Value. 

 4. In the Target Nodes list, verify that all the nodes you want your Master Controller widget to control 
are listed. If not:

 l To add nodes to the Target Nodes list, select them in the Node View, the Timeline view or 
the Camera view, then click on Add Selected Nodes in the Function Wizard dialog box.

 l To remove nodes from the Target Nodes list, select them in the Target Nodes list, then click 
on  Remove selected nodes.

 5. In the Attribute drop-down, select the node attribute that you want the slider to control. 

NOTE 

Some node attributes are hidden by default to avoid cluttering the Attribute drop-
down list. To display all attributes available for the target nodes, check the Advanced 
checkbox at the bottom of the dialog box.

 6. In the Label field, type in the display name for your Master Controller widget.

 7. In the Min Value field, type in the value to which you want the parameter to be set when the slider 
is moved to its lowest position. Likewise, in the Max Value field, type in the value to which you want 

190



the parameter to be set when the slider is moved to its highest position.

 8. Click OK.

 9. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
the Composite drop-down, select the main composite for your character rig. Then, click OK.

A Slider widget will be created and will appear in the Camera view. Manipulating it will update the 
attribute you selected for all of the nodes that were in the Target Nodes list.

NOTE 

The position of the Slider widget will be synchronize with the value of the selected 
parameter for the first node in the Target Nodes list. This means that if you manipulate 
the first node in the Target Nodes list, the slider’s position will automatically update to 
keep up with the value of this node’s parameter, but if you manipulate any other node in 
the Target Nodes list, the slider’s position will not be updated accordingly.
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Function Wizard Example 5: Creating a Master Controller Dashboard

If your character has multiple Master Controllers, you can lay them out side by side so as to be able to display 
all of them and use them separately. Then, you can use the Function Wizard to create a Checkbox widget that 
instantly displays or hides their controls. 

How to create a character dashboard with a Checkbox widget that toggles the 
visibility of all the character’s master controllers

 1. Create multiple Master Controllers for your character rig, as needed. 

 2. Connect pegs to each of your character’s Master Controller nodes so that you can move them 
around in the Camera view. Then, using the Transform tool, select each of them and lay them out so 
that they don’t overlap.
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 3. In the Node View, select all the Master Controller nodes for your character.

 4. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.

 5. In the Controller Type drop-down, select CheckboxWidget.

 6. In the Operation drop-down, select Show/Hide Controls.

 7. In the Target Nodes list, verify that all the nodes you want your Master Controller widget to control 
are listed. If not:

 l To add nodes to the Target Nodes list, select them in the Node View, the Timeline view or 
the Camera view, then click on Add Selected Nodes in the Function Wizard dialog box.

 l To remove nodes from the Target Nodes list, select them in the Target Nodes list, then click 
on  Remove selected nodes.

 8. In the Label field, type in the display name for your Master Controller widget.

 9. Click OK.
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 10. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
the Composite drop-down, select the main composite for your character rig. Then, click OK.

A new Checkbox widget is created and appears in the Camera view.

 11. In the Node View, locate the Master Controller node you just created with the Function Wizard and 
click on its  layer properties button.

 12. In the Layer Properties dialogue, in the Attributes tab, set the Show Controls Mode parameter to 
Always. This will ensure that the Checkbox widget you just created to show or hide your 
character’s Master Controllers is always visible. 

 13. To test your new dashboard, click on the  Hide All Controls button in the Camera view toolbar. 
This should hide all the Master Controllers except for the one you just created, since its Show 
Controls Mode is set to always.
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Function Wizard Example 6: Customizing the Function Code

The Function Wizard allows you to customize the code it automatically generates for your Master Controller 
widget.

By following the steps in the following example, you can create a 2D Point widget with the Function Wizard 
and tweak its code to make several drawings point towards its position. 

To create a Master Controller Widget with custom code, follow the steps below:

 1. Create an empty scene.

 2. In the Node View, add a Field-Chart node to your scene and connect it to your scene’s main 
composite. This will serve as a spatial reference for this tutorial’s purposes.

 3. In the scene’s default Drawing layer, using the  Brush or  Pencil tool, draw an arrow pointing 
from the centre of the scene’s field chart towards the right.

 4. In the Node View or the Timeline view, copy and paste your drawing layer three times so as to have 
four arrow drawings in your scene.
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 5. In the Advanced Animation toolbar, select the  Translate tool. Then, select each drawing layer 
and reposition them in a rectangular formation, like so:

 6. In the Node View or the Timeline view, select all four drawing layers.

 7. In the Master Controller toolbar, click on the  Function Wizard button.

The Function Wizard dialog appears.

 8. In the Controller Type drop-down, select Point2dWidget.

 9. In the Operation drop-down, select Set Value.

 10. In the Attribute drop-down, select Offset.

NOTE 

Although this Master Controller’s purpose is to make the arrows rotate, the Function 
Wizard will only allow you to select an attribute of the 2D (vector) type. This is because 
when the 2D point widget is manipulated, it provides its position on the X and Y 
coordinates as a 2D (vector) type value. We will make the Master Controller control the 
arrow’s rotation angle by customizing the script later.

 11. In the Label field, type in a name for your Master Controller that will indicate its purpose. In this 
example, the Master Controller will make all arrows point towards the 2D point widget, so it was 
named LookAt.
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 12. In the minimum and maximum fields for each axis, enter the following values:

 l XMin: -12

 l YMin: -12

 l XMax: 12

 l YMax: 12

 13. Although the code for the Master Controller you are about to create can be customized directly 
using the text field at the bottom of the dialogue, we will create this Master Controller using the 
default code for it for now, and edit its code in its properties so as to be able to test each change one 
by one. Hence, at this point, simply click OK to generate the Master Controller with the default 
function for a 2D Point widget.

 14. A dialog box will appear prompting you to select a composite to attach the Master Controller to. In 
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the Composite drop-down, select Top/Composite, then click OK.

A Master Controller node will be created, and its 2D Point widget will appear in the Camera view.

 15. In the Node view, locate the Master Controller that was just created by the Function Wizard, and 
click on its  layer properties button.

 16. Although no modification needs to be done to the code in the UI Data tab, you can take a look at it 
at this step. You will notice that the parameters you entered in the Function Wizard are all stored in 
this tab in JSON format. The actual code executed by the Master Controller, which is stored in the 
UI Script tab, refers to this data. Hence, you can easily make changes to the parameters of your 
Master Controller by updating the data in the UI Data tab, if needed.

 17. Open the UI Script tab. This tab contains the code that is executed each time the 2D Point widget is 
manipulated. It is the same code that was displayed in the text field in the Function Wizard, before 
you clicked OK to generate this Master Controller.

 

 18. In the Camera view toolbar, click on the  Hide All Controls button. This is necessary because 
when you make changes to the UI Script code of a Master Controller, these changes will not be 
reflected in its behavior until you hide the Master Controller’s controls, then display them again.

 19. In the UI Script tab, remove the two lines that update the target node’s offset. These lines both 
start with node.setTextAttr. Then, add the bolded lines below to log basic information as you move 
the 2D Point widget:
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function onPoint2dValueChanged(params, point2dVal)
{
   MessageLog.trace("START");
   var targetAttr = params.targetAttrs[0];
   MessageLog.trace("Attribute Name:" + targetAttr);
   for(var i=0; i<params.targetNodes.length; ++i)
   
{
     var targetNode = params.targetNodes[i];
     MessageLog.trace("-----------------------------");
     MessageLog.trace("Node Index:" + i);
     MessageLog.trace("Node Identifier:" + targetNode);
   }
   MessageLog.trace("END");
}

 20. Add the Message Log view to your workspace. To do this, click on the Add View button in the 
top-right corner of the view in the top-right area of your workspace, and select Message Log. 

 21. In the Node View, select the Master Controller node. Then, in the Camera view toolbar, click on  
Show Controls. This is to test if the changes you just made to the code contain any syntax error. If 
your code can run without issues, the Master Controller widget will reappear in the Camera view, 
and the Message Log will log a header for the type of widget being displayed, followed by “Done.”

 22. Using the Transform tool, move the 2D point widget around in the Camera view to test if 
information is logged as you manipulate it.
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 23. Using the node.getTextAttr() method, add code to isolate and output the position of each 
target node on the X and Y axes. 

function onPoint2dValueChanged(params, point2dVal)
{
   MessageLog.trace("START");
   var targetAttr = params.targetAttrs[0];
 
   for(var i=0; i<params.targetNodes.length; ++i)
   
{
     var targetNode = params.targetNodes[i];
     var pos_x = node.getTextAttr(targetNode, frame.current(), "OFFSET.X");
     var pos_y = node.getTextAttr(targetNode, frame.current(), "OFFSET.Y");
 
     MessageLog.trace("Node Index:" + i);
     MessageLog.trace("pos_x:" + pos_x);
     MessageLog.trace("pos_y:" + pos_y);
   }
   MessageLog.trace("END");
}
  
include(fileMapper.toNativePath(specialFolders.resource+"/scripts/utilities/ui/functionWizard/mcs/mcPoint2dFunction.js"))

 24. Add the bolded lines below so as to calculate the angle at which to rotate each arrow using the 
difference between the position of each arrow relative to the position of the 2D Point widget:

function onPoint2dValueChanged(params, point2dVal)
{
   MessageLog.trace("START");
   var targetAttr = params.targetAttrs[0];
 
   for(var i=0; i<params.targetNodes.length; ++i)
   
{
     var targetNode = params.targetNodes[i];
     var pos_x = node.getTextAttr(targetNode, frame.current(), "OFFSET.X");
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     var pos_y = node.getTextAttr(targetNode, frame.current(), "OFFSET.Y");
 
     var deltaX = point2dVal.x - pos_x;
     var deltaY = point2dVal.y - pos_y;
     var angle = Math.atan2(deltaY, deltaX) * 180 / Math.PI;
     MessageLog.trace("Node Index:" + i);
     MessageLog.trace("deltaX:" + deltaX);
     MessageLog.trace("deltaY:" + deltaY);
     MessageLog.trace("angle:" + angle);
   }
   MessageLog.trace("END");
}
  
include(fileMapper.toNativePath(specialFolders.resource+"/scripts/utilities/ui/functionWizard/mcs/mcPoint2dFunction.js"))

NOTE 

The Math module, the atan2() function and the PI property are built into the 
Harmony scripting interface as they are part of the ECMAScript language.

 25. Now that the script has all the information required to perform its task, we can add the 
node.setTextAttr() method to change the rotation angle of each arrow to make them point towards 
the 2D Point widget. We can also clean up the logging commands used until now to make sure 
each addition to the code worked as intended.

function onPoint2dValueChanged(params, point2dVal)
{
   var targetAttr = params.targetAttrs[0];
 
   for(var i=0; i<params.targetNodes.length; ++i)
   
{
     var targetNode = params.targetNodes[i];
     var pos_x = node.getTextAttr(targetNode, frame.current(), "OFFSET.X");
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     var pos_y = node.getTextAttr(targetNode, frame.current(), "OFFSET.Y");
 
     var deltaX = point2dVal.x - pos_x;
     var deltaY = point2dVal.y - pos_y;
     var angle = Math.atan2(deltaY, deltaX) * 180 / Math.PI;
 
     node.setTextAttr(targetNode, "ROTATION.ANGLEZ", frame.current(), angle); 
   }
}
  
include(fileMapper.toNativePath(specialFolders.resource+"/scripts/utilities/ui/functionWizard/mcs/mcPoint2dFunction.js"))
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TIPS 

The following are tips to help troubleshoot issues when changing the code of a Master 
Controller:

 l When a script encounters an problem, it usually stops executing without reporting 
errors by default. Hence, it’s a good idea to add logging throughout each step of 
your script and to keep an eye on the Message Log view as you test it.

 l After performing changes to the code of a Master Controller, hide and display its 
controls to test that it’s still able to load. If you don’t see a header message and an 
end message such as the ones in the example below when displaying the controls 
of a Master Controller, it is likely that the code for your Master Controller contains a 
syntax error.

 l Always make sure that your widget function is fully executed, until the end. A good 
way to verify this is to log a message such as “START” at the beginning of your 
function and “END” at the end of your function. That way, if your script doesn’t 
behave as expected, you can assess whether or not your function was called, and 
whether it was executed until the very end.

 l To activate the Script Debugger, the magic comment //!debug can be added at 
the beginning of your script, as shown below:
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 l The Script Debugger can be used to inspect variables, callstacks, and errors. 
However, because the Script Debugger will appear every time your code is 
executed, and your code is executed with every manipulation of the widget, it may 
be preferable to use logging to troubleshoot your code when possible.
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Creating a Master Controller Through Scripting
The following topics will introduce you to scripting for a Master Controller and provide examples of how to 
handle basic use cases. However, before going through this section, you should know that:

 l This documentation alone is not enough to be able to create a Master Controller through scripting. Such 
a task should only be taken by someone with sufficient experience in scripting or programming.

 l This is an introduction guide, not a reference. To obtain a list of all the modules, properties and methods 
related to the Master Controller, you must refer to the Master Controller Node section of the Harmony 
scripting API reference–see Harmony Scripting Reference on page 774.
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Creating a Master Controller
T-HSCP-002-002

To create a Master Controller, you must add a Master Controller node to the scene, then link it to a UI script, in 
which its widget and the way it interacts with elements in the scene will be programmed. The UI script of a 
Master Controller is executed when its controls are displayed. 

How to add a Master Controller to a scene

 1. In the Node view, add a Master Controller node by doing one of the following:

 l In the Node Library view, select the Misc filter, then drag and drop the Master Controller 
node from the Node Library view to the Node view.

 l Right-click on the Node view and select Insert > Misc > Master Controller.

 l Open the Node view menu and select Insert > Effects > Misc > Master Controller.

IMPORTANT 

The Master Controller node does not need to be connected to another node to work. 
However, if you do connect it to another node, the node system to which it is connected 
must ultimately be connected to a Display node.

 2. Click on the yellow square in the Master Controller node to open its Layer Properties.

NOTE 

The Layer Properties of a Master Controller are very similar to those of a Script Node. 
The main difference is that the Master Controller has access to methods allowing it to 
create and use widgets.

 3. Switch to the Script UI tab.

 4. In the scripting field of the Script UI tab, type in the following code to link to your widget script: 

include(scene.currentProjectPath() + "/scripts/myScript.js");

In this example, the script is located in a scripts subfolder of the scene folder, and is named 
myScript.js.

206



NOTE 

To make sure a UI script stored in the scene's file structure is copied over when you 
make a template that includes the Master Controller node, you must add this script to 
the Extra Files list of the Master Controller node—see Linking the Master Controller to 
its Files for Template Creation on page 230.

 5. Save your scene.

 6. Open the Script Editor view by doing one of the following:

 l From the top menu, select Windows > Script Editor.

 l From any existing view (ie: the Camera or Drawing view), click on the Add View  button 
and select Script Editor.

 7. In the Scope dropdown, select Project. 

The script list will now list scripts in the scripts subfolder of your scene.

 8. In the Script Editor toolbar, click on the New Script  button.

 9. In the New Script dialog, type in myScript and confirm.

 10. In the Save Script dialog, select Scene in the location dropdown and confirm.

The script scripts/myScript.js will be added to the list of scripts. 
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 11. Select scripts/myScript.js from the script list to load it in the editor. 

You are now ready to start scripting a widget for the Master Controller node.

NOTE 

To make sure the script is copied over with the Master Controller node if it is copied into a 
template, you must add the script file to the Extra Files tab of the Master Controller's properties—
see Linking the Master Controller to its Files for Template Creation on page 230.
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Creating Master Controller Widgets
T-HSCP-002-004

The UI script linked to a Master Controller node is called when the Master Controller node is selected and the 
user uses the Show Control command to display its controls in the camera view, which calls the  
onShowControl method of the Controller object of the node. Hence, to make the Master Controller node 
display a widget, you must define its widget in a function that overrides this method. 

The following example overrides a Master Controller's onShowControl method with a function that creates a 
basic slider widget. Simply copy and paste it to your UI script to test its effect.

// When Show Controls is called from the Harmony UI, create a script widget 
// and register it to the main Controller.
 Controller.onShowControl = function()
{  
   // Initialize the array of widgets
   Controller.controls = [];
   // Add a slider widget.
   Controller.controls.push(new SliderWidget());
}

Similarly, you can handle the case where the control is hidden using the onHideControl method. 

// Called when the user hides the Master Controller node controls
 Controller.onHideControl = function()
{
   MessageLog.trace("Slider hidden.");
}

NOTE 

When the control is hidden, it is destroyed and the attributes that were set by the user when they 
manipulated it are not preserved. This occurs regardless of whether or not the onHideControl 
method is overridden. Hence, there is no need to script the destruction of the widget. 

It is possible to create a Master Controller with several widgets. For example, you can combine a 
TranslationXWidget and TranslationYWidget to make a 2D Translation widget by creating them as 
elements of the same Controller.controls array.

// Create a TranslationX and TranslationY widget in the same Master Controller.
 Controller.onShowControl = function()
{  
   // Initialize the array of widgets
   Controller.controls = [];
   // Add the TranslationX and TranslationY widgets
   Controller.controls.push(new TranslationXWidget());
   Controller.controls.push(new TranslationYWidget());
}
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Save your script.

NOTES 

 l To display and test your widget, see Displaying and Testing Master Controller Widgets.

 l To learn about the different classes of widget available for the Master Controller, refer to the 
Master Controller Node section of the Harmony scripting reference–see Harmony Scripting 
Reference on page 774.
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Setting the Properties of a Master Controller Widget
T-HSCP-002-005

When creating a widget, you can customize it by declaring its properties. These properties can be passed as 
parameters in the constructor of the widget. For example, the following code creates a Slider widget with a full 
set of custom properties:

Controller.controls.push(new SliderWidget(  
{ 
   data : "mySlider", // name of the created attribute
   width : 0.15,      // width of the slider frame
   height : 0.2,      // height of the slider frame
   min : 0,           // minimum value of the slider
   max : 100,         // maximum value of the slider
   frame_color : ColorRGBA(40,100,150), // the colour of the slider frame
   slider_color : ColorRGBA(135,135,135), // the colour of the slider handle
   slider_selection_color : ColorRGBA(200,200,150), // the colour of the slider frame when selected
}));

The data property of a widget can be set to a string that uniquely identifies its attributes. Hence, if two 
widgets are created with an identical data property, they will have the same attribute, like in this example:

// Create a 2d point widget.  
 Controller.controls.push(new Point2dWidget(  
{ 
   data : "Magnet",                      // name of the created attribute
   size : 0.05,                          // the diameter of the point
   selection_color : ColorRGBA(80,50,50) // the colour of the point manipulator when selected.
}));
  
// Create a 2d point widget.  
 Controller.controls.push(new Point2dWidget(  
{ 
   data : "Magnet",                      // name of the created attribute
   size : 0.1,                           // the diameter of the point
   selection_color : ColorRGBA(20,70,70) // the colour of the point manipulator when selected.
}));

Each type of Master Controller widget has its own set of properties that can be set at its creation. All of their 
properties are optional and have default values if not set. 

NOTE 

To learn about the properties of each type of widget, refer to the Master Controller Node section of 
the Harmony scripting reference–see Harmony Scripting Reference on page 774.
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Linking Attributes Between Different Master Controller Widgets
T-HSCP-002-007

By default, Master Controller widgets are created with their own attributes. It is possible to link the attributes 
between several widgets using the data property.

In the following example, a widget that is composed of two 2D points which are linked by a line is created. 
There is no such widget in the Master Controller API, but there is a 2D Point widget (Point2dWidget) and a 
2D Line Display widget (Line2dDisplayWidget) , the data property of the latter is an array of two 2D 
Points. Hence, we can simply create two Point2dWidget, then create a Line2dDisplayWidget and set its 
data property to an array of the data properties of both Point2dWidget. The Line2dDisplayWidget will 
follow the position of the two 2D Points. 

// Create 2 2d point widgets.
var pointWidgetA = new Point2dWidget();
var pointWidgetB = new Point2dWidget();
 Controller.controls.push(pointWidgetA);
 Controller.controls.push(pointWidgetB);
// Display a line linking the 2 2d point widgets.
 Controller.controls.push(new Line2dDisplayWidget(
{
   data : [pointWidgetA.data(), pointWidgetB.data()]
}));

This capability can be used to create a widget consisting of a more complex network of lines and points.

Another way to do this is by setting the data property of two widgets with an identical string. For example, if 
two Point2dWidget are created with an identical string in their data property, they will share the same 
attribute.

// Create a 2d point widget.  
 Controller.controls.push(new Point2dWidget(  
{ 
   data : "Magnet",                      // name of the created attribute
   size : 0.05,                          // the diameter of the point
   selection_color : ColorRGBA(80,50,50) // the colour of the point manipulator when selected.
}));
  
// Create a 2d point widget.  
 Controller.controls.push(new Point2dWidget(  
{ 
   data : "Magnet",                      // name of the created attribute
   size : 0.1,                           // the diameter of the point
   selection_color : ColorRGBA(20,70,70) // the colour of the point manipulator when selected.
}));
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Updating a Node's Attribute when Manipulating a Master Controller 
Widget

T-HSCP-002-006

In order for a Master Controller widget to have any effect on an element in the scene, it must be programmed 
to set the value of an attribute for an element when the widget is being manipulated by the user. 

Master Controller widgets emit a signal when they are manipulated. You can control what happens when they 
are manipulated by creating a function that handles the value given by the widget, and connect that function 
to the valueChanged signal of the widget.

// Callback function for when the slider value changes
function mySliderValueChanged(newSliderValue)  
{ 
   MessageLog.trace("The value of the slide changed to " + newSliderValue);
}
 
 Controller.onShowControl = function()
{  
   Controller.controls = [];
   Controller.controls.push(new SliderWidget());
 
   // Connect the valueChanged signal to the sliderValueChanged 
   // function
   Controller.controls[0].valueChanged.connect(mySliderValueChanged);
}

Then, functions in the Harmony scripting interface must be used to affect the attributes of elements in the 
scene based on the value provided with the widget's signal. In this example, we use the slider widget's value 
to make the horizontal position of a peg named My_Peg_A , located in the scene's top level, vary between 0 
and 2 fields. The horizontal position of a peg is stored in the attribute POSITION.X.

TIPS 

 l You can easily obtain the names of a node's attributes for scripting by enabling Publish 
Attribute Mode in the Node View and opening a node's Layer Properties dialog. For more 
information, see Accessing Node Attribute Names for Scripting on page 801.

 l While position attributes for a peg are stored in the POSITION attribute group, position 
attributes for a drawing layer are stored in the OFFSET attribute group.

function mySliderValueChanged(newSliderValue)  
{ 
   var percentage = newSliderValue / 100.0;
   // make the slider sets a My_Peg_A x position between 0 and 2 fields
   var newXValue = percentage * 2; 
   node.setTextAttr("Top/My_Peg_A", "POSITION.X", frame.current(), newXValue);
}
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Widgets that can be manipulated will call the valueChanged signal when the user manipulates them. Other 
widgets, such as the Line2dDisplayWidget, cannot be manipulated and are only designed to display useful 
information to the user, so they do not support this signal. 

Most widgets handle transforming manipulations done to them by the user into attribute value changes on 
their own through their valueChanged signal. For example, a SliderWidget that has a minimum value 
between 0 and 100 will convert manipulations done to its handle into a value between 0 and 100 and pass 
that value through the signal. The CustomWidget, on the other hand, allows the user to program specific 
algorithms to handle manipulations done to it by using dragStarted, drag and dragEnded signals. 
Although this is particularly useful for the CustomWidget, those events are inherited by widgets from the 
WidgetBase class, and are hence available to all widgets. 

To create custom actions for drag manipulations, simply connect a callback to one of these signals.

Controller.onShowControl = function()
{ 
   var c = new CustomWidget( 
   { 
     data : "TranslationX",
     drag_manipulator : "SCRIPT",
     painter : "ARROW_X",
     picker : "MONO", 
     local_transformation : "TRANSLATION_X", 
     attribute : "DOUBLE"
   } ); 
         
   // Register drag callback functions
   c.dragStarted.connect(onDragStart);
   c.drag.connect(onDrag);
}

In the callback function, convert the mouse position from the world coordinates system into the Master 
Controller's OpenGL model coordinates.

var myController = Controller;
var drag_offset = new Vector3d;
var drag_offsetZ = new Vector3d;
function onDragStart(context)  
{ 
   // The context drag point is expressed in world coordinates. 
   // Convert the point in model coordinates and project it 
   // on the Master Controller XY plane.
   var projectedPoint = context.projectToModelPlane(context.dragPoint());
   var modelPickingPoint = projectedPoint;
   if(myController.controls.length &amp;gt; 0)
   
{
     // If other script widgets affecting the local transformation of 
     // the Master Controller are registered after the current widget, 
     // they may affect the position
     // of the current widget. Take their transformations into account.
     modelPickingPoint = context.multiplyByPostMatrix(modelPickingPoint);
   }
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   // Compute the delta between the controlled Peg position and the picked point.
   var pegPosition = node.getAttr(getPegPath(),frame.current(), "POSITION").pos3dValue();
   var modelOriginPoint = scene.toOGL(pegPosition); 
 
   drag_offset = modelOriginPoint.minus(modelPickingPoint);
}
  
function onDragTransX(context)   
{ 
   var projectedPoint = context.projectToModelPlane(context.dragPoint());
   var localPoint = projectedPoint;
   if(myController.controls.length &amp;gt; 0)
   
{
     localPoint = context.multiplyByPostMatrix(projectedPoint);
   }
   var fieldPoint = scene.fromOGL(localPoint.add(drag_offset)); 
 
   var newValue = fieldPoint.x;
 
   node.setTextAttr(myController.node, "TranslationX", frame.current(),  newValue);
   node.setTextAttr(getPegPath(), "POSITION.X", frame.current(), newValue);
}
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Updating the Attributes of a Master Controller Widget
T-HSCP-002-008

The attributes of a Master Controller widget can be initialized are their creation. However, it may also be useful 
to update their attributes in other circumstances. 

For example, if a SliderWidget is set to control the horizontal position of a drawing that is already animated 
to go from left to right. If the user moves the Timeline cursor to a different frame, the drawing will be in a 
different horizontal position, but the slider's value won't be automatically updated to reflect the drawing's 
current horizontal position unless we program it to do so. 

This can be done by using the global Controller object's onFrameChanged method. This method is called 
every time the current frame is changed, and it can be overriden with a custom function that will update the 
attributes of the widget based on the attributes of the element(s) it controls. 

A Master Controller widget's attributes can be accessed by their data() method, which returns an object of 
the Attribute type. The value of a widget can be updated by calling its data().setValue() method. For 
more information on the Attribute class, refer to the Harmony scripting reference.

// Called when the current frame of the application changes
 Controller.onFrameChanged = function()
{
   // Get the peg current position in x.
   var xPegPosition = node.getAttr("Top/My_Peg_A", frame.current(), "POSITION.3DPATH.X").doubleValue();
   // If the peg x position is computed as “slider value” / 100.0 * 2.0 
   // The script widget slider value would be computed as:
   var sliderValue = xPegPosition * 100.0 / 2.0;
   Controller.controls[0].data().setValue(sliderValue);
}

If more than one attribute was assigned to a widget's data property at its creation, those attributes can be 
accessed by passing their zero-based index as a parameter to the widget's data() method. Take for example 
this script where a widget composed of two Point2dWidget linked by a Line2dDisplayWidget are 
created:

// Create 2 2d point widgets and 1 line 2d widget reusing
// the 2d point widget attributes.
var pointWidgetA = new Point2dWidget();
var pointWidgetB = new Point2dWidget();
var line2dWidget = new Line2dDisplayWidget(
{
   data : [pointWidgetA.data(), pointWidgetB.data()]
});

The two following methods of setting the values of the two Point2DWidget are equivalent, but the second 
one uses the data() method of the Line2dDisplayWidget and passes the index of each Point2DWidget 
to access them:
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// Set the attribute values of the two 2D point widgets by referring to their
// variable names.
 pointWidgetA.data().setValue(new Point2d(3,3));
 pointWidgetB.data().setValue(new Point2d(-3,-3));

// Set the attribute values of the two 2D point widgets by referring to the
// data array of the 2D line widget.
 line2dWidget.data(0).setValue(new Point2d(3,3));
 line2dWidget.data(1).setValue(new Point2d(-3,-3));
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Applying the Coordinates of a Master Controller Widget to a Node
T-HSCP-002-011

When using a widget like the Point2dWidget, which is used to input X and Y coordinates by dragging a dot 
around the scene, you may want to connect the Master Controller or to a node system so that it is properly 
positioned in the stage. For example, a widget that controls a body part of a character may be connected to 
that character's master peg so that it follows the character's movement in the scene.

The coordinates you obtain from a Point2dWidget when it is moved by the user will be relative to its parent 
peg's position. For example, the Point2dWidget may initially appear in the corner of a scene because it is the 
child of a character that is positioned there, but its initial position will still be 0, 0, 0, which might not be 
accurate for the widget's purpose. Hence, before you can use the widget's coordinates to make transformations 
on an element in the scene, you will have to calculate its actual position in the stage (referred to here as a 
world point) by applying its parent's transformations, or matrix, to its coordinates. This can be accomplished 
with the following function:

// Return the given point 2d, in OGL coordinates, in world coordinates.
function getWorldPoint2d(modelPoint2d, nodePath)  
{   
   // Convert the model point into world coordinates. 
   // Apply the parent node transformation to the position
   // to go from (the node) model coordinates to world coordinates.
   var parentNode = node.srcNode(nodePath, 0);
   var parentTransformation = node.getMatrix(parentNode, frame.current());
 
   var modelPoint3d = new Point3d(modelPoint2d.x, modelPoint2d.y, 0);
   var worldPoint = parentTransformation.multiply(modelPoint3d);
 
   return worldPoint;   
}

If the element that the Point2dWidget is supposed to control is also connected to a node system that applies 
transformations to it, for example a body part in a character model, applying transformations using a world 
point is likely going to offset it a lot more than intended. Even if that body part is in a corner of the stage 
because this is where its character is located, its actual coordinates might also be 0, 0, 0 if only its parents were 
offset, but it itself has not been moved directly. Hence, before applying the coordinates of the world point 
calculated above to the target element, you will need to calculate the relative coordinates you want to apply to 
the element, referred to here as a model point, by applying the reverse matrix of the element's parent to the 
world point, using a function such as the following one:

// Convert the position from world coordinates to the target model  
// coordinates.
// Apply the inverse of the node parent transformation to the world position
// to go from world coordinates to (the node) model coordinates
function getModelPoint(worldPoint, nodePath)
{  
   var parentNode = node.srcNode(nodePath, 0);
   var parentTransformation = node.getMatrix(parentNode, frame.current());
   var inverseTransformation = parentTransformation.getInverse();
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   var modelPoint = inverseTransformation.multiply(worldPoint);
   return modelPoint;
}

To bring all this together, several more calculations must be made. For example, you may have to convert 
points from Harmony's field coordinates system to an orthonormal coordinates system (referred to in the 
scripting interface as OpenGL coordinates). This is because Harmony's field system does not use the same 
length for horizontal and vertical fields, which can cause serious inaccuracies, for example, when handling 
matrices that contain rotations. 

The following example demonstrates how to  process the coordinates provided by a Point2dWidget and 
apply them to a peg named MyPeg in the top level of the scene, using the two functions declared above in the 
process:

// Callback when the position value has changed
function point2dValueChanged(newFieldPosition2d)  
{ 
   // The 2d position attributes typically have their value expressed in
   // field.
   // Convert the field position into OpenGL coordinates. 
   // The OpenGL point will be expressed in the Master Controller node model
   // coordinates system.
   var mcModelPoint2d = scene.toOGL(newFieldPosition2d); 
 
   // Compute the position of the master controller in world coordinates.
   var worldPoint = getWorldPoint2d(mcModelPoint2d, "Top/MasterController");
 
   // Convert the position from world coordinates to the target peg model 
   // coordinates
   // Apply the inverse of the peg parent node transformation to the world 
   // position to go from world coordinates to (the peg) model coordinates
   var pegNode = "Top/MyPeg";
   var pegModelPoint = getModelPoint(worldPoint, pegNode);
     
   // Get the peg position which is in fields
   var fieldCenterPoint = node.getAttr(pegNode, frame.current(), "POSITION" ).pos3dValue();
   // Convert from fields to OpenGL coordinates
   var pegModelCenterPoint = scene.toOGL(fieldCenterPoint); 
     
   // Compute the new position of the Peg after applying the magnet to it.
   var newPegModelCenterPoint = computePosition(pegModelPoint, pegModelCenterPoint, 0.001);
 
   // Convert from OpenGL to fields coordinates
   var newPegFieldCenterPoint = scene.fromOGL(newPegModelCenterPoint); 
 
   // Set the peg attribute values to the new values.
   node.setTextAttr(pegNode, "POSITION.3DPATH.X", frame.current(), newPegFieldCenterPoint.x);
   node.setTextAttr(pegNode, "POSITION.3DPATH.Y", frame.current(), newPegFieldCenterPoint.y);
   node.setTextAttr(pegNode, "POSITION.3DPATH.Z", frame.current(), newPegFieldCenterPoint.z);
}
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TIP 

You can easily obtain the names of a node's attributes for scripting by enabling Publish Attribute 
Mode in the Node View and opening a node's Layer Properties dialog. For more information, see 
Accessing Node Attribute Names for Scripting on page 801.
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Applying the Coordinates of a Master Controller Widget to a 
Deformation Node

T-HSCP-002-012

It is possible to use Master Controller widgets to apply transformations to deformers. However, before 
attempting that, it is important to understand the difference between deformations that have absolute 
attributes and the ones that have relative attributes.

When using the Rigging tool to create Bone, Game Bone and Curve transformation chains, Harmony creates 
each deformation node with the attribute "Apply Parent Transformation" enabled. This attribute makes it so 
each point is deformed by their parent—the previous point in the chain—before they apply their own 
deformations to the drawing. This makes manipulating these types of deformation points difficult as their 
deformation matrices are not fully reversible. 

Hence, using a Master Controller widget to manipulate deformers is more easily achieved with Envelope type 
deformations. The Rigging tool creates Curve deformation nodes with the attribute "Apply Parent 
Transformation" disabled. This means envelope deformation points are not affected by their parent's 
deformations. Therefore, the deformation matrix for all the points in a Curve deformation chain is the same, 
that is, the one carried by the parent of the chain's offset, which would typically be a peg or a drawing node, 
and would hence be fully reversible. The process then becomes similar to when a widget is used to manipulate 
pegs or elements. 

TIP 

If you want to use the Master Controller to control deformation nodes that are relative to other 
deformation nodes, you can do so using the getDeformationComponentMatrix method of the 
DeformationUtils namespace. For more information, refer to the Harmony scripting reference.

With the inverse matrix of a deformation node, we can convert world coordinates to a deformation node's 
coordinates system. However, it is important to understand that curve and envelope deformation nodes are 
represented by three points: The central point, and the two tangent points defining the secondary points of 
the Bezier curves. If you plan to change the position of a curve or envelope deformation node, you will also 
need to modify its tangent positions, with an algorithm such as:

Tangent0 in fields = Previous-Offset + rotation(Vector(length0 * 0.1, 0), orientation0 degrees)
 Tangent1 = Offset + rotation(Vector(length1 * 0.1, 0), orientation1 degrees) 

In the Harmony scripting interface, this would be expressed like so:

var t0FldU = add(previousDeformationNode.fieldOffset, rotate(Point2d(deformationNode.length0 * 0.1, 0), deformationNode.orientation0));
var t1FldU = add(p1FieldUndeformed, rotate(Point2d(deformationNode.length1 * 0.1, 0), 180 + deformationNode.orientation1));

In this example, the deformationNode and previousDeformationNode are Deformation type objects 
defined as:
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function Deformation (nodePath)
{
   var currentFrame = frame.current();
   this.fieldOffset = node.getAttr(nodePath, currentFrame, "offset").pos2dValue();
   this.OGLOffset = scene.toOGL(this.fieldOffset);
 
   this.nodePath = nodePath;
   this.nodeType = node.type(nodePath);
 
   if(this.nodeType == "OffsetModule")
   
{
     this.orientation0 = node.getAttr(nodePath, currentFrame, "orientation").doubleValue();
     this.orientation1 = 0;
     this.length0 = 0;
     this.length1 = 0;
   }
   if(this.nodeType == "CurveModule")
   
{
     this.orientation0 = node.getAttr(nodePath, currentFrame, "orientation0").doubleValue();
     this.orientation1 = node.getAttr(nodePath, currentFrame, "orientation1").doubleValue();
 
     this.length0 = node.getAttr(nodePath, currentFrame, "length0").doubleValue();
     this.length1 = node.getAttr(nodePath, currentFrame, "length1").doubleValue();
   }
}

TIP 

You can easily obtain the names of a node's attributes for scripting by enabling Publish Attribute 
Mode in the Node View and opening a node's Layer Properties dialog. For more information, see 
Accessing Node Attribute Names for Scripting on page 801.

In the following example, we use a Point2dWidget to move the position of envelope deformation nodes 
towards it proportionally to the inverse distance between those two points. As the user drags the widget 
around the stage, the deformation points will inch towards it:

This is the node system for this example:
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First, we calculate the position of the Point2dWidget in the coordinates system of each parent peg of each 
deformation group in the scene.

// Get the deformation chains
getDeformationChains(leftmostParent, deformationChains);
  
for(var i=0; i&lt;deformationChains.length; ++i)
{
   // The first node of a deformation chain is always an Offset in our case.
   // Convert the position from world coordinates to the target peg
   // model coordinates.
   // Apply the inverse of the peg parent node transformation to the
   // world position to go from world coordinates to (the peg) model
   // coordinates
   var pegParentNode = node.srcNode(node.parentNode(deformationChains[i][0].nodePath), 0);
   var pegParentTransformation = node.getMatrix(pegParentNode, frame.current());
   var inversePegTransformation = pegParentTransformation.getInverse();
 
   var pegModelPoint = inversePegTransformation.multiply(worldPoint);
 
   // A deformation chain is simply an array of deformation node parameters.
   var deformationChain = deformationChains[i];
   if(deformationChain.length == 0)
     continue;
 
   // Apply the magnet translation for the deformation node offset and
   // both tangent points.
   // The first node is the Offset which doesn’t require a previous position.
   moveDeformationNode(deformationChain[0], new Deformation(""), pegModelPoint);
   for(var j=1; j&lt;deformationChain.length; ++j)
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{
     moveDeformationNode(deformationChain[j], deformationChain[j-1], pegModelPoint);
   }
}

Then, we compute the new position of the offset and tangent points of the deformation chains. We must also 
compute new orientation values from the new tangent point positions.

function moveDeformationNode(deformationNode, previousDeformationNode, magnetPoint)
{   
   if(deformationNode.nodeType == "OffsetModule")
   
{
     var p1FieldDeformed = scene.fromOGL(computePosition(magnetPoint, deformationNode.OGLOffset));
 
     node.setTextAttr(deformationNode.nodePath, "offset.X", frame.current(), p1FieldDeformed.x);
     node.setTextAttr(deformationNode.nodePath, "offset.Y", frame.current(), p1FieldDeformed.y);
   }
   else if(deformationNode.nodeType == "CurveModule")
   {  
     // Compute the new Offset attribute position
     var p1FieldUndeformed = deformationNode.fieldOffset;
     var p1FieldDeformed = scene.fromOGL(computePosition(magnetPoint, deformationNode.OGLOffset));
 
     // Set the new Offset attribute values.
     node.setTextAttr(deformationNode.nodePath, "offset.X", frame.current(), p1FieldDeformed.x);
     node.setTextAttr(deformationNode.nodePath, "offset.Y", frame.current(), p1FieldDeformed.y);
 
     // Compute the Tangent 0 position
     var t0FldU = add(previousDeformationNode.fieldOffset,rotate(Point2d(deformationNode.length0*0.1,0),deformationNode.orientation0));
     var t0OGLU = scene.toOGL(t0FldU);
     // Compute the new Tangent 0 position
     var t0FldD = scene.fromOGL(computePosition(magnetPoint, t0OGLU));
 
     // To compute the new orientation 0 position,
     // compute the new position of the previous node.
     var p0FieldDeformed = scene.fromOGL(computePosition(magnetPoint, previousDeformationNode.OGLOffset));
 
     // Compute the inverse of the tangent calculation
     // to get the new orientation 0 position
     var vRef0 = Point2d(1,0);
     var ori0D = -angleDelta(minus(toPoint2d(t0FldD),p0FieldDeformed),vRef0);
 
     // Compute the Tangent 1 position
     var t1FldU = add(p1FieldUndeformed,rotate(Point2d(deformationNode.length1*0.1,0),180+deformationNode.orientation1));
     var t1OGLU = scene.toOGL(t1FldU);
 
     // Compute the new Tangent 1 position
     var t1FldD = scene.fromOGL(computePosition(magnetPoint, t1OGLU));
 
     // Compute the inverse of the tangent calculation
     // to get the new orientation 1 position
     var vRef1 = Point2d(-1,0);  
     var ori1D = -angleDelta(minus(toPoint2d(t1FldD),p1FieldDeformed),vRef1);
 
     // Set the new orientation attribute values.
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     node.setTextAttr(deformationNode.nodePath, "orientation0", frame.current(), ori0D);
     node.setTextAttr(deformationNode.nodePath, "orientation1", frame.current(), ori1D);
   }
}

TIP 

Should you want to apply the deformations of a deformation chain to another deformation chain, 
you can use the applyVertexTransform method of the DeformationUtils namespace. For 
more information, refer to the Harmony scripting interface reference.  
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Connecting Master Controller Widgets to Nodes
T-HSCP-002-009

Like the Script node, the input and output ports of a Master Controller node are fully customizable. To 
customize the ports of a Master Controller node, open its Layer Properties and select the Specifications tab. In 
the following example, this specifications sheet will add one Peg (green) input port, one Image (blue) input 
port and one Image (blue) output port to the Master Controller node:

<specs>
   <ports>
     <in type="PEG"/>
     <in type="IMAGE"/>
     <out type="IMAGE"/>
   </ports>
   <attributes>
   </attributes>
</specs>

IMPORTANT 

Although the Master Controller does not require to be connected to a node system, it must at least 
have one output port in order to work. 

To apply the change in the configuration of the input ports, you must save, close and reopen the scene. 

If the first (rightmost) input port of the Master Controller node is a Peg input port, you can connect a peg node 
to it to affect the visible position of the widget in the Camera view. You can add more input ports and use them 
to detect where the Master Controller is relative to the remainder of the node network. 

NOTE 

To learn about the attributes of a Master Controller node, refer to the Script Node reference .
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Controlling Nodes Connected to a Master Controller
T-HSCP-002-016

A Master Controller node can detect the nodes that are connected to it and apply transformations on these 
nodes. 

Using the Specifications tab of the Master Controller layer properties, an input port can be added to the 
Master Controller which will indicate which node system to control. Using this port, the script can be made to 
scan the node system connected to it, and look for the expected pattern. For information on how to add port to 
a Master Controller node, see Connecting Master Controller Widgets to Nodes on page 226.

NOTE 

You should avoid using the main (rightmost) input port of the Master Controller node for this 
purpose, as transformations sent to this port will affect the position of the widget in the stage.

For example, if we take the magnet widget programmed in the previous topic, this magnet attracts Element 
nodes towards its position every time the mouse drags it. The rightmost input port of this widget's Master 
Controller node is used to position the widget, but its leftmost port is used to specify the entry point of the 
node system to control. To accomplish this, use the srcNode method of the Controller object.

// Get the parent node of the Master Controller node
// from its leftmost port.
var leftmostParent = node.srcNode(myController.node, 1);
  
// From the leftmost parent node of the Master Controller,
// gather every Element node children.
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var elementNodes = [];
getElementChildren(leftmostParent, elementNodes);
  
var nbElements = elementNodes.length;
for(var i=0; i&amp;lt;nbElements; ++i)
{
   // do something
}

From there, you can use the node global object's dstNode method to find its children, as its type method to 
obtain the type of each node. 

// Recursively look for child Element nodes.
function getElementChildren(parentPath, elementPaths)
{
   // Assume that the parent node has only one output port
   // For nodes with multiple output ports, iterate on the last
   // parameter using numberOfOutputPorts.
   var numberOfLinks = node.numberOfOutputLinks(parentPath, 0); 
   for(var i=0; i &amp;lt; numberOfLinks; ++i)
   
{
     // Get the child node path
     var childPath = node.dstNode(parentPath, 0, i);
 
     // Check the type of the child (READ is the Element node type)
     if(node.type(childPath) == "READ")
     
{
       elementPaths.push(childPath);
     }
     else
     
{
       // Recursively inspect the child node children
       getElementChildren(childPath, elementPaths);
     }
   }
}

If a node is inside a group, use the parentNode method of the node object to access the node's parent group 
node.

var myDeformationGroupPath = node.parentNode(myOffsetDeformationNodePath);
var pegParentNode = node.srcNode(myDeformationGroupPath, 0);
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Referring to the Master Controller Node
T-HSCP-002-017

It is possible for the Master Controller node to refer to itself. The path to its own node is available in the global 
Controller object. Because this object is created by the Master Controller node, it is specific to that node. 

function myCallback(newValue)
{
   // Get the parent node of the Master Controller by using its path from the
   // Controller.
   var masterControllerParentNode = node.srcNode(myController.node, 0);
}

The example above does not refer to the Controller object directly, but rather, to an object named 
myController. This is because the Controller object is only available at the root level of the script or within 
its own methods. To use the Controller object in other function in the script, it must be stored in a global 
variable:

// The script context will be initialized when Show Controls will be called.
// Keep a script global copy of the Controller object.
var myController = Controller;
  
function point2dValueChanged(newPointValue)
{
   // Not OK, the Controller global object isn’t available in callbacks
   var masterControllerParentNode = node.srcNode(Controller.node, 0);
   // OK, use a copy from the script global scope
   var masterControllerParentNode = node.srcNode(myController.node, 0);
}
  
// Called when the user shows the Master Controller module controls
 Controller.onShowControl = function()
{   
   Controller.controls = [];  
   Controller.controls.push(new Point2dWidget);  
   Controller.controls[0].valueChanged.connect(point2dValueChanged);
}
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Linking the Master Controller to its Files for Template Creation
T-HSCP-003-005

By default, if you create a template of a character that uses a Master Controller, files used by the Master 
Controller, such as script files, pose databases or any other asset files, will not be automatically copied over 
with the template. Hence, the Master Controller will not work when the character template is imported in 
another scene. To make sure your Master Controller node is always copied with its dependencies, you must list 
the files it depends on in its Extra Files property.

NOTE 

Files to include with a Master Controller template must be located inside the scene directory, or in 
one of its sub-directories, in order for Harmony to be able to copy them with the template. 

How to specify files and folders to copy when creating a template that contains a 
Master Controller.

 1. In the Node view, click on the yellow square  of the Master Controller node to open its Layer 
Properties.

 2. Select the Extra Files tab.

 3. Next to the Files to copy field, click on the  Function  button to create a pseudo-function in which 
to store file and folder names.
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 4. Click on the  Function  button again to open the Files to copy dialog.

 5. In the text field of the File to Copy dialog, do one of the following:

 l If all of your Master Controller's files are within one sub-directory of your scene, type the 
name of that sub-directory. For example, if you stored all the files for your Master Controller 
in the scripts sub-directory of your scene, type script.

 l Type in the path to each file your Master Controller depends on, relative to the scene 
directory. For example, if your Master Controller uses the file myScript.js in the scripts 
sub-directory of your scene, type scripts/myScript.js. You can type one file path per 
line.

 6. Click OK.

If you create a template that include the Master Controller node, the files listed in the Extra Files 
parameter will be copied in the template's directory. 
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Displaying and Testing Master Controller Widgets
T-RIG3-008-007

To use a Master Controller, you must first display its widget in the Camera and Perspective views. There are 
two ways to do this:

 l Using the Master Controller view, you can quickly find Master Controllers in your scene and display 
their widgets.

 l You can find and select the Master Controller node in the Node or Timeline view and use the Show 
Control command to display its widget.

TIP 

If you make changes to your Master Controller, you can hide and show the Master Controller's 
widget to reload its script and test your changes.

How to display or hide the Master Controller's widget using the Master Controller 
view

 1. Do one of the following to add the Master Controller view to your workspace:

 l In the top-right corner of the an existing view, click on the  Add View button and select 
Master Controller.

 l In the top menu, select Windows > Master Controller. 

The Master Controller view appears. In it, the Master Controllers list at the bottom displays all the 
Master Controllers in your scene, with their whole group hierarchy followed by their name.
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 2. If there are a lot of Master Controllers in the list, you can do one of the following to filter the list:

 l In the Path list at the top of the Master Controller view, expand the Top item to display a list 
of the groups in your scene, then select the group corresponding to the character in which 
the Master Controller you want to select is located.

 l In the Name field, type in part of the name of the Master Controller you want to display.
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 l In the Name field, type in part of the name of the group in which the Master Controller you 
want to display belongs.

 3. In the Master Controllers list, select the Master Controller you want to display. 

 4. In the bottom-right corner of the Master Controller view, click on the 
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 Show Master Controller button.

The widget displays in the Camera and Perspective views. 

NOTE 

You can follow the same steps to hide a widget that is already displayed.

How to manually find and display or hide the Master Controller's widget

 1. In the Node view or Timeline view, navigate to and select the Master Controller node you want to 
display or hide.

 2. Do one of the following to display the Master Controller's widget:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.
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 l Press Shift + F11.

The widget displays in the Camera and Perspective views. 

 3. In the Tools toolbar, select the  Transform tool.

 4. Click and drag on the widget to try manipulating it.

NOTE 

You can follow the same steps to hide a widget that is already displayed.

How to hide all Master Controller widgets

 1. Do one of the following:

 l In the Camera view toolbar, click on Hide All Controls .

 l From the top menu, select View > Hide All Controls.

 l Press Shift + C.
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Manipulating a Master Controller Widget
Once you have displayed a Master Controller widget, you can manipulate it with the Transform tool to test its 
effect.

How to manipulate a Master Controller widget

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Camera or Perspective view, click and drag on the widget.
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Changing the Position of a Master Controller Widget
By default, a Master Controller widget will always appear where it is scripted to appear. However, it is 
possible to manually offset the widget of a Master Controller from its default position. This is done by attaching 
a peg to the Master Controller, then manipulating the peg. The Master Controller's widget will move along 
with the peg, as if it was a drawing layer. Likewise, if you need a Master Controller's widget to be positioned 
relative to a specific character, you can connect the Master Controller to this character's master peg. 

By default, Master Controllers do not have an input port to which you can connect a peg. To be able to do this, 
you must configure it to have a transformation input port. Those ports are green and are usually used to 
connect pegs.

NOTE 

If you configure your Master Controller to have several input ports, the peg that will be used to 
offset the Master Controller widget must be the first of its input ports. The first input port of a 
Master Controller node is always the rightmost input port in the Node view. 

How to connect a peg to a Master Controller and offset its widget

 1. In the Node view, locate the Master Controller node.

 2. Click on its  Layer Properties button to open its Layer Properties dialog.

 3. Open the Specifications tab. By default, the content of this tab will be as follows:

<specs>
   <ports>
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     <in type="IMAGE"/>
     <out type="IMAGE"/>
   </ports>
   <attributes>
   </attributes>
</specs>

 4. Click on the  Edit button to open the Specifications editor. 

 5. In the Value field of the Specifications editor, replace the word IMAGE with PEG in the following 
line:

<in type="IMAGE"/>

It should now be:

<in type="PEG"/>

 6. Click on OK.

The Master Controller node's input port switches from blue to green. This is how you can tell that it 
is now a transformation (peg) input port, which can be connected to a peg.

 7. In the Node view, locate and select the Master Controller node.

 8. Do one of the following to display the Master Controller's widget:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.
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 l Press Shift + F11.

The widget displays in the Camera and Perspective views.

 9. In the Tools toolbar, select the  Transform tool.

 10. Press Ctrl + P (Windows/Linux) or  ⌘  + P (macOS) to instantly create a parent peg attached to the 
Master Controller.

 11. In the Node view, click on the Peg node to select it.

A transformation box appears in the Camera view.
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 12. In the Camera view, click and drag on the Master Controller's widget to offset its position.
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Chapter 18: Effects

Chapter 18: Effects
T-HFND-010-001

When creating a scene, rigging a character or once your animation is finished, you can add effects such as 
blurs, glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects 
change the way layers or groups of layers are rendered in your scene. 

Harmony supports OpenFX plugins, and has its own integrated particle systems as well as light shading 
(normal map)—see About OpenFX on page 473, About Light Shading in Harmony on page 393, and About 
Particles on page 388.

Effects are special types of nodes that you can add to your scene's structure. For an effect node to work, it must 
be connected under a drawing, a composite, another effect, or any other node that outputs an image. Effect 
nodes  alter the image information sent to their input port, and output the processed image through their 
output port. This gives you flexibility in deciding which elements of your scene are affected by an effect.

Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area 
they should affect.  A good example of this is the Tone effect, which is used to add a shadow of a given shape 
to a layer. Alone, the Tone effect has no impact on the drawing it is connected to. Once combined with a matte 
layer, the Tone effect will use the matte's shape to apply a shadow to the drawing. Even if the matte's shape 
bleeds outside of the drawing's outlines, the shadow will only be applied within the drawing's outlines. 
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A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the 
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details 
in the matte layer are ignored by the effect, only its shape is taken in account.

In the Node view, an effect must be connected to the drawing or composite it is meant to affect by its input 
(top) port, and its output (bottom) port must be connected to the scene's main composite.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be 
connected. 

The matte port has a  Matte  icon underneath it. You can invert the matte by double-clicking on this icon, 
which will make the effect use the negative space of the matte drawing rather than the matte drawing itself as 
its matte. When an effect's matte is inverted, the Matte appears black on white instead of white on black: .

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using 
the Layer Properties view. You can also click on a node's  Layer Properties  icon to open its layer properties in 
a dialog. If desired, you can even animate the parameters of your effect by converting their values to functions. 
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Chapter 18: Effects

TIP 

If you need to use the uncut version of your drawing layer anywhere else in your scene, you can 
bypass the effect it is connected to by connecting the drawing layer's output port to other input 
ports of your composite, or to other effects or composite, as needed. This will create new cables, 
leaving your layer's connection to its effect unaffected. 
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Adding Effects Nodes
T-HFND-010-004

In Harmony, you can add effects through the Node view. You can select an effect from the Node Library view, 
drag it to the Node view and connect it to drawing layers to form a network of nodes. Then, by adjusting each 
node's parameters, you can achieve exactly the look you have in mind.

How to add an effect

 1. Do one of the following:

 l In the Node Library view, select an effect and drag it to the Node view. You can use the 
Search toolbar to find nodes quicker.
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Chapter 18: Effects

TIP 

You can use the Search  field in the Node Library view to search for a node by 
name. 

 l In the Node view, right-click and select Insert, select the category of the node you want to 
add, then select the type of node you want to add.
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Connecting Effects
T-HFND-010-006

For an effect to work, it must be connected to a layer or composite. The effect will be applied to the image 
output by the layer or composite, and the transformed image will be composited with other elements in the 
scene. 

How to connect an effect

 1. Do one of the following:

 l If you want the drawing to only display in your scene as filtered by the effect, click on the 
input port connecting the scene composite to the drawing, then drag it to the input port of 
the effect, like so:

The drawing is only connected to the effect.

 l If you want the drawing to show both in its original state and as filtered by the effect, click 
on the drawing's output port and drag it to the input port of the effect, like so:

The drawing will be connected to both the effect and the scene composite. 

 2. Click and drag on the output port of the effect, the connect it to the scene composite.
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Chapter 18: Effects

TIP 

You can quickly connect an effect as the intermediary between a drawing and a composite by 
holding the Alt key, then clicking and dragging the effect over the connection between the 
drawing and the composite.                 

You can remove an effect from the connection between a drawing and a composite using the 
same technique. 
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Adding a Matte Drawing to an Effect
Some effects can use, or even require the use of a matte layer. The matte layer is a drawing that determines the 
area that the effect affects.

For example, a Cutter effect needs to be connected to a matte layer, because it uses the drawing in the matte 
layer to determine which part of the drawing to cut out. However, a Colour-Scale effect can be used without a 
matte layer, in which case it will affect the colour of all of the drawing it is connected to, but if it is connected to 
a matte layer, it will only affect the colours of the part of the drawing that is covered by the matte drawing. 

In the Node view, effects and nodes that require a matte layer will always have a matte port  at their left. 
Effects and nodes that can use a matte layer, but which don't require it, will have their matte port hidden by 
default, and it will appear if you bring a connection cable near their left edge. 

TIP 

The same mechanic works with Drawing nodes. Although they do not have a matte port by 
default, but if you connect a drawing or a composite near their left edge, a matte port will appear. 
When a Drawing node is connected to a matte, the part of the drawing covered by the matte is cut 
out from that drawing, which is the same as if the drawing was connected to a Cutter node—see 
About Masking and Cutting Parts of Elements in your Scenes on page 274.

How to connect a drawing to an effect's matte connection                                       in the Timeline view                 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .
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Chapter 18: Effects

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Timeline view, locate the effect layer for which you created a matte and click on the Expand 
 button right of its name.

Just below the effect, a list of parameters for the effect appears. If the effect has a matte connection, 
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the first parameter in the list will be Matte, and its value will be <Drop layer here>.

 5. Click and hold on the matte layer, then drag and drop it over <Drop layer here>.

The matte layer will be set as the effect's matte property.

<

NOTES 

 l When a drawing layer is used as an effect's matte, the artwork in that layer is not 
visible in the scene, since it is only used as the effect's matte. 

 l If you want to disconnect the effect from the matte, you can click on the Unlink  
button at the right of the Matte parameter to unlink the matte layer from the effect. 
This will make the matte drawing visible in the scene again. 

 6. By default, the effect is applied to the matte's opaque areas and the matte's transparent areas are 
ignored. If you want to invert this effect, which means apply the effect on the matte's transparent 
areas and ignore the matte's opaque areas, double-click on the layer (but not on its name) to open 
its Layer Properties dialog.

 7. In the Layer Properties dialog of the effect, there should be an Invert Matte parameter. If the effect 
has several tabs in its layer properties, you might have to look through each tab to find this 
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parameter. Check the check box for this parameter to invert the effect of the matte.

NOTE 

For Cutter nodes, this parameter is just named Inverted. 

How to connect a drawing to an effect's matte port in the Node view

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.
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 4. In the Node View, locate the effect node and the matte drawing node.

Notice that the matte drawing node is connected to your scene's main composite.

 5. Click on the input port of the composite that is connected to the matte drawing, then drag it over to 
the left edge of the effect node. 

If it's an effect that requires a matte, such as a Cutter there will already be a matte port at the left 
edge of the effect node. If it's an effect that can optionally use a matte, such as Colour-Scale, the 
matte port will pop up when you drag the cable over the left edge of the effect node.

The matte drawing is now used as the effect node's matte. 

 6. By default, the effect is applied to the matte's opaque areas and the matte's transparent areas are 
ignored. If you want to invert this effect, which means apply the effect on the matte's transparent 
areas and ignore the matte's opaque areas, double-click on the Matte  icon  of the effect to invert 
it. When an effect's matte is inverted, its matte icon also appears inverted .
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Configuring an Effect
Once your effect is connected, you can configure it by changing its layer properties. There are two ways to 
access a layer's properties:

 l By selecting it. Its layer properties will display in the Layer Properties view, which can be added to your 
workspace.

 l By opening its Layer Properties dialog. 

NOTE 

Most effects do not have a visible effect in the Camera view's default preview mode (OpenGL View 
). This preview mode is very fast and is optimized for animation, but not for effects. To preview 

an effect as you change its parameters, you must set the Camera view's preview mode to Render 
View , which will update slowly, but will render the effects as they would appear in the final 
rendered image. 

How to view a layer's properties in the Layer Properties view

 1. Do one of the following to display the Layer Properties view:

 l In the top right corner of any existing view, click on the Add View button and select Layer 
Properties.

 l In the top menu, select Windows > Layer Properties.

 2. In the Timeline or Node view, select the effect node you want to configure.

The selected node's layer properties are now displaying in the Layer Properties view. 

How to open a layer's Layer Properties dialog

 1. Do one of the following:
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 l In the Node view, locate the effect you want to configure and click on the Layer Properties 
 icon just left of the node's name. 

 l In the Timeline view, double-click on the effect layer you want to configure, but not on its 
name.

The layer's Layer Properties dialog appears. 

How to configure an effect

 1. In the toolbar under the Camera view, click on the Render View  button to make Harmony 
render the effects in the Camera view. 

TIP 

If your scene currently does not have a background, the negative space in your scene 
will render in black. To circumvent this, you can add a Colour-Card layer underneath all 
the other layers in your scene by clicking on the Add Layer  button in the toolbar 
over the layer list and selecting Colour-Card.
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Chapter 18: Effects

 2. In the Layer Properties view or the Layer Properties dialog, adjust the parameters of the effect until 
you have the expected results. 

The preview in the Camera view will update every time you make changes, but each change may 
take a short while before appearing in the Camera view, as the Render Preview mode requires more 
computing power to update. 

NOTE 

For more information on how to configure certain effects, refer to Examples of Effect 
Usage on page 335. For detailed information on the properties of each available effect, 
see  refer to the Nodes / Layers section of the Reference guide.

 3. Once you are done, you can dismiss the Layer Properties dialog if it was open, and you can set the 
preview mode of the Camera view back to OpenGL by clicking on the OpenGL View  button in 
the toolbar at the bottom of the Camera view. 
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Animating an Effect
You may need to animate some effects to obtain the expected results. For example, you may want the radius of 
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the 
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish. 

Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a 
parameter to different values at different points in the scene by adding keyframes to it, and setting each 
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of 
the previous keyframe to the value of the next keyframe. Drawing layers are animated by having their 
coordinates associated to functions. Likewise, effects can be animated by associating their parameters to 
functions. 

Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an 
effect's parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline 
view. You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which 
display all of a layer's parameters.

NOTE 

To learn how to preview animated effects, refer to About Effects Preview on page 267.

How to animate an effect parameter in the Timeline view

 1. In the Timeline view, locate the effect you want to animate, and click on the  Expand  button right 
of its name. 

The list of parameters that effect's paramaters that are available in the Timeline view appears.

 2. In the right area of the Timeline view, in the same row as the parameter you want to animate, select 
the frame where you want to create the first animation keyframe for the effect.
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 3. Create a keyframe by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 4. In the left area of the Timeline view, under the Parameters column, adjust the value of the 
parameter for this keyframe by doing one of the following:

 l Click and hold on the value of the parameter, then drag it towards the left to reduce its 
value, or towards the right to increase its value.

 l Click on the value of the parameter. A text field will appear. Type in the new value of the 
parameter, then press Enter.

 5. In the right area of the Timeline view, click on the frame where you want to create the second 
animation keyframe for the effect.
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 6. Create the second keyframe for your effect's animation by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 7. In the Parameters column, adjust the value of the parameter at the current keyframe. 

 8. Repeat the steps to create as many animation keyframe for your effect as needed.

 9. To adjust the timing between the keyframes of your animation, select the first keyframe.

 10. In the Timeline toolbar, click on the  Set Ease for Multiple Parameters  button.

The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be 
focused on the first  keyframe  in your animation, which should have a  Bezier handle  right next 
to it, pointing to the right. 

 11. Click on the 
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 Bezier handle  and drag it towards the right, at any angle, to adjust the ease-in of the animation.

 12. Click on Apply/Next.

The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last 
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are 
more animation keyframes after this one, it will have two Bezier handles, one pointing in each 
direction.

 13. Click on the left  Bezier handle  and drag it towards the left, at any angle, to adjust the ease-out of 
the animation between the previous keyframe and the current keyframe. 
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 14. If there is a  Bezier handle pointing towards the right, click on it and drag it towards the right, at 
any angle, to adjust the ease-in of the animation between the current keyframe and the next 
keyframe.

 15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire 
scene. 

How to animate an effect in the Layer Properties dialog

 1. Open the effect's Layer Properties by doing one of the following:

 l Add the Layer Properties view to your workspace, then select the effect in the Timeline or 
Node view.

 l In the Timeline view, double-click on the effect layer, but not on its name.

 l In the Node view, locate the effect node and click on its Layer Properties  button. 

 2. In the effect's layer properties, locate the parameter that you want to animate and click on the  
Function  button to its right.
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The parameter's input field will be greyed out. This is because you cannot directly edit a parameter 
once it is attached to a function. The field will indicate the name of the function that was created for 
it, in this format:

Name of node: Name of function: Value at current frame

 3. Click on the parameter's Function button again.

The Bezier Editor dialog opens. 

This dialog will allow you to animate the function. The function graph at the bottom is made to 
represent the values of the function throughout each frame in the scene. 

 4. In the function graph, click and drag on the red cursor  to move it to the frame where you want to 
create your first animation keyframe.
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 5. Click on the  Add Keyframe  button to create the first animation keyframe for the effect.

A keyframe  is created and should be visible in the function graph. If you do not see it, that is 
because the function graph is not positioned to include the keyframe within its frame. To move the 
function graph to view the function's keyframe, click on the  Reset View  or  Reset View 
Vertically  button. 

 6. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 

TIP 

If you want to set the keyframe to a value that is outside of the function graph's 
frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom 
back in.
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 7. Click and drag on the red cursor to move it to the frame where you want to create your second 
animation keyframe. 

 8. Click on the Add Keyframe  button to create the second animation keyframe for the effect.
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 9. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 

 10. If you want to adjust the timing of the animation between the first and second keyframes, do the 
following:

 l Click and drag the  Bezier handle  of the first keyframe  towards the right, in any direction, 
to affect the ease-in of the animation.
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 l Click and drag the  Bezier handle  of the second keyframe  towards the left, in any direction, 
to affect the ease-out of the animation.

 11. Repeat these steps until you created and timed every animation keyframe required to animate your 
effect.
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About Effects Preview
T-HFND-010-010

Most effects must be rendered so you can preview them properly. Some effects can be displayed in the 
OpenGL view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter, 
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered 
automatically, deselect the Auto-Render option and do the preview update manually.

You might also need to play back your animation and see the final effect before final rendering. But first, you 
must connect a Render Preview node to each effect.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see 
your animation with the final effects or use a Render Preview node for each effect.  Effects must be calculated 
before they can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the 
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a 
check preview.
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Previewing Effects in Render Mode
T-HFND-010-011

You can preview a single final frames with all effects calculated in the Camera view when you enable the 
Render mode. You cannot playback your animation in Render mode. You can also disable the auto-render 
option when adjusting several effect parameters to avoid slowing down your computer.

How to preview effects in Render mode

 1. In the Camera view status bar, click the Render View  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render. 
Depending on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

 1. In the Camera view status bar, click the Auto-Render  button. In the top menu, you can enable 
and disable Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the 
Auto-Render  button.

How to manually update the rendering preview

 1. In the Camera view status bar, click the Render  button.
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Previewing Effects in OpenGL Mode
If you want to playback your animation and see rendered effects, you can use the Preview node to see your 
effects in the Camera view OpenGL mode.

How to preview effects in OpenGL mode 

 1. To adjust the effect's visual controls in OpenGL mode, from the Node Library view, drag a Render 
Preview node to the Node view. Connect it between the effect and the Composite nodes.

 2. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

As you modify the effect's parameters and controls, the frames are rendered to ensure a real-time 
playback. The larger the resolution and the heavier the effect, the longer the rendering process will 
take. Green frames are rendered, red frames are pending and yellow frames are rendering.

 3. To display the controls, select the node in the Node view,  and do one of the following:

‣ In the Camera View toolbar, click the Show Control  button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (macOS).

The controls appear.
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 4. In the Tools toolbar, select the Transform  tool or press Shift + T.

 5. In the Camera view, adjust the controls.

 6. To set the preview parameters, click the Layer Properties  button of the Preview Render node in 
the Node view.

The Preview Render properties display.

Parameter Description

Name Allows you to enter a name for the node.

Preview Resolution
Lets you  set the resolution used to generate the preview. 
Resolutions range from 1/4 to 1/64th of the scene resolution. 
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Outdated Images Mode

Do Not Render: Does not render any effects in your scene.

Show Without Effects: Shows the outdated images without 
any effect.

Use Previously Rendered: Uses the previously rendered 
images. The old images will be used until the new ones are 
rendered.

Pre-render Next Frames Starts a pre-render job for every frame of the timeline.
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Playing Back Effects
T-HFND-010-012

To playback your effects, you need to do a temporary render.

How to play back effects

 1. In the Playback toolbar, click the Render and Play  button.

The Play node opens and loads the frames.

 2. Once the frames are loaded, click the Play  button in the Play window.

 3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE 

While previewing effects, you can press the Spacebar to stop and start playback.
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Changing the Preview Resolution
The Preview Resolution button allows you to quickly get a preview at half, one-third, or one-quarter of the 
scene resolution.

How to change Preview Resolution

 1. In the Camera view status bar, click the Preview Resolution button.

 2. Select any of the following resolution:

‣ 1:1 of Scene Resolution

‣ 1:2 of Scene Resolution

‣ 1:3 of Scene Resolution

‣ 1:4 of Scene Resolution

‣ 1:8 of Scene Resolution

‣ 1:16 of Scene Resolution

‣ 1:32 of Scene Resolution

‣ Progressive Render

You can also enable/disable Progressive Render Preview option:

 l From the Top menu, select View > Progressive Render Preview.

 2. Preview your effects animation.
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About Masking and Cutting Parts of Elements in your Scenes
An important part of staging and rigging is cutting. Cutting is the process of making parts of a drawing that 
intersect with another drawing invisible. It allows you, for example, to mask parts of a character that should 
appear behind a background element that is drawn on the same layer as other background elements, to mask 
two parts of a rig that should not overlap, or to confine an effect within the outlines of an element in your 
scene. 

There are two methods to cutting in Harmony:

 l Using the matte port of a drawing layer. With this port, you can connect any drawing layer to another 
drawing layer or composite, and use the latter as the drawing layer's matte. Any part of the drawing 
that intersects with the artwork in its matte will be hidden. 

 l Using a Cutter effect. A cutter effect can be connected to a drawing, effect or composite, and then can 
use any other drawing layer or composite as its matte. Any part of what is connected to the Cutter effect 
which intersects with the artwork in its matte will be hidden. 

Hence, if you only want to hide parts of a single drawing layer, you can use the drawing's matte port. If you 
want to hide parts of the image output by a composite or an effect, you will have to use a cutter effect

NOTE 

In either case, the effects of cutting can be inverted. When inverted, only the parts of the artwork 
that intersect with the matte are visible, and everything else is hidden.
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Using the Matte Port of a Drawing Layer
Each drawing in a Harmony scene has their own Matte port. Connecting a drawing or composite to a drawing's 
matte port will make the parts of the drawing that intersect with the matte image invisible. 

Optionally, you can invert a drawing layer's matte. This will make parts of the drawing that intersect with the 
matte image visible, and everything else hidden. 

How to connect a matte drawing node to a drawing node

 1. In the toolbar above the layer list in Timeline view, click on the Add Layer  button and select 
Drawing.

 2. Give your new drawing layer a relevant name for a matte layer, such as "Matte-Drawing", then click 
on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
a semi-transparent area of the matte will appear semi-transparent. For example, if a 
matte is filled with a colour that has an alpha value of 64 (25% opaque), instead of 
making the parts of the drawing it covers completely invisible, it will subtract the 
matte's opacity from the opacity of those parts of the drawing, making them 75% 
opaque. 

 4. In the Node view, click on the output port of the matte drawing node and drag the cable to the left 
edge of the drawing node. A Matte port will appear. Release the mouse button to connect the 
matte drawing node to the matte port of the drawing node. 
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At this point, areas of the drawing layer that intersect with the artwork in the matte drawing node 
are hidden. 

 5. If you want to invert the matte effect for the drawing node, so that the artwork that intersects with 
the artwork in the matte layer is visible and that everything else is hidden, double-click on the 
Cutter node's Matte  icon to toggle its Inverted parameter. When an effect's matte is inverted, its 
matte port also appears inverted . 
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Using the Cutter Node
T-HFND-010-009A

You can use the Cutter node to hide parts of a drawing, a group or an effect. The Cutter node must be 
connected to a drawing that will serve as a matte. Parts of the drawing, group or effect that intersect with the 
matte drawing will be hidden. 

Optionally, you can also invert the Cutter node's matte, which will make parts of the drawing, group or effect 
that intersect with the matte drawing visible, and everything else will be hidden.

How to use the Cutter effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Cutter effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Cutter. 

TIP 

You can also create Cutter nodes by pressing a keyboard shortcut. To be able to do this, 
you must assign a keyboard shortcut to the Create Cutter command in the Node View 
section of the Keyboard Shortcuts dialog. To access the Keyboard Shortcuts dialog: 

 l Windows or GNU/Linux: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Premium > Keyboard Shortcuts.

 2. While holding the Alt key, move the Cutter node over the cable connecting the drawing to your 
scene's main composite. The Cutter node will become connected as an intermediary between the 
drawing and its composite. 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.
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 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Node view, connect the output port of the matte drawing node to the Cutter node's left input 
(matte) port.

At this point, areas of the drawing layer that intersect with the artwork in the matte drawing node 
are hidden. 

 5. If you want to invert the Cutter's effect, so that the artwork that intersects with the artwork in the 
matte layer is visible and that everything else is hidden, double-click on the Cutter node's  
Matte  icon to toggle its Inverted parameter. When an effect's matte is inverted, its matte port also 
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appears inverted . 
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About Opacity and Transparency
Harmony has two ways of adding transparency to your scene:

 l The Opacity parameter is a parameter each drawing layer. It is set to 100% by default. By lowering it, 
you can make an individual layer appear more transparent.

 l The Transparency effect is an effect node that can be attached to individual layers or to a composite. It 
has a Transparency parameter that is set to 50 by default. The higher it is, the more transparent the 
layer or composite it is attached to will appear.

It is important to know when to use either approach. For example, to make a character composed of several 
layers transparent, it is preferable to connect the character rig's nodes to a composite and connect the 
Transparency effect to this composite, as reducing the opacity of individual layers will make their overlapping 
parts visible—see About Composite Nodes on page 1234.

You can however animate a Transparency effect's parameter in the Timeline view, so this may be a preferable 
approach even if you only want to animate the transparency for a single layer. To learn how to add and 
animate an effect, see Adding Effects Nodes on page 245, Connecting Effects on page 247 and Animating an 
Effect on page 257.
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Setting the Layer Opacity
If you need specific layers to appear semi-transparent, you can quickly set a drawing layer's opacity parameter 
directly in the Timeline view.

A drawing layer's opacity parameter will appear in the Timeline view when this drawing layer has thumbnails 
display enabled:

How to set a drawing layer's opacity

 1. In the Timeline view, do one of the following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

The Opacity parameter is displayed left of the drawing layer's thumbnail.

 2. Do one of the following:

 l Double-click on the value of the Opacity parameter and type in its new value.

 l Click and drag the value of the Opacity parameter to the left to reduce it, or to the right to 
increase it.
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Overriding Colours and Textures
The Colour Override Effect is one of the most useful and commonly used effects in Harmony, as it considerably 
expands the flexibility with which you can use colours and textures in your animation. With the Colour 
Override effect, you can replace individual colours or textures used your scene's drawings with other colours or 
textures. If your scene has different clones of the same palette, you can also use the Colour Override effect to 
make certain drawings use specific clones of the palette, whereas they would otherwise use the topmost clone 
in the palette list.
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Overriding a Colour
With the Colour-Override node, you can change the colour of some swatches.

How to override colours

 1. From the Colours section, select the colour swatch to modify and move it to the Individual Colour 
Overrides section. Several options are available to modify your colours.

 2. Once the swatch appears in the Colour-Overrides section, click the drop-down arrow and select 
one of the following options from the Mode menu:

 l Override colour: When selecting a colour swatch from a clone palette (not set as the 
current palette), use this option to override the current colour and use the swatch from 
the clone palette over the corresponding one in the current palette.

 l Colour Not Visible: Renders the selected colour invisible in the Camera view.

 l New RGB Only: Overrides the colour swatch RGB value while maintaining its original 
alpha value. You can select a new colour by clicking on the colour swatch and 
choosing a new colour from the Colour Picker window.

 l New Alpha Only: Overrides the swatch's alpha channel while maintaining its original 
RGB values. You can select a new alpha value by clicking on the colour swatch and 
choosing an alpha value from the Colour Picker window.

 l New RGBA: Overrides the swatch's colour and alpha values. You can select a new 
colour by  clicking on the colour swatch and choosing an alpha value from the Colour 
Picker window.
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Overriding a Colour With a Texture
With the Colour Override node, you can apply a texture over a selected colour. Any zone painted with the 
selected colour swatch will be overridden by the selected texture.

There are different ways to apply the texture over your colour:
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NOTE 

The result will only be visible in the Camera view in Render mode. In OpenGL mode, you will see 
the original colour.

The matrix position can be modified using the Edit Gradient and Texture  tool. To do so, your drawing zone 
must be painted with a gradient swatch or texture swatch.

Texture - Original Matrix

Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring 
up the Browser window to search for your texture. The texture's default matrix (fixed proportion and 
orientation) is mapped to the full size of the bounding box of each colour area to be overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all 
traced and cut from the same piece of stretched or squashed fabric.
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Texture - Global Bbox Centered

Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing 
all colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut 
from the same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words, 
each fill area will not only have the texture scaled to its individual proportions, but also stretched or squashed 
to fit within its contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.

Modulate Pencil Texture Colour (Replace Transformation)

Overrides the initial texture fill's transformation (matrix) established when you painted the line or modified it 
with the Edit Gradient and Texture  tool. This transformation override will be done by modifying the Peg's 
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position.

Modulate Pencil Texture Colour (Combine Transformation)

Combines the initial texture fill's transformation (matrix) established when you drew the line or modified it 
with the Edit Gradient and Texture  tool with the new position transformation you will create when 
modifying the Peg's position.

Override with This Texture Centered on Overridden Objects' Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be 
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece 
of fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture 
zone will be centered in the middle of the bounding box's centre.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position. 
The advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to 
follow the general motion of a character if you want the texture to follow instead of having the character 
moving across the fixed texture—see How to animate a texture override with a peg on page 290.

Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box 
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all 
traced and cut from the same piece of stretched or squashed fabric.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
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Textures - Use Input Image

How to apply a texture over a colour

 1. From the Colours section, select the colour swatch to override and drag it to the Individual Colour 
Overrides section.

 2. Once the swatch appears in the Individual Colour Overrides section, select it and then click on the  
Mode drop-down button  and select one of the following options:

 l Texture - Original Matrix

 l Texture - Global Bbox Matrix

 l Texture - Global Bbox Centered

 l Texture - Contour Bbox Matrix

 l Texture - Scale to Screen

 l Override With This Texture Centered on Overridden Objects Centre

 l Texture - Use Input Peg

 l Texture - Use Image Image

The Browse  icon appears in the New column.

 3. In the Colour-Override section, in the New column, click the Browse  icon to select your custom 
texture.

 4. Browse for your texture file.

 5. Click Open.
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 6. If you want to select a new texture to replace the existing one, click the Browse  button again 
and select a new one to replace the existing one.

How to animate a texture override with a peg

 1. From the Node Library view, drag a Peg node to  the Node view.

 2. Connect the Peg node in the Colour Override's middle port. The green port will take the 
transformation of the Peg to modify the texture's position.

 3. In the Node view, select the Peg node.

 4. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 5. In the Camera view bottom toolbar, enable the Render  mode.

 6. In the Camera view, move the Peg's position. As you move it, you can see the texture being 
modified. You can animate the position by adding position keyframes in the Timeline view. You can 
use the Random Fill function to quickly create a random shake.
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Modifying a Texture Fill's Transformation
When you paint a zone with a bitmap texture swatch, you may want to modify the size or position of the 
texture's matrix at the compositing level. For example, you may want to do this to animate the position of the 
texture in a zone. With the Colour-Override and a Peg node, you can animate the texture.

How to modify a texture fill's transformation

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

 1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate 
the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the final 
Composite, set as Pass-Through.

 2. Connect the Peg node in the Colour Override's middle port. The green port will take the 
transformation of the Peg to modify the texture's position.

 3. Click the Colour-Override's square yellow properties button to open its property editor.

 4. In the Palettes section, select the palette containing the bitmap texture swatch.

 5. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the 
Individual Colour Overrides section.
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 6. Once the swatch appears in the Individual Colour Overrides section, select it and then click the 
Override Mode button and select one of the following:

 l Override the colour's transformation: Overrides the initial texture's transformation 
(matrix) established when you painted the zones or modified with the Edit Gradient 
and Texture  tool. This transformation override will be done by modifying the Peg's 
position.

 l Combine the colour's transformation: Combines the initial texture's transformation 
(matrix) established when you painted the zones or modified with the Edit Gradient 
and Texture  tool with the new position transformation you will create when 
modifying the Peg's position.

 7. In the Node view, select the Peg node.

 8. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 9. In the Camera view bottom toolbar, enable the Render  mode.

 10. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being 
modified. You can animate the position by adding position keyframes in the Timeline view.
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Overriding a Texture on a Pencil Line
A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override 
node, you can override the pencil line's texture or texture fill and replace it by another one, or you can animate 
the texture's position.

With the Edit Gradient and Texture  tool, you can modify the size and position for both types of textures on 
a pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's 
matrix.

When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using 
the Colour-Override node and a Peg. 

You can modify and animate a pencil texture's position using the Colour-Override node and a Peg node. This 
lets you create a shaky line style which is a very popular design style. The main issue with this style is that it 
works well in traditional and tradigital animation, when the artist draws the line differently on each drawing, 
but it does not work in cut-out animation where the same drawing is used for the entire animation. The same 
issue happens when the same drawing is held for more than a few frames. The line moves during the 
animation, but stops moving during the drawing hold, which looks bad.
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With the Colour-Override node, you can animate the position of the pencil line texture independently from the 
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.

How to modify the pencil line texture

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

 2. In the Node view, connect the Colour-Override node under the Drawing node you want to animate 
the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the final 
Composite, set as Pass-Through.

 3. Connect the Peg node in the Colour Override's middle port. The green port will take the 
transformation of the Peg to modify the texture's position.

 4. Click the Colour-Override's square yellow properties button to open its property editor.

 5. In the Palettes section, select the palette containing the colour to override.

 6. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to 
the Individual Colour Overrides section.
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 7. Once the swatch appears, select it and then click on the Override Mode  button. Select one of the 
following options from the drop-down menu:

 l Modulate Pencil Texture Colour (replace transformation): Overrides the initial 
texture fill's transformation (matrix) established when you painted the line or 
modified it with the Edit Gradient and Texture  tool. This transformation override 
will be done by modifying the Peg's position.

 l Modulate Pencil Texture Colour (combine transformation): Combines the initial 
texture fill's transformation (matrix) established when you drew the line or modified it 
with the Edit Gradient and Texture  tool with the new position transformation you 
will create when modifying the Peg's position.

 8. In the Node view, select the Peg node.

 9. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 10. In the Camera view bottom toolbar, enable the Render  mode.

 11. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being 
modified. You can animate the position by adding position keyframes in the Timeline view.
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How to modify the pencil line texture

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

 2. In the Node view, connect the Colour-Override node under the Drawing node you want to animate 
the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the final 
Composite, set as Pass-Through.
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 3. Connect the Peg node in the Colour Override's middle port. The green port will take the 
transformation of the Peg to modify the texture's position.

 4. Click the Colour-Override's square yellow properties button to open its property editor.

 5. In the Palettes section, select the pencil texture palette containing the texture you want to use. By 
default, every scene has a pencil texture palette named after the name of the scene followed by _
pencil_texture.

 6. In the Colours section, select the pencil texture used to draw your lines and drag it to the Individual 
Colour Overrides section.

 7. When the swatch appears in the Individual Colour Overrides section, select it and click the 
Override Mode  button. Select one of the following:

 l Change Pencil Texture Transformation: Overrides the initial pencil texture's transformation 
(matrix) established when you drew the line or modified with the Edit Gradient and Texture 

 tool. This transformation override will be done by modifying the Peg's position.

 l Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation 
(matrix) that was established when you drew the line or modified with the Edit Gradient and 
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Texture  tool with the new position transformation you will create when modifying the 
Peg's position.

 8. In the Node view, select the Peg node.

 9. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 10. In the Camera view bottom toolbar, enable the Render  mode.

 11. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture being 
modified. You can animate the position by adding position keyframes in the Timeline view. You can 
use the Random Fill function to quickly create a random shake. 
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Overriding a Colour with a Texture Sequence
In production, you may need to map a live action sequence or bitmap image sequence into a zone or over 
several zones. For example, you could have a mirror shattered into several pieces and you want to map video or 
someone talking into those pieces. You can paint the mirror pieces with a specific colour swatch and use the 
Colour-Override node to map the image sequence into the pieces. It can also be a single image without having 
to be an image sequence.

NOTE 

To learn how to modify a texture's exposure based on an animation or character's motion, see 
Animating Textures Based on Action  on page 302.

How to override a colour with a bitmap image sequence

 1. From the Node Library view, drag a Colour-Override node to the Node view.

 2. In the Node view, connect the Colour-Override node under the drawing node that contains the line 
you want to animate.

 3. Connect the Live Action or Bitmap Image Sequence node in the Colour-Override's left port. The 
blue left port will input the images into the colour zones. Note that your image sequence's exposure 
needs to span over all the frames you it to be visible for. If there is not images exposed, the colour 
will not be overridden when frames are blank.

 4. Click the Colour-Override's square yellow button to open its property editor.

 5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to 
override.

 6. In the Colours section, select the pencil texture used to draw your lines and drag it to the Colour-
Override section.
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 7. Once the swatch appears in the Colour-Override section, select it and then click the Override Mode 
button and select Texture - Use Image Input.

 8. In the Node view, select the bitmap image node.

 9. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 10. In the Camera view bottom toolbar, enable the Render  mode.

 11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills 
being modified. You can animate the position by adding position keyframes in the Timeline view.
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Animating Textures Based on Action 
An effect often applied at the compositing stage is the texture overlays. With this effect, you can replace solid 
colours in your character with tiled-on bitmap textures, or replace their solid outlines with textured, natural-
looking pencil lines. 

To enhance this effect, you may want the texture override to be animated. The texture override can be 
composed of multiple drawings, which can be looped through as the scene plays out. You may want these 
texture drawings to change at a constant pace, or only when the character's action is fast enough to warrant it, 
to give it a more organic or stylized look.

This is where the Exposure Fill Using Render Change command comes in handy. This functionality allows you 
to automatically fill the texture layer's column with different drawing exposures relative to how intense the 
action is in the rendered image. You can define how much action is enough to warrant a drawing swap, letting 
the textures sit still when the character is inert but making them animated when they move. 

The Exposure Fill Using Render Change command can be applied on any drawing layer, but the most common 
case where this feature will be when a layer containing texture drawings is being used by a Colour-Override 
through its texture port to replace one of a character's colours with a texture. The drawing layer containing the 
texture drawings should have at least a few different texture drawings for the Exposure Fill Using Render 
Change command to be able to swap between them. For more information on this approach, see Overriding a 
Colour with a Texture Sequence on page 300.
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Using the Exposure Fill Using Render Change to Animate a Texture 
Fill

You can use the Exposure Fill Using Render Change functionality to automatically fill the column of a texture 
override layer with drawing exposures. The exposures will change more or less depending on the amount of 
motion that occurs between every frame, allowing you to easily make textures animated when the character is 
moving, and make them still when the character is not.

TIP 

Harmony will analyze how much action occurs between every frame based on the image sent to 
your scene's Display node. Hence, if you prefer that Harmony only analyzes the action for specific 
elements of your scene, you can add a Display node to your scene, connect it to the elements you 
wish to analyze, and use it as your current display—see About Displays on page 1253. 

NOTE 

The Exposure Fill Using Render Change command modifies the timing (exposure) of the selected 
layer. If you modify the character animation, you may need to reapply the exposure fill as the 
texture's exposure might no longer give the same final result.

How to animate a texture using the Exposure Fill Using Render Change functionality

 1. In the Timeline view, select the textures or live-action sequence.

 2. From the top menu, select Scene > Default Display > desired Display node.

 3. From the top menu, select Animation > Exposure Fill > Using Render Change.

Wait while Harmony creates a low resolution render of the images to preview.
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 4. In the Fill Exposure Using Render Changes window, use the Frame slider to view the motion 
change analysis.

 5. Based on your style preference, adjust the parameters to assign when the texture exposure 
changes will occur. You can adjust the type of filter to use for the motion detection, as well as 
threshold values to indicate what will be considered a big enough motion variation for an exposure 
change. 

Parameter Description

Changes Detection Settings

Frame: Use the slider to see when a change is necessary. A 
red edge indicates there is a large enough motion for the 
texture to change.

Use: Lets you use either the Red, Green, Blue, or Alpha 
channel, or Luminance difference between frames to analyze 
the motion changes. The Alpha channel is selected by 
default as it is the most commonly used parameter.

304



Pixel Value Change Threshold: The percentage of change in 
a pixel to be considered different from one frame to another. 
The higher the value, the more change is required when 
comparing two images in order for a new texture to be used.

Area Change Threshold: The percentage of non-empty 
pixels that must change from one frame to another to be 
considered different.

Fill Settings

These settings let you change the exposure. You can also 
decide on how many images you want to cycle. 

First/Last Frame: Lets you set the first and last frame for the 
exposure change. You can set this for the entire scene or for 
part of the scene (frames 20 to 32 for example).

Number of Drawings in Cycle: Lets you set of the number of 
drawings to include in the cycle.

First Drawing Used in Cycle: Lets you set the first drawing 
used in the cycle. Your drawings must be named using 
numeric values only, or number values with a prefix or suffix. 
It cannot only be letters.

Drawing Name Prefix: Adds a prefix before the number. For 
example, texture_01, texture_02 and so on.

Drawing Name Suffix: Adds a suffix after the number. For 
example, 01_texture, 02_texture and so on.

 6. Click OK.

The selected layer's exposure is updated. If you modify the exposure of motion in your animation, 
you may need to repeat this procedure.
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About Fading Colours
Using the Colour Fade effect, you can change the colours of a part of your scene, such as a character, a prop or a 
background, to a different set of colours over a specific span of time. 

The Colour Fade effect works a lot like the Colour Override effect, except that it has an animatable parameter, 
Fade, the value of which can go from 0 to 100: At 0, the colours in the image are unchanged, at 100, the 
colours in the image are replaced by the override colours, and at 50, the colours in the image are an even mix 
between the original colours and the override colours. Hence, by animating this parameter from 0 to 100, you 
can create a colour fade effect.

Just like with the Colour Override effect, you can use cloned palettes to replace several colours at the same 
time with the colours in an alternate palette, or you can select individual colours in the image and replace them 
with custom colours one by one.
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Adding a Colour-Fade Effect
To create a Colour Fade effect, you must add a Colour Fade node to your scene and connect it under the 
element, effect or composite which you want the effect to be applied.

NOTE 

Just like the Colour Override effect, the Colour Fade effect can only work on vector drawings, as it 
uses colour IDs to identify which colours to override. 

How to add a Colour-Fade effect

 1. Do one of the following:

 l In the Node Library view, select the Filter category and the Colour-Correct sub-category, 
then drag and drop the Colour-Fade node to the Node View. 

 l In the top-left corner of the Node View, open the View Menu and select Insert > Filter > 
Colour Correct.

 l Right-click in the Node View and, in the context menu, select Insert > Filter > Colour-Correct

A Colour-Correct node is added to the Node View.

 2. Press and hold the Alt key.

 3. Click and drag the Colour-Correct node over the cable under the element, effect or composite to 
which you want to apply the colour fade effect.

307

Harmony 21 Premium User Guide                          



Chapter 18: Effects

Using the Colour Fade Effect to Fade Individual Colours
You can use the Colour Fade effect to change specific colours in your artwork with custom colours. 

How to configure the Colour-Fade effect to fade specific colours to custom colours

 1. In the Node View, click on the Layer Properties button of the Colour-Correct node.

The Layer Properties dialog of the Colour-Correct node appears.

 2. Do one of the following:

 l In the Palettes list, select the palette containing the colour that you want to change. Then, in 
the Colours list, select the colour swatch for the colour you want to change.

 l If the colour you want to override is visible in the Camera or Drawing view, you can instantly 
selected it by clicking on the Colour Eyedropper button above the Colours list, then clicking 
on the colour in the Camera or Drawing view. The colour will be selected in the Colours list.

 3. Click on the Add button between the Colours list and the Individual Colour Overrides list.

The swatch is added to the Individual Colour Overrides list.

 4. In the Individual Colour Overrides list, in the row for the colour you just added, click on the drop-
down button right of the Mode column to select the colour override mode:

 l Override Colour: If this colour is overridden by one of the palettes in the Whole Palette 
Overrides list, this option will prevent this specific colour from being overridden.

 l Colour Not Visible: Areas filled with the selected colour become invisible.

 l New RGB Only: Areas filled with the selected colour fade to a new colour with custom red, 
green and blue values, but the colour’s alpha value remain unchanged.

 l New Alpha Only: Areas filled with the selected colour value fade to the same colour with a 
different alpha value.

 l New RGBA: Areas filled with the selected colour fade to a new colour with custom red, 
green, blue and alpha values.

 5. If you selected New RGB Only, New Alpha Only or New RGBA, click on the colour swatch in the 
New column to open a colour picker and select the new colour and/or alpha values.
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Using the Colour Fade Effect to Fade to a Different Palette
You can use the Colour Fade effect to change the colours in your artwork from the colours in their original 
palette to the colours in an alternate palette. This works just like overriding a character’s palette with an 
alternate palette using the Colour-Override effect.

For this to work, your alternate palette must be a clone of the original palette. This is because the Colour-Fade 
effect knows which colours in the original palette to replace with which colours in the alternate palette based 
on each colour’s “colour ID”. When you clone a palette, you create a new palette with the same colour IDs as 
the original palette, but you can change the colours in the cloned palette without affecting the original 
palette—see Cloning a Palette  on page 714.

If you add a colour to the original palette after you created a clone of it, you can clone the colour from the 
original palette to the clone palette, so that it also has the same colour IDs across palettes—see Copying and 
Pasting Colours  on page 671.

How to configure the Colour-Fade effect to fade to an alternate palette

 1. In the Node View, click on the Layer Properties button of the Colour-Correct node.

The Layer Properties dialog of the Colour-Correct node appears.

 2. In the Palettes list, select the clone palette which you want to use to override the element’s original 
palette.

NOTE 

You do not need to select the original palette used in your artwork. The Colour Fade 
effect only needs the alternate palette. It will find which colours to replace with the 
colours in the alternate palette by matching their colour IDs

TIP 

You can also use an alternate palette that is on your computer or your Harmony Server 
database, even if it is not in your scene:

 l To add a palette from your Harmony Server database, click on the Add database 
palette button.

 l To add a palette from your computer to the list, click on the Add file system palette 
button.

 3. Click on the Add button between the Palettes list and the Whole Palettes Overrides list.

As soon as the clone palette is added to the Whole Palette Overrides list, you should see its effect 
in the Camera view. 
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NOTE 

If you don’t see the effect of the palette override, make sure that the palette you 
selected is actually a clone, and not just a copy, of one of the palettes used by the scene 
element to which the effect is connected—see Cloning a Palette  on page 714.
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Animating the Colour Fade Effect
When using a Colour Fade effect, you need to animate the transition from the original colours to the alternate 
colours. This is done by animating its Fade parameter, which can range from 0 to 100. At 0, the Colour Fade 
outputs the original colours. At 100, the Colour Fade outputs the alternate colours. At any value in-between, 
the Colour Fade outputs a mix of the original and alternate colours.

How to animate the Colour-Fade effect

 1. Locate the Colour-Fade effect in the Timeline view.

TIP 

You can quickly locate the Colour-Fade in the Timeline view by doing the following:

 a. Select the Colour-Fade node in the Node View.

 b. Click on the Timeline view to focus on it.

 c. Press O to scroll to the Colour-Fade node in the Timeline view.

 2. In the Layers list, right of the Colour-Fade layer, click on the Expand button to expand the layer’s 
parameters.

The Fade parameters is listed under the Colour-Fade layer.

 3. Right of the Fade parameter, select the frame where you want the colour fade effect to begin.

 4. Do one of the following to create an animation keyframe:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 5. In the Parameters column, next to the Colour-Fade layer, there should be the number 100. Do one 
of the following:

 l Double-click on this value and type 0.

 l Click on the value and drag towards the left until it reaches 0.

 6. Right of the Fade paramter, select the frame where you want the colour fade effect to end.

 7. Do one of the following to create an animation keyframe:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.
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 l Press F6.

 8. In the Parameters column, next to the Colour-Fade layer, do one of the following:

 l Double-click on the value and type 100.

 l Click on the value and drag towards the right until it reaches 100.

The Colour-Fade effect will fade its input image from its original colours at the frame where its Fade 
parameter is set to 0 to its alternate colours at the frame where its Fade parameter is set to 100. 

 9. If you are not satisfied with the way the original colours transition to their replacement colours, try 
changing the Colour Space parameter to a different option:
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Adjusting Colour Curves
With the help of the different channel curves, the Colour Curves effect allows you to modify the brightness 
and contrast of an image. Depending on if you modify the input, the output values or a mix of both, you can 
darken the shadow of a picture, brighten the highlights. By adding a point to the middle of the curve you can 
also modify the medium values.
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Connection
The Colour Curves node takes an image of any type as its input and outputs an image with different brightness 
and contrast parameters.
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Modifying Colour Curves

How to add point to a curve

 1. Open the Layer Properties of the Colour Curves node that you want to modify.

 2. Select the Channel that you want to modify.

 3. Use the modifier Ctrl and click on the curve where you want to add a control point.

NOTE 

On an unmodified curve, you will notice that both Input and Output values are the same for 
each new control point added to the curve, since the curve has not been modified yet.

How to apply a texture to a drawing

If you want to apply a texture on a drawing to give it a dirtier look, you need to make sure that the texture 
receives the same colours as your drawing, but in a different tonality and by keeping the original colour 
swatches intact. Even though there may be different ways of doing it in Harmony, the Colour Curves node 
may become really handy in this kind of situation.
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 1. Import a bitmap texture image into Harmony. In the top menu, select File > Import > Images.

NOTE 

Make sure the imported image will be kept as an Original Bitmap. 

 2. Connect a Channel Swap node under the Texture drawing node.

 3. Open the Layer Properties of the Channel Swap.

 4. For each channel (Red, Green, Blue and Alpha) select Luminance.
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NOTES 

 l By selecting the Luminance option, it will limit the output to a single channel 
and makes it appear as if it were the same perceived brightness as it was 
when it was coloured.

 l It would have been possible to recreate the same example without using the 
Channel Swap node, but you would have needed to modify every curve 
within the Colour Curves. The Channel Swap node makes it easier to 
manage. 

The other reason why using the Channel Swap may be the best thing to do is because 
managing more than one curve, or even converting an image to a grayscale will lose the 
contrast value of the image. In that, the human eye sees colours as brighter values, even if 
they are at the same brightness. What luminance does, is it flattens to a grayscale, but uses 
an algorithm that weights the RGB based on the human eye. So it'll bump up greens, lessen 
blues, ect. to make it more real to the human eye.

 5. Connect a Colour Curves node under the Channel Swap node.

 6. Open the Layer Properties of the Colour Curves node to create a better contrast on your texture.

 7. Select the Alpha channel.

 8. Select the first control point and move it to the right.

By doing so, the texture will have more contrast, since the middle colour values will become darker.
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 9. Select the last control point and move it down.

This will reduce the amount of white.

 10. Make a more progressive curve by playing with the handles of both control points.
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 11. Connect a 2nd Colour Curves node under your Drawing.

 12. Open the Layer Properties of the Colour Curves node to create a better contrast on your texture.

 13. Select the Alpha channel.

 14. Select the last control point and move it to the left.

By doing so, the texture will have more contrast, since the middle colour values will become 
brighter.

 15. Make a more progressive curve by playing with the handles of both control points.
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 16. Add a Cutter node.

 17. While holding ALT, insert a Cutter node under the Colour Curves of the Drawing node. The Colour 
Curves node should be connected to the matte-port of the Cutter node.

 18. Connect the Colour Curves from the Texture drawing node to the Image input of the cutter.

 19. Make sure the Cutter's matte option is inverted.

 20. Add a second Cutter node.

 21. While holding ALT, insert a Cutter node under the first Cutter node. It should be connected to the 
Matte-port of the 2nd Cutter node.

 22. Drag a second cable from the Drawing node to the Image input of the 2nd Cutter.

 23. Make sure the Cutter's matte option is inverted.
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 24. Add a Blending node.

 25. While holding ALT, insert the Blending node between the Drawing node and the second Cutter 
node.

 26. Open the Blending’s Layer Properties.

 27. Select the Blend mode Multiply.
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 28. Drag a third cable from the Drawing node and connect it to the right-most position on the 
Composite node.

 29. In the Camera view, visualize the effect in Render mode.
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Adjusting Colour Levels
You can adjust the colour levels on an imported bitmap image or scanned image using the Colour Levels node.

How to change the contrast of an image 

 1. In the Top menu, select File > Import > Images.

 2. Select the Create Single Layer Named option under the Create layer(s) section.

 3. Define the name for that Drawing layer.

 4. Select the Keep As Original Bitmap option under the Import Options section.

 5. Click on the OK button to validate.

 6. Drag from the Node Library view to the node view a Colour Levels node.
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 7. Select the Colour Levels node and, while holding ALT (or Cmd on Mac), move it near the cable link 
linking the sketch drawing node to the Composite node. 

This will connect it directly to the cable under the sketch drawing node.

 8. From now on, enable the Render View mode as the following effects and parameters are not visible 
in OpenGL mode.

 9. Open the Colour Levels node’s Layer Properties to modify the parameters.
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 10. In the RGB tab: 

 l Increasing the value of the Input Black parameter will make the darkest parts of the drawing 
closer to black

 l Decreasing the values of the Input White parameter will make the lightest parts of the 
drawing closer to white

 l Modifying the values of the Gamma parameter to a higher value than one will increase the 
value of dark colours proportionally to their actual values, increasing the contrast between 
them and making them lighter. 

 l Increasing the Output Black level will make the black pixels in the drawing appear lighter. 
All other pixels in the drawing will also appear lighter, but the closer to white they are, the 
less lightness is added to them. 

 l Decreasing the Output White level will make the white pixels in the drawing appear darker. 
All other pixels in the drawing will appear darker, but the closer to black they are, the less 
darkness is added to them.

NOTE 

The same logic is kept for all parameters within each channel tab, but instead of 
modifying all the channels at the same time like in the RGB tab, the other one 
will modify only one channel at a time.

Example with random values for some channels:
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Original

      Red                                     Green                                   Blue

How to clear a sketch drawing to keep only the lines

                                  Before                                                                    After

@ 2018 hedgehog by Clemence Dufresne

 1. In the Top menu, select File > Import > Images.

 2. Select the Create Single Layer Named option under the Create layer(s) section.

 3. Define the name for that Drawing layer.
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 4. Select the Keep As Original Bitmap option under the Import Options section.

 5. Click on the OK button to validate.

 6. Drag from the Node Library view to the node view a Colour Card node

 7. Connect the Colour Card on the right side of the sketch drawing port on the Composite node.
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The Colour Card will make it easier to clean up the drawing and see the remaining grey spots when 
playing with the Colour Levels.

 8. Drag from the Node Library view to the node view a Colour Levels node.

 9. Select the Colour Levels node and, while holding ALT (or Cmd on Mac), move it near the cable link 
linking the sketch drawing node to the Composite node. 

This will connect it directly to the cable under the sketch drawing node.
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 10. From now on, enable the Soft Render and keep working with it since the next effects don’t appear 
in OpenGL.

 11. Open the Colour Levels node’s Layer Properties to modify the parameters.

The Colour Levels node will be useful to reduce the amount of greys and to clean up the image.
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 12. In the RGB tab: 

 l Increasing the value of the Input Black parameter will make the darkest parts of the drawing 
closer to black

 l Decreasing the values of the Input White parameter will make the lightest parts of the 
drawing closer to white

 l Modifying the values of the Gamma parameter to a higher value than one will increase the 
value of dark colours proportionally to their actual values, increasing the contrast between 
them and making them lighter. 

 13. Drag from the Node Library view to the Node view a Negate node.

 14. Connect the Negate node under the Colour Levels node.

No need to modify its Layer Properties. Values can be kept as is.
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The Negate node will make the line brighter where it exists, and darker where it doesn't. So the 
luminance will be able to pick it up for alpha.

 15. Drag from the Node Library view to the Node view a Channel Swap node.

 16. Connect the Channel Swap node under the Negate node.

 17. Open the Channel Swap node’s Layer Properties to modify its parameters.

By Turning all RGB channels except the Alpha to black and using the luminance option to be the 
alpha. It is now possible to have a black drawing with an invisible background.
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 l Modify the Red Channel to: Full Off

 l Modify the Green Channel to: Full Off

 l Modify the Blue Channel to: Full Off

 l Modify the Alpha Channel to: Luminance
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NOTE 

 l By modifying a channel to “Full Off”, it changes the channel to Black.

 l By modifying a channel to “Lumiance”, it changes the channel to White.
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Examples of Effect Usage
The following section gives examples of how to use a few commonly used effects in Harmony.
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Adding a Highlight to a Drawing
Using the Highlight effect, you can apply a highlight to a drawing. Contrary to the Glow effect, the Highlight 
effect does not convert your drawing into a glow, it applies the glow onto your drawing. The resulting render 
includes both the drawing to its glow.

The Highlight effect uses a matte drawing layer to determine which areas of the drawing to apply the 
highlight to. The highlight will not be applied outside of the drawing or outside of the matte. 

How to use the Highlight effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Highlight effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Highlight. 

 2. While holding the Alt key, move the Highlight node over the cable connecting the drawing to your 
scene's main composite. The Highlight node will become connected as an intermediary between 
the drawing and its composite. 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.
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 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. Connect the Matte drawing to the Matte port of the Highlight node.

 5. Display the Highlight properties and adjust the properties to control the type and amount of blur 
and the colour of the highlight effect—see the Reference guide .

337

Harmony 21 Premium User Guide                          



Chapter 18: Effects

Adding a Shadow to a Drawing
Using the Tone effect, you can apply a shadow to a drawing. Contrary to the Shadow effect, the Tone effect 
does not convert your drawing into a shadow, it applies the shadow onto your drawing. The resulting render 
includes both the drawing to its shadow.

The Shadow effect uses a matte drawing layer to determine which areas of the drawing to apply the shadow 
to. The shadow will not be applied outside of the drawing or outside of the matte. 

How to use the Tone effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Tone effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Tone. 

 2. While holding the Alt key, move the Tone node over the cable connecting the drawing to your 
scene's main composite. The Tone node will become connected as an intermediary between the 
drawing and its composite. 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.
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 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. Connect the Matte drawing to the Matte port of the Tone node.

 5. Display the Tone properties and adjust the properties to control the type and amount of blur and 
the colour of the Tone effect—see the Reference guide .
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Creating a Drop Shadow
The Shadow effect converts the drawing layer it is connected to into a dark, blurry matte. You can control the 
type and amount of blur, as well as the colour of the shadow.

On its own, simply connecting a drawing or composite to this effect will only convert your drawing to a 
shadow, which might not be useful. However, it is possible to make both the original character and its shadow 
version appear in your scene, and have the shadow version transformed and distorted to appear as a drop 
shadow. You can accomplish this by doing one of the following: You can accomplish this by creating a node 
system similar to this one:

TIP 

When creating a drop shadow against a floor, you can obtain a more realistic effect by using a 
Quadmap to transform the shadow instead of a Peg. A Quadmap is similar to a peg, except that it 
allows you to  apply perspective effect to the drawings underneath it. 

How to create a drop shadow for an animated character

 1. In the Node view, make sure your character's rig is in a group with a composite. If it is not, select all 
the nodes making your character's right, and do one of the following:

 l Right-click on the selection, then select Group > Group Selection with Composite.

 l In the top-left corner of the Node View, open the View Menu , then select Nodes > 
Group Selection with Composite.

 l Press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS).
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 2. Using the Node Library, add a Peg, an Apply-Peg-Transformation, and a Shadow node to your 
node system. 

 3. Connect the output port of your character rig to the input port of the Shadow node.

 4. Connect the output port of the Shadow node to the right-most input port (Image) of the Apply-
Peg-Transformation node.
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 5. Connect the output port of the peg to the leftmost input port (Transformation) of the Apply-Peg-
Transformation node.

 6. Connect the output port of the Apply-Peg-Transformation node to your scene's main composite, 
just right of the connection for your character rig. This way, the shadow will appear behind your 
character rig. 

 7. Select the Apply-Peg-Transformation's Peg node.

 8. In the Tools toolbar, select the Transform  tool. 
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 9. In the Camera view, scale and skew the selection so that it looks like a drop shadow. 
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Adding a Radial Zoom Blur to a Scene
T-COMP2-003-006

The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or rotating 
camera. You can use a matte to isolate the area of the image from which you want the effect to radiate from. For 
example, in the illustration below, a circular matte was created to mask the eyeball and a Negate effect was 
applied so the blur is outside the matte. Then the centre point was positioned on the character's iris, which is 
the centre of the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see:

https://www.toonboom.com/resources/video-tutorials/chapter/adam-phillips-harmony-effects

NOTE 

To learn about the Blur Radial Zoom parameters, see the Reference guide .

How to use the Blur Radial Zoom

 1. In the toolbar at the bottom of the Camera view, click on Render View . 

 2. Do one of the following:

 l From the Node Library view, drag a Blur-Radial-Zoom node to the Node view.

 l Right-click in the Node View and select Insert > Filter > Blur > Blur-Radial-Zoom. 

344

https://www.toonboom.com/resources/video-tutorials/chapter/adam-phillips-harmony-effects


 3. Click on the port connecting the composite to the drawing node, and drag the cable to the right-
most (Image) input port of the Blur-Radial-Zoom node.

 4. Click on the output port of the Blur-Radial-Zoom node and drag it to the composite to connect the 
effect to the composite. 

 5. On the Blue Radial Zoom node, click on the Layer Properties  icon to open the node's Layer 
Properties dialog. 
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 6. In the Layer Properties dialog, increase the Blurriness value.

 7. In the Direction section, click on any of the direction presets to modify the direction of the blur. Each 
preset button has an icon that represents the results of the preset.

 8. In the Node or Timeline view, select the Blur-Radial-Zoom node.

 9. In the Camera view toolbar, click on the Show Control .

A red dot appears in the middle of the Camera view. This dot determines the focus (centre)of the 
radial-zoom blur effect.
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 10. In the Tools toolbar, select the Transform  tool.

 11. Click and drag on the red dot to position it where you want the focus of the radial-zoom blur effect 
to be.

How to create a radial-zoom blur around an isolated area

 1. In the toolbar above the layer list in Timeline view, click on the Add Layer  button and select 
Drawing.

 2. Give your new drawing layer a relevant name for a matte layer, such as "Matte-Drawing", then click 
on Add and Close.

347

Harmony 21 Premium User Guide                          



Chapter 18: Effects

 3. In the new matte drawing layer, draw the shape of the area that you want to isolate from the 
radial-zoom blur, and fill it. 

 4. In the Node view, click on the port connecting the composite to the matte drawing layer and drag it 
to the left edge of the Blur-Radial-Zoom blur. A matte input port will appear when you bring a 
cable near the left edge.

 5. Click on the Layer Properties  button of the Blur-Radial-Zoom node to open its Layer Properties 
dialog. 

 6. Check the Invert Matte check box at the bottom of the layer properties dialog.
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Everything outside of the matte drawing is now affected by the radial-zoom blur. 
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Applying a Greyscale Matte to a Scene
Here is an example on how to use the Matte Output option of the Greyscale node. A frosted window was 
created using a snowflake image over a blue rectangle and a colourful background.

Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale node, it turns into a greyscale image. There is no 
transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the 
Matte View mode of the Camera view is enabled, you can see the transparency levels generated from the 
colour values. 

When you connect the Snowflake images into a Cutter effect's Matte port along with the Window images, the 
window will be semitransparent, matching the alpha (transparency) channel generated by the Greyscale 
node.
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NOTE 

To learn more about the Greyscale filter, see the Reference guide .
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About the Animated Matte Generator
T-COMP2-002-003

The Animated Matte Generator effect is a very advanced tool in Harmony's suite of effects with three key 
features:

 l Matte Animation

 l Feathered Effect

 l Snapping

Matte Animation

The Animated Matte Generator takes a vector drawing as input and generates animatable points for its 
contours. This allows you to animate the points and contours of a vector drawing, which can come in handy if 
you want to animate simple parts of a character rig, like fingers, eyebrows and eyelids. 

Feathered Effect

The Animated Matte Generator can use the vector drawing it is connected to as the basis for an effect matte, 
from which you can create an outer contour and an inner contour, and use them to generate a custom-shaped 
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feathered effect. The matte's contours can be animated. The resulting effect can be used as-is, or serve as a 
transparency mask for other effects or drawings. 

Snapping

You can set some of the points and contours of an Animate Matte Generator to snap to the contours of a 
drawing in your scene. This can be especially useful if you want to create shadows or highlights that match the 
shape of a drawing. 
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Adding an Animated Matte Generator Node
T-COMP2-002-004

In order to use the Animated Matte Generator, you must connect it to a vector drawing layer, called the source 
drawing, which will be used to define the default shape of the matte before it is animated. 

A source drawing for an Animated Matte Generator should follow these guidelines:

 l It should be simple. The Animated Matte Generator will create an animatable control point for each 
vector point in the drawing, so having too many points could make it very difficult to animate. 

If you want to create a feathered effect, make your drawing a simple shape with a solid colour. If you 
want to animate a drawing's shapes and contours, make sure the drawing's lines are made with pencil 
lines and not brush strokes, that the drawing has been flattened and optimized and that all 
unnecessary vector points have been removed using the Contour Editor or the Smooth Editor tools. 

 l It must be a single vector drawing layer. The Animated Matte Generator cannot work with composites, 
effects, bitmap layers or anything but a vector drawing node. 

 l If you have Overlay and Underlay Arts enabled, the Overlay Arts should be used for annotations only. 
The Animated Matte Generator will ignore the Overlay art layer in the source drawing.

How to add an Animated Matte Generator node

 1. In the Node view, add an Animated Matte Generator node to your scene by doing one of the 
following:

 l In the Node Library, select the Generator filter, and drag and drop the Animated-Matte-
Generator node from the Node Library view to the Node view.

 l In the Node view, right-click and select Insert > Generator > Animated-Matte-Generator.

 l Open the Node view menu and select Insert > Generator > Animated-Matte-Generator.

 2. Connect the Animated Matte Generator node as an intermediary between your source drawing 
node and its composite, by doing one of the following:
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 l While holding the Alt key, drag the Animated Matte Generator node over the cable 
connecting the source drawing node to the composite. 

 l Connect the output of the source drawing node to the Source Drawing (right) input port of 
the Animated Matte Generator node, then the output port of the Animated Matte Generator 
node to the composite.

TIP 

If you want the generated matte's contours to snap to the contours of another drawing in your 
scene, you can also connect it to another drawing, which is referred to as the snapping source. 
For more information, see About Snapping with the Animated Matte Generator on page 384.
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About Matte Creation and Animation with the Animated Matte 
Generator

T-COMP2-002-005

The Animated Matte Generator node converts the vector points of its source drawing into matte points. Those 
points can be animated, allowing you to freely morph the shape of the source drawing as your scene plays out. 

You can animate the points of an Animated Matte Generator by displaying its controls in the Camera view, 
then moving them using the Transform tool. Moving and tweaking the contour points for an Animated Matte 
Generator works a lot like using the Contour Editor tool.
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Displaying Animated Matte Generator Controls

T-COMP2-002-006

The points and contours of an Animated Matte Generator can be edited and animated in the Camera view by 
displaying its controls and manipulating them with the Transform tool.

How to display the Animated Matte Generator controls

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 3. In the Tools toolbar, select the Transform  tool to be able to manipulate the matte controls in the 
Camera view.

TIP 

In the Tool Properties view, you can enable Control Selection Mode  to enable selecting 
several control points in the Camera view by drawing a lasso or marquee around them with 
the Transform tool. This can make animating the control points of the Animated Matte 
Generator easier. 
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Adding Points to an Animated Matte Generator

T-COMP2-002-007

You can add additional points to the ones already generated by the Animated Matte Generator for your source 
drawing. 

NOTE 

If you have already animated the Animated Matte Generator, creating a matte point will also add 
that point to every keyframe. Therefore, you will have to position that point on every keyframe of 
your animation to make sure it looks and moves as expected.

How to add new matte points to an Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 3. In the Tools toolbar, select the Transform  tool.

 4. In the Editing Mode panel of the Animated Matte Generator view, select Add Matte Point .

NOTE 

Contrary to tools like the Contour Editor, you cannot use a keyboard shortcut to click 
and add a point to a matte contour.
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 5. In the Camera view, click on the matte contour where you want the new point to be created.

NOTE 

Adding a matte point to one of the matter's contours will also add a point to the matte's other 
contour. It is not possible to have a different amount of points on a matte's inner and outer 
contours. 
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Removing Points from an Animated Matte Generator

You can remove controls points that you do not intend to use, whether they were automatically generated by 
the Animated Matte Generator or added manually.

NOTE 

If you have already animated the Animated Matte Generator, removing a matte point will remove 
that point on every keyframe, which will affect the shape of the matte throughout the scene.

How to remove matte points from an Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 3. In the Tools toolbar, select the Transform  tool.

 4. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point .

 5. In the Camera view, select the point you want to remove. You can select several points by holding 
Shift while clicking on each point.
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 6. In the Camera view, click on the matte contour where you want the new point to be created.

NOTE 

Removing a matte point from one of the matter's contours will also remove its corresponding 
point to the matte's other contour. It is not possible to have a different amount of points on a 
matte's inner and outer contours. 
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Animating the Contour of an Animated Matte Generator Contour

T-COMP2-002-008

Every control point for an Animated Matte Generator can be animated independently, giving you full control 
on the shape of your drawing or effect throughout the scene. You can animate the contours of an Animated 
Matte Generator by displaying its controls in the Camera view, then manipulating its points using the 
Transform tool.

How to animate the points and contours of an Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 3. In the Tools toolbar, select the Transform  tool.

TIP 

In the Tool Properties view, you can enable Control Selection Mode  to enable 
selecting several control points in the Camera view by drawing a lasso or marquee 
around them with the Transform tool. This can make animating the control points of the 
Animated Matte Generator easier. 

 4. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 5. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point . 

This mode allows you to move and tweak matte points and contours in the Camera view.
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 6. In the Timeline view, move the Timeline cursor to the frame where you want to create the initial 
pose of the Animated Matte Generator. 

 7. Do one of the following:

 l Click and drag a matte point to reposition it.

 l Click and drag a contour to tweak its curve.

 l Select a matte point to display its curve handles.

 l Click and drag one of the curve handles of a matte point to influence the curves on both sides 
of the matte point.

 l While holding Alt, click and drag one of the curve handles to influence the curve only on one 
side of a matte point.
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 l While holding Alt, click on a matte point to remove its curve handles.

 l While holding Alt, click and drag a matte point with no curve handles to create its curve 
handles. 

 8. In the Timeline view, move the cursor to the frame where you want to create your next pose. 

 9. Repeat steps 7 and 8 until the animation for your matte is completed.

Points that have been left in their resting positions appear light blue, and points that have been 
animated will appear dark blue, except when selected. 
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TIP 

In the Animated Matte Generator view, you can enable the Auto Key on All Points  option 
to create keyframes for all matte points every time you manipulate a matte point, or the Fix 
Adjacent Keyframes  option to create the necessary keyframes to avoid overlapping 
animation without creating keyframes on all points. 

TIP 

You can select multiple points in the matte by holding Shift and clicking on each point you 
wish to select. You can also move a single point in a selection of multiple points without 
deselecting other points by holding Ctrl, then clicking and dragging the point you wish to 
move.
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About the Outer & Inner Contours of the Animated Matte Generator
T-COMP2-002-009

An animated matte generator has two separate contours: The inner contour and the outer contour. It 
automatically generates both contours based on the source drawing it is connected to, so both contours start 
out having the exact same shape and position, and their points start out being locked together. Therefore, until 
you separate the points of the outer and inner contours, your Animated Matte Generator will behave as if it 
had a single contour.

You can define the Animated Matte Generator's inner and outer contours separately by disabling one of them, 
then manipulating the points in the other one. Each point that is animated on one of the contours while the 
other one is disabled will become independent from the other contour. 

There are two cases where you need an inner and an outer contour:

 l To create a feathered effect. When the Animated Matte Generator's Output Type is set to Feathered, it 
generates a gradient going from the inner contour to the outer contour, allowing you to create light and 
shadow effects that match very precise shapes. 

 l To create an animation based on both contours. By setting the Animated Matte Generator's Output 
Type to Interpolate Between Contours, you can make your matte drawing morph from the outer 
contour's shape to the inner contour's shape, and vice versa, by animating the Animated Matte 
Generator's Interpolation Factor. 
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TIP 

The Animated Matte Generator keeps track of which points  correspond with each other across the 
inner and outer contours. You can enable the Point Id  option in the  Animated Matte Generator 
view to display the identification number of each matte point in the Camera view. Points from the 
inner contour that match points from the outer contour will have the same identification number.         
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Separating the Outer and Inner Contours of an Animated Matte 
Generator

T-COMP2-002-010

How to separate the inner and outer contours of an Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. In the Tools toolbar, select the Transform  tool.

 3. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

TIP 

In the Tool Properties view, you can enable Control Selection Mode  to enable 
selecting several control points in the Camera view by drawing a lasso or marquee 
around them with the Transform tool. This can make animating the control points of the 
Animated Matte Generator easier. 

 4. In the Animated Matte Generator view, do one of the following:

 l If you want the Outer Contour to be based on the shape and dimensions of your matte 
drawing and the Inner Contour to be smaller, disable the Outer Contour  option and 
enable the Inner Contour  option.

 l If you want the Inner Contour to be based on the shape and dimensions of your matte 
drawing and the Outer Contour to be bigger, enable the Outer Contour  option and 
disable the Inner Contour  option.

The matte points will appear orange instead of blue. This means they represent a single contour 
instead of both contours together. 
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TIP 

You can quickly enable one contour and disable the other one by holding the Alt key 
and clicking on the button of the contour you wish to enable. 

 5. In the Camera view, move the control points that you want to separate to their intended position:

 l If you are editing the inner contour, move each point you want to separate from the outer 
contour towards the centre of the shape so that they are inside the outer contour.

 l If you are editing the outer contour, move each point you want to separate from the inner 
contour away from the centre of the matte so that they wrap around the inner contour.
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NOTE 

You can keep some control points locked together. For example, if you want to create a 
feathered effect that gradates from one side to the other instead of from the centre out, 
you can keep the control points on one of the sides of the matte locked together. 

 6. When you are done separating outer and inner contour points, enable both the Outer Contour  
and Inner Contour  options of the Animated Matte Generator view again so you can animate 
them together.

The points that were separated will appear orange, and will be linked to their corresponding point 
in the other contour by a blue line. If some points are still locked together, they will appear blue. 

TIP 

You can select multiple points in the matte by holding Shift and clicking on each point you 
wish to select. You can also move a single point in a selection of multiple points without 
deselecting other points by holding Ctrl, then clicking and dragging the point you wish to 
move.

NOTE 

If your selection includes both points from the inner and outer contour:                 

 l Clicking and dragging on one of the selected points from the outer contour will only move 
the selected points in the outer contour. 

 l Clicking and dragging on one of the selected points from the inner contour will only move 
the selected points in the inner contour. 

This is so you can easily select points from both contours with the lasso, but only manipulate 
points from one contour at a time. To move all the selected points regardless of which contour 
they are part of, you must do one of the following:

 l Click and drag one of the blue lines connecting an inner contour point and an outer contour 
point that are part of your selection.

 l If your selection includes points that have not been split, click and drag one of those points.
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Scaling the Contours of an Animated Matte Generator

You can use the scaling control of the Animated Matte Generator to quickly scale the control points of your 
matte contours. This is especially useful for quickly separating the outer contour and the inner contours. 

How to use the scaling controls of the Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. In the Tools toolbar, select the Transform  tool.

 3. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 4. In the Matte Visibility panel of the Animated Matte Generator view, do one of the following:

 l If you don't want to separate the inner and outer matte contours, or if they are already 
separated, enable both the Outer Contour  and Inner Contour  options.

 l If you want to shrink the inner contour only, disable the Outer Contour  option and enable 
the Inner Contour  option.

 l If you want to shrink the inner contour only, enable the Outer Contour  option and disable 
the Inner Contour  option.

TIP 

You can quickly enable one contour and disable the other one by holding the Alt key 
and clicking on the button of the contour you wish to enable. 

 5. In the Editing Mode panel of the Animated Matte Generator view, enable the Scaling Controls  
option.

Scaling controls appear over the enabled matte contours. If both matte contours are enabled, a blue 
scaling control appear in-between the outer and inner contours which can be used to scale both 
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contours simultaneously.

 6. If you want to scale the matte points from a specific pivot point, click and drag the purple square in 
the middle of the scaling control to position the scaling pivot.

 7. Do one of the following:

 l If you want to scale both the outer and inner contours together, click and drag any control 
point of the blue scaling box.

 l If you want to scale the outer contour only, click and drag any control point of the red scaling 
box.

 l If you want to scale the inner contour only, click and drag any control point of the green 
scaling box.

372



Merging Outer & Inner Contours for an Animated Matte Generator

If you have separated the matte points of the outer and inner contours of an Animate Matte Generator, you can 
lock them back together so that they behave as single matte points again.

How to merge outer and inner contour points

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. In the Tools toolbar, select the Transform  tool.

 3. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 4. In the Editing Mode panel of the Animated Matte Generator view, click on Define Matte Point .

 5. In the Camera view, select the contour point you want to merge with its corresponding point in the 
other contour. If you want to merge several contour points with their corresponding contour points, 
hold shift and click on each point to select them together.

NOTE 

You do not need to select the point in both the outer and inner contours. Simply 
selecting the point from one of the two contours is enough to merge it with the 
corresponding point in the other contour. 

 6. In the Animated Matte Generator toolbar, click on Merge Inner and Outer Matte Contours .

The selected matte points and their corresponding matte points are moved to the same position, 
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halfway between their respective positions, and are locked together again.

TIP 

You can also lock a contour point back to its corresponding point by clicking and dragging it 
very close to its corresponding point. When close enough, it will snap to that point and appear 
blue. Releasing it in this state will lock the corresponding contour points together. 
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Animating Interpolated Contours with the Animated Matte Generator

T-COMP2-002-011

The Animated Matte Generator can output an image that is an interpolation (in-between) of its outer contour 
and its inner contour. How close to the outer or inner contour this image is is based on its Interpolation Factor 
parameter, which can be animated. Hence, you can animate the Animated Matte Generator to morph from the 
outer contour to the inner contour, and vice versa.

How to interpolate between contours with the Animated Matte Generator

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. In the Tool Properties view, set the Output Type to Interpolate Between Contours.

 3. In the Tools toolbar, select the Transform  tool.

 4. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 5. In the Matte Visibility Settings panel of the Animated Matte Generator view, enable the Outer 
Contour  and disable the Inner Contour .

 6. In the Camera view, adjust the matte  points until you obtain the expected shape for the first 
contour.
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 7. In the Matte Visibility Settings panel of the Animated Matte Generator view, disable the Outer 
Contour  and enable the Inner Contour .

 8. In the Camera view, adjust the matte points until you obtain the expected shape for the second 
contour.

 9. In the Matte tab of Layer Properties view, click on the Create Bezier  button of the 
Interpolation Factor property.

 10. If the Parameters column is not enabled in the Timeline view, click on the Show Parameters  
button in the bottom-left corner of the Timeline view to display it.

 11. In the Timeline view, locate the Animated Matte Generator layer and click on the Expand 
Parameters  button on its right to list its parameters. 
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The Interpolation Factor parameter will appear in the list of parameters, second to the 
Snapping Source parameter.

 12. Move the Timeline cursor to the frame where you want to start animating the matte. 

 13. In the Parameters column of the Timeline view, right of the Interpolation Factor parameter, set 
the desired value for the interpolation factor at the current frame:         

 l An interpolation factor closer to 0 will generate a drawing that looks closer to the outer 
matte of the animated matte generator. 

 l An interpolation factor closer to 100 will generate a drawing that looks closer to the 
inner matte of the animated matte generator.

 l An interpolation factor set to 50 will generate a drawing that is an in-between of the 
outer and inner contours.

 14. Move the Timeline cursor to the frame where you want to create your interpolation pose.

 15. In the Parameters column of the Timeline view, set the desired value for the Interpolation 
Factor parameter at the current frame. 

 16. Repeat steps 14 and 15 until you've completed your interpolated contour animation.
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About the Feathered Effect of the Animated Matte Generator
One of the most important capabilities of the Animated Matte Generator is to create a feathered effect. This 
effect is generated by filling the inner contour of the matte with a solid colour, and the outer contour with a 
gradient going from the inner contour colour to its outer contour colour. This gradient is made to fit the shape of 
both the inner and the outer contours, allowing you to generate glows, shadows and light effects with specific 
shapes. 

To create a feathered effect, the Output Type parameter of the Animated Matte Generator must be set to 
Feathered. When this option is use, the Animated Matte Generator ignores the colours in the source drawing 
and only uses the shape of the inner and outer contours. The inner and outer colours of the feathered effect, as 
well as the way they are interpolated, can be set in the Advanced tab of the Animated Matte Generator's 
Layer Properties.
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Creating a Feathered Effect with the Animated Matte Generator

T-COMP2-002-012

How to create a feathered effect with the Animated Matte Generator

 1. Make sure the source drawing connected to the Animated Matte Generator closely matches the 
outer shape of the intended effect, but that it is simple, does not have too many vector points and is 
only painted in a single colour. 

 2. In the Node or Timeline view, select the Animated Matte Generator node.

 3. In the Tool Properties view, set the Output Type to Feathered.

 4. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 5. In the Camera view, click on Render View to see what the feathered effect will look like when 
rendered as you configure and animate it.

 6. In the Tools toolbar, select the Transform  tool.

 7. In the Animated Matte Generator view, do one of the following:

 l If you want the Outer Contour to be based on the shape and dimensions of your matte 
drawing and the Inner Contour to be smaller, disable the Outer Contour  option and 
enable the Inner Contour  option.

 l If you want the Inner Contour to be based on the shape and dimensions of your matte 
drawing and the Outer Contour to be bigger, enable the Outer Contour  option and 
disable the Inner Contour  option.

 8. In the Animated Matte Generator view, enable the Define Matte Point  option.
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 9. In the Camera view, move the control points that you want to separate to their intended position. 
For example, if you are editing the outer contour, you would want its control points to wrap around 
the inner contour. If you are editing the inner contour, you would want its control points to be inside 
the outer contour.

TIP 

If you want to quickly scale up the outer contour or scale down the inner contour, you 
can enable the Scaling Controls  option in the Animated Matte Generator view to 
scale all the points of the matte contours simultaneously.

 10. In the Layer Properties view, select the Advanced tab.

 11. In the Interpolation Mode drop-down, select one of the following options:

 l Distance: Generates a linear gradient going from the inner contour to the outer contour.

 l Parametric: Generates a linear gradient going from each side of the inner contour to the 
corresponding side of the outer contour. This mode is different from the Distance 
interpolation mode by how it makes the gradients track the matching sides of the inner and 
outer contours.
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 l Dot: Generates a gradient going from the inner contour to the outer contour, but based on a 
power function that creates the illusion of a thinner, harder outline.

 l None: The outer and the inner contour are solid shapes, filled with their respective colours.

 12. In the Colour Interpolation dropdown, select one of the following options:

 l Constant: Generates a gradient based on the inner colour, gradating in transparency only. 
The inner contour will have the opacity of the inner colour, and will gradate towards full 
transparency towards the outer contour. 
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 l Linear 2 Colours: Creates a gradient that steadily gradates from the inner colour to the outer 
colour.

 l Gamma 2 Colours: Creates a gradient that gradates from the inner colour to the outer colour 
on a Gamma curve, the power of which can be set in the Colour Gamma field. For more 
information, see the Colour Gamma field section below. 

 13. If you set the Colour Interpolation parameter to Gamma 2 Colours, adjust the Colour Gamma 
parameter until you obtain the desired effect. When the Colour Gamma is set to any value between 
0 and 1, the gradient will ease in from the inner colour to the outer colour. When it is set to any 
value above 1, the gradient will ease out from the inner colour to the outer colour. 

 14. Set the Inner Colour to the colour that should fill the inner contour of the matte.
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 15. Set the Outer Colour to the colour that the Inner Colour should gradate to in the outer contour. 

NOTE 

If the Colour Interpolation mode is set to Constant, this option will be disabled and the 
colour will simply gradate to full transparency. 

 16. In the Alpha Interpolation dropdown, select one of the following options:

 l Linear: Steadily gradates from the inner contour's alpha to the outer contour's aplha.

 l Gamma: Calculates the alpha going from the inner contour to the outer contour based on a 
Gamma curve, the power of which can be set in the Alpha Gamma field. For more 
information, see the Alpha Gamma field section below. 

 17. If you set the Alpha Interpolation parameter to Gamma, adjust the Alpha Gamma parameter until 
you obtain the desired effect. When the Alpha Gamma is set to any value between 0 and 1, the 
alpha values will ease in from the alpha value of the inner colour to the alpha value of the outer 
colour. When it is set to any value above 1, the alpha values will ease out from the alpha value of 
the inner colour to the alpha value of the outer colour. 
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About Snapping with the Animated Matte Generator
You can make some of the points and contours of the animated matte snap to the contours of a drawing in your 
scene. This is especially useful if you want to use the Animated Matte Generator to create highlights or 
shadows and you need the effect's outlines to match a drawing's outlines. 
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Connecting a Snapping Source Drawing to an Animated Matte 
Generator

T-COMP2-002-013

In order to make the contours of an Animated Matte Generator to a drawing in your scene, you must first 
connect that drawing to the Animated Matte Generator node through its Snapping Source (left) port.

NOTE 

The Snapping Source drawing of an Animated Matte Generator must be a single vector drawing 
node. Snapping will not work with any other type of node. 

How to connect the Animated Matte Generator to a snapping source drawing

 1. In the Node view, create a connection going from the output port of the snapping source drawing 
node to the Snapping Source (left) input port of the Animated Matte Generator node. 

 2. Create a connection going from the output port of the snapping source drawing node to the input 
port of the source drawing node. This will ensure that if the snapping source is moved or animated, 
the matte will follow the movement of the snapping source.

385

Harmony 21 Premium User Guide                          



Chapter 18: Effects

Making Matte Contours Snap to a Drawing

T-COMP2-002-013A

In order for matte points and contours to snap to the contours of the snapping source drawing, you must use 
the Set to Snap mode of the Animated Matte Generator view to select which points and which contours of the 
matte should snap.

How to make an Animated Matte Generator snap to the contours of the snapping 
source drawing

 1. In the Node or Timeline view, select the Animated Matte Generator node.

 2. Display the controls of the Animated Matte Generator node by doing one of the following:

 l In the Camera view toolbar, click on Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

The control points for the Animated Matte Generator display in the Camera view.

 3. In the Tools toolbar, select the Transform  tool.

 4. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point .

 5. Adjust the contours of the matte so that they are close to the contours of the snapping source 
drawing. Contours and points will only snap if they are at a short distance from the contours of the 
snapping source drawing. 

 6. In the Editing Mode panel of the Animated Matte Generator view, select Set to Snap .

Switches to enable or disable snapping appear over each of the matte's contours and points in the 
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Camera view. 

 7. In the Camera view, do one of the following:

 l To enable or disable snapping on a matte point, click on its control point.

 l To enable or disable snapping on a matte contour, click on the snapping switch for that 
contour. 

Points that are set to snap will appear green instead of purple. Contours that are set to snap will 
have a magnet icon on their snapping switch.

 8. If a point or contour does not snap to the contour of the snapping source drawing, adjust the 
position and curves of the matte so that they are closer to the contour of the snapping source 
drawing.

TIP 

You can adjust the maximum distance from which a matte point or contour will snap to the 
drawing source, whether the matte should snap to all contours or only the outlines of the 
snapping source as well as which one of the snapping source's art layers the matte snaps to in 
the layer properties of the Animated Matte Generator.
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About Particles
Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, grass or 
fire to more complex systems, such as swarms of animated insects-- all in a fraction of the time it would usually 
take.

Particle effects act in the same way as all other effects in Harmony, except they always work within their own 
specifically structured system. You can attach a Blur effect node under a Drawing node and the image 
contained in the Drawing node will become blurry. Particle effect set-ups are more complex than simply 
adding a node and playing with its parameters. To keep things simple, just think of each Particle effect as its 
own group.
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About the Particle System Structure
This is what the basic structure of a particle system looks like in the Node view. This structure can change 
depending on the type of effect you are trying to create. 

NOTE 

To learn more about each particle node, see the Reference guide .

Colour Coding

Particle effects are colour coded to make them easy to identify by colour and function. Each colour represents a 
different function. For example, Action nodes, such as Velocity, Move-Particles and the Sprite Emitter are 
purple. 

You’ll also notice that the ports above and below each node are colour-coded. These indicate the kind of node 
these ports should be connected to. For example, the output (bottom) port of an Action node is dark blue, 
which is the colour of the Particle-System-Composite node, to which Action nodes must be connected. 

Otherwise, some particle nodes have standard green and blue ports, which must be connected to standard 
peg and image ports respectively. This can help you easily structure your particle system as you add 
components to it.

Node Types

The types of nodes that are part of a particle system are as follows:   

 l Region: These nodes are used to define the region from where the particles are emitted. These regions 
can be Planar or 3D.

 l Region Composite: This node combines Region nodes. In case you have more than one region in your 
effect, this composite will help define the position and the render order of the different regions.
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 l Action: These nodes define the particle dynamics. They determine how particles are created and moved 
around in space. If there are multiple Action nodes hooked to a composite, they are executed from right 
to left. Hence, it is typical of a particle system to have an Emitter node in its right-most port, as this 
node creates the particles before they are affected by other actions. 

 l System Composite: Unlike a regular composite that reads all the position information from its in-port 
nodes and combines them accordingly, a System Composite is specifically designed to handle Action 
node information.

 l Baker: These nodes allow you to make decisions about the way the particles are created and processed. 

 l Visualizer: This node assembles a particle system through its middle port and renders it as a flat image 
that can be composited onto your scene. It also allows you to offset and animate the generated image. 
The left input port allows you to connect it to a peg that will offset, scale and rotate the rendered image. 
The right input port allows you to connect it to a peg that will determine the position of the rendered 
image on the z-axis, without affecting its apparent size. 
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Accessing Default Particle Templates
Harmony comes with particle templates, which are node systems that you can insert into your scene and which 
are already configured to generate some kind of particles. You can then modify these node systems to generate 
the particles you want, such as by changing the effect’s sprite with your own artwork, and then tweaking its 
parameters to generate particles the way you want them to. 

There are two barebone particle systems, Basic Particle System and Basic Gravity Based System, which 
generate white dots. 

 l Basic Particle System: This effect template has the simplest structure and the parameters for all of its 
nodes are set to the default values. For example, the Planar-Region has not been rotated or resized, the 
particles have not been randomized in the Sprite-Emitter, and the particles start their generation on 
the first frame and die out at the maximum number allotted in the Particle-Baker.    

 l Basic Gravity Based System: This effect template simulates particles being generated from a source 
with special emphasis on adding gravity to the particle system.

There are also more elaborate pre-build examples:

 l Animated Grass: Simulates a patch of grass that is swaying in the wind. Uses an animated drawing 
layer as a sprite.

 l Bees: Simulates a crowd of bees flying around. Uses an animated drawing layer as a sprite. Animate the 
position of the bees using the Peg layer.

 l Bouncing Balls: Simulates the randomness of a set of bouncing tennis balls. 

 l Bubble Vortex: Simulates a swarm of insects emerging from a single origin point (such as the opening of 
a hive) and forming a tornado-shaped, tubular vortex.

 l Confetti: Simulates confetti being thrown upward and falling back to the ground.

 l Fairies: A fun example of how you can have a particle (the Fairy) which generates particles (the Fairy 
Dust).

 l Fairy: An example of how you can create a trail of Fairy Dust following an animated drawing layer.

 l Fire - Simulates a camp fire.

 l Fire_Particles - Simulates a large fire filing the entire screen width. 

 l Grass: Simulates a static patch of grass at a fully grown state.  

 l Horizontal Speed Lines: Simulates horizontal speed lines that will radiate in one direction from a central 
point. 

 l Leaves: Simulates autumn leaves falling in the wind.  

 l Lemmings: Simulates the classic game Lemmings. Uses an animated drawing layer as a sprite. This is 
also a good example to use to learn how to use Bounce Planes, as the particles will fall until they hit a 
bounce plane.

391

Harmony 21 Premium User Guide                          



Chapter 18: Effects

 l Looping Dust: Simulates a cloud of dust twirling in the wind. 

 l Rain: Simulates a fairly turbulent rainfall with 3 different coloured raindrops.  

 l Rain 2: Simulates rain water splashes as drops hit the ground

 l Rain3: Simulates a fine rain falling vertically. 

 l Snow Windy: Simulates snowflakes falling in the wind. 

 l Sparkly 2 Colours: Simulates magical sparkles.

 l Speed Lines: Simulates radial Speed Lines that will radiate outwards from a central point. 

 l Spay Wand: Simulates a wan spraying magical sparkles at a target. 

 l Toon Fire: Simulates a more cartoony camp fire. 

 l Trail Particles: Simulates a trail of sparkle following a given path. 

 l Twinkle Particles: Simulates a shower of twinkling particles.

How to insert particle templates into a scene:

 1. Do one of the following:

 l To quickly insert a basic template, in the top menu, select Insert > Particle and then select 
either Basic Particle System or Basic Gravity Based System.

 l In the Node Library view, select the Particle category, then the Examples sub-category, 
then drag and drop any one of the templates into the Node View. 

 l In the Node View, right-click and, in the context menu, select Insert > Particle > Examples 
and select any of the examples to insert it into the Node View. 

The particles template is added to your scene. Connect the output port of its Particle-Visualizer 
node to your scene’s composite to make it visible. Then, you can start experimenting with the 
parameters of each node to make your own particle effect. 

NOTE 

To learn more about each particle node, see the Reference guide .
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About Light Shading in Harmony

Cut-out animation allows for great advancements and time saving in production, but it has certain limitations. 
One of the main advantages of using a cut-out puppet is the ability to reuse your characters without having to 
redraw them and you can modify your animations very quickly. This speeds up the process quite a bit. One of 
the disadvantages of cut-out animation when wanting to retain the time saving factor and ability to quickly 
modify an animation, is the fact that you cannot easily create tones and highlights. To do so, you must draw all 
the highlight zones for each frame by hand. Following that, if you want to modify your animation, you have to 
redraw those zones. This slows down the process. There are a few tricks for doing simple automated 
highlights, but the results are not always convincing.

The Harmony Light Shading effect provides a proper solution to this issue. It allows you to add a few nodes to 
your original puppet rig and obtain a customizable lighting effect on your characters. It can be applied to any 
object in your scene, not only on cut-out characters. The light shading effect allows you to define your volume 
zones as well as your light source and animate its position. 

In Harmony, all drawings are flat 2D planes, unless you imported 3D elements. A light source cannot interact 
well with a flat shape to create tone and highlight areas within it. To create shading zones, Harmony uses the 
bevel principle to create a three-dimensional shape illusion. To do that, you must define which object or 
combination of objects should be defined as a volume. Next, you can carve and emboss areas  using colour zones 
within the volumes to create what is referred to as 3D geometry.
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If you have a scene with one single drawing layer, you will define that layer as your volume object, since there 
are no other elements in the scene. The light shading effect will emboss the contour of the shape, but if you 
want to have highlight and tone zones within the drawing, you will need to carve and emboss areas using 
specific colour zones.

If you have a cut-out character composed of several drawing layers, you will need to identify the different 
layers or group of layers you want to define as volume objects. For example, you could group the arm, forearm 
and hand layers as one object, while the head could be another volume. Depending on your design, you will 
have to analyze and decide what should be grouped. You can then use colours to carve areas within those 
volumes.
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The beauty of the light shading effect is that you only have to set it up once. You can animate the light source 
position, shading style, as well as colour and your volume objects, carving and adding areas will be accurately 
used. There's no need to redraw another set of zones depending on the light source or even draw tones for any 
animation frames. This only needs to be done once in the character rig. The compositing artist will then have 
the freedom to play around with the light positioning and ambiances.

Harmony provides you with a series of nodes and parameters allowing you to shape, carve and model your 
image's 3D geometry as you like. Each volume object has an ID number. You can have several volumes using 
the same ID so they can receive the same shading, smoothing and bevelling parameters. If you want to treat 
each area individually, you can assign them different ID numbers.

You also have the possibility to create tones, not only highlights. You can also combine both on the same 
image. Both tones and highlights react to the same carving colours, modelling parameters, and set volume 
objects.
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About Light Shading Nodes
You can build your light shading effect using these five nodes:

 l Volume Object  on page 397

 l Normal Map on page 397

 l Light Position  on page 398

 l Light Shader  on page 399

 l Tone Shader  on page 399

To learn more about each node's parameters, see the Reference guide .

Volume Object 

The Volume Object node allows you to define which parts of your rig constitute a single volume to which 
shading should be applied. For example, if you need the arm, forearm and hand of your character to be shaded 
together, you can connected all the nodes that constitute these body parts to the same Volume Object node, 
and the shading will be applied to these parts of your rig as if they were a single object.

NOTES 

 l Even if you want to apply shading separately to a single drawing, you must connect a Volume 
Object node under that drawing.

 l If you create separate Volume Object nodes for parts of your rig that are attached together, you 
may see bumps in the shading where the joints overlap. 

Normal Map

The Normal Map node lets you centralize all Volume Object nodes and chisel out the shading 3D geometry 
(bevel height, smoothing, carving, etc.). It could be described as carving a bas relief. You only need one Normal 
Map node per light shading effect and, in general, only one per scene.
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A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to 
a format supported by your plugin. The Normal Map Converter node has been optimized to work with 
GenArts® plugins, but you also have the ability to use it on custom plugins..

Light Position 

The Light Position node is the actual light source interacting with all the defined volume objects. You can set its 
position in relation to the objects and animate it over time. All volumes will react according to the light's 
motion.

This is not where you set the light type or colour. You'll be adjusting these in the Light Shader and Tone 
Shader nodes.
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Light Shader 

The Light Shader node lets you adjust the highlight parameters, such as the colour, to create the desired 
ambiance. You can animate most parameters over time to create a mood change, sunset or any other type of 
light transition. The beveling height and smoothing is set in the Normal Map node.

Tone Shader 

The Tone Shader node lets you adjust the tone parameters, such as the colour, to create the desired ambiance. 
You can animate most parameters over time to create shade transitions. The beveling height and smoothing is 
set in the Normal Map node.
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Light Shading Setup
The first step in setting up your light shading effect is to identify which volumes you want the light to interact 
with. 

To learn more about each node's parameters, see the Reference guide .

Here's what a basic light shading effect node structure looks like:

How to set up a basic light shading effect

 1. In the Node Library view, select a Volume Object node from the Shading category and drag it to 
the Node view.

 2. In the Node view, connect the Volume Object node between the drawing node and the Composite 
node. Click on the node's properties button (yellow square) and rename it with the volume it 
represents. This will make it much easier to edit the beveling in the Normal Map node later on.
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If you need to combine several elements into one volume, you can connect the elements into a 
Composite node set to Pass-Through and connect that Composite node to the Volume Object node.

 3. In the Node Library view, in the Shading category, select a Normal Map node and drag it to the 
Node view.

 4. In the Node view, connect a second connection from the Volume Object node to the Normal Map 
node. Don't connect the Normal Map's output port yet.
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 5. In the Node Library view, in the Shading category, select a Light Shader or Tone Shader node and 
drag it to the Node view.

 6. In the Node view, connect the Normal Map output node to the shader node's middle input port.

 7. From the Volume Object node, pull out a third connection and connect it to the shader node's right 
input port.
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 8. In the Node Library view, in the Shading category, select a Light Position node and drag it to the 
Node view.

 9. In the Node view, connect the Light Position output node to the shader node's left input port 
(green).
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 10. Connect the shader's output port to the Composite node to the left (in front) of the Volume Object's 
Composite connection. This will display the light shading effect on top of the original drawing. 
Connecting it to the right would result to nothing as the effect would be hidden behind the 
drawing.

 11. If you added colours to your drzwing to carve in some areas, in the Node Library view, select a 
Colour-Override node and drag it to the Node view.

 12. In the Node view, connect the Colour-Override node between the Volume Object and the 
Composite nodes. Make sure the Volume Object node is connected to the Colour-Override's right 
input port.
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 13. Click the Colour-Override node's properties button (yellow square) to open the Layer Parameters 
dialog. From the Colours section, drag your carving colours to the Individual Colour Overrides 
section. In the Mode column, set all your colours to Colour not visible.

 14. To combine both the Tone Shader and the Light Shader, from the Node Library bring the other 
shader node and drag it to the Node view.
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 15. In the Node view, connect the same Light Position, Normal Map and Volume Object nodes to the 
new shader node.

 16. Click the Normal Map node's properties button (yellow square) to open the Layer Parameters 
dialog.

 17. In the Volume Creation section, from the Object List , select all the Volume Object nodes you want 
to use in this map.

‣ It's possible to add all Volume Object nodes at the same time by selecting the Add all Defined 
Objects option or it's possible to add each Volume Object node one by one.

 18. In the Camera view, enable the Render mode to view the final effect.
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 19. See the Reference guide  to adjust the light shading parameters.
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Adding and Carving Volumes
Once your basic volumes are set up, you can use colours from your colour palettes to carve or add zones. 
Depending on the design of the drawing, you may want to use the same palette as the character, background 
or object, or you may want to use a specific palette reserved specifically for this purpose.

To learn more about each node's parameters, see the Reference guide .

How to add and carve volumes

 1. Add colour swatches in your character's colour palette or in a new palette solely reserved for 
carving. Name them Carving and Adding. By choosing different colours, it will be easier to 
differentiate where those colours will carve or add.

 2. In the Camera or Drawing view, draw the areas you want to carve out and add. It's recommended to 
draw them in the Underlay or Colour Art layer.

 3. In the Node view, click the Normal Map's properties button (yellow square) to open the Layer 
Properties window.
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 4. In the Override Modelling by Colour section, click Add Colour and select the palette containing 
your carving and adding colours.

 5. Add your Carving and Add colour swatches.

 6. Increase or decrease the Carving - Adding value by adjusting the slider to carve or emboss your 
volumes using the colour zones.

 7. In the Camera view, enable the Render mode to view the final effect.
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Animating the Light Source and Target
You can set up the light source and animate it.

How to display the controls of the Light Position node

 1. In the Node view, select the Light Position node.

 2. Do one of the following:

‣ In the Camera View toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (macOS).

A yellow camera appears in the scene, representing the light source.
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How to animate the light source and the target

 1. In the Tools toolbar, select the Transform  tool and animate the light source or target.

 2. Before moving the light source for the first time, you must move the light to make it visible. At the 
moment, the target is not visible because it is hidden behind the light source.

A red line appears, starting at the light source. This line represents the direction of the light. The 
green dot at the end of the line represents the target. Depending on the setting of your Light 
Shader or Tone Shader node, the direction or target may be more useful.
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About Surface Shading
The Surface Shading set of nodes is an advanced version of the original Light Shading set of nodes. It provides 
the ability to perform more advanced lighting effects in Harmony, such as cast shadows and ambient occlusion.

The legacy Volume Object and Normal Map nodes in Harmony work by adding bevel to the drawings that 
constitute the rig. This creates an overall rounded volume with lighting that would normally be difficult to 
obtain with flat drawings. However, this approach is often limited to simpler rounded shapes and simple 
surfaces.

The Surface Shading set of nodes allows you to create more specific shapes, as well as to define the height of 
the bevel across the shapes. By using the original beveled surface, as well as specifically defined surfaces and 
animateable height maps, you are able to create a Surface Map that is more reactive to the light in your 
environment. 

While the drawings that constitute the rig remain flat, the Volume Object and Surface Map nodes allow you to 
provide an extra layer of information to the accompanying nodes to help define the surface of the drawings. 
The surfaces can still be added and carved, but can also be overlapped and placed in relation to one-another 
in a height map, allowing to generate advanced light effects such as cast shadows and ambient occlusion.

Harmony provides you with a series of nodes allowing you to bevel, shape, carve and model your image's 
height map as you like. Each volume object has an ID number and several volumes can share the same ID. 
Height maps can be added to specifically define a volume, shapes can be modeled for animated surface 
definition and joints can be blended with the height mattes. This all comes together in a system that allows 
you to dynamically relight a character in a scene for a rich volumetric appearance.
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NOTE 

For more information on the Light Shading effect, which is the legacy version of the Surface 
Shading effect, see About Light Shading in Harmony on page 393.
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Surface Shading
Unlike the Light Shading effect, the Surface Shading effect uses the field units of the scene for its parameters. 
This allows the system to light drawings and cast shadows relative to their positions in the scene and in 
relation to the surrounding drawings. Although it requires some extra configuration, this system allows for 
more customization, such as rounded surfaces, custom height-maps, and cast shadows.

The Surface Shading effects blends the different light and shadow effects in your rig. A flat-character rig is 
created with the same Volume Object nodes as the Light Shading nodes to define the relative heights and 
surface modeling.

NOTE 

By default, Volume Objects are ignored in a scene until they are rendered with a Normal Map or 
Surface Map. The Normal Map and Surface Map will convert these Volume Objects into relevant 
surface data used for lighting the scene.

The Surface Shading nodes include:

 l Volume Object on page 415

 l Surface Map on page 415

 l Surface Normal on page 416

 l Cast Shadow on page 417

 l Ambient Occlusion on page 418

 l Height Shape Nodes on page 419

 l Light & Tone Shaders on page 420
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Volume Object

The Volume Object node allows you to define which parts of your rig constitute a single volume to which 
shading should be applied. For example, if you need the arm, forearm and hand of your character to be shaded 
together, you can connected all the nodes that constitute these body parts to the same Volume Object node, 
and the shading will be applied to these parts of your rig as if they were a single object.

NOTES 

 l Even if you want to apply shading separately to a single drawing, you must connect a Volume 
Object node under that drawing.

 l If you create separate Volume Object nodes for parts of your rig that are attached together, you 
may see bumps in the shading where the joints overlap. 

Surface Map

The Surface Map behaves similarly to the Normal Map, but instead of defining the surface orientation, it is used 
to define the overall surface height and modeling in the scene. This node accumulates all drawings, Volume 
Objects, height maps and height mattes attached to the Pass-Through composites above. These individual 
layers are combined into a single Surface Mapping which is then used as a guide for further Light and Shading 
nodes.
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NOTE 

The surface map appears similar to a normal map, but it behaves differently. The red, green and 
blue channels represent the X, Y and Z coordinates of their respective pixel in the scene. Hence, 
isolating the blue channel in the surface map is useful for previewing the height of each pixel. 

The Surface Map uses a lot of the same parameters as the Normal Map, but also requires that you set the 
height ranges of each volume object relative to each other. By doing this, a surface is constructed that can be 
used to cast shadows relative to each other.

Surface Normal

The Surface Normal node converts the output of the Surface Map into a normal image similar to the output of 
the original Normal Map. Once converted, this output is compatible with the original Light and Tone Shader 
and allows these nodes to use new surface shading options.
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Cast Shadow

The Cast Shadow node samples the Surface Map and calculates the shadow that each surface should receive 
based on that surface’s elevation, the surrounding elevations and the current position of the Light Position 
node. A shadow is rendered when a surface does not receive any light due to a surface blocking the path of the 
light source.

NOTE 

All of the Surface Shading nodes work in the same field-units as the drawings in the scene and 
require that the light be placed in front of the drawing and their defined height in the Z-axis.
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Ambient Occlusion

The ambient occlusion node creates a shadow that helps to emphasize the depth and roundness of a 
character. This node shades the areas on a surface that would be difficult for any ambient light to reach—areas 
with deep holes, crevices or overlapping surfaces. The darkness of this shadow is relative to the difference in 
depth between a given pixel and the surrounding pixels within a range. This shadow does not use any light 
position, but instead behaves as an ambient shadow in the scene.
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NOTE 

The Ambient Occlusion Node can be used to add volume to a flat character, even without a direct 
light source.

Height Shape Nodes

The addition of the Height Map port on the Volume Object node allows for the customization of any surface 
defined in the Surface Map. The Height Shape series of nodes provides a way to create an animatable height 
that works well with the Volume Object -- this can be used to create custom surfaces and animated heights 
over the course of a scene.
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NOTE 

The Shape Curves and Shape Lines nodes can be used together in the same rig. This allows you to 
create a height map with both edges and curves that best fit the drawing’s surface.

Light & Tone Shaders

The Light Shader and Tone Shader use the surface and depth information provided by the Surface Normal 
node to generate diffuse light, specular highlight and light fall-off. 

NOTE 

Only the Surface Map node is able to provide the Height Map and Height Matte definition to the 
Light and Tone Shaders. This information is not available when using the original Normal Map 
node.
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How to Rig with Surface Shading
The first step in Surface Shading is to identify the surfaces that will need lighting, shading or cast-shadows. 
Volume Objects can be used to join multiple drawings into a single surface, or separated into different Volume 
Object IDs and blended with the Height Matte. The Volume Objects for a rig can be created at either the 
rigging or compositing stage—but it is important that these Volume Objects accurately represent a surface in 
relation to the rest of surfaces in the rig.

The Surface Map node combines all the Volume Objects in your rig and allows you to a add a height to each 
volume definition. This allows you to define each surface’s range in relation to the others in the rig. These 
surfaces can be animated within the surface mapping, joints can be masked and height maps can be used to 
further define and animate the surface. All surface depths are in the same units as the field used by pegs in the 
scene—this provides a consistent relationship between the surface heights and the pegs and drawings in the 
scene.

The Surface Shading nodes render in relation to the overall surface defined by the Surface Map. Volume Object 
nodes are used to define individual surface layers and the Surface Map node accumulates these into a single 
elevation-map facing towards the camera. When a light is placed in the scene, surfaces that are in front of 
others will receive more light and will occlude the surfaces that are further away.

Here's what a basic surface shading effect node structure looks like:

NOTE 

A Surface Shading node system is very similar to a legacy Light Shading node system, except that 
it provides more surface definition and effect options.
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How to Set Up a Basic Surface Shading Rig

 1. In the Node Library view, select a Volume Object node from the Shading category and drag it to 
the Node view.

 2. In the Node view, do one of the following:

 l If you want to create a Volume Object for a single drawing, connect the Volume Object node 
between the drawing node and the Composite node.

 l If you need to combine several elements into one volume object, connect each of these 
elements to a Pass Through composite, then connect that Composite node to the Volume 
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Object node.

TIPS 

 l To create a Pass Through composite, drag a Composite node from the Combine 
section of the Node Library into the Node view, then click on its  Layer Properties 
button and, in the Layer Properties dialog, set the Mode parameter to Pass 
Through.

 l If you are working with a complex character rig, your rig will contain many Volume 
Object nodes representing different part of the rig. You should name each Volume 
Object node so that it identifies which part of the rig the object represents. To 
rename the node, click on its  Layer Properties button and type its new name in 
the Name field.

 3. In the Node Library view, in the Shading category, select a Surface Map node and drag it to the 
Node view. Then, connect the output port of the Volume Object node to the input port of the 
Surface Map node.
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 4. In the Node Library view, in the Shading category, select a Surface Normal node and drag it to the 
Node view. Then, connect the output port of the Surface Map node to the input port of the Surface 
Normal node. This will convert the map provided by the Surface Map node into a normal map, 
which the Light Shader and Tone Shader nodes can use to generate their effects.
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NOTE 

The Surface Map node provides the surface information of your combined Volume 
Object nodes in field units. The Ambient Occlusion and Cast Shadow nodes can be 
attached directly to this node as they only require the height of the surfaces to 
generate their effect. 

However, in order for the Light Shader and Tone Shader nodes to be able to work with 
the Surface Map node, a Surface Normal node needs to be attached between them. The 
Surface Normal node converts the surface information from field units to directional 
normals, which is required by the Light Shader and Tone Shader nodes to generate 
their effects. 

 5. In the Node Library view, in the Shading category, select a Light Shader node and drag it to the 
Node view. Then, connect the output port of the Surface Normal node to the middle input port of 
the Light Shader node.

 6. Create a new connection from the output port of the Volume Object node to the rightmost input 
port of the Light Shader node.
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 7. In the Node Library view, in the Shading category, select a Light Position node and drag it to the 
Node view. Then, connect the output port of the Light-Position node to the leftmost (green) input 
port of the Light-Shader node.

 8. Connect the output port of the Light Shader node to the scene composite, left of the port 
connecting the Composite node to the Volume Object node. This will ensure that the light shading 
effect is composited on top of the artwork.
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 9. In the Node Library view, in the Shading category, select a Tone Shader node and drag it to the 
Node view. Then, connect it to the Volume Object node, the Surface Normal node and the Light 
Position node in the same way you did with the Light Shading node.

 10. In the Node Library view, in the Shading category, select a Cast Shadow node and drag it to the 
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Node view. Then, connect the output port of the Surface Map node to the middle input port of the 
Cast Shadow node. 

 11. Create a new connection from the output port of the Volume Object node to the rightmost input 
port of the Cast Shadow node. 
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 12. Create a new connection from the output port of the Light Position node to the leftmost input port 
of the Cast Shadow node.
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NOTE 

The Light Position node is used to define the position of the light source in the scene. In 
this example, the Light Shader, Tone Shader and Cast Shadow all use the same light 
source. However, it is also possible to connect different Light Position nodes to each of 
these nodes to create a more complex lighting effect that uses different light sources. 

 13. Connect the output port of the Cast Shadow node to the scene composite, just left of port 
connecting the Composite node to the Volume Object node.

 14. In the Node Library view, in the Shading category, select anAmbient Occlusion node and drag it to 
the Node view. Then, connect the output port of the Surface Map node to the leftmost input port of 
the Ambient Occlusion node, and the output port of the Volume Object node to the rightmost input 
port of the Ambient Occlusion node. 
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NOTE 

While the Cast Shadow node generates shading based on the position of the light 
source, the Ambient Occlusion node generates shading based on the height map of the 
volume object.

 15. At this point, the rig is ready, but the Surface Map needs to be customized to best represent the 
surface being rendered. 

In the Node View, click on the  Layer Properties button of the Surface Map node to open its Layer 
Properties dialog.

 16. In the Volume Creation section, from the Object List , select all the Volume Object nodes you want 
to use in this map.
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NOTE 

If multiple Volume Object nodes are connected to the Surface Map node, they will all 
appear in this list.

 17. The Surface Map requires that the elevation range of each Volume Object be specified. This is done 
by specifying the Elevation Min and Elevation Max for each volume object in the list.

TIPS 

 l You can set the elevation parameters to negative values to set the height of objects 
further back in the stage.

 l After the elevation values are set, they can be animated by connecting a peg or an 
animated height map to the Volume Object node. For more information, see Defining 
and Animating Elevation on page 458

 l You can also carve out parts of your volume object in the Surface Map node the same 
way you can with the Normal Map node of the legacy Light Shading effect—see 
Adding and Carving Volumes on page 408.

 l For best results, consider using blending modes to composite the shading effects to 
your rig—see Surface Blending on page 455.
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Positioning the Light Source for Surface Shading
You can manipulate the position of the Light Source for your shading system in the Camera view. For best 
results, it is recommended to position the light source above all the volume objects in your scene. In other 
words, its position on the Z-axis must be higher than the highest volume object in your rig. 

How to position the light source for surface shading

 1. In the Tools toolbar, select the  Transform tool. 

 2. In the Node View, select the Light Position node.

 3. Show the controls for the Light Position node by doing one of the following:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

A control resembling a light projector will appear in the Camera view.

 4. Reposition the light source to the desired position by moving the red control point:

 l To change the position of the light source on the x and y axes, click and drag on the light 
projector. 
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 l To change the position of the light source on the z-axis, press and hold the Alt key, then 
click and drag on the light projector. 

Move the light in the scene to best represent the desired lighting condition.

 5. To make the light source point towards the artwork, position the target of the light source over the 
artwork by moving the purple control point:

 l To change the position of the target on the x and y axes, click and drag on the light 
projector. 

 l To change the position of the target on the z-axis, press and hold the Alt key, then click and 
drag on the light projector. 

TIP 

You can also adjust the position of the light source in the layer properties of the Light 
Position node. To access them, in the Node View, click on the  Layer Properties 
button inside the Light Position node.

 6. To preview the effect of the new position of the light source, click on the  Render View button in 
the toolbar at the bottom of the Camera view.
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Creating a Cast Shadow Effect
To take advantage of Cast Shadows or Ambient Occlusion, it is helpful to have multiple Volume Objects or 
larger overall elevation ranges in the Surface Map. The size and value of both the Cast Shadow and the 
Ambient Occlusion are dependent on the relative elevations of the surface; the Cast Shadow also depends on 
the Light Position relative to the surface’s mapping.

Create a Cast Shadow with Multiple Volume Objects

 1. Start by setting up a simple Surface Map node with two image sources. To do this, follow the steps 
in How to Rig with Surface Shading on page 421.

To create a Surface Map that combines multiple Volume Object nodes, you must connect all the 
Volume Object nodes to a Composite node, and set this Composite node’s Mode property to Pass 
Through. 
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 2. For each Volume Object node in your rig, click on their  Layer Properties button to open their 
Layer Properties dialog, and set their ID parameter to different numbers. 

For example, in this case, the ID of Volume-Object-Leaf_1 would be set to 1 and the ID of Volume-
Object-Leaf_2 would be set to 2.

 3. In the Node View, click the  Layer Properties button of the Surface Map node to open its Layer 
Properties dialog. 

 4. In the Volume Creation section, add the Volume Objects you want to use to generate the surface 
map to the list below by doing one of the following:
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 l Open the Object drop-down and select each Volume Object you want to add to the list one 
by one.

 l To add all the Volume Object nodes connected to the Surface Map node to the list, open the 
Object drop-down and select Add All Defined Objects.

 5. For each Volume Object node in the list:

 a. Set the Elevation Min value to a value equal or higher than the Elevation Max value of the 
previous object. For the first object, this can be set to 0.

 b. Set the Elevation Max value to a value higher than the Elevation Min value for that object.

For example, if you have two Volume Objects, you can set the Elevation Min and Elevation max 
values for the first object to 0 and 1 respectively, and the Elevation Min and Elevation Max values 
for the second object to 1 and 2 respectively. 
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NOTES 

 l The Elevation Min and Elevation Max values for an object determine the range of 
space that each object occupies on the z-axis, and hence, how high each object is 
relative to other objects. This affects, among other things, how one object casts a 
shadow on other objects behind it.

 l The Elevation Min parameter of an object should be equal or higher to the Elevation 
Max parameter of the previous object, so that volumes do not clip together.

 l Elevation Min and Elevation Max parameters can have decimal values so as to lay 
different Volume Objects closer together.

 l An object that is too elevated may end up behind the camera, which will cause the 
surface to be rendered with a hole in it. 

 l To have a visual representation of your Surface Map as you configure the elevation of 
your objects, see Previewing the Surface Map on page 443.

 6. In the Node Library view, in the Shading category, select a Cast Shadow node and drag it to the 
Node View. 

 7. Connect the output port of the Surface Map node to the middle input port of the Cast Shadow node.

 8. Connect the output port of the Composite node combining your Volume Objects to the rightmost 
input port of the Cast Shadow node.
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 9. In the Node Library view, in the Shading category, select a Light Position node and drag it to the 
Node view. Then, connect the output port of the Light Position node to the leftmost (green) input 
port of the Cast Shadow node.

 10. Connect the output port of the Cast Shadow node to the scene’s main Composite node, left of the 
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port connecting that Composite node to the Composite that combines your Volume Object nodes. 
This will ensure that the shading effect is applied on top of the artwork.

 11. Position the Light Position node so that the object in the front casts a shadow onto the object in the 
back—see Positioning the Light Source for Surface Shading on page 433.

 12. In the toolbar below the Camera view, click on the  Render View button to preview the cast 
shadow effect.
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Previewing the Surface Map

The Surface Map’s render contains technical information used for calculating shadows and lighting. With some 
manipulation, this render can be very useful for problem-solving surface details and rigging.

The standard surface map renders a mapping that displays the X-position in fields in the red channel, the Y-
position in fields in the green channel and the Z-position (elevation) in fields in the blue channel. The X and Y 
(red and green) coordinates are calculated automatically, but the Z values (blue channel) are provided by the 
defined ranges in the Surface Map and the attached Height Maps.

How to visualize the elevation of a Surface Map

 1. In the Node Library view, in the Filter category, drag a Channel-Swap node to the Node View. 
Then, connect the output port of the Surface Map node to the Input Port of the Channel Swap node.

 2. In the Node Library view, in the Output category, drag a Display node to the Node View. Then, 
connect the output port of the Channel Swap node to the input port of the Display node.
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 3. Click on the Layer Properties button for the Channel Swap node and, in the Layer Properties dialog, 
set Red Channel from, Green Channel from and Blue Channel from parameters to Blue.

 4. In the Display toolbar, select the display connected to the Channel Swap node to visualize its 
output in the Camera view.

 5. In the toolbar at the bottom of the Camera view, click on Render View to preview the elevation of 
the Surface Map node. The preview will be in greyscale, with higher values rendered as brighter 
greys than lower values. 
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About Soft Shadow Options for Surface Shading

Soft Shadowing can be done in a number of different ways depending on the intended appearance of the 
rendered shadow.

By default, a surface is in shadow when the light source is occluded by another surface in the direction of the 
ray of the light source.

In this case, Surface A occludes the edge of Surface B, and causes a shadow where the light is blocked. The 
Surface is either lit, or in shadow and no blending is considered.

On the left, the shadow can be seen on Surface B. On the right, a side-view representation demonstrates that 
the shadow occurs when the single ray from the light source is blocked by Surface A.

The Soft Shadow Sample Size property defines a light range in Z that is used to interpolate the amount of 
shadow on a given surface. This creates a soft shadow that blends along the direction of the light and fades to 
a lighter shadow as it recedes from the occlusion source.
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On the left, a softer shadow can be seen on Surface B. On the right, a side-view representation demonstrates 
that the shadow creates a penumbra when only a portion of the light is occluded. The Soft Shadow Sample 
Size defines the height-range of the light source—the penumbra is created by interpolating how much of the 
light source is occluded between the upper and lower range of the light.

Sometimes, multiple options can be used to help better represent shadows on softer surfaces.

On the left, a basic shadow with Shadow Sample Size of 0 causes a hard shaded surface. In the centre, the 
shadow’s aliasing bias and blend is set to help blend out the shadow details closer to the occlusion source at 
the starting edge of the shadow. On the right, the Shadows Sample Size is set to a larger number to create a 
softer shadow that blends as it recedes away from the light source.
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If a more diffused shadow is preferred, the shadow can be created with multiple samples that are offset. This is 
helpful when creating lighting conditions that are less direct or for creating shadows that blend softer around 
the contours of the surfaces.

On the left, a hard edged shadow with no sampling. In the centre, the shadow is calculated by sampling only a 
handful of times, creating a shadow that appears to be created from multiple light sources. On the right, the 
shadow is calculated with many samples, creating a blended surface that appears more rounded and softer 
over the entire surface.
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Adding Ambient Occlusion

Ambient Occlusion can be easily added to any Light Shading system provided that it contains at least two 
Volume Objects.

To Create a Ambient Occlusion with Multiple Volume Objects

 1. Start by setting up a simple Surface Map rig with at least Volume Objects—see Creating a Cast 
Shadow Effect.

NOTE 

In this example, the shading system does not have Cast Shadow, Light Shader and 
Tone Shader nodes. That way, the only shading effect will be the Ambient Occlusion 
node, and its effect will be easier to see. 

 2. In the Node Library view, in the Shading category, select an Ambient Occlusion node and drag it to 
the Node view. 

 3. Connect the output port of the Surface Map node to the left input port of the Ambient Occlusion 
node. 

 4. Connect the output port of the Composite node combining all your Volume Object nodes to the 
right input port of the Ambient Occlusion node.
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 5. Connect the output port of the Ambient Occlusion node to the scene’s main Composite node, left of 
the port connecting that Composite node to the Composite that combines your Volume Object 
nodes. This will ensure that the shading effect is applied on top of the artwork.
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NOTE 

Contrary to other shading effects, the Ambient Occlusion node does not require a Light 
Position node. This is because the Ambient Occlusion shades the surface with screen-
space ambient occlusion (SSAO). It calculates the amount a surface is exposed to 
ambient lighting, For example, surfaces that are in deep crevices are shaded darker as 
less light is reflected from nearby surfaces in these areas.

 6. In the toolbar below the Camera view, click on the  Render View button to preview the ambient 
occlusion effect.

TIP 

As demonstrated in the screenshot above, adding Ambient Occlusion to your shading 
system helps outline separate surfaces. Additionally, it can help amplify the volume of 
your objects. 
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Surface Light Options for the Light Shader and Tone Shader Effects
When using the Surface Map and Surface Normal, new options become available on the Light Shader node 
and Tone Shader node. These options can be found in the new Surface tab of the nodes.

When using the Surface Normal node with the Light Shader or Tone Shader, the shader is able to light 
relative to the Z-position of the light and the elevation of the surface in the scene. This also allows for the 
addition of a specular highlight on the lit surface.

The original diffuse lighting from the Light Shader. The diffuse-style of lighting is created by calculating the 
amount of light being absorbed by the surface by using the direction of the light and the orientation of the 
surface.
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The specular highlight helps to define shinier surfaces and is often used to emphasize more rounded surfaces. 
The specular-style of lighting is created by calculating the amount of light being reflected off of the surface 
and into the camera.

To learn more about the Specular Options check out the Light Shader and Tone Shader reference.
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Light Fall-off
Now that the Light and Tone nodes are using field units in the scene, the light can fall-off as it recedes into the 
distance. When using the fall-off property, the brightness of a surface is calculated based on its distance from 
the light source. The light is at full strength at the Light Position node’s source and falls off, becoming less 
powerful, as it recedes towards the target.

The fall-off defines the percentage falloff at the weakest part of the light, the Light Position’s target. A value of 
100% in the fall-off property will cause the light to fall-off completely, and no longer light the surface. The 
value of the rendered light is determined by the power of the light ray at the point that it intersects the 
surface.

The fall-off value can also be used to make the surface appear brighter when closer to the light. When the 
falloff is turned on with a value above zero, a light directly near the surface appears brighter and more direct 
than a light further from the surface.
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Surface Blending
For best results, always consider the blending of the light on the surfaces and use appropriate light, tone and 
shadow colours with proper blending modes.

In a very basic light effect rig, the default settings of the effect can appear abrasive if not blended 
appropriately. In this case, a simple Light Shader and Cast Shadow have been added. Without proper colours, 
masking and blending, the colours appear washed-out.
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The screen blend mode has been added to the lighting effect and a multiply blend mode has been added to 
the shadow effect. To prevent light from being rendered in areas with cast shadows, the Light Shader has 
been cut by the Cast Shadow’s render. For an overall rich effect, more appropriate colours have been chosen 
for the Light Shader and Cast Shadow node.
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The resulting effect appears much more vibrant and less washed-out.
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Defining and Animating Elevation
There are a number of ways to define and animate the elevation of a surface. These methods are  useful for 
defining specific surface shapes, or animating the elevation to better represent the elevation and lighting 
conditions in the scene.

The Volume Object provides three extra ports to further define the elevation of a particular surface.

The Z-Offset Port

The Z Offset port allows you to add a peg to the Volume Object in order to move the surface’s elevation range 
in the scene. By adding a peg to the volume object, the peg can be animated to move the surface’s elevation 
relative to other surfaces in the scene. This will also affect the shadows cast by the surface. This is useful for 
animating and offsetting the surface’s overall elevation range in the surface mapping, such as the changing 
elevations on the individual drawings in a full turn-around character rig.
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The Height Map Port

The height map is useful for adding specific surface detail to a Volume Object, or for adding animated height 
maps like the Shape Node. The Height Map port converts the attached image into elevation information that 
can be used to light and shade the surface. This image  can be connected to a drawing that better defines the 
surface or it can be animated over time as the surface changes—it can even use bump texture data for surface 
definition.

The incoming image is converted to greyscale, multiplied by the Volume Object’s Elevation Min and Elevation 
Max and smoothed by the smoothness value. This height map is then added to the surface’s existing elevation 
in the Surface Map and is considered when lighting and shading the surface.
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NOTES 

 l The surface information can be used to both add and carve an existing volume object. 

 l The Height Map port can use both vector and bitmap images as its input.

 l This can be used in conjunction with the Shape Height nodes to make animatable height 
shapes—see 
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The Height Matte Port

The Height Matte port allows you to mask out regions of a Volume Object in order to blend the ranges in a 
Surface Map. The Height Matte port uses an image with alpha values (like a gradient) to mask out the height 
ranges provided by the Volume Object. The Volume Object’s surface is then blended with the underlying 
surfaces. This can be used in places where drawings intersect one another at joints or breaks in the surface, 
such as the shoulder, hip or nose.

By default, fully opaque pixels are masked out of the surface and transparent pixels are included. This can be 
inverted by checking Invert Height Matte in the Volume Object’s properties.

NOTE 

For more information on the Volume Object node and its properties, refer to the Reference Guide.
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Creating Animatable Height Shapes for Surface Shading

As explained in Defining and Animating Elevation on page 458, it is possible to add shape definition to a 
Volume Object by connecting a drawing to it. But it is also possible to create basic animatable shapes and use 
them to add shape definition to a Volume Object. This allows you to animate parts of the surfaces in your 
surface shading system.

This is done by creating a system of Shape Line, Shape Curve and Shape Render nodes, and connecting it to 
the Height Map port of your Volume Object. 
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While the Shape Line and Shape Curve nodes define the points of the shape, the Shape Render node 
combines those points to generate shapes, and fill those shape with a height map, which can then be used by 
the Volume Object node, instead of a drawing or bitmap image. 

How to create an animatable height map

 1. In the Node Library view, in the Shading category, select a Shape Render node and drag it to the 
Node view. This node acts as a composite for all attached Shaped nodes. 

 2. In the Node Library view, in the Output category, select a Display node and drag it to the Node 
view. Then, connect the output port of the Shape Render node to the input port of that Display 
node.

NOTE 

This Display node will be used to preview your shape as you build it. 

 3. In the drop-down in the Display toolbar at the top of the user interface, select the Display node you 
just created to preview it in the Camera view. 

 4. In the Node Library view, in the Shading category. Then, do one of the following:

 l If you want to create a polygonal shape, select a Shape Line node and drag it to the Node 
View.

 l If you want to create a curved shape, select a Shape Curve node and drag it to the Node 
View.

A single Shape Line or Shape Curve node defines a single point in the shape of the region. Hence, 
you must repeat this process until you have as many Shape Line or Shape Curve nodes as necessary 
to define each point in the shape of the region you want to create.

For example, if you want to create a rectangle, you would need four Shape Line nodes, one for each 
of the four points defining a rectangle. If you want to create an ellipsis, you would need four Shape 
Curve nodes instead.

 5. Position the Shape Line or Shape Curve nodes vertically, and connect them in a chain.
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 6. Connect the output port of the lowest Shape Line or Shape Curve node to the Shape Render node.

NOTE 

Like a Composite node, the Shape Render node will create as many input ports as you 
connect nodes to it. This is because you can combine several shapes by connecting 
several chains of Shape Curve or Shape Line nodes to the Shape Render node. 
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TIP 

Shape Line and Shape Curve nodes can be used together, to create shapes that are 
made of curves and straight lines.

 7. Select the Shape Render node and display its controls in the Camera view by doing one of the 
following:

 l In the Camera view toolbar, click on  Show Control .

 l From the top menu, select View > Show > Control.

 l Press Shift + F11.

NOTE 

Only one set of handles will appear, but this is because all points are in the same 
position.

 8. Drag each point out and form the desired shape. If you are working with Shape Curve nodes, 
manipulate the Bezier handles for each point to obtain the desired curves.
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 9. You may notice that there is no contour linking the last point in the chain to the first point. To fix 
this, In the Node View, click on the  Layer Properties button for the lowest Shape Line or Shape 
Curve node in the chain. Then, in its Layer Properties dialog, check the Close Shape Contour 
option. 

 10. Repeat steps 4 through 9 to create another shape inside the first one. 
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NOTE 

You can connect several chains of Line Shape or Curve Shape nodes to the Shape 
Render node to give it several shapes. 

 11. Select all the points of the inner shape by holding the Shift key and clicking on each point. When 
the points are selected, they will be highlighted in purple.

 12. While holding the Alt key, click on one of the selected points and drag it upwards. This will move 
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the points closer towards the camera. As a result, the points will appear larger to give you a visual 
indication of their position on the z-axis. 

 

 13. In the toolbar at the bottom of the Camera view, click on the  Render View button to preview the 
high map generated by your shapes. There should be a gradient going from the contour of the outer 
shape to the contour of the inner shape. The lightness of each pixels is representative of its height 
in the height map. 
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TIPS 

 l The Shape Render is best used to provide a Height Map for a Volume Object node—see 

 l The output of the Shape Render node is in fields, which means that the differences when 
adjusting the height of certain points may be difficult to discern. For a more legible preview, 
you can connect the Shape Render node to the Height Map port of a Volume Object, then 
preview the resulting surface map instead—see Previewing the Surface Map on page 443.
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Using Shapes to Blend Joints in a Surface Shading System

Different parts of a rig typically need to be placed at different elevations so that they generate cast shadows 
on each other. However, this causes hard seams to appear where different parts of a rig join together. For 
example, in the Height Map below, the character’s left arm is more elevated than their body, creating a hard 
seam around its shoulder which will make it “pop out” when a Cast Shadow effect is applied. 

TIP 

Displaying the blue channel of a Surface Map in the Camera view will show the relative heights of 
the surfaces in the Surface Map. This is helpful for setting up a character’s Volume Objects and 
blending the elevations of the surfaces. To generate this preview, see Previewing the Surface Map 
on page 443.

To fix this, a height map shape can be created to taper the height between the higher volume object and the 
lower volume object. 

The first step is to create a single shape rig. The shape must be created to cover the part of the volume object 
that needs to be blended—see Creating Animatable Height Shapes for Surface Shading on page 462.
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Then, the points that are closer to the joint must be moved down, so as to create a height map that will taper 
from the higher Volume Object’s height to the lower Volume Object’s height. 

To move points backwards, select them and, while holding the Alt key, click and drag them downward. The 
points will shrink in size to indicate that they are further away from the camera.

This causes the elevation of the arm to be sloped. The effect of this slope will be visible in the light, tone and 
cast shadow effects applied to the rig. 

It is also possible to blend the joint by calculating the difference in elevation between the two Volume Objects, 
then applying this elevation difference to the control points near the joint. This allows you to blend the joints 
with much more precision, which should prevent even very subtle seams to appear near the joint.
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In this case, the elevation of the Arm01-Object needs to meet the elevation of the Torso-Object at the joint. 
Considering that:

 l The Torso-Object has an elevation range from 1 to 2, while the Arm01-Object has an elevation range 
from 2 to 3.

 l The Torso-Object’s Elevation Baseline parameter is set to 50%. Hence, with no height map applied, the 
elevation of the torso is of 1.5 field, since that is the middle point between its minimum elevation of 1 
and its maximum elevation of 2.

 l The  Arm01-Object’s Elevation Baseline parameter is also set to 50%. Hence, with no height map 
applied, the elevation of the arm is of 2.5 fields, since that is the middle point between its minimum 
elevation of 2 and its maximum elevation of 3.

This means that, when no height map is applied, the Arm01-Object is exactly 1 field (2.5 - 1.5) above the 
Torso-Object. Hence, in order for the shoulder and the torso to meet, the points around the shoulder need to 
be moved down by 1 field. 

Since each point in a height map shape is a node, you can tweak the elevation of each point by opening the 
Layer Properties for its corresponding node, and entering the desired elevation for the point in its (z) Axis 
parameter. 

In this case, the points near the joint need to be moved down 1 field. This can be accomplished by setting their 
position on the z-axis to 1 B.
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About OpenFX
T-COMP2-008-002A

To expand your compositing possibilities, you can use OpenFX plugins directly in Harmony.

OpenFX is an open standard used to create visual effects plugins. These plugins can be used in any application 
that supports the standard. This means that banks of visual effect plugins can be developed by programmers 
and shared with various platform users. Harmony is one of these platforms.

To learn more about OpenFX, refer to:

 l openfx.sourceforge.net

 l openeffects.org

To learn more about  the main OpenFX plugin providers, refer to:

 l toolfarm.com/products/category/3316/all

To demonstrate this feature, the Sapphire package from GenArts® will be used. You can download the 
Sapphire library at:

 l genarts.com/sapphire
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Installing an OpenFX Package
T-COMP2-008-002B

Once you have purchased or downloaded an OpenFX package, you need to launch the executable file to install 
it. All OpenFX plugins install in a centralized location that all applications can read from. You will not need to 
do anything in Harmony. They will appear automatically in the Node Library view once the package of your 
choice is installed.

Here is the centralized installation path:

 l Windows: C:\Program Files (x86)\Common Files\OFX\Plugins

 l macOS: /Library/OFX/Plugins

 l GNU/Linux: /usr/OFX/Plugins

How to install an OpenFX package for Harmony

 1. Download the OpenFX package you want to install.

 2. Quit Harmony.

 3. Launch the OpenFX package installer and follow the installation instructions.

 4. Launch Harmony.

 5. In the Node Library view, in the Categories section, select the category matching the package's 
name. 

All effects included in the package are now available to use in Harmony.
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Using OpenFX Plugins
T-COMP2-008-002C

All OpenFX plugins can be customized by adjusting their parameters. Settings are organized by category and 
some of them can be expanded and collapsed for clarity. Parameters can also be animated over time.

Some effects also have visual controls to set the position or angle. If you want to adjust the controls for your 
effect, you must do so in OpenGL mode. To see the effect in OpenGL mode, you need to connect a Render 
Preview node to your effect.

How to use and edit an OpenFX plugin in Harmony

 1. From the Node Library view, select an effect plugin and drag it to the Node view.

 2. Connect your drawing nodes or other required nodes to the effect plugin.

 3. In the Camera view, enable the Render  mode to see the final rendered effect.

 4. In the Node view, click the effect node's yellow square to open the Layer Properties window and 
adjust its parameters.
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NOTE 

In the Layer Properties window, you can expand some parameter sections to see many more 
controls.

 5. Adjust the effect's visual control in OpenGL mode by dragging a Render Preview node from the 
Node Library view to the Node view. Connect it between the plugin and the Composite nodes.
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 6. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

 7. To display the controls, in the Node view, select the plugin effect node and do one of the following:

 l In the Camera toolbar, click the Show Control button.

 l From the top menu, select View > Show > Control.

 l Press Shift + F11 (Windows/Linux) or ⌘  + F11 (macOS).

The controls appear.

 8. In the Tools toolbar, select the Transform  tool or press Shift + T.
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 9. In the Camera view, adjust the controls.
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Using the Normal Map Converter
Harmony has the ability to generate normal maps. The main usage is to create light shading effects on flat 2D 
drawings. The normal map will carve and emboss a flat plane using vectors. The X, Y and Z coordinates of the 
normal map vectors are stored in RGB values to convert the 3D aspect into a visual result and use it to create 
various effects, such as light reflections (light shading). The X value is stored in the Red channel. The Y value is 
stored in the Green channel. The Z value is stored in the Blue channel.

A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to 
a format supported by your plugin. The Normal Map Converter node has been optimized to work with 
GenArts® plugins, but you also have the ability to use it on custom plugins.

NOTE 

Note that not all normal map formats are supported.

The Normal Map Converter uses the following formula per channel:

 l value * (+/- length) + offset

 l * +/- depending if inverse is set to true ("-" if true)

How to use the Normal Map Converter node

 1. In the Node Library view, go to the Shading category and select the Normal Map Converter node.

 2. Drag it to the Node view.
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 3. Connect the Normal Map Converter node between the Normal Map node and your custom plugin 
node.

 4. Select the Normal Map Converter node.

 5. In the Layer Properties view, adjust the node's properties.

Parameter Description

Conversion Type
By default, the conversion type is set to Genarts. If you work 
with a different manufacturer and want to adjust the 
parameters, set the conversion type to Custom.

Offset
Offsets the original position of the vector. You need to read 
the plugin documentation to know the offset you need to 
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use. You must use the same offset value as the manufacturer 
is using. By default the offset is set to 0.

Length

The Normal Map Converter normalizes Harmony vectors to 1. 
By default the length value is set to 1. If your plugin requires 
shorter or longer vectors, enter a value smaller or greater than 
1. It will multiply the vector length.

Invert Red
Inverts the red value (x). If your value is 125, the invert setting 
will transform it to -125.

Invert Green
Inverts the green value (y). If your value is 125, the invert 
setting will transform it to -125.

Invert Blue
Inverts the blue value (z). If your value is 125, the invert 
setting will transform it to -125.

 6. If the plugin you are using stores the X,Y and Z coordinates in different channels, you can use the 
Channel-Swap node to reassign the colour channels.
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About Node Categories
Customizing the categories is a great way to organize the nodes according to how you like to work and the 
nodes you use most often. You can easily add categories and subcategories, remove categories you don't use, 
and rename categories.

Displaying All Nodes 483

Adding a Node Library View Category 484

Removing a Node Library View Category 486

Renaming a Library View Category 487

Adding Nodes to Categories 488

Removing Nodes from Categories 489

Searching for Nodes, Categories, and Descriptions 490
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Displaying All Nodes
You can display all the nodes available in the Node Library view.

How to display all the nodes

 1. If a category is selected and you want to see all the nodes available in the library, in the Node 
Library view, place your cursor in the Node Search field.

The Node Library view displays all the nodes.
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Adding a Node Library View Category
You can add a Node Library view category to organize your most commonly used nodes or group them in a 
more convenient way to your pipeline.

How to add a category

 1. Do one of the following:

 l To create a new main category, click in the Node Search field.

 l To create a subcategory, select a category.

 2. Do one of the following:

 l From the Node Library menu, select New Category.

 l Right-click in the category area and select New Category.

The New Category window displays.

 3. In the New Category window, type in the name of a new category and click OK.

The new category appears in the Category list. Now you can add nodes to your new category—see 
Adding a Node Library View Category on page 484.
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Removing a Node Library View Category
You can remove custom categories you are not using in the Node Library view.

How to remove categories

 1. From the Category list, select a category to remove.

 2. Do one of the following:

 l From the Node Library menu, select Remove Category.

 l Right-click in the category area and select Remove Category.

The Confirm Remove Category window displays.

 3. Click Yes.
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Renaming a Library View Category
You can rename a Node Library view category to keep it organized.

How to rename categories

 1. From the Category list, select a category to rename.

 2. Do one of the following:

 l From the Node Library menu, select Rename Category.

 l Right-click in the category area and select Rename Category.

The Confirm Rename Category window displays.

 3. Type in a new name for the category and click OK.

487

Harmony 21 Premium User Guide                          



Chapter 18: Effects

Adding Nodes to Categories
Once you've created a category, you can add nodes to it for easy access. Later on, you can go back and remove 
any nodes you no longer use. You can only add and remove nodes from a category you created.

When you add a node to a new category, it is essentially a copy of the node. The node in its default location 
remains there. You cannot delete nodes from their default categories or move them.

How to add nodes

 1. Select a node from any category and drag it to a category you created.

A copy of the selected node is added to your new category.
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Removing Nodes from Categories
You can remove nodes you no longer use from custom categories.

How to remove nodes

 1. Select a node from a category you created.

NOTE 

Nodes from the default categories cannot be removed.

 2. Do one of the following:

 l From the Node Library menu, select Remove Node.

 l Right-click in the category area and select Remove Node.

 l Press Del.

The node is removed from the category. 
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Searching for Nodes, Categories, and Descriptions
Sometimes it's faster to type in the name of a node instead of looking through all the categories. You can also 
search for category names or descriptions as well. Once you type in the name of a node, description or category 
in the Node Search tool, it is displayed in the library. Sometimes the result of a node search is in one or more 
categories for convenience. 

How to search for nodes

 1. In the Node Library, place your cursor in the Node Search field.

The Node Library view displays all the nodes.

 2. Type in the name of a node, category or description.

Depending on how you are viewing the nodes, the Node Library view displays the node, categories 
and/or description you typed in.  

 3. To return to displaying all the nodes, place your cursor in the Node Search field again and delete 
the node name in the Search field.
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Chapter 19: Sound
With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing 
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to 
trim unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want 
to continue throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would 
best apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for 
your character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your 
animation based on the mouth chart.
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About the Sound  Editor
When you double-click on a sound layer in the Timeline view, the Sound Element Editor appears.

 l Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

 l Layer Name: This field displays the layer's name.

 l Sound Editor: This button opens the Sound editor.

 l Start Frame/End Frame: These fields determine the start and end frame of the sound file.

 l Detect: This button launches the automated lip-sync detection.

 l Map: This button opens the Map Lip-sync dialog box.

 l Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the 
thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Layer
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer 
Properties view.

If you double-click on a sound layer in the Timeline view, or in a sound column in the Xsheet view, the Sound 
Element Editor dialog will open. This dialog allows you to fine-tune the sound track's lip sync, start time, stop 
time and volume.
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NOTE 

Contrary to all other layers, sound layers are not represented by nodes in the Node view.
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Importing Sound
T-HFND-007-009

If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound 
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and 
quality should you use third party software for post-production. Another good practice is to keep your 
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation 
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly in 
Harmony when needed.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files.

NOTE 

Importing a soundtrack longer than your scene will not extend your scene's length. Sound 
playback will stop at the end of your scene's length.

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Sounds.

 l From the Xsheet menu, select File > Import > Sounds.

 l From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help 
you visualize at which frames the sound effects in your soundtrack occur. 

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by 
default. If you wish, you can display a sound column's waveform by right-clicking on it, then 
selecting Sound Display > Waveform.

496



497

Harmony 21 Premium User Guide                          



Chapter 19: Sound

Playing Sound
T-HFND-007-010

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it through 
the Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the 
ones included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the 
unwanted sound by clicking the Disable Layer  button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you 
can do one of the following to troubleshoot the issue:

 l Shrink down the Camera view size to reduce the cached image size.

 l Playback your scene without sound first, then add the sound. If you do not cache the images first without 
sound, the playback will try to follow the sound by skipping images that will never get cached.

 l In the Preferences panel, in the OpenGL tab, reduce the size of the Playback Cache Size (in mb) 
preference.

How to play back sound

 1. To select a starting point:

 l In the Xsheet view, click on a cell in the sound column.

 l In the Timeline view, click on a cell in the sound layer. You can also slide the red 
playhead to the correct cell.

 2. In the Playback toolbar, activate the Enable Sound  button.

 3. Do one of the following:

 l Click the Play  button in the Playback toolbar.

 l From the top menu, select Play > Play or click on the Enter/Return key.

 4. To hear the sound played back again and again, do one of the following:

 l Click the Loop  button in the Playback toolbar 

 l From the top menu, select Play > Loop.

 5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer  button.
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Changing the Sound Display
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing 
needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the Timeline 
View toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by 
default.

How to change the sound display in the Timeline view

 1. In the Timeline view's right area, right-click in the frame section and select Show Sound 
Waveforms or in the Timeline view menu, select View > Show > Show Sound Waveforms.

 l You can change the waveform scale using the Zoom Waveform  icon on individual sound layers 
in the Timeline view's left side.

How to change the sound display in the Xsheet view

 1. Right-click in the sound column or on the sound column header, and select Sound Display and one 
of the following:

 l Sound Name: Shows the name of the sound file, as well as the file format. The line 
running vertically through the column frames between the same file name indicates a 
continuity of the same sound file in these frames.

 l Mouth Shapes: Shows the letter (or name depending on the way you named your 
character's different mouth positions) in the column's frames. There is only one mouth 
position allotted per frame and this position should correspond to the sound file after 
performing a lip-sync.

 l Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or 
zoom out on the waveform, or pass the scroll cursor  over the Zoom Waveform  
icon.
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the 
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds 
from the Timeline view. 

How to scrub a sound from the Timeline view

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

 3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent 
sound frames. This allows you to do a more fluid scrubbing.
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About Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real 
time. It also means that as you scrub over a frame, you will hear the section of your sound file that is allotted to 
that frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to 
hear nuances in pitch and tone. 

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played 
back according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle 
and jog sliders to perform analog sound scrubbing, however, external hardware and their corresponding 
software can be used in conjunction with Harmony for improved analog sound scrubbing results. 

NOTE 

Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog 
controls.

 l Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline view 
jump by large increments in the direction you are moving the shuttle.
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 l Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental movements along 
the soundwave. Use the Frame field to see the frame number which you are on. As you rotate the dial, 
your speed in fps appears directly after the FPS field. 

How to perform an analog sound scrub

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. In the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences 
(macOS).

 3. In the Sound tab, select the Analog Sound Scrubbing option.

 4. Click OK.

 5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to start 
your sound scrub. 

‣ In the Timeline view, drag the red playhead to the desired location.

 6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing Sound
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the 
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside 
of Harmony and imported into your scene.

How to open the Sound Element editor

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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 l Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard 
when the final movie is rendered. It may be shorter than the original sound sample due to the 
length of the scene. If any edits are made to the sound sample, they can be heard here. In the 
Sound Element panel, notice the coloured tabs that indicate the start and end frames of a sound 
segment. The frame number is displayed in the tab.

 l Current Sound: Displays the original sound file in its entirety and is where you can edit its 
properties. This window remains empty until you click inside the Sound Element Editor.

 l Lip-sync Preview: Lets you preview the automated detection and to manually insert different 
mouth positions to correspond with the sound sample. 
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Cropping Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make 
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame 
number is shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.

How to change start or end frame of a sound

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound section (only the selected sound plays).

 3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to 
start playing. 
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two 
clips in the same element.

 4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

 5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element 
section.

If you only want to hear the selected clip, click the Play  button  in the Current Sound section.

 6. Click Apply/Next.
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The Xsheet and Timeline views display the sound clip at the start frame you selected.
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Trimming Sound
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For 
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. 
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to 
edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click the 
Play  button in the Current Sound panel (only the selected sound plays).

 3. Using the Current Sound section, decide on the part of the file you want to play by dragging the 
left and right boundaries of the selection area.

 4. Click the Play  button in the Current Sound section to check that you have trimmed the desired 
sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim 
it more accurately.

 5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end 
positions you selected.
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Looping Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. From the Sound Element section, select the sound section you want to loop.

 3. In the Current Sound section, type the number of times you want the sound to play in the Number 
of Loops field.

 4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) 
until the next sound sample starts or until the scene ends. This means that the looping could be cut 
if the next sound sample starts too soon or if the scene ends too quickly.
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in 
and fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original 
sound file is not affected.

How to adjust the overall volume of the entire sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element section, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound section.

 3. In the Current Sound section, use the Volume slider to adjust the volume.

 4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element section, select the sound you want to work on.

 3. In the Current Sound section, click on the thin blue line above the waveform to add an envelope 
marker.

 4. Drag the envelope markers to adjust the volume at that frame and to create the time of the 
transition. The line from the edge of the clip to the envelope marker identifies how the volume 
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increases (fades-in) or decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards 
increases the volume. 

NOTE 

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and 
right (bottom and top) channels.

 5. Click the Play  button in the Current Sound panel to check the fade envelopes.
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Setting the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start 
or stop at specific frames. This customized playback range does not affect the actual sound in the Sound 
element. 

How to change the playback range in the Sound Element editor 

 1. Drag the start or end range markers in the Sound Element section to the boundary frames you 
want.

 2. When you click the Play  button to play back your sound in the Sound Element editor, it only 
plays the sound which exists between the two markers.
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Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For 
example, when performing a lip-sync, only a single view of the various mouth positions for a character can 
exist on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-
quarter view and have mouth position changes to fit with the sound sample from these two different views, 
you would need to cut up the sound samples needed for the profile view mouth positions on one layer and the 
sound samples needed for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

 1. In the Timeline Layer toolbar, click the Add Layer button.

 2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

 3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound 
Element editor. Click Apply/Next to accept the change.

1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut 
and Shift + click on the final cell of the cut. The sample to be cut becomes highlighted.
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2. Drag the selection into the empty sound layer below.

 4. You can now continue to cut-up and distribute the sound sample between the two layers or carry 
on to the lip-synching process for each layer and its corresponding facial view.

NOTE 

If you need to duplicate your sound layer to keep an unedited copy for safety, select the 
Duplicate Selected Layers button in the Timeline View toolbar. You must customize the toolbar 
to display this button because it is not included in this toolbar by default.
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About Lip-sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE 

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound
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When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to 
work, your character's mouth layer should already contain a mouth drawing for each drawing in the mouth 
chart, and these drawings should be named by their corresponding letter. 
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, 
Xsheet view and Sound Element editor.

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 
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NOTE 

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the  Enable Sound  option.

 8. Press the  Play  button in the Playback toolbar to see and hear the results in the Camera view

How to generate a  sound detection for lip-sync in the Xsheet or Timeline view

 1. Do one of the following: 

 l In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-
Sync > Auto Lip-Sync Detection. 

 l From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

NOTE 

To show the mouth chart letters, if they're not already present in the Xsheet view, right-click 
on the sound column and select Lip-Sync > Sound Display > Mouth Shapes. 
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Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X 
markers in the frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element editor

 1. Do one of the following:

 l In the Timeline view, double-click on the sound layer.

 l In  the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.

 2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

 3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync 
letter to each sound cell.
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Mapping the Lip-Sync Detection
Harmony can automatically map Automatically maps drawings in an element to the mouth chart you have 
generated for a sound. This can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically 
labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

 1. To open the Lip-Sync Mapping dialog box, do one of the following:

‣ In the Layer Properties view, click on the Map button.

‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > 
Map Lip-Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

 2. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

 3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on 
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you 
want to use the drawings or select the desired symbol from the drop-down menu.
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 4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you do not 
have to do anything.
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Modifying the Lip-sync Detection
You can change the mouth position assigned to a frame if you think another position is more appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony 
would normally assign an X image for the silent period. However, if you want your character's mouth to hang 
open in astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an 
F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the 
Lip-Sync Detection on page 522.

How to change the mouth position assignment of a sound from the Sound Element 
editor and Layer Properties view

 1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet 
view to open the Sound Element editor.

 2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth 
position assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current 
frame. 

 3. To change the image assigned to the frame, click on the image of the mouth position you want from 
below the preview image. The preview image changes to the mouth position image you select. You 
can perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.
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How to change the lip assignment of a sound in the Xsheet or Timeline view

 1. Right-click in the cell that contains the mouth position you want to change.

 2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that 
reflects the mouth position you want to use for that sound. You can also select Animation > Lip-
Sync > Change Mouth Shape > the desired mouth shape from the top menu.

NOTE 

Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.
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Manual Lip-syncing
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed 
at each frame of your character's d ialogue. For this process, you will be using the Sound Scrubbing 
functionality, which plays the part of your sound track at the current frame whenever you move your Timeline 
cursor, allowing you to identify which phonemes you should match your character's mouth to. You will also be 
using drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.
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 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.

How to swap drawings using the Drawing Substitutions view

 1. Add the Drawing Substitutions view to your workspace by doing one of the following:

 l In the top-right corner of any existing view, click on the  Add View button and select 
Drawing Substitutions.

 l In the top menu, select Windows > Drawing Substitutions.

 2. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 3. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 4. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 5. In the Drawing Substitutions view, click on the mouth pose you want to expose at the current frame.
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TIP 

You can also press [ to substitute the selected drawing with the previous drawing and ] to 
substitute it with the next drawing. 
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, 
such as an editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of 
individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

 2. In the Output section, click Browse and specify where you want to save the exported sound file.

 3. In the Export Range section, select one of the following options:

 l All: Exports the sound over all the frames of your scene.

 l Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

 l Process Soundtracks Individually: Each soundtrack from all layers is exported as 
individual files.

 l Merge all Soundtracks: One single file is created, combining all the sound files you 
imported in your scene. Note that it will only use the sound files in the selected frame 
range set in the Export Range section. If you selected to export all the frames, all the 
sound files will be processed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. 
It is a good idea to verify what is required by the software or device that  you may want to use next 
with the sound file.
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 6. Click OK.

The generated sound files appear in the selected directory and are named according to the scene 
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Chapter 20: 3D Integration
Harmony is able to integrate 3D models into your animation. Like 3D-enabled elements, you can animate a 3D 
model on its geometry by translating it, rotating it or scaling it on the X, Y and Z axes. Using a Subnode 
Animation node, you can also animate the individual parts (subnodes) of a 3D model separately. 

By default, a 3D model in a Harmony scene will be rendered using OpenGL, which is unlikely to render in the 
desired quality. To properly render a 3D model, you must configure your scene to render the model through 
Autodesk Maya. When properly set up, Harmony will seamlessly make Maya render the 3D model, then 
composite the rendered image into the final render of the scene. For more information, see 3D Rendering in 
Harmony on page 593. 

TIP 

As you work with 3D objects in Harmony, you will most likely want to integrate 2D and 3D objects 
together. To learn more about manipulating 2D objects in 3D space, see Positioning Layers in 3D 
Space on page 965 and About the 3D Transform Tool on page 959.  
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Creating 3D Models for Harmony
The first step to integrating 3D models into a Harmony scene is to export the model into a supported format so 
that it can be imported in a Harmony scene. Harmony can work with the following types of 3D objects.

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

If you set up your scene to render through Autodesk Maya, Harmony will use the original Maya project to create 
the rendered image. Hence, even though these formats do not carry all the details of the original project, your 
choice of 3D model type has no effect on the final render. An 3D model in Harmony can hence be considered a 
reference model. You can even export the model with optimizations, such as lower resolution textures or 
reduced details in the geometry, so as to enhance performance when manipulating the object in Harmony. 
Note however that the exported model must be in the same size and position as the model in the Maya project.

However, if you do not plan to render the scene through Autodesk Maya, be aware that the model will be 
rendered as it appears in the Camera view, using OpenGL, and that the render will based strictly on 3D object 
file imported in the scene, not on the Maya project. Hence, for that purpose, it is recommended to export your 
model in Filmbox (.fbx) format, as that format can be exported with textures, and to not make texture or 
geometry optimizations that would affect the quality of the exported model. 

Otherwise, even when rendering with Autodesk Maya, the Filmbox (.fbx) is still one of the most useful model 
types to work with in Harmony. Since this format can be exported with its textures, this gives a more accurate 
preview of what the rendered image will look like in the Camera view. Also, an .fbx model can be exported 
with subnode animations, which Harmony can play in the scene. 

Another particularly useful 3D model type is Alembic (.abc). Although this type does not store any texture  
information, it can store the baked in geometry of a 3D model that is animated with deformations. Harmony 
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can play the different frames of animated Alembic file in the scene, allowing the animator to use the baked-in 
transformations of an animated model as a reference for animating other elements in the scene around it. If 
exported from Maya, an Alembic (.abc) file can also store basic colour information (on a per-vertex basis) 
which Harmony can display and render. 

At last, the Collada (.dae) format allows artists to use models exported from SketchUp without using Sketchup 
Pro. 

When importing a 3D model, you have the option to convert it to a Filmbox (.fbx) file before storing it in the 
scene. This is because Harmony converts the model to .fbx format internally so it can work with it, so 
converting the file will allow Harmony to skip converting it internally every time the scene is opened. 

534



Exporting 3D Objects for Harmony
Before importing your 3D model in Harmony, you must export it in a format supported by Harmony. The 
following steps will explain how to export a 3D object in Filmbox (.fbx) or Alembic (.abc) format from Autodesk 
Maya. Depending on the software and version you are using as well as the file type you wish to export, the 
instructions may vary. Please refer to the documentation of your 3D authoring software as needed. 

NOTE 

If your model is animated and you want its animation to play in the Harmony scene, you should 
export it in Filmbox (.fbx) format if the animation does not use deformations, and in Alembic (.abc) 
format if the animation uses deformations. 

IMPORTANT 

When exporting a Filmbox (.fbx) file from Autodesk Maya, you must set the Type parameter to 
Binary and the Version parameter in FBX File Format panel to 2014/2015 to make sure it is 
compatible with Harmony.

How to export a 3D object in Filmbox (.fbx) for Harmony

 1. In Autodesk Maya, create your 3D object. Make sure your 3D object is ready for rendering by 
properly creating its textures and setting up the lights in the stage. Harmony will use the original 
Maya project to create the final renders. 

535

Harmony 21 Premium User Guide                          



Chapter 20: 3D Integration

TIP 

The animation done on the 3D object in Harmony will be applied to the Maya project 
when rendering. To avoid moving the object out of its light source, it is recommended to 
make the light source a child of the 3D object, so that the light moves along with it. In 
Maya, you can make a layer a child of another layer by middle-clicking it and dragging 
it over the intended parent.

 2. Save your Maya binary file *.mb as you will use it later on.
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 1. From the top menu, select File > Export All.

The Export All dialog box opens.

 2. In the Files of type drop-down, select FBX Export.  
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 3. In the Animation section of the Options panel, check the Animation checkbox if you want the 
subnode animations to be included in the model. 

 4. In the Embed Media section of the Options panel, check the Embed Media checkbox. This will 
export textures with the model. 

 5. In the FBX File Format section of the Options panel:

 a. Set the Type option to Binary.

 b. Set the Version option to FBX 2014/2015.

 6. Click on Export All.

An .fbx file will be created in the selected location.

How to export a 3D object in Alembic (.abc) for Harmony

 1. In Autodesk Maya, create your 3D object. Make sure your 3D object is ready for rendering by 
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properly creating its textures and setting up the lights in the stage. Harmony will use the original 
Maya project to create the final renders. 

TIP 

The animation done on the 3D object in Harmony will be applied to the Maya project 
when rendering. To avoid moving the object out of its light source, it is recommended to 
make the light source a child of the 3D object, so that the light moves along with it. In 
Maya, you can make a layer a child of another layer by middle-clicking it and dragging 
it over the intended parent.

 2. Save your Maya binary file *.mb as you will use it later on.

 3. From the top menu, select Cache > Alembic Cache > Export All to Alembic.
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The Export All dialog box opens.

 4. In the Cache time range dialog box, select the range of frames that you want to export in the 
Alembic (.abc) file:

 l Current frame: Exports only the current frame.

 l Render settings: Exports the frame range specified in the Render Settings dialog.

 l Time Slider: Exports the frame range covered by the time slider. 

 l Start/End: Exports the frame range specified in the Start/End fields below. 

 5. If you want to import the vertex colours of your 3D model into Harmony, scroll down to and expand 
the Advanced Options section, then check the Write Color Sets option.
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 6. Click on Export All.

An .abc file will be created in the selected location.
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Importing 3D Objects in Harmony
There are two approaches to importing a 3D model in a Harmony scene:

 l Importing it as a 3D model allows you to manipulate and animate the 3D model in all three dimensions, 
to separate and animate its sub-nodes, and to render the 3D model through Autodesk Maya using your 
preferred rendering engine when rendering your scene.

 l Rendering it as a 2D layer allows you to render the 3D model from a fixed position and angle and 
import it into your scene as a 2D bitmap layer. This is mostly useful if you intend to use the 3D model as 
a referenece to draw backgrounds, characters or props. This will keep your scene lighter.
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Importing 3D Objects in a  Scene
Once you have exported a model using a 3D authoring software, you can import it into Harmony and integrate 
it to your scene.

NOTE 

You have the possibility to convert your 3D models to the .fbx format upon import to Harmony. 
This will allow Harmony to render 3D files with the associated textures without the need to copy 
over the textures manually, provided that the auxiliary files are linked correctly and named 
appropriately on your disk).

How to import 3D models

 1. In Harmony, select File > Import > 3D Models.

The Import 3D Models dialog box opens.

 2. In the Files field, click on Browse.

An Open dialog appears.
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 3. Browse to an select your 3D model, then click on Open.

NOTE 

You can only import .osb, .3ds, .obj, .fbx, .abc and .dae type 3D models. 

 4. In the Layer section, choose your import options.

 l Create Layer(s): This option is selected by default. A new layer will be created for the 
selected files for the import. You have two choices:

 l Create Single Layer Named: Imports all the selected files into a single layer. The layer 
will be named after the name you enter in the text input field to the right. 

 l Create Layer(s) Based on Filename: Creates a different layer for each file selected for 
import. The layers will be automatically named according to the name of each file. 

 l Add to Existing Layer: Imports the selected files into an existing 3D layer in the scene. Use 
the drop-down menu to select which 3D layer to import it to.

 5. In the Conversion section, select the Convert to FBX format option if your file isn't already a *.fbx 
file and you would like it to be. This format incorporates all associated files, such as the texture files.

 6. Make sure the Convert to 2D options is unchecked. 

NOTE 

If you want to convert a 3D model to a 2D layer, see Importing a 3D Object as a 
Rendered 2D Image on page 546.

 7. Click OK.

The 3D model is imported into the scene.
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Importing a 3D Object as a Rendered 2D Image
You can import a 3D model as a rendered 2D image in a bitmap layer. This can be useful if you want to use a 3D 
model as a reference to draw 2D backgrounds, characters or props. 

When you import a 3D model as a 2D image, you will be prompted to choose the point of view from which the 
model is rendered. After that, the model will be rendered into a bitmap layer in your scene. Since the 3D 
model will be rendered into a bitmap layer, you will not be able to make 3D manipulations on it.

NOTE 

Later, if needed, you can adjust the point of view from which the model is rendered and render it 
again—see Repositioning a 3D Model Rendered as a 2D Image on page 551.

How to import a 3D model as a rendered 2D image

 1. In Harmony, select File > Import > 3D Models.

The Import 3D Models dialog box opens.

 2. In the Files field, click on Browse.

An Open dialog appears.
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 3. Browse to an select your 3D model, then click on Open.

NOTE 

If you want to import a 3D model as a rendered 2D image, you can only import a single 
3D model at a time. 

NOTE 

You can only import .osb, .3ds, .obj, .fbx, .abc and .dae type 3D models. 

 4. In the Layer section, select Create Layer(s). When you import a 3D model as a rendered 2D image, 
you must import it into a new layer. Then, choose one of the following options:

 l Create Single Layer Named: Imports the model into a layer named after the name you enter 
in the text input field to the right.

 l Create Layer(s) Based on Filename: Imports the model into a layer named after its file name.

 5. In the Conversion section, check the Convert to 2D option.

 6. Click OK.

The Render 3D Model dialog appears.

NOTE 

For information on all the parameters in this dialog, see the Reference Guide.

 7. If you want the model to fit inside the camera field, click on the Fit Model to View button just 
beneath the parameters to the right.
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 8. In the preview area, do the following to adjust the camera's point of view relative to the 3D model:

 l Either click and drag on the vertical slider to the right or scroll the mouse wheel up or down 
to adjust the distance between the camera and the model. 

 l Hold Ctrl + Shift (Windows/Linux) or ⌘  + Shift (macOS), then click and drag on the preview 
area to rotate the camera.

 l Hold Spacebar, then click and drag on the preview area to pan the camera laterally. 

 9. If you want to adjust the amount of perspective applied on the way the 3D model is rendered, 
adjust the Focal Length parameter. Increasing it will reduce the amount of perspective applied on 
the model, and decreasing it will increase the amount of perspective applied on the model. 

NOTE 

Increasing this setting will also decrease the perceived size of the 3D model, and 
decreasing it will increase its perceived size. You must then adjust the camera's distance 
from the model or the model's scaling to compensate. 
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 10. Adjust the Translation parameters until the 3D model is in the right position for the scene:

 l X: The horizontal position of the 3D model, from west to east.

 l Y: The vertical position of the 3D model, from south to north.

 l Z: The position of the 3D model relative to the camera, from near to far. 

 11. Adjust the Rotation parameters until the 3D model is in the right angle for the scene:

 l X: The rotation angle of the model around the horizontal axis. 

 l Y: The rotation angle of the model around the vertical axis.

 l Z: The rotation angle of the model around the z-axis. 

 12. Adjust the Scaling parameters until the 3D model is in the right size for the scene:

 l Lock Scaling Axis: When enabled, you can use the X scaling field to set the scaling of the 3D 
model on all axes, preserving its proportions. 

 l X: The horizontal scaling of the model.

 l Y: The vertical scaling of the model.

 l Z: The scaling of the model on the z-axis.

 13. Once the model is in the right position, angle and size, click on Render to Scene.

The model is added to the scene, rendered into a 2D bitmap layer.
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Repositioning a 3D Model Rendered as a 2D Image

If you have rendered a 3D model in a 2D scene, and later decide that you need the model to be rendered from 
a different point of view, you do not need to re-import it into your scene. You can change the point of view of 
the rendered model directly. 

IMPORTANT 

If you have drawn anything on the layer in which the 3D model was rendered, updating the 
model's position will discard the artwork on that layer.

How to change the point of view of a rendered 3D model

 1. In the Timeline view, right-click on the layer in which your 3D model was imported, and select 
Update 3D Model Position.

TIP 

A layer in which a 3D model was rendered as a 2D image will have a  special  icon  
next to its name.

The Render 3D Model dialog appears. The 3D model is in the same position as the one in which it 
was rendered, allowing you to tweak its current position.

NOTE 

For information on all the parameters in this dialog, see the Reference Guide.

 2. If you want the model to fit inside the camera field, click on the Fit Model to View button just 
beneath the parameters to the right.
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 3. In the preview area, do the following to adjust the camera's point of view relative to the 3D model:

 l Either click and drag on the vertical slider to the right or scroll the mouse wheel up or down 
to adjust the distance between the camera and the model. 

 l Hold Ctrl + Shift (Windows/Linux) or ⌘  + Shift (macOS), then click and drag on the preview 
area to rotate the camera.

 l Hold Spacebar, then click and drag on the preview area to pan the camera laterally. 

 4. If you want to adjust the amount of perspective applied on the way the 3D model is rendered, 
adjust the Focal Length parameter. Increasing it will reduce the amount of perspective applied on 
the model, and decreasing it will increase the amount of perspective applied on the model. 

NOTE 

Increasing this setting will also decrease the perceived size of the 3D model, and 
decreasing it will increase its perceived size. You must then adjust the camera's distance 
from the model or the model's scaling to compensate. 
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 5. Adjust the Translation parameters until the 3D model is in the right position for the scene:

 l X: The horizontal position of the 3D model, from west to east.

 l Y: The vertical position of the 3D model, from south to north.

 l Z: The position of the 3D model relative to the camera, from near to far. 

 6. Adjust the Rotation parameters until the 3D model is in the right angle for the scene:

 l X: The rotation angle of the model around the horizontal axis. 

 l Y: The rotation angle of the model around the vertical axis.

 l Z: The rotation angle of the model around the z-axis. 

 7. Adjust the Scaling parameters until the 3D model is in the right size for the scene:

 l Lock Scaling Axis: When enabled, you can use the X scaling field to set the scaling of the 3D 
model on all axes, preserving its proportions. 

 l X: The horizontal scaling of the model.

 l Y: The vertical scaling of the model.

 l Z: The scaling of the model on the z-axis.

 8. Click on Render to Scene.

The selected layer is updated with the 3D model as rendered from its new point of view. 
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About the Scale Factor of 3D Objects
When importing a 3D object created in a 3D modeling application, such as Maya, Cinema4D, Blender or 
others,  the 3D object can appear much larger or smaller than intended inHarmony. Therefore, you may have to 
scale it up or down for it to be in the right proportions. This is because 3D modeling applications use different 
base units than Harmony. For example, Autodesk Maya works in centimetres, and Blender works in metres, 
whereas Harmony works in fields. 

To remedy this, you can apply a scaling factor to your 3D model. This has advantages over simply scaling down 
your model with the Transform tool, such as:

 l If you animate your 3D model, changing its scale factor will change its size in all of its animation 
keyframes.

 l If you use the same 3D model several times in your scene, changing its scale factor will change the size 
of every instance of the 3D model.

 l Changing a 3D model's scale factor does not affect its actual scale coordinate. For example, if your 3D 
model's scale coordinate is 1, but you set its scale factor to 0.5, the 3D model will appear half its original 
size, but its scale coordinate will still be 1. Hence, the scale factor servers to change your model's default 
size. 
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Setting the Scale Factor for a 3D Model
If you have imported a 3D model into your scene, and you find that its default size is too big or too small for your 
scene, you can adjust its scale factor. Adjusting a 3D model's scale factor affects its size throughout the whole 
scene, even if it is already animated.

How to set the scale factor of a 3D model

 1. In the Library view, select the 3D Models library.

 2. Select the 3D model for which you want to set the scale factor.

 3. Right-click on the 3D model and select Set Scale Factor.

The Model Properties dialog appears. 

By default, the model's scale factor is set to 1.000 (or 1), which means the model is neither scaled 
up or down.

 4. Do one of the following:

 l If you want the model to appear smaller, enter a value between 0 and 1. For example, to 
make the model half of its original dimensions, enter 0.5. 

 l If you want the model to appear bigger, enter a value above 1. For example, to make the 
model twice its original dimensions, enter 2. 

 5. Click on the OK button.
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The model's new scale factor is applied to all its instances in the scene, throughout the entire scene. 
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Determining the Scale Factor for a 3D model
Before importing a 3D object, you must consider the scale factor to use. You can calculate the appropriate scale 
factor for a 3D model by comparing the measuring units used by Harmony to the ones used by your 3D 
modeling software. 

This can be done by importing a cube that is 1 unit in size, cubed, in your 3D modeling software, into Harmony. 
Then, you can adjust this cube's scale factor until it matches a unit in Harmony. 

To be able to match the size of the cube against a unit in Harmony, you can enable the 12 Fields grid. Units in a 
12 Fields grid are shorter vertically than they are horizontally, to match the 4:3 aspect ration of legacy 
standard displays, but you can use their horizontal size as a reference for square units in Harmony.

How to determine the right scale factor for your 3D models

 1. In your 3D modeling software, create a cube that is 1 cubed unit in size (a cube that is 1 unit in 
width, 1 unit in height and 1 unit in depth).

 2. Export the model from into one of the formats supported by Harmony:

 l Filmbox (.fbx)

 l 3DS Max (.3ds)

 l Wavefront OBJ (.obj)

 l Allembic (.abc)

 l Collada (.dae)

 3. Import the cube into your scene—see Importing 3D Objects in a  Scene.

 4. In the Library view, open the 3D Models library.

 5. Right-click on the model and select Set Scale Factor.

The Model Properties dialog appears.

 6. In the Scale Factor field, verify that the model's scaling factor is set to 1.0.

 7. Click on OK.

 8. In the Timeline view, create an empty layer—see Adding Layers in the Timeline View.

 9. In the new layer, select the cell at the current frame.
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 10. Do one of the following to create an empty drawing at the current frame:

 l Right-click on the selected cell and select Drawing > Create Empty Drawing.

 l In the top menu, select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R.

 11. In the top menu, select View > Grid > Show Grid or press Ctrl + G (Windows) or ⌘  + G (macOS).

The 12 Field Grid displays over the empty drawing you just created.

NOTE 

To display the grid, you need to have a drawing selected. The grid is offset if the layer in 
which the drawing is offset, hence the need to create a new layer and an empty 
drawing.

 12. Open the Perspective view. 

 13. While holding Ctrl + Alt, click and drag on the Perspective view to rotate it, so that you can clearly 
see how the cube's vertexes align with the grid. 

 14. In the Library view, using trial and error, adjust the 3D model's scaling factor so that its horizontal 
edges touch the vertical vertexes -1 and 1.
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Once you get the cube to fit in those vertical lines, your cube's scale factor will be adjusted to 
Harmony's coordinate system. You can use this scale factor on every model exported from your 3D 
modeling software. 
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Setting the Default Scale Factor for 3D Models
To preserve the proportions between 3D models in Harmony, you should set all your 3D models to the same 
scale factor. Once you've determined the ideal scale factor for your project, you can set the default scale factor 
to apply to 3D models when you import a 3D model into a scene. 

How to set the default scale factor for 3D models

 1. In the top menu, select Edit (Windows/Linux) or Harmony Premium (macOS) > Preferences.

The Preferences dialog appears.

 2. Select the General tab.

 3. In the 3D Models section, in the Default Scale Factor field, type in the default scale factor for your 
3D models. 

 4. Click on OK. 

From now on, when you import a 3D model, its scale factor will automatically be set to the scale 
factor your just entered. 
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Using Animated 3D Models
By default, a 3D model imported in Harmony will appear static throughout the scene. However, a Filmbox 
(.fbx) or Alembic (.abc) 3D model that has been exported with animations in it and imported in Harmony can 
be made to play out its animation in the scene, and to render with its animations later.

This is possible with two types of 3D objects:

 l Filmbox (.fbx) files can be imported with their subnode animations. This means the geometric 
transformations on each subnode in each frame of the model can be imported and played out.

 l Alembic (.abc) files can be imported with their deformations baked into every frame.  This is useful if you 
need to use models that are animated with deformations. However, Alembic files do not have texture 
and hence appear solid white in the preview.

In both cases, the 3D model will be rendered by Maya, using the original Maya project file. Hence, the result 
will be the same in the rendered image. The difference is the kind of information that is visible in the OpenGL 
preview of Harmony. 
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Playing the Animation of a 3D Model in a Harmony Scene
Animated 3D models imported in Harmony will appear static at first. To play their animation in the scene, the 
frames of their embedded animation must be exposed in their Xsheet column. 

The 3D model itself being a drawing, typically named 1, that must be exposed throughout the scene, you can 
indicate which animation frame inside the 3D model to expose in a given frame of the scene by entering, in a 
cell in the Xsheet, the name of the drawing followed by a comma and the number of the model's animation 
frame to expose. 

For example, if the model is named 1, and you wish to expose the frames 1 to 15 of its animation in the scene, 
the model's Xsheet column should have drawings from 1,1 to 1,15 exposed, inclusively.

NOTE 

In the example above, the first frame of the model appears as 1 instead of 1,1. Harmony will 
always display the first frame of the model as the model's name without any frame number. 

You can quickly fill the Xsheet column of a 3D model with its embedded animation frames using the Sequence 
Fill dialog.

How to fill the Xsheet column of an animated 3D model

 1. In the Xsheet view, locate the column of the 3D model. 

 2. In the column, select the frame range in which you want the animation of the 3D model to play out.

 3. Do one of the following:

 l Right-click on the selection, then select Exposure > Sequence Fill.

 l Open the Xsheet view menu, then select Exposure > Sequence Fill.
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 l In the top menu, select Animation > Cell > Sequence Fill.

 l Press Ctrl + M

The Sequence Fill dialog box appears.

 4. Check the Padding checkbox.

 5. In the Padding field, enter the name of the drawing name of the 3D model, followed by a comma. 
For example, if the 3D model is named 1, enter 1,.

TIP 

The text in the Padding field is used to prefix drawing names by default. Optionally, the 
# character can be used to indicate where in the padding text should the drawing 
number be inserted. 

 6. Depending on how the animation in the 3D model should play out, set the following parameters:

 l In the Starting Value field, enter the first frame of the model's animation that should play in 
the scene.
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 l In the Increment field, enter the amount of frames that each exposure should increment by. 
For example, if your model is animated on ones, but you want its animation to skip every 
other frame to play on twos, set this value to 2.

 l In the Hold field, enter the amount of frames each exposed animation frame should take.

 l If you want the animation to cycle, check the Cycle checkbox and enter enter the amount of 
times the animation should repeat in the corresponding field.

 l If you want the animation to stop at a specific frame rather than at the end of the selection, 
check the End Frame checkbox and enter the number of the embedded animation frame at 
which to stop the animation.

 7. Click on OK or Apply.

The animation of your 3D model will play out in the selected frames. 
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3D Object Manipulation & Animation
Once you have imported the 3D model into your scene, you can easily manipulate it to set up your scene. You 
can even add keyframes, just like any other element, and animate it on a trajectory.

Using Peg Nodes to Control the Position of 3D Objects

You can use Peg nodes to control the position of 3D objects, and connect them as you would with 2D layers to 
create rigs. 

Using Transformation Tools to Manipulate 3D Models

Once the 3D option is enabled, your transformation tools automatically become 3D transformation tools. This 
means you can now manipulate them on the Z-axis as well. The Translate , Rotate  and Scale  tools 
are found in the Advanced Animation toolbar and the Transform  tool can be found in the Tools toolbar. You 
can use these tools to set up or animate your 3D model. 

You can also set up all these position parameters using the Layer Properties window—see About 3D 
Parameters.

NOTE 

Just like with 2D layers, if you're setting up the initial position of your 3D models, you should set the 
Animate mode to  Animate Off in the Tools toolbar, then set it back to  Animate Current 
Frame when you're ready to animate.
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About 3D Objects in Different Views
Before you can properly view and set up the 3D element in your scene, you will need to use the Perspective 
and Camera views together, as well as the Top and Side views. 

TIP 

Using the Depth View mode can also be a useful tool when setting up 3D objects, see—Using the 
Depth View Mode on page 969.

567

Harmony 21 Premium User Guide                          



Chapter 20: 3D Integration

About 3D Objects in the Perspective View

In the Perspective view, you can see your scene in a complete 3D environment. In this environment, you can set 
up and animate your 3D model more easily. You can rotate the view on the three axes by holding down Ctrl + 
Shift (Windows/Linux) or ⌘  + Shift (macOS), and clicking and dragging.
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About 3D Objects in the Camera View

You can preview the position of your 3D model in the Camera view and see what it will look like in the camera 
frame. You can preview your scene in  OpenGL  mode.

You can view your 3D objects in Render  mode, but only basic settings will be used to render the 3D 
element. To get a fully textured and lit render, you can use Autodesk Maya. If you want to render using your 3D 
objects using Maya as a background process, before you can view your 3D elements in Render  mode, you 
must add a Maya Batch Render node to your Node view and set up your system with the correct path to the 
rendering utility you will be using. Note that you will need to add your Maya project inside the 3D object's 
element folder in your Harmony scene. If you do not complete this setup, the 3D model will simply not 
appear—see 3D Rendering in Harmony.

If you want to override the order of your 2D and 3D elements to follow the Composite node ordering rather 
than the Z-axis order, you can use the Flatten node—see the Reference guide .
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About 3D Objects in the Top and Side Views

The Top and Side views help you position your element in the 3D environment. This can be really helpful for 
precisely visualizing the actual position of your model without perspective.
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About  Translate Tool 3D Manipulation
Once you enable the 3D option, the 3D Translate tool becomes available. Direction arrows appear around the 
pivot points to indicate the different axes.

If you click on a direction arrow, you can move a layer on only one axis. If you click anywhere else, the layer can 
move freely on two axes at once. Once the arrow is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have 
the optimum point of view on your stage to understand the setup. In this case, it is best to use the direction 
ellipses.
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About Rotate Tool 3D Manipulation
Once you enable the 3D option, the 3D Rotate tool becomes available. A rotation sphere appears around the 
pivot points to indicate the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at the same time. When the ellipse is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have 
the optimum point of view on your stage to understand the setup.
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About Scale Tool 3D Manipulation
Once you enable the 3D option, the 3D Scale tool is available. You will see one of two things:

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the 
different axes. If you click and drag on this scaling cube, it will scale proportionally on all axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the 
object proportionally. When the control point is selected, it turns pink.
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About Transform Tool 3D Manipulation
Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D 
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Transform  tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate  tool.
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To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.

If you click and drag on the scaling cube, it will scale proportionally on all axes.
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Manipulating and Animating 3D Object Subnodes
A 3D model can be rigged so that different parts of it, referred to as subnodes, can be subjected to their own 
geometric transformations. 

Using the 3D Graph view, you can see the list of subnodes available for the selected 3D model. Each subnode 
represents a part of the 3D model that can be transformed and animated independently, or even hidden. Like 
with peg hierarchies, subnodes that are children of other subnodes will be transformed along with their 
parents. If you select a subnode in the 3D Graph view, it will be highlighted in the Camera view, and the 
Transform tool will be set to manipulate that subnode rather than the whole 3D model. 

NOTE 

To learn more about the 3D Graph view, see the Reference guide .

You can also visually select a subnode in a 3D model by holding Ctrl (Windows/Linux) or ⌘  (macOS) and 
clicking on a part of the model in the Camera view. The corresponding subnode will be selected.

When a subnode is selected, you can transform it using the Transform  tool the exact same way you would 
transform the whole 3D object—see 3D Object Manipulation & Animation on page 566.

If you make a transformation on a 3D model subnode directly, this transformation will be static. In order to 
animate a 3D model subnode, you must connect the 3D object's node to a Subnode Animation node, which will 
store the animation information for each of the model's subnodes that you animate. In both cases, the 
transformations and animations done on 3D model subnodes will appear in the final render, even if the model 
is rendered through Autodesk Maya.

It is also possible to rig an element in the scene to follow the animation of one of the subnodes of a 3D model. 
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IMPORTANT 

If your 3D model has been imported in Harmony scene through a template or scene that has been 
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been 
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra 
subnodes that are not in the original Maya project. This might cause errors with the position and 
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import 
the original 3D model file in your Harmony scene before animating it. 
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Disabling Subnodes
To hide parts of a 3D model, you can disable their corresponding subnodes in the 3D Graph view. This will also 
hide all their children.

How to disable subnodes

 1. In the 3D Graph view, select one or multiple subnodes. 

 1. Do one of the following:

 l In the 3D Graph view toolbar, click on the Disable Subnode  button.

 l Open the 3D Graph view menu  and select Subnodes > Disable. 

The subnode is disabled. It appears dark red in the 3D Graph view. Its children appear dark grey to 
indicate that they are not disabled, but that they are children of a disabled subnode.
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In the Camera or Perspective view the corresponding part of the 3D model is hidden.
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Enabling Subnodes
Disabled subnodes are invisible. To make them visible again, you can enable them in the 3D Graph view.

How to enable subnodes

 1. In the 3D Graph view, select one or several disabled subnodes. Disabled subnodes will display in 
dark red, and their children will display in dark grey. 

 1. Do one of the following:

 l In the 3D Graph view toolbar, click on the Enable Subnode  button.

 l Open the 3D Graph view menu  and select Subnodes > Enable. 

The subnode and its children are enabled. 
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In the Camera or Perspective view the corresponding 3D model part is displayed.
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Animating Individual Parts of 3D Models
A typical 3D model is comprised of several parts (subnodes) that can be transformed independently. By 
default, transformations made on 3D model subnodes are static. If you need to animate the subnodes of a 3D 
model, you need to connect the 3D model to a Subnode Animation node. This node will store the keyframes for 
each subnode that you animate and will also make them available in the Timeline view. 

IMPORTANT 

If your 3D model has been imported in Harmony scene through a template or scene that has been 
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been 
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra 
subnodes that are not in the original Maya project. This might cause errors with the position and 
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import 
the original 3D model file in your Harmony scene before animating it. 

How to animate a part of your 3D model

 1. In the Node Library view, select 3D in the sections list and locate the Subnode Animation node. 
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 2. Drag and drop the Subnode Animation node from the Node Library into the Node view.

 3. In the Node view, connect the Subnode Animation node under the element node of your 3D model.

The Subnode Animation node automatically appears in the Timeline view, under the layer of the 3D 
model.

 4. In the Timeline view, select the frame where you want your first animation keyframe to be created.                     

 5. In the Tools toolbar, select the Transform tool .
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 6. Do one of the following:

 l In the Camera or Perspective view,  click on your 3D model once to select the whole object, 
then click again on the part you wish to animate to select it. 

 l In the 3D Graph view, select the subnode you wish to animate.

 1. Use the Transform tool to move, rotate or scale the individual part.

 2. The subnode appears in the Timeline view.
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 3. In the Timeline view, expand the subnode layer to view its properties.

A keyframe appears in the first frame, recording the movement that was just made.

 4. Continue adding keyframes and making changes to the properties values to animate the individual 
part of the 3D model.
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Adding the Subnodes to the Timeline View
When you animate a subnode using a Subnode Animation node, the subnodes you animate will be 
automatically added to the parameters of the Subnode Animation in the Timeline view, allowing you to 
manipulate its keyframes, and the parameters of subnodes that are not animated will remain hidden.

However, there might be situations where you want to add subnodes to the Timeline view before animating 
them. For example, if you want to create a keyframe for a subnode in its default resting position, or if you want 
to prepare a scene for an animator and only make subnodes that are intended to be animated visible in the 
Timeline view. This is possible using the 3D Graph view. 

IMPORTANT 

If your 3D model has been imported in Harmony scene through a template or scene that has been 
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been 
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra 
subnodes that are not in the original Maya project. This might cause errors with the position and 
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import 
the original 3D model file in your Harmony scene before animating it. 

How to make properties available in the 3D Graph view

 1. In the Node Library view, select 3D in the sections list and locate the Subnode Animation node. 

 2. Drag and drop the Subnode Animation node from the Node Library into the Node view.
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 3. In the Node view, connect the Subnode Animation node under the element node of your 3D model.

The Subnode Animation node automatically appears in the Timeline view, under the layer of the 3D 
model.

 4. In the 3D Graph view, select a subnode that you intend to animate.

 5. Do one of the following: 

 l In the 3D Graph view toolbar, click on the Make Properties Available  button.

 l Open the 3D Graph view menu  and select Insert > Make Properties Available. 

The subnode appears in the Timeline view.
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 6. In the Timeline view, click on the Expand  button left of the subnode to display its parameters.
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Applying the Animation of a 3D Subnode to an Element
It is possible to apply the animation on a 3D model's subnode onto other elements such as 2D layers, pegs or 
other 3D models in the scene, making the subnode act like parent peg to these elements. This can be 
especially useful of a decal or an effect is meant to follow a specific part of a 3D model. 

How to automatically setup 3D Kinematic Output nodes with your system

 1. Do one of the following:

 l In the Camera or Perspective view, using the Transform  tool, click on the 3D model to 
select it, then on the part of the 3D model that you want to rig to another element to select 
its subnode.
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 l In the 3D Graph view, select the subnode which you want to rig to another element. 

 2. Do one of the following: 

 l In the 3D Graph view toolbar, click on the Add 3D Kinematic Output   button.

 l Open the 3D Graph view menu  and select Insert > 3D Kinematic Ouput. 

A 3D Kinematic Output node appears in the Node view, connected under the 3D Model's Subnode 
Animation node. The 3D Kinematic Output node is named after the subnode, followed by -Output.

An asterisk appears right of the name of the subnode in the 3D Graph view, to indicate the 
connection of the 3D Kinematic Output node.
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 3. In the Node view, connect the output port of the 3D Kinematic Output node to the input port of the 
element that should follow the subnode's movement. In this example, the layer fire will follow 
the movement of the shell_37_Key subnode.

Any transformations made to the 3D model subnode will now also be applied to the drawing.
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3D Rendering in Harmony
In order to properly render 3D models in Harmony scenes, the scene as well as your workstation must be 
configured to allow rendering the model through Autodesk Maya. This is required to render the 3D models 
with the same rendering quality as originally intended. Otherwise, Harmony will use OpenGL to render the 3D 
model, which might not give the expected results.

To perform this render, Harmony uses the original Autodesk Maya project, to which it applies the 
transformations done on the model and its subnodes inside the scene, and sends it to Autodesk Maya for 
rendering. Then, it takes the rendered image and composites it with other elements in the scene to create the 
full image. This works just as well when outputting the final rendering images as when switching to Render 
Preview mode in the Camera view.

Autodesk Maya can render using its own rendering engine or third party renderers. Likewise, Harmony can 
make Autodesk Maya perform the render using different rendering engines. Specifically, the following engines 
are supported by Harmony:

 l Maya

 l Mental Ray

 l Renderman Reyes

 l Renderman RIS

 l Arnold

NOTE 

It is recommended to use either Renderman or Arnold to render 3D objects through Autodesk 
Maya, as those rendering engines will return deep texture images, which can be composited 
relative to other elements in your scene with antialiasing. When using other rendering engines, 
3D models that clip with elements in your scene may have a hard pixelated seam at their 
intersection.

For rendering through Autodesk Maya to work, the following conditions must be met:
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 l Autodesk Maya—and of the rendering engine, if not Autodesk Maya—must be installed and activated 
on the workstation performing the render.

 l The path to Maya must have been set in Harmony's local preferences on the workstation performing the 
render.

 l If rendering using the Renderman engine, the path to Renderman must have been set in Harmony's 
local preferences on the workstation performing the render. 

 l A copy of the original Maya project file, along with all its texture files, must be in the element folder 
where the imported 3D model is located, with the same file name as the imported 3D model, but with 
the Maya project file extension (.ma or .mb).

 l A Render Maya Batch node must be connected under the 3D model in the Node view and, optionally, 
configured to select a specific rendering engine.

The following topics will detail how to achieve this configuration.

NOTE 

The Render Maya Batch node outputs a bitmap to your scene's node system. You can apply bitmap 
effects to the rendered image. 
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Setting 3D Renderer Paths
In order to render 3D models through Autodesk Maya, you must configure Harmony with the installation path 
to Autodesk Maya. 

If your 3D models are to be rendered using the Renderman engine, you must also configure Harmony with the 
installation path to Renderman. This is because Harmony needs to use Renderman to read the images output 
by the Renderman engine, which are in Deep Texture (.dtex) format. If you are using any other rendering 
engine, this step is not required. 

NOTE 

If you are using Harmony Server, note that this preference is stored on your workstation, not in your 
database user account. This is because Autodesk Maya and Renderman may be installed in 
different locations on each workstation. Hence, this must be configured on each workstation that 
will perform rendering through Autodesk Maya. 

How to set 3D renderer paths

 1. Add the Scripting toolbar to your interface by doing one of the following:

 l From the top menu, select Windows > Toolbars > Scripting.

 l Right-click on any existing toolbar or on the top space of any view in your workspace, then 
select Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts button to open the Scripts Manager window.

 3. In the Files list of the Scripts Manager, select TB__Set_3dRenderer_Paths.js.
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 4. In the Functions list, select TB_Set_3dRenderer_Paths.

 5. Click on the Add  button to add the script to the Scripting toolbar. 

 6. Click OK.

 7. In the Scripting toolbar, click on the TB_Set_3dRenderer_Paths script  button.

The Set 3D Renderer Paths dialog box opens.

 8. In the Maya Installation Path section, click on the browse (...) button.

 9. In the Select Folder dialog, browse to the root installation folder of Autodesk Maya on your 
machine. For example, by default, the installation path of Autodesk Maya 2016 would be 
C:\Program Files\Autodesk\Maya2016.                                           

 10. Click on Select Folder.
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 11. If you intend to use the RenderMan engine, click on the browse (...) button in the RenderMan 
Installation Path section.

 12. In the Select Folder dialog, browse to the root installation folder of Autodesk Maya on your 
machine. For example, by default, the installation path of RenderMan Studio 20.2 for Autodesk 
Maya 2016 would be C:\Program Files\Pixar\RenderManStudio-20.2maya2016.                                           

 13. Click on Select Folder.

Harmony can now communicate with Autodesk Maya and, if needed, RenderMan.
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Connecting the 3D Model to the Renderer
At last, to render a 3D model using Autodesk Maya, you must connect the element node containing the 3D 
model to a Maya Batch Render node. The Maya Batch Render node will take the 3D model as its input, render 
it through Autodesk Maya, then composite the rendered image into the scene. The 3D model as rendered by 
Autodesk Maya will appear in both the final rendered image and in the Render Preview  mode of the 
Camera view.

TIP 

When rendering using a 3D renderer, you can start Harmony from a command line terminal and to 
display the Message Log view in your workspace. This will allow you to see the information 
Harmony outputs about the rendering process, which could be useful to debug the process if any 
problem occurs.

How to connect the 3D model to the rendering engine

 1. In the Node Library view, select 3D in the sections list and locate the RenderMayaBatch node. 

 2. Drag and drop the Maya Batch Render node from the Node Library into the Node view.

 3. In the Node view, connect the Maya Batch Render node under the node of the 3D model. If the 3D 
object is connected to a Subnode Animation node, connect the Maya Batch Render node under the 
Subnode Animation node instead.
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 4. Repeat the previous steps for each 3D model node in your scene.

 5. In the Camera view, click the Render View  button to verify that the 3D model is rendered 
through Autodesk Maya.

NOTE 

The generation of the preview may take several seconds and make Harmony appear to 
hang for a moment. 

You are now set to render your animation project.

TIP 

You can apply effects on the rendered image by connecting effect nodes under the Maya 
Batch Render node.                 
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Copying your Maya Project to the Scene Directory
In order to allow Harmony to render 3D models using Autodesk Maya, you must include the original Maya 
project file in the element folder where the 3D model was imported, along with all its textures. The project 
must be renamed to have the same file name as the imported 3D model, so that Harmony can locate it and 
send it to Autodesk Maya for rendering.

Harmony will take the transformations done on the imported 3D model and its subnodes, and apply them to 
the model in the original Maya project so that it is rendered with the animation done in Harmony. Hence, the 
imported 3D model must be in the same size and position as the model in the Maya project. However, it is 
possible to use a 3D model with lower resolution textures or no textures at all, as well as less detail in the 
geometry, in the Harmony scene, to help with performance when manipulating the 3D model in Harmony. This 
will not affect the rendered image, as the original Maya project will be used to render the scene.

TIP 

If you prefer, you can skip this step and make your scene render your Maya project from its original 
location on your machine—see Linking a Maya Batch Render Node to an External Maya Project.

How to set up rendering

 1. In a file browser, locate and copy the original Maya project file along with all its textures. The 
extension of the project file should either me .mb or .ma.

 2. Browse to the folder of the scene's element in which the 3D model was imported. This folder 
should be located in the scene's root folder, in the elements subfolder. For example, if your scene 
is located in C:\Documents\MyScene and the element is named LR_ship, the element folder 
would be located in C:\Documents\MyScene\elements\Ship.

The 3D model that was imported in the Harmony scene should be located in this folder. 
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 3. Paste the Maya project files and its textures in the element's folder. 

 4. Rename the Maya project file to have the same file name as the imported 3D model file, but 
preserve its file extension. For example, if the imported 3D model is named Ship-1.fbx and your 
Maya project file is named pirateship.ma, rename the Maya project to Ship-1.ma. 

 5. Harmony will now be able to use Maya project file when attempting to render the 3D model. 
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Selecting a Rendering Engine
By default, when rendering a 3D model through Autodesk Maya, the model will be rendered using the 
rendering engine its Maya project file is configured to use. However, it is also possible to select which 
rendering engine to use by selecting it in the layer properties of the Maya Batch Render node. It is important to 
always use the rendering engine the model was intended to be rendered with. 

Harmony supports the following rendering engines:

 l Maya

 l Mental Ray

 l Renderman Reyes

 l Renderman RIS

 l Arnold

NOTE 

It is recommended to use either Renderman or Arnold to render 3D objects through Autodesk 
Maya, as those rendering engines will return deep texture images, which can be composited 
relative to other elements in your scene with antialiasing. When using other rendering engines, 
3D models that clip with elements in your scene may have a hard pixelated seam at their 
intersection.

IMPORTANT 

The selected rendering engine must be installed on the workstation on which Harmony is 
rendering the scene, or the model will not be rendered and will be invisible in the rendered image. 
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How to select the rendering engine for a 3D model

 1. In the Node view, locate the Maya Batch Render node, and click on its Layer Properties button.

The Layer Properties dialog for the Maya Batch Render node appears.

 2. In the Attributes tab, in the Renderer field, enter one of the following values, depending on which 
rendering engine you wish to use:

 l Maya's native rendering engine: mayasoftware or maya

 l Renderman (Reyes): renderman, rendermanreyes or reyes

 l Renderman (RIS): rendermanris or ris

 l Arnold: arnold

 3. Click on Close.

 4. In the Camera view, click on the Render View  button.

The 3D model will now be rendered in the newly selected rendering engine.
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Linking a Maya Batch Render Node to an External Maya Project
If you prefer to keep the Maya project used to render the 3D model in its original location, you can configure 
your Maya Batch Render node to render the Maya project from its original location rather than from the 3D 
model's element directory in the scene. This is done in two  steps:

 1. Adding the Original Maya File Name field to the layer properties of your Maya Batch Render node.

 2. Typing the path to the Maya project in the Original Maya File Name field. 

NOTES 

 l If you link your Maya Batch Render node to an external Maya project, you will need the Maya 
project to remain in this location for your scene to render properly. This means you will be 
unable to render the 3D model in your scene if you try render it from a different computer, or if 
you move or delete the Maya project. 

 l This procedure is entirely optional and is more technical than the default approach, which is to 
copy the 3D model in the element folder of your 3D model. If you prefer to go with the more 
simple method, see Copying your Maya Project to the Scene Directory

How to add the Original Maya File Name field to the layer properties of the Maya 
Batch Render node

 1. In the Node View, locate the MayaBatchRender node, and click on its Layer Properties button.

The Layer Properties dialog for the Maya Batch Render node appears.

 2. Click on the Specifications tab. 

In the Specifications field, an XML script defines the input ports, output ports and attributes of the 
Maya Batch Render node. 
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 3. Copy the line below:

    <attr type="string" name="OriginalMayaFileName" value="" tooltip="Write your project path here"/>

 4. Paste it right above the </attributes> line:

You have now added the OriginalMayaFileName attribute to the Maya Batch Render Node. 
However, you will not see it in the Attributes tab right away.

 5. Save your scene, close it and re-open it. Afterwards, the OriginalMayaFileName property will be 
visible in the Attributes tab of the Maya Batch Render node's layer properties, right under 
renderer.

How to link the Maya Batch Render node to your original Maya project

 1. In the Node View, locate the MayaBatchRender node, and click on its Layer Properties button.

The Layer Properties dialog for the Maya Batch Render node appears. The OriginalMayaFileName 
field should appear under the renderer field. 

 2. In the Attributes tab, select the OriginalMayaFileName field. 
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 3. Type in the path to the Maya project containing your 3D model. You must type the path to the 
directory as well as the name of the project file, including its extension. Whether you are using 
Windows, macOS or GNU/Linux, you must use forward slashes (/) to separate the directories.

For example, if your Maya project is stored in a folder named MayaProject in your Documents 
folder and is named MayaProject.ma, and your username is username, you would type the 
following location to point to it:

 l On Windows: C:/Users/username/Documents/MayaProject/MayaProject.ma

 l On macOS: /Users/username/Documents/MayaProject/MayaProject.ma

 l On GNU/Linux: /home/username/Documents/MayaProject/MayaProject.ma

Optionally, you can type in a relative path. The path is relative to the specific element folder of your 
3D model, which is in a folder named elements inside your scene folder. So, for example, if you 
want to store your 3D models in a folder named 3dmodels inside your scene folder, you can type in 
the following relative path:

../../3dmodels/MayaProject.ma

In a relative path, two consecutive periods (..) refer to the parent folder. So, by referring to the 
parent folder of the parent folder of the 3D model's elements folder, you get to the scene folder.
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Adjusting the Antialiasing of a Rendered 3D Model 
Rendering engines such as Maya and Mental Ray output images in a format that uses a simple Z-buffer that 
does not allow for proper antialiasing around the edges of the geometry. Hence, it is ultimately better for 
image quality to render using RenderMan or Arnold if possible. Otherwise, if a different rendering engine must 
be used and there appears to be pixelated hard seams around 3D models, the Z Buffer Smoothing node can be 
used to smooth out the edges of the rendered model.

How to use the Z Buffer Smoothing 

 1. In the Node Library view, select 3D in the sections list and locate the Z Buffer Smoothing node. 

 2. Drag and drop the Z Buffer Smoothing node into the Node view.

 3. In the Node view, connect the Z Buffer Smoothing node under the MayaBatchRender node of the 
3D model.

 4. Click on the Layer Properties button of the Z Buffer Smoothing node to open its Layer Properties 
dialog. 

608



 5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your 
Maya models. In most cases, you will have to experiment with a balance between the histogram 
range and the kernel size to obtain the best result. 
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Chapter 21: Rendering & Exporting 
Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to 
further edit your movie using a third party software, composite the movie in a larger body of work or put it up 
directly on the web, Harmony supports several formats for all your rendering needs.

NOTE 

The different editions of Harmony support the following maximum render resolutions:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited
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About  Rendering Write Nodes
When you render a scene in Harmony, what is actually rendered is what is connected to your scene's Write 
node. Rendering a scene's Write nodes is the main way to export a scene into image and movie files for post 
production. 

The Node view allows you to branch out and merge elements of your scene in specific ways. By default, a scene 
has a Write node connected to its main composite, meaning all of the scene's elements are rendered. However, 
a Write node can be connected to any node in your scene that outputs image information, even a drawing or 
an effect. A scene's renders are based on the image information that is sent to its Write node, and nothing 
else. Hence, you can control exactly what gets rendered, which is especially useful if you want to have 
elements in your scene that are only visible in the Camera view, such as a storyboard overlay or a camera 
guide, without having them appear in the renders. 

You can also set up a scene to create multiple renders by connecting several Write nodes to it. Your Write 
nodes can be connected  to different elements of your scene, which allows you to create separate renders for 
different parts of your Node view every time your scene is rendered. For example, a scene can have a Write 
node for rendering the scene without any annotations, so that render can be used in post production, and 
another one for rendering the scene with its storyboard and annotations for reviewing. A scene can also have 
multiple Write Nodes connected to the same composite, which can allow you to render the same image in 
multiple file formats or locations at the same time.

Each Write node can be configured to export individual frames as image files, a video file, or both 
simultaneously.
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Adding Write Nodes
The Write node lets you render and output connected image information.

How to add a Write node

 1. In the Node Library, select the Output from the list of categories.

 2. Select the Write node and drag it to the Node view.

 3. In the Node view, connect the final Composite node or any other node which outputs an image you 
want to render to the Write node.
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Exporting Image Sequences from the Node View
To export an image sequence, you must to adjust a few settings in the Write node’s properties. The most 
important one is the Drawing Type parameter, which determines the image format in which individual frames 
are exported.

How to configure the Write node to export an image sequence

 1. In the Node view, open the Write node’s editor by clicking its square yellow properties button.

 2. In the Output tab, select the Drawing option to create an image sequence.

 3. Click Choose and browse to the directory where you want to save the output. You can also type in a 
directory name, which will be created in your scene's directory, or click on Default to export your 
frames in your scene's  frames subdirectory.

 4. In the Drawing Filename field, type the image sequence’s name prefix. It is recommended to leave 
the hyphen (-) at the end of the name to separate the image name from the image number.

613

Harmony 21 Premium User Guide                          



Chapter 21: Rendering & Exporting

 5. In the Colour Space drop-down, select the colour space in which you want the rendered frames to 
be exported—see About Colour Space Management on page 777.

 6. In the Start field, select the starting number for the image sequence.

 7. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.

 8. In the Drawing Type field, select the file format in which your project will output.

NOTES 

 l A lot of formats are listed as their file extension, but some also have suffixes to 
indicate how they are encoded. For example, PNGDP4 means PNG: double precision 
with 4 channels, which means the exported PNG images will have 16 bits per 
channel instead of 8 bits, and will also have an alpha (transparency) channel. 

 l For more information on supported export formats, refer to the Reference Guide.
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 9. Click Close.

NOTE 

The project will not start rendering at this point. This step only configures how your 
scene will be rendered.
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Exporting Movie Files from the Node View
To export a QuickTime movie, you need to adjust few settings in the Write node’s properties.

How to configure the Write node to export a movie file

 1. In the Node view, open the Write node’s Layer Properties by doing one of the following:

 l Click on the yellow square  at the left end of the Write node.

 l Right-click on the Write node, then select Layer Properties.

 2. In the Output tab, select the Movie option to create a movie file.

A Movie Folder and Movie Filename field appear among the Drawing Folder and Drawing 
Filename fields.

 3. In the Colour Space drop-down, select the colour space in which you want the movie to be 
exported—see About Colour Space Management on page 777.

 4. Right to Movie Folder, click Choose and browse to the directory where you want the movie file to 
be exported.

You can also click on Default to set the output directory to frames. This will export the movie to 
your scene's frames subdirectory. 

 5. In the Movie Filename field, enter the desired name of the movie file to be exported, without its 
extension.

 6. In the drop-down right of the Movie checkbox, select one of the following export types:

 l QuickTime ProRes Movie (*.mov): The Apple QuickTime format. This is the default 
export format and is recommended for its portability, and also because it allows you to 
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choose among several video codecs.

NOTES 

 l On Windows, Apple QuickTime must be installed to allow Harmony to 
export QuickTime movies. You can configure the export of QuickTime 
movies to use any codec that is compatible with QuickTime, including 
H.264, MPEG-4 and Animation.

 l On macOS, Harmony uses Apple AVFoundation to export QuickTime 
movies, which allows you to export using codecs such as H.264, Apple 
ProRes 422 and Apple ProRes 4444, among others.

 l If you are looking to export a QuickTime movie with transparency, be 
sure to choose a codec that supports encoding with an alpha channel.

 l On GNU/Linux, Harmony uses the OpenQuickTime library to export 
QuickTime movies. This only allows you to export videos in non-
proprietary formats such as Motion-JPEG, Photo JPEG, PNG or 
Uncompressed (RGB).

 l H.264/MPEG-4                      (*.mov)                    : A simple movie format that uses the H.264 codec, which is 
supported by most web browsers.

NOTES 

 l Using this format does not require additional software. However, if this 
is the first time you export a movie in H.264/MPEG-4 format, you will 
be prompted to download the OpenH264 library from Cisco. Simply 
click Yes when prompted, and Harmony will automatically download 
the library, then export the movie. 

 l There are no encoding options for this format. 

 l This format supports resolutions of up to 4096×2304. Each dimension 
must be a multiple of 16 pixels. 

 l Audio exported in this format is encoded in PCM 16-bit stereo, 22.05 
kHz.

 l Windows Media Video (*.wmv): The native format for Windows Media Player.
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NOTES 

 l Windows Media Video (.wmv) files can only be exported on Windows. 

 l Video players and editors on non-Windows systems can generally not 
open Windows Media Video (.wmv) files.

 7. If you want to configure the video and audio compression settings for the movie to be rendered, click 
on the Customize button next to Movie Options.

NOTES 

 l For information on how to configure movie settings for a QuickTime Movie 
(.mov), see:

 l Windows: Configuring Movie Settings for QuickTime Movies on Windows 
on page 638

 l macOS: Configuring Movie Settings for QuickTime Movies on macOS on 
page 642

 l GNU/Linux: Configuring Movie Settings for QuickTime Movies on 
GNU/Linux

 l For information on how to configure the movie settings when exporting in 
Windows Media Video (.wmv) format, see  Configuring Movie Settings for 
Windows Media Video.

 l When exporting in H.264/MPEG-4 (.mp4) format, there are no video and 
audio compression settings.

 l If you are using GNU/Linux and are exporting in QuickTime Movie (.mov) 
format, there will be a button for the Video Options and one for the Sound 
Options.
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IMPORTANT 

If you are using Harmony Server, and not all the machines in your database's render farm use 
the same operating systems as the one you are currently using, you should make sure the 
machines that will render your scene are compatible with your movie format and movie 
options. Specifically, look out for the following exception cases:         

 l If you configure a Write Node to export in QuickTime Movie format and render the scene on 
a Windows machine that does not have Apple QuickTime installed, no movie will be 
rendered.

 l If you configure a Write Node to export QuickTime movies on one platform and render it on 
a different platform that supports exporting QuickTime movies, the default video and audio 
compression settings for QuickTime Movie (.mov) files on that platform ill be used.

NOTE 

The project will not start rendering at this point. This step only configures how your scene will be 
rendered.
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About Multiple Renders
Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a lot of time as 
you do not have to return between each render to start a new one.

To use multiple renders, connect as many Write nodes as needed to match the required number of exports. 
Then, adjust each Write node’s settings to create image sequences or movies.

NOTE 

Each Write node must be configured to export with different file names or in different locations. If 
one Write node is configured to export images or a movie file with the same file name as with 
another Write node, one will overwrite the other. 

When you have multiple Write nodes in a scene, it is useful to rename the nodes according to their output 
settings such as: low_resolution_movie or HDTV_sequence.

To export different resolutions concurrently, you need to create a combination of the following:

 l Write node

 l Scale-Output node

 l Crop node

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to NTSC, you 
will need to combine the Crop node with a Scale Output node.

Once you know the type of render you want to do, you will need to retrieve your nodes from the Node Library 
and connect them to the scene’s network. 
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Adding Multiple Write Nodes

Harmony allows you to render multiple exports simultaneously. For example, you can export a version of your 
project, a full high-res version and an image sequence with a transparent background all at the same time.

How to connect nodes to export multiple renders

 1. In the Node Library view, retrieve the necessary Write, Scale-Output and Crop nodes.

 2. Connect the final Composite node to the first Write node. (Make sure you have a Display node 
reading the same information.)

 3. Open the Write node’s editor by clicking on its square yellow properties button.

 4. Name the Write node according to the render type that you are planning to do.

 5. Configure the Write node's parameters—see Exporting Image Sequences from the Node View on 
page 613 and Exporting Movie Files from the Node View.

 6. Connect the other Write nodes and repeat steps 2 to 5.
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 7. Using the Alt key, insert the Scale-Output nodes between the final Composite node and their 
corresponding Write node.

 8. Using the Alt key, insert the Crop nodes between the final Composite node and their 
corresponding Write or Scale node.

 l If the output from the Crop node has to be scaled down, use a Scale-Output node.
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 9. Connect a Display node to each Scale-Output or Crop node to see each final image in the Camera 
view.
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Setting Up Scale-Output Nodes

Once your Write nodes are connected, if you want one of your renders to be smaller than your scene's 
resolution, but have the same aspect ratio and contain the same camera frame, you can use the Scale-Output 
node to shrink the image output by your scene's composite before it reaches the Write node. 

You can use a Scale-Ouput node in conjunction with a Crop node to produce a render that is in a different 
resolution and aspect ratio than your scene's. For example, if you want a scene in HD 1080p to render in NTSC, 
you can use the Scale-Output node to scale down the image to 960 x 540 pixels, which matches the NTSC 
resolution height, but has a greater resolution width to preserve the aspect ratio of HD 1080p. Then, you can 
use a Crop node to crop the image to 720 x 540 pixels, cropping out the image in the left and right edges to 
make it fit an NTSC screen. 

NOTE 

If you use a Scale-Output node to scale up the image, it will look pixelated. If you want to export a 
scene in multiple resolutions, you should set your scene's resolution to be the highest resolution in 
which you want to render, and use Scale-Output nodes to scale down the output.

How to set a Scale-Output node

 1. In the Node Library view, select Scale-Output from the list of categories.

 2. Select the Scale-Output node and drag it to the Node view.

 3. In the Node view, connect the Composite node to the Input port of the Scale-Output node.
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 4. In the Node view, connect the Scale-Output node to the input ports of both the Display node and 
the Write node.

 

 5. In the Node view, open the Scale-Output node’s editor by clicking its yellow square properties 
button.

 6. In the Layer Properties dialog box, do one of the following:

 l Under Customer Resolution, type in the Width and Height of the resolution you 
want to scale to, in pixels.
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 l Uncheck the Custom Resolution option, then choose one of the available resolution 
presets in the Resolution Name drop down list.

 7. Click Close.
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Setting Up Crop Nodes

Once your Write nodes are connected, if you want one of your renders to be in a different aspect ratio than 
your scene's, you can use the Crop node. For example, if you want a scene with an aspect ratio of 16:9 to 
produce a render in 4:3, you can use a Crop node to crop out the image on the left and right edges of the 
camera frame. 

You can use a Scale-Ouput node in conjunction with a Crop node to produce a render that is in a different 
resolution and aspect ratio than your scene's. For example, if you want a scene in HD 1080p to render in NTSC, 
you can use the Scale-Output node to scale down the image to 960 x 540 pixels, which matches the NTSC 
resolution height, but has a greater resolution width to preserve the aspect ratio of HD 1080p. Then, you can 
use a Crop node to crop the image to 720 x 540 pixels, cropping out the image in the left and right edges to 
make it fit an NTSC screen. 

How to set a Crop Node

 1. In the Node Library view, select Output from the list of categories on the left.

 2. Drag the Crop node to the Node view.

 3. In the Node view, connect the Composite node to the Input port of the Crop node.

 4. In the Node view, connect the Crop node to the input ports of both the Display node and the Write 
node.
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 5. In the Node view, open the Crop node’s property editor by clicking the yellow square properties 
button.

 6. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

 7. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display 
node in the Display toolbar. In the Advanced Animation toolbar, select the Translate  tool and 
with the middle mouse button, move the crop area. If the Animate mode of the Tools toolbar is set 
to  Animate Current Frame, the position of the crop area will be animated over time.

 8. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more 
information), you can create a function to animate the cropped selection. Click the Function  
button beside the Local dialog box to create a Bezier or ease curve.

 9. If you created a function curve to animate the cropped selection, click again on the Function  
button and edit the curve by adding keyframes and moving the selection box in the Camera view.If 
you created a function curve to animate the cropped selection, click again on the Function  
button and edit the curve by adding keyframes and moving the selection box in the Camera view.
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 10. If you want to draw a frame around the area to crop instead of actually cropping the image, enable 
the Draw Frame option.

 11. If you enabled the Draw Frame option, click on the colour rectangle to open a Colour Picker dialog 
and adjust the colour of the frame to draw.

 12. If you wish to only use this Crop node when rendering your scene at specific resolution, click on the 
Enabling tab.
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 13. Do one of the following to configure when your Crop node should be used for rendering:

 l Select Always Enabled if your Crop node should be enabled every time the scene is 
rendered.

 l Select Enabled when resolution name is if you want your Crop node to only be 
enabled when rendering your scene in one of the available resolution presets. Then, 
in the Filter name drop down list, select the resolution preset at which your scene 
must be rendered for the Crop node to be enabled.

 l Select Enabled when resolution isif you want your Crop node to only be enabled 
when rendering your scene at a specific resolution. Then, in the X resolution and Y 
resolution fields, type in the width and height of the resolution at which your scene 
must be rendered for the Crop node to be enabled, in pixels. 

 14. Click Close.
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Rendering from Write Nodes
Once your Write nodes are properly set up, you can render them using the Render Write Nodes dialog. 

How to render the scene's Write nodes

 1. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (macOS).

The Render Write Nodes dialog appears.

NOTE 

If you are using Harmony Server, the Render Write Nodes dialog will have a Batch 
Composite Options section. Enabling this option will send your scene to batch 
rendering instead of rendering it locally. Simply disable this option and follow the steps 
below. For information on how to use Batch Composite Options, see Batch Rendering.

 2. In the Range section, select the frame range to render by doing one of the following:

 l If you want to render all the frames in your scene, select All Frames.

 l If you want to render a specific sequence of frames, select Selected Frames then, in 
the fields to the right, enter the number of the first and last frame of the frame 
sequence you wish to render.

 1. If your production is intended for broadcasting on NTSC compatible televisions, enable Field 
Composite Options.

 l To export a scene animated at 24 frames per second in 60 frames per second so that 
the frames can be combined with the 3:2 pulldown technique, enable the Add 
Pulldown option. 

 l If you want Harmony to automatically interlace the exported frames to create a 30 
frames per second sequence, enable the Automatic Combine option.
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 l By default, odd frames are interlaced on the first field (odd lines), and even frames are 
interlaced on the second field (even lines). If you wish to interlace odd frames on the 
second field and even frames on the first field, enable the Second Field First option.

 2. Enable the Preview option to automatically preview the exported image sequence in Play once the 
render is done. 

 3. Click OK.

Harmony begins rendering the scene's Write nodes.

If you enabled the Preview option, the exported images will load in Play once the render is done. 
You can user Play to play the image sequence with the scene's soundtrack. 
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Exporting a Movie File
T-HFND-010-013

Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export 
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your 
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space. 
Depending on the format in which you export your movie, you can also customize the video and audio 
compression settings for quality or for disk space. 

If you added burn-in information to your scene, it will be included in your exported file—see the Reference 
guide .

How to export a movie file

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. In the Output section, open the Video Format drop-down and select the desired format for your 
movie file:

 l QuickTime ProRes Movie (*.mov): The Apple QuickTime format. This is the default 
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export format and is recommended for its portability, and also because it allows you to 
choose among several video codecs.

NOTES 

 l On Windows, Apple QuickTime must be installed to allow Harmony to 
export QuickTime movies. You can configure the export of QuickTime 
movies to use any codec that is compatible with QuickTime, including 
H.264, MPEG-4 and Animation.

 l On macOS, Harmony uses Apple AVFoundation to export QuickTime 
movies, which allows you to export using codecs such as H.264, Apple 
ProRes 422 and Apple ProRes 4444, among others.

 l If you are looking to export a QuickTime movie with transparency, be 
sure to choose a codec that supports encoding with an alpha channel.

 l On GNU/Linux, Harmony uses the OpenQuickTime library to export 
QuickTime movies. This only allows you to export videos in non-
proprietary formats such as Motion-JPEG, Photo JPEG, PNG or 
Uncompressed (RGB).

 l H.264/MPEG-4                      (*.mov)                    : A simple movie format that uses the H.264 codec, which is 
supported by most web browsers.

NOTES 

 l Using this format does not require additional software. However, if this 
is the first time you export a movie in H.264/MPEG-4 format, you will 
be prompted to download the OpenH264 library from Cisco. Simply 
click Yes when prompted, and Harmony will automatically download 
the library, then export the movie. 

 l There are no encoding options for this format. 

 l This format supports resolutions of up to 4096×2304. Each dimension 
must be a multiple of 16 pixels. 

 l Audio exported in this format is encoded in PCM 16-bit stereo, 22.05 
kHz.

 l Windows Media Video (*.wmv): The native format for Windows Media Player.
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NOTES 

 l Windows Media Video (.wmv) files can only be exported on Windows. 

 l Video players and editors on non-Windows systems can generally not 
open Windows Media Video (.wmv) files.

 3. Click on the Browse button.

 4. In the Save dialog that appears, browse to the location where you want to export the movie file. 

 5. In the File name field, type in the file name you want the movie file to have.

 6. Click on Save.

 7. In the Export From Display Node drop-down, select the Display node from which you want to 
render your scene.

NOTE 

If there is no Display node in your scene, the only available option will be Display All. 
This renders all the nodes in your scene, including ones that are not connected to 
anything. You can add other Display nodes to your scene and connect them under 
specific parts of your scene to be able to render these parts only.

 8. From the Export Range section, do one of the following:

 l Select All if you want to render the entire scene.

 l Select Frames if you want to render a part of your scene. Then, in the field to the right, type 
in the first frame of the sequence you want to export, and in the other field, the last frame of 
the sequence you want to render.

 9. Open the Resolution drop-down and do one of the following:

 l Select Same as Scene Resolution if you want to export a movie with the same resolution as 
your scene.
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 l Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of 
Scene Resolution if you want to export a movie that is smaller than the resolution of your 
scene.

 l Select Custom if you want to manually set the export resolution. Then, in the Width and 
Height fields, type in the desired resolution for your movie, in pixels.

 10. In the Colour Space drop-down, select the colour space in which you want the movie to be 
exported—see About Colour Space Management on page 777.

 11. In the Options section, click on Movie Options if you want to configure the video and audio 
compression settings for the movie to export.

NOTES 

 l For information on how to configure movie settings for a QuickTime Movie 
(.mov), see:

 l Windows: Configuring Movie Settings for QuickTime Movies on Windows 
on page 638

 l macOS: Configuring Movie Settings for QuickTime Movies on macOS on 
page 642
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 l GNU/Linux: Configuring Movie Settings for QuickTime Movies on 
GNU/Linux

 l For information on how to configure the movie settings when exporting in 
Windows Media Video (.wmv) format, see  Configuring Movie Settings for 
Windows Media Video.

 l When exporting in H.264/MPEG-4 (.mp4) format, there are no video and 
audio compression settings.

 l If you are using GNU/Linux and are exporting in QuickTime Movie (.mov) 
format, there will be a button for the Video Options and one for the Sound 
Options.

 12. Click OK.

 13. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 14. Browse to the location on your computer where you exported your movie file, and double-click on it 
to view it in your video player.
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Configuring Movie Settings for QuickTime Movies on Windows
On Windows, it is possible to export QuickTime Movie (.mov) files using the libraries provided with Apple 
QuickTime.

Harmony allows you to customize the video and audio compression settings for your QuickTime movies via 
QuickTime's own configuration interface. This makes it possible to export movies using any codec that is 
compatible with the QuickTime framework.

NOTE 

To export QuickTime Movies on Windows, Apple QuickTime must be installed on your machine. 

How to configure video and sound settings for QuickTime movies on Windows

 1. Proceed to the Movie Settings dialog for the type of movie you want to export—see Exporting a 
Movie File, Exporting Movie Files from the Node View or Exporting OpenGL Frames.

 2. In the Movie Settings dialog:

 l Make sure the Video checkbox is checked.

 l If you want your movie file to have an audio stream, make sure Sound is checked.

 3. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 4. In the Compression Type drop-down, select a video compression codec. It is recommended to use 
one of the following codecs, depending on your usage scenario:

 l H.264: A very effective lossy compression algorithm that is commonly supported by web 
browsers and most media players.

 l MPEG-4 Video: A very effective lossy compression algorithm that is commonly supported by 
media players, but less so by web browsers.

 l Animation: A high quality compression algorithm that is commonly used for media 
interchange and video editing. 

TIPS 

 l You can export a video with transparency by selecting the Animation codec and 
setting the Depth setting to Millions of Colors+.

 l You can export a video with virtually lossless compression by selecting the 
Animation codec and setting Quality setting to Best.

NOTE 

The availability of certain of the compression settings described below will depend on 
the selected compression type.

 5. In the Motion section, make sure the Frame Rate drop-down is set to Current. This will ensure that 
the video's frame rate matches the frame rate of your Harmony project. 
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 6. If you set the Compression Type to H.264, make sure the Key Frames option is set to All.

 7. In the Quality section, if you set the Compression Type to Animation, select the desired colour 
depth for your video in the Depth drop-down. 

 8. In the Quality section, use the slider to choose a quality setting. 

NOTE 

The selected quality setting will impact the movie's file size.

 9. If you set the Compression Type to H.264, in the Quality section, select the encoding method:

 l Best quality (Multi-pass): This will extend the time required for the export, but optimize the 
quality of the video.

 l Faster encoding (Single-pass): This will shorten the time required for the export, but may 
sacrifice some video quality.

 10. In the Data Rate section, select Automatic to let QuickTime determine the best bit rate for your 
movie, or Restrict to to set a maximum bit rate for your movie and limit its file size. 

 11. If you set the Data Rate to Restrict to, enter the maximum bit rate, in kilobits per second, in the text 
field to the right. 

 12. If you set the Data Rate to Restrict to, in the Optimized For drop-down, select the intended 
distribution method for your movie. 

 13. Click OK.

 14. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

640



 15. From the Compressor menu, select the algorithm to use to compress the movie's audio track.

NOTE 

It is recommended to leave this setting to None, as other formats are likely to sacrifice 
audio quality for negligible savings in disk space.

 16. In the Rate field, select the desired sample rate for the movie's audio track

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you select a 
higher sample rate, your project's audio will be upsampled, which means it will take 
more disc space without increasing in quality. 

 17. Right of Size, select the desired  bit depth for the audio track. This determines the amount of 
precision used to record each wavelength in the audio track. 

NOTE 

The standard bit depth is 16-bit. If you choose 8-bit, the amount of disk space the audio 
track of your movie file requires will be halved, but the audio quality will be significantly 
lower.

 18. Right of Use, select whether you want to export audio in the Mono or Stereo channel mode. 

NOTE 

Stereo sound has a separate track for the left and right speakers, whereas mono sound 
only has a single audio track for all speakers. 

 19. Click OK.

 20. In the Movie Settings dialog, click OK.

641

Harmony 21 Premium User Guide                          



Chapter 21: Rendering & Exporting

Configuring Movie Settings for QuickTime Movies on macOS
On macOS, Harmony allows you to export QuickTime Movie files (.mov) using the Apple AVFoundation 
framework, which is pre-installed with macOS.

Contrary to Windows and GNU/Linux, Harmony uses its own user interface to let you configure the 
compression settings for QuickTime Movies on macOS. Using this interface, you can choose to export your 
movie using either the H.264, the Apple ProRes 422 or the Apple ProRes 4444 video codec. You can also 
configure the quality of the audio track, but the audio will always be exported in uncompressed PCM format. 

How to configure the video and sound settings for QuickTime movies on macOS

 1. Proceed to the Movie Options dialog for the type of movie you want to export—see Exporting a 
Movie File, Exporting Movie Files from the Node View or Exporting OpenGL Frames.

 2. In the Movie Options dialog box, click on the Codec drop-down and select one of the following 
video compression codecs:

NOTE 

The list of codecs available depends on the version of macOS being used. 

 l H.264 Legacy: A very effective lossy compression algorithm that is commonly supported by web 
browsers and media players.

 l H.265  Legacy: Same compression quality as H.264, but with a smaller compression size. This is 
useful for videos intended for the web and mobile devices. Not supported on all major browsers or 
operating systems.

 l Apple ProRes 422  Legacy: A nearly lossless compression algorithm commonly used for video 
editing on Apple systems. This codec is optimized for preserving video quality, but not for 
publishing or streaming.
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 l Apple ProRes 422 HQ  Legacy: Preserves visual quality at the same high level as Apple ProRes 
4444 but for 4:2:2 image sources (cleaner footage for things like green screening). Heavier than 
Apple ProRes 422 for real-time editing performance.

 l Apple ProRes 422 LT  Legacy: A more highly compressed codec than Apple ProRes 422, with 
roughly 70 percent of the data rate and 30 percent smaller file sizes. This codec is perfect for 
environments with limited storage capacity and data rates.

 l Apple ProRes 422 Proxy  Legacy: An even more highly compressed codec than Apple ProRes 422 
LT, intended for use in offline workflows that require low data rates but full-resolution video.

 l Apple ProRes 4444  Legacy: A nearly lossless compression algorithm commonly used for video 
editing on Apple systems. Compared to Apple ProRes 422, this codec preserves more colour detail 
and supports transparency. However, it results in heavier file sizes.

 8. If you want to export a video with transparency, check the Alpha option.             

NOTE 

This option is only available when exporting with the Apple ProRes 4444 codec. Other 
codecs do not support transparency.

 9. If you want your movie file to have an audio track, make sure the Sound checkbox is checked.

 10. In the Rate drop-down, select the desired sample rate for the movie's audio track. The higher the 
sample rate, the better the quality.

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you 
select a higher sample rate, your project's audio will be upsampled, which means 
it will take more disc space without increasing in quality. 

 11. Right of Use, select whether you want to export audio using the Mono or Stereo channel mode.

NOTE 

Stereo sound has a separate track for the left and right speakers, whereas mono 
sound only has a single audio track for all speakers. 

 12. Click OK.
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Configuring Movie Settings for QuickTime ProRes Movies on macOS
On macOS, Harmony allows you to export QuickTime ProRes Movie files (.mov) using the Apple AVFoundation 
framework, which is pre-installed with macOS.

Contrary to Windows and GNU/Linux, Harmony uses its own user interface to let you configure the 
compression settings for QuickTime Movies on macOS. Using this interface, you can choose to export your 
movie using either the Apple ProRes 422 or the Apple ProRes 4444 video codec. You can also configure the 
quality of the audio track, but the audio will always be exported in uncompressed PCM format. 

How to configure the video and sound settings for QuickTime movies on macOS

 1. Proceed to the Movie Options dialog for the type of movie you want to export—see Exporting a 
Movie File, Exporting Movie Files from the Node View or Exporting OpenGL Frames.

 2. In the Movie Options dialog box, click on the Codec drop-down and select one of the following 
video compression codecs:

NOTE 

The list of codecs available depends on the version of macOS being used. 

 l Apple ProRes 422: A nearly lossless compression algorithm commonly used for video editing on 
Apple systems. This codec is optimized for preserving video quality, but not for publishing or 
streaming.

 l Apple ProRes 422 HQ: Preserves visual quality at the same high level as Apple ProRes 4444 but 
for 4:2:2 image sources (cleaner footage for things like green screening). Heavier than Apple 
ProRes 422 for real-time editing performance.
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 l Apple ProRes 422 LT: A more highly compressed codec than Apple ProRes 422, with roughly 70 
percent of the data rate and 30 percent smaller file sizes. This codec is perfect for environments 
with limited storage capacity and data rates.

 l Apple ProRes 422 Proxy: An even more highly compressed codec than Apple ProRes 422 LT, 
intended for use in offline workflows that require low data rates but full-resolution video.

 l Apple ProRes 4444: A nearly lossless compression algorithm commonly used for video editing on 
Apple systems. Compared to Apple ProRes 422, this codec preserves more colour detail and 
supports transparency. However, it results in heavier file sizes.

 l Apple ProRes 4444 XQ: It is the highest quality version of Apple ProRes. It preserves the detail in 
high-dynamic-range imagery for 4:4:4:4 image source and preserves greater dynamic ranges. It 
features a target data rate of approximately 500 Mbps.

 7. If you want to export a video with transparency, check the Alpha option.             

NOTE 

This option is only available when exporting with the Apple ProRes 4444 and Apple 
ProRes 4444 XQ codec. Other codecs do not support transparency.

 8. If you want your movie file to have an audio track, make sure the Sound checkbox is checked.

 9. In the Rate drop-down, select the desired sample rate for the movie's audio track. The higher the 
sample rate, the better the quality.

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you 
select a higher sample rate, your project's audio will be upsampled, which means 
it will take more disc space without increasing in quality. 

 10. Right of Use, select whether you want to export audio using the Mono or Stereo channel mode.

NOTE 

Stereo sound has a separate track for the left and right speakers, whereas mono 
sound only has a single audio track for all speakers. 

 11. Click OK.
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Configuring Movie Settings for QuickTime Movies on GNU/Linux
Harmony is able to export QuickTime Movie (.mov) files  on all supported platforms. On Windows, Harmony 
uses libraries that are bundled with Apple QuickTime to export QuickTime movies. On macOS, Harmony uses 
the AVFoundation framework, which is pre-installed with the operating system.

Because neither QuickTime nor the AVFoundation framework are available for GNU/Linux, Harmony instead 
relies on a free and open-source alternative, OpenQuickTime, to export QuickTime-compatible movies on 
GNU/Linux. OpenQuickTime comes pre-installed with Harmony, and is not bundled with any proprietary 
codecs. Hence, it offers a more limited set of compression settings.

How to configure video and sound settings for QuickTime movies on GNU/Linux

 1. Proceed to the Video Options dialog for the type of movie you want to export—see Exporting a 
Movie File, Exporting Movie Files from the Node View or Exporting OpenGL Frames.

 2. In the Video Options dialog, select the preferred video compression method in the codec drop-
down:

 l Motion-JPEG A: A very portable codec that performs lossy JPEG compression and interlaces 
the frames. Motion-JPEG A compression is less efficient than Photo JPEG in terms of quality 
and file size, but may be a more portable alternative for software that does not support 
Photo JPEG. 

 l Photo JPEG: Encodes the movie as a sequence of JPEG images. JPEG images have lossy 
compression. This is the most efficient codec for file size. 

 l Portable Network Graphics (PNG): Encodes the movie as a sequence of PNG images. PNG 
images have lossless compression.

 l Tag Image File Format (TIFF): Encodes the movie as a sequence of uncompressed TIFF 
images. This codec is lossless. 

 l Uncompressed (RGB): Encodes the movie as uncompressed bitmap data. This codec is 
lossless. 
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NOTE 

Portable Network Graphics (PNG) and Photo JPEG are the only codecs in this list that 
are natively supported by both Harmonyand GNOME's Totem Video Player. Other 
codecs may require additional software to play on GNU/Linux workstations. 

 3. If exporting in Motion-JPEG A or Photo JPEG, set the desired JPEG quality for your video in the 
quality field. This setting ranges from 0 to 100, and is set to 85 by default. A higher setting 
increases picture quality, but makes the resulting movie file heavier.

 4. If exporting in Motion-JPEG A, set the desired field dominance in the fieldDominance field. Videos 
encoded in Motion-JPEG A are interlaced. When set to 1, odd frames are encoded on the first field. 
When set to 2, odd frames are encoded on the second field. 

 5. Click OK.

 6. Open the Sound Options dialog.

 7. In the Sound Options dialog, select the preferred audio compression algorithm in the codec field: 

 l A-Law 2:1: This codec uses logarithms to compress audio data. The resulting audio stream 
requires half the disk space of uncompressed audio data, but is of noticeably lower quality.

 l IMA 4:1: This codec compresses audio data to require a quarter of the disk space required for 
uncompressed audio data. It is not supported by a lot of software.

 l Twos Complement - Little Endian PCM: A standard uncompressed audio codec. 

 l Twos Complement - Big Endian PCM: A legacy standard uncompressed audio codec. This 
codec may be compatible with older editing interfaces. 

 l (mu)-Law 2:1: Similarly to A-Law, this codec uses logarithms to compress audio data. The 
resulting audio stream requires half the disk space of uncompressed audio data, but is of 
noticeably lower quality.
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NOTE 

It is recommended to leave this option to its default value, Twos Complement - Little 
Endian PCM, as it is commonly used for storing uncompressed audio. Other encoding 
formats are likely to sacrifice audio quality for negligible savings in disk space.

 8. In the Sample rate drop down menu, select 22050. This is the only sample rate supported for movie 
export in Harmony on Linux.

 9. Click OK.
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Configuring Movie Settings for Windows Media Video
On Windows, it is possible to export in Windows Media Video format. This format is natively supported by 
Windows, and is offered in Harmony as an alternative for exporting in QuickTime Movie format, as the latter 
requires installing QuickTime on Windows.

When exporting in Windows Media Video format, Harmony allows you to select the video compression quality 
as well as one of the preset sound compression profiles.

How to configure video and sound settings for Windows Media Video

 1. Proceed to the WMV Options dialog for the type of movie you want to export—see Exporting a 
Movie File, Exporting Movie Files from the Node View or Exporting OpenGL Frames.

 1. In the Video section, select the desired Variable Bit Rate Quality for your video. A higher setting 
will ensure a better image quality, whereas a lower setting will reduce the size of your movie file.

 2. If you want your movie file to have an audio track, make sure the Sound checkbox is checked.

 3. Using the Profile drop-down menu, select the preferred compression settings for your movie's 
soundtrack. Each profile has a combination of audio sample rate, sample size and channel mode, 
which cover the following options:

 l Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz and 44100 Hz. The 
higher the sample rate, the better the audio quality. 

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you 
select a higher sample rate, your project's audio will be upsampled, which means 
it will take more disc space without increasing in quality. 

 l Sample size: Also known as bit depth, this determines the amount of precision used to 
record each wavelength in the audio track. The standard size is 16-bit. If you choose 8-bit, 
the amount of disk space the audio track of your movie file requires is halved, but the audio 
quality will be significantly lower.
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NOTE 

Exporting in 8-bit audio requires Apple QuickTime to be installed. 

 l Channel mode:  Available channel modes are Stereo and Mono. Stereo sound has a separate 
audio track for the left and the right speakers, whereas mono sound uses a single track for all 
speakers.

 4. Click OK.
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Exporting an Animated GIF
You can export your scene, or part of your scene, as an animated GIF image. 

Animated GIFs are a portable format commonly used for exchanging short animations and clips on the web. 
They can be played in any web browser and in many image viewers. 

Animated GIFs are a convenient sharing format, but they are not a publishing format. They are not as 
optimized for fast download and playback as movie files, cannot contain audio and, most importantly, can only 
contain up to 256 different colours throughout the entire animation. Hence, if your animation contains textures 
or gradients, it is likely to lose quality when exported as an animated GIF, as Harmony will have to limit the 
amount of different colours used in the exported image. 

NOTE 

For more information on the Export to Animated GIF dialog, see the Reference Guide.

How to export an animated GIF image

 1. In the top menu, select File > Export > Animated GIF.

The Export to Animated GIF dialog box appears.

 2. In the Output section, click on the Browse button.

 3. In the Save dialog that appears, browse to the location where you want to export the animated GIF. 
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 4. In the File name field, type in the file name you want the animated GIF to have.

 5. Click on Save.

 6. In the Export From Display Node drop-down, select the Display node from which you want to 
render your scene.

NOTE 

If there is no Display node in your scene, the only available option will be Display All. 
This renders all the nodes in your scene, including ones that are not connected to 
anything. You can add other Display nodes to your scene and connect them under 
specific parts of your scene to be able to render these parts only.

 7. From the Export Range section, do one of the following:

 l Select All if you want to render the entire scene.

 l Select Frames if you want to render a part of your scene. Then, in the field to the right, type 
in the first frame of the sequence you want to export, and in the other field, the last frame of 
the sequence you want to render.

 8. Open the Resolution drop-down and do one of the following:

 l Select Same as Scene Resolution if you want to export an animated GIF with the same 
resolution as your scene.

 l Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of 
Scene Resolution if you want to export an animated GIF that is smaller than the resolution of 
your scene.
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 l Select Custom if you want to manually set the export resolution. Then, in the Width and 
Height fields, type in the desired resolution for your movie, in pixels.

 9. In the Dithering drop-down, select whether you would like to use dithering to blend pixels of 
different colours in gradients and, if so, which type to use:

 l None: No dithering will be applied. Each pixel rendered is rendered with the colour in the 
palette that is the closest to its actual colour. 

 l Diffusion: Blends pixels in irregular patterns to blend pixels and simulate the colour as 
closely as possible. 

 l Pattern: Blends pixels in regular checkered patterns to simulate the colour without created 
clusters of pixels. 

 10. If you want the animated GIF to loop, check the Loop option. If you only want it to play once, 
uncheck it. 

 11. Click on OK.

A progress bar appears.

 12. Browse to the location on your computer where you exported your animated GIF, and double-click 
on it to view it in your image previewer. 
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Exporting Flash (SWF) Movies
Exports a Flash movie file. 

Harmony supports exporting Flash movie files with a limited subset of vector and bitmap effects, the latter 
which can be previewed in Render View  mode.

The following can also be exported in Flash movies:

 l Pencil line thickness, which are converted to brush strokes

 l Auto-Patch nodes, for patching the joints between different parts of a cut-out character

 l Burn-in information, such as time code, frame number and scene information—see the Reference guide .

Before attempting to export a Flash movie, it is recommended to preview how your scene will render in Flash 
using the SWF Preview command. To do this, do one of the following:

 l From the top menu, select Play > Test SWF Movie.

 l In the Playback toolbar, click and hold the Render and Play  button to open its mode menu, select 
the Test SWF Movie  mode, then click on the button again. 

How to export a .swf movie

 1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (.swf) dialog box opens.
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 2. Click Browse and select a file name and destination path for your movie.

 3. In the Display Source section, select a Display node to read from in the Export From Display Node 
menu.

 4. In the Export Range section, select one of the following options:

‣ All: To export all the frames of your movie.

‣ Frames: To export a frame range. Enter the frame range in the fields.

 5. In the Options section, enter a Frame rate (fps). By default, it will be set to match the fps of your 
Harmony project. If you choose a lower frame rate, your export playback will be faster than your 
actual project. The reverse is also true for a higher frame rate. 

 6. In the same section, select the JPEG quality:

‣ 100 = Full quality

‣ 50 = Average quality at about 1/5th of the size.

‣ 25 = Medium quality where loss of high image resolution starts to occur.

‣ 10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣ 1 = Lowest quality where there is extreme loss of colour and detail and the image becomes 
nearly unrecognizable. 

 7. To prevent your movie from being imported into another application, select the Protect from 
Import option.

 8. For a lighter format, select the Compress Movie option. The movie may lose some quality, but the 
file will be lighter.

 9. To retain the thickness of pencil lines, select the Convert Pencil Lines to Brush Lines option. 

 10. In the Do Not Export section, select the effects you do NOT want to be rendered in the SWF movie.

Note that certain Harmony effects are not listed in this section as they are not compatible and 
therefore not available for SWF export. These effects will not appear in the SWF render. 

 11. Click OK.

 12. Browse to the location on your computer where you saved your Flash Movie and double-click on it 
to view the export.
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Exporting OpenGL Frames
Because rendering scenes requires a lot of computer resources, and playback in Harmony does not always 
keep up with the scene's framerate, it may be difficult to decide how to preview your animation as you're 
working on it. Exporting OpenGL frames gives a more convenient alternative.

OpenGL is the name of the engine used to display your scene's content as you are working on it. Hence, 
exporting OpenGL frames basically means you're exporting frames as they are usually rendered in the Camera 
view: Without antialiasing, compositing or effects. This is significantly faster than exporting your final frames, 
and can allow you to preview your animation in real-time without having to wait for a render. 

TIP 

You can quickly and easily create and view an OpenGL render of your scene using the Record and 
Play command. To do this, do one of the following:    

 l In the top menu, select Play > Record and Play.

 l In the playback toolbar, click and hold the Render and Play  button, select Record and Play 
to set the button to Record and Play mode, then click on the button again. 

How to export OpenGL Frames

 1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.
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 2. In the Output section, click Browse and select the directory where you wish to export the frames. 

 3. In the Filename field, enter a file name for the file to export. If you're exporting frames as individual 
images, the specified file name  will be used as a prefix, and the frame number will be used as a 
suffix. To use the default file name, click on Default.

 4. In the Format section, select Frames if you want to export each frame as an individual image, or 
Movie if you want to export a QuickTime movie file.

 5. If you are exporting frames:

 a. Select a numbering format in the Suffix dropdown. The numbering format determines how 
many digits to use for the frame numbers. For example, if the Suffix is set to 001, the first 
frame will be numbered 001, the second one will be numbered 002, etc. 

 b. If you are exporting frames, select an image format from the Drawing Type dropdown.

NOTES 

 l A lot of formats are listed as their file extension, but some also have suffixes to 
indicate how they are encoded. For example, PNGDP4 means PNG: double precision 
with 4 channels, which means the exported PNG images will have 16 bits per 
channel instead of 8 bits, and will also have an alpha (transparency) channel. 

 l For more information on supported export formats, refer to the Reference Guide.

If you are exporting a movie:

 a. In the Video Format drop-down menu, select the desired format for your movie file:

 l QuickTime ProRes Movie (*.mov): The Apple QuickTime format. This is the default 
export format and is recommended for its portability, and also because it allows you to 
choose among several video codecs.
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NOTES 

 l On Windows, Apple QuickTime must be installed to allow Harmony to 
export QuickTime movies. You can configure the export of QuickTime 
movies to use any codec that is compatible with QuickTime, including 
H.264, MPEG-4 and Animation.

 l On macOS, Harmony uses Apple AVFoundation to export QuickTime 
movies, which allows you to export using codecs such as H.264, Apple 
ProRes 422 and Apple ProRes 4444, among others.

 l If you are looking to export a QuickTime movie with transparency, be 
sure to choose a codec that supports encoding with an alpha channel.

 l On GNU/Linux, Harmony uses the OpenQuickTime library to export 
QuickTime movies. This only allows you to export videos in non-
proprietary formats such as Motion-JPEG, Photo JPEG, PNG or 
Uncompressed (RGB).

 l H.264/MPEG-4                      (*.mov)                    : A simple movie format that uses the H.264 codec, which is 
supported by most web browsers.

NOTES 

 l Using this format does not require additional software. However, if this 
is the first time you export a movie in H.264/MPEG-4 format, you will 
be prompted to download the OpenH264 library from Cisco. Simply 
click Yes when prompted, and Harmony will automatically download 
the library, then export the movie. 

 l There are no encoding options for this format. 

 l This format supports resolutions of up to 4096×2304. Each dimension 
must be a multiple of 16 pixels. 

 l Audio exported in this format is encoded in PCM 16-bit stereo, 22.05 
kHz.

 l Windows Media Video (*.wmv): The native format for Windows Media Player.
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NOTES 

 l Windows Media Video (.wmv) files can only be exported on Windows. 

 l Video players and editors on non-Windows systems can generally not 
open Windows Media Video (.wmv) files.

 b. In the Options section, click on Movie Options if you want to configure the video and audio 
compression settings for the movie to export.

NOTES 

 l For information on how to configure movie settings for a QuickTime Movie 
(.mov), see:

 l Windows: Configuring Movie Settings for QuickTime Movies on Windows 
on page 638

 l macOS: Configuring Movie Settings for QuickTime Movies on macOS on 
page 642

 l GNU/Linux: Configuring Movie Settings for QuickTime Movies on 
GNU/Linux

 l For information on how to configure the movie settings when exporting in 
Windows Media Video (.wmv) format, see  Configuring Movie Settings for 
Windows Media Video.

 l When exporting in H.264/MPEG-4 (.mp4) format, there are no video and 
audio compression settings.

 l If you are using GNU/Linux and are exporting in QuickTime Movie (.mov) 
format, there will be a button for the Video Options and one for the Sound 
Options.

 6. From the Resolution section, select a resolution for export. If you are running some quick tests, then 
you might want to reduce the resolution to save on exporting time. You can also select the Custom 
option to specify the desired Width and Height of your exported frames.

 7. In the Range section, do one of the following:

 l If you want to render all the frames in your scene, select All Frames.

 l If you want to render a specific sequence of frames, select Selected Frames then, in the fields 
to the right, enter the number of the first and last frame of the frame sequence you wish to 
render.

 l If you want to export the current frame, select Current Frame.
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 l If you want to export specific frames, select Selected Frames, then click on each frame you 
wish to export in the frames list to the right. You can also click and drag to select a range of 
frames in the list. If you want to remove a frame from your selection, simply click on it again.

 8. In the Options section, select a Display node to use for rendering your OpenGL frames from.  It is 
recommended to render from the Display node located under the final Composite node, unless you 
want to render a specific section displayed by a particular Display node.

 9. In the Options section, select the Open in Player option to view the rendered frames.

 10. Click OK.
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About PSD Layouts
Harmony allows you to export the contents of your scene as a Photoshop Document (.psd) layout. This can be 
helpful for scene setup, background art retakes, or even planning of animation. 

Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a 
camera movement in this scene, you should also set this up, as you can export the camera keyframes to 
generate a clear and complete layout.You can also create all the layouts for your production in the same 
Harmony  project which can be imported later on when you start each scene’s project. This will help set up the 
scene and begin its creation. You can use the layout .psd files to create the background art of each scene and 
make sure everything is correctly framed and at the right size. Finally, you can also have a layer with a drawing 
of the rough poses of the character or action and generate your layout posing from there.

NOTE 

Because the layout image is one static .psd file, only the first frame of your drawing layers will be 
exported—see Scene Staging on page 903 and Digital Animation on page 985.

NOTE 

For information on importing a PSD layout, see Importing PSD Layouts on page 1203.
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Exporting a PSD Layout
T-LAY-006-001

You can export your scene's first frame as a PSD layout to modify and paint in an external image editing 
software. The matching XLI file always has to be with the exported layout file.

NOTE 

For information on importing a PSD layout, see Importing PSD Layouts on page 1203.

How to export your scene as a layout

 1. Before exporting your scene as a layout, position your background elements, and everything you 
need as a reference in your scene, including a camera movement. 

 2. From the top menu, select one of the following:

 l File > Export > Layout Image to export all the elements in your scene to the layout 
.psd file.

 l File > Export > Layout Image from Selection to export only the selected elements. 

The Export Layout Image dialog box opens.

662



 3. In the Export Layout Image dialog box, set the export parameters—see the Reference guide .

 4. Click OK to validate the settings and export a .psd file of your layout.

The resulting image is a .psd file with one or two layers, each of which is contained in a 
corresponding group. These groups make the layout .psd file ready for a multilayer .psd import. 

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera 
option, this group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame 
when you exported the layout image.

NOTE 

An .xli  file is exported along with your .psd file. This file contains all the necessary information 
for correctly importing and automatically positioning your layout image in a Harmony project. 
Do not delete the .xli file or rename it. Also, always keep it at the same location as the layout 
.psd file.
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, 
such as an editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of 
individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

 2. In the Output section, click Browse and specify where you want to save the exported sound file.

 3. In the Export Range section, select one of the following options:

 l All: Exports the sound over all the frames of your scene.

 l Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

 l Process Soundtracks Individually: Each soundtrack from all layers is exported as 
individual files.

 l Merge all Soundtracks: One single file is created, combining all the sound files you 
imported in your scene. Note that it will only use the sound files in the selected frame 
range set in the Export Range section. If you selected to export all the frames, all the 
sound files will be processed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. 
It is a good idea to verify what is required by the software or device that  you may want to use next 
with the sound file.
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 6. Click OK.

The generated sound files appear in the selected directory and are named according to the scene 
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Batch Rendering
In Harmony Server, you can choose to render your scene locally or to send it to the render farm on your 
network so that other computers can render your scenes while you continue working on your station. This 
option is not available in Harmony Stand Alone, as render jobs are sent to a Harmony Server database, and 
machines that perform the render must be connected to this database.

There are two approaches to rendering a scene in Harmony Server:

 l Local Rendering is done directly by your machine in your Harmony session. Hence, it uses your 
machine's resources and will prevent you from working on the scene until the render is done. You will 
see the render progress in real time and will be able to preview the results right after it's finished. 

 l Batch Rendering is done by sending a scene to the server's render queue so it can be processed by the 
render farm. This allows you to keep working on your scene while the render is being done. The 
rendering progress can be monitored in Control Center and, when finished, the results can be 
previewed in  Play. Batch Rendering gives you access to additional rendering options. 

When sending a scene to batch rendering, it is not rendered immediately. Computers connected to the 
Harmony database that are configured to render scenes for the database check for new render jobs 
periodically, and start performing the render job when they find one that isn't already being rendered by 
another machine.

NOTE 

To configure a Harmony Server database and to set up clients to perform batch rendering jobs, 
refer to the Harmony Installation Guide.

How to send a scene to the batch rendering queue

 1. Save your scene.

 2. In the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (macOS).

The Render Write Nodes dialog appears.
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 1. In the Range section, select the frame range to render by doing one of the following:

 l If you want to render all the frames in your scene, select All Frames.

 l If you want to render a specific sequence of frames, select Selected Frames then, in 
the fields to the right, enter the number of the first and last frame of the frame 
sequence you wish to render.

 3. Enable Batch Composite Options. This will send your scene to your Harmony database's batch 
rendering farm, whereas disabling this option will make Harmony render your scene locally. 

NOTE 

When Batch Composite Options is enabled, the Preview option is not available. This is 
because Harmony does not track the progress of a render when it is performed by the 
Harmony database's render farm. You can only enable the Preview option when 
rendering locally.

 4. If you want the machine that will render your scene to output detailed information about the 
process in its log, enable the Debug option.

 5. If you want to split the render job for your scene into several smaller render jobs, so that the load 
can be shared by different machines in the render farm, enable the Chunk option. Then, enter the 
amount of frames each chunk should render in the Size (Frames) field.

 6. If you want to render the scene from a specific camera, select the desired camera from the Camera 
drop down list. A scene can have several cameras added in the Node or Timeline view, and each of 
them can be animated independently. 
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 7. In the Resolution section, do one of the following to select the resolution in which to render the 
scene:

 l If you want to render the scene in its actual resolution, select By Name and, in the 
resolution preset drop down list, select Default.

 l If you want to render the scene in one of the available preset resolutions, select By 
Name and, in the resolution preset drop down list, select the desired resolution 
preset.

 l If you want to render the scene in a specific resolution, select By Value, then enter the 
Width and Height of the desired resolution, in pixels. 

 8. If your production is intended for broadcasting on NTSC compatible televisions, enable Field 
Composite Options.

 l To export a scene animated at 24 frames per second in 60 frames per second so that 
the frames can be combined with the 3:2 pulldown technique, enable the Add 
Pulldown option. 

 l If you want Harmony to automatically interlace the exported frames to create a 30 
frames per second sequence, enable the Automatic Combine option.

 l By default, odd frames are interlaced on the first field (odd lines), and even frames are 
interlaced on the second field (even lines). If you wish to interlace odd frames on the 
second field and even frames on the first field, enable the Second Field First option.

 9. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render queue. 

If the selected frames were already sent to the Render queue, but were not yet rendered, dialog 
box opens to inform you that these frames were already in the queue, but that they have been 
updated with the selected options.

TIP 

You can also send scenes to batch rendering and check the status of the rendering queue 
using the Control Center application.
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Chapter 22: Library & Templates
T-RIG-009-001

Using templates and symbols, you can share and reuse any elements you create in Harmony. The Harmony 
library lets you store several different elements such as puppets, backgrounds, animations and key poses. In 
fact, anything you create in Harmony can be stored in the library.

The Library view is where you can store and reuse your artwork and animation in other scenes or build props 
and puppets.

The library is a storage centre for all production assets; the elements stored in the library are called templates. 
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional 
animation processes. The library can contain any asset used in a Toon Boom Harmony Premium production. 

Using the library is as simple as dragging the content into the library to store your artwork and then dragging 
it to the Timeline or Camera view when you want to reuse it.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 

When working on the database, the structure of the library differs from when working on Harmony Stand 
Alone. 

Harmony Server provides three default library folders: 

 l Symbols: The only library folder containing symbols for your project. You can organize the symbols 
library folder using subfolders, but you cannot create a second library for your symbols. This library is 
local to your project. 
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 l Environment: A folder located inside the Environment folder. Every asset stored in this folder is 
accessible from any job and scene contained within this environment. 

 l Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene 
contained within this job. 

NOTE 

You can create a folder called library  in the usa_db folder on the server to create a global library. 
Once the Harmony application is restarted, a Global  library folder automatically appears in every 
user's library. Every asset stored in this folder is accessible from any scene, job and environment. 
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About Structure
As you will probably create a large number of symbols and templates, you will soon realize they need to be 
organized. You can create different libraries and subfolders to easily access your assets. For example, you can 
create a different library for each project and divide it into several categories, such as:

 l Characters

 l Props

 l Backgrounds
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Creating Libraries
T-LAY-005-001

There are two ways to create libraries. 

 l Directly through your operating system

 l Using Harmony's interface

Although you can only have one symbol library folder, you can organize it by creating subfolders.

How to create a library folder through your operating system

 1. On your computer, create a new folder with a relevant name in the location where you want the 
library to be stored.

How to create a library folder in Harmony

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library folder.

 3. Click the New Folder button.

A new folder appears.

 4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.
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Opening Libraries
T-LAY-005-002

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network 
as a library. Opening a library means linking the folder to your Library view. You only need to open the library 
once. The library folder is available every time you open the application until you decide to close the library 
and unlink it.

How to open a library

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library Folders section.
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Closing Libraries
You may not always require all the library folders in the Library List. If so, you can close the ones you do not 
need. Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate 
it on your hard drive or network and open it in the Library view.

How to close a library

 1. On the right side of the Library view, select the library folder to close.

 2. In the Library View menu, select Folders > Close Library.

The library closes.
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Creating Folders
T-ANIMPA-003-009

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or 
in the Harmony Library view, so you can easily access assets. By default, any new library you link to your 
Library view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain 
the right to modify it before being able to add a new folder to it.

How to create a folder

 1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

 2. In the Library View menu, select Edit > Right to Modify.

 3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the 
plus [+] sign to expand it.

676



Deleting Folders
You can delete a folder from the library if its contents are no longer needed.

NOTE 

All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the 
data cannot be retrieved.

How to delete a folder

 1. In the Library view's left side, select the folder to delete.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

 3. In the Library View menu, select Folders > Delete Folder or press Del.
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Renaming Folders
Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

 1. In the Library view's left side, select the folder to rename.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

 3. In the Library View menu, select Folders > Rename Folder.

 4. Rename the selected folder.

 5. Press Enter/Return to validate the operation.
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Refreshing Libraries
If you update the content of your libraries through your operating system, you will need to refresh your library 
folders in the Library view.

How to refresh a library

 1. In the Library view's left side, select the folder to refresh.

 2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.
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Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) 
for you. You can generate template thumbnails yourself, if they do not display or if the process has been 
stopped.

How to generate thumbnails

 1. In the Library view's right side, select the template in which you want to generate thumbnails.

 2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.
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Deleting Thumbnails
You can also delete thumbnails if you want to send a template to another user or studio and keep your 
packages small.

How to delete thumbnails

 1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Searching in Libraries
When working on a movie or series, you will probably end up with many templates and symbols in your 
library. Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

 1. From the left side of the Library view, select the library in which you want to search.

 2. In the Search field, type the name or partial name of the symbol or template you are looking for.

 3. The arrows have been replaced by X that appears on the right side in search bar to clear the field. 
The Search engine will look for results within the library master folder and its subfolders. It will not 
look in other libraries.
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About Templates
T-LAY-005-003

When you want to reuse artwork and animation from your project in other scenes, you must create a template. 
A template can be seen as a portable scene or package that you can drag inside your project. A template is an 
individual copy of the artwork stored in the library which you can reuse in different scenes. Once a template is 
stored in the library, you can access it from any project.

Master Template

You can create a master template out of a cut-out puppet you created so you can reuse it throughout a single 
project or a full production. A cut-out character's master template stores the entire rig, structure, drawings, 
and keyframes of the different poses of your puppet into a single asset.

Master templates are created from the Node view.

The Timeline view and the Node view display different information about a scene and its structure. To make 
sure a character's main template, also called the master template, is rigged exactly the way it was meant to be 
when it's imported into a scene, it should be created with all the connections, effects, composites, nodes, pegs, 
groups, drawings, timings, as well as all the other information in the scene it was originally created in. 

Because the Node view is the most faithful representation of a rig's structure, it is recommended to create 
master templates from the Node view rather than the Timeline view. Templates created from the Timeline 
view may lose the extra connections, effects and groupings that are visible in the Node view but which aren't 
properly connected to its main structure. 

Action Templates

An action template, also known as  animation template, is created from the Timeline view. This template allow 
you to reuse animations, key poses and part of an animation and contains mainly keyframes and drawing 
exposures. For example, you can reuse head positions or a leg animation from a walk-cycle and place them 
inside other animations. When it is extracted from the Timeline view, it loses the extra connections, effects, 
and groupings from the Node view.

An action template is used with a master template. It cannot be used on its own since it does not contain all 
the information required to rebuild the puppet skeleton and advanced connections. The standard process is to 
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first import the master template to the Node view or Timeline’s left side, and then slide the action template 
into the Timeline’s right side. This allows you to first build the skeleton and then give it the right pose.

The combination of master and action templates will function as long as the layer order and connections are 
the same.

When you create an action template, be sure to name it so you can easily identify it as an animation.
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Creating Templates
T-ANIMPA-003-010

You can create a template from both the Timeline and Node views. When creating templates of 3D objects, all 
associated textures linked to Maya files will be incorporated into the template.

NOTE 

If you are creating a template from a character rig master template, you should collapse everything 
inside a master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and 
selecting its root layer. This can be useful for creating templates based on character rigs or scene 
backgrounds.

 2. In the Library view, select a folder to store the template. By default, you will have a library named 
Harmony Premium Library , which is stored on your computer, in the Toon Boom Harmony Premium 
Library subfolder of your Documents folder.

 3. If the library folder is  locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 
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 5. In the Rename dialog box, give the new template a name.

 6. Click OK.

How to create a template from the Node view

 1. In the Library view, select the folder in which you want to store the template.

 2. If the library folder is  locked , right-click and select Right to Modify. 

 3. In the Node view, select the nodes for creating the template and group them. It is very important to 
group your cut-out character rig before storing it in the Library, so your files are organized.

 4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G 
(Windows/Linux) or ⌘  + G (macOS). Make sure you have a composite under the connections before 
grouping, otherwise there will be numerous connections going outside the group.

 5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

 6. In the Node view, select the group node and copy and paste it inside the template folder in the 
Library view or press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (macOS).
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 7. In the Rename dialog box, give the new template a name and click OK.
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Deleting Templates
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary. 

How to delete a template

 1. In the Library view, select the folder containing the template to delete.

NOTE 

If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Delete or press Del.
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Editing Templates
You can open a template and edit it just like any other project. If you want modify your templates, you can edit 
them using the Edit Template command.

How to edit a template

 1. In the Library view, select the folder containing the template to edit.

NOTE 

If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

 3. Edit the template.

 4. From the top menu, select File > Save.

 5. In the top menu, select File > Quit (Windows/Linux) or Harmony Premium > Quit (macOS).
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Importing Templates
There are several ways you can import templates in your scene.

For greater control over how the action template behaves when brought into the Timeline view, you can use 
the Paste Special feature—see Using Paste Special on page 712.

NOTE 

Dragging a template into your scene copies the content in your Timeline and does not link it to the 
original. You can modify this individual copy at any time.

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If 
you drop a template in the layers list in the Timeline view, it will be inserted between the layers 
where you dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template 
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into 
your scene, this will replace the drawings and keyframes in your scene with the ones from the 
template. This is useful for importing pose or animation templates for characters that are already in 
your scene. 
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How to import a  template into the Node view

 1. In the Library view, select the template or symbol you want to import.

 2. Drag the selected template to the Node or Camera view or the left side of the Timeline view.
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 3. In the Node view, connect your template to your scene's Composite node. To do this, click its out-
port and drag the connection to the Composite node until an in-port appears.

How to import a template with symbols

 1.  From the right side of the Library view, select the action template that contains symbols.

 2. Hold down Alt as you drag it from the Library view to the right side of the Timeline view and drop it 
next to a template with the exact same rig.

The Paste Special window opens.

 3. Select the Advanced tab.
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 4. Select one of the following options from the Symbols menu:

 l Copy symbols if they do not exist: This is the default setting for this operation and will 
prevent symbols in an action template from being copied.

 l Duplicate symbols: Makes copies of the symbols in your template.
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Opening Templates as Folders
Since a template is like a scene, you can open the template's folder and select elements inside it such as 
drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or a 
palette. In this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

How to open a template as a folder

 1. In the Library view, select the folder that contains the template to open. If the library folder is 
locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Open As Folder.

 3. In the library list section, click on the template's folder to display its content.

 4. Drag the content to the Timeline or Colour view.
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About Symbols
A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain 
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in 
which you place a series of different drawings for each body part of your puppets or when you have a repeating 
cycle. However, symbols are not necessary for creating characters. 

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can 
nest many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of 
the Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click 
on the symbol's name to move up the chain.
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Creating Symbols
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can 
also create symbols out of each body part in your cut-out puppets.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library 
into your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the 
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.

How to create a symbol from the Timeline view

 1. In the Timeline view, select the layer or cells from which your want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced 
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to 
use it.

 How to create a symbol from the Node view

 1. In the Node view, select the nodes from which you want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (macOS) your 
selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens.

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced 
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to 
use it.
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Creating a Symbol from a Drawing
You can create a symbol from a drawing selection.

How to create a symbol from a drawing selection

 1. In the Tools toolbar, select the Select  or Cutter  tool.

 2. In the Camera view, select the drawing elements to create a symbol.

 3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the entire 
layer.

The Create Symbol from Drawing Selection dialog box opens.

 4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add your 
symbol on the layer's current cell. If there is already an exposure on that cell, the symbol will be 
added to a new layer.

 5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select 
the Cut Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the 
Cut Artwork From Source Drawing option.

 6. Click OK.
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The new symbol appears in the Library view's symbol folder and in the Timeline view as a new 
layer.
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Creating Empty Symbols
You can create a symbol without any artwork in it.

How to create an empty symbol

 1. In the Library view, select the Symbol folder.

 2. Do one of the following:

 l In the Library view's right side, right-click and select New Symbol. 

 l From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top 
 button in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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Deleting Symbols
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve 
the data. The symbol cannot be retrieved once you close the application.

How to delete a symbol

 1. In the Library view, select the symbol to delete.

 2. Right-click and select Delete or press Del.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the 
symbol from the library and scene.
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Editing Symbols
You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located 
in the position where they were created. The pivot is translated at the centre of the symbol.

How to edit a symbol from the Timeline view

 1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E 
(macOS)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

 2. Do one of the following:

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl 
+ Shift + E (Windows/Linux) or ⌘  + Shift + E (macOS). 

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.
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How to edit a symbol from the Library view

 1. In the Library view, select the symbol to edit.

 2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl 
+ Shift + E (Windows/Linux) or ⌘  + Shift + E (macOS). 

How to edit your symbol in the Node view

 1. In the Node view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or ⌘  + E 
(macOS) to use the Edit Selected Symbol command.

 2. In the Node view, inside the Symbol’s top node is the composition of your symbol. In this example, a 
group node was turned into a symbol.
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 3. In the Camera view, edit your symbol.

 4. In the Node view’s top-left corner, click the Top  button to return to the top node. Or press Ctrl + 
Shift + E (Windows/Linux) or ⌘  + Shift + E (macOS) to use the Leave Current Symbol command.
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Importing Symbols
There are several ways you can import symbols in your scene. 

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the 
library. If you import a symbol into your scene several times in the Timeline view, they will all be linked to the 
original symbol. If you modify one, they will all be modified. 

How to import a symbol in the Timeline view

 1. In the Library view, select the symbol you want to import.

 2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE 

This may be useful if you saved a character's body parts as separate symbols. If you dropped 
them into the Timeline view, then they would all appear in the centre, haphazardly one on top 
of the other. It would be more efficient to arrange them into their correct places as you bring 
them into the scene.
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Expanding Symbols
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The 
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root 
timeline. The symbol's layers will be parented to it in case you created motions and transformations on the 
drawing layer that contains the symbol. Breaking the hierarchy could result in the loss of any scaling and 
animation you may have created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you 
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to expand a symbol

 1. In the Timeline view, select the symbol to expand.

 2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group

 1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

 2. From the top menu, select Edit > Expand Selected Symbol in a Group.

 3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the 
Expand Arrow to enter the group.
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Converting Symbols to Templates
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content 
in another scene, you must create a template. This conversion breaks the drawing's link with both the original 
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to convert a symbol into a template

 1. From the Library view, select the symbol to convert into a template and drag it to the Camera or 
Timeline view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not 
be placed in the centre of your camera frame, but rather wherever your cursor drops it within the 
camera frame.

 2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to 
any other library folder. Make sure you have the right to modify the library folder.
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 3. In the Rename dialog box, rename the new template.

 4. Click OK.
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Importing Files in the Library
Harmony lets you import sound files and images directly through the Library view. Simply open the folder 
containing your files in the Library view and drag them directly from there.

How to open a file through the Library

 1. In the Library view menu, select Folders > Open Library.

 2. Browse for the folder containing the files you want to import.

 3. Click Open.

 4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. 
You can choose to import only the keyframes without the drawings or import only the drawings that are not 
already in your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a 
symbol in your scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left 
side, all the frames will be exposed. However, if you import it into an existing layer, you can use the Paste 
Special dialog box to adjust the import behaviour to fit your requirements.Once you set the parameters, 
Harmony will reuse them each time you import a symbol in the Timeline view’s right side until you set new 
parameters.

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Do one of the following:

 l While holding down the Alt key, click and drag on the template, then drop it on the 
Timeline view, over the layer and at the frame where you want to paste it.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS). Then, in the Timeline view, click on the 
frame where you want to paste the template and press Ctrl + B (Windows/Linux) or ⌘  + B 
(macOS)

The Paste Special dialog box opens.

 3. In the Paste Special dialog box, select the desired parameters—see the Paste Special Dialog Box 
topic of the Reference guide .

 4. Click OK. 

712



713

Harmony 21 Premium User Guide                          



Chapter 23: Gaming in Harmony

Chapter 23: Gaming in Harmony
There are two main pipelines for exporting data from Harmony to your game engine: 

 l Raw Game Data Export  on page 715

 l Frame-by-Frame Export  on page 716

Creating Animation in Harmony

When creating character rigs and animation for games, there are a few things to think about before starting.  
Artists and programmers should work together to make sure their needs are met. 

 l What platforms will your game be create for?  Windows, Mac, Mobile, iOS, PS, XBOX, etc. 

 l What game engine will you be using?

 l What  will be animation style used to create the look of the game?  Hand drawn, cut-out, with textures, 
etc. 

These are just a few of the questions to consider before getting started.  They all have an impact on how you 
design, build, and animate characters. 

For example, if you’re planning a mobile game for smart phones, then you will most likely want to keep your 
game under 50 MB, so it can be downloaded without having to be on Wi-Fi.  In that case, your most important 
consideration is to create efficient characters with very tight sprite sheets and reuse a lot of the animation to 
keep the file sizes small.    During the process, you will need to: 

 l Rig and animate characters in Harmony.

 l Extract the Harmony data. 

 l Import the Harmony data into the game engine.  

Keep in mind, if you’re working with a custom engine, you can also process the Harmony data that’s exported 
and use it in a custom game engine.  If you need assistance with adapting data for your engine, contact 
store.toonboom.com/contact/support. 

If you’re making a game for consoles, like the PS or Xbox, then you have the freedom to create larger textures.  
You may want to animate frame-by-frame, or you may want to animate with a cut-out character.
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If you're simply going to export on a frame-by-frame sequence, then you can use all the tools in Harmony 
without limitations.  You can then process an exported image sequence into a sprite sheet.  

Raw Game Data Export 

Raw game data export is appropriate when you want the file sizes to be as small as possible.  Toon Boom lets 
you extract all the data from Harmony to incorporate into a game engine.  You can extract the skeleton 
information, drawing information, and keyframe animation data, as well as deformations (bones and 
articulations only), cutter, transparency nodes, and timing columns. 

 l Advantage: This is the lightest export, and will keep file sizes small which is ideal for mobile 
applications.  

 l Disadvantage: You are somewhat limited in the tools you can use in Harmony.  You can use tools like 
Morphing as well as Curve and Envelope deformers, but you’ll need to bake it out to drawings so they're 
interpreted properly in the game engine.  You can use Cutter effects (masking), but you cannot cascade 
them, meaning you cannot have more than one in a hierarchy chain.  The Game Bone deformers can be 
used on your rig with having to bake it to drawings.

However, even with these limitations, you can create really great cut-out character animation in Harmony and 
extract all the data.  By moving, rotating, scaling, and skewing the different drawing layers, you can create 
advanced looking animation.  

When you extract the data, you'll have sprite sheets that contain only the drawings of the body parts used in 
your Harmony scene file.    You can also support multiple animations, such as idle, run, and jump, and reuse the 
same skeleton and drawings when possible by simply exporting new animation data. 

Toon Boom has fully integrated this solution with the Unity game development rendering engine. If you are 
creating your game in Unity, you have a seamless pipeline without the need to re-treat the data in your game 
engine. 
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Frame-by-Frame Export 

You can export from Harmony using an image sequence, which can be recompiled into a sprite sheet.

Advantage: You can use any of the tools in Harmony when you animate!

Disadvantage: These sprite sheets can become quite heavy and end up as large textures to process in the 
game. This may be fine for many games, like console games, but when you’re doing game development for 
mobile devices, such as iOS or Android, you need to be very light on your texture space. Also, file sizes should 
be kept under 50 MB to facilitate downloading without needing to be connected to Wi-Fi.

There is a script available in Harmony that allows you to export your animation in frame-by-frame to the 
EaselJS game engine   EaselJS is a javascript web compatible game engine.  It uses a json data structure to map 
each frame to an entry in the sprite sheet.  The data structure is easy to understand and can be adapted or 
converted to a different game engine if you need to.

To export to EaselJS, you need to add the script in the Scripting toolbar (TB_ExportToEaselJS).  This script is 
included in Harmony.  See the Scripting guide for more information on how to add the script to your Scripting 
toolbar and the interface parameters.
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About Game Asset Creation
In this section, you'll find guidelines for rigging, deformation, cutter and many useful animation tips.
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Game Rigging Guidelines
For complete procedures on how to rig a character, see Character Rigging.

The following is a list of general guidelines to keep in mind when rigging your character. As you're planning 
the character rig for your game, keep in mind the style of the character, and create your custom colour palette.  
However, there are some limitations to consider if you plan to extract the game data:

 l Set your Harmony scene to be a square resolution (e.g. 1024 x 1024). You can do this in the Scene 
Setting dialog box—see the Reference guide .

 l Draw the art on the Line Art and Colour Art layers only. The information contained in the Overlay and 
Underlay will not be exported to Unity. It is however safe for using as a reference layer, just not 
anything that will be exported.

 l Create rigs in the Timeline view only.  The Node view can have complex connections that are not always 
interpreted well by game engines.

 l Nudge layers in Z space if you need to reorder layers.  However, significant Z offsets are not supported 
within a character rig. 

 l Make every layer in your game engine  a separate scene in Harmony.  If you have two characters at 
different depths, put them in separate scene files. 

 l Character rigs in groups at the root level of your Harmony scene will render to a single plane in Unity, 
but use separate sprite sheet and animation data sets.  Keep this in mind for scenes in which you may 
have more than one character interacting with each other. 

 l Don’t use any effects.  Effects like colour overrides are not interpreted by game engines.  Use only direct 
hierarchy, drawing swaps, and keyframe animation. 

 l Don’t use 3D space.  If you want to set things up in 3D space, you can do this when you get to your game 
engine. 

 l Set your pivot points on Peg layers using the Rotate tool to set the pivot on the entire layer.  Peg pivots 
are recommended over drawing pivots.  You should also set the pivot points on your drawing layers, 
even if you don’t animate on them, as this will allow you to retrieve the information later on in the game 
engine if you need to put a locator on a drawing layer.

 l Don’t use Morphing.  This is not yet supported in game engines. 

 l Both Morphing and Deformations can be used and then baked out to individual drawings.  These 
drawings will then show up as new drawings in your sprite sheet.  Be wary of doing this too often as it 
will increase your texture space! 

 l For your pegs, when you animate, use Bezier curves and set them to Separate.  If you use 3D Path, it’s 
heavier than Separate. 

 l Be mindful of where you put your character before exporting. The master pivot of your exported game 
object will be the center of your Harmony scene (0,0).

 l Be sure to have a Display at the end of your hierarchy.
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Keeping these tips in mind will allow you to create a tight, efficient 2D game character in Harmony while 
taking advantage of all the great tools. 

Here are some things you should do: 

 l Create a simple parent-child relationship hierarchy in the Timeline view.

 l Use peg layers to contain keyframe animation data, set to Separate Position.

 l Use drawing layers to draw on, creating new drawings when needed.

 l Use the Rotate tool to set the pivot points on the peg layers.

 l Name your layers properly so if you need to fetch a specific layer’s pivot point later on in the game 
engine, you can easily recognize the layer you need.  If you have a top-level Group A, which has a child 
group inside it (Group B), and the drawing layer is a child of Group B, then the drawing layer is exported 
as A_B_DrawingLayer.

 l Set your anchors and props, see—Setting Anchors and Props.

You can use any of the drawing tools you want: Pencil and Brush tools, textured lines, solid areas, and 
gradients.  Each individual drawing will be rendered out and assembled into a sprite sheet later.

NOTE 

Because the Unity game engine does not support Unicode characters, it is recommended to avoid 
using it in scenes intended for games.
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Game Deformation Guidelines
Harmony can export deformations to the game engine XML format. Only hierarchies made of Game Bones can 
be successfully exported. In addition, Kinematic Outputs were implemented to complement your game bones—
see About Game Bone Deformations on page 722.

Deformation in Harmony come with a wide set of features. However, some of these features are not compatible 
with the game engine SDK and must hence not be used for gaming. Hence, Game Bone deformers do not 
support the following standard Bone deformer features:

 l Zones of influence

 l Curve and Envelope deformations

 l Having more than a single pose in the deformation hierarchy

The deformation in the game engine SDK does not behave exactly as the deformation in Harmony.

To comply with most game engines and maintain fast calculations, the SDK implements a linear base skinning 
algorithm to linearly blend the bones at articulations. You may notice some differences depending on the 
curvature of the articulations used.

NOTE 

* Not currently available in the Cocos2d-x implementation of the game engine SDK.
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About Game Bone Deformations

T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like 
structure in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a 
character's limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For 
example, a Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that 
the upper arm and forearm can be moved independently, without having to draw the upper arm and the 
forearm on different layers. Harmony will deform the drawing to make it look articulated. The different parts of 
a Game Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
differences between the Bone and Game Bone deformations are that Game Bone deformations do not have 
Bias and Region of Influence properties. The articulation folds also look slightly more rounded.
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Game Cutter Guidelines
The cutter, or mask, operation in Harmony is used for cutting off drawings with custom shapes. The game 
engine SDK implements both cutters and inverted cutters with the following limitations:

 l For a sprite, only a single cutter drawing can be applied when it is rendered. This also applies to a 
composite of multiple matte drawings. The game engine SDK will only use the first matte drawing 
during rendering and discard the others.

 l A deformed drawing cannot be cut, but a cut drawing can be deformed.    

NOTE 

Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Creating Metadata Notes
As you create assets for your game in Harmony, you may want to make notes about the scene or specific parts 
of the character or props for the programmer. These embedded notes that will be exported with your assets to 
Unity are known as metadata.

How to access the Metadata Editor view

 l In the top-right corner of a view, click the Add View  button and select Metadata Editor.

 l In the top menu, select Windows > Metadata Editor.

How to create scene metadata

 1. In the Metadata Editor view, in the Scene Metadata section, click on the plus button to create a 
new metadata entry.

The Add Metadata dialog box appears.

 2. In the Add Metadata dialog box, enter the name of your new scene entry.

NOTE 

For any anchor or prop information created within the Metadata Editor, the naming 
convention must always use the prefix "game.". The term "game." is recognized 
automatically by Unity as a metadata information. For example: game.Armor001.

 3. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are 
through.

 4. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 5. Enter the value information for this entry. 

 6. Continue adding value information for all your entries.

This information will be exported with your Harmony assets. Once in Unity, scene Metadata will 
appear in Inspector view > Metadata when the asset is selected in the Hierarchy view.
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How to create node metadata

 1. In the Timeline view, click on the layer to which you would like to attach metadata.

The name of the layer appears near the top of the Node Metadata section.

 2. In the Node Metadata section, click on the plus button to create a new metadata entry.

The Add Metadata dialog box appears.

 3. In the Add Metadata dialog box, enter the name of your new node entry.

NOTE 

For any anchor or prop information created within the Metadata Editor, the naming 
convention must always use the prefix "game.". The term "game." is recognized 
automatically by Unity as a metadata information. For example: game.Armor001.

 4. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are 
through.

 5. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 6. Enter the value information for this entry. 

 7. Continue adding value information for all your entries.

This information will be exported with your Harmony assets, more specifically, this information will 
be linked to the selected layer. Once in Unity, scene Metadata will appear in Inspector view > 
Metadata when the asset is selected in the Hierarchy view.
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Game Animation Tips
When animating for games, depending on the type of game you’re creating, you may need to limit your 
animation.  For example, if you’re creating mobile games and you want to keep the file sizes small and playback 
fast on all devices, then limit yourself to simple keyframe animation with as few drawing swaps as possible.  If 
you’re creating console games, you have the freedom to create more drawings and have a higher complexity.  
You can explore with your programmer the limitations of the platforms you’re exporting to, and what your 
game engine supports.

Here are some tips for efficient, lightweight animation: 

 l Use mainly transformations, such as move, rotate, scale, and skew. 

 l Create additional drawing swaps when needed.

 l If you use Curve and Envelope deformers or Morphing, you’ll need to bake out the drawings for export.  
Be careful when doing this, as you may want to keep the number of drawings small.  Don’t bake out an 
entire sequence, just selected drawings. You don't need to bake the Game Bone deformers.

 l The bigger the drawings are in the Drawing view, the more pixels they will occupy in the texture size on 
the sprite sheet.  When setting up your rig, make sure to not scale individual layers by using a keyframe 
with the Transform tool.  If you want to scale things up or down, use the Select tool.  This will keep things 
the same relative size on the sprite sheet.  When you export the sprite sheets, in the script you can also 
set the resolution of the sprite sheet so the drawings can be scaled down for smaller devices.

 l Only drawings which are exposed in the scene will be exported to the sprite sheet.  For example, if you 
have 10 drawings in your Library view, but only two of them are showing in your scene, only those two 
will be exported.  This keeps the sprite sheet as tight as possible. 
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Animating Multiple Sequences

You will always have multiple animations for your characters.  For example, an idle sequence, a run sequence, 
an action sequence, and so on.  You need to work in a specific structure so you can export all of these animations 
to a single sprite sheet. 

There are two different work flows that you can use:

 l Workflow 1: Separate Scenes 

 l Workflow 2: Separating Using Scene Markers
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Workflow 1: Separate Scenes

First, create a scene file with the name of the character, such as Space Duck.  This is the file where you can 
create or import your game rig. In the top menu, select File > Save As New Version, and give this new version 
the name of the animation.  For example, Idle. 

Every time you need to do a new animation using the same character, perform a Save As New Version.  In the 
end, you may have something like this: 

Scene: Space Duck 

Versions: 

 l Idle 

 l Run 

 l Jump 

 l Shoot 

When you run the export script, it will export the drawings from the current scene into the export folder.  It will 
also let you know if there are any other scene versions that were already exported to that folder.  If so, then it 
will recompile the sprite sheet to include all the drawings from all the animations. This allows the maximum 
possible reuse of drawings. 
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Workflow 2: Separating Using Scene Markers

You can also create all of your character animations in a single scene, one after the other, such as idle, run, jump 
and shoot. Then use scene markers to mark and separate the individual animations, see—Creating a Scene 
Marker on page 298.

When you are marking individual animation frame ranges, be sure that they start and end with a keyframe. Do 
not create scene markers for a range of frames that starts or ends in the middle of an interpolated movement.

When exporting your sprite sheet, in the Export To Sprite Sheet dialog box, be sure to check the Use Scene 
Markers to Export Clips option.

The animated clips are divided and listed in the stage.xml in the same way that they would appear if you had 
exported each animated sequence from separate scenes to the same file location.
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About the Orthographic Camera
In Harmony, there are two types of cameras available:

 l Perspective

 l Orthographic

The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to 
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the 
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with the 
orthographic camera, by default, you need to create a new custom scene resolution.
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Using the Harmony Game Previewer
If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, 
you can use the Harmony Previewer application. You can visualize your characters in the Unity game engine 
with no programming required.

To get the latest version of the Harmony Game Previewer, visit our Gaming landing page:

https://www.toonboom.com/games

How to use the previewer on Windows

 1. Download the Harmony Game Previewer for Windows:

 l https://download.toonboom.com/games/GamePreviewer-11.1.0.0047-windows.zip

 2. Extract the following to your hard drive:

 l GamePreviewer-[version].exe 

 l GamePreviewer-[version]_Data folder

 3. Copy your export from Harmony to this folder:

 l GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\

 4. Start the Game Previewer application.

 5. Select the export you want to preview.

How to use the previewer on macOS

 1. Download the Harmony Game Previewer for macOS:

 l https://download.toonboom.com/games/GamePreviewer-11.1.0.0047-macosx.zip

 2. Extract the GamePreviewer-[version].app.
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 3. Right-click on the GamePreviewer-[version].app and select Show Package Contents.

 4. Copy your export from Harmony to this folder: 
Contents/Data/StreamingAssets/HarmonyResources/

 5. Start the Game Previewer application.

 6. Choose the export you want to preview
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About Exporting to Unity
If you have a custom game engine, you can take the exported Harmony data and proceed with your usual 
process.  Or you can modify the export script to fit your convention.  

Before exporting a scene:

 l Be sure to set your Display as Display and not Display All.

 l Be certain to save your scene. Harmony makes the export based on the tvg files, any unsaved updates 
you have added will not be exported.

 l Set your Harmony scene to be a square resolution (ex. 1024 x 1024). Select Scene > Scene Settings.

The Transparency parameter attached to the element node is exported along with the animation. You can set 
the transparency through the Layer Properties window (Advanced tab).
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Clearing Scripts
If you were using Harmony 12.1 or earlier, it is strongly suggested that you clear your scripts before exporting 
animation for the first time. This will ensure there's no conflict with previous versions of the scripts and you 
have the most up-to-date script.

How to clear your scripts

 1. Close Harmony if it is open.

 2. Browse to the script folder location:

 l Windows:

 l Toon Boom Harmony Premium: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon Boom Harmony 
Premium\1200-scripts

 l macOS: 

On macOS, the Library folder is a hidden folder. To display the display the folder, told 
down the Alt key.

 l Toon Boom Harmony Premium: /Users/[user_
name]/Library/Preferences/Toon Boom Animation/Toon Boom 
Harmony/1200-scripts

 3. Delete the 1200-scripts folder.

 4. Restart Harmony and test the export.
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Setting Anchors and Props
Before exporting to Unity, you need to set your anchors and props.

An anchor is an attachment point you can use to bind one or several props to a specific location that is 
predefined by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and 
easily swappable from within Harmony or Unity.

How to set an anchor

 1. Create a new Drawing layer and rename it according to the anchor you are creating.

 2. Inside the Layer Properties of your drawing layer, make sure that pivot option is set to  Don’t Use 
Embedded Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on 
Parent Peg does not transition well to Unity and you will lose your pivot information.

 3. Once this is done, you can use any of the animation tools to reposition the pivot point of your layer, 
such as the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot 
coordinates from the Layer Properties of your Drawing layer. If the pivot is not repositioned, its 
default place will be at the centre of your Harmony scene (0,0).

 4. Once this is set up, select the Drawing layer and click the Toggle Anchor  button in the Game 
toolbar. You can also make a multi-selection to set an anchor on multiple Drawing layers 
simultaneously.

The Drawing layer is highlighted in red in the Timeline and Node views. Your anchor can now be 
used to attach a prop.

How to set a prop

 1. Create a new Drawing layer or take an existing prop on which you want to attach an anchor.

 2. Position the Drawing Pivot of the prop layer using a tool on the Advanced Animation toolbar, such 
as the Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is 
positioned accordingly.

 3. With the prop Drawing layer selected, click the Toggle Prop  button in the Game toolbar. You 
can also make a multi-selection to set a prop on multiple Drawing layers simultaneously.

The prop Drawing layer is highlighted in green in the Timeline and Node views.
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 4. Do one of the following:

 l Connect the anchor and prop to the parent peg.

 l Connect the prop under the anchor to create a parent/child hierarchy.
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Exporting Sprite Sheets
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or 
multiple sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, 
and jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations 
in that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are 
exported individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the 
sprite sheet to include all the drawings from all the animations in that folder, creating a new animation file, but 
reusing the same skeleton.

NOTE 

Programmers may be interested to note that the XML data exported by Harmony can be converted 
afterwards to a more optimized binary data structure.  To convert XML to Binary format, use the 
Xml2Bin utility. This utility converts the XML data structure generated through the Toon Boom 
Harmony software to a compressed binary data structure. This utility is available in the gaming 
SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx: Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you 
want to integrate with other game engines.

How to export sprite sheets

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Sprite Sheets  button in the Game toolbar.

The Export to Sprite Sheets window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If 
not, you can save anywhere, then transfer the animation into your Unity project, or any other game 
engine you want to use.

 4. Set your sprite sheet preferences, see—the Reference guide .

 5. Click Export.
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Exporting to Easel JS
The Export to Easel JS window lets you flatten an image sequence of your animation. Even if you have a fully 
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened 
output of each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of 
work as you have access to any tools or effect modules you want to use. However, this can result in heavier files 
depending on the length, complexity and export size of your animation.

NOTE 

Programmers may be interested to note that the XML data exported by Harmony can be converted 
afterwards to a more optimized binary data structure.  To convert XML to Binary format, use the 
Xml2Bin utility. This utility converts the XML data structure generated through the Toon Boom 
Harmony software to a compressed binary data structure. This utility is available in the gaming 
SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx: Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you 
want to integrate with other game engines.

How to export to Easel JS

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Easel JS  button in the Game toolbar.

The Export to Easel JS window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If 
not, you can save anywhere, then transfer the animation into your Unity project, or any other game 
engine you want to use.

 4. Set your sprite sheet preferences, see the Reference guide .

 5. Click Export.
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About Working in Unity
The Harmony Gaming Animation Guide is a basic guide on how to import Harmony projects and configure 
them, design and animate characters, and includes some tips. It is not meant as a guide on how to program 
games.
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About the Sample Unity Project
Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported 
from Harmony.  Inside this project is an Assets folder which contains the following folders: 

 l Plugins 

 l Scenes (demo scenes and a previewer) 

 l Scripts (all Harmony scripts) 

 l StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder. 
This way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder.  You can 
also manually place exported Harmony data into this location.
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About the Unity Interface
Here are the main components of the Unity interface and their equivalents in Harmony:

Unity Harmony Description

Scene view Perspective view
This is where you set the scene, selecting and positioning 
environments, the player, the camera, enemies, and all 
other GameObjects. 

Game view Camera view
The rendered view from the camera(s) in your game. It is 
representative of the final, published game. 

Inspector Layer Properties
Displays detailed information about the selected 
GameObject, including all attached Components and their 
properties.

Hierarchy Layers in Timeline view
Displays the hierarchy of elements in the scene, and lets 
you set up parent-child relationships for different game 
objects.

Project Browser --- Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy.  To show a Harmony object, you must add a 
special component.  With the main camera selected, in the Inspector, select Add Component > Scripts > 
Harmony Camera.
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Importing Harmony Files into Unity
Once you've finished creating your artwork and cyclable animated character movements in Harmony, it's time 
to import them into Unity for game integration.

How to import Harmony files directly into Unity

 1. Create a Unity 2D project.

 2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought 
in. Do one of the following:

 l Go to the Unity Asset Store (assetstore.unity3d.com/en/#!/content/31211) and save the 
Harmony Game SDK file on your computer. Then import it in your project from the following: 
Top Menu > Asset > Import Package > Custom Package.

 l Search for the Harmony Game SDK in the Unity Asset Store, then download and import the 
package. You can access the Asset Store from the following: Top Menu > Window > Asset 
Store.

NOTE 

For each new Unity project, you must repeat step 2 as it contains the necessary files and 
folders to make the Harmony import process work.

 3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >

 l Harmony Object:  Lets you browse for the exported Harmony project folder.  If 
you’ve already saved this to your StreamingAssets folder, you can browse to it 
through there.  Then it adds the Harmony scene to your Unity file, and sets up 
the rendering, audio, and animation scripts you need to get going.

 l Harmony Texture Object: Lets you browse for the exported Harmony project 
folder similarly to Harmony Object, but creates a Unity plane to render your 
animation on it.
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About Game Objects
GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically 
everything you create in Unity will be a GameObject.  There are two main types of GameObject you can use to 
import Harmony data: 

 l Create Empty

 l Create Other > Plane 

To understand the process fully, there are two examples using an empty GameObject and a plane GameObject 
with the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your 
Harmony data.
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Using Empty Game Objects

An Empty Game object is a regular GameObject in which you can load the exported Harmony data.  All the 
individual body parts on the sprite sheet come in as separate elements, but are treated as one whole object 
with a dynamically created bounding box.  If you put a transparency on this object, you would see the 
overlapping transparencies of all the individual objects.  This creates a higher-quality render and should be the 
default if you’re not animating the transparency of an object.  With this option, direct rendering will read the 
depth information in the scene but not write it.  Note that with this option, the rendering cannot be customized.
 

How to use an empty GameObject

 1. Select GameObject > Create Empty.  

 2. Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo 
file, rename the GameObject to SpaceCat by doing one of the following:

 l Double-click on the name and rename it in the Hierarchy.

 l Select the GameObject and rename it in the Inspector. 

 3. At this point, it’s an empty object.  Accessing Harmony data is done through scripts.

 l Select the SpaceCat GameObject. 

 l In the Inspector, go to Add Component > Scripts > Harmony Renderer.

A new section appears in the Inspector called Harmony Renderer (Script).
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This will let you load an animation file.  You must put the path of the asset relative to the 
HarmonyResources folder.  Before this, you must export from Harmony directly to this folder, or 
manually copy and paste the data here.

 4. You exported a scene called SpaceCat.  In the Project Folder, place HarmonyResources/SpaceCat 
under the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z 
because the default Harmony project is for an HD screen.

 5. You won’t see anything until you define a few parameters:

 l Set the Clip Name Size to 1. A second field will appear, Element 0. 

 l Enter the clip name for the animation you want to load.

 6. Double-check on the right Clip Name to put in Element 0; you can check the output you exported 
from Harmony.  

 7. Double-check the stage.xml file, which was exported to the folder you specified when exporting 
from Harmony.  Our default export path is to StreamingAssets, so it will automatically load in the 
game engine.

 8. Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName]. 

You’ll find the data that was exported.  In this case, we’re looking for SpaceCat. Select the file 
marked stage to load the data you want to double-check. 
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The text data appears in the Inspector.

The name to use for loading the object is the stage name.  In this case, SpaceDuck_
SpaceCatIdle.

 9. If your GameObject has animation in it, and you want it to load the animation data from the 
Harmony export, add one more component by doing the following:

 l Select the GameObject.

 l In the Inspector, select Add Component and select Scripts > Harmony Animation. 

 10. To loop the animation, you must set a GameObject to define it:

 l Select  GameObject > Create Empty and rename it: LoopAll.  

 l Click the LoopAll GameObject to display its properties in the Inspector. 

 l Click Add Component > Scripts > Loop All.   

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on 
all GameObjects on runtime and asks them to loop, which is useful when testing the animation.  
When programming the actual game, you should write additional scripts to control the different 
elements separately.
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Using Plane Game Objects

Renders the entire character to a plane. This renders your character to texture data.  If you animate the 
transparency of the plane, then the transparency of the rendered output is animated; you won't see the 
transparencies of the overlapping elements.  However, you will have one static bounding box the size of the 
plane that you render to. 

Use this option when you want to animate the transparency of a character in a scene.  Also, you can write your 
own custom shaders.  Simply set the Render Target to eRenderTarget.   You can see an example of this in the 
sample project DemoRenderTarget.  

 How to use a plane GameObject

 1. Select GameObject > Create Other > Plane.  

 2. Select Add Component > Scripts > Harmony Renderer. 

 3. Set Size to 1 and Element to 0 on the clip name as per previous instructions. 

 4. Set Render Target to eRender Texture.  

 5. Render Texture Viewport:  

 l X: To reposition the animation correctly; it should be -½ the width of your Harmony 
project.

 l Y: To reposition the animation correctly; it should be -½ the height of your Harmony 
project. 

 l W: Width of your Harmony project 

 l H: Height of your Harmony project.  

 6. Use the custom Shader created by Toon Boom to have a transparent background with 
premultiplied alpha channel.  This is what produces nice, antialiased drawings in your output.  

 7. With the Plane selected in the Inspector, go to Mesh Renderer > Materials. Under Element 0, 
select UnlitTransparentPremultiplied. 

 8. If you're starting with the Toon Boom demo project, this renderer should already be loaded in your 
list. 

You can also write your own custom shaders and use them here. 
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 9. You must also add the animation component.  Select the Plane. In the inspector, click Add 
Component > Scripts > Harmony Animation.

Once your Harmony GameObject is imported, you should be able to see your character both in the Scene 
and the Hierarchy views. From here you can attach one or several props to an anchor.
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Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is 
predefined by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and 
easily swappable from within Harmony or Unity.

How to attach the prop to an anchor

 1. Open up your character in the Hierarchy view to have access to both the props and the anchors. 

 2. Click on the prop you wish to attach, and drag it onto the appropriate anchor. 
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 3. Repeat these steps for each prop and anchor in your project.

 4. In the Inspector view, under Frame, you can select which frame you wish to show. If you only had 
one drawing in your prop, then you will not have multiple options.

 5. If part of your character is cut off by the plane of the character, now that the props are showing, you 
will need to regenerate the mesh. To do so, select your GameObject. After this is done, go to 
Inspector View > Render > Generate Mesh.
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Placing Locators in Unity
In Unity, it's possible to assign a target to some part an imported Harmony animation.  For example, in the 
Space Duck scene, the character has a gun. You may want to attach some other action to this animated gun, 
such as shooting spheres and cubes out of its end. For this, you need to place a locator at the end of the gun. 

You can see some examples of this in the provided Unity project.  The first example is in the demo scene 
DemoLocator,  which shows a simple cylinder attached to the end of the gun. 

The second example DemoCallback shows the gun shooting spheres and cubes.

You can access any drawing layer created in Harmony later in Unity and use its pivot point to attach objects 
and animated sequences. In Harmony, you should set the pivot points on your drawing layers with the Rotate 
tool.

You can also create an empty drawing layer in Harmony, when setting up your character, to be used later in 
Unity. Use Create Empty Drawing to create a blank drawing, then use the Rotate tool to set the pivot point on 
this drawing layer.  In the Space Duck example, an empty drawing layer called hook_gun was created on 
which you can attach the locator in Unity. 

When you access the imported Harmony character in Unity, you can access the data with a script.  

How to set a locator to a part of a character

 1. Select Game Object > Create Empty to add a new GameObject to extract the target's position, 
rotation, and scale. 

 2. Drag and drop the new object so that it's a child of the character. 

It becomes indented.  

 3. Rename the GameObject to: Hook Gun.

 4. In the Inspector of the target object, select Add Component > Scripts > Harmony Locator.

 5. Enter the name of the drawing layer to which you want to attach.
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 6. To find the exact name for the Locator Name, look at the skeleton.xml file in the Streaming 
Assets folder.  You can find it in Streaming Assets > Harmony Resources > Name of Harmony File 
> skeleton.

All the drawing and peg layers are listed. In this example, look for  space_duck_hook_gun. 
Having drawing layers with distinctive names makes them easy to recognize when you need to 
retrieve them.

You can copy the name of the layer into the Locator Name to see the Transform information 
updating dynamically as you run the simulation.

 7. Now you can attach anything as a child of this Locator Object.  For testing purposes, you could 
attach a cylinder for example.  In a real example, you’d want something to shoot out of the end of 
the gun, so you can see the Callback example to verify how that works.
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Setting Up Collisions in Unity
Extracting the bounding box information is useful when you want to make something collide with your 
character.  When you put a 2D character into a 3D scene, you may want to use Physics to make the 2D 
character collide with the 3D plane.  To use the following scripts, you will need Unity 4.3 or higher. 

In the Demo scene, open the DemoPhysics example to see collisions and bounding boxes.  In this example, 
there’s a 3D plane and some 2D characters.  The 2D characters have a collision defined with their bounding 
box, and they're also reacting to the physics of the scene to fall with gravity. 

Colliders were improved to provide several different types of colliders for use in Unity. You can select polygon 
colliders and box colliders for a more accurate bounding box.

How to set up collisions

 1. Select your imported character.  

 2. In the inspector, select Add Component > Physics 2D > Box Collider 2D.  

 3. To enable the Physics on the character, go to Add Component > Physics 2D > Rigid Body 2D.  

NOTE 

You can also use 3D physics on the imported files. 

You can now adjust the variables and see the results.
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About Working with Audio in Unity
When you create scene files in Harmony with audio, the audio is exported into the project folder.  However it’s 
important to understand how the game is built to determine the best way to handle audio.  

When a game is built from Unity, it creates its own database for holding the assets.  Within the export, the 
Streaming Assets folder is preserved intact.  This is what enables the Toon Boom plugin to access those assets 
on the fly, and render them in the camera to create the final animation you see on the screen. 

However when it comes to audio, the game first looks for the audio in the Unity database. So this is the most 
efficient place to store the audio for the real game.

If audio can't be found in the Unity database, then the game looks in the Streaming Assets folder to find the 
audio.  When it does, it copies the audio on-the-fly back into the Unity database.  Since this action is quite 
costly, don’t leave the audio in the Streaming Assets folder for the final game.  It’s fine to leave it there while 
you’re testing, but not for the final game.  

The audio should be copied back into the Unity database, either manually or by automating this process with a 
script.
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Harmony Unity SDK
This section will guide you how to  import Harmony animations into Unity through the use of Harmony SDK.

Prerequisites

 l Install the latest Microsoft Visual C++ Redistributable for Visual Studio.

https://support.microsoft.com/en-ca/help/2977003/the-latest-supported-visual-c-downloads

 l
NOTE 

The SDK requires the latest version of the Microsoft Visual C++ Redistributable for Visual 
Studio. Without the above prerequisite, the native  HarmonyRenderer.dll will fail to load 
and animations will not appear in the editor or the player. 

SDK Contents

Once the .unityasset package file have been imported, find a Toon Boom Harmony Game SDK folder that 
consists of:

 l Harmony Game Previewer: Assets for the previewer application.

 l Harmony SDK: Assets for the SDK. This can be imported into another project.

 l Source: It contains source code for the native C++ library that processes Harmony animations.

How to import animations

 1. Export Harmony animations within Unity into an XML format from the Harmony game tools. Please 
see <Inset link to game export docs page>.

Once exported, you will see a folder with the files as shown below. These files can be placed to the 
desired location on your computer.
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 l audio folder: This is optional and unused

 l spriteSheets folder: If exported as a sprite sheet.

 l sprites folder: If exported as separate sprites.

 l animation.xml

 l drawingAnimation.xml

 l skeleton.xml

 l spriteSheets.xml If exported as a sprite sheet.

 l Stage.xml

 1. Import plugin inside Unity.

 2. Create a new Harmony Project Import.

How to create Harmony Project Import

This is an asset containing the custom import settings for your Harmony project.

 1. Right click in the project view or use the Assets menu and select Create Harmony Project Import.
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 l Harmony Project XML Path: This is the path to the Harmony Project folder. Click Browse to 
navigate to the folder containing your  Harmony project to import.

 l Output Path: This is the path to the Harmony Project asset that will be  created and updated when 
importing the asset. Choose an appropriate save location within your Unity project.

 l Generate Prefab: If checked, the importer should  automatically generate a prefab for this Harmony  
project.

 l Existing Prefab: This shows a reference to the prefab to update, if  one exists already.

 l Frame Rate: The animation frame rate used by Unity's animation  system to playback the Harmony 
frames. This should  match your frame rate in Harmony.

 l Stepped: If checked, the animations will pass between integer  frames and thus not interpolate 
smoothly. If unchecked, the animation will be played back between integer frames, for a smooth 
animation.

 l Strip Prefix: This is used to remove a prefix on the animation name. For  instance, if we want 
"Wishling_Idle" to become "Idle",  we set the prefix to "Wishling_". This is useful  where the 
animation name for games is same for all the characters.

 l Animation Folder Name: The name of the sub-folder that contains the generated Unity animation 
files.

 l Import: The button to trigger the importing process.

 2. Click the Import button to start the import process and the prefab generation.
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The importer will automatically generate a prefab that can easily be dragged into the scene to use as a Game 
Object.

NOTE 

 l For large characters this can be a lengthy process.

 l If the sprite were exported separately, it will also generate sprite atlases for the asset.
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Asset Manipulation

This section consists of two new components Harmony Mesh and Harmony Renderer once the prefab is 
created..

Harmony Mesh

The Harmony Mesh component is used by the Harmony Renderer to create asset meshes based on the 
exposed drawings in your animation.

Harmony Renderer

Harmony Renderer is used to control the animation and rendering of Harmony assets as well as exposing 
important variables you may want to change during runtime.

 l Project: A reference to the Harmony Project Binary asset. This asset is generated by the importer and 
contains the Harmony project data in an efficient binary format.

 l Render Settings: The render settings are used to modify your asset, either by changing the resolution or 
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the Shader used to render or the quality of the  deformation.

 l Resolution: The resolution used to display this character. This matches associated sprite sheets names.

 l Material: The material used to shade this character. Hardware Skinning is the default unlit material 
provided with the SDK.

 l Color: Option that multiply the selected color onto the asset.

 l Discretization Steps: Slider that defines the arrangement of all the deformed drawings.

 l Clip Settings: The clips settings are used to see the animations without opening the Animation window. 
This only affects the project when in Editor mode, when you play the game, the Animator overrules the 
settings inside the Clip Settings.

 l l Current Clip Index: A numerical clip index to display. It can be animated in the Animation 
window.

 l Current Clip: A drop down for selecting which animation to display. It matches the Current Clip 
Index.

 l Current Frame: The frame number currently being displayed.

 l Animation Settings: These settings are same as importing Asset settings. It is useful while importing or 
re-importing asset modifications inside Harmony. Once modifications are done click Update Animator or 
Update Current Clip in order to save your modifications.
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 l Frame Rate: The animation frame rate used by Unity's animation system to playback the 
Harmony frames. This should match your frame rate in Harmony.

 l Stepped: If checked, the animations will pass between integer  frames and thus not interpolate 
smoothly. If unchecked, the animation will be played back between integer frames, for a smooth 
animation.

 l Strip Prefix: This is used to remove a prefix on the animation name. For  instance, if we want 
"Wishling_Idle" to become "Idle",  we set the prefix to "Wishling_". This is useful  where the 
animation name for games is same for all the characters.

 l Update Animator: Click this button to update the entire set of  animations on this character to 
match what is in the Harmony project. This will update existing animations with the new settings 
you entered and add any missing ones.

 l Update Current Clip: This will update only the currently selected clip.

 l Skin Settings: The Skin Settings allow you to change in real-time the skin you’ve exported from 
Harmony. To change a skin you first need to press the + button to add a group, you need to add as many 
groups as you had in your Harmony export. If you had no groups, just add one and leave it on all. You can 
define which group you want to modify, and then which skin to assign to which group. You can then 
remove a group by selecting any group and pressing the - button.
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How to change a skin

 1. Click  button to add a group/groups.

 2. Modify the group, and assign the skin to group.

 3. Remove a group by selecting any group and clicking  button.
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Harmony Previewer

This section explains how to use the Harmony Previewer to view animations without installing Unity.

You can find a build for Windows or macOS inside the Harmony Game Previewer folder that you can just unzip. 

NOTE 

Do not unzip the build inside your Unity project, it is advised to unzip it in its own folder.

How to use the Previewer
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 1. Run the Harmony Game Previewer.exe or Harmony Game Previewer.app

 2. Select which project to load from the loader menu. These projects are loaded from the Harmony 
Resources folder in the same directory as  the Harmony Game Previewer.exe or Harmony Game 
Previewer.app

 3. Navigate through the animations using Prev / Next button.

 4. Adjust the Frame Rate, Tint, Discretization Step and Skin settings with the controls at the top left.

 5. Click Go back button to return to the previous menu and load a different animation.
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Troubleshooting

Unity Questions

Q. My Harmony asset does not appear in the Unity Editor.

A. There are several possible reasons for this. Check the following:

 l Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory?  The plugin 
is named HarmonyRenderer.bundle on macOS and HarmonyRenderer.dll on 
Windows.

 l Is the clip name valid ? Make sure the clip name exists in the stage.xml file.

 l Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a 
newer version, make sure to regenerate the binary files if you use them so they’re 
compatible with the SDK.

Q. My Harmony asset does not appear in iOS or Android when exported from Unity.

A. There are several possible reasons for this. Check the following:

 l Make sure the Harmony assets are copied in the StreamingAssets directory. Since the 
HarmonyRenderer plugin cannot use Unity’s asset database, the Harmony assets were 
packaged as plain files so they are accessible to the plugin.

 l Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is 
in the Assets/Plugins/iOS directory.

 l Is the clip name spelled correctly? Windows and macOS aren’t usually case sensitive file 
systems, but iOS and Android are. This implies that an asset that is visible on the editor 
will not appear on the mobile platform because it cannot be found.

 l Make sure the size of your sprite sheets does not exceed the hardware limit of the device 
you're working on. Otherwise, the texture might not appear at all.

 l Is the path to the project folder an absolute path? If it is, it might not work on the mobile 
device as that path will not exist on the platform. Make sure to use relative paths to the 
StreamingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always 
appear behind the Harmony assets even if I change the order index in the GameObjects.

A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are, 
however, several solutions for working around this problem:

Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite 
like the other 3D elements in the scene and you can change the compositing order by incrementing or 
decrementing the Z value of the transform.

Use multiple cameras to render your scene in parts. Here’s how:
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Harmony Camera

 1. Create a new camera.

 2. Make sure you set the Harmony GameObjects to a specific layer (top-right of the game object inspector).

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in the 
background).

 4. Add the HarmonyCamera component to this camera so the Harmony GameObjects render properly.

Sprite Camera

 1. Create a new camera.

 2. Make sure to set the 2D sprite objects to a specific layer.

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in front of the 
2D sprites).

 4. Make sure to set the clear flags to Depth Only or Don't Clear.

 5. Set the depth to be higher than the Harmony camera.

 6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to 
keep Game Ojects in sync.

Q. How can you specify the frame rate of the animation?  My animation does not play at the same frame rate in 
Harmony and in the Game Previewer in the Unity Editor.

A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the 
HarmonyAnimation component, you can schedule animations at the speed you want.

Example

HarmonyAnimation animation = GetComponent<HarmonyAnimation>();

if (animation != null)

{

animation.PlayAnimation( frameRate, clipName );

}

Q. I cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?

A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer 
component in the GameObject, and so cannot be shown directly in the Scene view.

However, you should still be able to preview your assets in the Game view (even when not playing).   To help 
find and position assets, we also added bounding box shapes rendered in the editor and the Game view.

Q. How is memory management handled in Unity for Harmony assets?

A. Most of the memory extensive algorithms are executed in the C++ plugin.  The data structure is maintained 
alive as long as a GameObject refers to it.  This means you can instantiate as many clones of a character without 
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reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its 
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject 
uses them and a cleanup call is issued once they are destroyed.

Q. The Harmony assets memory does not appear in the Unity profiler.  Can we profile the assets memory?

A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a 
C++ plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers 
such as the one provided with XCode or Visual Studio should allow you to track your application’s memory 
including the Harmony assets and should also provide a more accurate result.

General Questions

Q. How can you specify the resolution used for the drawings in the sprite sheet?

A. The drawing resolution is not fixed in Harmony.  Since you're exporting the scene to multiple sprite sheets in 
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to 
see the resolution of a drawing compared to the rest of the scene.  By enabling the light table in the Drawing 
view, you will see all of the scene’s drawings untransformed in the same proportion as they will appear in the 
sprite sheet. More specifically, the resolution used in the sprite sheet for a drawing is the size it appears 
untransformed in the Camera view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export 
Sprite Sheet dialog box).

Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a 
drawing and use the Transform tool to scale it back up so it does not change visually in the Camera view. This 
should allow you to alter the size of drawings in the sprite sheet.

Q. The assets take time to load on mobile devices. Is there any way to speed up the process?

A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines. 
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project. 
At some point, they should be converted to a binary compact data structure that can be read into memory a lot 
faster than the XML.

You can use the Xml2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool 
is in the Utils/Xml2Bin folder and a precompiled version for macOS is available in the Utils/macosx 
folder.

Q. There are problems with the character I exported in the game engine. Pieces are not exported or are not 
showing in the proper order. What can I do ?

A.  To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are 
some of the key points for building a character that is compatible with the rendering in the game engine SDK:

 l Build your rig in the Timeline view. The game engine SDK data structure is similar to what 
is displayed in the Timeline view and an advanced node system might not always export 
properly.
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 l Because every top level node in your scene will render separately in the game engine 
SDK, they may not intersect. A top level node is also isolated in its separate sprite sheet to 
allow the artist better memory segmentation of the character. If you created a character 
with top level nodes and this was not the intended result, create a top level group or peg 
to group them all together.

 l Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its 
parent (as it does in Harmony).  To change the ordering, add some Z offset to the child 
layer.

 l The export script does not handle plain bitmap images.  Toon Boom vector drawings and 
Toon Boom bitmap drawings are supported though.

 l The export script does not handle symbols.

Q. There are some animation issues when playing the game, the animation will always default to 
the first animation in the drop-down list (usually Idle).

A. This is because Idle is set as the default state in the animation controller. Do the following:

 l You can edit the animation controller using Window Animator.

 l You will see the animation state machine. Notice the arrow connecting Entry 
to the Idle state.

 l Changing the default state of the state machine to a different state, will 
change which animation plays while in play mode and move this arrow.

 l By right-clicking and choosing "Make Transition" you can link animations 
together for playback.

 l The game developer is responsible for changing the animation state 
machine to match the needs of the game.
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Chapter 28: Scripting Guide
T-ANIMPA-007-001 & T-HSCP-001-001

Harmony provides you with several scripting interfaces to allow you to automate and streamline certain tasks 
as well as to add customs functionalities to the application. Those scripting interfaces use Qt Script, a scripting 
language based on the ECMAScript standard which is very similar to JavaScript. 

Harmony has four different scripting interfaces:

 l Harmony Scripting is the main scripting interface. Among many possible uses, Harmony scripts can 
automate workflows and functionalities in Harmony, create dialogs and perform batch operations on a 
scene.

 l The Extended Scripting Interface is a suite of modules for power users. It includes modules for editing 
drawings, for creating tools and toolbars and for executing Python scripts.

 l The Script Node is a special node which can take input from image or peg nodes, process its information 
in a custom-made script and output the processed peg or image information in the desired way. It allows 
you to create nodes that have custom behaviours. For example, the Maya Render Batch node is actually 
a Script Node configured to render your scene through an external rendering engine.

 l Control Center Scripting allows you to create scripts that can be launched in a command line interface 
via the Control Center application. They can be used to perform batch operations on the different 
elements of a Harmony Server database.

Harmony Scripting Reference

This section of the documentation explains how to use the Harmony Script Editor, but does not teaches how to 
write scripts nor does it contain in-depth information about the classes and modules that are available in the 
Harmony scripting interface. The reference guides for each of the Harmony scripting interfaces are located on 
different documentation websites. These reference guides document all the modules and classes that are 
available in the Harmony scripting interfaces, as well as all of their methods and properties. 

To access one of the Harmony scripting interface reference guides, open the Help menu at the top of the 
Harmony user interface and select Scripting Interface Documentation, Extended Scripting Interface 
Documentation or Script Node Documentation.

To access the Control Center scripting interface reference guide, open Control Center. Then, in the top menu 
of the Control Center user interface, open the Help menu and select Scripting Interface Documentation.

About Qt Script

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and 
JScript. However, there are some differences that distinguish Qt Script from these other scripting languages, 
which are familiar to web programmers. 
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The Qt Script environment provides several standard classes and modules that are not documented in the 
Harmony scripting documentation. For a reference of the QT development environment, refer to the Qt 
Documentation website, which can be accessed at the following address:

http://doc.qt.io/qt-4.8/index.html

For a tutorial on writing JavaScript, refer to to the JavaScript Tutorial section of W3Schools, which can be 
accessed at the following address:

https://www.w3schools.com/js

NOTES 

As of Toon Boom Harmony 10.3, Toon Boom Animation has changed its scripting language from 
QSA script to Qt Script. Scripts are stored in plain text in files with the .js extension, instead of
 .qsa. This change to the API improves the software and gives access to 64-bit capabilities of the 
scripting interface.

Eery effort was made to ensure backward compatibility with QSA scripts. Hence, simple functions 
can be ported without making any changes, but class definitions must conform to the Qt Script 
syntax. Therefore, scripts that define classes must be updated. For detailed instructions on how to 
update from QSA to Qt scripts, see the Moving from QSA to Qt Script documentation of the Qt 
website, which can be accessed at the following address:

http://doc.qt.io/qt-4.8/porting-qsa.html 
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Creating Scripts
T-HSCP-001-002

You can create scripts for Harmony by using the Script Editor view. 

TIP 

To help familiarize yourself with Harmony scripts, you can open the Script Editor view and look into 
the TB_sceneCreated script. This script is automatically executed when you create a scene. By 
default, it sets the scene's length to 60 frames and creates a basic layout containing a single 
drawing layer. You can customize this script to automatically set up scenes you create to fit your 
project's needs.

NOTE 

                                 When using Harmony Stand Alone, user scripts are stored in the following location:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony Premium\2000-scripts

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon 
Boom Harmony Premium/2000-scripts

 l GNU/Linux: /home/[username]/Toon Boom Animation/Toon Boom Harmony 
Premium/2000-scripts

When using Harmony Server, user scripts are stored in the following location, depending on the 
level at which you save them:

 l User: /USA_DB/users/[username]/Harmony Premium/2000-scripts

 l Job: /USA_DB/jobs/[job_name]

 l Environment: /USA_DB/environments/[environment name]

 l Global: /USA_DB/scripts

How to create a script

 1. In the top-right corner of the Camera or Drawing view, click on the  Add View button and select 
Script Editor.

The Script Editor view is added to your workspace. It lists all the scripts packaged with Harmony as 
well as any script you previously created.
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 2. Do one of the following:

 l In the Script Editor toolbar, click the  New Script   button. 

 l In the top-left corner of the Script Editor view, click on the  Menu button and select select 
File > New Script.

The New Script dialog box appears.

 3. Type in a name for your script and click on OK.

A dialog prompts you to select the location in which to create the script.

 4. In the drop-down menu, select the location in which you want to create the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.
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NOTE 

If you are using Harmony Stand Alone, the script will be saved to the preferences 
for your account on your computer. if you are using Harmony Server, the script 
will be saved to the preferences for your Harmony database user.

 l Global: If you are using Harmony Server, select this option to save the script to the Harmony 
database's global script directory. Anyone who is logged in to the database will be able to 
edit and run this script. 

 l Environment: If you are using Harmony Server, select this option to save the script to the 
current scene's environment. Anyone will be able to edit and run the script as long as they 
are working on a scene inside this environment.

 l Job: If you are using Harmony Server, select this option to save the script to the current 
scene's job. Anyone will be able to edit and run the script as long as they are working on a 
scene inside this job.

 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 

 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

Your script is added to the list of scripts in the Script Editor.

 5. Select the script your just created in the list. 

You can now start editing your script in the Script Editor. 

 6. Click on the text field in the right area of the Script Editor and start writing your script. 

The following is an example of a script that will display a message box saying "Hello World!"

function HelloWorld()
{
   MessageBox.information("Hello World!");
}
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NOTE 

For information on how to use the Qt scripting language in Harmony, see Scripting Guide on 
page 774. You can also open the scripting reference guide directly from the Script Editor by 
clicking on the  Menu button in the top-left corner and  selecting Help > Scripting Interface 
Documentation.
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Editing a Script Packaged with Harmony
Harmony comes pre-installed with several scripts. These scripts are stored in a read-only location among 
other files that are packaged by Harmony. Hence, by default, they cannot be edited. 

To edit a script that was installed with Harmony, you must copy it to a location where it can be edited. This can 
easily be done by using the Make Editable button of the Script Editor view. This button creates a copy of the 
script and stores it in a location where you can make changes to it. Meanwhile, the original copy of the script 
remains untouched, and it is possible to revert to it later if you want. 

IMPORTANT 

Some buttons and menu items in the Harmony user interface run scripts that are packaged with 
Harmony. Hence, making changes to scripts packaged with Harmony may impact its functionality.         

NOTE 

If you make unwanted changes to a script that was packaged with Harmony, you can restore its 
original version—see Restoring a Harmony Script on page 791.

How to edit a script that is packaged with Harmony

 1. In the file list of the Script Editor, select any of the scripts that are packaged with Harmony. 

TIP 

Scripts that are packaged with Harmony have Application Resources as their location.

 2. Under the script editor, click on the Make Editable button.

A dialog prompts you to select the location in which to copy the script.

 3. In the drop-down menu, select the location in which you want to copy the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.
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NOTE 

If you are using Harmony Stand Alone, the script will be saved to the preferences 
for your account on your computer. if you are using Harmony Server, the script 
will be saved to the preferences for your Harmony database user.

 l Global: If you are using Harmony Server, select this option to save the script to the Harmony 
database's global script directory. Anyone who is logged in to the database will be able to 
edit and run this script. 

 l Environment: If you are using Harmony Server, select this option to save the script to the 
current scene's environment. Anyone will be able to edit and run the script as long as they 
are working on a scene inside this environment.

 l Job: If you are using Harmony Server, select this option to save the script to the current 
scene's job. Anyone will be able to edit and run the script as long as they are working on a 
scene inside this job.

 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 

 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

 4. Click on OK.

In the file list, the location of the selected script is updated to the one you selected.

Under the script editor, the Make Editable button is replaced with the Save button. This means that 
you can make changes to the script and save those changes.
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Checking Script Syntax
You can verify the syntax of your script before you attempt to run it. 

How to verify the syntax of a script 

 1. In the File list of the Script Editor, select the script you want to check. 

 2. Under the editor, click on the  Verify button. 

A dialog appears and displays whether or not it found a syntax error in the script, and if it did, the 
location and type of error. 
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Testing a Script
You can test a script using the  Run command, which is available in the Script Editor toolbar and menu. The 
run command can execute a specific function in one of your scripts, or an entire script. What the Run command 
is set to run is called the target.

To select which function in which script the Run command should execute, you must use the  Set Target 
command, which will prompt you to select a script and a function. Once you've done this, every time you use 
the  Run command, it will execute the function you set as your target. If you need to test a different function 
or script later, you will have to use the  Set Target command again to change the target script and function. 
This allows you to work on and repeatedly test one script or one function at a time when working on a script. 

NOTES 

 l If you use the  Run command without setting a target first, you will be prompted to set a 
target. The selected target will persist until you use the  Set Target command to change it.

 l The target script and function is also used by the  Debug command. 

 l To run a script from the global scope rather than running a specific function, you can select 
<Nothing> as the target function.                 

 l Although you can run  a script at the global scope, you cannot create a toolbar button that runs 
a script at the global scope. Toolbar buttons can only run specific functions within a script. 
Hence, running a script at the global scope should be done for testing purposes only.

How to test a script

 1. If you are currently editing the script you want to test, save it by clicking on the Save button 
underneath the editor. 

 2. Do one of the following:

 l In the Script Editor toolbar, click on the  Set Target button.

 l In the top-left corner of the Script Editor, click on the  Menu button and  select 
Play/Debug > SetTarget.
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A dialog appears listing all the scripts as well as all the functions in the current script. 

 3. In the Files list of the dialog, select the script you want to test.

 4. In the Functions list of the dialog, select the function you want to test. 

NOTE 

If you want to test the whole script from the global scope, select the <Nothing> 
function.

 5. Click on OK. 

 6. Do one of the following to execute the target function:

 l In the Script Editor toolbar, click on the  Run button.

 l In the top-left corner of the Script Editor, click on the  Menu button and select 
Play/Debug > Run.
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Debugging Scripts
T-HSCP-001-003

If you are having issues with a script you're working on, you can debug your script using the  Debug 
command. With the Debug command, you can run a specific function in your script, or an entire script, through 
a debugging interface.

To select which function in which script the Debug command should debug, you must use the  Set Target 
command, which will prompt you to select a script and a function. Once you've done this, every time you use 
the  Debug command, it will debug the function you set as your target. If you need to debug a different 
function or script later, you will have to use the Set Target command again to change the target script and 
function. This allows you to work on and repeatedly debug one function at a time when working on a script. 

NOTES 

 l If you use the Debug command without setting a target first, you will be prompted to set a 
target. The selected target will persist until you use the  Set Target command to change it.

 l The target script and function is also used by the  Run command. 

 l To debug a script from the global scope rather than debugging a specific function, you can 
select <Nothing> as the target function.

 l Although you can run  a script at the global scope, you cannot create a toolbar button that runs 
a script at the global scope. Toolbar buttons can only run specific functions within a script. 
Hence, debugging a script at the global scope should be done for testing purposes only.

How to debug a script

 1. If you are currently editing the script you want to debug, save it by clicking on the Save button 
underneath the editor. 

 2. Do one of the following:

 l In the Script Editor toolbar, click on the  Set Target button.

 l In the top-left corner of the Script Editor, click on the  Menu button and  select 
Play/Debug > SetTarget.
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A dialog appears listing all the scripts as well as all the functions in the current script. 

 3. In the Files list of the dialog, select the script you want to debug.

 4. In the Functions list of the dialog, select the function you want to debug.

 5. 
NOTE 

If you want to debug the whole script from the global scope, select the <Nothing> 
function.

 6. Do one of the following to execute the target function:

 l In the Script Editor toolbar, click on the  Run button.

 l In the top-left corner of the Script Editor, click on the  Menu button and select 
Play/Debug > Debug.

The Qt Script Debugger opens. In it, you will find standard debugging controls. 
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Using the Scripting Sandbox
The sandbox is a space in the Script Editor in which you can type or paste code snippets and test or debug 
them on the fly, without having to put them in the context of a function, and without having to create a script 
or to modify an existing script. It's also a useful tool to get yourself familiarized with the Harmony scripting 
interface.

How to use the Script Editor sandbox

 1. In the File list, select << Sandbox >>.

 2. In the text field of the script editor, type in your code.

The following sample code will display a message box saying "Hello World!"

 MessageBox.information("Hello World!");

 3. Do one of the following:

 l To verify the syntax of your script, click on the Verify button under the text field. 

 l To test your script, click on the  Run button in the Scripting toolbar or, in the top-left 
corner of the Script Editor, click on the  Menu button and select Play/Debug > Run. 

 l To debug your script, click on the  Debug button in the Scripting toolbar or, in the top-left 
corner of the Script Editor, click on the  Menu button and select Play/Debug > Debug. 
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Importing Scripts
T-ANIMPA-007-002

If you want to use scripts written by other users, you can transfer the .js files from their computer to yours, 
then use the Script Editor to import the .js files from where they are stored on your computer. 

NOTES 

 l When you import a script, any user interface (.ui) or icon (.png) file that is in the same 
directory and has the same filename as the script will also be imported.

 l                                  When using Harmony Stand Alone, user scripts are stored in the following location:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Premium\2000-scripts

 l macOS: /Users/[username]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Premium/2000-scripts

 l GNU/Linux: /home/[username]/Toon Boom Animation/Toon Boom Harmony 
Premium/2000-scripts

When using Harmony Server, user scripts are stored in the following location, depending on 
the level at which you save them:

 l User: /USA_DB/users/[username]/Harmony Premium/2000-scripts

 l Job: /USA_DB/jobs/[job_name]

 l Environment: /USA_DB/environments/[environment name]

 l Global: /USA_DB/scripts

How to import scripts

 1. Do one of the following:

 l In the Script Editor toolbar, click on  Import Script.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select File > 
Import Script. 

An Open dialog appears.

 2. In the Open dialog, browse to the location of the script you want to import. Select it, then click on 
Open.
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A dialog prompts you to select the location in which to import the script.

 3. In the drop-down menu, select the location in which you want to import the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.

NOTE 

If you are using Harmony Stand Alone, the script will be saved to the preferences 
for your account on your computer. if you are using Harmony Server, the script 
will be saved to the preferences for your Harmony database user.

 l Global: If you are using Harmony Server, select this option to save the script to the Harmony 
database's global script directory. Anyone who is logged in to the database will be able to 
edit and run this script. 

 l Environment: If you are using Harmony Server, select this option to save the script to the 
current scene's environment. Anyone will be able to edit and run the script as long as they 
are working on a scene inside this environment.

 l Job: If you are using Harmony Server, select this option to save the script to the current 
scene's job. Anyone will be able to edit and run the script as long as they are working on a 
scene inside this job.

 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 

 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

 4. Click on OK.

The script is copied to the chosen location and can now be edited and executed in the Script Editor 
view. It can also be added as a button to the Scripting toolbar—see Adding Scripts as Toolbar 
Buttons on page 799.
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Deleting Scripts
You can delete custom scripts from the Script Editor.

IMPORTANT 

When you delete a script in the Script Editor, the file containing this script is permanently deleted 
from your file system.

NOTES 

 l You cannot delete a script that is in the Application Resources folder. Those scripts were 
installed with Harmony and are read only. 

 l If you made a script that was packaged with Harmony editable by copying it to another 
location, you can delete your version of the script. This will restore the original version of the 
script to the File list. 

How to delete a script

 1. In the Script Editor, in the File list, select the script you want to delete.

 2. Do one of the following:

 l From the Script Editor toolbar, click the  Delete Script button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select File > 
Delete Script. 

TIP 

If you have deleted one of the scripts that are packaged with Harmony and wish to restore it, 
see Restoring a Harmony Script on page 791
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Restoring a Harmony Script
If you made a script that was packaged with Harmony editable so you could make changes to it, you can easily 
revert to the original version of the script at any time by using the Restore to Default button of the Script 
Editor view. This button deletes your copy of the script and restores the version of the script that was installed 
with Harmony to the File list. 

IMPORTANT 

Restoring a Harmony script to its original version will permanently discard any changes you made 
to it. 

How to restore a script packaged with Harmony to its original version

 1. In the File list of the Script Editor view, select a script that was installed with Harmony and to 
which you made changes that you want to revert.

 2. At the bottom of the Script Editor view, click on the Restore to Default button.

A prompt will ask you to confirm discarding the changes you made to the script. 

 3. If you are sure you want to permanently revert the script to its original version, click on Yes. 

The script is restored to the original version that was installed with Harmony. 

NOTE 

When restoring a script to its original version, its location is set to Application 
Resources and it becomes read-only, as it was before you made changes to it. If you 
want to make changes to the script again, you must make it editable again—see Editing 
a Script Packaged with Harmony.
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Using an External Script Editor
T-HSCP-001-004

If you are more comfortable editing your scripts using another text editor or syntax highlighter, Harmony 
allows you to set an external script editor and use that one instead.

NOTE 

On Windows and macOS, if you try to open a script in the external editor without setting it first, 
Harmony will open the script in the default editor for JavaScrtipt (.js) files on your machine. 

How to set an external editor

 1. Do one of the following:

 l In the Script Editor toolbar, click the  Set External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> Set External Editor. 

The Set External Editor window opens.

 2. In the external editor, type  the complete and absolute path to the text editing application you want 
to use, including its name and extension. For example, if you want to use notepad++ on Windows, 
you could type:

C:\Program Files\Notepad++\notepad++.exe

On macOS, if you want to use an application that supports the AppleScript Open Document 
protocol, simply typing the name of the application might work, for example:

TextWrangler

Typing the name of the application you want to use will also work if that application has its path in 
the PATH environment variable, such as notepad on Windows or gedit on GNU/Linux. 

 3. Click on OK.

How to edit a script in an external editor

 1. In the File list, select the script you want to edit. 
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 2. Do one of the following:

 l In the Script Editor toolbar, click the  Open with External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> External Editor. 

 3. In the external editor that opens, make the desired changes to your script, save the script and close 
the external editor. 

 4. In Harmony, the changes you made to your script in the external editor will not appear immediately. 
You can load those changes by selecting another script in the File list, then selecting the script you 
changed again. 
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Storing Scripts in a Custom Directory
By default, in Harmony Stand Alone, you can store custom scripts either in your user preferences or in a scene's 
scripts sub-folder. In Harmony Server, you can also store scripts in the folder of a scene's job or environment, 
or in a folder for the entire Harmony database. 

If you prefer, it is possible to store your scripts in a specific custom location on your file system. This is done by 
adding the path to the custom location in the TOONBOOM_GLOBAL_SCRIPT_LOCATION environment variable. 
When this environment variable is set, Harmony will look for JavaScript (.js) files in that directory and add 
them to the list of scripts in the Script Editor, with System Variable as their location. 

Additionally, when you create a script, import a script or make an original Harmony script editable, you will get 
to store the script in the directory in the TOONBOOM_GLOBAL_SCRIPT_LOCATION environment variable by 
selecting System Variable in the prompt asking you where to store the script.

If you are working in a collaborative environment, you can make this directory read-only so that only people 
with special privileges can add or edit scripts in this directory. Harmony will check whether it has privileges to 
edit scripts in this location before allowing users to make changes to them. Otherwise, Harmony will only 
allow the user to run them. 

The method for setting an environment variable varies depending on the operating system you're using, as 
well as whether you want the environment variable to be set for everyone who uses the computer, or only the 
current user.

How to set the path to the custom scripts directory for the current user on Windows

 1. Open the Windows Control Panel:

 l On Windows 7: Open the Start menu and select All Programs > Accessories > System 
Tools > Control Panel.

 l On Windows 8.1 or Windows 10: Open the Start menu and, in the programs list, select 
Windows System > Control Panel.

 2. Select User Accounts, then User Accounts again.

 3. In the left pane, select Change my environment variables. 

 4. Under the User variables list, click on New.

The New User Variable dialog appears.

 5. In the Variable Name field, type TOONBOOM_GLOBAL_SCRIPT_LOCATION.

 6. Click on Browse Directory.

A Browse for Folder dialog appears.

 7. Browse to and select the directory in which you want to store scripts, then click on OK.
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 8. In the New User Variable dialog, click on OK. 

 9. In the Environment Variables dialog, click on OK. 

The next time you launch Harmony, you will be able to create, load and edit scripts in the directory 
you set as a custom script location.

How to set the path to the custom scripts directory for all users on Windows

 1. Open the Windows Control Panel:

 l On Windows 7: Open the Start menu and select All Programs > Accessories > System 
Tools > Control Panel.

 l On Windows 8.1 or Windows 10: Open the Start menu and, in the programs list, select 
Windows System > Control Panel.

 2. Select System and Security > System.

 3. In the left pane, select Advanced system settings. 

 4. Open the Advanced tab.

 5. Click on Environment Variables.

 6. Under the System variables list, click on New.

The New System Variable dialog appears. 

 7. In the Variable Name field, type TOONBOOM_GLOBAL_SCRIPT_LOCATION.

 8. Click on Browse Directory.

A Browse for Folder dialog appears.

 9. Browse to and select the directory in which you want to store scripts, then click on OK.

 10. In the New System Variable dialog, click on OK. 

 11. In the Environment Variables dialog, click on OK. 

The next time you launch Harmony, you will be able to create, load and edit scripts in the directory 
you set as a custom script location.

How to set the path to the custom scripts directory for the current user on macOS

 1. In a Terminal, type in the following command to create a launch agent for your user:

$ vi ~/Library/LaunchAgents/com.toonboom.global.script.location.plist
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 2. Press the i key to enter insert mode and start editing the file.

 3. Add the following text to the launch agent, replacing <path to scripts directory> with the 
absolute (full) path to the directory where you want to store scripts:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0/EN" "http://www.apple.com/DTDs/PropertList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>Label</key>
   <string>com.toonboom.global.script.location</string>
   <key>ProgramArguments</key>
   <array>
     <string>sh</string>
     <string>-c</string>
     <string>launchctl setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts directory>"</string>
   </array>
   <key>RunAtLoad</key>
   <true />
</dict>
</plist>

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 

 1. In the terminal, type the following command to enable the launch agent:

$ launchctl load -w 
~/Library/LaunchAgents/com.toonboom.global.script.location.plist

How to set the path to the custom scripts directory for all users on macOS

 1. In a Terminal, type in the following command to edit the login script for all users:

$ sudo vi /etc/profile

 2. Press the i key to enter insert mode and start editing the file.

 3. Add the following lines at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

export TOONBOOM_GLOBAL_SCRIPT_LOCATION="<path to scripts directory>"
 launchctl setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts directory>"

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 
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How to set the path to the custom scripts directory for the current user on GNU/Linux

 1. In a Terminal, type in the following command to edit the Bash login script for your user:

$ vi ~/.bash_profile

 2. Press the i key to enter insert mode and start editing the file.

 3. Add the following line at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

export TOONBOOM_GLOBAL_SCRIPT_LOCATION="<path to scripts directory>"

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 

 6. In the same Terminal, type in the following command to edit the CSH login script for your user:

$ vi ~/.login 

 7. Press the i key to enter insert mode and start editing the file.

 8. Add the following line at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts directory>"

How to set the path to the custom scripts directory for all users on GNU/Linux

 1. In a Terminal, type in the following command to edit the Bash login script for your user:

$ sudo vi /etc/profile

 2. Press the i key to enter insert mode and start editing the file.

 3. Add the following line at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

export TOONBOOM_GLOBAL_SCRIPT_LOCATION="<path to scripts directory>"

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 

 6. In the same Terminal, type in the following command to edit the CSH login script for your user:

$ sudo vi /etc/csh.login 
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 7. Press the i key to enter insert mode and start editing the file.

 8. Add the following line at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts directory>"

798



Adding Scripts as Toolbar Buttons
To use scripts in your regular workflow, you can add them as buttons to the Scripting toolbar. You can add 
buttons to the Scripting toolbar that are configured to run ax specific function in a script and, if you want, give 
these button a specific icon and tool tip. 

NOTE 

For more information on the Scripting toolbar and the Scripts Manager dialog, see the Reference 
Guide. 

How to link a script to a toolbar button

 1. Add the Scripting toolbar to your workspace by doing one of the following:

 l From the top menu, select Windows > Toolbars > Scripting.

 l Right-click on any toolbar and select Scripting.

The Scripting toolbar is added to your workspace.

 1. In the Scripting toolbar, click the  Manage Scripts  button.

The Scripts Manager dialog box opens and displays the available scripts.

 2. In the Files list, select the script file containing the function you want to add to the toolbar.

The functions in the selected script appear in the Functions list.

 3. In the Functions list, select the function that you want to add to the toolbar.
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 4. Between the Functions and In Toolbar list, click on the  Right Arrow  button.

The selected function is added to the In Toolbar list. 

 5. If you want to add a custom icon to the toolbar button for your script, click on the Customize Icon 
button and, in the Open dialog that appears, browse to and select the icon file that you want the 
button to have. 

You can use .png, .jpg, .xpm or .tvg files as toolbar icons. 

 6. If you want to add a custom tooltip to the toolbar button for your script, click on the Customize 
Tooltip button and, in the dialog that appears, type in the tooltip for your toolbar button.

 7. Click on OK.

A button for the selected function is added to the Scripting toolbar. If you click on this button, the 
function your selected will be executed. 

TIP 

You can stop a script while it is running by pressing the Esc key or clicking on the  Stop  
button on the Scripting toolbar.
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Accessing Node Attribute Names for Scripting
If you want to make scripts that manipulate elements in your scene, you must use the proper methods and 
naming conventions to access the attributes of nodes in your scene via the scripting interface. For example, if 
you have a peg node named Drawing-P at your scene's root, you can obtain the position of a peg node on the 
(x) axis with the following steps:

var sNode = "Top/Drawing-P"; // The full path to the node.
var wAttr = node.getAttr(sNode, 1, "position.x"); // The attribute for this node's position on the (x) axis.
var myAttributeValue = wAttr.doubleValue(); // The value of the attribute.

The same can be done in a single line.

var myAttributeValue = node.getAttr("Top/Drawing-P", 1, "position.x").doubleValue();

You can easily get similar examples of how to access any attribute for any note by enabling the Show Attribute 
Information option of the Node View. When this option is enabled, in the Layer Properties dialog, each 
attribute will have a button allowing you to view the full path to the node, the real name of the attribute in the 
scripting interface, the type of the attribute as well as a code example of how to obtain the attribute's value.

How to obtain information for accessing a node's attribute via the scripting interface

 1. In the top-left corner of the Node view, click on the  Menu button and select View > Show 
Attribute Information.

 2. In the Node view, locate the node which you want to manipulate through scripting. 

 3. Click on the  Layer Properties  button for this node. 

The Layer Properties dialog for this node appears. Right of each attribute is a  Show Attribute 
Information button. 
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 4. Click on the  Show Attribute Information button next to the attribute which you want to access 
through scripting. 

The Attribute Information dialog appears and displays information on the attribute, as well as a 
sample script to access the attribute.
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