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Introduction

Introduction
Harmony is a complete animation software allowing you to create all kinds of creative animation projects. It 
comes with a very wide variety of tools and features. 

In this Getting Started Guide, you will learn the basics of how to use the main features in Harmony Essentials, 
which will quickly bring you up to speed. Refer to the complete Toon Boom Harmony Essentials documentation 
available online at docs.toonboom.com to learn about all the tools and options, as well as more advanced 
techniques.
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Chapter 1: Creating a Scene

Chapter 1: Creating a Scene
As soon as you launch Harmony, you are greeted with the Welcome screen, from which you can:

 l Create scenes

 l Choose your new scene's resolution

 l Manage your scene resolution presets

 l Quickly open recently opened scenes

 l Browse for and open a scene you already created.

 l Watch Harmony video tutorials on the web.

 l Access the support web page.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.
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NOTE 

The scene name should not exceed 23 characters and cannot contain special 
characters, such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location 
field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created. The main application window will appear with your new scene opened in it.
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Chapter 2: Introduction to the Harmony User Interface
Using Toon Boom Harmony Essentials will be significantly easier if you first become familiar with its user 
interface. The following chapter gives you a basic introduction to the most important elements of the user 
interface. As you go through the ensuing chapters, you will learn more detailed information about each of these 
elements. 

When you start Toon Boom Harmony Essentials for the first time, the default workspace is displayed. The 
workspace is divided in rectangular user interfaces which are referred to as views, each of which has its own 
specific purpose. The top and left side of the user interface, as well as some views, also contain toolbars, each 
with specific functions.

Views
Views are small user interfaces that each have a specific purposes. They can be added to the main application 
window, in which case they are “docked”, or can be opened as separate windows. 

Each views has a tab on top of it which contains its name. Not only this can be used to identify the views you’re 
working with, tabs also allow you to stack several views  in the same area of the user interface. For example, in 
the default workspace, most of the area is occupied by the Camera view. At the top of the camera view are two 
tabs, one that says Camera and the other that says Drawing. This is because the Drawing view is stacked with 
the Camera view, and you can quickly switch between both by clicking on either tab.
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Right of the tabs of each division in your workspace are the  Add View and  Close View buttons, which 
allow you to stack more views or to remove the currently selected view from this area of the workspace. 

Adding a View

You can add, remove, move and stack views all over your workspace to optimize your workflow. 

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the  Add View  button 

 2. Select the desired view from the list.

The view appears as a new tab, in the section of your workspace where you added it.
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NOTE 

Some views, such as the Camera view, can be opened in multiple instances. For example, this 
can be useful if you want to have two instances of the Camera views open, each focused on 
different areas of your scene, to quickly switch between working on these two areas. 

How to add a view to your workspace                                    as a window                 

 1. Open the Windows menu.                     

 2. In the Windows menu, select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

 1. Click and drag the floating view by its tab and do one of the following:

 l Drop the window over another tab to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the 
edge of a view, a cyan rectangle appears, indicating where the view will be docked.
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Here is a short introduction to each of the most commonly used views in Harmony.

Camera view

The Camera view is the centre of operations in Harmony. In this view, you can draw, paint, animate, set up your 
scene, manipulate objects, open symbols and preview your animation.

The Camera view also has a top and bottom toolbar that you can use to navigate in the view, change the 
display mode or go up your symbol hierarchy. 
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Drawing view

In Harmony, you can draw in both the Drawing or Camera views. Although the two views are similar, there are 
some differences  when it comes to drawing.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light 
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion 
Skin to display the previous and next drawings of the currently selected drawing layer.
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Tool Properties view

The Tool Properties view contains the most common options and operations related to the currently selected 
tool. When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select  tool, the Tool Properties view will display the options and operations 
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

15
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Colour view

The Colour view is where you create colours and palettes and import existing palettes into your project. The 
Colour view is also necessary for drawing, painting and creating colour styling.

Timeline view

To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to 
become familiar with the Timeline view, how it works, and its interface.

The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and 
ordering layers. The Timeline view displays layers, effects,  sounds, keyframe values, scene length, layer names, 
drawings, keyframes, timing, and frames.
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The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their 
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing 
name is displayed when you place your pointer over the drawing’s exposure.

Drawing Substitutions View

The Drawing Substitutions view allows you to view all the drawings in the selected layer in a list of thumbnails, 
as well as to quickly select which drawing should be exposed at the current frame. 
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Xsheet view

The Xsheet view lets you read the timing vertically by displaying it in a grid, with each drawing layer 
represented by a column, each frame of your scene represented by a row, and each exposed drawing displayed 
by its name in the cells. It is meant to work like a traditional animation exposure sheet. 

Using the functions panel, you can also view the functions and keyframes of the motion paths for the selected 
column, with the value of those functions for each frame listed in the cells. 

Contrary to the Timeline view, the Xsheet view does not display pegs, effects or layer hierarchy. Hence, it is 
optimized for traditional and paperless animation, whereas the Timeline view is optimized for digital or cut-out 
animation.
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Library view

The Library view is used to store elements such as animation, drawings, backgrounds and character models so 
as to reuse in different scenes and projects. You can also use the Library view to create and store symbols, as 
well as to store and import images and sound files. 

To reuse elements from a scene in other scenes, you must create a template so that you can import it into 
different scenes. Templates can contain anything from a single drawing to a whole scene structure. You can 
create a template by creating it in a scene, then copying the elements you want in your template into a library. 
The resulting template is structured like a mini-scene that contains only the elements you copied into it. A 
template does not have any dependencies on the scene it was originally created in. Hence, it can safely be 
imported in any other scene.

Additionally, the Library view's Drawing Substitutions panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 
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Toolbars
The Harmony interface contains toolbars that quicky give you you access many useful tools. You can add, move 
and remove toolbars in your workspace. 

Toolbars are separated in two main categories:

 l Workspace  toolbars are toolbars that have a general purpose. For example, the File, Edit, Workspace 
and Deformation toolbars at the top, as well as the Tools toolbar on the left, are workspace toolbars. 
Those toolbars can be placed at the top, bottom, left or right edge of the application window. They can 
also be placed at the edge of specific views if preferred. 

 l View toolbars are toolbars that are useful for a specific view. For example, the Camera view has a Camera 
toolbar at its top. View toolbars can only be displayed inside their respective view. They can be placed at 
the top, bottom, left or right edge of their view. 

Adding Toolbars

How to add or remove a workspace toolbar to the general workspace

 1. Do one of the following:

 l In the top menu, select Windows > Toolbars and in the sub-menu, select the toolbar you 
want to add. 

 l Right-click on any toolbar that is at the top or side of the workspace, or in the empty space 
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next to these toolbars, and select the toolbar you want to add in the contextual menu.

How to add a view toolbar to a view

 1. Do one of the following:

 l Click on the tab of the view for which you want to add a toolbar to set the focus on it. Then, in 
the top menu, select Windows > Toolbars and select the toolbar you want to add.

NOTE 

In the list of toolbars in the top menu and in the contextual menu of the 
workspace, the toolbars listed above the separator are workspace toolbars, and 
the ones below the separator are view toolbars.

 l In the top area of the view to which you want to add a toolbar, to the left of its tab, right-click 
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and  select the toolbar you want to add in the contextual menu.

NOTES 

 l In the list of toolbars in the contextual menu of a view, the toolbars listed 
above the separator are workspace toolbars, and the ones below the 
separator are view toolbars.

 l If you select a workspace toolbar in the contextual menu of a view, this 
workspace toolbar will be added to the view. If it was already present in your 
workspace, it will be removed from its previous location.

 l When a workspace toolbar is added to a view that is stacked with other 
views, that toolbar is visible in every view that is stacked in the same area. For 
example, if you add the Advanced Animation toolbar to the Camera view, it 
will also be visible in the Drawing view. 

22



How to move a toolbar around

 1. Click and hold the handle at the left of the toolbar you want to move.

 2. Do one of the following:

 l If the toolbar is horizontal, move it up or down to make it pop out of its row.

 l If the toolbar is vertical, move it left or right to make it pop out of its column.

 3. Do one of the following:

 l To reorder toolbars, drag the toolbar where you want it to be located and drop it.

The toolbar will move to its new position. Toolbars to the right (or to the bottom, if the toolbar 
is vertical) will be offset to make space for it.

 l To move the toolbar to a new row or to a new column, simply move the toolbar where the 
new row or column should be created. For example, to create a new row of toolbars at the top 
of the user interface, move it just below the existing toolbars at the top of the user interface. 
A new row or column will appear, highlighted in cyan.

When you drop the toolbar, the new row will be created and the toolbar will be placed at the 
left end of the row.
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Likewise, to create a new column at the left of the user interface, move the toolbar just right 
of the existing toolbars at the left of the user interface.

 l To move the toolbar to another edge of the user interface, drag it all the way to that edge of 
the user interface.

How to move a toolbar over another toolbar

 1. Make sure both toolbars are in the same row or column. If they are not, move both toolbars to the 
same row or column using the method previously described. 

 l If the toolbars are horizontal, click and hold the handle at the left of the rightmost toolbar. 
Then, without going outside of the toolbar’s row, slide the toolbar towards the left.

 l If the toolbars are vertical, click and hold the handle at the top of the bottom toolbar. Then, 
without going outside of the toolbar’s column, slide the toolbar up. 

As you slide the toolbar over the other toolbar, the other toolbar’s buttons become hidden and a 
pop-up menu button appear.

 2. To separate the toolbars again, simply slide the same toolbar in the opposite direction.
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 3. To expand a toolbar that is overlapped by another toolbar, click on the expand button at the right of 
the overlapped toolbar.

Tools Toolbar

The Tools toolbar contains the main tools you need to work in Harmony. In the default workspace, this toolbar 
located on the left edge of the application window. 

Some of the buttons in the Tools toolbar have a triangle in their bottom-right corner. This is to indicate that 
several tools are stacked on this button. To access these tools, either click and hold on the tool button, or select 
the tool then click on it again. 

TIP 

Many toolbar buttons have a keyboard shortcut associated to them. You can check which keyboard 
shortcut is associated to a button by leaving your mouse cursor over the button for a second. If the 
button has a keyboard shortcut, it will be indicated in the tooltip that appears. 
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File Toolbar

The File toolbar contains buttons for common file operations such as New, Save and Open. These commands 
can also be found in the File top menu.

Edit Toolbar

The Edit toolbar contains common operations such as Undo, Redo, Cut, Copy and Paste. These commands can 
also be found in the Edit top menu.

Playback Toolbar

The Playback toolbar allows you to play your animation as well as to set some playback options such as looping, 
audio playback, playback range and playback speed. 

Interface Navigation
With the help of menu commands and keyboard shortcuts, some views let you navigate their content by 
zooming in, zooming out, panning and rotating them. You can also reset the zoom level, pan and rotation angle 
of these views as needed.

The navigation commands in the table below can be used in the following views, with some exceptions:
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 l Camera

 l Drawing

 l Timeline

 l Xsheet

 l Function

 l Side and Top

TIP 

Keyboard shortcuts can be customized. You can view, search for and change keyboard shortcuts for 
Harmony in the Keyboard Shortcuts dialog. To access the Keyboard shortcuts dialog:

 l Windows: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Essentials > Keyboard Shortcuts.

Command Action Access Methods

Zoom In
Zooms in the 
view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the Timeline and Xsheet views)

Zoom Out
Zooms out the 
view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except in the Timeline and Xsheet 
views)

Zoom In or Out
Zooms in or out of 
the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle mouse button while 
dragging the mouse up or down.

Pan
Moves the view 
horizontally or 
vertically.

Hold down the Spacebar and drag in the direction you want to pan 
the view.

Reset Pan
Resets the view’s 
pan to its default 
position.

View > Reset Pan

Press Shift + N
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Command Action Access Methods

Reset View
Resets the view to 
its default 
position.

View > Reset View

Press Shift + M

The  Reset View button at the bottom of the Camera view.

Reset Rotation
Resets the view’s 
rotation to its 
default position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s 
zoom to its 
default position.

View > Reset Zoom

Rotate View Rotates the view.
While holding Ctrl + Alt (Windows/Linux) or Ctrl + ⌘  (macOS), click 
and drag the rotating disc to rotate it clockwise or counterclockwise.

Rotate 30 CW

Rotates the 
Camera view 30 
degrees 
clockwise, like an 
animation table.

View > Rotate View CW

Rotate 30 CCW

Rotates the 
Camera view 30 
degrees counter-
clockwise, like an 
animation table.

View > Rotate View CCW

Mirror View

Temporarily flips 
the Camera or 
Drawing view 
horizontally, 
allowing you to 
view and edit your 
artwork as if it 
was being 
mirrored.

View > Mirror View

In the Camera or Drawing toolbar, click on the  Mirror View 
button.

Toggle Quick 
Close-up

Instantly 
multiplies the 
view's Zoom 

Shift + Z
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Command Action Access Methods

Factor by 4. For 
example, if the 
Camera View's 
Zoom Factor is at 
100%, this will 
make it toggle 
between 400% 
and 100%. 

Toggle Full 
Screen

Cycles through 
the following 
display modes:

 l Normal 
Full-
Screen: 
The main 
application 
window 
becomes 
full screen.

 l View Full-
Screen: 
The 
selected 
view 
becomes 
full screen 
and all 
other 
views are 
collapsed.

 l Normal: 
The main 
application 
window is 
restored to 
its original 
size and 
collapsed 
views are 
expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  + F (macOS)
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Touch Interface
If you are working with a touch screen, a trackpad or a tablet that supports touch input, you can also use 
standard two-finger gestures to zoom, rotate and pan the Camera and Drawing Views. To be able to do this, 
you must first enable the Support Gestures preference.

How to enable gesture support

 1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS 
X).

 2. Open the General tab.

 3. In the Touch Interface section, check the Support Gestures check box.

 4. Click on OK.

 5. Restart Harmony.

You can now manipulate the Camera and Drawing views by dragging two fingers on your touch 
interface.

How to use gestures

 1. In the Camera or Drawing view, press two fingers a short distance from each other.

 2. Do one of the following:

 l To pan the view, drag your two fingers in any direction, keeping both fingers at the same 
distance from each other.

 l To zoom in, drag your two fingers away from each other.
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 l To zoom out, drag your two fingers closer to each other.

 l To rotate, drag your two fingers in a curve so that they revolve in the same direction.
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Chapter 3: How to Add Layers
Just like with traditional animation, Harmony uses layers to keep elements such as characters, backgrounds and 
props separate from each other, allowing you to animate them independently. 

When you create a new scene, your scene will have a default layer named Drawing, in which you can 
immediately start drawing. 

Layers can be selected and managed in the Timeline view. A scene can have as many layers as needed. When 
your scene has several layers, layers higher in the list appear over lower layers.

Renaming Layers
In a new scene, there is only one layer created by default, named Drawing. In traditional animation, it is 
common to name animation layers with single letters (A, B, C, etc.) and layout layers with acronyms (BG for 
background, OL for overlay, etc). So you can start off your scene by giving your first layer an appropriate name.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

A text-input field appears over the name.
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 2. Type in the new name for your layer and press Enter/Return.

The layer now has the new name.

Adding Layers

How to add a drawing element from the Timeline view

 1. Do one of the following:

 l In the Timeline view, click the  Add Drawing Layer  button.

 l In the top menu, select Insert > Drawing.

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (macOS).

The Add Drawing Layer dialog appears.

 2. In the Name field, type in the name for your new layer. 

 3. Do one of the following:

 l Click Add to create this layer, but leave the dialog open so you can create more layers.

 l Click Add and Close to create this layer and close the dialog. 

A new drawing layer is added to the Timeline view.
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Deleting Layers

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

NOTE 

You can select several contiguous layers by holding down the Shift key, clicking on the 
first layer you want to select, then on the last layer you want to select. You can also 
select several layers by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key and 
clicking on each layer you want to select. 

 2. Do one of the following:

 l In the Timeline’s Layer toolbar, click the Delete Layers button. 

 l Right-click on the selection and select Delete.

The selected layers are removed from the Timeline view.

Reordering Layers

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.
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 2. Click and drag the selection, then do one of the following:

 l Drop the selection between two layers to move it between those layers. A cyan line will 
appear between the layers where the selection will be moved.

 l Drop the selection onto a layer to rig the selected layers as children over that layer. 

Grouping Layers
Grouping layers allows you to keep your scene structure organized. 

Additionally, you can put several layers inside a group, then add an effect on this group to apply that effect on 
all the layers inside the group. 

How to group layers in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

NOTE 

Any layer between the selected layers will be grouped with the selected layers. 

 2. Do one of the following: 

 l Right-click on the highlighted layers and select Group Selection.

 l Press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS). 

A new Group layer is added to the Timeline view.
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If you click on the  Expand Group button, you will find the grouped layers rigged as children of 
the group layer. 

Hiding and Showing Layers
You can temporarily hide layers so that they do not clutter the Camera view while you are working on other 
layers.

How to hide a layer in the Timeline view

 1. In the Timeline view, left of the layer you want to hide, click on the  Disable Layer button.

The layer will become invisible in the Camera view. 

 2. When you want to unhide the layer, click on the  Enable Layer button to display it again.

Locking and Unlocking Layers
You can temporarily lock layers. Locked layers can still be edited in the Timeline or Xsheet view, but you cannot 
select them, draw them or manipulate them in the Camera view. This can be useful to avoid accidentally 
selecting or drawing over your backgrounds, overlays, props or characters you are not currently working on.
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How to lock a layer in the Timeline view

 1. In the Timeline view, left of the layer you want to lock, click on the Lock button.

The layer will become impossible to select or draw on in the Camera view. The name of the layer will 
appear in red in the Timeline view.

 2. When you want to unlock the layer, click on the  Unlock Layer button to display it again.

37

Harmony 20 Essentials Getting Started Guide                          



Chapter 4: How to Draw

Chapter 4: How to Draw
When you create a scene, your scene comes with a default Drawing layer in which you can immediately start 
drawing. 

NOTE 

Depending on your drawing style and what you are comfortable with, you may prefer to draw with 
the Brush tool or the Pencil tool. For more information on the difference between those tools, see 
When you create a scene, your scene comes with a default Drawing layer in which you can 
immediately start drawing.  on page 38.

How to draw with the Brush tool

 1. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

 2. If you want to try drawing with the Brush tool, do one of the following:

 l In the Tools toolbar, select the  Brush  tool.

 l In the top menu, select Tools > Brush.

 l Press Alt + B.

If you want to try drawing with the Pencil too, do one of the following:

 l In the Tools toolbar, select the  Pencil tool.

 l In the top menu, select Tools > Pencil.

 l Press Alt + /.

 3. In the Presets list of the Tool Properties view, select a brush or pencil preset to use. 

 4. Use the Maximum Size slider to select the desired size for your brush or pencil.
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 5. To select a colour, click on the colour you wish to use in the Colour view. For more information on how 
to create and edit colours, see How to create or edit colour swatches on page 48.

 6. In the Drawing or Camera  view, start drawing.

 7. If you are using the Brush tool and wish to makes changes to your brush, in the Tool Properties view, 
click on the arrow button to open the Brush Properties dialog. In this dialog, you can customize the 
size, shape and smoothing of your brush.
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TIPS 

 l You can quickly adjust the size of the selected drawing tool by pressing and holding the O 
key, then clicking and dragging in the drawing space. If you are using a tablet pen, doing 
this with the eraser tip of your pen will adjust the size of the Eraser tool, regardless of which 
drawing tool is selected. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 
the start of your drawing stroke will connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near existing 
artwork, the end of that drawing stroke will connect to that artwork.

Adjusting Artwork
Harmony offers multiple ways to adjust drawings. You can undo your last drawing stroke, erase parts of a 
drawing, move, transform or delete drawing strokes, and tweak the points and curves of your drawing strokes.

NOTE 

You cannot manipulate or tweak individual drawing strokes when drawing on a bitmap layer—see 
How to Add Layers on page 32. 

How to undo your last drawing stroke

 1. Do one of the following:

 l From the top menu, select Edit > Undo.

 l Press Ctrl + Z (Windows/Linux) or ⌘  + Z (macOS).
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How to erase

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Drawing or Camera view, draw an eraser stroke over the parts of your drawing you want to 
erase.

How to manipulate drawing strokes

 1. In the Tools toolbar, select the  Select tool or press Alt + S.

 2. In the Camera view, select the drawing strokes  you want to edit by doing one of the following:

 l Click on a drawing stroke to select it.

 l Hold Shift while clicking on a drawing stroke to add it to your selection.

 l Draw a lasso around drawing strokes to select them simultaneously.

 3. Do one of the following to edit your selection:

 l To reposition the selected artwork, click on it and drag where you want to position it.

NOTE 

You can also nudge your selection using the arrow keys, and fast-nudge your 
selection by holding Shift and pressing the arrow keys.

 l To rotate the selected artwork, click and grab just outside one of the handles at the corners of 
the control box and rotate it.
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 l To scale the selected artwork, click and drag on one of the control points at the corners or the 
middle of the edges of the control box. 

TIP 

While scaling artwork, you can preserve its proportions by pressing and holding 
the Shift key.

 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.
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 l To delete, press Del (Windows/Linux) or Backspace (macOS).

About Art Styles, Drawing Tools and Layer Types
The two main drawing tools in Harmony are the  Brush  tool and the  Pencil  tool. Depending on the 
drawing style you want to achieve, you may prefer to work with vector or bitmap layers.

On vector layers, it is possible to draw with pencil lines, textured pencil lines, vector brushes and  textured 
vector brushes. While pencil lines are vector centrelines to which you can add thickness, brush strokes are solid 
vector shapes filled with a colour, and textured brush strokes are  brush strokes filled with a bitmap texture that 
filter out their colour. 

On bitmap layers, you can only draw using solid or textured bitmap brushes. Hence, while vector layers are 
more flexible because they allow you to easily manipulate and tweak parts of your artwork, they can also 
accommodate more art styles.

However, if you use a textured brush on a vector layer, your brush strokes will have a bitmap texture. This 
means that, just like with artwork in bitmap layers, attempting to tweak or resize a textured brush stroke will 
require Harmony to resample the texture, which is liable to make it lose picture quality, unless its texture 
resolution was sufficiently increased before you started drawing.

One pitfall of using textured brushes on vector drawings is that, while bitmap drawings are always made of a 
single flat canvas, vector brush strokes are kept as separate objects. This means that laying on a lot of textured 
brush strokes on a vector drawing will require Harmony to store the texture for each of these strokes, and to 
composite them together in real time to display your drawing. This can cause texture-heavy vector drawings to 
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be heavier on application performance and in file size than bitmap drawings. This is however the only case 
where a vector drawing is likely to be heavier than a bitmap drawing. 

Though not recommended for sketching, textured pencil lines are a good compromise. Textured pencil lines are 
lighter and easier to edit. This means that the texture will update with the transformation if you scale or tweak 
your pencil line. This also means that you are able to change the texture applied to an existing pencil line or to 
apply a texture to a pencil line that does not already have one. Brush textures are recommended over textured 
pencil lines when trying to achieve natural-looking brushes.

NOTE 

Even if you flatten your artwork, textured brush strokes of different colours cannot be flattened 
together on vector layers. 

The following table compares the different approaches to drawing available in Harmony:

Drawing 
Tool

Layer 
Type

Specifics

Solid 
Pencil

Vector

Advantages: Very light and easy to tweak. Can be manipulated, recoloured and tweaked 
by the centreline. Can be zoomed in on or scaled up without losing quality. 

Disadvantages: Not optimized for transparency.

Recommended Use: Clean drawings with a solid and uniform outline style. 

Textured 
Pencil

Vector

Advantages: Light and easy to tweak. Can be manipulated, recoloured and tweaked by the 
centreline. Can be zoomed in on or scaled up without losing quality. 

Disadvantages: Not optimized for transparency. Not recommended for sketching. Does 
not look as natural as textured brushes.

Recommended Use: For light textured or mixed-style artwork that demands a lot of line 
manipulation. 

Solid 
Vector 
Brush

Vector

Advantages: Light file size. Reproduces traditional animation style. Can be manipulated, 
recoloured and edited by the contour or centreline. Can be zoomed in on or scaled up 
without losing quality.

Disadvantages: Cannot reproduce the look of natural media.

Recommended Use:  Sketches, clean traditional animation-style drawings.

Textured 
Vector 
Brush

Vector

Advantages: Can reproduce the look of natural media. As capable as textured bitmap 
brushes, but can be manipulated, edited and recoloured like solid vector brushes.

Disadvantages:  Overlapping brush strokes can make the drawing heavy on application 
performance and file sizes. Brush strokes of different colours cannot be flattened 
together. Tweaking, scaling up or zooming in on artwork is liable to make it lose texture 
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Drawing 
Tool

Layer 
Type

Specifics

quality.

Recommended Use:  For light bitmap-style textured artwork or mixed-style artwork.

Textured 
Bitmap 
Brush

Bitmap 

Advantages: Can reproduce the look of natural media. Better performance and lighter file 
size than texture-heavy vector artwork. Can be edited pixel by pixel.

Disadvantages: Brush strokes are always flattened together and cannot be modified 
individually. Can only be drawn or erased upon. Scaling up or zooming in on artwork is 
liable to make it lose picture quality.

Recommended Use: Texture-heavy bitmap artwork.
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Chapter 5: How to Paint
Toon Boom Harmony Essentials has some very powerful painting features to add colour to your drawings. 
Whereas some other software only allow users to work with one colour swatch at a time, painting in Harmony 
is done by using palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You 
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
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scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the 
mood and atmosphere of the scene without having to repaint each element.

Colour Palettes
In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a base colour palette should be created for each character, prop and effect in the production. This 
is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of 
red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production.

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

How to create a new palette 

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the palette list.
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How to create or edit colour swatches

 1. If you want to create a new colour swatch, click the Add Colour  button in the Colour view. If you 
want to edit an existing colour swatch, select the colour in the Colour view.

 2. Do one of the following to edit the colour swatch:

 l From the Colour view menu, select Colours  > Edit.

 l Double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's 
spectrum, then click on the desired colour in the colour wheel.

 l Enter the hue, saturation, value, red, green and blue values manually into their 
corresponding fields. All values range from 0 to 255. 

NOTE 

If you change a colour swatch after having drawn or painted areas of a drawing with it, all the 
areas that were painted with this colour in your drawings will update to the new colour. 

Painting
You can paint the closed zones of your drawings by using the Paint tool.
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How to paint drawings

 1. In the Timeline or Xsheet view, select the drawing you want to paint.

 2. In the Tools toolbar, select the  Paint  tool or press Alt + I.

 3. In the Colour view, select your character's palette.

 4. Select a colour from the palette.

 5. In the  Drawing or Camera view, start painting the colours on your drawing.

NOTE 

When opening a scene, the scene's palettes will not be immediately loaded into the Colour 
view. You must select a drawing first.

Closing Gaps
When painting, you may find that some areas of your drawings were not completely closed due to small gaps in 
their outlines, which prevents the Paint tool from filling the area as it only fills closed shapes. To close the zone, 
you can draw a line over the gap with the Brush or Pencil tool. However, it is also possible to close the gap by 
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adding an invisible line over it, which the Paint tool will treat like an ordinary line. In Harmony, invisible lines 
used to define areas to colour are called strokes.

The Close Gap tool lets you close small gaps in a drawing's outline by instantly drawing a stroke to fill the gap. 
Contrary to the Stroke tool, you do not need to draw with precision when using the Close Gap tool. Simply 
drawing a crude stroke near the gap will automatically create a straight stroke that connects directly from one 
end of the gap to the other.

How to use the Close Gap tool

 1. Before working with strokes, it's recommended to enable the Show Strokes option so that you can 
see them in the Drawing or Camera view. You can enable the Show Strokes option by doing one of 
the following:

 l From the top menu, select  View > Show > Show Strokes

 l Press K.

 2. Do one of the following:

 l In the Tools toolbar, select the  Close Gap tool. 

 l From the top menu, select Drawing > Drawing Tools > Close Gap.

 l Press Alt + C.

 3. In the Camera or Drawing view, trace an invisible line near to the gap to be closed. 

The gap automatically closes.
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NOTE 

The Paint tool also has a Close Gap option which can be enabled from the Tool Properties 
view. When enabled, Harmony will attempt to automatically find and close small gaps when 
you attempt to fill a shape that is not closed. 
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Chapter 6: How to Create Paperless Traditional Animation

Creating a Rough Animation
The first step to create paperless animation is the rough construction, which is the skeleton of your animation. 
You would usually start by animating the most important part of a character's action. For example, to animate a 
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and 
clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the 
details when you're satisfied with the movement. If you start animating all the details right away, you will lose a 
lot of time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. In the top row of the Timeline view, click on  Show All Thumbnails  to enable Thumbnail mode. 

 2. In the Tools toolbar, select the  Brush  tool or press Alt + B.

 3. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your 
rough animation. This will make the clean up process easier as your clean dark lines will contrast 
with your light sketch lines. 
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 4. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 5. In the Camera or Drawing view, draw the first key drawing.

As soon as you draw your first drawing stroke, a drawing is automatically created in the cell you 
selected.

 6. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of 
the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 7. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.
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 8. In the Tools toolbar, click the  Onion Skin  button. This will display the previous and next 
drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you 
can use them as references to draw new drawings with accuracy. This can be useful to draw 
breakdown poses between two key poses, or to add an in-between drawing between two other 
drawings.

 9. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing 
on it. To do this, do one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the 
green onion skin marker to make it include the next drawings you want to display in 
the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous 
and next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  
Remove Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.
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 l To decrease the amount of next drawings to display, click on the  Remove 
Next Drawing button in the Camera/Drawing view toolbar.

 10. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the  Create Empty Drawing  button.

 l Press Alt + Shift + R.

 11. In the Camera or Drawing view, draw your second key drawing.

 12. In the Timeline or Xsheet view, select a cell between the two key drawings. 

 13. Using the onion skin markers, ensure the onion skin covers both your first and last drawings.
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 14. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the  Create Empty Drawing  button.

 l Press Alt + Shift + R.

 15. In the Camera or Drawing view, draw your new pose.

 16. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new 
drawing.

NOTE 

When working with overlay layers in the Camera view, you can enable the  Current 
Drawing on Top  option in the status bar below the Camera view to make the layer you're 
working on appear over other layers. 

Reviewing your Animation
Flipping through drawings can help see if the drawings you're working on connect well together and create 
the proper illusion of movement. You can quickly flip through your drawings using the Go to Previous Drawing 
and Go to Next Drawing keyboard shortcuts.

How to flip through drawings

 1. In the Timeline or Xsheet view, select the drawing from which you wish to flip.

 2. Do one of the following:

 l Press F to go to the previous drawing.
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 l Press G to go to the next drawing.

 3. Press either shortcut repeatedly at a fast pace to flip through drawings backward or forward.

When your rough animation is finished, play it back to make sure it looks as expected before proceeding to the 
next step.

How to play your animation

 1. In the Timeline view, click on the  Solo Mode button left of each layer you want to see during 
playback in the Timeline view to enable  Solo mode on these layers. 

When one or more layer has Solo Mode enabled, only layers with Solo Mode enabled are visible, and 
other layers are hidden.                         

 2. In the Timeline view, move the red playhead to the first frame of your animation and click the Start 
button on the Timeline toolbar. Then, move the playhead to the last frame of your animation and 
click the Stop button.

 3. In the Playback toolbar, click the  Loop button to enable looping during playback.

 4. In the Playback toolbar, click the  Play button to begin playback.

Cleaning Up
When your rough animation is completed, it is time to clean it up and ink it. This step is also called tracing. It 
consists of tracing solid and clean lines over the rough animation to close any open zones. This is the final 
paperless animation step before the ink and paint step. 
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In traditional animation, cleaned up drawings are usually traced on a new sheet of paper with the rough 
underneath, made visible using the animation disk's light table. Likewise, in Harmony, you will need to add a 
new drawing layer on which to draw cleaned up drawings.  When you're done cleaning up, you can simply 
disable the layer containing the rough animation so that it does not appear in the final animation. This 
approach also allows you to keep the roughs and the cleaned up drawings intact and to manage them 
independently. 

In the Camera view, you will see your rough animation while working on your clean up layer. If you prefer to 
work in the Drawing view, you can enable the light table to display  the rough animation while tracing on your 
clean up layer.

How to trace your animation in a new layer

 1. In the Timeline view, rename the layer on which you created your rough animation by double-
clicking on its name and entering its new name, for example: "Rough".

 2. In the Timeline view, add a layer by doing one of the following:

 l In the Timeline view's layers toolbar, click on the  Add Drawing Layer  button 

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (macOS).

The Add Drawing Layer dialog appears.

 2. In the Name field, type in your new layer's name, for example: "Clean-up".

 3. Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

 4. In the Timeline view, click the Lock  icon of the layer containing your rough animation to prevent 
the layer from being selected in the Camera view.
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 5. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of 
your rough animation.

 6. In the Tools toolbar, select a drawing tool such as the Pencil  tool.

 7. In the Colour view, select a colour for tracing your animation. Pick a dark bold colour, such as black, to 
make sure it contrasts well with the light colour of your rough animation.

 8. In the Camera or Drawing view, start tracing the first key drawing.

NOTE 

If overlay layers are in the way, you can disable them temporarily by clicking on 
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their  Enable/Disable button  in the Timeline view, so that only your rough 
animation and your clean up layers are displayed.

 9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 10. In the Tools toolbar, click the  Enable Onion Skin  button to enable Onion Skin.

 11. Ensure onion skin displays your previous cleaned up drawing, by doing one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the 
green onion skin marker to make it include the next drawings you want to display in 
the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous 
and next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  
Remove Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove 
Next Drawing button in the Camera/Drawing view toolbar.

 12. In the Camera view, trace your next drawing.
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 13. Repeat the previous steps for each drawing.
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Chapter 7: How to Import Images
By default, Harmony works with vector images created within its own interface. Vector images are primarily 
composed of information about the different shapes composing the images, as well as their line and fill colours. 
This makes them easy to edit and paint, and allows us to resize them without affecting the image quality. In 
contrast, bitmap images are composed of colour information about each individual pixel composing the image. 
Hence, they are more fit for very detailed or realistic pictures, but they cannot be scaled without losing image 
quality. 

Typically, you would need to work with bitmap images if you must create some of your scene assets, such as 
backgrounds or props, in a different software. You can then import those bitmap image files into your Harmony 
scene.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Import as Bitmap: This imports the image exactly as is and ensures that it cannot be modified when 
working on the scene. This is useful for using backgrounds that were created in different software in 
your project.

 l Vectorize: Converts a bitmap  into Toon Boom vector art, which can easily be painted and edited using 
Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a 
different software.

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.
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 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 4. In the Vectorization section, make sure the Vectorize Image option is unchecked.

 5. Click OK.

NOTE 

By default, bitmap images will display in low resolution in the Camera view so as to avoid 
affecting playback performance. You can also adjust the display quality of a bitmap image by 
selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View > 
Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by 
activating the Render Preview  mode in the Camera view. 
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Vectorizing Images
Harmony allows you to import images as vector drawings. Vector drawings can easily be painted and edited 
using Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a 
different software, as you can then paint it in Harmony.

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
your computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.
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 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 3. In the Vectorization section, select the Vectorize Image  option. 

 4. Select one of the following options: 

 l Colour: Imports bitmaps as vector objects with their image as a bitmap texture. The resulting 
drawing can be drawn or erased over, but not repainted or tweaked. 

 l Black and White: Vectorizes drawings with a solid black line. This creates a 100% vector-
based drawing and paints it with the Vectorized Line colour swatch from your scene's 
palette.

 5. If you selected the Black and White option, set the following parameters:

Parameter Description

Threshold

Determines what values in the scanned image will be 
considered as part of the drawing, and what will be ignored 
and eliminated in the vectorized drawing. The lower the value, 
the darker the image and vice versa.

Smooth
Determines how smooth the lines will be. The lower the 
value, the more detail will be retained. The higher the value, 
the more polished and easy to edit the lines will be.

 6. Click OK.

Your vectorized images will appear in their selected destination.

NOTE 

If you have bitmap images in your Library, you can drag and drop them directly into your scene as a 
quick way of importing a bitmap image. However, you will not have access to all the import options. 
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Chapter 8: How to Position and Animate Layers
Setting up your scene can be compared to building a set for a television show. This is the point when you 
position each scene element such as the camera frame, the background elements and the characters.

Positioning Layers
The first step to setting up your scene is to place each layer in their initial position, angle and size. You can make 
any kind of geometric transformations on a layer using the Transform  tool.

How to pan, rotate, scale or skew a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 2. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 3. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 4. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click on 
each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.
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 1. Do one of the following:

 l To move: Move the cursor over the artwork. When the cursor changes into , click and 
drag on the artwork to move it.

 l To rotate: Place  the pointer outside of a corner of the bounding box. When the cursor 
changes into, , then click and drag to rotate.

 l To scale: Move the cursor over any of the yellow control points on the manipulator box. 
When the cursor changes into , click and drag to scale the layer. 

NOTE 

When scaling your selection, you can hold down Shift to preserve the 
proportions between its width and height.
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 l Move the cursor over one of the vertical edges of the manipulator box. When the cursor 
changes into , click and drag up or down to skew the layer vertically. 

 l Move the cursor over one of the horizontal edges of the manipulator box. When the cursor 
changes into , click and drag left or right to skew the layer horizontally. 

Repositioning the Pivot
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the 
position of the drawing's pivot point. For example, rotating a layer will make it rotate around its pivot point, and 
scaling the layer will make it scale as if its centre was actually its pivot point.

While making transformations using the Transform tool, you can drag and drop your selection's pivot. 
However, this has no permanent effect. It will only temporarily change the pivot's position to help you make 
transformations at the selected frame, but the actual pivot point of your drawing layer will remain the same. 

You can reposition a layer's pivot point permanently by using one of the tools in the Advanced Animation 
toolbar.

NOTE 

When you permanently move the pivot point of a layer that is already animated, all the 
transformations done on the layer on other keyframes will be recalculated according to the new 
pivot point's position. Therefore, your existing animation will look completely different, except at 
the current frame. It is recommended to always make sure your pivot point is at its ideal position 
before you start animating.
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How to permanently reposition the pivot point of a layer

 1. In the Advanced Animation toolbar, select the  Translate ,  Rotate ,  Scale , or  Skew tool.

 2. Do one of the following:

 l In the Timeline view, select the layer for which you want to move the pivot. 

 l In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the layer for which 
you want to move the pivot.

The  pivot point appears in the Camera view.

 3. Move the cursor over the pivot point. When the mouse cursor becomes , click and drag on the 
pivot point to reposition it.

The layer's pivot point is now repositioned. If the layer has been animated, its position will be offset 
across the scenes relative to how much you just offset the pivot point.

Animating a Layer
You can animate a layer by placing it in different positions, angles and sizes at different points across your 
scene's timeline. To do this, you can create animation keyframes on your layer. A keyframe records the 
geometrical transformations on a layer at a specific point in time. When two animation keyframes are on a layer 
at different points in your scene's Timeline, Harmony will automatically interpolate the position, angle and size 
of the layer on each frame between those two keyframes, creating an animation.
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How to animate a layer                 

 1. In the Tools toolbar, select the  Transform tool or press Shift + T.

 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. If your layer has a parent peg:

 l If you want to animate on the peg instead of the layer, make sure that  Peg Selection 
Mode is enabled in the Tool Properties view.

 l If you want to animate directly on the layer, make sure that  Peg Selection Mode is 
disabled in the Tool Properties view. 

 4. In the Timeline view, go to the first frame.

 5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is 
unchecked. This will make it so Harmony automatically creates the animation between the 
animation keyframes you create.

 6. Select the cell where you want to create your first keyframe

 7. To create your first keyframe, do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is created on the first frame of the Timeline view.
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 8. In the Camera view, select the element to animate and move, rotate, scale or skew it so that it is in 
its proper starting position.

 9. In the Timeline view, go to the frame on which you want to set the second position.

 10. Select the cell where you want to create your second keyframe. right-click on the selection and 
select Insert Keyframe.

The second keyframe appears in the Timeline view, along with a line going from your first keyframe 
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

 11. In the Camera view, move, rotate, scale or skew the element to that it is in its proper second 
position.

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.
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 13. In the Playback toolbar, click on the  Play  button to preview your animation.

NOTE 

If  you animate layers on the Z axis, you may want to preview your animations from the Top or 
Side views  during playback. However, playback is disabled by default in those view. To enable 
them, from the top menu, select Play > Enable Playback > Top View or Side View.
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Chapter 9: How to Position and Animate the Camera
In Harmony, you can animate objects by drawing them on their individual layer, then positioning them at 
different locations on different keyframes across the timeline, creating a motion path. The same principle can be 
applied to the scene's camera, since it is a layer itself. 

Adding a Camera
By default, a scene does not have a camera layer. In order to be able to tweak the scene's camera angle and 
position, you must add one to your scene. 

How to add a camera                 

 1. Do one of the following:

 l In the Timeline view, click the  Add Layer  button and, in the pop-up menu, select 
Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

Although it is possible to have several cameras in the same scene, you can only view your scene using one 
camera at a time. This can be useful if you are still working on your scene composition and have different camera 
set-ups to try out.

How to switch between cameras

 1. From the top menu, select Scene > Camera.

 2. Among the listed cameras, select the one you want to work with.

Adding a Parent Peg
Although it is possible to position a camera without rigging it under a peg, it is recommended to always rig it 
under a peg for two reasons:

 l It allows you to position, rotate and zoom the camera using the Transform tool. 

 l It allows you to animate camera movements. Without a parent peg, a camera's position, angle and zoom 
are static. 
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How to add a parent peg to a camera                

 1. In the Timeline view, select the Camera layer

.

 2. In the Layers toolbar, click the  Add Peg  button.

A Peg layer appears directly above the Camera layer and is automatically attached to it.

Positioning the Camera
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution as well as other related parameters in the Scene Settings window, accessible from the Scene 
top menu.

To reposition camera directly, you can move it using the  Transform or  Translate tool, you can rotate it 
using the  Rotate tool and you can zoom it using the l  Scale tool, from the Advanced Animation toolbar. 
Alternatively, you can type in its coordinates directly in the Layer Properties view. If you rigged the camera 
under a peg, you can do all sorts of manipulations to it using the Transform tool alone. The following steps 
indicate how to manipulate the camera when it is rigged under a peg. 

How to position a camera rigged under a peg in the Camera view

 1. Do one of the following to select the Camera's parent peg.

 l In the Timeline view, click on the Camera's parent peg layer.

 l In the Camera view, click on the camera frame. The camera frame is a thin rectangle around 
your scene's stage. 

A control box appears around the camera frame.
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 2. Do one of the following:

 l To move the camera frame: Position the cursor over any of its edges or over the centre. 
When the cursor becomes , click and drag on the camera frame to reposition it.

 l To zoom in or zoom out: Position the cursor over one of the corners of the camera frame. 
When the cursor becomes , click and drag on the corner to resize the camera frame. 
Shrinking the camera frame will zoom in on your scene, and expanding it will zoom out. 
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 l To rotate the camera: Position the cursor just outside one of its corners. When the cursor 
becomes , click and drag to rotate the camera frame.

Animating the Camera
A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and 
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, 
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate 
the camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the 
position and angle of the camera. 

You can animate your camera movements directly in the Camera view. 

How to animate the camera

 1. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
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to open the Animate pop-up menu and select  Animate Current Frame.

 2. In the Tools toolbar, select the  Transform tool or press Shift + T.

 3. On the right side of the Timeline view, on the Camera peg layer, select  the frame at which you want 
the camera movement to start.

 4. Do one of the following to add a keyframe:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 5. In the Camera view, manipulate the camera so that it is in the right position at the beginning of your 
camera movement.

 6. On the Timeline view, click on the cell where the camera movement will end.

 7. Do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 
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 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.

 8. In the Camera view, manipulate the camera so that it is in the right position for the end of your 
camera movement. 

 9. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 10. In the Playback toolbar, click on the  Play  button to preview your animation.
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Chapter 10: How to Rig a Cut-out Character
In Harmony, a character rig is basically a template based on your character's model, but in which all movable 
parts are broken down into different layers, and arranged in a hierarchy that facilitates digital animation, also 
known as cut-out animation.

To make a character rig, we must first make sure you have a character model to build on. If you have any 
drawing of a character available, import it into a new scene, then scale and position it to your liking. Otherwise, 
you can draw your character's model directly in Harmony. Once you have a model ready, we can start breaking 
it down into parts to build your rig with.

There are many techniques you can use to break down a puppet. In this section, you will learn about one of the 
most common and simplest methods. For your first character breakdown, follow these instructions to get an 
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be 
able to create your own techniques to satisfy the needs of your production.

Drawing the Pieces
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R 
(Windows/Linux) or ⌘  + R (macOS) to add new drawing layers.
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 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select the drawing tool of your choice. There are two commonly used methods 
to drawing the parts of a cut-out character model:

 l Using the  Pencil tool, then smoothing your lines with the  Smooth Editor tool

 l Using the  Polylinetool. This method allows you to draw with great precision, but 
may take more time.

These methods ensure each part is made with as few points as possible, so that they are easy to 
manipulate, modify or redraw.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see 
How to Paint on page 46.

 5. If you prefer working in the Drawing view, do one of the following to display the other layers in 
washed out colours:

 l In the Drawing view toolbar, lick the  Light Table  button.

 l Press Shift + L.

 6. In the Camera or Drawing view, draw the new part.
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 7. If you want to close an open shape without drawing a visible outline, you can draw an invisible line 
using the  Stroke  tool.

NOTE 

By default, strokes created with the Stroke tool are not visible. To see strokes in your 
drawing, select View > Show > Show Strokes from the top menu or press K.

 8. In the Tools toolbar, select the  Paint or Paint  Unpainted  tool to colour your drawing.

 9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 10. In the Camera or Drawing view, paint your drawing.

 11. In the Tools toolbar, select the  Select tool. Select your drawing and flatten the lines by clicking 
the  Flatten  button in the Tool Properties view.

 12. Repeat the entire process for every body part that you wish to make animatable. 
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the drawings directly.

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This 
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the 
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to 
create a hierarchy of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 
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NOTE 

It is also possible to make a drawing layer the parent of another drawing layer. Just like the way 
animating a peg animates its children layers, animating a drawing layer with children will also 
animate its children layers. Both layers will still appear in the animation.

How to create parent pegs for your layers in the Timeline view

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Peg button to add a parent peg to all selected layers.

Creating a Layer Hierarchy
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should 
influence other limbs, and how they can move independently. For example, when rigging a simple character's 
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. 
This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and 
hand will follow. 
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When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can 
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig 
the legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want to make a child layer.

 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you 
are not dropping the child layer between two layers. 

 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
your rig can serve as that parent, create a new peg and nest those layers under that peg.
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NOTE 

In the Timeline view, you can unparent layers by holding down Shift, dragging the selected 
parent away from the child layer and dropping it somewhere else in the list.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they are 
rendered. Layers on top of the list will be rendered over layers at the bottom of the list.  Should you need to 
change a layer's order while animating, you can nudge this layer's position on the Z-axis to override the layer 
order and force it to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.

 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the 
focus on the Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.

Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows 
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is 
useful for positioning and scaling your character relative to the scene, as well as to animate your character's 
trajectory when it has to move between areas of the scene.
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How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the  Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that your 
top layer is already a child of the peg, so don't include it in your selection.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers 
are added above the already parented layers, move that parented layer back on top of the layer 
stack.
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Chapter 11: How to Animate a Cut-out Character

Harmony provides very useful tools for animating cut-out character models. Using the Transform tool, you can 
move your character's parts to make your key poses, and let Harmony create the in-betweens. The timing of 
the movement can be adjusted to make life-like motion, and the drawings for the character's parts can be 
swapped at any point in your animation, allowing you to combine movement and drawing changes to create 
frame-perfect cut-out animations.

How to create a simple cut-out animation

We will create a simple cut-out animation by making your character's first pose on the first frame, its 
second pose on a later frame, and letting Harmony interpolate them. 

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 
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 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 8. In the Camera view, select the parts to animate. The Transform tool's control box will appear around 
the selected layer. Each part of the Transform tool control can be used to make different kinds of 
transformations:

 9. Use the Transform  tool to rotate, skew, scale or translate the selection to its new position.
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 10. Repeat for other parts of your character model until your first pose is complete. 

 11. In the Tools toolbar, enable the  Onion Skin   feature.

 12. In the Timeline view, select the frame where you want to have your second pose.

 13. Create keyframe for your second pose by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

Your second keyframe appears, along with a line going from your first keyframe to your second 
keyframe. This indicates that every frame in-between will be interpolated by Harmony.

If no line appears, it means your first keyframe was created as a stop-motion keyframe. To fix this, do 
one of the following.

 l Right-click on the first keyframe and select Set Motion Keyframe.

 l Select the first keyframe and press Ctrl + K (Windows/Linux) or ⌘  + K (macOS)

To make sure your new keyframes are set to Motion by default, select Animation from the top menu 
and make sure the Stop-Motion Keyframe option is unchecked. 

NOTE 

Each keyframe can be a Motion keyframe or a Stop-Motion keyframe. The frames 
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between two keyframes are interpolated by Harmony if the first of the two keyframes is 
a Motion keyframe. 

 14. In the Camera view, change your character's pose again.

 15. Repeat this process for all the poses you wish to add to your animation.

             How to adjust the ease of the animation         

 1. In the Timeline view, collapse the hierarchy of the rig (or of the part of the rig) to which you want to 
apply an ease. 

NOTE 

When you apply an ease to a layer with children, and this layer’s hierarchy is collapsed, 
the ease is applied to that layer and all of its children. 
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 2. Select one of your animation keyframes.

NOTE 

You should only select one keyframe. The Set Ease for Multiple Parameters dialog can 
only edit the ease on one keyframe at a time, but it also allows you to quickly jump 
between keyframes in your timeline.

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 4. In the Bezier editor, click and drag on the Bezier handle to adjust the ease for the selected 
keyframes.
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 5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields below the 
Bezier editor. The values are calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last. This will move the Beziers horizontally, 
away from their keyframe. The value must be between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
skewed you want the ease to be. This will move the Bezier vertically, towards their nearest 
keyframe if the value is positive, or away the nearest keyframe if their value is negative. The 
value must be between 0% and 100%.

 6. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the 
Filters section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. 
Note that Morphing is only available in Harmony Advanced and Harmony Premium.

 l Other: Applies the easing parameters to all the other selected functions, such as all 
functions created to animate effect parameters.

 7. Click one of the following buttons:

 l Apply/Previous: Applies the ease parameters to the selected keyframe and then 
jumps to the previous keyframe in the timeline so that you can adjust its ease next.

 l Apply: Applies the easing parameters to the selected keyframe.
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 l Apply/Next: Applies the ease parameters to the selected keyframe, then jumps the 
next keyframe in the timeline so that you can adjust its ease next.

 l Close: Closes the dialog box. If you did not apply the modifications, they will be 
cancelled

Navigating Layers
Since cut-out animation often involves complex models with extensive hierarchies, learning shortcuts to easily 
navigate between layers can save a lot of time. 

One very useful trick to learn is the Centre on Selection command, along with its keyboard shortcut. This 
command allows you to navigate directly to the selected layer in the Timeline view. Hence, you can use the 
Camera view to visually select the layer you wish to work on, then use the Centre on Selection shortcut to find 
the layer in the Timeline view, instead of going through the scene structure to locate it.

How to centre on the current selection in the Timeline view

 1. In the Timeline view, collapse all your layers. 

 2. In the Tools toolbar, select the  Transform  tool.

 3. In the Camera view, select any layer.

 4. Do one of the following:

 l Click on the Timeline view's tab to set the focus on it, then press O.

 l In the Timeline view toolbar, click the  Centre on Selection button.

The Timeline view is now centred on the selected layer, and all its parents have been automatically 
expanded. 

If you want to use the keyboard shortcut frequently, you might find that having to click on the Timeline view 
tab every time is tedious. To remedy this, you can enable the Focus On Mouse Enter preference. This will set the 
focus on a view as soon as your mouse cursor enters it, instantly making all of this view's keyboard shortcuts 
functional.

How to enable the Focus On Mouse Enter preference

 1. From the top menu, go to Edit > Preferences (Windows) or Harmony > Preferences (macOS).

 2. Open the General tab.

 3. In the Options section, check the Focus On Mouse Enter check box.

 4. Click on OK.
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Keyboard shortcuts for specific views will now work as soon as your mouse cursor enters the 
intended view. 

Harmony also has commands and keyboard shortcuts to quickly change your selection from the currently 
selected layer to its parent or child, allowing you to quickly navigate your character's hierarchy.

How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. Do one of the following:

 l Select Animation > Select Parent or press B to select the parent layer.

 l Select Animation > Select Child or press Shift + B to select the child layer. 
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NOTE 

When going up or down your node hierarchy, these keyboard shortcuts skip any effect node in 
the hierarchy and only select either peg or drawing nodes. This is because these shortcuts are 
optimized for cut-out animation. In the Keyboard Shortcuts dialog, under the General section, 
these shortcuts are named Select Parent Skipping Effects and Select Child Skipping Effects. 
If you want to use keyboard shortcuts to navigate the hierarchy without skipping effect nodes, 
you can assign custom keyboard shortcuts  for the Select Parent  and Select Child  commands 
instead. 
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Chapter 12: How to Use Deformers
Deformers give the ability to animate objects and parts of a character model using computer generated 
deformations. Deformations work by creating control points on a drawing and, when you move those points, 
the drawing is bent or distorted so that the parts of a drawing that are bound to a control point follow that 
control point wherever you position it.

Deformers can substantially increase the range of movements and animations a cut-out character rig is able to 
perform without having to draw new poses for it or resorting to frame-by-frame animation. A cut-out character 
rigged with deformations can be animated in a way that likens the fluidity and flexibility of traditional 
animation. Additionally, deformers can be used to tweak, enhance or facilitate frame by frame animation when 
needed.

Deformers work by rigging them on the body part you wish to deform, building the deformation structure, then 
animating it. This can be done easily using the  Rigging  tool.

There are two types of deformers available in Harmony Essentials:

 l Bone

 l Game Bone

Bone Deformer
The Bone deformation allows you to create a bone-like structure in which each part is solid, but with 
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or 
other parts that can be articulated such as torsos or fingers. 

For example, a Bone deformation can be used to articulate an arm that is made of a single drawing, so that the 
upper arm and forearm can be moved independently, without having to draw the upper arm and the forearm 
on different layers. Harmony will deform the drawing to make it look articulated. The different parts of a Bone 
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as 
animating articulations on different layers, without having to worry about parts detaching, pivot points, or 
clipping outlines.
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Game Bone Deformer
The Game Bone deformation is very similar to the Bone deformation. It allows you to create structured 
comprised of points, which represent the articulations, and straight line segments linking those points 
together, representing the bones. The Game Bone deformation is different in that it is optimized to be 
exported to game engines such as Unity. Hence, it is usually only used to animated characters destined to be 
imported to Unity games, rather than for animation productions. 

Contrary to the Bone deformations, Game Bone deformations do not have a Bias property. The articulation 
folds also look slightly more rounded.

Creating Deformers
The most simple way of creating deformers is to use the  Rigging  tool, available in the Deformation toolbar. 
With this tool, all you need to do to create a deformer is to select the layer you wish to deform, then place each 
point of your deformer in the Camera view.
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Deformers exist in your scene as a hierarchy of deformation layers. When you create a new deformer, the first 
point you set is the deformer's root, and each new point you create is a child of the previous point. Deformers 
are hence created in a chain, and should be created with your character's hierarchy in mind. For example, when 
you create a deformer for an arm, the root should be the shoulder joint, the second point should be the elbow 
and the third should be the wrist.

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging tool, it 
is automatically created as a parent of the selected layer, and will affect the selected layer and all its children. 
Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you could rig 
the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and the hand is the 
forearm's child. Then, if you create your deformer on the upper arm, it will be created as a parent of the upper 
arm, and will hence affect the whole arm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you 
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's 
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers that are 
under a deformer, they will exit the intended deformation zone, and may appear severely warped and 
distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under deformers 
should only be animated if the deformer is left untouched. Since the deformer will be created as a parent of all 
the peg's children, it will affect all the layers under the peg. 

How to create a Bone                  deformer

 1. Once your element is selected, select the  Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the  Bone  mode.

 3. Click where you want to create the root articulation of the bone structure. The root articulation 
should be the one that is bound to the remainder of the body. For example, for an arm, the root 
articulation would be its shoulder.
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 4. Click where you want the second articulation to be created. 

A bone will be created between the first and second articulation.

 5. Click where you want the next articulation to be created.

Observe that, as you create a new point, the previous point now has a circle around it. This is the 
radius of the articulation, which allows you to determine how much of the drawing should be part of 
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius. 

 6. Click and hold the previous articulation's radius control point and adjust the articulation's radius so 
that it properly covers the articulation.

 7. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in 
the right order going from the root to the extremity.

Displaying Deformers
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
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controls won't display automatically. Likewise, deselecting a deformation chain will not hide its deformation 
controls. 

Before you can animate or modify an existing deformation chain, you must manually display it.

How to display deformation controls

 1. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to display.

 l In the Timeline view, select any part of the deformation chain you want to display.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

NOTE 

The Show the Selected Deformation Chain and Hide All Others button will display all 
deformation chains that are in the hierarchy of the selection. For example, if the master peg of 
a character model is selected, all of its deformation chains will be displayed. Likewise, if multiple 
layers linked with different deformation chains are selected, all of their deformation chains will 
be displayed.

How to hide deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard 
the current selection, then click on  the  Show Selected Deformation Chain and Hide 
All Others  button in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the  Show the Selected 
Deformation Chain and Hide All Others  button in the deformation toolbar.

 l In the Camera toolbar, click the  Hide All Controls  button. 
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 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.

Animating With Deformers
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on 
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a 
deformer, except it requires using the  Transform  tool instead of the Rigging tool. When the Transform tool 
is selected, deformation controls in the Camera view display in green, which means they are in animation mode, 
whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.

How to animate Bone and Game Bone deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.
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 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 8. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to animate.

 l In the Timeline view, select any part of the deformation chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l To rotate the whole limb, click and drag on the first bone. This will rotate the first bone 
and all subsequent bones.

 l To bend the limb, click and drag on another bone. This will rotate the bone and all 
subsequent bones, but will leave the bones before it in their current position.
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 l To reposition an articulation, click and drag on its control point. This can be used to 
rotate, shorten or extend the bone, and will offset all subsequent bones.

 l To shorten or extend a bone without rotating it, press and hold the Alt key, then click 
and drag on its control point.

 l To offset the whole limb, click and drag on its root point.
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TIP 

You can also nudge an articulation in any direction by selecting it, then 
pressing on the arrow keys.

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 13. Transform your deformer's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 
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Importing Sound
If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound 
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and 
quality should you use third party software for post-production. Another good practice is to keep your 
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation 
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly in 
Harmony when needed.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files.

NOTE 

Importing a soundtrack longer than your scene will not extend your scene's length. Sound playback 
will stop at the end of your scene's length.

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help 
you visualize at which frames the sound effects in your soundtrack occur. 
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Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by 
default. If you wish, you can display a sound column's waveform by right-clicking on it, then 
selecting Sound Display > Waveform.

Automatic Lip-Sync Detection
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE 

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:
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 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, 
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and 
these drawings should be named by their corresponding letter. 

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.
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 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

NOTE 

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the  Enable Sound  option.

 8. Press the  Play  button in the Playback toolbar to see and hear the results in the Camera view

If you need to make adjustments to the automatically-generated lip-sync, see Animating Lip-Sync 
Manually on page 114.
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Animating Lip-Sync Manually
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's d ialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, 
allowing you to identify which phonemes you should match your character's mouth to. You will also be using 
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.
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How to swap drawings using the Drawing Substitutions view

 1. Add the Drawing Substitutions view to your workspace by doing one of the following:

 l In the top-right corner of any existing view, click on the  Add View button and select 
Drawing Substitutions.

 l In the top menu, select Windows > Drawing Substitutions.

 2. In the Playback toolbar, toggle the  Sound Scrubbing  button on.

 3. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 4. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 5. In the Drawing Substitutions view, click on the mouth pose you want to expose at the current frame.
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TIP 

You can also press [ to substitute the selected drawing with the previous drawing and ] to 
substitute it with the next drawing. 
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When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs, 
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the 
way layers or groups of layers are rendered in your scene. 

About Effects
Effects are special types of layers that you can add to your scene's structure. For an effect layer to work, it must 
be connected as the child of a drawing, a group, or another effect. Effects only alter the element that they are 
connected to. This gives you flexibility in deciding which elements of your scene are affected by an effect.

Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area 
they should affect. The most basic example of this is the Cutter effect. Alone, a cutter effect has no impact on 
the drawing it is connected to. Once combined with a matte layer, the Cutter effect cuts the shape of the matte 
out of the drawing.

A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the 
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details 
in the matte layer are ignored by the effect, only its shape is taken in account.

In the Timeline view, an effect must be rigged as the child of the drawing layer or group it is meant to affect. 
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If the effect can use a matte layer, it will have a Matte parameter when you expand its parameters list. You can 
drag and drop the layer you want to use a matte for your effect onto the Matte parameter of your effect to link 
them.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be connected. 

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using 
the Layer Properties view. You can also double-click on the layer to open its Layer Properties dialog.  If desired, 
you can even animate the parameters of your effect by converting their values to functions. 

Adding an Effect
In Harmony, you can add effects by selecting the layer or group you wish to add an effect to, then adding the 
effect through the Timeline view's Add Layers menu. Then, you can achieve the intended effect by adjusting its 
parameters in the Layers Properties view, and connecting it to a matte layer if applicable.

How to add an effect

 1. In the Timeline view, select the layer on which you want to add an effect.

 2. Do one of the following:

 l In the top menu, select Insert > Effects and select the effect you want to add. 

 l In the Layers toolbar above the layer list, click the  Add Layers  button, select 
Effects then select the effect you want to add. 

 l Right-click on the layer, then select Insert > Effects and select the effect you want to 
add. 

The effect appears in the Timeline view, underneath the selected layer. 

 3. In the Camera view, click the  Render View  button to see  the scene's rendered current frame and 
effect. 
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NOTE 

By default, your background will appear pitch black. To remedy this, you can add 
a Colour Card layer at the bottom of your layers list, and tweak its colour in the 
Layer Properties view. 

 4. In the Timeline view, double-click on the effect layer to open the Layer Properties window. You can 
also select the effect layer and see its properties in the Layer Properties view.

The Layer Properties view opens, displaying the parameters available for the selected effect.

 5. In the Layer Properties view, adjust the effect’s parameters as needed. 

NOTE 

Each time you make a change, the Camera view will need to refresh the rendered 
image, which may cause a little delay before you can observe its effect.

 6. Most effects will not play back in real time in Harmony. To play back your scene with the final effects, 
in the Playback toolbar, click the  Render and Play  button in the Timeline view toolbar. 

NOTE 

Once you have set the parameters for the effect, you can store it in the Library view as a 
template, so you can quickly reuse it without resetting the parameters again—see How to 
Create and Use Templates on page 150.

Using the Cutter Effect
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The Cutter effect cuts out a portion of an image. To do this, it needs to be connected to the drawing it is 
intended to cut as well as to a matte  layer. The cutter will take the shape of the drawing in the matte layer and 
cut this shape out of the drawing layer. This is especially useful if you want to make a character disappear 
between a background element, or if you want to cut out a hole in the middle of a character. 

Like all effects that use a matte, the Cutter's effect has an Inverted parameter, which is disabled by default. 
When enabled, the Cutter will have the reverse effect: Instead of cutting the matte's shape out of the drawing, 
it will cut everything outside of the matte's shape out of the drawing, leaving only the parts of the drawing that 
are covered by the matte. This can be useful if, for example, you want to draw shadows or highlights for a 
character, but you don't want to have to worry about them bleeding beyond your character's outline. You can 
simply connect your shadow or highlight to an inverted cutter, and use a clone of your character as the matte, 
and your effect will not display outside of your character's outlines.

How to use the Cutter effect

 1. Select a drawing layer.

 2. Do one of the following:

 l In the toolbar above the layer list in the Timeline view, click on the  Add Layer  button and 
select Effects > Cutter.

 l Right-click on the layer and select Insert > Effects > Cutter.

The Cutter effect is created as a child of the selected layer. 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.
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 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Timeline view, click on the Expand  button right of the Cutter layer.

The Cutter's Matte parameter appears below it.

 5. Drag and drop your matte layer next to your Cutter layer's Matte field, under the Parameters 
column.

The matte drawing layer becomes the Cutter layer's matte. At this point, areas of the artwork that 

122



intersect with the artwork in the matte drawing layer are hidden. 

 6. If you want to invert the Cutter's effect, so that the artwork that intersects with the artwork in the 
matte layer is visible and that everything else is hidden, double-click on the Cutter layer (but not on 
its name) to open its Layer Properties dialog, then check the Inverted parameter.

Animating an Effect
You may need to animate some effects to obtain the expected results. For example, you may want the radius of 
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the 
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish. 

Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a 
parameter to different values at different points in the scene by adding keyframes to it, and setting each 
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of the 
previous keyframe to the value of the next keyframe. Drawing layers are animated by having their coordinates 
associated to functions. Likewise, effects can be animated by associating their parameters to functions. 

Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an effect's 
parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline view. 
You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which display 
all of a layer's parameters.

How to animate an effect parameter in the Timeline view

 1. In the Timeline view, locate the effect you want to animate, and click on the  Expand  button right 
of its name. 
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The list of parameters that effect's paramaters that are available in the Timeline view appears.

 2. In the right area of the Timeline view, in the same row as the parameter you want to animate, select 
the frame where you want to create the first animation keyframe for the effect.

 3. Create a keyframe by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 4. In the left area of the Timeline view, under the Parameters column, adjust the value of the parameter 
for this keyframe by doing one of the following:

 l Click and hold on the value of the parameter, then drag it towards the left to reduce its value, 
or towards the right to increase its value.

 l Click on the value of the parameter. A text field will appear. Type in the new value of the 
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parameter, then press Enter.

 5. In the right area of the Timeline view, click on the frame where you want to create the second 
animation keyframe for the effect.

 6. Create the second keyframe for your effect's animation by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 7. In the Parameters column, adjust the value of the parameter at the current keyframe. 

 8. Repeat the steps to create as many animation keyframe for your effect as needed.

 9. To adjust the timing between the keyframes of your animation, select the first keyframe.

 10. In the Timeline toolbar, click on the  Set Ease for Multiple Parameters  button.

The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be focused 
on the first  keyframe  in your animation, which should have a  Bezier handle  right next to it, 
pointing to the right. 
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 11. Click on the  Bezier handle  and drag it towards the right, at any angle, to adjust the ease-in of the 
animation.

 12. Click on Apply/Next.

The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last 
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are 
more animation keyframes after this one, it will have two Bezier handles, one pointing in each 
direction.
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 13. Click on the left  Bezier handle  and drag it towards the left, at any angle, to adjust the ease-out of 
the animation between the previous keyframe and the current keyframe. 

 14. If there is a  Bezier handle pointing towards the right, click on it and drag it towards the right, at 
any angle, to adjust the ease-in of the animation between the current keyframe and the next 
keyframe.

 15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire 
scene. 
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How to animate an effect in the Layer Properties dialog

 1. Open the effect's Layer Properties by doing one of the following:

 l Add the Layer Properties view to your workspace, then select the effect in the Timeline view.

 l In the Timeline view, double-click on the effect layer, but not on its name.

 2. In the effect's layer properties, locate the parameter that you want to animate and click on the  
Function  button to its right.

The parameter's input field will be greyed out. This is because you cannot directly edit a parameter 
once it is attached to a function. The field will indicate the name of the function that was created for 
it, in this format:

Name of layer: Name of function: Value at current frame

 3. Click on the parameter's Function button again.

The Bezier Editor dialog opens. 
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This dialog will allow you to animate the function. The function graph at the bottom is made to 
represent the values of the function throughout each frame in the scene. 

 4. In the function graph, click and drag on the red cursor  to move it to the frame where you want to 
create your first animation keyframe.

 5. Click on the  Add Keyframe  button to create the first animation keyframe for the effect.

A keyframe  is created and should be visible in the function graph. If you do not see it, that is 
because the function graph is not positioned to include the keyframe within its frame. To move the 
function graph to view the function's keyframe, click on the  Reset View  or  Reset View 
Vertically  button. 
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 6. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 

TIP 

If you want to set the keyframe to a value that is outside of the function graph's 
frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom 
back in.

 7. Click and drag on the red cursor to move it to the frame where you want to create your second 
animation keyframe. 
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 8. Click on the Add Keyframe  button to create the second animation keyframe for the effect.

 9. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 
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 10. If you want to adjust the timing of the animation between the first and second keyframes, do the 
following:

 l Click and drag the  Bezier handle  of the first keyframe  towards the right, in any direction, 
to affect the ease-in of the animation.

 l Click and drag the  Bezier handle  of the second keyframe  towards the left, in any direction, 
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to affect the ease-out of the animation.

 11. Repeat these steps until you created and timed every animation keyframe required to animate your 
effect.

Creating an Effect Based on an Animated Character
The following tutorial demonstrates how to combine Effects with other Harmony functionalities to easily create 
a drop shadow for an animated character. By following these steps, you can create a drop shadow that will 
automatically follow your character's animation, even if you change the animation afterward.

How to create a drop shadow for an animated character

 1. In the Timeline view, select all the layers making your character's rig. If your character is under a 
master peg, selecting the master peg will also work. 

 2. Make sure your character's rig is in a group. If it is not, right-click on your selection, then select Group 
Selection.
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 3. With your character selected in the Timeline view, create a Clone of your character by doing one of 
the following:

 l Right click on your selection, then select Clone Selected Layers: Drawings and Timing.

 l From the Top menu, select Edit > Clone: Drawings and Timing.

NOTE 

Contrary to a duplicate, a cloned layer always has the same timing and exposure as its 
origin layer, even if its origin layer is changed later. Hence, you can make changes to 
your character's animation, and your cloned character's animation will automatically 
update with these changes.

 4. Add a Shadow effect to your group by doing one of the following.

 l In the Timeline view's layers toolbar, click on Add Layers  and select Effects > 
Shadow.

 l Right-click on your selection, then select Insert > Effects > Shadow.

 5. In the Timeline view, select the root layer of your character's clone.

 6. Create a parent peg for your clone by doing one of the following:

 l From the Timeline View layers toolbar, click the Add Peg  button.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (macOS).
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 7. In the Timeline view, select your clone's parent peg.

 8. In the Tools toolbar, select the Transform  tool. 

 9. In the Camera view, scale and skew your clone so that it looks like a drop-shadow. 
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Chapter 15: How to Use Drawing Guides
Drawing guides are drawing aids that you can add to your scene to help you draw backgrounds and objects 
with straight lines, square angles and graphic projection effects such as isometric projection, straight 
perspective or curvilinear perspective. In traditional art, this is often done with tools such as rulers, T-squares, 
set squares and vanishing points. Guides allow you to simulate the use of such tools in combination with the 
drawing tools in Harmony.

Harmony supports different types of drawing guides, each designed for a different kind of drawing task. Most 
of Harmony's drawing guides work by adding a horizon line and vanishing points to your drawing space. While 
using a drawing guide, dotted guide lines appear through your mouse cursor. These guide lines are either 
parallel or perpendicular to the horizon line, or are going from one of the guide's vanishing points to your mouse 
cursor. When you start drawing a stroke, your drawing tool instantly becomes locked to one of the guide's axes, 
as if you were drawing against a ruler. Optionally, you can use drawing guides as mere visual references, 
without locking your drawing tool against their axes.

Harmony supports the following types of drawing guides:

 l The Ruler allows you to position and rotate a simple axis, then draw a line along that axis, like a regular 
ruler.

 l The Square Grid helps you draw lines that are either parallel or perpendicular to a horizon line.

 l The Isometric Perspective guide helps you draw lines that are parallel to one of three axes: The x-axis, 
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the y-axis and the z-axis. The angle of each axis can be customized as needed.

This type of pseudo-perspective, also referred to as parallel projection, is often used in 2D games, 
computer graphics and schematics to depict 3D objects and environments without using any actual 
perspective, foreshortening or 3D rendering. In 2D animation, it is often used to draw long panning 
backgrounds from a low or high angle. 

 

 l The 1-Point Perspective guide helps you draw lines coming from a single vanishing point in the middle 
of the horizon. It also helps you draw lines that are either parallel or perpendicular to the horizon line. 

This is useful for drawing cuboid structures that are facing the camera. 

 l The 2-Point Perspective guide helps you draw lines coming from one of two vanishing points, which are 
placed on the horizon line outside the camera field. It also helps you draw lines that are perpendicular to 
the horizon line. 

This is useful for drawing cuboid structures from a specific horizontal angle. 
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 l The 3-Point Perspective (Bird's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed below the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from an elevated point of view.

 l The 3-Point Perspective (Worm's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed above the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from a low point of view. 
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 l The 3-Point Perspective (Horizontal Pan) guide helps you draw horizontally panoramic backgrounds, 
with curvilinear horizontal lines. A vanishing point is placed in the middle of the horizon line, to help 
draw lines on the z-axis, and two vanishing points are placed on the horizon line outside of the camera 
field, to define the curve of the horizontal lines. Vertical lines are made perpendicular to the horizon line. 

This is useful for drawing backgrounds meant to be panned over horizontally. Panning the camera 
horizontally over a background drawn with a 3-Point Perspective (Horizontal Pan) guide will simulate a 
rotation of the camera on the y-axis.

 l The 3-Point Perspective (Vertical Pan) guide helps you draw vertically panoramic backgrounds, with 
curvilinear vertical lines. A vanishing point is placed in the middle of the horizon line, to help draw lines 
on the z-axis, and two vanishing points are placed above and below the horizon line, outside of the 
camera field, to define the curve of the vertical lines. Horizontal lines are made parallel to the horizon 
line. 

This is useful for drawing background meant to be panned over vertically. Panning the camera vertically 
over a background drawn with a 3-Point Perspective (Vertical Pan) guide will simulate a vertical rotation 
of the camera on the x-axis. 
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 l The 4-Point Continuous Perspective guide is very similar to the 3 Point Perspective (Horizontal Pan) 
guide, except that it is designed to help draw full 360° panoramic backgrounds. 

This guide uses 5 vanishing points. When drawing a horizontal line, it is curved by arching over one of 
the vanishing points and reaching down to the two surrounding vanishing points. This creates a 
perspective effect where each vanishing point represents one of the cardinal points, except that the 
leftmost and the rightmost points represent the same cardinal point, effectively creating a looping 
background. Backgrounds made with the 4-Point Continuous Perspective guide can be looped 
horizontally to simulate a full rotation of the camera on the y-axis. 

 l The 4-Point Perspective (Vertical Pan) is a lot like the 2-Point Perspective guide, except that its 
vertical lines are curvilinear, so it can be used to make vertically panning backgrounds. Two vanishing 
points are on the horizon line, outside of the camera field, to help draw lines on the x-axis and the z-axis, 
and two vanishing points are placed above and below the camera field to define the curve of the vertical 
lines.
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This is useful for drawing backgrounds meant to be panned over vertically, in which cuboid objects are 
seen from an angle.

 l The 5-Point Perspective (Fish Eye) guide helps you draw backgrounds that are curvilinear on both the 
x-axis and the y-axis. It has one central vanishing point on the horizon line, from which lines on the z-
axis are drawn, two vanishing points at the extremities of its horizon line, to define the curve of the 
horizontal lines, and two vanishing points above and below the horizon line, to define the curve of the 
vertical lines. 

This guide can be used to draw backgrounds with a fisheye-style wide angle lens effect. It can also be 
used to draw backgrounds that are meant to be panned in various directions.

In order to use a drawing guide, you must first add it to your scene's guides list. To help yourself get familiarized 
with guides, you can start by adding 1-Point Perspective drawing guide to the guides list.
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How to add a 1-Point Perspective drawing guide to                                    your scene                 

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. Add the Guide view to your workspace by doing one of the following:

 l In the top-right corner of any view in your workspace, click on the  Add View button and 
select Guides.

 l In the top menu, select Windows > Guides. 

 3. In the Guides view, click on the  New Guide  button and select  1-Point Perspective. 

The new guide appears in the guides list. 

142



When a new guide is added, it is configured with a preset position and angle for its horizon line and a preset 
position for its vanishing points. In many cases, you have to make adjustments to your guide so that you can 
draw backgrounds and objects from the right point of view.

How to adjust a 1-Point Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  1-Point Perspective guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its vanishing point .

 l To rotate the guide, click and drag on its horizon line.

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.

Once your guide is selected and properly positioned, you can start drawing with it. 
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 How to draw with a drawing guide

 1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing 
by doing one of the following:

 l Right-click on the cell and select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R

 2. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 3. In the Guides view, select the guide you wish to use.

 4. To avoid accidentally editing your guide while you're drawing, click on the  Lock Guides button in 
the Guides view to toggle it on.

 5. If you want your drawing strokes to be locked against the axes of your guide, make sure the  
Align with Guide option of the Guides view if toggled on. Otherwise, toggle it off to be able to draw 
freely and only use the guides as references.

 6. Move the mouse cursor around the drawing space. Observe that guide lines are going through your 
mouse cursor, one for each of the axes of the drawing guide.

 7. Start drawing a stroke roughly at the same angle as one of the axes.

If the  Align with Guide option is enabled, the drawing stroke aligns to the axis that is the closest 
to its angle, as if you were drawing against a ruler.
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TIPS 

 l You can also manually select which axis to lock onto by pressing the Left Arrow and Right 
Arrow keys to cycle through each axis. The selected axis will appear bolder than the other 
ones. If you cycle through all the axes, no axis will be bold, meaning the axis your drawing 
tool locks against is determined by the angle of your drawing stroke again. 

 l Whether you're drawing or not, you can lock the position and angle of the guide lines by 
pressing and holding the Alt key. The guide lines will stop following the mouse cursor, 
allowing you to keep them at a specific angle and position. This can be used to draw over 
the same line several times over so as to adjust its length and thickness. 

Once you are done working with guides, you can disable them. When drawing guides are disabled, they are 
not displayed in your drawing space and do not affect the behaviour of your drawing tools. 

How to enable and disable drawing guides

 1. To enable or disable Drawing Guides, do one of the following: 

 l In the Guides view, click on the Enable Guide  button.

 l Press Shift + G.

NOTES 

 l Guides are automatically enabled when you add a new guide or when you select a guide in 
the guides list.

 l The guide that was selected when you disabled guides will be selected again when you re-
enable guides.

 l Drawing guides only work with the  Brush,  Pencil,  Stroke and  Line tools tools. 
If any other tool is selected, drawing guides will behave as if they are disabled. 
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Chapter 16: How to Create a Multiplane
In live action, when the camera moves around in a scene, objects near the camera will appear to move by a 
greater distance than objects far from the camera. In 2D animation, a similar effect can be achieved by creating 
a multiplane.

In Harmony, you can easily set-up a multiplane by creating a background over several layers, spreading them 
on the Z-axis to add depth, and then moving the camera through the resulting environment to create an 
impressive perspective illusion. 

In the following example, the background is made of 6 different layers, each picturing an object that is at a 
different distance from the camera. On the left, you can see how each object is positioned relative to the 
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned 
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the 
camera's point of view.
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Using the Maintain Size tool, you can easily turn a normal multi-layered background into a multiplane.  This tool 
allows you to move a layer closer to or further away from the camera  all the while automatically adjusting the 
layer's size proportionally to its distance from the camera, preserving its a apparent size from the camera's 
point of view. Hence, you do not have to worry about the size and position of your layers when you design your 
background. 

In a new Harmony scene, draw the different elements of a background on separate layers. Then, follow the 
steps below to turn your background into a multiplane. 

How to set up a multiplane using the Maintain Size tool

 1. Do one of the following:

 l In the Advanced Animation toolbar, select the  Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer 
from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.
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 3. Drag the layer along the Z-axis inside the camera cone. 

Your element will move on your scene's Z-axis, but it will keep the same apparent size in the Camera 
view. 
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Chapter 17: How to Create and Use Templates
You can create a template from a layer or from cells. You can store anything available in the Timeline view as a 
template. 

Creating a Template

How to create a template

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting 
its root layer. This can be useful for creating templates based on character rigs or scene 
backgrounds.

 2. In the Library view, select a folder to store the template. By default, you will have a library named 
Harmony Essentials Library , which is stored on your computer, in the Toon Boom Harmony 
Essentials Library subfolder of your Documents folder.

 3. If the library folder is  locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 

 5. In the Rename dialog box, give the new template a name.

 6. Click OK.
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TIP 

To rename a template once it is created, right-click on it and select Rename.

Importing a Template

How to import a template 

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If 
you drop a template in the layers list in the Timeline view, it will be inserted between the layers 
where you dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template 
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into 
your scene, this will replace the drawings and keyframes in your scene with the ones from the 
template. This is useful for importing pose or animation templates for characters that are already in 
your scene. 
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Chapter 18: How to Export a Movie
Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export 
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your 
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space. 
Depending on the format in which you export your movie, you can also customize the video and audio 
compression settings for quality or for disk space. 

How to export a movie file

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. In the Output section, open the Video Format drop-down and select the desired format for your 
movie file:

 l QuickTime Movie (*.mov): The Apple QuickTime format. This is the default export 
format and is recommended for its portability, and also because it allows you to choose 
among several video codecs.
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NOTES 

 l On Windows, Apple QuickTime must be installed to allow Harmony to 
export QuickTime movies. You can configure the export of QuickTime 
movies to use any codec that is compatible with QuickTime, including 
H.264, MPEG-4 and Animation.

 l On macOS, Harmony uses Apple AVFoundation to export QuickTime 
movies, which allows you to export using codecs such as H.264, Apple 
ProRes 422 and Apple ProRes 4444, among others.

 l If you are looking to export a QuickTime movie with transparency, be 
sure to choose a codec that supports encoding with an alpha channel.

 l H.264/MPEG-4                      (*.mov)                    : A simple movie format that uses the H.264 codec, which is 
supported by most web browsers.

NOTES 

 l Using this format does not require additional software. However, if this 
is the first time you export a movie in H.264/MPEG-4 format, you will 
be prompted to download the OpenH264 library from Cisco. Simply 
click Yes when prompted, and Harmony will automatically download 
the library, then export the movie. 

 l There are no encoding options for this format. 

 l This format supports resolutions of up to 4096×2304. Each dimension 
must be a multiple of 16 pixels. 

 l Audio exported in this format is encoded in PCM 16-bit stereo, 22.05 
kHz.

 l Windows Media Video (*.wmv): The native format for Windows Media Player.

NOTES 

 l Windows Media Video (.wmv) files can only be exported on Windows. 

 l Video players and editors on non-Windows systems can generally not 
open Windows Media Video (.wmv) files.

 l Flash (.swf)

 l Image sequence in Jpeg (.jpg), Targa (.tga) or Portable Network Graphics (.png) 
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format.

 3. Click on the Browse button.

 4. In the Save dialog that appears, browse to the location where you want to export the movie file. 

 5. In the File name field, type in the file name you want the movie file to have.

 6. Click on Save.

 7. From the Export Range section, do one of the following:

 l Select All if you want to render the entire scene.

 l Select Frames if you want to render a part of your scene. Then, in the field to the right, type 
in the first frame of the sequence you want to export, and in the other field, the last frame of 
the sequence you want to render.

 8. Open the Resolution drop-down and do one of the following:

 l Select Same as Scene Resolution if you want to export a movie with the same resolution as 
your scene.

 l Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of 
Scene Resolution if you want to export a movie that is smaller than the resolution of your 
scene.

 l Select Custom if you want to manually set the export resolution. Then, in the Width and 
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Height fields, type in the desired resolution for your movie, in pixels.

 9. Click OK.

 10. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 11. Browse to the location on your computer where you exported your movie file, and double-click on it 
to view it in your video player.

157

Harmony 20 Essentials Getting Started Guide                          



Glossary

Glossary

3D 
stereoscopic

Images or movies that actually output two different images, each from the point of 
view of one of the human eyes. When viewed or projected through special devices, 
such as a 3D display or virtual reality goggles, this creates the illusion that the 
elements in the image are actually in front of the viewer.

alpha channel An image channel that carries transparency information. An image already has 
three channels: red, green and blue (RGB). The alpha channel is the fourth channel 
(A). The matte, or the transparency information, is stored in this fourth channel. An 
image without an alpha channel is always opaque.

animatic A movie made by sequencing the panels in a storyboard, and timing each panel for 
the rough duration of the action they represent, and in sync with the soundtrack. 
Animatics are used to convert the storyboard into a very rough draft of the final 
movie, to determine the time alloted to each scene and each action and to 
synchronize the action with the sound track.

animation The simulation of movement created by drawing or editing individual frames.

anime Japanese animation.

arc Action rarely occurs in a straight-forward manner; rather it typically unfolds in 
what storytellers refer to as an arc. The purpose of a story arc is to move a 
character or situation from one state or scenario to the next.

aspect ratio The ratio between the width and height dimensions for any scene, frame or film 
format. Currently, the most popular aspect ration is 16:9. Legacy displays would 
use an aspect ratio of 4:3.

auto-feed An automated method of feeding drawings into a scanner in which multiple 
drawings are stacked into a sheet feeder. When the scanner is activated, the 
drawings are scanned consecutively, without further user intervention.

automatic lip-
sync 

detection

Automatically mapping drawings in an element to the mouth chart generated for a 
sound. This can save time when lip-syncing a voice track.

axis An imaginary line around which an object rotates.  For 2D graphics, there are two 
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axes: X (horizontal and Y (vertical).  For 3D graphics, there are three axes: X 
(horizontal, Y (vertical) and Z (depth).  In animations that constantly rotate, the axis 
element specifies what axis the object rotates around. A negative number causes 
an animation to rotate counter clockwise whereas a positive number causes an 
animation to rotate clockwise.

background The artwork that fills the camera field and which is behind the characters and 
props. Typically, this artwork represents the decor or stage in which the action 
occurs.

Bézier A method of defining curved lines invented by French mathematician Pierre 
Bézier. A Bézier curve is a mathematical or parametric curve. Bézier curves are 
defined by control points. In Harmony, Bézier curves have a starting point, an 
ending point and two inner control points that influence the curve between the 
starting and ending points.

bitmap An image defined by a mesh of pixels, as well as the individual colour of each one of 
its pixels.  Bitmap graphics are known for being preferable to vector graphics for 
highly detailed or photorealistic artwork. However, bitmap graphics cannot be 
scaled, rotate or skewed without losing picture quality.

breakdown In cut-out animation, breakdown is the action of breaking a character into pieces to 
create a puppet with articulations. To break down a character, the artist cuts parts, 
such as the hands and arms, from the character's model and pastes them in 
separate layers. Next, the joints are fixed and the pivots set.  In traditional 
animation, a breakdown is an animation pose generally found between two key 
poses. The key poses are the main poses in an animation and the breakdowns are 
secondary poses, ones that help describe the motion and the rotation curve 
(usually referred to as an arc).

camera shake Camera shake occurs in a scene when the camera moves slightly and quickly in 
several directions. This gives the impression of an impact, vibration or, for example, 
bumps on the road.

caption A text field containing dialogue, effects, sound or slugging information in a 
storyboard.

cel In traditional animation, a cel (also known as celluloid) is a transparent sheet on 
which the animation is inked and painted before being sent to the camera. The 
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picture's outline is drawn on the front of the cel and then coloured along the back.

character 
design

Each character in an animated film is drawn from multiple angles in poster-style 
format, called a model sheet, which serves as a reference for the animators.

chromatic 
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type 
of distortion in which there is a failure of a lens to focus all colours to the same 
convergence point.

clean up After rough drawings have been tested and approved, all the noise in the image 
(excess lines, notes, etc.) is removed to create final drawings which can be inked, 
painted and shot. The clean up process refers to either tracing a clean line over a 
rough drawing to achieve the final version or removing dirt and extra lines left by 
the scanning process.

CMYK Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model 
used in a process called offset printing.

colour card A colour card is a card containing one solid colour that is the same size as the 
camera. The colour card fills the background with a solid colour when there is no 
background image included.

colour model The official colour design that must be used to paint the animation. A model is the 
definitive character, prop or location design that each artist must follow for the 
production.

colour wheel A display of the colour spectrum in the form of a circle.

compositing Compositing is the action of incorporating all of a scene's elements to create the 
final result prior to rendering. For example, the compositing artist will import all the 
animation sequences, background, overlays and underlays in the scene and 
position them correctly. The artist will then set the camera frame and animate it, if 
needed. Finally, the animator will create all the computer-generated effects for the 
project.

cross dissolve When one scene transitions to the ensuing scene by fading out at the same time 
as the ensuing scene fades in.

160



cut When one scene transitions to the ensuing scene from one frame to the next, 
without any visual effect.

cut-out 
animation

The process known as cut-out animation is the action of animating characters 
made out of several pieces by moving them around frame by frame. Cut-out 
animation can either be computer generated or done traditionally using paper.

cycle A series of animation frames that can be repeated to simulate a continuous 
movement. For example, a character is often made to walk by animating them 
taking two steps forward, one with each foot, then cycling this animation.

dialogue The text spoken by a character in a movie or animation.

dope sheet Used by animators, directors and other members of a crew to track the sequence 
and timing of images, dialogue, sound effects, sound tracks and camera moves. 
Also known as an exposure sheet.

doping To assign a particular drawing to a range of frames.

double 
bounce walk

In the key frames and passing positions in a double bounce walk, the body is lower 
than a reference line drawn in the upright position. During the in-betweens, the 
body is above this line giving the appearance of a bounce.

dpi Dots per inch is the standard measure of resolution for computerized printers. It is 
sometimes applied to screens, in which case it should more accurately be referred 
to as pixels per inch. Either way, the dot is the smallest discrete element making up 
the image.

drag An operation which consists of clicking and holding the item, then moving it 
around by moving the mouse cursor. This can be done with the left mouse button 
or with the pen tip.

ease In animation, the ease, also known as velocity, is the acceleration and deceleration 
of a motion. It can be a motion created by a function curve, or a series of animated 
drawings. Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.
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ease-out Gradual deceleration in the action. Also known as slow-out.

establishing 
shot

A scene in which the viewer can see the whole area in which a sequence is 
happening. For example, if a child is playing on the ground in front of his house, the 
establishing shot would be a scene where the viewer can see the house, the 
ground, a part of the street and the buildings around the central point of action. 
This helps the viewer understand the story location and scene orientation.

exposure In animation, an exposure is the number of cels on which a drawing appears in the 
scene. For a drawing to appear longer, the exposure must be extended over a 
greater number of cels.

exposure 
sheet

A sheet with several vertical columns and horizontal frames used to indicate a 
scene's timing. Each column represents a scene layer. The drawing numbers in 
each column are indicated and repeated over the particular amount of frames they 
need to appear.  The exposure sheet is used by animators, directors and other 
members of a crew to track the sequence and timing of images, dialogue, sound 
effects, sound tracks and camera moves. Also known as a dope sheet.

fade in/fade 
out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in 
occurs when the first scene appears progressively, from complete transparency to 
its complete opacity. A fade out occurs when the last scene progressively 
disappears, going from complete opacity to complete transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field A measurement unit used in traditional animation to record and track the position 
of the camera as well as its proximity to the stage.

field chart A guide containing all the field units that animation and layout artists use to define 
the size of the camera field as well as the camera movements.

film-1.33 A resolution that is ideal for the widescreen film format that conforms to the 
standard 4:3 pixel aspect ratio.

film-1.66 A resolution that is ideal for the widescreen film format that conforms to the 16:9 
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pixel aspect ratio.

flipping In traditional animation, flipping is the action of going through the drawings of an 
animation sequence very quickly in order to see the animation in motion. Flipping 
can also be the action of creating a mirror transformation of an object.

follow-
through

The secondary motion caused by the main action. For example, a character 
wearing a cloak is running. The main action is the body running. This will cause the 
cloak to follow the motion, although it will not move at the same time, but react a 
few frames later and follow the main motion curve.

forward 
kinematics

Forward kinematics is a feature used to animate principally 3D characters and cut-
out puppets with hierarchy. It is used to animate a puppet from one of parent parts, 
such as a shoulder, and make the rest of the arm move with it as a single piece.

frame An animation frame is a single photographic image in a movie. In traditional 
animation, the North American standard generally contains 24 frames per second, 
while in Europe the standard is 25 frames per second.

frame rate The frame rate is the speed at which the frames are played. They are generally 
calculated by frame per second. For example, a scene could be played back at 12, 
24, 25, 30 or 60 frames per second or any other number.  This is the measurement 
of the frequency (rate) at which an imaging device produces unique consecutive 
images, called frames. The term applies equally to computer graphics, video 
cameras, film cameras, and motion capture systems.  Frame rate is most often 
expressed in frames per second (fps) and in progressive-scan monitors as hertz 
(Hz).

function A computer-generated motion, trajectory or path on which elements, other 
trajectories and effects parameters can be attached. The function can be controlled 
by adding keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV The acronym for High Definition Television, which is the current resolution 
standard for television productions. The resolution of HDTV productions is either 
1280×720 (HD ready) or1920×1080 (full HD) and their frame rate generally range 
from 23.976 to 30.
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hold A frame in the animation in which the character maintains its position without 
moving. A hold can be created between any two keyframes.

HSV Hue, Saturation and Value. A method of defining colours in terms of hue (tint), 
saturation (shade) and value (tone or luminance).

in-between The drawings that exist between the key poses. These are drawn to create fluid 
transitions between poses.

ink and paint The ink and paint process is the action of painting the empty zones and colouring 
the lines on the final animation drawings, while following a colour model.

interpolation The computer-generated motion created between two keyframes. You have the 
choice to create interpolation, or not, between your keyframes.

inverse 
kinematics 

(IK)

A feature used mainly to animate 3D characters and cut-out puppets with 
hierarchy. Inverse kinematics will animate a puppet from one of the extremities, 
such as a hand, and make the rest of the body follow naturally.

jump cut A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is 
generally caused by one scene ending, and a second one starting, with a similar 
image. The lack of difference causes the eye to see a little jump between the two 
scenes.

key pose Important positions in the action defining the starting and ending points of any 
smooth transition. Keys, or key poses, are the main drawings in an animation 
sequence describing the motion. For example, if an arm is waving, the keys will be 
of the arm at one extremity of the wave motion and the other extremity. By 
flipping those drawings, the animator can see the skeleton of the motion without 
having all the drawings.

keyboard 
shortcuts

A keyboard key, or a combination of keyboard keys, that is assigned to perform a 
specific command in the application when pressed.

keyframe Important positions in the action defining the starting and ending points of any 
action. A keyframe is a computer-generated position at a specific moment (frame) 
on a given trajectory.
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layer In animation, a layer is an individual column, level or character. A scene's layers are 
superimposed to form the final image.

layout The communication step between the storyboard and the animation. It is the 
action of putting the storyboard on model. That is, drawing the character by 
following the design in the model pack, so the animator can start working.  The 
layout artist draws the background, creates the camera and field guide matching 
the scene and camera motion. Lastly, the animator draws on model the main action 
poses.

layout and 
posing

The action of putting on model (at the right scale) the storyboard for the animator 
to start working.

layout artist The artist who draws the background, and creates the camera and field guide to 
match the scene and camera motion. They will draw on model the main action 
poses.

layout 
planning

Drawing of the main features of the scene used as reference when planning the 
animation and executing the initial stages of it.

layout process The communication step between the storyboard and the animation.

library A storage area containing templates and assets that can be reused in any project 
or scene.

light table A device that allows you to see other layers in transparency while you are working 
on a particular layer.

line of action The main centreline in an action pose. When drawing action poses, minding the 
line of action ensures the pose is dynamic and that its silhouette fits the direction of 
the action.

lip-sync The process of synchronizing a character's mouth to sounds in the dialogue sound 
track. The mouth is adjusted frame-by-frame to match the sound of the dialogue 
and provide the illusion that the character is speaking. Lip-sync can be used for 
any sound sequence, not only speech, you could for instance have a bird chirping or 
a wolf howling at the moon.
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low resolution A format that is ideal for videos destined for the web, where size and fast 
download of a video file take precedence over quality. A low-resolution image is 
one that lacks fine detail.

manual lip-
sync 

detection

The manual swapping of mouth position drawings to match a voice track. For this 
process, both sound scrubbing (listening to a sound wave broken up frame-by-
frame) and drawing substitutions are used.

master palette A group of colours attributed to a character or prop. The palette is used throughout 
the entire production to maintain consistency in the look and to ensure that the 
same colours are used throughout the production. Also known as palette.

model/colour 
model

The definitive character, prop or location design each artist must follow for a 
production. A colour model is the official colour design that must be used to paint 
the animation.

morphing A feature for creating computer-generated drawings between a source drawing 
and a destination drawing. Animation created with the morphing feature can be 
reused in different projects.

motion 
keyframe

A keyframe with computer-generated interpolation.

mouth chart A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is 
used to represent silence) used for lip-sync.

multiplane The effect of passing through multiple levels of drawings to create a sense of depth 
in a shot. A multiplane is a scene in which the layers are placed at different 
distances from the camera so that when the camera moves, a depth illusion occurs. 
With a multiplane, all the perspective and scale is calculated automatically.

NTSC The legacy standard analogue television broadcasting system used in North 
America.

nudge A small push (left, right, up, down, forward or backward) done with the keyboard 
arrow keys on a selected element. Nudging is used to move a selection very slightly 
and precisely.
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onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay A part of the scene environment, such as a chair or a bush, that is placed in front of 
the main animation.

PAL A resolution that works best with the European format for television and computer 
screens, as the rectangular pixels are displayed at a different orientation.

palette style A palette style is a second version of an existing palette with a slight change in the 
tint and value. A palette style can be used to create the night version of a palette. It 
may also be called a clone palette.

palette/master 
palette

A palette or master palette is a group of colours attributed to a character or a prop. 
The palette is used throughout the entire project to maintain a consistency in the 
look and avoid the colour changing during the animation. Also referred to as a 
master palette.

pan To move the camera across the scene in any direction.

panel In a storyboard, a panel is a frame in a shot. A shot can be composed of one or 
several panels.

paperless 
animation

The paperless animation process is the action of animating digitally. The main 
paperless animation process is to draw, frame by frame, the animation directly in 
the software.

passing 
position

When drawing a walk sequence for a character, the passing position is the point at 
which one leg passes the other.

path of action The path that the action follows.

peg In traditional animation, a tool used to ensure accurate registration of action as cel 
layers move. In digital animation, in which you are doing a more advanced puppet 
rigging, you can use peg layers. Peg layers are trajectory layers that do not contain 
drawings. They are motion paths that you can use to add path articulations. For 
the latter, you can also use an inverse kinematics tool.

phoneme A unit of sound in a language.
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pivot The point around which a peg or drawing rotates.

pixel The smallest element of an image displayed on a monitor or TV screen.  Pixel, short 
for picture element, is a single point in a graphic image. It is a small sample of an 
image, a dot, a square, or a very small section made out of smooth filtering. If you 
zoom in close enough on a digital image, you will see the pixels, which look like 
small squares of different colours and intensity.

pose-to-pose 
animation

The pose-to-pose animation process is the action of creating all the main action 
poses, called key poses, and then placing the secondary poses between the keys. 
The secondary poses are called breakdown. Finally, the animator fills the gaps with 
the in-between drawings to achieve a smooth animation.

rendering The final step when animating by computer. During rendering, the computer takes 
each pixel that appears on screen and processes all of the components, as well as 
adding motion blur before it produces a final image. The process of calculating the 
final images after the compositing process.

resolution The size of a scene, generally calculated in pixels. For example, the NTSC resolution 
is 720 x 480. The resolution should match the final output: HDTV, film-1.33, film-
1.66, NTSC, PAL, low.

RGB Red, Green, Blue. A method of defining colour by specifying amounts of these three 
colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table Equivalent to the animation disk/table, a device that allows you to rotate the 
workspace for greater comfort while drawing.

rotoscoping An animation technique in which animators trace over live-action film movement, 
frame by frame, for use in animated films. The act of sketching over live-action 
footage to create an animated sequence.

roughs Rough is a common name in an animation movie for a drawing that is used as a 
reference but which does not form part of the final image. A layout is a rough. The 
skeleton sketch of an animation or design. Roughs mainly consist of sketch lines 
and shapes, but can also contain design details.
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safe area The zone at the center of a scene's frame that is safe from being cropped by the TV 
frame. As a TV frame cuts a margin off the original frame size, maintaining a safe 
area ensures that the scene's main action will remain clearly visible once the film is 
screened on television.

scene A shot in a movie or show. A sequence is composed of several scenes. A scene 
changes to another scene by a simple cut or transition.

script The original text containing all the movie or show information. In animation, the 
script contains all of the location descriptions, dialogue, time and more. A project 
starts with a script.

sequence A series of scenes or shots forming a distinct part of the story or movie, usually 
connected by unity of location or time.

shot A scene in a movie or show. A sequence is composed of several shots. A shot 
changes to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound 
scrubbing

A process that lets you hear sound in real time while you move the playhead 
forward or backward. This is very useful for finely-tuning a lip-sync.

stop-motion 
keyframe

A keyframe with no computer-generated interpolation.

storyboard A visual plan of all the scenes and shots in an animation. The storyboard indicates 
what will happen, when it will happen and how the objects in a scene are laid out.

straight-
ahead 

animation

A technique in which an entire sequence is drawn from the first position to the last, 
in order. There is very little planning in this methodology. Where the character 
ends up and how it gets there can be a surprise for both the audience and the 
animator. While this approach is spontaneous and creative, it can create inaccurate 
results.
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strokes When not referring to actual brush or pencil strokes, strokes are invisible outlines 
that are used to define colour zones, or to close open colour zones.

symbol A symbol combines animation, artwork or layers into a single object that you can 
control in one layer. You can also create symbols out of each body part in your cut-
out puppets.  You can place whatever you want in a symbol. You can use symbols to 
animate a puppet or create reusable animations such as blinking.

tablet/pen A device used in conjunction with, or instead of, a mouse to move a mouse pointer 
(sometimes referred to as the cursor) around the computer screen.

template An asset stored in the library that can be reused in any project. A template can be 
a drawing, a series of keyframes, a sound file, a panel, a cut-out character, an effect, 
a trajectory, an animation, or anything else used in the animation.

thumbnail A very small image used as a reference or indicator.

timecode The timing information printed on a movie clip to indicate the scene, hour, minute 
and second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and 
paint

After the rough animations have gone through cleanup and a final line or pencil 
test, each drawing is traced and painted for the final animation. In today's digital 
world, this may be done in a variety ways other than the traditional celluloid or 
acetate methods.

track 
breakdown

The break down of an animated film's soundtrack into individual sounds to produce 
the precise frame-by-frame position of each sound.

traditional 
animation

A type of animation process whereby all the animation sequences are drawn by 
hand on paper before scanning or inking them on cels.

trajectory A computer-generated path or trajectory that elements can follow. The trajectory 
can be controlled by control points, keyframes and velocity.

transition An effect placed between two scenes as they pass from one to the other. Common 
transition effects are cross-dissolve and wipe.
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underlay In animation, an underlay is a specific part of the decor placed behind the main 
animation.

vector A vector-based image is composed of points and Bézier curves. The computer 
reads the points and traces the segments, linking them to reproduce the image 
shape. There is no fixed size or resolution in a vector image. The graphic can be 
enlarged and distorted as much as desired and the system will simply recalculate 
the segments and rebuild the shapes. Vector images are translated and displayed 
in pixels once the calculation is done.

velocity In animation, the velocity, also known as ease, is the acceleration or deceleration of 
a motion. This can be achieved by a function curve, or via a series of animated 
drawings. Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle A series of drawings "on the spot"  that describe the walk for a character. The 
illusion of movement is created by the use of background pans. To avoid making 
innumerable drawings, animators routinely make a walk cycle for a character.

zone An area which can be painted with colour.
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