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Introduction

Introduction
The Harmony core functionality are explained in this User guide. All the steps required to create and complete 
a project are covered in the following chapters with concept descriptions and detailed step-by-step 
procedures focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide 
and Preference guide. Some of them are explained here where necessary to the understanding of a given 
concept or procedure.  
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Chapter 1: Project Creation

Chapter 1: Project Creation
Once Harmony Essentials is installed, you are ready to start the application and animate! In this chapter, you 
will learn about starting the application, as well as creating, opening and saving scenes
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Starting Harmony
T-HFND-001-002

You can run Harmony Essentials from your operating system's desktop. 

WARNING 

On macOS, Harmony and its other applications will not run on the first time unless you right-click 
on the application, then select Open. You will be prompted to confirm a security exception, which 
will require administrative privileges. 

How to start Harmony 

 1. Depending on your operating system, do one of the following:

 l Windows: Do one of the following:

 l On the desktop, double-click  Harmony Essentials

 l Open the Start menu and, in the list of programs, select Harmony 17 Essentials >  
Harmony Essentials.

 l macOS: In Finder, proceed to Applications >  Toon Boom Harmony 17 Essentials and 
double-click  Harmony Essentials.

The Harmony Essentials application launches and displays a splash screen. After the splash screen, 
the Welcome Screen will appear —see About the Welcome Screen on page 29. 
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About the Welcome Screen
T-HFND-001-003

As soon as you launch Harmony, you are greeted with the Welcome screen, from which you can:

 l Create scenes

 l Choose your new scene's resolution

 l Manage your scene resolution presets

 l Quickly open recently opened scenes

 l Browse for and open a scene you already created.

 l Watch Harmony video tutorials on the web.

 l Access the support web page.
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About Scenes
When working in production, it is important to keep your work organized. It is important to create a naming 
convention chart and establish a file storage structure before starting the project. It is not only extremely 
important that everyone follows the criteria laid out in the naming convention chart and the file storage 
structure, but also that they understand the organization and where to find the files.

A well thought-out and logical naming convention will help keep your production structured and allow it to run 
smoothly by preventing the loss of files due to chaotic organization.

In this section, you will learn how to create, open, organize,  and name the different components in your 
animation project.
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Creating Scenes
T-HFND-001-005

All scenes created via  Harmony Stand Alone are independent and local to the computer. You can create or 
open a scene using the Welcome screen or the File menu.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.

NOTE 

The scene name should not exceed 23 characters and cannot contain special 
characters, such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location 
field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created. The main application window will appear with your new scene opened in it.
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How to create a new scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > New. 

 l In the File toolbar, click the New  button. 

 l Press Ctrl + N (Windows/Linux) or ⌘  + N (macOS).

The New Scene dialog box opens.

 2. In the Project Name field, type the scene's name.

 3. Select a scene directory by clicking the Browse button.

NOTE 

The scene name cannot exceed 23 characters and cannot contain special characters, such as 
*&^%!.

 4. In the Resolution window, select the scene’s resolution and click Create.

A new scene is created.
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Creating Custom Resolutions
T-HFND-001-006

You can create your own custom resolution presets for your projects.

How to create a custom resolution

 1. Create a new scene from the Welcome screen or from the File menu in Harmony.

 2. Set the scene resolution by doing one of the following:

 l Select a scene resolution from the Camera sizes drop-down menu.

 l Set a custom resolution by changing the values in the Width and Height fields. This 
preset will not be saved.

NOTE 

The different editions of Harmony support the following maximum render 
resolutions:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited

 l Add a new resolution to the list by clicking the Add   button. You can delete a 
custom resolution from the Resolution list by selecting it, and clicking the Delete 
button.

 3. In the New Resolution dialog box, fill in the following fields and click Create.

 l Resolution Name: Name your new resolution.

 l Resolution: Set the width and height of the scene, in pixels. 
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 l Field of View: Select how the angle of the field of view  should be determined. 

 l Horizontal Fit: The angle of the field of view is adjusted to the width of the 
scene.

 l Vertical Fit: The angle of the field of view is adjusted to the height of the scene. 

 l Custom Fov: Set the angle of the field of view to a custom value. 

 l Frame Rate: The amount of frames to play each second. You can select one of the 
preset frame rates in the Preset drop-down, or type in a custom frame rate in the 
Frames per second field. 
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Opening Scenes
T-HFND-001-007

You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen

 1. In the Recent Scenes section, click Open.

The Open Scene browser opens.

 2. Browse and select an .xstage file.

 3. Click Open.

How to open a scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > Open. 

 l In the File toolbar, click the Browse  button. 

 l Press Ctrl + O (Windows/Linux) or ⌘  + O (macOS).

The Open Scene browser opens.

 2. Browse and select the desired .xstagefile.

 3. Click Open.

How to open a recent scene from the Welcome screen

 1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu

 1. From the top menu, select File > Open Recent.

 2. Select a scene from the displayed list.
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Setting the Scene Length
T-HFND-001-009

Once you have opened your scene, you can set its length. 

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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About Scene Settings
T-HFND-001-010

When you created your  scene, you set up the resolution and the alignment. However, if you want to change 
these settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options are 
separated into four tabs.

NOTE 

Refer to the Scene Setting dialog box  in the Reference guide to learn more about the individual 
parameters of the Scene Settings dialog box.

How to access the Scene Settings dialog box

 1. In the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.
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Saving Scenes

T-HFND-001-011

You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses 
the same drawings in all versions. 

How to save a scene

 1. Do one of the following

 l In the top menu, select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (macOS).
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Saving Scenes as Copies

Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene 
a new name. The name cannot exceed 23 characters.

 3. Click Save.
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Saving Scenes as New Versions

Saving a new version of your scene allows you to save your scene at it's current location, under a new file name. 

How to save a new version of a scene

 1. Select File > Save As New Version.

The Save Version dialog box opens.

 2. In the Save Version dialog box, type the new version name.

 3. Click OK.
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Enabling Auto-Save

T-ANIMPA-001-001

You can allow the software to automatically save your scene, as well as decide on the interval of time between 
auto-saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows: Select Edit > Preferences.

 l macOS: Select Harmony Essentials > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): The frequency at which auto-save happens.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you 
are drawing or doing anything in the application. Auto-save will not happen until you 
have stopped using the application for this amount of seconds. 

 l Ask Before Saving: Before performing an auto-save, you are prompted with a 
message to confirm if you want to save or not. 

 l Enabled: This enables the Auto-save feature. If you do not want the system to 
automatically save your work, uncheck this option. Auto-save is off by default.
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About the File Structure
T-HFND-001-008

A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the 
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the 
files contained in the folder structure.

Here is an example of the file structure contained in a scene. As you work and use more features, different 
folders may appear in your structure.

The Harmony scene folder contains the following folders:

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation 
column in the Xsheet view.

audio Contains all imported audio files.

elements
Contains all the drawing files. The drawings are organized by folders named like 
the layers they are associated with.

environments
If the scene was exported from a Harmony Server database, this directory will 
contain the palettes and templates that were stored in the scene's environment. 
Otherwise, it is empty.

frames
Contains the final frames after a render if you are using the default settings of the 
Write node in the Node view.

42

Harmony 17 Essentials User Guide                          



Chapter 1: Project Creation

jobs
If the scene was exported from a Harmony Server database, this directory will 
contain the palettes and templates that were stored in the scene's job. Otherwise, 
it is empty.

palette-library Contains scene palettes and scene palette list files.

timings
This folder is used when a user links external images to a scene and wants to 
store a backup copy in case the link breaks.
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Chapter 2: User Interface
T-HFND-003-001

Knowing how to manage the Toon Boom Harmony Essentials interface helps you to work efficiently and 
organize your workspace conveniently. There are a series of views and toolbars you can use as you perform 
different operations. Usually, each person has a specific way of working in the interface and prefer particular 
views and toolbars. In this chapter, you will learn about the main elements of the interface and how to manage 
them.

NOTE 

To learn more about each view's properties, see the Reference guide.
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

 1. In the top menu, select Edit > Preferences (Windows) or Harmony Essentials > Preferences 
(macOS) .

The Preferences dialog box opens.

 2. In the General tab, in the Options section, uncheck the Use Dark StyleSheet (Requires Relaunch) 
check box.

 3. Click OK.

 4. Close and relaunch Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. 

By default, Harmony will automatically launch in your operating system language if it is one of the supported 
languages. Otherwise, it will launch in English. 

There are two ways of controlling the language in which Harmony launches:

 l By changing the Language preference in the Preferences dialog.

 l By launching Harmony from a command line, with the -lang parameter followed by a two-letters 
language code.

How to change the user interface language for Harmony

 1. In the top menu, select Edit > Preferences (Windows) or Harmony Essentials > Preferences 
(macOS) .

The Preferences dialog box opens.

 1. In the General tab, in the Language section, open the Language (Requires Relaunch) drop-down 
and select the desired user interface language.

 2. Click OK. 

 3. Close and relaunch Harmony.

How to start Harmony in a specific user interface language from the command line

 1. Open a Command Prompt or Terminal window.
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 2. Type in the following command, including the quotation marks, but don't press Enter/Return yet. 

 l Windows: "C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony 17 Essentials\win64\bin\HarmonyEssentials.exe"

 l macOS: "/Applications/Toon Boom Harmony 17 Essentials/Harmony 
Essentials.app/Contents/MacOS/Harmony Essentials"

 3. Type a space, then type the following parameter depending on which language you want to launch 
Harmony in:

 l English:  -lang en

 l Chinese: -lang zh

 l Japanese: -lang ja

 l Spanish: -lang es

 4. Press Enter/Return.

Harmony will launch in the specified language.
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About Menus
T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, 
some commands are available and others are not. The top menu is always located at the very top of the 
interface.

The top menu contains the following categories:

 l File

 l Edit

 l View

 l Play

 l Insert

 l Scene

 l Drawing

 l Animation

 l Windows

 l Help

On macOS, there is also a Harmony Essentials category that contains the following commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.
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To access a  view menu, click the Menu  button in the top-left corner of a view.

A view menu is available in the following views:

 l Colour

 l Function

 l Library

 l Script Editor

Quick Access Menu

A quick access menu lets you open a list of the commands you will use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also 
have their own toolbars which you can move around. You can reposition the toolbars to suit your work style or 
hide unused ones.

NOTE 

Throughout this section, there may be slight differences between your interface and the 
illustrations in this guide. This is because the images are taken from Harmony Premium.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the 
views that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu 
updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a 
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move 
from the top area to the view.

The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog 
box, you can organize different toolbars to suit your working style.

If the default toolbar does not contain the tools you require, you can customize the toolbar.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to expand 
the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to close 
Harmony and restart it for the new interface to be displayed.   A default set of tools will appear in the toolbar. 
However, you can customize the toolbar with the tools that more closely fit your work pattern. 

Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means 
that you can change the default set of tools and replace the tools you use less frequently with ones use more 
often. This customizing is done through the Toolbar Manager.
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Adding Toolbars
T-HFND-003-004

You can add toolbars simply by using menus.

How to add or close a toolbar

 1. Select Windows > Toolbars > toolbar.

 l You can right-click anywhere in the toolbar area to access Harmony toolbars. View 
toolbars, however, are not available by right-clicking the toolbar area. You can access 
the toolbar of any open and active view by right-clicking in the view's top area or the 
Windows menu. 
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Moving Toolbars
T-HFND-003-005

You can move toolbars simply by dragging them to a new location.

How to move a toolbar

 1. Select the toolbar you want to move by clicking its anchor point  and dragging it into a view toolbar 
area or another position in the top or side interface toolbar area.

 2. When a highlighted zone appears showing an available location for the toolbar, release the mouse 
button and drop the toolbar into position.
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Resizing Toolbars
T-HFND-003-006

You can resize a toolbar by sliding its tail-end.

How to resize a toolbar

 1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end. 

 2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.

55



Customizing View Toolbars
T-HFND-003-007

You can customize a view toolbar to add, remove, and reorder icons.

How to customize a view toolbar

 1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a 
new button. You can also reorder the buttons. Make sure the button you right-click on is active.

 2. From the menu, select Customize.

The Toolbar Manager window opens.

 3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click 
the Right Arrow   button to switch it to the Toolbar list.
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 4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left 
Arrow   button to switch to the Available Tools list.

 5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click 
the Up  or Down  buttons to move it to the correct location.

 6. Click OK when you are finished.
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About Views
T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a 
view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing 
or other type of selection or the option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application, unless you disable the 
Automatically Save Workspace option in the Preferences dialog box.
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Adding Views
T-HFND-003-009

You can easily add views through the top menu or each view.

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the  Add View  button 

 2. Select the desired view from the list.

The view appears as a new tab, in the section of your workspace where you added it.
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NOTE 

Some views, such as the Camera view, can be opened in multiple instances. For example, this 
can be useful if you want to have two instances of the Camera views open, each focused on 
different areas of your scene, to quickly switch between working on these two areas. 

How to add a view to your workspace                                    as a window                 

 1. Open the Windows menu.                     

 2. In the Windows menu, select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

 1. Click and drag the floating view by its tab and do one of the following:

 l Drop the window over another tab to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the 
edge of a view, a cyan rectangle appears, indicating where the view will be docked.
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NOTE 

The view in which you are currently working will have a red square surrounding it, marking is as 
your active view.
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Closing Views
T-HFND-003-010

You can close one or multiple views by using their closing button.

How to close a view

 1. Click the Close View  button.

If there are several tabs in the same view, press Shift and click the Close View  button to close all 
tabs at the same time.
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Showing and Hiding Views
T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the window you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011

You can move views by dragging their name tab to a new location.

How to move views

 1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s 
tab.

 2. When a blue rectangle outline appears showing an available location for the view, release the tab to 
drop the view into position. One of three things will happen:

 l The view becomes a tabbed view.

 l The view becomes a floating window.

 l The view becomes a new docked view.
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Resizing Views
T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. When you see the Resizing  icon, drag the side of the view to the desired size.
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About Preferences
An important feature of Toon Boom Harmony Essentials is the Preferences dialog box. From here you can 
customize the behaviour of various user interface elements, as well as drawing and animation tools, and enable 
or disable advanced features.

NOTE 

For a list of all the preferences as well as their functionality, refer to the Preferences guide.

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows:

 l In the top menu, select Edit > Preferences.

 l Press Ctrl + U.

 l macOS:

 l In the top menu, select Harmony Essentials > Preferences.

 l Press ⌘  + U.
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About Keyboard Shortcuts 
Harmony uses keyboard shortcuts to allow you to quickly use commands you are familiar with without having to 
browse through menus and toolbars. Learning the keyboard shortcuts for the commands you use the most 
often can be a great way to increase your productivity with Harmony. 

Using the Keyboard Shortcuts dialog, you can: check which keyboard shortcuts are assigned to which 
commands, you can customize existing keyboard shortcuts, and you can assign keyboard shortcuts to 
commands that don't have any.

NOTE 

For more information on how to configure keyboard shortcuts as well as a list of commands and 
their default keyboard shortcuts, refer to the Keyboard Shortcuts guide.

How to open the Keyboard Shortcuts dialog box

 1. Do one of the following:

 l Windows: In the top menu, select Edit > Keyboard Shortcuts.

 l macOS: In the top menu, select Harmony Essentials > Keyboard Shortcuts.
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About Workspaces
T-HFND-003-014

The Harmony interface is composed of several views. You can customize your workspace to suit your working 
style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the 
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can 
access these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your 
workspaces as they are and only save the modifications when you really want to, you must disable the 
Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can 
save your workspace as a new version to avoid over-writing the current one. If you do not want to modify the 
current workspace, use the Workspace Manager to create another one and then modify that one.

Your customized preferences are stored in the following location and you can save them to either share with 
someone else, copy to a second computer or simply back them up.

Your workspaces are stored in the following location:

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon Boom 
Harmony Essentials\1700-layouts-xml

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon Boom 
Harmony Essentials/1700-layouts-xml
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Loading Workspaces
T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the following:

 l Select Windows > Workspace > Workspace.

 l Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016

You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.
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 5. Select the new workspace and click the Right Arrow  button to move it to the Workspace 
toolbar.

 6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit 
the name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving Workspaces
T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save Workspace preference

 1. From the top menu, select Edit > Preferences (Windows) or Harmony Essentials > Preferences 
(macOS) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save Workspace option.

 4. Click OK. 

The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

 1. Do one of the following:

 l In the Workspace toolbar, click the Save Workspace   button. 

 l You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   button 
to move it to the Available Workspaces list.

 3. Select the workspace from the Available Workspaces list, then click the Delete  button to delete 
the workspace.

 4. Click OK.

74

Harmony 17 Essentials User Guide                          



Chapter 2: User Interface

Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow   
button to move it to the Workspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button 
to move it to the Available Workspaces list.

 3. Click OK. 
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  
buttons to move it up or down.

 3. Click OK. 
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Restoring the Default Workspace
T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select Windows > Restore Default Workspace.
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About Interface Navigation
Toon Boom Harmony Essentials lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of 
the interface.

The navigation commands in the table below can be used in the following views, with some exceptions:

 l Camera

 l Drawing

 l Timeline

 l Xsheet

 l Function

 l Side and Top

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the 
Timeline and Xsheet views)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down (except in 
the Timeline and Xsheet views)

Zoom In or Out Zooms in or out of the view.

Roll the middle mouse button up or 
down.

Hold down the Spacebar and the 
middle mouse button while dragging 
the mouse up or down.

Pan Moves the view horizontally or vertically.
Hold down the Spacebar and drag in 
the direction you want to pan the view.

Reset Pan Resets the view’s pan to its default position.
View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position. View > Reset View
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Command Action Access Methods

Press Shift + M

Reset Rotation
Resets the view’s rotation to its default 
position.

View > Reset Rotation

Press Shift + X

Reset Zoom Resets the view’s zoom to its default position. View > Reset Zoom

Rotate View Rotates the view.

While holding Ctrl + Alt 
(Windows/Linux) or Ctrl + ⌘  (macOS), 
click and drag the rotating disc to rotate 
it clockwise or counterclockwise.

Rotate 30 CW
Rotates the Camera view 30 degrees 
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW
Rotates the Camera view 30 degrees counter-
clockwise, like an animation table.

View > Rotate View CCW

Mirror View
Temporarily flips the Camera or Drawing view 
horizontally, allowing you to view and edit 
your artwork as if it was being mirrored.

View > Mirror View

In the Camera or Drawing toolbar, click 
on the  Mirror View button.

Toggle Quick 
Close-up

Instantly multiplies the view's Zoom Factor by 
4. For example, if the Camera View's Zoom 
Factor is at 100%, this will make it toggle 
between 400% and 100%. 

Shift + Z

Toggle Full Screen

Cycles through the following display modes:

 l Normal Full-Screen: The main 
application window becomes full 
screen.

 l View Full-Screen: The selected view 
becomes full screen and all other 
views are collapsed.

 l Normal: The main application window 
is restored to its original size and 
collapsed views are expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  + 
F (macOS)
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TIP 

Keyboard shortcuts can be customized. To change your keyboard shortcuts, in the top menu, select 
Edit (Windows) or Harmony Essentials (macOS) > Keyboard Shortcuts.

Using the Play Menu to Navigate

From the top menu, you can select any of the following commands from the Play menu to navigate around the 
interface.

Command Description

Start Frame Lets you set the frame on which playback will start.

End Frame Lets you set the frame on which playback will end.

First Frame Jump to the first frame. You can also press <.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline view.  You 
can also press the comma (,) key.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. You can 
also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Go to Frame

Opens the Go to Frame window in which you can enter the number of the frame 
you want to display. 

You can also use the Go button, which you can add to the Timeline toolbar 
through the Toolbar Manager. Open the Go to Frame dialog box and enter the 
frame number to jump to.

Enable Playback Plays back your animation from the Top or Side views.
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony. 
The documentation of features and procedures exists online, but you can access it through the software.

A simple, but fast way to find a description of certain menu items and preferences is through the Integrated 
Help.
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Accessing the Documentation
T-HFND-001-004

The Harmony documentation can be accessed from the Help menu.

How to access the Harmony Essentials documentation

 1. From the top menu, select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in 
the Preferences panel, use the Integrated Help.

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through a history of the help information that you called up during your 
session.

How to use the Integrated Help with Menu Items

 1. In the top menu, go to Help > Show What's This or press F1 on Windows or ⌘  + / on macOS.

The Integrated Help window appears.

 2. In the top menu, click on a menu heading to display its contents.

 3. Use your mouse to hover over a menu item.

 4. Press  F1 on Windows or ⌘  + / on macOS.

In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences

 1. In the top menu, go to Help > Show What's This or press F1 on Windows or ⌘  + / on macOS.

The Integrated Help window appears.

 2. In the top menu, go to Edit > Preferences (Windows) or Harmony > Preferences (macOS).

The Preferences window appears.

 3. In the Preferences window, use your mouse to hover over a preference.

 4. Press  F1 on Windows or ⌘  + / on macOS.

In the Integrated Help window, a description of the preference appears.
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How to scroll through the bank of searched items

 l In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE 

The moment you close the Integrated Help window all searched items will be erased from the 
memory bank. In order to keep an on-going record of all the search requests made, you must keep 
the window open.
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Chapter 3: Layers and Columns
T-RIG-009-003

Before filling in any values or setting any timing or exposure, you need to create drawing elements. Each 
drawing element is represented as a vertical column in the Xsheet view and a horizontal layer in the Timeline 
view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will be 
applied to both.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named 
the same way as the drawing element and is in fact, linked to the drawing element. Its purpose is to contain all 
the drawings related to this element (layer, column). For example, in cut-out animation, a character can have 
many heads available. All of the head drawings will be contained in this folder, even if they are not exposed in 
the Timeline or the Xsheet view.

Drawings are exposed in cells/frames and linked to the drawings saved in the layer's directory. When you 
remove a drawing from a cell/frame, it is not displayed, but still exists in the directory.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all exposures of drawing “1” are updated 
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the 
drawing.

NOTE 

There are different element types available, such as sound and expression. A sound element 
contains sound files. Expressions, Beziers, 3D path, Quadmaps and Pegs are for motion purposes 
during the compositing step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu. 
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Layer and Column Types
A column is also known as a layer. There are several types of layers you can add in the Timeline and Xsheet 
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently 
in the Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. 

 

Any time you need to create a vector drawing or import a symbol or image, you can use a drawing layer. You 
can also create bitmap artwork on a drawing layer.

Bitmap Layer
If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you 
choose to vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a 
bitmap into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer
You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when 
you create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE 

If you want to have several cameras with different settings, you can keep adding Camera layers in 
your Timeline view (however, only one will ever be visible at a time as you can only have one camera 
at a time in your timeline). To switch to a different camera, select Scene > Camera and select 
another camera layer.

Effect Layer
To enhance the look of your scene, you can add effect layers and attach your drawings to them.
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When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the 
Functions section of the  Xsheet view.

Colour-Card Layer
The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no 
background colour and if you render it as a QuickTime movie or image sequence, it will have a black 
background.

This layer is not visible in the Xsheet view.

Group Layer
A Group layer can be used to organize the Timeline view. 

You can drag and drop other layers onto a Group layer and then collapse the Group layer to hide these other 
layers from view. 

Peg Layer
A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any 
drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  Functions 
section of the Xsheet view.

Quadmap Layer
A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This 
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the 
deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the 
Functions section of the Xsheet view.

Sound Layer
You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your 
Timeline and Xsheet view when you import a sound file in your scene.
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In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types
In the Xsheet view, you can add several advanced column types to create particular animation paths. When 
you create these columns, they are not linked automatically to any particular drawing layer. You can create a 
motion path using these columns and then link or unlink several drawing or peg layers to it. 

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression 

• Annotation
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Adding Layers and Columns
T-HFND-005-002

There are different ways to add a drawing elements (layers and columns) to your project. By default, when you 
create a new scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in 
the Timeline view.

When you add an element, it will appear as a column in the Xsheet view,  a layer in the Timeline view. 
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Adding Layers in the Timeline View
T-LAY-001-007

Drawing elements are more commonly known as layers in the Timeline view. Create them using the following 
procedure:

How to add a drawing element from the Timeline view

 1. Do one of the following:

 l In the Timeline view, click the  Add Drawing Layer  button.

 l In the top menu, select Insert > Drawing.

 l Press Ctrl + R (Windows/Linux) or ⌘  + R (macOS).

The Add Drawing Layer dialog appears.

 2. In the Name field, type in the name for your new layer. 

 3. Do one of the following:

 l Click Add to create this layer, but leave the dialog open so you can create more layers.

 l Click Add and Close to create this layer and close the dialog. 

A new drawing layer is added to the Timeline view.
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Adding Columns from the Xsheet View
Drawing elements in the Xsheet view are more commonly known as columns. You can add columns using the 
following procedure:

How to add a drawing element from the Xsheet view

 1. Do one of the following:

 l In the Xsheet menu, select Columns > Add Columns. 

 l Click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a relevant element name.

 3. In the Type field, select Drawing. 

 4. To complete the operation:

 l Click Add and Close to add your new layers and close the dialog box.

 l Click Add to add your new layers and keep the dialog box open to add column.

 l Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column 
Types on page 88.
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Using the Advanced Add Column Dialog Box
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Deleting Layers and Columns
T-HFND-005-004

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

NOTE 

You can select several contiguous layers by holding down the Shift key, clicking on the 
first layer you want to select, then on the last layer you want to select. You can also 
select several layers by holding the Ctrl (Windows/Linux) or ⌘  (macOS) key and 
clicking on each layer you want to select. 

 2. Do one of the following:

 l In the Timeline’s Layer toolbar, click the Delete Layers button. 

 l Right-click on the selection and select Delete.

The selected layers are removed from the Timeline view.

How to delete columns in the Xsheet view

 1. In the Xsheet view, select the columns to be deleted by clicking on their header.
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 2. Do one of the following

 l Right-click on the selection and select Delete Columns. 

 l In the Xsheet toolbar, click the Delete Columns  button.

 l Press Del.

The Confirm Delete dialog box opens.

 3. To complete the operation:

 l Click OK to delete the selected layers.

 l Click Cancel to cancel the operation.
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Renaming Layers and Columns
T-LAY-001-008

Once you add layers and columns to your project, you can modify their names.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

A text-input field appears over the name.

 2. Type in the new name for your layer and press Enter/Return.

The layer now has the new name.

How to rename a layer in the Layer Properties editor

 1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

 2. In the Name field, rename the layer.

 3. Click Close.
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Reordering  Layers and Columns
You can change the order of your elements in the Timeline view and Xsheet view. When you change the order 
of your elements in one view, the other one is updated.

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.

 2. Click and drag the selection, then do one of the following:

 l Drop the selection between two layers to move it between those layers. A cyan line will 
appear between the layers where the selection will be moved.

 l Drop the selection onto a layer to rig the selected layers as children over that layer. 

How to reorder columns in the Xsheet view

 1. In the Xsheet view, click on the column’s header with the middle mouse button.

 2. Drag the column to its new position.
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Enabling and Disabling Layers
T-HFND-005-010

You can disable layers so that they do not appear in the rendered image or in the Camera view. This can have 
many purposes:

 l If you used a layer to sketch rough animation or drawings, ideas or designs, you can disable the layer 
permanently once you're done using it as a reference, without deleting the layer.

 l If a specific layer, such as an overlay, character or prop, is in the way of the layer you're working on, you 
can disable it temporarily to de-clutter the Camera view. 

Disabling a layer also hides it from the rendered image. Hence, if you want to hide a layer temporarily, you must 
re-enable it before rendering your scene. 

Likewise, it is also possible to disable peg layers, which makes the peg's child layers unaffected by the peg's 
transformations. You can also disable effect layers to disable their effect. 

How to show or hide all layers

 1. In the layers toolbar, click on the  Enable/Disable All button to enable or disable all layers.

How to show or hide individual layers

 1. Do one of the following:

 l Click the layer's  Enable/Disable button to show or hide that layer. 

 l Press A to show selected layers or D to hide selected layers.

 l Right-click on the selected layer and select Enable > Enable/Disable. 

How to enable the selected layer and disable all others

 1. Right click on the selected layer and select Enable > Disable All Others.
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Enabling or Disabling Solo Mode on a Layer
Solo Mode allows you to instantly and temporarily hide all layers except for the layer or layers you're currently 
working on. Solo Mode can be enabled on one or several layers, and works with the following logic:

 l If Solo Mode is not enabled on any layer, then all enabled layers are visible.

 l If Solo Mode is enabled on a single layer, then only this layer is visible and all others are hidden.

 l If Solo Mode is enabled on several layers, then only these layers are visible and all others are hidden.

While disabling a layer makes it invisible in the rendered image, enabling Solo Mode only affects the preview 
image in the Camera view. 

NOTES 

 l If Solo Mode is enabled on a disabled layer, this layer will not be visible in the Camera view. 

 l If a drawing layer is connected to an inverted Cutter effect, you must enable Solo Mode on both 
the drawing layer and the Cutter effect for them to be visible. 

How to enable or disable Solo Mode on a layer

 1. In the Timeline view, click on the  Solo Mode button left of each layer that you want to make 
visible in the Camera view.

 2. To disable Solo Mode on a layer, click on its  Solo Mode button again.

If you have Solo Mode enabled on many layers and you want to quickly go back to only seeing one layer, you 
can quickly disable Solo Mode on all but one layers, and enable Solo Mode on that layer.

How to enable Solo Mode on a layer and disable it on all other layers

 1. While holding the Alt key, click on the  Solo Mode button of the only layer that you want to make 
visible in the Camera view.

If you want to quickly turn off Solo Mode for all layers it has been enabled on, you can do so by clicking on the 
Toggle solo mode on or off button in the Layers toolbar of the Timeline View.

How to toggle Solo Mode off for all layers

 1. In the Layers toolbar of the Timeline view, click on the  Toggle solo mode on or off button to 
disable Solo Mode on all layers.

 2. When you want to enable Solo Mode again, you can do one of the following:
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 l To instantly enable Solo Mode again on all the layers on which it was previously enabled, click 
on the  Toggle solo mode on or off button again.

 l To only enable Solo Mode again on a single specific layer, click on the  Solo Mode button 
for that layer.
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Locking and Unlocking Layers
You can prevent modifications to a layer by locking in it. While a layer is locked, you cannot select it, manipulate 
it, draw in it, or change its timing in the Timeline view. 

Locking a layer is especially useful if you want to avoid selecting it in the Camera view. Clicking on a locked 
drawing with the Transform tool in the Camera view will select whichever drawing is behind it, if there is any. 
This can help ensure that backgrounds and, more importantly, foreground elements, remain in place once they 
have been properly positioned.

NOTE 

When a layer is locked, you can still make changes to its timing in the Xsheet view.

How to lock a layer or a selection of layers

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock. 

 l Click one of the selected layer’s Lock  icon. 

 l Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (macOS).

All selected layers are locked. 
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How to unlock a locked layer or a selection of locked layers

 1. In the Timeline view, select one or more locked layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Unlock. 

 l Click a selected layer’s Lock  icon. 

 l Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (macOS). 

All selected layers are unlocked.

How to lock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Lock All. 

 l In the Timeline view, select all layers and click Lock  icon of a selected layer. 

 l Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (macOS).

All layers are locked.
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How to unlock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Unlock All. 

 l In the Timeline view, select all layers (locked) and click Lock icon of a selected layer. 

 l Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (macOS). 

All layers are unlocked.

How to lock all other layers

 1. In the Timeline view, select the layers you do not want to lock.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock All Others. 
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 l Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (macOS). 

All layers are locked except the selected ones.

How to display locked drawings as outline

 1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings  option.

 2. You can also set this option as a permanent preference. From the top menu, select Edit > 
Preferences (Windows) or Harmony Essentials > Preferences (macOS).

 3. In the Preferences dialog box, select the Camera tab.

 4. In the Tools section, select the Show Locked Drawings As Outlines option.
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Navigating Layers and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and 
layers. Displays the previous drawing, next drawing, previous layer or next layer. using keyboard shortcuts that 
work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames

• Columns

How to navigate through drawings, frames and columns

 1. In the Timeline or Xsheet view, select a cell.

 2. Once the cell is selected, you can navigate between:

 l Previous and next layers: From the top menu, select Drawing > Previous Layer and 
Next Layer or press H and J.

 l Previous and next drawings: From the top menu, select Drawing > Previous Drawing 
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and Next Drawing or press F and G..

 l Previous and next frames: From the top menu, select Play > Previous Frame and Next 
Frame or press comma (,) and period (.).
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About Clone and Duplicate Layers 
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You 
can do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone 
uses the same drawings for all layers. A duplicated layer is simply an independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, you 
should clone your layer. If you simply want to copy your layers and be able to modify your drawings without 
affecting the original layer, use the duplicate option.
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About Clone Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, 
both will be updated. However, cloned layers can have different timings.

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or 
only the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element 
folder, as well as the same drawing and function columns. Therefore, if you change the drawing exposure or 
keyframe on one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the 
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a 
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing 
exposures to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will 
create a heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same 
timing (function and exposure columns). 
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Cloning Layers

You can clone layers in several ways. Cloned layers use the same drawings.

How to clone a layer

 1. In the Timeline view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

 l From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and 
Timing.

 l In the Timeline view, right-click on the layers and select Clone Selected Layers: 
Drawings Only or Clone Selected Layers: Drawings and Timing.

The cloned layer appears. 
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About Duplicate Layers
T-HFND-006-013

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as 
an independent timing (exposure). When you need the drawings to be modified independently, you will want 
to duplicate the layer instead of cloning it.
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Duplicating Layers

T-HFND-006-014

You can easily duplicate layers. Once duplicated, the layers are completely independent. Drawings are also 
duplicated.

How to duplicate a layer

 1. In the Timeline view, select one or more layers.

 2. Do one of the following:

 l In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

 l From the top menu, select Edit > Duplicate.

The duplicated layer appears.
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About Groups
When working with complex rigs, you may want to group layers together to avoid cluttering the Timeline view 
and keep your layers organized.

Groups can also be useful if you need to apply the same effect to several layers at once. For example, if 
transparency is applied to each individual layer making a character rig, the seams between its body parts will 
become visible. Instead, if you group all of the rig's layers together, then add a Transparency effect to the 
group, Harmony will compose the layers inside the group into a single image before applying the effect.
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Grouping Layers
You can group layers to keep your Timeline view organized.

How to group layers in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

NOTE 

Any layer between the selected layers will be grouped with the selected layers. 

 2. Do one of the following: 

 l Right-click on the highlighted layers and select Group Selection.

 l Press Ctrl +Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS). 

A new Group layer is added to the Timeline view.

If you click on the  Expand Group button, you will find the grouped layers rigged as children of 
the group layer. 
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Ungrouping Layers
If needed you can ungroup layers you have previously grouped together.

How to ungroup layers in the Timeline view

 1. In the Timeline view, select the group you want to ungroup.

 2. Right-click on the group and select Ungroup. 

All the group's layers will be placed outside of the group, and the group will be removed. 
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Displaying Layer and Column Properties
Each element has its own set of properties that you can modify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline 
view. If you're working with the Xsheet, you can display its properties as well. You can display a layer's 
properties as a window or as a view of its own.

The Layer Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

 l Lock the layer

 l Change the track colour

The Column Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

How to display a layer's properties

 1. Do one of the following:

 l In the Layer Properties view is not part of your workspace, from the top menu, select 
Windows > Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

The properties display—see Element/Drawing Node in the Reference guide .
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About Layer and Column Display
You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline 
view or a column in the Xsheet view displays. You can stay organized without changing the content of 
elements or your animation output.
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Expanding and Collapsing Layers and Columns
To simplify the look of the Timeline or Xsheet view, you can expand and collapse some of the layers and 
columns. If layers are parented to other ones, you can collapse the parent layer to hide its children.   

How to collapse or expand selected layers in the Timeline view

 1. In the Timeline view, select the layer(s) to collapse or expand.

 2. Do one of the following:

 l Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

 l Click the Expand Children  button on the parent layer.

 l Click the Collapse/Expand  button  (you may have to customize the toolbar to 
display it).

 l Press  Ctrl + I (Windows/Linux) or ⌘  + I (macOS).

How to collapse or expand all layers in the Timeline view

 1. Do one of the following:

 l Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

 l In the Timeline toolbar, click the Collapse All  or Expand All  buttons (you may 
have to customize the toolbar to display them).

 l Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button to display the Functions list.

 2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or 
expand.

 3. Do one of the following:

 l Right-click on the column’s header and select Expand/Collapse > Collapse Selection 

119



or Expand Selection.

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:

 l Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

 l Press 0 and 9.
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Showing and Hiding Layers and Columns
As you work in the Drawing, Camera or Xsheet view, some layers or columns may be in the way, such as those 
that were used as references. You can hide these layers to make your work area less cluttered and easier to 
navigate.
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Showing and Hiding Columns

The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can 
be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without 
using the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is 
disabled in the Timeline view.

How to show and hide columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button.

 2. On the right side of the Functions section, click the Expand  button to display the Column List 
section.

 3. Do one of the following:

 l In the Column List section, select the columns to display and deselect the columns to 
hide. 

 l In the Xsheet toolbar, click the Hide Selected Column  button (you may have to 
customize the toolbar to display it).
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Showing Hidden Columns

In order to save visual space in the Xsheet view, columns can be hidden from view. The hidden layer's presence 
is indicated by a thicker grey line between columns.

How to show hidden columns in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Click the thick grey line that represents a hidden column. 

 l Right-click on the column header and select Show Hidden Columns.

 l Press Alt + Shift + H.

The Show Hidden Columns dialog box opens.

 2. In the Show column, select the hidden columns you want to display in the Xsheet view.

 l Click Check to select all the selected columns.

 l Click Uncheck to deselect all selected columns.
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Showing and Hiding Column Types

You can hide specific column types from view, in order to work more easily with one aspect of your project. For 
example, you could hide all the Drawing columns in the Xsheet, so that you could work more easily with your 3D 
Path Columns. 

How to show and hide column types using the Column List

 1. In the Column List section, click the button corresponding to the column type you want to show or 
hide.

Column Type Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns
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Displaying Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular 
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of 
the current frame below the column header.

NOTE 

To display thumbnails in the Timeline view, see Displaying Drawing Thumbnails in the Timeline 
View.

How to display the thumbnails

 1. In the Xsheet toolbar, click the Show Thumbnails  button.

The thumbnails row appear appear underneath the column names.
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Changing Layer and Column Colours
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. 

How to change the layer’s colour in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

 2. In the Select Colour dialog box, select a new colour for your layer.

 3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, 
selected colour for easy identification. The corresponding column colour is also updated in the 
Xsheet.

How to reset a layer’s colour in the Timeline view

 1. In the Timeline view, select the layers to reset.

 2. In the Timeline toolbar, click the Default Track Colour  button (you may have to customize the 
toolbar to display it).
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How to change a column’s colour in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

 3. In the Select Colour dialog box, select a new colour for your columns.

 4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

 1. In the Xsheet view, select the columns to reset.

 2. Right-click on the column’s header and select Colour > Default Columns Colour.
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Chapter 4: Timing
When you create hand-drawn animation traditionally or in a paperless environment, it's important to know 
how to set and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure 
sheet created by the animator. In a paperless workflow, the animator creates and manages their own exposure 
sheet directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital 
animator, you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn 
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using. 
Depending on your working style, some actions may seem preferable to do in one view instead of another. 
Many of the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often 
show both techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation 
paths for symbols are covered in separate chapters.

NOTE 

The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters 
and parts, but is not really needed for animation and timing. If you plan to work with cut-out 
animation, you can still learn useful tips by reviewing the section on exposure sheets.
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About Scene Length
In Harmony, the length of each scene is determined by the amount of frames it contains. You can calculate the 
amount of frames your scene requires based on the amount of time it should span over with the formula, in 
which l is the scene's length, s is the amount of seconds your scene requires, and fps is the scene's frame rate. 

l = s × fps

Likewise, a scene's length in seconds can be calculated with the reverse formula:

s = l ÷ fps

By default, scenes created in Harmony are 60 frames in length. At 24 frames per second, this makes a scene of 
2½ seconds in length. You should set your scene's length based on how much time you plan for it to require 
after creating your scene so you can plan your animation based on the scene's length. However, it is possible to 
adjust your scene's length at any time. You can also insert or remove frames at any point in your scene.
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Setting the Scene Length
T-HFND-007-007

You can set the scene length by entering its exact amount of frames or by adjusting its length using the scene 
length bracket in the Timeline view. 

How to set the scene's length in frames

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.

How to modify the scene length in the Timeline view

 1. In the ruler of the Timeline view, click and drag the red scene length bracket  and move it to the left 
to shorten the scene or to the right to extend the scene.
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Adding Frames in the Middle of a Scene
You can add frames to your scene before or after the currently selected frame(s). All of your scene's animation 
before or after the selection will be offset by the amount of frames you added.

How to add frames to the middle of a scene

 1. In the Timeline or Xsheet view, select a frame or a range of frames.  

 2. Do one of the following:

 l From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames 
After Selection. 

 l In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.

 l In the Xsheet toolbar, click the Add Frames  button to add frame after your selection. 

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (macOS) to add frames before the selection, or Ctrl 
+ H to add frames after the selection.

The Add Frames dialog box opens.

 3. In the Number of Frames to Add field, enter the amount of frames to add to the scene.

 4. Click OK.
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Adding Frames at the Beginning of a Scene
You can add frames at the beginning of your scene using the Add Frames at Start dialog. All of your scene's 
animation will be offset by the amount of frames you added.

How to add frames at the start or end of a scene

 1. In the top menu, select Scene > Frames > Add Frames at Start.

The Add Frames dialog box opens.

 2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 3. Click OK.
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Adding Frames at the End of a Scene
You can add a set amount of frames at the end of your scene using the Add Frames at End dialog.

NOTE 

You can also extend your scene's length by entering its total length or by manipulating the scene 
length bracket in the Timeline view—see Setting the Scene Length on page 131.

How to add frames at the start or end of a scene

 1. In the top menu, select Scene > Frames > Add Frames at End.

The Add Frames dialog box opens.

 2. In the Number of Frames to Add field, enter the number of frames to add to the scene.

 3. Click OK.
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Removing Frames from a Scene
It is possible to remove frames from your scene. Your scene will be shortened by the amount of selected frames, 
and all the animation after the selection will move back to close the gap. 

How to remove a frame or a range of frames  in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

 1. In the Xsheet view, do one of the following:

 l Select a frame in a given column.

 l Select a frame range by clicking the first frame’s number and then dragging the 
selection highlight down to the last frame to delete.

 

 2. To delete the selected frames, do one of the following: 

 l From the top menu, select Scene > Frame > Remove Selected Frames. 

 l Press Del to delete the selection. 

 l Click the Remove Frames  button. To remove several frame selections, click the 
button repeatedly.

If you selected a range of frames, the Warning dialog box may open.
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 3. To complete the operation:

 l Click Yes to delete the selection.

 l Click No to delete only the exposure in the cell and not the frames.

 l Select the Don’t Show This Message Again option to prevent the warning message 
from being displayed each time you delete a frame range.
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About Exposure
T-HFND-006-006

In Harmony, exposure is the term used for the link between a cell, which is a single frame in a drawing layer, 
and a drawing. 

This concept comes from traditional animation. When drawings were finished and ready to be added to the 
animation, they would be placed under a camera, and taking one snapshot of the drawing would equate to one 
exposure. Hence, exposure is an important concept for planning out the drawings required for your action, as 
well as the timing in which they will be displayed as your scene plays out. It is especially important when 
drawings are used several times in a scene, which is a common practice to save on production time and costs, as 
you can re-use a drawing by exposing it over multiple frames. 

In traditional animation, it is typical to plan a scene by filling the exposure sheet with the exposure before 
creating the animation. An exposure sheet is made of cells, which represent frames, spread across columns, 
representing drawing layers, and the exposure is planned by filling each cell with the identification numbers for 
the drawings you plan your scene's action to require. This allows animators to figure out the timing of their 
scene's actions and to allocate the amount of drawings each action will require before they start drawing, 
removing decision making from the animation process. 

In Harmony, you can achieve this process by using the Xsheet view, which is very similar to a traditional 
animation exposure sheet. You can fill each cell in your scene's drawing layers with the number of the drawings 
you plan to create, at the frames at which you intend to expose them, and set the exposure of each drawing to 
the amount of frames you intend them to take. 

Filling a cell with a drawing identifier allows Harmony to keep track of which frames should display which 
drawings. For example, if you fill cell 1 and 2 of the drawing layer A with the number 5, then start drawing in 
cell 1 or 2, Harmony will create the drawing A-5, which will display in layer A when at frame 1 or 2 of your 
scene. Otherwise, if you start drawing inside an empty cell, Harmony will automatically create a drawing and 
assign it an available drawing number.
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About Creating Exposure
In traditional and paperless animation, it is useful to plan your scene by creating its exposure before creating 
the drawings. The most basic method of creating a scene's exposure is by manually entering the name 
(typically a number) of each drawing in each cell of each column in your scene using the Xsheet view. However, 
Harmony has many tools allowing you to streamline the exposure filling process. If you plan to animate on twos 
or threes, Harmony can automatically expose each drawing added to your exposure sheet over the preferred 
amount of frames. You can also fill a range of cells with the same drawing, a number sequence, or a cycle. 
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Typing Exposures

T-HFND-006-007

To fill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section 
of the Timeline.

NOTE 

You can only use alphanumeric values (0 to 9, a to z) and the underscore (_) and dash (-).

How to type a value in the Timeline view

 1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing 
you want to create.

 2. Press Enter/Return to validate the value.

How to type a value in the Xsheet view

 1. In an Xsheet column, double-click on a cell.

 2. Type a value or drawing name in the cell.
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 3. Press Enter/Return to move to the next cell.

 4. Press Esc to exit the typing mode.
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Setting the Exposure Hold

Drawings in an animation project are often exposed for more than one frame to save on production costs. In 
western animation, each drawing is usually exposed on two frames, and in Japanese animation, each drawing is 
usually exposed on three frames. In both cases, exceptions can be made for quick or detailed actions that 
require precise timing. 

In the industry, this type of exposure is known as animation in double or triple frames, or animation on twos or 
on threes. 

To save time when creating your scene's exposure, you can configure the Xsheet to hold the exposure. This will 
make every new exposure you type into the Xsheet exposed for the preferred amount of frames. After you 
enter the exposure for a cell, the selected cell will be after this exposure's hold, allowing you to quickly fill a 
column with exposure while respecting the selected hold. 

How to hold an exposure

 1. Do one of the following:

 l From the top menu, select Animation > Cell > Hold Exposure > Hold the desired amount of 
cells.

 l Right-click on the Xsheet and select Exposure > Hold Exposure > Hold the desired amount 
of cells.

 2. Type a value or drawing name in the cell.

 3. Type a value or drawing name in the cell.

 l Press Enter/Return to move on to the next cell.

 l Press Esc to quit the typing mode.
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Toggling Between Inserting and Overwriting Exposure        

T-HFND-006-007

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes 
control the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites 
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence 
over existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed 
down the column.

How to switch between the Overwrite and Insert modes

 1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.
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Filling a Selection with a Specific Exposure

You can fill a selection with the same drawing using the Fill Selection dialog box. You can fill a selection of a 
single drawing, several drawings or even several columns. 

How to fill a selection with a specific exposure

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Fill Selection. 

 l Press Ctrl + T (Windows/Linux) or ⌘  + T (macOS)).

The Fill Selection dialog box opens.

 3. In the Value field, type the desired value.

 4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key 
Exposure After option. Otherwise, leave it deselected.

 5. Click OK.
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Creating an Exposure Sequence

You can quickly create a sequence with a gesture by holding the Shift key while extending an exposure, or use 
the Sequence Fill dialog box to create a custom sequence within your selection. While the former is faster, the 
latter allows you to determine your sequence's hold and increment, to create a backward sequence or to 
configure it in multiple other ways. 

How to extend an exposure to create a sequence

 1. In the Xsheet view, select a cell containing a number.

 2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

 3. Hold down the Shift key. Make sure a plus sign (+) appears.

 4. Pull down the selection box to the desired frame.

NOTE 

The red selection box must be visible when releasing the cursor. If not, the action is 
considered cancelled.

 5. First release the Shift key, then release the mouse button.
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How to fill a selection with a sequence

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l From the top menu, select Animation > Cell > Sequence Fill. 

 l In the Timeline view, right-click and select Exposure > Sequence Fill.

 l Press Ctrl + M (Windows/Linux) or ⌘  + M (macOS)).

The Sequence Fill dialog box opens.

 3. In the Starting Value field, type the first number in the sequence.

 4. In the Increment field, type the number by which the drawing number will increase from frame to 
frame. For example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; 
and -2 gives you this: 8-6-4-2.
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Creating an Exposure Cycle 

T-HFND-006-008

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways. 
This can be useful for example if you want to make or use a looping character's walking animation, referred to as 
a walk cycle.

When you create cycle, each instance of each cycled drawing is linked to the same drawing file. This means 
that if you change a drawing for the first instance of the cycle, it will update for every other instance of the 
cycle. 

How to  create a cycle

 1. In the Timeline view, select the cell range to loop.

 2. In the Timeline toolbar, click the Create Cycle  button (you may have to customize the toolbar to 
display it).

The Create Cycle dialog box opens.

 3. Enter the number of cycles you want, including the current selection.
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Inserting Blank Cells

You can place an empty cell between other cells. 

NOTE 

Inserting a blank cell never overwrites existing cells, even if the Xsheet view is set to Overwrite 
mode. This is because overwriting existing cells with blank cells would replicate the behavior of 
deleting exposure.

How to insert a blank cell

 1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

 2. Do one of the following:

 l In the top menu, select Animation > Cell > Insert Blank Cell. 

 l Right-click and select Exposure > Insert Blank Cell.

 l In the Timeline or Xsheet toolbar, click the Insert Blank Cell  button. Note that you may 
have to add this button to your toolbar by right-clicking on it and selecting Customize.

 l Press Shift + J.

A blank cell is inserted.
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Filling Empty Cells

T-LAY-002-005

You can automatically fill gaps between exposures using the Fill Empty Cells command. This will extend the 
exposure of cell exposed right before the gap until the end of the gap. 

How to fill empty cells

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Right-click and select Exposure > Fill Empty Cells.

 l From the top menu, select Animation > Cell > Fill Empty Cells.

 l In the Timeline toolbar, click the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.
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Toggling Extending Previous Drawing Exposure

T-HFND-006-005

With the Extend Exposure of Previous Drawing preference enabled, you can configure Harmony to 
automatically extend a previous drawing's exposure when creating a new drawing, automatically filling the 
gaps as you create drawings.

This preference is enabled by default. If you disable it, gaps between previous drawings and new drawing will 
not be automatically filled:

How to enable or disable the Extend Exposure of Previous Drawing preference

 1. Open the Preferences dialog box by doing one of the following:

 l Select Edit > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.

 2. Select the General tab.
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 3. In the Timeline section, check or uncheck the Extend Exposure of Previous Drawing option.

 4. Click OK.
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About Adjusting Exposure
The exposure of drawings in a scene often needs to be adjusted as you flesh out your animation and your 
scene's action starts taking form. Your scene's action may require more or less drawings than initially planned, 
or some drawings may need to be exposed for longer or shorter times than expected. There are many ways to 
adjust your scene's exposure, giving you the flexibility to quickly make changes and test them so you can fine-
tune your animation.
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Increasing Exposures

T-ANIMPA-006-005

Increasing the exposure Adds one more exposure to a selected cell; repeating this action adds an extra cell 
each time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing 
an exposure pushes the existing exposure forward. 

How to increase exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l Press +.

 l At the bottom-right corner of the Xsheet view, set the number of cells over which the 
drawing will be exposed. 

 l In the Xsheet  toolbar, click the Increase Exposure  button.

 l Right-click and select Exposure > Increase Exposure.

 l From the top menu, select Animation > Cell > Increase Exposure. 
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Decreasing Exposures

T-ANIMPA-006-006

Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the 
beginning of selection. You can do this for one cell or a range.

How to decrease a single exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l Press -.

 l At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will 
be exposed. 

 l In the Xsheet toolbar, click the Decrease Exposure  button.

 l Right-click and select Exposure > Decrease Exposure. 

 l From the top menu, select Animation > Cell > Decrease Exposure. 

How to decrease a range of exposures

 1. In the Timeline or Xsheet view,  select a range of cells.
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 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure and Pull. 

 l Right-click and select Exposure > Clear Exposure and Pull.

 l In the Xsheet toolbar, click the Clear Exposure and Pull  button.

The exposure is reduced by the selected number of cells.
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Extending Single Exposures

T-HFND-007-008

Extending the exposure lets you select a cell and extend it to the desired frame. 

How to extend an exposure in the Timeline view

 1. In the Timeline view, select the cell you want to extend.

 2. Do one of the following:

 l Right-click and select Extend Exposure.

 l In the Timeline View menu, select Exposure > Extend Exposure.

 l Select Animation > Cell > Extend Exposure.

 l Press F5.

 3. In the Extend Exposure dialog box, enter the frame number to extend your cell to.

 4. Indicate if you want to insert the new frames before the following exposure or overwrite it. If you 
select insert, any following exposure will be moved down. If you select Overwrite, the following 
exposure will be erased and replaced by the drawing being extended.

NOTE 

You can also select the last cell where you want to extend your drawing to (such 
as the last cell of the layer), right-click and select Extend Exposure. You will not 
be prompted the dialog box.

How to extend an exposure gesturally

 1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down 
 cursor.
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 2. Pull down the selected cell to the desired frame. 

NOTE 

The red selection box must be visible when releasing the cursor. If not, the action 
is considered cancelled.

How to extend an exposure from the top menu

 1. Select a cell and do one of the following:

 l From the top menu, select Animation > Cell > Extend Exposure.

 l Press F5.

The Extend Exposure dialog box opens.

 2. Enter the frame number you want to extend the cell to.
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Setting the Exposure

T-HFND-006-009

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

 1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

 2. Do one of the following:

 l Select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set Exposure.

 l In the Timeline toolbar, click one of the Set Exposure     buttons. Note that 
you may have to add this button to your toolbar by right-clicking on it and selecting 
Customize.

 l In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure 
to 1, 2, or 3, or Set Exposure.

 3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of 
frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Deleting Exposures

You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline 
or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again 
in a cell.

You can delete the exposure in a selected cell range  or delete the entire exposure of a drawing exposed over 
several cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

 1. In the Timeline or Xsheet view, select the exposure you want to delete.

 2. Do one of the following:

 l Press Del.

 l Right-click and select Delete.

How to clear the entire exposure of a drawing

 1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure.

 l In the Timeline view, right-click and select Exposure > Clear Exposure.
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Moving Cells

T-ANIMPA-006-007

To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame 
in the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from 
one location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

 1. In the Timeline view, select one or more cells to move.

 2. Drag the cells to the new location.

 3. Drop the selection by doing one of the following:

 l Drop by simply releasing the mouse or pen.

 l Hold Ctrl (Windows/Linux) or ⌘  (macOS) while dropping the selection to copy the 
cells. The original cells will not be moved.

 l Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

 1. In the Xsheet view, select one or more cells.

 2. In the Xsheet view, position the pointer over the small dotted area  on the left side of the selected 
cells.

 3. Drag the selection to any other cell in the same column or in another column.

 4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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 l Hold down Ctrl (Windows/Linux) or ⌘  (macOS) while dropping the selection to copy 
the cells. The original selection will not be moved.

 l Press Shift while dropping the selection to insert it between existing frames.
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About Rippling and Overwriting the Exposure in the Timeline View
T-ANIMPA-006-004

By default, you can only use your mouse to drag and drop frames in the Timeline view. However, if you zoom in 
sufficiently, you are able to tweak the exposure of each drawing by clicking and dragging the junction between 
two drawings. 

Just like in some video editing software, when tweaking the duration of a drawing by dragging its side, you can 
decide whether to ripple or overwrite subsequent frames. This is determined by whether you grab the edge of 
the drawing by the left or the right side of said edge. 

Although not required, this functionality is especially useful when displaying thumbnails in the Timeline view, 
as you can preview the exposed drawings as you modify their exposure. As a reference, tweaking exposure in 
the timeline is only possible when you zoom in on the timeline at least close enough to fully view the thumbnails 
of drawings exposed on two frames. For more information, see Displaying Drawing Thumbnails in the Timeline 
View on page 463. 
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Changing Exposure and Rippling Drawings in the Timeline View

If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their 
right edge with the mouse cursor. If your mouse cursor is just left of the drawing's right edge, a yellow highlight 
will appear. This means dragging the drawing's edge will adjust its exposure and ripple the ensuing drawings. 

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline view

 1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

NOTE 

Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it 
is very useful.

 2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed 
on twos, by doing one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the 
exposure. 
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 4. Click and drag the right edge of the drawing to change its exposure.

If you move the edge to the right, the drawing's exposure is extended, and all the drawings 
exposed after this drawing are moved forward.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawings exposed 
after this drawing are moved backward.

NOTE 

You can drag the edge further left and completely remove the drawing, making subsequent 
drawings overwrite it.     

168

Harmony 17 Essentials User Guide                          



Chapter 4: Timing

Changing Exposure and Overwriting Drawings in the Timeline View

If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their 
right edge with the mouse cursor. If your mouse cursor is just right of the drawing's right edge, a red highlight 
will appear. This means dragging the drawing's edge will adjust its exposure and overwrite ensuing drawings. 

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline view

 1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

NOTE 

Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it 
is very useful.

 2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed 
on twos, by doing one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the 
exposure. 
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 4. Click and drag the right edge of the drawing to change its exposure.

If you move the edge to the right, the drawing's exposure is extended, and all the drawing right 
after is overwritten.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawing right after is 
exposed over it.

NOTE 

You can drag the edge further left and completely remove the drawing, making the drawing 
right after overwrite it.
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About Drawings
Drawings that are created in Toon Boom Harmony Essentials are not stored in their cells. They are actual files 
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need 
to edit the file and not the cells.
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Creating Empty Drawings
T-LAY-003-003

The Create Empty Drawing  command automatically Creates a drawing in the selected cell, replacing any 
drawing that may already be exposed in that cell and the following ones until it meets another drawing, key 
exposure or a blank cell. 

How to create an empty drawing

 1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

 2. Do one of the following:

 l In the top menu, select Drawing > Create Empty Drawing.

 l In the  Timeline view toolbar, click the Create Empty Drawing  button. 

 l Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline view.
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Renaming Drawings
T-HFND-005-003

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

You can also rename a series of drawings relative to their frame position, which is useful in hand-drawn 
animation.

How to rename a drawing

 1. In the Timeline or Xsheet view, select the drawing to rename.

 2. Do one of the following:

 l Right-click and select Drawings > Rename Drawing.

 l In the Timeline toolbar, click the Rename Drawing  button (you may have to 
customize the toolbar to display it).

 l Press Ctrl + D (Windows/Linux) or ⌘  + D (macOS).

The Rename Drawing dialog box opens.

 3. In the New Name field, type in the new drawing name.
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Deleting Drawings
You can permanently delete a drawing file from a project's folder.

NOTE 

Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

 1. In the Timeline or Xsheet view, select the drawings to delete.

 2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing
T-LAY-003-004

If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the 
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new 
drawing. The exposure of the original drawing that was on the current cell is removed. The original drawing is 
not deleted from the project folder or other cells in which it is exposed.

With Toon Boom Harmony Essentials, you can create a keyframe at the same time as you duplicate your 
drawing. This way, you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

 1. In the Timeline or Xsheet view, select the drawing to duplicate.

 2. Do one of the following:

 l From the top menu, select Drawing > Duplicate Drawings.

 l Right-click  and select Drawings > Duplicate Drawings.

 l In the Xsheet toolbar, click the Duplicate Drawing  button.

 l Press Alt + Shift + D.
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the 
actual drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is 
visible over a series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not 
linked to drawings. Keyframes can be moved independently from the drawing exposure. 

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to 
duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, 
new drawings will be created only when drawings with the same name do not already exist in 
the destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with 
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template,  such 
as when placing new drawings after the animation, then delete the template's 
animation.  It will still have updated the drawings but not override the existing 
animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will 
always be created. If drawing files with the same name already exist, Harmony will create a new 
name for the drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can 
use the Paste Special Again command instead. You can paste your selection using the same settings as in the 
most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

 1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS). 
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 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

 3. Do one of the following:

 l Right-click and select Paste Special.

 l From the top menu, select Edit > Paste Special.

 l In the Xsheet  or Timeline toolbar, click the Paste Special  button (you may need to 
customize the toolbar to display it).

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (macOS). 

The Paste Special dialog box opens.
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 4. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They 
Do Not Exist option.

How to paste new drawings with the previous Paste Special settings

 1. Do one of the following:

 l From the top menu, select Edit > Paste Special Again.

 l Right-click and select Paste Special Again

 l In the Timeline or Xsheet  toolbar, click the Paste Special Again  button (you may 
have to customize the toolbar to display it).

 l Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (macOS).
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About Frame Markers
Frame markers are simple colour markers that you can add in the Timeline view. They can be added to any 
frame, regardless of whether or not it contains a drawing. They can help you organize your scene by marking 
important frames in your scene.

Contrary to scene markers, frame markers are placed on a specific frame in a specific layer. They can only be 
added to a single frame, and not to a span of frames. 

Frame markers also distinguish themselves from drawing markers in that they do not mark drawings, but 
frames. They can even be added to frames that do not contain any drawing. They are also only visible in the 
Timeline view.
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Adding Frame Markers
You can add frame markers to any frame in your scene by right-clicking on that frame. 

How to add a frame marker

 1. In the Timeline view, select the frame you want to mark.

 2. Right-click on the frame you want to mark and, in the context menu, select Mark Frame, then the 
colour you want to mark the frame with.

A little square will appear over the marked frame, in the colour your selected.
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Moving Frame Markers
You can move frame markers by dragging and dropping them, just like you would with drawings and 
keyframes.

NOTE 

If you drag and drop frames containing frame markers, they will be moved along with the frames 
regardless of which paste preset is currently selected.

How to move frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to move. 

TIP 

If you want to move several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to move.

 2. Click and drag on the selection, and drop it where you want the frame marker to be moved.
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Copying, Cutting and Pasting Frame Markers
You can copy and paste, or cut and paste frame markers just like you would with drawings and keyframes.

NOTE 

If you copy and paste or cut and paste frames containing frame markers, the frame markers will be 
affected regardless of which paste preset is currently selected.

How to copy and paste frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to copy.

TIP 

If you want to copy several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to copy.

 2. Do one of the following:

 l Right-click on the selection and select Copy cells from Timeline.

 l In the top menu, select Edit > Copy cells from Timeline.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 3. In the Timeline view, select the frame where you want to paste the copied frame marker.

 4. Do one of the following: 

 l Right-click on the selection and select Paste cells in Timeline.

 l In the top menu, select Edit > Paste cells in Timeline.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

How to cut and paste frame markers

 1. In the Timeline view, select the frame containing the frame marker you want to cut and paste.

TIP 

If you want to cut several frame markers simultaneously, you can select all the frame 
containing the frame markers you want to cut.
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 2. Do one of the following:

 l Right-click on the selection and select Cut cells from Timeline.

 l In the top menu, select Edit > Cut cells from Timeline.

 l Press Ctrl + X (Windows/Linux) or ⌘  + X (macOS).

 3. In the Timeline view, select the frame where you want to paste the copied frame marker.

 4. Do one of the following: 

 l Right-click on the selection and select Paste cells in Timeline.

 l In the top menu, select Edit > Paste cells in Timeline.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).
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Removing Frame Markers
You can remove frame markers from the same menu from which you can add frame markers.

How to add a frame marker

 1. In the Timeline view, select the frame containing the frame marker you want to remove. 

TIP 

If you want to remove several frame markers, select all the frames containing the frame 
markers you want to remove.

 2. Right-click on the frame and, in the context menu, select Mark Frame > Remove Frame Marker.

The frame marker will be removed.
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About Scene Markers
T-ANIMPA-005-010

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can 
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in 
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is 
displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection 
and mark the whole section.
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Creating Scene Markers on Current Frames
Change the colour of the area above a frame by setting a scene marker. This will allow you to find the frame 
more rapidly when quickly scanning the Timeline.

How to mark the current frame

 1. In the Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you 
right-click on a different frame, the scene marker will be created on the current frame on which the 
playhead is positioned.

 2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the 
colour of the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene 
marker. Click OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when 
you hover your mouse over the scene marker.
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In the Timeline view, the scene marker is displayed at the current frame. 

 5. Hover over the scene marker to display its tooltip.
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Creating Scene Markers on Frame Ranges
T-ANIMPA-005-011

Change the colour of the area above a frame range by setting a scene marker. This will allow you to find the 
range more rapidly when quickly scanning the Timeline.

How to create a scene marker on a frame range

 1. In the frame counter area, select the frame range you want to mark.

 2. Right-click and select Create Scene Marker.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the 
colour of the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene 
marker. Click OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when 
you hover your mouse over the scene marker.

In the Timeline view, the scene marker is displayed over the selected frame counters. 
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 5. Hover over the scene marker to display its tooltip.
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Editing Scene Markers
You can modify the colour of a scene marker or edit the note attached to it.

How to edit a scene marker

 1. In the frame counter area, select the entire scene marker.

NOTE 

It's important to select the entire length of the scene marker, otherwise the Timeline Scene 
Marker dialog box will not open for editing.

 2. Right-click and select Scene Markers > Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

 3. Make your changes.

 4. Click OK.
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Deleting Scene Markers
If you deem it no longer necessary to have a frame or a range of frames marked, you can delete the scene 
marker.

How to delete a scene marker

 1. In the frame counter area, select at least one frame in the scene marker you want to delete.

 2. Right-click and select Scene Markers > Delete Scene Marker.
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Chapter 5: Drawing
Harmony has many powerful tools, views, and features for sketching, drawing and animating with ease. This 
chapter describes the main assets needed when drawing , as well as tips on how to start and use these tools 
efficiently. 
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About Drawing Tools
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and 
styles.

Here are the drawing tools available in Harmony. 

Icon Tool Name

Select

Cutter

Reposition All Drawings

Contour Editor

Centerline Editor

Smooth Editor

Perspective

Envelope

Edit Gradient/Texture

Brush

Pencil

Eraser
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Icon Tool Name

Text

Line

Rectangle

Ellipse

Polyline

Paint

Paint Unpainted

Unpaint

Stroke

Close Gap

Dropper

Each drawing tool has a series of options to customize its behaviour and drawing style. When you select a tool, 
the Tool Properties view displays the properties of the currently selected tool, where you can configure your 
drawing tool's behavior and style, if applicable. 
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About the Brush Tool
T-HFND-004-003

The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it 
was created with a paint brush.

When drawing with the Brush tool, you can use the Select Tool, Contour Editor, Smooth Editor, Perspective 
and Envelope tool to scale your brush strokes or to tweak their shape.

NOTE 

To learn more about the options of the Brush tool, see the Reference Guide.
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Drawing with the Brush Tool

T-HFND-004-003A 

In the Camera or Drawing view, you can draw on any drawing layer type with the Brush tool. 

How to draw with the Brush tool                  

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Tool Properties view, set the Maximum Size to the desired brush size. 

NOTE 

If you are drawing with a mouse, your strokes will always be at their maximum size. If you are 
using a pressure-sensitive tablet, your strokes will vary in size depending on the pressure of 
your pen, ranging between 25% to 100% of the maximum size. 

 4. In the Colour view, click a colour swatch to select a colour.

 5. In the Drawing or Camera view, start drawing.
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TIPS 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 
the start of your drawing stroke will connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near existing 
artwork, the end of that drawing stroke will connect to that artwork.

198

Harmony 17 Essentials User Guide                          



Chapter 5: Drawing

Creating a Brush

T-ANIMPA-002-001

Drawing a stroke with the Brush tool creates a vector shape and simply fills it with the selected colour.

A brush's tip can be shaped like a circle, a diamond or a square, and can be configured to have a specific size, 
aspect ratio and angle. Also, your brush strokes can be automatically smoothed by Harmony as you draw.

How to create a                                   brush

 1. In the Tools toolbar, select the Brush  or Eraser  tool.

 2. In the Tool Properties view,  click the arrow button to open the Brush/Eraser Properties dialog.

The Brush Properties dialog opens.

 1. In the brush tip list, select either Circle, Diamond or Square. 
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 2. Use the Maximum Size slider to set the maximum size of your brush tip.

NOTE 

When drawing with a mouse, your brush is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your brush's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 3. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your 
brush when using your pen with very little pressure. The minimum size is set to a percentage of your 
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to 
affect the brush size, set this parameter to 100%.

 4. If you want your brush to keep the same size relative to the camera frame when the camera zooms 
in on or zooms out of the scene, check the Proportional to Camera option.

 5. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush 
tip vertically all the while preserving its horizontal size.

 6. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.

 7. If you want your brush tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 8. If you want your brush tip to rotate when you rotate your pen, check the Use Pen Rotation check 
box. 
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NOTE 

This option only works if your tablet and your pen support pen rotation. 

 9. Click on the Smoothing tab.

 10. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  stroke's direction, curves and corners. A higher setting will prevent your line from being shaky, 
but is liable to reduce your drawing precision and to round sharp corners into curves.

 11. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 12. Either close or set aside the Brush Properties dialog.

 13. In the Camera or Drawing view, start drawing to test your brush settings.
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About Brush Presets

Setting up your brush to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 
and error. Once you have found the correct settings for your brush, you will want to reuse it throughout your 
project for consistency. You can do that by creating and using brush presets.

Harmony comes preloaded with many brush presets which you can select from the Tool Properties view. It is 
also possible to create your own brush presets by configuring your brush, then saving it as a preset. 

Brush presets are saved in your preferences. You can also export your brush presets into an .xml file, and 
import them on a different workstation, allowing you to share your brush presets between the different people 
collaborating on your project.
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Creating a Brush Preset

You can create your own custom brush presets by configuring your brush, then adding it as a preset.

How to create a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. Click on the Arrow button to open the Brush Properties dialog.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Brush.

 4. Do one of the following:

 l From the Brush Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 5. In the New Preset window, type a name for your new brush preset.

Your new brush preset is added to the end of the list of brush presets.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Timeline or Xsheet view, select an empty cell in a drawing layer. 

 2. In the Camera or Drawing view, draw the artwork with which you want to create a stamp.

 3. Do one of the following:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 
Timeline or Xsheet view. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  
tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—
see—Selecting, Repositioning and Transforming Artwork on page 271.

 4. In the Tools toolbar, select the  Stamp  tool.
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 5. In the Tool Properties view, click on the New Preset  button.

 6. In the New Preset dialog, type the desired name for your new stamp.

 7. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Selecting a Brush Preset

Harmony provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming a Brush Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select the brush preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Brush Presets

You can export brush presets into an .xml file which will contain all of your brush's settings. This can be useful 
if you wish to back up or share your brush presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export presets 
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the 
presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Brush Presets

You can import brush presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want 
to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About the Pencil Tool
T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. 
The pencil creates a central vector shape. 

The Brush  tool takes account of pressure sensitivity, allowing you to create lines with variable thicknesses 
when using a pen tablet, creating a contour vector shape. You can set different parameters, such as the size 
and smoothness of the Brush tool in the Tool Properties view. If you draw with the Brush tool and want to 
modify the thickness variation, use the Contour Editor  tool. 

The Pencil, Polyline  and Shape    tools let you create a central vector line of uniform thickness. Pressure 
sensitivity is not supported with pencil lines. You can set different parameters, such as the size and smoothness 
of the Pencil tool in the Tool Properties view.

NOTE 

To learn more about the Pencil tool options, see the Reference Guide.
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Drawing with the Pencil Tool

T-HFND-004-004A

Using the Pencil tool, you can draw vector pencil lines which can be easily tweaked and reshaped as needed.

How to draw with the Pencil tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

TIPS 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.

 l If you press and hold Alt before drawing a stroke, and start drawing near existing artwork, 
the start of your drawing stroke will connect to that artwork.

 l If you press and hold Alt while drawing a stroke, and end your drawing stroke near existing 
artwork, the end of that drawing stroke will connect to that artwork.
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Creating a Pencil

T-LAY-001-001

You can configure a pencil's size as well as how much Harmony should automatically smooth your pencil lines 
when drawing.

How to modify the pencil settings

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

The Pencil tool properties appear in the Tool Properties view.

 2. Use the Size slider to set the size of your pencil line.

 3. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  pencil lines. A higher setting will prevent your line from being shaky, but is liable to reduce your 
drawing precision and to round sharp corners into curves.

 4. In the Camera or Drawing view, start drawing to test your pencil settings.
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Disabling Pencil Line Textures

After you selected a pencil line texture, if you wish to resume drawing solid pencil lines again, you can do so 
using either the Colour view or the Pencil Properties dialog. 

How to resume drawing with a solid pencil line using the Colour view

 1. Click on the Show Pencil Texture Palettes  button to display your pencil texture palettes.

 2. Over the swatch list, click on the No Texture button.

From now on, the pencil lines you draw will not have a texture.

How to resume drawing with a solid pencil line Pencil Properties dialog

 1. In the Colour view, select the colour with which you wish to draw. 

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the 
Pencil Properties dialog.

 4. In the Pencil Properties dialog, click on the Texture tab.

 5. In the pencil textures library, select None.
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From now on, the pencil lines you draw will not have a texture.
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About Pencil Presets

Setting up your pencil to perfectly reproduce the desired art style can require a lot of tweaking as well as trial 
and error. Once you have found the correct settings for your pencil, you will want to reuse it throughout your 
project for consistency. You can do that by creating and using pencil presets.

Harmony comes preloaded with a few pencil presets which you can select from the Tool Properties view. It is 
also possible to create your own pencil presets by configuring your pencil, then saving it as a preset. 

Pencil presets are saved in your preferences. You can also export your brush presets into an .xml file, and 
import them on a different workstation, allowing you to share your brush presets between the different people 
collaborating on your project.
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Creating Pencil Presets

T-LAY-002-002

You can create your own custom pencil presets.  

NOTE 

To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. Configure your brush to be exactly how you wish to use it in the future—see Creating a Pencil on 
page 215.

 3. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 4. Type in a name for your new pencil thickness stencil and click OK.

 5. Start drawing in the Drawing or  Camera view. 
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Selecting a Pencil Preset

T-ANIMPA-010-001

A pencil preset is a pencil with specific properties. 

Regular pencil presets allow you to set the size and smoothing of a pencil line, or the size of a shape.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing or Camera view, draw your pencil line or shape.
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Renaming Pencil Presets

You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets

You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Exporting Pencil Presets

T-ANIMPA-010-005

You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export presets 
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the 
presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Pencil Presets 

T-ANIMPA-010-006

You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want 
to export the presets
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 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Pencil Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About Shape Tools
T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a 
square or circle into a much more complex drawing—see About the Contour Editor Tool on page 292 . 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

NOTES 

 l The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, 
rename, import and export presets, see About the Pencil Tool on page 213.  

 l To learn more about the shape tool parameters, see the Reference guide . 
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Creating Rectangles, Circles and Lines with the Shape Drawing Tools

T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also draw 
perfect circles and squares. 

How to draw with the rectangle or ellipse tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Rectangle  or Ellipse  tool.

 3. To automatically fill the shape, in the Tool Properties view, enable the Auto Fill  option.

 4. In the Camera view, click and hold where you want one of the corners of your shape to be, then 
move the mouse cursor where you want the opposing corner of the shape to be.

TIPS 

 l To draw a perfect square or circle (with equal width and height), hold the Shift key. 
You can also enable the  Draw Square or  Draw Circle option in the Tool 
Properties view.

 l To draw the rectangle or ellipse from its centre instead of its corner, hold the Alt key.
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Creating Vector Shapes with the Polyline Tool

You can use the Polyline tool to draw complex segmented lines or curved lines by creating each point 
constituting the line. 

How to draw with the Polyline tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Camera or Drawing view, do one of the following:

 l Click to create a point with no Bezier handles.

 l Click and drag to create a point and its Bezier handles in the same stroke.

TIP 

While dragging to create a Bezier handle, you can:

 l Hold the Alt key to only change the angle of the outer handle, and leave the inner 
handle at its current angle.

 l Hold the Shift key to lock the angle of the handle at every 15 degrees. 

 4. Click or click and drag somewhere else to create the second point in your line. A line will be drawn 
between the first point and the second point. 

 5. Repeat the previous step until your line is complete. 

 6. While holding Ctrl (Windows/Linux) or ⌘  (macOS), click anywhere in the drawing space to release 
the Polyline tool from the line you've been building. You can then start building a new line. 

 7. If you want to make adjustments to the line you created, you can use the Contour Editor  tool—
see Reshaping a Shape, Pencil Line or Stroke with the Contour Editor Tool on page 293.
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About the Stamp Tool
The Stamp tool allows you to create stamps out of drawings in your projects, then stamp those drawings over 
your artwork. You can click on your artwork to apply your stamp once, or draw a stroke with the Stamp tool, as 
you would with the Brush or Pencil tool, to apply the stamp repeatedly along the stroke.

A stamp can contain one or several drawings. When a stamp is made of multiple drawings, it will cycle through 
each one of its drawings each time it is stamped onto your artwork. Hence, when you draw a stroke with a 
multi-drawing stamp, you will see the stamp tool cycle through the sequence of drawings as you draw the 
stroke. The way the drawings in a multi-drawing stamp are cycled through can even be customized. Among 
other settings, you can make it cycle backward, stamp random drawings or even stamp only a specific drawing 
in the sequence. 

Other than being able to easily re-use drawings, The Stamp tool can be used to streamline drawing if you need 
to draw something that requires a lot of repetitive detail, such as starry skies, grass, weather conditions or 
particle-type effects. For example, a stamp made of a few different drawings of a blade of grass can be used to 
draw a grass line by drawing a few strokes of that stamp over the same horizontal line. The ability to 
randomize the size, angle and distance of the stamping can give the result of using this procedure a more 
natural look. 
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NOTES 

 l To learn more about the Stamp tool properties, see the Reference Guide

 l The Stamp tool replaces the Dynamic Brush option of the Brush tool in Harmony 15.0 and 
earlier.
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Creating a Stamp

You can create a stamp by drawing the artwork for your stamp, then selecting it and creating a stamp preset. 

How to create a stamp 

 1. In the Timeline or Xsheet view, select an empty cell in a drawing layer. 

 2. In the Camera or Drawing view, draw the artwork with which you want to create a stamp.

 3. Do one of the following:

 l If you want to create a stamp with all the artwork in the drawing, select this drawing in the 
Timeline or Xsheet view. 

 l If you want to create a stamp with part of the artwork in the drawing, select the Select  
tool in the Tools toolbar, then select the artwork that you want to use to create a stamp—
see—Selecting, Repositioning and Transforming Artwork on page 271.

 4. In the Tools toolbar, select the  Stamp  tool.

 5. In the Tool Properties view, click on the New Preset  button.
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 6. In the New Preset dialog, type the desired name for your new stamp.

 7. Click OK.

A stamp containing the selected artwork is added to the Presets list for the Stamp tool. You can 
now draw with the Stamp tool using this stamp.

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Creating a Multi-Drawing Stamp

You can create a stamp containing a series of drawings. All you need to do is create each drawing you want to 
add to your stamp in a separate drawing cell, then create a stamp with those drawings selected. The resulting 
stamp will cycle through each one of those drawings as you use it. 

In order to create a stamp using multiple drawings, your drawings must either be in a single contiguous 
horizontal or vertical sequence.

How to create a multi-drawing stamp 

 1. In the Timeline view, select an empty cell. 

 2. In the Camera or Drawing view, create the first drawing you want to have in the drawing sequence 
of your stamp.

 3. In the Timeline view, select the cell right after the current cell.
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 4. In the Camera or Drawing view, create the second drawing you want to have in the drawing 
sequence of your stamp.

 5. Repeat these previous steps until you have all the drawings you want to have in your stamp, in one 
continuous sequence of drawings, in the same layer.

NOTE 

You can also create a stamp using drawings in a sequence of layers, provided that those 
drawings are all in the same frame and that those layers are adjacent to each other. The 
drawings in the stamp will be ordered from top to bottom.

 6. In the Timeline view, select all the cells containing the drawings you want to add to your stamp. 

TIPS 

 l You can click and drag over a sequence of drawing cells to select them.

 l You can also select multiple cells by clicking on the first cell you want to select, 
holding shift, then clicking on the last cell you want to select. 

 7. In the Tools toolbar, select the   Stamp  tool.
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 8. In the Tool Properties view, click on  New Preset.

The New Preset dialog appears.

 9. In the New Preset dialog, type the desired name for your new stamp.

 10. Click OK.

A multi-drawing stamp containing the artwork in all the selected layers is added to the Presets list. 

NOTE 

Once your stamp has been created, you can delete the artwork you used to create it from your 
project. The artwork in your stamps will be saved in your preferences.
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Configuring a Stamp

When drawing a stroke with the stamp tool, the way the stamp is applied in terms of size, angle, spacing can 
be customized.

How to configure the size, pressure sensitivity, roundness, angle and spacing of a 
stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want to adjust the size of the stamp, change the Maximum Scale setting until you obtain the 
desired size.
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NOTE 

The Scale of a stamp is relative to the original size of the drawing used to create the 
stamp. At 100% scale, the stamp added to your artwork will be the same size as its 
original drawing. 

 4. If you're using a pressure-sensitive pen tablet and want the size of the stamp to depend on the 
amount of pressure you put on your pen, reduce the Minimum Scale setting. 

 5. If you would like to flip the stamp horizontally, click on the two-ended horizontal arrow  over the 
stamp thumbnail. If you would like to flip the stamp vertically, click on the two-ended vertical arrow 
left of the stamp thumbnails. 

 6. If your stamp is round or square, and you would like it to appear flat or squished, reduce the 
Roundness parameter. This will scale down the stamp vertically.

 7. If you want your stamp to be added to your artwork at an angle, change the Angle parameter. This 
setting rotates the stamp counterclockwise, on a 360 degrees scale.

 8. If you want to change the amount of space between each stamp when you draw a stroke with the 
Stamp tool, adjust the Spacing parameter. 

 9. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.
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NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can randomize the size, angle and spacing of the stamp. This will make the Stamp tool apply a randomly 
picked value to these parameters every time it applies a stamp to your artwork.

How to randomize the size, angle and spacing of a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.

The Stamp Properties dialog opens.

 3. If you want the size of the stamp to be randomized every time the stamp is added to your artwork, 
decrease the Minimum Scale setting, then increase the Random Size setting.
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NOTE 

The Random Size setting makes the size of each stamp vary randomly between its 
Minimum Scale and Maximum Scale. The higher the Random Size is, the closer to its 
Minimum Scale the random size can be.

 4. If you want the angle of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Angle setting.

 5. If you want the spacing of your stamp to be randomized every time the stamp is added to your 
artwork, increase the Random Spacing setting.

 6. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 

You can make a multi-drawing stamp cycle through its sequence of drawings in several different ways. You can 
also randomize the cycle, or disable it so that it only stamps the drawing of your choice. 

How to change the way a multi-drawing stamp cycles through its drawings

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.
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The Stamp Properties dialog opens.

 1. In the Cycle drop-down, select the desired cycling method:

 l Forward: Starts by applying the first drawing in the sequence, then the next one, and so on 
until it reaches the last drawing in the sequence, then cycles back to the first one.

 l Reverse: Starts by applying the last drawing in the sequence, then the previous one, and so 
on until it reaches the first drawing in the sequence, then cycles back to the last one.

 l Forward->Reverse: Starts by cycling forward through the sequence until it reaches the last 
drawing, then cycles backward to the first drawing, and so on.
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 l Reverse->Forward: Starts by cycling backward through the sequence until it reaches the 
first drawing, then cycles back to the last drawing, and so on.

 l Random: Applies a random drawing in the sequence each time the stamp is applied. 

 l Hold: Applies a single one of the drawings in the sequence over and over again. 

 2. If you selected the Hold option, select which one of the stamps in the sequence you wish to stamp 
onto your artwork by changing the Stamp setting in the Tool Properties view. For example, if you 
only want to stamp the second drawing in the sequence, set the Stamp setting to 2.

 3. If you want the cycle to restart at the beginning of each one of your drawing strokes, enable the 
Reset Cycle for Each Stroke option.

 4. If you want the current settings to be saved to your stamp preset, click on the Update Brush Preset 
 button at the top-right corner of the Stamp Properties dialog.

NOTE 

You can use the Stamp tool with the currently selected settings without updating your 
preset. 
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Updating a Stamp

A stamp in your Presets list does not only contain its drawings, but also its properties. If you have made any 
changes to the properties of your stamp, and wish for those properties to be set automatically whenever you 
use that stamp, you can update the stamp. This will save the current properties of the stamp into its preset. 

Once that is done, the current properties of the stamp will be loaded the next time you select it from the 
Presets list, even after you close and reopen the project. 

NOTE 

You cannot update the drawings in a stamp. You can only update its parameters. If you need to use 
different drawings for your stamp, you must create a new stamp—see Creating a Stamp on page 
232 and Creating a Multi-Drawing Stamp on page 234.

How to update a stamp

 1. In the Presets list of the Tool Properties view, select the stamp that you want to configure.

 2. In the Tool Properties view, just right of the stroke preview area, click on the Show Extended 
Properties   button.
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The Stamp Properties dialog opens.

 3. In the Stamp Properties dialog, adjust the settings of your stamp as desired—see Configuring a 
Stamp on page 237.

 4. In the top-right corner of the Stamp Properties dialog, click on the Update Preset  button.

The selected stamp properties will be loaded whenever you select this stamp, even after you close 
and reopen your project. 
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Drawing with the Stamp Tool

Once you have created a stamp, you can start drawing with it. You can either stamp it into your artwork once at 
a time, or draw strokes with the tool, making it apply the stamp repeatedly onto your artwork along your 
strokes.

How to draw with the Stamp tool

 1. In the Layer panel of the Stage or Camera view or the Layers view, select the layer on which you 
want to apply the stamp.                     

 2. In the Tools toolbar, select the  Stamp  tool.

 3. In the Tool Properties view, select a stamp from the Presets list—see Creating a Stamp on page 232 
and Creating a Multi-Drawing Stamp on page 234.

 4. Move the mouse cursor over the Stage or Camera view. You will see the stamp under your mouse 
cursor as it will be applied into your artwork. If you want to adjust the size in which it will be applied, 
adjust the Maximum Scale setting in the Tool Properties view.

 5. By default, your stamp will be applied at an even size, angle and distance. Also, if your stamp is a 
multi-drawing stamp, it will cycle through its drawings in their original order. If you want your stamp 
to be applied with different parameters, see Configuring a Stamp.

 6. In the Camera or Drawing view, do one of the following:

 l To apply the stamp once, simply click where you want to apply it.

 l To draw a stroke along which the stamp is applied multiple times, simply draw a stroke with 
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the tool as you would with the Brush or Pencil tool. 

TIPS 

 l If your stamp has multiple drawings in it, you can select which drawings to stamp by using 
the Stamp slider in the Tool Properties view. You can also cycle through the stamp's 
drawings by pressing the Left Arrow and Right Arrow keys. 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, your 
drawing stroke will turn into a closed shape.
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Renaming Stamps

You can rename stamps you have created to make them easier to identify in the Presets list. 

How to rename a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to rename.

 3. Open the Brush Presets  menu, then select Rename Brush.

 4. In the Rename Brush dialog, enter the new name for your stamp.

 5. Click OK.

The stamp's new name updates in the Presets list. 
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Deleting Stamps

You can delete stamps you no longer need from the Presets list. 

How to delete a stamp.

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Presets list of the Tool Properties view, select the stamp you want to delete.

 3. Click on the Delete Brush  button just above the Presets list.

The stamp is removed from the Presets list. 
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Exporting Stamps

You can export stamps you have created to keep a backup of them, or to import them for use in another project.

How to export stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset   menu and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil, Eraser and Stamp tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export your 
stamps, uncheck Select/Deselect All, then check Stamp.

 4. Click on Export.

A save dialog appears.

 5. Browse to the location where you want to save the .xml file that will contain your presets.

 6. Enter the desired file name for your presets file. 

 7. Click on Save.
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Importing Stamps

You can import stamps you have exported from another project into your current project, allowing you to reuse 
them between projects or to restore backups of your stamps. 

How to import stamps

 1. In the Tools toolbar, select the Stamp  tool. 

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

An Open File dialog appears.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your stamps

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import the stamps from this file, uncheck Select/Deselect All and check Stamps.

 6. Click on Import.

The imported stamps will be added to the Presets list in the Tool Properties view. 
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Changing The Way Stamps Are Displayed

By default, your stamps are listed in the Tool Properties dialog as strokes. You can also preview them as big 
thumbnails if you want to be able to pick them without scrolling, or as small thumbnails if you have a lot. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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Stamp Tool Modes

When you select the Stamp tool, its properties are displayed in the Tool Properties view.

 Draw Behind Mode

When enabled, your drawing strokes will be added underneath the existing artwork instead of over it.

NOTE 

Your stroke will  appear over your artwork as you draw it, until you release the mouse cursor or 
tablet pen. 
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About the Stroke Tool
T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for 
drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool 
can be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE 

To learn more about the Stroke tool parameters, see the Reference guide .

253



Creating Invisible Lines with the Stroke Tool 

T-HFND-004-013A

You can draw invisible lines with the Stroke tool. These lines can be used to delimit or close off colour areas 
when you colour drawing with the Paint tool.

How to draw invisible lines with the Stroke tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. Make sure strokes are visible in your drawing space by doing one of the following:

 l In the top menu, select View >  Show > Show Strokes

 l Press K. 

 3. Select the Stroke tool by doing one of the following:

 l In the Tools toolbar, double-click on Paint. In its drop-down menu, select the  Stroke tool

 l Press Alt + V.

 4. In the Camera or Drawing view, start drawing.

TIPS 

 l If you press and hold the Shift key before or while you are drawing, your stroke will 
be a straight line until you stop drawing or release the Shift key.

 l If you press and hold the Shift and the Alt keys before drawing, your stroke will be a 
straight line in an angle that is a multiple of 15 degrees. 

 l If you press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) key while drawing, 
your stroke will be a closed shape.

 l If you press and hold Alt before drawing a stroke, and you start your stroke near 
another stroke, the start of your stroke will connect to the other stroke. Likewise, if 
you press and hold the Alt key and end your stroke near another stroke, the end of 
the stroke will connect to that stroke.
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NOTE 

If the Show Strokes option is not enabled, the following message will appear after you 
draw a stroke. To remedy this, refer to step 2. 

Authors

Marie-Eve Chartrand
        Christopher Diaz

chrisdiazart.com
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About the Eraser Tool
T-HFND-004-010

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it. 

Just like the Brush tool, the Eraser tool is pressure-sensitive, allowing you to erase with more precision if you are 
using a pen tablet.

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when 
drawing and designing. Harmony provides you with a variety of default eraser styles and allows you to create 
and save your own eraser presets. 

NOTE 

To learn more about each individual parameter of the Eraser tool, see the Reference Guide.
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Erasing 

T-HFND-004-010A

Using the Eraser tool, you can erase portions of your drawing by drawing strokes over it.

How to erase with the Eraser tool

 1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Presets list of the Tool Properties view, select a brush preset to use. 

NOTE 

To learn how to create an Eraser preset, see Creating an Eraser on page 258.

 4. Set the Maximum Size to the desired Eraser size. 

NOTE 

If you are drawing with a mouse, your strokes will always be at their maximum size. If 
you are using a pressure-sensitive tablet, your strokes will vary in size depending on the 
pressure of your pen, ranging between 25% to 100% of the maximum size. 

 5. In the Camera or Drawinga view, start erasing.

TIPS 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 

 l If you press and hold the Shift and Alt keys before or while drawing, you will draw a 
straight horizontal or vertical line.
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Creating an Eraser

Drawing a stroke with the Eraser tool cuts out the stroke from your artwork. 

An eraser's tip can be shaped like a circle, a diamond or a square, and can be configured to have a specific size, 
aspect ratio and angle. Also, your eraser strokes can be automatically smoothed by Harmony as you erase.

How to create                                      an eraser                 

 1. In the Tools toolbar, select the Eraser tool or press  Alt + B. 

 2. In the Tool Properties view,  click the arrow button to open the Eraser Properties view.

The Eraser Properties dialog opens.

 3. In the brush tip list, select either Circle, Diamond or Square. 
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 4. Use the Maximum Size slider to set the maximum size of your eraser tip, in pixels. 

NOTE 

When drawing with a mouse, your eraser is always at its maximum size. When drawing 
with a pressure-sensitive pen tablet, your eraser's size will range between its minimum 
and maximum size, depending on the amount of pressure you put on the pen when 
drawing. 

 5. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the percentage 
of your eraser tip's maximum size your eraser should be when you use your pen with very little 
pressure. If you don't want the pressure on your pen to affect the eraser size, set this parameter to 
100%.

 6. If you want your eraser tip to have uneven dimensions, use the Roundness slider to shrink the 
eraser tip vertically all the while preserving its horizontal size.

 7. If you want your eraser tip to be at an angle, use the Angle slider to rotate your brush tip.

 8. If you want your eraser tip to stretch when you tilt your pen, use the Pen Tilt Sensitivity slider to set 
how much the tip should stretch. The tip will stretch by the percentage you set, in the direction in 
which you tilt the pen.

NOTE 

This option only works if your tablet and your pen support tilt sensitivity.

 9. If you want your eraser ip to rotate when you rotate your pen, check the Use Pen Rotation check 
box. 

NOTE 

This option only works if your tablet and your pen support pen rotation. 

 10. Click on the Smoothing tab.
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 11. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on 
your  stroke's direction, curves and corners. A higher setting will prevent your line from being shaky, 
but is liable to reduce your drawing precision and to round sharp corners into curves.

 12. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on 
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control 
points for the resulting vector shape. 

 13. Either close or set aside the Eraser Properties dialog.

 14. In the Camera or Drawing view, start erasing to test your eraser settings.
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About Eraser Presets

Once you have found the correct settings for your eraser, you might want to reuse it throughout your project for 
consistency. You can do that by creating and using eraser presets.

Harmony comes preloaded with a few eraser presets which you can select from the Tool Properties view. It is 
also possible to create your own eraser presets by configuring your eraser then saving it as a preset. 

Eraser presets are saved in your preferences. You can also export your eraser presets into an .xml file, and 
import them on a different workstation, allowing you to share your eraser presets between the different people 
collaborating on your project.
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Creating an Eraser Preset

You can create your own custom eraser preset by configuring your eraser, then adding it as a preset.

How to create an eraser preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. Click on the Arrow button to open the Eraser Properties dialog.

 3. In the Eraser Properties dialog, configure your eraser—see Creating an Eraser.

 4. Do one of the following:

 l From the Eraser Properties dialog, click on the New Brush Preset  button in the top-
right corner. 

 l In the Tool Properties view, click the New Brush Preset  button.

 l In the Tool Properties view, open the Brush Presets  menu  and select New Brush 
Preset.

 5. In the New Preset window, type a name for your new eraser preset.

Your new eraser preset is added to the end of the list of eraser presets.
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Selecting an Eraser Preset

Harmony provides you with default eraser presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset from the Presets list.
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Updating a Brush Preset

If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in 
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 1. In the Tool Properties view, select the Brush Preset you wish to update.

 2. Click on the Arrow button to open the Brush Properties view.

 3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Brush.

 4. Click on the Update Brush Preset  button  in the upper-right corner of the Brush Properties 
dialog. 
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Renaming an Eraser Preset

To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select an eraser preset to rename. 

 3. Open the Brush Preset menu  and select Rename Brush. 

 4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset

You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tools toolbar, select the  Eraser  tool or press Alt + E.

 2. In the Tool Properties view, select the eraser preset you want to delete.

 3. Do one of the following:

 l Click the Delete Brush  button.

 l Open the Brush Preset menu  and select Delete Brush.
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Exporting Eraser Presets

You can export eraser presets into an .xml file which will contain all of your eraser's settings. This can be useful 
if you wish to back up or share your eraser presets.

How to export pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Export Brushes.

The Export Brushes dialog opens. This dialog allows you to export brush presets for the Brush, 
Pencil and Eraser tools. 

 3. By default, the presets for all your tools will be selected for export. If you only wish to export presets 
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the 
presets.

 4. Click Export.

 5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml 
file and enter its file name.

 6. Click Save.
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Importing Eraser Presets

You can import eraser presets that you previously exported from Harmony. 

How to import pencils, brushes and erasers

 1. In the Tools toolbar, select either the Brush , Pencil  or Eraser  tool.

 2. In the Tool Properties view, open the Brush Preset menu  and select Import Brushes.

 3. In the browser window that appears, navigate to and select the .xml file in which you exported 
your brush presets.

 4. Click Open.

The Import Brushes dialog box opens.

 5. By default, the presets for any tools included in the file will be selected for import. If you only wish to 
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want 
to export the presets

 6. Click Import.

The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display

You can display your preset list as thumbnails or a list. 

How to change the way presets are previewed in the Tool Properties view

 1. In the Tool Properties view, open the Brush Presets  menu.

 2. Select one of the following options:

 l Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their 
tip.

 l Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a 
preview of their tip.

 l Stroke View: Displays presets in a list, with their name and a preview of a stroke done 
with each preset. 
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About the Select Tool
T-HFND-004-005

The Select tool allows you to select drawing strokes and drawing objects. When selected, you  can use the 
Select tool to scale, translate, rotate, resize, flip and delete them.

NOTES 

 l The Select tool can only be used to select, reposition and transform whole drawing strokes. If 
you need to cut out part of your artwork to reposition or transform it, you must use the Cutter 
tool—see About the Cutter Tool.

 l To learn more about the Select tool options, see the Reference Guide .
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Selecting, Repositioning and Transforming Artwork

T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups, then reposition, rotate, scale and skew them. 

NOTE 

The select tool can only select whole drawing strokes. If you need to cut out part of your artwork, 
use the Cutter tool instead—see About the Cutter Tool on page 285.

How to select artwork

 1. In the Timeline view, select the cell on which you want to select drawing objects.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera view, select the artwork you want to edit by doing one of the following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l By default, you can only select artwork in the currently selected layer. You can select 
artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All from 
the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).
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 4. Do one of the following to edit your selection:

 l To reposition the selected artwork, click on it and drag where you want to position it.

NOTE 

You can also nudge your selection using the arrow keys, and fast-nudge your 
selection by holding Shift and pressing the arrow keys.

 l To rotate the selected artwork, click and grab just outside one of the handles at the corners of 
the control box and rotate it.

 l To scale the selected artwork, click and drag on one of the control points at the corners or the 
middle of the edges of the control box. 
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TIP 

While scaling artwork, you can preserve its proportions by pressing and holding 
the Shift key.

 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.

 l To delete, press Del (Windows/Linux) or Backspace (macOS).
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Selecting Artwork in Several Drawings

You can use the Select tool to select and manipulate artwork in several drawings in the same layer at the same 
time. There are two approaches to doing this, both of which are options available in the Tool Properties view:

 l  Apply to All Frames: When you draw a lasso or marquee in the Camera or Drawing views, it will 
select strokes in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: When you draw a lasso or marquee in the Camera or Drawing views, it 
will select strokes in that area in all of the drawings currently displayed in the Onion Skin. This method 
allows you to select and manipulate artwork in a specific range of drawings, and allows you to see the 
artwork you selected in the Camera or Drawing view. 

How to select artwork in a specific range of drawings

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to edit.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to edit:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Select tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 
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NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select. 

Strokes in the current drawing and in the drawings displayed in the Onion Skin that fit inside the 
lasso or marquee you drew will be selected.

How to select artwork in all exposed drawings in a layer

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to edit. 

 2. In the Tools toolbar, select the  Select tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select.

Strokes in the current drawing as well as in all other drawings exposed in the current layer that fit 
inside the lasso or marquee you drew will be selected.
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Selecting Artwork in Several Layers

You can use the Select tool to select artwork in several layers simultaneously. There are two ways to do this:

 l By selection: If you select several layers in the Timeline or Xsheet view, you will be able to select and 
manipulate artwork in all of the selected layers.

 l  Apply to All Visible Layers mode: By enabling this mode, you will be able to select artwork in all of 
the layers that are visible in the Camera view simultaneously. 

NOTE 

You can only select artwork in several layers simultaneously in the Camera view. 

How to select artwork in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Select tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers button is toggled off. 

 4. In the Timeline or Xsheet view, select all the layers you want to edit simultaneously. 

TIPS 

 l To select multiple layers, press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) 
key, then click on each layer you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by clicking 
on the first layer you want to select, then, while holding Shift, clicking on the last 
layer you want to select. Every layer in-between will also be selected. 

NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 

At this point, you can select artwork in all of the selected layers. 
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 5. In the Camera view, do one of the following:

 l Draw a lasso or marquee around all the drawing strokes that you want to select. 

 l While holding Shift, click on each drawing stroke that you want to select.

How to select artwork in all visible layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Select tool.

 3. In the Tool Properties view, click on the  Apply to All Visible Layers button to toggle it on. 

NOTE 

If  Light Table is enabled, all the visible layers will appear fully opaque. This indicates 
that the currently selected tool can work on all visible layers simultaneously. 

TIP 

You can also select artwork from all visible layers by holding the Ctrl (Windows) or ⌘  
(macOS) key while using the Select tool. 

 4. In the Camera view, do one of the following:

 l Draw a lasso or marquee around all the drawing strokes that you want to select. 

 l While holding Shift, click on each drawing stroke that you want to select.
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Inverting a Selection

You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or Shift + 
⌘  + I (macOS).

278

Harmony 17 Essentials User Guide                          



Chapter 5: Drawing

Repositioning the Selection Pivot

You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Camera or Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain 
there until you make a new selection.
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Arranging and Reordering Drawing Strokes

The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing 
or Camera view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the following: 

 l From the top menu, select Drawing > Arrange > Bring to Front—Moves the selected 
art to the front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘  + Shift + 
PgUp (macOS). 

 l From the top menu, select Drawing > Arrange > Bring Forward—Moves the selected 
art one level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘  + 
PgUp (macOS).

 l From the top menu, select Drawing > Arrange > Send Backward—Moves the selected 
art one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘  + PgDown 
(macOS).

 l From the top menu, select Drawing > Arrange > Send to Back—Moves the selected 
art behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux) 
or ⌘  + Shift + PgDown (macOS).

 4. In the Drawing View and Camera View toolbars, you can also add the following buttons—see 
Customizing View Toolbars on page 56.

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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Grouping Drawing Strokes

Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the 
selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. 
Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Group.

 l From the Camera or Drawing view menu,  select Edit > Group > Group.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (macOS). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Ungroup.

 l From the Camera or Drawing view menu,  select Edit > Group > Ungroup.

 l Press Ctrl + Shift + G (Windows/Linux) or ⌘  + Shift + G (macOS). 

281



About the Repositioning All Drawings Tool
T-ANIMPA-010-008

The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every 
drawing included in a layer. 

If your hand-drawn animation requires to be repositioned in the grid, as soon as your select the Reposition All 
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the 
controls the same was as the Select tool—see About the Select Tool on page 270. 

NOTE 

To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning All Drawings in a Layer

T-ANIMPA-010-009

Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the 
current layer. 

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects 
every stroke in your drawing in the Drawing and Camera view.

 2. Do any of the following:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.

 l To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift 
to maintain the selection’s ratio.
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 l To skew, drag the sides or top and bottom segments, between the control points.

 3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated 
or skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the 
Tool Properties view.
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About the Cutter Tool
T-HFND-004-007

The Cutter tool lets you cut out part of a drawing so that you can transform it, copy it or delete it.  You can use it 
to scale or reposition the portion of a flattened drawing. You can also use it to trim strokes using a single 
gesture.

NOTE 

To learn more about the Cutter tool options, see the Reference guide .
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Cutting Artwork 

T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Camera or Drawing view, draw a lasso around the artwork you want to cut away.

The artwork inside the lasso you drew will be cut from the rest of the artwork and will be selected. 

TIPS 

 l You can add another part of your artwork to the selection by holding Shift and 
drawing another lasso. 

 l By default, the Cutter tool will only work on the current layer. You can cut artwork 
from all visible layers by holding the Ctrl (Windows) or ⌘  (macOS) key.

 3. Once you've cut out artwork, you can manipulate it like with the Select tool. For example:

 l To move the selected artwork, click and drag it.

 l To delete the selected area, press Del.

 l To scale, rotate or skew the selection, use the controls around the selection's bounding box.
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Cutting Artwork in Several Drawings

You can use the Cutter tool to cut out and manipulate artwork in several drawings in the same layer at the same 
time. There are two approaches to doing this, both of which are options available in the Tool Properties view:

 l  Apply to All Frames: When you draw a lasso or marquee in the Camera or Drawing views, it will cut 
out artwork in that area in all of the exposed drawings in the current layer. 

 l  Apply to Onion Skin Range: When you draw a lasso or marquee in the Camera or Drawing views, it 
will cut out artwork in that area in all of the drawings currently displayed in the Onion Skin. This method 
allows you to cut out and manipulate artwork in a specific range of drawings, and allows you to see the 
artwork you cut out in the Camera or Drawing view. 

How to select artwork in a specific range of drawings

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to edit.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to edit:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Cutter tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 
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NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select. 

The artwork in the current drawing and in the drawings displayed in the Onion Skin will be cut out 
by the lasso or marquee you drew and will become selected. 

How to select artwork in all exposed drawings in a layer

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, draw a lasso or marquee around the artwork you want to select.

The artwork in all the drawings in the current layer will be cut out by the lasso or marquee you drew 
and will become selected.
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Cutting Artwork in Multiple Layers

You can use the Cutter tool to cut out artwork in several layers simultaneously. There are two ways to do this:

 l By selection: If you select several layers in the Timeline or Xsheet view, you will be able to cut out and 
manipulate artwork in all of the selected layers.

 l  Apply to All Visible Layers mode: By enabling this mode, you will be able to cut out artwork in all of 
the layers that are visible in the Camera view simultaneously. 

NOTE 

You can only cut artwork in several layers simultaneously in the Camera view. 

How to cut out artwork in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers button is toggled off. 

 4. In the Timeline or Xsheet view, select all the layers you want to edit simultaneously. 

TIPS 

 l To select multiple layers, press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) 
key, then click on each layer you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by clicking 
on the first layer you want to select, then, while holding Shift, clicking on the last 
layer you want to select. Every layer in-between will also be selected. 

NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 

At this point, you can cut artwork in all of the selected layers. 
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 5. In the Camera view, draw a lasso or marquee around the artwork that you want to cut out. Note that 
only artwork in the selected layers will be cut out and selected.

How to select artwork in all visible layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to edit are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to edit. 

 2. In the Tools toolbar, select the  Cutter tool.

 3. In the Tool Properties view, click on the  Apply to All Visible Layers button to toggle it on. 

NOTE 

If  Light Table is enabled, all the visible layers will appear fully opaque. This indicates 
that the currently selected tool can work on all visible layers simultaneously. 

TIP 

You can also cut artwork from all visible layers by holding the Ctrl (Windows) or ⌘  
(macOS) key while using the Cutter tool. 

 4. In the Camera view, draw a lasso or marquee around the artwork that you want to cut out.
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About the Contour Editor Tool
T-HFND-004-008

The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings. 

Artwork in Harmony is made of vector shapes. Vector shapes are defined by points, the lines joining the points 
together (contours) and the curve vectors, represented by Bezier handles, which make the curve of said lines.

The Contour Editor tool allows you to select a contour or point, and change the position of points, add and 
remove points from the shape, rotate, lengthen and shorten curve handles to influence the curve of contours 
between those points, or drag contours between points to change their curve directly. 

Since pencil lines are defined by a single line with a line width, you can use the Contour Editor to easily modify 
the shape of pencil lines. In contrast, brush strokes are full vector shapes, so the Contour Editor can be used to 
modify their shape. 

The Contour Editor can be used to tweak vector artwork in all sorts of ways. It can be used to perfect a pencil 
line, correct shapes, or create complex shapes out of a basic ellipse or rectangle.

NOTE 

To learn more about the Contour Editor tool options, see the Reference Guide.
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Reshaping a Shape, Pencil Line or Stroke with the Contour Editor Tool

T-HFND-004-008A

You can use the Contour Editor tool to tweak the contours of vector shapes and brush strokes in your drawings, 
as well as reshape pencil lines and strokes. 

How to reshape drawings

 1. In the Tools toolbar, select the Contour Editor  tool or press Alt + Q.

 2. In the Drawing or Camera view, click the shape, contour or pencil line you want to edit near the area 
you wish to change.

The shape or line's control points appear.

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 

TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 
while clicking on points to add them to your selection. You can use the Contour Editor to 
scale and rotate a selection of multiple points by enabling the  Show Contour Editor 
Control  option in the Tool Properties view.
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 4. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.
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 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.

 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 
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 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.

 l To remove a control point, select the control point and press Del (Windows/Linux) or 
Backspace (macOS).

296

Harmony 17 Essentials User Guide                          



Chapter 5: Drawing

About the Centerline Editor
T-HFND-004-009B

The Centerline Editor allows you to tweak and reshape brush strokes by manipulating their centre line rather 
than their contour. This gives you a flexibility that is similar to the one you have when using the Contour Editor 
tool to manipulate pencil lines.

In Harmony, pencil lines are composed of a centreline, to which the thickness and colour is added by the 
application. This makes it easy to edit pencil lines with the Contour Editor, as you can tweak their centreline, 
and their contour will . Brush strokes, however, are stored as their outer shape. Therefore, using the contour 
editor on a brush strokes does not allow you to edit the center line of the stroke, but rather, its contours.

The Centerline Editor tool creates a center line for a brush stroke, and gives you access to control points and 
Bezier handles for this center line, allowing you to deform the brush stroke the same way you can deform a 
pencil line using the Contour Editor.

Keep in mind that brush strokes are vector shapes with a fill. As such, the Centerline Editor must do guess work 
to figure out the centreline of your brush strokes, and apply deformations on its shape as you tweak its control 
points. The Centerline Editor will not be able to make a accurate centreline out of brush strokes that merge 
together, that look scrambled or that otherwise do not have a clear direction.    
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NOTE 

  If you use the Centerline Editor to deform a closed brush stroke with a fill inside it, the fill will not be 
reshaped to fit the new shape of the brush stroke.

NOTE 

To learn more about the Centerline Editor tool options, see the Reference Guide.
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Reshaping Brush Strokes Using the Centerline Editor

T-HFND-004-009C

You can use the Centerline Editor tool to reshape brush strokes from their center line rather than their contour, 
like you would reshape pencil lines using the Contour Editor.

How to reshape brush strokes

 1. In the Tools toolbar, double-click on the Contour Editor  button and select the Centerline Editor 
 tool, or press Alt + W.

 2. In the  Drawing or Camera view, click the contour or pencil line you want to edit near the area you 
wish to change.

The Centerline Editor creates a center line manipulator based on the outline's shape, with control 
points. 

 3. Click on one of the points to select it. 

The point's Bezier handles appears, as well as Bezier handles for the surrounding points. 
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TIP 

You can select several points by drawing a lasso around the points, or by holding Shift 
while clicking on points to add them to your selection. You can use the Contour Editor to 
scale and rotate a selection of multiple points by enabling the Show Centerline Editor 
Control  option in the Tool Properties view.

 4. Do one of the following:

 l To move a point or a selection of multiple points, click and drag it. 

 l To change the curve on both sides of a point, drag one of its Bezier handles.

 l To change the curve on only one side of a point, press and hold the Alt key, then drag one of 
its Bezier handles.

 l To deform the contour, drag a part of the contour between two points.
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 l To deform the curve between two points, hold the Shift key and drag the contour between 
two points.

 l To remove a point's Bezier handles and make the lines it is connected to straight, press and 
hold the Alt key and click on the point.

 l Straight lines have no Bezier handles at their points by default. To create Bezier handles for 
these points and make their lines curved, pres and hold the Alt key, then click and hold the 
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse 
cursor until you release the mouse button. 

301



 l To add a control point, press Ctrl (Windows/Linux) or ⌘  (macOS) and click on the contour 
where you want the new point to be created.
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About the Smooth Editor Tool 
T-ANIMPA-010-010

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw 
may look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of 
your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the 
lines, the Smooth Editor  tool. 

NOTE 

To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Artwork Using the Smooth Editor

T-ANIMPA-010-011

You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select Drawing > Tools > Smooth Editor.

 2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass 
over the same line several times to remove more points and make the line smoother. Note that by 
default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—
see the Reference guide  to learn about the various settings available.

TIPS 

 l If you press and hold the Shift key before or while drawing, you will draw a straight line.

 l If you press and hold the Spacebar key while drawing a straight line, the angle of your line 
will lock. If you are using a pressure-sensitive tablet, you can draw over your line to adjust its 
thickness. 
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About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and 
edge anchor points to warp the shape.

NOTES 

To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool

Use the Perspective tool to distort a drawing's bounding box and simulate a perspective effect. 

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or 
press Alt + 0.

 2. In the Camera or Drawing view, select the artwork you want to deform by doing one of the 
following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l By default, you can only select artwork in the currently selected layer. You can select 
artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All from 
the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You 
can warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE 

To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool

You can warp your drawings using the Envelope tool. 

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 2. In the Timeline view, select a drawing to deform.

 3. In the Camera or Drawing view, select the artwork you want to deform by doing one of the 
following:

 l Click on a drawing stroke to select it.

 l Draw a lasso around drawing strokes  to select them simultaneously.

TIPS 

 l To add more drawing strokes to the selection, press and hold the Shift key and 
either click or draw a lasso around the strokes you want to select.

 l By default, you can only select artwork in the currently selected layer. You can select 
artwork from any visible layer by holding the Ctrl (Windows/Linux) or ⌘  (macOS) 
key. 

 l If you prefer drawing a rectangle rather than a lasso to select artwork, click on the 
 Lasso button in the Tool Properties view and select  Marquee. 

 l You can select all the drawing strokes in the drawing by select Edit > Select All from 
the top menu or by press ing Ctrl + A (Windows/Linux) or ⌘  + A (macOS).

A rectangle appears around the selected artwork. Bezier handles stem from each corner of the 
rectangle, which can be manipulated to make the sides of the rectangle into curves.
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 4. Click and drag the different anchor points and handles to deform the image.
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TIPS 

 l In the Tool Properties view, you can enable the  Show Advanced Controls  option to 
control the warp points inside the control box.

 l You can also divide the control box into several sections by increasing the value in the 
Width and Height fields of the Tool Properties view. 
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About the Text Tool
With the Text tool, you can add text in your project using various fonts and texts attributes. 

Text objects are drawing objects in the same was as brush strokes and drawing groups are, so they can be 
manipulated with the select tool. After you have written and formatted your text, you can break the string 
apart to convert the letters into drawing objects that can than be individually modified with tools such as 
Select, Perspective, Contour Editor, Smooth Editor. 

NOTE 

To learn more about the Text tool options, see the Reference guide .
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Adding Text to Drawings

You can use the Text tool to add text to your drawings. 

How to add text to drawings 

 1. Do one of the following: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Drawing > Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing or Camera view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you will 
type—see the Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always 
return to edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box with the Text   tool and moving the anchor 
point right or left. Using the Select tool will distort and scale your text itself rather than changing 
the width and height of your text box.
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Breaking Text Into Letters or Vector Shapes

Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break 
ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that 
you can edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use 
the Select tool to select the letters to convert.

 5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into 
a regular drawing object, with no more text attributes.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break Apart 
Text Layers to break the selection into a regular drawing object, with no more text 
attributes.
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About Drawing Space Management
When you are drawing in the Camera or Drawing view, you can zoom, pan and rotate the view to make it 
easier to determine where to place objects, determine the scale of objects, and when zooming out, get an 
overall view of the panel and its contents. You can also use the grid to help you determine the size and 
placement of objects as you draw. 

If you like drawing in the Camera view, but don't want overlays to cover the drawing you're working on, you 
can enable the Current Drawing on Top option.
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About the Zoom Tool
The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

NOTE 

To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Camera or Drawing view. 

 3. In the Tools Properties view, do the following:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Camera or 
Drawing view. When you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Camera or Drawing 
view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing or Camera view. When you are zoomed in your 
workspace, you may need to pan to a different area of your image. You can do so with the Hand tool or the 
Spacebar keyboard shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the following:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing or Camera view and 
drag. 

 l You can also Hold down the Spacebar, click in the Drawing or Camera view and move 
your mouse in the direction you want to pan the view.
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About the Rotate View Tool
T-LAY-001-005

The Rotate View  tool lets you rotate the Drawing or Camera view, the same way as you would do with a real 
animation disc  for increased flexibility. This tool can also be used in the Perspective view.

The Rotate View tool has no options in the Tool Properties view.

How to use the Rotate View tool

 1. Do one of the following:

 l From the top menu, select Drawing > Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool in the Hand tool menu.

 l In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (Windows/Linux) or ⌘  + Alt (macOS).

The rotation disc appears.

 2. In the Drawing or Camera view, click and drag to rotate the space. 
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 3. Release the keyboard shortcut or switch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About Mirror View
T-H16NEW-001-001

A recurring challenge for artists is to draw characters and objects with their elements properly aligned and 
with respect to their proportions and shapes. While drawing, the eye tends to get used to the imperfections in 
the shapes and proportions in your artwork, making it hard  to spot and correct them. A common trick to avoid 
this pitfall is to flip your artwork horizontally. This allows you to look at your artwork as if you were looking at it 
for the first time, making all the mistakes in shapes, positioning and proportion obvious to your eye.

Using the Mirror View command, you can temporarily flip the drawing space horizontally, whether in the 
Camera or Drawing view. This will allow you to see your artwork and your animation as if your whole stage was 
flipped, and you can even use the drawing and animation tools on the flipped artwork. Once you are done, you 
can disable Mirror View to instantly undo it and resume working with your artwork in its original orientation. 

NOTE 

Just like panning, rotating and zooming in or out of the Camera and Drawing views, Mirror view is 
strictly a temporary visual effect. It does not affect the rendered image nor does it have any 
permanent effect on your artwork, your layers or your scene's layout.

How to temporarily flip the Camera or Drawing view horizontally

 1. Click anywhere on the Camera or Drawing view to set the focus on the view you're drawing in.

TIP 

You can click on a view's tab to set the focus on it without clicking on anything inside it. 

 2. Do one of the following:

 l In the Camera or Drawing toolbar, click on the  Mirror View button.

 l In the top menu, open the View menu and select Mirror View. 

Everything in the Camera or Drawing view will now appear flipped horizontally. A small overlay 
with the text Mirror View appears in the top-left corner of the drawing space to help you remember 
that you are working in Mirror View. 
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TIP 

You can add a button to enable and disable Mirror View to your Camera or Drawing view 
toolbar. To customize a toolbar's buttons, right-click on the toolbar and select Customize. 

How to unflip the Camera or Drawing view

 1. Click anywhere on the Camera or Drawing view to set the focus on the view you're using to draw. 

TIP 

You can click on a view's tab to set the focus on it without clicking on anything inside it. 

 2. In the top menu, open the View menu and select Mirror View. 

Everything in the Camera or Drawing view will be unflipped. The "Mirror View" overlay will 
disappear.
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Displaying the Current Drawing on Top
T-ANIMPA-010-020

In the Camera view, when you draw on a layer, the artwork is displayed in the correct order. For example, if the 
layer on which you are drawing is located behind an object on another layer, the lines you draw will be hidden 
behind that object.

You can display a selected drawing on top of everything while you draw. Then, each time you  select a drawing 
tool, the drawing is displayed in front of everything in the Camera view. The Timeline view ordering remain 
unchanged. 

How to display the drawing on top

 1. Do one of the following:

 l From the top menu, select View > Show > Current Drawing on Top. 

 l In the Camera bottom toolbar, click the Current Drawing on Top button.

NOTE 

The Current Drawing on Top status is retained when you exit Harmony. When 
you restart the application, the last status will be used.

 2. In the Tools toolbar, select a drawing tool. You only need to enable this option once, it is not 
necessary to do it each time you select a drawing tool.  

 3. In the Camera view, start drawing.
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About the Grid 
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a given 
layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the grid 
boundaries as it is only a visual reference.  

In the Camera view, the Grid is visible when you select a drawing tool.
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Displaying the Grid

You can display the grid and it will be visible in the Drawing view. It will be visible in the Camera view when 
you select a drawing tool. 

Use the Show Grid option to display a grid in the Drawing or Camera views. 

How to display the grid 

 1. Do one of the following: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (Windows/Linux) or ⌘  + ' (macOS).
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Modifying the Grid

You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the following: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid.

 l View > Grid > 12 Field Grid—Displays a 12-field size grid.

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements.

 l View > Grid > Overlay—Displays the grid over the drawing elements.

 3. In the Drawing View and Camera View toolbars, you can also add the following buttons—see 
Customizing View Toolbars on page 56.

 l Grid Outline Only  button 

 l Square  button 

 l 12 Field Grid  button 

 l 16 Field Grid  button 

 l Underlay  button 

 l Overlay  button
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About OpenGL Antialiasing
T-ANIMPA-010-016

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you 
draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast real-
time display called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing 
preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias 
your drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or 
off; by default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE 

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.

326

Harmony 17 Essentials User Guide                          



Chapter 5: Drawing

Setting the Full Scene Antialiasing Preference

T-ANIMPA-010-017

You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE 

You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the following:

 l Select Edit > Preferences (Windows) or Harmony Essentials > Preferences (macOS). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. 
The number of samples is basically equivalent to the amount of times a pixel will be enlarged to 
calculate the antialiasing. This technique is called supersampling. The higher the number of samples, 
the better the antialiasing quality will be, but the heavier it will be on performance.

 4. Restart Harmony.
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About Pen Stabilization
By default, when drawing with freehand drawing tools such as the brush, pencil or eraser tools, Harmony 
smoothens each drawing stroke you create right after creating it. It does this by generating the vector shape of 
your drawing stroke, then simplifying its structure of points and curves, to remove what appears to be jittering. 
However, this can cause your precisely executed strokes to lose in precision and quality.

When drawing with minutia and precision, you can use Harmony's pen stabilizer instead. The pen stabilizer 
allows you to easily draw curved lines with precision without having to apply smoothing to them after you have 
drawn them.

Harmony's pen stabilizer works by letting you draw a stroke of a certain length without generating artwork 
right away. Once your stroke reaches this length, Harmony starts generating an actual drawing stroke that 
trails behind your mouse cursor or tablet pen. It determines the direction the drawing stroke takes using one of 
the two following methods, depending on which one you select:

 l Average: Harmony calculates the average direction of all of your mouse or pen gestures between the 
end of the actual drawing stroke and the current position of your mouse cursor or pen tip, and extends 
the stroke in this average direction, effectively evening out jitter and rounding sharp turns. 

 l Pulled String: When you start drawing a stroke, Harmony positions the drawing tool where your stroke 
starts. As you move the mouse or tablet pen, the drawing tool remains in that position, but a "string" 
appears, linking your drawing tool to your mouse cursor or pen tip.

This string has a certain maximum length. Once that length is reached, the string pulls the drawing tool 
in the direction of your mouse cursor or tablet pen.

NOTE 

The distance between your mouse cursor or tablet pen and the stroke can be adjusted. For 
the purpose of demonstration, these images were done using the largest supported 
distance.

Both methods allow you to cancel out the jittering and the small mistakes in your drawing strokes as you make 
them, rather than afterwards. But the two methods feel different:
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 l The Average method takes into account all your drawing gestures. Therefore, if you jitter a lot while 
drawing, your strokes may jitter a little. It is also tricky to create sharp corners with this method. 
However, this method tends to create very consistently smooth drawing curves. Also, since it actually 
follows the gesture of your mouse or tablet pen, you might find that this method feels more natural than 
the Pulled String method. 

 l The Pulled String method gives you more precise control, and can be used to make sharp corners with 
the right technique, but may be harder to learn and to master. Your drawing tool does not follow your 
drawing strokes, it just gets pulled in the direction of your mouse cursor or tablet pen, which means the 
way your drawing gestures translate into drawing strokes is different than what you're used to. 

You may need to do some trial and error to determine which method fits your drawing style the best. You can 
also customize the distance by which your drawing stroke trails behind your mouse cursor or tablet pen. A 
shorter distance will feel more natural, but a longer distance will stabilize your drawing strokes more. 

The Pen Stabilizer works with the  Brush,  Pencil,  Stamp and  Stroke tools. Optionally, it can also 
work with the  Eraser tool.
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Using Drawing Tool Stabilization
You can enable and configure pen stabilization using the Pen Settings toolbar. You may have to do some trial 
and error to find the settings that work for you and to get used to drawing with the stabilizer.

NOTE 

For more information on the Pen Settings toolbar,refer to the Reference Guide.

How to configure drawing tool stabilization

 1. Add the Pen Settings toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Pen Settings.

 l Right-click on any existing toolbar and, in the context menu, select Pen Settings.

 2. In the drop-down to the left of the toolbar, select one of the following Pen Stabilizer modes:

 l Average: Harmony calculates the average direction of all of your mouse or pen gestures 
between the end of the actual drawing stroke and the current position of your mouse cursor 
or pen tip, and extends the stroke in this average direction, effectively evening out jitter and 
rounding sharp turns. 

 l Pulled String: When you start drawing a stroke, Harmony positions the drawing tool where 
your stroke starts. As you move the mouse or tablet pen, the drawing tool remains in that 
position, but a "string" appears, linking your drawing tool to your mouse cursor or pen tip.

This string has a certain maximum length. Once that length is reached, the string pulls the 
drawing tool in the direction of your mouse cursor or tablet pen.

 3. In the field just right of the drop-down, select the stabilizer distance you want to use. You can enter 
a number between 0 and 100. You can also click and drag on the  left-right button right of the text 
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field to adjust its value.

NOTES 

 l This sets the distance by which your drawing tool trails behind your mouse cursor or 
tablet pen. The higher the distance, the more stabilized your drawing motions will 
be, but the harder it will be to draw sharp corners and precise shapes. 

 l For casual drawing, it is recommended to try values ranging between 5 and 20 at 
first. Higher values are more useful for drawing with a lot of minutia.

 4. Click on the  Stabilizer Settings button and:

 l If you selected the Average method and you want your drawing strokes to catch up with your 
tablet pen when you hold the pen tip against your tablet without moving it, make sure the 
Catch Up option is checked. Otherwise, uncheck it.

NOTE 

Stabilization makes your drawing stroke trail behind as you move your mouse 
cursor or tablet pen tip. This option makes your stroke catch up to your tablet pen 
when you hold it against the tablet without moving. This option only works when 
drawing with a tablet pen.

 l If you selected the Pulled String method and you want  the virtual string between your mouse 
cursor or pen tip and your drawing tool to display, make sure the Show String option is 
checked. Otherwise, uncheck it. 

 l If you want to use the pen stabilizer with the Eraser tool, make sure the Eraser option is 
checked. Otherwise, uncheck it.

 5. Try to draw in the Camera or Drawing view to test how your settings work out, and make 
adjustments as needed until you have the configuration that works best for you.

 6. When you want to disable pen stabilization, open the stabilization drop-down in the Pen Settings 
toolbar and select Stabilizer Off.
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About Pen Pressure Curve Customization
When you use a pressure-sensitive tablet with the Brush, Eraser, Pencil and Stamp tools, Harmony takes the 
amount of pressure you put on your tablet pen in account as you draw. It uses this information to determine the 
thickness of your drawing stroke. For example, while using the Brush tool, the harder you press on you tablet 
pen, the bigger your brush strokes will be, and vice versa.

To determine the thickness of your drawing strokes, it uses your drawing tool's Minimum Size and Maximum 
Size parameters, which can be set in the Tool Properties view. The thickness of your drawing stroke is always 
going to vary between those two parameters, based on how much pressure you put on your tablet pen.

By default, the size of your drawing strokes is directly proportional to the amount of pressure you put on your 
pen. It is calculated using this simple formula:

This means that if you apply 25% of the pressure your tablet pen can detect, the thickness of your drawing 
strokes will be 25% of the way between your tool's minimum size and its maximum size. Likewise, if you apply 
75% of the pressure your tablet pen can detect, the thickness of your drawing stroke will be 75% of the way 
between your tool's minimum size and its maximum size. 

Harmony allows you to customize the way it processes the pressure you put on your tablet pen into the 
thickness of your drawing strokes.  You can do this by tweaking the pressure curve in the Pen Pressure Feel 
dialog.

Depending on how you hold and use your tablet pen, this may allow you to have better control over the 
thickness of your drawing strokes. For example, if you tend to put a lot of pressure on your pen, you may want 
Harmony to let you draw thinner lines unless you apply even more pressure than you usually do. Likewise, if you 
tend to put very little pressure on your pen, you may want Harmony to generate thicker lines unless you apply 
even less pressure than you usually do.
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Customizing the Pen Pressure Curve
You can make adjustments to the curve used by Harmony to process the pressure from your tablet pen via the 
Pen Pressure Feel dialog, which can be accessed from the Pen Settings toolbar.

NOTE 

For more information on the Pen Pressure Feel dialog,refer to the Reference Guide.

How to customize the curve by which tablet pen pressure is applied to the size of your 
drawing tool

 1. Add the Pen Settings toolbar to your workspace by doing one of the following:

 l In the top menu, select Windows > Toolbars > Pen Settings.

 l Right-click on any existing toolbar and, in the context menu, select Pen Settings.

 2. In the Pen Settings toolbar, click on the  Pen Pressure Feel button.

The Pen Pressure Feel dialog appears.

 3. In the Tools toolbar, select either the  Brush tool.

NOTE 

The pressure curve affects all tools that supports pressure-sensitivity, such as the  
Brush tool,  the  Eraser tool and the  Stamp tool. However, you should use the  
Brush tool to test out your pressure settings. 

 4. Make sure that the minimum size of your drawing tool is low enough and that its maximum size is 

333



high enough that you can clearly see how the pen pressure affects the thickness of your lines.

TIP 

To do this, in the Tool Properties view, click on the  Show Extended Properties button 
to open the Brush or Pencil Properties dialog. Then, adjust the value of the Minimum 
Size and the Maximum Size sliders. 

 5. If you want to be able to lightly brush the tip of your tablet pen against your tablet without actually 
drawing, increase the value in the Min Pressure field. 

 6. If you don't want to have to press your tablet pen all the way down to draw in your drawing tool's 
maximum size, decrease the value in the Max Pressure field.

 7. To try a curve preset select one in the Curve Preset field. This will instantly change the shape of 
your pressure curve. 

 8. To adjust the shape of the curve manually:

 l Click and drag on the  leftmost   Bezier handle to change the shape of the curve from the 
leftmost point.

 l Click and drag on the  rightmost Bezier handle to change the shape of the curve from the 
rightmost point.

The following is a list of examples of how you can adjust the curve, depending on the way you use 
your tablet pen:

 l If you make an ease-in curve like the one below, the size of your drawing strokes will tend to 
be closer to the minimum size of your drawing tool, unless you apply a lot of pressure on your 
tablet pen.

 l If you make an ease-out curve like the one below, the size of your drawing strokes will tend to 
be closer to the maximum size of your drawing tool, unless you apply very little pressure on 
your tablet pen.
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 l If you make an ease-in-ease-out curve like the one below, the size of your drawing strokes 
will tend to be closer to the minimum size of your drawing tool when applying light pressure, 
and to be closer to the maximum size of your drawing tool when applying more pressure, but 
it will rarely be the median between the minimum and the maximum size.

 l If you make an ease-out-ease-in curve like the one below, the size of your drawing strokes 
will tend to be closer to median between the minimum and maximum size of your drawing 
tool, unless you apply very little or a lot of pressure on your tablet pen.

 9. Test out how your new settings feel by drawing strokes in the Camera or Drawing view, and make 
adjustments as needed until you have the configuration that works best for you.

335



About Drawing Guides
T-LAY-001A-001

Drawing guides are drawing aids that you can add to your scene to help you draw backgrounds and objects 
with straight lines, square angles and graphic projection effects such as isometric projection, straight 
perspective or curvilinear perspective. In traditional art, this is often done with tools such as rulers, T-squares, 
set squares and vanishing points. Guides allow you to simulate the use of such tools in combination with the 
drawing tools in Harmony.

Harmony supports different types of drawing guides, each designed for a different kind of drawing task. Most 
of Harmony's drawing guides work by adding a horizon line and vanishing points to your drawing space. While 
using a drawing guide, dotted guide lines appear through your mouse cursor. These guide lines are either 
parallel or perpendicular to the horizon line, or are going from one of the guide's vanishing points to your mouse 
cursor. When you start drawing a stroke, your drawing tool instantly becomes locked to one of the guide's axes, 
as if you were drawing against a ruler. Optionally, you can use drawing guides as mere visual references, 
without locking your drawing tool against their axes.

Harmony supports the following types of drawing guides:

 l The Ruler allows you to position and rotate a simple axis, then draw a line along that axis, like a regular 
ruler.

 l The Square Grid helps you draw lines that are either parallel or perpendicular to a horizon line.

 l The Isometric Perspective guide helps you draw lines that are parallel to one of three axes: The x-axis, 
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the y-axis and the z-axis. The angle of each axis can be customized as needed.

This type of pseudo-perspective, also referred to as parallel projection, is often used in 2D games, 
computer graphics and schematics to depict 3D objects and environments without using any actual 
perspective, foreshortening or 3D rendering. In 2D animation, it is often used to draw long panning 
backgrounds from a low or high angle. 

 

 l The 1-Point Perspective guide helps you draw lines coming from a single vanishing point in the middle 
of the horizon. It also helps you draw lines that are either parallel or perpendicular to the horizon line. 

This is useful for drawing cuboid structures that are facing the camera. 

 l The 2-Point Perspective guide helps you draw lines coming from one of two vanishing points, which are 
placed on the horizon line outside the camera field. It also helps you draw lines that are perpendicular to 
the horizon line. 

This is useful for drawing cuboid structures from a specific horizontal angle. 
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 l The 3-Point Perspective (Bird's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed below the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from an elevated point of view.

 l The 3-Point Perspective (Worm's Eye View) guide helps you draw lines coming from one of three 
vanishing points. Like with the 2-Point Perspective guide, two vanishing points are placed on the 
horizon line, which are used to draw horizontal lines on either the x-axis or the z-axis. The other 
vanishing point is placed above the horizon line to help draw lines on the y-axis.

This is useful for drawing cuboid structures from a low point of view. 
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 l The 3-Point Perspective (Horizontal Pan) guide helps you draw horizontally panoramic backgrounds, 
with curvilinear horizontal lines. A vanishing point is placed in the middle of the horizon line, to help 
draw lines on the z-axis, and two vanishing points are placed on the horizon line outside of the camera 
field, to define the curve of the horizontal lines. Vertical lines are made perpendicular to the horizon line. 

This is useful for drawing backgrounds meant to be panned over horizontally. Panning the camera 
horizontally over a background drawn with a 3-Point Perspective (Horizontal Pan) guide will simulate a 
rotation of the camera on the y-axis.

 l The 3-Point Perspective (Vertical Pan) guide helps you draw vertically panoramic backgrounds, with 
curvilinear vertical lines. A vanishing point is placed in the middle of the horizon line, to help draw lines 
on the z-axis, and two vanishing points are placed above and below the horizon line, outside of the 
camera field, to define the curve of the vertical lines. Horizontal lines are made parallel to the horizon 
line. 

This is useful for drawing background meant to be panned over vertically. Panning the camera vertically 
over a background drawn with a 3-Point Perspective (Vertical Pan) guide will simulate a vertical rotation 
of the camera on the x-axis. 
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 l The 4-Point Continuous Perspective guide is very similar to the 3 Point Perspective (Horizontal Pan) 
guide, except that it is designed to help draw full 360° panoramic backgrounds. 

This guide uses 5 vanishing points. When drawing a horizontal line, it is curved by arching over one of 
the vanishing points and reaching down to the two surrounding vanishing points. This creates a 
perspective effect where each vanishing point represents one of the cardinal points, except that the 
leftmost and the rightmost points represent the same cardinal point, effectively creating a looping 
background. Backgrounds made with the 4-Point Continuous Perspective guide can be looped 
horizontally to simulate a full rotation of the camera on the y-axis. 

 l The 4-Point Perspective (Vertical Pan) is a lot like the 2-Point Perspective guide, except that its 
vertical lines are curvilinear, so it can be used to make vertically panning backgrounds. Two vanishing 
points are on the horizon line, outside of the camera field, to help draw lines on the x-axis and the z-axis, 
and two vanishing points are placed above and below the camera field to define the curve of the vertical 
lines.
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This is useful for drawing backgrounds meant to be panned over vertically, in which cuboid objects are 
seen from an angle.

 l The 5-Point Perspective (Fish Eye) guide helps you draw backgrounds that are curvilinear on both the 
x-axis and the y-axis. It has one central vanishing point on the horizon line, from which lines on the z-
axis are drawn, two vanishing points at the extremities of its horizon line, to define the curve of the 
horizontal lines, and two vanishing points above and below the horizon line, to define the curve of the 
vertical lines. 

This guide can be used to draw backgrounds with a fisheye-style wide angle lens effect. It can also be 
used to draw backgrounds that are meant to be panned in various directions.

Guides are made to work with the following tools. To avoid cluttering your drawing space, they are only visible 
when one of these tools is selected:
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 l  Brush  

 l  Pencil  

 l  Stroke 

 l  Line 

To use a guide, you must add the Guides view to your workspace. Then, you can add the guide you wish to use 
to your scene's guides list. A newly added guide will have its horizon line and vanishing points in preset 
positions. You can rotate and reposition the horizon line as well as reposition the vanishing points to fit your 
scene's needs. When using curvilinear perspective guides, you can also adjust the Beziers of the curves to make 
them narrower or wider.

The Guides view allows you to have as many guides as you want, and each one will preserve the adjustments 
you make to it. In the Guides view, you can also select which guide you wish to use, rename, delete and reorder 
guides as needed, as well as cut, copy, paste, export and import guides between different scenes. 

NOTES 

 l The guide list, its guides and their individual parameters are saved with your scene. Hence, you 
can create a configure a guide specifically for the backgrounds and objects in your scene in one 
Harmony session, then reuse them exactly as you configured them in a later Harmony session.

 l Changes made to a guide or to the guide list can be undone with the Undo command. 
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Adding  Drawing Guides
T-LAY-001A-002

The first step in using drawing guides is to add a guide to the scene's guides list.

How to add a drawing guide to                                      your scene                 

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. Add the Guide view to your workspace by doing one of the following:

 l In the top-right corner of any view in your workspace, click on the  Add View button and 
select Guides.

 l In the top menu, select Windows > Guides. 

 3. In the Guides view, click on the  New Guide  button and choose one of the following types of 
guides:

 l  Ruler

 l  Square Grid

 l  Isometric Perspective

 l  1-Point Perspective

 l  2-Point Perspective
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 l  3-Point Perspective (Bird’s-Eye View)

 l  3-Point Perspective (Worm’s-Eye View)

 l  3-Point Perspective (Horizontal Pan)

 l  3-Point Perspective (Vertical Pan)

 l  4-Point Continuous Perspective

 l  4-Point Perspective (Vertical Pan)

 l  5-Point Perspective (Fisheye)

NOTE 

For information on each kind of guide in the list, see About Drawing Guides on page 336

The new guide appears in the guides list. 

NOTES 

 l Adding a guide automatically toggles the  Enable Guides option on, and automatically 
toggles the  Lock Guides option off, so that you can immediately view and adjust your 
new guide. 

 l Your new guide will come in a preset position with preset parameters. To make adjustments 
to your guide, see Editing Drawing Guides on page 349.
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Selecting the Active Drawing Guide
A Harmony scene can have several guides in its guides list, but you can only see, edit and use one guide at a 
time. You can decide which guide you're working with by selecting it from the guides list. The selected guide 
will display in your drawing space. 

When a guide is active, its horizon line, vanishing points and other visual elements will display in your drawing 
space. Also, dotted lines will follow your mouse cursor when you move it inside your drawing space. Each of 
these lines represents one of the axes of your drawing guide.

NOTE 

Although you can select the active guide at any time, a guide will only be visible, editable and 
usable if either the  Brush,  Pencil,  Stroke or  Line tool is selected.

How to select the active guide from the guides list

 1. In the Guides view, click on the desired guide in the guides list

The selected guide will become active in the Camera and Drawing views.
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NOTE 

If guides are disabled, clicking on a guide in the guides list will enable them.

How to quickly switch between guides using keyboard shortcuts

 1. Click on the tab for the Camera or Drawing view to set the focus on that view.

 2. Press the Up Arrow or Down Arrow key to select the previous or next guide in the list. 

NOTE 

Using the Up Arrow or Down Arrow to select a guide will only work if guides are already 
enabled.
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Renaming Drawing Guides
When adding a guide, it is automatically named after its guide type. Since you can have several guides of the 
same type in the same guides list, you might need to rename your guides to be able to easily differentiate them.

NOTE 

It is not required to give a unique name to each guide in the guides list.

How to rename a guide using the Guide Menu

 1. In the Guides view, select a guide from the list.

 2. Click on the  Menu button and select Rename Guide.

The Rename Guide dialog box appears.

 3. In the Rename Guide: field, type in a new name for the selected guide.

 4. Click on OK.

How to rename a guide using the Guide List

 1. In the Guides view, double-click on a guide displayed in the list.

The guide's name turns into a text input field.

347



 2. In the text field, type in the new name for the guide.

 3. Press Enter/Return.
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Editing Drawing Guides
T-LAY-001A-005

After a guide is added, it is configured with a preset position and angle for its horizon line, a preset position for 
its vanishing points, a preset size and, if applicable, preset Bezier curves. In many cases, you have to make 
adjustments to your guide so that you can use it to draw backgrounds and objects from the right point of view.

Different guides can be customized in different ways. This sections provides steps on how to customize each 
type of guide. 

NOTES 

 l You can view a guide and make changes to it directly in the Camera or Drawing view when the 
 Brush,  Pencil,  Stroke or  Line tool is selected. 

 l When you make a change to a guide, you can undo that change with the Undo command.

 l Changes made to guides are saved to your scene.
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Adjusting a Ruler Drawing Guide

The Ruler guide is simply a ruler. It has a single axis that you can position and rotate. You can draw along this 
axis as if you were drawing against a ruler. 

NOTE 

To add a Ruler guide to your scene, see Adding  Drawing Guides.

How to adjust a Ruler guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Ruler guide that you wish to make adjustments to.

The guide appears in the Camera or Drawing view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its offset handle .

TIP 

You can press and hold the Shift key to only move the guide horizontally or 
vertically relative to the camera angle. 

 l To rotate the guide, click and drag on one of its rotation handles . It will rotate around the 
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opposite rotation handle.

TIPS 

 l You can press and hold the Shift key to make the angle of the ruler snap to 
the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around its centre.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a Square Grid Drawing Guide

The Square Grid guide helps you draw lines that are either parallel or perpendicular to the horizon line. You can 
customize it by repositioning and rotating its horizon line.

NOTE 

To add a Square Grid guide to your scene, see Adding  Drawing Guides.

How to adjust a Square Grid guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Square Grid guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view. 

TIP 

To see the parallel and perpendicular reference lines, click on the  Show Reference 
Lines option button in the Guides view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its offset handle .

 l To rotate the guide, click and drag on its horizon line.
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TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.

353



Adjusting an Isometric Perspective Drawing Guide

The Isometric Perspective guide helps you draw lines that are parallel to one of three axes: the x-axis, the y-
axis and the z-axis. By default, the z-axis is at 26.565° from the horizon, the x-axis is at 153.435° from the 
horizon, and the y-axis is at 90° from the horizon. 

These specific angles are commonly used in video games and computer generated graphics, as lines in these 
angles do not require antialiasing to be properly rendered in pixels. The angle of all three of these axes can be 
adjusted independently as needed. For example:

 l You can achieve "true" isometric perspective, where the angle between each axis is equal, by setting the 
angle of the x-axis to -150° and the angle of the z-axis to -30°.

 l You can achieve cabinet-type oblique projection by setting the angle of the x-axis to -180°.

 l You can achieve military-type oblique projection by setting the angle of the x-axis to -135° and the 
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angle of the z-axis to -45°.

NOTE 

To add a Isometric Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust an Isometric Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  Isometric Perspective guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view.
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TIP 

To display the reference lines for the guide, click on the  Show Reference Lines option 
button on in the Guides view. 

 4. Do one of the following:

 l To reposition the guide, click and drag on the offset handle .

 l To adjust the angle of one of the axes, click and drag on the rotation handle  for that axis.

TIPS 

 l The angle of the axis you are adjusting will appear in the top-left corner of the 
Camera or Drawing view as you adjust it. 

 l You can hold the Shift key while rotating one of the axes to make it snap to 
the nearest angle that is a multiple of 5°. The x-axis and z-axis will also snap 
to 26.565° and 153.435°, which are their default angles.

 l To adjust the angle of both horizontal axes, press and hold the Alt key, then click and drag 
on the rotation handle of either the x-axis or the z-axis. 

TIP 

This will set the angle of both the x-axis and the z-axis to the same value, 
making your guide symmetrical.

 l To rotate the entire guide, press and hold the Alt key, then click and drag on the rotation 
handle of the y-axis. 
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Adjusting a 1-Point Perspective Drawing Guide

The 1-Point Perspective guide can help you draw backgrounds and objects with front-facing perspective. It 
provides a horizon line and a single vanishing point. The height and angle of the horizon line as well as the 
position of the vanishing point on the horizon line can be adjusted as needed. 

NOTE 

To add a 1-Point Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a 1-Point Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  1-Point Perspective guide that you wish to make adjustments to.

The selected guide appears in the Camera or Drawing view. 

 4. Do one of the following:

 l To reposition the guide without rotating it, click and drag on its vanishing point .

 l To rotate the guide, click and drag on its horizon line.
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TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 5. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 2-Points Perspective Drawing Guide

The 2-Points Perspective guide can help you draw backgrounds and objects seen from the ground, but at an 
angle. It provides a horizon line and two vanishing points, which are located outside of the camera field by 
default. The height and angle of the horizon line as well as the position of both vanishing points can be 
adjusted as needed.

NOTE 

To add a 2-Points Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a 2-Points Perspective guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  2-Points Perspective guide that you wish to make adjustments to. 

The selected guide appears in the Camera or Drawing view. 

NOTE 

The vanishing points for this guide are far outside of the camera field by default. You 
may need to zoom out in order to be able to see them.
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 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   and move it up 
or down. This will rotate the horizon line around the opposite vanishing point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that vanishing 
point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.
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Adjusting a 3-Points Perspective (Bird's-Eye View) Drawing Guide

The 3-Points Perspective (Bird's-Eye View) guide can help you draw backgrounds and objects with 
perspective from an elevated point of view. It provides a horizon line, which is located just underneath the 
camera field, and on which there are two vanishing points: one for drawing lines on the x-axis and one for 
drawing lines on the z-axis. Another vanishing point, used to draw lines on the y-axis, is located far above the 
camera field. 

The height and angle of the horizon line, the position of its two vanishing points as well as the position of the 
upper vanishing point can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Bird's-Eye View) guide to your scene, see Adding  Drawing Guides.

How to adjust a 3-Points Perspective (Bird's-Eye View) guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  3-Points Perspective (Bird's-Eye View) guide that you wish to make 
adjustments to. 

The selected guide appears in the Camera or Drawing view. 
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NOTE 

The horizon line and vanishing points for this guide are far outside of the camera field by 
default. You may need to zoom out in order to be able to see them.

 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   on the horizon 
line and move it up or down. This will rotate the horizon line around the opposite vanishing 
point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that vanishing 
point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.

 l To reposition the bottom vanishing point, click and drag on that vanishing point .

TIPS 

 l You can press and hold the Alt key to position the point on the axis that is 
perpendicular to the horizon line and in the middle of its two vanishing 
points. 

 l You can press and hold the Shift key to make the point only move horizontally 
or vertically relative to the camera angle. 
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Adjusting a 3-Points Perspective (Worm's Eye View) Drawing Guide

The 3-Points Perspective (Worm's-Eye View) guide can help you draw backgrounds and objects with 
perspective from an low point of view. It provides a horizon line, which is located just below the camera field, 
and on which there are two vanishing points: one for drawing lines on the x-axis and one for drawing lines on 
the z-axis. Another vanishing point, used to draw lines on the y-axis, is located far above the camera field. 

The height and angle of the horizon line, the position of its two vanishing points as well as the position of the 
lower vanishing point can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Worm's-Eye View) guide to your scene, see Adding  Drawing 
Guides.

How to adjust a 3-Points Perspective (Worm's-Eye View) guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the  3-Points Perspective (Worm's-Eye View) guide that you wish to 
make adjustments to. 

The selected guide appears in the Camera or Drawing view. 
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NOTE 

The horizon line and vanishing points for this guide are far outside of the camera field by 
default. You may need to zoom out in order to be able to see them.

 4. Do one of the following:

 l To move the horizon line along with the two vanishing points that are on it, click and drag on 
the horizon line.

 l To rotate the horizon line, click and drag on one of the two vanishing points   on the horizon 
line and move it up or down. This will rotate the horizon line around the opposite vanishing 
point.

TIPS 

 l You can press and hold the Shift key to make the angle of the horizon line 
snap to the nearest multiple of 15°.

 l You can press and hold the Alt key to make the guide rotate around the 
centre of its horizon line.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To reposition one of the vanishing points on the horizon line, click and drag on that vanishing 
point  and move it left or right. 

TIP 

You can press and hold the Alt key to make both points move simultaneously, so 
that they are both at the same distance from the centre of the horizon line.

 l To reposition the top vanishing point, click and drag on that vanishing point .

TIPS 

 l You can press and hold the Alt key to position the point on the axis that is 
perpendicular to the horizon line and in the middle of its two vanishing 
points. 

 l You can press and hold the Shift key to make the point only move horizontally 
or vertically relative to the camera angle. 
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Adjusting a 3-Points Perspective (Horizontal Pan) Drawing Guide

The 3-Points Perspective (Horizontal Guide) helps you draw backgrounds and objects with front-facing 
perspective and curvilinear horizontal lines. It provides a horizon line, a central vanishing point, used to draw 
lines on the z-axis, and two vanishing points at the extremities of the horizon line, used to draw curvilinear 
horizontal lines. 

The position and size of the guide, the height and angle of the horizon line, the distance of the outer vanishing 
points from the central vanishing point as well as the shape of the curves can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Horizontal Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a            3-Points Perspective (Horizontal Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the       3-Point Perspective (Horizontal Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the left and right vanishing points, click and drag on either 
one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide horizontally and make its curves wider or 
narrower.

 l To scale up the guide, press and hold Shift, then click and drag on either the left or right 
vanishing points .

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the green dots  in the top-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost top-right curve, and affect 
all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting the 3-Points Perspective (Vertical Pan) Drawing Guide

The 3-Points Perspective (Vertical Pan) Guide helps you draw backgrounds and objects with front facing 
perspective and curvilinear vertical lines. It provides a horizon line, a central vanishing point, used to draw lines 
on the z-axis, and two vanishing points above and below the horizon line, used to draw curvilinear vertical 
lines.

The position and size of the guide, the height and angle of the horizon line, the distance of the outer vanishing 
points from the horizon line as well as the shape the curves can be adjusted as needed.

NOTE 

To add a 3-Points Perspective (Vertical Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a             3-Points Perspective (Vertical Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        3-Point Perspective (Vertical Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the top and bottom vanishing points, click and drag on 
either one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide vertically and make its curves wider or 
narrower.

 l To scale up the guide, press and hold Shift, then click and drag on either the top or bottom 
vanishing points .

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the red dots  in the bottom-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost bottom-right curve, and 
affect all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 4-Points Continuous Perspective Drawing Guide

The 4-Points Continuous Perspective helps you draw backgrounds with perspective and curvilinear horizontal 
lines that span over up to four cardinal points, so as to make backgrounds that can be panned in a loop to 
simulate a 360° camera rotation. It provides a horizon line with five vanishing points spread evenly along it. 
Each vanishing point represents one cardinal point, except for the two vanishing points at the extremities, 
which represent the same cardinal point, adding up to four cardinal points.

The size and position of the guide, the height and angle of the horizon line, the distance between the 
vanishing points as well as the shape of the curves can be adjusted as needed.

NOTE 

To add a 4-Points Continuous Perspective guide to your scene, see Adding  Drawing Guides.

How to adjust a             4-Points Continuous Perspective                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        4-Point Continuous Perspective       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between the  vanishing points, click and drag on one of the two points 
 located left and right of the central vanishing point. 

NOTES 

 l All of the vanishing points on the horizon line will move so that they are at 
the same distance from each other.

 l This will stretch or squash the guide horizontally and make its curves wider or 
narrower.

 l To scale up the guide, press and hold Shift, then click and drag on one of the two points  
located left and right of the central vanishing point.

NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the green dots  in the top-right 
corner of the central part of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost top-right curve, and affect 
all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 4-Points Perspective (Vertical Pan) Drawing Guide

The 4-Points Perspective (Vertical Pan) guide helps you draw backgrounds and objects with perspective from 
an angle with curvilinear vertical lines. It provides a horizon line on which there are two vanishing points, one 
for drawing lines on the x-axis and the other for drawing lines on the z-axis. There are two more vanishing 
points above and below the horizon line, used to draw curvilinear vertical lines.

The position and size of the guide, the height and angle of the horizon line,  the position of the two vanishing 
points on the horizon line, the distance of the top and bottom vanishing points from the horizon line as well as 
the shape of the curves can be adjusted as needed.

NOTE 

To add a 4-Points Perspective (Vertical Pan) guide to your scene, see Adding  Drawing Guides.

How to adjust a             4-Points Perspective (Vertical Pan)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        4-Point Perspective (Vertical Pan)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 
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NOTE 

The vanishing points for this guide are far outside of the camera field by default. You 
may need to zoom out in order to be able to see them.

 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 

TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To adjust the distance between either one of the left and right vanishing points and the 
central vanishing point, click and drag on one of these points .

TIP 

You can press and hold the Alt key while dragging one of the outer vanishing 
points  to make both vanishing points move and keep both points at the same 
distance from the central vanishing point.

 l To adjust the distance between the top and bottom vanishing points, click and drag on 
either one of these points . 

NOTES 

 l The vanishing point at the other end will also move so as to keep both points 
at the same distance from the central vanishing point.

 l This will stretch or squash the guide  and make its curves wider or narrower.

 l To scale up the guide, press and hold Shift, then click and drag on one of the four outer 
vanishing points .
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NOTE 

If you previously adjusted the position of outer vanishing points relative to the 
central vanishing point, doing this will reset their position.

 l To skew the curves of the guide, click and drag on one of the red dots  in the bottom-right 
corner of the guide. 

NOTE 

These dots act as the Bezier handles of the outermost bottom-right curve, and 
affect all the curves of the guide.

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Adjusting a 5-Points Perspective (Fisheye) Drawing Guide

The 5-Points Perspective (Fisheye) guide helps you draw backgrounds and objects with both horizontal and 
vertical curvilinear perspective. It provides a horizon line, a central vanishing point, used to draw lines on the z-
axis, two vanishing points at the horizontal extremities, used to draw curvilinear horizontal lines, and two 
vanishing points at the vertical extremities, used to draw vertical lines.

The position, angle and size of the guide can be adjusted as needed.

NOTE 

To add a 5-Points Perspective (Fisheye) guide to your scene, see Adding  Drawing Guides.

How to adjust a             5-Points Perspective (Fisheye)                      guide

 1. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.

 2. In the Guides view, make sure that the  Enable Guides option button is toggled on.

 3. In the guides list, select the        5-Point Perspective (Fisheye)       guide that you wish to make 
adjustments to.

 4. In the Guides view, make sure the  Show Reference Lines option button is toggled on. This will 
allow you to see how the adjustments you make to your guide affect its curves. 

 5. Do one of the following:

 l To reposition the guide, click and drag on its central vanishing point .

 l To rotate the guide, click and drag on its horizon line. 
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TIPS 

 l When the mouse is positioned over the horizon line, the mouse cursor will 
change to  to indicate that you are about to rotate the guide.

 l When rotating a guide, its angle displays in the top-left corner of the Camera 
or Drawing view.

 l To scale up the guide, click and drag on one of the four outer vanishing points .

 6. Once you are done making adjustments to the guide, you can click on the  Lock Guides button in 
the Guides view so as to avoid accidentally modifying your guide while drawing.
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Locking Guides to Prevent Editing Them
T-LAY-001A-008

When using a drawing tool with a guide, you are also able to edit the guide's horizon line, vanishing points and 
other parameters by manipulating them in the Camera or Drawing view. Hence, it is possible to make changes 
to your guide by accident when drawing too close to one of its visual elements. Once you are done making 
adjustments to a guide, it is recommended to lock guides to be able to draw freely without having to worry 
about making accidental changes to your guides.

How to prevent editing of  Drawing Guides while drawing

 1. In the Guides view, click on the  Lock Guide  button. 

NOTES 

 l The Lock Guide option prevents editing all guides, not just the selected one. 

 l When adding a new guide, the Lock Guide option is automatically toggled off to allow the 
new guide to be edited immediately.
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Drawing with Drawing Guides
T-LAY-001A-006

When guides are enabled and a guide is selected, you can use this guide to assist you in drawing with precision 
or perspective. The guide will display dotted lines going through your mouse cursor as you move it inside the 
drawing space. Each of these lines represents one of the axes of the selected guide. 

When you start drawing a stroke, your drawing tool will automatically lock against the axis that most closely 
matches the angle of your stroke, forcing you to draw a straight line along that axis, as if you were using a ruler 
or a set square. 

NOTES 

 l Guides can only be used with the  Brush,  Pencil,  Stroke or  Line tool.

 l If the  Align with Guide option in the Guides view is toggled off, your mouse cursor will not 
lock against the axes in your guide. 

How to draw using guides

 1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing 
by doing one of the following:

 l Right-click on the cell and select Drawing > Create Empty Drawing.

 l Press Alt + Shift + R

 2. In the Tools toolbar, select either the  Brush,  Pencil,  Stroke or  Line tool.

NOTE 

Drawing guides are only visible in the Camera or Drawing view when one of these tools 
is selected.
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 3. In the Guides view, select the guide you wish to use.

 4. To avoid editing your guide by accident while drawing, make sure the  Lock Guides option is 
toggled on—see Locking Guides to Prevent Editing Them on page 376. 

 5. If you want your drawing strokes to be locked against the axes of your guide, make sure the  
Align with Guide option of the Guides view if toggled on. Otherwise, toggle it off to be able to draw 
freely and only use the guides as references—see Drawing Freehand Perspective with Drawing 
Guides on page 381.

 6. Move the mouse cursor around the drawing space. Observe that guide lines are going through your 
mouse cursor, one for each of the axes of the drawing guide.

 7. Start drawing a stroke roughly at the same angle as one of the axes.

If the  Align with Guide option is enabled, the drawing stroke aligns to the axis that is the closest 
to its angle, as if you were drawing against a ruler.
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TIPS 

 l You can also manually select which axis to lock onto—see Locking Drawing Strokes to a 
Specific Axis.

 l Whether you're drawing or not, you can lock the position and angle of the guide lines by 
pressing and holding the Alt key. The guide lines will stop following the mouse cursor, 
allowing you to keep them at a specific angle and position. This can be used to draw over 
the same line several times over so as to adjust its length and thickness. 
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Locking Drawing Strokes to a Specific Axis
T-LAY-001A-010

When using a drawing guide with the  Align with Guide option enabled, your drawing tool will 
automatically lock against one of the axes of your guide. Which axis it locks onto is the one that is the closest to 
the angle of your stroke as you start drawing.

If you want, you can manually select which axis to lock your drawing tool against, so as to avoid accidentally 
locking against the wrong axis. 

How to lock your drawing tool to a specific axis

 1. Set the focus to the Camera or Drawing view, for example, by clicking on the view's tab.

 2. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes. The 
selected axis will be displayed in bold across your mouse cursor.

All your drawing strokes will lock onto the selected axis. 

How to re-enable using all axes

 1. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes, until none of 
them are displayed in bold across your mouse cursor. 
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Drawing Freehand Perspective with Drawing Guides
By default, when drawing with a drawing guide active, your mouse cursor will lock against one of your guide's 
axes, forcing it to draw along the axis as if you were drawing against a ruler. 

If you want, you can disable this behaviour by turning off the  Align with Guide option, and only use your 
drawing guide as a visual reference. This can be useful if you want to draw with less rigid drawing style. 

When the Align with Guide option is disabled:

 l Your drawing tool will allow you to draw in any direction. 

 l The guide will still be visible, but will only serve as a visual aid. 

 l While drawing, the dotted line representing the axis you are drawing along will lock into place instead 
of following your mouse cursor, so that you can follow it as you draw.

How to draw freehand perspective

 1. In the Guides view, click on the Align with Guide  button to toggle it off

 2. Start drawing.
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Viewing Drawing Guide Reference Lines
T-LAY-001A-007

By default, a guide will only display its horizon line and its vanishing points, as well as dotted lines going 
through your mouse cursor to represent its axes. 

To help you lay out objects in your drawing, you can also enable reference lines. Reference lines are semi-
transparent lines displaying all over your drawing space, representing your guide's axes at different angles or 
distances.

When using reference lines, you can decide the amount of lines that display in your drawing space. If you have 
too many reference lines, they will be very close to each other and your drawing space might feel cluttered, but 
if you have too few, you might not always have a reference line close enough to the stroke you wish to draw to 
help serve as a reference.

How to view Drawing Guide Reference lines

 1. In the Guides view, click on the  Show Reference Lines  button to toggle it on.

The reference lines appear as a semi-transparent overlay all over your drawing space.

 2. In the Guides view, click and drag on the Number of Lines slider to adjust the amount of reference 
lines displayed in your drawing space.
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Minimizing Guide Cursor Axes Display
By default, the guide axes that are drawn across your mouse cursor extend throughout your entire drawing 
space. You may want those axes to only extend to a short distance around your cursor, so that they can still 
serve as guides without obstructing your drawing space or drawing your eye away from your mouse cursor. You 
can do this by disabling the  Full Cursor Display option, which is enabled by default.

When the Full Cursor Display option is disabled:

 l The axis lines displaying across your mouse cursor only span on a short distance from your mouse cursor.

 l When drawing a stroke, all axis lines disappear until you finish drawing the stroke. By default, only the 
axis you are drawing on disappears.

 l The actual axes used to lock your drawing tool still extend across the entire drawing space. This is 
strictly a visual option. 

How to minimize the Drawing Guide's cursor axes display

 1. In the Guides view, toggle the Full Cursor Display  button off. 

The guide axes now only span over a short distance from your mouse cursor.
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Erasing Using Drawing Guides
By default, drawing guides have no effect when using the  Eraser tool. If you want, you can enable using the 
Eraser tool with guides.

How to erase using a Drawing Guide

 1. In the Guides view, click on the  Enable Guide with Eraser button to toggle it on.

The  Eraser  tool will now  work with the currently selected guide, just like the  Brush,  
Pencil,  Stroke and  Line tools. 

 2. Start erasing.

NOTE 

When this option is enabled, it is also possible to make adjustments to your guide while the  
Eraser too is selected.
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Enabling and Disabling Drawing Guides
T-LAY-001A-009

Once you are done working with guides, you can disable them. When drawing guides are disabled, they are 
not displayed in your drawing space and do not affect the behaviour of your drawing tools. 

How to enable and disable drawing guides

 1. To enable or disable Drawing Guides, do one of the following: 

 l In the Guides view, click on the Enable Guide  button.

 l Press Shift + G.

NOTES 

 l Guides are automatically enabled when you add a new guide or when you select a guide in 
the guides list.

 l The guide that was selected when you disabled guides will be selected again when you re-
enable guides.

 l Drawing guides only work with the  Brush,  Pencil,  Stroke and  Line tools tools. 
If any other tool is selected, drawing guides will behave as if they are disabled. 
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Reordering Drawing Guide Lists
The drawing guides in your guides list can be reordered. 

How to reorder a Drawing Guide list

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows) or ⌘  (macOS) key and 
clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide in-
between will also be selected.

 2. Drag and drop the selected guides to their desired position in the list.
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Cutting and Pasting Drawing Guides
You can cut a drawing guide from your guides list and paste it into the guides list of another scene.

How to cut and paste drawing guides

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows) or ⌘  (macOS) key and 
clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide in-
between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Menu button and select Cut.

 l Press Ctrl + X (Windows/Linux) or ⌘  + X (macOS).

The selected guides are deleted from the list and stored in the clipboard.

 3. In the top menu, select File > Open and open a different Harmony scene.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guides, select the guide that will act as an insertion point.

 5. Do one of the folliowing:

 l In the Guides view, click on the  Menu button and select Paste.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Drawing Guides that were cut from the previous guides list are pasted in the current guides list.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.
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Copying & Pasting Drawing Guides
T-LAY-001A-004

You can copy drawing guides from your guides list and paste them into the guides list of another scene.

How to copy and paste drawing guides

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows) or ⌘  (macOS) key and 
clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide in-
between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Menu button and select Copy.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS).

 3. In the top menu, select File > Open and open a different Harmony scene.

 4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains 
guide, select a guide that will act as an insertion point.

 5. Do one of the folliowing:

 l In the Guides view, click on the  Menu button and select Paste.

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Drawing Guides that were copied from the previous guides list are pasted in the current guides list.

NOTE 

If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus 
is on the Guides view.
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Exporting and Importing Drawing Guides
You can export drawing guides from the current scene into a file, then and import them into another scene.

How to export drawing guides to a file

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows) or ⌘  (macOS) key and 
clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide in-
between will also be selected.

 2. In the Guides view, click on the  Menu button and select Export Selected Guides.

 3. In the Export Guides dialog box that appears, choose a destination folder, type in the name of the 
file you want to export, then click on Save.

The selected guides are exported to the destination file. A confirmation dialog box displays the 
amount of guides that were exported.

How to import drawing guides

 1. In the Timeline or Thumbnail view, select the destination panel. 

 2. In the Guides view, click on the  Menu button and select Import Guides.

 3. In the Import Guides dialog box that appears, browse to the folder in which you exported your 
guides, select the file in which you exported your guides and click on Open.

The guides that were stored in the file are inserted at the bottom of the guides list. A confirmation 
dialog box displays the amount of guides that were imported.

NOTE 

When importing a list of guides, duplicate guides are filtered out to avoid cluttering the list. The 
confirmation dialog box will specify if duplicates were detected and filtered out.
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Deleting Drawing Guides
T-LAY-001A-003

You can delete drawing guides from the guides list.

How to delete a Drawing Guide

 1. In the Guides view, select one or multiple guides from the list.

TIPS 

 l You can select multiple guides by holding the Ctrl (Windows) or ⌘  (macOS) key and 
clicking on each guide you want to select.

 l You can select a series of guide by holding the Shift key, clicking on the first guide 
you want to select, then clicking on the last guide you want to select. Every guide in-
between will also be selected.

 2. Do one of the following:

 l In the Guides view, click on the  Delete Guide  button

 l Press Del (Windows/Linux) or Backspace (macOS).

The selected guided are deleted from the list.
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About Drawing Optimization 
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those 
drawings to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to flatten 
your artwork or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected 
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change the 
appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an 
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging 
the transparent drawing objects will cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to 
be repainted later.
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Flattening Drawings
T-ANIMPA-002-006

The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By 
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will 
be easier if they are flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  
button in the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a 
pencil line. It also smooths out the shape.  

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  
button in the Tool Properties view.
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Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your 
drawings. This mainly means that transparencies will not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to optimize. 

 3. Do one of the following:

 l From the top menu, select Drawing > Optimize > Optimize.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Optimize. 

394

Harmony 17 Essentials User Guide                          



Chapter 5: Drawing

Reducing the Drawing Texture Resolution

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects whose texture 
resolution you wan to reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Reduce 
Drawing Texture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the 
drawings in your layer.

 6. Click OK.
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About Strokes Conversion 
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For 
many reasons, you may want to switch your stroke types to another type to use the various advantage set they 
offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes 
(strokes) to pencil lines. 

You can also break text objects apart—see Breaking Text Into Letters or Vector Shapes on page 314.
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Converting Brush Strokes to Pencil Lines 
The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. 
The brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or 
press ^.

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ^
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Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour strokes 
brush lines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or 
press &.

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &.
 

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l Select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + 
F12 (Windows/Linux only)
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Chapter 6: Painting and Colours
T-ANIMFX-003-001

Toon Boom Harmony Essentials has some very powerful painting features to add colour to your drawings. 
Whereas some other software only allow users to work with one colour swatch at a time, painting in Harmony 
is done by using palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You 
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 
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Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the 
mood and atmosphere of the scene without having to repaint each element.
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About Colour Swatches
T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap 
texture swatches.

A colour palette is an actual file on the hard drive. 
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Adding a Colour Swatch 
T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. Do one of the following to edit the colour swatch:

 l From the Colour view menu, select Colours  > Edit.

 l Double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's 
spectrum, then click on the desired colour in the colour wheel.

 l Enter the hue, saturation, value, red, green and blue values manually into their 
corresponding fields. All values range from 0 to 255. 

 l Click the Dropper  button to select any colour on your screen. It can be from the 
Harmony interface, your operating system or any other open application. 
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 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.

 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can 
quickly access it later.

 7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-
clicking on its name.

By default, when you create a new colour swatch, its colour will be the same as the currently selected colour 
swatch, or black if no colour swatch is selected. You can make Harmony create new colour swatches with a 
specific default colour instead. 
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Adding a Gradient Colour Swatch 
T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker window opens.

 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. In the Gradient slider, create your gradient:

 l To change one of the colours of your gradient, select a key colour from the gradient slider, 
then pick its colour in the colour picker.
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 l To add a key colours to your gradient, click anywhere on the colour slider, between the 
existing key colour.

 l To delete a key colour, use the mouse to pull down on it.

 l To move a key colour's position in the gradient, use the mouse to drag it left or right.

NOTE 

To learn how to reposition the gradient zones in your drawings, see About the Edit Gradient 
and Texture Tool on page 445.
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Adding a Texture Colour Swatch 
T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. This allows you to fill zones in your artwork with 
custom patterns and textures. 

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool 
instead of plaid, just update the texture file in the swatch and the entire project updates. Any 
transformation previously applied to the texture’s position in your drawings will be kept.

NOTE 

To learn how to reposition the textured zones in your drawings, see About the Edit Gradient 
and Texture Tool on page 445.
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Copying and Pasting Colours 
When you're creating palettes, you may want to copy colour swatches or their values and paste them in other 
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour 
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is 
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch 
from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the 
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V 
(Windows/Linux) or ⌘  + V (macOS).

 l To paste the colour values of the copied swatch over an existing colour swatch, select 
Colours > Paste Colour Values.
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How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch you want toget the ID from.

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS).

 3. Paste the copied value as plain text in the desired document.
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Deleting a Colour Swatch
T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will 
be displayed in red and the system will try to recover them the next time you load the scene. 

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Del.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.

411



Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Replacing Colours and Textures in Drawings
T-H15NEW-004-001

Although it is always possible to change colours and textures in existing drawings by updating the swatch in 
the palette, there may be situations where you want to replace a colour or texture in your drawings with a 
different colour or texture swatch, without updating the existing swatch. For example, you may want to only 
replace a colour with a different colour in specific drawings, but not in all the drawings that use the original 
colour, or you may want to replace a colour with a colour from a different palette without changing your 
palettes. 

Using the Recolour Drawing dialog, you can replace all instances of a colour or texture used in your drawings 
with a different colour or texture swatch. This will actually change the colours or textures from within the 
drawings, without making any changes to your palette. You can perform this operation on the currently 
selected drawing, on all drawings in the current layer or in all drawings in your scene.

How to recolour drawings

 1. First, make sure one of the palettes in your scene already has a swatch containing the colour or 
texture you want to replace the original colour with—see About Colour Swatches on page 403, 
About the Edit Gradient and Texture Tool and Adding a Texture Colour Swatch  on page 408.

 2. In the Timeline or Xsheet view, select the drawing or drawing layers you wish to recolour. 

NOTE 

You can select multiple layers if needed. 

NOTE 

You can skip this step if you intend to recolour all the drawings in your scene.

 3. In the Colour view, click on Show Colour Palettes  if you want to replace a colour, gradient or 
texture, or on Show Pencil Texture Palettes  if you want to replace a pencil texture. You can also 
click on Show All Palettes . 

 4. In the Colour view, select the colour or texture swatch you want to replace by doing one of the 
following:

 l Select the palette in which the colour or texture swatch is located, then select the swatch you 
wish to replace. 

 l If the drawing in the Camera or Drawing view contains the colour or texture you want to 
replace, select the Dropper  tool in the Tools toolbar, then click on that colour or texture in 
the drawing. The Colour view will automatically select that colour or texture's palette as well 
as that colour or texture's swatch.
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 5. Do one of the following:

 l Right-click on the swatches list, then select Recolour Drawings.

 l Open the Colour view menu , then select Colours > Recolour Drawings.

The Recolour Drawings dialog appears.

 6. In the Replace Colour In panel, select whether you want to replace the selected colour in the Current 
Drawing, in All drawings in the selected layers or in All drawings in the scene.

 7. In the palette list in the Replacement Colour panel, select the palette that contains the colour or 
texture swatch you want to replace the original colour or texture with.

 8. In the swatches list, select the colour or texture swatch you want to replace the original colour or 
texture with.

 9. Click OK.

A dialog displays showing the progress of the recolour operation. When finished, the original colour 
or texture is replaced with the replacement colour or texture in your drawing.
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Changing the Colour Display Mode 
The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The 
gradient colour swatches will be identified as (gradient). 
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About Palettes
T-ANIMPA-003-001

In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a base colour palette should be created for each character, prop and effect in the production. This 
is referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of 
red, green, blue and opacity (the latter which is referred to as alpha).

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production.

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this 
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the 
painted zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain 
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night 
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the 
mood and atmosphere of the scene without having to repaint each element.
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In Harmony, colour palettes are individual *.plt files that are stored in each scene's palette-library folder 
and which can be copied, transferred and imported as needed.
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About Scene and Element Palette Lists

By default, you can only add palettes to a scene's palette list. With the Advanced Palette Lists preference 
enabled, you can choose to store add palettes to the palette list of individual elements if you choose. Here is an 
explanation of the two different levels of palette lists:

 l Scene palette list: This palette list and its palettes are available for and can be used in all of the scene's 
elements. Hence, it is the most simple and least restrictive approach, and is the type of palette used by 
Harmony when Advanced Palette Lists mode is disabled. It is most recommended to add your palettes 
to your scene's palette list if you are doing digital animation, where character models can be made of 
many different elements that must use the same palette. 

 l Element palette list: A palette list associated with a single element in your scene. An element is the 
container for the drawings used by a drawing layer. Hence, when an element has a palette list with its 
own palettes, only the drawings in that element can use the colours in these palettes, and the palettes 
in this element's palette list will only be shown in the Colour view when a drawing from this element is 
selected. 

Using element palette lists as certain advantages, depending on your type of production:

 l In paperless and traditional animation projects, characters are usually drawn on single elements. Hence, 
you can use this to associate characters in a scene to their colour palette.

 l If a scene requires a lot of palettes, linking those palettes only to elements that need them rather than to 
the whole scene can help declutter your palette list. 

 l When a palette and its clone are in the scene's palette list, Harmony will only use whichever palette is 
highest in the list. If you want one element to use the original palette and another element to use the 
cloned palette, you can do so by adding the right palette to each element's palette list.
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About the Palette List
T-ANIMPA-003-006

A palette list is a file containing all of the links to the palette files. Each scene created has its own palette list, 
and every element in your scene can use colours from any palette in your scene's palette list.
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Showing and Hiding the Palette List

By default, the palette list is enabled. If you want to only use one palette for all of your scenes, you can disable 
the palette list simply by collapsing it, which will give more vertical space to your colour swatch list:

How to show or hide the palette list

 1. In the Colour view, right over the palettes list, click on the expand/collapse arrow to expand or 
collapse the palettes list. 
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Creating a Palette
T-ANIMPA-003-002 

You can create a palette in either Basic or Advanced mode.

      How to create a new palette 

 1. Do one of the following:

 l In the Colour View, click the New Palette  button over the palette list.

 l From the Colour view menu, select Palettes  > New

The Create Palette dialog box opens.

 2. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains 
information to be easy to identify, such as the name of the character and information about the type 
of setting for this palette, if any.

 3. Click OK.

The palette appears in the drawing element’s palette list.
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Importing a Colour Palette
T-ANIMPA-003-005

You can import an existing palette from your file system or network into your scene. This will create a copy of 
the palette file and add it to your palette list. 

How to import a palette into your project                

 1. Do one of the following:

 l In the Colour view, click on the Import  button.

 l From the Colour menu , select Palettes > Import. 

 l Right-click on the palette list and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes 
by browsing to the palette-library sub-folder of the scene's folder.

 3. Click Open.

The palette is copied to your project and added to your scene's palette list.
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Renaming a Palette
T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not 
be deleted, so you can add it back to your palette list later if you need it. 

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Palette 
A duplicated palette is a simple copy of the original palette. When you duplicate a palette, the duplicated 
palette will have the same colour names and values, but will have different colour IDs so that Harmony does not 
mix it up with its original palette. This is useful when you want to create different palettes for similar models, 
but want to avoid having to create the palette and its colours all over again. You can just start with your 
duplicate palette, tweak the colours and  add and remove colours as needed.

How to duplicate a palette                 

 1. In the Colour view, select a palette to duplicate.

 2. Do one of the following: From the Colour  menu, select Palettes > Duplicateor right-click and select 
Duplicate.

 l Right-click on the palette and select Duplicate.

 l Open the Colour menu , then select  select Palettes > Duplicate.

The Duplicate palette dialog box opens

 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is 
based on the original palette name followed by "-copy". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 

 4. Click OK.

The duplicated palette appears in the palette list.
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Cloning a Palette 
Cloning a palette creates an exact copy of the palette, where each colour swatch has the same colour ID as in 
the original palette, but which you can modify independently afterward. Since painted zones in drawings are 
associated to their colour by their colour ID, this means that any drawing colored with the original palette can 
have its colours replaced with the cloned palette's colours just by switching the palette in the scene with the 
cloned palette. 

A good example of how this can be useful is when you want to make variants of a character's palette. A 
character usually has only one master palette, although there are times when the characters are placed in 
different lighting conditions and require a different colour shading. The night palette is a popular choice when a 
scene or sequence changes from day to night. Instead of creating a different palette for the character and 
repainting all of its zones with the night palette, you can just clone the character's master palette, tweak its 
colours, and the character will have its original colours or its night colours depending on which one of the 
palettes is in the palette list, without having to repaint your drawings. 

When a palette and its clone are present in the same scene, Harmony uses the palette that is highest in the 
list. If one palette clone is present in the scene's palette list and another clone is present in the element's 
palette list, the element will use the palette in its own palette list. 

How to clone a palette                 

 1. In the Colour view, select a palette to clone.

 2. Do one of the following: From the Colour  menu, select Palettes > Clone or right-click and select 
Clone.

 l Right-click on the palette and select Clone.

 l Open the Colour menu , then select  select Palettes > Clone.

The Clone palette dialog box opens
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 3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is 
based on the original palette name followed by "-clone". The palette list above this field lists the 
palettes that already exist in the selected location. Make sure you enter a name that is not already 
used by another palette. 

 4. Click OK.

The cloned palette appears in the palette list.

NOTE 

You can modify your cloned palette by changing its colour swatches individually, or you can use the 
Tint Panel to change all of the palette's colour swatches simultaneously—see Tinting a Palette's 
Colour Swatches on page 428.
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Tinting a Palette's Colour Swatches
You can use the Tint Panel dialog to offset, blend or mix all the different colour swatches in a palette 
simultaneously. This can be useful if you want to give a cloned palette a different tint, for example to make a 
night-themed version of a character's master palette. 

How to tint a palette

 1. In the Palette list, select the palette you want to tint.

 2. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

 3. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

 4. Offset, blend, or mix the colours using the sliders and increasing the Amount value.
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 5. Select the Preview option to see a preview of the colours while you adjust them.
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Reordering Palettes in the Palette List
You may want your palettes to be listed in a specific order. In a lot of cases, this is strictly a matter of 
convenience. However, if your palette list contains palettes that have been cloned off each other, Harmony will 
use the palette that is located the highest in the list to determine the colours to use in the drawings. Hence, if 
you are using cloned palettes, you must mind the order of your palettes in the palette list. For more information, 
see Cloning a Palette  on page 426.

How to reorder palettes in the palette list

 1. Select the palette you wish to reorder.

 2. Do one of the following:

 l In the Palette list toolbar, click the Up  or Down  buttos.

 l From the Colour View menu, select Palettes > Move Up or Move Down. 
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that 
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, 
and so on.

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and 
paint process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do 
not belong in the drawing, extra floating artwork around the drawing that must be removed), painting the 
lines and filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean, 
only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning 
a set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a 
new colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is 
known as a colour swatch—see About Palettes on page 416. 
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Flipping Between Models

T-LAY-002-001

Once your models are loaded in the Model view, you can flip through them using a keyboard shortcut or toolbar 
buttons.

How to flip between models

 1. Do one of the following:

 l In the Model View toolbar, click the Next Model   or Previous Model  buttons.

 l From the Model View menu, select Next Model or Previous Model. 

 l Press F and G.

The previous or next model appears in the Model view.
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Copying Colour Models

You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. In the Model View toolbar, select the Select  tool.

 2. In the Model view, select your model.

 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing 
Object, or select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline 
or press Ctrl + V (Windows/Linux) or ⌘  + V (macOS). 

The model appears in the selected view.

How to copy part of the model from the Model view

 1. In the Model View toolbar, select the Cutter  tool or press Alt + T.

 2. In the Model view, use the Cutter tool to create a selection around the part of your model that you 
want to copy.
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 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C 
(macOS).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the following:

 l Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

 l Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V 
(Windows/Linux) or ⌘  + V (macOS). 

The model appears in the selected view.
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Painting Drawings
T-HFND-004-011

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several 
different modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines 
defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap 
option.

NOTE 

To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. In the Timeline or Xsheet view, select the cell on which you want to paint.

 2. Do one of the following:

 l In the Tools toolbar, click the Paint  tool.

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and filled zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or filled zone will 
remain unchanged.
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 l The Unpaint   mode unpaints everything it touches, including empty and filled 
zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a 
lasso or marquee selection to paint several zones or pencil lines at the same time.

NOTE 

The last colour you select while using the Paint tool will be used the next time you 
select the Paint tool if you're using the unlocked painting tools in the Colour view.

436

Harmony 17 Essentials User Guide                          



Chapter 6: Painting and Colours

Authors

Marie-Eve Chartrand
        Christopher Diaz

chrisdiazart.com

437

http://www.chrisdiazart.com/


Painting Several Drawings Simultaneously

You can use the Paint tool on several drawings in the same layer at the same time. When you set up the Paint 
tool to work on several drawings, if you click on a colour zone in the current  drawing to fill it, it will fill any colour 
zone located where you clicked in other drawings as well. This can be useful if you have several drawings with 
colour zones that mostly overlap each other, such as in a typical walk cycle, or in any animation where the 
character mostly stays in place:

There are two approaches to painting several drawings at the same time. Both are options available in the Tool 
Properties view:

 l  Apply to All Frames: When you click on a colour zone in the Camera or Drawing view, it will fill the 
area you clicked on in every exposed drawing in the current layer.

 l  Apply to Onion Skin Range: When you click on a colour zone in the Camera or Drawing view, it will 
fill the area you clicked on in every drawing that is displayed in the Onion Skin. This method allows you 
to only fill a specific range of drawings, and allows you to see those drawings in the Camera or Drawing 
view as you fill them.

How to paint a specific range of drawings simultaneously

 1. In the Timeline or Xsheet view, select a drawing somewhere in the middle of the range of drawings 
you want to paint.

 2. In the Tools toolbar, click on the  Onion Skin button to enable Onion Skin.

 3. Adjust the range of the Onion Skin so that it covers every drawing you want to paint:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
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next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.

The drawings included in the Onion Skin range will appear in red and green in the Camera or 
Drawing view. 

 4. In the Tools toolbar, select the  Paint tool. 

 5. In the Tool Properties view, click and hold on the  Apply to All Frames button and, in the pop-up 
menu, select  Apply to Onion Skin Range. 

NOTE 

If this button is already set to  Apply to Onion Skin Range, simply click on it to toggle 
it on.

 6. In the  Camera or Drawing view, click in an area where the colour zones for all the drawings in the 
Onion Skin overlap each other to fill them all simultaneously. 

How to paint all exposed drawings in a layer simultaneously

 1. In the Timeline or Xsheet view, select any of the drawings in the layer that you want to paint. 

 2. In the Tools toolbar, select the  Paint tool. 

 3. In the Tool Properties view, click on the  Apply to All Frames button to enable the Apply to All 
Frames mode. 

NOTE 

If this button is currently set to  Apply to Onion Skin Range mode, click and hold on 
the button to open its pop-up menu and select  Apply to All Frames.

 4. In the Camera or Drawing view, click in an area where the colour zones for most or all of your 
drawings overlap each other to fill them all simultaneously. 
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Painting Several Layers Simultaneously

You can use the Paint tool to fill drawings in several layers simultaneously. When you set up the Paint tool to 
work on several layers, if you click on a colour zone in the current  drawing to fill it, it will fill any colour zone 
located where you clicked in the drawings in the other layers as well. 

NOTE 

You can only paint several layers simultaneously in the Camera view. 

How to paint a drawing in several specific layers simultaneously

 1. Do one of the following:

 l In the Timeline view, move the red Timeline playhead to the frame where all the drawings 
you want to paint are exposed. 

 l In the Timeline or Xsheet view, select one of the drawings you want to paint. 

 2. In the Tools toolbar, select the  Paint tool.

 3. In the Tool Properties view, make sure the  Apply to All Visible Layers button is toggled off. 

 4. In the Timeline or Xsheet view, select all the layers you want to paint simultaneously. 

TIPS 

 l To select multiple layers, press and hold the Ctrl (Windows/Linux) or ⌘  (macOS) 
key, then click on each layer you want to select.

 l In the Timeline or Xsheet view, you can select a contiguous series of layers by clicking 
on the first layer you want to select, then, while holding Shift, clicking on the last 
layer you want to select. Every layer in-between will also be selected. 

NOTE 

If  Light Table is enabled, the selected layers will appear fully opaque. This indicates 
that the currently selected tool can work on all selected layers simultaneously. 

At this point, you can paint artwork in all of the selected layers. 

 5. In the Camera view, click in an area where the colour zones for the drawings in the selected layers 
overlap each other to fill them simultaneously. 
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Repainting

T-ANIMPA-011-004

You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.  

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint a 
section by manually painting over the lines. This is useful when the vectorization triangles are not placed as you 
would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, where 
there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will 
only show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are not 
added one on top of each other. 

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Camera or Drawing view, draw on the zones to repaint.
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Selecting Strokes with the Current Colour

You can select zones painted with a specific colour swatch.

How to select the zones painted with the current colour

 1. In the Colour view, select the colour from which you want to select the corresponding zones.

 2. Do one of the following:

 l Select Drawing > Select Strokes With Current Colour. 

 l Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (macOS).
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Closing Gaps
T-HFND-004-014

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.

The Close Gap tool allows you to close small gaps in a drawing by creating small, invisible strokes between the 
two closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View > Show > Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be 
flattened with your artwork. They will cut overlapping drawing strokes in two pieces.

The gap automatically closes.
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Picking a Colour with the Dropper Tool
T-ANIMPA-011-002

While working in the Camera or Drawing view, you can use the Dropper  tool to pick a colour from your drawing 
without going to the Colour view. 

How to use the Dropper tool

 1. Do one of the following:

 l In the Tools toolbar, select the Dropper  tool.

 l From the top menu, select Drawing > Drawing Tools > Dropper.

 l Press Alt + D. 

 2. In the Camera or Drawing view, click on the desired colour.

 l If you're using another drawing tool such as the Paint tool, you can temporarily hold 
down the D key and click in your drawing before releasing the key to pick your colour. 
When you release the key,  you will return to your previous tool. You may also want to 
select the zones painted with the colour currently selected in the Colour view. This can 
be useful for removing rough lines from a clean drawing.
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About the Edit Gradient and Texture Tool
T-HFND-006-019

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set 
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you 
can select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s 
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them 
afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with 
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both 
elements independently at the same time.

NOTE 

For information on the Edit Gradient/Texture tool properties, see the Reference Guide
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Using the Edit Gradient and Texture Tool 

T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Chapter 7: Paperless Animation
T-HFND-006-001

Toon Boom Harmony Essentials is a powerful paperless animation software that incorporates animation and 
drawing tools to make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles of 
animation still apply. 

One of the advantages of working with paperless animation is that you do not lose time scanning elements in 
and testing them because everything is already digital. You can simply draw your animation and play back your 
line test right away. This also saves the substantial amount of paper required by traditional animation. Another 
practical advantage is the ability to undo and redo some actions that are often difficult on paper, such as 
erasing brush strokes.

NOTE 

When you draw on an empty cell, Harmony automatically creates a drawing that spans over a 
single frame in that cell. You can adjust that drawing's timing as needed afterward. However, it is 
possible to create, name and set the timing of each drawing before creating your animation, which 
can help organize your workflow. For more information, see Timing on page 129.
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Creating a Rough Animation
T-LAY-003-005

The first step to create paperless animation is the rough construction, which is the skeleton of your animation. 
You would usually start by animating the most important part of a character's action. For example, to animate a 
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and 
clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the 
details when you're satisfied with the movement. If you start animating all the details right away, you will lose a 
lot of time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. In the top row of the Timeline view, click on  Show All Thumbnails  to enable Thumbnail mode. 

 2. In the Tools toolbar, select the  Brush  tool or press Alt + B.

 3. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your 
rough animation. This will make the clean up process easier as your clean dark lines will contrast 
with your light sketch lines. 
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 4. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 5. In the Camera or Drawing view, draw the first key drawing.

As soon as you draw your first drawing stroke, a drawing is automatically created in the cell you 
selected.

 6. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of 
the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.

 7. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.
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 8. In the Tools toolbar, click the  Onion Skin  button. This will display the previous and next 
drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you 
can use them as references to draw new drawings with accuracy. This can be useful to draw 
breakdown poses between two key poses, or to add an in-between drawing between two other 
drawings.

 9. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing 
on it. To do this, do one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the 
green onion skin marker to make it include the next drawings you want to display in 
the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous 
and next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  
Remove Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.
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 l To decrease the amount of next drawings to display, click on the  Remove 
Next Drawing button in the Camera/Drawing view toolbar.

 10. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the  Create Empty Drawing  button.

 l Press Alt + Shift + R.

 11. In the Camera or Drawing view, draw your second key drawing.

 12. In the Timeline or Xsheet view, select a cell between the two key drawings. 

 13. Using the onion skin markers, ensure the onion skin covers both your first and last drawings.
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 14. Create a new empty drawing by doing one of the following:

 l In the Timeline or Xsheet toolbar, click on the  Create Empty Drawing  button.

 l Press Alt + Shift + R.

 15. In the Camera or Drawing view, draw your new pose.

 16. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new 
drawing.

NOTE 

When working with overlay layers in the Camera view, you can enable the  Current 
Drawing on Top  option in the status bar below the Camera view to make the layer you're 
working on appear over other layers. 
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Creating the Tie Down Animation
Once your rough animation  is correct, you can start adding extra details, such as arms, clothes or hair. You can 
add the extra details on the same layer with the same colour or you can also create a new colour so that you can 
always see your original sketch.

If your primary and secondary animation were done as a rough drawing, it is now time to put your drawing on 
model, also known as tie down. This means that you have to review your animation and ensure that every 
single detail is on model and there is no volume distortion. You can do this directly on the original sketch layer 
or on a new layer.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing element 
and use the Light Table feature to draw over the first drawing element. This technique can also be used if you 
want to reuse your rough animation for other characters. For example, if you have a rough walk-cycle, you can 
reuse it for another character and add its personal features in a new layer. This way, you only need to animate 
the secondary animation instead of the whole body again. 
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How to create secondary animation on the same layer

 1. In the Xsheet or Timeline view, select the cell in which you want to add new details.

 2. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

 3. In the Drawing Tools toolbar, select your drawing tool.

 4. In the Camera or Drawing view, draw the secondary animation.

 5. Do one of the following:

 l In the Xsheet or Timeline view, select the next cell in which you want to draw.

 l Press F and G to navigate between your drawings.

 6. Do one of the following:

 l Select View > Onion Skin > Show Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 7. Extend the onion skin.

 8. In the Camera or Drawing view, draw the secondary animation.
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 9. You can also use the Playback toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

 1. Add a new drawing layer and name it secondary_animation.

 2. In the Timeline or Xsheet view, select the rough layer's timing.

 3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘  
+ B (macOS).

 4. Choose Never create drawing files from the options to paste the timing but not the drawing files.

 5. If you are working in the Drawing view, in the Drawing View toolbar, enable the Light Table.

 6. In the Xsheet or Timeline view, select the cell where you want to add the new details.
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 7. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for 
example) or select the same rough colour as before.

 8. In the Tools toolbar, select your drawing tool.

 9. In the Drawing or Camera view, draw the secondary animation on top of your rough drawing.

 10. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

 11. Do one of the following:

 l In the top, Drawing View or Camera View menu, select View > Onion Skin > Show 
Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 12. Extend the onion skin.

 13. In the Camera or Drawing view, draw the next secondary animation.

 14. You can also use the Playback toolbar to play the animation in real time.
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Cleaning Animation
T-HFND-006-010

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It 
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless 
animation step before the ink and paint step.

You will need to add a new drawing layer to create your clean drawing. This is the equivalent of adding a sheet 
of paper and tracing the rough using the animation disk. This allows you to keep the roughs and the cleans 
intact. You only need to lock the rough layer to prevent it from appearing in the scene. 

If you plan on tracing your animation in the Drawing view, use the light table to display all the layers in your 
project.

How to trace animation in a new layer

 1. In the Layer toolbar, click the Add Drawing Layer  button and add a new layer.

 2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid 
selecting the layer in the Camera view.

 3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key 
drawing of your rough animation.

 4. In the Tools toolbar, select the drawing tool of your choice. The Pencil  tool is recommended.

 5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, would 
ensure that it contrasts well with the light colour of your rough animation.

 6. In the Camera or Drawing view, start tracing the first key drawing.
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 7. If you have some other layers in the way, you can disable them temporarily from the Timeline view 
so that only the rough animation and clean-up layer are displayed in the Camera view. 

 8. In the Tools toolbar, click the Onion Skin  button and pull on the blue onion skin handles in the 
Timeline view to extend the number of frames you can see.

 9. Use the buttons in the toolbar above the drawing space to adjust how many previous and next 
drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next Drawing 
button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next Drawing 
button in the Camera/Drawing view toolbar.

 10. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 11. In the Drawing or Camera view, trace your next drawing.
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 12. Repeat the previous steps for each drawing.
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Paperless Animation Tools
To understand paperless animation, you must first discover the tools available. There are, of course, drawing 
tools, but also practical features such as setting a drawing as a key, breakdown or in-between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work 
efficiently, as you would with an animation table, paper and pencils. 

The onion skin and light table are used to preview previous and next drawings, cells, elements and frames. 
When designing or animating, it is very useful to see your previous drawings. Just as if you were building a cut-
out puppet, you want to view other drawing elements to know where to draw the new element. 

Harmony has many useful advanced features such as the Flipping toolbar, enhanced onion skin, extra drawing 
layers, and automated matte generation.
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Displaying Drawing Thumbnails in the Timeline View
T-ANIMPA-006-003

In the Timeline view, it is possible to preview the drawings in your scene by enabling the display of thumbnails 
for your drawing layers. You can display the thumbnail for all drawing layers or for individual drawing layers. 
This allows you to preview the drawing in the current frame as well as drawings exposed in every frame of your 
scene, which can be useful for managing your drawings and for adjusting their timing.

You can enable Thumbnails for all drawing layers simultaneously or for individual drawing layers. When 
thumbnails are displayed for a layer, the Timeline view also displays the name of each drawing as well as the 
amount of frames on which each drawing is exposed for that layer. Enabling thumbnails on a layer also gives 
access to that layer's Opacity parameter in the left panel of the Timeline view. 

How to display or hide thumbnails for all drawing layers

 1. In the Layers toolbar of the Timeline view, click on the Show/Hide All Thumbnails  button
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How to display or hide thumbnails for a specific drawing layer

 1. Do one of the following: 

 l In the Timeline view, left of the layer's name, click on the Show/Hide Thumbnails  button.

 l In the Timeline view, select the layer and press T.

Even when thumbnails are displayed for a layer, it is likely that you won't be able to see the full thumbnails for 
individual drawings that are exposed over 1 or 2 frames because, by default, frames are not large enough to 
display their thumbnails. To make the frames larger so that thumbnails have enough horizontal space to be 
displayed, you must zoom in on the Timeline view.

How to zoom in on the Timeline view.

 1. Set the focus on the Timeline view, for example by clicking on the Timeline view tab.

 2. Do one of the following:

 l Drag the Timeline Zoom  slider to the right.

 l Click on the Timeline view's tab, then press 2 repeatedly. 

 l Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘  (macOS) 
and roll the mouse wheel up.
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TIP 

If you animate mostly on twos or threes, you can adjust the Timeline zoom to fully display the 
thumbnails of drawings exposed over two or three frames, or you can zoom in enough to 
display the thumbnails of drawings exposed over a single frame, depending on your 
preference.

TIP 

To reset the Timeline Zoom to its default zoom level, click on the Reset Zoom  icon left of the 
Timeline Zoom slider.

NOTE 

When zoomed in on the Timeline view, you can tweak the exposure of your drawing by dragging 
the edges of the drawings with your mouse cursor. This is especially useful when displaying 
thumbnails as you can visually adjust the timing of your animation. For more information, see About 
Rippling and Overwriting the Exposure in the Timeline View.
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About Onion Skin
One of the most basic techniques of  traditional animation is to place two drawings on a light table, put an 
animation sheet over them and draw between the outlines of the two drawings to make an in-between. In 
Harmony, this technique is streamlined with Onion Skin.

Onion Skin is a powerful feature in Harmony that allows you to display the drawings surrounding your current 
drawing in washed, semi-transparent outlines so as to help you use them as reference to make your poses, your 
breakdowns and your in-betweens. 

Onion Skin works in both the Camera and Drawing view. When using Onion Skin, you can choose to include 
one or several drawings before, after or both before and after the current drawing. By default, drawings before 
the current drawing appear in red, and drawings after the current drawing appear in green. 
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Enabling the Onion Skin

You can enable the onion skin to see your previous and next drawings as reference.  

NOTE 

You can modify the onion skin display in the Preferences panel.

How to enable the onion skin

 1. In the Timeline view, select the layer you want to draw on and the frame in which you want to draw.

 2. Do one of the following:

 l In the Tools toolbar, click on the   Onion Skin button.

 l In the Timeline view, click on the   Onion Skin button left of the layer name.

 l In the top menu, select View > Onion Skin > Show Onion Skin.

 l Press Alt + O.

Onion Skin will be enabled. By default, it will display two frames before and two drawings after the 
current drawing.
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Selecting Drawings to Display in Onion Skin

When you enable Onion Skin, by default, it will display two drawings before the current drawing and two 
drawings after the current drawing. You can adjust how many drawings before and after the current drawing 
to display. There are two methods to doing this:

 l Adjusting the Onion Skin handles in the Timeline view. When Onion Skin is enabled, a red handle and a 
green handle appear before and after the red playhead in the Timeline view. Those handles indicate 
and allow you to adjust the range of drawings displayed in the Onion Skin.

 l Using the     toolbar buttons or menu commands to add or remove drawings from the Onion 
Skin one at a time.

NOTE 

If you choose to include drawings to display in the Onion Skin by drawing instead of by frame, you 
cannot use the Onion Skin handles in the Timeline view—see Selecting Drawings to Include in 
Onion Skin by Frames or by Drawings.

How to select drawings to display in the Onion Skin using the Onion Skin handles in the 
Timeline view

 1. Select the layer you want to draw on, the frame in which you want to draw, and enable Onion 
Skin—see Enabling the Onion Skin.

Blue handles appear on each side of the Timeline play head.

All the drawings in the current layer over which these handles span are included in the Onion Skin.
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 2. Click on the handle left of the play head and drag it so that it includes only and all the previous 
drawings you want to display in the Onion Skin.

 3. Click on the handle right of the play head and drag it so that it includes only and all the next 
drawings you want to display in the Onion Skin.
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The Onion Skin will display only, and all the drawings that are within the span of the blue handles. 

How to increase or decrease drawings to display in the Onion Skin one at a time

 1. Select the layer you want to draw on, the frame in which you want to draw, and enable Onion 
Skin—see Enabling the Onion Skin.

The Onion Skin displays in the Camera or Drawing view, with the default amount of previous and 
next drawings included. 

 2. Do one of the following as many times as necessary to include only the drawings you want to see in 
the Onion Skin:
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 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next Drawing 
button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next Drawing 
button in the Camera/Drawing view toolbar.

The Onion Skin will update with as many or as few previous and next drawings as you add or 
remove.

TIPS 

 l You can also select those commands in the top menu, in View > Onion Skin.

 l This menu also has commands to instantly set the amount of previous and next drawings to 
include in the Onion Skin to zero, one, two or three. 

 l You can also add the commands to instantly set the amount of drawings to include to zero, 
one, two or three to the Camera/Drawing view toolbar by right-clicking on the toolbar and 
selecting Customize. 
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Selecting Drawings to Include in Onion Skin by Frames or by 
Drawings

When you select which drawings to include in the Onion Skin, you are actually just setting the amount of 
drawings to include before and after the current drawings. 

Because drawings can be exposed over multiple frames, this gives Harmony two possible approaches to 
determine which drawings to include in the Onion Skin:

Selecting Drawings by Frames
With this method, if you set the Onion Skin to include one drawing before and after the current frame, it will 
include the drawings in the frame right before and right after the current frame. This means that even if the 
same drawing is exposed throughout this span of three frames, only that drawing will be displayed in the 
Onion Skin.

This method is the default one used when using Onion Skin in the Camera view. The reason for this is that the 
Camera view is often used for cut-out animation. When doing cut-out animation, layers often have the same 
drawing exposed for long spans while the layer itself is animated with translations, rotations and scaling. By 
using Onion Skin by frames, you can display the position of the layer before and after the current frame in the 
Onion Skin, even if it's the same drawing, just in different positions. 

Selecting Drawings by Drawings
With this method, if you set the Onion Skin to include one drawing before and after the current frame, it will 
include the nearest drawing that is different from the current drawing before the current frame, and the 
nearest drawing that is different from the current drawing after the current frame. 

This method is more useful for frame-by-frame animation. Since frame-by-frame animation typically does not 
use layer animations, it is usually only relevant to have different drawings in the Onion Skin.

Changing Between Methods
In the Timeline view, you can decide whether to include drawings by frames or by drawings. In the Drawing 
view, however, drawings included in the Onion Skin are always selected by drawing, since the Drawing view 
can only be used for frame-by-frame animation, whereas the Camera view can be used for both frame-by-
frame and cut-out animation.

How to switch between selecting drawings for Onion Skin by drawing or by frame

 1. In the top menu, select View > Onion Skin and select either Onion Skin by Frames or Onion Skin by 
Drawings.
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Displaying the Onion Skin in the Other Layers 

T-LAY-003-006

When doing paperless animation, you typically only need the Onion Skin to display for the current layer. It is 
however possible to display the Onion Skin for multiple layers simultaneously. To do this, you must draw in the 
Timeline view, where all your layers are visible by default. 

In the Camera view, when Onion Skin is enabled, the Onion Skin of the currently selected layer is always 
displayed. However, it is also possible to enable persistent Onion Skin on other layers in your scene. You can do 
this by clicking the Onion Skin button just left of individual layers in the Timeline view. When Onion Skin is 
enabled on specific layers, the Onion Skin for these layers display along with the Onion Skin of the current 
layer, allowing you use both as reference. 

When you enable Onion Skin using the Onion Skin button in the Tools toolbar, persistent Onion Skin is 
automatically enabled on the currently selected layer. Hence, if you want to switch to a different layer and hide 
the Onion Skin for the layer you are no longer working on, you can also use the Onion Skin button next to that 
other layer to disable Onion Skin on it. 

NOTE 

If you are using Onion Skin with a complex scene with a lot of drawing layers, such as in Cut-Out 
animation, there are more advanced techniques for displaying and hiding Onion Skin on multiple 
layers. For more information, see About Using Onion Skin in Cut-out Animation

How to display Onion Skin on multiple layers in the Camera view

 1. Select the layer and frame on which you want to draw.

 2. In the Timeline view, click on the  Onion Skin icon just left of the selected layer to enable Onion 
Skin on it.

The icon will light up, indicating that Onion Skin is now enabled for this layer.
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 3. Click on the Onion Skin icon for each layer that you want to include in the Onion Skin. 

The Onion Skin for all layers on which it is enabled will display in the Camera view. 

NOTE 

If you want to remove a layer from the Onion Skin, you can click on its  Onion Skin icon again 
to disable Onion Skin for that layer However, keep in mind that, when Onion Skin is enabled 
on any layer, it always includes the currently selected layer as well. Therefore, if you disable 
Onion Skin on the current layer, the Onion Skin for that layer will keep displaying.
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Removing Cross Hairs with the Shift and Trace Tool

Once you are done with the cross hairs you have added with the Shift and Trace tool, you can instantly remove 
all of them from your drawings.

How to remove all cross hairs

 1. Do one of the following:                 

 l In the Tool Properties view, click on the Remove All Cross Hair  button.

 l In the Shift and Trace toolbar, click on the Remove All Cross Hair  button.
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Generating a Matte

T-ANIMPA-006-013

You can quickly generate a matte to be displayed behind your rough animation so you don't see the 
background through the drawings. It can be generated in any art layer.

How to generate a matte

 1. Do one of the following:

 l In the Tools toolbar, select the Select  tool.

 l Press Alt + S.

 2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

NOTE 

You can also apply the operation to all the drawings in the layer at the same time.

 3. Do one of the following:

 l In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

 4. If you want to create a matte for all the drawings included in your layer, select the Apply to All 
Drawings option.

 5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower 
value, the closer to your lines’ contours the matte will be shaped. The higher the value, the looser 
the matte will be shaped.
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 6. In the Source Art menu, select the layer from which you want the matte created: Line ArtColour Art.

 7. In the Destination Art menu, select the layer on which you want the matte to be created: Line 
ArtColour Art.

 8. If you already have artwork on the destination layer and you want the content to be deleted before 
the matte is added into it, select the Clear Destination Art First option.

 9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you 
ever need to keep them for later), select the Copy Stroke in Destination option.

 10. Click OK.
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Previewing Animation with Mini Playback
You can quickly preview parts of your animation using Mini Playback. Mini Playback allows you to quickly 
preview a short span of animation starting a few frames before the current frame and ending a few frames 
after the current frame, at a customizable frame rate. 

How to use Mini Playback

 1. In the Timeline or Xsheet view, select a frame between the animation frames that you want to 
preview. 

 2. Do one of the following to add the Mini Playback toolbar to your workspace:

 l In the top menu, select Windows > Toolbars > Mini Playback.

 l Right-click on any existing toolbar and select Mini Playback. 

 3. In the Mini Playback toolbar, click on the  Mini Playback Dialog button. 

The Mini Playback dialog appears.

NOTE 

You can also open the Mini Playback dialog by selecting Play > Mini Playback from the 
top menu.

 4. In the Frame Rate drop-down, select the frame rate at which you want to preview your animation, 
in frames per second, or leave it to Same as Scene if you want to preview your animation at the 
frame rate set for your scene. 

 5. In the Before field, enter the amount of frames before the current frame to play. 

 6. In the After field, enter the amount of frames after the current frame to play. 

 7. Click on the  Play button.

Your scene starts playing at the chosen amount of frames before the current frame, and stops 
playing at the chosen amount of frames after the current frame.

 8. If you are satisfied with the Mini Playback configuration, you can close the Mini Playback dialog, and 
you can do one of the following to start Mini Playback again:
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 l In the Mini Playback toolbar, click on the  Mini Playback button.

 l In the top menu, select Play > Start Mini Playback. 
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Chapter 8: Scene Staging

Setting up your scene can be compared to building a set for a television show. This is the point when you 
position each scene element such as the camera frame, the background elements and the characters.

To learn how to position and animate your camera, see Camera Set-up and Animation on page 645.
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About Layer Position

Setting up the scene also involves positioning the different scene elements within the camera frame.

At this time, the elements are set to a static position. See Digital Animation on page 525 to learn how to 
animate the elements and the camera.
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Disabling Animation Keyframe Creation When Transforming Elements
T-HFND-008-001

By default, when you move, rotate, scale or skew elements in your scene using the  Transform tool or any of 
the  Advanced Animation tools, Harmony records the position of that element at the current 
frame into a keyframe. This means that, if you transform the same element on several frames, it will become 
animated. This is because the Animate mode of Harmony is set to  Animate Current Frame by default, to 
facilitate animation.

When staging a scene, you usually want to position, rotate, scale and skew elements throughout the length of 
the scene, not just at the current frame. It is possible to do this by setting the Animate mode to Animate Off. 
When Animate Off mode is selected, any transformations you make to layers, pegs deformations or other 
elements to your scene using the  Transform tool or the  Advanced Animation tool is applied 
across your entire scene, without creating a keyframe at the current frame.

If you set the Animate mode to Animate Off and reposition an element that is already animated, the element 
will be offset on every existing keyframe for this element, offsetting its entire animation. This can be very useful 
if you need to reposition, rotate or scale an element after having animated it.

How to set the Animate mode to Animate Off

 1. Do one of the following:

 l In the Tools toolbar, click on the Animate mode button which, depending on the currently 
selected mode, will either have the  Animate Current Frame,  Animate Onion Skin 
Range or  Animate Off icon, and select   Animate Off in the pop-up menu.

 l In the top menu, select Animation > Animate > Animate Off. 
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Selecting Layers
T-HFND-008-002

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform  tool. When using this tool, its 
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection  Mode 
option in the Tool Properties view is disabled or it will limit the selection to pegs only.

How to select a layer in the Camera view

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

 3. In the Camera view, click on the element to be repositioned. You can select more than one element 
at a time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to select from the Timeline or Xsheet view

 l In the Timeline view, click the layer corresponding to the element you want to reposition. 

 l In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.

How to select non-adjacent elements in the Timeline or Xsheet view

 l In the Timeline view,  hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on any layers that 
you would like to add to the selection.

 l In the Xsheet view,  hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on any columns that 
you would like to add to the selection.

  The non-adjacent, selected layers and columns are highlighted in the Timeline and Xsheet views.

How to select all elements within a group in the Timeline view

 1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.
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All elements contained within the group are selected.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. In the Timeline view toolbar, click the Centre on Selection  button  or press O.
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About the Transform Tool 
T-HFND-008-003

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera 
view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is 
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and 
vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip 
Scale Y will perform a flip on your drawing layer following its original axis.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Repositioning Temporary Pivots with the Transform Tool

T-HFND-008-004

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can 
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is 
only moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot 
position—see About Advanced Animation Tools on page 499.

How to temporarily reposition the pivot point

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously 
repositioned.

 4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this 
position as long as you do not deselect the drawing. Using the Transform tool to reposition your 
pivot will temporarily override the existing pivot point position until you complete the current 
transformation. Then it returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a 
ghost so you know where it is and also from where the animation will be interpolated when you 
create motion paths. The animation is always interpolated from the original pivot and not the 
temporary pivot.
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Panning with the Transform Tool

T-HFND-008-005

You can pan (translate) a layer using the Transform tool.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 2. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 3. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 4. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click on 
each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 5. Move the cursor over the artwork. When the cursor changes into , click and drag on the artwork 
to move it.
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Rotating with the Transform Tool

T-HFND-008-006

You can rotate a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to rotate 
from a different point.

How to rotate a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 2. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 3. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 4. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click on 
each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 5. Place  the pointer outside of a corner of the bounding box. When the cursor changes into, , then 
click and drag to rotate.
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Scaling with the Transform Tool

T-HFND-008-007

You can scale a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to scale 
from a different point.

How to scale a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 2. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 3. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 1. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click on 
each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.

 2. Move the cursor over any of the yellow control points on the manipulator box, then click and drag to 
scale the layer. 
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NOTE 

When scaling your selection, you can hold down Shift to preserve the proportions 
between its width and height.
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Skewing with the Transform Tool

T-HFND-008-008

You can skew a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to skew 
from a different point.

How to skew a layer using the Transform tool

 1. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 2. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 3. In the Tool Properties view, make sure  Peg Selection Mode  is disabled. 

 4. In the Camera or Timeline view, click on the layer you want to manipulate to select it. 

TIPS 

 l If you want to select multiple layers in the Camera view, hold down Shift and click on 
each layer you wish to select. 

 l If you want to select multiple layers in the Timeline view, hold down Ctrl 
(Windows/Linux) or ⌘  (macOS) and click on each layer you wish to select. 

 l If you want to select a contiguous series of layers in the Timeline view, hold down 
Shift, click on the first layer you want to select, then on the last layer you want to 
select. 

A manipulator control box appears around the selected layer.
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 5. Do one of the following:

 l Move the cursor over one of the vertical edges of the manipulator box, then click and drag up 
or down to skew the layer vertically. 

 l Move the cursor over one of the horizontal edges of the manipulator box, then click and drag 
left or right to skew the layer horizontally. 
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Flipping with the Transform Tool

T-HFND-008-009

You can flip a layer using the Transform tool. There are two ways to flip.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

 5. Do one of the following:

 l From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

 l In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  
buttons.

 l Press 4 or 5. 

How to flip an element following its original axis

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Camera view, use the Transform  tool to select an element that has already been 
transformed.

 4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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About Advanced Animation Tools
T-HFND-008-010

You can also use the advanced animation tools to position your layers. The difference between these tools and 
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as 
the Transform tool adjusts all parameters together.

You can find the advanced animation tools in the Advanced Animation Tools toolbar.
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Repositioning Permanent Pivots

Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the 
position of the drawing's pivot point. For example, rotating a layer will make it rotate around its pivot point, and 
scaling the layer will make it scale as if its centre was actually its pivot point.

While making transformations using the Transform tool, you can drag and drop your selection's pivot. 
However, this has no permanent effect. It will only temporarily change the pivot's position to help you make 
transformations at the selected frame, but the actual pivot point of your drawing layer will remain the same. 

You can reposition a layer's pivot point permanently by using one of the tools in the Advanced Animation 
toolbar.

NOTE 

When you permanently move the pivot point of a layer that is already animated, all the 
transformations done on the layer on other keyframes will be recalculated according to the new 
pivot point's position. Therefore, your existing animation will look completely different, except at 
the current frame. It is recommended to always make sure your pivot point is at its ideal position 
before you start animating.

How to permanently reposition the pivot point of a layer

 1. In the Advanced Animation toolbar, select the  Translate ,  Rotate ,  Scale , or  Skew tool.

 2. Do one of the following:

 l In the Timeline view, select the layer for which you want to move the pivot. 

 l In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the layer for which 
you want to move the pivot.

The  pivot point appears in the Camera view.

 3. Move the cursor over the pivot point. When the mouse cursor becomes , click and drag on the 
pivot point to reposition it.
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The layer's pivot point is now repositioned. If the layer has been animated, its position will be offset 
across the scenes relative to how much you just offset the pivot point.
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Using the Translate Tool

T-LAY-004-002

You can use the Translate tool to pan your elements on the X, Y and Z axes.

How to use the Translate tool

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. Do one of the following: 

 l In the Advanced Animation toolbar, click the  Translate  tool.

 l From the top menu, select Animation > Tools > Translate. 

 l Press Alt + 2.

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 4. Drag the selection to a new area. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Rotate Tool

You can use the Rotate tool to rotate your objects on the x,y and z axis.

How to use the Rotate tool

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Rotate. 

 l In the Advanced Animation toolbar, click the Rotate  tool.

 l Press the Alt + 3. 

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 4. Rotate the layer. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Scale Tool

You scan use the Scale tool to squash, stretch, and resize your elements.

How to use the Scale tool

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Scale. 

 l In the Advanced Animation toolbar, click the Scale  tool.

 l Press Alt + 4. 

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (macOS) to select your element. 

 4. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s 
ratio when using the corner control points. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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Using the Skew Tool

You can use the Skew tool to distort your elements on the x and y axis.

How to use the Skew tool

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. Do one of the following: 

 l Select Animation > Tools > Skew. 

 l In the Advanced Animation toolbar, click the Skew  tool.

 l Press Alt + 5.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (macOS) on the element to select it 
and drag a side of the bounding box up, down or sideways. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click 
(Windows/Linux) or ⌘  + Shift + click (macOS) on each element to select them. 
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About the Layer Properties View
T-HFND-008-011

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these 
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in 
the Camera view. These values can also be animated over time.

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters  button. 

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field 
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the 
north-south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has 
been drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have 
drawn on the page. This allows scanned drawings, imported images and paperless drawings to be properly 
registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something 
like the following:
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 l X Axis: -4 or 4W (4 West)

 l Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something 
like the following:

 l X Axis: 3 or 3E (3 East)

 l Y Axis: -2 or 2S (2 South)
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Displaying the Layer Properties View

You can display the Layer Properties view in several ways.

How to display layer parameters

 1. Do one of the following:

 l In the Layer Properties view is not part of your workspace, from the top menu, select 
Windows > Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

The properties display—see Element/Drawing Node in the Reference guide .
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Positioning Elements with the Layer Properties View

T-HFND-008-012

You can type values to position your elements using exact coordinates. 

How to position an element with coordinates

 1. In the Timeline view, select a layer.

 2. In the Position section, select one of the following options:

 l Separate to independently edit the different coordinate fields. Continue to step 3.

 l 3D Path to use a 3D path function when animating your element. Continue to step 4.

 

 3. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—
see About Multiplane on page 513.

As you type in values, the element’s position is updated in the Camera view. 

 4. Use the Function  buttons to create function curves and add keyframes to animate the 
parameter.

 5. In the Scale section, select one of the following options:

 l Locked to resizes the element uniformly in three directions.

 l Separate to resize the element in any direction without affecting the others.

 6. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position
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 7. Use the Function  buttons to create function curves and add keyframes to animate the 
parameter.

 8. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can 
enter values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

 9. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

 10. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This 
will change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see the Reference guide .
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Setting the Auto-Apply Option

If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences 
dialog box (General tab). Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click 
the Apply button to see any modifications.

How to enable or disable the Auto Apply option

 l From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

 1. In the top menu, select Edit > Preferences (Windows) or
Harmony Essentials > Preferences (macOS).

The Preferences dialog box opens.

 2. In the Preferences dialog box, select the General tab.

 3. In the Options section, select or deselect the Auto Apply option.
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Resetting Transformations 
You can easily reset layers to their original position. With the Reset command, you can return the value of a 
selected element to the initial value of the active tool. For example, if the Rotate  tool is active, the 
transformation angle will be reset to 0 and if the Transform  tool is active, the all transformation parameters 
values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg 
Selection Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if 
keyframes were created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Multiplane
T-HFND-008-013

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create 
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through 
this environment to create an impressive perspective illusion.

In live action, when the camera moves around in a scene, objects near the camera will appear to move by a 
greater distance than objects far from the camera. In 2D animation, multiplanes can be used to achieve a similar 
effect without having to use 3D. 

In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and 
positioning them at different depths relative to the camera.  

Before creating a multiplane, make sure you have a proper understanding of the environment in which your 
scene happens. Picture what your scene's background would be like in 3D, then image the camera moving 
through the space, and how the objects in the picture move at different speeds depending on where they are 
in relation to the camera lens.

In the following example, the background is made of 6 different layers, each picturing an object that is at a 
different distance from the camera. On the left, you can see how each object is positioned relative to the 
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned 
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the 
camera's point of view.
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NOTE 

When creating a multiplane background, it is important to draw each layer fully. Even if some parts 
of a background layer is hidden behind a foreground layer in the camera's initial position, panning 
or zooming the camera may expose parts of background layers that are not initially visible.

In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You 
can do this by moving a layer using the Transform Tool  in the Side or Top views. You can also move a layer 
on Z-axis directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your 
element closer to the camera makes them appear bigger, and moving them further makes them appear smaller. 
It is also possible to move elements on the Z-axis without affecting their apparent size by using the Maintain 
Size tool in the Advanced Animation toolbar.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the 
Top and Side views.
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NOTE 

Just like with other transformations, transformations on the Z-axis on a parent layer will also affect 
the apparent position on the Z-axis of its child layers. Therefore, a child layer's apparent position on 
the Z-axis can be affected by any of its parents.
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Setting Up Multiplanes
T-HFND-008-017

You can setup your elements as a multiplane to create a parallax effect when moving your camera. You simply 
need to spread and scale the objects on the Z-axis.

How to rotate a scene in the Perspective view

 1. In the Tools toolbar, select the Rotate View   tool.

 2. Click in the view, and drag the cursor around to rotate the view or press and hold Ctrl + Alt 
(Windows/Linux) or ⌘  + Alt (macOS) and click and drag to rotate the view one axis at a time. 

How to set up a multiplane

 1. To maintain the visual scale in the Camera view as you move your element, do one of the following:

 l In the Advanced Animation toolbar, select the Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer 
from the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

 3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the 
same in the Camera view.
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 4. For your element to scale up or down in relation to their distance to the camera, do one of the 
following:

 l In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode 
 option is disabled in the Tool Properties view.

 l In the Advanced Animation toolbar, select the Translate  tool and select a layer 
from the thumbnails section of the Top or Side view.

 l Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

 5. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging the 
element to make sure it only moves along the X-axis.

 6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while 
dragging the element to make sure it only moves along the Y-axis.
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About Alignment Guides
Alignment guides are horizontal and vertical rulers that you can add to the Camera view and position 
anywhere in your scene to help you align elements to specific positions in the stage.

When an alignment guide is added, it is added to the scene. Alignment guides are visible no matter which 
layer is selected or which frame is the current frame. 

Alignment guides are only visible when using the  Transform tool. When manipulating an element with the 
 Transform tool, it is possible to make it snap to alignment guides. 
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Adding Alignment Guides
You can add horizontal or vertical alignment guides to your scene.

NOTES 

 l When you add a guide, it is instantly positioned in the center of your scene. You can move it 
with the  Transform tool.

 l Guides are only visible when the  Transform tool is selected.

How to add an alignment guide

 1. In the Tools toolbar, select the  Transform tool.

 2. Do one of the following:

 l In the Camera view toolbar, click on the  New Horizontal Alignment Guide or  New 
Vertical Alignment Guide button.

 l In the top menu, select View > Alignment Guides > New Horizontal Alignment Guide or  
New Vertical Alignment Guide.

The guide is added to the centre of your scene.
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Moving Alignment Guides
You can move alignment guides with the  Transform tool. 

NOTE 

Guides cannot be moved if they are locked—see Locking and Unlocking Alignment Guides.

How to move an alignment guide

 1. In the Tools toolbar, select the  Transform tool.

 2. Position your mouse cursor over the guide. The cursor will change to  .

 3. Click and drag on the guide.
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Snapping to Alignment Guides
When manipulating elements with the Transform tool, you can make them snap to alignment guides in your 
scene by enabling the  Snap to Alignment Guides option. 

How to snap elements to alignment guides

 1. In the Tools toolbar, select the  Transform tool.

 2. In the Tool Properties view, toggle the  Snap to Alignment Guides button on. 

 3. In the Camera view, click and drag the element you want to snap against the guide.
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Locking and Unlocking Alignment Guides
When alignment guides are locked, it is not possible to move them with the  Transform tool. 

Guides are only visible when the  Transform tool is selected, and can only be manipulated using the 
Transform tool. Once you are sure that your guides are in the right position, you might want to lock them so as 
to avoid accidentally moving them when trying to move elements in your scene.

How to lock or unlock alignment guides

 1. In the top menu, select View > Alignment Guides > Lock Alignment Guides. 
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Hiding and Displaying Alignment Guides
It is possible to toggle the visibility of alignment guides in your scene.

NOTES 

 l When alignment guides are hidden, the  Transform tool does not snap to them. Hiding 
alignment guides effectively disables them. 

 l Adding an alignment guide automatically toggles their visibility on. 

How to hide or display alignment guides

 1. Do one of the following:

 l In the toolbar below the Camera view, click on the  Show Alignment Guide button to 
toggle it on or off.

 l In the top menu, select View > Alignment Guides > Show Alignment Guides to toggle it on 
or off. 
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Clearing Alignment Guides
It is possible to instantly remove all alignment guides from your scene. However, it is not possible to delete a 
single alignment guide and keep all others. 

How to clear all alignment guides

 1. In the top menu, select View > Alignment Guides > Clear Alignment Guides.
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Chapter 9: Digital Animation

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera 
moves and camera shakes, adjust the easing, shape your paths with control points and much more.

Before animating the position of your layers, you need to create motion paths which are trajectories on which 
you can attach drawing objects. Using keyframes, you can then record key positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a 
simple motion, you will learn the basics of animating a layer.

There are two ways to create motion paths: animated drawing layers and pegs. They each have different 
purposes. 
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About Pegs
T-HFND-009-004

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg 
holes at the bottom or top of the animation paper are used to keep all the sheets even and at the same 
registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones 
are oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg 
hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to 
the shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and 
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create 
animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales
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You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds. 
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory 
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to 
control your puppet as one object.
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Adding Pegs
T-ANIMCO-001-001

You can add peg to your Timeline view and parent the layers to animate to it. 

How to add a peg in the Timeline view

 1. In the Timeline view, select the layer on which you want to attach a peg.

 2. Do one of the following: 

 l From the Timeline view layers toolbar, click the Add Peg  button.

 l From the top menu, select Insert > Peg.

 l Right-click on the selected layer, then select Insert > Peg.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (macOS).

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg 
layer automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to 
the Peg layer. This relationship is called a parent-child relationship.

 3. If you intend to add multiple pegs or if the layer name that was added to the peg does not 
accurately represent the content of the Peg layer, you can rename it. Click the layer name and type 
in a new name. Or double-click the layer and type a new name into the dialog box.

 4. If you did not create your peg layer directly above the layer you intended on parenting it to, then 
drag the layer you want to attach to the peg and drop it directly below the Peg layer. The 
indentation of the layer below the Peg layer indicates whether it was correctly attached or not.
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 l You can unparent layers by holding down Shift and dragging the selected parents 
away from the child layer. Drop your selected between other layers.
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Enabling Peg Selection Mode
In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in the 
Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers 
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent 
Skipping Effects command.

How to enable the Peg Selection Mode

 1. In the Tools toolbar, select the  Transform tool or press Shift + T.

 2. In the Tool Properties view, click the Peg Selection Mode  button.

 3. In the Camera view, select an element parented to a peg.
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About Drawing Layers
T-ANIMCO-001-002

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

Harmony keeps track of the animation by storing each parameter of each layer in their own function curve. 
When you add a keyframe to a layer, a keyframe is created on each of these functions, and transformations 
done on a layer via the Camera view are translated into coordinates which are then stored in those functions. It 
is possible to edit these functions individually using the Function view, but that is rarely necessary, as Harmony 
provides easy-to-use tools for visually controlling trajectories and timing in the Camera and Timeline views.

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select 
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls 
tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily  identify 
them as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.
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About Layer Parameters
T-HFND-009-008

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew 
and scales. Each parameter has its own function which is a mathematical formula expressing the relationship 
between position values. You can view each function on a graph as a simple curve, such as the one below.

There are several options available for setting up function parameters:

 l Locked Positions (3D Path)

 l Separate Positions

 l Locked Scales

 l Separate Scales

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. 
When you lock or unlock parameters, this does not convert the functions from one to the other, but creates new 
ones.

In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you 
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth 
trajectories.
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When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the 
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its 
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth 
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one 
another. This is why in cut-out animation it is recommended to use separate position settings. But if you work 
with 3D path, you can use the Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes 
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works 
with 3D paths.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls 
directly on their function curve. This is useful when you want to set keyframes on one of the curves without 
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal 
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal) 
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions, 
you can squash, stretch and skew your elements.
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Displaying Layer Parameters
T-ANIMCO-001-004

You can easily display the parameters for each layer in the Timeline view.

How to display the layer parameters in the Timeline view

 1. Do one of the following:

 l In the Timeline’s left side, click a layer's Expand  button. 

 l In the Timeline view menu, select View > Show Functions.

 l Press Alt + F. 
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Setting Layer Parameters
T-ANIMCO-001-003

You can modify the layer parameters to different types of function and linking some of them together.

How to set the layer parameters

 1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also 
see the parameters in the Layer Properties window when you select the layer in the Timeline view.

The Layer Properties window opens.

 2. Select the Transformation tab.

 3. In the Position section, select the 3D Path or Separate option.

 4. In the Scale section, select the Locked or Separate option.

 5. Click Close.
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Enabling Constant Z
T-HFND-009-008A

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

 1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that 
you must select the 3D Path option for the layer.

 2. Double-click on one of the position functions to open the Function editor.

 3. In the Function editor, select the Constant Z  button.
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About Keyframes
T-HFND-009-005

Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like 
to create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no 
interpolation) and motion keyframes (computer-generated interpolation).

In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is 
constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops 
to its new location.

With motion keyframes, Harmony generates the interpolation between the keyframes. This means that a value 
for each frame between the keyframes is calculated by Harmony to progress from the value of the previous 
keyframe to the value of the next keyframe. 
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About Keyframe Creation
There are several different ways you can create keyframes. You can add a coordinate keyframe, position 
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer 
stays the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do 
not want to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be 
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and 
Skew parameters.
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Creating Keyframes in the Timeline View

T-HFND-009-006

You can add keyframes in the Timeline view to multiple layers, a single layer or a specific parameter.

How to create keyframes in the Timeline view

 1. In the Timeline view, select the cell on which you want to add a keyframe.

 2. Add a keyframe  by doing one of the following:

 l From the top menu, select Insert > Keyframe.

 l Right-click  on the selection and select Insert Keyframe.

 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the 
current frame.

 How to add a keyframe for a specific parameter

 1. On the right side of the Drawing layer, press the + to expose the different functions of that drawing.

 2. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

 3. Do one of the following:

 l Right-click the selected cell and select Insert Keyframe.
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 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

How to create a keyframe and duplicate the drawing at the same time

 1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a 
keyframe.

 2. Do one of the following:

 l From the top menu, select Insert > Keyframe and Duplicate Drawing.

 l Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

 l Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the 
original drawing.
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Creating Keyframes in the Function View

You can add keyframe directly on the graph using the Function view.

How to add or delete keyframes in the Function editor

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

 2. Double-click on the parameter layer name to open the Function editor window or click once on the 
parameter layer to display it in the Function view's left sidebar. If you are using the Function view, 
you must click on the function name from the sidebar list to view it in the graph display region.

 3. In the Function editor, do one of the following:

 l In the graph section, click on the frame  where you want to make changes.

 l In the Frame field, enter the frame number.

In the graph display area, the red playhead moves to that frame number.

 4. In the Function editor, click the Add Keyframe   button.
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 5. Click on the newly created keyframe and drag it up to increase the value of the function or down to 
decrease the value. Depending on the selected function, this could increase or decrease the width of 
the object (scale_x) or change the object's vertical position (position_y). Pull on the handles to create 
non-linear transition speeds between keyframes.

 6. If you do not like the changes you just made, select and delete the new keyframe by pressing  Del or 
clicking the and Delete keyframe  button.

You can delete an existing keyframe by using the same process.
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Creating Keyframes in the Xsheet View

If you prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view 
and then select the layer you want to modify. If you double-click on a function column's header, you will display 
the corresponding function curve in the Function editor.

How to add a keyframe in the Xsheet view

 1. In the Xsheet view, click the Expand button located on the right side of the main section to show 
the Functions section. 

 2. In the Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding 
keyframes in the Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

 3. In the Xsheet view, go to the function column on which you want to add a keyframe.

 4. Double-click on the cell on which you want to add a keyframe and type a numeric value.
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 5. Press Enter/Return to continue to the next cell.

 6. Press Esc to exit the typing mode.

How to convert a cell into a keyframe

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Select the cell to convert.

 3. Right-click on the cell and select Set Selection As Keyframe or press F6.

 4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in 
Selection or press F7.
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Automatically Creating Animation Keyframes When Transforming 
Elements

T-ANIMCO-001-007

Before you start animating, you should set the Animate mode of Harmony to  Animate Current Frame. This 
mode ensures that, whenver you use the  Transform tool or any of the  Advanced Animation 
tools to move, rotate, scale or skew an element in your scene, a keyframe is created at the current frame in 
which the new coordinates of the element are stored.

When this mode is enabled, all you need to do to animate elements in your scene is to select the frame where 
you want to create an animation keyframe, then position the element you want to animate in the position, 
angle, scale and skew you want it to be at this frame, and repeat for every animation keyframe you want to 
create. Since a keyframe is automatically created at the current frame each time you transform an element, 
making transformations on your elements on different frames in your scene will automatically create an 
animation. 

How to set the Animate mode to Animate Current Frame

 1. Do one of the following:

 l In the Tools toolbar, click on the Animate mode button which, depending on the currently 
selected mode, will either have the  Animate Current Frame,  Animate Onion Skin 
Range or  Animate Off icon, and select   Animate Current Frame in the pop-up menu.

 l In the top menu, select Animation > Animate > Animate Current Frame. 
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Deleting Keyframes
T-HFND-009-007

You can delete keyframes independently from drawing exposure.

NOTE 

If you select a keyframe in the Timeline view and press the Del key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to delete a keyframe

 1. In the Timeline view, select a keyframe and do one of the following:

 l Right-click and select Delete Keyframes. 

 l From the top menu, select Animation > Delete Keyframe.

 l Press F7.

 l In the Timeline View toolbar, click on the Delete Keyframes  button.

 l Use the Transform  tool to select a keyframe to delete from the trajectory in the 
Camera view and press Del.
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Animating with Keyframes
T-ANIMCO-001-005

You can animate a layer or a peg by creating keyframes and moving your drawings in the Camera view.

How to animate a layer                                       or a peg                 

 1. In the Tools toolbar, select the  Transform tool or press Shift + T.

 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. If your layer has a parent peg:

 l If you want to animate on the peg instead of the layer, make sure that  Peg Selection 
Mode is enabled in the Tool Properties view.

 l If you want to animate directly on the layer, make sure that  Peg Selection Mode is 
disabled in the Tool Properties view. 

 4. In the Timeline view, go to the first frame.

 5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is 
unchecked. This will make it so Harmony automatically creates the animation between the 
animation keyframes you create.

 6. Select the cell where you want to create your first keyframe

 7. To create your first keyframe, do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is created on the first frame of the Timeline view.

 8. In the Camera view, select the element to animate and move, rotate, scale or skew it so that it is in 
its proper starting position.
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 9. In the Timeline view, go to the frame on which you want to set the second position.

 10. Select the cell where you want to create your second keyframe. right-click on the selection and 
select Insert Keyframe.

The second keyframe appears in the Timeline view, along with a line going from your first keyframe 
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

 11. In the Camera view, move, rotate, scale or skew the element to that it is in its proper second 
position.
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NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 13. In the Playback toolbar, click on the  Play  button to preview your animation.

NOTE 

If  you animate layers on the Z axis, you may want to preview your animations from the Top or 
Side views  during playback. However, playback is disabled by default in those view. To enable 
them, from the top menu, select Play > Enable Playback > Top View or Side View.
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Animating, Repositioning or Transforming an Element Over Several 
Frames
By default, when you use the  Transform tool or the  Advanced Animation tool to reposition an 
element, its coordinates are changed in the current frame only. However, it is possible to move, rotate, scale 
and skew an element on several keyframes simultaneously. This is done by changing the Animate mode.

There are three different Animate modes:

 l  Animate Current Frame: When you transform an element, its position, angle, scale and skew are 
stored in a keyframe at the current frame. This means that a keyframe is created at the current frame, if 
there is not one already.

 l  Animate Onion Skin Range: When you transform an element, the transformation is applied to every 
frame in the Onion Skin. This means that it is applied to every keyframe inside the Onion Skin range, 
and, if needed, keyframes are created at the beginning and the end of the Onion Skin to preserve the 
transformations you make.

 l  Animate Off: When you transform an element, the transformation is applied throughout the entire 
scene. If the element has keyframes, the transformation is applied to all of these keyframes. No keyframe 
is automatically created when using this mode. 

How to move, rotate, scale or skew an element over a specific span of frames

 1. In the Tools toolbar, select the  Transform tool.

TIP 

You can also make transformations over several keyframes using the  Translate,  
Rotate,  Scale,  Skew or  Maintain Size tools, which can be selected in the 
Advanced Animation toolbar.

 2. In the Timeline or Camera view, select the element you want to transform. 

 3. In the Tools toolbar, click on the Animate mode button which, depending on the currently selected 
mode, will either have the  Animate Current Frame,  Animate Onion Skin Range or  
Animate Off icon, and select Animate Onion Skin Range in the pop-up menu.

Animate Onion Skin Range is now enabled. At the same time, Onion Skin becomes enabled, and 
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the Onion Skin handles appear left and right of the red playhead in the Timeline view.

 4. In the Timeline view, move the timeline playhead to a frame somewhere in the middle of the span of 
frames you want to transform.

 5. Adjust the range of the Onion Skin so that it covers every frame you want to apply the 
transformation to by doing one of the following:

 l In the Timeline view, click and drag on the red  onion skin marker to make it include the 
previous drawings you want to display in the onion skin, then click and drag on the green 
onion skin marker to make it include the next drawings you want to display in the onion skin.

 l Use the buttons in the toolbar above the drawing space to adjust how many previous and 
next drawings are included in the Onion Skin:

 l To increase the amount of previous drawings to display, click on the  Add Previous 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of previous drawings to display, click on the  Remove 
Previous Drawing button in the Camera/Drawing view toolbar.

 l To increase the amount of next drawings to display, click on the  Add Next 
Drawing button in the Camera/Drawing view toolbar.

 l To decrease the amount of next drawings to display, click on the  Remove Next 
Drawing button in the Camera/Drawing view toolbar.
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NOTE 

If there are no keyframes at the beginning and at the end of the Onion Skin range, 
keyframes will be automatically created at those frames to store the transformation you 
will make. If you want to avoid this, make sure the Onion Skin range begins and ends on 
a keyframe.

The position of the layer in every frame in the Onion Skin range will appear in the Camera view, as 
Onion Skin. 

 6. In the Camera view, use the Transform tool to move, scale, rotate or skew the selected element.

NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.
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The transformation is applied on every keyframe within the Onion Skin range on the selected layer. 

NOTE 

Make sure to set the Animate mode back to Animate Current Frame when you want your 
transformations to only affect the current frame again.

How to move, scale, rotate or skew an element throughout the entire scene

 1. In the Tools toolbar, select the  Transform tool.

TIP 

You can also make transformations throughout the entire scene using the  Translate, 
 Rotate,  Scale,  Skew or  Maintain Size tools, which can be selected in the 

Advanced Animation toolbar.

 2. In the Timeline or Camera view, select the element you want to transform. 

 3. In the Tools toolbar, click on the Animate mode button which, depending on the currently selected 
mode, will either have the  Animate Current Frame,  Animate Onion Skin Range or  
Animate Off icon, and select  Animate Off in the pop-up menu.
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 4. In the Camera view, use the Transform tool to move, scale, rotate or skew the selected element.

NOTES 

 l For information on how to use the Transform tool to move, rotate, scale or skew an 
element, see About the Transform Tool .

 l You can also use the Advanced Animation tools to move, rotate, scale and skew 
elements—see About Advanced Animation Tools.

The transformation is applied to the element throughout the entire scene. If the element has 
animation keyframes, the transformation is applied to every keyframe as well.

NOTE 

Make sure to set the Animate mode back to Animate Current Frame when you want your 
transformations to only affect the current frame again.
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Changing Keyframe Values
Once a keyframe is added, beside moving the image in the Camera view, you can change its value by typing it 
in the Timeline and Function views.

How to change the keyframe values in the Timeline view

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or 
press Alt + F. 

 2. Select the parameter for which you want to create a function curve.

 3. Place the cursor over the blue number value of the parameter and do one of the following:

 l Wait until the cursor changes to a white hand with a two-way arrow and then drag 
the hand left to decrease the value or right to increase the value.

 l Double-click on the blue number and enter a value in the field.

How to change a keyframe value in the Function editor

 1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg 
layer's name.
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 2. Double-click on the parameter layer name to open the Editor window or click once on the parameter 
layer to display it in the Function view.

 3. In the graph of the Function editor, select a white keyframe. 

The keyframe turns red and displays a pointed yellow handle.

 4. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.

 5. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

 6. Keep adjusting the values until you are satisfied with the results.

 7. Click Close.
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Switching Between Motion and Stop-Motion Keyframes
T-ANIMCO-001-006

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

How to switch between motion and stop-motion in the Timeline view

 1. On the right side of the Timeline view, select one or more keyframes to modify.

 2. Switch between motion and stop-motion by doing one of the following:

 l Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (macOS) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (macOS) for stop-motion keyframes.

 l In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe 
 button.

How to switch between motion and stop-motion keyframes in the Function view

 1. Open the Function view.

 2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.

 3. Do one of the following:

 l In the Transformation tab, click the Function Editor  button.
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 l In the Timeline view, click the Expand Function  button or press Alt + F and double-
click on the function to edit.

 4. On the function curve, select one or more keyframes to modify.

 5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.
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Jumping to Keyframes
You can jump between the selected layer's keyframes in the Timeline view.

How to jump to keyframes

 1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip 
through.

 2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press 
semicolon (;) and single quote (').
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About Controls
T-HFND-009-010

Camera moves and motion paths can become quite advanced, especially with moves through 3D space. 
Harmony provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D 
perspective.

You can display the trajectory of a motion path when you select an object from any view it can be selected in.

A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both 
keyframes and control points. Both can be used to shape a path; each have their own behaviour, however only 
keyframes appear in the Timeline view. 

 l Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in 
time.

 l Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. 
There are no velocity handles available on a control point. The velocity segments are set between 
keyframes only, making curves and trajectories much smoother. Control points can only be added on a 
3D path.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.
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Displaying Controls
T-HFND-009-011

You can display a layer's controls to adjust a trajectory or other parameters such as a gradient's position or 
deformation settings.

How to display the layer’s controls

 1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want 
to display is selected in the Timeline view.

 2. From the top menu, select View > Show > Control or press Shift + F11 or in the Camera view 
toolbar, click on the Show Control  button.

NOTE 

If nothing appears in the Camera view, you may not have animated or selected 
the layer.
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Adding Control Points
T-HFND-009-012

You can add control points on 3D Path trajectories. You need to display the layer's controls in the Camera view.

How to add a control point on a trajectory

 1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

 2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top 
menu or press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.

 3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point 
and press P once. If you hold the key down, control points will be added continuously until you 
release the key.

A control point is added to the trajectory.
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Toggling Point Types
You can convert a control point into a keyframe and a keyframe into a control point. The position and other 
values will remain in both cases, only the frame will change. A control point is not locked in time.

How to switch between keyframe and control point

 1. In the Camera view, use the Transform  tool select a point to convert.

 2. To convert the point:

 l From the top menu, select Animation > Lock in Time.

 l In the Function view or Function Editor, select the keyframe to convert and click the 
Lock in Time  button.
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Adjusting Tension, Bias, and Continuity
You can adjust the shape of the curve passing through a point by modifying the bias, tension, and continuity 
settings. You can also set preferred settings as default.

How to adjust the control point preferences

 1. From the top menu, select Edit > Preferences (Windows) or Harmony Essentials > Preferences 
(macOS).

The Preferences dialog box opens.

 2. Select the Camera tab and adjust the parameters in the Control Points section.
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Offsetting Trajectories
By offsetting a trajectory, you Lets you reposition the visual trajectory without offsetting or modifying your 
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location 
than the centre of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you 
have several elements attached to one trajectory, you might want your trajectory to be at a different location to 
represent the group's motion better.

How to offset a trajectory

 1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

 2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

 3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the 
trajectory, any transformation done using the Spline Offset tool will be ignored.

 4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, 
but also on the Z-axis using the Top and Side views.
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About Functions
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally 
create the ones you need to avoid being overloaded with too many functions you might not use.

When you select an element in the Camera view and move it around, it will automatically create the 
corresponding function curves. If you need to create certain functions manually, you can always do it through 
the Layer Properties view or editor.  You can then share it with other layer parameters or set keyframes directly 
on the function curve instead of doing it in the Timeline or Camera view.

You can also link a layer's parameter to an existing function curve or attach several parameters to the same 
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera 
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but 
this may produce undesirable results and even induce a feeling of motion sickness as you watch the final 
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore 
the angle, scale and skew. 

By default, all function curves can only be used and modified using their original parameter. If you want another 
layer or parameter to use the same function curve, you must share it.

There are two ways to share a function:

 l Share Functions command

 l Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:

Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Local Disconnects the parameter from any function and changes it to shared.

3D Path Displays the list of every shared 3D Path function available

Bezier Displays the list of every shared Bezier curve available

Velobased Displays the list of every shared velocity based curve available

3D Rotation Displays the list of every shared 3D Rotation function available

Connected Displays the list of every shared connected function curve
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Unconnected Displays the list of every shared unconnected function curve

All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have 
two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your 
needs, including: 

 l Bezier function

 l Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you can use a Bezier 
function.

These function editors present different ways of editing the values over time. The shape of the created graph 
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is 
largely based on your working preference. 

You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you 
do this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a 
Velobased function to control its velocity.

With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it 
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an 
element.
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You can convert a Bezier functions so you can edit it using the controls offered by that type of function. 
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Creating Functions
You can create function curves in several different ways. You cannot create function curves directly in the 
Xsheet view. You must do this in the Layer Properties window or the Timeline view.

 How to create the function curve in the Timeline view

 1. In the Timeline view, expand the layer's parameters.

 2. Click the Function button and, in the drop-down menu, select Create Bezier.

How to create function curves using the Layer Properties view

 1. In the Timeline view, double-click on the layer you want to create function curves for.

The Layer Properties Editor opens.
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 2. In the Transformation tab, click the Function Arrow button beside the local function information.

 3. Create a 3D Path, Bezier, or Velobased curve.

You can click the Function  button to open the Function editor.

574

Harmony 17 Essentials User Guide                          



Chapter 9: Digital Animation

About Copying Motions
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them 
and even copy them.

When you have position keyframes set in your drawing layer and you want to move them around when moving 
your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and 
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the 
Paste Reverse command to completely reverse the flow of your animation.
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Using Timeline Paste Modes
Use can copy and paste or drag and drop keyframes and drawings in the Timeline view using various modes.

How to paste a selection using different modes

 1. In the Timeline view, select the cells you want to copy and paste.

 2. In the Timeline toolbar, click the desired Paste  mode button.

 3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS).

 4. In the Timeline view's right side, select the cell on which you want to paste your selection.

 5. Select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or ⌘  + V (macOS).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only
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Paste Mode: Exposures Only
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Using Paste Special
You can copy drawing exposures and keyframes and paste only a portion of your selection using Paste Special.

How to copy and paste a motion using Paste Special

 1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go 
to step 3.

 2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or 
⌘  + C (macOS).

 3. Edit your selection by doing the following:

 l To paste the selection, in the Timeline view, select the first cell on which you want to 
paste your keyframes and from the top menu, select Edit > Paste Special or press Ctrl 
+ B (Windows/Linux) or ⌘  + B (macOS).

 l To move the selection, in the Timeline view, drag the selection and hold down Alt. 
Drop the selection where you need it and release the hot key.

The Paste Special window opens.

 4. Set the Drawing, Pegs and Functions, and Cycles parameters. 

 5. Click OK.
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About Velocity
T-ANIMCO-001-009

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters 
script and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve 
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle 
and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them 
to adjust the ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for 
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected 
keyframes in the same frame.
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Displaying Velocity Curves
You can display a parameter's function curve and adjust the easing with the relevant controls.

How to display the velocity curve

 1. In the Timeline view, click the Expand  button on a layer or press Alt + F.

The layer’s functions are displayed.

 2. Double-click the desired function. Note that 3D Paths have a specific velocity curve controlling the 
X, Y, and Z axis together. You need to click on the Position:Velocity layer.

The Function Editor opens as the Bezier Editor.
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The editor will not be displayed if the function does not already exist.
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Adjusting Bezier Curve Velocity
You can reshape a Bezier curve velocity using the Function view controls.

How to adjust a Bezier curve velocity

 1. In the Function view, select a keyframe.

 2. Drag the controls to modify the shape of the curve.

You can reshape the function using the Bézier controls.

 3. The Continuity options influence how you can move the handles:

 l Straight: Lets you move the handles together, maintaining the same angle to the 
point.

 l Corner: Lets you move the handles independently.

 l Smooth: Lets you move the handles together, maintaining the same distance and 
angle to the point.
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Creating Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when 
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those 
two frames.

How to create a step velocity

 1. Click the Hold Value Editor  button.

The Hold Value editor opens.

 2. In the Hold Value Editor, enter the following values:

 l Start: The starting frame for the effect.

 l Stop: The last frame for the effect.

 l Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) 
consistently between keyframes. That is, there is no acceleration in the effect.

How to create a step velocity for multiple parameters

 1. Add the Scripting toolbar to your interface:
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 l Go to the top menu and select Windows > Toolbars > Scripting.

 l right-click on the empty space near the top of the interface  and from the quick-access menu 
selecting Scripting.

 l right-click on the empty space near the top of a view and from the quick-access menu 
selecting Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager 
window.

 3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_CreateStepsOn.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_CreateStepsOn script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Timeline view, select the layer whose parameter values you would like to hold. 

 9. In the Scripting toolbar, click on the TB_CreateStepsOn script  button.

The Create Function Step On dialog box appears.
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 10. In the Settings section, enter the hold value by changing the number in the Every Number of 
Frames field.

 11. In the Selection section, enter the first and last frame numbers to define the selection range.

NOTE 

The playhead location determines the lowest value you can enter for the first frame, 
when defining the selection range. You need to move the playhead to frame one if you 
would like to set frame one as the lowest possible starting value. 

 12. Click OK.

 13. In the Timeline view, expand the layer properties of the selected layer by clicking on its plus  
button.

 14. Double-click on a parameter layer to open its Bezier Editor. If that parameter was animated, the 3 
frame hold from frame 20 to 60 was applied.
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 15. In the Bezier Editor, click on any of the keyframes to bring up the bezier point handles and use them 
to reshape the velocity curve for that parameter.
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This means that multiple parameters can have the same stepped velocity, but have different ease-in 
ease-out curves defining that velocity.
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Adjusting Velocity in the Timeline View
If you would rather avoid playing with graphs and function curves, you can adjust the velocity in the Timeline 
view.

How to set the ease in the Timeline view

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE 

Only the first selected keyframe will be considered when using the Set Ease For Multiple 
Parameter function. If many keyframes are selected on the same layer, the ease values will be 
applied only on the first keyframe and the rest will be ignored.

 2. In the Timeline toolbar, select an option from the Set Ease Type menu.

NOTE 

TIP: Optimize your workflow by adding the Apply Ease to Selection  button to the Timeline 
toolbar. This lets you quickly reapply the ease type without going through the Set Ease Type 
menu each time. To add the button to the toolbar, right-click on the toolbar area of the 
Timeline view and select Customize. 
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Setting Ease on Multiple Parameters
T-HFND-009-013

You can adjust the velocity on multiple parameters at a same frame for consistency.

How to set the ease on multiple parameters

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE 

Only the first selected keyframe will be considered when using the Set Ease For 
Multiple Parameter function. If many keyframes are selected on the same layer, 
the ease values will be applied only on the first keyframe and the rest will be 
ignored.

 2. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.
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 4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as 
Rotation or Scale. Deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions.

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. 
Note that it applies to the Morphing velocity function found in the Layer Properties 
window, not the basic morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other the selected functions, such as all 
functions created to animate effect parameters.

 5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are 
calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value 
corresponding to the length of time you want the easing to last. Stay between 0% 
and 100%. If you go beyond 100%, your motion will overshoot. 

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
strong you want the easing out to be. Stay between 0% and 100%. If you go beyond 
100%, your motion will overshoot. 

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 6. Once done, click one of the following:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then 
selects the previous keyframe in the timeline.

590

Harmony 17 Essentials User Guide                          



Chapter 9: Digital Animation

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then 
selects the next keyframe in the timeline.

 l Close: Close the dialog box. If you did not apply the modifications, they will be 
cancelled.
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Chapter 10: Importing & Scanning
Toon Boom Harmony Essentials allows you to import external content as well as being able to draw directly in 
the software. This means that characters, backgrounds and videos created in other drawing, painting and 
multimedia programs can be brought in and animated. You can import QuickTime videos, pictures, multilayered 
.psd files, as well as .ai, .swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize 
them.

NOTE 

For sound import, refer to Importing Sound on page 73.
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About Importing Bitmap Images
T-HFND-007-001

Images can come in many different file formats and are usually saved in a format that retains the original 
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, 
while others are not resolution dependent due to their vector nature. Toon Boom Harmony Essentials supports 
the following bitmap image formats: JPEG, BMP, PNG (16 bits per channel RGB and RGBA), TGA, PSD (16 bits 
per channel), TIFF, SGI, TVG, OMF, PAL, SCAN.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Import as Bitmap: This imports the image exactly as is and ensures that it cannot be modified when 
working on the scene. This is useful for using backgrounds that were created in different software in 
your project.

 l Vectorize: Converts a bitmap  into Toon Boom vector art, which can easily be painted and edited using 
Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a 
different software.

When importing images, the settings used to import are saved in your user settings.
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Importing Bitmap Images As Original Bitmap
T-HFND-007-002

Importing a bitmap image in its original format ensures it is preserved exactly as is in Harmony. When 
importing a bitmap image, you have several options available such as where you want to import the file and 
how to name it. 

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more 
images on your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the 
following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
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will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 4. In the Vectorization section, make sure the Vectorize Image option is unchecked.

 5. Click OK.

NOTE 

By default, bitmap images will display in low resolution in the Camera view so as to avoid 
affecting playback performance. You can also adjust the display quality of a bitmap image by 
selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View > 
Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by 
activating the Render Preview  mode in the Camera view. 
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Adjusting the Bitmap Image Display Quality 

T-HFND-007-004

Your original bitmaps are imported as is in your project. In the Camera view, they may appear low quality as a 
proxy image is displayed in its place to insure fast playback.

If the bitmap images that you imported look blurry or slightly pixelated, you can increase the image proxy 
display by changing the quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

 1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is 
encapsulated or simply select the bitmap image layer in the Timeline view if it's not.

 2. Do one of the following:

 l From the top menu, select View > Bitmap File Quality.

 l Press Ctrl + Q (Windows/Linux) or ⌘  + Q (macOS).

The Bitmap Image Quality dialog box opens.

 3. Drag the slider to the right to improve the quality.

 4. Click OK.

 5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and 
return to your scene.
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Vectorizing Images on Import
You can import bitmap images as vector drawings, which allows you to edit them using Harmony's vector 
drawing tools. This is especially useful to convert bitmap line art scanned or created in a different software into 
vector line art so it can be painted in Harmony. 

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from 
your computer.
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 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 3. In the Vectorization section, select the Vectorize Image  option. 

 4. Select one of the following options: 

‣ Colour: Imports bitmaps as vector objects with their image as a bitmap texture. The resulting 
drawing can be drawn or erased over, but not repainted or tweaked. 

‣ Black and White: Vectorizes drawings with a solid black line. This creates a 100% vector-based 
drawing and paints it with the Vectorized Line colour swatch from your scene's palette.

 5. If you selected the Black and White option, set the following parameters:

Parameter Description

Threshold

Determines what values in the scanned image will be 
considered as part of the drawing, and what will be ignored 
and eliminated in the vectorized drawing. The lower the value, 
the darker the image and vice versa.

Smooth
Determines how smooth the lines will be. The lower the 
value, the more detail will be retained. The higher the value, 
the more polished and easy to edit the lines will be.

 6. Click OK.

Your vectorized images will appear in their selected destination.
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About Importing a Multi-Layer PSD
It is possible to import Photoshop Document (.psd) images into Harmony. This allows you to create 
backgrounds, characters and other assets in Adobe Photoshop with multiple layers and effects, then import 
them in Harmony once you're finished editing them. 

When importing a Photoshop Document (.psd) file, you have a choice of how to import the multiple layers into 
your Harmony scene:

 l Single Layer: Imports the rasterized, flattened version of the PSD into a single layer in your scene.

 l Groups as Layers: This imports every group in the PSD file as a single layer in your Harmony scene. 
Then, every layer inside a given group is imported as a single drawing inside the layer in the Harmony 
scene.

This can be useful if you want to create characters or props in Photoshop and import them in Harmony. 
You can create all the drawings for each layer in Photoshop and import them into Harmony in a single 
step.
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Importing Multi-layer PSD Files
T-HFND-007-003

You can import a multi-layer PSD file into Harmony using the Import Images dialog. When you attempt to 
import a PSD into a Harmony scene, you will be prompted to choose whether to import your PSD as a single 
layer or as multiple layers. 

NOTE 

Your .psd image file must be set to RGB mode within Adobe Photoshop prior to being imported 
into Harmony.

How to import a multi-layer PSD file

 1. In Adobe Photoshop, organize your layers and groups so that they are imported as expected in 
Harmony—see About Importing a Multi-Layer PSD.

 2. In Harmony, do one of the following:

 l In the top menu, select File > Import > Images 

 l In the Files toolbar, click on the  Import Images  button.

The Import Images dialog box opens.

 3. In the Files section, click Browse to find and select the .psd image on your computer.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports 
the images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this 
will create two layers, one named "a" and one named "b". Layer "a" will contain the 
two first images and "b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can 
only import into layers that are compatible with your import options. For example, if 
you're importing images as vector drawings, you can only import them into vector 
drawing layers. 

 5. In the Import Options section, select the following option to import your image as its original format.

 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment 
section, decide on the size and placement of your image within the camera frame. 
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Depending on the Scene Settings (the height and width in pixels that you chose for 
your project), an image that you import may get scaled to the point where all its 
individual pixels become visible.

 6. Decide whether to select Vectorize Imported Items option.

 7. Click OK.

The Multilayer Image Import Settings dialog box opens.

 8. In the Create drop-down, select one of the following:

 l Single Layer: Imports the rasterized, flattened version of the PSD into a single layer in your 
scene.

 l Groups as Layers: This imports every group in the PSD file as a single layer in your Harmony 
scene. Then, every layer inside a given group is imported as a single drawing inside the layer 
in the Harmony scene.

 9. If your image has transparency, in the Transparency section, select how the colour values in the 
semi-transparent pixels in the image were premultiplied with their alpha values. This allows 
Harmony to demultiply the values so that it can properly blend the image with the other elements in 
your scene. 

You can choose between the following options:
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 l Premultiplied with Black: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to black they are. When an 
image that is premultiplied with black is loaded in a software that does not support 
transparency, it appears blended with a black background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements in 
your scene.

 l Premultiplied with White: The colour values of semi-transparent pixels in the image have 
been encoded so that the more transparent they are, the closer to white they are. When an 
image that is premultiplied with white is loaded in a software that does not support 
transparency, it appears blended with a white background. Select this to make Harmony 
reverse this premultiplication so that the image blends properly with other visual elements in 
your scene.

 l Straight: The colour of semi-transparent pixels in the image is encoded independently from 
their transparency. When an image that is not premultiplied is loaded in a software that does 
not support transparency, semi-transparent pixels simply appear fully opaque, making its 
edges appear pixelated. 

 l Clamp Colour to Alpha: This is the same as Premultiplied with Black, except that it also 
prevents the colour values for a given pixel from being higher than that pixel's alpha value. 
This option is only useful if you are working with images that are supposed to be 
premultiplied with black, but where the colour values of pixels have been increased without 
their alpha values being adjusted accordingly. 

TIP 

Typically, the composite image of a PSD file, which is imported when importing a PSD 
as a single layer, is Premultiplied with White, whereas the individual layers of a PSD file 
use Straight transparency. 

 10. Click OK.

The imported PSD file is imported into your scene. In the Timeline view, one or several layers are 
added to your scene, depending on the import options your selected.

NOTE 

If you import the PSD file with the Groups as Layers or the Individual Layers 
option, all of the layers and drawings imported into your scene will be linked to 
the same PSD file in your scene folder. Hence, deleting any of the drawings or 
layers imported from the PSD file is liable to delete all of the drawings imported 
from the PSD file.
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About Importing Vector Files
T-HFND-007-005

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony Essentials to convert your files to 
the Toon Boom format (TVG) and create a colour palette based on the colour settings of the original file. 

When importing AI and PDF files:

 l RGB is supported, CMYK is not.

 l Gradients and textures are not supported.

 l Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and 
Actionscript 3, cannot be imported.

 l When importing an Illustrator or PDF file in Toon Boom Harmony Essentials, by default the file will be 
imported as separate layers. The import will use the Illustrator file's top level groups as separate layer 
names. However, you can change this behaviour by deselecting the PDF/Illustrator Import as Separate 
Layers option, to import your file as a single layer .

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or 
multiplaning, it can easily be imported into Harmony. 

The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.
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Importing Adobe Illustrator (.ai) files and Portable Document Files 
(.pdf)

T-HFND-007-006

You can import vector Adobe Illustrator (.ai) files as well as Portable Document Files (.pdf) through the 
Library view and File menu. Make sure to have the rights to modify your Library folder and that the colours in 
your file are encoded in RGB. 

How to import an .ai or .pdf file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type in a name for the new template or keep the name of the original AI or PDF file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.
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The message window opens.

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option if you plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under 
the imported file’s name.
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Importing Flash Movies (.swf)
You can import Flash (.swf) files in Harmony exported for any version of Flash Player up to version 14.

IMPORTANT 

Some effects are not supported when imported from Flash movies into Harmony. 

How to import a SWF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the 
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain 
locked and you will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your.swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type a name for the new template or keep the name of the original *.swf file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until 

the copy cursor  appears before releasing the folder.
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 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before 
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session 
option. This might be useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created 
under the imported file’s name.

NOTE 

All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT 
DELETE THIS PEG. To maintain the look of your movie, it's important not to delete this peg or 
detach its child layers.
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The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become 
regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or 
drawings within symbols collapse into their corresponding parent symbol.

NOTE 

Some layers in your .swf movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate 
layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony Essentials 
file are grouped together in one folder. In our example, this means that when you scroll through the 
Drawing Substitution preview in the Library view, the different hand, leg, tentacles, antennae, torso 
and facial positions are all organized together.
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Distributing SWFs to Layers

In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers 
might be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers 
again. 

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the drawing that contains elements you want to redistribute onto 
individual layers.  To select the all the elements of the selected drawing layer, press Ctrl + A 
(Windows/Linux) or ⌘  + A (macOS).

 3. Do one of the following:

 l From the top menu, select Drawing > Distribute to Layers.

 l In the Tool Properties view of the Select tool, click the Distribute to Layers  button.

The number of drawing layers corresponding to the different grouped elements are created in the 
Timeline view. The selected elements in the original drawing layer are removed. Each element is 
distributed onto a new drawing layer.

 4. Repeat the process for each drawing that contains elements to redistribute.
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About FLA  Import
You can export files from Flash and import them in Harmony to  transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and macOS. It is not possible to do so on 
GNU/Linux versions.

On the Flash side, users can work with these versions:

 l Adobe Flash CS5

 l Adobe Flash CS5.5

 l Adobe Flash CS6

 l Adobe Flash CC

 l Adobe Flash CC 2014

 l Adobe Flash CC 2015

NOTE 

Exports from older versions of Flash are not possible.

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape 
lines, drawing objects, groups and bitmaps at the scene level won’t be exported. If these elements are present, 
you will be prompted to perform a clean up of the scene level. For details on importing Flash files, see Flash 
Export and Import Guidelines on page 629.

As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe 
Extension Manager—see Installing the Export to Harmony Option on page 613.

It is important to use the correct version of Adobe Extension Manager: 

 l If more than one version of Flash is installed on your computer, be careful where you install the extension. 
If it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in this version 
and not the other.
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 l If you have a previous version of the  extension, you must remove it first and install the latest extension—
see About FLA  Import on page 611.

Harmony includes a script specially created to import FLA Export packages. You must add this script to your 
interface in order to use it—see Displaying the Import Flash Scene Icon on page 624.

When you export your FLA files, a folder will be created that contains the stage.tpl and export.json files, 
as well as all the .swf and.txt  files in your scene. The export.json file is used by a Harmony script to 
organize and construct the hierarchy from your exported files.

Once the Flash project is successfully imported into Harmony, here's how the hierarchy was constructed:

 l Each symbol has its own peg in which all the transformation information is stored.

 l The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came 
from the rotation point of the symbol in Flash.

 l Registration point of the symbol in Flash represents the centre of the drawing space in Harmony. 
Therefore, the position of the drawing inside a symbol will be exactly the same in Stage.

 l One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you 
have more than one zone using the same colour, they will be linked to the same colour swatch.

 l If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects. 
Harmony is now able to understand when more than one symbol share the same mask in Flash. Each 
symbol sharing the same mask will be grouped by a composite and connected to the cutter.
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Installing the Export to Harmony Option

The extension is required in order for Flash to export files to Harmony. The extension is called Export to 
Harmony.zxp and is located here: 

OS Edition Location

Windows

Premium
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Essentials [version] Premium\resources\flash

Advanced
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Essentials [version] Advanced\resources\flash

Essentials
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony Essentials [version] Essentials\resources\flash

macOS

Premium
Applications > Toon Boom Harmony Essentials [version] 
Premium > tba > resources > flash

Advanced
Applications > Toon Boom Harmony Essentials [version] 
Advanced > tba > resources > flash

Essentials
Applications > Toon Boom Harmony Essentials [version]  
Essentials > tba > resources > flash

NOTE 

Before installing the extension, you must remove all Harmony offline and database preferences.

How to install the Export to Harmony extension

 1. Launch Adobe Extension Manager.

 2. In the top-right corner of the Adobe Extension Manager, click on Install.

An Open dialog appears.

 3. In the Open dialog, browse to and select the Export to Harmony.zxp file, then click on Open.

A message opens informing you that you're about to install the Export to Harmony extension.

 4. Click on Accept.

You may see the following message confirming that you want to install the extension. Click Install.
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 5. In order for the changes to take effect, you must close and restart Adobe Flash.

 6. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

 1. If open, close Adobe Flash.

 2. Start Adobe Extension Manager.

 3. From the Products list, select Adobe Flash. 

If you have a previous version of the Export to Harmony.zxp extension installed, it will be 
listed in the right pane.

 4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.

 5. Click Yes.
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Adobe has stopped  maintaining and updating their Extension Manager CC, therefore, it has become difficult to 
install extensions. In order to link an extension from Animate CC, follow the steps below. 

How to install an extension on Windows with Adobe Animate CC version 2015 and 
higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdWin

 3. Unzip the ExManCmd_win.zip package.

 4. Put the ExManCmd_win folder in a safe place.

NOTE 

The ExManCmd_win folder must not be deleted; this folder is necessary for 
installing or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads 
folder:

C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 17 
Essentials\resources\flash\flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. In the ExManCmd_win folder, hold Shift and right-click to select Open command window here.

 10. Enter the following command: 

ExManCmd.exe /install <filename.zxp>.

 11. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by 
the Extension Manager CC.
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 12. Open Animate CC.

 13. Access Top Menu > Commands.

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.

 

NOTE 

If you have a region language  other than English (US) installed on your computer, 
or if you have more than one language installed on your computer, Animate CC 
may not be able detect in which language folder the extension has been 
installed. If this occurs, you will not be able to see the Export to Harmony menu 
option in Top Menu > Commands list. To correct this, proceed to How to ensure 
Adobe detects extension files installed on your computer on page 616.

How to ensure Adobe detects extension files installed on your computer

 1. Browse to:

C:\Users\<UserName>\AppData\Local\Adobe\Animate <VersionNumber>

If Adobe detects more than one language on your computer, you will see multiple language folders in 
the path. For example:
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 2. Look inside each folder to detect the main language used by Adobe on your computer. To do so, 
compare the contents of both folders.

For example, inside the en_Ca\Configuration:

For example, inside the en_US\Configuration:
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The main folder is the one with more files. In this case, Adobe is using English (US) as the main 
language. The folder en_CA only contains what was installed with the extension installation: 
commands, Javascript and WindowSWF.

 3. Copy and paste the contents of the commands folder within the sub-language folder, to the 
commands folder within the main language folder .
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 4. Copy and paste the contents of the Javascript folder within the sub-language folder, to the 
Javascript folder within the main language folder.

 5. Copy and paste the contents of the WindowSWF folder within the sub-language folder, to the 
WindowSWF folder within the main language folder.
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How to install an extension on macOS with Adobe Animate CC version 2015 and 
higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdMac

 3. Unzip the ExManCmd_mac file.

 4. Put the ExManCmd_mac folder in a safe place.

NOTE 

The ExManCmd_mac folder must not be deleted; this folder is necessary for 
installing or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads 
folder:

/Applications/Toon Boom Harmony 17 Essentials/Harmony 
Essentials.app/Contents/tba/resources/flash/flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. Drag and drop the .zxp file directly into the ExManCmd_mac folder.

 10. In Terminal, go to the folder where the ExManCmd_mac package was extracted.
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For example, if you have put the ExManCmd_mac folder into the Downloads folder:

cd Dowonloads/ExManCmd_mac/

 11. Enter the following command:

Contents/MacOS/ExManCmd --install <filename.zxp>

 12. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by 
the Extension Manager CC.

 13. Open Animate CC.

 14. Access Top Menu > Commands. 

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.
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Exporting FLA Files

How to export FLA files for Harmony from Adobe Flash

 1. Open your.fla file in Adobe Flash. 

NOTE 

In case of a new file, it needs to be saved before continuing the exportation process. If not, the 
export won't be completed.

 2. Return to the scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

 3. Do one of the following:

 l Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony. 

 l Adobe Flash CC: Window > Extensions > Export to Harmony.

NOTE 

This window must be opened once after installing the extension in the extension manager 
because it creates a drect link to Harmony (even if the window is not used). Afterwards, you do 
not have to reopen it if there is no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will 
appear in Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value 
of Harmony. If needed, you can change the compression: Photo (JPG) or Lossless (PNG).

 4. Do one of the following:

 l In the Export to Harmony window, click Export button. 

 l Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:
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Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all 
groups to verify if any symbols are hidden inside, breaking drawing objects to transfer them as 
shapes, drawing substitutions, and so on. Problematic situations will also be mentioned. If nothing 
appears in the Output tab, then your.fla file is clean and does not need any conversions.

The .txt files contain the drawing substitution information and at which frame they are exposed. 
A .swf file is created for each symbol in Flash and a .tpl file is created of them. The corresponding 
export.json file is also created, which you will need when importing your Flash scene in Harmony. 
These files are in a folder located at the same location as the.fla file.  The folder name is the same 
as the .fla file.

NOTE 

If  a folder with the same name as the .fla file already exists, you will be prompted to replace 
the folder. Be aware that saving Flash projects as .xfl files will automatically create a folder 
with the same name as the .fla file. In this case, the folder of the export will be created inside 
the folder of the xfl. If this not what you want, place a copy of the.fla in another path on 
your computer before the export.
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Displaying the Import Flash Scene Icon

When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash 
Scene icon. If the icon does not appear in the Scripting toolbar, add it to the toolbar. Note that you will only 
have to do this once. After that, you can import Flash files whenever needed.

How to display the Flash Import script icon

 1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

 2. Click the Manage Scripts  button.

The Scripts Manager opens.

 3. From the Files section, select TB_Import_Flash_Scene.js. 

On your computer, here is the location of the script file:

 l Windows:
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 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Harmony Essentials\1400-scripts

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Advanced\1400-scripts

 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Essentials\1400-scripts

 l macOS: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Harmony/1400-scripts

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Advanced/1400-scripts

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Essentials/1400-scripts

On macOS, the Library folder is a hidden folder. To display the display the folder, told down the Alt 
key.

 l Global: [Server_Name] > USA_DB > scripts

 l Environment: [Server_Name] > USA_DB > environments > [environment_name]

 l Job: [Server_Name] > USA_DB > jobs > [job name]

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-scripts

 5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to 
the In Toolbar section.
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 6. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash 
scenes.

626

Harmony 17 Essentials User Guide                          



Chapter 10: Importing & Scanning

Importing FLA Files

Once your extension is installed, your FLA file has been exported and your displayed the FLA import script in 
your toolbar, you are ready to import your FLA file in Harmony.

How to import FLA files

 1. In the Scripting toolbar, click the Import Flash  button.

 2. In the Import Files dialog box, locate the export.json file contained in the folder that was created 
when you exported your files from Flash.

 3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery. 

 4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option. 

In a few moments, the .fla files are imported in Harmony. 
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 5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.
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Flash Export and Import Guidelines
The following points are guidelines for you to create optimal Flash files to export to or import in Harmony.

The following are limitations that apply when importing .swf files, whether they were exported specifically for 
Harmony or just regular Flash Movie files. 

Drawing Features
 l The line width will be preserved, whether it's constant or varied with the Width tool. 

 l Any line caps and line joins other than round will be converted to round line caps and line joins

 l The flow of gradients must be set to Extend Color, which is the default flow for gradients. Gradients with 
a Reflect or Repeat flow will cause the entire symbol in which they're located to be ignored. 

Effects

The following effects will not be imported by Harmony:

 l Filters (ie: Adjust Colour, Drop Shadow, Bevel, etc.)

 l Colour Effects (ie: Alpha, Advanced, Brightness and Tint)

 l Blending (ie: Layer, Darken, Multiply, etc.)

 l Render: Cache as Bitmap (Export as Bitmap is supported)

 l 3D Rotations

 l Component properties

Bitmap Images

Bitmap images must be either .jpg or .png format. Symbols that have their Render mode set to Cache as 
Bitmap will also be imported.

Flash Export Guidelines
The following are rules to follow when exporting assets from Flash for import in Harmony. 

Scene Root

What can be at the scene root:

 l Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:

 l Shapes: Colour shapes and line shapes

 l Bitmaps

 l Drawing objects
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 l Groups: The group works differently at the scene level. They are understood as shapes at the scene 
level—see Flash Export and Import Guidelines on page 629.

Timeline

These features can be used in the Flash file, but will not appear when imported in Harmony.

 l Guide layers for references

 l Locked layers

 l Disabled layers

 l Folders in the Timeline view

 l Other: Several symbols on the same layer/keyframe. Harmony will spread them over several drawing 
layers, implicitly performing a Distribute to Layers operation in the process.

Not recommended:

 l Mixed layers—see Flash Export and Import Guidelines on page 629

 l Symbols, shapes, bitmaps and groups in the same layer/keyframe

 l Symbols with drawing objects

Library View

In the Library view, the following will not be exported:

 l ActionScript Linkage

 l Embedded fonts

Mixed Layers

Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony. 
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers 
altogether.

A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be 
a mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony 
understands symbols better than groups or drawing elements, some information can be lost along the way.

Parameter Description

Drawing Objects
No matter what is inside a drawing object, it will always be understood as a 
shape. So if a drawing object shares the same layer with a shape, it won’t be a real 
mixed layer, since they are all understood as shapes.

Symbols and Drawing If there are symbols and drawing objects/shapes sharing the same layer, the 
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Objects/Shapes on the Same 
Layer

symbols will be separated from them and all the drawing objects/shapes will be 
kept together. Drawing objects and shapes cannot be separated. In Harmony, the 
symbols will have their own Drawing node and the drawing objects/shapes will 
share the same Drawing node. Since only symbols can have a name, its name is 
propagated to the Drawing node and peg.

Drawing objects and shapes, however, can't do this. Drawing objects and shapes 
will receive the name of the MovieClip followed by an underscore and an 
appropriate number. For example, if you have a group inside a symbol called 
HEAD, the group will be named HEAD_1 if there is already a Drawing node that 
was created with the same name.

Mixed Instances at the Same 
Level as a Symbol

Mixed instances at the same level as a symbol can occur when, at the same level 
inside a symbol, there is more than one type of element sharing the same timeline 
at a specific frame. Those elements may be mixed layers.

Type of problems that can occur if mixed instances are kept:

 l Order of appearance can be lost

 l Some layers can merge together

 l Transparency of shapes can cut other shapes
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Importing QuickTime Movies
T-ANIMPA-004-002

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation. 
Toon Boom Harmony Essentials allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

 1. From the top menu, select File > Import > Movie.

 2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE 

Do not browse for the movie file again. Leave the automatically generated field text as “many 
files selected”.

 3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see the 
Reference guide .

 4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the 
film frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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About Scanning
Harmony can receive images from any TWAIN device, such as  scanners or digital cameras. You can load these 
images as bitmaps into your scene or convert them into vector-based images that can be edited using 
Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of 
your device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the 
digital exposure sheet.

Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import 
them in Harmony. The scanning process is the point where the traditional production becomes digital. It's the 
moment where you use Harmony to control the project.
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Scanning Images 
Toon Boom Harmony Essentials can receive images from any TWAIN device such as scanners and digital 
cameras. These images can either be loaded into your scene as bitmaps or converted into vector- based images 
that can be edited using Toon Boom Harmony Essentials.

If your operating system does not automatically recognize your device after it has been connected, you must 
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the 
device manufacturer’s website.

How to scan images

 1. From the top menu, select File > Acquire > From TWAIN.

The Acquire from scanner window opens. 

 2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the 
Scanner menu. If none are available, check your device to ensure that it's properly connected to your 
computer. If your device still does not appear in the menu, you may have to shut down and restart 
the software.
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 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or 
existing layer—see the Reference guide .

 4. In the Drawing Options section, set the following options if desired:

 l Drawing Name: Name of the drawing to import.

 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click 
Scan.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the 
view.

 6. Click Scan to scan your drawing.

 7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next 
letter to capture your next frame.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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Vectorizing Scanned Drawings
You can turn scanned images into vector drawings, while maintaining the sketchiness of a pencil line or into 
vector images with a bitmap fill. Both options can add life to an animation, which straight vectorization with 
smoothing does not usually afford.

How to scan and vectorize drawings

 1. From the top menu, select File > Acquire from TWAIN or press Ctrl + Shift + S (Windows/Linux) or 
⌘  + Shift + S (macOS).

The Acquire from scanner window opens.

 2. Select your scanner from the Scanner list.
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 3. Click Preview to get a test scan of your drawing.

 4. In the Layer section, select one of the following:

 l Create Layer: Imports an image into a new layer. Type a name for the layer in the 
Name field. 

 l Add to Existing Layer: Imports the image into an existing layer. Select a layer from the 
Layer list.

 5. In the Vectorization section, select the Vectorize Image option and then set the following:

 l Colour: Creates a vector rectange with the bitmap as a texture inside.

 l Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-
based drawing. Set the Threshold and Smooth parameters.

Threshold: Determines which black, white or grey pixels become a black line. 0% means all the 
light pixels will be kept as black vector line. A value of 100% means only the very dark pixels 
become a black line.

Smooth: Determines the smoothness of lines. The higher the value, the less angular and bumpt 
the resulting lines will be.

Auto Apply: Automatically applies the colour or black and white settings to the scanned images.

 6. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the 
view.

 7. Click Scan to import your drawing.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until 
you have finished scanning all your drawings.
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About Custom Vectorization Parameters 

You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center 
modules when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green 
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure 
red, blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting 
in your tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker 
window and watch the indicator colour zone lines disappear.
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Creating Vectorization Styles 

With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to 
set the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

 l Black and White: All the lines become vector based and 100% black. The white areas become 
completely transparent.

 l Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained 
inside a vector frame. The white areas become completely transparent.

 l Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and 
turn them into 100% vector lines, preserving their original colours—see the Reference guide .

How to create or modify the vectorization parameters

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization 
parameters (i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

 l In the Layer section, decide on the layer options.

 l In the Import Options section, select the Convert to Toon Boom Vector Drawing option

 l Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

 4. The Vectorization Parameters dialog box opens.

 5. Set the different options available in the Vectorization Parameters dialog box—see the Reference 
guide .
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 6. Click the Vectorize  button to update the Vectorized Image preview.

The vectorized image is just a preview. The actual vectorization happens when you click OK in the 
Import Images dialog box. There are many options to try in the Vectorization Parameters dialog box. 
These are applied during the vectorization process.

 7. To set advanced parameters, read the information on the Help tab, then type in the Advanced 
Options field at the bottom of the dialog box.

 8. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan 
module vectorization style list, click  Save.

 9. In the Browser window, name and save the file.

 10. To save the current settings as your default settings, click Save As Default. To restore the default 
settings, click Restore Defaults.

 11. To load a vectorization style, click Load and locate the existing *.vof file.

 12. Click OK.
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Configuring the VectOptions.conf File

Toon Boom Harmony Essentials Server uses a file called VectOptions.conf to get the vectorization style 
when batch vectorizing a series of drawings. A series of default styles is available in this file, but you will 
certainly want to create your own to fit your production style.

How to set the VectOptions.conf file 

 1. Launch Configuration Editor:

 l Windows: Open the Start menu and, in the Programs list, select  Toon BoomHarmony 17 
Essentials > Tools >  Configuration Editor.

 l macOS: In Finder, go to Applications > Toon Boom Harmony 17 Essentials > Tools >  
Configuration Editor.

 l GNU/Linux: In a terminal, type the following command:

$ sudo /usr/local/ToonBoomAnimation/harmonyEssentials_17/lnx86_
64/bin/ConfigEditor

The Configuration Editor window opens.

 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your 
custom vectorization style. These options are the same as in the Vectorization Parameters dialog 
box. It is recommended that you create your vectorization style using Harmony and the 
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Vectorization Parameters window and copy the result parameters in this file—see About Custom 
Vectorization Parameters  on page 638

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new 
ones to the list using the parameters you got using the Vectorization Parameters window. Notice 
that some of the lines have a “#” sign at the beginning to indicate that the line is a comment and will 
not appear in the style list. The lines that have no sign at the beginning appear in the style list.

 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black 
Lines.

 6. Under the style name line, type the following: 

options:

 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization 
Parameters window.

‣ To open the *.vof file, use any plain text editor application.
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 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Essentials Scan on your computer, you can start the application 
and verify that the new style appears in the Vectorization Style list under Edit > Vectorization 
Style.  

NOTE 

If you are using the batch processing method available with Toon Boom Harmony Essentials 
Server to scan and vectorize drawings, the selected style must be available on all the machines 
included in the batch processing list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch 
processing.
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Chapter 11: Camera Set-up and Animation
T-HFND-009-001

Harmony contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis 
offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera 
position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field 
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the 
north-south (up-down) direction and the Z axis is the forward-backward direction.

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution and other parameters in the Scene Settings window. 

By default, a scene does not have a camera layer. In order to be able to tweak the camera's angle and position, 
you must add one to your scene. Although it is possible to have several cameras in the same scene, you can only 
view your scene using one camera at a time. This can be useful if you are still working on your scene composition 
and have different camera framing to try out.

The Camera layer is static which means that if you need to animate it, you must put it under a parent peg.

You can reposition your camera frame directly in the Camera view, using the advanced animation tools. 
Another way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing 
this positions the camera precisely where you want it to be rather than gauging it visually.
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Adding a Camera
T-HFND-009-002

By default, there is no camera in the scene. The frame visible in the Camera view is only a reference based on 
your project's resolution. In order to position your camera, you must add one to your scene.

How to add a camera                 

 1. Do one of the following:

 l In the Timeline view, click the  Add Layer  button and, in the pop-up menu, select 
Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

647



Selecting the Active Camera
T-HFND-009-003

You can add multiple cameras to your scene, but only one can be active at a time. You can select your active 
camera from the Camera list.

How to select the active camera from the Camera list

 1. From the top menu, select Scene > Camera > camera.
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Positioning the Camera Frame
You can grab the camera frame and move it around in the Camera view. You can also setup the camera position 
by entering coordinates and values in the Layer Properties view.

How to reposition the camera frame in the Camera view

 1. In the Tools toolbar, if  Animate Current Frame or  Animate Onion Skin Range mode is 
enabled, click on it to open the Animate pop-up menu and select Animate Off.

 2. Do one of the following: 

 l In the Advanced Animation toolbar, click the  Translate  tool.

 l From the top menu, select Animation > Tools > Translate. 

 l Press Alt + 2.

 3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the 
camera layer from the Timeline view.

The selected camera frame is highlighted.

 4. Drag the camera frame to a new position. 
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 5. To tilt the camera frame, do one of the following to select the Rotate tool:

 l From the top menu, select Animation > Tools > Rotate.

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 3.

 6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

 7. To move the camera frame closer to or further away from the scene, do one of the following to select 
the Scale tool:

 l From the top menu, select Animation > Tools > Scale.
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 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 4.

NOTE 

The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to set up the camera frame using the Layer Properties view

 1. In the Timeline view, select the camera layer.

 2. In the Layer Properties view, adjust the camera's properties.

 3. Type or use the numeric stepper to adjust the coordinate and angle values—see the Reference 
guide .
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Resetting the Camera Position
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the 
selected element to the initial value of the active tool. For example, if the Rotate tool is active, the 
transformation angle will be reset to 0 and if the Transform tool is active, then all parameters values will be 
reset.

How to reset the camera position

 1. In the Tools toolbar, select the Transform  tool or press Shift + T. If you want to reset a single 
parameter, select the corresponding Advanced Animation tool, such as the  Rotate  tool.

 2. In the Timeline or Camera view, select the camera layer.

 3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Animating the Camera
T-HFND-009-009

A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and 
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, 
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate 
the camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the 
position and angle of the camera. 

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or 
Top views, which can be especially useful when animating a camera in a multiplane scene, where each layer is 
positioned at a different distance from the camera. 

How to add a parent peg to a camera                

 1. In the Timeline view, select the Camera layer

.

 2. In the Layers toolbar, click the  Add Peg  button.

A Peg layer appears directly above the Camera layer and is automatically attached to it.

How to animate the camera

 1. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 2. In the Tools toolbar, select the  Transform tool or press Shift + T.

 3. On the right side of the Timeline view, on the Camera peg layer, select  the frame at which you want 
the camera movement to start.
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 4. Do one of the following to add a keyframe:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 5. In the Camera, Top or Side view, manipulate the camera so that it is in the right position at the 
beginning of your camera movement.
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TIP 

To make a 3D camera movement, you can manipulate the Camera in the Top or Side 
view, in which it appears as a cone.                              

 6. On the Timeline view, click on the cell where the camera movement will end.

 7. Do one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.

 8. In the Camera, Top or Side view, manipulate the camera so that it is in the right position for the end 
of your camera movement. 
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 9. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 10. In the Playback toolbar, click on the  Play  button to preview your animation.
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Chapter 12: Character Rigging
Harmony is a great tool for building characters. You can use different techniques and features to break down 
your puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create 
very advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with 
those concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformations on page 771.
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About Rig Types
T-RIG-001-001

A rig is the process in which you will take apart the multiple pieces of your character and then reattach them 
together to get them to move individually. Harmony provides you with a multitude of tools to help you build 
characters. From the simplest of rigs, to a fully rotating character. There are about as many ways to rig a 
character as there are individuals who make them. The complexity of the rig is often determined by the level of 
animation to be achieved.
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About Simple Rigs
T-RIG-001-002

Simple rigging is very fast and easy to do. It is built as follows:

 l All the body parts are independent

 l All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by 
a parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a 
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand 
to move along a curved path.
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About Drawing Hierarchy Rigs
T-RIG-001-003

When you want one part to follow another part, such as the forearm following the arm, you can attach the 
layers one to the other. For example, you can attach the forearm layer to the arm layer without having to 
encapsulate the forearm into the arm layer. They will still be parented, but you can access the forearm directly 
without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to 
select them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, 
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is 
often a good solution.

NOTE 

To attach one layer to another, you must drag the desired layer onto the other one in the Timeline 
view.

Harmony offers powerful techniques to create hierarchies between your layers without having to 
encapsulate layers into each other. These techniques are a great improvement over the less 
efficient and time consuming method of creating parenting between your layers by inserting 
symbols into other symbols. Therefore, rigging with symbols inside symbols is NOT recommended.
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About Peg Hierarchy Rigs
T-RIG-001-004

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that 
do not contain drawings. They are motion paths that you can use to control your entire puppet or advanced 
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale 
a body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that 
could be attached to that part. 

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer 
follow the same trajectory.
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About Scene Setup for Rigging
Planning your rig is an essential step in avoiding missteps at later stages. Once a rig has moved on to the 
animation level, it becomes more difficult to fix potential blunders, since updating the rig scene doesn't have 
repercussions on rigs outside of that scene.  These different topics will help you avoid such mistakes.
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About Models
To begin breaking down your puppet, you must first import your character into a new project. You can also 
draw your character directly in the scene.

You can import your character in several different formats: 

 l Library template—see Library & Templates

 l External vector format

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and 
scale it to fit inside the safe area frame.

If you have several views of your character, place each view in a separate cell and center them one on top of 
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the 
same size.
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Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. 
Then, import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all 
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any 
layer that is not in a folder group, by itself or otherwise, will not be imported.
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About Size Relation
Understanding the relative size of every character and prop is important for maintaining consistency and 
structure throughout your project.

A production may contain many characters and props. It is not unusual for these to have been created by 
different people. If there is no size control implemented, the characters and elements created by different 
artists can vary greatly in size. When this occurs, the characters that are put together in a scene will be out of 
proportion. The animator or person doing the scene setup will then have to scale them to the correct size.

When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is 
scaled to its proper size, the outline may be so thin that the difference between one character's outline and 
another's will not look very good.

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling 
them so they are in proportion with each other. This line up is very important and should be handed to any 
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body 
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually 
done during the character design step. When the character builder imports the model to the break down 
scene, the size relation should be correct.

Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can 
display the field chart using the Show Grid option in the Camera and Drawing views.
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How to display the field chart

 1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or ⌘  + ' (macOS).

‣ Click the Show Grid  button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good 
idea to create and save pens with precise sizes and parameters to trace and design your models and break 
downs—see About the Brush Tool on page 196.
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Setting Preferences for Rigging
 

Before you start adding layers to your puppets, make sure the Default Separate Position  is enabled.

With the Default Separate Position preference selected, when you create new peg layers, their X, Y and Z axes 
are independent from each other.

For cut-out animation, you want to have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at 
the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This 
gives you more freedom when animating with motion keyframes and nudging parts forward and backward 
over time.

How to set the Default Separate Position option

 1. Do one of the following:

 l Windows: Select Edit > Preferences.

 l macOS: Select Harmony Essentials > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (macOS).

 2. In the Preferences dialog box, select the General tab.

 3. In the Settings section, select the  Default Separate Position for Pegs option.

 4. Click OK.
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About Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention chart before 
starting the project. When dealing with thousands of characters, pieces and puppets, it is easy to get lost. 
Proper naming of both drawing layers and drawing substitutions is essential to keeping your workflow 
consistent throughout your project.
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Naming Drawing Layers
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient 
in later steps. 

One common practice is to add one or two letters for the character/prop name, so that we don't make it too 
long. You can then add the name of the part that you've separated. It is recommended to add an indicator of 
the position of your character's symetrical pieces to keep track of which part you are selecting. Common 
practice is to add either "F" or "B" (for front and back view) or "R" or "L" (for right or left). Avoid using spaces in 
between the words and opt for an underscore instead.

 l Character Orcus's right arm = 

  OR_arm_F 

  or 

  OR_arm_R.

Pink: Front or Right 

Blue: Back or Left
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About Character Breakdown
T-RIG-001-006

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what 
parts will be broken apart and how they will be divided. Will the hair be separated into one, two or three 
sections? Will the hand be separated from the sleeve? To determine what is best for your character, observe 
the model in the Camera or Drawing view.

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil 
and the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the 
eyeball. For a more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth 
shape, teeth, tongue and interior one from another.
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Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full 
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and 
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a 
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly overlapping 
and complete. A common mistake is to trace the part just as it appears on the model.
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Tracing the Model
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R 
(Windows/Linux) or ⌘  + R (macOS) to add new drawing layers.

 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select the drawing tool of your choice. There are two commonly used methods 
to drawing the parts of a cut-out character model:

 l Using the  Pencil tool, then smoothing your lines with the  Smooth Editor tool

 l Using the  Polylinetool. This method allows you to draw with great precision, but 
may take more time.

These methods ensure each part is made with as few points as possible, so that they are easy to 
manipulate, modify or redraw.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see 
About Palettes on page 416.

 5. If you prefer working in the Drawing view, do one of the following to display the other layers in 
washed out colours:

 l In the Drawing view toolbar, lick the  Light Table  button.

 l Press Shift + L.

 6. In the Camera or Drawing view, draw the new part.
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 7. If you want to close an open shape without drawing a visible outline, you can draw an invisible line 
using the  Stroke  tool.

NOTE 

By default, strokes created with the Stroke tool are not visible. To see strokes in your 
drawing, select View > Show > Show Strokes from the top menu or press K.

 8. In the Tools toolbar, select the  Paint or Paint  Unpainted  tool to colour your drawing.

 9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 10. In the Camera or Drawing view, paint your drawing.
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 11. In the Tools toolbar, select the  Select tool. Select your drawing and flatten the lines by clicking 
the  Flatten  button in the Tool Properties view.

 12. Repeat the entire process for every body part that you wish to make animatable. 
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Breaking Down the Main Parts

To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. 

Breaks a character into its main body parts. There is no need to create any layers prior to this process. Make 
sure your model is well centered and sized in the Camera view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the 
artwork of the part you want to break down. You will clean the extra bits and pieces later.

Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines 
and colour zones.

How to break down the main parts

 1. In the Timeline view, select the cell of the model that corresponds to the first view to break down.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or 
press Alt + S.

 l In the Tool Properties view, you can switch to the Lasso  selection mode.

 3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the 
Cutter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your previous 
selection.
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 4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.

 5. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

 6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

 7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

 8. Repeat the previous steps for each main body part.
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Breaking Down Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You are now 
ready to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this time you 
will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts

 1. In the Timeline view, lock your model layer by clicking its Lock  button.

 2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

 3. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press Alt + 
S.

 4. In the Camera view, create a selection around the part to break down.
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‣ If you click on a zone, the Cutter  tool will select the zone and end the selection at the first 
point of intersection that it meets. Click on the line with the Cutter tool to select it up to the next 
intersection.

 5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.

 6. In the Layer Name field, type the name of the layer you want to create following the naming 
convention you established previously.

 7. Select the Cut Artwork From Source option to remove the selected artwork from your original 
drawing. In this case, you want to cut the artwork from the colour model.

 8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

 9. Repeat the previous steps for each body part.
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NOTE 

If you forgot to add some artwork to a layer you previously created, you can always add it later. 

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from 
Drawing Selection dialog box by pressing F9 (Windows/Linux) or ⌘  + F9 (macOS). In the dialog 
box, select an existing layer from the list instead of typing a new name. Click OK to add the artwork 
to the existing drawing in the layer you selected.
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Breaking Down Other Views

If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

 l Breaking down the new view in a new set of layers

 l Breaking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are 
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Repeat the following steps for each extra view you need to break down.

How to break down the other views

 1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't 
forget to unlock the layer.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, in the Tools toolbar select the Select  tool or press Alt + S.

 2. In the Camera view, create a selection around the first part to break down. 

 3. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 
(Windows/Linux) or ⌘  + F9 (macOS).

The Create Drawing From Drawing Selection dialog box opens.

684

Harmony 17 Essentials User Guide                          



Chapter 12: Character Rigging

 4. In the Layer Name field, select the corresponding layer from the list if you want to use the same 
layers or type a new name if you want to create a new layer.

 5. Deselect the Cut Artwork From Source option to keep the selected artwork on your original 
drawing. You do not want to cut the artwork from the colour model.

 6. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as 
the cell it was taken from. It is not incorporated in the other view's drawings.

 7. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views, follow the exact same process as you did for the first 
view you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down Other 
Views on page 684.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to 
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing Parts and Articulations

Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and 
complete the articulation.

Cleaning the Parts

You will need to use a series of drawing tools to clean the parts:

 l  Brush tool

 l  Eraser tool

 l  Select tool

 l  Cutter tool

 l  Contour Editor tool

 l  Paint tool

 l  Close Gap tool

How to clean your drawings

 1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

 2. In the Timeline view, select the cell containing the drawing to fix.

 3. In the Camera view, delete the extra bits using the Select  or Cutter  tool. You can also use the 
Eraser  tool.
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 4. Draw the missing lines using the Brush  tool. If you use the Brush tool, it is recommended that you 
enable the Auto-Flatten  option in the Tool Properties view.

 5. Using the Paint  tool, paint the gaps. You can close some gaps with invisible lines using the Close 
Gap  tool or press Alt + C.

 6. Reshape your lines using the Contour Editor  tool or press Alt + Q.
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 7. Using the Select  tool, select the entire drawing and click the Flatten  button in the Tool 
Properties view to flatten your drawings.

 8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be 
present in your drawing or press K.

 9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any 
unnecessary invisible lines in the drawing.

 10. Repeat this entire process for each drawing to fix.
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About Articulations
Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move 
properly and will not look good.

If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect 
will create the joint for you.
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Creating Classical Articulations

Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent 
results, but it's not the most efficient method. In many instances, it causes limitations and extra drawing 
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually 
a circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping 
the bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

 1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the 
upper arm.

 2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor  
tool.

 3. In the Colour view, select an outline colour.

 4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part 
in a half-circle shape.

If you are working in the Drawing view, click the Light Table  button in the Drawing toolbar or 
press Shift + L.

 5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines 
that may be present in your drawing.

 6. In the Drawing or Camera view, select all the strokes in your drawing.

 7. In the Tools Properties view, click the Flatten  button.

 8. In the Drawing or Camera view, select all the strokes in your drawing.

 9. Repeat the previous steps for the other articulations.
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 10. In the Timeline  view, select the cell of the part that will be on top of the joint.

NOTE 

When placing rotation pivots later on, make sure they are positioned at the 
centre of the articulation.
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About Ordering Layers
T-HFND-005-005

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level 
in the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind. 
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same 
layers (front, three-quarter, back, etc.).
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Ordering Layers in the Timeline View
T-HFND-005-006

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be 
displayed behind. If you have multiple views, you should order your layers based on the most common view, 
which is generally the three-quarter front.

How to order layers

 1. In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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About Z Nudging
T-HFND-005-008

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as 
the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the 
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE 

You will do the same for the layers that are not in the right order on the extra views. Do not place 
the drawing on another layer. You want to keep all your drawings of the body parts in the same 
layers like a box containing all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:

 l Up and down (Y-axis)

 l Left and right (X-axis)

 l Backwards and forwards (Z-axis)
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Nudging Layers

T-HFND-005-009

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be 
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the 
Timeline view. The forward-backward position can also be animated over time.

How to nudge layers backwards and forwards

 1. In the Tools toolbar, select the Transform  tool. 

 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is 
around the Camera view before selecting the element.

 4. To move the element forward,  press Alt + Up Arrow and to move the element backward,  press Alt + 
Down Arrow.
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About Pivots
T-RIG-006-001

Even with a complex hierarchy, a rig is useless without positioning the proper pivot points. This will allow the 
puppet's pieces to rotate correctly. The arm needs to rotate from the shoulder and stay attached to the torso, 
so its pivot point needs to be positioned accordingly. A good way to achieve this is to position the pivot point 
exactly in the center of the articulation.

The initial position of the pivot point is always at the center of the scene. Sometimes there will not be an 
obvious place of rotation to place the pivot point, but it's a good idea to reposition the pivot to the best 
transformation point. For instance, the master peg, which generally controls the entire rig, is often best 
positioned between the character's feet.
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About Permanent Pivots
T-RIG-006-002

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate  
tool.
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Setting Permanent Pivots

T-RIG-006-004

In this section, we'll take a look at one of the options we have for setting pivots. The permanent pivot allows 
you to push your rigs to great lengths without having to worry about repositioning your pivot once it is set.

How to set the pivots with the Rotate tool

 1. In the Advanced Animation toolbar, select the Rotate  tool.

 2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, 
you can also hold down Ctrl (Windows/Linux) or ⌘  (macOS) and click on the piece whose pivot you 
want to set.

 3. In the Camera view, drag the blue pivot to reposition it.

 4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as 
where to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE 

If you added other pegs to your rig, you must set their pivot using the same 
method.
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Setting Multiple Permanent Pivots

You can simultaneously set the position of pivots for several drawing layers or pegs  that you would like to rotate 
and scale from the same point of origin, 

How to set pivots on multiple pegs

 1. Select the multiple pegs or drawing layers from either the node view or timeline view.

 2. Select any Advanced Animation tool, such as the  Rotate tool. 

 3. Reposition your pivot using the Advanced Animation tool

NOTE 

Never use the Transform tool to permanently position pivots. The Transform tool only 
temporarily repositions it to accommodate your transformation, usually during the animation 
process.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the drawings directly.

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This 
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the 
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to 
create a hierarchy of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 

NOTE 

It is also possible to make a drawing layer the parent of another drawing layer. Just like the way 
animating a peg animates its children layers, animating a drawing layer with children will also 
animate its children layers. Both layers will still appear in the animation.

How to create parent pegs for your layers in the Timeline view

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Peg button to add a parent peg to all selected layers.
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Creating Hierarchies
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should 
influence other limbs, and how they can move independently. For example, when rigging a simple character's 
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. 
This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and 
hand will follow. 

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can 
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig 
the legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want to make a child layer.
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 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you 
are not dropping the child layer between two layers. 

 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at 
the root. While rigging, if you want several layers to have a common parent, but no existing part of 
your rig can serve as that parent, create a new peg and nest those layers under that peg.

NOTE 

In the Timeline view, you can unparent layers by holding down Shift, dragging the selected 
parent away from the child layer and dropping it somewhere else in the list.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they are 
rendered. Layers on top of the list will be rendered over layers at the bottom of the list.  Should you need to 
change a layer's order while animating, you can nudge this layer's position on the Z-axis to override the layer 
order and force it to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.

 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the 
focus on the Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.
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Adding the Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows 
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is 
useful for positioning and scaling your character relative to the scene, as well as to animate your character's 
trajectory when it has to move between areas of the scene.

How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the  Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that your 
top layer is already a child of the peg, so don't include it in your selection.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers 
are added above the already parented layers, move that parented layer back on top of the layer 
stack.
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Invert-Cutting
When rigging a character, there may be instances when you want to have the ability to move a particular piece 
to give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the 
drawing sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't want to 
be visible.

How to mask an object in the Timeline view

 1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece 
to cut.

 2. Select the layer that will act as the mask.

 3. In the Timeline view, right-click on the layer and select Clone Selected Layers: Drawings and 
Timing.

 4. Select the layer to be masked.

 5. In the Layer toolbar, click the Add Layer button and select Effects > Cutter.
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 6. Click the Expand Parameters  button to display the Cutter properties.

 7. Drag the cloned layer ONTO the Matte parameter connection area.

The masking layer name appears in the Matte parameter area and the masking layer is 
repositionned above the effect.

The masking layer is no longer visible in the Camera view. You can see that the masking layer is 
connected to the Cutter effect by clicking the Show/Hide Additional Links  button to display the 
Additional Links section.

 8. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-
click on the Mask layer to open the Layer Properties window. In the Layer Properties window, 
enable the Inverted option.
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 9. In the Tools toolbar, select the Transform  tool and move the cut object within the masking zone.
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Grouping Rigs
Once your rigging is completed, you must group the puppet's skeleton to help organize the often large and 
complex networks. This way, once you have imported two or three characters into the scene, three Group 
nodes will be displayed instead of all the rigging connections of three puppets.

How to group nodes

 1. In the Node view, select all your nodes.

 2. In the top menu, select Edit > Group > Group Selected Layers  or press Ctrl + G (Windows/Linux) or 
⌘  + G (macOS).

Your nodes are grouped.

 3. Click on the Group node's right arrow to enter the group.

 4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select the 
Group category and select a Multi-Port Out node.
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 5. Drag the Multi-Port-Out node to the Node view.

 6. Connect the Composite node's output port into the Multi-Port Out node. 

An output port is created on your Group node.

 7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should now 
see an output port on your Group node.

 8. Click on the Group's Properties button to open the Layer Properties window.

 9. In the Layer Properties window, rename the Group node with your character's name.

 10. Click Close.
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Creating Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to 
create all of the function curves and block your pose in place.

How to create the keyframes

 1. In the Timeline view, collapse the master peg by clicking the Expand  arrow.

 2. In the Timeline view, select the first cell.

 3. Do one of the following:

 l From the top menu, select Insert > Keyframe. 

 l In the Timeline View toolbar, click the Add Keyframe  button.

 l Press F6.

NOTE 

If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates 
a keyframe but also duplicates a drawing.
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Chapter 13: Cut-out Animation
Harmony provides some great tools for rigging and animating cut-out character models. You can make simple  
rigs or give your characters flexible capabilities using peg hierarchies, groups, cutters, and deformers, among 
other things. You can create basic animations with the Transform tool, or more advanced animation with 
Deformers. Harmony also supports onion skin and image swapping features to help you animate efficiently and 
quickly. 
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About Animating with the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has many 
useful functions: 

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece 
from their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when 
many parts are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out 
animation.

When animating with the Transform tool, make sure to select the right selection mode. In this example, make 
sure that the Peg Selection  Mode  is disabled in the  Tool Properties view or it will limit the selection in the 
Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward 
Kinematics equivalent. 

The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global 
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the 
permanent pivot is displayed as a ghost. 

NOTE 

The interpolation of the animation poses is always calculated from each individual part's permanent 
pivot. If there's a parent peg on a limb, make sure to select it instead of making a selection of each 
part to avoid setting individual keyframes.
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Animating with the Transform Tool
The Transform tool allows you to move, rotate, scale and skew a selection or multi-selection. 

How to animate using the Transform tool

 1. In the Tools toolbar, click the Transform  tool or press Shift + T.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Timeline view, go to the frame on which you want to set the first position.

 4. In the Timeline toolbar, click the Add Keyframe  button or press F6. It is recommended to add a 
keyframe before moving the character. Moving a character's part without setting a keyframe will 
create keyframes only on certain parameters of the animation. You could run into issues later on 
when setting poses between existing ones. Creating a keyframe on all layers and parameters will 
ensure your pose is set and will not be modified by other poses later on.

 5. In the Camera view, select the element to animate and move it.

 6. In the Timeline view, go to the frame where you want to set the next position.

 7. In the Timeline toolbar, click the Add Keyframe  button or press F6.

 8. In the Camera view, animate the character.
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Resetting Transformations
With the Reset command, you can return a selected element to its initial position and scale values, depending 
on which tool is active. For example, if the Rotate  tool is active, the transformation angle will be reset to 0 
and if the Transform  tool is active, then all transformation  values will be reset.

The Reset All option Resets all transformations on the current frame in a selected layer. Your keyframe will 
remain, but all the values will return to the starting value. All transformations are reset regardless of the tool 
you're using.

The Reset All Except Z option resets Resets all transformations on the current frame except the Z position. This 
is useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different 
views of a character. You might want to reset the transformation, but not necessarily the Z position. 

NOTE 

When using the Transform  tool to select elements in the Camera view, always make sure the Peg 
Selection Mode  option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if 
keyframes were created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 
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 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all 
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Hierarchy Navigation
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the 
parent-child chain. You can navigate between the children of the same parent. You can also easily center on 
your selection in the Timeline view.
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Navigating Layers
Navigate between the layers in the Timeline view, using keyboard shortcuts or the Animation menu. This way 
of navigating only works for unparented layers or the children of a parent layer. If you are navigating between 
unparented layers, parent layers can be selected, but their children will be skipped. If you start on a parented 
layer (child), only the other children of the same parent will be available for selection.

How move up and down the layer stack

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Camera or Timeline view, select an unparented layer or child layer of a parent with several 
children.

 3. From the top menu, select:

 l Animation > Select Previous Sibling or press / to select the previous child layer.

 l Animation Select Next Sibling or press ? to select the next child layer. 
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Selecting Parent and Children
When animating, large movements that are made at the root (parent) of a chain cause secondary movements 
throughout the rest (children) of the chain. For example, when you rotate the arm of a character from the 
shoulder, the forearm and hand will follow. However, in order to make the movement appear natural and 
graceful, the forearm and hand should not move at the same speed or angle. As a result, animators often need 
to move up and down a chain, intermittently selecting parent and children, in order to make both large and fine 
movements.

How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the  Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. Do one of the following:

 l Select Animation > Select Parent or press B to select the parent layer.

 l Select Animation > Select Child or press Shift + B to select the child layer. 
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NOTE 

When going up or down your node hierarchy, these keyboard shortcuts skip any effect node in 
the hierarchy and only select either peg or drawing nodes. This is because these shortcuts are 
optimized for cut-out animation. In the Keyboard Shortcuts dialog, under the General section, 
these shortcuts are named Select Parent Skipping Effects and Select Child Skipping Effects. 
If you want to use keyboard shortcuts to navigate the hierarchy without skipping effect nodes, 
you can assign custom keyboard shortcuts  for the Select Parent  and Select Child  commands 
instead. 
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. In the Timeline view toolbar, click the Centre on Selection  button  or press O.
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About Keyframes
Keyframes are the building blocks of Cut-out animation. Unlike Traditional animation, where every pose is 
drawn, Cut-out animation uses keyframes to mark major poses (key poses) and lets the software create all the 
poses in between.

In Harmony, you can create two kinds of keyframes: Motion and Stop-Motion. Motion keyframes behave like the 
description above; they allow for the automatic creation of drawings between two keyframed poses. Stop-
Motion keyframes do not allow for interpolation between keyframes. They are often used to block poses, 
somewhat similar to what you would see in Traditional Animation.
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Creating Motion Keyframes
T-LAY-004-001

After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it 
using motion keyframes. When you use motion keyframes, the drawings gradually move to the next position 
instead of staying on the spot until the next keyframe.

How to  create motion keyframes

 1. In the top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click on the selection and select Insert Keyframe. 

 l Click the Add Keyframe  button in the Timeline toolbar.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected 
element, a keyframe will be automatically created on the current frame.
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How to convert a stop-motion keyframe into a motion keyframe

 1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.

 2. Do one of the following:

 l Right-click on the selection and select Set Motion Keyframe. 

 l Click the Motion Keyframe  button in the Timeline View toolbar.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (macOS).  
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Creating Stop-motion Keyframes
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing 
key poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the 
interpolation between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is 
constant. There is no animation generated by the computer between the poses. The drawing remains in 
position until the next keyframe, then moves to its new position.

How to create stop-motion keyframes

 1. In the top menu, make sure the Animation > Stop-motion Keyframe option is selected.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click and select Insert Keyframe. 

 l In the Timeline toolbar, click the Add Keyframe  button.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected 
element, a keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe

 1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

 2. Do one of the following:

 l Right-click and select Set Stop-Motion Keyframes. 

 l In the Timeline toolbar, click the Stop-Motion Keyframe  button.

 l Press Ctrl + L (Windows/Linux) or ⌘  + L (macOS). 
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About Swapping Drawings
T-RIG-004-001

Cut-out animation often requires using several different drawings on the same layers. For example, it is typical 
to have several drawings in the mouth layer so that you can animate the character's mouth by swapping its 
drawings, since it is complicated to animate a mouth with deformations and transformations alone. It is also 
typical to have several hand drawings in the hand layers, to avoid having to animate the hand's fingers 
individually and to allow for quick hand rotations. 

Hence, a cut-out animator is often required to swap drawings on some layers throughout the scene to complete 
their cut-out animation. To allow for a flexible, adaptable and optimal workflow, there are several ways to swap 
drawings. But before learning how to swap drawings, it is important to understand the difference between a 
layer's drawings and its exposure. In Harmony, each layer has its own pool of drawings, referred to as an 
element, Which drawing is displayed for a layer at any frame in the scene is called exposure. For example, a 
hand layer may contain dozens of different hand poses, but only display one or two of them throughout the 
scene, with the first one displayed for the first half of the scene and the second one displaying during the 
second half.

The exposure for a scene's layers is represented visually in the Xsheet view.
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You can also see how the exposure is separated throughout the scene in the Timeline view. Each exposure is 
represented by a gray rectangle. 

NOTE 

You can see which drawings are exposed in each rectangle by enabling Thumbnails—see 
Displaying Drawing Thumbnails in the Timeline View.
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When you swap a drawing, you change which one of the layer's drawing is exposed at the current frame up 
until the end of its exposure. For example, if you select the frame at the beginning of a drawing's exposure, and 
swap its drawing, the drawing will be swapped for the entire span of that exposure. 

Otherwise, if you select the frame in the middle of an exposure and swap its drawing, the drawing will be 
swapped from the current frame up until the end of that exposure.

This breaks the exposure into two exposures, which is visible in the Timeline view

There are three ways to swap drawings:
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 l The Drawing Picker view displays all the drawing in the selected layer's elements as thumbnails. You 
can see every drawing you can choose from and pick the drawing you want by clicking on it.

 l The Library view has a Drawing Substitution panel in its top-right corner. It allows you to swap 
drawings by selecting the drawing you want using a slider, or by typing the number or name of that 
drawing in a text field.

 l The Timeline view's Parameters column displays which drawing is exposed on drawing layers at the 
current frame. You can swap drawings by clicking and dragging on the drawing name, or by typing its 
number or name manually. 
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Swapping Drawings in the Drawing Substitutions View
The Drawing Substitutions view is the easiest way to swap drawings. When you select a layer, the Drawing 
Substitutions view will display every drawing in that layer's element as thumbnails. All you have to do is select 
the frame where you want to swap drawings, then click on the thumbnail of the drawing you want to expose.

How to swap drawings using the Drawing Substitutions view

 1. Add the Drawing Substitutions view to your workspace by doing one of the following:

 l In the top-right corner of any existing view, click on the  Add View button and select 
Drawing Substitutions.

 l In the top menu, select Windows > Drawing Substitutions.

 2. Do one of the following:

 l In the Timeline or Xsheet view, select the layer on which you want to swap drawings.

 l In the Tools toolbar, select the  Transform tool. Then, in the Camera view, select the layer 
on which you want to swap drawings.

NOTE 

Make sure the  Peg Selection mode is turned off in the Tool Properties view. 
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 3. In the Timeline or Xsheet view, select the frame at which you want to swap drawings. 

NOTE 

You can select a range of frames to substitute drawings in several frames at the same 
time—see About Swapping Multiple Drawings

 4. In the Drawing Substitutions view, click on the drawing with which you want to expose at the 
current frame.

The drawing exposed in the current frame is swapped with the drawing you just selected.

734

Harmony 17 Essentials User Guide                          



Chapter 13: Cut-out Animation

TIP 

You can also press [ to substitute the current drawing with the previous drawing and ] to 
substitute it with the next drawing. 
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Swapping Drawings in the Library View
T-LAY-003-002

The Library view has a convenient Drawing Substitution panel in which you can quickly swap the drawing in 
the selected frame for another drawing. Under the drawing thumbnail, you can use the slider to cycle through 
the drawings in the selected layer's element, or use the text field to type in the name of the drawing you want 
to expose.

How to swap images in the Library view

 1. Do one of the following:

 l In the Timeline or Xsheet view, select the layer on which you want to swap drawings.

 l In the Tools toolbar, select the  Transform tool. Then, in the Camera view, select the layer 
on which you want to swap drawings.

NOTE 

Make sure the  Peg Selection mode is turned off in the Tool Properties view. 
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 2. In the Timeline or Xsheet view, select the frame at which you want to swap drawings. 

NOTE 

You can select a range of frames to substitute drawings in several frames at the same 
time—see About Swapping Multiple Drawings

 3. Open the Library view. The Drawing Substitution panel, in the top-left corner, will display the 
selected drawing, the name of the layer and the name of the drawing at the current frame. 

 4. Do one of the following:

 l Click and drag on the slider to cycle through the drawings in the layer's element. Leave the 
slider once you see the drawing you want to expose in the thumbnail.
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 l In the text field, type in the number or name of the drawing you want to expose. 

 l Press [ to substitute the current drawing with the previous drawing and ] to substitute it 
with the next drawing. 

The drawing exposed in the current frame is swapped with the drawing you just selected.
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Swapping Drawings in the Timeline View
T-LAY-003-001

In the Timeline view, there is a Parameters column right of the Layers column. For drawing layers, the 
Parameters column displays the name or number of the drawing exposed at the current frame. You can quickly 
swap which drawing is exposed at the current frame by clicking and dragging on the value in the Parameters 
column. This is a more technical approach, as you do not have a preview of the drawing you are selecting. 
Hence, you have to know the name or number of the drawing you have to select. If you do know it, this 
technique can save you time as it can be done on the fly while working in the Timeline view.

How to swap a drawing in the Timeline view

 1. In the Timeline view, select the cell in which you want to swap drawings. 

 2. In the fields under the Parameters column, right of the layer's name, do one of the following:

 l Click and hold on the drawing number or name, then drag left to cycle back through the 
drawings in the element, or right to cycle forward through the drawings in the element. 
When the number or name of the drawing you want to expose appears, release the mouse 
button.

 l Double-click on the drawing number or name and, in the text field that appears, type in the 
name of the drawing you want to expose and press ENTER.
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About Swapping Multiple Drawings
If you select a range of frames in the Timeline view, you can swap drawings over the entire selected range of 
frames at the same time. However, there are two approaches to doing this, with two different results.

Drawing Picker, Library View or Keyboard Shortcuts
If you select a range of frames in the Timeline view, then use the Drawing Picker view, the Library view or the [ 
and ] keyboard shortcuts to swap drawings, the drawing in every frame in the selected range will be replaced 
with the new drawing. However, subsequent drawings will not be substituted, even if they are part of the 
same exposure. This will make the selected range of frames into its own exposure, breaking it from the 
exposure before and after the selection.

Timeline View
If you select a range of frames in the Timeline view, then use the Parameters column to swap drawings, the 
every frame in the selected range will be replaced with the new drawing up and until the end of the last 
exposure in the selection.
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About Key Exposures
Key exposures are a feature that can help preserve the exposure of specific drawings at specific frames of your 
scene when you perform drawing substitution. 

Before working with key exposures, it is important to understand how exposure works with Harmony. An 
exposure basically represents the span of time (or frames) during which a specific drawing is displayed in your 
scene. You can see the exposure of each drawing for a given layer in the Xsheet view. For example, here we 
have a layer in which drawing 1 is exposed from frames 1 to 6, then drawing 2 is exposed from frames 7 to 10, 
and drawing 3 is exposed from frames 11 to 12:

As you can see, in the Xsheet view, an exposure is represented  in its first frame by the name of the drawing, 
then in every subsequent frame by a vertical line. The number represents the moment where the exposure of a 
drawing starts, which is called a key exposure, the line represents the span during which this drawing's 
exposure is repeated, which is just called exposure.

Typically, key exposures are automatically created when the exposed drawing changes. However, it is possible 
to add key exposure in the middle of a drawing's exposure without changing the exposed drawing, simply to 
break its exposure into two separate blocks of exposure. For example, here, you have drawing 1 exposed from 
frames 1 to 8, but it is split into two blocks of exposure by a Key Exposure at frame 5.

This is useful for managing what happens when you perform drawing substitution. In Harmony, when you 
swap a drawing for another drawing at a specific frame, it replaces which drawing is exposed on all the frames 
starting from the current frame up until the next key exposure. For example, here, if we switch the drawing at 
frame 3 with drawing 6, drawing 6 will be exposed from frame 3 all the way to frame 8, because there is a key 
exposure at frame 9. 
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In this other example, because there is a key exposure at frame 5, if the drawing at frame 3 is switched from 
drawing 1 to drawing 6, the substitution will only happen on frames 3 and 4. The key exposure at frame 5 will 
prevent the substitution from spanning any further:

Hence, by using Key Exposures, you can make sure the drawing exposed at a specific frame does not get 
swapped just because you swapped the drawing in earlier frames. The drawing exposed with a Key Exposure 
only gets swapped if you select the frame where that Key Exposure is and swap the drawing in it.
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Adding Key Exposures

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This 
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property 
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is 
the same drawing or not.

How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

 l In the Timeline toolbar, click the Add Key Exposure  button.

 l Right-click and select Exposure > Add Key Exposure.

A new key exposure is added at the current frame. 
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Removing Key Exposures

When you no know longer need a key exposure, you can remove it. 

You can also remove key exposures of where the drawing is different than in the previous frame. When you 
remove a key exposure, the exposure of the drawing before it is extended over the exposure of the deleted key 
exposure.

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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Removing Duplicate Key Exposures

A duplicate key exposure is when a key exposure exposes the same drawing as the frame before it. You can 
quickly remove all duplicate key exposures in a span of frames and only preserve the key exposure that is 
necessary for your animation.

How to remove duplicate key exposures

 1. In the Timeline or Xsheet view, select the span of frames in which you want to remove duplicate 
exposure.

 2. Right-click on the selection and select Exposure > Remove Duplicate Key Exposure.
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About Eases
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature 
and set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve 
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle 
and left handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can 
pull on them to adjust the ease in and ease out, or type values in the fields. 

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and 
arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one 
frame.
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Setting Eases for Multiple Parameters
You can adjust eases for multiple parameters at once.

How to set ease on multiple parameters

 1. In the Timeline view, collapse your character model's hierarchy.

 2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the 
keyframe on every layer simultaneously.

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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 5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the 
Filters section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position 
Z and 3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. 
Note that Morphing is only available in Harmony Advanced and Harmony Premium.

 l Other: Applies the easing parameters to all the other selected functions, such as all 
functions created to animate effect parameters.

 6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values 
are calculated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value 
corresponding to the length of time you want the easing to last. The value must be 
between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how 
strong you want the easing out. The value must be between 0% and 100%.

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 7. Click one of the following buttons:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then 
selects the previous keyframe in the timeline.

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then 
selects the next keyframe in the timeline.
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 l Close: Closes the dialog box. If you did not apply the modifications, they will be 
cancelled.

NOTE 

If a range containing multiple keyframes is selected, only the first selected keyframe will be 
affected by the Seat Ease for Multiple Parameters functionality.
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About Using Onion Skin in Cut-out Animation
T-HFND-006-006

Although Onion Skin is primarily designed for frame-by-frame animation, you may find Onion Skin to be useful 
when doing cut-out animation. Just like with paperless animation, you can use Onion Skin to help you use 
existing poses in your scene as references to create new key poses, breakdowns or in-betweens. Also, 
displaying the Onion Skin for the different frames of a movement can help you visualize the timing of your 
animation.

NOTE 

The following topic explains how to control which layers in a cut-out rig are displayed in the Onion 
Skin. For more information on how to use Onion Skin in general, see About Onion Skin.

When the Onion Skin is displayed, it is displayed for:

 l The currently selected layer and its children.

 l All layers for which the Onion Skin is enabled.

When you enable Onion Skin, it is automatically enabled on the selected layer and its children, and disabled for 
other layers. This way, if you select your character rig's master peg, enable Onion Skin, it will be enabled for all 
its layers. If you select one of its layers to animate it, the Onion Skin for the whole rig will persist. 

This makes managing Onion Skin while doing cut-out animation relatively seamless. However, you may still 
want to manage which layers are visible in the Onion Skin. For example, you may want to add more layers to 
the Onion Skin as their position is needed to help you pose specific layers, or you may want to remove layers 
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from the Onion Skin to de-clutter it, or prevent it from hindering software performance. There are several 
techniques for managing which layers are displayed in the Onion Skin.

NOTE 

Keep in mind that the selected layer and its children are always displayed in the Onion Skin. Hence, 
when you select a layer and try to remove it from the Onion Skin, it will remain displayed in the 
Onion Skin until you select a different layer.

The Onion Skin  Button in the Tools Toolbar

When you click on the Onion Skin button in the Tools toolbar to enable Onion Skin, it is enabled on all the 
selected layers and their children. This is persistent even if you select different layers. Hence, it is a good idea to 
select your character model, or the part of it that you want to animate, before enabling Onion Skin.

When Onion Skin is enabled, if you click on the Onion Skin button, it will disable Onion Skin for all layers.

The Onion Skin  Button in the Timeline View

In the Timeline view, there is an Onion Skin button left of each drawing layer. If you click on it, it will toggle 
whether Onion Skin is enabled on that individual layer.
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Also, and perhaps more importantly, when a peg that is the parent of one or several drawing layers is 
collapsed, it also has an Onion Skin button. Clicking on this button will toggle Onion Skin on every drawing 
layer rigged under that peg. This allows you to quickly enable Onion Skin on your whole rig or on a large part of 
your rig.

Likewise, you can quickly disable Onion Skin on part of your rig this way.
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The Onion Skin Menu
In the top menu, under View, there is an Onion Skin sub-menu. This menu contains several commands allowing 
you to add or remove layers to and from the Onion Skin:

 l Add to Onion Skin: Adds the selected layer and all of its children to the Onion Skin.

NOTE 

You can run this command instantly by pressing Shift + S.

 l Remove from Onion Skin: Removes the selected layer and all of its children from the Onion Skin.
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 l Remove Unselected from Onion Skin: Removes every layer but the selected layer and its children from 
the Onion Skin. This can be useful if you have Onion Skin enabled on your whole rig or on a big part of 
your rig, but you selected a smaller part of the rig and you only want Onion Skin to be enabled on it. 

 l Add All to Onion Skin: Adds all of the layers in your scene to the Onion Skin:

NOTE 

You can run this command instantly by pressing Alt + Shift + O

 l Remove All from Onion Skin: Disables Onion Skin on all of the layers in your scene.
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NOTE 

You can run this command instantly by pressing Ctrl + Shift + O (Windows/Linux) or ⌘  + 
Shift + O (macOS).
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Using the Outline Mode
Use the Outline mode to temporarily convert all the drawings on a layer to outlines. You can still select and 
manipulate the drawings in this mode. Select a drawing by selecting its outline. The fill is not taken into account 
when making selections in this mode.

Toggling drawings to outlines

 1. In the Timeline view, click once on the Change Track Colour button of a layer to toggle all drawings 
of that layer to outlines, in the Camera view.
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Changing the outline colour

 1. In the Timeline view, double-click on the Change Track Colour button of a layer to open the Select 
Colour dialog box.

 2. In the Select Colour window, select a new colour for your outlines.
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 3. Click Ok.

The colour swatch and frames of the selected layer take on the new colour.

 4. In the Timeline view, click once on the change track colour of a layer to toggle all drawings of that 
layer to outlines, in the Camera view.
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The outlines of the layer's drawings appear in the selected colour.
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Flipping Through Poses
When animating, it is useful to flip through poses to see the flow of your animation without going through each 
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses

 1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

 2. Do one of the following:

 l From the top menu, select Animation > Go to Previous Keyframe or Go to Next 
Keyframe.

 l Press semicolon (;) and single quote ('). 
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Flipping Parts
If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip 
Vertical options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select the parts to be flipped.

 4. In the  Tool Properties view, click the Flip Horizontal  or Flip Vertical  option or press 4 or 5 
respectively.
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Animating Lip-Sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE 

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound
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When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, 
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and 
these drawings should be named by their corresponding letter. 

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 
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NOTE 

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the  Enable Sound  option.

 8. Press the  Play  button in the Playback toolbar to see and hear the results in the Camera view

You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, 
allowing you to identify which phonemes you should match your character's mouth to. You will also be using 
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the  Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.
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How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the  Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.
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Ordering  in Z-Depth
The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new 
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows 
you to create a multiplane and move elements closer or farther from the camera. This allows you to move the 
puppet’s pieces in front of or behind other ones without physically changing the layer position. 

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is 
created where different Z values can be entered. This allows the piece to move forward and backwards in 
space without requiring you to change the drawing’s original position or break the layer hierarchy. This also 
means that the layer ordering is maintained throughout the scene. You can combine animation assets so 
Harmony can interpolate them. 

How to nudge elements on the Z-axis

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.
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 2. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.

 3. In the Camera view, select the part to be repositioned and hold down the Alt key. 

 4. Using the Up Arrow or Down Arrow arrow keys, nudge the part until it moves to the desired 
position.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle 

 1. In the Xsheet or  Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells From the Timeline.

 3. In the Xsheet or  Timeline view, select the cell where you want your cycles to start.

 4. From the top menu, select one of the following:

 l Edit > Paste Cycle 

 l Press Ctrl + / (Windows/Linux) or ⌘  + / (macOS).
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The Paste Special dialog box opens.

 5. In the Cycles drop-down, select the type of cycle to paste:

 l Normal (forward): Pastes the selection as is, starting with the first cell and ending with the 
last.

 l Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

 l Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the 
last cell and ending with the first cell.

 l Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.

 1. In the Number of Cycles field, enter the number of cycles to paste.

 2. Click OK.
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How to create a reverse animation cycle

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

 2. From the top menu, select Edit > Copy.

 3. In the  Timeline view, select the cell where you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (macOS).
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Chapter 14: Deformations
T-RIG-007-001

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations  
act as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character 
made out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. 

A deformation skeleton is composed of deformation nodes, which are the various pieces (here represented as 
layers or nodes) required to articulate or deform your drawings, such as a series of bones or game bones.
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About Deformation Types
The 4 types of deformers are: Bone, Game Bone, Curve and Envelope. Each type has its own advantages and 
limitations and need to be rigged and handled in different ways.
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About Bone Deformations
T-RIG-007-002

The Bone deformation allows you to create a bone-like structure in which each part is solid, but with 
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or 
other parts that can be articulated such as torsos or fingers. 

For example, a Bone deformation can be used to articulate an arm that is made of a single drawing, so that the 
upper arm and forearm can be moved independently, without having to draw the upper arm and the forearm 
on different layers. Harmony will deform the drawing to make it look articulated. The different parts of a Bone 
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as 
animating articulations on different layers, without having to worry about parts detaching, pivot points, or 
clipping outlines.
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About Game Bone Deformations
T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like 
structure in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a 
character's limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For 
example, a Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that 
the upper arm and forearm can be moved independently, without having to draw the upper arm and the 
forearm on different layers. Harmony will deform the drawing to make it look articulated. The different parts of 
a Game Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
difference between the Bone and Game Bone deformations is that Game Bone deformations do not have a 
Bias property. The articulation folds also look slightly more rounded.
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About Creating Deformations
Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing.  However, whenever you close your project, the 
deformation controls display is turned off. When you reopen the project, you can display all controls or only 
some of them—see Displaying Selected Deformation Controls on page 17.
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About Selecting Elements for Deformation
Deformation groups are added to your scene's hierarchy in different places, depending on whether a drawing 
or peg element is selected.

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging tool, it 
is automatically created as a parent of the selected layer, and will affect the selected layer and all its children. 
Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you could rig 
the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and the hand is the 
forearm's child. Then, if you create your deformer on the upper arm, it will be created as a parent of the upper 
arm, and will hence affect the whole arm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you 
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's 
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers that are 
under a deformer, they will exit the intended deformation zone, and may appear severely warped and 
distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under deformers 
should only be animated if the deformer is left untouched. Since the deformer will be created as a parent of all 
the peg's children, it will affect all the layers under the peg. 
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Creating a Split Deformation Chain
It is possible to create a deformation chain that splits into multiple branches, allowing to rig complex drawings 
with multiple extremities using a single deformation chain. 

When creating a split deformation chain, a Deformation Composite layer is automatically added to your rig. This 
deformation composite connects all the branches of the split deformation chain to the drawing it deforms. You 
can see which deformation layers are connected to the Deformation Composite in the Additional Links column 
of the Timeline view,.

How to create a split deformation chain

 1. Select the drawing layer or the deformation chain to which you want to add a branch. 

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer controls in the Camera view. This also hides all the deformer controls that were 
displayed.

 3. Select the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 4. In the deformation chain, select the point from which you want the new deformation branch to 
start.

 5. Place the cursor where you want your new branch's first point to be and click. A new chain is 
created.

 6. Create the remainder of your chain's points as you would create a regular deformation.
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NOTE 

When using the Rigging tool, you can select which existing deformation point you want the next 
deformation point you create to branch from at any time by selecting a point in the Camera view. 
When you create a deformation point, it is always linked to the currently selected point, if any. 
Creating a point automatically selects it, which is why deformations are built in a single chain by 
default. 
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About the Envelope Creator
The traditional method of creating envelope deformations is to create it point by point. However, since 
envelopes are often used to deform drawings and shapes around their outlines, having to create envelope 
deformation chains by tracing their outline with the Rigging tool may be redundant. 

Using the Envelope Creator, you can automatically generate a deformation chain that either wraps around the 
outlines of your artwork, or goes right through its shape. This can help you quickly generate envelope or curve 
deformation chains based on your artwork. 

Before making the Envelope Creator generate an envelope, you can configure the amount of points it should 
create on the deformation chain as well as how those points will be distributed along the shape. If the results of 
the Envelope Creator are not satisfactory, you can try tweaking the parameters and make it generate a new 
envelope, and repeat the procedure until you get the best deformation chain possible.
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Editing the Resting Positions for Bone and Game Bone Deformations
Every deformation point has a resting position. The resting position is important as it acts as the starting point 
for all the transformations that will be made to the drawing when animating. Using the Rigging tool, you can 
make adjustments to the resting positions of the point in a deformation chain.

How to make adjustments to a Bone or Game Bone deformation chain

 1. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to edit.

 l In the Timeline view, select any part of the deformation chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 1. In the Deformation toolbar, click the  Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 2. In the Camera view, set up the deformation chain.

 l To rotate the a bone, click and drag on it. This will rotate the selected bone and all 
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subsequent bones in the chain.

 l To offset the whole chain, click and drag on its root control point.

 l To reposition an articulation, click and drag on its control point.
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 l To adjust an articulation's radius, click and drag on its radius control point. Make sure 
the radius of the articulation covers the articulation itself.

 3. Repeat until all the articulations and bones of the chain are correctly aligned to the element to 
which it is linked. 

 4. Test your modifications using the  Transform  tool.

TIP 

When manipulating the articulation of a Bone or Game Bone deformer, you can press and hold 
the Alt key to lock the bone's angle and only shorten or elongate the bone. You can also hold 
the Ctrl (Windows/Linux) or ⌘  (macOS) key to break the articulation off its chain and make it 
into a new, separate deformation chain.

How to add an articulation to a Bone or Game Bone deformation chain

 1. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to edit.

 l In the Timeline view, select any part of the deformation chain you want to edit.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.
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 3. In the Deformation toolbar, select the  Rigging  tool.

The deformation chain turns from green to red, meaning that you are editing the deformation chain 
rather than animating it.

 4. Press and hold the Alt key.

 5. While holding the Alt key, click on the bone where you want to add an articulation.
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Selecting Region of Influence Types
There are four types of region of influence:

 l Zero: This creates no influence around the deformer.

 l Infinite: This is the default option. The influence goes all the way to the image boundaries or until it 
intersects with another zone of influence. When working on a cut-out puppet built on several element 
layers, the best choice is to keep the default Infinite option as the zone of influence type. In the following 
examples, the zones of influence are explained through deformation chains on a single bitmap image. It's 
also recommended to keep the regions of influence to Infinite when using Envelope deformers.

 l Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value. 
When you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and 
make sure that only the element you want to follow the deformation is included inside the zone.

 l Shaped: This creates a custom region of influence around the deformer that can be adjusted using 
control points and Bezier handles. When you set up the boundaries of your Shaped zone of influence, 
you should be as accurate as possible and make sure that only the elements that you want to follow the 
deformation are included inside the zone.

  When you have an Elliptic zone of influence selected in the Node view, you can convert it to a Shaped 
zone using the Convert Elliptic Zone of Influence to Shape option.

How to select a region of influence type

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see 
Displaying Selected Deformation Controls on page 17.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:

 l Zero

 l Infinite

 l Elliptic

 l Shaped
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Setting Up Elliptic Regions of Influence
An elliptical region of influence is suited for regular shapes. Modify its parameters to refine the region 
boundaries.

How to set up the Elliptic region of influence

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see 
Displaying Selected Deformation Controls on page 17.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

 4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius
This defines the size of the fade area around the actual region 
of influence's boundaries.

Transversal Influence Radius 
Left

When the Symmetric Ellipse of Influence option is enabled, 
this field controls the Left and Right transversal radius values. 
When disabled, it controls the size of the left transversal 
radius. By default, this value is set to 2.

Transversal Influence Radius 
Right

When the Symmetric Ellipse of Influence option is enabled, 
this field becomes inactive. The Left Transversal radius value 
is automatically applied to the Right Transversal. When the 
Symmetric Ellipse of Influence option is disabled, it controls 
the size of the Right Transversal radius. By default, this value 
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is set to 2.

Longitudinal Influence 
Radius Begin

When the Symmetric Ellipse of Influence option is enabled, 
this field becomes inactive. The End Longitudinal value is 
automatically applied to the Begin Longitudinal value. When 
the Symmetric Ellipse of Influence option is disabled, it 
controls the size of the Begin Longitudinal radius. By default, 
this value is set to 0.25.

Longitudinal Influence 
Radius End

When the Symmetric Ellipse of Influence option is enabled, 
this field controls both the Begin and End Longitudinal radius 
values. When this option is disabled, it controls the size of 
the End Longitudinal radius. By default, this value is set to 
0.25.

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be 
symmetrical on both the transversal and longitudinal radii. In 
this case, use the Transversal Influence Radius Left field to set 
the transversal radius value and use the Longitudinal 
Influence Radius End field to set the longitudinal radius value. 
The two other fields will remain unused unless you disable 
the Symmetric Ellipse Influence option. In that case, you can 
set up different radius sizes for the four radii directions.

 5. You can also modify the elliptic shape in the Camera view using the  Rigging  tool.
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 l If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the 
Camera view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging 
it left/right will modify both longitudinal radius sizes. Dragging it up/down will modify both 
transversal radius sizes.

 l If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera 
view. Drag the top-corner point left/right to modify the end longitudinal radius size and up/down to 
modify the left transversal radius size. Drag the bottom-corner control point left/right to modify the 
beginning longitudinal radius size and up/down to modify the right transversal radius size.
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Setting Up Shaped Regions of Influence
A Shaped region of influence is suited for irregular forms. Modify the region parameters to refine the shape's 
boundaries.

How to set up the Shaped zone of influence

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see 
Displaying Selected Deformation Controls on page 17.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties, 
the zone of influence will be square. This square has control points on all four corners and each 
control point as two control levers. If you converted an Elliptic zone to a shape, the zone will have 
more control points and handles.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—see Setting Up Shaped 
Regions of Influence on page 10.

 l In the Camera view, use the Rigging tool and drag a control point to redefine its 
position and shape.
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 l Click and drag the control lever handle to modify the corners and redefine the shape.

 l Hold Alt down while dragging the control lever handle to move one handle at a time.
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Converting Elliptic Regions of Influence into Shapes
After you have tried tweaking an elliptical region of influence, you may find that you need to convert the ellipse 
into a shape, in order to create a more precise region. Instead of losing all the tweaks you have made, you can 
use the elliptical region you have created as a base for a Shaped region of influence.

How to convert an Elliptic zone of influence to a shape

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see 
Displaying Selected Deformation Controls on page 17.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to 
display the deformer of the selected piece.

 3. In the Tools toolbar, click the  Rigging  button.

 4. In the Tool Properties view, in the Operations section, click the Convert Elliptic Zone of Influence to 
Shape  button.

The zone of influence is automatically converted to a shape. The shape is retained and control points 
appear around the zone, so you can customize the shape. 
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About Assembly
After you have created all the deformation chains for your character, you will need to assemble these separate 
body parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body 
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the 
deformations down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation 
chain but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will 
follow the movement of the chain just like a regular cut-out character hierarchy piece without being influenced 
by the deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the 
deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will 
automatically rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of 
your character will be rigged with a deformation chain, you must set pivot points for the pieces that are not 
using deformations—see Setting Permanent Pivots on page 699.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep in mind:
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 l You cannot parent deformers directly because deformers are not designed to be used on other 
deformers. To assemble deformers, you must insert a Kinematic Output node.

 l Your peg must be placed above the deformer.

14



Assembling in the Timeline View
In order to assemble the rigged parts of your character in the Timeline view, you need to use a Kinematic 
Output layer.

How to assemble a puppet using the Kinematic Output node in the Timeline view

 1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

 2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

 3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you 
want your limb or piece to follow. For example, onto the neck deformer if you want your head to 
follow it without being deformed or onto the arm deformer if you want your hand to follow.
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 l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder 
them—see About Ordering Layers on page 693.

 l It's good practice to rename the Kinematic Output layer to reflect which deformer it is 
assigned to as the Timeline view can become very large and layers can be positioned 
far apart. Select the Kinematic Output node and in the Layer Properties window, 
rename the node. You can also double-click on the layer's name.
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Displaying Selected Deformation Controls
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
controls won't display automatically. Likewise, deselecting a deformation chain will not hide its deformation 
controls. 

Before you can animate or modify an existing deformation chain, you must manually display it.

How to display deformation controls

 1. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to display.

 l In the Timeline view, select any part of the deformation chain you want to display.

 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

NOTE 

The Show the Selected Deformation Chain and Hide All Others button will display all 
deformation chains that are in the hierarchy of the selection. For example, if the master peg of 
a character model is selected, all of its deformation chains will be displayed. Likewise, if multiple 
layers linked with different deformation chains are selected, all of their deformation chains will 
be displayed.
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Hiding Deformation Controls
If you no longer want to animate or modify deformers, you can hide the deformation controls so that they no 
longer clutter the Camera view.

How to hide deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard 
the current selection, then click on  the  Show Selected Deformation Chain and Hide 
All Others  button in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the  Show the Selected 
Deformation Chain and Hide All Others  button in the deformation toolbar.

 l In the Camera toolbar, click the  Hide All Controls  button. 

 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.
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About Deformation Animation
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on 
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a 
deformer, except it requires using the  Transform  tool instead of the Rigging tool. When the Transform tool 
is selected, deformation controls in the Camera view display in green, which means they are in animation mode, 
whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.
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Animating Bone and Game Bone Deformers
You can add keyframes to deformers reposition their deformation controls to create animated sequences.

How to animate Bone and Game Bone deformations

 1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 2. Select the first frame of the scene.

 3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing 
one of the following:

 l Right-click on the first frame in the Timeline and select Extend Exposure. 

 l Press F5. 

 4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will 
make your model exposed (visible) throughout your whole scene.

 5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame 
of every layer of the model. This ensures that when you make the second pose later, your first pose 
will not be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 6. In the Tools toolbar, select the  Transform  tool or press Shift + T.

 7. In the Tools toolbar, if Animate Off or  Animate Onion Skin Range mode is selected, click on it 
to open the Animate pop-up menu and select  Animate Current Frame.
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 8. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to animate.

 l In the Timeline view, select any part of the deformation chain you want to animate.

 9. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 10. In the Camera view, do the following:

 l To rotate the whole limb, click and drag on the first bone. This will rotate the first bone 
and all subsequent bones.

 l To bend the limb, click and drag on another bone. This will rotate the bone and all 
subsequent bones, but will leave the bones before it in their current position.
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 l To reposition an articulation, click and drag on its control point. This can be used to 
rotate, shorten or extend the bone, and will offset all subsequent bones.

 l To shorten or extend a bone without rotating it, press and hold the Alt key, then click 
and drag on its control point.

 l To offset the whole limb, click and drag on its root point.

TIP 

You can also nudge an articulation in any direction by selecting it, then 
pressing on the arrow keys.

 11. In the Timeline view, go to the frame on which you want to set the next key pose. 

 12. Add a keyframe on the current frame by doing one of the following:
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 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 13. Transform your deformer's points to make your new key pose. 

 14. Repeat the previous steps until your animation is complete. 

TIP 

You can also manipulate the deformers by selecting them, then typing their coordinates 
manually in the Layer Properties view.                  
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Resetting a Deformer to its Resting Position
You can reset the positions deformation points to their original resting positions, whether for the current frame 
or for the entire scene.

How to reset the position of one or several deformation points at the current frame

 1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the 
resting position.

 2. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to reset.

 l In the Timeline view, select any part of the deformation chain you want to reset.

 3. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 4. In the Camera view, select the deformation point you want to reset. 

TIP 

You can select several deformation points by pressing and holding Ctrl, then clicking on 
each point you want to reset to add them to the selection.

 5. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of 
the selected chain on the current frame.

How to set the position of all the points of a deformation chain throughout the scene

 1. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation 
chain you want to reset.

 l In the Timeline view, select any part of the deformation chain you want to reset.
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 2. In the Deformation toolbar, either:

 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the 
selected element's deformation chain and hide any other deformation chain that is currently 
displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation 
chain along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 3. In the Deformation toolbar, click the  Reset All Keyframes button.
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Disabling Deformations in the Camera View Preview
When adding new drawings while animating, you may need to see the reference drawings as their original 
resting position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable 
deformations in Harmony so that all drawings appear in their resting position.

NOTE 

Disabling deformations is only a display mode. Although drawings will not appear deformed in the 
Camera view, even in Render View mode, they will still be deformed in the rendered images.

How to enable or disable deformation preview

 1. In the Deformation toolbar, click on the Enable Deformations  button to toggle deformation 
preview.

26



Transferring Curve Positions of Legacy Deformations
You can Lets you transfer all of the information from first curve deformer to its parent Offset node. This is useful 
for a legacy scene created using Curve deformations where the Offset's position has been placed far away from 
the drawing to make sure it doesn't affect  the drawing's deformation. You can bring back the offset and give it 
the first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The 
offset no longer needs to be placed far away.

How to transfer a curve's position to its parent offset

 1. In the Node view, select the root Offset and the first curve.

 2. From the top menu, select Animation > Deformation > Set Curves and Offsets Independent from 
Parent.

 3. In the Node view, select only the first curve node.
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 4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.

In the Node view, the first Curve node is disabled and the values are transferred to the parent 
Offset node.
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Converting Legacy Deformation Chains
You can also convert a legacy deformation rig to the new format using a script. You can select which chain you 
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original 
puppet is maintained.

How to convert legacy deformation chains to the new structure

 1. In the Node or Timeline view, select the deformation group containing the chain you want to 
convert to the new structure.

 2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the 
toolbar, you can load it.

 l In the Scripting toolbar, click on Manage Scripts

 l In the Script Manager dialog, in the File column, select the TB_
CovertLegacyDeformation.js script. If you cannot find the script in the list (most likely 
due to a software upgrade installation), you can load the script through the Script 
Editor view from the default resources folder—see Importing Scripts in the Scripting 
guide.

 l In the Functions column, select TB_ConvertLegacyDeformation.

 l Click the Right Arrow button to move the function to the Scripting toolbar.
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 l Click OK.

The legacy chain is converted.
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Chapter 16: Effects

Chapter 16: Effects
T-HFND-010-001

When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs, 
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the 
way layers or groups of layers are rendered in your scene. 

Effects are special types of layers that you can add to your scene's structure. For an effect layer to work, it must 
be connected as the child of a drawing, a group, or another effect. Effects only alter the element that they are 
connected to. This gives you flexibility in deciding which elements of your scene are affected by an effect.

Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area 
they should affect. The most basic example of this is the Cutter effect. Alone, a cutter effect has no impact on 
the drawing it is connected to. Once combined with a matte layer, the Cutter effect cuts the shape of the matte 
out of the drawing.

A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the 
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details 
in the matte layer are ignored by the effect, only its shape is taken in account.

In the Timeline view, an effect must be rigged as the child of the drawing layer or group it is meant to affect. 

32



If the effect can use a matte layer, it will have a Matte parameter when you expand its parameters list. You can 
drag and drop the layer you want to use a matte for your effect onto the Matte parameter of your effect to link 
them.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be connected. 

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using 
the Layer Properties view. You can also double-click on the layer to open its Layer Properties dialog.  If desired, 
you can even animate the parameters of your effect by converting their values to functions. 
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Adding Effects Layers
T-HFND-010-004

In Harmony, you can add effects through the Timeline view, connecting them to your drawing layers and then 
adjusting the parameters until you achieve the look you want.

How to add an effect

 1. In the Timeline view, select the layer on which you want to add an effect.

 2. Do one of the following:

 l In the top menu, select Insert > Effects and select the effect you want to add. 

 l In the Layers toolbar above the layer list, click the Add Layers  button, select 
Effects then select the effect you want to add. 

 l Right-click on the layer, then select Insert > Effects and select the effect you want to 
add. 

The effect appears in the Timeline view, underneath the selected layer. 
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Connecting Effects
T-HFND-010-006

For an effect to work, it must be connected to a layer or group. The effect will be applied to the image output by 
the layer or group, and the transformed image will be composited with other elements in the scene. 

How to connect an effect

 1. In the Timeline view, select the effect you want to connect.

 2. Drag and drop the effect over the layer or group which you want it to affect.

The effect will become a child of the layer or group on which you dropped it. It will appear right 
beneath that layer or group, with its icon and name indented towards the right. 
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Adding a Matte Drawing to an Effect
Some effects can use, or even require the use of a matte layer. The matte layer is a drawing that determines the 
area that the effect affects.

For example, a Cutter effect needs to be connected to a matte layer, because it uses the drawing in the matte 
layer to determine which part of the drawing to cut out. However, a Colour-Scale effect can be used without a 
matte layer, in which case it will affect the colour of all of the drawing it is connected to, but if it is connected to 
a matte layer, it will only affect the colours of the part of the drawing that is covered by the matte drawing. 

TIP 

Drawing layers can also be connected to a matte layer. When a drawing layer has a matte layer, 
the part of the drawing covered by the matte layer is cut out from that drawing, which is the same 
as if the drawing was connected to a Cutter effect—see About Masking and Cutting Parts of 
Elements in your Scenes on page 56.

How to connect a drawing to an effect's matte connection                 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.
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NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Timeline view, locate the effect layer for which you created a matte and click on the Expand 
 button right of its name.

Just below the effect, a list of parameters for the effect appears. If the effect has a matte connection, 
the first parameter in the list will be Matte, and its value will be <Drop layer here>.

 5. Click and hold on the matte layer, then drag and drop it over <Drop layer here>.

The matte layer will be set as the effect's matte property.

<
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NOTES 

 l When a drawing layer is used as an effect's matte, the artwork in that layer is not 
visible in the scene, since it is only used as the effect's matte. 

 l If you want to disconnect the effect from the matte, you can click on the Unlink  
button at the right of the Matte parameter to unlink the matte layer from the effect. 
This will make the matte drawing visible in the scene again. 

 6. By default, the effect is applied to the matte's opaque areas and the matte's transparent areas are 
ignored. If you want to invert this effect, which means apply the effect on the matte's transparent 
areas and ignore the matte's opaque areas, double-click on the layer (but not on its name) to open 
its Layer Properties dialog.

 7. In the Layer Properties dialog of the effect, there should be an Invert Matte parameter. If the effect 
has several tabs in its layer properties, you might have to look through each tab to find this 
parameter. Check the check box for this parameter to invert the effect of the matte.

NOTE 

For Cutter nodes, this parameter is just named Inverted. 
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Configuring an Effect
Once your effect is connected, you can configure it by changing its layer properties. There are two ways to 
access a layer's properties:

 l By selecting it. Its layer properties will display in the Layer Properties view, which can be added to your 
workspace.

 l By opening its Layer Properties dialog. 

NOTE 

Most effects do not have a visible effect in the Camera view's default preview mode (OpenGL View 
). This preview mode is very fast and is optimized for animation, but not for effects. To preview 

an effect as you change its parameters, you must set the Camera view's preview mode to Render 
View , which will update slowly, but will render the effects as they would appear in the final 
rendered image. 

How to view a layer's properties in the Layer Properties view

 1. Do one of the following to display the Layer Properties view:

 l In the top right corner of any existing view, click on the Add View button and select Layer 
Properties.

 l In the top menu, select Windows > Layer Properties.

 2. In the Timeline view, select the effect layer you want to configure.

The selected layer's layer properties are now displaying in the Layer Properties view. 

How to open a layer's Layer Properties dialog

 1. In the Timeline view, double-click on the effect layer you want to configure, but not on its name.
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The layer's Layer Properties dialog appears. 

How to configure an effect

 1. In the toolbar under the Camera view, click on the Render View  button to make Harmony render 
the effects in the Camera view. 

TIP 

If your scene currently does not have a background, the negative space in your scene 
will render in black. To circumvent this, you can add a Colour-Card layer underneath all 
the other layers in your scene by clicking on the Add Layer  button in the toolbar 
over the layer list and selecting Colour-Card.

 2. In the Layer Properties view or the Layer Properties dialog, adjust the parameters of the effect until 
you have the expected results. 

The preview in the Camera view will update every time you make changes, but each change may 
take a short while before appearing in the Camera view, as the Render Preview mode requires more 
computing power to update. 
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NOTE 

For more information on how to configure certain effects, refer to Examples of Effect 
Usage on page 66. For detailed information on the properties of each available effect, 
see  refer to the Layers section of the Reference guide.

 3. Once you are done, you can dismiss the Layer Properties dialog if it was open, and you can set the 
preview mode of the Camera view back to OpenGL by clicking on the OpenGL View  button in 
the toolbar at the bottom of the Camera view. 
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Animating an Effect
You may need to animate some effects to obtain the expected results. For example, you may want the radius of 
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the 
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish. 

Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a 
parameter to different values at different points in the scene by adding keyframes to it, and setting each 
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of the 
previous keyframe to the value of the next keyframe. Drawing layers are animated by having their coordinates 
associated to functions. Likewise, effects can be animated by associating their parameters to functions. 

Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an effect's 
parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline view. 
You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which display 
all of a layer's parameters.

NOTE 

To learn how to preview animated effects, refer to About Effects Preview on page 52.

How to animate an effect parameter in the Timeline view

 1. In the Timeline view, locate the effect you want to animate, and click on the  Expand  button right 
of its name. 

The list of parameters that effect's paramaters that are available in the Timeline view appears.

 2. In the right area of the Timeline view, in the same row as the parameter you want to animate, select 
the frame where you want to create the first animation keyframe for the effect.
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 3. Create a keyframe by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 4. In the left area of the Timeline view, under the Parameters column, adjust the value of the parameter 
for this keyframe by doing one of the following:

 l Click and hold on the value of the parameter, then drag it towards the left to reduce its value, 
or towards the right to increase its value.

 l Click on the value of the parameter. A text field will appear. Type in the new value of the 
parameter, then press Enter.

 5. In the right area of the Timeline view, click on the frame where you want to create the second 
animation keyframe for the effect.
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 6. Create the second keyframe for your effect's animation by doing one of the following:

 l In the Timeline toolbar, click the  Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 7. In the Parameters column, adjust the value of the parameter at the current keyframe. 

 8. Repeat the steps to create as many animation keyframe for your effect as needed.

 9. To adjust the timing between the keyframes of your animation, select the first keyframe.

 10. In the Timeline toolbar, click on the  Set Ease for Multiple Parameters  button.

The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be focused 
on the first  keyframe  in your animation, which should have a  Bezier handle  right next to it, 
pointing to the right. 
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 11. Click on the  Bezier handle  and drag it towards the right, at any angle, to adjust the ease-in of the 
animation.

 12. Click on Apply/Next.

The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last 
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are 
more animation keyframes after this one, it will have two Bezier handles, one pointing in each 
direction.

 13. Click on the left  Bezier handle  and drag it towards the left, at any angle, to adjust the ease-out of 
the animation between the previous keyframe and the current keyframe. 
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 14. If there is a  Bezier handle pointing towards the right, click on it and drag it towards the right, at 
any angle, to adjust the ease-in of the animation between the current keyframe and the next 
keyframe.

 15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire 
scene. 

How to animate an effect in the Layer Properties dialog

 1. Open the effect's Layer Properties by doing one of the following:

 l Add the Layer Properties view to your workspace, then select the effect in the Timeline view.

 l In the Timeline view, double-click on the effect layer, but not on its name.

 2. In the effect's layer properties, locate the parameter that you want to animate and click on the  
Function  button to its right.
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The parameter's input field will be greyed out. This is because you cannot directly edit a parameter 
once it is attached to a function. The field will indicate the name of the function that was created for 
it, in this format:

Name of layer: Name of function: Value at current frame

 3. Click on the parameter's Function button again.

The Bezier Editor dialog opens. 

This dialog will allow you to animate the function. The function graph at the bottom is made to 
represent the values of the function throughout each frame in the scene. 

 4. In the function graph, click and drag on the red cursor  to move it to the frame where you want to 
create your first animation keyframe.
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 5. Click on the  Add Keyframe  button to create the first animation keyframe for the effect.

A keyframe  is created and should be visible in the function graph. If you do not see it, that is 
because the function graph is not positioned to include the keyframe within its frame. To move the 
function graph to view the function's keyframe, click on the  Reset View  or  Reset View 
Vertically  button. 

 6. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 
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TIP 

If you want to set the keyframe to a value that is outside of the function graph's 
frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom 
back in.

 7. Click and drag on the red cursor to move it to the frame where you want to create your second 
animation keyframe. 

 8. Click on the Add Keyframe  button to create the second animation keyframe for the effect.
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 9. Adjust the value of the parameter at the current frame by doing one of the following:

 l In the Value field over the function graph, type in the desired value for the parameter.

 l In the function graph, click and drag on the  keyframe , and move it up to increase its value, 
or down to decrease it. 

 10. If you want to adjust the timing of the animation between the first and second keyframes, do the 
following:

 l Click and drag the  Bezier handle  of the first keyframe  towards the right, in any direction, 
to affect the ease-in of the animation.
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 l Click and drag the  Bezier handle  of the second keyframe  towards the left, in any direction, 
to affect the ease-out of the animation.

 11. Repeat these steps until you created and timed every animation keyframe required to animate your 
effect.
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About Effects Preview
T-HFND-010-010

Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL 
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter, 
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered 
automatically, deselect the Auto-Render option and do the preview update manually.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see 
your animation with the final effects.  Effects must be calculated before they can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the 
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a 
check preview.
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Previewing Effects in Render Mode
T-HFND-010-011

You can preview a single final frames with all effects calculated in the Camera view when you enable the 
Render mode. You cannot playback your animation in Render mode. You can also disable the auto-render 
option when adjusting several effect parameters to avoid slowing down your computer.

How to preview effects in Render mode

 1. In the Camera view status bar, click the Render View  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render. 
Depending on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

 1. In the Camera view status bar, click the Auto-Render  button. In the top menu, you can enable 
and disable Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the 
Auto-Render  button.

How to manually update the rendering preview

 1. In the Camera view status bar, click the Render  button.
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Playing Back Effects
T-HFND-010-012

To playback your effects, you need to do a temporary render.

How to play back effects

 1. In the Playback toolbar, click the Render and Play  button.

The Play node opens and loads the frames.

 2. Once the frames are loaded, click the Play  button in the Play window.

 3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE 

While previewing effects, you can press the Spacebar to stop and start playback.
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Changing the Preview Resolution
The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or one-
quarter of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command

 1. From the top menu, select View > Preview Resolution and one of the following: 

‣ Same as Scene Resolution

‣ 3/4 of Scene Resolution

‣ 1/2 of Scene Resolution

‣ 1/3 of Scene Resolution

‣ 1/4 of Scene Resolution

‣ Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.

 2. In the dialog box, select a resolution from the presets or type a new X-Y value.

 3. Click OK.

 4. Preview your effects animation.
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About Masking and Cutting Parts of Elements in your Scenes
An important part of staging and rigging is cutting. Cutting is the process of making parts of a drawing that 
intersect with another drawing invisible. It allows you, for example, to mask parts of a character that should 
appear behind a background element that is drawn on the same layer as other background elements, to mask 
two parts of a rig that should not overlap, or to confine an effect within the outlines of an element in your scene. 

There are two methods to cutting in Harmony:

 l Using the matte port of a drawing layer. With this port, you can connect any drawing layer to another 
drawing layer or group, and use the latter as the drawing layer's matte. Any part of the drawing that 
intersects with the artwork in its matte will be hidden. 

 l Using a Cutter effect. A cutter effect can be connected to a drawing, effect or group, and then can use 
any other drawing layer or group as its matte. Any part of what is connected to the Cutter effect which 
intersects with the artwork in its matte will be hidden. 

Hence, if you only want to hide parts of a single drawing layer, you can use the drawing's matte port. If you 
want to hide parts of a group or an effect, you will have to use a cutter effect

NOTE 

In either case, the effects of cutting can be inverted. When inverted, only the parts of the artwork 
that intersect with the matte are visible, and everything else is hidden.
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Using the Matte Port of a Drawing Layer
Each drawing in a Harmony scene has their own Matte port. Connecting a drawing or group to a drawing's 
matte port will make the parts of the drawing that intersect with the matte image invisible. 

Optionally, you can invert a drawing layer's matte. This will make parts of the drawing that intersect with the 
matte image visible, and everything else hidden. 

How to connect a matte drawing layer to a drawing layer

 1. In the toolbar above the layer list in Timeline view, click on the Add Layer  button and select 
Drawing.

 2. Give your new drawing layer a relevant name for a matte layer, such as "Matte-Drawing", then click 
on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
a semi-transparent area of the matte will appear semi-transparent. For example, if a 
matte is filled with a colour that has an alpha value of 64 (25% opaque), instead of 
making the parts of the drawing it covers completely invisible, it will subtract the 
matte's opacity from the opacity of those parts of the drawing, making them 75% 
opaque. 
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 4. In the Timeline view, click on the Expand  button right of the drawing layer.

The drawing layer's parameters appear below it. The first parameter is the Matte parameter, which 
allows you to use another layer in your scene as the drawing layer's matte.

 5. Drag and drop your matte layer next to your drawing layer's Matte field, under the Parameters 
column.

The matte drawing layer becomes the drawing layer's matte.  At this point, areas of the drawing 
that intersect with the artwork in the matte drawing layer are hidden. 

 6. If you want to invert the matte effect for the drawing layer, so that the artwork that intersects with 
the artwork in the matte layer is visible and that everything else is hidden, do the following:

 a. Double-click on the drawing layer (but not on its name) to open its Layer Properties dialog

 b. In the Layer Properties dialog, select the Drawing tab.

 c. Check the Invert Matte check box.
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Using the Cutter Node
T-HFND-010-009A

You can use the Cutter node to hide parts of a drawing, a group or an effect. The Cutter node must be 
connected to a drawing that will serve as a matte. Parts of the drawing, group or effect that intersect with the 
matte drawing will be hidden. 

Optionally, you can also invert the Cutter node's matte, which will make parts of the drawing, group or effect 
that intersect with the matte drawing visible, and everything else will be hidden.

How to use the Cutter effect

 1. Select a drawing layer.

 2. Do one of the following:

 l In the toolbar above the layer list in the Timeline view, click on the  Add Layer  button and 
select Effects > Cutter.

 l Right-click on the layer and select Insert > Effects > Cutter.

The Cutter effect is created as a child of the selected layer. 

 1. In the toolbar above the layer list in Timeline view, click on  Add Drawing Layer .

 2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer, 
such as "Matte-Drawing", then click on Add and Close.

 3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but 
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.
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NOTE 

Mattes can also have semi-transparent areas. Areas of the drawing that are covered by 
semi-transparent areas of the matte are partially affected by the effect.

 4. In the Timeline view, click on the Expand  button right of the Cutter layer.

The Cutter's Matte parameter appears below it.

 5. Drag and drop your matte layer next to your Cutter layer's Matte field, under the Parameters 
column.

The matte drawing layer becomes the Cutter layer's matte. At this point, areas of the artwork that 
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intersect with the artwork in the matte drawing layer are hidden. 

 6. If you want to invert the Cutter's effect, so that the artwork that intersects with the artwork in the 
matte layer is visible and that everything else is hidden, double-click on the Cutter layer (but not on 
its name) to open its Layer Properties dialog, then check the Inverted parameter.
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About Opacity and Transparency
Harmony has two ways of adding transparency to your scene:

 l The Opacity parameter is a parameter each drawing layer. It is set to 100% by default. By lowering it, 
you can make an individual layer appear more transparent.

 l The Transparency effect is an effect layer that can be attached to individual layers or to a group. It has a 
Transparency parameter that is set to 50 by default. The higher it is, the more transparent the layer or 
group it is attached to will appear.

It is important to know when to use either approach. For example, to make a character composed of several 
layers transparent, it is preferable to put the character's layers in a group and add a Transparency effect to the 
group, as reducing the opacity of individual layers will make their overlapping parts visible—see About Groups 
on page 113.

If you need to animate the transparency of elements in your scene, it is possible to animate the opacity of 
individual layers by creating a function for the layer's opacity parameter, which you can do from the Advanced 
tab of the Layer Properties view. However, this may be impractical as a layer's opacity parameter cannot be 
animated in the Timeline view. You can only animate it by opening the Function Editor from the Layer 
Properties—see Creating Functions on page 573.

A layer's opacity parameter is static. If you need to animate the transparency of elements in your scene, you 
must use a Transparency effect, as the value of its transparency parameter can be animated. To learn how to 
add and animate an effect, see Adding Effects Layers on page 34 and Animating an Effect on page 42.
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Setting the Layer Opacity
If you need specific layers to appear semi-transparent, you can quickly set a drawing layer's opacity parameter 
directly in the Timeline view.

A drawing layer's opacity parameter will appear in the Timeline view when this drawing layer has thumbnails 
display enabled:

How to set a drawing layer's opacity

 1. In the Timeline view, do one of the following:

 l Left of the layer's name in the Layers list, click on the Show Thumbnails  icon.

 l Select the drawing layer and press T.

 l Left of the Layers list header, click on the Show All Thumbnails  icon.

The Opacity parameter is displayed left of the drawing layer's thumbnail.

 2. Do one of the following:

 l Double-click on the value of the Opacity parameter and type in its new value.

 l Click and drag the value of the Opacity parameter to the left to reduce it, or to the right to 
increase it.
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Examples of Effect Usage
The following section gives examples of how to use a few commonly used effects in Harmony.
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Creating a Drop Shadow
The Shadow effect converts the drawing layer it is connected to into a dark, blurry matte. You can control the 
type and amount of blur, as well as the colour of the shadow.

On its own, simply connecting a drawing or group to this effect will only convert your drawing to a shadow, 
which might not be useful. However, it is possible to make both the original character and its shadow version 
appear in your scene, and have the shadow version transformed and distorted to appear as a drop shadow. 
You can accomplish this by doing one of the following:

 l Cloning the layers or group. You can then add the effect to the clone, and add a peg on top of the clone 
to transform it.

 l Adding the layers or group to a symbol, then putting two instances of that symbol in your scene. You can 
then add the effect to one of the instances, and add a peg on top to transform it.

TIP 

When creating a drop shadow against a floor, you can obtain a more realistic effect by using a 
Quadmap to transform the shadow instead of a Peg. A Quadmap is similar to a peg, except that it 
allows you to  apply perspective effect to the drawings underneath it. 

How to create a drop shadow for an animated character

 1. In the Timeline view, select all the layers making your character's rig. If your character is under a 
master peg, selecting the master peg will also work. 

 2. Make sure your character's rig is in a group. If it is not, right-click on your selection, then select Group 
Selection.
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 3. With your character selected in the Timeline view, create a Clone of your character by doing one of 
the following:

 l Right click on your selection, then select Clone Selected Layers: Drawings and Timing.

 l From the Top menu, select Edit > Clone: Drawings and Timing.

NOTE 

Contrary to a duplicate, a cloned layer always has the same timing and exposure as its 
origin layer, even if its origin layer is changed later. Hence, you can make changes to 
your character's animation, and your cloned character's animation will automatically 
update with these changes.

 4. Add a Shadow effect to your group by doing one of the following.

 l In the Timeline view's layers toolbar, click on Add Layers  and select Effects > 
Shadow.

 l Right-click on your selection, then select Insert > Effects > Shadow.

 5. In the Timeline view, select the root layer of your character's clone.

 6. Create a parent peg for your clone by doing one of the following:

 l From the Timeline View layers toolbar, click the Add Peg  button.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (macOS).

 7. In the Timeline view, select your clone's parent peg.

 8. In the Tools toolbar, select the Transform  tool. 
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 9. In the Camera view, scale and skew your clone so that it looks like a drop-shadow. 
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Chapter 17: Sound
With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing 
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to 
trim unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to 
continue throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would 
best apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for 
your character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your 
animation based on the mouth chart.
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About the Sound  Editor
When you double-click on a sound layer in the Timeline view, the Sound Element Editor appears.

 l Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

 l Layer Name: This field displays the layer's name.

 l Sound Editor: This button opens the Sound editor.

 l Start Frame/End Frame: These fields determine the start and end frame of the sound file.

 l Detect: This button launches the automated lip-sync detection.

 l Map: This button opens the Map Lip-sync dialog box.

 l Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the 
thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Layer
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer 
Properties view.

If you double-click on a sound layer in the Timeline view, or in a sound column in the Xsheet view, the Sound 
Element Editor dialog will open. This dialog allows you to fine-tune the sound track's lip sync, start time, stop 
time and volume.
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Importing Sound
T-HFND-007-009

If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound 
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and 
quality should you use third party software for post-production. Another good practice is to keep your 
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation 
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly in 
Harmony when needed.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files.

NOTE 

Importing a soundtrack longer than your scene will not extend your scene's length. Sound playback 
will stop at the end of your scene's length.

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > 
Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help 
you visualize at which frames the sound effects in your soundtrack occur. 

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by 
default. If you wish, you can display a sound column's waveform by right-clicking on it, then 
selecting Sound Display > Waveform.
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Playing Sound
T-HFND-007-010

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it through 
the Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the 
ones included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the 
unwanted sound by clicking the Disable Layer  button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you 
can do one of the following to troubleshoot the issue:

 l Shrink down the Camera view size to reduce the cached image size.

 l Playback your scene without sound first, then add the sound. If you do not cache the images first without 
sound, the playback will try to follow the sound by skipping images that will never get cached.

How to play back sound

 1. To select a starting point:

 l In the Timeline view, click on a cell in the sound layer. You can also slide the red 
playhead to the correct cell.

 2. In the Playback toolbar, activate the Enable Sound  button.

 3. Do one of the following:

 l Click the Play  button in the Playback toolbar.

 l From the top menu, select Play > Play or click on the Enter/Return key.

 4. To hear the sound played back again and again, do one of the following:

 l Click the Loop  button in the Playback toolbar 

 l From the top menu, select Play > Loop.

 5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer  button.
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Changing the Sound Display
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing 
needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the Timeline 
View toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by 
default.

How to change the sound display in the Timeline view

 1. In the Timeline view's right area, right-click in the frame section and select Show Sound 
Waveforms.

 l You can change the waveform scale using the Zoom Waveform  icon on individual sound layers in 
the Timeline view's left side.

How to change the sound display in the Xsheet view

 1. Right-click in the sound column or on the sound column header, and select Sound Display and one 
of the following:

 l Sound Name: Shows the name of the sound file, as well as the file format. The line 
running vertically through the column frames between the same file name indicates a 
continuity of the same sound file in these frames.

 l Mouth Shapes: Shows the letter (or name depending on the way you named your 
character's different mouth positions) in the column's frames. There is only one mouth 
position allotted per frame and this position should correspond to the sound file after 
performing a lip-sync.

 l Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or 
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zoom out on the waveform, or pass the scroll cursor  over the Zoom Waveform  
icon.
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the 
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds 
from the Timeline view. 

How to scrub a sound from the Timeline view

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

 3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent 
sound frames. This allows you to do a more fluid scrubbing.
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Editing Sound
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the 
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of 
Harmony and imported into your scene.

How to open the Sound Element editor

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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 l Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard 
when the final movie is rendered. It may be shorter than the original sound sample due to the 
length of the scene. If any edits are made to the sound sample, they can be heard here. In the Sound 
Element panel, notice the coloured tabs that indicate the start and end frames of a sound segment. 
The frame number is displayed in the tab.

 l Current Sound: Displays the original sound file in its entirety and is where you can edit its 
properties. This window remains empty until you click inside the Sound Element Editor.

 l Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth 
positions to correspond with the sound sample. 
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Cropping Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make 
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame 
number is shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.

How to change start or end frame of a sound

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section.

Click the Play  button in the Current Sound section (only the selected sound plays).

 3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to 
start playing. 
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two 
clips in the same element.

 4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

 5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element 
section.

If you only want to hear the selected clip, click the Play  button  in the Current Sound section.
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 6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.

83

Harmony 17 Essentials User Guide                          



Chapter 17: Sound

Trimming Sound
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For 
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. 
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to 
edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish 
one sound section from another on the same sound layer, check the frame numbers that appear on 
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click the 
Play  button in the Current Sound panel (only the selected sound plays).

 3. Using the Current Sound section, decide on the part of the file you want to play by dragging the left 
and right boundaries of the selection area.

 4. Click the Play  button in the Current Sound section to check that you have trimmed the desired 
sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim 
it more accurately.

 5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end 
positions you selected.
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Looping Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. From the Sound Element section, select the sound section you want to loop.

 3. In the Current Sound section, type the number of times you want the sound to play in the Number of 
Loops field.

 4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until 
the next sound sample starts or until the scene ends. This means that the looping could be cut if the 
next sound sample starts too soon or if the scene ends too quickly.
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in 
and fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original 
sound file is not affected.

How to adjust the overall volume of the entire sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element section, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound section.

 3. In the Current Sound section, use the Volume slider to adjust the volume.

 4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the 
Xsheet view.

 2. In the Sound Element section, select the sound you want to work on.

 3. In the Current Sound section, click on the thin blue line above the waveform to add an envelope 
marker.
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 4. Drag the envelope markers to adjust the volume at that frame and to create the time of the 
transition. The line from the edge of the clip to the envelope marker identifies how the volume 
increases (fades-in) or decreases (fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards 
increases the volume. 

NOTE 

To create an even effect, be sure to adjust the envelope markers uniformly in both the left and 
right (bottom and top) channels.

 5. Click the Play  button in the Current Sound panel to check the fade envelopes.
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Setting the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start 
or stop at specific frames. This customized playback range does not affect the actual sound in the Sound 
element. 

How to change the playback range in the Sound Element editor 

 1. Drag the start or end range markers in the Sound Element section to the boundary frames you 
want.

 2. When you click the Play  button to play back your sound in the Sound Element editor, it only 
plays the sound which exists between the two markers.
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Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For 
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist 
on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-quarter view 
and have mouth position changes to fit with the sound sample from these two different views, you would need 
to cut up the sound samples needed for the profile view mouth positions on one layer and the sound samples 
needed for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

 1. In the Timeline Layer toolbar, click the Add Layer button.

 2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

 3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound 
Element editor. Click Apply/Next to accept the change.

1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut 
and Shift + click on the final cell of the cut. The sample to be cut becomes highlighted.
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2. Drag the selection into the empty sound layer below.

 4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on 
to the lip-synching process for each layer and its corresponding facial view.

NOTE 

If you need to duplicate your sound layer to keep an unedited copy for safety, select the 
Duplicate Selected Layers button in the Timeline View toolbar. You must customize the toolbar 
to display this button because it is not included in this toolbar by default.
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About Lip-sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE 

The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to 
the sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound
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When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated 
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, 
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and 
these drawings should be named by their corresponding letter. 
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, 
Xsheet view and Sound Element editor.

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell. 

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 
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NOTE 

If the selected layer contains symbols, you can map the lip-sync using drawings located 
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't 
Use Any Symbol if you want to use the drawings or select the desired symbol from the 
drop-down menu.

 5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip 
this step.

 6. Click OK.

 7. In the Playback toolbar, enable the  Enable Sound  option.

 8. Press the  Play  button in the Playback toolbar to see and hear the results in the Camera view

How to generate a  sound detection for lip-sync in the Xsheet or Timeline view

 1. Do one of the following: 

 l In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-
Sync > Auto Lip-Sync Detection. 

 l From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. 

How to generate a sound detection for lip-sync using the Sound Element editor

 1. Do one of the following:

 l In the Timeline view, double-click on the sound layer.

 l In  the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.
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 2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

 3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync 
letter to each sound cell.
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Mapping the Lip-Sync Detection
Harmony can automatically map Automatically maps drawings in an element to the mouth chart you have 
generated for a sound. This can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically 
labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

 1. To open the Lip-Sync Mapping dialog box, do one of the following:

‣ In the Layer Properties view, click on the Map button.

‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map 
Lip-Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

 2. From the Destination Layer menu, select the layer that contains the mouth positions for the 
character's voice track. 

 3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on 
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you 
want to use the drawings or select the desired symbol from the drop-down menu.
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 4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the 
phoneme it represents. If your drawings are already named with the phoneme letters, you do not 
have to do anything.
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Modifying the Lip-sync Detection
You can change the mouth position assigned to a frame if you think another position is more appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony 
would normally assign an X image for the silent period. However, if you want your character's mouth to hang 
open in astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an 
F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the Lip-
Sync Detection on page 96.

How to change the mouth position assignment of a sound from the Sound Element 
editor and Layer Properties view

 1. Double-click the sound layer name in the Timeline view to open the Sound Element editor.

 2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth 
position assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current 
frame. 

 3. To change the image assigned to the frame, click on the image of the mouth position you want from 
below the preview image. The preview image changes to the mouth position image you select. You 
can perform the same operation in the Layer Properties view.

The position is updated in the Timeline view.
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NOTE 

Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.
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Manual Lip-syncing
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, 
allowing you to identify which phonemes you should match your character's mouth to. You will also be using 
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the  Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the 
drawing name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current 
drawing automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the  Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with 
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. 
The current drawing is swapped for the one in the preview window.
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Chapter 18: Rendering & Exporting 
Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to 
further edit your movie using a third party software, composite the movie in a larger body of work or put it up 
directly on the web, Harmony supports several formats for all your rendering needs.

NOTE 

The different editions of Harmony support the following maximum render resolutions:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited
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Exporting Image Sequences
In Harmony, you can export you scene as a sequence of image files, which can be played in Play or imported in a 
video editing software for post-production.

You can export an image sequence in a handful of different image types. If you want to export images with 
transparency, you can do so by selecting an image type that supports it, such as TGA, PNG or PSD, then 
setting the Colour Mode to Colour with Transparency. You can also export images with deep colour (16 
bits/channel) by selecting a file type that supports it, such as PNG or PSD, and setting the Colour Depth to 16 
bits/channel.

How to render an image sequence

 1. From the top menu, select File > Export > Images or press Ctrl + Shift + Y (Windows/Linux) or ⌘  + 
Shift + Y (macOS).
The Export Images dialog box opens.

 2. In the Prefix field, enter a prefix for the file names of the exported images. The images will be named 
with the prefix, followed by their frame number. T

 3. Click Browse and select the directory in which to export your images, or click on Default to set the 
export destination to your scene's frames subfolder.

 4. In the Format section, choose the desired image format in the File Type drop down list. Colour Mode 
and Colour Depth from their respective menus.

 5. In the Colour Mode drop down list, select whether you want the exported images to be in 
Greyscale, Colour or Colour with Transparency. 

 6. In the Colour Depth drop down list, select whether you want the exported images to be in 8 
bits/channel or 16 bits/channel. 8 bits per channel is the most standard colour depth, but 16 bits 
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per channel allows for more colour precision.

NOTE 

Most image formats will export in Colour at 8 bits/channel. Only a few image formats, 
such as PNG , TGA and PSD, can be exported in different colour modes and colour 
depths. 

 1. In the Range section, select the frame range to render by doing one of the following:

 l If you want to render all the frames in your scene, select All Frames.

 l If you want to render a specific sequence of frames, select Selected Frames then, in 
the fields to the right, enter the number of the first and last frame of the frame 
sequence you wish to render.

 7. Enable the Preview option to automatically preview the exported image sequence in Play once the 
render is done. 

 8. Click OK.

Harmony begins rendering the scene's frames.

If you enabled the Preview option, the exported images will load in Play once the render is done. 
You can user Play to play the image sequence with the scene's soundtrack. 
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Exporting a Movie File
T-HFND-010-013

Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export 
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your 
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space. 
Depending on the format in which you export your movie, you can also customize the video and audio 
compression settings for quality or for disk space. 

How to export a movie file

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. In the Output section, open the Video Format drop-down and select the desired format for your 
movie file:

 l QuickTime Movie (*.mov): The Apple QuickTime format. This is the default export 
format and is recommended for its portability, and also because it allows you to choose 
among several video codecs.
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NOTES 

 l On Windows, Apple QuickTime must be installed to allow Harmony to 
export QuickTime movies. You can configure the export of QuickTime 
movies to use any codec that is compatible with QuickTime, including 
H.264, MPEG-4 and Animation.

 l On macOS, Harmony uses Apple AVFoundation to export QuickTime 
movies, which allows you to export using codecs such as H.264, Apple 
ProRes 422 and Apple ProRes 4444.

 l H.264/MPEG-4                      (*.mov)                    : A simple movie format that uses the H.264 codec, which is 
supported by most web browsers.

NOTES 

 l Using this format does not require additional software. However, if this 
is the first time you export a movie in H.264/MPEG-4 format, you will 
be prompted to download the OpenH264 library from Cisco. Simply 
click Yes when prompted, and Harmony will automatically download 
the library, then export the movie. 

 l There are no encoding options for this format. 

 l This format supports resolutions of up to 4096×2304. Each dimension 
must be a multiple of 16 pixels. 

 l Audio exported in this format is encoded in PCM 16-bit stereo, 22.05 
kHz.

 l Windows Media Video (*.wmv): The native format for Windows Media Player.

NOTES 

 l Windows Media Video (.wmv) files can only be exported on Windows. 

 l Video players and editors on non-Windows systems can generally not 
open Windows Media Video (.wmv) files.

 3. Click on the Browse button.

 4. In the Save dialog that appears, browse to the location where you want to export the movie file. 

 5. In the File name field, type in the file name you want the movie file to have.

 6. Click on Save.
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 7. From the Export Range section, do one of the following:

 l Select All if you want to render the entire scene.

 l Select Frames if you want to render a part of your scene. Then, in the field to the right, type 
in the first frame of the sequence you want to export, and in the other field, the last frame of 
the sequence you want to render.

 8. Open the Resolution drop-down and do one of the following:

 l Select Same as Scene Resolution if you want to export a movie with the same resolution as 
your scene.

 l Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of 
Scene Resolution if you want to export a movie that is smaller than the resolution of your 
scene.

 l Select Custom if you want to manually set the export resolution. Then, in the Width and 
Height fields, type in the desired resolution for your movie, in pixels.

 9. In the Options section, click on Movie Options if you want to configure the video and audio 
compression settings for the movie to export.
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NOTES 

 l For information on how to configure movie settings for a QuickTime Movie 
(.mov), see:

 l Windows: Configuring Movie Settings for QuickTime Movies on Windows 
on page 109

 l macOS: Configuring Movie Settings for QuickTime Movies on macOS on 
page 113

 l For information on how to configure the movie settings when exporting in 
Windows Media Video (.wmv) format, see  Configuring Movie Settings for 
Windows Media Video.

 l When exporting in H.264/MPEG-4 (.mp4) format, there are no video and 
audio compression settings.

 l If you are using GNU/Linux and are exporting in QuickTime Movie (.mov) 
format, there will be a button for the Video Options and one for the Sound 
Options.

 10. Click OK.

 11. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 12. Browse to the location on your computer where you exported your movie file, and double-click on it 
to view it in your video player.
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Configuring Movie Settings for QuickTime Movies on Windows
On Windows, it is possible to export QuickTime Movie (.mov) files using the libraries provided with Apple 
QuickTime.

Harmony allows you to customize the video and audio compression settings for your QuickTime movies via 
QuickTime's own configuration interface. This makes it possible to export movies using any codec that is 
compatible with the QuickTime framework.

NOTE 

To export QuickTime Movies on Windows, Apple QuickTime must be installed on your machine. 

How to configure video and sound settings for QuickTime movies on Windows

 1. Proceed to the Movie Settings dialog—see Exporting a Movie File.

 2. In the Movie Settings dialog:

 l Make sure the Video checkbox is checked.

 l If you want your movie file to have an audio stream, make sure Sound is checked.

 3. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 4. In the Compression Type drop-down, select a video compression codec. It is recommended to use 
one of the following codecs, depending on your usage scenario:

 l H.264: A very effective lossy compression algorithm that is commonly supported by web 
browsers and most media players.

 l MPEG-4 Video: A very effective lossy compression algorithm that is commonly supported by 
media players, but less so by web browsers.

 l Animation: A high quality compression algorithm that is commonly used for media 
interchange and video editing. 

TIPS 

 l You can export a video with transparency by selecting the Animation codec and 
setting the Depth setting to Millions of Colors+.

 l You can export a video with virtually lossless compression by selecting the 
Animation codec and setting Quality setting to Best.

NOTE 

The availability of certain of the compression settings described below will depend on 
the selected compression type.
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 5. In the Motion section, make sure the Frame Rate drop-down is set to Current. This will ensure that 
the video's frame rate matches the frame rate of your Harmony project. 

 6. If you set the Compression Type to H.264, make sure the Key Frames option is set to All.

 7. In the Quality section, if you set the Compression Type to Animation, select the desired colour 
depth for your video in the Depth drop-down. 

 8. In the Quality section, use the slider to choose a quality setting. 

NOTE 

The selected quality setting will impact the movie's file size.

 9. If you set the Compression Type to H.264, in the Quality section, select the encoding method:

 l Best quality (Multi-pass): This will extend the time required for the export, but optimize the 
quality of the video.

 l Faster encoding (Single-pass): This will shorten the time required for the export, but may 
sacrifice some video quality.

 10. In the Data Rate section, select Automatic to let QuickTime determine the best bit rate for your 
movie, or Restrict to to set a maximum bit rate for your movie and limit its file size. 

 11. If you set the Data Rate to Restrict to, enter the maximum bit rate, in kilobits per second, in the text 
field to the right. 

 12. If you set the Data Rate to Restrict to, in the Optimized For drop-down, select the intended 
distribution method for your movie. 

 13. Click OK.

 14. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.
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 15. From the Compressor menu, select the algorithm to use to compress the movie's audio track.

NOTE 

It is recommended to leave this setting to None, as other formats are likely to sacrifice 
audio quality for negligible savings in disk space.

 16. In the Rate field, select the desired sample rate for the movie's audio track

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you select a 
higher sample rate, your project's audio will be upsampled, which means it will take 
more disc space without increasing in quality. 

 17. Right of Size, select the desired  bit depth for the audio track. This determines the amount of 
precision used to record each wavelength in the audio track. 

NOTE 

The standard bit depth is 16-bit. If you choose 8-bit, the amount of disk space the audio 
track of your movie file requires will be halved, but the audio quality will be significantly 
lower.

 18. Right of Use, select whether you want to export audio in the Mono or Stereo channel mode. 

NOTE 

Stereo sound has a separate track for the left and right speakers, whereas mono sound 
only has a single audio track for all speakers. 

 19. Click OK.

 20. In the Movie Settings dialog, click OK.
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Configuring Movie Settings for QuickTime Movies on macOS
On macOS, Harmony allows you to export QuickTime Movie files (.mov) using the Apple AVFoundation 
framework, which is pre-installed with macOS.

Contrary to Windows, Harmony uses its own user interface to let you configure the compression settings for 
QuickTime Movies on macOS. Using this interface, you can choose to export your movie using either the H.264, 
the Apple ProRes 422 or the Apple ProRes 4444 video codec. You can also configure the quality of the audio 
track, but the audio will always be exported in uncompressed PCM format. 

How to configure the video and sound settings for QuickTime movies on macOS

 1. Proceed to the Movie Options dialog—see Exporting a Movie File.

 2. In the Movie Options dialog box, click on the Codec drop-down and select one of the following video 
compression codecs:

 l H.264: A very effective lossy compression algorithm that is commonly supported by web 
browsers and media players. 

 l Apple ProRes 422: A nearly lossless compression algorithm commonly used for video editing 
on Apple systems. This codec is optimized for preserving video quality, but not for publishing 
or streaming.

 l Apple ProRes 4444: A nearly lossless compression algorithm commonly used for video 
editing on Apple systems. Compared to Apple ProRes 422, this codec preserves more colour 
detail and supports transparency. However, it results in heavier file sizes.

 3. If you want to export a video with transparency, check the Alpha option.
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NOTE 

This option is only available when exporting with the Apple ProRes 4444 codec. Other 
codecs do not support transparency.

 4. If you want your movie file to have an audio track, make sure the Sound checkbox is checked.

 5. In the Rate drop-down, select the desired sample rate for the movie's audio track. The higher the 
sample rate, the better the quality.

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you select a 
higher sample rate, your project's audio will be upsampled, which means it will take 
more disc space without increasing in quality. 

 6. Right of Use, select whether you want to export audio using the Mono or Stereo channel mode.

NOTE 

Stereo sound has a separate track for the left and right speakers, whereas mono sound 
only has a single audio track for all speakers. 

 7. Click OK.
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Configuring Movie Settings for Windows Media Video
On Windows, it is possible to export in Windows Media Video format. This format is natively supported by 
Windows, and is offered in Harmony as an alternative for exporting in QuickTime Movie format, as the latter 
requires installing QuickTime on Windows.

When exporting in Windows Media Video format, Harmony allows you to select the video compression quality 
as well as one of the preset sound compression profiles.

How to configure video and sound settings for Windows Media Video

 1. Proceed to the WMV Options dialog—see Exporting a Movie File.

 1. In the Video section, select the desired Variable Bit Rate Quality for your video. A higher setting will 
ensure a better image quality, whereas a lower setting will reduce the size of your movie file.

 2. If you want your movie file to have an audio track, make sure the Sound checkbox is checked.

 3. Using the Profile drop-down menu, select the preferred compression settings for your movie's 
soundtrack. Each profile has a combination of audio sample rate, sample size and channel mode, 
which cover the following options:

 l Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz and 44100 Hz. The 
higher the sample rate, the better the audio quality. 

NOTE 

Harmony cannot export audio at a higher sample rate than 22.050 kHz. If you 
select a higher sample rate, your project's audio will be upsampled, which means 
it will take more disc space without increasing in quality. 

 l Sample size: Also known as bit depth, this determines the amount of precision used to record 
each wavelength in the audio track. The standard size is 16-bit. If you choose 8-bit, the 
amount of disk space the audio track of your movie file requires is halved, but the audio quality 
will be significantly lower.
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NOTE 

Exporting in 8-bit audio requires Apple QuickTime to be installed. 

 l Channel mode:  Available channel modes are Stereo and Mono. Stereo sound has a separate 
audio track for the left and the right speakers, whereas mono sound uses a single track for all 
speakers.

 4. Click OK.
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Exporting an Animated GIF
You can export your scene, or part of your scene, as an animated GIF image. 

Animated GIFs are a portable format commonly used for exchanging short animations and clips on the web. 
They can be played in any web browser and in many image viewers. 

Animated GIFs are a convenient sharing format, but they are not a publishing format. They are not as 
optimized for fast download and playback as movie files, cannot contain audio and, most importantly, can only 
contain up to 256 different colours throughout the entire animation. Hence, if your animation contains textures 
or gradients, it is likely to lose quality when exported as an animated GIF, as Harmony will have to limit the 
amount of different colours used in the exported image. 

NOTE 

For more information on the Export to Animated GIF dialog, see the Reference Guide.

How to export an animated GIF image

 1. In the top menu, select File > Export > Animated GIF.

The Export to Animated GIF dialog box appears.

 2. In the Output section, click on the Browse button.

 3. In the Save dialog that appears, browse to the location where you want to export the animated GIF. 

 4. In the File name field, type in the file name you want the animated GIF to have.

 5. Click on Save.
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 6. From the Export Range section, do one of the following:

 l Select All if you want to render the entire scene.

 l Select Frames if you want to render a part of your scene. Then, in the field to the right, type 
in the first frame of the sequence you want to export, and in the other field, the last frame of 
the sequence you want to render.

 7. Open the Resolution drop-down and do one of the following:

 l Select Same as Scene Resolution if you want to export an animated GIF with the same 
resolution as your scene.

 l Select 3/4 of Scene Resolution, 1/2 of Scene Resolution, 1/3 of Scene Resolution or 1/4 of 
Scene Resolution if you want to export an animated GIF that is smaller than the resolution of 
your scene.

 l Select Custom if you want to manually set the export resolution. Then, in the Width and 
Height fields, type in the desired resolution for your movie, in pixels.

 8. In the Dithering drop-down, select whether you would like to use dithering to blend pixels of 
different colours in gradients and, if so, which type to use:
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 l None: No dithering will be applied. Each pixel rendered is rendered with the colour in the 
palette that is the closest to its actual colour. 

 l Diffusion: Blends pixels in irregular patterns to blend pixels and simulate the colour as closely 
as possible. 

 l Pattern: Blends pixels in regular checkered patterns to simulate the colour without created 
clusters of pixels. 

 9. If you want the animated GIF to loop, check the Loop option. If you only want it to play once, 
uncheck it. 

 10. Click on OK.

A progress bar appears.

 11. Browse to the location on your computer where you exported your animated GIF, and double-click 
on it to view it in your image previewer. 
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Exporting Flash (SWF) Movies
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Batch Rendering
In Harmony Server, you can choose to render your scene locally or to send it to the render farm on your network 
so that other computers can render your scenes while you continue working on your station. This option is not 
available in Harmony Stand Alone, as render jobs are sent to a Harmony Server database, and machines that 
perform the render must be connected to this database.

There are two approaches to rendering a scene in Harmony Server:

 l Local Rendering is done directly by your machine in your Harmony session. Hence, it uses your 
machine's resources and will prevent you from working on the scene until the render is done. You will 
see the render progress in real time and will be able to preview the results right after it's finished. 

 l Batch Rendering is done by sending a scene to the server's render queue so it can be processed by the 
render farm. This allows you to keep working on your scene while the render is being done. The 
rendering progress can be monitored in Control Center and, when finished, the results can be 
previewed in  Play. Batch Rendering gives you access to additional rendering options. 

When sending a scene to batch rendering, it is not rendered immediately. Computers connected to the 
Harmony database that are configured to render scenes for the database check for new render jobs 
periodically, and start performing the render job when they find one that isn't already being rendered by 
another machine.

NOTE 

To configure a Harmony Server database and to set up clients to perform batch rendering jobs, 
refer to the Harmony Installation Guide.

How to send a scene to the batch rendering queue

 1. Save your scene.

 2. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y 
(Windows/Linux) or ⌘  + Shift + Y (macOS).

 1. In the Range section, select the frame range to render by doing one of the following:

 l If you want to render all the frames in your scene, select All Frames.

 l If you want to render a specific sequence of frames, select Selected Frames then, in 
the fields to the right, enter the number of the first and last frame of the frame 
sequence you wish to render.

 3. Enable Batch Composite Options. This will send your scene to your Harmony database's batch 
rendering farm, whereas disabling this option will make Harmony render your scene locally. 
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NOTE 

When Batch Composite Options is enabled, the Preview option is not available. This is 
because Harmony does not track the progress of a render when it is performed by the 
Harmony database's render farm. You can only enable the Preview option when 
rendering locally.

 4. If you want the machine that will render your scene to output detailed information about the process 
in its log, enable the Debug option.

 5. If you want to split the render job for your scene into several smaller render jobs, so that the load can 
be shared by different machines in the render farm, enable the Chunk option. Then, enter the 
amount of frames each chunk should render in the Size (Frames) field.

 6. If you want to render the scene from a specific camera, select the desired camera from the Camera 
drop down list. A scene can have several cameras added in the Timeline view, and each of them can 
be animated independently. 

 7. In the Resolution section, do one of the following to select the resolution in which to render the 
scene:

 l If you want to render the scene in its actual resolution, select By Name and, in the 
resolution preset drop down list, select Default.

 l If you want to render the scene in one of the available preset resolutions, select By 
Name and, in the resolution preset drop down list, select the desired resolution preset.

 l If you want to render the scene in a specific resolution, select By Value, then enter the 
Width and Height of the desired resolution, in pixels. 

 8. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render queue. 

If the selected frames were already sent to the Render queue, but were not yet rendered, dialog box 
opens to inform you that these frames were already in the queue, but that they have been updated 
with the selected options.

You can also send scenes to batch rendering and check the status of the rendering queue using the 
Control Center application.
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Chapter 19: Library & Templates
T-RIG-009-001

Using templates and symbols, you can share and reuse any elements you create in Harmony. The Harmony 
library lets you store several different elements such as puppets, backgrounds, animations and key poses. In 
fact, anything you create in Harmony can be stored in the library.

The Library view is where you can store and reuse your artwork and animation in other scenes or build props 
and puppets.

The library is a storage centre for all production assets; the elements stored in the library are called templates. 
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation 
processes. The library can contain any asset used in a Toon Boom Harmony Essentials production. 

Using the library is as simple as dragging the content into the library to store your artwork and then dragging 
it to the Timeline or Camera view when you want to reuse it.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 
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About Structure
As you will probably create a large number of symbols and templates, you will soon realize they need to be 
organized. You can create different libraries and subfolders to easily access your assets. For example, you can 
create a different library for each project and divide it into several categories, such as:

 l Characters

 l Props

 l Backgrounds
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Creating Libraries
T-LAY-005-001

There are two ways to create libraries. 

 l Directly through your operating system

 l Using Harmony's interface

Although you can only have one symbol library folder, you can organize it by creating subfolders.

How to create a library folder through your operating system

 1. On your computer, create a new folder with a relevant name in the location where you want the 
library to be stored.

How to create a library folder in Harmony

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library folder.

 3. Click the New Folder button.

A new folder appears.

 4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.
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Opening Libraries
T-LAY-005-002

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network 
as a library. Opening a library means linking the folder to your Library view. You only need to open the library 
once. The library folder is available every time you open the application until you decide to close the library and 
unlink it.

How to open a library

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library Folders section.
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Closing Libraries
You may not always require all the library folders in the Library List. If so, you can close the ones you do not 
need. Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it 
on your hard drive or network and open it in the Library view.

How to close a library

 1. On the right side of the Library view, select the library folder to close.

 2. In the Library View menu, select Folders > Close Library.

The library closes.
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Creating Folders
T-ANIMPA-003-009

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or 
in the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library 
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the 
right to modify it before being able to add a new folder to it.

How to create a folder

 1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

 2. In the Library View menu, select Edit > Right to Modify.

 3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the 
plus [+] sign to expand it.
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Deleting Folders
You can delete a folder from the library if its contents are no longer needed.

NOTE 

All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data 
cannot be retrieved.

How to delete a folder

 1. In the Library view's left side, select the folder to delete.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

 3. In the Library View menu, select Folders > Delete Folder or press Del.
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Renaming Folders
Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

 1. In the Library view's left side, select the folder to rename.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and 
select Right to Modify.

 3. In the Library View menu, select Folders > Rename Folder.

 4. Rename the selected folder.

 5. Press Enter/Return to validate the operation.
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Refreshing Libraries
If you update the content of your libraries through your operating system, you will need to refresh your library 
folders in the Library view.

How to refresh a library

 1. In the Library view's left side, select the folder to refresh.

 2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.
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Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) 
for you. You can generate template thumbnails yourself, if they do not display or if the process has been 
stopped.

How to generate thumbnails

 1. In the Library view's right side, select the template in which you want to generate thumbnails.

 2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.
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Deleting Thumbnails
You can also delete thumbnails if you want to send a template to another user or studio and keep your 
packages small.

How to delete thumbnails

 1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Searching in Libraries
When working on a movie or series, you will probably end up with many templates and symbols in your library. 
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

 1. From the left side of the Library view, select the library in which you want to search.

 2. In the Search field, type the name or partial name of the symbol or template you are looking for.

 3. Click the left  and right  arrows to see the previous and next results. The Search engine will 
look for results within the library master folder and its subfolders. It will not look in other libraries.
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About Templates
T-LAY-005-003

When you want to reuse artwork and animation from your project in other scenes, you must create a template. 
A template can be seen as a portable scene or package that you can drag inside your project. A template is an 
individual copy of the artwork stored in the library which you can reuse in different scenes. Once a template is 
stored in the library, you can access it from any project.
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Creating Templates
T-ANIMPA-003-010

You can create a template using the Timeline view.

NOTE 

If you are creating a template from a character rig master template, you should collapse everything 
inside a master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting 
its root layer. This can be useful for creating templates based on character rigs or scene 
backgrounds.

 2. In the Library view, select a folder to store the template. By default, you will have a library named 
Harmony Essentials Library , which is stored on your computer, in the Toon Boom Harmony 
Essentials Library subfolder of your Documents folder.

 3. If the library folder is  locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 

 5. In the Rename dialog box, give the new template a name.
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 6. Click OK.
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Deleting Templates
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary. 

How to delete a template

 1. In the Library view, select the folder containing the template to delete.

NOTE 

If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Delete or press Del.
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Editing Templates
You can open a template and edit it just like any other project. If you want modify your templates, you can edit 
them using the Edit Template command.

How to edit a template

 1. In the Library view, select the folder containing the template to edit.

NOTE 

If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

 3. Edit the template.

 4. From the top menu, select File > Save.

 5. In the top menu, select File > Quit (Windows) or Harmony Essentials > Quit (macOS).

140



Importing Templates
There are several ways you can import templates in your scene.

For greater control over how the action template behaves when brought into the Timeline view, you can use 
the Paste Special feature—see Using Paste Special on page 159.

NOTE 

Dragging a template into your scene copies the content in your Timeline and does not link it to the 
original. You can modify this individual copy at any time.

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If 
you drop a template in the layers list in the Timeline view, it will be inserted between the layers 
where you dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template 
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into 
your scene, this will replace the drawings and keyframes in your scene with the ones from the 
template. This is useful for importing pose or animation templates for characters that are already in 
your scene. 
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How to import a template with symbols

 1.  From the right side of the Library view, select the action template that contains symbols.

 2. Hold down Alt as you drag it from the Library view to the right side of the Timeline view and drop it 
next to a template with the exact same rig.

The Paste Special window opens.

 3. Select the Advanced tab.

 4. Select one of the following options from the Symbols menu:
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 l Copy symbols if they do not exist: This is the default setting for this operation and will 
prevent symbols in an action template from being copied.

 l Duplicate symbols: Makes copies of the symbols in your template.
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Opening Templates as Folders
Since a template is like a scene, you can open the template's folder and select elements inside it such as 
drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or a 
palette. In this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

How to open a template as a folder

 1. In the Library view, select the folder that contains the template to open. If the library folder is locked, 
right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Open As Folder.

 3. In the library list section, click on the template's folder to display its content.

 4. Drag the content to the Timeline or Colour view.
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About Symbols
A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain 
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in 
which you place a series of different drawings for each body part of your puppets or when you have a repeating 
cycle. However, symbols are not necessary for creating characters. 

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest 
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the 
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on 
the symbol's name to move up the chain.
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Creating Symbols
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can 
also create symbols out of each body part in your cut-out puppets.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library 
into your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the 
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.

How to create a symbol from the Timeline view

 1. In the Timeline view, select the layer or cells from which your want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens
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 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced 
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to 
use it.

147

Harmony 17 Essentials User Guide                          



Chapter 19: Library & Templates

Creating a Symbol from a Drawing
You can create a symbol from a drawing selection.

How to create a symbol from a drawing selection

 1. In the Tools toolbar, select the Select  or Cutter  tool.

 2. In the Camera view, select the drawing elements to create a symbol.

 3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the entire 
layer.

The Create Symbol from Drawing Selection dialog box opens.

 4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add your 
symbol on the layer's current cell. If there is already an exposure on that cell, the symbol will be 
added to a new layer.

 5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select 
the Cut Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut 
Artwork From Source Drawing option.
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 6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new 
layer.
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Creating Empty Symbols
You can create a symbol without any artwork in it.

How to create an empty symbol

 1. In the Library view, select the Symbol folder.

 2. Do one of the following:

 l In the Library view's right side, right-click and select New Symbol. 

 l From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top  
button in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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Deleting Symbols
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve 
the data. The symbol cannot be retrieved once you close the application.

How to delete a symbol

 1. In the Library view, select the symbol to delete.

 2. Right-click and select Delete or press Del.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the 
symbol from the library and scene.
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Editing Symbols
You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located 
in the position where they were created. The pivot is translated at the centre of the symbol.

How to edit a symbol from the Timeline view

 1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E 
(macOS)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

 2. Do one of the following:

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl 
+ Shift + E (Windows/Linux) or ⌘  + Shift + E (macOS). 

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.
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How to edit a symbol from the Library view

 1. In the Library view, select the symbol to edit.

 2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl 
+ Shift + E (Windows/Linux) or ⌘  + Shift + E (macOS). 
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Importing Symbols
There are several ways you can import symbols in your scene. 

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. 
If you import a symbol into your scene several times in the Timeline view, they will all be linked to the original 
symbol. If you modify one, they will all be modified. 

How to import a symbol in the Timeline view

 1. In the Library view, select the symbol you want to import.

 2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE 

This may be useful if you saved a character's body parts as separate symbols. If you dropped 
them into the Timeline view, then they would all appear in the centre, haphazardly one on top 
of the other. It would be more efficient to arrange them into their correct places as you bring 
them into the scene.
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Expanding Symbols
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The 
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root 
timeline. The symbol's layers will be parented to it in case you created motions and transformations on the 
drawing layer that contains the symbol. Breaking the hierarchy could result in the loss of any scaling and 
animation you may have created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you 
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to expand a symbol

 1. In the Timeline view, select the symbol to expand.

 2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group

 1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

 2. From the top menu, select Edit > Expand Selected Symbol in a Group.

 3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the 
Expand Arrow to enter the group.
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Converting Symbols to Templates
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content 
in another scene, you must create a template. This conversion breaks the drawing's link with both the original 
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to convert a symbol into a template

 1. From the Library view, select the symbol to convert into a template and drag it to the Camera or 
Timeline view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not 
be placed in the centre of your camera frame, but rather wherever your cursor drops it within the 
camera frame.

 2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to 
any other library folder. Make sure you have the right to modify the library folder.
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 3. In the Rename dialog box, rename the new template.

 4. Click OK.
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Importing Files in the Library
Harmony lets you import sound files and images directly through the Library view. Simply open the folder 
containing your files in the Library view and drag them directly from there.

How to open a file through the Library

 1. In the Library view menu, select Folders > Open Library.

 2. Browse for the folder containing the files you want to import.

 3. Click Open.

 4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You 
can choose to import only the keyframes without the drawings or import only the drawings that are not 
already in your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a 
symbol in your scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left side, 
all the frames will be exposed. However, if you import it into an existing layer, you can use the Paste Special 
dialog box to adjust the import behaviour to fit your requirements.Once you set the parameters, Harmony will 
reuse them each time you import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Do one of the following:

 l While holding down the Alt key, click and drag on the template, then drop it on the Timeline 
view, over the layer and at the frame where you want to paste it.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (macOS). Then, in the Timeline view, click on the 
frame where you want to paste the template and press Ctrl + B (Windows/Linux) or ⌘  + B 
(macOS)

The Paste Special dialog box opens.

 3. In the Paste Special dialog box, select the desired parameters—see the Paste Special Dialog Box 
topic of the Reference guide .

 4. Click OK. 
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Chapter 20: Gaming in Harmony
There are two main pipelines for exporting data from Harmony to your game engine: 

 l Raw Game Data Export  on page 161

 l Frame-by-Frame Export  on page 162

Creating Animation in Harmony

When creating character rigs and animation for games, there are a few things to think about before starting.  
Artists and programmers should work together to make sure their needs are met. 

 l What platforms will your game be create for?  Windows, Mac, Mobile, iOS, PS, XBOX, etc. 

 l What game engine will you be using?

 l What  will be animation style used to create the look of the game?  Hand drawn, cut-out, with textures, 
etc. 

These are just a few of the questions to consider before getting started.  They all have an impact on how you 
design, build, and animate characters. 

For example, if you’re planning a mobile game for smart phones, then you will most likely want to keep your 
game under 50 MB, so it can be downloaded without having to be on Wi-Fi.  In that case, your most important 
consideration is to create efficient characters with very tight sprite sheets and reuse a lot of the animation to 
keep the file sizes small.    During the process, you will need to: 

 l Rig and animate characters in Harmony.

 l Extract the Harmony data. 

 l Import the Harmony data into the game engine.  

Keep in mind, if you’re working with a custom engine, you can also process the Harmony data that’s exported 
and use it in a custom game engine.  If you need assistance with adapting data for your engine, contact 
store.toonboom.com/contact/support. 

If you’re making a game for consoles, like the PS or Xbox, then you have the freedom to create larger textures.  
You may want to animate frame-by-frame, or you may want to animate with a cut-out character.
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If you're simply going to export on a frame-by-frame sequence, then you can use all the tools in Harmony 
without limitations.  You can then process an exported image sequence into a sprite sheet.  

Raw Game Data Export 

Raw game data export is appropriate when you want the file sizes to be as small as possible.  Toon Boom lets 
you extract all the data from Harmony to incorporate into a game engine.  You can extract the skeleton 
information, drawing information, and keyframe animation data, as well as deformations (bones and 
articulations only), cutter, transparency nodes, and timing columns. 

 l Advantage: This is the lightest export, and will keep file sizes small which is ideal for mobile applications.
  

 l Disadvantage: You are somewhat limited in the tools you can use in Harmony.  You can use tools like 
Morphing as well as Curve and Envelope deformers, but you’ll need to bake it out to drawings so they're 
interpreted properly in the game engine.  You can use Cutter effects (masking), but you cannot cascade 
them, meaning you cannot have more than one in a hierarchy chain.  The Game Bone deformers can be 
used on your rig with having to bake it to drawings.

However, even with these limitations, you can create really great cut-out character animation in Harmony and 
extract all the data.  By moving, rotating, scaling, and skewing the different drawing layers, you can create 
advanced looking animation.  

When you extract the data, you'll have sprite sheets that contain only the drawings of the body parts used in 
your Harmony scene file.    You can also support multiple animations, such as idle, run, and jump, and reuse the 
same skeleton and drawings when possible by simply exporting new animation data. 

Toon Boom has fully integrated this solution with the Unity game development rendering engine. If you are 
creating your game in Unity, you have a seamless pipeline without the need to re-treat the data in your game 
engine. 
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Chapter 20: Gaming in Harmony

Frame-by-Frame Export 

You can export from Harmony using an image sequence, which can be recompiled into a sprite sheet.

Advantage: You can use any of the tools in Harmony when you animate!

Disadvantage: These sprite sheets can become quite heavy and end up as large textures to process in the 
game. This may be fine for many games, like console games, but when you’re doing game development for 
mobile devices, such as iOS or Android, you need to be very light on your texture space. Also, file sizes should 
be kept under 50 MB to facilitate downloading without needing to be connected to Wi-Fi.

There is a script available in Harmony that allows you to export your animation in frame-by-frame to the 
EaselJS game engine   EaselJS is a javascript web compatible game engine.  It uses a json data structure to map 
each frame to an entry in the sprite sheet.  The data structure is easy to understand and can be adapted or 
converted to a different game engine if you need to.

To export to EaselJS, you need to add the script in the Scripting toolbar (TB_ExportToEaselJS).  This script is 
included in Harmony.  See the Scripting guide for more information on how to add the script to your Scripting 
toolbar and the interface parameters.
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About Game Asset Creation
In this section, you'll find guidelines for rigging, deformation, cutter and many useful animation tips.
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Game Rigging Guidelines
For complete procedures on how to rig a character, see Character Rigging.

The following is a list of general guidelines to keep in mind when rigging your character. As you're planning the 
character rig for your game, keep in mind the style of the character, and create your custom colour palette.  
However, there are some limitations to consider if you plan to extract the game data:

 l Set your Harmony scene to be a square resolution (e.g. 1024 x 1024). You can do this in the Scene 
Setting dialog box—see the Reference guide .

 l Nudge layers in Z space if you need to reorder layers.  However, significant Z offsets are not supported 
within a character rig. 

 l Make every layer in your game engine  a separate scene in Harmony.  If you have two characters at 
different depths, put them in separate scene files. 

 l Character rigs in groups at the root level of your Harmony scene will render to a single plane in Unity, 
but use separate sprite sheet and animation data sets.  Keep this in mind for scenes in which you may 
have more than one character interacting with each other. 

 l Don’t use any effects.  Effects are not interpreted by game engines.  Use only direct hierarchy, drawing 
swaps, and keyframe animation. 

 l Set your pivot points on Peg layers using the Rotate tool to set the pivot on the entire layer.  Peg pivots 
are recommended over drawing pivots.  You should also set the pivot points on your drawing layers, even 
if you don’t animate on them, as this will allow you to retrieve the information later on in the game 
engine if you need to put a locator on a drawing layer.

 l Deformations can be used and then baked out to individual drawings.  These drawings will then show up 
as new drawings in your sprite sheet.  Be wary of doing this too often as it will increase your texture 
space! 

 l For your pegs, when you animate, use Bezier curves and set them to Separate.  If you use 3D Path, it’s 
heavier than Separate. 

 l Be mindful of where you put your character before exporting. The master pivot of your exported game 
object will be the center of your Harmony scene (0,0).

 l Be sure to have a Display at the end of your hierarchy.

Keeping these tips in mind will allow you to create a tight, efficient 2D game character in Harmony while taking 
advantage of all the great tools. 

Here are some things you should do: 

 l Create a simple parent-child relationship hierarchy in the Timeline view.

 l Use peg layers to contain keyframe animation data, set to Separate Position.

 l Use drawing layers to draw on, creating new drawings when needed.

 l Use the Rotate tool to set the pivot points on the peg layers.
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 l Name your layers properly so if you need to fetch a specific layer’s pivot point later on in the game 
engine, you can easily recognize the layer you need.  If you have a top-level Group A, which has a child 
group inside it (Group B), and the drawing layer is a child of Group B, then the drawing layer is exported 
as A_B_DrawingLayer.

 l Set your anchors and props, see—Setting Anchors and Props.

You can use any of the drawing tools you want: Pencil and Brush tools, textured lines, solid areas, and 
gradients.  Each individual drawing will be rendered out and assembled into a sprite sheet later.

NOTE 

Because the Unity game engine does not support Unicode characters, it is recommended to avoid 
using it in scenes intended for games.
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Game Deformation Guidelines
Harmony can export deformations to the game engine XML format. Only hierarchies made of Game Bones can 
be successfully exported. In addition, Kinematic Outputs were implemented to complement your game bones—
see About Game Bone Deformations on page 168.

The deformation in the game engine SDK does not behave exactly as the deformation in Harmony.

To comply with most game engines and maintain fast calculations, the SDK implements a linear base skinning 
algorithm to linearly blend the bones at articulations. You may notice some differences depending on the 
curvature of the articulations used.

NOTE 

* Not currently available in the Cocos2d-x implementation of the game engine SDK.
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About Game Bone Deformations

T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like 
structure in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a 
character's limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For 
example, a Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that 
the upper arm and forearm can be moved independently, without having to draw the upper arm and the 
forearm on different layers. Harmony will deform the drawing to make it look articulated. The different parts of 
a Game Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
difference between the Bone and Game Bone deformations is that Game Bone deformations do not have a 
Bias property. The articulation folds also look slightly more rounded.
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Game Cutter Guidelines
The cutter, or mask, operation in Harmony is used for cutting off drawings with custom shapes. The game 
engine SDK implements both cutters and inverted cutters with the following limitations:

 l For a sprite, only a single cutter drawing can be applied when it is rendered. This also applies to a 
composite of multiple matte drawings. The game engine SDK will only use the first matte drawing 
during rendering and discard the others.

 l A deformed drawing cannot be cut, but a cut drawing can be deformed.    

NOTE 

Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Creating Metadata Notes
As you create assets for your game in Harmony, you may want to make notes about the scene or specific parts 
of the character or props for the programmer. These embedded notes that will be exported with your assets to 
Unity are known as metadata.

How to access the Metadata Editor view

 l In the top-right corner of a view, click the Add View  button and select Metadata Editor.

 l In the top menu, select Windows > Metadata Editor.

How to create scene metadata

 1. In the Metadata Editor view, in the Scene Metadata section, click on the plus button to create a 
new metadata entry.

The Add Metadata dialog box appears.

 2. In the Add Metadata dialog box, enter the name of your new scene entry.

NOTE 

For any anchor or prop information created within the Metadata Editor, the naming 
convention must always use the prefix "game.". The term "game." is recognized 
automatically by Unity as a metadata information. For example: game.Armor001.

 3. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are 
through.

 4. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 5. Enter the value information for this entry. 

 6. Continue adding value information for all your entries.

This information will be exported with your Harmony assets. Once in Unity, scene Metadata will 
appear in Inspector view > Metadata when the asset is selected in the Hierarchy view.
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How to create node metadata

 1. In the Timeline view, click on the layer to which you would like to attach metadata.

The name of the layer appears near the top of the Node Metadata section.

 2. In the Node Metadata section, click on the plus button to create a new metadata entry.

The Add Metadata dialog box appears.

 3. In the Add Metadata dialog box, enter the name of your new node entry.

NOTE 

For any anchor or prop information created within the Metadata Editor, the naming 
convention must always use the prefix "game.". The term "game." is recognized 
automatically by Unity as a metadata information. For example: game.Armor001.

 4. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are 
through.

 5. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 6. Enter the value information for this entry. 

 7. Continue adding value information for all your entries.

This information will be exported with your Harmony assets, more specifically, this information will 
be linked to the selected layer. Once in Unity, scene Metadata will appear in Inspector view > 
Metadata when the asset is selected in the Hierarchy view.
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Game Animation Tips
When animating for games, depending on the type of game you’re creating, you may need to limit your 
animation.  For example, if you’re creating mobile games and you want to keep the file sizes small and playback 
fast on all devices, then limit yourself to simple keyframe animation with as few drawing swaps as possible.  If 
you’re creating console games, you have the freedom to create more drawings and have a higher complexity.  
You can explore with your programmer the limitations of the platforms you’re exporting to, and what your 
game engine supports.

Here are some tips for efficient, lightweight animation: 

 l Use mainly transformations, such as move, rotate, scale, and skew. 

 l Create additional drawing swaps when needed.

 l If you use Curve and Envelope deformers or Morphing, you’ll need to bake out the drawings for export.  
Be careful when doing this, as you may want to keep the number of drawings small.  Don’t bake out an 
entire sequence, just selected drawings. You don't need to bake the Game Bone deformers.

 l The bigger the drawings are in the Drawing view, the more pixels they will occupy in the texture size on 
the sprite sheet.  When setting up your rig, make sure to not scale individual layers by using a keyframe 
with the Transform tool.  If you want to scale things up or down, use the Select tool.  This will keep things 
the same relative size on the sprite sheet.  When you export the sprite sheets, in the script you can also 
set the resolution of the sprite sheet so the drawings can be scaled down for smaller devices.

 l Only drawings which are exposed in the scene will be exported to the sprite sheet.  For example, if you 
have 10 drawings in your Library view, but only two of them are showing in your scene, only those two 
will be exported.  This keeps the sprite sheet as tight as possible. 
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Animating Multiple Sequences

You will always have multiple animations for your characters.  For example, an idle sequence, a run sequence, an 
action sequence, and so on.  You need to work in a specific structure so you can export all of these animations to 
a single sprite sheet. 

There are two different work flows that you can use:

 l Workflow 1: Separate Scenes 

 l Workflow 2: Separating Using Scene Markers
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Workflow 1: Separate Scenes

First, create a scene file with the name of the character, such as Space Duck.  This is the file where you can 
create or import your game rig. In the top menu, select File > Save As New Version, and give this new version 
the name of the animation.  For example, Idle. 

Every time you need to do a new animation using the same character, perform a Save As New Version.  In the 
end, you may have something like this: 

Scene: Space Duck 

Versions: 

 l Idle 

 l Run 

 l Jump 

 l Shoot 

When you run the export script, it will export the drawings from the current scene into the export folder.  It will 
also let you know if there are any other scene versions that were already exported to that folder.  If so, then it 
will recompile the sprite sheet to include all the drawings from all the animations. This allows the maximum 
possible reuse of drawings. 
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Workflow 2: Separating Using Scene Markers

You can also create all of your character animations in a single scene, one after the other, such as idle, run, jump 
and shoot. Then use scene markers to mark and separate the individual animations, see—Creating Scene 
Markers on Frame Ranges on page 188.

When you are marking individual animation frame ranges, be sure that they start and end with a keyframe. Do 
not create scene markers for a range of frames that starts or ends in the middle of an interpolated movement.

When exporting your sprite sheet, in the Export To Sprite Sheet dialog box, be sure to check the Use Scene 
Markers to Export Clips option.

The animated clips are divided and listed in the stage.xml in the same way that they would appear if you had 
exported each animated sequence from separate scenes to the same file location.
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Using the Harmony Game Previewer
If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, you 
can use the Harmony Previewer application. You can visualize your characters in the Unity game engine with 
no programming required.

To get the latest version of the Harmony Game Previewer, visit our Gaming landing page:

https://www.toonboom.com/games

How to use the previewer on Windows

 1. Download the Harmony Game Previewer for Windows:

 l https://download.toonboom.com/games/GamePreviewer-11.1.0.0047-windows.zip

 2. Extract the following to your hard drive:

 l GamePreviewer-[version].exe 

 l GamePreviewer-[version]_Data folder

 3. Copy your export from Harmony to this folder:

 l GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\

 4. Start the Game Previewer application.

 5. Select the export you want to preview.

How to use the previewer on macOS

 1. Download the Harmony Game Previewer for macOS:

 l https://download.toonboom.com/games/GamePreviewer-11.1.0.0047-macosx.zip
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 2. Extract the GamePreviewer-[version].app.

 3. Right-click on the GamePreviewer-[version].app and select Show Package Contents.

 4. Copy your export from Harmony to this folder: 
Contents/Data/StreamingAssets/HarmonyResources/

 5. Start the Game Previewer application.

 6. Choose the export you want to preview
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About Exporting to Unity
If you have a custom game engine, you can take the exported Harmony data and proceed with your usual 
process.  Or you can modify the export script to fit your convention.  

Before exporting a scene:

 l Be sure to set your Display as Display and not Display All.

 l Be certain to save your scene. Harmony makes the export based on the tvg files, any unsaved updates 
you have added will not be exported.

 l Set your Harmony scene to be a square resolution (ex. 1024 x 1024). Select Scene > Scene Settings.

The Transparency parameter attached to the element node is exported along with the animation. You can set 
the transparency through the Layer Properties window (Advanced tab).
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Clearing Scripts
If you were using Harmony 12.1 or earlier, it is strongly suggested that you clear your scripts before exporting 
animation for the first time. This will ensure there's no conflict with previous versions of the scripts and you 
have the most up-to-date script.

How to clear your scripts

 1. Close Harmony if it is open.

 2. Browse to the script folder location:

 l Windows:

 l Toon Boom Harmony Advanced: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon BoomHarmony 
EssentialsEssentials\1200-scripts

 l macOS: 

On macOS, the Library folder is a hidden folder. To display the display the folder, told 
down the Alt key.

 l Toon Boom Harmony Advanced: /Users/[user_
name]/Library/Preferences/Toon Boom Animation/Toon Boom Stage 
Essentials/1200-scripts

 3. Delete the 1200-scripts folder.

 4. Restart Harmony and test the export.
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Setting Anchors and Props
Before exporting to Unity, you need to set your anchors and props.

An anchor is an attachment point you can use to bind one or several props to a specific location that is 
predefined by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and 
easily swappable from within Harmony or Unity.

How to set an anchor

 1. Create a new Drawing layer and rename it according to the anchor you are creating.

 2. Inside the Layer Properties of your drawing layer, make sure that pivot option is set to  Don’t Use 
Embedded Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on 
Parent Peg does not transition well to Unity and you will lose your pivot information.

 3. Once this is done, you can use any of the animation tools to reposition the pivot point of your layer, 
such as the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot 
coordinates from the Layer Properties of your Drawing layer. If the pivot is not repositioned, its 
default place will be at the centre of your Harmony scene (0,0).

 4. Once this is set up, select the Drawing layer and click the Toggle Anchor  button in the Game 
toolbar. You can also make a multi-selection to set an anchor on multiple Drawing layers 
simultaneously.

The Drawing layer is highlighted in red in the Timeline. Your anchor can now be used to attach a 
prop.

How to set a prop

 1. Create a new Drawing layer or take an existing prop on which you want to attach an anchor.

 2. Position the Drawing Pivot of the prop layer using a tool on the Advanced Animation toolbar, such 
as the Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is 
positioned accordingly.

 3. With the prop Drawing layer selected, click the Toggle Prop  button in the Game toolbar. You 
can also make a multi-selection to set a prop on multiple Drawing layers simultaneously.
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The prop Drawing layer is highlighted in green in the Timeline.

 4. Do one of the following:

 l Connect the anchor and prop to the parent peg.

 l Connect the prop under the anchor to create a parent/child hierarchy.
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Exporting Sprite Sheets
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or 
multiple sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, 
and jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations 
in that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are 
exported individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite 
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but 
reusing the same skeleton.

NOTE 

Programmers may be interested to note that the XML data exported by Harmony can be 
converted afterwards to a more optimized binary data structure.  To convert XML to Binary format, 
use the Xml2Bin utility. This utility converts the XML data structure generated through the Toon 
Boom Harmony software to a compressed binary data structure. This utility is available in the 
gaming SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx: Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you 
want to integrate with other game engines.

How to export sprite sheets

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Sprite Sheets  button in the Game toolbar.

The Export to Sprite Sheets window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If 
not, you can save anywhere, then transfer the animation into your Unity project, or any other game 
engine you want to use.

 4. Set your sprite sheet preferences, see—the Reference guide .

 5. Click Export.
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Exporting to Easel JS
The Export to Easel JS window lets you flatten an image sequence of your animation. Even if you have a fully 
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened 
output of each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work 
as you have access to any tools or effect modules you want to use. However, this can result in heavier files 
depending on the length, complexity and export size of your animation.

NOTE 

Programmers may be interested to note that the XML data exported by Harmony can be 
converted afterwards to a more optimized binary data structure.  To convert XML to Binary format, 
use the Xml2Bin utility. This utility converts the XML data structure generated through the Toon 
Boom Harmony software to a compressed binary data structure. This utility is available in the 
gaming SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx: Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you 
want to integrate with other game engines.

How to export to Easel JS

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Easel JS  button in the Game toolbar.

The Export to Easel JS window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If 
not, you can save anywhere, then transfer the animation into your Unity project, or any other game 
engine you want to use.

 4. Set your sprite sheet preferences, see the Reference guide .

 5. Click Export.
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About Working in Unity
The Harmony Gaming Animation Guide is a basic guide on how to import Harmony projects and configure 
them, design and animate characters, and includes some tips. It is not meant as a guide on how to program 
games.

186



About the Sample Unity Project
Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported 
from Harmony.  Inside this project is an Assets folder which contains the following folders: 

 l Plugins 

 l Scenes (demo scenes and a previewer) 

 l Scripts (all Harmony scripts) 

 l StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder. 
This way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder.  You can 
also manually place exported Harmony data into this location.
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About the Unity Interface
Here are the main components of the Unity interface and their equivalents in Harmony:

Unity Harmony Description

Scene view Perspective view
This is where you set the scene, selecting and positioning 
environments, the player, the camera, enemies, and all other 
GameObjects. 

Game view Camera view
The rendered view from the camera(s) in your game. It is 
representative of the final, published game. 

Inspector Layer Properties
Displays detailed information about the selected 
GameObject, including all attached Components and their 
properties.

Hierarchy Layers in Timeline view
Displays the hierarchy of elements in the scene, and lets 
you set up parent-child relationships for different game 
objects.

Project Browser --- Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy.  To show a Harmony object, you must add a 
special component.  With the main camera selected, in the Inspector, select Add Component > Scripts > 
Harmony Camera.
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Importing Harmony Files into Unity
Once you've finished creating your artwork and cyclable animated character movements in Harmony, it's time 
to import them into Unity for game integration.

How to import Harmony files directly into Unity

 1. Create a Unity 2D project.

 2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought 
in. Do one of the following:

 l Go to the Unity Asset Store (assetstore.unity3d.com/en/#!/content/31211) and save the 
Harmony Game SDK file on your computer. Then import it in your project from the following: 
Top Menu > Asset > Import Package > Custom Package.

 l Search for the Harmony Game SDK in the Unity Asset Store, then download and import the 
package. You can access the Asset Store from the following: Top Menu > Window > Asset 
Store.

NOTE 

For each new Unity project, you must repeat step 2 as it contains the necessary files and 
folders to make the Harmony import process work.

 3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >

 l Harmony Object:  Lets you browse for the exported Harmony project folder.  If 
you’ve already saved this to your StreamingAssets folder, you can browse to it 
through there.  Then it adds the Harmony scene to your Unity file, and sets up 
the rendering, audio, and animation scripts you need to get going.

 l Harmony Texture Object: Lets you browse for the exported Harmony project 
folder similarly to Harmony Object, but creates a Unity plane to render your 
animation on it.

190

https://www.assetstore.unity3d.com/en#!/content/31211


About Game Objects
GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically 
everything you create in Unity will be a GameObject.  There are two main types of GameObject you can use to 
import Harmony data: 

 l Create Empty

 l Create Other > Plane 

To understand the process fully, there are two examples using an empty GameObject and a plane GameObject 
with the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your 
Harmony data.
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Using Empty Game Objects

An Empty Game object is a regular GameObject in which you can load the exported Harmony data.  All the 
individual body parts on the sprite sheet come in as separate elements, but are treated as one whole object 
with a dynamically created bounding box.  If you put a transparency on this object, you would see the 
overlapping transparencies of all the individual objects.  This creates a higher-quality render and should be the 
default if you’re not animating the transparency of an object.  With this option, direct rendering will read the 
depth information in the scene but not write it.  Note that with this option, the rendering cannot be customized.
 

How to use an empty GameObject

 1. Select GameObject > Create Empty.  

 2. Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo 
file, rename the GameObject to SpaceCat by doing one of the following:

 l Double-click on the name and rename it in the Hierarchy.

 l Select the GameObject and rename it in the Inspector. 

 3. At this point, it’s an empty object.  Accessing Harmony data is done through scripts.

 l Select the SpaceCat GameObject. 

 l In the Inspector, go to Add Component > Scripts > Harmony Renderer.

A new section appears in the Inspector called Harmony Renderer (Script).
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This will let you load an animation file.  You must put the path of the asset relative to the 
HarmonyResources folder.  Before this, you must export from Harmony directly to this folder, or 
manually copy and paste the data here.

 4. You exported a scene called SpaceCat.  In the Project Folder, place HarmonyResources/SpaceCat 
under the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z 
because the default Harmony project is for an HD screen.

 5. You won’t see anything until you define a few parameters:

 l Set the Clip Name Size to 1. A second field will appear, Element 0. 

 l Enter the clip name for the animation you want to load.

 6. Double-check on the right Clip Name to put in Element 0; you can check the output you exported 
from Harmony.  

 7. Double-check the stage.xml file, which was exported to the folder you specified when exporting 
from Harmony.  Our default export path is to StreamingAssets, so it will automatically load in the 
game engine.

 8. Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName]. 

You’ll find the data that was exported.  In this case, we’re looking for SpaceCat. Select the file 
marked stage to load the data you want to double-check. 
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The text data appears in the Inspector.

The name to use for loading the object is the stage name.  In this case, SpaceDuck_SpaceCatIdle.

 9. If your GameObject has animation in it, and you want it to load the animation data from the 
Harmony export, add one more component by doing the following:

 l Select the GameObject.

 l In the Inspector, select Add Component and select Scripts > Harmony Animation. 

 10. To loop the animation, you must set a GameObject to define it:

 l Select  GameObject > Create Empty and rename it: LoopAll.  

 l Click the LoopAll GameObject to display its properties in the Inspector. 

 l Click Add Component > Scripts > Loop All.   

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on 
all GameObjects on runtime and asks them to loop, which is useful when testing the animation.  
When programming the actual game, you should write additional scripts to control the different 
elements separately.
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Using Plane Game Objects

Renders the entire character to a plane. This renders your character to texture data.  If you animate the 
transparency of the plane, then the transparency of the rendered output is animated; you won't see the 
transparencies of the overlapping elements.  However, you will have one static bounding box the size of the 
plane that you render to. 

Use this option when you want to animate the transparency of a character in a scene.  Also, you can write your 
own custom shaders.  Simply set the Render Target to eRenderTarget.   You can see an example of this in the 
sample project DemoRenderTarget.  

 How to use a plane GameObject

 1. Select GameObject > Create Other > Plane.  

 2. Select Add Component > Scripts > Harmony Renderer. 

 3. Set Size to 1 and Element to 0 on the clip name as per previous instructions. 

 4. Set Render Target to eRender Texture.  

 5. Render Texture Viewport:  

 l X: To reposition the animation correctly; it should be -½ the width of your Harmony 
project.

 l Y: To reposition the animation correctly; it should be -½ the height of your Harmony 
project. 

 l W: Width of your Harmony project 

 l H: Height of your Harmony project.  

 6. Use the custom Shader created by Toon Boom to have a transparent background with 
premultiplied alpha channel.  This is what produces nice, antialiased drawings in your output.  

 7. With the Plane selected in the Inspector, go to Mesh Renderer > Materials. Under Element 0, select 
UnlitTransparentPremultiplied. 

 8. If you're starting with the Toon Boom demo project, this renderer should already be loaded in your 
list. 

You can also write your own custom shaders and use them here. 
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 9. You must also add the animation component.  Select the Plane. In the inspector, click Add 
Component > Scripts > Harmony Animation.

Once your Harmony GameObject is imported, you should be able to see your character both in the Scene 
and the Hierarchy views. From here you can attach one or several props to an anchor.
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Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is 
predefined by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and 
easily swappable from within Harmony or Unity.

How to attach the prop to an anchor

 1. Open up your character in the Hierarchy view to have access to both the props and the anchors. 

 2. Click on the prop you wish to attach, and drag it onto the appropriate anchor. 
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 3. Repeat these steps for each prop and anchor in your project.

 4. In the Inspector view, under Frame, you can select which frame you wish to show. If you only had 
one drawing in your prop, then you will not have multiple options.

 5. If part of your character is cut off by the plane of the character, now that the props are showing, you 
will need to regenerate the mesh. To do so, select your GameObject. After this is done, go to 
Inspector View > Render > Generate Mesh.
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Placing Locators in Unity
In Unity, it's possible to assign a target to some part an imported Harmony animation.  For example, in the 
Space Duck scene, the character has a gun. You may want to attach some other action to this animated gun, 
such as shooting spheres and cubes out of its end. For this, you need to place a locator at the end of the gun. 

You can see some examples of this in the provided Unity project.  The first example is in the demo scene 
DemoLocator,  which shows a simple cylinder attached to the end of the gun. 

The second example DemoCallback shows the gun shooting spheres and cubes.

You can access any drawing layer created in Harmony later in Unity and use its pivot point to attach objects 
and animated sequences. In Harmony, you should set the pivot points on your drawing layers with the Rotate 
tool.

You can also create an empty drawing layer in Harmony, when setting up your character, to be used later in 
Unity. Use Create Empty Drawing to create a blank drawing, then use the Rotate tool to set the pivot point on 
this drawing layer.  In the Space Duck example, an empty drawing layer called hook_gun was created on 
which you can attach the locator in Unity. 

When you access the imported Harmony character in Unity, you can access the data with a script.  

How to set a locator to a part of a character

 1. Select Game Object > Create Empty to add a new GameObject to extract the target's position, 
rotation, and scale. 

 2. Drag and drop the new object so that it's a child of the character. 

It becomes indented.  

 3. Rename the GameObject to: Hook Gun.

 4. In the Inspector of the target object, select Add Component > Scripts > Harmony Locator.

 5. Enter the name of the drawing layer to which you want to attach.
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 6. To find the exact name for the Locator Name, look at the skeleton.xml file in the Streaming 
Assets folder.  You can find it in Streaming Assets > Harmony Resources > Name of Harmony File > 
skeleton.

All the drawing and peg layers are listed. In this example, look for  space_duck_hook_gun. Having 
drawing layers with distinctive names makes them easy to recognize when you need to retrieve 
them.

You can copy the name of the layer into the Locator Name to see the Transform information 
updating dynamically as you run the simulation.

 7. Now you can attach anything as a child of this Locator Object.  For testing purposes, you could attach 
a cylinder for example.  In a real example, you’d want something to shoot out of the end of the gun, 
so you can see the Callback example to verify how that works.

200



Setting Up Collisions in Unity
Extracting the bounding box information is useful when you want to make something collide with your 
character.  When you put a 2D character into a 3D scene, you may want to use Physics to make the 2D 
character collide with the 3D plane.  To use the following scripts, you will need Unity 4.3 or higher. 

In the Demo scene, open the DemoPhysics example to see collisions and bounding boxes.  In this example, 
there’s a 3D plane and some 2D characters.  The 2D characters have a collision defined with their bounding 
box, and they're also reacting to the physics of the scene to fall with gravity. 

Colliders were improved to provide several different types of colliders for use in Unity. You can select polygon 
colliders and box colliders for a more accurate bounding box.

How to set up collisions

 1. Select your imported character.  

 2. In the inspector, select Add Component > Physics 2D > Box Collider 2D.  

 3. To enable the Physics on the character, go to Add Component > Physics 2D > Rigid Body 2D.  

NOTE 

You can also use 3D physics on the imported files. 

You can now adjust the variables and see the results.
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About Working with Audio in Unity
When you create scene files in Harmony with audio, the audio is exported into the project folder.  However it’s 
important to understand how the game is built to determine the best way to handle audio.  

When a game is built from Unity, it creates its own database for holding the assets.  Within the export, the 
Streaming Assets folder is preserved intact.  This is what enables the Toon Boom plugin to access those assets 
on the fly, and render them in the camera to create the final animation you see on the screen. 

However when it comes to audio, the game first looks for the audio in the Unity database. So this is the most 
efficient place to store the audio for the real game.

If audio can't be found in the Unity database, then the game looks in the Streaming Assets folder to find the 
audio.  When it does, it copies the audio on-the-fly back into the Unity database.  Since this action is quite 
costly, don’t leave the audio in the Streaming Assets folder for the final game.  It’s fine to leave it there while 
you’re testing, but not for the final game.  

The audio should be copied back into the Unity database, either manually or by automating this process with a 
script.
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Troubleshooting

Unity Questions

Q. My Harmony asset does not appear in the Unity Editor.

A. There are several possible reasons for this. Check the following:

 l Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory?  The plugin 
is named HarmonyRenderer.bundle on macOS and HarmonyRenderer.dll on 
Windows.

 l Is the clip name valid ? Make sure the clip name exists in the stage.xml file.

 l Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a 
newer version, make sure to regenerate the binary files if you use them so they’re 
compatible with the SDK.

Q. My Harmony asset does not appear in iOS or Android when exported from Unity.

A. There are several possible reasons for this. Check the following:

 l Make sure the Harmony assets are copied in the StreamingAssets directory. Since the 
HarmonyRenderer plugin cannot use Unity’s asset database, the Harmony assets were 
packaged as plain files so they are accessible to the plugin.

 l Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is in 
the Assets/Plugins/iOS directory.

 l Is the clip name spelled correctly? Windows and macOS aren’t usually case sensitive file 
systems, but iOS and Android are. This implies that an asset that is visible on the editor 
will not appear on the mobile platform because it cannot be found.

 l Make sure the size of your sprite sheets does not exceed the hardware limit of the device 
you're working on. Otherwise, the texture might not appear at all.

 l Is the path to the project folder an absolute path? If it is, it might not work on the mobile 
device as that path will not exist on the platform. Make sure to use relative paths to the 
StreamingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always 
appear behind the Harmony assets even if I change the order index in the GameObjects.

A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are, 
however, several solutions for working around this problem:

Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite 
like the other 3D elements in the scene and you can change the compositing order by incrementing or 
decrementing the Z value of the transform.

Use multiple cameras to render your scene in parts. Here’s how:
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Harmony Camera

 1. Create a new camera.

 2. Make sure you set the Harmony GameObjects to a specific layer (top-right of the game object inspector).

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in the 
background).

 4. Add the HarmonyCamera component to this camera so the Harmony GameObjects render properly.

Sprite Camera

 1. Create a new camera.

 2. Make sure to set the 2D sprite objects to a specific layer.

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in front of the 
2D sprites).

 4. Make sure to set the clear flags to Depth Only or Don't Clear.

 5. Set the depth to be higher than the Harmony camera.

 6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to keep 
Game Ojects in sync.

Q. How can you specify the frame rate of the animation?  My animation does not play at the same frame rate in 
Harmony and in the Game Previewer in the Unity Editor.

A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the 
HarmonyAnimation component, you can schedule animations at the speed you want.

Example

HarmonyAnimation animation = GetComponent<HarmonyAnimation>();

if (animation != null)

{

animation.PlayAnimation( frameRate, clipName );

}

Q. I cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?

A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer 
component in the GameObject, and so cannot be shown directly in the Scene view.

However, you should still be able to preview your assets in the Game view (even when not playing).   To help 
find and position assets, we also added bounding box shapes rendered in the editor and the Game view.

Q. How is memory management handled in Unity for Harmony assets?

A. Most of the memory extensive algorithms are executed in the C++ plugin.  The data structure is maintained 
alive as long as a GameObject refers to it.  This means you can instantiate as many clones of a character without 
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reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its 
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject 
uses them and a cleanup call is issued once they are destroyed.

Q. The Harmony assets memory does not appear in the Unity profiler.  Can we profile the assets memory?

A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a 
C++ plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers 
such as the one provided with XCode or Visual Studio should allow you to track your application’s memory 
including the Harmony assets and should also provide a more accurate result.

General Questions

Q. How can you specify the resolution used for the drawings in the sprite sheet?

A. The drawing resolution is not fixed in Harmony.  Since you're exporting the scene to multiple sprite sheets in 
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to 
see the resolution of a drawing compared to the rest of the scene.  By enabling the light table in the Drawing 
view, you will see all of the scene’s drawings untransformed in the same proportion as they will appear in the 
sprite sheet. More specifically, the resolution used in the sprite sheet for a drawing is the size it appears 
untransformed in the Camera view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export 
Sprite Sheet dialog box).

Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a 
drawing and use the Transform tool to scale it back up so it does not change visually in the Camera view. This 
should allow you to alter the size of drawings in the sprite sheet.

Q. The assets take time to load on mobile devices. Is there any way to speed up the process?

A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines. 
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project. 
At some point, they should be converted to a binary compact data structure that can be read into memory a lot 
faster than the XML.

You can use the Xml2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool 
is in the Utils/Xml2Bin folder and a precompiled version for macOS is available in the Utils/macosx 
folder.

Q. There are problems with the character I exported in the game engine. Pieces are not exported or are not 
showing in the proper order. What can I do ?

A.  To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are 
some of the key points for building a character that is compatible with the rendering in the game engine SDK:

 l Build your rig in the Timeline view. The game engine SDK data structure is similar to what 
is displayed in the Timeline view and an advanced node system might not always export 
properly.

 l Because every top level node in your scene will render separately in the game engine SDK, 
they may not intersect. A top level node is also isolated in its separate sprite sheet to allow 
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the artist better memory segmentation of the character. If you created a character with top 
level nodes and this was not the intended result, create a top level group or peg to group 
them all together.

 l Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its 
parent (as it does in Harmony).  To change the ordering, add some Z offset to the child 
layer.

 l The export script does not handle plain bitmap images.  Toon Boom vector drawings and 
Toon Boom bitmap drawings are supported though.

 l The export script does not handle symbols.
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Chapter 25: Scripting Guide

Chapter 25: Scripting Guide
T-ANIMPA-007-001

The Harmony Scripting guide contains information to help you use Qt Script, the scripting language used by 
Toon Boom Harmony Essentials.

Qt Script provides access to many of the functions supported in the  Harmony interface. With Qt Script, you can 
automate a number of Harmony functions to speed up the completion of various repetitive tasks.

Qt Script is an object-oriented scripting language based on the ECMAScript standard, like JavaScript and 
JScript. However, there are some differences that distinguish Qt Script from these other scripting languages, 
which are familiar to web programmers. For a reference on how to write Qt Scripts for the  Harmony scripting 
interface, see Scripting Reference on page 210.

NOTES 

 l For a reference of the QT development environment, refer to the Qt Documentation website. 

 l For a tutorial on writing JavaScript, refer to the JavaScript Tutorial section of W3Schools.

 l As of Toon Boom Harmony 10.3, Toon Boom Animation has changed its scripting language 
from QSA script to Qt Script for a better and faster scripting environment. Qt Script is very 
similar to JavaScript. Scripts are stored in plain text in files with the .js extension, instead of
 .qsa. This change to the API improves the software and gives access to 64-bit capabilities of 
the scripting interface.

To avoid complications for users of earlier version, every effort was made to enable backward 
compatibility with QSA scripts. Simple functions can be ported without making any changes. 
However, class definitions must conform to the Qt Script syntax. Therefore, scripts that define 
classes must be updated. For detailed instructions on how to update from QSA to Qt scripts, see 
the Moving from QSA to Qt Script documentation of the Qt website. 

Scripting Reference 210

Creating Scripts 211

Editing a Script Packaged with Harmony 214

Checking Script Syntax 216

Testing a Script 217

Debugging Scripts 219

Using the Scripting Sandbox 221

Importing Scripts 222

Deleting Scripts 224

Restoring a Harmony Script 225
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Scripting Reference
T-HSCP-001-001

In Harmony, you can open the scripting reference guide from the Script Editor view by opening the  view 
menu  and selecting Help > Scripting Interface Documentation.
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Creating Scripts
T-HSCP-001-002

You can create scripts for Harmony by using the Script Editor view. 

TIP 

To help familiarize yourself with Harmony scripts, you can open the Script Editor view and look into 
the TB_sceneCreated script. This script is automatically executed when you create a scene. By 
default, it sets the scene's length to 60 frames and creates a basic layout containing a single 
drawing layer. You can customize this script to automatically set up scenes you create to fit your 
project's needs.

NOTE 

User scripts are stored in the following location:                                

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom Animation\Toon 
Boom Harmony Essentials\1700-scripts

 l macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon 
Boom Harmony Essentials/1700-scripts

How to create a script

 1. In the top-right corner of the Camera or Drawing view, click on the  Add View button and select 
Script Editor.

The Script Editor view is added to your workspace. It lists all the scripts packaged with Harmony as 
well as any script you previously created.
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 2. Do one of the following:

 l In the Script Editor toolbar, click the  New Script   button. 

 l In the top-left corner of the Script Editor view, click on the  Menu button and select select 
File > New Script.

The New Script dialog box appears.

 3. Type in a name for your script and click on OK.

A dialog prompts you to select the location in which to create the script.

 4. In the drop-down menu, select the location in which you want to create the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.

 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 

 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

Your script is added to the list of scripts in the Script Editor.

 5. Select the script your just created in the list. 
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You can now start editing your script in the Script Editor. 

 6. Click on the text field in the right area of the Script Editor and start writing your script. 

The following is an example of a script that will display a message box saying "Hello World!"

function HelloWorld()
{
   MessageBox.information("Hello World!");
}

NOTE 

For information on how to use the Qt scripting language in Harmony, see Scripting Reference 
on page 210. You can also open the scripting reference guide directly from the Script Editor by 
clicking on the  Menu button in the top-left corner and  selecting Help > Scripting Interface 
Documentation.
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Editing a Script Packaged with Harmony
Harmony comes pre-installed with several scripts. These scripts are stored in a read-only location among other 
files that are packaged by Harmony. Hence, by default, they cannot be edited. 

To edit a script that was installed with Harmony, you must copy it to a location where it can be edited. This can 
easily be done by using the Make Editable button of the Script Editor view. This button creates a copy of the 
script and stores it in a location where you can make changes to it. Meanwhile, the original copy of the script 
remains untouched, and it is possible to revert to it later if you want. 

IMPORTANT 

Some buttons and menu items in the Harmony user interface run scripts that are packaged with 
Harmony. Hence, making changes to scripts packaged with Harmony may impact its functionality.         

NOTE 

If you make unwanted changes to a script that was packaged with Harmony, you can restore its 
original version—see Restoring a Harmony Script on page 225.

How to edit a script that is packaged with Harmony

 1. In the file list of the Script Editor, select any of the scripts that are packaged with Harmony. 

TIP 

Scripts that are packaged with Harmony have Application Resources as their location.

 2. Under the script editor, click on the Make Editable button.

A dialog prompts you to select the location in which to copy the script.

 3. In the drop-down menu, select the location in which you want to copy the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.
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 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 

 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

 4. Click on OK.

In the file list, the location of the selected script is updated to the one you selected.

Under the script editor, the Make Editable button is replaced with the Save button. This means that 
you can make changes to the script and save those changes.
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Checking Script Syntax
You can verify the syntax of your script before you attempt to run it. 

How to verify the syntax of a script 

 1. In the File list of the Script Editor, select the script you want to check. 

 2. Under the editor, click on the  Verify button. 

A dialog appears and displays whether or not it found a syntax error in the script, and if it did, the 
location and type of error. 
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Testing a Script
You can test a script using the  Run command, which is available in the Script Editor toolbar and menu. The 
run command can execute a specific function in one of your scripts, or an entire script. What the Run command 
is set to run is called the target.

To select which function in which script the Run command should execute, you must use the  Set Target 
command, which will prompt you to select a script and a function. Once you've done this, every time you use the 

 Run command, it will execute the function you set as your target. If you need to test a different function or 
script later, you will have to use the  Set Target command again to change the target script and function. 
This allows you to work on and repeatedly test one script or one function at a time when working on a script. 

NOTES 

 l If you use the  Run command without setting a target first, you will be prompted to set a 
target. The selected target will persist until you use the  Set Target command to change it.

 l The target script and function is also used by the  Debug command. 

 l To run a script from the global scope rather than running a specific function, you can select 
<Nothing> as the target function.                 

 l Although you can run  a script at the global scope, you cannot create a toolbar button that runs a 
script at the global scope. Toolbar buttons can only run specific functions within a script. Hence, 
running a script at the global scope should be done for testing purposes only.

How to test a script

 1. If you are currently editing the script you want to test, save it by clicking on the Save button 
underneath the editor. 

 2. Do one of the following:

 l In the Script Editor toolbar, click on the  Set Target button.

 l In the top-left corner of the Script Editor, click on the  Menu button and  select Play/Debug 
> SetTarget.
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A dialog appears listing all the scripts as well as all the functions in the current script. 

 3. In the Files list of the dialog, select the script you want to test.

 4. In the Functions list of the dialog, select the function you want to test. 

NOTE 

If you want to test the whole script from the global scope, select the <Nothing> 
function.

 5. Click on OK. 

 6. Do one of the following to execute the target function:

 l In the Script Editor toolbar, click on the  Run button.

 l In the top-left corner of the Script Editor, click on the  Menu button and select Play/Debug 
> Run.
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Debugging Scripts
T-HSCP-001-003

If you are having issues with a script you're working on, you can debug your script using the  Debug 
command. With the Debug command, you can run a specific function in your script, or an entire script, through 
a debugging interface.

To select which function in which script the Debug command should debug, you must use the  Set Target 
command, which will prompt you to select a script and a function. Once you've done this, every time you use the 

 Debug command, it will debug the function you set as your target. If you need to debug a different function 
or script later, you will have to use the Set Target command again to change the target script and function. 
This allows you to work on and repeatedly debug one function at a time when working on a script. 

NOTES 

 l If you use the Debug command without setting a target first, you will be prompted to set a 
target. The selected target will persist until you use the  Set Target command to change it.

 l The target script and function is also used by the  Run command. 

 l To debug a script from the global scope rather than debugging a specific function, you can 
select <Nothing> as the target function.

 l Although you can run  a script at the global scope, you cannot create a toolbar button that runs a 
script at the global scope. Toolbar buttons can only run specific functions within a script. Hence, 
debugging a script at the global scope should be done for testing purposes only.

How to debug a script

 1. If you are currently editing the script you want to debug, save it by clicking on the Save button 
underneath the editor. 

 2. Do one of the following:

 l In the Script Editor toolbar, click on the  Set Target button.

 l In the top-left corner of the Script Editor, click on the  Menu button and  select Play/Debug 
> SetTarget.
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A dialog appears listing all the scripts as well as all the functions in the current script. 

 3. In the Files list of the dialog, select the script you want to debug.

 4. In the Functions list of the dialog, select the function you want to debug.

 5. 
NOTE 

If you want to debug the whole script from the global scope, select the <Nothing> 
function.

 6. Do one of the following to execute the target function:

 l In the Script Editor toolbar, click on the  Run button.

 l In the top-left corner of the Script Editor, click on the  Menu button and select Play/Debug 
> Debug.

The Qt Script Debugger opens. In it, you will find standard debugging controls. 
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Using the Scripting Sandbox
The sandbox is a space in the Script Editor in which you can type or paste code snippets and test or debug 
them on the fly, without having to put them in the context of a function, and without having to create a script 
or to modify an existing script. It's also a useful tool to get yourself familiarized with the Harmony scripting 
interface.

How to use the Script Editor sandbox

 1. In the File list, select << Sandbox >>.

 2. In the text field of the script editor, type in your code.

The following sample code will display a message box saying "Hello World!"

 MessageBox.information("Hello World!");

 3. Do one of the following:

 l To verify the syntax of your script, click on the Verify button under the text field. 

 l To test your script, click on the  Run button in the Scripting toolbar or, in the top-left 
corner of the Script Editor, click on the  Menu button and select Play/Debug > Run. 

 l To debug your script, click on the  Debug button in the Scripting toolbar or, in the top-left 
corner of the Script Editor, click on the  Menu button and select Play/Debug > Debug. 
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Importing Scripts
T-ANIMPA-007-002

If you want to use scripts written by other users, you can transfer the .js files from their computer to yours, 
then use the Script Editor to import the .js files from where they are stored on your computer. 

NOTES 

 l When you import a script, any user interface (.ui) or icon (.png) file that is in the same 
directory and has the same filename as the script will also be imported.

 l User scripts are stored in the following location:                                

 l Windows: C:\Users\[username]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Essentials\1700-scripts

 l macOS: /Users/[username]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Essentials/1700-scripts

How to import scripts

 1. Do one of the following:

 l In the Script Editor toolbar, click on  Import Script.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select File > 
Import Script. 

An Open dialog appears.

 2. In the Open dialog, browse to the location of the script you want to import. Select it, then click on 
Open.

A dialog prompts you to select the location in which to import the script.

 3. In the drop-down menu, select the location in which you want to import the script:

 l User: Saves the script to a directory in your user preferences directory. You will be able to run 
and edit the script from any scene as long as you are logged in as the same user.

 l Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to edit and 
run the script when working on this specific scene. 
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 l System Variable: Save the script to the directory in the TOONBOOM_GLOBAL_SCRIPT_
LOCATION environment variable. This option is only available if this environment variable is 
set.

 4. Click on OK.

The script is copied to the chosen location and can now be edited and executed in the Script Editor 
view. It can also be added as a button to the Scripting toolbar—see Adding Scripts as Toolbar 
Buttons on page 231.
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Deleting Scripts
You can delete custom scripts from the Script Editor.

IMPORTANT 

When you delete a script in the Script Editor, the file containing this script is permanently deleted 
from your file system.

NOTES 

 l You cannot delete a script that is in the Application Resources folder. Those scripts were 
installed with Harmony and are read only. 

 l If you made a script that was packaged with Harmony editable by copying it to another location, 
you can delete your version of the script. This will restore the original version of the script to the 
File list. 

How to delete a script

 1. In the Script Editor, in the File list, select the script you want to delete.

 2. Do one of the following:

 l From the Script Editor toolbar, click the  Delete Script button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select File > 
Delete Script. 

TIP 

If you have deleted one of the scripts that are packaged with Harmony and wish to restore it, 
see Restoring a Harmony Script on page 225
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Restoring a Harmony Script
If you made a script that was packaged with Harmony editable so you could make changes to it, you can easily 
revert to the original version of the script at any time by using the Restore to Default button of the Script 
Editor view. This button deletes your copy of the script and restores the version of the script that was installed 
with Harmony to the File list. 

IMPORTANT 

Restoring a Harmony script to its original version will permanently discard any changes you made 
to it. 

How to restore a script packaged with Harmony to its original version

 1. In the File list of the Script Editor view, select a script that was installed with Harmony and to which 
you made changes that you want to revert.

 2. At the bottom of the Script Editor view, click on the Restore to Default button.

A prompt will ask you to confirm discarding the changes you made to the script. 

 3. If you are sure you want to permanently revert the script to its original version, click on Yes. 

The script is restored to the original version that was installed with Harmony. 

NOTE 

When restoring a script to its original version, its location is set to Application Resources 
and it becomes read-only, as it was before you made changes to it. If you want to make 
changes to the script again, you must make it editable again—see Editing a Script 
Packaged with Harmony.
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Using an External Script Editor
T-HSCP-001-004

If you are more comfortable editing your scripts using another text editor or syntax highlighter, Harmony allows 
you to set an external script editor and use that one instead.

NOTE 

If you try to open a script in the external editor without setting it first, Harmony will open the script 
in the default editor for JavaScrtipt (.js) files on your machine. 

How to set an external editor

 1. Do one of the following:

 l In the Script Editor toolbar, click the  Set External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> Set External Editor. 

The Set External Editor window opens.

 2. In the external editor, type  the complete and absolute path to the text editing application you want 
to use, including its name and extension. For example, if you want to use notepad++ on Windows, 
you could type:

C:\Program Files\Notepad++\notepad++.exe

On macOS, if you want to use an application that supports the AppleScript Open Document 
protocol, simply typing the name of the application might work, for example:

TextWrangler

Typing the name of the application you want to use will also work if that application has its path in 
the PATH environment variable, such as notepad on Windows. 

 3. Click on OK.

How to edit a script in an external editor

 1. In the File list, select the script you want to edit. 
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 2. Do one of the following:

 l In the Script Editor toolbar, click the  Open with External Editor button.

 l In the top-left corner of the Script Editor view, click on the  Menu button and select  Editor 
> External Editor. 

 3. In the external editor that opens, make the desired changes to your script, save the script and close 
the external editor. 

 4. In Harmony, the changes you made to your script in the external editor will not appear immediately. 
You can load those changes by selecting another script in the File list, then selecting the script you 
changed again. 
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Storing Scripts in a Custom Directory
By default, you can store custom scripts either in your user preferences or in a scene's scripts sub-folder.

If you prefer, it is possible to store your scripts in a specific custom location on your file system. This is done by 
adding the path to the custom location in the TOONBOOM_GLOBAL_SCRIPT_LOCATION environment variable. 
When this environment variable is set, Harmony will look for JavaScript (.js) files in that directory and add 
them to the list of scripts in the Script Editor, with System Variable as their location. 

Additionally, when you create a script, import a script or make an original Harmony script editable, you will get 
to store the script in the directory in the TOONBOOM_GLOBAL_SCRIPT_LOCATION environment variable by 
selecting System Variable in the prompt asking you where to store the script.

If you are working in a collaborative environment, you can make this directory read-only so that only people 
with special privileges can add or edit scripts in this directory. Harmony will check whether it has privileges to 
edit scripts in this location before allowing users to make changes to them. Otherwise, Harmony will only allow 
the user to run them. 

The method for setting an environment variable varies depending on the operating system you're using, as 
well as whether you want the environment variable to be set for everyone who uses the computer, or only the 
current user.

How to set the path to the custom scripts directory for the current user on Windows

 1. Open the Windows Control Panel:

 l On Windows 7: Open the Start menu and select All Programs > Accessories > System 
Tools > Control Panel.

 l On Windows 8.1 or Windows 10: Open the Start menu and, in the programs list, select 
Windows System > Control Panel.

 2. Select User Accounts, then User Accounts again.

 3. In the left pane, select Change my environment variables. 

 4. Under the User variables list, click on New.

The New User Variable dialog appears.

 5. In the Variable Name field, type TOONBOOM_GLOBAL_SCRIPT_LOCATION.

 6. Click on Browse Directory.

A Browse for Folder dialog appears.

 7. Browse to and select the directory in which you want to store scripts, then click on OK.

 8. In the New User Variable dialog, click on OK. 

 9. In the Environment Variables dialog, click on OK. 
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The next time you launch Harmony, you will be able to create, load and edit scripts in the directory 
you set as a custom script location.

How to set the path to the custom scripts directory for all users on Windows

 1. Open the Windows Control Panel:

 l On Windows 7: Open the Start menu and select All Programs > Accessories > System 
Tools > Control Panel.

 l On Windows 8.1 or Windows 10: Open the Start menu and, in the programs list, select 
Windows System > Control Panel.

 2. Select System and Security > System.

 3. In the left pane, select Advanced system settings. 

 4. Open the Advanced tab.

 5. Click on Environment Variables.

 6. Under the System variables list, click on New.

The New System Variable dialog appears. 

 7. In the Variable Name field, type TOONBOOM_GLOBAL_SCRIPT_LOCATION.

 8. Click on Browse Directory.

A Browse for Folder dialog appears.

 9. Browse to and select the directory in which you want to store scripts, then click on OK.

 10. In the New System Variable dialog, click on OK. 

 11. In the Environment Variables dialog, click on OK. 

The next time you launch Harmony, you will be able to create, load and edit scripts in the directory 
you set as a custom script location.

How to set the path to the custom scripts directory for the current user on macOS

 1. In a Terminal, type in the following command to create a launch agent for your user:

$ vi ~/Library/LaunchAgents/com.toonboom.global.script.location.plist

 2. Press the i key to enter insert mode and start editing the file.
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 3. Add the following text to the launch agent, replacing <path to scripts directory> with the 
absolute (full) path to the directory where you want to store scripts:

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE plist PUBLIC "-//Apple//DTD PLIST 1.0/EN" 
"http://www.apple.com/DTDs/PropertList-1.0.dtd">
<plist version="1.0">
<dict>
   <key>Label</key>
   <string>com.toonboom.global.script.location</string>
   <key>ProgramArguments</key>
   <array>
     <string>sh</string>
     <string>-c</string>
     <string>launchctl setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts 
directory>"</string>
   </array>
   <key>RunAtLoad</key>
   <true />
</dict>
</plist>

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 

 1. In the terminal, type the following command to enable the launch agent:

$ launchctl load -w 
~/Library/LaunchAgents/com.toonboom.global.script.location.plist

How to set the path to the custom scripts directory for all users on macOS

 1. In a Terminal, type in the following command to edit the login script for all users:

$ sudo vi /etc/profile

 2. Press the i key to enter insert mode and start editing the file.

 3. Add the following lines at the end of the script, replacing <path to scripts directory> with 
the absolute (full) path to the directory where you want to store scripts:

export TOONBOOM_GLOBAL_SCRIPT_LOCATION="<path to scripts directory>"
 launchctl setenv TOONBOOM_GLOBAL_SCRIPT_LOCATION "<path to scripts directory>"

 4. Press Esc to exit insert mode. 

 5. Type in :wq and press Enter to save and quit. 
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Adding Scripts as Toolbar Buttons
To use scripts in your regular workflow, you can add them as buttons to the Scripting toolbar. You can add 
buttons to the Scripting toolbar that are configured to run ax specific function in a script and, if you want, give 
these button a specific icon and tool tip. 

NOTE 

For more information on the Scripting toolbar and the Scripts Manager dialog, see the Reference 
Guide. 

How to link a script to a toolbar button

 1. Add the Scripting toolbar to your workspace by doing one of the following:

 l From the top menu, select Windows > Toolbars > Scripting.

 l Right-click on any toolbar and select Scripting.

The Scripting toolbar is added to your workspace.

 1. In the Scripting toolbar, click the  Manage Scripts  button.

The Scripts Manager dialog box opens and displays the available scripts.

 2. In the Files list, select the script file containing the function you want to add to the toolbar.

The functions in the selected script appear in the Functions list.

 3. In the Functions list, select the function that you want to add to the toolbar.
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 4. Between the Functions and In Toolbar list, click on the  Right Arrow  button.

The selected function is added to the In Toolbar list. 

 5. If you want to add a custom icon to the toolbar button for your script, click on the Customize Icon 
button and, in the Open dialog that appears, browse to and select the icon file that you want the 
button to have. 

You can use .png, .jpg, .xpm or .tvg files as toolbar icons. 

 6. If you want to add a custom tooltip to the toolbar button for your script, click on the Customize 
Tooltip button and, in the dialog that appears, type in the tooltip for your toolbar button.

 7. Click on OK.

A button for the selected function is added to the Scripting toolbar. If you click on this button, the 
function your selected will be executed. 

TIP 

You can stop a script while it is running by pressing the Esc key or clicking on the  Stop  
button on the Scripting toolbar.
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