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User Guide
The Harmony core functionality are explained in this User guide. All the steps required to create and complete
a project are covered in the following chapters with concept descriptions and detailed step-by-step
procedures focused on the task at hand.
Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide
and Preference guide. Some of them are explained here where necessary to the understanding of a given
concept or procedure.
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Chapter 1: Project Creation
Once Harmony Premium is installed, you are ready to start the application and animate! In this chapter, you will
learn about starting the application, as well as creating, opening and saving scenes
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About Harmony Stand Alone
Harmony Stand Alone allows you to create, open, save and manage scenes on your computer's file system.
Unlike Harmony Server, Harmony Stand Alone does not have a database system. Each scene you create is an
independent project, and you must organize your scenes yourself.
If you have a Harmony Server license, you can still choose to run Harmony in Stand Alone mode if you like.
However, if you have a Harmony Stand Alone license, you can only run Harmony in Stand Alone mode.
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Starting Harmony in Stand Alone Mode
T-HFND-001-002
You can run Harmony Premium from your operating system's desktop.
WARNING
On macOS, Harmony and its other applications will not run on the first time unless you right-click
on the application, then select Open. You will be prompted to confirm a security exception, which
will require administrative privileges.

How to start Harmony Stand Alone
1. Do one of the following:
l

Windows: Start > Programs > Harmony 15.0 Premium > Harmony Premium

l

macOS: Applications > Toon Boom Harmony 15.0 Premium > Harmony Premium

l

GNU/Linux: Applications > Toon Boom Harmony 15.0 Premium > Harmony Premium

The Harmony Premium application launches and displays a splash screen. After the splash screen:
l

If you have a Harmony Stand Alone license, the Welcome Screen will appear

l

If you have a Harmony Server license, the Log-In Screen will appear. You can proceed from
the Log-In Screen to the Welcome Screen by selecting Work Offline and clicking on the
OK button.

Once you are at the Welcome Screen, see About the Welcome Screen on page 44.
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About the Welcome Screen
T-HFND-001-003
When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display
the Welcome screen by selecting Help > Show Welcome Screen.
NOTE
If you are using Harmony Server in Database mode, the Welcome screen will not open. Instead, the
database selector will open and allow you to open a scene from the database.

The Welcome screen allows you to:
1. Create scenes
2. Choose your scene resolution
3. Manage your scene resolution presets
4. Quickly open recently opened scenes
5. Browse for and open a scene from your documents
6. Watch Harmony video tutorials
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7. Open the online support page
8. Decide to skip the Welcome screen and open Harmony directly on launch from now on
NOTE
To display the Welcome screen later on, go to the top menu and select Help > Show Welcome
Screen. You can enable showing the Welcome screen on launch again by unchecking the Do not
show this window on startup option.
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About Harmony Stand Alone Scenes
When working in production, it is important to keep your work organized. It is important to create a naming
convention chart and establish a file storage structure before starting the project. It is not only extremely
important that everyone follows the criteria laid out in the naming convention chart and the file storage
structure, but also that they understand the organization and where to find the files.
A well thought-out and logical naming convention will help keep your production structured and allow it to run
smoothly by preventing the loss of files due to chaotic organization.
In this section, you will learn how to create, open, organize, and name the different components in your
animation project.
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Creating Scenes in Harmony Stand Alone
T-HFND-001-005
All scenes created via Harmony Stand Alone are independent and local to the computer. You can create or
open a scene using the Welcome screen or the File menu.
If you are using Harmony Server, you must use the Control Center application to create your scenes before you
can open them in Harmony. Harmony Server scenes cannot be created directly in Harmony.

How to create a scene from the Welcome screen
1. In the Name field, type the scene’s name.

NOTE
The scene name should not exceed 23 characters and cannot contain special
characters, such as *&^%!.
2. To decide in which directory the scene will be created, click the Browse button next to the Location
field.

3. From the Camera Size menu, select a scene resolution.

4. Click on Create Scene.
A new scene is created.
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How to create a new scene from the File menu
1. Do one of the following:
l

From the top menu, select File > New.

l

In the File toolbar, click the New

l

Press Ctrl + N (Windows/Linux) or ⌘ + N (macOS).

button.

The New Scene dialog box opens.

2. In the Project Name field, type the scene's name.

3. Select a scene directory by clicking the Browse button.

NOTE
The scene name cannot exceed 23 characters and cannot contain special characters, such as
*&^%!.
4. In the Resolution window, select the scene’s resolution and click Create.
A new scene is created.

48

Chapter 1: Project Creation

Creating Custom Resolutions in Harmony Stand Alone
T-HFND-001-006
You can create your own custom resolution presets for your projects.

How to create a custom resolution
1. Create a new scene from the Welcome screen or from the File menu in Harmony.
2. Set the scene resolution by doing one of the following:
l

Select a scene resolution from the Camera sizes drop-down menu.

l

Set a custom resolution by changing the values in the Width and Height fields. This
preset will not be saved.
NOTE
The different editions of Harmony support the following maximum render
resolutions:

l

l

Harmony Essentials: 2K (2048x1556)

l

Harmony Advanced: 4K (4096x3112)

l

Harmony Premium: Unlimited

Add a new resolution to the list by clicking the Add

button. You can delete a

custom resolution from the Resolution list by selecting it, and clicking the Delete
button.
3. In the New Resolution dialog box, fill in the following fields and click Create.

l

Resolution Name: Name your new resolution.

l

Resolution: Set the width and height of the scene, in pixels.
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l

Field of View: Select how the angle of the field of view should be determined.
l

Horizontal Fit: The angle of the field of view is adjusted to the width of the
scene.

l

l

Vertical Fit: The angle of the field of view is adjusted to the height of the scene.

l

Custom Fov: Set the angle of the field of view to a custom value.

Frame Rate: Type in the amount of animation frames to play each second.
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Opening Scenes in Harmony Stand Alone
T-HFND-001-007
You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen
1. In the Recent Scenes section, click Open.
The Open Scene browser opens.
2. Browse and select an .xstage file.
3. Click Open.

How to open a scene from the File menu
1. Do one of the following:
l

From the top menu, select File > Open.

l

In the File toolbar, click the Browse

l

Press Ctrl + O (Windows/Linux) or ⌘ + O (macOS).

button.

The Open Scene browser opens.
2. Browse and select the desired .xstagefile.
3. Click Open.

How to open a recent scene from the Welcome screen
1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu
1. From the top menu, select File > Open Recent.
2. Select a scene from the displayed list.
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Setting the Scene Length in Harmony Stand Alone
T-HFND-001-009
Once you have opened your scene, you can set its length.

How to set the scene length
1. Select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.
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About Scene Settings in Harmony Stand Alone
T-HFND-001-010
When you created your scene, you set up the resolution and the alignment. However, if you want to change
these settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options are
separated into four tabs.
NOTE
Refer to the Scene Setting dialog box in the Reference guide to learn more about the individual
parameters of the Scene Settings dialog box.

How to access the Scene Settings dialog box
1. In the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
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About Saving in Harmony Stand Alone
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title
bar beside the scene name to indicate that the scene contains unsaved changes.
To save the current state of a scene as another scene, you can use the Save As command. The Save As window
prompts you to give a new name and choose a different location to this scene before saving it. This will create a
complete scene directory for the new scene. The Save As command is not available in Harmony Server.
It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or
parameters to see which one will work best. Harmony allows you to save several versions of the same scene.
You can also automatically save your work by enabling Auto-Save.
IMPORTANT
When a scene has several versions, the drawings and palettes are the same between all the
different scene versions. You can modify the timing, effects, parameters and camera motions in a
specific scene version, but if you make change to a drawing or a palette, the change will affect all
scene versions.
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Saving Scenes in Harmony Stand Alone
T-HFND-001-011
You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses
the same drawings in all versions.

How to save a scene
1. Do one of the following
l

In the top menu, select File > Save.

l

Press Ctrl + S (Windows/Linux) or ⌘ + S (macOS).
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Saving Scenes as Copies in Harmony Stand Alone
Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy
1. Select File > Save As.
2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene
a new name. The name cannot exceed 23 characters.
3. Click Save.
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Saving Scenes as New Versions in Harmony Stand Alone
Saving a new version of your scene allows you to save your scene at it's current location, under a new file name.

How to save a new version of a scene
1. Select File > Save As New Version.
The Save Version dialog box opens.
2. In the Save Version dialog box, type the new version name.
3. Click OK.
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Enabling Auto-Save in Harmony Stand Alone
T-ANIMPA-001-001
You can allow the software to automatically save your scene, as well as decide on the interval of time between
auto-saves.

How to auto-save a scene
1. Do one of the following:
l

Windows/Linux: Select Edit > Preferences.

l

macOS: Select Harmony Premium > Preferences.

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. Select the General tab.
3. In the Save section, set the Auto-Save parameters:
l

Interval (minutes): The frequency at which auto-save happens.

l

Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you
are drawing or doing anything in the application. Auto-save will not happen until you
have stopped using the application for this amount of seconds.

l

Ask Before Saving: Before performing an auto-save, you are prompted with a
message to confirm if you want to save or not.

l

Enabled: This enables the Auto-save feature. If you do not want the system to
automatically save your work, uncheck this option. Auto-save is off by default.
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About the File Structure in Harmony Stand Alone
T-HFND-001-008
A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the
files contained in the folder structure.
Here is an example of the file structure contained in a scene. As you work and use more features, different
folders may appear in your structure.

The Harmony scene folder contains the following folders:
Folder

Contents

annotation

Contains the images and thumbnails created while drawing in an Annotation
column in the Xsheet view.

audio

Contains all imported audio files.

elements

Contains all the drawing files. The drawings are organized by folders named like
the layers they are associated with.

environments

If the scene was exported from a Harmony Server database, this directory will
contain the palettes and templates that were stored in the scene's environment.
Otherwise, it is empty.

frames

Contains the final frames after a render if you are using the default settings of the
Write node in the Node view.
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jobs

If the scene was exported from a Harmony Server database, this directory will
contain the palettes and templates that were stored in the scene's job. Otherwise,
it is empty.

palette-library

Contains scene palettes and scene palette list files.

timings

This folder is used when a user links external images to a scene and wants to
store a backup copy in case the link breaks.
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About Harmony Server

Harmony can be used in database mode (online) via the server connection (Harmony Server) or as a standalone
application (offline).
Several animators can work simultaneously on the same project while the asset library provides users with easy
access to up-to-date media assets. Harmony is scalable; more than 100 staging clients can share animation just
as easily as a few can.
Harmony Server is the link between the client machines and the server. It lets you work on the different
projects stored in the central Harmony database.
At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository.
The server is compatible with Windows, GNU/Linux or macOS. To learn more, refer to the Control Center
Guide.
If you have a Harmony Server license, when you start Harmony, you can opt to either work offline in the
application as a standalone software, or connect to the database to work on projects via the database.
When working with Harmony Server, the scenes and their data are stored directly on the server. No data is
saved or stored on the client machine. The client machines access the database and load the scenes and
drawings directly from the server. Each time the user saves his scene, the data is updated directly on the
server. There are no upload or download operations (check-in, check-out) done between the server and the
clients.
NOTE
If you have a standalone license, you will not have access to the database. You will automatically
start the application in standalone mode.
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About the Database Structure in Harmony Server
Harmony Server has a client-server configuration linked through a network. Although the user is working on a
client machine, all of the data is saved on the server.
You can compare the Harmony Server structure to a filing cabinet. Every element is structured and follows a
strictly organized hierarchy.
The following production structure hierarchy is used:
l

Environment: Production, project, feature film, series—see Environment Structure on page 62

l

Job: Episode and sequence from each environment

l

Scene: Scene from each job

l

Element: Layers and columns from each scene

l

Drawing: Drawings from each element

If you imagine the environment as a filing cabinet containing all the folders and information, then the following
structure is used:
l

The job is a drawer in the filing cabinet containing all the folders related to the drawer’s topic.

l

The scenes are the folders contained in that drawer

l

The elements are the papers contained in the folder

l

The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so
nothing is lost. By adhering to this structure, every user working in the database always knows where to find
the scenes to work on.

Environment Structure
Before you create or save any elements in your production, you should decide upon a project name. This should
reflect the content or title. Use the name to create the project’s environment, where you will store all of your

62

Chapter 1: Project Creation

production elements.
For example, the environment could be called adventure_movie. An environment can be used for movies,
series, commercials, student work database, etc.
For a series, you can create an environment with the same name as the series, such as smith_family. Then
you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers
represent:
l

sm: The first two letters of the name smith

l

ep: Episode

l

001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can
create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require
splitting into episodes or sequences, you can group them all in the same environment.
For a database of student’s work, you can create an environment and name it with the class or group name,
such as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store
the different student exercises in separate scenes under their job name.

63

Harmony 15.0 Premium User Guide

About the Database File Structure in Harmony Server
ForHarmony Server, the scene files as well as user and configuration files are contained within the database
structure. If you want to share or archive a project, you will need to use Control Center to export your data from
the database. If you receive a package from another user or studio, you will also need to use Control Center to
import it in your database. Refer to the Control Center User Guide to learn how.
All Harmony Server directories are located at the root of your file system by default. On Windows, this is at the
root of the C:\ drive. On macOS and GNU/Linux, this is simply referred to as the root directory, or /.

/usa_db

The usa_db directory contains the file structure of the database server. This is
where all the information about the database structure is stored, including the
hierarchy of environment, jobs and scenes, their various settings, user profiles
and the location of the scene data on the network.

/usadata

The usadata directory is where all the scene data is actually stored. It is stored
in a different directory than the database structure to allow using different
machines to store the database and to store the scene data. There may be
several usadata folders, each followed by a number. This occurs when the
server is configured to store scene data on more than one data server, to
expand its storage space.

Although the hierarchy of a database starts with environments, inside which are jobs and inside which are
scenes, the environments and jobs in a Harmony Server database are stored in separate folders in /usa_db.
Hence, while browsing /usa_db, you cannot navigate from an environment to one of its jobs. You must go
directly to the jobs directory to find its content.
Inside a job directory, you will find one folder for each scene contained in the job. This is actually a shortcut that
points to the actual scene data folder of the scene, which is located to one of the /usadata folder for the
database.
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Starting Harmony in Server Mode
T-HFND-001-002
You can run Harmony Premium from your operating system's desktop.
WARNING
On macOS, Harmony and its other applications will not run on the first time unless you right-click
on the application, then select Open. You will be prompted to confirm a security exception, which
will require administrative privileges.

How to start Harmony
1. Do one of the following:
l

Windows: Start > Programs > Harmony 15.0 Premium > Harmony Premium

l

macOS: Applications > Toon Boom Harmony 15.0 Premium Network > Harmony Premium

l

GNU/Linux: Applications > Toon Boom Harmony 15.0 Premium > Harmony Premium

The Harmony Premium application launches and displays a splash screen. After the splash screen,
the log-in dialog box appears—see Connecting to the Database in Harmony Server on page 66.
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Connecting to the Database in Harmony Server
Before you can work in Harmony via Harmony Server, you must be connected to the Harmony database.

How to connect to the Harmony database
1. Start Harmony —see Starting Harmony in Server Mode.
2. In the log-in dialog, select the Connect to Database option.

3. In the User Name field, type in your Harmony username.
NOTE
This username should be provided to you by your project lead or system administrator.
4. Click on OK.
The Database Selector dialog box opens, displaying the environments available in Harmony
database.
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You can now navigate to a scene and open it—see Opening a Scene in Harmony Server.
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About Scenes in Harmony Server
In Harmony Server, you must use Control Center to create scenes. Then, you can open your scenes in Harmony
and configure them, set them up, create several versions and manage those versions.
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About Scene Creation in Harmony Server
When working in Harmony Server, you can only open and edit scenes that were already created. To create
scenes, you must use the Control Center module.
For documentation on how to use Control Center to create scenes, refer to the Control Center User Guide.
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Opening a Scene in Harmony Server
Once you are connected to the database in Harmony, you can open a scene in the database.

How to open a scene in Harmony Server
1. Connect to the database—see Connecting to the Database in Harmony Server on page 66.
The Database Selector appears when you log-in.

2. In the Environments column, select the scene's environment (project, movie, season).

3. In the Jobs column, select the scene's job (episode, sequence).
4. In the Scenes column, select the scene.
5. Get the permissions needed for this session by selecting one or several of the following options:
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l

Get rights to modify the scene: Allows you to modify the selected version of the scene as
well as to manage and overwrite other versions. Other users will not be able to open a
different version of the scene until you close the scene..

l

Get rights to modify the scene version: Allows you to modify the currently selected scene
version only. Unless the Get rights to modify the scene option is also checked, you will not be
able to change other versions of the scene. This allows other users to modify different
versions of the scene while you are working on the selected version.

l

Get rights to modify the scene assets: Automatically gets the rights to modify all of the
scene's assets, locking other users from making changes to them until you close the scene.
This means that you will have the rights to modify all the scene's versions, drawings,
palettes, its palette list, but not its library folder. If this option is unchecked, drawings and
palettes will be locked unless you unlock them manually. This can allow another user to work
on the scene's drawings and palettes in Harmony Paint while you are working on the scene's
timing or staging in Harmony.

6. Choose the version you want to open from the Version menu.

NOTE
The Saved By and Saved Date fields display the user who last saved the selected scene
and the date of the last save.

7. Click on Open.
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About Scene Settings in Harmony Server
When you create a scene in Harmony Server, its settings such as the scene resolution and framerate are set to
default values. You can change your scene's resolution, framerate, alignment and other settings using the
Scene Settings dialog.
NOTE
Refer to the Scene Setting dialog box in the Reference guide to learn more about the individual
parameters of the Scene Settings dialog box.

How to access the Scene Settings dialog box
1. In the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
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Setting the Scene Length in Harmony Server
How to set the scene length
1. Select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.
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About Saving and Scene Versions in Harmony Server
When you use Harmony Server and work in a scene on the database, there are many choices and options
available when you save your work. Specifically, the Advanced Save dialog lets you do the following:
l

Save the scene as the current version.

l

Save different versions representing different stages of the production of your scene.

l

Save different versions representing different scene setups.

l

Choose specific assets that you want to save, such as drawings or palettes.

When you open the scene from the database and select the version you want to edit, you can save the changes
you made in the current version or create a new version. The simplest way to save your work is to update the
current version.
You can delete any unnecessary versions using the Versions window.
When working with multiple versions, you may want to merge some of the changes from one version into
another. You may have created a version with some suggestions that you submitted to the director while
continuing to work on the official version. If the director has approved some of the changes, you can go ahead
and import them into the official version.
You might want to save some specific aspects of your scene or save a new version. The Advance Save feature
allows you to do this. Once you have chosen the components to save, you will conclude the procedure by
following the instructions in the section. All the specific components that are selected throughout the different
tabs of the Advanced Save dialog box will be saved.
You can also automatically save your work by enabling Auto-Save.
IMPORTANT
When a scene has several versions, the drawings and palettes are the same between all the
different scene versions. You can modify the timing, effects, parameters and camera motions in a
specific scene version, but if you make change to a drawing or a palette, the change will affect all
scene versions.
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Saving a Scene in Harmony Server
The first time you save a scene in Harmony Server, you will be prompted to create a first scene version. Once
the scene has at least one scene version, you can instantly save to that version every time you make changes to
your scene.

How to save the first version of a scene in Harmony Server
1. Make sure you have the necessary rights to save the current scene version. If you do not, you can
acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene in
the top menu.
2. Do one of the following:
l

In the top menu, select File > Save.

l

In the File toolbar, click on the

l

Press Ctrl + S (Windows/Linux) or ⌘ + S (macOS).

Save button.

When saving the scene for the first time, the Save dialog box opens, prompting you to name the
version.
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3. In the This Version field, enter a relevant name for the current version.

4. In the Description field, if you want, you can enter a short description of the current version.

5. Click on Save.
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Saving a New Scene Version in Harmony Server
You can save different versions of your scene and add descriptions to each version to keep track of the changes
made to a scene over time

How to save a new version of the scene in Harmony Server
1. Make sure that you have the necessary rights to save the current scene version. If you do not, you
can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify
Scene from the top menu.
2. From the top menu, select File > Advanced Save.
The Advanced Save dialog appears.

3. Make sure the Save option is checked.
4. Select the New Version option.
5. In the New Version field, enter a relevant name for the new version of your scene.
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6. In the Description field, if you want, you can enter a short description of the current version.

7. If you want the new version to be marked as the current scene version, make sure the Mark as
Current option is checked. This will make the version you are creating the default version of the
scene, when opening it.
8. Click on Save.
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Deleting Scene Versions in Harmony Server
View a list of the different versions of your scene, along with their corresponding description. Use this
information to delete various versions.

How to delete versions
1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene.
2. Select File > Manage Versions.
The Versions window opens.

3. In the Existing Versions list, select the scene version you want to delete. When a version is selected,
information about it appears in the Description area.
4. Click Delete.
The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone.

5. Click one of the following:
l

Yes: Only if you are absolutely certain that the version can be deleted.
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l

No: To cancel the operation and keep the version.
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Merging Scene Versions in Harmony Server
If you have two different versions of a scene that need to be brought together, you can merge them.

How to merge scene versions
1. From the top menu, select Edit > Open Merge Editor.
The Choose Scene Versions for Merge window opens.

2. In the Select Version to Merge Changes From list, select the scene version from which you want to
merge the changes from in your current open version.

In the Use Another Version for Reference section, you can select a different scene version to merge
the changes into, rather than your current version.
3. Click Load.
The Merge Editor opens.
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4. From the right column, select the layers you want to merge the changes from into the reference
version.
5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate from what
frame to what frame you want to take the changes from.
6. Click Merge Selected to complete the operation.
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Advanced Saving in Harmony Server
Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your
scene.

How to use the Advanced Save dialog box
1. Make sure that you have the necessary rights to save the current scene version. If you do not, you
can acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify
Scene from the top menu.
2. From the top menu, select File > Advanced Save.
The Advanced Save dialog appears.

For information on the parameters in the Advanced Save Dialog Box, refer to the Advanced Save
Dialog Box topic of the Reference guide.
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Enabling Auto-Save
You can allow the software to automatically save your scene, as well as decide on the interval of time between
auto-saves.

How to auto-save a scene
1. Do one of the following:
l

Windows/Linux: Select Edit > Preferences.

l

macOS: Select Harmony Premium > Preferences.

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. Select the General tab.
3. In the Save section, set the Auto-Save parameters:
l

Interval (minutes): The frequency at which auto-save happens.

l

Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you
are drawing or doing anything in the application. Auto-save will not happen until you
have stopped using the application for this amount of seconds.

l

Ask Before Saving: Before performing an auto-save, you are prompted with a
message to confirm if you want to save or not.

l

Enabled: This enables the Auto-save feature. If you do not want the system to
automatically save your work, uncheck this option. Auto-save is off by default.
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About the Scene File Structure in Harmony Server
A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the
files contained in the folder structure.
Here is an example of the file structure contained in a scene. As you work and use more features, different
folders may appear in your structure.

The Harmony scene folder contains the following folders:
Folder

Contents

annotation

Contains the images and thumbnails created while drawing in an Annotation
column in the Xsheet view.

audio

Contains all imported audio files.

database

This is no longer used for new projects. It remains for projects created with older
versions of the software.

elements

Contains all the drawing files. The drawings are organized by folders named like
the layers they are associated with.

frames

Contains the final frames after a render if you are using the default settings of the
Write node in the Node view.

palette-library

Contains scene palettes and scene palette list files.

stage

Contains one .stage file for each version of the scene.
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timings

This folder is used when a user links external images to a scene and wants to
store a backup copy in case the link breaks.
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About Global Lock in Harmony Server
Harmony Server has a lock system, referred to as Global Lock, for the different scenes and scene assets.
Because all the data on the server can be accessed directly and modified from any client machine by default,
the scenes are locked. You must obtain the rights to modify scenes in order to save your work on the server.
Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users can only
open the scene in read-only mode. They will not be able to save any modifications.
If you work in standalone mode, you automatically have the rights to modify all drawings and palettes.
Global Lock offers three levels which are available from the Database Selector when you log in to Harmony.
From there, you can select a scene and obtain the rights to modify it by selecting the desired lock option.

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked.
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked items.
If someone tries to open a locked scene, it will be displayed as read-only.
Here are the different lock possibilities:
Lock

Description

Scene or Version Lock

Controls the Xsheet timing, layers, nodes but not the drawing, palettes, palettelists or templates.

Drawing Lock

Only one user can edit and save a locked drawing.

Palette Lock

Only one user can edit and save a locked palette.

Palette-list Lock

Only one user can edit and save a locked palette-list.
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Library Folder lock

Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Center module.
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Acquiring Rights to Loaded Scenes in Harmony Server
If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire the
necessary rights without closing and reloading the scene.
Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This
process is done during the initial loading of the scene. To learn more about enabling the rights to modify while
creating environments, jobs and scenes, refer to the Control Center Guide.

How to set the scene's rights after the scene is loaded
1. In the top menu, select File and one of the following:
l

Rights to Modify Scene: Allows you to modify the selected version of the scene as well
as to manage and overwrite other versions. Other users will not be able to open a
different version of the scene until you close the scene.

l

Rights to Modify Scene Version: Allows you to modify the currently selected scene
version only. Unless the Get rights to modify the scene option is also checked, you
will not be able to change other versions of the scene. This allows other users to
modify different versions of the scene while you are working on the selected
version.
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About Drawing Lock in Harmony Server
The drawings are stored on the server database providing access to them from every client machine. They are
locked to avoid different users from modifying the same drawings simultaneously. Only one person at a time
can get the rights to modify them. The drawing rights are independent from the scene rights because in a
production rush, two users may need to work on the same scene to finish painting the drawings faster. One
user will get the rights for one set of drawings, and the second user the rights to another set of drawings. This
prevents work from being duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new
drawings by drawing directly on an empty cell. This mode is enabled by default when you open a scene version
with the rights enabled.
NOTE
If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing
mode is not available.
When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a
selection of specific drawings. This is useful when, for example, many users are working on the same scene
during the ink and paint process and they want to split the drawings to paint between them.
Also, once you got the rights to modify drawings, you can release these rights if necessary.
If your system crashes and the drawings remain locked, you can force the release of the rights. You must use
this option carefully as data loss may occur if the scene is currently open and being edited by another person.
Verify that no one else is using the scene prior to forcing the release of the drawing rights.
Since the drawings are stored on the server, you might at times need to refresh the drawings that are
displayed in your scene.
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Locking & Unlocking Drawings in Harmony Server
You can acquire and release the rights to modify drawings when working with Harmony Server.

How to enable the Edit Drawing Mode
l

From the top menu, select Edit > Edit Drawing Mode.

How to get the rights on a selection of drawings
1. Make sure that the Edit Drawing Mode is disabled.
2. In the Xsheet view, select the drawings you want to edit.
3. Select Edit > Get Rights to Modify Drawings or press Alt + L.

How to release the rights on a selection of drawings
1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Release Rights to Modify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings
1. In the Xsheet view, select the drawings you want to release.
2. Select Edit > Force Release Rights to Modify Drawings.
A Warning dialog box opens.
l

Click Yes if you want to continue to force the release.

l

Click No if you want to cancel the force release.

How to read changed drawings
l

Select File > Read Changed Drawings.
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Verifying a Scene's Integrity
The Check Files commandVerifies the integrity of the drawing and palette files in your project. Use the Check
Files dialog box to verify that the data is consistent, correct, and accessible.

How to open the Check Files dialog box
1. From the top menu, select Scene > Check Files.

2. Click Check Colours to open the Check Colours dialog box.
The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Chapter 2: Interface
T-HFND-003-001
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your
workspace conveniently. There are a series of views and toolbars you can use as you perform different
operations. Usually, each person has a specific way of working in the interface and prefer particular views and
toolbars. In this chapter, you will learn about the main elements of the interface and how to manage them.
NOTE
To learn more about each view's properties, see the Reference guide.
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme
1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium >
Preferences (macOS) .
The Preferences dialog box opens.
2. Select the General tab.
3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.
4. Restart Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. Harmony will automatically change to you
OS language if it corresponds to one of these four languages. If you would like to start Harmony in one of those
language independently from your OS, you can do so by launching it from a command prompt terminal with a
parameter that specifies the desired language.

How to start Harmony using a specific user interface language
1. Start a termninal, command prompt, or shell on your OS.
2. Using the change drive command (cd), navigate to the Harmony executable file location:
l

l

l

l

Windows: cd "C:\Program Files
(x86)\Toon Boom Animation\Toon Boom Harmony 15.0 Premium\win64\bin"
macOS (Stand Alone): cd "/Applications/Toon Boom Harmony 15.0
Premium/tba/macosx/bin"
macOS (Server): cd "/Applications/Toon Boom Harmony 15.0 Premium
Network/tba/macosx/bin"
GNU/Linux: cd /usr/local/ToonBoomAnimation/harmonyPremium_15.0/lnx86_
64/bin

3. To start Harmony in a specific language, type in the name of the Harmony application including the
language argument (-lang) and language code (two letters):
l

l

Windows:
l

English: HarmonyPremium.exe -lang en

l

Chinese: HarmonyPremium.exe -lang zh

l

Japanese: HarmonyPremium.exe -lang ja

l

Spanish: HarmonyPremium.exe -lang es

macOS:
l

English: ./Harmony\ Premium -lang en

l

Chinese: ./Harmony\ Premium -lang zh

l

Japanese: ./Harmony\ Premium -lang ja

l

Spanish: ./Harmony\ Premium -lang es
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l

GNU/Linux:
l

English: ./HarmonyPremium -lang en

l

Chinese: ./HarmonyPremium -lang zh

l

Japanese: ./HarmonyPremium -lang ja

l

Spanish: ./HarmonyPremium -lang es

4. Press Enter/Return to validate and launch Harmony in the desired language.
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About Menus
T-HFND-003-002
Harmony contains three types of menus from which you can access many commands and options:

Top Menu
The top menu contains most of the commands. Depending on the view you're working in and the element,
some commands are available and others are not. The top menu is always located at the very top of the
interface.

The top menu contains the following categories:
l

File

l

Edit

l

View

l

Play

l

Insert

l

Scene

l

Drawing

l

Animation

l

Windows

l

Help

On macOS, there is also a Harmony Premium category that contains the following commands:
l

Preferences

l

About

l

Quit

View Menu
A view menu contains commands specifically related to that view.
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To access a view menu, click the Menu

button in the top-left corner of a view.

A view menu is available in the following views:
l

Camera

l

Colour

l

Drawing

l

Function

l

Library

l

Model

l

Node Library

l

Node

l

Perspective

l

Script Editor

l

Side

l

Timeline

l

Top

l

Xsheet

Quick Access Menu
A quick access menu lets you open a list of the commands you will use most often.
To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003
Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also
have their own toolbars which you can move around. You can reposition the toolbars to suit your work style or
hide unused ones.
You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the
views that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu
updates.
The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move
from the top area to the view.
The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog
box, you can organize different toolbars to suit your working style.
If the default toolbar does not contain the tools you require, you can customize the toolbar.
If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to expand
the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to close
Harmony and restart it for the new interface to be displayed. A default set of tools will appear in the toolbar.
However, you can customize the toolbar with the tools that more closely fit your work pattern.

Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means
that you can change the default set of tools and replace the tools you use less frequently with ones use more
often. This customizing is done through the Toolbar Manager.
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Adding Toolbars
T-HFND-003-004
You can add toolbars simply by using menus.

How to add or close a toolbar
1. Select Windows > Toolbars > toolbar.
l

You can right-click anywhere in the toolbar area to access Harmony toolbars. View
toolbars, however, are not available by right-clicking the toolbar area. You can access
the toolbar of any open and active view by right-clicking in the view's top area or the
Windows menu.
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Moving Toolbars
T-HFND-003-005
You can move toolbars simply by dragging them to a new location.

How to move a toolbar
1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar
area or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse
button and drop the toolbar into position.
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Resizing Toolbars
T-HFND-003-006
You can resize a toolbar by sliding its tail-end.

How to resize a toolbar
1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.
2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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Customizing View Toolbars
T-HFND-003-007
You can customize a view toolbar to add, remove, and reorder icons.

How to customize a view toolbar
1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a
new button. You can also reorder the buttons. Make sure the button you right-click on is active.
2. From the menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click
the Right Arrow

button to switch it to the Toolbar list.

104

Chapter 2: Interface

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left
Arrow

button to switch to the Available Tools list.

5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click
the Up

or Down

buttons to move it to the correct location.

6. Click OK when you are finished.
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Enabling the Flat Toolbar
Delete this text and replace it with your own content.

How to use enable the Flat Tool Toolbar preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium >
Preferences (macOS).
2. In the Preferences dialog box, select the General tab.
3. Select the Flat Tool Toolbar option.
4. Click OK.
5. Save your work and close Harmony.
6. Restart Harmony.
The Tools toolbar no longer contains nested tools.
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About Views
T-HFND-003-008
The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a
view.
When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing
or other type of selection or the option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application, unless you disable the
Automatically Save Workspace option in the Preferences dialog box.
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Adding Views
T-HFND-003-009
You can easily add views through the top menu or each view.

How to add a view to your workspace as a tab
1. In the top-right corner of an existing view, click the Add View

button

2. Select the desired view from the list.
The view appears as a new tab in the same section of your workspace:
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NOTE
Some views, such as the Camera, Perspective, Library, Model and Node views, can be opened
in multiple instances. For example, this can be useful if you want to have two instances of the
Camera views open, each focused on different areas of your scene, to quickly switch between
working on these two areas.

How to add a view to your workspace as a window
1. Open the Windows menu.
2. Select the view you wish to add.
The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace
1. Drag a window by its tab and do one of the following:
l

Drop the window onto other existing tabs to add it to that set of tabs.

l

Drop the window above, below or beside an existing view. When you get close to the
edge of a view, a black rectangle with a blue background appears, indicating where
the view will be inserted.
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NOTE
The view in which you are currently working will have a red square surrounding it, marking is as
your active view.
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Closing Views
T-HFND-003-010
You can close one or multiple views by using their closing button.

How to close a view
1. Click the Close View

button.

If there are several tabs in the same view, press Shift and click the Close View
tabs at the same time.
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Showing and Hiding Views
T-HFND-003-012
You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view
1. On the edge of the window you want to hide, click the Collapse/Expand button.
The view is compressed and only the Collapse/Expand button is visible.
2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011
You can move views by dragging their name tab to a new location.

How to move views
1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s
tab.
2. When a blue rectangle outline appears showing an available location for the view, release the tab to
drop the view into position. One of three things will happen:

l

The view becomes a tabbed view.

l

The view becomes a floating window.

l

The view becomes a new docked view.
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Resizing Views
T-HFND-003-013
You can resize a view by sliding its edges.

How to resize a view
1. Place the pointer on the edge of the view to resize.
2. When you see the Resizing

icon, drag the side of the view to the desired size.
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About Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences
dialog box to set parameters and options.
NOTE
To learn about the different preferences available, refer to the Preferences Guide.

When using Harmony Stand Alone, your custom preferences are stored in the following location, depending on
your operating system:
l

Windows: C:\Users\[user_name]\AppData\Roaming\Toon Boom Animation\Toon Boom [Harmony
Premium\full-1500-pref
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NOTE
On Windows, the AppData folder is hidden. To display it in Explorer, in the top menu, open
the View pane and check the Hidden Items checkbox.

l

macOS: /Users/[user_name]/Library/Preferences/Toon Boom Animation/Toon Boom [Harmony
Premium/full-1500-pref
NOTE
On macOS, the Library folder is hidden. To display it in Finder, hold down the Alt key.

l

GNU/Linux: /home/[user_name]/Toon Boom Animation/Toon Boom [Harmony Premium/full-1500-pref/

When using Harmony Server, preferences are stored in your Harmony Server account's user space on the
database server, in the following path:
l

/USA_DB/users/[user_name]/Harmony Premium/full-1500-pref

How to open the Preferences dialog box
1. Do one of the following:
l

Windows or GNU/Linux: In the top menu, select Edit > Preferences.

l

macOS: In the top menu, select Harmony Premium > Preferences.

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).
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About Workspaces
T-HFND-003-014
The Harmony interface is composed of several views. You can customize your workspace to suit your working
style, save it as a new workspace, and load it from the Workspace toolbar.
The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can
access these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your
workspaces as they are and only save the modifications when you really want to, you must disable the
Automatically Save Workspace option.
The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can
save your workspace as a new version to avoid over-writing the current one. If you do not want to modify the
current workspace, use the Workspace Manager to create another one and then modify that one.
Your customized preferences are stored in the following location and you can save them to either share with
someone else, copy to a second computer or simply back them up.
When working with Harmony Stand Alone, your custom workspaces are stored in:
l

l

l

Windows: C:\Users\[username]\AppData\Preferences\Toon Boom Animation\Toon
BoomHarmony Premium\1500-layouts-xml
macOS: /Users/[username]/Library/Preferences/Toon Boom Animation/Toon Boom
Harmony Premium/1500-layouts-xml
GNU/Linux: /home/[username]/Toon Boom Animation/Toon Boom Harmony
Premium/1500-layouts-xml

When working with Harmony Server, you workspaces are stored in:
/USA_DB/users/Harmony Premium/1500-layouts-xml
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Loading Workspaces
T-HFND-003-015
You can load an existing workspace from the drop-down menu.

How to load a workspace
1. Do one of the following:
l

Select Windows > Workspace > Workspace.

l

Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016
You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click the Add

button to add a workspace.

4. Select the new workspace that was created. Click Rename and give it a new name.
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5. Select the new workspace and click the Right Arrow
toolbar.

6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. Choose the workspace to be renamed from the list.
3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit
the name.

4. Type in the new name of the workspace.
5. Press the Enter/Return key to validate the name.
6. Click OK.
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Saving Workspaces
T-HFND-003-017
You can either save your workspaces automatically or manually.

How to save your workspace as a new version
1. From the top menu, select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.
2. Type in a workspace name and click OK.

How to disable the Automatically Save Workspace preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium >
Preferences (macOS) to open the Preferences dialog box.
2. Select the General tab.
3. In the Options section, deselect the Automatically Save Workspace option.
4. Click OK.
The Save Workspace

button appears in the Workspace toolbar.

How to save a workspace manually
1. Do one of the following:
l

In the Workspace toolbar, click the Save Workspace

l

You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow

button

to move it to the Available Workspaces list.

3. Select the workspace from the Available Workspaces list, then click the Delete
the workspace.
4. Click OK.
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Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow
button to move it to the Workspace toolbar.
3. Click OK.

How to hide a workspace
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow
to move it to the Available Workspaces list.
3. Click OK.
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces
1. Do one of the following:
l

In the Workspace toolbar, click the

button.

l

From the top menu, select Windows > Workspace > Workspace Manager.

2. In the Workspace toolbar, select the workspace to be reordered and on the Up
buttons to move it up or down.

3. Click OK.
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Restoring the Default Workspace
T-HFND-003-018
You can restore modified workspaces to their original layout.

How to restore the default workspaces
l

Select Windows > Restore Default Workspace.
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About Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the
interface.
The navigation commands in the table below can be used in the following views, with some exceptions:
l

Camera

l

Drawing

l

Perspective

l

Timeline

l

Xsheet

l

Node View

l

Function

l

Side and Top

l

Model

Command

Action

Access Methods
View > Zoom In

Zoom In

Press 2

Zooms in the view.

Roll the mouse wheel up (except in
the Timeline and Xsheet views)
View > Zoom Out
Zoom Out

Press 1

Zooms out the view.

Roll the mouse wheel down (except
in the Timeline and Xsheet views)
Roll the middle mouse button up or
down.

Zoom In
or Out

Zooms in or out of the view.

Pan

Moves the view horizontally or vertically.

Hold down the Spacebar and the
middle mouse button while dragging
the mouse up or down.
Hold down the Spacebar and drag in
the direction you want to pan the
view.
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View > Reset Pan

Reset Pan

Resets the view’s pan to its default position.

Reset
View

Resets the view to its default position.

Reset
Rotation

Resets the view’s rotation to its default position.

Reset
Zoom

Resets the view’s zoom to its default position.

View > Reset Zoom

Rotate
View

Rotates the view.

Press Ctrl + Alt (Windows/Linux) or
Ctrl + ⌘ (macOS) and drag in the
direction you want to rotate the view.

Rotate 30
CW

Rotates the Camera view 30 degrees clockwise, like an
animation table.

View > Rotate View CW

Rotate 30

Rotates the Camera view 30 degrees counter-clockwise,

CCW

like an animation table.

Toggle
Quick
Close-up

Instantly multiplies the view's Zoom Factor by 4. For
example, if the Camera View's Zoom Factor is at 100%,
this will make it toggle between 400% and 100%.

Press Shift + N
View > Reset View
Press Shift + M
View > Reset Rotation
Press Shift + X

View > Rotate View CCW

Shift + Z

Cycles through the following display modes:
l

Toggle
Full
Screen

l

l

Normal Full-Screen: The main application
window becomes full screen.
View Full-Screen: The selected view becomes full
screen and all other views are collapsed.
Normal: The main application window is restored
to its original size and collapsed views are
expanded.
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Using the Play Menu to Navigate
From the top menu, you can select any of the following commands from the Play menu to navigate around the
interface.
Command

Description

Start Frame

Lets you set the frame on which playback will start.

End Frame

Lets you set the frame on which playback will end.

First Frame

Jump to the first frame. You can also press <.

Previous Frame

Jumps to the frame before the frame currently selected in the Timeline view. You
can also press the comma (,) key.

Next Frame

Jumps to the frame after the currently selected frame in the Timeline view. You can
also press the period (.) key.

Last Frame

Jumps to the last frame. You can also press >.
Opens the Go to Frame window in which you can enter the number of the frame
you want to display.

Go to Frame

You can also use the Go button, which you can add to the Timeline toolbar
through the Toolbar Manager. Open the Go to Frame dialog box and enter the
frame number to jump to.

Enable Playback

Plays back your animation from the Top, Side, or Perspective views.
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony.
The documentation of features and procedures exists online, but you can access it through the software.
A simple, but fast way to find a description of certain menu items and preferences is through the Integrated
Help.
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Accessing the Documentation
T-HFND-001-004
The Harmony documentation can be accessed from the Help menu.

How to access the Harmony Premium documentation
1. From the top menu, select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in
the Preferences panel, use the Integrated Help.
If you keep the Integrated Help window open for the entire duration of your work session, then you can use the
forward and backward arrows to scroll through a history of the help information that you called up during your
session.

How to use the Integrated Help with Menu Items
1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘ + / on macOS.
The Integrated Help window appears.

2. In the top menu, click on a menu heading to display its contents.
3. Use your mouse to hover over a menu item.

4. Press F1 on Windows/Linux or ⌘ + / on macOS.
In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences
1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘ + / on macOS.
The Integrated Help window appears.

2. In the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (macOS).
The Preferences window appears.
3. In the Preferences window, use your mouse to hover over a preference.

4. Press F1 on Windows/Linux or ⌘ + / on macOS.
In the Integrated Help window, a description of the preference appears.
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How to scroll through the bank of searched items
l

In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE
The moment you close the Integrated Help window all searched items will be erased from the
memory bank. In order to keep an on-going record of all the search requests made, you must keep
the window open.
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Chapter 3: Drawing
Harmony has many powerful tools, views, and features for sketching, drawing and animating with ease. This
chapter describes the main assets needed when drawing , as well as tips on how to start and use these tools
efficiently.
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About Drawing Tools
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and
styles.
Here are the drawing tools available in Harmony, followed by the types of layer on which they are supported. If
you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap layer,
some tools are not available. When tools are not available, they are grayed out in the Tools toolbar.
Icon

Tool Name

Vector Layer

Bitmap Layer

•

•

Cutter

•

•

Reposition All Drawings

•

Select

Contour Editor

•

Centerline Editor

•

Pencil Editor

•

Smooth Editor

•

Perspective

•

Envelope

Edit Gradient/Texture

•

Brush

•
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Pencil

•

Text

•

•

Eraser

•

•

Paint

•

•

Ink

•

Paint Unpainted

•

Repaint

•

Unpaint

•

Stroke

•

Close Gap

•

Line

•

•

•

•

Rectangle

•

•

Ellipse

•

•

Polyline

•

Dropper

•
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Each drawing tool has a series of options to customize its behaviour and drawing style. When you select a tool,
the Tool Properties view displays the properties of the currently selected tool, where you can configure your
drawing tool's behavior and style, if applicable.
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About the Brush Tool
T-HFND-004-003
The Brush tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it
was created with a paint brush.
With the Brush tool, you can draw solid vector strokes or textured bitmap strokes, depending on your brush
properties. Solid vector brush strokes are made of a vector shape filled with a solid colour, making them limited
in terms of art style, but lightweight and easy to manage. Textured brush strokes can have a bitmap brush tip,
a bitmap paper texture, and various settings such as hardness, randomness, antialiasing and transparency.
Hence, they can be used to draw in various art styles, add natural-looking details to your drawing and
reproduce the feel of a real brush stroke.
When drawing on vector layers, you can use the Select Tool, Contour Editor, Smooth Editor, Perspective and
Envelope tool to scale your brush strokes or to tweak their shape. If your strokes contain a bitmap texture,
Harmony will scale or deform the texture to fit the new shape of your brush. If your brush is scaled up or
deformed in a way that takes more volume, Harmony will automatically generate new pixels for the textures,
which might cause them to lose quality.
On vector layers, textured vector brush strokes are composed of a greyscale bitmap mask applied to their
colour. Hence, their colour can be repainted or updated as easily as with solid vector brush strokes. Changing
the colour used to paint a textured vector brush stroke from the colour palette will update the colour in textured
vector brush stroke, as it would with solid vector brush strokes, all the while preserving its texture.
You can also create dynamic brushes, which allow you to use artwork created in Harmony as if it was a brush tip
or a stamp.
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Drawing with the Brush Tool
T-HFND-004-003A
In the Camera or Drawing view, you can draw on any drawing layer type with the Brush tool.

How to draw with the Brush tool on a vector layer
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. In the Tool Properties view, set the Maximum Size to the desired brush size.
NOTE
If you are drawing with a mouse, your strokes will always be at their maximum size. If you are
using a pressure-sensitive tablet, your strokes will vary in size depending on the pressure of
your pen, ranging between 25% to 100% of the maximum size.
4. In the Colour view, click a colour swatch to select a colour.

5. In the Drawing or Camera view, start drawing.

How to draw with the Brush tool on a bitmap layer
1. In the Timeline view, add a bitmap drawing layer.
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. In the Tool Properties view, set the Maximum Size to the desired brush size. If you are drawing with
a mouse, your strokes will always be at their maximum size. If you are using a pressure-sensitive
tablet, your strokes will vary in size depending on the pressure of your pen, ranging between 25%
to 100% of the maximum size by default.
4. In the Colour view, select a colour.
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5. If you would prefer using Red/Green/Blue sliders, you can switch between HSV and RGB sliders by
doing one of the following:
l

Select Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders.

l

Right-click on the colour sliders and select RGB Sliders or HSV Sliders.

NOTE
Although you can use colours from your colour palette to paint on a bitmap layer, colours
used in a bitmap drawing layer are not linked to their colour swatch in the palette. This
means that, contrary to vector drawing, updating the colours in your colour palette will
not update your bitmap drawings with the new colours.
6. In the Camera or Drawing view, start drawing.
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NOTE
You can hold Ctrl (Windows/Linux) or ⌘ (macOS) while drawing to force your stroke to be a closed
shape. This will automatically draw a straight line between the beginning and the end of your
stroke.
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Creating a Solid Brush
T-ANIMPA-002-001A
When drawing with the Brush tool on a vector layer, you can use either solid vector brushes or textured vector
brushes. By default, your brush will be a solid vector brush. A solid vector brush creates a vector shape and
simply fills it with the selected colour, making lightweight, simple crisp strokes.
A solid vector brush's tip can be shaped like a circle, a diamond or a square, and can be configured to have a
specific size, aspect ratio and angle. Also, solid vector brushes can be automatically smoothed by Harmony as
you draw.
If you are drawing on a bitmap layer, you can only use textured brushes. You can create a textured brush that
makes solid looking strokes, but they can not be automatically smoothed by Harmony, nor can they tweaked
with vector tools such as the Contour Editor. For more information, see About Vector and Bitmap Layers on
page 376.

How to create a solid vector brush
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

The Brush Properties dialog opens.
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1. In the Brush Type dropdown list, select Solid Vector.
2. In the brush tip list, select either Circle, Diamond or Square.
3. Use the Maximum Size slider to set the maximum size of your brush tip.
NOTE
When drawing with a mouse, your brush is always at its maximum size. When drawing
with a pressure-sensitive pen tablet, your brush's size will range between its minimum
and maximum size, depending on the amount of pressure you put on the pen when
drawing.
4. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your
brush when using your pen with very little pressure. The minimum size is set to a percentage of your
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to
affect the brush size, set this parameter to 100%.
5. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush
tip vertically all the while preserving its horizontal size.
6. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.
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7. Click on the Smoothing tab.

8. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's direction, curves and corners. A higher setting will prevent your line from being shaky,
but is liable to reduce your drawing precision and to round sharp corners into curves.
9. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control
points for the resulting vector shape.
10. Either close or set aside the Brush Properties dialog.
11. In the Camera or Drawing view, start drawing to test your brush settings.
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Creating a Textured Brush
T-LAY-001-004
Using textured brushes, you can create an infinite range of fuzzy, textured and watercolour lines. You can use
bitmap brush tips, adjust your line's hardness and opacity, combine two tips and apply a paper texture to your
brush strokes so as to adapt the Brush tool to a variety of art styles and create natural-looking brush strokes.
When drawing on a vector layer, brushes are solid vector brushes by default. You can however create a
textured vector brush which combines both Harmony's vector and bitmap drawing capabilities. You can tweak
textured vector brush strokes using various vector editing tools such as the Contour Editor, the Smooth Editor,
the Perspective and the Envelope tools, and Harmony will resample the textures inside your brush strokes with
each modification.
If you are drawing on a bitmap layer, your brush is always textured. You can configure a textured brush to look
crisp and solid if desired, but brush strokes on a bitmap layer cannot be tweaked or smoothed.
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Configuring a Textured Brush Tip
T-ANIMPA-002-002
The Brush tool supports two types of brush tips: Solid and Textured. Solid brush tips are plain shapes that can
be used to draw vector shapes filled with a solid color, whereas textured brush tips are bitmap images with
various shapes and opacity levels that can be used to create natural-looking brush strokes.

Solid brush tips are not customizable. The selection is limited to either a circle, diamond or square-shaped brush
tip, the proportions and angle of which can be adjusted. While Harmony also comes bundled with preset
textured brush tips, it is also possible to create and use your own textured brush tips.

How to configure a textured brush tip
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
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4. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see
Adding a Brush Tip on page 150.
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5. Use the Maximum Size slider to set the maximum size of your brush tip.
NOTE
When drawing with a mouse, your brush is always at its maximum size. When drawing
with a pressure-sensitive pen tablet, your brush's size will range between its minimum
and maximum size, depending on the amount of pressure you put on the pen when
drawing.
6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your
brush when using your pen with very little pressure. The minimum size is set to a percentage of your
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to
affect the brush size, set this parameter to 100%.
7. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush
tip vertically all the while preserving its horizontal size.
8. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.
9. Use the Hardness slider to set how much of the outer part of your brush tip should fade to
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush
will only be opaque in its center, and will gradually become transparent towards its edges.
10. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints
the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip has
been stamped repeatedly over your canvas instead of dragged on it.
11. If you want the size of your brush tip to vary each time it's printed on your canvas, set the
Random Size setting to any value above 0 %.
12. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set
the Random Angle setting to any value above 0 °.
13. If you want the spacing between each instance of the brush tip to be random, set the Random
Spacing setting to any value above 0 %.
14. If you want the spacing between each instance of the brush tip to be random, set the Random
Spacing setting to any value above 0 %.
15. In the Camera or Drawing view, start drawing to test your brush settings.
It is also possible to use textures when drawing with the Pencil tool. Those textures follow the angle of your
pencil lines, which may create more interesting results depending on your desired drawing style. For more
information, see About Pencil Line Textures on page 199.
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Adding a Brush Tip

In the Brush or Eraser Properties dialog, you will find a set of default brush tips which are bundled
with Harmony, but you can also create your own brush tips, then export your collection or import an existing
set.
To make your own brush tip, you must first create an image file containing the brush tip, either in Harmony or in
a third party software, like Adobe Photoshop, then import it into Harmony. A brush tip must be a greyscale
image. Colors in brush tips are not acknowledged by Harmony, as brush tips only use the colour you are
painting with in Harmony. Your brush tip should also not contain transparency, as Harmony determines the
brush tip's transparency based on its black, white and grey levels. Its black parts will appear 100% opaque, its
white parts will appear 100% transparent, and its grey parts will appear semitransparent.
You can import brush tips in any image format supported by Harmony. It is recommended to create brush tips
in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.
Brush tips are shared between the brush tool and the eraser tool. Like paper textures and brush presets, paper
textures are saved in your preferences. You can also export your brush tips into an .xml file, and import them
on a different workstation, allowing you to share your brush tips between the different people collaborating on
your project.

How to add a brush tip
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
eraser tool.
4. Do one of the following:
l

Click on the Paper Texture menu icon

l

Click the Add Paper Texture button.

and select Add.
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5. In the file browser window, navigate to the location of your texture image file and select it.
6. Click Open to import the file into the Paper Texture library.
By default, an imported texture is given the name of the image file.
Renaming Brush Tips

You can rename your bitmap brush tips to keep your list organized.

How to rename a brush tip
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
eraser tool.
4. Select the brush tip you wish to rename.
5. Click on the Paper Texture menu icon

and select Rename.

6. In the Rename dialog box that appears, type in the new name of the brush tip.
7. Click OK.
Deleting Brush Tips

You can delete unnecessary brush tips to keep your list organized.

How to delete a brush tip
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
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eraser tool.
4. Select the brush tip you wish to delete.
5. Do one of the following:
l

Click on the Paper Texture menu icon

l

Click the Delete

and select Delete.

button.

NOTE
You can delete any brush tip in the Paper Texture library, including the default paper textures,
except for the three solid brush tips: Circle, Diamond and Square. Also, brush tips will not get
deleted if they are used in a brush preset.

Exporting Brush Tips

You can export brush tips to share, backup or install on a new computer.

How to export brush tips
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
eraser tool.
4. Click on the Paper Texture menu icon

and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured
brush tips and your paper textures.
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5. By default, both your brush tips and your paper textures are selected for export. If you only wish to
export your brush tips, uncheck the Select Paper Textures option.
6. Click Export.
7. In the Export Textures window that appears, browse to a location where you want save the .xml
file and give it a name.
8. Click Save.
Importing Brush Tips

You can import Harmony brush tips you previously exported.

How to import brush tips
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.
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3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
eraser tool.
4. Click on the Paper Texture menu icon

and select Import.

5. In the browser window that appears, navigate to and select the .xml file in which you exported
your brush tips.
6. Click Open.
In the Import Tips and Textures dialog box appears.

7. If the selected .xml file also contains paper textures, they will be selected for import along with the
brush tips by default. If you wish to only import the paper textures, uncheck the Select Paper
Textures option.
8. Click Import.
The imported brush tips appear in the Brush Tips Library.
Changing the Brush Tip Display

You can display your preset list as thumbnails or a list.
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How to change the Brush Tips thumbnail display
1. In the Tools toolbar, select the Brush

or Eraser

tool.

2. In the Tool Properties view, click the arrow button to open the Brush/Eraser Properties dialog.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector if you are using the
brush tool or the Eraser Type to Textured Eraser or Textured, Preserve Vector if you are using the
eraser tool.
1. Click on the Brush Tips menu icon

.

2. Select one of the following options:
l

Small Thumbnail: Displays brush tips in a grid of small thumbnails.

l

Large Thumbnail: Displays brush tips in a grid of large thumbnails with their name.
The default view setting.

l

List View: Displays brush tips in a list, with their name on the left and their texture on
the right of each row.
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Configuring Smoothing for a Textured Brush
T-ANIMPA-002-003
If you are drawing on a vector layer, the Brush Properties dialog will have a Smoothing tab, which allows to
configure how Harmony automatically smooths your brush strokes. If you are drawing on a bitmap layer, this
topic is not applicable, as bitmap layers do not support automatic smoothing.

How to configure a textured brush's smoothing
1. In the Brush Properties dialog, open the Smoothing tab.

2. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's direction, curves and corners. A higher setting will prevent your line from being shaky,
but is liable to reduce your drawing precision and to round sharp corners into curves.
3. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control
points for the resulting vector shape.
4. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring Antialiasing and Transparency for a Textured Brush
A textured brush can be either antialiased or not antialiased. Without antialiasing, your brush strokes will only
create fully opaque artwork. With antialiasing enabled, you also have the option to set the flow and opacity of
your brush, allowing you to simulate the effect of inks and paints with various consistencies.
NOTE
If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set
to Textured Vector Brush to enable the textured brush options.

How to configure a brush's antialiasing and transparency settings
1. In the Brush Properties dialog, open the Transparency tab.

2. If you want your brush to have antialiasing or transparency, enable the Antialiasing option.
NOTE
If the Antialiasing option is disabled, all Transparency settings will be disabled, and your
brush will only create fully opaque artwork.
3. Use the Maximum Flow slider to set the consistency of your brush strokes. A lower flow will make
your stroke more transparent towards the extremities and more opaque in its center, whereas a
higher flow will make your stroke consistently opaque.
4. If you are using a pressure-sensitive pen tablet, use the Minimum Flow slider to set the percentage
of the maximum flow that you want your brush to use when using your pen with very little pressure.
If you don't want the pressure on your pen to affect the flow, set this parameter to 100%.
5. Use the Maximum Opacity slider to set the maximum opacity of your brush strokes.
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6. If you are using a pressure-sensitive pen tablet, use the Minimum Opacity slider to set the
percentage of the maximum opacity that you want your brush to use when using your pen with very
little pressure. If you don't want the pressure on your pen to affect the opacity, set this parameter to
100%.
7. If you want the Flow of your brush to be randomized, set the Random Flow setting to any value over
0 %.
8. If you want the Opacity of your brush to be randomized, set the Random Opacity setting to any
value over 0 %.
9. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring a Textured Brush with a Dual Tip
Textured brushes can also have a dual tip. A dual tip is a secondary tip that can be blended into your primary
tip in various blend modes, with its own full set of tip settings.
NOTE
If you are working on a vector layer, make sure the Brush Type option in the Tip tab is set
to Textured Vector Brush to enable the textured brush options.

How to configure a brush with a dual tip
1. In the Brush Properties dialog, click on the Dual Tip tab.
2. Check the check box in the Dual Tip tab to enable the Dual Tip functionality.

3. In the Brush Tip list, select the desired brush tip. If you want to create your own brush tip, see
Adding a Brush Tip on page 150.
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4. In the Blend Mode drop-down list, select the algorithm with which you want your secondary tip to
blend into your primary tip:
l

Multiply will draw the least opaque pixel of either brush tip, making more spaced out,
inconsistent strokes.

l

Color Dodge will add the opacity of the pixels in both brush tips, making more opaque
strokes.

l

Combine will draw the most opaque pixel of either brush tip, combining the tip shapes
without increasing their opacity.

5. Use the Maximum Size slider to set the maximum size of your brush tip.
NOTE
When drawing with a mouse, your brush is always at its maximum size. When drawing
with a pressure-sensitive pen tablet, your brush's size will range between its minimum
and maximum size, depending on the amount of pressure you put on the pen when
drawing.
6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your
brush when using your pen with very little pressure. The minimum size is set to a percentage of your
brush tip's maximum size, which is 25% by default. If you don't want the pressure on your pen to
affect the brush size, set this parameter to 100%.
7. If you want your brush tip to have uneven dimensions, use the Roundness slider to shrink the brush
tip vertically all the while preserving its horizontal size.
8. If you want your brush tip to be at an angle, use the Angle slider to rotate your brush tip.
9. Use the Hardness slider to set how much of the outer part of your brush tip should fade to
transparency. If you set it to 100 %, the brush will be completely solid. If you set it to 0 %, the brush
will only be opaque in its center, and will gradually become transparent towards its edges.
10. Use the Spacing slider to set how much distance you must drag your brush before Harmony prints
the brush tip onto your canvas, relative to your brush's size. The default setting is 7%, which
produces a relatively realistic brush stroke-like result. If this setting is too low, your brush strokes
might feel too thick and opaque. If this setting is too high, your strokes will look like the brush tip has
been stamped repeatedly over your canvas instead of dragged on it.
11. If you want the size of your brush tip to vary each time it's printed on your canvas, set the
Random Size setting to any value above 0 %.
12. If you want the angle of your brush tip to be random each time the tip is printed on your canvas, set
the Random Angle setting to any value above 0 °.
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13. If you want the spacing between each instance of the brush tip to be random, set the Random
Spacing setting to any value above 0 %.
14. If you want the spacing between each instance of the brush tip to be random, set the Random
Spacing setting to any value above 0 %.
15. In the Camera or Drawing view, start drawing to test your brush settings.
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Configuring a Brush with a Paper Texture
T-ANIMPA-002-004
Paper textures are bitmap textures that you can apply to your brush strokes as you draw. They act as
transparency filters that are tiled over your brush strokes to make them look grainy, as if you were drawing on a
rough paper surface. While Harmony comes bundled with preset paper textures, it is also possible to create
and use your own paper textures.

How to configure a brush with a paper texture
1. In the Brush Properties dialog, click on the Paper Texture tab.
2. Check the check box in the Paper Texture tab to enable paper textures.
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3. In the paper texture list, select the desired paper texture. If you wish to create your own paper
texture, see Adding a Paper Texture on page 163.
4. Using the Texture Scale slider, select the scaling factor at which to scale the paper texture when
applying it to your brush strokes.
5. If you want your brush strokes to get more opaque as you drag your brush or when you draw over
them, enable the Additive option.
6. If you want the paper texture to always be aligned to the same grid regardless of where you draw
your strokes, enable the Aligned option. Otherwise, your paper textures will be positioned relative
to where you start your drawing stroke, and if you draw two strokes one over the other, their paper
textures will clash with each other.
7. In the Camera or Drawing view, start drawing to test your brush settings.
It is also possible to use textures when drawing with the Pencil tool. However, those textures follow the shape
of the line instead of tiling over your strokes. For more information, see About Pencil Line Textures on page 199
Adding a Paper Texture

In the Brush Properties dialog, you will find a set of default paper textures which are bundled with Harmony,
but you can also create your own paper textures, then export your collection or import an existing set.
To make your own paper texture, you must first create an image file containing the texture, either in Harmony
or in a third party software, like Adobe Photoshop, then import it into Harmony. A paper texture must be a
greyscale image. Colors in paper textures are not acknowledged by Harmony, as paper textures are applied
onto the colour you are painting with in Harmony. Your texture should also not contain transparency, as
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Harmony determines the texture's transparency based on its black, white and grey levels. When drawing with
a paper texture, its black parts will appear 100% opaque, its white parts will appear 100% transparents, and
its grey parts will appear semitransparent.
You can import brush tips in any image format supported by Harmony. It is recommended to create paper
textures in a resolution ranging from 100 x 100 pixels to 400 x 400 pixels.
Like brush tips and brush presets, paper textures are saved in your preferences. You can also export your paper
textures into an .xml file, and import them on a different workstation, allowing you to share your textures
between the different people collaborating on your project.

How to add a paper texture
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
1. Click on the Paper Texture tab.
2. Check the check box in the Paper Texture tab to enable paper textures.
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1. In the Brush Properties dialog, do one of the following:
l

From the Paper Texture menu, select Add.

l

Click the Add Paper Texture button.

2. In the browser window that appears, navigate to where you saved your texture file.
3. Click Open to import the file into the Paper Texture library.
By default, an imported texture is given the name of the image file.
Renaming a Paper Texture

You can rename your paper textures to keep your list organized.

How to rename a paper texture
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
1. Click on the Paper Texture tab.
2. Check the check box in the Paper Texture tab to enable paper textures.
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3. Select the texture you want to rename.
4. Click on the Paper Texture menu icon

and select Rename.

5. In the Rename Texture dialog box that appears, type in the new name for the texture.

6. Click OK.
Deleting Paper Textures

You can delete unnecessary paper textures from your preset list.
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How to delete a paper texture
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
1. Click on the Paper Texture tab.
2. Check the check box in the Paper Texture tab to enable paper textures.

1. Select the texture you want to delete.
2. Do one of the following:
l

Click on the Paper Texture menu icon

l

Click the Delete

and select Delete.

button.
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NOTE
You can delete any paper texture in the Paper Texture library, including the
default paper textures, as long as no brush preset is using that paper texture.

Exporting Paper Textures

You can export paper textures into an .xml file which will contain their name and bitmap texture. This can be
useful if you wish to back up or share your paper textures.

How to export paper textures
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.

3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
4. Click on the Paper Texture tab.
5. Check the check box in the Paper Texture tab to enable paper textures.
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6. Click on the Paper Texture menu icon

and select Export.

The Export Tips and Textures dialog opens. This dialog allows you to export both your textured
brush tips and your paper textures.
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7. By default, both your brush tips and your paper textures are selected for export. If you only wish to
export your paper textures, uncheck the Select Brush Tips option.
8. Click on the Export button.
9. In the Export Textures dialog that appears, browse to a location where you would like to save the
.xml file, then type in the desired file name.
10. Click Save.
Importing Paper Textures

You can import paper texture presets you previously exported from Harmony.

How to import paper textures
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.
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3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
4. Click on the Paper Texture tab.
5. Check the check box in the Paper Texture tab to enable paper textures.

6. Click on the Paper Texture menu icon

and select Import.

7. In the browser window that appears, navigate to and select the .xml file in which you exported
your paper textures.
8. Click Open.
In the Import Tips and Textures dialog box appears.
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9. If the selected .xml file also contains brush tips, they will be selected for import along with the
paper textures by default. If you only wish to import the paper textures, uncheck the Select
Brush Tips option.
10. Click Import.
The imported paper textures will appear in the Paper Texture Library.
Changing the Paper Texture Display

You can change the way the paper textures are displayed in the paper textures list of the Brush Properties
dialog.

How to change the Paper Texture thumbnail display
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, click the Arrow button to open the Brush Properties view.
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3. If you are drawing on a vector layer, set the Brush Type to Textured Vector to enable the textured
brush options. If you are drawing on a bitmap layer, the textured brush options are always enabled.
4. Click on the Paper Texture tab.
5. Check the check box in the Paper Texture tab to enable paper textures.

1. Click on the Paper Texture menu icon

.

2. Select one of the following options:
l

Small Thumbnail: Displays paper textures in a grid of small thumbnails.

l

Large Thumbnail: Displays paper textures in a grid of large thumbnails with their
names. The default view setting.

l

List View: Displays paper textures in a list, with their name on the left and their
texture on the right of each row.
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Setting the Textured Brush Resolution
An important thing to take in consideration when drawing with textured brushes is that, contrary to solid
vector brushes, textured brushes store their texture in bitmap data, which is stored in individual pixels. This
implies that, where solid vector artwork can be scaled and zoomed in without issue, textured brush strokes are
resolution dependent, and are liable to lose quality and appear pixelated if they are enlarged or zoomed in.
By default, textured brush strokes have a pixel density of 100%. At this density, when your scene is not
zoomed in and your artwork is not scaled up, each pixel in the textured brush strokes corresponds to one pixel
in the rendered image. Scaling it up or zooming in will require Harmony to render several pixels using the same
pixel from the brush stroke's texture, making the artwork lose quality.
Hence, before you start drawing using textured brushes, it is important to consider if you will need to zoom
onto or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your
bitmap artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure the pixel
density for your textured brush strokes is of at least 300% before you start drawing.
You can specify the pixel density for textured brushes at the scene level or at the drawing level:
l

Setting the pixel density at the scene level will make newly created drawings have the specified pixel
density, but it will not change the pixel density of existing textured artwork.

l

Setting the pixel density at the drawing level will allow you to change the pixel density of existing
drawings, but will not affect the pixel density of drawings created afterward.
NOTE
If you are drawing on a bitmap layer, you must set the pixel density and canvas size for bitmap
artwork instead—see Setting the Bitmap Resolution on page 380.

How to set the pixel density for textured brush strokes for a scene
1. From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
2. Select the Bitmap Resolution tab.
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3. In the Pixel Density field of the Default Texture Pixel Density for Vector Drawings section, enter
the desired percentage of pixel density. If you intend to scale or zoom in on your artwork, make sure
your pixel density is set to be at least the factor by which your artwork will scaled or zoomed on. For
example, if you intend to scale your artwork by 300%, you need to set the pixel density to at least
300%. If you intend to zoom in on your artwork from 12 fields to 6 fields, you need to set the pixel
density to at least 200%. If you intend to do both, you need to set the pixel density to at least 600%,
as the camera zoom and scaling factor will have a multiplying effect on the apparent scaling of your
artwork.
4. Click OK.
From now on, new drawings created in your scene will have the selected pixel density for textured
brush strokes.
Since changing the bitmap resolution settings for your scene will only affect newly created drawings, you may
also want to change the pixel density for existing drawings. This is possible. However, if you choose to change
the pixel density of textures in existing artwork, it will be resampled. If you increase the pixel density of existing
artwork, Harmony will have to generate extra pixels for the texture, which will cause the artwork to lose
quality. Hence, it is important to calculate and set the proper pixel density for your textured artwork before you
start drawing.

How to change the pixel density for textured brushes strokes in existing drawings
1. In the Timeline, Node or Camera view, select the drawing for which you want to change the
textured brush stroke resolution.
2. From the top menu, select Drawing > Change Vector Drawing Brush Resolution.
The Change Vector Drawing Brush Textures Resolution dialog opens.

3. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or
zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your
artwork will scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you
need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12
fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you
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need to set the pixel density to at least 600%, as the camera zoom and scaling factor will have a
multiplying effect on the apparent scaling of your artwork.
4. If you want the specified pixel density to be applied on the existing textured brush strokes in the
drawing, check the Apply to Existing Strokes option.
5. If you want the specified pixel density to be applied to all the drawing's art layers (ie: Line Art,
Colour Art and, if enabled, Overlay Art and Underlay Art), check the Apply to All Art Layers option.
Otherwise, only the currently active art layer will be affected.
6. If you want the specified pixel density to be applied to all drawings in the active layer, check the
Apply to All Drawings option. Otherwise, only the current drawing will be affected.
7. Click OK.
From now on, new brush strokes will be in the selected drawing will be in the specified pixel
density.
NOTE
This does not change the default pixel density for the scene. New drawings will still be created
with the scene's default pixel density.
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About Brush Presets
Setting up your brush to perfectly reproduce the desired art style can require a lot of tweaking as well as trial
and error. Once you have found the correct settings for your brush, you will want to reuse it throughout your
project for consistency. You can do that by creating and using brush presets.

Harmony comes preloaded with many brush presets which you can select from the Tool Properties view. It is
also possible to create your own brush presets by configuring your brush, then saving it as a preset.
Like brush tips and paper textures, brush presets are saved in your preferences. You can also export your brush
presets into an .xml file, and import them on a different workstation, allowing you to share your brush presets
between the different people collaborating on your project.
NOTE
Brush presets are not to be confused with brush tips and paper textures. Brush tips and paper
textures are one of the many properties of a brush, whereas a brush preset contains all the
properties of a brush.

NOTE
Brush presets for vector layers and for bitmap layers are separate. A brush preset created while
working on a vector layer cannot be used when working on a bitmap layer, and vice versa.

177

Harmony 15.0 Premium User Guide

Creating a Brush Preset
You can create your own custom brush presets by configuring your brush, then adding it as a preset.

How to create a brush preset
1. Make sure the current drawing layer is vector if you wish to create a vector brush preset, or bitmap if
you wish to create a bitmap brush preset—see About Vector and Bitmap Layers
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. Click on the Arrow button to open the Brush Properties dialog.

4. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid Brush
or Creating a Textured Brush.
5. Do one of the following:
l

From the Brush Properties dialog, click on the New Brush Preset

button in the top-

right corner.
l

In the Tool Properties view, click the New Brush Preset

l

In the Tool Properties view, open the Brush Presets menu

button.
and select New Brush

Preset.
6. In the New Preset window, type a name for your new brush preset.
Your new brush preset is added to the end of the list of brush presets.
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Creating a Dynamic Brush Preset
You can create dynamic brush presets allowing you to stamp custom patterns. You can either repeat the same
pattern or loop a pattern made of several drawings.

How to create a new dynamic brush
1. In the Tools toolbar, select a drawing tool.
2. In the Camera or Drawing view, draw the pattern you want to use as your dynamic brush stamp.

3. In the Tools toolbar, click the Select

4. In the Tools toolbar, select the Brush

tool and select the parts of the drawing you want to repeat.

tool or press Alt + B.

5. In the Tool Properties view, do one of the following:
l

Click the Add Dynamic Brush

button.

l

Open the Brush Preset menu

and select New Dynamic Brush.

A new dynamic brush preset is added at the bottom of the Presets list.
6. Open the Brush Preset menu

and select Rename Brush.

7. In the Rename Brush dialog box, type in a name for the new dynamic brush and click OK.
8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
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9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the Maximum
Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings
1. In the Timeline view, click the Add Drawing Layers

button to create the layers you want to use

as patterns in your dynamic brush. Make sure to rename your layers.

2. In the Camera view, draw the individual drawings of your pattern on separate layers.

180

Chapter 3: Drawing

3. In the Tools toolbar, select the Select

tool.

1. In the Tool Properties view, disable the Works on Single Drawing

option to allow the Select tool

to grab artwork on multiple layers.
2. In the Camera view, select all the drawings you want to add to your new dynamic brush.

3. In the Tools toolbar, select the Brush

tool or press Alt + B.

4. In the Tool Properties view, do one of the following:
l

Click the Add Dynamic Brush

button.

l

Open the Brush Preset menu

and select New Dynamic Brush.

A new dynamic brush preset is added at the bottom of the Presets list.
5. Open the Brush Preset menu

and select Rename Brush.

6. In the Rename Brush dialog box, type in a name for the new dynamic brush and click OK.
7. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
When you use this brush, you will cycle through the drawings.
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Selecting a Brush Preset
Harmony provides you with default brush presets available in the Tool Properties view.

How to select a brush preset
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush preset from the Presets list.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

1. In the Tool Properties view, select the Brush Preset you wish to update.
2. Click on the Arrow button to open the Brush Properties view.

3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid Brush
or Creating a Textured Brush.
4. Click on the Update Brush Preset

button in the upper-right corner of the Brush Properties

dialog.
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Renaming a Brush Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush preset to rename.
3. Open the Brush Preset menu

and select Rename Brush.

4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets.

How to delete a brush preset
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select the brush preset you want to delete.
3. Do one of the following:
l

Click the Delete Brush

button.

l

Open the Brush Preset menu

and select Delete Brush.
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Exporting Brush Presets
You can export brush presets into an .xml file which will contain all of your brush's settings. This can be useful
if you wish to back up or share your brush presets.

How to export pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Export Brushes.

The Export Tips and Textures dialog opens. This dialog allows you to export brush presets for the
Brush, Pencil and Eraser tools.

3. By default, the presets for all your tools will be selected for export. If you only wish to export presets
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the
presets.
4. Click Export.
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5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml
file and enter its file name.
6. Click Save.
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Importing Brush Presets
You can import brush presets that you previously exported from Harmony.

How to import pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Import Brushes.

3. In the browser window that appears, navigate to and select the .xml file in which you exported
your brush presets.
4. Click Open.
The Import Brushes dialog box opens.

5. By default, the presets for any tools included in the file will be selected for import. If you only wish to
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want
to export the presets
6. Click Import.
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The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list.

How to change the Brush Presets display
1. In the Tool Properties view, click on the Brush Presets menu button

.

2. Select one of the following options:
l

Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their
tip.

l

Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

l

Stroke View: Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.
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Adjusting Texture Opacity
An advantage of using textured vector brushes on vector layers is that you can adjust their opacity afterward.
Using the Adjust Line Texture Opacity dialog, you can adjust the opacity levels between the most opaque and
the most transparent pixels in your textures.

How to adjust the line texture opacity
1. If you are in Camera view, select the Current Drawing on Top option—see Displaying the Current
Drawing on Top on page 334.
2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.
3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.

4. Do one of the following:
l

Drag the upper slider towards the right to increase the transparency of the more
transparent pixels.

l

Drag the lower slider towards the left to increase the opacity of the more opaque
pixels.

5. If you want to apply the changes to all drawings exposed on the layer, enable the Apply to All
Drawings option.
6. Click OK.
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About the Pencil Tool
T-HFND-004-004
The Pencil tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation.
The pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

The Brush and Pencil tools are used for drawing and sketching. Both tools support pressure sensitivity,
allowing you to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil
and shape tools produce central vector lines. This means that a pencil line’s control points (used to deform its
shape) are located along the length of the central spine, while the Brush line’s control points are located along
the contour.

l

If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor tool.

l

If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor tool.

l

You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool, as
it produces a more realistic and natural feel. Transparent pencil lines may not display the way you want when
they overlap:
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The pencil line is more appropriate for the final line of your clean drawings. Also, if you're drawing for digital
animation and intend to use the Auto-Patch effect to connect the parts of your character model, you should use
pencil lines for the Auto-Patch effect to work as expected.
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Drawing with the Pencil Tool
T-HFND-004-004A
Using the Pencil tool, you can draw vector pencil lines which can be easily tweaked and reshaped as needed.

How to draw with the Pencil tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.

NOTE
You can press Shift + Alt as you draw to draw straight lines.
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NOTE
Pencil lines are central vector lines. Sometimes, two pencil lines may look connected because their
edges overlap, but if their centerline is not connected, they will be considered an open shape. To
make sure the end of your stroke connects to the beginning of your stroke, hold the Alt key when
you start or finish drawing a pencil line.
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Creating a Pencil
T-LAY-001-001
You can configure a pencil's size, how much Harmony should automatically smooth your pencil lines when
drawing, the shape of the tips and corners of your pencil line as well as its texture.

How to modify the pencil settings
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

The Pencil Properties dialog opens.

3. Use the Maximum Size slider to set the maximum size of your pencil line.
4. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the size of your
pencil when using your pen with very little pressure. The minimum size is set to a percentage of your
pencil's maximum size, which is 20% by default. If you don't want the pressure on your pen to affect
the pencil size, set this parameter to 100%.
5. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's direction, curves and corners. A higher setting will prevent your line from being shaky,
but is liable to reduce your drawing precision and to round sharp corners into curves.
6. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control
points for the resulting vector shape.
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7. Click on the Shape pop-up buttons to select whether you want the Start and End of your pencil
lines to be Round or Flat, and whether you want the points and corners where pencil lines Join to
be Round, Mitre-shaped or Beveled.

8. Click on the Texture tab.

9. If you want your pencil line to have a texture, select the desired pencil line texture from the pencil
line texture library. Otherwise, select None. For more information on pencil line textures, see About
Pencil Line Textures on page 199.
10. Either close or set aside the Pencil Properties dialog.
11. In the Camera or Drawing view, start drawing to test your pencil settings.
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About Pencil Line Textures
Just like the Brush tool, the Pencil tool also supports textures. However, there are important differences
between the way brush textures and pencil textures work.
For one thing, a pencil line texture is applied with regard to the width and direction of the pencil lines. For
example, if you draw a spiral with a dash texture, the dashes will follow the curves of the spiral, and if you draw
a thicker line with the same texture, the dashes will be both longer and thicker.

Like colours, pencil textures are stored in special palettes in your scene. While brush textures are stored in your
artwork as bitmap data, pencil textures are stored in your artwork by linking the pencil line with its pencil
texture in the palette. This means that if you scale or tweak your pencil line, the pencil texture will be generated
again based on the new line's shape and the original texture. This also means that you are able to change the
pencil texture of an existing pencil line or to apply a texture to a pencil line that does not already have one.

Pencil line textures can also be used with the Line, Rectangle, Ellipse and Polyline tools, as those tools also
draw pencil lines.

199

Harmony 15.0 Premium User Guide

Drawing with Pencil Textures
You can draw a textured pencil line by selecting the pencil texture, then drawing.
There are two ways to select a pencil texture line. You can select a pencil texture palette, then one of its pencil
texture swatches in the Colour view, as you would do to select a colour, or you can select a pencil texture from
the current pencil texture palette in the Pencil Properties dialog.
Your pencil texture will be combined with the selected colour to make a textured colour line.
NOTE
You can also draw with textured pencil lines with the Line, Rectangle and Ellipse tools.

How to draw with a textured pencil line using the Colour view
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Colour view, select the colour with which you wish to draw.
3. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.

4. In the palette list, select the pencil texture palette containing the desired pencil texture.

5. In the swatch list, select the pencil texture you want to use.
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6. In the Camera or Drawing view, draw a pencil line.

How to draw with a textured pencil line using the Pencil Properties dialog
1. In the Colour view, select the colour with which you wish to draw.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

4. In the Pencil Properties dialog, click on the Texture tab.

NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
5. In the Texture library, select a texture for the pencil.
6. In the Camera or Drawing view, draw a pencil line.
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Applying a Pencil Textures to a Pencil Line
You can apply a pencil texture to an existing pencil line. You can also change a textured pencil line's texture by
following the same steps.
NOTE
You can also apply pencil line textures on artwork created with the Line, Rectangle, Ellipse and
Polyline tools.

How to apply a pencil line texture to an existing pencil line using the Colour view
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Drawing or Camera view, select a pencil line.

3. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.

4. In the palette list, select the pencil texture palette containing the desired pencil texture.

5. In the swatch list, select the pencil texture you want to apply to your pencil line.
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6. The selected pencil line now uses the selected pencil line texture.

How to apply a pencil line texture to an existing pencil line using the Tool Properties
view
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Drawing or Camera view, select a pencil line.

3. In the Tool Properties view, scroll down to the pencil texture library panel.

NOTE
The texture library in the Tool Properties view lists the same pencil textures as the ones
in the currently selected pencil texture palette in the Colour view.
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4. Select the pencil texture you wish to apply.

5. The selected pencil line now uses the selected pencil line texture.
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Editing a Pencil Line's Texture
There are two kinds of modification you can make to a pencil line's texture. Using the Edit Gradient/Texture
tool, you can scale the texture by its length and thickness, as well as offset its starting position. Using the
Pencil Editor tool, you can change the texture's symmetry relative to the line's center.

How to scale the length or thickness of a pencil line texture.
1. In the Tools toolbar, select the Edit Gradient/Texture

tool or press Shift + F3.

2. Click on the pencil line you want to edit.

3. Drag one of the square-shaped handles to scale the texture's length, thickness, or both
simultaneously.

How to offset a pencil line's texture.
1. In the Tools toolbar, select the Edit Gradient/Texture
2. Click on the pencil line you want to edit.

3. Drag the triangle-shaped handle to offset the texture.
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How to change a pencil line's symmetry
1. In the Tools toolbar, select the Pencil Editor

tool or press 8.

2. Click on the pencil line you want to edit.

3. Drag one of the line's control points closer or further away from the center line to change the size of
its half of the texture.
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Disabling Pencil Line Textures
After you selected a pencil line texture, if you wish to resume drawing solid pencil lines again, you can do so
using either the Colour view or the Pencil Properties dialog.

How to resume drawing with a solid pencil line using the Colour view
1. Click on the Show Pencil Texture Palettes

button to display your pencil texture palettes.

2. Over the swatch list, click on the No Texture button.

From now on, the pencil lines you draw will not have a texture.

How to resume drawing with a solid pencil line Pencil Properties dialog
1. In the Colour view, select the colour with which you wish to draw.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

4. In the Pencil Properties dialog, click on the Texture tab.
5. In the pencil textures library, select None.
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From now on, the pencil lines you draw will not have a texture.
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Pencil Texture Palettes
Just like colours used by your drawings, pencil textures are stored in pencil texture swatches, which are stored
in pencil texture palettes. Because pencil lines drawn with pencil textures are linked to the pencil texture in
their pencil texture palette, pencil textures can be shared and updated just as easily as colours in your Harmony
project.
For example, you can create the texture palette for your character in your character model's scene, then make
scenes that include this character link to that character's pencil texture palette, as you can with their colour
palette, to make sure both their colour and line textures are the same throughout your project. For more
information, see About Advanced Palette Management on page 418.
Just as with colour palettes, you can update a swatch in a pencil texture palette with a different texture, and the
pencil lines that are drawn with this texture will update with the new texture. This means your pencil textures
can always be subjected to revisions. It is also possible to override a pencil texture with another one using the
Colour-Override effect, and to clone a pencil texture palette, change the textures in its swatches, and decide if
the drawings in a scene will use the original or cloned texture palette—see Overriding a Texture on a Pencil
Line on page 1416 and Cloning a Palette on page 449.
When you create a new scene, your palette list will be preloaded with a default colour palette and a default
texture palette, the latter which is contains some sample pencil textures. If you wish, you can use these textures
for your project, you can build on this palette and add new textures as needed, or you can create your own
texture palette, loaded with only your custom textures, to use across your project. You can configure Harmony
to create new scenes with your own custom pencil texture palette.
NOTE
The following topics will introduce you to the basics of creating and using pencil texture palettes.
For more information on creating and managing swatches and palettes, see About Colour
Swatches on page 395 and About Palettes on page 416.
Creating a Pencil Texture Palette

Creating a pencil texture palette allows you to manage your own pencil textures as you wish. You can create
separate pencil texture palettes for different characters, props and backgrounds as needed, and share them
among the people collaborating on your project like you would with colour palettes.
Creating a pencil texture palette is as simple as creating a colour palette. When creating a palette, you have the
option to create it as a colour or a pencil texture palette.
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NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to create a pencil texture palette (Basic palette list mode)
1. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.
2. Do one of the following:
l

In the Colour View, click the New Palette

button over the palette list.

l

From the Colour view menu, select Palettes > New

The Create Palette dialog box opens.
3. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains
information to be easy to identify, such as the name of the character and information about the type
of setting for this palette, if any.

4. In the Palette Type drop-down, select Pencil Texture.
5. Click OK.
The palette appears in the drawing element’s palette list.

How to create a pencil texture palette (Advanced palette list mode)
1. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.
2. If you want to add the palette to an element's palette list, select a drawing from the element for
which you want to create a palette in the Timeline, Xsheet or Camera view.
3. Do one of the following:
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l

In the Colour View, click the New Palette

button over the palette list.

l

From the Colour view menu, select Palettes > New

The Palette Browser dialog box opens.

4. In the Palette Location panel, select the location where you want to store the palette file. If you are
using Harmony Server, you can store the palette in any environment, job, scene or element on your
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element,
or inside its provisional job or environment. For more information, see About Palette Storage
Locations on page 421.
5. In the New Palette Name field, enter the name for the new palette. The palette list above this field
lists the palettes that already exist in the selected location. Make sure you enter a name that is not
already used by another palette.
6. In the Palette Type drop-down, select Pencil Texture.
7. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.

8. Click OK.
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The new palette appears in the palette list.
Adding a Pencil Line Texture

You can create your own pencil textures by first creating an image file containing the texture, either
in Harmony or in a third party software, then importing it to your pencil texture palette.
A pencil texture must be created with transparency, as Harmony will only use the image's transparency
channel to determine how to apply the texture to your pencil lines. Hence, pencil textures can be in image
format that are supported by Harmony and which supports transparency: .png, .tga, .tif, .psd, .psb and
.sgi.
A pencil texture can be of any size, but the bigger the image resolution, the thicker the lines you can draw with
it without seeing pixels. The pencil texture will follow your pencil lines on their horizontal axis, like so:

NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to add a pencil line texture using the Colour view
1. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.

2. In the palette list, select the pencil texture palette containing the desired pencil texture.
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3. Do one of the following:
l

Click on the Add Texture

button.

l

Right-click on the swatch list and select New Texture.

l

Open the Colour view menu

and select Colours > New Texture.

4. In the file browser dialog, navigate to the location of your texture image file and select it.
5. Click Open.
The texture is added to your pencil texture palette.

You can start drawing with your new pencil texture.

How to add a pencil line texture using the Pencil Properties dialog
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

3. In the Pencil Properties dialog, click on the Texture tab.
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NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
4. Do one of the following:
l

Click on the New Texture

l

Open the Brush menu

button over the pencil textures list.
and select New Texture.

5. In the file browser dialog, navigate to the location of your texture image file and select it.
6. Click Open.
The texture is added to your pencil texture palette.

7. In the pencil texture library, select the new pencil texture.
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You can start drawing with your new pencil texture.
Renaming Pencil Line Textures

You can rename pencil textures from the Colour view or from the Pencil Properties dialog box.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to rename a pencil line texture using the Colour view
1. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.

2. In the palette list, select the pencil texture palette containing the desired pencil texture.
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3. In the swatch list, double-click on the name of the texture you wish to rename.

4. Enter the texture's name, then click outside of the text input field to confirm the new name.

How to rename a pencil line texture using the Pencil Properties dialog
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

3. In the Pencil Properties dialog, click on the Texture tab.
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NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
4. In the pencil texture library, select the texture you wish to rename.

5. Open the Brush menu

and select Rename Texture.

The Rename Texture dialog box opens.

6. In the Name field, type in the desired name for your texture
7. Click OK.
You can start drawing with your new pencil texture.
Deleting Pencil Line Textures

You can delete pencil texture palettes that you do not need.
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NOTE
You should not delete any pencil texture that is used in your project, as pencil lines using a deleted
pencil texture will become solid pencil lines.

NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to rename a pencil line texture using the Colour view
1. In the Colour view, click on the Show Pencil Texture Palettes

button to display your pencil

texture palettes.

2. In the palette list, select the pencil texture palette containing the desired pencil texture.

1. In the swatch list, select the pencil texture you wish to delete.
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2. Do one of the following:
l

Click on the Remove Colour button.

l

Right-click on the pencil texture and select Delete.

l

Open the Colour view menu and select Colours > Delete.

l

Press Del (Windows/Linux) or Backspace (macOS).

The selected pencil texture is removed from the pencil texture palette.

How to rename a pencil line texture using the Pencil Properties dialog
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

3. In the Pencil Properties dialog, click on the Texture tab.

NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
4. In the pencil texture library, select the texture you wish to delete.
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5. Do one of the following:
l

Click on the Delete Texture

l

Open the Brush menu

button.

and select Delete Texture.

The selected pencil texture is removed from the pencil texture palette.
Replacing a Pencil Texture

Just like you can edit a colour swatch and simultaneously update all the drawings using the colour swatch with
this new colour, you can replace an existing pencil texture with a different texture, and update all pencil lines
that use this texture with the new texture.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to replace an existing pencil line texture
1. In the Colour view, click on the Show Pencil Texture Palettes
texture palettes.
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2. In the palette list, select the pencil texture palette containing the desired pencil texture.

3. In the swatch list, select the pencil texture that you want to replace.

4. Do one of the following:
l

Right-click on the pencil texture and select Edit Texture.

l

Open the Colour view menu and select Colours > Edit Texture.

5. In the file browser dialog, navigate to the location of your new texture image file and select it.
6. Click Open.
The selected texture is replaced with the new texture file. It is also renamed based on the new
texture's file name.

Any pencil line that was drawn with the older pencil texture will now be drawn with the new pencil
texture.
Setting the Default Pencil Texture Palette

You can make a pencil texture palette into the default texture palette which is added to every new scene you
create. This will be saved in your user preferences.

How to add a texture to your preferences
1. In the Colour view, click on the Show Pencil Texture Palettes

222

button to display your pencil

Chapter 3: Drawing

texture palettes.

2. In the palette list, select the pencil texture palette containing the desired pencil texture.

3. In the Tools toolbar, select the Pencil

tool or press Alt + /.

4. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

5. In the Pencil Properties dialog, click on the Texture tab.

NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
6. Do one of the following:
l

Click on the Use as Default Texture Palette
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button.
l

Open the Brush menu

and select Use as Default Texture Palette.

From now on, new scenes created in Harmony will have the selected pencil texture palette as their
default pencil texture palette.
Recovering the Default Pencil Texture Palette

If you have made modifications on the default pencil texture palette in your scene that you wish to undo, you
can easily re-import the default pencil texture palette back into your scene as a new pencil texture palette.

How to recover the default pencil texture palette into your scene
1. Click on the Show Pencil Texture Palettes

2. In the Tools toolbar, select the Pencil

button to display your pencil texture palettes.

tool or press Alt + /.

3. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

4. In the Pencil Properties dialog, click on the Texture tab.
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NOTE
The texture library in the Texture tab lists the same pencil textures as the ones in the
currently selected pencil texture palette in the Colour view.
5. Click on the Reload Default Texture Palette

button.

A copy of the default pencil texture palette is added to the scene's pencil texture palette list.
Converting a Colour Palette to a Pencil Texture Palette

As of Harmony 15, each palette is set to either be a colour palette, or a texture palette, and both palette types
are kept in separate lists. However, in Harmony 14 and prior versions, pencil texture palettes were just regular
palettes, which you had to temporarily set at your pencil texture palette in order to use it for pencil line textures.
Because of this, if you open a scene created in Harmony 14 or prior, and which contains pencil texture palettes,
Harmony 15 will not be able to tell which palettes are colour palettes and which ones are pencil texture
palettes. Hence, you must manually move your pencil texture palettes to the pencil texture palette list before
you can use them for pencil line textures.
The only exception to this is if a scene created in a prior version of Harmony has a pencil texture palette named
penstyle_opacity. Because this was the default name for pencil texture palettes in older versions of
Harmony, Harmony 15 will automatically convert those palettes to pencil texture palettes.
NOTE
Converting a colour palette to a pencil texture palette is permanent. You cannot convert a pencil
texture palette to a colour palette. However, you will be prompted to confirm before making the
conversion, and the conversion can be undone with the Undo command.
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NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to convert a colour palette to a pencil texture palette
1. In the palette list of the Colour view, select the palette you want to convert to a pencil texture
palette.
2. Do one of the following:
l

Right-click on the palette and select Change to Pencil Texture.

l

Open the Colour view menu

and select Palettes > Change to Pencil Texture.

The palette will be moved from the colour palette list to the pencil texture palette list. To see
it, click on the Show Pencil Texture Palettes

button or the Show All Palettes
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About Pencil Presets
Setting up your pencil to perfectly reproduce the desired art style can require a lot of tweaking as well as trial
and error. Once you have found the correct settings for your pencil, you will want to reuse it throughout your
project for consistency. You can do that by creating and using pencil presets.

Harmony comes preloaded with a few pencil presets which you can select from the Tool Properties view. It is
also possible to create your own pencil presets by configuring your pencil, then saving it as a preset.
Pencil presets are saved in your preferences. You can also export your brush presets into an .xml file, and
import them on a different workstation, allowing you to share your brush presets between the different people
collaborating on your project.
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Creating Pencil Presets
T-LAY-002-002
You can create your own custom pencil presets.
Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the thickness
of the line varies according the amount of pressure you apply with a pen and tablet.

NOTE
To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, click on the arrow button next to the stroke preview area to open the
Pencil Properties dialog.

3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Pencil on
page 197.
4. In the Tool Properties view, click the New Brush

button.

The New Preset dialog box opens.

5. Type in a name for your new pencil thickness stencil and click OK.
6. Start drawing in the Drawing or Camera view.
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Creating Pencil Thickness Presets
T-LAY-002-003
Thickness stencils that are indicated with this

icon are also set with specific properties, but disregards the

pressure of your pen and tablet. The line thickness varies. You can access thickness stencils from the list of
presets on the Tool Properties view or create your own.

How to create a pencil thickness stencil
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the pencil line or shape from which you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil

button.

A new thickness stencil is added to the end of the list in the Presets menu.
4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or
Camera view to apply the thickness stencil you created.
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Selecting a Pencil Preset
T-ANIMPA-010-001
A pencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness
stencils.

How to select a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

2. In the Tool Properties view, use the Presets menu to select a pencil preset.

3. In the Drawing or Camera view, draw your pencil line or shape.
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Applying a Pencil Preset
T-ANIMPA-010-004
You can apply a pencil preset on already drawn pencil lines using the Select tool.

How to apply a thickness stencil to a pencil line or shape
1. In the Tools toolbar, select the Select

tool.

2. In the Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.
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Renaming Pencil Presets
You can rename your pencil presets to keep your list organized.

How to rename a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Presets menu, select the thickness stencil or preset you want to rename.
3. From the Brush menu

, select Rename Brush.

The Rename Preset dialog box opens.

4. In the Name field, type in the new name.
5. Click OK.
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Deleting Pencil Presets
You can delete unnecessary presets from your list.

How to delete a thickness stencil or pencil preset
1. In the Tools toolbar, select the Pencil

tool.

2. In the Presets menu, select the thickness stencil or preset to delete.
3. Click the Delete Preset

button.
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Exporting Pencil Presets
T-ANIMPA-010-005
You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Export Brushes.

The Export Tips and Textures dialog opens. This dialog allows you to export brush presets for the
Brush, Pencil and Eraser tools.

3. By default, the presets for all your tools will be selected for export. If you only wish to export presets
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the
presets.
4. Click Export.
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5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml
file and enter its file name.
6. Click Save.
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Importing Pencil Presets
T-ANIMPA-010-006
You can import Harmony pencil presets that you previously exported.

How to import pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Import Brushes.

3. In the browser window that appears, navigate to and select the .xml file in which you exported
your brush presets.
4. Click Open.
The Import Brushes dialog box opens.

5. By default, the presets for any tools included in the file will be selected for import. If you only wish to
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want
to export the presets
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6. Click Import.
The imported brush, eraser and pencil styles will appear in the Presets list.

237

Harmony 15.0 Premium User Guide

Changing the Pencil Preset Display
You can display your preset list as thumbnails or a list.

How to change the Brush Presets display
1. In the Tool Properties view, click on the Brush Presets menu button

.

2. Select one of the following options:
l

Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their
tip.

l

Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

l

Stroke View: Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.
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Changing Pencil Line Opacity Display
A central vector outline can obscure the true edges of a shape's fill. You can change the opacity of central vector
lines and outlines, while working, to bypass this problem. This feature only works in the OpenGL view. This
feature is meant to be used as a working tool, like the Light Table or Onion Skin, therefore this transparency
effect will not appear when the scene is rendered. However, the opacity value that you set will remain as the
set preference, even after you end a session and close the software.

If you want the transparency of a line or outline to show up in the render of your scene, use one of the many
other options that Harmony offers, such as colouring the line with a semi-transparent swatch or using the
Transparency or Colour-Override effects.

How to Use the Pencil Line Opacity feature
1. In either the Drawing view or Camera view toolbar, click on the Top Light icon. The Pencil Lines
Opacity feature can also be accessed through the Preferences panel.

The Onion Skin and Light Table Transparency dialog opens.
2. In the Onion Skin and Light Table Transparency dialog box, use the Pencil Lines Opacity slider to
globally increase or decrease the opacity of central vector lines. Sliding the slider all the way to the
right equals 100% opacity. Sliding the slider all the way to the left equals 0% opacity.
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3. Click OK.

NOTE
If your object has a vector contour outline (created by the Brush tool), this feature will not work. It
must have a central vector outline (created by one of the shape tools or Pencil tool).
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About Shape Tools
T-HFND-004-006
In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a
square or circle into a much more complex drawing—see About the Contour Editor Tool on page 287 and
About the Pencil Editor Tool on page 298.
The available shape tools are:
l

Line tool

l

Rectangle tool

l

Ellipse tool

l

Polyline tool

The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, rename, import
and export presets, see About the Pencil Tool on page 193.
To learn more about the shape tool parameters, see the Reference guide .
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Creating Rectangles, Circles and Lines with the Shape Drawing
Tools
T-HFND-004-006A
You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also draw
perfect circles and squares.
NOTE
To learn more about the shape tool parameters, see the Reference guide .

How to draw with a shape tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Rectangle

, Ellipse

, or Line

tool.

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill
4. In the Camera view, click and drag to draw the shape.

l

Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

l

Hold down Alt to draw the rectangle or ellipse from its centre.

l

Hold down Shift to snap the line every 15 degrees.

l

Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor

tool to deform the shape and create your drawing.
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Creating Vector Shapes with the Polyline Tool
You can use the Polyline tool to draw long and curvy lines.
NOTE
To learn more about the Polyline tool options, see the Reference guide .

How to draw with the Polyline tool
1. In the Timeline view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Polyline

tool or press Alt + _.

3. In the Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your
line.
4. Click a new area and drag to create a second point and Bezier handle.
l

Press Alt to pull only one handle, instead of two.

l

Press Shift to snap the handles to 45, 90, or 180 degrees.

5. Repeat the previous step until your shape is completed.
6. Press Ctrl (Windows/Linux) or ⌘ (macOS) and click to release the Polyline tool from the current
path or shape that it is creating. Continue to use the tool to make multiple, independent paths or
shapes.
7. If necessary, reshape the lines using the Contour Editor
Line or Stroke with the Contour Editor Tool on page 288.
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About the Stroke Tool
T-HFND-004-013
There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for
drawing tones and highlights directly on the character.

The Stroke tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool
can be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.
Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE
To learn more about the Stroke tool parameters, see the Reference guide
Authors
Marie-Eve Chartrand
Christopher Diaz
chrisdiazart.com
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Creating Invisible Lines with the Stroke Tool
T-HFND-004-013A
You can draw invisible lines with the Stroke tool as well as with the Pencil tool.
NOTE
To learn more about the Stroke tool parameters, see the Reference guide

How to draw invisible lines with the Stroke tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar from the Paint drop-down menu, select the Stroke
3. From the top menu, select View > Show Drawing > Show Strokes

tool or press Alt + V.

or press K.

4. In the Tool Properties view, you can adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to draw invisible lines with the Pencil tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. From the top menu, select View > Drawing > Show Strokes

or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
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If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to show the strokes with washed-out colours
1. From the top menu, select View > Show > Show Stroke With Colour Wash.

Authors
Marie-Eve Chartrand
Christopher Diaz
chrisdiazart.com
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About the Eraser Tool
T-HFND-004-010
Using the Eraser tool, you can remove parts of your drawing.
It is a good idea to create and save erasers with precise sizes and parameters in order to save time when
drawing and designing. Harmony provides you with a variety of default eraser styles and allows you to create
and save your own eraser presets.
The Eraser tool has as many options as the Brush tool. You can configure an Eraser to have a vector or textured
tip, automatic smoothing, transparency, a dual tip and a paper texture.
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Erasing
T-HFND-004-010A
You can erase portion of your artwork using the Eraser tool.

How to erase with the Eraser tool
1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.
2. In the Tools toolbar, select the Eraser

tool or press Alt + E.

3. In the Tool Properties view, set the Maximum Size to the desired Eraser size.
NOTE
If you are drawing with a mouse, your strokes will always be at their maximum size. If
you are using a pressure-sensitive tablet, your strokes will vary in size depending on the
pressure of your pen, ranging between 25% to 100% of the maximum size.
4. In the Camera or Drawing view, start erasing.
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Creating a Solid Eraser
When using the Eraser tool on a vector layer, you can use either solid vector erasers or textured vector erasers.
By default, your eraser will be a solid vector eraser. A solid vector eraser cuts out the shape of its stroke from
your vector artwork.
A solid vector eraser's tip can be shaped like a circle, a diamond or a square, and can be configured to have a
specific size, aspect ratio and angle. Also, solid vector erasers can be automatically smoothed by Harmony as
you draw.
If you are erasing on a bitmap layer, you can only use textured erasers, although you can configured a textured
eraser to appear solid.

How to create a solid vector eraser
1. In the Tools toolbar, select the Eraser

tool or press Alt + B.

2. In the Tool Properties view, click the arrow button to open the Eraser Properties view.

The Eraser Properties dialog opens.
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3. In the Eraser Type dropdown list, select Solid Vector.
4. In the brush tip list, select either Circle, Diamond or Square.
5. Use the Maximum Size slider to set the maximum size of your eraser tip, in pixels.
NOTE
When drawing with a mouse, your eraser is always at its maximum size. When drawing
with a pressure-sensitive pen tablet, your eraser's size will range between its minimum
and maximum size, depending on the amount of pressure you put on the pen when
drawing.
6. If you are using a pressure-sensitive pen tablet, use the Minimum Size slider to set the percentage
of your eraser tip's maximum size your eraser should be when you use your pen with very little
pressure. If you don't want the pressure on your pen to affect the eraser size, set this parameter to
100%.
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7. If you want your eraser tip to have uneven dimensions, use the Roundness slider to shrink the
eraser tip vertically all the while preserving its horizontal size.
8. If you want your eraser tip to be at an angle, use the Angle slider to rotate your brush tip.
9. Click on the Smoothing tab.

10. Use the Centerline Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's direction, curves and corners. A higher setting will prevent your line from being shaky,
but is liable to reduce your drawing precision and to round sharp corners into curves.
11. Use the Contour Smoothing slider to set the amount of smoothing Harmony should perform on
your stroke's contour. A higher setting will round sharp corners and reduce the amount of control
points for the resulting vector shape.
12. Either close or set aside the Eraser Properties dialog.
13. In the Camera or Drawing view, start erasing to test your eraser settings.
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Creating a Textured Eraser
A textured eraser can have the same settings as a textured brush: It can have a bitmap tip of any shape, can be
hard or soft, semi-transparent, combine two tips and be applied with a paper texture effect.
When working on a bitmap layer, the eraser tool is always textured, whereas when working on vector layers,
erasers are solid vector by default. A solid vector eraser merely cuts out the shape of the eraser stroke from the
vector artwork, whereas a textured vector eraser makes the artwork's bitmap texture more opaque or fully
invisible, depending on its intensity, then cuts out some of the vector artwork that the eraser made fully
invisible.
A textured eraser works like a reverse textured brush: It makes the pixels in a brush stroke's texture more—or
completely—transparent, depending on the eraser's intensity. This effect can only be obtained by using a
textured eraser on a textured brush stroke. If you use a textured eraser on solid vector shapes or on pencil lines,
the eraser will act like a solid vector eraser, that is, it will merely cut out the shape of the stroke from the
artwork. This is because solid vector shapes and pencil lines don't have a bitmap texture, and therefore the
textured eraser cannot work on the opacity of their individual pixels. Hence, when working on vector layers, it
is better to use a textured eraser only if all your artwork is composed of textured brush strokes, or it might wield
strange-looking results.

This outlines one of the advantages of working with bitmap layers. On bitmap layers, your brushes and erasers
always work as textured brushes and erasers.
Another issue you might encounter when erasing textured vector artwork is that textured vector brush strokes
are not flattened together, whereas on bitmap layers, your artwork is always flattened. This implies that if you
use a semi-transparent eraser on textured vector artwork, and the artwork has overlapping strokes, all the
strokes you erase will become semi-transparent, the resulting image will be a composite of the overlapping
strokes. On a bitmap layer, this would simply result in a single layer of semi-transparent artwork.
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There are two different types of textured vector erasers: Textured and Textured, Preserve Vector. A simple
textured eraser will do two things: First, it will make textured brush strokes more or completely transparent
where you erased, and second, it will cut out from the brush stroke's vector shape where it made its texture
completely transparent. In contrast, a Textured, Preserve Vector-type eraser will only make the texture brush
strokes more or fully transparent, but will leave its vector shape intact.

Creating a textured eraser works exactly like creating a textured brush. Therefore, you can follow the steps in
the Creating a Textured Brush section to learn how to create a textured eraser.
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About Eraser Presets
Once you have found the correct settings for your eraser, you might want to reuse it throughout your project for
consistency. You can do that by creating and using eraser presets.
Harmony comes preloaded with a few eraser presets which you can select from the Tool Properties view. It is
also possible to create your own eraser presets by configuring your eraser then saving it as a preset.
Like eraser tips and paper textures, eraser presets are saved in your preferences. You can also export your
eraser presets into an .xml file, and import them on a different workstation, allowing you to share your eraser
presets between the different people collaborating on your project.
NOTE
Eraser presets are not to be confused with eraser tips and paper textures. Eraser tips and paper
textures are one of the many properties of an eraser, whereas an eraser preset contains all the
properties of a brush.

NOTE
Eraser presets for vector layers and for bitmap layers are separate. An eraser preset created while
working on a vector layer cannot be used when working on a bitmap layer, and vice versa.
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Creating an Eraser Preset
You can create your own custom eraser preset by configuring your eraser, then adding it as a preset.

How to create an eraserpreset
1. Make sure the current drawing layer is vector if you wish to create a vector eraser preset, or bitmap
if you wish to create a bitmap eraser preset—see About Vector and Bitmap Layers
2. In the Tools toolbar, select the Eraser

tool or press Alt + E.

3. Click on the Arrow button to open the Eraser Properties dialog.

4. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid Eraser
and Creating a Textured Eraser.
5. Do one of the following:
l

From the Eraser Properties dialog, click on the New Brush Preset

button in the top-

right corner.
l

In the Tool Properties view, click the New Brush Preset

l

In the Tool Properties view, open the Brush Presets menu

button.
and select New Brush

Preset.
6. In the New Preset window, type a name for your new eraser preset.
Your new eraser preset is added to the end of the list of eraser presets.
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Selecting an Eraser Preset
Harmony provides you with default eraser presets available in the Tool Properties view.

How to select a brush preset
1. In the Tools toolbar, select the Eraser

tool or press Alt + E.

2. In the Tool Properties view, select an eraser preset from the Presets list.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in
the Tool Properties view, then updating your preset with your brush current's parameters.

How to update a brush preset
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

1. In the Tool Properties view, select the Brush Preset you wish to update.
2. Click on the Arrow button to open the Brush Properties view.

3. Configure your brush to be exactly how you wish to use it in the future—see Creating a Solid Brush
or Creating a Textured Brush.
4. Click on the Update Brush Preset

button in the upper-right corner of the Brush Properties

dialog.
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Renaming an Eraser Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset
1. In the Tools toolbar, select the Eraser

tool or press Alt + E.

2. In the Tool Properties view, select an eraser preset to rename.
3. Open the Brush Preset menu

and select Rename Brush.

4. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets.

How to delete a brush preset
1. In the Tools toolbar, select the Eraser

tool or press Alt + E.

2. In the Tool Properties view, select the eraser preset you want to delete.
3. Do one of the following:
l

Click the Delete Brush

button.

l

Open the Brush Preset menu

and select Delete Brush.
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Exporting Eraser Presets
You can export eraser presets into an .xml file which will contain all of your eraser's settings. This can be useful
if you wish to back up or share your eraser presets.

How to export pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Export Brushes.

The Export Tips and Textures dialog opens. This dialog allows you to export brush presets for the
Brush, Pencil and Eraser tools.

3. By default, the presets for all your tools will be selected for export. If you only wish to export presets
for specific tools, uncheck Select/Deselect All and select the tools for which you want to export the
presets.
4. Click Export.
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5. In the Export Presets dialog that appears, browse to the location where you want to save the .xml
file and enter its file name.
6. Click Save.
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Importing Eraser Presets
You can import eraser presets that you previously exported from Harmony.

How to import pencils, brushes and erasers
1. In the Tools toolbar, select either the Brush
2. Open the Brush Preset menu

, Pencil

or Eraser

tool.

and select Import Brushes.

3. In the browser window that appears, navigate to and select the .xml file in which you exported
your brush presets.
4. Click Open.
The Import Brushes dialog box opens.

5. By default, the presets for any tools included in the file will be selected for import. If you only wish to
import presets for specific tools, uncheck Select/Deselect All and select the tools for which you want
to export the presets
6. Click Import.
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The imported brush, eraser and pencil styles will appear in the Presets list.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list.

How to change the Brush Presets display
1. In the Tool Properties view, click on the Brush Presets menu button

.

2. Select one of the following options:
l

Small Thumbnail: Displays presets in a grid of small thumbnails with a preview of their
tip.

l

Large Thumbnail: Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

l

Stroke View: Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.
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Erasing Synced Drawings
Normally in the Camera view, the only drawings and lines that can be erased are those on the selected layer.
The Apply to Synced Drawing Layers

option allows for the inclusion of drawings on layers synced to the

selected drawing layer.
Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to erase synced drawings
1. In the Tools toolbar, select the Erase

tool.

2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other
layers that it is synced with will display the link icon.

3. In the Tool Properties panel, enable the Apply to Synced Drawing Layers option.

4. In the Camera view, start to erase.
Notice that only the selected drawing and its corresponding synced drawings have been erased.
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About the Select Tool
T-HFND-004-005
The Select tool allows you to select drawing strokes and drawing objects. When selected, you can use the
Select tool to scale, translate, rotate, resize, flip and delete them.
NOTE
To learn more about the Select tool options, see the Reference guide .
Authors
Marie-Eve Chartrand
Christopher Diaz
chrisdiazart.com
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Selecting
T-HFND-004-005A
Using the Select tool, you can select drawing strokes and groups.
NOTE
To learn more about the Select tool options, see the Reference guide .

How to select objects
1. In the Timeline view, select the cell on which you want to select drawing objects.
2. In the Tools toolbar, select the Select

tool or press Alt + S.

3. In the Camera or Drawing view, select strokes or drawing object you want to edit by doing one of
the following:
l

Click on a stroke or drawing object to select it.

l

Shift + Click on a stroke or drawing object to add it to a multiple selection.

l

Draw a lasso around drawing strokes or objects to select them simultaneously.

l

From the top menu, select Edit > Select All or press Ctrl + A (Windows/Linux) or ⌘ +
A (macOS) to select all the strokes and drawing objects in the drawing.

4. Do one of the following to edit your selection:
l

To reposition, click the selected drawing object and drag the selection to a new area.
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NOTE
You can also nudge your selection using the arrow keys, and fast-nudge
your selection by holding Shift and pressing the arrow keys.

l

To rotate, grab the selection box handle and rotate it.

l

To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift
to lock the selection’s ratio.

l

To skew, drag sideways or up and down the sides or top and bottom segments,
between the control points.
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l

To delete, press Del (Windows/Linux) or Backspace (macOS).
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Selecting Drawing Strokes in Synced Drawings
Normally in the Camera view, any visible line or drawing can be selected. When you enable the Works on
Single Drawing mode, only drawings from the currently selected layer can be selected.
The Apply to Synced Drawing Layers option works in conjunction with the Works on Single Drawing mode.
The Works on Single Drawing mode still limits the selection to a single layer, but the Apply to Synced Drawing
Layers option allows for the inclusion of drawings on layers synced to the selected drawing layer.
Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to select synced drawings
1. In the Tools toolbar, select the Select

tool.

2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other
layers that it is synced with will display the link icon.

3. In the Tool Properties panel, enable the Works on Single Drawing mode and the Apply to Synced
Drawing Layers option.

4. In the Camera view, select a drawing or any of its corresponding synced drawings.
Notice that only those drawings are selectable.
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Inverting a Selection
You can invert your selection to select everything else in your drawing that was not previously selected.

How to invert a selection
1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or Shift +
⌘ + I (macOS).
You can also find the Invert Selection option in the Camera or Drawing View menu by selecting Edit
> Invert Selection.
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Repositioning the Selection Pivot
You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point
1. In the Camera or Drawing view, select the drawing object you want to transform.
The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.
This becomes the new position of the pivot point for the current transformation and will remain
there until you make a new selection.
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Arranging and Reordering Drawing Strokes
The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing
or Camera view.

How to arrange drawing strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the strokes to be reordered.
3. Do one of the following:
l

From the top menu, select Drawing > Arrange > Bring to Front—Moves the selected
art to the front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘ + Shift +
PgUp (macOS).

l

From the top menu, select Drawing > Arrange > Bring Forward—Moves the selected
art one level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘ +
PgUp (macOS).

l

From the top menu, select Drawing > Arrange > Send Backward—Moves the selected
art one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘ + PgDown
(macOS).

l

From the top menu, select Drawing > Arrange > Send to Back—Moves the selected
art behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux)
or ⌘ + Shift + PgDown (macOS).

4. In the Drawing View and Camera View toolbars, you can also add the following buttons—see
Customizing View Toolbars on page 104.
l

Bring to Front

button

l

Bring Forward

button

l

Send Backward

l

Send to Back

button
button
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Grouping Drawing Strokes
Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the
selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing.
Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group groups.

How to group strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the strokes to be grouped.
3. Do one of the following:
l

From the top menu, select Edit > Group > Group.

l

From the Camera or Drawing view menu, select Edit > Group > Group.

l

Press Ctrl + G (Windows/Linux) or ⌘ + G (macOS).

How to ungroup strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the groups to be ungrouped.
3. Do one of the following:
l

From the top menu, select Edit > Group > Ungroup.

l

From the Camera or Drawing view menu, select Edit > Group > Ungroup.

l

Press Ctrl + Shift + G (Windows/Linux) or ⌘ + Shift + G (macOS).
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Working on a Single Drawing with the Select Tool
In the Drawing view, the select tool will always work on the selected layer only. In the Camera view, you can set
the Select tool to either work on all visible layers or on the selected layers only.
NOTE
To learn more about the Select tool options, see the Reference guide .

How to enable the Select Tool Works on Single Drawing preference
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. Do one of the followings:
l

In the Tool Properties view, click the Single Drawing Mode

button.

l

Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences
(macOS). In the Camera tab, go to the Tools section and select the Select Tool Works
on Single Drawing option and click OK.

3. In the Camera view, make your selection. Note that you may need to restart Harmony depending on
your system.
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About the Repositioning All Drawings Tool
T-ANIMPA-010-008
The Reposition All Drawings tool is used to reposition, scale, rotate or skew all drawing strokes on every
drawing included in a layer.

If your hand-drawn animation requires to be repositionned in the grid, as soon as your select the Reposition All
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the
controls the same was as the Select tool—see About the Select Tool on page 267.
You can use the Drawing Desk feature to select specific drawings and avoid repositioning all the drawings—
see About the Drawing Desk on page 540.
NOTE
To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning All Drawings in a Layer
T-ANIMPA-010-009
Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the
current layer.
NOTE
To learn more about the Reposition All Drawings tool options, see the Reference guide .

How to reposition all drawings
1. From the Tools toolbar, select the Reposition All Drawings

tool. This also automatically selects

every stroke in your drawing in the Drawing and Camera view.
2. Do any of the following:
l

To reposition, click and drag your selection to a new area.

l

To rotate, rotate the selection box handle.
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l

To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift
to maintain the selection’s ratio.

l

To skew, drag the sides or top and bottom segments, between the control points.

3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated
or skewed will follow the same transformation.
4. You can also adjust the position by modifying the settings and using the operation buttons in the
Tool Properties view.
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Repositioning All Drawings in Synced Layers
Normally in the Camera view, the only drawings that can be repositioned are those from the selected layer. The
Apply to Synced Drawing Layers option allows for the inclusion of drawings on layers synced to the selected
drawing layer.
Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to reposition all synced drawings
1. In the Tools toolbar, select the Reposition All Drawings

tool.

2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other
layers that it is synced with will display the link icon.

3. In the Tool Properties panel, enable the Apply to Synced Drawing Layers

option—see the

Reference guide .

4. In the Camera view, click and drag the drawings highlighted by a bounding box to a new location.
Notice that only drawings from the selected layer and its corresponding synced drawings have
been selected.
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5. Delete, move, scale, skew or rotate the cut selection.
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About the Cutter Tool
T-HFND-004-007
The Cutter tool lets you cut a drawing to move, copy, or delete it. You can use it to scale or reposition the portion
of a flattened or bitmap drawing. You can also use it to trim strokes using a single gesture.
NOTE
To learn more about the Cutter tool options, see the Reference guide .
Authors
Marie-Eve Chartrand
Christopher Diaz
chrisdiazart.com
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Cutting Artwork
T-HFND-004-007A
Use the Cutter tool to trim and cut your artwork.
NOTE
To learn more about the Cutter tool options, see the Reference guide .

How to cut drawings
1. In the Tools toolbar, select the Cutter

tool or press Alt + T.

2. In the Camera or Drawing view, select an area to cut away.

l

To delete the selected area, press Del.

l

To move the selection, drag it to a new area.

l

Use the bounding box controls to scale, skew, or rotate the cut piece.
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Cutting Synced Drawings
Normally in the Camera view, the only drawings and lines that can be cut are those on the selected layer. The
Apply to Synced Drawing Layers

option allows for the inclusion of drawings on layers synced to the

selected drawing layer.
Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to cut synced drawings
1. In the Tools toolbar, select the Cutter

tool.

2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other
layers that it is synced with will display the link icon.

3. In the Tool Properties panel, enable the Apply to Synced Drawing Layers option.

4. In the Camera view, create a region that includes both drawings.
Notice that only drawings from the selected layer and its corresponding synced drawings were
repositioned in the Camera view.
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About the Contour Editor Tool
T-HFND-004-008
The Contour Editor lets you reshape vector shapes, brush strokes and lines in your drawings.
Artwork in Harmony is made of vector shapes. Vector shapes are defined by points, the lines joining the points
together (contours) and the curve vectors, represented by Bezier handles, which make the curve of said lines.

The Contour Editor tool allows you to select a contour or point, and change the position of points, add and
remove points from the shape, rotate, lengthen and shorten curve handles to influence the curve of contours
between those points, or drag contours between points to change their curve directly.
Since pencil lines are defined by a single line with a line width, you can use the Contour Editor to easily modify
the shape of pencil lines. In contrast, brush strokes are full vector shapes, so the Contour Editor can be used to
modify their shape.

The Contour Editor can be used to tweak vector artwork in all sorts of ways. It can be used to perfect a pencil
line, correct shapes, or create complex shapes out of a basic ellipse or rectangle.
NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.
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Reshaping a Shape, Pencil Line or Stroke with the Contour Editor
Tool
T-HFND-004-008A
You can use the Contour Editor tool to tweak the contours of vector shapes and brush strokes in your drawings,
as well as reshape pencil lines and strokes.
NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.

How to reshape drawings
1. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

2. In the Drawing or Camera view, click the shape, contour or pencil line you want to edit near the area
you wish to change.
The shape or line's control points appear.

3. Click on one of the points to select it.
The point's Bezier handles appears, as well as Bezier handles for the surrounding points.
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TIP
You can select several points by drawing a lasso around the points, or by holding Shift
while clicking on points to add them to your selection. You can use the Contour Editor to
scale and rotate a selection of multiple points by enabling the Show Contour Editor
Control

option in the Tool Properties view.

4. Do one of the following:
l

To move a point or a selection of multiple points, click and drag it.

l

To change the curve on both sides of a point, drag one of its Bezier handles.

l

To change the curve on only one side of a point, press and hold the Alt key, then drag one of
its Bezier handles.

l

To deform the contour, drag a part of the contour between two points.
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l

To deform the curve between two points, hold the Shift key and drag the contour between
two points.

l

To remove a point's Bezier handles and make the lines it is connected to straight, press and
hold the Alt key and click on the point.

l

Straight lines have no Bezier handles at their points by default. To create Bezier handles for
these points and make their lines curved, pres and hold the Alt key, then click and hold the
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse
cursor until you release the mouse button.
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l

To add a control point, press Ctrl (Windows/Linux) or ⌘ (macOS) and click on the contour
where you want the new point to be created.

l

To remove a control point, select the control point and press Del (Windows/Linux) or
Backspace (macOS).
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About the Centerline Editor
T-HFND-004-009B
The Centerline Editor allows you to tweak and reshape brush strokes by manipulating their center line rather
than their contour. This gives you a flexibility that is similar to the one you have when using the Contour Editor
tool to manipulate pencil lines.
In Harmony, pencil lines are vector information calculated by their center line and the width of the line. This
makes it easy to edit pencil lines with the Contour Editor. Brush strokes, however, are stored as shapes.
Therefore, using the Contour Editor on a brush stroke does not allow you to edit the center line of the stroke,
but rather, its contour.
The Centerline Editor tool creates a center line for a brush stroke, and gives you access to control points and
Bezier handles for this center line, allowing you to deform the brush stroke the same way you can deform a
pencil line using the Contour Editor.
.

Keep in mind that brush strokes are vector shapes with a fill. As such, the Centerline Editor must do guess work
to figure out the center line of your brush strokes, and apply deformations on its shape as you tweak its control
points. The Centerline Editor will not be able to make a clear center line out of brush strokes that merge
together, that look scrambled or that do not have a clear direction.
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NOTE
The Centerline Editor is also able to tweak textured brush strokes with their texture. Note that this
will resample its texture, which may make it lose quality.

NOTE
If you use the Centerline Editor to deform a closed brush stroke with a fill inside it, the fill will not be
reshaped to fit the new shape of the brush stroke.
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Reshaping Brush Strokes Using the Centerline Editor
T-HFND-004-009C
You can use the Centerline Editor tool to reshape brush strokes from their center line rather than their contour,
like you would reshape pencil lines using the Contour Editor.
NOTE
The Centerline Editor is also able to tweak textured brush strokes with their texture. Note that this
will resample its texture, which may make it lose quality.

NOTE
If you use the Centerline Editor to deform a closed brush stroke with a fill inside it, the fill will not be
reshaped to fit the new shape of the brush stroke.

How to reshape brush strokes
1. In the Tools toolbar, double-click on the Contour Editor
tool, or press Alt + W.

button and select the Centerline Editor

2. In the Drawing or Camera view, click the contour or pencil line you want to edit near the area you
wish to change.
The Centerline Editor creates a center line manipulator based on the outline's shape, with control
points.

3. Click on one of the points to select it.
The point's Bezier handles appears, as well as Bezier handles for the surrounding points.
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TIP
You can select several points by drawing a lasso around the points, or by holding Shift
while clicking on points to add them to your selection. You can use the Contour Editor to
scale and rotate a selection of multiple points by enabling the Show Centerline Editor
Control

option in the Tool Properties view.

4. Do one of the following:
l

To move a point or a selection of multiple points, click and drag it.

l

To change the curve on both sides of a point, drag one of its Bezier handles.

l

To change the curve on only one side of a point, press and hold the Alt key, then drag one of
its Bezier handles.
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l

To deform the contour, drag a part of the contour between two points.

l

To deform the curve between two points, hold the Shift key and drag the contour between
two points.

l

To remove a point's Bezier handles and make the lines it is connected to straight, press and
hold the Alt key and click on the point.
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l

Straight lines have no Bezier handles at their points by default. To create Bezier handles for
these points and make their lines curved, press and hold the Alt key, then click and hold the
point and drag the mouse cursor away from it. A new Bezier handle will follow your mouse
cursor until you release the mouse button.

l

To add a control point, press Ctrl (Windows/Linux) or ⌘ (macOS) and click on the contour
where you want the new point to be created.
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About the Pencil Editor Tool
T-HFND-004-009
A pencil line is a central vector shape. Control points are located along the central spine allowing you to adjust
the stroke curve and position. Using the Pencil Editor tool, you can adjust the thick and thin areas of pencil
lines. Using the Contour Editor tool, you can reposition the spine of the stroke.
NOTE
To learn more about the Pencil Editor tool options, see the Reference guide .
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Tweaking the Thickness of Pencil Lines with the Pencil Editor Tool
T-HFND-004-009A
You can use the Pencil Editor tool to reshape the pencil line thickness.
NOTE
To learn more about the Pencil Editor tool options, see the Reference guide .

How to reshape pencil lines
1. In the Tools toolbar, select the Pencil Editor

tool.

2. In the Camera or Drawing view, select a pencil line and click to reshape it.

3. Select one or several points by clicking them or circling around.

4. Press Del to delete a selected point.
5. Press Ctrl (Windows/Linux) or ⌘ (macOS) and click the central spine to add a set of points to adjust
the contour.
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6. To modify the shape, you can:
l

Move the selected points to a new area. If you select matching points on each side of
the line, holding the Shift key will move them both. This way you can thicken or thin a
line from both sides at the same time.

l

Pull on the Bezier handle to move both points’ handles as one.

l

Hold down Alt and pull on one of the Bezier handles. It moves the handle
independently from the other one.
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l

Pull directly on the line between two points. No selection is necessary. Holding down
the Shift key will limit the contour modification to the curve between the two first
points.

l

If an anchor point has no visible Bezier handle, hold down Alt to display them.
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Editing a Pencil Line Texture with the Pencil Editor Tool
When working with textured pencil lines, the Pencil Editor will deform the textures starting from the centre
lines.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line
1. Do one of the following:
l

In the Tools toolbar, select the Pencil Editor

tool.

l

From the top menu, select Drawing > Drawing Tools > Pencil Editor.

2. Click on the pencil line to be modified to bring up its contour envelope.

3. Select one of the contour points around the envelope and move its position to change the size of the
tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play with
the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to
look squashed.
Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the
number of tiles, while expanding it will increase the number of tiled images.
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About the Smooth Editor Tool
T-ANIMPA-010-010
When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw
may look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of
your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the
lines, the Smooth Editor tool.
NOTE
To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Artwork Using the Smooth Editor
T-ANIMPA-010-011
You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool
1. In the Tools toolbar, select the Smooth Editor

tool or select Drawing > Tools > Smooth Editor.

2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass
over the same line several times to remove more points and make the line smoother. Note that by
default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—
see the Reference guide to learn about the various settings available.
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About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and
edge anchor points to warp the shape.

NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.

NOTE
To learn more about the Perspective tool options, see the Reference guide .

306

Chapter 3: Drawing

Deforming a Drawing with the Perspective Tool
Use the Perspective tool to distort a drawing's bounding box and simulate a perspective effect.
NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.

NOTE
To learn more about the Perspective tool options, see the Reference guide .

How to deform a drawing with the Perspective tool
1. In the Tools toolbar, select the Perspective

tool from the Contour Editor drop-down menu or

press Alt + 0.
2. In the Camera or Drawing view, select a drawing to deform.
3. Click and drag the different anchor points to deform the shape.

307

Harmony 15.0 Premium User Guide

About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You
can warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.

NOTE
To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool
You can warp your drawings using the Envelope tool.
NOTE
If you use the Contour Editor, Perspective or Envelope tool on a textured brush stroke, it will deform
its texture to fit the new shape of the brush stroke. Note that this will resample the texture, which
is liable to make it lose quality.

NOTE
To learn more about the Envelope tool options, see the Reference guide .

How to warp a drawing with the Envelope tool
1. In the Tools toolbar, select the Envelope

tool from the Contour Editor drop-down menu.

2. In the Timeline view, select a drawing to deform.
3. In the Camera or Drawing view, select the region you want to deform

4. Click and drag the different anchor points and handles to deform the image.
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5. To display more controls, in the Tool Properties view, click the Show Advanced Controls

6. Increase the height and width of the grid to get more control points to deform your image.
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About the Text Tool
With the Text tool, you can add text in your project using various fonts and texts attributes.

Text objects are drawing objects in the same was as brush strokes and drawing groups are, so they can be
manipulated with the select tool. After you have written and formatted your text, you can break the string
apart to convert the letters into drawing objects that can than be individually modified with tools such as
Select, Perspective, Contour Editor, Smooth Editor.
NOTE
To learn more about the Text tool options, see the Reference guide .
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Adding Text to Drawings
You can use the Text tool to add text to your drawings.
NOTE
To learn more about the Text tool options, see the Reference guide .

How to add text to drawings
1. Do one of the following:
l

In the Tools toolbar, select the Text

tool.

l

From the top menu, select Drawing > Tools > Text.

l

Press Alt + 9.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.
3. In the Drawing or Camera view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will
type—see the Reference guide .
5. Type in the desired text.

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always
return to edit the text by selecting the Text

tool and clicking in the text.

7. You can resize the text box by selecting your text box with the Text

tool and moving the anchor

point right or left. Using the Select tool will distort and scale your text itself rather than changing
the width and height of your text box.
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Breaking Text Into Letters or Vector Shapes
Text contained in a text field is treated as a single drawing object. You can easily separate the text so each
character becomes an individual drawing object that you can select and modify independently.

How to break a text object
1. In the Tools toolbar, click the Select

tool or press Alt + S.

2. In the Drawing or Camera view, select the text object you want to break.

3. From the top menu, select Drawing > Convert > Break ApartText Layers.
l

From the Drawing or Camera view menu, select Drawing > Convert > Break
ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that
you can edit.
4. If you want to convert your independent letter to a complete vector object that you can deform, use
the Select tool to select the letters to convert.
5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into
a regular drawing object, with no more text attributes.
l

From the Drawing or Camera view menu, select Drawing > Convert > Break Apart
Text Layers to break the selection into a regular drawing object, with no more text
attributes.
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About Tool Presets
T-ANIMPA-002-008
Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often.
That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush,
Pencil, Eraser, Rectangle, Ellipse, and Line.
The difference between a tool preset and a brush preset is that when you save a tool preset, you have the
option of saving the colour and assigning a shortcut, which you cannot do with brush presets.
The Tool Presets toolbar lets you create new tool presets and manage them.
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Displaying the Tool Preset Toolbar
Use the Tool Preset toolbar to create, manage and select your custom tool presets. You can display the toolbar
in the Drawing and Camera views as well as the top area.

How to display the Tool Presets toolbar
1. Do one of the following:
l

From the top menu, select Windows > Toolbars > Tool Presets.

l

Right-click an empty area below the top menu and select Tool Presets.
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Creating Tool Presets
T-ANIMPA-002-009
You can create your custom tool presets to quickly access brushes and pencils settings and colours you use
frequently.

How to create a tool preset
1. In the Tools toolbar, select a tool, for example the Brush tool.
2. Use the Tool Properties view to customize the tool.
3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool.
NOTE
When using a tool preset in a scene that is not using the assigned colour swatch,
a colour recovery dialog box appears prompting you to add the colour to the
scene.
4. In the Tool Presets toolbar, click the New Tool Preset button.
5. In the New Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the
File

button.
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7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By
default, the shortcuts are unassigned. To assign a keyboard shortcut, select Edit > Preferences >
Shortcuts > Tool Presets (Windows/Linux) or Harmony Premium > Preferences > Shortcuts >
Tool Presets (macOS).
8. When you select an option, it will take effect when you use the tool preset. If an option is deselected,
then using a tool preset will not override your current settings.
l

Colour: Saves the current colour into the tool preset.

9. Click OK.
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Selecting Tool Presets
You can select tool presets in the Tool Presets toolbar.

How to select a tool preset
l

In the Tool Presets toolbar, click the tool preset

icon you assigned when creating the preset.

Note that when using this preset in a new scene not using the assigned colour swatch, a colour
recovery dialog box appears prompting you to add the colour to the scene.
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Deleting Tool Presets
You can delete unnecessary tool presets to keep your list organized.

How to delete a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.
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Updating Tool Presets
T-ANIMPA-002-010
You can update existing tool presets through the Manage Tool Presets dialog box.

How to update a tool preset
1. In the Tool Properties view, update the tool settings.
2. In the Tool Presets toolbar, click the Manage Tool Presets

button.

3. In the Manage Tool Presets dialog box, select the tool preset from the list.
4. Update the additional parameters such as the icon, Colour, Layer and Draw Behind options.
5. Click Update.
6. Click OK.
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Exporting Tool Presets
You can export tool presets for backup, sharing, or installing on a different computer.

How to export a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets
The Manage Tool Presets dialog box opens.
2. Click Export.
3. In the Export Brush Presets window that opens, click Export.
4. Select a folder and click Select Folder.
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Importing Tool Presets
You can import Harmony tool presets you previously exported.

How to import a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

The Manage Tool Presets dialog box opens.
2. Click Import.
3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select
Folder.
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About the Tool Colour Swatches
T-ANIMPA-010-018
While drawing and painting, you can let Harmony retain the last colour you selected for each one of the
following tool types:
l

Brush

l

Paint

l

Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint, and Pencil tools.

You can also link or unlink the colour swatch used between vector and bitmap layers.
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Unlinking the Tool Colour Swatches
T-ANIMPA-010-019
You can unlink the tool colour swatches and use separated colours for the Brush, Paint, and pencil line tools.
If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link the
three swatches together.

How to unlink the tool colour swatches
1. In the Colour view, if the storage swatches are linked, click the Link

2. Click on the Brush

storage swatch.

3. In the Colour list, select the desired colour.
4. Click the Pencil

storage swatch.

5. In the Colour list, select a colour.
6. Click the Paint

storage swatch.
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7. In the Colour list, select a colour.
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Linking the Tool Colour Swatches
You can link the tool colour swatches so all the tools use the same colour swatch.

How to link the storage swatches
1. In the Tools toolbar, select one of the following tools:
l

Brush

l

Paint

l

Pencil

l

Polyline

l

Line

l

Ellipse

l

Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Using Independent Bitmap Colour Swatches
When working in the Colour view, by default the current colour is active for both vector and bitmap layers. You
can however, use different reference colours for each layer.
Although you can use colours from your colour palette to paint on a bitmap layer, colours used in a bitmap
drawing layer are not linked to their colour swatch in the palette. This means that, contrary to vector drawing,
updating the colours in your colour palette will not update your bitmap drawings with the new colours.

How to use independent colours
l

From the Colour view menu, select Colours > Independent Bitmap Colour.
Whichever colour you choose as the reference color is retained for that layer type.
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About Drawing Space Management
When you are drawing in the Camera or Drawing view, you can zoom, pan and rotate the view to make it
easier to determine where to place objects, determine the scale of objects, and when zooming out, get an
overall view of the panel and its contents. You can also use the grid to help you determine the size and
placement of objects as you draw.
If you like drawing in the Camera view, but don't want overlays to cover the drawing you're working on, you
can enable the Current Drawing on Top option.
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About the Zoom Tool
The Zoom tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.
NOTE
To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool
1. In the Tools toolbar, select the Zoom

tool available in the Hand tool drop-down menu.

2. Click in the Camera or Drawing view.
3. In the Tools Properties view, do the following:
l

Enable the Zoom In

mode to zoom in mode when you click in the Camera or

Drawing view. When you're in Zoom In mode, hold as you click to zoom out.
l

Enable the Zoom Out

mode to zoom out when you click in the Camera or Drawing

view.
l

Click on the Zoom In

l

Click on the Zoom Out

button to immediately zoom in. You can also press 2.
button to immediately zoom out. You can also press 1.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing or Camera view. When you are zoomed in your
workspace, you may need to pan to a different area of your image. You can do so with the Hand tool or the
Spacebar keyboard shortcut.
The Hand tool has no options in the Tool Properties view.

How to use the Hand tool
1. Do one of the following:
l

In the Tools toolbar, select the Hand

tool, click in the Drawing or Camera view and

drag.
l

You can also Hold down the Spacebar, click in the Drawing or Camera view and move
your mouse in the direction you want to pan the view.
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About the Rotate View Tool
T-LAY-001-005
The Rotate View tool lets you rotate the Drawing or Camera view, the same way as you would do with a real
animation disc for increased flexibility. This tool can also be used in the Perspective view.

The rotation angles for the Camera and Drawing views are independent; if you rotate the Drawing view 25
degrees, if you switch to the Camera view, you can use the rotary table in that view and rotate it to a different
angle without affecting the settings in the other view.
When using the Rotate View tool, you are only rotating your workspace. You can not changing the actual
rotation angle of your drawings. Exporting your project will completely ignore the Rotate View angle.
The Rotate View tool has no options in the Tool Properties view.
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Rotating the Workspace
T-LAY-001-006
You can use the Rotate View tool to rotate your drawing workspace.

How to use the Rotate View tool
1. Do one of the following:
l

From the top menu, select Drawing > Tools > Rotate View.

l

In the Tools toolbar, select the Rotate View tool in the Hand tool menu.

l

In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

l

Hold down Ctrl + Alt (Windows/Linux) or ⌘ + Alt (macOS).

The rotary table appears.

2. In the Drawing or Camera view, click and drag to rotate the space.

3. Release the keyboard shortcut or switch to a new drawing tool.
4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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Displaying the Current Drawing on Top
T-ANIMPA-010-020
In the Camera view, when you draw on a layer, the artwork is displayed in the correct order. For example, if the
layer on which you are drawing is located behind an object on another layer, the lines you draw will be hidden
behind that object.

You can display a selected drawing on top of everything while you draw. Then, each time you select a drawing
tool, the drawing is displayed in front of everything in the Camera view. The Timeline and Node view ordering
remain unchanged.

How to display the drawing on top
1. Do one of the following:
l

From the top menu, select View > Show > Current Drawing on Top.

l

In the Camera bottom toolbar, click the Current Drawing on Top

button.

NOTE
The Current Drawing on Top status is retained when you exit Harmony. When
you restart the application, the last status will be used.
2. In the Tools toolbar, select a drawing tool. You only need to enable this option once, it is not
necessary to do it each time you select a drawing tool.
3. In the Camera view, start drawing.
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About the Grid
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a given
layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the grid
boundaries as it is only a visual reference.
In the Camera view, the Grid is visible when you select a drawing tool.

335

Harmony 15.0 Premium User Guide

Displaying the Grid
You can display the grid and it will be visible in the Drawing view. It will be visible in the Camera view when
you select a drawing tool.
Use the Show Grid option to display a grid in the Drawing or Camera views.

How to display the grid
1. Do one of the following:
l

In the Drawing View toolbar, press the Show Grid

l

In the Camera View toolbar, press the Show Grid

l

Select View > Grid > Show Grid.

l

Press Ctrl + ' (Windows/Linux) or ⌘ + ' (macOS).
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Modifying the Grid
You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on.

How to modify the grid display
1. Select View > Grid > Show Grid to display the grid.
2. To modify the grid, select one of the following:
l

View > Grid > Grid Outline Only—Displays the outline of the grid only.

l

View > Grid > Square—Displays a standard square grid.

l

View > Grid > 12 Field Grid—Displays a 12-field size grid.

l

View > Grid > 16 Field Grid—Displays a 16-field size grid.

l

View > Grid > Underlay—Displays the grid under the drawing elements.

l

View > Grid > Overlay—Displays the grid over the drawing elements.

3. In the Drawing View and Camera View toolbars, you can also add the following buttons—see
Customizing View Toolbars on page 104.
l

Grid Outline Only

button

l

Square

l

12 Field Grid

button

l

16 Field Grid

button

l

Underlay

l

Overlay

button

button
button
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About OpenGL Antialiasing
T-ANIMPA-010-016
Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you
draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast realtime display called OpenGL. If you prefer to see smooth lines as you draw, you can enable the antialiasing
preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias
your drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or
off; by default, it is disabled.
There is no need to modify your graphic card settings.
NOTE
Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference
T-ANIMPA-010-017
You can enable the Full Scene Antialiasing preference to smooth out the OpenGL artwork.
NOTE
You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters
1. Do one of the following:
l

Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences
(macOS).

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

The Preferences dialog box opens.
2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

3. Number or samples: Enter the number of samples you want to be used for the antialiasing process.
The number of samples is basically equivalent to the amount of times a pixel will be enlarged to
calculate the antialiasing. This technique is called supersampling. The higher the number of samples,
the better the antialiasing quality will be, but the longer it will take to calculate.
4. Restart Harmony.
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About Drawing Guides
T-LAY-001A-001
Drawing guides can assist you in drawing background and objects that require straight lines, square angles
and, more importantly, perspective. In traditional art. This is usually done using rulers, set squares, and
vanishing points to draw lines from. Guides are meant to reproduce the usage of such tools in combination with
Harmony's drawing tools.
When a guide is in use, it adds a horizon line and vanishing points to your drawing space, which can be moved
to fit your scene's needs, and it locks your drawing tools so that they draw straight lines, either going from one
of your vanishing points, or parallel to your guide's horizontal or vertical axis. This makes the process of drawing
structures with volume and perspective streamlined. Also, guides display dotted lines going through your
mouse cursor going from your vanishing points or parallel to your guide's horizontal and vertical axes to help
you visualize the axes your drawing strokes will follow.
Harmony supports the following types of drawing guides:
l

The Square Grid guide simply helps you draw on the horizontal and vertical axes, which are relative to
the horizon line.

l

The 1-Point Perspective guide helps you draw lines coming from a single vanishing point, which is in
the middle of the horizon by default. It also helps you draw along the horizontal and vertical axes. This
can help create realistic-looking backgrounds with buildings, walls and objects that are facing your
camera.
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l

The 2-Point Perspective guide helps you draw lines going from one of two vanishing points, which are
positioned left and right of your drawing space. This can help create realistic-looking backgrounds with
buildings, walls and objects that are at an angle from your camera.

l

The 3-Point Perspective guide helps you draw lines going from one of 3 vanishing points: Two
horizontal vanishing points positioned left and right of your drawing space, and one vertical vanishing
point positioned below or above your drawing space. This can help you draw realistic looking
backgrounds from a low or high angle. The 3-Point Perspective guide has two presets: Bird's Eye View
preset and the Worm's-Eye View, which can be used for high angle and low angle perspectives,
respectively.

Guides are made to work with the following tools. They are only visible in your drawing space when one of
these tools is selected:
l

Brush

l

Pencil

l

Stroke

l

Line

Before you can use a guide, you must use the Guide view to add the guide you wish to use to your scene's
guides list. A new guide will have its horizon line and vanishing points in preset positions, which can be
adjusted to fit your scene's needs. Using the Guides view, you can add, select, rename, delete, cut, copy, paste
and reorder guides as needed. Your guides list can also be exported to a file and re-imported into a different
scene. When a guide is selected, you can use it, but you can also adjust its horizon line and vanishing points.
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NOTE
Your guide list and its guides are part of your scene's data. They are saved with your scene.
Changes done to your guides list or to a guide can be undone with the Undo command.

342

Chapter 3: Drawing

Adding Drawing Guides
T-LAY-001A-002
The first step in using drawing guides is to create a guide in the Guides view.

How to Add a Drawing Guide to your Scene
1. From the top menu, select Windows > Guides to add the Guides view to the current workspace.
2. In the Guides view, select the

New Guide button and choose one of the following types of

guides:
l

Square Grid

l

1-Point Perspective

l

2-Point Perspective

l

3-Point Perspective (Bird’s-eye View)

l

3-Point Perspective (Worm’s-eye View)

The new guide appears in the Guides view list.

3. To add another guide, repeat the previous step.
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Renaming Drawing Guides
Since guides can be customized, you may want to give them specific name to help you identify them

How to rename a guide using the Guide Menu
1. In the Guides view, select a guide from the list.
2. In the Guide Menu, select Rename Guide.
The Rename Guide dialog box opens.
3. In the Rename Guide dialog box, enter the new guide name.
4. Press OK.

How to rename a guide using the Guide List
1. In the Guides view, double-click on a guide displayed in the list.
The guide's name becomes editable.
2. In the editable name field, enter a new name for the guide.
3. Press Enter/Return.

NOTE
It is not required to give a unique name to each guide in a guides list.
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Deleting Drawing Guides
T-LAY-001A-003
You can delete a drawing guide from your list.

How to delete a Drawing Guide
1. In the Guides view, select one or multiple guides from the list.
2. In the Guides view, select the Delete Guide

button or press Del (Windows/Linux) or Backspace

(macOS).
The selected guided are deleted from the list.
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Selecting the Active Drawing Guide
A Harmony scene can have as many guides as needed, but you can only use one guide at a time. You can decide
which guide you're using by selecting it from the guides list. The selected guide will display in your drawing
space.
Although you can select the active guide at any time, a guide will only behave as active if one of the following
drawing tools is selected:
l

Brush

l

Pencil

l

Stroke

l

Line

Once a guide is active, it will display its horizon line and vanishing points in your drawing space. There will also
be two or three dotted lines following your mouse cursor in the drawing area: One line for each horizontal or
vertical axis in your guide, and one line going from each vanishing point in your guide through your mouse
cursor.

How to select the active guide from the guides list
1. In the Guide view, click on the desired guide in the guides list
The selected guide will become active.
NOTE
If Guides are disabled, clicking on a guide in the guides list will enable them.

How to quickly switch between guides
1. Set the focus on your Camera or Drawing view, for example, by clicking on the view's tab.
2. Press the Up Arrowor Down Arrow key to select the previous or next guide in the list.
NOTE
Using the Up Arrow or Down Arrow to select a guide will only work if guides are already
enabled.
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Cutting Drawing Guides
You can cut a drawing guide from your guides list. This will remove the guide from the list allow you to paste it
into another scene.

How to cut a Drawing Guide
1. In the Guides view, select one or multiple guides from the list.
2. In the Guides view menu, select Cut or press Ctrl + X (Windows/Linux) or ⌘ + X (macOS).
The selected guides are deleted from the list and stored in the clipboard.
3. In the top menu, select File > Open and open a different Harmony scene.
4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains
guide, select a guide that will act as an insertion point.
5. In the Guides View menu, select Paste or press Ctrl + V (Windows/Linux) or ⌘ + V (macOS).
Drawing Guides that were copied from the previous guides list are pasted in the current guides list,
under the selected guide, if any.
NOTE
If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus
is on the Guides view.
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Copying Drawing Guides
T-LAY-001A-004
You can copy drawing guides and paste them into other scenes.

How to copy a Drawing Guide
1. In the Guides view, select one or multiple guides from the list.
2. In the Guides View menu, select Copy or press Ctrl + C (Windows/Linux) or ⌘ + C (macOS).
3. In the top menu, select File > Open and open a different Harmony scene.
4. In the Guides view, click on the guides list to set the focus on it. If the guides list already contains
guide, select a guide that will act as an insertion point.
5. In the Guides View menu, select Paste or press Ctrl + V (Windows/Linux) or ⌘ + V (macOS).
Drawing Guides that were copied from the previous guides list are pasted in the current guides list,
under the selected guide, if any.
NOTE
If you want to use the Cut, Copy and Paste keyboard shortcuts on guides, make sure the focus
is on the Guides view.
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Reordering Drawing Guide Lists
The drawing guides in your guides list can be reordered.

How to reorder a Drawing Guide list
1. In the Guides view, select one or multiple guides from the list.
2. Drag and drop the selected guides to their desired position in the list.

349

Harmony 15.0 Premium User Guide

Editing Drawing Guides
T-LAY-001A-005
When a new guide is created, it comes with a preset horizon line and, if applicable, preset vanishing points.
The position and angle of the horizon line as well as the position of any vanishing point in the selected guide
can be adjusted visually from within your drawing space.
Guides can only be edited with the Brush, Pencil, Stroke or Line tool. The selected guide will only be visible
when one of these tools is selected.

How to edit a drawing guide
1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing
by doing one of the following:
l

Right-click on the cell and select Drawing > Create Empty Drawing.

l

Press Alt + Shift + R

2. In the Tools toolbar, select the Brush

, Pencil

, Stroke

or Line

tool.

3. In the Guides view, select a guide to make it the active guide.
Once a guide is active, its horizon line and vanishing point(s) appear in the drawing area.

4. In the Guides view, make sure the Lock Guide

option is disabled. This ensures you're able to edit

the active guide.
5. In the drawing area, zoom out until all vanishing points are visible (if necessary).
6. In the drawing area, grab either the horizon or a vanishing point and move it to its desired location.
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When using the square grid or 1-point perspective guides, the angle of the horizon can be modified
by manipulating the horizon line itself.

When using the 2-point or 3-point perspective guides, the angle of the horizon can be modified by
manipulating one of the two vanishing points on the horizon.

When adjusting the horizon line, you can hold down Shift to snap the horizon line at every 15
degrees. This makes it easy to maintain a perfectly horizontal horizon.
NOTE
Each modification to a guide can be undone with the Undo command.
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Drawing with Drawing Guides
T-LAY-001A-006
Once a guide is active and properly set up, you can use it to assist you in creating a drawing with perspective.
The guide will display its axes going through your mouse cursor as you move it inside your drawing space.
When you start drawing a stroke, your drawing tool will become locked to the axis that most closely matches
the angle of your stroke, forcing you to draw a straight line along that axis, as if you were using a ruler or a set
square.
Guides can only be used with the Brush, Pencil, Stroke or Line tool. The selected guide will only be visible when
one of these tools is selected.

How to draw using guides
1. In the Timeline or Xsheet view, select a drawing, or select an empty cell and create a new drawing
by doing one of the following:
l

Right-click on the cell and select Drawing > Create Empty Drawing.

l

Press Alt + Shift + R

2. In the Tools toolbar, select the Brush

, Pencil

, Stroke

or Line

tool.

3. In the Guides view, select the guide you wish to use.

4. In the drawing area, draw a stroke with the current drawing tool. From the initial gesture, the tool
locks on one of the guide's axes, forcing it to draw a straight line that follows the axis.
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NOTE
Some guides do not lock onto a horizontal or vertical axis line by design. At any time, when
drawing with the Brush or Pencil tool, you can hold down Shift + Alt before starting the stroke;
this will force the tool to draw a straight line that locks at every 15 degrees. You can also
achieve the same effect with the Line tool by holding down Shift before drawing a stroke.
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Locking Drawing Strokes to a Specific Axis
T-LAY-001A-010
When using a drawing guide, your drawing tool with lock onto one of its axes based on the initial direction of
your drawing stroke. In some situations, it may be hard for the tool to lock onto the expected guide axis. To
remedy this, it is possible to manually select which axis you want to lock your drawing strokes to.

How to lock your drawing tool to a specific axis
1. Set the focus to the Camera or Drawing view, for example, by clicking on the view's tab.
2. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes. The
selected axis will be displayed in bold across your mouse cursor.
All your drawing strokes will lock onto the selected axis.

How to re-enable using all axes
1. Press the Left Arrow or Right Arrow key repeatedly to cycle through your guide's axes, until none of
them are displayed in bold across your mouse cursor.

354

Chapter 3: Drawing

Drawing Freehand Perspective with Drawing Guides
By default, all strokes drawn with an active drawing guide are straight lines that follow one of the guide's axes.
To achieve a different style, you might want to draw with freehand perspective instead, where you use the
guides as references, but without forcing your strokes to be straight and aligned with their axes. This can be
done by disabling the Align with Guide option, which is enabled by default.
When the Align with Guide option is disabled:
l

The Brush, Pencil, Line and Eraser tools will no longer lock to your guide's axes, allowing you to draw
strokes in any direction.

l

The guide will still be visible, but will only serve as a visual aid.

l

The initial angle of your stroke will still determine which axis you're using, but instead of locking your
stroke on the axis, it will simply make the reference line for that axis bolder, to help you draw along it.

How to draw freehand perspective
1. In the Guides view, activate the Align with Guide

button.

You can now draw freely and use the guide as a visual aid.

2. Start drawing.
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Erasing Using Drawing Guides
By default, drawing guides have no effect when using the Eraser tool. However, if needed, you can make the
Eraser tool use your selected guide.

How to erase using a Drawing Guide
1. In the Guides view, activate the Enable Guide with Eraser
The Eraser
Stroke

button.

tool will now work with the currently selected guide, just like the Brush

and Line

, Pencil

tools.

2. Start erasing.
NOTE
With the Enable Guide with Eraser option, you can also edit your guide's horizon line and
vanishing points using the Eraser tool.
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Viewing Drawing Guide Reference Lines
T-LAY-001A-007
By default, a guide will only display its horizon line, its vanishing point, and its axes relative to your mouse
cursor's position. To help you lay out the objects in your drawing, you can also enable reference lines. Reference
lines are multiple semi-transparent lines that are drawn in parallel to your axes and from your vanishing points,
at an equal distance or angle from each other, to cover your entire drawing space with visual guides.
When using reference lines, you can decide the amount of lines that display in your drawing space. If you have
too many reference lines, they will be very close to each other and your drawing space might feel cluttered, but
if you have too few, you might not always have a reference line close enough to the stroke you wish to draw to
help serve as a reference.

How to view Drawing Guide Reference lines
1. In the Guides view, activate the Show Reference Lines

button.

The reference lines appear as a semi-transparent overlay.

2. In the Guides view, use the Number of Lines slider to adjust the line density.
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Minimizing Guide Cursor Axes Display
By default, the guide axes that are drawn across your mouse cursor extend throughout your entire drawing
space. You may want those axes to only extend to a short distance around your cursor, so that they can still
serve as guides without obstructing your drawing space or drawing your eye away from your mouse cursor. You
can do this by disabling the Full Cursor Display option, which is enabled by default.
When the Full Cursor Display option is disabled:
l

The guide axes displaying across your mouse cursor only span on a short distance from your mouse
cursor.

l

When drawing a stroke, all guide axes disappear until you finish drawing the stroke. By default, only the
axis you are drawing on disappears.

l

The actual axes used to lock your drawing tool still extend across the entire drawing space. Only the
axes displayed in your drawing space are shortened.

How to minimize the Drawing Guide's cursor axes display
1. In the Guides view, toggle the Full Cursor Display

button off.

The guide axes now only span over a short distance from your mouse cursor.
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Preventing the Editing of Drawing Guides
T-LAY-001A-008
When using a drawing tool with a guide, you are also able to edit the guide's horizon line and vanishing points.
This may be a problem if you need to draw close to the horizon line or to your vanishing points, as you may
accidentally displace them instead. Once you're sure that your guide is properly set up, it is recommended to
lock your guides before you start drawing, so you don't have to worry about editing them by accident.

How to prevent editing of Drawing Guides while drawing
1. In the Guides view, activate the Lock Guide

button.

NOTE
The Lock Guide option locks the editing of all guides, not just the selected one. When creating
a new guide, the Lock Guide option is automatically disabled to allow the new guide to be
edited immediately.
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Enabling and Disabling Drawing Guides
T-LAY-001A-009
When you want to stop working with guides, you must disable them. When drawing guides are disabled:
l

The Brush, Pencil, Line and Eraser tools have their normal, non-constrained behavior.

l

The horizon, vanishing points, guide axes and reference lines are not displayed.

How to enable and disable a Drawing Guide
1. To enable or disable Drawing Guides, do one of the following:
l

In the Guides view, enable or disable the Enable Guide

l

Press Shift + G.

button.

NOTE
The guide that was selected when you disable guides will be restored when you enable them
again.

NOTE
Drawing guides only work with the Brush, Pencil, Stroke and Line tools. They will behave as if
they were disabled when any other tool is selected.
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Importing and Exporting Drawing Guide Lists
How to export Drawing Guides to a file
1. In the Guides view, select one or multiple guides from the list.
2. In the Guides View menu, select Export Selected Guides.
3. In the Export Guides dialog box that displays, choose a destination filename and folder and click
Save.
The selected guides are written into the destination file. A message displays to confirm the amount
of guides that were exported.

How to import Drawing Guides from a file
1. In the Timeline or Thumbnail view, select the destination panel.
2. In the Guides View menu, select Import Guides.
3. In the Import Guides dialog box that displays, choose a file from a previous export and click Open.
The Drawing Guides from the imported file are inserted at the bottom of the Drawing Guide list. A
message displays to confirm the amount of guides that were added.
NOTE
When importing a list of guides, duplicate guides are filtered out to avoid cluttering the list. The
import confirmation will indicate if duplicates were detected and filtered out.
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About Drawing Optimization
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those
drawings to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to flatten
your artwork or optimize your brush stroke textures.
The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change the
appearance of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to create an
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging
the transparent drawing objects will cause them to lose the effect of the layered transparent colours.

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to
be repainted later.

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing
into another. If you cut a portion from a textured line and paste it into a different drawing, Harmony pastes the
entire unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of
the source drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not
touch the vector area. If there are many textured lines in your scene, this will greatly reduce the file size.
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In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first, it
appears as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However,
using the Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more
texture bitmap exists beyond the cropped boundary. If you use the Crop Brush Texture command, the bitmap
texture is cropped to the boundaries of the textured line’s vector contour (as seen in the fourth image where
the vector envelope has been pulled out to reveal empty space).
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Flattening Drawings
T-ANIMPA-002-006
The Flatten operation is used to merge drawing objects and brush strokes into a single layer. If you draw new
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will
be easier if they are flattened.

How to flatten drawings
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the drawing strokes you want to flatten.
3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten
button in the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a
pencil line. It also smooths out the shape.

How to smooth drawings
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the drawing strokes you want to smooth out.
3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth
button in the Tool Properties view.
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Creating Contour Strokes
The Create Contour Stroke option is used to add a permanent invisible line around a shape that was drawn
directly in Harmony. This allows you to unpaint your lines with the Paint tool but maintain the shape of the
lines, should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer option.

How to create contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to create
contour strokes for.
3. From the top menu, select Drawing> Optimize > Create Contour Strokes.
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Removing Contour Strokes
The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the
intersection triangles created during vectorization.

How to remove contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to
remove contour strokes for.
3. From the top menu, select Drawing> Optimize > Remove Contour Strokes.
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Removing Extra Strokes
The Remove Extra Strokes command allows you to instantly remove invisible lines that are adjacent to the
artwork in your selection.
NOTE
This will only remove invisible lines that are adjacent to visible artwork. Invisible lines that are not
connected to any visible shape or line will not be removed.

How to remove extra strokes
1. In the Tools toolbar, select the Select

tool.

2. In the Camera or Drawing view, use the Select tool to select the artwork from which you want to
remove extra strokes.
3. Do one of the following:
l

In the top menu, select Drawing > Optimize > Remove Extra Strokes.

l

In the Camera or Drawing view, open the View Menu
Remove Extra Strokes.
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Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your
drawings. This mainly means that transparencies will not be flattened.

How to optimize a drawing
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the drawing strokes you want to optimize.
3. Do one of the following:
l

From the top menu, select Drawing > Optimize > Optimize.

l

From the Camera or Drawing view menu, select Drawing > Optimize > Optimize.
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Cropping Brush Textures
The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath
the vector contour of a textured line

How to crop the brush texture
1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop.
2. Do one of the following:
l

From the top menu, select Drawing > Optimize > Crop Brush Textures.

l

From the Camera View or Drawing View menu, select Drawing > Optimize > Crop
Brush Textures.
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Reducing the Drawing Texture Resolution
When you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be
heavy. You can reduce the size and resolution of the textures in a drawing.

How to reduce the drawing texture resolution
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects whose texture
resolution you wan to reduce.
3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.
l

From the Camera or Drawing view menu, select Drawing > Optimize > Reduce
Drawing Texture Resolution.

4. In the dialog box, drag the slider toward the left to reduce the texture resolution.
5. Enable the Apply to All Drawings option if you want the modification to be applied to all the
drawings in your layer.
6. Click OK.
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About Strokes Conversion
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For
many reasons, you may want to switch your stroke types to another type to use the various advantage set they
offer.
There are three types of strokes:
l

Brush strokes (contour vector)

l

Pencil strokes (central vector)

l

Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes
(strokes) to pencil lines.
You can also break text objects apart—see Breaking Text Into Letters or Vector Shapes on page 314.
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Converting Brush Strokes to Pencil Lines
The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil strokes.
The brush stroke thickness will be lost.

How to convert brush strokes to pencil lines
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the strokes you want to convert.
3. Do one of the following:
l

From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or
press ^.

l

Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ^
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Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into contour strokes
brush lines.

How to convert pencil lines to brush strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the strokes you want to convert.
3. Do one of the following:
l

From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or
press &.

l

Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &.

l

In the Tool Properties view, press the Pencil Lines to Brush Strokes
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the strokes you want to convert.
3. Do one of the following:
l

Select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only).

l

Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift +
F12 (Windows/Linux only)
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About Vector and Bitmap Layers
T-LAY-001-002
With Harmony, you have the choice to use vector or bitmap drawing tools. Vector drawing tools allow you to
make drawings that can be scaled without losing quality, to easily tweak and fine tune your drawings and to
use the whole suite of drawing tools available in Harmony, whereas bitmap drawing tools allow you to lay on
brush strokes to make more traditional-looking artwork, and to tweak your drawing by the pixel rather than by
their strokes and contours.

When drawing, whether you can use vector or bitmap drawing tools is determined by whether the art layer
you are drawing on is a vector or a bitmap layer. By default, each drawing layer has two art layers: Line Art and
Colour Art, and each of these art layers can be a vector or a bitmap layer. This can be useful if, for example, you
wish your line art to be done using bitmap drawing tools, and then to paint your drawings using vector
drawing tools, or vice versa.
NOTE
Optionally, drawing layers can have two extra art layers, the Overlay Art layer, which appears over
the other art layers, and the Underlay Art layers, which appears underneath. For more information,
see Enabling Overlay and Underlay Art Layers on page 559.
Using bitmap layers may be preferable if you find that vector drawings are too limiting for the desired art style,
or if your vector drawings are so complex that they affect software performance. However, bitmap layers have
the following limitations which you should carefully consider before using them:
l

In vector drawings, each stroke is a separate drawing object by default, and each of these drawing
objects, as well as each of their points, curves and outlines, can be manipulated independently. It is not
possible to do that with bitmap layers, as they are always a single drawing object. They can be drawn,
filled or erased over, and manipulated as a whole, but its individual elements cannot be manipulated
independently.
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l

By default, bitmap layers are created at the same pixel density as your scene's camera when it is in its
default position. This means that your artwork will lose picture quality if you zoom in on it or scale it up. If
you need bitmap drawings to be scaled up or zoomed on, you must set your bitmap artwork's pixel
density higher before you start drawing.

l

Bitmap drawings may require more storage space than vector drawings. Note that this depends a lot on
the amount of space in your drawing that is covered by artwork. Harmony does not store bitmap data
for empty areas of your drawings.

When drawing on a bitmap layer, the following tools are unavailable, as they exploit the vector drawing
capabilities of Harmony:
l

Pencil

l

Contour Editor

l

Pencil Editor

l

Smooth Editor

l

Perspective

l

Envelope

l

Ink

l

Stroke

l

Close Gap

l

Polyline
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Adding Bitmap Layers
T-ANIMPA-002-013
By default, new scenes created in Harmony will have a single vector layer. You can choose whether a drawing
layer will be a vector or a bitmap layer at its creation. Therefore, if you want to use a bitmap layer, you can
simply create one.
Each drawing layer in your scene has two sub-layers, referred to as Line Art and Colour Art, each which can be
either Vector or Bitmap. When creating a new layer, you can choose whether each of these art layers will be
vector or bitmap art layers.

How to add a bitmap layer
1. In the Timeline view, click the Add Drawing Layer

button,

The Add Drawing Layer window opens.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, Line
Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay Art
Layers on page 559.

2. If you want a fully bitmap layer, select Bitmap for all the art layers. If you want parts of your drawing
to use bitmap drawing tools and other parts of your drawings to use vector drawing tools, set the
corresponding art layers to Bitmap or Vector, depending on your needs.
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3. Click OK.
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Setting the Bitmap Resolution
When drawing in bitmap, it is important to understand that, contrary to vector artwork, bitmap artwork is
stored in pixels. This implies that, where vector artwork can be scaled and zoomed in without issue, bitmap
artwork is resolution dependent, and is liable to drop in picture quality and appear pixelated if it is enlarged or
zoomed in.
By default, bitmap layers created in Harmony have a pixel density of 100%. At this density, when your scene is
not zoomed in and your artwork is not scaled up, each pixel in your artwork corresponds to one pixel in the
rendered image. Scaling it up or zooming in will require Harmony to render several pixels using the same
bitmap pixel, making the artwork lose quality.
Hence, before you start drawing on your bitmap layer, it is important to consider if you will need to zoom onto
or scale up your artwork, and set the pixel density accordingly. For example, if you intend to scale your bitmap
artwork up to 300%, or if you intend to zoom in from 12 fields to 4 fields, you should make sure your bitmap
artwork's pixel density is of at least 300% before you start drawing.
The pixel density of a bitmap layer affects the amount of pixels it contains, but not its apparent size in the
scene. For example, if your scene resolution is set to 1920 x 1080 and your bitmap artwork's pixel density is
300%, its resolution will be 5760 x 3240. However, it will be scaled down to 1920 x 1080, and the extra pixels
will be used to preserve the image quality if the artwork is zoomed on or scaled up.

Bitmap layers are also limited by a canvas. By default, this canvas is set to be 200% of the scene's width and
height. This means that your artwork can bleed outside any edge of the camera frame by 50% of its size. If you
need your bitmap artwork to have a larger canvas, it is possible to change its canvas size. This can be useful for
example if you want to create a panning background in a bitmap layer. If you want a background to pan
horizontally over three times the width of the camera frame, you would need to set its canvas width to at least
300%, but it is recommended to make your canvas bigger than what you plan to use so as to avoid accidentally
including the edges of your artwork in the picture.
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You can specify the pixel density and canvas size at the scene level or at the drawing level:
l

Setting the pixel density and canvas size at the scene level will make it newly created bitmap drawings
have the specified settings, but it will not change the pixel density and canvas size of existing bitmap
drawings.

l

Setting the pixel density and canvas size at the drawing level will allow you to change the pixel density
and canvas size of existing drawings in a bitmap layer, but will not affect the pixel density and canvas
size of drawings created afterward.
NOTE
If you are using textured brushes on a vector drawing layer, you must set the pixel density for
vector drawing brush textures instead—see Setting the Textured Brush Resolution on page 174.

How to set the canvas size and pixel density of bitmap layers for a scene
1. From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
2. Select the Bitmap Resolution tab.
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1. In the Default Canvas Size & Pixel Density for Bitmap Drawings section, do the following:
a. In the Width and Height fields, enter the percentage of your scene's resolution that you want
the canvas of your bitmap layer to occupy. By default, both values will be set to 200%, which
means the width and height of your bitmap canvas will be twice the width and height of your
scene's resolution. When the camera is in its default position, this leaves extra space around
the camera frame to draw on your bitmap layer.
b. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale
or zoom in on your artwork, make sure your pixel density is set to be at least the factor by
which your artwork will scaled or zoomed on. For example, if you intend to scale your artwork
by 300%, you need to set the pixel density to at least 300%. If you intend to zoom in on your
artwork from 12 fields to 6 fields, you need to set the pixel density to at least 200%. If you
intend to do both, you need to set the pixel density to at least 600%, as the camera zoom
and scaling factor will have a multiplying effect on the apparent scaling of your artwork.
2. Click OK.
From now on, new bitmap drawings created in your scene will have the selected canvas size and
pixel density.
Since changing the bitmap resolution settings for your scene will only affect newly created bitmap drawings,
you may also want to change the bitmap resolution settings for existing bitmap drawings. This is possible.
However, if your bitmap layer already contains artwork, it will be resampled.
This is not necessarily a problem if you want to lower your bitmap layer's pixel density, which you might want
to do to save on disk space and help Harmony's performance. However, if you want to increase your bitmap
layer's pixel density, Harmony will have to generate extra pixels for your bitmap drawing, which will cause the
image to lose quality. Hence, it is important to calculate and set the proper pixel density for your bitmap
drawings before you start drawing.

How to change the canvas size and pixel density of existing bitmap drawings
1. In the Timeline, Node or Camera view, select the bitmap drawing for which you want to change the
canvas size or pixel density.

382

Chapter 3: Drawing

2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.
The Change Bitmap Drawing Resolution dialog opens.

3. In the Width and Height fields, enter the percentage of your scene's resolution that you want the
canvas of your bitmap layer to occupy. By default, both values will be set to 200%, which means the
width and height of your bitmap canvas will be twice the width and height of your scene's
resolution. When the camera is in its default position, this leaves extra space around the camera
frame to draw on your bitmap layer.
4. In the Pixel Density field, enter the desired percentage of pixel density. If you intend to scale or
zoom in on your artwork, make sure your pixel density is set to be at least the factor by which your
artwork will scaled or zoomed on. For example, if you intend to scale your artwork by 300%, you
need to set the pixel density to at least 300%. If you intend to zoom in on your artwork from 12
fields to 6 fields, you need to set the pixel density to at least 200%. If you intend to do both, you
need to set the pixel density to at least 600%, as the camera zoom and scaling factor will have a
multiplying effect on the apparent scaling of your artwork.
5. Enable the Resample Bitmap option if you want your drawings to preserve their apparent size in
the scene.
6. If you want the specified settings to be applied to all of the drawing's art layers (ie: Line Art, Colour
Art and, if enabled, Overlay Art and Underlay Art), check the Apply to All Art Layers option.
Otherwise, only the currently active art layer will be affected.
7. If you want the specified settings to be applied to all drawings in the active layer, check the Apply
to All Drawings option. Otherwise, only the current drawing will be affected.
8. Click OK.
The selected drawing's canvas size and pixel density is set to the specified settings.

383

Harmony 15.0 Premium User Guide

NOTE
This does not change the default canvas size and pixel density for the scene. New drawings
will still be created with the scene's default canvas size and pixel density.
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Using Colours with Bitmap Layers
Contrary to vector layers, colours used in bitmap layers are not linked to their swatch in your scene's palette.
Therefore, if you update a colour in your palette, this new colour will be updated in the drawings in your vector
layers, but your bitmap layers will remain intact. Hence, it is important to know exactly the colours you wish to
use before your start painting on a bitmap layer.
Because bitmap layers are not linked to your colour palettes, this adds extra flexibility when painting on a
bitmap layer. Although you are still able to use the colour swatches from your colour palette, you can also pick
any other colour and paint right away with it, without having to create a colour swatch for it in your palette.
Hence, when a bitmap layer is selected, the Colour view lists your palettes and their swatches, but it also
features an extra panel, Bitmap Colour, which allows you to create a colour on the go.

NOTE
The Bitmap Colour panel only allows you to create solid or semi-transparent colours. If you wish to
use a gradient or bitmap texture in a bitmap drawing, you must still create a colour swatch for it in
one of your scene's palettes.
By default, the bitmap colour sliders allow you to pick a colour by choosing its Hue, Saturation and Value. These
sliders are referred to as the HSV Sliders. If you prefer, you can also pick your bitmap colour by choosing its
Red, Green and Blue values, by switching to the RGB sliders .

How to change between HSV and RGB sliders
1. Do one of the following:
l

Right click on the Bitmap Colour panel and select either HSV Sliders or RGB Sliders.

l

Open the Colour View menu

and select Colour > Bitmap Colour

Sliders > HSV Sliders or RGB Sliders.
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Painting with Gradients or Textures on Bitmap Layers
When drawing on a vector layer, each stroke is its own vector drawing object, and can be manipulated
independently at any time unless you flatten or group your strokes together. When drawing on a bitmap layer,
most modifications are immediately merged into the artwork, making it a single bitmap drawing that can only
be drawn on, painted on or erased. One exception to this rule is when you paint a zone with a gradient or
texture.
When using the Paint tool to fill a zone in a bitmap layer with a gradient or texture, a temporary vector object
in the shape of the fill is created, and contains the fill. This allows you to use the Edit Gradient/Texture tool on
this vector shape to tweak your gradient or texture so that it has the intended position, angle and scale. Then,
the next modification you make to your bitmap layer—be it with a drawing tool, or by pasting artwork—will
cause the gradient/texture to merge with your artwork, making it no longer possible to tweak it with the Edit
Gradient/Texture tool from that point on. Hence, it is important to make sure your gradients or textures look
exactly as you intend them to before continuing to work on your drawing.
NOTE
Certain tools, such as the Text or Cutter tool, will not cause your gradient/texture to merge with
your artwork.
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Manipulating Bitmap Artwork
T-ANIMPA-002-014
Since bitmap artwork is stored as color information for each pixel, scaling your artwork requires Harmony to
resample it. This means that if you scale up your artwork, it is liable to lose picture quality. Furthermore, since
Toon Boom bitmaps are embedded in a rectangular canvas, you cannot select a part of your bitmap with the
Select tool to transform it. With Toon Boom bitmaps, the Select tool is only able to select the entire canvas. If
you want to transform a part of your bitmap drawing, you must use the Cutter tool to cut out the part you wish
to manipulate.
However, artwork that you manipulate is not immediately resampled. This is to make sure you can manipulate
your artwork in multiple steps before it is merged into your artwork again, allowing to preserve as much of its
quality as possible. While manipulating your artwork, it temporarily becomes an object that is separate from
your bitmap canvas. Then, it is merged back into your canvas and resampled to match its pixel density when
you perform your next drawing operation on it.
In the following example, a circle is scaled down. Then, when zooming in on it, it appears to have preserved all
its precision. R ight after drawing a short stroke right next to the edge, it is sampled down to match the layer's
pixel density:

Likewise, if bitmap artwork is scaled up, it will be resampled after a drawing operation is performed on it. In this
example, the artwork is scaled up and looks pixelated. Once a stroke is drawn next to it, Harmony resamples it,
and creates the missing pixels so that it does not look pixelated:
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Changing Art Modes
Whether a layer is a bitmap or a vector layer is decided when creating it. However, it is also possible to change
the art mode for an existing layer.
If you convert a vector layer to a bitmap layer, the artwork will not be immediately converted, but it will be
automatically flattened and rasterized into a single bitmap image if you make any modifications to your artwork
using drawing tools.
If you convert a bitmap layer into a vector layer, the existing bitmap artwork will become a single drawing
object, which you will be able to manipulate with the select tool or cutter tool, but which you won't be able to
draw over, erase or repaint. However, you can convert it to a vector rectangle with its artwork as its texture
using the Convert Drawings to Match Layer Type command. It will still not be possible to edit the actual
artwork, but you will be able to draw or erase over it, as well as tweak the contour of its canvas.
If you want to actually vectorize a bitmap layer's artwork into vector outlines, see Vectorizing Bitmap Artwork.

How to change the art mode
1. Open the Layer Properties view.
2. In the Timeline view, select the layer you want to edit.
3. In the Layer Properties view, select the Drawing tab.
4. In the Art Layers section, select the whether the art mode should be Vector or Bitmap for each art
layer.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, Line
Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay Art
Layers on page 559.

5. In the Timeline view, right-click on the layer and select Convert Drawings to Match Layer Type.
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A message box appears informing you of how many drawings were converted.
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Vectorizing Bitmap Artwork
It is possible to convert artwork in a bitmap layer into vector outlines, which you can then edit and paint using
Harmony's vector drawing tools. This procedure takes the bitmap drawing in the layer's line art layer, then
converts it to vector outlines and inserts them into a vector drawing layer, which you must create as your
destination layer for the vectorization.
NOTE
To do this, your bitmap drawing you should be line art only, and it should be in your drawing layer's
line art layer.

How to vectorize a bitmap drawing
1. In the Timeline view, create a new vector drawing layer, and make sure it is listed right below your
bitmap drawing layer. If it is not, drag and drop the vector drawing layer below the bitmap drawing
layer to reorder it.

2. On the right side of the Timeline view, select all the bitmap drawings you vectorize, along with the
frames in the vector layer which should serve as a destination for the vectorized images.

3. Right-click on the selected frames, then select Drawings > Vectorize Line Art in Selected Drawing.
The Convert to Vector Drawing dialog box opens.

4. In the Vectorization section, select a vectorization preset. Among the default presets, you can select
Black and White if you wish to make crisp, vector only outlines, or Grey if you wish to preserve your
line art's texture. You can customize your own preset using the Add or Edit buttons.
5. Click OK.

390

Chapter 3: Drawing

Your bitmap drawing layer's line art is vectorized and inserted into your vector drawing layer.
6. Click on the Enable/Disable Layer

icon next to your bitmap drawing layer to hide your bitmap

line art and see your vectorized line art.
NOTE
For this functionality to work, your selection must absolutely have frames from a bitmap
drawing layer on top, and frames from a vector drawing layer in the bottom, and nothing else.
Otherwise, an error message indicating how to use this feature will appear.
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Setting the Default Art Mode for New Layers
You can configure Harmony to create drawing layers with specific art modes for each art layer using the
Preferences dialog.

How to adjust the art mode settings in the Preferences dialog box
1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Harmony Premium >
Preferences ( macOS ).
2. Select the Node View tab.

By default, drawing layers have two art layers: Line Art and Colour Art. If your Support Overlay and
Underlay Arts preference is enabled, your drawing layers will have four art layers: Overlay Art, Line
Art, Colour Art and Underlay Art. For more information, see Enabling Overlay and Underlay Art
Layers on page 559.

3. In the Layer Drawing Options section, set the art layers to the desired art mode. Once this option is
enabled, all new layers will follow these settings. It will not affect any existing layers.
4. Click OK.
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Chapter 4: Colours
T-ANIMFX-003-001
Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some
other software only allow users to work with one colour swatch at a time, painting in Harmony is done by using
palettes containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the
painted zones. This way, you can change the look of your character at any time without having to repaint it!
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Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the
mood and atmosphere of the scene without having to repaint each element.
It is also possible to use colour swatches from palettes in bitmap drawings, although changing the colours in the
palettes will not automatically update colours used in bitmap layers. Likewise, it is possible to create drawing
layers with bitmap line art and vector colour art, all with the same palettes —see About Art Layers on page 555
and Creating Colour Art from Line Art on page 561.
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About Colour Swatches
T-HFND-006-017
You can use several different types of colour swatches, including solid colour, gradient colour and bitmap
texture swatches.

A colour palette is an actual file on the hard drive.
In Harmony Server, these palette files can be stored in a different location on the server. They can be stored in
the Environment, Job, Scene, or Element folder and linked to any palette list. This means that if the original
palette file is modified, it will update in every drawing element the palette is linked to.
In Harmony Server, to avoid accidentally modifying the palette, the palette files can be locked. If a palette must
be modified, you must get the rights to modify them before doing so.
In Toon Boom Harmony, when you add a swatch, it is created using the colour of the currently selected swatch
from your palette. However, you can set a default colour to be used every time you create a new colour in your
colour palette. This is useful for creating different shades of the same basic colour.
The default colour is also the colour used when you choose to vectorize images you're scanning into your scene,
however you add the Default colour swatch to your palette in a different way, so it's unique. It has a unique ID
number that makes it easily recognizable from all the other colours in your colour palettes. Being able to change
this colour allows you to change the basic colour of all scanned drawings. This can be useful on more than just
an aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create
problems.
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Locking and Unlocking the Colour List
In Harmony Server, you can lock and unlock the colour list to avoid modifying or modify the colour swatches.

How to lock and unlock the colour list
1. In the Colour view, click the Edit Palette Mode

button.

A grey pencil icon appears in the top-right corner of the Palette list.
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Adding a Colour Swatch
T-HFND-006-017A
You can add as many colour swatches as you want in your palette.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to add a solid colour swatch
1. In the Colour view, click the Add Colour

button.

2. Do one of the following to edit the colour swatch:
l

From the Colour view menu, select Colours > Edit.

l

Double-click on the colour swatch.

The Colour Picker window opens.

3. To set your colour, do one of the following:
l

Select either Red, Green, Blue, Hue, Saturarion of Value to change the colour wheel's
spectrum, then click on the desired colour in the colour wheel.
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l

Enter the hue, saturation, value, red, green and blue values manually into their
corresponding fields. All values range from 0 to 255.

l

Click the Dropper

button to select any colour on your screen. It can be from the

Harmony interface, your operating system or any other open application.

You can also click Multi Wheel Mode to open the Multiwheel Colour window. This displays all the
picking area styles together and also contains a picking undo list. To return to the regular Colour
Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. Rename the colour swatch in the Colour Picker window or directly in the colour list by doubleclicking on its name.
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By default, when you create a new colour swatch, its colour will be the same as the currently selected colour
swatch, or black if no colour swatch is selected. You can make Harmony create new colour swatches with a
specific default colour instead.

How to change the default swatch colour for all your colour palettes
1. Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences (macOS).
2. In the Preferences dialog box, select the Drawing tab.
3. In the New Colour Pots section, select the Create New Colour Pots Using the Default Colour
option. You can also click the colour swatch beside the option to change the default colour.
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Adding a Gradient Colour Swatch
T-HFND-006-017B
You can transform any colour swatch into a linear or radial gradient.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to create a gradient colour swatch
1. In the Colour view, select a colour to modify .
2. Do one of the following:
l

Click the new colour and from the Colour View menu, select Colours > New.

l

Double-click on the colour swatch.

The Colour Picker window opens.
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3. Select the Gradient option.
4. Select the Linear or Radial option.
5. In the Gradient slider, create your gradient:
l

To change one of the colours of your gradient, select a key colour from the gradient slider,
then pick its colour in the colour picker.

l

To add a key colours to your gradient, click anywhere on the colour slider, between the
existing key colour.

l

To delete a key colour, use the mouse to pull down on it.

l

To move a key colour's position in the gradient, use the mouse to drag it left or right.
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NOTE
To learn how to reposition the gradient zones in your drawings, see About the Edit Gradient
and Texture Tool on page 500.
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Adding a Texture Colour Swatch
T-HFND-006-017C
You can add bitmap texture colour swatches to your palette. This allows you to fill zones in your artwork with
custom patterns and textures.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to create a texture colour
1. From the Colour menu, select Colours > New Texture or click the New Texture

button.

The Browser window opens.
2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.
The texture is added to the colour list.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool
instead of plaid, just update the texture file in the swatch and the entire project updates. Any
transformation previously applied to the texture’s position in your drawings will be kept.
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NOTE
To learn how to reposition the textured zones in your drawings, see About the Edit Gradient
and Texture Tool on page 500.
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Copying and Pasting Colours
When you're creating palettes, you may want to copy colour swatches or their values and paste them in other
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour
swatch in a different palette.
You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch
from.
If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to copy and paste colours
1. In the Colour view, select one or more colours to copy.
l

In the Colour view, click the Edit Palette Mode
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2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C
(macOS).
3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V
(Windows/Linux) or ⌘ + V (macOS).
l

To paste the colour values of the copied swatch over an existing colour swatch, select
Colours > Paste Colour Values.

How to clone a colour swatch
1. In the Colour view, select the colour swatch you want to clone.
l

In the Colour view, click the Edit Palette Mode

button to edit the colour list.

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C
(macOS).
3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.
4. From the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.

How to copy a colour ID
1. In the Colour view, select the colour swatch you want toget the ID from.
l

In the Colour view, click the Edit Palette Mode

button to edit the colour list.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or
⌘ + C (macOS).
3. Paste the copied value as plain text in the desired document.
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Deleting a Colour Swatch
T-ANIMPA-003-007
You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will
be displayed in red and the system will try to recover them the next time you load the scene.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to delete a colour swatch
1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:
l

From the Colour View menu, select Colours > Delete.

l

Click the Delete Colour

l

Right-click and select Delete.

l

Press Del.

button.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.
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If you delete colour swatches already in use, the zones painted with them turn red so you can easily
identify them.
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Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to replace a texture swatch
1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click Open to update the colour swatch.
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Replacing Colours and Textures in Drawings
T-H15NEW-004-001
Although it is always possible to change colours and textures in existing drawings by updating the swatch in
the palette, there may be situations where you want to replace a colour or texture in your drawings with a
different colour or texture swatch, without updating the existing swatch. For example, you may want to only
replace a colour with a different colour in specific drawings, but not in all the drawings that use the original
colour, or you may want to replace a colour with a colour from a different palette without changing your
palettes.
Using the Recolour Drawing dialog, you can replace all instances of a colour or texture used in your drawings
with a different colour or texture swatch. This will actually change the colours or textures from within the
drawings, without making any changes to your palette. You can perform this operation on the currently
selected drawing, on all drawings in the current layer or in all drawings in your scene.

How to recolour drawings
1. First, make sure one of the palettes in your scene already has a swatch containing the colour or
texture you want to replace the original colour with—see About Colour Swatches on page 395,
About the Edit Gradient and Texture Tool, Adding a Texture Colour Swatch on page 404 and
Adding a Pencil Line Texture on page 213.
2. In the Timeline, Xsheet or Node view, select the drawing or drawing layers you wish to recolour.
NOTE
You can select multiple layers if needed.

NOTE
You can skip this step if you intend to recolour all the drawings in your scene.
3. In the Colour view, click on Show Colour Palettes
texture, or on Show Pencil Texture Palettes
click on Show All Palettes

if you want to replace a colour, gradient or

if you want to replace a pencil texture. You can also

.

4. In the Colour view, select the colour or texture swatch you want to replace by doing one of the
following:
l

Select the palette in which the colour or texture swatch is located, then select the swatch you
wish to replace.

l

If the drawing in the Camera or Drawing view contains the colour or texture you want to
replace, select the Dropper

tool in the Tools toolbar, then click on that colour or texture in
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the drawing. The Colour view will automatically select that colour or texture's palette as well
as that colour or texture's swatch.
5. Do one of the following:
l

Right-click on the swatches list, then select Recolour Drawings.

l

Open the Colour view menu

, then select Colours > Recolour Drawings.

The Recolour Drawings dialog appears.

6. In the Replace Colour In panel, select whether you want to replace the selected colour in the Current
Drawing, in All drawings in the selected layers or in All drawings in the scene.
7. In the palette list in the Replacement Colour panel, select the palette that contains the colour or
texture swatch you want to replace the original colour or texture with.
8. In the swatches list, select the colour or texture swatch you want to replace the original colour or
texture with.
9. Click OK.
A dialog displays showing the progress of the recolour operation. When finished, the original colour
or texture is replaced with the replacement colour or texture in your drawing.

413

Harmony 15.0 Premium User Guide

Protecting Colours
T-ANIMPA-011-006
When you are finished inking one colour, you can lock it so if you ever paint over it accidentally, the work
already done will not be affected. You can also use the Protect Colour feature to block the filling colours if you
painted all of the animation in Line Art and you plan to repaint the lines.
When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you can protect
In the Colour view, you can protect a colour swatch to avoid repainting or unpainting the zones linked to that
swatch. If you using the Paint tool and this option is deselected, you will repaint or unpaint the protected
colours on your drawings until you enable the option again.

How to protect colours
1. In the Colour view, select the colour to be protected.

2. Do one of the following:
l

Right-click and select Protect Colour.

l

From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

How to enable the Respect Protected Colours option
1. Do one of the following:
l

In the Paint tool properties, click the Respect Protected Colour

l

From the top menu, select Drawing> Colour Protection > Respect Colour Protection.

l

Press Shift + S.
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Changing the Colour Display Mode
The Colour view has two display modes:
l

List

l

Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes
1. From the Colour View menu, and do one of the following:
l

Select Colours > Swatch Mode to display the swatches.

l

Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values
l

From the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The
gradient colour swatches will be identified as (gradient).
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About Palettes
T-ANIMPA-003-001
In animation, specific colours are used to paint each part of each character. In order to maintain absolute
consistency, a base colour palette should be created for each character, prop and effect in the production. This
is referred to as a master palette.
Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of
red, green, blue and opacity (the latter which is referred to as alpha).
Using a master colour palette has many benefits, including:
l

Each character consistently retains their dedicated colours.

l

You cannot accidentally use a colour which is not in the master palette.

l

Standardization and colour consistency throughout the production.

l

Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and
consistency in the painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, and so on.
When you modify the colour of an existing swatch, it automatically updates all the zones painted with this
swatch throughout the entire scene. The colour swatch has a unique ID number that associates it with the
painted zones. This way, you can change the look of your character at any time without having to repaint it!
Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain
using colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night
scene. Using palettes linked to your character in this way allows you to instantly change its colouring to suit the
mood and atmosphere of the scene without having to repaint each element.
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About Advanced Palette Management
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created in Harmony,it is stored in your scene's palette-library subfolder by default, and linked to your
scene's palette list. However, Harmony has advanced palette management features that allow you to store and
manage your palettes in manners that may better serve your production's needs. This is called Advanced
Palette Lists mode. To enable these features, you must enable the Advanced Palette Lists preference.
The Advanced Palette Lists mode unlocks two features that can be very useful, especially for a big production:
l

Palette location: While palette files are stored in a scene's palette library directory by default, you can
choose to store palettes in different locations, allowing you to easily share palettes between different
scenes in a Harmony Server database.

l

Palette list type: Whereas palettes are usually added to a scene's palette list, making them available to
all the elements in your scene, you can also choose to add palettes to the palette list of individual
elements (layers) in your scene.

When the Advanced Palette Lists mode is enabled, Harmony open a dialog called the Palette Browser
whenever you want to create, import, clone, duplicate or link to a palette, which allows you to decide your
palette's location and palette list type.

To use advanced palette lists, it is important to understand the difference between a palette's location and a
palette list's level. For example, it is possible to add a palette file stored in a scene's palette library folder to an
element's palette list. This can be useful if you wish to have the same palette file used by several specific
elements in your scene, without copying it in the palette library folder of each element that uses it. The reverse
is possible: You can add a palette file stored in an element's palette library folder to a scene's palette list,
making the palette usable for all the elements in the scene, even if it is stored inside a single element's folder.
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Enabling the Advanced Palette Lists Mode
Advanced Palette Lists mode is disabled by default to avoid cluttering a basic workflow with too many options,
but it enables palette management capabilities that are very useful for big productions. Mainly, this preference
allows you to:
l

Create palettes inside a scene's environment, job or element palette-library directory, instead of the
scene's palette-library directory. Storing a palette at the environment or job level can be especially
useful if you want to use the same palette in several scenes without creating dependencies between
animation scenes and colour model scenes.

l

Create palettes for specific elements instead of the entire scene. You can do this by adding, importing or
linking to a palette in an element's palette list. A palette in an element's palette list can only be used by
that element.

You can set up the Advanced Palette Lists option in the Preferences panel.

How to set the Advanced Palette Lists mode
1. Do one of the following:
l

From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium
> Preferences (macOS).

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. Select the Advanced tab.
3. In the Advanced Options section, select the Advanced Palette Lists option.
4. Click OK.
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About Scene and Element Palette Lists
By default, you can only add palettes to a scene's palette list. With the Advanced Palette Lists preference
enabled, you can choose to store add palettes to the palette list of individual elements if you choose. Here is an
explanation of the two different levels of palette lists:
l

Scene palette list: This palette list and its palettes are available for and can be used in all of the scene's
elements. Hence, it is the most simple and least restrictive approach, and is the type of palette used by
Harmony when Advanced Palette Lists mode is disabled. It is most recommended to add your palettes
to your scene's palette list if you are doing digital animation, where character models can be made of
many different elements that must use the same palette.

l

Element palette list: A palette list associated with a single element in your scene. An element is the
container for the drawings used by a drawing layer. Hence, when an element has a palette list with its
own palettes, only the drawings in that element can use the colours in these palettes, and the palettes
in this element's palette list will only be shown in the Colour view when a drawing from this element is
selected.

Using element palette lists as certain advantages, depending on your type of production:
l

In paperless and traditional animation projects, characters are usually drawn on single elements. Hence,
you can use this to associate characters in a scene to their colour palette.

l

If a scene requires a lot of palettes, linking those palettes only to elements that need them rather than to
the whole scene can help declutter your palette list.

l

When a palette and its clone are in the scene's palette list, Harmony will only use whichever palette is
highest in the list. If you want one element to use the original palette and another element to use the
cloned palette, you can do so by adding the right palette to each element's palette list.
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About Palette Storage Locations
Palettes can also be stored in four different locations. The best location to store palettes depends on the type of
production, the purpose of the palette, your pipeline and your backup plan. Here is an introduction to each type
of palette location and their purpose:
l

Element: The palette-library folder inside an element's folder in the scene. This is the recommended
location if you are adding palettes to the palette lists of individual elements.

l

Scene: The palette-library folder inside the scene's folder. This is the default location when creating a
palette in the scene's palette list, and is the location chosen by Harmony when creating a palette with
the Advanced palette Lists preference disabled. This is a suitable location to store the palettes of
characters, props and backgrounds used in a single scene, a small project, or any production that uses
Harmony Stand Alone.

l

Job: For Harmony Server, this is the palette-library folder inside the job's folder on the database server.
This is the recommended location if you want to share the same palette between several scenes in the
same job, like for characters, props and backgrounds that are used in across entire episodes or smallerscale projects.

l

Environment: For Harmony Server, this is the palette-library folder inside the environment's folder on
the database server. This is the recommended location if you want to share the same palette between
several scenes in the same environment, like for characters, props and backgrounds that are used across
an entire series or movie.

It is actually possible, but not recommended, to use palettes that are from a different job or environment. For
example, if you wish to store a colour model's palette in the colour model's scene, you can make animation
scenes that user this character link to the palette in the colour model's scene. However, this means your scene
will depend on the colour model's scene and its palette being available at this location to render its colours. If
the colour model's scene is moved or deleted, or if you export the animation scene and import it in another
database, it will not be able to retrieve the palette. Hence, you would have to export the colour model along
with the animated scene, and import it into the other database. If you were to store the colour model's palette
in its element folder, this would have the same restriction, with the added risk of breaking links to the original
palette if the character model's element is renamed. However, if you are sure that the structure of your
Harmony database will remain static and available at all time and at all steps of your production, then you can
store your palettes in whichever job or environment you see fit.
Another reason why it is better to store shared palettes in a scene's job or environment is because, when you
export a Harmony scene, you can choose to export the palettes in the scene's job or environment palette
libraries along with it. These palettes are then stored with the exported scene and, when importing the scene
back into the database, you can choose to import the job and environment palettes that were exported with it
back into the scene's job and environment.
Even in Harmony Stand Alone, you can store palettes at the job or environment level, even though Harmony
Stand Alone scenes do not have a job or an environment. When you do this, palettes are stored inside a
provisional jobs or environments directory inside the scene directory. If you import your scene to a Harmony
Server database, you can choose to import the files located in that scene's provisional job and environment into
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the scene's job and environment. Hence, when using Harmony Stand Alone, you should only store palettes at
the job or environment level if you intend to import your scene in a database later.
If you wish, you can also link a palette from any location on your machine or network to a palette list. This can be
useful if you have are doing a project in Harmony Stand Alone, and want all your scenes to source their palettes
from the same location. However, it is not recommended to do this with Harmony Server projects, as opening a
scene linked to an external palette on a different workstation will require that palette to be in the same file
path as on the workstation where the palette was linked.
NOTE
In Harmony Server, even if you store palettes in a job or environment, they will not become
immediately accessible to the scenes inside that job or environment. You must still add them to the
scene's palette list, or to the palette list of one of its elements, before you can use the palette.
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About Exporting Palettes
It is important to understand what is happening to a palette file when the scene is exported.
Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in
the database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or
Environment level. The palette files can be accessed from any scene of any project.
When you export scenes from Harmony to either archive or send them to other users or studios, you can choose
to export it with palettes stored in the scene's own job or environment, but if your scene uses palettes stored in
other jobs, environments, or in any other location, those palettes will not be exported. Hence, if you wish to use
the same palette for several scenes, it is recommended to store that palette at the environment or job level to
avoid ever facing a situation where a scene no longer has access to its palette.
For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from
Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2.
If Scene 2 was linked to any of these, the system will create a recovery palette the next time Scene 2 is opened
in another Harmony system.
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About Backing Up and Recovering Palettes
Although Harmony Server opens palettes in read-only mode by default, there is always the possibility of
palettes that are shared between scenes getting modified or their swatches getting deleted by accident. That
is why it is a good idea to copy and back up your palette libraries, your master palette directories and your
colour models.
If you open a scene and a palette file happens to be missing, it will still appear in the palette list for that scene or
element, with a strike through across its name.

When Harmony attempts to load a drawing that uses colours from a missing palette, or colours that were
removed from their palette, it will display the zones painted with the missing colours in red. Then, it will prompt
you to recover the missing colours into a recovery palette. A recovery palette is based on the colour information
which Harmony stores in each drawing as a backup mechanism. This palette is stored at the scene level, and is
not shared or sourced externally.
Whether you choose to perform colour recovery or not, your artwork will preserve the colour IDs which
Harmony uses to associate brush strokes, pencil lines and filled zones with the colour swatches in your palettes.
Hence, if you recover your original palette, you can just import or link it back to your scene—and remove the
recovery palette, if you have one—and Harmony will automatically associate your artwork with the original
palette again. You will not have to repaint your drawings.
You can backup your palettes by copying them manually using your operating system's shell, or by cloning
them using the Palette Operations dialog. In both cases, the palette preserves the colour IDs, making it easy to
replace a missing palette with its backup. For more information on the Palette Operations, see Palette
Operations on page 456.
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About the Palette List
T-ANIMPA-003-006
A palette list is a file containing all of the links to the palette files. Each scene created has its own palette list.
However, it is also possible to assign palette lists to individual layers in a scene. To be able to do that, you must
first enable Advanced Palette Lists mode—see Enabling the Advanced Palette Lists Mode on page 419.
l

Scene Palette List
The scene palette list is simple to understand and convenient. Every element in your scene can use
colours from a palette in your scene's palette list. This is especially useful for digital animation, as a cutout character model will often be divided into dozens of different layers which will all use the same
palette.

The scene palette list is stored inside the scene's directory in a file named PALETTE_LIST, and its
palettes are usually located in the scene's palette-library subfolder.
l

Element Palette List
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An element palette list is a list of palettes that is associated to an individual layer (element) in your scene.
Only the drawings inside that element are able to use the colours in the palettes of its element palette
list. The palettes in an element palette list will only be visible in the colour view when a drawing from
that element is selected. This can be useful if you are doing traditional animation in which characters are
usually drawn on a single layer, so you can assign each character to their individual palette.

An element's palette list is stored in a file named PALETTE_LIST, inside the element's directory in the
scene's elements subdirectory. An element's palettes can be stored in palette-library
subdirectory of the element's directory.
If you have the Advanced Palette List preference enabled, then you can build a palette list by creating palettes
in different locations, or linking to palettes from different locations. You might notice that the icon left of each
palette in the list looks different depending on where the palette is sourced from. The following is a table
explaining the meaning of each icon in the list.
Icon

Description
Indicates that the palette is stored at the same level as its palette list. For example, a palette that is stored
in the scene's palette library and which is listed in the scene's palette list, or a palette that is stored in an
element's palette library and which is listed in that same element's palette list.
Indicates that the palette file is stored in an external location, such as a different scene, an element in a
different scene, a job other than the scene's job, an environment other than the scene's environment, or a
custom location on your file system or network. This means the palette is liable to be missing if it is
moved from its original location, or if the scene is exported from the database into an offline scene or to a
different database.
This indicates that the palette is stored at a higher level than its palette list, making it a shared palette. For
example, a palette in your scene's palette list that is stored in the palette library of the scene's job or
environment, or a palette in an element's palette list that is stored in the palette library of the scene.
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Indicates a potentially dangerous situation. For example, a palette file that is stored in one of the scene's
element folders, but which is added to your scene's palette list. The whole scene can use the palette, but
since it's stored inside an element, deleting that element will make your whole scene lose access to that
palette.
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Showing and Hiding the Palette List
By default, the palette list is enabled. If you want to only use one palette for all of your scenes, you can disable
the palette list simply by collapsing it, which will give more vertical space to your colour swatch list:

How to show or hide the palette list
1. In the Colour view, right over the palettes list, click on the expand/collapse arrow to expand or
collapse the palettes list.
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Locking and Unlocking the Palette List
In Harmony Server, palette lists are open in read only mode when loading a scene. This is to prevent users from
accidently removing palettes. To create, link to, reorder or remove palettes, you must first unlock your scene's
palette list.

How to lock and unlock to the palette list
1. Do one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option
is checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.
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Displaying Colour and Pencil Texture Palettes
Besides regular colour palettes, Harmony also supports pencil texture palettes. A pencil texture can be
combined with a colour to create pencil lines of various styles, ranging from styles reproducing traditional
drawing tools such as chalk or felt to simple patterns like dots and circles. For more information, see About
Pencil Line Textures on page 199.
By default, the Colour view only lists colour palettes in its palette list. You can make the Colour view list only
pencil texture palettes, or all types of palettes.

How to change the palette list's filter to show colour palettes, pencil texture palettes, or
both
1. In the Colour view, do one of the following:
l

If you only want to only see colour palettes, press the Show Colour Palettes

l

If you only want to see texture palettes, press the Show Texture Palettes

l

If you want to see both types of palettes, press the Show All Palettes

button.
button.

button.

NOTE
If you open the Link Palette dialog, it will only list either colour palettes or pencil texture palettes,
depending on which filter is currently applied to the palette list. If the palette list is set to display all
palettes, the dialog will list the type of palettes of the last palette list filter that was used.
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Creating a Palette
T-ANIMPA-003-002
You can create a palette in either Basic or Advanced mode.
By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the
Basic mode. This setting stores the palettes automatically for you and saves them at the Scene level. When you
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes:
Environment, Job, Scene, or Element.To enable Advanced Palette Lists, see Enabling the Advanced Palette
Lists Mode on page 419.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to create a new palette (Basic palette list mode)
1. Do one of the following:
l

In the Colour View, click the New Palette

button over the palette list.

l

From the Colour view menu, select Palettes > New

The Create Palette dialog box opens.
2. In the Create Palette dialog, enter the new palette's name. Make sure your palette name contains
information to be easy to identify, such as the name of the character and information about the type
of setting for this palette, if any.

3. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you want
to create a pencil texture palette—see About Pencil Line Textures.
4. Click OK.
The palette appears in the drawing element’s palette list.
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How to create a palette (Advanced palette list mode)
1. If you want to add the palette to an element's palette list, select a drawing from the element for
which you want to create a palette in the Timeline, Xsheet or Camera view.
2. Do one of the following:
l

In the Colour View, click the New Palette

button over the palette list.

l

From the Colour view menu, select Palettes > New

The Palette Browser dialog box opens.

3. In the Palette Location panel, select the location where you want to store the palette file. If you are
using Harmony Server, you can store the palette in any environment, job, scene or element on your
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element,
or inside its provisional job or environment. For more information, see About Palette Storage
Locations on page 421.
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4. In the New Palette Name field, enter the name for the new palette. The palette list above this field
lists the palettes that already exist in the selected location. Make sure you enter a name that is not
already used by another palette.
5. Set the Palette Type to Colour if you want to create a colour palette, or to Pencil Texture if you want
to create a pencil texture palette—see About Pencil Line Textures.
6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.

7. Click OK.
The new palette appears in the palette list.
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Linking a Colour Palette
T-ANIMPA-003-004
Linking a palette means adding a palette to your scene's palette list, or to an element's palette list, without
making a local copy of that palette in your scene's palette library. This means your scene will depend in this
palette remaining in its location in order to render its colours, but it allows you to reuse the same palette files for
several scenes, making sure that recurring characters and objects keep their original colours across a
production and that any late change done to their colour scheme can be quickly reflected across all your scenes.
In Harmony Server, environments, jobs, scenes and elements can all have their own palette library, and you can
link to a palette from the palette library of any environment, job, scene or element in your database. However,
to make it easier to ensure scenes do not lose access to their palettes, it is recommended to only link to palettes
from within the scene's own environment, job, scene or elements. The most important reason for this is that if
you export a scene that uses palettes from other jobs, environments, scenes or elements, these palettes will not
be exported. Hence, they will be missing if you import them in a different database. However, you can export a
scene with all of its assets along with the assets contained in its own job and environment.
You can also link to palettes from any location on your machine or network, but this is not a recommended
approach for Harmony Server projects, as your scene will require the palette to be in the same file path if you
open it on a different workstation—see Linking to an External Palette on page 436.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to link a colour palette
1. If you want to add the palette to an element's palette list, select a drawing from the element for
which you want to create a palette in the Timeline, Xsheet or Camera view.
2. Do one of the following:
l

From the Colour View menu, select Palettes > Link.

l

Right-click and select Link.

l

Click the Link Palette

button.

The Palette Browser: Link Palette dialog box opens.
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3. In the Palette Location panel, browse to the location of the palette you want to link to.
4. In the Palette list, select the palette you want to link to.
5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.
The palette appears in the Colour view.
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Linking to an External Palette
You can link to a palette from anywhere on your machine or network from within a palette list. This can be
useful if you are working on a Harmony Stand Alone project on a single workstation, and wish to source
palettes that will be used in several scenes from the same location.
NOTE
Linking to an external palette will cause your scene dependent on that palette being located in the
same location it was linked from originally. This means that your scene will be missing colors if your
palette has been renamed, moved or deleted, or if you try to open the scene on a different machine
without first copying the palette in the same location. Hence, this is not a recommended workflow
for large scale productions or for Harmony Server scenes.

NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to link to an external palette
1. In the Colour view, click on the Create Palette

button to create a palette to be used as external.

2. Save your scene by selecting File > Save from the top menu or by clicking the Save

button or

press Ctrl + S (Windows/Linux) or ⌘ + S (macOS).
3. On your computer or server, create a master directory. Ideally, this should be created in your Root
folder to keep it within the project directory. You could also place it inside your Colour Model’s
subdirectory.
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4. Name the folder appropriately, for example: Joe_master_palette.
5. From your operating system, browse to your Toon Boom Harmony scene and open the palettelibrary folder.

6. Select and copy your palette *.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene, or open the scene in which you want to link the palette.
8. If you want to add the palette to an element's palette list, select a drawing from the element for
which you want to create a palette in the Timeline, Xsheet or Camera view.
9. From the Colour View menu, select Palettes > Link to External.
The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to
link.
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11. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.
12. Click OK.
The linked palette appears in the Colour view, with the External
is located outside of your scene's structure.
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Importing a Colour Palette
T-ANIMPA-003-005
You can import an existing palette from your file system or network into your scene. This will create a copy of
the palette file and add it to your palette list.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to import a palette into your project (Basic palette list mode)
1. Do one of the following:
l

From the Colour menu

, select Palettes > Import.

l

Right-click on the palette list and select Import.

The Browser window opens.
2. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes
by browsing to the palette-library sub-folder of the scene's folder.
3. Click Open.
The Import Palette dialog box appears.

4. In the New Palette Name field, enter the name for the imported palette.
The palette is copied to your project and added to your scene's palette list.

How to import a palette into your project (Advanced palette list mode)
1. If you want to add the palette to an element's palette list, select a drawing from the element for
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which you want to create a palette in the Timeline, Xsheet or Camera view.
2. Do one of the following:
l

From the Colour menu

, select Palettes > Import.

l

Right-click on the palette list and select Import.

The Browser window opens.
3. Browse for a palette file located (*.plt) on your hard drive. You can usually find a scene's palettes
by browsing to the palette-library sub-folder of the scene's folder.
4. Click Open.
The Palette Browser dialog box appears.

5. In the Palette Location panel, select the location where you want to store the palette file. If you are
using Harmony Server, you can store the palette in any environment, job, scene or element on your
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element,
or inside its provisional job or environment. For more information, see About Palette Storage
Locations on page 421.
6. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.
7. In the New Palette Name field, name the imported palette.
The palette is copied to your project and added to your scene's palette list.
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Renaming a Palette
T-ANIMPA-003-003
You can rename a colour palette to keep your list organized.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to rename a palette
1. In the Colour view, select the palette to rename.

2. Do one of the following:
l

Right-click and select Rename.

l

From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not
be deleted, so you can add it back to your palette list later if you need it.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to remove a palette
1. In the Colour view, select the palette to remove.

2. Do one of the following:
l

From the Colour View menu, select Palettes > Remove.

l

Right-click on the selected palette and select Remove.

l

Click the Remove Palette

button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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NOTE
If you wish to delete the palette file, you can select the Remove and Delete From Disk option from
the same menu. You will be prompt to confirm the deletion. Note that the palette will be deleted
from your file system, and there will be no way to recover it.
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Duplicating a Palette
A duplicated palette is a simple copy of the original palette. When you duplicate a palette, the duplicated
palette will have the same colour names and values, but will have different colour IDs so that Harmony does not
mix it up with its original palette. This is useful when you want to create different palettes for similar models,
but want to avoid having to create the palette and its colours all over again. You can just start with your
duplicate palette, tweak the colours and add and remove colours as needed.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to duplicate a palette (Basic palette list mode)
1. In the Colour view, select a palette to duplicate.

2. Do one of the following: From the Colour menu, select Palettes > Duplicateor right-click and select
Duplicate.
l

Right-click on the palette and select Duplicate.

l

Open the Colour menu

, then select select Palettes > Duplicate.

The Duplicate palette dialog box opens

3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is
based on the original palette name followed by "-copy". The palette list above this field lists the
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palettes that already exist in the selected location. Make sure you enter a name that is not already
used by another palette.
4. Click OK.
The duplicated palette appears in the palette list.

How to duplicate a palette (Advanced palette list mode)
1. In the Colour view, select a palette to duplicate.

2. Do one of the following: From the Colour menu, select Palettes > Duplicate or right-click and select
Duplicate.
l

Right-click on the palette and select Duplicate.

l

Open the Colour menu

, then select select Palettes > Duplicate.

The Palette Browser dialog box opens.
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3. In the Palette Location panel, select the location where you want to store the palette file. If you are
using Harmony Server, you can store the palette in any environment, job, scene or element on your
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element,
or inside its provisional job or environment. For more information, see About Palette Storage
Locations on page 421.
4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is
based on the original palette name followed by "-copy". The palette list above this field lists the
palettes that already exist in the selected location. Make sure you enter a name that is not already
used by another palette.
5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.

6. Click OK.
The duplicated palette appears in the palette list.
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Cloning a Palette
Cloning a palette creates an exact copy of the palette, where each colour swatch has the same colour ID as in
the original palette, but which you can modify independently afterward. Since painted zones in drawings are
associated to their colour by their colour ID, this means that any drawing colored with the original palette can
have its colours replaced with the cloned palette's colours just by switching the palette in the scene with the
cloned palette.
A good example of how this can be useful is when you want to make variants of a character's palette. A
character usually has only one master palette, although there are times when the characters are placed in
different lighting conditions and require a different colour shading. The night palette is a popular choice when a
scene or sequence changes from day to night. Instead of creating a different palette for the character and
repainting all of its zones with the night palette, you can just clone the character's master palette, tweak its
colours, and the character will have its original colours or its night colours depending on which one of the
palettes is in the palette list, without having to repaint your drawings.

When a palette and its clone are present in the same scene, Harmony uses the palette that is highest in the
list. If one palette clone is present in the scene's palette list and another clone is present in the element's
palette list, the element will use the palette in its own palette list.
NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to clone a palette (Basic palette list mode)
1. In the Colour view, select a palette to clone.
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2. Do one of the following: From the Colour menu, select Palettes > Clone or right-click and select
Clone.
l

Right-click on the palette and select Clone.

l

Open the Colour menu

, then select select Palettes > Clone.

The Clone palette dialog box opens

3. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is
based on the original palette name followed by "-clone". The palette list above this field lists the
palettes that already exist in the selected location. Make sure you enter a name that is not already
used by another palette.
4. Click OK.
The cloned palette appears in the palette list.

How to clone a palette (Advanced palette list mode)
1. In the Colour view, select a palette to clone.
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2. Do one of the following: From the Colour menu, select Palettes > Clone or right-click and select
Clone.
l

Right-click on the palette and select Clone.

l

Open the Colour menu

, then select select Palettes > Clone.

The Palette Browser dialog box opens.

3. In the Palette Location panel, select the location where you want to store the palette file. If you are
using Harmony Server, you can store the palette in any environment, job, scene or element on your
database. In Harmony Stand Alone, you can store the palette in the scene, inside one of its element,
or inside its provisional job or environment. For more information, see About Palette Storage
Locations on page 421.
4. In the New Palette Name field, enter the name for the new palette. By default, the palette's name is
based on the original palette name followed by "-clone". The palette list above this field lists the
palettes that already exist in the selected location. Make sure you enter a name that is not already
used by another palette.
5. In the Palette List panel, select whether you want the palette to be added to the Scene Palette List,
or to the Element Palette List of the currently selected element. Note that in the latter case, the
palette will only be usable by the element. For more information, see About Scene and Element
Palette Lists on page 420.
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6. Click OK.
The cloned palette appears in the palette list.

NOTE
You can modify your cloned palette by changing its colour swatches individually, or you can use the
Tint Panel to change all of the palette's colour swatches simultaneously—see Tinting a Palette's
Colour Swatches on page 453.
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Tinting a Palette's Colour Swatches
You can use the Tint Panel dialog to offset, blend or mix all the different colour swatches in a palette
simultaneously. This can be useful if you want to give a cloned palette a different tint, for example to make a
night-themed version of a character's master palette.

NOTE
If you are using Harmony Server, make sure you have the rights to modify the selected palette by
doing one of the following:
l

In the Colour view, make sure the Edit Palette Mode

toggle button is pressed in.

l

In the palette list of the Colour view, right-click on the selected palette and select either Get
Rights to Modify Palette or Get Rights to Modify All Palettes.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette or Get Rights

to Modify All Palettes.

How to tint a palette
1. In the Palette list, select the palette you want to tint.
2. From the Colour View menu, select Palettes > Tint Panel or right-click and select Tint Panel.
The Blend/Offset Tint panel opens.
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3. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A
(Windows/Linux) or ⌘ + A (macOS).
4. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

5. Select the Preview option to see a preview of the colours while you adjust them.
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Reordering Palettes in the Palette List
You may want your palettes to be listed in a specific order. In a lot of cases, this is strictly a matter of
convenience. However, if your palette list contains palettes that have been cloned off each other, Harmony will
use the palette that is located the highest in the list to determine the colours to use in the drawings. Hence, if
you are using cloned palettes, you must mind the order of your palettes in the palette list. For more information,
see Cloning a Palette on page 449.
NOTE
If a palette in the scene's palette list has been cloned into an element's palette list, Harmony will
use the palette in the element's palette list for this element.

NOTE
If you are using Harmony Server, make sure you have the rights to modify the palette list by doing
one of the following:
l

From the top menu, open the Edit menu and ensure the Edit Palette List Mode option is
checked

l

Right-click on the palette list and select Get Rights to Modify Palette List.

l

From the Colour view menu

, select Palettes > Get Rights to Modify Palette List

How to reorder palettes in the palette list
1. Select the palette you wish to reorder.
2. Do one of the following:
l

In the Palette list toolbar, click the Up

or Down

l

From the Colour View menu, select Palettes > Move Up or Move Down.
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Palette Operations
When you start Toon Boom Harmony connected to the database, you can access the Palette Operations dialog
box which lets you clone, rename, or delete palettes in your database, without having to open a scene or
browse the database's file system in your operating system's shell.
NOTE
The Palette Operations dialog box never makes any change to any palette list in your database. All
it allows you to do is manipulate palettes files. You should be careful not to rename or delete
palettes that are required by some of your existing scenes, or Harmony will be unable to locate
those palettes when you open one of those scenes.
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Opening the Palette Operations Dialog Box
You can open the Palette Operations dialog box in Harmony Server.

How to open the Palette Operations dialog box
1. Start Harmony and log in.
2. Close the Database Selector dialog box.
3. From the top menu, select Tools > Palette Operations.

The Palette Operations dialog box opens.
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Cloning a Palette in the Palette Operations Dialog Box
From the Palette Operations window, you can clone palettes in Harmony Server.

How to clone a palette in the Palette Operations dialog box
1. Select the palette you want to clone at the location and level in which it was stored.

2. Click Clone.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every time
you perform this operation.
4. Click Yes.
The Palette Browser dialog box opens.
5. Select the level to store the palette file.

458

Chapter 4: Colours

6. In the New Palette Name field, enter the name of your palette.
7. Click OK.
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Renaming a Palette in the Palette Operations Dialog Box
You can rename palettes in the Palette Operations dialog box in Harmony Server.

How to rename a palette in the Palette Operation dialog box
1. Select the palette you want to rename at the location and level in which it was stored.

2. Click Rename.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every time
you perform this operation.
4. Click Yes.
The Rename Palette dialog box opens.
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5. Type in a name for the palette.
6. Click OK.
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Deleting a Palette in the Palette Operations Dialog Box
You can delete palette files from the Palette Operations dialog box in Harmony Server.

How to delete a palette in the Palette Operation dialog box
1. Select the palette you want to delete at the location and level in which it was stored.

2. Click Delete.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every time
you perform this operation.
NOTE
It is not recommended to disable the warning message as deleting a palette
cannot be undone.
4. Click Yes.
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting,
and so on.
When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and
paint process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do
not belong in the drawing, extra floating artwork around the drawing that must be removed), painting the
lines and filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean,
only painting and inking.
Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning
a set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a
new colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is
known as a colour swatch—see About Palettes on page 416.
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About Colour Models
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That
drawing can be used and loaded in any of your Harmony scenes—see Painting Drawings on page 478.

Once a drawing is loaded in the Model view, you can use the Model view Dropper to select a colour from the
model and use it to paint in your Camera or Drawing view without having to pick the colour from the colour
palette.
You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the
character directly from its colour model and paste these elements into the Drawing or Camera views.
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Loading Colour Models
T-ANIMPA-004-005
You can load any TVG drawings in your Model view. To avoid browsing for models every single time you work
on your scene, you can store default models in your scene and load those.

How to load a colour model from the Timeline or Xsheet view
1. In the Timeline or Xsheet view, select a drawing (*.tvg).

2. Bring the model into the Model view by doing one of the following:
l

In the Timeline view, drag the selected drawing and drop it directly in the Model view.

l

From the Model View menu, select Use Current Drawing as Model.
NOTE
The Use Current Drawing as Model button is not part of the default Model View
toolbar. To add the Use Current Drawing as Model button to the Model toolbar,
right-click in the Model view toolbar and select Customize. Drag the Use Current
Drawing as Model

button from the Available Tools column and move it to the

right (Toolbar) column. Click OK.

l

In the Model View toolbar, click Current Drawing

button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive
1. Do one of the following:
l

In the Model View toolbar, click the Import Model

l

From the Model View menu, select Import Model.

l

Select File > Import > Colour Model.

button.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database for
Harmony Server.
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3. Click Open.
The model appears in the Model view.

How to load the default models
1. In your scene’s folder, create a new folder and name it models.
2. On your hard drive, copy the *.tvg drawing file you want to use as colour models in your scene.
3. Paste the copied models in the models folder you created.
4. Do one of the following:
l

From the Model View menu, select Load Default Models.

l

In the Model View toolbar, click the Load Default Model

button.

NOTE
The Load Default Model button is not part of the default Model View toolbar. To
add the Load Default Model button to the Model toolbar, right-click in the Model
view toolbar and select Customize. Drag the Load Default Model

button from

the Available Tools column and move it to the right (Toolbar) column. Click OK.

How to load a single drawing from the Library view
1. In the Library view, click the template containing the drawing to import in the Model view.
2. Right-click on the template and select Open As Folder.
3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders
until *.tvg files appear on the right side.
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4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.

How to load a template with multiple drawings from the Library view
1. In the Library view, find the template you want to import in the Model view.
2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.
3. Use the Previous Model

and Next Model

buttons in the Model View toolbar to view all the

drawings contained in the template. This can often be the front, profile, and 3/4 views of a
character.
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How to load a symbol from the Library view
1. In the Library view’s left side, select the Symbols folder.
2. In the Library view’s right side, select the symbol you want to use as a model, and drag and drop it
into the Model view.

3. Use the Previous Model

and Next Model

buttons in the Model View toolbar to view all the

drawings contained in the template. This can often be the front, profile, and 3/4 views of a
character.
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Clearing Colour Models
You can remove colour models from the Model view.

How to clear a colour model
l

In the Model View menu, select Clear Model or press Del.
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Flipping Between Models
T-LAY-002-001
Once your models are loaded in the Model view, you can flip through them using a keyboard shortcut or toolbar
buttons.

How to flip between models
1. Do one of the following:
l

In the Model View toolbar, click the Next Model

l

From the Model View menu, select Next Model or Previous Model.

l

Press F and G.

The previous or next model appears in the Model view.

470

or Previous Model

buttons.

Chapter 4: Colours

Copying Colour Models
You can copy pieces or the entire colour model to paste in your scene,

How to copy the entire model from the Model view
1. In the Model View toolbar, select the Select

tool.

2. In the Model view, select your model.

3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘ + C
(macOS).
4. In the Timeline view, make sure you have the correct layer and frame selected.
5. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing
Object, or select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline
or pressCtrl + V (Windows/Linux) or ⌘ + V (macOS).
The model appears in the selected view.

How to copy part of the model from the Model view
1. In the Model View toolbar, select the Cutter

tool or press Alt + T.

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you
want to copy.
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3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘ + C
(macOS).
4. In the Timeline view, make sure you have the correct layer and frame selected.
5. Do one of the following:
l

Select the Drawing or Camera view and select Edit > Paste Drawing Object.

l

Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V
(Windows/Linux) or ⌘ + V (macOS).

The model appears in the selected view.
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About Dirt Cleanup
T-INK-002-001
When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them.
These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

If there are some marks that cannot be removed with the automated tools, you can erase them with the Eraser
tool or select them with the Select tool and then delete them. It's always safer to select and delete them than to
erase them, so you do not overlook anything.
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Removing Dirt
T-INK-002-002
The Remove Dirt tool selects small dots and hairs on the drawing.
Raising the Remove Dirt level will select bigger dots. When selecting larger dots, be careful not to lose small
details like pupils and nostrils. Once you have chosen the level, you can apply it to the current drawing or the
entire animation sequence. This is a quick way to get rid of most dirt and dust.
During this process, the dirt that will be removed is highlighted in red.

How to use the Remove Dirt tool
1. Do one of the following:
l

From the top menu, select Drawing > Clean Up > Remove Dirt.

l

From the Camera or Drawing View menu, select Drawing > Clean Up > Remove Dirt.

l

Press Shift + D.

2. Increase the Remove Dirt value by moving the slider to the right.
3. Select the Apply to All Drawings option if you want to apply the operation to all drawings in the
layer.
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Removing Dirt Outside the Selection
T-INK-002-003
The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art,
it can result in large output files, especially if you work in high-definition resolutions.

How to clean dirt with Remove Art Outside Selection
1. In the Tools toolbar, select the Select

tool.

2. In the Tool Properties view, click the Permanent Selection

button.

3. Draw a selection around the animation making sure to include the entire animation sequence.

4. In the Camera or Drawing View menu, select Drawings > Clean Up and one of the following options:
l

Remove Art Outside Selection to delete artwork outside your selection on a single
drawing.

l

Remove Art Outside Selection on All Drawings to delete artwork outside your
selection on all the drawings.

The art outside the selection is removed.

475

Harmony 15.0 Premium User Guide

Removing the Art Inside the Selection
T-INK-002-004
You can delete any art inside a selection with the Remove Art Inside Selection option. We recommend that you
clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in large
output files, especially if you work in high definition resolutions.
You can simultaneously apply this operation to all your drawings in the layer by using the Remove Art Inside
Selection on All Drawings command.

How to clean dirt with Remove Art Inside Selection
1. In the Tools toolbar, click the Select

tool or press Alt + S.

2. To apply the action to your entire animation, click the Permanent Selection

button in the Tool

Properties view.
3. In the Camera or Drawing view, draw a selection around the animation. Make sure the area is large
enough to include all the zones to be cleaned up on all drawings.
4. From the top menu, select Drawing > Clean Up > Remove Art Inside Selection to delete artwork
inside your selection on one single drawing. You can also press Delete.
5. To apply the action on all your drawings in the layer, select Drawing > Clean Up > Remove Art
Inside Selection on All Drawings to delete artwork inside your selection on all the drawings.
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Removing Hair
T-INK-002-005
The Remove Hair command lets you remove any small strokes created in the Colour Art layer from very thick
lines or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the
drawing.

How to use the Remove Hair tool
1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.
2. From the top menu, select View > Show > Show Strokes to display the invisible lines or press K.
3. In the top menu, select Drawing > Clean Up > Remove Hair.
The Remove Hair dialog box opens.

4. Move the slider to the right to increase the number and length of hairs to be selected.
5. Select the Apply to All Drawings option if you want to apply the operation to all the drawings in the
layer.

6. Click OK.
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Painting Drawings
T-HFND-004-011
The main tool you will use to paint your drawings with is the Paint tool. The Paint tool can be used in several
different modes, which can be customized in the Tool Properties view.
The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines
defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap
option.
NOTE
To learn more about the Paint tool options, see the Reference guide .

How to paint drawings
1. In the Timeline or Xsheet view, select the cell on which you want to paint.

2. Do one of the following:
l

In the Tools toolbar, click the Paint

l

Press Alt + I.

tool.

In the Tool Properties view or Tools toolbar, you can select additional painting modes.
l

The Paint

mode paints everything it touches, including empty and filled zones.

l

The Paint Unpainted

mode paints only empty zones. Any line or filled zone will

remain unchanged.
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l

The Repaint

mode paints everything it touches except empty zones. Any zone

that is not painted will remain intact.

l

The Unpaint

mode unpaints everything it touches, including empty and filled

zones.

3. In the Colour view, select a colour.

4. In the Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a
lasso or marquee selection to paint several zones or pencil lines at the same time.
NOTE
The last colour you select while using the Paint tool will be used the next time you
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select the Paint tool if you're using the unlocked painting tools in the Colour view.

Authors
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Repainting
T-ANIMPA-011-004
You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.
You can repaint lines, zones, and brush strokes using the Repaint tool. The repaint pencil lines more efficiently,
see Inking Lines on page 495. The Repaint tool does not fill empty zones, even if they are closed.
If you imported and vectorized drawings, during the vectorization process on traditional scanned drawings,
triangles are added on the lines' intersections to break the artwork in segments. This way, when you paint a
line, it will not repaint the entire drawing, only the relevant segment—see Creating Break Triangles on page
490.

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint a
section by manually painting over the lines. This is useful when the vectorization triangles are not placed as you
would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, where
there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will
only show on painted areas that are already painted.
Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are not
added one on top of each other.
NOTE
To avoid repainting specific colours, see Protecting Colours

How to access the Repaint Tool
1. In the Tools toolbar, select the Repaint

tool. You can also find the option in the Tool Properties

view when the Paint tool is selected.
2. In the Camera or Drawing view, click on the zones to repaint. You can also make a lasso or marquee
selection around several zones.
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How to enable the Repaint Brush mode
1. In the Tools toolbar, select the Brush

tool.

2. In the Tool Properties view, click the Repaint Brush

button.

3. In the Camera or Drawing view, draw on the zones to repaint.
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Repainting a Selection
The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection
using the Select tool in order for this command to be available. You can also click on the colour swatch in the
colour palette to automatically repaint your selection.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the
drawings contained within the same layer. You must enable the Permanent Selection option in the Select tool
Tool Properties view and then select an area of your drawing using the Select tool in order for this command to
be available. The Permanent Selection option lets you maintain the same selection throughout the drawings of
a same layer.

NOTE
To avoid repainting specific colours, see Protecting Colours
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How to repaint a selection
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the zones to repaint.
3. To repaint the selection on all drawings, enable the Permanent Selection

option in the Select

tool Tool Properties view.
4. Do one of the following:
l

From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint
Selection or Repaint Selection on All Drawings.
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Repainting Outside a Selection
The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been
drawn using the Select tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all
the drawings contained within the same layer. You must enable the Permanent Selection option in the Select
tool Tool Properties view and then select an area of your drawing using the Select tool in order for this
command to be available. The Permanent Selection option lets you maintain the same selection throughout the
drawings of a same layer.

NOTE
To avoid repainting specific colours, see Protecting Colours

How to repaint outside a selection
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the zones you do not want to repaint.
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3. To repaint outside the selection on all drawings, enable the Permanent Selection

option in the

Select tool Tool Properties view.
4. Do one of the following:
l

From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint
Outside Selection or Repaint Outside Selection on All Drawings.
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Unpainting a Selection
The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a
selection using the Select tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all
the drawings within the same layer.
You must enable the Permanent Selection option in the Select tool Tool Properties view and then select an area
of your drawing using the Select tool in order for this command to be available. The Permanent Selection option
lets you maintain the same selection throughout the drawings of a same layer.

How to unpaint a selection
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the zones to unpaint.
3. To unpaint the selection on all drawings, enable the Permanent Selection

option in the Select

tool Tool Properties view.
4. Do one of the following:
l

From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint
Selection or Unpaint Selection on All Drawings.
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Unpainting Outside a Selection
The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection
have been drawn using the Select tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the
drawings within the same layer. You must enable the Permanent Selection option in the Select tool Tool
Properties view and then select an area of your drawing using the Select tool in order for this command to be
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a
same layer.

How to unpaint outside a selection
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, select the zones you don't want to unpaint.
3. To unpaint the selection on all drawings, enable the Permanent Selection

option in the Select

tool Tool Properties view.
4. Do one of the following:
l

From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint
Selection or Unpaint Selection on All Drawings.
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Selecting Strokes with the Current Colour
You can select zones painted with a specific colour swatch.

How to select the zones painted with the current colour
1. In the Colour view, select the colour from which you want to select the corresponding zones.

2. Do one of the following:
l

Select Drawing > Select Strokes With Current Colour.

l

Press Ctrl + Shift + A (Windows/Linux) or ⌘ + Shift + A (macOS).
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Creating Break Triangles
T-ANIMPA-011-005
The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A single
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes time
to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly become
time consuming to ink.
Toon Boom Harmony lets you create triangular breaks at line intersections. These intersections are the
probable locations where colour line breaks naturally occur, such as where a sleeve meets a hand.

How to create breaking triangles on a drawing
1. In the Drawing or Camera view, use the Select

tool to select part or all of the drawing to be

broken.

2. Select Drawing > Create Breaking Triangles. If your brush strokes are not flattened, they will be
flattened automatically before the breaking occurs.

3. Use the Repaint tool

to paint the outline of different colour zones with different colours.
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Closing Gaps
T-HFND-004-014
When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.
The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between the two
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few
millimeters away. The two closest points automatically close the gap.

How to close gaps
1. Select View > Show > Show Strokes or press K to see a preview of the result.
2. In the Tools toolbar, select the Close Gaps

tool.

3. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible.
4. Enable the Auto-Flatten

option in the Tool Properties view if you want your strokes to be

flattened with your artwork. They will cut overlapping drawing strokes in two pieces.
The gap automatically closes.

Authors
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Picking a Colour with the Dropper Tool
T-ANIMPA-011-002
While working in the Camera or Drawing view, you can use the Dropper tool to pick a colour from your drawing
without going to the Colour view.

NOTE
To learn more about the Dropper tool options, see the Reference guide .

How to use the Dropper tool
1. Do one of the following:
l

In the Tools toolbar, select the Dropper

tool.

l

From the top menu, select Drawing > Drawing Tools > Dropper.

l

Press Alt + D.

2. In the Camera or Drawing view, click on the desired colour.
l

If you're using another drawing tool such as the Paint tool, you can temporarily hold
down the D key and click in your drawing before releasing the key to pick your colour.
When you release the key, you will return to your previous tool. You may also want to
select the zones painted with the colour currently selected in the Colour view. This can
be useful for removing rough lines from a clean drawing.
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Inking Lines
T-HFND-004-012
Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint,
Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you have a drawing,
such as the one below, and you use the Paint tool to paint one of the lines, the entire line is painted.

However, if you select the Ink tool instead and click on the same pencil line, only the segment that you clicked
on between two intersections will be painted.

Painting and inking can be used in combination depending on what you need to paint. If you need to ink a
character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a
character’s neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same
continuous outline, then the Ink tool might prove more useful.
NOTE
Unless you are repainting all the lines in an entire animation sequence, do not use the Apply Tool to
All Drawings option. Since the line positions change a lot over time, you risk painting lines that
should not be painted.

NOTE
To avoid repainting specific colours, see Protecting Colours

NOTE
To learn more about the Ink tool options, see the Reference guide .
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How to use the Ink tool
1. In the Tools toolbar, select the Ink

tool located in the Paint tool drop-down menu.

2. In the Drawing or Camera view, click on the pencil lines to repaint.
l

The newly inked segment is always moved on top of all other pencil strokes, even if it
was behind all other pencil strokes before it was inked. To reverse that behaviour,
disable the Raise

l

option in the Tool Properties view.

Hold down Alt while clicking a segment to do the opposite option from the Raise mode
current state. The inked segment will be sent to the back or forward, even if it was in
front or behind all other segments to begin with.

Authors
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Verifying Painted Zones
T-ANIMPA-011-008
When the ink and paint process is completed, it's always a good idea to verify that every zone was painted
properly.
The first step to check your ink and paint is to go through all your drawings and verify that there are no colour
mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the Xsheet.
The backlight produces Produces a silhouette effect by changing the drawing’s coloured areas into a single
dark, solid colour. Use this to verify the completeness of the ink and paint process. Any unpainted zones can be
seen as the light shows through the unpainted areas of the silhouetted drawing.

How to preview drawings from the Xsheet
1. First, save your scene.
2. Do one of the following:
l

From the top menu, select File> Save.

l

Click the Save

l

Press Ctrl + S (Windows/Linux) or ⌘ + S (macOS).

button.

3. In the Xsheet view, select the range of drawings or the whole column to preview.
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4. In the Xsheet View menu, select View > Preview Selected Drawings or press Alt + P.
The Play window opens.

5. Play your drawings.
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6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence
while looping the playback.

How to use the backlight

NOTE
This feature is only available in the Drawing view.
1. Do one of the following:
l

From the top menu, select View > Backlight.

l

Press Alt + Shift + B.

2. Verify the drawings in the Colour Art to make sure that all the areas are painted. From the Camera
or Drawing View menu , select View > Switch to Colour Art or press L.
3. In the Art Layer toolbar, click the Preview All Art Layers

button to see the colour zones with

lines to ensure that you did not forget any spots between the colour filling and lines.
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About the Edit Gradient and Texture Tool
T-HFND-006-019
If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you
can select the next texture and paste the previous position to continue the modifications.
If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s
position, angle and scale settings instead of the default ones, you can store your own settings and reuse them
afterward.
This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with
textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both
elements independently at the same time.
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Using the Edit Gradient and Texture Tool
T-HFND-006-019A
You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone.

How to use Edit Gradient/Texture tool
1. Do one of the following:
l

In the Tools toolbar, click the Edit Texture

tool.

l

From the Camera or Drawing View menu, select Drawing Tools > Edit
Gradient/Texture.

l

Press Shift + F3.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Storing the Gradient and Texture Settings
You can store the position, scale, and angle of a selected gradient or texture to reuse it in other painting zones.

How to store gradient and texture settings
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Camera or Drawing view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient
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Pasting a Stored Gradient or Texture
You can apply the gradient and texture settings previously stored to paint zones with the same gradient or
texture, in the same position, scale and angle.

How to use the stored gradient and texture settings
1. In the Tools toolbar, select the Brush

or Paint

tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient
3. In the Camera or Drawing view, draw and paint.
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Editing Pencil Line Textures with the Edit Gradient/Texture Tool
You can use the Edit Gradient/Texture tool to tweak the way a texture or gradient is applied onto a pencil line.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line
1. Do one of the following:
‣

In the Tools toolbar, select the Edit Gradient/Texture

tool.

‣

From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.

‣

Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on
the top of the editor controls to stretch the tiled texture throughout the length of the stroke.
As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or
gradient.
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4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s
central vector, stretching them vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit a pencil line with both a texture and a
gradient
1. Do one of the following:
‣

In the Tools toolbar, select the Edit Gradient/Texture

tool.

‣

From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture.

‣

Press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.
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4. Use the bottom controls edit the “brush” texture.
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Chapter 5: Paperless Animation
T-HFND-006-001
Toon Boom Harmony is a powerful paperless animation software that incorporates animation and drawing
tools to make your work easier and more efficient.
Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles of
animation still apply.

One of the advantages of working with paperless animation is that you do not lose time scanning elements in
and testing them because everything is already digital. You can simply draw your animation and play back your
line test right away. This also saves the substantial amount of paper required by traditional animation. Another
practical advantage is the ability to undo and redo some actions that are often difficult on paper, such as
erasing brush strokes.
NOTE
When you draw on an empty cell, Harmony automatically creates a drawing that spans over a
single frame in that cell. You can adjust that drawing's timing as needed afterward. However, it is
possible to create, name and set the timing of each drawing before creating your animation, which
can help organize your workflow. For more information, see Timing on page 569.
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Creating a Rough Animation
T-LAY-003-005
The first step to create paperless animation is the rough construction, which is the skeleton of your animation.
You would usually start by animating the most important part of a character's action. For example, to animate a
walk cycle, you will start with the torso motion and the legs. Secondary animation such as the head, arms and
clothes can be added afterward.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the
details when you're satisfied with the movement. If you start animating all the details right away, you will lose a
lot of time if you have to make corrections, and your animation is likely to look rigid.

How to create a rough animation
1. In the top row of the Timeline view, click on Show All Thumbnails

to enable Thumbnail mode.

2. Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS) to open the Preferences dialog box.
3. Select the Exposure Sheet tab.
4. Select the Use Current Frame as Drawing Name option. When this preference is enabled, each
new drawing will be named by the frame number they are created on.
5. In the Tools toolbar, select the Brush

tool or press Alt + B.

6. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your
rough animation. This will make the clean up process easier as your clean dark lines will contrast
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with your light sketch lines.

7. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.
8. In the Camera or Drawing view, draw the first key drawing.

As soon as you draw your first stroke, a drawing is automatically created in the cell you selected.

9. Increase the Timeline view's zoom level until you see the thumbnails inside the cells by doing one of
the following:
l

Drag the Timeline Zoom

slider to the right.

l

Click on the Timeline view's tab, then press 2 repeatedly.

l

Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘ (macOS)
and roll the mouse wheel up.

511

Harmony 15.0 Premium User Guide

10. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This
will help you stay organized.
l

Enable the Mark Drawing toolbar by selecting Windows > Toolbar > Mark Drawing
from the top menu, then click on the Mark Selected Drawings as Key

l

button.

Enable the Xsheet toolbar by focusing on the Xsheet, then selecting Windows
> Toolbar > Xsheet from the top menu. Then, click on the Mark as Key Drawing
button.

l

In the Timeline view menu, select Drawings > Mark Drawing As > Key Drawing.

11. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

12. In the Tools toolbar, click the Onion Skin

button. This will display the previous and next

drawings in a light colour in the Camera or Drawing view, behind your current drawing, so that you
can use them as references to draw new drawings with accuracy. This can be useful to draw
breakdown poses between two key poses, or to add an in-between drawing between two other
drawings.
13. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing
on it. To do this, do one of the following:
l

In the Timeline view, drag the blue onion skin markers to extend the number of past
and future drawings to display as onion skin.
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l

In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous
Drawing

, Onion Skin Reduce One Previous Drawing

Next Drawing

and Onion Skin Add One Next Drawing

, Onion Skin Reduce One
buttons to adjust the

span of the onion skin frame by frame.
NOTE
When in the Drawing view, you can use the Onion Skin toolbar to make onion
skin display only specific types of drawings, such as key drawings or
breakdowns. Keep in mind that this does not work in the Camera view.
14. Create a new empty drawing by doing one of the following:
l

In the Timeline or Xsheet toolbar, click on the Create Empty Drawing

l

Press Alt + Shift + R.

15. In the Camera or Drawing view, draw your second key drawing.

16. In the Xsheet or Timeline view, identify the drawing as a key drawing.
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17. In the Timeline or Xsheet view, select a cell between the two key drawings. Using the onion skin
markers, ensure the onion skin covers both your first and last drawings.

18. Create a new empty drawing by doing one of the following:
l

In the Timeline or Xsheet toolbar, click on the Create Empty Drawing

l

Press Alt + Shift + R.

button.

19. In the Camera or Drawing view, draw your new pose.

20. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new
drawing.
NOTE
When working with overlay layers in the Camera view, you can enable the Current Drawing
on Top

option to make the layer you're working on appear over other layers.
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Creating the Tie Down Animation
Once your rough animation is correct, you can start adding extra details, such as arms, clothes or hair. You can
add the extra details on the same layer with the same colour or you can also create a new colour so that you can
always see your original sketch.

If your primary and secondary animation were done as a rough drawing, it is now time to put your drawing on
model, also known as tie down. This means that you have to review your animation and ensure that every
single detail is on model and there is no volume distortion. You can do this directly on the original sketch layer
or on a new layer.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing element
and use the Light Table feature to draw over the first drawing element. This technique can also be used if you
want to reuse your rough animation for other characters. For example, if you have a rough walk-cycle, you can
reuse it for another character and add its personal features in a new layer. This way, you only need to animate
the secondary animation instead of the whole body again.
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How to create secondary animation on the same layer
1. In the Xsheet or Timeline view, select the cell in which you want to add new details.
2. In the Colour view, create a new colour (give it the same name and add the prefix _2 or _sec, for
example) or select the same rough colour as before.
3. In the Drawing Tools toolbar, select your drawing tool.
4. In the Camera or Drawing view, draw the secondary animation.

5. Do one of the following:
l

In the Xsheet or Timeline view, select the next cell in which you want to draw.

l

Press F and G to navigate between your drawings.

6. Do one of the following:
l

Select View > Onion Skin > Show Onion Skin.

l

In the Timeline view menu, select Onion Skin > Show Onion Skin.

l

Press Alt + O.

7. Extend the onion skin.
8. In the Camera or Drawing view, draw the secondary animation.
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9. Use the Flip and Easy Flipping toolbars to review your animation—see the Flip and Easy Flipping
toolbars in the Reference guide.

10. You can also use the Playback toolbar to play the animation in real time.

How to create your secondary animation on an extra layer
1. Add a new drawing layer and name it secondary_animation.
2. In the Timeline or Xsheet view, select the rough layer's timing.
3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘
+ B (macOS).
4. Choose Never create drawing files from the options to paste the timing but not the drawing files.

5. If you are working in the Drawing view, in the Drawing View toolbar, enable the Light Table.
6. In the Xsheet or Timeline view, select the cell where you want to add the new details.
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7. In the Colour view, create a new colour (give it the same name and add the prefix _2 or _sec, for
example) or select the same rough colour as before.
8. In the Tools toolbar, select your drawing tool.
9. In the Drawing or Camera view, draw the secondary animation on top of your rough drawing.

10. Do one of the following:
‣

In the Xsheet View, select the next cell in which you want to draw.

‣

In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

11. Do one of the following:
l

In the top, Drawing View or Camera View menu, select View > Onion Skin > Show
Onion Skin.
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l

In the Timeline view menu, select Onion Skin > Show Onion Skin.

l

Press Alt + O.

12. Extend the onion skin.
13. In the Camera or Drawing view, draw the next secondary animation.
14. Use the Flip and Easy Flipping toolbars to review your animation—see the Reference guide .

15. You can also use the Playback toolbar to play the animation in real time.
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Cleaning Animation
T-HFND-006-010
When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It
consists of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless
animation step before the ink and paint step.

You will need to add a new drawing layer to create your clean drawing. This is the equivalent of adding a sheet
of paper and tracing the rough using the animation disk. This allows you to keep the roughs and the cleans
intact. You only need to lock the rough layer to prevent it from appearing in the scene.
If you plan on tracing your animation in the Drawing view, use the light table to display all the layers in your
project.

How to trace animation in a new layer
1. In the Layer toolbar, click the Add Drawing Layer
2. In the Timeline view, click the Lock

button and add a new layer.

button of the layer containing your rough animation to avoid

selecting the layer in the Camera view.

3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key
drawing of your rough animation.
4. In the Tools toolbar, select the drawing tool of your choice. The Pencil

tool is recommended.

5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, would
ensure that it contrasts well with the light colour of your rough animation.
6. In the Camera or Drawing view, start tracing the first key drawing.
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7. If you have some other layers in the way, you can disable them temporarily from the Timeline view
so that only the rough animation and clean-up layer are displayed in the Camera view.
8. In the Tools toolbar, click the Onion Skin

button and pull on the blue onion skin handles in the

Timeline view to extend the number of frames you can see.
9. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing
Onion Skin Reduce One Previous Drawing
Onion Skin Add One Next Drawing

, Onion Skin Reduce One Next Drawing

,

and

buttons to adjust the span of the onion skin frame by frame.

10. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
11. In the Drawing or Camera view, trace your next drawing.
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12. Repeat the previous steps for each drawing.
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Paperless Animation Tools
To understand paperless animation, you must first discover the tools available. There are, of course, drawing
tools, but also practical features such as setting a drawing as a key, breakdown or in-between.
When you create hand-drawn animation digitally, there are certain tools you require in order to work
efficiently, as you would with an animation table, paper and pencils.
The onion skin and light table are used to preview previous and next drawings, cells, elements and frames.
When designing or animating, it is very useful to see your previous drawings. Just as if you were building a cutout puppet, you want to view other drawing elements to know where to draw the new element.
Harmony has many useful advanced features such as the Flipping toolbar, enhanced onion skin, extra drawing
layers, and automated matte generation.
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Displaying Drawing Thumbnails in the Timeline View
T-ANIMPA-006-003
In the Timeline view, it is possible to preview the drawings in your scene by enabling the display of thumbnails
for your drawing layers. You can display the thumbnail for all drawing layers or for individual drawing layers.
This allows you to preview the drawing in the current frame as well as drawings exposed in every frame of your
scene, which can be useful for managing your drawings and for adjusting their timing.

You can enable Thumbnails for all drawing layers simultaneously or for individual drawing layers. When
thumbnails are displayed for a layer, the Timeline view also displays the name of each drawing as well as the
amount of frames on which each drawing is exposed for that layer. Enabling thumbnails on a layer also gives
access to that layer's Opacity parameter in the left panel of the Timeline view.

How to display or hide thumbnails for all drawing layers
1. In the Layers toolbar of the Timeline view, click on the Show/Hide All Thumbnails
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How to display or hide thumbnails for a specific drawing layer
1. Do one of the following:
l

In the Timeline view, left of the layer's name, click on the Show/Hide Thumbnails

l

In the Timeline view, select the layer and press T.

button.

Even when thumbnails are displayed for a layer, it is likely that you won't be able to see the full thumbnails for
individual drawings that are exposed over 1 or 2 frames because, by default, frames are not large enough to
display their thumbnails. To make the frames larger so that thumbnails have enough horizontal space to be
displayed, you must zoom in on the Timeline view.

How to zoom in on the Timeline view.
1. Set the focus on the Timeline view, for example by clicking on the Timeline view tab.
2. Do one of the following:
l

Drag the Timeline Zoom

slider to the right.

l

Click on the Timeline view's tab, then press 2 repeatedly.

l

Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘ (macOS)
and roll the mouse wheel up.
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TIP
If you animate mostly on twos or threes, you can adjust the Timeline zoom to fully display the
thumbnails of drawings exposed over two or three frames, or you can zoom in enough to
display the thumbnails of drawings exposed over a single frame, depending on your
preference.

TIP
To reset the Timeline Zoom to its default zoom level, click on the Reset Zoom

icon left of the

Timeline Zoom slider.

NOTE
When zoomed in on the Timeline view, you can tweak the exposure of your drawing by dragging
the edges of the drawings with your mouse cursor. This is especially useful when displaying
thumbnails as you can visually adjust the timing of your animation. For more information, see About
Rippling and Overwriting the Exposure in the Timeline View.

526

Chapter 5: Paperless Animation

About the Onion Skin
The Onion Skin tool lets Lets you preview the previous and next drawings. By default, the previous drawings
appear in a shade of red and the next drawings are displayed with a shade of green. You can change these
colours in the Preferences dialog box.
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Enabling the Onion Skin
T-ANIMPA-006-008
You can enable the onion skin to see your previous and next drawings as reference,
NOTE
You can modify the onion skin display in the Preferences panel.

How to enable the onion skin
1. Do one of the following:
l

From the top menu, select View > Onion Skin > Show Onion Skin.

l

In the Timeline view, click the Onion Skin

l

In the Tools toolbar, click the Onion Skin

l

Press Alt + O.

button on a layer.

button.

Blue arrows appear on both sides of the play head.
2. Drag the blue arrows to add more frames to the onion skin display.
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Displaying Marked Drawings in the Onion Skin
In the Drawing view, you can set up your onion skin to display marked drawings only, in the same way that you
flip through your drawings marked as key, breakdown or in-between drawings—see About Marked Drawings
on page 533

How to display marked drawings in the onion skin
1. From the top menu, select Windows > Toolbars > Onion Skin.

2. In the Tools toolbar, click the Show Onion Skin

button.

3. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the
onion skin preview.

4. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing
Onion Skin Reduce One Previous Drawing
Onion Skin Add One Next Drawing

, Onion Skin Reduce One Next Drawing

,

and

buttons to adjust the span of the onion skin frame by frame.

5. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.
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Displaying the Onion Skin in the Other Layers
T-LAY-003-006
You may need to see the onion skin for the other layers previous and next drawing. The Light Table option in
the Onion Skin toolbar allows you to do that.

How to enable the onion skin in other layers
You might need to refer to previous and next drawings in other layers than the current one. In the
Drawing view, use the Enable Onion Skin in Other Elements feature to see the previous and next drawings
of the layers visible in Light Table mode.
1. In the top menu, select Windows > Toolbars > Onion Skin.

2. In the Tools toolbar, click the Onion Skin
3. In the Drawing view, click the Light Table

button.
button.

4. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the
onion skin preview.

5. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing
Onion Skin Reduce One Previous Drawing
Onion Skin Add One Next Drawing

, Onion Skin Reduce One Next Drawing

,

and

buttons to adjust the span of the onion skin frame by frame.

6. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements
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l

The current layer is displayed by default in shades of green and red.

l

Drawings in timeline layers above the current layer are displayed by default in shades
of blue.

l

Drawings in timeline layers below the current layer are displayed by default in shades
of yellow.
NOTE
You can change the default onion skin display colours in the Preferences dialog
box.

532

Chapter 5: Paperless Animation

About Marked Drawings
T-HFND-006-004
When working with several animators, directors or even other studios, the necessity for retakes will often arise.
Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or Retake
In-betweens. In the Xsheet view, you can identify drawings as Key, Breakdown or In-between.

About the Key Drawing
A key drawing is a visually significant pose in a movement, often an extreme position. For example, if a
character that is sitting down falls on his back, the key poses would be the character sitting and the character
on his back. Of course, it may vary from one animation to another.

About the Breakdown Drawing
A breakdown drawing is a pose somewhere between two key poses that better shows the movement. Most
animation moves are arcs, such as an arm waving, somebody bending, or a leg walking. All of these movements
are rotations. The breakdown pose is used to describe this curve better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. These
actions can be a big stomach jiggle as somebody jumps, a cloak floating behind somebody that is running, or
arms moving after the main body action. These moves will generally have a different timing than the primary
action. They will mainly start later and finish later. So, the breakdown drawings are used to complete the key
drawings.
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Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often be closer to
one or the other depending on the timing and the action. Also, you can have more than one breakdown pose
between two keys.
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Marking Drawings
T-HFND-006-004A
You can mark your drawings as Key, Breakdown, or other custom marks.

How to mark a drawing as Key, Breakdown or In-between
1. From the top menu, select Windows > Toolbars > Mark Drawing.
The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline
view.
3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing
Breakdown Drawing

or Mark as In-between Drawing

, Mark as

. In the Xsheet menu, you can also

select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing,
Retake Key, Retake BD and Retake IB.
l

If you selected Mark as Key Drawing, a

icon appears in the cell.

l

If you selected Mark as Breakdown Drawing, a

l

If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since
it is used to remove a Key or Breakdown marker.
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Creating Custom Markers
If your production requires you to mark drawings with a custom marker, you also have the option to create your
own.
Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of
code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing toolbars, but
also in the Onion Skin and Flip toolbars.

NOTE
You can create custom shortcuts for the Drawing Identification options in the Preferences dialog
box.

How to create custom markers
1. With a bitmap editing software, create the following icons in PNG format:
l

Mark Drawing Toolbar icon (24 x 24 pixel)

l

Onion Skin Toolbar icon (24 x 24 pixel)

l

Flip Toolbar icon (24 x 24 pixel)

l

Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.
3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder.
l

Windows:
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l

Toon Boom Harmony Premium: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon Boom
Harmony\full-1200-pref\drawingTypes.d

l

Toon Boom Harmony Advanced: C:\Users\[user_
name]\AppData\Roaming\Toon Boom Animation\Toon Boom
StageAdvanced\full-1200-pref\drawingTypes.d

l

macOS:
On macOS, the Library folder is a hidden folder. To display the display the folder, told
down the Alt key.
l

Toon Boom Harmony Premium: /Users/[user_
name]/Library/Preferences/Toon Boom Animation/Toon Boom
Harmony/full-1200-pref/drawingTypes.d

l

Toon Boom Harmony Advanced: /Users/[user_
name]/Library/Preferences/Toon Boom Animation/Toon Boom Stage
Advanced/full-1200-pref/drawingTypes.d

l

GNU/Linux:
l

/home/user_name/Toon Boom Animation/Toon Boom Harmony/full1200-pref/drawingTypes.d

l

/home/user_name/Toon Boom Animation/Toon Boom
StageAdvanced/full-1200-pref/drawingTypes.d

In Harmony Server, the path is global for all users so you must create the folder and place in /USA_
DB.
l

/USA_DB/drawingTypes.d
NOTE
If the drawingTypes.d folder does not exist, you must create it. To do so, copy the
resources folder from the following location.
l

Windows: Start > Programs > Harmony 15.0 Premium

l

macOS: Applications > Toon Boom Harmony 15.0Premium > resources >
drawingTypes.d

l

GNU/Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_
64/bin/Stage/resources/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.
5. In the same directory, open the drawingTypes.xml file in a text editor.
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6. For each custom icon you want to create, add the following line. Make sure to place it before this
closing tag: </DrawingTypes>.
l

<DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png"
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:
l

NewButtonName: Write the name of your new marker. This name will appear in the
button tooltip.

l

XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet
column. Include the file extension.

l

MarkDrawingIcon.png: Write the name of the icon that you created to appear in the
Mark Drawing toolbar. Include the file extension.

l

FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar.
Include the file extension.

l

OnionIcon.png: Write the name of the icon that you created to appear in the Onion
Skin toolbar. Include the file extension.

8. Save the file and close it.
9. Start Harmony.
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About the Drawing Desk
T-ANIMPA-008-002
You can work on a portion of an animation sequence or specific drawings from different layers. To do this, select
the segment needed in one or more layers in the Xsheet or Timeline view and then use the drawing desk to
allow you to work only on these drawings.
This can be useful went you need to reposition drawings, use the Shift and Trace feature, paint multiple
drawings at once, or apply the same transformation to drawings for different layers—see About Shift and
Trace on page 544.
The Drawing Desk is only available in the Drawing view.
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Adding Drawings to the Drawing Desk
T-ANIMPA-008-004
You can send drawings your selected in the Xsheet view to the drawing desk. You can also send new drawings
to an existing set in the Drawing Desk.

How to send several drawings to the drawing desk
1. Do one of the following:
l

In the Xsheet or Timeline view, select a consecutive cell range from one or several
layers.

l

In the Xsheet view, hold down Ctrl (Windows/Linux) or ⌘ (macOS) and click on any
cell to add it to the selection, even if it is not consecutive.

2. Do one of the following:
l

In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

l

In the Xsheet view, right-click and select Send Drawings to Desk.

l

In the Xsheet view, hold down the Alt key and click on the selection.

The drawing desk opens on the side of the Drawing view.
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NOTE
The drawing desk is by default on the left side of the Drawing view. You can change its
positioning in the Preferences dialog box.
3. If the drawing desk side panel is hidden, click the Arrow button, located on the left side of the view.

How to add more drawings to the drawing desk
1. In the Timeline or Xsheet view, select the drawings to be added.
2. Do one of the following:
l

In the Timeline or Xsheet view menu, select Drawings > Add Drawings to Desk

l

Alt + click the selection.
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Modifying Thumbnails in the Drawing Desk
For your convenience you can modify the way the thumbnails are displayed in the Drawing Desk.

How to clear drawings and send new ones to the drawing desk
1. Select a new drawing in the Timeline or Xsheet view.
2. In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.
The previous drawing desk selection is removed and replaced with the current selection.

How to change the size of drawing desk thumbnails
l

Right-click the drawing desk and select No Thumbnail, Small Thumbnail, Medium Thumbnail or
Large Thumbnail.

How to change the position of a thumbnail in the drawing desk
1. In the drawing desk, select the thumbnail.
2. Click the Move Drawing Up

and Moving Drawing Down

buttons as needed, to move it to the

new position in the drawing desk.

How to clear selected or all drawings from the drawing desk
1. In the drawing desk, select one or more drawings to remove.
2. Do one of the following:
l

Right-click the drawing desk and select Remove Selected Drawings or Remove All
Drawings.

l

In the Drawing view, press Esc to remove all drawings.
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About Shift and Trace
T-ANIMPA-008-003
When hand drawing animation, it is very important to stay on model as it is easy to lose the proportions or
features of a character. The Shift and Trace feature lets you temporarily move a drawing so you can trace it on a
new drawing. This is similar to animators working on an animation light table and using an entire character or
cut-out pieces of a character and moving it underneath the new drawing to trace it.
Your drawings will not be modified. It will only be moved, rotated or scaled in the Shift and Trace mode. When
you turn off this mode, the repositioned drawing returns to its normal state.
If you use the Shift and Trace feature frequently, you can assign custom shortcuts for Shift and Trace operations
in the Preferences dialog box—see the Preferences guide.
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Enabling Shift and Trace
T-ANIMPA-008-005
You need to send drawings to the Drawing Desk and enable the Shift and Trace option to be able to use it—
see About the Drawing Desk on page 540.

How to enable the Shift and Trace mode
1. Go to the Drawing view.
2. In the Tools toolbar, click the Show Onion Skin

button—see Paperless Animation Tools.

3. Send the selected drawings to the drawing desk—see About the Drawing Desk on page 540.

4. In the Drawing Desk toolbar, click the Shift and Trace Enable
Registration marks appear at the bottom of your drawings.
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Shifting Drawings
T-ANIMPA-008-006
Once the Shift and Trace option is enabled, you can use the controls to shift the drawings. This does not modify
your original drawings.

How to shift
Using the shift and trace manipulator, you can move the registration marks to reposition selected drawings
while you work.
1. In the Drawing Desk toolbar, click the Shift and Trace Manipulator

button.

At the bottom of the Drawing view, a window displays a zoomed in view of the manipulator. You
can move the dividing line between the manipulator and the Drawing view to resize the area.

2. In the Drawing view, transform the drawing as needed, positioning it between your two key poses.
l

To reposition, click and drag the drawing to a new area.

l

To rotate from the centre peg, click the flat peg hole and rotate.
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l

To scale, pull or push on the triangle control.

l

To show the pivot point, hold Alt. The pivot point is in the middle of your current
drawing view. To rotate from the pivot point, hold Alt and rotate.
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l

To scale from the pivot point, hold Shift and move your cursor.

l

Click and drag the pivot point to move it to a new position. Once the pivot point is
moved, you can hold Alt and move your drawing to show it again.

3. To select another drawing and reposition it, hold down Ctrl (Windows/Linux) or ⌘ (macOS).
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4. If necessary, click the Shift and Trace Reset

button to reset the position of the modified drawing.
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Tracing Drawings
T-ANIMPA-008-007
You can trace your new drawings once you shifted the reference artwork.

How to trace
1. In the drawing desk, select the drawing into which you want to trace.

2. Select the check box next to the drawing you want to allow to be temporarily transformed. By
default, all drawings are enabled for Shift and Trace operations.

3. Select the drawing you want to move.

4. If you want to trace more than one drawing at the same time, you can link them together. In the
drawing desk, select several drawings and click the Link Drawings
together—see Tracing Drawings.
5. In the Tools toolbar, select a drawing tool.
6. In the Drawing view, trace your drawing.
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Linking Drawings in the Drawing Desk
T-ANIMPA-008-008
When using the Shift and Trace feature, you can link different drawings from the drawing desk, so they move
together when dragging or scaling. These drawings can be from different columns in the Xsheet view.

How to link your shift and trace drawings
1. In the drawing desk, display the drawings you want to use for the Shift and Trace operation.
2. Hold down Ctrl (Windows/Linux) or ⌘ (macOS) and select the drawings you want to link together.
3. In the Drawing Desk toolbar, click the Link Drawings

button to enable linking.

Coloured boxes appear beside drawing thumbnails to identify different linked drawing groups.
A link icon appears beside the currently selected drawing and all drawings linked to it.

4. Shift your linked drawings.
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5. To unlink your drawings, select one of the linked drawings and click the Link Drawing

button

again to disable it.
6. You can shift your drawings independently.

7. To unlink your drawings, select one of the linked drawings and click the Link Drawing
again to disable it.

553

button

Harmony 15.0 Premium User Guide

Enabling the Drawing Desk Onion Skin
You may end up with a lot of drawings in your onion skin display while working with the Shift and Trace
feature. You can disable individual drawings from the onion skin display without deactivating them.

How to enable and disable individual onion skin drawings
1. In the Tools toolbar, click the Onion Skin

button.

2. In the Drawing Desk, click on the drawing’s Onion Skin
enabled, the icon's

colour changes .
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About Art Layers
T-RIG-005-000
Art layers give you the possibility to divide the artwork in your drawing on different layers. For example, you
can separate the outline and colour fill on two art layers, similar to 1950s traditional cell animation. These art
layers are contained within a single drawing as opposed to the layers in the Timeline view or Xsheet columns
where individual drawings with individual timing are stacked one on top of the other—see About Art Layers on
page 555.

Toon Boom Harmony drawings include four art layers.
l

Overlay on page 556

l

Line Art on page 556

l

Colour Art on page 557

l

Underlay on page 557

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour Art are
displayed. You need to enable the Support Overlay and Underlay Arts option in the Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and facilitate
creation and revision.
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Overlay
The Overlay layer can serve multiple purposes:
l

Highlights and tones

l

Annotations and corrections

l

Sketching
You can also draw in the Overlay layer as it's a regular layer.

Line Art
In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The outline is
drawn in the Line Art layer and colour is painted in the Colour Art layer.
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Colour Art
In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line
Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are generated from Line Art to
contain the painted area.

When you are doing rough animation, you may want to send a clip for feedback or approval before carrying on
with your work. If you have several characters in your project that are overlapping, it may be difficult to
understand what is going on as you can see through the characters. Toon Boom Harmony can generate a
matte automatically in the Underlay, or even in the Colour Art layer, and fill all the zones inside your characters
to make them opaque. This process is fast and easy, and allows you to send easy-to-understand movies.

Underlay
The Underlay layer can serve multiple purposes. It is frequently used by animators to sketch rough animation or
generate a matte colour when doing line testing.

557

Harmony 15.0 Premium User Guide

Separated Lines and Colours
A drawing is composed of line and colour filling layers. Lines and colours can be separated or kept together,
depending on which animation process you use. The following diagram presents Line Art and Colour Art layers
recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the Line Art
when drawings are vectorized unless you specified otherwise.
When working with Cut-out animation, we recommend that you do all of the work in the Line Art.
Once the drawing sequence is completed for paperless drawings, you can proceed with creating Colour Art
strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from Line Art option to
create strokes from your lines.
You can create strokes in the Colour Art during the following stages:
l

After the full drawing is completed in Line Art

l

While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to patch gaps.
Use the Auto-Create Colour Art from Brush option to create the strokes at the same time as the lines are
drawn. This creates strokes from the lines and brush strokes created in the Line Art while you draw and is
useful for fixing drawings. However, if you are drawing a new sketch, it is better to create the strokes afterward
using the Create Colour Art from Line Art option.
NOTE
Make sure to select the Advanced Art Mode in the Preferences dialog box to use this feature.
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Enabling Overlay and Underlay Art Layers
T-LAY-002-004
By default, the Overlay and Underlay art layers are disabled to simplyify the workflow. You can enable the
support of those additional art layers in the Preferences panel.

How to enable the Support Overlay and Underlay Arts option
1. Select Edit > Preferences ( Windows/Linux ) or Harmony Premium > Preferences ( macOS ).
2. In the Preferences dialog box, select the Advanced tab.
3. In the Advanced Options section, select the Support Overlay and Underlay Arts option.
4. Click OK.
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Switching Between Art Layers
T-RIG-005-000A
You can use the Art Layers toolbar and keyboard shortcuts to switch between art layers.

How to switch between drawing layers
1. In the Art Layer toolbar, click the Line Art

or Colour Art

buttons. When switching art layers,

you can edit the select layer without affecting the other one.

2. Click the Preview All Enabled Art Layers

button to display all layers together. Even when the

Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You
will only be able to see the selected art layer by itself if you enable the Current Drawing on Top
option located in the Camera bottom toolbar.
NOTE
To edit both Line Art and Colour Art at the same time, you must enable the Apply
to Line Art and Colour Art

button in the Tool Properties of the tools

supporting the operation.

How to switch between the drawing layers in Advanced Art mode
1. In the Art Layer toolbar, click the Overlay Art

, Line Art

, Colour Art

or Underlay Art

buttons to display the appropriate layer—see How to enable the Support Overlay and Underlay
Arts option on page 559. When switching art layers, you can edit the selected layer without
affecting the other one.

2. Click the Preview All Enabled Art Layers

button to display all the layers together. The other ones

are only displayed as a reference. By default, the Preview mode is always enabled in the Camera
view. You can view only the selected art layer if you select the Current Drawing on Top
the Camera bottom toolbar.
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Creating Colour Art from Line Art
T-RIG-005-000B
Lets you use the outline you traced on one of the four embedded layers (line art, colour art, overlay, underlay)
and create invisible strokes to paint your drawings on separate layers. This provides more inking and painting
flexibility.
You can also configure this option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones from the Line Art layer
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, click the Permanent Selection

button if you want to apply the

operation on all drawings in the layer.
3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection
around the entire animation sequence if you want to apply the operation to all your drawings.
4. In the Drawing View toolbar, click the Create Colour Art from Line Art

button or press *.

How to create strokes with the Create Colour Art Automatically option
1. In the Tools toolbar, select the Brush tool.
2. In the Tool Properties view, enable the Create Colour Art Automatically

option.

3. Draw the required lines.
4. Once you're done, deselect the Create Colour Art Automatically

option.

You are now ready to paint.

How to configure the Create Colour Art from Line Art option
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view or the Drawing View toolbar, Shift + click the Create Colour Art from
Line Art

button.

The Configure Line Art to Colour Art dialog box opens.
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Parameter

Description

Use rendered version of the
drawing

Renders the drawing and vectorize it to calculate the position of the
centreline that will produce the colour art stroke.

Maximum Resolution for
rendered image

The size of the rendered image.

Threshold for rendered image

The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered

This value represents how precise the fitting of the colour art zone in relation

Beziers

to the line art will be.

Source layer

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want
the colour art to be created from.

Destination layer

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want
the colour art to be created on.

Clear Destination Art Layer
First

Deletes the content before the colour art is added. This is useful when you
already have artwork on the destination layer.

Perform Line Art to Colour
Art Operation Immediately

Performs the Create Colour Art from Line Art command when you click OK.
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Generating a Matte
T-ANIMPA-006-013
You can quickly generate a matte to be displayed behind your rough animation so you don't see the
background through the drawings. It can be generated in any art layer.

How to generate a matte
1. Do one of the following:
l

In the Tools toolbar, select the Select

l

Press Alt + S.

tool.

2. In the Camera or Drawing view, select the drawing you want to create a matte for.
NOTE
You can also apply the operation to all the drawings in the layer at the same time.
3. Do one of the following:
l

From the top menu, select Drawing > Generate Auto-Matte.

l

In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to All
Drawings option.
5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower
value, the closer to your lines’ contours the matte will be shaped. The higher the value, the looser
the matte will be shaped.

563

Harmony 15.0 Premium User Guide

6. In the Source Art menu, select the layer from which you want the matte created: Line Art,Colour
Art, Underlay or Overlay.
7. In the Destination Art menu, select the layer on which you want the matte to be created: Line
Art,Colour Art, Underlay or Overlay.
8. If you already have artwork on the destination layer and you want the content to be deleted before
the matte is added into it, select the Clear Destination Art First option.
9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you
ever need to keep them for later), select the Copy Stroke in Destination option.
10. Click OK.
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Flipping Animation
T-ANIMPA-006-010
Using the Easy Flipping toolbar, you can rapidly flip through drawings in the Drawing view, just as you would
with paper drawings in traditional animation.

How to use the Easy Flipping toolbar
1. Switch to the Drawing view.
2. In the top menu, select Windows > Toolbars > Easy Flipping to enable the Easy Flipping toolbar.

3. In the Easy Flipping toolbar, click the Previous

or Next

button to see the previous or next

drawing of your animation.
4. To display drawings in the first frame after you reach the last frame of your animation, select the
Loop option.

5. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

The further you move the slider to the left or right, the faster the drawings will flip.
6. In the Preroll field, enter the amount of drawings to automatically flip through before and after the
current drawing.
7. In the FPS field, enter the speed at which you would like to automatically flip through your drawings,
in frames per second.
8. Click on the Easy Flip button

to automatically flip through the drawings based on the Preroll and

FPS settings.
By default, the Flipping toolbar will flip through all drawings in the range specified in its Preroll field. Optionally,
you can use the Flip toolbar to only flip through certain types of drawings, such as key drawings or
breakdowns, provided that you marked these drawings as such prior—see About Marked Drawings.
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How to use the Flip toolbar
1. In the top menu, select Windows > Toolbars > Flip.

2. Click on the corresponding button for each type of drawing you wish you flip through:
Icon

Drawing Type

Key Drawing

Breakdown

In-between (Unmarked drawings)

Retake-Key

Retake-Breakdown

Retake-In-between

The Easy Flipping toolbar will only flip through drawings marked with the enabled drawing types.
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NOTE
If no drawing types are selected in the Flip toolbar, the Easy Flipping toolbar will flip through all
drawing types.
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Previewing and Playing Drawings
It is a good idea to preview your drawings to check your animation's ink and paint, verify that there are no
colour mistakes, or to play your animation in real time. You can do this by scrolling through your drawings or
pressing F and G. You can also use the Preview option in the Xsheet view.

How to preview drawings from the Xsheet view
1. Save your scene.
2. Do one of the following:
l

From the top menu, select File > Save.

l

Click the Save

l

Press Ctrl + S (Windows/Linux) or ⌘ + S (macOS).

button.

3. In the Xsheet view, select the range of drawings or the whole column to preview.
4. Open the Xsheet view menu

and select View > Preview Selected Drawings.

The Harmony Play application opens and loads the selected drawings.
5. In the Play window, press the Play

button to play back your drawings.

6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence
while looping the playback.
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Chapter 6: Timing
When you create hand-drawn animation traditionally or in a paperless environment, it's important to know
how to set and modify the timing of your drawings.

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure
sheet created by the animator. In a paperless workflow, the animator creates and manages their own exposure
sheet directly in Harmony without the need for reproduction.
If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital
animator, you may prefer to work with a timeline to visualize your timing. Harmony offers both.
The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn
animation. You can set the animation sequence's exposure and name the drawings.
The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.
You can adjust timing in both views; your choice depends on which technique you're accustomed to using.
Depending on your working style, some actions may seem preferable to do in one view instead of another.
Many of the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often
show both techniques. You can choose which one you prefer.
In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation
paths for symbols are covered in separate chapters.
NOTE
The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters
and parts, but is not really needed for animation and timing. If you plan to work with cut-out
animation, you can still learn useful tips by reviewing the section on exposure sheets.
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About Scene Length
In Harmony, the length of each scene is determined by the amount of frames it contains. You can calculate the
amount of frames your scene requires based on the amount of time it should span over with the formula, in
which l is the scene's length, s is the amount of seconds your scene requires, and fps is the scene's frame rate.
l = s × fps
Likewise, a scene's length in seconds can be calculated with the reverse formula:
s = l ÷ fps
By default, scenes created in Harmony are 60 frames in length. At 24 frames per second, this makes a scene of
2½ seconds in length. You should set your scene's length based on how much time you plan for it to require
after creating your scene so you can plan your animation based on the scene's length. However, it is possible to
adjust your scene's length at any time. You can also insert or remove frames at any point in your scene.
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Setting the Scene Length
T-HFND-007-007
You can set the scene length by entering its exact amount of frames or by adjusting its length using the scene
length bracket in the Timeline view.

How to set the scene's length in frames
1. Select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to modify the scene length in the Timeline view
1. In the ruler of the Timeline view, click and drag the red scene length bracket and move it to the left
to shorten the scene or to the right to extend the scene.
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Adding Frames in the Middle of a Scene
You can add frames to your scene before or after the currently selected frame(s). All of your scene's animation
before or after the selection will be offset by the amount of frames you added.

How to add frames to the middle of a scene
1. In the Timeline or Xsheet view, select a frame or a range of frames.

2. Do one of the following:
l

From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames
After Selection.

l

In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add
Frames After Selection.

l

In the Xsheet toolbar, click the Add Frames

button to add frame after your selection.

l

Press Ctrl + G (Windows/Linux) or ⌘ + G (macOS) to add frames before the selection, or Ctrl
+ H to add frames after the selection.

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the amount of frames to add to the scene.
4. Click OK.
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Adding Frames at the Beginning of a Scene
You can add frames at the beginning of your scene using the Add Frames at Start dialog. All of your scene's
animation will be offset by the amount of frames you added.

How to add frames at the start or end of a scene
1. In the top menu, select Scene > Frames > Add Frames at Start.
The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.
3. Click OK.
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Adding Frames at the End of a Scene
You can add a set amount of frames at the end of your scene using the Add Frames at End dialog.
NOTE
You can also extend your scene's length by entering its total length or by manipulating the scene
length bracket in the Timeline view—see Setting the Scene Length on page 571.

How to add frames at the start or end of a scene
1. In the top menu, select Scene > Frames > Add Frames at End.
The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames to add to the scene.
3. Click OK.
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Removing Frames from a Scene
It is possible to remove frames from your scene. Your scene will be shortened by the amount of selected frames,
and all the animation after the selection will move back to close the gap.

How to remove a frame or a range of frames in the Xsheet view
In the Xsheet view, you can remove any selected frame range, such as the last frame.
1. In the Xsheet view, do one of the following:
l

Select a frame in a given column.

l

Select a frame range by clicking the first frame’s number and then dragging the
selection highlight down to the last frame to delete.

2. To delete the selected frames, do one of the following:
l

From the top menu, select Scene > Frame > Remove Selected Frames.

l

Press Del to delete the selection.

l

Click the Remove Frames

button. To remove several frame selections, click the

button repeatedly.
If you selected a range of frames, the Warning dialog box may open.
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3. To complete the operation:
l

Click Yes to delete the selection.

l

Click No to delete only the exposure in the cell and not the frames.

l

Select the Don’t Show This Message Again option to prevent the warning message
from being displayed each time you delete a frame range.
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About Layers and Columns
T-RIG-009-003
Before filling in any values or setting any timing or exposure, you need to create drawing elements. Each
drawing element is represented as a vertical column in the Xsheet view and a horizontal layer in the Timeline
view.
In Harmony, whether you work in the Timeline or Xsheet view, any modification you do to one view will be
applied to both. You can also see your layers displayed in the Node view as nodes.
When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named
the same way as the drawing element and is in fact, linked to the drawing element. Its purpose is to contain all
the drawings related to this element (layer, column). For example, in cut-out animation, a character can have
many heads available. All of the head drawings will be contained in this folder, even if they are not exposed in
the Timeline or the Xsheet view.
Drawings are exposed in cells/frames and linked to the drawings saved in the layer's directory. When you
remove a drawing from a cell/frame, it is not displayed, but still exists in the directory.
When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that
when you modify, repaint, or correct a drawing named “1,” all exposures of drawing “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the
drawing.

NOTE
There are different element types available, such as sound and expression. A sound element
contains sound files. Expressions, Beziers, eases, 3D path, Quadmaps and Pegs are for motion
purposes during the compositing step. It's not necessary to create these types to create your
exposure sheet.
You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.
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Layer and Column Types
A column is also known as a layer. There are several types of layers you can add in the Timeline and Xsheet
view. Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently
in the Xsheet view.

Drawing Layer
The most common layer type is the drawing layer.

Any time you need to create a vector drawing or import a symbol or image, you can use a drawing layer. You
can also create bitmap artwork on a drawing layer.
NOTE
Bitmap images are contained in bitmap layers.

Bitmap Layer
If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you
choose to vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a
bitmap into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer
You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when
you create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.
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NOTE
If you want to have several cameras with different settings, you can keep adding Camera layers in
your Timeline view (however, only one will ever be visible at a time as you can only have one camera
at a time in your timeline). To switch to a different camera, select Scene > Camera and select
another camera layer.

Effect Layer
To enhance the look of your scene, you can add effect layers and attach your drawings to them.

In Harmony, there is a series of effect nodes in the Node Library view.
When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the
Functions section of the Xsheet view.

Colour-Card Layer
The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no
background colour and if you render it as a QuickTime movie or image sequence, it will have a black
background.

This layer is not visible in the Xsheet view.

Group Layer
A Group layer can be used to organize both the Timeline and Node views.

You can drag and drop other layers onto a Group layer and then collapse the Group layer to hide these other
layers from view.

Peg Layer
A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any
drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the Functions
section of the Xsheet view.
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Quadmap Layer
A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the
deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the
Functions section of the Xsheet view.

Sound Layer
You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types
In the Xsheet view, you can add several advanced column types to create particular animation paths. When
you create these columns, they are not linked automatically to any particular drawing layer. You can create a
motion path using these columns and then link or unlink several drawing or peg layers to it.
Advanced column types include:
• Timing
• 3D Path
• 3D Rotation
• Bezier Curve
• Ease Curve
• Expression
• Annotation
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Adding Layers and Columns
T-HFND-005-002
There are different ways to add a drawing elements (layers and columns) to your project. By default, when you
create a new scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in
the Timeline view.
When you add an element, it will appear as a column in the Xsheet view or as, a layer in the Timeline view, and
a node in the Node view.

582

Chapter 6: Timing

Adding Layers in the Timeline View
T-LAY-001-007
Drawing elements are more commonly known as layers in the Timeline view. Create them using the following
procedure:

How to add a drawing element from the Timeline view
1. In the Timeline view, click the Add Drawing Layer

button or press Ctrl + R (Windows/Linux) or

⌘ + R (macOS).
The Add Drawing Layer window opens.

2. In the Name field, name your new layer.
2. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a
bitmap layer.
3. Do one of the following:
l

Click Add to add a first layer and keep the window open to add more layers.

l

Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.
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Adding Layers from the Top Menu
Another way to add layers to the Timeline view is through the top menu.

How to add a drawing element from the top menu
1. From the top menu, select Insert > Drawing.
The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name and click OK.
The new drawing element appears in your scene.
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Adding Columns from the Xsheet View
Drawing elements in the Xsheet view are more commonly known as columns. You can add columns using the
following procedure:

How to add a drawing element from the Xsheet view
1. Do one of the following:
l

In the Xsheet menu, select Columns > Add Columns.

l

Click the Add Columns

l

Press Shift + C.

button.

The Add Column dialog box opens.

2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing.

4. To complete the operation:
l

Click Add and Close to add your new layers and close the dialog box.

l

Click Add to add your new layers and keep the dialog box open to add column.

l

Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column
Types on page 579.
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Using the Advanced Add Column Dialog Box
How to create a column using the advanced Add Column dialog box
You can use the advanced Add Column dialog box to make more file format and field size options available
when you insert a column.
1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium >
Preferences (macOS) and select the Advanced tab.
2. In the Advanced Options section, select the Advanced Element Mode option to access the
advanced Add Column dialog box.

3. Click OK.
4. In the Xsheet menu, select Columns > Add Column or press Shift + C.
The Add Column dialog box opens.
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5. In the Name field, type the new column’s name.
6. In the Type menu, select the Drawing type.
7. In the Element section, select one of the following:
l

Create New Element: Creates an independent column with its own drawing folder.

l

Reuse Existing Folder: Links your column to an existing folder within the Element
folder of your scene. If you select this option, in the Folder menu, select the folder to
which you want to link your new column.

l

Use Existing Element: Uses drawings from an existing column in the new column.
Both columns will be attached to the same set of drawings, but their timing will remain
independent from one another. If you modify one of the drawings, it will be modified in
both columns. This is the same principle as the Clone column.

In the Name menu, select the column to which you want to link your new column.

8. If you selected the Create New Element option:
l

Deselect the Vector option if you want your layer to contain bitmap images or enable
it if you want the layer to contain vector drawings. Most of the time, the Vector option
will be enabled.

l

If you deselected the Vector option, from the Bitmap Format list, select which type of
bitmap image you want to insert in the column. Select the SCAN type if you are
planning to scan drawings using the Toon Boom Harmony Scan module.

l

If you deselected the Vector option and you chose the SCAN type, from the Scan
Type menu, select what kind of scanning you want to achieve.

l

In the Field Chart field, when importing traditional animation, indicate the size of
paper on which the animation or background was drawn. If you are not using
perforated animation paper, leave the 12 field default value as is.

9. Do one of the following:
l

Click OK to create the new column and close the dialog box.

l

Click Apply to create the new column but keep the dialog box opened to create other
new columns.
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Deleting Layers and Columns
T-HFND-005-004
You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view
1. In the Timeline view, select the layers to delete.

2. Do one of the following:
l

In the Timeline’s Layer toolbar, click the Delete Layers

l

Right-click on the selection and select Delete.

button.

How to delete columns in the Xsheet view
1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following
l

Right-click on the selection and select Delete Columns.

l

In the Xsheet toolbar, click the Delete Columns

l

Press Del.
The Confirm Delete dialog box opens.
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l

Select the Delete Drawing Files and Element Folder option if you want to delete the
drawings and folders linked to the selected column.

3. To complete the operation:
l

Click OK to delete the selected layers.

l

Click Cancel to cancel the operation.

The Warning dialog box may open.

4. Do one of the following:
l

Click Yes to delete all the frames from your scene.

l

Click No to keep the frames in your scene.

l

Select the Don’t Show This Message Again option if you do not want the dialog box
to display again in the future.
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Renaming Layers and Columns
T-LAY-001-008
Once you add layers and columns to your project, you can modify their names.

How to rename a layer in the Timeline view
1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor
1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.
The Layer Properties editor opens.
2. In the Name field, rename the layer.

3. Click Close.

How to rename a column
1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that the
column is linked to (this also appears in the column header just below the column name).
The Drawing dialog box opens.
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2. In the Name field, rename the column.
3. Click OK.
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About Layer and Column Display
You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline
view or a column in the Xsheet view displays. You can stay organized without changing the content of
elements or your animation output.
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Expanding and Collapsing Layers and Columns
To simplify the look of the Timeline or Xsheet view, you can expand and collapse some of the layers and
columns. If layers are parented to other ones, you can collapse the parent layer to hide its children.

How to collapse or expand selected layers in the Timeline view
1. In the Timeline view, select the layer(s) to collapse or expand.
2. Do one of the following:
l

Right-click on the selection and select Collapse/Expand > Collapse/Expand.

l

Click the Expand Children Arrow

l

Click the Collapse/Expand

button on the parent layer.

button (you may have to customize the toolbar to

display it).
l

Press Ctrl + I (Windows/Linux) or ⌘ + I (macOS).

How to collapse or expand all layers in the Timeline view
1. Do one of the following:
l

Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

l

In the Timeline toolbar, click the Collapse All

or Expand All

buttons (you may

have to customize the toolbar to display them).
l

Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view
1. In the Xsheet toolbar, click the Show Column List

button to display the Functions list.

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or
expand.
3. Do one of the following:
l

Right-click on the column’s header and select Expand/Collapse > Collapse Selection
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or Expand Selection.
l

In the Xsheet toolbar, click the Collapse Selection

or Expand Selection

buttons

(you may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view
Do one of the following:
l

Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

l

Press 0 and 9.

l

In the Xsheet toolbar, click the Collapse All

or Expand All

customize the toolbar to display it).
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Showing and Hiding Layers and Columns
As you work in the Drawing, Camera or Xsheet view, some layers or columns may be in the way, such as those
that were used as references. You can hide these layers to make your work area less cluttered and easier to
navigate.
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Showing and Hiding Layers
T-HFND-005-010
You can show and hide layers in the Timeline view in several different ways.
When using the Solo mode to show or hide layers, here's how it works:
l

If you have anything selected, it is not affected.

l

When multiple layers are selected and you enable/disable the Solo mode on any of those layers, it is
applied to all the selected layers.

l

When multiple layers are selected and you enable/disable the Solo mode on layers that are not part of
the selection, it is applied only to those particular layers.

When exporting or rendering a scene, the Solo mode setting of layers is ignored.
NOTE
When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it
unless the mask is also enabled.

How to show or hide all layers
1. Click one of the following in the Layers toolbar:

l

Enable/Disable All

button to show or hide all layers.

Any hidden layers are unhidden, so you can view all layers.
l

Solo Mode

button to view disable your current Solo mode selection. Any soloed

drawing or sound layers are disabled, so you can view all layers. When you click again
on the Solo Mode button, you last Solo selection is displayed.

How to show or hide individual layers
1. Do one of the following:
l

In the Layer toolbar, click the Solo Mode

l

Click the layer's Enable/Disable All

button.

button to show or hide that layer.
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l

Press A to show a layer or D to hide selected layers.

l

In the Timeline toolbar, click the Enable/Disable

button (you may have to customize

the toolbar to display it).
When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view.

How to enable the selected layer and disable all others
1. Do one of the following:
l

Hold down Alt and click the Solo Mode

button of the layer you want to solo and

hide all other layers.
l

In the Timeline toolbar, click the Disable All Others

button (you may have to

customize the toolbar to display it).

How to show and hide layer types in the Timeline view
1. From the Timeline menu, select View > Show > Show Manager.
The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.
3. Click Set As Default to make these new settings the default ones that will be used each time to
start the application. Click Restore Default to restore the settings used when installing the
application.
In the Xsheet view, you have the choice of hiding or showing certain types of columns such as
Annotation and Functions.
In the Timeline view, you can hide or show certain types of layers such as Group and Effect.
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Showing and Hiding Columns
The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can
be used to hide individual columns.
If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without
using the Column List section.
You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is
disabled in the Timeline view.

How to show and hide columns in the Xsheet view
1. In the Xsheet toolbar, click the Show Column List

button.

2. On the right side of the Functions section, click the Expand

button to display the Column List

section.
3. Do one of the following:
l

In the Column List section, select the columns to display and deselect the columns to
hide.

l

In the Xsheet toolbar, click the Hide Selected Column
customize the toolbar to display it).
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Showing Hidden Columns
In order to save visual space in the Xsheet view, columns can be hidden from view. The hidden layer's presence
is indicated by a thicker grey line between columns.

How to show hidden columns in the Xsheet view
1. In the Xsheet view, do one of the following:
l

Click the thick grey line that represents a hidden column.

l

Right-click on the column header and select Show Hidden Columns.

l

Press Alt + Shift + H.

The Show Hidden Columns dialog box opens.

2. In the Show column, select the hidden columns you want to display in the Xsheet view.
l

Click Check to select all the selected columns.

l

Click Uncheck to deselect all selected columns.
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Showing All Columns
In order to save visual space in the Xsheet view, columns can be hidden from view. You can bring all the hidden
columns back into view all at once.

How to show all columns
l

In the Xsheet menu, select View > Unhide All Columns.
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Showing and Hiding Column Types
You can hide specific column types from view, in order to work more easily with one aspect of your project. For
example, you could hide all the Drawing columns in the Xsheet, so that you could work more easily with your 3D
Path Columns.

How to show and hide column types using the Column List
1. In the Column List section, click the button corresponding to the column type you want to show or
hide.

Column Type

Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns

How to show and hide column types using the Column Types Manager
1. In the Xsheet view, select View > Column Types Manager.
The Column Types dialog box opens.
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2. Select the types of columns you want to display and disable the ones you want to hide.
Click Set As Default if you want to make these new settings the default ones used each time you start
Harmony.
Click Restore Default if you want to return the settings to their defaults.
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Showing and Hiding Function Columns
Function columns (columns that house translation, rotation, scale, etc. information) that are associated with
another column type, for example a Drawing column, are often hidden from view. You can bring these columns
into the forefront, in order to work with them or view their information.

How to show or hide function columns on the left side of the Xsheet view
1. Right-click on a column and select Tag > Function Columns Visible or Function Columns Invisible.
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Customizing the Column Appearance
In Harmony, you can customize the way the column displays drawings, empty cells and the column width.
You can modify the following elements:
l

Empty cells

l

Row units

l

Held exposure

l

Column width

How to change the appearance of an empty cell
1. From the Xsheet menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units
1. From the Xsheet menu, select View > Row Units > Frames or Feet.

How to modify the look of a held exposure
1. In the Xsheet menu, select View > Held Exposures > Line or Value.
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How to modify column width
1. In the Xsheet view, select a column.
2. From the Xsheet menu, select View > Set Columns Width.
The Xsheet Column Width dialog box opens.

3. In the Column Width field, enter the desired width in pixels.
4. Do one of the following:
l

Click OK to validate and close the dialog box.

l

Click Apply to validate the operation and keep the dialog box opened to adjust the
next column’s width.

l

Click Set As Default to create all the new columns to this width.

l

Click Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet menu, select View > All Columns to
Default Width.
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Displaying Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of
the current frame below the column header.

How to display the thumbnails
1. Do one of the following:
l

In the Xsheet toolbar, click the Show Thumbnails

l

In the Xsheet menu, select View > Show Thumbnails.

The thumbnails appear.
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Changing Layer and Column Colours
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. The
colours you choose will be reflected in the Node view.

How to change the layer’s colour in the Timeline view
1. In the Timeline view, click the Change Track Colour

button of the layer you want to modify.

2. In the Select Colour dialog box, select a new colour for your layer.

3. Click OK.
The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter,
selected colour for easy identification. The corresponding column colour is also updated in the
Xsheet.

How to reset a layer’s colour in the Timeline view
1. In the Timeline view, select the layers to reset.
2. In the Timeline toolbar, click the Default Track Colour
toolbar to display it).
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How to change a column’s colour in the Xsheet view
1. In the Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.
3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.
The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view
1. In the Xsheet view, select the columns to reset.
2. Right-click on the column’s header and select Colour > Default Columns Colour.
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About Scene Markers
T-ANIMPA-005-010
Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is
displayed when you hover over the scene marker.
There are two ways to add a scene marker. You can mark the current frame or make a frame range selection
and mark the whole section.
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Creating Scene Markers on Current Frames
Change the colour of the area above a frame by setting a scene marker. This will allow you to find the frame
more rapidly when quickly scanning the Timeline.

How to mark the current frame
1. In the Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you
right-click on a different frame, the scene marker will be created on the current frame on which the
playhead is positioned.
2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scene marker you created.

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene
marker. Click OK.
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4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when
you hover your mouse over the scene marker.

In the Timeline view, the scene marker is displayed at the current frame.
5. Hover over the scene marker to display its tooltip.
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Creating Scene Markers on Frame Ranges
T-ANIMPA-005-011
Change the colour of the area above a frame range by setting a scene marker. This will allow you to find the
range more rapidly when quickly scanning the Timeline.

How to create a scene marker on a frame range
1. In the frame counter area, select the frame range you want to mark.

2. Right-click and select Create Scene Marker.
The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the
colour of the last scene marker you created.

3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene
marker. Click OK.

4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when
you hover your mouse over the scene marker.

612

Chapter 6: Timing

In the Timeline view, the scene marker is displayed over the selected frame counters.
5. Hover over the scene marker to display its tooltip.
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Editing Scene Markers
You can modify the colour of a scene marker or edit the note attached to it.

How to edit a scene marker
1. In the frame counter area, select the entire scene marker.
NOTE
It's important to select the entire length of the scene marker, otherwise the Timeline Scene
Marker dialog box will not open for editing.

2. Right-click and select Scene Markers > Edit Scene Marker.
The Timeline Scene Marker dialog box opens.

3. Make your changes.
4. Click OK.

614

Chapter 6: Timing

Deleting Scene Markers
If you deem it no longer necessary to have a frame or a range of frames marked, you can delete the scene
marker.

How to delete a scene marker
1. In the frame counter area, select at least one frame in the scene marker you want to delete.

2. Right-click and select Scene Markers > Delete Scene Marker.
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Setting Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce the FPB
(Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view lets you pace your
animation according to the tempo or beat of the soundtrack music or to any rhythmic sound, such as the ticking
of a clock or water leaking from a spout.

How to set the tempo markers
1. In the Xsheet menu, select View > Set Tempo Marker.
The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.
‣

Starting Frame: Enter the number of the frame where you want the tempo markers to begin.

‣

Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

‣

Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) in
which a tempo marker will appear in the Xsheet view.

3. Click OK.
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Reordering Layers and Columns
You can change the order of your elements in the Timeline view and Xsheet view. When you change the order
of your elements in one view, the other one is updated.

How to reorder layers in the Timeline view
1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location.
3. Do one of the following:
l

Drop the selection on an existing layer to make it a child of another element layer.

l

Drop it between the existing layers. Timeline layers that are located above the
selection are displayed in front it. Layers located under it in the Timeline View are
displayed behind it.

How to reorder columns in the Xsheet view
1. In the Xsheet view, click on the column’s header with the middle mouse button.
2. Drag the column to its new position.
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Navigating Layers and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and
layers. Displays the previous drawing, next drawing, previous layer or next layer. using keyboard shortcuts that
work in the Camera, Drawing, Xsheet and Timeline views.
You can navigate through:
• Drawings
• Frames
• Columns

How to navigate through drawings,and frames and columns
1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:
l

Previous and next layers: From the top menu, select Drawing > Previous Layer and
Next Layer or press H and J.

l

Previous and next drawings: From the top menu, select Drawing > Previous Drawing
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and Next Drawing or press F and G..

l

Previous and next frames: From the top menu, select Play > Previous Frame and Next
Frame or press comma (,) and period (.).
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Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify anything
you want in the duplicated element without affecting the original one.

How to duplicate an element
1. In the Timeline or Xsheet view, click the layer or column to duplicate.

2. Do one of the following:
l

(Xsheet) Right-click on the column and select Duplicate Selected Columns.

l

(Xsheet) In the Xsheet menu, select Drawings > Duplicate Drawings.

l

(Timeline) Right-click on the layer and select Duplicate Selected Layers.

l

(Timeline) In the Timeline menu, select Layers > Duplicate Selected Layers.

The new duplicated layer or column appears.
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Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the
original. For example, if you modify a drawing in the cloned or original column, it is updated in both columns.
You can choose whether or not to copy the column timing to the cloned columns.
l

You can modify the column timing independently from each other, but the drawings remain linked.

l

You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from the Node view in the same way.
This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element
1. In the Timeline or Xsheet view, select the layer or column to clone.

2. Do one of the following:
l

From the top menu, select Edit > Clone: Drawings Only to clone only the layer or
column drawings.

l

From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only.

l

From the Xsheet menu, select Columns: Clone Selected Columns: Drawings Only.

The new cloned layer or column appears.
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About Sync Layers
Use the Sync Layer feature when you need drawings to be separated on different layers, but to have the same
timing, such as with the front and back of a shirt collar. The drawing exposures of synced layers not only
update automatically, but their drawing substitutions correspond as well, as long as the drawings are labeled
properly.

When using certain drawing tools, such at the Select, Cutter and Reposition All Drawings tools, you can enable
the Apply to Synced Drawings option while you work. To learn more about this option—see the Reference .
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Syncing Two Layers
The Sync Layer feature allows for drawings to be separated on different layers, but to have the same timing.

How to sync two layers
1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

2. From the right-click menu, select Sync Layers With.
The Convert to Synced Drawing Layer dialog box opens.

3. From the drop-down list, select a parent drawing layer to sync with the currently selected layer.
4. Click OK.
In the Timeline view, when you click on either of the two synced layers, the other will display the link
icon.

In the Node view, when you click on either of the two synced nodes, the other will display the link
icon.
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In the right side of the Timeline view, the child layer will update to the parent layer's timing.

5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in either of the
two layers.
The other synced layer immediately updates to the same timing.
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Syncing Multiple Layers
You may want to sync more than two layers. However, once a layer is synced, the Sync Layers menu option
becomes disabled for that layer. In order to sync a layer to a layer that has already been synced, you need to
use the Sync Layers command on the yet unsynced layer.

How to sync multiple layers
1. In the Timeline view, right-click on the drawing layer you would like to sync with an already synced
pair.

2. From the right-click menu, select Sync Layers With.
The Convert to Synced Drawing Layer dialog box opens.

3. From the drop-down list, select the parent drawing layer you would like to sync with the currently
selected layer. This should be a drawing layer already synced with another drawing layer. You can
select either the parent or the child from that linked pair; they both appear in the drop-down list.
4. Click OK.
In the Timeline view, when you click on any of the synced layers, the others will display the link icon.
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In the Node view, when you click on any of the synced nodes, the others will display the link icon.

In the right side of the Timeline view, the child layer will update to the parent layer's timing.

5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in any of the
synced layers.
The other synced layers immediately update to the same timing.
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Creating Synced Layers
Create a new drawing layer to be synced immediately with an existing drawing layer.

How to create a new synced layer
1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

2. From the right-click menu, select Add Synced Drawing Layer.
The Add Synced Drawing Layer dialog box opens.

3. In the Add Synced Drawing Layer dialog box, add a single or multiple drawing layers.
4. When you are finished, click Close.
In the Timeline view, when you click on any of the synced layers, the others will display the link icon.

In the Node view, when you click on any of the synced nodes, the others will display the link icon.

627

Harmony 15.0 Premium User Guide

In the right side of the Timeline view, the child layer will update to the parent layer's timing.
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Selecting All Synced Layers
You can select all the drawing layers that are linked to the selected drawing layer, in the Timeline or Node view.

How to select all synced layers
1. In the Timeline view, select a layer that is synced to at least one or more layer or in the Node view,
select a node that is synced to one or more node.
2. In the view menu

, select Edit > Select Synced Layers.

In the Timeline view, all the layers synced to the selected layer become highlighted.

In the Node view, all the nodes synced to the selected layer become highlighted.
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Unsyncing Layers
Once layers have been synced, they can just as easily be unsynced.

How to unsync layers
1. In the Timeline view, right-click on the child layer of a synced pairing.
2. From the right-click menu, select Unsync Layer.
The parent layer is unsynced and the link icons disappears.

NOTE
If this menu item is disabled, then the selected layer is either the parent layer or a layer that is
already unsynced.
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About Annotation Columns
T-ANIMPA-005-001
The annotation columns are useful for marking actions, corrections or other information related to your
animation that you want to draw or write. This way, you can print your Xsheet, take it back to your animation
table and work with the annotations.
Before you can draw in the Annotation column, you must first activate the Enable Drawing option to activate
the Drawing mode. Pen tablet pressure sensitivity is not supported in the annotation column.
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Adding Annotation Columns
T-ANIMPA-005-002
Add annotation columns to mark actions, corrections or other information related to your animation.

How to add an annotation column
1. Do one of the following:
l

In the Xsheet menu, select Columns > Add Columns.

l

In the Xsheet toolbar, click the Add Columns

l

Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.
3. From the Type list, select Annotation and click OK.
The new column appears.
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Drawing in Annotation Columns
T-ANIMPA-005-003
In the annotation column, you can draw sketches and ideas that will be useful in producing your animation.

How to draw in the annotation column
1. Do one of the following:
‣

In the Xsheet menu, select Annotation > Enable Drawing.

‣

In the Annotation column header, click the icon in the upper-right corner to cycle through the
icons until the Brush

icon is displayed.

The Drawing mode is enabled.
2. To draw in an Annotation column, simply use your mouse or pen tablet.
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Typing in Annotation Columns
T-ANIMPA-005-004
In the annotation column, you can type in your notes and relevant information that will be useful in producing
your animation.
Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the
typing will work. To learn about typing values in the Xsheet view, see Typing Exposures on page 648.

How to type in an annotation column
1. Do one of the following:
l

In the selected cell, press Ctrl (Windows/Linux) or ⌘ (macOS).

l

In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘ + Shift + click
(macOS).

2. In the selected cell, type the desired text.
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Erasing in Annotation Columns
T-ANIMPA-005-005
You can erase part or all of the annotation column’s text and drawn annotations. Annotations that you type in
cannot be erased using this method.

How to erase part of a drawn annotation using Erasing mode
1. In the annotation column header, click the icon in the upper-right corner to cycle through the icons
until the Eraser

icon is displayed.

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

NOTE
When using a pen on a tablet, you MUST flip your pen to the eraser side for the
eraser to work.
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Modifying Annotation Column Pen Options
T-ANIMPA-005-006
You can change the pen size and colour when you draw in the annotation column.

How to modify the pen width
1. In the Xsheet menu, select Annotation > Pen Width and do one of the following:
l

Select a pen width preset.

l

Select Change Current to display the Pen Width dialog box. In the Pen Width field,
type the number of pixels for the pen size and click OK.

How to modify the pen colour
1. In the Xsheet menu, select Annotation > Change Pen Colour.
The Select Colour dialog box opens.

2. Choose a new colour.
3. Click OK.
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Showing and Hiding Annotation Column Tick Marks
T-ANIMPA-005-007
When working with the annotation columns, it is useful to display tick marks on odd-numbered frames.

To display the tick marks, you must run a short script.

How to display tick marks
1. From the top menu, select Windows > Script Editor.
2. From the Script Editor menu, select File > New Script.
3. Type in a name for your script and click OK.
4. In the File list, select the script you created.
5. On the right side of the view, type the following script:
function display_tick_marks()
{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));
}
6. Click Verify.
The script is verified.
7. From the Script Editor menu, select Play/Debug > Run.

637

Harmony 15.0 Premium User Guide

A dialog box opens with your script selected in the Files column.
8. In the Functions column, select display_tick_marks and click OK.
Tick marks appear on odd frames in the Annotation column. If you do not see tick marks, close and
restart Harmony.

How to turn off the display of tick marks
1. Follow steps 1 to 5 of How to display tick marks and use the following script:
{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));
}
2. Follow steps 6 to 8.
All tick marks are removed from the Annotation column.

638

Chapter 6: Timing

Importing Annotation Files
T-ANIMPA-005-008
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in the
Annotation columns, you can easily import them.

How to import annotation files
1. In the Xsheet view, select the first cell in the Annotation column where you want the imported
image to start.

2. Do one of the following:
l

Right-click on the cell and select Annotation > Import File.

l

From the Xsheet menu, select Annotation > Import File.

3. Browse for the bitmap image to import.
4. Click Open.
The image appears in the Annotation column.
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Using Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to bring
images into the project. For example, you may have background scenes created in a third party software that
you might need to update in the future. By using Timing columns, you can dynamically link your backgrounds,
expose different backgrounds at different times, and have live, automatic updating capabilities.
IMPORTANT
If the project file is moved, or if the folder that the column is linked to is moved, then dynamic linking
is broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column
1. In the Xsheet view, click the Add Columns

button.

2. In the Add Column dialog box, type in the name of the new column, then from the Type menu, select
Timing.
3. Do one of the following:
l

Click OK if you are finished.

l

Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header,
<unused>.

4. In the Node view, add a new node.
5. Open the Layer Properties editor by clicking the yellow square of the node.
6. In the Drawing tab, select the Timing Columns option.
7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to
locate a folder, you must select a file in the folder you want and then delete the dash and the suffix
(for example, background-01 should be renamed to background) from the file name in the field. If
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you leave the full file name selected, Harmony will display that file for the entire duration of the
scene, regardless of the contents of the Timing Column field.
NOTE
This means that all the images in the folder that you are linking to are named using the naming
convention described above. If for some reason you are unable to access a certain directory,
type the directory extension directly in the path extension field at the top of the browser
window.
8. In the Timing Column field, click the Arrow button to create a new timing column, or select the name
of the column from the list. If you have an element directory selected in the Name field, the Timing
Column will indicate which files are called from that element directory. Remember that the file
displayed at each frame is based on the element name, cell label, and extension. If the element is
toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> header changes to the name of the node in the Node view.
9. From the Extension list, select the file format of the files you want to display.
10. Click OK.
11. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the
drawing file that you want to expose to make it appear in the Camera view.
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Using the Element Manager
The Element Manager window lets you Opens the Element Manager window where you can add, delete or
modify elements (drawing folders) in your scene. If you have drawing folders that are not linked to a column in
your scene, use the Element Manager to delete them if needed. See xref Reference > Windows > Element
Manager.

How to use the Element Manager
l

From the top menu, select Scene > Element Manager.—see the Reference guide .
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Displaying Layer and Column Properties
Each element has its own set of properties that you can modify, including effect and peg layers.
If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline
view or selected node in the Node view. If you're working with the Xsheet, you can display its properties as
well. You can display a layer's properties as a window or as a view of its own.
The Layer Properties editor allows you to:
l

Rename the layer

l

Enable or disable the layer

l

Lock the layer

l

Change the track colour

l

Activate the onion skin preview

l

Adjust the positioning and animation parameters

l

Adjust many other advanced parameters

The Column Properties editor allows you to:
l

Rename the layer

l

Enable or disable the layer

How to display a layer's properties
1. Do one of the following:
l

In the Layer Properties view is not part of your workspace, from the top menu, select
Windows > Layer Properties. In the Timeline view, select a layer

l

In the Timeline view, double-click on a layer.

l

Press Shift + E.

l

In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .
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How to display a column's properties in the Xsheet view
1. In the Xsheet view, do one of the following:
l

Double-click on a column header.

l

Right-click on a column header and select Column Editor.

The properties for the column are displayed.

2. (Optional) To view additional properties, select Edit > Preferences from the top menu.
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3. In the Preferences dialog box, select the Advanced tab, then select the Advanced Element Mode
option.

4. In the Xsheet view, double-click on a column header.
Additional properties for the column are displayed.
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About Exposure
T-HFND-006-006
In Harmony, exposure is the term used for the link between a cell, which is a single frame in a drawing layer,
and a drawing.
This concept comes from traditional animation. When drawings were finished and ready to be added to the
animation, they would be placed under a camera, and taking one snapshot of the drawing would equate to one
exposure. Hence, exposure is an important concept for planning out the drawings required for your action, as
well as the timing in which they will be displayed as your scene plays out. It is especially important when
drawings are used several times in a scene, which is a common practice to save on production time and costs, as
you can re-use a drawing by exposing it over multiple frames.
In traditional animation, it is typical to plan a scene by filling the exposure sheet with the exposure before
creating the animation. An exposure sheet is made of cells, which represent frames, spread across columns,
representing drawing layers, and the exposure is planned by filling each cell with the identification numbers for
the drawings you plan your scene's action to require. This allows animators to figure out the timing of their
scene's actions and to allocate the amount of drawings each action will require before they start drawing,
removing decision making from the animation process.
In Harmony, you can achieve this process by using the Xsheet view, which is very similar to a traditional
animation exposure sheet. You can fill each cell in your scene's drawing layers with the number of the drawings
you plan to create, at the frames at which you intend to expose them, and set the exposure of each drawing to
the amount of frames you intend them to take.
Filling a cell with a drawing identifier allows Harmony to keep track of which frames should display which
drawings. For example, if you fill cell 1 and 2 of the drawing layer A with the number 5, then start drawing in
cell 1 or 2, Harmony will create the drawing A-5, which will display in layer A when at frame 1 or 2 of your
scene. Otherwise, if you start drawing inside an empty cell, Harmony will automatically create a drawing and
assign it an available drawing number.
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About Creating Exposure
In traditional and paperless animation, it is useful to plan your scene by creating its exposure before creating
the drawings. The most basic method of creating a scene's exposure is by manually entering the name
(typically a number) of each drawing in each cell of each column in your scene using the Xsheet view. However,
Harmony has many tools allowing you to streamline the exposure filling process. If you plan to animate on twos
or threes, Harmony can automatically expose each drawing added to your exposure sheet over the preferred
amount of frames. You can also fill a range of cells with the same drawing, a number sequence, a cycle, or even
random drawing numbers.
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Typing Exposures
T-HFND-006-007
To fill in your exposure, you can type the values directly in the Xsheet view.
If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section
of the Timeline.
NOTE
You can only use alphanumeric values (0 to 9, a to z) and the underscore (_) and dash (-).

How to type a value in the Timeline view
1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing
you want to create.

2. Press Enter/Return to validate the value.

How to type a value in the Xsheet view
1. In an Xsheet column, double-click on a cell.

2. Type a value or drawing name in the cell.
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3. Press Enter/Return to move to the next cell.

4. Press Esc to exit the typing mode.
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Setting the Exposure Hold
Drawings in an animation project are often exposed for more than one frame to save on production costs. In
western animation, each drawing is usually exposed on two frames, and in Japanese animation, each drawing is
usually exposed on three frames. In both cases, exceptions can be made for quick or detailed actions that
require precise timing.
In the industry, this type of exposure is known as animation in double or triple frames, or animation on twos or
on threes.
To save time when creating your scene's exposure, you can configure the Xsheet to hold the exposure. This will
make every new exposure you type into the Xsheet exposed for the preferred amount of frames. After you
enter the exposure for a cell, the selected cell will be after this exposure's hold, allowing you to quickly fill a
column with exposure while respecting the selected hold.

How to hold an exposure
1. Do one of the following:
l

In the Xsheet menu, select Exposure > Hold Exposure > Hold the desired amount of cells.

l

From the top menu, select Animation > Cell > Hold Exposure > Hold the desired amount of
cells.

l

Right-click on the Xsheet and select Exposure > Hold Exposure > Hold the desired amount
of cells.

2. Type a value or drawing name in the cell.
3. Type a value or drawing name in the cell.
l

Press Enter/Return to move on to the next cell.

l

Press Esc to quit the typing mode.
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Toggling Between Inserting and Overwriting Exposure
T-HFND-006-007
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes
control the filling behaviour. The Timeline view only uses the Overwrite mode.
By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence
over existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed
down the column.

How to switch between the Overwrite and Insert modes
1. Do one of the following:
‣

In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣

Press I.
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Filling a Selection with a Specific Exposure
You can fill a selection with the same drawing using the Fill Selection dialog box. You can fill a selection of a
single drawing, several drawings or even several columns.

How to fill a selection with a specific exposure
1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:
l

From the top menu, select Animation > Cell > Fill Selection.

l

In the Xsheet toolbar, click the Fill Selection

button. Note that you may have to add this

button to your toolbar by right-clicking on it and selecting Customize.
l

Press Ctrl + T (Windows/Linux) or ⌘ + T (macOS)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.
4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key
Exposure After option. Otherwise, leave it deselected.
5. Click OK.
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Creating an Exposure Sequence
You can quickly create a sequence with a gesture by holding the Shift key while extending an exposure, or use
the Sequence Fill dialog box to create a custom sequence within your selection. While the former is faster, the
latter allows you to determine your sequence's hold and increment, to create a backward sequence or to
configure it in multiple other ways.

How to extend an exposure to create a sequence
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click the red arrow

on the cell’s right side. Make sure to see the drag down

cursor.

3. Hold down the Shift key. Make sure a plus sign (+) appears.
4. Pull down the selection box to the desired frame.

NOTE
The red selection box must be visible when releasing the cursor. If not, the action is
considered cancelled.
5. First release the Shift key, then release the mouse button.
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How to fill a selection with a sequence
1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:
l

From the top menu, select Animation > Cell > Sequence Fill.

l

In the Timeline view, right-click and select Exposure > Sequence Fill.

l

In the Xsheet toolbar, click the Sequence Fill

button (you may have to customize the

toolbar to display it).
l

Press Ctrl + M (Windows/Linux) or ⌘ + M (macOS)).

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.
4. In the Increment field, type the number by which the drawing number will increase from frame to
frame. For example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7;
and -2 gives you this: 8-6-4-2.
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Creating an Exposure Cycle
T-HFND-006-008
Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.
This can be useful for example if you want to make or use a looping character's walking animation, referred to as
a walk cycle.
When you create cycle, each instance of each cycled drawing is linked to the same drawing file. This means
that if you change a drawing for the first instance of the cycle, it will update for every other instance of the
cycle.
NOTE
You can also copy and paste drawings and keyframes into cycles—see Pasting Cycles on page 704.

How to create a cycle
1. In the Timeline view, select the cell range to loop.

2. In the Timeline toolbar, click the Create Cycle

button (you may have to customize the toolbar to

display it).
The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.
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Filling a Selection with Random Exposure
You can Lets you fill in random values over a selection. You can give a maximum and a minimum value and create
a range for Harmony to choose the random values from. The selection can be over one cell or a cell range in one
column or more or an entire column or many entire columns.

How to fill cells randomly
1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:
l

Select Animation > Cell > Fill Cells Randomly.

l

Right-click on the selection and select Exposure > Fill Cells Randomly.

l

In the Xsheet view, click the Fill Cells Randomly

button. Note that you may have to add

this button to your toolbar by right-clicking on it and selecting Customize.
The Fill Cells Randomly dialog box opens.

3. In the Minimum Value field, enter the lowest acceptable value.
4. In the Maximum Value field, enter the highest acceptable value.
5. In the Hold field, choose an exposure holding value.
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6. If you are applying this option to a drawing column, select the Whole Numbers option to avoid
decimal points.
7. Click OK.
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Inserting Blank Cells
You can place an empty cell between other cells.
NOTE
Inserting a blank cell never overwrites existing cells, even if the Xsheet view is set to Overwrite
mode. This is because overwriting existing cells with blank cells would replicate the behavior of
deleting exposure.

How to insert a blank cell
1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

2. Do one of the following:
l

In the top menu, select Animation > Cell > Insert Blank Cell.

l

Right-click and select Exposure > Insert Blank Cell.

l

In the Timeline or Xsheet toolbar, click the Insert Blank Cell

button. Note that you may

have to add this button to your toolbar by right-clicking on it and selecting Customize.
l

Press Shift + J.

A blank cell is inserted.

660

Chapter 6: Timing

661

Harmony 15.0 Premium User Guide

Filling Empty Cells
T-LAY-002-005
You can automatically fill gaps between exposures using the Fill Empty Cells command. This will extend the
exposure of cell exposed right before the gap until the end of the gap.

How to fill empty cells
1. In the Timeline or Xsheet view, select a cell range.

2. Do one of the following:
l

Right-click and select Exposure > Fill Empty Cells.

l

From the top menu, select Animation > Cell > Fill Empty Cells.

l

In the Timeline toolbar, click the Fill Empty Cells

button.

Each drawing in the selection is exposed in the range of empty cells that follow it.
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Toggling Extending Previous Drawing Exposure
T-HFND-006-005
With the Extend Exposure of Previous Drawing preference enabled, you can configure Harmony to
automatically extend a previous drawing's exposure when creating a new drawing, automatically filling the
gaps as you create drawings.

This preference is enabled by default. If you disable it, gaps between previous drawings and new drawing will
not be automatically filled:

How to enable or disable the Extend Exposure of Previous Drawing preference
1. Open the Preferences dialog box by doing one of the following:
l

Select Edit > Preferences.

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

The Preferences dialog box opens.
2. Select the Exposure Sheet tab.
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3. In the Drawing Creation section, check or uncheck the Extend Exposure of Previous Drawing
option.

4. Click OK.
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About Adjusting Exposure
The exposure of drawings in a scene often needs to be adjusted as you flesh out your animation and your
scene's action starts taking form. Your scene's action may require more or less drawings than initially planned,
or some drawings may need to be exposed for longer or shorter times than expected. There are many ways to
adjust your scene's exposure, giving you the flexibility to quickly make changes and test them so you can finetune your animation.
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Increasing Exposures
T-ANIMPA-006-005
Increasing the exposure Adds one more exposure to a selected cell; repeating this action adds an extra cell
each time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing
an exposure pushes the existing exposure forward.

How to increase exposure
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
l

Press +.

l

At the bottom-right corner of the Xsheet view, set the number of cells over which the
drawing will be exposed.

l

In the Xsheet toolbar, click the Increase Exposure

l

Right-click and select Exposure > Increase Exposure.

l

From the top menu, select Animation > Cell > Increase Exposure.
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Decreasing Exposures
T-ANIMPA-006-006
Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the
beginning of selection. You can do this for one cell or a range.

How to decrease a single exposure
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
l

Press -.

l

At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will
be exposed.

l

In the Xsheet toolbar, click the Decrease Exposure

l

Right-click and select Exposure > Decrease Exposure.

l

From the top menu, select Animation > Cell > Decrease Exposure.

How to decrease a range of exposures
1. In the Timeline or Xsheet view, select a range of cells.
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2. Do one of the following:
l

From the top menu, select Animation > Cell > Clear Exposure and Pull.

l

Right-click and select Exposure > Clear Exposure and Pull.

l

In the Xsheet toolbar, click the Clear Exposure and Pull

The exposure is reduced by the selected number of cells.
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Extending Single Exposures
T-HFND-007-008
Extending the exposure lets you select a cell and extend it to the desired frame.

How to extend an exposure in the Timeline view
1. In the Timeline view, select the cell you want to extend.
2. Do one of the following:
l

Right-click and select Extend Exposure.

l

In the Timeline View menu, select Exposure > Extend Exposure.

l

Select Animation > Cell > Extend Exposure.

l

Press F5.

3. In the Extend Exposure dialog box, enter the frame number to extend your cell to.
4. Indicate if you want to insert the new frames before the following exposure or overwrite it. If you
select insert, any following exposure will be moved down. If you select Overwrite, the following
exposure will be erased and replaced by the drawing being extended.

NOTE
You can also select the last cell where you want to extend your drawing to (such
as the last cell of the layer), right-click and select Extend Exposure. You will not
be prompted the dialog box.

How to extend an exposure gesturally

1. In the Xsheet view, select the red arrow
cursor.

in the cell’s right side. Make sure you see the drag down
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2. Pull down the selected cell to the desired frame.
NOTE
The red selection box must be visible when releasing the cursor. If not, the action
is considered cancelled.

How to extend an exposure from the top menu
1. Select a cell and do one of the following:
l

From the top menu, select Animation > Cell > Extend Exposure.

l

Press F5.

The Extend Exposure dialog box opens.
2. Enter the frame number you want to extend the cell to.
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Setting the Exposure
T-HFND-006-009
You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure
1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

2. Do one of the following:
l

Select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set Exposure.

l

In the Timeline toolbar, click one of the Set Exposure

buttons. Note that

you may have to add this button to your toolbar by right-clicking on it and selecting
Customize.
l

In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure
to 1, 2, or 3, or Set Exposure.

3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of
frames you want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Deleting Exposures
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline
or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again
in a cell.
You can delete the exposure in a selected cell range or delete the entire exposure of a drawing exposed over
several cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures
1. In the Timeline or Xsheet view, select the exposure you want to delete.
2. Do one of the following:
l

Press Del.

l

Right-click and select Delete.

How to clear the entire exposure of a drawing
1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
2. Do one of the following:
l

From the top menu, select Animation > Cell > Clear Exposure.

l

In the Timeline view, right-click and select Exposure > Clear Exposure.

l

In the Xsheet toolbar, click the Clear Exposure
toolbar to display it).
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Moving Cells
T-ANIMPA-006-007
To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame
in the same column or into another column.
You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from
one location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view
1. In the Timeline view, select one or more cells to move.

2. Drag the cells to the new location.

3. Drop the selection by doing one of the following:
l

Drop by simply releasing the mouse or pen.

l

Hold Ctrl (Windows/Linux) or ⌘ (macOS) while dropping the selection to copy the
cells. The original cells will not be moved.

l

Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view
1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, position the pointer over the small dotted area

on the left side of the selected

cells.

3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:
‣

Drop the selection to overwrite the existing cells.
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l

Hold down Ctrl (Windows/Linux) or ⌘ (macOS) while dropping the selection to copy
the cells. The original selection will not be moved.

l

Press Shift while dropping the selection to insert it between existing frames.

How to turn off the Gestural Drag mode
1. Do one of the following:
‣

In the Xsheet view, right-click and deselect Gestural Drag Mode.

‣

From the Xsheet menu, select Edit > Gestural Drag Mode
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‣

In the Xsheet toolbar, click the Toggle Gestural Drag Mode

button (you may have to customize

the toolbar to display it).

The dragging pad disappears on selected cells when the Gestural Drag mode is off.
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Enabling or Disabling Overwriting Exposures and Keyframes During
Drag and Drop
You can change the way the Timeline behaves when you drag and drop a selection of keyframes or drawings
with the Overwrite Exposure and Keyframes during Drag and Drop preference. When this preference is
enabled, dragging and dropping drawings and keyframes in the Timeline view will overwrite the drawings and
keyframes between the selection and the destination, as if the selection "wiped" everything on the way to the
destination. This behavior is more similar to the one observed when manipulating keyframes in Adobe
Animate. If disabled, dragging and dropping a selection in the timeline will simply remove the keyframes and
drawings from the source, and overwrite the destination with them, leaving anything else unaffected.
You can set this mode in two places: the Timeline toolbar and the Preferences dialog box.

How to enable or disable overwriting exposure and keyframes in the Preferences dialog
1. From the top menu, open the Edit (Windows/Linux) or Harmony [Edition] (macOS) menu and
select Preferences. In the Timeline tab, check or uncheck the Overwrite Exposures and Keyframes
During Drag and Drop option, then click OK.
2. Open the Timeline tab.
3. In the Paste / Drag & Drop panel, check or uncheck the Overwrite Exposures and Keyframes
During Drag and Drop option.

4. Click OK.

How to enable or disable overwriting exposure and keyframes in the Timeline view
1. In the Timeline toolbar, click the Toggle Override Exposure and Keyframe During Drag and Drop
button. Note that you may have to add this button to your toolbar by right-clicking on it and
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selecting Customize.

679

Harmony 15.0 Premium User Guide

About Rippling and Overwriting the Exposure in the Timeline View
T-ANIMPA-006-004
By default, you can only use your mouse to drag and drop frames in the Timeline view. However, if you zoom in
sufficiently, you are able to tweak the exposure of each drawing by clicking and dragging the junction between
two drawings.
Just like in some video editing software, when tweaking the duration of a drawing by dragging its side, you can
decide whether to ripple or overwrite subsequent frames. This is determined by whether you grab the edge of
the drawing by the left or the right side of said edge.

Although not required, this functionality is especially useful when displaying thumbnails in the Timeline view,
as you can preview the exposed drawings as you modify their exposure. As a reference, tweaking exposure in
the timeline is only possible when you zoom in on the timeline at least close enough to fully view the thumbnails
of drawings exposed on two frames. For more information, see Displaying Drawing Thumbnails in the Timeline
View on page 524.
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Changing Exposure and Rippling Drawings in the Timeline View
If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their
right edge with the mouse cursor. If your mouse cursor is just left of the drawing's right edge, a yellow highlight
will appear. This means dragging the drawing's edge will adjust its exposure and ripple the ensuing drawings.

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline view
1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the following:
l

Left of the layer's name in the Layers list, click on the Show Thumbnails

l

Select the drawing layer and press T.

l

Left of the Layers list header, click on the Show All Thumbnails

icon.

icon.

NOTE
Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it
is very useful.
2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed
on twos, by doing one of the following:
l

Drag the Timeline Zoom

slider to the right.

l

Click on the Timeline view's tab, then press 2 repeatedly.

l

Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘ (macOS)
and roll the mouse wheel up.

3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the
exposure.

681

Harmony 15.0 Premium User Guide

4. Click and drag the right edge of the drawing to change its exposure.
If you move the edge to the right, the drawing's exposure is extended, and all the drawings
exposed after this drawing are moved forward.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawings exposed
after this drawing are moved backward.

NOTE
You can drag the edge further left and completely remove the drawing, making subsequent
drawings overwrite it.
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Changing Exposure and Overwriting Drawings in the Timeline View
If you zoom in on the Timeline view, you can change the exposure of individual drawings by grabbing their
right edge with the mouse cursor. If your mouse cursor is just right of the drawing's right edge, a red highlight
will appear. This means dragging the drawing's edge will adjust its exposure and overwrite ensuing drawings.

How to extend a drawing's exposure and ripple ensuing drawings in the Timeline view
1. In the Timeline view, enable thumbnails display for your drawing layer by doing one of the following:
l

Left of the layer's name in the Layers list, click on the Show Thumbnails

l

Select the drawing layer and press T.

l

Left of the Layers list header, click on the Show All Thumbnails

icon.

icon.

NOTE
Displaying thumbnails is not required for tweaking exposure in the Timeline view, but it
is very useful.
2. Zoom in on the Timeline view at least enough to fully display the thumbnails of drawings exposed
on twos, by doing one of the following:
l

Drag the Timeline Zoom

slider to the right.

l

Click on the Timeline view's tab, then press 2 repeatedly.

l

Move the mouse cursor in the Timeline view, then hold Ctrl (Windows/Linux) or ⌘ (macOS)
and roll the mouse wheel up.

3. Move the mouse cursor just left of the right edge of the drawing of which you want to change the
exposure.
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4. Click and drag the right edge of the drawing to change its exposure.
If you move the edge to the right, the drawing's exposure is extended, and all the drawing right
after is overwritten.

If you move the edge to the left, the drawing's exposure is reduced, and all the drawing right after is
exposed over it.

NOTE
You can drag the edge further left and completely remove the drawing, making the drawing
right after overwrite it.
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About Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure
work in Harmony:
l

Keyframe: A keyframe is a point in time where a change to the properties of the object or character
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its
contents are moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

l

Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames.
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can be moved independently from the drawing exposure.

l

Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain
exposed on a specific frame. If a drawing is exposed before a key exposure and you swap out that
drawing for another one, then the original drawing is retained. This preserves the key drawing. Note
that Harmony automatically sets a key exposure when you perform a drawing swap.
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Adding Key Exposures
Key exposures are mainly used for swapping drawings in cut-out animation where you will have numerous
drawings for the various positions of the mouth or eyes of a character for example.
If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is
the same drawing or not.
NOTE
Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be
automatically updated even if set as a key exposure. This keeps your existing animation key poses
intact. It is frequently used on a mouth or eyes layer.
Example: Swapping a drawing with no key exposure
In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure
Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead
is positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing
5 for drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure
1. In the Timeline view, select the drawing cell to set as the key exposure.
2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure
‣

In the Timeline toolbar, click the Add Key Exposure

‣

In the Timeline menu, select Exposure > Add Key Exposure.

‣

Right-click and select Exposure > Add Key Exposure.

button.

button.

A new key exposure is added.
If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that
same drawing. If you added a key exposure anywhere other than the beginning of the drawing,
then the drawing is split in two and both parts contain the same drawing.
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key
exposure is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1
(DR 1). When the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4
(DR 4).

How to remove a key exposure
1. In the Timeline view, select a key exposure to remove.
2. Do one of the following:
l

l

l

In the Timeline toolbar, click the Remove Key Exposure

button.

In the Timeline menu, select Exposure > Remove Key Exposure.
Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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Removing Duplicate Key Exposures
When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of
specific key exposures, unnecessary key exposures will be created. You can delete these duplicates without
affecting the rest of the drawing. The first drawing of the selection will be used for the range.
NOTE
Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures
1. In the Timeline view, select the layer that contains duplicate key exposures.
2. In the Timeline toolbar, click the Remove Duplicate Key Exposure
customize the toolbar to display it).
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Toggling Pasting Key Exposures
When copy and pasting drawings, by default, key exposures that were in the copied selection are also pasted.
You can choose to omit key exposures when pasting drawings by using the Paste Special dialog box or by
modifying the currently selected paste preset.

How ignore or enforce key exposures when copying and pasting drawings using Paste
Special
1. In the Timeline or Xsheet view, select the drawings you want to copy.
2. Do one of the following:
l

Press Ctrl + C (Windows/Linux) or ⌘ + C (macOS).

l

Right-click on the selection and select on Copy cells from the Timeline/Xsheet.

l

From the top menu, select Edit > Copy cells from the Timeline/Xsheet.

3. In the Timeline or Xsheet view, select the cell where you want to paste your selection.
4. Do one of the following:
l

Press Ctrl + B (Windows/Linux) or ⌘ + B (macOS).

l

Right-click on the destination and select Paste Special.

l

From the top menu, select Edit > Paste Special.

The Paste Special dialog box opens.
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5. Check or uncheck the Enforce Key Exposure optiojn, depending on whether or not you want to
paste key exposures.
6. Click OK.

How ignore or enforce key exposures when copying and pasting drawings using Paste
Presets
1. In the Timeline or Xsheet view, select the drawings you want to copy.
2. Do one of the following:
l

Press Ctrl + C (Windows/Linux) or ⌘ + C (macOS).

l

Right-click on the selection and select on Copy cells from the Timeline/Xsheet.

l

From the top menu, select Edit > Copy cells from the Timeline/Xsheet.

3. In the Timeline or Xsheet view, select the cell where you want to paste your selection.
4. In the Timeline view toolbar, check whether the All Drawings Attribute
Exposures Only

, Keyframes Only

paste preset is selected.

5. From the Timeline menu, select Edit > Modify Paste Presets > the active paste preset.
The Edit Exposure Paste Preset dialog box opens.

6. Check or uncheck the Enforce Key Exposure option, depending on whether or not you want to
paste key exposures.
7. Click OK.
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8. Do one of the following:
l

Press Ctrl + V (Windows/Linux) or ⌘ + V (macOS)

l

Right-click on the destination and select Paste Cells in Timeline/Paste.

l

From the top menu, select Edit > Paste Cells in Timeline/Paste.
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About Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in
the project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the
file and not the cells.
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Creating Empty Drawings
T-LAY-003-003
The Create Empty Drawing command automatically Creates a drawing in the selected cell, replacing any
drawing that may already be exposed in that cell and the following ones until it meets another drawing, key
exposure or a blank cell.

How to create an empty drawing
1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.
2. Do one of the following:
l

In the top menu, select Drawing > Create Empty Drawing.

l

In the Xsheet view menu, select Drawings > Create Empty Drawing.

l

In the Xsheet view toolbar, click the Create Empty Drawing

l

In the Timeline view toolbar, click the Create Empty Drawing

l

Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline view.
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Renaming Drawings
T-HFND-005-003
To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.
You can also rename a series of drawings relative to their frame position, which is useful in hand-drawn
animation.

How to rename a drawing
1. In the Timeline or Xsheet view, select the drawing to rename.

2. Do one of the following:
l

Right-click and select Drawings > Rename Drawing.

l

In the Timeline toolbar, click the Rename Drawing

button (you may have to

customize the toolbar to display it).
l

Press Ctrl + D (Windows/Linux) or ⌘ + D (macOS).

The Rename Drawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix
You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet
breakdown and deformation animation.
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1. In the Timeline or Xsheet view, select a drawing sequence. Note that you can only select a drawing
range in one column or layer at a time.
2. Right-click and select Drawings > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.

3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position
1. In the Timeline or Xsheet view, select the drawing sequence to rename.

2. Select Drawing > Rename by Frame.
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Deleting Drawings
You can permanently delete a drawing file from a project's folder.
NOTE
Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing
1. In the Timeline or Xsheet view, select the drawings to delete.

2. Do one of the following:
‣

From the top menu, select Drawing > Delete Selected Drawings.

‣

Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing
T-LAY-003-004
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new
drawing. The exposure of the original drawing that was on the current cell is removed. The original drawing is
not deleted from the project folder or other cells in which it is exposed.
With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This
way, you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing
1. In the Timeline or Xsheet view, select the drawing to duplicate.

2. Do one of the following:
l

From the top menu, select Drawing > Duplicate Drawings.

l

Right-click and select Drawings > Duplicate Drawings.

l

In the Xsheet toolbar, click the Duplicate Drawing

l

Press Alt + Shift + D.
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the
actual drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is
visible over a series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not
linked to drawings. Keyframes can be moved independently from the drawing exposure.
If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to
duplicate the drawings, you must use the Paste Special feature.
There are four different ways to paste your selected drawings with the Paste Special dialog box:
When adding exposures to a drawing layer, drawing files will not be created.
Only create drawing files when they do not exist: When adding exposures to a drawing layer,
new drawings will be created only when drawings with the same name do not already exist in
the destination.
Replace existing drawings. Create drawing files when they do not exist: Replace drawings with
the same names to update a scene with new modified drawings and preserve the animation.
Tip: If you don't want to lose the existing animation when pasting a template, such
as when placing new drawings after the animation, then delete the template's
animation. It will still have updated the drawings but not override the existing
animation.
Always create drawing files: When adding exposures to a drawing layer, new drawings will
always be created. If drawing files with the same name already exist, Harmony will create a new
name for the drawing.
If you want to perform another Paste Special operation using the same settings you used previously, you can
use the Paste Special Again command instead. You can paste your selection using the same settings as in the
most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command
1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or
⌘ + C (macOS).
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2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

3. Do one of the following:
l

Right-click and select Paste Special.

l

From the top menu, select Edit > Paste Special.

l

In the Xsheet or Timeline toolbar, click the Paste Special
customize the toolbar to display it).

l

Press Ctrl + B (Windows/Linux) or ⌘ + B (macOS).

The Paste Special dialog box opens.
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4. Select the Basic tab.
5. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They
Do Not Exist option.

How to paste new drawings with the previous Paste Special settings
1. Do one of the following:
l

From the top menu, select Edit > Paste Special Again.

l

Right-click and select Paste Special Again

l

In the Timeline or Xsheet toolbar, click the Paste Special Again
have to customize the toolbar to display it).

l

Press Ctrl + Shift + B (Windows/Linux) or ⌘ + Shift + B (macOS).
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Pasting Reversed
Once you've copied an animated sequence, you can paste back its drawings in the reverse order.
NOTE
You can perform the same operation using the Paste Special dialog box. To open the Paste Special
dialog box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (macOS).

How to paste a reversed cycle
1. In the Timeline or Xsheet view, select the cell range to paste in reverse order.

2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C
(Windows/Linux) or ⌘ + C (macOS).
3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

4. Do one of the following:
l

From the top menu, select Edit > Paste Reverse.
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l

Right-click and select Paste Reverse.

l

Press Ctrl + . (Windows/Linux) or ⌘ + . (macOS).
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Pasting Cycles
Once you have created a cycle from an animated sequence, you can paste it anywhere, for as many times as you
like and in any direction that you choose.

How to paste a cycle
1. In the Timeline or Xsheet view, select the cell range to loop.

2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C
(Windows/Linux) or ⌘ + C (macOS).
3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

4. Do one of the following:
l

From the top menu, select Edit > Paste Cycle.

l

Right-click and select Paste Cycle.

l

Press Ctrl + / (Windows/Linux) or ⌘ + / (macOS).

The Paste Cycle dialog box opens.
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5. Do one of the following:
l

In the Number of Cycles field, enter the number of cycles you want to paste.

l

Increase or decrease the number of cycles you want to paste.

6. In the Cycle Type menu, select the type of cycle you want to paste.

l

Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your
selection and ending with the last.

l

Reverse: Pastes cycles in the reverse order of the original selection, starting with the
last cell of your selection and ending with the first one.

l

Forward > Reverse: Pastes the first cycle in your selection as is, then the following one
in reverse order. This repeated until all cycles are pasted.

l

Reverse > Forward: Pastes the first cycle in your selectionin reverse order, then the
following one as is. This repeated until all cycles are pasted.

7. Click OK.

NOTE
You can also paste cycles using the Paste Special dialog instead of the Paste Cycle dialog. The
Paste Special dialog gives you access to the same options along with many other options. To access
the Paste Special dialog, do one of the following:
l

Press Ctrl + B (Windows/Linux) or ⌘ + B (macOS).

l

Right-click on the destination and select Paste Special.

l

From the top menu, select Edit > Paste Special.
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Modifying Paste Presets
When pasting key frames and exposures, you can modify the existing presets to your liking. There are three
presets you can modify: the default presets for both key frames and exposures, key frames only and exposures
only.

How to modify paste presets
1. From the Timeline view menu, select Edit > Modify Paste Presets and one of the following options:
l

All to edit the default paste preset settings.

l

Key Frame to edit the preset settings for pasting key frames.

l

Exposure to edit the preset settings for pasting exposures.

The Edit Paste Presets dialog box opens.

2. Refer to the following table and edit the presets as desired.
Parameter

Description

Drawings

Add/Remove
Exposure

Never create drawing files: When adding exposures to a drawing layer,
drawing files will not be created.
Only create drawing files when they do not exist: When adding exposures to
a drawing layer, new drawings will be created only when drawings with the
same name do not already exist in the destination.
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Always create drawing files: When adding exposures to a drawing layer,
new drawings will always be created. If drawing files with the same name
already exist, Harmony will create a new name for the drawing.

Enforce Key Exposure

Fill Gap with
Previous Drawing
Fill to Next Key
Exposure

If there are key exposures that exist on copied drawings, they are preserved
when pasting. No key exposures are added. This is the default behavior
when pasting.

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fills selected area till the next key exposure.

Keyframes
Motion: Copies the properties of the selected motion keyframe to the new
frame.
Velocity: Copies the properties of the selected velocity keyframe to the new
frame.

Add/Remove
Keyframes

Rotation: Copies the properties of the selected rotation keyframe to the new
frame.
Scale: Copies the properties of the selected scale keyframe to the new frame.
Skew: Copies the properties of the selected skew keyframe to the new frame.
Force Keyframes at Function's Beginning and End: Adds a keyframe to the
beginning and end of the pasted function, reproducing the source function.
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Merging Drawings
There are two methods of merging drawings.
l

You can merge selected drawings in adjacent elements. The columns and layers will be left intact, and
each new merged drawing will reside in the frames of the left-most column or lower layer.

l

You can merge elements. All drawings will be merged. Unused columns and layers will be deleted, but
the original drawing files are still accessible.
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Merging Selected Drawings
You can merge drawings from adjacent layers or columns. The merged drawings will appear in the lower layer
or left-most column of the two layers or columns selected.

How to merge selected drawings
1. In the Xsheet view, select the drawings to merge.

2. Do one of the following:
‣

In the Xsheet menu, select Columns> Merge Selected Drawings.

‣

In the Timeline menu, select Layers > Merge Selected Drawings.
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3. Do one of the following:
‣

In the Xsheet menu, select Columns > Merge Selected Columns.

‣

In the Timeline menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining columns
will be left blank at the corresponding frames. In the Timeline view, the bottom timeline layer will contain
the merged drawings from all layers and the other layers will be left blank at the corresponding frames.
Drawings are not deleted and are still accessible.
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Merging All Drawings
You can merge all the drawings in two layers or columns.

How to merge all the drawings in two layers or columns
1. Do one of the following:
‣

In the Timeline view, select the layers you want to merge.

‣

In the Xsheet view, Shift-click the headers of the columns you want to merge.

‣

In the top menu, select Edit > Merge.

‣

In the Xsheet menu, select Columns > Merge Selected Columns.

‣

In the Timeline menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings
from all layers and the other layers will be deleted. Drawings are not deleted and are still accessible.
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Printing the Xsheet
Once you have marked all the information, corrections, and timing you want in the Xsheet view, you can print
your exposure sheet. Printing the Xsheet allows you to take it with you to your animation table or give a copy to
the animator. You can also use it to create your Xsheet skeleton directly in Harmony.

How to print your exposure sheet
1. Select File > Print > Xsheet.
The Print dialog box opens.

2. To set up your print:
l

Windows: In the Select Printer section, select your printer and adjust the rest of the
printing settings.

l

GNU/Linux: In the Print Destination section, select your printer and adjust the rest of
the printing settings.

l

macOS: In the Printer section, select your printer and adjust the rest of the settings by
clicking on the Parameters

button. You can also click PDF and select an option

from the menu if you want to save a PDF version of your exposure sheet.
NOTE
Refer to your printer user guide to learn more about its options.
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3. Do one of the following:
l

Windows and macOS: Click Print.

l

GNU/Linux: Click OK.
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Chapter 7: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing
feature can help speed up the process. This powerful feature automatically creates computer-generated
drawings between your vector drawings to save time and increase productivity. You can easily modify the
timing and velocity (ease in and ease out) of a morphing animation.
One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can
be time-consuming because these types of effects are usually slow moving requiring a large number of closely
placed inbetweens.
The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving
time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with more
time to spend on complex animation tasks such as walk cycles or acrobatic sequences.
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you
are more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be
producing some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and
which drawing lines may be more useful or problematic will enable you to design your key drawings so they
morph efficiently.
NOTE
The more complex the shape is, the longer it takes to morph. If it takes more time to morph a
drawing than to hand-draw it, then it is better to animate it instead of morphing. However, if you
spot an occasion when you can morph your drawings, do it! It allows you to fix your timing and
velocity in no time without having to create any extra drawings!
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About Source and Destination Drawings
The morphing feature matches similar shapes in a source and a destination drawing. Harmony evaluates the
source's shape properties and matches them to the most similar ones in the destination drawing.

Morphing works between similar shapes, which are drawings that have the same palette, colours and number
of shapes. You can even change any shape into another one, as long as the source and destination keep the
same colours, number of lines and number of shapes.
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About Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules
before you start morphing.
NOTE
Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap
layers or Toon Boom bitmap drawings.
Here are a few tips about creating morphing sequences:
l

When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil
line for simple closed shapes.

l

If you are using pencil lines, use Contour hints instead of Pencil hints. Use Pencil hint if you want the
Pencil line to switch direction.

l

Flatten your drawing before starting a morphing sequence.

l

If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the
source line is closer to the dot than the destination line, the source line will morph into the dot and the
destination line will disappear.

l

Use the same colour swatch between two drawings. You cannot morph between two different colour
swatches even if they have the same RGB values. This can be turned to your advantage for complex
morphing.

l

Similar shapes should have the same number of colour zones. This only applies to the number of zones
and lines and not the number of points on a curve.

l

If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the
morphing will fail.

l

For example, if you are morphing a face so it turns from the front to the side, the nose is located in the
middle of the face on the source drawing. However if after morphing, the nose ends up outside or
merged with the face profile line on the destination drawing, this will give undesirable results. You can
avoid this by using morphing layers and splitting the nose on a separate layer.
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About the Closest Similar Shape Rule
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it
will morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (colour ID)
and has the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same colour swatch.
It will morph with the red diamond shape (1) in the next drawing. The red diamond shape (2) in the source
drawing will morph with the red heart shape (2) located in the same area in the destination drawing. The black
spade shape (3) in the source drawing will morph with the black club shape (3) located in the same area in the
destination drawing. Finally, the black club shape (4) in the source drawing will morph into the black spade
shape (4) located above in the destination drawing.
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About the Pencil Line to Pencil Line Rule
If you trace a shape using a pencil line such as the Ellipse

, Rectangle

, Polyline

, Line

or Pencil

tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central
vector).

A pencil line will never morph with a brush stroke.

Pencil lines with thickness are supported in morphing sequences. The thickness will morph according to the
thickest and thinnest areas in the source and destination drawings.
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Pencil lines with textures are not supported in a morphing sequence. During the morphing, the texture will
disappear and show without pencil line opacity texture.

If you have pencil lines in your source drawing, the same number of pencil lines must be present in the
destination drawings. A pencil line will appear if it is not found in the destination drawing. It will pop out on the
first or last frame depending on which one it is drawn.
When two pencil lines cross one another, they are considered to be two lines and not four lines anymore (as it
was in version 7.8 and below of the application). In this case, you must have two pencil lines in your destination
drawing for your morphing to work correctly.
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About the Fill Shape to Fill Shape Rule
If you have a brush stroke or a colour fill ( contour vectors), make sure that you morph it with another brush
stroke or fill zone. It is important to undersand that strokes drawn with the Brush tool are the same thing as
zones painted with the Paint tool. Vector points are located along the contour. They are simply not the same
size. Contour vectors will not morph with pencil lines (central vectors). A brush stroke can morph into a colour
fill zone and vice versa as they are the exact same thing.
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About the Same Colour Swatch Rule
Harmony does not morph between colours. If you want to perform a colour transition, you have to create the
effect during the compositing step of your production. A colour palette is composed of colour swatches. Each
colour swatch has its own unique identification number, even if two swatches are the same colour value, they
are identified independently. A colour zone or shape will morph with another one painted with the same colour
swatch.
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About the Vanishing and Appearing Rule
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or
disappear.
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About the Colour Art and Line Art Rule
In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically,
an extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular
layer on which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.
l

A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art.

l

A shape drawn in Line Art can only be morphed with another shape existing in the Line Art.

l

A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating Morphing
When it comes to morphing, you will need to practice and become at ease with it. Once you are familiar with
the basic rules, you can start creating morphing sequences. To begin, start with simple elements. When you are
confident with the morphing process, you can start to use complex and advanced morphing techniques, such
as head rotations or full characters.

NOTE
As you create and adjust your morphing sequences, you will often use the Tool Properties view.
Using this view allows you to do things such as toggle between your key drawings, adjust the
easing or select a hint type.

How to create a basic morph
1. In the Timeline toolbar, click the Add Drawing Layer

button to add a new layer to your project.

2. Rename the new layer ( for example, Morphing).
3. In the Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:
l

In the Tools toolbar, select the Rectangle

l

Press Alt + 7.

tool.

5. In the Camera or Drawing view, draw a rectangle.
NOTE
When drawing a rectangle or an ellipsis, you can hold down the Shift key to
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draw your shape with equal dimensions, so as to make a square or a circle
instead. You can also hold down the Alt key to draw the shape from its center
rather than from its corner.
6. Paint your rectangle using the Paint tool.

7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

8. Do one of the following:
l

In the Tools toolbar, select the Ellipse

l

Press Alt + =.

tool.

9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.

10. In the Xsheet or Timeline view, select the range of frames going from your first drawing to your
second drawing, including the frames containing the drawings.
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11. Do one of the following:
l

From the top menu, select Animation > Morphing > Create Morphing.

l

In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing

l

Press Alt + M.

Arrows going from the first key drawing to the second key drawing appear, indicating that
computer-generated inbetweens have been created.

727

Harmony 15.0 Premium User Guide

Deleting Morphing
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.

How to delete a morphing sequence
1. In the Xsheet or Timeline view, select a cell in the morphing sequence.
2. Do one of the following:
l

From the top menu, select Animation > Morphing > Delete Morphing.

l

From the Xsheet or Timeline view menu, select Morphing > Delete Morphing.

l

right-click on your sequence and select Morphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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About Morphing Velocity and Timing
Once you have set up a morphing sequence, you can control its velocity and timing.
When you look at your animation you will notice that the morphing motion is constant. To produce a less
mechanical motion, you will probably want to create some ease in or ease out.

If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one
function curve rather than several separate ones. Having all of your velocity parameters in one place is more
efficient and easier to modify.
Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the morphing
sequence. The sequence will always start with the source drawing and end at the destination. You can play the
morphing sequence backwards or forwards during the animation.
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Adjusting the Morphing Velocity
You can have two levels of easing:
l

In the Tool Properties View, you can adjust the velocity of each sequence in your layer independently

l

In the Layer Properties editor, you can adjust the morphing velocity function to control the entire layer's
easing

How to adjust the velocity in the Tool Properties view
1. In the Tools toolbar, select the Morphing

tool or press F3.

2. In the Timeline view, click on a frame in the morphing sequence you want to adjust.
3. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the
sequence's velocity.

How to adjust the velocity in the Layer Properties editor
1. In the Timeline view, double-click on the drawing layer to open the Layer Properties editor.
2. In the Layer Properties editor, go to the Advanced tab and click on the Function

button to create

a function curve.

3. In the Layer Properties editor, click the Function

button again to open the velocity curve.

4. Add a keyframe at the first frame of the morphing (source) and one at the end (destination) by
clicking on the Add/Remove Keyframe

button.
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5. Move the destination keyframe upward.

NOTE
It is important that the last keyframe remains above the first one.
6. Make sure that the first keyframe is not a stop-motion keyframe. To do this, disable the Stop-motion
Keyframe

button. To use the Toggle Stop-Motion Segment feature, press S.

7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the
curve go downward instead of upward, the animation will play backward until the curve starts to go
upward again.
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NOTE
If you have more than one morphing sequence in the same layer, you need to add a keyframe
on the velocity curve for each source and destination drawing.
8. If you want your morphing to play back on a double frame exposure rather than single frame, you
can use the Hold Value editor and set the velocity to change every second frame, instead of every
frame.
9. In the Morphing Function editor, click on the Hold Value Editor
hold the value for two frames.
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Adjusting the Morphing Timing
If you did not place your source and destination drawings on the correct frames you may need to extend or
shrink the sequence length.

How to extend or shrink a morphing sequence length
1. In the Timeline view, select the source or destination drawing.
2. Click on your selection and drag the drawing to its new frame.
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About Morphing Hints
Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to
place hints to ensure Harmony morphs your drawings the way you intended.

Hints are points that are placed in both the source and destination drawings to associate zones and lines
between the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line
that is not following the colour fill zone, or when a part of your source drawing doesn't morph into its
corresponding part of the destination drawing. By default, Harmony will associate a corner or a point in the
source drawing with the nearest corner or point in the destination drawing. Hence, hints quickly become
necessary if the shape being morphed or its movement is complex.
Hints always exist on both the source and destination drawing. When you create a hint on either drawing in a
morph, a corresponding hint will automatically appear on the other drawing. The same principle applies if you
delete a hint.
The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this
may also fix the smaller ones at the same time.
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Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to
correctly use and place hints.
If you are morphing two sequences in a row, you will have to create a different set of hint points for each
sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create
two morphing sequences; one sequence between drawings 1 and 2, and a second sequence between
drawings 2 and 3.

NOTE
Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will
have a set of hints for the first sequence and another set for the second sequence. The two sets of
hints will not show at the same time. Each set of hints that appears always corresponds to the
morphing sequence you are working on.
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About Hint Types
To correct morphing distortions, Harmony has different types of hints available for controlling different types of
problems.
Each type of hint has a different purpose and they can all be used in the same drawing. Use the Morphing tool
to add hints to your morphing sequences.
Hint points in the source drawing are green and red in the destination drawing.
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About Contour Hints
The Contour Hint point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It
allows you to control the line thickness and contour position. Also, if a contour is not animated correctly, you can
use hints to correct the animation. For example, if a flag is not waving properly.
When adding a Contour Hint point, make sure to place it far enough away from the contour so you can see it
snap to the contour.
Contour Hint points are yellow.
NOTE
Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour,
when in fact, it has not and the morphing will remain unchanged.

NOTE
To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations
over time.
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About Zone Hints
The Zone Hint point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the centre
of the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For
example, in a splash animation there are many water droplets that are the same colour. Harmony automatically
morphs the droplet to the nearest one. This is not always the one you may have predicted. A Zone Hint will
force a colour zone to morph with another one.
Zone Hint points are cyan in colour.
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About Pencil Hints
A Pencil Hint point is used to control a pencil line, also known as central vector. It can be used on drawings that
were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil Hint
snaps to the central vector. Make sure to place it far enough away from the line so you will see it snap when you
move it.
Pencil Hint points are magenta in colour.
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About Vanishing Point Hints
A Vanishing Point Hint is used to control the trajectory of a vanishing shape. A shape will vanish from the
source drawing when there is no corresponding shape in the destination drawing. If you do not place a
Vanishing Point Hint to control the point of disappearance, the shape will vanish into its centre.
Vanishing Point Hint points are green in colour.

740

Chapter 7: Morphing

About Appearing Point Hints
An Appearing Point Hint is used to control the trajectory of an appearing shape. A shape will appear in the
destination drawing when there is no corresponding shape in the source drawing. If you do not place an
Appearing Point Hint to control the point of appearance, the shape will appear from its centre and expand
outwards.
Appearing Point Hint points are violet in colour.
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Adding and Deleting Morphing Hints
Using the Morphing tool you can use hints to correct the morphing sequence.

How to add and hints
1. In the Timeline or Xsheet view, select the source drawing of your morphing sequence.
2. In the Tools toolbar, select the Morphing

tool or press F3.

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a
reference.

3. In the Tool Properties view, select the type of hint you want to use.

l

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil
line. Note that you obtain better results using the Pencil Hint point on pencil line
rather than Contour Hint points.

l

Select Pencil Hint to correct a pencil line (Central vector).

l

Select Zone Hint to correct a colour zone morphing match.

l

Select Vanishing Point Hint to correct a vanishing shape's trajectory.

l

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the problematic area.
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5. Select the hint's point and move it to its correct position.

6. In the Timeline or Xsheet view, select your destination drawing.
7. Find and move the corresponding hint's point to the matching part of your destination drawing.

8. In the Playback toolbar, press the Play

button to see the result.

How to delete hints
1. Select one or many hints.
2. Press Del.
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NOTE
To delete all of the hint points at once, press Shift + Del.
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Copying Hint Points
If you have two morphing sequences that use the same drawing and you would like to copy it and its hint
points, you can do so in the Drawing view.

How to copy a drawing and its hints
1. Do one of the following:
l

In the Tools toolbar, click the Select

l

Press Alt + S.

tool.

2. In the Drawing view, select the drawing to reuse in your second morphing sequence.
3. Do one of the following:
l

In the top menu, select Edit > Copy.

l

Press Ctrl + C (Windows/Linux) or ⌘ + C (macOS).

745

Harmony 15.0 Premium User Guide

4. In the Timeline view, select the cell where the new drawing will be.

5. In the Drawing view, paste your selection.
6. Do one of the following:
l

In the top menu, select Edit > Paste .

l

Press Ctrl + V (Windows/Linux) or ⌘ + V (macOS).

7. In the Timeline view, select the cell where the second drawing will be.

8. In the Drawing or Camera view, draw your second drawing.

9. Do one of the following:
l

In the Timeline view, create the morphing sequence for the new drawings.

l

Press Alt + M.
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10. Do one of the following:
l

In the Tools toolbar, select the Morphing

l

Press F3.

tool.

11. In the Drawing or Camera view, position your hint points.
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About Morphing Layers
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control and may not
work properly, by dividing the drawings into morphing layers, the task becomes much easier.
The major points used in controlling a morphing sequence are the intersections. If there are many lines
intersecting within a drawing, the system will require more control—see About Hint Types on page 736
An important aspect of morphing is to identify possible problem zones in order to fix them and avoid
potentially frustrating situations.

Simple details that look easy to morph can sometimes be more challenging than they may initially appear to be.
For example, you may find that the nose becomes an issue when performing a head rotation. As explained
earlier, the drawings need to be similar in their number of shapes. Generally, on a head rotation, the source
nose is in the centre of the face, but on the destination, the nose line is part of the face outline. This means that
on the source drawing, the nose and the face outline are two separate shapes, whereas they are combined into
one shape on the destination drawing.
Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the
destination nose grows from the character's cheek.

748

Chapter 7: Morphing

Any shape that is contained inside another one and has to morph out of that shape will be problematic for the
same reasons as the nose is. At some point during the morphing sequence, the shape contained inside the face
will merge with the face outline, and then become a separate shape again.
Morphing layers are all contained in the same drawing layer. It is like having a mini Timeline within a Timeline
layer, or a mini Xsheet within an Xsheet column.
Each morphing layer can have its own duration and velocity. Also, because you only have a single element to
handle in your Timeline or Xsheet view, it will be treated as one element for the Compositing process, making
the compositor's work easier.
You can separate all of your elements into different drawing elements and have many layers, but you would
have to create a large number of morphing sequences and make sure that you modify all of their timings
properly.
Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene
structure by adding more elements, which can be very important for Cut-out animation puppets. For example, if
you morph a front head to a three-quarter head where the ear needs to be separate, you do not want to add a
new ear layer at the same time and have to worry about connecting it inside the puppet's construction. Instead,
simply create an ear morphing layer within the head layer.
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NOTE
Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can
also use the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one
and so one. This technique is useful if you plan to do more than one morphing sequence in the same
column. For example, front head to three-quarter head to side head. The three-quarter drawings
will be used in both morphing sequences.
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Creating Morphing with Morphing Layers
You can create morphing sequences on separated layers using morphing layers.

How to create a morph with morphing layers
1. In the Timeline view, add a new drawing element and name it properly.
2. In the first cell, draw the main source shape such as the head shape or body shape. Do not add
details like eyes.

3. In the Timeline view, select the destination cell.
4. Enable and extend the Onion Skin.

5. In the destination cell, draw the second drawing.
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6. In the Timeline view, select the in-between cells.
7. Do one of the following:
l

Right-click and select Morphing > Create Morphing.

l

Press Alt + M.

8. In the Tools toolbar, select the Morphing

tool.

9. In the Morphing Tools Properties view, click on the Add Layer

button to add a new morphing

layer. When you click on a morphing layer drawing, it automatically appears on top of the others. If
you want it to stay in place, for example the wing behind the body, enable the Show Morphing in
Place

option in the Morphing Tool Properties view.

10. Double-click on the new layer's name and name it appropriately.
11. Press Enter/Return.

12. Use the Up
l

and Down

arrow buttons to move the new layer above or below the Main layer.

If placed above the Main layer, it will be displayed in front. If it is placed below, it will
be displayed behind.
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13. To create new drawings, double-click on the blank area under the From section to create the source
drawing and the To section for the destination drawing and type a different value than the ones
used for the main layer.
14. Press Enter/Return.
You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

15. Click on the new source drawing to start drawing the new part. (Make sure that you are working on
the proper drawing by verifying the name in the Camera or Drawing view's bottom left corner.)

16. In the Camera or Drawing view, draw the source drawing.
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17. Once the source drawing is done, use the Morphing Tool Properties view and click on the
destination drawing's name and draw it in the Camera or Drawing view.
18. Repeat steps 9 to 15 for each layer needed. You can add as many layers as you want.
19. Enable or disable the layers that you want to display or hide while drawing.

20. If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.
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About Morphing Key Drawings
Once you have a morphing sequence, you can add a morphing key drawing.

A morphing key drawing allows you to insert extra details into a morphing sequence. For example, during a
morphing sequence you may need to insert a detail such as teeth or a mouth; this is easy to do when you use a
morphing key drawing. Instead of creating an entirely new drawing, convert a computer generated inbetween to a morphing key drawing and add your extra details to it and the next key drawing.
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Inserting Morphing Key Drawings
A morphing key drawing converts a computer-generated morphing frame into a real drawing that you can
edit. It splits the morphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing
1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing
keyframe.

2. Do one of the following:
l

In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

l

Right-click and select Morphing > Insert Morphing Key Drawing.

The new morphing key drawing appears.

3. In the Drawing or Camera view, draw your new details on the morphing key drawing.
4. In the Playback toolbar, press the Play

button to see the result.
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About Transparency Morphs
To be able to morph shapes with holes or transparent colours, it is important to understand the process of
analyzing and morphing a shape. Harmony begins the process by reading the exterior outline of the entire
shape. So if you are morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as
colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled with
an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour
so that you can control it and flatten the transparency to cut a hole through the main shape.
The same thing happens when you have holes painted with semi-transparent colours. To see through your
shapes, you have to follow the same process as morphing shapes with holes.
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Morphing Transparencies
You can use invisible colours to morph holes and transparencies.

How to morph a shape with a hole
1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. Do one of the following:
l

In the Tools toolbar, select the Morphing

l

Press F3.

5. In the Tool Properties view, enable the Flatten
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A hole appears in the shape.
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About Morphing Quality
Increasing the morphing quality settings improves the line shape between vector points. It also creates a larger
file, so only increase quality when you are zooming in closely. You can adjust the quality in the Tool Properties
view and in the Preferences panel.

When morphing in Toon Boom Harmony, there is a preference you can set to help you set the default quality of
morphing sequences. Refer to the Preferences Guide for complete descriptions.
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Setting the Morphing Quality Level
Increase the morphing quality to smooth out morphed lines.

How to set a morphing sequence's quality level
1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. Do one of the following:
l

In the Tools toolbar, select the Morphing

l

Press F3.

tool.

3. In the Tool Properties view, adjust the Quality level.
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Converting Morphing Animations to Drawings
Harmony lets Lets you convert your morphing inbetweens to real drawings you can edit. This is useful when
manually editing a morphing sequence or if you prefer to have animation timing in double frame (on twos)
instead of single frame (on ones).

How to convert morphing inbetweens to drawings
1. In the Timeline or Xsheet view, select a morphed drawing in the morphing sequence you want to
convert to real drawings.

2. Do one of the following:
l

In the top menu, select Animation > Morphing > Convert Morphing to Drawings.

l

Right-click and select Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename you want to give to your new drawings. In this case, you could type
circle.
4. Click OK.
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Chapter 8: Rigging
Harmony is a great tool for building characters. You can use different techniques and features to break down
your puppets.
This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create
very advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with
those concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformations on page 1071.
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About Rig Types
T-RIG-001-001
A rig is the process in which you will take apart the multiple pieces of your character and then reattach them
together to get them to move individually. Harmony provides you with a multitude of tools to help you build
characters. From the simplest of rigs, to a fully rotating character. There are about as many ways to rig a
character as there are individuals who make them. The complexity of the rig is often determined by the level of
animation to be achieved.
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About Simple Rigs
T-RIG-001-002
Simple rigging is very fast and easy to do. It is built as follows:
l

All the body parts are independent

l

All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by
a parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a
straight trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand
to move along a curved path.
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About Drawing Hierarchy Rigs
T-RIG-001-003
When you want one part to follow another part, such as the forearm following the arm, you can attach the
layers one to the other. For example, you can attach the forearm layer to the arm layer without having to
encapsulate the forearm into the arm layer. They will still be parented, but you can access the forearm directly
without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to
select them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children,
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is
often a good solution.
NOTE
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline
view.
Harmony offers powerful techniques to create hierarchies between your layers without having to
encapsulate layers into each other. These techniques are a great improvement over the less
efficient and time consuming method of creating parenting between your layers by inserting
symbols into other symbols. Therefore, rigging with symbols inside symbols is NOT recommended.
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About Peg Hierarchy Rigs
T-RIG-001-004
Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that
do not contain drawings. They are motion paths that you can use to control your entire puppet or advanced
hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale
a body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that
could be attached to that part.
Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer
follow the same trajectory.
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About Scene Setup for Rigging
Planning your rig is an essential step in avoiding missteps at later stages. Once a rig has moved on to the
animation level, it becomes more difficult to fix potential blunders, since updating the rig scene doesn't have
repercussions on rigs outside of that scene. These different topics will help you avoid such mistakes.
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About Models
To begin breaking down your puppet, you must first import your character into a new project. You can also
draw your character directly in the scene.

You can import your character in several different formats:
l

Library template—see Library

l

Bitmap image or picture

l

External vector format

Model Alignment
When setting the character model in your scene, we recommend that you to center it in the Camera view and
scale it to fit inside the safe area frame.
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If you have several views of your character, place each view in a separate cell and center them one on top of
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the
same size.

Photo Puppets
If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software.
Then, import your parts and vectorize them as textured images.
A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.
In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any
layer that is not in a folder group, by itself or otherwise, will not be imported.
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About Size Relation
Understanding the relative size of every character and prop is important for maintaining consistency and
structure throughout your project.
A production may contain many characters and props. It is not unusual for these to have been created by
different people. If there is no size control implemented, the characters and elements created by different
artists can vary greatly in size. When this occurs, the characters that are put together in a scene will be out of
proportion. The animator or person doing the scene setup will then have to scale them to the correct size.
When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is
scaled to its proper size, the outline may be so thin that the difference between one character's outline and
another's will not look very good.

Line Up
A line up consists of copying and pasting all of your character designs into the same drawing and then scaling
them so they are in proportion with each other. This line up is very important and should be handed to any
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body
beside the prop. This enables the animator to know what size to draw or set the prop.
In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually
done during the character design step. When the character builder imports the model to the break down
scene, the size relation should be correct.

Field Chart
The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can
display the field chart using the Show Grid option in the Camera and Drawing views.
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How to display the field chart
1. Do one of the following:
‣

From the top menu, select View > Grid > Show Grid.

‣

Press Ctrl + ' (Windows/Linux) or ⌘ + ' (macOS).

‣

Click the Show Grid

button in the Camera View and Drawing View toolbars.

Brush Size
There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good
idea to create and save pens with precise sizes and parameters to trace and design your models and break
downs—see About the Brush Tool on page 139.
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Setting Preferences for Rigging
Before you start adding layers to your puppets, make sure the Default Separate Position for Elements and the
Default Separate Position for Pegs preferences are enabled.
With the Default Separate Position preferences selected, when you create new layers, their X, Y and Z axes are
independent from each other.
By default, the Default Separate Position for Elements preference is enabled. For cut-out animation, you want
to have three independent axes so you can control them individually.
When you lock the three positions together, each time you add a keyframe, it is added on all three positions at
the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This
gives you more freedom when animating with motion keyframes and nudging parts forward and backward
over time.

How to set the Default Separate Position options
1. Do one of the following:
l

Windows/Linux: Select Edit > Preferences.

l

macOS: Select Harmony Premium > Preferences.

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. In the Preferences dialog box, select the General tab.
3. In the Settings section, select the Default Separate Position for Elements and the Default
Separate Position for Pegs options.
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4. Click OK.

775

Harmony 15.0 Premium User Guide

About Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention chart before
starting the project. When dealing with thousands of characters, pieces and puppets, it is easy to get lost.
Proper naming of both drawing layers and drawing substitutions is essential to keeping your workflow
consistent throughout your project.
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Naming Drawing Layers
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient
in later steps.
One common practice is to add one or two letters for the character/prop name, so that we don't make it too
long. You can then add the name of the part that you've separated. It is recommended to add an indicator of
the position of your character's symetrical pieces to keep track of which part you are selecting. Common
practice is to add either "F" or "B" (for front and back view) or "R" or "L" (for right or left). Avoid using spaces in
between the words and opt for an underscore instead.
l

Character Orcus's right arm =
OR_arm_F
or
OR_arm_R.

Pink: Front or Right
Blue: Back or Left
In the event that you've forgotten to add a prefix or suffix to your character's drawing layers, you can add them
after your layers have been created.

How to add a prefix or suffix to a series of layers
1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A
(Windows/Linux) or ⌘ + A (macOS).
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2. In the Scripting toolbar, click the Add Prefix or Suffix Script

button. If the Scripting toolbar is not

visible, you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the
Add Prefix or Suffix Script

button is not visible in the Scripting toolbar.

The Add Prefix or Suffix dialog box opens.
3. Select the Prefix or Suffix option depending on what you want to add to the layers' name.
4. Type the prefix or suffix information to be added to the layer's name.

5. Click OK.
6. The defined prefix or suffix is added to the selected nodes and layers.

How to remove a prefix of suffix to a series of layers
1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A
(Windows/Linux) or ⌘ + A (macOS).
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2. In the Scripting toolbar, click the Add Prefix or Suffix Script

button. If the Scripting toolbar is not

visible, you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the
Add Prefix or Suffix Script

button is not visible in the Scripting toolbar, see the Scripting guide

The Add Prefix or Suffix dialog box opens.
3. Select the Prefix or Suffix option depending on what you want remove from the layers' name.
4. Type the prefix or suffix information to be deleted from the layer's name.

5. Click OK.
6. The defined prefix or suffix is removed from the selected nodes and layers.
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Naming Drawings Substitutions
We recommend that you use a naming convention for your drawings. Especially if you combine all the angles of
a character in the same breakdown scene, it is a good idea to identify each angle used.

Before breaking down the characters for your production, we recommend that you create a drawing name
convention that represents the angle used. For example, use "f" for front, "s" for side, "q" for three-quarter so
that the drawing name looks like this: f1, f2, f3, s1, s2, etc. This will be quite useful during animation and
drawing substitution. Since drawings are displayed in alphabetical and numerical order, all the drawings for
the front view will be together, then all the drawings for the three quarter view, and so on.
Keep in mind that in the drawing substitution library, drawings will show in alphabetical order. If you want
them positioned in a certain order, make sure you name them accordingly.

How to add a prefix to one or more drawings
1. In the Timeline view, select the drawing range to rename.

2. Do one of the following:
‣

Right-click on the selection and select Drawings > Rename Drawing with Prefix.

‣

From the top menu, select Drawing > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.
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3. Type the characters you want to add before the current drawing name.
4. Click OK.

NOTE
To rename a drawing, select the drawing and use the Rename Drawing option. Ctrl + D
(Windows/Linux) or ⌘ + D (Mac OS X). or . Do not double-click on the frame and write a new
name, as this will create a new drawing and hide your actual one. Note that the hidden
drawing has not been deleted and is still located within the element folder. Simply retype the
name and it will reappear.
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About Character Breakdown
T-RIG-001-006
Now that you have imported or designed your model, the next step is to analyze it. This is to determine what
parts will be broken apart and how they will be divided. Will the hair be separated into one, two or three
sections? Will the hand be separated from the sleeve? To determine what is best for your character, observe
the model in the Camera or Drawing view.

Eyelids and Pupils
For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil
and the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the
eyeball. For a more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw
To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth
shape, teeth, tongue and interior one from another.
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Keeping Fingers Attached to the Hand
To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and
produces a less mechanical effect.

Flipping Logos
You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a
character's puppet.

Complete and Overlapping Pieces
For a better result with animated parts, it is important to understand that they must be properly overlapping
and complete. A common mistake is to trace the part just as it appears on the model.
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Tracing the Model
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing
1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R
(Windows/Linux) or ⌘ + R (macOS)—see .

2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select the drawing tool of your choice. There are two commonly used methods
to drawing the parts of a cut-out character model:
l

Using the Pencil

l

Using the Polyline

tool, then smoothing your lines with the Smooth Editor

tool

tool. This method allows you to draw with great precision, but

may take more time.
These methods ensure each part is made with as few points as possible, so that they are easy to
manipulate, modify or redraw.
4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see
.
5. If you prefer working in the Drawing view, do one of the following to display the other layers in
washed out colours:
l

In the Drawing view toolbar, lick the Light Table

l

Press Shift + L.

6. In the Camera or Drawing view, draw the new part.
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7. If you want to close an open shape without drawing a visible outline, you can draw an invisible line
using the Stroke

tool.

NOTE
By default, your strokes are not visible. To see the strokes in your drawing, select View >
Show > Show Strokes from the top menu or press K.
8. In the Tools toolbar, select the Paint

or Paint Unpainted

tool to colour your drawing.

9. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.
10. In the Camera or Drawing view, paint your drawing.
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11. In the Tools toolbar, select the Select
the Flatten

tool. Select your drawing and flatten the lines by clicking

button in the Tool Properties view.

12. If your lines are composed of several pencil strokes, you might want to combine them into one single
smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool
Properties view, click the Merge Pencil Lines

button.

13. Repeat the entire process for every body part that you wish to make animatable.
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About Cutting the Character into Pieces
If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with
the Cutter tool, you select and send pieces of the model on a new layer.

The first step in breaking down your character is to do a rough cut down of the main parts, such as the body,
arms, legs and head. Using the Create Drawing from Drawing Selection feature lets you automatically create
layers and copy your selection in it.
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Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature.
Breaks a character into its main body parts. There is no need to create any layers prior to this process. Make
sure your model is well centered and sized in the Camera view.
You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the
artwork of the part you want to break down. You will clean the extra bits and pieces later.
Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines
and colour zones.

How to break down the main parts
1. In the Timeline view, select the cell of the model that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter
l

tool.

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or

press Alt + S.
l

In the Tool Properties view, you can switch to the Lasso

selection mode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the
Cutter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣

Hold down Shift to create a new lasso selection around another zone and add it to your previous
selection.
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4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (macOS).
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming
convention you established previously.
6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original
drawing. You do not want to cut the artwork from the colour model.
7. Click OK.
The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

8. Repeat the previous steps for each main body part.
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Breaking Down Secondary Parts
You should now have a layer for each main part of the character for the first view to break down. You are now
ready to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the main part break down process except that this time you
will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts
1. In the Timeline view, lock your model layer by clicking its Lock

button.

2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

3. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, choose the Select

tool from the Tools toolbar or press Alt +

S.
4. In the Camera view, create a selection around the part to break down.
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‣

If you click on a zone, the Cutter

tool will select the zone and end the selection at the first

point of intersection that it meets. Click on the line with the Cutter tool to select it up to the next
intersection.

5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (macOS).
The Create Drawing From Drawing Selection dialog box opens.

6. In the Layer Name field, type the name of the layer you want to create following the naming
convention you established previously.
7. Select the Cut Artwork From Source option to remove the selected artwork from your original
drawing. In this case, you want to cut the artwork from the colour model.
8. Click OK.

794

Chapter 8: Rigging

The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.

9. Repeat the previous steps for each body part.
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NOTE
If you forgot to add some artwork to a layer you previously created, you can always add it later.
In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from
Drawing Selection dialog box by pressing F9 (Windows/Linux) or ⌘ + F9 (macOS). In the dialog
box, select an existing layer from the list instead of typing a new name. Click OK to add the artwork
to the existing drawing in the layer you selected.

796

Chapter 8: Rigging

Breaking Down Other Views
If your character model has more than one view, now is the time to break them down.
The process is very similar to breaking down the first view. You have two choices:
l

Breaking down the new view in a new set of layers

l

Breaking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are
breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.
Repeat the following steps for each extra view you need to break down.

How to break down the other views
1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't
forget to unlock the layer.

2. In the Tools toolbar, select the Cutter
l

tool.

If you prefer to use the Select tool, in the Tools toolbar select the Select

tool or press Alt + S.

2. In the Camera view, create a selection around the first part to break down.

3. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (macOS).
The Create Drawing From Drawing Selection dialog box opens.
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4. In the Layer Name field, select the corresponding layer from the list if you want to use the same
layers or type a new name if you want to create a new layer.
5. Deselect the Cut Artwork From Source option to keep the selected artwork on your original
drawing. You do not want to cut the artwork from the colour model.
6. Click OK.
The artwork is inserted into the existing layer. The drawing is created in the same frame number as
the cell it was taken from. It is not incorporated in the other view's drawings.

7. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views, follow the exact same process as you did for the first
view you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down Other
Views on page 797.
Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to
have the same layer structure.
Here is an example of how your timeline should look at this stage:
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Completing Parts and Articulations
Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and
complete the articulation.

Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:
l

Brush tool

l

Eraser tool

l

Select tool

l

Cutter tool

l

Contour Editor tool

l

Paint tool

l

Close Gap tool

How to clean your drawings
1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.
3. In the Camera view, delete the extra bits using the Select
Eraser

tool.
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4. Draw the missing lines using the Brush
enable the Auto-Flatten

5. Using the Paint
Gap

tool. If you use the Brush tool, it is recommended that you

option in the Tool Properties view.

tool, paint the gaps. You can close some gaps with invisible lines using the Close

tool or press Alt + C.

6. Reshape your lines using the Contour Editor

tool or press Alt + Q.
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7. Using the Select

tool, select the entire drawing and click the Flatten

button in the Tool

Properties view to flatten your drawings.
8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be
present in your drawing or press K.

9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any
unnecessary invisible lines in the drawing.
10. Repeat this entire process for each drawing to fix.

802

Chapter 8: Rigging

Distributing to Layers
When breaking down a character, you can distribute each selected art stroke to a new layer.
Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke.
If one part of your puppet is composed of several strokes, you must group them before distributing them onto
new layers.
NOTE
You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers
1. In the Tools toolbar, click the Select

tool.

2. In the Camera view, select the art strokes you want to distribute to different layers.

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers

button

in the Tool Properties view.
Drawing layers are created in the Timeline view, each corresponding to the different strokes or
groups of strokes selected. Each stroke or group of strokes is distributed into each new Drawing
layer. The selected strokes in the original drawing layer are removed.
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About Articulations
Once your pieces are traced, you can go ahead and complete the articulations.
Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move
properly and will not look good.
If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect
will create the joint for you.
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Creating Classical Articulations
Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent
results, but it's not the most efficient method. In many instances, it causes limitations and extra drawing
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually
a circle; the overlapping part cannot be sent behind without showing the joint.
Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping
the bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation
1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the
upper arm.

2. In the Tools toolbar, select the Pencil

, Polyline

, Ellipse

, Cutter

, or Contour Editor

tool.
3. In the Colour view, select an outline colour.
4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part
in a half-circle shape.

If you are working in the Drawing view, click the Light Table

button in the Drawing toolbar or

press Shift + L.
5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines
that may be present in your drawing.
6. In the Drawing or Camera view, select all the strokes in your drawing.
7. In the Tools Properties view, click the Flatten

button.

8. In the Drawing or Camera view, select all the strokes in your drawing.
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9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary,
invisible lines in your drawing.
10. Repeat the previous steps for the other articulations.
11. In the Timeline view, select the cell of the part that will be on top of the joint.

NOTE
When placing rotation pivots later on, make sure they are positioned at the
centre of the articulation.
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About Auto-Patch Articulations
Harmony has a very efficient node to automatically patch an articulation without you having to do any line
adjustment or colour overlapping. You can draw your two pieces with their complete lines overlapping each
other in semicircles and the Auto-patch node will create a perfect articulation from it.

In order for the Auto-patch to work on your puppet, you must draw the outline with the Pencil tool (pencil lines)
on the Line Art layer of your drawing, and then paint the colour on the Colour Art layer.

You can use this technique in even more efficiently by adding extra lines in the Overlay layer of your drawing to
create a fold illusion for a bent elbow.
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About the Auto Patch Node
The Auto Patch node is used mainly when creating joint patches for cut-out puppets drawn with pencil lines
and painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a seamless
joint, you can draw complete pieces, and with the Auto Patch node, automatically create a perfect articulation.

The requirements for this effect to work are:
l

Drawing outlines must be drawn in pencil lines

l

Drawing outlines must be drawn in the Line Art layer

l

Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when you
paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.
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When using the regular patch technique, recommended for the brush line, the result with pencil lines is very
odd looking because the colour fill zone is bigger than the pencil line inner contour.

Instead of using the regular patch method, you can use the Auto Patch node. It will automatically extract the
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.
The node connection for the Auto Patch is quite simple. Once your basic character rigging is done, add the
Auto Patch node to the joints you want to cover. There is no need to set any parameters.
Refer to the following example to connect this effect:
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About Ordering Layers
T-HFND-005-005
At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level
in the Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind.
Second, you can use the Z-axis nudging (forward and backward) if you have extra views included in the same
layers (front, three-quarter, back, etc.).
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Ordering Layers in the Timeline View
T-HFND-005-006
In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be
displayed behind. If you have multiple views, you should order your layers based on the most common view,
which is generally the three-quarter front.

How to order layers
1. In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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Ordering Layers in the Node View
T-HFND-005-007
The Node view allows you to reorder layers without breaking any hierarchy. For example, if you want the Head
layer to appear behind all the facial features, in the Timeline view, you cannot simply move the layer down
because you will break the parenting between the head layers. In the Node view, since you have a set of
flexible connections, you can change the Composite node ordering without breaking the parenting between
the nodes.

The Composite node ordering corresponds to your timeline ordering unless the Node view's organization is too
complex for the Timeline view to display. The element connected in the left-most port of the Composite node is
displayed in front in the Camera view and the one connected in the right-most port is displayed behind.

How to order layers in the Node view
1. In the Node view, select the node's output cable connected to the Composite node and drag it to its
new position.
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About Z Nudging
T-HFND-005-008
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as
the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE
You will do the same for the layers that are not in the right order on the extra views. Do not place
the drawing on another layer. You want to keep all your drawings of the body parts in the same
layers like a box containing all of the hands or all of the shoes.
Harmony allows you to move your elements in three dimensions:
l

Up and down (Y-axis)

l

Left and right (X-axis)

l

Backwards and forwards (Z-axis)
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Nudging Layers
T-HFND-005-009
In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the
Timeline view. The forward-backward position can also be animated over time.

How to nudge layers backwards and forwards
1. In the Tools toolbar, select the Transform

tool. Make sure to enable the Animate

mode.

2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is
around the Camera view before selecting the element.
3. To move the element forward, press Alt + Up Arrow and to move the element backward, press Alt +
Down Arrow.
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About Pivots
T-RIG-006-001
Even with a complex hierarchy, a rig is useless without positioning the proper pivot points. This will allow the
puppet's pieces to rotate correctly. The arm needs to rotate from the shoulder and stay attached to the torso,
so its pivot point needs to be positioned accordingly. A good way to achieve this is to position the pivot point
exactly in the center of the articulation.
The initial position of the pivot point is always at the center of the scene. Sometimes there will not be an
obvious place of rotation to place the pivot point, but it's a good idea to reposition the pivot to the best
transformation point. For instance, the master peg, which generally controls the entire rig, is often best
positioned between the character's feet.

816

Chapter 8: Rigging

About Permanent Pivots
T-RIG-006-002
This is a permanent pivot, sometime referred to as peg pivot, that is applied to the entire drawing or peg layer.
If you modify its position, it will be changed for the entire layer, modifying the animation, scale and rotation
interpolation. The permanent pivot is set using the Rotate, Translate or Scale tool. The Transform tool will only
move that pivot temporarily for positioning purposes, but the animation interpolation will be done from the
original permanent pivot's position. The Transform tool is designed to move the pivot temporarily during the
animation process. It also permits you to select multiple pegs and apply a common temporary pivot.
To permanently move a peg pivot, use the Rotate or Scale tool. You can also directly type the values in the
Layer Properties window in the Pivot section's (x) Axis and (y) Axis fields.
In the Layer Properties window, in the Drawing Pivot section, select the Don't Use Embedded Pivot option to
use the permanent pivot.
For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate
tool.
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Setting Permanent Pivots
T-RIG-006-004
In this section, we'll take a look at one of the options we have for setting pivots. The permanent pivot allows
you to push your rigs to great lengths without having to worry about repositioning your pivot once it is set.

How to set the pivots with the Rotate tool
1. In the Advanced Animation toolbar, select the Rotate

tool.

2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view,
you can also hold down Ctrl (Windows/Linux) or ⌘ (macOS) and click on the piece whose pivot you
want to set.
3. In the Camera view, drag the blue pivot to reposition it.

4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as
where to place the pivot, put it in the center of the selected piece or group of pieces.
NOTE
If you added other pegs to your rig, you must set their pivot using the same
method.
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Setting Multiple Permanent Pivots
You can simultaneously set the position of pivots for several drawing layers or pegs that you would like to rotate
and scale from the same point of origin,

How to set pivots on multiple pegs
1. Select the multiple pegs or drawing layers from either the node view or timeline view.
2. Select any Advanced Animation tool, such as the

Rotate tool.

3. Reposition your pivot using the Advanced Animation tool
NOTE
Never use the Transform tool to permanently position pivots. The Transform tool only
temporarily repositions it to accommodate your transformation, usually during the animation
process.
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About Drawing Pivots
T-RIG-006-003
The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If you
have many different views of a character within one layer, the pivot positions can be different and the
animation will adjust to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not
mixing different views within the same layers or are using pegs to animate your layers, it is recommended to
use the permanent pivot.
You can set a different pivot for each one of your drawings. For example, if you have a series of drawings from
different views, they are not likely to rotate from the same location. In that case, you can set a different pivot for
these drawings by using the Drawing Pivot

tool.

In the Layer Properties window, in the Drawing Pivot section, select the Apply Embedded Pivot on Drawing
Layer option to use the drawing pivot directly on the drawing layer. If you want to apply the drawing pivot to a
parent peg to force the peg to follow the drawing pivot variations, enable the Apply Embedded Pivot on
Parent Peg option.
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Setting Multiple Drawing Pivots
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same
drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all
at once. If your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other
drawings in the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing
while the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range
1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand1.

2. In the Timeline view, select the cell that contains the correct pivot.
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3. From the top menu, select Edit > Copy.
4. In the Timeline view, select the cell range that requires the same pivot.

5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B
(macOS).
The Paste Special dialog box opens.

6. In the Paste Special dialog box, select the Advanced tab.
7. In the Drawings section, select the Update Drawing Pivot option.
8. Click OK.
NOTE
You can also copy and paste the pivot from one drawing to another using the
keyboard shortcuts Ctrl + C and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V
(macOS) when the drawing pivot tool is active and the focus is around the
Camera view.
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About Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same as
the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each drawing
can have its own pivot. If you are not mixing different views within the same layers or are using pegs to animate
your layers, it is recommended to use the Peg pivot.

823

Harmony 15.0 Premium User Guide

Setting Symbol Pivots
If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the articulations. You can
set the pivots using the Rotate tool which sets it for the entire layer or you can set the pivots directly on your
symbol and have a different pivot for each symbol cell. By default, when you create symbols, the symbol pivot is
located at the centre of your drawing. You will need to move it onto the shoulder or elbow.
You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must be at the
top level of your character building scene and not inside the symbols.
By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different pivots for
different cells, refer to the following procedure.
Do the following steps for each layer in the Timeline view.

How to set the pivots on a symbol
1. In the Tools toolbar, select the Drawing Pivot

tool or select Drawing > Tools > Drawing Pivot.

2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.

3. If you only want to set one pivot for your symbol, in the Tool Properties view, select the Set the Pivot
for Symbol on All Frames

l

button.

Deselect this button if you want to set a series of different pivots for your symbol's
cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the
desired location.
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5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and
in the Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform
drawings that are under their hierarchy, without transforming the drawings directly.
When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the
position and exposure of your drawing layers independently in the Timeline view. It also makes it easier to
create a hierarchy of which body parts can be animated together and independently.

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool
Properties view. You can also disable animating drawing layers, so that only pegs can be animated.
NOTE
It is also possible to make a drawing layer the parent of another drawing layer. Just like the way
animating a peg animates its children layers, animating a drawing layer with children will also
animate its children layers. Both layers will still appear in the animation as long as they are also
connected to your scene's composite.

How to create parent pegs for your layers in the Timeline view
1. In the Timeline view, select all the layers.

2. In the Timeline Layer toolbar, click the Add Peg
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button to add a parent peg to all selected layers.
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When creating layers or pegs in the Timeline view, your Node view may look tangled up.

3. In the Node view, select all the nodes and, in the Network View toolbar, click the Order Network
Down

button.
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How to create parent pegs for your layers in the Node view
1. From the Node view, select all the drawing layers for which you want to create pegs.
2. Press Ctrl + Shift + P (Windows/Linux) or ⌘ + Shift + P (Mac OS X)
3. Pegs are created, named and connected to their child drawing layers. They will not automatically
connect if the top port of your drawing layer is already connected to another node.
4. If the nodes are tangled, select all the nodes and, in the Network View toolbar, click the
Order Network Down

button.
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Disabling Animation on Drawing Layers
By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to switch
your drawings so they can no longer be animated without a peg has certain advantages. It means that you can
access the drawing substitution feature for this drawing layer, while being able to create keyframes on its
parent peg. This feature is also available for backward compatibility when bringing in templates created in
older versions of Harmony, so as not to lose their offset keyframes or drawing substitution keyframes.
When selecting the element in the Camera view, the actual drawing layer is selected, but the motion you will
create will automatically be transposed to the peg layer. You cannot animate (add keyframes) directly onto the
drawing layer if the option is disabled. You will still be able to perform certain offset movements in the
Transformation tab of the Layer Properties, but not using any of the animation tools in the Tools toolbar.
There are two ways to disable animation on drawing layers, via the Layer Properties window and the
Preferences dialog box. When you disable animation in the Layer Properties window, it affects only the
selected layer and not any others.
If you prefer this style of animation and want every drawing element that you create to not be animated, you
can disable the Element Node “Animate Using Animation Tools” Default Value preference. This will disable the
Animate Using Animation Tools option on all the new layers you will create from that point on so you don't
have to do this through the Layers Properties window for every layer. It is recommended to disable this
preference before starting a new character rig.

How to disable animation on a single layer
1. In the Timeline view, double-click on a layer.
The Layer Properties dialog opens.
2. Open the Controls tab.
3. Uncheck the Animate Using Animation Tools option.
Notice that the layer functions are no longer available in the Timeline view.
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How to disable animation for several drawing layers
1. In the Timeline or Node view, select all the layers/nodes for which you want to disable animation.
2. In the Node View toolbar, click on Set Properties on Many Layers

button.

The Set Properties on Many Layers dialog appears.

3. Under Animate Using Animation Tools, select Off.
4. Click on the OK button.

How to disable animation for all new drawing layers
1. In the top menu, select Edit (Windows/Linux) or Harmony [Edition] (macOS) > Preferences.
The Preferences dialog opens.
2. Select the Advanced tab.
3. Uncheck the Element Node "Animate Using Animation Tools" Default Value option.
4. Click on the OK button.
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Creating Hierarchies
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should
influence other limbs, and how they can move independently. For example, when rigging a simple character's
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer.
This way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and
hand will follow.

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig
the legs to the hips. This would make a hierarchy like this:
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How to create a hierarchy in the Timeline view
1. In the left area of the Timeline view, select the layer which you want to make a child layer.
2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you
are not dropping the child layer between two layers.
3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at
the root. While rigging, if you want several layers to have a common parent, but no existing part of
your rig can serve as that parent, create a new peg and nest those layers under that peg.

NOTE
In the Timeline view, you can unparent layers by holding down Shift, dragging the selected
parent away from the child layer and dropping it somewhere else in the list.

How to create a hierarchy in the Node view
1. Position your nodes as if they were in a tree representing their intended hierarchy, with the highest
nodes on top and the lowest nodes at the bottom.
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2. Drag a cable from the output port (bottom) of a node which you want to make into a parent node.
3. Connect the cable to the input port (top) of the node which you want to make into its child node.

4. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at
the root. While rigging, if you want several layers to have a common parent, but no existing part of
your rig can serve as that parent, create a new peg and nest those layers under that peg.
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NOTE
In the Node view, you can unlink nodes from their parent and child by holding down the Alt
key and moving them anywhere in the node view. This will delete the node's connections
instantly. If the node has both a parent and a child, this will automatically connect its former
parent to its former child.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they are
rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Likewise, in the Node
view, layers that are connected to the leftmost port of a composite are rendered on top of layers connected to
ports to the right. Should you need to change a layer's order while animating, you can nudge this layer's
position on the Z-axis to override the layer order and force it to appear beneath or over other layers.

How to nudge a layer on the Z-axis
1. In the Tools toolbar, select the Transform

tool.

2. In the Timeline, Node or Camera view, select the layer you want to nudge.
3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the
focus on the Camera view.
4. Do one of the following:
l

To nudge the layer forward, press Alt + Down Arrow.

l

To nudge the layer backward, press Alt + Up Arrow.

834

Chapter 8: Rigging

Adding the Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows
you to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is
useful for positioning and scaling your character relative to the scene, as well as to animate your character's
trajectory when it has to move between areas of the scene.

How to add a master peg in the Timeline view
1. In the Timeline view, select the top layer.
2. In the Timeline view, click on the Add Peg

button.

A new peg is added to the timeline as a parent of the selected layer.
3. Name the new peg Master plus the character's name.
4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that your
top layer is already a child of the peg, so don't include it in your selection.
5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers
are added above the already parented layers, move that parented layer back on top of the layer
stack.
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How to add a master peg in the Node view
1. In the Node view, hold Ctrl (Windows/Linux) or ⌘ (macOS) and select each node that you want to
attach to your new peg.
2. Do one of the following:
l

From the Node view menu, select Insert > Peg.

l

Press Ctrl + P (Windows/Linux) or ⌘ + P (macOS).

3. Rename the new peg Master plus the character's name.
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Fine-Tuning the Rig
Once your rig is done, you have access to a lot of tools and tricks that you can add to make your rig even more
efficient. Colours that can help you distinguish certain layers, or parts of your node view, cutter systems and
much more. For more great options and features on creating powerful rigs, refer to Deformations.
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Invert-Cutting
When rigging a character, there may be instances when you want to have the ability to move a particular piece
to give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the
drawing sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't want to
be visible.

How to mask an object in the Node view
1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece
to cut.

2. From the Node Library view, select the Favorites category and then select the Cutter node.
3. Drag the Cutter node to the Node view.
4. Connect the object you want to cut to the Cutter node's right port and connect the Cutter to the
Composite node.
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5. Pull out a cable from the masking object and connect it to the Cutter node's left port.

6. Your masking effect is most likely inverted and what you want to cut is probably showing. Click the
Mask node's yellow button to open the Layer Properties window. In the Layer Properties window,
enable the Inverted option.
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7. From the Tools toolbar, select the Transform

tool and move the cut object within the masking

zone.
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Changing Composite Modes
When you create a character with Harmony, you have to connect all your nodes in the Composite node. The
Composite node takes all the different images coming out of your drawing nodes and flattens them into one
single image.
This is useful when it is time to apply an effect to your entire character or group your layers for a more organized
network.
The regular Composite node will flatten all the pieces into one image preventing interaction with props or
characters connected to a different Composite node. That is why you have to change the Composite node's
type to a special one that will still output one single image but will not flatten the drawings together. This will
allow you to nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind
other characters and objects. This Composite type is called Pass Through.

How to change your Composite node to a Pass Through
1. In the Node view, click on the Composite node's Properties button.

The Layer Properties dialog box opens.
2. From the Mode menu, select Pass Through.

3. Click Close.
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Adding Displays
The Display node lets you see a section of the network in the Camera view. By renaming the Display node with
your character's name, you can quickly identify it in the Global Display toolbar and isolate your character to see
it better while working on it.
If you do not have a Display node in your network, you can add one by selecting one from the Node Library
view and dragging it into the Node view.

How to add a Display node
1. In the Node Library view, select the IO tab and select the Display node.
2. Drag the node to the Node view.

3. Connect the Composite node's output port into the Display node's input port.
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How to rename your Display node
1. In the Node view, click on the Display node's Properties button to open the editor.

2. In the Layer Properties window, rename the Display node with your character's name.

3. Click Close.
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Grouping Rigs
Once your rigging is completed, you must group the puppet's skeleton to help organize the often large and
complex networks. This way, once you have imported two or three characters into the scene, three Group
nodes will be displayed instead of all the rigging connections of three puppets.

How to group nodes
1. In the Node view, select all your nodes.
2. In the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or
⌘ + G (macOS).
Your nodes are grouped.
3. Click on the Group node's right arrow to enter the group.

4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select the
Group category and select a Multi-Port Out node.
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5. Drag the Multi-Port-Out node to the Node view.
6. Connect the Composite node's output port into the Multi-Port Out node.
An output port is created on your Group node.
7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should now
see an output port on your Group node.

8. Click on the Group's Properties button to open the Layer Properties window.

9. In the Layer Properties window, rename the Group node with your character's name.
10. Click Close.
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Creating Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to
create all of the function curves and block your pose in place.

How to create the keyframes
1. In the Timeline view, collapse the master peg by clicking the Expand

arrow.

2. In the Timeline view, select the first cell.

3. Do one of the following:
l

From the top menu, select Insert > Keyframe.

l

In the Timeline View toolbar, click the Add Keyframe

l

Press F6.

button.

NOTE
If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates
a keyframe but also duplicates a drawing.
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About Backdrops
T-RIG-008-001
Backdrops are a way to work with complex node systems that let you associate a selected set of nodes by
colour. You can add as many backdrops to your node structure as needed. The idea is to visually organize the
structure so you can quickly identify the particular set of nodes.
You can customize the backdrops with different colours. For example, the upper part of a character's body could
be in different shades of red, while the lower body is in shades of green. When you create a backdrop to the
Node view, the default colour is red.
Once you have created a backdrop with nodes inside, you can move the backdrop to the desired location and
arrange multiple backdrops neatly. You can also resize backdrops to accommodate the number of nodes in your
rig.
You can select the nodes you want to add to the backdrop before creating it and vice versa—create an empty
backdrop and then drag the desired nodes into the backdrop.
NOTE
Because backdrops are not layers, its properties do not appear in a node's properties.
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For your convenience, you can add backdrops as templates to the library—see Create a Template from the
Node view in Chapter 7: Library of the Cut-out Animation Guide.
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Adding Backdrops
T-RIG-008-002
You can add colourful backdrop to organize your nodes and group parts of your cut-out characters.

How to add a backdrop
1. In the Node view, do one of the following:
l

Select the nodes to include in the backdrop.

l

Click anywhere in the Node view to deselect any selected items.

2. From the Node View menu, select Insert > Backdrop.
If you selected nodes, a red backdrop displays around the nodes you selected.

If you did not select anything, a red backdrop displays in the Node view.
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Removing Backdrops
If no longer needed, you can easily remove backdrops.

How to remove a backdrop
1. In the Node view, clear any backdrop or node selections.
2. Alt+ click on the title bar of a backdrop to only select the backdrop, without the nodes.
l

If you want to delete the backdrop and all its nodes, simply select the backdrop
without using the Alt key.

3. Press Del.
l

If you had a node selection, depending on your project, the Confirm Delete window
may display. Deselect the Delete Drawing Files and Element Folders. If you have
multiple version of a scene, you will want to keep all the files and folders associated
with it. If you select this option, all the drawings and folders linked to this backdrop
will be deleted.

851

Harmony 15.0 Premium User Guide

Customizing Backdrops
T-RIG-008-003
Once you've created a backdrop, customizing it is a great way to organize your work. You can change the colour
of the backdrop, give it a name which displays in the title bar of the backdrop, and add any notes or
instructions pertaining to the nodes contained in the backdrop.

How to customize a backdrop
1. To resize a backdrop, drag the triangle in the lower-right corner of the backdrop window.

2. Click the yellow square properties button.
The Backdrop Properties window opens.

3. To change the colour of the backdrop, click the Colour list and select a colour.
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4. In the Name field, type in a name for the backdrop.
5. In the Text field, type in any notes or instructions in the backdrop.
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Organizing Nodes in Backdrops
Once you have deselected all items in the Node view, you can organize any of the nodes by dragging and
moving them around even if they are in a backdrop. You can move nodes from one backdrop to another.

How to organize nodes in backdrops
1. Click anywhere in the Node view to deselect all items.
2. Organize the nodes by dragging them from one or more backdrops.
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Moving Backdrops
T-RIG-008-004
When you want to move a backdrop, you can do so either with or without the nodes it contains. Moving a
backdrop with its nodes lets you quickly organize entire sections of a complex rig.
Moving the backdrop only (without its nodes) gives you a chance to reorganize a node structure. Perhaps
nodes should be grouped differently for a better workflow or nested within another backdrop for optimal
organization.

How to move a backdrop and its contents
1. Click anywhere in the Node view to deselect all items.
2. Click the title bar of a backdrop and drag to a new location.

How to move a backdrop without its contents
1. Click anywhere in the Node view to deselect all items.
2. Hold down Alt and drag the backdrop by the title bar to a new location.
3. Click anywhere outside the backdrop to set its new position.
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Copying and Pasting Backdrops
When you copy a backdrop, its contents are copied along with the backdrop name, colour, and any notes.
When selecting a backdrop, all backdrops underneath it are also selected.
When you select a backdrop with the Alt key, the backdrop retains its Z order.
NOTE
A selection that contains only backdrops cannot be copied.

How to copy and paste a backdrop
1. Select one or more backdrops to copy and press Ctrl + C (Windows/Linux) or ⌘ + C (macOS).
2. To paste the copied backdrop(s), press Ctrl + V (Windows/Linux) or ⌘ + V (macOS). Note that
nodes will be pasted as clones. They will link to the same drawing columns and existing function
columns.
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About Pose Copier
T-RIG3-007-001
The pose copier is a scrip that can be added to your Scripting toolbar. The goal of the Pose Copier is to facilitate
the reuse of poses from a master template by taking information from it and pasting it at the desired frame. It
does not create new information outside of what is contained in the template.

In order for the Pose Copier to work, templates need to be set up properly to maximize the compatibility of the
script. It is recommended to keep only the frames that will be needed. Empty or unused frames may appear
within the sliders.
For a simple use of the script, create a template of the part that you wish to use with the pose copier. It could be
the entire character, the head, the lip sync or any other part. It is recommended to template groups as opposed
to scattered individual nodes. To maximize compatibility, keep the hierarchy of your template identical to the
hierarchy of your rig.
You can also create an advanced setup to select specific frames using guide layers—see About Guide Layers on
page 859.
NOTE
To learn more about the Pose Copier dialog box, see the Reference guide
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Adding the Pose Copier Script to the Scripting Toolbar
T-RIG3-007-002
To use the Pose Copier, you need to add the script to the Scripting toolbar.

How to add the Pose Copier script to your Scripting toolbar
1. Select Windows > Toolbars > Scripting to display the Scripting toolbar.
2. In the Scripting toolbar, press the Manage Scripts

button to open the Scripts Manager.

3. In the Files section, select the TB_Pose_Copier.js script file.
4. In the Functions section, select TB_Pose_Copier function.
5. Press the Add Script to Toolbar

button to send it to the Scripting toolbar.

6. Press OK to close the Script Manager.
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About Guide Layers
T-RIG3-007-003
The guide layers are ordinary drawing layers named in a way that will associate them with the 3 sliders of the
pose copier. These layers will need to be incorporated inside the template for the sliders to work when
activating the pose copier script.

You need to create three drawing layers for the three sliders to work. These will need to be named accordingly
including a dash character. Suffixes may be added after the dash for additional information as seen in the
example above.
l

slv- for the vertical layer that will be used for the tilt

l

slh- for the horizontal layer which will be used for the turn

l

slx- for the second horizontal layer that will be used for the lipsync

In those guide layers, you will need to create empty drawing cells. These frames will represent the different
slider positions to which you will have access in the pose copier. The guide layer frames need to match the
character's frames if they are to show an accurate view of the information that will be pasted.

In the example above, the slh (horizontal) slider contains 5 frames. The horizontal sliders are read in
alphabetical order from left to right. You can add numbers to display them in the desired order.
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l

1front

l

2quarter-front

l

3side

l

4quarter-back

l

5back

The slv (vertical) slider contains 3 frames. The vertical slider works in alphabetical order from the way down
and moving up, hence the numerical prefix.
l

1down

l

2mid

l

3up

The slx (expression) slider contains 5 frames. Each of these frames holds different combinations which will be
used for the different sliders to access the frames of the template.
l

A

l

B

l

C

l

D

l

E

For example, setting the slh (horizontal) slider to 1front, the slv (vertical) slider to 3down and the slx
(expression) slider to B will display a front pose, looking down, using the B mouth.

NOTE
To learn more about the Pose Copier dialog box, see the Reference guide
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Creating Guide Layers
T-RIG3-007-004
For each template, three guide layers can be created to associate with the three sliders of the pose copier.

How to create guide layers
1. With your rig open, go to the Timeline view, click the Add Drawing Layer

button or press Ctrl +

R (Windows/Linux) or ⌘ + R (macOS) and create 3 new drawing layers. You may also create those
nodes in the node view or x-sheet view.
2. Name the prefix of each drawing layer based on the different sliders. The suffix can be anything to
identify the sliders. The dash must be included within the name in order for the sliders to work.
‣

slv- for the vertical slider

‣

slh- for horizontal slider 1

‣

slx- for horizontal slider 2

3. Based on the rig of your character, select each layer one at a time and click on the

button to

create new empty drawing at the desired frame. The frame's location will be shown on the slider of
the pose copier.
4. Select the drawing cell and rename it with the desired information by doing one of the following.
‣

Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X)

‣

From the timeline, right click on the cel and select Drawings > Rename Drawings...

5. Extend exposure up to the next position on the timeline that you wish to include in the sliders.
6. Reuse frames by selecting frames from the Drawing Substitution display in the Library view.

For more information about guide layers, see About Guide Layers on page 859
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Creating a Pose Copier Template
T-RIG3-007-005
The pose copier template is a regular template of assets that will be used to copy and paste information from
the template over to a scene. Guide layers may be used inside of the pose copier template as additional
efficiency tools for selecting your pose.

How to create a Pose Copier template
1. In the Node view or in the leftmost section of the Timeline view, select the nodes intended to make
the template.
If you have created guide layer nodes, make sure to include them in the selection as well.
2. Copy the selection using one of the following:
‣

Press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).

‣

From the top menu, select Edit > Copy.

3. In the Library view, select a folder to store the template.
4. If a library folder is locked, right-click and select Right to Modify.
5. With the folder selected, paste the selection into the folder using one of the following:
‣

Press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).

‣

From the top menu, select Edit > Paste.

6. In the Rename dialog box, give the new template a name.
To rename a template once it is created, right-click on the symbol and select Rename.
7. Click OK.
8. Right-click on the template and select Generate Thumbnails.
You will see a preview of your template in the Drawing Substitution area of your Library view. The
thumbnails are the images used inside the Pose Copier, therefore it is essential to do this before
using the Pose Copier the script. Once this step is completed, the thumbnails are stored within the
template. You will not need to do this again unless you recreate your template.
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Pasting Poses Using the Pose Copier
T-RIG3-007-006
Once the templates have been created and set up properly, it is easy to paste a variety of poses from one or
multiple templates onto a still character awaiting posing.

Depending on how the template has been set up, a different destination has to be set up in order for the
pasting to take place.

How to Set the Default Destination with the Pose Copier script.
1. In the Library view, select the template you want to copy poses from.
2. If it was not done previously, right-click on the template and select Generate Thumbnails.
The thumbnails are generated and showing in the Drawing Substitution View.
3. With the template still selected, run the TB_Pose_Copier script by clicking on it in the Scripting
toolbar—see Adding the Pose Copier Script to the Scripting Toolbar on page 858.
The Pose Copier dialog box opens.
4. From the timeline, select the destination of the pasted keyframes by selecting the node or topmost
node of your hierarchy for the selected template.
5. With the destination highlighted in the timeline, (see below table for setting the proper
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destination) press the Set Default Destination Module button from the Pose Copier dialog box.
Once selected, this information will remain saved within the template.
Selecting the Destination Layer
Type of template

Paste by Layer Name Option

Default Destination
Set it on the same group as the

Enabled
Grouped Nodes

templated group or any node above it
in the hierarchy. If a node inside that
group is selected, pasting will not
take place.

Disabled

Select the same group as the one
templated.

Enabled

Select any node in the hierarchy as
the default position.

Nodes
Disabled

Unless you've only templated a single
node, it is preferable to turn on the
Paste By Layer Name option.

How to Paste Poses With the Pose Copier Script
1. Do one of the following:
l

Set Default Destination to the designated layer and enable the Use Default Destination
Module option.

l

Manually select the layer for the destination of the pasting.

2. Select a pose using the different sliders—see About Guide Layers on page 859.
3. Click Paste to apply it on your character at the currently selected frame.
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About the Master Controller
The Master Controller is a node that is capable of generating custom on-screen manipulators, or widgets,
which can be programmed to affect one or several elements in a scene when manipulated. They are created
and configured entirely through the scripting interface of Harmony. This allows you to create controls that can
manipulate any amount of elements in your scene based on specific algorithms, making their capabilities
virtually infinite.

Several types of Master Controller widgets can be created:
l

The Slider Widget creates a slider that the user can slide. When manipulated, it provides a value
between its minimum and maximum values.

l

The 2D Line Display widget displays a line going between two 2D Point widgets to make a "bone" type
manipulator.
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l

The 2D Point Widget creates a point that the user can freely drag around the stage. When
manipulated, it provides its position.

l

The 3D Rotation Widget creates a 3D sphere that the user can rotate in all directions. When
manipulated, it provides an object with a rotation angle for each axis.

l

The X, Y and Z Rotation Widgets create a circle that can be rotated around the stage around its axis.
When manipulated, it provides a rotation angle.

l

The X, Y and Z Translation Widgets create an arrow that can be dragged along its axis. When
manipulated, it provides an offset.

l

The Custom Widget can be composed of one or multiple elements from other widget types, and the
behavior of which when manipulated can be customized.

The end goal of master controllers is to give studios the ability to create tools that make it easy for scene
planners and animators to manipulate rigs and objects in the way they were designed to be manipulated.
There are two approaches to creating master controllers:
l

Scripting: This method allows you to create a master controller of any kind for any purpose whatsoever.
However, since it requires using the Harmony scripting interface, it is recommended to only attempt this
if you have solid bases in scripting.
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l

Pose Interpolation Grid: This is a dialog what allows you to easily generate a 2D point widget master
controller which will make a character, or part of a character, interpolate between a grid of poses.
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Creating a Master Controller Through Scripting
The following topics will introduce you to scripting for a Master Controller and provide examples of how to
handle basic use cases. However, before going through this section, you should know that:
l

This documentation alone is not enough to be able to create a Master Controller through scripting. Such
a task should only be taken by someone with sufficient experience in scripting or programming.

l

This is an introduction guide, not a reference. To obtain a list of all the modules, properties and methods
related to the Master Controller, you must refer to the Master Controller Node section of the Harmony
scripting API reference.
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Creating a Master Controller
T-HSCP-002-002
To create a Master Controller, you must add a Master Controller node to the scene, then link it to a UI script, in
which its widget and the way it interacts with elements in the scene will be programmed. The UI script of a
Master Controller is executed when its controls are displayed.

How to add a Master Controller to a scene
1. In the Node view, add a Master Controller node by doing one of the following:
l

In the Node Library view, select the Misc filter, then drag and drop the Master Controller
node from the Node Library view to the Node view.

l

Right-click on the Node view and select Insert > Misc > Master Controller.

l

Open the Node view menu and select Insert > Effects > Misc > Master Controller.
IMPORTANT
The Master Controller node does not need to be connected to another node to work.
However, if you do connect it to another node, the node system to which it is connected
must ultimately be connected to a Display node.

2. Click on the yellow square in the Master Controller node to open its Layer Properties.
NOTE
The Layer Properties of a Master Controller are very similar to those of a Script Node.
The main difference is that the Master Controller has access to methods allowing it to
create and use widgets.
3. Switch to the Script UI tab.
4. In the scripting field of the Script UI tab, type in the following code to link to your widget script:
include(scene.currentProjectPath() + "/scripts/myScript.js");

In this example, the script is located in a scripts subfolder of the scene folder, and is named
myScript.js.
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NOTE
To make sure a UI script stored in the scene's file structure is copied over when you
make a template that includes the Master Controller node, you must add this script to
the Extra Files list of the Master Controller node—see Creating Templates with a Master
Controller on page 894.
5. Save your scene.
6. Open the Script Editor view by doing one of the following:
l

From the top menu, select Windows > Script Editor.

l

From any existing view (ie: the Camera or Drawing view), click on the Add View
and select Script Editor.

7. In the Scope dropdown, select Project.

The script list will now list scripts in the scripts subfolder of your scene.
8. In the Script Editor toolbar, click on the New Script

button.

9. In the New Script dialog, type in myScript and confirm.
10. In the Save Script dialog, select Scene in the location dropdown and confirm.
The script scripts/myScript.js will be added to the list of scripts.
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11. Select scripts/myScript.js from the script list to load it in the editor.

You are now ready to start scripting a widget for the Master Controller node.

NOTE
To make sure the script is copied over with the Master Controller node if it is copied into a template,
you must add the script file to the Extra Files tab of the Master Controller's properties—see
Creating Templates with a Master Controller on page 894.
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Creating Master Controller Widgets
T-HSCP-002-004
The UI script linked to a Master Controller node is called when the Master Controller node is selected and the
user uses the Show Control command to display its controls in the camera view, which calls the
onShowControl method of the Controller object of the node. Hence, to make the Master Controller node
display a widget, you must define its widget in a function that overrides this method.
The following example overrides a Master Controller's onShowControl method with a function that creates a
basic slider widget. Simply copy and paste it to your UI script to test its effect.
// When Show Controls is called from the Harmony UI, create a script widget
// and register it to the main Controller.
Controller.onShowControl = function()
{
// Initialize the array of widgets
Controller.controls = [];
// Add a slider widget.
Controller.controls.push(new SliderWidget());
}

Similarly, you can handle the case where the control is hidden using the onHideControl method.
// Called when the user hides the Master Controller node controls
Controller.onHideControl = function()
{
MessageLog.trace("Slider hidden.");
}

NOTE
When the control is hidden, it is destroyed and the attributes that were set by the user when they
manipulated it are not preserved. This occurs regardless of whether or not the onHideControl
method is overridden. Hence, there is no need to script the destruction of the widget.
It is possible to create a Master Controller with several widgets. For example, you can combine a
TranslationXWidget and TranslationYWidget to make a 2D Translation widget by creating them as
elements of the same Controller.controls array.
// Create a TranslationX and TranslationY widget in the same Master Controller.
Controller.onShowControl = function()
{
// Initialize the array of widgets
Controller.controls = [];
// Add the TranslationX and TranslationY widgets
Controller.controls.push(new TranslationXWidget());
Controller.controls.push(new TranslationYWidget());
}
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Save your script, then refer to the following topic to display and use the Master Controller's widget.
NOTE
To learn about the different widgets available for the Master Controller, refer to the Master
Controller Node section of the Harmony scripting reference.
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Displaying & Testing Widgets
You can display the Master Controller's widget in the Camera and Perspective views by using the Show
Control command.
When you make changes to the UI script, you can reload the script by hiding and displaying the Master
Controller's controls again. This can be very useful to test your script as you're working on it.

How to display or hide the Master Controller's widget
1. In the Node view, select the Master Controller node.
2. Do one of the following to display the Master Controller's control:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The widget displays in the Camera and Perspective views.
NOTE
You can follow the same steps to hide a widget that is already displaying.

When the widget is displaying, you can manipulate it using the Transform tool.

How to manipulate a Master Controller widget
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Camera or Perspective view, click and drag the widget's control.
If you have several Master Controller widgets on screen, you can use the Hide All Controls command to hide
them all simultaneously.

How to hide all Master Controller widgets
1. Do one of the following:
l

In the Camera view toolbar, click on Hide All Controls

l

From the top menu, select View > Hide All Controls.

l

Press Shift + C.
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Setting the Properties of a Master Controller Widget
T-HSCP-002-005
When creating a widget, you can customize it by declaring its properties. These properties can be passed as
parameters in the constructor of the widget. For example, the following code creates a Slider widget with a full
set of custom properties:
Controller.controls.push(new SliderWidget(
{
data : "mySlider", // name of the created attribute
width : 0.15,
// width of the slider frame
height : 0.2,
// height of the slider frame
min : 0,
// minimum value of the slider
max : 100,
// maximum value of the slider
frame_color : ColorRGBA(40,100,150), // the colour of the slider frame
slider_color : ColorRGBA(135,135,135), // the colour of the slider handle
slider_selection_color : ColorRGBA(200,200,150), // the colour of the slider frame when
selected
}));

The data property of a widget can be set to a string that uniquely identifies its attributes. Hence, if two
widgets are created with an identical data property, they will have the same attribute, like in this example:
// Create a 2d point widget.
Controller.controls.push(new Point2dWidget(
{
data : "Magnet",
// name of the created attribute
size : 0.05,
// the diameter of the point
selection_color : ColorRGBA(80,50,50) // the colour of the point manipulator when
selected.
}));
// Create a 2d point widget.
Controller.controls.push(new Point2dWidget(
{
data : "Magnet",
// name of the created attribute
size : 0.1,
// the diameter of the point
selection_color : ColorRGBA(20,70,70) // the colour of the point manipulator when
selected.
}));

Each type of Master Controller widget has its own set of properties that can be set at its creation. All of their
properties are optional and have default values if not set.
NOTE
To learn about the properties of each type of widget, refer to the Master Controller Node section of
the Harmony scripting reference.
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Linking Attributes Between Master Controller Widgets
T-HSCP-002-007
By default, Master Controller widgets are created with their own attributes. It is possible to link the attributes
between several widgets using the data property.
In the following example, a widget that is composed of two 2D points which are linked by a line is created.
There is no such widget in the Master Controller API, but there is a 2D Point widget (Point2dWidget) and a
2D Line Display widget (Line2dDisplayWidget) , the data property of the latter is an array of two
2D Points. Hence, we can simply create two Point2dWidget, then create a Line2dDisplayWidget and set
its data property to an array of the data properties of both Point2dWidget. The Line2dDisplayWidget
will follow the position of the two 2D Points.
// Create 2 2d point widgets.
var pointWidgetA = new Point2dWidget();
var pointWidgetB = new Point2dWidget();
Controller.controls.push(pointWidgetA);
Controller.controls.push(pointWidgetB);
// Display a line linking the 2 2d point widgets.
Controller.controls.push(new Line2dDisplayWidget(
{
data : [pointWidgetA.data(), pointWidgetB.data()]
}));

This capability can be used to create a widget consisting of a more complex network of lines and points.
Another way to do this is by setting the data property of two widgets with an identical string. For example, if
two Point2dWidget are created with an identical string in their data property, they will share the same
attribute.
// Create a 2d point widget.
Controller.controls.push(new Point2dWidget(
{
data : "Magnet",
// name of the created attribute
size : 0.05,
// the diameter of the point
selection_color : ColorRGBA(80,50,50) // the colour of the point manipulator when
selected.
}));
// Create a 2d point widget.
Controller.controls.push(new Point2dWidget(
{
data : "Magnet",
// name of the created attribute
size : 0.1,
// the diameter of the point
selection_color : ColorRGBA(20,70,70) // the colour of the point manipulator when
selected.
}));
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Updating a Node's Attribute when Manipulating a Master Controller
Widget
T-HSCP-002-006
In order for a Master Controller widget to have any effect on an element in the scene, it must be programmed to
set the value of an attribute for an element when the widget is being manipulated by the user.
Master Controller widgets emit a signal when they are manipulated. You can control what happens when they
are manipulated by creating a function that handles the value given by the widget, and connect that function
to the valueChanged signal of the widget.
// Callback function for when the slider value changes
function mySliderValueChanged(newSliderValue)
{
MessageLog.trace("The value of the slide changed to " + newSliderValue);
}
Controller.onShowControl = function()
{
Controller.controls = [];
Controller.controls.push(new SliderWidget());
// Connect the valueChanged signal to the sliderValueChanged
// function
Controller.controls[0].valueChanged.connect(mySliderValueChanged);
}

Then, functions in the Harmony scripting interface must be used to affect the attributes of elements in the
scene based on the value provided with the widget's signal. In this example, we use the slider widget's value to
make the horizontal position of a peg named My_Peg_A , located in the scene's top level, vary between 0 and 2
fields. The horizontal position of a peg is stored in the attribute POSITION.X.
TIPS
l

You can easily obtain the names of a node's attributes for scripting by enabling Publish
Attribute Mode in the Node View and opening a node's Layer Properties dialog. For more
information, refer to the Scripting Guide.

l

While position attributes for a peg are stored in the POSITION attribute group, position
attributes for a drawing layer are stored in the OFFSET attribute group.

function mySliderValueChanged(newSliderValue)
{
var percentage = newSliderValue / 100.0;
// make the slider sets a My_Peg_A x position between 0 and 2 fields
var newXValue = percentage * 2;
node.setTextAttr("Top/My_Peg_A", "POSITION.X", frame.current(), newXValue);
}
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Widgets that can be manipulated will call the valueChanged signal when the user manipulates them. Other
widgets, such as the Line2dDisplayWidget, cannot be manipulated and are only designed to display useful
information to the user, so they do not support this signal.
Most widgets handle transforming manipulations done to them by the user into attribute value changes on
their own through their valueChanged signal. For example, a SliderWidget that has a minimum value
between 0 and 100 will convert manipulations done to its handle into a value between 0 and 100 and pass
that value through the signal. The CustomWidget, on the other hand, allows the user to program specific
algorithms to handle manipulations done to it by using dragStarted, drag and dragEnded signals.
Although this is particularly useful for the CustomWidget, those events are inherited by widgets from the
WidgetBase class, and are hence available to all widgets.
To create custom actions for drag manipulations, simply connect a callback to one of these signals.
Controller.onShowControl = function()
{
var c = new CustomWidget(
{
data : "TranslationX",
drag_manipulator : "SCRIPT",
painter : "ARROW_X",
picker : "MONO",
local_transformation : "TRANSLATION_X",
attribute : "DOUBLE"
} );
// Register drag callback functions
c.dragStarted.connect(onDragStart);
c.drag.connect(onDrag);
}

In the callback function, convert the mouse position from the world coordinates system into the Master
Controller's OpenGL model coordinates.
var myController = Controller;
var drag_offset = new Vector3d;
var drag_offsetZ = new Vector3d;
function onDragStart(context)
{
// The context drag point is expressed in world coordinates.
// Convert the point in model coordinates and project it
// on the Master Controller XY plane.
var projectedPoint = context.projectToModelPlane(context.dragPoint());
var modelPickingPoint = projectedPoint;
if(myController.controls.length &amp;gt; 0)
{
// If other script widgets affecting the local transformation of
// the Master Controller are registered after the current widget,
// they may affect the position
// of the current widget. Take their transformations into account.
modelPickingPoint = context.multiplyByPostMatrix(modelPickingPoint);
}
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// Compute the delta between the controlled Peg position and the picked point.
var pegPosition = node.getAttr(getPegPath(),frame.current(), "POSITION").pos3dValue();
var modelOriginPoint = scene.toOGL(pegPosition);
drag_offset = modelOriginPoint.minus(modelPickingPoint);
}
function onDragTransX(context)
{
var projectedPoint = context.projectToModelPlane(context.dragPoint());
var localPoint = projectedPoint;
if(myController.controls.length &amp;gt; 0)
{
localPoint = context.multiplyByPostMatrix(projectedPoint);
}
var fieldPoint = scene.fromOGL(localPoint.add(drag_offset));
var newValue = fieldPoint.x;
node.setTextAttr(myController.node, "TranslationX", frame.current(), newValue);
node.setTextAttr(getPegPath(), "POSITION.X", frame.current(), newValue);
}
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Updating the Attributes of a Master Controller Widget
T-HSCP-002-008
The attributes of a Master Controller widget can be initialized are their creation. However, it may also be useful
to update their attributes in other circumstances.
For example, if a SliderWidget is set to control the horizontal position of a drawing that is already animated
to go from left to right. If the user moves the Timeline cursor to a different frame, the drawing will be in a
different horizontal position, but the slider's value won't be automatically updated to reflect the drawing's
current horizontal position unless we program it to do so.
This can be done by using the global Controller object's onFrameChanged method. This method is called
every time the current frame is changed, and it can be overriden with a custom function that will update the
attributes of the widget based on the attributes of the element(s) it controls.
A Master Controller widget's attributes can be accessed by their data() method, which returns an object of
the Attribute type. The value of a widget can be updated by calling its data().setValue() method. For
more information on the Attribute class, refer to the Harmony scripting reference.
// Called when the current frame of the application changes
Controller.onFrameChanged = function()
{
// Get the peg current position in x.
var xPegPosition = node.getAttr("Top/My_Peg_A", frame.current(),
"POSITION.3DPATH.X").doubleValue();
// If the peg x position is computed as “slider value” / 100.0 * 2.0
// The script widget slider value would be computed as:
var sliderValue = xPegPosition * 100.0 / 2.0;
Controller.controls[0].data().setValue(sliderValue);
}

If more than one attribute was assigned to a widget's data property at its creation, those attributes can be
accessed by passing their zero-based index as a parameter to the widget's data() method. Take for example
this script where a widget composed of two Point2dWidget linked by a Line2dDisplayWidget are
created:
// Create 2 2d point widgets and 1 line 2d widget reusing
// the 2d point widget attributes.
var pointWidgetA = new Point2dWidget();
var pointWidgetB = new Point2dWidget();
var line2dWidget = new Line2dDisplayWidget(
{
data : [pointWidgetA.data(), pointWidgetB.data()]
});

The two following methods of setting the values of the two Point2DWidget are equivalent, but the second
one uses the data() method of the Line2dDisplayWidget and passes the index of each Point2DWidget
to access them:
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// Set the attribute values of the two 2D point widgets by referring to their
// variable names.
pointWidgetA.data().setValue(new Point2d(3,3));
pointWidgetB.data().setValue(new Point2d(-3,-3));

// Set the attribute values of the two 2D point widgets by referring to the
// data array of the 2D line widget.
line2dWidget.data(0).setValue(new Point2d(3,3));
line2dWidget.data(1).setValue(new Point2d(-3,-3));
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Connecting Master Controller Widgets to Nodes
T-HSCP-002-009
Like the Script node, the input and output ports of a Master Controller node are fully customizable. To
customize the ports of a Master Controller node, open its Layer Properties and select the Specifications tab. In
the following example, this specifications sheet will add one Peg (green) input port, one Image (blue) input port
and one Image (blue) output port to the Master Controller node:
<specs>
<ports>
<in type="PEG"/>
<in type="IMAGE"/>
<out type="IMAGE"/>
</ports>
<attributes>
</attributes>
</specs>

IMPORTANT
Although the Master Controller does not require to be connected to a node system, it must at least
have one output port in order to work.
To apply the change in the configuration of the input ports, you must save, close and reopen the scene.
If the main (first, rightmost) input port of the Master Controller node is a Peg input port, you can connect a peg
node to it to affect the visible position of the widget in the Camera view. You can add more input ports and use
them to detect where the Master Controller is relative to the remainder of the node network.
NOTE
To learn about the attributes of a Master Controller node, refer to the Script Node reference .
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Applying the Coordinates of a Master Controller Widget to a Node
T-HSCP-002-011
When using a widget like the Point2dWidget, which is used to input X and Y coordinates by dragging a dot
around the scene, you may want to connect the Master Controller or to a node system so that it is properly
positioned in the stage. For example, a widget that controls a body part of a character may be connected to
that character's master peg so that it follows the character's movement in the scene.
The coordinates you obtain from a Point2dWidget when it is moved by the user will be relative to its parent
peg's position. For example, the Point2dWidget may initially appear in the corner of a scene because it is the
child of a character that is positioned there, but its initial position will still be 0, 0, 0, which might not be
accurate for the widget's purpose. Hence, before you can use the widget's coordinates to make transformations
on an element in the scene, you will have to calculate its actual position in the stage (referred to here as a world
point) by applying its parent's transformations, or matrix, to its coordinates. This can be accomplished with the
following function:
// Return the given point 2d, in OGL coordinates, in world coordinates.
function getWorldPoint2d(modelPoint2d, nodePath)
{
// Convert the model point into world coordinates.
// Apply the parent node transformation to the position
// to go from (the node) model coordinates to world coordinates.
var parentNode = node.srcNode(nodePath, 0);
var parentTransformation = node.getMatrix(parentNode, frame.current());
var modelPoint3d = new Point3d(modelPoint2d.x, modelPoint2d.y, 0);
var worldPoint = parentTransformation.multiply(modelPoint3d);
return worldPoint;
}

If the element that the Point2dWidget is supposed to control is also connected to a node system that applies
transformations to it, for example a body part in a character model, applying transformations using a world
point is likely going to offset it a lot more than intended. Even if that body part is in a corner of the stage
because this is where its character is located, its actual coordinates might also be 0, 0, 0 if only its parents were
offset, but it itself has not been moved directly. Hence, before applying the coordinates of the world point
calculated above to the target element, you will need to calculate the relative coordinates you want to apply to
the element, referred to here as a model point, by applying the reverse matrix of the element's parent to the
world point, using a function such as the following one:
// Convert the position from world coordinates to the target model
// coordinates.
// Apply the inverse of the node parent transformation to the world position
// to go from world coordinates to (the node) model coordinates
function getModelPoint(worldPoint, nodePath)
{
var parentNode = node.srcNode(nodePath, 0);
var parentTransformation = node.getMatrix(parentNode, frame.current());
var inverseTransformation = parentTransformation.getInverse();
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var modelPoint = inverseTransformation.multiply(worldPoint);
return modelPoint;
}

To bring all this together, several more calculations must be made. For example, you may have to convert points
from Harmony's field coordinates system to an orthonormal coordinates system (referred to in the scripting
interface as OpenGL coordinates). This is because Harmony's field system does not use the same length for
horizontal and vertical fields, which can cause serious inaccuracies, for example, when handling matrices that
contain rotations.
The following example demonstrates how to process the coordinates provided by a Point2dWidget and
apply them to a peg named MyPeg in the top level of the scene, using the two functions declared above in the
process:
// Callback when the position value has changed
function point2dValueChanged(newFieldPosition2d)
{
// The 2d position attributes typically have their value expressed in
// field.
// Convert the field position into OpenGL coordinates.
// The OpenGL point will be expressed in the Master Controller node model
// coordinates system.
var mcModelPoint2d = scene.toOGL(newFieldPosition2d);
// Compute the position of the master controller in world coordinates.
var worldPoint = getWorldPoint2d(mcModelPoint2d, "Top/MasterController");
// Convert the position from world coordinates to the target peg model
// coordinates
// Apply the inverse of the peg parent node transformation to the world
// position to go from world coordinates to (the peg) model coordinates
var pegNode = "Top/MyPeg";
var pegModelPoint = getModelPoint(worldPoint, pegNode);
// Get the peg position which is in fields
var fieldCenterPoint = node.getAttr(pegNode, frame.current(), "POSITION" ).pos3dValue();
// Convert from fields to OpenGL coordinates
var pegModelCenterPoint = scene.toOGL(fieldCenterPoint);
// Compute the new position of the Peg after applying the magnet to it.
var newPegModelCenterPoint = computePosition(pegModelPoint, pegModelCenterPoint, 0.001);
// Convert from OpenGL to fields coordinates
var newPegFieldCenterPoint = scene.fromOGL(newPegModelCenterPoint);
// Set the peg attribute values to the new values.
node.setTextAttr(pegNode, "POSITION.3DPATH.X", frame.current(),
newPegFieldCenterPoint.x);
node.setTextAttr(pegNode, "POSITION.3DPATH.Y", frame.current(),
newPegFieldCenterPoint.y);
node.setTextAttr(pegNode, "POSITION.3DPATH.Z", frame.current(),
newPegFieldCenterPoint.z);
}
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TIP
You can easily obtain the names of a node's attributes for scripting by enabling Publish Attribute
Mode in the Node View and opening a node's Layer Properties dialog. For more information, refer
to the Scripting Guide.
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Applying the Coordinates of a Master Controller Widget to a
Deformation Node
T-HSCP-002-012
It is possible to use Master Controller widgets to apply transformations to deformers. However, before
attempting that, it is important to understand the difference between deformations that have absolute
attributes and the ones that have relative attributes.
When using the Rigging tool to create Bone, Game Bone and Curve transformation chains, Harmony creates
each deformation node with the attribute "Apply Parent Transformation" enabled. This attribute makes it so
each point is deformed by their parent—the previous point in the chain—before they apply their own
deformations to the drawing. This makes manipulating these types of deformation points difficult as their
deformation matrices are not fully reversible.
Hence, using a Master Controller widget to manipulate deformers is more easily achieved with Envelope type
deformations. The Rigging tool creates Curve deformation nodes with the attribute "Apply Parent
Transformation" disabled. This means envelope deformation points are not affected by their parent's
deformations. Therefore, the deformation matrix for all the points in a Curve deformation chain is the same, that
is, the one carried by the parent of the chain's offset, which would typically be a peg or a drawing node, and
would hence be fully reversible. The process then becomes similar to when a widget is used to manipulate pegs
or elements.
TIP
If you want to use the Master Controller to control deformation nodes that are relative to other
deformation nodes, you can do so using the getDeformationComponentMatrix method of the
DeformationUtils namespace. For more information, refer to the Harmony scripting reference.
With the inverse matrix of a deformation node, we can convert world coordinates to a deformation node's
coordinates system. However, it is important to understand that curve and envelope deformation nodes are
represented by three points: The central point, and the two tangent points defining the secondary points of
the Bezier curves. If you plan to change the position of a curve or envelope deformation node, you will also need
to modify its tangent positions, with an algorithm such as:
Tangent0 in fields = Previous-Offset + rotation(Vector(length0 * 0.1, 0), orientation0
degrees)
Tangent1 = Offset + rotation(Vector(length1 * 0.1, 0), orientation1 degrees)

In the Harmony scripting interface, this would be expressed like so:
var t0FldU = add(previousDeformationNode.fieldOffset, rotate(Point2d
(deformationNode.length0 * 0.1, 0), deformationNode.orientation0));
var t1FldU = add(p1FieldUndeformed, rotate(Point2d(deformationNode.length1 * 0.1, 0), 180
+ deformationNode.orientation1));
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In this example, the deformationNode and previousDeformationNode are Deformation type objects
defined as:
function Deformation (nodePath)
{
var currentFrame = frame.current();
this.fieldOffset = node.getAttr(nodePath, currentFrame, "offset").pos2dValue();
this.OGLOffset = scene.toOGL(this.fieldOffset);
this.nodePath = nodePath;
this.nodeType = node.type(nodePath);
if(this.nodeType == "OffsetModule")
{
this.orientation0 = node.getAttr(nodePath, currentFrame, "orientation").doubleValue();
this.orientation1 = 0;
this.length0 = 0;
this.length1 = 0;
}
if(this.nodeType == "CurveModule")
{
this.orientation0 = node.getAttr(nodePath, currentFrame, "orientation0").doubleValue
();
this.orientation1 = node.getAttr(nodePath, currentFrame, "orientation1").doubleValue
();
this.length0 = node.getAttr(nodePath, currentFrame, "length0").doubleValue();
this.length1 = node.getAttr(nodePath, currentFrame, "length1").doubleValue();
}
}

TIP
You can easily obtain the names of a node's attributes for scripting by enabling Publish Attribute
Mode in the Node View and opening a node's Layer Properties dialog. For more information, refer
to the Scripting Guide.
In the following example, we use a Point2dWidget to move the position of envelope deformation nodes
towards it proportionally to the inverse distance between those two points. As the user drags the widget
around the stage, the deformation points will inch towards it:
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This is the node system for this example:

First, we calculate the position of the Point2dWidget in the coordinates system of each parent peg of each
deformation group in the scene.

// Get the deformation chains
getDeformationChains(leftmostParent, deformationChains);
for(var i=0; i&lt;deformationChains.length; ++i)
{
// The first node of a deformation chain is always an Offset in our case.
// Convert the position from world coordinates to the target peg
// model coordinates.

888

Chapter 8: Rigging

// Apply the inverse of the peg parent node transformation to the
// world position to go from world coordinates to (the peg) model
// coordinates
var pegParentNode = node.srcNode(node.parentNode(deformationChains[i][0].nodePath), 0);
var pegParentTransformation = node.getMatrix(pegParentNode, frame.current());
var inversePegTransformation = pegParentTransformation.getInverse();
var pegModelPoint = inversePegTransformation.multiply(worldPoint);
// A deformation chain is simply an array of deformation node parameters.
var deformationChain = deformationChains[i];
if(deformationChain.length == 0)
continue;
// Apply the magnet translation for the deformation node offset and
// both tangent points.
// The first node is the Offset which doesn’t require a previous position.
moveDeformationNode(deformationChain[0], new Deformation(""), pegModelPoint);
for(var j=1; j&lt;deformationChain.length; ++j)
{
moveDeformationNode(deformationChain[j], deformationChain[j-1], pegModelPoint);
}
}

Then, we compute the new position of the offset and tangent points of the deformation chains. We must also
compute new orientation values from the new tangent point positions.
function moveDeformationNode(deformationNode, previousDeformationNode, magnetPoint)
{
if(deformationNode.nodeType == "OffsetModule")
{
var p1FieldDeformed = scene.fromOGL(computePosition(magnetPoint,
deformationNode.OGLOffset));
node.setTextAttr(deformationNode.nodePath, "offset.X", frame.current(),
p1FieldDeformed.x);
node.setTextAttr(deformationNode.nodePath, "offset.Y", frame.current(),
p1FieldDeformed.y);
}
else if(deformationNode.nodeType == "CurveModule")
{
// Compute the new Offset attribute position
var p1FieldUndeformed = deformationNode.fieldOffset;
var p1FieldDeformed = scene.fromOGL(computePosition(magnetPoint,
deformationNode.OGLOffset));
// Set the new Offset attribute values.
node.setTextAttr(deformationNode.nodePath, "offset.X", frame.current(),
p1FieldDeformed.x);
node.setTextAttr(deformationNode.nodePath, "offset.Y", frame.current(),
p1FieldDeformed.y);
// Compute the Tangent 0 position
var t0FldU = add(previousDeformationNode.fieldOffset,rotate(Point2d
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(deformationNode.length0*0.1,0),deformationNode.orientation0));
var t0OGLU = scene.toOGL(t0FldU);
// Compute the new Tangent 0 position
var t0FldD = scene.fromOGL(computePosition(magnetPoint, t0OGLU));
// To compute the new orientation 0 position,
// compute the new position of the previous node.
var p0FieldDeformed = scene.fromOGL(computePosition(magnetPoint,
previousDeformationNode.OGLOffset));
// Compute the inverse of the tangent calculation
// to get the new orientation 0 position
var vRef0 = Point2d(1,0);
var ori0D = -angleDelta(minus(toPoint2d(t0FldD),p0FieldDeformed),vRef0);
// Compute the Tangent 1 position
var t1FldU = add(p1FieldUndeformed,rotate(Point2d
(deformationNode.length1*0.1,0),180+deformationNode.orientation1));
var t1OGLU = scene.toOGL(t1FldU);
// Compute the new Tangent 1 position
var t1FldD = scene.fromOGL(computePosition(magnetPoint, t1OGLU));
// Compute the inverse of the tangent calculation
// to get the new orientation 1 position
var vRef1 = Point2d(-1,0);
var ori1D = -angleDelta(minus(toPoint2d(t1FldD),p1FieldDeformed),vRef1);
// Set the new orientation attribute values.
node.setTextAttr(deformationNode.nodePath, "orientation0", frame.current(), ori0D);
node.setTextAttr(deformationNode.nodePath, "orientation1", frame.current(), ori1D);
}
}

TIP
Should you want to apply the deformations of a deformation chain to another deformation chain,
you can use the applyVertexTransform method of the DeformationUtils namespace. For
more information, refer to the Harmony scripting interface reference.
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Controlling Nodes Connected to a Master Controller
T-HSCP-002-016
A Master Controller node can detect the nodes that are connected to it and apply transformations on these
nodes.

Using the Specifications tab of the Master Controller layer properties, an input port can be added to the Master
Controller which will indicate which node system to control. Using this port, the script can be made to scan the
node system connected to it, and look for the expected pattern. For information on how to add port to a Master
Controller node, see Connecting Master Controller Widgets to Nodes on page 882.
NOTE
You should avoid using the main (rightmost) input port of the Master Controller node for this
purpose, as transformations sent to this port will affect the position of the widget in the stage.
For example, if we take the magnet widget programmed in the previous topic, this magnet attracts Element
nodes towards its position every time the mouse drags it. The rightmost input port of this widget's Master
Controller node is used to position the widget, but its leftmost port is used to specify the entry point of the node
system to control. To accomplish this, use the srcNode method of the Controller object.
// Get the parent node of the Master Controller node
// from its leftmost port.
var leftmostParent = node.srcNode(myController.node, 1);
// From the leftmost parent node of the Master Controller,
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// gather every Element node children.
var elementNodes = [];
getElementChildren(leftmostParent, elementNodes);
var nbElements = elementNodes.length;
for(var i=0; i&amp;lt;nbElements; ++i)
{
// do something
}

From there, you can use the node global object's dstNode method to find its children, as its type method to
obtain the type of each node.
// Recursively look for child Element nodes.
function getElementChildren(parentPath, elementPaths)
{
// Assume that the parent node has only one output port
// For nodes with multiple output ports, iterate on the last
// parameter using numberOfOutputPorts.
var numberOfLinks = node.numberOfOutputLinks(parentPath, 0);
for(var i=0; i &amp;lt; numberOfLinks; ++i)
{
// Get the child node path
var childPath = node.dstNode(parentPath, 0, i);
// Check the type of the child (READ is the Element node type)
if(node.type(childPath) == "READ")
{
elementPaths.push(childPath);
}
else
{
// Recursively inspect the child node children
getElementChildren(childPath, elementPaths);
}
}
}

If a node is inside a group, use the parentNode method of the node object to access the node's parent group
node.
var myDeformationGroupPath = node.parentNode(myOffsetDeformationNodePath);
var pegParentNode = node.srcNode(myDeformationGroupPath, 0);
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Referring to the Master Controller Node
T-HSCP-002-017
It is possible for the Master Controller node to refer to itself. The path to its own node is available in the global
Controller object. Because this object is created by the Master Controller node, it is specific to that node.
function myCallback(newValue)
{
// Get the parent node of the Master Controller by using its path from the
// Controller.
var masterControllerParentNode = node.srcNode(myController.node, 0);
}

The example above does not refer to the Controller object directly, but rather, to an object named
myController. This is because the Controller object is only available at the root level of the script or within its
own methods. To use the Controller object in other function in the script, it must be stored in a global
variable:
// The script context will be initialized when Show Controls will be called.
// Keep a script global copy of the Controller object.
var myController = Controller;
function point2dValueChanged(newPointValue)
{
// Not OK, the Controller global object isn’t available in callbacks
var masterControllerParentNode = node.srcNode(Controller.node, 0);
// OK, use a copy from the script global scope
var masterControllerParentNode = node.srcNode(myController.node, 0);
}
// Called when the user shows the Master Controller module controls
Controller.onShowControl = function()
{
Controller.controls = [];
Controller.controls.push(new Point2dWidget);
Controller.controls[0].valueChanged.connect(point2dValueChanged);
}
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Creating Templates with a Master Controller
T-HSCP-003-005
If you create a template of a character that uses a Master Controller, by default, the Master Controller's script
file will not be copied over in the template. The same goes for any other file the Master Controller could depend
on, such as an interpolation grid. Hence, the Master Controller will not work when the character template is
imported in another scene. To circumvent this, you must specify the master controller's script file and its
dependencies in the Extra Files property of the Master Controller node.
NOTE
Files to include with a Master Controller template must be located inside the scene directory, or in
one of its sub-directories, in order for Harmony to be able to copy them with the template.

How to specify files and folders to copy when creating a template that contains a
Master Controller.
1. In the Node view, click on the yellow square

of the Master Controller node to open its Layer

Properties.

2. Select the Extra Files tab.

3. Next to the Files to copy field, click on the Function
to store file and folder names.
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4. Click on the Function

button again to open the Files to copy dialog.

5. In the text field of the File to Copy dialog, do one of the following:
l

If all of your Master Controller's files are within one sub-directory of your scene, type the
name of that sub-directory. For example, if you stored all the files for your Master Controller in
the scripts sub-directory of your scene, type script.

l

Type in the path to each file your Master Controller depends on, relative to the scene
directory. For example, if your Master Controller uses the file myScript.js in the scripts
sub-directory of your scene, type scripts/myScript.js. You can type one file path per
line.

6. Click OK.
If you create a template that include the Master Controller node, the files listed in the Extra Files
parameter will be copied in the template's directory.
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About the Pose Interpolation Grid Script
T-HSCP-003-002
The Pose Interpolation Grid script is a reusable script that can be applied on pretty much any rig. The purpose
of this script is to allow a Rigging artist without any scripting knowledge to apply an orientation master
controller (2D dot) on a puppet for animators to quickly select a given pose or any interpolation option between
two given pose and use it as a key pose. This is only one example of what the master controllers can be used
for.
The principle is similar to the Pose Copier except that it is simpler to setup, much faster to use for the animators,
and allows them to select any interpolated pose instead of copying the exact one provided in the Pose Copier.
There is no need to select an external template to find the poses. Once the puppet is imported in the scene, the
poses are automatically imported along with the Master Controllers. When the animator displays the controls
on the Master Controllers node, the poses are loaded, the control widget is displayed and the animator is ready
to move the character to select any interpolated pose.
This script works quite well on 360 rigs for head and body orientation, and can be used on any standard
production rig to quickly pose arms, blinks, expressions, or anything else useful.
To make the setup easier to understand, the concept of the script is based on a visual grid.

To help you understand, the following example makes concrete use of the spatial grid for the setup poses. The
wrist is positioned on specific coordinates on the grid ((0, -1), (-5, -1), (-5, 5), (0, 5)).
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In your rigging setup scene, you would pose your character arm following a similar setup if you want to make
use of this master controller sample script.

Later on, when the master controllers script is setup, the control 2D dot will be placed on the wrist and will
allow the animator to move the arm from the wrist and chose any pose or interpolated frame between these
four poses.
The poses don't have to be spread in space, they can be stacked one on top of the other as would expressions
be. The visual control point then becomes a bit more symbolic. You can decide that the upper left corner
correspond to happy or angry and the bottom right one correspond to sad or anxious.
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You can create reference layers to help the animators remember where to move the dot to access a certain
expression. Using the Visibility node, you can make these handles only visible in OpenGL and be sure they
don't export in Render mode.
Where the grid concept becomes even more useful and makes a lot of sense is with 180 or 360 head
orientation and rotations. The idea is to feed poses to the master controllers for the animator to be able to
quickly set the key poses. The poses are given to the master controllers script by entering frame numbers, the
frame on which the official poses are set. When you have several head angles and tilts, it can be confusing to
know what frame number to enter and in what order to input them. A grid allows you to make sense of the
frames and position the visual control point.
Included in this master controllers script, are grid presets taking into consideration flipped poses. When
building a 360 production rig, Rigging artists will not create poses for both sides. They will create the poses for
the first 180 rotation and then copy the keyframes over and use a parent peg to flip these poses to create the
full 360 rotation, unless the character is not symmetrical. This sample script takes this method into
consideration, providing flipping preset grids.
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As shown above, some of the examples can be as simple as a 2x2 grid with four poses or could have a lot more
rows and columns such as a 6x3 grid with 18 poses and flips. The script allows you to chose the grid size you
need, save presets, position the control dot for each pose and filter which functions, deformers, pegs, and
parameters the master controllers will affect.
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Using the Interpolation Grid Script
T-HSCP-003-004
Before using the Interpolation Grid, you must create all the poses required for your Master Controller. To do this,
you can create a scene with your character rig in it, and put each possible pose for your character on a different
frame of the scene. The Interpolation Grid will use the frame number of each frame containing a pose as an
identifier for the pose.
Once your character's key poses are properly laid out in your scene's timeline, the next step is to select the
nodes which you intend to animate with the Master Controller in the Node view, then launch the
InterpolationGrid script. This script will open a dialog which will allow you to associate parts of the interpolation
grid to frames in your scene.

How to launch the Interpolation Grip setup interface
1. To make the coordinate setup easier, from the Node Library view, import a Grid node to your Node
view and connect it behind the elements.

2. To easily remember your frames, you can use Timeline markers to indicate the poses you intend to
use in the master controllers.

3. Add the Scripting toolbar to your workspace by doing one of the following:
l

In the top menu, select Windows > Toolbars > Scripting.

l

Right-click on any existing toolbar and select Scripting.

4. Follow these steps to add the Interpolation Grid script to the Scripting toolbar:
a. In the Scripting toolbar, click on the Manage Script
The Scripts Manager dialog appears.
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b. In the Files list of the Scripts Manager, select TB_Interpolation_Grid.js.

c. In the Functions list, select TB_Interpolation_Grid.
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d. Click on the Add script to toolbar

button.

The TB_Interpolation_Grid function of the TB_Interpolation_Grid.js script is
added to the In Toolbar list.

e. Click OK.
f. A button

for the TB_Interpolation_Grid script is added to the Scripting toolbar.

5. In the Node view, select the layers or group the master controllers will control.
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TIP
It is recommended to keep your character rig inside a single group to make its selection
easier.
6. In the Scripting toolbar, click on the TB_Interpolation_Grid script

button.

The Interpolation Grid dialog appears, with the Grid Parameters dialog just over it.

7. In the Keyframe count field of the Grid Parameters dialog, set the horizontal (X) and vertical (Y) size
of the grid to match the amount of vertical and horizontal poses you created for your character.
8. If the grid is too low or too high in relation to the character or where the affect zone is, you can
adjust the centre position of the grid.
9. You can also change the cell size to be bigger or smaller based on your artwork and poses.
10. From the Preset drop-down menu, you can select a preset grid if you want to reuse a provided or
custom grid.
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11. Click Done.
12. In the Visual Grid area, double click on the grid points to set the frame number corresponding to this
point's pose.

13. In the State Properties section, you can type a custom Identifier for the pose. For example, if the
selected frame has the character looking up towards the left, you could label the pose Look-UpLeft. You can also adjust the frame number of the pose, as well as the X and Y position the 2D point
widget must be positioned to obtain this pose.

14. Once your grid is completed, if you want to save it as a reusable preset for later setup or adjustments
to the current one, click the Save Preset button. You will be prompted to give a name to your preset.
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15. To avoid affecting unnecessary functions, such as pieces or deformers points that are not moving in
the given poses, in the Monitored Attributes section, press Filter Attributes to only retain the
modified attributes. The option is only available when all frames in the grid are set.

16. In the Output section, in the Name field, enter the name of the Master Controller node that will be
created.
17. In the Interpolation Grid interface, press Create.
18. You will be prompted to select a destination for the .tbstate file which will contain the
interpolation grid data. It is highly recommended to save this file in the scripts subfolder of your
scene's folder, so that it can easily be bundled with the Master Controller's script.
At this point, a new Master Controller node containing your interpolation grid will be added to the
Node View, and the controller for the Master Controller widget will appear as a blue dot in the
Camera view.

19. In the Timeline view, move the playhead to a frame that does not contain one of your interpolation
grid's poses, so that you can test the Master Controller without affecting your poses.
20. Move the widget in the screen to test the positions and the interpolation.
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TIP
At any time, the MasterController can be shown or hidden in the Camera view by doing one of
the following:
l

In the Camera view toolbar, click on the Show Control

l

In the top menu, select View > Show > Control.

button.

IMPORTANT
The Master Controller created by this script depends on files in your scene which, by default,
will not be copied over if you create a template with your character rig. If you intend to create a
template with your character rig, Creating Templates with a Master Controller on page 894 to
make sure your Master Controller will work when you create a template with it.
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Chapter 9: Cut-out Animation
Harmony provides some great tools for rigging and animating cut-out character models. You can make simple
rigs or give your characters flexible capabilities using peg hierarchies, groups, composites, cutters, and
deformers, among other things. You can create basic animations with the Transform tool, or more advanced
animation with Inverse Kinematics as well as Bone and Curve Deformers. Harmony also supports advanced
onion skin and image swapping features to help you animate efficiently and quickly.
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About Animating with the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has many
useful functions:

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece
from their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when
many parts are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out
animation.
When animating with the Transform tool, make sure to select the right selection mode. In this example, make
sure that the Peg Selection

Mode is disabled in the Tool Properties view or it will limit the selection in the

Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward
Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the
permanent pivot is displayed as a ghost.
NOTE
The interpolation of the animation poses is always calculated from each individual part's permanent
pivot. If there's a parent peg on a limb, make sure to select it instead of making a selection of each
part to avoid setting individual keyframes.
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Animating with the Transform Tool
The Transform tool allows you to move, rotate, scale and skew a selection or multi-selection.

How to animate using the Transform tool
1. In the Tools toolbar, click the Transform

tool or press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Timeline view, go to the frame on which you want to set the first position.
4. In the Timeline toolbar, click the Add Keyframe

button or press F6. It is recommended to add a

keyframe before moving the character. Moving a character's part without setting a keyframe will
create keyframes only on certain parameters of the animation. You could run into issues later on
when setting poses between existing ones. Creating a keyframe on all layers and parameters will
ensure your pose is set and will not be modified by other poses later on.
5. In the Camera view, select the element to animate and move it.

6. In the Timeline view, go to the frame where you want to set the next position.

7. In the Timeline toolbar, click the Add Keyframe
8. In the Camera view, animate the character.
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Resetting Transformations
With the Reset command, you can return a selected element to its initial position and scale values, depending
on which tool is active. For example, if the Rotate
and if the Transform

tool is active, the transformation angle will be reset to 0

tool is active, then all transformation values will be reset.

The Reset All option Resets all transformations on the current frame in a selected layer. Your keyframe will
remain, but all the values will return to the starting value. All transformations are reset regardless of the tool
you're using.
The Reset All Except Z option resets Resets all transformations on the current frame except the Z position. This
is useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different
views of a character. You might want to reset the transformation, but not necessarily the Z position.
NOTE
When using the Transform tool to select elements in the Camera view, always make sure the Peg
Selection Mode option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset or press R. This will reset the current frame if
keyframes were created.
The selected layer(s) return to their original position.

How to reset all transformations on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset All or press Shift + R.
The selected layer(s) return to their original position.

How to reset all transformation values except Z
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

911

Harmony 15.0 Premium User Guide

3. From the top menu, select Animation > Reset All Except Z.
All values except for those set on the Z axis are reset.

How to completely reset the layers' parameters
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset.
3. Do one of the following:
l

Right-click the selected layers and select Clear All Values. This will remove all
keyframes and reset all values for the entire layer.

l

In the Timeline View menu, select Layers > Clear All Values. This will remove all
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Hierarchy Navigation
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the
parent-child chain. You can navigate between the children of the same parent. You can also easily center on
your selection in the Timeline or Node view.
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Navigating Layers
Navigate between the layers in the Timeline view, using keyboard shortcuts or the Animation menu. This way
of navigating only works for unparented layers or the children of a parent layer. If you are navigating between
unparented layers, parent layers can be selected, but their children will be skipped. If you start on a parented
layer (child), only the other children of the same parent will be available for selection.

How move up and down the layer stack
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera or Timeline view, select an unparented layer or child layer of a parent with several
children.

3. From the top menu, select:
l

Animation > Select Previous Sibling or press / to select the previous child layer.

l

Animation Select Next Sibling or press ? to select the next child layer.
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Selecting Parent and Children
When animating, large movements that are made at the root (parent) of a chain cause secondary movements
throughout the rest (children) of the chain. For example, when you rotate the arm of a character from the
shoulder, the forearm and hand will follow. However, in order to make the movement appear natural and
graceful, the forearm and hand should not move at the same speed or angle. As a result, animators often need
to move up and down a chain, intermittently selecting parent and children, in order to make both large and fine
movements.

How to select the parent or child of the selected layer
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

4. Do one of the following:
l

Select Animation > Select Parent or press B to select the parent layer.

l

Select Animation > Select Child or press Shift + B to select the child layer.

l

Select Animation > Select Children to select all child layers at the same time.

NOTE
When going up or down your node hierarchy, these keyboard shortcuts skip any effect node
encountered. They will only change the selection to the next drawing or peg node found in the
hierarchy. This is because those shortcuts are optimized for digital animation. In the Shortcuts
tab of your preferences, you will find that these shortcuts are actually called Select Parent
Skipping Effects and Select Child Skipping Effects. If you want to use keyboard shortcuts to
navigate the hierarchy without skipping effect nodes, you can create custom keyboard
shortcuts for the Select Parent and Select Child commands in the Shortcuts tab of the
Preferences dialog box. Refer to the Harmony Preferences Guide to learn how to create custom
keyboard shortcuts.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can
use the Centre on Selection feature to display the selected object's layer in the Timeline view.
Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it
hard to locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar
to focus on the selected node in the Node view. You can also select elements in the Timeline or Xsheet view.
This can be useful when there are too many objects in the scene or when an object is hard to grab. Finally, you
can select all the elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view
1. In the Camera or Node view, select a layer.
2. Do one of the following:
l

From the Timeline view menu, select View > Centre on Selection or press O.

l

In the Timeline view toolbar, click the Centre on Selection

button.

How to center on the selected layer in the Node view
1. In the Camera or Timeline view, select a layer.
2. Do one of the following:
l

From the Node View menu, select View > Centre on Selection.

l

In the Node View toolbar, click the Centre On Selection

l

In the Node view, press O.
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About Keyframes
Keyframes are the building blocks of Cut-out animation. Unlike Traditional animation, where every pose is
drawn, Cut-out animation uses keyframes to mark major poses (key poses) and lets the software create all the
poses in between.
In Harmony, you can create two kinds of keyframes: Motion and Stop-Motion. Motion keyframes behave like the
description above; they allow for the automatic creation of drawings between two keyframed poses. StopMotion keyframes do not allow for interpolation between keyframes. They are often used to block poses,
somewhat similar to what you would see in Traditional Animation.
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Creating Motion Keyframes
T-LAY-004-001
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it
using motion keyframes. When you use motion keyframes, the drawings gradually move to the next position
instead of staying on the spot until the next keyframe.

How to create motion keyframes
1. In the top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.
2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:
l

Right-click on the selection and select Insert Keyframe.

l

Click the Add Keyframe

l

Press F6.

l

In the Camera view, if the Animate mode is enabled, as soon as you move the selected

button in the Timeline toolbar.

element, a keyframe will be automatically created on the current frame.
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How to convert a stop-motion keyframe into a motion keyframe
1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.

2. Do one of the following:
l

Right-click on the selection and select Set Motion Keyframe.

l

Click the Motion Keyframe

l

Press Ctrl + K (Windows/Linux) or ⌘ + K (macOS).

button in the Timeline View toolbar.
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Creating Stop-motion Keyframes
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing
key poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the
interpolation between your keyframes.
When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is
constant. There is no animation generated by the computer between the poses. The drawing remains in
position until the next keyframe, then moves to its new position.

How to create stop-motion keyframes
1. In the top menu, make sure the Animation > Stop-motion Keyframe option is selected.
2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:
l

Right-click and select Insert Keyframe.

l

In the Timeline toolbar, click the Add Keyframe

l

Press F6.

l

In the Camera view, if the Animate mode is enabled, as soon as you move the selected

button.

element, a keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe
1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

2. Do one of the following:
l

Right-click and select Set Stop-Motion Keyframes.

l

In the Timeline toolbar, click the Stop-Motion Keyframe

l

Press Ctrl + L (Windows/Linux) or ⌘ + L (macOS).
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About Swapping Drawings
T-RIG-004-001
Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the
animation a more traditional animation look. You can add as many new drawings as you want in your scene and
use them in your current animation. You can also add new drawings to the library and use them in other scenes.
But before starting to swap drawings, it's important to understand how keyframes, exposure and key exposure
work in Harmony:

l

Keyframe: A keyframe is a point in time where a change to the properties of the object or character
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its
contents are moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

l

Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames.
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings.
Keyframes can be moved independently from the drawing exposure.

l

Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain
exposed on a specific frame. If a drawing is exposed before a key exposure and you swap out that
drawing for another one, then the original drawing is retained. This preserves the key drawing. Note
that Harmony automatically sets a key exposure when you perform a drawing swap.

When you want to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution
window lets you see the drawings before selecting one for swapping. In this view, you are actually selecting
drawings in your scene layers, not drawings in the Library.
NOTE
Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing
exposure.
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Swapping Drawings in the Timeline View
T-LAY-003-001
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is
different. If you are using the Parameters area of the Timeline view to select a drawing to replace a selected
frame range, the new drawing will replace the frame range and continue until the next key exposure. In the
following example, drawing 2 (DR2) is replaced by a new drawing, starting at the beginning of the selected
frame range and ending at the next key exposure.

How to swap a drawing in the Timeline view
1. In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

2. In the Drawing Substitution field, position the pointer over the value and drag left or right to change
the cell or drawing exposed for another one. You can also type in the drawing name or symbol’s cell
number if you know it.
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Swapping Drawings in the Library View
T-LAY-003-002
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is
different. If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is
split in two and the exposure before and after the frame range remain the same. In the following example,
drawing 2 (DR 2) is split in two and the selected frame range is filled with a new drawing.

How to swap images in the Library view
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection
3. In the Camera view, use the Transform

button is deselected.

tool to select a part of the drawing to swap.

NOTE
You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one
symbol for another.

4. In the Timeline view, select the cell range in which you want to swap the drawing.
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5. In the Library view, go to the Drawing Substitution window.

6. Scroll through the symbol's frames or drawings by doing one of the following:
‣

From the top menu, select Animation > Substitute Drawing Previous or Substitute Drawing
Next.

‣

Drag the slider left or right.

‣

Press +.

The drawing or symbol’s cell on the current frame is replaced.
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Adding Key Exposures
If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property
of an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is
the same drawing or not.
NOTE
Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be
automatically updated even if set as a key exposure. This keeps your existing animation key poses
intact. It is frequently used on a mouth or eyes layer.
Example: Swapping a drawing with no key exposure
In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure.

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure
Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead
is positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing
5 for drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure
1. In the Timeline view, select the drawing cell to set as the key exposure.
2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure
‣

In the Timeline toolbar, click the Add Key Exposure

‣

In the Timeline menu, select Exposure > Add Key Exposure.

‣

Right-click and select Exposure > Add Key Exposure.

button.

button.

A new key exposure is added.
If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that
same drawing. If you added a key exposure anywhere other than the beginning of the drawing,
then the drawing is split in two and both parts contain the same drawing.
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key
exposure is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1
(DR 1). When the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4
(DR 4).

How to remove a key exposure
1. In the Timeline view, select a key exposure to remove.
2. Do one of the following:
l

l

l

In the Timeline toolbar, click the Remove Key Exposure

button.

In the Timeline menu, select Exposure > Remove Key Exposure.
Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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About Eases
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature
and set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle
and left handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can
pull on them to adjust the ease in and ease out, or type values in the fields.
If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and
arm of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one
frame.
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Setting Eases for Multiple Parameters
You can adjust eases for multiple parameters at once.

How to set ease on multiple parameters
1. In the Timeline view, collapse your character model's hierarchy.
2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the
keyframe on every layer simultaneously.

3. Do one of the following:
l

In the Timeline view, right-click and select Set Ease For Multiple Parameters.

l

In the Timeline toolbar, you can click the Set Ease For Multiple Parameters

button.

The Set Ease For Multiple Parameters dialog box opens.

4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the
Filters section, deselect the function types you do not want to affect.
l

Motion: Applies the easing parameters to the selected Position X, Position Y, Position
Z and 3D Path functions

l

Rotation: Applies the easing parameters to the selected Angle functions.

l

Scale: Applies the easing parameters to the selected Scale functions.

l

Skew: Applies the easing parameters to the selected Skew functions.

l

Morphing: Applies the easing parameters to the selected Morphing Velocity functions.
Note that it is applied to the Morphing Velocity function in the Layer Properties
window, not to the basic Morphing ease in the Tool Properties view.

l

Other: Applies the easing parameters to all the other selected functions, such as all
functions created to animate effect parameters.

6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values
are calculated in percentage.
l

In the Left Time Ratio and Right Time Ratio fields, type the percentage value
corresponding to the length of time you want the easing to last. The value must be
between 0% and 100%.

l

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how
strong you want the easing out. The value must be between 0% and 100%.

l

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

7. Click one of the following buttons:
l

Apply/Previous: Applies the easing parameters to the selected keyframes and then
selects the previous keyframe in the timeline.

l

Apply: Applies the easing parameters to the selected keyframes.

l

Apply/Next: Applies the easing parameters to the selected keyframes and then
selects the next keyframe in the timeline.
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l

Close: Closes the dialog box. If you did not apply the modifications, they will be
cancelled.

NOTE
If a range containing multiple keyframes is selected, only the first selected keyframe will be
affected by the Seat Ease for Multiple Parameters functionality.
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Using the Onion Skin in Cut-out Animation
T-HFND-006-006
When animating cut-out characters, it is useful to see the previous and next frames on the animation. However,
it can sometimes be confusing to see the onion skin for every part of the character. You will often only want to
see the onion skin on a single part or a few parts, such as the arm that is currently being animated.

While animating in the Camera view, there is a series of different onion skin options. You can enable these
options in the menu or manually in the Timeline view using the layer's Show Onion Skin

button. Only

selected layers will be displayed in the onion skin preview; you can change the display options when you use
the onion skin.

How to use the onion skin
1. In the Tools toolbar, click the Onion Skin
2. In the Tools toolbar, click the Transform

button or press Alt + O.
tool or press Shift + T.

3. In the Camera view, select one or more elements.
4. Select View > Onion Skin and one of the following commands:
l

Add to Onion Skin: Adds a series of selected elements to the onion skin preview.

l

Remove From Onion Skin: Removes a series of selected elements from the onion skin
preview.

l

Remove Unselected from Onion Skin: Removes all elements except the ones selected
from the onion skin preview.

l

Add All to Onion Skin: Adds all of the scene's elements to the onion skin preview.

l

Remove All from Onion Skin: Removes all of the scene's elements from the onion skin
preview.

Add to Onion Skin
The Add to Onion Skin command adds a series of selected elements to the onion skin preview. The keyboard
shortcut is Shift + S.
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Remove from Onion Skin
The Remove From Onion Skin command removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion Skin
The Remove Unselected from Onion Skin command removes all elements except the ones selected from the
onion skin preview.

Add All to Onion Skin
The Add All to Onion Skin command adds all scene elements to the onion skin preview. The keyboard shortcut
is Alt + Shift + O.
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Remove All from Onion Skin
The Remove All Onion Skin command removes all scene elements from the onion skin preview. The keyboard
shortcut is Ctrl + Shift + O (Windows/Linux) or ⌘ + Shift + O (macOS).
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Using the Outline Mode
Use the Outline mode to temporarily convert all the drawings on a layer to outlines. You can still select and
manipulate the drawings in this mode. Select a drawing by selecting its outline. The fill is not taken into account
when making selections in this mode.

Toggling drawings to outlines
1. In the Timeline view, click once on the Change Track Colour button of a layer to toggle all drawings
of that layer to outlines, in the Camera view.
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Changing the outline colour
1. In the Timeline view, double-click on the Change Track Colour button of a layer to open the Select
Colour dialog box.

2. In the Select Colour window, select a new colour for your outlines.
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3. Click Ok.

The colour swatch and frames of the selected layer take on the new colour. In the Node view, the
layer's corresponding node also displays the colour marker.

4. In the Timeline view, click once on the change track colour of a layer to toggle all drawings of that
layer to outlines, in the Camera view.
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The outlines of the layer's drawings appear in the selected colour.
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Flipping Through Poses
When animating, it is useful to flip through poses to see the flow of your animation without going through each
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses
1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

2. Do one of the following:
l

From the top menu, select Animation > Go to Previous Keyframe or Go to Next
Keyframe

l

Press semicolon (;) and single quote (').
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Flipping Parts
If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip
Vertical options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the Tool Properties view, click the Flip Horizontal
respectively.
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Animating Lip-Sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a
particularly tedious part of the animation process.

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE
The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to
the sound they are meant to produce.
This is an approximation of the English phonemes each mouth shape can be used to represent:
l

A: m, b, p, h

l

B: s, d, j, i, k, t

l

C: e, a

l

D: A, E

l

E: o

l

F: u, oo

l

G: f, ph

l

X: Silence, undetermined sound

943

Harmony 15.0 Premium User Guide

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work,
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and
these drawings should be named by their corresponding letter.

How to generate a sound detection for lip-sync using the Layer Properties view
1. In the Timeline or Xsheet view, select the sound layer.
The options for that layer will appear in the Layer Properties view.
2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell.
3. Click the Map button to open the Lip-Sync Mapping dialog box.

4. From the Destination Layer menu, select the layer that contains the mouth positions for the
character's voice track.
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NOTE
If the selected layer contains symbols, you can map the lip-sync using drawings located
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't
Use Any Symbol if you want to use the drawings or select the desired symbol from the
drop-down menu.
5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip
this step.
6. Click OK.
7. In the Playback toolbar, enable the Enable Sound
8. Press the Play

option.

button in the Playback toolbar to see and hear the results in the Camera view

You can manually create the lip-syncing for your scene by selecting which mouth drawing should be exposed at
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality,
which plays the part of your sound track at the current frame whenever you move your Timeline cursor,
allowing you to identify which phonemes you should match your character's mouth to. You will also be using
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the
drawing name (often a letter) until it changes to the swapping

pointer.

5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current
drawing automatically changes to the new selection.

945

Harmony 15.0 Premium User Guide

How to animate lip-sync using the Library view
1. In the Playback toolbar, click the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape.
The current drawing is swapped for the one in the preview window.
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Ordering in Z-Depth
The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows
you to create a multiplane and move elements closer or farther from the camera. This allows you to move the
puppet’s pieces in front of or behind other ones without physically changing the layer position.

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is
created where different Z values can be entered. This allows the piece to move forward and backwards in
space without requiring you to change the drawing’s original position or break the layer hierarchy. This also
means that the layer ordering is maintained throughout the scene. You can combine animation assets so
Harmony can interpolate them.

How to nudge elements on the Z-axis
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, click the Animate

tool or press Shift + T.
button.
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3. In the Camera view, select the part to be repositioned and hold down the Alt key.
4. Using the Up Arrow or Down Arrow arrow keys, nudge the part until it moves to the desired
position.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy Cells From the Timeline.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. From the top menu, select one of the following:
l

Edit > Paste Cycle

l

Press Ctrl + / (Windows/Linux) or ⌘ + / (macOS).
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The Paste Special dialog box opens.

5. In the Cycles drop-down, select the type of cycle to paste:
l

Normal (forward): Pastes the selection as is, starting with the first cell and ending with the
last.

l

Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

l

Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the
last cell and ending with the first cell.

l

Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell,
going to the first one and ending with the last cell.
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1. In the Number of Cycles field, enter the number of cycles to paste.

2. Click OK.

How to create a reverse animation cycle
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want the cycles to start.
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4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘ + . (macOS).
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About Inverse Kinematics
The Inverse Kinematics (IK) tool allows you to pull on a character's extremities, such as the hands and feet, and
have the rest of the body follow. It can be used on any piece connected in a hierarchy. However, you don't have
to use IK every time you have a hierarchy rig. This tool is useful when you want to bend a character's knees,
make it sit and move the rest of the body, and so on. It will also assist you with posing difficult moves.

In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony uses the
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character.
Inverse Kinematics in Harmony uses the connection between each of the parts' pivots.
Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present. IK
only works on a hierarchy where the pivots are properly set.
Harmony provides different tools for animating cut-out characters and trajectories. The two main tools used to
animate characters are the Transform and Inverse Kinematics tools.
Here, we'll compare the usage of these tools and explain the Inverse Kinematics philosophy.
l

Transform Tool
Also known as forward kinematics, the Transform tool is the main tool to use for cut-out animation. This
tool rotates, scales, moves and skews selected elements as one global element.
Forward kinematics means that the limb is animated from the parent down to the last child as a single
piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as a complete
arm drawing.

l

Inverse Kinematics Tool (IK)
This tool helps you achieve complex motions, such as sitting down or knee bending. The Inverse
Kinematics tool moves and rotates every selected element as a chain.
Inverse kinematics means that the element is animated from the child up to the parent. In other words, if
the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly natural way in
terms of the movement, rotation and bending.

The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and parts are
attached to one another. In other words, it depends on the rigging type.
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There are several ways to rig a puppet. These are the three main rigging techniques:
l

l

l

The Basic Rig Technique
l

This is the simplest rig technique.

l

There are no connections between the parts.

l

They are free to move, rotate and scale independently from each other.

l

The Inverse Kinematics tool CANNOT be used on this type of rigging.

The Hierarchy Rig Technique
l

This is a complex rig technique.

l

All the parts are connected to each other.

l

As they move, rotate and scale, they will influence all the other parts.

l

The Inverse Kinematics tool can be used on this type of rigging.

The Mixed Rig Technique
l

This is the best of the basic and hierarchy rig.

l

Some parts are independent such as the torso.

l

Some parts are set up in a hierarchy such as the arms and legs.

l

Independent parts are rigged in hierarchy using parent pegs.

l

The Inverse Kinematics tool can be used on this type of rigging.

Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (forward kinematics) as it has all the main motions: rotate, scale, skew,
move and select. You can also control the exact position of the parts while using the Transform tool. As well, the
Transform tool creates a temporary global pivot on the selection that can be moved around for the animation
purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you can use
the Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible to lock the feet or
any other part to a particular spot and move the rest of the body, which will react to the constraints.
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You will not be using it to
animate all the time.
Also, the Inverse Kinematics tool can be used to create the character's posing faster. Posing is a crucial part in
the animation process. The Inverse Kinematics tool can be used to pose the character more naturally,
depending on your own preferences.
An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as
an arm or a portion of the arm.
Here are some tips and tricks to help you to use the Inverse Kinematics tool.
l

Inverse Kinematics on Mixed Rigs
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The Inverse Kinematics tool can be used on a full puppet's body even if it's connected as a mixed rig,
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails on the
puppet's feet, select the full body master peg and move the character as if it was connected in a full
hierarchy rig. This technique works on most mix rigs.
l

Inverse Kinematics Constraints
It's important to remember that you can add and remove IK constraints (nails, hold orientation, etc.) at
any time during the animation. They hold a certain part on the spot while you animate the rest of the
body. Because they're not constricting one part to another object, you can add or remove them without
affecting any of the animation you have already completed.

l

Useful Shortcuts
l

While using the Inverse Kinematics tool, you can Ctrl + click (Windows/Linux) or ⌘ + click
(macOS) to select any part.

l

Hold Alt to rotate the selected part without affecting the IK chain.

l

Press Shift and click in a part's pivot to add or remove an IK Nail.

l

Press Shift and click on a bone to add or remove and Hold Orientation constraint.
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About IK Hierarchy Chains
Before going any further, a word about IK chains. There are three types of chains:
l

Single Chains
The single chains are the most basic of chains. A single chain is a straight line with no secondary
chain attached. It goes up to the first intersection.

l

Direct Chains
A direct chain is a single chain which goes directly to the core (root).

l

All Chains
All chains are attached and move together when one part is moved.
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About IK Setup
The first time you display the character's skeleton, notice a series of bones on the extremities which are out of
place. There may also be some elements that you would like to exclude from the IK chain.

It is highly recommended to set up the skeleton before starting your animation.
Before fixing any bones, or excluding layers from the IK skeleton, make sure all the elements you want to be
parented in a chain are set up.
You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms. If the
body is not completely rigged in hierarchy, the skeleton will look a bit more messy, but the IK tool will still work
properly.
When working with the IK tool, you will probably want to move the main parts around, but not necessarily the
small ones such as the nose or ears. To do this, you can select some elements on your character and exclude
them from the skeleton.
Once you remove the extra elements from the skeleton, set the bone orientation for the extremity parts. By
default, they are oriented horizontally towards the right. This orientation often works for the feet but not
necessarily for the hair or hands.
Harmony allows you to set a minimum and maximum angle constraint on certain joints, such as the knees or
elbows. When using the Inverse Kinematics tool or even the Forward Kinematics (Transform tool), it is possible
that some joints will bend in the wrong direction.
If you plan to animate a lot with the Inverse Kinematics tool, it's a good idea to try the angle constraints. The
angle constraints can be set by the character builder or by the animator in particular scenes where it's needed.
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NOTE
It is recommended to use the minimum and maximum angles only if the character does not change
view within the same layers. For example, if a character is facing the camera and has some angle
limitations enabled, it could be problematic if the character switches to side or quarter view since
the joints won't bend the same way.
Use the minimum and maximum angle constraints if your character's views are in different
templates or layers. If the character's views are in the same layers, then it's better not to use the
angle constraints.
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Excluding Elements from IK Skeletons
You can easily remove elements from your IK skeleton to simply it.

How to exclude elements from the skeleton
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) on the part to exclude from
the skeleton.

4. In the Tool Properties view, click the Exclude from IK

button.

5. Repeat the process for every part to be excluded from the skeleton.
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Orienting Bones
Extremity bones can be rotated to match the drawing's orientation.

How to set the bone orientation
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, enable the Bone Editing

mode.

3. In the Camera view, click on the pivot belonging to the part whose bone you want to reposition,
then pull the pivot in the desired direction.

4. Repeat this process for each bone you want to position.
NOTE
This command only works on the extremities.
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Setting Minimum and Maximum Angles
You can set minimum and maximum angles your character's limbs to avoid overbending them.

How to set the minimum and maximum angles
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode

is

enabled.
3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) on the piece to set the
minimum and maximum angle.

4. In the Tool Properties view, in the Selection section, click the Enable Min/Max Angle

option.

5. In the Camera view, rotate the Minimum and Maximum handles to set the angle.

6. Test the angles using the IK Manipulation

mode.

7. For additional control over the Min/Max Angle, go to Edit > Preferences (Windows/Linux) or
Harmony Premium > Preferences (macOS). Select the Camera tab. In the Inverse Kinematics
section, look at the Min/Max Angle Constraint Weight. Although the maximum value goes up to 1.0,
in a production setting, the most practical value would be closer to 0.1. This value acts similar to the
Stiffness setting in the Tool Properties view. The higher the value, the more difficult it becomes to
approach the minimum and maximum values.
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About Nails
Often, you will want to animate only part of a character, such as the arm and not the entire body. You can do
this using IK nails, which are IK constraints that temporarily cut or constrain the chain. With IK nails, you can cut
an IK chain or block a part on the spot. For example, you can fix a character's feet to the ground when it walks.
There are different types of constraints you can place on the chain:
l

IK Nail: Blocks the X, Y and Z positions.

l

Hold Orientation: Blocks the angle.

l

Hold X: Blocks only the X position.

l

Hold Y: Blocks only the Y position.

l

Enable Maximum and Minimum Angles: Sets limitations on the angle parameter to prevent the
puppet from bending too far.
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Setting Nails
You can place nails on your skeleton to temporarily hold it in place.

How to set an IK nail
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) on the part to set a nail on.
4. In the Tool Properties view, select a type of nail:

l

Hold the Shift key and click on any part's pivot to set a regular nail on it without
having to select it.

l

Hold the Shift key and click on the bone to set a Hold Orientation nail.

l

Select the nail type in the top menu by selecting Animation > IK Constraints > desired
nail.

l

Remove the nail at any time using the same technique you did for placing the nail. It
will not affect the animation.

5. To remove all nails except the Enable Min/Max Angle ones, from the top menu, select Animation >
IK Constraints > Remove All Constraints.

964

Chapter 9: Cut-out Animation

Animating with Inverse Kinematics
Inverse Kinematics works best when you lock a part of the character on the spot, such as a foot on the floor,
then select the entire body or another extremity and move it. It also works well in single chain mode when you
need to simply position a limb.
To learn more about the IK tool's properties, see the Reference guide .
NOTE
To lock a part in place, use the IK Nail option—see About Nails on page 963.

How to animate with the Inverse Kinematics tool
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) on a part of the body.
The entire IK skeleton appears.

3. Click on a part of the body and pull on it to move the character.
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4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You
can Shift + click on a bone to lock the orientation of the bone.

5. Click on another part of the character and pull on it.
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About IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key
poses. However, when you use motion keyframes to auto in-between the animation, you'll notice a movement
of the feet. This motion is caused by the in-betweening of the rotations.
The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration between
keyframes.
If you place a nail on the shoulder to move just the arm, you don't necessarily want to keep the shoulder in the
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to
have a slight, natural motion following the main body action. Of course, this is not the case when you fix a hand
or a foot on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed
it. That is why you can apply an IK constraint on a frame range and on selected body parts.
To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much.
For example, to fix a foot that is moving too much, you must correct the angles on the foot, leg and thigh. To fix
a hand, you must correct the angles on the hand, forearm and upper arm.
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Setting IK Keyframe Constraints
When setting up a hierarchy chain, the parent is usually the part that is at a logical point of rotation. For
example, in the case of a leg, the parent would be the thigh, as it rotates from the hip and its children would be
the shin and foot that will always follow.
However, sometimes you come across a situation where you need the movement to stem from the child, such as
in the case of a ballerina, where the shin and thigh rotation follow the position of the foot. In order to keep the
foot from gliding around, making the kinds of secondary movements that children do, you need to nail the foot
in place and constrain its orientation (rotation). Sometimes this constraint needs to be held for several frames.

How to apply IK constraints on a frame range
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Camera view, click on the part on which you want to apply the constraint.
3. In the Timeline view, select the first frame on which you want to start applying the constraint.

4. In the Tool Properties view, enable the Apply IK Constraints
5. In the Tool Properties view, click the IK Keyframe

mode.

button to enter the first frame number.

6. In the Timeline view, move the playhead to the last frame on which you want to apply the
constraint.

The IK Keyframe field should now look like this:
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7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on the
thigh by holding down the Shift key and clicking its pivot.

8. In the Tool Properties view, select the type of constraint to apply to the piece. The most common
one is a combination of the regular Nail

and Hold Orientation

options.

9. In the Camera view, click on the bone of the part you want to apply a constraint to.
A warning message appears asking you to confirm that you want to add a constraint on that
particular piece and for that frame duration.

10. Click OK.
The constraint is applied.
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Chapter 10: Motion Paths

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera
moves and camera shakes, adjust the easing, shape your paths with control points and much more.
Before animating the position of your layers, you need to create motion paths which are trajectories on which
you can attach drawing objects. Using keyframes, you can then record key positions along the trajectory.
Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a
simple motion, you will learn the basics of animating a layer.
There are two ways to create motion paths: animated drawing layers and pegs. They each have different
purposes.
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About Pegs
T-HFND-009-004
A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg
holes at the bottom or top of the animation paper are used to keep all the sheets even and at the same
registration.
There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones
are oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg
hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to
the shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.
Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create
animation and camera motion.
A peg is composed of many customizable parameters. These parameters are:
l

X, Y and Z positions (3D Path or Separate Positions)

l

Angle (rotation)

l

Skew

l

X and Y Scales

l

Euler Angle or Quaternion Angle (when 3D option is enabled)

l

Z Scale (when 3D option is enabled)
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You can control a peg’s trajectory the same way as the animated drawing layer.
A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds.
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to
control your puppet as one object.
In Harmony, you can add pegs to the Node view using the Node Library view and they will instantly appear in
the Timeline view. The nodes you add to the Node view are synchronized with the ones in the Timeline view.
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Adding Pegs
T-ANIMCO-001-001
You can add peg to your Timeline view and parent the layers to animate to it.

How to add a peg in the Timeline view
1. In the Timeline view, select the layer on which you want to attach a peg.

2. Do one of the following:
l

From the Timeline view layers toolbar, click the Add Peg

button.

l

From the Timeline view menu, select Insert > Peg.

l

From the top menu, select Insert > Peg.

l

Right-click on the selected layer, then select Insert > Peg.

l

In the Node Library, select a Peg node and drag it to the Node view.

l

Press Ctrl + P (Windows/Linux) or ⌘ + P (macOS).

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg
layer automatically takes the name of its child layer, with the addition of the suffix -P.
The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to
the Peg layer. This relationship is called a parent-child relationship.

3. If you intend to add multiple pegs or if the layer name that was added to the peg does not
accurately represent the content of the Peg layer, you can rename it. Click the layer name and type
in a new name. Or double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then
drag the layer you want to attach to the peg and drop it directly below the Peg layer. The
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indentation of the layer below the Peg layer indicates whether it was correctly attached or not.

l

You can unparent layers by holding down Shift and dragging the selected parents
away from the child layer. Drop your selected between other layers.

How to add a peg in the Node view via the Node Library
1. In the Node Library view, select the Move tab.
2. Select a Peg node and drag it to the Node view. You can also press Ctrl + P (Windows/Linux) or ⌘ +
P (macOS).

3. In the Node view, select the Peg node's output port and connect it to a Drawing or Camera node.

The advanced connections in the Node view are shown in the Timeline view, unless they cannot be
reproduced in a timeline layout.
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Enabling Peg Selection Mode
In the Tool Properties view, the Peg Selection Mode

lets you automatically select the peg layers in the

Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent
Skipping Effects command.

How to enable the Peg Selection Mode
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tool Properties view, click the Peg Selection Mode
3. In the Camera view, select an element parented to a peg.
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Connecting Nodes to Pegs
You can connect several nodes to a single parent peg or give them each their own peg.

How to create an automatic connection to a parent peg
1. In the Node view, select one or more drawing nodes that are not parented to any other node.

2. Press Ctrl + P (Windows/Linux) or ⌘ + P (macOS) to add a new peg node to the Node view and
automatically connect it to the selected nodes. Press Ctrl + Shift + P (Windows/Linux) or ⌘ + Shift +
P (macOS) to add a peg to each node.
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About Drawing Layers
T-ANIMCO-001-002
You can create a motion path directly on layers (animated layers).

You can control and define a trajectory using several different parameters, including:
l

X, Y and Z positions (3D Path or Separate Positions)

l

Angle (rotation)

l

Skew

l

X and Y Scales

3D objects and 3D-enabled layers also have these extra paramaters:
l

Euler Angle or Quaternion Angle (when 3D option is enabled)

l

Z Scale (when 3D option is enabled)

Harmony keeps track of the animation by storing each parameter of each layer in their own function curve.
When you add a keyframe to a layer, a keyframe is created on each of these functions, and transformations
done on a layer via the Camera view are translated into coordinates which are then stored in those functions. It
is possible to edit these functions individually using the Function view, but that is rarely necessary, as Harmony
provides easy-to-use tools for visually controlling trajectories and timing in the Camera and Timeline views.
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If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls
tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily identify
them as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.
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Disabling Layer Animation
By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do
so by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure
and keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose their
offset keyframes or drawing substitution keyframes.

How to disable animation on a drawing layer
1. In the Timeline view, double-click the layer on which you want to set the parameter.
The Layer Properties editor opens.
2. In the Controls tab, deselect the Animate Using Animation Tools option.
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About Layer Parameters
T-HFND-009-008
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew
and scales. Each parameter has its own function which is a mathematical formula expressing the relationship
between position values. You can view each function on a graph as a simple curve, such as the one below.

There are several options available for setting up function parameters:
l

Locked Positions (3D Path)

l

Separate Positions

l

Locked Scales

l

Separate Scales

l

Quaternion (3D Rotation)

l

Euler Angles (3D Rotation)

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation.
When you lock or unlock parameters, this does not convert the functions from one to the other, but creates new
ones.
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In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you
add a keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth
trajectories.

When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one
another. This is why in cut-out animation it is recommended to use separate position settings. But if you work
with 3D path, you can use the Constant Z feature to avoid this from happening.
The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works
with 3D paths.
When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls
directly on their function curve. This is useful when you want to set keyframes on one of the curves without
affecting the others.
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When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal)
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions,
you can squash, stretch and skew your elements.
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Displaying Layer Parameters
T-ANIMCO-001-004
You can easily display the parameters for each layer in the Timeline view.

How to display the layer parameters in the Timeline view
1. Do one of the following:
l

In the Timeline’s left side, click a layer's Expand

l

In the Timeline view menu, select View > Show Functions.

l

Press Alt + F.
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Setting Layer Parameters
T-ANIMCO-001-003
You can modify the layer parameters to different types of function and linking some of them together.

How to set the layer parameters
1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also
see the parameters in the Layer Properties window when you select the layer in the Timeline view.
The Layer Properties window opens.

2. Select the Transformation tab.
3. In the Position section, select the 3D Path or Separate option.
4. In the Scale section, select the Locked or Separate option.
5. Click Close.
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Enabling Constant Z
T-HFND-009-008A
You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option
1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that
you must select the 3D Path option for the layer.
2. Double-click on one of the position functions to open the Function editor.
3. In the Function editor, select the Constant Z

button.
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About Keyframes
T-HFND-009-005
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like
to create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no
interpolation) and motion keyframes (computer-generated interpolation).
In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is
constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops
to its new location.

With motion keyframes, Harmony generates the interpolation between the keyframes. This means that a value
for each frame between the keyframes is calculated by Harmony to progress from the value of the previous
keyframe to the value of the next keyframe.
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Enabling the Animate Mode
T-ANIMCO-001-007
The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view.
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled,
keyframes are not created when an object's parameters change.
When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your
drawing layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off
1. In the Tools toolbar, click the Animate

button or select Animation > Animate.
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About Keyframe Creation
There are several different ways you can create keyframes. You can add a coordinate keyframe, position
keyframe or a keyframe along with your drawing duplication.
You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer
stays the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do
not want to modify the original.
You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and
Skew parameters.
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Creating Keyframes in the Timeline View
T-HFND-009-006
You can add keyframes in the Timeline view to multiple layers, a single layer or a specific parameter.

How to create keyframes in the Timeline view
1. In the Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe by doing one of the following:
l

From the top menu, select Insert > Keyframe.

l

Right-click on the selection and select Insert Keyframe.

l

Press F6.

l

In the Timeline View toolbar, click the Add Keyframe

button.

If the Animate mode is enabled in the Camera view, a keyframe is automatically created on the
current frame.

How to add a keyframe for a specific parameter
1. On the right side of the Drawing layer, press the + to expose the different functions of that drawing.
2. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

3. Do one of the following:
l

Right-click the selected cell and select Insert Keyframe.
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l

Press F6.

l

In the Timeline View menu, select Motion > Insert Keyframe.

l

In the Timeline View toolbar, click the Add Keyframe

button.

How to create a keyframe and duplicate the drawing at the same time
1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a
keyframe.

2. Do one of the following:
l

From the top menu, select Insert > Keyframe and Duplicate Drawing.

l

Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

l

Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the
original drawing.

How to add a Position keyframe
1. In the Timeline view, select the cell on which you want to add a position keyframe.

2. From the top menu, select Insert > Position Keyframe.
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Creating Keyframes in the Function View
You can add keyframe directly on the graph using the Function view.

How to add or delete keyframes in the Function editor
1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand

button or

press Alt + F.

2. Double-click on the parameter layer name to open the Function editor window or click once on the
parameter layer to display it in the Function view's left sidebar. If you are using the Function view,
you must click on the function name from the sidebar list to view it in the graph display region.
3. In the Function editor, do one of the following:
l

In the graph section, click on the frame where you want to make changes.

l

In the Frame field, enter the frame number.

In the graph display area, the red playhead moves to that frame number.
4. In the Function editor, click the Add Keyframe
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5. Click on the newly created keyframe and drag it up to increase the value of the function or down to
decrease the value. Depending on the selected function, this could increase or decrease the width of
the object (scale_x) or change the object's vertical position (position_y). Pull on the handles to create
non-linear transition speeds between keyframes.
6. If you do not like the changes you just made, select and delete the new keyframe by pressing Del or
clicking the and Delete keyframe

button.

You can delete an existing keyframe by using the same process.
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Creating Keyframes in the Xsheet View
If you prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.
To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view
and then select the layer you want to modify. If you double-click on a function column's header, you will display
the corresponding function curve in the Function editor.

How to add a keyframe in the Xsheet view
1. In the Xsheet view, click the Expand button located on the right side of the main section to show the
Functions section.

1. In the Timeline view, select the layer that contains the parameters to modify.
The columns appear in the Xsheet view if function curves were previously created by adding
keyframes in the Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

2. In the Xsheet view, go to the function column on which you want to add a keyframe.
3. Double-click on the cell on which you want to add a keyframe and type a numeric value.
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4. Press Enter/Return to continue to the next cell.
5. Press Esc to exit the typing mode.

How to convert a cell into a keyframe
1. In the Xsheet view, go to the function column on which you want to add a keyframe.
2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press F6.

4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in
Selection or press F7.
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Deleting Keyframes
T-HFND-009-007
You can delete keyframes independently from drawing exposure.
NOTE
If you select a keyframe in the Timeline view and press the Del key, you will also delete the drawing
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to delete a keyframe
1. In the Timeline view, select a keyframe and do one of the following:
l

Right-click and select Delete Keyframes.

l

In the Timeline view menu, select Motion > Delete Keyframes.

l

From the top menu, select Animation > Delete Keyframe.

l

Press F7.

l

In the Timeline View toolbar, click on the Delete Keyframes

l

Use the Transform

button.

tool to select a keyframe to delete from the trajectory in the

Camera view and press Del.
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Animating with Keyframes
T-ANIMCO-001-005
You can animate a layer or a peg by creating keyframes and moving your drawings in the Camera view.

How to animate a layer or a peg
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. If your layer has a parent peg and you want to animate the drawing layer directly, make sure the
Peg Selection Mode

is disabled in the Tool Properties view.

3. In the Tools toolbar, enable the Animate

mode. This allows the Transform tool to affect the

position and size of a layer at the current keyframe only, whereas it would otherwise affect the
layer's position and size throughout the whole scene.
4. In the Timeline view, go to the first frame.

5. From the top menu, select Animation and make sure the Stop-Motion Keyframe option is
unchecked. This will make it so Harmony automatically creates the animation between the
animation keyframes you create.
6. Select the cell where you want to create your first keyframe
7. To create your first keyframe, do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is created on the first frame of the Timeline view.

8. In the Camera view, select the element to animate and move it to its first position.
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9. In the Timeline view, go to the frame on which you want to set the second position.

10. Select the cell where you want to create your second keyframe. right-click on the selection and
select Insert Keyframe.
The second keyframe appears in the Timeline view, along with a line going from your first keyframe
to your second keyframe. This indicates that every frame in-between will be animated by Harmony.

11. In the Camera view, move the element to its second position.

12. In the Timeline view, select the first frame to rewind to the beginning of your animation.
13. In the Playback toolbar, click on the Play

button to preview your animation.
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NOTE
If your scene has 3D objects, or if you animate layers on the Z axis, you may want to preview
your animations from the Top, Side or Perspective views during playback. However, playback
is disabled by default in those view. To enable them, from the top menu, select Play > Enable
Playback > Top View, Side View or Perspective View.
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Changing Keyframe Values
Once a keyframe is added, beside moving the image in the Camera view, you can change its value by typing it
in the Timeline and Function views.

How to change the keyframe values in the Timeline view
1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand

button or

press Alt + F.

2. Select the parameter for which you want to create a function curve.
3. Place the cursor over the blue number value of the parameter and do one of the following:
l

Wait until the cursor changes to a white hand with a two-way arrow and then drag
the hand left to decrease the value or right to increase the value.

l

Double-click on the blue number and enter a value in the field.

How to change a keyframe value in the Function editor
1. In the Timeline view, open the peg element's parameters by clicking the Plus
layer's name.
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2. Double-click on the parameter layer name to open the Editor window or click once on the parameter
layer to display it in the Function view.
3. In the graph of the Function editor, select a white keyframe.
The keyframe turns red and displays a pointed yellow handle.
4. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.

5. Press Enter/Return or click the Play

button to view the changes made in the Camera view.

6. Keep adjusting the values until you are satisfied with the results.
7. Click Close.
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Switching Keyframe Types
T-ANIMCO-001-006
You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

How to switch between motion and stop-motion in the Timeline view
1. On the right side of the Timeline view, select one or more keyframes to modify.

2. Switch between motion and stop-motion by doing one of the following:
l

Right-click on the selected keyframes and select Set Motion Keyframes or Set StopMotion Keyframes.

l

Press Ctrl + K (Windows/Linux) or ⌘ + K (macOS) for motion keyframes and Ctrl + L
(Windows/Linux) or ⌘ + L (macOS) for stop-motion keyframes.

l

In the Timeline View toolbar, click the Motion Keyframe
button.

or Stop-Motion Keyframe

How to switch between motion and stop-motion in the Coordinates and Control Points
view
1. Using the Transform

tool, in the visible path in the Camera or Timeline view, select the keyframe

to convert.
2. In the Coordinates and Control Point view, select/deselect the Stop-Motion Keyframe option.

How to switch between motion and stop-motion keyframes in the Function view
1. Open the Function view.
2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.
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The Layer Properties window opens.

3. Do one of the following:
l

In the Transformation tab, click the Function Editor

l

In the Timeline view, click the Expand Function

button.
button or press Alt + F and double-

click on the function to edit.

4. On the function curve, select one or more keyframes to modify.
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5. Select or deselect the Stop-motion Keyframe

button to set a stop-motion or motion keyframe.
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Changing Stop-motion Keyframe Colour
To easily identify stop-motion keyframes in the Timeline view, you can customize the colour In the Preferences
dialog box.

How to set the stop-motion keyframe colour
1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘ + U (macOS).
2. Select the General tab.
3. In the Colours section, click Edit Colours.
4. In the Colours dialog box, select the Xsheet and Timeline tab.
5. In the Timeline section, click the Stop Motion Keyframe swatch.
6. In the Select Colour window, select a new colour and close the windows.
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Jumping to Keyframes
You can jump between the selected layer's keyframes in the Timeline view.

How to jump to keyframes
1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip
through.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press
semicolon (;) and single quote (').
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About Controls
T-HFND-009-010
Camera moves and motion paths can become quite advanced, especially with moves through 3D space.
Harmony provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D
perspective.
You can display the trajectory of a motion path when you select an object from any view it can be selected in.
A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both
keyframes and control points. Both can be used to shape a path; each have their own behaviour, however only
keyframes appear in the Timeline view.
l

Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in
time.

l

Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory.
There are no velocity handles available on a control point. The velocity segments are set between
keyframes only, making curves and trajectories much smoother. Control points can only be added on a
3D path.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-intime using the Coordinates and Control Points view.
Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear
in the Coordinates and Control Point view. You can also see the same information in the Coordinates and
Control Points toolbar.
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You can adjust these parameters by selecting the control points and keyframes in the Camera, Top and Side
views with the Transform

tool.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.
Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.
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Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.
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Displaying Controls
T-HFND-009-011
You can display a layer's controls to adjust a trajectory or other parameters such as a gradient's position or
deformation settings.

How to display the layer’s controls
1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want
to display is selected in the Timeline view.

2. From the top menu, select View > Show > Control or press Shift + F11 or in the Camera view
toolbar, click on the Show Control

button.

NOTE
If nothing appears in the Camera view, you may not have animated or selected
the layer.
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Adding Control Points
T-HFND-009-012
You can add control points on 3D Path trajectories. You need to display the layer's controls in the Camera view.

How to add a control point on a trajectory
1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.
2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top
menu or press Shift + F11.
The trajectory appears in the Camera, Top, Side and Perspective views.

3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point
and press P once. If you hold the key down, control points will be added continuously until you
release the key.
A control point is added to the trajectory.

1013

Harmony 15.0 Premium User Guide

Toggling Point Types
You can convert a control point into a keyframe and a keyframe into a control point. The position and other
values will remain in both cases, only the frame will change. A control point is not locked in time.

How to switch between keyframe and control point
1. In the Camera view, use the Transform

tool select a point to convert.

2. To convert the point:
l

In the Coordinates and Control Points view, select or deselect the Locked in Time
option.

l

From the top menu, select Animation > Lock in Time.

l

In the Function view or Function Editor, select the keyframe to convert and click the
Lock in Time

l

button.

Press Alt + L.
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Adjusting Tension, Bias, and Continuity
You can adjust the shape of the curve passing through a point by modifying the bias, tension, and continuity
settings. You can also set preferred settings as default.

How to adjust the Continuity, Tension and Bias parameters
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Timeline view, select the layer that contains the parameters you want to adjust.
3. From the top menu, select View > Show > Control or press Shift + F11 to display the trajectory.
4. In the Camera view, select a control point or keyframe.

5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

How to adjust the control point preferences
1. From the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences
(macOS).
The Preferences dialog box opens.
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2. Select the Camera tab and adjust the parameters in the Control Points section.
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Converting Angled and Curved Corners
When you select a control point on a path, you can switch between a rounded or angled corner by using the
Linear/Curve command.

How convert an angled or curved corner
1. In the Timeline view, double-click the layer that contains the point you want to convert.
The Layer Properties window opens.
2. On the Transformation tab, select the 3D Path option.
3. In the Tools toolbar, select the Transform

tool or press Shift + T.

4. In the Camera view, select the point to convert.
5. From the top menu, select Animation > Linear Motion.
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Offsetting Trajectories
By offsetting a trajectory, you Lets you reposition the visual trajectory without offsetting or modifying your
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location
than the centre of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you
have several elements attached to one trajectory, you might want your trajectory to be at a different location to
represent the group's motion better.

How to offset a trajectory
1. In the Animation Tools toolbar, select the Spline Offset

tool or press Alt + 8.

2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.
3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the
trajectory, any transformation done using the Spline Offset tool will be ignored.

4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes,
but also on the Z-axis using the Top and Side views.
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About Functions
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally
create the ones you need to avoid being overloaded with too many functions you might not use.
When you select an element in the Camera view and move it around, it will automatically create the
corresponding function curves. If you need to create certain functions manually, you can always do it through
the Layer Properties view or editor. You can then share it with other layer parameters or set keyframes directly
on the function curve instead of doing it in the Timeline or Camera view.
You can also link a layer's parameter to an existing function curve or attach several parameters to the same
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but
this may produce undesirable results and even induce a feeling of motion sickness as you watch the final
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore
the angle, scale and skew.
By default, all function curves can only be used and modified using their original parameter. If you want another
layer or parameter to use the same function curve, you must share it.
There are two ways to share a function:
l

Share Functions command

l

Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:
Parameter

Description

Create 3D Path

Creates a new 3D Path Column set

Create Bezier

Creates a new Bezier curve

Create Ease

Creates a new Ease curve

Local

Disconnects the parameter from any function and changes it to shared.

3D Path

Displays the list of every shared 3D Path function available

Bezier

Displays the list of every shared Bezier curve available

Ease

Displays the list of every shared Ease curve available

Velobased

Displays the list of every shared velocity based curve available
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Expression

Displays the list of every shared Expression function available

3D Rotation

Displays the list of every shared 3D Rotation function available

Connected

Displays the list of every shared connected function curve

Unconnected

Displays the list of every shared unconnected function curve

All

Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have
two or more parameters following the same function.
Depending on your favourite working method, you can create different types of function curves to suit your
needs, including:
l

Ease function

l

Bezier function

l

Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an
Ease or Bezier function.
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These function editors present different ways of editing the values over time. The shape of the created graph
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is
largely based on your working preference.
With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls.
You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you
do this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a
Velobased function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an
element.

You can convert Ease and Bezier function so you can edit them using the controls offered by that type of
function.
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Creating Functions
You can create function curves in several different ways. You cannot create function curves directly in the
Xsheet view. You must do this in the Layer Properties window or the Timeline view.

How to create the function curve in the Timeline view
1. In the Timeline view, expand the layer's parameters.
2. Click the Function button and, in the drop-down menu, select Create Bezier or Create Ease.

How to create function curves using the Layer Properties view
1. In the Timeline view, double-click on the layer you want to create function curves for.
The Layer Properties Editor opens.
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2. In the Transformation tab, click the Function Arrow button beside the local function information.
3. Create a 3D Path, Bezier, Ease or Velobased curve. You can also create an Expression column—see
About Expression Columns on page 1059.

You can click the Function

button to open the Function editor.
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Converting Functions
You can duplicate the functions in a column and send them to another column in different ways.

How to convert Ease and Bezier functions
1. In the Xsheet view, show the function columns.
2. In the Xsheet view, click the Expand button located on the right side of the main section to show
the Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.

3. On the right side of the Functions section, click the Expand button to display the Column List
section.

4. In the Timeline view, click the layer that contains you function columns you want to display.

5. In the Xsheet view, right-click on the column header, select Convert and one of the following:
l

Convert the Column: The values of multiple effects may be linked to the original
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column. When you use the Convert the Column command, all links to the original
column will transfer to the new converted column.
l

Create a New Column and Update Links: Creates a new function from the original. All
links to the original column will transfer to the new column. The original function
column will remain in the exposure sheet in case you decide you want to switch back
to it.

l

Create a New Unused Column: Creates a new column based on the values in the
original column and leaves all links pointing to the original column. You can use this
command to experiment with various functions and then link effect values to the new
function curve column.
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Sharing Functions
You can connect two or more functions to a shared function. If that shared function is modified, then the linked
functions will vary accordingly.

How to share a function using the Layer Properties editor
1. In the Timeline view, double-click on the layer that contains the function to share.

The Layer Properties window displays.
2. In the Transformation tab, click the Arrow button beside the function you want to share and select
Local.

The function is shared with the other layers and parameters.
Shared functions are visible in the main section of the Xsheet view.
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3. From the same menu in which you chose the Bezier option (in our example), select the function you
just shared and attach it to your parameter.

4. In the Timeline view, open the Layer Properties editor of the other layer that contains the
parameters you want to link to the shared function.
5. In the Layer Properties editor or view, attach the parameter to the shared function the same way
you did for the first layer.
The two parameters are both linked to the same function curve and follow the same path. If you
modify the curve, both parameters will update.
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How to share a function using the Share Functions command
1. In the Timeline view, select the function layer to share.

2. Right-click and select Share Functions.
The function is shared with the other layers and parameters.
Shared functions are visible in the main section of the Xsheet view.

3. In the Timeline view, double-click on the layer that contains the parameters you want to link to the
shared function.
The Layer Properties Editor opens.
4. In the Transformation tab, click the Function Arrow

button beside the function you want to link

to the function column.
5. From the menu, select the function you just shared from the 3D Path, Bezier, Ease, Velobased,
Expression, Connected, Unconnected, or All menu and attach it to your parameter.
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The two parameters are both linked to the same function curve and should follow the same path. If
you modify the curve, both parameters will update.
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Linking Functions
You can give the same series of motions that you created for one layer to another. These motions may include
moving, rotating, scaling and skewing. An example would be a car tire. You could animate the rotation of one
tire and then link that rotation function to another tire, so that they both rotate together. The tire may also
move up and down if it is driving along a bumpy road. This would mean that you would have to copy the x and
y-axis position functions as well.
Linking motion works with many layer types, including drawing, peg or 3D subnode.
In the example below, the rotation from a peg will be copied onto a drawing layer.

How to link the motion from one element to another
1. Open the Layer Properties of the element whose motion you would like to copy. You can do this is in
one of two ways:
l

In the Timeline view, double-click on the layer.

l

In the Node view, click on the node's yellow square.

2. In the Layer Properties, locate the parameter you would like to copy, for example Rotation: Angle z,
then open the function menu for that parameter, by clicking on the arrow button at the end of the
row.

3. In the function menu, select Copy Function Link.
4. Open the Layer Properties for the second element. You can have the Layer Properties for both
elements open at the same time. If you plan to perform multiple copy-pastes, it may be a good idea
to keep them both open.
5. Verify that the motion types are the same for both elements. For example, if the Position type for
your first element is set to Separate, be sure that the Position type for your second element is set to
the same.
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6. In the second element's Layer Properties, open the function menu for the same parameter, for
example Rotation: Angle z.

7. In the function menu, select Paste Function Link.
Notice in the parameter's function field that the copied motion function appears, including the name
of element that the function was copied from.
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In the Timeline view, all the keyframes relating to that motion appear in the Timeline.

8. In the Camera view, slide the red playhead back and forth to view the two linked objects.
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9. Repeat steps 2-8 for any other motion that you would like linked.
Simply deleting the keyframes from an element that was linked to another does not break the link between the
two objects. You must clear the function field for all linked parameters in the Layer Properties of the linked
element.

How to unlink the motion between two elements
1. Open the Layer Properties of the element which contains linked functions.
2. Open the function menu for a parameter with a linked motion function and select Local.
The property field is reset to 0.
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About Copying Motions
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them
and even copy them.
As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want
to paste the drawings or just the keys or maybe everything. There are different paste options available in the
Timeline view which give you maximum flexibility when reusing and pasting.
Note that these modes also apply when you drag instead of copying and pasting.
There are three different modes for pasting your selection:
l

Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

l

Paste Mode: Keyframes Only: Pastes only the keyframes.

l

Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when moving
your drawing's timing, you can use the Paste Special feature to only move selected keyframes.
You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and
drawings.
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the
Paste Reverse command to completely reverse the flow of your animation.
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Using Timeline Paste Modes
Use can copy and paste or drag and drop keyframes and drawings in the Timeline view using various modes.

How to paste a selection using different modes
1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline toolbar, click the desired Paste

mode button.

3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or
⌘ + C (macOS).
4. In the Timeline view's right side, select the cell on which you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline or press Ctrl + V (Windows/Linux) or ⌘ + V (macOS).
Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only
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Paste Mode: Exposures Only

1037

Harmony 15.0 Premium User Guide

Using Paste Special
You can copy drawing exposures and keyframes and paste only a portion of your selection using Paste Special.

How to copy and paste a motion using Paste Special
1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go
to step 3.

2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or
⌘ + C (macOS).
3. Edit your selection by doing the following:
l

To paste the selection, in the Timeline view, select the first cell on which you want to
paste your keyframes and from the top menu, select Edit > Paste Special or press Ctrl
+ B (Windows/Linux) or ⌘ + B (macOS).

l

To move the selection, in the Timeline view, drag the selection and hold down Alt.
Drop the selection where you need it and release the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters.
5. Click OK.
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Cycling Animations
You can copy and cycle a section of your animation or your entire animation.

How to cycle an animation
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.
2. From the top menu, select Edit > Copy Cells from the Xsheet/Timeline.
3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘ + / (macOS).
The Paste Cycle dialog box opens.

5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.
6. In the Cycle Type, select the type of cycle to paste.

l

Normal (forward): Pastes your selection as it is, starting with the first cell and ending
with the last.

l

Reverse: Pastes your selection reversed, starting with the last cell and ending with
the first.

l

Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going
to the last one and ending with the first cell.
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l

Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last
cell, going to the first one and ending with the last cell.
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Pasting Reverse Motions
You can paste your animation reversed from its original flow.

How to reverse the animation flow
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.
4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘ + . (macOS).
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About Velocity
T-ANIMCO-001-009
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters
script and set the amount.
The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle
and left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them
to adjust the ease in and ease out, or type values in the fields.
You can reshape the velocity function using Bezier controls.

You can also reshape the velocity function using Ease controls.
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If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected
keyframes in the same frame.
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Displaying Velocity Curves
You can display a parameter's function curve and adjust the easing with the relevant controls.

How to display the velocity curve
1. In the Timeline view, click the Expand

button on a layer or press Alt + F.

The layer’s functions are displayed.

2. Double-click the desired function. Note that 3D Paths have a specific velocity curve controlling the
X, Y, and Z axis together. You need to click on the Position:Velocity layer.

The Function Editor opens as the Ease Editor or Bezier Editor.
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The editor will not be displayed if the function does not already exist.
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Adjusting Bezier Curve Velocity
You can reshape a Bezier curve velocity using the Function view controls.

How to adjust a Bezier curve velocity
1. In the Function view, select a keyframe.
2. Drag the controls to modify the shape of the curve.
You can reshape the function using the Bézier controls.

3. The Continuity options influence how you can move the handles:
l

Straight: Lets you move the handles together, maintaining the same angle to the
point.

l

Corner: Lets you move the handles independently.

l

Smooth: Lets you move the handles together, maintaining the same distance and
angle to the point.
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Adjusting Ease Curve Velocity
You can reshape an Ease curve velocity using the Function view controls.

How to reshape the function using Ease controls
1. In the Function view, select a keyframe.
You can reshape the function using the Ease controls.

2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the
green line. The ease in slope is indicated in blue.
As you change the values visually, the value in the Ease In field is updated. This value represents the
number of frames in the ease-in.
3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the
green line. The ease-out slope is indicated in red.
As you change the values visually, the value in the Ease Out field is updated. This value represents
the number of frames in the ease-out.
4. To adjust the ease-in or ease-out, drag the handles around the keyframe.
The Continuity options, Corner and Straight, influence how you can move the handles:
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l

Straight: Lets you move the handles together, maintaining the same angle to the
point.

l

Corner: Lets you move the handles independently.
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Creating Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those
two frames.

How to create a step velocity
1. Click the Hold Value Editor

button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:
l

Start: The starting frame for the effect.

l

Stop: The last frame for the effect.

l

Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened)
consistently between keyframes. That is, there is no acceleration in the effect.

How to create a step velocity for multiple parameters
1. Add the Scripting toolbar to your interface:
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l

Go to the top menu and select Windows > Toolbars > Scripting.

l

right-click on the empty space near the top of the interface and from the quick-access menu
selecting Scripting.

l

right-click on the empty space near the top of a view and from the quick-access menu
selecting Scripting.

2. In the Scripting toolbar, click on the Manage Scripts

button to open the Scripts Manager

window.
3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.
The functions associated with that file appear in the Functions section.
4. In the Functions section, select TB_CreateStepsOn.
The Add script to toolbar

button becomes active.

5. Click on the Add script to toolbar
The TB_CreateStepsOn script

button.
button is added to the Scripting toolbar.

6. Click Apply.
7. Click OK.
8. In the Timeline view, select the layer whose parameter values you would like to hold.
9. In the Scripting toolbar, click on the TB_CreateStepsOn script
The Create Function Step On dialog box appears.
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10. In the Settings section, enter the hold value by changing the number in the Every Number of
Frames field.
11. In the Selection section, enter the first and last frame numbers to define the selection range.
NOTE
The playhead location determines the lowest value you can enter for the first frame,
when defining the selection range. You need to move the playhead to frame one if you
would like to set frame one as the lowest possible starting value.
12. Click OK.
13. In the Timeline view, expand the layer properties of the selected layer by clicking on its plus
button.

14. Double-click on a parameter layer to open its Bezier Editor. If that parameter was animated, the 3
frame hold from frame 20 to 60 was applied.
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15. In the Bezier Editor, click on any of the keyframes to bring up the bezier point handles and use them
to reshape the velocity curve for that parameter.
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This means that multiple parameters can have the same stepped velocity, but have different ease-in
ease-out curves defining that velocity.
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Adjusting Velocity in the Timeline View
If you would rather avoid playing with graphs and function curves, you can adjust the velocity in the Timeline
view.

How to set the ease in the Timeline view
1. In the Timeline view, select a keyframe on one or more layers.

NOTE
Only the first selected keyframe will be considered when using the Set Ease For Multiple
Parameter function. If many keyframes are selected on the same layer, the ease values will be
applied only on the first keyframe and the rest will be ignored.
2. In the Timeline toolbar, select an option from the Set Ease Type menu.

NOTE
TIP: Optimize your workflow by adding the Apply Ease to Selection

button to the Timeline

toolbar. This lets you quickly reapply the ease type without going through the Set Ease Type
menu each time. To add the button to the toolbar, right-click on the toolbar area of the
Timeline view and select Customize.
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Setting Ease on Multiple Parameters
T-HFND-009-013
You can adjust the velocity on multiple parameters at a same frame for consistency.

How to set the ease on multiple parameters
1. In the Timeline view, select a keyframe on one or more layers.

NOTE
Only the first selected keyframe will be considered when using the Set Ease For
Multiple Parameter function. If many keyframes are selected on the same layer,
the ease values will be applied only on the first keyframe and the rest will be
ignored.
2. Do one of the following:
l

In the Timeline view, right-click and select Set Ease For Multiple Parameters.

l

In the Timeline toolbar, click the Set Ease For Multiple Parameters

button.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.
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4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as
Rotation or Scale. Deselect the function types you do not want to affect.
l

Motion: Applies the easing parameters to the selected Position X, Position Y, Position
Z and 3D Path functions.

l

Rotation: Applies the easing parameters to the selected Angle functions.

l

Scale: Applies the easing parameters to the selected Scale functions.

l

Skew: Applies the easing parameters to the selected Skew functions.

l

Morphing: Applies the easing parameters to the selected Morphing Velocity functions.
Note that it applies to the Morphing velocity function found in the Layer Properties
window, not the basic morphing ease in the Tool Properties view.

l

Other: Applies the easing parameters to all the other the selected functions, such as all
functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are
calculated in percentage.
l

In the Left Time Ratio and Right Time Ratio fields, type the percentage value
corresponding to the length of time you want the easing to last. Stay between 0%
and 100%. If you go beyond 100%, your motion will overshoot.

l

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how
strong you want the easing out to be. Stay between 0% and 100%. If you go beyond
100%, your motion will overshoot.

l

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following:
l

Apply/Previous: Applies the easing parameters to the selected keyframes and then
selects the previous keyframe in the timeline.
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l

Apply: Applies the easing parameters to the selected keyframes.

l

Apply/Next: Applies the easing parameters to the selected keyframes and then
selects the next keyframe in the timeline.

l

Close: Close the dialog box. If you did not apply the modifications, they will be
cancelled.
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About Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values in another
function. An expression is a mathematical formula that allows you to manipulate the value in the source function
to create new values for the destination effect.
For example, in a scene with two characters, one is walking across the stage and the other is following the
same path two steps behind. Without expressions, you would have to manually enter the values for the
position of the peg to be one frame behind the original element. However, you can save time by building an
expression that does it for you. Then, if you change the position of the element in the original column, Harmony
automatically updates the Expression columns linked to it.

When you want to create an expression for an effect, you must add an Expression column to the Xsheet view,
build the expression and then link the Expression column to the parameter you want to control.

Writing Expressions
Expressions are based on a JavaScript (JS) program. You can access the full capability of the JS language and
write any type of program, as long as it executes relatively quickly.
The entire JavaScript must be defined within the expression code. There is no common repository of JS
functions and services available to the expression column scripting environment. However, with the Harmony
C++ SDK, you can extend the API of functions available to the expression scripting environment.
If you're working with an old project that contains expressions, they are converted to a JS program. Only simple
expressions are updated. Complex expressions and expressions using non-ported services cannot be
converted. For these type of expressions, you must convert them manually.
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Expression Dialog Box
The Expression dialog box is where you write expressions. It's a simple text editor that can handle incomplete
or invalid JS programs although they will not be evaluated. Harmony can save and load invalid JS programs.
The Expression editor evaluates the current script at the current global frame and reports any errors or returns
the numerical result of the program.

Expression JavaScript Program
An expression JavaScript program can be any valid program. The only requirement is the last statement of the
script must leave a number on the stack. The “return” statement is NOT needed as the script is not a function.

Valid Expression Column JS Program
Example 1
10
This is a simple program returning 10.
Example 2
currentFrame
This is another simple program returning the current frame. The variable “currentFrame” is one of the
predefined variables and services available.
Example 3
value( “MyBezierFunction”, currentFrame - 1 );
A simple expression program that returns the value of the Bezier function “MyBezierFunction” at the previous
frame. If this function does not exist in the scene, the expression column will be blank in the Xsheet. If this
function does exist, the expression column will show the value of that function at the frame.
Example 4

This programs evaluates the Fibonacci series starting at the current frame. The value will be computed up to a
certain frame. After that frame, the program is too complex and will be stopped by the engine before finishing.
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Errors
Programs that take too long to execute, that don't generate a numerical value, or has syntax errors will not be
compiled and will not compute a value. The scripting editor will show the condition that triggers this, but the
Xsheet will display a blank field.

API
To refer to the values in a column, use the column name and frame number. If you do not state the frame
number, then Harmony uses the value of the current frame. You can refer to the frame numbers in the following
ways:
l

currentFrame: Refers to the current frame number.

l

numFrames: Refers to the total number of frames in a scene.

Consider the expression: value ( “peg x”, currentFrame-1)
l

This expression says that the current frame value will be the same as the previous frame value of the
element peg x.

Now consider this expression: value ( “peg_angle”, currentFrame - 2] * 3
l

In this expression, Harmony is to look two frames before the current frame in the column "peg_angle"
and multiply the value by 3 to derive the value for the current frame of the expression column.

Predefined Functions
Most mathematic functions are obvious. They either take an angle or value, or return an angle or value. Angles
are always specified in degrees. If the input argument is not valid, the function will log an error (which is visible
in the script editor) and the Xsheet does not display anything.
The two variants of the function value() are used to get the value of 2D functions at the current frame or the
specified frame. The first argument is always a string that identifies the function. The optional second argument
is the frame to use.
For example: value( “myFavBezier”, currentFrame-1)
Function

Description

sin (angle)

Returns the sinus from the angle specified in degrees.

cos (cosine)

Returns the cosinus from the angle specified in degrees.

tan (angle)

Returns the tangent from the angle specified in degrees.
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asin( v )

Returns the arcs in degrees.

acos( v )

Returns the arccos in degrees.

atan( v )

Returns arctan as an angle in degrees from the first quadrant.

atan2( x, y )

Returns the arc tangent in degrees.

int

Returns the integer value of the “v”. Undefined behaviour for negative number.

ceil( v )

Returns the next integer greater or equal than “v”.

floor( v )

Returns the integer value of v. Remove the fractional part.

abs( v )

Returns the absolute value.

sqrt( v )

Returns the square root for v >= 0.

exp( v )

Returns the “e” exponent v. (see c library exp( f )).

ln( v )

Returns the natural logarithmic of v for v > 0.

ln

Logarithm of a value.

value( columnName)

Value of the function specified by “columnName” at the current frame.

value(columnName,frame)

Value of the function specified by “columnName” at the frame specified by
“frame”.
Indentify the text wrapped by columnName to be renamed whenever the column
named “columnName” is renamed.

column( columnName )

node( nodeName )

column() is a keyword that does nothing at runtime, but helps Harmony track
which references to a function needs to be renamed in the script when a function
is renamed. For example, if you have a function named “B” and this one gets
renamed to “C” through some scripts or by the user, all expression scripts
referencing “B” will automatically be updated to refer to “C” if their call was
wrapped as column( “B” ).
Identifies a node/node that is in the same group as another node which is using
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this expression column.

node( nodeName )

node( nodeName) and node( nodeName ) are two functions that return a proxy to
a node that must be in the same group as another node using that expression
column. For this method to work, the expression must be connected to a node
“A” and the script must refer to a node “B” in the same group as node “A”. The
resulting object is a proxy to a node which cannot be converted to a number. This
proxy object is only usable by an SDK plugin.

numFrames

A constant that represents the number of frames in the current scene.

currentFrame

A constant that represents the current frame (1 based).
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Writing Expressions
The number of expressions you can write is limitless. Find below an example of an expression for an effect.

How to build an expression for an effect
1. In the Xsheet view menu, select Columns > Add Columns or press Shift + C.
The Add Column dialog box opens.

2. In the Name field, type a name for the column.
3. From the Type menu, select Expression and click OK.
4. Double-click on the column's header to open the Expression dialog box.

5. Type an expression in the dialog box.
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NOTE
To address a specific component of a 3D path, the syntax is "Peg x", not "Peg_x".
6. Click OK or Apply to activate the expression.
The cells in the Expression column are filled with values based on the expression you created.

7. To apply the values in the Expression column to an effect, link the Expression column to the
parameter values. In the drawing's layer properties, link the function to the new Expression column.
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About Animation Resources
As you are animating, you might find that you are constantly selecting the same elements from your scene, in
order to progressively move and manipulate them. You can create a preset for almost any selection or group
selection in your scene, in order to speed up the animating process.
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Creating Selection Presets
As you're animating, you might find that you are constantly selecting the same pegs, drawing layers, bezier
points on a deformation envelope, part of a character rig, etc. You can create a preset that automatically selects
any defined element or group of elements.

How to add the Selection Preset script to the Scripting Toolbar
1. Add the Scripting toolbar to your interface:
l

Go to the top menu and select Windows > Toolbars > Scripting.

l

right-click on the empty space near the top of the interface and from the quick-access menu
selecting Scripting.

l

right-click on the empty space near the top of a view and from the quick-access menu
selecting Scripting.

2. In the Scripting toolbar, click on the Manage Scripts

button to open the Scripts Manager

window.
3. In the Scripts Manager, in the Files section, select the file TB_SelectionPreset.js.
The functions associated with that file appear in the Functions section.
4. In the Functions section, select TB_SelectionPreset.
The Add script to toolbar

button becomes active.

5. Click on the Add script to toolbar

button.
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The TB_SelectionPreset script

button is added to the Scripting toolbar.

6. Click Apply.
7. Click OK.

How to create a preset from a selection
1. In the Scripting toolbar, click on the TB_SelectionPreset

button.

The Selection Presets dialog window opens.
2. In your scene, select an individual element or group of elements. This can include, but is not limited
to: pegs, drawing layers, deformation controls, part of a character (such as the entire rig of the head
from the Node view).
3. In the Selection Presets window, click on the plus button.
The Save Selection As Preset dialog box opens.

4. Enter a name for the new selection preset in the field provided.
5. Click OK.
The new selection preset name appears in the Selection Presets window.
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How to use a Selection Preset
1. In the Scripting toolbar, click on the TB_SelectionPreset

button.

The Selection Presets window opens.
2. Double-click in the Group field next to the Selection Preset you wish to use OR select a preset from
the Name column and click on the Apply To Selection button.

The defined selection is selected.
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Chapter 11: Deformations
T-RIG-007-001
Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations
act as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character
made out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. This also
allows you to take an area in a single bitmap image and create animation by distortion.
A deformation skeleton is composed of deformation nodes, which are the various pieces (here represented as
layers or nodes) required to articulate or deform your drawings, such as a series of bones, curves or game bones.
NOTE
It's important to note that the deformation feature was completely rebuilt in Harmony 12 to simplify
the process and no longer works like it was in the previous releases. If you would like to convert
characters with deformation chains created in Harmony 11 or before, you can use the TB_
ConvertLegacyDeformation.js script to do so—see About Legacy Deformations on page
1156.
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About Deformation Types
The 4 types of deformers are: Bone, Game Bone, Curve and Envelope. Each type has its own advantages and
limitations and need to be rigged and handled in different ways.
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About Bone Deformations
T-RIG-007-002
The Bone deformation allows you to create a bone-like structure in which each part is solid, but with
articulations that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or
other parts that can be articulated such as torsos or fingers. For example, a Bone deformation can be used to
articulate an arm that is made of a single drawing, so that the upper arm and forearm can be moved
independently, without having to draw the upper arm and the forearm on different layers. Harmony will
deform the drawing to make it look articulated. The different parts of a Bone deformation can be rotated
around their joint, extended and shortened, giving you the same capabilities as animating articulations on
different layers, without having to worry about parts detaching, pivot points, or clipping outlines.
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About Game Bone Deformations
T-RIG-007-003
The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like
structure in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a
character's limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For
example, a Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that
the upper arm and forearm can be moved independently, without having to draw the upper arm and the
forearm on different layers. Harmony will deform the drawing to make it look articulated. The different parts of
a Game Bone deformation can be rotated around their joint, extended and shortened, giving you the same
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot
points, or clipping outlines.
The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines
such as Unity. Hence, it is usually only used for game development and not in animated productions. The
differences between the Bone and Game Bone deformations are that Game Bone deformations do not have
Bias and Region of Influence properties. The articulation folds also look slightly more rounded.
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About Curve Deformations
T-RIG-007-004
The Curve deformation allows you to deform parts of a character using a vector curve. By manipulating the
curve's points and their bezier handles, you can change the curve's direction, shape and length, and Harmony
will deform the drawing to match the curve's shape. Curve deformations are mostly used to animate elements
that don't have joints, such as hair bangs or facial features, or body parts with so many joints that they seem
curved, such the torso. They can also be used to animate the limbs of characters in a rubber hose style of
animation, where arms and legs are bent in curves.
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About Envelope Deformations
T-RIG-007-005
The Envelope deformation allows you to deform an image using Bezier handles located all around the contour
of the shape. Envelope deformation chains are composed of Curve deformation nodes. It is regularly used to
deform shapes, such as hair, cloak, shoulder shape, head shape and so on. You can use the Envelope
deformation to deform a drawing so it looks like it changes from a profile view to a front view to create head
and character rotations using only one set of drawings.

The main differences between the Curve and Envelope deformers is that the Envelope chain can be closed by
connecting the last Curve deformation node to the initial Offset point. Once connected, the Offset point no
longer repositions the entire chain, only its own control point.
NOTE
It's not recommended to use the Envelope deformations on bitmap images and textures.
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About Chain Creation
Using the Rigging tool, you can quickly create a basic deformation rig.
As you create your chains, the controls will be showing. However, whenever you close your project, the
deformation controls display is turned off. When you reopen the project, you can display all controls or only
some of them—see Displaying Selected Deformation Controls on page 1119.
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Selecting Elements for Deformation
Deformation groups are added to your scene's hierarchy in different places, depending on whether a drawing
or peg element is selected.

How to select the element on which to create a deformer
A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging
tool, it is automatically created as a parent of the selected layer, and will affect the selected layer and all its
children. Hence, it's important to select the right layer before attempting to create a deformer.
For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you
could rig the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and
the hand is the forearm's child. Then, if you create your deformer on the upper arm, it will be created as a
parent of the upper arm, and will hence affect the whole arm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you
create a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's
children. This is because a peg is likely to be more useful over a deformer than under. If you move layers
that are under a deformer, they will exit the intended deformation zone, and may appear severely warped
and distorted. Hence, it's better to create deformations under pegs as much as possible, and pegs under
deformers should only be animated if the deformer is left untouched. Since the deformer will be created as
a parent of all the peg's children, it will affect all the layers under the peg.
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Creating Bone Deformation Chains
You can easily create bone deformation chains on parts of your rig using the Rigging tool.

How to create a Bone deformation chain
1. Make sure the right element for the creation of your deformation chain is selected—see Selecting
Elements for Deformation on page 1078.
2. Once your element is selected, select the
3. In the Tool Properties view, click on the

Rigging tool in the Deformation toolbar
Bone button to enable Bone mode.

4. In the Tool Properties view, enable the Automatically create a group when creating a new
deformation rig

option so that your deformation chains are created inside groups. Every point in

a deformation chain is an individual layer, so creating deformers with this option disabled is liable to
clutter your Timeline and Node view.
5. Place the cursor at the root of your drawing or drawing hierarchy, click once and release. For
example, if you're creating a deformer for a whole arm, click on the shoulder joint.

6. Move your cursor at the location where you want your first bone to finish and your second bone to
start, and click again. An articulation control point will automatically be inserted between each bone
you create.

7. Move your cursor where you want the next articulation to be and click to create the next point.
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Observe that, as you create a new point, the previous point now has a circle around it. This is the
radius of the articulation, which allows you to determine how much of the drawing should be part of
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius
setting.
8. Click and hold the previous articulation's radius manipulator and adjust the articulation's radius so
that it covers the limb.

9. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in
the right order going from the root to the extremity.

NOTE
It is possible to reuse a deformation group on another drawing, for example on a symmetrical body
part, such as with the right and left arms. To do this, you need to rig the way you would for a multipose character, using a Transformation Switch—see Creating Main Deformation Chains for Multipose Rigs on page 1147, as well as the Associate Parent Transformation Switch for Selected
Elements button—see Reusing Deformation Groups for Multi-pose Rigs on page 1149.
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Creating Game Bone Deformation Chains
If you are working on a character that is meant to be exported as a game asset for use in Unity, and you want to
use deformations to animate your character, you must use Game Bone deformations. These deformations
replicate the type of deformation supported by Unity and can be exported to Unity as they are, without having
to bake the deformations into drawings first.

How to create a Game Bone deformation chain
1. Make sure the right element for the creation of your deformation chain is selected—see Selecting
Elements for Deformation on page 1078.
2. Once your element is selected, select the
3. In the Tool Properties view, click on

Rigging tool in the Deformation toolbar

Game Bone to enable Game Bone mode.

4. In the Tool Properties view, enable the Automatically create a group when creating a new
deformation rig

option so that your deformation chains are created inside groups. Every point in

a deformation chain is an individual layer, so creating deformers with this option disabled is liable to
clutter your Timeline and Node view.
5. Place the cursor at the root of your drawing or drawing hierarchy, click once and release. For
example, if you're creating a deformer for a whole arm, click on the shoulder joint.

6. Move your cursor at the location where you want your first bone to finish and your second bone to
start, and click again. An articulation control point will automatically be inserted between each bone
you create.

7. Move your cursor where you want the next articulation to be and click to create the next point.
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Observe that, as you create a new point, the previous point now has a circle around it. This is the
radius of the articulation, which allows you to determine how much of the drawing should be part of
the articulation. Every point in a bone deformer, except for the first and the last one, has a radius
setting.
8. Click and hold the previous articulation's radius manipulator and adjust the articulation's radius so
that it covers the limb.

9. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in
the right order going from the root to the extremity.
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Creating Curve Deformation Chains
Depending on your character and the style of animation you want to achieve, sometimes it is better to use
Curve Deformers, instead of Bones, to rig your character.

How to create a Curve deformer
1. Once your element is selected, select the Rigging
2. In the Tool Properties view, enable the Curve

tool in the Deformation toolbar.
mode.

3. In the Tool Properties view, enable the Automatically create a group when creating a new
deformation rig

option so that your deformation chains are created inside groups. Every point in

a deformation chain is an individual layer, so creating deformers with this option disabled is liable to
clutter your Timeline and Node view.
4. Place the cursor at the root of your drawing or drawing hierarchy. For example, if you're creating a
deformer for a whole arm, place your cursor over the shoulder joint.
5. Press and hold the mouse button to create the point, then drag to towards the direction where you
want your curve to bend to set the position of this curve's bezier handle, just as you would when
drawing a curve using the Polyline tool—see Creating Vector Shapes with the Polyline Tool on page
244.

6. Click again at the location where you want the curve to end and drag backwards to extend the
second bezier handle.

7. As you go, you can use your mouse cursor to reposition the existing bezier handles as needed. You
can hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier
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on the opposite site of the point.
8. Repeat this process until you have finished building the Curve chain.

NOTE
It is possible to reuse a deformation group on another drawing, for example on a symmetrical body
part, such as with the right and left arms. To do this, you need to rig the way you would for a multipose character, using a Transformation Switch—see Creating Main Deformation Chains for Multipose Rigs on page 1147, as well as the Associate Parent Transformation Switch for Selected
Elements button—see Reusing Deformation Groups for Multi-pose Rigs on page 1149.
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Creating Envelope Deformation Rigs
Before adding deformations, you might want to use a default type of region of influence. You can set these
parameters in the Rigging tool's properties—see the Reference guide .

How to create an Envelope deformation rig
1. Once your element is selected, select the Rigging

tool in the Deformation toolbar.

2. In the Tool Properties view, enable the Envelope

mode.

3. In the Tool Properties view, enable the Automatically create a group when creating a new
deformation rig

option so that your deformation chains are created inside groups. Every point in

a deformation chain is an individual layer, so creating deformers with this option disabled is liable to
clutter your Timeline and Node view.
4. Place the cursor where you want to start creating your envelope.
5. Press and hold the mouse button to create the point, then drag to towards the direction where you
want your curve to bend to set the position of this curve's bezier handle, just as you would when
drawing a curve using the Polyline tool—see Creating Vector Shapes with the Polyline Tool on page
244.

6. Working as you would when building a Curve deformer, continue adding control points around your
shape. You can place your control points slightly outside of your contour line.
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7. As you go, you can use your mouse cursor to reposition the existing bezier handles as needed. You
can hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier
on the opposite site of the point.
8. When you're ready to close Envelope deformer, hold down Alt and click on the first point of your
deformation chain.

NOTE
It's not recommended to use the Envelope deformers on bitmap images and textures.
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Creating a Split Deformation Chain
It is possible to create a deformation chain that splits into multiple branches, allowing to rig complex drawings
with multiple extremities using a single deformation chain.
When creating a split deformation chain, a Deformation Composite node is automatically added to your rig.
This deformation composite connects all the branches of the split deformation chain to the drawing it deforms.
You can see which deformation nodes are connected to the Deformation Composite in the Node view.

How to create a split deformation chain
1. Select the drawing layer or the deformation chain to which you want to add a branch.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. Select the Rigging

tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the
deformation. A red chain indicates that you're modifying the rig.
4. In the deformation chain, select the point from which you want the new deformation branch to
start.
5. Place the cursor where you want your new branch's first point to be and click. A new chain is
created.
6. Create the remainder of your chain's points as you would create a regular deformation.
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NOTE
When using the Rigging tool, you can select which existing deformation point you want the next
deformation point you create to branch from at any time by selecting a point in the Camera view.
When you create a deformation point, it is always linked to the currently selected point, if any.
Creating a point automatically selects it, which is why deformations are built in a single chain by
default.
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Automatically Grouping Deformation Nodes
In a deformation chain, each deformation point is its own layer in the Timeline view and its own Node in the
Node view. This can add a lot of clutter to a character rig that uses deformers. Harmony can automatically
create deformation chains inside groups to keep your scene structure tidy and organized.

How to automatically group deformation nodes
1. From the Deformation toolbar, click the Rigging

tool.

2. In the Tool Properties view, in the Rig Tool Options section, enable the Automatically Create Group
when Creating a New Deformation Rig

option.

This option automatically creates a deformation group connected to the input port of the selected
element. This group includes all the necessary deformation nodes you created.
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Adding Deformation Nodes
The Node Library view allows you to manually add the nodes necessary to create the deformation skeleton.
Additional nodes such as the Kinematic Output are available to create advanced rigs.

How to add a deformation node
1. In the Node Library view, select the Deformation category.
2. From the Node Library view, select a deformation node and drag it to the Node view. Note that the
Glue, Mesh Warp, Refract, and Turbulence nodes are not directly related to deformation rigging.
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About Rest Position Setting
As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation,
you may need to make adjustments to the deformation chain to better fit your needs.
A deformation rig has a resting position and an animated position. The resting position is the original pose the
character is in when not animated with keyframes. You can always revert your animated character to its resting
position to recover the initial scale, angle, and shape. You can revert the entire character or only certain
deformation chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the
character in production.
You can also set additional parameters in the Layer Properties window—see the Reference guide .
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Setting Rest Positions for Bone and Game Bones
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0
point for all the transformations that will be made to the drawing when animating. The resting position is also
where we can see what parts of the drawing are assigned to which bone or articulation.

How to set up Bone and Game Bone deformation chains
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. In the Deformation toolbar, click the Rigging

tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red
chain indicates the puppet is in a resting position. Make sure your chain is red.

4. In the Camera view, set up the deformation chain.
l

Rotate the first bone to change the angle of the chain.

1093

Harmony 15.0 Premium User Guide

l

Use the root control to reposition (offset) the entire chain.

l

Use the control points to reposition the articulations. This will elongate, shorten or
change the direction of the bone and offset the subsequent children.
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l

Use the articulation's control (square) to change the size of the articulation. For quality
purposes, it is recommended to have an articulation which fits the diameter of the part
it controls.

5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to
which it is linked. You can also set additional parameters in the Layer Properties window—see the
Reference guide .
6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset
Current Keyframe
7. Use the Transform

button. This will set the current resting position as the current frame one.
tool. For optimal results, make sure the size of the articulation is

approximately the same size as the drawing.

How to add an articulation to an existing Bone or Game Bone deformation
1. Select the drawing layer or the deformation chain to which you want to add an articulation.
2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button to display the deformer controls in the Camera view. This also hides all the deformer
controls that were displayed.
3. Select the Rigging

tool.

The deformation chain turns from green to red. A green chain indicates that you're animating
the deformation. A red chain indicates that you're modifying the rig.
4. Move your cursor over the bone segment, where you want to add an articulation.
5. Hold Alt and click.

1095

Harmony 15.0 Premium User Guide

NOTE
You can only insert new articulations inside Bone and Game Bone deformations.

1096

Chapter 11: Deformations

Setting Rest Positions for Curve Chains
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0
point for all the transformations that will be made to the drawing when animating. The resting position is also
where we can see what parts of the drawing are assigned to which curve.

How to set up a Curve deformation chain
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. In the Deformation toolbar, click the Rigging

tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red
chain indicates the puppet is in a resting position. Make sure your chain is red.

4. In the Camera view, setup the deformation chain.
l

Use the Pivot rotation handle to change the angle of the chain.

l

Use the Pivot centre control point to reposition the entire chain.
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l

Use the curve handles to modify the shape of the curve.

l

Use the curve’s square control points to resize and reposition each segment of the
curve chain.

5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You
can also set additional parameters in the Layer Properties window—see the Reference guide .
6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset
Current Keyframe

button. This will set the current resting position as the current frame one.

7. Test your modifications using the Transform

tool.
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Setting Rest Positions for Envelopes
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0
point for all the transformations that will be made to the drawing when animating. The resting position is also
where we can see what parts of the drawing are assigned to which envelope.

How to set up an Envelope deformation chain
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer controls in the Camera view. This also hides all the deformer controls that were
displayed.
3. In the Deformation toolbar, click the Rigging

tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red
chain indicates the puppet is in a resting position. Make sure your chain is red.

4. In the Camera view, set up the deformation chain.
l

Use the envelope’s square control points to resize and reposition each segment of the
envelope chain.

l

Use the curve handles to modify the shape of the envelope.
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5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You
can also set additional parameters in the Layer Properties window—see the Reference guide .
6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset
Current Keyframe

button. This will set the current resting position as the current frame one.

7. Test your modifications using the Transform

tool.
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About Regions of Influence

To increase the quality of your animation and the accuracy of the deformation effect, you can modify the regions
of influence around the deformation chains. A region of influence is the zone around the deformer within which
art will be influenced by the deformation. The deformer has the power to shape all art contained within the
influence area on its own element or on its children elements.
Zones of influence are different depending on the deformer type and zone type you selected. Note that the
Game Bone deformers do not support regions of influences. Game Bone deformers are set to Infinite and
cannot be changed.
You can find the settings for the zones of influence in the Layer Properties of the Curve, Bone and Envelope
nodes, as well as in the Rigging tool properties.
To understand better the various parameters available in the nodes' layer properties, you should know more
about the following terms:
l

Radius: The radius determines the size of a zone. The radius value is the length from the central point of
the zone to its edge. By increasing the radius value, you increase the size of the area.

l

Transversal: The transversal parameter is related to the width of the zone in relation to the bone. The
transversal value cuts across the bone.
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l

Longitudinal: The longitudinal parameter is related to the length of the zone in relation to the bone. The
longitudinal value is parallel to the bone's length.

NOTE
You can also prevent a child’s element from undergoing its parent deformation by connecting it
through a kinematic output—see About Assembly on page 1113.
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Selecting Region of Influence Types
There are four types of region of influence:
l

Zero: This creates no influence around the deformer.

l

Infinite: This is the default option. The influence goes all the way to the image boundaries or until it
intersects with another zone of influence. When working on a cut-out puppet built on several element
layers, the best choice is to keep the default Infinite option as the zone of influence type. In the following
examples, the zones of influence are explained through deformation chains on a single bitmap image. It's
also recommended to keep the regions of influence to Infinite when using Envelope deformers.

l

Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value.
When you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and
make sure that only the element you want to follow the deformation is included inside the zone.

l

Shaped: This creates a custom region of influence around the deformer that can be adjusted using
control points and Bezier handles. When you set up the boundaries of your Shaped zone of influence,
you should be as accurate as possible and make sure that only the elements that you want to follow the
deformation are included inside the zone.
When you have an Elliptic zone of influence selected in the Node view, you can convert it to a Shaped
zone using the Convert Elliptic Zone of Influence to Shape option.

How to select a region of influence type
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on
page 1119.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
display the deformer of the selected piece.
3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:
l

Zero

l

Infinite

l

Elliptic

l

Shaped
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Setting Up Elliptic Regions of Influence
An elliptical region of influence is suited for regular shapes. Modify its parameters to refine the region
boundaries.

How to set up the Elliptic region of influence
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on
page 1119.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer of the selected piece.
3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius

This defines the size of the fade area around the actual region
of influence's boundaries.
When the Symmetric Ellipse of Influence option is enabled,
this field controls the Left and Right transversal radius values.
When disabled, it controls the size of the left transversal
radius. By default, this value is set to 2.

Transversal Influence Radius
Left

Transversal Influence Radius
Right

When the Symmetric Ellipse of Influence option is enabled,
this field becomes inactive. The Left Transversal radius value
is automatically applied to the Right Transversal. When the
Symmetric Ellipse of Influence option is disabled, it controls
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the size of the Right Transversal radius. By default, this value
is set to 2.

Longitudinal Influence
Radius Begin

When the Symmetric Ellipse of Influence option is enabled,
this field becomes inactive. The End Longitudinal value is
automatically applied to the Begin Longitudinal value. When
the Symmetric Ellipse of Influence option is disabled, it
controls the size of the Begin Longitudinal radius. By default,
this value is set to 0.25.

When the Symmetric Ellipse of Influence option is enabled,

Longitudinal Influence
Radius End

Symmetric Ellipse Influence

this field controls both the Begin and End Longitudinal radius
values. When this option is disabled, it controls the size of
the End Longitudinal radius. By default, this value is set to
0.25.

Enabled by default. The shape of the ellipse will be
symmetrical on both the transversal and longitudinal radii. In
this case, use the Transversal Influence Radius Left field to set
the transversal radius value and use the Longitudinal
Influence Radius End field to set the longitudinal radius value.
The two other fields will remain unused unless you disable
the Symmetric Ellipse Influence option. In that case, you can
set up different radius sizes for the four radii directions.

5. You can also modify the elliptic shape in the Camera view using the Rigging
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l

If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the
Camera view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging
it left/right will modify both longitudinal radius sizes. Dragging it up/down will modify both
transversal radius sizes.

l

If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera
view. Drag the top-corner point left/right to modify the end longitudinal radius size and up/down to
modify the left transversal radius size. Drag the bottom-corner control point left/right to modify the
beginning longitudinal radius size and up/down to modify the right transversal radius size.
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Setting Up Shaped Regions of Influence
A Shaped region of influence is suited for irregular forms. Modify the region parameters to refine the shape's
boundaries.

How to set up the Shaped zone of influence
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on
page 1119.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer of the selected piece.
If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties,
the zone of influence will be square. This square has control points on all four corners and each
control point as two control levers. If you converted an Elliptic zone to a shape, the zone will have
more control points and handles.

3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—see Setting Up Shaped
Regions of Influence on page 1107.
l

In the Camera view, use the Rigging tool and drag a control point to redefine its
position and shape.
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l

Click and drag the control lever handle to modify the corners and redefine the shape.

l

Hold Alt down while dragging the control lever handle to move one handle at a time.
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Converting Elliptic Regions of Influence into Shapes
After you have tried tweaking an elliptical region of influence, you may find that you need to convert the ellipse
into a shape, in order to create a more precise region. Instead of losing all the tweaks you have made, you can
use the elliptical region you have created as a base for a Shaped region of influence.

How to convert an Elliptic zone of influence to a shape
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on
page 1119.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer of the selected piece.

3. In the Tools toolbar, click the Rigging

button.

4. In the Tool Properties view, in the Operations section, click the Convert Elliptic Zone of Influence to
Shape

button.

The zone of influence is automatically converted to a shape. The shape is retained and control points
appear around the zone, so you can customize the shape.
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Modifying Influence Fade Radii
To illustrate the zone of influence Fade Radius and its effect, the bitmap picture will be swapped with a grid
pattern.

There is an area called the deformer Fade which surrounds the region of influence; this is the link between the
strict boundaries of the zone of influence and the surrounding region. This area gradually stretches or squashes
following the deformation. You can change the Fade Radius value to modify the size of this area and the
exponent of the deformation fade effect.

If you built a custom deformation system from the Node Library view and are using a Deformation-Switch node,
you can change the default behaviour so the fading effect is inside the zone of influence instead of outside. This
is explained in this example.

How to modify the Influence Fade radius
1. In the Node or Timeline view, select the deformation group or nodes containing the deformation
chain you want to set the region of influence for—see Displaying Selected Deformation Controls on
page 1119.
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2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button to

display the deformer of the selected piece.

3. In the Layer Properties window, under the Region of Influence section, adjust the Influence Fade
Radius field to modify size of the fading area. The default value is 0.5.
4. If you built a custom node structure, using deformation nodes from previous versions of Harmony
and are using a Deformation-Switch node, you can also set the fade radius there. In the Node view,
select the Deformation-Switch node under the Deformation-Composite node in your deformation
chain.

5. In the Layer Properties window, set the following options:

Parameter

Description

Influence Fade Exponent

Modify the exponent value or type the exact value in the field.
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Fade Inside Zones

l

A value of 1 is similar to a linear curve.

l

A higher value will result in an ease-in type of curve.

l

A lower value will result in an ease-out type of curve.

By default this option is disabled, meaning that the Fade
effect will occur outside the zone of influence. You can enable
this option so the fade effect is inside the zone of influence.
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About Assembly
After you have created all the deformation chains for your character, you will need to assemble these separate
body parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the
deformations down the hierarchy chains.
The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation
chain but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will
follow the movement of the chain just like a regular cut-out character hierarchy piece without being influenced
by the deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the
deformation.
When building a cut-out puppet with deformations, each part controlled by a deformation chain will
automatically rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of
your character will be rigged with a deformation chain, you must set pivot points for the pieces that are not
using deformations—see Setting Permanent Pivots on page 818.

Assembling Guidelines
When assembling a puppet with deformers, there are some guidelines to keep in mind:

1113

Harmony 15.0 Premium User Guide

l

You cannot parent deformers directly because deformers are not designed to be used on other
deformers. To assemble deformers, you must insert a Kinematic Output node.

l

Your peg must be placed above the deformer.
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Assembling in the Timeline View
In order to assemble the rigged parts of your character in the Timeline view, you need to use a Kinematic
Output layer.

How to assemble a puppet using the Kinematic Output node in the Timeline view
1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

2. From the top menu, select Insert > Kinematic Output.
The node appears in the Timeline view as a parent of your selection.

3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you
want your limb or piece to follow. For example, onto the neck deformer if you want your head to
follow it without being deformed or onto the arm deformer if you want your hand to follow.
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l

If your pieces are no longer ordered properly, use the Z-nudging feature to reorder
them—see About Ordering Layers on page 810.

l

It's good practice to rename the Kinematic Output layer to reflect which deformer it is
assigned to as the Timeline view can become very large and layers can be positioned
far apart. Select the Kinematic Output node and in the Layer Properties window,
rename the node. You can also double-click on the layer's name.
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Assembling in the Node View
In order to assemble the rigged parts of your character in the Node view, you need to use a Kinematic Output
node.

How to assemble a puppet using the Kinematic Output node in the Node view
1. In the Node Library view, go to the Deformation section, select the Kinematic Output node and
drag it to the Node view.

2. Pull out a second output connection (bottom port) from the deformer node you want your piece or
limb to follow and connect it to the Kinematic Output port.
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3. Connect the Kinematic Output node to the piece you want to follow the deformer.

‣

If it a good practice to rename the Kinematic Output node to reflect which deformer it is assigned
to as the node structure can become very large and nodes can be positioned far apart. Select the
Kinematic Output node and in the Layer Properties view, rename the node.

‣

You can pull out multiple connections from the same Kinematic Output node if many limbs and
pieces must follow a single deformer. For example, you can use the same Kinematic Output node
for both arms and the neck to follow the body deformer.
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Displaying Selected Deformation Controls
Harmony lets you control which deformers are displayed in the Camera view independently from the current
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view.
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation
controls won't display right away. Likewise, deselecting a deformation chain will not hide its deformation
controls. Before you can animate or modify an existing deformation chain, you must manually display it.

How to display deformation controls
1. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.
NOTE
The Show the Selected Deformation Chain and Hide All Others button will display all
deformation chains that are in the hierarchy of the selection. For example, if the master peg of
a character model is selected, all of its deformation chains will be displayed. Likewise, if multiple
layers linked with different deformation chains are selected, all of their deformation chains will
be displayed.
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Hiding Deformation Controls
If you no longer want to animate or modify deformers, you can hide the deformation controls so that they no
longer clutter the Camera view.

How to hide deformation controls
1. Do one of the following:
l

Click in the negative space of the Camera view, Timeline view or Node view to discard
the current selection, then click on the Show Selected Deformation Chain and Hide All
Others

l

button in the Deformation toolbar.

Select a layer that is not linked to any deformer, then click the Show the Selected
Deformation Chain and Hide All Others

button in the deformation toolbar.

l

In the Camera toolbar, click the Hide All Controls

l

From the top menu, select View > Hide All Controls.

l

Press Shift + C.
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About Deformation Animation
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on
their corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a
deformer, except it requires using the Transform

tool instead of the Rigging tool. When the Transform tool

is selected, deformation controls in the Camera view display in green, which means they are in animation mode,
whereas when the Rigging tool is selected, they display in red, meaning they are in rigging mode.
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Animating Bone and Game Bone Deformers
You can add keyframes to deformers reposition their deformation controls to create animated sequences.

How to animate Bone and Game Bone deformations
1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

2. Select the first frame of the scene.

3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing
one of the following:
l

Right-click on the first frame in the Timeline and select Extend Exposure.

l

Press F5.

4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will
make your model exposed (visible) throughout your whole scene.
5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame
of every layer of the model. This ensures that when you make the second pose later, your first pose
will not be affected. To do this do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is added on the current frame.

6. In the Tools toolbar, select the Transform
7. In the Tools toolbar, enable the Animate

tool or press Shift + T.
mode. This allows the Transform tool to affect the

position and size of a layer at the current keyframe only, whereas it would otherwise affect the
layer's position and size throughout the whole scene.
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8. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.
10. In the Camera view, do the following:
l

Rotate the first bone to rotate the limb.

l

Rotate the subsequent bones to bend the limb.

l

Use the root control to reposition (offset) the entire chain.
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l

Use the control points to reposition the articulations. This will elongate, shorten, or
change the direction of the bone and offset the subsequent children.

11. In the Timeline view, go to the frame on which you want to set the next key pose.
12. Add a keyframe on the current frame by doing one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

13. Transform your deformation chain's points to make your new key pose.
14. Repeat the previous steps until your animation is complete.
NOTE
When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt
key to lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl
(Windows/Linux) or ⌘ (macOS) key to break the articulation off its chain and make it into a
new, separate deformer chain.
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NOTE
You can also manipulate the deformer by typing values directly in the Layer Properties of the
deformation effect nodes.
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Animating Curve Deformers
Add keyframes and reposition the curve deformers to create animated sequences.

How to animate Curve deformations
1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

2. Select the first frame of the scene.

3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing
one of the following:
l

Right-click on the first frame in the Timeline and select Extend Exposure.

l

Press F5.

4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will
make your model exposed (visible) throughout your whole scene.
5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame
of every layer of the model. This ensures that when you make the second pose later, your first pose
will not be affected. To do this do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is added on the current frame.

6. In the Tools toolbar, select the Transform
7. In the Tools toolbar, enable the Animate

tool or press Shift + T.
mode. This allows the Transform tool to affect the

position and size of a layer at the current keyframe only, whereas it would otherwise affect the
layer's position and size throughout the whole scene.
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8. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.
10. In the Camera view, do the following:
l

Click on the centre of the deformation's root pivot and drag it around to reposition the
entire limb.

l

Use the pivot’s square handle to rotate the entire chain.

l

Use the square control point located at the extremity of a bone to stretch or shorten
its length.
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l

Use the curve handles to modify the shape of the curve.

l

A point in an Curve deformation that's between two other points will have two bezier
handles, one of each side. If you rotate one of the bezier handles, the opposite bezier
will follow by default. If you wish to rotate one of the bezier handles independently
from the other, do as follow:
l

Select the handle you want to move independently from the other.
The handle’s colour turns white.

l

Press and hold Alt.

l

Rotate the handle.
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l

By default, transforming a point in a Curve deformation chain does not offset
subsequent points. However, it is possible to offset a curve deformation point along
with all its children:
l

Select the point you want to transform
The point's colour turns white.

l

Press and hold Ctrl (Windows/Linux) or ⌘ (macOS).

l

Either move the deformation point or rotate one of its handles. If you
move the deformation point, subsequent points will be offset
horizontally and vertically. If you rotate one of its handles, subsequent
points will rotate around the deformation point.
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NOTE
You can also manipulate the deformers by typing values directly in the Layer Properties of the
Deformation nodes.
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Animating Envelope Deformers
Add keyframes and reposition the envelope deformers to create animated sequences.

How to animate Envelope deformations
1. In the Timeline view, collapse your character using the Expand/Collapse arrow.

2. Select the first frame of the scene.

3. To ensure your model doesn't disappear after 1 frame, open the Extend Exposure dialog by doing
one of the following:
l

Right-click on the first frame in the Timeline and select Extend Exposure.

l

Press F5.

4. In the Extend Exposure dialog, type in the amount of frames in your scene and confirm. This will
make your model exposed (visible) throughout your whole scene.
5. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame
of every layer of the model. This ensures that when you make the second pose later, your first pose
will not be affected. To do this do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is added on the current frame.

6. In the Tools toolbar, select the Transform
7. In the Tools toolbar, enable the Animate

tool or press Shift + T.
mode. This allows the Transform tool to affect the

position and size of a layer at the current keyframe only, whereas it would otherwise affect the
layer's position and size throughout the whole scene.
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8. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

9. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.
10. In the Camera view, do the following:
l

Move the control points located along the envelope to deform your drawing.

l

Use the envelope's control point handles to modify the drawing`s shape.

l

A point in an Envelope deformation that's between two other points will have two
bezier handles, one of each side. If you rotate one of the bezier handles, the opposite
bezier will follow by default. If you wish to rotate one of the bezier handles
independently from the other, do as follow:
l

Select the handle you want to move independently from the other.
The handle’s colour turns white.

l

Press and hold Alt.
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l

Rotate the handle.

NOTE
You can also manipulate the deformers by typing values directly in the Layer Properties of the
Deformation nodes.
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Animating Multiple Points
When animating curve and envelope deformers, the position of each point is independent from one another. In
situations where you need to animate several deformation points simultaneously, you can select several
deformation points simultaneously. By default, this only allows you to move the selected points laterally.
However, you can also rotate or scale a selection of deformation points by using the Show Manipulator option of
the Deformation toolbar. This option will display a manipulator bounding box with scale and rotation handles,
which works similarly to the one you can use to transform drawing strokes with the Select tool or drawing
layers with the Transform tool.
NOTE
You can only use the deformation manipulator with Curve and Envelope deformers. Because the
position of bone deformers is hierarchical, which means moving one articulation offsets all its
children articulations, it is not possible to animate a selection of multiple bone deformation points.

How to use the deformation manipulator to animate multiple curve or envelope
deformation points
1. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

2. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.

3. Click on one of the deformation points you want to animate to select it.
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4. While holding the Ctrl key, click on each other deformation point that you want to animate to add
them to the selection.

5. In the Deformation toolbar, click on the Show Manipulator

button to enable the deformation

manipulator bounding box.
A manipulator bounding box appears around your selection.

6. If you want to rotate or scale your selection from a specific pivot point, drag and drop the pivot point
of the manipulator to the preferred position.
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7. Do one of the following:
l

If you want to scale your selection, click and drag one of the square scale handles in the
corner of the manipulator.

l

If you want to rotate your selection, position your mouse just outside of the manipulator, near
a corner. When your mouse cursor displays a rotation wheel
manipulator.
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Resetting a Deformer to its Resting Position
If you need to reset the current pose of the entire chain for the entire scene, you have the possibility to reset the
deformation chain to the resting position on the current frame, or on all frames.

How to reset the position of deformers from the Camera view
1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the
resting position.
2. Do one of the following:
l

In the Camera, Timeline or Node view, select one of the drawing elements linked to the
deformation chain you want to display.

l

In the Timeline or Node view, select the deformation group or any part of the deformation
chain you want to display.

3. In the Deformation toolbar, click the Show the Selected Deformation Chain and Hide All Others
button.
The selected deformation controls appear in the Camera view and all the others are hidden.
4. In the Camera view, select the deformation point you want to reset. To select several deformation
point, hold Ctrl and click on each point you want to reset to add them to the selection.
5. In the Deformation toolbar, click on the Reset Current Keyframe

button to reset the position of

the selected chain on the current frame.

How to reset the position of deformers from the Timeline or Node view
1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the
resting position.
2. In the Timeline or Node view, select the deformation group or node you want to reset.
3. In the Deformation toolbar, click on the Reset Current Keyframe

button to reset the position of

the selected chain on the current frame.

TIP
To completely reset the position and remove all keyframes on all frames, click on the Reset All
Keyframes

button.
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Converting Deformation Animations to Drawings
You may want to adjust your deformation animation. Convert deformation animations to drawing sequences, so
you can adjust the drawings using the drawing tools. You may also want to change the timing and set it on
double frames instead of single frame. Harmony offers you the option to convert your deformation animation to
an actual drawing sequence.

How to convert deformation animation to drawings
1. In the Timeline view, select the deformation frame range for which you want to convert to drawings.

2. From the top menu, select Animation > Deformation > Convert Deformed Drawing to Drawings.
The Baking Drawing window opens. Wait for the baking to complete.

Your selection is converted to vector drawings.
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Disabling Deformation Preview
When adding new drawings while animating, you may need to see the reference drawings as their original
resting position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable
deformations in Harmony so that all drawings appear in their resting position.
NOTE
Disabling deformations is only a display mode. Although drawings will not appear deformed in the
Camera view, even in Render View mode, they will still be deformed in the rendered images.

How to enable or disable deformation preview
1. In the Deformation toolbar, click on the Enable Deformations
preview.
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About Multi-pose Deformation Rigs (Transformation Chains)

Creating and rigging a full character turnaround can be achieved by creating multiple deformation chains on a
same character without having to create completely different puppets.
For a simplified process, you can keep each view of your character separate in the Timeline or Node view. If you
create separate rigs for each view, then you can simply turn on or off the exposure of each view in the timeline
when needed.
However, if you want to keep the entire character, with all views, in one group/rig on the timeline, then you can
follow the process described here by building a multi-pose deformation rig, also known as multiple
transformation chains.
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About Character Preparation for a Multi-pose Deformation Rig
Before building a puppet’s deformation skeleton, you must prepare your character. The best way to proceed is
to have the limbs on separate drawing layers. This is similar to a standard cut-out puppet preparation, but uses
fewer pieces. Since this is a more advanced type of puppet, you should keep the character’s head, hands, feet,
and facial features on a separate layer from the body, arms, and legs. This will prevent the extremities from
being distorted if the limbs are stretched during an action. It will also let you use drawing substitution to swap
hands, feet, eyes and mouth poses during animation.

There are many ways to break down a cut-out puppet. The example described in this chapter uses these
pieces:
•

Body

•

Left Ear

•

Right Ear

•

Head

•

Left Eye

•

Right Eye

•

Mouth

•

Left Eyebrow

•

Right Eyebrow

•

Nose

•

Left Arm

•

Right Arm

•

Left Hand

•

Right Hand

•

Left Leg

•

Right Leg

•

Left Foot

•

Right Foot

Refer to the following topic to learn how to break down a character: Rigging on page 763.
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About Structure for Multi-pose Deformation Rigs
Each pose (transformation chain) you rig within the same element has to be part of a separate subgroup, all of
which are gathered together by a Transformation-Switch node. The group name is not relevant in the multipose structure. These subgroups can be renamed once the rig is complete. The Transformation-Switch node
uses the drawing name to associate a transformation chain with it. If you rename a drawing after is has been
linked to a transformation chain, you will have to manually change the drawing name associated to the chain in
the Transformation-Switch layer properties. You might want to rename your drawing before you start rigging
so the names correspond to the poses. For example: front, side, quarter, etc.
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Renaming Drawings for Multi-pose Deformation Rigs
Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear node structure
for your project. If you leave your drawing as is and do not rename it, your deformation subgroups could become
slightly confusing. If you plan to have several drawings using the same rig within an element, for instance,
drawing substitution, then you should rename these extra drawings before starting your rig.

How to rename drawings
1. In the Xsheet view, locate the column that corresponds to the element which includes several
drawings that will use the same chain, such as a character that has several costumes which you plan
to swap by using drawing substitution. In our example, we will use the rabbit’s feet, which will all
use the same deformation curve.

2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged.
3. From the Xsheet menu, select Drawings > Rename Drawing or press Ctrl + D (Windows/Linux) or
⌘ + D (macOS).
4. In the Rename Drawing dialog box, type a relevant new name for the drawing and click OK.
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5. In the Xsheet view, select the next drawing in the column and select Drawings > Rename Drawing
from the Xsheet menu.
6. In the Rename Drawing dialog box, type the same name that you gave the first drawing of the
column, exactly as it is written and add and any number. For example, if the first drawing is named
front, the subsequent drawings are named: front_1, front_2, front_3, etc.
7. Repeat steps 5 and 6 for each subsequent drawing that needs to be renamed.
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Creating New Deformation Chains (Transformation Chains)
The process of creating multiple deformation chains on the same character is divided in four steps: creating the
main chain, creating additional chains, renaming the chains, and associating additional drawings to the chains.
The drawings are associated with deformation chains. For example, if you want to rig the puppet's arm, you will
need to add a deformation chain to the arm drawing. If the arm has multiple pieces such as upper arm, forearm
and hand, you will create the deformation chain on the upper arm and afterward link the forearm and hand to
that same chain. When creating the additional transformation chains on the other views of your rig, you will
create them on the upper arm. The forearm and hand will not influence which chain is used. They will follow the
upper arm chain. If the drawing exposure is changed on the upper arm, the deformation chain will change to
the associated one. If the forearm or hand exposure is changed, the same deformation chain will remain. You
must create the deformation chain on the drawing that will have the most influence when changing the
puppet's view.
After creating your deformation rig, you may want to convert an animated character's pose to a new
deformation chain. This can be useful when you want to add a pose to a turn-around deformation rig you have
already spent time creating and manipulating. You can take the pose at the current frame and the state of the
deformations and create a new drawing set along with a new deformation chain using the current position.
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Creating Main Deformation Chains for Multi-pose Rigs
The first step in creating a multi-pose rig is to create the main chain for the additional poses.

How to create the main deformation chain
1. In the Timeline view, make sure the time marker is set to the frame displaying your first drawing.
2. In the Node view, select the drawing layer containing the drawing you want to create the chain for.
If you want to create the chain for an arm composed in multiple pieces, you must select only one of
the drawing layer, such as the upper arm. The additional pieces will be added afterward.

3. In the Deformation toolbar, click the Create New Deformation Chain

button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

4. In the Deformation toolbar, select the Rigging

tool.

5. Create your deformer structure—see About Chain Creation on page 1077.

6. If needed, in the Node view, link the new deformation group to the additional pieces, such as the
forearm and hand.
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7. Repeat these steps for all the deformation chains that need to be created on the current puppet's
view.
These chains are now the default deformation chains that will be used on all drawings not using a
custom deformation chain.
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Reusing Deformation Groups for Multi-pose Rigs
When creating a deformation rig, you may want to copy and paste the deformation group created for a
drawing and connect it to another drawing. For example, after creating a bone or curve chain for the arm of a
character, you may want to copy and paste the deformation group to use it on the other arm.
The problem with copying and pasting deformation groups is that the Transformation switch in the group will
still point to the first drawing it was connected to. You can easily correct this problem by using the Associate
Parent Transformation Switch with Selected Element button.

How to copy bones and curves
1. In the Node view, copy the deformation group node.

2. Paste the deformation group node.
3. Connect the second set of drawings to the deformation group node. If these drawings are attached
to a peg, be sure to put the deformation group between the drawings and the peg.

4. Enter the Deformation group by clicking on its grey arrow.
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5. Open the Transformation Switch properties by clicking on the yellow box.

Notice that the drawing that the Transformation Switch points to is the original drawing that it was
connected to.

6. Exit the deformation group to return to the main Node view.
7. Select the drawing node connected to the copied deformation group. If there are multiple drawing
nodes connected to the same deformation group, select the drawing at the top of the hierarchy or
the one that makes the most sense for your setup.
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8. From the Deformation toolbar, click on the Associate Parent Transformation Switch to Selected
Element

button. If you do not see this button in the Deformation toolbar, you need to add it—see

the Reference guide .
The Transformation Switch now points to the correct drawing.

9. Rename the deformation group to match its associated drawings.
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Creating Additional Deformation Chains for Multi-pose Rigs
The second step to creating a multi-pose rig is to create additional chains. after the creation of the main chain.

How to create additional deformation chains
1. In the Timeline view, move the playhead (current frame) to the character's next position.
2. In the Node or Timeline view, select the drawing you want to set a new deformation chain
(transformation chain) for. If you had previously selected the upper arm in a multiple parts arm
structure, select the same drawing layer (upper arm).

3. In the Deformation toolbar, click the Create New Deformation Chain

button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

4. In the Deformation toolbar, select the Rigging

tool.

5. Create your new deformer structure—see About Chain Creation on page 1077.
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Renaming Transformation Chains on Multi-pose Rigs
Rename your transformation chains in order to keep track of and better organize your rig's various poses.

How to rename a transformation chain (deformation chain)
1. In the Timeline or Node view, select the drawing layer containing the chains you want to rename.
Make sure your current frame contains a deformation chain.

2. In the Deformation toolbar, click on the Rename Transformation

button,

The Rename Transformations dialog opens.

3. Rename the different transformation chains (deformation chains) to match the view they are
associated with.

4. Click OK.
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Linking Drawings to Transformation Chains
Link drawings to transformation chains, so that the drawings can be animated using the chains.

How to associate a drawing to a transformation chain
1. In the Timeline or Node view, select the drawing layer containing the drawing you want to link to an
existing deformation chain. The deformation chain has to exist on that same layer. You cannot
associate a drawing to a chain created on a different layer.
2. To associate the drawing to the chain, do one of the the following:
l

In the Deformation toolbar, select the desired chain from the Transformation Chain
drop-down list.

l

In the Node view, select the Transformation-Switch contained in the deformation
group and in the Layer Properties view, type the drawing name in the field
corresponding to the desired chain. The drawing names must be semi-colon
separated.
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Converting Drawings to New Deformation Chains
Link existing drawings to new deformation chains.

How to convert a drawing to a new deformation chain
1. In the Timeline view, go to the frame you want to transform into an new pose (deformation chain).
2. Select the drawing you want to convert and add a new chain.
3. Do one of the following:
l

From the top menu, select Animation > Deformation > Convert to New Drawing and
Add Deformation Chain.

l

In the Deformation toolbar, click the Convert to New Drawing and Add
Deformation Chain

button.

A new transformation is created and added to the list.
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About Legacy Deformations
Releases prior to Harmony 12 used a different deformation structure. The current structure is simplified.
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Transferring Curve Positions of Legacy Deformations
You can Lets you transfer all of the information from first curve deformer to its parent Offset node. This is useful
for a legacy scene created using Curve deformations where the Offset's position has been placed far away from
the drawing to make sure it doesn't affect the drawing's deformation. You can bring back the offset and give it
the first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The
offset no longer needs to be placed far away.

How to transfer a curve's position to its parent offset
1. In the Node view, select the root Offset and the first curve.

2. From the top menu, select Animation > Deformation > Set Curves and Offsets Independent from
Parent.
3. In the Node view, select only the first curve node.
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4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.
In the Node view, the first Curve node is disabled and the values are transferred to the parent
Offset node.
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Converting Legacy Deformation Chains
You can also convert a legacy deformation rig to the new format using a script. You can select which chain you
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original
puppet is maintained.

How to convert legacy deformation chains to the new structure
1. In the Node or Timeline view, select the deformation group containing the chain you want to
convert to the new structure.
2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the
toolbar, you can load it.
l

In the Scripting toolbar, click on Manage Scripts

l

In the Script Manager dialog, in the File column, select the TB_
CovertLegacyDeformation.js script. If you cannot find the script in the list (most likely
due to a software upgrade installation), you can load the script through the Script
Editor view from the default resources folder—see Importing Scripts in the Scripting
guide.

l

In the Functions column, select TB_ConvertLegacyDeformation.

l

Click the Right Arrow button to move the function to the Scripting toolbar.
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l

Click OK.

The legacy chain is converted.
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Chapter 12: Staging

Setting up your scene can be compared to building a set for a television show. This is the point when you
position each scene element such as the camera frame, the background elements and the characters.
To learn how to position and animate your camera, see Cameras on page 1259.
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About Layer Position

Setting up the scene also involves positioning the different scene elements within the camera frame.
At this time, the elements are set to a static position. See Motion Paths on page 971 to learn how to animate
the elements and the camera.
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About the Animate Mode
T-HFND-008-001
The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view.
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled,
keyframes are not created when an object's parameters change.
When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your
drawing layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off
1. In the Tools toolbar, click the Animate

button or select Animation > Animate.
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Selecting Layers
T-HFND-008-002
There are different ways to select the layers you want to reposition.
You can select your elements directly in the Camera view using the Transform tool. When using this tool, its
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection Mode
option in the Tool Properties view is disabled or it will limit the selection to pegs only.

How to select a layer in the Camera view
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tool Properties view, make sure that the Peg Selection Mode

is deselected.

3. In the Camera view, click on the element to be repositioned. You can select more than one element
at a time. Hold down Shift while clicking on the elements to be selected.
The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to select from the Timeline or Xsheet view
l

In the Timeline view, click the layer corresponding to the element you want to reposition.

l

In the Xsheet view, click the column header corresponding to the element you want to reposition.
The selected element is highlighted in the Camera view.

How to select non-adjacent elements in the Timeline or Xsheet view
l

In the Timeline view, hold down Ctrl (Windows/Linux) or ⌘ (macOS) and click on any layers that
you would like to add to the selection.

l

In the Xsheet view, hold down Ctrl (Windows/Linux) or ⌘ (macOS) and click on any columns that
you would like to add to the selection.
The non-adjacent, selected layers and columns are highlighted in the Timeline and Xsheet views.

How to select all elements within a group in the Node view
1. In the Node view, navigate to the group whose elements you want to select.
2. Hold down Alt and drag a marquee selection around the group node.
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All elements within that group are selected.

How to select all elements within a group in the Timeline view
1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.
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Setting Bounding Box Styles
You can change the display style of selected elements to a bounding box style. This removes the default overlay
highlight and leaves only the bounding box around the selected element.

How to set the bounding box selection style
1. In the Camera view bottom toolbar, click the BBox Selection Style
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can
use the Centre on Selection feature to display the selected object's layer in the Timeline view.
Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it
hard to locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar
to focus on the selected node in the Node view. You can also select elements in the Timeline or Xsheet view.
This can be useful when there are too many objects in the scene or when an object is hard to grab. Finally, you
can select all the elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view
1. In the Camera or Node view, select a layer.
2. Do one of the following:
l

From the Timeline view menu, select View > Centre on Selection or press O.

l

In the Timeline view toolbar, click the Centre on Selection

button.

How to center on the selected layer in the Node view
1. In the Camera or Timeline view, select a layer.
2. Do one of the following:
l

From the Node View menu, select View > Centre on Selection.

l

In the Node View toolbar, click the Centre On Selection

l

In the Node view, press O.
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About the Transform Tool
T-HFND-008-003
Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera
view.
When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode

is

deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

NOTE
Refer to About 3D Space Positioning on page 1560 to learn about the 3D Transform tool and how
to position elements in 3D space.
There are two different options you can use when you want to flip your element.
The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and
vertical axis.
Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip
Scale Y will perform a flip on your drawing layer following its original axis.
l

The Flip Horizontal command flips the layer following the Camera view X-axis.

l

The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Repositioning Temporary Pivots with the Transform Tool
T-HFND-008-004
Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is
only moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot
position—see About Advanced Animation Tools on page 1176.

How to temporarily reposition the pivot point
1. In the Tools toolbar, select the Transform

tool.

2. In the Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select your element.
The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously
repositioned.

4. Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will remain in this
position as long as you do not deselect the drawing. Using the Transform tool to reposition your
pivot will temporarily override the existing pivot point position until you complete the current
transformation. Then it returns automatically to its original position.
When you translate the pivot point using the Transform tool, the permanent pivot will appear as a
ghost so you know where it is and also from where the animation will be interpolated when you
create motion paths. The animation is always interpolated from the original pivot and not the
temporary pivot.
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Panning with the Transform Tool
T-HFND-008-005
You can pan (translate) a layer using the Transform tool.

How to pan a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and
click on each layer you wish to select.
5. Drag the selection to a new area.
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Rotating with the Transform Tool
T-HFND-008-006
You can rotate a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to rotate
from a different point.

How to rotate a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and
click on each layer you wish to select.
5. Place the pointer outside of a corner of the bounding box, then click and drag to rotate.

NOTE
You can display a rotation handle on the bounding box when transforming a
layer. In the Preferences dialog box, select the Camera tab and then select the
Use Rotation Lever with Transformation Tools option. This preference is off by
default.
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Scaling with the Transform Tool
T-HFND-008-007
You can scale a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to scale
from a different point.

How to scale a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and
click on each layer you wish to select.
5. Click an drag the top, side or corner control point.

NOTE
When scaling your selection, you can hold down Shift to preserve the proportions between its
width and height.

1173

Harmony 15.0 Premium User Guide

Skewing with the Transform Tool
T-HFND-008-008
You can skew a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to skew
from a different point.

How to skew a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer. If you want to select multiple layers, hold down Shift and
click on each layer you wish to select.
5. Place the pointer on the edge of the selection's bounding box, between two control points and drag
sideways or up and down.
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Flipping with the Transform Tool
T-HFND-008-009
You can flip a layer using the Transform tool. There are two ways to flip.
l

The Flip Horizontal command flips the layer following the Camera view X-axis.

l

The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode
4. In the Camera view, use the Transform

is deselected.

tool to select a drawing layer to flip.

5. Do one of the following:
l

From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical.

l

In the Tool Properties view, click the Flip Horizontal

and the Flip Vertical

buttons.
l

Press 4 or 5.

How to flip an element following its original axis
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tool Properties view, make sure the Peg Selection Mode
3. In the Camera view, use the Transform

is deselected.

tool to select an element that has already been

transformed.
4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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About Advanced Animation Tools
T-HFND-008-010
You can also use the advanced animation tools to position your layers. The difference between these tools and
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as
the Transform tool adjusts all parameters together.
You can find the advanced animation tools in the Advanced Animation Tools toolbar.
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Repositioning Permanent Pivots
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the
position of the drawing's pivot point. While making transformations using the Transform tool, you can drag and
drop your selection's pivot. However, this has no permanent effect. It will only temporarily change the pivot's
position to help you make transformations at the selected frame, but the actual pivot point of your drawing
layer will remain the same. You can reposition a layer's pivot point permanently using the advanced animation
tools.

How to permanently reposition the pivot point
1. In the Advanced Animation toolbar, select the Translate

, Rotate

, Scale

, or Skew

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) to select your element.
The pivot point appears in the Camera view.

3. Drag the pivot point to a new position.

NOTE
When you permanently move the pivot point of a layer that is already animated, all the
transformations done on the layer on other keyframes will be recalculated according to the
new pivot point's position. Therefore, your existing animation will look completely different,
except at the current frame. It is recommended to always make sure your pivot point is at its
ideal position before you start animating.
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Using the Translate Tool
T-LAY-004-002
You can use the Translate tool to pan your elements on the X, Y and Z axes.

How to use the Translate tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

From the top menu, select Animation > Tools > Translate.

l

In the Advanced Animation toolbar, click the Translate

l

Press Alt + 2.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) to select your element.
4. Drag the selection to a new area.

l

You can select multiple layers at the same time. Press Ctrl + Shift + click
(Windows/Linux) or ⌘ + Shift + click (macOS) on each element to select them.
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Using the Rotate Tool
You can use the Rotate tool to rotate your objects on the x,y and z axis.

How to use the Rotate tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

From the top menu, select Animation > Tools > Rotate.

l

In the Advanced Animation toolbar, click the Rotate

l

Press the Alt + 3.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) to select your element.
4. Rotate the layer.

l

You can select multiple layers at the same time. Press Ctrl + Shift + click
(Windows/Linux) or ⌘ + Shift + click (macOS) on each element to select them.
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Using the Scale Tool
You scan use the Scale tool to squash, stretch, and resize your elements.

How to use the Scale tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

From the top menu, select Animation > Tools > Scale.

l

In the Advanced Animation toolbar, click the Scale

l

Press Alt + 4.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) to select your element.
4. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s
ratio when using the corner control points.

l

You can select multiple layers at the same time. Press Ctrl + Shift + click
(Windows/Linux) or ⌘ + Shift + click (macOS) on each element to select them.
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Using the Skew Tool
You can use the Skew tool to distort your elements on the x and y axis.

How to use the Skew tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

Select Animation > Tools > Skew.

l

In the Advanced Animation toolbar, click the Skew

l

Press Alt + 5.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (macOS) on the element to select it
and drag a side of the bounding box up, down or sideways.

l

You can select multiple layers at the same time. Press Ctrl + Shift + click
(Windows/Linux) or ⌘ + Shift + click (macOS) on each element to select them.
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About the Layer Properties View
T-HFND-008-011
Each layer has a series of parameters that you can modify to adjust an element's position. You can access these
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in
the Camera view. These values can also be animated over time.
You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters

button.

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the
north-south (up-down) direction and the Z axis is the forward-backward direction.
In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has
been drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have
drawn on the page. This allows scanned drawings, imported images and paperless drawings to be properly
registered together.
If you want to move your drawing in the upper-left region of the camera frame, you would type in something
like the following:
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l

X Axis: -4 or 4W (4 West)

l

Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something
like the following:
l

X Axis: 3 or 3E (3 East)

l

Y Axis: -2 or 2S (2 South)
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Displaying the Layer Properties View
You can display the Layer Properties view in several ways.

How to display layer parameters
1. Do one of the following:
l

In the Layer Properties view is not part of your workspace, from the top menu, select
Windows > Layer Properties. In the Timeline view, select a layer

l

In the Timeline view, double-click on a layer.

l

Press Shift + E.

l

In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .
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Positioning Elements with the Layer Properties View
T-HFND-008-012
You can type values to position your elements using exact coordinates.

How to position an element with coordinates
1. In the Timeline view, select a layer.
2. In the Layer Properties view, select Enable 3D option to display the 3D parameters in the Layer
Properties.
3. In the Position section, select one of the following options:
l

Separate to independently edit the different coordinate fields. Continue to step 3.

l

3D Path to use a 3D path function when animating your element. Continue to step 4.

4. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—
see About Multiplane on page 1199.
As you type in values, the element’s position is updated in the Camera view.
5. Use the Function

buttons to create function curves and add keyframes to animate the

parameter.
6. In the Scale section, select one of the following options:
l

Locked to resizes the element uniformly in three directions.

l

Separate to resize the element in any direction without affecting the others.
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7. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position
8. Use the Function

buttons to create function curves and add keyframes to animate the

parameter.
9. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can
enter values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

10. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

11. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This
will change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see the Reference guide .

1186

Chapter 12: Staging

About Selection Locking
You can prevent correctly positioned layers from being selected in the Camera view by locking them in the
Timeline view. This is useful for making a multiple selection inside the Camera view while avoiding to select
them. Once a layer has been locked, its locked state will be remembered the next time you open a saved
project.
You can perform five types of locking actions on your layers:
l

The Lock

option lets you lock Locks one or a multiple selection of layers.

l

The Unlock

l

The Lock All

l

The Unlock All

l

The Lock All Others

button lets you unlock Unlocks one or a multiple selection of locked layers.
option lets you lock Locks all the layers in the Timeline view.
button lets you unlock Unlocks all the layers in the Timeline view.
button lets you lock Locks every layer except the selected ones.
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Locking Layers
You can perform five types of locking actions on your layers. You will still be able to modify locked layers in the
Timeline and Layer Properties views, but you will not be able to select them through the Camera view.

How to lock a layer or a selection of layers
1. In the Timeline view, select one or more layers.

2. Do one of the following:
l

From the top menu, select Animation > Lock > Lock.

l

Click one of the selected layer’s Lock

l

Press Ctrl + Alt + L (Windows/Linux) or ⌘ + Alt + L (macOS).

icon.

All selected layers are locked.

How to unlock a locked layer or a selection of locked layers
1. In the Timeline view, select one or more locked layers.
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2. Do one of the following:
l

From the top menu, select Animation > Lock > Unlock.

l

Click a selected layer’s Lock

l

Press Ctrl + Shift + K (Windows/Linux) or ⌘ + Shift + K (macOS).

icon.

All selected layers are unlocked.

How to lock all layers
1. Do one of the following:
l

From the top menu, select Animation > Lock > Lock All.

l

In the Timeline view, select all layers and click Lock

l

Press Ctrl + Shift + L (Windows/Linux) or ⌘ + Shift + L (macOS).

icon of a selected layer.

All layers are locked.

How to unlock all layers
1. Do one of the following:
l

From the top menu, select Animation > Lock > Unlock All.

l

In the Timeline view, select all layers (locked) and click Lock
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l

Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘ + Alt + Shift + L (macOS).

All layers are unlocked.

How to lock all other layers
1. In the Timeline view, select the layers you do not want to lock.

2. Do one of the following:
l

From the top menu, select Animation > Lock > Lock All Others.

l

Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘ + Alt + Shift + O (macOS).

All layers are locked except the selected ones.

How to display locked drawings as outline
1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings
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2. You can also set this option as a permanent preference. From the top menu, select Edit >
Preferences (Windows/Linux) or Harmony Premium > Preferences (macOS).
3. In the Preferences dialog box, select the Camera tab.
4. In the Tools section, select the Show Locked Drawings As Outlines option.
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About Auto-Apply
When you modify a parameter in a property dialog box, Automatically applies changes you make to a property
window or dialog box. Harmony applies the modification automatically and displays the result in the Camera
view. When working on a heavy scene, it is useful to turn off this option.If you want to always work in AutoApply mode, you can deselect the Auto-Apply option in the Preferences dialog box (General tab). Then, each
time you start Harmony, the Auto-Apply mode will be off. You must click the Apply button to see any
modifications.
When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties view
and any other parameter dialog boxes.
l

Click Apply to apply the current change.

l

Click OK to apply the current change and close the Layer Properties.
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Setting the Auto-Apply Option
If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences
dialog box (General tab). Then, each time you start Harmony, the Auto-Apply mode will be off. You must click
the Apply button to see any modifications.

How to enable or disable the Auto Apply option
l

From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference
1. In the top menu, select Edit > Preferences (Windows/Linux) or
Harmony Premium > Preferences (macOS).
The Preferences dialog box opens.
2. In the Preferences dialog box, select the General tab.
3. In the Options section, select or deselect the Auto Apply option.
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Resetting Transformations
You can easily reset layers to their original position. With the Reset command, you can return the value of a
selected element to the initial value of the active tool. For example, if the Rotate
transformation angle will be reset to 0 and if the Transform

tool is active, the

tool is active, the all transformation parameters

values will be reset.
When selecting elements in the Camera view using the Transform tool, always make sure that the Peg
Selection Mode

is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to reset the transformation on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset or press R. This will reset the current frame if
keyframes were created.
The selected layer(s) return to their original position.

How to reset all transformations on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset All or press Shift + R.
The selected layer(s) return to their original position.

How to reset all transformation values except Z
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset All Except Z.
All values except for those set on the Z axis are reset.

How to completely reset the layers' parameters
1. In the Tools toolbar, select the Transform

tool or press Shift + T.
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2. In the Timeline or Camera view, select one or more drawing layers to reset.
3. Do one of the following:
l

Right-click the selected layers and select Clear All Values. This will remove all
keyframes and reset all values for the entire layer.

l

In the Timeline View menu, select Layers > Clear All Values. This will remove all
keyframes and reset all values for the entire layer.

The selected layers return to their original position.
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About Opacity and Transparency
Harmony has two ways of adding transparency to your scene:
l

The Opacity parameter is a parameter each drawing layer. It is set to 100% by default. By lowering it,
you can make an individual layer appear more transparent.

l

The Transparency effect is an effect node that can be attached to individual layers or to a composite. It
has a Transparency parameter that is set to 50 by default. The higher it is, the more transparent the
layer or composite it is attached to will appear.

It is important to know when to use either approach. For example, to make a character composed of several
layers transparent, it is preferable to connect the character rig's nodes to a composite and connect the
Transparency effect to this composite, as reducing the opacity of individual layers will make their overlapping
parts visible—see About Composite Nodes on page 1218.

You can however animate a Transparency effect's parameter in the Timeline view, so this may be a preferable
approach even if you only want to animate the transparency for a single layer. To learn how to add and
animate an effect, see Adding Effects Nodes on page 1354, Connecting Effects on page 1356 and Animating
an Effect on page 1366.
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Setting the Layer Opacity
If you need specific layers to appear semi-transparent, you can quickly set a drawing layer's opacity parameter
directly in the Timeline view.
A drawing layer's opacity parameter will appear in the Timeline view when this drawing layer has thumbnails
display enabled:

How to set a drawing layer's opacity
1. In the Timeline view, do one of the following:
l

Left of the layer's name in the Layers list, click on the Show Thumbnails

l

Select the drawing layer and press T.

l

Left of the Layers list header, click on the Show All Thumbnails

icon.

icon.

The Opacity parameter is displayed left of the drawing layer's thumbnail.

2. Do one of the following:
l

Double-click on the value of the Opacity parameter and type in its new value.

l

Click and drag the value of the Opacity parameter to the left to reduce it, or to the right to
increase it.
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About Multiplane
T-HFND-008-013
One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through
this environment to create an impressive perspective illusion.

In live action, when the camera moves around in a scene, objects near the camera will appear to move by a
greater distance than objects far from the camera. In 2D animation, multiplanes can be used to achieve a similar
effect without having to use 3D.
In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and
positioning them at different depths relative to the camera.
Before creating a multiplane, make sure you have a proper understanding of the environment in which your
scene happens. Picture what your scene's background would be like in 3D, then image the camera moving
through the space, and how the objects in the picture move at different speeds depending on where they are
in relation to the camera lens.
In the following example, the background is made of 6 different layers, each picturing an object that is at a
different distance from the camera. On the left, you can see how each object is positioned relative to the
camera, as if you were looking at them from the side. On the right, you can see how layers are positioned
relative to each other as if you were looking at the scene from a corner. Below, you can see the scene from the
camera's point of view.

1199

Harmony 15.0 Premium User Guide

NOTE
When creating a multiplane background, it is important to draw each layer fully. Even if some parts
of a background layer is hidden behind a foreground layer in the camera's initial position, panning
or zooming the camera may expose parts of background layers that are not initially visible.
In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You
can do this by moving a layer using the Transform Tool

in the Side or Top views. You can also move a layer

on Z-axis directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your
element closer to the camera makes them appear bigger, and moving them further makes them appear smaller.
It is also possible to move elements on the Z-axis without affecting their apparent size by using the Maintain
Size

tool in the Advanced Animation toolbar.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the
Top and Side views.
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Just like with other transformations, transformations on the Z-axis on a parent layer will also affect the
apparent position on the Z-axis of its child layers. Therefore, a child layer's apparent position on the Z-axis can
be affected by any of its parents. Once transformations on the Z-axis have been performed on several layers in
a hierarchy, it may be difficult to keep track of which layers have been moved on the Z-axis and which ones
have not. To help with this, it is possible to compare the selected layer's Z coordinate value with its apparent
position on the Z-axis using the Coordinates and Control Point view or the Coordinate toolbar. Both these
interfaces feature a field to tweak the layer's Z coordinate, which is independent from parent layers, as well as a
field displaying the layer's cumulative Z coordinate, which is the sum of the Z coordinate of the selected layer
with the Z coordinate of all its parents.

To enable the Coordinate toolbar, do one of the following:
l

From the top menu, select Windows > Toolbars > Coordinate.

l

Right-click on any visible toolbar and select Coordinate.

To enable the Coord. and Control Points view, do one of the following:
l

From the top menu, select Windows > Coord. and Control Points.

l

From any view already open, click the Add View
and Control Points.
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Setting Up Multiplanes
T-HFND-008-017
You can setup your elements as a multiplane to create a parallax effect when moving your camera. You simply
need to spread and scale the objects on the Z-axis.
Using the Depth View mode can also be a useful tool when setting up multiplanes, see—Using the Depth View
Mode on page 1569.

How to rotate a scene in the Perspective view
1. In the Tools toolbar, select the Rotate View

tool.

2. Click in the view, and drag the cursor around to rotate the view or press and hold Ctrl + Alt
(Windows/Linux) or ⌘ + Alt (macOS) and click and drag to rotate the view one axis at a time.

How to set up a multiplane
NOTE
Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z
Dragging option by selecting Animation > No Z Dragging. This option is disabled by default.

1. To maintain the visual scale in the Camera view as you move your element, do one of the following:
l

In the Advanced Animation toolbar, select the Maintain Size

l

From the top menu, select Animation > Tools > Maintain Size.

l

Press Alt + 6.

tool.

2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer
from the Timeline view.
The selected layer is highlighted in the Top, Side and Camera views.
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3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the
same in the Camera view.

4. For your element to scale up or down in relation to their distance to the camera, do one of the
following:
l

l

In the Tools toolbar, select the Transform
tool. Make sure the Peg Selection Mode
option is disabled in the Tool Properties view.
In the Advanced Animation toolbar, select the Translate
from the thumbnails section of the Top or Side view.

l

Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.
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5. In the Top view, drag the element sideways to position it horizontally. Hold Shift while dragging the
element to make sure it only moves along the X-axis.
6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while
dragging the element to make sure it only moves along the Y-axis.
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About Clone and Duplicate Layers
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You
can do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone
uses the same drawings for all layers. A duplicated layer is simply an independent copy.
If you want to maintain the ability to modify drawings and propagate the changes through all layers, you
should clone your layer. If you simply want to copy your layers and be able to modify your drawings without
affecting the original layer, use the duplicate option.
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About Clone Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer,
both will be updated. However, cloned layers can have different timings.

In the Timeline view, the left part of the layer is a node, same as in the Node view. These nodes are linked to
columns. The right part of the Timeline view corresponds to the Xsheet column. These columns can contain
drawing exposures or value keyframes. One node can be linked to several columns; one drawing column and
several parameter columns (rotation, position, scale, pivot, etc.).

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or
only the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element
folder, as well as the same drawing and function columns. Therefore, if you change the drawing exposure or
keyframe on one layer, all cloned layers will be updated.
You may want to create a large group of characters reusing the same animation, but want to slightly offset the
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing
exposures to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will
create a heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same
timing (function and exposure columns).
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Cloning Layers
You can clone layers in several ways. Cloned layers use the same drawings.

How to clone a layer
1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.
2. Do one of the following:
l

From the Xsheet menu, select Columns > Clone Selected Columns: Drawings Only or
Columns > Clone Selected Columns: Drawings and Timing.

l

From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and
Timing.

l

From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only or
Layers > Clone Selected Layers: Drawings and Timing.

l

In the Timeline view, right-click on the layers and select Clone Selected Layers:
Drawings Only or Clone Selected Layers: Drawings and Timing.

l

In the Node menu, select Nodes > Clone Selected Layers: Drawings Only or Nodes >
Clone Selected Layers: Drawings and Timing. When you clone a node, it does not
automatically connect itself to the Composite node of your scene.

The cloned layer appears.

NOTE
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C
and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (macOS), this creates a CLONE not a
duplicate. Nodes will be linked to the same drawings. Pegs will be linked to the same function
columns.
To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C
(Windows/Linux) or ⌘ + C (macOS) and Ctrl + B (Windows/Linux) or ⌘ + B (macOS) for Paste
Special, and in the Advanced tab, select Nodes: Create New Columns.
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About Duplicate Layers
T-HFND-006-013
You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as
an independent timing (exposure). When you need the drawings to be modified independently, you will want
to duplicate the layer instead of cloning it.

1208

Chapter 12: Staging

Duplicating Layers
T-HFND-006-014
You can easily duplicate layers. Once duplicated, the layers are completely independent. Drawings are also
duplicated.

How to duplicate a layer
1. In the Timeline, Xsheet or Node view, select one or more layers.
2. Do one of the following:
l

In the Timeline menu, select Layers > Duplicate Selected Layers.

l

In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

l

In the Node menu, select Nodes > Duplicate Selected Nodes. When you duplicate a
node, it does not automatically connect itself to the Composite node of your scene.

l

From the Xsheet menu, select Columns > Duplicate Selected Layers.

l

From the top menu, select Edit > Duplicate.

The duplicated layer appears.
NOTE
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C
and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (macOS), this creates a CLONE not a
duplicate. Nodes will be linked to the same drawings. Pegs will be linked to the same function
columns.
To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C
(Windows/Linux) or ⌘ + C (macOS) and Ctrl + B (Windows/Linux) or ⌘ + B (macOS) for Paste
Special, and in the Advanced tab, select Nodes: Create New Columns.
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About Timeline View Modes
The View Modes button lets you streamline the process of working with elements in the Timeline view. There
are three different view modes you can choose to work in. With each mode you select, certain elements may or
may not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding
elements when you want to focus on specific ones. To select a view mode, use the drop-down menu in the
bottom-left corner of the Timeline view.

Normal View Mode
Normal View

mode is the default Timeline view mode. It shows everything connected to the chosen

display. In this mode, anything not connected to the currently set default display will not be shown in the
Timeline view. This also means that you cannot add certain elements to the Timeline view, as by default,
when added they are not connected to any display or composite node. An example of such an element is a
peg.
NOTE
If you prefer to work as you did before, where you see everything in the Timeline whether it is
connected to a Display or not, you can change the Always Display Unconnected Nodes setting
in the Preferences dialog box, Timeline tab.

Selection Only Mode
When working in Selection Only

mode, only elements currently selected in the Camera or Node view

will be visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Layers
The View Tagged Nodes

mode lets

you see only elements which have been assigned a Tagged status. An item that has been tagged will
appear in the Timeline view with a small asterisk beside its name.
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Once your elements are tagged and you have switched over to View Tagged Layers mode, the Timeline
view will display only tagged elements. The red bar on the left of the layers indicates you are in this view
mode.

While in this mode, the asterisks are not displayed beside the tagged elements.
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Tagging Layers
You can tag layers to easily visualize them in the Timeline view.

How to tag or untag elements in the Camera view
1. In the Camera view, select one or more elements.
2. Right-click and select Tag or Untag.

How to tag or untag elements in the Timeline or Node view
1. In the Timeline or Node view, select one or more elements.
2. Do one of the following:
l

Right-click and select Tag and one of the following:

l

In the Timeline or Node view menu, select Edit > Tag and one of the following:
l

Timeline Tag: Tags selected elements in the Timeline or Node views.

l

Timeline Untag: Untags selected layer in the Timeline view.

l

Timeline Untag All: Untags all tagged elements.

l

Timeline Untag All Others: Untags all elements except the selected one.
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About Nodes
The Node view uses a visual set of connections (nodes) to show how each element in the scene is connected
and brought to the final image. It allows you to add extra elements and effects, and to move beyond the
possibilities offered by the Timeline and Xsheet views. Each node corresponds to a layer in the Timeline view.
Very few nodes are only visible in the Node view.
The basic rules of the Node view are quite simple. Once you understand them, a lot can be accomplished.
Each node used to build a node system is available in the Node Library view as well as through the Insert menu
in the Node view. In addition, each time you create a layer from the Timeline or Xsheet views, the
corresponding node is created in the Node view.

Each element in the Node view is called a node. There are several different types of nodes:

This is an example of an average node, a simple drawing node that represents a layer in the Timeline view. This
node has an input port (top) that allows information to flow through it. It has an output port (bottom) that
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exports its information in a downward flow. On the left is a yellow button that displays the node's property
editor, where you can adjust its parameters. Lastly, there is an arrow that displays a thumbnail of the node's
contents at the current frame.

This is an example of a simple effect node taking a single image input and outputting a processed (blurred in
this case) image.

Node

Description

Drawing

Transfers drawing information.

Effect

Processes effects on drawings and transfers drawing information.

Input/Output

Acts as the interface between each node and node system.

Transformation

Controls the camera and element transformations over time.

Composite

Combines multiple source images.
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About Input and Output Ports
T-HFND-010-005
Each node has an input port at the top and an output port at the bottom. Some are blue and others are lightgreen or bright green.
Blue indicates drawing information.

Light green indicates position and movement (transformation).

Bright green shows the element on top of the composition and outputs that element’s Z position to the
Composite node. When many elements have different Z positions (multiplane, different distances from the
camera) and are placed through a Composite node that flattens them together (producing one image with one
Z value), the system needs to give a Z position to this new image. It uses the bright green port information.

Finally, some nodes contain more than one input port. These are usually effect nodes needing different drawing
or position information in order to perform their calculation. When the two ports are blue, the Drawing is on the
right and the Matte is on the left. If it's light-green, the drawing needs extra position information.
A matte, also called mask, is the shape that will be used by the effect node to modify the original image (left
input port). The effect will only be applied where the matte overlaps the original image. Sometimes the matte
will act as a negative shape that the effect will exclude. This all depends on the nature and editing properties of
the effect.
Some effects contain three input ports. If they are green, then they require a transformation (Peg, Quadmap,
Quake, etc.) connection (coordinate and value information).
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Both the Write and Display nodes do not have output ports. This is because the information that flows into
them can go no further in the node system. The Write node records the images and renders the final output.
The Display node captures the visual information and outputs it to the Camera, Perspective, Top, Side and
Timeline views.

If you are unsure of the type of connection required for a node, you can click on the port itself and the port type
will be displayed.

On each port is a tooltip which displays the source of input ports and the destination(s) of the output ports
(node names).
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Displaying Port Tooltips
You can display any port tooltips by clicking on a port or connecting a cable.

How to display a port's tooltip
1. In the Node view, hover the pointer over a port.
The port's tooltip displays source and destination information.

2. Click on any port to display the port type label. The label will also display as you connect cables into
ports.
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About Composite Nodes
The Composite node allows you to use several images and output a single image. You can compare that to
doing pre-compositions in editing software. You can connect several drawing, image generators and effect
nodes in your Composite node and one bitmap (or vector in some cases) comes out of it.
Refer to the following example to connect this effect:

Using Composites is necessary if you wish to apply effects to several layers combined. For example, if you want
a character rig that is composed of several layers to appear transparent, you must connect all the layers of your
character's rig to the same composite, and connect a Transparency effect to that composite.
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By default, the image resulting from the Composite node is a bitmap. The layers are composited together
depending on their position on the Z-axis (forward-backward) first, then their order in the Composite node. If
two images are at the same position on the Z-axis, their order in the Composite will determine which one is
displayed in front and which one is displayed behind.
TIP
You can quickly connect a selection of layers to a new composite using the Group Selection
with Composite option—see Grouping Nodes on page 1238.
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About Peg Nodes
The Peg nodes control the transformation of elements (position, scale, skewing and rotation) over time. The
green ports at the top and bottom of the node indicate that it accepts transformation information which can be
passed on (inputs and outputs transformation information).
One peg can be used to control many different nodes or one node can accept more than one peg. In a situation
like the latter, one peg might be used to modify the rotation, while the other is used to modify the position of
the effect and then animated differently over time.
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Adding Nodes
T-ANIMPA-012-002
Each node used to build a node system is available in the Node Library view as well as through the Insert menu
in the Node view

How to add nodes from the Node Library
1. Do one of the following:
l

In the Node Library, select a node and drag it to the Node view.

l

In the Node Library, select a node and press Enter/Return to add it to the Node view.

How to add nodes using the Insert menu
1. Anywhere in the Node view, right-click and select Insert > the desired category > the desired
node. The categories are the same as in the Node Library view.
l

In the Node View menu, you can also select Insert > Effects > the desired category >
the desired node.

The new node appear at the center of the visible Node view area.
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Connecting and Disconnecting Nodes
You can connect nodes by dragging cables from output ports to input ports. You can disconnect nodes by
pulling on the cable connections.

How to connect nodes
1. In the Node view, do one of the following:
l

Extend a cable from the first node’s output port (bottom port) and connect it to the
second node’s input port (top port).

l

Select the node to connect, hold down the Alt key and drag the node on an existing
cable.

It is possible to create links between nodes in the Node view by clicking on one node and Ctrlclicking (Windows) or ⌘-clicking (macOS) on a second port.
Select a node and Ctrl-click (Windows) or ⌘-click (macOS) a port:
l

l

l

l

l

l

Click a node and then Ctrl-click (Windows) or ⌘-click (macOS) the input port of a
different node. The nodes are linked.
Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (macOS) a
different node. The nodes are linked.
Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (macOS) a
Composite node. The node is linked to a new input port of the Composite.
Click a port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (macOS) port
of a Composite node. The selected port replaces the link in the Composite's input port.
Click an output port of a node and then Ctrl-click (Windows) or ⌘-click (macOS) the
input port of a Group node. The selected output port replaces the link to the group.
Click an output port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click
(macOS) the input port of a Group node. The selected output port links to a new inport of the group.
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NOTE
You can reconnect a node's output port without disconnecting its destination port by dragging
the connect from the output port to another output port while holding Ctrl (Windows/Linux) or
⌘ (macOS).

How to disconnect nodes
1. In the Node view, select the node to disconnect, hold down the Alt key and drag the node away.
You can also pull on the connection cable.
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Spreading Nodes
When you are working in the Node view and adding many nodes, your scene may look a bit messy and be
difficult to follow. Harmony provides scripts which organize and display the nodes in a more orderly fashion.

How to spread the node system
1. In the Node view, select some or all of your nodes.

2. Display the Node View toolbar by selecting Window > Toolbars > Node View.
3. Click the Order Node View Up

or Order Node View Down

button.

The Order Node View Settings dialog box opens.

4. Set values for the X Overlap%, Layer Spacing and Vertical Spacing. The default value is set for
optimal organization.
5. Click OK.
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Enabling and Disabling Nodes
As with the Timeline layers, you can turn the Node view nodes on or off. When you turn off a node in the Node
view, its corresponding layer in the Timeline and Xsheet views is also turned off. Nodes that are turned off are
displayed in red.

How to disable nodes
1. In the Node view, select the node(s) you want to enable.
2. In the Node View menu, select Nodes > Disable or press D.

How to disable all other nodes
1. In the Node view, select the node(s) to remain enabled.

2. In the Node view menu, select Nodes > Disable All Others.
All nodes are disabled except for those selected. This operation only affects the current level layers.
It does not affect the nested nodes within a group.
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How to enable nodes
1. In the Node view, select the disabled node(s) you want to enable.

2. In the Node View menu, select Nodes > Enable or press A. This keyboard shortcut is also valid in the
Timeline view.

How to enable all nodes
1. In the Node View menu, select Nodes > Enable All.

1226

Chapter 12: Staging

Navigating the Node View
You can navigate to the parent or child node of the selected node or selected cable in the Node view.
The Navigator is a small square window inside the Node view that displays a bird's eye view of the network.
The view displayed in the Node view is shown framed in the Navigator display. You can drag this frame to pan
the current Node view display.
When your networks grows more complex, you can pan the Node view to locate and work on specific nodes.

How to navigate the Node view
1. In the Node view, select a node or cable, and press the Ctrl + Up Arrow/Down Arrow arrows
(Windows) or ⌘ + Up Arrow/Down Arrow arrows (macOS).

How to display all nodes
1. From the Node View menu, select View > Show All Nodes or press Shift + comma (,).

How to show or hide the navigator, do one of the following
l

In the Node view menu, select View > Navigator > Hide Navigator or Show Navigator.

l

Press Ctrl + Shift + W (Windows/Linux) or ⌘ + Shift + W (macOS).
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How to position the navigator
l

In the Node view menu, select View > Navigator > and select Top Left, Top Right, Bottom Left, or
Bottom Right.

How to magnify the Node view
1. In the Node view, hold down Z.
A black outline surrounds the area you were at before pressing Z.
2. Change the magnification level of the magnifier by rolling the mouse wheel. You can also pan your
mouse to move around the magnified area.
3. When satified with the magnified area's position, click inside the magnified area to set it as your
new view point.
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How to pan the Node view
1. Select a node, press Spacebar and drag to a new location.
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Displaying Node Thumbnails
In the Node view, some nodes have a thumbnail option, identified by an arrow next to the properties button
(square yellow button). Thumbnails can be very useful when navigating the network to easily identify the
content of each node or analyze the flow of images and effects.

How to display a node’s thumbnail
1. In the Node view, click on the arrow in the node.
The thumbnail opens.

If no thumbnail appears, click the Render View

button in the Camera view (bottom toolbar) to

generate them.

How to show thumbnails of selected nodes
1. In the Node view, select the node(s) whose thumbnails you want to display.

2. In the Node View menu, select View > Show Selected Thumbnails or press T.
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If no thumbnail appears, click the Render View

button in the Camera view (bottom toolbar) to

generate them.

How to hide a node’s thumbnail
1. In the Node view, click the arrow in the node.
The thumbnail closes and the node returns to its closed state.

How to hide thumbnails for the selected nodes
1. In the Node view, select the node(s) whose thumbnails you want to hide.

1231

Harmony 15.0 Premium User Guide

2. In the Node View menu, select View > Hide Selected Thumbnails or press T.

How to hide all nodes thumbnails
1. In the Network View menu, select View > Hide All Thumbnails.
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Adjusting Node Thumbnails
It is possible to adjust the size, resolution and background colour of thumbnails in the Node view.

How to adjust the size, resolution or background colour of Node thumbnails
1. In the Node view, click on the Arrow button of a Node to display its thumbnail. For other methods to
display Node thumbnails, see Displaying Node Thumbnails on page 1230

1. Click on the node to select it.
The node's thumbnail controls appear.

1. Do one of the following:
l

To resize the thumbnail, click and drag the handle in its top-right corner.

l

To change the resolution of the thumbnail, click and hold the resolution drop-down on the
bottom-left corner, drag the mouse cursor over the desired resolution, then release the
mouse button.
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l

The change the background colour of the thumbnail, click on the square in the bottom-right
corner of the thumbnail.
The background colour cycles over white, black, blue and grey.
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Changing Cable Styles
You can customize the look of the cables in the Node view to fit your style of working. You can display the cable
lines as Bezier (curved) lines or straight lines.

How to change cable styles
l

In the Node View menu, select View > Cable Style > Bezier or Line.
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About Groups
With so many connections and nodes possible, the Timeline and Node views can quickly become cluttered. You
can use groups to keep your scenes organized.
When working with complex rigs, you may want to group layers together to avoid cluttering the Timeline view
and keep your layers organized.

When grouping nodes, you can choose to create a simple group, or a group with a composite. A simple group
will simply help you organize your Node view, whereas a group with composite will connect all the nodes in
your group to the same composite, and connect that composite to the outside of your group. This makes the
group have a single outgoing connection for its composite, rather than one connection for each node that
connected to your scene's composite.
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Hence, grouping nodes with a composite is a quick way of connecting several layers that need to be
composited together to the same composite node. However, grouping nodes without a composite allows you to
connect the layers inside the group to different parts of the Node view outside of the group, allowing you to
preserve and tweak the stacking order of the group's content relative to the remainder of the scene if needed.
Using the Move to Parent Group command allows you to move the selected node to the parent level,
maintaining all connections. If the operation cannot maintain the connections between the nodes, you will be
notified and the operation will be terminated.
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Grouping Nodes
You can group your nodes to keep your work organized.

How to group layers in the Timeline view
1. In the Timeline view, select the elements you want to group.
Any layers between the selected layers will be automatically grouped as well, so if the stacking
order does not matter, move extra layers above or below the layers want to group.
2. Do one of the followings:
l

Right-click on the highlighted layers and select Group Selection With Composite.

l

Right-click on the highlighted layers and select Group Selection.

l

From the top menu, select Edit > Group > Group Selected Layers.

The layers appear indented under a new Group layer in the Timeline view and in a new Group node
in the Node view.

How to group nodes in the Node view
1. In the Node view, drag a selection around the nodes you want to group.

2. In the Node menu, do one of the following:
l

Select Edit > Group > Group Selected Layers.

l

Press Ctrl + G (Windows/Linux) or ⌘ + G (macOS).

You can also right-click in the Node view and select one of the following:
l

Group > Group Selection With Composite or press Ctrl +Shift + G (Windows/Linux)
or ⌘ + Shift + G (macOS).

l

Group > Group Selection or press Ctrl + G (Windows/Linux) or ⌘ + G (macOS)

The selected nodes are grouped.
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NOTE
To ensure that you have a Multi-Port Out node in your group and that your group remains
connected, include a Composite node in your selection and make sure it is connected to the
main Composite node of the scene before grouping.
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Ungrouping Nodes
You can ungroup groups of nodes using the Node view.

How to ungroup a group of nodes
1. In the Node view, select the group you want to ungroup.

2. In the Node menu, select Edit > Group > Ungroup.
The selected group is ungrouped.
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Entering Groups
You can enter groups to see their content.

How to enter a group node
1. In the Node view, click the arrow on the right side of the group node you want to enter.

l

Inside the group node, the Multi-Port In and Multi-Port Out nodes ensure that your connections
continue beyond the group.
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Exiting Groups
You can exit groups and return to the complete node system.

How to exit a group node
1. In the Node view, click the destination in the Group Hierarchy menu. You can also select Nodes >
Exit Group from the Node menu.
‣

You can click on the top blue arrow in the Node view to exit the current group.

‣

When you enter a group, the Group Hierarchy menu displays the path to where you are. In this
example, we are inside the group named Deform_Bob. To exit this group, click Top at the
bottom-left corner of the Node view.
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Moving Up Group Levels
In a node system, there can be nested groups (a group in a group). You can easily move up the nested
hierarchy.

How to move up a level in a group
l

Click the arrow at the top of the Node view.
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Moving Nodes to Parent Group
You can select nodes within a group and move them out to the parent group.

How to move selected nodes to the parent group
1. In the Node view, go inside the group and select the nodes you want to move up to the parent
group level.

2. From the Node menu, select Nodes > Move to Parent Group or press Ctrl + Shift + U
(Windows/Linux) or ⌘ + Shift + U (macOS).
The selected nodes are moved to the parent group level.
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Adding the Properties of a Node to the Properties of its Parent
Group
Using Publish Attribute Mode, you can select properties in any node's Layer Properties dialog and push them
to the layer properties of their parent group. This way, if you need to make frequent changes to specific
properties of specific nodes inside a group, you can access those properties directly from the Layer Properties
dialog for that group, instead of having to enter that group and locate those specific nodes every time.

How to publish a node's attributes to its parent group
1. In the top-left corner of the Node view, open the View Menu

and select View > Publish

Attribute Mode.
2. In the Node view, locate the node for which you want to publish attributes.
3. Click on the Layer Properties

button for this node.

The Layer Properties dialog for this node appears. Notice that:
l

A Tab field is at the top of the layer properties dialog. The attributes you publish will be in a
tab inside the parent group's layer properties, and the tab will have the name you put in this
field. The parent group will have one tab for each node that has published attributes.

l

A check box and a text field is right of each group of attributes, such as Position, Scale,
Rotation, etc. If you check a group's check box, all of the attributes in this group will be listed
in the parent group's properties.

l

A check box and a text field is right of each individual attribute.

4. In the Tab field, give a name to the tab that will appear in the parent group's properties for this
node.
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5. For each attribute or attribute group that you want to add to the parent group's properties:
a. Check the check box just right of this attribute or attribute group

b. If you want this attribute or attribute group to have a custom name in the parent group's
properties, type in that name in the text field just right of the check box.
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6. Repeat for each attribute you wish to publish.

7. In the Node view, navigate to the parent group by doing one of the following:
l

Click on the Up

arrow near the top of the node view.
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l

Click on the parent group's name in the hierarchy displayed at the bottom of the Node view.

8. Click on the Layer Properties

button for that group.

The group's Layer Properties dialog opens. In the group's layer properties, each attribute you chose
to publish are in a tab with the given tab name. You can edit those attributes from here, and the
changes will be applied to the node's attributes.
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9. If you don't want the attributes published to this group to also be published to this group's parent
group (if it has one), uncheck the Publish to Parent Groups option.
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About Displays
The Display node is an important node; it is used by the export and views to display your scene, primarily the
Camera and Timeline views. By default, a scene's node system always has a Display node which can be used to
show your entire scene, a single node or a group of nodes through a Composite or Group node. You might use it
to see one single character as you animate it, debug your node system as you create complex effects or export
your complete scene or a portion of it.

You can have more than one Display node in the Node view, so you can visualize different sections of the scene
without disabling or disconnecting elements that are in the way. This is useful in cut-out animation as it allows
you to see one puppet without viewing all the other characters. It's also useful during compositing and helps
you visualize and debug effects.
To use this display concept, show the Display toolbar which will let you select different Display nodes available
in the node system.
You can also use the Scene > Display menu to select the desired Display node to update the contents of the
Camera, Top, Side, Perspective, and Timeline views.
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When your scene does not have a Display node, it is automatically set to Display All which uses the Timeline
view ordering and shows floating nodes from the Node view. You can also set your scene to use Display All
using the Display toolbar.
NOTE
If you try to add a peg or other transformation layer in the Timeline view without having a layer
selected, an error message will display. Make sure to change to Display All. The peg layer will be
floating in the Node view and will not be visible in the Timeline view. The Timeline view shows only
layers that are connected to the Composite node.
If you switch to Display All, you run the risk of not realizing when you have floating nodes that are
not connected to your composite. For this reason, it is not recommended to work in Display All
mode.
When your scene contains many nodes and you cannot see them all, you can display all nodes at that level.
Harmony has two display modes. By default, it is set to the Basic Display mode.
When creating a scene in Basic Display mode, a Display node is automatically added to the node system and
connected to the final Composite node. All of the views are set to use this Display node. This means that only
the elements connected in that Composite node will show in the Camera view.
You can add and connect more Display nodes to your node system and select the one you want by using the
Display menu. In Basic mode, every view is set to the same Display node.
In Advanced Display mode, every view using the display concept has its own Display menu and each one can
be set to a different Display node. To switch from Basic to Advanced Display mode, you must enable the
Advanced Display option in the Preferences dialog box (Advanced tab). These Display menus allow you to set
the views to different displays. By default, all views are set to Default to follow the main Display toolbar
selection. However, you may want different views set on different displays. For example, you can have one
Camera view to display the full scene and another Camera view to only display the character being animated.
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In this case, you can set the first Camera view on the final display and the second on the character’s Display
node.

If you want the views to follow the main Display toolbar selection, set the display option of each display menu to
Default.
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Adding Display Nodes
To display different portions of your scene, you need to add several Display node to your project.

How to add a Display node
1. Do one of the followings:
l

In the Node view, press Ctrl + Y (Windows/Linux) or ⌘ + Y (macOS).

l

In the Node menu, select Insert > Display.

l

In the Node view, right-click and select Insert > Output > Display.

l

In the Node Library view, in the Output category, select a Display node and drag it to
the Node view.
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Changing Global Displays
Using the Display toolbar, you can change which display to view the scene from.

How to set a different Display node as a global display
1. Do one of the following:
l

In the Display toolbar drop-down, select a display.

l

From the top menu, select Scene > Default Display and select a display.

Each view is updated if set to the Default display option.
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Setting Advanced Display Options
You can set your views to show different display outputs simultaneously with the Advanced Display option.

How to enable the Advanced Display option
1. Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium >
Preferences (macOS).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. In the Preferences dialog box, select the Advanced tab.
3. In the Advanced Options section, select the Advanced Display option.
A Display menu appears in the top-left corner of the Camera, Timeline, Perspective, Top, and Side
views.
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Setting Properties for Many Layers
When working with several layers, you may frequently want to modify a series of settings. Instead of opening
the properties for each individual layer, you can set the properties for many layers so you can change a common
setting in a single click.
This allows you to modify the following settings:
l

3D Path or Separate mode

l

Use Embedded Pivot

l

Overlay

l

Line Art

l

Colour Art

l

Underlay

l

Animate Using Animation Tools
NOTE
You can access this function in the Node View toolbar. You can add the button to the Timeline View
toolbar through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script
section under the name Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_
many_layers.js.

How to set properties for many layers
1. In the Node or Timeline view, select all the layers you want to modify at the same time.
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2. In the Node or Timeline View toolbar, click the Set Properties for Many Layers

button. This option

is not available by default in the Timeline View toolbar. You must add it through the Customize
option. right-click on the toolbar and select Customize. In the Available Tools list, select Script: TB_
Set_Properties_on_many_layers and move it to the Toolbar list.
The Set Properties for Many Layers dialog box opens.

3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave
the As Is option selected to avoid modifying it. Each node will keep its original setting. Select any
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other options for all nodes to change to this parameter regardless of their original setting.
4. Click OK.
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Chapter 13: Cameras
T-HFND-009-001
Harmony contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis
offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera
position is centred and backed up to 12 fields.
It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field
chart. Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the
north-south (up-down) direction and the Z axis is the forward-backward direction.
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution and other parameters in the Scene Settings window. If you're working in a gaming animation
pipeline, you also have to possibility to set an orthographic camera.
By default, a scene does not have a camera layer. In order to be able to tweak the camera's angle and position,
you must add one to your scene. Although it is possible to have several cameras in the same scene, you can only
view your scene using one camera at a time. This can be useful if you are still working on your scene composition
and have different camera framing to try out.
The Camera layer is static which means that if you need to animate it, you must put it under a parent peg.
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You can reposition your camera frame directly in the Camera view, using the advanced animation tools.
Another way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing
this positions the camera precisely where you want it to be rather than gauging it visually.

Once you have a 3D set, the exciting part is to do a camera move in it. This section teaches you the main steps
required to perform a 3D camera move. Once you know how to do this, you can enjoy the delights of working in
3D space and traveling through your creations!

Clipping Planes
You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that
range is visible. This is useful when dealing with 3D elements and 3D sets. For example, the camera can be
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looking inside a 3D box or room and you might want the foreground wall to not obstruct the view of the
interior. By default, the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.

Camera Types
In Harmony, there are two types of cameras available:
l

Perspective

l

Orthographic

The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.
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The orthographic camera can be set in the Scene Settings dialog box. In order to create scenes with the
orthographic camera, by default, you need to create a new custom scene resolution.
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Adding a Camera
T-HFND-009-002
By default, there is no camera in the scene. The frame visible in the Camera view is only a reference based on
your project's resolution. In order to position your camera, you must add one to your scene.

How to add a camera in the Timeline view or Top menu
1. Do one of the following:
l

In the Timeline view, click the Add Layer

l

From the top menu, select Insert > Camera.

button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to add a camera in the Node view
1. In the Node Library view, select the Camera node from the Favorites or Move category.

2. Drag the Camera node to the Node view.
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Setting the Camera Type
You can set your camera to either Perspective or Orthographic. The orthographic is specifically used for gaming.
It removes any depth or perspective.

How to set the camera type
1. From the top menu, select Scene > Scene Settings.
2. Select the Resolution tab.
3. In the Projection section, select Orthographic or Perspective.
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Selecting the Active Camera
T-HFND-009-003
You can add multiple cameras to your scene, but only one can be active at a time. You can select your active
camera from the Camera list.

How to select the active camera from the Camera list
1. From the top menu, select Scene > Camera > camera.
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Positioning the Camera Frame
You can grab the camera frame and move it around in the Camera view. You can also setup the camera position
by entering coordinates and values in the Layer Properties view.

How to reposition the camera frame in the Camera view
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

From the top menu, select Animation > Tools > Translate.

l

In the Advanced Animation toolbar, click the Translate

l

Press Alt + 2.

tool.

3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the
camera layer from the Timeline or Node view.
The selected camera frame is highlighted.

4. Drag the camera frame to a new position.
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5. To tilt the camera frame, do one of the following to select the Rotate tool:
l

From the top menu, select Animation > Tools > Rotate.

l

In the Advanced Animation toolbar, select the Rotate

l

Press Alt + 3.

tool.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

7. To move the camera frame closer to or further away from the scene, do one of the following to select
the Scale tool:
l

From the top menu, select Animation > Tools > Scale.
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l

In the Advanced Animation toolbar, select the Rotate

l

Press Alt + 4.

tool.

NOTE
The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to set up the camera frame using the Layer Properties view
1. In the Timeline view, select the camera layer.
2. In the Layer Properties view, adjust the camera's properties.
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3. Type or use the numeric stepper to adjust the coordinate and angle values—see the Reference
guide .
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Resetting the Camera Position
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the
selected element to the initial value of the active tool. For example, if the Rotate tool is active, the
transformation angle will be reset to 0 and if the Transform tool is active, then all parameters values will be
reset.

How to reset the camera position
1. In the Tools toolbar, select the Transform

tool or press Shift + T. If you want to reset a single

parameter, select the corresponding Advanced Animation tool, such as the Rotate
2. In the Timeline, Node, or Camera view, select the camera layer.
3. From the top menu, select Animation > Reset or press Shift + R.
The camera automatically returns to its original position.
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Setting the Camera Clipping Planes
You can modify how far and how close the camera can see by adjusting the clipping planes.

How to modify the camera clipping plane
1. In the Timeline or Node view, select the Camera node.
2. In the Layer Properties view, go to the Clipping Planes section.

3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything
behind this plane will no longer be visible.
4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything
behind this plane will no longer be visible.
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Locking Drawings to the Camera Angle
When you create a 3D camera move in your scene, notice that layers are treated as flat objects. That is,
animation layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper.
Use the Ortholock layer when mixing flat animation layers with a set built in 3D. Ortholock forces your drawing
layer to always follow the Camera angle. It does not follow its position or zooming level, only the rotation. This
prevents drawings from being distorted by the camera motion.

NOTE
Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained
inside a symbol does not consider the position of the camera contained in the root scene. Keep your
Ortholock layers in the root scene.

How to add an Ortholock layer
1. In the Node Library view, select the Move category.
2. Select the Ortholock node and drag it to the Node view.
3. In the Node view, drag an output cable from the Ortholock node and connect it to the node you
want to keep facing the camera.
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Animating the Camera
T-HFND-009-009
A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static,
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate
the camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the
position and angle of the camera.

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or
Top views, which can be especially useful when animating a camera in a multiplane scene, where each layer is
positioned at a different distance from the camera, or if your scene contains 3D models.

How to animate the camera
1. In the Tools toolbar, enable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. In the Timeline view, select the Camera layer.

4. From the Layers toolbar, click the Add Peg

button.

A Peg layer appears directly above the Camera layer and is automatically attached to it. The new
Peg layer takes the name of the camera layer with the suffix -P added to indicate that it is its Peg
layer.

5. On the right side of the Timeline view, on the Camera Peg layer, select the frame at which you want
the camera movement to start.
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6. Do one of the following to add a keyframe:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as this keyframe.

7. Do one of the following to move the camera:
l

In the Camera view, select the Camera, which is now be represented by a thin yellow
rectangle with a red highlight, and move it to the desired position.

l

In the Top or Side view, select the camera, which is now represented by a large, yellow
V-shaped cone, and move it to the desired position.

1275

Harmony 15.0 Premium User Guide

8. On the Timeline view, click on the cell where the camera movement will end.
9. Do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe appears in that cell.

10. Select the camera in the Camera, Top or Side view and move it to the desired position.
11. In the Timeline view, select the first frame to rewind to the beginning of your animation.
12. In the Playback toolbar, click on the Play

button to preview your animation.
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Creating 3D Camera Movements
If you want to view your 3D camera move, you must be in the Perspective view.

How to create a 3D camera move
1. In the Tools toolbar, enable the Animate
2. In the Timeline view, click the Add Layers

mode.
button and select Camera to add a camera to your

scene.
3. In the Timeline view, select the new camera layer.
4. In the Timeline Layer toolbar, click the Add Peg

button to add a parent peg to the camera.

5. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.
6. In the Layer Properties dialog box, go to the Transformation tab and select the Enable 3D option.
7. In the Rotation section, select the Quaternion option.
8. In the Perspective view, click the Show/Hide Camera button to see your camera cone.
9. Setup your workspace to display the Camera view and Perspective view at the same time so you
can compare the results.

10. In the Tools toolbar, select the Transform

tool.

11. In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.

12. In the Timeline view, select the Camera-Peg layer.
13. In the Timeline view, go to the last frame.
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14. In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only.
Always do one axis at a time to keep control of the positioning.

15. Once the camera is rotated at the correct angle, grab one of the direction arrows to move the
camera to the correct position. A keyframe is automatically created in the Timeline view.
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Enabling the 3D Playback Mode
In order to see a playback of you animation in 3D, you need to turn on the option to see playbacks in the
Perspective view.

How to enable the playback mode in 3D
1. From the top menu, select Play > Enable Playback > Perspective View.
2. In the Playback toolbar, click the Play

button to see the results.
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Animating a Camera Shake Using the Quake Node
One very common camera move you will do is a camera shake. You can use the Quake node to generate an
automated quake instead of manually entering random keyframes. This way, you can simulate the shock of
something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake node to create a camera shake
1. From the Node Library view, drag a Quake node to the Node view.
2. If you do not have a Camera node already, drag one from the Node Library view to the Node view.
3. Connect the Quake node to the Camera node.

4. Click the Quake node's yellow square properties button to open the Quake properties.

5. In the Quake properties window, adjust the following parameters:
l

Hold Time: Enter the number of frames you want one of the quake vibrations
(position) to hold for. Most camera shakes are done in a single frame (1) or double
frame (2).
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l

Interpolate: An interpolation is generated between the random values. Instead of
jumping to the next position, it will slowly progress forwards to the next position. It's
the same principle as stop-motion keyframes and motion keyframes.

l

Move Amplitude: This is the strength of the quake. The higher the value, the stronger
the quake. If the value is set to 0, there is no motion. To have the motion start and stop
at a specific frame during the scene, you can create a function curve and animate the
amplitude over time. Simply click the Function

button to generate the function,

then click on it again to open the Function Editor.

l

Apply on X, Y, Z: Applies the quake to the X, Y and Z-axis.

l

Rotation Amplitude: When the value is higher than 0, a rotating quake is applied. The
higher the value, the stronger the quake.

l

Random Seed: Generates a different randomization pattern. If you cascade two
Quake nodes or more to apply a different amplitude on a different axis, you can change
the Random Seed value to generate a different randomization pattern. If the X quake
has a strong amplitude and the Y quake a weak amplitude and you do not want them
to follow the same random pattern, then set the Random Seed value of the Quake
nodes to different numbers.
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Animating the Line Thickness on Camera Move
As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements become
thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same size or become
thicker at a different speed, you can use the thickness feature to adjust your brush stroke and pencil line
thickness. You can modify the size of the lines even if the camera is not animated.

How to adjust the pencil line thickness of a drawing layer in the Camera view
1. In the Camera view, enable Render View

to see the effects of the pencil line thickness settings.

2. In the Timeline view, double-click on a drawing layer to display the Layer Properties window.
3. Select the Line Thickness tab.
4. Ajust the following parameters to have the desired pencil line thickness in the current frame and
camera position.

Adjust Pencil Lines Thickness: Enables the options below to adjust the line thickness in the
rendered image.
Normal Thickness: This setting makes the line thickness adjustments take one of two very
different behaviors:
l

Enabled: The line thickness settings are applied to pencil lines in all art layers in the
element. This setting should be used if you want to adjust the line thickness of pencil
lines.

l

Disabled: The line thickness settings are applied to all art, whether brush strokes or
pencil lines, in the line art layer, so that it fits the desired thickness pattern around art
in the colour art layer. This setting should be used for drawings that have their line art
on the line art layer and their colour art on the colour art layer, which is typical of
traditional and paperless animation productions.
NOTE
When this option is disabled, all artwork in the line art layer that does not
surround artwork in the colour art layer will be cropped out.
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Zoom Independent Thickness: Makes the thickness of pencil lines remain unchanged when
the camera zooms in or zooms out.
Proportional: The factor by which to adjust line thickness. The original line thickness in the
drawing will be multiplied by this value. A value between 0 and 1 can be used to make pencil
lines thinner.
Constant: The offset by which to adjust line thickness. This value will be added to the
original line thickness in the drawing. A negative number can be entered to make pencil lines
thinner.
Minimum: The minimum pencil line thickness allowed. Line thickness will not go below this
value.
Maximum: The maximum pencil line thickness allowed. Line thickness will not go above this
value. Set it to 0 to disable maximum line thickness.
5. To start animating the pencil line, create a function on one or more of the Proportional, Constant,
Minimum and Maximum parameters by clicking on their corresponding Bezier

button,

depending on which setting(s) would better accommodate the desired effect.
6. Click again on the parameter's Bezier

button to open the Function Editor for that function.

7. Use the Function Editor to animate the value of the parameter across the scene.

1284

Chapter 14: Import

Chapter 14: Import
Toon Boom Harmony allows you to import external content as well as being able to draw directly in the
software. This means that characters, backgrounds and videos created in other drawing, painting and
multimedia programs can be brought in and animated. You can import QuickTime videos, pictures, multilayered
.psd files, as well as .ai, .swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize
them.

NOTE
For sound import, refer to Importing Sound on page 1511.
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About Importing Bitmap Images
T-HFND-007-001
Images can come in many different file formats and are usually saved in a format that retains the original
specifications set by the image creator. Some formats can preserve the transparency or transparent layers,
while others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the
following bitmap image formats: JPEG, BMP, PNG (16 bits per channel RGB and RGBA), TGA, PSD (16 bits per
channel), TIFF, SGI, TVG, OMF, PAL, SCAN.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the
following options:
l

Keep as Original Bitmap: This imports the image exactly as is and ensures that it cannot be modified
when working on the scene. This is useful for using backgrounds that were created in different software
in your project.

l

Import as Toon Boom Bitmap Drawing: This imports the image as is, but allows you to edit it using
Harmony's bitmap drawing tools.

l

Import as Toon Boom Vector Drawing: Converts a bitmap into Toon Boom vector art, which can easily
be painted and edited using Harmony's vector drawing tools. This can be useful for importing line art
scanned or created using a different software.

When importing images or 3D models, or when linking images, the settings used to import are saved in your
user settings.
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Importing Bitmap Images As Original Bitmap
T-HFND-007-002
Importing a bitmap image in its original format ensures it is preserved exactly as is in Harmony. When
importing a bitmap image, you have several options available such as where you want to import the file and
how to name it.

How to import a bitmap image in its original format
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import >

button.

Images.
The Import Images dialog box opens.

2. In the Files section of the Import Images dialog box, click Browse to find and select one or more
images on your computer.
3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the
following options:
l

Create Single Layer Named: Creates a new layer with the specified name and imports
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the images into it.
l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

4. In the Vectorization section, make sure the Vectorize Image option is unchecked.
5. In the Import Options section, select the Keep As Original Bitmap option.
6. In the Alignment section, decide on the size and placement of your image within the camera frame.
You can choose between the following options:
Parameter

Description
Adjusts the image's size to fit completely within the scene's
field, both vertically and horizontally, making sure the entire
image is visible.
If the image's orientation is portrait, then it will adjust the
image's height to fit the field's height, without affecting the
image's aspect ratio:

Fit

If the image orientation is landscape, then it will adjust the
image's width to fit the field's width, without affecting the
image's aspect ratio:
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This has the opposite effect to the fit parameter. The image's
smallest dimension will be made to fit the scene frame's
matching dimension, and the image's largest dimension will
be adjusted proportionally, making the image fill the entire
scene field, and bleed past its boundaries it if its aspect ratio
does not match the field's aspect ratio. This option can be
used to import a panning background image, also referred to
as a pan.
If the image's orientation is portrait, it will adjust the image's
width to fit the field's width, without affecting its aspect ratio:

Pan

If the image's orientation is landscape, it will adjust the
image's height to fit the field's height, without affecting its
aspect ratio:

1289

Harmony 15.0 Premium User Guide

Scales the image to fit the scene's resolution, making each
pixel in the image take one pixel in the scene's field. For
Project Resolution

example, if the image's dimensions in pixels are half of the
scene's resolution in pixels, then the image's dimensions will
appear to be half of the scene field's dimensions.

7. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the
way the pixels along the edge are blended with the other colours. You can choose between the
following options:
Parameter

Description

Premultiplied with White

Individual pixels at the edge of an image are blended with
white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the
colour is clamped to the alpha, the colour value cannot be
higher than the alpha value. It calculates the real colour value
faster. When the RGB values are multiplied with the alpha
value, that is to say, if you have a pixel of value R=247,
G=188, B=29 and the alpha is 50% or the image has a 50%
transparency, then the actual RGB values that are output
would be half of the amounts listed above.

8. Click OK.
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NOTE
By default, bitmap images will display in low resolution in the Camera view so as to avoid
affecting playback performance. You can also adjust the display quality of a bitmap image by
selecting it with the Transform tool, then opening the Bitmap Image Quality dialog via View >
Bitmap File Quality. You can also preview your bitmap image in your scene's resolution by
activating the Render Preview

mode in the Camera view.
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Adjusting the Bitmap Image Display Quality
T-HFND-007-004
Your original bitmaps are imported as is in your project. In the Camera view, they may appear low quality as a
proxy image is displayed in its place to insure fast playback.
If the bitmap images that you imported look blurry or slightly pixelated, you can increase the image proxy
display by changing the quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality
1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is
encapsulated or simply select the bitmap image layer in the Timeline view if it's not.
2. Do one of the following:
l

From the top menu, select View > Bitmap File Quality.

l

From the Camera menu, select View > Bitmap File Quality.

l

Press Ctrl + Q (Windows/Linux) or ⌘ + Q (macOS).

The Bitmap Image Quality dialog box opens.

3. Drag the slider to the right to improve the quality.
4. Click OK.
5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and
return to your scene.
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Importing Bitmap Images As Toon Boom Bitmap
T-HFND-007-002
Importing a bitmap imageas Toon Boom bitmap preserves its original detail, but allows the user to modify them
using Harmony's bitmap drawing tools.

How to import a bitmap image as a Toon Boom bitmap drawing
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import >

button.

Images.
The Import Images dialog box opens.

1. In the Files section of the Import Images dialog box, click Browse to select one or more images from
your computer.
2. Select the destination for your images:
l

Create Single Layer Named: Creates a new layer with the specified name and imports
the images into it.
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l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

2. In the Alignment section, decide on the size and placement of your image within the camera
frame. You can choose between the following options:
Parameter

Description
Adjusts the image's size so that its height matches the
scene's height, without affecting its aspect ratio.

Vertical Fit

Adjusts the image's size so that its width matches the
scene's width, without affecting its aspect ratio.

Horizontal Fit
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Actual Size

Imports the image in its actual size, without adjusting its size
relative to the scene's resolution. For example, if the image's
dimensions in pixels are half of the scene's resolution in
pixels, then the image's dimensions will appear to be half of
the scene field's dimensions.

3. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the
way the pixels along the edge are blended with the other colours. You can choose between the
following options:
Parameter

Description

Premultiplied with White

Individual pixels at the edge of an image are blended with
white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white
and greys.

4. Click OK.
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Vectorizing Images on Import
You can import bitmap images as vector drawings, which allows you to edit them using Harmony's vector
drawing tools. This is especially useful to convert bitmap line art scanned or created in a different software into
vector line art so it can be painted in Harmony.

How to import and vectorize a bitmap image
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import >
Images.

The Import Images dialog box opens.
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1. In the Files section of the Import Images dialog box, click Browse to select one or more images from
your computer.
2. Select the destination for your images:
l

Create Single Layer Named: Creates a new layer with the specified name and imports
the images into it.

l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

3. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.
4. In the Vectorization section, decide whether you want to import your image in black and white or in
greyscale. You can also click the New Preset

button to create a custom vectorization parameter

preset.
‣

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based
drawing. The outlines of your drawings will be painted with the Vectorized Line colour swatch of
your scene's colour palette.

‣

Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep
the texture from the scan, and the white of the paper becomes transparent.
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NOTE
You can double-click on any of the presets at any time to open the Vectorization Parameters
dialog box to customize your option.
5. Click OK.
Your vectorized images will appear in their selected destination.
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Linking Layers to External Images
When working on a large production, you may want to centralize the backgrounds in one directory instead of
duplicating the background several times in different scenes. As backgrounds are generally reused in many
scenes, some studios like to save space on the server and link the different scenes to the background directory.
Also, if they modify one background, it is modified everywhere at the same time without having to reimport it.
To do so, you must use the Timing columns.
Timing columns are exposure sheet columns that link to files that are outside the scene’s structure. Because of
these external links, care must be taken not to break the links by moving the scene’s location or the
background directory’s location. Breaking a link will result in images not appearing in your scene.
NOTE
Refer to the Timing chapter in the Traditional Animation, Paperless Animation or Cut-out
Animation Guide to learn more about using Timing columns.
If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized server, you
can also use the Link to Images option.

How to link a layer to an external image
1. From the top menu, select File > Import > Link to Images.
The Link to Images dialog box opens.

2. Click the Browse button to select the image you want to link your scene to.

1299

Harmony 15.0 Premium User Guide

3. Do one of the following:
l

Select the Create Timing Layer option to create a new Timing column in the Xsheet
view. Then select one of the following:
l

Create Single Timing Named: Type the new column name in the text
field.

l

Create Timing(s) Based on Filenames: Creates file names based on the
selected file's name.

l

Select the Add to Existing Timing Layer option to insert the file into an existing
Timing column.

4. Select the Copy to Timings Directory option if you want to copy the selected file into the Timings
folder located in the scene directory. Note that the Timing column will link to the Timings folder.
5. Click OK.
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Importing Multi-layer PSD Files
T-HFND-007-003
PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain
multiple layers. This is advantageous as the image remains fully editable in terms of any colour correction,
effects, masking, transparency, or compositing that were made to the .psd file in Adobe Photoshop. Harmony
supports 8 and 16 bit files.

NOTE
Note that your .psd image file must be set to RGB mode within Adobe Photoshop prior to being
imported into Harmony.

How to import a multi-layer PSD file
1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or
that all the elements you want to import as a single layer in Harmony are grouped together in their
own folder. Any layer that is not in a folder group, by itself or otherwise, will not be imported.

2. In Harmony, go to the top menu and select File > Import > Images or click the Import Images
button.
The Import Images dialog box opens.
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3. In the Files section, click Browse to find and select the .psd image on your computer.
4. In the Layer section, select the Create Layer(s) option, then select one of the following options:
l

Create Single Layer Named: Creates a new layer with the specified name and imports
the images into it.

l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in
symbols.
6. In the Import Options section, select the following option to import your image as its original format.
l

Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment
section, decide on the size and placement of your image within the camera frame.
Depending on the Scene Settings (the height and width in pixels that you chose for
your project), an image that you import may get scaled to the point where all its
individual pixels become visible.

7. Decide whether to select Vectorize Imported Items option.
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8. Click OK.
The Multilayer Image Import Settings dialog box opens.

9. From the Create menu, select one of the following:
l

Single Layer: To import the Camera and Layout layers merged together.

l

Separated Layers: To keep your Camera and Layout layers separated.

10. From the Transparency menu, select one of Alpha option.
11. Click OK.
Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group
folders.
NOTE
The artwork displayed in every one of your layers as a result of a multilayer PSD
file import is linked to the same source image. This means that if you use the
Drawing > Delete Selected Drawings command to physically delete the drawing
from the project folder, the exposed drawing will be deleted in all layers at once.
Once deleted from the project folder, the image cannot be retrieved unless you
reimport your psd file.
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About Importing Vector Files
T-HFND-007-005
You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon
Boom format (TVG) and create a colour palette based on the colour settings of the original file.
When importing AI and PDF files:
l

RGB is supported, CMYK is not.

l

Gradients and textures are not supported.

l

Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and
Actionscript 3, cannot be imported.

l

When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be imported as
separate layers. The import will use the Illustrator file's top level groups as separate layer names.
However, you can change this behaviour by deselecting the PDF/Illustrator Import as Separate Layers
option, to import your file as a single layer .

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or
multiplaning, it can easily be imported into Harmony.
The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.
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Importing Adobe Illustrator (.ai) files and Portable Document Files
(.pdf)
T-HFND-007-006
You can import vector Adobe Illustrator (.ai) files as well as Portable Document Files (.pdf) through the
Library view and File menu. Make sure to have the rights to modify your Library folder and that the colours in
your file are encoded in RGB.

How to import an .ai or .pdf file
1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain
locked and you will not be able to import files.

2. Do one of the following:
l

In the top menu, select File > Import > SWF, Illustrator Files to Library.

l

Right-click on any unlocked folder and select Import Files.

The browser window opens.
3. Find and select your AI or PDF file in the Import Files dialog box and click Open.
The Rename dialog box opens.

4. Type in a name for the new template or keep the name of the original AI or PDF file.
5. Click OK.
A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until
the copy cursor

appears before releasing the folder.
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The message window opens.
7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session
option if you plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under
the imported file’s name.
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Importing Flash Movies (.swf)
You can import Flash (.swf) files in Harmony exported for any version of Flash Player up to version 14.
IMPORTANT
Some effects are not supported when imported from Flash movies into Harmony.

How to import a SWF file
1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the
library folder. Make sure the Lock icon disappears from the folder. If not, your library will remain
locked and you will not be able to import files.

2. Do one of the following:
l

In the top menu, select File > Import > SWF, Illustrator Files to Library.

l

Right-click on any unlocked folder and select Import Files.

The browser window opens.
3. Find and select your.swf file from the Import Files dialog box and click Open.
The Rename dialog box opens.

4. Type a name for the new template or keep the name of the original *.swf file.
5. Click OK.
A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until
the copy cursor

appears before releasing the folder.
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7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before
clicking the Yes button, you have the option of selecting the Do Not Ask Again For This Session
option. This might be useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created
under the imported file’s name.
NOTE
All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT
DELETE THIS PEG. To maintain the look of your movie, it's important not to delete this peg or
detach its child layers.
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The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become
regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or
drawings within symbols collapse into their corresponding parent symbol.
NOTE
Some layers in your .swf movie may be combined in a single layer as a result of optimization
enhancements in your movie file. You can easily move these elements back onto separate
layers.
In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are
grouped together in one folder. In our example, this means that when you scroll through the
Drawing Substitution preview in the Library view, the different hand, leg, tentacles, antennae, torso
and facial positions are all organized together.
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Distributing SWFs to Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers
might be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers
again.

How to distribute to layers
1. In the Tools toolbar, click the Select

tool.

2. In the Camera view, select the drawing that contains elements you want to redistribute onto
individual layers. To select the all the elements of the selected drawing layer, press Ctrl + A
(Windows/Linux) or ⌘ + A (macOS).
3. Do one of the following:
l

From the top menu, select Drawing > Distribute to Layers.

l

In the Tool Properties view of the Select tool, click the Distribute to Layers

button.

The number of drawing layers corresponding to the different grouped elements are created in the
Timeline view. The selected elements in the original drawing layer are removed. Each element is
distributed onto a new drawing layer.
4. Repeat the process for each drawing that contains elements to redistribute.
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About FLA Import
You can export files from Flash and import them in Harmony to transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and macOS. It is not possible to do so on
GNU/Linux versions.
On the Flash side, users can work with these versions:
l

Adobe Flash CS5

l

Adobe Flash CS5.5

l

Adobe Flash CS6

l

Adobe Flash CC

l

Adobe Flash CC 2014

l

Adobe Flash CC 2015
NOTE
Exports from older versions of Flash are not possible.

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape
lines, drawing objects, groups and bitmaps at the scene level won’t be exported. If these elements are present,
you will be prompted to perform a clean up of the scene level. For details on importing Flash files, see Flash
Export and Import Guidelines on page 1329
As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe
Extension Manager—see Installing the Export to Harmony Option on page 1313.
It is important to use the correct version of Adobe Extension Manager:
l

If more than one version of Flash is installed on your computer, be careful where you install the extension.
If it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in this version
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and not the other.
l

If you have a previous version of the extension, you must remove it first and install the latest extension—
see About FLA Import on page 1311.

Harmony includes a script specially created to import FLA Export packages. You must add this script to your
interface in order to use it—see Displaying the Import Flash Scene Icon on page 1324.
When you export your FLA files, a folder will be created that contains the stage.tpl and export.json files,
as well as all the .swf and.txt files in your scene. The export.json file is used by a Harmony script to
organize and construct the node system from your exported files.
Once the Flash project is successfully imported into Harmony, here's how the node system was constructed:
l

Each symbol has its own peg in which all the transformation information is stored.

l

Whenever there are more than three symbols nested inside a symbol, a Composite node is automatically
created to group them all.

l

The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came
from the rotation point of the symbol in Flash.

l

Registration point of the symbol in Flash represents the centre of the drawing space in Harmony.
Therefore, the position of the drawing inside a symbol will be exactly the same in Stage.

l

The imported node system is connected to the Composite of the scene, which contains the Write and
Display nodes.

l

One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you
have more than one zone using the same colour, they will be linked to the same colour swatch.

l

If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects.
Harmony is now able to understand when more than one symbol share the same mask in Flash. Each
symbol sharing the same mask will be grouped by a composite and connected to the cutter.
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Installing the Export to Harmony Option
The extension is required in order for Flash to export files to Harmony. The extension is called Export to
Harmony.zxp and is located here:
OS

Windows

macOS

Edition

Location

Premium

C:\Program Files (x86)\Toon Boom Animation\Toon Boom
Harmony [version] Premium\resources\flash

Advanced

C:\Program Files (x86)\Toon Boom Animation\Toon Boom
Harmony [version] Advanced\resources\flash

Essentials

C:\Program Files (x86)\Toon Boom Animation\Toon Boom
Harmony [version] Essentials\resources\flash

Premium

Applications > Toon Boom Harmony [version] Premium > tba >
resources > flash

Advanced

Applications > Toon Boom Harmony [version] Advanced > tba
> resources > flash

Essentials

Applications > Toon Boom Harmony [version] Essentials > tba
> resources > flash

NOTE
Before installing the extension, you must remove all Harmony offline and database preferences.

How to install the Export to Harmony extension
1. Launch Adobe Extension Manager.
2. In the top-right corner of the Adobe Extension Manager, click on Install.
An Open dialog appears.
3. In the Open dialog, browse to and select the Export to Harmony.zxp file, then click on Open.
A message opens informing you that you're about to install the Export to Harmony extension.
4. Click on Accept.
You may see the following message confirming that you want to install the extension. Click Install.
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5. In order for the changes to take effect, you must close and restart Adobe Flash.
6. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)
1. If open, close Adobe Flash.
2. Start Adobe Extension Manager.
3. From the Products list, select Adobe Flash.
If you have a previous version of the Export to Harmony.zxp extension installed, it will be
listed in the right pane.
4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.
5. Click Yes.
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Adobe has stopped maintaining and updating their Extension Manager CC, therefore, it has become difficult to
install extensions. In order to link an extension from Animate CC, follow the steps below.

How to install an extension on Windows with Adobe Animate CC version 2015 and
higher
1. Ensure the following software is installed:
l

Adobe Creative Cloud

l

Animate CC and Mobile Device Packaging

2. Download the ExManCmd from Adobe’s website.
https://docs.toonboom.com/go/download/ExManCmdWin
3. Unzip the ExManCmd_win.zip package.
4. Put the ExManCmd_win folder in a safe place.
NOTE
The ExManCmd_win folder must not be deleted; this folder is necessary for
installing or updating .zxp files.
5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads
folder:
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 15.0
Premium\resources\flash\flashexport.zip
6. Unzip the flashexport.zip package.
7. Open the folder containing the unzipped files.
8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.
9. In the ExManCmd_win folder, hold Shift and right-click to select Open command window here.
10. Enter the following command:
ExManCmd.exe /install <filename.zxp>.
11. Press Enter.
If no error message displays, the extension has been installed on your computer and recognized by
the Extension Manager CC.
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12. Open Animate CC.
13. Access Top Menu > Commands.
If the Export to Harmony option appears in the Top Menu > Commands list, your installation was
successful.

NOTE
If you have a region language other than English (US) installed on your computer,
or if you have more than one language installed on your computer, Animate CC
may not be able detect in which language folder the extension has been
installed. If this occurs, you will not be able to see the Export to Harmony menu
option in Top Menu > Commands list. To correct this, proceed to How to ensure
Adobe detects extension files installed on your computer on page 1316.

How to ensure Adobe detects extension files installed on your computer
1. Browse to:
C:\Users\<UserName>\AppData\Local\Adobe\Animate <VersionNumber>
If Adobe detects more than one language on your computer, you will see multiple language folders in
the path.
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For example:

2. Look inside each folder to detect the main language used by Adobe on your computer. To do so,
compare the contents of both folders.
For example, inside the en_Ca\Configuration:

For example, inside the en_US\Configuration:
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The main folder is the one with more files. In this case, Adobe is using English (US) as the main
language. The folder en_CA only contains what was installed with the extension installation:
commands, Javascript and WindowSWF.
3. Copy and paste the contents of the commands folder within the sub-language folder, to the
commands folder within the main language folder .
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4. Copy and paste the contents of the Javascript folder within the sub-language folder, to the
Javascript folder within the main language folder.

5. Copy and paste the contents of the WindowSWF folder within the sub-language folder, to the
WindowSWF folder within the main language folder.
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How to install an extension on macOS with Adobe Animate CC version 2015 and
higher
1. Ensure the following software is installed:
l

Adobe Creative Cloud

l

Animate CC and Mobile Device Packaging

2. Download the ExManCmd from Adobe’s website.
https://docs.toonboom.com/go/download/ExManCmdMac
3. Unzip the ExManCmd_mac file.
4. Put the ExManCmd_mac folder in a safe place.
NOTE
The ExManCmd_mac folder must not be deleted; this folder is necessary for
installing or updating .zxp files.
5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads
folder:
/Applications/Toon Boom Harmony 15.0 Premium/tba/resources/flash/flashexport.zip
6. Unzip the flashexport.zip package.
7. Open the folder containing the unzipped files.
8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.
9. Drag and drop the .zxp file directly into the ExManCmd_mac folder.
10. In Terminal, go to the folder where the ExManCmd_mac package was extracted.
For example, if you have put the ExManCmd_mac folder into the Downloads folder:
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cd Dowonloads/ExManCmd_mac/
11. Enter the following command:
Contents/MacOS/ExManCmd --install <filename.zxp>
12. Press Enter.
If no error message displays, the extension has been installed on your computer and recognized by
the Extension Manager CC.

13. Open Animate CC.
14. Access Top Menu > Commands.
If the Export to Harmony option appears in the Top Menu > Commands list, your installation was
successful.
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Exporting FLA Files
How to export FLA files for Harmony from Adobe Flash
1. Open your.fla file in Adobe Flash.
NOTE
In case of a new file, it needs to be saved before continuing the exportation process. If not, the
export won't be completed.
2. Return to the scene level.
Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.
3. Do one of the following:
l

Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony.

l

Adobe Flash CC: Window > Extensions > Export to Harmony.

NOTE
This window must be opened once after installing the extension in the extension manager
because it creates a drect link to Harmony (even if the window is not used). Afterwards, you do
not have to reopen it if there is no need to change the option.
The Export to Harmony window opens from which you can set the resolution of the files as it will
appear in Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value
of Harmony. If needed, you can change the compression: Photo (JPG) or Lossless (PNG).

4. Do one of the following:
l

In the Export to Harmony window, click Export button.

l

Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:
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Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all
groups to verify if any symbols are hidden inside, breaking drawing objects to transfer them as
shapes, drawing substitutions, and so on. Problematic situations will also be mentioned. If nothing
appears in the Output tab, then your.fla file is clean and does not need any conversions.
The .txt files contain the drawing substitution information and at which frame they are exposed.
A .swf file is created for each symbol in Flash and a .tpl file is created of them. The corresponding
export.json file is also created, which you will need when importing your Flash scene in Harmony.
These files are in a folder located at the same location as the.fla file. The folder name is the same
as the .fla file.
NOTE
If a folder with the same name as the .fla file already exists, you will be prompted to replace
the folder. Be aware that saving Flash projects as .xfl files will automatically create a folder
with the same name as the .fla file. In this case, the folder of the export will be created inside
the folder of the xfl. If this not what you want, place a copy of the.fla in another path on
your computer before the export.
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Displaying the Import Flash Scene Icon
When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash
Scene icon. If the icon does not appear in the Scripting toolbar, add it to the toolbar. Note that you will only
have to do this once. After that, you can import Flash files whenever needed.

How to display the Flash Import script icon
1. From the top menu, select Windows > Toolbars > Scripting.
The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

2. Click the Manage Scripts

button.

The Scripts Manager opens.

3. From the Files section, select TB_Import_Flash_Scene.js.
On your computer, here is the location of the script file:
l

Windows:
l

Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon
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Boom Animation\Toon Boom Harmony\1400-scripts
l

Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon
Boom Animation\Toon Boom Advanced\1400-scripts

l

Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon
Boom Animation\Toon Boom Essentials\1400-scripts

l

macOS:
l

Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/1400-scripts

l

Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon
Boom Animation/Toon Boom Advanced/1400-scripts

l

Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom
Animation/Toon Boom Essentials/1400-scripts

On macOS, the Library folder is a hidden folder. To display the display the folder, told down the Alt
key.
l

Global: [Server_Name] > USA_DB > scripts

l

Environment: [Server_Name] > USA_DB > environments > [environment_name]

l

Job: [Server_Name] > USA_DB > jobs > [job name]

l

User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-scripts

5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to
the In Toolbar section.
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6. Click OK.
The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash
scenes.

1326

Chapter 14: Import

Importing FLA Files
Once your extension is installed, your FLA file has been exported and your displayed the FLA import script in
your toolbar, you are ready to import your FLA file in Harmony.

How to import FLA files
1. In the Scripting toolbar, click the Import Flash

button.

2. In the Import Files dialog box, locate the export.json file contained in the folder that was created
when you exported your files from Flash.
3. Click Open.
In a few moments, the colour recovery dialog box appears, requesting a colour recovery.

4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option.
In a few moments, the .fla files are imported in Harmony.
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5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.
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Flash Export and Import Guidelines
The following points are guidelines for you to create optimal Flash files to export to or import in Harmony.
The following are limitations that apply when importing .swf files, whether they were exported specifically for
Harmony or just regular Flash Movie files.

Drawing Features
l

The line width will be preserved, whether it's constant or varied with the Width tool.

l

Any line caps and line joins other than round will be converted to round line caps and line joins

l

The flow of gradients must be set to Extend Color, which is the default flow for gradients. Gradients with
a Reflect or Repeat flow will cause the entire symbol in which they're located to be ignored.

Effects
The following effects will not be imported by Harmony:
l

Filters (ie: Adjust Colour, Drop Shadow, Bevel, etc.)

l

Colour Effects (ie: Alpha, Advanced, Brightness and Tint)

l

Blending (ie: Layer, Darken, Multiply, etc.)

l

Render: Cache as Bitmap (Export as Bitmap is supported)

l

3D Rotations

l

Component properties

Bitmap Images
Bitmap images must be either .jpg or .png format. Symbols that have their Render mode set to Cache as
Bitmap will also be imported.

Flash Export Guidelines
The following are rules to follow when exporting assets from Flash for import in Harmony.

Scene Root
What can be at the scene root:
l

Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:
l

Shapes: Colour shapes and line shapes

l

Bitmaps
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l

Drawing objects

l

Groups: The group works differently at the scene level. They are understood as shapes at the scene
level—see Flash Export and Import Guidelines on page 1329.

Timeline
These features can be used in the Flash file, but will not appear when imported in Harmony.
l

Guide layers for references

l

Locked layers

l

Disabled layers

l

Folders in the Timeline view

l

Other: Several symbols on the same layer/keyframe. Harmony will spread them over several drawing
layers, implicitly performing a Distribute to Layers operation in the process.

Not recommended:
l

Mixed layers—see Flash Export and Import Guidelines on page 1329

l

Symbols, shapes, bitmaps and groups in the same layer/keyframe

l

Symbols with drawing objects

Library View
In the Library view, the following will not be exported:
l

ActionScript Linkage

l

Embedded fonts

Mixed Layers
Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony.
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers
altogether.
A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be
a mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony
understands symbols better than groups or drawing elements, some information can be lost along the way.
Parameter

Description

Drawing Objects

No matter what is inside a drawing object, it will always be understood as a
shape. So if a drawing object shares the same layer with a shape, it won’t be a real
mixed layer, since they are all understood as shapes.
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When there is a symbol inside a group, the group will be ungrouped
automatically during the export from Flash. The symbol inside it will be
understood by Harmony as a Drawing node.
Groups that Contain Only
Symbols (MovieClip or
graphic)

Groups that Contain
Symbols and Shapes

Symbols and Groups on the
Same Layer

But if there is more than one symbol inside the group, all the symbols will be
understand as if they were only one symbol. For example, if you have a group
containing five MovieClips and one graphic, Harmony will create one Drawing
node to contain the five MovieClips and one graphic. This can be useful when you
want to create a repetitive texture and you don’t want to have each repetition
separated in Harmony. There is no differentiation between symbols.
When there is one or more symbols with shapes inside the same group, the
group will be ungrouped automatically during the export from Flash, but all the
symbols and shapes will be exported as if they were one symbol. There is no
differentiation between symbols and shapes.
If there are symbols and groups sharing the same layer, each symbol will be
separated from all the groups which will then be grouped together as one
element. In Harmony, each symbol will have its own Drawing node, but all groups
share one Drawing node. Since only symbols can have a name, its name is
propagated to the Drawing node and peg.
Groups, however, will receive the name of the MovieClip followed by an
underscore and an appropriate number. For example, of you have a group inside a
symbol called HEAD, the group will receive the name HEAD_1 if there is already a
Drawing node that was created with the same name.

Symbols and Drawing
Objects/Shapes on the Same
Layer

If there are symbols and drawing objects/shapes sharing the same layer, the
symbols will be separated from them and all the drawing objects/shapes will be
kept together. Drawing objects and shapes cannot be separated. In Harmony, the
symbols will have their own Drawing node and the drawing objects/shapes will
share the same Drawing node. Since only symbols can have a name, its name is
propagated to the Drawing node and peg.
Drawing objects and shapes, however, can't do this. Drawing objects and shapes
will receive the name of the MovieClip followed by an underscore and an
appropriate number. For example, if you have a group inside a symbol called
HEAD, the group will be named HEAD_1 if there is already a Drawing node that
was created with the same name.

Groups and Drawing
Objects or Shapes on the
Same Layer

In order to have groups and drawing objects/shapes on the same layer, these
elements must first be inside a symbol. Groups and drawing objects/shapes
sharing the same layer in Flash will be exported as one Drawing node. This
Drawing node will contain both drawing objects and shapes, and receive the
name of the symbol in which they are contained.

Mixed Instances at the Same

Mixed instances at the same level as a symbol can occur when, at the same level
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inside a symbol, there is more than one type of element sharing the same timeline
at a specific frame. Those elements may be mixed layers.
Type of problems that can occur if mixed instances are kept:
Level as a Symbol
l

Order of appearance can be lost

l

Some layers can merge together

l

Transparency of shapes can cut other shapes
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Importing PSD Layouts
T-LAY-006-002
If you exported a Photoshop layout image from a Harmony project using the Export Layout Image function, you
can easily import it back into Harmony, simply be sure to import it at the beginning of the project for accurate
scene planning.
NOTE
Harmony supports both .psd and .psb file formats.

NOTE
For information on exporting PSD layouts, see About PSD Layouts on page 1673

How to import a PSD layout
1. In your Harmony project, select File > Import > Images.
The Import Images dialog box opens.

2. In the Files section, click Browse to find and select the .psd or .psb layout file on your computer. Note
that this layout file must have its corresponding .xli file in the same folder.
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3. Once you have selected the layout file, the Use Position Information Contained in XLI File option
appears in the Layer section.
This option is enabled by default. When you import the layout image in your scene, it will be
automatically positioned to fit the original layout scene creating an accurate layout guide. You can
disable this option if you want the imported layout image to be imported according to the normal
behaviour of the import process. The layout image will be incorrectly aligned as it was when it was
first created.

4. In the Layer section, select the Create Layer(s) option, then select one of the following options:
l

Create Single Layer Named: Creates a new layer with the specified name and imports
the images into it.

l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

5. Select the Create Symbol for Imported Items option if you want the layers to be contained in
symbols.
6. In the Layer section, select the Create Layer(s) option, then select one of the following options:
l

Create Single Layer Named: Creates a new layer with the specified name and imports

1334

Chapter 14: Import

the images into it.
l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this
will create two layers, one named "a" and one named "b". Layer "a" will contain the
two first images and "b" will contain the third one.

l

Add to Existing Layer: Imports the images into the specified layer. Note that you can
only import into layers that are compatible with your import options. For example, if
you're importing images as vector drawings, you can only import them into vector
drawing layers.

7. Select the Create Symbol for Imported Items option if you want the layers to be contained in
symbols.
8. In the Import Options section, select the following option to import your image as its original format.
l

Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment
section, decide on the size and placement of your image within the camera frame.
Depending on the Scene Settings (the height and width in pixels that you chose for
your project), an image that you import may get scaled to the point where all its
individual pixels become visible.

9. Decide whether to select Vectorize Imported Items option.
10. Click OK.
The Multilayer Image Import Settings dialog box opens.

11. From the Create menu, select one of the following:
l

Single Layer: To import the Camera and Layout layers merged together.

l

Separated Layers: To keep your Camera and Layout layers separated.

12. From the Transparency menu, select an alpha option—see the Reference guide .
13. Click OK.
Your image appears as separate layers in the Timeline view, corresponding to the .psd layer group
folders Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.
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Importing QuickTime Movies
T-ANIMPA-004-002
When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Toon Boom Harmony allows you to import QuickTime movies into your project.

How to import a QuickTime movie
1. From the top menu, select File > Import > Movie.
2. Browse for the QuickTime movie to import and click Open.
The Import Images dialog box opens.
NOTE
Do not browse for the movie file again. Leave the automatically generated field text as “many
files selected”.

3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see the
Reference guide .
4. Click OK.
The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the
film frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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About Scanning
Harmony can receive images from any TWAIN device, such as scanners or digital cameras. You can load these
images as bitmaps into your scene or convert them into vector-based images that can be edited using
Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of
your device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the
digital exposure sheet.
Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import
them in Harmony. The scanning process is the point where the traditional production becomes digital. It's the
moment where you use Harmony to control the project.
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Scanning Images
Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be
edited using Toon Boom Harmony.
If your operating system does not automatically recognize your device after it has been connected, you must
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the
device manufacturer’s website.

How to scan images
1. From the top menu, select File > Import > From Scanner.
The Scan Drawings window opens.

2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the
Scanner menu. If none are available, check your device to ensure that it's properly connected to your
computer. If your device still does not appear in the menu, you may have to shut down and restart
the software.
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3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or
existing layer—see the Reference guide .
4. In the Import Options section, select the type of image you want to create—see the Reference guide
.
5. In the Alignment section, decide on the size and placement of your scanned image within the
camera frame. Depending on the scene settings (the height and width, in pixels, that you chose for
your project), an image that you scan may be scaled to the point where all its individual pixels
become visible—see the Reference guide .
6. In the Drawing Options section, set the following options if desired:

l

Drawing Name: Name of the drawing to import.

l

Hold Value: Type the number of frames that the drawing will be exposed.

l

Scan and Advance: Lets you scan one drawing after another every time you click
Scan.

l

Flip Drawing: Mirrors the drawings horizontally and scans it this way.

7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the
view.

8. Click Scan to scan your drawing.
9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next
letter to capture your next frame.

10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until
you have finished scanning all your drawings.
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Vectorizing Scanned Drawings
You can turn scanned images into vector drawings, while maintaining the sketchiness of a pencil line or into
vector images with a bitmap fill. Both options can add life to an animation, which straight vectorization with
smoothing does not usually afford.

How to scan and vectorize drawings
1. From the top menu, select File > Import > From Scanner.
The Scan Drawings window opens.
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2. Select your scanner from the Scanner list.

3. Click Preview to get a test scan of your drawing.
4. In the Layer section, select one of the following:
l

Create Layer: Imports an image into a new layer. Type a name for the layer in the
Name field.

l

Add to Existing Layer: Imports the image into an existing layer. Select a layer from the
Layer list.

5. In the Import Options section, select the Convert to Vector Drawing option.
6. In the Vectorization section, set the following:

l

Black and White: Vectorizes drawings as a solid black line; creates a 100% vectorbased drawing. Set the Threshold and Smooth parameters.

l

Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling.
Lines keep the texture from the scan, and the white of the paper becomes
transparent.

l

New Preset: Lets you create a new preset.

l

Delete Preset: Lets you delete any preset in the list.

l

Custom vectorization: Lets you set custom vectorization parameters—see About
Custom Vectorization Parameters on page 1343.

7. In the Drawing Options section, set the following options if desired:
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l

Drawing Name: Name of the drawing to import.

l

Hold Value: Type the number of frames that the drawing will be exposed.

l

Scan and Advance: Lets you scan one drawing after another every time you click
Scan.

l

Overwrite: Lets you overwrite existing drawings—see Vectorizing Scanned Drawings
on page 1340.

l

Flip Drawing: Mirrors the drawings horizontally and scans it this way.

8. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the
view.

9. Click Scan to import your drawing.
10. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next
letter to capture your next frame.

11. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until
you have finished scanning all your drawings.
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About Custom Vectorization Parameters
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be
saved, shared and also inserted into the VectOptions.conf file used by the Harmony Scan and Control
Center modules when scanning or vectorizing a series of drawings.
You can use an interface to select and test the different options, as well as type in some advanced settings.
The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure
red, blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting
in your tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker
window and watch the indicator colour zone lines disappear.
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Creating Vectorization Styles
With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to
set the Harmony Scan module vectorization style list.
You can vectorize drawings using one of the following methods:
l

Black and White: All the lines become vector based and 100% black. The white areas become
completely transparent.

l

Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained
inside a vector frame. The white areas become completely transparent.

l

Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and
turn them into 100% vector lines, preserving their original colours—see the Reference guide .

How to create or modify the vectorization parameters
1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization
parameters (i.e. from the scanner).
2. In the Scan Drawings window, do the following:
l

In the Layer section, decide on the layer options.

l

In the Import Options section, select the Convert to Toon Boom Vector Drawing option

l

Click Preview.

3. In the Vectorization section, click the Vectorization Parameters

button.

4. The Vectorization Parameters dialog box opens.
5. Set the different options available in the Vectorization Parameters dialog box—see the Reference
guide .
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6. Click the Vectorize button to update the Vectorized Image preview.
The vectorized image is just a preview. The actual vectorization happens when you click OK in the
Import Images dialog box. There are many options to try in the Vectorization Parameters dialog box.
These are applied during the vectorization process.
7. To set advanced parameters, read the information on the Help tab, then type in the Advanced
Options field at the bottom of the dialog box.
8. To save your vectorization parameters to reuse them later, share them, or use them to set the
Harmony Scan module vectorization style list, click Save.
9. In the Browser window, name and save the file.

10. To save the current settings as your default settings, click Save As Default. To restore the default
settings, click Restore Defaults.
11. To load a vectorization style, click Load and locate the existing *.vof file.
12. Click OK.
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Configuring the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to
create your own to fit your production style.

How to set the VectOptions.conf file
1. Launch Configuration Editor:
l

Windows: Open the Start menu and, in the Programs list, select Toon BoomHarmony 15.0
Premium > Tools >

l

Configuration Editor.

macOS: In Finder, go to Applications > Toon BoomHarmony 15.0 Premium> Tools >
Configuration Editor.

l

GNU/Linux: In a terminal, type the following command:
$ sudo /usr/local/ToonBoomAnimation/harmonyPremium_15.0/lnx86_
64/bin/ConfigEditor

The Configuration Editor window opens.
2. In the bottom section of the window, select the VectOptions.conf tab.

3. Scroll down the VectOptions.conf file to see all the different options available for creating your
custom vectorization style. These options are the same as in the Vectorization Parameters dialog
box. It is recommended that you create your vectorization style using Harmony and the

1346

Chapter 14: Import

Vectorization Parameters window and copy the result parameters in this file—see About Custom
Vectorization Parameters on page 1343
4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new
ones to the list using the parameters you got using the Vectorization Parameters window. Notice
that some of the lines have a “#” sign at the beginning to indicate that the line is a comment and will
not appear in the style list. The lines that have no sign at the beginning appear in the style list.

5. To create a new style, type the following below the existing styles:
style_name:
This should be followed by the name of your new style. For example: style_name: Black
Lines.
6. Under the style name line, type the following:
options:
7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization
Parameters window.
‣

To open the *.vof file, use any plain text editor application.
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8. In the Configuration Editor’s top menu, select File > Save.
9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify
that the new style appears in the Vectorization Style list under Edit > Vectorization Style.
NOTE
If you are using the batch processing method available with Toon Boom Harmony Server to
scan and vectorize drawings, the selected style must be available on all the machines included
in the batch processing list.
Refer to the Harmony Server Guide Guide to learn more about setting up and using batch
processing.
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Overwriting Using Scanned Drawings
At times, it might be more efficient to create a scene and fill in the exposure sheet before scanning. Then you
can simply scan your drawings to fill in the necessary cells in the exposure sheet. Note that when you start
scanning, the drawings are named sequentially regardless of whether there is an exposure or not in the
Xsheet.

How to overwrite existing drawings
1. In the Xsheet, select the first cell to overwrite.
2. From the top menu, select File > Import > From Scanner.
3. In the Scan Drawings window, do the following:
l

Scanner: Select your scanner from the list.

l

Layer: Select the Add to Existing Layer option.

l

Import Options: Select the Convert to Toon Boom Vector Drawing option.

l

Vectorization: Select an appropriate option: Black and White or Grey, or create a new
preset.

l

Drawing Options: Select the Overwrite option.
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4. Click Preview.
The scanner window opens.
5. Make any necessary adjustments to the image before scanning, then click Preview.
6. In the Scan Drawings window, click Scan.
The scanned drawing replaces the selected cell in the Xsheet, filling the entire exposure. The
Drawing Options section indicates the name of the cell the drawing overwrote and its exposure
value.
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Chapter 15: Effects
T-HFND-010-001
When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs,
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the
way layers or groups of layers are rendered in your scene.

Harmony supports OpenFX plugins, and has its own integrated particle systems as well as light shading
(normal map)—see About OpenFX on page 1489, About Light Shading in Harmony on page 1470, and About
Particles on page 1465.
Effects are special types of nodes that you can add to your scene's structure. For an effect node to work, it must
be connected under a drawing, a composite, another effect, or any other node that outputs an image. Effect
nodes alter the image information sent to their input port, and output the processed image through their
output port. This gives you flexibility in deciding which elements of your scene are affected by an effect.
Some effects need to be linked to another layer, referred to as a matte layer, which is used to define the area
they should affect. A good example of this is the Tone effect, which is used to add a shadow of a given shape to
a layer. Alone, the Tone effect has no impact on the drawing it is connected to. Once combined with a matte
layer, the Tone effect will use the matte's shape to apply a shadow to the drawing. Even if the matte's shape
bleeds outside of the drawing's outlines, the shadow will only be applied within the drawing's outlines.
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A matte layer is simply a regular drawing layer that is connected to an effect as its matte. The effect takes the
shape of the drawing in the matte layer to determine the area of the drawing it affects. The colours and details
in the matte layer are ignored by the effect, only its shape is taken in account.
In the Node view, an effect must be connected to the drawing or composite it is meant to affect by its input
(top) port, and its output (bottom) port must be connected to the scene's main composite.

If the effect can use a matte layer, it will have a matte port on its left to which the matte layer can be connected.

The matte port has a Matte

icon underneath it. You can invert the matte by double-clicking on this icon,

which will make the effect use the negative space of the matte drawing rather than the matte drawing itself as
its matte. When an effect's matte is inverted, the Matte appears black on white instead of white on black:

.

Once your effect is connected, you can adjust its parameters by selecting it, then adjusting its parameters using
the Layer Properties view. You can also click on a node's Layer Properties

icon to open its layer properties in

a dialog. If desired, you can even animate the parameters of your effect by converting their values to functions.
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TIP
If you need to use the uncut version of your drawing layer anywhere else in your scene, you can
bypass the effect it is connected to by connecting the drawing layer's output port to other input
ports of your composite, or to other effects or composite, as needed. This will create new cables,
leaving your layer's connection to its effect unaffected.
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Adding Effects Nodes
T-HFND-010-004
In Harmony, you can add effects through the Node view. You can select an effect from the Node Library view,
drag it to the Node view and connect it to drawing layers to form a network of nodes. Then, by adjusting each
node's parameters, you can achieve exactly the look you have in mind.

How to add an effect
1. Do one of the following:
l

In the Node Library view, select an effect and drag it to the Node view. You can use the
Search toolbar to find nodes quicker.
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TIP
You can use the Search

field in the Node Library view to search for a node by

name.

l

In the Node view, right-click and select Insert, select the category of the node you want to
add, then select the type of node you want to add.
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Connecting Effects
T-HFND-010-006
For an effect to work, it must be connected to a layer or composite. The effect will be applied to the image
output by the layer or composite, and the transformed image will be composited with other elements in the
scene.

How to connect an effect
1. Do one of the following:
l

If you want the drawing to only display in your scene as filtered by the effect, click on the
input port connecting the scene composite to the drawing, then drag it to the input port of
the effect, like so:

The drawing is only connected to the effect.
l

If you want the drawing to show both in its original state and as filtered by the effect, click on
the drawing's output port and drag it to the input port of the effect, like so:

The drawing will be connected to both the effect and the scene composite.
2. Click and drag on the output port of the effect, the connect it to the scene composite.
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TIP
You can quickly connect an effect as the intermediary between a drawing and a composite by
holding the Alt key, then clicking and dragging the effect over the connection between the
drawing and the composite.

You can remove an effect from the connection between a drawing and a composite using the
same technique.
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Adding a Matte Drawing to an Effect
Some effects can use, or even require the use of a matte layer. The matte layer is a drawing that determines the
area that the effect affects.
For example, a Cutter effect needs to be connected to a matte layer, because it uses the drawing in the matte
layer to determine which part of the drawing to cut out. However, a Colour-Scale effect can be used without a
matte layer, in which case it will affect the colour of all of the drawing it is connected to, but if it is connected to
a matte layer, it will only affect the colours of the part of the drawing that is covered by the matte drawing.
In the Node view, effects and nodes that require a matte layer will always have a matte port

at their left.

Effects and nodes that can use a matte layer, but which don't require it, will have their matte port hidden by
default, and it will appear if you bring a connection cable near their left edge.

TIP
The same mechanic works with Drawing nodes. Although they do not have a matte port by
default, but if you connect a drawing or a composite near their left edge, a matte port will appear.
When a Drawing node is connected to a matte, the part of the drawing covered by the matte is cut
out from that drawing, which is the same as if the drawing was connected to a Cutter node—see
About Masking and Cutting Parts of Elements in your Scenes on page 1383.

How to connect a drawing to an effect's matte connection in the Timeline view
1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer
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2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.

3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.
4. In the Timeline view, locate the effect layer for which you created a matte and click on the Expand
button right of its name.

Just below the effect, a list of parameters for the effect appears. If the effect has a matte connection,
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the first parameter in the list will be Matte, and its value will be <Drop layer here>.

5. Click and hold on the matte layer, then drag and drop it over <Drop layer here>.

The matte layer will be set as the effect's matte property.

<
NOTES
l

When a drawing layer is used as an effect's matte, the artwork in that layer is not
visible in the scene, since it is only used as the effect's matte.

l

If you want to disconnect the effect from the matte, you can click on the Unlink
button at the right of the Matte parameter to unlink the matte layer from the effect.
This will make the matte drawing visible in the scene again.

6. By default, the effect is applied to the matte's opaque areas and the matte's transparent areas are
ignored. If you want to invert this effect, which means apply the effect on the matte's transparent
areas and ignore the matte's opaque areas, double-click on the layer (but not on its name) to open
its Layer Properties dialog.
7. In the Layer Properties dialog of the effect, there should be an Invert Matte parameter. If the effect
has several tabs in its layer properties, you might have to look through each tab to find this

1360

Chapter 15: Effects

parameter. Check the check box for this parameter to invert the effect of the matte.
NOTE
For Cutter nodes, this parameter is just named Inverted.

How to connect a drawing to an effect's matte port in the Node view
1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer

.

2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.

3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.
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1. In the Node View, locate the effect node and the matte drawing node.

Notice that the matte drawing node is connected to your scene's main composite.
2. Click on the input port of the composite that is connected to the matte drawing, then drag it over to the
left edge of the effect node.

If it's an effect that requires a matte, such as a Cutter there will already be a matte port at the left edge of
the effect node. If it's an effect that can optionally use a matte, such as Colour-Scale, the matte port will
pop up when you drag the cable over the left edge of the effect node.
The matte drawing is now used as the effect node's matte.
3. By default, the effect is applied to the matte's opaque areas and the matte's transparent areas are
ignored. If you want to invert this effect, which means apply the effect on the matte's transparent areas
and ignore the matte's opaque areas, double-click on the Matte icon
an effect's matte is inverted, its matte icon also appears inverted
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Configuring an Effect
Once your effect is connected, you can configure it by changing its layer properties. There are two ways to
access a layer's properties:
l

By selecting it. Its layer properties will display in the Layer Properties view, which can be added to your
workspace.

l

By opening its Layer Properties dialog.
NOTE
Most effects do not have a visible effect in the Camera view's default preview mode (OpenGL View
). This preview mode is very fast and is optimized for animation, but not for effects. To preview
an effect as you change its parameters, you must set the Camera view's preview mode to Render
View

, which will update slowly, but will render the effects as they would appear in the final

rendered image.

How to view a layer's properties in the Layer Properties view
1. Do one of the following to display the Layer Properties view:
l

In the top right corner of any existing view, click on the Add View button and select Layer
Properties.

l

In the top menu, select Windows > Layer Properties.

2. In the Timeline or Node view, select the effect node you want to configure.
The selected node's layer properties are now displaying in the Layer Properties view.

How to open a layer's Layer Properties dialog
1. Do one of the following:
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l

In the Node view, locate the effect you want to configure and click on the Layer Properties
icon just left of the node's name.

l

In the Timeline view, double-click on the effect layer you want to configure, but not on its
name.

The layer's Layer Properties dialog appears.

How to configure an effect
1. In the toolbar under the Camera view, click on the Render View
the effects in the Camera view.
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TIP
If your scene currently does not have a background, the negative space in your scene
will render in black. To circumvent this, you can add a Colour-Card layer underneath all
the other layers in your scene by clicking on the Add Layer

button in the toolbar

over the layer list and selecting Colour-Card.
2. In the Layer Properties view or the Layer Properties dialog, adjust the parameters of the effect until
you have the expected results.
The preview in the Camera view will update every time you make changes, but each change may
take a short while before appearing in the Camera view, as the Render Preview mode requires more
computing power to update.
NOTE
For more information on how to configure certain effects, refer to Examples of Effect
Usage on page 1388. For detailed information on the properties of each available effect,
see refer to the Nodes / Layers section of the Reference guide.
3. Once you are done, you can dismiss the Layer Properties dialog if it was open, and you can set the
preview mode of the Camera view back to OpenGL by clicking on the OpenGL View
the toolbar at the bottom of the Camera view.
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Animating an Effect
You may need to animate some effects to obtain the expected results. For example, you may want the radius of
a Glow effect to slowly increase and decrease to make it pulsate throughout a scene, or you may want the
transparency of a Transparency effect to increase from 0% to 100% to make a drawing vanish.
Almost all numerical parameters in an effect can be attached to a function. A function allows you to set a
parameter to different values at different points in the scene by adding keyframes to it, and setting each
keyframes to a specific value. Between keyframes, the value of the parameter will progress from the value of the
previous keyframe to the value of the next keyframe. Drawing layers are animated by having their coordinates
associated to functions. Likewise, effects can be animated by associating their parameters to functions.
Some effect parameters can be animated directly in the Timeline view, but not all. When you expand an effect's
parameters in the Timeline view, some of its parameters may be hidden to avoid cluttering the Timeline view.
You can animate those parameters from the Layer Properties view or the Layer Properties dialog, which display
all of a layer's parameters.
NOTE
To learn how to preview animated effects, refer to About Effects Preview on page 1376.

How to animate an effect parameter in the Timeline view
1. In the Timeline view, locate the effect you want to animate, and click on the Expand

button right

of its name.

The list of parameters that effect's paramaters that are available in the Timeline view appears.

2. In the right area of the Timeline view, in the same row as the parameter you want to animate, select
the frame where you want to create the first animation keyframe for the effect.

1366

Chapter 15: Effects

3. Create a keyframe by doing one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

4. In the left area of the Timeline view, under the Parameters column, adjust the value of the parameter
for this keyframe by doing one of the following:
l

Click and hold on the value of the parameter, then drag it towards the left to reduce its value,
or towards the right to increase its value.

l

Click on the value of the parameter. A text field will appear. Type in the new value of the
parameter, then press Enter.

5. In the right area of the Timeline view, click on the frame where you want to create the second
animation keyframe for the effect.
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6. Create the second keyframe for your effect's animation by doing one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

7. In the Parameters column, adjust the value of the parameter at the current keyframe.
8. Repeat the steps to create as many animation keyframe for your effect as needed.
9. To adjust the timing between the keyframes of your animation, select the first keyframe.
10. In the Timeline toolbar, click on the Set Ease for Multiple Parameters

button.

The Set Ease for Multiple Parameters dialog appear. The function graph in this dialog will be focused
on the first keyframe

in your animation, which should have a Bezier handle

pointing to the right.
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11. Click on the Bezier handle

and drag it towards the right, at any angle, to adjust the ease-in of

the animation.

12. Click on Apply/Next.
The Set Ease for Multiple Parameters dialog will focus on the second keyframe. If this is the last
keyframe in the animation, it will only have one Bezier handle, pointing towards the left. If there are
more animation keyframes after this one, it will have two Bezier handles, one pointing in each
direction.

13. Click on the left Bezier handle

and drag it towards the left, at any angle, to adjust the ease-out

of the animation between the previous keyframe and the current keyframe.
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14. If there is a Bezier handle pointing towards the right

, click on it and drag it towards the right, at

any angle, to adjust the ease-in of the animation between the current keyframe and the next
keyframe.

15. Repeat the previous steps until the timing for your animation is adjusted throughout the entire
scene.

How to animate an effect in the Layer Properties dialog
1. Open the effect's Layer Properties by doing one of the following:
l

Add the Layer Properties view to your workspace, then select the effect in the Timeline or
Node view.

l

In the Timeline view, double-click on the effect layer, but not on its name.

l

In the Node view, locate the effect node and click on its Layer Properties

button.

2. In the effect's layer properties, locate the parameter that you want to animate and click on the
Function

button to its right.
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The parameter's input field will be greyed out. This is because you cannot directly edit a parameter
once it is attached to a function. The field will indicate the name of the function that was created for
it, in this format:
Name of node: Name of function: Value at current frame
3. Click on the parameter's Function button again.
The Bezier Editor dialog opens.

This dialog will allow you to animate the function. The function graph at the bottom is made to
represent the values of the function throughout each frame in the scene.
4. In the function graph, click and drag on the red cursor
create your first animation keyframe.

1371

to move it to the frame where you want to
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5. Click on the Add Keyframe
A keyframe

button to create the first animation keyframe for the effect.

is created and should be visible in the function graph. If you do not see it, that is

because the function graph is not positioned to include the keyframe within its frame. To move the
function graph to view the function's keyframe, click on the Reset View
button.

or Reset View Vertically

6. Adjust the value of the parameter at the current frame by doing one of the following:
l

In the Value field over the function graph, type in the desired value for the parameter.

l

In the function graph, click and drag on the keyframe
or down to decrease it.

1372

, and move it up to increase its value,

Chapter 15: Effects

TIP
If you want to set the keyframe to a value that is outside of the function graph's
frame, you can press the 1 key to zoom out. You can also press the 2 key to zoom
back in.

7. Click and drag on the red cursor to move it to the frame where you want to create your second
animation keyframe.

8. Click on the Add Keyframe

button to create the second animation keyframe for the effect.
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9. Adjust the value of the parameter at the current frame by doing one of the following:
l

In the Value field over the function graph, type in the desired value for the parameter.

l

In the function graph, click and drag on the keyframe

, and move it up to increase its value,

or down to decrease it.

10. If you want to adjust the timing of the animation between the first and second keyframes, do the
following:
l

Click and drag the Bezier handle of the first keyframe
to affect the ease-in of the animation.
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l

Click and drag the Bezier handle of the second keyframe

towards the left, in any

direction, to affect the ease-out of the animation.

11. Repeat these steps until you created and timed every animation keyframe required to animate your
effect.
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About Effects Preview
T-HFND-010-010
Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.
Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter,
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered
automatically, deselect the Auto-Render option and do the preview update manually.
You might also need to play back your animation and see the final effect before final rendering. But first, you
must connect a Render Preview node to each effect.
You cannot play back your animation in Render mode. You must perform a render or a preview render to see
your animation with the final effects or use a Render Preview node for each effect. Effects must be calculated
before they can be viewed in real time.
To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a
check preview.
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Previewing Effects in Render Mode
T-HFND-010-011
You can preview a single final frames with all effects calculated in the Camera view when you enable
the Render mode. You cannot playback your animation in Render mode. You can also disable the auto-render
option when adjusting several effect parameters to avoid slowing down your computer.

How to preview effects in Render mode
1. In the Camera view status bar, click the Render View

button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render.
Depending on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option
1. In the Camera view status bar, click the Auto-Render

button. In the top menu, you can enable

and disable Scene > Render > Auto-Render.
Once the Auto-Render option is disabled, you must request the preview update by clicking the
Auto-Render

button.

How to manually update the rendering preview
1. In the Camera view status bar, click the Render
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Previewing Effects in OpenGL Mode
If you want to playback your animation and see rendered effects, you can use the Preview node to see your
effects in the Camera view OpenGL mode.

How to preview effects in OpenGL mode
1. To adjust the effect's visual controls in OpenGL mode, from the Node Library view, drag a Render
Preview node to the Node view. Connect it between the effect and the Composite nodes.

2. In the Camera view, enable the OpenGL

mode to see the rendered effect in OpenGL.

As you modify the effect's parameters and controls, the frames are rendered to ensure a real-time
playback. The larger the resolution and the heavier the effect, the longer the rendering process will
take. Green frames are rendered, red frames are pending and yellow frames are rendering.

3. To display the controls, select the node in the Node view, and do one of the following:
‣

In the Camera View toolbar, click the Show Control

‣

From the top menu, select View > Show > Control.

‣

Press Shift + F11 (Windows/Linux) or ⌘ + F11 (macOS).

The controls appear.
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4. In the Tools toolbar, select the Transform

tool or press Shift + T.

5. In the Camera view, adjust the controls.
6. To set the preview parameters, click the Layer Properties

button of the Preview Render node in

the Node view.
The Preview Render properties display.

Parameter

Description

Name

Allows you to enter a name for the node.

Preview Resolution

Lets you set the resolution used to generate the preview.
Resolutions range from 1/4 to 1/64th of the scene resolution.
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Do Not Render: Does not render any effects in your scene.

Outdated Images Mode

Show Without Effects: Shows the outdated images without
any effect.
Use Previously Rendered: Uses the previously rendered
images. The old images will be used until the new ones are
rendered.

Pre-render Next Frames

Starts a pre-render job for every frame of the timeline.
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Playing Back Effects
T-HFND-010-012
To playback your effects, you need to do a temporary render.

How to play back effects
1. In the Playback toolbar, click the Render and Play

button.

The Play node opens and loads the frames.

2. Once the frames are loaded, click the Play

button in the Play window.

3. Select Scene > Render > Cancel Preview Render to cancel the rendering.
NOTE
While previewing effects, you can press the Spacebar to stop and start playback.
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Changing the Preview Resolution
The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or onequarter of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command
1. From the top menu, select View > Preview Resolution and one of the following:
‣

Same as Scene Resolution

‣

3/4 of Scene Resolution

‣

1/2 of Scene Resolution

‣

1/3 of Scene Resolution

‣

1/4 of Scene Resolution

‣

Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.

2. In the dialog box, select a resolution from the presets or type a new X-Y value.
3. Click OK.
4. Preview your effects animation.
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About Masking and Cutting Parts of Elements in your Scenes
An important part of staging and rigging is cutting. Cutting is the process of making parts of a drawing that
intersect with another drawing invisible. It allows you, for example, to mask parts of a character that should
appear behind a background element that is drawn on the same layer as other background elements, to mask
two parts of a rig that should not overlap, or to confine an effect within the outlines of an element in your scene.
There are two methods to cutting in Harmony:
l

Using the matte port of a drawing layer. With this port, you can connect any drawing layer to another
drawing layer or composite, and use the latter as the drawing layer's matte. Any part of the drawing
that intersects with the artwork in its matte will be hidden.

l

Using a Cutter effect. A cutter effect can be connected to a drawing, effect or composite, and then can
use any other drawing layer or composite as its matte. Any part of what is connected to the Cutter effect
which intersects with the artwork in its matte will be hidden.

Hence, if you only want to hide parts of a single drawing layer, you can use the drawing's matte port. If you
want to hide parts of the image output by a composite or an effect, you will have to use a cutter effect
NOTE
In either case, the effects of cutting can be inverted. When inverted, only the parts of the artwork
that intersect with the matte are visible, and everything else is hidden.
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Using the Matte Port of a Drawing Layer
Each drawing in a Harmony scene has their own Matte port. Connecting a drawing or composite to a drawing's
matte port will make the parts of the drawing that intersect with the matte image invisible.
Optionally, you can invert a drawing layer's matte. This will make parts of the drawing that intersect with the
matte image visible, and everything else hidden.

How to connect a matte drawing node to a drawing node
1. In the toolbar above the layer list in Timeline view, click on the Add Layer

button and select

Drawing.
2. Give your new drawing layer a relevant name for a matte layer, such as "Matte-Drawing", then click
on Add and Close.

3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
a semi-transparent area of the matte will appear semi-transparent. For example, if a
matte is filled with a colour that has an alpha value of 64 (25% opaque), instead of
making the parts of the drawing it covers completely invisible, it will subtract the
matte's opacity from the opacity of those parts of the drawing, making them 75%
opaque.
4. In the Node view, click on the output port of the matte drawing node and drag the cable to the left
edge of the drawing node. A Matte port will appear. Release the mouse button to connect the matte
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drawing node to the matte port of the drawing node.

At this point, areas of the drawing layer that intersect with the artwork in the matte drawing node
are hidden.
5. If you want to invert the matte effect for the drawing node, so that the artwork that intersects with
the artwork in the matte layer is visible and that everything else is hidden, double-click on the
Cutter node's Matte

icon to toggle its Inverted parameter. When an effect's matte is inverted, its

matte port also appears inverted

.
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Using the Cutter Node
T-HFND-010-009A
You can use the Cutter node to hide parts of a drawing, a group or an effect. The Cutter node must be
connected to a drawing that will serve as a matte. Parts of the drawing, group or effect that intersect with the
matte drawing will be hidden.
Optionally, you can also invert the Cutter node's matte, which will make parts of the drawing, group or effect
that intersect with the matte drawing visible, and everything else will be hidden.

How to use the Cutter effect
1. Select a drawing layer and do one of the following:
l

From the Node Library view, select the Cutter effect and drag it to the Node view.

l

In the Node view, right-click and select Insert > Combine > Cutter.

2. While holding the Alt key, move the Cutter node over the cable connecting the drawing to your
scene's main composite. The Cutter node will become connected as an intermediary between the
drawing and its composite.

1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer

.

2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.

3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.
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NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.
4. In the Node view, connect the output port of the matte drawing node to the Cutter node's left input
(matte) port.

At this point, areas of the drawing layer that intersect with the artwork in the matte drawing node
are hidden.
5. If you want to invert the Cutter's effect, so that the artwork that intersects with the artwork in the
matte layer is visible and that everything else is hidden, double-click on the Cutter node's Matte
icon to toggle its Inverted parameter. When an effect's matte is inverted, its matte port also appears
inverted

.
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Examples of Effect Usage
The following section gives examples of how to use a few commonly used effects in Harmony.
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Adding a Highlight to a Drawing
Using the Highlight effect, you can apply a highlight to a drawing. Contrary to the Glow effect, the Highlight
effect does not convert your drawing into a glow, it applies the glow onto your drawing. The resulting render
includes both the drawing to its glow.

The Highlight effect uses a matte drawing layer to determine which areas of the drawing to apply the highlight
to. The highlight will not be applied outside of the drawing or outside of the matte.

How to use the Highlight effect
1. Select a drawing layer and do one of the following:
l

From the Node Library view, select the Highlight effect and drag it to the Node view.

l

In the Node view, right-click and select Insert > Combine > Highlight.

2. While holding the Alt key, move the Highlight node over the cable connecting the drawing to your
scene's main composite. The Highlight node will become connected as an intermediary between the
drawing and its composite.

1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer

.

2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.
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3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.
4. Connect the Matte drawing to the Matte port of the Highlight node.

5. Display the Highlight properties and adjust the properties to control the type and amount of blur
and the colour of the highlight effect—see the Reference guide .
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Adding a Shadow to a Drawing
Using the Tone effect, you can apply a shadow to a drawing. Contrary to the Shadow effect, the Tone effect
does not convert your drawing into a shadow, it applies the shadow onto your drawing. The resulting render
includes both the drawing to its shadow.

The Shadow effect uses a matte drawing layer to determine which areas of the drawing to apply the shadow
to. The shadow will not be applied outside of the drawing or outside of the matte.

How to use the Tone effect
1. Select a drawing layer and do one of the following:
l

From the Node Library view, select the Tone effect and drag it to the Node view.

l

In the Node view, right-click and select Insert > Combine > Tone.

2. While holding the Alt key, move the Tone node over the cable connecting the drawing to your
scene's main composite. The Tone node will become connected as an intermediary between the
drawing and its composite.

1. In the toolbar above the layer list in Timeline view, click on Add Drawing Layer

.

2. In the Add Drawing Layer dialog, give your new drawing layer a relevant name for a matte layer,
such as "Matte-Drawing", then click on Add and Close.
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3. In the new matte drawing layer, draw a matte for your effect. Your matte can be a simple shape, but
should be filled with a colour, as only parts of the matte that are opaque will be taken in account.

NOTE
Mattes can also have semi-transparent areas. Areas of the drawing that are covered by
semi-transparent areas of the matte are partially affected by the effect.
4. Connect the Matte drawing to the Matte port of the Tone node.

5. Display the Tone properties and adjust the properties to control the type and amount of blur and
the colour of the Tone effect—see the Reference guide .

1392

Chapter 15: Effects

Creating a Drop Shadow
The Shadow effect converts the drawing layer it is connected to into a dark, blurry matte. You can control the
type and amount of blur, as well as the colour of the shadow.
On its own, simply connecting a drawing or composite to this effect will only convert your drawing to a shadow,
which might not be useful. However, it is possible to make both the original character and its shadow version
appear in your scene, and have the shadow version transformed and distorted to appear as a drop shadow.
You can accomplish this by doing one of the following: You can accomplish this by creating a node system
similar to this one:

TIP
When creating a drop shadow against a floor, you can obtain a more realistic effect by using a
Quadmap to transform the shadow instead of a Peg. A Quadmap is similar to a peg, except that it
allows you to apply perspective effect to the drawings underneath it.

How to create a drop shadow for an animated character
1. In the Node view, make sure your character's rig is in a group with a composite. If it is not, select all
the nodes making your character's right, and do one of the following:
l

Right-click on the selection, then select Group > Group Selection with Composite.

l

In the top-left corner of the Node View, open the View Menu

, then select Nodes

> Group Selection with Composite.
l

Press Ctrl +Shift + G (Windows/Linux) or ⌘ + Shift + G (macOS).
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2. Using the Node Library, add a Peg, an Apply-Peg-Transformation, and a Shadow node to your
node system.

3. Connect the output port of your character rig to the input port of the Shadow node.

4. Connect the output port of the Shadow node to the right-most input port (Image) of the ApplyPeg-Transformation node.
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5. Connect the output port of the peg to the leftmost input port (Transformation) of the Apply-PegTransformation node.

6. Connect the output port of the Apply-Peg-Transformation node to your scene's main composite,
just right of the connection for your character rig. This way, the shadow will appear behind your
character rig.

7. Select the Apply-Peg-Transformation's Peg node.
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8. In the Tools toolbar, select the Transform

tool.

9. In the Camera view, scale and skew the selection so that it looks like a drop shadow.
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Adding a Radial Zoom Blur to a Scene
T-COMP2-003-006
The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or rotating
camera. You can use a matte to isolate the area of the image from which you want the effect to radiate from. For
example, in the illustration below, a circular matte was created to mask the eyeball and a Negate effect was
applied so the blur is outside the matte. Then the centre point was positioned on the character's iris, which is
the centre of the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see:
https://www.toonboom.com/resources/video-tutorials/chapter/adam-phillips-harmony-effects 
NOTE
To learn about the Blur Radial Zoom parameters, see the Reference guide .

How to use the Blur Radial Zoom
1. In the toolbar at the bottom of the Camera view, click on Render View

.

2. Do one of the following:
l

From the Node Library view, drag a Blur-Radial-Zoom node to the Node view.

l

Right-click in the Node View and select Insert > Filter > Blur > Blur-Radial-Zoom.
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3. Click on the port connecting the composite to the drawing node, and drag the cable to the rightmost (Image) input port of the Blur-Radial-Zoom node.

4. Click on the output port of the Blur-Radial-Zoom node and drag it to the composite to connect the
effect to the composite.

5. On the Blue Radial Zoom node, click on the Layer Properties
Properties dialog.
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6. In the Layer Properties dialog, increase the Blurriness value.

7. In the Direction section, click on any of the direction presets to modify the direction of the blur. Each
preset button has an icon that represents the results of the preset.
8. In the Node or Timeline view, select the Blur-Radial-Zoom node.
9. In the Camera view toolbar, click on the Show Control

.

A red dot appears in the middle of the Camera view. This dot determines the focus (centre)of the
radial-zoom blur effect.
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10. In the Tools toolbar, select the Transform

tool.

11. Click and drag on the red dot to position it where you want the focus of the radial-zoom blur effect
to be.

How to create a radial-zoom blur around an isolated area
1. In the toolbar above the layer list in Timeline view, click on the Add Layer

button and select

Drawing.
2. Give your new drawing layer a relevant name for a matte layer, such as "Matte-Drawing", then click
on Add and Close.
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3. In the new matte drawing layer, draw the shape of the area that you want to isolate from the radialzoom blur, and fill it.

4. In the Node view, click on the port connecting the composite to the matte drawing layer and drag it
to the left edge of the Blur-Radial-Zoom blur. A matte input port will appear when you bring a cable
near the left edge.

5. Click on the Layer Properties

button of the Blur-Radial-Zoom node to open its Layer Properties

dialog.
6. Check the Invert Matte check box at the bottom of the layer properties dialog.
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Everything outside of the matte drawing is now affected by the radial-zoom blur.
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Applying a Greyscale Matte to a Scene
Here is an example on how to use the Matte Output option of the Greyscale node. A frosted window was
created using a snowflake image over a blue rectangle and a colourful background.
Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale node, it turns into a greyscale image. There is no
transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the
Matte View mode of the Camera view is enabled, you can see the transparency levels generated from the
colour values.
When you connect the Snowflake images into a Cutter effect's Matte port along with the Window images, the
window will be semitransparent, matching the alpha (transparency) channel generated by the Greyscale node.
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NOTE
To learn more about the Greyscale filter, see the Reference guide .
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Overriding Colours and Textures
The Colour Override Effect is one of the most useful and commonly used effects in Harmony, as it considerably
expands the flexibility with which you can use colours and textures in your animation. With the Colour Override
effect, you can replace individual colours or textures used your scene's drawings with other colours or textures.
If your scene has different clones of the same palette, you can also use the Colour Override effect to make
certain drawings use specific clones of the palette, whereas they would otherwise use the topmost clone in the
palette list.
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Overriding a Colour
With the Colour-Override node, you can change the colour of some swatches.

How to override colours
1. From the Colours section, select the colour swatch to modify and move it to the Individual Colour
Overrides section. Several options are available to modify your colours.

2. Once the swatch appears in the Colour-Overrides section, click the drop-down arrow and select
one of the following options from the Mode menu:
l

Override colour: When selecting a colour swatch from a clone palette (not set as the
current palette), use this option to override the current colour and use the swatch from
the clone palette over the corresponding one in the current palette.

l

Colour Not Visible: Renders the selected colour invisible in the Camera view.

l

New RGB Only: Overrides the colour swatch RGB value while maintaining its original
alpha value. You can select a new colour by clicking on the colour swatch and choosing
a new colour from the Colour Picker window.

l

New Alpha Only: Overrides the swatch's alpha channel while maintaining its original
RGB values. You can select a new alpha value by clicking on the colour swatch and
choosing an alpha value from the Colour Picker window.

l

New RGBA: Overrides the swatch's colour and alpha values. You can select a new
colour by clicking on the colour swatch and choosing an alpha value from the Colour
Picker window.
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Overriding a Colour With a Texture
With the Colour Override node, you can apply a texture over a selected colour. Any zone painted with the
selected colour swatch will be overridden by the selected texture.

There are different ways to apply the texture over your colour:
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NOTE
The result will only be visible in the Camera view in Render mode. In OpenGL mode, you will see the
original colour.
The matrix position can be modified using the Edit Gradient and Texture

tool. To do so, your drawing zone

must be painted with a gradient swatch or texture swatch.

Texture - Original Matrix
Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring
up the Browser window to search for your texture. The texture's default matrix (fixed proportion and
orientation) is mapped to the full size of the bounding box of each colour area to be overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.
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Texture - Global Bbox Centered

Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing
all colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut
from the same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words,
each fill area will not only have the texture scaled to its individual proportions, but also stretched or squashed to
fit within its contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.
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Modulate Pencil Texture Colour (Replace Transformation)
Overrides the initial texture fill's transformation (matrix) established when you painted the line or modified it
with the Edit Gradient and Texture

tool. This transformation override will be done by modifying the Peg's

position.

Modulate Pencil Texture Colour (Combine Transformation)
Combines the initial texture fill's transformation (matrix) established when you drew the line or modified it with
the Edit Gradient and Texture

tool with the new position transformation you will create when modifying

the Peg's position.

Override with This Texture Centered on Overridden Objects' Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece of
fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture zone
will be centered in the middle of the bounding box's centre.
With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.
The advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to
follow the general motion of a character if you want the texture to follow instead of having the character
moving across the fixed texture—see How to animate a texture override with a peg on page 1412.

Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box
encompassing the colour areas to be overridden. With multiple objects, it will look as though their fills were all
traced and cut from the same piece of stretched or squashed fabric.
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With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.

Textures - Use Input Image
How to apply a texture over a colour
1. From the Colours section, select the colour swatch to override and drag it to the Individual Colour
Overrides section.
2. Once the swatch appears in the Individual Colour Overrides section, select it and then click on the
Mode drop-down button and select one of the following options:
l

Texture - Original Matrix

l

Texture - Global Bbox Matrix

l

Texture - Global Bbox Centered

l

Texture - Contour Bbox Matrix

l

Texture - Scale to Screen

l

Override With This Texture Centered on Overridden Objects Centre

l

Texture - Use Input Peg

l

Texture - Use Image Image

The Browse

icon appears in the New column.

3. In the Colour-Override section, in the New column, click the Browse
texture.

4. Browse for your texture file.
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5. Click Open.
6. If you want to select a new texture to replace the existing one, click the Browse

button again

and select a new one to replace the existing one.

How to animate a texture override with a peg
1. From the Node Library view, drag a Peg node to the Node view.

2. Connect the Peg node in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the texture's position.
3. In the Node view, select the Peg node.
4. In the Advanced Animation toolbar, select the Translate
5. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

6. In the Camera view, move the Peg's position. As you move it, you can see the texture being
modified. You can animate the position by adding position keyframes in the Timeline view. You can
use the Random Fill function to quickly create a random shake.
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Modifying a Texture Fill's Transformation
When you paint a zone with a bitmap texture swatch, you may want to modify the size or position of the
texture's matrix at the compositing level. For example, you may want to do this to animate the position of the
texture in a zone. With the Colour-Override and a Peg node, you can animate the texture.

How to modify a texture fill's transformation
1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate
the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the final
Composite, set as Pass-Through.
2. Connect the Peg node in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the texture's position.
3. Click the Colour-Override's square yellow properties button to open its property editor.
4. In the Palettes section, select the palette containing the bitmap texture swatch.
5. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the
Individual Colour Overrides section.

1413

Harmony 15.0 Premium User Guide

6. Once the swatch appears in the Individual Colour Overrides section, select it and then click the
Override Mode button and select one of the following:
l

Override the colour's transformation: Overrides the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient
and Texture tool. This transformation override will be done by modifying the Peg's
position.

l

Combine the colour's transformation: Combines the initial texture's transformation
(matrix) established when you painted the zones or modified with the Edit Gradient
and Texture tool with the new position transformation you will create when modifying
the Peg's position.

7. In the Node view, select the Peg node.
8. In the Advanced Animation toolbar, select the Translate
9. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

10. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being
modified. You can animate the position by adding position keyframes in the Timeline view.
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Overriding a Texture on a Pencil Line
A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override
node, you can override the pencil line's texture or texture fill and replace it by another one, or you can animate
the texture's position.
With the Edit Gradient and Texture

tool, you can modify the size and position for both types of textures on

a pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's
matrix.

When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using
the Colour-Override node and a Peg.
You can modify and animate a pencil texture's position using the Colour-Override node and a Peg node. This
lets you create a shaky line style which is a very popular design style. The main issue with this style is that it
works well in traditional and tradigital animation, when the artist draws the line differently on each drawing,
but it does not work in cut-out animation where the same drawing is used for the entire animation. The same
issue happens when the same drawing is held for more than a few frames. The line moves during the
animation, but stops moving during the drawing hold, which looks bad.
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With the Colour-Override node, you can animate the position of the pencil line texture independently from the
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.

How to modify the pencil line texture

1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.
2. In the Node view, connect the Colour-Override node under the Drawing node you want to animate
the line for. Note that for a cut-out puppet, you would connect the Colour-Override under the final
Composite, set as Pass-Through.
3. Connect the Peg node in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the texture's position.
4. Click the Colour-Override's square yellow properties button to open its property editor.
5. In the Palettes section, select the palette containing the colour to override.
6. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to
the Individual Colour Overrides section.
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7. Once the swatch appears, select it and then click on the Override Mode button. Select one of the
following options from the drop-down menu:
l

Modulate Pencil Texture Colour (replace transformation): Overrides the initial
texture fill's transformation (matrix) established when you painted the line or modified
it with the Edit Gradient and Texture

tool. This transformation override will be

done by modifying the Peg's position.
l

Modulate Pencil Texture Colour (combine transformation): Combines the initial
texture fill's transformation (matrix) established when you drew the line or modified it
with the Edit Gradient and Texture

tool with the new position transformation you

will create when modifying the Peg's position.
8. In the Node view, select the Peg node.
9. In the Advanced Animation toolbar, select the Translate
10. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

11. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being
modified. You can animate the position by adding position keyframes in the Timeline view.

How to modify the pencil line texture
1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.
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2. In the Node view, connect the Colour-Override node under the Drawing node you want to
animate the line for. Note that for a cut-out puppet, you would connect the Colour-Override
under the final Composite, set as Pass-Through.
3. Connect the Peg node in the Colour Override's middle port. The green port will take the
transformation of the Peg to modify the texture's position.
4. Click the Colour-Override's square yellow properties button to open its property editor.
5. In the Palettes section, select the pencil texture palette containing the texture you want to use.
By default, every scene has a pencil texture palette named after the name of the scene followed
by _pencil_texture.

6. In the Colours section, select the pencil texture used to draw your lines and drag it to the
Individual Colour Overrides section.
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7. When the swatch appears in the Individual Colour Overrides section, select it and click the
Override Mode button. Select one of the following:
l

Change Pencil Texture Transformation: Overrides the initial pencil texture's
transformation (matrix) established when you drew the line or modified with the Edit
Gradient and Texture

tool. This transformation override will be done by modifying

the Peg's position.
l

Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation
(matrix) that was established when you drew the line or modified with the Edit Gradient
and Texture

tool with the new position transformation you will create when

modifying the Peg's position.
8. In the Node view, select the Peg node.
9. In the Advanced Animation toolbar, select the Translate
10. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

11. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture
being modified. You can animate the position by adding position keyframes in the Timeline
view. You can use the Random Fill function to quickly create a random shake.
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Overriding a Colour with a Texture Sequence
In production, you may need to map a live action sequence or bitmap image sequence into a zone or over
several zones. For example, you could have a mirror shattered into several pieces and you want to map video or
someone talking into those pieces. You can paint the mirror pieces with a specific colour swatch and use the
Colour-Override node to map the image sequence into the pieces. It can also be a single image without having
to be an image sequence.
NOTE
To learn how to modify a texture's exposure based on an animation or character's motion, see
Animating Textures Based on Action on page 1424.

How to override a colour with a bitmap image sequence
1. From the Node Library view, drag a Colour-Override node to the Node view.
2. In the Node view, connect the Colour-Override node under the drawing node that contains the line
you want to animate.
3. Connect the Live Action or Bitmap Image Sequence node in the Colour-Override's left port. The blue
left port will input the images into the colour zones. Note that your image sequence's exposure
needs to span over all the frames you it to be visible for. If there is not images exposed, the colour
will not be overridden when frames are blank.

4. Click the Colour-Override's square yellow button to open its property editor.
5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to
override.
6. In the Colours section, select the pencil texture used to draw your lines and drag it to the ColourOverride section.
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7. Once the swatch appears in the Colour-Override section, select it and then click the Override Mode
button and select Texture - Use Image Input.
8. In the Node view, select the bitmap image node.
9. In the Advanced Animation toolbar, select the Translate
10. In the Camera view bottom toolbar, enable the Render

, Rotate

or Scale

tool.

mode.

11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills
being modified. You can animate the position by adding position keyframes in the Timeline view.
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Animating Textures Based on Action
An effect often applied at the compositing stage is the texture overlays. With this effect, you can replace solid
colours in your character with tiled-on bitmap textures, or replace their solid outlines with textured, naturallooking pencil lines.
To enhance this effect, you may want the texture override to be animated. The texture override can be
composed of multiple drawings, which can be looped through as the scene plays out. You may want these
texture drawings to change at a constant pace, or only when the character's action is fast enough to warrant it,
to give it a more organic or stylized look.
This is where the Exposure Fill Using Render Change command comes in handy. This functionality allows you
to automatically fill the texture layer's column with different drawing exposures relative to how intense the
action is in the rendered image. You can define how much action is enough to warrant a drawing swap, letting
the textures sit still when the character is inert but making them animated when they move.
The Exposure Fill Using Render Change command can be applied on any drawing layer, but the most common
case where this feature will be when a layer containing texture drawings is being used by a Colour-Override
through its texture port to replace one of a character's colours with a texture. The drawing layer containing the
texture drawings should have at least a few different texture drawings for the Exposure Fill Using Render
Change command to be able to swap between them. For more information on this approach, see Overriding a
Colour with a Texture Sequence on page 1422.
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Using the Exposure Fill Using Render Change to Animate a Texture
Fill
You can use the Exposure Fill Using Render Change functionality to automatically fill the column of a texture
override layer with drawing exposures. The exposures will change more or less depending on the amount of
motion that occurs between every frame, allowing you to easily make textures animated when the character is
moving, and make them still when the character is not.
TIP
Harmony will analyze how much action occurs between every frame based on the image sent to
your scene's Display node. Hence, if you prefer that Harmony only analyzes the action for specific
elements of your scene, you can add a Display node to your scene, connect it to the elements you
wish to analyze, and use it as your current display—see About Displays on page 1250.

NOTE
The Exposure Fill Using Render Change command modifies the timing (exposure) of the selected
layer. If you modify the character animation, you may need to reapply the exposure fill as the
texture's exposure might no longer give the same final result.

How to animate a texture using the Exposure Fill Using Render Change functionality
1. In the Timeline view, select the textures or live-action sequence.

2. From the top menu, select Scene > Default Display > desired Display node.
3. From the top menu, select Animation > Exposure Fill > Using Render Change.
Wait while Harmony creates a low resolution render of the images to preview.
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4. In the Fill Exposure Using Render Changes window, use the Frame slider to view the motion change
analysis.
5. Based on your style preference, adjust the parameters to assign when the texture exposure
changes will occur. You can adjust the type of filter to use for the motion detection, as well as
threshold values to indicate what will be considered a big enough motion variation for an exposure
change.

Parameter

Description
Frame: Use the slider to see when a change is necessary. A
red edge indicates there is a large enough motion for the
texture to change.

Changes Detection Settings

Use: Lets you use either the Red, Green, Blue, or Alpha
channel, or Luminance difference between frames to analyze
the motion changes. The Alpha channel is selected by default
as it is the most commonly used parameter.
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Pixel Value Change Threshold: The percentage of change in a
pixel to be considered different from one frame to another.
The higher the value, the more change is required when
comparing two images in order for a new texture to be used.
Area Change Threshold: The percentage of non-empty pixels
that must change from one frame to another to be considered
different.
These settings let you change the exposure. You can also
decide on how many images you want to cycle.
First/Last Frame: Lets you set the first and last frame for the
exposure change. You can set this for the entire scene or for
part of the scene (frames 20 to 32 for example).
Number of Drawings in Cycle: Lets you set of the number of
drawings to include in the cycle.
Fill Settings

First Drawing Used in Cycle: Lets you set the first drawing
used in the cycle. Your drawings must be named using
numeric values only, or number values with a prefix or suffix.
It cannot only be letters.
Drawing Name Prefix: Adds a prefix before the number. For
example, texture_01, texture_02 and so on.
Drawing Name Suffix: Adds a suffix after the number. For
example, 01_texture, 02_texture and so on.

6. Click OK.
The selected layer's exposure is updated. If you modify the exposure of motion in your animation, you
may need to repeat this procedure.
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About the Animated Matte Generator
T-COMP2-002-003
The Animated Matte Generator effect is a very advanced tool in Harmony's suite of effects with three key
features:
l

Matte Animation

l

Feathered Effect

l

Snapping

Matte Animation
The Animated Matte Generator takes a vector drawing as input and generates animatable points for its
contours. This allows you to animate the points and contours of a vector drawing, which can come in handy if
you want to animate simple parts of a character rig, like fingers, eyebrows and eyelids.
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Feathered Effect
The Animated Matte Generator can use the vector drawing it is connected to as the basis for an effect matte,
from which you can create an outer contour and an inner contour, and use them to generate a custom-shaped
feathered effect. The matte's contours can be animated. The resulting effect can be used as-is, or serve as a
transparency mask for other effects or drawings.

Snapping
You can set some of the points and contours of an Animate Matte Generator to snap to the contours of a
drawing in your scene. This can be especially useful if you want to create shadows or highlights that match the
shape of a drawing.
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Adding an Animated Matte Generator Node
T-COMP2-002-004
In order to use the Animated Matte Generator, you must connect it to a vector drawing layer, called the source
drawing, which will be used to define the default shape of the matte before it is animated.
A source drawing for an Animated Matte Generator should follow these guidelines:
l

It should be simple. The Animated Matte Generator will create an animatable control point for each
vector point in the drawing, so having too many points could make it very difficult to animate.
If you want to create a feathered effect, make your drawing a simple shape with a solid colour. If you
want to animate a drawing's shapes and contours, make sure the drawing's lines are made with pencil
lines and not brush strokes, that the drawing has been flattened and optimized and that all
unnecessary vector points have been removed using the Contour Editor or the Smooth Editor tools.

l

It must be a single vector drawing layer. The Animated Matte Generator cannot work with composites,
effects, bitmap layers or anything but a vector drawing node.

l

If you have Overlay and Underlay Arts enabled, the Overlay Arts should be used for annotations only.
The Animated Matte Generator will ignore the Overlay art layer in the source drawing.

How to add an Animated Matte Generator node
1. In the Node view, add an Animated Matte Generator node to your scene by doing one of the
following:
l

In the Node Library, select the Generator filter, and drag and drop the Animated-MatteGenerator node from the Node Library view to the Node view.

l

In the Node view, right-click and select Insert > Generator > Animated-Matte-Generator.

l

Open the Node view menu and select Insert > Generator > Animated-Matte-Generator.

2. Connect the Animated Matte Generator node as an intermediary between your source drawing
node and its composite, by doing one of the following:
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l

While holding the Alt key, drag the Animated Matte Generator node over the cable
connecting the source drawing node to the composite.

l

Connect the output of the source drawing node to the Source Drawing (right) input port of
the Animated Matte Generator node, then the output port of the Animated Matte Generator
node to the composite.

TIP
If you want the generated matte's contours to snap to the contours of another drawing in your
scene, you can also connect it to another drawing, which is referred to as the snapping source.
For more information, see About Snapping with the Animated Matte Generator on page 1460.
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About Matte Creation and Animation with the Animated Matte
Generator
T-COMP2-002-005
The Animated Matte Generator node converts the vector points of its source drawing into matte points. Those
points can be animated, allowing you to freely morph the shape of the source drawing as your scene plays out.
You can animate the points of an Animated Matte Generator by displaying its controls in the Camera view,
then moving them using the Transform tool. Moving and tweaking the contour points for an Animated Matte
Generator works a lot like using the Contour Editor tool.
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Displaying Animated Matte Generator Controls
T-COMP2-002-006
The points and contours of an Animated Matte Generator can be edited and animated in the Camera view by
displaying its controls and manipulating them with the Transform tool.

How to display the Animated Matte Generator controls
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.

3. In the Tools toolbar, select the Transform

tool to be able to manipulate the matte controls in the

Camera view.
TIP
In the Tool Properties view, you can enable Control Selection Mode

to enable selecting

several control points in the Camera view by drawing a lasso or marquee around them with the
Transform tool. This can make animating the control points of the Animated Matte Generator
easier.
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Adding Points to an Animated Matte Generator
T-COMP2-002-007
You can add additional points to the ones already generated by the Animated Matte Generator for your source
drawing.
NOTE
If you have already animated the Animated Matte Generator, creating a matte point will also add
that point to every keyframe. Therefore, you will have to position that point on every keyframe of
your animation to make sure it looks and moves as expected.

How to add new matte points to an Animated Matte Generator
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
3. In the Tools toolbar, select the Transform

tool.

4. In the Editing Mode panel of the Animated Matte Generator view, select Add Matte Point

.

NOTE
Contrary to tools like the Contour Editor, you cannot use a keyboard shortcut to click
and add a point to a matte contour.
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5. In the Camera view, click on the matte contour where you want the new point to be created.

NOTE
Adding a matte point to one of the matter's contours will also add a point to the matte's other
contour. It is not possible to have a different amount of points on a matte's inner and outer
contours.
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Removing Points from an Animated Matte Generator
You can remove controls points that you do not intend to use, whether they were automatically generated by
the Animated Matte Generator or added manually.
NOTE
If you have already animated the Animated Matte Generator, removing a matte point will remove
that point on every keyframe, which will affect the shape of the matte throughout the scene.

How to remove matte points from an Animated Matte Generator
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
3. In the Tools toolbar, select the Transform

tool.

4. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point

.

5. In the Camera view, select the point you want to remove. You can select several points by holding
Shift while clicking on each point.
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6. In the Camera view, click on the matte contour where you want the new point to be created.

NOTE
Removing a matte point from one of the matter's contours will also remove its corresponding
point to the matte's other contour. It is not possible to have a different amount of points on a
matte's inner and outer contours.
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Animating the Contour of an Animated Matte Generator Contour
T-COMP2-002-008
Every control point for an Animated Matte Generator can be animated independently, giving you full control on
the shape of your drawing or effect throughout the scene. You can animate the contours of an Animated Matte
Generator by displaying its controls in the Camera view, then manipulating its points using the Transform tool.

How to animate the points and contours of an Animated Matte Generator
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
3. In the Tools toolbar, select the Transform

tool.

TIP
In the Tool Properties view, you can enable Control Selection Mode

to enable

selecting several control points in the Camera view by drawing a lasso or marquee
around them with the Transform tool. This can make animating the control points of the
Animated Matte Generator easier.
4. In the Tools toolbar, enable the Animate

option.

5. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point
This mode allows you to move and tweak matte points and contours in the Camera view.

6. In the Timeline view, move the Timeline cursor to the frame where you want to create the initial
pose of the Animated Matte Generator.

1438

.

Chapter 15: Effects

7. Do one of the following:
l

Click and drag a matte point to reposition it.

l

Click and drag a contour to tweak its curve.

l

Select a matte point to display its curve handles.

l

Click and drag one of the curve handles of a matte point to influence the curves on both sides
of the matte point.

l

While holding Alt, click and drag one of the curve handles to influence the curve only on one
side of a matte point.
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l

While holding Alt, click on a matte point to remove its curve handles.

l

While holding Alt, click and drag a matte point with no curve handles to create its curve
handles.

8. In the Timeline view, move the cursor to the frame where you want to create your next pose.
9. Repeat steps 7 and 8 until the animation for your matte is completed.
Points that have been left in their resting positions appear light blue, and points that have been
animated will appear dark blue, except when selected.
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TIP
In the Animated Matte Generator view, you can enable the Auto Key on All Points

option to

create keyframes for all matte points every time you manipulate a matte point, or the
Fix Adjacent Keyframes

option to create the necessary keyframes to avoid overlapping

animation without creating keyframes on all points.

TIP
You can select multiple points in the matte by holding Shift and clicking on each point you wish
to select. You can also move a single point in a selection of multiple points without deselecting
other points by holding Ctrl, then clicking and dragging the point you wish to move.
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About the Outer & Inner Contours of the Animated Matte Generator
T-COMP2-002-009
An animated matte generator has two separate contours: The inner contour and the outer contour. It
automatically generates both contours based on the source drawing it is connected to, so both contours start
out having the exact same shape and position, and their points start out being locked together. Therefore, until
you separate the points of the outer and inner contours, your Animated Matte Generator will behave as if it had
a single contour.
You can define the Animated Matte Generator's inner and outer contours separately by disabling one of them,
then manipulating the points in the other one. Each point that is animated on one of the contours while the
other one is disabled will become independent from the other contour.

There are two cases where you need an inner and an outer contour:
l

To create a feathered effect. When the Animated Matte Generator's Output Type is set to Feathered, it
generates a gradient going from the inner contour to the outer contour, allowing you to create light and
shadow effects that match very precise shapes.

l

To create an animation based on both contours. By setting the Animated Matte Generator's Output
Type to Interpolate Between Contours, you can make your matte drawing morph from the outer
contour's shape to the inner contour's shape, and vice versa, by animating the Animated Matte
Generator's Interpolation Factor.
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TIP
The Animated Matte Generator keeps track of which points correspond with each other across the
inner and outer contours. You can enable the Point Id

option in the Animated Matte Generator

view to display the identification number of each matte point in the Camera view. Points from the
inner contour that match points from the outer contour will have the same identification number.
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Separating the Outer and Inner Contours of an Animated Matte
Generator
T-COMP2-002-010

How to separate the inner and outer contours of an Animated Matte Generator
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. In the Tools toolbar, select the Transform

tool.

3. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
TIP
In the Tool Properties view, you can enable Control Selection Mode

to enable

selecting several control points in the Camera view by drawing a lasso or marquee
around them with the Transform tool. This can make animating the control points of the
Animated Matte Generator easier.
4. In the Animated Matte Generator view, do one of the following:
l

If you want the Outer Contour to be based on the shape and dimensions of your matte
drawing and the Inner Contour to be smaller, disable the Outer Contour
enable the Inner Contour

l

option and

option.

If you want the Inner Contour to be based on the shape and dimensions of your matte
drawing and the Outer Contour to be bigger, enable the Outer Contour
disable the Inner Contour

option and

option.

The matte points will appear orange instead of blue. This means they represent a single contour
instead of both contours together.
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TIP
You can quickly enable one contour and disable the other one by holding the Alt key
and clicking on the button of the contour you wish to enable.
5. In the Camera view, move the control points that you want to separate to their intended position:
l

If you are editing the inner contour, move each point you want to separate from the outer
contour towards the centre of the shape so that they are inside the outer contour.

l

If you are editing the outer contour, move each point you want to separate from the inner
contour away from the centre of the matte so that they wrap around the inner contour.
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NOTE
You can keep some control points locked together. For example, if you want to create a
feathered effect that gradates from one side to the other instead of from the centre out,
you can keep the control points on one of the sides of the matte locked together.
6. When you are done separating outer and inner contour points, enable both the Outer Contour
and Inner Contour

options of the Animated Matte Generator view again so you can animate

them together.
The points that were separated will appear orange, and will be linked to their corresponding point
in the other contour by a blue line. If some points are still locked together, they will appear blue.

TIP
You can select multiple points in the matte by holding Shift and clicking on each point you wish
to select. You can also move a single point in a selection of multiple points without deselecting
other points by holding Ctrl, then clicking and dragging the point you wish to move.

NOTE
If your selection includes both points from the inner and outer contour:
l

Clicking and dragging on one of the selected points from the outer contour will only move
the selected points in the outer contour.

l

Clicking and dragging on one of the selected points from the inner contour will only move
the selected points in the inner contour.

This is so you can easily select points from both contours with the lasso, but only manipulate
points from one contour at a time. To move all the selected points regardless of which contour
they are part of, you must do one of the following:
l

Click and drag one of the blue lines connecting an inner contour point and an outer contour
point that are part of your selection.

l

If your selection includes points that have not been split, click and drag one of those points.
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Scaling the Contours of an Animated Matte Generator
You can use the scaling control of the Animated Matte Generator to quickly scale the control points of your
matte contours. This is especially useful for quickly separating the outer contour and the inner contours.

How to use the scaling controls of the Animated Matte Generator
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. In the Tools toolbar, select the Transform

tool.

3. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
4. In the Matte Visibility panel of the Animated Matte Generator view, do one of the following:
l

If you don't want to separate the inner and outer matte contours, or if they are already
separated, enable both the Outer Contour

l

options.

If you want to shrink the inner contour only, disable the Outer Contour
the Inner Contour

l

and Inner Contour

If you want to shrink the inner contour only, enable the Outer Contour
the Inner Contour

option and enable

option.
option and disable

option.

TIP
You can quickly enable one contour and disable the other one by holding the Alt key
and clicking on the button of the contour you wish to enable.
5. In the Editing Mode panel of the Animated Matte Generator view, enable the Scaling Controls
option.
Scaling controls appear over the enabled matte contours. If both matte contours are enabled, a blue
scaling control appear in-between the outer and inner contours which can be used to scale both
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contours simultaneously.

6. If you want to scale the matte points from a specific pivot point, click and drag the purple square in
the middle of the scaling control to position the scaling pivot.
7. Do one of the following:
l

If you want to scale both the outer and inner contours together, click and drag any control
point of the blue scaling box.

l

If you want to scale the outer contour only, click and drag any control point of the red scaling
box.

l

If you want to scale the inner contour only, click and drag any control point of the green
scaling box.
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Merging Outer & Inner Contours for an Animated Matte Generator
If you have separated the matte points of the outer and inner contours of an Animate Matte Generator, you can
lock them back together so that they behave as single matte points again.

How to merge outer and inner contour points
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. In the Tools toolbar, select the Transform

tool.

3. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
4. In the Editing Mode panel of the Animated Matte Generator view, click on Define Matte Point

.

5. In the Camera view, select the contour point you want to merge with its corresponding point in the
other contour. If you want to merge several contour points with their corresponding contour points,
hold shift and click on each point to select them together.
NOTE
You do not need to select the point in both the outer and inner contours. Simply
selecting the point from one of the two contours is enough to merge it with the
corresponding point in the other contour.
6. In the Animated Matte Generator toolbar, click on Merge Inner and Outer Matte Contours

.

The selected matte points and their corresponding matte points are moved to the same position,
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halfway between their respective positions, and are locked together again.

TIP
You can also lock a contour point back to its corresponding point by clicking and dragging it
very close to its corresponding point. When close enough, it will snap to that point and appear
blue. Releasing it in this state will lock the corresponding contour points together.
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Animating Interpolated Contours with the Animated Matte
Generator
T-COMP2-002-011
The Animated Matte Generator can output an image that is an interpolation (in-between) of its outer contour
and its inner contour. How close to the outer or inner contour this image is is based on its Interpolation Factor
parameter, which can be animated. Hence, you can animate the Animated Matte Generator to morph from the
outer contour to the inner contour, and vice versa.

How to interpolate between contours with the Animated Matte Generator

1. In the Node or Timeline view, select the Animated Matte Generator node.
2. In the Tool Properties view, set the Output Type to Interpolate Between Contours.
3. In the Tools toolbar, select the Transform

tool.

4. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.

5. In the Matte Visibility Settings panel of the Animated Matte Generator view, enable the Outer
Contour

and disable the Inner Contour

.

6. In the Camera view, adjust the matte points until you obtain the expected shape for the first
contour.
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7. In the Matte Visibility Settings panel of the Animated Matte Generator view, disable the Outer
Contour

and enable the Inner Contour

.

8. In the Camera view, adjust the matte points until you obtain the expected shape for the second
contour.

9. In the Matte tab of Layer Properties view, click on the Create Bezier

button of the

Interpolation Factor property.

10. If the Parameters column is not enabled in the Timeline view, click on the Show Parameters
button in the bottom-left corner of the Timeline view to display it.
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11. In the Timeline view, locate the Animated Matte Generator layer and click on the Expand
Parameters

button on its right to list its parameters.

The Interpolation Factor parameter will appear in the list of parameters, second to the
Snapping Source parameter.

12. Move the Timeline cursor to the frame where you want to start animating the matte.
13. In the Parameters column of the Timeline view, right of the Interpolation Factor parameter, set
the desired value for the interpolation factor at the current frame:
l

An interpolation factor closer to 0 will generate a drawing that looks closer to the outer
matte of the animated matte generator.

l

An interpolation factor closer to 100 will generate a drawing that looks closer to the
inner matte of the animated matte generator.

l

An interpolation factor set to 50 will generate a drawing that is an in-between of the
outer and inner contours.

14. Move the Timeline cursor to the frame where you want to create your interpolation pose.
15. In the Parameters column of the Timeline view, set the desired value for the Interpolation Factor
parameter at the current frame.
16. Repeat steps 14 and 15 until you've completed your interpolated contour animation.
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About the Feathered Effect of the Animated Matte Generator
One of the most important capabilities of the Animated Matte Generator is to create a feathered effect. This
effect is generated by filling the inner contour of the matte with a solid colour, and the outer contour with a
gradient going from the inner contour colour to its outer contour colour. This gradient is made to fit the shape of
both the inner and the outer contours, allowing you to generate glows, shadows and light effects with specific
shapes.

To create a feathered effect, the Output Type parameter of the Animated Matte Generator must be set
to Feathered. When this option is use, the Animated Matte Generator ignores the colours in the source
drawing and only uses the shape of the inner and outer contours. The inner and outer colours of the feathered
effect, as well as the way they are interpolated, can be set in the Advanced tab of the Animated Matte
Generator's Layer Properties.
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Creating a Feathered Effect with the Animated Matte Generator
T-COMP2-002-012

How to create a feathered effect with the Animated Matte Generator
1. Make sure the source drawing connected to the Animated Matte Generator closely matches the
outer shape of the intended effect, but that it is simple, does not have too many vector points and is
only painted in a single colour.

2. In the Node or Timeline view, select the Animated Matte Generator node.
3. In the Tool Properties view, set the Output Type to Feathered.
4. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
5. In the Camera view, click on Render View to see what the feathered effect will look like when
rendered as you configure and animate it.
6. In the Tools toolbar, select the Transform

tool.

7. In the Animated Matte Generator view, do one of the following:
l

If you want the Outer Contour to be based on the shape and dimensions of your matte
drawing and the Inner Contour to be smaller, disable the Outer Contour
enable the Inner Contour

l

option and

option.

If you want the Inner Contour to be based on the shape and dimensions of your matte
drawing and the Outer Contour to be bigger, enable the Outer Contour
disable the Inner Contour

option.

8. In the Animated Matte Generator view, enable the Define Matte Point
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9. In the Camera view, move the control points that you want to separate to their intended position.
For example, if you are editing the outer contour, you would want its control points to wrap around
the inner contour. If you are editing the inner contour, you would want its control points to be inside
the outer contour.

TIP
If you want to quickly scale up the outer contour or scale down the inner contour, you
can enable the Scaling Controls

option in the Animated Matte Generator view to

scale all the points of the matte contours simultaneously.
10. In the Layer Properties view, select the Advanced tab.
11. In the Interpolation Mode drop-down, select one of the following options:
l

Distance: Generates a linear gradient going from the inner contour to the outer contour.

l

Parametric: Generates a linear gradient going from each side of the inner contour to the
corresponding side of the outer contour. This mode is different from the Distance
interpolation mode by how it makes the gradients track the matching sides of the inner and
outer contours.
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l

Dot: Generates a gradient going from the inner contour to the outer contour, but based on a
power function that creates the illusion of a thinner, harder outline.

l

None: The outer and the inner contour are solid shapes, filled with their respective colours.

12. In the Colour Interpolation dropdown, select one of the following options:
l

Constant: Generates a gradient based on the inner colour, gradating in transparency only.
The inner contour will have the opacity of the inner colour, and will gradate towards full
transparency towards the outer contour.
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l

Linear 2 Colours: Creates a gradient that steadily gradates from the inner colour to the outer
colour.

l

Gamma 2 Colours: Creates a gradient that gradates from the inner colour to the outer colour
on a Gamma curve, the power of which can be set in the Colour Gamma field. For more
information, see the Colour Gamma field section below.

13. If you set the Colour Interpolation parameter to Gamma 2 Colours, adjust the Colour Gamma
parameter until you obtain the desired effect. When the Colour Gamma is set to any value between
0 and 1, the gradient will ease in from the inner colour to the outer colour. When it is set to any
value above 1, the gradient will ease out from the inner colour to the outer colour.

14. Set the Inner Colour to the colour that should fill the inner contour of the matte.

1458

Chapter 15: Effects

15. Set the Outer Colour to the colour that the Inner Colour should gradate to in the outer contour.
NOTE
If the Colour Interpolation mode is set to Constant, this option will be disabled and the
colour will simply gradate to full transparency.
16. In the Alpha Interpolation dropdown, select one of the following options:
l

Linear: Steadily gradates from the inner contour's alpha to the outer contour's aplha.

l

Gamma: Calculates the alpha going from the inner contour to the outer contour based on a
Gamma curve, the power of which can be set in the Alpha Gamma field. For more
information, see the Alpha Gamma field section below.

17. If you set the Alpha Interpolation parameter to Gamma, adjust the Alpha Gamma parameter until
you obtain the desired effect. When the Alpha Gamma is set to any value between 0 and 1, the
alpha values will ease in from the alpha value of the inner colour to the alpha value of the outer
colour. When it is set to any value above 1, the alpha values will ease out from the alpha value of the
inner colour to the alpha value of the outer colour.

1459

Harmony 15.0 Premium User Guide

About Snapping with the Animated Matte Generator
You can make some of the points and contours of the animated matte snap to the contours of a drawing in your
scene. This is especially useful if you want to use the Animated Matte Generator to create highlights or
shadows and you need the effect's outlines to match a drawing's outlines.
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Connecting a Snapping Source Drawing to an Animated Matte
Generator
T-COMP2-002-013
In order to make the contours of an Animated Matte Generator to a drawing in your scene, you must first
connect that drawing to the Animated Matte Generator node through its Snapping Source (left) port.
NOTE
The Snapping Source drawing of an Animated Matte Generator must be a single vector drawing
node. Snapping will not work with any other type of node.

How to connect the Animated Matte Generator to a snapping source drawing
1. In the Node view, create a connection going from the output port of the snapping source drawing
node to the Snapping Source (left) input port of the Animated Matte Generator node.

2. Create a connection going from the output port of the snapping source drawing node to the input
port of the source drawing node. This will ensure that if the snapping source is moved or animated,
the matte will follow the movement of the snapping source.
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Making Matte Contours Snap to a Drawing
T-COMP2-002-013A
In order for matte points and contours to snap to the contours of the snapping source drawing, you must use
the Set to Snap mode of the Animated Matte Generator view to select which points and which contours of the
matte should snap.

How to make an Animated Matte Generator snap to the contours of the snapping
source drawing
1. In the Node or Timeline view, select the Animated Matte Generator node.
2. Display the controls of the Animated Matte Generator node by doing one of the following:
l

In the Camera view toolbar, click on Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11.

.

The control points for the Animated Matte Generator display in the Camera view.
3. In the Tools toolbar, select the Transform

tool.

4. In the Editing Mode panel of the Animated Matte Generator view, select Define Matte Point

.

5. Adjust the contours of the matte so that they are close to the contours of the snapping source
drawing. Contours and points will only snap if they are at a short distance from the contours of the
snapping source drawing.

6. In the Editing Mode panel of the Animated Matte Generator view, select Set to Snap

.

Switches to enable or disable snapping appear over each of the matte's contours and points in the
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Camera view.

7. In the Camera view, do one of the following:
l

To enable or disable snapping on a matte point, click on its control point.

l

To enable or disable snapping on a matte contour, click on the snapping switch for that
contour.

Points that are set to snap will appear green instead of purple. Contours that are set to snap will
have a magnet icon on their snapping switch.
8. If a point or contour does not snap to the contour of the snapping source drawing, adjust the
position and curves of the matte so that they are closer to the contour of the snapping source
drawing.
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TIP
You can adjust the maximum distance from which a matte point or contour will snap to the
drawing source, whether the matte should snap to all contours or only the outlines of the
snapping source as well as which one of the snapping source's art layers the matte snaps to in
the layer properties of the Animated Matte Generator.
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About Particles
Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, grass or
fire to more complex systems, such as swarms of animated insects-- all in a fraction of the time it would usually
take.

Particle effects act in the same way as all other effects in Harmony, except they always work within their own
specifically structured system. You can attach a Blur effect node under a Drawing node and the image
contained in the Drawing node will become blurry. Particle effect set-ups are more complex than simply adding
a node and playing with its parameters. To keep things simple, just think of each Particle effect as its own
group.
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About the Particle Basic Structure
This is what the basic structure of a particle system looks like in the Node view. This structure can change
depending on the type of effect you are trying to create.

To learn more about each particle node, see the Reference guide .
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About the Particle System Colour Coding
Particle effects are colour coded to make them easy to identify by colour and function. Each colour represents a
different function. For example, Action nodes, such as Velocity, Move-Particles and the Sprite Emitter are
bright purple. These colours can be edited in the Preferences dialog box by going to Edit / Harmony Premium
> Preferences > General tab > Edit Colours button > Particle tab.

In addition to defining groups by colour, node in-ports and out-ports are also colour-coded. In the network
shown in the illustration above, the Particle-Baker is dark yellow and the Particle Visualizer purple. Look closely
and you will notice that the in-port on the Particle Visualizer, where the Particle-Baker is connected, is also
dark yellow. Similarly, the out-port on the Particle-Baker, where the Particle Visualizer is connected, is purple.
This system gives you an idea, at the very least, of what type of node is needed to fill a specific port.
l

Visualizer - This node assembles a particle system through its middle port. It can accept a Peg on either
side. The system is flattened at this node and generated as a single image. This lets you move the
effect's position in your scene or change its render order.

l

Action - These nodes affect the particle dynamics; they determine how they are created and moved
around in space. If there are multiple Action nodes hooked to a composite, they are executed from right
to left. Due to this ordering, there should generally be an emitter on the right-most port.

l

System Composite - Unlike a regular composite that reads all the position information from its in-port
nodes and combines them accordingly, a System Composite is specifically designed to handle Action
node information.

l

Baker - These nodes allow you to make decisions about the particle system's position, angle, number, etc. the
same way that a baker would make decisions about the ingredients that go in a cake.

l

Region Composite - This node combines Region nodes. In case you have more than one Region in your
effect, this composite will help define the position and render order of the different Regions.

l

Region - These nodes are used to define the region from where the particles are emitted. These regions
can be Planar or 3D.
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Accessing Default Particle Templates
Harmony comes with some basic Particle effect templates. You can change the effect's "sprite" with a drawing,
image or animated sequence of your own. Then tweak its properties to adjust the effect to your liking. Or you
can use the templates to analyze their structure so you can build your own.
NOTE
To learn more about each particle node, see the Reference guide .

How to access the Particle templates
1. From the top menu, select Insert > Particle > and one of the following Particle effect templates:
l

Basic Particle System: This effect template has the simplest structure and the parameters for
all of its nodes are set to the default values. For example, the Planar-Region has not been
rotated or resized, the particles have not been randomized in the Sprite-Emitter, and the
particles start their generation on the first frame and die out at the maximum number allotted
in the Particle-Baker.

l

Basic Gravity Based System: This effect template simulates particles being generated from a
source with special emphasis on adding gravity to the particle system.

l

You also have access to pre-built examples :
l

Animated Grass - Simulates a patch of grass that is swaying in the wind. Uses an
animated drawing layer as a sprite.

l

Bees - Simulates a crowd of bees flying around. Uses an animated drawing layer as a
sprite. Animate the position of the bees using the Peg layer.

l

Bouncing Balls - Simulates the randomness of a set of bouncing tennis balls.

l

Bubble Vortex - Simulates a swarm of insects emerging from a single origin point (such as
the opening of a hive) and forming a tornado-shaped, tubular vortex.

l

Confetti - Simulates confetti being thrown upward and falling back to the ground.

l

Fairies - A fun example of how you can have a particle (the Fairy) which generates particles
(the Fairy Dust).

l

Fairy - An example of how you can create a trail of Fairy Dust following an animated
drawing layer.

l

Fire - Simulates a camp fire.

l

Fire_Particles - Simulates a large fire filing the entire screen width.
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l

Grass - Simulates a static patch of grass at a fully grown state.

l

Horizontal Speed Lines - Simulates horizontal speed lines that will radiate in one direction
from a central point.

l

Leaves - Simulates autumn leaves falling in the wind.

l

Lemmings - Simulates the classic game Lemmings. Uses an animated drawing layer as a
sprite. This is also a good example to use to learn how to use Bounce Planes, as the
particles will fall until they hit a bounce plane.

l

Looping Dust - Simulates a cloud of dust twirling in the wind.

l

Rain - Simulates a fairly turbulent rainfall with 3 different coloured raindrops.

l

Rain 2 - Simulates rain water splashes as drops hit the ground

l

Rain3 - Simulates a fine rain falling vertically.

l

Snow Windy - Simulates snowflakes falling in the wind.

l

Sparkly 2 Colours - Simulates magical sparkles.

l

Speed Lines - Simulates radial Speed Lines that will radiate outwards from a central point.

l

Spay Wand - Simulates a wan spraying magical sparkles at a target.

l

Toon Fire - Simulates a more cartoony camp fire.

l

Trail Particles - Simulates a trail of sparkle following a given path.

l

Twinkle Particles - Simulates a shower of twinkling particles.

1469

Harmony 15.0 Premium User Guide

About Light Shading in Harmony

Cut-out animation allows for great advancements and time saving in production, but it has certain limitations.
One of the main advantages of using a cut-out puppet is the ability to reuse your characters without having to
redraw them and you can modify your animations very quickly. This speeds up the process quite a bit. One of
the disadvantages of cut-out animation when wanting to retain the time saving factor and ability to quickly
modify an animation, is the fact that you cannot easily create tones and highlights. To do so, you must draw all
the highlight zones for each frame by hand. Following that, if you want to modify your animation, you have to
redraw those zones. This slows down the process. There are a few tricks for doing simple automated
highlights, but the results are not always convincing.
The Harmony Light Shading effect provides a proper solution to this issue. It allows you to add a few nodes to
your original puppet rig and obtain a customizable lighting effect on your characters. It can be applied to any
object in your scene, not only on cut-out characters. The light shading effect allows you to define your volume
zones as well as your light source and animate its position.
In Harmony, all drawings are flat 2D planes, unless you imported 3D elements. A light source cannot interact
well with a flat shape to create tone and highlight areas within it. To create shading zones, Harmony uses the
bevel principle to create a three-dimensional shape illusion. To do that, you must define which object or
combination of objects should be defined as a volume. Next, you can carve and emboss areas using colour zones
within the volumes to create what is referred to as 3D geometry.
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If you have a scene with one single drawing layer, you will define that layer as your volume object, since there
are no other elements in the scene. The light shading effect will emboss the contour of the shape, but if you
want to have highlight and tone zones within the drawing, you will need to carve and emboss areas using
specific colour zones.

If you have a cut-out character composed of several drawing layers, you will need to identify the different layers
or group of layers you want to define as volume objects. For example, you could group the arm, forearm and
hand layers as one object, while the head could be another volume. Depending on your design, you will have to
analyze and decide what should be grouped. You can then use colours to carve areas within those volumes.
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The beauty of the light shading effect is that you only have to set it up once. You can animate the light source
position, shading style, as well as colour and your volume objects, carving and adding areas will be accurately
used. There's no need to redraw another set of zones depending on the light source or even draw tones for any
animation frames. This only needs to be done once in the character rig. The compositing artist will then have
the freedom to play around with the light positioning and ambiances.

Harmony provides you with a series of nodes and parameters allowing you to shape, carve and model your
image's 3D geometry as you like. Each volume object has an ID number. You can have several volumes using the
same ID so they can receive the same shading, smoothing and bevelling parameters. If you want to treat each
area individually, you can assign them different ID numbers.
You also have the possibility to create tones, not only highlights. You can also combine both on the same image.
Both tones and highlights react to the same carving colours, modelling parameters, and set volume objects.
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About Light Shading Nodes
You can build your light shading effect using these five nodes:
l

Volume Object on page 1474

l

Normal Map on page 1474

l

Light Position on page 1475

l

Light Shader on page 1476

l

Tone Shader on page 1476

To learn more about each node's parameters, see the Reference guide .

Volume Object
The Volume Object node lets you define a volume zone the light will interact with.

If there is a single drawing on which you want to apply shading, you only need one Volume Object node. For
cut-out characters, you will require more as you will define which should be different volumes. For example, you
could decide that the arm, forearm, and hand will form one shape for the light to hit and create a highlight. You
could then define the body as a separate volume. If you use different Volume Object nodes on the arm pieces,
you will get odd carvings and bumps where the joints overlap. Before adding light shading to your rig, you
should analyze how the parts will interact with one another.
All the Volume Object nodes in your structure will be gathered in the Normal Map node where you can define
the parameter for each volume.

Normal Map
The Normal Map node lets you centralize all Volume Object nodes and chisel out the shading 3D geometry
(bevel height, smoothing, carving, etc.). It could be described as carving a bas relief. You only need one Normal
Map node per light shading effect and, in general, only one per scene.
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A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to
a format supported by your plugin. The Normal Map Converter node has been optimized to work with
GenArts® plugins, but you also have the ability to use it on custom plugins..

Light Position
The Light Position node is the actual light source interacting with all the defined volume objects. You can set its
position in relation to the objects and animate it over time. All volumes will react according to the light's motion.

This is not where you set the light type or colour. You'll be adjusting these in the Light Shader and Tone Shader
nodes.
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Light Shader
The Light Shader node lets you adjust the highlight parameters, such as the colour, to create the desired
ambiance. You can animate most parameters over time to create a mood change, sunset or any other type of
light transition. The beveling height and smoothing is set in the Normal Map node.

Tone Shader
The Tone Shader node lets you adjust the tone parameters, such as the colour, to create the desired ambiance.
You can animate most parameters over time to create shade transitions. The beveling height and smoothing is
set in the Normal Map node.
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Light Shading Setup
The first step in setting up your light shading effect is to identify which volumes you want the light to interact
with.
To learn more about each node's parameters, see the Reference guide .
Here's what a basic light shading effect node structure looks like:

How to set up a basic light shading effect
1. In the Node Library view, select a Volume Object node from the Shading category and drag it to
the Node view.
2. In the Node view, connect the Volume Object node between the drawing node and the Composite
node. Click on the node's properties button (yellow square) and rename it with the volume it
represents. This will make it much easier to edit the beveling in the Normal Map node later on.
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If you need to combine several elements into one volume, you can connect the elements into a
Composite node set to Pass-Through and connect that Composite node to the Volume Object node.

3. In the Node Library view, in the Shading category, select a Normal Map node and drag it to the
Node view.
4. In the Node view, connect a second connection from the Volume Object node to the Normal Map
node. Don't connect the Normal Map's output port yet.
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5. In the Node Library view, in the Shading category, select a Light Shader or Tone Shader node and
drag it to the Node view.
6. In the Node view, connect the Normal Map output node to the shader node's middle input port.

7. From the Volume Object node, pull out a third connection and connect it to the shader node's right
input port.
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8. In the Node Library view, in the Shading category, select a Light Position node and drag it to the
Node view.
9. In the Node view, connect the Light Position output node to the shader node's left input port
(green).
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10. Connect the shader's output port to the Composite node to the left (in front) of the Volume Object's
Composite connection. This will display the light shading effect on top of the original drawing.
Connecting it to the right would result to nothing as the effect would be hidden behind the
drawing.

11. If you added colours to your drzwing to carve in some areas, in the Node Library view, select a
Colour-Override node and drag it to the Node view.
12. In the Node view, connect the Colour-Override node between the Volume Object and the
Composite nodes. Make sure the Volume Object node is connected to the Colour-Override's right
input port.
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13. Click the Colour-Override node's properties button (yellow square) to open the Layer Parameters
dialog. From the Colours section, drag your carving colours to the Individual Colour Overrides
section. In the Mode column, set all your colours to Colour not visible.

14. To combine both the Tone Shader and the Light Shader, from the Node Library bring the other
shader node and drag it to the Node view.
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15. In the Node view, connect the same Light Position, Normal Map and Volume Object nodes to the
new shader node.

16. Click the Normal Map node's properties button (yellow square) to open the Layer Parameters dialog.
17. In the Volume Creation section, from the Object List , select all the Volume Object nodes you want to
use in this map.

‣

It's possible to add all Volume Object nodes at the same time by selecting the Add all Defined
Objects option or it's possible to add each Volume Object node one by one.

18. In the Camera view, enable the Render mode to view the final effect.
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19. See the Reference guide to adjust the light shading parameters.
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Adding and Carving Volumes
Once your basic volumes are set up, you can use colours from your colour palettes to carve or add zones.
Depending on the design of the drawing, you may want to use the same palette as the character, background
or object, or you may want to use a specific palette reserved specifically for this purpose.

To learn more about each node's parameters, see the Reference guide .

How to add and carve volumes
1. Add colour swatches in your character's colour palette or in a new palette solely reserved for
carving. Name them Carving and Adding. By choosing different colours, it will be easier to
differentiate where those colours will carve or add.
2. In the Camera or Drawing view, draw the areas you want to carve out and add. It's recommended to
draw them in the Underlay or Colour Art layer.
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3. In the Node view, click the Normal Map's properties button (yellow square) to open the Layer
Properties window.
4. In the Override Modelling by Colour section, click Add Colour and select the palette containing your
carving and adding colours.

5. Add your Carving and Add colour swatches.
6. Increase or decrease the Carving - Adding value by adjusting the slider to carve or emboss your
volumes using the colour zones.

7. In the Camera view, enable the Render mode to view the final effect.
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Animating the Light Source and Target
You can set up the light source and animate it.

How to display the controls of the Light Position node
1. In the Node view, select the Light Position node.
2. Do one of the following:
‣

In the Camera View toolbar, click the Show Control

button.

‣

From the top menu, select View > Show > Control.

‣

Press Shift + F11 (Windows/Linux) or ⌘ + F11 (macOS).

A yellow camera appears in the scene, representing the light source.
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How to animate the light source and the target
1. In the Tools toolbar, select the Transform

tool and animate the light source or target.

2. Before moving the light source for the first time, you must move the light to make it visible. At the
moment, the target is not visible because it is hidden behind the light source.
A red line appears, starting at the light source. This line represents the direction of the light. The
green dot at the end of the line represents the target. Depending on the setting of your Light
Shader or Tone Shader node, the direction or target may be more useful.
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About OpenFX
T-COMP2-008-002A
To expand your compositing possibilities, you can use OpenFX plugins directly in Harmony.

OpenFX is an open standard used to create visual effects plugins. These plugins can be used in any application
that supports the standard. This means that banks of visual effect plugins can be developed by programmers
and shared with various platform users. Harmony is one of these platforms.
To learn more about OpenFX, refer to:
l

openfx.sourceforge.net

l

openeffects.org

To learn more about the main OpenFX plugin providers, refer to:
l

toolfarm.com/products/category/3316/all

To demonstrate this feature, the Sapphire package from GenArts® will be used. You can download the
Sapphire library at:
l

genarts.com/sapphire
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Installing an OpenFX Package
T-COMP2-008-002B
Once you have purchased or downloaded an OpenFX package, you need to launch the executable file to install
it. All OpenFX plugins install in a centralized location that all applications can read from. You will not need to do
anything in Harmony. They will appear automatically in the Node Library view once the package of your choice
is installed.
Here is the centralized installation path:
l

Windows: C:\Program Files (x86)\Common Files\OFX\Plugins

l

macOS: /Library/OFX/Plugins

l

GNU/Linux: /usr/OFX/Plugins

How to install an OpenFX package for Harmony
1. Download the OpenFX package you want to install.
2. Quit Harmony.
3. Launch the OpenFX package installer and follow the installation instructions.
4. Launch Harmony.
5. In the Node Library view, in the Categories section, select the category matching the package's
name.
All effects included in the package are now available to use in Harmony.
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Using OpenFX Plugins
T-COMP2-008-002C
All OpenFX plugins can be customized by adjusting their parameters. Settings are organized by category and
some of them can be expanded and collapsed for clarity. Parameters can also be animated over time.
Some effects also have visual controls to set the position or angle. If you want to adjust the controls for your
effect, you must do so in OpenGL mode. To see the effect in OpenGL mode, you need to connect a Render
Preview node to your effect.

How to use and edit an OpenFX plugin in Harmony
1. From the Node Library view, select an effect plugin and drag it to the Node view.
2. Connect your drawing nodes or other required nodes to the effect plugin.
3. In the Camera view, enable the Render

mode to see the final rendered effect.

4. In the Node view, click the effect node's yellow square to open the Layer Properties window and
adjust its parameters.
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NOTE
In the Layer Properties window, you can expand some parameter sections to see many more
controls.

5. Adjust the effect's visual control in OpenGL mode by dragging a Render Preview node from the
Node Library view to the Node view. Connect it between the plugin and the Composite nodes.
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6. In the Camera view, enable the OpenGL

mode to see the rendered effect in OpenGL.

7. To display the controls, in the Node view, select the plugin effect node and do one of the following:
l

In the Camera toolbar, click the Show Control

l

From the top menu, select View > Show > Control.

l

Press Shift + F11 (Windows/Linux) or ⌘ + F11 (macOS).

The controls appear.
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8. In the Tools toolbar, select the Transform

tool or press Shift + T.

9. In the Camera view, adjust the controls.
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Using the Normal Map Converter
Harmony has the ability to generate normal maps. The main usage is to create light shading effects on flat 2D
drawings. The normal map will carve and emboss a flat plane using vectors. The X, Y and Z coordinates of the
normal map vectors are stored in RGB values to convert the 3D aspect into a visual result and use it to create
various effects, such as light reflections (light shading). The X value is stored in the Red channel. The Y value is
stored in the Green channel. The Z value is stored in the Blue channel.

A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to
a format supported by your plugin. The Normal Map Converter node has been optimized to work with
GenArts® plugins, but you also have the ability to use it on custom plugins.
NOTE
Note that not all normal map formats are supported.
The Normal Map Converter uses the following formula per channel:
l

value * (+/- length) + offset

l

* +/- depending if inverse is set to true ("-" if true)

How to use the Normal Map Converter node
1. In the Node Library view, go to the Shading category and select the Normal Map Converter node.
2. Drag it to the Node view.
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3. Connect the Normal Map Converter node between the Normal Map node and your custom plugin
node.

4. Select the Normal Map Converter node.
5. In the Layer Properties view, adjust the node's properties.

Parameter

Description

Conversion Type

By default, the conversion type is set to Genarts. If you work
with a different manufacturer and want to adjust the
parameters, set the conversion type to Custom.

Offset

Offsets the original position of the vector. You need to read
the plugin documentation to know the offset you need to use.
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You must use the same offset value as the manufacturer is
using. By default the offset is set to 0.

Length

Invert Red

The Normal Map Converter normalizes Harmony vectors to 1.
By default the length value is set to 1. If your plugin requires
shorter or longer vectors, enter a value smaller or greater than
1. It will multiply the vector length.
Inverts the red value (x). If your value is 125, the invert setting
will transform it to -125.

Invert Green

Inverts the green value (y). If your value is 125, the invert
setting will transform it to -125.

Invert Blue

Inverts the blue value (z). If your value is 125, the invert
setting will transform it to -125.

6. If the plugin you are using stores the X,Y and Z coordinates in different channels, you can use the
Channel-Swap node to reassign the colour channels.
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About Node Categories
Customizing the categories is a great way to organize the nodes according to how you like to work and the
nodes you use most often. You can easily add categories and subcategories, remove categories you don't use,
and rename categories.

Displaying All Nodes

1499

Adding a Node Library View Category

1500

Removing a Node Library View Category

1502

Renaming a Library View Category

1503

Adding Nodes to Categories

1504

Removing Nodes from Categories

1505

Searching for Nodes, Categories, and Descriptions

1506
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Displaying All Nodes
You can display all the nodes available in the Node Library view.

How to display all the nodes
1. If a category is selected and you want to see all the nodes available in the library, in the Node
Library view, place your cursor in the Node Search field.

The Node Library view displays all the nodes.
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Adding a Node Library View Category
You can add a Node Library view category to organize your most commonly used nodes or group them in a
more convenient way to your pipeline.

How to add a category
1. Do one of the following:
l

To create a new main category, click in the Node Search field.

l

To create a subcategory, select a category.

2. Do one of the following:
l

From the Node Library menu, select New Category.

l

Right-click in the category area and select New Category.

The New Category window displays.

3. In the New Category window, type in the name of a new category and click OK.
The new category appears in the Category list. Now you can add nodes to your new category—see
Adding a Node Library View Category on page 1500.
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Removing a Node Library View Category
You can remove custom categories you are not using in the Node Library view.

How to remove categories
1. From the Category list, select a category to remove.
2. Do one of the following:
l

From the Node Library menu, select Remove Category.

l

Right-click in the category area and select Remove Category.

The Confirm Remove Category window displays.

3. Click Yes.
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Renaming a Library View Category
You can rename a Node Library view category to keep it organized.

How to rename categories
1. From the Category list, select a category to rename.
2. Do one of the following:
l

From the Node Library menu, select Rename Category.

l

Right-click in the category area and select Rename Category.

The Confirm Rename Category window displays.

3. Type in a new name for the category and click OK.
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Adding Nodes to Categories
Once you've created a category, you can add nodes to it for easy access. Later on, you can go back and remove
any nodes you no longer use. You can only add and remove nodes from a category you created.
When you add a node to a new category, it is essentially a copy of the node. The node in its default location
remains there. You cannot delete nodes from their default categories or move them.

How to add nodes
1. Select a node from any category and drag it to a category you created.

A copy of the selected node is added to your new category.
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Removing Nodes from Categories
You can remove nodes you no longer use from custom categories.

How to remove nodes
1. Select a node from a category you created.
NOTE
Nodes from the default categories cannot be removed.
2. Do one of the following:
l

From the Node Library menu, select Remove Node.

l

Right-click in the category area and select Remove Node.

l

Press Del.

The node is removed from the category.
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Searching for Nodes, Categories, and Descriptions
Sometimes it's faster to type in the name of a node instead of looking through all the categories. You can also
search for category names or descriptions as well. Once you type in the name of a node, description or category
in the Node Search tool, it is displayed in the library. Sometimes the result of a node search is in one or more
categories for convenience.

How to search for nodes
1. In the Node Library, place your cursor in the Node Search field.

The Node Library view displays all the nodes.
2. Type in the name of a node, category or description.
Depending on how you are viewing the nodes, the Node Library view displays the node, categories
and/or description you typed in.

3. To return to displaying all the nodes, place your cursor in the Node Search field again and delete the
node name in the Search field.
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Chapter 16: Sound
With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to
trim unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to
continue throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection.
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would
best apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for
your character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your
animation based on the mouth chart.
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About the Sound Editor
When you double-click on a sound layer in the Timeline view, the Sound Element Editor appears.

l

Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

l

Layer Name: This field displays the layer's name.

l

Sound Editor: This button opens the Sound editor.

l

Start Frame/End Frame: These fields determine the start and end frame of the sound file.

l

Detect: This button launches the automated lip-sync detection.

l

Map: This button opens the Map Lip-sync dialog box.

l

Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the
thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Layer
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view.

If you double-click on a sound layer in the Timeline view, or in a sound column in the Xsheet view, the Sound
Element Editor dialog will open. This dialog allows you to fine-tune the sound track's lip sync, start time, stop
time and volume.
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NOTE
Contrary to all other layers, sound layers are not represented by nodes in the Node view.
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Importing Sound
T-HFND-007-009
If you wish to add sound to your animation, it is recommended to edit and mix your sound files in a sound
editing software. Having full-length pre-mixed soundtracks ensures the audio preserves its timing, mixing and
quality should you use third party software for post-production. Another good practice is to keep your
soundtrack separated in tracks for music, sound effects and characters to make it easier to sync your animation
with voices and sounds. Otherwise, it is possible to clip sound effects and adjust their volume directly
in Harmony when needed.
If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the
exported scenes, allowing you to save time on splitting and importing your sound track.
Harmony can import .wav, .aiff and .mp3 audio files.
NOTE
Importing a soundtrack longer than your scene will not extend your scene's length. Sound playback
will stop at the end of your scene's length.

How to import a sound file
1. Do one of the following:
l

From the top menu, select File > Import > Sound.

l

In the Xsheet view, right-click anywhere in the frame area and select Import >
Sounds.

l

From the Xsheet menu, select File > Import > Sounds.

l

From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.
2. From the Select Sound File dialog box, find and select a sound file.
The sound file appears as a layer in the Timeline view. Its waveform is displayed in the track to help
you visualize at which frames the sound effects in your soundtrack occur.

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by
default. If you wish, you can display a sound column's waveform by right-clicking on it, then
selecting Sound Display > Waveform.
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Playing Sound
T-HFND-007-010
Before playing back any sound, click the Enable Sound

button in the Playback toolbar or enable it through

the Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the
ones included within symbols.
If there are two or more sound layers and you want to listen to them independently, you can disable the
unwanted sound by clicking the Disable Layer

button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you
can do one of the following to troubleshoot the issue:
l

Shrink down the Camera view size to reduce the cached image size.

l

Playback your scene without sound first, then add the sound. If you do not cache the images first without
sound, the playback will try to follow the sound by skipping images that will never get cached.

l

In the Preferences panel, in the OpenGL tab, reduce the size of the Playback Cache Size (in mb)
preference.

How to play back sound
1. To select a starting point:
l

In the Xsheet view, click on a cell in the sound column.

l

In the Timeline view, click on a cell in the sound layer. You can also slide the red
playhead to the correct cell.

2. In the Playback toolbar, activate the Enable Sound

button.

3. Do one of the following:
l

Click the Play

button in the Playback toolbar.

l

From the top menu, select Play > Play or click on the Enter/Return key.

4. To hear the sound played back again and again, do one of the following:
l

Click the Loop

button in the Playback toolbar

l

From the top menu, select Play > Loop.

5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer
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Changing the Sound Display
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing
needs.
You can show or hide the waveform in the Timeline view by selecting the Waveform

button in the Timeline

View toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by
default.

How to change the sound display in the Timeline view
1. In the Timeline view's right area, right-click in the frame section and select Show Sound
Waveforms or in the Timeline view menu, select View > Show > Show Sound Waveforms.

l

You can change the waveform scale using the Zoom Waveform

icon on individual sound layers in

the Timeline view's left side.

How to change the sound display in the Xsheet view
1. Right-click in the sound column or on the sound column header, and select Sound Display and one
of the following:
l

Sound Name: Shows the name of the sound file, as well as the file format. The line
running vertically through the column frames between the same file name indicates a
continuity of the same sound file in these frames.

l

Mouth Shapes: Shows the letter (or name depending on the way you named your
character's different mouth positions) in the column's frames. There is only one mouth
position allotted per frame and this position should correspond to the sound file after
performing a lip-sync.

l

Waveform: Shows a vertical display of the sound file's actual waveform. In the column
header, in the field under the column name, you can type in a percentage to zoom in or
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zoom out on the waveform, or pass the scroll cursor
icon.
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds
from the Timeline view.

How to scrub a sound from the Timeline view
1. Do one of the following:
‣

From the top menu, select Play > Enable Sound Scrubbing.

‣

Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣

In the Playback toolbar, enable the Sound Scrubbing

button.

2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent
sound frames. This allows you to do a more fluid scrubbing.
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About Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real
time. It also means that as you scrub over a frame, you will hear the section of your sound file that is allotted to
that frame. As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to
hear nuances in pitch and tone.
Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back
according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle and jog
sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can
be used in conjunction with Harmony for improved analog sound scrubbing results.

NOTE
Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony
Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog
controls.

l

Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline view
jump by large increments in the direction you are moving the shuttle.
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l

Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental movements along
the soundwave. Use the Frame field to see the frame number which you are on. As you rotate the dial,
your speed in fps appears directly after the FPS field.

How to perform an analog sound scrub
1. Do one of the following:
‣

From the top menu, select Play > Enable Sound Scrubbing.

‣

Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣

In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences
(macOS).
3. In the Sound tab, select the Analog Sound Scrubbing option.
4. Click OK.
5. Do one of the following:
‣

In the Playback toolbar, use the Shuttle to find the general location of where you want to start
your sound scrub.

‣

In the Timeline view, drag the red playhead to the desired location.

6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing Sound
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of
Harmony and imported into your scene.

How to open the Sound Element editor
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.
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l

Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard
when the final movie is rendered. It may be shorter than the original sound sample due to the
length of the scene. If any edits are made to the sound sample, they can be heard here. In the Sound
Element panel, notice the coloured tabs that indicate the start and end frames of a sound segment.
The frame number is displayed in the tab.

l

Current Sound: Displays the original sound file in its entirety and is where you can edit its
properties. This window remains empty until you click inside the Sound Element Editor.

l

Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.

1521

Harmony 15.0 Premium User Guide

Cropping Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make
sure the sound ends by a certain frame, you must set an end frame.
In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame
number is shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.

How to change start or end frame of a sound
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish
one sound section from another on the same sound layer, check the frame numbers that appear on
tabs flanking the start and stop lines of each waveform section.

Click the Play

button in the Current Sound section (only the selected sound plays).

3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to
start playing.
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two
clips in the same element.
4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

5. To hear how all the clips fit together in the element, click the Play

button in the Sound Element

section.

If you only want to hear the selected clip, click the Play
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6. Click Apply/Next.
The Xsheet and Timeline views display the sound clip at the start frame you selected.
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Trimming Sound
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise.
The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest.
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to
edit sound files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish
one sound section from another on the same sound layer, check the frame numbers that appear on
tabs flanking the start and stop lines of each waveform section. Or select a soundwave and click the
Play

button in the Current Sound panel (only the selected sound plays).

3. Using the Current Sound section, decide on the part of the file you want to play by dragging the left
and right boundaries of the selection area.

4. Click the Play

button in the Current Sound section to check that you have trimmed the desired

sections. Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim
it more accurately.

5. Click Apply/Next.
The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end
positions you selected.
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Looping Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
2. From the Sound Element section, select the sound section you want to loop.
3. In the Current Sound section, type the number of times you want the sound to play in the Number of
Loops field.

4. Press the Enter/Return key.
The looped sound appears after the current sound. They are indicated by their grey waveforms, as
opposed to black.
When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until
the next sound sample starts or until the scene ends. This means that the looping could be cut if the
next sound sample starts too soon or if the scene ends too quickly.
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in
and fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original
sound file is not affected.

How to adjust the overall volume of the entire sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
2. In the Sound Element section, select the sound you want to work on.
A more detailed version of the selected sound appears in the Current Sound section.
3. In the Current Sound section, use the Volume slider to adjust the volume.

4. Click the Play

button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the
Xsheet view.
2. In the Sound Element section, select the sound you want to work on.
3. In the Current Sound section, click on the thin blue line above the waveform to add an envelope
marker.
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4. Drag the envelope markers to adjust the volume at that frame and to create the time of the
transition. The line from the edge of the clip to the envelope marker identifies how the volume
increases (fades-in) or decreases (fades-out) over time.
Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards
increases the volume.
NOTE
To create an even effect, be sure to adjust the envelope markers uniformly in both the left and
right (bottom and top) channels.

5. Click the Play

button in the Current Sound panel to check the fade envelopes.
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Setting the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start
or stop at specific frames. This customized playback range does not affect the actual sound in the Sound
element.

How to change the playback range in the Sound Element editor
1. Drag the start or end range markers in the Sound Element section to the boundary frames you
want.

2. When you click the Play

button to play back your sound in the Sound Element editor, it only

plays the sound which exists between the two markers.
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Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist
on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-quarter view
and have mouth position changes to fit with the sound sample from these two different views, you would need
to cut up the sound samples needed for the profile view mouth positions on one layer and the sound samples
needed for the three-quarter view on another.
For this task, you will need an empty sound layer.

How to add an empty sound layer
1. In the Timeline Layer toolbar, click the Add Layer button.
2. From the drop-down menu, select Sound.
An empty (silent) sound layer appears in both the Timeline and Xsheet views.

3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound
Element editor. Click Apply/Next to accept the change.

1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut
and Shift + click on the final cell of the cut. The sample to be cut becomes highlighted.
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2. Drag the selection into the empty sound layer below.

4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on
to the lip-synching process for each layer and its corresponding facial view.
NOTE
If you need to duplicate your sound layer to keep an unedited copy for safety, select the
Duplicate Selected Layers button in the Timeline View toolbar. You must customize the toolbar
to display this button because it is not included in this toolbar by default.
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About Lip-sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a
particularly tedious part of the animation process.

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE
The letters assigned to these mouth shapes are standard identifiers, they do NOT correspond to
the sound they are meant to produce.
This is an approximation of the English phonemes each mouth shape can be used to represent:
l

A: m, b, p, h

l

B: s, d, j, i, k, t

l

C: e, a

l

D: A, E

l

E: o

l

F: u, oo

l

G: f, ph

l

X: Silence, undetermined sound
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When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated
with the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work,
your character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and
these drawings should be named by their corresponding letter.
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view,
Xsheet view and Sound Element editor.

How to generate a sound detection for lip-sync using the Layer Properties view
1. In the Timeline or Xsheet view, select the sound layer.
The options for that layer will appear in the Layer Properties view.
2. In the Layer Properties, click Detect.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each sound cell.
3. Click the Map button to open the Lip-Sync Mapping dialog box.

4. From the Destination Layer menu, select the layer that contains the mouth positions for the
character's voice track.
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NOTE
If the selected layer contains symbols, you can map the lip-sync using drawings located
directly on the layer or use the symbol's frames. In the Symbol Layer field select Don't
Use Any Symbol if you want to use the drawings or select the desired symbol from the
drop-down menu.
5. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the
phoneme it represents. If your drawings are already named with the phoneme letters, you can skip
this step.
6. Click OK.
7. In the Playback toolbar, enable the Enable Sound
8. Press the Play

option.

button in the Playback toolbar to see and hear the results in the Camera view

How to generate a sound detection for lip-sync in the Xsheet or Timeline view
1. Do one of the following:
l

In the Xsheet or Timeline view, right-click on the sound layer's cells and select LipSync > Auto Lip-Sync Detection.

l

From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

NOTE
To show the mouth chart letters, if they're not already present in the Xsheet view, right-click
on the sound column and select Lip-Sync > Sound Display > Mouth Shapes.
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Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X
markers in the frame are replaced by these designated letters.

How to generate a sound detection for lip-sync using the Sound Element editor
1. Do one of the following:
l

In the Timeline view, double-click on the sound layer.

l

In the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.
2. In Sound Element section, select the waveform for which you want to generate a mouth chart.
3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync
letter to each sound cell.
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Mapping the Lip-Sync Detection
Harmony can automatically map Automatically maps drawings in an element to the mouth chart you have
generated for a sound. This can save time when you are lip-synching a voice track.
In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically
labels all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer
1. To open the Lip-Sync Mapping dialog box, do one of the following:
‣

In the Layer Properties view, click on the Map button.

‣

In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map
Lip-Sync.

‣

From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer menu, select the layer that contains the mouth positions for the
character's voice track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on
the layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you
want to use the drawings or select the desired symbol from the drop-down menu.
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4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the
phoneme it represents. If your drawings are already named with the phoneme letters, you do not
have to do anything.
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Modifying the Lip-sync Detection
You can change the mouth position assigned to a frame if you think another position is more appropriate.
For example, you may have a character who says nothing for 10 frames between two speeches. Harmony
would normally assign an X image for the silent period. However, if you want your character's mouth to hang
open in astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an
F.
If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the LipSync Detection on page 1537.

How to change the mouth position assignment of a sound from the Sound Element
editor and Layer Properties view
1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet
view to open the Sound Element editor.
2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth
position assignment on.
In the Lip-sync image area, the image on top represents the lip position assigned to the current
frame.

3. To change the image assigned to the frame, click on the image of the mouth position you want from
below the preview image. The preview image changes to the mouth position image you select. You
can perform the same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.
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How to change the lip assignment of a sound in the Xsheet or Timeline view
1. Right-click in the cell that contains the mouth position you want to change.
2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that
reflects the mouth position you want to use for that sound. You can also select Animation > LipSync > Change Mouth Shape > the desired mouth shape from the top menu.

NOTE
Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.
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Manual Lip-syncing
You can manually create the lip-syncing for your scene by selecting which mouth drawing should be exposed at
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality,
which plays the part of your sound track at the current frame whenever you move your Timeline cursor,
allowing you to identify which phonemes you should match your character's mouth to. You will also be using
drawing substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the
drawing name (often a letter) until it changes to the swapping

pointer.

5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current
drawing automatically changes to the new selection.

How to animate lip-sync using the Library view
1. In the Playback toolbar, click the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with
rounded lips for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape.
The current drawing is swapped for the one in the preview window.
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, such
as an editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of
individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack
1. From the top menu, select File > Export > Soundtrack.
The Export Soundtracks dialog box opens.

2. In the Output section, click Browse and specify where you want to save the exported sound file.
3. In the Export Range section, select one of the following options:
l

All: Exports the sound over all the frames of your scene.

l

Frames: Sets the start and end frames in the corresponding fields on the right.

4. From the Options menu, select one of the following:
l

Process Soundtracks Individually: Each soundtrack from all layers is exported as
individual files.

l

Merge all Soundtracks: One single file is created, combining all the sound files you
imported in your scene. Note that it will only use the sound files in the selected frame
range set in the Export Range section. If you selected to export all the frames, all the
sound files will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export.
It is a good idea to verify what is required by the software or device that you may want to use next
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with the sound file.
6. Click OK.
The generated sound files appear in the selected directory and are named according to the scene
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Chapter 17: 3D Space
Harmony is well known for its multiplane space where you can move your layers forward and backward on the
Z-axis. Harmony brings you a true three-dimensional space where you can actually rotate your camera and
layers on all axes. This lets you perform a 360 degree rotation around elements, create a floor and even build
sets!

NOTE
If you are using 3D rotations in your animation, do not render your project as a SWF as these
parameters are not supported by that format.
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Enabling the 3D Option
Before you can rotate layers in three axes instead of two, you must enable the 3D option in the layer properties.
By default, when you create layers in Harmony, you can only move them as flat layers.

How to enable the 3D option
1. In the Timeline view, select the layer you want to move in 3D space.
2. In the Layer Properties view select the Transformation tab.
3. Select the Enable 3D option to display the 3D parameters for that layer.
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New parameters appear in the Layer Properties window.
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About 3D Parameters
When working in 3D, notice that three sets of parameters are modified: scale, rotation, pivot.

1548

Chapter 17: 3D Space

About the 3D Scale Parameter
When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or
separated. When the Scale is locked, the object you are scaling is uniformly resized in three directions. When
the Scale is separated, the object you are scaling can be squashed and stretched in any direction without
affecting the other ones.

NOTE
You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional
scaling is used to scale objects that were rotated on their axes or to scale a group of objects laid out
in three dimensions.
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About the 3D Rotation Parameter
The main parameter you will use when working in three-dimensions is rotation. Without using 3D rotation, you
are simply working using the multiplane technique.

3D rotation can be used in two different ways:

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three
rotation functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the velocity
of the three rotation functions simultaneously.
The X, Y and Z functions are linked. When you add a keyframe on one of them, it also adds it to the two others.
If you are planning to animate an element such as the camera, you should use the Quaternion rotation rather
than Euler Angles. Quaternion creates a smooth trajectory and interpolation since the path is controlled by the
same keyframes and a single velocity.

Euler Angles Rotation
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The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are
independent of each other; each has its own velocity.
When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis
independently.
Euler Angles are mainly used to position elements with exact coordinates and rotate elements on a single axis.
The interpolation between the keyframes will not be as smooth as the Quaternion one since each function
works individually.
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About the 3D Pivot Parameter
When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. When you
work in two dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the
transformations will be performed. In 3D, the transformations are made on three axes, so the centre of rotation
and scaling also becomes three-dimensional.

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot

tool to

reposition the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis
remains at zero until you change it in the Top, Side or Perspective view using the transformation tools.
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About 3D Tools
Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are
found in the Advanced Animation toolbar as well as the Transform

tool. Instead of letting you move

elements only on the X and Y axes, you can also manipulate them on the Z-axis.
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About the 3D Translate Tool
Once the 3D option is enabled on a layer, the Translate

tool will work as a 3D Translate tool on that layer.

This tool is able to move elements on all three axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer
can move freely on two axes at once. Once the arrow is selected, it will turn pink.
NOTE
If you move the layers in the Perspective view, it may be difficult to control the motion since you
may not have the optimum point of view on your stage to understand the setup. In this case, it is
best to use the direction arrows.
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About the 3D Rotate Tool
Once the 3D option is enabled on a layer, the Rotate

tool will work as a 3D Rotate tool on that layer. This

tool is able to rotate elements on all three axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.
NOTE
If you move the layers in the Perspective view, it may be difficult to control the motion since you
may not have the optimum point of view on your stage to understand the setup. In this case, it is
best to use the direction ellipses.
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About the 3D Scale Tool
Once the 3D option is enabled on a layer, the Scale

tool will work as a 3D Scale tool on that layer. This tool is

able to scale elements on three axes.
Depending on the selection, the 3D Scale tool will display one of the following:
• A scaling rectangle appears if your drawing is flat.
• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the
different axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the
object proportionally. Once the control point is selected, it will turn pink.
NOTE
If you move the layers in the Perspective view, it may be difficult to control the motion since you
may not have the optimum point of view on your stage to understand the setup.
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About the 3D Transform Tool
Once the 3D option is enabled on a layer, the Transform tool will work as a 3D Transform tool on that layer.
This tool is able to translate, rotate and scale elements on all three axes.

To translate an element, grab the direction arrows in the same way that you would with the Translate tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale tool.
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About 3D Space Positioning
To position elements in 3D space, you need to understand what you want to build and what is involved in
building it.

Simple sets like the one above are easy to build, light to manage and probably what you will use 3D staging for
most often.
If you have a project based on a room, it can be useful to build it in 3D. This saves you from having to redraw the
background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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About Planning
When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map out
the parts you need.

A complex set that is more intricate in its design will require more careful planning. Not only will you have to list
the pieces you need, but you will also have to think about what can be reused. If you have a series of windows in
your set, you would create a symbol from the drawing, rather than copy paste it several times all over your set.
This way, if you need to make any correction to its design, you will only need to do it once and all the instances
of your symbol throughout your set will be corrected. The same can be done with for each piece of your set.
Here is an example of all the source drawings required to build the castle.

These are the only drawings required to build the entire castle. As you can see, there are not that many
considering the final result. The rest is constructed by assembling symbols and through reuse. However, keep
in mind that although you are using simple drawings and symbols to optimize your set, the more you add to
your project, the heavier the toll it takes on your machine's RAM. While the scene's package itself is really light,
running the scene places heavy demands on your RAM and video card.
Using the drawings shown previously, here are a couple of pieces that were put together.
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Here is the final result. A large and impressive fortress.
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About Maximizing Efficiency
When your main set is built, you will want to store it in the Library. It is important to know that when you
import such a large structure in one of your production scenes, the set may be slow to run. To avoid long
rendering sessions or slow manipulation, remove all faces and planes that are not visible in your scene.
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Positioning Layers in 3D Space
Once your drawings and symbols are assembled, it is time to position them. This section explains how this is
done using the example of a simple room.

How to position layers in 3D space
1. Next to the Camera and Drawing view tabs, click on the Add View

button and select

Perspective.
The Perspective view appears in the same section of your workspace as your Camera and Drawing
views. This view allows you to view your scene from any angle and point of view, rather than from
your Camera's point of view. In this view, the usual navigation keyboard shortcuts work the same,
but you can also press Ctrl + Alt (Windows/Linux) or ⌘ + Alt (macOS) to rotate the view in any
angle and on any axis

2. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.
3. In the Transformation tab, select the Enable 3D option.

4. In the Rotation section, select the Euler Angles option.
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5. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.

6. To position the height of the floor, type values in the Position section of the Layer Properties, use
the Translate

tool or Transform

tool.

7. Repeat the process for the other pieces to position.
8. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.
9. Do one of the following to duplicated the layer.
l

From the top menu, select Edit > Duplicate.

l

Right-click and select Edit > Duplicate.
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10. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use
the Translate or Transform tool. If you want to position your layer visually, consider using the
Camera, Top or Side view so as to be able to position it with precision.

11. If your walls are touching each other, you should make them intersect by extending one end of the
wall through the other wall. This prevents accidentally leaving small gaps between them.

You now have a complete 3D room.
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NOTE
The Transform tool as well as the Advanced Animation tool can be used with 3D layers as with
2D layers. The Transform tool allows you to reposition, rotate and scale 3D layers on any axis,
but does not allow you to skew 3D layers. You can use these tools on 3D layers in the Camera,
Perspective, Top and Side views.
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Using the Depth View Mode
The Depth View mode can come in handy when positioning 3D models, creating multiplane backgrounds and
building sets in 3D space.

How to use the Depth view
1. In the Node view, open your Layer Properties of your composite by clicking on the yellow box.
2. In the Layer Properties window, set the Input Ordering to 3D.

3. In the Camera view, click on the Render View mode
View

button and from the menu, select Depth

mode.

The image of your scene changes from full colour to various shades of black, white and grey.

4. The Depth View mode displays images in a relative white to black gradient scale. The object(s)
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closest to the camera are displayed in white and the object(s) furthest from the camera are
displayed in black. If the position of the last object changes along the z-axis, that object will still
remain black, so long as it retains its position as the object the farthest back. It does not matter
where that object is in 3D space, it just matters what its position is relative to the other object in the
same space. The objects closest and farthest from the camera set the range of the white to black
scale. All the other objects fall somewhere in between.
5. In the Timeline or Node view, disable elements that you don't need, in order to work better with the
elements that you would like to reposition. In the example below, the background elements have
been disabled so that repositioning elements in the room can be done more precisely.

As you can see, the same elements in the Depth View mode are now displayed differently, because
their relative positions have changed. Without the background present, the corner of the room
becomes the element that is the furthest back, while the right part of the right wall is the element
that is the closest and is therefore displayed in white.
Deep blue signifies infinity. The space around elements goes on forever and therefore does not fall
into the white to black scale.
6. In the Camera, Top, Side or Perspective views, use the Transform tool or any of the Advanced
Animation tools (Translate, Rotate, Scale, etc.) to reposition elements in your scene, using the
Camera's Depth View mode to verify your adjustments as you make them.
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About 3D Input Output Options
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level
compositing.
The Composite node's main task takes all of your image's output and converts it into a single flat image that you
can render out. You can alter it further by manipulating a three-dimensional scene setup. You can also modify a
Composite's behaviour as seen in the Staging on page 1161 chapter.

The default options combination is:
l

As Bitmap, for the output behaviour

l

3D flat, for the input ordering

By default, a Composite node is set to output a flat bitmap image and to correctly composite elements
positioned in 3D space.

For example, if you have two intersecting walls, and use the default combination, you will see the following
result:
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This image is correctly represented in the Camera view and is output from the Composite node as a flat
drawing. The Z-axis value of your elements are not retained, it becomes an independent composition with only
one forward-backward value.
NOTE
When building a 3D set out of planes, it is recommended that you set the composite mode to As
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of
planes.

3D Input Ordering Option
The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the
Camera view will be correct, but the elements will not be converted into a flat image. The 3D position of your
images will be remembered until the next Composite node. This mode is quite advanced and should only be
used in very advanced cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option
If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D
objects. The perspective caused by the 3D rotation will be correctly represented, but the elements will not
intersect. The result will be similar to the following:
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About 3D Composite Nodes
If you start combining several composite nodes in your Node view, it is important to understand how they work
if you want to get the desired result.
There is a specific order in which you should set your Composite nodes. Each time you process images through a
3D Flat Composite node, the images will be merged together. Images processed in later Composite nodes
cannot be inserted between images of the previous composite since it is a flat image.

If you used Pass-Through type Composite nodes in your network, the images will not be processed together
before the final Composite. It is important to keep your final Composite as a 3D Flat Composite in order to read
the layer ordering correctly.
The most efficient networking system for obtaining the desired result is likely the Pass-Through composite
mode throughout the whole network. This way, you can create individual compositions to keep your network
clean and organized, but process everything together at the end.
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NOTE
When building a 3D set out of planes, it is recommended that you set the composite mode to As
Seamless Bitmap. This avoids intersection issues when rendering the 3D objects created out of
planes.
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Drawing on 3D-Rotated Layers
As you build your project in the Perspective view, you may rotate and reposition 2D drawings to lay flat against
different planes of your 3D model. If you then want to draw on these 2D drawings, you will see that it is not
possible. In order to draw on a 2D drawing in the Perspective view, the drawing needs to be facing the camera.

How to turn a 2D object to face the camera so you can draw on it
1. In the Perspective view, select the 2D drawing with the Transform tool

2. From the Perspective view menu

.

, select View > Face Selected to Draw.

The Perspective view is reset so that the 2D drawing is now facing the camera.
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3. Select a drawing tool from the Drawing Tools toolbar and modify the drawing.
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Chapter 18: 3D Integration
Harmony is able to integrate 3D models into your animation. Like 3D-enabled elements, you can animate a
3D model on its geometry by translating it, rotating it or scaling it on the X, Y and Z axes. Using a Subnode
Animation node, you can also animate the individual parts (subnodes) of a 3D model separately.

By default, a 3D model in a Harmony scene will be rendered using OpenGL, which is unlikely to render in the
desired quality. To properly render a 3D model, you must configure your scene to render the model through
Autodesk Maya. When properly set up, Harmony will seamlessly make Maya render the 3D model, then
composite the rendered image into the final render of the scene. For more information, see 3D Rendering in
Harmony on page 1620.
TIP
As you work with 3D objects in Harmony, you will most likely want to integrate 2D and 3D objects
together. To learn more about manipulating 2D objects in 3D space, see Positioning Layers in 3D
Space on page 1565 and About the 3D Transform Tool on page 1558.
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Integrating 3D Objects in Harmony
The first step to integrating 3D models into a Harmony scene is to export the model into a supported format so
that it can be imported in a Harmony scene. Harmony can work with the following types of 3D objects.
l

Filmbox (.fbx)

l

3DS Max (.3ds)

l

Wavefront OBJ (.obj)

l

Allembic (.abc)

l

Collada (.dae)

If you set up your scene to render through Autodesk Maya, Harmony will use the original Maya project to create
the rendered image. Hence, even though these formats do not carry all the details of the original project, your
choice of 3D model type has no effect on the final render. An 3D model in Harmony can hence be considered a
reference model. You can even export the model with optimizations, such as lower resolution textures or
reduced details in the geometry, so as to enhance performance when manipulating the object in Harmony.
Note however that the exported model must be in the same size and position as the model in the Maya project.
However, if you do not plan to render the scene through Autodesk Maya, be aware that the model will be
rendered as it appears in the Camera view, using OpenGL, and that the render will based strictly on 3D object
file imported in the scene, not on the Maya project. Hence, for that purpose, it is recommended to export your
model in Filmbox (.fbx) format, as that format can be exported with textures, and to not make texture or
geometry optimizations that would affect the quality of the exported model.
Otherwise, even when rendering with Autodesk Maya, the Filmbox (.fbx) is still one of the most useful model
types to work with in Harmony. Since this format can be exported with its textures, this gives a more accurate
preview of what the rendered image will look like in the Camera view. Also, an .fbx model can be exported with
subnode animations, which Harmony can play in the scene.
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Another particularly useful 3D model type is Alembic (.abc). Although this type does not store any texture
information, it can store the baked in geometry of a 3D model that is animated with deformations. Harmony
can play the different frames of animated Alembic file in the scene, allowing the animator to use the baked-in
transformations of an animated model as a reference for animating other elements in the scene around it. If
exported from Maya, an Alembic (.abc) file can also store basic colour information (on a per-vertex basis) which
Harmony can display and render.
At last, the Collada (.dae) format allows artists to use models exported from SketchUp without using
Sketchup Pro.
When importing a 3D model, you have the option to convert it to a Filmbox (.fbx) file before storing it in the
scene. This is because Harmony converts the model to .fbx format internally so it can work with it, so converting
the file will allow Harmony to skip converting it internally every time the scene is opened.
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Exporting 3D Objects for Harmony
Before importing your 3D model in Harmony, you must export it in a format supported by Harmony. The
following steps will explain how to export a 3D object in Filmbox (.fbx) or Alembic (.abc) format from Autodesk
Maya. Depending on the software and version you are using as well as the file type you wish to export, the
instructions may vary. Please refer to the documentation of your 3D authoring software as needed.
NOTE
If your model is animated and you want its animation to play in the Harmony scene, you should
export it in Filmbox (.fbx) format if the animation does not use deformations, and in Alembic (.abc)
format if the animation uses deformations.

IMPORTANT
When exporting a Filmbox (.fbx) file from Autodesk Maya, you must set the Type parameter
to Binary and the Version parameter in FBX File Format panel to 2014/2015 to make sure it is
compatible with Harmony.

How to export a 3D object in Filmbox (.fbx) for Harmony

1. In Autodesk Maya, create your 3D object. Make sure your 3D object is ready for rendering by
properly creating its textures and setting up the lights in the stage. Harmony will use the original
Maya project to create the final renders.
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TIP
The animation done on the 3D object in Harmony will be applied to the Maya project
when rendering. To avoid moving the object out of its light source, it is recommended to
make the light source a child of the 3D object, so that the light moves along with it. In
Maya, you can make a layer a child of another layer by middle-clicking it and dragging it
over the intended parent.

2. Save your Maya binary file *.mb as you will use it later on.
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1. From the top menu, select File > Export All.

The Export All dialog box opens.
2. In the Files of type drop-down, select FBX Export.
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3. In the Animation section of the Options panel, check the Animation checkbox if you want the
subnode animations to be included in the model.
4. In the Embed Media section of the Options panel, check the Embed Media checkbox. This will
export textures with the model.
5. In the FBX File Format section of the Options panel:
a. Set the Type option to Binary.
b. Set the Version option to FBX 2014/2015.

6. Click on Export All.
An .fbx file will be created in the selected location.

How to export a 3D object in Alembic (.abc) for Harmony
1. In Autodesk Maya, create your 3D object. Make sure your 3D object is ready for rendering by
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properly creating its textures and setting up the lights in the stage. Harmony will use the original
Maya project to create the final renders.

TIP
The animation done on the 3D object in Harmony will be applied to the Maya project
when rendering. To avoid moving the object out of its light source, it is recommended to
make the light source a child of the 3D object, so that the light moves along with it. In
Maya, you can make a layer a child of another layer by middle-clicking it and dragging it
over the intended parent.

2. Save your Maya binary file *.mb as you will use it later on.
3. From the top menu, select Cache > Alembic Cache > Export All to Alembic.
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The Export All dialog box opens.

4. In the Cache time range dialog box, select the range of frames that you want to export in the
Alembic (.abc) file:
l

Current frame: Exports only the current frame.

l

Render settings: Exports the frame range specified in the Render Settings dialog.

l

Time Slider: Exports the frame range covered by the time slider.

l

Start/End: Exports the frame range specified in the Start/End fields below.

5. If you want to import the vertex colours of your 3D model into Harmony, scroll down to and expand
the Advanced Options section, then check the Write Color Sets option.
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6. Click on Export All.
An .abc file will be created in the selected location.

1586

Chapter 18: 3D Integration

Importing 3D Objects in a Scene
Once you have exported a model using a 3D authoring software, you can import it into Harmony and integrate
it to set up your 2D animation scene.
You have the possibility to convert your 3D models to the .fbx format upon import to Harmony. This will allow
Harmony to render 3D files with the associated textures without the need to copy over the textures manually
(as long as the auxiliary files are linked correctly and named appropriately on your disk).

How to import 3D models
1. In Harmony, select File > Import > 3D Models.
The Import 3D Models dialog box opens.

2. Click Browse and locate your 3D model file. Only *.osb. *.3ds, *.obj, *.fbx, *.abc and *dae file formats
are supported.
3. Click Open to validate your choice and close the browsing window.
4. In the Layer section, choose your import options.
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l

Create Layer(s): This option is selected by default. A new layer will be created for the
selected files for the import. You have two choices:
l

Create Single Layer Named: Imports all your selected files in the same layer you can
name.

l

Create Layer(s) Based on Filename: Creates a different layer for each file selected for
import. The layers will be automatically named according to the file names.

l

Add to Existing Layer: Imports the selected files into an existing 3D layer in the scene. Use
the drop-down menu to select a 3D layer.

5. In the Conversion section, select the Convert to FBX format option if your file isn't already a *.fbx
file and you would like it to be. This format incorporates all associated files, such as the texture files.
6. Click OK to validate your choices and import the selected file(s).
The 3D models are imported in the scene.
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Using Animated 3D Models
By default, a 3D model imported in Harmony will appear static throughout the scene. However, a Filmbox (.fbx)
or Alembic (.abc) 3D model that has been exported with animations in it and imported in Harmony can be
made to play out its animation in the scene, and to render with its animations later.
This is possible with two types of 3D objects:
l

Filmbox (.fbx) files can be imported with their subnode animations. This means the geometric
transformations on each subnode in each frame of the model can be imported and played out.

l

Alembic (.abc) files can be imported with their deformations baked into every frame. This is useful if you
need to use models that are animated with deformations. However, Alembic files do not have texture
and hence appear solid white in the preview.

In both cases, the 3D model will be rendered by Maya, using the original Maya project file. Hence, the result will
be the same in the rendered image. The difference is the kind of information that is visible in the
OpenGL preview of Harmony.
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Playing the Animation of a 3D Model in a Scene
Animated 3D models imported in Harmony will appear static at first. To play their animation in the scene, the
frames of their embedded animation must be exposed in their Xsheet column.
The 3D model itself being a drawing, typically named 1, that must be exposed throughout the scene, you can
indicate which animation frame inside the 3D model to expose in a given frame of the scene by entering, in a
cell in the Xsheet, the name of the drawing followed by a comma and the number of the model's animation
frame to expose.
For example, if the model is named 1, and you wish to expose the frames 1 to 15 of its animation in the scene,
the model's Xsheet column should have drawings from 1,1 to 1,15 exposed, inclusively.

NOTE
In the example above, the first frame of the model appears as 1 instead of 1,1. Harmony will
always display the first frame of the model as the model's name without any frame number.
You can quickly fill the Xsheet column of a 3D model with its embedded animation frames using the Sequence
Fill dialog.

How to fill the Xsheet column of an animated 3D model
1. In the Xsheet view, locate the column of the 3D model.
2. In the column, select the frame range in which you want the animation of the 3D model to play out.
3. Do one of the following:
l

Right-click on the selection, then select Exposure > Sequence Fill.

l

Open the Xsheet view menu, then select Exposure > Sequence Fill.
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l

In the top menu, select Animation > Cell > Sequence Fill.

l

Press Ctrl + M

The Sequence Fill dialog box appears.

4. Check the Padding checkbox.
5. In the Padding field, enter the name of the drawing name of the 3D model, followed by a
comma. For example, if the 3D model is named 1, enter 1,.

TIP
The text in the Padding field is used to prefix drawing names by default. Optionally, the
# character can be used to indicate where in the padding text should the drawing
number be inserted.
6. Depending on how the animation in the 3D model should play out, set the following parameters:
l

In the Starting Value field, enter the first frame of the model's animation that should play in
the scene.
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l

In the Increment field, enter the amount of frames that each exposure should increment
by. For example, if your model is animated on ones, but you want its animation to skip every
other frame to play on twos, set this value to 2.

l

In the Hold field, enter the amount of frames each exposed animation frame should take.

l

If you want the animation to cycle, check the Cycle checkbox and enter enter the amount of
times the animation should repeat in the corresponding field.

l

If you want the animation to stop at a specific frame rather than at the end of the selection,
check the End Frame checkbox and enter the number of the embedded animation frame at
which to stop the animation.

7. Click on OK or Apply.
The animation of your 3D model will play out in the selected frames.
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3D Object Manipulation & Animation
Once you have imported the 3D model into your scene, you can easily manipulate it to set up your scene. You
can even add keyframes, just like any other element, and animate it on a trajectory.

Using Peg Nodes to Control the Position of 3D Objects
You can use Peg nodes to control the position of 3D objects, and connect them as you would with 2D layers to
create rigs.

Using Transformation Tools to Manipulate 3D Models
Once the 3D option is enabled, your transformation tools automatically become 3D transformation tools. This
means you can now manipulate them on the Z-axis as well. The Translate
found in the Advanced Animation toolbars and the Transform

, Rotate

and Scale

tools are

tool can be found in the Tools toolbar. You

can use these tools to set up or animate your 3D model.
You can also set up all these position parameters using the Layer Properties window—see About 3D
Parameters.
NOTE
If you want to set up the position of your 3D model, you must disable the Animate
forget to re-enable it when if you want to animate it.
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About 3D Objects in Different Views
Before you can properly view and set up the 3D element in your scene, you will need to use the Perspective and
Camera views together, as well as the Top and Side views.
TIP
Using the Depth View mode can also be a useful tool when setting up 3D objects, see—Using the
Depth View Mode on page 1569.
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About 3D Objects in the Perspective View
In the Perspective view, you can see your scene in a complete 3D environment. In this environment, you can set
up and animate your 3D model more easily. You can rotate the view on the three axes by holding down Ctrl +
Shift (Windows/Linux) or ⌘ + Shift (macOS), and clicking and dragging.
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About 3D Objects in the Camera View
You can preview the position of your 3D model in the Camera view and see what it will look like in the camera
frame. You can preview your scene in OpenGL

You can view your 3D objects in Render

mode.

mode, but only basic settings will be used to render the 3D element.

To get a fully textured and lit render, you can use Autodesk Maya. If you want to render using your 3D objects
using Maya as a background process, before you can view your 3D elements in Render

mode, you must add

a Maya Batch Render node to your Node view and set up your system with the correct path to the rendering
utility you will be using. Note that you will need to add your Maya project inside the 3D object's element folder
in your Harmony scene. If you do not complete this setup, the 3D model will simply not appear—see 3D
Rendering in Harmony.

If you want to override the order of your 2D and 3D elements to follow the Composite node ordering rather
than the Z-axis order, you can use the Flatten node—see the Reference guide .
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About 3D Objects in the Top and Side Views
The Top and Side views help you position your element in the 3D environment. This can be really helpful for
precisely visualizing the actual position of your model without perspective.
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About Translate Tool 3D Manipulation
Once you enable the 3D option, the 3D Translate tool becomes available. Direction arrows appear around the
pivot points to indicate the different axes.

If you click on a direction arrow, you can move a layer on only one axis. If you click anywhere else, the layer can
move freely on two axes at once. Once the arrow is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have
the optimum point of view on your stage to understand the setup. In this case, it is best to use the direction
ellipses.
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About Rotate Tool 3D Manipulation
Once you enable the 3D option, the 3D Rotate tool becomes available. A rotation sphere appears around the
pivot points to indicate the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer
rotates freely on two axes at the same time. When the ellipse is selected, it turns pink.
If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have
the optimum point of view on your stage to understand the setup.
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About Scale Tool 3D Manipulation
Once you enable the 3D option, the 3D Scale tool is available. You will see one of two things:
• A scaling rectangle appears if your drawing is flat.
• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the
different axes. If you click and drag on this scaling cube, it will scale proportionally on all axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the
object proportionally. When the control point is selected, it turns pink.
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About Transform Tool 3D Manipulation
Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Transform

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate
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To scale an element, grab the scaling control points in the same way that you would with the Scale
If you click and drag on the scaling cube, it will scale proportionally on all axes.
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Manipulating and Animating 3D Object Subnodes
A 3D model can be rigged so that different parts of it, referred to as subnodes, can be subjected to their own
geometric transformations.
Using the 3D Graph view, you can see the list of subnodes available for the selected 3D model. Each subnode
represents a part of the 3D model that can be transformed and animated independently, or even hidden. Like
with peg hierarchies, subnodes that are children of other subnodes will be transformed along with their
parents. If you select a subnode in the 3D Graph view, it will be highlighted in the Camera view, and the
Transform tool will be set to manipulate that subnode rather than the whole 3D model.

NOTE
To learn more about the 3D Graph view, see the Reference guide .
You can also visually select a subnode in a 3D model by holding Ctrl (Windows/Linux) or ⌘ (macOS) and
clicking on a part of the model in the Camera view. The corresponding subnode will be selected.
When a subnode is selected, you can transform it using the Transform

tool the exact same way you would

transform the whole 3D object—see 3D Object Manipulation & Animation on page 1593.
If you make a transformation on a 3D model subnode directly, this transformation will be static. In order to
animate a 3D model subnode, you must connect the 3D object's node to a Subnode Animation node, which will
store the animation information for each of the model's subnodes that you animate. In both cases, the
transformations and animations done on 3D model subnodes will appear in the final render, even if the model is
rendered through Autodesk Maya.
It is also possible to rig an element in the scene to follow the animation of one of the subnodes of a 3D model.
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IMPORTANT
If your 3D model has been imported in Harmony scene through a template or scene that has been
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra
subnodes that are not in the original Maya project. This might cause errors with the position and
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import
the original 3D model file in your Harmony scene before animating it.
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Disabling Subnodes
To hide parts of a 3D model, you can disable their corresponding subnodes in the 3D Graph view. This will also
hide all their children.

How to disable subnodes
1. In the 3D Graph view, select one or multiple subnodes.

1. Do one of the following:
l

In the 3D Graph view toolbar, click on the Disable Subnode

l

Open the 3D Graph view menu

button.

and select Subnodes > Disable.

The subnode is disabled. It appears dark red in the 3D Graph view. Its children appear dark grey to
indicate that they are not disabled, but that they are children of a disabled subnode.
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In the Camera or Perspective view the corresponding part of the 3D model is hidden.
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Enabling Subnodes
Disabled subnodes are invisible. To make them visible again, you can enable them in the 3D Graph view.

How to enable subnodes
1. In the 3D Graph view, select one or several disabled subnodes. Disabled subnodes will display in
dark red, and their children will display in dark grey.

1. Do one of the following:
l

In the 3D Graph view toolbar, click on the Enable Subnode

l

Open the 3D Graph view menu

button.

and select Subnodes > Enable.

The subnode and its children are enabled.
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In the Camera or Perspective view the corresponding 3D model part is displayed.
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Animating Individual Parts of 3D Models
A typical 3D model is comprised of several parts (subnodes) that can be transformed independently. By default,
transformations made on 3D model subnodes are static. If you need to animate the subnodes of a 3D model,
you need to connect the 3D model to a Subnode Animation node. This node will store the keyframes for each
subnode that you animate and will also make them available in the Timeline view.

IMPORTANT
If your 3D model has been imported in Harmony scene through a template or scene that has been
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra
subnodes that are not in the original Maya project. This might cause errors with the position and
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import
the original 3D model file in your Harmony scene before animating it.

How to animate a part of your 3D model
1. In the Node Library view, select 3D in the sections list and locate the Subnode Animation node.
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2. Drag and drop the Subnode Animation node from the Node Library into the Node view.
3. In the Node view, connect the Subnode Animation node under the element node of your 3D model.

The Subnode Animation node automatically appears in the Timeline view, under the layer of the 3D
model.

4. In the Timeline view, select the frame where you want your first animation keyframe to be created.
5. In the Tools toolbar, select the Transform tool

.
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6. Do one of the following:
l

In the Camera or Perspective view, click on your 3D model once to select the whole object,
then click again on the part you wish to animate to select it.

l

In the 3D Graph view, select the subnode you wish to animate.

1. Use the Transform tool to move, rotate or scale the individual part.

2. The subnode appears in the Timeline view.
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3. In the Timeline view, expand the subnode layer to view its properties.

A keyframe appears in the first frame, recording the movement that was just made.
4. Continue adding keyframes and making changes to the properties values to animate the individual
part of the 3D model.
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Adding the Subnodes to the Timeline View
When you animate a subnode using a Subnode Animation node, the subnodes you animate will be
automatically added to the parameters of the Subnode Animation in the Timeline view, allowing you to
manipulate its keyframes, and the parameters of subnodes that are not animated will remain hidden.
However, there might be situations where you want to add subnodes to the Timeline view before animating
them. For example, if you want to create a keyframe for a subnode in its default resting position, or if you want
to prepare a scene for an animator and only make subnodes that are intended to be animated visible in the
Timeline view. This is possible using the 3D Graph view.
IMPORTANT
If your 3D model has been imported in Harmony scene through a template or scene that has been
exported from Storyboard Pro 5.0 or Storyboard Pro 5.1, and a subnode in this 3D model has been
transformed or animated in Storyboard Pro 5.0 or 5.1, it is possible that this 3D model has extra
subnodes that are not in the original Maya project. This might cause errors with the position and
visibility of some subnodes when rendering the model. In this case, it is recommended to re-import
the original 3D model file in your Harmony scene before animating it.

How to make properties available in the 3D Graph view
1. In the Node Library view, select 3D in the sections list and locate the Subnode Animation node.

2. Drag and drop the Subnode Animation node from the Node Library into the Node view.
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3. In the Node view, connect the Subnode Animation node under the element node of your 3D model.

The Subnode Animation node automatically appears in the Timeline view, under the layer of the 3D
model.

4. In the 3D Graph view, select a subnode that you intend to animate.

5. Do one of the following:
l

In the 3D Graph view toolbar, click on the Make Properties Available

l

Open the 3D Graph view menu

button.

and select Insert > Make Properties Available.
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The subnode appears in the Timeline view.

6. In the Timeline view, click on the Expand

button left of the subnode to display its parameters.
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Applying the Animation of a 3D Subnode to an Element
It is possible to apply the animation on a 3D model's subnode onto other elements such as 2D layers, pegs or
other 3D models in the scene, making the subnode act like parent peg to these elements. This can be especially
useful of a decal or an effect is meant to follow a specific part of a 3D model.

How to automatically setup 3D Kinematic Output nodes with your system
1. Do one of the following:
l

In the Camera or Perspective view, using the Transform

tool, click on the 3D model to

select it, then on the part of the 3D model that you want to rig to another element to select
its subnode.
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l

In the 3D Graph view, select the subnode which you want to rig to another element.

2. Do one of the following:
l

In the 3D Graph view toolbar, click on the Add 3D Kinematic Output

l

Open the 3D Graph view menu

button.

and select Insert > 3D Kinematic Ouput.

A 3D Kinematic Output node appears in the Node view, connected under the 3D Model's Subnode
Animation node. The 3D Kinematic Output node is named after the subnode, followed by -Output.

An asterisk appears right of the name of the subnode in the 3D Graph view, to indicate the
connection of the 3D Kinematic Output node.
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3. In the Node view, connect the output port of the 3D Kinematic Output node to the input port of the
element that should follow the subnode's movement. In this example, the layer fire will follow the
movement of the shell_37_Key subnode.

Any transformations made to the 3D model subnode will now also be applied to the drawing.
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3D Rendering in Harmony
In order to properly render 3D models in Harmony scenes, the scene as well as your workstation must be
configured to allow rendering the model through Autodesk Maya. This is required to render the 3D models
with the same rendering quality as originally intended. Otherwise, Harmony will use OpenGL to render the 3D
model, which might not give the expected results.

To perform this render, Harmony uses the original Autodesk Maya project, to which it applies the
transformations done on the model and its subnodes inside the scene, and sends it to Autodesk Maya for
rendering. Then, it takes the rendered image and composites it with other elements in the scene to create the
full image. This works just as well when outputting the final rendering images as when switching to Render
Preview mode in the Camera view.
Autodesk Maya can render using its own rendering engine or third party renderers. Likewise, Harmony can
make Autodesk Maya perform the render using different rendering engines. Specifically, the following engines
are supported by Harmony:
l

Maya

l

Mental Ray

l

Renderman Reyes

l

Renderman RIS

l

Arnold
NOTE
It is recommended to use either Renderman or Arnold to render 3D objects through Autodesk
Maya, as those rendering engines will return deep texture images, which can be composited
relative to other elements in your scene with antialiasing. When using other rendering engines,
3D models that clip with elements in your scene may have a hard pixelated seam at their
intersection.

For rendering through Autodesk Maya to work, the following conditions must be met:
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l

Autodesk Maya—and of the rendering engine, if not Autodesk Maya—must be installed and activated
on the workstation performing the render.

l

The path to Maya must have been set in Harmony's local preferences on the workstation performing the
render.

l

If rendering using the Renderman engine, the path to Renderman must have been set in Harmony's
local preferences on the workstation performing the render.

l

A copy of the original Maya project file, along with all its texture files, must be in the element folder
where the imported 3D model is located, with the same file name as the imported 3D model, but with
the Maya project file extension (.ma or .mb).

l

A Render Maya Batch node must be connected under the 3D model in the Node view and, optionally,
configured to select a specific rendering engine.

The following topics will detail how to achieve this configuration.
NOTE
The Render Maya Batch node outputs a bitmap to your scene's node system. You can apply bitmap
effects to the rendered image.
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Setting 3D Renderer Paths
In order to render 3D models through Autodesk Maya, you must configure Harmony with the installation path
to Autodesk Maya.
If your 3D models are to be rendered using the Renderman engine, you must also configure Harmony with the
installation path to Renderman. This is because Harmony needs to use Renderman to read the images output
by the Renderman engine, which are in Deep Texture (.dtex) format. If you are using any other rendering
engine, this step is not required.
NOTE
If you are using Harmony Server, note that this preference is stored on your workstation, not in your
database user account. This is because Autodesk Maya and Renderman may be installed in
different locations on each workstation. Hence, this must be configured on each workstation that
will perform rendering through Autodesk Maya.

How to set 3D renderer paths
1. Add the Scripting toolbar to your interface by doing one of the following:
l

From the top menu, select Windows > Toolbars > Scripting.

l

Right-click on any existing toolbar or on the top space of any view in your workspace, then
select Scripting.

2. In the Scripting toolbar, click on the Manage Scripts button to open the Scripts Manager window.
3. In the Files list of the Scripts Manager, select TB__Set_3dRenderer_Paths.js.
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4. In the Functions list, select TB_Set_3dRenderer_Paths.

5. Click on the Add

button to add the script to the Scripting toolbar.

6. Click OK.
7. In the Scripting toolbar, click on the TB_Set_3dRenderer_Paths script

button.

The Set 3D Renderer Paths dialog box opens.

8. In the Maya Installation Path section, click on the browse (...) button.
9. In the Select Folder dialog, browse to the root installation folder of Autodesk Maya on your machine.
For example, by default, the installation path of Autodesk Maya 2016 would be
C:\Program Files\Autodesk\Maya2016.
10. Click on Select Folder.
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11. If you intend to use the RenderMan engine, click on the browse (...) button in the RenderMan
Installation Path section.
12. In the Select Folder dialog, browse to the root installation folder of Autodesk Maya on your machine.
For example, by default, the installation path of RenderMan Studio 20.2 for Autodesk Maya 2016
would be C:\Program Files\Pixar\RenderManStudio-20.2maya2016.
13. Click on Select Folder.
Harmony can now communicate with Autodesk Maya and, if needed, RenderMan.
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Connecting the 3D Model to the Renderer
At last, to render a 3D model using Autodesk Maya, you must connect the element node containing the
3D model to a Maya Batch Render node. The Maya Batch Render node will take the 3D model as its input,
render it through Autodesk Maya, then composite the rendered image into the scene. The 3D model as
rendered by Autodesk Maya will appear in both the final rendered image and in the Render Preview

mode

of the Camera view.
TIP
When rendering using a 3D renderer, you can start Harmony from a command line terminal and to
display the Message Log view in your workspace. This will allow you to see the information
Harmony outputs about the rendering process, which could be useful to debug the process if any
problem occurs.

How to connect the 3D model to the rendering engine
1. In the Node Library view, select 3D in the sections list and locate the RenderMayaBatch node.

2. Drag and drop the Maya Batch Render node from the Node Library into the Node view.
3. In the Node view, connect the Maya Batch Render node under the node of the 3D model. If the 3D
object is connected to a Subnode Animation node, connect the Maya Batch Render node under the
Subnode Animation node instead.
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4. Repeat the previous steps for each 3D model node in your scene.
5. In the Camera view, click the Render View

button to verify that the 3D model is rendered

through Autodesk Maya.
NOTE
The generation of the preview may take several seconds and make Harmony appear to
hang for a moment.
You are now set to render your animation project.
TIP
You can apply effects on the rendered image by connecting effect nodes under the Maya Batch
Render node.
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Copying your Maya Project to the Scene Directory
In order to allow Harmony to render 3D models using Autodesk Maya, you must include the original Maya
project file in the element folder where the 3D model was imported, along with all its textures. The project must
be renamed to have the same file name as the imported 3D model, so that Harmony can locate it and send it to
Autodesk Maya for rendering.
Harmony will take the transformations done on the imported 3D model and its subnodes, and apply them to
the model in the original Maya project so that it is rendered with the animation done in Harmony. Hence, the
imported 3D model must be in the same size and position as the model in the Maya project. However, it is
possible to use a 3D model with lower resolution textures or no textures at all, as well as less detail in the
geometry, in the Harmony scene, to help with performance when manipulating the 3D model in Harmony. This
will not affect the rendered image, as the original Maya project will be used to render the scene.
TIP
If you prefer, you can skip this step and make your scene render your Maya project from its original
location on your machine—see Linking a Maya Batch Render Node to an External Maya Project

How to set up rendering
1. In a file browser, locate and copy the original Maya project file along with all its textures. The
extension of the project file should either me .mb or .ma.
2. Browse to the folder of the scene's element in which the 3D model was imported. This folder should
be located in the scene's root folder, in the elements subfolder. For example, if your scene is located
in C:\Documents\MyScene and the element is named LR_ship, the element folder would be
located in C:\Documents\MyScene\elements\Ship.
The 3D model that was imported in the Harmony scene should be located in this folder.
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3. Paste the Maya project files and its textures in the element's folder.
4. Rename the Maya project file to have the same file name as the imported 3D model file, but preserve
its file extension. For example, if the imported 3D model is named Ship-1.fbx and your Maya
project file is named pirateship.ma, rename the Maya project to Ship-1.ma.

5. Harmony will now be able to use Maya project file when attempting to render the 3D model.
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Selecting a Rendering Engine
By default, when rendering a 3D model through Autodesk Maya, the model will be rendered using the
rendering engine its Maya project file is configured to use. However, it is also possible to select which rendering
engine to use by selecting it in the layer properties of the Maya Batch Render node. It is important to always
use the rendering engine the model was intended to be rendered with.

Harmony supports the following rendering engines:
l

Maya

l

Mental Ray

l

Renderman Reyes

l

Renderman RIS

l

Arnold
NOTE
It is recommended to use either Renderman or Arnold to render 3D objects through Autodesk
Maya, as those rendering engines will return deep texture images, which can be composited
relative to other elements in your scene with antialiasing. When using other rendering engines,
3D models that clip with elements in your scene may have a hard pixelated seam at their
intersection.

IMPORTANT
The selected rendering engine must be installed on the workstation on which Harmony is
rendering the scene, or the model will not be rendered and will be invisible in the rendered image.

1629

Harmony 15.0 Premium User Guide

How to select the rendering engine for a 3D model
1. In the Node view, locate the Maya Batch Render node, and click on its Layer Properties

button.

The Layer Properties dialog for the Maya Batch Render node appears.
2. In the Attributes tab, in the Renderer field, enter one of the following values, depending on which
rendering engine you wish to use:
l

Maya's native rendering engine: mayasoftware or maya

l

Renderman (Reyes): renderman, rendermanreyes or reyes

l

Renderman (RIS): rendermanris or ris

l

Arnold: arnold

3. Click on Close.
4. In the Camera view, click on the Render View

button.

The 3D model will now be rendered in the newly selected rendering engine.
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Linking a Maya Batch Render Node to an External Maya Project
If you prefer to keep the Maya project used to render the 3D model in its original location, you can configure
your Maya Batch Render node to render the Maya project from its original location rather than from the 3D
model's element directory in the scene. This is done in two steps:
1. Adding the Original Maya File Name field to the layer properties of your Maya Batch Render node.
2. Typing the path to the Maya project in the Original Maya File Name field.
NOTES
l

If you link your Maya Batch Render node to an external Maya project, you will need the Maya
project to remain in this location for your scene to render properly. This means you will be
unable to render the 3D model in your scene if you try render it from a different computer, or if
you move or delete the Maya project.

l

This procedure is entirely optional and is more technical than the default approach, which is to
copy the 3D model in the element folder of your 3D model. If you prefer to go with the more
simple method, see Copying your Maya Project to the Scene Directory

How to add the Original Maya File Name field to the layer properties of the Maya
Batch Render node
1. In the Node View, locate the MayaBatchRender node, and click on its Layer Properties

button.

The Layer Properties dialog for the Maya Batch Render node appears.
2. Click on the Specifications tab.
In the Specifications field, an XML script defines the input ports, output ports and attributes of the
Maya Batch Render node.
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3. Copy the line below:
<attr type="string" name="OriginalMayaFileName" value="" tooltip="Write your
project path here"/>

4. Paste it right above the </attributes> line:

You have now added the OriginalMayaFileName attribute to the Maya Batch Render Node.
However, you will not see it in the Attributes tab right away.
5. Save your scene, close it and re-open it. Afterwards, the OriginalMayaFileName property will be
visible in the Attributes tab of the Maya Batch Render node's layer properties, right under renderer.

How to link the Maya Batch Render node to your original Maya project
1. In the Node View, locate the MayaBatchRender node, and click on its Layer Properties
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The Layer Properties dialog for the Maya Batch Render node appears. The OriginalMayaFileName
field should appear under the renderer field.

2. In the Attributes tab, select the OriginalMayaFileName field.
3. Type in the path to the Maya project containing your 3D model. You must type the path to the
directory as well as the name of the project file, including its extension. Whether you are using
Windows, macOS or GNU/Linux, you must use forward slashes (/) to separate the directories.
For example, if your Maya project is stored in a folder named MayaProject in your Documents
folder and is named MayaProject.ma, and your username is username, you would type the
following location to point to it:
l

On Windows: C:/Users/username/Documents/MayaProject/MayaProject.ma

l

On macOS: /Users/username/Documents/MayaProject/MayaProject.ma

l

On GNU/Linux: /home/username/Documents/MayaProject/MayaProject.ma

Optionally, you can type in a relative path. The path is relative to the specific element folder of your
3D model, which is in a folder named elements inside your scene folder. So, for example, if you
want to store your 3D models in a folder named 3dmodels inside your scene folder, you can type in
the following relative path:
../../3dmodels/MayaProject.ma
In a relative path, two consecutive periods (..) refer to the parent folder. So, by referring to the
parent folder of the parent folder of the 3D model's elements folder, you get to the scene folder.
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Adjusting the Antialiasing of a Rendered 3D Model
Rendering engines such as Maya and Mental Ray output images in a format that uses a simple Z-buffer that
does not allow for proper antialiasing around the edges of the geometry. Hence, it is ultimately better for image
quality to render using RenderMan or Arnold if possible. Otherwise, if a different rendering engine must be
used and there appears to be pixelated hard seams around 3D models, the Z Buffer Smoothing node can be
used to smooth out the edges of the rendered model.

How to use the Z Buffer Smoothing
1. In the Node Library view, select 3D in the sections list and locate the Z Buffer Smoothing node.
2. Drag and drop the Z Buffer Smoothing node into the Node view.
3. In the Node view, connect the Z Buffer Smoothing node under the MayaBatchRender node of the
3D model.

4. Click on the Layer Properties

button of the Z Buffer Smoothing node to open its Layer Properties

dialog.
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5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your
Maya models. In most cases, you will have to experiment with a balance between the histogram
range and the kernel size to obtain the best result.
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Chapter 19: Export
Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to
further edit your movie using a third party software, composite the movie in a larger body of work or put it up
directly on the web, Harmony supports several formats for all your rendering needs.

NOTE
The different editions of Harmony support the following maximum render resolutions:
l

Harmony Essentials: 2K (2048x1556)

l

Harmony Advanced: 4K (4096x3112)

l

Harmony Premium: Unlimited
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About Rendering Write Nodes
When you render a scene in Harmony, what is actually rendered is what is connected to your scene's Write
node. Rendering a scene's Write nodes is the main way to export a scene into image and movie files for post
production.
The Node view allows you to branch out and merge elements of your scene in specific ways. By default, a scene
has a Write node connected to its main composite, meaning all of the scene's elements are rendered. However,
a Write node can be connected to any node in your scene that outputs image information, even a drawing or
an effect. A scene's renders are based on the image information that is sent to its Write node, and nothing else.
Hence, you can control exactly what gets rendered, which is especially useful if you want to have elements in
your scene that are only visible in the Camera view, such as a storyboard overlay or a camera guide, without
having them appear in the renders.
You can also set up a scene to create multiple renders by connecting several Write nodes to it. Your Write
nodes can be connected to different elements of your scene, which allows you to create separate renders for
different parts of your Node view every time your scene is rendered. For example, a scene can have a Write
node for rendering the scene without any annotations, so that render can be used in post production, and
another one for rendering the scene with its storyboard and annotations for reviewing. A scene can also have
multiple Write Nodes connected to the same composite, which can allow you to render the same image in
multiple file formats or locations at the same time.
Each Write node can be configured to export individual frames as image files, a video file, or both
simultaneously.
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Adding Write Nodes
The Write node lets you render and output connected image information.

How to add a Write node
1. In the Node Library, select the Output from the list of categories.
2. Select the Write node and drag it to the Node view.

3. In the Node view, connect the final Composite node or any other node which outputs an image you
want to render to the Write node.
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Exporting Image Sequences from the Node View
To export an image sequence, you must to adjust a few settings in the Write node’s properties. The most
important one is the Drawing Type parameter, which determines the image format in which individual frames
are exported.

How to configure the Write node to export an image sequence
1. In the Node view, open the Write node’s editor by clicking its square yellow properties button.

2. In the Output tab, select the Drawing option to create an image sequence.

3. Click Choose and browse to the directory where you want to save the output. You can also type in a
directory name, which will be created in your scene's directory, or click on Default to export your
frames in your scene's frames subdirectory.
4. In the Drawing Filename field, type the image sequence’s name prefix. It is recommended to leave
the hyphen (-) at the end of the name to separate the image name from the image number.

5. In the Start field, select the starting number for the image sequence.
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6. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.
7. In the Drawing Type field, select the file format in which your project will output

NOTE
A lot of formats are listed as their file extension, but some also have suffixes to indicate
how they are encoded. For example, PNGDP4 means PNG: double precision with 4
channels, which means the exported PNG images will have 16 bits per channel instead
of 8 bits, and will also have an alpha (transparency) channel.
8. Click Close.
NOTE
The project will not start rendering at this point. This step only configures how your
scene will be rendered.
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Exporting Movie Files from the Node View
To export a QuickTime movie, you need to adjust few settings in the Write node’s properties.

How to set the Write node to export a movie file
1. In the Node view, open the Write node’s Layer Properties by doing one of the following:
l

Click on the yellow square at the left end of the Write node.

l

Right-click on the Write node, then select Layer Properties.

2. In the Output tab, select the Movie option to create a movie file.

A Movie Folder and Movie Filename field appear among the Drawing Folder and Drawing Filename
fields.

3. Right to Movie Folder, click Choose and browse to the directory where you want the movie file to
be exported.
You can also click on Default to set the output directory to frames. This will export the movie to
your scene's frames subdirectory.
4. In the Movie Filename field, enter the desired name of the movie file to be exported, without its
extension.
5. Right of the Movie option, select one of the following export types:
l

Quick Time Movie (*.mov): Available on Windows, macOS and GNU/Linux.

l

Windows Media Video (*.wmv): Available on Windows only.
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NOTE
On Windows and macOS, Apple QuickTime must be installed in order to export
QuickTime movies. On GNU/Linux, Harmony uses a more limited, open source
QuickTime-compatible library which does not require additional software.
6. To configure the video and audio compression settings for your exported movie file, do one of the
following:
l

If on Windows or macOS and exporting a QuickTime movie, click on Movie Settings to
open the QuickTime Movie Settings dialog box—see Configuring Movie Settings for
QuickTime Movies on Windows and macOS on page 1662

l

If on Windows and exporting in Windows Media Video format, click on Movie Settings
to open the Windows Media Video Settings dialog box—see Configuring Movie
Settings for Windows Media Video.

l

If your video format is QuickTime Movie and you're on a GNU/Linux machine, click on
Video Options to configure the video compression settings for your movie file, or on
Sound Options to configure its audio compression settings—see Configuring Movie
Settings for QuickTime Movies on GNU/Linux.

NOTE
If you are using Harmony Server, and not all the machines in your database's render farm use
the same operating systems as the one you are using, you should make sure the machines that
will render your scene are compatible with your movie format and movie options. Specifically,
look out for the following exception cases:
l

If your Write node is configured to export in Windows Media Video format, the machine
that will perform the render must be a Windows machine, running Windows 7 or later,
with Windows Media Player installed.

l

If your Write node is configured to export in QuickTime Movie format and the machine that
will perform the render is a Windows or macOS machine, this machine must have Apple
QuickTime installed.

l

If your Write node is configured to export in QuickTime Movie format, be aware that
Windows and macOS use Apple QuickTime to perform the render, whereas GNU/Linux use
the OpenQuickTime library, which has a different configuration platform and a more limited
set of compression settings. Therefore, configuring a Write node's movie render on
Windows or macOS to have the render performed by GNU/Linux machines, or vice versa,
might have unexpected results.
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NOTE
The project will not start rendering at this point. This step only configures how your scene will be
rendered.

1644

Chapter 19: Export

About Multiple Renders
Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a lot of time as
you do not have to return between each render to start a new one.
To use multiple renders, connect as many Write nodes as needed to match the required number of exports.
Then, adjust each Write node’s settings to create image sequences or movies.
NOTE
Each Write node must be configured to export with different file names or in different locations. If
one Write node is configured to export images or a movie file with the same file name as with
another Write node, one will overwrite the other.
When you have multiple Write nodes in a scene, it is useful to rename the nodes according to their output
settings such as: low_resolution_movie or HDTV_sequence.
To export different resolutions concurrently, you need to create a combination of the following:
l

Write node

l

Scale-Output node

l

Crop node

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to NTSC, you
will need to combine the Crop node with a Scale Output node.
Once you know the type of render you want to do, you will need to retrieve your nodes from the Node Library
and connect them to the scene’s network.
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Adding Multiple Write Nodes
Harmony allows you to render multiple exports simultaneously. For example, you can export a version of your
project, a full high-res version and an image sequence with a transparent background all at the same time.

How to connect nodes to export multiple renders
1. In the Node Library view, retrieve the necessary Write, Scale-Output and Crop nodes.

2. Connect the final Composite node to the first Write node. (Make sure you have a Display node
reading the same information.)
3. Open the Write node’s editor by clicking on its square yellow properties button.
4. Name the Write node according to the render type that you are planning to do.
5. Configure the Write node's parameters—see Exporting Image Sequences from the Node View on
page 1640 and Exporting Movie Files from the Node View.

6. Connect the other Write nodes and repeat steps 2 to 5.
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7. Using the Alt key, insert the Scale-Output nodes between the final Composite node and their
corresponding Write node.

8. Using the Alt key, insert the Crop nodes between the final Composite node and their
corresponding Write or Scale node.

l

If the output from the Crop node has to be scaled down, use a Scale-Output node.
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9. Connect a Display node to each Scale-Output or Crop node to see each final image in the Camera
view.
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Setting Up Scale-Output Nodes
Once your Write nodes are connected, if you want one of your renders to be smaller than your scene's
resolution, but have the same aspect ratio and contain the same camera frame, you can use the Scale-Output
node to shrink the image output by your scene's composite before it reaches the Write node.
You can use a Scale-Ouput node in conjunction with a Crop node to produce a render that is in a different
resolution and aspect ratio than your scene's. For example, if you want a scene in HD 1080p to render in NTSC,
you can use the Scale-Output node to scale down the image to 960 x 540 pixels, which matches the NTSC
resolution height, but has a greater resolution width to preserve the aspect ratio of HD 1080p. Then, you can
use a Crop node to crop the image to 720 x 540 pixels, cropping out the image in the left and right edges to
make it fit an NTSC screen.
NOTE
If you use a Scale-Output node to scale up the image, it will look pixelated. If you want to export a
scene in multiple resolutions, you should set your scene's resolution to be the highest resolution in
which you want to render, and use Scale-Output nodes to scale down the output.

How to set a Scale-Output node
1. In the Node Library view, select Scale-Output from the list of categories.
2. Select the Scale-Output node and drag it to the Node view.

3. In the Node view, connect the Composite node to the Input port of the Scale-Output node.
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4. In the Node view, connect the Scale-Output node to the input ports of both the Display node and
the Write node.

5. In the Node view, open the Scale-Output node’s editor by clicking its yellow square properties
button.

6. In the Layer Properties dialog box, do one of the following:
l

Under Customer Resolution, type in the Width and Height of the resolution you want
to scale to, in pixels.
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l

Uncheck the Custom Resolution option, then choose one of the available resolution
presets in the Resolution Name drop down list.

7. Click Close.
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Setting Up Crop Nodes
Once your Write nodes are connected, if you want one of your renders to be in a different aspect ratio than
your scene's, you can use the Crop node. For example, if you want a scene with an aspect ratio of 16:9 to
produce a render in 4:3, you can use a Crop node to crop out the image on the left and right edges of the
camera frame.
You can use a Scale-Ouput node in conjunction with a Crop node to produce a render that is in a different
resolution and aspect ratio than your scene's. For example, if you want a scene in HD 1080p to render in NTSC,
you can use the Scale-Output node to scale down the image to 960 x 540 pixels, which matches the NTSC
resolution height, but has a greater resolution width to preserve the aspect ratio of HD 1080p. Then, you can
use a Crop node to crop the image to 720 x 540 pixels, cropping out the image in the left and right edges to
make it fit an NTSC screen.

How to set a Crop Node
1. In the Node Library view, select Output from the list of categories on the left.
2. Drag the Crop node to the Node view.

3. In the Node view, connect the Composite node to the Input port of the Crop node.

4. In the Node view, connect the Crop node to the input ports of both the Display node and the Write
node.
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5. In the Node view, open the Crop node’s property editor by clicking the yellow square properties
button.

6. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

7. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display node
in the Display toolbar. In the Advanced Animation toolbar, select the Translate
middle mouse button, move the crop area. If the Animate

tool and with the

mode is enabled, the position of the

crop area will be animated over time.
8. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more
information), you can create a function to animate the cropped selection. Click the Function
button beside the Local dialog box to create a Bezier or ease curve.
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9. If you created a function curve to animate the cropped selection, click again on the Function
button and edit the curve by adding keyframes and moving the selection box in the Camera view.If
you created a function curve to animate the cropped selection, click again on the Function

button

and edit the curve by adding keyframes and moving the selection box in the Camera view.

10. If you want to draw a frame around the area to crop instead of actually cropping the image, enable
the Draw Frame option.

11. If you enabled the Draw Frame option, click on the colour rectangle to open a Colour Picker dialog
and adjust the colour of the frame to draw.

12. If you wish to only use this Crop node when rendering your scene at specific resolution, click on the
Enabling tab.
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13. Do one of the following to configure when your Crop node should be used for rendering:
l

Select Always Enabled if your Crop node should be enabled every time the scene is
rendered.

l

Select Enabled when resolution name is if you want your Crop node to only be
enabled when rendering your scene in one of the available resolution presets. Then, in
the Filter name drop down list, select the resolution preset at which your scene must
be rendered for the Crop node to be enabled.

l

Select Enabled when resolution isif you want your Crop node to only be enabled
when rendering your scene at a specific resolution. Then, in the X resolution and Y
resolution fields, type in the width and height of the resolution at which your scene
must be rendered for the Crop node to be enabled, in pixels.

14. Click Close.
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Rendering from Write Nodes
Once your Write nodes are properly set up, you can render them using the Render Write Nodes dialog.

How to render the scene's Write nodes
1. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y
(Windows/Linux) or ⌘ + Shift + Y (macOS).
The Render Write Nodes dialog appears.

NOTE
If you are using Harmony Server, the Render Write Nodes dialog will have a
Batch Composite Options section. Enabling this option will send your scene to batch
rendering instead of rendering it locally. Simply disable this option and follow the steps
below. For information on how to use Batch Composite Options, see Batch Rendering.
2. In the Range section, select the frame range to render by doing one of the following:
l

If you want to render all the frames in your scene, select All Frames.

l

If you want to render a specific sequence of frames, select Selected Frames then, in
the fields to the right, enter the number of the first and last frame of the frame
sequence you wish to render.

1. If your production is intended for broadcasting on NTSC compatible televisions, enable Field
Composite Options.
l

To export a scene animated at 24 frames per second in 60 frames per second so that
the frames can be combined with the 3:2 pulldown technique, enable the Add
Pulldown option.

l

If you want Harmony to automatically interlace the exported frames to create a 30
frames per second sequence, enable the Automatic Combine option.
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l

By default, odd frames are interlaced on the first field (odd lines), and even frames are
interlaced on the second field (even lines). If you wish to interlace odd frames on the
second field and even frames on the first field, enable the Second Field First option.

2. Enable the Preview option to automatically preview the exported image sequence in Harmony Play
once the render is done.
3. Click OK.
Harmony begins rendering the scene's Write nodes.

If you enabled the Preview option, the exported images will load in Harmony Play once the render is
done. You can user Harmony Play to play the image sequence with the scene's soundtrack.
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Exporting a Movie File
T-HFND-010-013
Using the Export Movie dialog, you can export your animation as a video file. By default, Harmony will export
your entire scene in its full resolution. If you prefer, you can choose to export only a specific frame range in your
scene, or to export in a smaller resolution, which can be useful if you need to save on time or disk space.
If you have specific requirements for the quality and size of your exported video files, you can use the Movie
Options dialog to configure the video and audio compression settings. If you're exporting a QuickTime movie,
you have access to all of the codecs and compression settings made available by QuickTime's interface.
If you added burn-in information to your scene, it will be included in your exported file—see the Reference
guide .

How to export a movie file
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. In the Video Format drop-down menu, select the desired format for your movie file:
l

Quick Time Movie (*.mov): Available on Windows, macOS and GNU/Linux.

l

Windows Media Video (*.wmv): Available on Windows only.
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NOTE
On Windows and macOS, Apple QuickTime must be installed in order to export
QuickTime movies. On GNU/Linux, Harmony uses a more limited, open source
QuickTime-compatible library which does not require additional software.
3. Click Browse to select the location and file name of your exported movie file.
4. Click OK.
5. In the Display Source section, select the Display node to use for rendering your project.
NOTE
If there is no Display node in your scene, the only available option will be Display All.
This renders all the nodes in your scene, including ones that are not connected to
anything, in the order in which they're listed in the Timeline view. If you wish to have
control over what is rendered, it is recommended to have at least one Display node in
your scene and to connect it to the composite you wish to render.
6. From the Export Range section, decide whether you want to export the entire scene (All) or a
specific frame range. If you decide on the latter, enter the frame range.

7. In the Resolution section, select one of the following from the menu:
l

A preferred resolution ratio.

l

Custom: Enables the Width and Height fields so you can enter a specific size.
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8. In the Options section, do one of the following to configure your movie's video and sound
compression settings:
l

If on Windows or macOS and exporting a QuickTime movie, click on Movie Settings to
open the QuickTime Movie Settings dialog box—see Configuring Movie Settings for
QuickTime Movies on Windows and macOS on page 1662

l

If on Windows and exporting in Windows Media Video format, click on Movie Settings
to open the Windows Media Video Settings dialog box—see Configuring Movie
Settings for Windows Media Video.

l

If your video format is QuickTime Movie and you're on a GNU/Linux machine, click on
Video Options to configure the video compression settings for your movie file, or on
Sound Options to configure its audio compression settings—see Configuring Movie
Settings for QuickTime Movies on GNU/Linux.

9. Click OK.
10. In the Export to QuickTime Movie dialog box, click OK.
A progress bar appears.

11. Browse to the location on your computer where you exported your movie and double-click on it to
view it in your video player.
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Configuring Movie Settings for Windows Media Video
On Windows, it is possible to export in Windows Media Video format.

How to configure video and sound settings for Windows Media Video
1. In the Video section, select the desired Variable Bit Rate Quality for your video. A higher setting will
ensure a better image quality. A lower setting will create a smaller video file.

2. Using the Sound checkbox, select whether or not you want your movie file to have sound.
3. Using the Profile drop-down menu, select the preferred compression settings for your movie's
soundtrack. Each profile has a combination of audio sample rate, sample size and channel mode,
which cover the following options:
l

Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz and 44100 Hz. The
default setting is 22050 Hz. It is best to export your audio at a rate that matches the rate of
your original sound files. For example, if your file has an audio sample rate of 48000 Hz and
you choose a sample rate of 22050 Hz, the sound will play at the same speed, but higher
frequencies will be missing, making it sound muffled. For reference, the standard sound
quality is 44000 kHz for films, and 48000 kHz for DVD. Lower rates are liable to impact the
quality of your movie's soundtrack negatively, but they can be useful if disk space or
download speed is critical.

l

Sample size: Also known as Bit Depth, this determines the amount of precision used to
record each wavelength in the soundtrack. The standard size is 16-bit. If you choose 8-bit,
the amount of disk space your sound track requires is halved, but the audio will sound
muffled.

l

Channel mode: Stereo sound has a separate sound track for the left and the right speakers,
allowing to make the origin of each sound realistically match the origin of their corresponding
action. If you choose Mono, your sound track may use less disk space, but both the left and
right channels will be merged into a single track.
NOTE
Exporting in 8-bit audio requires Apple QuickTime to be installed.
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Configuring Movie Settings for QuickTime Movies on Windows and
macOS
On Windows and macOS, you can export QuickTime movies. You can configure the video and audio settings for
your exported movies using the configuration interface provided by QuickTime.
NOTE
To export QuickTime Movies on Windows, Apple QuickTime must be installed on your machine.

How to configure video and sound settings for QuickTime movies on Windows and
macOS
1. In the Movie Settings dialog box, select whether you want your movie to include Video and Sound
data, as well as if the video should be optimized for Internet streaming.

2. In the Video section, click Settings.
The Standard Video Compression Settings dialog box opens.
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3. From the Compression Type menu, select a codec. The availability of certain compression settings
depends on the Compression Type selected. For example, when the Animation compression type is
selected, the Data Rate option is greyed out.
TIP
If you want to render a QuickTime movie with high quality compression and
transparency, you can use the Animation video codec with the colour depth set to
Millions of Colours+.
4. In the Motion section, choose a Frame Rate from the list.
By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a
lower frame rate, your export playback will be faster than your actual project. The reverse is also true
for a higher frame rate.
5. If you want keyframes inserted, select the Every option and set the number per frame.
This is the option recommended by QuickTime. For further details, refer to the QuickTime
documentation.
6. In the Quality section, use the slider to choose a quality setting. Remember that the better the
quality of the export, the larger the file.
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7. From the Data Rate section, either choose to allow the program to automatically select the most
optimal bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost
to the quality of the export.
8. In the same section, from the Optimized For menu, select the intended viewing method for the
export.
9. Click OK.
10. From the Movie Settings dialog box, click Sound Settings.
The Sound Settings dialog box opens.

11. From the Compressor menu, select a compression type. The default setting is None. This exports
your audio as is without performing any lossy compression or conversion, preserving its fidelity.
Other compressors can be used if you need your movie's audio track to be exported in a specific
format, or if disk space or download speed is critical, but they may impact the quality of your movie's
soundtrack negatively.
12. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of
your original sound files. For example, if your file has an audio sample rate of 48 kHz and you choose
a conversion rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be
missing, making it sound muffled. For reference, the standard sound quality is 48 kHz for
broadcasting and DVD. Lower rates are liable to impact the quality of your movie's soundtrack
negatively, but they can be useful if disk space or download speed is critical.
13. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of
precision used to record each wavelength in the soundtrack. The standard size is 16-bit. If you
choose 8-bit, the amount of disk space your sound track requires is halved, but the audio will sound
muffled.
14. Select whether to Use the Mono or Stereo channel mode. Stereo sound has a separate sound track
for the left and the right speakers, allowing to make the origin of each sound realistically match the
origin of their corresponding action. If you choose Mono, your sound track may use less disk space,
but both the left and right channels will be merged into a single track.
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Exporting a QuickTime Movie with Lossless Compression and
Transparency
It is possible to export a QuickTime movie with lossless video compression and transparency by using specific
compression settings.

How to export a lossless QuickTime movie with transparency
1. In the Video section of the Movie Settings dialog, select Settings.
2. In the Standard Video Compression Settings dialog, set the Compression Type to Animation.
3. In the Compressor section, set the Depth to Millions of Colors+ .

4. Click OK.
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Configuring Movie Settings for QuickTime Movies on GNU/Linux
On Windows and macOS, Harmony uses QuickTime to export QuickTime movie files. On GNU/Linux, QuickTime
is not supported, but Harmony is still able to export QuickTime-compatible movie files using the
OpenQuickTime library, which is included in Harmony's package. As a third party library, OpenQuickTime offers
a more limited set of compression settings.

How to configure video and sound settings for QuickTime movies on GNU/Linux
1. Open the Video Options dialog.

2. In the Video Options dialog, select the preferred Codec:
l

Motion-JPEG A: A very portable codec that performs lossy JPEG compression and interlaces
the frames. Motion-JPEG A compression is less efficient than Photo JPEG in terms of quality
and file size, but may be a more portable alternative for software that does not support Photo
JPEG.

l

Photo JPEG: Encodes the movie as a sequence of JPEG images. JPEG images have lossy
compression. This is the most efficient codec for file size.

l

Portable Network Graphics (PNG): Encodes the movie as a sequence of PNG images. PNG
images have lossless compression.

l

Tag Image File Format (TIFF): Encodes the movie as a sequence of uncompressed
TIFF images. This codec is lossless.

l

Uncompressed (RGB): Encodes the movie as uncompressed bitmap data. This codec is
lossless.
NOTE
Portable Network Graphics (PNG) and Photo JPEG is the only codec supported by both
Harmonyand GNOME's Totem Video Player. Other codecs may require additional
software to play on Linux workstations.

3. If exporting in Motion-JPEG A or Photo JPEG, set the desired JPEG quality for your video in the
Quality field. This setting ranges from 0 to 100, and is set to 85 by default. A higher setting
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increases picture quality, but makes the resulting movie file heavier.
4. If exporting in Motion-JPEG A, set the desired Field Dominance. Motion-JPEG A is interlaced.
When set to 1, odd frames are encoded on the first field. When set to 2, odd frames are encoded on
the second field.
5. Click OK.
6. Open the Sound Options dialog.

7. In the Sound Options dialog, select the preferred Codec:
l

A-Law 2:1: This codec uses logarithms to compress audio data. The resulting audio stream
requires half the disk space of uncompressed audio data, but is of noticeably lower quality.

l

IMA 4:1: This codec compresses audio data to require a quarter of the disk space required for
uncompressed audio data. It is not supported by a lot of software.

l

Twos Complement - Little Endian PCM: A standard uncompressed audio codec.

l

Twos Complement - Big Endian PCM: A legacy standard uncompressed audio codec. This
codec may be compatible with older editing interfaces.

l

(mu)-Law 2:1: Similarly to A-Law, this codec uses logarithms to compress audio data. The
resulting audio stream requires half the disk space of uncompressed audio data, but is of
noticeably lower quality.

8. In the Sample Rate drop down menu, select 22050. This is the only sample rate supported for movie
export in Harmony on Linux.
9. Click OK.
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Exporting Flash (SWF) Movies
Exports a Flash movie file.
Harmony supports exporting Flash movie files with a limited subset of vector and bitmap effects, the latter
which can be previewed in Render View

mode.

The following can also be exported in Flash movies:
l

Pencil line thickness, which are converted to brush strokes

l

Auto-Patch nodes, for patching the joints between different parts of a cut-out character

l

Burn-in information, such as time code, frame number and scene information—see the Reference guide .

Before attempting to export a Flash movie, it is recommended to preview how your scene will render in Flash
using the SWF Preview command. To do this, do one of the following:
l

From the top menu, select Play > Test SWF Movie.

l

In the Playback toolbar, click and hold the Render and Play
Test SWF Movie

mode, then click on the button again.

How to export a .swf movie
1. From the top menu, select File > Export > SWF.
The Export to Flash Movie (.swf) dialog box opens.
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2. Click Browse and select a file name and destination path for your movie.
3. In the Display Source section, select a Display node to read from in the Export From Display Node
menu.
4. In the Export Range section, select one of the following options:
‣

All: To export all the frames of your movie.

‣

Frames: To export a frame range. Enter the frame range in the fields.

5. In the Options section, enter a Frame rate (fps). By default, it will be set to match the fps of your
Harmony project. If you choose a lower frame rate, your export playback will be faster than your
actual project. The reverse is also true for a higher frame rate.
6. In the same section, select the JPEG quality:
‣

100 = Full quality

‣

50 = Average quality at about 1/5th of the size.

‣

25 = Medium quality where loss of high image resolution starts to occur.

‣

10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣

1 = Lowest quality where there is extreme loss of colour and detail and the image becomes
nearly unrecognizable.

7. To prevent your movie from being imported into another application, select the Protect from
Import option.
8. For a lighter format, select the Compress Movie option. The movie may lose some quality, but the file
will be lighter.
9. To retain the thickness of pencil lines, select the Convert Pencil Lines to Brush Lines option.
10. In the Do Not Export section, select the effects you do NOT want to be rendered in the SWF movie.
Note that certain Harmony effects are not listed in this section as they are not compatible and
therefore not available for SWF export. These effects will not appear in the SWF render.
11. Click OK.
12. Browse to the location on your computer where you saved your Flash Movie and double-click on it to
view the export.
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Exporting OpenGL Frames
Because rendering scenes requires a lot of computer resources, and playback in Harmony does not always keep
up with the scene's framerate, it may be difficult to decide how to preview your animation as you're working on
it. Exporting OpenGL frames gives a more convenient alternative.
OpenGL is the name of the engine used to display your scene's content as you are working on it. Hence,
exporting OpenGL frames basically means you're exporting frames as they are usually rendered in the Camera
view: Without antialiasing, compositing or effects. This is significantly faster than exporting your final frames,
and can allow you to preview your animation in real-time without having to wait for a render.
TIP
You can quickly and easily create and view an OpenGL render of your scene using the Record and
Play command. To do this, do one of the following:
l

l

In the top menu, select Play > Record and Play.
In the playback toolbar, click and hold the Render and Play
button, select Record and Play
to set the button to Record and Play mode, then click on the button again.

How to export OpenGL Frames
1. From the top menu, select File > Export > OpenGL Frames.
The Export OpenGL Frames dialog box opens.

2. In the Output section, click Browse and select the directory where you wish to export the frames.

1670

Chapter 19: Export

3. In the Filename field, enter a file name for the file to export. If you're exporting frames as individual
images, the specified file name will be used as a prefix, and the frame number will be used as a suffix.
To use the default file name, click on Default.
4. In the Format section, select Frames if you want to export each frame as an individual image, or
Movie if you want to export a QuickTime movie file.
5. If you are exporting frames:
a. Select a numbering format in the Suffix dropdown. The numbering format determines how
many digits to use for the frame numbers. For example, if the Suffix is set to 001, the first
frame will be numbered 001, the second one will be numbered 002, etc.
b. If you are exporting frames, select an image format from the Drawing Type dropdown.
NOTE
A lot of formats are listed as their file extension, but some also have suffixes to indicate
how they are encoded. For example, PNGDP4 means PNG: double precision with 4
channels, which means the exported PNG images will have 16 bits per channel instead
of 8 bits, and will also have an alpha (transparency) channel.
If you are exporting a movie:
a. In the Video Format drop-down menu, select the desired format for your movie file:
l

Quick Time Movie (*.mov): Available on Windows, macOS and GNU/Linux.

l

Windows Media Video (*.wmv): Available on Windows only.
NOTE
On Windows and macOS, Apple QuickTime must be installed in order to export
QuickTime movies. On GNU/Linux, Harmony uses a more limited, open source
QuickTime-compatible library which does not require additional software.

b. In the Options section, do one of the following to configure your movie's video and sound
compression settings:
l

If on Windows or macOS and exporting a QuickTime movie, click on Movie Settings to
open the QuickTime Movie Settings dialog box—see Configuring Movie Settings for
QuickTime Movies on Windows and macOS on page 1662

l

If on Windows and exporting in Windows Media Video format, click on Movie Settings
to open the Windows Media Video Settings dialog box—see Configuring Movie
Settings for Windows Media Video.
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l

If your video format is QuickTime Movie and you're on a GNU/Linux machine, click on
Video Options to configure the video compression settings for your movie file, or on
Sound Options to configure its audio compression settings—see Configuring Movie
Settings for QuickTime Movies on GNU/Linux.

6. From the Resolution section, select a resolution for export. If you are running some quick tests, then
you might want to reduce the resolution to save on exporting time. You can also select the Custom
option to specify the desired Width and Height of your exported frames.
7. In the Range section, do one of the following:
l

If you want to render all the frames in your scene, select All Frames.

l

If you want to render a specific sequence of frames, select Selected Frames then, in the fields
to the right, enter the number of the first and last frame of the frame sequence you wish to
render.

l

If you want to export the current frame, select Current Frame.

l

If you want to export specific frames, select Selected Frames, then click on each frame you
wish to export in the frames list to the right. You can also click and drag to select a range of
frames in the list. If you want to remove a frame from your selection, simply click on it again.

8. In the Options section, select a Display node to use for rendering your OpenGL frames from. It is
recommended to render from the Display node located under the final Composite node, unless you
want to render a specific section displayed by a particular Display node.
9. In the Options section, select the Open in Player option to view the rendered frames.
10. Click OK.
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About PSD Layouts
Harmony allows you to export the contents of your scene as a Photoshop Document (.psd) layout. This can be
helpful for scene setup, background art retakes, or even planning of animation.

Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a camera
movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear
and complete layout.You can also create all the layouts for your production in the same Harmony project which
can be imported later on when you start each scene’s project. This will help set up the scene and begin its
creation. You can use the layout .psd files to create the background art of each scene and make sure everything
is correctly framed and at the right size. Finally, you can also have a layer with a drawing of the rough poses of
the character or action and generate your layout posing from there.
NOTE
Because the layout image is one static .psd file, only the first frame of your drawing layers will be
exported—see Staging on page 1161 and Motion Paths on page 971.

NOTE
For information on importing a PSD layout, see Importing PSD Layouts on page 1333
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Exporting PSD Layouts
T-LAY-006-001
You can export your scene's first frame as a PSD layout to modify and paint in an external image editing
software. The matching XLI file always has to be with the exported layout file.
NOTE
For information on importing a PSD layout, see Importing PSD Layouts on page 1333

How to export your scene as a layout
Before exporting your scene as a layout, position your background elements, and everything you need as a
reference in your scene, including a camera movement.
1. From the top menu, select one of the following:
l

File > Export > Layout Image to export all the elements in your scene to the layout
.psd file.

l

File > Export > Layout Image from Selection to export only the selected elements.

The Export Layout Image dialog box opens.
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2. In the Export Layout Image dialog box, set the export parameters—see the Reference guide
3. Click OK to validate the settings and export a .psd file of your layout.
The resulting image is a .psd file with one or two layers, each of which is contained in a
corresponding group. These groups make the layout .psd file ready for a multilayer .psd import.

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera
option, this group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame
when you exported the layout image.

NOTE
An .xli file is exported along with your .psd file. This file contains all the necessary information
for correctly importing and automatically positioning your layout image in a Harmony project.
Do not delete the .xli file or rename it. Also, always keep it at the same location as the layout
.psd file.
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, such
as an editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of
individual files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack
1. From the top menu, select File > Export > Soundtrack.
The Export Soundtracks dialog box opens.

2. In the Output section, click Browse and specify where you want to save the exported sound file.
3. In the Export Range section, select one of the following options:
l

All: Exports the sound over all the frames of your scene.

l

Frames: Sets the start and end frames in the corresponding fields on the right.

4. From the Options menu, select one of the following:
l

Process Soundtracks Individually: Each soundtrack from all layers is exported as
individual files.

l

Merge all Soundtracks: One single file is created, combining all the sound files you
imported in your scene. Note that it will only use the sound files in the selected frame
range set in the Export Range section. If you selected to export all the frames, all the
sound files will be processed.

5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export.
It is a good idea to verify what is required by the software or device that you may want to use next
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with the sound file.
6. Click OK.
The generated sound files appear in the selected directory and are named according to the scene
name. Individual files keep their original name; only a prefix matching the scene name is added.
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Batch Rendering
In Harmony Server, you can choose to render your scene locally or to send it to the render farm on your network
so that other computers can render your scenes while you continue working on your station. This option is not
available in Harmony Stand Alone, as render jobs are sent to a Harmony Server database, and machines that
perform the render must be connected to this database.
There are two approaches to rendering a scene in Harmony Server:
l

Local Rendering is done directly by your machine in your Harmony session. Hence, it uses your
machine's resources and will prevent you from working on the scene until the render is done. You will
see the render progress in real time and will be able to preview the results right after it's finished.

l

Batch Rendering is done by sending a scene to the server's render queue so it can be processed by the
render farm. This allows you to keep working on your scene while the render is being done. The
rendering progress can be monitored in Control Center and, when finished, the results can be
previewed in Harmony Play. Batch Rendering gives you access to additional rendering options.

When sending a scene to batch rendering, it is not rendered immediately. Computers connected to the
Harmony database that are configured to render scenes for the database check for new render jobs
periodically, and start performing the render job when they find one that isn't already being rendered by
another machine.
NOTE
To configure a Harmony Server database and to set up clients to perform batch rendering jobs,
refer to the Harmony Installation Guide.

How to send a scene to the batch rendering queue
1. Save your scene.
2. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y
(Windows/Linux) or ⌘ + Shift + Y (macOS).
The Render Write Nodes dialog appears.
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1. In the Range section, select the frame range to render by doing one of the following:
l

If you want to render all the frames in your scene, select All Frames.

l

If you want to render a specific sequence of frames, select Selected Frames then, in
the fields to the right, enter the number of the first and last frame of the frame
sequence you wish to render.

3. Enable Batch Composite Options. This will send your scene to your Harmony database's batch
rendering farm, whereas disabling this option will make Harmony render your scene locally.
NOTE
When Batch Composite Options is enabled, the Preview option is not available. This is
because Harmony does not track the progress of a render when it is performed by the
Harmony database's render farm. You can only enable the Preview option when
rendering locally.
4. If you want the machine that will render your scene to output detailed information about the process
in its log, enable the Debug option.
5. If you want to split the render job for your scene into several smaller render jobs, so that the load can
be shared by different machines in the render farm, enable the Chunk option. Then, enter the
amount of frames each chunk should render in the Size (Frames) field.
6. If you want to render the scene from a specific camera, select the desired camera from the Camera
drop down list. A scene can have several cameras added in the Node or Timeline view, and each of
them can be animated independently.
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7. In the Resolution section, do one of the following to select the resolution in which to render the
scene:
l

If you want to render the scene in its actual resolution, select By Name and, in the
resolution preset drop down list, select Default.

l

If you want to render the scene in one of the available preset resolutions, select By
Name and, in the resolution preset drop down list, select the desired resolution preset.

l

If you want to render the scene in a specific resolution, select By Value, then enter the
Width and Height of the desired resolution, in pixels.

8. If your production is intended for broadcasting on NTSC compatible televisions, enable Field
Composite Options.
l

To export a scene animated at 24 frames per second in 60 frames per second so that
the frames can be combined with the 3:2 pulldown technique, enable the Add
Pulldown option.

l

If you want Harmony to automatically interlace the exported frames to create a 30
frames per second sequence, enable the Automatic Combine option.

l

By default, odd frames are interlaced on the first field (odd lines), and even frames are
interlaced on the second field (even lines). If you wish to interlace odd frames on the
second field and even frames on the first field, enable the Second Field First option.

9. Click OK to start the rendering process.
A confirmation dialog box opens to inform you that the frames have been sent to the Render queue.

If the selected frames were already sent to the Render queue, but were not yet rendered, dialog box
opens to inform you that these frames were already in the queue, but that they have been updated
with the selected options.
You can also send scenes to batch rendering and check the status of the rendering queue using the
Control Center application.
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Chapter 20: Library
T-RIG-009-001
Using templates and symbols, you can share and reuse any elements you create in Harmony. The Harmony
library lets you store several different elements such as puppets, backgrounds, animations and key poses. In
fact, anything you create in Harmony can be stored in the library.

The Library view is where you can store and reuse your artwork and animation in other scenes or build props
and puppets.
The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation
processes. The library can contain any asset used in a Toon Boom Harmony production.
Using the library is as simple as dragging the content into the library to store your artwork and then dragging
it to the Timeline or Camera view when you want to reuse it.
Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from.
When working on the database, the structure of the library differs from when working on Harmony Stand
Alone.

Harmony Server provides three default library folders:
l

Symbols: The only library folder containing symbols for your project. You can organize the symbols
library folder using subfolders, but you cannot create a second library for your symbols. This library is
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local to your project.
l

Environment: A folder located inside the Environment folder. Every asset stored in this folder is
accessible from any job and scene contained within this environment.

l

Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene
contained within this job.
NOTE
You can create a folder called library in the usa_db folder on the server to create a global library.
Once the Harmony application is restarted, a Global library folder automatically appears in every
user's library. Every asset stored in this folder is accessible from any scene, job and environment.
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About Structure
As you will probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:
l

Characters

l

Props

l

Backgrounds
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Creating Libraries
T-LAY-005-001
There are two ways to create libraries.
l

Directly through your operating system

l

Using Harmony's interface

Although you can only have one symbol library folder, you can organize it by creating subfolders.

How to create a library folder through your operating system
1. On your computer, create a new folder with a relevant name in the location where you want the
library to be stored.

How to create a library folder in Harmony
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse for the location where you want to store your new library folder.
3. Click the New Folder button.
A new folder appears.
4. Name the new library folder with a relevant name and click OK.
The new library appears in the Library List section.
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Opening Libraries
T-LAY-005-002
Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network
as a library. Opening a library means linking the folder to your Library view. You only need to open the library
once. The library folder is available every time you open the application until you decide to close the library and
unlink it.

How to open a library
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder and click OK.
The new library appears in the Library Folders section.
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Closing Libraries
You may not always require all the library folders in the Library List. If so, you can close the ones you do not
need. Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it
on your hard drive or network and open it in the Library view.

How to close a library
1. On the right side of the Library view, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.
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Creating Folders
T-ANIMPA-003-009
Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or
in the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the
right to modify it before being able to add a new folder to it.

How to create a folder
1. On the left side of the Library view, select the library folder to which you want to add a subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > New Folder.
The new folder appears in the Library. Click on the library containing the new folder and click the
plus [+] sign to expand it.
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Deleting Folders
You can delete a folder from the library if its contents are no longer needed.
NOTE
All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data
cannot be retrieved.

How to delete a folder
1. In the Library view's left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and
select Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press Del.
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Renaming Folders
Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder
1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and
select Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press Enter/Return to validate the operation.
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Refreshing Libraries
If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.

How to refresh a library
1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press F5.
The library displays the new content.
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Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails)
for you. You can generate template thumbnails yourself, if they do not display or if the process has been
stopped.

How to generate thumbnails
1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.
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Deleting Thumbnails
You can also delete thumbnails if you want to send a template to another user or studio and keep your
packages small.

How to delete thumbnails
1. In the Library View menu, select Edit > Delete Thumbnails.
All the thumbnails contained in the library are removed.
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Searching in Libraries
When working on a movie or series, you will probably end up with many templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool
1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left

and right

arrows to see the previous and next results. The Search engine will

look for results within the library master folder and its subfolders. It will not look in other libraries.
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About Templates
T-LAY-005-003
When you want to reuse artwork and animation from your project in other scenes, you must create a template.
A template can be seen as a portable scene or package that you can drag inside your project. A template is an
individual copy of the artwork stored in the library which you can reuse in different scenes. Once a template is
stored in the library, you can access it from any project.

Master Template
You can create a master template out of a cut-out puppet you created so you can reuse it throughout a single
project or a full production. A cut-out character's master template stores the entire rig, structure, drawings, and
keyframes of the different poses of your puppet into a single asset.
Master templates are created from the Node view.
The Timeline view and the Node view display different information about a scene and its structure. To make
sure a character's main template, also called the master template, is rigged exactly the way it was meant to be
when it's imported into a scene, it should be created with all the connections, effects, composites, nodes, pegs,
groups, drawings, timings, as well as all the other information in the scene it was originally created in.
Because the Node view is the most faithful representation of a rig's structure, it is recommended to create
master templates from the Node view rather than the Timeline view. Templates created from the Timeline view
may lose the extra connections, effects and groupings that are visible in the Node view but which aren't
properly connected to its main structure.

Action Templates
An action template, also known as animation template, is created from the Timeline view. This template allow
you to reuse animations, key poses and part of an animation and contains mainly keyframes and drawing
exposures. For example, you can reuse head positions or a leg animation from a walk-cycle and place them
inside other animations. When it is extracted from the Timeline view, it loses the extra connections, effects, and
groupings from the Node view.
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An action template is used with a master template. It cannot be used on its own since it does not contain all the
information required to rebuild the puppet skeleton and advanced connections. The standard process is to first
import the master template to the Node view or Timeline’s left side, and then slide the action template into the
Timeline’s right side. This allows you to first build the skeleton and then give it the right pose.
The combination of master and action templates will function as long as the layer order and connections are the
same.
When you create an action template, be sure to name it so you can easily identify it as an animation.
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Creating Templates
T-ANIMPA-003-010
You can create a template from both the Timeline and Node views. When creating templates of 3D objects, all
associated textures linked to Maya files will be incorporated into the template.
NOTE
If you are creating a template from a character rig master template, you should collapse everything
inside a master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Timeline view
1. In the Timeline view, select some cells or layers.
You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting
its root layer. This can be useful for creating templates based on character rigs or scene
backgrounds.
2. In the Library view, select a folder to store the template. By default, you will have a library named
Harmony Premium Library , which is stored on your computer, in the Toon Boom Harmony
Premium Library subfolder of your Documents folder.
3. If the library folder is locked

, right-click and select Right to Modify.

4. Drag the selection to the chosen library folder.
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5. In the Rename dialog box, give the new template a name.
6. Click OK.

How to create a template from the Node view
1. In the Library view, select the folder in which you want to store the template.
2. If the library folder is locked

, right-click and select Right to Modify.

3. In the Node view, select the nodes for creating the template and group them. It is very important to
group your cut-out character rig before storing it in the Library, so your files are organized.
4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux)
or ⌘ + G (macOS). Make sure you have a composite under the connections before grouping,
otherwise there will be numerous connections going outside the group.

5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

6. In the Node view, select the group node and copy and paste it inside the template folder in the
Library view or press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (macOS).
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7. In the Rename dialog box, give the new template a name and click OK.
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Deleting Templates
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.

How to delete a template
1. In the Library view, select the folder containing the template to delete.
NOTE
If the library folder is locked, right-click on the folder and select Right to Modify.
2. Right-click on the selection and select Delete or press Del.
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Editing Templates
You can open a template and edit it just like any other project. If you want modify your templates, you can edit
them using the Edit Template command.

How to edit a template
1. In the Library view, select the folder containing the template to edit.
NOTE
If the library folder is locked, right-click on the folder and select Right to Modify.
2. Right-click on the selection and select Edit Template.
A new Harmony application opens.
3. Edit the template.
4. From the top menu, select File > Save.
5. In the top menu, select File > Quit (Windows/Linux) or Harmony Premium > Quit (macOS).
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Importing Templates
There are several ways you can import templates in your scene.
For greater control over how the action template behaves when brought into the Timeline view, you can use
the Paste Special feature—see Using Paste Special on page 1723.
NOTE
Dragging a template into your scene copies the content in your Timeline and does not link it to the
original. You can modify this individual copy at any time.

How to import a template into the Timeline or Camera view
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If
you drop a template in the layers list in the Timeline view, it will be inserted between the layers
where you dropped it.
If your template has the same layer structure as a part of your scene, you can drop the template
directly onto the frames on the right side of the Timeline view. Instead of inserting new layers into
your scene, this will replace the drawings and keyframes in your scene with the ones from the
template. This is useful for importing pose or animation templates for characters that are already in
your scene.
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How to import a template into the Node view
1. In the Library view, select the template or symbol you want to import.
2. Drag the selected template to the Node or Camera view or the left side of the Timeline view.
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3. In the Node view, connect your template to your scene's Composite node. To do this, click its outport and drag the connection to the Composite node until an in-port appears.

How to import a template with symbols
1. From the right side of the Library view, select the action template that contains symbols.
2. Hold down Alt as you drag it from the Library view to the right side of the Timeline view and drop it
next to a template with the exact same rig.
The Paste Special window opens.

3. Select the Advanced tab.
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4. Select one of the following options from the Symbols menu:

l

Copy symbols if they do not exist: This is the default setting for this operation and will
prevent symbols in an action template from being copied.

l

Duplicate symbols: Makes copies of the symbols in your template.

1704

Chapter 20: Library

Opening Templates as Folders
Since a template is like a scene, you can open the template's folder and select elements inside it such as
drawings.
Instead of importing the entire contents of a template, you may only want to import a few drawings or a
palette. In this case, use the Open As Folder command to import the items you want.
If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

How to open a template as a folder
1. In the Library view, select the folder that contains the template to open. If the library folder is locked,
right-click on the folder and select Right to Modify.
2. Right-click on the selection and select Open As Folder.
3. In the library list section, click on the template's folder to display its content.

4. Drag the content to the Timeline or Colour view.
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About Symbols
A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name to move up the chain.
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Creating Symbols
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can
also create symbols out of each body part in your cut-out puppets.
To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library
into your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.

How to create a symbol from the Timeline view
1. In the Timeline view, select the layer or cells from which your want to create a symbol.
2. Do one of the following:
‣

From the top menu, select Edit > Create Symbol.

‣

In the Edit toolbar, click the Create Symbol

‣

Press F8.

‣

Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens
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3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.
The new symbol appears in the Library view's Symbol folder. The current selection is not replaced
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to
use it.

How to create a symbol from the Node view
1. In the Node view, select the nodes from which you want to create a symbol.
2. Do one of the following:
‣

From the top menu, select Edit > Create Symbol.

‣

In the Edit toolbar, click the Create Symbol

‣

Press F8.

‣

Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (macOS) your

button.

selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens.
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3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.
The new symbol appears in the Library view's Symbol folder. The current selection is not replaced
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to
use it.
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Creating a Symbol from a Drawing
You can create a symbol from a drawing selection.

How to create a symbol from a drawing selection
1. In the Tools toolbar, select the Select

or Cutter

tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.
‣

Clicking the Create Symbol

button in the Edit toolbar will create a symbol from the entire

layer.
The Create Symbol from Drawing Selection dialog box opens.

4. In the Symbol Name field, type the name of the symbol.
‣

You can also select an existing layer from the Symbol Name drop-down menu. It will add your
symbol on the layer's current cell. If there is already an exposure on that cell, the symbol will be
added to a new layer.

5. You can choose to place the current selected artwork in the drawing or remove it:
‣

To remove currently selected artwork from the drawing and place it in the new symbol, select
the Cut Artwork From Source Drawing option.

‣

To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut
Artwork From Source Drawing option.
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6. Click OK.
The new symbol appears in the Library view's symbol folder and in the Timeline view as a new
layer.
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Creating Empty Symbols
You can create a symbol without any artwork in it.

How to create an empty symbol
1. In the Library view, select the Symbol folder.
2. Do one of the following:
l

In the Library view's right side, right-click and select New Symbol.

l

From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top
button in the Camera view.
To rename a symbol once it is created, right-click on the symbol and select Rename.
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Deleting Symbols
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve
the data. The symbol cannot be retrieved once you close the application.

How to delete a symbol
1. In the Library view, select the symbol to delete.
2. Right-click and select Delete or press Del.
‣

If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the
symbol from the library and scene.
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Editing Symbols
You can either edit a symbol from the Timeline view or from the Library view.
When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located
in the position where they were created. The pivot is translated at the centre of the symbol.

How to edit a symbol from the Timeline view
1. Do one of the following:
‣

In the Timeline view, double-click on the symbol's cell to edit the symbol.

‣

In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘ + E
(macOS)).

‣

Click the Edit Selected Symbol

button in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

2. Do one of the following:
To return to the project's timeline, click the Top

button in the Camera view's top-left corner, press Ctrl

+ Shift + E (Windows/Linux) or ⌘ + Shift + E (macOS).
‣

In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.
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How to edit a symbol from the Library view
1. In the Library view, select the symbol to edit.
2. Right-click and select Edit > Edit Symbol or double-click on the symbol.
You are now inside the symbol and you are able to edit it.

To return to the project's timeline, click the Top

button in the Camera view's top-left corner, press Ctrl

+ Shift + E (Windows/Linux) or ⌘ + Shift + E (macOS).

How to edit your symbol in the Node view
1. In the Node view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or ⌘ + E
(macOS) to use the Edit Selected Symbol command.

2. In the Node view, inside the Symbol’s top node is the composition of your symbol. In this example, a
group node was turned into a symbol.
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3. In the Camera view, edit your symbol.
4. In the Node view’s top-left corner, click the Top

button to return to the top node. Or press Ctrl +

Shift + E (Windows/Linux) or ⌘ + Shift + E (macOS) to use the Leave Current Symbol command.
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Importing Symbols
There are several ways you can import symbols in your scene.
When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library.
If you import a symbol into your scene several times in the Timeline view, they will all be linked to the original
symbol. If you modify one, they will all be modified.

How to import a symbol in the Timeline view
1. In the Library view, select the symbol you want to import.
2. Drag the selected symbol to one of the following:
‣

The Timeline view's left side to import it into the centre of the camera frame.

‣

The Camera view to place it at the location where you release your cursor.
NOTE
This may be useful if you saved a character's body parts as separate symbols. If you dropped
them into the Timeline view, then they would all appear in the centre, haphazardly one on top
of the other. It would be more efficient to arrange them into their correct places as you bring
them into the scene.
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Expanding Symbols
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root
timeline. The symbol's layers will be parented to it in case you created motions and transformations on the
drawing layer that contains the symbol. Breaking the hierarchy could result in the loss of any scaling and
animation you may have created.
You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to expand a symbol
1. In the Timeline view, select the symbol to expand.

2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group
1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

2. From the top menu, select Edit > Expand Selected Symbol in a Group.
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3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the
Expand Arrow to enter the group.
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Converting Symbols to Templates
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content
in another scene, you must create a template. This conversion breaks the drawing's link with both the original
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to convert a symbol into a template
1. From the Library view, select the symbol to convert into a template and drag it to the Camera or
Timeline view. If you drop your symbol into the Camera view instead of the Timeline view, it will not
be placed in the centre of your camera frame, but rather wherever your cursor drops it within the
camera frame.

2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to
any other library folder. Make sure you have the right to modify the library folder.
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3. In the Rename dialog box, rename the new template.

4. Click OK.

1721

Harmony 15.0 Premium User Guide

Importing Files in the Library
Harmony lets you import sound files and images directly through the Library view. Simply open the folder
containing your files in the Library view and drag them directly from there.

How to open a file through the Library
1. In the Library view menu, select Folders > Open Library.
2. Browse for the folder containing the files you want to import.
3. Click Open.
4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You
can choose to import only the keyframes without the drawings or import only the drawings that are not
already in your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a
symbol in your scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left side,
all the frames will be exposed. However, if you import it into an existing layer, you can use the Paste Special
dialog box to adjust the import behaviour to fit your requirements.Once you set the parameters, Harmony will
reuse them each time you import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box
1. In the Library view, select the symbol or template to import.
2. Do one of the following:
l

While holding down the Alt key, click and drag on the template, then drop it on the Timeline
view, over the layer and at the frame where you want to paste it.

l

Press Ctrl + C (Windows/Linux) or ⌘ + C (macOS). Then, in the Timeline view, click on the
frame where you want to paste the template and press Ctrl + B (Windows/Linux) or ⌘ + B
(macOS)

The Paste Special dialog box opens.
3. In the Paste Special dialog box, select the desired parameters—see the Paste Special Dialog Box
topic of the Reference guide .
4. Click OK.
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Chapter 21: Gaming
Harmony can be used to create and animate characters that can be imported in Unity. The procedure is very
similar to rigging and animating characters for a regular animated production, and requires no programming
skills. However, you must follow some guidelines when creating and animating your character to make sure it is
properly imported in Unity.

The procedure for creating game assets in Harmony can be broken down into the following steps.
l

Rig and animate your characters in Harmony, while following the guidelines for rigging and animating
game characters in this guide.

l

Separate your character's different animation clips.

l

Create anchors and props for your character, if needed.

l

Export the character from Harmony into a sprite sheet format that can be imported in Unity.

l

Import the exported data into Unity.
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Rigging Guidelines
The following section explains how to create game assets in Harmony. You should go over this section before
you start creating your character rigs, as it not only contains useful guidelines and tips for rigging game
characters in Harmony, it also contains important information on what you can and cannot do when using
Harmony to rig and animate game characters.

1726

Chapter 21: Gaming

Exporting Rigged Sprite Sheets or Rendered Sprite Sheets
When creating game assets in Harmony, the first decision you should take is which type of export you intend to
make:
l

Rigged Sprite Sheets is where you export a sprite sheet with one sprite for each layer in your character
along with metadata allowing Unity to build and animate your character using those sprites. This is the
traditional way of exporting sprite sheets, and most other Harmony features related to gaming are
optimized for it.
NOTE
In Harmony, this is simply referred to as exporting sprite sheets.

l

Rendered Sprite Sheets is when you export a sprite sheet with one sprite representing your entire
character, rendered and flattened, for each animation frame in your scene. This means that Unity does
not have to reproduce the way Harmony renders your character, as it is already rendered. This method
creates significantly heavier packages, does not work with some other gaming features in Harmony and
is harder to import in Unity, but it ensures that what you see in Harmony is also what you will see in your
game.
NOTE
In Harmony, this is referred to as exporting to Easel JS.
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The following table offers a detailed comparison of all the advantages and limitations of between the traditional
method of exporting sprite sheets versus exporting to Easel JS:
Advantages

l

Disadvantages

Significantly lighter packages.
l

l

Rigged
Sprite
Sheets

l

l

Allows you to easily import the assets
in Unity using the Harmony Game
SDK package.

l

Rendered
Sprite
Sheets
(Easel JS)

Does not support Curve or Envelope deformations,
except if baked into frame-by-frame animations.
Does not support Morphing, except if baked into

Allows you to create props and
anchors in Harmony.

l

Different animation clips can be
separated by scene versions or can be
separated with scene markers,
whichever is preferred.

l

Does not support any effect except for the Cutter.

l

Using cutters has several limitations.

l

The matte port of drawing layers cannot be used.

frame-by-frame animations.

l

l

Only supports Game Bone-type deformations.

All methods of animating, including
morphing, curve deformations and
envelope deformations are supported.

l

Effects are supported.

l

What you see is what you get.

l

Harder to import in Unity. This format cannot be
imported using the Harmony Game SDK. Developers
must write their own scripts to import the exported
sprite sheets.
Exported sprite sheets are significantly heavier in file
size, which may make it unsuitable for mobile games
due to file-size and bandwidth limitations.

l

l
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Scene Set-Up Guidelines
The following are guidelines you must follow when creating and setting up scenes in which you intend to create
game assets for Unity.
Scenes

Resolution

You must create one scene for each character. A scene can contain all of a character's different
animations and props, but should not contain several characters that need to act independently from
each other.
Your scene's resolution should be square, meaning its width and height should be equal. For
example, 1024 x 1024 is a proper scene resolution for a game object.
It is highly recommended to use a power of two for the dimensions of your scene, such as 64, 128,
256, 512, 1024, etc. This is because graphics cards naturally handle textures with such dimensions.
While recent video cards will adjust to non-standard texture sizes, which might cause some
overhead and slow down your game's performance, older video cards might not be able to display
these textures at all.

Node
System

Main Pivot

Make sure you have a Display node at the bottom of your scene's node system. Display nodes are
created by default when creating a new scene, so you should not remove it.

When imported in Unity, the master pivot of your GameObject will be exactly where the centre of
your scene is. Hence, if you want the pivot to be at a specific position on your character in Unity, you
should position your character accordingly in your Harmony scene.
For example, if you want the pivot point of a bipedal character to be between its two feet, at the
centre of its drop shadow, you should position this character so that the point in the middle of its
feet is in the centre of the scene.
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Naming

Do not use non-alphanumerical characters in scene, layer, drawing and group names. Only use
letters, numbers, dashes and underscores. Unity does not support Unicode characters in names.
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Guidelines for Rigging Game Characters in Harmony
The following are guidelines to follow when creating a character rig in Harmony if you plan to export it for use in
Unity.
NOTE
You do not need to follow these guidelines if you intend to export a rendered sprite sheet—see
Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page 1727.

Resources
Usage

When rigging and animating game sprites, you need to keep in mind the size of the exported sprite
sheets as well as the resources required to play out their animations.
If you are working on a console or PC game, you have a lot of leeway for both, as they often have
high performance video cards and a lot of storage space.
If you are working on a mobile game, you might need to take measures to ensure your animation and
sprite sheets are lightweight, as mobile devices have slower rendering hardware and more limited
storage space. Also, some users may want to download your game over a mobile data network with
costly data charges.

Hierarchy

When creating your character rig's structure, you should use a simple peg-layer hierarchy, which
means:
l

Each body part of the character that you want to animate independently is on its own
drawing layer.

l

l

l

Each drawing layer has its own parent peg, which should be used for animating the layer.
Pegs can be rigged in a hierarchy to make body parts attached to each other move together.
For example, a hand's peg can be rigged under the forearm's peg, and the forearm's peg
under the arm's peg, etc.
You can create groups to keep your rig structure tidy and organized.

Body parts that are meant to move together with other body parts (i.e.: the head with the neck, the
forearm with the arm, etc.) can be rigged together in either one of these ways:
l

By rigging the peg of the child part under the peg of the parent part. For example, you could
rig the forearm's parent peg to be the child of the bicep's parent peg. Moving the bicep's peg
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would automatically move the forearm.

l

By rigging both parts under a common peg. For example, you could rig the forearm and the
bicep's parents pegs under a dedicated peg for the whole arm. You could hence move the
bicep's peg independently, or move the arm peg to move both the bicep and the forearm
together.

TIP
Create your rigs in the Timeline view, and not the Node view, to ensure that they have a
simple, tree-like hierarchy.

z-Axis
Positioning

Nudging layers on the z-Axis to change the order in which they appear is supported and its effect
will be visible in Unity. However, you should not attempt to put layers at significant distances from
each other on the z-Axis in Harmony, as they will not be rendered in perspective in Unity.

NOTE
You can make sure the preview of your character in Harmony matches the way it will be
rendered in Unity by setting your scene's Projection setting to Orthographic, which will
make all layers display on a 2D plane in Harmony. You can change this option in the Scene
Settings dialog, by selecting Scene > Scene Settings from the top menu.
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Animation
functions

By default, pegs use 3D Path functions to record their position. It is recommended, but not required,
to configure your pegs to use Separate position functions instead, as 3D Path functions are a bit
heavier on performance. You can make a peg use separate functions by opening its Layer properties,
then selecting Separate under the Position section.

NOTE
Converting a peg or layer's function type to Separate will discard any existing animation on
that peg or layer.

How to make a peg's position functions separate
1. Do one of the following to access the peg's Layer Properties:
l

Open the Layer Properties view, then select the peg layer in the Timeline or Node
view.

l

l

In the Timeline view, double-click on the peg layer, but not inside its name, to
open its Layer Properties dialog.
In the Node view, click on the

Layer Properties button inside the peg node to

open its Layer Properties dialog.
2. In the Transformation tab of the peg's Layer Properties, under Position, select Separate.
Also, you should only animate using Bezier type functions. This is the default type of function
that Harmony creates when you animate a peg or a layer. However, some animators or rig artists may
have the habit of manually configuring their layers and pegs to use Ease functions instead.
Exporting animation that uses Ease type functions to Unity is not supported, so you should not do
that when creating a game asset.
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How to make sure peg's position functions are Bezier functions
1. Do one of the following to access the peg's Layer Properties:
l

l

l

Open the Layer Properties view, then select the peg layer in the Timeline or Node
view.
In the Timeline view, double-click on the peg layer, but not inside its name, to
open its Layer Properties dialog.
In the Node view, click on the

Layer Properties button inside the peg node to

open its Layer Properties dialog.
2. Right of one of the Position functions, click on the

Function button to open its

Function editor.
l

If the title of the dialog is Bezier Editor, then the function is a Bezier function.

l

If the title of the dialog is Ease Editor, click on Close. Then, click on the
button next to the

Menu

Function button and select Create Bezier to create a

Bezier function instead. Repeat for each of the functions in the Transformation
tab.

Effects

Aside from the Cutter, you should not use any effect, as no other effect supported by Harmony can
be exported to Unity.

NOTES
l

l

Bitmap

Symbols
Art Layers

This includes Colour-Override and other simple colour effects. No such effect will
be exported to Unity.
The Cutter effect also has limitations when rigging a character for gaming—see
Guidelines for using the Cutter Effect for Game Assets in Harmony on page 1735.

You can use Toon Boom Bitmap drawings in your character rig. However, original bitmap files
(i.e.: .png or .tga files) are not supported.
The use of symbols is not supported.
Only the artwork in the Line Art and Colour Art layers will be exported to Unity.
By default, those are the only two art layers available. However, if you enabled the Support Overlay
and Underlay Arts preferences, which is available in the Advanced tab of the Preferences dialog,
you can use the Overlay and Underlay Art layers as reference or sketch layers. They will be visible
in Harmony, but they will not be exported in your sprite sheets.
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Guidelines for using the Cutter Effect for Game Assets in Harmony
If you intend to use cutters in a character rig that you plan to import in Unity, you must follow the following
guidelines to ensure your character displays as expected in your game.
NOTE
You do not need to follow these guidelines if you intend to export a rendered sprite sheet—see
Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page 1727.

No Consecutive
Cutters

You can only connect a single cutter under any drawing. If you connect several cutters in
a chain, only one of them will take effect in Unity.

No Using Composites
as Mattes

You can only connect individual drawings to the matte port of a Cutter. You cannot use a
composite or effect as the matte of a Cutter.
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No Using the Drawing
Layer's Matte Port

No Cutting a
Deformed Drawing

Although drawing nodes have their own matte port, you should not use them. You must
use Cutter effects if you want to mask parts of certain layers.

You cannot connect a cutter under a drawing that is under a deformation.
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Guidelines and Tips for Animating Game Assets in Harmony
The following are guidelines to follow when animating a character in Harmony if you intend to export it for use
in Unity.
NOTE
You do not need to follow these guidelines if you intend to export a rendered sprite sheet—see
Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page 1727.

Animation on
Pegs

When animating game sprites in Harmony, you should animate the body parts on their parent
pegs or their deformations, and not on the drawing layers directly, to keep the drawing
information and the animation information separate.

TIP
To facilitate this workflow, you can enable the

Peg Selecton Mode option in the Tool

Properties of the Transform tool. This will ensure that, when you click on a drawing layer in
the Camera view, its parent peg is selected instead. You can also disable animation on your
drawing layers—see Disabling Animation on Drawing Layers on page 829.

Animation
Techniques

It is recommended to use geometrical transformations—done with the
Transform tool or the
Advanced Animation tools—to animate the body parts of your rig as much as
possible, as those are easier for Unity and for graphics cards to render. You should only use
deformations, drawings swaps or frame by frame animation when necessary.

Deformations

If you want to use deformations for your animation, you must use Game Bone deformations.
Game Bone deformations are similar to regular Bone deformations, but have less options and are
designed to render the way Unity would render them—see About Game Bone Deformations on
page 1074.
Unity does not support Harmony's Curve or Envelope deformations. Hence, if you want to use
these to animate your character, you will need to bake the animations made with Curve and
Envelope deformations into frame by frame animations before exporting your sprite sheet. Note
however that this will make the resulting sprite sheet heavier in file size as each frame of these
animations will be exported as a single sprite—see Converting Deformation Animations to
Drawings on page 1138.
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Moprhing
Tool

Exported
Assets

Unity does not support animations made with Harmony's

Morphing tool. Hence, if you want

to use these to animate your character using the Morphing tool, you will need to bake the
animations made with this tool into frame by frame animations. Note however that this will make
the resulting sprite sheet heavier in file size as each frame of these animations will be exported as
a single sprite—see Converting Morphing Animations to Drawings on page 762.
Drawings that are not used by your character or its props will not be exported with the sprite
sheet. Hence, you do not need to delete unused drawings from your scene to optimize the
exported assets.
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Guidelines for Adding Audio to your Game Assets
The Harmony Game SDK supports exporting sound clip from a Harmony scene into a Unity GameObject.
However, there are important limitations to consider if you plan to do this.
No Clipping

If you clip your sound effects in Harmony, they will still be imported as whole in Unity. Hence, you
should edit your sound effects in a sound editing software before importing them in Harmony.
Likewise, if a sound effect extends past the end of the scene, it will not be cut off in Unity. It will
play until the end.

No Splitting

No Volume
Adjustments

If you are separating your animation clips with scene markers, you cannot have a single audio file
play over several scene markers. If you do this, the sound effect will play from beginning to end in
each of the exported clips.

If you adjust the volume envelope of a sound effect in Harmony, these adjustments will not be
exported to Unity.

Importing

Sound effects exported with your Harmony assets will not automatically play with your animations

into Unity

in Unity. The developer must themselves program the logic for playing sound clips.

Because of these limitations, it is highly recommended to only import audio in your Harmony scene and export
them with your sprite sheets when necessary, such as when you need to lip-sync your character's mouth with
their dialogue. Otherwise, it is recommended to add your sound clips in Unity instead.

1740

Chapter 21: Gaming

Creating Multiple Clips for a Game Object in Harmony
A game sprite typically has more than one animation. With Harmony, you can create all of your character's
animation clips in the same scene, provided that you separate them properly.
There are two possible approaches for separating your animation clips. Make sure to read about each carefully
to choose the right one for your pipeline:
Approach

Description

Separating
Clips Using
Scene
Markers

With this approach, you create all of your character's different animation clips in the same scene,
and add scene markers, which are markers that span over a certain part of your scene with a color
and a name, to separate each clip.

Separating
Clips by
Scene
Version

With this approach, you create your rig in the first version of your scene, then save a new scene
version for each animation clip you want to add to your character.

NOTE
Using this method is required if you intend to export a rendered sprite sheet—see

Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page 1727.
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Separating Clips Using Scene Markers
Separating animation clips using scene markers is the recommended method if you intend to export a rigged
sprite sheet. It is convenient as it allows you to create and edit all your animations in the same scene.
NOTE
This method is not supported if you intend to export a fully rendered sprite sheet—see Exporting
Rigged Sprite Sheets or Rendered Sprite Sheets on page 1727
This method consists of creating all of your character's animations in different spans of the scene's timeline.
Then, you mark which animation corresponds to which clip by adding scene markers. Scene markers mark a
range of frames in your scene with a colour and a name. The name you give to a scene marker is the name the
animation clip will have in Unity.
NOTE
To learn how to creating scene markers, see Creating Scene Markers on Frame Ranges on page
612.
When separating your clips with scene markers, keep in mind that:
l

Each scene marker must have a Note. The note will be the name of the clip in Unity. Hence, the note
should be a single line composed only of alphanumerical characters, dashes or underscores.

l

Make sure to add keyframes at the beginning and end of each scene marker, so that your animations are
properly separated when Harmony exports your spritesheet.

l

When you export your sprite sheet, in the Export To Sprite Sheet dialog box, make sure to check the
Use Scene Markers to Export Clips option. Otherwise, your sprite sheet's clips will be separated by
scene version instead.
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NOTE
This option will be checked by default if the scene contains scene markers.
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Separating Clips by Scene Version
This is the legacy method for separating clips in a sprite sheet. It is supported whether you want to export a
rigged or rendered sprite sheet—see Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page
1727.
To separate your clips by scene version, you must proceed like this:
1. First, you create a scene and, in this scene, create the full rig for your character, without animating it.
2. Then, you save a new version of your scene for the first animation clip you want to create. To do this,
select File > Save As New Version from the top menu. Give this scene version the name you want your
clip to have. For example, if you want to create your character's idle animation, you could name this scene
version Idle.
3. In this scene version, create your character's animation. Make sure the animation starts as soon as the
scene begins and that the scene ends as soon as the animation is over.
4. To create another clip, repeat steps 2 and 3 until you have all the clips you need for your character.
In the end, your scene and its versions may have something like this:
Scene

Version

l

Idle

l

Run

l

Jump

l

Shoot

SpaceDuck
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About Anchors and Props
Anchors and props are a feature of Unity allowing you to attach a prop, such as an item or a weapon, to a body
part in your character rig. This is done by creating an anchor on your rig, which is a point that can be moved
and rotated, and to which the prop can be bound. For example, you could make the hand of your character an
anchor, and the weapon the character wields with that hand a prop.

A prop can be enabled and disabled in Unity. Also, a single prop can have several different drawings in it,
which can be switched in Unity at any time. Hence, creating props for your character allows them to carry or
wear different objects and equipment without rendering a sprite sheet of your character for each object.
NOTE
To be able to export your character with anchors and props, you must export your character as a
rigged sprite sheet—see Exporting Rigged Sprite Sheets or Rendered Sprite Sheets on page
1727.
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Creating an Anchor for a Game Character
An anchor is simply a layer that has been marked as an anchor. Creating anchors is required to make props
follow the animation of the layer they are rigged to.
In Unity, an anchor is a point, whereas a layer in Harmony is more like a canvas. Hence, the exact position of the
anchor is based on the position of the layer's pivot point in Harmony. Because of this, it is recommended to
create a layer specifically for the anchor in Harmony, instead of using one of your character's existing layers, so
that you can position its pivot point without affecting your character's animation.
For example, if the character's hand is meant to be an anchor for a weapon prop, the hand's pivot point would
usually be on the wrist to optimize animation, but you'd want the anchor for this hand to be positioned in the
palm. Hence, you could create an empty drawing layer, rigged under the same peg as the hand, make this layer
the anchor, and position its pivot point in the hand's palm.
NOTE
For a layer to work as an anchor, it must have a drawing, because drawings store pivot points.
Hence, if you want an empty layer to be used as an anchor, you must put an empty drawing in it so
that you can set its pivot point.

How to create an anchor
1. If the Game toolbar is not already in your workspace, do one of the following to add it:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

The Game toolbar is added to your workspace.

2. In the Timeline view, scroll to and select the layer for the body part which you want to use as an
anchor.
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3. Create a new drawing layer by doing one of the following:
l

In the toolbar over the layers list, click on

Add Drawing Layer

l

Right-click on the layer and select Insert > Drawing Layer.

l

Press Ctrl + R

4. In the Add Drawing Layer dialog, type in a name for your anchor.
TIP
To make it easier to associate your anchor and its props in Unity, it is recommended to
give your layer a name that indicates which prop it will be attached to. For example, if
you are creating an anchor for a prop layer named Weapon, you could name it Weapon_
anchor.
5. Click on Add and Close.
The anchor layer will be created as a sibling to the body part you previously selected. If you
animated this body part's parent peg, the anchor layer will move at the same time as that body
part.

6. In the Timeline view, select the first frame in the anchor layer.
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7. In the anchor layer, create an empty drawing by doing one of the following:
l

In the Timeline view, right-click on the first frame of the layer and select Drawings > Create
Empty Drawing.

l

In the top menu, select Drawing > Create Empty Drawing.

l

Press Alt + Shift + R.

TIP
If you have Overlay and Underlay Art layers enabled, you can draw a cross hair in the
Overlay or the Underlay art layer where the anchor's pivot is positioned, to help you
keep track of the anchor's position. Artwork in Overlay and Underlay Art layers is not
exported to Unity. You can find the Support Overlay and Underlay Arts preference in
the Advanced tab of the Preferences dialog.

8. Extend the exposure of the empty drawing until the end of your scene by doing one of the
following:
l

In the top menu, select Animation > Cell > Extend Exposure.

l

Press F5.

The Extend Exposure dialog appears.
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9. In the Extend to Frame field of the Extend Exposure dialog, type in the amount of frames in your
scene.
10. Click on OK.
The exposure of the anchor drawing is extended until the end of the scene.

11. In the Timeline view, double-click on the anchor layer (but not on its name) to open its Layer
Properties dialog.
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12. In the Transformation tab, under the Drawing Pivot section, open the Use Embedded Pivots dropdown and select either Don't Use Embedded Pivot or Apply Embedded Pivot.

13. Close the Layer Properties dialog.
14. In the Advanced Animation toolbar, select either the

Translate,

Rotate,

Scale or

Skew

tool.
15. In the Camera view, click and drag on the pivot point

and position it where you want the anchor

to be positioned.

16. In the Game toolbar, click on

Toggle Anchor.

The layer will now be an anchor. Its colour in the Timeline view will be changed to red.

In the Metadata Editor view, its Node Metadata should contain the following entry:
game.isAnchor
You now have an anchor layer for which you can create props.
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Creating Props for Game Characters
A prop is simply a drawing layer that has been marked as a prop. To make sure it follows its anchor's animation,
it must be either rigged as a child or a sibling of the anchor in the rig hierarchy.
A prop can have one or several drawings. All drawings in a prop will be exported with your character, and it
will be possible to switch between the different drawings for your prop in Unity.

How to create a prop
1. If the Game toolbar is not already in your workspace, do one of the following to add it:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

The Game toolbar is added to your workspace.

2. Select the anchor layer to which you want your prop to be attached.

3. Create a new drawing layer by doing one of the following:
l

In the toolbar over the layers list, click on

Add Drawing Layer

l

Right-click on the layer and select Insert > Drawing Layer.

l

Press Ctrl + R

4. In the Add Drawing Layer dialog, type in a name for your prop layer.
5. Click on Add and Close.
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The prop layer will be created as a sibling to the anchor layer you previously selected. If you animate
the anchor layer's parent peg, the prop will also move along with it.

TIP
You can also rig the prop to be a child of the anchor layer, like so:

6. In the Timeline view, select the first frame of the prop layer.

7. Create an empty drawing in the prop layer by doing one of the following:
l

In the Timeline view, right-click on the first frame of the layer and select Drawings > Create
Empty Drawing.

l

In the top menu, select Drawing > Create Empty Drawing.

l

Press Alt + Shift + R.

8. In the Advanced Animation toolbar, select either the
tool.
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9. In the Camera view, click and drag on the pivot point

and position it where you want the anchor

to be positioned.

10. In the Game toolbar, click on

Toggle Prop.

The layer will now be a prop layer. Its colour in the Timeline view will be changed to green.

In the Metadata Editor view, its Node Metadata will contain the following entry:
game.isProp
You can now start drawing your props in the prop layer.
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TIP
You can create several drawings in a single prop layer. You will get to toggle between those
drawings after attaching the prop to the anchor in Unity.

1754

Chapter 21: Gaming

Adding Metadata Notes to Game Props
You can add metadata notes to props, which will have a name and value. This metadata will be accessible in
Unity. It will be visible in the Inspector view when the prop is selected in the Hierarchy view
You can use this mechanic to add properties to your props in Harmony, then use them in Unity. For example, if a
character has a weapon for a prop, you could add the attack power of that weapon as a metadata note for the
prop.

How to add metadata to a prop
1. If the Metadata Editor view is not in your workspace, do one of the following:
l

In the top-right corner of a view, click the

Add View button and select Metadata Editor.

l

In the top menu, select Windows > Metadata Editor.

2. In the Timeline view, select the prop layer to which you want to add metadata.
The name of the layer appears near the top of the Node Metadata section.

3. In the Node Metadata section, click on the

Add Node Metadata Entry button to create a new

metadata entry.
The Add Metadata dialog box appears.
4. In the Add Metadata dialog box, type in game. followed by the name of the metadata variable you
want to add.

NOTE
For the prop's metadata to be imported in Unity, its name must begin with game
followed by a period.
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5. Do one of the following:
l

Click on the Add button if you want to add more metadata entries.

l

Click on the Add and Close button to add this metadata entry and close the Add Metadata
dialog.

The metadata entries you created as added to the Metadata Editor view, in the Node Metadata
section.

6. In the Metadata Editor view, double-click on the cell right of the name of the new metadata entry, in
the Value column, to edit the entry's value.

7. Type in the value for this metadata entry and press ENTER.
You now created a metadata entry with a name and value for your prop.
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Using the Harmony Game Previewer
If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, you
can use the Harmony Previewer application. You can visualize your characters in the Unity game engine with
no programming required.

To get the latest version of the Harmony Game Previewer, visit our Gaming landing page:
https://www.toonboom.com/games

How to use the previewer on Windows
1. Download the Harmony Game Previewer for Windows:
l

https://docs.toonboom.com/go/download/GamePreviewer-12-2-windows

2. Extract the following to your hard drive:
l

GamePreviewer-[version].exe

l

GamePreviewer-[version]_Data folder

3. Copy your export from Harmony to this folder:
l

GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\

4. Start the Game Previewer application.
5. Select the export you want to preview.

How to use the previewer on macOS
1. Download the Harmony Game Previewer for macOS:
l

https://docs.toonboom.com/go/download/GamePreviewer-12-2-mac
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2. Extract the GamePreviewer-[version].app.
3. Right-click on the GamePreviewer-[version].app and select Show Package Contents.
4. Copy your export from Harmony to this folder:
Contents/Data/StreamingAssets/HarmonyResources/
5. Start the Game Previewer application.
6. Choose the export you want to preview
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About Exporting to Unity
Using the

Export to Sprite Sheet and

Export to Easel JS buttons in the Game toolbar, you can export

your character into a package containing sprite sheets and metadata that can be imported into a game engine.
Specifically, if you use the Export to Sprite Sheet option, your character will be exported as a rigged, animated
skeleton with sprites, in a format that can easily be imported using the Harmony Game SDK package for Unity,
without any scripting required.

If you use the Export to Easel JS option, your character will be exported with each animation frame rendered as
a full body sprite, along with metadata that can be used to import it in Unity. However, you will need to
program the logic for importing the spritesheet into Unity yourself.

TIP
Since both the Export to Sprite Sheet and Export to Easel JS dialogs are scripts, you can modify
them in Harmony's Script Editor view, to make them export in a format that is compatible with your
game engine. Those scripts are named TB_ExportToSpriteSheets.js and TB_
ExportToEaselJS.js, respectively.
Before exporting your character as a spritesheet, ensure that:
l

The current display is set to Display, or if you added other display nodes to your scene, to a display that
shows your entire character rig. If the current display is set to Display All, the exported files will not have
any spritesheet.

l

Your scene is saved. Harmony creates the sprites using the drawing files in your scene folder. Hence, any
unsaved changes will not appear in the exported sprite sheets.

l

The dimensions of your scene are set to a number that is a power of two, such as 512, 1024, 2048, etc.
Graphic cards work with textures the dimensions of which are a power of two.

l

Your character rig is positioned so that the centre of the stage is where you want its pivot point to be.
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l

You respected all the guidelines for rigging and animating game assets—see Rigging Guidelines on
page 1726.
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Installing the Scripts for Exporting Game Sprite Sheets
The scripts that are required for exporting game assets have been significantly updated in Harmony 15.0.5.
Because scripts packaged with Harmony are copied to your user preferences when you first launch Harmony,
but do not get replaced by Harmony when you launch it again, if you have used any version of Harmony
between 15.0.0 and 15.0.4 inclusively, your preferences have the older versions of these scripts, and the
updated scripts will not be copied to your preferences so as to avoid overwriting these older scripts.
Hence, you must update the scripts in your preferences manually in order to be able to export your game assets
from Harmony. To do this, you must copy them from the Harmony installation directory to your preferences.

How to copy the new gaming scripts to your preferences on Windows
1. Open an Explorer window.
2. Navigate to the following location:
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 15.0
Premium\resources\scripts
3. Select the following file:
TB_ExportToSpriteSheets.js
4. Right-click on the selected files and select Copy.
5. In the top menu, select View and check the Hidden items option in the Show/hide section.

6. Navigate to the folder of your user's scripts:
l

If you are using Harmony Stand Alone:
C:\Users\<your username>\AppData\Toon Boom Animation\Toon Boom
Harmony Premium\1500-scripts

l

If you are using Harmony Server:
C:\USA_DB\users\<username>\Harmony Premium\1500-scripts

7. Right-click inside the folder and select Paste.
8. When prompted, confirm that you want to replace the existing files.
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How to copy the new gaming scripts to your preferences on macOS
1. Open a Finder window.
2. Navigate to the following location:
/Applications/Toon Boom Harmony 15.0 Premium/tba/resources/scripts
3. Se,lect the following file:
TB_ExportToSpriteSheets.js
4. Right-click on the selected file and select Copy "TB_ExportToSpriteSheets.js".
5. Navigate to the folder of your user's scripts:
l

If you are using Harmony Stand Alone:
a. While holding the Alt key, in the top menu, select Go > Library.

b. From there, go to Preferences/Toon Boom Animation/Toon Boom Harmony
Premium/1500-scripts.
l

If you are using Harmony Server:
a. In the top menu, select Go > Computer.
b. From there, double-click on the name of your computer's main partition (usually
Macintosh HD), then go to USA_DB/users/<username>/Harmony Premium/1500scripts.

6. Right-click inside the folder and select Paste.
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7. When prompted, confirm that you want to replace the existing files.
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Exporting a Game Character as a Rigged Sprite Sheets
The Export to Sprite Sheets dialog allows you to export your rig into a sprite sheet and its animation into
animation metadata, in a package that can be directly imported into Unity using the Harmony package for
Unity.
If you created the different animation clips in the same scene and separated with scene markers, all you need to
do is open the Export to Sprite Sheet dialog and export your sprite sheet and animations once.
However, if you separated your animation clips by saving them in different scene versions, you will need to start
by exporting the sprite sheet from your base scene, then open each scene version and export their animation
clip one by one.
NOTE
When exporting a sprite sheet, a Display node must be connected under your scene's main
composite, and this display node must be selected as the current display. All scenes are created
with a Display node by default, which is named Display. To make sure it is the current display,
select Scene > Default Display > Display from the top menu. If the current display is set to
Display All, the sprite sheets will not be exported.

How to export sprite sheets for a character with clips separated by scene markers
1. If the Game toolbar is not already in your workspace, do one of the following to add it:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

The Game toolbar is added to your workspace.

2. In the Display toolbar, make sure your scene's main display (typically named Display) is selected, and
not Display All.
3. In the Game toolbar, click on the

Export to Sprite Sheets button.

The Export to Sprite Sheets dialog appears.
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4. Right of the Asset Path field, click on the ... button.
A folder select dialog opens.
5. Browse to and select the directory in which you want to create your asset directory.
NOTE
You do not need to create a directory specifically for your exported assets. One will be
created with the name in the Asset Name field.
6. In the Asset Name field, type in the name of the directory in which to export your assets. This will
also be the name of the GameObject in Unity.
7. Under Existing Clips, make sure the Use Scene Markers to Export Clips option is checked.
8. Select the Sprite Resolutions tab.
This tab contains a list of all the resolutions in which your sprite sheets will be exported.
9. Do the following to export in the resolutions you want your game support:
l

To add a resolution, click on the

Add Resolution button. A row will be added to the list.

Double-click on each field in the new row to type in its name, its width and its height, in that
order from left to right.
l

To remove a resolution, select it in the list, then click on the

Remove Resolution button.

10. For most usages, the other default parameters in the dialog should be fine. To learn more about the
parameters in the Export to Sprite Sheet dialog, refer to the Export to Sprite Sheet Dialog Box topic
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of the Reference guide.
11. Click on Export.
Harmony will export the sprite sheet for your rig and the animation for all of the clips in your scene.

How to export sprite sheets for a character with clips separated by scene version
1. If the Game toolbar is not already in your workspace, do one of the following to add it:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

The Game toolbar is added to your workspace.

2. Open the base scene version for your character, that is: the scene version in which you built your
character rig.
3. Make sure every drawing used by every scene version of your character is exposed at least once in
this scene version. To do this:
a. Add as many frames to your scene as there are drawings in the layer with the most
drawings.
b. Leave the first frame with the drawings for your character's normal poses.
c. In subsequent frames, expose the other drawings in each layer until every drawing used for
all of your character's animation clips is exposed for at least one frame.
4. In the Display toolbar, make sure your scene's main display (typically named Display) is selected, and
not Display All.
5. In the Game toolbar, click on the

Export to Sprite Sheets button.

The Export to Sprite Sheets dialog appears.
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6. Right of the Asset Path field, click on the ... button.
A folder select dialog opens.
7. Browse to and select the directory in which you want to create your asset directory.
NOTE
You do not need to create a directory specifically for your exported assets. One will be
created with the name in the Asset Name field.
8. In the Asset Name field, type in the name of the directory in which to export your assets. This will
also be the name of the GameObject in Unity.
9. Under Existing Clips, make sure the Use Scene Markers to Export Clips option is unchecked.
10. Select the Sprite Resolutions tab.
This tab contains a list of all the resolutions in which your sprite sheets will be exported.
11. Do the following to export in the resolutions you want your game support:
l

To add a resolution, click on the

Add Resolution button. A row will be added to the list.

Double-click on each field in the new row to type in its name, its width and its height, in that
order from left to right.
l

To remove a resolution, select it in the list, then click on the

Remove Resolution button.

12. For most usages, the other default parameters in the dialog should be fine. To learn more about the
parameters in the Export to Sprite Sheet dialog, refer to the Export to Sprite Sheet Dialog Box topic
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of the Reference guide.
13. Click on Export.
Harmony will export the sprite sheet for your base rig.
14. Open the scene version for the first animation clip for your character.
15. Repeat steps 5 to 14 to export the animation for this scene version. Make sure to export in the exact
same directory in which you exported the sprite sheet for your base rig.
16. Repeat for each scene version containing an animation clip for your character.
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Exporting Game Assets to Easel JS
The Export to Easel JS dialog allows you to export your game character as a sprite sheet, in which each
animation frame in your scene is rendered as an individual sprite.
Since the Export to Easel JS dialog renders each frame in your scene, there will not be any visible difference
between the way your character is rendered by Harmony and how it is rendered in your game engine.
However, the Export to Easel JS dialog has the following important limitations:
l

Contrary to the Export to Sprite Sheet dialog, the Export to Easel JS only outputs a sprite sheet and an
XML document delimiting each sprite in the sheet. Hence, they cannot be imported into Unity using the
Harmony Game SDK package. You must program the logic to import those sprite sheets into your game
engine yourself.

l

The Export to Easel JS dialog does not export anchors and props.

l

To export to Easel JS, you must separate your animation clips using scene versions. The Export
to Easel JS dialog will not export separate animation clips if you have separated them using scene
markers.

l

Fully rendered sprite sheets are much heavier in size than rigged sprite sheets, which is what the Export
to Sprite Sheet dialog exports.

How to export a game character to Easel JS
1. Do the following to add the Game toolbar to your workspace:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

The Game toolbar is added to your workspace.

2. Open the base scene version for your character, that is: the scene version in which you built your
character rig.
3. In the Game toolbar, click on the

Export to Easel JS button.

The Export to Easel JS dialog appears.
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4. Right of the Asset Path field, click on the ... button.
A folder select dialog opens.
5. Browse to and select the directory in which you want to create your asset directory.
NOTE
You do not need to create a directory specifically for your exported assets. One will be
created with the name in the Asset Name field.
6. In the Asset Name field, type in the name of the directory in which to export your assets. This will
also be the name of the GameObject in Unity.
7. In the Display drop-down, select which Display node to render the character from:
l

Unconnected Display will simply render everything visible in the scene.

l

Display is the display node created by default when creating a scene. Typically, it also
displays everything in the scene unless you connected it somewhere else.

l

If you created more Display nodes in your scene, they should be in this list. Selecting any
display node will only render what is visible to that Display node.
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8. In the Sprite Resolutions section, there is a list of all the resolutions in which your sprite sheets will
be exported. Do the following to export in the resolutions you want your game support:
l

To add a resolution, click on the

Add Resolution button. A row will be added to the list.

Double-click on each field in the new row to type in its name, its width and its height, in that
order from left to right.
l

To remove a resolution, select it in the list, then click on the

Remove Resolution button.

9. For most usages, the other default parameters in the dialog should be fine. To learn more about the
parameters in the Export to Sprite Sheet dialog, refer to the Export to Easel JS Dialog Box topic of
the Reference guide.
10. Click on Export.
Harmony will export the sprite sheet for your base rig.
11. Open the scene version for the first animation clip for your character.
12. Repeat steps 3 to 10 to export the animation for this scene version. Make sure to export in the exact
same directory in which you exported the sprite sheet for your base rig.
13. Repeat for each scene version containing an animation clip for your character.
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Converting Exported Game Assets from XML to Binary
Programmers may be interested to note that the XML data exported by Harmony can be converted afterwards
to a more optimized binary data structure. To convert XML to Binary format, use the Xml2Bin utility. This utility
converts the XML data structure generated through the Toon Boom Harmony software to a compressed binary
data structure. This utility is available in the gaming SDK in the following directory:
HarmonySDK/Source/Utils/
This directory contains the following:
l

macosx: Precompiled binary for macOS.

l

win32: Precompiled binary for Windows.

l

Xml2Bin: Xml2Bin sources.

l

Xml2Bin/proj.mac/Xml2Bin.xcodeproj: XCode project formacOS.

l

Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio project for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you want to
integrate with other game engines.
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About Working in Unity
The following section details how to import a character which you have created in Harmony and exported
using the Export to Sprite Sheet dialog into a Unity project. Once your character is imported, you will also learn
how to preview the clips and the props you created in Harmony in Unity, if applicable.
NOTES
l

The following section does not explain how to import a package exported using the Export
to Easel JS dialog, as this dialog only exports a basic sprite sheet.

l

The following section does not explain how to create a game in Unity. It only explains how to
import and preview assets created in Harmony.

l

No coding skills are required to follow the methods in this section
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About the Sample Unity Project
Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported
from Harmony. Inside this project is an Assets folder which contains the following folders:
l

Plugins

l

Scenes (demo scenes and a previewer)

l

Scripts (all Harmony scripts)

l

StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder.
This way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder. You can
also manually place exported Harmony data into this location.
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About the Unity Interface
Here are the main components of the Unity interface and their equivalents in Harmony:
Unity

Harmony

Description

Scene view

Perspective view

This is where you set the scene, selecting and positioning
environments, the player, the camera, enemies, and all other
GameObjects.

Game view

Camera view

The rendered view from the camera(s) in your game. It is
representative of the final, published game.

Inspector

Layer Properties

Displays detailed information about the selected
GameObject, including all attached Components and their
properties.

Hierarchy

Layers in Timeline view

Displays the hierarchy of elements in the scene, and lets
you set up parent-child relationships for different game
objects.

Project Browser

---

Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy. To show a Harmony object, you must add a
special component. With the main camera selected, in the Inspector, select Add Component > Scripts >
Harmony Camera.
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Importing Harmony Files into Unity
Once you've finished creating your artwork and cyclable animated character movements in Harmony, it's time
to import them into Unity for game integration.

How to import Harmony files directly into Unity
1. Create a Unity 2D project.
2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought
in. Do one of the following:
l

Go to the Unity Asset Store (https://docs.toonboom.com/go/download/UnityPackage) and
save the Harmony Game SDK file on your computer. Then import it in your project from the
following: Top Menu > Asset > Import Package > Custom Package.

l

Search for the Harmony Game SDK in the Unity Asset Store, then download and import the
package. You can access the Asset Store from the following: Top Menu > Window > Asset
Store.
NOTE
For each new Unity project, you must repeat step 2 as it contains the necessary files and
folders to make the Harmony import process work.

3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >
l

Harmony Object: Lets you browse for the exported Harmony project folder. If
you’ve already saved this to your StreamingAssets folder, you can browse to it
through there. Then it adds the Harmony scene to your Unity file, and sets up
the rendering, audio, and animation scripts you need to get going.

l

Harmony Texture Object: Lets you browse for the exported Harmony project
folder similarly to Harmony Object, but creates a Unity plane to render your
animation on it.
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About Game Objects
GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically
everything you create in Unity will be a GameObject. There are two main types of GameObject you can use to
import Harmony data:
l

Create Empty

l

Create Other > Plane

To understand the process fully, there are two examples using an empty GameObject and a plane GameObject
with the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your
Harmony data.
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Using Empty Game Objects
An Empty Game object is a regular GameObject in which you can load the exported Harmony data. All the
individual body parts on the sprite sheet come in as separate elements, but are treated as one whole object
with a dynamically created bounding box. If you put a transparency on this object, you would see the
overlapping transparencies of all the individual objects. This creates a higher-quality render and should be the
default if you’re not animating the transparency of an object. With this option, direct rendering will read the
depth information in the scene but not write it. Note that with this option, the rendering cannot be customized.

How to use an empty GameObject
1. Select GameObject > Create Empty.
2. Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo
file, rename the GameObject to SpaceCat by doing one of the following:
l

Double-click on the name and rename it in the Hierarchy.

l

Select the GameObject and rename it in the Inspector.

3. At this point, it’s an empty object. Accessing Harmony data is done through scripts.
l

Select the SpaceCat GameObject.

l

In the Inspector, go to Add Component > Scripts > Harmony Renderer.

A new section appears in the Inspector called Harmony Renderer (Script).
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This will let you load an animation file. You must put the path of the asset relative to the
HarmonyResources folder. Before this, you must export from Harmony directly to this folder, or
manually copy and paste the data here.
4. You exported a scene called SpaceCat. In the Project Folder, place HarmonyResources/SpaceCat
under the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z
because the default Harmony project is for an HD screen.
5. You won’t see anything until you define a few parameters:
l

Set the Clip Name Size to 1. A second field will appear, Element 0.

l

Enter the clip name for the animation you want to load.

6. Double-check on the right Clip Name to put in Element 0; you can check the output you exported
from Harmony.
7. Double-check the stage.xml file, which was exported to the folder you specified when exporting
from Harmony. Our default export path is to StreamingAssets, so it will automatically load in the
game engine.
8. Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName].
You’ll find the data that was exported. In this case, we’re looking for SpaceCat. Select the file
marked stage to load the data you want to double-check.
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The text data appears in the Inspector.

The name to use for loading the object is the stage name. In this case, SpaceDuck_SpaceCatIdle.
9. If your GameObject has animation in it, and you want it to load the animation data from the
Harmony export, add one more component by doing the following:
l

Select the GameObject.

l

In the Inspector, select Add Component and select Scripts > Harmony Animation.

10. To loop the animation, you must set a GameObject to define it:
l

Select GameObject > Create Empty and rename it: LoopAll.

l

Click the LoopAll GameObject to display its properties in the Inspector.

l

Click Add Component > Scripts > Loop All.

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on
all GameObjects on runtime and asks them to loop, which is useful when testing the animation.
When programming the actual game, you should write additional scripts to control the different
elements separately.
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Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is
predefined by the anchor.
A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and
easily swappable from within Harmony or Unity.

How to attach the prop to an anchor
1. Open up your character in the Hierarchy view to have access to both the props and the anchors.
2. Click on the prop you wish to attach, and drag it onto the appropriate anchor.

3. Repeat these steps for each prop and anchor in your project.
4. In the Inspector view, under Frame, you can select which frame you wish to show. If you only had
one drawing in your prop, then you will not have multiple options.
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5. If part of your character is cut off by the plane of the character, now that the props are showing, you
will need to regenerate the mesh. To do so, select your GameObject. After this is done, go to
Inspector View > Render > Generate Mesh.
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Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is
predefined by the anchor.
A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and
easily swappable from within Harmony or Unity.

How to attach the prop to an anchor
1. In the Hierarchy view, click on the right-pointing arrow left of your GameObject to expand its
content and see its Props and Anchors hierarchies.

2. Expand both the Props and Anchors hierarchies to view your character's list of props and anchors.

3. Select a prop, then drag and drop it over the anchor you want to attach it to. It should end up being
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a child of the anchor.

4. Select the prop in the Hierarchy view to view its properties in the Inspector view.

Each prop has a Frame property. The prop has one frame for each drawing that was in the prop's
drawing layer in Harmony. Its default value, 0, makes the prop invisible.
5. Select the Frame field.
6. Type in the index of the drawing you want to display in the prop object. For example, if your prop
only had one drawing in Harmony, type 1 to display it. If your prop had 5 drawings, type a number
between 1 and 5 to display one of those drawings in the prop object.

The selected prop frame will display in the Scene view, attached to its anchor.
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Troubleshooting
Unity Questions
Q. My Harmony asset does not appear in the Unity Editor.
A. There are several possible reasons for this. Check the following:
l

Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory? The plugin
is named HarmonyRenderer.bundle on macOS and HarmonyRenderer.dll on
Windows.

l

Is the clip name valid ? Make sure the clip name exists in the stage.xml file.

l

Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a
newer version, make sure to regenerate the binary files if you use them so they’re
compatible with the SDK.

Q. My Harmony asset does not appear in iOS or Android when exported from Unity.
A. There are several possible reasons for this. Check the following:
l

Make sure the Harmony assets are copied in the StreamingAssets directory. Since the
HarmonyRenderer plugin cannot use Unity’s asset database, the Harmony assets were
packaged as plain files so they are accessible to the plugin.

l

Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is in
the Assets/Plugins/iOS directory.

l

Is the clip name spelled correctly? Windows and macOS aren’t usually case sensitive file
systems, but iOS and Android are. This implies that an asset that is visible on the editor
will not appear on the mobile platform because it cannot be found.

l

Make sure the size of your sprite sheets does not exceed the hardware limit of the device
you're working on. Otherwise, the texture might not appear at all.

l

Is the path to the project folder an absolute path? If it is, it might not work on the mobile
device as that path will not exist on the platform. Make sure to use relative paths to the
StreamingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always
appear behind the Harmony assets even if I change the order index in the GameObjects.
A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are,
however, several solutions for working around this problem:
Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite
like the other 3D elements in the scene and you can change the compositing order by incrementing or
decrementing the Z value of the transform.
Use multiple cameras to render your scene in parts. Here’s how:
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Harmony Camera
1. Create a new camera.
2. Make sure you set the Harmony GameObjects to a specific layer (top-right of the game object inspector).
3. In the camera, set the culling mask to this layer (and the other layers you want rendered in the
background).
4. Add the HarmonyCamera component to this camera so the Harmony GameObjects render properly.
Sprite Camera
1. Create a new camera.
2. Make sure to set the 2D sprite objects to a specific layer.
3. In the camera, set the culling mask to this layer (and the other layers you want rendered in front of the
2D sprites).
4. Make sure to set the clear flags to Depth Only or Don't Clear.
5. Set the depth to be higher than the Harmony camera.
6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to keep
Game Ojects in sync.
Q. How can you specify the frame rate of the animation? My animation does not play at the same frame rate in
Harmony and in the Game Previewer in the Unity Editor.
A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the
HarmonyAnimation component, you can schedule animations at the speed you want.
Example
HarmonyAnimation animation = GetComponent<HarmonyAnimation>();
if (animation != null)
{
animation.PlayAnimation( frameRate, clipName );
}
Q. I cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?
A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer
component in the GameObject, and so cannot be shown directly in the Scene view.
However, you should still be able to preview your assets in the Game view (even when not playing). To help
find and position assets, we also added bounding box shapes rendered in the editor and the Game view.
Q. How is memory management handled in Unity for Harmony assets?
A. Most of the memory extensive algorithms are executed in the C++ plugin. The data structure is maintained
alive as long as a GameObject refers to it. This means you can instantiate as many clones of a character without
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reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject
uses them and a cleanup call is issued once they are destroyed.
Q. The Harmony assets memory does not appear in the Unity profiler. Can we profile the assets memory?
A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a
C++ plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers
such as the one provided with XCode or Visual Studio should allow you to track your application’s memory
including the Harmony assets and should also provide a more accurate result.

General Questions
Q. How can you specify the resolution used for the drawings in the sprite sheet?
A. The drawing resolution is not fixed in Harmony. Since you're exporting the scene to multiple sprite sheets in
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to
see the resolution of a drawing compared to the rest of the scene. By enabling the light table in the Drawing
view, you will see all of the scene’s drawings untransformed in the same proportion as they will appear in the
sprite sheet. More specifically, the resolution used in the sprite sheet for a drawing is the size it appears
untransformed in the Camera view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export
Sprite Sheet dialog box).
Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a
drawing and use the Transform tool to scale it back up so it does not change visually in the Camera view. This
should allow you to alter the size of drawings in the sprite sheet.
Q. The assets take time to load on mobile devices. Is there any way to speed up the process?
A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines.
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project.
At some point, they should be converted to a binary compact data structure that can be read into memory a lot
faster than the XML.
You can use the Xml2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool
is in the Utils/Xml2Bin folder and a precompiled version for macOS is available in the Utils/macosx
folder.
Q. There are problems with the character I exported in the game engine. Pieces are not exported or are not
showing in the proper order. What can I do ?
A. To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are
some of the key points for building a character that is compatible with the rendering in the game engine SDK:
l

Build your rig in the Timeline view. The game engine SDK data structure is similar to what is displayed in
the Timeline view and an advanced node system might not always export properly.

l

Because every top level node in your scene will render separately in the game engine SDK, they may not
intersect. A top level node is also isolated in its separate sprite sheet to allow the artist better memory
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segmentation of the character. If you created a character with top level nodes and this was not the
intended result, create a top level group or peg to group them all together.
l

Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its parent (as it
does in Harmony). To change the ordering, add some Z offset to the child layer.

l

The export script does not handle plain bitmap images. Toon Boom vector drawings and Toon Boom
bitmap drawings are supported though.

l

The export script does not handle symbols.

1790

