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Reference

Reference
Harmony has several commands, dialog boxes, and buttons. The Reference section lists all of them along with
the matching definition. To understand how to use these functions in a production context, read the User
guide.
In the Reference guide, you will learn about the various parameters available in dialog boxes, menus, nodes,
toolbars, views, and windows.
The Preferences guide provides additional details about each individual preference.
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Chapter 1: Dialog Boxes
Dialog boxes contain controls such as options and lists through which you can carry out a particular command
or task. For example, in the Scene Settings dialog box, you must indicate the resolution and alignment. A typical
dialog box looks as follows:
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Add Column Dialog Box
The Add Column dialog box lets you add a column in the Xsheet view.
By default, when you create a new scene, there is one drawing column in the Xsheet view and one
corresponding drawing layer in the Timeline view.
You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in the
Timeline view.

How to access the Add Column dialog box
1. Do one of the following:
l

In the Xsheet menu, select Columns > Add Columns.

l

Click the Add Columns

l

Press Shift + C.

button.

Parameter

Description

Name

Lets you give the new column a meaningful name.

Type

Lets you select a type of column to create. Choices include: Drawing, Timing,
Sound, 3D Path, 3D Rotation, Bezier Curve, Ease Curve, Expression and
Annotation.

Drawing Layer Options
Line Art

Creates a vector or bitmap drawing column in the Line Art layer.

Colour Art

Creates a vector or bitmap drawing column in the Colour Art layer.

Element
Create New Element

Creates an independent column with its own drawing folder.

Vector

Select this option if you want the layer to contain vector drawings.
Deselect this option if you want the layer to contain bitmap images.
Most of the time, the Vector option will be enabled.
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Bitmap Format

Lets you select the type of bitmap image to insert in the column. Select SCAN
from the list if you are planning to scan drawings using the Toon Boom Harmony
Scan module.

Scan Type

If you chose SCAN from the Bitmap Format list, select the kind of scanning you
want to achieve.

Field Chart

When importing traditional animation, lets you indicate the size of paper on
which the animation or background was drawn. If you are not using perforated
animation paper, leave the 12 field default value as is.

Use Existing Element

Uses drawings from an existing column in the new column. Both columns will be
attached to the same set of drawings, but their timing will remain independent
from one another. If you modify one of the drawings, it will be modified in both
columns. This is the same principle as the Clone column.

Name

Lets you select the column to which you want to link your new column.

Add and Close

Adds the selected type of layers to the Timeline view and corresponding column
in the Xsheet view and closes the dialog box. The names of the layers/columns
are automatically numbered incrementally.

Add

Adds the selected type of layers to the Timeline view and corresponding column
in the Xsheet view. The dialog box remains open for you to add as many
layers/columns as needed. The names of the layers/columns are automatically
numbered incrementally.

Close

Closes the dialog box.
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Add Drawing Layer Dialog Box
The Add Drawing Layer dialog box lets you add a drawing layer to your project.
By default, when you create a new scene, there is one drawing column in the Xsheet view and one
corresponding drawing layer in the Timeline view.
You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in the
Timeline view.

How to access the Add Drawing Layer dialog box
1. Do one of the following:
l

In the Timeline view, click the Add Drawing Layer

l

From the top menu, select Insert > Drawing.

l

Press Ctrl + R (Windows/Linux) or ⌘ + R (macOS).

button.

Parameter

Description

Name

Lets you give the new layer a meaningful name.

Add and Close

Adds the selected type of layers to the Timeline view and corresponding column
in the Xsheet view and closes the dialog box. The names of the layers/columns
are automatically numbered incrementally.

Add

Adds the selected type of layers to the Timeline view and corresponding column
in the Xsheet view. The dialog box remains open for you to add as many
layers/columns as needed. The names of the layers/columns are automatically
numbered incrementally.

Close

Closes the dialog box.
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Create Function Step On Dialog Box
The Create Function Step On dialog box lets you hold the same value over a selected number of frames for
multiple parameters (pos x, scale y, etc.). This works well when you are animating drawings on 2s or 3s, for
example, and you want to hold the same value for a function over those two or three frames.

How to access the Create Function Step On dialog box
1. Add the Scripting toolbar to your interface:
l

Go to the top menu and select Windows > Toolbars > Scripting.

l

right-click on the empty space near the top of the interface and from the quick-access menu
selecting Scripting.

l

right-click on the empty space near the top of a view and from the quick-access menu
selecting Scripting.

2. In the Scripting toolbar, click on the Manage Scripts

button to open the Scripts Manager

window.
3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.
The functions associated with that file appear in the Functions section.
4. In the Functions section, select TB_CreateStepsOn.
The Add script to toolbar

button becomes active.
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5. Click on the Add script to toolbar
The TB_CreateStepsOn script

button.
button is added to the Scripting toolbar.

6. Click Apply.
7. Click OK.
8. In the Timeline view, select the layer whose parameter values you would like to hold.
9. In the Scripting toolbar, click on the TB_CreateStepsOn script
The Create Function Step On dialog box appears.

Parameter

Description

Settings

16
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Every Number of Frames

Enter in the number of frames you would like to hold your functions.

Selection

First Frame

Enter in the frame number of where you would like the stepped holds to
start. The playhead location determines the lowest value you can enter for
the first frame. You need to move the playhead to frame one if you would
like to set frame one as the lowest possible starting value.

Last Frame

Enter in the frame number of where you would like the stepped holds to
stop.
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Create Palette Dialog Box
The Create Palette dialog box allows you to create a colour palette for your scene. Palettes created with this
dialog box are added to your scene's palette list, and stored in your scene's palette-library subdirectory.

How to access the Create Palette dialog box
1. Do one of the following:
l

In the Colour View, click the New Palette

button over the palette list.

l

From the Colour view menu, select Palettes > New

Parameter

Description

New Palette Name

Lets you enter a name for the new palette.
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Export to Easel JS Dialog Box
The Export to Easel JS dialog allows you to export your game character as a sprite sheet, in which each
animation frame in your scene is rendered as an individual sprite.
Since the Export to Easel JS dialog renders each frame in your scene, there will not be any visible difference
between the way your character is rendered by Harmony and how it is rendered in your game engine.
However, the Export to Easel JS dialog has the following important limitations:
l

Contrary to the Export to Sprite Sheet dialog, the Export to Easel JS only outputs a sprite sheet and an
XML document delimiting each sprite in the sheet. Hence, they cannot be imported into Unity using the
Harmony Game SDK package. You must program the logic to import those sprite sheets into your game
engine yourself.

l

The Export to Easel JS dialog does not export anchors and props.

l

Fully rendered sprite sheets are much heavier in size than rigged sprite sheets, which is what the Export
to Sprite Sheet dialog exports.

19

Chapter 1: Dialog Boxes

How to access the Export to Easel JS window
1. Do one of the following:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

2. Click the

Export to Easel JS button.

Parameter

Description

Select Directory
Save Path

The target directory in which to export your sprite sheets.
The name of the folder in which the spritesheet and its metadata will be

Save Name

saved. This folder will be located inside the Save Path folder. If it does not exist, it
will be created. This will also be the name of your asset in Unity.

Existing Clips in Folder

Existing Clips List

If you already exported clips for this character, this will display the list of clips that
already exist in the target directory.

Scene Options
The Display from which to render your character. If the Unconnected_Display
option is selected, all of the visual information in your scene will be rendered.
Display

NOTE
You can only create Displays in Harmony Premium.

Sprite Sheet Preferences
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Max Width

The maximum width, in pixels, of the exported sprite sheets.

Max Height

The maximum height, in pixels, of the exported sprite sheets.

Expand Sprite Sheet

Creates sprite sheets in the smallest possible size to contain all the sprites, up
until it reaches the maximum width and height.

Fixed Sprite Sheet

Creates a texture of the specified size (Max Width and Max Height) even if it does
not fill it up completely by all the drawings in your scene.
Allows you to choose between one of these two resolution types:
l

Resolution Type
l

Reuse Frames

POT: Exports to sprite sheets with sizes that are a power of 2. For
example: 1024 x 1024. This is optimized for many graphics cards, but
consumes more memory.
NPOT: Some game engines are optimized specifically to render to non
powers of two, so that it will avoid those numbers. Example: 1000 x 1000.

This option works in tandem with the Threshold option. The export will compare
the drawings in your project to reuse a maximum of similar drawings and reduce
the amount of information found in the sprite sheet, making it lighter. The export
will omit the creation of new drawings if the difference is less than the threshold
percentage.

Threshold

Calculates the differences between multiple drawings. A 2% threshold will
prevent the creation of a new drawing if the drawing is too similar to an existing
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big,
only 2 of those pixels need to be different from my other drawing in order to
create a new one. The higher the threshold, the fewer similar drawings you will
have.

Sprite Resolutions
Add Resolution

Allows you to add a resolution in which to export your sprite sheets.

Remove Resolution

Removes the selected resolution from the resolutions list.

Resolutions List

The list of resolutions in which the sprite sheet will be exported. The whole sprite
sheet will be rendered once for each resolution in the list.
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Export to Video Dialog Box
The Export to Video dialog box lets you export your animation as a movie file.

How to access the Export to QuickTime Movie dialog box
1. From the top menu, select File > Export > Movie.

Parameter

Description

Output
Choose among the following output formats:
l

l

Video Format

Quick Time Movie (*.mov): Available on Windows, macOS and
GNU/Linux.
Windows Media Video (*.wmv): Available on Windows only.

NOTE
On Windows and macOS, Apple QuickTime must be installed in order
to export QuickTime movies. On GNU/Linux, Harmony uses a more
limited, open source QuickTime-compatible library which does not
require additional software.
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Output file

The full path and file name of the movie file to export.

Browse

Opens a dialog allowing you to browse to the desired export directory and
enter the desired filename.

Export Range
All

Exports all the frames in your scene.

Frames

Lets you specify the frame range to export using the two input fields to the
right. The first input field is for specifying the first frame to export, and the
second one is for specifying the last frame to export. All the frames inbetween, including the ones specified, will be exported.

Resolution
Lets you specify a resolution to export in relative to your scene's actual
resolution:
l

l

Resolution list
l

l

l

Width / Height

Same as Scene Resolution: Exports a movie in the same resolution as
your scene's resolution.
3/4 of Scene Resolution: Exports a movie at 75% of the scene's width
and height.
1/2 of Scene Resolution: Exports a movie at 50% of the scene's width
and height.
1/4 of Scene Resolution: Exports a movie at 25% of the scene's width
and height.
Custom: Lets you specify the preferred resolution of your exported
video file in the Width and Height fields below.

Lets you specify the width and height of video file you wish to export, in
pixels. To preserve your scene's aspect ratio, changing the value of the Width
or Height field will automatically update the other field with a proportional
value.

Options

Movie Options

Opens the movie settings dialog box for your selected video format, in which
you can set the video and audio compression settings for your video file—see
QuickTime Movie Settings Dialog Box and Windows Media Video Settings
Dialog Box.
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Export to Sprite Sheet Dialog Box
The Export to Sprite Sheets dialog allows you to export your rig into a sprite sheet and its animation into
animation metadata, in a package that can be directly imported into Unity using the Harmony package for
Unity.
To export all the clips for your character, you will need to start by exporting the sprite sheet from your base
scene, then open each scene version and export their animation clip one by one.

How to access the Export to Sprite Sheets window
1. Do one of the following:
l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

2. Click the

Export to Sprite Sheets button.
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Parameter

Description

Select Directory
Asset Path

The target directory in which to export your sprite sheets.

Asset Name

The name of the folder in which the spritesheet and its metadata will be
saved. This folder will be located inside the Save Path folder. If it does not exist, it
will be created. This will also be the name of your asset in Unity.

Existing Clips

Existing Clips List

If you already exported clips for this character, this will display the list of clips that
already exist in the target directory.
Uses scene markers to define the export range, instead of exporting the entire
scene.

Use Scene Markers to
Export Clips

NOTE
Scene markers are not supported in Harmony Essentials. They are
supported in Harmony Advanced and Harmony Premium.

Project Settings

Unit Scale

Lets you change the scale when exporting to Unity to accommodate the size of
the export without it affecting the Harmony scene. This helps you resize assets
properly for Unity without having to resize them in Harmony. The basic scale is
one Animation Field for one Unity unit.

Preset

Lets you select the unit conversion from Harmony to Unity, by selecting one of 4
presets. Note: a field is a unit of measure in traditional animation grid.

Sprite Sheet Preferences
Max Width

The maximum width, in pixels, of the exported sprite sheets.

Max Height

The maximum height, in pixels, of the exported sprite sheets.

Expand Sprite Sheet

Creates sprite sheets in the smallest possible size to contain all the sprites, up
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Parameter

Description

until it reaches the maximum width and height.

Fixed Sprite Sheet

Creates a texture of the specified size (Max Width and Max Height) even if it does
not fill it up completely by all the drawings in your scene.
Allows you to choose between one of these two resolution types:
l

Resolution Type
l

Reuse Frames

POT: Exports to sprite sheets with sizes that are a power of 2. For
example: 1024 x 1024. This is optimized for many graphics cards, but
consumes more memory.
NPOT: Some game engines are optimized specifically to render to non
powers of two, so that it will avoid those numbers. Example: 1000 x 1000.

This option works in tandem with the Threshold option. The export will compare
the drawings in your project to reuse a maximum of similar drawings and reduce
the amount of information found in the sprite sheet, making it lighter. The export
will omit the creation of new drawings if the difference is less than the threshold
percentage.
Calculates the differences between multiple drawings. A 2% threshold will

Threshold

prevent the creation of a new drawing if the drawing is too similar to an existing
drawing. For instance, with a 2% threshold, and my drawing is 100 pixels big,
only 2 of those pixels need to be different from my other drawing in order to
create a new one. The higher the threshold, the fewer similar drawings you will
have.

Sprite Resolutions
Add Resolution

Allows you to add a resolution in which to export your sprite sheets.

Remove Resolution

Removes the selected resolution from the resolutions list.

Resolutions List

The list of resolutions in which the sprite sheet will be exported. The whole sprite
sheet will be rendered once for each resolution in the list.

Delete Existing Clips

Select this option to delete clips that you already exported in the export directory.

Bake Animation Curves

Instead of saving your character's animation as interpolations, this bakes them
into frame-by-frame geometric transformations. This can help increase
performance in your game, as your game engine will not have to interpolate your
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Parameter

Description

character's animations on its own. It will however create a heavier package.

Clear Texture Folder

When creating the sprite sheet, Harmony creates temporary files in a folder
named texture inside the scene directory. Check this option to automatically
delete this folder after exporting your sprite sheets.
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Extend Exposure Dialog Box
The Extend Exposure dialog box lets you extend the exposure of a selected cell in the Timeline or Xsheet.

How to access the Extend Exposure dialog box
1. Select a cell and do one of the following:
l

From the top menu, select Animation > Cell > Extend Exposure.

l

Press F5.

The Extend Exposure dialog box opens.

Parameter

Description

Extend to Frame

Lets you enter the frame up to which you want to extend the exposure. You can
expose the drawing in the frames and replace the drawings that were originally
there or move the subsequent frames forward in time.

Overwrite

Lets you expose the drawing in the frames and replace the drawings that were
orginally there.

Insert

Lets you expose the drawing in the frames and move the subsequent frames
forward in the Timeline view.
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Import Images Dialog Box
T-HFND-007-011
The Import Images dialog box lets you import bitmap images and vectorize them, making the images editable.
Then you can use a variety of drawing tools to edit the image. Or you can always keep the original bitmap
image as is.
Also, you can choose to import bitmap images on bitmap or vector layers depending on your project..

How to open the Import Images dialog box
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import >

button.

Images.
The Import Images dialog box opens.

Parameter

Description

Files
Browse

Lets you find and select images on your computer.

Layer
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Create Layers(s)

Create layers for imported images.

Create Single Layer
Named

Creates a new layer with the specified name and imports the images into it.

Create Layer(s) Based
on Filenames

Creates a layer based on each unique filename prefix. For example, if you import
three files named a-1.tga, a-2.tga and b-1.tga, this will create two layers, one
named "a" and one named "b". Layer "a" will contain the two first images and "b"
will contain the third one.

Add to Existing Layer

Imports the images into the specified layer. Note that you can only import into
layers that are compatible with your import options. For example, if you're
importing images as vector drawings, you can only import them into vector
drawing layers.

Vectorization
Vectorize Image

Imports a drawing and converts it to a Toon Boom vector drawing.

Colour

Imports bitmaps as vector objects with their image as a bitmap texture. The
resulting drawing can be drawn or erased over, but not repainted or tweaked.

Black and White

Vectorizes drawings with a solid black line. This creates a 100% vector-based
drawing and paints it with the Vectorized Line colour swatch from your scene's
palette.

Threshold

Determines what values in the scanned image will be considered as part of the
drawing, and what will be ignored and eliminated in the vectorized drawing. The
lower the value, the darker the image and vice versa.

Smooth

Determines how smooth the lines will be. The lower the value, the more detail will
be retained. The higher the value, the more polished and easy to edit the lines will
be.
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QuickTime Movie Settings Dialog Box
The Movie Settings dialog box lets you set the compression settings for the movie you will export.

NOTE
On Windows, Apple QuickTime must be installed to be able to export QuickTime Movie (.mov) files.

How to access the Movie Settings dialog box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to QuickTime Movie (*.mov).
3. Click on the Movie Settings button.

Parameter

Description

Video

Settings

Opens the Standard Video Compression Settings dialog box. This is where you
can set the video compression settings for the movie you will export—see
QuickTime Standard Video Compression Settings Dialog Box on page 56.

Filter

Opens the Choose Video Filter dialog box, where you can select from a range of
filters to apply to your video export.
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Size

Opens the Export Size Settings dialog box. This dialog is available because of the
way the Apple QuickTime interface is designed, but its settings are not taken in
account by Harmony. The size of the exported video is determined by Harmony.

Settings

Opens the Sound Settings dialog box. This is where you can you set the sound
compression settings for the movie you will export—see QuickTime Sound
Settings Dialog Box on page 54.

Sound

If this option is enabled, the video will be optimized to start playing while it is
downloading, as videos do in web browsers and web-based streaming
applications.
l

Prepare for Internet
Streaming

l

l

Fast Start: The video plays as soon as enough data required to start
playback has been downloaded.
Fast Start - Compressed Header: Same as Fast Start, except the header is
compressed for an even faster start. Requires QuickTime 3.0 or later.
Hinted Streaming: Allows you to optimize the movie file for streaming
through QuickTime Server Software. Click on the Settings button to
configure how hints are created in your movie file.
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New Scene Dialog Box
The New Scene window lets you create a new scene.

How to access the New Scene window
1. Do one of the following:
l

From the top menu, select File > New.

l

In the File toolbar, click the New

l

Press Ctrl + N (Windows/Linux) or ⌘ + N (macOS).

button.

The New Scene dialog box opens.

Parameter

Description

Name

Lets you type in a name for the new scene.

Location

Lists the locations you used most frequently for storing scenes.

Browse

Opens a browser in which you can specify a location for the new scene that
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is not listed in the Location list.
Camera Size

Opens a list of resolutions.

+ (Create Custom
Resolution)

Opens the New Resolution window in which you can create a custom
resolution that is added to the Camera Size list.

- (Delete Custom Resolution)

Lets you remove a custom resolution from the Camera Size list.

Width

Indicates the width of the resolution you chose from the Camera Size list.

Frame Rate

Indicates the frame rate of the resolution you chose from the Camera Size
list.
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Paste Preset Dialog Box
When pasting key frames and exposures, you can modify the existing presets to your liking. There are three
presets you can modify: the default presets for both key frames and exposures, key frames only and exposures
only.

Parameter

Description

Drawings
Never create drawing files: When adding exposures to a drawing layer, drawing
files will not be created.

Add/Remove
Exposure

Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will be created only when drawings with the same
name do not already exist in the destination.
Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Enforce Key Exposure

If there are key exposures that exist on copied drawings, they are preserved when
pasting. No key exposures are added. This is the default behavior when pasting.

Fill Gap with
Previous Drawing

Fills selected area in the Xsheet or Timeline view with the previous drawing.

Fill to Next Key

Fills selected area till the next key exposure.
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Exposure
Keyframes
Motion: Copies the properties of the selected motion keyframe to the new frame.
Velocity: Copies the properties of the selected velocity keyframe to the new frame.

Add/Remove
Keyframes

Rotation: Copies the properties of the selected rotation keyframe to the new
frame.
Scale: Copies the properties of the selected scale keyframe to the new frame.
Skew: Copies the properties of the selected skew keyframe to the new frame.
Force Keyframes at Function's Beginning and End: Adds a keyframe to the
beginning and end of the pasted function, reproducing the source function.
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Paste Special Dialog Box
The Paste Special dialog box lets you determine how templates and symbols are imported in the Timeline view.
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You
can choose to import only the keyframes without the drawings or import only the drawings that are not
already in your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a
symbol in your scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left side,
all the frames will be exposed. However, if you import it into an existing layer, you can use the Paste Special
dialog box to adjust the import behaviour to fit your requirements.Once you set the parameters, Harmony will
reuse them each time you import a symbol in the Timeline view’s right side until you set new parameters.

How to access the Paste Special dialog box
1. In the Library view, select the symbol or template to import.
2. Do one of the following:
l

While holding down the Alt key, click and drag on the template, then drop it on the Timeline
view, over the layer and at the frame where you want to paste it.

l

Press Ctrl + C (Windows/Linux) or ⌘ + C (macOS). Then, in the Timeline view, click on the
frame where you want to paste the template and press Ctrl + B (Windows/Linux) or ⌘ + B
(macOS)

The Paste Special dialog box opens.
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Parameter

Description

Drawings
Do Nothing

Does not create or overwrite drawings.
Never create drawing files: When adding exposures to a drawing layer, drawing
files will not be created.
Only create drawing files when they do not exist: When adding exposures to a
drawing layer, new drawings will be created only when drawings with the same
name do not already exist in the destination.

Add/Remove
Exposure

Replace existing drawings. Create drawing files when they do not exist: Replace
drawings with the same names to update a scene with new modified drawings
and preserve the animation.
Tip: If you don't want to lose the existing animation when pasting
a template, such as when placing new drawings after the
animation, then delete the template's animation. It will still have
updated the drawings but not override the existing animation.
Always create drawing files: When adding exposures to a drawing layer, new
drawings will always be created. If drawing files with the same name already
exist, Harmony will create a new name for the drawing.

Symbols
Copy symbols if they
do not exist

This is the default setting for this operation and will prevent Symbols in an Action
template from being copied.

Duplicate symbols

Creates a duplicate of the symbol instead of linking the Symbol instance to the
original one. The new Symbol is created in the Library.

Paste all Frames of
the symbol (full
movie)

When enabled, the Paste Special command exposes all the symbol's frames
instead of only the first one.

Add Remove/Keyframes
Motion

Copies the properties of the selected motion keyframe to the new frame.

38

Harmony 15.0 Essentials Reference Guide

Velocity

Copies the properties of the selected velocity keyframe to the new frame.

Rotation

Copies the properties of the selected rotation keyframe to the new frame.

Scale

Copies the properties of the selected scale keyframe to the new frame.

Skew

Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at
Function's Beginning
and End

Adds a keyframe to the beginning and end of the pasted function, reproducing
the source function.

Cycles
Normal (forward): Pastes your selection as is, starting with the first cell and
ending with the last.
Reverse: Pastes your selection in reverse, starting with the last cell and ending
with the first.
Cycle Type
Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell,
going to the last one and ending with the first cell.
Reverse > Forward: Pastes your selection as a reverse yo-yo, starting with the
last cell, going to the first one and ending with the last cell.
Number of Cycles

Lets you set the number of cycles.
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Preferences Dialog Box
The Preferences dialog box lets you adjust preferences to suit your work style, allowing you to work more
efficiently.
NOTE
To learn more about the individual preferences, refer to the Preferences guide.

NOTE
Some preferences require you to exit and restart the application, or close a view and reopen it.

How to access the Preferences dialog box
Do one of the following:
l

Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences (macOS).

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).
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Recolour Drawings Dialog Box
The Recolour Drawing dialog box allows you to replace all instances of a colour or texture in drawings with a
different colour or texture swatch in one of the scene's palettes. This replaces the colours or textures in the
drawings without requiring you to modify the palettes. You can use this dialog to perform colour replacement in
the current drawing, in all the drawings in one or several layers or in all drawings in your scene.
This dialog will replace the colour or texture that is currently selected in the Colour view with the colour or
texture that you select inside the dialog.

How to access the Recolour Drawings dialog
1. In the Colour view, select the colour or texture swatch you want to replace by doing one of the
following:
l

Select the palette in which the colour or texture swatch is located, then select the swatch you
wish to replace.

l

If the drawing in the Camera or Drawing view contains the colour or texture you want to
replace, select the Dropper

tool in the Tools toolbar, then click on that colour or texture in

the drawing. The Colour view will automatically select that colour or texture's palette as well
as that colour or texture's swatch.
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2. Do one of the following:
l

Right-click on the swatches list, then select Recolour Drawings.

l

Open the Colour view menu

Parameter

, then select Colours > Recolour Drawings.

Description
Allows you to select which drawings will be affected by the colour replacement:
l

l

Replace Colour In

Current drawing: Replaces the selected colour in the currently selected
drawing only.
All drawings in the currently selected layers: Replaces the selected colour
in all the drawings in the layer that is currently selected in the Timelime or
Xsheet view.

NOTE
This option can work with several drawing layers selected.

l

Replacement Colour

All drawings in the scene: Replaces the selected colour in every drawing
in the current scene.

Allows you to select the palette and colour or texture swatch to replace the
selected colour or texture with.
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Scene Settings Dialog Box
The Scene Settings dialog box lets you select settings for the resolution of your scene.
You are already required to select resolution settings when creating a scene, but those settings can also be
modified later using the Scene Settings dialog box.

How to access the Scene Settings dialog box
1. In the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.

Resolution Tab

The resolution tab allows you to set the width and height of your scene in pixels as well as whether the angle of
the field of view.
Icon

Parameter

Description
You can select your project’s resolution (camera frame size) from this
preset list.

Resolution Presets

l

HDTV_1080p24: The standard definition for high definition
television at 24 frames per second, mostly used in the Americas
and some Asian countries that used the NTSC standard for
analogue television.
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l

l

l

l

HDTV_1080p25: The standard definition for high definition
television at 25 frames per second, usually for broadcasting in
European, African, Asian and Australian countries that used the
PAL or SECAM standard for analogue television.
HDTV_720p24: The former standard high definition resolution
at 24 frames per second.
film-2K: A standard HD format for film projectors with a low
aspect ratio.
film-1.33_H: The standard resolution for the academy film
format that conforms to the standard 4:3 aspect ratio.

l

l

l

l

l

l

l

l

l

l

film-1.66_H: The standard resolution for widescreen film format
that conforms to the 16:9 aspect ratio.
film-1.66_V: The standard resolution for widescreen film
format, but with a vertical field of view.
NTSC: The standard resolution and framerate for analogue
standard definition televisions in most of the Americas (except
Brazil, Paraguay, Uruguay and Argentina), Japan, Taiwan, South
Korea, the Philippines and Myanmar.
PAL: The standard resolution and framerate for analogue
standard definition televisions in Europe, Africa, Australia, most
of Asia, Brazil, Uruguay and Argentina.
720p-240p: A series of standard widescreen presets named
after their resolution heights.
low: A resolution based on NTSC with half of its standard
dimensions.
Web_Video: A legacy format for web streaming.
Game_512: A preset for the gaming pipeline, with a square
canvas.
HDTV: The standard definition for high definition television at
24 frames per second, with a horizontal fit field of view.
HDTV_Vertical: The standard definition for high definition
television at 24 frames per second, with a vertical fit field of
view.

Selected Resolution Preset

Displays the name of the selected resolution preset just below the
presets list. If you have made any changes to the resolution since
selecting a preset, this will display "(custom)".

Save Resolution Setting

Allows you to save the current resolution settings as a new preset. If
you have a resolution preset selected, this button is only available if
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you have made changes to the resolution since selecting the preset.
You will be prompted to type in the name of the new resolution preset.

Resolution

The resolution of the scene defines the width and height of the canvas
in pixels. By default, the scene will be rendered in this resolution.

Scene Width

The width of the resolution for the scene, in pixels.

Scene Height

The width of the resolution for the scene, in pixels.

Aspect Ratio

Displays the ratio between the horizontal and vertical dimensions of
the scene. For example, if the scene width and height are the same
value, this ratio equals 1. The standard aspect ratio for widescreen
televisions is 1.777. For legacy displays, it is 1.333.

Frame per second

The amount of frames in your scene that should play out every second.
The standard framerate for film production is 24 fps. However,
televisions in some countries play at 25 fps.
The angle of the field of view, which determines the size of the camera
cone as well as the way the field grid used to position elements is
adjusted to fit the scene.
l

l

Field of View

Horizontal Fit: The field of view is automatically adjusted so
that the field grid and camera cone fit the horizontal length of
the scene.
Vertical Fit: The field of view is automatically adjusted so that
the field grid and camera cone fits the vertical length of the
scene.

NOTE
Objects in Harmony are positioned in fields, based on a
traditional animation grid which extends to 12 fields from the
center in each direction, and which has 4:3 proportions by
default. In a scene with 4:3 proportions, this grid fits the
camera field perfectly. However, since most scenes have an
aspect ratio of 16:9, the grid does not fit the camera field
perfectly. If the field of view is Horizontal Fit, the grid's width
will match the scene's width, but will extend beyond its
vertical edges. If the field of view is Vertical Fit, the grid's
height will match the scene's height, will not extends to its
horizontal edges.
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Scripts Manager Dialog Box
The Scripts Manager dialog allows you to create buttons in the Scripting toolbar. Each button you create can
run a specific function in one of your scripts. You can also choose an icon and a tool tip for the button, if you
want.

NOTE
For tasks related to this dialog box, see the User Guide.

How to access the Scripts Manager Dialog Box
1. In the Scripting toolbar, click on the

Manage Scripts button.

The Scripts Manager dialog box opens.

Parameter

Description

Files

A list of the available JavaScript files.

Functions

A list of the available functions for the selected script.

In Toolbar

The list of script functions already added to the Scripting toolbar.
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Runs the selected function.
Execute

TIP
Press Esc to interrupt the execution of the script.

Customize Icon

Allows you to select an icon for the toolbar button. Clicking on this button will
open an Open dialog prompting you to browse for and select a .png, .jpg, .xpm
or .svg file.

Customize Tooltip

Allows you to type in a custom tooltip for the toolbar button.
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Select Colour Dialog Box
The Select Colour dialog box lets you set the colour of layers and columns. Using colours for layers and columns
helps to differentiate them visually, making them easy to identify.
You can select a colour by choosing from a basic set of colours, using the colour wheel or by specifying the HSV
or RGB values. Once you have selected a colour, you can adjust its intensity and save it as a custom colour that
you can reuse.

How to access the Select Colour dialog box in the Timeline view
1. In the Timeline view, click the Change Track Colour

button of the layer you want to modify.

The Select Colour dialog box opens.

How to access the Select Colour dialog box in the Xsheet view
1. In the Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.
The Select Colour dialog box opens.

Parameter

Description
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Basic colours

A basic set of colours to choose from.

Custom colours

Displays the custom colours you previously stored using the Add to Custom
Colours button.

Add to custom colours

Lets you add the selected colour to the Custom colours list above.

Colour wheel

Lets you select a colour by dragging the T-shaped pointer.

Value slider

Once you select a colour, you can drag the slider to change the intensity and see
it previewed in the Colour Preview window below..

Colour Preview

Displays the colour you are currently selecting. To apply the colour, click OK.

Hue, Saturation, Value

Lets you set the hue (colour), saturation (amount of colour) and brightness
(value) of the colour.

Red, Green, Blue

Lets you set the red, green and blue values.
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Set Ease for Multiple Parameters Dialog Box
The Edit Set Ease for Multiple Parameters dialog box lets you apply ease to multiple functions and keyframes.
You can display the function curve and modify the Bezier or Ease curve.

How to access the Set Ease for Multiple Parameters dialog box
1. In the Timeline view, select a keyframe on one or more layers.

2. Do one of the following:
l

In the Timeline view, right-click and select Set Ease For Multiple Parameters.

l

In the Timeline toolbar, click the Set Ease For Multiple Parameters

button.

The Set Ease For Multiple Parameters dialog box opens.

Parameter

Description

Filters
Motion

Motion: Applies the easing parameters to the selected Position X, Position Y,
Position Z and 3D Path functions.
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Rotation: Applies the easing parameters to the selected Angle functions.
Scale: Applies the easing parameters to the selected Scale functions.
Skew: Applies the easing parameters to the selected Skew functions.
Morphing: Applies the easing parameters to the selected Morphing Velocity
functions. Note that it applies to the Morphing velocity function found in the
Layer Properties window, not the basic morphing ease in the Tool Properties
view.
Other: Applies the easing parameters to all the other the selected functions, such
as all functions created to animate effect parameters.

Left and Right Time Ratio

Lets you type the percentage value corresponding to the length of time you want
the easing to last. Stay between 0% and 100%. If you go beyond 100%, your
motion will overshoot.

Left and Right Value Ratio

Lets you type the percentage value of how strong you want the easing out to be.
Stay between 0% and 100%. If you go beyond 100%, your motion will overshoot.

Apply/Previous

Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

Apply

Applies the easing parameters to the selected keyframes.

Apply/Next

Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

Close

Close the dialog box. If you did not apply the modifications, they will be
cancelled.
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OpenQuickTime Sound Options Dialog Box
The OpenQuickTime Video Options dialog box is used to configure the audio compression settings when
exporting a QuickTime movie file on Linux.

On Windows and macOS, Harmony uses Apple QuickTime to export QuickTime movies, and hence uses
QuickTime's interface to configure video and audio compression settings for exporting movies. Since QuickTime
is not supported on GNU/Linux, Harmony uses the OpenQuickTime library to create QuickTime-compatible
movie files, which have a more limited set of compression settings.

How to access the OpenQuickTime Sound Options dialog box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to QuickTime Movie (*.mov).
3. Click on the Sound Options button.

Parameter

Description
Lets you select a codec. By default, the following codecs will be available:
l

l

Codec
l

l

l

A-Law 2:1: This codec uses logarithms to compress audio data. The
resulting audio stream requires half the disk space of uncompressed audio
data, but is of noticeably lower quality.
IMA 4:1: This codec compresses audio data to require a quarter of the disk
space required for uncompressed audio data. It is not supported by a lot
of software.
Twos Complement - Little Endian PCM: A standard uncompressed audio
codec.
Twos Complement - Big Endian PCM: A legacy standard uncompressed
audio codec. This codec may be compatible with older editing interfaces.
(mu)-Law 2:1: Similarly to A-Law, this codec uses logarithms to compress
audio data. The resulting audio stream requires half the disk space of
uncompressed audio data, but is of noticeably lower quality.
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Sample rate

The sample rate at which to export your scene's audio. The only available option
is 22050Hz.
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QuickTime Sound Settings Dialog Box
The Sound Settings dialog box lets you set the audio compression settings when you want to export a
QuickTime Movie (.mov) file.

NOTE
On Windows, Apple QuickTime must be installed to be able to export QuickTime Movie (.mov) files.

How to access the Sound Settings Dialog Box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to QuickTime Movie (*.mov).
3. Click on the Movie Settings button.
4. In the Movie Setting dialog box that opens, click Settings in the Sound section.

Parameter

Description

Compressor

Lets you select a compression type. The default setting is None. This exports your
audio as is without performing any lossy compression or conversion, preserving
its fidelity. Other compressors can be used if you need your movie's audio track to
be exported in a specific format, or if disk space or download speed is critical, but
they may impact the quality of your movie's soundtrack negatively.

Rate

Lets you select the audio rate at which to export. It is best to export your audio at
a rate that matches the rate of your original sound files. For example, if your file
has an audio sample rate of 48 kHz and you choose a conversion rate of 22.05
kHz, the sound will play at the same speed, but higher frequencies will be
missing, making it sound muffled. For reference, the standard sound quality is 48
kHz for broadcasting and DVD. Lower rates are liable to impact the quality of your
movie's soundtrack negatively, but they can be useful if disk space or download
speed is critical.
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Parameter

Description

Size

Lets you select the encoding size. Also known as Bit Depth, this determines the
amount of precision used to record each wavelength in the soundtrack. The
standard size is 16-bit. If you choose 8-bit, the amount of disk space your sound
track requires is halved, but the audio will sound muffled.
Lets you decide whether to use the Mono or Stereo channel mode. Stereo sound
has a separate sound track for the left and the right speakers, allowing to make

Use

the origin of each sound realistically match the origin of their corresponding
action. If you choose Mono, your sound track may use less disk space, but both
the left and right channels will be merged into a single track.
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QuickTime Standard Video Compression Settings Dialog Box
The Standard Video Compression Settings dialog box lets you configure the video compression settings when
exporting a QuickTime Movie (.mov) file.

NOTE
On Windows, Apple QuickTime must be installed to be able to export QuickTime Movie (.mov) files.

How to access the Standard Video Compression Settings Dialog Box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to QuickTime Movie (*.mov).
3. Click on the Movie Settings button.
4. In the Movie Setting dialog box that opens, click Settings in the Video section.

Parameter

Description

Compression Type

Allows you to select the codec to use for the video stream of your movie file. The
availability of codecs may vary between machines. If you are unsure of which
codec is best fit for you, it is recommended to use H.264 for maximum portability,
and to use Animation if quality is more important.
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Parameter

Description

NOTE
The Animation codec, among a few others, allows you to set the colour
depth to Millions of Colors+, which supports transparency.

Motion

Frame Rate

The amount of frames per second for the video stream. Leave this setting to
Current to use your project's frame rate.
Some codecs compress the video by recording a limited amount of keyframes,
which are frames in which the entire picture is encoded, pixel by pixel and, inbetween, recording deltas, which are frames that are only defined by their
difference with the previous frame. This significantly reduces the size of the
movie file. However, the less keyframes a movie has, the more it is likely to
encounter decoding errors, and the harder it is for players to scrub or jump to a
specific time in the video. This option allows you to decide when keyframes are
inserted in the video stream.
Automatic: Lets the encoder decide when keyframes should be inserted.

Key Frames

Every ... frames: Allows you to set the exact interval, in frames, at which
keyframes should be inserted.
All: Encodes every frame as a keyframe. This option will significantly impact file
size, but will make it easier to scrub through the video without causing any
rendering error.

NOTE
If you are using the H.264 codec, you must set the Key Frames option to

All, or you will get an error message when you confirm the compression
settings.

Frame Reordering

Encodes frames in a different order than the one at which they are meant to be
displayed. This allows for more efficient compression, but may not be compatible
with some players.

Compressor

Depth

Allows you to set the colour depth for your video. A lower colour depth will
reduce the size of the video stream but will have significant impacts on picture
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Parameter

Description

quality.

TIP
Set this to Millions of Colors+ if you want to export a video with
transparency.

Quality

Lets you choose a quality setting for the video compression. A higher quality
setting will increase the size of the movie file, but will look better. A lower quality
setting will reduce the size of the movie file, but will cause blurriness and
compression artifacts to appear in the picture.
Allows you to choose between the following scan modes:
l

l

Scan Mode /
Interlaced

Interlaced: Frames are encoded starting with their odd-numbered
scanlines, then their even-numbered scanlines.
Progressive: Frames are encoded whole, from the highest scanline to the
lowest scanline.

NOTE
Some codecs will display a drop-down allowing you to select Interlaced or
Progressive, while others will simply have an Interlaced checkbox.

Allows you to select one of the following aspect ratios:
Aspect Ratio

Filter

l

4:3: For output on standard definition displays.

l

16:9: For output to widescreen displays.

When exporting with the PNG compression type, this determines the algorithm
with which each pixel is encoded relative to other pixels. Leaving this option to
Best will export in the most space-efficient filter, without compromising picture
quality. Picking a filter may increase rendering speed a bit, at the expense of some
disk space.

Data Rate
Automatic

Lets the encoder use the optimal bit rate for your compression settings.

Restrict To

Allows you to specify the encoding bit rate.
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Parameter

Description

NOTE
This setting will override other compression settings, so that the specified
bit rate is respected.

Optimize the encoding to be responsive depending on the intended viewing
method:
l

Optimized For
l

l

CD/DVD-ROM: Optimizes the bit rate for a video that will be played using
an optical disc player.
Download: Optimizes the bit rate for a file that is going to be downloaded,
then viewed from the user's hard drive.
Streaming: Optimized the bit rate for a video that will be streamed from
the web and played as the video is being downloaded.
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Tint Offset/Blend Dialog Box
You can offset, blend, or mix the colours in a colour palette using the sliders and increasing the Amount value.

How to access the Tint Offset/Blend dialog box
1. From the Colour View menu, select Palettes > Tint Panel or right-click and select Tint Panel.
The Blend/Offset Tint panel opens.

Parameter

Description

Offset

Offsets the selected colours by the adjustments made using the HSB and RGB
sliders. Use the Amount slider to adjust the degree of offset. Use the Alpha slider
to adjust the opacity of the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right corner. Use
the Amount slider to adjust the degree of blend. A blend of 100% turns the
selected colours into the same colour as the swatch. Adjusting the HSB and RGB
sliders affect the swatch colour, which in turn affects the selected colours on the
left. Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use the slider just
beneath to mix the Base and Tint colours by different amounts. This will affect the
mixed swatch whether it is selected or not. Select either the Tint or Base swatch
and use the HSB and RGB sliders to adjust its colour. This will affect the mixed
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swatch colour, which in turn affects the selected colours on the left.
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Toolbar Manager Dialog Box
The Toolbar Manager dialog box lets you customize the toolbar in any of the views. You can add your favourite
tools to a toolbar for an efficient workflow.

How to access the Toolbar Manager dialog box
1. Right-click on a toolbar in any view and select Customize. Note that the menu will not appear if you
right-click on a disabled icon.

Parameter

Description

Available Tools

Displays the complete list of tools available for customizing a toolbar.

Toolbar

Displays a list of the tools currently available on the toolbar.

Default

Restores the toolbar with its default items.
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Vectorization Parameters Dialog Box
The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure
red, blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting
in your tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker
window and watch the indicator colour zone lines disappear.

How to open the Vectorization Parameters dialog box
1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization
parameters (i.e. from the scanner).
2. In the Scan Drawings window, do the following:
l

In the Layer section, decide on the layer options.

l

In the Import Options section, select the Convert to Toon Boom Vector Drawing
option

l

Click Preview.

63

Chapter 1: Dialog Boxes

3. In the Vectorization section, click the Vectorization Parameters

button.

Options Tab
The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter

Description

Input

The input filters are applied to the bitmap image before it is vectorized.

One Pass

One threshold value is applied to both the Line and Colour Art. For drawings with
distinct vector-style lines of mattes, you only need one pass.

Two Passes

Applies a different threshold value to each layer. For greyscale drawings, you may
want to perform the vectorization process twice to apply different threshold
values to the Line and Colour Art layers.

Threshold

Determines which values in the scanned image are considered part of the Line
and Colour Art layer and what will be eliminated from the vectorized drawing; 0%
is white and 100% is black. The threshold is between these two values.

Expand Bitmap

Lets you enter a value to scale the bitmap to detect small variations in the line.
Use this option if you scanned a greyscale image and want to preserve small
variations in the texture to apply to the line art.

Jag Filter

Lets you enter a value to scale back the bitmap to remove some of the line’s
roughness. This is useless when you have a drawing that appears quite rough;
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the Jag filter will eliminate excess strokes in the final drawing.

Line Art Threshold
(%)

Determines which values in the scanned image are considered part of the Line Art
layer and what will be eliminated from the vectorized drawing; 0% is white and
100% is black. The threshold is between these two values.

Colour Art Threshold
(%)

Determines which values in the scanned image are considered part of the Colour
Art layer and what will be eliminated from the vectorized drawing; 0% is white
and 100% is black. The threshold is between these two values.

Output

The output filters are applied during the vectorization process.
No Colour Art

Does not generate filling zones in the Colour Art layer.

No Texture

Does not generate texture in the Line Art layer in the final images. Select this
option to create solid lines in the final line art.

Generate Matte in
Underlay Layer

Creates an opaque zone behind your drawing’s lines to avoid seeing through the
layers.

Colour as Texture

Converts colour values into a texture layer.

Optical Registration

The optical registration options are used to automatically align drawings based
on the position of the peg holes on the animation paper. The peg holes must
appear in the scanned drawings for the optical registration to work.

DPI

Lets you enter the dots-per-inch value of your image. You must enter the same
value as the DPI used to scan the image.

Peg Side

Lets you select the position of the peg holes on your drawings. Identify whether
they are on the top, bottom, left or right.
Determines how exact the location of the peg holes must be for the software to
recognize them. There are two values to choose from:

Strictness

Strict: The peg holes must be in a tightly defined area to be recognized.
Loose: The peg holes can be recognized somewhere in a larger area. This is the
recommended setting.

Field Chart

Lets you indicate the size of the animation paper, 12 or 16.
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Post Processing

The Post Processing filters are applied to the final vector images.

Remove Holes

Removes holes of a specified value that might make painting difficult.

Remove Dirt

Removes stray marks and dirt of a specified value. Try a value around 500.

Remove Hair Size

Removes small strokes that have no line art.

Remove Hair: Number
of Passes

The number of times the drawing will be analyzed to identify hair marks.

Miscellaneous
Close Gaps

Closes gaps in the Colour Art so you can paint it.

Smooth Passes for
Line Art Before
Breaking Triangles

The number of times the smoothing operation runs before creating the triangles
that break lines in the drawing. If unnecessary triangles are appearing in the
drawing, increase this value.

Smooth Passes for

The number of times the smoothing operation is performed after the triangles

Line Art

have been created. This further smooths the line art.

Preview
Show Strokes

Shows the strokes in the Vectorized Image panel.

Stroke Thickness

Shows the size of the strokes.

Help Tab
The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields
at the bottom of the Vectorization Parameters dialog box.
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File IO Options
-file <filename (including extension)> [ options ]
-infile <filename (including extension)>; same as -file
-outfile <filename>; alternate output file
-informat <format>; the input format. Used if reading from stdin
-debug; turn on debug mode
-noforce; don't force output if image is inconsistent
-version; print version information and quit
-output_version <version>; output files of this version. Valid versions can be: 0 or 604
-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options
-register <dpi side strictness>; perform optical registration.
• Side can be one of left, right, top, bottom or l, r, t, b.
• Strictness can be either loose, strict or l, s.
-register_center_peg_holes; will use only round holes in 16 fields page
-rcph; short form of register_center_peg_holes
-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)
-rlf; short form of registration_looseness_factor
-rdebug; output registration debug messages
-pegpitch <inch (default 8.000000)>; distance between peg bars
-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0
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-rmargin <inch (default 1)>; region size where to look for peg bars
-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image
-pdfc; short form of -peg_distance_from_center
-out_peg_position <side (default same)>; wanted position of the peg on the drawing.
• Can be one of right, left, top, bottom (or r, l, t, b) or same.
• A rotation will be performed if it is different from the side passed to -register.
-output_peg_matrix; output the peg transformation matrix on standard output.
-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options
-pixel <pixel_shape (default '4x3')>; Valid values: 4x3
-gap <worldUnits (default 10)>; close gaps up to this big
-pencil; generate line art only
-keep_dirt; don't filter out dirt
-thresh <threshold (default 0.2)>; range 0.0 to 1.0
-rmv_hairs <worldUnits (default 1)> <passes (default 1)>
• remove hairs of size smaller than "size" in "passes" passes
-rmv_holes <area (default 7)>; remove holes smaller than "area"
-rmv_dirt <area (default 1)>; remove dirt smaller than "area"
• try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared
-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"
• distance from each other. Use -no_break to remove all triangles
-no_texture; don't generate textured strokes
-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour
-noclosegap; disable all gap closing algorithms
-no_break; disable the breaking of line art
-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap
-fit_errorc <error (default 1.000000>; fitting error for the colour art
-fit_errorl <error (default 1.000000>; fitting error for the line art
-smoothl <passes (default 1>; number of smooth passes for line art
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-smoothc <passes (default 1>; number of smooth passes for colour art
-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)
-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"
(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,
-rmv_holesc, -rmv_dirtl and -rmv_dirtc)
-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0
-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0
-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-rmv_holesl <area (default 7)>; remove line art holes smaller than "area"
-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area"
-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area"
-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area"
try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in
world units squared
-margins <inch (default 0.25)>; remove margin around bitmap
-top_margin <inch (default 0.25)>; remove margin at top of bitmap
-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap
-left_margin <inch (default 0.25)>; remove margin at left of bitmap
-right_margin <inch (default 0.25)>; remove margin at right of bitmap
-remove_peg_bars; remove the peg bar holes
-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size
-fs; short hand for -field_size
-peg_bar_size <inch (default 1)>; the size of the peg bar region
-noframe; do not put a frame around the colour art
-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
-downscale_input <default 1>; downscale the raw input by this integer factor
69

Chapter 1: Dialog Boxes

-downscale_texture <default 1>; downscale the output texture by this integer factor
-buildmatte; generate a matte on underlay for line test
-buildmatte_colourart; generate a matte on colour art for line test
NOTE
-buildmatte and -buildmatte_colourart are mutually exclusive
-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information
-pixel_margins <inch (default 0)>; remove margin around bitmap
-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap
-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap
-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap
-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap
-dpi <(default -1)>; dpi information of input bitmap

RGB Keying Options
-rgb; generate separate zones for red, green and blue lines
-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value
-no_red; ignore red colour in vectorization
-no_green; ignore green colour in vectorization
-no_blue; ignore blue colour in vectorization
-flatten; flatten the drawing after generating colours
-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area
-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb
-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on
saturation and value to consider a pixel to be grey

Colour Vectorization Options
-color_vectorize; perform a colour vectorization
-file2 <colour art filename>; specify the colour art bitmap
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-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.01.0)> <edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid
filename or "" if no file)>; generate brush texture for the line art
-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation
(0.0-1.0)>; specify a pressure strategy for the centre line.
-blur_radius <pixels (default 0)>; blur the penstyle texture generated
-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before
computing texture
-ccsp <times (default 3)>; short for -color_contour_smooth_passes
-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture
-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)
-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only
-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles
-bubble_length <value (default 10)>; max number of circles in a bubble
-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >=
1.0)
-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be
>= 1.0)
-uniform_gap; the space between bubbles is constant

4 Colour Vectorization
-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:
rgbdiff:value ; between [0.0-1.0] or [0-255]
dark:value ; between [0.0-1.0] or [0-255]
grey:value ; between [0.0-1.0] or [0-255]
white:value ; between [0.0-1.0] or [0-255]
dirt:value ; dirt area. 200 is a good value
rt:value ; between [0.0-1.0] or [0-255]
gt:value ; between [0.0-1.0] or [0-255]
bt:value ; between [0.0-1.0] or [0-255]
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NOTE
There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20
dark:20 grey:120 white:250 dirt:200 rt:240 gt:240 bt:240
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OpenQuickTime Video Options Dialog Box
The OpenQuickTime Video Options dialog box is used to configure the video compression settings when
exporting a QuickTime movie file on Linux.

On Windows and macOS, Harmony uses Apple QuickTime to export QuickTime movies, and hence uses
QuickTime's interface to configure video and audio compression settings for exporting movies. Since QuickTime
is not supported on GNU/Linux, Harmony uses the OpenQuickTime library to create QuickTime-compatible
movie files, which have a more limited set of compression settings.

How to access the OpenQuickTime Video Options dialog box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to QuickTime Movie (*.mov).
3. Click on the Video Options button.

Parameter

Description
Lets you select a codec. By default, the following codecs will be available:
l

l

Codec

l

l

l

Motion-JPEG A: A very portable codec that performs lossy
JPEG compression and interlaces the frames. Motion-JPEG A
compression is less efficient than Photo JPEG in terms of quality and file
size, but may be a more portable alternative for software that does not
support Photo JPEG.
Photo JPEG: Encodes the movie as a sequence of JPEG images. JPEG
images have lossy compression. This is the most efficient codec for file
size.
Portable Network Graphics (PNG): Encodes the movie as a sequence of
PNG images. PNG images have lossless compression.
Tag Image File Format (TIFF): Encodes the movie as a sequence of
uncompressed TIFF images. This codec is lossless.
Uncompressed (RGB): Encodes the movie as uncompressed bitmap data.
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This codec is lossless.

Quality

fieldDominance

For JPEG-type codecs, lets you set the JPEG compression quality. By default, this
will be set to 85. Possible values range from 0 to 100. The higher the quality, the
more disk space the resulting video file will take.
For codecs with interlacing. This is set to 1 by default. If set to 1, the first field will
be encoded on odd frames, and the second field will be encoded on even frames.
If set to 2, the first field will be encoded on even frames, and the second field will
be encoded on odd frames.

compression

The amount of lossless compression to perform when exporting in PNG format.
PNG compression is lossless, but higher compression settings will take longer to
encode and decode.

packbits

For TIFF movies, this option adds extra lossless compression to the encoding.

lendian

Encodes data in little endian byte order, instead of big endian.
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Windows Media Video Settings Dialog Box
The WMV Settings dialog box lets you set the video and audio settings when exporting a Windows Media
Video (.wmv)movie.

NOTE
The option to export to Windows Media Video is only available on Windows.

How to access the WMV Settings dialog box
1. From the top menu, select File > Export > Movie.
The Export Movie dialog box opens.
2. Set Movie Format to Windows Media Video (*.wmv).
3. Click on the Movie Settings button.

Parameter

Description

Video
Variable Bit Rate
Quality

Lets you choose a quality setting ranging from 5 to 100 for the video stream. The
higher the quality of the export, the larger the resulting file.

Sound
Lets you choose among preset combinations of audio sample rates, sample sizes
and channel modes for the audio stream:
l

Profile

Sample rate: Available sample rates are 8000 Hz, 16000 Hz, 22050 Hz
and 44100 Hz. The default setting is 22050 Hz. It is best to export your
audio at a rate that matches the rate of your original sound files. For
example, if your file has an audio sample rate of 48000 Hz and you choose
a sample rate of 22050 Hz, the sound will play at the same speed, but
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higher frequencies will be missing, making it sound muffled. For
reference, the standard sound quality is 44000 kHz for films, and 48000
kHz for DVD. Lower rates are liable to impact the quality of your movie's
soundtrack negatively, but they can be useful if disk space or download
speed is critical.
l

l

Sample size: Also known as Bit Depth, this determines the amount of
precision used to record each wavelength in the soundtrack. The standard
size is 16-bit. If you choose 8-bit, the amount of disk space your sound
track requires is halved, but the audio will sound muffled.
Channel mode: Stereo sound has a separate sound track for the left and
the right speakers, allowing to make the origin of each sound realistically
match the origin of their corresponding action. If you choose Mono, your
sound track may use less disk space, but both the left and right channels
will be merged into a single track.

NOTE
Exporting in 8-bit audio requires Apple QuickTime to be
installed.
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Chapter 2: Menus
The Menus section covers all the menu entries available in Harmony. There are several types of menus in
Harmony: main menus, quick-access menus and view menus. Menus contains most of the functions available.
They may also have a toolbar button or keyboard shortcut equivalent.
Main Menus
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Animation Menu

80

Drawing Menu

85

Edit Menu

90

File Menu

93

Help Menu

96

Insert Menu

97

Play Menu

99

Scene Menu

101

View Menu

103

Windows Menu

107

View Menus

109

Colour View Menu

110

Function View Menu

113

Library View Menu

115

Script Editor View Menu

117
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Main Menus
The main menu contain most of the commands. Depending on the view you're working in and the element,
some commands are available and others not. The main menu is always located at the very top of the interface.

On macOS, there is also a Harmony Essentials category that contains the following commands: Preferences,
About, and Quit.
Animation Menu

80

Drawing Menu

85

Edit Menu

90

File Menu

93

Help Menu

96

Insert Menu

97

Play Menu

99

Scene Menu

101

View Menu

103

Windows Menu

107
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Animation Menu
The Animation menu lets you access tools, adjust animation timing, set and parameters, lock or unlock layers,
and select elements in the Xsheet and Timeline views.

How to access the Animation menu
l

At the top of the interface, select Animation.

Command

Description

Animate

Enables the Animate mode which records the position, rotation, scale,
skew, etc. of objects as keyframes in the Timeline view. Turn off the
Animate mode to reposition objects for the entire scene. When the
Animate mode is disabled, keyframes are not created when an object's
parameters change.

Stop-Motion Keyframe

Sets a stop-motion keyframe which there is no computer-generated
motion between two keyframes. The segment is constant or flat. The
drawing remains still until the playback reaches the next keyframe,
then the drawing pops to its new location.

Delete Keyframe

Deletes the selected keyframes.

Tools

Transform

Allows you to select drawing layers and position, rotate, scale and
skew them.

Translate

Lets you move the selected element along the X and Y axes.

Rotate

Turns a selected element around its pivot point.

Scale

Increases or decreases the size of a selected element. You can scale an
object up to make it larger or down to make it smaller. Press Shift to
scale the element while maintaining its proportions.

Skew

Slants the selected element.

Maintain Size

Keeps elements the same size aspect ratio in the Camera view as you
move them towards or away from the camera.
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Spline Offset

Lets you reposition the visual trajectory without offsetting or
modifying your animation. By default, the trajectory is located at 0,0,0
fields. If your elements were drawn in a different location than the
centre of the drawing area, it will look like the trajectory is not aligned
with your drawing. Also, if you have several elements attached to one
trajectory, you might want your trajectory to be at a different location
to represent the group's motion better.

Increase Exposure

Adds one more exposure to a selected cell; repeating this action adds
an extra cell each time. This is an efficient way to extend a drawing's
exposure and is always set in Insert mode. Increasing an exposure
pushes the existing exposure forward.

Decrease Exposure

Decreases exposure of a selected cell by one; repeating this action
decreases one exposure adds an extra cell each time. This is an
efficient way to shorten a drawing's exposure. Decreasing an exposure
pulls in the existing exposure.

Set Exposure to

Lets you set the exposure to 1, 2, 3 or a custom exposure.

Extend Exposure

Lets you enter the frame up to which you want to extend the exposure.
You can expose the drawing in the frames and replace the drawings
that were originally there or move the subsequent frames forward in
time.

Add Key Exposure

Adds a key exposure to the selected cell.

Remove Key Exposure

Removes only the key exposure (key frames) not all the exposures. The
existing key exposure is replaced by the preceding exposure.

Cell

Remove Duplicate Key Exposure

When working with drawings to adjust the timing of a mouth in a
lipsync, for example, and forcing the use of specific key exposures,
unnecessary key exposures will be created. You can delete these
duplicates without affecting the rest of the drawing. The first drawing
of the selection will be used for the range.

NOTE
Duplicate key exposures may occur when pasting with the
Enforce Key Exposure option selected.
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Fill Empty Cells

Lets you fill empty cells to extend the exposure of single frame
drawings to fill the range of empty cells after each one.When creating
drawings on cells that are not side-by-side, the exposure of the first
drawing no longer fills automatically. You must select the frame range
where you want your drawings to hold their exposure up to the next
drawing and use the Fill Empty Cells command.

Insert Blank Cell

Adds an empty cell between other cells.

Clear Exposure

Removes the exposure from the selected cell.

Clear Exposure and Pull

Replaces the exposure from the selected cell with exposures that
follow it.

Fill Selection

Lets you fill the same value over an entire selection. The selection can
be over one cell, a cell range in one column, a cell range over many
columns, an entire column, or many columns. You can use numbers,
words, letters, or any alphanumeric value.

Sequence Fill

Lets you create a numbered sequence over a selection. The sequence
can be forward, backward, single, double or higher increment, as a
cycle, and so on. The selection can be over one cell or a cell range in
one column or more or an entire column or many entire columns.

Lip-Sync
Auto Lip-Sync Detection

Generates a sound detection for lip-sync.

Map Lip-Sync

Automatically maps drawings in an element to the mouth chart you
have generated for a sound. This can save time when you are lipsynching a voice track.

Flip Horizontal

Flips the selection horizontally.

Flip Vertical

Flips the selection vertically.

Flip Scale X

Once your drawing layer is rotated, the original horizontal and vertical
axes change. The Flip Scale X and Flip Scale Y will perform a flip on
your drawing layer following its original axis.Remembers the original

Flip
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X-axis of the layer and flips the element following it.

Flip Scale Y

Remembers the original Y-axis of the layer and flips the element
following it.

Lock in Time

Indicates whether the point is locked to a specific frame (keyframe) or
only locked to a specific position and the curve can flow through it
freely as other points are being added, moved, or adjusted (control
point).

Substitute Drawing Previous

Replaces the drawing or cell's symbol on the current frame by the
previous drawing.

Substitute Drawing Next

Replaces the drawing or cell's symbol on the current frame by the next
drawing.

Go to Previous Keyframe

Goes to the previous keyframe.

Go to Next Keyframe

Goes to the next keyframe.

Select Child

Select Children

Lets you select the first element parented to the selected peg element
in the Timeline view.
Lets you select all elements parented to the selected peg element in the
Timeline view.

Lock

Reset

Lock

Locks one or a multiple selection of layers.

Unlock

Unlocks one or a multiple selection of locked layers.

Lock All

Locks all the layers in the Timeline view.

Unlock All

Unlocks all the layers in the Timeline view.

Lock All Others

Locks every layer except the selected ones.
Returns the value of the selected element to the initial value of the
active tool. For example, if the Rotate tool is active, the transformation

83

Chapter 2: Menus

angle will be reset to 0 and if the Transform tool is active, all the
transformation values will be reset.

Reset All

Resets all transformations on the current frame in a selected layer.
Your keyframe will remain, but all the values will return to the starting
value. All transformations are reset regardless of the tool you're using.
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Drawing Menu
The Drawing menu lets you access many tools related to drawing, painting, dirt removal, optimizing strokes,
and more.

How to access the Drawing menu
l

At the top of the interface, select Drawing.

Command

Description

Drawing Tools

Allows you to select one of the drawing tools available in Harmony.

Select

Allows you to select and reposition, scale, rotate and skew brush
strokes, pencil lines, shapes and other parts of your artwork.

Contour Editor

Allows you to edit the vector contours of brush strokes, pencil lines
and shapes in your artwork. You can add, remove, tweak and move
vector points, move the Bezier handles of the vector points as well as
deform vector outlines.

Centerline Editor

Allows you to tweak and deform a brush stroke by manipulating the
points at the centre of its line rather than its contour.

Cutter

Allows you to cut a part of your artwork, then reposition, scale, rotate
and skew it.

Smooth Editor

Allows you to optimize contours and lines by removing its extra
points, making them easier to edit.

Perspective

Allows you to deform artwork by applying a perspective effect on it.

Envelope

Allows you to deform and warp artwork by moving points and
tweaking lines in a grid.

Reposition All Drawings

Allows you to reposition, scale, rotate and skew all drawings in the
current layer.

Drawing Pivot

Allows you to position the pivot on a drawing layer by clicking where
you want its location to be.
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Brush

A pressure-sensitive tool for creating a contour shape with a thick and
thin line effect, as if created with a paint brush.

Pencil

A pressure-sensitive tool for drawing outlines. Pencil lines are made of
central vector lines, making them easier to tweak and edit than brush
strokes.

Text

Allows you to add text and to format it.

Eraser

A pressure-sensitive tool for erasing parts of a drawing.

Dropper

Allows you to select a colour by clicking on a colour in your artwork.

Morphing

Allows you to create and configure a morphing sequence, which will
automatically generate the in-betweens between two drawings in the
current layer.

Line

Draws a straight line segment going from one point to the other.

Rectangle

Draws a rectangle.

Ellipse

Draws an ellipse.

Polyline

Allows you to draw shapes, segmented lines or complex curved lines
by clicking to create each point in the sequence of line segments.

Paint

Allows you to fill colour zones with a colour or texture.

Repaint Brush

Like the Brush tool, but only paints over existing brush strokes.

Close Gap

Allows you to close open shapes so that they can be filled with the
Paint tool. By drawing a stroke near a small gap in a shape, this tool
will create a small invisible stroke connecting the two closest points
around the gap.

Stroke

Allows you to create invisible lines that can serve as colour zones that
can be filled, or close the gaps in existing colour zones.

Edit Gradient/Texture

Allows you to adjust the position, angle and size of gradients and
textures in a colour zone.
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Hand

Allows you to pan the Camera and Drawing views.

Zoom

Allows you zoom in and out of the Camera and Drawing views.

Rotate View

Lets you rotate the Camera and Drawing views just like with a real
animation disc.

Convert

Pencil Lines to Brush Strokes

Converts the selected centreline pencil strokes into contour strokes
brush lines.

Brush Strokes to Pencil Lines

Converts selected contour strokes into centreline pencil strokes. The
brush stroke thickness will be lost.

Strokes to Pencil Lines

Converts the selected invisible line to a pencil line.

Break Apart Text Layers

Text is treated as a single drawing object. This separates the text so
each character becomes an individual drawing object you can select
and modify independently.

Optimize

Flatten

Merges drawing objects and brush strokes into a single layer. If you
draw new lines to fix a drawing or line with many brush strokes, it can
be useful to flatten them all into a single shape. By default, lines are
drawn one on top of each other. If you intend to repaint the lines or
modify their shape, it will be easier if they are flattened.

Smooth

Smooths selected drawing strokes and removes extra points.

Optimize

Reduces the number of layers, such as overlapping brush strokes, in
the selected drawing objects. Drawing objects will only be flattened
and optimized if the selected objects do not change the appearance of
the final image when they are merged.

Transform
Flip Horizontal

Flips the current selection horizontally.
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Flip Vertical

Flips the current selection vertically.

Rotate 90 CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 CCW

Rotates the current selection 90 degrees counter-clockwise.

Rotate 180

Rotates the current selection 180 degrees.

Arrange
Bring to Front

Moves the selected art to the front (on top).

Bring Forward

Moves the selected art one level forward (closer to the front).

Send Backward

Moves the selected art one level lower (behind).

Send to Back

Moves the selected art behind everything (bottom / back).

Create Empty Drawing

Creates a drawing in the selected cell, replacing any drawing that may
already be exposed in that cell and the following ones until it meets
another drawing, key exposure or a blank cell.

Duplicate Drawings

Lets you duplicate the drawing and work on a copy of it. This lets you
modify an existing drawing but retain the original. When duplicating a
drawing, the selected cell is replaced with the new drawing. The
exposure of the original drawing that was on the current cell is
removed. The original drawing is not deleted from the project folder or
other cells in which it is exposed.

Delete Selected Drawings

Permanently removes selected drawings. Once you save your project,
these drawings cannot be recovered.

Rename Drawing

Lets you give a selected drawing a new name.

Select Strokes with Current Colour

Lets you select drawing elements and painted areas with the same
colour as the currently selected colour in your colour palette.

Previous Drawing

When a cell is selected in the Timeline or Xsheet view, displays the
previous drawing.
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Next Drawing

When a cell is selected in the Timeline or Xsheet view, displays the
next drawing.

Previous Layer

When a cell is selected in the Timeline or Xsheet view, displays the
previous layer.

Next Layer

Once a cell is selected in the Timeline or Xsheet view, you can navigate
between the drawings, frames, and layers. Displays the previous
drawing, next drawing, previous layer or next layer.
When a cell is selected in the Timeline or Xsheet view, displays the
next layer.
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Edit Menu
The Edit menu lets you repeat and undo actions, cut/copy/paste selected objects, select and manipulate objects,
work with symbols, and access the Preferences dialog box.

How to access the Edit menu
l

From the top menu, select Edit.

Command

Description

Undo

Removes the last change made to your project. Harmony supports
multiple undo, so you can undo changes you made in the order you
made them.

Redo

Redoes an operation you have undone. This command is active only
after you use the Undo command.

Cut

Removes selected objects. You can then paste the object or its
properties to another object.

Copy

Copies selected objects and properties.

Paste

Places an object you cut or copied into the location you select in a
view.

Paste Special

Opens the Paste Special dialog box which lets you determine how
templates and symbols are imported in the Timeline view.
There are advanced paste options for drawings, timings, keyframes,
layers, as well as palettes and symbols.

Paste Special Again

Pastes new drawings with the previous Paste Special settings.

Delete

Removes selected objects.

Select All

Selects all drawing objects in the current drawing window in the
Drawing, Timeline and Camera views. This helps you manage multiple
objects as one when moving them.

Deselect All

Deselects all selected objects in the Drawing and Camera views.
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Invert Selection

Deselects the currently selected items and selects all other items that
were not selected. For example, if some lines are selected in a drawing,
this command will deselect them and select any other lines in the
drawing that were not selected.

Create Symbol

Creates a symbol from selected drawing elements in the Drawing or
Camera view or a layer or cells in the Timeline view.
Extracts a symbol's contents and places it on the root timeline. Its
contents will be copied and inserted into the root timeline. The symbol
will not be removed from the Timeline view once it is expanded.

Expand Symbol

The symbol's layers will be parented to it in case you created motions
and transformations on the drawing layer that contain the symbol.
Breaking the hierarchy could result in the loss of any scaling and
animation you may have created.

Duplicate Selected Symbol

Creates a duplicate of a selected symbol. If other symbols are nested
inside the new symbol, they are not duplicated. If you modify them, the
original and other instances will also be modified.

Clone: Drawings Only

Creates a copy of the drawings in the selected layer in the Timeline
view or column in the Xsheet view. The timing it not copied.

Clone: Drawings and Timing

Creates a copy of the drawings and their timings in the selected layer
in the Timeline view or column in the Xsheet view.

Duplicate

Duplicates a layer to have a copy of the drawings that are independent
from the original ones, as well as an independent timing (exposure).
When you need the drawings to be modified independently, you will
want to duplicate the layer instead of cloning it.

Merge

Combines all drawings. Unused columns and layers will be deleted,
but the original drawing files are still accessible.

Group
Group

Groups selected drawing objects in the Camera or Drawing view.

Ungroup

Ungroups a selected group of drawing objects in the Camera or
Drawing view.
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Edit Drawing Mode

When the Auto-Get Rights to Modify Drawings option is selected in
the Preferences dialog box (General tab), the system automatically
gets the rights to modify drawings when you select a drawing.
Otherwise, you must manually get the rights to modify drawings.

Edit Palette List Mode

When the Auto-Get Rights to Modify Palette option is selected in the
Preferences dialog box (General tab), the system automatically gets
the rights to modify palettes and palette lists when you select a colour
from a palette. Otherwise, you must manually get the rights to modify
a palette or palette list.

Get Rights to Modify Drawing

Manually releases the rights to modify a selected drawing.

Release Rights to Modify Drawing

Manually releases rights to modify a selected drawing.

Force Release Rights to Modify Drawing

This option is always available even if the Get Rights to Modify All
Scene Assets option is not selected in the Database Selector dialog
box.

Preferences

Opens the Preferences dialog box where you can set your preferences
for Harmony.
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File Menu
The File menu lets you open, close, save, scan, print, and import and export files.

How to access the File menu
l

From the top menu, select File.

Command

Description

New

Creates a new scene while closing any scene already open. The New
Scene dialog box opens, asking for directory, name, and resolution
information.

Open

Displays the Open Scene dialog box where you can browse for a scene
file. You can open a new scene from the current one and the previous
scene will close.

Open Recent

Displays a list of the most recently opened scenes.

Clear

Clears the list of recently opened scenes.

Close

Closes the currently opened scene, but does not close the Harmony
application.

Save

Saves all changes made to the opened scene, drawings, palettes, and
palette lists.
Lets you do the following:
l

l

Advanced Save
l

l

Rights to Modify Scene Version

Save the scene as the current version.
Save different versions representing different stages of the
production of your scene.
Save different versions representing different scene setups.
Choose specific assets that you want to save, such as
drawings or palettes.

Allows you to modify the selected version of the scene as well as to
manage and overwrite other versions. Other users will not be able to
open a different version of the scene until you close the scene.
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Rights to Modify Scene

Allows you to modify the currently selected scene version only. Unless
the Get rights to modify the scene option is also checked, you will not
be able to change other versions of the scene. This allows other users
to modify different versions of the scene while you are working on the
selected version.
Determines which drawing files have been modified on disk since you
loaded them. All updated drawings will be reloaded.

Read Changed Drawings

NOTE
Reloading a locked drawing will discard unsaved changes.

Manage Versions

Allows you to manage all the versions of the current scene.
Saves the current file with a different name and at a different location.
Saves the current state of a scene as another scene. The Save As
window prompts you for a new name and a different location for this
scene before saving it. This will create a complete scene directory for
the new scene.

Save As

NOTE
The scene name cannot exceed 23 characters.

Save as New Version

Saves the current scene as another version. The Save Version dialog
box prompts you to give a name for this new version. This will create a
new .xstage file in your current project directory.

Acquire

From TWAIN

Opens the Acquire from Scanner window from which you can set
parameters before scanning.

Import
Images

Imports bitmap images which you can choose to vectorize.

Movie

Lets you convert a QuickTime movie to an image sequence and audio
file.
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Sound

Lets you import sound files into your project.

SWF, Illustrator Files to Library

Lets you import SWF files into your project.

Images

Exports a scene as a bitmap image sequence. If there is sound in your
scene, it will not be exported with the images.

Movie

Exports animation as a QuickTime movie.

Export

Exports a Flash movie file.
SWF

Harmony supports exporting Flash movie files with a limited subset of
vector and bitmap effects, the latter which can be previewed in Render
View

Quit

mode.

Closes the application.
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Help Menu
The Help menu lets you display the Harmony documentation, Welcome screen and end user license agreement,
as well as access the Toon Boom website, and identify the product name and version number.

How to access the Help menu
l

At the top of the interface, select Help.

Command

Description

Online Help

Opens the Harmony Help system, complete with instructions on how
to use the system. This requires an internet connection.

Getting Started

Opens the Harmony Getting Started Guide (in PDF format) in a
browser window. Requires Acrobat Reader.

Toon Boom on the Web

Opens the Toon Boom website, which features a Support and
Community > Forum section.
The Customer Experience Improvement Program allows Toon Boom to

Customer Experience Improvement
Program

collect usage information. The data does not contain any personally
identifiable information and cannot be used to identify you. The data
will consist of a basic hardware description, a project summary and
usage information. The information is used only for software
improvement purposes, as well as for sharing with third parties for the
same reason.
This program is enabled by default but is voluntary. If you prefer not to
participate, you can opt out when you first launch the software, by
using a global preference, or by a command line argument.

About

Identifies the product name and version number.

Show Welcome Screen

Displays the Harmony Welcome screen.

Show End User License Agreement

Displays the End User License Agreement.
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Insert Menu
The Insert menu lets you create empty symbols in the Library view, different types of layers in the Timeline
view, keyframes and control points.

How to access the Insert menu
l

At the top of the interface, select Insert.

Command

Description

Create Empty Symbol in Library

Creates an empty symbol in the Library view to which you can edit
(add content).

Bone

Adds a new Bone layer to the Timeline view.

Camera

Adds a new Camera layer to the Timeline view.

Colour-Card

Adds a new Colour-Card layer to the Timeline view.

Drawing

Adds a new Drawing layer to the Timeline view and a column in the
Xsheet view.

Game Bone

Adds a new Game Bone layer to the Timeline view.

Kinematic Output

Adds dd a new Kinematic Output layer to the Timeline view.

Peg

Adds a new Peg layer to the Timeline view.

Quadmap

Adds a new Quadmap layer to the Timeline view.

Effects

Adds a new layer in the Timeline view with the effect you select: Blur,
Brightness-Contrast, Colour-Scale, Cutter, Glow, Shadow, or
Transparency.

Keyframe

Adds a keyframe to the selected cell in the Timeline view.

Keyframe and Duplicate Drawing

Adds a keyframe to the selected drawing layer cell in the Timeline view
and creates a duplicate of the drawing, which sits on top of the
original drawing.
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Control Point

Adds a control point to the trajectory of the selected element or peg in
the Camera view when the element or peg is in a 3D path. Note that
you must have a 3D path in the peg portion in order to add a control
point.
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Play Menu
The Play menu lets you play back animation and sound. Use it to scrub the sound to create your lip-sync, loop
the playback, navigate through frames, and change the playback range and speed.

How to access the Play menu
l

At the top of the interface, select Play.

Command

Description

Play

Plays the scene in the Camera or Drawing view.

Render and Play

Renders your scene's frames, then opens the rendered frames
in Harmony Play for playback.
This allows you to preview your scene's animation in real time, with
the effects rendered and with no risk of slowdown.
Exports your scene as it appears in the Camera view into a movie file,
then opens it in your workstation's default video player.

Record and Play

This allows you to preview your animation without any risk of
slowdown, but it does not preview the effects in your scene. However,
it is much faster than Render and Play.
This button automates the usage of the Export OpenGL Frames dialog
see

Test SWF Movie

Quickly exports your scene as a Flash Movie (.swf), then opens it in
your workstation's default web browser.

Stop

Stops playback.

Playback Speed

Opens the Set New Frame Rate dialog box where you can set the
frame rate at which the playback plays.

Loop

If pressed, your scene will repeat indefinitely when playing. Otherwise,
it will stop when the end is reached.

Enable Sound

Turns on sound during playback.
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Enable Sound Scrubbing

Turns on sound scrubbing during playback.

Start Frame

Opens the Set Playback Start Frame dialog box , in which you can
enter the frame number from which to start playback.

Stop Frame

Opens the Set Playback Stop Frame dialog box, in which you can set
the frame number at which to stop playback.

First Frame

Moves the red playhead to the first frame.

Previous Frame

Moves the red playhead to the previous frame.

Next Frame

Moves the red playhead to the next frame.

Last Frame

Moves the red playhead to the last frame.

Go to Frame

Opens the Go to Frame dialog box where you can enter the frame
number on which the red playhead to be positioned in the Timeline
view.

Enable Playback
Top View

Plays back your animation in the Top view.

Side View

Plays back your animation in the Side view.

Perspective View

Plays back your animation in the Perspective view.
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Scene Menu
The Scene menu lets you set the scene length, add frames to the scene, view different displays of the scene, set
render options, access the Scene Settings dialog box and Elements Manager window, and verify the drawing
and palette files in your project.

How to access the Scene menu
l

At the top of the interface, select Scene.

Command

Description

Scene Length

Lets you set the length of the scene in frames.

Frame
Add Frames at Start

Adds the number of frames you specify to the beginning of the scene.

Add Frames at End

Adds the number of frames you specify to the end of the scene.

Add Frames Before Selection
Adds the number of frames you specify before or after your selection.
Add Frames After Selection
Remove Selected Frames

Deletes the selected frames from your scene.

Camera

Default Camera

Scene Settings

Lets you select a camera. If you only add one camera to your scene,
you will only see Default Camera in your list.
Opens the Scene Settings dialog box where you can set the resolution,
alignment, bitmap resolution and many other parameters.

Render

Auto Render

Automatically recalculates the preview image whenever you modify a
parameter. If your scene is heavy and you do not want the preview
rendered automatically, deselect the Auto-Render option and do the
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preview update manually.Note that this will slow down Harmony as it
takes resources to update every frame.
Cancel Preview Render

Cancels a render that was started.
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View Menu
The View menu lets you manipulate the view by zooming, panning, or rotating. You can also display the grid
and change its size, use the onion skin feature to help with drawing, and set the preview resolution.

How to access the View menu
l

At the top of the interface, select View.

Command

Description
Cycles through the following display modes:
l

Toggle Full Screen

l

l

Normal Full-Screen: The main application window becomes
full screen.
View Full-Screen: The selected view becomes full screen and
all other views are collapsed.
Normal: The main application window is restored to its original
size and collapsed views are expanded.

Zoom In

Zooms in the view.

Zoom Out

Zooms out the view.

Rotate View CW

Rotates the Camera view 30 degrees clockwise, like an animation
table.

Rotate View CCW

Rotates the Camera view 30 degrees counter-clockwise, like an
animation table.

Reset Zoom

Resets the view’s zoom to its default position.

Reset Rotation

Resets the view’s rotation to its default position.

Reset Pan

Resets the view’s pan to its default position.

Reset View

Resets the view to its default position.

Grid
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Show Grid

Displays the grid.

Underlay

Displays the grid under the drawing elements.

Overlay

Displays the grid over the drawing elements.

Square Grid

Displays a standard square grid.

12 Field Grid

Displays a 12-field size grid.

16 Field Grid

Displays a 16-field size grid.

Onion Skin

Show Onion Skin

Lets you preview the previous and next drawings. By default, the
previous drawings appear in a shade of red and the next drawings are
displayed with a shade of green. You can change these colours in the
Preferences dialog box.

Add to Onion Skin

Adds a series of selected elements to the onion skin preview.

Remove from Onion Skin

Removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion
Skin

Removes all elements except the ones selected from the onion skin
preview.

Add All to Onion Skin

Adds all of the scene's elements to the onion skin preview.

Remove All from Onion Skin

Removes all of the scene's elements from the onion skin preview.

Onion Skinning by Drawing

In Camera view, the onion skin by default is per frame, this option lets
you set it by drawing so you don't see any exposure's onion skin from
the same drawing.

Reduce One Previous Drawing

Reduces the number of previous visible drawings by one.

Add One Previous Drawing

Adds one drawing to the number of previous visible drawings.

104

Harmony 15.0 Essentials Reference Guide

Reduce One Next Drawing

Reduces the number of next visible drawings by one.

Add One Next Drawing

Adds one drawing to the number of next visible drawings.

Light Table

Turns on the light table so you can see the previous and subsequent
active layers in washed-out colours. It is useful for seeing the other
layers when designing, animating or cleaning up your animation.

Show

Safe Area

Displays the TV safety zone and the centre of the camera frame. The
safe area adapts to the scene resolution, as well as the safety zone and
frame’s centre.

Camera Mask

Displays a black mask around the scene’s frame to avoid seeing the
unnecessary artwork. This option is handy when you're animating and
setting up the scene. It allows you to see your scene’s composition
better.

Control

Displays the controls of the selected element.

Current Drawing on Top

Displays the selected drawing on top of everything while you draw. By
enabling this option, each time you select a drawing tool, the selected
drawing is displayed in front of everything in the Camera view. The
Timeline view ordering remain unchanged.You only need to enable this
option once, it is not necessary to do it each time you select a drawing
tool.

Show Strokes

Displays the strokes in your drawings so that the invisible lines stand
out.

Hide All Controls

Hides the controls of the selected element.

Preview Resolution
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Same as Scene Resolution
3/4 of Scene Resolution
1/2 of Scene Resolution

Lets you choose a resolution for previewing a scene.

1/3 of Scene Resolution
1/4 of Scene Resolution

Custom

Lets you select a resolution from a list of presets or enter X and Y
values for a custom preview resolution.
Let's you increase or decrease the preview quality of raw bitmap
images. By default, bitmap files imported in Harmony will display in a
low resolution in the Camera view to avoid hindering performance.

TIP

Bitmap File Quality

You can change the default resolution in which bitmap files
are displayed in the Camera view by changing the
Small Bitmap Resolution preference located in the Camera tab
of the Preferences dialog.

NOTE
This only affects the way bitmap images display in the
OpenGL preview of the scene in the Camera view. The
preview quality of bitmap images does not affect the final
render.
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Windows Menu
The Windows menu lets you customize your workspace to suit your working style, save it as a new workspace,
and load it from the Workspace toolbar. You can also show or hide the different toolbars and views in Harmony.

How to access the Windows menu
l

From the top menu, select Windows.

Command

Description

Restore Default Workspace

Returns modified workspaces to their original default layout if you do
not like the current modifications or inadvertently closed some
windows.

Workspace

Workspace Manager

Workspace

Opens the Workspace Manager where you can modify, create, delete,
rename and reorder your workspaces.
Lets you open workspaces designed specifically for animating,
compositing, hand drawing, scripting and the default workspace.

Toolbars

Lets you show or hide these toolbars: Playback, File, Edit, Advanced
Animation, Scripting, Tools, Workspace, Deformation, Camera View,
Xsheet View and Timeline View.

Camera

Shows or hides the Camera view.

Colour

Shows or hides the Colour view.

Drawing

Shows or hides the Drawing view.

Function

Shows or hides the Function view.

Layer Properties

Shows or hides the Layer Properties view.

Library

Shows or hides the Library view.

Message Log

Shows or hides the Message Log view.

107

Chapter 2: Menus

Side

Shows or hides the Side view.

Timeline

Shows or hides the Timeline view.

Tool Properties

Shows or hides the Tool Properties view.

Top

Shows or hides the Top view.

Xsheet

Shows or hides the Xsheet view.

Integrated Help

Shows or hides the Integrated Help view.

Metadata Editor

Shows or Hides the Metadata Editor view.

Script Editor

Shows or hides the Script Editor view.
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View Menus
A view menu contains commands specifically related to that view.

How to access a view menu
1. In the top-left corner of a view, click the Menu

button.

Colour View Menu

110

Function View Menu

113

Library View Menu

115

Script Editor View Menu

117
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Colour View Menu
The Colour View menu lets you access commands related to the Colour view such as creating new palettes,
adding new colour swatches, and displaying the Tint panel.

How to access the Colour menu
l

In the upper-left corner of the Colour view, click the menu

Command

button.

Description

Palettes
Creates a new colour palette.

New

By default, Toon Boom Harmony is set to the Basic mode. For simple
productions, it is recommended to use the Basic mode. This setting stores the
palettes automatically for you and saves them at the Scene level. When you use
the Advanced Palette Lists mode, you can decide at which level you want to store
your palettes: Environment, Job, Scene, or Element.

Import

Imports a colour palette located on your hard drive.

Remove

Removes the selected palette from the palette list.

Remove and Delete
on Disk

Removes the selected palette from the palette list and deletes the palette file from
the disk.

Rename

Lets you five the selected colour palette a new name.

Duplicate

Creates a copy of the original palette, using the same names and colour values,
but has a different ID and is independent from the original palette. This ensures
that both the duplicate and original palettes are completely independent.

Clone

Creates a copy of the master palette. The colours in each palette have the same
properties. The colours have the same identification number pointing to the same
colour zones, but they can have different names and RGBA values.

Move Up

Moves the selected colour palette up one level.

Move Down

Moves the selected colour palette down one level.
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Colour Editor

Opens the Colour Editor where you can pick and edit colour swatches.

Tint Panel

Opens the Tint panel where you can modify a series of colours to blend a tint in
them or offset their RGBA values.

Current Palette
Overrides

When clone palettes are present in the palette list, by default, priority is given to
the palette that is the highest in the palette list to decide which colours to apply
to drawings. With this option enabled, priority is given to the currently selected
palette. Selecting any of the clone palettes will make drawings use colours from
the selected palette instead.

Display Colour
Values

Display the colour values beside their colour swatches in the palette list.

Colours
Cut

Cuts the selected colour swatch from the palette.

Copy

Copies the selected colour swatch which you can paste in a different palette.

Copy Colour ID

Copies a colour swatch's colour ID so you can keep a reference file of colour IDs
or use them with custom plug-ins. Example of a colour ID: 075cf5b552401130.

Paste Colour Values

Pastes the colour value of the copied swatch over an existing colour swatch.

Paste As New
Colours

Creates a new colour swatch from the colour value of the copied swatch.

Paste As Clones

Pastes a copied colour to a new palette as a clone of the original one. Both colour
use the same colour ID. They have to be in different palettes.

New

Creates a new colour swatch from the colour swatch that was last selected.

Edit

Opens the Colour Picker window in which you can edit the selected colour
swatch.

Delete

Deletes the selected colour swatch from the palette.

New Texture

Lets you add a bitmap colour swatch to your palette. You can load photos and
textures and paint your drawings with it. The bitmap image must be a .tga or .psd
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file format.

Edit Texture

Opens the browser to replace the texture used in a textured colour swatch. All
zones using the swatch will be updated with the new texture.

Scale Down Texture

Lets you set a new maximum texture size or scaling factor.

Protect Colour

Locks a selected colour, so if you ever paint over it accidentally, the work already
done will not be affected. You can also block the filling colours if you painted all
of the animation in Line Art and plan to repaint the lines.

Swatch Mode

Displays the colour swatches with its corresponding name inside the swatch.
When this option is not selected, the names of the colour swatches are displayed
beside the swatch.

Independent Bitmap
Colour

Bitmap colour selection is independent from the vector colour selection.

Bitmap Colour Sliders
RGB

Displays the colour picking sliders as RGB (red, green, blue).

HSV

Displays the colour picking sliders as HSV (hue, saturation, value).
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Function View Menu
The Functions View menu lets you do many things in the Camera view, including selecting and editing objects
in different views, changing the display, setting morphing parameters, accessing tools and many more.

How to access the Function menu
l

In the upper-left corner of the Function view, click the menu

Command

button.

Description

Edit

Cut

Removes selected objects. You can then paste the object or its properties to
another object.

Copy

Copies selected objects and properties.

Paste

Places an object you cut or copied into the location you select in a view.

Delete

Removes selected objects.

Select Next Keyframe

Selects the next keyframe.

Select Previous
Keyframe

Selects the previous keyframe.

Select Left Handle

Selects the left handle of the selected keyframe.

Select Right Handle

Selects the right handle of the selected keyframe.

Select All

Selects all objects in the Function view. This helps you manage multiple objects
as one.

Deselect All

Deselects all selected objects in the Function view.

View
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Show Current Frame

Displays the current frame

Toggle Grid

Enables the display of the grid.

Reset Zoom

Resets the view’s zoom to its default position.

Reset Pan

Resets the view’s pan to its default position.

Reset View

Resets the view to its default position.

Function List
Auto Load Selection
Clear
Load Selection
Add Selection
Remove Selection
Show Motion:
Show Rotation:
Show

Show Scale:
Show Skew:
Show Other:
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Library View Menu
The Library View menu lets you access commands specific to the Library view, such as opening a Library or
getting the rights to modify a library folder.

How to access the Library menu
l

In the upper-left corner of the Library view, click the menu

Command

button.

Description

View
List

Displays the contents of the selected folder as a list.

Thumbnails

Displays the contents of the selected folder as a thumbnails.

Details

Displays the details of the selected file.

Generate Thumbnails

Creates a thumbnail to display in the preview window.

Edit
Creates a new symbol from a drawing or part of a drawing in the
Drawing or Camera view, or a layer in the Timeline view.
New Symbol

If your selection is in the Timeline , the new symbol appears in the Symbol folder.
The current selection is not replaced by the new symbol. The new symbol only
appears in the library. You must drag it into your scene to use it.
If your selection is in the Drawing or Camera view, the new symbol appears in the
Symbol folder and in the Timeline view as a new layer.

Cut

Cuts the selected file in the Library view.

Copy

Copies the selected file in the Library view.

Paste

Pastes the selected file in the Library view.

Delete

Deletes the selected file in the Library view.
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Delete Thumbnails

Deletes any thumbnails that were generated for display in the preview window.
Places you inside the symbol where you can edit it.

Edit Symbol

To return to the project's timeline, click the Top

button in the Camera view's

top-left corner, press Ctrl + Shift + E (Windows/Linux) or ⌘ + Shift + E (macOS).
Remove Unused Files

Removes any files not in use in the selected template.

Rename Template

Lets you rename a selected template.

Import Files

Imports vector files such as AI, PDF, and SWF. You requires the right to modify
the library in which you want to import the files.

Folders

New Folder

Creates a new folder in the Library view. Before you can create a new folder, you
must have the right to modify the folder in which you are creating the new folder.

Refresh

Updates the view and its contents.

Open Library

Lets you open a library on your computer.

Close Library

Unlinks a library folder from your library list.
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Script Editor View Menu
The Script Editor view menu gives you access to all of the commands needed for editing and testing scripts in
the Script Editor view—see Script Editor View on page 282.

How to access the Script Editor view menu
1. Add the Script Editor view to your workspace by doing one of the following:
l

In the top-right corner of an existing view, click on the

Add View button and select Script

Editor.
l

In the top menu, select Windows > Script Editor.

2. In the top-left corner of the Script Editor view, click on the

Button

Menu button.

Description

File
Creates a new script. When you click on this button, you are first prompted to type in a
name for the script. Then, you will be prompted to select which location to save the
script in:
l

New Script

l

User: Saves the script to your user preferences. You will be able to run and edit
the script from any scene as long as you are logged in as the same user.
Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to
edit and run the script when working on this specific scene.

NOTE
For more information on script locations, see Script Editor View.

Allows you to import a script from your machine into Harmony. When you click on this
button, you are prompted to browse for and select a script on your file system. Then,
you are prompted to select which location to import the script in:
Import Script

l

l

User: Saves the script to your user preferences. You will be able to run and edit
the script from any scene as long as you are logged in as the same user.
Scene: Save the script to the scene's scripts sub-folder. Anyone will be able to
edit and run the script when working on this specific scene.
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Button

Description

NOTE
For more information on script locations, see Script Editor View.

Deletes the selected script.

NOTES
l

Delete Script
l

Refresh Script
File List

You cannot delete a script if it is in the Application Resources location,
as those are scripts that are installed with Harmony.
If you delete a script that was originally in Application Resources but
which you copied to another location so you could make changes to it,
the original version of the script in the Application Resources folder
will be restored to the list.

Refresh the list of scripts in the Script Editor. If there are new scripts in your user
preferences or your scene's scripts sub-folder, click on this button to be able to open
them in the Script Editor.

Editor
Allows you to type in the path and name for your preferred text editing software.

NOTES
Set External
Editor

l

l

External Editor

On macOS, only typing the name of your preferred text editing software
is enough if that application supports the AppleScript Open Document
protocol.
On Windows, unless your text editor is in your system's PATH
environment variable, you will have to type in the full path to the editor.

Opens the selected script in the chosen external text editing software.

Play/Debug

Set Target

Prompts you to select which script and which function to use with the Run and Debug
commands.
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Button

Description

Runs the target script and function.

NOTES
l

Run
l

l

If you have not set a target script and function, you will be prompted to
set one when you select this command.
You can set or change the target script and function by selecting Set
Target from this menu.
If you are editing <<<Sandbox>>>, this button will simply run what
you typed into the sandbox, regardless of whether another target is set.

Open the target script and function in the Qt Script Debugger, in which you can test and
debug the function.

NOTES
l

Debug
l

l

Stop

If you have not set a target script and function, you will be prompted to
set one when you select this command.
You can set or change the target script and function by selecting Set
Target from this menu.
If you are editing <<<Sandbox>>>, this button will simply debug what
you typed into the sandbox, regardless of whether another target is set.

If a script is currently running, this interrupts its execution.

Help
Opens the reference documentation for the Harmony scripting interface in a web
browser.
Scripting
Interface
Documentation

NOTE
This documentation is installed with Harmony and does not require Internet
access.
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Chapter 3: Layers
In Harmony, everything that constitutes the different elements of a scene, including drawing layers, sound
effects, visual effects and pegs is represented by a layer in the Timeline view.
At the core of the rendered picture is the drawing layer, which is used to display drawings. Those layers are
rendered from bottom to top, with the bottommost layer appearing in the background, and the topmost layer
appearing in the foreground.
Some layers, such as Peg, Bone or Quadmap layers, are made to offset drawing layers. They must be created as
the parent of a drawing layer, or of a hierarchy of drawing layers, in order to transform the layers in the
rendered image.
Other layers, such as Blur and Transparency layers, are made to transform the picture output by drawing
layers. They must be created as children of drawing layers, or groups of drawing layers, in order to transform
the drawings.
Deformation Layers

122

Bone Layers

123

Deformation Composite Layer

125

Game Bone Layer

126

Kinematic Output Layer

128

Effect Layers

129

Blur Layer

130

Colour-Scale Layer

132

Cutter Layer

134

Glow Layer

136

Shadow Layer

140

Transparency Layer

143

Image Layers

144

Colour-Card Layer

145

Drawing Layer

147

Move Layers

151

Camera Layer

152

Peg Layer

153

Quadmap Layer

155
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Sound Layer

158
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Deformation Layers
Deformation layers are layers that make deformers. In Harmony, deformers are made of chains of deformation
layers laid out in a hierachy. Each deformation layer represents a point in the deformation chain.
Bone Layers

123

Deformation Composite Layer

125

Game Bone Layer

126

Kinematic Output Layer

128
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Bone Layers
The Bone node is one of the main nodes used to build a deformation rig. Each Bone node consists of a bone and
an articulation. You can chain Bone nodes to create a skeleton chain for your character. The Rigging tool can be
used to create and connect those nodes automatically.

Properties

Parameter

Descriptions

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no visible
effect on the rendered image, nor on the preview in the Camera, Side and Top
views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Allows you to enter a name for the node.

Resting Parameters Rest Offset
(x) Axis

This is the bone x-axis (horizontal) coordinates for the resting position.

(y) Axis

This is the bone y-axis (vertical) coordinates for the resting position.
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Rest Radius

This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation

This is the bone's orientation angle for the resting position.

Rest Bias

This is the articulation's bias (roundness and smoothness) for the resting
position.

Rest Length

This is the bone's length for the resting position.

Deform Parameters Offset

2D Path

When this option is enabled, the X and Y-axis parameters are controlled by the
same 2D path function.

Separate

When this option is enabled, the X and Y-axis parameters are individual one from
another.

Path

When using a 2D Path, this field displays the name of the function.

(x) Axis

This is the bone X-axis (horizontal) coordinates for the animation position. This
parameter can be linked to a function to be animated over time.

(y) Axis

This is the bone y-axis (vertical) coordinates for the animation position. This
parameter can be linked to a function to be animated over time.

Radius

This is the articulation's radius value (articulation size) for the animation position.
This parameter can be linked to a function to be animated over time.

Orientation

This is the bone's orientation angle for the animation position. This parameter can
be linked to a function to be animated over time.

Bias

This is the articulation's bias (roundness and smoothness) for the animation
position. This parameter can be linked to a function to be animated over time.

Length

This is the bone's length for the animation position. This parameter can be linked
to a function to be animated over time.
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Deformation Composite Layer
The Deformation-Composite node is automatically added to a rig when creating a split deformation chain. It is
used to link the different nodes of a split deformation chain together before deforming the drawing it is linked
to.

Properties
Parameter

Description

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no
visible effect on the rendered image, nor on the preview in the Camera,
Side and Top views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Use this field to rename the node.
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Game Bone Layer
The Bone node is one of the main node used to build a deformation rig. Each Bone node consists of a bone and
an articulation. Chaining Bone nodes will create a skeleton chain for your character. The Rigging tool can be
used to create and connect those nodes automatically.

Parameter

Descriptions

Resting Parameters Rest Offset
(x) Axis

This is the bone X-axis (horizontal) coordinates for the resting position.

(y) Axis

This is the bone Y-axis (vertical) coordinates for the resting position.

Rest Radius

This is the articulation's radius value (articulation size) for the resting position.

Rest Orientation

This is the bone's orientation angle for the resting position.

Rest Length

This is the bone's length for the resting position.

Deform Parameters Offset

2D Path

When this option is enabled, the X and Y axis parameters are controlled by the
same 2D path function.
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Separate

When this option is enabled, the X and Y axis parameters are individual from each
other.

Path

When using a 2D Path, this field displays the name of the function curve.

(x) Axis

This is the bone X-axis (horizontal) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.

(y) Axis

This is the bone Y-axis (vertical) coordinates for the animation position. This
parameter can be linked to a function curve to be animated over time.

Radius

This is the articulation's radius value (articulation size) for the animation position.
This parameter can be linked to a function curve to be animated over time.

Orientation

This is the bone's orientation angle for the animation position. This parameter can
be linked to a function curve to be animated over time.

Length

This is the bone's length for the animation position. This parameter can be linked
to a function curve to be animated over time.
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Kinematic Output Layer
The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation
chain but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will
follow the movement of the chain just like a regular cut-out character hierarchy piece without being influenced
by the deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the
deformation.
Connect a Kinematic Output node below the deformation node you want your drawing to follow.
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Effect Layers
Effect layers can be connected under a layer or under a group to transform the image.
Should you need to apply the same effect to several layers combined, you must group them together so
that Harmony composes those layers into a single image before applying the effect.
Blur Layer

130

Colour-Scale Layer

132

Cutter Layer

134

Glow Layer

136

Shadow Layer

140

Transparency Layer

143
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Blur Layer
T-HFND-010-007
The Blur effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect is
useful when you want to make cloudy images not realistically seen in detail, such as a drawing object that is
farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective.
Other uses include the general softening of objects such as snow, stars and shadows that do not naturally have
a hard outline.

Refer to the following example to connect this effect:

Properties

Parameter

Description

Name

Allows you to enter a name for the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When this option is deselected, the effect's values
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Parameter

Description

remain unchanged regardless of any depth or scale changes. This option should
be deselected when multiple drawings are composited and attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the blur.
The blur radius is affected by the drawing scale and camera position. Click the
Edit Curve button to change these values over time by adjusting the function
curve.

Quality

Select High for a slow and accurate operation or Low for a faster operation with a
more raw look.

Matte

Invert Matte

Inverts the matte used to generate the effect. By default, the effect is applied to
the opaque areas of the matte drawing. When this option is enabled, the effect is
applied to the transparent areas of the matte instead.
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Colour-Scale Layer
The Colour-Scale effect offsets an image's colours. This effect is useful in creating ambient transitions, such as
from daytime to nighttime.

Refer to the following example to connect this effect:

Properties

Parameter

Description

Name

Allows you to enter a name for the node.

Red

The factor by which to multiply red values in the image.
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Parameter

Description

Green

The factor by which to multiply green values in the image.

Blue

The factor by which to multiply blue values in the image.

Alpha

The factor by which to multiply alpha values in the image.

Hue

The colour or hue to offset the image.

Saturation

The amount of colour to offset the image.
Enter the value for the colour to offset the image. The actual colour values of the
image are not changed; instead, the channels are multiplied by a selected amount.
For example:
l

Value
l

l

Invert Matte

A value of 1 does not change the colour values.
A value greater than 1 brings the colour channel value closer to 255 (or
white).
A value less than 1 brings the colour channel value closer to zero (0 or
black).

Inverts the matte used to generate the effect. By default, the effect is applied to
the opaque areas of the matte drawing. When this option is enabled, the effect is
applied to the transparent areas of the matte instead.
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Cutter Layer
T-HFND-010-009
The Cutter effect cuts out a portion of an image. To do this, it needs to be connected to the drawing it is
intended to cut as well as to a matte layer. The cutter will take the shape of the drawing in the matte layer and
cut this shape out of the drawing layer. This is especially useful if you want to make a character disappear
between a background element, or if you want to cut out a hole in the middle of a character.
Like all effects that use a matte, the Cutter's effect has an Inverted parameter, which is disabled by default.
When enabled, the Cutter will have the reverse effect: Instead of cutting the matte's shape out of the drawing,
it will cut everything outside of the matte's shape out of the drawing, leaving only the parts of the drawing that
are covered by the matte. This can be useful if, for example, you want to draw shadows or highlights for a
character, but you don't want to have to worry about them bleeding beyond your character's outline. You can
simply connect your shadow or highlight to an inverted cutter, and use a clone of your character as the matte,
and your effect will not display outside of your character's outlines.
The Cutter effect can be used with 2D-3D integration. Rendered 2D drawings, integrated with 3D models,
display soft, anti-aliased edges, even where the Cutter effect is applied.

Refer to the following example to connect this effect:

Properties
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Parameter

Description

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no visible
effect on the rendered image, nor on the preview in the Camera, Side and Top
views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Allows you to enter a name for the node.

Inverted

When this option is enabled, the Cutter node will invert the matte shape to cut
the drawing. Instead of cutting the image intersecting with the matte, it will cut
any artwork outside of the matte shape.
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Glow Layer
T-HFND-010-009B
The Glow effect turns your image into a glow area with a bright soft-edged light or diffuse light region around
an image. The Glow effect is useful for creating a shining rim around objects, such as the sun or stars. Clone your
layer to display the original image on top of the glow.

Refer to the following example to connect this effect:
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Properties

Parameter

Description

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no visible
effect on the rendered image, nor on the preview in the Camera, Side and Top
views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Allows you to enter a name for the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.
Allows you to choose between the following blur types for the effect:
l

Blur Type
l

Radial: The edges of the matte are blurred evenly around points that make
up the edge of the matte.
Directional: The matte is blurred in the direction configured with the
Directional Angle and Directional Falloff Rate parameters.
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Parameter

Description

Radius

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.
If you set the Blur Type to Directional, this sets the angle of the blur. The value
goes from 0 to 360, with 0 meaning west, and angles going counterclockwise.
For example:

Directional Angle

l

0: Blurs the image to the west.

l

90: Blurs the image to the south.

l

180: Blurs the image to the east.

l

270: Blurs the image to the north.

The distance where the blur fades from the edge of the image. Select a decimal
value between 0 and 1. For example:
Directional Falloff Rate

l

l

Invert Matte

0: Makes the blur fade out slowly, distributing the blur evenly from the
edge of the character to the farthest edge of the blur.
1: Makes the blur fade out quickly. The blur is heaviest closer to the edge
of the image.

Inverts the matte used to generate the effect. By default, the effect is applied to
opaque areas of the drawing. When this option is enabled, the effect is applied to
transparent or empty areas of the drawing.
Instead of using the colour in the Colour parameters, this uses the colours in the
source drawing to generate the effect.

Use Source Colour

NOTE
The effect of this parameter is only visible in Render View

Multiplicative

mode.

Multiplies the colours of the effect with the colours of the background. This
intensifies the effect.

Colour
Red

The amount of red to add to the colour in the background image.

Green

The amount of green to add to the colour in the background image.
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Parameter

Description

Blue

The amount of blue to add to the colour in the background image.

Alpha

The alpha value of the effect.

Colour Swatch

Opens the Colour Picker dialog, in which you can visually select a colour for the
effect.

Intensity

Allows you to set the factor by which to multiply the intensity of the effect. This
parameter can take a decimal value between 0 and 1. At 1, the effect is fully
applied. At 0, the effect is not visible.
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Shadow Layer
With the Shadow effect, you can turn a drawing into a shadow. It doesn't matter if the drawing layer is a fully
coloured character. The Shadow effect will render it into a grey, semitransparent, slightly blurry silhouette. You
must clone your layer to see the original image displayed on top of the shadow.

Refer to the following example to connect this effect:

Properties
Parameter

Description

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no visible
effect on the rendered image, nor on the preview in the Camera, Side and Top
views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Allows you to enter a name for the node.

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.
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Parameter

Description

Allows you to choose between the following blur types for the effect:
l

Blur Type
l

Radius

Radial: The edges of the matte are blurred evenly around points that make
up the edge of the matte.
Directional: The matte is blurred in the direction configured with the
Directional Angle and Directional Falloff Rate parameters.

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.
If you set the Blur Type to Directional, this sets the angle of the blur. The value
goes from 0 to 360, with 0 meaning west, and angles going counterclockwise.
For example:

Directional Angle

l

0: Blurs the image to the west.

l

90: Blurs the image to the south.

l

180: Blurs the image to the east.

l

270: Blurs the image to the north.

The distance where the blur fades from the edge of the image. Select a decimal
value between 0 and 1. For example:
Directional Falloff Rate

l

l

Invert Matte

0: Makes the blur fade out slowly, distributing the blur evenly from the
edge of the character to the farthest edge of the blur.
1: Makes the blur fade out quickly. The blur is heaviest closer to the edge
of the image.

Inverts the matte used to generate the effect. By default, the effect is applied to
opaque areas of the drawing. When this option is enabled, the effect is applied to
transparent or empty areas of the drawing.
Instead of using the colour in the Colour parameters, this uses the colours in the
source drawing to generate the effect.

Use Source Colour

NOTE
The effect of this parameter is only visible in Render View

Multiplicative

mode.

Multiplies the colours of the effect with the colours of the background. This
intensifies the effect.
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Parameter

Description

Colour

Red

The amount of red to subtract from the colour in the background image. To obtain
a shadow effect, this value must be negative.

Green

The amount of green to subtract from the colour in the background image. To
obtain a shadow effect, this value must be negative.

Blue

The amount of blue to subtract from the colour in the background image. To
obtain a shadow effect, this value must be negative.

Alpha

The alpha value of the effect.

Colour Swatch

Opens the Colour Picker dialog, in which you can visually select a colour for the
effect.

Intensity

Allows you to set the factor by which to multiply the intensity of the effect. This
parameter can take a decimal value between 0 and 1. At 1, the effect is fully
applied. At 0, the effect is not visible.
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Transparency Layer
T-HFND-010-008
The Transparency effect is used to make an image partially transparent. The Transparency effect is useful
when fading images in and out, such as a phantom or to make something partially see-through, such as a
window.

Refer to the following example to connect this effect:

You can enter a value in the Transparency field or change the transparency value over time by linking it to a
function curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in
other words, invisible. Entering a value of 0 will render the element completely opaque.

Properties

Parameter

Description

Name

Allows you to enter a name for the node.

Transparency

Lets you set the opacity of an element. Values range from 0 to 100. A value of 100
will make the element 100% transparent and a value of 0 will render the element
completely opaque.
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Image Layers
Image layers generate an image that display in your scene's render. The drawing layer, which is the main type
of layer used in Harmony, generates an image based on the drawings in its element which are exposed at the
current frame. The Colour-Card simply fills the render area with a solid colour.
Colour-Card Layer

145

Drawing Layer

147
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Colour-Card Layer
T-ANIMPA-012-001
The Colour Card allows you to fill the scene's background with a solid colour when there is no background
image. If no drawing or colour-card is present to cover the scene's background, the scene will be rendered on a
pitch black canvas.

NOTE
By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card
behind all elements that have a value lower than 12 Backward. Most of the time, the Colour card
will appear automatically behind all the scene elements as they are all set to 0 Backward, unless
you have changed the Z ordering of the scene components. If so, the Colour Card will be in front of
the elements that are pushed back to more than 12 fields backward.

Connection
The Colour Card does not need to be connected to anything in your scene. It simply needs to be added to it
alongside your drawing layers and groups.

Because a Colour Card has a default position on the z-axis of 12 Backward, it will appear behind all the layers in
your scene regardless of whether or not it has layers underneath it.
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Layer Properties

Parameter

Description

Enable/Disable

Allows you to enable or disable the layer. When disabled, a layer has no visible
effect on the rendered image, nor on the preview in the Camera, Side and Top
views.

Colour Swatch

Sets the colour of the layer in the Timeline view.

Name

Allows you to enter a name for the node.

Depth

This parameter can be used to determine whether the colour card displays behind
or in front of elements with the same position on the z-axis.

Offset Z

The position of the Colour Card on the Z-axis. By default, this is set to 12 B to
ensure the Colour Card appears behind other elements in the scene. You can set
this to 0 F to make the Colour Card respect the order of the layers in the Timeline
view.

Colour

The colour and transparency of the Colour Card. You can also attach these
parameters to function columns to change their values over time.
Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch

Opens the Colour Picker window in which you can specify the colour.

Invert Matte

If an image is connected to the Colour Card's matte port, by default, the colour is
only applied on the opaque areas of the matte. If this parameter is enabled, the
colour is applied to the transparent areas of the matte instead.
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Drawing Layer
The Drawing layer is at the core of a scene's structure. A drawing layer is linked to an element, which contains
a series of drawing, and its Xsheet column, which indicates when and for how long each drawing is exposed.
The layer is what connects the element and its exposure to the rendered image. It indicates the position of the
drawings relative to other elements and to the stage, as well as the drawing's connections with pegs, groups
and effects, if any.
Although drawing layers can be transformed and animated on their own, it is typical to connect them under a
parent peg. This allows you to keep the position and animation information of the element in the peg, making it
easier to manipulate the exposure and the transformations separately. This is especially useful in digital cut-out
animation where manipulating and transforming layers is often the main method of simulating movement, and
changing drawings is the secondary method.

You can also connect a drawing layer as a child of another drawing layer. Just like with pegs, any
transformation done to the parent layer, whether on itself or through one of its parents, will also be applied to
the child layer.

Optionally, you can connect a matte drawing to a drawing layer. When a drawing layer has a matte drawing,
only the parts of the drawings that intersect with the opaque areas of the matte drawing will be rendered. This
allows you to accomplish the same effect as connecting the drawing layer to a cutter effect.
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Layer Properties
The drawing layer's properties are organized in the following tabs:
l

Transformation Tab

l

Drawing Tab

Transformation Tab
The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an
element.

Parameter

Position

Description
3D Path: Use a 3D path to position the element. A 3D path uses a single function
to define the position on the X, Y and Z axes. This function is made of control
points linked by a curvilinear path, making the movement follow a natural curve.
The pace and ease of the movement is determined by a single velocity function.
Separate: Positions the element using separate functions for the X, Y and Z axes.
This allows to control the direction and pace of the movement across all three
axes separately. Unless ease is applied to the axes, the trajectory of the element
will follow straight lines going between each keyframe.
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Path: If the 3D Path option is selected, this field allows you to create or select the
3D Path function used to position the element.
Path (x) Axis: The position of the element on the East-West axis, in fields.
Path (y) Axis: The position of the element on the South-North axis, in fields.
Path (z) Axis: The position of the element in the Back-Front axis, in fields.
Velocity: If the 3D Path option is selected, this function is used to control the
pace at which the element moves towards each control point in the 3D Path
function, on all three axes simultaneously.

Scale

Locked: Uses a single scale parameter to scale the element, preserving its
proportions.
Separate: Uses a separate parameter to scale the element on the X and Y axis,
allowing to stretch or squash the element.
(x) Axis: The horizontal scale factor. The default value is 1.
(y) Axis: The vertical scale factor. The default value is 1.

Rotation

Angle z: The angle at which the element is rotated, based on the 360 degrees
scale. Values below 0 or above 360 degrees will cause the rotation to cycle.

Skew

Skew: The angle at which the element is skewed. This value can range from -90
to 90 degrees.
(x) Axis: The horizontal position of the pivot point of the element relative to the
pivot point of the drawing, in fields.
(y) Axis: The vertical position of the pivot point of the element relative to the pivot
point of the drawing, in fields.

Pivot

NOTE
These parameters can be changed visually by clicking and dragging the
pivot point when using on of the tools in the Advanced Animation toolbar.

Drawing Tab
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Parameter

Description

Matte

Invert Matte: If a drawing, group or effect is added to the drawing's Matte
attribute, the part of the drawing that intersect with the matte's opaque areas will
be cut out by default. If this parameter is enabled, the part of the drawing that
intersect with the matte's transparent areas will be cut out instead.
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Move Layers
Move layers are used to animate layers as well as camera motions.
Camera Layer

152

Peg Layer

153

Quadmap Layer

155
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Camera Layer
You can setup the camera position by entering coordinates and values in the Layer Properties view.

Parameter

Description

Enable/Disable

Turns the camera layer on or off.

Change Track Colour

The Change Track Colour button lets you change the colour of the exposed
frames; this helps you to quickly locate a layer in the Timeline view. Click the
Change Track Colour button to open the Select Colour window and choose a new
colour. You can modify the colour for any type of layer, such as group, peg,
drawing, and effects.

Name

Displays the current layer name. You can rename the layer by typing in a new layer
name.

Position

Displays the current position of the camera layer using X-axis (East/West), Y-axis
(North/South) and Z-axis (Forward/Backward) coordinates. To reposition your
camera frame, type in the new values corresponding to the desired position
coordinates. You can also use the up and down arrows to set the value of each
field.

Angle

Displays the current rotation value. To set a new rotation position, type in a new
angle value. You can also use the up and down arrows to set the new angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. The camera
will perform a rotation taking the position of the pivot as its angle centre. By
default, the pivot is set at the centre of the camera frame. To reposition the pivot
point, enter new X and Y coordinates values in the appropriate field. To see the
pivot's position, the Rotate tool must be selected.
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Peg Layer
Find below a description of all the Peg node parameters.

Transformation Tab
Parameter

Description
3D Path: Use a 3D path to position the element. A 3D path uses a single function
to define the position on the X, Y and Z axes. This function is made of control
points linked by a curvilinear path, making the movement follow a natural curve.
The pace and ease of the movement is determined by a single velocity function.
Separate: Positions the element using separate functions for the X, Y and Z axes.
This allows to control the direction and pace of the movement across all three
axes separately. Unless ease is applied to the axes, the trajectory of the element
will follow straight lines going between each keyframe.

Position

Path: If the 3D Path option is selected, this field allows you to create or select the
3D Path function used to position the element.
Path (x) Axis: The position of the element on the East-West axis, in fields.
Path (y) Axis: The position of the element on the South-North axis, in fields.
Path (z) Axis: The position of the element in the Back-Front axis, in fields.
Velocity: If the 3D Path option is selected, this function is used to control the
pace at which the element moves towards each control point in the 3D Path
function, on all three axes simultaneously.
Locked: Uses a single scale parameter to scale the element, preserving its
proportions.

Scale

Separate: Uses a separate parameter to scale the element on the X and Y axis,
allowing to stretch or squash the element.
(x) Axis: The horizontal scale factor. The default value is 1.
(y) Axis: The vertical scale factor. The default value is 1.

Rotation

Angle z: Lets you type in a degree value for the rotation angle. Note that you can
enter values greater than 360 and -360 degrees. If you enter 720, the object will
rotate twice.

Skew

Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: The horizontal position of the pivot point of the element relative to the
pivot point of the drawing, in fields.
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(y) Axis: The vertical position of the pivot point of the element relative to the pivot
point of the drawing, in fields.
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Quadmap Layer
T-COMP2-010-001
The Quadmap transformation layer lets you deform the shape of an element. For example, you can use it to
create a drop-shadow effect on an element.

You can edit the Quadmap visually in the Camera view.

How to edit the Quadmap in the Camera view
1. In the Timeline view, click the Add Layer

button and select Quadmap.

2. Connect the drawing you want to deformto the Quadmap.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire
duration of the element.
4. In the Timeline view, click on the Quadmap layer to select it.
5. From the top menu, select View > Show > Control or pressShift + F11.
The quadmap handles appear around the element in the window. There is also a pivot point at the
centre of the quadmap frame that you can reposition.
6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift +
click to select multiple points.
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TIP
The position of the points can be animated. To do this, open the Quadmap layer layer properties
and create functions for each of the coordinates.

Properties

Parameter

Description

Name

Lets you rename the node.

2D Path

Changes the X and Y values simultaneously and control the velocity of the
change.
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Separate

Changes the X and Y values separately. Each one can be attached to separate
function curves.
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Sound Layer
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view.

If you double-click on a sound layer in the Timeline view, or in a sound column in the Xsheet view, the Sound
Element Editor dialog will open. This dialog allows you to fine-tune the sound track's lip sync, start time, stop
time and volume.
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Chapter 4: Tools Properties
Harmony has a wide variety of drawing and manipulation tools and each one of them has a series of options
and modes available in the Tool Properties view. This section covers these options.

Brush Tool Properties

162

Centerline Editor Tool Properties

168

Close Gap Tool Properties

169

Contour Editor Tool Properties

170

Cutter Tool Properties

172

Ellipse Tool Properties

174

Envelope Tool Properties

177

Eraser Tool Properties

180

Line Tool Properties

185

Paint Tool Properties

188

Pencil Tool Properties

191

Perspective Tool Properties

195

Polyline Tool Properties

197

Rectangle Tool Properties

201

Reposition All Drawings Tool Properties

204

Rigging Tool Properties

206

Select Tool Properties

207

Smooth Editor Tool Properties

213

Stroke Tool Properties

215

160

Harmony 15.0 Essentials Reference Guide

Text Tool Properties

217

Transform Tool Properties

220

Zoom Tool Properties

223
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Brush Tool Properties
When you select the Brush

tool, its properties and options appears in the Tool Properties view.

Brush Properties
The following properties affect the brush's size, smoothing and other properties for the drawing style of your
brush. Those properties can be saved into brush presets for later use.
Icon

Property

Description
The Preview area lets you see a preview of the stroke your drawing tool
will make.

Preview Area

The arrow button right of the preview area opens the Brush Properties
dialog.

Brush Properties Dialog
While the Tool Properties view only gives you access to a few of the
brush properties, a list of brush presets and other drawing options, the
Brush Properties dialog gives you access to all the available options for
your brush's tip and texture. For more information on
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the Pencil Properties dialog, see the Brush Properties Dialogsection
below.
Defines the maximum width of brush strokes.
Maximum Size

If the tool is used with a pressure sensitive pen tablet, the width of the
stroke will vary between its maximum size and minimum size depending
on the amount of pressure used. If used with a mouse, the width of the
stroke will always be its maximum size.
Defines the number of control points added to the centre line. The fewer
the control points the smoother (but less faithful) the line.

Smoothing

NOTE
This option is only available when drawing on a vector layer.

Brush Presets
These options allow you to select, create and manage pencil presets.
Icon

Property

Description
By default, Harmony has preloaded brush presets. You can also create
your own brush presets by configuring your brush, then saving its
properties into a new preset. It is also possible to export and import brush
presets.

Presets list

New Brush Preset

Creates a new preset based on the current brush properties.

Delete Brush

Deletes the currently selected preset.

Rename Brush

Deletes the currently selected preset.
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Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail

Displays presets in a grid of small thumbnails with a preview of their tip.

Large Thumbnail

Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

Stroke View

Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.

Drawing Options
These options affect the way your drawing strokes are integrated into your artwork.
Icon

Property

Description
When enabled, your brush strokes will appear behind the existing
artwork. Note that they will appear over your artwork while drawing your
stroke, until you release the brush.

Draw Behind

When enabled, your brush strokes will only repaint existing artwork and
will not add colour to empty areas. If you repaint semi-transparent
artwork, your artwork will not become more opaque than it already is.
Repaint Brush

Auto-Flatten Mode

By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
strokes into existing artwork.
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Brush Properties Dialog
Brushes have an extensive set of options and properties that are not displayed in the Tool Properties view, but
rather, in a dialog you can access from it. To open the Brush Properties dialog, click on the arrow button right of
the stroke display area.

Tip Tab
The Tip tab allows you to configure the shape, size, hardness and spacing of your brush tip.

Property

Description
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Brush Tip Library

This is where you select the shape of the brush tip. By default it is round.
The minimum and maximum sizes of your drawing tool produce the thick and
thin effect on your stroke. This works with the pressure sensitivity of a pen
tablet.
l

l

Minimum and Maximum Size

Maximum Size: Defines the maximum width of the stroke.
Minimum Size: Defines the minimum width of the stroke in relation to
and as a percentage of the maximum size.

NOTE
Setting the Minimum Size value to 100% eliminates the possibility of
creating width variation on your stroke. In other words, you would be
forcing a uniform line width using the Maximum Size value.

The Roundness and Angle parameters allow you to change the shape and
orientation of the tip.
l

Roundness and Angle
l

Roundness: Squashes the height of the tip from its centre point. 100%
roundness = the native height of the tip. A smaller percentage will make
the brush tip look flatter and more narrow. The squashing is NOT relative
to the angle value—if the tip is rotated, the squashing function still uses
the brush tip's original orientation.
Angle: Rotates the brush tip counter-clockwise. 0° = the tip's native
orientation.

Smoothing Tab
The Smoothing tab contains options to configure how Harmony should automatically smooth your brush
strokes as you paint.
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Property

Description

Centerline Smoothing

Defines the amount of smoothing Harmony should perform on your brush stroke's
direction, curves and corners. A higher setting will prevent your line from being
shaky, but is liable to reduce drawing precision and turn sharp angles into curves.

Contour Smoothing

Defines the amount of smoothing Harmony should perform on outer contour of the
brush stroke. A higher setting will round sharp corners and reduce the amount of
control points for the resulting vector shape.
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Centerline Editor Tool Properties
When you select the Centerline Editor tool, its properties and options appear in the Tool Properties view.

Tool Options
Icon

Property

Description
Sets the selection mode to Lasso, which allows you to select
multiple items by drawing a lasso around them.

Lasso

TIP
When this option is enabled, you can press and hold the
Alt key to temporarily use Marquee mode.

Sets the selection mode to Marquee, which allows you to select
multiple items by drawing a rectangle around them.
Marquee

TIP
When this option is enabled, you can press and hold the
Alt key to temporarily use Lasso mode.

When enabled, selecting several control points will make a
manipulator bounding box appear. You can use this manipulator
to scale and rotate the selection of points.

Show Centerline Editor Controls
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Close Gap Tool Properties
When you select the Close Gap tool, its properties and options appears in the Tool Properties view.

Tool Options
Icon

Property

Description

Auto-Flatten Mode

By default, when drawing, each new stroke is created
as a separate drawing object, which can be edited
independently from other parts of the artwork. When
enabled, the Auto-Flatten option automatically
merges strokes into existing artwork.
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Contour Editor Tool Properties
When you select the Contour Editor tool, its properties and options appear in the Tool Properties view.

Tool Options
Icon

Property

Description
Sets the selection mode to Lasso, which allows you to select multiple
items by drawing a lasso around them.

Lasso

TIP
When this option is enabled, you can press and hold the Alt
key to temporarily use Marquee mode.

Sets the selection mode to Marquee, which allows you to select
multiple items by drawing a rectangle around them.
Marquee

TIP
When this option is enabled, you can press and hold the Alt
key to temporarily use Lasso mode.

Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will
snap to it.
Snap to Contour

Snap and Align

Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point
to.
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When enabled, selecting several control points will make a manipulator
bounding box appear. You can use this manipulator to scale and rotate
the selection of points.

Show Contour Editor
Controls

Operations
Icon

Property

Description
The Smooth operation lets you smooth out selected drawing strokes
and remove extra points.
l

From the top menu, select Drawing> Optimize > Smooth or
press Alt + Shift + S.

Smooth Selection
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Cutter Tool Properties
When you select the Cutter tool, its properties and options appear in the Tool Properties view.

Tool Options
Icon

Property

Description
Sets the selection mode to Lasso, which allows you to select multiple items by
drawing a lasso around them.

Lasso

TIP
When this option is enabled, you can press and hold the Alt key to
temporarily use Marquee mode.

Sets the selection mode to Marquee, which allows you to select multiple items
by drawing a rectangle around them.
Marquee

TIP
When this option is enabled, you can press and hold the Alt key to
temporarily use Lasso mode.

When using the Lasso selection type, the Use Mouse Gesture option lets you
automatically delete any extra sections of line in your artwork by simply dragging
your mouse over it.

NOTE
Use Mouse
Gesture

For this operation to work, you lines CANNOT be flattened.
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Operations
Icon

Property

Description

Flip Horizontal

Flips the current selection horizontally.

Flip Vertical

Flips the current selection vertically.

Rotate 90 Degrees
CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees
CCW

Rotates the current selection 90 degrees counter-clockwise.

173

Chapter 4: Tools Properties

Ellipse Tool Properties
When you select the Ellipse tool, its properties and options appear in the Tool Properties view.

Icon

Tool Name

Description

Size

Defines the width of the pencil line used to draw the circle.

Presets

Harmony provides a variety of presets and also lets you create and save
your own. It is a good idea to create and save pencils with precise sizes
and parameters when you draw and design for efficiency and
consistency.
All tools using pencil lines share the same preset list. Therefore, the
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset
list.

New Brush

Creates a new preset based on the current brush properties.
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Delete Brush

Deletes the currently selected preset.

Rename Brush

Deletes the currently selected preset.

Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail, Large
Thumbnail, and Stroke
View

Allows you to display the presets as small square thumbnails, large
square thumbnails or a list of stroke preview.

When enabled, your brush strokes will appear behind the existing
artwork. Note that they will appear over your artwork while drawing your
stroke, until you release the brush.
Draw Behind

Use the Automatic Filling option to automatically fill your shape with the
selected colour as you draw. By default, the Shape tool creates the outline
of an empty shape that you can later fill using the Paint tool. This option
is unavailable for the line tool.
Automatic Filling

Snap to Contour

Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will snap
to it.

Snap and Align

Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid.
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By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
strokes into existing artwork.

Auto-Flatten Mode

NOTE
Using the Select tool, you can use select and remove a segment
of flattened pencil lines. Overlapping pencil lines drawn with the
Auto-Flatten mode are essentially cut into segments by the
overlap and can be treated as individual lines.
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Envelope Tool Properties
Selecting the Envelope tool displays its properties and options in the Tool Properties view.

Icon

Tool Name

Description
Increase the width and height values to add more
columns and rows to the deformation grids.

Width and Height

Sets the selection mode to Lasso, which allows you to
select multiple items by drawing a lasso around them.

TIP

Lasso

When this option is enabled, you can press
and hold the Alt key to temporarily use
Marquee mode.

Sets the selection mode to Marquee, which allows you
to select multiple items by drawing a rectangle around
them.

Marquee
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TIP
When this option is enabled, you can press
and hold the Alt key to temporarily use
Lasso mode.

Snap to Contour

Snaps your selection or point to any line you position
it on. As soon as you move it close enough to another
line, your point or selection will snap to it.

Snap and Align

Snaps the selected anchor point to any existing line
while displaying temporary rulers as a guide that you
can also snap your anchor point to.
Snaps your selection following the currently enabled
grid.

Snap to Grid

To display more controls,you can click on the Show
Advanced Controls button.

Show Advanced Controls

Flip Horizontal

Flips the current selection horizontally.

Flip Vertical

Flips the current selection vertically.
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Rotate 90 Degrees CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW

Rotates the current selection 90 degrees counterclockwise.
You can modify the central line smoothness of your
line using this option. This parameter smooths the
deformed lines. Increasing the value will result in a
smoother line with fewer control points. The more you

Smooth

increase the value, the less details and curves you will
get. Use the left and right arrows to increment the
value by one full unit. Use the Up - Down slider to
quickly increment the value.
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Eraser Tool Properties
When you select the Eraser

tool, its properties and options appear in the Tool Properties view.

The Eraser tool properties are almost identical to the Brush tool properties.

Icon

Tool Name

Description
The Preview area lets you see a preview of the stroke your drawing tool
will make.

Stroke Preview Area

Eraser Properties
Dialog

The arrow button right of the display area opens the Eraser Properties
dialog, which gives you access to all the parameters and options for your
eraser. The Tool Properties view only gives you access to a few of the
eraser properties, a list of eraser presets and options for the Eraser tool
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that are not related to the eraser properties. For more information on
the Eraser Properties dialog, see the Eraser Tool Properties section below.

Defines the maximum size of the eraser.
Maximum Size

Smoothing

Flow

If the tool is used with a pressure sensitive pen tablet, the width of the
stroke will vary between its maximum size and minimum size depending
on the amount of pressure used. If used with a mouse, the width of the
stroke will always be its maximum size.
Defines the number of control points added to the centre line. The fewer
the control points the smoother (but less faithful) the line.
Lets you set the opacity for each instance of the eraser tip that gets erased
from your artwork. Contrary to the Opacity parameter, the flow parameter
has a cumulative effect. This means that a lower flow will make your
eraser strokes less effective towards its extremities and more effective in
its center. Your stroke's flow will also accumulate if you draw over it. By
default, your eraser's flow varies with the amount of pressure you put on
your tablet pen.

NOTE
This option is only displayed in the Tool Properties view when
drawing on a bitmap layer.

Opacity

The Opacity parameter are where Lets you set the opacity of your brush
strokes. Contrary to the Flow parameter, the Opacity parameter is noncumulative. Your whole brush stroke's opacity will not exceed the Opacity
parameter. By default, the Opacity parameter varies depending on the
amount of pressure you put on your tablet pen.

NOTE
This option is only displayed in the Tool Properties view when
drawing on a bitmap layer.

New Eraser

Creates a new preset based on the current eraser properties.
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Delete Eraser

Deletes the currently selected preset.

Rename Eraser

Deletes the currently selected preset.

Import Erasers

Allows you to import brush presets exported from Harmony.

Export Erasers

Allows you to export your brush presets into an .xml file.

Small Thumbnail, Large
Thumbnail, and Stroke
View

Allows you to display the presets as small square thumbnails, large
square thumbnails or a list of stroke preview.

Eraser Properties Dialog
Erasers have an extensive set of options and properties that are not displayed in the Tool Properties view, but
rather, in a dialog you can access from it. To open the Eraser Properties dialog, click on the arrow button right of
the stroke display area.

The Eraser Properties dialog has two tabs. Below is detailed information about the options available in each
tab:
l

Tip Tab on page 182

l

Smoothing Tab on page 184

Tip Tab
The Tip tab allows you to configure the shape, size, hardness and spacing of your eraser tip.
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Tool Name

Description

Eraser Tip Library

This is where you select the shape of the eraser tip. By default, it is
round.
The minimum and maximum sizes of your drawing tool produce the
thick and thin effect on your stroke. This works with the pressure
sensitivity of a pen tablet.
l

l

Minimum and Maximum Size

Maximum Size: Defines the maximum width of the stroke.
Minimum Size: Defines the minimum width of the stroke in
relation to and as a percentage of the maximum size.

NOTE
Setting the Minimum Size value to 100% eliminates the
possibility of creating width variation on your stroke. In
other words, you would be forcing a uniform line width
using the Maximum Size value.
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The Roundness and Angle parameters allow you to change the
shape and orientation of the tip.
l

Roundness and Angle
l

Roundness: Squashes the height of the tip from its centre
point. 100% roundness = the native height of the tip. A
smaller percentage will make the brush tip look flatter and
more narrow. The squashing is NOT relative to the angle
value—if the tip is rotated, the squashing function still uses
the brush tip's original orientation.
Angle: Rotates the brush tip counter-clockwise. 0° = the
tip's native orientation.

Smoothing Tab
The Smoothing tab contains options to configure how Harmony should automatically smooth your eraser
strokes as you paint.

Tool Name

Description

Centerline Smoothing

Defines the amount of smoothing Harmony should perform on your eraser stroke's
direction, curves and corners. A higher setting will prevent your line from being
shaky, but is liable to reduce drawing precision and turn sharp angles into curves.

Contour Smoothing

Defines the amount of smoothing Harmony should perform on outer contour of the
eraser stroke. A higher setting will round sharp corners and reduce the amount of
control points for the resulting vector shape.
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Line Tool Properties
When you select the Line tool, its properties and options appear in the Tool Properties view.

Icon

Tool Name

Description

Size

Defines the width of the pencil line used to draw the line.

Presets

Harmony provides a variety of presets and also lets you create and save
your own. It is a good idea to create and save pencils with precise sizes
and parameters when you draw and design for efficiency and
consistency.
All tools using pencil lines share the same preset list. Therefore, the
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset
list.

New Brush

Creates a new preset based on the current brush properties.

Delete Brush

Deletes the currently selected preset.
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Rename Brush

Deletes the currently selected preset.

Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail, Large
Thumbnail, and Stroke
View

Allows you to display the presets as small square thumbnails, large
square thumbnails or a list of stroke preview.

When enabled, your brush strokes will appear behind the existing
artwork. Note that they will appear over your artwork while drawing your
stroke, until you release the brush.
Draw Behind

Snap to Contour

Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will snap
to it.

Snap and Align

Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.
Snaps your selection following the currently enabled grid.

Snap to Grid

Auto-Flatten Mode

By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
strokes into existing artwork.
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NOTE
Using the Select tool, you can use select and remove a segment
of flattened pencil lines. Overlapping pencil lines drawn with the
Auto-Flatten mode are essentially cut into segments by the
overlap and can be treated as individual lines.

When using the pencil tool, you can automatically close strokes with an
invisible stroke.

Auto-Close Gap

It is recommended to keep this option enabled when drawing with the
Pencil tool.
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Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.

Icon

Tool Name

Description
Sets the selection mode to Lasso, which allows you to
select multiple items by drawing a lasso around them.

TIP

Lasso

When this option is enabled, you can press
and hold the Alt key to temporarily use
Marquee mode.

Sets the selection mode to Marquee, which allows you
to select multiple items by drawing a rectangle around
them.
Marquee

TIP
When this option is enabled, you can press
and hold the Alt key to temporarily use
Lasso mode.

The Paint tool has three different modes available:
l

Paint Modes

l

l

The Paint mode paints everything it touches,
including empty and filled zones.
The Paint Unpainted mode paints only empty
zones. Any line or filled zone will remain
unchanged.
The Unpaint mode unpaints everything it
touches, including empty and filled zones.

The Apply to Multiple Drawings option is used for fast
painting in hand-drawn animation. When you want to

Apply to Multiple
Drawings
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paint several drawings in a same layer at once, such as
a walk cycle, you can enable this option and make a
selection in the Camera or Drawing view. All the
closed zones located within your Paint tool selection
are painted with the selected colour swatch.

You do not need to enable the Onion Skin preview to
use this option. The option will stay enabled only for
the next action. If you want to use it again, you must
click on the Apply to Multiple Drawings button again,
or press Alt + A.
In the Paint tool properties, this option keeps a
selection highlighted around the latest painted zone
after using the Paint, Unpaint, or Paint Unpainted tool.

Select Newly Painted, and
Unpainted
Contours/Lines

The Close Gap option has four modes available. When
the option is enabled, Harmony will consume more
resources while painting.

Close Gap
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l

l

l

l
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No Close Gap: The moment a zone has a gap in
it, the Paint tool will not fill the area.
Close Small Gap: If a zone has a small gap in it,
the Paint tool will fill the area. You can zoom
out to make the gap appear smaller and the
Paint tool will paint.
Close Medium Gap: If a zone has a medium gap
in it, the Paint tool will fill the area. You can
zoom out to make the gap appear smaller and
the Paint tool will paint.
Close Large Gap: If a zone has a large gap in it,
the Paint tool will fill the area. You can zoom
out to make the gap appear smaller and the
Paint tool will paint.
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Pencil Tool Properties
When you select the Pencil

tool, its properties and options appears in the Tool Properties view.

Pencil Properties
The following properties affect the pencil's width and smoothing. Those properties can be saved into pencil
presets for later use.
Icon

Tool Name

Description
The Preview area lets you see a preview of the stroke your drawing tool
will make.

Preview Area
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Size

Defines the width of the pencil line.

Smoothing

Defines the number of control points added to the centre line. The fewer
the control points the smoother (but less faithful) the line.

Pencil Presets
These options allow you to select, create and manage pencil presets.
Icon

Tool Name

Description

Presets list

Harmony provides a variety of pencil presets and also lets you create and
save your own. It is a good idea to create and save pencils with precise
sizes and parameters when you draw and design for efficiency and
consistency.
You can export the pencil presets that you have created and import those
that others have created. This is a good way for you and project
collaborators to keep a consistent look for the project.

New Preset

Creates a new preset based on the current brush properties.

Delete Preset

Deletes the currently selected preset.

Presets Menu

Gives access to more options for managing presets.

Rename Brush

Deletes the currently selected preset.

Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail

Displays presets in a grid of small thumbnails with a preview of their tip.

Large Thumbnail

Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

Stroke View

Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.
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Drawing Options
These options affect the way your drawing strokes are integrated into your artwork.
When enabled, your brush strokes will appear behind the existing
artwork. Note that they will appear over your artwork while drawing your
stroke, until you release the brush.
Draw Behind

When enabled, drawing a closed shape will automatically fill it with the
currently selected colour.
Auto Fill

When enabled, drawing a closed shape will automatically remove the
outstanding lines.
Trim Extra Lines

When the Trim Extra Lines option is enabled, enable this option to make
the point where the beginning and end of the stroke meet into a smooth
curve rather than a hard corner.

Align Handles After
Trim

Auto-Flatten Mode

By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
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strokes into existing artwork.

NOTE
Using the Select tool, you can use select and remove a segment
of flattened pencil lines. Overlapping pencil lines drawn with the
Auto-Flatten mode are essentially cut into segments by the
overlap and can be treated as individual lines.
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Perspective Tool Properties
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Icon

Tool Name

Description

Selection Tool Options
Sets the selection mode to Lasso, which allows you to
select multiple items by drawing a lasso around them.

TIP

Lasso

When this option is enabled, you can press
and hold the Alt key to temporarily use
Marquee mode.

Sets the selection mode to Marquee, which allows you
to select multiple items by drawing a rectangle around
them.
Marquee

TIP
When this option is enabled, you can press
and hold the Alt key to temporarily use
Lasso mode.

Snap to Contour

Snaps your selection or point to any line you position
it on. As soon as you move it close enough to another
line, your point or selection will snap to it.

Snap and Align

Snaps the selected anchor point to any existing line
while displaying temporary rulers as a guide that you
can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled
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grid.

Flip Horizontal

Flips the current selection horizontally.

Flip Vertical

Flips the current selection vertically.

Rotate 90 Degrees CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW

Rotates the current selection 90 degrees counterclockwise.
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Polyline Tool Properties
When you select the Polyline tool, its properties and options appear in the Tool Properties view.
NOTE
Like other shape tools, the Polyline tool creates pencil lines. Hence, its tool properties are similar to
the ones of the Pencil tool and it can be used with pencil presets.

Pencil Properties
Icon

Property

Description
The Preview area lets you see a preview of the stroke your drawing tool
will make.

Preview Area
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The arrow button right of the preview area opens the Pencil Properties
dialog.

Pencil Properties
Dialog

While the Tool Properties view only gives you access to the pencil size, a
list of pencil presets and other drawing options, the Pencil Properties
dialog gives you access to all the available options for your pencil's shape
and texture. For more information on the Pencil Properties dialog, see the
Polyline Tool Properties section below.

Size

Defines the width of the pencil line used to draw the shape.

Pencil Presets
Icon

Property

Description
Harmony provides a variety of presets and also lets you create and save
your own. It is a good idea to create and save pencils with precise sizes
and parameters when you draw and design for efficiency and

Presets list

consistency.
All tools using pencil lines share the same preset list. Therefore, the
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset
list.

New Preset

Creates a new preset based on the current brush properties.

Delete Preset

Deletes the currently selected preset.

Presets Menu

Gives access to more options for managing presets.

Rename Brush

Deletes the currently selected preset.

Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail

Displays presets in a grid of small thumbnails with a preview of their tip.
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Large Thumbnail

Displays presets in a grid of big thumbnails, with their name and a
preview of their tip.

Stroke View

Displays presets in a list, with their name and a preview of a stroke done
with each preset. This is the default setting.

Drawing Options
Icon

Property

Description

Snap to Contour

Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will snap
to it.
When enabled, drawing a closed shape will automatically fill it with the
currently selected colour.

Auto Fill

When enabled, drawing a closed shape will automatically remove the
outstanding lines.
Trim Extra Lines

When the Trim Extra Lines option is enabled, enable this option to make
the point where the beginning and end of the stroke meet into a smooth
curve rather than a hard corner.
Align Handles After
Trim
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By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
strokes into existing artwork.

Auto-Flatten Mode

NOTE
Using the Select tool, you can use select and remove a segment
of flattened pencil lines. Overlapping pencil lines drawn with the
Auto-Flatten mode are essentially cut into segments by the
overlap and can be treated as individual lines.
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Rectangle Tool Properties
When you select the Rectangle tool, its properties and options appear in the Tool Properties view.

Icon

Tool Name

Description

Size

Defines the width of the pencil line used to draw the rectangle.

Presets

Harmony provides a variety of presets and also lets you create and save
your own. It is a good idea to create and save pencils with precise sizes
and parameters when you draw and design for efficiency and
consistency.
All tools using pencil lines share the same preset list. Therefore, the
Polyline, Line, Rectangle, Ellipse, and Pencil tools share the same preset
list.

New Brush

Creates a new preset based on the current brush properties.

201

Chapter 4: Tools Properties

Delete Brush

Deletes the currently selected preset.

Rename Brush

Deletes the currently selected preset.

Import Brushes

Allows you to import brush presets exported from Harmony.

Export Brushes

Allows you to export your brush presets into an .xml file.

Small Thumbnail, Large
Thumbnail, and Stroke
View

Allows you to display the presets as small square thumbnails, large
square thumbnails or a list of stroke preview.

When enabled, your brush strokes will appear behind the existing
artwork. Note that they will appear over your artwork while drawing your
stroke, until you release the brush.
Draw Behind

Use the Automatic Filling option to automatically fill your shape with the
selected colour as you draw. By default, the Shape tool creates the outline
of an empty shape that you can later fill using the Paint tool. This option
is unavailable for the line tool.
Automatic Filling

Snap to Contour

Snaps your selection or point to any line you position it on. As soon as
you move it close enough to another line, your point or selection will snap
to it.

Snap and Align

Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.

Snap to Grid

Snaps your selection following the currently enabled grid.
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By default, when drawing, each new stroke is created as a separate
drawing object, which can be edited independently from other parts of
the artwork. When enabled, the Auto-Flatten option automatically merges
strokes into existing artwork.

Auto-Flatten Mode

NOTE
Using the Select tool, you can use select and remove a segment
of flattened pencil lines. Overlapping pencil lines drawn with the
Auto-Flatten mode are essentially cut into segments by the
overlap and can be treated as individual lines.
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Reposition All Drawings Tool Properties
When you use the Reposition All Drawings tool, its properties and options appear in the Tool Properties view.

Icon

Option

Description

Flip Horizontal

Flips the current selection horizontally.

Flip Vertical

Flips the current selection vertically.

Rotate 90 Degrees CW

Rotates the current selection 90 degrees
clockwise.

Rotate 90 Degrees CCW

Rotates the current selection 90 degrees
counter-clockwise.
Use the Offset X and Offset Y operation fields
to enter specific values and precisely
reposition the selected shape.

Offset X and Y
1. X: Type a value in this field to
reposition your selection along the Xaxis.
2. Y: Type a value in this field to
reposition your selection along the Y-
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axis.
3. Up/Down arrows: Use the up and
down arrows to modify the value in the
X or Y value field.
Use the Width and Height operation fields to
enter specific values to resize the selected
shape with precision.

1. Width: Type a value in this field to
resize the width of your selection.

Width and Height

2. Height: Type a value in this field to
resize the height of your selection.
3. Up/Down arrows: Use the up and
down arrows to modify the value in the
Width or Height fields.
4. Lock icon: Click the lock icon to lock or
unlock the ratio between the Width
and Height values.
The Angle operation lets you to enter specific
values and accurately rotate the selected
shape.

Angle

1. Angle: Type a degree value in this field
to rotate your selection.
2. Up/Down arrows: Use the up and
down arrows to modify the value in the
Angle value field.
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Rigging Tool Properties
In the Tool Properties view, you can customize not only the behaviour of the tool but also the settings of the
deformers that you will create.

Mode
Name

Button

Description

Bone Mode

Sets the Rigging tool to create Bone deformers.

Game Bone Mode

Sets the Rigging tool to create Game Bone deformers.

Options
Parameter

Button

Show All Manipulators
(Show All Controls)

Description
Lets you immediately see the resting position in red (Setup) and
the animated position in green.

Operations
Name
Reset Deform (Reset
Current Keyframe)

Button

Description
Copies the resting position of the deformation skeleton to
the current frame.
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Select Tool Properties
When you use the Select tool, its properties and options appear in the Tool Properties view.

Tool Options
Icon

Tool Name

Description
Sets the selection mode to Lasso, which allows you to
select multiple items by drawing a lasso around them.

TIP

Lasso

When this option is enabled, you can press
and hold the Alt key to temporarily use
Marquee mode.

Sets the selection mode to Marquee, which allows you
to select multiple items by drawing a rectangle around
them.
Marquee

TIP
When this option is enabled, you can press
and hold the Alt key to temporarily use
Lasso mode.

Snap to Contour

Snaps your selection or point to any line you position
it on. As soon as you move it close enough to another
line, your point or selection will snap to it.

Snap and Align

Snaps the selected anchor point to any existing line
while displaying temporary rulers as a guide that you
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can also snap your anchor point to.
Snaps your selection following the currently enabled
grid.

Snap to Grid

Lets you select all the zones and lines in your drawing
painted with the same colour swatch.

Select by Colour
In the Camera or Drawing view, click on any zone or
line in your drawing. All zones and lines of the same
colour are selected. Click the Select tool again to return
to the regular Select mode.

NOTE
Only the zones painted with the SAME
colour swatch will be selected. If another
zone is coloured with the exact same RGB
value (same colour), but not painted with the
same colour swatch, it will not be selected.

By default, when you draw a selection box in the
Camera view, the Select tool will select only the
drawing strokes of the current drawing. If you prefer
the Select tool to select all the strokes on all layers,

Works on Single Drawing
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you can disable the Works on Single Drawing option
in the Tool Properties view or disable the Select tool
Works on Single Drawing preference. To do this, go to
the top menu, select Edit > Preferences > Camera
(Windows/Linux) or Harmony Essentials >
Preferences > Camera (macOS) and uncheck the
Select tool Works on Single Drawing option.

Operations
Icon

Tool Name

Description

Flip Horizontal

Flips the current selection horizontally.

Flip Vertical

Flips the current selection vertically.

Rotate 90 Degrees CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW

Rotates the current selection 90 degrees counterclockwise.
Smooth out selected drawing strokes and remove
extra points.

Smooth

Merges drawing objects and brush strokes into a
single layer. If you draw new lines to fix a drawing or
line with many brush strokes, it can be useful to flatten
them all into a single shape. By default, lines are drawn

Flatten
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one on top of each other. If you intend to repaint the
lines or modify their shape, it will be easier if they are
flattened.

Lets you use the outline you traced on one of the four
embedded layers (line art, colour art, overlay, underlay)
and create invisible strokes to paint your drawings on
separate layers. This provides more inking and
painting flexibility.

Create Colour Art from
Line Art

You can also configure this option to create the
invisible strokes on any of the four embedded layers.
The Distribute to Layers option is used to separate the
selected art strokes and send them to new drawing
layers. In the Camera view, once you have drawn your
artwork, you can select the strokes you want to
distribute using the Select tool and click on the
Distribute to Layers button; you can also select
Drawing > Distribute to Layers. It will automatically
take every stroke from the drawing selection made in
the Camera view and separate them into a different
layer for each. If an artwork is composed of several
strokes, you must group them using Edit > Group >
Group before using the Distribute to Layers option.
This option cannot be done from the Drawing view.

Distribute to Layers

Converts the selected centre line pencil strokes into
contour strokes brush lines.

Pencil to Brush
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Use the Offset X and Offset Y operation fields to enter
specific values and precisely reposition the selected
shape.

Offset X and Y

1. X: Type a value in this field to reposition your
selection along the X-axis.
2. Y: Type a value in this field to reposition your
selection along the Y-axis.
3. Up/Down arrows: Use the up and down
arrows to modify the value in the X or Y value
field.
Use the Width and Height operation fields to enter
specific values to resize the selected shape with
precision.

1. Width: Type a value in this field to resize the
width of your selection.

Width and Height

2. Height: Type a value in this field to resize the
height of your selection.
3. Up/Down arrows: Use the up and down
arrows to modify the value in the Width or
Height fields.
4. Lock icon: Click the lock icon to lock or unlock
the ratio between the Width and Height values.
The Angle operation lets you to enter specific values
and accurately rotate the selected shape.

Angle

1. Angle: Type a degree value in this field to
rotate your selection.
2. Up/Down arrows: Use the up and down
arrows to modify the value in the Angle value
field.

211

Chapter 4: Tools Properties

When you select a pencil line with the Select tool,
additional options appear in the Tool Properties view.
Use the Adjusting the Pencil Line Thickness operation
field to resize the selected centreline strokes. This
operation is not permitted on contour line shapes,
such as brush strokes or shape fills.

Adjusting the Pencil Line
Thickness

When you select text with the Select tool, the tool
properties will display the Text tool options on the
bottom of the view. You can also press Alt + 9 to
display only the Text properties in the Tool Properties
view—see Text Tool Properties on page 217.
Adjusting the Text
Selection
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Smooth Editor Tool Properties
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties view.

Icon

Tool Name

Description
The Smoothing Style options allow you to smooth a
portion of your drawing by tracing a smoothing stroke
over the zone to optimize or by selecting an area of
the drawing with the Marquee or Lasso.
Note that by default, the Smooth Editor tool colour is
yellow, it was changed to orange for screen grab
clarity.

Smoothing Style

The Show Control Points option allows you to show
or hide the Bezier points around lines. When the
Bezier points are displayed, you can see the result of
your smoothing and the number of points left on the
curve. When it is turned off, only the original artwork
is displayed.

Show Control Points

This is where you set the minimum and maximum
sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with
the pressure sensitivity of a pen tablet.

Minimum Size and
Maximum Size

This options is available while using the Brush
Smoothing
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l

l

Maximum and Minimum Size: Defines the
maximum and minimum width of the stroke.
Up/Down arrows: Use the up and down
arrows to set the minimum and maximum size
value.

The Smoothness impacts the strength of the
smoothing result. The higher the value, the more
points are removed and the smoother the curve. The
Smoothness range is from 0 to 100; the default value
is 20.

Smoothness

You can modify the colour of the control points
displayed on the artwork while working with the
Smooth Editor tool by double-clicking on the colour
swatch.

Colour
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Stroke Tool Properties
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Icon

Tool Name

Description

Draw Stroke as
Straight Lines

Enable the Draw Stroke as Straight Lines option if you want the new strokes
you draw to be a perfect straight line. Disable the option if you want the
stroke to follow the mouse gesture.

Connect Line Ends

Enable the Connect Line Ends option if you want the start or end point of
your new stroke to connect to your existing strokes to make sure no gaps are
left in your drawing.
When enabled, drawing a closed shape will automatically fill it with the
currently selected colour.

Auto Fill

When enabled, drawing a closed shape will automatically remove the
outstanding lines.

Trim Extra Lines

Align Handles After
Trim

When the Trim Extra Lines option is enabled, enable this option to make the
point where the beginning and end of the stroke meet into a smooth curve
rather than a hard corner.
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Auto-Flatten Mode

By default, when drawing, each new stroke is created as a separate drawing
object, which can be edited independently from other parts of the artwork.
When enabled, the Auto-Flatten option automatically merges strokes into
existing artwork.

Smoothness

You can modify the central line smoothness of your line using this option.
This parameter smooths the initial movement of your line. Increasing the
value will result in a smoother line with fewer control points. Use the left and
right arrows to increment the value by one full unit. Use the Up - Down slider
to quickly increment the value.
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Text Tool Properties
Use the Text tool's properties to select the font type and other formatting options you want to apply to the
text.
If you already wrote your text, you must first use the Text tool and select the text portion you want to format.
You can modify the parameters of an entire text box using the Select tool.

Icon

Tool Name

Description
Use the Font drop-down menu to select a font. OTF fonts are supported.

Font Type

Use this option to bold your text selection.
Bold

Use this option to italicize your text selection.
Italic

Left Alignment

Use this option to left align the paragraph.
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Use this option to center align the paragraph.

Centered
Alignment

Use this option to right align the paragraph.

Right Alignment

Use this option to justify align the paragraph.

Justified
Alignment

Enter a size for the text.
Font Size

Kerning

Use the kerning field to modify the spacing between letters and characters. You
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can select the Auto Kern option to set the kerning automatically based on the
font’s predefined standard. A negative value decreases spacing between each
character, creating a letter overlap and a positive value increases it.

Enter a value in the Indent field to increase or decrease the indentation on the first
line of your text. A positive value sets the first line of your paragraph farther to the
right and a negative value sets it farther to the left.
Indent

Enter a value in the Line Spacing field to decrease or increase the space between
each line of text.

Line Spacing
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Transform Tool Properties
When selecting the Transform tool, several options are available in the Tool Properties view.

Icon

Tool Name

Description
Sets the selection mode to Lasso, which allows you to select
multiple items by drawing a lasso around them.

Lasso

TIP
When this option is enabled, you can press and hold the Alt
key to temporarily use Marquee mode.

Sets the selection mode to Marquee, which allows you to select
multiple items by drawing a rectangle around them.
Marquee

TIP
When this option is enabled, you can press and hold the Alt
key to temporarily use Lasso mode.

Peg Selection Mode

In the Camera view, the Peg Selection Mode limits the selection to
peg layers instead of drawing layers. This mode is useful when you
have created a character rig using peg layers for each drawing. That
way, you do not accidentally select the drawing layer when you
want to animate on the peg.
When disabled, the Transform tool selects the drawing layers.

Control Selection Mode

When enabled, it is possible to select one or several controls
displayed in the Camera by drawing a lasso/marquee around them.
By default, drawing a lasso or marquee with the Transform tool
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selects layers.

Snap and Align

Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor
point to.
Snaps your selection following the currently enabled grid.

Snap to Grid

Hide Manipulator Controls

The Hide Manipulator Controls button lets you hide the bounding
box and manipulator controls from the Camera view when an
element is selected.
Flips the current selection horizontally.

Flip Horizontal

You can also select Animation > Flip > Flip Horizontal from the top
menu or press 4 or 5.
Flips the current selection vertically.

Flip Vertical

You can also select Animation > Flip > Flip Vertical from the top
menu or press 4 or 5.

Rotate 90 Degrees CW

Rotates the current selection 90 degrees clockwise.

Rotate 90 Degrees CCW

Rotates the current selection 90 degrees counter-clockwise.

Use the Offset X and Offset Y operation fields to enter specific
values and precisely reposition the selected shape.
Offset X ad Y
1. X: Type a value in this field to reposition your selection along
the X-axis.

221

Chapter 4: Tools Properties

2. Y: Type a value in this field to reposition your selection along
the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify
the value in the X or Y value field.
Use the Width and Height operation fields to enter specific values
to resize the selected shape with precision.

Width and Height

1. Width: Type a value in this field to resize the width of your
selection.
2. Height: Type a value in this field to resize the height of your
selection.
3. Up/Down arrows: Use the up and down arrows to modify
the value in the Width or Height fields.
4. Lock icon: Click the lock icon to lock or unlock the ratio
between the Width and Height values.
The Angle operation lets you to enter specific values and accurately
rotate the selected shape.

Angle

1. Angle: Type a degree value in this field to rotate your
selection.
2. Up/Down arrows: Use the up and down arrows to modify
the value in the Angle value field.
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Zoom Tool Properties
When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Tool Options
Icon

Parameter

Description

Zoom In Mode

Use the mouse cursor to zoom in to the Camera or Drawing view.

Zoom Out
Mode

Use the mouse cursor to zoom out of the Camera or Drawing view.

Operations
Icon

Parameter

Description

Perform Zoom
In

Zoom in the Camera or Drawing view.

Perform Zoom
Out

Zoom out the Camera or Drawing view.

Reset Zoom

Restores the current zoom level to 100%.

Reset View

Restores the original display by resetting any pan, rotation or zoom actions.

The keyboard shortcut is 2.

The keyboard shortcut is 1.
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Chapter 5: Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some views also have a
toolbar which you can reposition to suit your work style. You can show or hide toolbars, as well as customize it
with the tools you use most often and hide the ones you don't.
Top Toolbars

225

Advanced Animation Toolbar

226

Deformation Toolbar

227

Edit Toolbar

230

File Toolbar

231

Game Toolbar

232

Playback Toolbar

234

Scripting Toolbar

237

Tools Toolbar

238

Workspace Toolbar

243

View Toolbars

244

Script Editor View Toolbar

245

Timeline View Toolbar

248

Xsheet View Toolbar

250
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Top Toolbars
Harmony has a series of toolbars that are added by default at the top of the interface. These toolbars can be
moved on the sides of the interface as well as within specific views.
All top toolbars can be added through the top menu Windows > Toolbars > desired toolbar.
Advanced Animation Toolbar

226

Deformation Toolbar

227

Edit Toolbar

230

File Toolbar

231

Game Toolbar

232

Playback Toolbar

234

Scripting Toolbar

237

Tools Toolbar

238

Workspace Toolbar
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Advanced Animation Toolbar
The Advanced Animation toolbar contains tools to position and animate layers. The Scale, Translate and
Rotate tools can be used to reposition the permanent pivot position of a layer. Unlike the Transform tool, each
tool in the Advanced Animation toolbar performs a single operation, either rotate, scale, translate or scale in
relation to the camera distance.

How to access the Advance Animation toolbar
1. Select Windows > Toolbars > Advanced Animation.

Icon

Tool Name

Description

Translate

Lets you move the selected element along the X and Y
axes.

Rotate

Turns a selected element around its pivot point.

Scale

Increases or decreases the size of a selected element.
You can scale an object up to make it larger or down
to make it smaller. Press Shift to scale the element
while maintaining its proportions.

Skew

Slants the selected element.

Maintain Size

Keeps elements the same size aspect ratio in the
Camera view as you move them towards or away from
the camera.

Spline Offset

Lets you reposition the visual trajectory without
offsetting or modifying your animation. By default, the
trajectory is located at 0,0,0 fields. If your elements
were drawn in a different location than the centre of
the drawing area, it will look like the trajectory is not
aligned with your drawing. Also, if you have several
elements attached to one trajectory, you might want
your trajectory to be at a different location to represent
the group's motion better.
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Deformation Toolbar
T-RIG-007-009
The Deformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is
displayed in the default interface.
By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and
select Customize, you can add additional buttons.

Default Buttons
Icon

Tool Name

Description
The Rigging tool is used to create a Bone deformation
chain. You also use it to set up the resting position.

Rigging Tool

To learn more about the Rigging tool's properties, see
Rigging Tool Properties on page 206.

Show Selected
Deformation Chains and
Hide All Others

Displays the deformer manipulators for the selected
drawings or selected deformers in the Camera view,
and hides all other deformer manipulators.

Show Manipulator

When several points from a curve or envelope
deformation chain are selected, this displays a
manipulator bounding box around them. Using this
manipulator, you can move, rotate and scale the
selected points together.
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The Reset Current Keyframe copies the resting
position, the original setup of your skeleton before
undergoing any deformation, to your current frame.
Once you have created a deformation chain, you can
use the Rigging tool to adjust the position and
appearance of the rig to fit the element. When the
skeleton is in place, you can use the Reset Current
Keyframe button to reset the current frame position to
the resting position.

Reset Current Keyframe

The Enable Deformations button allows you to display
your drawings in their original state or with
deformations while creating additional drawings.
Depending on the artwork you need to create, you
might need to refer to the other images either
deformed or in their original position.
Enable Deformations

NOTE
Disabling deformations is only a display
mode. Although drawings will not appear
deformed in the Camera view, even
in Render View mode, they will still be
deformed in the rendered images.

Optional Buttons
Icon

Tool Name

Description

Remove All Keyframes

The Remove All Keyframes option removes all
keyframes on the selected deformation chain.
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The Show All Controls button lets you visualize the
resting position in red (Setup mode) and the active
position (Animation) in green at the same time

Show All Controls
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Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These options can also
be found in the Edit menu.

How to access the Edit toolbar
1. Select Windows > Toolbars > Edit.

Icon

Tool Name

Description

Undo

Removes the last change made to your project.
Harmony supports multiple undo, so you can undo
changes you made in the order you made them.

Redo

Redoes an operation you have undone. This command
is active only after you use the Undo command.

Cut

Removes selected objects. You can then paste the
object or its properties to another object.

Copy

Copies selected objects and properties.

Paste

Places an object you cut or copied into the location
you select in a view.

Create Symbol

Creates a symbol from selected drawing elements in
the Drawing or Camera view or a layer or cells in the
Timeline view.
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File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options can also be
found in the File menu.

How to access the File toolbar
1. Select Windows > Toolbars > File.

Icon

Tool Name

Description

New (Harmony Stand
Alone)

Creates a new scene while closing any scene already open. The New
Scene dialog box opens, asking for directory, name, and resolution
information.

Open

Displays the Open Scene dialog box where you can browse for a scene
file. You can open a new scene from the current one and the previous
scene will close.

Save

Saves all changes made to the opened scene, drawings, palettes, and
palette lists.
Saves the current file with a different name and at a different location.

Save As

Saves the current state of a scene as another scene. The Save As
window prompts you for a new name and a different location for this
scene before saving it. This will create a complete scene directory for the
new scene.

NOTE
The scene name cannot exceed 23 characters.

Import Images

Imports bitmap images which you can choose to vectorize.
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Game Toolbar
The Game toolbar contains tools for setting anchors and props, as well as exporting to sprite sheets and Easel
JS.

How to access the Game toolbar
1. Do one of the following:

Icon

l

In the top menu, select Windows > Toolbars > Game.

l

Right-click on any existing toolbar and select Game.

Tool
Name

Description

Adds or remove the Anchor property for the selected layer. When a layer is an anchor, its

Toggle
Anchor

pivot point is exported as an anchor in Unity. A prop can be attached to the anchor to
follow the anchor's animation. Since the anchor is the layer's pivot, it will move and rotate
with the anchor layer's movement as well as its parent layers' movement.

TIP
You can see whether a layer has the Anchor property in the Metadata Editor
view—see Metadata Editor View on page 280

Adds or remove the Prop property for the selected layer. When a layer is a prop, it is
exported as a prop to Unity. A prop can be attached to an anchor on your character, which
makes it follow the anchor's animation.
Toggle
Prop

TIP
You can see whether a layer has the Prop property in the Metadata Editor view—
see Metadata Editor View on page 280

Export
to Sprite
Sheets

Opens the Export to Sprite Sheets dialog, from which you can export your scene as a
rigged sprite sheet that can be imported in Unity and which can have props and anchors—
see Export to Sprite Sheet Dialog Box on page 24.
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Icon

Tool
Name

Description

Export
to Easel
JS

Opens the Export to Easel JS dialog, from which you can export your scene as a rendered
sprite sheet that can be imported in Unity—see Export to Easel JS Dialog Box on page 19.
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Playback Toolbar
The Playback toolbar lets you play back animation and sound. Use it to scrub the sound to create your lip-sync,
loop the playback, navigate through frames, and change the playback range and speed.

Name

Play

Button

Description

Plays the scene in the Camera or Drawing view.
You can also select Play > Play or Stop from the top menu.
Renders your scene's frames, then opens the rendered frames
in Harmony Play for playback.

Render and Play

This allows you to preview your scene's animation in real time, with
the effects rendered and with no risk of slowdown.
You can click and hold this button to switch its mode to Record and
Play or Test SWF Movie.
Exports your scene as it appears in the Camera view into a movie file,
then opens it in your workstation's default video player.

Record and Play

Test SWF Movie

Enable Loop

This allows you to preview your animation without any risk of
slowdown, but it does not preview the effects in your scene.
However, it is much faster than Render and Play.
Quickly exports your scene as a Flash Movie (.swf), then opens it in
your workstation's default web browser.
If pressed, your scene will repeat indefinitely when playing.
Otherwise, it will stop when the end is reached.
You can also select Play > Loop from the top menu.

Enable Sound

Enable Sound Scrubbing

When pressed, your scene's soundtrack will play during playback.
You can also select Play > Enable Sound from the top menu.
When pressed, you will hear a sample of your scene's soundtrack at
the current frame when moving your scene's playhead in the Timeline
view.
This allows you to easily situate where the action is relative to the
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Name

Button

Description

sound track.
You can also select Play > Enable Sound Scrubbing.
Allows you to quickly play your scene forward or backward to
preview your animation.
Moving the handle towards the right will play your scene forward,
while moving it towards the left will play your scene backward.
Jog Frames

The closer to the edge you move the handle, the faster the playback
will be, allowing you to dose the speed at which your scene is
played. When the handle is at the edge, your scene will play at its
actual framerate.
Once the head is released, it returns to the middle and playback
stops.

Frame

Lets you manually enter the current frame number, setting the
playhead's position.
Let's you manually enter the number of the first frame to play during
playback.

Start

TIP
You can also click on Start (just left of the input field) to
quickly set the Start frame to the current frame.

Let's you manually enter the number of the first frame to play during
playback.
Stop

TIP
You can also click on Stop (just left of the input field) to
quickly set the Stop frame to the current frame.

FPS (Frames per second)

Lets you set the amount of frames that should be played during every
second of playback, which is how the playback speed is determined.
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Name

Button

Description

NOTE
This does not change the frames per second setting in your
scene's resolution settings.
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Scripting Toolbar
The scripting toolbar allows you to create buttons that run functions in your scripts. You can add one button for
each function you want to be able to run, and clicking on the button will instantly run the script function your
linked it to.

How to add the Scripting toolbar to your workspace
1. Do one of the following:

Icon

l

In the top menu, select Windows > Toolbars > Scripting.

l

Right-click on any existing toolbar and select Scripting.

Tool Name

Description

Manage
Scripts

Opens the Scripts Manager dialog box where you can add scripts and functions to
your Scripting toolbar.

Stop Script

Stops the execution of a script launched from the Scripting toolbar.
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Tools Toolbar
The Tools toolbar contains all the main tools you need to work in Harmony. In the default workspace, this
toolbar located on the left-most side of the interface. A small triangle at the lower-right corner of a tool
indicates additional tools under the main tool. To access these tools, hold down the left mouse button until the
additional tools appear, then select one.

By default, the Tools toolbar displays several of its tools in pop-up menus that must be opened. It is possible to
make the Tools toolbar display every tool in its individual button instead by enabling the Flat Tools Toolbar
preference. This makes the selection of tools quicker. However, because there is not enough vertical space to
display all tools, some tools will be hidden from the Tools toolbar by default. Which tools are displayed in the
Tools toolbar when Flat Tools Toolbar is enabled can be customized. The order in which tools are listed in Flat
Tools Toolbar mode can also be customized.

How to make every tool in the Tools toolbar display in buttons rather than pop-up
menus
1. Do one of the following:
l

Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences
(macOS).

l

Press Ctrl + U (Windows/Linux) or ⌘ + U (macOS).

2. Select the General tab.
3. In the Options section, select the Flat Tool Toolbar option.
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4. Click OK and restart Harmony.

How to customize which tools are displayed in the Tools toolbar when it is in Flat mode
1. Right-click on the Tools toolbar and select Customize.
The Toolbar Manager dialog appears.

2. In the Available Tools list, select each tool that you want to add to the Tools toolbar, then click on
the Add the selected tool to the toolbar

button.

3. In the Toolbar list, select each tool that you want to remove from the Tools toolbar, then click on the
Remove the selected tool from the toolbar

Tool Name

Icon

button.

Description
Allows you to select and reposition, scale, rotate and skew brush strokes,
pencil lines, shapes and other parts of your artwork.

Select

Cutter

Allows you to cut a part of your artwork, then reposition, scale, rotate
and skew it.
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Reposition All
Drawings

Contour Editor

Centerline Editor

Allows you to reposition, scale, rotate and skew all drawings in the
current layer.
Allows you to edit the vector contours of brush strokes, pencil lines and
shapes in your artwork. You can add, remove, tweak and move vector
points, move the Bezier handles of the vector points as well as deform
vector outlines.
Allows you to tweak and deform a brush stroke by manipulating the
points at the centre of its line rather than its contour.

Smooth Editor

Allows you to optimize contours and lines by removing its extra points,
making them easier to edit.

Perspective

Allows you to deform artwork by applying a perspective effect on it.

Envelope

Allows you to deform and warp artwork by moving points and tweaking
lines in a grid.

Edit
Gradient/Texture

Allows you to adjust the position, angle and size of gradients and
textures in a colour zone.

Brush

A pressure-sensitive tool for creating a contour shape with a thick and
thin line effect, as if created with a paint brush.

Pencil

A pressure-sensitive tool for drawing outlines. Pencil lines are made of
central vector lines, making them easier to tweak and edit than brush
strokes.

Text

Allows you to add text and to format it.

Eraser

A pressure-sensitive tool for erasing parts of a drawing.

Paint

Allows you to fill colour zones with a colour or texture.

Paint Unpainted

Allows you to quickly fill empty zones in your artwork with a colour or
texture, leaving filled zones unchanged.
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Unpaint

Allows you to empty filled colour zones of their colour and texture.

Stroke

Allows you to create invisible lines that can serve as colour zones that
can be filled, or close the gaps in existing colour zones.

Close Gap

Allows you to close open shapes so that they can be filled with the Paint
tool. By drawing a stroke near a small gap in a shape, this tool will create
a small invisible stroke connecting the two closest points around the gap.

Line

Draws a straight line segment going from one point to the other.

Rectangle

Draws a rectangle.

Ellipse

Draws an ellipse.

Polyline

Allows you to draw shapes, segmented lines or complex curved lines by
clicking to create each point in the sequence of line segments.

Dropper

Allows you to select a colour by clicking on a colour in your artwork.

Hand

Allows you to pan the Camera and Drawing views.

Zoom

Allows you zoom in and out of the Camera and Drawing views.

Rotate View

Lets you rotate the Camera and Drawing views just like with a real
animation disc.

Animate Mode

Enables the Animate mode which records the position, rotation, scale,
skew, etc. of objects as keyframes in the Timeline view. Turn off the
Animate mode to reposition objects for the entire scene. When the
Animate mode is disabled, keyframes are not created when an object's
parameters change.

Transform

Allows you to select drawing layers and position, rotate, scale and skew
them.
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Onion Skin

Displays the previous and next frames of an animation. Useful when
animating cut-out characters.
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Workspace Toolbar
The Workspace toolbar lets you load other workspaces. The first time you start Harmony, the default
workspace is loaded. Other workspaces are available such as the Hand-Drawn Animation and Compositing
workspaces; these display different views and toolbars. You can access these workspaces and any you create,
from the Windows menu and the Workspace toolbar.

How to access the Workspace toolbar
1. Select Windows > Toolbars > Workspace.

Icon

Tool Name

Description

Workspace List

Allows you to select an existing workspace.

Workspace Manager

Opens the Workspace Manager where you can
organize, display, and remove workspace from your
list.

Save Workspace

When the Automatically Save Workspace preference
is disabled, the Save Workspace button becomes
available. This allows you to manually save your new
workspace configuration.
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View Toolbars
Harmony has a series of view specific toolbars that are only available in a given view. These toolbars can be
moved only within their view.
All view toolbars can be added, as long as the view is visible, through the top menu Windows > Toolbars >
desired toolbar.
Script Editor View Toolbar

245

Timeline View Toolbar

248

Xsheet View Toolbar

250

244

Harmony 15.0 Essentials Reference Guide

Script Editor View Toolbar
The Script Editor toolbar gives you quick access to some commonly used commands for editing and testing
scripts in the Script Editor view—see Script Editor View on page 282.

How to access the Script Editor toolbar
1. Add the Script Editor view to your workspace by doing one of the following:
l

In the top-right corner of an existing view, click on the

Add View button and select Script

Editor.
l

In the top menu, select Windows > Script Editor.

2. Click on the Script Editor view to set the focus on it.
3. In the top menu, select Windows > Toolbars > Script Editor.

Icon

Button

Description

Creates a new script. When you click on this button, you are first prompted to
type in a name for the script. Then, you will be prompted to select which location
to save the script in:
l

New Script
l

User: Saves the script to your user preferences. You will be able to run and
edit the script from any scene as long as you are logged in as the same
user.
Scene: Save the script to the scene's scripts sub-folder. Anyone will be
able to edit and run the script when working on this specific scene.

NOTE
For more information on script locations, see Script Editor View.

Import Script

Allows you to import a script from your machine into Harmony. When you click
on this button, you are prompted to browse for and select a script on your file
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Icon

Button

Description

system. Then, you are prompted to select which location to import the script in:
l

l

User: Saves the script to your user preferences. You will be able to run and
edit the script from any scene as long as you are logged in as the same
user.
Scene: Save the script to the scene's scripts sub-folder. Anyone will be
able to edit and run the script when working on this specific scene.

NOTE
For more information on script locations, see Script Editor View.

Deletes the selected script.

NOTES
l

Delete Script
l

You cannot delete a script if it is in the Application Resources
location, as those are scripts that are installed with Harmony.
If you delete a script that was originally in Application Resources
but which you copied to another location so you could make
changes to it, the original version of the script in the
Application Resources folder will be restored to the list.

Refresh Script
File List

Refresh the list of scripts in the Script Editor. If there are new scripts in your user
preferences or your scene's scripts sub-folder, click on this button to be able to
open them in the Script Editor.
Allows you to type in the path and name for your preferred text editing software.

NOTES
Set External
Editor

l

l

Open with
External Editor

On macOS, only typing the name of your preferred text editing
software is enough if that application supports the AppleScript
Open Document protocol.
On Windows, unless your text editor is in your system's PATH
environment variable, you will have to type in the full path to the
editor.

Opens the selected script in the chosen external text editing software.
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Icon

Button

Set Target

Description

Prompts you to select which script and which function to use with the
and

Run

Debug buttons.

Runs the target script and function.

NOTES
l

Run
l

If you have not set a target script and function, you will be
prompted to set one when you click on this button.
You can set or change the target script and function by clicking
on the

l

Set Target button.

If you are editing <<<Sandbox>>>, this button will simply run
what you typed into the sandbox, regardless of whether another
target is set.

Open the target script and function in the Qt Script Debugger, in which you can
test and debug the function.

NOTES
l

Debug
l

If you have not set a target script and function, you will be
prompted to set one when click on this button.
You can set or change the target script and function by clicking
on the

l

Stop Execution

Set Target button.

If you are editing <<<Sandbox>>>, this button will simply debug
what you typed into the sandbox, regardless of whether another
target is set.

If a script is currently running, this interrupts its execution.
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Timeline View Toolbar
The 3D Graph toolbar works in conjunction with the elements in the 3D Graph view.

Button

Name

Description

Set Ease Type

Create Empty Drawing

Duplicate Drawing

Insert Keyframe

Delete Keyframes

Set Motion Keyframe

Set Stop-Motion Keyframe

Go to Previous Keyframe

Go to Next Keyframe

Add Key Exposure

Delete Key Exposure

Centre On Selection

Set Ease for Multiple Parameters

Fill Empty Cells
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Paste Special

Enable/Disable

How to access the Timeline view toolbar
You can add the Timeline view toolbar to the Timeline view by:
l

Going to the top menu and selecting Windows > Toolbars > Timeline view.

l

right-clicking on the space at the top of the Timeline view and selecting Timeline view.
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Xsheet View Toolbar
The Xsheet toolbar contains the common timing operations such as Add Column, Delete Column, Clone
Column, and so on. These options can also be found in the top menu.
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Chapter 6: Views
The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a
view.
When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing
or other type of selection or the option does not apply to the active view.
Camera View

253

Colour View

259

Drawing View

264

Function View

267

Guides View

270

Integrated Help View

273

Layer Properties View

274

Library View

276

Message Log View

279

Metadata Editor View

280

Script Editor View

282

Side View

284

Timeline View

286

Tool Properties View

295

Top View

296

Xsheet View

298
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Camera View
The Camera view is the centre of operations in Harmony. In this view, you can draw, paint, animate, set up your
scene, manipulate objects, open symbols and preview your animation.
The Camera view also has a top and bottom toolbar that you can use to navigate in the view, change the
display mode or go up your symbol hierarchy.

How to access the Camera view
Do one of the following:
l

From the top menu, select Windows > Camera.

l

From any of the other views, click the Add View

Icon

button and select Camera.

Section

Description

Editing Stack

The Editing Stack menu displays the names of the
symbols and their hierarchy when you are editing a
symbol. You can click on the different names to go
back up to the different parent symbols or the
top/current project.

253

Chapter 6: Views

The Camera View toolbar contains all the tools and
options you can use in the Camera view to draw,
animate or set up the scene. The toolbar can be
displayed or hidden by right-clicking on it and
selecting or deselecting the Camera View toolbar.

Camera View Toolbar

When you have a drawing layer or drawing selected,
the Light Table button button allows you to fade the
colours of the other layers so you can see the current
artwork better as you edit with a drawing tool. Note
that the light table does not work when using a layer
editing tool, such as the Transform tool.
Light Table

When this button is enabled, the drawing that you are
currently editing with a drawing tool is temporarily
displayed in front of all the other elements. The actual
scene is not modified.

Current Drawing on Top

The Camera Mask button shows or hides Displays a
black mask around the scene’s frame to avoid seeing
the unnecessary artwork. This option is handy when
you're animating and setting up the scene. It allows
you to see your scene’s composition better.

Camera Mask

You can also access this from the top menu by
selecting View > Show > Camera Mask.
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The Safe Area button shows or hides Displays the TV
safety zone and the centre of the camera frame. The
safe area adapts to the scene resolution, as well as the
safety zone and frame’s centre.
You can also access this feature from the top menu by
selecting View > Show > Safe Area.
Safe Area

Drawings that are locked in the Timeline view (cannot
be selected in the Camera view) are displayed as
wireframes.

Outline Locked Drawings

The Reset View button resets any panning, zooming
or rotation done in the Camera view and returns the
display to the initial settings. You can also press Shift
+ M.

Reset View

The Zoom menu lets you enlarge or reduce the Camera
or Drawing view display.

Zoom Menu

To make the camera frame size always match the size

255

Chapter 6: Views

of your view, select the Fit to View option. Click the
drop-down arrow and select a zoom level or press 1
and 2.

The OpenGL View Mode button switches the Camera
view to fast display, letting you see your animation
play in real time. The OpenGL display requires less
memory. The final look of your effects is not shown in
the OpenGL View Mode. You must switch to the
Render View Mode to see your effects.
OpenGL View Mode

The Render View Mode button swithes the Camera
view to a fully rendered display showing the final
image of the current frame. If a modification is done to
your current frame or if you move to a different frame,
click the Update Preview button to update the display
if your preview does not update automatically.The
Render View Mode display lets you see the final look
of your frames including effects and antialiasing. You
cannot play back your scene in Render View Mode. To
see your scene fully rendered and to play it back, you
must press the Render and Play button in the
Playback toolbar.

Render View Mode
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The Matte View Mode button switches the Camera
view to a matte display showing the alpha channel of
the elements in your scene. The transparency level
ranges from 0 to 100 percent. Zero percent is
completely transparent and represented by black and
100 percent is completely opaque and represented by
white. Everything in between these extremes has a
transparency level somewhere between 1 and 99
percent and is represented in various shades of grey.
l

Matte View Mode

To access the Matte View mode, click on the
Render View button and select Matte View
from the drop-down menu.

The Depth View mode displays images in a relative
white to black gradient scale. The object(s) closest to
the camera are displayed in white and the object(s)
furthest from the camera are displayed in black. If the
position of the last object changes along the z-axis,
that object will still remain black, so long as it retains
its position as the object the farthest back. It does not
matter where that object is in 3D space, it just matters
what its position is relative to the other object in the
same space. The objects closest and farthest from the
camera set the range of the white to black scale. All
the other objects fall somewhere in between.

Depth View Mode
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l

To access the Depth View mode, click on the
Render View button and select Depth View
from the drop-down menu.

The Drawing Name field displays the name of the
selected drawing, as well as the layer containing it. If
the cell does not contain any drawing, an Empty
Cell text is shown in the field.

Drawing Name

The Tool Name field displays the name of the selected
tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s name will be highlighted
in red. You can temporarily override a tool by holding
its keyboard shortcut without the Alt key. For

Tool Name

example, the Select tool shortcut is Alt + S. If you hold
down the S key, you will switch to the Select tool.
When you release the key, you will return to the tool
you were using.

Frame Number

The Frame Number field displays the number of the
current frame.

Selected Colour

The colour swatch displays the currently selected
colour in the Colour view.
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Colour View
The Colour view is where you create colours and palettes and import existing palettes into your project. The
Colour view is also necessary for drawing, painting and creating colour styling.

How to access the Colour view
Do one of the following:
l

From the top menu, select Windows > Colour.

l

From any of the other views, click the Add View

button and select Colour.

Palette List Panel
Icon

Option

Description

View Menu

The View menu contains all the commands and options that you can use
in the Colour view to manage colours and palettes.

Collapse/Expand Palette

Allows you to show or hide your palette list and its options. By default, the
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List

palette list is displayed, but you may want to hide it if you are working with
a single palette and want to allow more vertical space for the colour
swatch list.

Add Palette

Allows you to create a new palette.

Deletes the currently selected palette. If the colour swatch is used in your
project, zones painted with colour swatches which have been deleted will
turn red, easily identifying them so you can repaint them with another
colour swatch.

Remove Palette

Import Palette

Allows you to import a palette from your machine into your scene's palette
list. The palette will be copied to your scene's folder.
Moves palettes further up or down the palette list.

Order Palette List

If a palette has been cloned, the highest palette among the original palette
and its clone(s) will be used by Harmony.
In Harmony Server, this icon appears when you have the modifying rights
on your scene's palette list. While several users can work on a scene at the
same time, only one user may have the right to modify a palette list at any
given time.

Edit Palette List Mode
Indicator

NOTE
In Harmony Stand Alone, you can always modify your scene's
palette list. On Harmony Server, you must unlock your palette list
before making modifications to it.
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Palette List
Icon

Description

In Harmony Server, this indicates that you have the rights to modify the palette.

Indicates that the palette is stored at the same level as its palette list. For example, a palette that is stored
in the scene's palette library and which is listed in the scene's palette list, or a palette that is stored in an
element's palette library and which is listed in that same element's palette list.
Indicates that the palette file is stored in an external location, such as a different scene, an element in a
different scene, a job other than the scene's job, or an environment other than the scene's environment.
This means the palette is liable to be missing if it is moved from its original location, or if the scene is
exported from the database into an offline scene or to a different database.
This indicates that the palette is stored at a higher level than its palette list, making it a shared palette. For
example, a palette in your scene's palette list that is stored in the palette library of the scene's job or
environment, or a palette in an element's palette list that is stored in the palette library of the scene.
Indicates a potentially dangerous situation. For example, a palette file that is stored in one of the scene's
element folders, but which is added to your scene's palette list. The whole scene can use the palette, but
since it's stored inside an element, deleting that element will make your whole scene lose access to that
palette.

Colour Swatch List Panel
Icon

Option

Description

Add Colour

Adds a new colour swatch to the bottom of your colour list.

Remove Colour

The Remove Colour button lets you delete the currently selected
colour swatches. If the colour swatch is used in your project, and
confirmation dialog will appear prompting you to confirm that you
want to delete the colour. Zones painted with colour swatches which
have been deleted will turn red, easily identifying them so you can
repaint them with another colour swatch.
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Allows you to import a bitmap image as a texture, which can be
painted with just like a colour. When used with the Brush or Paint
tools, bitmap textures are tiled inside the shape they fill. The scaling
and position of the texture inside their shape can be tweaked with the
Edit Gradient/Texture tool. When used with the Pencil tool or one of
the Shape tools, a bitmap texture will follow the pencil line's
direction.

Add Texture

Each colour swatch available in the Colour view can have its own
name, making it easy to identify which colour is used to paint what
part of your character or background.
Colour Swatch Name
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NOTE
Two colours can have the same name. Harmony identifies
colours by an identification number.

Also referred to as colour pots, the colour swatch is the actual colour
information for a colour in your palette. It is represented by a
rectangle displaying the colour in the list.
Colour Swatch
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Drawing View
In Harmony, you can draw in both the Drawing or Camera views. Although the two views are similar, there are
some differences when it comes to drawing.
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion
Skin to display the previous and next drawings of the currently selected drawing layer.

How to access the Drawing view
Do one of the following:
l

From the top menu, select Windows > Drawing .

l

From any of the other views, click the Add View
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Icon

Section

Description

Drawing Area

This is the main space in the Drawing view. It is where
you draw and where the drawings are displayed.
The Zoom menu lets you enlarge or reduce the Camera
or Drawing view display.
To make the camera frame size always match the size
of your view, select the Fit to View option. Click the
drop-down arrow and select a zoom level or press 1
and 2.

Zoom Menu

Drawing Name

The Drawing Name field displays the name of the
selected drawing, as well as the layer containing it. If
the cell does not contain any drawing, an Empty
Cell text is shown in the field.

Tool Name

The Tool Name field displays the name of the selected
tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s name will be highlighted
in red. You can temporarily override a tool by holding
its keyboard shortcut without the Alt key. For
example, the Select tool shortcut is Alt + S. If you hold
down the S key, you will switch to the Select tool.
When you release the key, you will return to the tool
you were using.

Frame Number

This field displays the current frame of the animation
you are working on.

Cursor Coordinates

This indicates the position of the your pointer in the
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drawing area.
The Colour Picker allows you to select a colour for
drawing.

Colour Picker
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Function View
The Function view lets you edit function curves and parameters. It contains a visual graph for adding, removing,
and editing keyframes, as well as adjusting the velocity. The Function view allows you to display multiple
functions in the background as a reference.

How to access the Function view
Do one of the following:
l

From the top menu, select Windows > Function.

l

From any of the other views, click the Add View

button and select Function.

How to display functions in the Function view
1. Open the Function view.
The Function view is blank until you select the layer containing the functions you want to display.
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2. To display a function in the Function view, click on the layer containing the functions to adjust in the
Timeline view.
3. To select the functions you want to edit, select them in the Function list.

Parameter

Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed (if any). Select the functions you want to see and edit, and hide the
ones you don't.

Display Toolbar

Allows you to modify how the editing area is displayed. You can hide the grid,
disable the synchronization with the current frame, reset the zoom level and
normalize the function display by stacking them one over the other to compare
them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and
Interpolation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, adjust
the segments to motion or stop-motion keyframes and set the velocity to create
steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.
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Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe values are
displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe. The
more the handle is pulled out horizontally, the slower the animation will be. The
more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section of a
curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can be
referenced to know the current frame of a keyframe.
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Guides View
The Guides view enables you to manage drawing guides for a given storyboard panel. Use Drawing Guides to
assist you in creating a drawing with perspective.
Guides can be added, selected, renamed, deleted, cut, copied, pasted and reordered. Guides can also be
exported to a file and re-imported later.

Icon

Name

Description

Enable Guide

Enables or disables drawing guides.

Options

When enabled:
l

Align with Guide

The Brush, Pencil, Line and (optionally) Eraser tools are constrained by
the Drawing Guide to draw/erase straight lines only.

When disabled:
l

The drawing tools are not constrained by the Drawing Guide, allowing
you to do freehand strokes. The guide acts as a visual aid only.

Lock Guide

Locks the editing of a Drawing Guide to prevent its accidental modification while
drawing.

Enable Guide
with Eraser

Toggles the use of Drawing Guides with the Eraser tool.
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Icon

Name

Description

When enabled:
l

Full Cursor
Display

Show Reference
Lines

Drawing Guide axes extend to the edge of the drawing area.

When disabled:
l

Drawing Guide axes are short.

l

Drawing Guide axes disappear while drawing a stroke.

Toggles the display of a visual reference consisting of lines that converge
towards the vanishing point(s).
Adjusts the amount of reference lines to display.

Number of Lines

Guides List
Allows you to add a guide to the scene's guides list. You can add a guide of one
of the following types:

New Guide

l

Square grid

l

1-point perspective

l

2-point perspective

l

3-point perspective (bird’s eye view)

l

3-point perspective (worm’s eye view)

Delete Guide

Deletes the selected Drawing Guide(s) from the scene's guides list.

Guides View
Menu

Opens a menu with the following commands:

Rename
Guide

Renames the selected Drawing Guide.

Cut

Cuts the selected Drawing Guide(s) from the list and adds it to the clipboard.

Copy

Copies the selected Drawing Guide(s) to the clipboard.
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Icon

Name

Description

Paste

Pastes Drawing Guide(s) from the clipboard to the scene's guides list. Pasted
guides are inserted under the selected guide.

Import
Guides

Imports Drawing Guides from a source file and inserts them at the bottom of the
scene's guides list. Duplicate guides are filtered out to avoid cluttering the list.

Export
Selected
Guides

Exports the selected Drawing Guide(s) to a destination file.

Displays the scene's list of guides and allows you to select which guide to
display and use.
Drawing Guides
List
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Integrated Help View
Use the Integrated Help when you are unsure about what a certain menu item is or the function of a specific
preference in the Preferences panel.
If you keep the Integrated Help window open for the entire duration of your work session, then you can use the
forward and backward arrows to scroll through a history of the help information that you called up during your
session.

How to access the Integrated Help view
1. Do one of the following:
l

From the top menu, select Windows > Integrated Help.

l

From any of the other views, click the Add View

273

button and select Integrated Help.

Chapter 6: Views

Layer Properties View
The Layer Properties editor or view lets you adjust the properties of a layer in the Timeline view The Layer
Properties can be viewed as a floating window or as a view (docked).
Each layer has its own set of properties that can be modified, including effect and peg layers. Display the Layer
Properties editor or view if you want to modify some of the layer’s properties, such as the name or the
antialiasing quality.
NOTE
To know more about the parameters displayed in the Layer Properties view, see Layers on page
120.

How to access the Layer Properties view
Do one of the following:
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l

From the top menu, select Windows > Layer Properties.

l

From any of the other views, click the Add View

button and select Layer Properties.

How to access the Layer Properties editor
l

Double-click on a layer in the Timeline view

l

Right-click on a layer in the Timeline view and select Layer Properties.

l

Select a layer in the Timeline view and press Shift + E.
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Library View
The Library view is used to store elements such as animation, drawings, backgrounds and character models so
as to reuse in different scenes and projects. You can also use the Library view to create and store symbols, as
well as to store and import images and sound files.
To reuse elements from a scene in other scenes, you must create a template so that you can import it into
different scenes. Templates can contain anything from a single drawing to a whole scene structure. You can
create a template by creating it in a scene, then copying the elements you want in your template into a library.
The resulting template is structured like a mini-scene that contains only the elements you copied into it. A
template does not have any dependencies on the scene it was originally created in. Hence, it can safely be
imported in any other scene.
Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from.

How to access the Library view
Do one of the following:
l

From the top menu, select Windows > Library.

l

From any of the other views, click the Add View

Icon

button and select Library.

Section

Description

View Menu

The Library menu lets you access commands related
to the Library view, importing .swf movies and
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Illustrator files, add a new folder, and refresh the
library’s content.
The Preview window lets you see the content of the
currently selected template or symbol in the
Template/Symbol list.

Preview Window

The Preview Playback button lets you play back the
content of the selected template or symbol if it
contains more than one frame. Press the Play button
to play back the preview.

Preview Playback

The Library Folder List displays all the folders linked to
the Library view.

There are two default folders:
Library Folder List

l

l

Symbols: This folder is the only folder
containing symbols. You can organize it by
adding subfolders inside.
Harmony Essentials Library: This is a default
folder found on the hard drive in your user
documents. This folder can contain templates,
but no symbols.

You can link new library folders to the Library view
and organize them with subfolders.
When working on a movie or series, you will probably
end up with many templates and symbols in your
library. Using the Search tool, you can quickly find the
templates and symbols in your folders.

Library Search tool
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The Template/Symbol list displays the templates or
symbols contained in the selected library folder. You
can display the templates by right-clicking the
symbols’ thumbnails and selecting View >
Thumbnails.

Template/Symbol List
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Message Log View
The Message log view displays information gathered during a render task, such as which frames and at what
time they were each rendered. The view also contains a list of the colour recovery operations.

How to access the Message Log view
Do one of the following:
l

From the top menu, select Windows > Message Log.

l

From any of the other views, click the Add View
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Metadata Editor View
The Metadata Editor view allows you to view and modify the information for props and anchors when creating
a game character or asset in Harmony. It displays your scene's metadata as well as the metadata for the
currently selected layer and allows you to add, remove or change the value of metadata nodes.

Usually, you do not need to manually add or modify metadata for a game character or asset using the Metadata
Editor. The commands available in the Game toolbar can be used to define props and anchors, which will
automatically fill your scene and layers with the proper metadata. The Metadata Editor is however useful for
visualizing the way Harmony stores this information, to tweak it as necessary and to debug any issue that could
occur when exporting a game asset to Unity.
IMPORTANT
You should avoid using any character but letters, numbers, dashes and underscores in the
Metadata Editor.

How to access the Metadata Editor view
l

In the top-right corner of a view, click the Add View

l

In the top menu, select Windows > Metadata Editor.

Parameter

Description
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Displays the metadata for the Harmony scene. Each entry has a name and a value.
Typically, metadata for a scene includes the following entry:

Scene Metadata

Metadata

guideList

Description

This is a node in which the guides created in the Guide View
are stored. This can be ignored—see Guides View.

Displays the metadata for the currently selected layer. Each metadata entry has a
name and a value.
Typically, metadata for a node includes the following entries:
Metadata

Description

game.isAnchor

When set to On, this sets the selected layer as
an anchor. This means that, in Unity, the layer's
pivot will be an anchor to which props can be
attached. A prop will follow its anchor's
movement.

game.isProp

When set to On, this sets the selected layer as
a prop. In Unity, a prop can be attached to an
anchor to follow its movement.

game.<metadata name>

When a layer has the game.isProp property,
you can add any metadata node to it provided
that the name of the metadata node starts with
game followed by a period (.). This metadata
will be exported to the list of metadata values
for the prop, which can be used in Unity.

Node Metadata
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Script Editor View
The Scripting view allows you to edit scripts to run in Harmony directly from the application. It displays a list of
available scripts, from which you can select an existing script, edit it, test it and save it. The Script Editor will
highlight the syntax of your script for easy reading.

How to access the Script Editor view
Do one of the following:
l

From the top menu, select Windows > Script Editor.

l

From any of the other views, click the Add View

Parameter

button and select Script Editor.

Description
The location of the scripts you are editing. The script editor can list, open and edit
scripts from the two following scopes:
l

Scope
l

User: Scripts are saved alongside your user preferences. Those scripts can
loaded, executed and edited in any scene, but only as the currently logged
in user.
Scene: Scripts are saved to the scripts subfolder of the currently opened
scene. This scope is for scripts that should be used in the scene
specifically, but should be available to any user that opens the scene.
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NOTE
User scripts are stored in the following location:
l

l

Windows: C:\Users\[username]\AppData\Roaming\Toon
Boom Animation\Toon Boom Harmony Essentials\1500scripts
macOS: /Users/[username]/Library/Preferences/Toon
Boom Animation/Toon Boom Harmony Essentials/1500scripts

The list of script files. Selecting a script will open it in the editor and allow you to
make changes to it.

Script list

NOTE
The << Sandbox >> item at the top of the list does not correspond to an
actual script file. It is a temporary container to type and test code, but
changes to the sandbox will not be saved.

Editor

A syntax highlighting text editor in which the script is loaded and can be edited.

Search toolbar

Allows you to search for a keyword within the script.

Verify

Verifies that the script has no syntax error.

Save

Save the modifications to the script to its corresponding script file.

283

Chapter 6: Views

Side View
T-HFND-008-015
The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a
scene’s stage from the side. This lets the camera cone and spacing between the elements to be seen.

How to access the Side view
Do one of the following:
l

From the top menu, select Windows > Side.

l

From any of the other views, click the Add View

Icon

button and select Side.

Section

Description

Thumbnails

A thumbnail of each drawing layer in the scene. The
order of the thumbnail images is based on each
element’s FB position in the scene space. You can see
a representation of the FB position of each layer in the
camera cone.

Camera Cone

The camera cone represents the camera’s position and
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field-of-view (FOV).

Axis Reference Arrows

The axis reference arrows let you maintain your
orientation when navigating in the view.

Show/Hide Camera

Shows or hides camera frame in the Perspective view.

Reset View

Resets the pan, rotation, and zoom of the Perspective
view.
This field displays the current zoom level in the
Perspective view. You can use the Zoom level dropdown menu to select a specific zoom level from the
list. Zoom levels from 2.5% to 6400% are available;
you can also select Fit To View to automatically use a
zoom level that lets you see all your scene layers and
information in the Perspective view at once.

Zoom Menu

Layer Name

This field displays the currently selected layer and
drawing name.

Tool Name

This field displays the currently selected tool.

Frame Number

This field displays the currently selected frame of your
animation.

Colour Swatch

This field displays the currently selected colour in the
palette.
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Timeline View
T-HFND-006-002
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to
become familiar with the Timeline view, how it works, and its interface.
The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and
ordering layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer names,
drawings, keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing
name is displayed when you place your pointer over the drawing’s exposure.

How to access the Timeline view
Do one of the following:
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l

From the top menu, select Windows > Timeline.

l

From any of the other views, click the Add View

Icon

Section

button and select Timeline.

Description
The Enable/Disable All button lets you enable or disable layers. Disabling a
layer makes the scene behave as if it didn't exist, including when rendering
the scene. For example:
l

A disabled drawing layer will be invisible.

l

A disabled sound layer will be mute.

l

A disabled peg layer will not affect the position of its child layers.

To disable a layer, click the layer's Enable/Disable button or press D.

Enable/Disable Layer

To enable a layer, click the layer's Enable/Disable button or press A.

NOTE
Next to sound layers, the Enable/Disable layer button will look like
this:

.

TIP
You can enable or disable all layers by clicking on the Enable or
disable all layers
button in the top row.

Enable/Disable
Solo Mode

Solo mode allows you to only view specific layers in the Camera view and
hide all others. When solo mode is enabled on one layer, only this layer will
be visible. If solo mode is enabled on several layers, and only these layers will
be visible. If solo mode is not enabled on any layer, all enabled layers will be
visible.
You can also use solo mode on sound tracks. If solo mode is enabled on any
sound tracks, only those sound tracks will play during playback.
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TIP
When some layers are in solo mode, you can disable or re-enable
solo mode on all layers that have it enabled by clicking on the Toggle
solo mode on or off
button in the top row.

For when the Onion Skin option is enabled, this allows you to enable or
disable Onion Skin on specific layers.

Add to/Remove from
Onion Skin

TIP
To activate the general Onion Skin preview, in the Tools toolbar, click
the Onion Skin button

The Lock/Unlock Layer button lets you prevent the selection or editing of a
layer in the Camera view. To select some of the layers without selecting
others, in the Timeline view, lock the layers you do not want to select. When
a layer is locked, its name is displayed in red.
Lock/Unlock Layer

In the top menu, there is a series of locking options. Select Animation > Lock
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> select one of the following:
l

Lock: Locks the currently selected element.

l

Unlock: Unlocks the currently selected element.

l

Lock All: Locks all the elements in the Camera view.

l

Unlock All: Unlocks all the elements in the Camera view.

l

Lock All Others: Locks all the elements in the Camera view except the
currently selected one.

Each drawing layer has a little colour swatch that has two functionalities:
l

Single-clicking a layer's colour swatch toggles Outline mode on or
off. Outline mode makes the layer display as nothing but the outlines
of its vector shapes in the Camera view, allowing you to see the
drawing's shape without it blocking the view of layers behind it.

Toggle Outline Mode /
Change Track Colour
l

Double-clicking the layer's colour swatch opens a colour picker
dialog that allows you to change the layer's track colour. The track
colour displays in the layer's track in the Timeline view, allowing you
to give special visibility to specific layers. It also determines the
colour of the layer's outlines if it's in outline mode.

Expands the layer to display a thumbnail of the drawing in the current frame,
as well as for each drawing in the timeline.

Show/Hide
Thumbnails

NOTE
By default, the timeline's zoom level does not allow enough
horizontal space to fully display the thumbnails of drawings exposed
for one or two frames only. To see the thumbnails for drawings with
short exposure, you must increase the timeline's zoom level—see

Timeline Zoom on page 294.
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When a drawing layer is in Show Thumbnails mode:
l

l

An exposure indicator appears at the right of each exposed drawing
in the timeline, indicating the amount of frames the drawing spans
over.
An Opacity parameter appears to the left of the layer, allowing you to
set the layer's opacity level.

TIP
You can show or hide thumbnails for all drawing layers by clicking on
the Show/Hide All Thumbnails

button in the top row.

Allows you to set the opacity level of the layer. Click and drag the value left
or right to decrease or increase the layer's opacity.
Opacity

NOTE
This parameter only displays for drawing layers that are in Show
Thumbnails mode.

This icon appears next to the active drawing layer, which is the layer you
draw on when using drawing tools.

Active Drawing Layer
Indicator

Add Layer

NOTE
The active drawing layer is not always the selected layer. For
example, if you select a drawing layer, then a peg layer, the peg
layer will be the selected layer, but the active drawing layer will
remain the last drawing layer you selected, until you select another
drawing layer.

The Add Layers button lets you add new layers to the Timeline view. When

290

Harmony 15.0 Essentials Reference Guide

you click the Add Layers button, a menu appears displaying the available
layer types.

Delete

The Delete Layers button lets you delete the currently selected layers in the
Timeline view.

Add Drawing Layer

The Add Drawing Layer button lets you automatically add a new drawing
layer to the Timeline view. By default, the layer is named Drawing.
The Add Peg button lets you add a peg layer to the timeline. If several layers
are selected, a peg is added and parented to each layer.

Add Peg

The Expand/Collapse button is used to display the children layers of a parent
layer. Once a layer is parented to another layer, it is indented to the right and
the Collapse/Expand Children button appears on the parent layer allowing
you to show or hide the child layer.
Expand/Collapse

The Show/Hide Functions button lets you display the functions embedded in
each layer. The functions are the different coordinates and values used to
record a layer’s parameters at each frame. This information is stored on the
function curves using keyframes.

Show/Hide Functions

If the layer can be connected to another layer, for example to use a drawing
layer as a matte, expanding a layer's functions will also list its possible
connections. You can connect layers by dragging and dropping a layer onto
another layer's connection.
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Adds a keyframe at the current frame of the selected function or removes the
keyframe at the current frame of the selected function, if there is one already.
Add/Remove
Keyframe

NOTE
This button only displays for function layers.

Moves the timeline cursor to the previous keyframe on the selected function.
Previous Keyframe

NOTE
This button only displays for function layers.

Moves the timeline cursor to the next keyframe on the selected function.
Next Keyframe

NOTE
This button only displays for function layers.

Displays the Function menu, which allows you to create a new function for
the function layer, or to link it to an existing shared function.
Function Menu

NOTE
This button only displays for functions layers, in the Parameters
column—see Show/Hide Parameters on page 293.

A frame where the value for one or more of the layer's functions is preset.
The position of each layers in key poses for digital animation is recorded in
function keyframes. You can grab and move function keyframes as well as
copy, cut, paste and delete them.

TIP
Function Keyframe

If you have a keyframe and a drawing selected simultaneously, and
you wish to delete the keyframe without deleting the drawing's
exposure by doing one of the following:
l

In the Timeline toolbar, click on the Delete Keyframe
button.

l

Press F7.

l

From the top menu, select Animation > Delete Keyframe
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NOTE
If a collapsed layer has children that have function keyframes, you
will see a white square

instead.

The Split button lets you split the Timeline view in two sections, allowing
you to see two different portions of the Timeline view. This can be useful if
you need to often switch between two specific points of a lengthy scene.

Split

Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented by a grey
block that extends from the first frame it is exposed to the last frame it is
exposed.

Shows or hides the Parameters column, right of the Layers column. The
Parameters column displays information on the layer at the current frame,
depending on the type of layer it is:
l

l

l

If the layer is a drawing, it displays the name of the drawing at the
current frame.
If the layer is a function, it displays the value of the function at the
current frame.
If the layer is a sound track, it displays the sound track's volume.

Show/Hide
Parameters
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Using the mouse, you can drag the parameter left and right to change its
value. This is especially useful for quickly changing a drawing's exposure at
the current frame.
Shows or hides the Additional Links column. The Additional Links column
displays layers that are connected under the layer, but for other purposes
than being the parent of those layers. For example, if a layer is used as the
matte of an effect, the effect will be displayed in that layer's Additional Links.
If more than one layers are in a layer's Additional Links, only the first of these
layers will be displayed, followed by the amount of extra linked layers there
are.
By clicking on the Additional Links, you can open a menu listing the linked
layers, and click on one of these layers to navigate to it.
Show/Hide Additional
Links

In the following example, the BOOM_Animation layer is used as the matte of
Cutter_1 and Cutter_2:

Timeline Zoom

Reduces or increases the width of frames in the Timeline view. Move the
slider right to increase the width or left to reduce it. You can also press 2 to
zoom in and 1 to zoom out when the Timeline view is focused on.
If you want to reset the Timeline view's zoom, click on the Timeline Zoon
icon left of the slider.
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Tool Properties View
T-HFND-004-002
The Tool Properties view contains the most common options and operations related to the currently selected
tool. When you select a tool from the Tools toolbar, the Tool Properties view updates.
For example, if you choose the Select tool, the Tool Properties view will display the options and operations
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

NOTE
To learn more about the options appearing in the Tool Properties view, see Tools Properties on
page 160.

How to access the Tool Properties view
Do one of the following:
l

From the top menu, select Windows > Tool Properties.

l

From any of the other views, click the Add View
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Top View
T-HFND-008-014
The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the
scene’s stage from above. This lets the camera cone and the spacing between the elements be seen.

How to access the Top view
Do one of the following:
l

From the top menu, select Windows > Top.

l

From any of the other views, click the Add View

Icon

button and select Top.

Section

Description

Thumbnails

A thumbnail of each drawing layer in the scene. The
order of the thumbnail images is based on each
element’s FB position in the scene space. You can see
a representation of the FB position of each layer in the
camera cone.

Camera Cone

The camera cone represents the camera’s position and
field-of-view (FOV).
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Axis Reference Arrows

The axis reference arrows let you maintain your
orientation when navigating in the view.

Show/Hide Camera

Shows or hides camera frame in the Perspective view.

Reset View

Resets the pan, rotation, and zoom of the Perspective
view.
This field displays the current zoom level in the
Perspective view. You can use the Zoom level dropdown menu to select a specific zoom level from the
list. Zoom levels from 2.5% to 6400% are available;
you can also select Fit To View to automatically use a
zoom level that lets you see all your scene layers and
information in the Perspective view at once.

Zoom Menu

Layer Name

This field displays the currently selected layer and
drawing name.

Tool Name

This field displays the currently selected tool.

Frame Number

This field displays the currently selected frame of your
animation.

Colour Swatch

This field displays the currently selected colour in the
palette.
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Xsheet View
T-HFND-006-003
The Xsheet view lets you read the timing vertically by displaying it in a grid, with each drawing layer
represented by a column, each frame of your scene represented by a row, and each exposed drawing displayed
by its name in the cells. It is meant to work like a traditional animation exposure sheet.
Using the functions panel, you can also view the functions and keyframes of the motion paths for the selected
column, with the value of those functions for each frame listed in the cells.
Contrary to the Timeline view, the Xsheet view does not display pegs, effects or layer hierarchy. Hence, it is
optimized for traditional and paperless animation, whereas the Timeline view is optimized for digital or cut-out
animation.

How to access the Xsheet view
Do one of the following:
l

From the top menu, select Windows > Xsheet.

l

From any of the other views, click the Add View
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Icon

Section

Description

View Toolbar

The view toolbar contains all the tools and options
you can use in the Xsheet view to manage columns
and timing.
The Xsheet view has three sections. By default, only
the main section is visible. It displays the drawing
layers, also known as drawing columns.

Xsheet Main Section

When using advanced compositing and animation
techniques, unconnected functions (motion paths)
also appear in the main section. Unconnected
functions mean that some motion paths are not
attached to any particular layer.
When you reconnect functions to a layer, they are still
visible in the main section.

299

Chapter 6: Views

The Functions section is used for more advanced
techniques. This section displays the functions
(paths) related to the selected layer in the Timeline
view. By default, the Functions section is hidden.
In the Xsheet view, click the Expand button located on
the right side of the main section. Click on the same
button to collapse it. You can also use the Show
Column List button in the Xsheet View toolbar. If you
select a drawing column in the main section of the
Xsheet view, the function columns will not be
displayed. You must select the layer from the Timeline
view.
Functions Section

The Column List section allows you to show and hide
columns in the Xsheet view. When you hide a layer in
the Xsheet view, it is also disabled in the Timeline
view.

Column List Section

You can use the Column List to hide individual
columns or hide an entire column type (drawing or
function) from the Xsheet view. By default, the
Functions section is hidden.
In the Xsheet view, click the Expand button on the
right side of the main section to show the Functions

300

Harmony 15.0 Essentials Reference Guide

section. Click on the same button to collapse it. You
can also use the Show Column List

button in the

Xsheet toolbar.
Go to the Xsheet view menu and select View > Show
Column List. Click the Expand button on the right side
of the Functions section to display the Column List
section.

Each column available in the Xsheet view has a header
displaying the column’s name. The column’s name is
the same as the corresponding timeline layer. If you
rename one or the other, they will both be renamed.
A quick access menu is available when you right-click.
This menu contains the command affecting an entire
column such as renaming, changing the default
colour, or deleting a column.
The tooltip that appears when you hover at the top of
each Xsheet column shows the folder path to the
source drawings for that column.
Column Header

In Harmony, the column header shows the layer’s
name and the name of the drawing folder to which it
is linked. If the name of the layer is the same as the
drawing folder, the drawing folder’s name will not be
displayed. To modify the name of the element folder
independently from the column and layer name, you
must select the Advanced Element Mode option
preference in the Advanced tab of the Preferences
dialog box.
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A drawing selected in dark red indicates that the
drawing is currently displayed in the Drawing and
Camera views. The current drawing selection is not
linked to the drawing displayed in the Camera view
since drawings from each visible layer are displayed at
once.

Current Drawing

The darker frame appearing in the Xsheet view
represents the current frame.
Current Frame

In the drawing columns, you can see the drawing
names and their exposure. You can use any
alphanumeric symbol to name your drawing. When a
drawing is exposed over more than one cell, a vertical
black line is displayed to indicate the continuity of the
exposure. When there is no drawing in a cell, the cell
will be blank.

Drawing Exposure
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On the left side of the Xsheet view, the frame numbers
are shown indicating where you are. These read
vertically instead of being displayed horizontally as
they are in the Timeline view.
l

To go to a particular frame, click the frame
number.

Frame Numbers

l

To select an entire range of frames, click and
drag a selection downwards.

At the bottom-right of the Xsheet view, you can see
the current frame number, as well as the column
containing the drawing currently displayed in the
Drawing view.
Current Frame Display

The functions columns are displayed in the Functions
section of the Xsheet view. They represent the motion
and rotation you applied to a drawing layer.
A function column can also be related to an effect.
Selecting the effect layer shows you the
corresponding function column in the Xsheet view.

Functions Column

The function columns display the position value or
effect value on each cell. If there is a keyframe on a
cell, a black square is displayed. Holding the same
value for several frames displays a vertical black line.
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You can quickly increase or decrease the exposure of
the selected cell by clicking on the up and down
arrows in the Increase/Decrease Exposure field.

Increase/Decrease
Exposure

The Overwrite/Insert button allows you to decide the
way the values are inserted into the Xsheet.

Overwrite/Insert Modes
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