
TOON BOOM HARMONY 14.0
PREMIUM EDITION

User Guide



     

 

2



Harmony 14 Premium - User Guide

Legal Notices

Toon Boom Animation Inc.
4200 Saint-Laurent, Suite 1020
Montreal, Quebec, Canada
H2W 2R2

Tel: +1 514 278 8666
Fax: +1 514 278 2666

toonboom.com

Disclaimer

The content of this guide is covered by a specific limited warranty and exclusions and limit of liability under the 
applicable License Agreement as supplemented by the special terms and conditions for Adobe®Flash® File Format 
(SWF). For details, refer to the License Agreement and to those special terms and conditions.

The content of this guide is the property of Toon Boom Animation Inc. and is copyrighted.

Any reproduction in whole or in part is strictly prohibited.

Trademarks

Harmony is a trademark of Toon Boom Animation Inc.

Publication Date

9/12/2019

Copyright © 2017 Toon Boom Animation Inc., a Corus Entertainment Inc. company. All rights reserved.

3

http://www.toonboom.com/


Contents     

Contents
Toon Boom Harmony 14.0Premium EditionUser Guide 1

Contents 4

Chapter 1: User Guide 32

Chapter 2: Project Creation 33

About the Database 34

About the Database Structure 35

Starting Harmony 37

Connecting to the Database 39

About the Global Lock 42

Acquiring Rights to Loaded Scenes 43

About the Welcome Screen 44

About Documentation 46

Accessing the Documentation 47

Using the Integrated Help 48

About Scenes 51

About the File Structure 52

Creating Scenes 55

Creating Custom Resolutions 57

Opening Scenes 58

Setting the Scene Length 59

About Scene Settings 60

About  Scene Versions in the Harmony Server 61

Saving Scene Versions in the Harmony Server 62

Deleting Scene Versions in the Harmony Server 63

Merging Scene Versions in the Harmony Server 65

Advanced Saving in the Harmony Server 67

Opening Drawings in Paint 68

Opening Elements in Paint 71

About Saving 74

Saving Scenes 75

Saving Scenes as Copies 76

4



Harmony 14 Premium - User Guide

Saving Scenes as New Versions 77

Auto-Saving Scenes 78

About Drawing Lock 79

Locking Drawings 80

Verifying the Project Integrity 81

About Preferences 82

Chapter 3: Interface 85

Changing the Theme Colours 86

Changing the User Interface Language 87

About Menus 89

About Toolbars 92

Adding Toolbars 94

Moving Toolbars 95

Resizing Toolbars 96

Customizing View Toolbars 97

Enabling the Flat Toolbar 99

About Views 100

Adding Views 101

Closing Views 103

Showing and Hiding Views 104

Moving Views 105

Resizing Views 106

About Workspaces 107

Loading Workspaces 108

Creating Workspaces 109

Renaming Workspaces 111

Saving Workspaces 112

Deleting Workspaces 113

Showing and Hiding Workspaces 114

Reordering Workspaces 115

Restoring the Default Workspace 116

About Interface Navigation 117

Chapter 4: Drawing 119

5



Contents     

About the Brush Tool 121

Drawing with the Brush Tool 122

Modifying the Brush Settings 124

Selecting a Brush Preset 126

Creating a Brush Preset 127

Creating Dynamic Brush Presets 128

Renaming a Brush Preset 131

Deleting a Brush Preset 132

Updating a Brush Preset 133

Exporting Brush Presets 134

Importing Brush Presets 135

Changing the Brush Preset Display 136

About Vector Textured Brushes 137

Drawing with Vector Textured Brushes 139

Adding a Paper Texture 142

Renaming a Paper Texture 143

Deleting Paper Textures 144

Erasing Textured Lines 145

Exporting Paper Textures 147

Importing Paper Textures 148

Adjusting the Line Texture Opacity 149

Changing the Paper Texture Display 150

About Bitmap Brushes 151

Drawing with Bitmap Brushes 156

Creating Bitmap Brushes 158

Renaming Brush Tips 161

Deleting Brush Tips 162

Exporting Brush Tips 163

Importing Brush Tips 164

Changing the Brush Tip Display 165

Adding Bitmap Layers 166

Changing Art Modes 167

Converting Artwork 168

6



Harmony 14 Premium - User Guide

Setting the Bitmap Art Mode Preferences 170

Changing the Bitmap Resolution 171

About the Pencil Tool 174

Drawing with the Pencil Tool 176

Modifying the Pencil Settings 178

Selecting a Pencil Preset 181

Creating Pencil Presets 182

Creating Pencil Thickness Presets 183

Renaming Pencil Presets 184

Deleting Pencil Presets 185

Applying a Pencil Preset 186

Exporting Pencil Presets 187

Importing Pencil Presets 188

Changing the Pencil Preset Display 189

Changing Pencil Line Opacity Display 190

About Pencil Line Texture 192

Selecting Pencil Textures 193

Creating Pencil Textures 194

Applying Pencil Textures 196

Adding Pencil Textures to your Preferences 197

Displaying the Pencil Style Opacity Palette 198

About Shape Tools 199

Drawing with the Polyline Tool 200

Drawing with the Rectangle, Ellipse, and Line Tools 201

About the Stroke Tool 203

Drawing with the Stroke Tool 204

About the Eraser Tool 206

Erasing 207

Erasing Synced Drawings 208

Modifying the Eraser Settings 210

Exporting Eraser Presets 212

Importing Eraser Presets 213

Changing the Eraser Preset Display 214

7



Contents     

About the Select Tool 215

Selecting 216

Selecting Synced Drawings 218

Inverting a Selection 220

Repositioning the Selection Pivot 221

Working on a Single Drawing with the Select Tool 222

About the Repositioning All Drawings Tool 223

Repositioning Drawings 224

Repositioning All Synced Drawings 226

About the Cutter Tool 228

Cutting Artwork 229

Cutting Synced Drawings 230

About the Contour Editor Tool 232

Reshaping a Drawing with the Contour Editor Tool 233

About the Pencil Editor Tool 235

Reshaping Pencil Lines 236

About the Smooth Editor Tool 239

Smoothing Lines 240

About the Perspective Tool 241

Deforming a Drawing with the Perspective Tool 242

About the Envelope Tool 243

Warping a Drawing with the Envelope Tool 244

About the Text Tool 246

Adding Text 247

Breaking Text Apart 249

About the Rotate View Tool 250

Rotating the Workspace 251

About the Hand Tool 252

About the Zoom Tool 253

About Tool Presets 254

Displaying the Tool Preset Toolbar 255

Creating Tool Presets 256

Selecting Tool Presets 258

8



Harmony 14 Premium - User Guide

Deleting Tool Presets 259

Updating Tool Presets 260

Exporting Tool Presets 261

Importing Tool Presets 262

About the Grid 263

Displaying the Grid 264

Modifying the Grid 265

Grouping Drawing Strokes 266

Arranging Drawing Strokes 267

About Drawing Optimization 268

Flattening Drawings 270

Smoothing Drawings 271

Creating Contour Strokes 272

Removing Contour Strokes 273

Removing Extra Strokes 274

Optimizing Drawings 275

Cropping Brush Textures 276

Reducing the Drawing Texture Resolution 277

About Strokes Conversion 278

Converting Brush Strokes to Pencil Lines 279

Converting Pencil Lines to Brush Strokes 280

Converting Strokes to Pencil Lines 281

About OpenGL Antialiasing 282

Setting the Full Scene Antialiasing Preference 283

About the Tool Colour Swatches 284

Unlinking the Tool Colour Swatches 285

Linking the Tool Colour Swatches 287

Using Independent Bitmap Colour Swatches 288

Displaying the Current Drawing on Top 289

Chapter 5: Paperless Animation 291

Creating a Rough Animation 292

Creating the Tie Down Animation 296

Cleaning Animation 301

9



Contents     

Paperless Animation Tools 303

Creating Empty Drawings 304

About the Onion Skin 305

Enabling the Onion Skin 306

Displaying Marked Drawings in the Onion Skin 307

Displaying the Onion Skin in the Other Layers 309

Flipping Animation 311

About Marked Drawings 313

Marking Drawings 314

Creating Custom Markers 316

About the Drawing Desk 319

Adding Drawings to the Drawing Desk 320

Modifying Thumbnails in the Drawing Desk 322

About Shift and Trace 323

Enabling Shift and Trace 324

Shifting Drawings 325

Tracing Drawings 329

Linking Drawings in the Drawing Desk 330

Enabling the Drawing Desk Onion Skin 332

About Art Layers 333

Enabling the Overlay and Underlay Support 337

Switching between Art Layers 338

Creating Colour Art from Line Art 339

Generating a Matte 341

Previewing Drawings 343

Chapter 6: Timing 345

About Scene Length 346

Setting Scene Lengths 347

Modifying the Visible Scene Length 348

Adding Frames to the Middle of a Scene 349

Adding Frames to the Start or End of a Scene 351

Removing Frames 352

About Layers and Columns 354

10



Harmony 14 Premium - User Guide

Layer and Column Types 355

Adding Layers and Columns 358

Adding Layers in the Timeline View 359

Adding Layers from the Top Menu 360

Adding Columns from the Xsheet View 361

Using the Advanced Add Column Dialog Box 362

Deleting Layers and Columns 364

Renaming Layers and Columns 366

About Layer and Column Display 368

Expanding and Collapsing Layers and Columns 369

Showing and Hiding Layers and Columns 371

Showing and Hiding Layers 372

Showing and Hiding Columns 374

Showing Hidden Columns 375

Showing All Columns 376

Showing and Hiding Column Types 377

Showing and Hiding Function Columns 378

Customizing the Column Appearance 379

Displaying Xsheet Thumbnails 381

Changing Layer and Column Colours 382

About Scene Markers 384

Creating Scene Markers on Current Frames 385

Creating Scene Markers on Frame Ranges 387

Editing Scene Markers 388

Deleting Scene Markers 389

Setting Tempo Markers 389

Reordering  Layers and Columns 391

Navigating Layers and Columns 392

Duplicating Layers and Columns 394

Cloning Layers and Columns 395

About Sync Layers 396

Syncing Two Layers 397

Syncing Multiple Layers 399

11



Contents     

Creating Synced Layers 401

Selecting All Synced Layers 403

Unsyncing Layers 404

About  Annotation Columns 405

Adding Annotation Columns 406

Drawing in Annotation Columns 407

Typing in Annotation Columns 408

Erasing in Annotation Columns 409

Modifying Annotation Column Pen Options 410

Showing and Hiding Annotation Column Tick Marks 411

Importing Annotation Files 413

Using Timing Columns 414

Using the Element Manager 416

Displaying Layer and Column Properties 417

About Exposures 420

Inserting and Overwriting Exposures 421

Typing Exposures 422

Holding Exposures 424

Extending Single Exposures 425

Extending Exposure Sequences 427

Extending Previous Drawing Exposures 428

Dragging Cells 430

Increasing Exposures 433

Decreasing Exposures 434

Deleting Exposures 436

Inserting Blank Cells 437

Setting the Exposure 438

Filling Selections with Single Exposures 440

Filling Selections with Sequences 441

Filling Selections Randomly 443

Filling Empty Cells 445

About Cycles 446

Creating Cycles 447

12



Harmony 14 Premium - User Guide

Pasting Cycles 448

Pasting Reversed Cycles 450

Overwriting Exposures and Keyframes 452

About Key Exposures 453

Adding Key Exposures 454

Removing Key Exposures 456

Removing Duplicate Key Exposures 457

Pasting Key Exposures Using Different Modes 458

Modifying Paste Presets 460

About Drawings 462

Renaming Drawings 463

Deleting Drawings 465

Duplicating a Drawing 466

Copying and Pasting Drawings 467

Merging Drawings 470

Merging Selected Drawings 471

Merging All Drawings 473

Printing the Xsheet 474

Chapter 7: Colours 477

About Colour Swatches 479

Locking and Unlocking the Colour List 480

Adding a Colour Swatch 481

Deleting a Colour Swatch 484

Adding a Gradient Colour Swatch 485

Adding a Texture Colour Swatch 487

Modifying a Texture Colour Swatch 488

Mixing Colours 489

Protecting Colours 491

Copying and Pasting Colours 492

Changing the Colour Display Mode 494

About Palettes 495

Element Level 497

Scene Level 497

13



Contents     

Where to Save the Palette File 497

What happens when you export a palette file? 498

Palette Backup 499

About the Palette List 500

Showing and Hiding the Palette List 503

Locking and Unlocking the Palette List 504

Enabling the Advanced Palette Mode 505

Creating a Colour Palette 506

Renaming a Colour Palette 510

Removing a Colour Palette 511

Duplicating a Colour Palette 512

Cloning a Colour Palette 513

About Linking and Importing Palettes 517

Importing a Colour Palette 519

Linking a Colour Palette 521

Linking to an External Colour Palette 523

Palette Operations 525

Opening the Palette Operations Dialog Box 526

Cloning a Palette in the Palette Operations Dialog Box 527

Renaming a Palette in the Palette Operations Dialog Box 529

Deleting a Palette in the Palette Operations Dialog Box 530

About Painting 532

About Colour Models 533

Loading Colour Models 534

Clearing Colour Models 537

Copying Colour Models 538

About Dirt Cleanup 540

Removing Dirt 541

Removing Dirt Outside the Selection 542

Removing the Art Inside the Selection 543

Removing Hair 544

Painting Drawings 545

Repainting 548

14



Harmony 14 Premium - User Guide

Repainting a Selection 549

Repainting Outside a Selection 551

Unpainting a Selection 553

Unpainting Outside a Selection 554

Selecting Strokes with the Current Colour 555

Creating Break Triangles 556

Closing Gaps 558

Picking a Colour with the Dropper Tool 559

Inking Lines 560

Verifying Painted Zones 562

About the Edit Gradient and Texture Tool 565

Using the Edit Gradient and Texture Tool 569

Storing the Gradient and Texture Settings 571

Using the Stored Gradient and Texture Settings 572

Chapter 8: Rigging 573

Chapter 8: About Rig Types 574

About Simple Rigs 575

About Drawing Hierarchy Rigs 576

About Peg Hierarchy Rigs 578

About Scene Setup for Rigging 579

About Models 580

About Size Relation 582

Setting Preferences for Rigging 584

About Naming Conventions 585

Naming Drawing Layers 586

Naming Drawings Substitutions 589

About Character Breakdown 591

Tracing the Model 594

About Cutting the Character into Pieces 597

Breaking Down the Main Parts 598

Breaking Down Secondary Parts 601

Breaking Down Other Views 604

Breaking Down Secondary Parts in the Extra Views 605

15



Contents     

Completing Parts and Articulations 606

Distributing to Layers 608

About Articulations 609

Creating Classical Articulations 610

About Auto-Patch Articulations 612

About the Auto Patch Node 613

About Ordering Layers 615

Ordering Layers in the Timeline View 616

Ordering Layers in the Node View 617

About Z Nudging 619

Nudging Layers 620

About Pivots 621

About Permanent Pivots 622

Setting Permanent Pivots 623

Setting Multiple Permanent Pivots 624

About Drawing Pivots 625

Setting  Multiple Drawing Pivots 626

About Symbol Pivot 628

Setting Symbol Pivots 629

Adding Pegs 631

Creating Hierarchies 633

Adding the Master Peg 637

Fine-Tuning the Rig 639

Invert-Cutting 640

Changing Composite Modes 642

Adding Displays 643

Grouping Rigs 645

Creating Keyframes 647

About Timeline Marking 648

About Backdrops 649

Adding Backdrops 651

Removing Backdrops 652

Customizing Backdrops 653

16



Harmony 14 Premium - User Guide

Organizing Nodes in Backdrops 655

Moving Backdrops 656

Copying and Pasting Backdrops 657

About Pose Copier 658

Adding the Pose Copier Script to the Scripting Toolbar 659

About Guide Layers 660

Creating Guide Layers 662

Creating a Pose Copier Template 663

Excluding Modules Using the Pose Copier 664

Pasting Poses Using the Pose Copier 666

Chapter 9: Deformation 669

About Deformer Types 670

About Bone Deformation 671

About Game Bone Deformation 672

About Curve Deformation 673

About Envelope Deformation 674

About Basic Deformation Chain Creation 675

Selecting Elements for Deformation 676

Adding Bones to Deformation Chains 678

Creating Curve Deformation Chains 680

Creating Envelope Deformation Rigs 682

Automatically Grouping Deformation Nodes 684

Adding Deformation Nodes 685

About  Rest Position Setting 686

Setting Rest Positions for Bone and Game Bones 688

Setting Rest Positions for Curve Chains 691

Setting Rest Positions for Envelopes 693

About Regions of Influence 695

Selecting Region of Influence Types 696

Setting Up Elliptic Regions of Influence 697

Setting Up Shaped Regions of Influence 700

Converting Elliptic Regions of Influence into Shapes 702

Modifying Influence Fade Radii 703

17



Contents     

About Assembly 705

Assembling in the Timeline View 707

Assembling in the Node View 709

Displaying Selected Deformation Controls 711

Hiding Deformation Controls 712

About Deformation Animation 713

Animating Bone and Game Bone Deformers 714

Animating Curve Deformers 717

Animating Envelope Deformers 721

Resetting a Deformer to its Resting Position 724

Converting Deformation Animation to Drawings 725

Disabling Deformation Preview 726

About Multi-pose Deformation Rigs (Transformation Chains) 727

About Character Preparation for a Multi-pose Deformation Rig 728

About Structure for Multi-pose Deformation Rigs 729

730

Renaming Drawings for Multi-pose Deformation Rigs 731

Creating New Deformation Chains (Transformation Chains) 733

Creating Main Deformation Chains for Multi-pose Rigs 734

Reusing Deformation Groups for Multi-pose Rigs 736

Creating Additional Deformation Chains for Multi-pose Rigs 739

Renaming Transformation Chains on Multi-pose Rigs 740

Linking Drawings to Transformation Chains 741

Converting Drawings to New Deformation Chains 742

About Legacy Deformations 743

Transferring Curve Positions of Legacy Deformations 744

Converting Legacy Deformation Chains 746

Chapter 10: Gaming in Harmony 749

About Game Asset Creation 752

Game Rigging Guidelines 754

Game Deformation Guidelines 756

Game Cutter Guidelines 757

Creating Metadata Notes 758

18



Harmony 14 Premium - User Guide

Game Animation Tips 760

Animating Multiple Sequences 760

About the Orthographic Camera 762

Using the Harmony Game Previewer 763

About Export to Unity 764

Clearing Scripts 765

Setting Anchors and Props 766

Exporting Sprite Sheets 768

Exporting to Easel JS 770

About Working in Unity 772

About the Sample Unity Project 773

About the Unity Interface 774

Importing Harmony Files into Unity 775

About Game Objects 776

Using Empty Game Objects 777

Using Plane Game Objects 780

Attaching Props to Anchors in Unity 781

Placing Locators in Unity 783

Setting Up Collisions in Unity 785

About Working with Audio in Unity 786

Chapter 10: Troubleshooting 787

Chapter 11: Library 791

About Structure 793

Creating Libraries 794

Opening Libraries 795

Closing Libraries 796

Creating Folders 797

Deleting Folders 798

Renaming Folders 799

Refreshing Libraries 800

Generating Thumbnails 801

Deleting Thumbnails 802

Searching in Libraries 803

19



Contents     

About Templates 804

Creating Templates 805

Deleting Templates 808

Editing Templates 809

Importing Templates 810

Opening Templates as Folders 813

About Symbols 814

Creating Symbols 815

Creating a Symbol from a Drawing 817

Creating Empty Symbols 819

Deleting Symbols 820

Editing Symbols 821

Importing Symbols 823

Expanding Symbols 823

Converting Symbols to Templates 825

Importing Files in the Library 826

Using Paste Special 827

Chapter 12: Cut-out Animation 829

About Animating with the Transform Tool 830

Animating with the Transform Tool 832

Resetting Transformations 833

About Hierarchy Navigation 835

Navigating Layers 836

Selecting Parent and Children 837

Centering on Selections 838

About Keyframes 839

Creating Motion Keyframes 840

Creating Stop-motion Keyframes 842

About Swapping Drawings 844

Swapping Drawings in the Timeline View 845

Swapping Drawings in the Library View 846

Adding Key Exposures 848

Removing Key Exposures 850

20



Harmony 14 Premium - User Guide

About Eases 851

Setting Eases for Multiple Parameters 852

Using the Onion Skin in Cut-out Animation 855

Add to Onion Skin 855

Remove from Onion Skin 856

Remove Unselected from Onion Skin 856

Add All to Onion Skin 856

Remove All from Onion Skin 856

Using the Outline Mode 857

Flipping Through Poses 860

Flipping Parts 861

Animating Lip-Sync 862

Ordering  in Z-Depth 866

Creating Cycles 868

About Timeline Marking 871

Marking the Current Frame 872

Marking Frame Ranges 874

Marking Layers with Colour 875

About Inverse Kinematics 876

About IK Hierarchy Chains 879

About IK Setup 881

Excluding Elements from IK Skeletons 883

Orienting Bones 884

Setting Minimum and Maximum Angles 885

About Nails 886

Setting Nails 887

Animating with Inverse Kinematics 888

About IK Keyframes 890

Setting IK Keyframe Constraints 891

Chapter 13: Morphing 893

About Source and Destination Drawings 894

About Morphing Rules 895

About the Closest Similar Shape Rule 896

21



Contents     

About the Pencil Line to Pencil Line Rule 897

About the Fill Shape to Fill Shape Rule 899

About the Same Colour Swatch Rule 900

About the Vanishing and Appearing Rule 901

About the Colour Art and Line Art Rule 902

Creating Morphing 903

Deleting Morphing 906

About Morphing Velocity and Timing 907

Adjusting the Morphing Velocity 908

Adjusting the Morphing Timing 911

About Morphing  Hints 912

About Hint Types 914

About Contour Hints 915

About Zone Hints 916

About Pencil Hints 917

About Vanishing Point Hints 918

About Appearing Point Hints 919

Adding and Deleting Morphing Hints 920

Copying Hint Points 923

About Morphing Layers 926

Creating Morphing with Morphing Layers 929

About Morphing Key Drawings 933

Inserting Morphing Key Drawings 934

About Transparency Morphs 935

Morphing Transparencies 936

About Morphing Quality 938

Setting the Morphing Quality Level 939

Converting Morphing Inbetweens to Drawings 940

Chapter 14: Import 941

About Bitmap Images 942

Importing Bitmap Images As Original Bitmap 943

Adjusting the Bitmap Image Display Quality 947

Importing Bitmap Images As Toon BoomBitmap 948

22



Harmony 14 Premium - User Guide

Vectorizing Images on Import 951

Linking Layers to External Images 953

About Vector File Import 955

Importing AI and PDFs 956

Importing SWF Files 958

Distributing SWFs to Layers 961

About FLA  Import 962

Installing the Export to Harmony Option 964

Exporting FLA Files 972

Displaying the Import Flash Scene Icon 974

Importing FLA Files 977

About Flash File Creation 979

Scene Root 979

Timeline 979

Library View 979

Effects 979

Drawing Features 980

Mixed Layers 981

About PSD Files 983

Importing Multi-layer PSD Files 984

Exporting PSD Layouts 987

Importing PSD Layouts 989

Importing QuickTime Movies 992

About Scanning 993

Scanning Images 994

Vectorizing Scanned Drawings 996

About Custom Vectorization Parameters 999

Creating Vectorization Styles 1000

Setting the VectOptions.conf File 1002

Overwriting Using Scanned Drawings 1007

Chapter 15: Staging 1009

About Layer Position 1010

About the Animate Mode 1011

23



Contents     

Selecting Layers 1012

Setting Bounding Box Styles 1014

Centering on Selections 1015

About the Transform Tool 1016

Repositioning Temporary Pivots with the Transform Tool 1018

Panning with the Transform Tool 1019

Rotating with the Transform Tool 1020

Scaling with the Transform Tool 1021

Skewing with the Transform Tool 1022

Flipping with the Transform Tool 1023

About Advanced Animation Tools 1024

Repositioning Permanent Pivots 1025

Using the Translate Tool 1026

Using the Rotate Tool 1027

Using the Scale Tool 1028

Using the Skew Tool 1029

About the Layer Properties View 1030

Displaying the Layer Properties View 1032

Positioning Elements with the Layer Properties View 1033

About Selection Locking 1035

Locking Layers 1036

About Auto-Apply 1039

Setting the Auto-Apply Option 1040

Resetting Transformations 1041

About Multiplane 1043

Setting Up Multiplanes 1046

About Clone and Duplicate Layers 1048

About Clone Layers 1049

Cloning Layers 1050

About Duplicate Layers 1051

Duplicating Layers 1052

About Timeline View Modes 1053

Tagging Layers 1055

24



Harmony 14 Premium - User Guide

About Nodes 1056

About Input and Output Ports 1058

Displaying Port Tooltips 1060

About Composite Nodes 1061

About Peg Nodes 1062

Adding Nodes 1063

Connecting and Disconnecting Nodes 1064

Spreading Nodes 1066

Enabling and Disabling Nodes 1067

Navigating the Node View 1069

Displaying Node Thumbnails 1071

Changing Cable Styles 1074

About Groups 1075

Grouping Nodes 1077

Grouping Layers 1078

Ungrouping Nodes 1079

Entering Groups 1080

Exiting Groups 1081

Moving Up Group Levels 1082

Moving Nodes to Parent Group 1083

Publishing Attributes 1084

About Displays 1086

Adding Display Nodes 1089

Changing Global Displays 1090

Setting Advanced Display Options 1091

Setting Properties for Many Layers 1092

Chapter 16: 3D Space 1095

Enabling the 3D Option 1096

About 3D Parameters 1098

About the 3D Scale Parameter 1099

About the 3D  Rotation Parameter 1100

Euler Angles Rotation 1100

About the 3D  Pivot Parameter 1102

25



Contents     

About 3D Tools 1103

About the 3D Translate Tool 1104

About the 3D Rotate Tool 1105

About the 3D Scale Tool 1106

About the 3D Transform Tool 1107

About 3D Space Positioning 1109

About Planning 1110

About Maximizing Efficiency 1112

Positioning Layers in 3D Space 1113

Using the Depth View Mode 1116

About 3D Input Output Options 1118

About 3D Composite Nodes 1120

Chapter 17: 2D-3D Integration 1123

About Reference Model 1124

About 3D Models in Harmony 1125

About the 3D Graph View 1126

Enabling Subnodes 1127

Disabling Subnodes 1128

Making Subnodes Animatable 1129

Linking to 3D Movements 1131

Exporting 3D Objects 1137

Setting 3D Renderer Paths 1140

Importing 3D Objects 1142

About 3D Object Manipulation 1144

About 3D Objects in Different Views 1145

About 3D Objects in the Perspective View 1146

About 3D Objects in the Camera View 1147

About 3D Objects in the Top and Side Views 1148

Animating Individual Parts of 3D Models 1149

About  Translate Tool 3D Manipulation 1152

About Rotate Tool 3D Manipulation 1153

About Scale Tool 3D Manipulation 1154

About Transform Tool 3D Manipulation 1155

26



Harmony 14 Premium - User Guide

2D Object Manipulation 1157

Editing 2D Objects in 3D Space 1158

About Rendering 3D Models with Autodesk Maya 1160

Preparing the Project Directory 1161

Setting the Path on Windows 1162

Setting the Script on Mac OS X 1164

Setting the Path on Linux 1165

About Node View Setup 1166

Setting Up Nodes for 3D Renders 1167

Setting Up 3D Transparency and Anti-aliasing 1169

Smoothing Using the Z-Buffer 1171

Chapter 18: Motion Paths 1173

About Pegs 1174

Adding Pegs 1176

Enabling Peg Selection Mode 1178

Connecting Nodes to  Pegs 1179

About Drawing Layers 1180

Disabling Layer Animation 1182

About Layer Parameters 1183

Displaying Layer Parameters 1185

Setting Layer Parameters 1186

Enabling Constant Z 1187

About Keyframes 1188

Enabling the Animate Mode 1189

About Keyframe Creation 1190

Creating Keyframes in the Timeline View 1191

Creating Keyframes in the Function View 1193

Creating Keyframes in the Xsheet View 1195

Deleting Keyframes 1197

Animating with Keyframes 1198

Changing Keyframe Values 1200

Switching Keyframe Types 1202

Changing Stop-motion Keyframe Colour 1205

27



Contents     

Jumping to Keyframes 1206

About Controls 1207

Displaying Controls 1209

Adding Control Points 1210

Toggling Point Types 1211

Adjusting Tension, Bias, and Continuity 1212

Converting Angled and Curved Corners 1214

Offsetting Trajectories 1215

About Functions 1217

Creating Functions 1219

Converting Functions 1221

Sharing Functions 1223

Linking Functions 1226

About Copying Motions 1229

Using Timeline Paste Modes 1230

Using Paste Special 1232

Cycling Animations 1233

Pasting Reverse Motions 1234

About Velocity 1235

Displaying Velocity Curves 1237

Adjusting Bezier Curve Velocity 1239

Adjusting  Ease Curve Velocity 1240

Creating Stepped Velocity 1241

Adjusting Velocity in the Timeline View 1245

Setting Ease on Multiple Parameters 1246

About Expression Columns 1248

Writing Expressions 1248

Expression Dialog Box 1248

Expression JavaScript Program 1249

API 1249

Predefined Functions 1250

Writing Expressions 1252

About Animation Resources 1255

28



Harmony 14 Premium - User Guide

Creating Selection Presets 1256

Chapter 19: Cameras 1259

Clipping Planes 1260

Camera Types 1262

Adding a Camera 1263

Setting the Camera Type 1265

Selecting the Active Camera 1266

Positioning the Camera Frame 1267

Resetting the Camera Position 1271

Setting the Camera Clipping Planes 1272

Animating the Camera 1274

Creating 3D Camera Movements 1277

Enabling the 3D Playback Mode 1279

Animating a Camera Shake Using the Quake Node 1280

Animating the Line Thickness on Camera Move 1282

Chapter 20: Sound 1285

About the Sound  Editor 1286

Sound Layer Properties 1287

Importing Sound 1288

Playing Sound 1289

Changing the Sound Display 1290

Sound Scrubbing 1292

About Analog Sound Scrubbing 1293

Editing Sound 1295

Cropping Sound 1297

Trimming Sound 1299

Looping Sound 1300

Mixing the Sound Volume 1301

Setting the Playback Range 1303

Adding an Empty Sound Layer 1304

About Lip-sync 1306

Generating a Lip-sync Detection 1307

Mapping the Lip-Sync Detection 1310

29



Contents     

Modifying the Lip-sync Detection 1311

Manual Lip-syncing 1313

Exporting Sound 1314

Chapter 21: Effects 1317

Adding Effects Nodes 1319

Connecting Effects 1320

About Node Categories 1323

Displaying All Nodes 1324

Adding a Node Library View Category 1325

Removing a Node Library View Category 1327

Renaming a Library View Category 1328

Adding Nodes to Categories 1329

Removing Nodes from Categories 1330

Searching for Nodes, Categories, and Descriptions 1331

About Effects Preview 1332

Previewing Effects in Render Mode 1333

Previewing Effects in OpenGL Mode 1334

Playing Back Effects 1336

Changing the Preview Resolution 1337

Animating an Effect 1338

About Advanced Node Usage 1341

Using the Shadow Node 1342

Using the Cutter Node 1345

Using the Highlight Node 1347

Using the Tone Node 1349

Using the Greyscale Matte Port 1351

Using the Blur Radial Zoom Effect 1353

Overriding a Colour 1358

Overriding a Colour With a Texture 1360

Modifying a Texture Fill's Transformation 1366

Overriding a Colour with a Bitmap Image Sequence 1369

Overriding a Texture on a Pencil Line 1371

About the Light Shading Effect 1377

30



Harmony 14 Premium - User Guide

About Light Shading Nodes 1381

Light Shading Setup 1384

Adding and Carving Volumes 1391

Animating the Light Source and Target 1393

About OpenFX 1395

Installing an OpenFX Package 1396

Using OpenFX Plugins 1397

Using the Normal Map Converter 1400

About Particles 1403

About the Particle Basic Structure 1404

About the Particle System Colour Coding 1405

Accessing Default Particle Templates 1406

About Exposure Fill Using Render Change 1408

Using the Exposure Fill Render Change 1409

Chapter 24: Export 1413

Exporting QuickTime Movies 1414

Exporting SWF Movies 1419

Exporting OpenGL Frames 1421

Exporting Sound 1423

About  Node View Export 1425

Adding Write Nodes 1426

Exporting Image Sequences from the Node View 1428

Exporting QuickTime Movies from the Node View 1434

About Multiple Renders 1436

Setting Scale-Output Nodes 1437

Setting Crop Nodes 1439

Exporting Multiple Renders 1442

Rendering from Write Nodes 1445

Batch Rendering 1446

31



Chapter 1: User Guide     

Chapter 1: User Guide
The Harmony core functionality are explained in this User guide. All the steps required to create and complete a 
project are covered in the following chapters with concept descriptions and detailed step-by-step procedures 
focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide and 
Preference guide. Some of them are explained here where necessary to the understanding of a given concept or 
procedure.  
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Chapter 2: Project Creation
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will learn about 
starting the application, creating scenes, setting the resolution and opening the scenes. 
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About the Database

Harmony can be used in database mode (online) via the server connection (Harmony Server) or as a standalone 
application (offline).

Several animators can work simultaneously on the same project while the asset library provides users with easy 
access to up-to-date media assets. Harmony is scalable; more than 100 staging clients can share animation just 
as easily as a few can. 

Harmony Server is the link between the client machines and the server. It lets you work on the different projects 
stored in the central Harmony database. 

At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository. The 
server is compatible with Windows, Linux or Mac OS X. To learn more, refer to the Control Center Guide.

If you installed the complete version (Harmony Server / Network), when you start Harmony, you can opt to either 
work offline in the application as a standalone software, or connect to the database to work on projects via the 
database.

When working with Harmony Server, the scenes and their data are stored directly on the server. No data is saved 
or stored on the client machine. The client machines access the database and load the scenes and drawings 
directly from the server. Each time the user saves his scene, the data is updated directly on the server. There are 
no upload or download operations (check-in, check-out) done between the server and the clients.

NOTE: If you have a standalone license, you will not have access to the database. You will automatically 
start the application in standalone mode.
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About the Database Structure
Harmony Server has a client-server configuration linked through a network. Although the user is working on a client 
machine, all of the data is saved on the server.

You can compare the Harmony Server structure to a filing cabinet. Every element is structured and follows a strictly 
organized hierarchy.

The following production structure hierarchy is used:

 l Environment: Production, project, feature film, series—see Environment Structure on page 35

 l Job: Episode and sequence from each environment

 l Scene: Scene from each job

 l Element: Layers and columns from each scene

 l Drawing: Drawings from each element

If you imagine the environment as a filing cabinet containing all the folders and information, then the following 
structure is used:

 l The job is a drawer in the filing cabinet containing all the folders related to the drawer’s topic.

 l The scenes are the folders contained in that drawer

 l The elements are the papers contained in the folder

 l The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so nothing is 
lost. By adhering to this structure, every user working in the database always knows where to find the scenes to 
work on.

Environment Structure

Before you create or save any elements in your production, you should decide upon a project name. This should 
reflect the content or title. Use the name to create the project’s environment, where you will store all of your 
production elements.

For example, the environment could be called adventure_movie. An environment can be used for movies, series, 
commercials, student work database, etc.
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For a series, you can create an environment with the same name as the series, such as smith_family. Then 
you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers 
represent:

 l sm: The first two letters of the name smith

 l ep: Episode

 l 001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can 
create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require 
splitting into episodes or sequences, you can group them all in the same environment.

For a database of student’s work, you can create an environment and name it with the class or group name, such 
as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store the 
different student exercises in separate scenes under their job name.
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Starting Harmony
T-HFND-001-002

You can run Harmony on Linux, Mac OS X or Windows operating systems.

NOTE: On Mac OS X 10.10.5 and more recent versions, Harmony and its modules will not start the first time if 
your security is set to Mac App Store and Identified Developers. Change your security to Anywhere or right-
click on Harmony or its modules to open it for the first time only.

How to start Harmony 

 1. Do one of the following:
 l Windows: Start > Programs > Harmony 14.0 Premium > Harmony Premium

 l Mac OS X: Applications > Toon Boom Harmony 14.0 Premium > Harmony Premium

 l Linux: /usr/local/ToonBoomAnimation/harmonyPremium_14/lnx86_64/bin/HarmonyPremium

Toon Boom Harmony opens. If you have the complete version installed, the login dialog box opens.

NOTE: If you have a standalone license, Toon Boom Harmony will open directly with the Welcome screen.

 2. To connect to the database, in the User Name field, enter your username. It is generally provided by the 
supervisor, system administrator or team lead.

 3. Select the  Connect to Database or Work Offline option.
 l Connect to Database: (Your database must first be set up.) Lets you work on Harmony connected to 

the database so you can access scenes stored in the central database of the Toon Boom Server; cer-
tain options become available in the different menus. However, you will not be able to create new 
scenes directly from Harmony Premium and the available scenes will be the ones that were previously 
created using the Control Center.

 l Work Offline: Enabled by default when you start Harmony for the first time. Using this mode lets you 
create new scenes and work locally on your machine on independent projects as you would with any 
local software. However, the following limitations apply:

 l Options exclusive to Harmony Server will not be available in the different menus.
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 l You will not have access to any projects stored in the central database of the Toon 
Boom Server.

 4. Click OK.

In Offline mode, the Welcome Screen opens—see About the Welcome Screen on page 44.

In Database mode, the Database Selector opens—see Connecting to the Database on page 39.
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Connecting to the Database

Before you can work in Harmony  via Harmony Server, you must be connected to the Harmony database. When you 
connect to the database, you cannot create new scenes directly from Harmony Premium. The available scenes will 
be the ones that were previously created using the Control Center module. 

How to connect to the Harmony database

 1. Start  Harmony —see Starting Harmony on page 37.

 2. In the Toon Boom Harmony window, select the Connect to Database option. 

 

 3. In the User Name field, type in your Harmony username which is provided by your project lead or system 
administrator. 

 

 4. Click OK. 

The Database Selector dialog box opens, displaying the environments available in Harmony database.
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 5. In the Environments column, select the scene's environment (project, movie). 

 

 6. In the Jobs column, select the scene's job (episode, sequence). 

 7. In the Scenes column, select the scene. 

 8. Get the permissions needed for this session by selecting one of the following options:

 

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can 
be locked. Locking means that you have the rights to modify a scene or its assets. Other users 
cannot modify locked items. If someone tries to open a locked scene, it will be displayed as read-
only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock Controls the Xsheet timing, layers, nodes but not the drawing, 
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palettes, palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

 9. Choose the version you want to open from the Version menu—see Saving Scenes on page 75.

 

 l The Saved By and Saved Date fields display the user who last saved the selected scene and 
the date of the last save.

 

 

 10. Click Open.
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About the Global Lock
Harmony Server has a lock system, referred to as Global Lock, for the different scenes and scene assets. 
Because all the data on the server can be accessed directly and modified from any client machine by default, the 
scenes are locked. You must obtain the rights to modify scenes in order to save your work on the server.

Only one user at a time can modify a scene. Once a scene is opened on a client machine, other users can only 
open the scene in read-only mode; they will not be able to save any modifications.

If you work in standalone mode, you automatically have the rights to modify all drawings and palettes.

Global Lock offers three levels which are available from the Database Selector when you log in to Harmony. From 
there, you can select a scene and obtain the rights to modify it by selecting the desired lock option.

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked. 
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked items. 
If someone tries to open a locked scene, it will be displayed as read-only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, nodes but not the drawing, palettes, 
palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a 
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is 
created using the Control Center module.
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Acquiring Rights to Loaded Scenes
If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire the necessary 
rights without closing and reloading the scene. 

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This process is 
done during the initial loading of the scene. To learn more about enabling the rights to modify while creating 
environments, jobs and scenes, refer to the  Control Center Guide.

How to set the scene's rights after the scene is loaded

 1. In the top menu, select File and one of the following:

 l Rights to Modify Scene: Allows you to modify the selected version of the scene and access 
the version manager during the opened session

 l Rights to Modify Scene Version: Allows you to modify the currently selected scene ver-
sion, but locks access to the version manager during the opened session.
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About the Welcome Screen
T-HFND-001-003

When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display 
the Welcome screen by selecting Help > Show Welcome Screen.

NOTE: If you are using Harmony Server in Database mode, the Welcome screen will not open. Instead, the 
database selector will open and allow you to open a scene from the database.

The Welcome screen allows you to:

 1. Create scenes

 2. Choose your scene resolution

 3. Quickly open recently edited scenes

 4. Manage your scene resolution presets

 5. Watch Harmony video tutorials

 6. Open the online support page

 7. Browse for and open a scene from your documents

 8. Decide to skip the Welcome screen and open Harmony directly on launch from now on
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NOTE: To display the Welcome screen later on, go to the top menu and select Help > Show Welcome 
Screen. You can enable showing the Welcome screen on launch again by unchecking the Do not show this win-
dow on startup option.
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony. The 
documentation of features and procedures exists online, but you can access it through the software.

A simple, but fast way to find a description of certain menu items and preferences is through the Integrated Help.
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Accessing the Documentation
T-HFND-001-004

The Harmony documentation can be accessed from the Welcome Screen and the Help menu.

How to access the Harmony documentation

 1. In the Support section, click on the Get Help  button.

Your default web browser opens to the Toon Boom Support page.

 2. From the Support page, under the Learn Toon Boom Software section, click on the Documentation button.

The Toon Boom Help page opens.

 3. From the Toon Boom Help page, click on the Harmony icon.

The Harmony Help page opens.

All the Harmony guides can also be opened directly in the software. Select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in the 
Preferences panel, use the Integrated Help.

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through a history of the help information that you called up during your 
session.

How to use the Integrated Help with Menu Items

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, click on a menu heading to display its contents.

 3. Use your mouse to hover over a menu item.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS X).

The Preferences window appears.

 3. In the Preferences window, use your mouse to hover over a preference.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the preference appears.

49



Chapter 2: Project Creation     About Documentation

How to scroll through the bank of searched items

 l In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE: The moment you close the Integrated Help window all searched items will be erased from the 
memory bank. In order to keep an on-going record of all the search requests made, you must keep the win-
dow open.
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About Scenes
When working in production, it is important to keep your work organized. It is important to create a naming 
convention chart and establish a file storage structure before starting the project. It is not only extremely important 
that everyone follows the criteria laid out in the naming convention chart and the file storage structure, but also that 
they understand the organization and where to find the files.

A well thought-out and logical naming convention will help keep your production structured and allow it to run 
smoothly by preventing the loss of files due to chaotic organization.

In this section, you will learn how to create, open, organize,  and name the different components in your animation 
project.
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About the File Structure
T-HFND-001-008

A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the 
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the files 
contained in the folder structure.

For Harmony Server, the scene files as well as user and configuration files are contained within the database 
structure. If you want to share or archive a project, you will need to use Control Center to export your data from 
the database. If you receive a package from another user or studio, you will also need to use Control Center to 
import it in your database. Refer to the Control Center Guide to learn how.

Harmony Server Database Files

All Harmony Server directories are located by default on Windows in C: or on Mac OS X at the root of the main 
drive where the operating system is installed.

/usa /usa/nt/bin/ • Program directory (.exe)

 /usa/etc/ • Configuration files directory

 /usa/etc/flexlm/ • License directory

/usa_db

 

• Centralized database containing the structure of all the data that 
Harmony uses, except for the drawings and final images

• Link to the databases (file systems)

• User profiles

/usadata

 

• All the data is stored here

• All the files including drawings, final frames, and sounds are 
placed in the different usadata folders

• There can be more than one usadata000 file system created, such 
as usadata001, depending on the disks and the computer’s 
organization

usa_db Structure

The usa_db folder contains the configuration files, database and project structure, as well as shortcuts to scene 
data. If you browse through usa_db to get to a scene, you will navigate directly to the jobs folder. Even though the 
root of the project structure is the environment, you will go to jobs. The environment folder contains only the 
environment list, global environment libraries and configuration files. This means that for different projects, even 
though jobs are contained in different environments in Control Center, jobs must have unique names as they are 
physically contained in the same jobs folder.

Within the jobs folder, you will find a directory for each individual job. Within each job folder, you will find the folder 
for the global job library, job palettes, as well as a shortcut for each scene contained in the job. These shortcuts 
go to the scene data location. Depending on the parameters set upon creating the scene in the Control Center, 
different scenes may be located on different file systemss on different servers, based on storage space and other 
structure organization.
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Scene File Structure

Here is an example of the file structure contained in a scene. As you work and use more features, different folders 
may appear in your structure.

The Harmony scene folder contains the following folders: frames, audio, elements, etc.

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation 
column in the Xsheet view.

audio Contains all imported audio files.

database
(Harmony Server) This is no longer used for new projects; it remains for projects 
created with older versions of the software.

elements
Contains all the drawing files. The drawings are organized by folders named like 
the layers they are associated with.

environments

(Harmony Stand Alone) Contains the exported palette files that were originally 
stored at the environment level in the Harmony Server database structure or the 
palettes in a Harmony Stand Alone scene that will be imported later at the 
environment level in Harmony Server.
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frames
Contains the final frames after a render if you are using the default settings of the 
Write node in the Node view.

jobs

(Harmony Stand Alone) Contains the exported palette files that were originally 
stored at the environment level in the Harmony Server database structure or the 
palettes in a Harmony Stand Alone scene that will be imported later at the 
environment level in Harmony Server.

palette-library Contains scene palettes and scene palette list files.

stage
(Harmony Server) Contains multiple versions of a scene. This is useful if you are 
experimenting with different ways to do a scene. Note that all versions of a scene 
use the same drawing and palette files.

timings
This folder is used when a user links external images to a scene and wants to 
store a backup copy in case the link breaks.
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Creating Scenes
T-HFND-001-005

All scenes created via  Harmony Stand Alone are independent and local to the computer. You can create or open a 
scene using the Welcome screen or the File menu.

In Harmony Server, you cannot create scenes directly in Harmony. You must use the Control Center application.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.

NOTE: The scene name should not exceed 23 characters and cannot contain special characters, 
such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created.

How to create a new scene from the File menu

 1. Do one of the following:
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 l From the top menu, select File > New. 

 l In the File toolbar, click the New  button. 

 l Press Ctrl + N (Windows/Linux) or ⌘  + N (Mac OS X).

The New Scene dialog box opens.

 2. In the Project Name field, type the scene's name.

 3. Select a scene directory by clicking the Browse button.

NOTE: The scene name cannot exceed 23 characters and cannot contain special characters, such as 
*&^%!.

 4. In the Resolution window, select the scene’s resolution and click Create.

A new scene is created.
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Creating Custom Resolutions
T-HFND-001-006

You can create your own custom resolution presets for your projects.

How to create a custom resolution

 1. Create a new scene from the Welcome screen or from the File menu in Harmony.

 2. Set the scene resolution by doing one of the following:

 l Select a scene resolution from the Camera sizes drop-down menu.

 l Set a custom resolution by changing the values in the Width and Height fields. This preset will 
not be saved.

 l Add a new resolution to the list by clicking the Add   button. You can delete a custom res-
olution from the Resolution list by selecting it, and clicking the Delete button.

 3. In the New Resolution dialog box, fill in the following fields and click Create.

 l Resolution Name: Name your new resolution.

 l Resolution: Set the width, height and aspect ratio of the resolution.

 l Field of View: Set the horizontal fit and vertical fit, or Custom Fov.

 l Frame Rate: Type the scene's frame rate per second.
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Opening Scenes
T-HFND-001-007

You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen

 1. In the Recent Scenes section, click Open.

The Open Scene browser opens.

 2. Browse and select an *.xstage file.

 3. Click Open.

How to open a scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > Open. 

 l In the File toolbar, click the Browse  button. 

 l Press Ctrl + O (Windows/Linux) or ⌘  + O (Mac OS X).

The Open Scene browser opens.

 2. Browse and select the desired *.xstage file.

 3. Click Open.

How to open a recent scene from the Welcome screen

 1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu

 1. From the top menu, select File > Open Recent.

 2. Select a scene from the displayed list.
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Setting the Scene Length
T-HFND-001-009

Once you have opened your scene, you can set its length. 

NOTE: Refer to the Scripting guide to learn how to modify the New Scene Start up script to set a different 
default scene length.

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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About Scene Settings
T-HFND-001-010

When you created your new scene, you set up the resolution and the alignment. However, if you want to change 
these initial settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options 
are separated into four tabs.

NOTE: Refer to the Scene Setting dialog box  in the Reference guide to learn more about the individual para-
meters of the Scene Settings dialog box.

How to access the Scene Settings dialog box

 1. Select Scene > Scene Settings.

The Scene Settings dialog box opens.
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About  Scene Versions in the Harmony Server
Harmony Server allows you to save, delete and merge versions on your scene. You can add descriptions to every 
saved version, in order to retain a record of all the changes made to the scene. When merging two versions, you can 
choose which differing elements to merge. When using the Advanced Save feature, you can choose to save specific 
drawings, palettes and palette lists.
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Saving Scene Versions in the Harmony Server
Save different versions of your scene and add a description to keep track of the changes made.

How to save the current version of a scene in Harmony Server

 1. Make sure you have the necessary rights to save the current scene version. If you do not, you can acquire 
the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene. 

 2. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X). 

When saving the scene for the first time, the Save dialog box opens, prompting you to name the version.

 

 3. Edit the information in the current version:

 l In the This Version field, enter a relevant name for the current version.

 

 l In the Description field, enter a short description of the current version. 

 

 4. Click Save. 
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Deleting Scene Versions in the Harmony Server
View a list of the different versions of your scene, along with their corresponding description. Use this information to 
delete various versions.

How to delete versions

 1. Make sure you have the necessary rights. If you do not, select File > Rights to Modify Scene. 

 2. Select File > Manage Versions. 

The Versions window opens. 

 

 3. In the Existing Versions list, select the scene version you want to delete. When a version is selected, inform-
ation about it appears in the Description area.

 4. Click Delete. 

The Confirm Delete Versions dialog box opens, warning you that the operation cannot be undone. 

 

 5. Click one of the following:

 l Yes: ONLY if you are absolutely certain that the version can be deleted.
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 l No: To cancel the operation and keep the version. 
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Merging Scene Versions in the Harmony Server
If you have two different versions of a scene that need to be brought together, you can merge them.

How to merge scene versions

 1. From the top menu, select Edit > Open Merge Editor.

The Choose Scene Versions for Merge window opens.

 2. In the Select Version to Merge Changes From list, select the scene version from which you want to merge 
the changes from in your current open version.

In the Use Another Version for Reference section, you can select a different scene version to merge the 
changes into, rather than your current version.

 3. Click Load.

The Merge Editor opens.
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 4. From the right column, select the layers you want to merge the changes from into the reference version.

 5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate from what 
frame to what frame you want to take the changes from.

 6. Click Merge Selected to complete the operation.
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Advanced Saving in the Harmony Server
Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your scene. 

How to use the Advanced Save dialog box

 1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can 
acquire the rights by selecting File > Rights to Modify Scene Version or Rights to Modify Scene. 

 2. From the top menu, select File > Advanced Save. 

The Advanced Save dialog box opens—see  the Reference guide for detailed parameter descriptions.
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Opening Drawings in Paint
This option will let you load drawings from one element at a time, for quick ink and paint on a single layer 
animation.

How to open drawings in Paint

 1. Once Paint is launched and you are logged in, select File > Open Drawings. Press Ctrl + O (Win-
dows/Linux) or ⌘  + O (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job, Scene and Element where the drawings you need to paint are located.

 

 3. Choose the version you want to open from the Version drop-down menu.

 

 l The Saved By and Saved Date fields display the user who was the last to save the selected 
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scene and the date of the last save. 

 

 4. Click on the Open button.

The Drawings Selector dialog box opens.

 5. Select the desired drawings from the drawings list:

 l Click on a single drawing to select it.

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 l Click on the All button to select all the drawings that are listed in the Drawings Selector.

 l Click on the Unpainted button to select all the drawings whose status appears as 
UNPAINTED.

 l Click on the Painted button to select all the drawings whose status appears as PAINTED.

 6. Click OK.

The selected drawings appear in the Drawing Thumbnails view

69



Chapter 2: Project Creation     About Scenes

 7. Use the Control panel to navigate between the previous and next drawings. Press F and G.

You are now ready to ink and paint!
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Opening Elements in Paint
This option will let you load drawings from several elements at once. This can be useful when an animation is 
separated in many layers, to insure that they are well aligned and that the painted shapes and lines fit together. A 
good example of this would be a dialogue with the chin and mouth separated from the rest of the head.

How to open elements in Paint

 1. Once Paint is launched and you are logged in, select File > Open Elements. Press Ctrl + E (Windows/Linux) 
or ⌘  + E (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job and Scene where the elements containing the drawings you need to paint are loc-
ated. 

 

 3. Choose the version you want to open from the Version drop-down menu.
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 l The Saved By and Saved Date fields display the user who was the last to save the selected 
scene and the date of the last save. 

 

 4. Click on the Open button.

The Open Elements dialog box opens.

 5. Select the elements you need to paint from the Elements list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 6. Select the frames you wish to load from the Frames list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 l Click on the All Frames button to load all the frames of the scene.

 7. Click OK.

The Drawing Thumbnails view is hidden and your selected elements are loaded in Paint.

 8. Enable the Light Table  option from the Drawing view toolbar to display all the drawing layers.

The selected layer are displayed in original colours and the other layers are displayed as washed out 
colours.
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 9. Use the Control Panel to navigate between previous and next layers. Press H and J.

 10. Use the Control panel to navigate between previous and next drawings. Press F and G.

You are now ready to ink and paint!
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About Saving
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title 
bar beside the scene name to indicate that the scene contains unsaved changes.

To save the current state of a scene as another scene, you can use the Save As command. The Save As window 
prompts you to give a new name and choose a different location to this scene before saving it. This will create a 
complete scene directory for the new scene. The Save As command is not available in Harmony Server.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or parameters 
to see which one will work best. Harmony allows you to save a new version of your scene. It is really important to 
note that the drawings and palettes are the same between ALL the scene versions. You can modify the timing, 
effects, parameters and camera motion, but if you modify the drawings, they will be changed everywhere.

You can also automatically save your work. Refer to the Preferences Guide to learn more about this function.

When you use Harmony Server and work in a scene on the database, there are many choices and options 
available when you save your work. 

Lets you do the following:

 l Save the scene as the current version.

 l Save different versions representing different stages of the production of your scene.

 l Save different versions representing different scene setups.

 l Choose specific assets that you want to save, such as drawings or palettes. 

When you open the scene from the database and select the version you want to edit, you can save the changes 
you made in the current version or create a new version. The simplest way to save your work is to update the 
current version. 

You can delete any unnecessary versions using the Versions window.

When working with multiple versions, you may want to merge some of the changes from one version into another. 
You may have created a version with some suggestions that you submitted to the director while continuing to 
work on the official version. If the director has approved some of the changes, you can go ahead and import them 
into the official version.

You might want to save some specific aspects of your scene or save a new version. The Advance Save feature 
allows you to do this. Once you have chosen the components to save, you will conclude the procedure by 
following the instructions in the  section. All the specific components that are selected throughout the different 
tabs of the Advanced Save dialog box will be saved. 
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Saving Scenes
T-HFND-001-011

You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses the 
same drawings in all versions. Harmony Server doesn't let you save your scenes as new copies.

How to save a scene

 l Select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).
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Saving Scenes as Copies
Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy (Harmony Stand Alone)

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene a new 
name. The name cannot exceed 23 characters.

 3. Click Save.
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Saving Scenes as New Versions
Saving a new version of your scene allows you to save your scene at it's current location, under a new file name. 

How to save a new version of a scene (Harmony Stand Alone)

 1. Select File > Save As New Version.

The Save Version dialog box opens.

 2. In the Save Version dialog box, type the new version name.

 3. Click OK.
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Auto-Saving Scenes
T-ANIMPA-001

You can allow the software to automatically save your scene, as well as decide on the length of time between 
saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l Mac OS X: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): This is the frequency at which the auto-save takes place.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are 
drawing or doing anything in the application. If so, Auto-save waits this number of seconds 
before attempting another save.

 l Ask Before Saving: Before performing an auto-save, you are prompted with a message to 
confirm if you want to save or not. You can choose to turn off this option.

 l Enabled: This enables the Auto-save feature. If you do not want the system to auto-
matically save your work, deselect this option. The auto-save is off by default.
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About Drawing Lock
The drawings are stored on the server database providing access to them from every client machine. They are 
locked to avoid different users from modifying the same drawings simultaneously. Only one person at a time can get 
the rights to modify them. The drawing rights are independent from the scene rights because in a production rush, 
two users may need to work on the same scene to finish painting the drawings faster. One user will get the rights for 
one set of drawings, and the second user the rights to another set of drawings. This prevents work from being 
duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new drawings by 
drawing directly on an empty cell. This mode is enabled by default when you open a scene version with the rights 
enabled.

NOTE: If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing 
mode is not available.

When you disable the Edit Drawing Mode, you can use the Get Rights to Modify Drawings option on a selection of 
specific drawings. This is useful when, for example, many users are working on the same scene during the ink and 
paint process and they want to split the drawings to paint between them.

Also, once you got the rights to modify drawings, you can release these rights if necessary.

If your system crashes and the drawings remain locked, you can force the release of the rights. You must use this 
option carefully as data loss may occur if the scene is currently open and being edited by another person. Verify that 
no one else is using the scene prior to forcing the release of the drawing rights.

Since the drawings are stored on the server,  you might at times need to refresh the drawings that are displayed in 
your scene. 
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Locking Drawings
You can acquire and release the rights to modify drawings when working with Harmony Server.

How to enable the Edit Drawing Mode

 l From the top menu, select Edit > Edit Drawing Mode.

How to get the rights on a selection of drawings

 1. Make sure that the Edit Drawing Mode is disabled.

 2. In the Xsheet view, select the drawings you want to edit.

 3. Select Edit > Get Rights to Modify Drawings or press Alt + L.

How to release the rights on a selection of drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Release Rights to Modify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

 1. In the Xsheet view, select the drawings you want to release.

 2. Select Edit > Force Release Rights to Modify Drawings.

A Warning dialog box opens.

 l Click Yes if you want to continue to force the release.

 l Click No if you want to cancel the force release.

How to read changed drawings

 l Select File > Read Changed Drawings.

80



Harmony 14 Premium - User Guide

Verifying the Project Integrity
The Check Files commandVerifies the integrity of the drawing and palette files in your project.  Use the Check Files 
dialog box to verify that the data is consistent, correct, and accessible.

How to open the Check Files dialog box

 1. From the top menu, select Scene > Check Files.

 2. Click Check Colours to open the Check Colours dialog box.

The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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About Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your 
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences 
dialog box to set parameters and options.

NOTE: To learn about the different preferences available, refer to the Preferences Guide.

When working with Harmony Stand Alone, your custom preferences are stored in:

 l Windows:

 l Toon Boom HarmonyPremium: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Premium \full-1400-pref

 l Toon Boom HarmonyAdvanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Advanced\full-1400-pref

 l Toon Boom HarmonyEssentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Essentials\full-1400-pref
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 l Mac OS X: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony Premium/full-1400-pref

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony Advanced/full-1400-pref

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony Essentials/full-1400-pref

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Linux: 

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony Premium/full-1400-pref/

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony Advanced/full-1400-pref/

When working with Harmony Server, your custom preferences are stored in:

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > full-1400-pref

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows/Linux: From the top menu, select Edit > Preferences.

 l Mac OS X: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).
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Chapter 3: Interface
T-HFND-003-001

Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your 
workspace conveniently. There are a series of views and toolbars you can use as you perform different operations. 
Usually, each person has a specific way of working in the interface and prefer particular views and toolbars. In this 
chapter, you will learn about the main elements of the interface and how to manage them.

NOTE: To learn more about each view's properties, see the Reference guide.

NOTE: 
On Windows, the default high-dpi setting was disabled so that text and UI element are shown properly. The 
application will appear a bit blurry but the text and UI elements will be displayed properly.

The previous behaviour is available by starting the application, Harmony[edition].exe, from the command 
line using the -enableHighDpi option.

To not have to start using the command line, the shortcut to start Harmony can be modified to add the option at 
the end of the target:

"C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premium\win64\bin\wstart.exe" 
Harmony[edition].exe -enableHighDpi

Replace the [edition] portion with the name of your edition (capitalized).
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(Mac OS X) .

The Preferences dialog box opens.

 2. Select the General tab.

 3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.

 4. Restart Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. Harmony will automatically change to you 
OS language if it corresponds to one of these four languages. If you would like to start Harmony in one of those 
language independently from your OS, you can use the command prompt or terminal to do so. 

How to start Harmony using a specific user interface language 

 1. Start a termninal, command prompt, or shell on your OS. 

 2. Using the change drive command (cd), navigate to the Harmony executable file location: 

 l Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premi-
um\win64\bin 

 l Mac OS X: /Applications/Toon Boom Harmony 14.0 Premium/tba/macosx/bin/ 

 l Linux: /usr/local/ToonBoomAnimation/harmonyPremium_14/lnx86_64/bin/

 3. To start Harmony in a specific language, type in the name of the Harmony application including the language 
argument (-lang) and language code (two letters): 

 l Windows: 
 l English:  HarmonyPremium.exe -lang en

 l Chinese: HarmonyPremium.exe -lang zh 

 l Japanese: HarmonyPremium.exe -lang ja 

 l Spanish: HarmonyPremium.exe -lang es

 l Mac OS X: 
 l English:  Harmony\ Premium -lang en

 l Chinese: Harmony\ Premium -lang zh

 l Japanese: Harmony\ Premium -lang ja

 l Spanish: Harmony\ Premium -lang es 

 l Linux: 
 l English:  HarmonyPremium -lang en

 l Chinese: HarmonyPremium -lang zh

 l Japanese: HarmonyPremium -lang ja

 l Spanish: HarmonyPremium -lang es

 4. Press Enter/Return to validate and launch Harmony in the desired language.
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About Menus
T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, some 
commands are available and others are not. The top menu is always located at the very top of the interface.

The top menu contains the following categories:

 l File

 l Edit

 l View

 l Play

 l Insert

 l Scene

 l Drawing

 l Animation

 l Windows

 l Help

On Mac OS X, there is also a Harmony Premium category that contains the following commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.

To access a  view menu, click the Menu  button in the top-left corner of a view.
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A view menu is available in the following views:

 l Camera

 l Colour

 l Drawing

 l Function

 l Library

 l Model

 l Node Library

 l Node

 l Perspective

 l Script Editor

 l Side

 l Timeline

 l Top

 l Xsheet

Quick Access Menu 

A quick access menu lets you open a list of the commands you will use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also have 
their own toolbars which you can move around. You can reposition the toolbars to suit your work style or hide 
unused ones.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the views 
that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a 
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move 
from the top area to the view.

The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog 
box, you can organize different toolbars to suit your working style.

If the default toolbar does not contain the tools you require, you can customize the toolbar.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to expand 
the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to close 
Harmony and restart it for the new interface to be displayed.   A default set of tools will appear in the toolbar. 
However, you can customize the toolbar with the tools that more closely fit your work pattern. 
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Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means that 
you can change the default set of tools and replace the tools you use less frequently with ones use more often. This 
customizing is done through the Toolbar Manager.
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Adding Toolbars
T-HFND-003-004

You can add toolbars simply by using menus.

How to add or close a toolbar

 1. Select Windows > Toolbars > toolbar.

 l You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, 
however, are not available by right-clicking the toolbar area. You can access the toolbar of 
any open and active view by right-clicking in the view's top area or the Windows menu. 
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Moving Toolbars
T-HFND-003-005

You can move toolbars simply by dragging them to a new location.

How to move a toolbar

 1. Select the toolbar you want to move by clicking its anchor point  and dragging it into a view toolbar area or 
another position in the top or side interface toolbar area.

 2. When a highlighted zone appears showing an available location for the toolbar, release the mouse button and 
drop the toolbar into position.
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Resizing Toolbars
T-HFND-003-006

You can resize a toolbar by sliding its tail-end.

How to resize a toolbar

 1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end. 

 2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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Customizing View Toolbars
T-HFND-003-007

You can customize a view toolbar to add, remove, and reorder icons.

How to customize a view toolbar

 1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a new button. 
You can also reorder the buttons. Make sure the button you right-click on is active.

 2. From the menu, select Customize.

The Toolbar Manager window opens.

 3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click the Right 
Arrow   button to switch it to the Toolbar list.
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 4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left Arrow  
 button to switch to the Available Tools list.

 5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click the Up 
 or Down  buttons to move it to the correct location.

 6. Click OK when you are finished.
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Enabling the Flat Toolbar
Delete this text and replace it with your own content.

How to use enable the Flat Tool Toolbar preference

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(Mac OS X).

 2. In the Preferences dialog box, select the General tab.

 3. Select the Flat Tool Toolbar option. 

 4. Click OK.

 5. Save your work and close Harmony. 

 6. Restart Harmony. 

The Tools toolbar no longer contains nested tools.
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About Views
T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or 
other type of selection or the option does not apply to the active view.

NOTE: To learn move about each view's properties, refer to 

Workspace modifications are automatically saved when you exit the application unless you deselected the 
Automatically Save Workspace option in the Preferences dialog box.
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Adding Views
T-HFND-003-009

You can easily add views through the top menu or each view.

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the Add View  button 

 2. Select a view from the list. Some views, such as the Camera, Perspective, Library, Model and Node views, 
can be opened in multiple instances. For example, this can be useful if you want to have two Camera views 
open, each focused on different areas of your scene, to quickly switch between working on these two areas. 

The view will appear as a new tab in the same section of your workspace:
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How to add a view to your workspace as a window

 1. Open the Windows menu.                     

 2. Select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.

How to dock a view window to your workspace

 1. Drag a window by its tab and do one of the following:

 l Drop the window onto other existing tabs to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the edge 
of a view, a black rectangle with a blue background appears, indicating where the view will 
be inserted.
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Closing Views
T-HFND-003-010

You can close one or multiple views by using their closing button.

How to close a view

 1. Click the Close View  button.

If there are several tabs in the same view, press Shift and click the Close View  button to close all tabs at 
the same time.
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Showing and Hiding Views
T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the window you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011

You can move views by dragging their name tab to a new location.

How to move views

 1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s tab.

 2. When a blue rectangle outline appears showing an available location for the view, release the tab to drop the 
view into position. One of three things will happen:

 l The view becomes a tabbed view.

 l The view becomes a floating window.

 l The view becomes a new docked view.
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Resizing Views
T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. When you see the Resizing  icon, drag the side of the view to the desired size.
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About Workspaces
T-HFND-003-014

The Harmony interface is composed of several views. You can customize your workspace to suit your working 
style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the 
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can access 
these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your 
workspaces as they are and only save the modifications when you really want to, you must disable the 
Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can save 
your workspace as a new version to avoid over-writing the current one. If you do not want to modify the current 
workspace, use the Workspace Manager to create another one and then modify that one.

Your customized preferences are stored in the following location and you can save them to either share with 
someone else, copy to a second computer or simply back them up.

When working with Harmony Stand Alone, your custom workspaces are stored in:

Windows

 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom Anim-
ation\Toon Boom Harmony\1400-layouts-xml

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Advanced\1400-layouts-xml

 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Essentials\1400-layouts-xml

Mac OS X

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony/1400-layouts-xml

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Advanced/1400-layouts-xml

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Essentials/1400-layouts-xml

Linux

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony/1400-layouts-xml/

 l /home/[user_name]/Toon Boom Animation/Toon Boom StageAdvanced/1400-layouts-xml/

When working with Harmony Server, your custom workspaces are stored in:

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-layouts-xml
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Loading Workspaces
T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the following:

 l Select Windows > Workspace > Workspace.

 l Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016

You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.

109



Chapter 3: Interface     About Workspaces

 5. Select the new workspace and click the Right Arrow  button to move it to the Workspace toolbar.

 6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit the name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving Workspaces
T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save Workspace preference

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(Mac OS X) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save Workspace option.

 4. Click OK. 

The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

 1. Do one of the following:

 l In the Workspace toolbar, click the Save Workspace   button. 

 l You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   button to move it 
to the Available Workspaces list.

 3. Select the workspace from the Available Workspaces list, then click the Delete  button to delete the work-
space.

 4. Click OK.
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Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow   but-
ton to move it to the Workspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button to move 
it to the Available Workspaces list.

 3. Click OK. 
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  buttons to 
move it up or down.

 3. Click OK. 
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Restoring the Default Workspace
T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select Windows > Restore Default Workspace.
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About Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.

The navigation commands in the table below can be used in the following views, with some exceptions:

 l Camera

 l Drawing

 l Perspective

 l Timeline

 l Xsheet

 l Node View

 l Function

 l Side and Top

 l Model

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the 
Timeline and Xsheet views)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down(except in the 
Timeline and Xsheet views)

Zoom In or Out Zooms in or out of the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle 
mouse button while dragging the mouse up 
or down.

Pan Moves the view horizontally or vertically.
Hold down the Spacebar and drag in the 
direction you want to pan the view.

Reset Pan
Resets the view’s pan to its default 
position.

View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position.

View > Reset View

Press Shift + M

 

Reset Rotation
Resets the view’s rotation to its default 
position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default 
position.

View > Reset Zoom
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Rotate View Rotates the view.
Press Ctrl+Alt (Windows/Linux) or Ctrl+⌘  
(Mac OS X) and drag in the direction you 
want to rotate the view.

Rotate 30 CW Rotates the Camera view 30 degrees 
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW Rotates the Camera view 30 degrees 
counter-clockwise, like an animation table.

View > Rotate View CCW

Toggle Quick Close-up

Instantly multiplies the view's Zoom 
Factor by 4. For example, if the Camera 
View's Zoom Factor is at 100%, this will 
make it toggle between 400% and 100%. 

Shift+Z

Toggle Full Screen

Cycles through the following display 
modes:

 l Normal Full-Screen: The main 
application window becomes full 
screen.

 l View Full-Screen: The selected 
view becomes full screen and all 
other views are collapsed.

 l Normal: The main application win-
dow is restored to its original size 
and collapsed views are expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  + F 
(Mac OS X)

 

Using the Play Menu to Navigate

From the top menu, you can select any of the following commands from the Play menu to navigate around the 
interface.

Command Description

Start Frame Lets you set the frame on which playback will start.

End Frame Lets you set the frame on which playback will end.

First Frame Jump to the first frame. You can also press <.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline view.  
You can also press the comma (,) key.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. You 
can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Go to Frame

Opens the Go to Frame window in which you can enter the number of the frame 
you want to display. 

You can also use the Go button, which you can add to the Timeline toolbar 
through the Toolbar Manager. Open the Go to Frame dialog box and enter the 
frame number to jump to.

Enable Playback Plays back your animation from the Top, Side, or Perspective views.
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Chapter 4: Drawing  
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and styles.

Depending on the type of layer you select, here are the drawing tools available:

Tool Name Icon Vector Layer Bitmap Layer

Select • •

Cutter • •

Reposition All Drawings •  

Contour Editor •  

Pencil Editor •  

Smooth Editor •  

Perspective •  

Envelope   

Edit Gradient/Texture •  

Brush • •

Pencil •  

Text • •

Eraser • •

Paint • •

Ink •  

Paint Unpainted • •

Repaint •  

Unpaint • •

Stroke •  

Close Gap •  

Line • •

Rectangle • •

Ellipse • •

Polyline •  

Dropper • •

Each drawing tool has a series of options to customize its behaviour and drawing style.
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The Tool Properties view displays the properties of the currently selected tool on the current layer you are 
working. If you are editing a vector layer, then all of the tools are available to you. If you are drawing on a bitmap 
layer, some tools are not available. When tools are not available, they are grayed out in the Tools toolbar.
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About the Brush Tool
T-HFND-004-003

The Brush    tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it was 
created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on the type of drawing layer you are using.  

If you draw with vector, you can enlarge your drawing and zoom into it without losing quality or resolution. You can 
also use the Contour Editor and Select tools to resize and modify lines. 

If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its resolution without 
encountering pixelization issues.

There are a variety of brush styles provided with Harmony, which you can use to create and save your own brush 
style. This lets you create brushes with precise sizes and parameters and save them so you can draw and design 
with them. Renaming a brush can make it easier to identify and access the brushes you use most frequently.

You can also create a dynamic brush for drawing with patterns created from your artwork. Create a new dynamic 
brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or 
multiple patterns that automatically switch through the patterns as you draw.

NOTE: To learn more about the Brush tool options, see the Reference guide .

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com
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Drawing with the Brush Tool
T-HFND-004-003A 

In the Camera or Drawing view, you can draw on any drawing layer type with the Brush tool. 

NOTE: To learn more about the Brush tool options, see the Reference guide .

How to draw with the Brush tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

 l Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) to force a line to join the start and end of the 
shape while drawing.
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Modifying the Brush Settings
You can modify several parameters such as the brush size and smoothing. 

NOTE: If you are trying to create artwork on a bitmap drawing layer, and therefore with a bitmap brush, see 
About Bitmap Brushes on page 151

How to modify the brush settings

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters. Click the arrow button.

The Brush Properties window opens.

Parameter Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter 
defines the  width of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the 
maximum size. If you do not have pressure sensitivity from a 
pen table, the minimum size value will be ignored. 

Smoothing
Defines the number of control points added to the centre line. 
The fewer the control points the smoother (but less faithful) the 
line.
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Contour Smoothness

Optimizes the contour line smoothness of the line. This 
parameter smooths the contour of the line once it has been 
traced. The higher the value, the fewer control points will 
compose your line. 

Tip Shape

Lets you select a tip shape—from round and square ones to star 
shaped. This option is disabled when using a textured brush.

NOTE: To learn more about the Brush tool options, see the Reference guide .
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Selecting a Brush Preset
Harmony provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets section.
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Creating a Brush Preset
You can create your own custom brush presets and add them to the existing list.  

How to create a brush preset

 1. Make sure your current brush has the settings you want in the preset you will create—see the Reference guide
 .

 2. In the Tool Properties view, do one of the following:

 l Click the arrow button to display the Brush Properties window and click the New Brush  but-
ton  in the upper-right corner.

 l Click the New Brush  button.

 l From the Brush  menu, select New Brush Preset.

 3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.
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Creating Dynamic Brush Presets
You can create dynamic brush presets allowing you to stamp custom patterns. You can either repeat the same 
pattern or loop a pattern made of several drawings. 

How to create a new dynamic brush

 1. In the Tools toolbar, select a drawing tool.

 2. In the Camera or Drawing view, draw the pattern you want to use as your dynamic brush stamp.

 3. In the Tools toolbar, click the Select  tool and  select the parts of the drawing you want to repeat.

 4. In the Tools toolbar, select the Brush  tool or press Alt + B.

 5. In the Tool Properties view, click the Add Dynamic Brush  button to add your selection as a new 
dynamic brush preset.

 6. From the Brush  menu, select Rename Brush.

 7. Type in a name for the new dynamic brush and click OK.

 8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
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 9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the Maximum Size 
value in the Tool Properties view.

How to create a dynamic brush with multiple drawings

 1. In the Timeline view, click the Add Drawing Layers  button to create the layers you want to use as pat-
terns in your dynamic brush. Make sure to rename your layers.

 2. In the Camera view, draw the individual drawings of your pattern on separate layers.

 3. In the Tools toolbar, select the Select  tool.

 4. In the Tool Properties view, disable the Works on Single Drawing  option to allow the Select tool to grab 
artwork on multiple layers.

 5. In the Camera view, select all the drawings you want to add to your new dynamic brush.
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 6. In the Tools toolbar, select the Brush  tool or press Alt + B.

 7. Click the Add Dynamic Brush  button to add your selection as a new Dynamic Brush preset.

 8. From the Brush menu, select Rename Brush.

The Rename Preset dialog box opens.

 9. Type in a name for the new dynamic brush and click OK.

 10. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When 
you use this brush, you will cycle through the drawings.
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Renaming a Brush Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tool Properties view, select a brush to rename. 

 2. From the Brush  menu, select Rename Brush. 

 3. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tool Properties view, select the brush preset you want to delete.

 2. Do one of the following:

 l Click the Delete Brush  button.

 l From the Brush  menu , select Delete Brush.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in the 
Tool Properties view and then update the preset. 

How to update a brush preset

 1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

 2. Change the brush settings and click the Update Brush Preset  button  in the upper-right corner.
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Exporting Brush Presets
You can export your presets to either backup. share, or install on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as 
any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file 
and give it a name.

 5. Click Save.
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Importing Brush Presets
You can import Harmony brush presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. 
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About Vector Textured Brushes
In Harmony, you can use the Brush  tool to draw with bitmap textured brushes on vector layers. Those brushes 
are a mix of vector contours with bitmap texture fills.

In the Brush Tool Properties view, you will find a series of default textured "brushes", but you can also create and 
import your own custom collection. In Harmony, when using a textured brush on a vector layer, the texture of a brush 
is referred to as the Paper Texture. In other words, we are attributing the texture not to the tool, but to the texture of 
the surface that is revealed when a stroke passes over it. You will understand why when you work with bitmap 
brushes on bitmap layers, where it is possible to have both a textured brush tip and a paper texture.

To create your own textured brush, you must prepare your texture file ahead of time, either in Harmony or in a third-
party software, such as Adobe Photoshop. Colour is not supported and transparency is not supported in the 
traditional sense. Black appears as 100% opaque, white appears as 100% transparent, and all the shades of grey in 
between appear as varying degrees of semitransparenty. A range of file formats are supported—.jpeg, .png, .tif, .psd, 
.tga to name a few. Alpha channels are disregarded on import. It is recommended that you maintain the texture 
resolution between 100 x 100 pixels and 400 x 400 pixels. 

You can import your custom paper textures in the extended Brush Properties window. Browsing for a texture file with 
a brush selected that is already using a paper texture will replace the file currently in use. It will not, however, replace 
the texture in lines already drawn. The replaced texture swatch will no longer be the selected texture, but it will 
remain in the texture library and not be deleted.

Harmony also allows you to import  textures as an .xml file that was exported from another project. In this way, you 
do not have to import individual image files one-by-one to have the same texture library and brush presets as others 
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who you are collaborating with. You can also export brush presets and textures, in order to share your default or 
customized textures and presets with other project collaborators.

When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and you lose the 
feather created while drawing with the Brush tool. In Harmony, a special option in the Eraser Tool Properties lets 
you create a soft edge on your textured lines. You can also cut or keep the vector frame as is.

At some point, you may want to modify the look of a textured drawing if you suddenly find that your lines look too 
hard or too light. You can adjust those parameters by using the Adjust Line Texture Opacity command.

To draw with textured lines, use the Brush tool and the correct brush in the list. You can also draw with pencil line 
texture—see About Pencil Line Texture on page 192

138



Harmony 14 Premium - User Guide

Drawing with Vector Textured Brushes
Delete this text and replace it with your own content. 

How to draw with textured lines

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. Select a texture for your brush from the textures presets available at the end of the list.

 3. If you want to modify the settings, in the Tool Properties view,  click the Arrow button to open the Brush Prop-
erties view.

 4. Click the Texture tab, select the Paper Texture option.

 5. Set the following parameters: 

Parameter Description

Hardness The hardness value corresponds to the softness of the line edge. 
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The lower the value, the softer the line edge will be. The higher the 

value, the sharper the line edge will be.  

Maximum Opacity
This value corresponds to the transparency of the stroke when the 
pressure is heavy.  

Minimum Opacity

This value corresponds to the transparency of the stroke when the 
pressure is light and is a percentage of the Maximum Opacity 
value. 

 6. In the Camera or Drawing view, start drawing.
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Adding a Paper Texture
You can add custom paper textures to your presets. 

How to add a paper texture

 1. Do one of the following:

 l From the Paper Texture menu , select Add.

 l Click the Add Paper Texture button.

 2. In the browser window that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Renaming a Paper Texture
You can rename your paper textures to keep your list organized. 

How to rename a paper texture

 1. In the Paper Texture library, select a texture.

 2. From the Paper Texture menu, select Rename.

 3. In the Rename Texture dialog box that appears, type in the new name for the texture. 

 4. Click OK.
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Deleting Paper Textures
You can delete unnecessary paper textures from your preset list. 

How to delete a paper texture

 1. In the Paper Texture library, select a texture.

 2. Do one of the following:

‣ In the Paper Texture menu, select Delete.

‣ Click the Delete  button.

NOTE: You can delete any texture in the texture library as long as there is no brush preset using it.
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Erasing Textured Lines
You can erase vector textures lines with a smooth eraser edge. 

How to erase textured lines

 1. In the Tools toolbar, select the Eraser  tool, press Alt + E.

 2. In the Tool Properties view, click the arrow button.

The Eraser Properties window opens.

 3. Adjust the following: 

Hardness
Defines the softness of the stroke edge. The lower the value, the 
softer the stroke edge will be. The higher the value, the sharper the 
stroke edge will be.

Saturation

Lets you adjust the softness of edge feathering. Works in con-
junction with the Hardness, e.g. 100% Hardness will yield no res-
ults in saturation change. 0% Hardness will allow a fine tuning of 
the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy.  A smal-
ler value will leave semi-transparent colour and texture. A larger 
value will ensure that everything is properly erased. This option in 
unavailable if the Keep Vectors option is disabled.

Minimum Opacity
Sets the minimum transparency of the brush, in relation to the Max-
imum Opacity, when the pressure is very light. A smaller value will 
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leave semi-transparent colour and texture. A larger value will 
ensure that everything is properly erased.  This option in unavailable 
if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the tex-
ture fill disappears. Disabling this option will cut the stroke's vector 
frame into different pieces when the Eraser tool passes over it. If 
you disable this option, the maximum and minimum opacity sliders 
are disabled as well.

 

 4. In the Camera or Drawing view, erase your textures lines.
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Exporting Paper Textures
You can export paper textures for either backup, sharing, or installing on a different computer. 

How to export paper textures

 1. In the Paper Texture menu, select Export.

 2. In the Export Tips and Textures window, scroll down the textures list to the paper textures and select or 
deselect any textures to create the list that you wish to export.  You can export brush tips at the same time 
too.

 3. Click on the Export button.

 4. In the Export Textures window that appears, browse to a location where you would like to save the .xml file 
and give it a name.

 5. Click Save.
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Importing Paper Textures
You can import paper texture presets you previously exported from Harmony. 

How to import paper textures

 1. In the Paper Texture menu, select Import.

 2. In the browser window that appears, navigate to and select  the .xml file.

 3. Click Open.

 4. In the Import Textures dialog box, select the paper textures that you wish to import. You can import any 
available brush tips at the same time too.

 5. Click Import.

The imported paper textures will appear in the Paper Texture Library. You can reuse any of the imported 
paper textures to create other brush style presets.
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Adjusting the Line Texture Opacity
If you drew with textured lines that are either too light or too dark, you can adjust the line texture opacity of your 
drawings.

How to adjust the line texture opacity

 1. If you are in Camera view, select the Current Drawing on Top option—see Displaying the Current Drawing 
on Top on page 289.

 2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.

 3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

 4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

 5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings 
option and click OK.
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Changing the Paper Texture Display
You can change the display of the paper texture presets to thumbnails or a list. 

How to change the Paper Texture thumbnail display

 1. From the Paper Texture menu, select one of the following:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.
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About Bitmap Brushes
With Harmony, you have the choice to draw with vector or bitmap brushes. This is decided by what modes you 
select for your layer. When adding a new drawing layer in Harmony, you can set your art layers (Line Art, Colour Art) 
to vector or bitmap. This way, you can draw in bitmap and paint in vector, draw everything in bitmap, or any other 
combination that suits your needs. If you are using the Overlay and Underlay layers, you can also set them to bitmap 
or vector.

When drawing on a bitmap layer, these are the tools available:

 l Brush

 l Cutter

 l Dropper

 l Edit Gradient/Texture

 l Ellipse

 l Eraser

 l Line

 l Paint

 l Paint Unpainted

 l Pivot

 l Rectangle

 l Repaint

 l Reposition All Drawings

 l Select

 l Text

 l Unpaint

On a bitmap layer, a temporary vector layer is created when painting with a gradient. Until a modification is made on 
your layer with a bitmap drawing tool, you can edit your last painted zone, by editing the gradient swatch, which is 
dynamically linked to the painted zone or using the Edit Gradient texture tool. When a bitmap drawing tool or action 
is used, a vector-to-bitmap conversion occurs. If there are vector elements on the layer (such as if you switched 
your art mode from vector to bitmap after having created vector artwork), they too will be converted to bitmap.

151



Chapter 4: Drawing      Changing the Paper Texture Display

Here is a list of tools and actions that will trigger a vector-to-bitmap conversion:

 l Brush

 l Ellipse 

 l Eraser

 l Line

 l Paint

 l Paint Unpainted

 l Rectangle

 l Repaint

 l Unpaint

 l Performing a paste with the Select tool selected

 l Performing a paste with the Cutter tool selected

This means that certain tools, such as the Text or Cutter tool, will not trigger a conversion. 

If you selected the incorrect art modes for your layer, you can open the Layer Properties view and change them. If 
you switch the art mode for a layer that already has strokes on it, the artwork will NOT be converted for bitmap 
artwork, but will be for vector artwork, though not immediately.  A drawing with bitmap strokes on a newly 
converted vector layer will remain bitmap. This means that the bitmap artwork will not be editable by some tools, 
such as the Eraser tool, but will be editable by other tools, such as the Cutter tool. However, a drawing with 
vector lines on a newly converted bitmap layer will remain vector temporarily, until a bitmap drawing tool or action 
is used. Then the vector-to-bitmap conversion will occur.

To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.

If you want to be able to edit the artwork in the new mode, you need to convert the drawings.

Vector-to-bitmap conversion includes flattening individual drawings into a single image. Flattening means that it 
will not be possible to select non-overlapping or overlapping elements as individual objects with the Select tool. 
Instead, the selection of one drawing will initiate the selection of all elements, with a single vector frame 
surrounding them.

Resampling is also triggered on bitmap layers with the use of a bitmap drawing tool. For example, if you draw the 
outline of a circle, scale it down and then zoom into it, you will see tiny square pixels along the edge of the line. If 
you then draw a line right next to it, you will notice two things: first that the square pixels of the new line are 
gigantic by comparison and that the pixels in the line of your circle suddenly become the same size. This is 
because the circle was resampled. It was not resampled when you scaled it down. It was resampled when you 
used a bitmap drawing tool. It is resampled so that all the drawn objects are scaled to the same bitmap grid, in 
other words that their basic unit, the pixel, is the same size. The grid is defined by the bitmap layer's resolution.
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Before you start drawing in bitmap, it is important to understand that your artwork will now be resolution dependent. 
If you zoom in your scene, you artwork will be enlarged. It is important to plan ahead and decide how high of a 
resolution you need your artwork to be. If you plan to zoom in your scene, the smallest section of the image that the 
camera will frame must be 100% the size of your scene resolution. For example, if your scene resolution is set to 
1920 x 1080 and you zoom- in 300% with your camera, then the resolution of the bitmap layer also has to be set to 
300%, otherwise its elements will look pixelated in the final render. It is important to change the bitmap layer 
resolution before you start drawing.

The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level affects newly 
created bitmap art layers. 

Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be very heavy. It 
depends on the amount of artwork you draw in it.
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There is a function to Lets you change the resolution of bitmap art for individual drawings. You can reduce the 
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution on an 
existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass (resampling) and 
create additional pixels to avoid losing too much quality, but only to a certain extent. This feature is very useful 
when you need to have a full resolution of a bitmap image (such as imported bitmaps as .psd or .tga for the 
background) for tracing to create a matte directly in Harmony.By default, Harmony creates small thumbnail 
images when imported as bitmap in order to increase performance by using a small thumbnail image instead of 
using the original large size bitmap for animation work in Harmony. This will make difficult to view details or trace 
due to the low resolution (blurry). This option temporary increases the resolution of bitmaps up to their original 
bitmap resolution to make tracing easier. 

For example, what if you used the default scene’s resolution for some bitmap art, but then discover you are 
zooming-in quite close?  If you do not want to see the pixels appear too much when you are zoomed in, you can 
set the bitmap resolution to 200% and the bitmap art will have a higher resolution with smaller pixels, but will NOT 
retain 100% of its quality. You can use this function on multiple drawings using the Apply to All Drawings option. 
Changing this option will affect existing and selected bitmap art layers.

If you draw an outline on a bitmap layer, you can still vectorize it. Using a vector drawing layer, simply select your 
bitmap drawing and the vector cell of where you want your vectorized line to be, and use the Vectorize Line Art in 
Selected Drawing function.

You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that when you 
continue drawing, your image will be resampled and your new strokes will be scaled to the scene resolution. 
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NOTE: Your drawing should be scaled up using the Transform  tool when animating, instead of the Select 
tool, in order to avoid creating very large bitmap layers. Harmony calculates the scaling of your drawings when 
you use the Transform tool; your image is mathematically transformed. When you use the Select tool to scale, 
you are physically scaling the drawing.

155



Chapter 4: Drawing      Changing the Paper Texture Display

Drawing with Bitmap Brushes
You can use the Brush tool to draw on bitmap layers.

How to draw with bitmap brushes

 1. In the Timeline view, add a bitmap drawing layer—see Drawing with Bitmap Brushes on page 156.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Colour view, select a colour.

 l To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select Col-
our > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on 
the colour sliders and select RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected 
colour. You can edit the colour  as much as you want, but your drawing will not be affected. You can 
still select colours from your vector colour palette to use the same tint, but you will not create links 
between your drawing and the swatches.

 4. In the Camera or Drawing view, start drawing.
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Creating Bitmap Brushes
With bitmap brushes in Harmony, you can create an infinite range of fuzzy, textured and watercolour lines. You 
can combine two different brush tips, with separate sets of parameters, with the Dual Tip feature. You can also 
select a paper texture that will mimic the texture of the surface that is being painted on. Uses these features 
separately or in combination to create distinct, natural-looking strokes.

How to create a bitmap brush preset

 1. In the Timeline view, create a new Bitmap drawing layer.

 2. In the Tools toolbar, select the Brush  tool or press  Alt + B.

 3. In the Tool Properties view, select a brush and click the Arrow button to open the Bitmap Brush Properties 
view.

 4. In the Tip tab, select a brush tip.

158



Harmony 14 Premium - User Guide

 5. Click on the different tabs to access the options available for adjustment. You can use the brush stroke pre-
view at the top to view all your adjustments in real time.

 l Tip tab: Make adjustments to size, brush tip angle, hardness and spacing.

 l Transparency tab: Make adjustments to flow and opacity.

 l Dual Tip tab: Select this option to enable the Dual Tip feature. Select a dual brush tip and 
make adjustments to its size, brush tip angle, hardness and spacing.

 l Paper Texture tab: Select this option to enable the Paper Texture feature. Select a paper tex-
ture and make adjustments to its scale, alignment and additivity. To learn more about using 
paper textures, see:
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 l Adding a Paper Texture on page 142

 l Renaming a Paper Texture on page 143

 l Deleting Paper Textures

 l Exporting Paper Textures

 l Importing Paper Textures

 l Changing the Paper Texture Display on page 150

 6. When you are satisfied with the look of your bitmap brush, click the Add New Brush Preset  button at 
the top-right corner of the Bitmap Brush Properties window.

 7. In the New Preset dialog box that appears, enter the name for your brush preset.

 8. Click OK.

If you continue to make adjustments to your new brush preset and want to save these changes, click the 
Update Preset  button. Otherwise, your modifications will only be saved until another brush preset or 
drawing tool is selected.

How to add a brush tip

 1. Do one of the following:

‣ From the Brush Tip menu, select Add.

‣ Click the Add  button.

 2. In the browser window that appears, navigate to where you saved your file.

 3. Click Open to import the file into the Brush Tip Library.

By default, an imported brush tip is given the name of the image file.
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Renaming Brush Tips
You can rename your bitmap brush tips to keep your list organized. 

How to rename a brush tip

 1. In the Brush Tip Library, select a brush tip.

 2. From the Brush Tip menu, select Rename.

 3. In the Rename  dialog box that appears, type in the new name of the brush tip. 

 4. Click OK.

161



Chapter 4: Drawing      Changing the Paper Texture Display

Deleting Brush Tips 
You can delete unnecessary brush tips to keep your list organized. 

How to delete a brush tip

 1. In the Brush Tip Library, select a brush tip.

 2. Do one of the following:

‣ In the Brush Tip menu, select Delete.

‣ Click the Delete  button.

The linked brush tip file does not get deleted and can therefore be reimported. 
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Exporting Brush Tips
You can export brush tips to share, backup or install on a new computer. 

How to export brush tips

 1. In the Brush Tip menu, select Export.

 2. In the Export Tips and Textures window,  select or deselect any of the brush tips to create the list to export. 
You can also export paper textures at the same time.

 3. Click Export.

 4. In the Export Textures window that appears, browse to a location where you want save the .xml file and 
give it a name.

 5. Click Save.
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Importing Brush Tips
You can import Harmony brush tips you previously exported.

How to import brush tips

 1. In the Brush Tip menu, select Import.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Textures dialog box, select the brush tips to import. You can also import paper textures at the 
same time.

 5. Click Import.

The imported brush  tips appear in the Brush Tips Library. You can reuse any of the imported tips to create 
other brush style presets.
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Changing the Brush Tip Display
You can display your preset list as thumbnails or a list.

How to change the Brush Tips thumbnail display

 1. From Brush Tip menu, select one of the following options:

Parameter Description

Small Thumbnail Reduces the size of the thumbnails in order to view more at the same time.

Large Thumbnail Increases the size of the thumbnails in order to see the images more clearly.

List View Allows you to see the name, as well as the thumbnail.
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Adding Bitmap Layers
When adding a layer, you must set your art layer parameters to bitmap in order to use bitmap layers. 

How to add a bitmap layer

 1. In the Timeline view, click the Add Drawing Layer button,

The Add Drawing Layer window opens.

If you are using the Overlay and Underlay layers, those art layers are also displayed.

 2. For each art layer, select the Vector or Bitmap option.

 3. Click OK.
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Changing Art Modes
Once a layer is created, you can change the individual art layers to be either bitmap or vector. If some artwork is 
already contained on the art layers, it will not be fully converted—see About Bitmap Brushes on page 151, 

How to change the art mode

 1. Open the Layer Properties view.

 2. In the Timeline view, select the layer you want to edit.

 3. In the Layer Properties view, select the Drawing tab.

 4. In the Art Layers section, select the art mode for each art layer.
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Converting Artwork
You can convert the artwork on an art layer to match its new layer type. You can also vectorize your bitmap 
artwork to work in a vector layer.

How to convert drawings to match the art mode

 1. In the Timeline view, select the layer that contains the drawings you want to convert.

 2. From the Timeline view menu, select Layers > Convert Drawings to Match Art Layer Type.

You can also right-click on the selected layer and select Convert Drawings to Match Art Layer Type.

All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not 
vectorized when converted to a vector art layer. They are simply inserted in a square vector frame 
containing a bitmap texture.

How to vectorize a bitmap drawing

 1. In the Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the drawing 
to vectorize. In your bitmap drawing, the artwork to vectorize must be placed on the Line Art layer (default 
drawing layer).

NOTE: 
If you place the vector drawing on top of the bitmap layer, you will not be able to perform the operation. A 
warning dialog box will display.

 2. On the right side of the Timeline view, select the bitmap drawing and corresponding cell in the vector draw-
ing layer.
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 3. Right-click and select Drawings > Vectorize Line Art in Selected Drawing.

The Convert to Vector Drawing dialog box opens.

 4. In the Vectorization section, select a vectorization preset. You can customize your own preset using the Add 
or Edit buttons.

 5. Click OK.

Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains intact.

169



Chapter 4: Drawing      Changing the Paper Texture Display

Setting the Bitmap Art Mode Preferences
You can set the vector and bitmap art mode settings you want to use by default via the Preference panel. 

How to adjust the art mode settings in the Preferences dialog box

 1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Harmony Premium > Preferences ( 
Mac OS X ).

 2. Select the Node View tab.

 3. In the Layer Drawing Options section, set the art layers to the desired art mode. Once this option is 
enabled, all new layers will follow these settings. It will not affect any existing layers.

 4. Click OK.
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Changing the Bitmap Resolution
You can change the bitmap drawing resolution at the scene or the drawing level—see About Bitmap Brushes on page 
151.

How to change the bitmap layer resolution at the scene level

 1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

 2. Select the Bitmap Resolution tab.

 3. Change the bitmap resolution settings and click OK.

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixels.

Width

This is the width of the resolution for the bitmap that will be created. This is not 
the actual size of the bitmap. TVG drawings (Toon Boom drawing native format) 
have an infinite size. Bitmap TVGs are composed of small tiles. Therefore it does 
not mean that because you have artwork at the four corners of your camera frame 
or even quite far outside of your drawing that your bitmap image will be very large 
and heavy. By default, it is set to the same width as the scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. By default, it 
is set to the same height as the scene resolution.

Resolution Factor
This is the size of the bitmap resolution in relation to the scene resolution. If you 
increase the percentage, the width and height fields will increase accordingly. If 
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you plan to animate the camera and zoom into your background, you will need to 
set a higher resolution so that the smaller area in which you will zoom will be 
100% of the scene resolution.

How to change the bitmap resolution at the drawing level

 1. In the Timeline view, select the drawing whose resolution you want to change.

NOTE: Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if 
you enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution 
before drawing. If you need to change the resolution of a drawing to be larger than the one set in the Scene 
Settings dialog box, create an empty drawing first and then follow this procedure.

 2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.

The Change Bitmap Drawing Resolution window opens.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixels.

Width

This is the width of the resolution for the bitmap that will be created. This is not 
the actual size of the bitmap. TVG drawings (Toon Boom drawing native 
format) have an infinite size. Bitmap TVGs are composed of small tiles. There-
fore it does not mean that because you have artwork at the four corners of your 
camera frame or even quite far outside of your drawing that your bitmap image 
will be very large and heavy. By default, it is set to the same width as the 
scene resolution.

Height
This is the height of the resolution for the bitmap that will be created. By 
default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If 
you increase the percentage, the width and height fields will increase accord-
ingly. If you plan to animate the camera and zoom into your background, you 
will need to set a higher resolution so that the smaller area in which you will 
zoom will be 100% of the scene resolution.

Resample Bitmap When this option is selected, the existing bitmap image is modified to match 
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the new resolution. If the width and height are increased, more pixels will be 
created to enlarge the image. Visually, the existing artwork will look the same, 
maybe a little bit smoothed out, but the size will look the same. When this 
option is deselected, the artwork is not modified. Only the reference grid is 
resized. If the scene resolution is 1920 x 1080 and you reduce the bitmap 
resolution to 960 x 540, the image will be scaled up to twice the size of the 
scene.

Apply to All Drawings
The modified settings are applied to all drawings in the drawing layer for a given 
art layer. If the Apply to Line Art and Colour Art option is enabled, it will then be 
applied to all bitmap art layers.

 3. Change the bitmap resolution.

 4. Click OK.
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About the Pencil Tool
T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The 
pencil creates a central vector shape. Pencil lines support pressure sensitivity and texture.

The Brush  and Pencil  tools are used for drawing and sketching. Both  tools support pressure sensitivity, allowing 
you to create lines with variable thickness. The Brush tool produces contour vector lines. The Pencil and shape 
tools produce central vector lines. This means that a pencil line’s control points (used to deform its shape) are 
located along the length of the central spine, while the Brush line’s control points are located along the contour.

 l If you draw with the Brush tool and want to modify the thickness variation, use the Contour Editor  tool. 

 l If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor  tool. 

 l You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line   option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the Brush tool as it 
produces a more realistic and natural feel. The pencil line is very useful for tracing clean or final drawings.
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Also, it is recommended to use brush lines when designing cut-out puppet articulations which use patches.

NOTE: To learn more about the Pencil tool options, see the Reference guide .
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Drawing with the Pencil Tool
T-HFND-004-004A

Using the Pencil tool, you can draw central vector lines which easily reshapeable.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to draw with the Pencil tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

 l When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the 
existing one. Pencil lines are central vector lines and you might think your line is connected, 
but in fact, only the contour is touching the other one. Also, make sure the central vector 
crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

 l To draw a straight line, press Shift + Alt as you draw.
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Modifying the Pencil Settings
You can modify the Pencil tool settings such as the size, smoothing, and ends, 

How to modify the pencil settings

 1. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Tool Properties view. Click the arrow button.

The Pencil Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce the thick and 
thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.

Parameter Description

Size and Smoothness tab

Maximum Size Sets the maximum width of the line.

Minimum Size Sets the minimum width of the line in relation to the maximum size.

Smoothness
Lets you modify the central line smoothness  of the line. This parameter smooths 
the initial movement of your line. Increasing the value will result in a smoother line 
with fewer control points.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter will smooth the 
contour of the line once it has been traced; the higher the value, the fewer control 
points will compose your line.

Shape

You can adjust the start, end, and joint  style of a pencil line.

 l Start: Lets you select the style of the start  tip, which is the first tip you 
drew. You can choose between Round or Flat style.
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 l End: Lets you select the style of the end tip, which is the last tip you drew. 
You can choose between Round or Flat style.

 l Join: Lets you select the joint style. The joints are where the line curves 
abruptly. You could also define the Join style as the corner style. You can 
choose between Round, Mitre and Bevel style.

Texture tab

Texture See About Pencil Line Texture on page 192.
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Selecting a Pencil Preset
A pencil preset is a pencil with specific properties. You can work with regular pencil presets and thickness stencils.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing or Camera view, draw your pencil line or shape.
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Creating Pencil Presets
You can create your own custom pencil presets.  

Regular pencil presets allow you to set the size and smoothing of the line or shape.  As you draw, the thickness of 
the line varies according the amount of pressure you apply with a pen and tablet.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, adjust your pencil settingsthe Reference guide .

 3. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 4. Type in a name for your new pencil thickness stencil and click OK.

 5. Start drawing in the Drawing or  Camera view. 
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Creating Pencil Thickness Presets
Thickness stencils that are indicated with this  icon  are also set with specific properties, but disregards the 
pressure of your pen and tablet. The line thickness varies. You can access thickness stencils from the list of presets 
on the Tool Properties view or create your own. 

How to create a pencil thickness stencil

 1. In the Tools toolbar, select the Select  tool.

 2. In the Camera view, select the pencil line or shape from which you want to take the style.

 3. In the Tool Properties view, click the New Thickness Stencil  button.

A new thickness stencil is added to the end of the list in the Presets menu.

 4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or Camera 
view to apply the thickness stencil you created.
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Renaming Pencil Presets
You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the thickness stencil or preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets
You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Applying a Pencil Preset
You can apply a pencil preset on already drawn pencil lines using the Select tool.

How to apply a thickness stencil to a pencil line or shape

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

 3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.
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Exporting Pencil Presets
You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as any 
pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file and 
give it a name.

 5. Click Save.
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Importing Pencil Presets 
You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Pencil Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Changing Pencil Line Opacity Display
A central vector outline can obscure the true edges of a shape's fill. You can change the opacity of central vector 
lines and outlines, while working, to bypass this problem. This feature only works in the OpenGL view. This 
feature is meant to be used as a working tool, like the Light Table or Onion Skin, therefore this transparency effect 
will not appear when the scene is rendered. However, the opacity value that you set will remain as the set 
preference, even after you end a session and close the software.

If you want the transparency of a line or outline to show up in the render of your scene, use one of the many other 
options that Harmony offers, such as colouring the line with a semi-transparent swatch or using the Transparency 
or Colour-Override effects.

How to Use the Pencil Line Opacity feature

 1. In either the Drawing view or Camera view toolbar, click on the Top Light icon. The Pencil Lines Opacity 
feature can also be accessed through the Preferences panel.

The Onion Skin and Light Table Transparency dialog opens.

 2. In the Onion Skin and Light Table Transparency dialog box, use the Pencil Lines Opacity slider to globally 
increase or decrease the opacity of central vector lines. Sliding the slider all the way to the right equals 
100% opacity. Sliding the slider all the way to the left equals 0% opacity.
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 3. Click OK.

NOTE: If your object has a vector contour outline (created by the Brush tool), this feature will not work. It must 
have a central vector outline (created by one of the shape tools or Pencil tool).
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About Pencil Line Texture
You can apply a texture to a pencil line. Pencil lines support texture. Before drawing, you can select or import a 
texture and apply it to your lines. You can also change it afterward using the Select  tool. Textures are independent 
from pencil templates.

When you import a texture in your pencil styles, it is saved in your scene. If you want to add that texture to a bank 
that you will reuse in different scenes, you can add that texture to your preferences.
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Selecting Pencil Textures
You can select various pencil textures from a preset list.

How to apply a preset texture to a pencil line

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Tool Properties view. Click the arrow button.

 3. In the Pencil Properties editor, select the Texture tab.

 4. In the Texture library, select a texture for the pencil.

 5. In the Camera or Drawing view, draw a pencil line.
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Creating Pencil Textures
You can create your own pencil texture presets. 

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil texture template with the Pencil tool

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, click the arrow button beside the stroke preview area.

 3. In the Pencil Properties editor, click the New Texture  button or select New Texture from the Texture 
menu.

 l To delete a preset style, click the Delete Texture  button or select Delete Texture from 
the Texture menu.

 4. Browse for your bitmap texture file. 

NOTE: The following file formats are supported: .jpg, .png, .psd, .sgi, .tif. Your texture MUST 
HAVE an alpha channel.

 5. Click Open.

The imported texture is saved in your texture list.

 6. In the Pencil Properties editor, select your new texture.
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 7. Click the Texture menu and select Rename Texture.

The Rename Opacity Texture dialog box opens.

 8. In the Name field, type the template name and click OK.

 9. In the Camera or Drawing view, draw your pencil line with your new texture.
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Applying Pencil Textures
You can apply a pencil texture preset to an already drawn line. 

How to apply a preset texture to a pencil line

 1. In the Tools toolbar, select the Select  tool.

 2. In the Drawing or Camera view, select a pencil line.

 3. In the Tool Properties view,  select a texture from the Textures area to apply to the selected stroke. 
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Adding Pencil Textures to your Preferences
You can add a pencil texture to your preset preferences. 

How to add a texture to your preferences

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Tool Properties view, click the arrow button beside the stroke preview area.

 3. In the Pencil Properties editor, select a texture from the Textures area to add to your preferences. 

 4. Click the Copy to Preference   button.
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Displaying the Pencil Style Opacity Palette
Each scene that has texture pencil lines has a special texture palette, which is hidden by default. This palette is 
created for a scene when drawing the first pencil stroke with texture. In order to see the texture palette, you must 
enable the Advance Palette Lists preference. Once enabled, you will see a palette named penstyle_opacity 
in your scene's palette list.

It is also possible to assign a custom palette as your pencil texture palette. All textures used to draw in your 
scene will be added to this custom palette. This can be useful if you want to re-use the textures from an existing 
texture palettes, or to save your custom texture palette at the Environment or Job level so as to use it in several 
scenes.

How to enable the Advanced Palette Lists preference

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Harmony Premium > Preferences ( 
Mac OS X ).

2. In the Preferences dialog box, select the Advanced tab.

3. In the Advanced Options section, select the Advanced Palette Lists option.

4. Click OK.

How to assign a custom palette as the Pencil Texture Palette

 1. In the Colour view, create your custom palette and save it at the level of your choice.

 2. Select the palette you want to assign as your pencil texture palette.

 3. From the Colour view menu, select Palette > Pencil Texture Palette.
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About Shape Tools
T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a square 
or circle into a much more complex drawing—see About the Contour Editor Tool on page 232  and About the Pencil 
Editor Tool on page 235. 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, rename, import and 
export presets, see About the Pencil Tool on page 174.  

To learn more about the shape tool parameters, see the Reference guide . 
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Drawing with the Polyline Tool 
You can use the Polyline tool to draw long and curvy lines. 

NOTE: To learn more about the Polyline tool options, see the Reference guide .

How to draw with the Polyline tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your line.

 4. Click a new area and drag to create a second point and Bezier handle.

 l Press Alt to pull only one handle, instead of two.

 l Press Shift to snap the handles to 45, 90, or 180 degrees.

 

 5. Repeat the previous step until your shape is completed.

 6. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click to release the Polyline tool from the current path or 
shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.

 7. If necessary, reshape the lines using the Contour Editor    tool—see Reshaping a Drawing with the Con-
tour Editor Tool on page 233.
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Drawing with the Rectangle, Ellipse, and Line Tools 
T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also draw 
perfect circles and squares. 

NOTE: To learn more about the shape tool parameters, see the Reference guide . 

How to draw with a shape tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Rectangle , Ellipse , or Line  tool.

 3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill  option.

 4. In the Camera view, click and drag to draw the shape.
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 l Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

 l Hold down Alt to draw the rectangle or ellipse from its centre.

 l Hold down Shift to snap the line every 15 degrees.

 l Hold down Alt to snap the start or end of the line to a nearby stroke.

 5. Use the Contour Editor  tool to deform the shape and create your drawing.
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About the Stroke Tool
T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for 
drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool can be 
useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 
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Drawing with the Stroke Tool 
T-HFND-004-013A

You can draw invisible lines with the Stroke tool as well as with the Pencil tool.  

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 

How to draw invisible lines with the Stroke tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar from the Paint drop-down menu, select the Stroke  tool or press Alt + V.

 3. From the top menu, select View > Show Drawing > Show Strokes  or press K. 

 4. In the Tool Properties view, you can adjust the smoothness.

 5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about 
the Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.

How to draw invisible lines with the Pencil tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. From the top menu, select View > Drawing > Show Strokes  or press K. 

 4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

 5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.
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Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about the 
Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.

How to show the strokes with washed-out colours

 1. From the top menu, select View > Show > Show Stroke With Colour Wash.
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About the Eraser Tool
T-HFND-004-010

Using the Eraser tool, you can remove parts of your drawing. When erasing brush strokes and painted areas, the 
contours will keep the shape you traced. When erasing pencil stroke, the central vector will be erased and the line 
tips will reshape based on the line's parameters. 

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing 
and designing. Toon Boom Harmony provides you with a variety of default eraser styles and allows you to create 
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again and 
again. 

The Eraser tool uses its own preset list, separated from the Brush tool. 

NOTE: To learn more about each individual parameter, see the Reference guide .
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Erasing 
T-HFND-004-010A

You can erase portion of your artwork using the Eraser tool.  

For information on erasing textured lines, see How to erase textured lines on page 145. 

NOTE: To learn more about each individual parameter, see the Reference guide .

How to erase with the Eraser tool

 1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Camera or Drawing view, start erasing.
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Erasing Synced Drawings
Normally in the Camera view, the only drawings and lines that can be erased are those on the selected layer. The 
Apply to Synced Drawing Layers  option allows for the inclusion of drawings on layers synced to the selected 
drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to erase synced drawings

 1. In the Tools toolbar, select the Erase  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other layers 
that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the  Apply to Synced Drawing Layers option.

 4. In the Camera view, start to erase. 

Notice that only the selected drawing and its corresponding synced drawings have been erased.
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Modifying the Eraser Settings 
T-HFND-004-010B

In the Tool Properties view, you can modify the Eraser tool parameters such as the size and smoothing. 

NOTE: To learn more about each individual parameter, see the Reference guide  .

How to modify the eraser settings

 1. In the Tools toolbar, select the Eraser  tool.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.
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The Size and Smoothness tab is where you set the minimum and maximum sizes of your drawing tool which 
will produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft 
or textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.

Hardness
Defines the softness of the stroke edge. The lower the value, the 
softer the stroke edge will be. The higher the value, the sharper the 
stroke edge will be.

Saturation

Lets you adjust the softness of edge feathering. Works in con-
junction with the Hardness, e.g. 100% Hardness will yield no res-
ults in saturation change. 0% Hardness will allow a fine tuning of 
the feathering of the soft stroke edge.

Maximum Opacity

The transparency of the brush when the pressure is heavy.  A smal-
ler value will leave semi-transparent colour and texture. A larger 
value will ensure that everything is properly erased. This option in 
unavailable if the Keep Vectors option is disabled.

Minimum Opacity

Sets the minimum transparency of the brush, in relation to the Max-
imum Opacity, when the pressure is very light. A smaller value will 
leave semi-transparent colour and texture. A larger value will 
ensure that everything is properly erased.  This option in unavailable 
if the Keep Vectors option is disabled.

Keep Vectors

Keeps the vector frames around your strokes intact, only the tex-
ture fill disappears. Disabling this option will cut the stroke's vector 
frame into different pieces when the Eraser tool passes over it. If 
you disable this option, the maximum and minimum opacity sliders 
are disabled as well.
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Exporting Eraser Presets
You can export your eraser presets for backup, sharing or installing on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the bitmap and vector brushes and erasers to export, as well as 
any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file 
and give it a name.

 5. Click Save.
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Importing Eraser Presets
You can import Harmony eraser presets you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Eraser Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. 
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About the Select Tool
T-HFND-004-005

Before you can edit objects, you must first select them using the Select tool. After that, you can scale, translate, 
rotate, and resize them, as well as reposition the pivot point.

NOTE: To learn more about the Select tool options, see the Reference guide .
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Selecting 
T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups. 

NOTE: To learn more about the Select tool options, see the Reference guide .

How to select objects

 1. In the Timeline view, select the cell on which you want to select drawing objects.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera or Drawing view, select the drawing objects.

 l You can select all the drawing objects in a drawing by using Edit > Select All or by pressing 
Ctrl + A (Windows/Linux) or ⌘  + A (Mac OS X).

 4. To deform or reposition a selection:

 l To reposition, click the selected drawing object and drag the selection to a new area.

 l To rotate, grab the selection box handle and rotate it.

 l To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock 
the selection’s ratio.
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 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.
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Selecting Synced Drawings
Normally in the Camera view, any visible line or drawing  can be selected. When you enable the Works on Single 
Drawing mode, only drawings from the currently selected layer can be selected.

The Apply to Synced Drawing Layers option works in conjunction with the Works on Single Drawing mode. The 
Works on Single Drawing mode still limits the selection to a single layer, but the Apply to Synced Drawing Layers 
option allows for the inclusion of drawings on layers synced to the selected drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to select synced drawings

 1. In the Tools toolbar, select the Select  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other layers 
that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the Works on Single Drawing mode and the Apply to Synced Drawing 
Layers option.

 4. In the Camera view, select a drawing or any of its corresponding synced drawings.

Notice that only those drawings are selectable. 
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Inverting a Selection
You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I.

You can also find the Invert Selection option in the Camera or Drawing View menu by selecting Edit > 
Invert Selection.
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Repositioning the Selection Pivot
You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Camera or Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you 
make a new selection.
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Working on a Single Drawing with the Select Tool
You can set the Select tool to select the artwork on all the layers or on the current layer only. In the Drawing view, 
it only works on the current layer. In the Camera view, you can set one mode or the other. 

NOTE: To learn more about the Select tool options, see the Reference guide .

How to enable the Select Tool Works on Single Drawing preference

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. Do one of the followings:

 l In the Tool Properties view, click the Works on Single Drawing  button.

 l Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences (Mac 
OS X). In the Camera tab, go to the Tools section and select the Select Tool Works on 
Single Drawing option and click OK.

 3. In the Camera view, make your selection. Note that you may need to restart Harmony depending on your 
system.
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About the Repositioning All Drawings Tool
The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every drawing 
included in a layer. 

If your hand-drawn animation requires to be repositionned in the grid, as soon as your select the Reposition All 
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the controls 
the same was as the Select tool—see About the Select Tool on page 215. 

You can use the Drawing Desk feature to select specific drawings and avoid repositioning all the drawings—see 
About the Drawing Desk on page 319. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning Drawings
Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the current 
layer. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects every 
stroke in your drawing in the Drawing and Camera view.

 2. Do any of the following:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.
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 l To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift to main-
tain the selection’s ratio.

 l To skew, drag the sides or top and bottom segments, between the control points.

 3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated or 
skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the Tool Prop-
erties view.
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Repositioning All Synced Drawings
Normally in the Camera view, the only drawings that can be repositioned are those from the selected layer. The 
Apply to Synced Drawing Layers  option allows for the inclusion of drawings on layers synced to the selected 
drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to reposition all synced drawings

 1. In the Tools toolbar, select the Reposition All Drawings  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other layers 
that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the  Apply to Synced Drawing Layers  option—see the Reference 
guide .

 4. In the Camera view, click and drag the drawings highlighted by a bounding box to a new location. 

Notice that only drawings from the selected layer and its corresponding synced drawings have been 
selected.
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 5. Delete, move, scale, skew or rotate the cut selection.
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About the Cutter Tool
T-HFND-004-007

The Cutter tool lets you cut a drawing to move, copy, or delete it.You can use it to scale or reposition the portion 
of a flattened or bitmap drawing. you can also use it to trim strokes using a single gesture.

NOTE: To learn more about the Cutter tool options, see the Reference guide .
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Cutting Artwork 
T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

NOTE: To learn more about the Cutter tool options, see the Reference guide .

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Camera or Drawing view, select an area to cut away.

 l To delete the selected area, press Delete.

 l To move the selection, drag it to a new area.

 l Use the bounding box controls to scale, skew, or rotate the cut piece.
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Cutting Synced Drawings
Normally in the Camera view, the only drawings and lines that can be cut are those on the selected layer. The 
Apply to Synced Drawing Layers  option allows for the inclusion of drawings on layers synced to the selected 
drawing layer.

Layers are synced when drawings need to be separated on different layers, but need to have the same timing.

How to cut synced drawings

 1. In the Tools toolbar, select the Cutter  tool.

 2. In the Timeline view, select a synced drawing layer. When you click on a synced layer, the other layers 
that it is synced with will display the link icon.

 3. In the Tool Properties panel, enable the  Apply to Synced Drawing Layers option.

 4. In the Camera view, create a region that includes both drawings. 

Notice that only drawings from the selected layer and its corresponding synced drawings were 
repositioned in the Camera view.
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About the Contour Editor Tool
T-HFND-004-008

The Contour Editor lets you reshape drawings. By displaying vector points around a shape and the central vector 
points in a pencil line, you can pull or push on these points to adjust the brush’s line thickness. Points can be 
selected and deleted. Each point has two Bezier handles for correcting the curves between two points. You can 
modify shapes by pulling and pushing directly on the segment between the points. You can use it to perfect a 
central shape pencil line, a contour shape brush line, or even create an elaborate shape from a basic ellipse or 
square.

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .
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Reshaping a Drawing with the Contour Editor Tool
T-HFND-004-008A

You can use the Contour Editor tool to reshape vector drawings by editing the points. 

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .

How to reshape drawings with the Contour Editor Tool

 1. In the Timeline or Xsheet view, select the cell in which you want to draw.

 2. In the Tools toolbar, select the Line , Ellipse , or Rectangle  tool. The following example uses the 
Ellipse tool.

 3. In the Tool Properties view, click the Ellipse  button, click the Auto Fill  button and set the pencil size 
to 0.

 4. In the Drawing or Camera view, draw a circle.

 5. In the Tools toolbar, select the Contour Editor  tool.

 6. In the Drawing or Camera view, click the line to reshape it.

 7. Select one or several points by clicking on them or circling around.
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 8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘  (Mac OS X)and click on the contour to add a new point to adjust the 
contour.

 9. To modify the shape, you can:

 l Pull on the Bezier handle. Both point’s handles will move as one.

 l Hold down Alt and pull on one of the Bezier handles. The point’s handle will move inde-
pendently from the other one.

 l Move the selected points to a new area.

 l Pull directly on the line between two points. No selection is necessary. Holding down Shift 
will limit the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

 l To add control points, press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the line.

 l To remove control points, select the control point and press Delete.
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About the Pencil Editor Tool
T-HFND-004-009

A pencil line is a central vector shape. Control    points are located along the central spine allowing you to adjust the    
stroke curve and position. Using the Pencil Editor tool, you can adjust the thick and thin areas of pencil lines. Using 
the Contour Editor tool, you can reposition the spine of the stroke.

NOTE: To learn more about the Pencil Editor tool options, see the Reference guide .

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com
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Reshaping Pencil Lines 
T-HFND-004-009A

You can use the Pencil Editor tool to reshape the pencil line thickness. 

NOTE: To learn more about the Pencil Editor tool options, see the Reference guide .

How to reshape pencil lines

 1. In the Tools toolbar, select the Pencil Editor  tool.

 2. In the Camera or Drawing view, select a pencil line and click to reshape it.

 3. Select one or several points by clicking them or circling around.

 4. Press Delete to delete a selected point.
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 5. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the central spine to add a set of points to adjust the 
contour.

 6. To modify the shape, you can:

 l Move the selected points to a new area. If you select matching points on each side of the line, 
holding the Shift key will move them both.  This way you can thicken or thin a line from both 
sides at the same time.

 l Pull on the Bezier handle to move both points’ handles s one.

 l Hold down Alt and pull on one of the Bezier handles. It moves the handle independently from 
the other one.
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 l Pull directly on the line between two points. No selection is necessary. Holding down the 
Shift key will limit the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handle, hold down Alt to display them.
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About the Smooth Editor Tool 
When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw may 
look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the lines, the 
Smooth Editor  tool. 

NOTE: To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Lines
You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select Drawing > Tools > Smooth Editor.

 2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass over 
the same line several times to remove more points and make the line smoother. Note that by default, the 
Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see the Reference 
guide  to learn about the various settings available.
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About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and edge 
anchor points to warp the shape.

To have even more control points to fully warp a vector image, see About the Envelope Tool. 

NOTE: To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool
Use the Perspective tool to distort a drawing's bounding box.  

NOTE: To learn more about the Perspective tool options, see the Reference guide .

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or press Alt + 
0.

 2. In the Camera or Drawing view, select a drawing to deform.

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You can 
warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE: To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool
You can warp your drawings using the Envelope tool.  

NOTE: To learn more about the Envelope tool options, see the Reference guide .

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 2. In the Timeline view, select a drawing to deform.

 3. In the Camera or Drawing view, select the region you want to deform

 4. Click and drag the different anchor points and handles to deform the image.
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 5. To display more controls, in the Tool Properties view, click the Show Advanced Controls  button.

 6. Increase the height and width of the grid to get more control points to deform your image.
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About the Text Tool
With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are part 
of a drawing, so you can manipulate them in the same way. OTF fonts are also supported.

Once your text is writing, you can break the strings apart to convert the letters into drawing objects that can than 
be individually modified with tools such as Select, Perspective, Contour Editor, Smooth Editor. 

NOTE: To learn more about the Text tool options, see the Reference guide .
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Adding Text
You can use the Text tool to add text to your drawings.  

NOTE: To learn more about the Text tool options, see the Reference guide .

How to add text to drawings 

 1. Do one of the following: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Drawing > Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing or Camera view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see the 
Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always return to 
edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box with the Text   tool and moving the anchor point right 
or left. Using the Select tool will distort and scale your text itself rather than changing the width and height of 
your text box.
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Breaking Text Apart
Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText Lay-
ers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that you can 
edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use the Select 
tool to select the letters to convert.

 5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into a reg-
ular drawing object, with no more text attributes.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text Lay-
ers to break the selection into a regular drawing object, with no more text attributes.
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About the Rotate View Tool
The Rotate View  tool lets you rotate the Drawing or Camera view, the same way as you would do with a real 
animation disc  for increased flexibility. This tool can also be used in the Perspective view.

The rotation angles for the Camera and Drawing views are independent; if you rotate the Drawing view 25 
degrees, if you switch to the Camera view, you can use the rotary table in that view and rotate it to a different 
angle without affecting the settings in the other view.

When using the Rotate View tool, you are only rotating your workspace. You can not changing the actual rotation 
angle of your drawings. Exporting your project will completely ignore the Rotate View angle.

The Rotate View tool has no options in the Tool Properties view.
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Rotating the Workspace
You can use the Rotate View tool to rotate your drawing workspace. 

How to use the Rotate View tool

 1. Do one of the following:

 l From the top menu, select Drawing > Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool.

 l In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X).

The rotary table appears.

 2. In the Drawing or Camera view, click and drag to rotate the space. 

 3. Release the keyboard shortcut or switch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing or Camera view. When you are zoomed in your 
workspace, you may need to pan to a different area of your image. You can do so with the Hand tool or the 
Spacebar keyboard shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the following:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing or Camera view and drag. 

 l You can also Hold down the Spacebar, click in the Drawing or Camera view and move your 
mouse in the direction you want to pan the view.
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About the Zoom Tool
The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

NOTE: To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Camera or Drawing view. 

 3. In the Tools Properties view, do the following:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Camera or Drawing view.
 When you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Camera or Drawing view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.
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About Tool Presets
Tool presets let you save a variety of settings and are very efficient for accessing the tools you use most often. 
That way, the tool is already set with the desired properties, such as colour, line thickness, whether to enable 
Draw Behind or Auto Flatten mode, and so on. You can create presets for these tools and many more: Brush, 
Pencil, Eraser, Rectangle, Ellipse, and Line. 

The difference between a tool preset and a brush preset is that when you save a tool preset, you have the option 
of saving the colour and assigning a shortcut, which you cannot do with brush presets.

The Tool Presets toolbar lets you create new tool presets and manage them. 

254



Harmony 14 Premium - User Guide

Displaying the Tool Preset Toolbar
Use the Tool Preset toolbar to create, manage and select your custom tool presets. You can display the toolbar in 
the Drawing and Camera views as well as the top area. 

How to display the Tool Presets toolbar

 1. Do one of the following:

 l From the top menu, select Windows > Toolbars > Tool Presets.

 l Right-click an empty area below the top menu and select Tool Presets.
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Creating Tool Presets
You can create your custom tool presets to quickly access brushes and pencils settings and colours you use 
frequently. 

How to create a tool preset

 1. In the Tools toolbar, select a tool, for example the Brush tool.

 2. Use the Tool Properties view to customize the tool. 

 3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the tool. 

NOTE: When using a tool preset in a scene that is not using the assigned colour swatch,  a col-
our recovery dialog box appears prompting you to add the colour to the scene.

 4. In the Tool Presets toolbar, click the New Tool Preset   button.

 5. In the New Preset dialog box, in the Name field, type a name for your new preset.

 6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the File  
button.
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 7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset. By default, the 
shortcuts are unassigned. To assign a keyboard shortcut, select Edit > Preferences > Shortcuts > Tool 
Presets (Windows/Linux) or Harmony Premium > Preferences > Shortcuts > Tool Presets (Mac OS X).

 8. When you select an option, it will take effect when you use the tool preset. If an option is deselected, then 
using a tool preset will not override your current settings. 

 l Colour: Saves the current colour into the tool preset.

 9. Click OK.
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Selecting Tool Presets
You can select tool presets in the Tool Presets toolbar. 

How to select a tool preset

 l In the Tool Presets toolbar, click the tool preset  icon you assigned when creating the preset.  Note that 
when using this preset in a new scene not using the assigned colour swatch,  a colour recovery dialog box 
appears prompting you to add the colour to the scene.
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Deleting Tool Presets
You can delete unnecessary tool presets to keep your list organized. 

How to delete a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.
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Updating Tool Presets
You can update existing tool presets through the Manage Tool Presets dialog box. 

How to update a tool preset

 1. In the Tool Properties view, update the tool settings.

 2. In the Tool Presets toolbar, click the Manage Tool Presets  button.

 3. In the Manage Tool Presets dialog box, select the tool preset from the list. 

 4. Update the additional parameters such as the icon, Colour, Layer and Draw Behind options.

 5. Click Update.

 6. Click OK.
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Exporting Tool Presets
You can export tool presets for backup, sharing, or installing on a different computer. 

How to export a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Export.

 3. In the Export Brush Presets window that opens, click  Export.

 4. Select a folder and click Select Folder.
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Importing Tool Presets
You can import Harmony tool presets you previously exported. 

How to import a tool preset

 1. In the Tool Presets toolbar, click the Manage Tool Presets  button.

The Manage Tool Presets dialog box opens.

 2. Click Import.

 3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select Folder.
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About the Grid 
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a given 
layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the grid boundaries 
as it is only a visual reference.  

In the Camera view, the Grid is visible when you select a drawing tool.
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Displaying the Grid
You can display the grid and it will be visible in the Drawing view. It will be visible in the Camera view when you 
select a drawing tool. 

Use the Show Grid option to display a grid in the Drawing or Camera views. 

How to display the grid 

 1. Do one of the following: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).
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Modifying the Grid
You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the following: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid. 

 l View > Grid > 12 Field Grid—Displays a 12-field size grid. 

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements. 

 l View > Grid > Overlay—Displays the grid over the drawing elements.

 3. In the Drawing View and Camera View toolbars, you can also add the following buttons—see Customizing 
View Toolbars on page 97.

 l Grid Outline Only  button 

 l Square  button 

 l 12 Field Grid  button 

 l 16 Field Grid  button 

 l Underlay  button 

 l Overlay  button
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Grouping Drawing Strokes
Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the 
selection, repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. 
Grouping does not flatten your objects. You can ungroup your selection at any time. You can also group groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Group.

 l From the Camera or Drawing view menu,  select Edit > Group > Group.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Ungroup.

 l From the Camera or Drawing view menu,  select Edit > Group > Ungroup.

 l Press Ctrl + Shift + G (Windows/Linux) or ⌘  + Shift + G (Mac OS X). 
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Arranging Drawing Strokes
The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing or 
Camera view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the following: 

 l From the top menu, select Drawing > Arrange > Bring to Front—Moves the selected art to the 
front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘  + Shift + PgUp (Mac OS X). 

 l From the top menu, select Drawing > Arrange > Bring Forward—Moves the selected art one 
level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘  + PgUp (Mac OS 
X).

 l From the top menu, select Drawing > Arrange > Send Backward—Moves the selected art 
one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘  + PgDown (Mac OS X).

 l From the top menu, select Drawing > Arrange > Send to Back—Moves the selected art 
behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux) or ⌘  + Shift 
+ PgDown (Mac OS X).

 4. In the Drawing View and Camera View toolbars, you can also add the following buttons—see Customizing 
View Toolbars on page 97.

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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About Drawing Optimization 
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those 
drawings to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to flatten 
your artwork or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected 
drawing objects. Drawing objects will only be flattened and optimized if the selected objects do not change the 
appearance of the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an 
additive colour effect, the selected transparent drawing objects will not be merged. This is because merging the 
transparent drawing objects will cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to 
be repainted later.

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath 
the vector contour of a textured line. This often occurs when you cut and paste textured lines from one drawing 
into another. If you cut a portion from a textured line and paste it into a different drawing, Harmony pastes the 
entire unseen texture bitmap from the source drawing into the new one, even if you only took a small portion of the 
source drawing. Using the Crop Brush Texture command will crop away extraneous texture that does not touch 
the vector area. If there are many textured lines in your scene, this will greatly reduce the file size.
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In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At first, it appears 
as if only a cropped section of the underlying texture bitmap was cut and pasted as well. However, using the 
Contour Editor tool to expand the vector envelope of the textured line, it is revealed that more texture bitmap exists 
beyond the cropped boundary. If you use the Crop Brush Texture command, the bitmap texture is cropped to the 
boundaries of the textured line’s vector contour (as seen in the fourth image where the vector envelope has been 
pulled out to reveal empty space). 
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Flattening Drawings
The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By 
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will be 
easier if they are flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  button in 
the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a pencil 
line. It also smooths out the shape.  

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  button in 
the Tool Properties view.
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Creating Contour Strokes
The Create Contour Stroke  option is used to add a permanent invisible line around a shape that was drawn 
directly in Harmony. This allows you to unpaint your lines with the Paint  tool but maintain the shape of the lines, 
should you need to repaint later.

This command is useful when inking and painting and using the Apply to All Drawings in Layer  option.

How to create contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to create con-
tour strokes for.

 3. From the top menu, select Drawing> Optimize > Create Contour Strokes.
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Removing Contour Strokes
The Remove Contour Stroke option is used to remove any permanently invisible lines that were created while 
scanning and vectorizing drawings or manually adding contour strokes. This is useful if you want to remove the 
intersection triangles created during vectorization.

How to remove contour strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to remove contour 
strokes for.

 3. From the top menu, select Drawing> Optimize > Remove Contour Strokes.
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Removing Extra Strokes
The Remove Extra Strokes option lets you remove the invisible lines in your selection.

How to remove extra strokes

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects from which you want to 
remove invisible lines. 

 3. From the top menu, select Drawing > Optimize >Remove Extra Strokes.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Remove Extra 
Strokes.
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Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your drawings. This 
mainly means that transparencies will not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to optimize. 

 3. Do one of the following:

 l From the top menu, select Drawing > Optimize > Optimize.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Optimize. 
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Cropping Brush Textures 
The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen beneath 
the vector contour of a textured line

How to crop the brush texture

 1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop. 

 2. Do one of the following:

 l From the top menu, select Drawing > Optimize > Crop Brush Textures.

 l From the Camera View or Drawing View menu, select Drawing > Optimize > Crop Brush 
Textures.
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Reducing the Drawing Texture Resolution
When you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be heavy. 
You can reduce the size and resolution of the textures in a drawing. 

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects whose texture resolution 
you wan to reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing Tex-
ture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your 
layer.

 6. Click OK.
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About Strokes Conversion 
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For many 
reasons, you may want to switch your stroke types to another type to use the various advantage set they offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes 
(strokes) to pencil lines. 

You can also break text objects apart—see Breaking Text Apart on page 249.

278



Harmony 14 Premium - User Guide

Converting Brush Strokes to Pencil Lines 
The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. The 
brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ̂ .

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ̂
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Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour strokes 
brush lines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press 
&.

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &. 

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l Select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12 (Windows/Linux 
only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only)
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About OpenGL Antialiasing
Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you 
draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast real-
time display called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing 
preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your 
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or off; by 
default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference
You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE: You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences (Mac OS 
X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. The 
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the anti-
aliasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

 4. Restart Harmony.
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About the Tool Colour Swatches
While drawing and painting, you can let Harmony retain the last colour you selected for each one of the following 
tool types:

 l Brush

 l Paint 

 l Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint,   and Pencil   tools.

You can also link or unlink the colour swatch used between vector and bitmap layers.
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Unlinking the Tool Colour Swatches 
You can unlink the tool colour swatches and use separated colours for the Brush, Paint, and pencil line tools. 

If you prefer to have Harmony use the same colour swatches regardless of the selected tool, you can link the three 
swatches together.

How to unlink the tool colour swatches

 1. In the Colour view, if the storage swatches are linked, click the Link   button to unlink them.

 2. Click on the Brush  storage swatch.

 3. In the Colour list, select the desired colour.

 4. Click the Pencil   storage swatch.

 5. In the Colour list, select a colour.

 6. Click the Paint   storage swatch.

 7. In the Colour list, select a colour.

285



Chapter 4: Drawing      About the Tool Colour Swatches

286



Harmony 14 Premium - User Guide

Linking the Tool Colour Swatches
You can link the tool colour swatches so all the tools use the same colour swatch.

How to link the storage swatches

 1. In the Tools toolbar, select one of the following tools:

 l  Brush

 l  Paint

 l  Pencil

 l  Polyline

 l  Line

 l  Ellipse

 l  Rectangle

 2. In the Colour view, if the storage swatches are unlinked, click the Link   button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.
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Using Independent Bitmap Colour Swatches
When working in the Colour view, by default the current colour is active for both vector and bitmap layers. You 
can however, use different reference colours for each layer. 

When using bitmap colours, there is no longer a link between the painted zones and selected colour. You can edit 
the colour  as much as you want, but your drawing will not be affected. You can still select colours from your 
vector colour palette to use the same tint, but you will not create links between your drawing and the swatches.

How to use independent colours

 l From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.
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Displaying the Current Drawing on Top
In the Camera view, when you draw on a layer, the artwork is displayed in the correct order. For example, if the layer 
on which you are drawing is located behind an object on another layer, the lines you draw will be hidden behind that 
object.

You can display a selected drawing on top of everything while you draw. Then, each time you  select a drawing tool, 
the drawing is displayed in front of everything in the Camera view. The Timeline and Node view ordering remain 
unchanged. 

How to display the drawing on top

 1. Do one of the following:

 l From the top menu, select View > Show > Current Drawing on Top. 

 l In the Camera bottom toolbar, click the Current Drawing on Top button.

NOTE: The Current Drawing on Top status is retained when you exit Harmony. When you restart 
the application, the last status will be used.

 2. In the Tools toolbar, select a drawing tool. You only need to enable this option once, it is not necessary to do 
it each time you select a drawing tool.  

 3. In the Camera view, start drawing.
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Chapter 5: Paperless Animation
T-HFND-006-001

Toon Boom Harmony is a powerful paperless animation software that incorporates animation and drawing tools to 
make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles of animation 
still apply. 

One of the advantages of working with paperless animation is that you do not lose time scanning elements in and 
testing them because everything is already digital. You can simply draw your animation and play back your line test 
right away. This also saves the substantial amount of paper required by traditional animation. Another practical 
advantage is the ability to undo and redo some actions that are often difficult on paper, such as erasing brush 
strokes.
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Creating a Rough Animation
The first step to complete a traditional paperless animation is the rough construction, which is the skeleton of your 
animation. You would usually start with the main action. For example, to animate a walk cycle, you will start with 
the torso motion and the legs. Head, arms and clothes will be added later during the secondary animation.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the details 
when you're satisfied with the movement. If you start animating all the details right away, you will lose a lot of 
time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X) to open the Preferences dialog box. 

 2. Select the Exposure Sheet tab. 

 3. Select the Use Current Frame as Drawing Name option. When this preference is enabled, drawings will 
be named like the frame they are created on (frame number).

 4. In the Tools toolbar, select the Brush  tool or press Alt + B.

 5. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your rough 
animation. This will make the clean up process easier as your clean dark lines will contrast with your light 
sketch lines. 

 6. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 7. In the Camera or Drawing view, draw the first key drawing.
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 8. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This will help 
you stay organized.

 l In the Mark Drawing toolbar, click the Mark Selected Drawings as Key  button.

 l In the Xsheet view, select Drawings > Mark Drawing As > Key Drawing.

 l In the Timeline view, select Drawings > Mark Drawing As > Key Drawing.

 

 9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

 10. In the Tools toolbar, click the Onion Skin  button. This will display the previous and next drawings in a light 
colour in the Camera or Drawing view, behind your current drawing, so that you can use them as references 
to draw new drawings with accuracy. This can be useful to draw breakdown poses between two key poses, 
or to add an in-between drawing between two other drawings.

 11. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing on it. To 
do this, do one of the following:

 l In the Timeline view, drag the blue onion skin markers to extend the number of past and future 
drawings to display as onion skin, if needed. 

 l In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing 
, Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing 
 and Onion Skin Add One Next Drawing  buttons to adjust the span of the onion skin 

frame by frame.
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NOTE: When in the Drawing view, you can use the Onion Skin toolbar to make onion skin dis-
play only specific types of drawings, such as key drawings or breakdowns. Keep in mind that 
this does not work in the Camera view.  

 12. In the Camera or Drawing view, draw your second key drawing.

 13. In the Xsheet or Timeline view, identify the drawing as a key drawing.

 14. In the Timeline or Xsheet view, select a cell between the two key drawings.

 15. In the Camera or Drawing view, draw your new pose.

 16. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new drawing.

NOTE: When working with overlay layers in the Camera view, you can enable the Current Drawing on Top 
 option to make the layer you're working on appear over other layers. 
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How to review your animation

 1. In the Timeline view, use the Enable/Disable All  and Solo  buttons to turn off any layers you don't  
want to see during playback.

 2. In the Timeline view, move the red playhead to the first frame of your animation and click the Start button on 
the Timeline toolbar. Then, move the playhead to the last frame of your animation and click the Stop button.

 3. In the Playback toolbar, click the Loop  button to enable looping during playback.

 4. In the Playback toolbar, click the Play  button to being playback.

NOTE: While animating, you can use the Flip and Easy Flipping toolbars to review your animation as you go —
see Flipping Animation on page 311. 
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Creating the Tie Down Animation
Once your rough animation  is correct, you can start adding extra details, such as arms, clothes or hair. You can 
add the extra details on the same layer with the same colour or you can also create a new colour so that you can 
always see your original sketch.

If your primary and secondary animation were done as a rough drawing, it is now time to put your drawing on 
model, also known as tie down. This means that you have to review your animation and ensure that every single 
detail is on model and there is no volume distortion. You can do this directly on the original sketch layer or on a 
new layer.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing element and 
use the Light Table feature to draw over the first drawing element. This technique can also be used if you want to 
reuse your rough animation for other characters. For example, if you have a rough walk-cycle, you can reuse it for 
another character and add its personal features in a new layer. This way, you only need to animate the secondary 
animation instead of the whole body again. 

How to create secondary animation on the same layer

 1. In the Xsheet or Timeline view, select the cell in which you want to add new details.
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 2. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for example) or 
select the same rough colour as before.

 3. In the Drawing Tools toolbar, select your drawing tool.

 4. In the Camera or Drawing view, draw the secondary animation.

 5. Do one of the following:

 l In the Xsheet or Timeline view, select the next cell in which you want to draw.

 l Press F and G to navigate between your drawings.

 6. Do one of the following:

 l Select View > Onion Skin > Show Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 7. Extend the onion skin.

 8. In the Camera or Drawing view, draw the secondary animation.
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 9. Use the Flip and Easy Flipping toolbars to review your animation—see the Flip and Easy Flipping toolbars 
in the Reference guide.

 10. You can also use the Playback toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

 1. Add a new drawing layer and name it secondary_animation.

 2. In the Timeline or Xsheet view, select the rough layer's timing.

 3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘  + B 
(Mac OS X).

 4. Choose Never create drawing files from the options to paste the timing but not the drawing files.

 5. If you are working in the Drawing view, in the Drawing View toolbar, enable the Light Table.

 6. In the Xsheet or Timeline view, select the cell where you want to add the new details.
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 7. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for example) or 
select the same rough colour as before.

 8. In the Tools toolbar, select your drawing tool.

 9. In the Drawing or Camera view, draw the secondary animation on top of your rough drawing.

 10. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

 11. Do one of the following:

 l In the top, Drawing View or Camera View menu, select View > Onion Skin > Show Onion 
Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.
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 12. Extend the onion skin.

 13. In the Camera or Drawing view, draw the next secondary animation.

 14. Use the Flip and Easy Flipping toolbars to review your animation—see the Reference guide . 

 

 15. You can also use the Playback toolbar to play the animation in real time.
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Cleaning Animation
T-HFND-006-010

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It consists 
of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless animation 
step before the ink and paint step.

You will need to add a new drawing layer to create your clean drawing. This is the equivalent of adding a sheet of 
paper and tracing the rough using the animation disk. This allows you to keep the roughs and the cleans intact. You 
only need to lock the rough layer to prevent it from appearing in the scene. 

If you plan on tracing your animation in the Drawing view, use the light table to display all the layers in your project.

How to trace animation in a new layer

 1. In the Layer toolbar, click the Add Drawing Layer  button and add a new layer.

 2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid selecting 
the layer in the Camera view.

 3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key drawing of your 
rough animation.

 4. In the Tools toolbar, select the drawing tool of your choice. The Pencil  tool is recommended.

 5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, would ensure 
that it contrasts well with the light colour of your rough animation.

 6. In the Camera or Drawing view, start tracing the first key drawing.
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 7. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that 
only the rough animation and clean-up layer are displayed in the Camera view. 

 8. In the Tools toolbar, click the Onion Skin  button and pull on the blue onion skin handles in the Timeline 
view to extend the number of frames you can see.

 9. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing , 
Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and 
Onion Skin Add One Next Drawing  buttons to adjust the span of the onion skin frame by frame.

 10. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 11. In the Drawing or Camera view, trace your next drawing.

 12. Repeat the previous steps for each drawing.
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Paperless Animation Tools
To understand paperless animation, you must first discover the tools available. There are, of course, drawing tools, 
but also practical features such as setting a drawing as a key, breakdown or in-between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work efficiently, as 
you would with an animation table, paper and pencils. 

The onion skin and light table are used to preview previous and next drawings, cells, elements and frames. When 
designing or animating, it is very useful to see your previous drawings. Just as if you were building a cut-out puppet, 
you want to view other drawing elements to know where to draw the new element. 

Harmony has many useful advanced features such as the Flipping toolbar, enhanced onion skin, extra drawing 
layers, and automated matte generation.
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Creating Empty Drawings
The Create Empty Drawing  command automatically creates Creates a drawing in the selected cell, replacing any 
drawing that may already be exposed in that cell and the following ones until it meets another drawing, key 
exposure or a blank cell. 

How to create an empty drawing

 1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

 2. Do one of the following:

 l In the top menu, select Drawing > Create Empty Drawing.

 l In the Xsheet view menu, select Drawings > Create Empty Drawing.

 l In the Xsheet view toolbar, click the Create Empty Drawing  button. 

 l In the  Timeline view toolbar, click the Create Empty Drawing  button. 

 l Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline view.
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About the Onion Skin
The Onion Skin   tool lets Lets you preview the previous and next drawings. By default, the previous drawings appear 
in a shade of red and the next drawings are displayed with a shade of green. You can change these colours in the 
Preferences dialog box. 
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Enabling the Onion Skin
You can enable the onion skin to see your previous and next drawings as reference,  

NOTE: You can modify the onion skin display in the Preferences panel.

How to enable the onion skin

 1. Do one of the following:

 l From the top menu, select View > Onion Skin > Show Onion Skin.

 l In the Timeline view, click the Onion Skin  button on a layer.

 l In the Tools toolbar, click the Onion Skin  button.

 l Press Alt + O.

Blue arrows appear on both sides of the play head.  

 2. Drag the blue arrows to add more frames to the onion skin display.  
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Displaying Marked Drawings in the Onion Skin
In the Drawing view, you can set up your onion skin to display marked drawings only, in the same way that you flip 
through your drawings marked as key, breakdown or in-between drawings—see About Marked Drawings on page 313

 

How to display marked drawings in the onion skin

 1. From the top menu, select Windows > Toolbars > Onion Skin.

 2. In the Tools toolbar, click the Show Onion Skin  button.

 3. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin pre-
view.

 4. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing , Onion Skin 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion Skin Add One 
Next Drawing  buttons to adjust the span of the onion skin frame by frame.

 5. In the Onion Skin toolbar, enable the markers you want to see in your Onion Skin preview.
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Displaying the Onion Skin in the Other Layers 
You may need to see the onion skin for the other layers previous and next drawing. The Light Table option in the 
Onion Skin toolbar allows you to do that.

How to enable the onion skin in other layers

You might need to refer to previous and next drawings in other layers than the current one. In the Drawing view, use 
the Enable Onion Skin in Other Elements feature to see the previous and next drawings of the layers visible in Light 
Table mode.

 1. In the top menu, select Windows > Toolbars > Onion Skin.

 2. In the Tools toolbar, click the Onion Skin  button.

 3. In the Drawing view, click the Light Table  button. 

 4. In the Timeline view, pull on the blue arrows to extend the number of drawings displayed in the onion skin pre-
view.

 5. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing , Onion Skin 
Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and Onion Skin Add One 
Next Drawing  buttons to adjust the span of the onion skin frame by frame.

 6. In the Onion Skin toolbar, enable the Enable Onion Skin in Other Elements option.
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 l The current layer is displayed by default in shades of green and red.

 l Drawings in timeline layers above the current layer are displayed by default in shades of 
blue.

 l Drawings in timeline layers below the current layer are displayed by default in shades of yel-
low.

NOTE: You can change the default onion skin display colours in the Preferences dialog box. 
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Flipping Animation
Toon Boom Harmony allows you to rapidly flip through drawings in the Drawing view just as you do with paper 
drawings. You can flip through the key, breakdown or in-between drawings individually, or view a combination. 

NOTE: To learn more about these toolbars, see the Reference guide .

How to flip through drawings

 1. Do one of the following:

 l In the top menu, select Windows > Toolbars > Easy Flipping.  

 l Select Windows > Toolbars > Flip.

 2. In the Easy Flipping toolbar, click the Previous  or Next  button to see the previous or next drawing of 
your animation.

 3. To display drawings in the first frame after you reach the last frame of your animation, select the Loop option.

 4. Move the slider to the right to flip forward and to the left to flip backward through your drawings.

 l The further you move the slider to the left or right, the faster the drawings will flip.

 5. Enter in a Preroll value to set  the number of drawings to be flipped through before the starting drawing. The 
starting drawing is determined by the position of the red playhead in the Timeline view.

 6. Enter a value in the FPS (frames per second) field to set the speed of flipping.

 7. Click on the Easy Flip button to automatically flip through the drawings based on the FPS.

 8. If you marked some of your drawings, you can flip through the markers and avoid seeing all the in-betweens. 
Enable the Flip Key, Breakdown or In-between buttons in the Flip toolbar to see only one type or a com-
bination—see Paperless Animation Tools
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About Marked Drawings
T-HFND-006-004

When working with several animators, directors or even other studios, the necessity for retakes will often arise. 
Harmony gives you the possibility to mark new drawings as either Retake Key, Retake Breakdown, or Retake In-
betweens.In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. 

About the Key Drawing

A key drawing is a visually significant pose in a movement, often an extreme position. For example, if a character 
that is sitting down falls on his back, the key poses would be the character sitting and the character on his back. Of 
course, it may vary from one animation to another.

About the Breakdown Drawing

A breakdown drawing is a pose somewhere between two key poses that better shows the movement. Most 
animation moves are arcs, such as an arm waving, somebody bending, or a leg walking. All of these movements are 
rotations. The breakdown pose is used to describe this curve better.

The breakdown drawing is then used to indicate secondary poses, also called the follow-through. These actions can 
be a big stomach jiggle as somebody jumps, a cloak floating behind somebody that is running, or arms moving after 
the main body action. These moves will generally have a different timing than the primary action. They will mainly 
start later and finish later. So, the breakdown drawings are used to complete the key drawings.

Note that a breakdown drawing is not always placed exactly in the middle of two keys. It will often be closer to one 
or the other depending on the timing and the action. Also, you can have more than one breakdown pose between two 
keys.
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Marking Drawings 
T-HFND-006-004A

You can mark your drawings as Key, Breakdown, or other custom marks.

How to mark a drawing as Key, Breakdown or In-between

 1. From the top menu, select Windows > Toolbars > Mark Drawing. 

The Mark Drawing toolbar displays.

 2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline view.

 3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing , Mark as Breakdown 
Drawing  or Mark as In-between Drawing . In the Xsheet menu, you can also select Drawing > 
Mark Drawing As > Key Drawing, Breakdown Drawing, In-between Drawing, Retake Key, Retake 
BD and Retake IB.

 l If you selected Mark as Key Drawing, a  icon appears in the cell.

 l If you selected Mark as Breakdown Drawing, a  icon appears in the cell.

 l If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is 
used to remove a Key or Breakdown marker.
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Creating Custom Markers
If your production requires you to mark drawings with a custom marker, you also have the option to create your 
own.

Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a bit of code. 
Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing toolbars, but also in the 
Onion Skin and Flip toolbars.

NOTE: You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to create custom markers

 1. With a bitmap editing software, create the following icons in PNG format:

 l Mark Drawing Toolbar icon (24 x 24 pixel)

 l Onion Skin Toolbar icon (24 x 24 pixel)

 l Flip Toolbar icon (24 x 24 pixel)

 l Xsheet Column icon (16 x 16 pixel)

 2. Close Harmony.

 3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder. 

 l Windows:

 l Toon Boom Harmony Premium: C:\Users\[user_name]\Ap-
pData\Roaming\Toon Boom Animation\Toon Boom Harmony\full-1200-
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pref\drawingTypes.d

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\Ap-
pData\Roaming\Toon Boom Animation\Toon Boom StageAdvanced\full-1200-
pref\drawingTypes.d

 l Mac OS X: 

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down 
the Alt key.

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Harmony/full-1200-pref/drawingTypes.d

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Stage Advanced/full-1200-pref/drawingTypes.d

 l Linux: 

 l /home/user_name/Toon Boom Animation/Toon Boom Harmony/full-1200-pre-
f/drawingTypes.d

 l /home/user_name/Toon Boom Animation/Toon Boom StageAdvanced/full-1200-
pref/drawingTypes.d

In Harmony Server, the path is global for all users so you must create the folder and place in /USA_DB.

 l /USA_DB/drawingTypes.d

NOTE: If the drawingTypes.d folder does not exist, you must create it. To do so, copy the 
resources folder from the following location.

 l Windows: Start > Programs > Harmony 14 Premium

 l Mac OS X: Applications > Toon Boom Harmony 14.0Premium > resources > draw-
ingTypes.d

 l Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_64/bin/Stage/re-
sources/drawingTypes.d

 4. Paste your icons in the drawingTypes.d directory.

 5. In the same directory, open the drawingTypes.xml file in a text editor.

 6. For each custom icon you want to create, add the following line. Make sure to place it before this closing tag: 
</DrawingTypes>.

 l <DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png" 
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commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png" onionIcon="OnionIcon.png" 
/>

 7. In that line, replace the following information with your new icon information:

 l NewButtonName: Write the name of your new marker. This name will appear in the button 
tooltip.

 l XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet 
column. Include the file extension.

 l MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark 
Drawing toolbar. Include the file extension.

 l FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar. 
Include the file extension.

 l OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin tool-
bar. Include the file extension.

 8. Save the file and close it.

 9. Start Harmony.

318



Harmony 14 Premium - User Guide

About the Drawing Desk
You can work on a portion of an animation sequence or specific drawings from different layers. To do this, select the 
segment needed in one or more layers in the Xsheet or Timeline view and then use the drawing desk to allow you to 
work only on these drawings. 

This can be useful went you need to reposition drawings, use the Shift and Trace feature, paint multiple drawings at 
once, or apply the same transformation to drawings for different layers—see About Shift and Trace  on page 323.

The Drawing Desk is only available in the Drawing view.
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Adding Drawings to the Drawing Desk
You can send drawings your selected in the Xsheet view to the drawing desk. You can also send new drawings to 
an existing set in the Drawing Desk.

How to send several drawings to the drawing desk

 1. Do one of the following:

 l In the Xsheet or Timeline view, select a consecutive cell range from one or several layers. 

 l In the Xsheet view, hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any cell 
to add it to the selection, even if it is not consecutive.

 2. Do one of the following:

 l In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

 l In the Xsheet view, right-click and select Send Drawings to Desk.

 l In the Xsheet view, hold down the Alt key and click on the selection.

The drawing desk opens on the side of the Drawing view.
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NOTE: The drawing desk is by default on the left side of the Drawing view. You can change its positioning in 
the Preferences dialog box.

 3. If the drawing desk side panel is hidden, click the Arrow button, located on the right side of the view.

How to add more drawings to the drawing desk

 1. In the Timeline or Xsheet view, select the drawings to be added.

 2. Do one of the following:

 l In the Timeline or Xsheet view menu, select Drawings > Add Drawings to Desk 

 l Alt + click the selection.
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Modifying Thumbnails in the Drawing Desk
For your convenience you can modify the way the thumbnails are displayed in the Drawing Desk.

How to clear drawings and send new ones to the drawing desk

 1. Select a new drawing in the Timeline or Xsheet view.

 2. In the Timeline or Xsheet view menu, select Drawings > Send Drawings to Desk.

The previous drawing desk selection is removed and replaced with the current selection.

How to change the size of drawing desk thumbnails

 l Right-click the drawing desk and select No Thumbnail, Small Thumbnail, Medium Thumbnail or Large 
Thumbnail.

How to change the position of a thumbnail in the drawing desk

 1. In the drawing desk, select the thumbnail.

 2. Click the Move Drawing Up  and Moving Drawing Down  buttons as needed, to move it to the new 
position in the drawing desk.

How to clear selected or all drawings from the drawing desk

 1. In the drawing desk, select one or more drawings to remove.

 2. Do one of the following:

 l Right-click the drawing desk and select Remove Selected Drawings or Remove All Draw-
ings.

 l In the Drawing view, press Esc to remove all drawings.
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About Shift and Trace 
When hand drawing animation, it is very important to stay on model as it is easy to lose the proportions or features of 
a character. The Shift and Trace feature lets you temporarily move a drawing so you can trace it on a new drawing. 
This is similar to animators working on an animation light table and using an entire character or cut-out pieces of a 
character and moving it underneath the new drawing to trace it.

Your drawings will not be modified. It will only be moved, rotated or scaled in the Shift and Trace mode. When you 
turn off this mode, the repositioned drawing returns to its normal state.

If you use the Shift and Trace feature frequently, you can assign custom shortcuts for Shift and Trace operations in 
the Preferences dialog box—see  the Preferences guide.
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Enabling Shift and Trace
You need to send drawings to the Drawing Desk and enable the Shift and Trace option to be able to use it—see 
About the Drawing Desk on page 319. 

How to enable the Shift and Trace mode

 1. Go to the Drawing view.

 2. In the Tools toolbar, click the Show Onion Skin  button—see Paperless Animation Tools.

 3. Send the selected drawings to the drawing desk—see About the Drawing Desk on page 319.

 4. In the Drawing Desk toolbar, click the Shift and Trace Enable  button.

Registration marks appear at the bottom of your drawings. 
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Shifting Drawings
Once the Shift and Trace option is enabled, you can use the controls to shift the drawings. This does not modify your 
original drawings. 

How to shift

Using the shift and trace manipulator, you can move the registration marks to reposition selected drawings while you 
work.

 1. In the Drawing Desk toolbar, click the Shift and Trace Manipulator  button.

At the bottom of the Drawing view, a window displays a zoomed in view of the manipulator. You can move 
the dividing line between the manipulator and the Drawing view to resize the area.

 2. In the Drawing view, transform the drawing as needed, positioning it between your two key poses.

 l To reposition, click and drag the drawing to a new area.

 l To rotate from the centre peg, click the flat peg hole and rotate.
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 l To scale, pull or push on the triangle control.

 l To show the pivot point, hold Alt. The pivot point is in the middle of your current drawing 
view. To rotate from the pivot point, hold Alt and rotate.
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 l To scale from the pivot point, hold Shift and move your cursor.

 l Click and drag the pivot point to move it to a new position. Once the pivot point is moved, you 
can hold Alt and move your drawing to show it again.

 3. To select another drawing and reposition it, hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X).
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 4. If necessary, click the Shift and Trace Reset  button to reset the position of the modified drawing.
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Tracing Drawings
You can trace your new drawings once you shifted the reference artwork. 

How to trace

 1. In the drawing desk, select the drawing into which you want to trace.

 2. Select the check box next to the drawing you want to allow to be temporarily transformed. By default, all draw-
ings are enabled for Shift and Trace operations.

 3. Select the drawing you want to move.

 4. If you want to trace more than one drawing at the same time, you can link them together. In the drawing desk, 
select several drawings and click the Link Drawings  button to lock their position together—see Tracing 
Drawings.

 5. In the Tools toolbar, select a drawing tool.

 6. In the Drawing view, trace your drawing.
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Linking Drawings in the Drawing Desk
When using the Shift and Trace feature, you can link different drawings from the drawing desk, so they move 
together when dragging or scaling. These drawings can be from different columns in the Xsheet view.

How to link your shift and trace drawings

 1. In the drawing desk, display the drawings you want to use for the Shift and Trace operation.

 2. Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and select the drawings you want to link together.

 3. In the Drawing Desk toolbar, click the Link Drawings button to enable linking.

Coloured boxes appear beside drawing thumbnails to identify different linked drawing groups.

A link icon appears beside the currently selected drawing and all drawings linked to it.

 4. Shift your linked drawings.

 5. To unlink your drawings, select one of the linked drawings and click the Link Drawing button again to 
disable it.

 6. You can shift your drawings independently.
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 7. To unlink your drawings, select one of the linked drawings and click the Link Drawing button again to dis-
able it.
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Enabling the Drawing Desk Onion Skin 
You may end up with a lot of drawings in your onion skin display while working with the Shift and Trace feature. 
You can disable individual drawings from the onion skin display without deactivating them.

How to enable and disable individual onion skin drawings

 1. In the Tools toolbar, click the Onion Skin  button.

 2. In the Drawing Desk, click on the drawing’s Onion Skin  button to enable or disable it. When enabled, 
the icon's  colour changes .
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About Art Layers
T-RIG-005-000

Art layers give you the possibility to divide the artwork in your drawing on different layers. For example, you can 
separate the outline and colour fill on two art layers, similar to 1950s traditional cell animation. These art layers are 
contained within a single drawing as opposed to the layers in the Timeline view or Xsheet columns where individual 
drawings with individual timing are stacked one on top of the other—see About Art Layers on page 333.

Toon Boom Harmony drawings include four art layers. 

 l Overlay on page 333

 l Line Art on page 334

 l Colour Art on page 334

 l Underlay on page 335

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour Art are 
displayed. You need to enable the Support Overlay and Underlay Arts option in the Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and facilitate 
creation and revision.

Overlay

The Overlay layer can serve multiple purposes:
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 l Highlights and tones

 l Annotations and corrections

 l Sketching

You can also draw in the Overlay layer as it's a regular layer.

Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The outline is drawn in 
the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn in the Line Art 
layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are generated from Line Art to contain 
the painted area.
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When you are doing rough animation, you may want to send a clip for feedback or approval before carrying on with 
your work. If you have several characters in your project that are overlapping, it may be difficult to understand what 
is going on as you can see through the characters. Toon Boom Harmony can generate a matte automatically in the 
Underlay, or even in the Colour Art layer, and fill all the zones inside your characters to make them opaque. This 
process is fast and easy, and allows you to send easy-to-understand movies.

Underlay

The Underlay layer can serve multiple purposes. It is frequently used by animators to sketch rough animation or 
generate a matte colour when doing line testing.

Separated Lines and Colours

A  drawing is composed of line and colour filling layers. Lines and colours can be separated or kept together, 
depending on which animation process you use. The following diagram presents Line Art and Colour Art layers 
recommendations based on the selected animation workflow.
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When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the Line Art when 
drawings are vectorized unless you specified otherwise.

When working with Cut-out animation, we recommend that you do all of the work in the Line Art. 

Once the drawing sequence is completed for paperless drawings, you can proceed with creating Colour Art 
strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from Line Art option to 
create strokes from your lines.

You can create strokes in the Colour Art during the following stages:

 l After the full drawing is completed in Line Art

 l While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to patch gaps. 
Use the Auto-Create Colour Art from Brush option to create the strokes at the same time as the lines are drawn. 
This creates strokes from the lines and brush strokes created in the Line Art while you draw and is useful for fixing 
drawings. However, if you are drawing a new sketch, it is better to create the strokes afterward using the Create 
Colour Art from Line Art option.

NOTE: Make sure to select the Advanced Art Mode in the Preferences dialog box to use this feature.
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Enabling the Overlay and Underlay Support 
By default, the Overlay and Underlay art layers are disabled to simplyify the workflow. You can enable the support of 
those additional art layers in the Preferences panel.

How to enable the Support Overlay and Underlay Arts option

 1. Select Edit > Preferences ( Windows/Linux ) or Harmony Premium > Preferences ( Mac OS X ).

 2. In the Preferences dialog box, select the Advanced tab.

 3. In the Advanced Options section, select the Support Overlay and Underlay Arts option.

 4. Click OK.
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Switching between Art Layers 
T-RIG-005-000A

You can use the Art Layers toolbar and keyboard shortcuts to switch between art layers.

How to switch between drawing layers

 1. In the  Art Layer toolbar, click the Line Art   or Colour Art    buttons. When switching art layers, you 
can edit the select layer without affecting the other one.

 2. Click the Preview All Enabled Art Layers   button to display all layers together. Even when the Preview 
mode is enabled, you will only be able to edit the select art layer. The other ones are only displayed as a ref-
erence. By default, the Preview mode is always enabled in the Camera view. You will only be able to see 
the selected art layer by itself if you enable the Current Drawing on Top  option located in the Camera 
bottom toolbar.

NOTE: To edit both Line Art and Colour Art at the same time, you must enable the Apply to 
Line Art and Colour Art  button in the Tool Properties of the tools supporting the operation.

How to switch between the drawing layers in Advanced Art mode

 1. In the  Art Layer toolbar, click the Overlay Art , Line Art , Colour Art  or Underlay Art  buttons to 
display the appropriate layer—see How to enable the Support Overlay and Underlay Arts option on page 
337. When switching art layers, you can edit the selected layer without affecting the other one.

 2. Click the Preview All Enabled Art Layers  button to display all the layers together. The other ones are 
only displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You 
can view only the selected art layer if you select the Current Drawing on Top  option in the Camera bot-
tom toolbar.
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Creating Colour Art from Line Art 
T-RIG-005-000B

Lets you use the outline you traced on one of the four embedded layers (line art, colour art, overlay, underlay) and 
create invisible strokes to paint your drawings on separate layers. This provides more inking and painting flexibility. 

You can also configure this option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones from the Line Art layer

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Tool Properties view, click the Permanent Selection  button if you want to apply the operation on all 
drawings in the layer.

 3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection around the 
entire animation sequence if you want to apply the operation to all your drawings.

 4. In the Drawing View toolbar, click the Create Colour Art from Line Art  button or press *.

How to create strokes with the  Create Colour Art Automatically option

 1. In the Tools toolbar, select the Brush tool. 

 2. In the Tool Properties view, enable the  Create Colour Art Automatically  option.

 3. Draw the required lines. 

 4. Once you're done, deselect the  Create Colour Art Automatically  option. 

You are now ready to paint.

How to configure the Create Colour Art from Line Art option

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Tool Properties view or the Drawing View toolbar, Shift + click the Create Colour Art from Line Art  
button.

The Configure Line Art to Colour Art dialog box opens.
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Parameter Description

Use rendered version of the 
drawing

Renders the drawing and vectorize it to calculate the position of the centreline 
that will produce the colour art stroke.

Maximum Resolution for 
rendered image

The size of the rendered image.

Threshold for rendered image The value of grey processed to create the rendered vectorized arts.

Fitting error for rendered Bez-
iers

This value represents how precise the fitting of the colour art zone in relation to 
the line art will be.

Source layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want 
the colour art to be created from.

Destination layer
Lets you select the layer (Line Art, Colour Art, Underlay or Overlay) you want 
the colour art to be created on.

Clear Destination Art Layer 
First

Deletes the content before the colour art is added. This is useful when you 
already have artwork on the destination layer.

Perform Line Art to Colour Art 
Operation Immediately

Performs the Create Colour Art from Line Art command when you click OK.
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Generating a Matte
You can quickly generate a matte to be displayed behind your rough animation so you don't see the background 
through the drawings. It can be generated in any art layer.

How to generate a matte

 1. Do one of the following:

 l In the Tools toolbar, select the Select  tool.

 l Press Alt + S.

 2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

NOTE: You can also apply the operation to all the drawings in the layer at the same time.

 3. Do one of the following:

 l From the top menu, select Drawing > Generate Auto-Matte. 

 l In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

 4. If you want to create a matte for all the drawings included in your layer, select the Apply to All Drawings 
option.

 5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower value, the 
closer to your lines’ contours the matte will be shaped. The higher the value, the looser the matte will be 
shaped.
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 6. In the Source Art menu, select the layer from which you want the matte created: Line Art,Colour Art, 
Underlay or Overlay.

 7. In the Destination Art menu, select the layer on which you want the matte to be created: Line Art,Colour 
Art, Underlay or Overlay.

 8. If you already have artwork on the destination layer and you want the content to be deleted before the 
matte is added into it, select the Clear Destination Art First option.

 9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you ever 
need to keep them for later), select the Copy Stroke in Destination option.

 10. Click OK.
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Previewing Drawings
It is a good idea to preview your drawings to check your animation ink and paint, verify that there are no colour 
mistakes, or to play your animation in real time. You can do this by scrolling through your drawings or pressing F and 
G. You can also use the Preview option in the Xsheet view.

How to preview drawings from the Xsheet view

 1. Save your scene. 

 2. Do one of the following:

 l From the top menu, select File > Save.

 l Click the Save  button.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. In the Xsheet view, select the range of drawings or the whole column to preview.

 4. In the Xsheet view menu, select View > Preview Selected Drawings.

Toon Boom Play opens.

 5. In the Play window, press the Play  button to play back your drawings.

 6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence while loop-
ing the playback.
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Chapter 6: Timing
When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how to set 
and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure sheet 
created by the animator. In a paperless workflow, the animator creates and manages their own exposure sheet 
directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital animator, 
you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn 
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using. 
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many of 
the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show both 
techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths 
for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and 
parts, but is not really needed for animation and timing. If you plan to work with cut-out animation, you can still 
learn useful tips by reviewing the section on exposure sheets.
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About Scene Length
The length of your scene is dependent on how many drawings you need to expose and for how long. A drawing 
can be a held for several frames to make the action appear slower or for just a few frames to make the action 
appear faster. When setting the timing for an animation, a lot of adding and removing of frames occur to get the 
timing just right. This invariably changes the scene length.

Adding and removing frames can be done in the Timeline, Xsheet or though the Scene menu.
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Setting Scene Lengths
T-HFND-007-007

You can set the scene length by adding the right number of frames to your scene. You can set the global scene 
length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.

347



Chapter 6: Timing     About Scene Length

Modifying the Visible Scene Length
In the Timeline view, you can choose to extend or reduce the limit for visible frames.

When you reduce the scene length, the hidden drawings and symbols are not deleted. They're still available if you 
extend the scene again.

How to modify the scene length in the Timeline view

 1. In the Timeline view, drag the scene length bracket:

 l Right: To add more frames to your scene.

 l Left: To reduce the number of frames in your scene.
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Adding Frames to the Middle of a Scene
As you're setting the timing for drawings, you may realize that you need to add extra frames. It is possible to add 
new frames either before or after any frame in your scene.

How to add frames to the middle of a scene

You can add frames anywhere in the middle of the scene—before or after a selection. If you select a frame row in the 
Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

 1. Do one of the following: 

 l In the Timeline view, select the frame to which you want to add frames before or after.

 l In the Xsheet view, select a frame row. 

 l In the Timeline view, select the frame to which you want to add frames before or after.

 2. Do one of the following:

 l From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames 
After Selection. 

 l In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.

 l In the Xsheet toolbar, click the Add Frames  button to add frame after your selection.

 l Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘  + G and  Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

 3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 4. Click OK.
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Adding Frames to the Start or End of a Scene
As you're setting the timing for drawings, it is possible to add new frames either the start or end of the scene.

How to add frames at the start or end of a scene

 1. In the top menu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

 2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 3. Click OK.
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Removing Frames
As you're setting the timing for drawings, it is possible to remove a frame or range of frames.

How to remove a frame or a range of frames  in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

 1. In the Xsheet view, do one of the following:

 l Select a frame in a given column.

 l Select a frame range by clicking the first frame’s number and then dragging the selection 
highlight down to the last frame to delete.

 

 2. To delete the selected frames, do one of the following: 

 l From the top menu, select Scene > Frame > Remove Selected Frames. 

 l Press Delete to delete the selection. 

 l Click the Remove Frames  button. To remove several frame selections, click the button 
repeatedly.

If you selected a range of frames, the Warning dialog box may open.

 3. To complete the operation:
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 l Click Yes to delete the selection.

 l Click No to delete only the exposure in the cell and not the frames.

 l Select the Don’t Show This Message Again option to prevent the warning message from 
being displayed each time you delete a frame range.
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About Layers and Columns
T-RIG-009-003

Before filling in any values or setting any timing or exposure, you need to create drawing elements. Each drawing 
element is represented as a vertical column in the Xsheet view and a horizontal layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will be applied 
to both. You can also see your layers displayed in the Node view as nodes.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named the 
same way as the drawing element and is in fact, linked to the drawing element. Its purpose is to contain all the 
drawings related to this element (layer, column). For example, in cut-out animation, a character can have many 
heads available. All of the head drawings will be contained in this folder, even if they are not exposed in the 
Timeline or the Xsheet view.

Drawings are exposed in cells/frames and linked to the drawings saved in the layer's directory. When you remove 
a drawing from a cell/frame, it is not displayed, but still exists in the directory.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all exposures of drawing “1” are updated 
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the 
drawing.

NOTE: There are different element types available, such as sound and expression. A sound element con-
tains sound files. Expressions, Beziers, eases, 3D path, Quadmaps and Pegs are for motion purposes dur-
ing the compositing step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu. 

NOTE: To learn more about the layer parameters, see the Reference guide .
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Layer and Column Types
A column is also known as a layer. There are several types of layers you can add in the Timeline and Xsheet view. 
Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in the 
Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. 

 

Any time you need to create a vector drawing or import a symbol or image, you can use a drawing layer. You can 
also create bitmap artwork on a drawing layer.

NOTE: Bitmap images are contained in bitmap layers.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you choose to 
vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a bitmap 
into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when you 
create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your 
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in 
your timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.
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In Harmony, there is a series of effect nodes in the Node Library view.

When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the 
Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no 
background colour and if you render it as a QuickTime movie or image sequence, it will have a black background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize both the Timeline and Node views. 

You can drag and drop other layers onto a Group layer and then collapse the Group layer to hide these other layers 
from view. 

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing 
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  Functions 
section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This 
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the 
deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the 
Functions section of the Xsheet view.
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Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your 
Timeline and Xsheet view when you import a sound file in your scene.

In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you 
create these columns, they are not linked automatically to any particular drawing layer. You can create a motion path 
using these columns and then link or unlink several drawing or peg layers to it. 

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression 

• Annotation
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Adding Layers and Columns
T-HFND-005-002

There are different ways to add a drawing elements (layers and columns) to your project. By default, when you 
create a new scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the 
Timeline view.

When you add an element, it will appear as a column in the Xsheet view or as,  a layer in the Timeline view, and a 
node in the Node view. 

NOTE: To learn more about the layer parameters, see the Reference guide .
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Adding Layers in the Timeline View
Drawing elements are more commonly known as layers in the Timeline view. Create them using the following 
procedure:

How to add a drawing element from the Timeline view

 1. In the Timeline view, click the Add Drawing Layer  button or press Ctrl + R (Windows/Linux) or ⌘  + R 
(Mac OS X).

The Add Drawing Layer window opens.

 2. In the Name field, name your new layer.

 2. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap layer.

 3. Do one of the following: 

 l Click Add to add a first layer and keep the window open to add more layers. 

 l Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.
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Adding Layers from the Top Menu
Another way to add layers to the Timeline view is through the top menu.

How to add a drawing element from the top menu

 1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

 2. In the Name field, type a relevant element name and click  OK.

The new drawing element appears in your scene.
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Adding Columns from the Xsheet View
Drawing elements in the Xsheet view are more commonly known as columns. You can add columns using the 
following procedure:

How to add a drawing element from the Xsheet view

 1. Do one of the following:

 l In the Xsheet menu, select Columns > Add Columns. 

 l Click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a relevant element name.

 3. In the Type field, select Drawing. 

 4. To complete the operation:

 l Click Add and Close to add your new layers and close the dialog box.

 l Click Add to add your new layers and keep the dialog box open to add column.

 l Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column Types on 
page 355.
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Using the Advanced Add Column Dialog Box

How to create a column using the advanced Add Column dialog box

You can use the advanced Add Column dialog box to make more file format and field size options available when 
you insert a column.

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(Mac OS X) and select the Advanced tab.

 2. In the Advanced Options section, select the Advanced Element Mode option to access the advanced 
Add Column dialog box.

 3. Click OK.

 4. In the Xsheet menu, select Columns > Add Column or press Shift + C.

The Add Column dialog box opens.

 5. In the Name field, type the new column’s name.
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 6. In the Type menu, select the Drawing type.

 7. In the Element section, select one of the following:

 l Create New Element: Creates an independent column with its own drawing folder.

 l Reuse Existing Folder: Links your column to an existing folder within the Element folder of 
your scene. If you select this option, in the Folder menu, select the folder to which you want to 
link your new column.

 l Use Existing Element: Uses drawings from an existing column in the new column. Both 
columns will be attached to the same set of drawings, but their timing will remain  independent  
from one another. If you modify one of the drawings, it will be modified in both columns. This is 
the same principle as the Clone column.

In the Name menu, select the column to which you want to link your new column.

 8. If you selected the Create New Element option:

 l Deselect the Vector option if you want your layer to contain bitmap images or enable it if you 
want the layer to contain vector drawings. Most of the time, the Vector option will be enabled.

 l If you deselected the Vector option, from the Bitmap Format  list, select which type of bitmap 
image you want to insert in the column. Select the SCAN type if you are planning to scan draw-
ings using the Toon Boom Harmony Scan module.

 l If you deselected the Vector option and you chose the SCAN type, from the Scan Type menu, 
select what kind of scanning you want to achieve.

 l In the Field Chart field, when importing traditional animation, indicate the size of paper on 
which the animation or background was drawn. If you are not using perforated animation paper, 
leave the 12 field default value as is.

 9. Do one of the following: 

 l Click OK to create the new column and close the dialog box. 

 l Click Apply to create the new column but keep the dialog box opened to create other new 
columns.
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Deleting Layers and Columns
T-HFND-005-004

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

 2. Do one of the following:

 l In the Timeline’s Layer toolbar, click the Delete Layers  button. 

 l Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

 1. In the Xsheet view, select the columns to be deleted by clicking on their header.

 2. Do one of the following

 l Right-click on the selection and select Delete Columns. 

 l In the Xsheet toolbar, click the Delete Columns  button.

 l Press Delete.

The Confirm Delete dialog box opens.

 l Select the Delete Drawing Files and Element Folder option if you want to delete the draw-
ings and folders linked to the selected column.

 3. To complete the operation:
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 l Click OK to delete the selected layers.

 l Click Cancel to cancel the operation.

The Warning dialog box may open.

 4. Do one of the following:

 l Click Yes to delete all the frames from your scene.

 l Click No to keep the frames in your scene.

 l Select the Don’t Show This Message Again option if you do not want the dialog box to dis-
play again in the future.
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Renaming Layers and Columns
Once you add layers and columns to your project, you can modify their names.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

 2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

 1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

 2. In the Name field, rename the layer.

 3. Click Close.

How to rename a column

 1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that the 
column is linked to (this also appears in the column header just below the column name).

The Drawing dialog box opens.
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 2. In the Name field, rename the column.

 3. Click OK.

367



Chapter 6: Timing     About Layers and Columns

About Layer and Column Display
You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline 
view or a column in the Xsheet view displays. You can stay organized without changing the content of elements 
or your animation output.
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Expanding and Collapsing Layers and Columns
To simplify the look of the Timeline or Xsheet view, you can expand and collapse some of the layers and columns. If 
layers are parented to other ones, you can collapse the parent layer to hide its children.   

How to collapse or expand selected layers in the Timeline view

 1. In the Timeline view, select the layer(s) to collapse or expand.

 2. Do one of the following:

 l Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

 l Click the Expand Children Arrow  button on the parent layer.

 l Click the Collapse/Expand  button  (you may have to customize the toolbar to display it).

 l Press  Ctrl + I (Windows/Linux) or ⌘  + I (Mac OS X).

How to collapse or expand all layers in the Timeline view

 1. Do one of the following:

 l Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

 l In the Timeline toolbar, click the Collapse All  or Expand All  buttons (you may have to 
customize the toolbar to display them).

 l Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button to display the Functions list.

 2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

 3. Do one of the following:

 l Right-click on the column’s header and select Expand/Collapse > Collapse Selection or 
Expand Selection.

 l In the Xsheet toolbar, click the Collapse Selection  or Expand Selection  buttons (you 
may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:
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 l Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

 l Press 0 and 9.

 l In the Xsheet toolbar, click the Collapse All  or Expand All  buttons  (you may have to customize the 
toolbar to display it).
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Showing and Hiding Layers and Columns
As you work in the Drawing, Camera or Xsheet view, some layers or columns may be in the way, such as those that 
were used as references. You can hide these layers to make your work area less cluttered and easier to navigate.
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Showing and Hiding Layers
T-HFND-005-010

You can show and hide layers in the Timeline view in several different ways.

When using the Solo mode to show or hide layers, here's how it works:

 l If you have anything selected, it is not affected.

 l When multiple layers are selected and you enable/disable the Solo mode on any of those layers, it is 
applied to all the selected layers. 

 l When multiple layers are selected and you enable/disable the Solo mode on layers that are not part of the 
selection, it is applied only to those particular layers. 

When exporting or rendering a scene, the Solo mode setting of layers is ignored. 

NOTE: When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it 
unless the mask is also enabled.

How to show or hide all layers

 1. Click one of the following in the Layers toolbar: 

 l Enable/Disable All  button to show or hide all layers. 

Any hidden layers are unhidden, so you can view all layers.

 l Solo Mode  button to view disable your current Solo mode selection. Any soloed drawing 
or sound layers are disabled, so you can view all layers. When you click again on the Solo 
Mode button, you last Solo selection is displayed.

How to show or hide individual layers

 1. Do one of the following:

 l In the Layer toolbar, click the Solo Mode  button.

 l Click the layer's Enable/Disable All  button to show or hide that layer. 

 

 l Press A to show a layer or D to hide selected layers.
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 l In the Timeline toolbar, click the Enable/Disable  button (you may have to customize the 
toolbar to display it).

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

 1. Do one of the following:

 l Hold down Alt and click the Solo Mode  button of the layer you want to solo and hide all 
other layers.

 l In the Timeline toolbar, click the Disable All Others  button (you may have to customize the 
toolbar to display it).

How to show and hide layer types in the Timeline view

 1. From the Timeline menu, select View > Show > Show Manager.

The Show Manager dialog box opens.

 2. Select the types of layers you want to display and deselect the ones you want to turn off.

 3. Click Set As Default to make these new settings the default ones that will be used each time to start the 
application. Click Restore Default to restore the settings used when installing the application.

In the Xsheet view, you have the choice of hiding or showing certain types of columns such as Annotation 
and Functions.

In the Timeline view, you can hide or show certain types of layers such as Group and Effect. 
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Showing and Hiding Columns
The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can 
be used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without 
using the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is 
disabled in the Timeline view.

How to show and hide columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button.

 2. On the right side of the Functions section, click the Expand  button to display the Column List section.

 3. Do one of the following:

 l In the Column List section, select the columns to display and deselect the columns to hide. 

 l In the Xsheet toolbar, click the Hide Selected Column  button (you may have to cus-
tomize the toolbar to display it).
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Showing Hidden Columns
In order to save visual space in the Xsheet view, columns can be hidden from view. The hidden layer's presence is 
indicated by a thicker grey line between columns.

How to show hidden columns in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Click the thick grey line that represents a hidden column. 

 l Right-click on the column header and select Show Hidden Columns.

 l Press Alt + Shift + H.

The Show Hidden Columns dialog box opens.

 2. In the Show column, select the hidden columns you want to display in the Xsheet view.

 l Click Check to select all the selected columns.

 l Click Uncheck to deselect all selected columns.
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Showing All Columns
In order to save visual space in the Xsheet view, columns can be hidden from view. You can bring all the hidden 
columns back into view all at once.

How to show all columns

 l In the Xsheet menu, select View > Unhide All Columns.
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Showing and Hiding Column Types
You can hide specific column types from view, in order to work more easily with one aspect of your project. For 
example, you could hide all the Drawing columns in the Xsheet, so that you could work more easily with your 3D 
Path Columns. 

How to show and hide column types using the Column List

 1. In the Column List section, click the button corresponding to the column type you want to show or hide.

Column Type Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns

How to show and hide column types using the Column Types Manager

 1. In the Xsheet view, select View > Column Types Manager.

The Column Types dialog box opens.

 2. Select the types of columns you want to display and disable the ones you want to hide.

Click Set As Default if you want to make these new settings the default ones used each time you start Harmony.

Click Restore Default if you want to return the settings to their defaults.
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Showing and Hiding Function Columns
Function columns (columns that house translation, rotation, scale, etc. information) that are associated with 
another column type, for example a Drawing column, are often hidden from view. You can bring these columns 
into the forefront, in order to work with them or view their information. 

How to show or hide function columns on the left side of the Xsheet view

 1. Right-click on a column and select Tag > Function Columns Visible or Function Columns Invisible.
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Customizing the Column Appearance
In Harmony, you can customize the way the column displays drawings, empty cells and the column width.

You can modify the following elements:

 l Empty cells

 l Row units

 l Held exposure

 l Column width

How to change the appearance of an empty cell

 1. From the Xsheet menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units

 1. From the Xsheet menu, select View > Row Units > Frames or Feet.

How to modify the look of a held exposure

 1. In the Xsheet menu, select View > Held Exposures > Line or Value.
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How to modify column width

 1. In the Xsheet view, select a column.

 2. From the Xsheet menu, select View > Set Columns Width.

The Xsheet Column Width dialog box opens.

 3. In the Column Width field, enter the desired width in pixels.

 4. Do one of the following:

 l Click OK to validate and close the dialog box.

 l Click  Apply to validate the operation and keep the dialog box opened to adjust the next 
column’s width.

 l Click  Set As Default to create all the new columns to this width.

 l Click  Close to cancel the operation.

 5. To restore all columns to the default value, in the Xsheet menu, select  View > All Columns to Default 
Width.
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Displaying Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular column. 
Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of the current 
frame below the column header.

How to display the thumbnails

 1. Do one of the following:

 l In the Xsheet toolbar, click the Show Thumbnails  button.

 l In the Xsheet menu, select View > Show Thumbnails. 

The thumbnails appear.
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Changing Layer and Column Colours
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. The 
colours you choose will be reflected in the Node view.

How to change the layer’s colour in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

 2. In the Select Colour dialog box, select a new colour for your layer.

 3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected 
colour for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

 1. In the Timeline view, select the layers to reset.

 2. In the Timeline toolbar, click the Default Track Colour  button (you may have to customize the toolbar 
to display it).

How to change a column’s colour in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

 3. In the Select Colour dialog box, select a new colour for your columns.
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 4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

 1. In the Xsheet view, select the columns to reset.

 2. Right-click on the column’s header and select Colour > Default Columns Colour.
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About Scene Markers
Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can 
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in 
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is 
displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and 
mark the whole section.
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Creating Scene Markers on Current Frames
Change the colour of the area above a frame by setting a scene marker. This will allow you to find the frame more 
rapidly when quickly scanning the Timeline.

How to mark the current frame

 1. In the Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you right-click 
on a different frame, the scene marker will be created on the current frame on which the playhead is posi-
tioned.

 2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the colour of 
the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. Click 
OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when you hover 
your mouse over the scene marker.
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In the Timeline view, the scene marker is displayed at the current frame. 

 5. Hover over the scene marker to display its tooltip.
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Creating Scene Markers on Frame Ranges
Change the colour of the area above a frame range by setting a scene marker. This will allow you to find the range 
more rapidly when quickly scanning the Timeline.

How to create a scene marker on a frame range

 1. In the frame counter area, select the frame range you want to mark.

 2. Right-click and select Create Scene Marker.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the colour of 
the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. Click 
OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when you hover 
your mouse over the scene marker.

In the Timeline view, the scene marker is displayed over the selected frame counters. 

 5. Hover over the scene marker to display its tooltip.
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Editing Scene Markers
You can modify the colour of a scene marker or edit the note attached to it.

How to edit a scene marker

 1. In the frame counter area, select the entire scene marker.

NOTE: It's important to select the entire length of the scene marker, otherwise the Timeline Scene Marker 
dialog box will not open for editing.

 

 2. Right-click and select Scene Markers > Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

 3. Make your changes.

 4. Click OK.
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Deleting Scene Markers
If you deem it no longer necessary to have a frame or a range of frames marked, you can delete the scene marker.

How to delete a scene marker

 1. In the frame counter area, select at least one frame in the scene marker you want to delete.

 2. Right-click and select Scene Markers > Delete Scene Marker.

Setting Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce the FPB 
(Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view lets you pace your animation 
according to the tempo or beat of the soundtrack music or to any rhythmic sound, such as the ticking of a clock or 
water leaking from a spout.

How to set the tempo markers

 1. In the Xsheet menu, select View > Set Tempo Marker.

The Tempo Marker dialog box opens.

 2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.

‣ Starting Frame: Enter the number of the frame where you want the tempo markers to begin.
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‣ Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in which a 
beat marker will appear. Keep in mind that, by default, 24 frames represent 1 second.

‣ Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats) in which 
a tempo marker will appear in the Xsheet view.

 3. Click OK.
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Reordering  Layers and Columns
You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of 
your elements in one view, the other one is updated.

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.

 2. Drag the selection to the new location.

 3. Do one of the following:

 l Drop the selection on an existing layer to make it a child of another element layer.

 l Drop it between the existing layers. Timeline layers that are located above the selection are dis-
played in front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

 1. In the Xsheet view, click on the column’s header with the middle mouse button.

 2. Drag the column to its new position.
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Navigating Layers and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and 
layers. Displays the previous drawing, next drawing, previous layer or next layer. using keyboard shortcuts that 
work in the Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames

• Columns

How to navigate through drawings,and frames and columns

 1. In the Timeline or Xsheet view, select a cell.

 2. Once the cell is selected, you can navigate between:

 l Previous and next layers: From the top menu, select Drawing > Previous Layer and 
Next Layer or press H and J.

 l Previous and next drawings: From the top menu, select Drawing > Previous Drawing 
and Next Drawing or press F and G..
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 l Previous and next frames: From the top menu, select Play > Previous Frame and Next 
Frame or press comma (,) and period (.).
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Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify anything 
you want in the duplicated element without affecting the original one.

How to duplicate an element

 1. In the Timeline or Xsheet view, click the layer or column to duplicate.

 2. Do one of the following: 

 l (Xsheet) Right-click on the column and select Duplicate Selected Columns.

 l (Xsheet) In the Xsheet menu, select Drawings > Duplicate Drawings.

 l (Timeline) Right-click on the layer and select Duplicate Selected Layers.

 l (Timeline) In the Timeline menu, select Layers > Duplicate Selected Layers. 

The new duplicated layer or column appears.
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Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the 
original. For example, if you modify a drawing in the cloned or original column, it is updated in both columns. 

You can choose whether or not to copy the column timing to the cloned columns. 

 l You can modify the column timing independently from each other, but the drawings remain linked.

 l You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from the Node view in the same way.

This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element

 1. In the Timeline or Xsheet view, select the layer or column to clone.

 2. Do one of the following:

 l From the top menu, select Edit > Clone: Drawings Only to clone only the layer or column 
drawings.

 l From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only.

 l From the Xsheet menu, select  Columns: Clone Selected Columns: Drawings Only.

The new cloned layer or column appears.
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About Sync Layers
Use the Sync Layer feature when you need drawings to be separated on different layers, but to have the same 
timing,  such as with the front and back of a shirt collar. The drawing exposures of synced layers not only update 
automatically, but their drawing substitutions correspond as well, as long as the drawings are labeled properly.

When using certain drawing tools, such at the Select, Cutter and Reposition All Drawings tools, you can enable 
the Apply to Synced Drawings option while you work. To learn more about this option—see the Reference .
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Syncing Two Layers
The Sync Layer feature allows for drawings to be separated on different layers, but to have the same timing.

How to sync two layers

 1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

 2. From the right-click menu, select Sync Layers With.

The Convert to Synced Drawing Layer dialog box opens.

 3. From the drop-down list, select a parent drawing layer to sync with the currently selected layer.

 4. Click OK.

In the Timeline view, when you click on either of the two synced layers, the other will display the link icon.

In the Node view, when you click on either of the two synced nodes, the other will display the link icon.
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In the right side of the Timeline view, the child layer will update to the parent layer's timing.

 5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in either of the two lay-
ers.

The other synced layer immediately updates to the same timing.
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Syncing Multiple Layers
You may want to sync more than two layers. However, once a layer is synced,  the Sync Layers menu option 
becomes disabled for that layer. In order to sync a layer to a layer that has already been synced, you need to use the 
Sync Layers command on the yet unsynced layer.

How to sync multiple layers

 1. In the Timeline view, right-click on the drawing layer you would like to sync with an already synced pair.

 2. From the right-click menu, select Sync Layers With.

The Convert to Synced Drawing Layer dialog box opens.

 3. From the drop-down list, select the parent drawing layer you would like to sync with the currently selected 
layer. This should be a drawing layer already synced with another drawing layer. You can select either the par-
ent or the child from that linked pair; they both appear in the drop-down list.

 4. Click OK.

In the Timeline view, when you click on any of the synced layers, the others will display the link icon.

In the Node view, when you click on any of the synced nodes, the others will display the link icon.
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In the right side of the Timeline view, the child layer will update to the parent layer's timing.

 5. In the Timeline or Xsheet view, change the drawing exposure or substitute drawings in any of the synced 
layers.

The other synced layers immediately update to the same timing.
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Creating Synced Layers
Create a new drawing layer to be synced immediately with an existing drawing layer.

How to create a new synced layer

 1. In the Timeline view, right-click on the drawing layer you would like to sync with another layer.

 2. From the right-click menu, select Add Synced Drawing Layer.

The Add Synced Drawing Layer dialog box opens.

 3. In the Add Synced Drawing Layer dialog box, add a single or multiple drawing layers.

 4. When you are finished, click Close.

In the Timeline view, when you click on any of the synced layers, the others will display the link icon.

In the Node view, when you click on any of the synced nodes, the others will display the link icon.

In the right side of the Timeline view, the child layer will update to the parent layer's timing.
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Selecting All Synced Layers
You can select all  the drawing layers that are linked to the selected drawing layer, in the Timeline or Node view.

How to select all synced layers

 1. In the Timeline view, select a layer that is synced to at least one or more layer or in the Node view, select a 
node that is synced to one or more node.

 2. In the view menu , select Edit > Select Synced Layers.

In the Timeline view, all the layers synced to the selected layer become highlighted.

In the Node view, all the nodes synced to the selected layer become highlighted.
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Unsyncing Layers
Once layers have been synced, they can just as easily be unsynced.

How to unsync layers

 1. In the Timeline view, right-click on the child layer of a synced pairing.

 2. From the right-click menu, select Unsync Layer.

The parent layer is unsynced and the link icons disappears.

NOTE: If this menu item is disabled, then the selected layer is either the parent layer or a layer that is already 
unsynced.
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About  Annotation Columns
T-ANIMPA-005-001

The annotation columns are useful for marking actions, corrections or other information related to your animation that 
you want to draw or write. This way, you can print your Xsheet, take it back to your animation table and work with 
the annotations.

Before you can draw in the Annotation column, you must first activate the Enable Drawing option to activate the 
Drawing mode. Pen tablet pressure sensitivity is not supported in the annotation column.
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Adding Annotation Columns
T-ANIMPA-005-002

Add annotation columns to mark actions, corrections or other information related to your animation.

How to add an annotation column

 1. Do one of the following: 

 l In the Xsheet menu, select Columns > Add Columns. 

 l In the Xsheet toolbar, click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type in an appropriate name.

 3. From the Type list, select Annotation and click OK.

The new column appears.
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Drawing in Annotation Columns
T-ANIMPA-005-003

In the annotation column, you can draw sketches and ideas that will be useful in producing your animation.

How to draw in the annotation column

 1. Do one of the following:

‣ In the Xsheet menu, select Annotation > Enable Drawing.

‣ In the Annotation column header, click the icon in the upper-right corner to cycle through the icons until the 
Brush  icon is displayed.

The Drawing mode is enabled.

 2. To draw in an Annotation column, simply use your mouse or pen tablet.
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Typing in Annotation Columns
T-ANIMPA-005-004

In the annotation column, you can type in your notes and relevant information that will be useful in producing your 
animation.

Typing in an annotation column is independent from the Drawing mode. You can be in either mode and the typing 
will work. To learn about typing values in the Xsheet view, see Typing Exposures on page 422.

How to type in an annotation column

 1. Do one of the following:

 l In the selected cell, press Ctrl (Windows/Linux) or ⌘  (Mac OS X).

 l In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘  + Shift + click (Mac 
OS X).

 2. In the selected cell, type the desired text.
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Erasing in Annotation Columns
T-ANIMPA-005-005

You can erase part or all of the annotation column’s text and drawn annotations. Annotations that you type in cannot 
be erased using this method.

How to erase part of a drawn annotation using Erasing mode

 1. In the annotation column header, click the icon in the upper-right corner to cycle through the icons until the 
Eraser  icon is displayed.

 2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.

NOTE: When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to 
work.
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Modifying Annotation Column Pen Options
T-ANIMPA-005-006

You can change the pen size and colour when you draw in the annotation column.

How to modify the pen width

 1. In the Xsheet menu, select Annotation > Pen Width and do one of the following:

 l Select a pen width preset.

 l Select  Change Current to display the Pen Width dialog box. In the Pen Width field, type 
the number of pixels for the pen size and click OK.

How to modify the pen colour

 1. In the Xsheet menu, select Annotation > Change Pen Colour.

The Select Colour dialog box opens.

 2. Choose a new colour.

 3. Click OK.
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Showing and Hiding Annotation Column Tick Marks
T-ANIMPA-005-007

When working with the annotation columns, it is useful to display tick marks on odd-numbered frames.

To display the tick marks, you must run a short script.

How to display tick marks

 1. From the top menu, select Windows > Script Editor.

 2. From the Script Editor menu, select File > New Script.

 3. Type in a name for your script and click OK.

 4. In the File list, select the script you created. 

 5. On the right side of the view, type the following script:

function display_tick_marks()

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

 6. Click Verify.

The script is verified. 

 7. From the Script Editor menu, select Play/Debug > Run.

A dialog box opens with your script selected in the Files column.

 8. In the Functions column, select display_tick_marks and click OK.
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Tick marks appear on odd frames in the Annotation column. If you do not see tick marks, close and restart 
Harmony.

How to turn off the display of tick marks

 1. Follow steps 1 to 5 of How to display tick marks and use the following script:

{

preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);

MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER", false));

}

 2. Follow steps 6 to 8. 

All tick marks are removed from the Annotation column.
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Importing Annotation Files
T-ANIMPA-005-008

If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or drawings in the 
Annotation columns, you can easily import them.

How to import annotation files

 1. In the Xsheet view, select the first cell in the Annotation column where you want the imported image to start.

 2. Do one of the following:

 l Right-click on the cell and select Annotation > Import File.

 l From the Xsheet menu, select Annotation > Import File. 

 3. Browse for the bitmap image to import.

 4. Click Open.

The image appears in the Annotation column.
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Using Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to bring images 
into the project. For example, you may have background scenes created in a third party software that you might 
need to update in the future. By using Timing columns, you can dynamically link your backgrounds, expose 
different backgrounds at different times, and have live, automatic updating capabilities.

IMPORTANT: If the project file is moved, or if the folder that the column is linked to is moved, then dynamic 
linking is broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column

 1. In the Xsheet view, click the Add Columns  button.

 2. In the Add Column dialog box, type in the name of the new column, then from the Type menu, select Tim-
ing.

 3. Do one of the following:

 l Click OK if you are finished.

 l Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header, <unused>.

 4. In the Node view, add a new node.

 5. Open the Layer Properties editor by clicking the yellow square of the node.

 6. In the Drawing tab, select the Timing Columns option.

 7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to locate a 
folder, you must select a file in the folder you want and then delete the dash and the suffix (for example, 
background-01 should be renamed to background) from the file name in the field. If you leave the full 
file name selected, Harmony will display that file for the entire duration of the scene, regardless of the con-
tents of the Timing Column field.
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NOTE: This means that all the images in the folder that you are linking to are named using the naming con-
vention described above. If for some reason you are unable to access a certain directory, type the directory 
extension directly in the path extension field at the top of the browser window.

 8. In the Timing Column field, click the Arrow button to create a new timing column, or select the name of the 
column from the  list. If you have an element directory selected in the Name field, the Timing Column will indic-
ate which files are called from that element directory. Remember that the file displayed at each frame is 
based on the element name, cell label, and extension. If the element is toto, the timing column is labeled 1, 
2, and 3, and the extension is TVG, Harmony will display drawings totobody-1.tvg, totobody-2.tvg, 
and totobody-3.tvg at the selected frames. 

In the Xsheet, the <unused> header  changes to the name of the node in the Node view.

 9. From the Extension  list, select the file format of the files you want to display.

 10. Click OK.

 11. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the drawing file 
that you want to expose to make it appear in the Camera view.
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Using the Element Manager
The Element Manager window lets you Opens the Element Manager window where you can add, delete or modify 
elements (drawing folders) in your scene. If you have drawing folders that are not linked to a column in your 
scene, use the Element Manager to delete them if needed. See xref Reference > Windows > Element Manager.

How to use the Element Manager

 l From the top menu, select Scene > Element Manager.—see the Reference guide .
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Displaying Layer and Column Properties
Each element has its own set of properties that you can modify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline view 
or selected node in the Node view. If you're working with the Xsheet, you can display its properties as well. You can 
display a layer's properties as a window or as a view of its own.

The Layer Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

 l Lock the layer

 l Change the track colour

 l Activate the onion skin preview

 l Adjust the positioning and animation parameters

 l Adjust many other advanced parameters

The Column Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

How to display a layer's properties

 1. Do one of the following:
 l In the Layer Properties view is not part of your workspace, from the top menu, select Windows > 

Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

 l In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .
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How to display a column's properties in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Double-click on a column header.

 l Right-click on a column header and select Column Editor.

The properties for the column are displayed.
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 2. (Optional) To view additional properties, select Edit > Preferences from the top menu. 

 3. In the Preferences dialog box, select the Advanced tab, then select the Advanced Element Mode option.

 4. In the Xsheet view, double-click on a column header.

Additional properties for the column are displayed.
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About Exposures
Harmony provides different ways to fill in exposures and values, create cycles, and set increments.
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Inserting and Overwriting Exposures

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes control 
the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites 
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over 
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down the 
column.

How to switch between the Overwrite and Insert modes

 1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.
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Typing Exposures
T-HFND-006-007

To fill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section of 
the Timeline.

NOTE: You can only use alphanumeric values (0 to 9, a to z) and the underscore (_) and dash (-).

How to type a value in the Timeline view

 1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing you want to 
create.

 2. Press Enter/Return to validate the value.

How to type a value in the Xsheet view

 1. In an Xsheet column, double-click on a cell.

 2. Type a value or drawing name in the cell.
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 3. Press Enter/Return to move to the next cell.

 4. Press Esc to exit the typing mode.
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Holding Exposures
Drawings in an animation project are often exposed for more than one frame. The most common exposure of a 
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation 
on twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save 
time, you can hold cells automatically as you type in the Xsheet view.

How to hold an exposure

 1. Do one of the following:

‣ In the Xsheet menu, select Exposure > Hold Exposure >  Hold 2 Cells.

‣ From the top menu, select Animation > Cell > Hold Exposure > the desired option.

 2. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.
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Extending Single Exposures
T-HFND-007-008

Extending the exposure lets you select a cell and extend it to the desired frame. 

How to extend an exposure in the Timeline view

 1. In the Timeline view, select the cell you want to extend.

 2. Do one of the following:

 l Right-click and select Extend Exposure.

 l In the Timeline View menu, select Exposure > Extend Exposure.

 l Select Animation > Cell > Extend Exposure.

 l Press F5.

 3. In the Extend Exposure dialog box, enter the frame number to extend your cell to.

 4. Indicate if you want to insert the new frames before the following exposure or overwrite it. If you select insert, 
any following exposure will be moved down. if you select Overwrite, the following exposure will be erased 
and replaced by the drawing being extended.

NOTE: You can also select the last cell where you want to extend your drawing to (such as the 
last cell of the layer), right-click and select Extend Exposure. You will not be prompted the dialog 
box.

How to extend an exposure gesturally

 1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down  cursor.

 2. Pull down the selected cell to the desired frame. 

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is 
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considered cancelled.

How to extend an exposure from the top menu

 1. Select a cell and do one of the following:
 l From the top menu, select Animation > Cell > Extend Exposure.

 l Press F5.

The Extend Exposure dialog box opens.

 2. Enter the frame number you want to extend the cell to.
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Extending Exposure Sequences
When working with a sequence that contains only numbers, you can extend an exposure sequence in a similar 
manner to extending a single exposure.

How to extend an exposure to create a sequence

 1. In the Xsheet view, select a cell containing a number.

 2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  cursor.

 3. Hold down the Shift key. Make sure a plus sign (+) appears.

 4. Pull down the selection box to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is con-
sidered cancelled.

 5. First release the Shift key, then release the mouse button.
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Extending Previous Drawing Exposures
T-HFND-006-005

When drawing on a blank frame, you can automatically create a new drawing and extend the timing from the 
previous exposed drawing. 

In the following example, a cell is selected in the Timeline view for creating a new drawing in image A. In image B, 
the previous exposure does not extend to the new drawing, while in image C, it does.

How to extend the exposure of previous drawings

 1. Open the Preferences dialog box by doing one of the following:

 l Select Edit > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. Select the Exposure Sheet tab.
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 3. In the Drawing Creation section, select the Extend Exposure of Previous Drawing option.

 4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.
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Dragging Cells
To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame in 
the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from one 
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

 1. In the Timeline view, select one or more cells to move.

 2. Drag the cells to the new location.

 3. Drop the selection by doing one of the following:

 l Drop by simply releasing the mouse or pen.

 l Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. 
The original cells will not be moved.

 l Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

 1. In the Xsheet view, select one or more cells.

 2. In the Xsheet view, position the pointer over the small dotted area  on the left side of the selected cells.

 3. Drag the selection to any other cell in the same column or in another column.

 4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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 l Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the 
cells. The original selection will not be moved.

 l Press Shift while dropping the selection to insert it between existing frames.

How to turn off the Gestural Drag mode

 1. Do one of the following:

‣ In the Xsheet view, right-click and deselect Gestural Drag Mode. 

‣ From the Xsheet menu, select Edit > Gestural Drag Mode

‣ In the Xsheet toolbar, click the Toggle Gestural Drag Mode button (you may have to customize the  
toolbar to display it).

 

The dragging pad disappears on selected cells when the Gestural Drag mode is off.
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Increasing Exposures
Increasing the exposure Adds one more exposure to a selected cell; repeating this action adds an extra cell each 
time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an 
exposure pushes the existing exposure forward. 

How to increase exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Increase Exposure. 

 l In the Xsheet  toolbar, click the Increase Exposure  button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

 l Right-click and select Exposure > Increase Exposure.

 l Press +.
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Decreasing Exposures
Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the 
beginning of selection. You can do this for one cell or a range.

How to decrease a single exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Decrease Exposure. 

 l In the Xsheet toolbar, click the Decrease Exposure  button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

 l Right-click and select Exposure > Decrease Exposure. 

 l Press -.

How to decrease a range of exposures

 1. In the Timeline or Xsheet view,  select a range of cells.
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 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure and Pull. 

 l Right-click and select Exposure > Clear Exposure and Pull.

 l In the Xsheet toolbar, click the Clear Exposure and Pull  button.

The exposure is reduced by the selected number of cells.

435



Chapter 6: Timing     Increasing Exposures

Deleting Exposures
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline or 
Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again in a 
cell.

You can delete the exposure in a selected cell range  or delete the entire exposure of a drawing exposed over 
several cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

 1. In the Timeline or Xsheet view, select the exposure you want to delete.

 2. Do one of the following:

 l Right-click and select Delete.

 l Press Delete.

How to clear the entire exposure of a drawing

 1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure.

 l In the Timeline view, right-click and select Exposure > Clear Exposure.

 l In the Xsheet toolbar, click the Clear Exposure  button (you may have to customize the 
toolbar to display it).
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Inserting Blank Cells
You can place an empty cell between other cells.  If you are set to Overwrite mode, the mode momentarily changes 
to Insert mode, in order to push down the existing exposures,

How to insert a blank cell

 1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

 2. Do one of the following:

 l In the top menu, select Animation > Cell > Insert Blank Cell. 

 l Right-click and select Exposure > Insert Blank Cell.

 l In the Timeline or Xsheet toolbar, click the Insert Blank Cell  button (you may have to cus-
tomize the toolbar to display it).

 l Press Shift + J.

A blank cell is inserted.
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Setting the Exposure
T-HFND-006-009

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

 1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

 2. Do one of the following:

 l Select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set Exposure.

 l In the Timeline toolbar, click one of the Set Exposure  buttons (you may have 
to customize the toolbar to display them).

 l In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 
1, 2, or 3, or Set Exposure.

 3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you 
want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.

438



Harmony 14 Premium - User Guide

439



Chapter 6: Timing     Increasing Exposures

Filling Selections with Single Exposures
You can Lets you fill the same value over an entire selection. The selection can be over one cell, a cell range in 
one column, a cell range over many columns, an entire column, or many columns. You can use numbers, words, 
letters, or any alphanumeric value.

How to fill a selection with a single exposure

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Fill Selection. 

‣ In the Xsheet toolbar, click the Fill Selection  button (you may have to customize the toolbar to 
display it).

‣ Press Ctrl + T (Windows/Linux) or ⌘  + T (Mac OS X)).

The Fill Selection dialog box opens.

 3. In the Value field, type the desired value.

 4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key Exposure 
After option. Otherwise, leave it deselected.

 5. Click OK.
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Filling Selections with Sequences
You can Lets you create a numbered sequence over a selection. The sequence can be forward, backward, single, 
double or higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column or 
more or an entire column or many entire columns.

How to fill a selection with a sequence

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l From the top menu, select Animation > Cell > Sequence Fill. 

 l In the Timeline view, right-click and select Exposure > Sequence Fill.

 l In the Xsheet toolbar, click the Sequence Fill  button (you may have to customize the toolbar 
to display it).

 l Press Ctrl + M (Windows/Linux) or ⌘  + M (Mac OS X)).

The Sequence Fill dialog box opens.

 3. In the Starting Value field, type the first number in the sequence.
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 4. In the Increment field, type the number by which the drawing number will increase from frame to frame. For 
example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you 
this: 8-6-4-2.
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Filling Selections Randomly
You can Lets you fill in random values over a selection. You can give a maximum and a minimum value and create a 
range for Harmony to choose the random values from. The selection can be over one cell or a cell range in one 
column or more or an entire column or many entire columns.

How to fill cells randomly

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Select Animation > Cell > Fill Cells Randomly.

 l In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the 
toolbar to display it).

The Fill Cells Randomly dialog box opens.

 3. In the Minimum Value field, enter the lowest acceptable value.

 4. In the Maximum Value field, enter the highest acceptable value.

 5. In the Hold field, choose an exposure holding value.

 6. If you are applying this option to a drawing column, select the Whole Numbers option to avoid decimal 
points.
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 7. Click OK.
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Filling Empty Cells
You can Lets you fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after 
each one.When creating drawings on  cells that are not side-by-side, the exposure of the first drawing no longer fills 
automatically. You must select the frame range where you want your drawings to hold their exposure up to the next 
drawing and use the Fill Empty Cells command.

How to fill empty cells

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Right-click and select Exposure > Fill Empty Cells.

 l From the top menu, select Animation > Cell > Fill Empty Cells.

 l In the Timeline toolbar, click the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.
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About Cycles
T-HFND-006-008

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop drawings using the following commands:

• Create Cycle

• Paste Cycle

• Paste Reverse

When you create a drawing cycle, all the repeated drawings are linked to the same original files. When modify, 
repaint, or correct a drawing named “1” for example, all drawings named “1” are updated simultaneously. In order 
to modify a drawing independently from its other exposures, you must duplicate the drawing.
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Creating Cycles
You can create cycles for animated sequences that need repeating, such as a character walking.

How to  create a cycle

 1. In the Timeline or Xsheet view, select the cell range to loop.

 2. In the Timeline toolbar, click the Create Cycle  button (you may have to customize the toolbar to display 
it).

The Create Cycle dialog box opens.

 3. Enter the number of cycles you want, including the current selection.
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Pasting Cycles
Once you have created a cycle from an animated sequence, you can paste it anywhere, for as many times as you 
like and in any direction that you choose.

How to paste a cycle

 1. In the Timeline or Xsheet view, select the cell range to loop.

 2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X).

 3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

 4. Do one of the following:

 l From the top menu, select Edit > Paste Cycle. 

 l Right-click and select Paste Cycle. 

 l Press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.
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 5. Do one of the following:

 l In the Number of Cycles field, enter the number of cycles you want to paste.

 l Increase or decrease the number of cycles you want to paste.

 6. In the Cycle Type menu, select the type of cycle you want to paste.

 l Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection 
and ending with the last.

 l Reverse: Pastes cycles in the reverse order of the original selection, starting with the last cell 
of your selection and ending with the first one.

 l Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in 
reverse order. This repeated until all cycles are pasted.

 l Reverse > Forward:  Pastes the first cycle in your selectionin reverse order, then the following 
one as is. This repeated until all cycles are pasted.

 7. Click OK.
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Pasting Reversed Cycles
Once you've copied an animated sequence, you can paste back its drawings in the reverse order.

NOTE: You can perform the same operation using the Paste Special dialog box. To open the 
Paste Special dialog box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  
+ B (Mac OS X).   

How to paste a reversed cycle

 1. In the Timeline or Xsheet view, select the cell range to paste in reverse order.

 2. From the top menu, select Edit > Copy Cell from Timeline or Xsheet or press Ctrl + C (Win-
dows/Linux) or ⌘  + C (Mac OS X).

 3. In the Timeline or Xsheet view, select the cell where you want your cycles to start.

 4. Do one of the following:

 l From the top menu, select Edit > Paste Reverse. 

 l Right-click and select Paste Reverse. 

 l Press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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Overwriting Exposures and Keyframes
If the area on which you are dropping a selection contains exposures and/or keyframes, they are overwritten by 
the content you selected by dragging. You can set this mode in two places: the Timeline toolbar and the 
Preferences dialog box.

How to overwrite exposures and keyframes

 1. In the Timeline or Xsheet view, drag to select the drawings you want to move.

 2. Do one of the following:

 l In the Timeline toolbar, click the Toggle Override Exposure and Keyframe During Drag and 
Drop  button (you may have to customize the toolbar to display it).

 l From the top menu, select Edit > Preferences or press Ctrl + U (Windows/Linux) or ⌘  + U 
(Mac OS X). Select the Timeline tab, then select the Overwrite Exposures and Key-
frames During Drag and Drop option.

 3. Drop your selection at the desired location.
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About Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure work 
in Harmony:

 l Keyframe: A keyframe is a point in time where a change to the properties of the object or character occurs. In 
Harmony, keyframes consist of the coordinates that determine how an entire layer and its contents are 
moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

 l Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. In 
Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Keyframes 
can be moved independently from the drawing exposure. 

 l Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed on 
a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for another 
one, then the original drawing is retained. This preserves the key drawing. Note that Harmony automatically 
sets a key exposure when you perform a drawing swap.
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Adding Key Exposures
Key exposures are mainly used for swapping drawings in cut-out animation where you will have numerous 
drawings for the various positions of the mouth or eyes of a character for example. 

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This 
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of 
an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is the 
same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be auto-
matically updated even if set as a key exposure.  This keeps your existing animation key poses intact. It is fre-
quently used on a mouth or eyes layer. 

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure. 

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is 
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key 
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for 
drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline menu, select Exposure > Add Key Exposure.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same 
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing is 
split in two and both parts contain the same drawing. 
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure 
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When 
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l  In the Timeline menu, select Exposure > Remove Key Exposure.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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Removing Duplicate Key Exposures
When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of specific 
key exposures, unnecessary key exposures will be created. You can delete these duplicates without affecting the 
rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

 1. In the Timeline view, select the layer that contains duplicate key exposures. 

 2. In the Timeline toolbar, click the Remove Duplicate Key Exposure  button (you may have to customize the 
toolbar to display it).
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Pasting Key Exposures Using Different Modes
As you animate, you will find that you reuse key exposures.  There are different options to paste your selected 
drawings when they contain key exposures:

• Enforce Key Exposure: If there are key exposures that exist on copied drawings, they are preserved 
when pasting. No key exposures are added. This is the default behavior when pasting.

• Fill Gap with Previous Drawing: Fills selected area in the Xsheet or Timeline view with the previous 
drawing.

• Fill to Next Key Exposure: Fills selected area till the next key exposure.

How to paste using different modes

 1. In the Timeline or Xsheet view, select the drawings you want to copy and press Ctrl + C (Windows/Linux) 
or ⌘  + C (Mac OS X). 

 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.

 3. Do one of the following:

‣ Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X).

The Paste Special dialog box opens.

‣ From the Timeline menu, select Edit > Modify Paste Presets > Exposure.

The Edit Exposure Paste Preset dialog box opens.
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 4. Select the Enforce Key Exposure or Fill to Next Key Exposure option. In the Paste Special dialog box, 
these options are on the Basic tab.

 5. Click OK.

 6. Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X) to paste your selection.
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Modifying Paste Presets
When pasting key frames and exposures, you can modify the existing presets to your liking. There are three 
presets you can modify: the default presets for both key frames and exposures, key frames only and exposures 
only.

How to modify paste presets

 1. From the Timeline view menu, select Edit > Modify Paste Presets and one of the following options:

 l All to edit the default paste preset settings.

 l Key Frame to edit the preset settings for pasting key frames.

 l Exposure to edit the preset settings for pasting exposures.

The Edit Paste Presets dialog box opens.

 2. Refer to the following table and edit the presets as desired.

Parameter Description

Drawings

Add/Remove Exposure

 

Never create drawing files: When adding exposures to a drawing layer, 
drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures 
to a drawing layer, new drawings will be created only when drawings with the 
same name do not already exist in the destination.

Always create drawing files: When adding exposures to a drawing layer, new 
drawings will always be created. If drawing files with the same name already 
exist, Harmony will create a new name for the drawing.

Enforce Key Exposure
If there are key exposures that exist on copied drawings, they are preserved 
when pasting. No key exposures are added. This is the default behavior when 
pasting.

Fill Gap with Previous Fills selected area in the Xsheet or Timeline view with the previous drawing.
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Drawing

Fill to Next Key 
Exposure

Fills selected area till the next key exposure.

Keyframes

Add/Remove 
Keyframes

Motion: Copies the properties of the selected motion keyframe to the new 
frame.

Velocity: Copies the properties of the selected velocity keyframe to the new 
frame.

Rotation: Copies the properties of the selected rotation keyframe to the new 
frame.

Scale: Copies the properties of the selected scale keyframe to the new frame.

Skew: Copies the properties of the selected skew keyframe to the new frame.

Force Keyframes at Function's Beginning and End: Adds a keyframe to the 
beginning and end of the pasted function, reproducing the source function.
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About Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in the 
project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and 
not the cells.
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Renaming Drawings
T-HFND-005-003

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

You can also rename a series of drawings relative to their frame position, which is useful in hand-drawn animation.

How to rename a drawing

 1. In the Timeline or Xsheet view, select the drawing to rename.

 2. Do one of the following:

 l Right-click and select Drawings > Rename Drawing.

 l In the Timeline toolbar, click the Rename Drawing  button (you may have to customize the 
toolbar to display it).

 l Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

 3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix

You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet breakdown and 
deformation animation.

 1. In the Timeline or Xsheet view, select a drawing sequence. Note that you can only select a drawing range in 
one column or layer at a time.

 2. Right-click and select Drawings > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.
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 3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position

 1. In the Timeline or Xsheet view, select the drawing sequence to rename.

 2. Select Drawing > Rename by Frame.
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Deleting Drawings
You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

 1. In the Timeline or Xsheet view, select the drawings to delete.

 2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the 
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing. 
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted 
from the project folder or other cells in which it is exposed.

With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This way, 
you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

 1. In the Timeline or Xsheet view, select the drawing to duplicate.

 2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawings.

‣ Right-click  and select Drawings > Duplicate Drawings.

‣ In the Xsheet toolbar, click the Duplicate Drawing  button.

‣ Press Alt + Shift + D.
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual 
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible over a 
series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. 
Keyframes can be moved independently from the drawing exposure. 

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to 
duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new 
drawings will be created only when drawings with the same name do not already exist in the 
destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with 
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template,  such as 
when placing new drawings after the animation, then delete the template's animation.  It 
will still have updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will always 
be created. If drawing files with the same name already exist, Harmony will create a new name for the 
drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can use 
the Paste Special Again command instead. You can paste your selection using the same settings as in the most 
recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

 1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X). 

 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.
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 3. Do one of the following:

 l Right-click and select Paste Special.

 l From the top menu, select Edit > Paste Special.

 l In the Xsheet  or Timeline toolbar, click the Paste Special  button (you may need to cus-
tomize the toolbar to display it).

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X). 

The Paste Special dialog box opens.

 4. Select the Basic tab.

 5. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They Do 
Not Exist option.

How to paste new drawings with the previous Paste Special settings

 1. Do one of the following:
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 l From the top menu, select Edit > Paste Special Again.

 l Right-click and select Paste Special Again

 l In the Timeline or Xsheet  toolbar, click the Paste Special Again  button (you may have to 
customize the toolbar to display it).

 l Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (Mac OS X).
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Merging Drawings
There are two methods of merging drawings. 

• You can merge selected drawings in adjacent elements. The columns and layers will be left intact, and 
each new merged drawing will reside in the frames of the left-most column or lower layer.

• You can merge elements. All drawings will be merged. Unused columns and layers will be deleted, but the 
original drawing files are still accessible.
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Merging Selected Drawings
You can merge drawings from adjacent layers or columns. The merged drawings will appear in the lower layer or left-
most column of the two layers or columns selected.

How to merge selected drawings

 1. In the Xsheet view, select the drawings to merge.

 2. Do one of the following:

‣ In the Xsheet menu, select Columns> Merge Selected Drawings.

‣ In the Timeline menu, select Layers > Merge Selected Drawings.
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 3. Do one of the following:

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timeline menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining columns will be left 
blank at the corresponding frames. In the Timeline view, the bottom timeline layer will contain the merged 
drawings from all layers and the other layers will be left blank at the corresponding frames. Drawings are not 
deleted and are still accessible.
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Merging All Drawings
You can merge all the drawings in two layers or columns.

How to merge all the drawings in two layers or columns

 1. Do one of the following:

‣ In the Timeline view, select the layers you want to merge.

‣ In the Xsheet view, Shift-click the headers of the columns you want to merge.

‣ In the top menu, select Edit > Merge.

‣ In the Xsheet menu, select Columns > Merge Selected Columns.

‣ In the Timeline menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the other columns will be 
deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings from all layers and 
the other layers will be deleted. Drawings are not deleted and are still accessible.
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Printing the Xsheet
Once you have marked all the information, corrections, and timing you want in the Xsheet view, you can print your 
exposure sheet. Printing the Xsheet allows you to take it with you to your animation table or give a copy to the 
animator. You can also use it to create your Xsheet skeleton directly in Harmony.

How to print your exposure sheet

 1. Select File > Print > Xsheet.

The Print dialog box opens.

 2. To set up your print:
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 l Windows: In the Select Printer section, select your printer and adjust the rest of the printing set-
tings. 

 l Linux: In the Print Destination section, select your printer and adjust the rest of the printing set-
tings. 

 l Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by click-
ing on the Parameters  button. You can also click  PDF and select an option from the menu if 
you want to save a PDF version of your exposure sheet. 

NOTE: Refer to your printer user guide to learn more about its options.

 3. Do one of the following:

 l Windows and Mac OS X: Click Print. 

 l Linux: Click OK.

475



Harmony 14 Premium - User Guide

476



Harmony 14 Premium - User Guide

Chapter 7: Colours
Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some other 
software only allow users to work with on colour swatch at a time, painting in Harmony is done by using palettes 
containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can 
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using 
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and 
atmosphere of the scene without tediously repainting each element.
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It is also possible to use colour swatches from palettes in bitmap drawings, although changing the colours in the 
palettes will not automatically update colours used in bitmap layers. Likewise, it is possible to create drawing 
layers with bitmap line art and vector colour art, all with the same palettes —see About Art Layers on page 333 and 
Creating Colour Art from Line Art  on page 339.
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About Colour Swatches
T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture 
swatches.

A colour palette is an actual file on the hard drive. 

In Harmony Server, these palette files can be stored in a different location on the server. They can be stored in the 
Environment, Job, Scene, or Element folder and linked to any palette list. This means that if the original palette file is 
modified, it will update in every drawing element the palette is linked to. 

In Harmony Server, to avoid accidentally modifying the palette, the palette files can be locked. If a palette must be 
modified, you must get the rights to modify them before doing so.

In Toon Boom Harmony, when you add a swatch, it is created using the colour of the currently selected swatch from 
your palette. However, you can set a default colour to be used every time you create a new colour in your colour 
palette. This is useful for creating different shades of the same basic colour.

The default colour is also the colour used when you choose to vectorize images you're scanning into your scene, 
however you add the Default colour swatch to your palette in a different way, so it's unique. It has a unique ID 
number that makes it easily recognizable from all the other colours in your colour palettes. Being able to change this 
colour allows you to change the basic colour of all scanned drawings. This can be useful on more than just an 
aesthetic level as sometimes when you go to NTSC or PAL, pure colours, such as pure black, can create problems.
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Locking and Unlocking the Colour List
In Harmony Server, you can lock and unlock the colour list to avoid modifying or modify the colour swatches.

How to lock and unlock the colour list 

 1. In the Colour view, click the Edit Palette Mode  button. 

A grey pencil icon appears in the top-right corner of the Palette list.
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Adding a Colour Swatch 
T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l In the colour wheel, select a colour.

 l Enter the HSV or RGB values in the corresponding fields.

 l Select the R,G,B,H,S or V options to change the look of the colour picking area.

 l Click the Dropper  button to select any colour on your screen. It can be from the Harmony 
interface, your operating system or any other open application. 
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You can also click Multi Wheel Mode to open the Multiwheel Colour window. This displays all the picking 
area styles together and also contains a picking undo list. To return to the regular Colour Picker window, 
click Single Wheel Mode.

 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.
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 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly 
access it later.

 7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on its 
name.

How to change the default swatch colour for all your colour palettes

 1. Select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences (Mac OS X).

 2. In the Preferences dialog box, select the Drawing tab.

 3. In the New Colour Pots section, select the Create New Colour Pots Using the Default Colour option. You 
can also click the colour swatch beside the option to change the default colour.

How to add a new colour swatch using the default colour

 1. From the Colour view menu, select Colours > New. 

A new swatch is added to your palette using the default colour swatch colour. The new swatch created 
with the New  command will be named New 0.
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Deleting a Colour Swatch
T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will be 
displayed in red and the system will try to recover them the next time you load the scene. 

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.
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Adding a Gradient Colour Swatch 
T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker window opens.

 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. Adjust the Gradient arrows to modify the colours.

 l Add extra colours by clicking between the arrows below the gradient bar. Then click on the 
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Colour Preview to select a colour.

 l Pull down the arrows to remove them.

 l Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see About the Edit 
Gradient and Texture Tool on page 565.
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Adding a Texture Colour Swatch 
T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. 

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

NOTE: 
To learn how to reposition the textured zones in your drawings, see About the Edit Gradient and 
Texture Tool on page 565.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of 
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously 
applied to the texture’s position in your drawings will be kept.
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Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Mixing Colours
If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint 
panel. You can also create palette styles, such as night and day styles.

How to mix colours

 1. In the Colour view, select the palette that contains the colours you want to offset or blend.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Tint Panel. 

 l Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.

 3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 4. Select Preview option.
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 5. Select the Offset, Blend, or Mixer option.

Parameter Description

Offset

Offsets the selected colours by the adjustments made using the 
HSB and RGB sliders. Use the Amount slider to adjust the 
degree of offset. Use the Alpha slider to adjust the opacity of the 
selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-
right corner. Use the Amount slider to adjust the degree of blend. 
A blend of 100% turns the selected colours into the same colour 
as the swatch. Adjusting the HSB and RGB sliders affect the 
swatch colour, which in turn affects the selected colours on the 
left. Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use 
the slider just beneath to mix the Base and Tint colours by dif-
ferent amounts. This will affect the mixed swatch whether it is 
selected or not. Select either the Tint or Base swatch and use 
the HSB and RGB sliders to adjust its colour. This will affect the 
mixed swatch colour, which in turn affects the selected colours 
on the left.

 6. Click Apply.
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Protecting Colours
When you are finished inking one colour, you can lock it so if you ever paint over it accidentally, the work already 
done will not be affected. You can also use the Protect Colour feature to block the filling colours if you painted all of 
the animation in Line Art and you plan to repaint the lines.

When painting, the Respect Protected Colour option is enabled by default. In the Colour view, you can protect In the 
Colour view, you can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you 
using the Paint tool and this option is deselected, you will repaint or unpaint the protected colours on your drawings 
until you enable the option again.

How to protect colours

 1. In the Colour view, select the colour to be protected.

 2. Do one of the following:

 l Right-click and select Protect Colour.

 l From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

How to enable the Respect Protected Colours option

 1. Do one of the following:

 l In the Paint tool properties, click the Respect Protected Colour button.

 l From the top menu, select Drawing> Colour Protection > Respect Colour Protection.

 l Press Shift + S.
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Copying and Pasting Colours 
When you're creating palettes, you may want to copy colour swatches or their values and paste them in other 
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour 
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is 
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch 
from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the 
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) 
or ⌘  + V (Mac OS X).

 l To paste the colour values of the copied swatch over an existing colour swatch, select Col-
ours > Paste Colour Values.
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How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X).

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch you want toget the ID from.

 l In the Colour view, click the Edit Palette Mode  button to edit the colour list. 

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

 3. Paste the copied value as plain text in the desired document.
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Changing the Colour Display Mode 
The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This 
option is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The 
gradient colour swatches will be identified as (gradient). 
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About Palettes
T-ANIMPA-003-001

In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. This is 
referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of red, 
green, blue and opacity, the latter which is referred to as alpha.

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette and 
add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, shirt, 
pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt file name 
extension. 

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using 
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and 
atmosphere of the scene without tediously repainting each element.
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In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is 
created from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene 
directory in a palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:

 l Element: The Palette Library folder is stored directly in the drawing Element folder.

 l Scene: The Palette Library folder is stored directly in the Scene folder.

 l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

 l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.
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By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended 
to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting 
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and 
scenes, to be shared between a series of client machines.

Element Level 
Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. When 
a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file with the 
colour model, the colourist can load them both from the same location. This also creates a more organized structure.

Scene Level 
Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes 
from the scene are stored together. The palette naming must be structured so the colourist or character builders can 
find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and retrieve 
their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all of 
the characters, props, effects, and location, the colour palette or model will often be directly imported to, or created 
in, the character building scene. Just as with a cut-out character building scene, each element uses the same 
palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene level. This 
prevents a palette overload because all of the models are in different scenes. It also allows each scene to have its 
own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Where to Save the Palette File
The palette storage location depends on the type of production and the backup plan being used. Some studios like to 
store their palettes at the Element level and others at the Environment level as this will not create a problem so long 
as the scene is in the Harmony structure. In fact, as long as the Harmony structure is maintained it can be stored at 
any level. However, difficulties may occur when the scene is backed up or transferred to another studio or database 
and removed from the structure.
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What happens when you export a palette file?
It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in the 
database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or 
Environment level. The palette files can be accessed from any scene of any project.

When you export scenes from Harmony to either archive or send them to other users or studios, the palettes 
stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette library, the Job 
and the Environment where it is stored. Any other palette from other Environments, Jobs, Elements or Scenes 
(even from the same job) will NOT follow. Instead a recovery palette will be created when the scene is reopened 
in another Harmony system. A recovery palette is a local palette created by the system when palettes and 
colours are missing. This palette is no longer shared with the rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from 
Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2. 
If Scene 2 was linked to any of these, the system will create a recovery palette the next time Scene 2 is opened in 
another Harmony system.

The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project
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• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will require more structure 
when exporting the scenes. The scene will have to be exported along with its colour model scene. The other studio 
you are working with must recreate an identical structure to yours, then import the received scenes into the same 
location as you have them in order to maintain the links.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though the palettes 
are locked by default. That is why it is a good idea to copy and back up your palette libraries and master palette 
directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing an 
altered file. Harmony automatically updates all of the files and drawings linked to it.
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About the Palette List
T-ANIMPA-003-006

The Colour view has two modes: basic and advanced.

 l Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only 
see the colours available in the Default palette which contains six basic colour swatches and is 
automatically named the same as your scene. For simple projects, you can manage with the default 
palette, but for movies, series, or shorts it is recommended that you create palettes for your characters. To 
create a palette, you have to switch to the Advanced mode of the Colour view and show the Palette list.

 l Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for your 
characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list. 
The scene also has a palette list.  For example, a drawing layer can use three different palettes stored in three 
different locations, while another drawing layer can use two of these palettes plus another one coming from 
another scene. The palette list keep track of the locations of the palettes.

There are two types of palette lists:

 l Scene Palette List 
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The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and 
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that 
use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only Scene 
Palette lists.

 l Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette 
at an element’s level. The Element Palette list is mainly used with traditional and paperless animation. 
Unlike cut-out animation, all columns (drawing elements) contain different characters, props, 
backgrounds, and effects. The Element Palette list is used when you do not necessarily want all of the 
palettes for all of your elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a 
global palette list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony 
uses the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour 
Palette  on page 513.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.
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Showing and Hiding the Palette List
You can show or hide the palette list in the Colour view. 

How to show or hide the Palette list

 l In the Colour view, click the Show/Hide Palette List View  button to expand or collapse the Palette List 
area.

The Palette List window opens and displays all your palettes.
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Locking and Unlocking the Palette List
To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or create a new 
palette, the palette list must first be unlocked. 

How to lock and unlock to the palette list

‣ From the top menu, select Edit > Edit Palette List Mode. 

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.
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Enabling the Advanced Palette Mode 
You can set up the Advanced Palette Lists option in the Preferences panel. This allows you to see the Element and 
Scene palette lists.

How to set the Advanced Palette Lists mode

 1. Do one of the following:

 l From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > 
Preferences (Mac OS X).

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the Advanced tab.

 3. In the Advanced Options section, select  the Advanced Palette Lists option.

 4. Click OK.
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Creating a Colour Palette
T-ANIMPA-003-002 

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the 
Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. When you 
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element.

If you are using Harmony Server, see About Palettes on page 495.

How to create a new palette (Basic Palette Lists mode)

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

 l Make sure you have the rights to modify the palette list. If not, select  Edit > Edit Palette 
List Mode.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

 1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

 2. Make sure that you have the necessary rights to modify the palette list. If you do not, select  Edit > Edit 
Palette List Mode.

 3. In the Colour view, click the Show Palette List View  button to display the palette list. 
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 4. Do one of the following:

 l From the Colour view menu, select Palettes > New. Before you can create a palette in the 
Advanced Palette Lists mode, you must first set your preferences to Advanced Palette Lists 
mode in the Preferences dialog box—see Enabling the Advanced Palette Mode  on page 505.

 l Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

 5. Select the level to store the palette file. 
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 l Environment: The palette-library folder is stored in the scene's parent environment folder.

 l Job: The  palette-library folder is stored in the scene's parent job folder. 

 l Scene: The  palette-library folder is stored directly in the scene folder. 

 l Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

 6. Name the palette. There is no need to add the suffix "palette" to the as it is always recognized as a palette 
file.

 

 7. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be 
divided in twenty to thirty different drawing elements that use the character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element. 

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out 
animation, all columns (drawing elements) contain different characters, props, backgrounds and 
effects. The Element Palette List is used because you do not necessarily want all of the palettes for 
all of your elements linked in every column. 
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The palette list is stored in the drawing element's directory instead of directly in the Scene level. This 
ensures that the links to the palettes appear only in the appropriate element. If you prefer to access a 
global palette list, link your palettes to the Scene Palette List.

 8. Click OK. 

The new palette appears in the palette list.

509



Chapter 7: Colours     About Palettes

Renaming a Colour Palette
T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Colour Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not be 
deleted and you can reimport it in your Palette list later on.

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette 
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a 
different ID and is independent from the original palette. This ensures that both palettes are completely 
independent.
This option is used when there are similar models and you want to avoid recreating and naming all the colours. 
You can change the values and the names afterward without affecting the original palette. You can also keep 
some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette 

 1. In the Colour view, select the palette to be duplicated.

 2. Do one of the following:

 l From the Colour menu, select Palettes > Duplicate. 

 l Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

 3. If you are in Advanced Palette List mode, select the palette storage level—see About Palettes on page 495.

 4. In the New Palette Name field, name the palette.

 5. In the New Palette Name field, name the palette.

 6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 
A character usually has only one master palette, although there are times when the characters are placed in different 
lighting conditions and require a different colour shading. The night palette is a popular choice when a scene or 
sequence changes from day to night. It can be difficult and time-consuming to repaint everything and creating two 
independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same properties. The colours 
have the same identification number pointing to the same colour zones, but they can have different names and 
RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will update. So 
there's no need to repaint the animation. All you have to do is create or import a clone palette (palette style).

How to clone a palette

 1. In the Colour view, select a palette to clone.

 2. From the Colour  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.
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 3. If you're in Advanced Palette List mode, select the palette storage level—see About Palettes on page 495.
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 4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

 5. Click OK.

The cloned palette appears in the palette list.

 6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing Colours on page 
489.

 7. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

 8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Windows/Linux) or 
⌘  + A (Mac OS X).

 9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.
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 10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.
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About Linking and Importing Palettes
Before you start colouring work such as ink and paint or even creating new colour models, you may want to load 
existing colour palettes to your scene. You can do so by importing colour palettes to your palette list, or by linking 
them to your palette list.

Importing a colour palette creates a copy of the palette file in your scene's palette folder, then adds it to your scene's 
palette list. Linking to a palette adds the palette to your scene's palette list, but from its original location. With the 
latter method, you can source the colors for your characters and backgrounds from their original model, and make 
modifications on your models that will apply to all your scenes.

On Harmony Server, you can link to a palette file from any scene, job or environment in your database. As a result, 
you can link to a palette from the scene in which you created your character and its original palette, or you can store 
the palettes used by your production at the job or environment level so they can be shared between scenes from a 
common palette library.

You can also link to a palette file from anywhere in your file system. This can be useful if you are using Harmony 
Stand Alone and want to use the same palette file across different scenes. You can also do this in Harmony Server, 
but it is not recommended, as the palette file may not be available when the scene that links to it is opened on a 
different machine. 

If you are storing palettes in element palette lists, you can link a palette from one element's palette list to another 
element's palette list. This allows you to share palette files between  two or more elements without storing them in 
the scene's palette list.

If a palette file is missing, it will still appear in the palette list for that scene or element, with a strike through across 
its name. If you preformed the automatic colour recovery for that palette, when the scene was opened, the colours of 
that palette will be made available in your scene.

The palette list displays icons next to each palette to indicate how it is linked to in the palette list.

Icon Description

Indicates that the palette is safe.

There won’t be any problems once the scene is exported. For example, the palette file is stored 
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in the scene folder and is linked to the Scene Palette List. 

Indicates that the palette file is stored in a directory external to the scene’s structure.

The palette file is probably stored in a Master Palette directory on a hard drive external to the 
palette-libraries planned for the palette storage. The warning in this case is that if you move your 
Master Palette directory to another location, you may loose the palette in your scene.

Indicates that a palette file stored in a level such as Element, Scene, Job or Environment is 
linked to a Palette list that is not on the same level. 

For example, a palette file is stored into the Environment folder and is linked to the Element 
Palette list. The palette is shared.

Indicates a potentially dangerous situation.

Problems may occur when trying to export or link to the palette file. For example, a palette file is 
stored into the element folder and is linked to the Scene Palette list. The issue in this case is 
that if you decide to delete the layer containing the palette, it will be lost from your scene.
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Importing a Colour Palette
T-ANIMPA-003-005

You can import an existing colour palette in your project. 

How to import a palette into your project

 1. Do one of the following:

 l From the Colour menu, select Palettes > Import. 

 l Right-click and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

 3. Click Open.

The Palette Browser opens. 
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 4. If you're in Advanced Palette mode, select the level where the palette file is stored—see About Palettes on 
page 495.

 5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette 
List or Element Palette List—see About Palettes on page 495.

 6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.
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Linking a Colour Palette
T-ANIMPA-003-004

You can link a palette from its original location as long as it is located in the Harmony structure. 

How to link a colour palette

 1. Do one of the following:

 l From the Colour View menu, select Palettes > Link. 

 l Right-click and select Link.

 l Click the Import  button.

The Palette Browser: Link Palette dialog box opens.
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 2. Select the level where the palette file is stored—see About Palettes on page 495.

 3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—see 
About the Palette List on page 500.

The palette appears in the Colour view.
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Linking to an External Colour Palette
You can link a palette from its original location. If you move the file, you break the link to the file.

How to link to an external palette

 1. In the Colour view, click on the Create Palette  button to create a palette to be used as external.

 2. Save your scene by selecting File > Save from the top menu or by clicking the Save   button or press Ctrl 
+ S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. On your computer or server, create a master directory. Ideally, this should be created in your Root folder to 
keep it within the project directory. You could also place it inside your Colour Model’s subdirectory.

 4. Name the folder appropriately, for example: Joe_master_palette.

 5. From your operating system, browse to your Toon Boom Harmony scene and open the palette-library folder.

 6. Select and copy your palette *.plt file to copy it to the master palette directory.
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 7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette. 

 8. In the Timeline or Xsheet view, select the element to link the palette to.

 9. From the Colour View menu, select Palettes > Link to External.

The Link to External Palette dialog box opens.

 10. Click Browse to search for your master palettes folder and select the palette *.plt file you want to link.

 11. In the Palette list section, select how you want to load the palette; at the scene or element level.

 12. Click OK.

The linked palette appears in the Colour view.

If a palette is outside the scene, the External  icon appears beside the palette name. 

NOTE: To link an element (such as a colour model) to the palette that is stored in the external palette dir-
ectory, you must remove the original palette from the element’s palette list. You will then load the duplicated 
palette into the palette list using the Link to External command, like you did for the other elements. 
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Palette Operations
When you start Toon Boom Harmony connected to the database, you can access the Palette Operations dialog box 
which lets you clone, rename, or delete palettes. 
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Opening the Palette Operations Dialog Box
You can open the Palette Operations dialog box in Harmony Server.

How to open the Palette Operations dialog box

 1. Start Harmony and log in. 

 2. Close the Database Selector dialog box. 

 3. From the top menu, select Tools > Palette Operations. 

The Palette Operations dialog box opens. 
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Cloning a Palette in the Palette Operations Dialog Box
From the Palette Operations window, you can clone palettes in Harmony Server.  

How to clone a palette in the Palette Operations dialog box 

 1. Select the palette you want to clone at the location and level in which it was stored. 

 2. Click Clone. 

A Warning dialog box opens. 

 

 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

 4. Click Yes.

The Palette Browser dialog box opens. 

 5. Select the level to store the palette file.
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 6. Name the palette. There is no need to add the suffix "palette"  to the name as it is always recognized as a 
palette file.

 

 7. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be 
divided in twenty to thirty different drawing elements that use the character's master palette. 

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element. 

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out 
animation, all columns (drawing elements) contain different characters, props, backgrounds and 
effects. The Element Palette List is used because you do not necessarily want all of the palettes for 
all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to 
access a global palette list, link your palettes to the Scene Palette List.

 8. Click OK.
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Renaming a Palette in the Palette Operations Dialog Box
You can rename palettes in the Palette Operations dialog box in Harmony Server.

How to rename a palette in the Palette Operation dialog box

 1. Select the palette you want to rename at the location and level in which it was stored. 

 2. Click Rename.

A Warning dialog box opens. 

 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

 4. Click Yes.

The Rename Palette dialog box opens. 

 

 5. Type in a name for the palette. 

 6. Click OK. 
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Deleting a Palette in the Palette Operations Dialog Box
You can delete palette files from the Palette Operations dialog box in Harmony Server. 

How to delete a palette in the Palette Operation dialog box

 1. Select the palette you want to delete at the location and level in which it was stored. 

 2. Click Delete. 

A Warning dialog box opens. 
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 3. Select the Don't show this message again option if you do not want to see this message every time you per-
form this operation.

NOTE: It is not recommended to disable the warning message as deleting a palette cannot be 
undone. 

 4. Click Yes.
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that 
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, and 
so on.

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and paint 
process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do not 
belong in the drawing, extra floating artwork around the drawing that must be removed), painting the lines and 
filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean, 
only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning a 
set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a new 
colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is known 
as a colour swatch—see About Palettes on page 495. 
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About Colour Models
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view. That drawing 
can be used and loaded in any of your Harmony scenes—see Painting Drawings on page 545. 

 

Once a drawing is loaded in the Model view, you can use the Model view Dropper to select a colour from the model 
and use it to paint in your Camera or Drawing view without having to pick the colour from the colour palette.

You can do more than just copy colours from a colour model. Harmony gives you the ability to copy parts of the 
character directly from its colour model and paste these elements into the Drawing or Camera views.
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Loading Colour Models
T-ANIMPA-004-005

You can load any TVG drawings in your Model view. To avoid browsing for models every single time you work on 
your scene, you can store default models in your scene and load those. 

How to load a colour model from the Timeline or Xsheet view

 1. In the Timeline or Xsheet view, select a drawing (*.tvg).

 2. Bring the model into the Model view by doing one of the following:

 l In the Timeline view, drag the selected drawing and drop it directly in the Model view.

 l From the Model View menu, select Use Current Drawing as Model.

NOTE: The Use Current Drawing as Model button is not part of the default Model View toolbar. 
To add the Use Current Drawing as Model button to the Model toolbar, right-click in the Model 
view toolbar and select Customize. Drag the Use Current Drawing as Model  button from 
the Available Tools column and move it to the right (Toolbar) column. Click OK.

 l In the Model View toolbar, click Current Drawing  button.

The model appears in the Model view.

How to browse for a colour model drawing on your hard drive

 1. Do one of the following: 

 l In the Model View toolbar, click the Import Model  button.

 l From the Model View menu, select Import Model. 

 l Select File > Import > Colour Model.

 2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database for Harmony 
Server.

 3. Click Open. 

The model appears in the Model view.
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How to load the default models

 1. In your scene’s folder, create a new folder and name it models.

 2. On your hard drive, copy the *.tvg drawing file you want to use as colour models in your scene.

 3. Paste the copied models in the models folder you created.

 4. Do one of the following:

 l From the Model View menu, select Load Default Models. 

 l In the Model View toolbar, click the Load Default Model  button.

NOTE: The Load Default Model button is not part of the default Model View toolbar. To add the 
Load Default Model button to the Model toolbar, right-click in the Model view toolbar and select 
Customize. Drag the Load Default Model  button from the Available Tools column and move it 
to the right (Toolbar) column. Click OK.

How to load a single drawing from the Library view

 1. In the Library view, click the template containing the drawing to import in the Model view.

 2. Right-click on the template and select Open As Folder.

 3. In the Library view’s left side, select the template’s folder and continuing expanding its subfolders until *.tvg 
files appear on the right side.

 4. In the Library view’s right side, select the TVG drawing to import and drag it into the Model view.
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How to load a template with multiple drawings from the Library view

 1. In the Library view, find the template you want to import in the Model view.

 2. In the Library view’s right side, drag the template (*.tpl file) and drop it directly in the Model view.

 3. Use the Previous Model   and Next Model  buttons in the Model View toolbar to view all the draw-
ings contained in the template. This can often be the front, profile, and 3/4 views of a character.

How to load a symbol from the Library view

 1. In the Library view’s left side, select the Symbols folder.

 2. In the Library view’s right side, select the symbol you want to use as a model, and drag and drop it into the 
Model view.

 3. Use the Previous Model  and Next Model  buttons in the Model View toolbar to view all the drawings 
contained in the template. This can often be the front, profile, and 3/4 views of a character.
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Clearing Colour Models
You can remove colour models from the Model view. 

How to clear a colour model

 l In the Model View menu, select Clear Model or press Delete.
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Copying Colour Models
You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. In the Model View toolbar, select the Select  tool.

 2. In the Model view, select your model.

 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing Object, or 
select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline or pressCtrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.

How to copy part of the model from the Model view

 1. In the Model View toolbar, select the Cutter  tool or press Alt + T.

 2. In the Model view, use the Cutter tool to create a selection around the part of your model that you want to 
copy.
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 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the following:

 l Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

 l Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V (Win-
dows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.
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About Dirt Cleanup
When paper drawings are passed through a scanner, there can be some hair and dirt scattered across them. 
These lines and dots need to be cleaned. Harmony provides different tools to help get rid of them quickly.

If there are some marks that cannot be removed with the automated tools, you can erase them with the Eraser 
tool or select them with the Select tool and then delete them. It's always safer to select and delete them than to 
erase them, so you do not overlook anything.
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Removing Dirt
The Remove Dirt tool selects small dots and hairs on the drawing.

Raising the Remove Dirt level will select bigger dots. When selecting larger dots, be careful not to lose small details 
like pupils and nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire 
animation sequence. This is a quick way to get rid of most dirt and dust.

During this process, the dirt that will be removed is highlighted in red.

How to use the Remove Dirt tool

 1. Do one of the following:

 l From the top menu, select Drawing > Clean Up > Remove Dirt.

 l From the Camera or Drawing View  menu, select Drawing > Clean Up > Remove Dirt.

 l Press Shift + D.

 2. Increase the Remove Dirt value by moving the slider to the right.

 3. Select the Apply to All Drawings option if you want to apply the operation to all drawings in the layer.

541



Chapter 7: Colours     About Painting

Removing Dirt Outside the Selection
The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is recommended 
that you clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in 
large output files, especially if you work in high-definition resolutions.

How to clean dirt with Remove Art Outside Selection

 1. In the Tools toolbar, select the  Select  tool.

 2. In the Tool Properties view, click the Permanent Selection  button.

 3. Draw a selection around the animation making sure to include the entire animation sequence.

 4. In the Camera or Drawing View  menu, select Drawings > Clean Up and one of the following options:

 l Remove Art Outside Selection to delete artwork outside your selection on a single draw-
ing.

 l Remove Art Outside Selection on All Drawings to delete artwork outside your selection 
on all the drawings.

The art outside the selection is removed.
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Removing the Art Inside the Selection
You can delete any art inside a selection with the Remove Art Inside Selection option. We recommend that you 
clean your Colour Art level as well. If you have a stroke accumulation in your Colour Art, it can result in large output 
files, especially if you work in high definition resolutions.

You can simultaneously apply this operation to all your drawings in the layer by using the Remove Art Inside 
Selection on All Drawings command.

How to clean dirt with Remove Art Inside Selection

 1. In the Tools toolbar, click the Select tool or press Alt + S.

 2. To apply the action to your entire animation, click the Permanent Selection  button in the Tool Properties 
view.

 3. In the Camera or Drawing view, draw a selection around the animation. Make sure the area is large enough to 
include all the zones to be cleaned up on all drawings.

 4. From the top menu, select Drawing > Clean Up > Remove Art Inside Selection to delete artwork inside 
your selection on one single drawing. You can also press Delete.

 5. To apply the action on all your drawings in the layer, select Drawing > Clean Up > Remove Art Inside 
Selection on All Drawings to delete artwork inside your selection on all the drawings.
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Removing Hair
The Remove Hair command lets you remove any small strokes created in the Colour Art layer from very thick 
lines or filled zones. Increasing the Remove Hair level value will select larger strokes for removal from the 
drawing.

How to use the Remove Hair tool

 1. In the Timeline or Xsheet view, select the drawing containing the drawing to clean.

 2. From the top menu, select View > Show > Show Strokes to display the invisible lines or press K.

 3. In the top menu, select Drawing > Clean Up > Remove Hair.

The Remove Hair dialog box opens.

 4. Move the slider to the right to increase the number and length of hairs to be selected. 

 5. Select the Apply to All Drawings option if you want to apply the operation to all the drawings in the layer.

 6. Click OK.
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Painting Drawings
T-HFND-004-011

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several different 
modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines defining a 
zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap option.

NOTE: To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. In the Timeline or Xsheet view, select the cell on which you want to paint.

 2. Do one of the following:

 l In the Tools toolbar, click the Paint  tool.

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and filled zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain 
unchanged.
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 l The Repaint   mode paints everything it touches except empty zones. Any zone that is 
not painted will remain intact.

 l The Unpaint   mode unpaints everything it touches, including empty and filled zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a lasso or 
marquee selection to paint several zones or pencil lines at the same time.

NOTE: The last colour you select while using the Paint tool will be used the next time you 
select the Paint tool if you're using the unlocked painting tools in the Colour view.
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Repainting
You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.  

You can repaint lines, zones, and brush strokes using the Repaint tool. The repaint pencil lines more efficiently, 
see Inking Lines on page 560. The Repaint tool does not fill empty zones, even if they are closed.

If you imported and vectorized drawings, during the vectorization process on traditional scanned drawings, 
triangles are added on the lines' intersections to break the artwork in segments. This way, when you paint a line, it 
will not repaint the entire drawing, only the relevant segment—see Creating Break Triangles on page 556.

 

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint a 
section by manually painting over the lines. This is useful when the vectorization triangles are not placed as you 
would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, where 
there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only 
show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are not 
added one on top of each other. 

NOTE: To avoid repainting specific colours, see Protecting Colours

How to access the Repaint Tool

 1. In the Tools toolbar, select the Repaint  tool. You can also find the option in the Tool Properties view 
when the Paint tool is selected. 

 2. In the Camera or Drawing view, click on the zones to repaint. You can also make a lasso or marquee selec-
tion around several zones.

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Camera or Drawing view, draw on the zones to repaint.
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Repainting a Selection
The Repaint Selection command is used to repaint any art inside a selection. You must first draw a selection using 
the Select  tool in order for this command to be available. You can also click on the colour swatch in the colour palette 
to automatically repaint your selection.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the drawings 
contained within the same layer. You must enable the Permanent Selection  option in the Select tool Tool Properties 
view and then select an area of your drawing using the Select  tool in order for this command to be available. The 
Permanent Selection option lets you maintain the same selection throughout the drawings of a same layer.

NOTE: To avoid repainting specific colours, see Protecting Colours

How to repaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones to repaint. 
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 3. To repaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint 
Selection or Repaint Selection on All Drawings.
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Repainting Outside a Selection
The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection has been 
drawn using the Select   tool, the entire drawing will be repainted.

The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection on all the 
drawings contained within the same layer. You must enable the Permanent Selection  option in the Select tool Tool 
Properties view and then select an area of your drawing using the Select  tool in order for this command to be 
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a same 
layer.

NOTE: To avoid repainting specific colours, see Protecting Colours

How to repaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones you do not want to repaint. 

 3. To repaint outside the selection on all drawings,  enable the Permanent Selection  option in the Select tool 
Tool Properties view. 

 4. Do one of the following: 
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 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Repaint Out-
side Selection or Repaint Outside Selection on All Drawings.
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Unpainting a Selection
The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first draw a 
selection using the Select  tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection on all the 
drawings within the same layer. 

You must enable the Permanent Selection  option in the Select tool Tool Properties view and then select an area of 
your drawing using the Select  tool in order for this command to be available. The Permanent Selection option lets 
you maintain the same selection throughout the drawings of a same layer.

How to unpaint a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint Selec-
tion or Unpaint Selection on All Drawings.
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Unpainting Outside a Selection
The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no selection 
have been drawn using the Select  tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection on all the 
drawings within the same layer. You must enable the Permanent Selection  option in the Select tool Tool 
Properties view and then select an area of your drawing using the Select  tool in order for this command to be 
available. The Permanent Selection option lets you maintain the same selection throughout the drawings of a 
same layer.

How to unpaint outside a selection

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the zones you don't want to unpaint. 

 3. To unpaint the selection on all drawings,  enable the Permanent Selection  option in the Select tool Tool 
Properties view. 

 4. Do one of the following: 

 l From the top menu, Camera or Drawing view menu, select Drawing > Paint > Unpaint 
Selection or Unpaint Selection on All Drawings.
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Selecting Strokes with the Current Colour
You can select zones painted with a specific colour swatch.

How to select the zones painted with the current colour

 1. In the Colour view, select the colour from which you want to select the corresponding zones.

 2. Do one of the following:

 l Select Drawing > Select Strokes With Current Colour. 

 l Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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Creating Break Triangles
The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A single 
colour, such as black, is often used when tracing a clean version of a rough sketch. However, when it comes time 
to soft trace the lines in different colours, the flattened or unflattened clean brush strokes can suddenly become 
time consuming to ink. 

Toon Boom Harmony lets you create triangular breaks at line intersections. These intersections are the probable 
locations where colour line breaks naturally occur, such as where a sleeve meets a hand.

How to create breaking triangles on a drawing

 1. In the  Drawing or Camera view, use the Select tool to select part or all of the drawing to be broken.

 2. Select Drawing > Create Breaking Triangles. If your brush strokes are not flattened, they will be 
flattened automatically before the breaking occurs.

 3. Use the Repaint tool  to paint the outline of different colour zones with different colours.
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Closing Gaps
T-HFND-004-014

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between the two 
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View > Show > Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be flattened with 
your artwork. They will cut overlapping drawing strokes in two pieces.

The gap automatically closes.
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Picking a Colour with the Dropper Tool
While working in the Camera or Drawing view, you can use the Dropper  tool to pick a colour from your drawing 
without going to the Colour view. 

NOTE: To learn more about the Dropper tool options, see the Reference guide .

How to use the Dropper tool

 1. Do one of the following:

 l In the Tools toolbar, select the Dropper  tool.

 l From the top menu, select Drawing > Drawing Tools > Dropper.

 l Press Alt + D. 

 2. In the Camera or Drawing view, click on the desired colour.

 l If you're using another drawing tool such as the Paint tool, you can temporarily hold down the D 
key and click in your drawing before releasing the key to pick your colour. When you release 
the key,  you will return to your previous tool. You may also want to select the zones painted 
with the colour currently selected in the Colour view. This can be useful for removing rough 
lines from a clean drawing.
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Inking Lines
T-HFND-004-012

Although pencil lines can be painted in much the same way as closed zones, you can use the Paint, Repaint, 
Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you have a drawing, such 
as the one below, and you use the Paint tool to paint one of the lines, the entire line is painted.

However, if you select the Ink  tool instead and click on the same pencil line, only the segment that you clicked on 
between two intersections will be painted.

Painting and inking can be used in combination depending on what you need to paint. If you need to ink a 
character’s outline in black, it might be easier to use the Paint tool. If you need to paint the outline of a character’s 
neck with a tan colour and its shirt outline blue and both the neck and shirt belong to the same continuous outline, 
then the Ink tool might prove more useful.

NOTE: Unless you are repainting all the lines in an entire animation sequence, do not use the Apply Tool to 
All Drawings option. Since the line positions change a lot over time, you risk painting lines that should not be 
painted.

NOTE: To avoid repainting specific colours, see Protecting Colours

NOTE: To learn more about the Ink tool options, see the Reference guide .

How to use the Ink tool

 1. In the Tools toolbar, select the Ink  tool located in the Paint tool drop-down menu.  
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 2. In the Drawing or Camera view, click on the pencil lines to repaint.

 l The newly inked segment is always moved on top of all other pencil strokes, even if it was 
behind all other pencil strokes before it was inked. To reverse that behaviour, disable the Raise 

 option in the Tool Properties view.

 l Hold down Alt while clicking a segment to do the opposite option from the Raise mode current 
state.  The inked segment will be sent to the back or forward, even if it was in front or behind all 
other segments to begin with.

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com

561

http://www.chrisdiazart.com/


Chapter 7: Colours     About Painting

Verifying Painted Zones
When the ink and paint process is completed, it's always a good idea to verify that every zone was painted 
properly.

The first step to check your ink and paint is to go through all  your drawings and verify that there are no colour 
mistakes. You can use the F and G keyboard shortcuts or the Preview option available in the Xsheet.

The backlight produces Produces a silhouette effect by changing the drawing’s coloured areas into a single dark, 
solid colour. Use this to verify the completeness of the ink and paint process. Any unpainted zones can be seen 
as the light shows through the unpainted areas of the silhouetted drawing.

How to preview drawings from the Xsheet

 1. First, save your scene. 

 2. Do one of the following:

 l From the top menu, select File> Save. 

 l Click the Save  button. 

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. In the Xsheet view, select the range of drawings or the whole column to preview.
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 4. In the Xsheet View  menu, select View > Preview Selected Drawings or press Alt + P.

The Play window opens.

 5. Play your drawings.

 6. Select the Preroll option to see blank frames at the beginning and end of the animation sequence while loop-
ing the playback.

How to use the backlight

NOTE: This feature is only available in the Drawing view.

 1. Do one of the following:

 l From  the top menu, select View > Backlight.

 l Press Alt + Shift + B. 

 2. Verify the drawings in the Colour Art to make sure that all the areas are painted. From the Camera or Drawing 
View menu , select View > Switch to Colour Art or press L.

 3. In the Art Layer toolbar, click the Preview All Art Layers  button  to see the colour zones with lines to 
ensure that you did not forget any spots between the colour filling and lines.
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About the Edit Gradient and Texture Tool
T-HFND-006-019

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its position 
in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set the first 
texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can select the 
next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s position, 
angle and scale settings instead of the default ones, you can store your own settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured 
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements 
independently at the same time.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

 l In the Tools toolbar, select the Pencil Editor  tool. 

 l From the top menu, select Drawing > Drawing Tools > Pencil Editor.

 2. Click on the pencil line to be modified to bring up its contour envelope.
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 3. Select one of the contour points around the envelope and move its position to change the size of the tiled 
texture or gradient. You can also pull directly on the lines of the contour envelope or play with the Bezier 
handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled texture to 
be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to look squashed.

Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the number of 
tiles, while expanding it will increase the number of tiled images. 

This editing technique does not just work on texture fills, but can also be applied to pencil lines drawn with 
a textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line

 1. Do one of the following:

‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.
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 3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull on the top of 
the editor controls to stretch the tiled texture throughout the length of the stroke. 

As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is distributed 
in the pencil line’s envelope. The envelope still acts as a boundary for the texture or gradient.

 

 4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central vector line. 
This is another way to resize the texture tile. Instead of stretching or shrinking it vertically, this motion 
stretches or shrinks it vertically. As gradients are parallel to the pencil line’s central vector, stretching them 
vertically gives no visual result.

How to use Edit Gradient/Texture tool to edit the texture and gradient of a pencil line

 1. Do one of the following:
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‣ In the Tools toolbar, select the Edit Gradient/Texture  tool. 

‣ From the top menu, select Drawing > Drawing Tools > Edit Gradient/Texture. 

‣ Press Shift + F3.

 2. Click on the pencil line to be modified to bring up the editor controls.

 3. Use the top editor controls edit the gradient.

 4. Use the bottom controls edit the “brush” texture.
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Using the Edit Gradient and Texture Tool 
T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l From the  Camera or Drawing View  menu, select Drawing Tools > Edit Gradient/Texture.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Storing the Gradient and Texture Settings
You can store the position, scale, and angle of a given gradient or texture painted zone to reuse on other ones as you 
paint them. 

How to store gradient and texture settings

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. In the Camera or Drawing view, select the gradient or texture zone to store.

 3. In the Tool Properties view, click the Store Colour Gradient  button.
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Using the Stored Gradient and Texture Settings
You can use the gradient and texture settings previously stored to paint zones using those exact parameters. 

How to use the stored gradient and texture settings

 1. In the Tools toolbar, select the Brush  or Paint  tool.

 2. In the Tool Properties view, click the Use Stored Colour Gradient  button.

 3. In the Camera or Drawing view, draw and paint.
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Chapter 8: Rigging
Harmony is a great tool for building characters. You can use different techniques and features to break down your 
puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create very 
advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with those 
concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformation on page 669.
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Chapter 8: About Rig Types
T-RIG-001-001

A rig is the process in which you will take apart the multiple pieces of your character and then reattach them 
together to get them to move individually. Harmony provides you with a multitude of tools to help you build 
characters. From the simplest of rigs, to a fully rotating character. There are about as many ways to rig a 
character as there are individuals who make them. The complexity of the rig is often determined by the level of 
animation to be achieved.
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About Simple Rigs
T-RIG-001-002

Simple rigging is very fast and easy to do. It is built as follows:

 l All the body parts are independent

 l All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by a 
parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a straight 
trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand to move 
along a curved path.

575



Chapter 8: About Rig Types     

About Drawing Hierarchy Rigs
T-RIG-001-003

When you want one part to follow another part, such as the forearm following the arm, you can attach the layers 
one to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate the 
forearm into the arm layer. They will still be parented, but you can access the forearm directly without having to 
enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select 
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, 
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is often a 
good solution.

NOTE: 
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without having to encapsulate 
layers into each other. These techniques are a great improvement over the less efficient and time consuming 
method of creating parenting between your layers by inserting symbols into other symbols. Therefore, rigging 
with symbols inside symbols is NOT recommended.
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About Peg Hierarchy Rigs
T-RIG-001-004

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that do 
not contain drawings. They are motion paths that you can use to control your entire puppet or advanced 
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale a 
body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that could 
be attached to that part. 

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer 
follow the same trajectory.
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About Scene Setup for Rigging
Planning your rig is an essential step in avoiding missteps at later stages. Once a rig has moved on to the animation 
level, it becomes more difficult to fix potential blunders, since updating the rig scene doesn't have repercussions on 
rigs outside of that scene.  These different topics will help you avoid such mistakes.
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About Models
To begin breaking down your puppet, you must first import your character into a new project. You can also draw 
your character directly in the scene.

You can import your character in several different formats: 

 l Library template—see Library

 l Bitmap image or picture

 l External vector format

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and 
scale it to fit inside the safe area frame.

If you have several views of your character, place each view in a separate cell and center them one on top of 
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the same 
size.
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Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. Then, 
import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all the 
elements you want to import as a single layer in Harmony are grouped together in their own folder. Any layer that is 
not in a folder group, by itself or otherwise, will not be imported.
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About Size Relation
Understanding the relative size of every character and prop is important for maintaining consistency and structure 
throughout your project.

A production may contain many characters and props. It is not unusual for these to have been created by different 
people. If there is no size control implemented, the characters and elements created by different artists can vary 
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The 
animator or person doing the scene setup will then have to scale them to the correct size.

When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is 
scaled to its proper size, the outline may be so thin that the difference between one character's outline and 
another's will not look very good.

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling 
them so they are in proportion with each other. This line up is very important and should be handed to any 
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body 
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually 
done during the character design step. When the character builder imports the model to the break down scene, 
the size relation should be correct.

Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can 
display the field chart using the Show Grid option in the Camera and Drawing views.
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How to display the field chart

 1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).

‣ Click the Show Grid  button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good idea to 
create and save pens with precise sizes and parameters to trace and design your models and break downs—see 
About the Brush Tool on page 121.
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Setting Preferences for Rigging
 

Before you start adding layers to your puppets, make sure the Default Separate Position  for Elements and the 
Default Separate Position for Pegs preferences are enabled.

With the Default Separate Position preferences selected, when you create new layers, their X, Y and Z axes are 
independent from each other.

By default, the Default Separate Position for Elements preference is enabled. For cut-out animation, you want to 
have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at the 
same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This 
gives you more freedom when animating with motion keyframes and nudging parts forward and backward over 
time.

How to set the Default Separate Position options

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l Mac OS X: Select Harmony Premium > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. In the Preferences dialog box, select the General tab.

 3. In the Settings section, select the Default Separate Position for Elements and the Default Separate 
Position for Pegs options.

 4. Click OK.
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About Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention chart before 
starting the project. When dealing with thousands of characters, pieces and puppets, it is easy to get lost. Proper 
naming of both drawing layers and drawing substitutions is essential to keeping your workflow consistent throughout 
your project.
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Naming Drawing Layers
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient in 
later steps. 

One common practice is to add one or two letters for the character/prop name, so that we don't make it too long. 
You can then add the name of the part that you've separated. It is recommended to add an indicator of the position 
of your character's symetrical pieces to keep track of which part you are selecting. Common practice is to add 
either "F" or "B" (for front and back view) or "R" or "L" (for right or left). Avoid using spaces in between the words 
and opt for an underscore instead.

 l Character Orcus's right arm = 

 OR_arm_F 

 or 

 OR_arm_R.

Pink: Front or Right 

Blue: Back or Left

In the event that you've forgotten to add a prefix or suffix to your character's drawing layers, you can add them 
after your layers have been created.

How to add a prefix or suffix to a series of layers

 1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).
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 2. In the Scripting toolbar, click the Add Prefix or Suffix Script  button. If the Scripting toolbar is not visible, 
you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the Add Prefix or 
Suffix Script  button is not visible in the Scripting toolbar.

The Add Prefix or Suffix dialog box opens.

 3. Select the Prefix or Suffix option depending on what you want to add to the layers' name.

 4. Type the prefix or suffix information to be added to the layer's name.

 5. Click OK.

 6. The defined prefix or suffix is added to the selected nodes and layers.

How to remove a prefix of suffix to a series of layers

 1. In the Network or Timeline view, select all the nodes or layers to rename or press Ctrl + A (Windows/Linux) or 
⌘  + A (Mac OS X).

 2. In the Scripting toolbar, click the Add Prefix or Suffix Script  button. If the Scripting toolbar is not visible, 
you can display it by selecting Windows > Toolbars > Scripting from the top menu. If the Add Prefix or 
Suffix Script  button is not visible in the Scripting toolbar, see the Scripting guide

The Add Prefix or Suffix dialog box opens.

 3. Select the Prefix or Suffix option depending on what you want remove from the layers' name.
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 4. Type the prefix or suffix information to be deleted from the layer's name.

 5. Click OK.

 6. The defined prefix or suffix is removed from the selected nodes and layers.
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Naming Drawings Substitutions
We recommend that you use a naming convention for your drawings. Especially if you combine all the angles of a 
character in the same breakdown scene, it is a good idea to identify each angle used.

Before breaking down the characters for your production, we recommend that you create a drawing name convention 
that represents the angle used. For example, use "f" for front, "s" for side, "q" for three-quarter so that the drawing 
name looks like this: f1, f2, f3, s1, s2, etc. This will be quite useful during animation and drawing substitution. Since 
drawings are displayed in alphabetical and numerical order, all the drawings for the front view will be together, then 
all the drawings for the three quarter view, and so on.

Keep in mind that in the drawing substitution library, drawings will show in alphabetical order. If you want them 
positioned in a certain order, make sure you name them accordingly.

How to add a prefix to one or more drawings

 1. In the Timeline view, select the drawing range to rename.

 2. Do one of the following:

‣ Right-click on the selection and select Drawings > Rename Drawing with Prefix.

‣ From the top menu, select Drawing > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.

 3. Type the characters you want to add before the current drawing name.

 4. Click OK.
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NOTE: To rename a drawing, select the drawing and use the Rename Drawing option. Ctrl + D (Win-
dows/Linux) or ⌘  + D (Mac OS X). or . Do not double-click on the frame and write a new name, as this will 
create a new drawing and hide your actual one. Note that the hidden drawing has not been deleted and is still 
located within the element folder. Simply retype the name and it will reappear.
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About Character Breakdown
T-RIG-001-006

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what parts 
will be broken apart and how they will be divided. Will the hair be separated into one, two or three sections? Will the 
hand be separated from the sleeve? To determine what is best for your character, observe the model in the Camera 
or Drawing view.

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and the 
eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the eyeball. For a 
more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth shape, 
teeth, tongue and interior one from another.
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Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full 
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and 
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a 
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly overlapping and 
complete. A common mistake is to trace the part just as it appears on the model.
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Tracing the Model
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Win-
dows/Linux) or ⌘  + R (Mac OS X)—see .

 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select a drawing tool.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see  .

 5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are 
easy to manipulation, modify or redraw. There exists two easy ways to do this:

 l By using the Polyline tool

 l By drawing with the Pencil tool, then smoothing your lines with the Smooth Editor tool

If you are working in the Drawing view, click the Light Table  button  in the Drawing View toolbar to 
display the other layers in washed out colours. You can also press Shift + L.

 6. If you want to close a shape without drawing an actual stroke, you can use the Stroke tool in the Tools tool-
bar to create an invisible hairline .
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 l Select View > Show > Show Strokes or press K to display the invisible lines.

 7. In the Tools toolbar, select the Paint or Paint Unpainted  tool to colour your drawing.

 8. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 9. In the Camera or Drawing view, paint your drawing.

 10. In the Tools toolbar, select the Select  tool. Select your drawing and flatten the lines by clicking the Flatten 
 button in the Tool Properties view.

 11. If your lines are composed of several pencil strokes, you might want to combine them into one single smooth 
pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool Properties view, click 
the Merge Pencil Lines  button.

595



Chapter 8: About Rig Types     About Naming Conventions

 12. Repeat the entire process for every body part that you wish to make animatable. 
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About Cutting the Character into Pieces
If you do not want to redraw all the artwork for your character, you can use the cut away technique where, with the 
Cutter tool, you select and send pieces of the model on a new layer.

The first step in breaking down your character is to do a rough cut down of the main parts, such as the body, arms, 
legs and head. Using the Create Drawing from Drawing Selection feature lets you automatically create layers and 
copy your selection in it.
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Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. 

Breaks a character into its main body parts. There is no need to create any layers prior to this process. Make sure 
your model is well centered and sized in the Camera view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the 
artwork of the part you want to break down. You will clean the extra bits and pieces later.

Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines 
and colour zones.

How to break down the main parts

 1. In the Timeline view, select the cell of the model that corresponds to the first view to break down.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press 
Alt + S.

 l In the Tool Properties view, you can switch to the Lasso  selection mode.

 3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the Cut-
ter tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your previous 
selection.
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 4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Windows/Linux) or 
⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

 5. In the Layer Name field, type the name of the layer you want to create following the naming convention you 
established previously.

 6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You do 
not want to cut the artwork from the colour model.

 7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame number 
as the cell it was taken from.

 8. Repeat the previous steps for each main body part.
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Breaking Down Secondary Parts
You should now have a layer for each main part of the character for the first view to break down. You are now ready 
to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this time you will cut 
away the artwork from the layer it has been selected from.

How to break down the secondary parts

 1. In the Timeline view, lock your model layer by clicking its Lock  button.

 2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

 3. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press Alt + S.

 4. In the Camera view, create a selection around the part to break down.
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‣ If you click on a zone, the Cutter  tool will select the zone and end the selection at the first point of 
intersection that it meets. Click on the line with the Cutter tool to select it up to the next intersection.

 5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

 6. In the Layer Name field, type the name of the layer you want to create following the naming convention you 
established previously.

 7. Select the Cut Artwork From Source option to remove the selected artwork from your original drawing. In 
this case, you want to cut the artwork from the colour model.

 8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame number 
as the cell it was taken from.

 9. Repeat the previous steps for each body part.

NOTE: 
If you forgot to add some artwork to a layer you previously created, you can always add it later. 

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from Drawing 
Selection dialog box by pressing F9 (Windows/Linux) or ⌘  + F9 (Mac OS X). In the dialog box, select an 
existing layer from the list instead of typing a new name. Click OK to add the artwork to the existing drawing in 
the layer you selected.
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Breaking Down Other Views
If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

 l Breaking down the new view in a new set of layers

 l Breaking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are break-
ing down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Repeat the following steps for each extra view you need to break down.

How to break down the other views

 1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't forget to 
unlock the layer.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, in the Tools toolbar select the Select  tool or press Alt + S.

 2. In the Camera view, create a selection around the first part to break down. 

 3. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.
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 4. In the Layer Name field, select the corresponding layer from the list if you want to use the same layers or type 
a new name if you want to create a new layer.

 5. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You do 
not want to cut the artwork from the colour model.

 6. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as the cell it 
was taken from. It is not incorporated in the other view's drawings.

 7. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views, follow the exact same process as you did for the first view 
you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down Other Views on 
page 604.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to 
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing Parts and Articulations
Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and 
complete the articulation.

Cleaning the Parts

You will need to use a series of drawing tools to clean the parts:

 l  Brush tool

 l  Eraser tool

 l  Select tool

 l  Cutter tool

 l  Contour Editor tool

 l  Paint tool

 l  Close Gap tool

How to clean your drawings

 1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

 2. In the Timeline view, select the cell containing the drawing to fix.

 3. In the Camera view, delete the extra bits using the Select  or Cutter  tool. You can also use the 
Eraser  tool.

 4. Draw the missing lines using the Brush  tool. If you use the Brush tool, it is recommended that you 
enable the Auto-Flatten  option in the Tool Properties view.
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 5. Using the Paint  tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap 
 tool or press Alt + C.

 6. Reshape your lines using the Contour Editor  tool or press Alt + Q.

 7. Using the Select  tool, select the entire drawing and click the Flatten  button in the Tool Properties 
view to flatten your drawings.

 8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be present 
in your drawing or press K.

 9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary invis-
ible lines in the drawing.

 10. Repeat this entire process for each drawing to fix.
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Distributing to Layers
When breaking down a character, you can distribute each selected art stroke to a new layer. 

Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke. 

If one part of your puppet is composed of several strokes, you must group them before distributing them onto new 
layers. 

NOTE: You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the art strokes you want to distribute to different layers.

 3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers  button in 
the Tool Properties view.

Drawing layers are created in the Timeline view, each corresponding to the different strokes or groups of 
strokes selected. Each stroke or group of strokes is distributed into each new Drawing layer. The selected 
strokes in the original drawing layer are removed.
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About Articulations
Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move 
properly and will not look good.

If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect will 
create the joint for you.
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Creating Classical Articulations
Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent 
results, but it's not the most efficient method. In many instances, it causes limitations and extra drawing 
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually a 
circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping the 
bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

 1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the upper 
arm.

 2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor  tool.

 3. In the Colour view, select an outline colour.

 4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part in a 
half-circle shape.

If you are working in the Drawing view, click the Light Table  button in the Drawing toolbar or press 
Shift + L.

 5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines that may 
be present in your drawing.

 6. In the Drawing or Camera view, select all the strokes in your drawing.

 7. In the Tools Properties view, click the Flatten  button.

 8. In the Drawing or Camera view, select all the strokes in your drawing.

 9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary, invis-
ible lines in your drawing.

 10. Repeat the previous steps for the other articulations.

 11. In the Timeline  view, select the cell of the part that will be on top of the joint.

610



Harmony 14 Premium - User Guide

NOTE: When placing rotation pivots later on, make sure they are positioned at the centre of the 
articulation.
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About Auto-Patch Articulations
Harmony has a very efficient node to automatically patch an articulation without you having to do any line 
adjustment or colour overlapping. You can draw your two pieces with their complete lines overlapping each other 
in semicircles and the Auto-patch node will create a perfect articulation from it.

In order for the Auto-patch to work on your puppet, you must draw the outline with the Pencil tool (pencil lines) on 
the Line Art layer of your drawing, and then paint the colour on the Colour Art layer.

You can use this technique in even more efficiently by adding extra lines in the Overlay layer of your drawing to 
create a fold illusion for a bent elbow.
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About the Auto Patch Node
The Auto Patch node is used mainly when creating joint patches for cut-out puppets drawn with pencil lines and 
painted in the Colour Art layer. Instead of removing a portion of the outline to attempt to create a seamless joint, you 
can draw complete pieces, and with the Auto Patch node, automatically create a perfect articulation.

The requirements for this effect to work are:

 l Drawing outlines must be drawn in pencil lines

 l Drawing outlines must be drawn in the Line Art layer

 l Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that when you 
paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil line.
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When using the regular patch technique, recommended for the brush line, the result with pencil lines is very odd 
looking because the colour fill zone is bigger than the pencil line inner contour.

Instead of using the regular patch method, you can use the Auto Patch node. It will automatically extract the 
Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be covered.

The node connection for the Auto Patch is quite simple. Once your basic character rigging is done, add the Auto 
Patch node to the joints you want to cover. There is no need to set any parameters. 

Refer to the following example to connect this node.
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About Ordering Layers
T-HFND-005-005

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in the 
Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind. Second, you 
can use the Z-axis nudging (forward and backward) if you have extra views included in the same layers (front, three-
quarter, back, etc.).
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Ordering Layers in the Timeline View
T-HFND-005-006

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be displayed 
behind. If you have multiple views, you should order your layers based on the most common view, which is 
generally the three-quarter front.

How to order layers

 1. In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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Ordering Layers in the Node View
T-HFND-005-007

The Node view allows you to reorder layers without breaking any hierarchy. For example, if you want the Head layer 
to appear behind all the facial features, in the Timeline view, you cannot simply move the layer down because you 
will break the parenting between the head layers. In the Node view, since you have a set of flexible connections, you 
can change the Composite node ordering without breaking the parenting between the nodes.

The Composite node ordering corresponds to your timeline ordering unless the Node view's organization is too 
complex for the Timeline view to display. The element connected in the left-most port of the Composite node is 
displayed in front in the Camera view and the one connected in the right-most port is displayed behind.

How to order layers in the Node view

 1. In the Node view, select the node's output cable connected to the Composite node and drag it to its new pos-
ition.
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About Z Nudging
T-HFND-005-008

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as the 
hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the 
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE: You will do the same for the layers that are not in the right order on the extra views. Do not place the 
drawing on another layer. You want to keep all your drawings of the body parts in the same layers like a box con-
taining all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:

 l Up and down (Y-axis)

 l Left and right (X-axis)

 l Backwards and forwards (Z-axis)
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Nudging Layers
T-HFND-005-009

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be 
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the Timeline 
view. The forward-backward position can also be animated over time.

How to nudge layers backwards and forwards

 1. In the Tools toolbar, select the Transform  tool. Make sure to enable the Animate  mode.

 2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is around the 
Camera view before selecting the element.

 3. To move the element forward,  press Alt + Up Arrow and to move the element backward,  press Alt + Down 
Arrow.
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About Pivots
T-RIG-006-001

Even with a complex hierarchy, a rig is useless without positioning the proper pivot points. This will allow the 
puppet's pieces to rotate correctly. The arm needs to rotate from the shoulder and stay attached to the torso, so its 
pivot point needs to be positioned accordingly. A good way to achieve this is to position the pivot point exactly in the 
center of the articulation.

The initial position of the pivot point is always at the center of the scene. Sometimes there will not be an obvious 
place of rotation to place the pivot point, but it's a good idea to reposition the pivot to the best transformation point. 
For instance, the master peg, which generally controls the entire rig, is often best positioned between the character's 
feet.
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About Permanent Pivots
T-RIG-006-002

This is a permanent pivot, sometime referred to as peg pivot, that is applied to the entire drawing or peg layer. If 
you modify its position, it will be changed for the entire layer, modifying the animation, scale and rotation 
interpolation. The permanent pivot is set using the Rotate, Translate or Scale tool. The Transform tool will only 
move that pivot temporarily for positioning purposes, but the animation interpolation will be done from the original 
permanent pivot's position. The Transform tool is designed to move the pivot temporarily during the animation 
process. It also permits you to select multiple pegs and apply a common temporary pivot.

To permanently move a peg pivot, use the Rotate  or Scale  tool. You can also directly type the values in the Layer 
Properties window in the Pivot section's (x) Axis and (y) Axis fields.

In the Layer Properties window, in the Drawing Pivot section, select the Don't Use Embedded Pivot option to 
use the permanent pivot.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate  
tool.
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Setting Permanent Pivots
T-RIG-006-004

In this section, we'll take a look at one of the options we have for setting pivots. The permanent pivot allows you to 
push your rigs to great lengths without having to worry about repositioning your pivot once it is set.

How to set the pivots with the Rotate tool

 1. In the Advanced Animation toolbar, select the Rotate  tool.

 2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, you can 
also hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on the piece whose pivot you want to set.

 3. In the Camera view, drag the blue pivot to reposition it.

 4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as where 
to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE: If you added other pegs to your rig, you must set their pivot using the same method.

623



Chapter 8: About Rig Types     About Ordering Layers

Setting Multiple Permanent Pivots
You can simultaneously set the position of pivots for several drawing layers or pegs  that you would like to rotate 
and scale from the same point of origin, 

How to set pivots on multiple pegs

 1. Select the multiple pegs or drawing layers from either the node view or timeline view.

 2. Select any Advanced Animation tool, such as the  Rotate tool. 

 3. Reposition your pivot using the Advanced Animation tool

NOTE: Never use the Transform tool to permanently position pivots. The Transform tool only temporarily 
repositions it to accommodate your transformation, usually during the animation process.
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About Drawing Pivots
T-RIG-006-003

The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own pivot. If you have 
many different views of a character within one layer, the pivot positions can be different and the animation will adjust 
to the pivot. The Drawing pivot can also be referred to as embedded pivot. If you are not mixing different views within 
the same layers or are using pegs to animate your layers, it is recommended to use the permanent pivot.

You can set a different pivot for each one of your drawings. For example, if you have a series of drawings from 
different views, they are not likely to rotate from the same location. In that case, you can set a different pivot for 
these drawings by using the Drawing Pivot  tool.

In the Layer Properties window, in the Drawing Pivot section, select the Apply Embedded Pivot on Drawing 
Layer option to use the drawing pivot directly on the drawing layer. If you want to apply the drawing pivot to a parent 
peg to force the peg to follow the drawing pivot variations, enable the Apply Embedded Pivot on Parent Peg 
option.
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Setting  Multiple Drawing Pivots
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the same drawing 
pivot, such as all of the three-quarter hands, you can select all of these hands cells and set the pivot all at once. If 
your pivot is already correctly set on your first drawing, copy and paste that pivot onto the other drawings in the 
Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a drawing while 
the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range

 1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on hand-1.

 2. In the Timeline view, select the cell that contains the correct pivot.

 3. From the top menu, select Edit > Copy.

 4. In the Timeline view, select the cell range that requires the same pivot.
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 5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X).

The Paste Special dialog box opens.

 6. In the Paste Special dialog box, select the Advanced tab.

 7. In the Drawings section, select the Update Drawing Pivot option.

 8. Click  OK.

NOTE: You can also copy and paste the pivot from one drawing to another using the keyboard 
shortcuts Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X) when the draw-
ing pivot tool is active and the focus is around the Camera view.
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About Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act the same as 
the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot. Inside a symbol, each drawing 
can have its own pivot. If you are not mixing different views within the same layers or are using pegs to animate 
your layers, it is recommended to use the Peg pivot.
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Setting Symbol Pivots 
If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the articulations. You can set 
the pivots using the Rotate tool which sets it for the entire layer or you can set the pivots directly on your symbol and 
have a different pivot for each symbol cell. By default, when you create symbols, the symbol pivot is located at the 
centre of your drawing. You will need to move it onto the shoulder or elbow.

You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must be at the top 
level of your character building scene and not inside the symbols.

By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different pivots for 
different cells, refer to the following procedure.

Do the following steps for each layer in the Timeline view.

How to set the pivots on a symbol

 1. In the Tools toolbar, select the Drawing Pivot  tool or select Drawing > Tools > Drawing Pivot.

 2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.

 3. If you only want to set one pivot for your symbol, in the Tool Properties view, select the Set the Pivot for Sym-
bol on All Frames  button.

 l Deselect this button if you want to set a series of different pivots for your symbol's cells.

 4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the desired 
location.
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 5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell and in the 
Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the actual drawing. 

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This 
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the position 
and exposure of your drawing layers independently in the Timeline view. It also makes it easier to create a hierarchy 
of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 

NOTE: It is also possible to make drawing layers the children of other drawing layers. Just like the way anim-
ating a peg animates its children layers, animating a drawing layer with children will also animate its children lay-
ers. 

How to create parent pegs for your layers in the timeline

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected layers.

s
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At this point, in the Node view, the layers look tangled. 

 3. In the Node view, select all the nodes and, in the  Network View toolbar, click the Order Network Down  
button.

How to parent drawing layers to pegs in the Node view

 1. From the Node view, select all the drawing layers for which you want to create pegs.

 2. Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS X)

 3. Pegs are created, named and connected to their child drawing layers. They will not automatically connect 
if the top port of your drawing layer is already connected to another node.

 4. If the nodes are tangled,  select all the nodes and, in the  Network View toolbar, click the Order Network 
Down  button.
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Creating Hierarchies
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should influence 
other limbs, and how they can move independently. For example, when rigging a simple character's arm, you can 
make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. This way, if the 
character moves their forearm, the hand will follow, and if they move their arm, the forearm and hand will follow. 

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can make a 
hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig the legs to the 
hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want tomake a child layer

 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you are not drop-
ping the child layer between two layers. 
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 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at the root. 
While rigging, if you want several layers to have a common parent, but no existing part of your rig can 
serve as that parent, create a new peg and nest those layers under that peg.

NOTE: In the Timeline view, you can unparent layers by holding down Shift and dragging the selected par-
ents away from the child layer. Drop your selected between other layers.

How to create a hierarchy in the Node view

 1. Position your nodes as if they were in a tree representing their intended hierarchy, with the highest nodes 
on top and the lowest nodes at the bottom.
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 2. Drag a cable from the output port (bottom) of a node which you want to make into a parent node.

 3. Connect the cable to the input port (top) of the node which you want to make into its child node.

 4. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at the root. 
While rigging, if you want several layers to have a common parent, but no existing part of your rig can serve 
as that parent, create a new peg and nest those layers under that peg.

NOTE: In the Node view, you can unlink nodes from their parent and child by holding down the Alt key and mov-
ing them anywhere in the node view. This will delete the node's connections instantly. If the node has both a par-
ent and a child, this will automatically connect its former parent to its former child.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they're 
rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Likewise, in the Node view, 
layers that are connected to the leftmost port of a composite are rendered on top of layers connected to ports to the 
right. Should you need to change a layer's order while animating, you can nudge this layer's position on the Z-axis to 
override the layer order and force it to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.
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 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the focus on 
the Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.
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Adding the Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows you to 
manipulate the entire rig from a single layer, without having to manipulate each individual part. This is useful for 
positioning and scaling your character relative to the scene, as well as to animate your character's trajectory when it 
has to move between areas of the scene.

How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is 
already parented to that peg.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers are 
added above the already parented layers, move that parented layer back on top of the layer stack.
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How to add a master peg in the Node view

 1. In the Node view, hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) and select each node that you want to 
attach to your new peg.

 2. Do one of the following:
 l From the Node view menu, select Insert > Peg.

 l Press Ctrl + P (Windows/Linux) or  ⌘  + P (Mac OS X).

 3. Rename the new peg Master plus the character's name. 
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Fine-Tuning the Rig
Once your rig is done, you have access to a lot of tools and tricks that you can add to make your rig even more 
efficient. Colours that can help you distinguish certain layers, or parts of your node view, cutter systems and much 
more. For more great options and features on creating powerful rigs, refer to Deformation.
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Invert-Cutting
When rigging a character, there may be instances when you want to have the ability to move a particular piece to 
give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the drawing 
sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't want to be visible.

How to mask an object in the Node view

 1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece to cut.

 2. From the Node Library view, select the Favorites category and then select the Cutter node.

 3. Drag the Cutter node to the Node view.

 4. Connect the object you want to cut to the Cutter node's right port and connect the Cutter to the Composite 
node.
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 5. Pull out a cable from the masking object and connect it to the Cutter node's left port.

 6. Your masking effect is most likely inverted and what you want to cut is probably showing. Click the Mask 
node's yellow button to open the Layer Properties window. In the Layer Properties window, enable the Inver-
ted option.

 7. From the Tools toolbar, select the Transform  tool and move the cut object within the masking zone.
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Changing Composite Modes
When you create a character with Harmony, you have to connect all your nodes in the Composite node. The 
Composite node takes all the different images coming out of your drawing nodes and flattens them into one single 
image.

This is useful when it is time to apply an effect to your entire character or group your layers for a more organized 
network.

The regular Composite node will flatten all the pieces into one image preventing interaction with props or 
characters connected to a different Composite node. That is why you have to change the Composite node's type 
to a special one that will still output one single image but will not flatten the drawings together. This will allow you 
to nudge your drawings on the Z-axis so that parts of you characters can pass in front and behind other characters 
and objects. This Composite type is called Pass Through.

How to change your Composite node to a Pass Through

 1. In the Node view, click on the Composite node's Properties button.

The Layer Properties dialog box opens.

 2. From the Mode menu, select Pass Through.

 3. Click Close.
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Adding Displays
The Display node lets you see a section of the network in the Camera view. By renaming the Display node with your 
character's name, you can quickly identify it in the Global Display toolbar and isolate your character to see it better 
while working on it.

If you do not have a Display node in your network, you can add one by selecting one from the Node Library view and 
dragging it into the Node view.

How to add a Display node

 1. In the Node Library view, select the IO tab and select the Display node.

 2. Drag the node to the Node view.

 3. Connect the Composite node's output port into the Display node's input port.

How to rename your Display node

 1. In the Node view, click on the Display node's Properties button to open the editor.
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 2. In the Layer Properties window, rename the Display node with your character's name.

 3. Click Close.
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Grouping Rigs
Once your rigging is completed, you must group the puppet's skeleton to help organize the often large and complex 
networks. This way, once you have imported two or three characters into the scene, three Group nodes will be 
displayed instead of all the rigging connections of three puppets.

How to group nodes

 1. In the Node view, select all your nodes.

 2. In the top menu, select Edit > Group > Group Selected Layers  or press Ctrl + G (Windows/Linux) or ⌘  + 
G (Mac OS X).

Your nodes are grouped.

 3. Click on the Group node's right arrow to enter the group.

 4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select the Group cat-
egory and select a Multi-Port Out node.
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 5. Drag the Multi-Port-Out node to the Node view.

 6. Connect the Composite node's output port into the Multi-Port Out node. 

An output port is created on your Group node.

 7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should now see an 
output port on your Group node.

 8. Click on the Group's Properties button to open the Layer Properties window.

 9. In the Layer Properties window, rename the Group node with your character's name.

 10. Click Close.
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Creating Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to 
create all of the function curves and block your pose in place.

How to create the keyframes

 1. In the Timeline view, collapse the master peg by clicking the Expand  arrow.

 2. In the Timeline view, select the first cell.

 3. Do one of the following:

 l From the top menu, select Insert > Keyframe. 

 l In the Timeline View toolbar, click the Add Keyframe  button.

 l Press F6.

NOTE: If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates a key-
frame but also duplicates a drawing.
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About Timeline Marking
As you animate, the Timeline view will accumulate many layers and keyframes. You might want to identify them 
using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can 
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in 
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is 
displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and 
mark the whole section.

To see how to mark the Timeline, see Marking the Current Frame, Marking Frame Ranges, Marking Layers with 
Colour
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About Backdrops
T-RIG-008-001

Backdrops are a way to work with complex node systems that let you associate a selected set of nodes by colour. 
You can add as many backdrops to your node structure as needed. The idea is to visually organize the structure so 
you can quickly identify the particular set of nodes.

You can customize the backdrops with different colours. For example, the upper part of a character's body could be 
in different shades of red, while the lower body is in shades of green. When you create a backdrop to the Node view, 
the default colour is red. 

Once you have created a backdrop with nodes inside, you can move the backdrop to the desired location and 
arrange multiple backdrops neatly. You can also resize backdrops to accommodate the number of nodes in your rig.

You can select the nodes you want to add to the backdrop before creating it and vice versa—create an empty 
backdrop and then drag the desired nodes into the backdrop.

NOTE: Because backdrops are not layers, its properties do not appear in a node's properties.
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For your convenience, you can add backdrops as templates to the library—see Create a Template from the Node 
view in Chapter 7: Library of the Cut-out Animation Guide.
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Adding Backdrops
T-RIG-008-002

You can add colourful backdrop to organize your nodes and group parts of your cut-out characters.

How to add a backdrop

 1. In the Node view, do one of the following:

 l Select the nodes to include in the backdrop.

 l Click anywhere in the Node view to deselect any selected items.

 2. From the Node View menu, select Insert > Backdrop.

If you selected nodes, a red backdrop displays around the nodes you selected.

If you did not select anything, a red backdrop displays in the Node view.
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Removing Backdrops
If no longer needed, you can easily remove backdrops.

How to remove a backdrop

 1. In the Node view, clear any backdrop or node selections.

 2. Alt+ click on the title bar of a backdrop to only select the backdrop, without the nodes.

 l If you want to delete the backdrop and all its nodes, simply select the backdrop without 
using the Alt key.

 3. Press Delete.

 l If you had a node selection, depending on your project, the Confirm Delete window may dis-
play. Deselect the Delete Drawing Files and Element Folders. If you have multiple ver-
sion of a scene, you will want to keep all the files and folders associated with it. If you select 
this option, all the drawings and folders linked to this backdrop will be deleted.

652



Harmony 14 Premium - User Guide

Customizing Backdrops
T-RIG-008-003

Once you've created a backdrop, customizing it is a great way to organize your work. You can change the colour of 
the backdrop, give it a name which displays in the title bar of the backdrop, and add any notes or instructions 
pertaining to the nodes contained in the backdrop.

How to customize a backdrop

 1. To resize a backdrop, drag the triangle in the lower-right corner of the backdrop window.

 2. Click the yellow square properties button.

The Backdrop Properties window opens.

 3. To change the colour of the backdrop, click the Colour list and select a colour.
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 4. In the Name field, type in a name for the backdrop.

 5. In the Text field, type in any notes or instructions in the backdrop.
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Organizing Nodes in Backdrops
Once you have deselected all items in the Node view, you can organize any of the nodes by dragging and moving 
them around even if they are in a backdrop. You can move nodes from one backdrop to another.

How to organize nodes in backdrops

 1. Click anywhere in the Node view to deselect all items.

 2. Organize the nodes by dragging them from one or more backdrops.
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Moving Backdrops
T-RIG-008-004

When you want to move a backdrop, you can do so either with or without the nodes it contains. Moving a 
backdrop with its nodes lets you quickly organize entire sections of a complex rig. 

Moving the backdrop only (without its nodes) gives you a chance to reorganize a node structure. Perhaps nodes 
should be grouped differently for a better workflow or nested within another backdrop for optimal organization.

How to move a backdrop and its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Click the title bar of a backdrop and drag to a new location.

How to move a backdrop without its contents

 1. Click anywhere in the Node view to deselect all items.

 2. Hold down Alt and drag the backdrop by the title bar to a new location.

 3. Click anywhere outside the backdrop to set its new position.
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Copying and Pasting Backdrops
When you copy a backdrop, its contents are copied along with the backdrop name, colour, and any notes. When 
selecting a backdrop, all backdrops underneath it are also selected.

When you select a backdrop with the Alt key, the backdrop retains its Z order.

NOTE: A selection that contains only backdrops cannot be copied.

How to copy and paste a backdrop

 1. Select one or more backdrops to copy and press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 2. To paste the copied backdrop(s), press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X). Note that nodes will 
be pasted as clones. They will link to the same drawing columns and existing function columns.
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About Pose Copier
The pose copier is a scrip that can be added to your Scripting toolbar. The goal of the Pose Copier is to facilitate 
the reuse of poses from a master template by taking information from it and pasting it at the desired frame. It does 
not create  new information outside of what is contained in the template.

In order for the Pose Copier to work, templates need to be set up properly to maximize the compatibility of the 
script. It is recommended to keep only the frames that will be needed. Empty or unused frames may appear within 
the sliders.

For a simple use of the script, create a template of the part that you wish to use with the pose copier. It could be 
the entire character, the head, the lip sync or any other part. It is recommended to template groups as opposed to 
scattered individual nodes. To maximize compatibility, keep the hierarchy of your template identical to the 
hierarchy of your rig.  

You can also create an advanced setup to select specific frames using guide layers—see About Guide Layers on 
page 660. 

NOTE: To learn more about the Pose Copier dialog box, see the Reference guide 
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Adding the Pose Copier Script to the Scripting Toolbar
To use the Pose Copier, you need to add the script to the Scripting toolbar.

How to add the Pose Copier script to your Scripting toolbar

 1. Select Windows > Toolbars > Scripting to display the Scripting toolbar.

 2. In the Scripting toolbar, press the Manage Scripts  button to open the Scripts Manager.

 3. In the Files section, select the TB_Pose_Copier.js script file. 

 4. In the Functions section, select TB_Pose_Copier function. 

 5. Press the Add Script to Toolbar  button to send it to the Scripting toolbar.

 6. Press OK to close the Script Manager.
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About Guide Layers
The guide layers are ordinary drawing layers named in a way that will associate them with the 3 sliders of the 
pose copier. These layers will need to be incorporated inside the template for the sliders to work when activating 
the pose copier script. 

You need to create three drawing layers for the three sliders to work. These will need to be named accordingly 
including a dash character. Suffixes may be added after the dash for additional information as seen in the 
example above.

 l slv- for the vertical layer that will be used for the tilt

 l slh- for the horizontal layer which will be used for the turn

 l slx- for the second horizontal layer that will be used for the lipsync

In those guide layers, you will need to create empty drawing cells. These frames will represent the different slider 
positions to which you will have access in the pose copier. The guide layer frames need to match the character's 
frames if they are to show an accurate view of the information that will be pasted.

In the example above, the slh (horizontal) slider contains 5 frames. The horizontal sliders are read in alphabetical 
order from left to right. You can add numbers to display them in the desired order.

 l 1front 

 l 2quarter-front 

 l 3side 
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 l 4quarter-back 

 l 5back 

The slv (vertical) slider contains 3 frames. The vertical slider works in alphabetical order from the way down and 
moving up, hence the numerical prefix.  

 l 1down 

 l 2mid 

 l 3up 

The slx (expression) slider contains 5 frames. Each of these frames holds different combinations which will be used 
for the different sliders to access the frames of the template. 

 l A 

 l B 

 l C 

 l D 

 l E

For example, setting the slh (horizontal) slider to 1front, the slv (vertical) slider to 3down and the slx (expression) 
slider to B will display a front pose, looking down, using the B mouth. 

NOTE: To learn more about the Pose Copier dialog box, see the Reference guide 
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Creating Guide Layers
For each template, three guide layers can be created to associate with the three sliders of the pose copier. 

How to create guide layers 

 1. With your rig open, go to the Timeline view, click the Add Drawing Layer  button or press Ctrl + R (Win-
dows/Linux) or ⌘  + R (Mac OS X) and create 3 new drawing layers. You may also create those nodes in 
the node view or x-sheet view.

 2. Name the prefix of each drawing layer based on the different sliders. The suffix can be anything to identify 
the sliders. The dash must be included within the name in order for the sliders to work.

‣ slv- for the vertical slider

‣ slh- for horizontal slider 1

‣ slx- for horizontal slider 2

 3. Based on the rig of your character, select each layer one at a time and click on the  button to create 
new empty drawing at the desired frame. The frame's location will be shown on the slider of the pose 
copier.

 4. Select the drawing cell and rename it with the desired information by doing one of the following.

‣ Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X) 

‣ From the timeline, right click on the cel and select Drawings > Rename Drawings...

 5. Extend exposure up to the next position on the timeline that you wish to include in the sliders.

 6. Reuse frames by selecting frames from the Drawing Substitution display in the Library view.

 

For more information about guide layers, see About Guide Layers on page 660
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Creating a Pose Copier Template 
The pose copier template is a regular template of assets that will be used to copy and paste information from the 
template over to a scene. Guide layers may be used inside of the pose copier template as additional efficiency tools 
for selecting your pose.

How to create a Pose Copier template

 1. In the Node view or in the leftmost section of the Timeline view, select the nodes intended to make the tem-
plate.      

If you have created guide layer nodes, make sure to include them in the selection as well.

 2. Copy the selection using one of the following: 

‣ Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

‣ From the top menu, select Edit > Copy.

 3. In the Library view, select a folder to store the template.

 4. If a library folder is locked, right-click and select Right to Modify.

 5. With the folder selected, paste the selection into the folder using one of the following: 

‣ Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

‣ From the top menu, select Edit > Paste.

 6. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename. 

 7. Click OK.

 8. Right-click on the template and select Generate Thumbnails.

You will see a preview of your template in the Drawing Substitution area of your Library view. The thumbnails 
are the images used inside the Pose Copier, therefore it is essential to do this before using the Pose Copier 
the script. Once this step is completed, the thumbnails are stored within the template. You will not need to do 
this again unless you recreate your template.
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Excluding Modules Using the Pose Copier
Inside the Pose Copier Script dialogue box, there is a button on the upper right corner called "Exclude Modules". 
On the immediate left of the button is a check box to enable or disable the option to excluded the nodes that have 
been added to the exclusion process.

How to create a node exclusion preset.

 1. From the pose copier dialogue box, click on the Exclude Modules button.

The Exclude Modules List dialogue box opens.

 2. From the timeline view select the elements that you wish to exclude from the pose copier template.

 3. Right click on the selected modules and select Tag > Timeline Tag.

The selected modules are tagged and an asterix * appears next to the tagged modules.

 4. In the dialogue box of the excluded modules list, enter a name for the preset that will be created. 

 5. Click the Create preset button.

A new preset is created.

 6. To add the tagged nodes to the preset, select the preset and click the Add tagged items to the selected pre-
set button.

The tagged modules are added to the preset.

How to exclude modules using the pose copier

 1. Press the Excluded Modules button to launch the Excluded Modules List dialogue box.
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 2. From the Excluded Modules List dialogue box, keep the presets that you wish to exclude checked while 
unchecking the ones you wish to include.

 3. Close the Excluded Modules List dialogue box.

 4. Check the box to the left of the Excluded Modules button to enable the option.

 5. Proceed with pasting keys from the template.

The excluded modules are no longer affected by the pasting options.
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Pasting Poses Using the Pose Copier 
Once the templates have been created and set up properly, it is easy to paste a variety of poses from one or 
multiple templates onto a still character awaiting posing. 

Depending on how the template has been set up, a different destination has to be set up in order for the pasting to 
take place.

How to Set the Default Destination with the Pose Copier script.

 1. In the Library view, select the template you want to copy poses from.

 2. If it was not done previously, right-click on the template and select Generate Thumbnails. 

The thumbnails are generated and showing in the Drawing Substitution View.

 3. With the template still selected, run the TB_Pose_Copier script by clicking on it in the Scripting toolbar—
see Adding the Pose Copier Script to the Scripting Toolbar on page 659.

The Pose Copier  dialog box opens.

 4. From the timeline, select the destination of the pasted keyframes by selecting the node or topmost node of 
your hierarchy for the selected template.

 5. With the destination highlighted in the timeline, (see below table for setting the proper destination) press 
the Set Default Destination Module button from the Pose Copier dialog box. 

Once selected, this information will remain saved within the template. 

Selecting the Destination Layer

Type of template Paste by Layer Name Option Default Destination

Grouped Nodes Enabled Set it on the same group as the templated 
group or any node above it in the 
hierarchy. If a node inside that group is 
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selected, pasting will not take place.

Disabled Select the same group as the one 
templated. 

Nodes Enabled Select any node in the hierarchy as the 
default position.

Disabled Unless you've only templated a single 
node, it is preferable to turn on the Paste 
By Layer Name option.

How to Paste Poses With the Pose Copier Script

 1. Do one of the following:

‣ Set Default Destination to the designated layer and enable the Use Default Destination Module 
option.

‣ Manually select the layer for the destination of the pasting.

 2. Select a pose using the different sliders—see About Guide Layers on page 660.

 3. Click Paste to apply it on your character at the currently selected frame.
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Chapter 9: Deformation
T-RIG-007-001

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations  act 
as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made out 
of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. This also allows you to 
take an area in a single bitmap image and create animation by distortion. 

A deformation skeleton is composed of deformation nodes, which are the various pieces (here represented as layers 
or nodes) required to articulate or deform your drawings, such as a series of bones, curves or game bones.

NOTE: It's important to note that the deformation feature was completely rebuilt in Harmony 12 to simplify the 
process and no longer works like it was in the previous releases. If you would like to convert characters with 
deformation chains created in Harmony 11 or before, you can use the TB_ConvertLegacyDeformation.js 
script to do so—see About Legacy Deformations on page 743.
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About Deformer Types
The 4 types of deformers are: Bone, Game Bone, Curve and Envelope. Each type has its own advantages and 
limitations and need to be rigged and handled in different ways.
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About Bone Deformation
T-RIG-007-002

The Bone deformation allows you to create a bone-like structure in which each part is solid, but with articulations 
that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or other parts that 
can be articulated such as torsos or fingers. For example, a Bone deformation can be used to articulate an arm that 
is made of a single drawing, so that the upper arm and forearm can be moved independently, without having to draw 
the upper arm and the forearm on different layers. Harmony will deform the drawing to make it look articulated. The 
different parts of a Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.
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About Game Bone Deformation
T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like structure 
in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a character's 
limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For example, a 
Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that the upper arm 
and forearm can be moved independently, without having to draw the upper arm and the forearm on different 
layers. Harmony will deform the drawing to make it look articulated. The different parts of a Game Bone 
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as 
animating articulations on different layers, without having to worry about parts detaching, pivot points, or clipping 
outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
differences between the Bone and Game Bone deformations are that  Game Bone deformations do not have Bias 
and Region of Influence properties. The articulation folds also look slightly more rounded.
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About Curve Deformation
T-RIG-007-004

The Curve deformation allows you to deform parts of a character using a vector curve. By manipulating the curve's 
points and their bezier handles, you can change the curve's direction, shape and length, and Harmony will deform 
the drawing to match the curve's shape. Curve deformations are mostly used to animate elements that don't have 
joints, such as hair bangs or facial features, or body parts with so many joints that they seem curved, such the torso. 
They can also be used to animate the limbs of characters in a rubber hose style of animation, where arms and legs 
are bent in curves. 
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About Envelope Deformation
T-RIG-007-005

The Envelope deformation allows you to deform an image using Bezier handles located all around the contour of 
the shape. Envelope deformation chains are composed of Curve deformation nodes. It is regularly used to deform 
shapes, such as hair, cloak, shoulder shape, head shape and so on. You can use the Envelope deformation to 
deform a drawing so it looks like it changes from a profile view to a front view to create head and character 
rotations using only one set of drawings.

The main differences between the Curve and Envelope deformers is that the Envelope chain can be closed by 
connecting the last Curve deformation node to the initial Offset point. Once connected, the Offset point no longer 
repositions the entire chain, only its own control point.

NOTE: It's not recommended to use the Envelope deformations on bitmap images and textures.
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About Basic Deformation Chain Creation
Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing.  However, whenever you close your project, the deformation 
controls display is turned off. When you reopen the project, you can display all controls or only some of them—see 
Displaying the Deformation Controls on page 1.
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Selecting Elements for Deformation
Deformation groups are added to your scene's hierarchy in different places, depending on whether a drawing or 
peg element is selected.

How to select the element on which to create a deformer 

A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging tool, it is 
automatically created as a parent of the selected layer, and will affect the selected layer and all its children. 
Hence, it's important to select the right layer before attempting to create a deformer.

For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you could rig 
the arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and the hand is the 
forearm's child. Then, if you create your deformer on the forearm, it will be created as a parent of the forearm, and 
will hence affect the whole arm, as its other parts are children of the forearm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you create 
a deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's children. This 
is because a peg is likely to be more useful over a deformer than under. If you move layers that are under a 
deformer, they will exit the intended deformation zone, and may appear severely warped and distorted. Hence, 
it's better to create deformations under pegs as much as possible, and pegs under deformers should only be 
animated if the deformer is left untouched. Since the deformer will be created as a parent of all the peg's children, 
it will affect all the layers under the peg. 
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Adding Bones to Deformation Chains
You can add either Bones of Game Bones to your deformation chain by using different modes.

How to create a Bone or Game Bone deformer

 1. Once your element is selected, select the Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the Bone  mode or the Game Bone  mode, depending on 
whether you're rigging for an animation project or a game—see Deformation on page 669.

 3. Place the cursor at the root of your drawing or drawing hierarchy, click once and release. For example, if 
you're creating a deformer for a whole arm, click on the shoulder joint.

 4. Move your cursor at the location where you want your first bone to finish and your second bone to start, 
and click again. An articulation control point will automatically be inserted between each bone you create. 

 5. Move your cursor where you want the next articulation to be and click to create the next point. 

 6. Observe that, as you create a new point, the previous point how has a circle around it. This indicates the 
radius of the articulation. Every point in a bone deformer except for the first and the last point in the chain 
have a radius setting. This allows you to determine how much of the drawing should be considered part of 
the articulation. The smaller the 

 7. Click and hold the previous articulation's radius manipulator and adjust the articulation's radius so that it 
covers the limb.
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 8. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in the right 
order going from the root to the extremity.

NOTE: It is possible to reuse a deformation group on another drawing, for example on a symmetrical body part, 
such as with the right and left arms. To do this, you need to rig the way you would for a multi-pose character, 
using a Transformation Switch—see Creating Main Deformation Chains for Multi-pose Rigs on page 734, as well 
as the Associate Parent Transformation Switch for Selected Elements button—see Reusing Deformation 
Groups for Multi-pose Rigs on page 736.
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Creating Curve Deformation Chains
Depending on your character and the style of animation you want to achieve, sometimes it is better to use Curve 
Deformers, instead of Bones, to rig your character.

How to create a Curve deformer 

 1. Once your element is selected, select the Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the Curve  mode.

 3. Place the cursor at the root of your drawing or drawing hierarchy. For example, if you're creating a deformer 
for a whole arm, place your cursor over the shoulder joint. 

 4. Press and hold the mouse button to create the point, then drag to towards the direction where you want 
your curve to bend to set the position of this curve's bezier handle, just as you would when drawing a curve 
using the Polyline tool—see Drawing with the Polyline Tool  on page 200.

 5. Click again at the location where you want the curve to end and drag backwards to extend the second bez-
ier handle.

 6. As you go, you can use your mouse cursor to reposition the existing bezier handles  as needed. You can 
hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier on the oppos-
ite site of the point.

 7. Repeat this process until you have finished building the Curve chain.
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NOTE: It is possible to reuse a deformation group on another drawing, for example on a symmetrical body part, 
such as with the right and left arms. To do this, you need to rig the way you would for a multi-pose character, 
using a Transformation Switch—see Creating Main Deformation Chains for Multi-pose Rigs on page 734, as well 
as the Associate Parent Transformation Switch for Selected Elements button—see Reusing Deformation 
Groups for Multi-pose Rigs on page 736.
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Creating Envelope Deformation Rigs
Before adding deformations, you might want to use a default type of region of influence. You can set these 
parameters in the  Rigging  tool's properties—see the Reference guide  .

How to create an Envelope deformation rig

 1. Once your element is selected, select the Rigging  tool in the Deformation toolbar.

 2. In the Tool Properties view, enable the Envelope  mode.

 3. Place the cursor where you want to start creating your envelope. 

 4. Press and hold the mouse button to create the point, then drag to towards the direction where you want 
your curve to bend to set the position of this curve's bezier handle, just as you would when drawing a curve 
using the Polyline tool—see Drawing with the Polyline Tool  on page 200.

 5. Working as you would when building a Curve deformer, continue adding control points around your shape. 
You can place your control points slightly outside of your contour line. 

 6. As you go, you can use your mouse cursor to reposition the existing bezier handles  as needed. You can 
hold down the Alt key if you wish to move a point's bezier handle without affecting the bezier on the oppos-
ite site of the point.
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 7. When you're ready to close Envelope deformer, hold down Alt and click on the first point of your deformation 
chain.

NOTE: It's not recommended to use the Envelope deformers on bitmap images and textures.
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Automatically Grouping Deformation Nodes
As you create chains, you can automatically group the deformation nodes to keep your structure clean and 
organized.

How to automatically group deformation nodes

 1. From the Deformation toolbar, click the Rigging  tool.

 2. In the Tool Properties view, in the Rig Tool Options section, enable the Automatically Create Group when 
Creating a New Deformation Rig option.

This option automatically creates a deformation group connected to the input port of the selected element. 
This group includes all the necessary deformation nodes  you created.
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Adding Deformation Nodes
The Node Library view allows you to manually add the nodes necessary to create the deformation skeleton. 
Additional nodes such as the Kinematic Output are available to create advanced rigs.

How to add a deformation node

 1. In the Node Library view, select the Deformation category.

 2. From the Node Library view, select a deformation node and drag it to the Node view. Note that the Glue,  
Mesh Warp, Refract, and Turbulence nodes are not directly related to deformation rigging.
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About  Rest Position Setting
As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation, 
you may need to make adjustments to the deformation chain to better fit your needs.

A deformation rig has a resting position and an animated position. The resting position is the original pose the 
character is in when not animated with keyframes. You can always revert your animated character to its resting 
position to recover the initial scale, angle, and shape. You can revert the entire character or only certain 
deformation chains, such as the arm or leg. Just make sure your resting position is fully set before deploying the 
character in production.

You can also set additional parameters in the Layer Properties window—see the Reference guide .

To understand better the various parameters available in the nodes' layer properties, you should know more about 
the following terms:

 l Radius: The radius determines the size of a zone. The radius value is the length from the central point of 
the zone to its edge. By increasing the radius value, you increase the size of the area.

 l Transversal: The transversal parameter is related to the width of the zone in relation to the bone. The 
transversal value cuts across the bone.

 l Longitudinal: The longitudinal parameter is related to the length of the zone in relation to the bone. The lon-
gitudinal value is parallel to the bone's length.
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Setting Rest Positions for Bone and Game Bones
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0 point 
for all the transformations that will be made to the drawing when animating. The resting position is also where we 
can see what parts of the drawing are assigned to which bone or articulation.

How to set up Bone and Game Bone deformation chains

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. In the Deformation toolbar, click the Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red chain 
indicates the puppet is in a resting position. Make sure your chain is red.

 4. In the Camera view, set up the deformation chain.

 l Rotate the first bone to change the angle of the chain.
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 l Use the root control to reposition (offset) the entire chain.

 l Use the control points to reposition the articulations. This will elongate, shorten or change the 
direction of the bone and offset the subsequent children.

 l Use the articulation's control (square) to change the size of the articulation. For quality pur-
poses, it is recommended to have an articulation which fits the diameter of the part it controls.
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 5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is 
linked. You can also set additional parameters in the Layer Properties window—see the Reference guide .

 6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current Key-
frame  button. This will set the current resting position as the current frame one.

 7. Use the Transform  tool. For optimal results, make sure the size of the articulation is approximately the 
same size as the drawing.

How to add an articulation to an existing Bone or Game Bone deformation

 1. Select the drawing layer or the deformation chain to which you want to add an articulation.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. Select the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 4. Move your cursor over the bone segment, where you want to add an articulation.

 5. Hold Alt and click.

NOTE: You can only insert new articulations inside Bone and Game Bone deformations.
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Setting Rest Positions for Curve Chains
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0 point for 
all the transformations that will be made to the drawing when animating. The resting position is also where we can 
see what parts of the drawing are assigned to which curve.

How to set up a Curve deformation chain

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. In the Deformation toolbar, click the Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red chain 
indicates the puppet is in a resting position. Make sure your chain is red.

 4. In the Camera view, setup the deformation chain.

 l Use the Pivot rotation handle to change the angle of the chain.

 l Use the Pivot centre control point to reposition the entire chain.
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 l Use the curve handles to modify the shape of the curve.

 l Use the curve’s square control points to resize and reposition each segment of the curve 
chain.

 5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You can 
also set additional parameters in the Layer Properties window—see the Reference guide .

 6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current Key-
frame  button. This will set the current resting position as the current frame one.

 7. Test your modifications using the Transform  tool.
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Setting Rest Positions for Envelopes
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0 point for 
all the transformations that will be made to the drawing when animating. The resting position is also where we can 
see what parts of the drawing are assigned to which envelope.

How to set up an Envelope deformation chain

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. In the Deformation toolbar, click the Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red chain 
indicates the puppet is in a resting position. Make sure your chain is red.

 4. In the Camera view, set up the deformation chain.

 l Use the envelope’s square control points to resize and reposition each segment of the envel-
ope chain.

 l Use the curve handles to modify the shape of the envelope.
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 5. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked. You can 
also set additional parameters in the Layer Properties window—see the Reference guide .

 6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current Key-
frame  button. This will set the current resting position as the current frame one.

 7. Test your modifications using the Transform  tool.
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About Regions of Influence

To increase the quality of your animation and the accuracy of the deformation effect, you can modify the regions of 
influence around the deformation chains. A region of influence is the zone around the deformer within which art will 
be influenced by the deformation. The deformer has the power to shape all art contained within the influence area on 
its own element or on its children elements. 

Zones of influence are different depending on the deformer type and zone type you selected. Note that the Game 
Bone deformers do not support regions of influences. Game Bone deformers are set to Infinite and cannot be 
changed.

You can find the settings for the zones of influence in the Layer Properties of the Curve, Bone and Envelope nodes, 
as well as in the Rigging tool properties.

NOTE: You can also prevent a child’s element from undergoing its parent deformation by connecting it through 
a kinematic output—see About Assembly on page 705.

695



Chapter 9: Deformation     About Regions of Influence

Selecting Region of Influence Types
There are four types of region of influence:

 l Zero: This creates no influence around the deformer.

 l Infinite: This is the default option. The influence goes all the way to the image boundaries or until it inter-
sects with another zone of influence. When working on a cut-out puppet built on several element layers, 
the best choice is to keep the default Infinite option as the zone of influence type. In the following 
examples, the zones of influence are explained through deformation chains on a single bitmap image. It's 
also recommended to keep the regions of influence to Infinite when using Envelope deformers.

 l Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value. When 
you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and make 
sure that only the element you want to follow the deformation is included inside the zone.

 l Shaped: This creates a custom region of influence around the deformer that can be adjusted using control 
points and Bezier handles. When you set up the boundaries of your Shaped zone of influence, you should 
be as accurate as possible and make sure that only the elements that you want to follow the deformation 
are included inside the zone.

 When you have an Elliptic zone of influence selected in the Node view, you can convert it to a Shaped 
zone using the Convert Elliptic Zone of Influence to Shape option.

How to select a region of influence type

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set the region of influence for—see Displaying the Deformation Controls on page 1.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:

 l Zero

 l Infinite

 l Elliptic

 l Shaped
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Setting Up Elliptic Regions of Influence
An elliptical region of influence is suited for regular shapes. Modify its parameters to refine the region boundaries.

How to set up the Elliptic region of influence

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set the region of influence for—see Displaying Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

 4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius
This defines the size of the fade area around the actual region of 
influence's boundaries.

Transversal Influence Radius 
Left

When the Symmetric Ellipse of Influence option is enabled, this 
field controls the Left and Right transversal radius values. When 
disabled, it controls the size of the left transversal radius. By 
default, this value is set to 2.

Transversal Influence Radius 
Right

When the Symmetric Ellipse of Influence option is enabled, this 
field becomes inactive. The Left Transversal radius value is 
automatically applied to the Right Transversal. When the 
Symmetric Ellipse of Influence option is disabled, it controls the 
size of the Right Transversal radius. By default, this value is set to 
2.

Longitudinal Influence Radius 
Begin

When the Symmetric Ellipse of Influence option is enabled, this 
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field becomes inactive. The End Longitudinal value is automatically 
applied to the Begin Longitudinal value. When the Symmetric 
Ellipse of Influence option is disabled, it controls the size of the 
Begin Longitudinal radius. By default, this value is set to 0.25.

Longitudinal Influence Radius 
End

When the Symmetric Ellipse of Influence option is enabled, this 
field controls both the Begin and End Longitudinal radius values. 
When this option is disabled, it controls the size of the End 
Longitudinal radius. By default, this value is set to 0.25.

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be symmetrical on 
both the transversal and longitudinal radii. In this case, use the 
Transversal Influence Radius Left field to set the transversal radius 
value and use the Longitudinal Influence Radius End field to set the 
longitudinal radius value. The two other fields will remain unused 
unless you disable the Symmetric Ellipse Influence option. In that 
case, you can set up different radius sizes for the four radii 
directions.

 5. You can also modify the elliptic shape in the Camera view using the  Rigging  tool.

 l If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the Camera 
view. Drag this point in any direction to increase or decrease the size of the Zone. Dragging it left/right will 
modify both longitudinal radius sizes. Dragging it up/down will modify both transversal radius sizes.

 l If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera view. 
Drag the top-corner point left/right to modify the end longitudinal radius size and up/down to modify the left 
transversal radius size. Drag the bottom-corner control point left/right to modify the beginning longitudinal 
radius size and up/down to modify the right transversal radius size.
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Setting Up Shaped Regions of Influence
A Shaped region of influence is suited for irregular forms. Modify the region parameters to refine the shape's 
boundaries.

How to set up the Shaped zone of influence

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set the region of influence for—see Displaying Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer of the selected piece.

If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties, the zone 
of influence will be square. This square has control points on all four corners and each control point as two 
control levers. If you converted an Elliptic zone to a shape, the zone will have more control points and 
handles.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—see Setting Up Shaped Regions 
of Influence on page 700.

 l In the Camera view, use the Rigging tool and drag a control point to redefine its position and 
shape.
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 l Click and drag the control lever handle to modify the corners and redefine the shape.

 l Hold Alt down while dragging the control lever handle to move one handle at a time.
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Converting Elliptic Regions of Influence into Shapes
After you have tried tweaking an elliptical region of influence, you may find that you need to convert the ellipse 
into a shape, in order to create a more precise region. Instead of losing all the tweaks you have made, you can 
use the elliptical region you have created as a base for a Shaped region of influence.

How to convert an Elliptic zone of influence to a shape

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set the region of influence for—see Displaying Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer of the selected piece.

 3. In the Tools toolbar, click the  Rigging  button.

 4. In the Tool Properties view, in the Operations section, click the Convert Elliptic Zone of Influence to Shape 
 button.

The zone of influence is automatically converted to a shape. The shape is retained and control points 
appear around the zone, so you can customize the shape. 
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Modifying Influence Fade Radii
To illustrate the zone of influence Fade Radius and its effect, the bitmap picture will be swapped with a grid pattern.

 

There is an area called the deformer Fade which surrounds the region of influence; this is the link between the strict 
boundaries of the zone of influence and the surrounding region. This area gradually stretches or squashes following 
the deformation. You can change the Fade Radius value to modify the size of this area and the exponent of the 
deformation fade effect. 

 

If you built a custom deformation system from the Node Library view and are using a Deformation-Switch node, you 
can change the default behaviour so the fading effect is inside the zone of influence instead of outside. This is 
explained in this example.

How to modify the Influence Fade radius

 1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you 
want to set the region of influence for—see Displaying Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer of the selected piece.
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 3. In the Layer Properties window, under the Region of Influence section, adjust the Influence Fade Radius 
field to modify size of the fading area. The default value is 0.5.

 4. If you built a custom node structure, using deformation nodes from previous versions of Harmony and are 
using a Deformation-Switch node, you can also set the fade radius there. In the Node view, select the 
Deformation-Switch node under the Deformation-Composite node in your deformation chain.

 5. In the Layer Properties window, set the following options:

Parameter Description

Influence Fade Exponent

Modify the exponent value or type the exact value in the field. 

 l A value of 1 is similar to a linear curve. 

 l A higher value will result in an ease-in type of curve. 

 l A lower value will result in an ease-out type of curve.

Fade Inside Zones
By default this option is disabled, meaning that the Fade effect 
will occur outside the zone of influence. You can enable this 
option so the fade effect is inside the zone of influence.
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About Assembly
After you have created all the deformation chains for your character, you will need to assemble these separate body 
parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body 
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the deformations 
down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain but 
not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the 
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the 
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will automatically 
rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of your character will 
be rigged with a deformation chain, you must set pivot points for the pieces that are not using deformations—see 
Setting Permanent Pivots on page 623.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep in mind:

 l You cannot parent deformers directly because deformers are not designed to be used on other deformers. To 
assemble deformers, you must insert a Kinematic Output node.
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 l Your peg must be placed above the deformer.
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Assembling in the Timeline View
In order to assemble the rigged parts of your character in the Timeline view, you need to use a Kinematic Output 
layer.

How to assemble a puppet using the Kinematic Output node in the Timeline view

 1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

 2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

 3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you want your 
limb or piece to follow. For example, onto the neck deformer if you want your head to follow it without being 
deformed or onto the arm deformer if you want your hand to follow.

 l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder them—see 
About Ordering Layers on page 615.
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 l It's good practice to rename the Kinematic Output layer to reflect which deformer it is 
assigned to as the Timeline view can become very large and layers can be positioned far 
apart. Select the Kinematic Output node and in the Layer Properties window, rename the 
node. You can also double-click on the layer's name.

708



Harmony 14 Premium - User Guide

Assembling in the Node View
In order to assemble the rigged parts of your character in the Node view, you need to use a Kinematic Output node.

How to assemble a puppet using the Kinematic Output node in the Node view

 1. In the Node Library view, go to the Deformation section, select the Kinematic Output node and drag it to the 
Node view.

 2. Pull out a second output connection (bottom port) from the deformer node you want your piece or limb to fol-
low and connect it to the Kinematic Output port.

 3. Connect the Kinematic Output node to the piece you want to follow the deformer.
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‣ If it a good practice to rename the Kinematic Output node to reflect which deformer it is assigned to as 
the node structure can become very large and nodes can be positioned far apart. Select the Kinematic 
Output node and in the Layer Properties view, rename the node.

‣ You can pull out multiple connections from the same Kinematic Output node if many limbs and pieces 
must follow a single deformer. For example, you can use the same Kinematic Output node for both 
arms and the neck to follow the body deformer.
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Displaying Selected Deformation Controls
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
controls won't display right away. Likewise, deselecting a deformation chain will not hide its deformation controls. 
Before you can animate or modify an existing deformation chain, you must manually display it.

How to display the selected deformation chains

 1. Do one of the following:

  l In the Timeline or Node view, select the deformation group or any part of the deformation chain 
you want to display.

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the deform-
ation chain you want to display.

 2. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.

NOTE: The Show Selected Deformation Chain and Hide All Others button will display all deformation chains 
that are in the hierarchy of the selection. For example, if the master peg of a character model is selected, all of 
its deformation chains will be displayed. Likewise, if multiple layers linked with different deformation chains are 
selected, all of their deformation chains will be displayed.
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Hiding Deformation Controls
You can hide all the deformation controls for your rig all at once.

How to hide the deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard the 
current selection, then click on  the Show Selected Deformation Chain and Hide All Others 

 button in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the Show the Selected 
Deformation Chain and Hide All Others button in the deformation toolbar.

 l In the Camera toolbar, click the Hide All Controls  button. 

 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.
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About Deformation Animation
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on their 
corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a deformer, 
except it requires using Transform tool instead of the Rigging tool. When the Transform tool is selected, 
deformation controls in the Camera view display in green, which means they are in animation mode, whereas when 
the Rigging tool is selected, they display in red, meaning they are in rigging mode.
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Animating Bone and Game Bone Deformers
You can add keyframes to deformers reposition their deformation controls to create animated sequences.

How to animate Bone and Game Bone deformations

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position 
and size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and 
size throughout the whole scene. 

 3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 4. Select the first frame of the scene.

 5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first 
frame in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type 
in the amount of frames in your scene and confirm. This will make your model exposed (visible) throughout 
your whole scene,

 6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of 
every layer of the model. This ensures that when you make the second pose later, your first pose will not 
be affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 7. Do one of the following:

  l In the Timeline or Node view, select the deformation group or any part of the deformation 
chain you want to display.

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the 
deformation chain you want to display.

 8. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.
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 9. In the Camera view, do the following:

 l Rotate the first bone to rotate the limb.

 l Rotate the subsequent bones to bend the limb.

 l Use the root control to reposition (offset) the entire chain.

 l Use the control points to reposition the articulations. This will elongate, shorten, or change the 
direction of the bone and offset the subsequent children.
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 10. In the Timeline view, go the frame on which you want to set the next key pose. 

 11. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 12. Repeat the previous steps to animate your character.

NOTE: When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt key to 
lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl (Windows/Linux) or 
⌘  (Mac OS X) key to break the articulation off its chain and make it into a new, separate deformer chain.

NOTE: You can also manipulate the deformer by typing values directly in the Layer Properties of the deform-
ation effect nodes.                     
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Animating Curve Deformers
Add keyframes and reposition the curve deformers to create animated sequences.

How to animate Curve deformations

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position and 
size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and size 
throughout the whole scene. 

 3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 4. Select the first frame of the scene.

 5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first frame 
in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type in the 
amount of frames in your scene and confirm. This will make your model exposed (visible) throughout your 
whole scene,

 6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of every 
layer of the model. This ensures that when you make the second pose later, your first pose will not be 
affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 7. Do one of the following:

  l In the Timeline or Node view, select the deformation group or any part of the deformation chain 
you want to display.

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the deform-
ation chain you want to display.

 8. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.
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 9. In the Camera view, do the following:

 l Click on the centre of the deformation's root pivot and drag it around to reposition the entire 
limb.

 l Use the pivot’s square handle to rotate the entire chain.

 l Use the square control point located at the extremity of a bone to stretch or shorten its 
length.

 l Use the curve handles to modify the shape of the curve. 
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 l A point in an Curve deformation that's between two other points will have two bezier handles, 
one of each side. If you rotate one of the bezier handles, the opposite bezier will follow by 
default. If you wish to rotate one of the bezier handles independently from the other, do as fol-
low:

 l Select the handle you want to move independently from the other. 

The handle’s colour turns white. 

 l Press and hold Alt. 

 l Rotate the handle.

 l By default, transforming a point in a Curve deformation chain does not offset subsequent 
points. However, it is possible to offset a curve deformation point along with all its children:

 l Select the point you want to transform 

The point's colour turns white. 

 l Press and hold Ctrl (Windows/Linux) or ⌘  (Mac OS X). 
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 l Either move the deformation point or rotate one of its handles. If you move the 
deformation point, subsequent points will be offset horizontally and vertically. 
If you rotate one of its handles, subsequent points will rotate around the 
deformation point. 

NOTE: You can also manipulate the deformers by typing values directly in the Layer Properties of the 
Deformation nodes.                 
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Animating Envelope Deformers
Add keyframes and reposition the envelope deformers to create animated sequences.

How to animate Envelope deformations

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position and 
size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and size 
throughout the whole scene. 

 3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 4. Select the first frame of the scene.

 5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first frame 
in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type in the 
amount of frames in your scene and confirm. This will make your model exposed (visible) throughout your 
whole scene,

 6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of every 
layer of the model. This ensures that when you make the second pose later, your first pose will not be 
affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 7. Do one of the following:

  l In the Timeline or Node view, select the deformation group or any part of the deformation chain 
you want to display.

 l In the Camera, Timeline or Node view, select one of the drawing elements linked to the deform-
ation chain you want to display.

 8. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.
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 9. In the Camera view, do the following:

 l Move the control points located along the envelope to deform your drawing.                        

 l Use the envelope's control point handles to modify the drawing`s shape.  

 l A point in an Envelope deformation that's between two other points will have two bezier 
handles, one of each side. If you rotate one of the bezier handles, the opposite bezier will fol-
low by default. If you wish to rotate one of the bezier handles independently from the other, 
do as follow:

 l Select the handle you want to move independently from the other. 

The handle’s colour turns white. 

 l Press and hold Alt. 

 l Rotate the handle.
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NOTE: You can also manipulate the deformers by typing values directly in the Layer Properties of the Deform-
ation nodes.                  
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Resetting a Deformer to its Resting Position
If you need to reset the current pose of the entire chain for the entire scene, you have the possibility to reset the 
deformation chain to the resting position on the current or all frames.

How to reset the position of deformers from the Camera view

 1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the resting pos-
ition.

 2. Do one of the following:

 l In the Camera, Timeline or Node view, select one of the drawing layers linked to the deformation 
chain you want to [[[Undefined variable Variables.SnippetVariable1]]].

 l In the Timeline or Node view, select the deformation group or any part of the deformation chain you 
want to [[[Undefined variable Variables.SnippetVariable1]]].

 3. In the Deformation toolbar, either:
 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the selec-

ted element's deformation chain and hide any other deformation chain that is currently displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation chain 
along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 4. In the Camera view, select the deformation point you want to reset. To select several deformation point, 
hold Ctrl and click on each point you want to reset to add them to the selection.

 5. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of the 
selected chain on the current frame.

How to reset the position of deformers from the Timeline                                     or Node                                  view

 1. In the Timeline view, move the playhead to the frame where you want to reset the deformer to its resting 
position.

 2. In the Timeline or Node view, select the deformation group or node you want to reset.

 3. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of the 
selected chain on the current frame.

NOTE: To completely reset the position and remove all keyframes on all frames, click on the Reset All Key-
frames  button.
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Converting Deformation Animation to Drawings
You may  want to adjust your deformation animation. Convert deformation animations to drawing sequences, so you 
can adjust the drawings using the drawing tools. You may also want to change the timing and set it on double frames 
instead of single frame. Harmony offers you the option to convert your deformation animation to an actual drawing 
sequence.

How to convert deformation animation to drawings

 1. In the Timeline view, select the deformation frame range for which you want to convert to drawings.

 2. From the top menu, select Animation > Deformation > Convert Deformed Drawing to Drawings.

The Baking Drawing window opens. Wait for the baking to complete.

Your selection is converted to vector drawings.
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Disabling Deformation Preview
When adding new drawings while animating, you may need to see the reference drawings as their original resting 
position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable 
deformations in Harmony so that all drawings appear in their resting position.

NOTE: Disabling deformations is only a display mode. Although drawings will not appear deformed in the 
Camera view, even in Render View mode, they will still be deformed in the rendered images.

How to disable the deformations to create new drawings

 1. In the Deformation toolbar, click on the Enable Deformations  button to toggle deformation preview.
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About Multi-pose Deformation Rigs (Transformation Chains)

Creating and rigging a full character turnaround can be achieved by creating multiple deformation chains on a same 
character without having to create completely different puppets.

For a simplified process, you can keep each view of your character separate in the Timeline or Node view.  If you 
create separate rigs for each view, then you can simply turn on or off the exposure of each view in the timeline when 
needed.

However, if you want to keep the entire character, with all views, in one group/rig on the timeline, then you can follow 
the process described here by  building a multi-pose deformation rig, also known as multiple transformation chains.
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About Character Preparation for a Multi-pose Deformation Rig
Before building a puppet’s deformation skeleton, you must prepare your character. The best way to proceed is to 
have the limbs on separate drawing layers. This is similar to a standard cut-out puppet preparation, but uses 
fewer pieces. Since this is a more advanced type of puppet, you should keep the character’s head, hands, feet, 
and facial features on a separate layer from the body, arms, and legs. This will prevent the extremities from being 
distorted if the limbs are stretched during an action. It will also let you use drawing substitution to swap hands, 
feet, eyes and mouth poses during animation.

There are many ways to break down a cut-out puppet. The example described in this chapter uses these pieces:

• Body • Left Ear • Right Ear

• Head • Left Eye • Right Eye

• Mouth • Left Eyebrow • Right Eyebrow

• Nose • Left Arm • Right Arm

 • Left Hand • Right Hand

 • Left Leg • Right Leg

 • Left Foot • Right Foot

Refer to the following topic to learn how to break down a character: Rigging on page 573.   
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About Structure for Multi-pose Deformation Rigs
Each pose (transformation chain) you rig within the same element has to be part of a separate subgroup, all of which 
are gathered together by a Transformation-Switch node. The group name is not relevant in the multi-pose structure. 
These subgroups can be renamed once the rig is complete. The Transformation-Switch node uses the drawing name 
to associate a transformation chain with it. If you rename a drawing after is has been linked to a transformation 
chain, you will have to manually change the drawing name associated to the chain in the Transformation-Switch 
layer properties. You might want to rename your drawing before you start rigging so the names correspond to the 
poses. For example: front, side, quarter, etc.
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Renaming Drawings for Multi-pose Deformation Rigs
Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear node structure for your 
project. If you leave your drawing as is and do not rename it, your deformation subgroups could become slightly 
confusing. If you plan to have several drawings using the same rig within an element, for instance, drawing 
substitution, then you should rename these extra drawings before starting your rig. 

How to rename drawings

 1. In the Xsheet view, locate the column that corresponds to the element which includes several drawings that 
will use the same chain, such as a character that has several costumes which you plan to swap by using 
drawing substitution. In our example, we will use the rabbit’s feet, which will all use the same deformation 
curve.

 

 2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged. 

 3. From the Xsheet menu, select Drawings > Rename Drawing or press Ctrl + D (Windows/Linux) or ⌘  + D 
(Mac OS X).

 4. In the Rename Drawing dialog box, type a relevant new name for the drawing and click OK.

 5. In the Xsheet view, select the next drawing in the column and select Drawings > Rename Drawing from the 
Xsheet menu.
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 6. In the Rename Drawing dialog box, type the same name that you gave the first drawing of the column, 
exactly as it is written and add and any number. For example, if the first drawing is named front, the sub-
sequent drawings are named: front_1, front_2, front_3, etc.

 7. Repeat steps 5 and 6 for each subsequent drawing that needs to be renamed.
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Creating New Deformation Chains (Transformation Chains)
The process of creating multiple deformation chains on the same character is divided in four steps: creating the main 
chain, creating additional chains, renaming the chains, and associating additional drawings to the chains.

The drawings are associated with deformation chains. For example, if you want to rig the puppet's arm, you will need 
to add a deformation chain to the arm drawing. If the arm has multiple pieces such as upper arm, forearm and hand, 
you will create the deformation chain on the upper arm and afterward link the forearm and hand to that same chain. 
When creating the additional transformation chains on the other views of your rig, you will create them on the upper 
arm. The forearm and hand will not influence which chain is used. They will follow the upper arm chain. If the drawing 
exposure is changed on the upper arm, the deformation chain will change to the associated one. If the forearm or 
hand exposure is changed, the same deformation chain will remain. You must create the deformation chain on the 
drawing that will have the most influence when changing the puppet's view.

After creating your deformation rig, you may want to convert an animated character's pose to a new deformation 
chain. This can be useful when you want to add a pose to a turn-around deformation rig you have already spent time 
creating and manipulating. You can take the pose at the current frame and the state of the deformations and create a 
new drawing set along with a new deformation chain using the current position.
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Creating Main Deformation Chains for Multi-pose Rigs
The first step in creating a multi-pose rig is to create the main chain for the additional poses.

How to create the main deformation chain

 1. In the Timeline view, make sure the time marker is set to the frame displaying your first drawing. 

 2. In the Node view, select the drawing layer containing the drawing you want to create the chain for. If you 
want to create the chain for an arm composed in multiple pieces, you must select only one of the drawing 
layer, such as the upper arm. The additional pieces will be added afterward.

 3. In the Deformation toolbar, click the Create New Deformation Chain  button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

 4. In the Deformation toolbar, select the Rigging   tool.

 5. Create your deformer structure—see About Basic Deformation Chain Creation on page 675.

 6. If needed, in the Node view, link the new deformation group to the additional pieces, such as the forearm 
and hand.
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 7. Repeat these steps for all the deformation chains that need to be created on the current puppet's view.

These chains are now the default deformation chains that will be used on all drawings not using a custom 
deformation chain.
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Reusing Deformation Groups for Multi-pose Rigs
When creating a deformation rig, you may want to copy and paste the deformation group created for a drawing 
and connect it to another drawing. For example, after creating a bone or curve chain for the arm of a character, 
you may want to copy and paste the deformation group to use it on the other arm. 

The problem with copying and pasting deformation groups is that the Transformation switch in the group will still 
point to the first drawing it was connected to. You can easily correct this problem by using the Associate Parent 
Transformation Switch with Selected Element button.

How to copy bones and curves

 1. In the Node view, copy the deformation group node.

 2. Paste the deformation group node.

 3. Connect the second set of drawings to the deformation group node. If these drawings are attached to a 
peg, be sure to put the deformation group between the drawings and the peg.

 4. Enter the Deformation group by clicking on its grey arrow.
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 5. Open the Transformation Switch properties by clicking on the yellow box.                     

Notice that the drawing that the Transformation Switch points to is the original drawing that it was connected 
to.

 6. Exit the deformation group to return to the main Node view.

 7. Select the drawing node connected to the copied deformation group. If there are multiple drawing nodes con-
nected to the same deformation group, select the drawing at the top of the hierarchy or the one that makes the 
most sense for your setup.

 8. From the Deformation toolbar, click on the Associate Parent Transformation Switch to Selected Element  
button. If you do not see this button in the Deformation toolbar, you need to add it—see the Reference guide .

The Transformation Switch now points to the correct drawing.
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 9. Rename the deformation group to match its associated drawings.
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Creating Additional Deformation Chains for Multi-pose Rigs
The second step to creating a multi-pose rig is to create additional chains. after the creation of the main chain.

How to create additional deformation chains

 1. In the Timeline view, move the playhead (current frame) to the character's next position.

 2. In the Node or Timeline view, select the drawing you want to set a new deformation chain (transformation 
chain) for. If you had previously selected the upper arm in a multiple parts arm structure, select the same 
drawing layer (upper arm).

 3. In the Deformation toolbar, click the Create New Deformation Chain  button.

A new deformation chain is created and appears in the Transformation Chain drop-down list.

 4. In the Deformation toolbar, select the Rigging   tool.

 5. Create your new deformer structure—see About Basic Deformation Chain Creation on page 675.
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Renaming Transformation Chains on Multi-pose Rigs
Rename your transformation chains in order to keep track of and better organize your rig's various poses.

How to rename a transformation chain (deformation chain)

 1. In the Timeline or Node view, select the drawing layer containing the chains you want to rename. Make 
sure your current frame contains a deformation chain.

 2. In the Deformation toolbar, click on the Rename Transformation  button,

The Rename Transformations dialog opens.

 3. Rename the different transformation chains (deformation chains) to match the view they are associated 
with.

 4. Click OK.
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Linking Drawings to Transformation Chains
Link drawings to transformation chains, so that the drawings can be animated using the chains.

How to associate a drawing to a transformation chain

 1. In the Timeline or Node view, select the drawing layer containing the drawing you want to link to an existing 
deformation chain. The deformation chain has to exist on that same layer. You cannot associate a drawing to 
a chain created on a different layer.

 2. To associate the drawing to the chain, do one of the the following:

 l In the Deformation toolbar, select the desired chain from the Transformation Chain drop-down 
list.

 l In the Node view, select the Transformation-Switch contained in the deformation group and in 
the Layer Properties view, type the drawing name in the field corresponding to the desired 
chain. The drawing names must be semi-colon separated.
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Converting Drawings to New Deformation Chains
Link existing drawings to new deformation chains.

How to convert a drawing to a new deformation chain

 1. In the Timeline view, go to the frame you want to transform into an new pose (deformation chain).

 2. Select the drawing you want to convert and add a new chain.

 3. Do one of the following: 

 l From the top menu, select Animation > Deformation > Convert to New Drawing and 
Add Deformation Chain.

 l In the Deformation toolbar, click the Convert to New Drawing and Add Deformation Chain 
 button.

A new transformation is created and added to the list.
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About Legacy Deformations
Releases prior to Harmony 12 used a different deformation structure. The current structure is simplified.
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Transferring Curve Positions of Legacy Deformations
You can Lets you transfer all of the information from first curve deformer to its parent Offset node. This is useful 
for a legacy scene created using Curve deformations where the Offset's position has been placed far away from 
the drawing to make sure it doesn't affect  the drawing's deformation. You can bring back the offset and give it the 
first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The offset 
no longer needs to be placed far away.

How to transfer a curve's position to its parent offset

 1. In the Node view, select the root Offset and the first curve.

 2. From the top menu, select Animation > Deformation > Set Curves and Offsets Independent from Par-
ent.

 3. In the Node view, select only the first curve node.

 4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.

In the Node view, the first Curve node is disabled and the values are transferred to the parent Offset node.
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Converting Legacy Deformation Chains
You can also convert a legacy deformation rig to the new format using a script. You can select which chain you 
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original 
puppet is maintained.

How to convert legacy deformation chains to the new structure

 1. In the Node or Timeline view, select the deformation group containing the chain you want to convert to the 
new structure.

 2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the tool-
bar, you can load it.

 l In the Scripting toolbar, click on Manage Scripts

 l In the Script Manager dialog, in the File column, select the TB_Cover-
tLegacyDeformation.js script. If you cannot find the script in the list (most likely due to a 
software upgrade installation), you can load the script through the Script Editor view from the 
default resources folder—see Importing Scripts in the Scripting guide.

 l In the Functions column, select TB_ConvertLegacyDeformation.

 l Click the Right Arrow button to move the function to the Scripting toolbar.
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 l Click OK.

The legacy chain is converted.
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Chapter 10: Gaming in Harmony
There are two main pipelines for exporting data from Harmony to your game engine: 

 l Raw Game Data Export  on page 750

 l Frame-by-Frame Export  on page 751

Creating Animation in Harmony

When creating character rigs and animation for games, there are a few things to think about before starting.  Artists 
and programmers should work together to make sure their needs are met. 

 l What platforms will your game be create for?  Windows, Mac, Mobile, iOS, PS, XBOX, etc. 

 l What game engine will you be using?

 l What  will be animation style used to create the look of the game?  Hand drawn, cut-out, with textures, etc. 

These are just a few of the questions to consider before getting started.  They all have an impact on how you design, 
build, and animate characters. 

For example, if you’re planning a mobile game for smart phones, then you will most likely want to keep your game 
under 50 MB, so it can be downloaded without having to be on Wi-Fi.  In that case, your most important consideration 
is to create efficient characters with very tight sprite sheets and reuse a lot of the animation to keep the file sizes 
small.    During the process, you will need to: 

 l Rig and animate characters in Harmony.

 l Extract the Harmony data. 

 l Import the Harmony data into the game engine.  

Keep in mind, if you’re working with a custom engine, you can also process the Harmony data that’s exported and 
use it in a custom game engine.  If you need assistance with adapting data for your engine, contact 
store.toonboom.com/contact/support. 

If you’re making a game for consoles, like the PS or Xbox, then you have the freedom to create larger textures.  You 
may want to animate frame-by-frame, or you may want to animate with a cut-out character.     

If you're simply going to export on a frame-by-frame sequence, then you can use all the tools in Harmony without 
limitations.  You can then process an exported image sequence into a sprite sheet.  
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Raw Game Data Export 

Raw game data export is appropriate when you want the file sizes to be as small as possible.  Toon Boom lets you 
extract all the data from Harmony to incorporate into a game engine.  You can extract the skeleton information, 
drawing information, and keyframe animation data, as well as deformations (bones and articulations only), cutter, 
transparency nodes, and timing columns. 

 l Advantage: This is the lightest export, and will keep file sizes small which is ideal for mobile applications.
  

 l Disadvantage: You are somewhat limited in the tools you can use in Harmony.  You can use tools like 
Morphing as well as Curve and Envelope deformers, but you’ll need to bake it out to drawings so they're 
interpreted properly in the game engine.  You can use Cutter effects (masking), but you cannot cascade 
them, meaning you cannot have more than one in a hierarchy chain.  The Game Bone deformers can be 
used on your rig with having to bake it to drawings.

However, even with these limitations, you can create really great cut-out character animation in Harmony and 
extract all the data.  By moving, rotating, scaling, and skewing the different drawing layers, you can create 
advanced looking animation.  

When you extract the data, you'll have sprite sheets that contain only the drawings of the body parts used in your 
Harmony scene file.    You can also support multiple animations, such as idle, run, and jump, and reuse the same 
skeleton and drawings when possible by simply exporting new animation data. 

Toon Boom has fully integrated this solution with the Unity game development rendering engine. If you are 
creating your game in Unity, you have a seamless pipeline without the need to re-treat the data in your game 
engine. 
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Frame-by-Frame Export 

You can export from Harmony using an image sequence, which can be recompiled into a sprite sheet.

Advantage: You can use any of the tools in Harmony when you animate!

Disadvantage: These sprite sheets can become quite heavy and end up as large textures to process in the game. 
This may be fine for many games, like console games, but when you’re doing game development for mobile devices, 
such as iOS or Android, you need to be very light on your texture space. Also, file sizes should be kept under 50 MB 
to facilitate downloading without needing to be connected to Wi-Fi.

There is a script available in Harmony that allows you to export your animation in frame-by-frame to the EaselJS 
game engine   EaselJS is a javascript web compatible game engine.  It uses a json data structure to map each frame 
to an entry in the sprite sheet.  The data structure is easy to understand and can be adapted or converted to a 
different game engine if you need to.

To export to EaselJS, you need to add the script in the Scripting toolbar (TB_ExportToEaselJS).  This script is 
included in Harmony.  See the Scripting guide for more information on how to add the script to your Scripting toolbar 
and the interface parameters.

751



Chapter 10: Gaming in Harmony     About Game Asset Creation

About Game Asset Creation
In this section, you'll find guidelines for rigging, deformation, cutter and many useful animation tips.
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Game Rigging Guidelines
For complete procedures on how to rig a character, see—Rigging.

The following is a list of general guidelines to keep in mind when rigging your character. As you're planning the 
character rig for your game, keep in mind the style of the character, and create your custom colour palette.  
However, there are some limitations to consider if you plan to extract the game data:

 l Set your Harmony scene to be a square resolution (e.g. 1024 x 1024). You can do this in the Scene Setting 
dialog box—see the Reference guide .

 l Draw the art on the Line Art and Colour Art layers only. The information contained in the Overlay and Under-
lay will not be exported to Unity. It is however safe for using as a reference layer, just not anything that will 
be exported.

 l Create rigs in the Timeline view only.  The Node view can have complex connections that are not always 
interpreted well by game engines.

 l Nudge layers in Z space if you need to reorder layers.  However, significant Z offsets are not supported 
within a character rig. 

 l Make every layer in your game engine  a separate scene in Harmony.  If you have two characters at dif-
ferent depths, put them in separate scene files. 

 l Character rigs in groups at the root level of your Harmony scene will render to a single plane in Unity, but 
use separate sprite sheet and animation data sets.  Keep this in mind for scenes in which you may have 
more than one character interacting with each other. 

 l Don’t use any effects.  Effects like colour overrides are not interpreted by game engines.  Use only direct 
hierarchy, drawing swaps, and keyframe animation. 

 l Don’t use 3D space.  If you want to set things up in 3D space, you can do this when you get to your game 
engine. 

 l Set your pivot points on Peg layers using the Rotate tool to set the pivot on the entire layer.  Peg pivots are 
recommended over drawing pivots.  You should also set the pivot points on your drawing layers, even if 
you don’t animate on them, as this will allow you to retrieve the information later on in the game engine if 
you need to put a locator on a drawing layer.

 l Don’t use Morphing.  This is not yet supported in game engines. 

 l Both Morphing and Deform can be used and then baked out to individual drawings.  These drawings will 
then show up as new drawings in your sprite sheet.  Be wary of doing this too often as it will increase your 
texture space! 

 l For your pegs, when you animate, use Bezier curves and set them to Separate.  If you use 3D Path, it’s 
heavier than Separate. 

 l Be mindful of where you put your character before exporting. The master pivot of your exported game 
object will be the center of your Harmony scene (0,0).

 l Be sure to have a Display at the end of your hierarchy.

Keeping these tips in mind will allow you to create a tight, efficient 2D game character in Harmony while taking 
advantage of all the great tools. 

Here are some things you should do: 
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 l Create a simple parent-child relationship hierarchy in the Timeline view.

 l Use peg layers to contain keyframe animation data, set to Separate Position.

 l Use drawing layers to draw on, creating new drawings when needed.

 l Use the Rotate tool to set the pivot points on the peg layers.

 l Name your layers properly so if you need to fetch a specific layer’s pivot point later on in the game engine, 
you can easily recognize the layer you need.  If you have a top-level Group A, which has a child group inside it 
(Group B), and the drawing layer is a child of Group B, then the drawing layer is exported as A_B_Draw-
ingLayer.

 l Set your anchors and props, see—Setting Anchors and Props

You can use any of the drawing tools you want: Pencil and Brush tools, textured lines, solid areas, and gradients.  
Each individual drawing will be rendered out and assembled into a sprite sheet later.

NOTE: Because the Unity game engine does not support Unicode characters, it is recommended to avoid using 
it in scenes intended for games.
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Game Deformation Guidelines
Harmony can export deformations to the game engine XML format. Only hierarchies made of Game Bones can be 
successfully exported. In addition, Kinematic Outputs were implemented to complement your game bones—see 
About Game Bone Deformation on page 672. 

Although deformation comes equipped with a wide range of features, many were restrained to ensure that 
performance is on par with gaming industry standards. The following features are not compatible with the game 
engine SDK:

 l Zones of influence

 l Curve and Envelope deformations

 l Only a single pose is allowed per deformation hierarchy

The deformation in the game engine SDK does not behave exactly as the deformation in Harmony.

To comply with most game engines and maintain fast calculations, the SDK implements a linear base skinning 
algorithm to linearly blend the bones at articulations. You may notice some differences depending on the 
curvature of the articulations used.

NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Game Cutter Guidelines
The cutter, or mask, operation in Harmony is used for cutting off drawings with custom shapes. The game engine 
SDK implements both cutters and inverted cutters with the following limitations:

 l For a sprite, only a single cutter drawing can be applied when it is rendered. This also applies to a composite 
of multiple matte drawings. The game engine SDK will only use the first matte drawing during rendering and 
discard the others.

 l A deformed drawing cannot be cut, but a cut drawing can be deformed.    

NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Creating Metadata Notes
As you create assets for your game in Harmony, you may want to make notes about the scene or specific parts of 
the character or props for the programmer. These embedded notes that will be exported with your assets to Unity 
are known as metadata.

How to access the Metadata Editor view

 l In the top-right corner of a view, click the Add View  button and select Metadata Editor.

 l In the top menu, select Windows > Metadata Editor.

How to create scene metadata

 1. In the Metadata Editor view, in the Scene Metadata section, click on the plus button to create a new 
metadata entry.

The Add Metadata dialog box appears.

 2. In the Add Metadata dialog box, enter the name of your new scene entry.

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention 
must always use the prefix "game.". The term "game." is recognized automatically by Unity as a 
metadata information. For example: game.Armor001.

 3. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are through.

 4. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 5. Enter the value information for this entry. 

 6. Continue adding value information for all your entries.

This information will be exported with your Harmony assets. Once in Unity, scene Metadata will appear in 
Inspector view > Metadata when the asset is selected in the Hierarchy view.

How to create node metadata

 1. In the Timeline view, click on the layer to which you would like to attach metadata.

The name of the layer appears near the top of the Node Metadata section.
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 2. In the Node Metadata section, click on the plus button to create a new metadata entry.

The Add Metadata dialog box appears.

 3. In the Add Metadata dialog box, enter the name of your new node entry.

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention 
must always use the prefix "game.". The term "game." is recognized automatically by Unity as a 
metadata information. For example: game.Armor001.

 4. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple entries. 
Continue adding multiple entries, clicking Add after each one. Click Close when you are through.

 5. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 6. Enter the value information for this entry. 

 7. Continue adding value information for all your entries.

This information will be exported with your Harmony assets, more specifically, this information will be linked 
to the selected layer. Once in Unity, scene Metadata will appear in Inspector view > Metadata when the 
asset is selected in the Hierarchy view.
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Game Animation Tips
When animating for games, depending on the type of game you’re creating, you may need to limit your animation.  
For example, if you’re creating mobile games and you want to keep the file sizes small and playback fast on all 
devices, then limit yourself to simple keyframe animation with as few drawing swaps as possible.  If you’re 
creating console games, you have the freedom to create more drawings and have a higher complexity.  You can 
explore with your programmer the limitations of the platforms you’re exporting to, and what your game engine 
supports.

Here are some tips for efficient, lightweight animation: 

 l Use mainly transformations, such as move, rotate, scale, and skew. 

 l Create additional drawing swaps when needed.

 l If you use Curve and Envelope deformers or Morphing, you’ll need to bake out the drawings for export.  Be 
careful when doing this, as you may want to keep the number of drawings small.  Don’t bake out an entire 
sequence, just selected drawings. You don't need to bake the Game Bone deformers.

 l The bigger the drawings are in the Drawing view, the more pixels they will occupy in the texture size on the 
sprite sheet.  When setting up your rig, make sure to not scale individual layers by using a keyframe with 
the Transform tool.  If you want to scale things up or down, use the Select tool.  This will keep things the 
same relative size on the sprite sheet.  When you export the sprite sheets, in the script you can also set the 
resolution of the sprite sheet so the drawings can be scaled down for smaller devices.

 l Only drawings which are exposed in the scene will be exported to the sprite sheet.  For example, if you 
have 10 drawings in your Library view, but only two of them are showing in your scene, only those two will 
be exported.  This keeps the sprite sheet as tight as possible. 

Animating Multiple Sequences
You will always have multiple animations for your characters.  For example, an idle sequence, a run sequence, an 
action sequence, and so on.  You need to work in a specific structure so you can export all of these animations to 
a single sprite sheet. 

There are two different work flows that you can use:

 l Workflow 1: Separate Scenes 

 l Workflow 2: Separating Using Scene Markers

Workflow 1: Separate Scenes  

First, create a scene file with the name of the character, such as Space Duck.  This is the file where you can 
create or import your game rig. In the top menu, select File > Save As New Version, and give this new version 
the name of the animation.  For example, Idle. 

Every time you need to do a new animation using the same character, perform a Save As New Version.  In the 
end, you may have something like this: 

Scene: Space Duck 

Versions: 
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 l Idle 

 l Run 

 l Jump 

 l Shoot 

When you run the export script, it will export the drawings from the current scene into the export folder.  It will also let 
you know if there are any other scene versions that were already exported to that folder.  If so, then it will recompile 
the sprite sheet to include all the drawings from all the animations. This allows the maximum possible reuse of 
drawings. 

Workflow 2: Separating Using Scene Markers

You can also create all of your character animations in a single scene, one after the other, such as idle, run, jump 
and shoot. Then use scene markers to mark and separate the individual animations, see—Creating Scene Markers 
on Frame Ranges on page 387

When you are marking individual animation frame ranges, be sure that they start and end with a keyframe. Do not 
create scene markers for a range of frames that starts or ends in the middle of an interpolated movement.

When exporting your sprite sheet, in the Export To Sprite Sheet dialog box, be sure to check the Use Scene 
Markers to Export Clips option.

The animated clips are divided and listed in the stage.xml in the same way that they would appear if you had 
exported each animated sequence from separate scenes to the same file location.
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About the Orthographic Camera
In Harmony, there are two types of cameras available:

 l Perspective

 l Ortographic

The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to 
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the 
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with the 
orthographic camera, by default, you need to create a new custom scene resolution.
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Using the Harmony Game Previewer
If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, you can 
use the Harmony Previewer application. You can visualize your characters in the Unity game engine with no 
programming required.

How to use the previewer on Windows

 1. Download the Harmony Game Previewer for Windows:

 l https://docs.toonboom.com/go/download/GamePreviewer-12-2-windows

 2. Extract the following to your hard drive:

 l GamePreviewer-[version].exe 

 l GamePreviewer-[version]_Data folder

 3. Copy your export from Harmony to this folder:

 l GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\

 4. Start the Game Previewer application.

 5. Select the export you want to preview.

How to use the previewer on Mac OS X

 1. Download the Harmony Game Previewer for Mac OS X:

 l https://docs.toonboom.com/go/download/GamePreviewer-12-2-mac

 2. Extract the GamePreviewer-[version].app.

 3. Right-click on the GamePreviewer-[version].app and select Show Package Contents.

 4. Copy your export from Harmony to this folder: Contents/Data/StreamingAssets/HarmonyResources/

 5. Start the Game Previewer application.

 6. Choose the export you want to preview
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About Export to Unity
If you have a custom game engine, you can take the exported Harmony data and proceed with your usual 
process.  Or you can modify the export script to fit your convention.  

Before exporting a scene:

 l Be sure to set your Display as Display and not Display All.

 l Be certain to save your scene. Harmony makes the export based on the tvg files, any unsaved updates 
you have added will not be exported.

 l Set your Harmony scene to be a square resolution (ex. 1024 x 1024). Select Scene > Scene Settings.

The Transparency parameter attached to the element node is exported along with the animation. You can set the 
transparency through the Layer Properties window (Advanced tab).
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Clearing Scripts
If you were using Harmony 12.1 or earlier, it is strongly suggested that you clear your scripts before exporting 
animation for the first time. This will ensure there's no conflict with previous versions of the scripts and you have the 
most up-to-date script.

How to clear your scripts

 1. Close Harmony if it is open.

 2. Browse to the script folder location:

 l Windows:

 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon 
Boom Animation\Toon Boom Harmony\1200-scripts

 l Mac OS X: 

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down 
the Alt key.

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon 
Boom Animation/Toon Boom Harmony/1200-scripts

 3. Delete the 1200-scripts folder.

 4. Restart Harmony and test the export.
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Setting Anchors and Props
Before exporting to Unity, you need to set your anchors and props.

An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined 
by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily 
swappable from within Harmony or Unity.

How to set an anchor

 1. Create a new Drawing layer and rename it according to the anchor you are creating.

 2. Inside the Layer Properties of your drawing layer, make sure that pivot option is set to  Don’t Use Embed-
ded Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on Parent Peg 
does not transition well to Unity and you will lose your pivot information.

 3. Once this is done, you can use any of the animation tools to reposition the pivot point of your layer, such 
as the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot coordinates from 
the Layer Properties of your Drawing layer. If the pivot is not repositioned, its default place will be at the 
centre of your Harmony scene (0,0).

 4. Once this is set up, select the Drawing layer and click the Toggle Anchor  button in the Game toolbar. 
You can also make a multi-selection to set an anchor on multiple Drawing layers simultaneously.

The Drawing layer is highlighted in red in the Timeline and Node views. Your anchor can now be used to 
attach a prop.

How to set a prop

 1. Create a new Drawing layer or take an existing prop on which you want to attach an anchor.

 2. Position the Drawing Pivot of the prop layer using a tool on the Advanced Animation toolbar, such as the 
Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is positioned 
accordingly.

 3. With the prop Drawing layer selected, click the Toggle Prop  button in the Game toolbar. You can also 
make a multi-selection to set a prop on multiple Drawing layers simultaneously.

The prop Drawing layer is highlighted in green in the Timeline and Node views.

 4. Do one of the following:

 l Connect the anchor and prop to the parent peg.
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 l Connect the prop under the anchor to create a parent/child hierarchy.
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Exporting Sprite Sheets
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or 
multiple sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, 
and jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations in 
that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are exported 
individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite 
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but reusing 
the same skeleton.

NOTE: 
Programmers may be interested to note that the XML data exported by Harmony can be converted 
afterwards to a more optimized binary data structure.  To convert XML to Binary format, use the Xml2Bin 
utility. This utility converts the XML data structure generated through the Toon Boom Harmony software to a 
compressed binary data structure. This utility is available in the gaming SDK under 
/HarmonySDK/Source/Utils/.

 l Utills/macosx:- Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you want to 
integrate with other game engines.

How to export sprite sheets

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Sprite Sheets  button in the Game toolbar.

The Export to Sprite Sheets window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If not, you 
can save anywhere, then transfer the animation into your Unity project, or any other game engine you want to 
use.

 4. Set your sprite sheet preferences, see—the Reference guide .

 5. Click Export.
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Exporting to Easel JS
The Export to Easel JS window lets you flatten an image sequence of your animation. Even if you have a fully 
rigged puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened output 
of each frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work as you 
have access to any tools or effect modules you want to use. However, this can result in heavier files depending 
on the length, complexity and export size of your animation.

NOTE: 
Programmers may be interested to note that the XML data exported by Harmony can be converted 
afterwards to a more optimized binary data structure.  To convert XML to Binary format, use the Xml2Bin 
utility. This utility converts the XML data structure generated through the Toon Boom Harmony software to a 
compressed binary data structure. This utility is available in the gaming SDK under 
/HarmonySDK/Source/Utils/.

 l Utills/macosx:- Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you want to 
integrate with other game engines.

How to export to Easel JS

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Easel JS  button in the Game toolbar.

The Export to Easel JS window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If not, you 
can save anywhere, then transfer the animation into your Unity project, or any other game engine you want to 
use.

 4. Set your sprite sheet preferences, see the Reference guide .

 5. Click Export.
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About Working in Unity
The Harmony Gaming Animation Guide is a basic guide on how to import Harmony projects and configure them, 
design and animate characters, and includes some tips. It is not meant as a guide on how to program games.
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About the Sample Unity Project
Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported from 
Harmony.  Inside this project is an Assets folder which contains the following folders: 

 l Plugins 

 l Scenes (demo scenes and a previewer) 

 l Scripts (all Harmony scripts) 

 l StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder. This 
way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder.  You can also 
manually place exported Harmony data into this location.
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About the Unity Interface
Here are the main components of the Unity interface and their equivalents in Harmony:

Unity Harmony Description

Scene view Perspective view
This is where you set the scene, selecting and positioning 
environments, the player, the camera, enemies, and all 
other GameObjects. 

Game view Camera view
The rendered view from the camera(s) in your game. It is 
representative of the final, published game. 

Inspector Layer Properties
Displays detailed information about the selected GameOb-
ject, including all attached Components and their prop-
erties.

Hierarchy Layers in Timeline view
Displays the hierarchy of elements in the scene, and lets 
you set up parent-child relationships for different game 
objects.

Project Browser --- Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy.  To show a Harmony object, you must add a 
special component.  With the main camera selected, in the Inspector, select Add Component > Scripts > 
Harmony Camera.
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Importing Harmony Files into Unity
Once you've finished creating your artwork and cyclable animated character movements in Harmony, it's time to 
import them into Unity for game integration.

How to import Harmony files directly into Unity

 1. Create a Unity 2D project.

 2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought in. Do 
one of the following:

 l Go to the Unity Asset Store (assetstore.unity3d.com/en/#!/content/31211) and save the Harmony 
Game SDK file on your computer. Then import it in your project from the following: Top Menu > Asset 
> Import Package > Custom Package.

 l Search for the Harmony Game SDK in the Unity Asset Store, then download and import the package. 
You can access the Asset Store from the following: Top Menu > Window > Asset Store.

NOTE: For each new Unity project, you must repeat step 2 as it contains the necessary files and folders 
to make the Harmony import process work.

 3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >

 l Harmony Object:  Lets you browse for the exported Harmony project folder.  If you’ve 
already saved this to your StreamingAssets folder, you can browse to it through there.  
Then it adds the Harmony scene to your Unity file, and sets up the rendering, audio, and 
animation scripts you need to get going.

 l Harmony Texture Object: Lets you browse for the exported Harmony project folder 
similarly to Harmony Object, but creates a Unity plane to render your animation on it.
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About Game Objects
GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically 
everything you create in Unity will be a GameObject.  There are two main types of GameObject you can use to 
import Harmony data: 

 l Create Empty

 l Create Other > Plane 

To understand the process fully, there are two examples using an empty GameObject and a plane GameObject 
with the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your 
Harmony data.
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Using Empty Game Objects
An Empty Game object is a regular GameObject in which you can load the exported Harmony data.  All the individual 
body parts on the sprite sheet come in as separate elements, but are treated as one whole object with a dynamically 
created bounding box.  If you put a transparency on this object, you would see the overlapping transparencies of all 
the individual objects.  This creates a higher-quality render and should be the default if you’re not animating the 
transparency of an object.  With this option, direct rendering will read the depth information in the scene but not write 
it.  Note that with this option, the rendering cannot be customized. 

How to use an empty GameObject

 1. Select GameObject > Create Empty.  

 2. Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo file, 
rename the GameObject to SpaceCat by doing one of the following:

 l Double-click on the name and rename it in the Hierarchy.

 l Select the GameObject and rename it in the Inspector. 

 3. At this point, it’s an empty object.  Accessing Harmony data is done through scripts.

 l Select the SpaceCat GameObject. 

 l In the Inspector, go to Add Component > Scripts > Harmony Renderer.

A new section appears in the Inspector called Harmony Renderer (Script).
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This will let you load an animation file.  You must put the path of the asset relative to the 
HarmonyResources folder.  Before this, you must export from Harmony directly to this folder, or manually 
copy and paste the data here.

 4. You exported a scene called SpaceCat.  In the Project Folder, place HarmonyResources/SpaceCat 
under the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z because the 
default Harmony project is for an HD screen.

 5. You won’t see anything until you define a few parameters:

 l Set the Clip Name Size to 1. A second field will appear, Element 0. 

 l Enter the clip name for the animation you want to load.

 6. Double-check on the right Clip Name to put in Element 0; you can check the output you exported from Har-
mony.  

 7. Double-check the stage.xml file, which was exported to the folder you specified when exporting from 
Harmony.  Our default export path is to StreamingAssets, so it will automatically load in the game engine.

 8. Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName]. 

You’ll find the data that was exported.  In this case, we’re looking for SpaceCat. Select the file marked 
stage to load the data you want to double-check. 

The text data appears in the Inspector.
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The name to use for loading the object is the stage name.  In this case, SpaceDuck_SpaceCatIdle.

 9. If your GameObject has animation in it, and you want it to load the animation data from the Harmony export, 
add one more component by doing the following:

 l Select the GameObject.

 l In the Inspector, select Add Component and select Scripts > Harmony Animation. 

 10. To loop the animation, you must set a GameObject to define it:

 l Select  GameObject > Create Empty and rename it: LoopAll.  

 l Click the LoopAll GameObject to display its properties in the Inspector. 

 l Click Add Component > Scripts > Loop All.   

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on all 
GameObjects on runtime and asks them to loop, which is useful when testing the animation.  When 
programming the actual game, you should write additional scripts to control the different elements separately.
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Using Plane Game Objects
Renders the entire character to a plane. This renders your character to texture data.  If you animate the 
transparency of the plane, then the transparency of the rendered output is animated; you won't see the 
transparencies of the overlapping elements.  However, you will have one static bounding box the size of the plane 
that you render to. 

Use this option when you want to animate the transparency of a character in a scene.  Also, you can write your 
own custom shaders.  Simply set the Render Target to eRenderTarget.   You can see an example of this in the 
sample project DemoRenderTarget.  

 How to use a plane GameObject

 1. Select GameObject > Create Other > Plane.  

 2. Select Add Component > Scripts > Harmony Renderer. 

 3. Set Size to 1 and Element to 0 on the clip name as per previous instructions. 

 4. Set Render Target to eRender Texture.  

 5. Render Texture Viewport:  

 l X: To reposition the animation correctly; it should be -½ the width of your Harmony project.

 l Y: To reposition the animation correctly; it should be -½ the height of your Harmony project. 

 l W: Width of your Harmony project 

 l H: Height of your Harmony project.  

 6. Use the custom Shader created by Toon Boom to have a transparent background with premultiplied alpha 
channel.  This is what produces nice, antialiased drawings in your output.  

 7. With the Plane selected in the Inspector, go to Mesh Renderer > Materials. Under Element 0, select 
UnlitTransparentPremultiplied. 

 8. If you're starting with the Toon Boom demo project, this renderer should already be loaded in your list. 

You can also write your own custom shaders and use them here. 

 9. You must also add the animation component.  Select the Plane. In the inspector, click Add Component > 
Scripts > Harmony Animation.

Once your Harmony GameObject is imported, you should be able to see your character both in the Scene and the 
Hierarchy views. From here you can attach one or several props to an anchor.
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Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined by 
the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a helmet 
attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily 
swappable from within Harmony or Unity.

How to attach the prop to an anchor

 1. Open up your character in the Hierarchy view to have access to both the props and the anchors. 

 2. Click on the prop you wish to attach, and drag it onto the appropriate anchor. 

 3. Repeat these steps for each prop and anchor in your project.

 4. In the Inspector view, under Frame, you can select which frame you wish to show. If you only had one draw-
ing in your prop, then you will not have multiple options.
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 5. If part of your character is cut off by the plane of the character, now that the props are showing, you will 
need to regenerate the mesh. To do so, select your GameObject. After this is done, go to Inspector View 
> Render > Generate Mesh.
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Placing Locators in Unity
In Unity, it's possible to assign a target to some part an imported Harmony animation.  For example, in the Space 
Duck scene, the character has a gun. You may want to attach some other action to this animated gun, such as 
shooting spheres and cubes out of its end. For this, you need to place a locator at the end of the gun. 

You can see some examples of this in the provided Unity project.  The first example is in the demo scene 
DemoLocator,  which shows a simple cylinder attached to the end of the gun. 

The second example DemoCallback shows the gun shooting spheres and cubes.

You can access any drawing layer created in Harmony later in Unity and use its pivot point to attach objects and 
animated sequences. In Harmony, you should set the pivot points on your drawing layers with the Rotate tool.

You can also create an empty drawing layer in Harmony, when setting up your character, to be used later in Unity. 
Use Create Empty Drawing to create a blank drawing, then use the Rotate tool to set the pivot point on this drawing 
layer.  In the Space Duck example, an empty drawing layer called hook_gun was created on which you can attach 
the locator in Unity. 

When you access the imported Harmony character in Unity, you can access the data with a script.  

How to set a locator to a part of a character

 1. Select Game Object > Create Empty to add a new GameObject to extract the target's position, rotation, 
and scale. 

 2. Drag and drop the new object so that it's a child of the character. 

It becomes indented.  

 3. Rename the GameObject to: Hook Gun.

 4. In the Inspector of the target object, select Add Component > Scripts > Harmony Locator.

 5. Enter the name of the drawing layer to which you want to attach.

 6. To find the exact name for the Locator Name, look at the skeleton.xml file in the Streaming Assets folder.  
You can find it in Streaming Assets > Harmony Resources > Name of Harmony File > skeleton.
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All the drawing and peg layers are listed. In this example, look for  space_duck_hook_gun. Having 
drawing layers with distinctive names makes them easy to recognize when you need to retrieve them.

You can copy the name of the layer into the Locator Name to see the Transform information updating 
dynamically as you run the simulation.

 7. Now you can attach anything as a child of this Locator Object.  For testing purposes, you could attach a cyl-
inder for example.  In a real example, you’d want something to shoot out of the end of the gun, so you can 
see the Callback example to verify how that works.
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Setting Up Collisions in Unity
Extracting the bounding box information is useful when you want to make something collide with your character.  
When you put a 2D character into a 3D scene, you may want to use Physics to make the 2D character collide with 
the 3D plane.  To use the following scripts, you will need Unity 4.3 or higher. 

In the Demo scene, open the DemoPhysics example to see collisions and bounding boxes.  In this example, there’s 
a 3D plane and some 2D characters.  The 2D characters have a collision defined with their bounding box, and they're 
also reacting to the physics of the scene to fall with gravity. 

Colliders were improved to provide several different types of colliders for use in Unity. You can select polygon 
colliders and box colliders for a more accurate bounding box.

How to set up collisions

 1. Select your imported character.  

 2. In the inspector, select Add Component > Physics 2D > Box Collider 2D.  

 3. To enable the Physics on the character, go to Add Component > Physics 2D > Rigid Body 2D.  

NOTE: You can also use 3D physics on the imported files. 

You can now adjust the variables and see the results.
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About Working with Audio in Unity
When you create scene files in Harmony with audio, the audio is exported into the project folder.  However it’s 
important to understand how the game is built to determine the best way to handle audio.  

When a game is built from Unity, it creates its own database for holding the assets.  Within the export, the 
Streaming Assets folder is preserved intact.  This is what enables the Toon Boom plugin to access those assets 
on the fly, and render them in the camera to create the final animation you see on the screen. 

However when it comes to audio, the game first looks for the audio in the Unity database. So this is the most 
efficient place to store the audio for the real game.

If audio can't be found in the Unity database, then the game looks in the Streaming Assets folder to find the audio.  
When it does, it copies the audio on-the-fly back into the Unity database.  Since this action is quite costly, don’t 
leave the audio in the Streaming Assets folder for the final game.  It’s fine to leave it there while you’re testing, but 
not for the final game.  

The audio should be copied back into the Unity database, either manually or by automating this process with a 
script.
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Chapter 10: Troubleshooting
Unity Questions

Q. My Harmony asset does not appear in the Unity Editor.

A. There are several possible reasons for this. Check the following:

 l Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory?  The plugin is 
named HarmonyRenderer.bundle on Mac OS X and HarmonyRenderer.dll on Win-
dows.

 l Is the clip name valid ? Make sure the clip name exists in the stage.xml file.

 l Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a newer 
version, make sure to regenerate the binary files if you use them so they’re compatible with the 
SDK.

Q. My Harmony asset does not appear in iOS or Android when exported from Unity.

A. There are several possible reasons for this. Check the following:

 l Make sure the Harmony assets are copied in the StreamingAssets directory. Since the Har-
monyRenderer plugin cannot use Unity’s asset database, the Harmony assets were packaged 
as plain files so they are accessible to the plugin.

 l Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is in the 
Assets/Plugins/iOS directory.

 l Is the clip name spelled correctly? Windows and Mac OS X aren’t usually case sensitive file 
systems, but iOS and Android are. This implies that an asset that is visible on the editor will not 
appear on the mobile platform because it cannot be found.

 l Make sure the size of your sprite sheets does not exceed the hardware limit of the device 
you're working on. Otherwise, the texture might not appear at all.

 l Is the path to the project folder an absolute path? If it is, it might not work on the mobile device 
as that path will not exist on the platform. Make sure to use relative paths to the Stream-
ingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always appear 
behind the Harmony assets even if I change the order index in the GameObjects.

A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are, however, 
several solutions for working around this problem:

Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite like 
the other 3D elements in the scene and you can change the compositing order by incrementing or decrementing the 
Z value of the transform.

Use multiple cameras to render your scene in parts. Here’s how:

Harmony Camera

 1. Create a new camera.

 2. Make sure you set the Harmony GameObjects to a specific layer (top-right of the game object inspector).
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 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in the back-
ground).

 4. Add the HarmonyCamera component to this camera so the Harmony GameObjects render properly.

Sprite Camera

 1. Create a new camera.

 2. Make sure to set the 2D sprite objects to a specific layer.

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in front of the 2D 
sprites).

 4. Make sure to set the clear flags to Depth Only or Don't Clear.

 5. Set the depth to be higher than the Harmony camera.

 6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to keep 
Game Ojects in sync.

Q. How can you specify the frame rate of the animation?  My animation does not play at the same frame rate in 
Harmony and in the Game Previewer in the Unity Editor.

A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the 
HarmonyAnimation component, you can schedule animations at the speed you want.

Example

HarmonyAnimation animation = GetComponent<HarmonyAnimation>();

if (animation != null)

{

animation.PlayAnimation( frameRate, clipName );

}

Q. I cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?

A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer component 
in the GameObject, and so cannot be shown directly in the Scene view.

However, you should still be able to preview your assets in the Game view (even when not playing).   To help find 
and position assets, we also added bounding box shapes rendered in the editor and the Game view.

Q. How is memory management handled in Unity for Harmony assets?

A. Most of the memory extensive algorithms are executed in the C++ plugin.  The data structure is maintained 
alive as long as a GameObject refers to it.  This means you can instantiate as many clones of a character without 
reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its 
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject 
uses them and a cleanup call is issued once they are destroyed.

Q. The Harmony assets memory does not appear in the Unity profiler.  Can we profile the assets memory?

A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a 
C++ plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers such 
as the one provided with XCode or Visual Studio should allow you to track your application’s memory including 
the Harmony assets and should also provide a more accurate result.
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General Questions

Q. How can you specify the resolution used for the drawings in the sprite sheet?

A. The drawing resolution is not fixed in Harmony.  Since you're exporting the scene to multiple sprite sheets in 
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to see 
the resolution of a drawing compared to the rest of the scene.  By enabling the light table in the Drawing view, you will 
see all of the scene’s drawings untransformed in the same proportion as they will appear in the sprite sheet. More 
specifically, the resolution used in the sprite sheet for a drawing is the size it appears untransformed in the Camera 
view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export Sprite Sheet dialog box).

Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a drawing 
and use the Transform tool to scale it back up so it does not change visually in the Camera view. This should allow 
you to alter the size of drawings in the sprite sheet.

Q. The assets take time to load on mobile devices. Is there any way to speed up the process?

A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines. 
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project. At 
some point, they should be converted to a binary compact data structure that can be read into memory a lot faster 
than the XML.

You can use the Xml2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool is in 
the Utils/Xml2Bin folder and a precompiled version for Mac OS X is available in the Utils/macosx folder.

Q. There are problems with the character I exported in the game engine. Pieces are not exported or are not showing 
in the proper order. What can I do ?

A.  To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are some 
of the key points for building a character that is compatible with the rendering in the game engine SDK:

 l Build your rig in the Timeline view. The game engine SDK data structure is similar to what is dis-
played in the Timeline view and an advanced node system might not always export properly.

 l Because every top level node in your scene will render separately in the game engine SDK, 
they may not intersect. A top level node is also isolated in its separate sprite sheet to allow the 
artist better memory segmentation of the character. If you created a character with top level 
nodes and this was not the intended result, create a top level group or peg to group them all 
together.

 l Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its parent 
(as it does in Harmony).  To change the ordering, add some Z offset to the child layer.

 l The export script does not handle plain bitmap images.  Toon Boom vector drawings and Toon 
Boom bitmap drawings are supported though.

 l The export script does not handle symbols.
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Chapter 11: Library
T-RIG-009-001

Using templates and symbols, you can share and reuse any elements you create in Harmony. The Harmony library 
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact, 
anything you create in Harmony can be stored in the library.

The Library view is where you can store and reuse your artwork and animation in other scenes or build props and 
puppets.

The library is a storage centre for all production assets; the elements stored in the library are called templates. 
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation 
processes. The library can contain any asset used in a Toon Boom Harmony production. 

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to the 
Timeline or Camera view when you want to reuse it.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 

When working on the database, the structure of the library differs from when working on Harmony Stand Alone. 

Harmony Server provides three default library folders: 

 l Symbols: The only library folder containing symbols for your project. You can organize the symbols library 
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your 
project. 

 l Environment: A folder located inside the Environment folder. Every asset stored in this folder is accessible 
from any job and scene contained within this environment. 

 l Job: A folder located inside the Job folder. Every asset stored in this folder is accessible from any scene con-
tained within this job. 

791



Chapter 11: Library     

NOTE: You can create a folder called library  in the usa_db folder on the server to create a global library. Once 
the Harmony application is restarted, a Global  library folder automatically appears in every user's library. 
Every asset stored in this folder is accessible from any scene, job and environment. 
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About Structure
As you will probably create a large number of symbols and templates, you will soon realize they need to be 
organized. You can create different libraries and subfolders to easily access your assets. For example, you can 
create a different library for each project and divide it into several categories, such as:

 l Characters

 l Props

 l Backgrounds
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Creating Libraries
There are two ways to create libraries. 

 l Directly through your operating system

 l Using Harmony's interface

Although you can only have one symbol library folder, you can organize it by creating subfolders.

How to create a library folder through your operating system

 1. On your computer, create a new folder with a relevant name in the location where you want the library to be 
stored.

How to create a library folder in Harmony

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library folder.

 3. Click the New Folder button.

A new folder appears.

 4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.
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Opening Libraries
Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as a 
library. Opening a library means linking the folder to your Library view. You only need to open the library once. The 
library folder is available every time you open the application until you decide to close the library and unlink it.

How to open a library

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library Folders section.
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Closing Libraries
You may not always require all the library folders in the Library List. If so, you can close the ones you do not need. 
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your 
hard drive or network and open it in the Library view.

How to close a library

 1. On the right side of the Library view, select the library folder to close.

 2. In the Library View menu, select Folders > Close Library.

The library closes.
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Creating Folders
T-ANIMPA-003-009

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in the 
Harmony Library view, so you can easily access assets. By default, any new library you link to your Library view is 
locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right to modify it 
before being able to add a new folder to it.

How to create a folder

 1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

 2. In the Library View menu, select Edit > Right to Modify.

 3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign 
to expand it.
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Deleting Folders
You can delete a folder from the library if its contents are no longer needed.

NOTE: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data 
cannot be retrieved.

How to delete a folder

 1. In the Library view's left side, select the folder to delete.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select 
Right to Modify.

 3. In the Library View menu, select Folders > Delete Folder or press Delete.
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Renaming Folders
Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

 1. In the Library view's left side, select the folder to rename.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select Right 
to Modify.

 3. In the Library View menu, select Folders > Rename Folder.

 4. Rename the selected folder.

 5. Press Enter/Return to validate the operation.
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Refreshing Libraries
If you update the content of your libraries through your operating system, you will need to refresh your library 
folders in the Library view.

How to refresh a library

 1. In the Library view's left side, select the folder to refresh.

 2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.
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Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for 
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

How to generate thumbnails

 1. In the Library view's right side, select the template in which you want to generate thumbnails.

 2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.

801



Chapter 11: Library     Deleting Thumbnails

Deleting Thumbnails
You can also delete thumbnails if you want to send a template to another user or studio and keep your packages 
small.

How to delete thumbnails

 1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Searching in Libraries
When working on a movie or series, you will probably end up with many templates and symbols in your library. Using 
the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

 1. From the left side of the Library view, select the library in which you want to search.

 2. In the Search field, type the name or partial name of the symbol or template you are looking for.

 3. Click the left  and right  arrows to see the previous and next results. The Search engine will look for 
results within the library master folder and its subfolders. It will not look in other libraries.
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About Templates
When you want to reuse artwork and animation from your project in other scenes, you must create a template. A 
template can be seen as a portable scene or package that you can drag inside your project. A template is an 
individual copy of the artwork stored in the library which you can reuse in different scenes. Once a template is 
stored in the library, you can access it from any project.

 

Master Template

You can create a master template out of a cut-out puppet you created so you can reuse it throughout a single 
project or a full production. A cut-out character's master template stores the entire rig, structure, drawings, and 
keyframes of the different poses of your puppet into a single asset.

Master templates are created from the Node view.

The Timeline view and the Node view display different information about a scene and its structure. To make sure 
a character's main template, also called the master template, is rigged exactly the way it was meant to be when 
it's imported into a scene, it should be created with all the connections, effects, composites, nodes, pegs, 
groups, drawings, timings, as well as all the other information in the scene it was originally created in. Because 
the Node view is the most faithful representation of a rig's structure, it is recommended to create master 
templates from the Node view rather than the Timeline view. 

Action Templates

An action template, also known as  animation template, is created from the Timeline view. This template allow 
you to reuse animations, key poses and part of an animation and contains mainly keyframes and drawing 
exposures. For example, you can reuse head positions or a leg animation from a walk-cycle and place them 
inside other animations. When it is extracted from the Timeline view, it loses the extra connections, effects, and 
groupings from the Node view.

An action template is used with a master template. It cannot be used on its own since it does not contain all the 
information required to rebuild the puppet skeleton and advanced connections. The standard process is to first 
import the master template to the Node view or Timeline’s left side, and then slide the action template into the 
Timeline’s right side. This allows you to first build the skeleton and then give it the right pose.

The combination of master and action templates will function as long as the layer order and connections are the 
same.

When you create an action template, be sure to name it so you can easily identify it as an animation.
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Creating Templates
T-ANIMPA-003-010

You can create a template from both the Timeline and Node views. When creating templates of 3D objects, all 
associated textures linked to Maya files will be incorporated into the template.

NOTE: If you are creating a template from a character rig master template, you should collapse everything 
inside a master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting the root 
layer. This can be useful for creating templates based on character rigs or scene backgrounds.

 2. In the Library view, select a folder to store the template. By default, a local scene will have a Harmony 
Premium Library folder, which is stored in your Documents folder. 

 3. If the library folder is locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 
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 5. In the Rename dialog box, give the new template a name.

 6. Click OK.

NOTE: To rename a template once it is created, right-click on the symbol and select Rename, or double-
click on the template's name.

How to create a template from the Node view

 1. In the Library view, select the folder in which you want to store the template.

 2. If the library folder is locked , right-click and select Right to Modify. 

 3. In the Node view, select the nodes for creating the template and group them. It is very important to group 
your cut-out character rig before storing it in the Library, so your files are organized.

 4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or 
⌘  + G (Mac OS X). Make sure you have a composite under the connections before grouping, otherwise 
there will be numerous connections going outside the group.

 5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

 6. In the Node view, select the group node and copy and paste it inside the template folder in the Library view 
or press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X).
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 7. In the Rename dialog box, give the new template a name and click OK.
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Deleting Templates
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary. 

How to delete a template

 1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Delete or press Delete.
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Editing Templates
You can open a template and edit it just like any other project. If you want modify your templates, you can edit them 
using the Edit Template command.

How to edit a template

 1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

 3. Edit the template.

 4. From the top menu, select File > Save.

 5. In the top menu, select File > Quit (Windows/Linux) or Harmony Premium > Quit (Mac OS X).
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Importing Templates
There are several ways you can import templates in your scene.

For greater control over how the action template behaves when brought into the Timeline view, you can use the 
Paste Special feature—see Using Paste Special on page 827.

NOTE: Dragging a template into your scene copies the content in your Timeline and does not link it to the ori-
ginal. You can modify this individual copy at any time.

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If you 
drop a template in the layers list in the Timeline view, it will be inserted between the layers where you 
dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template directly 
onto the frames on the right side of the Timeline view. Instead of inserting new layers into your scene, this 
will replace the drawings and keyframes in your scene with the ones from the template. This is useful for 
importing pose or animation templates for characters that are already in your scene. 
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How to import a Node view template

 1. In the Library view, select the template or symbol you want to import.

 2. Drag the selected template to the Node or Camera view or the left side of the Timeline view.

 3. If necessary, in the Node view, connect your template to the Composite node. To do this, click its out-port 
and drag the connection to the Composite node until an in-port appears.

 

811



Chapter 11: Library     Importing Templates

NOTE: If the template you are importing was created in the Node view, make sure to drop it in the Node view 
or on the left side of the Timeline view. Otherwise, some network connections could be broken. If you are 
importing a template containing the exact same connections as a template you imported previously, you can 
drop it on the Timeline view's right side over the existing layer. This will combine both templates and keep the 
same existing layers.

How to import a template with symbols

 1. From the right side of the Library view, select the action template that contains symbols.

 2. Hold down Alt as you drag it from the Library view to the right side of the Timeline view and drop it next to a 
template with the exact same rig.

The Paste Special window opens.

 3. Select the Advanced tab.

 4. Select one of the following options from the Symbols menu:

‣ Copy symbols if they do not exist: This is the default setting for this operation and will prevent 
symbols in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.
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Opening Templates as Folders
Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In 
this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

How to open a template as a folder

 1. In the Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

 2. Right-click on the selection and select Open As Folder.

 3. In the library list section, click on the template's folder to display its content.

 4. Drag the content to the Timeline or Colour view.
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About Symbols
A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain 
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in 
which you place a series of different drawings for each body part of your puppets or when you have a repeating 
cycle. However, symbols are not necessary for creating characters. 

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest 
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the 
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on 
the symbol's name to move up the chain.
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Creating Symbols
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also 
create symbols out of each body part in your cut-out puppets.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into 
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the Timeline 
view, they will all be linked to the original symbol. If you modify one, they will all be modified.

How to create a symbol from the Timeline view

 1. In the Timeline view, select the layer or cells from which your want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.
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The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the 
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.

 How to create a symbol from the Node view

 1. In the Node view, select the nodes from which you want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X) your selection 
to the Symbol folder in the Library view.

The Create Symbol dialog box opens.

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.

The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the 
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.
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Creating a Symbol from a Drawing
You can create a symbol from a drawing selection.

How to create a symbol from a drawing selection

 1. In the Tools toolbar, select the Select  or Cutter  tool.

 2. In the Camera view, select the drawing elements to create a symbol.

 3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.

 4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol on 
the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new 
layer.

 5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select the Cut 
Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut Artwork 
From Source Drawing option.

 6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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Creating Empty Symbols
You can create a symbol without any artwork in it.

How to create an empty symbol

 1. In the Library view, select the Symbol folder.

 2. Do one of the following:

 l In the Library view's right side, right-click and select New Symbol. 

 l From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top  button in 
the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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Deleting Symbols
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the 
data. The symbol cannot be retrieved once you close the application.

How to delete a symbol

 1. In the Library view, select the symbol to delete.

 2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the 
symbol from the library and scene.
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Editing Symbols
You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the 
position where they were created. The pivot is translated at the centre of the symbol.

How to edit a symbol from the Timeline view

 1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E (Mac OS X)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

 2. Do one of the following:

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift + E 
(Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

 1. In the Library view, select the symbol to edit.

 2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift 
+ E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

How to edit your symbol in the Node view

 1. In the Node view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or ⌘  + E (Mac 
OS X) to use the Edit Selected Symbol command.

 2. In the Node view, inside the Symbol’s top node is the composition of your symbol. In this example, a group 
node was turned into a symbol.

 3. In the Camera view, edit your symbol.

 4. In the Node view’s top-left corner, click the Top  button to return to the top node. Or press Ctrl + Shift + 
E (Windows/Linux) or ⌘  + Shift + E (Mac OS X) to use the Leave Current Symbol command.
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Importing Symbols
There are several ways you can import symbols in your scene. 

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If you 
import a symbol into your scene several times in the Timeline view, they will all be linked to the original symbol. If 
you modify one, they will all be modified. 

How to import a symbol in the Timeline view

 1. In the Library view, select the symbol you want to import.

 2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into 
the Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be 
more efficient to arrange them into their correct places as you bring them into the scene.

Expanding Symbols
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The 
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline. 
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer that 
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may have 
created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you 
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to expand a symbol

 1. In the Timeline view, select the symbol to expand.

 2. From the top menu, select Edit > Expand Symbol or press Shift + F8.
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How to expand a symbol in a group

 1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

 2. From the top menu, select Edit > Expand Selected Symbol in a Group.

 3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand 
Arrow to enter the group.
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Converting Symbols to Templates
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in 
another scene, you must create a template. This conversion breaks the drawing's link with both the original scene 
and symbol. It then becomes a separate entity that you can import into other projects.

How to convert a symbol into a template

 1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline 
view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the 
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.

 2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other lib-
rary folder. Make sure you have the right to modify the library folder.
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 3. In the Rename dialog box, rename the new template.

 4. Click OK.

Importing Files in the Library
Harmony lets you import sound files and images directly through the Library view. Simply open the folder 
containing your files in the Library view and drag them directly from there.

How to open a file through the Library

 1. In the Library view menu, select Folders > Open Library.

 2. Browse for the folder containing the files you want to import.

 3. Click Open.

 4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can 
choose to import only the keyframes without the drawings or import only the drawings that are not already in your 
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene, 
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be 
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the 
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you 
import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

 3. Set the parameters—see the Reference guide .

 4. Click OK. 
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Chapter 12: Cut-out Animation
Harmony provides some great tools for rigging and animating cut-out character models. You can make simple  rigs or 
give your characters flexible capabilities using peg hierarchies, groups, composites, cutters, and deformers, among 
other things. You can create basic animations with the Transform tool, or more advanced animation with Inverse 
Kinematics as well as Bone and Curve Deformers. Harmony also supports advanced onion skin and image 
swapping features to help you animate efficiently and quickly. 
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About Animating with the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has many 
useful functions: 

 

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from 
their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when many 
parts are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out 
animation.

When animating with the Transform tool, make sure to select the right selection mode. In this example, make 
sure that the Peg Selection  Mode  is disabled in the  Tool Properties view or it will limit the selection in the 
Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward 
Kinematics equivalent. 
The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global 
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the permanent 
pivot is displayed as a ghost. 

NOTE: The interpolation of the animation poses is always calculated from each individual part's permanent 
pivot. If there's a parent peg on a limb, make sure to select it instead of making a selection of each part to avoid 
setting individual keyframes.
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Animating with the Transform Tool
The Transform tool allows you to move, rotate, scale and skew a selection or multi-selection. 

How to animate using the Transform tool

 1. In the Tools toolbar, click the Transform  tool or press Shift + T.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Timeline view, go to the frame on which you want to set the first position.

 4. In the Timeline toolbar, click the Add Keyframe  button or press F6. It is recommended to add a key-
frame before moving the character. Moving a character's part without setting a keyframe will create key-
frames only on certain parameters of the animation. You could run into issues later on when setting poses 
between existing ones. Creating a keyframe on all layers and parameters will ensure your pose is set and 
will not be modified by other poses later on.

 5. In the Camera view, select the element to animate and move it.

 6. In the Timeline view, go to the frame where you want to set the next position.

 7. In the Timeline toolbar, click the Add Keyframe  button or press F6.

 8. In the Camera view, animate the character.
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Resetting Transformations
With the Reset command, you can return a selected element to its initial position and scale values, depending on 
which tool is active. For example, if the Rotate  tool is active, the transformation angle will be reset to 0 and if the 
Transform  tool is active, then all transformation  values will be reset.

The Reset All option Resets all transformations on the current frame in a selected layer. Your keyframe will remain, 
but all the values will return to the starting value. All transformations are reset regardless of the tool you're using.

The Reset All Except Z option resets Resets all transformations on the current frame except the Z position. This is 
useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views of a 
character. You might want to reset the transformation, but not necessarily the Z position. 

NOTE: When using the Transform  tool to select elements in the Camera view, always make sure the Peg 
Selection Mode  option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were 
created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformation values except Z

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.

833



Chapter 12: Cut-out Animation     About Animating with the Transform Tool

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all keyframes 
and reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all key-
frames and reset all values for the entire layer.

The selected layers return to their original position.
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About Hierarchy Navigation
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the parent-child 
chain. You can navigate between the children of the same parent. You can also easily center on your selection in the 
Timeline or Node view.
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Navigating Layers
Navigate between the layers in the Timeline view, using keyboard shortcuts or the Animation menu. This way of 
navigating only works for unparented layers or the children of a parent layer. If you are navigating between 
unparented layers, parent layers can be selected, but their children will be skipped. If you start on a parented layer 
(child), only the other children of the same parent will be available for selection.

How move up and down the layer stack

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Camera or Timeline view, select an unparented layer or child layer of a parent with several children.

 3. From the top menu, select:

 l Animation > Select Previous Sibling or press / to select the previous child layer.

 l Animation Select Next Sibling or press ? to select the next child layer. 
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Selecting Parent and Children
When animating, large movements that are made at the root (parent) of a chain cause secondary movements 
throughout the rest (children) of the chain. For example, when you rotate the arm of a character from the shoulder, 
the forearm and hand will follow. However, in order to make the movement appear natural and graceful, the forearm 
and hand should not move at the same speed or angle. As a result, animators often need to move up and down a 
chain, intermittently selecting parent and children, in order to make both large and fine movements.

How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select Anim-
ation > Select Child or press Shift + B to select the child layer or Animation > Select Children to select all 
child layers at the same time.

NOTE: These keyboard shortcuts ignore any effect node encountered in the Node or Timeline view. Only draw-
ing and peg nodes are considered. If you want to navigate the hierarchy including the effect nodes, you can cre-
ate a custom keyboard shortcut in the Preferences dialog box for the Select Parent Skipping Effects and Select 
Child Skipping Effects commands on the General tab. Refer to the Harmony Preferences Guide  to learn how to 
create custom keyboard shortcuts.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it hard 
to locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar to 
focus on the selected node in the Node view. You can also select elements in the Timeline or Xsheet view. This 
can be useful when there are too many objects in the scene or when an object is hard to grab. Finally, you can 
select all the elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. Do one of the following:

 l From the Timeline view menu, select View > Centre on Selection or press O.

 l In the Timeline view toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Node view

 1. In the Camera or Timeline view, select a layer.

 2. Do one of the following:

 l From the Node View menu, select View > Centre on Selection. 

 l In the Node View toolbar, click the Centre On Selection  button. 

 l In the Node view, press O.
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About Keyframes
Keyframes are the building blocks of Cut-out animation. Unlike Traditional animation, where every pose is drawn, 
Cut-out animation uses keyframes to mark major poses (key poses) and lets the software create all the poses in 
between.

In Harmony, you can create two kinds of keyframes: Motion and Stop-Motion. Motion keyframes behave like the 
description above; they allow for the automatic creation of drawings between two keyframed poses. Stop-Motion 
keyframes do not allow for interpolation between keyframes. They are often used to block poses, somewhat similar 
to what you would see in Traditional Animation.
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Creating Motion Keyframes
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using 
motion keyframes. When you use motion keyframes, the drawings gradually move to the next position instead of 
staying on the spot until the next keyframe.

How to  create motion keyframes

 1. In the top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click on the selection and select Insert Keyframe. 

 l Click the Add Keyframe  button in the Timeline toolbar.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected ele-
ment, a keyframe will be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

 1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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 2. Do one of the following:

 l Right-click on the selection and select Set Motion Keyframe. 

 l Click the Motion Keyframe  button in the Timeline View toolbar.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X).  
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Creating Stop-motion Keyframes
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing key 
poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the interpolation 
between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is 
constant. There is no animation generated by the computer between the poses. The drawing remains in position 
until the next keyframe, then moves to its new position.

How to create stop-motion keyframes

 1. In the top menu, make sure the Animation > Stop-motion Keyframe option is selected.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click and select Insert Keyframe. 

 l In the Timeline toolbar, click the Add Keyframe  button.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected ele-
ment, a keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe

 1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

 2. Do one of the following:

 l Right-click and select Set Stop-Motion Keyframes. 

 l In the Timeline toolbar, click the Stop-Motion Keyframe  button.

 l Press Ctrl + L (Windows/Linux) or ⌘  + L (Mac OS X). 
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About Swapping Drawings
T-RIG-004-001

Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the animation 
a more traditional animation look. You can add as many new drawings as you want in your scene and use them in 
your current animation. You can also add new drawings to the library and  use them in other scenes. But before 
starting to swap drawings, it's important to understand how keyframes, exposure and key exposure work in 
Harmony:

 l Keyframe: A keyframe is a point in time where a change to the properties of the object or character 
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its con-
tents are moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

 l Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. 
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Key-
frames can be moved independently from the drawing exposure. 

 l Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed 
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for 
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony auto-
matically sets a key exposure when you perform a drawing swap.

When you want to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the 
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution window 
lets you see the drawings before selecting one for swapping. In this view, you are actually selecting drawings in 
your scene layers, not drawings in the Library.

NOTE: Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing 
exposure.
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Swapping Drawings in the Timeline View
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different. If 
you are using the Parameters area of the Timeline view to select a drawing to replace a selected frame range, the 
new drawing will replace the frame range and continue until the next key exposure. In the following example, drawing 
2 (DR2) is replaced by a new drawing, starting at the beginning of the selected frame range and ending at the next 
key exposure.

How to swap a drawing in the Timeline view

 1. In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

 2. In the Drawing Substitution field, position the pointer over the value and drag left or right to change the cell or 
drawing exposed for another one. You can also type in the drawing name or symbol’s cell number if you know 
it.
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Swapping Drawings in the Library View
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different. 
If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is split in two and 
the exposure before and after the frame range remain the same. In the following example, drawing 2 (DR 2) is split 
in two and the selected frame range is filled with a new drawing.

How to swap images in the Library view

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  button is deselected.

 3. In the Camera view, use the Transform  tool to select a part of the drawing to swap.

NOTE: You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one sym-
bol for another.

 4. In the Timeline view, select the cell range in which you want to swap the drawing.

 5. In the Library view, go to the Drawing Substitution window.
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 6. Scroll through the symbol's frames or drawings by doing one of the following:

‣ From the top menu, select Animation > Substitute Drawing Previous or Substitute Drawing Next.

‣ Drag the slider left or right. 

‣ Press +.  

The drawing or symbol’s cell on the current frame is replaced.
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Adding Key Exposures
If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This 
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of 
an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is the 
same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be auto-
matically updated even if set as a key exposure.  This keeps your existing animation key poses intact. It is fre-
quently used on a mouth or eyes layer. 

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure. 

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is 
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key 
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for 
drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline menu, select Exposure > Add Key Exposure.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same 
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing is 
split in two and both parts contain the same drawing. 
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure 
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When 
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l  In the Timeline menu, select Exposure > Remove Key Exposure.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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About Eases
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature and 
set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve in 
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left 
handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can pull on them 
to adjust the ease in and ease out, or type values in the fields. 

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and arm 
of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one frame.
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Setting Eases for Multiple Parameters
You can adjust eases for multiple parameters at once.

How to set ease on multiple parametersHow to adjust the ease of the animation

 1. In the Timeline view, collapse your character model's hierarchy.

 2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the key-
frame on every layer simultaneously.

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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 5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Filters 
section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 
3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note 
that it is applied to the Morphing Velocity function in the Layer Properties window, not to the 
basic Morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other selected functions, such as all functions 
created to animate effect parameters.

 6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are cal-
culated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to 
the length of time you want the easing to last. The value must be between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out. The value must be between 0% and 100%.

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 7. Click one of the following buttons:

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

 l Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.
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NOTE: If a range containing multiple keyframes is selected, only the first selected keyframe will be affected 
by the Seat Ease for Multiple Parameters functionality.
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Using the Onion Skin in Cut-out Animation
When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it 
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see the 
onion skin on a single part or a few parts, such as the arm that is currently being animated.

While animating in the Camera view, there is a series of different onion skin options. You can enable these options in 
the menu or manually in the Timeline view using the layer's Show Onion Skin  button. Only selected layers will 
be displayed in the onion skin preview; you can change the display options when you use the onion skin.

How to use the onion skin

 1. In the Tools toolbar, click the Onion Skin  button or press Alt + O.

 2. In the Tools toolbar, click the Transform  tool or press Shift + T.

 3. In the Camera view, select one or more elements.

 4. Select View > Onion Skin and one of the following commands: 

 l Add to Onion Skin: Adds a series of selected elements to the onion skin preview.

 l Remove From Onion Skin: Removes a series of selected elements from the onion skin 
preview.

 l Remove Unselected from Onion Skin: Removes all elements except the ones selected 
from the onion skin preview.

 l Add All to Onion Skin: Adds all of the scene's elements to the onion skin preview.

 l Remove All from Onion Skin: Removes all of the scene's elements from the onion skin 
preview. 

Add to Onion Skin
The Add to Onion Skin command adds a series of selected elements to the onion skin preview. The keyboard 
shortcut is Shift + S.
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Remove from Onion Skin
The Remove From Onion Skin command removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion Skin
The Remove Unselected from Onion Skin command removes all elements except the ones selected from the 
onion skin preview.

Add All to Onion Skin
The Add All to Onion Skin command adds all scene elements to the onion skin preview. The keyboard shortcut is 
Alt + Shift + O.

Remove All from Onion Skin
The Remove All Onion Skin command removes all scene elements from the onion skin preview. The keyboard 
shortcut is Ctrl + Shift + O (Windows/Linux) or ⌘  + Shift + O (Mac OS X).
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Using the Outline Mode
Use the Outline mode to temporarily convert all the drawings on a layer to outlines. You can still select and 
manipulate the drawings in this mode. Select a drawing by selecting its outline. The fill is not taken into account 
when making selections in this mode.

Toggling drawings to outlines

 1. In the Timeline view, click once on the Change Track Colour button of a layer to toggle all drawings of that 
layer to outlines, in the Camera view.
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Changing the outline colour

 1. In the Timeline view, double-click on the Change Track Colour button of a layer to open the Select Colour 
dialog box.

 2. In the Select Colour window, select a new colour for your outlines.
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 3. Click Ok.

The colour swatch and frames of the selected layer take on the new colour. In the Node view, the layer's 
corresponding node also displays the colour marker.

 4. In the Timeline view, click once on the change track colour of a layer to toggle all drawings of that layer to out-
lines, in the Camera view.

The outlines of the layer's drawings appear in the selected colour.
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Flipping Through Poses
When animating, it is useful to flip through poses to see the flow of your animation without going through each 
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses

 1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

 2. Do one of the following:

 l From the top menu, select Animation > Go to Previous Keyframe or Go to Next Key-
frame  

 l Press semicolon (;) and single quote ('). 
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Flipping Parts
If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip Vertical 
options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select the parts to be flipped.

 4. In the  Tool Properties view, click the Flip Horizontal  or Flip Vertical  option or press 4 or 5 respectively.
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Animating Lip-Sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE: The letters assigned to these mouth shapes are standard identifiers, they NOT correspond to the 
sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated with 
the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, your 
character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and these 
drawings should be named by their corresponding letter. 
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How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice 
track. 
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 5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

 7. Click OK.

 8. In the Playback toolbar, enable the Enable Sound  option.

 9. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view

You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, allowing 
you to identify which phonemes you should match your character's mouth to. You will also be using drawing 
substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing 
name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing 
automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The cur-
rent drawing is swapped for the one in the preview window.
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Ordering  in Z-Depth
The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new 
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows you to 
create a multiplane and move elements closer or farther from the camera. This allows you to move the puppet’s 
pieces in front of or behind other ones without physically changing the layer position. 

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is created 
where different Z values can be entered. This allows the piece to move forward and backwards in space without 
requiring you to change the drawing’s original position or break the layer hierarchy. This also means that the layer 
ordering is maintained throughout the scene. You can combine animation assets so Harmony can interpolate 
them. 

How to nudge elements on the Z-axis

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, click the Animate  button.

 3. In the Camera view, select the part to be repositioned and hold down the Alt key. 

 4. Using the Up Arrow or Down Arrow arrow keys, nudge the part until it moves to the desired position.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle 

 1. In the Xsheet or  Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells From the Timeline.

 3. In the Xsheet or  Timeline view, select the cell where you want your cycles to start.

 4. From the top menu, select one of the following:

 l Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Special dialog box opens.

 l Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X).

The Paste Special dialog box opens.
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 2. In the Number of Cycles field, enter the number of cycles to paste.

 3. In the Cycle Type menu, select a type of cycle to paste.

 l Normal (forward): Pastes the selection as is, starting with the first cell and ending with the last.

 l Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

 l Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the last cell and 
ending with the first cell.

 l Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, going to the first 
one and ending with the last cell.

 5. Click OK.

How to create a reverse animation cycle

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.
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 2. From the top menu, select Edit > Copy.

 3. In the Xsheet or  Timeline view, select the cell where you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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About Timeline Marking
As you animate, the Timeline view will accumulate many layers and keyframes. You might want to identify them 
using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use 
it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an 
impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is displayed when 
you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and 
mark the whole section.

To see how to mark the Timeline, see Marking the Current Frame, Marking Frame Ranges, Marking Layers with 
Colour
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Marking the Current Frame
Sometimes you need a single frame or specific frames to stand out. You can do this by changing the colour just 
above the frame, in the frame counter area.

How to mark the current frame

 1. In the Timeline view, make sure the red playhead is set on the frame you want to mark. Even if you right-
click on a different frame, the scene marker will be created on the current frame on which the playhead is 
positioned.

 2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the 
colour of the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. 
Click OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when you 
hover your mouse over the scene marker.
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In the Timeline view, the scene marker is displayed at the current frame. 

 5. Hover over the scene marker to display its tooltip.
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Marking Frame Ranges
Sometimes you need a range of frames to stand out. You can do this by changing the colour just above the range, 
in the frame counter area.

How to create a scene marker on a frame range

 1. In the frame counter area, select the frame range you want to mark.

 2. Right-click and select Create Scene Marker.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or the 
colour of the last scene marker you created.

 3. Click the Colour swatch to open the Marker Colour dialog box and select a colour for the scene marker. 
Click OK.

 4. In the Note field, enter descriptive or title text and click OK. This text will appear in the tooltip when you 
hover your mouse over the scene marker.

In the Timeline view, the scene marker is displayed over the selected frame counters. 

 5. Hover over the scene marker to display its tooltip.
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Marking Layers with Colour
As you animate, you may want to differentiate between different types of layers, such as pegs and drawing layers, 
or simply highlight a layer you are currently working on. You can organize layers or make them stand out by changing 
the layer colour.

How to mark a layer with colour

 1. Click the Change Track Colour  button of a layer.

The Select Colour dialog box opens.

 2. Select a colour for the layer. You can modify the colour for any type of layer, such as group, peg, drawing and 
effects.
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About Inverse Kinematics
The Inverse Kinematics (IK) tool  allows you to pull on a character's extremities, such as the hands and feet, and 
have the rest of the body follow. It can be used on any piece connected in a hierarchy. However, you don't have to 
use IK every time you have a hierarchy rig. This tool is useful when you want to bend a character's knees, make it 
sit and move the rest of the body, and so on. It will also assist you with posing difficult moves. 

In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony uses the 
rigging hierarchy already created in the Timeline view, so there is no need to place bones in the character. Inverse 
Kinematics in Harmony uses the connection between each of the parts' pivots.

Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain present. IK 
only works on a hierarchy where the pivots are properly set.

Harmony provides different tools for animating cut-out characters and trajectories. The two main tools used to 
animate characters are the Transform and Inverse Kinematics tools.

Here, we'll compare the usage of these tools and explain the Inverse Kinematics philosophy.

 l Transform Tool

Also known as forward kinematics, the Transform tool is the main tool to use for cut-out animation. This 
tool rotates, scales, moves and skews selected elements as one global element.

Forward kinematics means that the limb is animated from the parent down to the last child as a single 
piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as a complete arm 
drawing.

 l Inverse Kinematics Tool (IK)

This tool helps you achieve complex motions, such as sitting down or knee bending. The Inverse 
Kinematics tool moves and rotates every selected element as a chain.

Inverse kinematics means that the element is animated from the child up to the parent. In other words, if 
the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly natural way in terms of 
the movement, rotation and bending.

The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and parts are 
attached to one another. In other words, it depends on the rigging type.
There are several ways to rig a puppet. These are the three main rigging techniques:
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 l The Basic Rig Technique

 l This is the simplest rig technique.

 l There are no connections between the parts. 

 l They are free to move, rotate and scale independently from each other. 

 l The Inverse Kinematics tool CANNOT be used on this type of rigging. 

 l The Hierarchy Rig Technique

 l This is a complex rig technique.

 l All the parts are connected to each other. 

 l As they move, rotate and scale, they will influence all the other parts. 

 l The Inverse Kinematics tool can be used on this type of rigging. 

 l The Mixed Rig Technique

 l This is the best of the basic and hierarchy rig.

 l Some parts are independent such as the torso. 

 l Some parts are set up in a hierarchy such as the arms and legs.

 l Independent parts are rigged in hierarchy using parent pegs.

 l The Inverse Kinematics tool can be used on this type of rigging. 

Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (forward kinematics) as it has all the main motions: rotate, scale, skew, move 
and select. You can also control the exact position of the parts while using the Transform tool. As well, the 
Transform tool creates a temporary global pivot on the selection that can be moved around for the animation 
purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you can use the 
Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible to lock the feet or any 
other part to a particular spot and move the rest of the body, which will react to the constraints.
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You will not be using it to 
animate all the time.
Also, the Inverse Kinematics tool can be used to create the character's posing faster. Posing is a crucial part in the 
animation process. The Inverse Kinematics tool can be used to pose the character more naturally, depending on 
your own preferences.
An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain, such as an 
arm or a portion of the arm.

Here are some tips and tricks to help you to use the Inverse Kinematics tool.

 l Inverse Kinematics on Mixed Rigs
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The Inverse Kinematics tool can be used on a full puppet's body even if it's connected as a mixed rig, 
meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails on the 
puppet's feet, select the full body master peg and move the character as if it was connected in a full 
hierarchy rig. This technique works on most mix rigs.

 l Inverse Kinematics Constraints  

It's important to remember that you can add and remove IK constraints (nails, hold orientation, etc.) at any 
time during the animation. They hold a certain part on the spot while you animate the rest of the body. 
Because they're not constricting one part to another object, you can add or remove them without affecting 
any of the animation you have already completed.

 l Useful Shortcuts

 l While using the Inverse Kinematics tool, you can Ctrl + click (Windows/Linux) or ⌘  + click 
(Mac OS X) to select any part. 

 l Hold Alt to rotate the selected part without affecting the IK chain. 

 l Press Shift and click in a part's pivot to add or remove an IK Nail. 

 l Press Shift and click on a bone to add or remove and Hold Orientation constraint.
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About IK Hierarchy Chains
Before going any further, a word about IK chains. There are three types of chains:

 l Single Chains

The single chains are the most basic of chains. A single chain is a straight line with no secondary 
chain attached. It goes up to the first intersection.

 l Direct Chains

A direct chain is a single chain which goes directly to the core (root).

 l All Chains

All chains are attached and move together when one part is moved.
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About IK Setup
The first time you display the character's skeleton, notice a series of bones on the extremities which are out of 
place. There may also be some elements that you would like to exclude from the IK chain.

It is highly recommended to set up the skeleton before starting your animation.

Before fixing any bones, or excluding layers from the IK skeleton, make sure all the elements you want to be 
parented in a chain are set up.

You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms. If the body is 
not completely rigged in hierarchy, the skeleton will look a bit more messy, but the IK tool will still work properly.

When working with the IK tool, you will probably want to move the main parts around, but not necessarily the small 
ones such as the nose or ears. To do this, you can select some elements on your character and exclude them from 
the skeleton.

Once you remove the extra elements from the skeleton, set the bone orientation for the extremity parts. By default, 
they are oriented horizontally towards the right. This orientation often works for the feet but not necessarily for the 
hair or hands.

Harmony allows you to set a minimum and maximum angle constraint on certain joints, such as the knees or 
elbows. When using the Inverse Kinematics tool or even the Forward Kinematics (Transform tool), it is possible that 
some joints will bend in the wrong direction.
If you plan to animate a lot with the Inverse Kinematics tool, it's a good idea to try the angle constraints. The angle 
constraints can be set by the character builder or by the animator in particular scenes where it's needed.
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NOTE: 
It is recommended to use the minimum and maximum angles only if the character does not change view 
within the same layers. For example, if a character is facing the camera and has some angle limitations 
enabled, it could be problematic if the character switches to side or quarter view since the joints won't bend 
the same way.

Use the minimum and maximum angle constraints if your character's views are in different templates or 
layers. If the character's views are in the same layers, then it's better not to use the angle constraints.
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Excluding Elements from IK Skeletons
You can easily remove elements from your IK skeleton to simply it.

How to exclude elements from the skeleton

 1. In the Tools toolbar, select the Inverse Kinematics   tool or press Shift + I.

 2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the part to exclude from the 
skeleton.

 4. In the Tool Properties view, click the Exclude from IK  button.

 5. Repeat the process for every part to be excluded from the skeleton.
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Orienting Bones
Extremity bones can be rotated to match the drawing's orientation.

How to set the bone orientation

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, enable the Bone Editing  mode.

 3. In the Camera view, click on the pivot belonging to the part whose bone you want to reposition, then pull 
the pivot in the desired direction.

 4. Repeat this process for each bone you want to position.

NOTE: This command only works on the extremities.
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Setting Minimum and Maximum Angles
You can set minimum and maximum angles your character's limbs to avoid overbending them.

How to set the minimum and maximum angles

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode  is enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the piece to set the minimum 
and maximum angle.

 4. In the Tool Properties view, in the Selection section, click the Enable Min/Max Angle  option.

 5. In the Camera view, rotate the Minimum and Maximum handles to set the angle.

 6. Test the angles using the IK Manipulation  mode.

 7. For additional control over the Min/Max Angle, go to Edit > Preferences (Windows/Linux) or Harmony 
Premium > Preferences (Mac OS X). Select the Camera tab. In the Inverse Kinematics section, look at the 
Min/Max Angle Constraint Weight. Although the maximum value goes up to 1.0, in a production setting, the 
most practical value would be closer to 0.1. This value acts similar to the Stiffness setting in the Tool Prop-
erties view. The higher the value, the more difficult it becomes to approach the minimum and maximum val-
ues.
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About Nails
Often, you will want to animate only part of a character, such as the arm and not the entire body. You can do this 
using IK nails, which are IK constraints that temporarily cut or constrain the chain. With IK nails, you can cut an 
IK chain or block a part on the spot. For example, you can fix a character's feet to the ground when it walks.

There are different types of constraints you can place on the chain:

 l IK Nail: Blocks the X, Y and Z positions.

 l Hold Orientation: Blocks the angle.

 l Hold X: Blocks only the X position.

 l Hold Y: Blocks only the Y position.

 l Enable Maximum and Minimum Angles: Sets limitations on the angle parameter to prevent the pup-
pet from bending too far.
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Setting Nails
You can place nails on your skeleton to temporarily hold it in place.

How to set an IK nail

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Tool Properties view, make sure the IK Manipulation Mode  is enabled.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the part to set a nail on.

 4. In the Tool Properties view, select a type of nail:

 l Hold the Shift key and click on any part's pivot to set a regular nail on it without having to select 
it.

 l Hold the Shift key and click on the bone to set a Hold Orientation nail.

 l Select the nail type in the top menu by selecting Animation > IK Constraints > desired nail.

 l Remove the nail at any time using the same technique you did for placing the nail. It will not 
affect the animation.

 5. To remove all nails except the Enable Min/Max Angle ones, from the top menu, select Animation > IK Con-
straints > Remove All Constraints.
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Animating with Inverse Kinematics
Inverse Kinematics works best when you lock a part of the character on the spot, such as a foot on the floor, then 
select the entire body or another extremity and move it. It also works well in single chain mode when you need to 
simply position a limb.

To learn more about the IK tool's properties, see the Reference guide .

NOTE: To lock a part in place, use the IK Nail option—see About Nails on page 886.

How to animate with the Inverse Kinematics tool

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on a part of the body.

The entire IK skeleton appears.

 3. Click on a part of the body and pull on it to move the character.

 4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You can Shift 
+ click on a bone to lock the orientation of the bone.
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 5. Click on another part of the character and pull on it. 
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About IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on the key 
poses. However, when you use motion keyframes to auto in-between the animation, you'll notice a movement of 
the feet. This motion is caused by the in-betweening of the rotations.

The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration between 
keyframes.

If you place a nail on the shoulder to move just the arm, you don't necessarily want to keep the shoulder in the 
same place until the next key pose. You will probably want the shoulder, or any other part that is nailed, to have a 
slight, natural motion following the main body action. Of course, this is not the case when you fix a hand or a foot 
on the spot. If you have a fixed hand or foot, you will probably want it to stay exactly where you placed it. That is 
why you can apply an IK constraint on a frame range and on selected body parts.

To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving too much. For 
example, to fix a foot that is moving too much, you must correct the angles on the foot, leg and thigh. To fix a 
hand, you must correct the angles on the hand, forearm and upper arm.
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Setting IK Keyframe Constraints
When setting up a hierarchy chain, the parent is usually the part that is at a logical point of rotation. For example, in 
the case of a leg, the parent would be the thigh, as it rotates from the hip and its children would be the shin and foot 
that will always follow.

However, sometimes you come across a situation where you need the movement to stem from the child, such as in 
the case of a ballerina, where the shin and thigh rotation follow the position of the foot. In order to keep the foot from 
gliding around, making the kinds of secondary movements that children do, you need to nail the foot in place and 
constrain its orientation (rotation). Sometimes this constraint needs to be held for several frames.

How to apply IK constraints on a frame range

 1. In the Tools toolbar, select the Inverse Kinematics  tool or press Shift + I.

 2. In the Camera view, click on the part on which you want to apply the constraint.

 3. In the Timeline view, select the first frame on which you want to start applying the constraint.

 4. In the Tool Properties view, enable the Apply IK Constraints  mode.

 5. In the Tool Properties view, click the IK Keyframe  button to enter the first frame number.

 6. In the Timeline view, move the playhead to the last frame on which you want to apply the constraint.

The IK Keyframe field should now look like this:

 7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on the thigh by 
holding down the Shift key and clicking its pivot.
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 8. In the Tool Properties view, select the type of constraint to apply to the piece. The most common one is a 
combination of the regular Nail  and Hold Orientation  options.

 9. In the Camera view, click on the bone of the part you want to apply a constraint to.

A warning message appears asking you to confirm that you want to add a constraint on that particular 
piece and for that frame duration.

 10. Click OK.

The constraint is applied.
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Chapter 13: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing feature 
can help speed up the process. This powerful feature automatically creates computer-generated drawings between 
your vector drawings to save time and increase productivity. You can easily modify the timing and velocity (ease in 
and ease out) of a morphing animation. 

One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can be 
time-consuming because these types of effects are usually slow moving requiring a large number of closely placed 
inbetweens.

The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving 
time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with more time to 
spend on complex animation tasks such as walk cycles or acrobatic sequences.

To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you are 
more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be 
producing some remarkable effects. 

It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and which 
drawing lines may be more useful or problematic will enable you to design your key drawings so they morph 
efficiently. 

NOTE: The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing 
than to hand-draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when 
you can morph your drawings, do it! It allows you to fix your timing and velocity in no time without having to cre-
ate any extra drawings!
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About Source and Destination Drawings
The morphing feature matches similar shapes in a source and a destination drawing. Harmony evaluates the 
source's shape properties and matches them to the most similar ones in the destination drawing.

Morphing works between similar shapes, which are drawings that have the same palette, colours and number of 
shapes. You can even change any shape into another one, as long as the source and destination keep the same 
colours, number of lines and number of shapes.
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About Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic morphing rules 
before you start morphing.

NOTE: Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap layers 
or Toon Boom bitmap drawings.

Here are a few tips about creating morphing sequences:

 l When learning about morphing, it is recommended that you use the Brush tool. You can use the Pencil line for 
simple closed shapes.

 l If you are using pencil lines, use Contour hints instead of Pencil hints. Use Pencil hint if you want the Pencil 
line to switch direction. 

 l Flatten your drawing before starting a morphing sequence.

 l If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If the 
source line is closer to the dot than the destination line, the source line will morph into the dot and the des-
tination line will disappear.

 l Use the same colour swatch between two drawings. You cannot morph between two different colour 
swatches even if they have the same RGB values. This can be turned to your advantage for complex morph-
ing.

 l Similar shapes should have the same number of colour zones. This only applies to the number of zones and 
lines and not the number of points on a curve.

 l If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the morphing 
will fail.

 l For example, if you are morphing a face so it turns from the front to the side, the nose is located in the middle 
of the face on the source drawing. However if after morphing, the nose ends up outside or merged with the 
face profile line on the destination drawing, this will give undesirable results. You can avoid this by using 
morphing layers and splitting the nose on a separate layer.
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About the Closest Similar Shape Rule
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This means it will 
morph with the zone nearest to it, as long as that zone uses the same palette's colour swatch (colour ID) and has 
the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same colour swatch. It 
will morph with the red diamond shape (1) in the next drawing. The red diamond shape (2) in the source drawing 
will morph with the red heart shape (2) located in the same area in the destination drawing. The black spade shape 
(3) in the source drawing will morph with the black club shape (3) located in the same area in the destination 
drawing. Finally, the black club shape (4) in the source drawing will morph into the black spade shape (4) located 
above in the destination drawing.
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About the Pencil Line to Pencil Line Rule
If you trace a shape using a pencil line such as the Ellipse , Rectangle , Polyline , Line  or Pencil  
tool, you have to morph it with another pencil line. Make sure that both drawings are pencil shapes (central vector).

A pencil line will never morph with a brush stroke.

Pencil lines with thickness are supported in morphing sequences. The thickness will morph according to the thickest 
and thinnest areas in the source and destination drawings.
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Pencil lines with textures are not supported in a morphing sequence. During the morphing, the texture will 
disappear and show without pencil line opacity texture.

If you have pencil lines in your source drawing, the same number of pencil lines must be present in the destination 
drawings. A pencil line will appear if it is not found in the destination drawing. It will pop out on the first or last 
frame depending on which one it is drawn.

When two pencil lines cross one another, they are considered to be two lines and not four lines anymore (as it 
was in version 7.8 and below of the application). In this case, you must have two pencil lines in your destination 
drawing for your morphing to work correctly.
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About the Fill Shape to Fill Shape Rule
If you have a brush stroke or a colour fill ( contour vectors), make sure that you morph it with another  brush stroke or 
fill zone. It is important to undersand that strokes drawn with the Brush tool are the same thing as zones painted with 
the Paint tool. Vector points are located along the contour. They are simply not the same size. Contour vectors will 
not morph with pencil lines (central vectors). A brush stroke can morph into a colour fill zone and vice versa as they 
are the exact same thing.
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About the Same Colour Swatch Rule
Harmony does not morph between colours. If you want to perform a colour transition, you have to create the 
effect during the compositing step of your production. A colour palette is composed of colour swatches. Each 
colour swatch has its own unique identification number, even if two swatches are the same colour value, they are 
identified independently. A colour zone or shape will morph with another one painted with the same colour 
swatch.
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About the Vanishing and Appearing Rule
If a colour zone does not find a match in the first or the second drawing, it will progressively appear or disappear.
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About the Colour Art and Line Art Rule
In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art. Basically, an 
extra layer is added in your drawings so that you can fill the colour zones on a separate layer. The regular layer on 
which you are drawing is called Line Art and the extra layer under the Line Art is the Colour Art.

 l A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art. 

 l A shape drawn in Line Art can only be morphed with another shape existing in the Line Art. 

 l A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating Morphing
When it comes to morphing, you will need to practice and become at ease with it. Once you are familiar with the 
basic rules, you can start creating morphing sequences. To begin, start with simple elements. When you are 
confident with the morphing process, you can start to use complex and advanced morphing techniques, such as 
head rotations or full characters.

NOTE: As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using 
this view allows you to do things such as toggle between your key drawings, adjust the easing or select a hint 
type. 

How to create a basic morph

 1. In the Timeline toolbar, click the Add Drawing Layer  button to add a new layer to your project.

 2. Rename the new layer ( for example, Morphing).

 3. In the Timeline or Xsheet view, select the first cell in the layer.

 4. Do one of the following:

 l In the Tools toolbar, select the Rectangle  tool.

 l Press  Alt + 7.

 5. In the Camera or Drawing view, draw a rectangle.

NOTE: When drawing a rectangle or an ellipsis, you can hold down the Shift key to draw your 
shape with equal dimensions, so as to make a square or a circle instead. You can also hold down 
the Alt key to draw the shape from its center rather than from its corner.
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 6. Paint your rectangle using the Paint tool.

 7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

 8. Do one of the following:

 l In the Tools toolbar, select the Ellipse  tool.

 l Press  Alt + =.

 9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.

 10. In the Xsheet or Timeline view, select the range of frame going from your first drawing to your second draw-
ing, including the frames containing the drawings.

 11. Do one of the following:

 l From the top menu,  select Animation > Morphing > Create Morphing.

 l In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing 

904



Harmony 14 Premium - User Guide

 l Press Alt + M.

Arrows appear between the two key drawings to show that computer generated inbetweens have been 
created.
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Deleting Morphing
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.

How to delete a morphing sequence

 1. In the Xsheet or Timeline view, select a cell in the morphing sequence. 

 2. Do one of the following:

 l From the top menu, select Animation > Morphing > Delete Morphing.

 l From the Xsheet or Timeline view menu, select Morphing > Delete Morphing.

 l Right-click on your sequence and select Morphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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About Morphing Velocity and Timing
Once you have set up a morphing sequence, you can control its velocity and timing. 

When you look at your animation you will notice that the morphing motion is constant. To produce a less mechanical 
motion, you will probably want to create some ease in or ease out.

If you have several morphing sequences on a single layer, you may find it easier to adjust their velocities on one 
function curve rather than several separate ones. Having all of your velocity parameters in one place is more 
efficient and easier to modify.

Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the morphing sequence. 
The sequence will always start with the source drawing and end at the destination. You can play the morphing 
sequence backwards or forwards during the animation.
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Adjusting the Morphing Velocity
You can have two levels of easing:

 l In the Tool Properties View, you can adjust the velocity of each sequence in your layer independently

 l In the Layer Properties editor, you can adjust the morphing velocity function to control the entire layer's 
easing

How to adjust the velocity in the Tool Properties view

 1. In the Tools toolbar, select the Morphing  tool or press F3.

 2. In the Timeline view, click on a frame in the morphing sequence you want to adjust.

 3. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the 
sequence's velocity.

How to adjust the velocity in the Layer Properties editor

 1. In the Timeline view, double-click on the drawing layer to open the Layer Properties editor.

 2. In the Layer Properties editor, go to the Advanced tab and click on the Function  button to create a func-
tion curve.

 3. In the Layer Properties editor, click the Function  button again to open the velocity curve.

 4. Add a keyframe at the first frame of the morphing (source) and one at the end (destination) by clicking on 
the Add/Remove Keyframe  button. 
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 5. Move the destination keyframe upward.

NOTE: It is important that the last keyframe remains above the first one.

 6. Make sure that the first keyframe is not a stop-motion keyframe. To do this, disable the Stop-motion Key-
frame button. To use the Toggle Stop-Motion Segment feature, press S. 

 7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the curve go 
downward instead of upward, the animation will play backward until the curve starts to go upward again.
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NOTE: If you have more than one morphing sequence in the same layer, you need to add a keyframe on the 
velocity curve for each source and destination drawing.

 8. If you want your morphing to play back on a double frame exposure rather than single frame, you can use 
the Hold Value editor and set the velocity to change every second frame, instead of every frame.

 9. In the Morphing Function editor, click on the Hold Value Editor  button and set the parameters to hold 
the value for two frames.
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Adjusting the Morphing Timing
If you did not place your source and destination drawings on the correct frames you may need to extend or shrink the 
sequence length.

How to extend or shrink a morphing sequence length

 1. In the Timeline view, select the source or destination drawing.

 2. Click on your selection and drag the drawing to its new frame.
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About Morphing  Hints
Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to 
place hints to ensure Harmony morphs your drawings the way you intended.

Hints are points that are placed in both the source and destination drawings to associate zones and lines between 
the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line that is not 
following the colour fill zone, or when a part of your source drawing doesn't morph into its corresponding part of 
the destination drawing. By default, Harmony will associate a corner or a point in the source drawing with the 
nearest corner or point in the destination drawing. Hence, hints quickly become necessary if the shape being 
morphed or its movement is complex. 

Hints always exist on both the source and destination drawing. When you create a hint on either drawing in a 
morph, a corresponding hint will automatically appear on the other drawing. The same principle applies if you 
delete a hint. 

The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions first, this may 
also fix the smaller ones at the same time.

Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn how to 
correctly use and place hints.
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If you are morphing two sequences in a row, you will have to create a different set of hint points for each sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you create two 
morphing sequences; one sequence between drawings 1 and 2, and a second sequence between drawings 2 and 3.

NOTE: Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will have 
a set of hints for the first sequence and another set for the second sequence. The two sets of hints will not show 
at the same time. Each set of hints that appears always corresponds to the morphing sequence you are working 
on.
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About Hint Types
To correct morphing distortions, Harmony has different types of hints available for controlling different types of 
problems.

Each type of hint has a different purpose and they can all be used in the same drawing. Use the Morphing tool to 
add hints to your morphing sequences.

Hint points in the source drawing are green and red in the destination drawing.
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About Contour Hints
The Contour Hint  point is used on the colour fill zone and brush lines; in other words, on Contour vectors. It allows 
you to control the line thickness and contour position. Also, if a contour is not animated correctly, you can use hints 
to correct the animation. For example, if a flag is not waving properly.

When adding a Contour Hint point, make sure to place it far enough away from the contour so you can see it snap to 
the contour. 

Contour Hint points are yellow.

NOTE: Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, when 
in fact, it has not and the morphing will remain unchanged.

NOTE: To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations over 
time.
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About Zone Hints
The Zone Hint  point is used on a colour zone to control the proximity rule. The Zone Hint is placed in the centre of 
the colour zone. Sometimes a colour zone is not associated with the corresponding one by default. For example, 
in a splash animation there are many water droplets that are the same colour. Harmony automatically morphs the 
droplet to the nearest one. This is not always the one you may have predicted. A Zone Hint will force a colour 
zone to morph with another one.

Zone Hint points are cyan in colour.
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About Pencil Hints
A Pencil Hint  point is used to control a pencil line, also known as central vector. It can be used on drawings that 
were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the Contour Hint, the Pencil Hint snaps 
to the central vector. Make sure to place it far enough away from the line so you will see it snap when you move it.

Pencil Hint points are magenta in colour.
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About Vanishing Point Hints

A Vanishing Point Hint  is used to control the trajectory of a vanishing shape. A shape will vanish from the source 
drawing when there is no corresponding shape in the destination drawing. If you do not place a Vanishing Point 
Hint to control the point of disappearance, the shape will vanish into its centre.

Vanishing Point Hint points are green in colour.
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About Appearing Point Hints
An Appearing Point Hint   is used to control the trajectory of an appearing shape. A shape will appear in the 
destination drawing when there is no corresponding shape in the source drawing. If you do not place an Appearing 
Point Hint to control the point of appearance, the shape will appear from its centre and expand outwards.

Appearing Point Hint points are violet in colour.
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Adding and Deleting Morphing Hints
Using the Morphing tool you can use hints to correct the morphing sequence.

How to add and hints

 1. In the Timeline or Xsheet view, select the source drawing of your morphing sequence.

 2. In the Tools toolbar, select the Morphing  tool or press F3.

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a reference.

 3. In the Tool Properties view, select the type of hint you want to use.

 l Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note 
that you obtain better results using the Pencil Hint point on pencil line rather than Contour 
Hint points.

 l Select Pencil Hint to correct a pencil line (Central vector).

 l Select Zone Hint to correct a colour zone morphing match.

 l Select Vanishing Point Hint to correct a vanishing shape's trajectory. 

 l Select Appearing Point Hint to correct an appearing shape's trajectory. 

 4. In the Camera or Drawing view, click on the drawing near the problematic area.
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 5. Select the hint's point and move it to its correct position.

 6. In the Timeline or Xsheet view, select your destination drawing.

 7. Find and move the corresponding hint's point to the matching part of your destination drawing. 

 8. In the Playback toolbar, press the Play  button to see the result.

How to delete hints

 1. Select one or many hints.

 2. Press Delete.
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NOTE: To delete all of the hint points at once, press Shift + Delete.
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Copying Hint Points
If you have two morphing sequences that use the same drawing and you would like to copy it and its hint points, you 
can do so in the Drawing view.

How to copy a drawing and its hints

 1. Do one of the following:

 l In the Tools toolbar, click the Select  tool.

 l Press  Alt + S.

 2. In the Drawing view, select the drawing to reuse in your second morphing sequence. 

 3. Do one of the following:

 l In the top menu, select Edit > Copy.

 l Press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 4. In the Timeline view, select the cell where the new drawing will be.
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 5. In the Drawing view, paste your selection. 

 6. Do one of the following:

 l In the top menu, select Edit > Paste .

 l Press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

 7. In the Timeline view, select the cell where the second drawing will be.

 8. In the Drawing or Camera view, draw your second drawing.

 9. Do one of the following:

 l In the Timeline view, create the morphing sequence for the new drawings.

 l Press Alt + M.

 10. Do one of the following:
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 l In the Tools toolbar, select the Morphing  tool.

 l Press F3.

 11. In the Drawing or Camera view, position your hint points.
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About Morphing Layers
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control and may not 
work properly, by dividing the drawings into morphing layers, the task becomes much easier.

The major points used in controlling a morphing sequence are the intersections. If there are many lines 
intersecting within a drawing, the system will require more control—see About Hint Types on page 914

An important aspect of morphing is to identify possible problem zones in order to fix them and avoid potentially 
frustrating situations.

Simple details that look easy to morph can sometimes be more challenging than they may initially appear to be. 
For example, you may find that the nose becomes an issue when performing a head rotation. As explained earlier, 
the drawings need to be similar in their number of shapes. Generally, on a head rotation, the source nose is in the 
centre of the face, but on the destination, the nose line is part of the face outline. This means that on the source 
drawing, the nose and the face outline are two separate shapes, whereas they are combined into one shape on 
the destination drawing.

Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish as the 
destination nose grows from the character's cheek.

Any shape that is contained inside another one and has to morph out of that shape will be problematic for the 
same reasons as the nose is. At some point during the morphing sequence, the shape contained inside the face 
will merge with the face outline, and then become a separate shape again.
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Morphing layers are all contained in the same drawing layer. It is like having a mini Timeline within a Timeline layer, 
or a mini Xsheet within an Xsheet column.

Each morphing layer can have its own duration and velocity. Also, because you only have a single element to handle 
in your Timeline or Xsheet view, it will be treated as one element for the Compositing process, making the 
compositor's work easier.

You can separate all of your elements into different drawing elements and have many layers, but you would have to 
create a large number of morphing sequences and make sure that you modify all of their timings properly. 

Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene structure 
by adding more elements, which can be very important for Cut-out animation puppets. For example, if you morph a 
front head to a three-quarter head where the ear needs to be separate, you do not want to add a new ear layer at the 
same time and have to worry about connecting it inside the puppet's construction. Instead, simply create an ear 
morphing layer within the head layer. 
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NOTE: Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can 
also use the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one and so 
one. This technique is useful if you plan to do more than one morphing sequence in the same column. For 
example, front head to three-quarter head to side head. The three-quarter drawings will be used in both morph-
ing sequences. 
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Creating Morphing with Morphing Layers
You can create morphing sequences on separated layers using morphing layers.

How to create a morph with morphing layers

 1. In the Timeline view, add a new drawing element and name it properly.

 2. In the first cell, draw the main source shape such as the head shape or body shape. Do not add details like 
eyes.

 3. In the Timeline view, select the destination cell.

 4. Enable and extend the Onion Skin.

 5. In the destination cell, draw the second drawing.

 6. In the Timeline view, select the in-between cells.

 7. Do one of the following:
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 l Right-click and select Morphing > Create Morphing.

 l Press Alt + M. 

 8. In the Tools toolbar, select the Morphing  tool.

 9. In the Morphing Tools Properties view, click on the Add Layer  button to add a new morphing layer. 
When you click on a morphing layer drawing, it automatically appears on top of the others. If you want it to 
stay in place, for example the wing behind the body, enable the Show Morphing in Place  option in the 
Morphing Tool Properties view. 

 10. Double-click on the new layer's name and name it appropriately.

 11. Press Enter/Return.

 12. Use the Up  and Down  arrow buttons to move the new layer above or below the Main layer. 

 l If placed above the Main layer, it will be displayed in front. If it is placed below, it will be dis-
played behind.
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 13. To create new drawings, double-click on the blank area under the From section to create the source drawing 
and the To section for the destination drawing and type a different value than the ones used for the main 
layer.

 14. Press Enter/Return.

You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

 15. Click on the new source drawing to start drawing the new part. (Make sure that you are working on the proper 
drawing by verifying the name in the Camera or Drawing view's bottom left corner.) 

 16. In the Camera or Drawing view, draw the source drawing.

 17. Once the source drawing is done, use the Morphing Tool Properties view and click on the destination draw-
ing's name and draw it in the Camera or Drawing view.
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 18. Repeat steps 9 to 15 for each layer needed. You can add as many layers as you want.

 19. Enable or disable the layers that you want to display or hide while drawing.

 20. If you want to change the layer duration, click on the layer and change the start and stop numbers.

The length indicator changes according to the new values.
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About Morphing Key Drawings
Once you have a morphing sequence, you can add a morphing key drawing.

A morphing key  drawing allows you to insert extra details into a morphing sequence. For example, during a morphing 
sequence you may need to insert a detail such as teeth or a mouth; this is easy to do when you use a morphing key  
drawing. Instead of creating an entirely new drawing, convert a computer generated in-between to a morphing key  
drawing and add your extra details to it and the next key drawing.
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Inserting Morphing Key Drawings
A morphing key  drawing converts a computer-generated morphing frame into a real drawing that you can edit. It 
splits the morphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing

 1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing key-
frame.

 2. Do one of the following:

 l In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

 l Right-click and select Morphing > Insert Morphing Key Drawing.

The new morphing key  drawing appears.

 3. In the Drawing or Camera view, draw your new details on the morphing key  drawing.

 4. In the Playback toolbar, press the Play  button to see the result.
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About Transparency Morphs
To be able to morph shapes with holes or transparent colours, it is important to understand the process of analyzing 
and morphing a shape. Harmony begins the process by reading the exterior outline of the entire shape. So if you are 
morphing a doughnut, it will first read the entire circular shape and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details such as colour 
zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is filled with an 
opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a transparent colour so that you 
can control it and flatten the transparency to cut a hole through the main shape.

The same thing happens when you have holes painted with semi-transparent colours. To see through your shapes, 
you have to follow the same process as morphing shapes with holes.
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Morphing Transparencies
You can use invisible colours to morph holes and transparencies.

How to morph a shape with a hole

 1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

 2. Paint both holes on the source and destination drawings.

 3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

 4. Do one of the following:

 l In the Tools toolbar, select the Morphing  tool.

 l Press F3.

 5. In the Tool Properties view, enable the Flatten  button.

A hole appears in the shape.
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About Morphing Quality
Increasing the morphing quality settings improves the line shape between vector points. It also creates a larger 
file, so only increase quality when you are zooming in closely. You can adjust the quality in the Tool Properties 
view and in the Preferences panel.

When morphing in Toon Boom Harmony, there is a preference you can set to help you set the default quality of 
morphing sequences. Refer to  the Preferences Guide for complete descriptions.
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Setting the Morphing Quality Level
Increase the morphing quality to smooth out morphed lines. 

How to set a morphing sequence's quality level

 1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

 2. Do one of the following:

 l In the Tools toolbar, select the Morphing  tool.

 l Press  F3.

 3. In the Tool Properties view, adjust the Quality level.
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Converting Morphing Inbetweens to Drawings
Harmony lets Lets you convert your morphing inbetweens to real drawings you can edit. This is useful when 
manually editing a morphing sequence or if you prefer to have animation timing in double frame (on twos) instead 
of single frame (on ones). 

How to convert morphing inbetweens to drawings

 1. In the Timeline or Xsheet view, select a morphed drawing  in the morphing sequence you want to convert to 
real drawings.

 2. Do one of the following:

 l In the top menu,  select Animation > Morphing > Convert Morphing to Drawings.

 l Right-click and select Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

 3. Type the drawing basename you want to give to your new drawings. In this case, you could type circle.

 4. Click  OK.
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Chapter 14: Import
Toon Boom Harmony allows you to import external content as well as being able to draw directly in the software. 
This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs 
can be brought in and animated. You can import QuickTime videos, pictures, multilayered .psd files, as well as .ai, 
.swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize them.

NOTE: For sound import, refer to Importing Sound on page 1288.
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About Bitmap Images
T-HFND-007-001

Images can come in many different file formats and are usually saved in a format that retains the original 
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, while 
others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the following bitmap 
image formats: JPEG, BMP, PNG (16 bits per channel RGB and RGBA), TGA, PSD (16 bits per channel), TIFF, 
SGI, TVG, OMF, PAL, SCAN.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Keep as Original Bitmap: This imports the image exactly as is and ensures that it can not be modified 
when working on the scene. This is useful for using backgrounds that were created in different software in 
your project.

 l Import as Toon Boom Bitmap Drawing: This imports the image as is, but allows you to edit it using Har-
mony's bitmap drawing tools.

 l Import as Toon Boom Vector Drawing: Converts a bitmap  into Toon Boom vector art, which can easily 
be painted and edited using Harmony's vector drawing tools. This can be useful for importing line art 
scanned or created using a different software.

When importing images or 3D models, or when linking images, the settings used to import are saved in your user 
settings.
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Importing Bitmap Images As Original Bitmap
T-HFND-007-002

Importing a bitmap image in its original format ensures it is preserved exactly as is in Harmony. When importing a 
bitmap image, you have several options available such as where you want to import the file and how to name it. 

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more images on 
your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following 
options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create two lay-
ers, one named "a" and one named "b". Layer "a" will contain the two first images and "b" will 
contain the third one.
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 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're import-
ing images as vector drawings, you can only import them into vector drawing layers. 

 4. In the Import Options section, select the Keep As Original Bitmap option.

 5. In the Alignment section, decide on the size and placement of your image within the camera frame. You 
can choose between the following options:

Parameter Description

Fit

Adjusts the image's size to fit completely within the scene's 
field, both vertically and horizontally, making sure the entire 
image is visible. 

If the image's orientation is portrait, then it will adjust the image's 
height to fit the field's height, without affecting the image's 
aspect ratio:

If the image orientation is landscape, then it will adjust the 
image's width to fit the field's width, without affecting the 
image's aspect ratio:

Pan

This has the opposite effect to the fit parameter. The image's 
smallest dimension will be made to fit the scene frame's 
matching dimension, and the image's largest dimension will be 
adjusted proportionally, making the image fill the entire scene 
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field, and bleed past its boundaries it if its aspect ratio does not 
match the field's aspect ratio. This option can be used to import 
a panning background image, also referred to as a pan.

If the image's orientation is portrait, it will adjust the image's 
width to fit the field's width, without affecting its aspect ratio:

If the image's orientation is landscape, it will adjust the image's 
height to fit the field's height, without affecting its aspect ratio:

Project Resolution

Scales the image to fit the scene's resolution, making each pixel 
in the image take one pixel in the scene's field. For example, if 
the image's dimensions in pixels are half of the scene's 
resolution in pixels, then the image's dimensions will appear to 
be half of the scene field's dimensions. 

 6. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the way the 
pixels along the edge are blended with the other colours. You can choose between the following options:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white and 
greys.

Clamp Colour to Alpha Premultiplies the colour value with the alpha value. When the colour 
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is clamped to the alpha, the colour value cannot be higher than the 
alpha value. It calculates the real colour value faster. When the 
RGB values are multiplied with the alpha value, that is to say, if you 
have a pixel of value R=247, G=188, B=29 and the alpha is 50% or 
the image has a 50% transparency, then the actual RGB values 
that are output would be half of the amounts listed above.

 7. Click OK.

NOTE: By default, bitmap images will display in low resolution in the Camera view so as to avoid affecting 
playback performance. You can also adjust the display quality of a bitmap image by selecting it with the 
Transform tool, then opening the Bitmap Image Quality dialog via View > Bitmap File Quality. You can also 
preview your bitmap image in your scene's resolution by activating the Render Preview mode in the Cam-
era view. 
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Adjusting the Bitmap Image Display Quality 
T-HFND-007-004

You original bitmap are imported as is in your project. In the Camera view, they may appear low quality as a proxy 
image is displayed in its place to insure fast playback.

If the bitmap images that you imported look blurry or slightly pixelated, you can increase the image proxy display by 
changing the quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

 1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or 
simply select the bitmap image layer in the Timeline view if it's not.

 2. Do one of the following:

 l From the top menu, select View > Bitmap File Quality.

 l From the Camera menu, select View > Bitmap File Quality.

 l Press Ctrl + Q (Windows/Linux) or ⌘  + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

 3. Drag the slider to the right to improve the quality.

 4. Click OK.

 5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and return to 
your scene.
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Importing Bitmap Images As Toon BoomBitmap
T-HFND-007-002

Importing a bitmap imageas Toon Boom bitmap preserves its original detail, but allows the user to modify them 
using Harmony's bitmap drawing tools.

How to import a bitmap image as a Toon Boom bitmap drawing

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from your 
computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename 
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will 
create two layers, one named "a" and one named "b". Layer "a" will contain the two first 
images and "b" will contain the third one.
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 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're importing 
images as vector drawings, you can only import them into vector drawing layers. 

 2. In the Alignment section, decide on the size and placement of your image within the camera frame. You can 
choose between the following options:

Parameter Description

Vertical Fit

Adjusts the image's size so that its height matches the scene's 
height, without affecting its aspect ratio.

Horizontal Fit

Adjusts the image's size so that its width matches the scene's width, 
without affecting its aspect ratio.

Actual Size

Imports the image in its actual size, without adjusting its size relative 
to the scene's resolution. For example, if the image's dimensions in 
pixels are half of the scene's resolution in pixels, then the image's 
dimensions will appear to be half of the scene field's dimensions. 

 3. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the way the 
pixels along the edge are blended with the other colours. You can choose between the following options:
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Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white and 
greys.

 4. Click OK.
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Vectorizing Images on Import
You can import bitmap images as vector drawings, which allows you to edit them using Harmony's vector drawing 
tools. This is especially useful to convert bitmap line art scanned or created in a different software into vector line art 
so it can be painted in Harmony. 

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from your 
computer.

 2. Select the destination for your images:
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 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename pre-
fix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create 
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and 
"b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're import-
ing images as vector drawings, you can only import them into vector drawing layers. 

 3. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.

 4. In the Vectorization section, decide whether you want to import your image in black and white or in grey-
scale. You can also click the New Preset  button to create a custom vectorization parameter preset.

‣ Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing. 
The outlines of your drawings will be painted with the Vectorized Line colour swatch of your scene's 
colour palette.

‣ Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep the 
texture from the scan, and the white of the paper becomes transparent.

NOTE: You can double-click on any of the presets at any time to open the Vectorization Parameters dialog 
box to customize your option. 

 5. Click OK.

Your vectorized images will appear in their selected destination.
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Linking Layers to External Images
When working on a large production, you may want to centralize the backgrounds in one directory instead of 
duplicating the background several times in different scenes. As backgrounds are generally reused in many scenes, 
some studios like to save space on the server and link the different scenes to the background directory. Also, if they 
modify one background, it is modified everywhere at the same time without having to reimport it. To do so, you must 
use the Timing columns.

Timing columns are exposure sheet columns that link to files that are outside the scene’s structure. Because of 
these external links, care must be taken not to break the links by moving the scene’s location or the background 
directory’s location. Breaking a link will result in images not appearing in your scene.

NOTE: Refer to the  Timing chapter in the Traditional Animation, Paperless Animation or Cut-out Animation 
Guide to learn more about using Timing columns.

If you are working with Toon Boom Harmony Server and all your scenes are located on a centralized server, you can 
also use the Link to Images option.

How to link a layer to an external image

 1. From the top menu, select File > Import > Link to Images.

The Link to Images dialog box opens.

 2. Click the Browse button to select the image you want to link your scene to.

 3. Do one of the following:
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 l Select the Create Timing Layer option to create a new Timing column in the Xsheet view. 
Then select one of the following:

 l Create Single Timing Named: Type the new column name in the text field.

 l Create Timing(s) Based on Filenames: Creates file names based on the 
selected file's name.

 l Select the Add to Existing Timing Layer option to insert the file into an existing Timing 
column.

 4. Select the Copy to Timings Directory option if you want to copy the selected file into the Timings folder 
located in the scene directory. Note that the Timing column will link to the Timings folder.

 5. Click OK.
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About Vector File Import
T-HFND-007-005

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon Boom 
format (TVG) and create a colour palette based on the colour settings of the original file. 

When importing AI and PDF files:

 l RGB is supported, CMYK is not.

 l Gradients and textures are not supported.

 l Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and Action-
script 3, cannot be imported.

 l When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be imported as sep-
arate layers. The import will use the Illustrator file's top level groups as separate layer names. However, you 
can change this behaviour by deselecting the PDF/Illustrator Import as Separate Layers option, to import 
your file as a single layer .

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or 
multiplaning, it can easily be imported into Harmony. 

The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.
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Importing AI and PDFs 
T-HFND-007-006

You can import vector Adobe Illustrator files as well as PDFs through the Library view and File menu. Make sure 
you have the rights to modify your Library folder and the your files are in RGB format.

How to import an AI or PDF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you 
will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type in a name for the new template or keep the name of the original AI or PDF file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.
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The message window opens.

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking the 
Yes button, you have the option of selecting the Do Not Ask Again For This Session option if you plan to 
import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the imported 
file’s name.
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Importing SWF Files
You can import .swf files in Harmony that were published using any version of Flash Player, up to version 14. 
Note that some effects may not appear when imported in Harmony. 

How to import a SWF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you 
will not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your.swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type a name for the new template or keep the name of the original *.swf file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.
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 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking the 
Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This might be 
useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the 
imported file’s name.

NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT 
DELETE THIS PEG. To maintain the look of your movie, it's important not to delete this peg or detach its child 
layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become regular 
drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or drawings within 
symbols collapse into their corresponding parent symbol.
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NOTE: Some layers in your .swf movie may be combined in a single layer as a result of optimization 
enhancements in your movie file. You can easily move these elements back onto separate layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped 
together in one folder. In our example, this means that when you scroll through the Drawing Substitution 
preview in the Library view, the different hand, leg, tentacles, antennae, torso and facial positions are all 
organized together.
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Distributing SWFs to Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might be 
combined as a single layer. If so, you can quickly redistribute these elements onto individual layers again. 

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the drawing that contains elements you want to redistribute onto individual layers.  
To select the all the elements of the selected drawing layer, press Ctrl + A (Windows/Linux) or ⌘  + A (Mac 
OS X).

 3. Do one of the following:
 l From the top menu, select Drawing > Distribute to Layers.

 l In the Tool Properties view of the Select tool, click the Distribute to Layers  button.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline 
view. The selected elements in the original drawing layer are removed. Each element is distributed onto a 
new drawing layer.

 4. Repeat the process for each drawing that contains elements to redistribute.

961



Chapter 14: Import     About Vector File Import

About FLA  Import
You can export files from Flash and import them in Harmony to  transfer character rigs, props and backgrounds.

Flash import is available on all three editions of Harmony on Windows and Mac OS X. It is not possible to do so 
on Linux versions.

On the Flash side, users can work with these versions:

 l Adobe Flash CS5

 l Adobe Flash CS5.5

 l Adobe Flash CS6

 l Adobe Flash CC

 l Adobe Flash CC 2014

 l Adobe Flash CC 2015

NOTE: Exports from older versions of Flash are not possible.

At the scene level (top timeline), you must have a symbol, such as a movie clip or graphic. Colour shapes, shape 
lines, drawing objects, groups and bitmaps at the scene level won’t be exported. If these elements are present, 
you will be prompted to perform a clean up of the scene level. For details on importing Flash files, see About Flash 
File Creation on page 979

As part of preparing to import Flash files in Harmony, you must add an extension to Flash using Adobe Extension 
Manager—see Installing the Export to Harmony Option on page 964.

It is important to use the correct version of Adobe Extension Manager: 

 l If more than one version of Flash is installed on your computer, be careful where you install the extension. 
If it's added to Adobe Extension Manager of Flash CS6, the extension will only be added in this version 
and not the other.

 l If you have a previous version of the  extension, you must remove it first and install the latest extension—
see About FLA  Import on page 962.
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Harmony includes a script specially created to import FLA Export packages. You must add this script to your 
interface in order to use it—see Displaying the Import Flash Scene Icon on page 974.

When you export your FLA files, a folder will be created that contains the stage.tpl and export.json files, as 
well as all the .swf and.txt  files in your scene. The export.json file is used by a Harmony script to organize 
and construct the node system from your exported files.

Once the Flash project is successfully imported into Harmony, here's how the node system was constructed:

 l Each symbol has its own peg in which all the transformation information is stored.

 l Whenever there are more than three symbols nested inside a symbol, a Composite node is automatically cre-
ated to group them all.

 l The pivot information is stored in the peg's Layer Properties (Pivot fields). The pivot information came from 
the rotation point of the symbol in Flash.

 l Registration point of the symbol in Flash represents the centre of the drawing space in Harmony. Therefore, 
the position of the drawing inside a symbol will be exactly the same in Stage.

 l The imported node system is connected to the Composite of the scene, which contains the Write and Dis-
play nodes.

 l One colour palette is created for each Flash import. One colour swatch is created per RGB value. If you have 
more than one zone using the same colour, they will be linked to the same colour swatch.

 l If there are masks in your Flash project, they will reconstructed in Harmony using Cutter effects. Harmony is 
now able to understand when more than one symbol share the same mask in Flash. Each symbol sharing the 
same mask will be grouped by a composite and connected to the cutter.
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Installing the Export to Harmony Option
The extension is required in order for Flash to export files to Harmony. The extension is called Export to 
Harmony.zxp and is located here: 

OS Edition Location

Windows

Premium
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony [version] Premium\resources\flash

Advanced
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony [version] Advanced\resources\flash

Essentials
C:\Program Files (x86)\Toon Boom Animation\Toon Boom 
Harmony [version] Essentials\resources\flash

Mac OS X

Premium
Applications > Toon Boom Harmony [version] Premium > tba 
> resources > flash

Advanced
Applications > Toon Boom Harmony [version] Advanced > tba 
> resources > flash

Essentials
Applications > Toon Boom Harmony [version]  Essentials > 
tba > resources > flash

NOTE: Before installing the extension, you must remove all Harmony offline and database preferences.

How to install the Export to Harmony extension

 1. Launch Adobe Extension Manager.

 2. In the top-right corner of the Adobe Extension Manager, click on Install.

An Open dialog appears.

 3. In the Open dialog, browse to and select the Export to Harmony.zxp file, then click on Open.

A message opens informing you that you're about to install the Export to Harmony extension.

 4. Click on Accept.

You may see the following message confirming that you want to install the extension. Click Install.
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 5. In order for the changes to take effect, you must close and restart Adobe Flash.

 6. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

 1. If open, close Adobe Flash.

 2. Start Adobe Extension Manager.

 3. From the Products list, select Adobe Flash. 

If you have a previous version of the Export to Harmony.zxp extension installed, it will be listed in the 
right pane.

 4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.

 5. Click Yes.

Adobe has stopped  maintaining and updating their Extension Manager CC, therefore, it has become difficult to 
install extensions. In order to link an extension from Animate CC, follow the steps below. 

How to install an extension on Windows with Adobe Animate CC version 2015 and higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdWin

 3. Unzip the ExManCmd_win.zip package.

 4. Put the ExManCmd_win folder in a safe place.
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NOTE: The ExManCmd_win folder must not be deleted; this folder is necessary for installing 
or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads folder:

C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 
Premium\resources\flash\flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. In the ExManCmd_win folder, hold Shift and right-click to select Open command window here.

 10. Enter the following command: 

ExManCmd.exe /install <filename.zxp>.

 11. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by the 
Extension Manager CC.

 

 12. Open Animate CC.

 13. Access Top Menu > Commands.

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.
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NOTE: If you have a region language  other than English (US) installed on your computer, or if you 
have more than one language installed on your computer, Animate CC may not be able detect in 
which language folder the extension has been installed. If this occurs, you will not be able to see 
the Export to Harmony menu option in Top Menu > Commands list. To correct this, proceed to 
How to ensure Adobe detects extension files installed on your computer on page 967.

How to ensure Adobe detects extension files installed on your computer

 1. Browse to:

C:\Users\<UserName>\AppData\Local\Adobe\Animate <VersionNumber>

 

If Adobe detects more than one language on your computer, you will see multiple language folders in the path.

 

For example:

 

 

 2. Look inside each folder to detect the main language used by Adobe on your computer. To do so, compare the 
contents of both folders.

For example, inside the en_Ca\Configuration:

 

 

For example, inside the en_US\Configuration:
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The main folder is the one with more files. In this case, Adobe is using English (US) as the main language. 
The folder en_CA only contains what was installed with the extension installation: commands, Javascript 
and WindowSWF.

 3. Copy and paste the contents of the commands folder within the sub-language folder, to the commands 
folder within the main language folder .
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 4. Copy and paste the contents of the Javascript folder within the sub-language folder, to the Javascript folder 
within the main language folder.

 5. Copy and paste the contents of the WindowSWF folder within the sub-language folder, to the WindowSWF 
folder within the main language folder.
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How to install an extension on Mac OS X with Adobe Animate CC version 2015 and higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdMac

 3. Unzip the ExManCmd_mac file.

 4. Put the ExManCmd_mac folder in a safe place.

NOTE: The ExManCmd_mac folder must not be deleted; this folder is necessary for installing 
or updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads folder:

/Applications/Toon Boom Harmony 14.0 Premium/tba/resources/flash/flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. Drag and drop the .zxp file directly into the ExManCmd_mac folder.

 10. In Terminal, go to the folder where the ExManCmd_mac package was extracted.

For example, if you have put the ExManCmd_mac folder into the Downloads folder:
cd Dowonloads/ExManCmd_mac/

 11. Enter the following command:

Contents/MacOS/ExManCmd --install <filename.zxp>

 12. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by the 
Extension Manager CC.
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 13. Open Animate CC.

 14. Access Top Menu > Commands. 

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was successful.
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Exporting FLA Files

How to export FLA files for Harmony from Adobe Flash

 1. Open your.fla file in Adobe Flash. 

NOTE: In case of a new file, it needs to be saved before continuing the exportation process. If not, the export 
won't be completed.

 2. Return to the scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

 3. Do one of the following:

 l Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony. 

 l Adobe Flash CC: Window > Extensions > Export to Harmony.

NOTE: This window must be opened once after installing the extension in the extension manager because it 
creates a drect link to Harmony (even if the window is not used). Afterwards, you do not have to reopen it if 
there is no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will appear in 
Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value of Harmony. If 
needed, you can change the compression: Photo (JPG) or Lossless (PNG).

 4. Do one of the following:

 l In the Export to Harmony window, click Export button. 

 l Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:

Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all groups to 
verify if any symbols are hidden inside, breaking drawing objects to transfer them as shapes, drawing 
substitutions, and so on. Problematic situations will also be mentioned. If nothing appears in the Output 
tab, then your.fla file is clean and does not need any conversions.
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The .txt files contain the drawing substitution information and at which frame they are exposed. A .swf file 
is created for each symbol in Flash and a .tpl file is created of them. The corresponding export.json file is 
also created, which you will need when importing your Flash scene in Harmony. These files are in a folder 
located at the same location as the.fla file.  The folder name is the same as the .fla file.

NOTE: If  a folder with the same name as the .fla file already exists, you will be prompted to replace the 
folder. Be aware that saving Flash projects as .xfl files will automatically create a folder with the same name 
as the .fla file. In this case, the folder of the export will be created inside the folder of the xfl. If this not what 
you want, place a copy of the.fla in another path on your computer before the export.
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Displaying the Import Flash Scene Icon
When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash Scene 
icon. If the icon does not appear in the Scripting toolbar, add it to the toolbar. Note that you will only have to do 
this once. After that, you can import Flash files whenever needed.

How to display the Flash Import script icon

 1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

 2. Click the Manage Scripts  button.

The Scripts Manager opens.

 3. From the Files section, select TB_Import_Flash_Scene.js. 

On your computer, here is the location of the script file:

 l Windows:

 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony\1400-scripts
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 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Advanced\1400-scripts

 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Essentials\1400-scripts

 l Mac OS X: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony/1400-scripts

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Advanced/1400-scripts

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Essentials/1400-scripts

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Global: [Server_Name] > USA_DB > scripts

 l Environment: [Server_Name] > USA_DB > environments > [environment_name]

 l Job: [Server_Name] > USA_DB > jobs > [job name]

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-scripts

 5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to the In 
Toolbar section.

 6. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash scenes.
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Importing FLA Files
Once your extension is installed, your FLA file has been exported and your displayed the FLA import script in your 
toolbar, you are ready to import your FLA file in Harmony.

How to import FLA files

 1. In the Scripting toolbar, click the Import Flash  button.

 2. In the Import Files dialog box, locate the export.json file contained in the folder that was created when you 
exported your files from Flash.

 3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery. 

 4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option. 

In a few moments, the .fla files are imported in Harmony. 
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 5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.
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About Flash File Creation
The following points are guidelines for you to create optimal Flash files to export to Harmony.

Scene Root
What can be at the scene root:

 l Only symbols. A minimum of one symbol is necessary. It could be a MovieClip or a graphic.

What cannot be used at the scene root:

 l Shapes: Colour shapes and line shapes

 l Bitmaps

 l Drawing objects

 l Groups: The group works differently at the scene level. They are understood as shapes at the scene level—
see Mixed Layers on page 981.

Timeline
These features can be used in the Flash file, but will not appear in Harmony Premium:

 l Guide layers for references

 l Locked layers

 l Disabled layers

 l Folders in the Timeline view

 l Other: Several symbols on the same layer/keyframe. In this case, Harmony Premium will separate them, giv-
ing them a proper layer/Drawing node. In other words, a Distribute to Layers action performed in the process 
of exporting/importing.

Not recommended:

 l Mixed layers—see Mixed Layers on page 981

 l Symbols with shapes, bitmaps, or group on the same layer/keyframe

 l Symbols with drawing objects

Library View
In the Library view, the following will not be exported:

 l ActionScript Linkage

 l Embedded fonts

Effects
The following effects will not be exported:

Filters Adjust Colour
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Drop Shadow

Blur

Glow

Gradient Bevel

Gradient Glow

Colour Effects (other than None)

Alpha 

Advanced 

Brightness

Tint

Display 

Blending (other than Normal):

 l Layer

 l Darken

 l Multiply

 l Lighten

 l Screen

 l Overlay

 l Hard Light

 l Add

 l Subtract

 l Difference

 l Invert

 l Alpha

 l Erase

 

Render: Cache as Bitmap

Component parameters

Drawing Features

 l Width tool: Any change on the thick and thin of a line

 l Line: 

 l Width

 l Cap: Any change of the line cap will be replaced by the round cap (None and Square)

 l Join: Any change of the line join will be replaced by the round join (Miter and Bevel)
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 l Gradient (Flow): Reflect colour, Repeat colour

 l Import Bitmap: When importing .swf files, you can import files that have an image compression of Photo 
(JPG) or Lossless (PNG). 

Mixed Layers
Mixed layers are something you must seriously consider before trying to export a Flash project to Harmony. 
Otherwise, there can be unexpected results or no export at all. In fact, it's best to avoid having mixed layers 
altogether.

A mixed layer is defined as a layer that has more than one instance of objects at the same keyframe. It could be a 
mix of symbols and groups; groups and drawing objects; symbols and shapes, and so on. Since Harmony 
understands symbols better than groups or drawing elements, some information can be lost along the way.

Parameter Description

Drawing Objects No matter what is inside a drawing object, it will always be understood as a 
shape. So if a drawing object shares the same layer with a shape, it won’t be a 
real mixed layer, since they are all understood as shapes.

Groups that Contain Only 
Symbols (MovieClip or 
graphic)

When there is a symbol inside a group, the group will be ungrouped automatically 
during the export from Flash. The symbol inside it will be understood by Harmony 
as a Drawing node.

But if there is more than one symbol inside the group, all the symbols will be 
understand as if they were only one symbol. For example, if you have a group 
containing five MovieClips and one graphic, Harmony will create one Drawing 
node to  contain the five MovieClips and one graphic. This can be useful when you 
want to create a repetitive texture and you don’t want to have each repetition 
separated in Harmony. There is no differentiation between symbols.

Groups that Contain 
Symbols and Shapes

When there is one or more symbols with shapes inside the same group, the group 
will be ungrouped automatically during the export from Flash, but all the symbols 
and shapes will be exported as if they were one symbol. There is no differentiation 
between symbols and shapes.

Symbols and Groups on the 
Same Layer 

If there are symbols and groups sharing the same layer, each symbol will be 
separated from all the groups which will then be grouped together as one element. 
In Harmony, each symbol will have its own Drawing node, but all groups share 
one Drawing node. Since only symbols can have a name, its name is propagated 
to the Drawing node and peg. 

Groups, however, will receive the name of the MovieClip followed by an 
underscore and an appropriate number. For example, of you have a group inside a 
symbol called HEAD, the group will receive the name HEAD_1 if there is already 
a Drawing node that was created with the same name.

Symbols and Drawing Object-
s/Shapes on the Same Layer

If there are symbols and drawing objects/shapes sharing the same layer, the 
symbols will be separated from them and all the drawing objects/shapes will be 
kept together. Drawing objects and shapes cannot be separated. In Harmony, the 
symbols will have their own Drawing node and the drawing objects/shapes will 
share the same Drawing node. Since only symbols can have a name, its name is 
propagated to the Drawing node and peg.

Drawing objects and shapes, however, can't do this. Drawing objects and shapes 
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will receive the name of the MovieClip followed by an underscore and an 
appropriate number. For example, if you have a group inside a symbol called 
HEAD, the group will be named HEAD_1 if there is already a Drawing node that 
was created with the same name.

Groups and Drawing 
Objects or Shapes on the 
Same Layer

In order to have groups and drawing objects/shapes on the same layer, these 
elements must first be inside a symbol. Groups and drawing objects/shapes 
sharing the same layer in Flash will be exported as one Drawing node. This 
Drawing node will contain both drawing objects and shapes, and receive the 
name of the symbol in which they are contained.

Mixed Instances at the 
Same Level as a Symbol

Mixed instances at the same level as a symbol can occur when, at the same level 
inside a symbol, there is more than one type of element sharing the same timeline 
at a specific frame. Those elements may be mixed layers.

Type of problems that can occur if mixed instances are kept:

 l Order of appearance can be lost

 l Some layers can merge together

 l Transparency of shapes can cut other shapes
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About PSD Files
Harmony allows you to export the contents of your scene as a PSD layout. This can be helpful for scene setup, 
background art retakes, or even planning of animation. 

Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a camera 
movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear 
and complete layout.You can also create all the layouts for your production in the same Harmony  project which can 
be imported later on when you start each scene’s project. This will help set up the scene and begin its creation. You 
can use the layout .psd files to create the background art of each scene and make sure everything is correctly 
framed and at the right size. Finally, you can also have a layer with a drawing of the rough poses of the character or 
action and generate your layout posing from there.

NOTE: Because the layout image is one static .psd file, only the first frame of your drawing layers will be expor-
ted—see Staging on page 1009 and Motion Paths on page 1173.
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Importing Multi-layer PSD Files
T-HFND-007-003

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain 
multiple layers. This is advantageous as the image remains fully editable in terms of any colour correction, 
effects, masking, transparency, or compositing that were made to the .psd file in Adobe Photoshop. Harmony 
supports 8 and 16 bit files.

NOTE: Note that your .psd image file must be set to RGB mode within Adobe Photoshop prior to being impor-
ted into Harmony.

How to import a multi-layer PSD file

 1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all 
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any 
layer that is not in a folder group, by itself or otherwise, will not be imported.

 2. In Harmony, go to the top menu and select File > Import > Images or click the Import Images  button.

The Import Images dialog box opens.
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 3. In the Files section, click Browse to find and select the .psd image on your computer.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create two lay-
ers, one named "a" and one named "b". Layer "a" will contain the two first images and "b" will 
contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're importing 
images as vector drawings, you can only import them into vector drawing layers. 

 5. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

 6. In the Import Options section, select the following option to import your image as its original format.

 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, 
decide on the size and placement of your image within the camera frame. Depending on the 
Scene Settings (the height and width in pixels that you chose for your project), an image that 
you import may get scaled to the point where all its individual pixels become visible.

 7. Decide whether to select Vectorize Imported Items option.

 8. Click OK.

The Multilayer Image Import Settings dialog box opens.
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 9. From the Create  menu, select one of the following:

 l Single Layer: To import the Camera and Layout layers merged together.

 l Separated Layers: To keep your Camera and Layout layers separated.

 10. From the Transparency menu, select one of Alpha option.

 11. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group folders.

NOTE: The artwork displayed in every one of your layers as a result of a multilayer PSD file 
import is linked to the same source image. This means that if you use the Drawing > Delete 
Selected Drawings command to physically delete the drawing from the project folder, the 
exposed drawing will be deleted in all layers at once. Once deleted from the project folder, the 
image cannot be retrieved unless you reimport your psd file.
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Exporting PSD Layouts
You can export your scene's first frame as a PSD layout to modify and paint in an external image editing software. 
The matching XLI file always has to be with the exported layout file.

How to export your scene as a layout

Before exporting your scene as a layout, position your background elements, and everything you need as a 
reference in your scene, including a camera movement. 

 1. From the top menu, select one of the following:

 l File > Export > Layout Image to export all the elements in your scene to the layout .psd file.

 l File > Export > Layout Image from Selection to export only the selected elements. 

The Export Layout Image dialog box opens.

 2. In the Export Layout Image dialog box, set the export parameters—see the Reference guide 

 3. Click OK to validate the settings and export a .psd file of your layout.

The resulting image is a .psd file with one or two layers, each of which is contained in a corresponding group. 
These groups make the layout .psd file ready for a multilayer .psd import. 
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The Camera_Set group contains the camera drawing layer. If you selected the Export Camera option, this 
group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame when 
you exported the layout image.

NOTE: An .xli  file is exported along with your .psd file. This file contains all the necessary information for cor-
rectly importing and automatically positioning your layout image in a Harmony project. Do not delete the .xli 
file or rename it. Also, always keep it at the same location as the layout .psd file.
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Importing PSD Layouts
If you exported a Photoshop layout image from a Harmony project using the Export Layout Image function, you can 
easily import it back into Harmony, simply be sure to import it at the beginning of the project for accurate scene 
planning.

Harmony supports both .psd and .psb file formats.

How to import a PSD layout

 1. In your Harmony project, select File > Import > Images.

The Import Images dialog box opens.

 2. In the Files section, click Browse to find and select the .psd or .psb layout file on your computer. Note that 
this layout file must have its corresponding .xli file in the same folder.

 3. Once you have selected the layout file, the Use Position Information Contained in XLI File option appears in 
the Layer section. 

This option is enabled by default. When you import the layout image in your scene, it will be automatically 
positioned to fit the original layout scene creating an accurate layout guide. You can disable this option if you 
want the imported layout image to be imported according to the normal behaviour of the import process. The 
layout image will be incorrectly aligned as it was when it was first created.
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 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename pre-
fix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create 
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and 
"b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're import-
ing images as vector drawings, you can only import them into vector drawing layers. 

 5. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

 6. In the Layer section, select the Create Layer(s) option, then select one of the following options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename pre-
fix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create 
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and 
"b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're import-
ing images as vector drawings, you can only import them into vector drawing layers. 

 7. Select the Create Symbol for Imported Items option if you want the layers to be contained in symbols.

 8. In the Import Options section, select the following option to import your image as its original format.

 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment sec-
tion, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image 
that you import may get scaled to the point where all its individual pixels become visible.

 9. Decide whether to select Vectorize Imported Items option.

 10. Click OK.

The Multilayer Image Import Settings dialog box opens.

990



Harmony 14 Premium - User Guide

 11. From the Create  menu, select one of the following:

 l Single Layer: To import the Camera and Layout layers merged together.

 l Separated Layers: To keep your Camera and Layout layers separated.

 12. From the Transparency menu, select an alpha option—see the Reference guide .

 13. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the .psd layer group folders 
Camera_Set and Layout_Set. You can now use this layout as a guide for scene settings.
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Importing QuickTime Movies
T-ANIMPA-004-002

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation. 
Toon Boom Harmony allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

 1. From the top menu, select File > Import > Movie.

 2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE: Do not browse for the movie file again. Leave the automatically generated field text as “many files 
selected”.

 3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see the Refer-
ence guide .

 4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the film 
frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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About Scanning
Harmony can receive images from any TWAIN device, such as  scanners or digital cameras. You can load these 
images as bitmaps into your scene or convert them into vector-based images that can be edited using Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of your 
device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the digital 
exposure sheet.

Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import them in 
Harmony. The scanning process is the point where the traditional production becomes digital. It's the moment where 
you use Harmony to control the project.
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Scanning Images 
Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These 
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be edited 
using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you must 
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the 
device manufacturer’s website.

How to scan images

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens. 

 2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the Scanner 
menu. If none are available, check your device to ensure that it's properly connected to your computer. If 
your device still does not appear in the menu, you may have to shut down and restart the software.

 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing 
layer—see the Reference guide .

 4. In the Import Options section, select the type of image you want to create—see the Reference guide .
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 5. In the Alignment section, decide on the size and placement of your scanned image within the camera frame. 
Depending on the scene settings (the height and width, in pixels, that you chose for your project), an image 
that you scan may be scaled to the point where all its individual pixels become visible—see the Reference 
guide .

 6. In the Drawing Options section, set the following options if desired:

 l Drawing Name: Name of the drawing to import.

 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click Scan.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 7. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 8. Click Scan to scan your drawing.

 9. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

 10. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.
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Vectorizing Scanned Drawings
You can turn scanned images into vector drawings, while maintaining the sketchiness of a pencil line or into 
vector images with a bitmap fill. Both options can add life to an animation, which straight vectorization with 
smoothing does not usually afford.

How to scan and vectorize drawings

 1. From the top menu, select File > Import > From Scanner.

The Scan Drawings window opens.

 2. Select your scanner from the Scanner list.
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 3. Click Preview to get a test scan of your drawing.

 4. In the Layer section, select one of the following:

 l Create Layer: Imports an image into a new layer. Type a name for the layer in the Name field. 

 l Add to Existing Layer: Imports the image into an existing layer. Select a layer from the Layer 
list.

 5. In the Import Options section, select the Convert to Vector Drawing option.

 6. In the Vectorization section,  set the following:

 l Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. Set the Threshold and Smooth parameters.

 l Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep 
the texture from the scan, and the white of the paper becomes transparent.

 l New Preset: Lets you create a new preset.

 l Delete Preset: Lets you delete any preset in the list.

 l Custom vectorization: Lets you set custom vectorization parameters—see About Custom Vec-
torization Parameters  on page 999.

 7. In the Drawing Options section, set the following options if desired:

 l Drawing Name: Name of the drawing to import.
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 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click Scan.

 l Overwrite: Lets you overwrite existing drawings—see Vectorizing Scanned Drawings on 
page 996.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 8. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the view.

 9. Click Scan to import your drawing.

 10. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to 
capture your next frame.

 11. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you 
have finished scanning all your drawings.
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About Custom Vectorization Parameters 
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center modules 
when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green pencil 
marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, blue, 
green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your tones 
and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and watch the 
indicator colour zone lines disappear.
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Creating Vectorization Styles 
With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to 
set the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

 l Black and White: All the lines become vector based and 100% black. The white areas become com-
pletely transparent.

 l Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained 
inside a vector frame. The white areas become completely transparent.

 l Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and 
turn them into 100% vector lines, preserving their original colours—see the Reference guide .

How to create or modify the vectorization parameters

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization para-
meters (i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

 l In the Layer section, decide on the layer options.

 l In the Import Options section, select the Convert to Toon Boom Vector Drawing option

 l Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

 4. The Vectorization Parameters dialog box opens.

 5. Set the different options available in the Vectorization Parameters dialog box—see the Reference guide .

 6. Click the Vectorize  button to update the Vectorized Image preview.
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The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import 
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are 
applied during the vectorization process.

 7. To set advanced parameters, read the information on the Help tab, then type in the Advanced Options field at 
the bottom of the dialog box.

 8. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan module 
vectorization style list, click  Save.

 9. In the Browser window, name and save the file.

 10. To save the current settings as your default settings, click Save As Default. To restore the default settings, 
click Restore Defaults.

 11. To load a vectorization style, click Load and locate the existing *.vof file.

 12. Click OK.
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Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch 
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to 
create your own to fit your production style.

How to set the VectOptions.conf file on Windows or Mac OS X

 1. Open the vectOptions.conf file:

 l Windows: Select Programs / All Programs > Harmony 14 > Tools > Configuration 
Editor.

 l Mac OS X: Select Applications > Harmony 14 > Tools > Configuration Editor.

The Configuration Editor window opens.

 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vec-
torization style. These options are the same as in the Vectorization Parameters dialog box. It is recom-
mended that you create your vectorization style using Harmony and the Vectorization Parameters window 
and copy the result parameters in this file—see About Custom Vectorization Parameters  on page 999

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones 
to the list using the parameters you got using the Vectorization Parameters window. Notice that some of 
the lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the 
style list. The lines that have no sign at the beginning appear in the style list.
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 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black Lines.

 6. Under the style name line, type the following: 

options:

 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Parameters 
window.

‣ To open the *.vof file, use any plain text editor application.

 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and 
vectorize drawings, the selected style must be available on all the machines included in the batch processing 
list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the vi text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_14/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5. 

$ sudo vi VectOptions.conf

 4. Enter the root password.

 5. Open the VectOptions.conf file:

$ vi VectOptions.conf

 6. To start editing, press I to enter Insert mode.

 7. When you're finished editing the file, press Esc to exit Insert mode.

 8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

 9. To exit the vi editor and return to the Terminal, type the following and press Enter/Return:

$ :q
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 10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the gedit text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_14/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5.

$ sudo gedit VectOptions.conf

 4. Enter the root password.

 5. Open the VectorOptions.conf file:

$ gedit VectOptions.conf

 6. Edit the parameters of the VectOptions.conf file as you would do in most text editor applications.

 7. Select File > Save.

 8. Select File > Quit.

 9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.
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NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and 
vectorize drawings, the selected style must be available on all the machines included in the batch processing 
list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.
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Overwriting Using Scanned Drawings
At times, it might be more efficient to create a scene and fill in the exposure sheet before scanning. Then you can 
simply scan your drawings to fill in the necessary cells in the exposure sheet. Note that when you start scanning, 
the drawings are named sequentially regardless of whether there is an exposure or not in the Xsheet.

How to overwrite existing drawings

 1. In the Xsheet, select the first cell to overwrite.

 2. From the top menu, select File > Import > From Scanner.

 3. In the Scan Drawings window, do the following:

 l Scanner: Select your scanner from the list.

 l Layer: Select the Add to Existing Layer option.

 l Import Options: Select the Convert to Toon Boom Vector Drawing option.

 l Vectorization: Select an appropriate option: Black and White or Grey, or create a new preset.

 l Drawing Options: Select the Overwrite option.

 4. Click Preview.

The scanner window opens. 
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 5. Make any necessary adjustments to the image before scanning, then click Preview.

 6. In the Scan Drawings window, click Scan.

The scanned drawing replaces the selected cell in the Xsheet, filling the entire exposure. The Drawing 
Options section indicates the name of the cell the drawing overwrote and its exposure value.
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Chapter 15: Staging

Setting up your scene can be compared to building a set for a television show. This is the point when you position 
each scene element such as the camera frame, the background elements and the characters.

To learn how to position and animate your camera, see Cameras on page 1259.
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About Layer Position

Setting up the scene also involves positioning the different scene elements within the camera frame.

At this time, the elements are set to a static position. See Motion Paths on page 1173 to learn how to animate the 
elements and the camera.
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About the Animate Mode
T-HFND-008-001

The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view. 
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled, 
keyframes are not created when an object's parameters change.

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your drawing 
layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off

 1. In the Tools toolbar, click the Animate  button or select Animation > Animate.
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Selecting Layers
T-HFND-008-002

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform  tool. When using this tool, its 
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection  Mode option 
in the Tool Properties view is disabled or it will limit the selection to pegs only.

How to select a layer in the Camera view

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

 3. In the Camera view, click on the element to be repositioned. You can select more than one element at a 
time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to select from the Timeline or Xsheet view

 l In the Timeline view, click the layer corresponding to the element you want to reposition. 

 l In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.

How to select non-adjacent elements in the Timeline or Xsheet view

 l In the Timeline view,  hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any layers that you 
would like to add to the selection.

 l In the Xsheet view,  hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any columns that you 
would like to add to the selection.

 The non-adjacent, selected layers and columns are highlighted in the Timeline and Xsheet views.

How to select all elements within a group in the Node view

 1. In the Node view, navigate to the group whose elements you want to select.

 2. Hold down Alt and drag a marquee selection around the group node.
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All elements within that group are selected.

How to select all elements within a group in the Timeline view

 1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.
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Setting Bounding Box Styles
You can change the display style of selected elements to a bounding box style. This removes the default overlay 
highlight and leaves only the bounding box around the selected element.

How to set the bounding box selection style

 1. In the Camera view bottom toolbar, click the BBox Selection Style  button.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can use 
the Centre on Selection feature to display the selected object's layer in the Timeline view.

Like the Timeline view with its many layers, when you have several nodes in the Node view, you may find it hard to 
locate which one is selected. You can use the Centre on Selection feature as well as the Search toolbar to focus on 
the selected node in the Node view. You can also select elements in the Timeline or Xsheet view. This can be useful 
when there are too many objects in the scene or when an object is hard to grab. Finally, you can select all the 
elements within a group at once via via the Node or Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. Do one of the following:

 l From the Timeline view menu, select View > Centre on Selection or press O.

 l In the Timeline view toolbar, click the Centre on Selection  button.

How to center on the selected layer in the Node view

 1. In the Camera or Timeline view, select a layer.

 2. Do one of the following:

 l From the Node View menu, select View > Centre on Selection. 

 l In the Node View toolbar, click the Centre On Selection  button. 

 l In the Node view, press O.
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About the Transform Tool 
T-HFND-008-003

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera 
view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is 
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

NOTE: Refer to About 3D Space Positioning on page 1109 to learn about the 3D Transform tool and how to 
position elements in 3D space.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and 
vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip 
Scale Y will perform a flip on your drawing layer following its original axis.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Repositioning Temporary Pivots with the Transform Tool
T-HFND-008-004

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can 
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is only 
moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot 
position—see About Advanced Animation Tools on page 1024.

How to temporarily reposition the pivot point

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously 
repositioned.

 4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this position 
as long as you do not deselect the drawing. Using the Transform tool to reposition your pivot will 
temporarily override the existing pivot point position until you complete the current transformation. Then it 
returns automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a ghost so 
you know where it is and also from where the animation will be interpolated when you create motion paths. 
The animation is always interpolated from the original pivot and not the temporary pivot.
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Panning with the Transform Tool
T-HFND-008-005

You can pan (translate) a layer using the Transform tool.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple lay-
ers to reposition them at the same time. Hold down Shift and select the different layers.
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Rotating with the Transform Tool
T-HFND-008-006

You can rotate a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to rotate 
from a different point.

How to rotate a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer outside of a corner of the bounding box and drag to rotate.

NOTE: You can display a rotation handle on the bounding box when transforming a layer. In 
the Preferences dialog box, select the Camera tab and then select the Use Rotation Lever 
with Transformation Tools option. This preference is off by default.                         
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Scaling with the Transform Tool
T-HFND-008-007

You can scale a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to scale from a 
different point.

How to scale a layer using the Transform tool

 1. In the Tools toolbar, enable or disable the Animate  mode if you want to animate or not.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold 
down Shift to lock the selection's aspect ratio. 

NOTE: When scaling your selection, you can hold down Shift to preserve its aspect ratio.
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Skewing with the Transform Tool
T-HFND-008-008

You can skew a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to skew 
from a different point.

How to skew a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer between two controls points and drag sideways or up and down. 
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Flipping with the Transform Tool
T-HFND-008-009

You can flip a layer using the Transform tool. There are two ways to flip.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

 5. Do one of the following:

 l From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

 l In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  buttons.

 l Press 4 or 5. 

How to flip an element following its original axis

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Camera view, use the Transform  tool to select an element that has already been transformed.

 4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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About Advanced Animation Tools
T-HFND-008-010

You can also use the advanced animation tools to position your layers. The difference between these tools and 
the Transform tool is that they modify only one parameter of the position such as the rotation or the scale as the 
Transform tool adjusts all parameters together.

You can find the advanced animation tools in the Advanced Animation Tools toolbar.
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Repositioning Permanent Pivots
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the position of 
the drawing's pivot point. While making transformations using the Transform tool, you can drag and drop your 
selection's pivot. However, this has no permanent effect. It will only temporarily change the pivot's position to help 
you make transformations at the selected frame, but the actual pivot point of your drawing layer will remain the 
same. You can reposition a layer's pivot point permanently using the advanced animation tools.

How to permanently reposition the pivot point

 1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  tool.

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

The pivot point appears in the Camera view.

 3. Drag the pivot point to a new position.

NOTE: When you permanently move the pivot point, of a layer that is already animated, all the transformations 
done on the layer on other keyframes will be recalculated according to the new pivot point's position. Therefore, 
your existing animation will look completely different, except at the current frame. It is recommended to always 
make sure your pivot point is at its ideal position before you start animating.
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Using the Translate Tool
You can use the Translate tool to pan your elements on the X, Y and Z axes.

How to use the Translate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Translate. 

 l In the Advanced Animation toolbar, click the Translate  tool.

 l Press Alt + 2.

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 4. Drag the selection to a new area. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) 
or ⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Rotate Tool
You can use the Rotate tool to rotate your objects on the x,y and z axis.

How to use the Rotate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Rotate. 

 l In the Advanced Animation toolbar, click the Rotate  tool.

 l Press the Alt + 3. 

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 4. Rotate the layer. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 
⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Scale Tool
You scan use the Scale tool to squash, stretch, and resize your elements.

How to use the Scale tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Scale. 

 l In the Advanced Animation toolbar, click the Scale  tool.

 l Press Alt + 4. 

1. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s ratio 
when using the corner control points. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) 
or ⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Skew Tool
You can use the Skew tool to distort your elements on the x and y axis.

How to use the Skew tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l Select Animation > Tools > Skew. 

 l In the Advanced Animation toolbar, click the Skew  tool.

 l Press Alt + 5.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select it and 
drag a side of the bounding box up, down or sideways. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 
⌘  + Shift + click (Mac OS X) on each element to select them. 
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About the Layer Properties View
T-HFND-008-011

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these 
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in the 
Camera view. These values can also be animated over time.

NOTE: To learn more about the layer parameters, see the Reference guide .

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters  button. 

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and 
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. 
Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has been 
drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have drawn on the 
page. This allows scanned drawings, imported images and paperless drawings to be properly registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something like 
the following:
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 l X Axis: -4 or 4W (4 West)

 l Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something like the 
following:

 l X Axis: 3 or 3E (3 East)

 l Y Axis: -2 or 2S (2 South)
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Displaying the Layer Properties View
You can display the Layer Properties view in several ways.

How to display layer parameters

 1. Do one of the following:
 l In the Layer Properties view is not part of your workspace, from the top menu, select Windows > 

Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

 l In the Node view, click on a node’s yellow properties button.

The properties display—see Element/Drawing Node in the Reference guide .
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Positioning Elements with the Layer Properties View
T-HFND-008-012

You can type values to position your elements using exact coordinates. 

NOTE: To learn more about the layer parameters, see the Reference guide .

How to position an element with coordinates

 1. In the Timeline view, select a layer.

 2. In the Layer Properties view, select Enable 3D option to display the 3D parameters in the Layer Properties.

 3. In the Position section, select one of the following options:

 l Separate to independently edit the different coordinate fields. Continue to step 3.

 l 3D Path to use a 3D path function when animating your element. Continue to step 4.

 

 4. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—see About 
Multiplane on page 1043.

As you type in values, the element’s position is updated in the Camera view. 

 5. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 6. In the Scale section, select one of the following options:

 l Locked to resizes the element uniformly in three directions.

 l Separate to resize the element in any direction without affecting the others.
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 7. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position

 8. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 9. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can enter 
values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

 10. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

 11. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will 
change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see the Reference guide .
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About Selection Locking
You can prevent correctly positioned layers from being selected in the Camera view by locking them in the Timeline 
view. This is useful for making a multiple selection inside the Camera view while avoiding to select them. Once a 
layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:

 l The Lock  option lets you lock Locks one or a multiple selection of layers. 

 l The Unlock  button lets you unlock Unlocks one or a multiple selection of locked layers.

 l The Lock All  option lets you lock Locks all the layers in the Timeline view. 

 l The Unlock All  button lets you unlock Unlocks all the layers in the Timeline view. 

 l The Lock All Others  button lets you lock Locks every layer except the selected ones.
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Locking Layers
You can perform five types of locking actions on your layers. You will still be able to modify locked layers in the 
Timeline and Layer Properties views, but you will not be able to select them through the Camera view.

How to lock a layer or a selection of layers

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock. 

 l Click one of the selected layer’s Lock  icon. 

 l Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (Mac OS X).

All selected layers are locked. 

How to unlock a locked layer or a selection of locked layers

 1. In the Timeline view, select one or more locked layers.

 2. Do one of the following: 
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 l From the top menu, select Animation > Lock > Unlock. 

 l Click a selected layer’s Lock  icon. 

 l Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (Mac OS X). 

All selected layers are unlocked.

How to lock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Lock All. 

 l In the Timeline view, select all layers and click Lock  icon of a selected layer. 

 l Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (Mac OS X).

All layers are locked.

How to unlock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Unlock All. 

 l In the Timeline view, select all layers (locked) and click Lock icon of a selected layer. 

 l Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (Mac OS X). 

All layers are unlocked.
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How to lock all other layers

 1. In the Timeline view, select the layers you do not want to lock.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock All Others. 

 l Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (Mac OS X). 

All layers are locked except the selected ones.

How to display locked drawings as outline

 1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings  option.

 2. You can also set this option as a permanent preference. From the top menu, select Edit > Preferences 
(Windows/Linux) or Harmony Premium > Preferences (Mac OS X).

 3. In the Preferences dialog box, select the Camera tab.

 4. In the Tools section, select the Show Locked Drawings As Outlines option.
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About Auto-Apply
When you modify a parameter in a property dialog box, Automatically applies changes you make to a property 
window or dialog box. Harmony applies the modification automatically and displays the result in the Camera view. 
When working on a heavy scene, it is useful to turn off this option.If you want to always work in Auto-Apply mode, 
you can deselect the Auto-Apply option in the Preferences dialog box (General tab). Then, each time you start 
Harmony, the Auto-Apply  mode will be off. You must click the Apply button to see any modifications.

When you disable this function, Apply and OK buttons at added at the bottom of the Layer Properties view and any 
other parameter dialog boxes. 

 l Click Apply to apply the current change.

 l Click OK to apply the current change and close the Layer Properties.
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Setting the Auto-Apply Option
If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences dialog 
box (General tab). Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click the Apply 
button to see any modifications.

How to enable or disable the Auto Apply option

 l From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

 1. In the top menu, select Edit > Preferences (Windows/Linux) or
Harmony Premium > Preferences (Mac OS X).

The Preferences dialog box opens.

 2. In the Preferences dialog box, select the General tab.

 3. In the Options section, select or deselect the Auto Apply option.
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Resetting Transformations 
You can easily reset layers to their original position. With the Reset command, you can return the value of a selected 
element to the initial value of the active tool. For example, if the Rotate  tool is active, the transformation angle 
will be reset to 0 and if the Transform  tool is active, the all transformation parameters values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg Selection 
Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were 
created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to reset all transformation values except Z

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All Except Z.

All values except for those set on the Z axis are reset.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all keyframes and 
reset all values for the entire layer.
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 l In the Timeline View menu, select Layers > Clear All Values. This will remove all key-
frames and reset all values for the entire layer.

The selected layers return to their original position.

1042



Harmony 14 Premium - User Guide

About Multiplane
T-HFND-008-013

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create 
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through this 
environment to create an impressive perspective illusion.

In live action, when the camera moves through the scene, objects near the camera will move by a greater distance 
than objects far from the camera. In 2D animation, multiplanes can be used to achieve a similar effect without 
resorting to 3D backgrounds. 

In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and 
positioning them at different depths relative to the camera.  

Before creating a multiplane, make sure you have a proper understanding of the environment in which your scene 
happens. Picture what your scene's background would be like in 3D, then image the camera moving through the 
space, and how the objects in the picture move at different speeds depending on where they are in relation to the 
camera lens.

In the following example, the background is made of 6 different layers, each picturing an object that is at a different 
distance from the camera. On the left, you can see how each object is positioned relative to the camera, as if you 
were looking at them from the side. On the right, you can see how layers are positioned relative to each other as if 
you were looking at the scene from a corner. Below, you can see the scene from the camera's point of view.
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NOTE: When creating a multiplane background, it is important to draw each layer fully. Even if some parts of 
a background layer is hidden behind a foreground layer in the camera's initial position, panning or zooming the 
camera may expose parts of background layers that are not initially visible.

In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You can 
do this by moving a layer using the Transform Tool  in the Side or Top views. You can also move a layer on Z-
axis directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your element 
closer to the camera makes them appear bigger, and moving them further makes them appear smaller. It is also 
possible to move elements on the Z-axis without affecting their apparent size by using the Maintain Size tool 
in the Advanced Animation toolbar.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the 
Top and Side views.
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Just like with other transformations, transformations on the Z-axis on a parent layer will also affect the apparent 
position on the Z-axis of its child layers. Therefore, a child layer's apparent position on the Z-axis can be affected by 
any of its parents. Once transformations on the Z-axis have been performed on several layers in a hierarchy, it may 
be difficult to keep track of which layers have been moved on the Z-axis and which ones have not. To help with this, 
it is possible to compare the selected layer's Z coordinate value with its apparent position on the Z-axis using the 
Coordinates and Control Point view or the Coordinate toolbar. Both these interfaces feature a field to tweak the 
layer's Z coordinate, which is independent from parent layers, as well as a field displaying the layer's cumulative Z 
coordinate, which is the sum of the Z coordinate of the selected layer with the Z coordinate of all its parents. 

To enable the Coordinate toolbar, do one of the following:

 l From the top menu, select Windows > Toolbars > Coordinate.

 l Right-click on any visible toolbar and select Coordinate.

To enable the Coord. and Control Points view, do one of the following:

 l From the top menu, select Windows > Coord. and Control Points.

 l From any view already open, click the Add View  button at the top-right corner and select Coord. and 
Control Points. 
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Setting Up Multiplanes
T-HFND-008-017

You can setup your elements as a multiplane to create a parallax effect when moving your camera. You simply 
need to spread and scale the objects on the Z-axis.

Using the Depth View mode can also be a useful tool when setting up multiplanes, see—Using the Depth View 
Mode on page 1116.

How to rotate a scene in the Perspective view

 1. In the Tools toolbar, select the Rotate View   tool.

 2. Click in the view, and drag the cursor around to rotate the view or press and hold Ctrl + Alt (Win-
dows/Linux) or ⌘  + Alt (Mac OS X) and click and drag to rotate the view one axis at a time. 

How to set up a multiplane

NOTE: Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging 
option by selecting Animation > No Z Dragging. This option is disabled by default.

 1. To maintain the visual scale in the Camera view as you move your element, do one of the following:

 l In the Advanced Animation toolbar, select the Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from 
the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

 3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the same 
in the Camera view.
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 4. For your element to scale up or down in relation to their distance to the camera, do one of the following:

 l In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode  
option is disabled in the Tool Properties view.

 l In the Advanced Animation toolbar, select the Translate  tool and select a layer from the 
thumbnails section of the Top or Side view.

 l Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

 5. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging the element 
to make sure it only moves along the X-axis.

 6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging the 
element to make sure it only moves along the Y-axis.
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About Clone and Duplicate Layers 
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You 
can do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone uses 
the same drawings for all layers. A duplicated layer is simply an independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, you should 
clone your layer. If you simply want to copy your layers and be able to modify your drawings without affecting the 
original layer, use the duplicate option.
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About Clone Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, both 
will be updated. However, cloned layers can have different timings.

In the Timeline view, the left part of the layer is a node, same as in the Node view. These nodes are linked to 
columns. The right part of the Timeline view corresponds to the Xsheet column. These columns can contain drawing 
exposures or value keyframes. One node can be linked to several columns; one drawing column and several 
parameter columns (rotation, position, scale, pivot, etc.).

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or only the 
drawings. If you choose to clone the drawings and timing, your node will be linked to the same element folder, as 
well as the same drawing and function columns. Therefore, if you change the drawing exposure or keyframe on one 
layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the timing 
so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a soldier and 
want to use it for an entire army, you may want to have 50 layers with 50 different drawing exposures to produce a 
slight difference in the timing. If you copy your layers and drawings 50 times over, it will create a heavier scene. It is 
better to clone the 50 layers with only their drawings without linking to the same timing (function and exposure 
columns). 
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Cloning Layers
You can clone layers in several ways. Cloned layers use the same drawings.

How to clone a layer

 1. In the Timeline, Xsheet or Network view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

 l From the Xsheet menu, select Columns > Clone Selected Columns: Drawings Only or 
Columns > Clone Selected Columns: Drawings and Timing.

 l From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and 
Timing.

 l From the Timeline menu, select Layers > Clone Selected Layers: Drawings Only or Lay-
ers > Clone Selected Layers: Drawings and Timing.

 l In the Timeline view, right-click on the layers and select Clone Selected Layers: Draw-
ings Only or Clone Selected Layers: Drawings and Timing.

 l In the Node menu, select Nodes > Clone Selected Layers: Drawings Only or Nodes > 
Clone Selected Layers: Drawings and Timing. When you clone a node, it does not auto-
matically connect itself to the Composite node of your scene.

The cloned layer appears. 

NOTE: 
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C and Ctrl + V 
(Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this creates a CLONE not a duplicate.  Nodes will be 
linked to the same drawings.  Pegs will be linked to the same function columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X) and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) for Paste Special, and in the Advanced tab, 
select Nodes: Create New Columns.
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About Duplicate Layers
T-HFND-006-013

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as an 
independent timing (exposure). When you need the drawings to be modified independently, you will want to duplicate 
the layer instead of cloning it.
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Duplicating Layers
T-HFND-006-014

You can easily duplicate layers. Once duplicated, the layers are completely independent. Drawings are also 
duplicated.

How to duplicate a layer

 1. In the Timeline, Xsheet or Node view, select one or more layers.

 2. Do one of the following:

 l In the Timeline menu, select Layers > Duplicate Selected Layers.

 l In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

 l In the Node menu, select Nodes > Duplicate Selected Nodes. When you duplicate a 
node, it does not automatically connect itself to the Composite node of your scene.

 l From the Xsheet menu, select Columns > Duplicate Selected Layers.

 l From the top menu, select Edit > Duplicate.

The duplicated layer appears.

NOTE: 
By default, when you select a node in the Node view and perform a copy/paste using Ctrl + C and Ctrl + V 
(Windows/Linux) or ⌘  + C and  ⌘  + V (Mac OS X), this creates a CLONE not a duplicate.  Nodes will be 
linked to the same drawings.  Pegs will be linked to the same function columns.

To duplicate a layer in the Node view using keyboard shortcuts, press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X) and Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) for Paste Special, and in the Advanced tab, 
select Nodes: Create New Columns.
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About Timeline View Modes
The View Modes  button lets you streamline the process of working with elements in the Timeline view. There are 
three different view modes you can choose to work in. With each mode you select, certain elements may or may not 
be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding elements when you 
want to focus on specific ones. To select a view mode, use the drop-down menu in the bottom-left corner of the 
Timeline view.

 Normal View Mode

Normal View  mode is the default Timeline view mode. It shows everything connected to the chosen display. In 
this mode, anything not connected to the currently set default display will not be shown in the Timeline view. This 
also means that you cannot add certain elements to the Timeline view, as by default, when added they are not 
connected to any display or composite node. An example of such an element is a peg.

NOTE: If you prefer to work as you did before, where you see everything in the Timeline whether it is connected 
to a Display or not, you can change the Always Display Unconnected Nodes setting in the Preferences dialog 
box, Timeline tab.

Selection Only Mode

When working in Selection Only  mode, only elements currently selected in the Camera or Node view will be 
visible in the Timeline. This makes it easier to concentrate on one or a few elements at a time.

View Tagged Layers

The View Tagged Nodes   mode lets 

you see only elements which have been assigned a Tagged status. An item that has been tagged will appear in the 
Timeline view with a small asterisk beside its name.
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Once your elements are tagged and you have switched over to View Tagged Layers mode, the Timeline view will 
display only tagged elements. The red bar on the left of the layers indicates you are in this view mode.

While in this mode, the asterisks are not displayed beside the tagged elements.
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Tagging Layers
You can tag layers to easily visualize them in the Timeline view.

How to tag or untag elements in the Camera view

 1. In the Camera view, select one or more elements.

 2. Right-click and select Tag or Untag.

How to tag or untag elements in the Timeline or Node view

 1. In the Timeline or Node view, select one or more elements.

 2. Do one of the following:

 l Right-click and select Tag and one of the following: 

 l In the Timeline or Node view menu, select Edit > Tag and one of the following: 

 l Timeline Tag: Tags selected elements in the Timeline or Node views.

 l Timeline Untag: Untags selected layer in the Timeline view.

 l Timeline Untag All: Untags all tagged elements.

 l Timeline Untag All Others: Untags all elements except the selected one.
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About Nodes
The Node view uses a visual set of connections (nodes) to show how each element in the scene is connected 
and brought to the final image. It allows you to add extra elements and effects, and to move beyond the 
possibilities offered by the Timeline and Xsheet views. Each node corresponds to a layer in the Timeline view. 
Very few nodes are only visible in the Node view.

The basic rules of the Node view are quite simple. Once you understand them, a lot can be accomplished.

Each node used to build a node system is available in the Node Library view as well as through the Insert menu in 
the Node view. In addition, each time you create a layer from the Timeline or Xsheet views, the corresponding 
node is created in the Node view.

Each element in the Node view is called a node. There are several different types of nodes: 

This is an example of an average node, a simple drawing node that represents a layer in the Timeline view. This 
node has an input port (top) that allows information to flow through it. It has an output port (bottom) that exports its 
information in a downward flow. On the left is a yellow button that displays the node's property editor, where you 
can adjust its parameters. Lastly, there is an arrow that displays a thumbnail of the node's contents at the current 
frame. 
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This is an example of a simple effect node taking a single image input and outputting a processed (blurred in this 
case) image.

Node Description

Drawing Transfers drawing information.

Effect Processes effects on drawings and transfers drawing information.

Input/Output Acts as the interface between each node and node system.

Transformation Controls the camera and element transformations over time.

Composite Combines multiple source images.
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About Input and Output Ports 
T-HFND-010-005

Each node has an input port at the top and an output port at the bottom. Some are blue and others are light-green 
or bright green. 

Blue indicates drawing information.

Light green indicates position and movement (transformation).

Bright green shows the element on top of the composition and outputs that element’s Z position to the Composite 
node. When many elements have different Z positions (multiplane, different distances from the camera) and are 
placed through a Composite node that flattens them together (producing one image with one Z value), the system 
needs to give a Z position to this new image. It uses the bright green port information.

Finally, some nodes contain more than one input port. These are usually effect nodes needing different drawing or 
position information in order to perform their calculation. When the two ports are blue, the Drawing is on the right 
and the Matte is on the left. If it's light-green, the drawing needs extra position information.

A matte, also called mask, is the shape that will be used by the effect node to modify the original image (left input 
port). The effect will only be applied where the matte overlaps the original image. Sometimes the matte will act as 
a negative shape that the effect will exclude. This all depends on the nature and editing properties of the effect.

Some effects contain three input ports. If they are green, then they require a transformation (Peg, Quadmap, 
Quake, etc.) connection (coordinate and value information).
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Both the Write and Display nodes do not have output ports. This is because the information that flows into them can 
go no further in the node system. The Write node records the images and renders the final output. The Display node 
captures the visual information and outputs it to the Camera, Perspective, Top, Side and Timeline views.

If you are unsure of the type of connection required for a node, you can click on the port itself and the port type will be 
displayed.

On each port is a tooltip which displays the source of input ports and the destination(s) of the output ports (node 
names).
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Displaying Port Tooltips
You can display any port tooltips by clicking on a port or connecting a cable.

How to display a port's tooltip

 1. In the Node view, hover the pointer over a port.

The port's tooltip displays source and destination information. 

 2. Click on any port to display the port type label. The label will also display as you connect cables into ports.
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About Composite Nodes
The Composite node allows you to use several images and output a single image. You can compare that to doing 
pre-compositions in editing software. You can connect several drawing, image generators and effect nodes in your 
Composite node and one bitmap (or vector in some cases) comes out of it. 

Refer to the following example to connect this node.

By default, the image resulting from the Composite node is a bitmap. The layers are composited together depending 
on their position on the Z-axis (forward-backward) first, then their order in the Composite node. If two images are at 
the same position on the Z-axis, their order in the Composite will determine which one is displayed in front and which 
one is displayed behind.
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About Peg Nodes
The Peg nodes control the transformation of elements (position, scale, skewing and rotation) over time. The green 
ports at the top and bottom of the node indicate that it accepts transformation information which can be passed on 
(inputs and outputs transformation information).

One peg can be used to control many different nodes or one node can accept more than one peg. In a situation 
like the latter, one peg might be used to modify the rotation, while the other is used to modify the position of the 
effect and then animated differently over time. 
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Adding Nodes
Each node used to build a node system is available in the Node Library view as well as through the Insert menu in 
the Node view

How to add nodes from the Node Library

Do any of the following:

 l In the Node Library, select a node and drag it to the Node view.

 l In the Node Library, select a node and press Enter/Return to add it to the Node view.

How to add nodes using the Insert menu

 1. Anywhere in the Node view, right-click and select Insert > the desired category > the desired node. The 
categories are the same as in the Node Library view.

 l In the Node View menu, you can also select Insert > Effects > the desired category > the 
desired node.

The new node appear at the center of the visible Node view area.
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Connecting and Disconnecting Nodes
You can connect nodes by dragging cables from output ports to input ports. You can disconnect nodes by pulling 
on the cable connections.

How to connect nodes

 1. In the Node view, do one of the following: 

 l Extend a cable from the first node’s output port (bottom port) and connect it to the second 
node’s input port (top port). 

 l Select the node to connect, hold down the Alt key and drag the node on an existing cable.

It is possible to create links between nodes in the Node view by clicking on one node and Ctrl-clicking 
(Windows) or ⌘-clicking (Mac OS X) on a second port.

Select a node and Ctrl-click (Windows) or ⌘-click (Mac OS X) a port:

 l Click a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input port of a different 
node. The nodes are linked.

 l Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a dif-
ferent node. The nodes are linked.

 l Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a Com-
posite node. The node is linked to a new input port of the Composite.

 l Click a port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) port of a 
Composite node. The selected port replaces the link in the Composite's input port.

 l Click an output port of a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input 
port of a Group node. The selected output port replaces the link to the group.

 l Click an output port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) 
the input port of a Group node. The selected output port links to a new in-port of the group.

NOTE: You can reconnect a node's output port without disconnecting its destination port by dragging the con-
nect from the output port to another output port while holding Ctrl (Windows/Linux) or ⌘  (Mac OS X).
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How to disconnect nodes

 1. In the Node view, select the node to disconnect, hold down the Alt key and drag the node away. You can also 
pull on the connection cable.
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Spreading Nodes
When you are working in the Node view and adding many nodes, your scene may look a bit messy and be difficult 
to follow.  Harmony provides scripts which organize and display the nodes in a more orderly fashion.

How to spread the node system

 1. In the Node view, select some or all of your nodes.

 2. Display the Node View toolbar by selecting Window > Toolbars > Node View.

 3. Click the Order Node View Up  or Order Node View Down  button. 

The Order Node View Settings dialog box opens.

 

 4. Set values for the X Overlap%, Layer Spacing and Vertical Spacing. The default value is set for optimal 
organization.

 5. Click OK.
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Enabling and Disabling Nodes
As with the Timeline layers, you can turn the Node view nodes on or off. When you turn off a node in the Node view, 
its corresponding layer in the Timeline and Xsheet views is also turned off. Nodes that are turned off are displayed in 
red.

How to disable nodes

 1. In the Node view, select the node(s) you want to enable.

 2. In the Node View menu, select Nodes > Disable or press D.

How to disable all other nodes

 1. In the Node view, select the node(s) to remain enabled.

 2. In the Node view menu, select Nodes > Disable All Others.

All nodes are disabled except for those selected. This  operation only affects the current level layers. It does 
not affect the nested nodes within a group.

How to enable nodes

 1. In the Node view, select the disabled node(s) you want to enable.
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 2. In the Node View menu, select Nodes > Enable or press A. This keyboard shortcut is also valid in the 
Timeline view.

How to enable all nodes

 1. In the Node View menu, select Nodes > Enable All.
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Navigating the Node View
You can navigate to the parent or child node of the selected node or selected cable in the Node view. 

The Navigator is a small square window inside the Node view that displays a bird's eye view of the network. The 
view displayed in the Node view is shown framed in the Navigator display. You can drag this frame to pan the 
current Node view display.

When your networks grows more complex, you can pan the Node view to locate and work on specific nodes.

How to navigate the Node view

 1. In the Node view, select a node or cable, and press the Ctrl + Up Arrow/Down Arrow arrows (Windows) or ⌘ 
+ Up Arrow/Down Arrow arrows (Mac OS X).

How to display all nodes

 1. From the Node View menu, select View > Show All Nodes or press Shift + comma (,).

How to show or hide the navigator, do one of the following

 l In the Node view menu, select View > Navigator > Hide Navigator or Show Navigator. 

 l Press Ctrl + Shift + W (Windows/Linux) or ⌘  + Shift + W (Mac OS X).
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How to position the navigator

 l In the Node view menu, select View > Navigator > and select Top Left, Top Right, Bottom Left, or Bot-
tom Right.

How to magnify the Node view

 1. In the Node view, hold down Z. 

A black outline surrounds the area you were at before pressing Z.

 2. Change the magnification level of the magnifier by rolling the mouse wheel. You can also pan your mouse 
to move around the magnified area.

 3. When satified with the magnified area's position, click inside the magnified area to set it as your new view 
point.

How to pan the Node view

 1. Select a node, press Spacebar and drag to a new location.
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Displaying Node Thumbnails 
In the Node view, some nodes have a thumbnail option, identified by an arrow next to the properties button (square 
yellow button). Thumbnails can be very useful when navigating the network to easily identify the content of each 
node or analyze the flow of images and effects.

How to display a node’s thumbnail

 1. In the Node view, click on the arrow in the node.

The thumbnail opens.

If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to generate 
them.

How to show thumbnails of selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to display. 

 2. In the Node View menu, select View > Show Selected Thumbnails or press T.
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If no thumbnail appears, click the Render View  button in the Camera view (bottom toolbar) to generate 
them.

How to hide a node’s thumbnail

 1. In the Node view, click the arrow in the node.

The thumbnail closes and the node returns to its closed state.

How to hide thumbnails for the selected nodes

 1. In the Node view, select the node(s) whose thumbnails you want to hide. 

 2. In the Node View menu, select View > Hide Selected Thumbnails or press T. 
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How to hide all nodes thumbnails

 1. In the Network View menu, select View > Hide All Thumbnails.

1073



Chapter 15: Staging     About Nodes

Changing Cable Styles
You can customize the look of the cables in the Node view to fit your style of working. You can display the cable 
lines as Bezier (curved) lines or straight lines.

How to change cable styles

 l In the Node View menu, select View > Cable Style > Bezier or Line.
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About Groups
With so many connections and nodes possible, the Timeline and Node views can quickly become crowded. Keep 
things organized by grouping your nodes.

You can create a simple group or a group with a Composite node. There are several advantages to using the Group 
Selection With Composite command over the simple Group Selection (which references both the Group layer in the 
Timeline view and the Group node in the Node view.

One of the advantages of using this command is that it groups all the selected elements into a neat node that has a 
nested composite. This means there is only one connection coming out of the Group node. With the simple Group 
node or command, the Group displays the same number of connections as elements in the group. Both grouping 
commands display the same structure in the Timeline view.

The Group Selection With Composite command should only be used before any work has been done in the Node 
view and is recommended for objects whose stacking order is of no consequence.
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Using the Group Selection from Composite command on elements that have effects, have been tweaked in the 
Node view, or whose stacking order is of consequence, may cause the grouped elements to lose their properties 
once grouped in this way. In addition, though you may only select a few nodes to group, if there are other layers in 
the Timeline view that exist between the selected layers, they will automatically be grouped, even if not selected.

Using the Move to Parent Group command allows you to move the selected node to the parent level, maintaining 
all connections.  If the operation cannot maintain the connections between the nodes, you will be notified and the 
operation will be terminated.

To quickly access parameters for nodes that are grouped, you can use the Publish Attribute Mode feature to 
select your most common parameters to modify and make them appear in the group Layer Properties editor. This 
way, you can access them directly without having to enter the group every time.
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Grouping Nodes 
You can group your nodes to keep your work organized.

How to group nodes

 1. In the Node view, drag a selection around the nodes you want to group.

 2. In the Node menu, do one of the following:

 l Select Edit > Group > Group Selected Layers.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X).

You can also right-click in the Node view and select one of the following:

 l Group > Group Selection With Composite or press Ctrl +Shift + G (Windows/Linux) or ⌘  + 
Shift + G (Mac OS X).

 l Group > Group Selection or press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X)

The selected nodes are grouped.

NOTE: 
To ensure that you have a Multi-Port Out node in your group and that your group remains connected, include a 
Composite node in your selection and make sure it is connected to the main Composite node of the scene 
before grouping.

1077



Chapter 15: Staging     About Groups

Grouping Layers
You can group your elements to keep your work organized.

How to group elements in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

Any layers between the selected layers will be automatically grouped as well, so if the stacking order does 
not matter, move extra layers above or below the layers want to group. 

 2. Do one of the followings: 

 l Right-click on the highlighted layers and select Group Selection With Composite. 

 l Right-click on the highlighted layers and select Group Selection.

 l From the top menu, select Edit > Group > Group Selected Layers.

The layers appear indented under a new Group layer in the Timeline view and in a new Group node in the 
Node view. 
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Ungrouping Nodes 
You can ungroup groups of nodes.

How to ungroup a group of nodes

 1. In the Node view, select the group you want to ungroup.

 2. In the Node menu, select Edit > Group > Ungroup.

The selected group is ungrouped.
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Entering Groups
You can enter groups to see their content.

How to enter a group node

 1. In the Node view, click the arrow on the right side of the group node you want to enter.

 l Inside the group node, the Multi-Port In and Multi-Port Out nodes ensure that your connections continue 
beyond the group.
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Exiting Groups
You can exit groups and return to the complete node system.

How to exit a group node

 1. In the Node view, click the destination in the Group Hierarchy menu. You can also select Nodes > Exit 
Group from the Node menu.

‣ You can click on the top blue arrow in the Node view to exit the current group.

‣ When you enter a group, the Group Hierarchy menu displays the path to where you are. In this example, 
we are inside the group named Deform_Bob. To exit this group, click Top at the bottom-left corner of the 
Node view.
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Moving Up Group Levels 
In a node system, there can be nested groups (a group in a group). You can easily move up the nested hierarchy.

How to move up a level in a group

 l Click the arrow at the top of the Node view.
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Moving Nodes to Parent Group
You can select nodes within a group and move them out to the parent group.

How to move  selected nodes to the parent group

 1. In the Node view, go inside the group and select the nodes you want to move up to the parent group level.

 2. From the Node menu, select Nodes > Move to Parent Group or press Ctrl + Shift + U (Windows/Linux) or 
⌘  + Shift + U (Mac OS X).

The selected nodes are moved to the parent group level.
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Publishing Attributes
To quickly access parameters for nodes that are grouped, you can use the Publish Attribute Mode feature to 
select your most common parameters to modify and make them appear in the group Layer Properties editor. This 
way, you can access them directly without having to enter the group every time.

How to use the Publish Attribute mode

 1. From the Node menu, select View > Publish Attribute Mode.

 2. In the Node view, enter the group containing the nodes you want to promote.

 3. Select the node whose attributes you want to publish.

 4. In the Layer Properties view, enable or disable the publishing options for the different parameters. You can 
easily distinguish them as they are labeled in red.

 5. Repeat the previous step for all the nodes that contain attributes you want to publish.
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 6. In the Node view, exit the group.

 7. Select the Group node.

In the Layer Properties view, you can see all published attributes. The different nodes are tabbed for easy 
access and organization.
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About Displays
The Display node is an important node; it is used by the export and views to display your scene, primarily the 
Camera and Timeline views. By default, a scene's node system always has a Display node which can be used to 
show your entire scene, a single node or a group of nodes through a Composite or Group node. You might use it to 
see one single character as you animate it, debug your node system as you create complex effects or export your 
complete scene or a portion of it. 

You can have more than one Display node in the Node view, so you can visualize different sections of the scene 
without disabling or disconnecting elements that are in the way. This is useful in cut-out animation as it allows 
you to see one puppet without viewing all the other characters. It's also useful during compositing and helps you 
visualize and debug effects.

To use this display concept, show the Display toolbar which will let you select different Display nodes available in 
the node system. 

You can also use the Scene > Display menu to select the desired Display node to update the contents of the 
Camera, Top, Side, Perspective, and Timeline views.
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When your scene does not have a Display node, it is automatically set to Display All which uses the Timeline view 
ordering and shows floating nodes from the Node view. You can also set your scene to use Display All using the 
Display toolbar.

NOTE: If you try to add a peg or other transformation layer in the Timeline view without having a layer selected, 
an error message will display. Make sure to change to Display All. The peg layer will be floating in the Node 
view and will not be visible in the Timeline view.  The Timeline view shows only layers that are connected to the 
Composite node.

If you switch to Display All, you run the risk of not realizing when you have floating nodes that are not connected 
to your composite.  For this reason, it is not recommended to work in Display All mode.

When your scene contains many nodes and you cannot see them all, you can display all nodes at that level.

Harmony has two display modes. By default, it is set to the Basic Display mode.

When creating a scene in Basic Display mode, a Display node is automatically added to the node system and 
connected to the final Composite node. All of the views are set to use this Display node. This means that only the 
elements connected in that Composite node will show in the Camera view. 

You can add and connect more Display nodes to your node system and select the one you want by using the 
Display menu. In Basic mode, every view is set to the same Display node.

In Advanced Display mode, every view using the display concept has its own Display menu and each one can be 
set to a different Display node. To switch from Basic to Advanced Display mode, you must enable the Advanced 
Display option in the Preferences dialog box (Advanced tab). These Display menus allow you to set the views to 
different displays. By default, all views are set to Default to follow the main Display toolbar selection. However, you 
may want different views set on different displays. For example, you can have one Camera view to display the full 
scene and another Camera view to only display the character being animated. In this case, you can set the first 
Camera view on the final display and the second on the character’s Display node.
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If you want the views to follow the main Display toolbar selection, set the display option of each display menu to 
Default.
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Adding Display Nodes
To display different portions of your scene, you need to add several Display node to your project.

How to add a Display node

 1. Do one of the followings:

 l In the Node view, press Ctrl + Y (Windows/Linux) or  ⌘  + Y (Mac OS X).

 l In the Node menu, select Insert > Display.

 l In the Node view, right-click and select Insert > Output > Display.

 l In the Node Library view, in the Output category, select a Display node and drag it to the Node 
view.
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Changing Global Displays
Using the Display toolbar, you can change the global display. All views responding to a display output will update 
to your new selection.

How to set a different Display node as a global display

 1. Do one of the following:
 l In the Display toolbar drop-down, select a display.

 l From the top menu, select Scene > Default Display and select a display.

Each view is updated if set to the Default display option.

1090



Harmony 14 Premium - User Guide

Setting Advanced Display Options
You can set your views to show different display outputs simultaneously with the Advanced Display option.

How to enable the Advanced Display option

 1. Do one of the following:

‣ From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Premium > Preferences 
(Mac OS X). 

‣ Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. In the Preferences dialog box, select the Advanced tab. 

 3. In the Advanced Options section, select the Advanced Display option.

A Display menu appears in the top-left corner of the Camera, Timeline, Perspective, Top, and Side views.
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Setting Properties for Many Layers
When working with several layers, you may frequently want to modify a series of settings. Instead of opening the 
properties for each individual layer, you can set the properties for many layers so you can change a common 
setting in a single click. 

This allows you to modify the following settings:

 l 3D Path or Separate mode

 l Use Embedded Pivot

 l Overlay

 l Line Art

 l Colour Art

 l Underlay

 l Animate Using Animation Tools

NOTE: You can access this function in the Node View toolbar. You can add the button to the Timeline View 
toolbar through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script section 
under the name Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_many_layers.js.

How to set properties for many layers

 1. In the Node or Timeline view, select all the layers you want to modify at the same time.

 2. In the Node or Timeline View toolbar, click the Set Properties for Many Layers button. This option is not 
available by default in the Timeline View toolbar. You must add it through the Customize option. Right-
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click on the toolbar and select Customize. In the Available Tools list, select Script: TB_Set_Properties_on_
many_layers and move it to the Toolbar list.

The Set Properties for Many Layers dialog box opens.

 3. Modify the properties. If your nodes have different parameters enabled for a certain setting, leave the As Is 
option selected to avoid modifying it. Each node will keep its original setting. Select any other options for all 
nodes to change to this parameter regardless of their original setting.

 4. Click OK.
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Chapter 16: 3D Space
Harmony is well known for its multiplane space where you can move your layers forward and backward on the Z-
axis. Harmony brings you a true three-dimensional space where you can actually rotate your camera and layers on 
all axes. This lets you perform a 360 degree rotation around elements, create a floor and even build sets! 

NOTE: If you are using 3D rotations in your animation, do not render your project as a SWF as these para-
meters are not supported by that format.
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Enabling the 3D Option
Before you can rotate layers in three axes instead of two, you must enable the 3D option in the layer properties. 
By default, when you create layers in Harmony, you can only move them as flat layers.    

How to enable the 3D option

 1. In the Timeline view, select the layer you want to move in 3D space.

 2. In the Layer Properties view select the Transformation tab.

 3. Select the Enable 3D option to display the 3D parameters for that layer.
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New parameters appear in the Layer Properties window.
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About 3D Parameters
When working in 3D, notice that three sets of parameters are modified: scale, rotation, pivot.
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About the 3D Scale Parameter
When using 3D, the Z-axis parameter appears in the list of settings. You can have the Scale locked or separated. 
When the Scale is locked, the object you are scaling is uniformly resized in three directions. When the Scale is 
separated, the object you are scaling can be squashed and stretched in any direction without affecting the other 
ones.

 

NOTE: You cannot add thickness to an object by scaling it in the third dimension. Three-dimensional scaling is 
used to scale objects that were rotated on their axes or to scale a group of objects laid out in three dimensions.

1099



Chapter 16: 3D Space     About 3D Parameters

About the 3D  Rotation Parameter
The main parameter you will use when working in three-dimensions is rotation. Without using 3D rotation, you are 
simply working using the multiplane technique.

3D rotation can be used in two different ways:

Quaternion Rotation

Quaternion Rotation is very similar to the 3D path position parameters. A Quaternion is composed of three 
rotation functions: X, Y and Z to control the rotation on three axes, and a velocity function to control the velocity of 
the three rotation functions simultaneously. 

The X, Y and Z functions are linked. When you add a keyframe on one of them, it also adds it to the two others.

If you are planning to animate an element such as the camera, you should use the Quaternion rotation rather than 
Euler Angles. Quaternion creates a smooth trajectory and interpolation since the path is controlled by the same 
keyframes and a single velocity.

Euler Angles Rotation

The Euler Angles Rotation is very similar to the Separate position parameters. The Euler Angles parameter is 
composed of three functions: X, Y and Z to control the rotation on three axes. These three functions are 
independent of each other; each has its own velocity.

When you add a keyframe on one function, the other ones do not receive it, allowing you to control each axis 
independently.
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Euler Angles are mainly used to position elements with exact coordinates and rotate elements on a single axis. The 
interpolation between the keyframes will not be as smooth as the Quaternion one since each function works 
individually.
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About the 3D  Pivot Parameter
When working in 3D, the drawing or layer pivot becomes a location that can move on three axes. When you work 
in two dimensions, the pivot is mainly an anchor point somewhere in the drawing from where the transformations 
will be performed. In 3D, the transformations are made on three axes, so the centre of rotation and scaling also 
becomes three-dimensional.

 

By default, the pivot is positioned at the centre of the stage: (0,0,0). When you use the Pivot  tool to reposition 
the centre of transformation, the pivot position is changed on the X and Y axes, but the Z-axis remains at zero 
until you change it in the Top, Side or Perspective view using the transformation tools.
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About 3D Tools
Once the 3D option is enabled, your transformation tools become 3D transformation tools. These tools are found in 
the Advanced Animation toolbar as well as the Transform  tool. Instead of letting you move elements only on the 
X and Y axes, you can also manipulate them on the Z-axis.
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About the 3D Translate Tool
Once you enable the 3D option, the 3D Translate  tool becomes available and you will see direction arrows 
appear around the pivot points to indicate the different axes.

You can click on the direction arrows to move your layer on only one axis. If you click anywhere else, the layer 
can move freely on two axes at once. Once the arrow is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may 
not have the optimum point of view on your stage to understand the setup. In this case, it is best to use the 
direction arrows.
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About the 3D Rotate Tool
Once you enable the 3D option, the 3D Rotate  tool becomes available and you will see a rotation sphere appear 
around the pivot points indicating the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at once. Once the ellipse is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may 
not have the optimum point of view on your stage to understand the setup. In this case, it is best to use the dir-
ection ellipses.
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About the 3D Scale Tool
Once you enable the 3D option, the 3D Scale  tool is available. You will see one of two things:

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the 
different axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the object 
proportionally. Once the control point is selected, it will turn pink.

NOTE: If you move the layers in the Perspective view, it may be difficult to control the motion since you may 
not have the optimum point of view on your stage to understand the setup.
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About the 3D Transform Tool
Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D 
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Translate tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate tool.

To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.
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About 3D Space Positioning
To position elements in 3D space, you need to understand what you want to build and what is involved in building it.

Simple sets like the one above are easy to build, light to manage and probably what you will use 3D staging for most 
often.

If you have a project based on a room, it can be useful to build it in 3D. This saves you from having to redraw the 
background for each scene and it will be entirely vector based.

Here, you can see some of the different backgrounds you can get in only three seconds from this set.
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About Planning
When you are building a room, there are only a few pieces to prepare. Before starting to build your set, map out 
the parts you need.

A complex set that is more intricate in its design will require more careful planning. Not only will you have to list 
the pieces you need, but you will also have to think about what can be reused. If you have a series of windows in 
your set, you would create a symbol from the drawing, rather than copy paste it several times all over your set. 
This way, if you need to make any correction to its design, you will only need to do it once and all the instances of 
your symbol throughout your set will be corrected. The same can be done with for each piece of your set.

Here is an example of all the source drawings required to build the castle. 

These are the only drawings required to build the entire castle. As you can see, there are not that many 
considering the final result. The rest is constructed by assembling symbols and through reuse. However, keep in 
mind that although you are using simple drawings and symbols to optimize your set, the more you add to your 
project, the heavier the toll it takes on your machine's RAM. While the scene's package itself is really light, 
running the scene places heavy demands on your RAM and video card.

Using the drawings shown previously, here are a couple of pieces that were put together.
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Here is the final result. A large and impressive fortress.
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About Maximizing Efficiency
When your main set is built, you will want to store it in the Library. It is important to know that when you import 
such a large structure in one of your production scenes, the set may be slow to run. To avoid long rendering 
sessions or slow manipulation, remove all faces and planes that are not visible in your scene.
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Positioning Layers in 3D Space
Once your drawings and symbols are assembled, it is time to position them. This section explains how this is done 
using the example of a simple room.

How to position layers in 3D space

 1. Next to the Camera and Drawing view tabs, click on the Add View button and select Perspective.

The Perspective view appears in the same section of your workspace as your Camera and Drawing views. 
This view allows you to view your scene from any angle and point of view, rather than from your Camera's 
point of view. In this view, the usual navigation keyboard shortcuts work the same, but you can also press 
Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X) to rotate the view in any angle and on any axis

 2. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

 3. In the Transformation tab, select the Enable 3D option.

 4. In the Rotation section, select the Euler Angles option.

 5. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.
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 6. To position the height of the floor, type values in the Position section of the Layer Properties, use the Trans-
late  tool or Transform  tool.

 7. Repeat the process for the other pieces to position.

 8. If you have parallel walls, once you have positioned one, select the Wall layer in the Timeline view.

 9. Do one of the following to duplicated the layer.

 l From the top menu, select Edit > Duplicate.

 l Right-click and select Edit > Duplicate.

 10. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use the 
Translate or Transform tool. If you want to position your layer visually, consider using the Camera, Top or 
Side view so as to be able to position it with precision.
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 11. If your walls are touching each other, you should make them intersect by extending one end of the wall 
through the other wall. This prevents seeing a small gap between them.

Now have a complete 3D room.

NOTE: The Transform tool as well as the Advanced Animation tool can be used with 3D layers as with 2D lay-
ers. The Transform tool allows you to reposition, rotate and scale 3D layers on any axis, but does not allow you 
to skew 3D layers. You can use these tools on 3D layers in the Camera, Perspective, Top and Side views. 
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Using the Depth View Mode
The Depth View mode can come in handy when positioning 3D models, creating multiplane backgrounds and  
building sets in 3D space.

How to use the Depth view

 1. In the Node view, open your Layer Properties of your composite by clicking on the yellow box.

 2. In the Layer Properties window, set the Input Ordering to 3D.

 3. In the Camera view, click on the Render View mode  button and from the menu, select Depth View 
mode.

The image of your scene changes from full colour to various shades of black, white and grey.

 4. The Depth View mode displays images in a relative white to black gradient scale. The object(s) closest to 
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the camera are displayed in white and the object(s) furthest from the camera are displayed in black. If the 
position of the last object changes along the z-axis, that object will still remain black, so long as it retains its 
position as the object the farthest back. It does not matter where that object is in 3D space, it just matters 
what its position is relative to the other object in the same space. The objects closest and farthest from the 
camera set the range of the white to black scale. All the other objects fall somewhere in between.

 5. In the Timeline or Node view, disable elements that you don't need, in order to work better with the elements 
that you would like to reposition. In the example below, the background elements have been disabled so that 
repositioning elements in the room can be done more precisely. 

As you can see, the same elements in the Depth View mode are now displayed differently, because their 
relative positions have changed. Without the background present, the corner of the room becomes the 
element that is the furthest back, while the right part of the right wall is the element that is the closest and is 
therefore displayed in white.

Deep blue signifies infinity. The space around elements goes on forever and therefore does not fall into the 
white to black scale.

 6. In the Camera, Top, Side or Perspective views, use the Transform tool or any of the Advanced Animation 
tools (Translate, Rotate, Scale, etc.) to reposition elements in your scene, using the Camera's Depth View 
mode to verify your adjustments as you make them.
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About 3D Input Output Options
In Harmony, you can create very advanced networks using effects, complex connections and multiple-level 
compositing.

The Composite node's main task takes all of your image's output and converts it into a single flat image that you 
can render out. You can alter it further by manipulating a three-dimensional scene setup. You can also modify a 
Composite's behaviour as seen in the Staging on page 1009 chapter. 

The default options combination is:

 l As Bitmap, for the output behaviour

 l 3D flat, for the input ordering

By default, a Composite node is set to output a flat bitmap image and to correctly composite elements positioned 
in 3D space.

For example, if you have two intersecting walls, and use the default combination, you will see the following result:
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This image is correctly represented in the Camera view and is output from the Composite node as a flat drawing. 
The Z-axis value of your elements are not retained, it becomes an independent composition with only one forward-
backward value.

NOTE: When building a 3D set out of planes, it is recommended that you set the composite mode to As Seam-
less Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.

3D Input Ordering Option

The visual result for the 3D Input Ordering option is the same as the 3D Flat option. The visual result in the Camera 
view will be correct, but the elements will not be converted into a flat image. The 3D position of your images will be 
remembered until the next Composite node. This mode is quite advanced and should only be used in very advanced 
cases. Most of the time you will use the 3D Flat Input ordering option.

2D Input Ordering Option

If you switch the Input Ordering option to 2D, the walls will be calculated as flat 2D objects and not as 3D objects. 
The perspective caused by the 3D rotation will be correctly represented, but the elements will not intersect. The 
result will be similar to the following:
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About 3D Composite Nodes
If you start combining several composite nodes in your Node view, it is important to understand how they work if 
you want to get the desired result.

There is a specific order in which you should set your Composite nodes. Each time you process images through a 
3D Flat Composite node, the images will be merged together. Images processed in later Composite nodes cannot 
be inserted between images of the previous composite since it is a flat image.

If you used Pass-Through type Composite nodes in your network, the images will not be processed together 
before the final Composite. It is important to keep your final Composite as a 3D Flat Composite in order to read 
the layer ordering correctly.

The most efficient networking system for obtaining the desired result is likely  the Pass-Through composite mode 
throughout the whole network. This way, you can create individual compositions to keep your network clean and 
organized, but process everything together at the end.
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NOTE: When building a 3D set out of planes, it is recommended that you set the composite mode to As Seam-
less Bitmap. This avoids intersection issues when rendering the 3D objects created out of planes.
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Chapter 17: 2D-3D Integration
Harmony provides you with impressive 2D-3D integration possibilities. This allows you to combine the two 
animation genres within the same production, resulting in some remarkable scene composition and a unique style.

Harmony supports the following 3D formats:

• FBX

• 3DS

• OBJ

• OSB

• Alembic (*.abc)

• Collada (*.dae)

You can work with Autodesk Maya, PIXIE, or 3Delight. In this guide, Autodesk Maya will be used. To work with 
Pixie or 3Delight, contact store.toonboom.com/contact/support.
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About Reference Model
When working in Harmony, the first thing to do is import a reference model. This model is what will be represented 
in the Camera view OpenGL mode.  Animators can reposition this model, animate the camera, and interact with it.  
Although several formats are supported, FBX (*.fbx) is the recommended format as this will allow you to embed 
textures for nicer looking reference models.

NOTE: When exporting an *.fbx from the FBX plug-in in Maya, choose the format 2014/2015, even if you are 
running a higher version of Maya.

Other supported formats are  Alembic (*.abc), (*.osb), Autodesk 3ds Max (*.3ds), Object (*.obj), and Collada 
(*.dae). The support of the Collada format enables artists using SketchUp to export to Harmony without the need 
to use SketchUp Pro.

Harmony offers options to convert  the 3D files directly to FBX (*.fbx) files and save them so that the next time 
you reload the scene it doesn’t have reconvert them.

When importing an FBX (*.fbx) model, remember that model will never be used for the final render.  Harmony itself 
does not have a 3D rendering engine embedded.  

Rendering of the OpenGL representation of the model is supported. However, this is not a high enough quality for 
a final product. Instead, rendering is supported through outside rendering engines.  The majority of users use Maya 
Softrender, although 3Delight and Pixie are also supported. 

You can optimize the model quite a bit.  The imported FBX model does not require high-resolution textures or 
sophisticated shaders.  It can even have a lower poly count than your final model.  It does, however, need to be the 
same size as your final model, as Harmony will be sending the position, rotation, and scale information of the 
model in the Harmony scene to Maya later to render.  Keeping the imported FBX file as light as possible will give 
you snappy performance while animating. 
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About 3D Models in Harmony
When rendering, a connection is opened between Harmony and the render engine—in this case Maya Softrender.  

Maya Batch is opened in the background and the information from the Harmony scene file is sent to Maya.  All the 
information needed, including the animation on the model and the position of the camera, is sent to Maya.  Maya 
Batch then opens in the background and the original .mb file is opened.  This file should match the FBX model in size, 
but may have a higher polygon count, a more advanced texturing setup, or even a more advanced set of shaders.  
Since the full Maya scene is loaded, you can use any shader, lighting setup, and texture that Maya Softrender 
supports.   

The opened scene file repositions the model inside based on the information provided from the Harmony scene file.  
For consistent lighting effects, you may want to parent the lighting rig to the model so it is also repositioned along 
with the model.    

The frame is then rendered and sent back to Harmony to be composited there.  The data comes back into Harmony 
as a series of Maya *.iff images.  These images contain not just image data, but also depth information, and 
Harmony will use this depth information to properly clip any 2D layers that are interacting with the 3D model in the 
Harmony scene, resulting in a perfect composite without the need to track any masks. 

You can also apply any effects that are supported on bitmaps to the rendered sequence, such as blurs and blending 
modes.   
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About the 3D Graph View
Use the 3D Graph view to navigate the parts of a 3D model and to show and hide the parts from view. With the 
Transform tool selected, you can select a subnode from the list to see it appear highlighted in the Camera and 
Perspective views. Use the arrow keys to quickly scroll through the list.

The 3D Graph view also allows for the set-up of animating parts of the 3D model, as well as linking 2D drawings 
to the movements of a 3D model's parts.

NOTE: To learn more about the 3D Graph view, see the Reference guide .
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Enabling Subnodes
Enable disabled subnodes in the 3D graph list to display the corresponding parts of a 3D model in the Camera and 
Perspective views.

How to enable subnodes

 1. In the 3D Graph view, select a subnode or multiple subnode names displayed in red, (a red subnode name 
indicates that the subnode is disabled).

 2. Click on the 3D Graph view menu button and select Subnodes > Enable. 

OR

In the 3D Graph view toolbar, click on the Enable Subnode  button.

The subnodes are enabled. 

In the Camera or Perspective view the corresponding 3D model part is displayed.
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Disabling Subnodes
Disable subnodes in the 3D graph list to hide the corresponding parts of a 3D model in the Camera and 
Perspective views.

How to disable subnodes

 1. In the 3D Graph view, select a subnode or multiple subnodes.

 2. Click on the 3D Graph view menu button and select Subnodes > Disable. 

OR

In the 3D Graph view toolbar, click on the Enable Subnode button.

The subnodes are disabled as indicated by the display of their names in red. 

In the Camera or Perspective view the corresponding 3D model part is hidden.
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Making Subnodes Animatable
A typical 3D model is comprised of many parts (subnodes). Not all of these parts need to be animated; most are just 
used for display. However, if you would like to animate a specific part, such as the door of a spaceship sliding open, 
you need to create properties for that subnode—in this case the door.

Properties, also known as function columns, allow an object to be moved, rotated, scaled, etc. Subnodes with 
properties will appear in the Timeline view as a layer. You can then keyframe movements of any of the subnode's 
properties in the Timeline view.

There are two ways to make properties available to a subnode:

 l In the 3D Graph view

 l By moving the subnode in the Camera or Perspective view—see Animating Individual Parts of 3D Models

How to make properties available in the 3D Graph view

 1. In the 3D Graph view, select a subnode that you would like to animate.

 2. Click on the 3D Graph view menu button and select Insert > Make Properties Available. 

OR

In the 3D Graph view toolbar, click on the Make Properties Available  button.

The subnode appears in the Timeline view.

 3. In the Timeline view, expand the subnode layer to view its properties.
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Linking to 3D Movements
You  can link 2D drawing layers, pegs, other 3D models and more to follow the movements of a part of a 3D model. 
To do this, you need to add a 3D Kinematic Output node to your 3D model setup in the Node view. More specifically, 
you need to link the 3D Kinematic Output node to both a specific 3D model subnode (part) and to the object that you 
would like to follow that subnode.

How to automatically setup 3D Kinematic Output nodes with your system

 1. In either the Camera, Perspective or 3D Graph view, select the part of the 3D model whose movements you 
would like followed.

 

If you are going to make the selection in the Camera or Perspective view, be sure to have the Transform tool 
selected. Click on your 3D model once to select the whole object, then click again to select the individual 
part.
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 2. In the 3D Graph view, click on the 3D Graph view menu button and select Insert > 3D Kinematic Out-
put. 

OR

In the 3D Graph view toolbar, click on the Add 3D Kinematic Output  button.

In the Node view, a 3D Kinematic Output node is added to your system. It is automatically given the name 
of the subnode + -Output.

An asterisk appears beside the subnode name in the 3D Graph view list to indicate the connection of the 
3D Kinematic Output node.

 3. In the Node view, connect the top port of the object that you would like to follow to the bottom port of the 
3D Kinematic Output node. In this example, a 2D drawing layer (fire) is connected.
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Any transformations made to the 3D model subnode will now also be applied to the drawing.

How to setup 3D Kinematic Output nodes from the Node Library

 1. In the Node Library, in the left menu bar, click on 3D. 
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 2. Drag and drop the 3D Kinematic Output node from the Node Library into the Node view.

 3. Connect the 3D Kinematic Output node under the Subnode Animation node of your 3D model.

 4. In either the Camera, Perspective or 3D Graph view, select the part of the 3D model whose movements 
you would like followed.
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If you are going to make the selection in the Camera or Perspective view, be sure to have the Transform tool 
selected. Click on your 3D model once to select the whole object, then click again to select the individual 
part.

 5. In the 3D Graph view,  click on the 3D Graph view menu button and select Edit > Copy Subnode Name. 
If this menu item is disabled, you may need to click on the highlighted subnode from the 3D Graph list and 
then try again. This usually occurs if you made your subnode selection in the Camera or Perspective view, 
instead of the 3D Graph view.

 6. In the Node view, open the Layer Properties of the 3D Kinematic Output node (yellow square).

 7. Right-click in the Subnode Name field and from the right-click menu, select Paste. Now the 3D Kinematic 
Output node knows which part of the 3D model to read. 

 8. In the Name field, delete 3D-Kinematic from the node name, then paste again. 

The name of the 3D Kinematic Output node should now be the name of the subnode + -Output. It is good 
practice to rename your 3D Kinematic Output node this way, so you know which subnode your object is 
following. This is especially true if you plan to add multiple 3D Kinematic Output nodes to your system.

An asterisk appears beside the subnode name in the 3D graph list to indicate the connection of the 3D 
Kinematic Output node.

1135



Chapter 17: 2D-3D Integration     Linking to 3D Movements

 9. In the Node view, connect the top port of the object that you would like to follow to the bottom port of the 
3D Kinematic Output node. In this example, a 2D drawing layer (fire) is connected.

Any transformations made to the 3D model subnode will now also be applied to the drawing.

NOTE: By default, all parts of an imported 3D model are visible for display, but not setup for animation. To 
setup a part of a 3D model for animation—see Making Subnodes Animatable.
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Exporting 3D Objects
Once you set up Toon Boom Harmony and your system for the use of 3D, the next step is to generate the 3D models 
you plan to import and use in your scene. You can use Autodesk Maya for this. Although FBX models can be 
exported from any software and imported into Harmony,  Maya has a better integration with Harmony if you require 
software rendered, high-quality images in your pipeline.

How to export a 3D object for Harmony

1. In Autodesk Maya, create your 3D object.

You should also complete the texturing of your 3D object, as well as set up a few lights in your scene. When 
you render your scene later through Harmony, it will use this original Maya scene to render with the shaders, 
textures, and lighting of the scene.

NOTE: When you animate the object in Harmony, it will use this scene file and push the animation from Har-
mony into this scene. For this reason, you may want to parent the lights to the object, so the lighting you set up 
moves with the object when it is animated. If not, the object may be rotated out of the lighting, resulting in a very 
dark 3D object. In Maya, you can parent one layer to another by middle-mouse clicking and dragging that layer.

 1. Save your Maya binary file *.mb as you will use it later on.

 2. Use the export command to export your model. Select File > Export All.
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The Export All dialog box opens.

2. In the Files of Type menu, select FBX Export.  

3. Select the Embed Media option to see the textures on the model when you import the FBX model into 
Harmony.  

4. From the Type list, select Binary. 

5. From the Version list, select FBX 2015 or below.

When you complete the export, an *.fbx file will be created.
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Instructions may differ depending on the version of Autodesk Maya you are using. Therefore it is 
important to refer to the Maya documentation for the correct instructions on how to create and 
export a 3D model.
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Setting 3D Renderer Paths
When using 3D models in Harmony, Harmony needs to be able to find and communicate with Maya, who then 
communicates with the 3D Render software ( Maya, Mental Ray, Arnold or RenderMan) to make 3D objects 
appear with the correct textures and lighting in Harmony. For this to happen, you need to tell Harmony where 
Maya is installed on your computer.

In order for Harmony to read back RenderMan's *.dtex file format, Harmony needs to use the RenderMan library. 
This means that Harmony needs to know where RenderMan is installed, if that is the 3D Renderer that Maya is 
using. The other supported file formats (*.iff and *.exr) are not read in the same way and therefore do not need to 
have their paths set.

How to set 3D renderer paths

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l Right-click on the empty space near the top of the interface  and from the quick-access menu select-
ing Scripting.

 l Right-click on the empty space near the top of a view and from the quick-access menu selecting 
Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager window.

 3. In the Scripts Manager, in the Files section, select the file TB__Set_3dRenderer_Paths.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_Set_3dRenderer_Paths.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.
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The TB_Set_3dRenderer_Paths script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Scripting toolbar, click on the TB_Set_3dRenderer_Paths script  button.

The Set 3D Renderer Paths dialog box opens.

 9. Click on the browse button, beside the Maya Installation Path field and browse for the location on your com-
puter where Maya is installed.

 10. Click on Select Folder.

 11. If your 3D models from Maya are using the 3D renderer RenderMan, click on the browse button beside the 
RenderMan Installation Path field and browse for the location on your computer where RenderMan is 
installed.

 12. Click on Select Folder.

Harmony can now communicate with Maya and access the RenderMan library.
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Importing 3D Objects
Once you have exported a model using a 3D authoring software, you can import it into Harmony and integrate it to 
set up your 2D animation scene.

You have the possibility to convert your 3D models to the *.fbx format upon import to Harmony. This will allow 
Harmony to render 3D files with the associated textures without the need to copy over the textures manually (as 
long as the auxiliary files are linked correctly and named appropriately on your disk).

How to import 3D models

 1. In Harmony, select File > Import > 3D Models.

The Import 3D Models dialog box opens.

 2. Click Browse and locate your 3D model file. Only *.osb. *.3ds, *.obj, *.fbx, *.abc and *dae file formats are 
supported.

 3. Click Open to validate your choice and close the browsing window.

 4. In the Layer section, choose your import options.

 l Create Layer(s): This option is selected by default. A new layer will be created for the 
selected files for the import. You have two choices:
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Create Single Layer Named: Imports all your selected files in the same layer 
you can name.

Create Layer(s) Based on Filename: Creates a different layer for each file 
selected for import. The layers will be automatically named according to the file 
names.

 l Add to Existing Layer: Imports the selected files into an existing layer in the scene. Use the 
drop-down menu to select a layer. Note that if you add to an existing vector layer, it will encap-
sulate the 3D model inside a symbol.

 5. In the Conversion section, select the Convert to FBX format option if your file isn't already a *.fbx file and 
you would like it to be. This format incorporates all associated files, such as the texture files.

 6. Click OK  to validate your choices and import the selected file(s).

The 3D models are imported in the scene.
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About 3D Object Manipulation
Once you have imported the 3D model into your scene, you can easily manipulate it to set up your scene. You 
can even add keyframes, just like any other element, and animate it on a trajectory.

Using Peg Nodes to Control the Position of 3D Objects

You can use Peg nodes to control the position of 3D objects, and connect them as you would with 2D layers to 
create rigs. 

Using Transformation Tools to Manipulate 3D Models

Once the 3D option is enabled, your transformation tools automatically become 3D transformation tools. This 
means you can now manipulate them on the Z-axis as well. The Translate , Rotate  and Scale  tools 
are found in the Advanced Animation toolbars and the Transform  tool can be found in the Tools toolbar. You 
can use these tools to set up or animate your 3D model. 

You can also set up all these position parameters using the Layer Properties window—see About 3D Parameters.

NOTE: If you want to set up the position of your 3D model, you must disable the Animate  mode. Don't 
forget to re-enable it when if you want to animate it.
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About 3D Objects in Different Views
Before you can properly view and set up the 3D element in your scene, you will need to use the Perspective and 
Camera views together, as well as the Top and Side views. 

Using the Depth View mode can also be a useful tool when setting up 3D objects, see—Using the Depth View Mode 
on page 1116.
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About 3D Objects in the Perspective View
In the Perspective view, you can see your scene in a complete 3D environment. In this environment, you can set 
up and animate your 3D model more easily. You can rotate the view on the three axes by holding down ⌘  + Alt 
(Mac OS X), and clicking and dragging.
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About 3D Objects in the Camera View
You can preview the position of your 3D model in the Camera view and see what it will look like in the camera frame. 
You can preview your scene in  OpenGL  mode.

 

You can view your 3D objects in Render  mode, but only basic settings will be used to render the 3D element. To 
get a fully textured and lit render, you can use Autodesk Maya. If you want to render using your 3D objects using 
Maya as a background process, before you can view your 3D elements in Render  mode, you must add a Maya 
Batch Render node to your Node view and set up your system with the correct path to the rendering utility you will be 
using. Note that you will need to add your Maya project inside the 3D object's element folder in your Harmony scene. 
If you do not complete this setup, the 3D model will simply not appear—see About Rendering 3D Models with 
Autodesk Maya on page 1160.

If you want to override the order of your 2D and 3D elements to follow the Composite node ordering rather than the Z-
axis order, you can use the Flatten node—see the Reference guide .
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About 3D Objects in the Top and Side Views
The Top and Side views help you position your element in the 3D environment. This can be really helpful for 
precisely visualizing the actual position of your model without perspective.
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Animating Individual Parts of 3D Models
A typical 3D model is comprised of many parts (subnodes). Not all of these parts need to be animated; most are just 
used for display. However, if you would like to animate a specific part, you need to add a Subnode Animation node 
under your 3D model and then create properties for that part.

Properties, also known as function columns, allow an object to be moved, rotated, scaled, etc. Subnodes with 
properties will appear in the Timeline view as a layer. You can then keyframe movements of any of the subnode's 
properties in the Timeline view.

If you would like to link the movements of one subnode to another, you can do so by linking functions—see Linking 
Functions.

.How to animate a part of your 3D model

 1. In the Node Library, in the left menu bar, click on 3D.

 

 2. Drag and drop the Subnode Animation node from the Node Library into the Node view.

 3. In the Node view, connect the Subnode Animation node under the node of your 3D model.
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The Subnode Animation node automatically appears in the Timeline view, under the 3D model layer.

 4. In the Tools toolbar, select the Transform tool .

 5. In the Camera or Perspective view,  click on your 3D model once to select the whole object, then click 
again to select the individual part.

 6. Use the Transform tool to move, rotate or scale the individual part.
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 7. The subnode appears in the Timeline view.

 8. In the Timeline view, expand the subnode layer to view its properties.

A keyframe appears in the first frame, recording the movement that was just made.

 9. Continue adding keyframes and making changes to the properties values to animate the individual part of the 
3D model.

NOTE: You can also make the properties (Pos x, Velocity, Scale y, etc.) available for a part of a 3D 
model in the Graph view —see Making Subnodes Animatable
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About  Translate Tool 3D Manipulation
Once you enable the 3D option, the 3D Translate tool becomes available. Direction arrows appear around the 
pivot points to indicate the different axes.

 

If you click on a direction arrow, you can move a layer on only one axis. If you click anywhere else, the layer can 
move freely on two axes at once. Once the arrow is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have the 
optimum point of view on your stage to understand the setup. In this case, it is best to use the direction ellipses.
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About Rotate Tool 3D Manipulation
Once you enable the 3D option, the 3D Rotate tool becomes available. A rotation sphere appears around the pivot 
points to indicate the different axes.

You can click on the direction ellipses to rotate your layer on one axis only. If you click anywhere else, the layer 
rotates freely on two axes at the same time. When the ellipse is selected, it turns pink.

If you move the layers in the Perspective view, it may be difficult to control the motion since you may not have the 
optimum point of view on your stage to understand the setup.

1153



Chapter 17: 2D-3D Integration     Animating Individual Parts of 3D Models

About Scale Tool 3D Manipulation
Once you enable the 3D option, the 3D Scale tool is available. You will see one of two things:

• A scaling rectangle appears if your drawing is flat.

• A scaling cube appears if your object has some rotated layers around the pivot points, indicating the 
different axes. If you click and drag on this scaling cube, it will scale proportionally on all axes.

Click on one of the three control points to scale the shape on one axis. Hold down the Shift key to scale the object 
proportionally. When the control point is selected, it turns pink.
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About Transform Tool 3D Manipulation
Once you enable the 3D option, the 3D Transform tool become available. This tool is a combination of the 3D 
Translate, 3D Rotate and 3D Scale tools.

To translate an element, grab the direction arrows in the same way that you would with the Transform  tool.

To rotate an element, grab the rotation ellipses in the same way that you would with the Rotate  tool.
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To scale an element, grab the scaling control points in the same way that you would with the Scale  tool.

If you click and drag on the scaling cube, it will scale proportionally on all axes.
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2D Object Manipulation
As you work with 3D objects in Harmony, you will most likely want to integrate 2D and 3D objects together. 
Ensuring that 2D objects appear in the correct perspective when set next to 3D models will be one of the main 
challenges. To learn more about manipulating 2D objects in 3D space, see Positioning Layers in 3D Space on page 
1113 and About the 3D Transform Tool on page 1107.
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Editing 2D Objects in 3D Space
As you build your project in the Perspective view, you may rotate and reposition 2D drawings to lay flat against 
different planes of your 3D model. If you then want to draw on these 2D drawings, you will see that it is not 
possible. In order to draw on a 2D drawing in the Perspective view, the drawing needs to be facing the camera.

How to turn a 2D object to face the camera so you can draw on it

 1. In the Perspective view, select the 2D drawing with the Transform tool .

 2. From the Perspective view menu , select View > Face Selected to Draw.

The Perspective view is reset so that the 2D drawing is now facing the camera.

 3. Select a drawing tool from the Drawing Tools toolbar and modify the drawing.
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About Rendering 3D Models with Autodesk Maya
There are  two ways to preview and render 3D elements in Toon Boom Harmony. You can render your scene using 
the OpenGL preview, or render calling Autodesk Maya, Pixie or 3Delight in the background.

If you do not set up a plugin to preview your model with Maya or your 3D software, the preview and rendering will 
be done using the OpenGL preview. The result will look flat and jagged, but it can be very handy while working 
and exporting shots for approval.

If you render a scene calling Autodesk Maya, Pixie or 3Delight, you will get a smooth result with texture and 
lighting.

Before you can render the 3D objects you imported in Harmony through Autodesk Maya soft render, you must 
prepare your system by setting some environment variables, and adjusting the Node view in Harmony.

This section is very technical; if you need help, or experience problems while setting up the 
3D rendering, contact store.toonboom.com/contact/support.
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Preparing the Project Directory
In order to set-up to render, you must first prepare the project directory.

How to set up rendering

 1. Copy your original Maya binary file  *.mb into your Harmony project directory at the same location as the .fbx 
file you imported. This .fbx file should be in the elements folder, inside a subfolder named like the element.

Example: If the element is called PirateShip,then the subfolder should be named PirateShip. 

 2. Rename the .mb file so it has the same name as the *.osb file. You saved the Maya *.mb file in Exporting 3D 
Objects on page 1137 of this document.

For example: If the *.fbx is called PirateShip-1.fbx, name the *.mb: PirateShip-1.mb.

 3. Copy any textures used in the Maya project into this same folder.
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Setting the Path on Windows
The path needs to be set up so that when Harmony launches Maya, it knows exactly where to look for the 
application.  On Windows, this can be set up using an environment variable.

How to set up the environment variable on Windows

 1. From Start, right-click on Computer and select Properties.

 2. From the Computer Properties dialog box, select Advanced System Settings.

The  System Properties dialog box opens.

 3. In the System Properties dialog box, click Environment Variables.

The Environment Variables dialog box opens.

 4. The first variable to set up is the Maya path. In the System Variables section, browse for the Path variable 
and select it.
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 5. Click Edit.

The Edit System Variable dialog box opens.

 6. In the Variable value field, add a semicolon (;) at the end of the last path.

 7. Copy the path to the bin folder of Maya following the semicolon. 

For example: For Autodesk Maya 2011 on Windows, the path would be as follows: 
C:\Program Files\Autodesk\Maya2011\bin

NOTE: You can browse to the installation folder of Maya and copy the complete path to the bin 
folder from the browser window to ensure you have the exact path.

 8. Click OK.

If you receive an error readout in the command line when you try to render, contact 
store.toonboom.com/contact/support and provide the error readout content.
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Setting the Script on Mac OS X
The Path needs to be set up so when Harmony launches Maya, it knows exactly where to look for the application.  
On Mac, you can set this up by placing a script in usr/bin.

Follow these steps to create the script to call Maya and to set it up. 

From the Terminal, you must create a file in which to save the script. 

How to create the script and set it up

 1. Switch to the directory in which you want to create the script file:

cd /usr/bin

 2. If the bin directory does not exist, then create it:

mkdir /usr/bin

 3. Create the script file called maya:

sudo vim maya

 4. Type in your password to get administrator access.

 5. From inside the text editor, select "i" to go to Insert Mode, and copy and paste the following text. Make 
sure the path is updated to the version of Maya you have running on your machine.

#!/bin/bash

exec /Applications/Autodesk/maya2014/Maya.app/Contents/MacOS/Maya "$@"

 6. Save and exit:

Esc :wq

 7. Edit the file to make sure all users can access it:

chmod ugo+x maya

1164



Harmony 14 Premium - User Guide

Setting the Path on Linux
The path needs to be set up so when Harmony launches Maya, it knows exactly where to look for the application. 
You can either do it in a tcshrc or a bash shell. In both instances, you are simply adding your path to the beginning of 
the $PATH environment variable. Note, this should generally be added to your .tcshrc file ( in your home directory ) 
or in your .bash_profile, depending on the type of shell you use.

How to set the path on Linux

 1. Do one of the following:

 l In a tcshrc shell:

setenv PATH /whatever/the/path/to/Maya/is:$PATH

 l In a bash shell:

export PATH=/whatever/the/path/to/Maya/is:$PATH
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  About Node View Setup
Now that your environment variables have been properly set up, the final step is to prepare your network to call 
the Autodesk Maya rendering utility. Once this is done, you can render the 3D objects in your Harmony project 
and preview them in the Camera view in the Render View  mode. This will allow you to composite your 3D 
scene and effects.

Use the Render Maya Batch node to connect Harmony and Maya.

This node uses the script renderMayaBatch();

This script starts a Maya Batch session, renders the 3D elements on that frame, and then closes the session. It 
will open and close the session for every frame to be rendered.
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Setting Up Nodes for 3D Renders
Before starting a render from Maya, there are a few nodes to connect in the Node view.

How to set up nodes for 3D render

 1. Start Toon Boom Harmony. It is recommended that you  run it from the command line. This way, you will have 
a printout of the process as it renders. Once it is started, you may also want to display the Message Log 
view.

 2. In the Node view, locate the 3D object node.

 3. In the Node Library view, select the RenderMayaBatch node and drag it to the Node view.

 4. In the Node view, hold the Alt key down while dragging the RenderMayaBatch node under the 3D object 
node to connect it.

 5. Repeat the previous steps for each 3D object node in your scene.

 6. Save and reload your scene so Autodesk Maya files can be retrieved from the project folder.

 7. In the Camera view, click the Render View  button.

All the elements of your scene appear in this complete preview of the rendered scene.

 8. To add effect filter nodes to your 3D object, make sure to connect them under the Maya render node.
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You are now set to render your animation project.
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Setting Up 3D Transparency and Anti-aliasing
Depending on the renderer used, better transparency can be supported when previewing and exporting integrated 3D 
models in Harmony, as well as the anti-aliasing of 2D objects overlapping 3D models. Install either the Arnold or 
RenderMan plug-in on Maya and then specify their use through the Maya Batch Render node in Harmony.

To setup the  Maya Batch Render node with your 3D model node—see Setting Up Nodes for 3D RendersSetting Up 
Nodes for 3D Renders

How to set the renderer for better transparency

 1. In the Node view, open the Maya Batch Render node properties by clicking on its yellow square.

 2. In the Attributes tab, in the renderer field, type in one of the following options:

 l renderMan

 l reyes

 l renderManRIS

 l RIS

 l arnold
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 3. Click Close.

 4. In the Camera view, click on the Render View  button.

All transparent parts of your 3D model pass and reflect light naturally and all 2D drawings integrated with 
the 3D models display soft edge anti-aliasing.
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Smoothing Using the Z-Buffer
When batch rendering 3D models originating from Maya, some unwanted artifacts may appear, particularly on mod-
els with outlines. This is due to problems with the depth information. You can use the Z-Buffer Smoothing node to 
smooth out the edges. 

How to use the Z Buffer Smoothing

 1. In the Node Library, select the 3D tab. 

 2. Select the Z Buffer Smoothing node and drag it to the Node view.

 3. In the Node view, place it between a MayaBatchRender node and the final Composite node.

 4. Display the Z Buffer Smoothing node properties. 
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 5. Adjust the Histogram Range and Kernel Size parameters to achieve the optimal rendering of your Maya 
models. In most cases, you will have to experiment with a balance between the histogram range and the 
kernel size.
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Chapter 18: Motion Paths

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera moves and 
camera shakes, adjust the easing, shape your paths with control points and much more.

Before animating the position of your layers, you need to create motion paths which are trajectories on which you 
can attach drawing objects. Using keyframes, you can then record key positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a 
simple motion, you will learn the basics of animating a layer.

There are two ways to create motion paths: animated drawing layers and pegs. They each have different purposes. 
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About Pegs
T-HFND-009-004

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg 
holes at the bottom or top of the animation paper are used to keep all the sheets even and at the same 
registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones are 
oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the 
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and 
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create 
animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

 l Euler Angle or Quaternion Angle (when 3D option is enabled)

 l Z Scale (when 3D option is enabled)

You can control a peg’s trajectory the same way as the animated drawing layer.
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A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds. 
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory 
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to control 
your puppet as one object.

In Harmony, you can add pegs to the Node view using the Node Library view and they will instantly appear in the 
Timeline view. The nodes you add to the Node view are synchronized with the ones in the Timeline view.

1175



Chapter 18: Motion Paths     About Pegs

Adding Pegs
T-ANIMCO-001-001

You can add peg to your Timeline view and parent the layers to animate to it. 

How to add a peg in the Timeline view

 1. In the Timeline view, select the layer on which you want to attach a peg.

 2. Do one of the following: 

 l From the Timeline View layers toolbar, click the Add Peg  button.

 l From the Timeline view menu, select Insert > Peg.

 l From the top menu, select Insert > Peg.

 l In the Node Library, select a Peg node  and drag it to the Node view.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X).

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer 
automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to the Peg 
layer. This relationship is called a parent-child relationship.

 3. If you intend to add multiple pegs or if the layer name that was added to the peg does not accurately rep-
resent the content of the Peg layer, you can rename it. Click the layer name and type in a new name. Or 
double-click the layer and type a new name into the dialog box.

 4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the 
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer 
below the Peg layer indicates whether it was correctly attached or not.
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 l You can unparent layers by holding down Shift and dragging the selected parents away from 
the child layer. Drop your selected between other layers.

How to add a peg in the Node view via the Node Library

 1. In the Node Library view, select the Move tab.

 2. Select a Peg node and drag it to the Node view. You can also press Ctrl + P (Windows/Linux) or ⌘  + P (Mac 
OS X).

 3. In the Node view, select the Peg node's output port and connect it to a Drawing or Camera node.

The advanced connections in the Node view are shown in the Timeline view, unless they cannot be 
reproduced in a timeline layout.
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Enabling Peg Selection Mode
In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in the 
Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers 
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent 
Skipping Effects command.

How to enable the Peg Selection Mode

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 1. In the Tool Properties view, click the Peg Selection Mode  button.

 2. In the Camera view, select an element parented to a peg.
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Connecting Nodes to  Pegs
You can connect several nodes to a single parent peg or give them each their own peg.

How to create an automatic connection to a parent peg

 1. In the Node view, select one or more drawing nodes that are not parented to any other node.

 2. Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X) to add a new peg node to the Node view and auto-
matically connect it to the selected nodes. Press Ctrl + Shift + P (Windows/Linux) or ⌘  + Shift + P (Mac OS 
X) to add a peg to each node.
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About Drawing Layers
T-ANIMCO-001-002

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

3D objects and 3D-enabled layers also have these extra paramaters:

 l Euler Angle or Quaternion Angle (when 3D option is enabled)

 l Z Scale (when 3D option is enabled)

Harmony keeps track of each parameter of each layer by storing them in their own function curve. When you add 
a keyframe to a layer, a keyframe is created on each of these functions, and transformations done on a layer via 
the Camera view are translated into coordinates which are then stored in those functions. It is possible to edit 
these functions individually using the Function view, but that is rarely necessary, as Harmony provides easy-to-
use tools for visually controlling trajectories and timing in the Camera and Timeline views.

1180



Harmony 14 Premium - User Guide

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select the 
layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls tab. If 
your layer was already animated, then your keyframes will appear dimmed so you can easily  identify them as ones 
that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.
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Disabling Layer Animation
By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do so 
by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated 
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure and 
keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for 
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose their 
offset keyframes or drawing substitution keyframes.

How to disable the animation feature on a layer

 1. In the Timeline view, double-click the layer on which you want to set the parameter.

The Layer Properties editor opens.

 2. In the Controls tab, deselect the Animate Using Animation Tools option.
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About Layer Parameters
T-HFND-009-008

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew and 
scales. Each parameter has its own function which is a mathematical formula expressing the relationship between 
position values. You can view each function on a graph as a simple curve, such as the one below.

There are several options available for setting up function parameters:

 l Locked Positions (3D Path)

 l Separate Positions

 l Locked Scales

 l Separate Scales

 l Quaternion (3D Rotation)

 l Euler Angles (3D Rotation)

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. When 
you lock or unlock parameters, this does not convert the functions from one to the other, but creates new ones.

In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you add a 
keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth 
trajectories.
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When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the 
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its 
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth 
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one another. 
This is why in cut-out animation it is recommended to use separate position settings. But if you work with 3D 
path, you can use the Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes 
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works 
with 3D paths.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls 
directly on their function curve. This is useful when you want to set keyframes on one of the curves without 
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal 
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal) 
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions, 
you can squash, stretch and skew your elements.
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Displaying Layer Parameters
T-ANIMCO-001-004

You can easily display the parameters for each layer in the Timeline view.

How to display the layer parameters in the Timeline view

 1. Do one of the following:

 l In the Timeline’s left side, click a layer's Expand  button. 

 l In the Timeline view menu, select View > Show Functions.

 l Press Alt + F. 
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Setting Layer Parameters
T-ANIMCO-001-003

You can modify the layer parameters to different types of function and linking some of them together.

How to set the layer parameters

 1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also see 
the parameters in the Layer Properties window when you select the layer in the Timeline view.

The Layer Properties window opens.

 2. Select the Transformation tab.

 3. In the Position section, select the 3D Path or Separate option.

 4. In the Scale section, select the Locked or Separate option.

 5. Click Close.
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Enabling Constant Z
T-HFND-009-008A

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

 1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that you must 
select the 3D Path option for the layer.

 2. Double-click on one of the position functions to open the Function editor.

 3. In the Function editor, select the Constant Z  button.
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About Keyframes
T-HFND-009-005

Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like to 
create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no 
interpolation) and motion keyframes (computer-generated interpolation).

In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is 
constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to 
its new location.

In motion keyframes, there is no automatic interpolation created between the selected point and the next one. The 
layer will maintain its position until the animation reaches the frame of the next point and will then jump to the new 
position. Deselect this option to generate interpolation and get the layer to progressively move to the next 
position.
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Enabling the Animate Mode
T-ANIMCO-001-007

The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view. 
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled, 
keyframes are not created when an object's parameters change.

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your drawing 
layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off

 1. In the Tools toolbar, click the Animate  button or select Animation > Animate.
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About Keyframe Creation
There are several different ways you can create keyframes. You can add a coordinate keyframe, position 
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays 
the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do not want 
to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be 
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and 
Skew parameters.
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Creating Keyframes in the Timeline View
T-HFND-009-006

You can add keyframes in the Timeline view to multiple layers, a single layer or a specific parameter.

How to create keyframes in the Timeline view

 1. In the Timeline view, select the cell on which you want to add a keyframe.

 2. Add a keyframe  by doing one of the following:

 l From the top menu, select Insert > Keyframe.

 l Right-click  on the selection and select Insert Keyframe.

 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the current frame.

 How to add a keyframe for a specific parameter

 1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

 2. Do one of the following:

 l Right-click the selected cell and select Insert Keyframe.

 l Press F6.

 l In the Timeline View menu, select Motion > Insert Keyframe.

 l In the Timeline View toolbar, click the Add Keyframe  button.

How to create a keyframe and duplicate the drawing at the same time

 1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a keyframe.

1191



Chapter 18: Motion Paths     About Keyframes

 2. Do one of the following:

 l From the top menu, select Insert > Keyframe and Duplicate Drawing.

 l Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

 l Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the original 
drawing.

How to add a Position keyframe

 1. In the Timeline view, select the cell on which you want to add a position keyframe.

 2. From the top menu, select Insert > Position Keyframe.
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Creating Keyframes in the Function View
You can add keyframe directly on the graph using the Function view.

How to add or delete keyframes in the Function editor

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt + F. 

 1. Double-click on the parameter layer name to open the Function editor window or click once on the parameter 
layer to display it in the Function view's left sidebar. If you are using the Function view, you must click on the 
function name from the sidebar list to view it in the graph display region.

 2. In the Function editor, do one of the following:

 l In the graph section, click on the frame  where you want to make changes.

 l In the Frame field, enter the frame number.

In the graph display area, the red playhead moves to that frame number.

 3. In the Function editor, click the Add Keyframe   button.
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 4. Click on the newly created keyframe and drag it up to increase the value of the function or down to 
decrease the value. Depending on the selected function, this could increase or decrease the width of the 
object (scale_x) or change the object's vertical position (position_y). Pull on the handles to create non-lin-
ear transition speeds between keyframes.

 5. If you do not like the changes you just made, select and delete the new keyframe by pressing  Delete or 
clicking the and Delete keyframe  button.

You can delete an existing keyframe by using the same process.
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Creating Keyframes in the Xsheet View
If you prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and 
then select the layer you want to modify. If you double-click on a function column's header, you will display the 
corresponding function curve in the Function editor.

How to add a keyframe in the Xsheet view

 1. In the Xsheet view, click the Expand button located on the right side of the main section to show the Func-
tions section. 

 1. In the Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding keyframes in the 
Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

 2. In the Xsheet view, go to the function column on which you want to add a keyframe.

 3. Double-click on the cell on which you want to add a keyframe and type a numeric value.

 4. Press Enter/Return to continue to the next cell.

 5. Press Esc to exit the typing mode.
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How to convert a cell into a keyframe

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Select the cell to convert.

 3. Right-click on the cell and select Set Selection As Keyframe or press F6.

 4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in Selec-
tion or press F7.
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Deleting Keyframes
T-HFND-009-007

You can delete keyframes independently from drawing exposure.

NOTE: If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to delete a keyframe

 1. In the Timeline view, select a keyframe and do one of the following:

 l Right-click and select Delete Keyframes. 

 l In the Timeline view menu, select Motion > Delete Keyframes.

 l From the top menu, select Animation > Delete Keyframe.

 l Press F7.

 l In the Timeline View toolbar, click on the Delete Keyframes  button.

 l Use the Transform  tool to select a keyframe to delete from the trajectory in the Camera 
view and press Delete.
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Animating with Keyframes
T-ANIMCO-001-005

You can animate a layer or a peg by creating keyframes and moving your drawings in the Camera view.

How to animate a layer or a peg

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. If you have parent pegs and are animating a drawing layer, in the Tool Properties view, make sure the Peg 
Selection Mode  is deselected.

 3. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position 
and size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and 
size throughout the whole scene. 

 4. In the Timeline view, go to the first frame.

 5. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert 
Keyframe.

A keyframe is created on the first frame of the Timeline view.

 6. In the Camera view, select the element to animate and move it to its first position.

 7. In the Timeline view, go to the frame on which you want to set the second position.
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 8. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert 
Keyframe.

A second keyframe is created on the Timeline view.

 9. In the Camera view, move the element to its second position.

 10. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 11. In the Playback toolbar, click on the Play  button to preview your animation.

NOTE: If your scene has 3D objects, or if you animate layers on the Z axis, you may want to preview your anim-
ations from the Top, Side or Perspective views while during playback. By default, playback is disabled in those 
view. To enable them, from the top menu, select Play > Enable Playback > Top View, Side View or Per-
spective View.
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Changing Keyframe Values
Once a keyframe is added, beside moving the image in the Camera view, you can change its value by typing it in 
the Timeline and Function views.

How to change the keyframe values in the Timeline view

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt 
+ F. 

 2. Select the parameter for which you want to create a function curve.

 3. Place the cursor over the blue number value of the parameter and do one of the following:

 l Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand 
left to decrease the value or right to increase the value.

 l Double-click on the blue number and enter a value in the field.

How to change a keyframe value in the Function editor

 1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg layer's 
name.

1200



Harmony 14 Premium - User Guide

 2. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer to 
display it in the Function view.

 3. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.

 4. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

 5. Keep adjusting the values until you are satisfied with the results.

 6. Click Close.
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Switching Keyframe Types
T-ANIMCO-001-006

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

How to switch between motion and stop-motion in the Timeline view

 1. On the right side of the Timeline view, select one or more keyframes to modify.

 2. Switch between motion and stop-motion by doing one of the following:

 l Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (Mac OS X) for stop-motion keyframes.

 l In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe  
button.

How to switch between motion and stop-motion in the Coordinates and Control Points view

 1. Using the Transform  tool, in the visible path in the Camera or Timeline view, select the keyframe to 
convert.

 2. In the Coordinates and Control Point view, select/deselect the Stop-Motion Keyframe option.

How to switch between motion and stop-motion keyframes in the Function view

 1. Open the Function view.

 2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.
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 3. Do one of the following:

 l In the Transformation tab, click the Function Editor  button.

 l In the Timeline view, click the Expand Function  button or press Alt + F and double-click on 
the function to edit.

 4. On the function curve, select one or more keyframes to modify.
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 5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.
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Changing Stop-motion Keyframe Colour
To easily identify stop-motion keyframes in the Timeline view, you can customize the colour In the Preferences 
dialog box.

How to set the stop-motion keyframe colour

 1. Open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab. 

 3. In the Colours section, click Edit Colours.

 4. In the Colours dialog box, select the Xsheet and Timeline tab.

 5. In the Timeline section, click the  Stop Motion Keyframe swatch.

 6. In the Select Colour window, select a new colour and close the windows.
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Jumping to Keyframes
You can jump between the selected layer's keyframes in the Timeline view.

How to jump to keyframes

 1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip through.

 2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press 
semicolon (;) and single quote (').
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About Controls
T-HFND-009-010

Camera moves and motion paths can become quite advanced, especially with moves through 3D space. Harmony 
provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D perspective.

You can display the trajectory of a motion path when you select an object from any view it can be selected in.

A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both 
keyframes and control points. Both can be used to shape a path; each have their own behaviour, however only 
keyframes appear in the Timeline view. 

 l Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in 
time.

 l Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. There are 
no velocity handles available on a control point. The velocity segments are set between keyframes only, mak-
ing curves and trajectories much smoother. Control points can only be added on a 3D path.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-in-time 
using the Coordinates and Control Points view. 

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear in 
the Coordinates and Control Point view. You can also see the same information in the Coordinates and Control 
Points toolbar.
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You can adjust these parameters by selecting the control points and keyframes in the Camera, Top and Side 
views with the Transform  tool.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.
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Displaying Controls
T-HFND-009-011

You can display a layer's controls to adjust a trajectory or other parameters such as a gradient's position or 
deformation settings.

How to display the layer’s controls

 1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to display 
is selected in the Timeline view.

 2. From the top menu, select View > Show > Control or press Shift + F11 or in the Camera view toolbar, click 
on the Show Control  button.

NOTE: If nothing appears in the Camera view, you may not have animated or selected the layer.
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Adding Control Points
T-HFND-009-012

You can add control points on 3D Path trajectories. You need to display the layer's controls in the Camera view.

How to add a control point on a trajectory

 1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

 2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top menu or 
press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.

 3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and press 
P once. If you hold the key down, control points will be added continuously until you release the key.

A control point is added to the trajectory.
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Toggling Point Types
You can convert a control point into a keyframe and a keyframe into a control point. The position and other values 
will remain in both cases, only the frame will change. A control point is not locked in time.

How to switch between keyframe and control point

 1. In the Camera view, use the Transform  tool select a point to convert.

 2. To convert the point:

 l In the Coordinates and Control Points view, select or deselect the Locked in Time option.

 l From the top menu, select Animation > Lock in Time.

 l In the Function view or Function Editor, select the keyframe to convert and click the Lock in 
Time  button.

 l Press Alt+L.
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Adjusting Tension, Bias, and Continuity
You can adjust the shape of the curve passing through a point by modifying the bias, tension, and continuity 
settings. You can also set preferred settings as default.

How to adjust the Continuity, Tension and Bias parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline view, select the layer that contains the parameters you want to adjust.

 3. From the top menu, select View > Show > Control  or press Shift + F11 to display the trajectory.

 4. In the Camera view, select a control point or keyframe.

 5. In the Coordinates and Control Points view, adjust the Continuity, Tension and Bias parameters.

How to adjust the control point preferences

 1. From the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences (Mac 
OS X).

The Preferences dialog box opens.

 2. Select the Camera tab and adjust the parameters in the Control Points section.
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Converting Angled and Curved Corners
When you select a control point on a path, you can switch between a rounded or angled corner by using the 
Linear/Curve command. 

How convert an angled or curved corner

 1. In the Timeline view, double-click the layer that contains the point you want to convert.

The Layer Properties window opens.

 2. On the Transformation tab, select the 3D Path option.

 3. In the Tools toolbar, select the Transform  tool or press Shift + T.

 4. In the Camera view, select the point to convert.

 5. From the top menu, select Animation > Linear Motion.
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Offsetting Trajectories
By offsetting a trajectory, you Lets you reposition the visual trajectory without offsetting or modifying your animation. 
By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location than the centre 
of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you have several elements 
attached to one trajectory, you might want your trajectory to be at a different location to represent the group's motion 
better.

How to offset a trajectory

 1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

 2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

 3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the tra-
jectory, any transformation done using the Spline Offset tool will be ignored.

 4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, but also 
on the Z-axis using the Top and Side views.
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About Functions
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally 
create the ones you need to avoid being overloaded with too many functions you might not use.
When you select an element in the Camera view and move it around, it will automatically create the corresponding 
function curves. If you need to create certain functions manually, you can always do it through the Layer Properties 
view or editor.  You can then share it with other layer parameters or set keyframes directly on the function curve 
instead of doing it in the Timeline or Camera view.
You can also link a layer's parameter to an existing function curve or attach several parameters to the same function 
curve. For example, if you have an aircraft performing loops between clouds, you may want the camera to follow the 
aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but this may produce 
undesirable results and even induce a feeling of motion sickness as you watch the final animation. Instead, you can 
share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore the angle, scale and skew. 

By default, all function curves can only be used and modified using their original parameter. If you want another layer 
or parameter to use the same function curve, you must share it.

There are two ways to share a function:

 l Share Functions command

 l Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:

Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Create Ease Creates a new Ease curve

Local Disconnects the parameter from any function and changes it to shared.

3D Path Displays the list of every shared 3D Path function available

Bezier Displays the list of every shared Bezier curve available

Ease Displays the list of every shared Ease curve available

Velobased Displays the list of every shared velocity based curve available

Expression Displays the list of every shared Expression function available

3D Rotation Displays the list of every shared 3D Rotation function available

Connected Displays the list of every shared connected function curve

Unconnected Displays the list of every shared unconnected function curve

All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have two or 
more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your needs, 
including: 

 l Ease function

 l Bezier function

1217



Chapter 18: Motion Paths     About Functions

 l Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you have the choice of an 
Ease or Bezier function.

These function editors present different ways of editing the values over time. The shape of the created graph 
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is 
largely based on your working preference. 
With the Ease editor, you can edit the shape of the function curves using the ease-in and ease-out controls.
You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you 
do this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a 
Velobased function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it 
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an 
element.

You can convert Ease and Bezier function so you can edit them  using the controls offered by that type of 
function. 
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Creating Functions
You can create function curves in several different ways. You cannot create function curves directly in the Xsheet 
view. You must do this in the Layer Properties window or the Timeline view.

 How to create the function curve in the Timeline view

 1. In the Timeline view, expand the layer's parameters.

 2. Click the Function button and, in the drop-down menu, select Create Bezier or Create Ease.

How to create function curves using the Layer Properties view

 1. In the Timeline view, double-click on the layer you want to create function curves for.

The Layer Properties Editor opens.
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 2. In the Transformation tab, click the Function Arrow button beside the local function information.

 3. Create a 3D Path, Bezier, Ease or Velobased curve. You can also create an Expression column—see 
About Expression Columns on page 1248.

You can click the Function  button to open the Function editor.
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Converting Functions
You can duplicate the functions in a column and send them to another column in different ways.

How to convert Ease and Bezier functions

 1. In the Xsheet view, show the function columns.

 2. In the Xsheet view, click the Expand button located on the right side of the main section to show the Func-
tions section. Click on the same button to collapse it. You can also use the Show Column List  button in 
the Xsheet View toolbar.

 3. On the right side of the Functions section, click the Expand button to display the Column List section.

 4. In the Timeline view, click the layer that contains you function columns you want to display.

 5. In the Xsheet view, right-click on the column header, select Convert and one of the following:

 l Convert the Column: The values of multiple effects may be linked to the original column. 
When you use the Convert the Column command, all links to the original column will transfer to 
the new converted column.
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 l Create a New Column and Update Links: Creates a new function from the original. All 
links to the original column will transfer to the new column. The original function column will 
remain in the exposure sheet in case you decide you want to switch back to it.

 l Create a New Unused Column: Creates a new column based on the values in the original 
column and leaves all links pointing to the original column. You can use this command to 
experiment with various functions and then link effect values to the new function curve 
column.
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Sharing Functions
You can connect two or more functions to a shared function. If that shared function is modified, then the linked 
functions will vary accordingly.

How to share a function using the Layer Properties editor

 1. In the Timeline view, double-click on the layer that contains the function to share.

The Layer Properties window displays.

 2. In the Transformation tab, click the Arrow  button beside the function you want to share and select Local.

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.

 3. From the same menu in which you chose the Bezier option (in our example), select the function you just 
shared and attach it to your parameter.
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 4. In the Timeline view, open the Layer Properties editor of the other layer that contains the parameters you 
want to link to the shared function.

 5. In the Layer Properties editor or view, attach the parameter to the shared function the same way you did for 
the first layer.

The two parameters are both linked to the same function curve and follow the same path. If you modify the 
curve, both parameters will update.

How to share a function using the Share Functions command

 1. In the Timeline view, select the function layer to share.

 2. Right-click  and select Share Functions.

The function is shared with the other layers and parameters.

Shared functions are visible in the main section of the Xsheet view.
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 3. In the Timeline view, double-click on the layer that contains the parameters you want to link to the shared 
function.

The Layer Properties Editor opens.

 4. In the Transformation tab, click the Function Arrow  button beside the function you want to link to the func-
tion column.

 5. From the menu, select the function you just shared from the 3D Path, Bezier, Ease, Velobased, Expression, 
Connected, Unconnected, or All menu and attach it to your parameter.

The two parameters are both linked to the same function curve and should follow the same path. If you 
modify the curve, both parameters will update.
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Linking Functions
You can give the same series of motions that you created for one layer to another. These motions may include 
moving, rotating, scaling and skewing. An example would be a car tire. You could animate the rotation of one tire 
and then link that rotation function to another tire, so that they both rotate together. The tire may also move up and 
down if it is driving along a bumpy road. This would mean that you would have to copy the x and y-axis position 
functions as well.

Linking motion works with many layer types, including drawing, peg or 3D subnode. 

In the example below, the rotation from a peg will be copied onto a drawing layer.

How to link the motion from one element to another

 1. Open the Layer Properties of the element whose motion you would like to copy. You can do this is in one of 
two ways:

 l In the Timeline view, double-click on the layer.

 l In the Node view, click on the node's yellow square.

 2. In the Layer Properties, locate the parameter you would like to copy, for example Rotation: Angle z, then 
open the function menu for that parameter, by clicking on the arrow button at the end of the row. 

 3. In the function menu, select Copy Function Link.

 4. Open the Layer Properties for the second element. You can have the Layer Properties for both elements 
open at the same time. If you plan to perform multiple copy-pastes, it may be a good idea to keep them 
both open.

 5. Verify that the motion types are the same for both elements. For example, if the Position type for your first 
element is set to Separate, be sure that the Position type for your second element is set to the same.

 6. In the second element's Layer Properties, open the function menu for the same parameter, for example 
Rotation: Angle z.
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 7. In the function menu, select Paste Function Link.

Notice in the parameter's function field that the copied motion function appears, including the name of 
element that the function was copied from.

In the Timeline view, all the keyframes relating to that motion appear in the Timeline.
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 8. In the Camera view, slide the red playhead back and forth to view the two linked objects.

 9. Repeat steps 2-8 for any other motion that you would like linked.

Simply deleting the keyframes from an element that was linked to another does not break the link between the 
two objects. You must clear the function field for all linked parameters in the Layer Properties of the linked 
element.

How to unlink the motion between two elements

 1. Open the Layer Properties of the element which contains linked functions.

 2. Open the function menu for a parameter with a linked motion function and select Local.

The property field is reset to 0.
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About Copying Motions
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and 
even copy them.

As you animate, you will find that you reuse many positions, drawings, and keys. However, you may only want to 
paste the drawings or just the keys or maybe everything. There are different paste options available in the Timeline 
view which give you maximum flexibility when reusing and pasting.

Note that these modes also apply when you drag instead of copying and pasting.

There are three different modes for pasting your selection:

 l  Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

 l  Paste Mode: Keyframes Only: Pastes only the keyframes.

 l   Paste Mode: Exposures Only: Pastes only the drawing exposure.

When you have position keyframes set in your drawing layer and you want to move them around when moving your 
drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and 
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the Paste 
Reverse command to completely reverse the flow of your animation.
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Using Timeline Paste Modes
Use can copy and paste or drag and drop keyframes and drawings in the Timeline view using various modes.

How to paste a selection using different modes

 1. In the Timeline view, select the cells you want to copy and paste.

 2. In the Timeline toolbar, click the desired Paste  mode button.

 3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘  
+ C (Mac OS X).

 4. In the Timeline view's right side, select the cell on which you want to paste your selection.

 5. Select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

Paste Mode: Exposures Only
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Using Paste Special
You can copy drawing exposures and keyframes and paste only a portion of your selection using Paste Special.

How to copy and paste a motion using Paste Special

 1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go to 
step 3.

 2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘  
+ C (Mac OS X).

 3. Edit your selection by doing the following:

 l To paste the selection, in the Timeline view, select the first cell on which you want to paste 
your keyframes and from the top menu, select Edit > Paste Special or press Ctrl + B (Win-
dows/Linux) or ⌘  + B (Mac OS X).

 l To move the selection, in the Timeline view, drag the selection and hold down Alt. Drop the 
selection where you need it and release the hot key.

The Paste Special window opens.

 4. Set the Drawing, Pegs and Functions, and Cycles parameters. 

 5. Click OK.
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Cycling Animations
You can copy and cycle a section of your animation or your entire animation.

How to cycle an animation

 1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells from the Xsheet/Timeline.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Cycle dialog box opens.

 5. In the Number of Cycles field, increase or decrease the number of cycles you want to paste.

 6. In the Cycle Type, select the type of cycle to paste.

 l Normal (forward): Pastes your selection as it is, starting with the first cell and ending with the 
last.

 l Reverse: Pastes your selection reversed, starting with the last cell and ending with the first.

 l Forward > Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to the 
last one and ending with the first cell.

 l Reverse > Forward: Pastes your selection as a reversed yo-yo, starting with the last cell, 
going to the first one and ending with the last cell.
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Pasting Reverse Motions
You can paste your animation reversed from its original flow.

How to reverse the animation flow

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.

 2. From the top menu, select Edit > Copy.

 3. In the Xsheet or Timeline view, select the cell on which you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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About Velocity
T-ANIMCO-001-009

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters script 
and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve in 
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left 
handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to adjust the 
ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

You can also reshape the velocity function using Ease controls.
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If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for 
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes 
in the same frame.
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Displaying Velocity Curves
You can display a parameter's function curve and adjust the easing with the relevant controls.

How to display the velocity curve

 1. In the Timeline view, click the Expand  button on a layer or press Alt + F.

The layer’s functions are displayed.

 2. Double-click the desired function. Note that 3D Paths have a specific velocity curve controlling the X, Y, and 
Z axis together. You need to click on the Position:Velocity layer.

The Function Editor opens as the Ease Editor or Bezier Editor.
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The editor will not be displayed if the function does not already exist.
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Adjusting Bezier Curve Velocity
You can reshape a Bezier curve velocity using the Function view controls.

How to adjust a Bezier curve velocity

 1. In the Function view, select a keyframe.

 2. Drag the controls to modify the shape of the curve.

You can reshape the function using the Bézier controls.

 3. The Continuity options influence how you can move the handles:

 l Straight: Lets you move the handles together, maintaining the same angle to the point.

 l Corner: Lets you move the handles independently.

 l Smooth: Lets you move the handles together, maintaining the same distance and angle to the 
point.
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Adjusting  Ease Curve Velocity
You can reshape an Ease curve velocity using the Function view controls.

How to reshape the function using Ease controls

 1. In the Function view, select a keyframe.

You can reshape the function using the Ease controls.

 2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the green 
line. The ease in slope is indicated in blue. 

As you change the values visually, the value in the Ease In field is updated. This value represents the 
number of frames in the ease-in.

 3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the green 
line. The ease-out slope is indicated in red. 

As you change the values visually, the value in the Ease Out field is updated. This value represents the 
number of frames in the ease-out.

 4. To adjust the ease-in or ease-out, drag the handles around the keyframe.

The Continuity options, Corner and Straight, influence how you can move the handles:

 l Straight: Lets you move the handles together, maintaining the same angle to the point.

 l Corner: Lets you move the handles independently.
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Creating Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when you 
are animating drawings on 2s, for example, and you want to hold the same value for a function over those two 
frames.

How to create a step velocity

 1. Click the Hold Value Editor  button.

The Hold Value editor opens.

 2. In the Hold Value Editor, enter the following values:

 l Start: The starting frame for the effect.

 l Stop: The last frame for the effect.

 l Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) consistently 
between keyframes. That is, there is no acceleration in the effect.

How to create a step velocity for multiple parameters

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l Right-click on the empty space near the top of the interface  and from the quick-access menu selecting 
Scripting.

 l Right-click on the empty space near the top of a view and from the quick-access menu selecting 
Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager window.

 3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.

The functions associated with that file appear in the Functions section.
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 4. In the Functions section, select TB_CreateStepsOn.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_CreateStepsOn script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Timeline view, select the layer whose parameter values you would like to hold. 

 9. In the Scripting toolbar, click on the TB_CreateStepsOn script  button.

The Create Function Step On dialog box appears.

 10. In the Settings section, enter the hold value by changing the number in the Every Number of Frames field.

 11. In the Selection section, enter the first and last frame numbers to define the selection range.
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NOTE: The playhead location determines the lowest value you can enter for the first frame, when 
defining the selection range. You need to move the playhead to frame one if you would like to set frame 
one as the lowest possible starting value. 

 12. Click OK.

 13. In the Timeline view, expand the layer properties of the selected layer by clicking on its plus  button.

 14. Double-click on a parameter layer to open its Bezier Editor. If that parameter was animated, the 3 frame hold 
from frame 20 to 60 was applied.
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 15. In the Bezier Editor, click on any of the keyframes to bring up the bezier point handles and use them to 
reshape the velocity curve for that parameter.

This means that multiple parameters can have the same stepped velocity, but have different ease-in ease-
out curves defining that velocity.
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Adjusting Velocity in the Timeline View
If you would rather avoid playing with graphs and function curves, you can adjust the velocity in the Timeline view.

How to set the ease in the Timeline view

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter 
function. If many keyframes are selected on the same layer, the ease values will be applied only on the first key-
frame and the rest will be ignored.

 2. In the Timeline toolbar, select an option from the Set Ease Type menu.

NOTE: TIP: Optimize your workflow by adding the Apply Ease to Selection  button to the Timeline toolbar. 
This lets you quickly reapply the ease type without going through the Set Ease Type menu each time. To add 
the button to the toolbar, right-click on the toolbar area of the Timeline view and select Customize. 
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Setting Ease on Multiple Parameters
T-HFND-009-013

You can adjust the velocity on multiple parameters at a same frame for consistency.

How to set the ease on multiple parameters

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Mul-
tiple Parameter function. If many keyframes are selected on the same layer, the ease values 
will be applied only on the first keyframe and the rest will be ignored.

 2. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.
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 4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as Rota-
tion or Scale. Deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 
3D Path functions.

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note 
that it applies to the Morphing velocity function found in the Layer Properties window, not the 
basic morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other the selected functions, such as all func-
tions created to animate effect parameters.

 5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are calculated 
in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to 
the length of time you want the easing to last. Stay between 0% and 100%. If you go beyond 
100%, your motion will overshoot. 

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out to be. Stay between 0% and 100%. If you go beyond 100%, your 
motion will overshoot. 

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 6. Once done, click one of the following:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

 l Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.
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About Expression Columns

In Harmony, you can use expressions to automate the calculation of effect values based on the values in another 
function. An expression is a mathematical formula that allows you to manipulate the value in the source function 
to create new values for the destination effect.

For example, in a scene with two characters, one is walking across the stage and the other is following the same 
path two steps behind. Without expressions, you would have to manually enter the values for the position of the 
peg to be one frame behind the original element. However, you can save time by building an expression that does 
it for you. Then, if you change the position of the element in the original column, Harmony automatically updates 
the Expression columns linked to it.

When you want to create an expression for an effect, you must add an Expression column to the Xsheet view, 
build the expression and then link the Expression column to the parameter you want to control.

Writing Expressions
Expressions are based on a JavaScript (JS) program. You can access the full capability of the JS language and 
write any type of program, as long as it executes relatively quickly.

The entire JavaScript must be defined within the expression code. There is no common repository of JS functions 
and services available to the expression column scripting environment. However, with the Harmony C++ SDK, 
you can extend the API of functions available to the expression scripting environment.

If you're working with an old project that contains expressions, they are converted to a JS program. Only simple 
expressions are updated. Complex expressions and expressions using non-ported services cannot be converted. 
For these type of expressions, you must convert them manually.

Expression Dialog Box
The Expression dialog box is where you write expressions. It's a simple text editor that can handle incomplete or 
invalid JS programs although they will not be evaluated. Harmony can save and load invalid JS programs.

The Expression editor evaluates the current script at the current global frame and reports any errors or returns the 
numerical result of the program.
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Expression JavaScript Program
An expression JavaScript program can be any valid program. The only requirement is the last statement of the script 
must leave a number on the stack. The “return” statement is NOT needed as the script is not a function.

Valid Expression Column JS Program

Example 1

10

This is a simple program returning 10.

Example 2

currentFrame

This is another simple program returning the current frame. The variable “currentFrame” is one of the predefined 
variables and services available.

Example 3

value( “MyBezierFunction”, currentFrame - 1 );

A simple expression program that returns the value of the Bezier function “MyBezierFunction” at the previous frame. 
If this function does not exist in the scene, the expression column will be blank in the Xsheet. If this function does 
exist, the expression column will show the value of that function at the frame.

Example 4

This programs evaluates the Fibonacci series starting at the current frame. The value will be computed up to a 
certain frame. After that frame, the program is too complex and will be stopped by the engine before finishing.

Errors

Programs that take too long to execute, that don't generate a numerical value, or has syntax errors will not be 
compiled and will not compute a value. The scripting editor will show the condition that triggers this, but the Xsheet 
will display a blank field.

API
To refer to the values in a column, use the column name and frame number. If you do not state the frame number, 
then Harmony uses the value of the current frame. You can refer to the frame numbers in the following ways:

 l currentFrame: Refers to the current frame number.

 l numFrames: Refers to the total number of frames in a scene.

Consider the expression: value ( “peg x”, currentFrame-1)
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 l This expression says that the current frame value will be the same as the previous frame value of the ele-
ment peg x.

Now consider this expression: value ( “peg_angle”, currentFrame - 2] * 3

 l In this expression, Harmony is to look two frames before the current frame in the column "peg_angle" and 
multiply the value by 3 to derive the value for the current frame of the expression column.

Predefined Functions
Most mathematic functions are obvious. They either take an angle or value, or return an angle or  value. Angles are 
always specified in degrees. If the input argument is not valid, the function will log an error (which is visible in the 
script editor) and the Xsheet does not display anything.

The two variants of the function value() are used to get the value of 2D functions at the current frame or the 
specified frame. The first argument is always a string that identifies the function. The optional second argument is 
the frame to use.

For example: value( “myFavBezier”, currentFrame-1)

Function Description

sin (angle) Returns the sinus from the angle specified in degrees.

cos (cosine) Returns the cosinus from the angle specified in  degrees.

tan (angle) Returns the tangent from the angle specified in  degrees.

asin( v ) Returns the arcs in degrees.

acos( v ) Returns the arccos in degrees.

atan( v ) Returns arctan as an angle in degrees from the first  quadrant.

atan2( x, y ) Returns the arc tangent in degrees.

int Returns the integer value of the “v”. Undefined  behaviour for negative number.

ceil( v ) Returns the next integer greater or equal than “v”.

floor( v ) Returns the integer value of v. Remove the fractional  part.

abs( v ) Returns the absolute value.

sqrt( v ) Returns the square root for v >= 0.

exp( v ) Returns the “e” exponent v. (see c library exp( f )).

ln( v ) Returns the natural logarithmic of v for v > 0.

ln Logarithm of a value.

value( columnName) Value of the function specified by “columnName” at the current frame.

value(columnName,frame)
Value of the function specified by “columnName” at the frame specified by 
“frame”.

column( columnName )

Indentify the text wrapped by columnName to be renamed whenever the 
column named “columnName” is renamed.

column() is a keyword that does nothing at runtime, but helps Harmony track 
which references to a function needs to be renamed in the script when a 
function is renamed. For example, if you have a function named “B” and this 
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one gets renamed to “C” through some scripts or by the user, all expression 
scripts referencing “B” will automatically be updated to refer to “C” if their call 
was wrapped as column( “B” ).

node( nodeName )

node( nodeName ) 

Identifies a node/node that is in the same group as another node which is using 
this expression column.

node( nodeName) and node( nodeName ) are two functions that return a proxy 
to a node that must be in the same group as another node using that 
expression column. For this method to work, the expression must be 
connected to a node “A” and the script must refer to a node “B” in the same 
group as node “A”. The resulting object is a proxy to a node which cannot be 
converted to a number. This proxy object is only usable by an SDK plugin.

numFrames A constant that represents the number of frames in the current scene.

currentFrame A constant that represents the current frame (1 based).
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Writing Expressions
The number of expressions you can write is limitless. Find below an example of an expression for an effect.

How to build an expression for an effect

 1. In the Xsheet view menu, select Columns > Add Columns or press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a name for the column.

 3. From the Type menu, select Expression and click OK.

 4. Double-click on the column's header to open the Expression dialog box.

 5. Type an expression in the dialog box.
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NOTE: To address a specific component of a 3D path, the syntax is "Peg x", not "Peg_x".

 6. Click OK or Apply to activate the expression.

The cells in the Expression column are filled with values based on the expression you created.

 7. To apply the values in the Expression column to an effect, link the Expression column to the parameter val-
ues. In the drawing's layer properties, link the function to the new Expression column.
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About Animation Resources
As you are animating, you might find that you are constantly selecting the same elements from your scene, in order 
to progressively move and manipulate them. You can create a preset for almost any selection or group selection in 
your scene, in order to speed up the animating process.
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Creating Selection Presets
As you're animating, you might find that you are constantly selecting the same pegs, drawing layers, bezier 
points on a deformation envelope, part of a character rig, etc. You can create a preset that automatically selects 
any defined element or group of elements.

How to add the Selection Preset script to the Scripting Toolbar

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l Right-click on the empty space near the top of the interface  and from the quick-access menu select-
ing Scripting.

 l Right-click on the empty space near the top of a view and from the quick-access menu selecting 
Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager window.

 3. In the Scripts Manager, in the Files section, select the file TB_SelectionPreset.js.

The functions associated with that file appear in the Functions section.

 4. In the Functions section, select TB_SelectionPreset.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_SelectionPreset script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.
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How to create a preset from a selection

 1. In the Scripting toolbar, click on the TB_SelectionPreset  button.

The Selection Presets dialog window opens.

 2. In your scene, select an individual element or group of elements. This can include, but is not limited to:  pegs, 
drawing layers, deformation controls, part of a character (such as the entire rig of the head from the Node 
view).

 3. In the Selection Presets window, click on the plus button.

The Save Selection As Preset dialog box opens.

 4. Enter a name for the new selection preset in the field provided.

 5. Click OK.

The new selection preset name appears in the Selection Presets window.

How to use a Selection Preset

 1. In the Scripting toolbar, click on the TB_SelectionPreset  button.

The Selection Presets window opens.

 2. Double-click in the Group field next to the  Selection Preset you wish to use OR select a preset from the 
Name column and click on the Apply To Selection button.
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The defined selection is selected.
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Chapter 19: Cameras
T-HFND-009-001

Harmony contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis 
offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera 
position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and measures 
0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. Harmony 
uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution and other parameters in the Scene Settings window. If you're working in a gaming animation 
pipeline, you also have to possibility to set an orthographic camera.

By default, a scene does not have a camera layer. In order to be able to tweak the camera's angle and position, you 
must add one to your scene. Although it is possible to have several cameras in the same scene, you can only view 
your scene using one camera at a time. This can be useful if you are still working on your scene composition and 
have different camera framing to try out.

The Camera layer is static which means that if you need to animate it, you must put it under a parent peg.
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You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another 
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this 
positions the camera precisely where you want it to be rather than gauging it visually.

Once you have a 3D set, the exciting part is to do a camera move in it. This section teaches you the main steps 
required to perform a 3D camera move. Once you know how to do this, you can enjoy the delights of working in 
3D space and traveling through your creations!

Clipping Planes
You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that range 
is visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be looking 
inside a 3D box or room and you might want the foreground wall to not obstruct the view of the interior. By default, 
the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.
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You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that range is 
visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be looking inside a 
3D box or room and you might want the foreground wall to not obstruct the view of the interior. By default, the near 
clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.
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Camera Types
In Harmony, there are two types of cameras available:

 l Perspective

 l Ortographic

The orthographic camera is specific to the gaming pipeline. It changes the camera type from perspective to 
orthographic. It becomes a camera without vanishing points. This means there is no more perspective in the 
Camera view. Objects, when moved on the Z-axis, will not change in size or scale.

The orthographic camera can be set in the Scene Settings dialog box. In order  to create scenes with the 
orthographic camera, by default, you need to create a new custom scene resolution.
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Adding a Camera
T-HFND-009-002

By default, there is no camera in the scene. The frame visible in the Camera view is only a reference based on your 
project's resolution. In order to position your camera, you must add one to your scene.

How to add a camera in the Timeline view or Top menu

 1. Do one of the following:

 l In the Timeline view, click the Add Layer  button and select Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to add a camera in the Node view

 1. In the Node Library view, select the Camera node from the Favorites or Move category.

 2. Drag the Camera node to the Node view.
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Setting the Camera Type
You can set your camera to either Perspective or Orthographic. The orthographic is specifically used for gaming. It 
removes any depth or perspective.

How to set the camera type

 1. From the top menu, select Scene > Scene Settings.

 2. Select the Resolution tab. 

 3. In the Projection section, select Orthographic or Perspective.
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Selecting the Active Camera
T-HFND-009-003

You can add multiple cameras to your scene, but only one can be active at a time. You can select your active 
camera from the Camera list.

How to select the active camera from the Camera list

 1. From the top menu, select Scene > Camera > camera.
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Positioning the Camera Frame
You can grab the camera frame and move it around in the Camera view. You can also setup the camera position by 
entering coordinates and values in the Layer Properties view.

How to reposition the camera frame in the Camera view

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Translate. 

 l In the Advanced Animation toolbar, click the Translate  tool.

 l Press Alt + 2.

 3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera 
layer from the Timeline or Node view.

The selected camera frame is highlighted.

 4. Drag the camera frame to a new position. 
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 5. To tilt the camera frame, do one of the following to select the Rotate tool:

 l From the top menu, select Animation > Tools > Rotate.

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 3.

 6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

 7. To move camera frame closer to or further away from the scene, do one of the following to select the Scale 
tool:

 l From the top menu, select Animation > Tools > Scale.

 l In the Advanced Animation toolbar, select the Rotate  tool.
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 l Press Alt + 4.

NOTE: The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to set up the camera frame using the Layer Properties view

 1. In the Timeline view, select the camera layer.

 2. In the Layer Properties view, adjust the camera's properties.
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 3. Type or use the numeric stepper to adjust the coordinate and angle values—see the Reference guide .
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Resetting the Camera Position
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the 
selected element to the initial value of the active tool. For example, if the Rotate tool is active, the transformation 
angle will be reset to 0 and if the Transform tool is active, then all parameters values will be reset.

How to reset the camera position

 1. In the Tools toolbar, select the Transform  tool or press Shift + T. If you want to reset a single parameter, 
select the corresponding Advanced Animation tool, such as the  Rotate  tool.

 2. In the Timeline, Node, or Camera view, select the camera layer.

 3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Setting the Camera Clipping Planes
You can modify how far and how close the camera can see by adjusting the clipping planes.

How to modify the camera clipping plane

 1. In the Timeline or Node view, select the Camera node.

 2. In the Layer Properties view, go to the Clipping Planes section.

 3. Modify the value of the Near Plane to pull or push the clipping area closer to the camera. Anything behind 
this plane will no longer be visible.

 4. Modify the value of the Far Plane to pull or push the clipping area closer to the camera. Anything behind 
this plane will no longer be visible.

Locking Drawings to the Camera Angle

When you create a 3D camera move in your scene, notice that layers are treated as flat objects. That is, 
animation layers that are supposed to face the camera at all times will look like a flat sheet of rotating paper. Use 
the Ortholock layer when mixing flat animation layers with a set built in 3D. Ortholock forces your drawing layer to 
always follow the Camera angle. It does not follow its position or zooming level, only the rotation. This prevents 
drawings from being distorted by the camera motion.
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NOTE: Adding an Ortholock layer in a symbol will not give the correct result. The Ortholock contained inside a 
symbol does not consider the position of the camera contained in the root scene. Keep your Ortholock layers in 
the root scene.

How to add an Ortholock layer

 1. In the Node Library view, select the Move category.

 2. Select the Ortholock node and drag it to the Node view.

 3. In the Node view, drag an output cable from the Ortholock node and connect it to the node you want to keep 
facing the camera.
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Animating the Camera
T-HFND-009-009

A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and 
you can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, 
which means it keeps the same position and angle throughout the whole scene. In order to be able to animate the 
camera, you need to connect it to a peg layer, which can be animated, and which will directly affect the position 
and angle of the camera. 

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or Top 
views, which can be especially useful when animating a camera in a multiplane or 3D scene.

How to animate the camera

 1. In the Tools toolbar, enable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Timeline view, select the Camera layer.

 4. From the Layers toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it. 

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a 
Peg layer, for example Camera-P.

 5. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want the 
camera movement to start.

 6. Do one of the following to add a keyframe:
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 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera position 
as this keyframe.

 7. Do one of the following to move the camera:

 8. In the Camera view, select the Camera, which should now be represented by a thin yellow rectangle with a 
red highlight, and move it to the desired position.Do one of the following to select In the Top, Side or Camera 
view, select the camera (the large V-shaped cone) and move it to the desired position. In the Camera view, 
the camera is represented by a thin frame. You need to click directly on one of the edges.

 l In the Camera view, select the Camera, which is now be represented by a thin yellow rectangle 
with a red highlight, and move it to the desired position.

 l In the Top or Side view, select the camera, which is now represented by a large, yellow V-
shaped cone, and move it to the desired position.
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 9. On the Timeline view, click on the cell where the camera move will end.

 10. Do one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.

 11. Select the camera in the Camera, Top or Side view and move it to the desired position. 

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 13. In the Playback toolbar, click on the Play  button to preview your animation.
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Creating 3D Camera Movements
If you want to view your 3D camera move, you must be in the Perspective view.

How to create a 3D camera move

 1. In the Tools toolbar, enable the Animate  mode.

 2. In the Timeline view, click the Add Layers  button and select Camera to add a camera to your scene.

 3. In the Timeline view, select the new camera layer.

 4. In the Timeline Layer toolbar, click the Add Peg  button to add a parent peg to the camera.

 5. In the Timeline view, double-click on the new peg layer to open the Layer Properties dialog box.

 6. In the Layer Properties dialog box, go to the Transformation tab and select the Enable 3D option.

 7. In the Rotation section, select the Quaternion option.

 8. In the Perspective view, click the Show/Hide Camera button to see your camera cone.

 9. Setup your workspace to display the Camera view and Perspective view at the same time so you can com-
pare the results.

 10. In the Tools toolbar, select the Transform  tool.

 11. In the Timeline view, select the Camera-Peg layer first frame and select Insert > Keyframe.

 12. In the Timeline view, select the Camera-Peg layer.

 13. In the Timeline view, go to the last frame.
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 14. In the Perspective view, grab one of the rotation ellipses and rotate the camera on one axis only. Always 
do one axis at a time to keep control of the positioning.

 15. Once the camera is rotated at the correct angle, grab one of the direction arrows to move the camera to the 
correct position. A keyframe is automatically created in the Timeline view.
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Enabling the 3D Playback Mode
In order to see a playback of you animation in 3D, you need to turn on the option to see playbacks in the Perspective 
view.

How to enable the playback mode in 3D

 1. From the top menu, select Play > Enable Playback > Perspective View.

 2. In the Playback toolbar, click the Play button to see the results.
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Animating a Camera Shake Using the Quake Node
One very common camera move you will do is a camera shake. You can use the Quake node to generate an 
automated quake instead of manually entering random keyframes. This way, you can simulate the shock of 
something heavy falling on the ground, like an earthquake or a strong vibration.

How to use the Quake node to create a camera shake

 1. From the Node Library view, drag a Quake node to the Node view.

 2. If you do not have a Camera node already, drag one from the Node Library view to the Node view.

 3. Connect the Quake node to the Camera node.

 4. Click the Quake node's yellow square properties button to open the Quake properties.

 5. In the Quake properties window, adjust the following parameters:

 l Hold Time: Enter the number of frames you want one of the quake vibrations (position) to 
hold for. Most camera shakes are done in a single frame (1) or double frame (2).

 l Interpolate: An interpolation is generated between the random values. Instead of jumping to 
the next position, it will slowly progress forwards to the next position. It's the same principle 
as stop-motion keyframes and motion keyframes.

 l Move Amplitude: This is the strength of the quake. The higher the value, the stronger the 
quake. If the value is set to 0, there is no  motion. To have the motion start and stop at a spe-
cific frame during the scene, you can create a function curve and animate the amplitude over 
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time. Simply click the Function  button to generate the function, then click on it again to 
open the Function Editor.

 l Apply on X, Y, Z: Applies the quake to the X, Y and Z-axis.

 l Rotation Amplitude: When the value is higher than 0, a rotating quake is applied. The higher 
the value, the stronger the quake.

 l Random Seed: Generates a different randomization pattern. If you cascade two Quake nodes 
or more to apply a different amplitude on a different axis, you can change the Random Seed 
value to generate a different randomization pattern. If the X quake has a strong amplitude and 
the Y quake a weak amplitude and you do not want them to follow the same random pattern, 
then set the Random Seed value of the Quake nodes to different numbers.
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Animating the Line Thickness on Camera Move
As you move the camera in your scene along the Z-axis, notice that, logically, the lines of the elements become 
thicker the closer the camera gets to the drawing. If you prefer the lines to remain the same size or become 
thicker at a different speed, you can use the thickness feature to adjust your brush stroke and pencil line 
thickness. You can modify the size of the lines even if the camera is not animated.

NOTE: This feature can only be viewed in the Camera view's Render mode.

How to adjust the pencil line thickness of a drawing layer in the Camera view

 1. In the Timeline view, double-click on a drawing layer to display the Layer Properties window.

 2. Select the Advanced tab.

 3. In the Line Thickness section, adjust some of the following parameters until you achieve the desired 
effect.

 l Adjust Pencil Lines Thickness: Lets you work with pencil lines and adjust their thickness. 
You will not see any changes to lines in the Camera view OpenGL mode. You must switch 
to the Render mode.

 l Normal Thickness: Disables all overrides on the brush stroke line thickness. This option 
must be enabled in order for the pencil line thickness parameter and pencil lines to appear. If 
you want to modify the brush stroke thickness, deselect this option. To enable brush strokes 
to work with the line thickness feature, you must first create central strokes in the Colour Art 
layer. The central strokes control the line variation of your brush strokes in the Line Art layer. 
Select Drawing > Create Colour Art from Line Art.

 l Zoom Independent Thickness: Select this if you want your line thickness to remain con-
stant independently from the camera move. Everything else will increase in size, but the line 
thickness will stay the same.

 l Proportional: Enter a multiple by which you want to increase the line thickness base on its 
original thickness. A value of 1 will result in no change; a value of 0 (zero) will hide the lines.

 l Constant:  Enter a value in pixels (based on a 720x540 screen resolution) to indicate the 
amount of pixels you want to add around the existing line.

 l Minimum: Enter a value in pixels (based on a 720x540 screen resolution) for the minimum 
line thickness allowed.
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 l Maximum: Enter a value in pixels (based on a 720x540 screen resolution) for the maximum line 
thickness allowed.
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Chapter 20: Sound
With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing 
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to trim 
unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to continue 
throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best 
apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for your 
character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your animation 
based on the mouth chart.
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About the Sound  Editor
When you double-click on a sound layer in the Timeline view, the Sound Element Editor appears.

 l Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

 l Layer Name: This field displays the layer's name.

 l Sound Editor: This button opens the Sound editor.

 l Start Frame/End Frame: These fields determine the start and end frame of the sound file.

 l Detect: This button launches the automated lip-sync detection.

 l Map: This button opens the Map Lip-sync dialog box.

 l Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the 
thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Layer Properties
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer Properties 
view.
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Importing Sound
T-HFND-007-009

If you wish to add sound to your animation, you should first edit and mix your sound files in a sound editing 
software. It is recommended to mix down your sound into full length sound tracks so that you can work with the 
exact same sound track in the different applications used for your production. 

Sound can be clipped in Harmony if needed. Importing a soundtrack longer than your scene will not extend your 
scene's length. Sound playback will stop at the end of your scene's length.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files. It is recommended to work with .wav and .aiff files if 
possible. 

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

 l From the Xsheet menu, select File > Import > Sounds.

 l From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help you 
visualize at which frames the sound effects in your soundtrack occur. 

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by default. 
If you wish, you can display a sound column's waveform by right-clicking on it, then selecting Sound 
Display > Waveform.
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Playing Sound
T-HFND-007-010

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it through the 
Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the ones 
included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the unwanted 
sound by clicking the Disable Layer  button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you can do 
one of the following to troubleshoot the issue:

 l Shrink down the Camera view size to reduce the cached image size.

 l Playback your scene without sound first, then add the sound. If you do not cache the imahes first without 
sound, the playback will try to follow the sound by skipping images that will never get cached.

 l In the Preferences panel, in the OpenGL tab, reduce the size of the Playback Cache Size (in mb) preference.

How to play back sound

 1. To select a starting point:

 l In the Xsheet view, click on a cell in the sound column.

 l In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to 
the correct cell.

 2. In the Playback toolbar, activate the Enable Sound  button.

 3. Do one of the following:

 l Click the Play  button in the Playback toolbar.

 l From the top menu, select Play > Play or click on the Enter/Return key.

 4. To hear the sound played back again and again, do one of the following:

 l Click the Loop  button in the Playback toolbar 

 l From the top menu, select Play > Loop.

 5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer  button.
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Changing the Sound Display
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the Timeline 
View toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by 
default.

How to change the sound display in the Timeline view

 1. In the Timeline view's right area, right-click in the frame section and select Show Sound Waveforms or in 
the Timeline view menu, select View > Show > Show Sound Waveforms.

 l You can change the waveform scale using the Zoom Waveform  icon on individual sound layers in the 
Timeline view's left side.

How to change the sound display in the Xsheet view

 1. Right-click in the sound column or on the sound column header, and select Sound Display and one of the 
following:

 l Sound Name: Shows the name of the sound file, as well as the file format. The line running 
vertically through the column frames between the same file name indicates a continuity of 
the same sound file in these frames.

 l Mouth Shapes: Shows the letter (or name depending on the way you named your char-
acter's different mouth positions) in the column's frames. There is only one mouth position 
allotted per frame and this position should correspond to the sound file after performing a lip-
sync.

 l Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or zoom 
out on the waveform, or pass the scroll cursor  over the Zoom Waveform  icon.
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the 
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds 
from the Timeline view. 

How to scrub a sound from the Timeline view

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

 3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent sound 
frames. This allows you to do a more fluid scrubbing.
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About Analog Sound Scrubbing
Harmony is set to the digital sound scrubbing mode by default. This means that all sounds are played in real time. It 
also means that as you scrub over a frame, you will hear the section of your sound file that is allotted to that frame. 
As you are scrubbing, although it is accurate, the sound can sound clipped. It can also be difficult to hear nuances in 
pitch and tone. 

Harmony has an analog sound scrubbing option. When sound scrubbing in this mode, the sound is played back 
according to the speed that the playhead or jog is manually adjusted. Harmony's interface offers shuttle and jog 
sliders to perform analog sound scrubbing, however, external hardware and their corresponding software can be 
used in conjunction with Harmony for improved analog sound scrubbing results. 

NOTE: Refer to the device's manual to configure its functionality with Harmony.

Performing an Analog Sound Scrub in Harmony

Before you can perform an analog sound scrub in Harmony, you have to learn about the Shuttle and Jog controls.

 l Shuttle: Pull the Shuttle control backward or forward to make the red playhead in the Timeline view jump by 
large increments in the direction you are moving the shuttle.

 l Jog: Drag the Jog control to make the "dial" rotate. The Jog controls finer incremental movements along the 
soundwave. Use the Frame field to see the frame number which you are on. As you rotate the dial, your 
speed in fps appears directly after the FPS field. 
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How to perform an analog sound scrub

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. In the top menu, select Edit > Preferences (Windows) or Harmony Premium > Preferences (Mac OS 
X).

 3. In the Sound tab, select the Analog Sound Scrubbing option.

 4. Click OK.

 5. Do one of the following:

‣ In the Playback toolbar, use the Shuttle to find the general location of where you want to start your 
sound scrub. 

‣ In the Timeline view, drag the red playhead to the desired location.

 6. In the Playback toolbar, use the Jog to fine-tune your scrub to just a few frames.
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Editing Sound
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the sound 
editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of Harmony 
and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.

 l Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard when the 
final movie is rendered. It may be shorter than the original sound sample due to the length of the scene. If any 
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edits are made to the sound sample, they can be heard here. In the Sound Element panel, notice the col-
oured tabs that indicate the start and end frames of a sound segment. The frame number is displayed in 
the tab.

 l Current Sound: Displays the original sound file in its entirety and is where you can edit its properties. 
This window remains empty until you click inside the Sound Element Editor.

 l Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth pos-
itions to correspond with the sound sample. 
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Cropping Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make 
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame number is 
shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.

How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking 
the start and stop lines of each waveform section.

Click the Play  button in the Current Sound section (only the selected sound plays).

 3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to start play-
ing. 
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in 
the same element.

 4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

 5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element section.

If you only want to hear the selected clip, click the Play  button  in the Current Sound section.

 6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.
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Trimming Sound
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For 
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. This 
means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit sound 
files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking 
the start and stop lines of each waveform section. Or select a soundwave and click the Play  button in the 
Current Sound panel (only the selected sound plays).

 3. Using the Current Sound section, decide on the part of the file you want to play by dragging the left and right 
boundaries of the selection area.

 4. Click the Play  button in the Current Sound section to check that you have trimmed the desired sections. 
Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim it more accur-
ately.

 5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end positions you 
selected.
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Looping Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. From the Sound Element section, select the sound section you want to loop.

 3. In the Current Sound section, type the number of times you want the sound to play in the Number of Loops 
field.

 4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the 
next sound sample starts or until the scene ends. This means that the looping could be cut if the next 
sound sample starts too soon or if the scene ends too quickly.
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and 
fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original sound file 
is not affected.

How to adjust the overall volume of the entire sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. In the Sound Element section, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound section.

 3. In the Current Sound section, use the Volume slider to adjust the volume.

 4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. In the Sound Element section, select the sound you want to work on.

 3. In the Current Sound section, click on the thin blue line above the waveform to add an envelope marker.

 4. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The line 
from the edge of the clip to the envelope marker identifies how the volume increases (fades-in) or decreases 
(fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards increases the 
volume. 
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NOTE: To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right 
(bottom and top) channels.

 5. Click the Play  button in the Current Sound panel to check the fade envelopes.
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Setting the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start or 
stop at specific frames. This customized playback range does not affect the actual sound in the Sound element. 

How to change the playback range in the Sound Element editor 

 1. Drag the start or end range markers in the Sound Element section to the boundary frames you want.

 2. When you click the Play  button to play back your sound in the Sound Element editor, it only plays the 
sound which exists between the two markers.
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Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For 
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist 
on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-quarter view 
and have mouth position changes to fit with the sound sample from these two different views, you would need to 
cut up the sound samples needed for the profile view mouth positions on one layer and the sound samples needed 
for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

 1. In the Timeline Layer toolbar, click the Add Layer button.

 2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

 3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound Element 
editor. Click Apply/Next to accept the change.

1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut and Shift 
+ click on the final cell of the cut. The sample to be cut becomes highlighted.
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2. Drag the selection into the empty sound layer below.

 4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the lip-
synching process for each layer and its corresponding facial view.

NOTE: If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate Selec-
ted Layers button in the Timeline View toolbar. You must customize the toolbar to display this button because it 
is not included in this toolbar by default.
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About Lip-sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE: The letters assigned to these mouth shapes are standard identifiers, they NOT correspond to the 
sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated with 
the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, your 
character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and these 
drawings should be named by their corresponding letter. 
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, Xsheet 
view and Sound Element editor.

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice 
track. 
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 5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

 7. Click OK.

 8. In the Playback toolbar, enable the Enable Sound  option.

 9. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view

How to generate a  sound detection for lip-sync in the Xsheet or Timeline view

 1. Do one of the following: 

 l In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-Sync > 
Auto Lip-Sync Detection. 

 l From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

NOTE: To show the mouth chart letters, if they're not already present in the Xsheet view, right-click on the 
sound column and select Lip-Sync > Sound Display > Mouth Shapes. 

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. The X markers in 
the frame are replaced by these designated letters.
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How to generate a sound detection for lip-sync using the Sound Element editor

 1. Do one of the following:

 l In the Timeline view, double-click on the sound layer.

 l In  the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.

 2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

 3. Right-click on the sound file and select Auto Lip-Sync Detection.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.
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Mapping the Lip-Sync Detection
Harmony can automatically map Automatically maps drawings in an element to the mouth chart you have 
generated for a sound. This can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically labels 
all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

 1. To open the Lip-Sync Mapping dialog box, do one of the following:

‣ In the Layer Properties view, click on the Map button.

‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-
Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

 2. From the Destination Layer menu, select the layer that contains the mouth positions for the character's 
voice track. 

 3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
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Modifying the Lip-sync Detection
You can change the mouth position assigned to a frame if you think another position is more appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would 
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in 
astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the Lip-Sync 
Detection on page 1310.

How to change the mouth position assignment of a sound from the Sound Element editor and Layer Prop-
erties view

 1. Double-click the sound layer name in the Timeline view or the sound column header in the Xsheet view to 
open the Sound Element editor.

 2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth position 
assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current frame. 

1. To change the image assigned to the frame, click on the image of the mouth position you want from below the 
preview image. The preview image changes to the mouth position image you select. You can perform the 
same operation in the Layer Properties view.

The position is updated in the Timeline and Xsheet views.

How to change the lip assignment of a sound in the Xsheet or Timeline view

1. Right-click in the cell that contains the mouth position you want to change.

2. From the pop-up menu, select Lip-Sync > Change Mouth Shape to and choose the letter that reflects the 
mouth position you want to use for that sound. You can also select Animation > Lip-Sync > Change Mouth 
Shape > the desired mouth shape from the top menu.
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NOTE: Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.
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Manual Lip-syncing
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, which 
plays the part of your sound track at the current frame whenever you move your Timeline cursor, allowing you to 
identify which phonemes you should match your character's mouth to. You will also be using drawing substitution to 
change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for 
an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing name 
(often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing auto-
matically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for 
an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The current 
drawing is swapped for the one in the preview window.
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, such as 
an editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of individual 
files. The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

 2. In the Output section, click Browse and specify where you want to save the exported sound file.

 3. In the Export Range section, select one of the following options:

 l All: Exports the sound over all the frames of your scene.

 l Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

 l Process Soundtracks Individually: Each soundtrack from all layers is exported as indi-
vidual files.

 l Merge all Soundtracks: One single file is created, combining all the sound files you impor-
ted in your scene. Note that it will only use the sound files in the selected frame range set in 
the Export Range section. If you selected to export all the frames, all the sound files will be 
processed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is 
a good idea to verify what is required by the software or device that  you may want to use next with the 
sound file.

 6. Click OK.
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The generated sound files appear in the selected directory and are named according to the scene name. 
Individual files keep their original name; only a prefix matching the scene name is added.
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Chapter 21: Effects
T-HFND-010-001

When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs, 
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the way 
layers or groups of layers are rendered in your scene. 

Harmony supports OpenFX plugins, and has its own integrated particle systems as well as light shading (normal 
map)—see About OpenFX on page 1395, About the Light Shading Effect on page 1377, and About Particles on page 
1403.

Effects are special types of nodes that you can add to your scene's structure. For an effect node to work, it must be 
connected to a drawing or a composite. Effects only alter the drawing or composite they are connected to, which 
gives you flexibility in deciding precisely which parts of your scene is affected.

Some effects need to be linked to another layer referred to as the matte layer, which is used to define the area they 
should affect. The most basic example of this is the Cutter effect. Alone, a cutter effect does not have any effect on 
your drawing. Once combined with a matte layer, the Cutter effect cuts the shape of the matte out of the drawing. 
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A matte layer is simply a drawing layer that is connected to an effect as its matte. The effect takes the shape of 
the drawing in the matte layer, ignoring its colours and details. 

In the Node view, an effect must be connected to the drawing or composite it is meant to affect by its input (top) 
port, and its output (bottom) port must be connected to the composite. Most effects that require a matte must be 
connected to their drawing layer by their right input port, and to their matte layer by their left input port, like this:

Once your effect is connected, you can adjust its parameters using the Layer Properties view. If desired, you can 
even animate the parameters of your effect by converting their values to functions. 

NOTE: If you need to use the uncut version of your drawing layer anywhere else in your scene, you can 
bypass the effect it is connected to by connecting the drawing layer's output port to other input ports of your 
composite, or to other effects or composite, as needed. This will create new cables, leaving your layer's con-
nection to its effect unaffected.
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Adding Effects Nodes
T-HFND-010-004

In Harmony, you can add effects through the Node view. You can select an effect from the Node Library view, drag it 
to the Node view and connect it to drawing layers to form a network of nodes. Then, by adjusting each node's 
parameters, you can achieve exactly the look you have in mind.

Although all effects should be added through the Node view, there are some effects that you can also quickly add 
through the Timeline view. 

How to add an effect in the Node view

 1. In the Node Library view, select an effect and drag it to the Node view. You can use the Search toolbar to find 
nodes quicker.

 l You can also right-click in the Node view, and select Insert > category > node.
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Connecting Effects
T-HFND-010-006

You can connect layers to effects that have a single input or multiple input, such as effects using masks.

How to connect an effect in the Node view

 1. To bring a node into the Node view, drag it from the Node Library and drop it in the Node view.

 2. Once in the Node view, click on the output port of a node and drag out a cable. You can then connect this 
cable to the input port of another node.

 l If you want to connect a node between two connected nodes, you can use the Alt key as 
you drag the new node over the existing cable connection. Using the same Alt key, you can 
also disconnect a node.

 l If you want to remove a node, select and press Delete to remove it from the Node view.

How to connect effects with more than one port

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select  an effect with more than one port, such as Highlight and 
drag it to the Node view. 
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 l In the Node view, right-click and select Insert > Combine > Highlight. 

 2. Connect the  node (Highlight in this example) between the drawing and Composite node.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

 5. Do one of the following:

 l Drag and drop the matte layer beside the Matte field.
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 l Connect the Matte drawing to the Matte port of the Highlight node.

 6. Display the effect properties and adjust them until you achieve the desired effect.
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About Node Categories
Customizing the categories is a great way to organize the nodes according to how you like to work and the nodes 
you use most often. You can easily add categories and subcategories, remove categories you don't use, and 
rename categories.

Displaying All Nodes 1324

Adding a Node Library View Category 1325

Removing a Node Library View Category 1327

Renaming a Library View Category 1328

Adding Nodes to Categories 1329

Removing Nodes from Categories 1330

Searching for Nodes, Categories, and Descriptions 1331
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Displaying All Nodes
You can display all the nodes available in the Node Library view.

How to display all the nodes

 1. If a category is selected and you want to see all the nodes available in the library, in the Node Library view, 
place your cursor in the Node Search field.

The Node Library view displays all the nodes.
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Adding a Node Library View Category
You can add a Node Library view category to organize your most commonly used nodes or group them in a more 
convenient way to your pipeline.

How to add a category

 1. Do one of the following:

 l To create a new main category, click in the Node Search field.

 l To create a subcategory, select a category.

 2. Do one of the following:

 l From the Node Library menu, select New Category.

 l Right-click in the category area and select New Category.

The New Category window displays.

 3. In the New Category window, type in the name of a new category and click OK.

The new category appears in the Category list. Now you can add nodes to your new category—see Adding a 
Node Library View Category on page 1325.
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Removing a Node Library View Category
You can remove custom categories you are not using in the Node Library view.

How to remove categories

 1. From the Category list, select a category to remove.

 2. Do one of the following:

 l From the Node Library menu, select Remove Category.

 l Right-click in the category area and select Remove Category.

The Confirm Remove Category window displays.

 3. Click Yes.
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Renaming a Library View Category
You can rename a Node Library view category to keep it organized.

How to rename categories

 1. From the Category list, select a category to rename.

 2. Do one of the following:

 l From the Node Library menu, select Rename Category.

 l Right-click in the category area and select Rename Category.

The Confirm Rename Category window displays.

 3. Type in a new name for the category and click OK.
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Adding Nodes to Categories
Once you've created a category, you can add nodes to it for easy access. Later on, you can go back and remove any 
nodes you no longer use. You can only add and remove nodes from a category you created.

When you add a node to a new category, it is essentially a copy of the node. The node in its default location remains 
there. You cannot delete nodes from their default categories or move them.

How to add nodes

 1. Select a node from any category and drag it to a category you created.

A copy of the selected node is added to your new category.
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Removing Nodes from Categories
You can remove nodes you no longer use from custom categories.

How to remove nodes

 1. Select a node from a category you created.

NOTE: Nodes from the default categories cannot be removed.

 2. Do one of the following:

 l From the Node Library menu, select Remove Node.

 l Right-click in the category area and select Remove Node.

 l Press Delete.

The node is removed from the category. 
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Searching for Nodes, Categories, and Descriptions
Sometimes it's faster to type in the name of a node instead of looking through all the categories. You can also search 
for category names or descriptions as well. Once you type in the name of a node, description or category in the Node 
Search tool, it is displayed in the library. Sometimes the result of a node search is in one or more categories for 
convenience. 

How to search for nodes

 1. In the Node Library, place your cursor in the Node Search field.

The Node Library view displays all the nodes.

 2. Type in the name of a node, category or description.

Depending on how you are viewing the nodes, the Node Library view displays the node, categories and/or 
description you typed in.  

 3. To return to displaying all the nodes, place your cursor in the Node Search field again and delete the node 
name in the Search field.
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About Effects Preview
T-HFND-010-010

Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL 
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter, 
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered 
automatically, deselect the Auto-Render option and do the preview update manually.

You might also need to play back your animation and see the final effect before final rendering. But first, you must 
connect a Render Preview node to each effect.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see your 
animation with the final effects or use a Render Preview node for each effect.  Effects must be calculated before 
they can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the 
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a 
check preview.
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Previewing Effects in Render Mode
T-HFND-010-011

You can preview a single final frames with all effects calculated in the Camera view when you enable the Render 
mode. You cannot playback your animation in Render mode. You can also disable the auto-render option when 
adjusting several effect parameters to avoid slowing down your computer.

How to preview effects in Render mode

 1. In the Camera view status bar, click the Render Mode  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render. Depending 
on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

 1. In the Camera view status bar, click the Auto-Render  button. In the top menu, you can enable and disable 
Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the Auto-Render 
 button.

How to manually update the rendering preview

 1. In the Camera view status bar, click the Render button.
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Previewing Effects in OpenGL Mode
If you want to playback your animation and see rendered effects, you can use the Preview node to see your 
effects in the Camera view OpenGL mode.

How to preview effects in OpenGL mode 

 1. To adjust the effect's visual controls in OpenGL mode, from the Node Library view, drag a Render Preview 
node to the Node view. Connect it between the effect and the Composite nodes.

 2. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

As you modify the effect's parameters and controls, the frames are rendered to ensure a real-time 
playback. The larger the resolution and the heavier the effect, the longer the rendering process will take. 
Green frames are rendered, red frames are pending and yellow frames are rendering.

 3. To display the controls, select the node in the Node view,  and do one of the following:

‣ In the Camera View toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

The controls appear.
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 4. In the Tools toolbar, select the Transform  tool or press Shift + T.

 5. In the Camera view, adjust the controls.

 6. To set the preview parameters, click the yellow square properties button on the Preview Render node.

The Preview Render properties display.

Parameter Description

Name Allows you to change the node's name.

Preview Resolution
Lets you  set the resolution used to generate the preview. Res-
olutions range from 1/4 to 1/64th of the scene resolution. 

Outdated Images Mode

Do Not Render: Does not render any effects in your scene.

Show Without Effects: Shows the outdated images without any 
effect.

Use Previously Rendered: Uses the previously rendered images. 
The old images will be used until the new ones are rendered.

Pre-render Next Frames Starts a pre-render job for every frame of the timeline.
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Playing Back Effects
T-HFND-010-012

To playback your effects, you need to do a temporary render.

How to play back effects

 1. In the Playback toolbar, click the Render and Play  button.

The Play node opens and loads the frames.

 2. Once the frames are loaded, click the Play  button in the Play window.

 3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE: While previewing effects, you can press the Spacebar to stop and start playback.
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Changing the Preview Resolution
The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or one-quarter 
of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command

 1. From the top menu, select View > Preview Resolution and one of the following: 

‣ Same as Scene Resolution

‣ 3/4 of Scene Resolution

‣ 1/2 of Scene Resolution

‣ 1/3 of Scene Resolution

‣ 1/4 of Scene Resolution 

‣ Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.

 2. In the dialog box, select a resolution from the presets or type a new X-Y value.

 3. Click OK.

 4. Preview your effects animation.
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Animating an Effect
In some cases, you may want to have the intensity,  color, or another parameter of an effect animated.  For 
example, you may want an object to fade in or out, which would require making its transparency level animated so 
that it increases or decreases as your scene goes. You can animate an effect's parameters by creating a function 
curve for its parameter. You can then add keyframes to the function and set them to different values, hence 
making your effect's parameter change value as your scene plays out. To do this, you will need to use the Layer 
Properties view.

How to animate an effect

 1. Add an effect node to the Node view by doing one of the following: 

 l Right-click in the Node view and select Insert > desired effect.

 l Drag a node from the Node Library view to the Node view.

 2. Connect the effect between the drawing element on which you want to apply the effect and a composite 
node. You can do this by manually unplugging your existing connections and creating the right con-
nections, or you can simply hold Alt as you drag your effect node over the connection between the drawing 
and the composite to automatically insert it in the connection.

The effect also appears in the Timeline view.
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 3. Create the function curve by doing one of the following:

 l Double-click on the effect layer to display the effect properties. Click the Function  button of 
the parameter you want to animate and create a function curve.

 l In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand  
button. Then click the Function  button of the parameter you want to animate and create a 
function curve.

 4. In the Timeline view, go to the frame on which you want to start animating the effect.

 5. In the Timeline toolbar, click the Add Keyframe  button.

 6. In the Value field of the parameter you want to animate, enter the keyframe value. If your keyframes are stop-
motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set Motion Key-
frame.
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 7. Repeat these steps until your effect's animation is complete.

NOTE: Refer to About Effects Preview on page 1332 to learn how to preview animated effects.
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About Advanced Node Usage
Some nodes only require to be connected to a drawing node, others require additional operations and connections. In 
this section you can see how to use some of the most common effects. You can also refer to the Nodes section in 
the Reference guide to learn more about each node—see the Reference guide .

Using the Shadow Node 1342

Using the Cutter Node 1345

Using the Highlight Node 1347

Using the Tone Node 1349

Using the Greyscale Matte Port 1351

Using the Blur Radial Zoom Effect 1353

Overriding a Colour 1358

Overriding a Colour With a Texture 1360

Modifying a Texture Fill's Transformation 1366

Overriding a Colour with a Bitmap Image Sequence 1369

Overriding a Texture on a Pencil Line 1371
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Using the Shadow Node 
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and 
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of 
the shadow. 

To add a shadow stretched out on the ground, simply add a Quadmap node to flip, stretch and skew the matte. 
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your 
character—see the Reference guide . 

NOTE: Don't forget that you need to connect your character in both the final Composite node and 
the Shadow effect if you want to see your character and its shadow.

To avoid duplicating the artwork or an entire set of nodes, you can drag a second connection from the image or 
group you wan to cast a shadow for and use the Peg-Apply node to offset it using a Quadmap node—see the 
Reference guide . 

How to use the Shadow effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Shadow effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Shadow. 

 2. Connect the Shadow node between the drawing and Composite node.
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 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

1. Do one of the following:

 l Drag and drop the matte layer beside the Matte field.

 l Connect the Matte drawing to the Matte port of the Shadow node.
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 5. Display the Shadow properties and adjust the properties to control the type and amount of blur and the col-
our of the tone effect.
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Using the Cutter Node 
You can use the Cutter node to cut out parts of a layer. You can also use it to only show certain parts of a layer by 
enabling its Inverted parameter.

How to use the Cutter effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Cutter effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Cutter. 

 2. Connect the Cutter node between the Drawing and Composite nodes.

 3. In the Timeline view, create a new layer, which will be used as your Cutter effect's Matte layer.

 4. In your new Matte layer, draw the shape that you want to cut out from your drawing layer. 

 5. Connect the Matte drawing to the Matte port of the Cutter node.
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 6. If you want to invert the Cutter's effect, double-click on your Cutter layer to open its Layer Properties dia-
log, then enable the Inverted option. 
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Using the Highlight Node
You can use the Highlight node to create light zones of your artwork. Anything outside of the given artwork will be 
automatically clipped. 

How to use the Highlight effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Highlight effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Highlight. 

 2. Connect the Highlight node between the drawing and Composite node.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

 5. Do one of the following:

 l Drag and drop the matte layer beside the Matte field.
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 l Connect the Matte drawing to the Matte port of the Highlight node.

 2. Display the Highlight properties and adjust the properties to control the type and amount of 
blur and the colour of the highlight effect—see the Reference guide .
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Using the Tone Node
You can use the Tone node to create shadow zones of your artwork. Anything outside of the given artwork will be 
automatically clipped. 

How to use the Tone effect

 1. Select a drawing layer and do one of the following:

 l From the Node Library view, select the Tone effect and drag it to the Node view. 

 l In the Node view, right-click and select Insert > Combine > Tone. 

 2. Connect the Tone node between the drawing and Composite node.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

 5. Do one of the following:

 l Drag and drop the matte layer beside the Matte field.
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 l Connect the Matte drawing to the Matte port of the Tone node.

 6. Display the Tone properties and adjust the properties to control the type and amount of blur and the colour 
of the tone effect—see the Reference guide .
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Using the Greyscale Matte Port
Here is an example on how to use the Matte Output option of the Greyscale node. A frosted window was created 
using a snowflake image over a blue rectangle and a colourful background.

Here are the three drawings used for the example:

When the snowflake image is connected into the Greyscale node, it turns into a greyscale image. There is no 
transparency visible in the Camera view Matte View mode.

When the Matte Output option is enabled, the snowflake image colours are displayed as normal, but when the Matte 
View mode of the Camera view is enabled, you can see the transparency levels generated from the colour values. 

When you connect the Snowflake images into a Cutter effect's Matte port along with the Window images, the 
window will be semitransparent, matching the alpha (transparency) channel generated by the Greyscale node.
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NOTE: To learn more about the Greyscale filter, see the Reference guide .
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Using the Blur Radial Zoom Effect
The Blur - Radial Zoom effect creates blurs around a centre point, simulating the look of a zooming or rotating 
camera. You can use a matte to isolate the area of the image from which you want the effect to radiate from. For 
example, in the illustration below, a circular matte was created to mask the eyeball and a Negate effect was applied 
so the blur is outside the matte. Then the centre point was positioned on the character's iris, which is the centre of 
the matte.

For detailed video tutorials and sample scenes by Adam Phillips, see toonboom.com/resources/video-
tutorials/chapter/adam-phillips-harmony-effects.

To learn about the Blur Radial Zoom parameters, see the Reference guide .

How to use the Blur Radial Zoom

 1. In the Camera view, enable the Render mode.

 2. From the Node Library view, drag a Blur Radial Zoom node to the Node view.

 3. Connect your drawing to the Blur Radial Zoom's right port.

 4. Connect the Blur Radial Zoom node to the Composite node.
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 5. On  the Blur Radial Zoom node, click the yellow square properties button to open its property editor.

 6. In the Layer Properties windowo, increase the Blurriness value.

 7. In the Direction section, click on any of the direction presets to modify the blur spin or zoom.

How to create a radial-zoom blur around an isolated area

 1. Connect a drawing and a background image to a Composite node.

 2. Connect the Composite node to the Blur-Radial Zoom node.
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 3. Connect a Blur-Radial-Zoom node to the Composite node and add the Write and Display nodes.

 4. Create a matte to isolate an area of the image. In the Timeline view, click the Add Layers  button and 
select Drawing. Give the layer a name, such as Mask.

 5. In the Drawing view, draw a filled shape. 

 6. The blur should radiate outwards from the mask. To do this, connect a Negate node to the mask. In the Neg-
ate properties, select the Negate Colour and Negate Alpha options. Deselect the Negate Colour Clamp 
to Alpha option. 
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 7. Connect these nodes to the rest of the tree. Your node structure should look like this:

 8. In the Blur - Radial Zoom property editor, Center section,  select one of the following options:

 l 2D Path: Lets you move the centre point visually in the Camera view.

 l Separate: Lets you control the x and y axis by entering values in the fields or by moving the 
centre point in the Camera view.

 9. Set a value for the Blurriness.

 10. With the Blur - Radial Zoom node selected in the Node view, select View > Show > Control or press Shift 
+ F11. 

A red centre point appears in the centre of the Camera view.
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 11. In the Tools toolbar, select the Transform  tool.

 12. Click the Animate Mode  button in the Tools toolbar if you want to create function curves to keyframe over 
time. Otherwise, values will be created for the duration of the scene.

 13. Move the centre point to the desired position. In our example, the centre was moved to the centre of the 
mask.

 14. In the Node view, select the mask you created. 

 15. In the Camera view, move the mask to the desired position.

 16. Continue to adjust the blur values until you achieve the desired effect.
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Overriding a Colour
With the Colour-Override node, you can change the colour of some swatches.

How to override colours

1. From the Colours section, select the colour swatch to modify and move it to the Individual Colour 
Overrides section. Several options are available to modify your colours.

2. Once the swatch appears in the Colour-Overrides section, click the drop-down arrow and select one of the 
following options from the Mode menu:

 l Override colour: When selecting a colour swatch from a clone palette (not set as the cur-
rent palette), use this option to override the current colour and use the swatch from the clone 
palette over the corresponding one in the current palette.

 l Colour Not Visible: Renders the selected colour invisible in the Camera view.

 l New RGB Only: Overrides the colour swatch RGB value while maintaining its original alpha 
value. You can select a new colour by clicking on the colour swatch and choosing a new col-
our from the Colour Picker window.

 l New Alpha Only: Overrides the swatch's alpha channel while maintaining its original RGB 
values. You can select a new alpha value by clicking on the colour swatch and choosing an 
alpha value from the Colour Picker window.
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 l New RGBA: Overrides the swatch's colour and alpha values. You can select a new colour by  
clicking on the colour swatch and choosing an alpha value from the Colour Picker window.
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Overriding a Colour With a Texture
With the Colour Override node, you can apply a texture over a selected colour. Any zone painted with the 
selected colour swatch will be overridden by the selected texture.

There are different ways to apply the texture over your colour:

NOTE: The result will only be visible in the Camera view in Render mode. In OpenGL mode, you will see the 
original colour.
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The matrix position can be modified using the Edit Gradient and Texture  tool. To do so, your drawing zone must 
be painted with a gradient swatch or texture swatch.

Texture - Original Matrix

Overrides the swatch's colour with a pattern or texture. You must right-click under the Texture header to bring up the 
Browser window to search for your texture. The texture's default matrix (fixed proportion and orientation) is mapped 
to the full size of the bounding box of each colour area to be overridden.

Texture - Global Bbox Matrix

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box encompassing 
the colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut from 
the same piece of stretched or squashed fabric.

Texture - Global Bbox Centered
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Overrides the colour with a texture that is scaled proportionally to the size of the bounding box encompassing all 
colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut from 
the same piece of fabric.

Texture - Contour Bbox Matrix

Overrides the colour with a disproportionately scaled texture for each individual colour area. In other words, each 
fill area will not only have the texture scaled to its individual proportions, but also stretched or squashed to fit 
within its contours.

Texture - Scale to Screen

Disproportionately scales the texture to the output resolution before applying it as an override.

Modulate Pencil Texture Colour (Replace Transformation)

Overrides the initial texture fill's transformation (matrix) established when you painted the line or modified it with 
the Edit Gradient and Texture  tool. This transformation override will be done by modifying the Peg's position.

Modulate Pencil Texture Colour (Combine Transformation)

Combines the initial texture fill's transformation (matrix) established when you drew the line or modified it with the 
Edit Gradient and Texture  tool with the new position transformation you will create when modifying the Peg's 
position.
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Override with This Texture Centered on Overridden Objects' Centre

Overrides the colour with a texture that is centered in the bounding box encompassing all colour areas to be 
overridden. With multiple objects, it will look as though their fills were all traced and cut from the same piece of 
fabric. The texture will not be stretched or distorted. It will be tiled in proportion. The centre of the texture zone will be 
centered in the middle of the bounding box's centre.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position. The 
advantage of being able to animate the texture is that it can be adjusted, scaled, rotated and translated to follow the 
general motion of a character if you want the texture to follow instead of having the character moving across the 
fixed texture—see How to animate a texture override with a peg on page 1364.

Texture - Use Input Peg

Overrides the colour with a texture that is scaled non-proportionally to the size of the bounding box encompassing 
the colour areas to be overridden. With multiple objects, it will look as though their fills were all traced and cut from 
the same piece of stretched or squashed fabric.

With this option, you can connect a Peg in the middle port to apply a transformation on the texture's position.

Textures - Use Input Image

How to apply a texture over a colour

 1. From the Colours section, select the colour swatch to override and drag it to the Individual Colour Overrides 
section.

 2. Once the swatch appears in the Individual Colour Overrides section, select it and then click on the  Mode 
drop-down button  and select one of the following options:

 l Texture - Original Matrix
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 l Texture - Global Bbox Matrix

 l Texture - Global Bbox Centered

 l Texture - Contour Bbox Matrix

 l Texture - Scale to Screen

 l Override With This Texture Centered on Overridden Objects Centre

 l Texture - Use Input Peg

 l Texture - Use Image Image

The Browse  icon appears in the New column.

 3. In the Colour-Override section, in the New column, click the Browse  icon to select your custom tex-
ture.

 4. Browse for your texture file.

 5. Click Open.

 6. If you want to select a new texture to replace the existing one, click the Browse  button again and 
select a new one to replace the existing one.

How to animate a texture override with a peg

 1. From the Node Library view, drag a Peg node to  the Node view.
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 2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of the 
Peg to modify the texture's position.

 3. In the Node view, select the Peg node.

 4. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 5. In the Camera view bottom toolbar, enable the Render  mode.

 6. In the Camera view, move the Peg's position. As you move it, you can see the texture being modified. You 
can animate the position by adding position keyframes in the Timeline view. You can use the Random Fill 
function to quickly create a random shake.
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Modifying a Texture Fill's Transformation
When you paint a zone with a bitmap texture swatch, you may want to modify the size or position of the texture's 
matrix at the compositing level. For example, you may want to do this to animate the position of the texture in a 
zone. With the Colour-Override and a Peg node, you can animate the texture.

How to modify a texture fill's transformation

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

 1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line 
for. Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set 
as Pass-Through.

 2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of 
the Peg to modify the texture's position.

 3. Click the Colour-Override's square yellow properties button to open its property editor.

 4. In the Palettes section, select the palette containing the bitmap texture swatch.

 5. In the Colours section, select the texture swatch you used to paint the drawing and drag it to the Individual 
Colour Overrides section.
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 6. Once the swatch appears in the Individual Colour Overrides section, select it and then click the Override 
Mode button and select one of the following:

 l Override the colour's transformation: Overrides the initial texture's transformation (matrix) 
established when you painted the zones or modified with the Edit Gradient and Texture  tool. 
This transformation override will be done by modifying the Peg's position.

 l Combine the colour's transformation: Combines the initial texture's transformation (matrix) 
established when you painted the zones or modified with the Edit Gradient and Texture  tool 
with the new position transformation you will create when modifying the Peg's position.

 7. In the Node view, select the Peg node.

 8. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 9. In the Camera view bottom toolbar, enable the Render  mode.

 10. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being modified. 
You can animate the position by adding position keyframes in the Timeline view.
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Overriding a Colour with a Bitmap Image Sequence
In production, you may need to map a live action sequence or bitmap image sequence into a zone or over several 
zones. For example, you could have a mirror shattered into several pieces and you want to map video or someone 
talking into those pieces. You can paint the mirror pieces with a specific colour swatch and use the Colour-Override 
node to map the image sequence into the pieces. It can also be a single image without having to be an image 
sequence.

To learn how to modify a texture's exposure based on an animation or character's motion, see About Exposure Fill 
Using Render Change on page 1408.

How to override a colour with a bitmap image sequence

 1. From the Node Library view, drag a Colour-Override node to the Node view.

 2. In the Node view, connect the Colour-Override node under the drawing node that contains the line you want to 
animate.

 3. Connect the Live Action or Bitmap Image Sequence node in the Colour-Override's left port. The blue left port 
will input the images into the colour zones. Note that your image sequence's exposure needs to span over all 
the frames you it to be visible for. If there is not images exposed, the colour will not be overridden when 
frames are blank.

 4. Click the Colour-Override's square yellow button to open its property editor.

 5. In the Colour-Override window, in the Palettes section, select the palette containing the colour to override.

 6. In the Colours section, select the pencil texture used to draw your lines and drag it to the Colour-Override sec-
tion.
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 7. Once the swatch appears in the Colour-Override section, select it and then click the Override Mode button 
and select Texture - Use Image Input.

 8. In the Node view, select the bitmap image node.

 9. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 10. In the Camera view bottom toolbar, enable the Render  mode.

 11. In the Camera view, move the Bitmap Image position. As you move it, you will see the texture fills being 
modified. You can animate the position by adding position keyframes in the Timeline view.
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Overriding a Texture on a Pencil Line
A pencil line can be drawn with a texture but also painted with a texture swatch. With the Colour-Override node, you 
can override the pencil line's texture or texture fill and replace it by another one, or you can animate the texture's 
position.

With the Edit Gradient and Texture  tool, you can modify the size and position for both types of textures on a 
pencil line; the drawing texture and the filling texture. By doing that, you are actually modifying the texture's matrix.

When you paint a pencil line with a bitmap colour swatch, you can override the position of the texture fill using the 
Colour-Override node and a Peg. 

You can modify and animate a pencil texture's position using the Colour-Override node and a Peg node. This lets 
you create a shaky line style which is a very popular design style. The main issue with this style is that it works well 
in traditional and tradigital animation, when the artist draws the line differently on each drawing, but it does not work 
in cut-out animation where the same drawing is used for the entire animation. The same issue happens when the 
same drawing is held for more than a few frames. The line moves during the animation, but stops moving during the 
drawing hold, which looks bad.
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With the Colour-Override node, you can animate the position of the pencil line texture independently from the 
drawing exposure. Even if a drawing's exposure is held over several frames, the line will move.

How to modify the pencil line texture

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.

1. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line 
for. Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set 
as Pass-Through.

 2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of 
the Peg to modify the texture's position.

 3. Click the Colour-Override's square yellow properties button to open its property editor.

 4. In the Palettes section, select the palette containing the colour to override.

 5. In the Colours section, select the bitmap texture swatch you used to paint your lines and drag it to the Indi-
vidual Colour Overrides section.
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 6. Once the swatch appears, select it and then click on the Override Mode  button. Select one of the following 
options from the drop-down menu:

 l Modulate Pencil Texture Colour (replace transformation): Overrides the initial texture fill's 
transformation (matrix) established when you painted the line or modified it with the Edit Gradi-
ent and Texture  tool. This transformation override will be done by modifying the Peg's pos-
ition.

 l Modulate Pencil Texture Colour (combine transformation): Combines the initial texture 
fill's transformation (matrix) established when you drew the line or modified it with the Edit 
Gradient and Texture  tool with the new position transformation you will create when modi-
fying the Peg's position.

 7. In the Node view, select the Peg node.

 8. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 9. In the Camera view bottom toolbar, enable the Render  mode.

 10. In the Camera view, move the Peg's position. As you move it, you will see the texture fills being modified. 
You can animate the position by adding position keyframes in the Timeline view.

How to modify the pencil line texture

 1. From the Node Library view, drag a Colour-Override node and a Peg node to the Node view.
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2. In the Node view, connect the Colour-Override node under the Drawing node you want to animate the line 
for. Note that for a cut-out puppet, you would connect the Colour-Override under the final Composite, set 
as Pass-Through.

 2. Connect the Peg node in the Colour Override's middle port. The green port will take the transformation of 
the Peg to modify the texture's position.

 3. Click the Colour-Override's square yellow properties button to open its property editor.

 4. In the Palettes section, select the penstyle_opacity palette.

 5. In the Colours section, select the pencil texture used to draw your lines and drag it to the Individual Colour 
Overrides section.
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 6. When the swatch appears in the Individual Colour Overrides section, select it and click the 
Override Mode  button. Select one of the following:

 l Change Pencil Texture Transformation: Overrides the initial pencil texture's transformation (matrix) 
established when you drew the line or modified with the Edit Gradient and Texture  tool. This trans-
formation override will be done by modifying the Peg's position.

 l Modulate Pencil Texture Matrix: Combines the initial pencil texture's transformation (matrix) that 
was established when you drew the line or modified with the Edit Gradient and Texture  tool with 
the new position transformation you will create when modifying the Peg's position.

 7. In the Node view, select the Peg node.

 8. In the Advanced Animation toolbar, select the Translate , Rotate  or Scale  tool.

 9. In the Camera view bottom toolbar, enable the Render  mode.

 10. In the Camera view, move the Peg's position. As you move it, you will see the pencil texture being modified. 
You can animate the position by adding position keyframes in the Timeline view. You can use the Random 
Fill function to quickly create a random shake. 
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About the Light Shading Effect

Cut-out animation allows for great advancements and time saving in production, but it has certain limitations. One of 
the main advantages of using a cut-out puppet is the ability to reuse your characters without having to redraw them 
and you can modify your animations very quickly. This speeds up the process quite a bit. One of the disadvantages 
of cut-out animation when wanting to retain the time saving factor and ability to quickly modify an animation, is the 
fact that you cannot easily create tones and highlights. To do so, you must draw all the highlight zones for each 
frame by hand. Following that, if you want to modify your animation, you have to redraw those zones. This slows 
down the process. There are a few tricks for doing simple automated highlights, but the results are not always 
convincing.

The Harmony Light Shading effect provides a proper solution to this issue. It allows you to add a few nodes to your 
original puppet rig and obtain a customizable lighting effect on your characters. It can be applied to any object in your 
scene, not only on cut-out characters. The light shading effect allows you to define your volume zones as well as 
your light source and animate its position. 

In Harmony, all drawings are flat 2D planes, unless you imported 3D elements. A light source cannot interact well 
with a flat shape to create tone and highlight areas within it. To create shading zones, Harmony uses the bevel 
principle to create a three-dimensional shape illusion. To do that, you must define which object or combination of 
objects should be defined as a volume. Next, you can carve and emboss areas  using colour zones within the 
volumes to create what is referred to as 3D geometry.
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If you have a scene with one single drawing layer, you will define that layer as your volume object, since there are 
no other elements in the scene. The light shading effect will emboss the contour of the shape, but if you want to 
have highlight and tone zones within the drawing, you will need to carve and emboss areas using specific colour 
zones.

If you have a cut-out character composed of several drawing layers, you will need to identify the different layers or 
group of layers you want to define as volume objects. For example, you could group the arm, forearm and hand 
layers as one object, while the head could be another volume. Depending on your design, you will have to analyze 
and decide what should be grouped. You can then use colours to carve areas within those volumes.
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The beauty of the light shading effect is that you only have to set it up once. You can animate the light source 
position, shading style, as well as colour and your volume objects, carving and adding areas will be accurately used. 
There's no need to redraw another set of zones depending on the light source or even draw tones for any animation 
frames. This only needs to be done once in the character rig. The compositing artist will then have the freedom to 
play around with the light positioning and ambiances.

Harmony provides you with a series of nodes and parameters allowing you to shape, carve and model your image's 
3D geometry as you like. Each volume object has an ID number. You can have several volumes using the same ID 
so they can receive the same shading, smoothing and bevelling parameters. If you want to treat each area 
individually, you can assign them different ID numbers.

You also have the possibility to create tones, not only highlights. You can also combine both on the same image. 
Both tones and highlights react to the same carving colours, modelling parameters, and set volume objects.
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About Light Shading Nodes
You can build your light shading effect using these five nodes:

 l Volume Object  on page 1381

 l Normal Map on page 1381

 l Light Position  on page 1382

 l Light Shader  on page 1382

 l Tone Shader  on page 1383

To learn more about each node's parameters, see the Reference guide .

Volume Object 

The Volume Object node lets you define a volume zone the light will interact with.

If there is a single drawing on which you want to apply shading, you only need one Volume Object node. For cut-out 
characters, you will require more as you will define which should be different volumes. For example, you could 
decide that the arm, forearm, and hand will form one shape for the light to hit and create a highlight. You could then 
define the body as a separate volume. If you use different Volume Object nodes on the arm pieces, you will get odd 
carvings and bumps where the joints overlap. Before adding light shading to your rig, you should analyze how the 
parts will interact with one another.

All the Volume Object nodes in your structure will be gathered in the Normal Map node where you can define the 
parameter for each volume.

Normal Map

The Normal Map node lets you centralize all Volume Object nodes and chisel out the shading 3D geometry (bevel 
height, smoothing, carving, etc.). It could be described as carving a bas relief. You only need one Normal Map node 
per light shading effect and, in general, only one per scene.
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A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to a 
format supported by your plugin. The Normal Map Converter node has been optimized to work with GenArts® 
plugins, but you also have the ability to use it on custom plugins..

Light Position 

The Light Position node is the actual light source interacting with all the defined volume objects. You can set its 
position in relation to the objects and animate it over time. All volumes will react according to the light's motion.

This is not where you set the light type or colour. You'll be adjusting these in the Light Shader and Tone Shader 
nodes.

Light Shader 

The Light Shader node lets you adjust the highlight parameters, such as the colour, to create the desired 
ambiance. You can animate most parameters over time to create a mood change, sunset or any other type of light 
transition. The beveling height and smoothing is set in the Normal Map node.
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Tone Shader 

The Tone Shader node lets you adjust the tone parameters, such as the colour, to create the desired ambiance. You 
can animate most parameters over time to create shade transitions. The beveling height and smoothing is set in the 
Normal Map node.
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Light Shading Setup
The first step in setting up your light shading effect is to identify which volumes you want the light to interact with. 

To learn more about each node's parameters, see the Reference guide .

Here's what a basic light shading effect node structure looks like:

How to set up a basic light shading effect

 1. In the Node Library view, select a Volume Object node from the Shading category and drag it to the Node 
view.

 2. In the Node view, connect the Volume Object node between the drawing node and the Composite node. 
Click on the node's properties button (yellow square) and rename it with the volume it represents. This will 
make it much easier to edit the beveling in the Normal Map node later on.
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If you need to combine several elements into one volume, you can connect the elements into a Composite 
node set to Pass-Through and connect that Composite node to the Volume Object node.

 3. In the Node Library view, in the Shading category, select a Normal Map node and drag it to the Node view.

 4. In the Node view, connect a second connection from the Volume Object node to the Normal Map node. Don't 
connect the Normal Map's output port yet.
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 5. In the Node Library view, in the Shading category, select a Light Shader or Tone Shader node and drag it to 
the Node view.

 6. In the Node view, connect the Normal Map output node to the shader node's middle input port.

 7. From the Volume Object node, pull out a third connection and connect it to the shader node's right input 
port.
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 8. In the Node Library view, in the Shading category, select a Light Position node and drag it to the Node view.

 9. In the Node view, connect the Light Position output node to the shader node's left input port (green).

 10. Connect the shader's output port to the Composite node to the left (in front) of the Volume Object's Com-
posite connection. This will display the light shading effect on top of the original drawing. Connecting it to the 
right would result to nothing as the effect would be hidden behind the drawing.
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 11. If you added colours to your drzwing to carve in some areas, in the Node Library view, select a Colour-
Override node and drag it to the Node view.

 12. In the Node view, connect the Colour-Override node between the Volume Object and the Composite 
nodes. Make sure the Volume Object node is connected to the Colour-Override's right input port.
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 13. Click the Colour-Override node's properties button (yellow square) to open the Layer Parameters dialog. From 
the Colours section, drag your carving colours to the Individual Colour Overrides section. In the Mode 
column, set all your colours to Colour not visible.

 14. To combine both the Tone Shader and the Light Shader, from the Node Library bring the other shader node 
and drag it to the Node view.

 15. In the Node view, connect the same Light Position, Normal Map and Volume Object nodes to the new shader 
node.

 16. Click the Normal Map node's properties button (yellow square) to open the Layer Parameters dialog.

1389



     About the Light Shading Effect

 17. In the Volume Creation section, from the Object List , select all the Volume Object nodes you want to use 
in this map.

‣ It's possible to add all Volume Object nodes at the same time by selecting the Add all Defined 
Objects option or it's possible to add each Volume Object node one by one.

 18. In the Camera view, enable the Render mode to view the final effect.

 19. See the Reference guide  to adjust the light shading parameters.
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Adding and Carving Volumes
Once your basic volumes are set up, you can use colours from your colour palettes to carve or add zones. 
Depending on the design of the drawing, you may want to use the same palette as the character, background or 
object, or you may want to use a specific palette reserved specifically for this purpose.

To learn more about each node's parameters, see the Reference guide .

How to add and carve volumes

 1. Add colour swatches in your character's colour palette or in a new palette solely reserved for carving. Name 
them Carving and Adding. By choosing different colours, it will be easier to differentiate where those col-
ours will carve or add.

 2. In the Camera or Drawing view, draw the areas you want to carve out and add. It's recommended to draw 
them in the Underlay or Colour Art layer.

 3. In the Node view, click the Normal Map's properties button (yellow square) to open the Layer Properties win-
dow.

 4. In the Override Modelling by Colour section, click Add Colour and select the palette containing your carving 
and adding colours.
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 5. Add your Carving and Add colour swatches.

 6. Increase or decrease the Carving - Adding value by adjusting the slider to carve or emboss your volumes 
using the colour zones.

 7. In the Camera view, enable the Render mode to view the final effect.
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Animating the Light Source and Target
You can set up the light source and animate it.

How to display the controls of the Light Position node

 1. In the Node view, select the Light Position node.

 2. Do one of the following:

‣ In the Camera View toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

A yellow camera appears in the scene, representing the light source.

How to animate the light source and the target

 1. In the Tools toolbar, select the Transform  tool and animate the light source or target.
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 2. Before moving the light source for the first time, you must move the light to make it visible. At the moment, 
the target is not visible because it is hidden behind the light source.

A red line appears, starting at the light source. This line represents the direction of the light. The green dot 
at the end of the line represents the target. Depending on the setting of your Light Shader or Tone Shader 
node, the direction or target may be more useful.
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About OpenFX
To expand your compositing possibilities, you can use OpenFX plugins directly in Harmony.

OpenFX is an open standard used to create visual effects plugins. These plugins can be used in any application that 
supports the standard. This means that banks of visual effect plugins can be developed by programmers and shared 
with various platform users. Harmony is one of these platforms.

To learn more about OpenFX, refer to:

 l openfx.sourceforge.net

 l openeffects.org

To learn more about  the main OpenFX plugin providers, refer to:

 l toolfarm.com/products/category/3316/all

To demonstrate this feature, the Sapphire package from GenArts® will be used. You can download the Sapphire 
library at:

 l genarts.com/sapphire
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Installing an OpenFX Package
Once you have purchased or downloaded an OpenFX package, you need to launch the executable file to install it. 
All OpenFX plugins install in a centralized location that all applications can read from. You will not need to do 
anything in Harmony. They will appear automatically in the Node Library view once the package of your choice is 
installed.

Here is the centralized installation path:

 l Windows: C:\Program Files (x86)\Common Files\OFX\Plugins

 l Mac OS X: /Library/OFX/Plugins

 l Linux: /usr/OFX/Plugins

How to install an OpenFX package for Harmony

 1. Download the OpenFX package you want to install.

 2. Quit Harmony.

 3. Launch the OpenFX package installer and follow the installation instructions.

 4. Launch Harmony.

 5. In the Node Library view, in the Categories section, select the category matching the package's name. 

All effects included in the package are now available to use in Harmony.
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Using OpenFX Plugins
All OpenFX plugins can be customized by adjusting their parameters. Settings are organized by category and some 
of them can be expanded and collapsed for clarity. Parameters can also be animated over time.

Some effects also have visual controls to set the position or angle. If you want to adjust the controls for your effect, 
you must do so in OpenGL mode. To see the effect in OpenGL mode, you need to connect a Render Preview node to 
your effect.

How to use and edit an OpenFX plugin in Harmony

 1. From the Node Library view, select an effect plugin and drag it to the Node view.

 2. Connect your drawing nodes or other required nodes to the effect plugin.

 3. In the Camera view, enable the Render  mode to see the final rendered effect.

 4. In the Node view, click the effect node's yellow square to open the Layer Properties window and adjust its 
parameters.
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NOTE: 
In the Layer Properties window, you can expand some parameter sections to see many more controls.

 

 5. Adjust the effect's visual control in OpenGL mode by dragging a Render Preview node from the Node 
Library view to the Node view. Connect it between the plugin and the Composite nodes.
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 6. In the Camera view, enable the OpenGL  mode to see the rendered effect in OpenGL.

 7. To display the controls, in the Node view, select the plugin effect node and do one of the following:

 l In the Camera toolbar, click the Show Control button.

 l From the top menu, select View > Show > Control.

 l Press Shift + F11 (Windows/Linux) or ⌘  + F11 (Mac OS X).

The controls appear.

 8. In the Tools toolbar, select the Transform  tool or press Shift + T.

 9. In the Camera view, adjust the controls.
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Using the Normal Map Converter
Harmony has the ability to generate normal maps. The main usage is to create light shading effects on flat 2D 
drawings. The normal map will carve and emboss a flat plane using vectors. The X, Y and Z coordinates of the 
normal map vectors are stored in RGB values to convert the 3D aspect into a visual result and use it to create 
various effects, such as light reflections (light shading). The X value is stored in the Red channel. The Y value is 
stored in the Green channel. The Z value is stored in the Blue channel.

A normal map can be used to create other effects. If you're are working with an OpenFX plugin or other plugin 
requiring a normal map, you can use the Normal Map Converter node to translate the Harmony normal map to a 
format supported by your plugin. The Normal Map Converter node has been optimized to work with GenArts® 
plugins, but you also have the ability to use it on custom plugins.

NOTE: Note that not all normal map formats are supported.

The Normal Map Converter uses the following formula per channel:

 l value * (+/- length) + offset

 l * +/- depending if inverse is set to true ("-" if true)

How to use the Normal Map Converter node

 1. In the Node Library view, go to the Shading category and select the Normal Map Converter node.

 2. Drag it to the Node view.

 3. Connect the Normal Map Converter node between the Normal Map node and your custom plugin node.
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 4. Select the Normal Map Converter node.

 5. In the Layer Properties view, adjust the node's properties.

Parameter Description

Conversion Type
By default, the conversion type is set to Genarts. If you work with a 
different manufacturer and want to adjust the parameters, set the 
conversion type to Custom.

Offset

Offsets the original position of the vector. You need to read the plu-
gin documentation to know the offset you need to use. You must 
use the same offset value as the manufacturer is using. By default 
the offset is set to 0.

Length

The Normal Map Converter normalizes Harmony vectors to 1. By 
default the length value is set to 1. If your plugin requires shorter or 
longer vectors, enter a value smaller or greater than 1. It will mul-
tiply the vector length.

Invert Red
Inverts the red value (x). If your value is 125, the invert setting will 
transform it to -125.
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Invert Green
Inverts the green value (y). If your value is 125, the invert setting 
will transform it to -125.

Invert Blue
Inverts the blue value (z). If your value is 125, the invert setting will 
transform it to -125.

 6. If the plugin you are using stores the X,Y and Z coordinates in different channels, you can use the Chan-
nel-Swap node to reassign the colour channels.
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About Particles
Particle effects are both cool and a huge time saver. You can create atmospheric effects, such as rain, grass or fire 
to more complex systems, such as swarms of animated insects-- all in a fraction of the time it would usually take.

Particle effects act in the same way as all other effects in Harmony, except they always work within their own 
specifically structured system. You can attach a Blur effect node under a Drawing node and the image contained in 
the Drawing node will become blurry. Particle effect set-ups are more complex than simply adding a node and 
playing with its parameters. To keep things simple, just think of each Particle effect as its own group.
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About the Particle Basic Structure
This is what the basic structure of a particle system looks like in the Node view. This structure can change 
depending on the type of effect you are trying to create. 

To learn more about each particle node, see the Reference guide .
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About the Particle System Colour Coding
Particle effects are colour coded to make them easy to identify by colour and function. Each colour represents a 
different function. For example, Action nodes, such as Velocity, Move-Particles and the Sprite Emitter are bright 
purple. These colours can be edited in the Preferences dialog box by going to Edit / Harmony Premium > 
Preferences > General tab > Edit Colours button > Particle tab.

In addition to defining groups by colour, node in-ports and out-ports are also colour-coded. In the network shown in 
the illustration above, the Particle-Baker is dark yellow and the Particle Visualizer purple. Look closely and you will 
notice that the in-port on the Particle Visualizer, where the Particle-Baker is connected, is also dark yellow. 
Similarly, the out-port on the Particle-Baker, where the Particle Visualizer is connected, is purple.

This system gives you an idea, at the very least, of what type of node is needed to fill a specific port.    

 l Visualizer - This node assembles a particle system through its middle port. It can accept a Peg on either 
side. The system is flattened at this node and generated as a single image. This lets you move the effect's 
position in your scene or change its render order.

 l Action - These nodes affect the particle dynamics; they determine how they are created and moved around in 
space. If there are multiple Action nodes hooked to a composite, they are executed from right to left. Due to 
this ordering, there should generally be an emitter on the right-most port.

 l System Composite - Unlike a regular composite that reads all the position information from its in-port nodes 
and combines them accordingly, a System Composite is specifically designed to handle Action node inform-
ation.

 l Baker - These nodes allow you to make decisions about the particle system's position, angle, number, etc. the 
same way that a baker would make decisions about the ingredients that go in a cake.

 l Region Composite - This node combines Region nodes. In case you have more than one Region in your 
effect, this composite will help define the position and render order of the different Regions.

 l Region - These nodes are used to define the region from where the particles are emitted. These regions can 
be Planar or 3D.
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Accessing Default Particle Templates
Harmony comes with some basic Particle effect templates. You can change the effect's "sprite" with a drawing, 
image or animated sequence of your own. Then tweak its properties to adjust the effect to your liking. Or you can 
use the templates to analyze their structure so you can build your own. 

NOTE: To learn more about each particle node, see the Reference guide .

How to access the Particle templates

 1. From the top menu, select Insert > Particle > and one of the following Particle effect templates:
 l Basic Particle System: This effect template has the simplest structure and the parameters for all 

of its nodes are set to the default values. For example, the Planar-Region has not been rotated or 
resized, the particles have not been randomized in the Sprite-Emitter, and the particles start their 
generation on the first frame and die out at the maximum number allotted in the Particle-Baker.    

 l Basic Gravity Based System: This effect template simulates particles being generated from a 
source with special emphasis on adding gravity to the particle system.

 l You also have access to pre-built examples :

 l Animated Grass - Simulates a patch of grass that is swaying in the wind. Uses an anim-
ated drawing layer as a sprite. 

 l Bees - Simulates a crowd of bees flying around. Uses an animated drawing layer as a 
sprite. Animate the position of the bees using the Peg layer.

 l Bouncing Balls - Simulates the randomness of a set of bouncing tennis balls. 

 l Bubble Vortex - Simulates a swarm of insects emerging from a single origin point (such as 
the opening of a hive) and forming a tornado-shaped, tubular vortex.

 l Confetti - Simulates confetti being thrown upward and falling back to the ground.

 l Fairies - A fun example of how you can have a particle (the Fairy) which generates particles 
(the Fairy Dust).

 l Fairy - An example of how you can create a trail of Fairy Dust following an animated drawing 
layer.

 l Fire - Simulates a camp fire.

 l Fire_Particles - Simulates a large fire filing the entire screen width. 

 l Grass - Simulates a static patch of grass at a fully grown state.  

 l Horizontal Speed Lines - Simulates horizontal speed lines that will radiate in one direction 
from a central point. 

 l Leaves - Simulates autumn leaves falling in the wind.  

 l Lemmings - Simulates the classic game Lemmings. Uses an animated drawing layer as a 
sprite. This is also a good example to use to learn how to use Bounce Planes, as the 
particles will fall until they hit a bounce plane.
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 l Looping Dust - Simulates a cloud of dust twirling in the wind. 

 l Rain - Simulates a fairly turbulent rainfall with 3 different coloured raindrops.  

 l Rain 2 - Simulates rain water splashes as drops hit the ground

 l Rain3 - Simulates a fine rain falling vertically. 

 l Snow Windy - Simulates snowflakes falling in the wind. 

 l Sparkly 2 Colours - Simulates magical sparkles.

 l Speed Lines - Simulates radial Speed Lines that will radiate outwards from a central point. 

 l Spay Wand - Simulates a wan spraying magical sparkles at a target. 

 l Toon Fire - Simulates a more cartoony camp fire. 

 l Trail Particles - Simulates a trail of sparkle following a given path. 

 l Twinkle Particles - Simulates a shower of twinkling particles.
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About Exposure Fill Using Render Change
A frequent effect applied at the compositing stage is texture overlay. Either a shaky textured line will be applied 
on an animation or colour fills will be replaced with textures. Most of these effects are created using the Colour 
Override effect—see the Reference guide .

You can replace a colour fill with a static or animated texture. For an animated texture, you can fill a character's 
wool sweater with four or five variations, filling the sweater zone and loop it throughout the sequence. This way 
the final animation can have a bit more of an organic style with moving textures and shaking lines.

You might also want to control when the textures move. When your character is still, you might want the texture 
to remain still as well. You could also want the texture to remain still if the character only moves slightly. You can 
control when the texture will move based on the animation motion. You can set the parameters that define what is 
considered a big enough change for the texture to start moving.

The motion analysis is based on the rendered images sent to a Display node. You can use the main Display node 
set below your final Composite node or add a specific Display node to analyze a specific portion of your node 
system, such as a character's sweater layers—see About Displays on page 1086. 

NOTE: To help display the scene, use the Advanced Display. In the Preferences dialog box, select the 
Advanced tab, then select the Advanced Display option. This allows different views to use individual Dis-
play nodes. 

The Exposure Fill Using Render Change command can be applied on any drawing or bitmap layer, but the most 
common case where this feature will be used is on a bitmap or drawing layer connected in a Colour-Override's 
texture port—see Overriding a Colour with a Bitmap Image Sequence on page 1369. The overridden colours 
should use the Texture - Use Image Input setting. Note that you might need to parent your character's master peg 
to the texture layer for the texture animation to follow your character.
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Using the Exposure Fill Render Change
You can use this option to animate the texture on your character on a given level of motion.

NOTE: The Exposure Fill Using Render Change command modifies the timing (exposure) of the selected layer. 
If you modify the character animation, you may need to reapply the exposure fill as the texture's exposure might 
no longer give the same final result.

How to use the Exposure Fill Using Render Change option

 1. In the Timeline view, select the textures or live-action sequence.

 2. From the top menu, select Scene > Default Display > desired Display node.

 3. From the top menu, select Animation > Exposure Fill > Using Render Change.

Wait while Harmony creates a low resolution render of the images to preview.

 4. In the Fill Exposure Using Render Changes window, use the Frame slider to view the motion change ana-
lysis.

 5. Based on your style preference, adjust the parameters to assign when the texture exposure changes will 
occur. You can adjust the type of filter to use for the motion detection, as well as threshold values to indicate 
what will be considered a big enough motion variation for an exposure change. 
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Parameter Description

Changes Detection Settings

Frame: Use the slider to see when a change is necessary. A red 
edge indicates there is a large enough motion for the texture to 
change.

Use: Lets you use either the Red, Green, Blue, or Alpha chan-
nel, or Luminance difference between frames to analyze the 
motion changes. The Alpha channel is selected by default as it is 
the most commonly used parameter.

Pixel Value Change Threshold: The percentage of change in a 
pixel to be considered different from one frame to another. The 
higher the value, the more change is required when comparing 
two images in order for a new texture to be used.

Area Change Threshold: The percentage of non-empty pixels 
that must change from one frame to another to be considered dif-
ferent.

Fill Settings

These settings let you change the exposure. You can also 
decide on how many images you want to cycle. 

First/Last Frame: Lets you set the first and last frame for the 
exposure change. You can set this for the entire scene or for part 
of the scene (frames 20 to 32 for example).

 Number of Drawings in Cycle: Lets you set of the number of 
drawings to include in the cycle.

 First Drawing Used in Cycle: Lets you set the first drawing 
used in the cycle. Your drawings must be named using numeric 
values only, or number values with a prefix or suffix. It cannot 
only be letters.

 Drawing Name Prefix: Adds a prefix before the number. For 
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example, texture_01, texture_02 and so on.

 Drawing Name Suffix: Adds a suffix after the number. For 
example, 01_texture, 02_texture and so on.

 6. Click OK.

The selected layer's exposure is updated. If you modify the exposure of motion in your animation, you may 
need to repeat this procedure.

1411



Harmony 14 Premium - User Guide

1412



Harmony 14 Premium - User Guide

Chapter 24: Export
Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to further 
edit your movie using a third party software, composite the movie in a larger body of work or put it up directly on the 
web, Harmony supports several formats for all your rendering needs.

The render resolution for the various editions of Harmony are:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited
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Exporting QuickTime Movies
T-HFND-010-013

If you need to create a video file, you can export your scene as a QuickTime movie. 

By default, Harmony will export your entire scene in your scene's actual resolution. You can also choose to 
export only a specific frame range in your scene, or to export in a smaller resolution, which can be useful if you 
need to save on time or disk space. If you have specific requirements for the quality of your exported video files, 
you also have access to the codecs and compression settings made available by QuiickTime's interface. 

If you added burn-in information to your scene, it will be included in your exported file—see the Reference guide .

How to export a QuickTime Movie

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. Click Browse and select a folder in which to save your movie and give it a file name for the export.

 3. Click OK.

 4. In the Display Source section, select the Display node to use for rendering your project.

NOTE: If there is no Display node in your scene, the only available option will be Display All. This 
renders nodes in your scene, including ones that are not connected to anything, in the order in which 
they're listed in the Timeline view. Hence, it is always recommended to have a Display node 
connected to your scene's main composite, and to render from that Display node, so as to have 
control over what is rendered.
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 5. From the Export Range section, decide whether you want to export the entire scene (All) or a specific frame 
range. If you decide on the latter, enter the frame range.

 6. In the Resolution section, select one of the following from the menu:

 l A preferred resolution ratio.

 l Custom:  Enables the Width and Height fields so you can enter a specific size.

 7. In the Options section, click Movie Options.

Parameter Description
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Video

Enables the customization of the video settings, filters and size.

Settings: Opens the Standard Video Compression Settings dialog 
box.

Filter: Opens the Choose Video Filter dialog box, where you can 
select from a range of filters to apply to your video export.

Size: Opens the Export Size Settings dialog box. The size settings 
are overridden by the Harmony's scene settings.

Sound
Enables the customization of the sound settings.

Settings: Opens the Sound Settings dialog box (see below).

Prepare for Internet Streaming Enables the customization of the Internet streaming options.

 8. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.

 9. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the default compression type and 
as a result the Data Rate option is greyed out. 

NOTE: If you want to render a QuickTime movie with lossless compression and transparency, you 
can use the Animation video codec with the colour depth set to Millions of Colours +. 

 10. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower 
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher 
frame rate. 
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 11. If you want keyframes inserted, select the Every option and set the number per frame. 

This is the option is recommended by QuickTime. For further details, refer to the QuickTime documentation.

 12. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of the 
export, the larger the file.

 13. From the Data Rate section, either choose to allow the program to automatically select the most optimal bit 
rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of the 
export. 

 14. In the same section, from the Optimized For menu, select the intended viewing method for the export.

 15. Click OK.

 16. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

 17. From the Compressor menu, select a compression type. The default setting is None. This exports your 
audio as is without performing any lossy compression or conversion, preserving its fidelity. Other com-
pressors can be used if you need your movie's audio track to be exported in a specific format, or if disk space 
or download speed is critical, but they may impact the quality of your movie's soundtrack negatively. 

 18. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of your ori-
ginal sound files. For example, if your file has an audio sample rate of 48 kHz and you choose a conversion 
rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be missing, making it 
sound muffled. For reference, the standard sound quality is 44.1 kHz for films, and 48 kHz for DVD. Lower 
rates are liable to impact the quality of your movie's soundtrack negatively, but they can be useful if disk 
space or download speed is critical.

 19. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of precision 
used to record each wavelength in the soundtrack. The standard size is 16-bit. If you choose 8-bit, the 
amount of disk space your sound track requires is halved, but the audio will sound muffled.

 20. Select whether to Use the Mono or Stereo channel mode.  Stereo sound has a separate sound track for the 
left and the right speakers, allowing to make the origin of each sound realistically match the origin of their cor-
responding action. If you choose Mono, your sound track may use less disk space, but both the left and right 
channels will be merged into a single track. 

 21. Click OK.
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 22. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 23. Browse to the location on your computer where you saved your QuickTime video and double-click on it to 
view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with transparency

 l In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu.
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Exporting SWF Movies
Exports a Flash movie file. 

The SWF export supports some bitmap effects (which can be previewed in Render View  mode) and SWF Blend 
Modes (vector effects which can be previewed in OpenGL View  mode).

The following are also supported:

 l Pencil line thickness: They are converted to brush strokes in the .swf file.

 l Auto Patch node for creating joint patches.

 l Burn-in information incuding time code, frame number and scene information—see the Reference guide .

If you have not already done so, you should preview the .swf by using the SWF preview  button to see what the 
two types of effects look like when blended together. Once you are satisfied with the results, go ahead and export 
your movie. 

How to export a .swf movie

 1. From the top menu, select File > Export > SWF.

The Export to Flash Movie (.swf) dialog box opens.

 2. Click Browse and select a file name and destination path for your movie.

 3. In the Display Source section, select a Display node to read from in the Export From Display Node menu.

 4. In the Export Range section, select one of the following options:

‣ All: To export all the frames of your movie.
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‣ Frames: To export a frame range. Enter the frame range in the fields.

 5. In the Options section, enter a Frame rate (fps). By default, it will be set to match the fps of your Harmony 
project. If you choose a lower frame rate, your export playback will be faster than your actual project. The 
reverse is also true for a higher frame rate. 

 6. In the same section, select the JPEG quality:

‣ 100 = Full quality

‣ 50 = Average quality at about 1/5th of the size.

‣ 25 = Medium quality where loss of high image resolution starts to occur.

‣ 10 = Low quality where “macro-blocking” or large pixelation become obvious.

‣ 1 = Lowest quality where there is extreme loss of colour and detail and the image becomes nearly 
unrecognizable. 

 7. To prevent your movie from being imported into another application, select the Protect from Import 
option.

 8. For a lighter format, select the Compress Movie option. The movie may lose some quality, but the file will 
be lighter.

 9. To retain the thickness of pencil lines, select the Convert Pencil Lines to Brush Lines option. 

 10. In the Do Not Export section, select the effects you do NOT want to be rendered in the SWF movie.

Note that certain Harmony effects are not listed in this section as they are not compatible and therefore not 
available for SWF export. These effects will not appear in the SWF render. 

 11. Click OK.

 12. Browse to the location on your computer where you saved your Flash Movie and double-click on it to view 
the export.
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Exporting OpenGL Frames
You can export the OpenGL frames (fast display mode) if you need a quick render for your scene. Heavier scenes 
containing 3D, multiple effects and camera moves can be fairly long to export.

Use the Export OpenGL Frames dialog box to select the frames you want to render from the OpenGL Camera view, 
then save the rendered frames as image files or as a QuickTime movie.

Frames saved from OpenGL view have neither antialiasing nor special effects. To render final frames with effects, 
export as images or a movie.

How to export OpenGL Frames

 1. From the top menu, select File > Export > OpenGL Frames.

The Export OpenGL Frames dialog box opens.

 2. In the Output section, click Browse and select a folder for the frames.

 3. In the Filename field, enter a name (prefix) for the frames or revert to the default name by clicking Default.

 4. In the Format section, decide if you want to export individual image frames or a movie.

 l Suffix: Lets you select the desired suffix. If you intend to render only a few frames, use 1 or 01, 
whereas if you intend to render 1000 frames, you can select 0001.

 l Drawing Type: Lets you select the file type to render, such as .tga or .sgi. 

 5. Click Movie Options to customize the Audio and Video settings for the *.mov export—see Exporting Quick-
Time Movies on page 1414. 

 6. From the Resolution section, select a resolution for export. If you are running some quick tests, then you 
might want to reduce the resolution to save time and space. You also have the option to set a Custom width 
and height to produce smaller or larger frames.

 7. In the Range section, decide whether you want to render all your frames, a range of frames, the current frame 
or selected frames.
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 8. In the Options section, select a Display node to use for rendering your OpenGL frames from.  It is always 
recommended to render from the Display node located under the final Composite node, unless you want to 
render a specific section displayed by a particular Display node.

 9. Click OK.
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Exporting Sound
At some point during the production, you might need to export a sound file to use it in another application, such as an 
editing software. Harmony allows you to export sound files as a merged soundtrack or as a series of individual files. 
The exported soundtracks are generated as *.wav files.

How to export a soundtrack

 1. From the top menu, select File > Export > Soundtrack.

The Export Soundtracks dialog box opens.

 2. In the Output section, click Browse and specify where you want to save the exported sound file.

 3. In the Export Range section, select one of the following options:

 l All: Exports the sound over all the frames of your scene.

 l Frames: Sets the start and end frames in the corresponding fields on the right.

 4. From the Options menu, select one of the following:

 l Process Soundtracks Individually: Each soundtrack from all layers is exported as individual 
files.

 l Merge all Soundtracks: One single file is created, combining all the sound files you imported 
in your scene. Note that it will only use the sound files in the selected frame range set in the 
Export Range section. If you selected to export all the frames, all the sound files will be pro-
cessed.

 5. In the Sound Settings section, set the Rate, Size and Use parameters for the soundtracks to export. It is a 
good idea to verify what is required by the software or device that  you may want to use next with the sound 
file.

 6. Click OK.
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The generated sound files appear in the selected directory and are named according to the scene name. 
Individual files keep their original name; only a prefix matching the scene name is added.
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About  Node View Export
The Node view allows you to make advanced connections and isolate certain portions of your project. It also allows 
you to perform multiple exports from the entire node structure or from specific sections.

For this kind of process, use the Write node. The Write node lets you render and output the connected image 
information. Using the Write node, you can export a project as a QuickTime movie or as image sequences. You can 
export one format at a time or both simultaneously.

NOTE: The formats used if you need to output a vector format are .tvg and .pdf. You can also export a .swf 
movie.
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Adding Write Nodes
The Write node lets you render and output connected image information.

How to add a Write node

 1. In the Node Library, select the Output from the list of categories.

 2. Select the Write node and drag it to the Node view.

 3. In the Node view, connect the final Composite node or any other node which outputs an image you want to 
render to the Write node.
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Exporting Image Sequences from the Node View
To export an image sequence, you need to adjust a few settings in the Write node’s properties.

Here is a list of all the  image formats supported for rendering with Write nodes.

Format Specification Description

TVG                                              

Toon Boom Vector Graphic (*.tvg)

Toon Boom's proprietary format for storing vector drawings. 

NOTE: To export TVG files, your Write node must be con-
nected to a vector drawing layer or to a vector composite node. 
The exported TVG files will contain the vector and bitmap draw-
ing information, but will ignore  effects and deformations. 

TGA                                              Full colour

Truevision TGA/TARGA (*.tga)

A standard image format with lossless compression and support for 
transparency.

TGA1                                              Greyscale

TGA3                                              Full colour

TGA4                                              
Full colour with trans-
parency

SGI                                              
Full colour / 8 bits per 
channel

Silicon Graphics Image (*.sgi)

A highly capable format with lossless compression as well as 
support for double precision and transparency.

SGI1                                              
Greyscale / 8 bits per 
channel

SGI3                                              
Full colour / 8 bits per 
channel

SGI4                                              
Full colour with trans-
parency / 8 bits per chan-
nel

SGIDP                                              
Full colour / 16 bits per 
channel

SGIDP3                                              
Full colour / 16 bits per 
channel

SGIDP4                                              
Full colour with trans-
parency / 16 bits per 
channel

PSD                                              
Full colour / 8 bits per 
channel Photoshop Document (*.psd)

An Adobe Photoshop proprietary format used for image editing. 

PSD files exported by Harmony contain a single background layer 
with the rasterized image. 

PSD1                                              
Greyscale / 8 bits per 
channel

PSD3                                              Full colour / 8 bits per 
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channel

PSD4                                              
Full colour with trans-
parency / 8 bits per chan-
nel

PSDDP                                              
Full colour / 16 bits per 
channel

PSDDP1                                              
Greyscale / 16 bits per 
channel

PSDDP3                                              
Full colour / 16 bits per 
channel

PSDDP4                                              
Full colour with trans-
parency / 16 bits per 
channel

YUV                                              

Y'UV frame (*.yuv)

A legacy format optimized for NTSC television. The image 
information is encoded in the Y'UV color space, which means Luma 
(Y') and Chrominance (UV). 

NOTE: YUV images must be exported in NTSC resolution 
(720 x 540), or they will not be legible.

PAL                                              

PAL frame (*.pal)

A legacy format optimized for PAL television.

NOTE: PAL images must be exported in PAL resolution (768 x 
576), or they will not be legible. 

SCAN                                              

Toon Boom Scan Files (*.scan)

A Toon Boom proprietary format used by Scan to store scanned 
image information along with its registration (peg) information. 
SCAN files are in gresycale. 

PNG                                              
Full colour / 8 bits per 
channel

Portable Network Graphics (*.png)

A highly portable image format with lossless compression as well 
as support for transparency and double-precision. PNG is typically 
used for Web applications, graphical user interfaces and image 
sharing.

PNG4                                              
Full colour with trans-
parency / 8 bits per chan-
nel

PNGDP                                              
Full colour / 16 bits per 
channel

PNGDP3                                              
Full colour / 16 bits per 
channel
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PNGDP4                                              
Full colour with trans-
parency / 16 bits per 
channel

JPG                                              

Jpeg (*.jpg)

A very compact image format with lossy compression. It is typically 
used for Web pages and photo sharing. Because it does not 
preserve image quality, it is recommended to never use it except 
when disk space or rendering time is critical and image quality is 
expendable. 

BMP                                              Full colour Bitmap (*.bmp)

A standard uncompressed image format commonly used on 
Microsoft operating systems. BMP4                                              

Full colour with trans-
parency

IFF                                              8 bits per channel

Interchange File Format (*.iff)

A container file format which can store text, image and sound data, 
and which is commonly used for exchanging data between different 
platforms. 

IFF files exported by Harmony contain the rendered image as well 
as Z-depth information for each pixel. If your scene has multiplane 
or 3D elements, this format can be used for compositing your 
animation with other graphical elements in 3D animation software. 

NOTE: Contrary to EXR and DTEX images, this format does 
not support antialiasing. It is recommended to use EXR or 
DTEX if possible. 

IFF_16                                              16 bits per channel

OPT                                              Full colour

Toon Boom OPT image (*.opt)

A legacy Toon Boom proprietary format that stores raw image data 
with lossless compression.

OPT1                                              Greyscale

OPT3                                              Full colour

OPT4                                              
Full colour with trans-
parency

VAR                                              

Toon Boom VAR image (*.var)

A legacy Toon Boom proprietary format that stores raw image data 
with lossless compression in greyscale.

TIFF                                              

Tagged Image File Format (*.tiff)

An image format with many compression and encoding settings. It 
is often used for image exchange in visual arts and publishing.

TIFF images exported by Harmony are uncompressed, encoded on 
a per-pixel (interleaved) basis in PC byte order. 

DPX                                               
8 bits per channel / Full 
color / RGB channel Digital Picture Exchange (*.dpx)
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order

A professional photo format that supports various different 
approaches to storing colour information, which can be used for 
storing, exchanging and editing raw information recorded by 
cameras. It is commonly used in film production. 

DPX3_8                                              
8 bits per channel / Full 
color / RGB channel 
order

DPX3_10                                              
10 bits per channel / Full 
color / RGB channel 
order

DPX3_12                                              
12 bits per channel / Full 
color / RGB channel 
order

DPX3_16                                              
16 bits per channel / Full 
color / RGB channel 
order

DPX3_10_
INVERTED_
CHANNELS                                              

10 bits per channel / Full 
color / BGR channel 
order

DPX3_12_
INVERTED_
CHANNELS                                              

12 bits per channel / Full 
color / BGR channel 
order

DPX3_16_
INVERTED_
CHANNELS                                              

16 bits per channel / Full 
color / BGR channel 
order

EXR                                              

OpenEXR (*.exr)

A highly capable deep image format. Each pixel in an EXR file is 
exported with its Z-depth information, as well as color and depth 
information of pixels further back for semi-transparent pixels. If your 
scene has multiplane or 3D elements, this format can be used for 
compositing your animation with other graphical elements in 3D 
animation software.

PDF                                              

Portable Document File (*.pdf)

Typically, PDF files are used to store, archive, share and print 
documents. However, Harmony uses the PDF format for its 
capability to store bitmap images and vector graphics.

If the write node is connected to a vector drawing layer or to a 
vector composite, the exported PDF files will contain the image as 
a vector graphic. It will ignore bitmap layers, effects and 
deformations. Otherwise, the PDF files will contain the rendered 
image as a bitmap.

DTEX                                              

Deep Texture (*.dtex)

A commonly used deep image format. Each pixel in an DTEX file is 
exported with its Z-depth information, as well as color and depth 
information of pixels further back for  semi-transparent pixels. If your 
scene has multiplane or 3D elements, this format can be used for 
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compositing your animation with other graphical elements in 3D 
animation software.

NOTE: Exporting in Deep Texture requires RenderMan to be 
installed on the machine and the path to RenderMan properly 
configured in Harmony. For more information, see the Setting 
3D Renderer Paths topic of the User Guide.

 

How to set the Write node to export an image sequence

 1. In the Node view, open the Write node’s editor by clicking its square yellow properties button.

 2. In the Output tab, select the Drawing option to create an image sequence.

 3. Click Choose and browse to the directory where you want to save the output. You can also use the 
default directory to save in the default frames folder included in the scene directory.

 4. In the Drawing Filename field, type the image sequence’s name prefix. It is recommended to leave the 
hyphen (-) at the end of the name to separate the image name from the image number.
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 5. In the Start field, select the starting number for the image sequence.

 6. In the Leading Zeros field, select the number of digits you want to see after the sequence prefix.

 7. In the Drawing Type field, select the file format in which your project will output.

NOTE: When the file format includes a "4" at the end of its name, it means that an alpha channel will be cre-
ated.

 8. Click Close.

The project will not start rendering yet, since these are only the settings. You can still modify your scene.
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Exporting QuickTime Movies from the Node View
To export a QuickTime movie, you need to adjust few settings in the Write node’s properties.

How to set the Write node to export a QuickTime movie

 1. In the Node view, open the Write node’s property editor by clicking on its square yellow properties button.

 2. In the Output tab, select the Movie option to create a movie file.

 3. Click Choose and browse to the desired directory to save the output.

You can also use the default directory to save in the default Frames folder included in the scene folder.

 4. In the Movie Filename field, name the output file. You do not need to write the file format extension.

 5. Click Customize  to open the Movie Settings dialog box.

 6. In the Movie Settings dialog box, in the Video section, click Settings to set your video options.
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 7. Click OK.

 8. In the Movie Settings dialog box, in the Sound section, click Settings to set your audio options.

 9. Click  OK.

The project will not start rendering yet. These are only the settings. You can still modify your scene.
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About Multiple Renders
Harmony lets you simultaneously render many formats and resolutions for a scene. This saves a lot of time as 
you do not have to return between each render to start a new one.

To use multiple renders, connect as many Write nodes as needed to match the required number of exports. Then, 
adjust each Write node’s settings to create image sequences or movies.

NOTE: YOU MUST GIVE DIFFERENT NAMES TO EACH OUTPUT FILE. This is especially important if 
you save them all in the same folder, so they do not overwrite each other.

When you have multiple Write nodes in a scene, it is useful to rename the nodes according to their output settings 
such as: low_resolution_movie or HDTV_sequence.

To export different resolutions concurrently, you need to create a combination of the following:

 l Write node—see About  Node View Export on page 1425

 l Scale-Output node

 l Crop node

If you start with a higher resolution and want to crop down to a lower resolution, such as HDTV to NTSC, you will 
need to combine the Crop node with a Scale Output node.

Once you know the type of render you want to do, you will need to retrieve your nodes from the Node Library and 
connect them to the scene’s network. 
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Setting Scale-Output Nodes
Once your Write nodes are connected, you need some Scale-Output nodes to change the resolution output of the 
Write node without changing the scene settings. For example, if you export in a high resolution and a low resolution, 
you need one Scale-Output node.

Set the project’s resolution to the highest resolution needed for this export and use the Scale-Output nodes to scale 
down the other outputs. 

DO NOT scale up the output size, that will not provide a good result. It is also better to use the Scale-Output node to 
scale down in a same aspect ratio so that it does not distort the image.

How to set a Scale-Output node

 1. In the Node Library view, select Scale-Output from the list of categories.

 2. Select the Scale-Output node and drag it to the Node view.

 3. In the Node view, connect the Composite node to the Input port of the Scale-Output node.

 4. In the Node view, connect the Scale-Output node to the input ports of both the Display node and the Write 
node.
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 5. In the Node view, open the Scale-Output node’s editor by clicking its yellow square properties button.

 6. In the Layer Properties dialog box, select a resolution from the suggested Resolution Name list or type in 
new resolution values to indicate the resolution to scale to.

 7. Click Close.
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Setting Crop Nodes
To output two files with different aspect ratios, such as 16:9 and 4:3, you can use the Crop node. This node is used 
to crop the final image in order to discard excess information without distorting the render.

How to set a Crop Node

 1. In the Node Library view, select Output from the list of categories on the left.

 2. Drag the Crop node to the Node view.

 3. In the Node view, connect the Composite node to the Input port of the Crop node.

 4. In the Node view, connect the Crop node to the input ports of both the Display node and the Write node.

 5. In the Node view, open the Crop node’s property editor by clicking the yellow square properties button.
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 6. In the Layer Properties dialog box, type new resolution values to indicate the resolution to crop to.

 7. You can manually enter the X -Y Offset, or move it in the Camera view. Select the right Display node in the 
Display toolbar. In the Advanced Animation toolbar, select the Translate  tool and with the middle 
mouse button, move the crop area. If the Animate  mode is enabled, the position of the crop area will be 
animated over time.

 8. If you want to create a Pan and Scan effect (panning the cropped selection over time to show more inform-
ation), you can create a function to animate the cropped selection. Click the Function  button beside the 
Local dialog box to create a Bezier or ease curve.

 9. If you created a function curve to animate the cropped selection, click again on the Function  button 
and edit the curve by adding keyframes and moving the selection box in the Camera view.If you created a 
function curve to animate the cropped selection, click again on the Function  button and edit the curve 
by adding keyframes and moving the selection box in the Camera view.
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 10. Enable the Draw Frame option if, instead of cropping the images, you prefer to have Harmony draw the frame 
over the rendered scene.

 11. Click in the colour rectangle to adjust the frame colour as desired if you have enabled the Draw Frame option.

 12. Click Close.

The Crop node also has an advanced Enabling tab for determining when the Crop node should be activated.

 l Always Enabled: Makes the Crop node always produce output.

 l Enabled when resolution name is: Activates the Crop node only when the resolution of the 
scene matches the value in the Filter Name menu. The listed resolutions come from the Res-
olution/Frame Rate dialog box.

 l Enabled when resolution is: Activates the Crop node whenever the scene’s resolution 
matches the values in the X and Y resolution fields.
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Exporting Multiple Renders
Harmony allows you to render multiple exports simultaneously. For example, you can export a version of your 
project, a full high-res version and an image sequence with a transparent background all at the same time.

How to connect nodes to export multiple renders

 1. In the Node Library view, retrieve the necessary Write, Scale-Output and Crop nodes.

 2. Connect the final Composite node to the first Write node. (Make sure you have a Display node reading the 
same information.)

 3. Open the Write node’s editor by clicking on its square yellow properties button.

 4. Name the Write node according to the render type that you are planning to do.

 5. Set the Write node parameters—see About  Node View Export on page 1425.

 6. Connect the other Write nodes and repeat steps 2 to 5.
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 7. Using the Alt key, insert the Scale-Output nodes between the final Composite node and their corresponding 
Write node.

 8. Using the Alt key, insert the Crop nodes between the final Composite node and their corresponding Write or 
Scale node.

 l If the output from the Crop node has to be scaled down, use a Scale-Output node.
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 9. Connect a Display node to each Scale-Output or Crop node to see each final image in the Camera view.
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Rendering from Write Nodes
If you want to render from your Write node, you will need to use the Render Write Nodes option found in the File 
menu.

Renders all the Write nodes in a node structure. 

When working with Harmony Server, you can send your scene to batch processing and to a render farm.

How to render the scene from the Write node

 1. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y (Windows/Linux) 
or ⌘  + Shift + Y (Mac OS X).

 2. In the Range section, select the frame range to render.

 3. Select the Field Composite Options option 

 4. To render the final images as fields for display on interlaced monitors, select the Field Composite Options.

 5. Select the Preview option to automatically see the image sequence result once the render is done. The pre-
view will not show up for a QuickTime movie.

 6. Click OK.

All renders start.
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Batch Rendering
Harmony Server has the possibility to render your scene locally or send it to a render farm so other computers can 
render your scenes while you continue working on your station. This option is not available with Harmony Stand 
Alone. 

There are two approaches to rendering a scene in Harmony Server:

 l Local Rendering is done directly by your machine in your Harmony session. Hence, it uses your 
machine's resources and will prevent you from working on the scene until the render is done. You will see 
the render progress in real time and will be able to preview the results right after it's finished. 

 l Batch Rendering is done by sending a scene to the server's render queue so it can be processed by the 
render farm. This allows you to keep working on your scene while the render is being done. The rendering 
progress can be monitored in Control Center and, when finished, the results can be previewed in  Play. 

Batch rendering is a background process divided over several machines or a render farm. Sending your scene to 
batch render will share the rendering load with other machines in the render farm and lessen the amount of work 
required by your computer. 

The parameters for the format and file type to render are set in the Write nodes contained in your scene's Node 
view. Before sending your scene to batch rendering, make sure to set the Write nodes to export in the proper 
location, and set the format parameters. Note that you can have more than one Write nodes in your scene if you 
require several exports—see About  Node View Export on page 1425.

NOTE: Refer to the Harmony Server Guide and Installation Guide to learn how to send scenes to batch 
render and check the status of the Render queue. 

How to send a scene to the batch rendering queue

 1. Save all the contents of your scene, all drawings, colour palettes and the palette list. 

 2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).
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 3. From the top menu, select File > Export > Render Write Nodes or press Ctrl + Shift + Y (Windows/Linux) 
or ⌘  + Shift + Y (Mac OS X).

If the system administrator did not complete the resolution configuration tasks, a warning message will open. 
This message notifies you that the resolution.conf file was not properly inserted in the configuration folder. 

 4. Click OK to continue. You will still be able to render your scene. 

The Render Write Nodes dialog box opens. 

 5. In the Range section, select the frames you want to render: 

 l All Frames: Sends all the frames in the scene to be rendered.

 l Selected Frames: Sends the specified range of frames to be rendered. 

 6. Select the Batch Composite option. 

 l Select the Chunk option if you want to split the render jobs into several smaller render jobs. 
This can be useful for example if you want your scene to be rendered by several machines in 
the render farm at the same time. Note that this only affects Frame renders. If the render 
includes a movie file, the movie will still be exported as a single file once all the frames have 
been rendered.

 l Enter the number of frames for each chunk in the Size (Frames) field. For example, if your 
scene is 100 frames long and you enter a value of 20, there would be five entries in the queue of 
20 frames each. 

1447



Chapter 24: Export     Batch Rendering

 l Select from which camera the scene should be rendered. By default, scenes only have one 
Camera, but more can be added in the Node View, and each of them can be positioned and 
animated independently. 

 7. Select the Field Composite Options option to create a field composite to refine your selection.

 l Add Pulldown: Renders using the 3:2 pull-down approach. Every odd-numbered frame will 
be rendered on 3 images, and every even-numbered frame will be rendered on 2 images. 

Images will be named in pairs to indicate that they are to be combined together. Therefore, 
the output will look like this:

Exported Image File Rendered Frame

final-0001-f1.tga Frame 1 of the scene

final-0001-f2.tga Frame 1 of the scene

final-0002-f1.tga Frame 1 of the scene

final-0002-f2.tga Frame 2 of the scene

final-0003-f1.tga Frame 2 of the scene

final-0003-f2.tga Frame 3 of the scene

final-0004-f1.tga Frame 3 of the scene

final-0004-f2.tga Frame 3 of the scene

This makes a scene animated in 24 frames per second output in 60 images per second. 
Hence, once the paired images are combined, this will make a 30 frames per second render.

 l Automatic Combine: Combines each pair of images rendered with Pulldown by interlacing 
them together.

 l Second Field First: By default, when images rendered with Pulldown are combined, the 
first image in a pair is rendered on odd lines (referred to as the first field), and the second is 
rendered on even lines (referred to as the second field). This does the opposite: The second 
image in a pair is rendered on odd lines and the first one is rendered on even lines.

 8. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render queue. 

If the selected frames were already sent to the Render queue, but were not yet rendered, dialog box opens 
to inform you that these frames were already in the queue, but that they have been updated with the latest 
rendering request.                 
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You can also send scenes to batch rendering and check the status of the rendering queue from Control Center. 
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