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Chapter 1: Harmony Server
What is Harmony?
Harmony is a team-based infrastructure for animation production. Its array of cutting-edge features increases
productivity and encourages creativity. Developed in conjunction with leading studios worldwide, Harmony is
specifically designed for long-term episodic and feature length projects, providing a true animation pipeline. Several
animators can work simultaneously on the same scene while the asset library provides users with easy access to
up-to-date media assets.

Harmony is truly scalable; more than 100 staging clients can share animation just as easily as a few can. Whether
you are a start-up studio or a large established animation facility, Harmony serves as the animation backbone
ensuring sustainability and growth.
Harmony is a powerful solution that brings together multiple teams working on the same project, whether in-house or
remotely. The Harmony solution offers a robust asset management system that enables users to quickly locate
assets, share tasks on complex scenes and centralize all assets in a common repository. Tremendous gains in
efficiency and quality are made by the teams, who enjoy a smooth flow between each task, and more time dedicated
to their creative assignments.

What is Harmony Server ?
At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository. Loaded
with production proven tools to manage administration tasks, the server is completely flexible and will fit in with your
existing infrastructure, whether you're on Windows, Mac or Linux.

In addition, the server is critical at the end of a production for rendering projects efficiently. The rendering process,
controlled directly by the server, not only renders production scenes but also executes the batch vectorization of the
scanned drawings. You can send an unlimited number of scenes to render and change their priorities depending on
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your deadline. You can also render final frames locally or batch process over a network in the background or at
scheduled times.

What is Web Control Center?

When you're running a studio, you will most likely have a database setup. This enables all the artists working on
your production to share the same scenes and assets.
What the Web Control Center enables you to do is to host this database on the Internet. Then, you can have
freelancers log in from anywhere with an Internet connection. They can download a scene from the database,
work on it, and upload it again. No more need to spend time copying files to an FTP. No need to have an
administrator exporting and importing files from the database. You can do it all directly through Web Control
Center.
About Check Out and Global Lock

9

Pausing the Harmony Server

10
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About Check Out and Global Lock
When working with Harmony Server, all scenes and their data are stored directly on the database; no data is saved
or stored on the client machine. The client machines access the database and load the scenes and drawings directly
from the server. Each time the user saves a scene, the data is updated directly on the server. There are no upload or
download operations done between the server and the clients. However, when working with the Web Control
Center, users must download and upload scenes to the Harmony database.
Harmony has a lock system, referred to as global lock, for the different scenes and scene assets. Since all data on
the server can be accessed directly and modified from any client machine, by default, scenes are locked and users
must get the rights to modify them in order to save their work onto the server. Only one user at a time can modify a
scene. Once a scene is opened on a client machine, other users can open the scene in read-only mode if they need
to consult it, but they will not be able to save any modifications.
In the Web Control Center, when a scene is downloaded locally by a user, global locking does not apply as it will be
modified in Harmony Stand Alone. To ensure that scenes are not simultaneously modified and causing conflicts,
scenes downloaded through the Web Control Center can be checked out by a user. When scenes are checked out,
they can be opened in read-only mode in Harmony Server.
Global lock has several levels:
A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked. Locking
means that you have the rights to modify a scene or its assets. Other users cannot modify locked items. If someone
tries to open a locked scene, it will be displayed as read-only.
Here are the different lock possibilities:
Lock

Description

Scene or Version Lock

Controls the Xsheet timing, layers, nodes but not the drawing, palettes, palettelists or templates.

Drawing Lock

Only one user can edit and save a locked drawing.

Palette Lock

Only one user can edit and save a locked palette.

Palette-list Lock

Only one user can edit and save a locked palette-list.

Library Folder lock

Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Center module.
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Pausing the Harmony Server

Pausing the Harmony Server
You can pause the Harmony server instead of shutting down the whole database, such as when you need to
synchronize two different databases. Users will not be able to work while the server is in pause mode. In the case
of saving a scene, a warning message saying that the server is paused will appear. The server will take note of
the save command and commit the changes to be saved after it resumes.
The file paths for this procedure will vary depending on which platform you are using: Windows, Linux or Mac OS
X.
How to pause the Harmony server
1. In the terminal or shell, go to the bin folder of the Toon Boom Harmony application:
l

l

l

Windows: cd "\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony
14.0 Premium\win64\bin"
Linux: cd /usr/local/ToonBoomAnimation/harmonyPremium_14/lnx86_64/bin
Mac OS X: cd /Applications/Toon\ Boom\ Harmony\ 14.0\ Premium\ Network/tbs/macosx/bin

2. In the bin folder, type dbu -p to pause the server.
If you want to check the state of the server to verify that it is in fact paused, you can type dbu -P.
3. When you want to restart the server, type dbu -res to resume.
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Chapter 2: Control Center
Using Harmony Server has the advantage that it centralizes your entire production on your server and organizes it
into structured database. The key piece of Harmony Server is the Control Center module. From Control Center, you
can manage your production database, users, visualize your rendering queue and more.

This chapter explains the general administrative tasks which must be performed to successfully run the Harmony
solution.
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Starting Control Center
To manage a production, you will need the Control Center module. Control Center is used to create new
environments, jobs, scenes and users, as well as to import and export scene packages. Control Center directly
manages your server database.
You can start Control Center from the server or any client machine.

Before accessing the main Control Center interface, the Database Login dialog box opens, requesting a user name.
By default, there is a user name created called usabatch. Type this user name to log in the first time. Once logged
into Harmony, you can create your own set of users.

IMPORTANT: IMPORTANT: Do not delete the usabatch user name as it is used by Toon Boom Harmony
Server for batch processing.

How to open Control Center
1. Do one of the following:
l

Windows: Start > Programs > Harmony 14 [edition] > Control Center

l

Mac OS X: Applications > Toon Boom Harmony 14.0 [edition] > Control Center

l

Linux: /usr/local/ToonBoomAnimation/harmony_14/lnx86_64/bin/Controlcenter

The Database Login dialog box opens.

2. In the User Name field, type usabatch. This is the default Harmony user.
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Starting Control Center

The Control Center application opens.
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Control Center Interface

The Control Center interface is divided into six areas:
Parameter

Description

Top menu

Contains the commands available in Control Center. You can also find the commands in the contextual menus available in each area by right-clicking.

Environments

Displays one of your projects, such as a feature film, a TV series or a group of TV
spots.

Jobs

Shows the sequences or episodes in your project (Environment). Select a project
from the Environments list to see your jobs.

Scenes

Shows the scenes in an episode or sequence (Job). Select a job from the Jobs list
to see your scenes.

Elements

Shows the layers or columns in a scene. Select a scene from the Scenes list to
see your elements.

Drawings

Shows the drawings in your layer or column (Element). Select an element from
the Elements list to see your drawings.

Here is a typical example of the database structure:
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Control Center Interface
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About Users in Control Center
In an animation studio, there are people using Harmony who will be assigned different tasks, such as ink and paint or
compositing. Normally, you should create a different user for each one. This way, the person assigned to ink and
paint will only have access to the Paint module and not to other features that are not relevant to their work.
Anyone who uses Harmony must have a login name in order to run any of the modules. When using Harmony in
standalone mode, there is no username or password required. The Harmony login is independent from the computer
session login.
On Windows, by default, only the usabatch and BATCH users are created. However, you should not use them for
your staff. These should be kept for Harmony Server when performing background operations, such as batch
processing—see .
Viewing User Lists in Control Center

18

Adding Users in Control Center

19

Deleting Users in Control Center

21

Editing User Information in Control Center

22

About User Creation for Batch Processing in Control Center

23

User Types and Restrictions

24
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About Users in Control Center

Viewing User Lists in Control Center
The User List dialog box lists all the users and their details, including: username, first and last names, and user
type. The buttons at the bottom of the dialog box let you add, delete or modify the list of users.
How to view the user list
1. From the top menu, select Admin > Users.
The User List dialog box opens and displays your login name and a list of the other users in the system.
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Adding Users in Control Center
All Harmony users must have their name on the user list to log in to any application. The system uses the login to
track activities; it is not a security lockout.
Each user also has a user "type" assigned to it which allows access to only some of the Harmony modules.
How to add a user to Harmony
1. To view the list of Harmony users, select Admin > Users.
The User List dialog box opens.

2. Click Add.
The Add User dialog box opens.

3. In the User Name field, type the person's user name.
4. Type the person's first name and last name in the corresponding First Name and Last Name fields. You can
enter a space if you want leave the field blank.

5. In the Type menu, select the user type. This defines the type of work the user typically performs. It will allow
or block the person from accessing certain Harmony applications and perform operations in Control Center—
see User Types and Restrictions in Web Control Center on page 92.
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About Users in Control Center

6. Click OK.
The name appears in alphabetical order in the user list.
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Deleting Users in Control Center
As your studio network grows and evolves, you may need to delete old or obsolete user profiles from your system.
After you delete a user profile, the person who used that profile will no longer be able to access Harmony. You
cannot delete yourself from the user list. If you accidentally delete a name, you must follow the procedure for adding
a user to put the user back into the system.
How to delete a user
1. To view the list of users, select Admin > Users.
The User List dialog box opens.

2. In the user list, select the name you want to delete.
3. Click Delete.
The Confirm dialog box opens.

4. Confirm if you want to delete the user from Harmony.
l

Click OK to delete the selected user.

l

Click Cancel to abort the delete command.
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About Users in Control Center

Editing User Information in Control Center
You can edit the user profiles at any time to update the user information.

NOTE: NOTE: To change your own user profile, login as usabatch (the default user).

How to modify user information
1. To view the list of users, select Admin > Users.
The User List dialog box displays.

2. Select the profile to modify.
3. Click Modify.
The Modify User dialog box appears.

4. Type or select the new information in any or all of the following:
l

User Name: The user's login name

l

First Name: The user's given name

l

Last Name: The user's family name

l

Type: The type of access the user has in the system

5. Click OK.
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About User Creation for Batch Processing in Control Center
If you intend to use the batch processing feature in Harmony or if you are installing the application on the server
machine, you must create:
l

An operating system user called usabatch

l

A Harmony user name called usabatch through the Control Center module.

Harmony uses this user profile during batch rendering.

IMPORTANT: It is important to verify that these users exist before starting a project and setting the batch processing.

l

Operating System Users
Windows: The usabatch operating system user profile was automatically created by the installation
wizard.
Mac OS X: The usabatch operating system user profile must be created manually or using the
configuration assistant.
Linux: You must manually create the usabatch operating system user.
Regardless of the operating you are using, a usabatch user account must exist on your operating system. If
you need to create this account, see your system administrator.

l

Harmony User Names
The usabatch Harmony user is created during the installation process on Windows, Mac OS X and Linux.
There is no need to create it manually unless it was deleted. To manually create the usabatch Harmony
user, refer to the Toon Boom Harmony Installation Guide.
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About Users in Control Center

User Types and Restrictions
Here are the different user types available and their restrictions/permissions:

Feature

Web
Control
Control
Center
Center

RND,
Coordinator,
Supervisor,
TD,
Executive

Animator

Xsheet,
Archive

Scan

Ink &
Paint

Create Environment

•

•

•

Change Asset Lock on Environment

•

•

•

Delete Environment

•

•

•

View Vectorize Queue

•

•

•

•

•

•

View Render Queue

•

•

•

•

•

•

Create Job

•

•

•

•

Change Job Priority

•

•

•

•

•

•

•

Change Job Status

•

•

•

Delete Job

•

•

•

Create Scene

•

•

•

•

•

Delete Scene

•

•

•

Unlock scenes locked by
another user

•

•

•

Unlock scene version locked
by another user

•

•

•

Unlock scenes locked by me

•

•

•

•

•

Unlock scene version locked
by me

•

•

•

•

•

Move Scene

•

Rename Scene

•

•

•

Clear Scene

•

•

•

Change Scene Priority

•

•

•

•

•

•

•

Change Scene Status

•

•

•

•

•
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Reorder Scenes

•

•

•

Copy Scenes

•

•

•

•

Send to Vectorize

•

•

•

•

•

•

•

Send to Unvectorize

•

•

•

•

•

•

•

Send to Rendering

•

•

•

•

•

•

•

Add/Modify/Delete Users

•

•

•

Change Approval Policy

•

•

•

Change Vectorize Style

•

•

•

•

•

•

Change Asset Lock

•

•

Database Lock Manager

•

•

Export Scenes

•

•

•

•

•

Import Scenes

•

•

•

•

•

View Error Log

•

•

•

•

•

•

•

View Elements

•

•

•

•

•

•

View Drawings

•

•

•

•

•

•

Open in Harmony

•

•

•

•

Open in Paint

•

•

•

•

•

Open in Scan

•

•

•

•

•

•
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About Environments, Jobs and Scenes in Control Center

About Environments, Jobs and Scenes in Control Center
Every project you create with the Harmony solution starts with an environment; it is the highest level in Control
Center. You can build a complete environment by adding jobs, scenes, elements and drawings.
Control Center divides your animation project into the following hierarchy, which organizes the sections of your
animated projects:

•

Environment: This is the name of your animation project.
Example: adventure_movie

•

Jobs: These are the major sections of an environment, such as sequences or episodes.
Example: adv_seq_001, adv_seq_002

IMPORTANT: All jobs are stored in the same location in the Harmony database. Be sure to prefix all job
names appropriately, so you can identify the project it belongs to. Each job must have a different name. You
cannot give two jobs the same name.

•

Scene: These are the different shots in a job.
Scenes are contained in their respective job folder in the Harmony database. Prefix all scenes names
appropriately, so you can identify which environment and job they belong to.
Example: sc_001, sc_002

•

Elements: These are the different layers and columns in your scenes.
If you have not created an exposure sheet yet, the Frames column in the Scenes list displays 0 and no
elements appear in the Elements or Drawings list.
For example, scene 002 of show_episode_6 could have the following elements:
•

A background called bg.

•

A character called tony.

•

A highlight effect called hl.

You would then find these elements under job 002 and the show_episode_6 scene. The Elements list
would display the element names, types of elements in a scene, the type of scans, and the size of the field
chart.
•

Drawings: These are actual drawings of the elements (layers) in your scene.
26
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For example, the tony element in 002 of show_episode_6 could consist of 35 drawings. To find these
drawings, you would look under Drawings to see the keyframes, state, and stage of each drawing.
As your projects come and go, you will probably want to start cleaning up your database, as well as your server's
hard disk, by removing old and obsolete environments and their associated animation data.

IMPORTANT: After you delete a scene, job, or environment, the associated data is permanently removed
from your storage disks. Make sure you really want to erase these items before you delete them as there is no
way to retrieve the data after it has been erased.

You might want to export old environments and archive them somewhere else before you delete them from your
system.

If you are working in a mixed Windows/Mac OS X/Linux environment or share files with other studios that do, you should use lowercase letters to name the various items in your animation projects and not include any spaces in component name. For example, write the_show instead of
The Show. This recommendation is due to the fact that Linux is case-sensitive while Windows
is not.

About Environments in Control Center
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31
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About Environments, Jobs and Scenes in Control Center
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About Environments in Control Center
Harmony uses environments to manage and organize related projects. Using environments allows you to organize
your production projects by their nature or type.
If your projects center around episodic and commercial types of work, you can create two environments. For
example, one environment called commercials and the other called the_show. Then you can insert the jobs that
relate to each type of project. When you want to work on a commercial project, open the commercials
environment and select the commercial job you need. Similarly, if you want to work on an episodic project, open the
environment called the_show.
Environment

Job
sc_001
dentist

commercials

sc_002
soda

sc_001

cereal

sc_001
sc_001

sho_001
sc_002
the_show

sho_002

sc_001
sc_001

dentist
sc_002
Creating Environments in Control Center

30

Deleting Environments in Control Center

31

Setting the Resolution File for Control Center

32
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About Environments, Jobs and Scenes in Control Center

Creating Environments in Control Center
Create environments in order to manage and organize you studio's projects.
How to create an environment in Control Center
1. Do one of the following:
‣

From the top menu, select Environment > Create.

‣

Right-click in the Environments section and select Create.

In mixed platform Environments (Windows/Mac OS X and Windows/Linux) it is best to name everything in
lowercase so data can be interpreted the same way on each operating system. The same is true if working
between studios using Windows, Mac OS X, and Linux.
The Create Environment dialog box appears.

2. In the Environment Name field, type the new project's name.

NOTE: The environment name must be composed of alphanumeric and can include underscores (_), but no
spaces or other special characters, and it is case-sensitive. By default, an envuironment's name cannot
exceed 23 characters. If Unicode is enabled, an environment's name cannot exceed 120 characters.

3. If you want the user to automatically get the rights to modify all the scene assets (drawing, scene setup,
palette lists, etc.), select the Get Rights to Modify All Scene Assets option.

4. Click OK.
The new environment appears in alphabetical order in the Environments list.
After you create an environment, you must add it to the Batch Processing queue so it can vectorize and
render the drawings and scenes automatically. You only have to add the environment to the Batch
Processing queue once.
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Deleting Environments in Control Center
When you are ready to remove old environments, you can delete them from the database. However, in order to
prevent accidental loss of data, you can only delete an empty environment (an environment that contains no jobs,
images, or palette information).
How to delete an environment
1. In the environment section, select the environment to delete from the Environments list.
2. Do one of the following:
l

From the top menu, select Environment > Delete.

l

Right-click in the Environments section and select Delete.

The Delete command is only available for an empty environment. You must delete the scenes
and jobs before you can successfully delete the environment.

The Confirm dialog box appears.

3. Click Yes to delete the selected Environment.
The environment no longer appears in the Environments list.
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Setting the Resolution File for Control Center
When you create a new environment or job, you can create a project resolution list that will appear in Harmony
Advanced or Harmony Premium. If you work with a particular resolution, you can insert it in your list so it's
available when doing the compositing in Harmony.
You need to copy the resolution.conf file at the server, environment or job level. If you insert the file at the
environment level, it is not necessary to add one at the job level. All jobs in the environment will use the
resolution.conf file at the environment level. If you want all environments to use the same resolution.conf file,
place the copy at the server level in the USA_DB folder.
Starting with Harmony Server 11.1, the resolution list is stored in an XML file. The resolution.conf file is still used
and it is still the file that you will copy from the samples folder. If you modify the resolution list in the Scene
Settings dialog box, Harmony will convert the file to an XML file.
The resolution.conf file is located here:
l

Windows: Program Files > Toon Boom Animation > Harmony 14 [Edition] > resources > samples

l

Mac OS X: Applications > Harmony 14 [Edition] > tba > resources > samples

l

Linux: /usr/local/ToonBoomAnimation/harmony_14/resources/samples

NOTE: For Web Control Center, there is a WebCC preview resolution for previewing movies and thumbnails. It should be in the samples folder. If it is not, be sure to place a copy in the resolution presets.

Insert the Resolution.conf file in the following directory:
Resolutions common to all jobs in
the environment.

/USA_DB/environments/environment_
name/resolution.conf

Resolutions common to all scenes in
/USA_DB/db_jobs/job_name/resolution.conf
the job.
Resolutions common to all scenes
and environments.

/USA_DB/resolution/resolution.conf

All scenes found under the environment or job have access to the resolutions stored in that file.
You can simply type new resolutions, modify or delete existing ones from the list. This file can also be sent to
other studios with whom you are working.
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Below is the resolution.xml file created by Harmony.
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About Jobs in Control Center
Within each environment is a list of jobs. These jobs contain all the segments for your animated sequence. If you
are creating a weekly television series called The Show, you could name your job show_ep_06 (the_show
would be the name of your environment).
If each episode was composed of 100 animated shots, each job would contain 100 scenes.
If you want to remove a job and its data from the Harmony database and archive it, you can export the job from
Control Center.

IMPORTANT: You cannot archive a job by deleting the job. If you want to archive a job, you should export it
to a new location where it can be stored permanently.

Creating Jobs in Control Center
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Changing Job Stages in Control Center
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Changing Job Priorities in Control Center
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Deleting Jobs in Control Center
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Creating Jobs in Control Center
Every job must be created under an environment. Each job must have a unique name. Two jobs cannot have the
same name, even if they appear in two different environments, because all the jobs are in the same folder on the
server.
How to create a job
1. In the Environments section, select the project in which you want to create a job.
2. Do one of the following:
l

From the top menu, select Job > Create.

l

Right-click in the Jobs section and select Create.

The Create Job dialog box appears.

3. In the Name field, type the name of the job you want to create.

NOTE: The job name must be composed of alphanumeric and can include underscores (_), but no spaces or
other special characters, and it is case-sensitive. By default, a job's name cannot exceed 23 characters. If
Unicode is enabled, a job's name cannot exceed 120 characters.

4. In the TD menu, select a technical director (TD). You must select a technical director to create the job.
A TD is usually the person who oversees the animation project and makes sure the work is done properly.
Select the person who most closely resembles this definition. If you do not have a particular user for the task,
you can simply assign usabatch.
When you create your Harmony users, you can label a user as a technical director (TD).
5. In the ATD menu, select an assistant technical director (ATD). You must select an assistant technical director to create the job. If you do not have an ATD, select the same person for the TD and ATD jobs.
In some studios, the responsibilities of the technical director can be shared by more than one person. This
second person is the ATD.
The technical director and assistant technical director you select appear in the Scenes list for each scene of
the job.
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6. In the Approval menu, select how Harmony will mark the various stages the scenes will pass in your production schedule.
l

l

Automatic: When you work on your scenes, Harmony automatically approves their status
at each stage
Manual: When you work on the scenes, the technical director or the assistant technical director must approve their status at each stage using the Change Stage command (available
in the Scene menu).

7. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or Render
queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of other projects with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
If you do not know what priority to assign to your project, you can leave it at 5. You can always change it
later.
8. Click OK.
Control Center adds your new job to the selected environment and it appears in alphabetical order in the
Jobs list.
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Changing Job Stages in Control Center
As you continue working on your animation project, you may want to update the status of the jobs in your
environment. This status can display one of three things:
l

The stage the job has reached

l

When the job will be vectorized

l

When the job will be rendered

As you complete your animation project, you can update a job's status to reflect where it is in the overall production
process. You can classify jobs as being "In Production" or "Completed".
l

l

In Production: The job is still a work in progress. The other nodes can still access this job.
Completed: The job is finished. The Harmony database still has all the job's components (scenes, elements,
drawings), but the job neither appears nor is accessible from the Harmony applications.
In most cases, you would mark a job as "Completed" after it has been finalized (inked, painted, rendered) and
transferred to a medium, such as Blu-ray, or sent to post-production.
You can change a job's status from "Completed" to "In Production" at any time to continue working on it.

Changing the job's stage from In Production to Completed only hides the job in the Control Center window; all the
associated files with the job are still on your system.
How to change a job's stage and view the list of completed jobs
1. In the Environments section, select an environment.
2. Do one of the following:
l

From the top menu, select Job > Change Stage.

l

Right-click in the Jobs section and select Change Stage.

The Change Stage of Jobs window appears.

3. Select the jobs whose stage you want to change.
l

If you want to change a job from In Production to Completed, select the jobs in the In Production list.
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If you want to change a job from Completed to In Production, select the jobs in the Completed list.

4. Click one of the Change buttons to change the job's status.
l

Click the Change to Completed

l

Click the Change to In Production

button to change a job that is in production.
button to change a job that is completed.

5. Click OK.
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Changing Job Priorities in Control Center
Before you send a job's scenes to be vectorized or rendered, you can change the job's priority level in the processing
queue. Increasing a job's priority lets the system process it before other jobs in the processing queue.
Use the Choose New Priority dialog box to change a job's rendering and vectorization queue priority. The priority is
set using a sliding scale where 0 is the highest priority and 10 is the lowest.
For example, if job B is before job A in the queue, you can change the priority, so job A is processed first.
Changing a job's priority does not affect vectorizing or rendering jobs that are already sent in the queue. It will only
affect jobs that are sent after making the change. If you want to change a job's priority after it has been sent to the
queue, use the Change Priority button in the Queue window.
How to change a job's priority
1. In the Environments section, select the environment containing the job you want to change the priority for.
2. In the Jobs section, select the job whose priority you want to change.
3. Do one of the following:
l

From the top menu, select Job > Change Priority.

l

Right-click in the Jobs section and select Change Priority.

The Choose New Priority dialog box appears.

4. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or Render
queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of other projects
with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
5. Click OK. When you send this job to be vectorized or rendered, it will have this new priority in the processing
queue.
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Deleting Jobs in Control Center
You should only delete jobs that you no longer need or that have already been exported to an archive (using the
Export command available in the Admin menu).
When you delete a job, the following components are permanently removed:
l

Scenes

l

Elements

l

Drawings

l

Database information associated with the selected job

l

Palettes stored under the selected job

Before you delete a job:
l

l

Make sure no one else is currently using the job. Failure to do this may result in file corruption and loss of
your work.
Wait until everyone is offline. This ensures no one can open the data files while you delete them.

NOTE: You cannot delete a job if it still contains scenes.

How to delete a job
1. In the Environments section, select the environment containing the job you want to delete.
2. In the Jobs section, select the job you want to delete.
3. Do one of the following:
l

From the top menu, select Job > Delete.

l

Right-click in the Jobs section and select Delete.

The Confirm dialog box appears.

4. Click OK.

40

Harmony 14 Server Installation Guide

About Scenes
After you create a scene, you can view the corresponding elements and drawings in the Control Center window.
When you select the environment and the job, the corresponding scenes for the selected job appears in the Scenes
list in the Control Center window.
For each scene in your job, you must create a unique exposure sheet to lay out the drawings, camera effects, audio
tracks, and other special effects for that scene.
Creating Scenes in Control Center
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Renaming Scenes in Control Center
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Changing Scene Priorities in Control Center
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Clearing Scenes in Control Center
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Copying Exposure Sheet in Control Center
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Creating Scenes in Control Center
When creating your scene, you must select the path where you want to store the scene data and where you want
the new scene to appear in the Scenes list. You can create a single scene or create multiple scenes all at once.
You do not have to enter the word "scene" when entering scene names. The system automatically adds scenein front of the name. For example, when you type"3" in the Scene Name field, the scene name automatically
displays as "scene-3" throughout the file system. The scene name will have "scene-" as a prefix, but that will only
be visible when looking at the scene on the file system. The scene will appear without this prefix in all the
Harmony applications.
How to create a scene
1. In the Environments section, select the environment containing the job you want to add scenes in.
2. In the Jobs section, select the job you want to add scenes in.
3. Do one of the following:
l

In the Scene section, select Scene> Create.

l

Right-click in the Scenes section and select Create.

The Create Scene dialog box appears.

4. Click in the Scene Name(s) field and enter the name for the first scene you want to create.
5. Press the Enter/Return keyboard shortcut to move onto the next scene.
6. Enter the name of the next scene you want to create.

NOTE: By default, when creating a new scene or renaming a scene, the scene's name cannot exceed 23
characters. If Unicode is enabled, the scene's name can not exceed 119 characters.
When creating scenes in Control Center, you should enter the scene names exactly as they appear on the
actual animation. This ensures that the information in your environment is consistent with the actual
animation.
The job and scene names are alphanumeric and can include underscores (_), but no spaces, or other special
characters. The environment name is case-sensitive.
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7. Repeat the previous steps until you have named all the scenes you want to create.

8. In the File System list, click the path where you want to store the files.
If you do not see the desired path in the list, specify a different path in the Other File System field.
If you are unsure which disk drive to select, consult your technical director or system administrator.
The information in the File System list displays:
l

Available drives on which you can store new scenes

l

Space that is currently available (in megabytes)

l

The percentage of space the drives are currently using

NOTE: Although you can add as many scenes as you wish, you can only select one path at a time. Therefore,
Control Center stores all scenes you create in one session at the same place (same path).

9. Select where you want to place the scene in the Scenes list from the Add Scenes menu. These are the
options:
‣

At Bottom: Places the new scenes at the bottom of the list

‣

At Top: Places the new scenes at the top of the list

‣

Before Selected: Places the new scenes before the selected scene

‣

After Selected: Places the new scenes after the selected scene

‣

Name Sort: Arranges the new scenes alphabetically.

NOTE: To use the After Selected and Before Selected options, you must select another scene from the Scene
list in the Control Center window.

10. Click OK.
The new scene is created and displayed in the Scenes list. If you do not want to create the scene, click
Cancel.
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Deleting Scenes in Control Center
When you delete a scene, you not only remove the scene from the Control Center window, but you also
permanently remove all the information associated with the scene including:
l

Exposure sheet (and all associated versions)

l

Elements

l

Drawings

l

Database information

l

Any palettes stored in that scene's palette library

Before you delete a scene:
l

Make sure that you really want to remove all this information from the system

l

Are you going to use the scene in the future?

l

Do you need to archive the scene for future use?

l

Make sure no one else is currently using the scene.

l

failure to do this may result in file corruption and loss of your work.

l

Wait until everyone is offline. This ensures no one can open the scene while you delete it.

How to delete a scene
1. In the Scenes list, select the scene name you want to delete.
2. Select Scene > Delete or right-click anywhere in the Scenes list and select Delete.
The Confirm dialog box appears.

3. Click Yes to delete the scene and all its related information.
The scene name and all its associated files are deleted.
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Moving Scenes in Control Center
When you create a scene, it and its associated files are stored on one drive. If you find you are running out of space,
you can move a scene to another drive. However, you can consolidate all the scenes for a particular job in a single
directory allowing you to find related information quickly. You may also want to file your scenes in specific
directories, creating a customized directory system. The Move command lets you move scene data from one file
system to another.
Before you move a scene's data:
l

l

Make sure no one else is currently using the scene's data. Failure to do this may result in file corruption and
loss of your work.
Wait until everyone is offline. This ensures no one can open the data files while you move them.

How to move a scene from one directory to another directory
1. In the Scenes section, select the scenes you want to move.
2. Do one of the following:
l

From the top menu, select Scene > Move.

l

Right-click anywhere in the Scenes list and select Move.

The Move Scene dialog box appears.

3. In the Select Scene(s) to Move field, select the scenes you want to move from their current directory.
4. Click Calculate to know how much hard disk space your selection requires.
5. In the Move Scenes To list, select the directory where you want to move the scene. If it does not appear in
the list, enter the directory path in the Other field.
The Control Center node automatically checks the amount of free space for each directory and compares it to
the size of the scene you want to move.
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If there is not enough disk space on a particular drive/mount point to store the scene, the directory displays
a not "enough space message". Choose another disk from the list.
6. Click OK.
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Renaming Scenes in Control Center
As you work on your scenes, their nature and contents may change and the name you gave the scene when you
began the project may no longer reflect its contents. In this case, you can rename the scene to more accurately
reflect its contents.
Before you rename a scene:
l

Make sure no one else is currently using the scene.
Failure to do this may result in file corruption and loss of your work.

l

Wait until everyone is offline. This ensures no one can open the scene while you rename it.

How to rename a scene
1. In the Scenes section, select the scene to rename.
2. Do one of the following:
l

From the top menu, select Scene > Rename.

l

Right-click anywhere in the Scenes list and select Rename.

The Rename Scene dialog box appears.

3. In the Enter New Scene Name field, type the new name for the scene and click OK. Try to keep scene
names brief. It is recommended that you use no more than 23 characters.

NOTE: Use lower case letters if these scenes may be used with a Windows workstation.

NOTE: By default, when creating a new scene or renaming a scene, the scene's name cannot exceed 23 characters. If Unicode is enabled, the scene's name can not exceed 119 characters.

47

Chapter 2: Control Center

About Environments, Jobs and Scenes in Control Center

Changing Scene Priorities in Control Center
You can change the scene's priority level in the processing queue. Increasing a scene's priority lets the system
process it before other scenes in the processing queue.
Use the Choose New Priority dialog box to change a scene's rendering and vectorization queue priority. The
priority is set using a sliding scale where 0 is the highest priority and 10 is the lowest. If a scene has already been
sent to the queue changing the priority at this point will not affect its priority in the queue. Changes will only be
applied next time it is sent to the queue. To change a scene's priority after it's been sent to the queue, use the
Change Priority button in the Queue window.
For example, If scene B comes before scene A in the queue, you can change the scene's priority so that scene A
will be processed first.
How to change a scene's priority
1. Select the environment, the job and the scene you want to prioritize.
2. Do one of the following:
l

From the top menu, select Scene > Change Priority.

l

Right-click anywhere in the Scenes list and select Change Priority.

The Choose New Priority dialog box appears.

3. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or Render
queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of other projects with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
4. Click OK.
The new scene priority appears in the Scenes list in the Priority column.
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Changing Scene Stages in Control Center
The Change Status command allows you to change the approval stage name of a selected scene that is in Manual
approval mode. You can also create customized approval stages that reflect the approval process in your production
environment.
A scene's status is a method of tracking its progress in your production; the scene's current status does not stop
you from advancing the scene to other stages.
Changing a scene's status and making manual approvals allows you to assign and change a scene's approval
stages to keep track of its current status. For example, if you have a scene whose drawings are being scanned, you
will mark it as the Scan stage. After you begin adding colour to these line drawings, you can change the scene's
stage to Paint. If the selected scene has an automatic approval policy, the Change Stage command will be inactive
in the Scene menu. To change a scene's status, you must ensure that the approval policy is set to Manual.
How to change a scene's status
1. In the Scenes section, select a scene.
2. Do one of the following:
l

From the top menu, select Scene > Change Status.

l

Right-click anywhere in the Scenes list and select Change Status.

The Change Status dialog box appears.

The current status of the selected scene appears in the From Stage field.
3. Select the status you want to apply to the current scene from the To Stage menu.
4. Click OK.
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Resequencing Scenes in Control Center
You can change the sequence of scenes in your job, which affects the order in which the scenes appear in the job
throughout the system. You can place a scene anywhere in the Scenes list or you can sort them
alphanumerically.
How to resequence a scene
1. Select the job whose scenes you want to re-sequence from the Jobs panel.
2. Do one of the following:
l

From the top menu, select Scene > Reorder.

l

Right-click anywhere in the Scenes list and select Reorder.

The Reorder Scenes dialog box appears.

3. Select the reordering method by clicking on the column headers or dragging the scenes up or down.
4. Once the scenes are ordered, click OK.
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Clearing Scenes in Control Center
If you must restart a scene from scratch, you can completely erase a scene's exposure sheet. When you clear a
scene, you delete all exposure sheet database information and reset the scene as if it were completely new. You are
only deleting the files from the database; Control Center does not actually delete any image files (drawings, scan,
final frames). If you have questions concerning the contents of a scene, you should contact the technical director
responsible for the scene in question.
If you must clear a scene from Control Center, make sure no one else is currently using the scene's data. If you
clear a scene that someone else is working on at that moment, you run the risk of corrupting the files and losing
work.
If you must clear a scene, you should wait until everyone is offline to ensure that no one can open the data files while
you clear them from Control Center.
How to clear a scene
1. Select the environment, job or scene you want to clear.
2. Do one of the following:
l

From the top menu, select Scene > Clear.

l

Right-click anywhere in the Scenes list and select Clear.

The Confirm dialog box appears.

3. Click OK.
The Scene list refreshes itself and displays blank elements and drawings lists, showing that the Control
Center node has deleted the exposure sheet for the scene you cleared.
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Copying Exposure Sheet in Control Center
When you have two scenes with similar exposure sheet information, instead of entering the information twice,
you can:
1. Enter the information for one exposure sheet.
2. Copy it to the other scene.
3. Modify the second exposure sheet as needed.
The Copy command lets you copy an existing exposure sheet from one scene into another scene. You can then
modify the copied exposure sheet using Harmony.
How to copy an exposure sheet to another scene
1. Select the environment and the job from the Control Center window.
2. Do one of the following:
l

From the top menu, select Scene > Copy.

l

Right-click anywhere in the Scenes list and select Copy.

The Copy Scene dialog box appears.

3. Select the environment, job, and scene to copy from the exposure sheet from the From panel.
The lower half of the dialog box displays the environments, jobs, and scenes to which you can copy the
exposure sheet.
4. Select the environment, job, and scene where you want to copy the selected exposure sheet to the To
panel.
5. If you want to copy the associated animation data files with the scene's exposure sheet, select the Copy
All Data Files option. Harmony will place a copy of the animation data in the target scene's storage
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directory.
6. Click OK.
7. If the scene you are copying to already has an exposure sheet, a Confirm dialog box appears to make sure
you want to replace the existing exposure sheet.
l

Click Yes if you want to copy over the existing exposure sheet.

l

Click No to cancel the copy or to select a different scene.

The Copy Xsheet dialog box disappears. You can view and modify the copied exposure sheet using Harmony
Advanced or Harmony Premium.
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About Elements and Drawings in Control Center
You must use Harmony Advanced or Harmony Premium, instead of Control Center, to add elements or drawings
to your environment. After you add them in the exposure sheet and save the source, Control Center displays
them in the Elements and Drawings panels.

When you select a scene in the Scenes list, all of the elements associated with the scene (background,
characters, etc.) appear in the Elements and Drawings lists. Control Center retrieves these components from
information you previously entered in the exposure sheet.
You can click the Expand/Collapse

buttons to show or hide the Elements and Drawings sections.
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About Scene Import and Export in Control Center
You can export your scene to work offline from a location where the Harmony server is not located. An example
would be from the studio to your home. When you return to the studio, you can then import your scene to reintegrate
it back into the Harmony environment.
If your scene has shared images, textures (used colour-overrides) and palettes stored at the environment or job level
on the Harmony server, these links will be broken when you export your file. You can create presets to point to
where these linked files are located. For example, you can store your images, textures and palettes somewhere on
your home computer and create a preset to point to where these files are located. Then when you get back to the
studio, you can select another preset that points to where the files are located on the Harmony server.
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Remapping Palettes, Textures and Linked Images in Control
Center
When working in a studio, shared palettes, images and textures used in colour-overrides are saved to specific
locations, at the environment or job level, on the Harmony server. When you export your scene to work offline at
another location, such as from home, you will find that when you open the scene from the new location, Harmony
will be unable to find these files.
To avoid this problem, you can create presets that will point to where these shared files are located when you are
working offline from a different location, as well as presets to point back to the Harmony server when you get
back to the studio.
You will still need the studio to give you a package with the shared palettes, textures and images.
Once you have created remapping presets, the Choose the Remapping Group dialog box will open every time you
open a scene.

NOTE: When exporting your scene, do NOT check the options to have shared palettes exported from the
environment and job levels.

How to create remapping presets
1. Transfer palette, image, texture files, taken as a package from the studio, to a safe location on your computer.
2. Go to the etc folder in the Harmony program/application files:
l

l

Windows/Linux: Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premium\etc
Mac OS X: Applications/Toon Boom Harmony 14.0 Premium Network/tba/etc

3. Open the relink.xml file in a text editor.
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4. Copy and paste the code indicated below to the indicated location.

5. Change the relink name from "group1" to something more informative. An example would be "Offline".
6. Change the description values to the locations where you have stored your offline palettes, images and textures on your computer.
The description values do NOT set the location paths for these files. Description values are descriptive lines
of text. They appear in the GUI of the Choose the Remapping Group dialog box that opens to relink offline
assets. The set path locations would not be visible otherwise in the Choose the Remapping Group dialog box
and it's useful to know these locations. Therefore the description values and path type values should be
identical, as one describes the other. You can add or remove as many description values as you like.

57

Chapter 2: Control Center

Remapping Palettes, Textures and Linked Images in Control Center

7. Change the path type values to the desired locations for your palettes, textures and images. These commands set the location paths. An example for a path type value, when you are working offline, is somewhere on your home computer.
8. If you would like to create multiple presets, repeat steps 3-6, using a different relink name each time. An
example would be "Online", where your path type values would point to locations on the Harmony server.
How to use remapping presets offline
1. Open your scene in Harmony Harmony from your present location.
2. Select to Work Offline.
The Choose the Remapping Group dialog box appears. If it does not appear, remapping presets have not
been created. This needs to be done first.

3. From the Select Group drop-down list, select a preset.
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OR
If you haven't changed location from your last session, click Don't Remap which opens your Harmony
scene.
4. If you selected a preset, click Select.
Your Harmony scene opens with all the shared images, textures and palettes properly linked.
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Exporting Scenes from Control Center
You can use Control Center's export utility to migrate scenes from your system for archival purposes, to export to
third party software or to copy scene data.
Harmony creates two files during export:
l

README.txt: Includes export statistics, such as creation date and user ID

l

IEContents.dat: Includes export parameters

NOTE: You can compress the export package to make it transportable. However, it will resolve hard links
and symbolic links, which might be contrary to your export options.

How to export data
1. Launch Control Center. To learn more about the different launch methods, see Starting Control Center on
page 13.
2. From the top menu, select Admin > Export.
The Export Scene(s) dialog box appears.
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3. Enter the path where you want to export the files. You can also use the Browse button to select the path and
create a folder. The destination must be an existing empty folder or a new folder that will be created during the
export process.
4. Click Add to select the scenes that you want to export from the Harmony database. You can select a job to
select all the scenes in the job. The scenes you select will appear in the list.
5. Select one or more scenes and click Remove to remove scenes from the export list.
6. In the Data Options tab, select what you want to export:
Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements in the scene.

Database

Final Frames

If you select this option and deselect the Elements option, you can
access the elements from the Element Manager in the Control Center,
but their drawing and bitmap files will not be included. The list of
available versions in the scene is also exported. It is not possible to
open a scene if this is not selected for export.
Exports the directory that contains the final, rendered frames.

61

Chapter 2: Control Center

Exporting Scenes from Control Center

Other Directories

Exports all other directories and files in the scene's data structure.

Elements

Selected by default, this option exports the contents (drawing and
bitmap files) of the Element directories.

Timing Drawings

Selected by default, this option exports the contents of the Timing
directories.

Annotation

Lets you export the different drawings created while drawing in the
Annotation columns and imported images.

Stage (xsheet & network)

Selected by default, this option exports the Harmony directory, which
contains the Harmony files for each scene you export. These files are
necessary if you want to reuse the exposure sheet (timing) and the
node structure from the original scene.
If this option is selected, you can select the Get Outside Drawings
option to copy drawings into the scene folder that is referred to by the
Timing columns and their Element (Drawing) nodes.
Exports the palette-library directories. Decide if you want to export
the palette-library from the environment, job or scene level. When you
select a level, the palette-library in lower-level directories will also be
exported.

Palettes

Check Backup if you want to export the palette-list file which is
necessary for the scene to know which palettes to use. In most cases,
you should select this option as well as the Scene option.
Macros

Exports the macros (customized effect and node connections) that
were created and stored in the environment, jobs or scenes to be
exported. This is necessary if you have legacy scenes with macros.

Libraries

Exports templates created at the selected levels.

7. In the Advanced Options tab:
l

l

Windows: Due to constraints in the operating system, you do not have any choices on the
Advanced Options tab. In Linux, you can make the following selections.
(Mac OS X and Linux): Select how you want to package the exported scene. The choices
you make here are related to the size of the export package as well as the speed of the
export process. In Linux, you can make the following selections.
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l

Select one of the following options in the Exporting Files section:

Parameter

Description
Speeds up the export process by making hard links to the original files
on the file system. Hard links keep disk space usage to a minimum
and ensure a quick export process.

As hard links if possible, otherwise copy

If it is not possible to create hard links (because the links cross file
systems, for example), the entire contents will be copied to the
destination directory, which will be a slower process that will take up
more space on your file system.
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As hard links when possible, otherwise
symbolic links

Ensures a quicker export process. However, if symbolic links are
used and the original file is deleted, the symbolic link will be broken.

As symbolic links

Exports the scene using symbolic links to the original scene files
(when importing, imports the scene using symbolic links to the export
directory). While this process will reduce the size of the export directory, if the original file is deleted, the symbolic link will be broken.

Copy

Copies all scene data to the export location. This produces the largest
export package and therefore takes the longest to complete.
However, it is the simplest method.

8. In the Valid Links Options section, select one of the following options:
Parameter

Description

Keep them

Maintains symbolic links.

Resolve them

Removes symbolic links, replacing them with the actual files.
When you use this option, the export package will contain real files,
rather than symbolic links.

Ignore them

Does not include valid symbolic links in the export package.

9. In the Broken Links Options section, select of the following options:
Parameter

Description

Keep them

Keeps symbolic links to missing files. When the missing files are
placed in the path searched by the symbolic link, broken links will
be valid again.

Ignore them

Does not include broken symbolic links in the export package.

10. Click Calculate to get a preview of the size of your export package.
11. Click Export.
The selected files and components are exported. Use the Message Log tab to view messages generated
during the export process.
Unlike Windows, where the database information and scene data have been copied to a different directory,
Linux creates a set of links to the data. You must use additional Linux commands to retrieve the animation
data pointed to by the links.
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Importing Scenes to Control Center
You can use the import utility to integrate scenes into a Harmony environment.
If the imported files are compressed, you must decompress them to a temporary directory before you can import
them into Harmony. If you don't know how to decompress these files, see your system administrator.
How to import files into Control Center
1. Select Admin > Import.
The Import Scene(s) dialog box appears.

2. In the Package Directory section, click on the browse button at the end of the field to search for a Harmony
scene to import.
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Any supported Harmony file can be imported, including IEContents.dat files. The IEContents.dat
file includes database and scene file information. IEContents.dat files are created when you DO NOT
check the Export to Offline option in the Export Scene(s) dialog box in Control Center.
3. In the Destination section, click the browse button to open the File System Selector window. Select the
environment, job and file system for where you want to place the imported scene.

4. In the Scene(s) to Import section, select the scenes you would like to import. If no scenes are selected, all
the scenes will be imported.
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5. In the Data Options tab, customize your import options:
Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements in the
scene.

Database

If you select this option and deselect the Elements option, you
can access the elements from the Element Manager in
the Control Center, but their drawing and bitmap files will not be
included. The list of available versions in the scene is also
exported. It is not possible to open a scene if this is not selected
for export.

Final Frames

Exports the directory that contains the final, rendered frames.

Other Directories

Exports all other directories and files in the scene's data
structure.

Elements

Selected by default, this option exports the contents (drawing
and bitmap files) of the Element directories.

Timing Drawings

Selected by default, this option exports the contents of the
Timing directories.

Annotation

Lets you export the different drawings created while drawing in
the Annotation columns and imported images.
Selected by default, this option exports the Harmony directory,
which contains the Harmony files for each scene you export.
These files are necessary if you want to reuse the exposure
sheet (timing) and the node structure from the original scene.

Stage (xsheet & network)
If this option is selected, you can select the Get Outside
Drawings option to copy drawings into the scene folder that is
referred to by the Timing columns and their Element (Drawing)
nodes.
Exports the palette-library directories. Decide if you want to
export the palette-library from the environment, job or scene
level. When you select a level, the palette-library in lower-level
directories will also be exported.
Palettes
Check Backup if you want to export the palette-list file which is
necessary for the scene to know which palettes to use. In most
cases, you should select this option as well as the Scene
option.

Macros

Exports the macros (customized effect and node connections)
that were created and stored in the environment, jobs or scenes
to be exported. This is necessary if you have legacy scenes
with macros.

Libraries

Exports templates created at the selected levels.

6. Check the Remap Paths for Linked Palettes and Images option if your scene contains palettes, images or textures linked to a an offline location. Then from the drop-down list, select the preset that points to the location
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on the server where copies of these same files are located—see Remapping Palettes, Textures and Linked
Images in Control Center on page 56
7. Check the Check In option (beside the Import button), if your scene was checked out during export. If your
scene was not checked out, this option remains disabled.
8. Click Import.
If the scene already exists, the Scene Exists dialog box appears.

Decide if you want to import or skip importing your first selected scene. The Import All Scenes option will
import all selected scenes.
9. Use the Message Log tab to view messages generated during the import process.
If the name of the scene you are importing in Control Center is too long, you will be prompted with an error
message stating that it will be truncated. A scene's name cannot exceed 23 characters.
If you are importing scenes that were exported from the Harmony Network, or worked on in Harmony
Stand Alone, the system will try to retrieve the version name.

68

Harmony 14 Server Installation Guide

Troubleshooting in Control Center
If you have any problems exporting in Harmony, review the instructions to make sure you have followed them
completely. If you continue to have problems, consult the following list to troubleshoot common import and export
problems.
Problem: Import or Export Not Successful
If the transfer is not successful, an error dialog box appears to describe the problem. The most common
reason for a failed transfer is due to your current network permissions. See your system administrator for
help.
If the transfer fails in the middle of the process, the files that were imported or exported may be corrupt or
incomplete.
l

For a failed import, use Control Center to delete the scene.

l

For a failed export, manually delete the incomplete export folder.
If you click the Message Log tab, you can see more detailed descriptions, including error messages.
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Storing Files on Linux in Control Center
After Harmony copies the exported data to a temporary directory, you can move the archived data to your storage
device.
Copying the exported data to a storage device is a two-fold process. Copy the exported animation files to a file on
the storage device. Then remove the temporary export data from your system.
In Linux, exporting your scenes using the Export command makes Harmony copy scene information and link
information to the temporary export directory you selected. Therefore, you must retrieve the animation data from
your server and copy it, along with the database information, to your storage device.
How to export your files to a storage device on Linux
1. Open a Linux shell and log in to the machine that connects to the storage device.
2. Copy the exported files using links from the source directory to the selected destination file. To export to a
file on a storage device, type the following command in a shell:
tb_backup_export_data -from [source_directory] -to [destination_file]
-writetarfile
l

Where [source_directory] is the folder where the scene was exported to.

l

Where [destination_file] is the file that will be created by the tb_ backup_export_data script.

3. After a successful copy of the exported data, remove the temporary export directory using the following
command:
tb_remove_export_data [export_directory]
l

Where [export_directory] is the folder where the scene was temporarily exported to before it
was copied to the file or storage device.
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Control Center Commands
Command

Action

Access Methods

About Toon Boom
Harmony

Mac OS X: Displays product, version,
licensing and copyright information.

Quit

Mac OS X: Closes the Control Center
window and ends the current session.

⌘ + Q.

File Commands
The File menu commands let you access the Log file and exit the application on Windows/Linux.
Command

Action

Access Methods

Exit

Windows/Linux: Closes the Control Center
window and ends the current session.

Ctrl + Q

View Log

Lets you view errors and warning messages
related to your actions during the current
Control Center session.

Environment Commands
The Environment menu commands let you manage the environments and queues.
Command

Action

Access Methods

Create

Opens a Create Environment dialog box,
where you can enter a name for a new
environment.

Right-click on the Environments list and select
Create.

Delete

Lets you delete an environment from the
database. You cannot delete an environment
Right-click on the Environments list and select
unless it is empty; delete all of the
Delete.
environment's scenes and jobs before
activating this command.

Change Asset
Lock

Enables or disables the automatic Global
Lock on the scenes under the selected
Environment.

Right-click on the selected environment in the
Environments list and select Change Asset
Lock.

Vectorize Queue

Opens the Vectorize Queue dialog box
where you can display the progress and
prioritize the drawings that the system is
converting to the TVG vector file format.

Right-click on the Environments list and select
Vectorize Queue.

Render Queue

Opens the Render Queue dialog box where
Right-click on the Environments list and select
you can monitor and prioritize the progress of
Render Queue.
the drawings that the system is rendering.

Job Commands
The Job menu commands let you manage the jobs and their state.
Command

Action

Access Methods
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Opens the Create Job dialog box where you
can add a new job to the selected
environment.
Create

Delete

Your job must have a name that is unique to
the animation database (for example, you
cannot have two jobs with the same name
even if they exist in different environments;
they are all in the same database).
Removes a job from the selected
environment. When a job is deleted, its
scenes, elements, drawings, palette library,
and database information are permanently
removed. If you want to archive a job, you
should only delete the job after you have
used the command to create the archive.

Right-click on the Environments list and select
Create.

Right-click on the Jobs list and select Delete.

Before you activate this command, verify
that the selected jobs are not currently in
use.

Change Stage

Opens the Change Stage of Jobs dialog box
where you can record the current stage of the
environment's jobs in the production
Right-click on the Jobs list and select
process. You can change the job from In
Change Stage.
Production to Completed, or from
Completed back to In Production if you
need to perform further work.

Change Priority

Opens the Choose New Priority dialog box
where you can set the priority of the
rendering and vectorizing tasks for one or
Right-click on the Jobs list and select Change
more jobs. The priority is set using a sliding Priority.
scale where 0 is the highest priority and 10 is
the lowest.

Scene Commands
The Scene menu commands let you manage the scenes.
Command

Action

Access Methods

Opens the Create Scene dialog box where
you can add one or more scenes to the
selected job. You can also choose to:
Create

•
•

Copy

Right-click on the Scenes list and select
Add a scene from another file system
Create.
and add it to your job.
Choose the position the scene will
take within the job.

Opens the Copy Scene dialog box where you
can copy a scene's exposure sheet into
Right-click on the Scenes list and select
another scene. You can select a source and Copy.
destination scene in which to copy the
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Xsheet data.
Removes a scene from the database. Before
you activate this command, make sure all
users are logged out of Toon Boom Harmony
and that no files are currently in use.

Delete

When a scene is deleted, its exposure sheet,
elements, drawings, palette library and
Right-click on the Scenes list and select
database information are permanently
Delete.
removed. If you want to archive a scene, you
should only delete the scene after you have
used the command to create the archive.
Before you activate this command, verify
that the selected scenes are not currently in
use.

Move

Opens the Move Scene dialog box where
you can move one or more scenes and their
associated files to a file location of your
choice. The Move Scene command allows
you to select one or more scenes and
calculate the amount of space you will need
at the new location to accommodate the
moved scene.

Right-click on the Scenes list and select
Move.

Before you activate this command, make
sure all users are logged out of Toon Boom
Harmony and that no files are currently in
use.

Rename

Opens the Rename Scene dialog box where
you can enter a new name for the selected
scene. Before you activate this command,
Right-click on the Scenes list and select
verify that no users are using the scene, all
Rename.
users are logged out of Toon Boom Harmony
and that no files are currently in use.
Unlocks a scene was locked in Harmony.
Generally, a scene unlocks when it is closed
by a user. However, if a computer crashes
while a scene is locked and in use, a scene
may remained locked even if it is not open.

Force Unlock

An unlock confirmation message appears
detailing the consequences of using this
option.

Right-click on the Scenes list and select
Force Unlock.

If you activated this command for more than
one scene, you will be prompted for
confirmation to unlock each scene
separately.
Force Unlock
Version

Unlocks a version of a scene that has been
Right-click on the Scenes list and select
locked by Harmony. Generally, a scene
Force Unlock Version.
unlocks when it is closed by a user, however
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if a computer crashes while a scene is
locked and in use, a scene may remained
locked even if it is not open.
An unlock confirmation message appears
detailing the consequences of using this
option.
If you activated this command for more than
one scene, you will be prompted for
confirmation to unlock each scene
separately.
Checks in a scene that was checked out, but
not checked back in.
Force Checkin

Use this command only in extreme cases.
Otherwise, two versions of the same scene
will be in use, which will cause conflicts.

Checkin

Checks in a scene that you checked out.

Checkout

Checks out a scene. If a scene is already
checked out, it is available as read-only and
you cannot make any changes to it.

Change Priority

Opens the Choose New Priority dialog box
where you can set the priority of the
rendering and vectorizing tasks for one or
more scenes. The priority is set using a
sliding scale where 0 is the highest priority
and 10 is the lowest.

Right-click on the Scenes list and select
Change Priority.

Activating this command affects all
subsequent scenes you create. You can
change the priority of a scene already sent to
the batch processing queue by using the
Change Priority button in the queue.

Change Stage

Opens the Change Scene Stage dialog box
where you can record the current stage of
progress in a scene in an environment or a
production.

Right-click on the Scenes list and select
Change Stage.

This command is inactive if the scene's
approval policy has been set to Manual in the
Change Approval Policy dialog box.
Reorder

Clear

Opens the Reorder Scenes dialog box where
Right-click on the Scenes list and select
you can change the sequence of the scenes
Reorder.
in a job.
Deletes a scene's exposure sheet. Only
exposure sheet files are deleted from the
database, not image files.
A delete confirmation message appears,
detailing the consequences of using this
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option and requests that you contact your
Technical Director if you are unclear about
this procedure.
Before you activate this command, make
sure that all users are logged out of Toon
Boom Harmony and that no files are
currently in use.
Send to Vectorize

Converts the Send to Vectorize command to
Right-click on the Scenes list and select
convert the selected drawings to the TVG
Send to Vectorize.
vector file format.

Send to
Unvectorize

Opens the Send Scenes to Unvectorize
dialog box where you can convert a scene's
vector drawings into bitmap drawings.

Right-click on the Scenes list and select
Send to Unvectorize.

Opens the Composite dialog box where you
Send to Rendering can add one or more scenes to the rendering
queue.

Right-click on the Scenes list and select
Send to Rendering.

Element Commands
The Element menu commands let you vectorize and unvectorize the elements.
Command

Action

Access Methods

Send to
Unvectorize

Opens the Send Elements to Unvectorize
dialog box and converts an element's vector
drawings into bitmap drawings.

Right-click on the Elements list and select
Send to Unvectorize.

Send to Vectorize

Converts the drawings for the selected
elements to the TVG vector file format.

Right-click on the Elements list and select
Send to Vectorize.

Drawing Commands
The Drawing menu commands let you vectorize and unvectorize the drawings.
Command

Action

Access Methods

Send to
Unvectorize

Opens the Send Drawings to Unvectorize
dialog box and converts selected vector
drawings into bitmap drawings.

Right-click on the Drawings list and select
Send to Unvectorize.

Send to Vectorize

Vectorizes the selected drawings.

Right-click on the Drawings list and select
Send to Vectorize.

Admin Commands
The Admin menu commands let you import and export scenes, and manage the users and approval policy.
Command

Action

Access Methods

Users

Opens the User List dialog box where you
can display all valid Toon Boom Harmony
users in the network. You can add, delete, or
modify users in this list.
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Command

Action

Change Approval
Policy

Opens the Change Approval Policy dialog
box where you can select a manual or
automatic approval of the production status
at each stage of each scene.

Vectorize Style

Opens the Vectorization Styles dialog where
you can select the vectorization style you
want to apply to drawings before sending
them to the vectorization queue.

Export

Access Methods

Opens the Export Scenes dialog box where
you can transfer copied data from the
database to a different directory.
You can also export scenes to Stage (offline
version) by selecting Export Offline.

Import

Opens the Import Scenes dialog box where
you can transfer copied data from another
directory into the database.

Lock When
Opening Scene

No Lock, Scene Lock, Version Lock, Asset
Lock options

Database Lock
Manager

Allow Unicode
Names

Lets you use up to 120 ASCII characters for
names of environments, jobs and scenes.
This means you can use characters for languages, such as Japanese, Chinese,
French, Spanish, and others, characters for
names in your database setup.

Help Commands
The Help menu commands let you access the Help files and Control Center About information when using
Windows/Linux.
Command

Action

Access Methods

Help

Lets you view the Control Center integrated
help system.

F1

Customer
Improvement
Experience
Program

The Customer Experience Improvement
Program allows Toon Boom to collect usage
information. The data does not contain any
personally identifiable information and cannot
be used to identify you. The data will consist
of a basic hardware description, a project
summary and usage information. The
information is used only for software
improvement purposes, as well as for
sharing with third parties for the same
reason.
This program is enabled by default but is
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Command

Action

Access Methods

voluntary. If you prefer not to participate, you
can opt out when you first launch the
software, by using a global preference, or by
a command line argument.
About

Windows/Linux: Displays product, version,
licensing and copyright information.
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Chapter 3: Web Control Center
Web Control Center is a web version of the Control Center for freelancers to connect to a studio's Harmony
database and download scenes to work on them remotely. Scenes can be uploaded when ready and merged back
on the server.

The Web Control Center can also be used inside a studio instead of the Control Center to make use of the movie
previews and thumbnails for each scene in the database.
More than one user can be logged into Web Control Center at the same time. Web Control Center updates live. This
means that a user can see changes being made in Web Control Center while he is making changes himself.
Connecting to Web Control Center
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83

About Users in Web Control Center
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Viewing User Lists in Web Control Center

86

Adding Users in Web Control Center

87

Deleting Users in Web Control Center

89

Editing User Information in Web Control Center

90

Refreshing User Lists in Web Control Center
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Creating Environments in Web Control Center
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Deleting Environments in Web Control Center
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Setting the Resolution File for Web Control Center
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Deleting Jobs in Web Control Center
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Deleting Scenes to Web Control Center
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Checking Scenes In and Out in Web Control Center

112

Renaming Scenes in Web Control Center
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Reordering Scenes in Web Control Center
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Clearing Scenes in Web Control Center
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Changing the Status of Scenes in Web Control Center
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Customizing the Scene Status Colour in Web Control Center
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Assigning Users Scenes in Web Control Center
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Setting Scene Priority in Web Control Center
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Searching Scenes in Web Control Center
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Vectorizing Scenes in Web Control Center
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Rendering Scenes in Web Control Center
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Downloading and Uploading Scenes in Web Control Center
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132

Web Control Center Commands
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Connecting to Web Control Center
Before you can access the Web Control Center to exchange scenes as a freelancer or manage the database as an
administrator, you must open a web browser and enter the Web Control Center URL. The URL must be set by the
studio's IT department. Refer to the Harmony Server Installation Guide for details on how to install and set up the
Web Control Center.
Note that if the Web Control Center application is not running, you will not be able to connect to it.
When installing Harmony Server, a default user is created called usabatch. The password is also usabatch.
When you log in for the first time, use this username and password. Once logged in, you can create a set of users.

NOTE:
l

Do not delete the usabatch username as it is used by Harmony Server for batch processing.

l

It is highly recommended to change the password.

How to connect to Web Control Center
1. Open a web browser.
2. In the Address bar, type the Web Control Center URL provided by the studio you are working with.
l

l

If you are an administrator viewing the Web Control Center instance installed on your machine,
enter localhost:8080. 8080 is the default port. If you modified it, enter your custom port
number in place of 8080.
If you are testing the connection from a different machine connected to the same local network,
enter [name of machine]:8080 or the custom port number you previously set.

The Web Control Center page opens.
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3. In the Username field, type the username assigned to you by the studio. If you are an administrator, enter
the administrator username.
4. In the Password field, type the password assigned to you by the studio. You can change your password
later. If you are an administrator, enter the administrator password.
5. Click Login.
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Web Control Center Interface
To manage a production, you will need the Web Control Center. Web Control Center is used to create new
environments, jobs, scenes and users, as well as to import and export scene packages. Web Control Center directly
manages your server database.

The Web Control Center interface is divided into several areas:
Parameter

Description

Top menu

Contains all the commands available in the Web Control Center. You can also
find the commands in the contextual menus available in each area by right-clicking.

Environments

Displays one of your projects, such as a feature film, a TV series or a group of TV
spots.

Jobs

Displays the sequences or episodes in your project (Environment). You can only
see your jobs when you select a project from the Environments list.

Scenes

Displays the scenes in an episode or sequence (Job). You can only see your
scenes when you select a job from the Jobs list. You can also see who checked
out the scene, as well as the number of versions and frames.
Click the Add Column button to add information columns to the scene list such as
Current Version, Frames, Checkout User and Priority.
Displays information on a selected scene, such as the name, priority, technical
director and user who checked the scene out.

Scene Information

You can also preview the scene's thumbnail and rendered clip of selected
scenes. When you select a scene that has no thumbnail available, the request is
sent to the Harmony database to create it. But first, batch processing must be
enabled on the Web Control Center server. If not, nothing will happen. For more
information, see Batch Processing in the Harmony Server Installation Guide to
learn how to set it up.
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NOTE: When navigating, click the Return to Scene list button in the top bar to return to the main page.
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About Users in Web Control Center
In an animation studio, there are people using Harmony who will be assigned different tasks, such as ink and paint or
compositing. Normally, you should create a different user for each one. This way, the person assigned to ink and
paint will only have access to the Paint module and not to other features that are not relevant to their work.
Anyone who uses Harmony must have a login name in order to run any of the modules. When using Harmony in
standalone mode, there is no username or password required. The Harmony login is independent from the computer
session login.
On Windows, by default, only the usabatch and BATCH users are created. However, you should not use them for
your staff. These should be kept for Harmony Server when performing background operations, such as batch
processing—see .
Users connecting to the database through Web Control Center should have a password as it's more secure when
accessing via the Internet. For Web Control Center users, it is recommended to create the users through Web
Control Center so you can set the password.

IMPORTANT: Before making the Web Control Center public, set passwords for all users so that deletion of
assets are restricted.
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Viewing User Lists in Web Control Center
The User List dialog box lists all the users and their details, including: username, first and last names, and user
type.
How to view the user list
1. Select Admin > Manage Users.
The Manage Users screen displays a list of users in the system.

2. Select a user from the list.
The user information is displayed on the right.

3. When you are finished, click Return to Scene List at the top-left of the screen.
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Adding Users in Web Control Center
All Harmony users must have their name on the user list to log in to any application. The system uses the login to
track activities; it is not a security lockout.
Each user also has a user "type" assigned to it which allows access to only some of the Harmony modules.
How to add a user to Harmony
1. Select Admin > Manage Users.
2. In the upper-right corner of the Manage Users screen, click Add User.
The Create New User section displays.

3. In the New username field, enter the person's user name.
4. Type the person's first name and last name in the corresponding First Name and Last Name fields. If you
want leave the field blank, enter a space.
5. In the Type list, select the user type to define the type of work the user typically performs. This will restrict
access to certain Harmony modules and operations in the Control Center—see .
General users should be set to Animator, Xsheet, Scan or Ink & Paint so they can't delete environments, jobs
or scenes.

6. For the password, do one of the following:
l

To set a password (recommended), select the Set Password option and enter a secure password in the New Password field. The user has the ability to modify the password later on.
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If you do not want the user to have a password, deselect the Set Password option and go to
step 8.

7. In the Confirm New Password field, retype the password to confirm it.
8. Click Create.
The name appears in alphabetical order in the user list.
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Deleting Users in Web Control Center
As your studio network grows and evolves, you may need to delete old or obsolete user profiles from your system.
After you delete a user profile, the person who used that profile will no longer be able to access Harmony. You
cannot delete yourself from the user list. If you accidentally delete a name, you must follow the procedure for adding
a user to put the user back into the system.
How to delete a user
1. Select Admin > Manage Users.
2. In the Manage Users screen:
l

Right-click on a user and select Delete User.

l

Select a user and click on the Delete User button.

The Confirm dialog box opens.
3. Click OK.
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Editing User Information in Web Control Center
You can edit the user profiles at any time to update the user information.

NOTE: To change your own user profile, log in as usabatch (the default user).

How to modify user information
1. Select Admin > Manage Users.
2. In the Manage Users screen, select the user to modify.
The Editing [username] section appears.
3. Modify the information as required.
4. Click Apply.
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Refreshing User Lists in Web Control Center
If new users were created through the Control Center module while working in Web Control Center, you can refresh
the list to get the most up to date information.
How to refresh the user list
1. Select Admin > Manage Users.
2. In the Manage Users screen, right-click on the user list and select Refresh List.

91

Chapter 3: Web Control Center

About Users in Web Control Center

User Types and Restrictions in Web Control Center
Here are the different user types available and their restrictions/permissions:

Feature

Web
Control
Control
Center
Center

RND,
Coordinator,
Supervisor,
TD,
Executive

Animator

Xsheet,
Archive

Scan

Ink &
Paint

Create Environment

•

•

•

Change Asset Lock on Environment

•

•

•

Delete Environment

•

•

•

View Vectorize Queue

•

•

•

•

•

•

View Render Queue

•

•

•

•

•

•

Create Job

•

•

•

•

Change Job Priority

•

•

•

•

•

•

•

Change Job Status

•

•

•

Delete Job

•

•

•

Create Scene

•

•

•

•

•

Delete Scene

•

•

•

Unlock scenes locked by
another user

•

•

•

Unlock scene version locked
by another user

•

•

•

Unlock scenes locked by me

•

•

•

•

•

Unlock scene version locked
by me

•

•

•

•

•

Move Scene

•

Rename Scene

•

•

•

Clear Scene

•

•

•

Change Scene Priority

•

•

•

•

•

•

•

Change Scene Status

•

•

•

•

•
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Reorder Scenes

•

•

•

Copy Scenes

•

•

•

•

Send to Vectorize

•

•

•

•

•

•

•

Send to Unvectorize

•

•

•

•

•

•

•

Send to Rendering

•

•

•

•

•

•

•

Add/Modify/Delete Users

•

•

•

Change Approval Policy

•

•

•

Change Vectorize Style

•

•

•

•

•

•

Change Asset Lock

•

•

Database Lock Manager

•

•

Export Scenes

•

•

•

•

•

Import Scenes

•

•

•

•

•

View Error Log

•

•

•

•

•

•

•

View Elements

•

•

•

•

•

•

View Drawings

•

•

•

•

•

•

Open in Harmony

•

•

•

•

Open in Paint

•

•

•

•

•

Open in Scan

•

•

•

•

•

•
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About Environments, Jobs and Scenes in Web Control Center
Every project you create with the Harmony solution starts with an environment, the highest level in the Web
Control Center. After that, you can add jobs and scenes. Elements (layers and columns) and drawings can only
be created directly in Harmony Advanced or Harmony Premium when working with the Web Control Center.
The Web Control Center divides your animation project into the following categories which organize the
components of your animated projects:

l

Environment: This is the name of your animation project.
Example: adventure_movie

l

Jobs: These are the major sections of an environment, such as sequences or episodes.
Example: adv_seq_001, adv_seq_002

IMPORTANT: All jobs are stored in the same location in the Harmony database. Be sure to prefix all job
names appropriately, so you can identify the project in which it belongs. Each job must have a different
name. You cannot give two jobs the same name.

l

Scenes: These are the different shots in a job.
Scenes are contained in their respective job folder in the Harmony database. If desired, prefix all scenes
names appropriately, so you can identify the environment and job to which they belong.
Example: adv_sc_001, adv_sc_002, adv_sc_003 and so on.

As your projects come and go, you will probably want to start cleaning up your database, as well as your server's
hard drive, by removing old and obsolete environments and their associated animation data.
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IMPORTANT: After you delete a scene, job, or environment, the associated data is permanently removed
from your storage disks. Make sure you really want to erase these items before you delete them as there is no
way to retrieve the data after it has been erased.

You might want to export old environments and archive them somewhere else before you delete them from your
system.

NOTE: If you are working in a mixed Windows/Mac OS X/Linux environment or share files with other studios
that do, you should use lowercase letters to name the various items in your animation projects and not include
any spaces. For example, write the_show instead of The Show. This is useful for Linux because it is casesensitive whereas Windows is not.
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132

96

Harmony 14 Server Installation Guide

About Environments in Web Control Center
Harmony uses environments to manage and organize related projects. Using environments allows you to organize
your production projects by their nature or type.
If your projects center around episodic and commercial types of work, you can create two environments. For
example, one environment called commercials and the other called the_show. Then you can insert the jobs that
relate to each type of project. When you want to work on a commercial project, open the commercials
environment and select the commercial job you need. Similarly, if you want to work on an episodic project, open the
environment called the_show.
Environment

Job
sc_001
dentist
sc_002

commercials

soda

sc_001

cereal

sc_001
sc_001

sho_001
sc_002
the_show

sho_002

sc_001
sc_001

dentist
sc_002
Creating Environments in Web Control Center
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Creating Environments in Web Control Center
Create environments in order to manage and organize you studio's projects.
How to create an environment in Web Control Center
1. From the top menu, select Environment > Create.
In mixed platform Environments (Windows/Mac OS X and Windows/Linux) it is best to name everything in
lowercase so data can be interpreted the same way on each operating system. The same is true if working
between studios using Windows, Mac OS X, and Linux.
The Create Environment dialog box appears.

2. In the Create Environment field, enter a name for the new project.

NOTE: The environment name is alphanumeric and can include underscores (_), but no spaces or other special characters. The environment name is case sensitive.

3. To grant the user with the rights to modify all the scene assets (drawing, scene setup, palette lists, etc.),
select the Change Asset Lock option.
4. Click Create.
The new environment appears in alphabetical order in the Environments list.

NOTE: After you create an environment, you must add it to the Batch Processing queue so it can vectorize
and render the drawings and scenes automatically. You only need to do this once. You can only do this in a
shell with the Setdef command.
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Deleting Environments in Web Control Center
When you are ready to remove old environments, you can delete them from the database. However, in order to
prevent accidental loss of data, you can only delete an empty environment (one that contains no jobs, images, or
palette information).
How to delete an environment
1. In the environment section, select the environment to delete from the Environment list.
2. Select Environment > Delete.
The Confirm dialog box appears.
3. Click OK.
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Setting the Resolution File for Web Control Center
When you create a new environment or job, you can create a project resolution list that will appear in Harmony
Advanced or Harmony Premium. If you work with a particular resolution, you can insert it in your list so it's
available when doing the compositing in Harmony.
You need to copy the resolution.conf file at the server, environment or job level. If you insert the file at the
environment level, it is not necessary to add one at the job level. All jobs in the environment will use the
resolution.conf file at the environment level. If you want all environments to use the same resolution.conf file,
place the copy at the server level in the USA_DB folder.
Starting with Harmony Server 11.1, the resolution list is stored in an XML file. The resolution.conf file is still used
and it is still the file that you will copy from the samples folder. If you modify the resolution list in the Scene
Settings dialog box, Harmony will convert the file to an XML file.
The resolution.conf file is located here:
l

Windows: Program Files > Toon Boom Animation > Harmony 14 [Edition] > resources > samples

l

Mac OS X: Applications > Harmony 14 [Edition] > tba > resources > samples

l

Linux: /usr/local/ToonBoomAnimation/harmony_14/resources/samples

NOTE: For Web Control Center, there is a WebCC preview resolution for previewing movies and thumbnails. It should be in the samples folder. If it is not, be sure to place a copy in the resolution presets.

Insert the Resolution.conf file in the following directory:
Resolutions common to all jobs in
the environment.

/USA_DB/environments/environment_
name/resolution.conf

Resolutions common to all scenes in
/USA_DB/db_jobs/job_name/resolution.conf
the job.
Resolutions common to all scenes
and environments.

/USA_DB/resolution/resolution.conf

All scenes found under the environment or job have access to the resolutions stored in that file.
You can simply type new resolutions, modify or delete existing ones from the list. This file can also be sent to
other studios with whom you are working.
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Below is the resolution.xml file created by Harmony.
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About Jobs in Web Control Center
Within each environment is a list of jobs that contains all the segments for your animated sequence. If you are
creating a weekly television series called The Show, you could name your job show_ep_06 (the_show would
be the name of your environment).
If each episode is composed of 100 animated shots, each job would contain 100 scenes.

IMPORTANT: You cannot archive a job by deleting it. To archive a job, export first and save it to a secure location to be stored permanently.
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Creating Jobs in Web Control Center
Every job must be created under an environment. Each job must have a unique name. Two jobs cannot have the
same name, even if they appear in two different environments, because all the jobs are in the same folder on the
server.
How to create a job
1. From the Environment list, select the project in which you want to create a job.
2. Select Job > Create.
The Create Job window opens.

3. In the New Job Name field, enter the name of the job to create.

NOTE: The job name is alphanumeric and can include underscores (_), but no spaces or other special characters. The job name is case-sensitive.

4. From the Technical Director list, select a technical director (TD). The names available are generated from a
list of all possible users by their login username. You must select a TD to create the job.
A TD is usually the person who oversees the animation project and makes sure the work is done properly.
Select the person who most closely resembles this definition. If you do not have a particular user for the task,
you can simply assign this field to: BATCH.
When creating Harmony users, you can label a user as a TD.
5. From the Assistant Technical Director list, select an assistant technical director (ATD). The names available
are generated from a list of all possible users by their login username. You must select an ATD to create the
job. If you do not have an ATD, select the same person for the TD and ATD jobs. In some studios, the
responsibilities of the TD can be shared by more than one person. This second person is the ATD.
6. From the Approval list, select how Harmony will mark the various stages that the scenes will pass through in
your production schedule.
l

l

Automatic: When you work on scenes, Harmony automatically approves their status at each
stage.
Manual: When you work on scenes, the TD or ATD must approve their status at each stage
using the Change Status command in the Scene menu.

103

Chapter 3: Web Control Center

About Environments, Jobs and Scenes in Web Control Center

7. Adjust the Priority slider to increase or decrease the job's priority (0 means the job has the highest priority
for processing through the Vectorize or Render queue, and a job with a priority of 10 is the least important).
Jobs with higher priorities pass in front of other projects with lower priorities in the rendering and vectorizing queues.
If you do not know what priority to assign to your project, leave it at 5. You can always change it later.
8. Click OK.
Web Control Center adds the new job to the selected environment; it appears in alphabetical order in the
Jobs list.
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Changing Job Status in Web Control Center
As you complete your animation project, you can update a job's status to reflect its progress in the overall
production. You can indicate a job as being in production or not. If a job is in production, other modules can still
access this job. If a job is no longer in production, it means the job is completed. The Harmony database still has all
the job's components (scenes, elements, drawings), but the job neither appears nor is accessible from the Harmony
applications.
In most cases, a job is no longer in production after it has been finalized (inked, painted, rendered) and transferred to
a medium, such as Blu-ray, or sent to post-production. However, if you need to continue working on a job, you can
revert its status at any time.
How to change the status of a job
1. From the Environment list, select an environment.
2. Select Job > Change Status.
The Change Status window opens.

3. Deselect any completed jobs and close the window.
The deselected jobs no longer appear in the Jobs list.
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Changing Job Priorities in Web Control Center
Before sending a job's scenes to be vectorized or rendered, you can set their priority level for the processing
queue. Increasing the priority of a job makes the system process it before other jobs in the queue. For example, if
job B is before job A in the queue, you can change the priority, so job A is processed first.
Changing a job's priority does not affect the vectorizing or rendering of jobs already sent to the queue. It will only
affect jobs that are sent after the priorities were changed.
How to change a job's priority
1. From the Environment list, select the environment with the job whose priority you want to change.
2. From the Job list, select a job.
3. Select Job > Change Priority.
The Change Priority window opens.

4. Adjust the slider to increase or decrease the priority (0 means the job has the highest priority for processing
through the Vectorize or Render queue. A job with a priority of 10 is the least important). Jobs with higher
priorities will pass in front of other projects with lower priorities in the queues.
5. Click OK.
When you send this job to be vectorized or rendered, it will have this new priority in the processing queue.
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Deleting Jobs in Web Control Center
When you no longer need a job, you can delete it. Doing so will permanently remove the following:
l

Scenes

l

Elements

l

Drawings

l

Database information associated with the selected job

l

Palettes stored under the selected job

Before you delete a job:
l

l

Make sure no one else is currently using the job. Failure to do this may result in file corruption and loss of your
work.
Wait until everyone is offline. This ensures no one can open the data files while you delete them.

NOTE: You cannot delete a job if it still contains scenes.

How to delete a job
1. From the Environment list, select the environment with the job you want to delete.
2. From the Job list, select a job to delete.
3. Select Job > Delete.
4. Click OK.
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About Scenes in Web Control Center
After you create a scene, you can view some of the scene information in the Scenes list, such as the version,
number of frames and status.

NOTE: It is useful to have at least one Display node in your scene as it dictates what is displayed in the
movie and thumbnail of the selected scene.

NOTE: Add more categories to the Scenes list by clicking the plus (+) icon at the top-right corner and selecting items to view—see Scenes List on page 137.

NOTE: When selecting scenes from the Scenes list, there is a delay for the first preview/thumbnail update
because it is done in batch render.
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Creating Scenes in Web Control Center
When creating scenes, you must indicate where you want to store the scene data and where you want the new
scene to appear in the Scenes list. You can create a single scene or multiple scenes at the same time.
How to create a scene in Web Control Center
1. From the Environment list, select the environment with the job in which you want to add scenes.
2. From the Job list, select the job in which you want to add scenes.
3. Select Scene > Create.
The Create Scene window opens.

4. In the first field, enter the name of the scene to create.
5. To create additional scenes, do one of the following:
l

Click the plus (+) sign and enter a name.

l

Press Enter/Return.

Repeat until you have the required number of scenes.

NOTE: By default, when creating a new scene or renaming a scene, the scene's name cannot exceed 23 characters. If Unicode is enabled, the scene's name can not exceed 119 characters. Job and scene names are
alphanumeric and can include underscores (_), but no spaces, or other special characters. All names are casesensitive.

6. From the File System list, select the path where you want to store the files.
If you are unsure which hard drive to select, consult your technical director or system administrator.

NOTE: Although you can add as many scenes as you want, you can only select one path at a time. Therefore,
the Web Control Center stores all scenes you create in one session at the same place (same path).
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7. Select where you want to place the scene(s) in the Scenes list from the Add Scene(s) list:
l

At Bottom: Places the new scenes at the bottom of the list.

l

At Top: Places the new scenes at the top of the list.

8. Click Create.
The new scene(s) are created and displayed in the Scene list. If you do not want to create the scene(s),
click the close button (x) at the top-right corner of the Create Scene window.
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Deleting Scenes to Web Control Center
When deleting a scene, you remove the scene from the Web Control Center window, as well as permanently
removing all the information associated with the scene including:
l

Exposure sheet (and all associated versions)

l

Elements

l

Drawings

l

Database information

l

Any palettes stored in that scene's palette library

Before you delete a scene:
l

Be sure you really want to remove all this information from the system.

l

Are you going to use the scene in the future?

l

Do you need to archive the scene for future use?

l

l

Make sure no one else is currently using the scene. Failure to do this may result in file corruption and loss of
work.
Wait until everyone is offline. This ensures no one will open the scene as you are trying to delete it.

How to delete a scene
1. From the Scenes list, select a scene name to delete.
2. Do one of the following:
l

Select Scene > Delete.

l

Right-click and select Delete.

The Confirm dialog box appears.
3. Click OK.
The scene name all its associated files are deleted.
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Checking Scenes In and Out in Web Control Center
It is important to check out a scene before working on it. If you have downloaded a scene to work on and forgot to
perform a checkout, other users can access and modify the scene on the server which would cause conflicts with
your work when you upload the scene later. In the Web Control Center, you can check out the scene even if you
have started to modify it. Once you check out a scene, others can only access a read-only copy.
When you are finished working on a scene, you must upload it to the database and check the scene back in.

NOTE: Remember that even if you forget to check out a scene, you can still perform partial updates to the
scene in the database when you use the Update Database Scene command (File menu). This could cause
conflicts with other users. For more information on partially updating scenes, see Partial Scene Updating in
Web Control Center on page 132.

How to check out or check in a scene
1. From the Scenes list, select the scene to check out.
2. Do one of the following:
l

Select Scene > Checkout or Checkin.

l

Right-click and select Checkout or Checkin.

The Checkout or Checkin Scene confirmation window opens.
3. Click OK.
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Renaming Scenes in Web Control Center
As you work on scenes, their nature and content may change and the name of the scene may no longer be relevant.
When this happens, you can rename the scene.
Before renaming a scene:
l

l

Make sure no one else is currently using the scene. Failure to do this may result in file corruption and loss of
your work.
Wait until everyone is offline. This ensures no one can open the scene while you rename it.

How to rename a scene
1. From the Scenes list, select a scene to rename.
2. Do one of the following:
l

Select Scene > Rename.

l

Right-click and select Rename.

The Rename Scene window opens.

3. Enter the new scene name and click Rename.

NOTE:
l

Use lower case letters if the scenes may be used with a Windows workstation.

l

When creating a new scene or renaming a scene, the scene name cannot exceed 23 characters.
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Reordering Scenes in Web Control Center
You can change the sequence of scenes in your job, which affects the order in which the scenes appear in the job
throughout the system. You can place a scene anywhere in the Scenes list or sort them alphanumerically.
How to reorder a scene
1. Select a scene from the Scenes list.
2. Select Scene > Reorder.
The Reorder Scenes window opens.

3. Drag a scene up or down to reorder it.
4. Click OK.
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Clearing Scenes in Web Control Center
If you must clear a scene from Web Control Center, wait until everyone is offline to ensure no one can open the data
files while you clear them. Otherwise, there is a risk of corrupting the files and losing work.
How to clear a scene
1. From the Scenes list, select a scene to clear.
2. Do one of the following:
l

Select Scene > Clear.

l

Right-click and select Clear.

The Confirm dialog box appears.
3. Click OK.
The Scene list refreshes and displays blank elements and drawings lists, showing that the Web Control
Center module has deleted the exposure sheet for the scene you cleared.
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Changing the Status of Scenes in Web Control Center
Changing a scene's status and making manual approvals is a way to track its progress in your production. For
example, in a scene whose drawings are being scanned, you can set the scene status to Scan. After you begin
adding colour to these line drawings, you can change the scene status to Paint.
To change a scene's status, the approval policy must be set to Manual. You can also create customized approval
stages that reflect the approval process in your production environment—see About Jobs in Web Control Center
on page 102.
Users who have limited rights in Web Control Center can still change the status of a scene, as long as it is a
scene that is assigned to them.
How to change a scene's status
1. Select a scene from the Scenes list.
2. Do one of the following:
l

Select Scene > Change Status.

l

Right-click and select Change Status.

The Change Status window opens.

3. Select a status for the scene.
4. Click Apply.
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Customizing the Scene Status Colour in Web Control Center
Changing a scene's status is easy when you can use colours to help differentiate them. With a glance at the Scenes
list, you can quickly assess the status of a production.
You can add new scene statuses and customize their name and colour, as well as manually edit the list.
How to customize the scene status colour
1. Select Admin > Change Statuses.
The Change Custom Statuses window opens.

2. In the Status field, type in the name of the new status to create.
3. Click the arrow and select a colour for the new status.

4. Click Add Config.
The new status and its colour are displayed. The list of statuses updates with the new status and its colour
defnition.

NOTE: You can manually edit the name and colour definition of scene statuses. If you do, make sure there is no
comma at the end of the last line.
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5. Click Save.
The new status is added to the list of statuses and the Change Custom Statuses window closes.
The next time you change the status of a scene, the new status will be available from the list.

6. Select a status for the scene.
7. Click Apply.
How to edit the Scene Status list
1. Select Admin > Change Statuses.

2. In the Change Custom Statuses window, manually edit the name and colour of a scene status. You can
also add or delete a status.

118

Harmony 14 Server Installation Guide

NOTE: At the end of the last line, make sure there is no comma.

3. Click Save.
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Assigning Users Scenes in Web Control Center
Assigning a user to a scene makes it easy to manage your production and track its progress.
How to assign a user to a scene
1. Select a scene from the Scenes list.
2. Do one of the following:
l

Select Scene > Assign User.

l

Right-click and select Assign to User.

The Assign User window opens.

3. Select a user to assign to the scene.
4. Click Assign.
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Setting Scene Priority in Web Control Center
You can change a scene's rendering and vectorization queue priority to place it ahead of or behind other scenes. For
example, if scene B comes before scene A in the queue, change the scene's priority so scene A is processed first.
If a scene was already sent to the queue, changing the priority will not affect its priority in the queue. Changes will
only be applied the next time it is sent to the queue.

NOTE: If you want to change a scene's priority after it has been sent to the queue, you can do so using the
Change Priority button in the Queue window in the Control Center module—see Viewing the Render Queue in
the Harmony Server Installation Guide.

How to change the scene priority
1. Select a scene from the Scenes list.
2. Do one of the following:
l

Select Scene > Change Priority.

l

Right-click and select Change Priority.

The Change Priority window opens.

3. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or Render
queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of other projects
with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
4. Close the window.
The new scene priority appears in the Priority column of the Scenes list.
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Searching Scenes in Web Control Center
When managing your production, you will want to search and filter scenes to accurately track progress. In the
Web Control Center, you can search scenes by user or state, or both at the same time.
How to search scenes by user or state
1. Click Advanced search.

Two search fields appear.

2. Do one or both of the following:
l

To search for a user, select one from the Select a User list.

The Scenes list updates to display only the scenes assigned to the user you selected.

l

To search for a state, select one from the Select a State list.
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The Scenes list updates to display only the scenes assigned to the state you selected. In this example, we
searched for a user named BATCH and a state called "done". The result is one scene displayed below.

How to reset the Advanced Search fields
1. Do one of the following:
l

l

Click Advanced search to close the search fields. Click Advanced search again to reopen
the fields.
Place your cursor in a search field and press Backspace repeatedly until the field is blank.
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Vectorizing Scenes in Web Control Center
When your scene is completed, you can revectorize scanned drawings with a different vectorization style,
including TVG, greyscale, greyscale rougher lines or soft edge, and tones/highlights. You can also choose to
convert vector drawings into bitmap drawings.
If you didn't scan drawings and just did them paperless or imported them, you cannot revectorize them because
the original bitmaps are required in the scene.
How to vectorize scenes
1. Select a scene from the Scenes list.
2. Do one of the following:
l

Select Scene > Vectorize.

l

Right-click and select Send to Vectorize.

The Send to Vectorize window opens.

3. Select a vectorization style for the scene.
4. Click Send to Vectorize.
How to unvectorize scenes
1. Select a scene from the Scenes list.
2. Do one of the following:
l

Select Scene > Unvectorize.

l

Right-click and select Send to Unvectorize.

The Send to Unvectorize window opens.
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3. From the Antialiasing Quality list, select a quality level.
4. In the Antialiasing Exponent field, set the .
5. In the Resolution section, select one of the following:
l

As Scanned to use the resolution at which the drawing was scanned.

l

Use Custom Resolution, then enter the desired X and Y resolution.

6. From the Output File Format list, select a format for the unvectorized scene.
7. In the Command Line field, you can enter a command from the utransform utility. For example, you can set
the background colour: -bgcolor 1.0 1.0 1.1.
8. Click Send to Unvectorize.
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Rendering Scenes in Web Control Center
When one or more scenes are complete, you can send them to the batch processing machine for rendering. You
can also use Harmony Advanced or Harmony Premium to render scenes, but since you must open each scene
individually in Harmony, you can only send one scene to render at a time.
How to send a group of scenes to the Render queue
1. Select the environment, job and scenes to send to the Render queue.
2. Do one of the following:
l

Select Scene > Send to Rendering.

l

Right-click and select Send to Rendering.

The Send to Rendering window opens.

3. In the Range section, select the frames to render:
l

l

All Frames: Sends all the frames in the scene to be rendered.
Selected Frames: Sends a range of frames to be rendered. You can only do this if you
selected one scene. Enter the frame range.

4. Select the Chunk Size (Frames) option if you want to split the frames into chunks. This lets you process
frames among many stations instead of just one. Enter the number of frames in each chunk.
5. From the Version list, select the version of the scene to render.
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6. From the Camera list, select the camera to render the scene's images. These are the cameras you created in
Harmony.
7. If you want to create a sequence of images in fields, such as in NTSC or PAL, select Enable Field Composite option and any of the following:
l

Add Pulldown: Uses the 3:2 pulldown technique.

l

Automatic Combine: Combines even and odd fields on a scene's image.

l

Second Field First: Always starts with the second field before combining with the first field.

8. Click Send to Rendering.
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Downloading and Uploading Scenes in Web Control Center
Web Control Center allows you to download (export offline) scenes from a studio's Harmony database and work
on them locally from a remote location. When downloading the scene, you have the option to check it out so it's
locked; this prevents other users from modifying your scene while you are working on it. When you are finished
working on your scene, you can upload (import) it, merging it back into the Harmony database.
When downloading a scene, the data is first placed in the user's exchange folder where it can then be downloaded
on the user's remote computer. The exchange folder is located in the USA_DB directory of the Harmony
database. This folder contains individual folders for each user; this is where uploaded and downloaded scenes are
stored.
You can download scenes individually or in bulk.

NOTE: When working on local scenes, do not change the folder names or structures as it will cause problems when reimporting scenes.

When you no longer need the stored packages in the exchange folder, delete them to keep your storage space
organized.
You can view all operations and error messages related to these processes in the Log view.
If you want to upload environments, jobs and scenes for archiving, you must use the Control Center. Web Control
Center only allows you to upload and download scenes for exchange between studios and freelancers.

NOTE: Scenes cannot be uploaded or downloaded using a tablet.

How to download an individual scene
1. From the Scenes list, select a scene to export.
2. In right pane, click Export Offline.
The Export Offline window opens.

3. Select the Checkout option to lock the scene, preventing anyone from modifying the scene.
4. Click More Options.
Additional options for exporting offline are displayed, including the palettes and libraries for the
environment and job. You can also export external drawings.

128

Harmony 14 Server Installation Guide

5. Select the appropriate options and click Export.
The selected scene is zipped and exported to your user exchange folder. Wait for the Export process to
complete.
6. Close the Successful Export dialog box.
7. Select File > Manage Uploaded/Exported Files.
The Exchange Manager window opens.

8. To delete exported files after you download them, select the Delete from Exchange After Download option
in the bottom-right corner.
9. In the Package list, click a web link to download.
How to download multiple scenes
1. From the Scenes list, select the scenes to export.
2. Select Admin > Export.
The Export screen opens. The selected scenes are listed in the List of Scenes to Export section.
l

l

To add more scenes, select the environment, job and scenes to add and click Add Selected
Scenes.
To remove unwanted scenes, select the scene and click Remove Selected Scene.

3. To export:
l

Click Export Offline to export your selection to your user exchange folder using the preset
options. Select the Checkout option to lock the scene, preventing anyone from modifying the
scene. Click Export.
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To export your selection with custom options, click Export to Another Database. The
Export with Options window opens—see Import or Export to Another Database Options on
page 138. Select the appropriate options and click Export.

4. Close the Successful Export dialog box.
5. In the top-left corner, click Return to Scene List to return to the main page.
6. Select File > Manage Uploaded/Exported Files.
7. To delete exported files after you download them, select the Delete from Exchange After Download
option in the bottom-right corner.
8. In the Package list, select the Zip file to download.
How to upload scenes back to the database
1. Zip (compress) your package. It should have the exact same structure and internal naming as the package
you downloaded.
2. In Web Control Center, select Admin > Import.
The Import page opens.
3. Click Add Another File to your Exchange to upload your zip file.

NOTE: You can also import your zipped packaged through the Exchange Manager by selecting File > Manage Uploaded/Exported Files. In the Exchange Manager, click Select Zip File to Upload. Once the package is imported, go to the Import page to push it back to the Harmony database. Select Admin > Import.
Click Import to import your package.
You can export offline many scenes in one package but when you reimport them, each scene must be in its
own individual zip package. However, if you export/import to database, you can do multiple scenes at the
import.

Once the package is imported, the package details disappear.
4. Select the Checkin option to check your scene back into the Harmony database and allow other users to
modify it.
5. To import:
l

l

Click Quick Import to import your scenes using the preset options.
Click Import with Options to import your scenes with custom options—see Import or Export
to Another Database Options on page 138.
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NOTE: If you are trying to import a scene that was checked out by another user, you will not be able to complete the operation. A warning message will be prompted.

How to refresh the list of files in the Exchange Manager
1. In the Exchange Manager, click the Refresh List button.

How to open the Log view
1. Select Help > View Log.
The Log view opens. Green messages indicate successful operations, orange indicates warnings, and
red messages are errors or failed operations.

2. To clear all messages from the Log view, click Clear Log.
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Partial Scene Updating in Web Control Center
Web Control Center allows you to update a database scene with only the changes you made to the same scene
on your local computer, and vice versa. If there were changes to the database scene, you can download them to
its offline version on your local computer. Web Control Center works in tandem with Harmony to make the
upload, download and updating of scenes seamless and quick.
When uploading or downloading a scene, Harmony prepares the export package with only the changes in the
scene, zips it, sends it over the Internet, unzips it and finally imports it, updating the destination scene. This is
done directly in Harmony Premium or Harmony Advanced; there is no need to do this in the Web Control Center.
How to perform a partial scene update
1. Open a web browser and connect to the Web Control Center—see Connecting to Web Control Center on
page 81.
2. From the Scenes list, select the scene on which you want to work offline.
3. In the Export Offline pane on the right, click Export Offline.

The Export Offline window opens.

4. Select the Checkout option to check out the scene.
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NOTE: As a general rule, you should check out the scene from Web Control Center before working on it. Otherwise, there may be conflict issues if another user checks out the scene while you are working on it.

5. Click Export.
The Export Completed confirmation window opens.

6. Close the confirmation window.
7. Select File > Manage Uploaded/Exported Files.
The Exchange Manager opens and displays the files in your user exchange.

8. Select the Download option in the upper-right corner.
9. (Optional) Select the Delete from Exchange After Download option to remove the package from your user
exchange after you have downloaded the scene on your computer.
10. Click the file you exported offline.

The scene downloads to your computer.
11. Close the Exchange Manager.
12. In Harmony, open the Preferences dialog box by pressing Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
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13. Select the General tab.
14. In the Web Control Center section, enter the host name and host port. If you are unsure, consult the studio's system administrator for this information.
l

l

Host name: Name of the Web Control Center server name.
Host port: 8080 (the default port number) or custom port number set by the system administrator.

15. Locate and open the downloaded scene and make whatever changes are needed.
16. To perform a partial scene update, select File > Update Database Scene.
The User Credentials dialog box opens.

17. Enter your username and password for Web Control Center and click OK.
Harmony prepares the export package with only the changes in the scene, zips it, sends it over the
Internet, unzips it and imports it back into the database. You can perform as many partial scene updates
as you like.
18. When you are finished working on the scene, check it back in Web Control Center by doing one of the following:
l

In the Scenes list, right-click on the scene and select Checkin.

l

Select Scene > Checkin.

How to update the offline scene with the latest database scene changes
1. In Harmony, open the scene to update.
2. From the top menu, select File > Download Database Changes.
Harmony prepares the export package with only the changes in the database scene, zips it, sends it over
the Internet, unzips it and imports it to the offline scene on your computer. You can perform as many partial
database scene downloads as needed.
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Web Control Center Commands
File Menu
Command

Description

Manage Uploaded/Exported Files

Opens the Exchange Manager, where you can upload zip files from your
computer or download zip files exported from Web Control Center.
NOTE: This command is not available on tablets.

Environment Menu
Command

Description

Create

Lets you create an environment and set the rights for modifying scene
assets.

Delete

Lets you delete an environment from the database. This command is only
available if the environment does not contain any jobs or scenes. If it
does, they must be deleted before the environment can be deleted.

Change Asset Lock

Lets you set the rights for modifying the scene assets of a selected
environment.

Job Menu
Command

Description
Lets you a new job to the selected environment.

Create

Your job must have a unique name in the animation database. You
cannot have two jobs with the same name, even if they exist in different
environments, as they are all stored in the same folder on the database.
Removes a job from the selected environment.

Delete

When a job is deleted, its scenes, elements, drawings, palette library,
and database information are permanently deleted. If you want to archive
a job, you should delete the job only after you have exported it and saved
it in a secure location.
Before deleting a job, verify that it is not currently in use.

Change Approval Policy

Let you select or deselect scenes for manual approval from the TD or
ATD.

Change Status

Lets you indicate whether jobs are in production or completed. You can
always put a completed job back in production.

Change Priority

Lets you set the priority of the selected job for the rendering and
vectorization queues. 0 = highest priority, 10 - lowest priority.

Scene Menu
Command

Description
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Reset List Sorting

Resets the order of the scenes in the Scenes list. Click on the Current
Version heading to order to the scenes numerically by version number.
Click again to reverse the order.

Open

Launches Harmony and opens the scene in it. If it was not previously
specified, you will be asked to specify the path to the software's
executable file.
Opens the Create Scene window where you can add one or more scenes
to the selected job. You can also choose to:

Create

•

Select the file system where the created scenes will be stored.

•

Choose the position the scene will take within the job.

Removes a scene from the database. Before you use this command,
make sure the selected scenes is not currently in use.
Delete

Rename

When a scene is deleted, its exposure sheet, elements, drawings, palette
library and database information are permanently removed. If you want to
archive a scene, you should delete the scene only after you have
exported it and saved it in a secure location.
Opens the Rename Scene window where you can enter a new name for
the selected scene. Before doing this, verify that the scene is not in use.
Unlocks a scene or version of a scene locked in Harmony.

Force Unlock

Force Unlock Version

Usually, a scene unlocks when it is closed by a user. However, if a
computer crashes while a scene is locked (in use), a scene may remain
locked even if it is not open.
If you used this command on more than one scene, you are prompted for
confirmation to unlock each scene separately.

Checks in a scene that was checked out, but not checked back in.
Force Checkin

Use this command only in extreme cases. Otherwise, two versions of the
same scene will be in use, which will cause conflicts.

Checkin

Checks in a scene that you checked out.

Checkout

Checks out a scene. If a scene is already checked out, it is available as
read-only and you cannot make any changes to it.
Lets you set the priority of the selected scene for the rendering and
vectorization queues. 0 = highest priority, 10 = lowest priority.

Change Priority

To change the priority of a scene already sent to the batch processing
queue, use the Change Priority button in the queue through the Control
Center module.

Assign User

Lets you assign a user to a scene.

Change Status

Lets you change the status of a scene to indicate where it is in the
animation production process.

Reorder

Lets you change the order of scenes in a job.

Clear

Lets you delete a scene's exposure sheet, network, elements and
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database information. Image files will need to be deleted manually.
Before using this command, make sure that none of the files in question
are currently in use.
Send to Vectorize

Lets you revectorize scanned drawings in the selected scene to the
vector style you set.

Send to Unvectorize

Lets you convert a scene's vector drawings into bitmap drawings.

Send to Rendering

Lets you add one or more scenes to the rendering queue.

Admin Menu
Command

Description

Change Password

Lets you change your password or set an empty password (no password
needed for login).

Change Statuses

Lets you edit, reorder, or remove statuses, as well as add colours to
statuses.

Manage Users

Displays a list of all system users. You can add, delete or modify user
information in this list.

Export

Lets you select scenes to export from the selected environment and job.

Import

Lets you upload single or multiple project zip files to your exchange folder
and then import them.

Help Menu
Command

Description

Help on WCC

Opens the Web Control Center integrated help system.

Developer Help

Lets you access documentation on other APIs.

About

Opens the About Web Control Center page which displays copyright
information.

View Log

Opens the WebCC log window which details the activity in the Web Control Center.

Scenes List
Parameter

Description

Current Version

Displays the version number of the scene. For example, there can be
many versions of the same scene saved in the root project folder.

Frames

Displays the number of frames in the scene. This indicates the length
of the scene. If artwork has not been created in the scene yet, the number of frames in the Frames column displays 0.

Checkout User

Indicates the name of the individual who checked out the scene by
their login username.

Status

Indicates the status of the scene in the animation production process.
The default status is left blank to indicate that the scene has not been
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assigned a status. The assignable statuses are: Scan, Vectorize, Pencil Test, Paint, Sceneplanning, Camera and Completed.
TD

Displays the name of the technical director of the scene by their login
username.

ATD

Displays the name of the assistant technical director of the scene by
their login username.

Priority

Displays the priority of the scene on a scale of 0–10 (0 = highest priority, 10 = lowest priority).

Assigned

Displays the to which a scene is assigned.

Import or Export to Another Database Options
Exporting to another database makes a package with many scenes that must be imported into another database.
You cannot open them offline as individual scenes. This is useful when exchanging large quantities of scenes
from one studio to another. However, a freelancer working on a limited number of scenes may not want to create
a personal database at home.

Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements
in the scene.

Database

If you select this option and deselect
the Elements option, you can access the elements
from the Element Manager in the Control Center, but
their drawing and bitmap files will not be included. The
list of available versions in the scene is also exported.
It is not possible to open a scene if this is not selected
for export.

Final Frames

Exports the directory that contains the final, rendered
frames.

Other Directories

Exports all other directories and files in the scene's
data structure.

Elements

Selected by default, this option exports the contents
(drawing and bitmap files) of the Element directories.

Timing Drawings

Selected by default, this option exports the contents
of the Timing directories.

Annotation

Lets you export the different drawings created while
drawing in the Annotation columns and imported
images.

Stage (xsheet & network)

Selected by default, this option exports the Harmony
directory, which contains the Harmony files for each
scene you export. These files are necessary if you
want to reuse the exposure sheet (timing) and the
node structure from the original scene.
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If this option is selected, you can select the Get
Outside Drawings option to copy drawings into the
scene folder that is referred to by the Timing columns
and their Element (Drawing) nodes.

Palettes

Exports the palette-library directories. Decide if you
want to export the palette-library from the
environment, job or scene level. When you select a
level, the palette-library in lower-level directories will
also be exported.
Check Backup if you want to export the palette-list file
which is necessary for the scene to know which
palettes to use. In most cases, you should select this
option as well as the Scene option.

Macros

Exports the macros (customized effect and node
connections) that were created and stored in the
environment, jobs or scenes to be exported. This is
necessary if you have legacy scenes with macros.

Libraries

Exports templates created at the selected levels.
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Chapter 4: Service Launcher
The Service Launcher allows users without full administrative rights to launch three Toon Boom Harmony services:
ToonBoom Process (for batch rendering and vectorization), Database Server and WebCC.
The Service Launcher also relaunches these services periodically if any should happen to stop.
Service Launcher Top Menu

142

Service Launcher Preferences Tab

143

Service Launcher ToonBoom Process Tab

144

Service Launcher Database Server Tab

146

Service Launcher WebCC Tab

148
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Service Launcher Top Menu

Service Launcher Top Menu
Access these menus and their commands from the top menu bar of the Service Launcher window.
Menu

Server

Command

Description

Save All Settings

Select this command to register any changes
made to the options in the Service Launcher.

Stop All Processes

Select this command to stop all service processes.

Quit

Select this command to quit the Service
Launcher application.

Help

Select this command to launch Toon Boom's
website, where you can find various
resources for support.

About

Select this command to open the About Toon
Boom Service Launcher window. This window contains version and copyright information.

Help

142

Harmony 14 Server Installation Guide

Service Launcher Preferences Tab
Use the options available in the Preferences tab to customize the behaviour of the Service Launcher.

Parameter

Description

Services location

Displays the location path of the Service Launcher application on your computer.
You can click on the ellipses button, at the end of the field, to browse for a new
location.

Application parameters
Launch on login

Check this option if you would like to launch the Service Launcher application
every time you login to your computer. This enables the Display Window option.

Display window

Check this option if you would like to the Service Launcher window to open when
the Service Launcher is launched on login. Otherwise, the Service Launcher
application will run in the background and be accessible to open through your computer's task bar.

Notify me on errors

Check this option if you would like to be notified of errors.

Show last lines of log files

Allows you to enter the maximum number of lines from the bottom of the log file
that you would like displayed for the ToonBoom Process, Database Server and
WebCC services.

On error

Allows you to enter the number of seconds that the Service Launcher should wait
before trying to relaunch any of services, should they happen to stop.
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Service Launcher ToonBoom Process Tab
The ToonBoom Process service is responsible for batch rendering and vectorization processes. Use the options
available in ToonBoom Process tab to customize the service's behaviour.

Parameter

Description

Launch button

Click on this button to start the service. The status will change from Closed to
Running.

Stop button

This button is enabled when the service is running. Click on this button to stop
the service.

Launch when Service
Launcher starts

Check this option to automatically launch the ToonBoom Proces service when
the Service Launcher is launched. This bypasses the need to click on the
Launch button.

Parameters
Debug

Check this option if you would like to debug any problems that may occur while
the ToonBoom Process service is running. Debugging may add time to the rendering and vectorization processes.

Schedule

This option is checked by default. It is strongly recommended that you leave
this option enabled. It runs the ToonBoom Process service using the scheduler.

144

Harmony 14 Server Installation Guide

Other Parameters

Help tab

Copy and paste parameter codes from the Help tab to the Other Parameters
field. Click on the Update Parameters button to initiate the usage of these
parameters when the service is launched.
This tab lists all the available options for the ToonBoom Process (tbprocess).
Parameter codes are listed along with a description of their function. You can
copy and paste a parameter code into the Other Parameters field and then click
Update Parameters to initiate the usage of these parameters when the service is launched.
This tab lists a record of all the activity created by the service. It only lists up to
the maximum number of lines specified in the Preferences tab.

Log tab

l

l

Clear Window button: clears the existing log data from the window.
View Complete Log button: launches the Dialog window which displays a complete version of the logo information.
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Service Launcher Database Server Tab
The Database Server centralizes all production assets in a repository and manages administrative tasks.

Parameter

Description

Launch button

Click on this button to start the service. The status will change from Closed to
Running.

Stop button

This button is enabled when the service is running. Click on this button to stop
the service.

Launch when Service
Launcher starts

Check this option to automatically launch the Database Server service when
the Service Launcher is launched. This bypasses the need to click on the
Launch button.

Parameters
Debug

Check this option if you would like to debug any problems that may occur while
the service is running. Debugging may add time to the current Database Server
processes.

Keep Alive

Check this option if you would like the Database Server to automatically
restart in the event that it crashes or fails. You can select the wait period before
relaunch in the Preferences tab.

Other Parameters

Copy and paste parameter codes from the Help tab to the Other Parameters
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field. Click on the Update Parameters button to initiate the usage of these
parameters when the service is launched.

Help tab

This tab lists all the available options for the Database Server (dbserver). Parameter codes are listed along with a description of their function. You can copy
and paste a parameter code into the Other Parameters field and then click
Update Parameters to initiate the usage of these parameters when the service is launched.
This tab lists a record of all the activity created by the service. It only lists up to
the maximum number of lines specified in the Preferences tab.

Log tab

l

l

Clear Window button: clears the existing log data from the window.
View Complete Log button: launches the Dialog window which displays a complete version of the logo information.
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Service Launcher WebCC Tab
Web Control Center is a web version of the Control Center for freelancers to connect to a studio's Harmony
database and download scenes to work on them remotely. Scenes can be uploaded when ready and merged back
on the server.

Parameter

Description

Launch button

Click on this button to start the service. The status will change from Closed to
Running.

Stop button

This button is enabled when the service is running. Click on this button to stop
the service.

Launch when Service
Launcher starts

Check this option to automatically launch the WebCC service when the Service Launcher is launched. This bypasses the need to click on the Launch button.

Parameters
Authentication

Check this option to display the Login screen when users connect to Web Control Center. Users must have a valid username and password.

Port

8080 is the default port number for connection. If it was modified, you can enter
your custom port number in its place.

Other Parameters

Copy and paste parameter codes from the Help tab to the Other Parameters
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field. Click on the Update Parameters button to initiate the usage of these
parameters when the service is launched.

Help tab

This tab lists all the available options for the Web Control Center. Parameter
codes are listed along with a description of their function. You can copy and
paste a parameter code into the Other Parameters field and then click Update
Parameters to initiate the usage of these parameters when the service is
launched.
This tab lists a record of all the activity created by the service. It only lists up to
the maximum number of lines specified in the Preferences tab.

Log tab

l

l

Clear Window button: clears the existing log data from the window.
View Complete Log button: launches the Dialog window which displays a complete version of the logo information.
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