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Chapter 1: User Guide
The Harmony core functionality are explained in this User guide. All the steps required to create and complete a 
project are covered in the following chapters with concept descriptions and detailed step-by-step procedures 
focused on the task at hand.  

Detailed parameter descriptions for all buttons, commands, and functions are covered in the Reference guide and 
Preference guide. Some of them are explained here where necessary to the understanding of a given concept or 
procedure.  
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Chapter 2: Project Creation
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will learn about 
starting the application, creating scenes, setting the resolution and opening the scenes. 
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Starting Harmony
T-HFND-001-002

You can run Harmony on Linux, Mac OS X or Windows operating systems.

NOTE: On Mac OS X 10.10.5 and more recent versions, Harmony and its modules will not start the first time 
if your security is set to Mac App Store and Identified Developers. Change your security to Anywhere or 
right-click on Harmony or its modules to open it for the first time only.

How to start Harmony 

 1. Do one of the following:
 l Windows: Start > Programs > Harmony 14.0 Essentials > Harmony EssentialsHarmony Essen-

tials

 l Mac OS X: Applications > Toon Boom Harmony 14.0 Essentials > Harmony EssentialsHarmony 
Essentials

Toon Boom Harmony opens. If you have the complete version installed, the login dialog box opens.
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About the Welcome Screen
T-HFND-001-003

When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display the 
Welcome screen by selecting Help > Show Welcome Screen.

The Welcome screen allows you to:

 1. Create scenes

 2. Choose your scene resolution

 3. Quickly open recently edited scenes

 4. Manage your scene resolution presets

 5. Watch Harmony video tutorials

 6. Open the online support page

 7. Browse for and open a scene from your documents
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About Documentation
The documentation is a way to help you find answers to your questions about how things work in Harmony. The 
documentation of features and procedures exists online, but you can access it through the software.

A simple, but fast way to find a description of certain menu items and preferences is through the Integrated Help.
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Accessing the Documentation
T-HFND-001-004

The Harmony documentation can be accessed from the Welcome Screen and the Help menu.

How to access the Harmony documentation

 1. In the Support section, click on the Get Help  button.

Your default web browser opens to the Toon Boom Support page.

 2. From the Support page, under the Learn Toon Boom Software section, click on the Documentation button.

The Toon Boom Help page opens.

 3. From the Toon Boom Help page, click on the Harmony icon.

The Harmony Help page opens.

All the Harmony guides can also be opened directly in the software. Select Help > Online Help.
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Using the Integrated Help
If you are unsure about what a certain menu item is in the Top menu or the function of a specific preference in the 
Preferences panel, use the Integrated Help.

If you keep the Integrated Help window open for the entire duration of your work session, then you can use the 
forward and backward arrows to scroll through a history of the help information that you called up during your 
session.

How to use the Integrated Help with Menu Items

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, click on a menu heading to display its contents.

 3. Use your mouse to hover over a menu item.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the menu item appears.
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How to use the Integrated Help with Preferences

 1. In the top menu, go to Help > Show What's This or press F1 on Windows/Linux or ⌘  + / on Mac OS X.

The Integrated Help window appears.

 2. In the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS X).

The Preferences window appears.

 3. In the Preferences window, use your mouse to hover over a preference.

 4. Press  F1 on Windows/Linux or ⌘  + / on Mac OS X.

In the Integrated Help window, a description of the preference appears.
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How to scroll through the bank of searched items

 l In the Integrated Help window, click on the forward or backward arrow buttons.

NOTE: The moment you close the Integrated Help window all searched items will be erased from the 
memory bank. In order to keep an on-going record of all the search requests made, you must keep the win-
dow open.
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About Scenes
When working in production, it is important to keep your work organized. It is important to create a naming 
convention chart and establish a file storage structure before starting the project. It is not only extremely important 
that everyone follows the criteria laid out in the naming convention chart and the file storage structure, but also that 
they understand the organization and where to find the files.

A well thought-out and logical naming convention will help keep your production structured and allow it to run 
smoothly by preventing the loss of files due to chaotic organization.

In this section, you will learn how to create, open, organize,  and name the different components in your animation 
project.
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About the File Structure
T-HFND-001-008

A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the 
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the files 
contained in the folder structure.

/usa /usa/nt/bin/

 /usa/etc/

 /usa/etc/flexlm/

/usa_db

Scene File Structure

Here is an example of the file structure contained in a scene. As you work and use more features, different folders 
may appear in your structure.

The Harmony scene folder contains the following folders: frames, audio, elements, etc.

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation 
column in the Xsheet view.

audio Contains all imported audio files.

elements
Contains all the drawing files. The drawings are organized by folders named 
like the layers they are associated with.

environments
Contains the exported palette files that were originally stored at the 
environment level in the Harmony Server database structure or the palettes in 
a Harmony Stand Alone scene that will be imported later at the environment 
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level in Harmony Server.

frames
Contains the final frames after a render if you are using the default settings of 
the Write node in the Node view.

jobs

Contains the exported palette files that were originally stored at the 
environment level in the Harmony Server database structure or the palettes in 
a Harmony Stand Alone scene that will be imported later at the environment 
level in Harmony Server.

palette-library Contains scene palettes and scene palette list files.

timings
This folder is used when a user links external images to a scene and wants to 
store a backup copy in case the link breaks.
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Creating Scenes
T-HFND-001-005

All scenes created via  Harmony Stand Alone are independent and local to the computer. You can create or open a 
scene using the Welcome screen or the File menu.

How to create a scene from the Welcome screen

 1. In the  Name field, type the scene’s name.

NOTE: The scene name should not exceed 23 characters and cannot contain special char-
acters, such as *&^%!.

 2. To decide in which directory the scene will be created, click the Browse button next to the Location field.

 3. From the Camera Size menu, select a scene resolution.

 4. Click on Create Scene.

A new scene is created.

How to create a new scene from the File menu

 1. Do one of the following:
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 l From the top menu, select File > New. 

 l In the File toolbar, click the New  button. 

 l Press Ctrl + N (Windows/Linux) or ⌘  + N (Mac OS X).

The New Scene dialog box opens.

 2. In the Project Name field, type the scene's name.

 3. Select a scene directory by clicking the Browse button.

NOTE: The scene name cannot exceed 23 characters and cannot contain special characters, such as *&^%!.

 4. In the Resolution window, select the scene’s resolution and click Create.

A new scene is created.
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Creating Custom Resolutions
T-HFND-001-006

You can create your own custom resolution presets for your projects.

How to create a custom resolution

 1. Create a new scene from the Welcome screen or from the File menu in Harmony.

 2. Set the scene resolution by doing one of the following:

 l Select a scene resolution from the Camera sizes drop-down menu.

 l Set a custom resolution by changing the values in the Width and Height fields. This preset 
will not be saved.

 l Add a new resolution to the list by clicking the Add   button. You can delete a custom res-
olution from the Resolution list by selecting it, and clicking the Delete button.

 3. In the New Resolution dialog box, fill in the following fields and click Create.

 l Resolution Name: Name your new resolution.

 l Resolution: Set the width, height and aspect ratio of the resolution.

 l Field of View: Set the horizontal fit and vertical fit.

 l Frame Rate: Type the scene's frame rate per second.
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Opening Scenes
T-HFND-001-007

You can open scenes from the Welcome Screen and the File menu. You can also open your recent scenes.

How to open a scene from the Welcome screen

 1. In the Recent Scenes section, click Open.

The Open Scene browser opens.

 2. Browse and select an *.xstage file.

 3. Click Open.

How to open a scene from the File menu

 1. Do one of the following:

 l From the top menu, select File > Open. 

 l In the File toolbar, click the Browse  button. 

 l Press Ctrl + O (Windows/Linux) or ⌘  + O (Mac OS X).

The Open Scene browser opens.

 2. Browse and select the desired *.xstage file.

 3. Click Open.

How to open a recent scene from the Welcome screen

 1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu

 1. From the top menu, select File > Open Recent.

 2. Select a scene from the displayed list.
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Setting the Scene Length
T-HFND-001-009

Once you have opened your scene, you can set its length. 

NOTE: Refer to the Scripting guide to learn how to modify the New Scene Start up script to set a different 
default scene length.

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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About Scene Settings
T-HFND-001-010

When you created your new scene, you set up the resolution and the alignment. However, if you want to change 
these initial settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options 
are separated into four tabs.

NOTE: Refer to the Scene Setting dialog box  in the Reference guide to learn more about the individual para-
meters of the Scene Settings dialog box.

How to access the Scene Settings dialog box

 1. Select Scene > Scene Settings.

The Scene Settings dialog box opens.
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Advanced Saving in the Harmony Server
Use the Advanced Save dialog box to save specific drawings, palettes and palette lists as a version of your 
scene. 
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Opening Drawings in Paint
This option will let you load drawings from one element at a time, for quick ink and paint on a single layer animation.

How to open drawings in Paint

 1. Once Paint is launched and you are logged in, select File > Open Drawings. Press Ctrl + O (Win-
dows/Linux) or ⌘  + O (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job, Scene and Element where the drawings you need to paint are located.

 

 3. Choose the version you want to open from the Version drop-down menu.

 

 l The Saved By and Saved Date fields display the user who was the last to save the selected 
scene and the date of the last save. 
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 4. Click on the Open button.

The Drawings Selector dialog box opens.

 5. Select the desired drawings from the drawings list:

 l Click on a single drawing to select it.

 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) 
key.

 l Click on the All button to select all the drawings that are listed in the Drawings Selector.

 l Click on the Unpainted button to select all the drawings whose status appears as 
UNPAINTED.

 l Click on the Painted button to select all the drawings whose status appears as PAINTED.

 6. Click OK.

The selected drawings appear in the Drawing Thumbnails view

 7. Use the Control panel to navigate between the previous and next drawings. Press F and G.
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You are now ready to ink and paint!
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Opening Elements in Paint
This option will let you load drawings from several elements at once. This can be useful when an animation is 
separated in many layers, to insure that they are well aligned and that the painted shapes and lines fit together. A 
good example of this would be a dialogue with the chin and mouth separated from the rest of the head.

How to open elements in Paint

 1. Once Paint is launched and you are logged in, select File > Open Elements. Press Ctrl + E (Win-
dows/Linux) or ⌘  + E (Mac OS X).

The Database Selector opens, displaying the Environments available from the Harmony database.

 

 2. Select the Environment, Job and Scene where the elements containing the drawings you need to paint are 
located. 

 

 3. Choose the version you want to open from the Version drop-down menu.
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 l The Saved By and Saved Date fields display the user who was the last to save the selected 
scene and the date of the last save. 

 

 4. Click on the Open button.

The Open Elements dialog box opens.

 5. Select the elements you need to paint from the Elements list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 6. Select the frames you wish to load from the Frames list:
 l You can create a continuous multiple selection by holding the Shift key.

 l You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘  (Mac OS X) key.

 l Click on the All Frames button to load all the frames of the scene.

 7. Click OK.

The Drawing Thumbnails view is hidden and your selected elements are loaded in Paint.

 8. Enable the Light Table  option from the Drawing view toolbar to display all the drawing layers.

The selected layer are displayed in original colours and the other layers are displayed as washed out colours.
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 9. Use the Control Panel to navigate between previous and next layers. Press H and J.

 10. Use the Control panel to navigate between previous and next drawings. Press F and G.

You are now ready to ink and paint!
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About Saving
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title bar 
beside the scene name to indicate that the scene contains unsaved changes.

To save the current state of a scene as another scene, you can use the Save As command. The Save As window 
prompts you to give a new name and choose a different location to this scene before saving it. This will create a 
complete scene directory for the new scene. The Save As command is not available in Harmony Server.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or parameters to 
see which one will work best. Harmony allows you to save a new version of your scene. It is really important to note 
that the drawings and palettes are the same between ALL the scene versions. You can modify the timing, effects, 
parameters and camera motion, but if you modify the drawings, they will be changed everywhere.

You can also automatically save your work. Refer to the Preferences Guide to learn more about this function.

You can delete any unnecessary versions using the Versions window.
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Saving Scenes
T-HFND-001-011

You can save your scene, save a new copy or save a new version. Don't forget that saving a new version uses 
the same drawings in all versions. 

How to save a scene

 l Select File > Save.

 l Press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).
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Saving Scenes as Copies
Saving a copy of your scene allows you to choose a new file name and location for your scene.

How to save a scene as a copy

 1. Select File > Save As.

 2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene a new 
name. The name cannot exceed 23 characters.

 3. Click Save.

47



Chapter 2: Project Creation     About Saving

Saving Scenes as New Versions
Saving a new version of your scene allows you to save your scene at it's current location, under a new file name. 

How to save a new version of a scene

 1. Select File > Save As New Version.

The Save Version dialog box opens.

 2. In the Save Version dialog box, type the new version name.

 3. Click OK.
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Auto-Saving Scenes
T-ANIMPA-001

You can allow the software to automatically save your scene, as well as decide on the length of time between 
saves.

How to auto-save a scene

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l Mac OS X: Select Harmony Essentials > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the General tab.

 3. In the Save section, set the Auto-Save parameters:

 l Interval (minutes): This is the frequency at which the auto-save takes place.

 l Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are 
drawing or doing anything in the application. If so, Auto-save waits this number of seconds 
before attempting another save.

 l Ask Before Saving: Before performing an auto-save, you are prompted with a message to con-
firm if you want to save or not. You can choose to turn off this option.

 l Enabled: This enables the Auto-save feature. If you do not want the system to automatically 
save your work, deselect this option. The auto-save is off by default.
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About Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your 
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences 
dialog box to set parameters and options.

NOTE: To learn about the different preferences available, refer to the Preferences Guide.

 l Windows:

 l Toon Boom HarmonyPremium: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Premium \full-1400-pref

 l Toon Boom HarmonyAdvanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Advanced\full-1400-pref

 l Toon Boom HarmonyEssentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Harmony Essentials\full-1400-pref

 l Mac OS X: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Premium/full-1400-pref

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Advanced/full-1400-pref

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony Essentials/full-1400-pref
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On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

How to open the Preferences dialog box

 1. Do one of the following:

 l Windows/Linux: From the top menu, select Edit > Preferences.

 l Mac OS X: Select Harmony Essentials > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).
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Chapter 3: Interface
T-HFND-003-001

Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your 
workspace conveniently. There are a series of views and toolbars you can use as you perform different operations. 
Usually, each person has a specific way of working in the interface and prefer particular views and toolbars. In this 
chapter, you will learn about the main elements of the interface and how to manage them.

NOTE: To learn more about each view's properties, see the Reference guide.

NOTE: 
On Windows, the default high-dpi setting was disabled so that text and UI element are shown properly. The 
application will appear a bit blurry but the text and UI elements will be displayed properly.

The previous behaviour is available by starting the application, Harmony[edition].exe, from the command 
line using the -enableHighDpi option.

To not have to start using the command line, the shortcut to start Harmony can be modified to add the option at 
the end of the target:

"C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premium\win64\bin\wstart.exe" 
Harmony[edition].exe -enableHighDpi

Replace the [edition] portion with the name of your edition (capitalized).
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Changing the Theme Colours
The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences 
(Mac OS X) .

The Preferences dialog box opens.

 2. Select the General tab.

 3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.

 4. Restart Harmony.
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Changing the User Interface Language
Harmony is available in English, Spanish, Japanese, and Chinese. Harmony will automatically change to you 
OS language if it corresponds to one of these four languages. If you would like to start Harmony in one of those 
language independently from your OS, you can use the command prompt or terminal to do so. 

How to start Harmony using a specific user interface language 

 1. Start a termninal, command prompt, or shell on your OS. 

 2. Using the change drive command (cd), navigate to the Harmony executable file location: 

 l Windows: C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 Premi-
um\win64\bin 

 l Mac OS X: /Applications/Toon Boom Harmony 14.0 Premium/tba/macosx/bin/ 

 3. To start Harmony in a specific language, type in the name of the Harmony application including the language 
argument (-lang) and language code (two letters): 

 l Windows: 
 l English:  HarmonyPremium.exe -lang en

 l Chinese: HarmonyPremium.exe -lang zh 

 l Japanese: HarmonyPremium.exe -lang ja 

 l Spanish: HarmonyPremium.exe -lang es

 l Mac OS X: 
 l English:  Harmony\ Premium -lang en

 l Chinese: Harmony\ Premium -lang zh

 l Japanese: Harmony\ Premium -lang ja

 l Spanish: Harmony\ Premium -lang es 

 4. Press Enter/Return to validate and launch Harmony in the desired language.
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About Menus
T-HFND-003-002

Harmony contains three types of menus from which you can access many commands and options:

Top Menu 

The top menu contains most of the commands. Depending on the view you're working in and the element, some 
commands are available and others are not. The top menu is always located at the very top of the interface.

The top menu contains the following categories:

 l File

 l Edit

 l View

 l Play

 l Insert

 l Scene

 l Drawing

 l Animation

 l Windows

 l Help

On Mac OS X, there is also a Harmony Essentials category that contains the following commands:

 l Preferences

 l About

 l Quit

View Menu 

A view menu contains commands specifically related to that view.

To access a  view menu, click the Menu  button in the top-left corner of a view.
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A view menu is available in the following views:

 l Colour

 l Function

 l Library

 l Script Editor

Quick Access Menu 

A quick access menu lets you open a list of the commands you will use most often.

To access this menu, right-click anywhere in a view.
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About Toolbars
T-HFND-003-003

Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also have 
their own toolbars which you can move around. You can reposition the toolbars to suit your work style or hide 
unused ones.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations 
in this guide. This is because the images are taken from Harmony Premium.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the views 
that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a 
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move 
from the top area to the view.

The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog 
box, you can organize different toolbars to suit your working style.

If the default toolbar does not contain the tools you require, you can customize the toolbar.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to expand 
the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to close 
Harmony and restart it for the new interface to be displayed.   A default set of tools will appear in the toolbar. 
However, you can customize the toolbar with the tools that more closely fit your work pattern. 
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Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means that 
you can change the default set of tools and replace the tools you use less frequently with ones use more often. This 
customizing is done through the Toolbar Manager.
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Adding Toolbars
T-HFND-003-004

You can add toolbars simply by using menus.

How to add or close a toolbar

 1. Select Windows > Toolbars > toolbar.

 l You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, 
however, are not available by right-clicking the toolbar area. You can access the toolbar of 
any open and active view by right-clicking in the view's top area or the Windows menu. 
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Moving Toolbars
T-HFND-003-005

You can move toolbars simply by dragging them to a new location.

How to move a toolbar

 1. Select the toolbar you want to move by clicking its anchor point  and dragging it into a view toolbar area or 
another position in the top or side interface toolbar area.

 2. When a highlighted zone appears showing an available location for the toolbar, release the mouse button and 
drop the toolbar into position.
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Resizing Toolbars
T-HFND-003-006

You can resize a toolbar by sliding its tail-end.

How to resize a toolbar

 1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end. 

 2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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Customizing View Toolbars
T-HFND-003-007

You can customize a view toolbar to add, remove, and reorder icons.

How to customize a view toolbar

 1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a new button. 
You can also reorder the buttons. Make sure the button you right-click on is active.

 2. From the menu, select Customize.

The Toolbar Manager window opens.

 3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click the Right 
Arrow   button to switch it to the Toolbar list.
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 4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left Arrow  
 button to switch to the Available Tools list.

 5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click the Up 
 or Down  buttons to move it to the correct location.

 6. Click OK when you are finished.
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About Views
T-HFND-003-008

The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify 
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are 
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or 
other type of selection or the option does not apply to the active view.

NOTE: To learn move about each view's properties, refer to 
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Workspace modifications are automatically saved when you exit the application unless you deselected the 
Automatically Save Workspace option in the Preferences dialog box.
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Adding Views
T-HFND-003-009

You can easily add views through the top menu or each view.

How to add a view to your workspace as a tab

 1. In the top-right corner of an existing view, click the Add View  button 

 2. Select a view from the list. Some views, such as the Camera view, can be opened in multiple instances. For 
example, this can be useful if you want to have two Camera views open, each focused on different areas of 
your scene, to quickly switch between working on these two areas. 

The view will appear as a new tab in the same section of your workspace:

How to add a view to your workspace as a window

 1. Open the Windows menu.                     

 2. Select the view you wish to add.                     

The view will appear as a new window over Harmony's main application window.
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How to dock a view window to your workspace

 1. Drag a window by its tab and do one of the following:

 l Drop the window onto other existing tabs to add it to that set of tabs.

 l Drop the window above, below or beside an existing view. When you get close to the edge 
of a view, a black rectangle with a blue background appears, indicating where the view will 
be inserted.
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Closing Views
T-HFND-003-010

You can close one or multiple views by using their closing button.

How to close a view

 1. Click the Close View  button.

If there are several tabs in the same view, press Shift and click the Close View  button to close all tabs at 
the same time.
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Showing and Hiding Views
T-HFND-003-012

You can temporarily show and hide views using the collapsing buttons.

How to temporarily hide a view

 1. On the edge of the window you want to hide, click the Collapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

 2. Click the Collapse/Expand button again to redisplay the view.
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Moving Views
T-HFND-003-011

You can move views by dragging their name tab to a new location.

How to move views

 1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s tab.

 2. When a blue rectangle outline appears showing an available location for the view, release the tab to drop the 
view into position. One of three things will happen:

 l The view becomes a tabbed view.

 l The view becomes a floating window.

 l The view becomes a new docked view.
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Resizing Views
T-HFND-003-013

You can resize a view by sliding its edges.

How to resize a view

 1. Place the pointer on the edge of the view to resize.

 2. When you see the Resizing  icon, drag the side of the view to the desired size.
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About Workspaces
T-HFND-003-014

The Harmony interface is composed of several views. You can customize your workspace to suit your working 
style, save it as a new workspace, and load it from the Workspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the 
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can access 
these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.

By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your 
workspaces as they are and only save the modifications when you really want to, you must disable the 
Automatically Save Workspace option.

The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can save 
your workspace as a new version to avoid over-writing the current one. If you do not want to modify the current 
workspace, use the Workspace Manager to create another one and then modify that one.

Your customized preferences are stored in the following location and you can save them to either share with 
someone else, copy to a second computer or simply back them up.

When working with Harmony Stand Alone, your custom workspaces are stored in:

Windows

 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom Anim-
ation\Toon Boom Harmony\1400-layouts-xml

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Advanced\1400-layouts-xml

 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Essentials\1400-layouts-xml

Mac OS X

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Harmony/1400-layouts-xml

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Advanced/1400-layouts-xml

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom Anim-
ation/Toon Boom Essentials/1400-layouts-xml

Linux

 l /home/[user_name]/Toon Boom Animation/Toon Boom Harmony/1400-layouts-xml/

 l /home/[user_name]/Toon Boom Animation/Toon Boom StageAdvanced/1400-layouts-xml/

When working with Harmony Server, your custom workspaces are stored in:

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-layouts-xml
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Loading Workspaces
T-HFND-003-015

You can load an existing workspace from the drop-down menu.

How to load a workspace

 1. Do one of the following:

 l Select Windows > Workspace > Workspace.

 l Select a workspace from the Workspace toolbar.
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Creating Workspaces
T-HFND-003-016

You can create new workspaces through the Workspace Manager dialog box.

How to create a new workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select an existing workspace.

 3. At the bottom of the Available Workspaces list, click the Add  button to add a workspace.

 4. Select the new workspace that was created. Click Rename and give it a new name.
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 5. Select the new workspace and click the Right Arrow  button to move it to the Workspace toolbar.

 6. Click OK.
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Renaming Workspaces
You can rename a workspace through the Workspace Manager dialog box.

How to rename a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. Choose the workspace to be renamed from the list.

 3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit the name. 

 4. Type in the new name of the workspace.

 5. Press the Enter/Return key to validate the name.

 6. Click OK. 
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Saving Workspaces
T-HFND-003-017

You can either save your workspaces automatically or manually.

How to save your workspace as a new version

 1. From the top menu, select Windows > Workspace > Save Workspace As.

The Save Workspace As dialog box opens.

 2. Type in a workspace name and click OK. 

How to disable the Automatically Save Workspace preference

 1. From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences 
(Mac OS X) to open the Preferences dialog box.

 2. Select the General tab.

 3. In the Options section, deselect the Automatically Save Workspace option.

 4. Click OK. 

The Save Workspace   button appears in the Workspace toolbar.

How to save a workspace manually

 1. Do one of the following:

 l In the Workspace toolbar, click the Save Workspace   button. 

 l You can also select Windows > Workspace > Save Workspace.
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Deleting Workspaces
You can delete a workspace through the Workspace Manager dialog box.

How to delete a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow   button to move it 
to the Available Workspaces list.

 3. Select the workspace from the Available Workspaces list, then click the Delete  button to delete the work-
space.

 4. Click OK.
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Showing and Hiding Workspaces
You can show and hide workspaces from your drop-down list through the Workspace Manager dialog box.

How to show a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow   but-
ton to move it to the Workspace toolbar.

 3. Click OK. 

How to hide a workspace

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow   button to move 
it to the Available Workspaces list.

 3. Click OK. 
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Reordering Workspaces
You can reorder workspaces in your drop-down list through the Workspace Manager dialog box.

How to reorder workspaces

 1. Do one of the following:

 l In the Workspace toolbar, click the         button.

 l From the top menu, select Windows > Workspace > Workspace Manager.

 2. In the Workspace toolbar, select the workspace to be reordered and on the Up  or Down  buttons to 
move it up or down.

 3. Click OK. 
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Restoring the Default Workspace
T-HFND-003-018

You can restore modified workspaces to their original layout.

How to restore the default workspaces

 l Select Windows > Restore Default Workspace.
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About Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.

The navigation commands in the table below can be used in the following views, with some exceptions:

 l Camera

 l Drawing

 l Timeline

 l Xsheet

 l Function

 l Side and Top

Command Action Access Methods

Zoom In Zooms in the view. 

View > Zoom In

Press 2

Roll the mouse wheel up (except in the 
Timeline and Xsheet views)

Zoom Out Zooms out the view.

View > Zoom Out

Press 1 

Roll the mouse wheel down(except in the 
Timeline and Xsheet views)

Zoom In or Out Zooms in or out of the view.

Roll the middle mouse button up or down.

Hold down the Spacebar and the middle 
mouse button while dragging the mouse up 
or down.

Pan Moves the view horizontally or vertically.
Hold down the Spacebar and drag in the 
direction you want to pan the view.

Reset Pan
Resets the view’s pan to its default 
position.

View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position.

View > Reset View

Press Shift + M

 

Reset Rotation
Resets the view’s rotation to its default 
position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default 
position.

View > Reset Zoom

Rotate View Rotates the view.
Press Ctrl+Alt (Windows/Linux) or Ctrl+⌘  
(Mac OS X) and drag in the direction you 
want to rotate the view.

Rotate 30 CW Rotates the Camera view 30 degrees View > Rotate View CW
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clockwise, like an animation table.

Rotate 30 CCW Rotates the Camera view 30 degrees 
counter-clockwise, like an animation table.

View > Rotate View CCW

Toggle Quick Close-up

Instantly multiplies the view's Zoom 
Factor by 4. For example, if the Camera 
View's Zoom Factor is at 100%, this will 
make it toggle between 400% and 100%. 

Shift+Z

Toggle Full Screen

Cycles through the following display 
modes:

 l Normal Full-Screen: The main 
application window becomes full 
screen.

 l View Full-Screen: The selected 
view becomes full screen and all 
other views are collapsed.

 l Normal: The main application win-
dow is restored to its original size 
and collapsed views are expanded.

View > Toggle Full Screen

Press Ctrl + F (Windows/Linux) or ⌘  + F 
(Mac OS X)

 

Using the Play Menu to Navigate

From the top menu, you can select any of the following commands from the Play menu to navigate around the 
interface.

Command Description

Start Frame Lets you set the frame on which playback will start.

End Frame Lets you set the frame on which playback will end.

First Frame Jump to the first frame. You can also press <.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline view.  
You can also press the comma (,) key.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. You 
can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Go to Frame

Opens the Go to Frame window in which you can enter the number of the frame 
you want to display. 

You can also use the Go button, which you can add to the Timeline toolbar 
through the Toolbar Manager. Open the Go to Frame dialog box and enter the 
frame number to jump to.

Enable Playback Plays back your animation from the Top or Side views.
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Chapter 4: Drawing  
Harmony has a wide array of drawing tools and drawing features to allow flexible design, work methods and styles.

Tool Name Icon

Select

Cutter

Reposition All Drawings

Contour Editor

Smooth Editor

Perspective

Envelope

Edit Gradient/Texture

Brush

Pencil

Text

Eraser

Paint

Ink

Paint Unpainted

Repaint

Unpaint

Stroke

Close Gap

Line

Rectangle

Ellipse

Polyline

Dropper

Each drawing tool has a series of options to customize its behaviour and drawing style.
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About the Brush Tool
T-HFND-004-003

The Brush    tool is pressure sensitive and lets you create a contour shape with a thick and thin line effect, as if it 
was created with a paint brush.

With the Brush tool, you can draw as vector or bitmap, depending on the type of drawing layer you are using.  

If you draw with vector, you can enlarge your drawing and zoom into it without losing quality or resolution. You 
can also use the Contour Editor and Select tools to resize and modify lines. 

If you draw with bitmap, you will not be able to scale your drawing beyond 100% of its resolution without 
encountering pixelization issues.

There are a variety of brush styles provided with Harmony, which you can use to create and save your own brush 
style. This lets you create brushes with precise sizes and parameters and save them so you can draw and design 
with them. Renaming a brush can make it easier to identify and access the brushes you use most frequently.

You can also create a dynamic brush for drawing with patterns created from your artwork. Create a new dynamic 
brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic brushes using a single or 
multiple patterns that automatically switch through the patterns as you draw.

NOTE: To learn more about the Brush tool options, see the Reference guide .
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Drawing with the Brush Tool
T-HFND-004-003A 

In the Camera or Drawing view, you can draw on any drawing layer type with the Brush tool. 

NOTE: To learn more about the Brush tool options, see the Reference guide .

How to draw with the Brush tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Brush  tool or press Alt + B.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

 l Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) to force a line to join the start and end of the shape 
while drawing.
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Modifying the Brush Settings
You can modify several parameters such as the brush size and smoothing. 

How to modify the brush settings

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters. Click the arrow button.

The Brush Properties window opens.

Parameter Description

Maximum Size
Defines the maximum size of your drawing tool. This parameter 
defines the  width of the stroke.

Minimum Size
Defines the minimum size of your stroke as a percentage of the 
maximum size. If you do not have pressure sensitivity from a pen 
table, the minimum size value will be ignored. 
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Smoothing
Defines the number of control points added to the centre line. The 
fewer the control points the smoother (but less faithful) the line.

Contour Smoothness
Optimizes the contour line smoothness of the line. This parameter 
smooths the contour of the line once it has been traced. The higher 
the value, the fewer control points will compose your line. 

Tip Shape

Lets you select a tip shape—from round and square ones to star 
shaped. This option is disabled when using a textured brush.

NOTE: To learn more about the Brush tool options, see the Reference guide .
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Selecting a Brush Preset
Harmony provides you with default brush presets available in the Tool Properties view. 

How to select a brush preset

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Tool Properties view, select a brush preset from the Presets section.
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Creating a Brush Preset
You can create your own custom brush presets and add them to the existing list.  

How to create a brush preset

 1. Make sure your current brush has the settings you want in the preset you will create—see the Reference 
guide .

 2. In the Tool Properties view, do one of the following:

 l Click the arrow button to display the Brush Properties window and click the New Brush  
button  in the upper-right corner.

 l Click the New Brush  button.

 l From the Brush  menu, select New Brush Preset.

 3. In the New Preset window, type a name for your new brush preset.

The new brush is added to the end of the list of brush presets.
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Creating Dynamic Brush Presets
You can create dynamic brush presets allowing you to stamp custom patterns. You can either repeat the same 
pattern or loop a pattern made of several drawings. 
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Renaming a Brush Preset
To keep your list comprehensive and organized, you can name your custom brush presets.

How to rename a brush preset

 1. In the Tool Properties view, select a brush to rename. 

 2. From the Brush  menu, select Rename Brush. 

 3. Type in a new name for the brush and click OK.
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Deleting a Brush Preset
You can keep your preset list clean by deleting unwanted custom presets. 

How to delete a brush preset

 1. In the Tool Properties view, select the brush preset you want to delete.

 2. Do one of the following:

 l Click the Delete Brush  button.

 l From the Brush  menu , select Delete Brush.
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Updating a Brush Preset
If you want to modify the settings of an existing custom preset, you can do so by adjusting the parameters in the 
Tool Properties view and then update the preset. 

How to update a brush preset

 1. Select the brush preset to update and click the arrow button to display the Brush Properties window.

 2. Change the brush settings and click the Update Brush Preset  button  in the upper-right corner.
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Exporting Brush Presets
You can export your presets to either backup. share, or install on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file and 
give it a name.

 5. Click Save.
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Importing Brush Presets
You can import Harmony brush presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Brush Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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Drawing with Vector Textured Brushes
Delete this text and replace it with your own content. 

How to draw with textured lines

 1. In the Tools toolbar, select the Brush  tool or press  Alt + B. 

 2. Select a texture for your brush from the textures presets available at the end of the list.

 3. If you want to modify the settings, in the Tool Properties view,  click the Arrow button to open the Brush 
Properties view.

 4. Click the Texture tab, select the Paper Texture option.

 5. Set the following parameters: 

Parameter Description

Hardness The hardness value corresponds to the softness of the line edge. 
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The lower the value, the softer the line edge will be. The higher 
the value, the sharper the line edge will be.  

Maximum Opacity
This value corresponds to the transparency of the stroke when 
the pressure is heavy.  

Minimum Opacity

This value corresponds to the transparency of the stroke when 
the pressure is light and is a percentage of the Maximum Opacity 
value. 

 6. In the Camera view, start drawing.
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Adding a Paper Texture
You can add custom paper textures to your presets. 

How to add a paper texture

 1. Do one of the following:

 l From the Paper Texture menu , select Add.

 l Click the Add Paper Texture button.

 2. In the browser window that appears, navigate to where you saved your texture file.

 3. Click Open to import the file into the Paper Texture library.

By default, an imported texture is given the name of the image file.
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Erasing Textured Lines
You can erase vector textures lines with a smooth eraser edge. 

How to erase textured lines

 1. In the Tools toolbar, select the Eraser  tool, press Alt + E.

 2. In the Tool Properties view, click the arrow button.

The Eraser Properties window opens.

 3. Adjust the following: 

 

 4. In the Camera view, erase your textures lines.
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Adjusting the Line Texture Opacity
If you drew with textured lines that are either too light or too dark, you can adjust the line texture opacity of your 
drawings.

How to adjust the line texture opacity

 1. If you are in Camera view, select the Current Drawing on Top option—see Displaying the Current Draw-
ing on Top on page 174.

 2. In the Timeline view, select the drawing that contains the opacity you want to adjust.

 3. In the Camera  view menu, select Drawing > Adjust Line Texture Opacity.

The Adjust Line Texture Opacity dialog box opens. 

 4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.

 5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All Drawings 
option and click OK.
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About the Pencil Tool
T-HFND-004-004

The Pencil  tool is for drawing the final images, such as character nodes, cut-out puppet and clean animation. The 
pencil creates a central vector shape. 

The Brush  tool takes account of pressure sensitivity, allowing you to create lines with variable thicknesses when 
using a pen tablet, creating a contour vector shape. You can set different parameters, such as the size and 
smoothness of the Brush tool in the Tool Properties view. If you draw with the Brush tool and want to modify the 
thickness variation, use the Contour Editor  tool. 

The Pencil, Polyline  and Shape    tools let you create a central vector line of uniform thickness. Pressure sensitivity is 
not supported with pencil lines. You can set different parameters, such as the size and smoothness of the Pencil 
tool in the Tool Properties view.

NOTE: To learn more about the Pencil tool options, see the Reference guide .
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Drawing with the Pencil Tool
T-HFND-004-004A

Using the Pencil tool, you can draw central vector lines which easily reshapeable.

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to draw with the Pencil tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. In the Colour view, click a colour swatch to select a colour.

 4. In the Drawing or Camera view, start drawing.

 l When you get close to an existing pencil line, hold Alt to draw and connect your stroke to the 
existing one. Pencil lines are central vector lines and you might think your line is connected, 
but in fact, only the contour is touching the other one. Also, make sure the central vector 
crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

 l To draw a straight line, press Shift + Alt as you draw.
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Selecting a Pencil Preset
A pencil preset is a pencil with specific properties. 

Regular pencil presets allow you to set the size and smoothing of a pencil line, or the size of a shape.

How to select a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, use the Presets menu to select a pencil preset.

 3. In the Drawing or Camera view, draw your pencil line or shape.
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Creating Pencil Presets
You can create your own custom pencil presets.  

NOTE: To learn more about the Pencil tool options, see the Reference guide .

How to create a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Tool Properties view, adjust your pencil settingsthe Reference guide .

 3. In the Tool Properties view, click the New Brush  button.

The New Preset dialog box opens.

 4. Type in a name for your new pencil thickness stencil and click OK.

 5. Start drawing in the Drawing or  Camera view. 

110



Harmony 14 Essentials - User Guide

Renaming Pencil Presets
You can rename your pencil presets to keep your list organized.

How to rename a pencil preset

 1. In the Tools toolbar, select the Pencil , Line , Ellipse , or Rectangle  tool. 

 2. In the Presets menu, select the preset you want to rename.

 3. From the Brush menu , select Rename Brush.

The Rename Preset dialog box opens.

 4. In the Name field, type in the new name.

 5. Click OK.
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Deleting Pencil Presets
You can delete unnecessary presets from your list. 

How to delete a thickness stencil or pencil preset

 1. In the Tools toolbar, select the Pencil  tool.

 2. In the Presets menu, select the thickness stencil or preset to delete.

 3. Click the Delete Preset  button.
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Exporting Pencil Presets
You can export your pencil presets to either backup, share or install on a different computer.

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file and 
give it a name.

 5. Click Save.
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Importing Pencil Presets 
You can import Harmony pencil presets that you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Pencil Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. Dis-
plays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About Shape Tools
T-HFND-004-006

In Harmony, you can use the shape tools to draw circles, lines and rectangles. You can also easily reshape a 
square or circle into a much more complex drawing—see About the Contour Editor Tool on page 140 . 

The available shape tools are: 

 l Line tool

 l Rectangle tool

 l Ellipse tool

 l Polyline tool 

The shape tools use the same pencil presets as the Pencil tool. To learn how to create, delete, rename, import 
and export presets, see About the Pencil Tool on page 107.  

To learn more about the shape tool parameters, see the Reference guide . 
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Drawing with the Polyline Tool 
You can use the Polyline tool to draw long and curvy lines. 

NOTE: To learn more about the Polyline tool options, see the Reference guide .

How to draw with the Polyline tool

 1. In the Timeline view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Polyline   tool or press Alt + _.

 3. In the Camera or Drawing view, click and drag to create a point and a Bezier handle to shape your line.

 4. Click a new area and drag to create a second point and Bezier handle.

 l Press Alt to pull only one handle, instead of two.

 l Press Shift to snap the handles to 45, 90, or 180 degrees.

 

 5. Repeat the previous step until your shape is completed.

 6. Press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click to release the Polyline tool from the current path or 
shape that it is creating. Continue to use the tool to make multiple, independent paths or shapes.

 7. If necessary, reshape the lines using the Contour Editor    tool—see Reshaping a Drawing with the Contour 
Editor Tool on page 141.
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Drawing with the Rectangle, Ellipse, and Line Tools 
T-HFND-004-006A

You can use the Line, Rectangle, or Ellipse tool to draw shape without having to trace them. You can also draw 
perfect circles and squares. 

NOTE: To learn more about the shape tool parameters, see the Reference guide . 

How to draw with a shape tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Rectangle , Ellipse , or Line  tool.

 3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill  option.

 4. In the Camera view, click and drag to draw the shape.
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 l Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

 l Hold down Alt to draw the rectangle or ellipse from its centre.

 l Hold down Shift to snap the line every 15 degrees.

 l Hold down Alt to snap the start or end of the line to a nearby stroke.

 5. Use the Contour Editor  tool to deform the shape and create your drawing.
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About the Stroke Tool
T-HFND-004-013

There are two different ways to draw invisible lines, using the Pencil tool or Stroke tool.

Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be useful for 
drawing tones and highlights directly on the character.

The Stroke  tool draws invisible lines only. You cannot add thickness to the line. Unlike the Close Gap tool that 
creates a short, straight line between two points, the stroke line will stay exactly where you draw it. This tool can 
be useful for closing a zone in a particular way or creating some hard shadows or highlight areas.

Sometimes, it may be difficult to see strokes, especially if your colours are similar to the blue stroke colour. In 
Harmony, you can display the strokes in washed-out colours so the invisible lines stand out.

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 
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Drawing with the Stroke Tool 
T-HFND-004-013A

You can draw invisible lines with the Stroke tool as well as with the Pencil tool.  

NOTE: To learn more about the Stroke tool parameters, see the Reference guide 

How to draw invisible lines with the Stroke tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar from the Paint drop-down menu, select the Stroke  tool or press Alt + V.

 3. From the top menu, select View > Show Drawing > Show Strokes  or press K. 

 4. In the Tool Properties view, you can adjust the smoothness.

 5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about the 
Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.

How to draw invisible lines with the Pencil tool

 1. In the Timeline or Xsheet view, select the cell on which you want to draw.

 2. In the Tools toolbar, select the Pencil  tool or press Alt + /.

 3. From the top menu, select View > Drawing > Show Strokes  or press K. 

 4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.

 5. In the Camera or Drawing view, start drawing.

If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first stroke, a 
Message dialog box opens.

121



Chapter 4: Drawing      About the Stroke Tool

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you about 
the Show Strokes option.

 6. Click OK.

 7. You can modify the stroke shape with the Contour Editor  tool.
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About the Eraser Tool
T-HFND-004-010

Using the Eraser tool, you can remove parts of your drawing. When erasing brush strokes and painted areas, the 
contours will keep the shape you traced. When erasing pencil stroke, the central vector will be erased and the line 
tips will reshape based on the line's parameters. 

It is a good idea to create and save erasers with precise sizes and parameters in order to save time when drawing 
and designing. Toon Boom Harmony provides you with a variety of default eraser styles and allows you to create 
and save your own.

Eraser presets are created by saving the properties of the current eraser as a preset, in order to reuse it again and 
again. 

The Eraser tool uses its own preset list, separated from the Brush tool. 

NOTE: To learn more about each individual parameter, see the Reference guide .
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Erasing 
T-HFND-004-010A

You can erase portion of your artwork using the Eraser tool.  

NOTE: To learn more about each individual parameter, see the Reference guide .

How to erase with the Eraser tool

 1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

 2. In the Tools toolbar, select the Eraser  tool or press Alt + E.

 3. In the Camera or Drawing view, start erasing.
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Modifying the Eraser Settings 
T-HFND-004-010B

In the Tool Properties view, you can modify the Eraser tool parameters such as the size and smoothing. 

NOTE: To learn more about each individual parameter, see the Reference guide  .

How to modify the eraser settings

 1. In the Tools toolbar, select the Eraser  tool.

 2. In the Tool Properties view, the preview area displays the stroke that will be produced after you customize 
the different parameters in the Eraser Properties view. Click the arrow button.

The Eraser Properties window opens.

The Size and Smoothness tab is where you set the minimum and maximum sizes of your drawing tool which 
will produce the thick and thin effect on your stroke.

The Soft Eraser tab needs to be enable for its parameters to become active. This feature only works on soft 
or textured brush strokes. Both tabs works with the pressure sensitivity of a pen tablet.
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Exporting Eraser Presets
You can export your eraser presets for backup, sharing or installing on a different computer. 

How to export pencils, brushes and erasers

 1. From the Brush menu, select Export.

 2. In the Export Brushes dialog box, select the vector brushes and erasers to export, as well as any pencils.

 3. Click Export.

 4. In the Export Brushes window that appears, browse to the location where you want to save the .xml file 
and give it a name.

 5. Click Save.

126



Harmony 14 Essentials - User Guide

Importing Eraser Presets
You can import Harmony eraser presets you previously exported. 

How to import pencils, brushes and erasers

 1. From the Brush menu , select Import Brushes.

 2. In the browser window that appears, navigate to and select the .xml file.

 3. Click Open.

 4. In the Import Brushes dialog box, select the brushes brushes and erasers you want to import. You can also 
import pencils at the same time.

 5. Click Import.

The imported brush, eraser and pencil styles will appear in the presets library. You can reuse any of the 
imported tips to create other brush, eraser and pencil style presets.
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Changing the Eraser Preset Display
You can display your preset list as thumbnails or a list. 

How to change the Presets Library thumbnail display

 1. From the Brush menu, select one of the following:

Parameter Description

Small Thumbnail
Reduces the size of the thumbnails in order to view more at the same time. Dis-
plays an image of the tool's tip and its maximum size.

Large Thumbnail
Increases the size of the thumbnails in order to see the images more clearly. 
Displays an image of the tool's tip, its maximum size and its name.

Stroke View Displays the tool's name, maximum size and stroke preview.
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About the Select Tool
T-HFND-004-005

Before you can edit objects, you must first select them using the Select tool. After that, you can scale, translate, 
rotate, and resize them, as well as reposition the pivot point.

NOTE: To learn more about the Select tool options, see the Reference guide .
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Selecting 
T-HFND-004-005A

Using the Select tool, you can select drawing strokes and groups. 

NOTE: To learn more about the Select tool options, see the Reference guide .

How to select objects

 1. In the Timeline view, select the cell on which you want to select drawing objects.

 2. In the Tools toolbar, select the Select  tool or press Alt + S.

 3. In the Camera view, select the drawing objects.

 l You can select all the drawing objects in a drawing by using Edit > Select All or by pressing 
Ctrl + A (Windows/Linux) or ⌘  + A (Mac OS X).

 4. To deform or reposition a selection:

 l To reposition, click the selected drawing object and drag the selection to a new area.

 l To rotate, grab the selection box handle and rotate it.

 l To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to lock 
the selection’s ratio.
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 l To skew, drag sideways or up and down the sides or top and bottom segments, between the 
control points.
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Inverting a Selection
You can invert your selection to select everything else in your drawing that was not previously selected. 

How to invert a selection

 1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I.
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Repositioning the Selection Pivot
You can temporarily reposition the selection's pivot position to rotate, scale, or skew from a different point.

How to temporarily reposition the pivot point

 1. In the Camera or Drawing view, select the drawing object you want to transform. 

The pivot point appears in the middle of your selection.

 2. Click the pivot point and drag it to a new position.

This becomes the new position of the pivot point for the current transformation and will remain there until you 
make a new selection.
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Working on a Single Drawing with the Select Tool
You can set the Select tool to select the artwork on all the layers or on the current layer only. In the Drawing view, 
it only works on the current layer. In the Camera view, you can set one mode or the other. 

NOTE: To learn more about the Select tool options, see the Reference guide .

How to enable the Select Tool Works on Single Drawing preference

 1. In the Tools toolbar, select the Select  tool or press Alt + S.

 2. Do one of the followings:

 l In the Tool Properties view, click the Works on Single Drawing  button.

 l Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences (Mac 
OS X). In the Camera tab, go to the Tools section and select the Select Tool Works on 
Single Drawing option and click OK.

 3. In the Camera view, make your selection. Note that you may need to restart Harmony depending on your 
system.
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About the Repositioning All Drawings Tool
The Reposition All Drawings  tool is used to reposition, scale, rotate or skew all drawing strokes on every drawing 
included in a layer. 

If your hand-drawn animation requires to be repositionned in the grid, as soon as your select the Reposition All 
Drawings tool, all the strokes in all the drawings exposed on the current layer are selected. You can use the controls 
the same was as the Select tool—see About the Select Tool on page 129. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .
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Repositioning Drawings
Use the Reposition All Drawings tool to reposition all the drawing strokes on all drawings exposed in the current 
layer. 

NOTE: To learn more about the Reposition All Drawings tool options, see the Reference guide .

How to reposition all drawings

 1. From the Tools toolbar, select the Reposition All Drawings  tool. This also automatically selects every 
stroke in your drawing in the Drawing and Camera view.

 2. Do any of the following:

 l To reposition, click and drag your selection to a new area.

 l To rotate, rotate the selection box handle.
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 l To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift to main-
tain the selection’s ratio.

 l To skew, drag the sides or top and bottom segments, between the control points.

 3. When you release your cursor, every drawing in the drawing layer you repositioned, scaled, rotated or 
skewed will follow the same transformation.

 4. You can also adjust the position by modifying the settings and using the operation buttons in the Tool Prop-
erties view.
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About the Cutter Tool
T-HFND-004-007

The Cutter tool lets you cut a drawing to move, copy, or delete it.You can use it to scale or reposition the portion 
of a flattened drawing. you can also use it to trim strokes using a single gesture.

NOTE: To learn more about the Cutter tool options, see the Reference guide .

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com
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Cutting Artwork 
T-HFND-004-007A

Use the Cutter tool to trim and cut your artwork. 

NOTE: To learn more about the Cutter tool options, see the Reference guide .

How to cut drawings

 1. In the Tools toolbar, select the Cutter  tool or press Alt + T.

 2. In the Camera or Drawing view, select an area to cut away.

 l To delete the selected area, press Delete.

 l To move the selection, drag it to a new area.

 l Use the bounding box controls to scale, skew, or rotate the cut piece.
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About the Contour Editor Tool
T-HFND-004-008

The Contour Editor lets you reshape drawings. By displaying vector points around a shape and the central vector 
points in a pencil line, you can pull or push on these points to adjust the brush’s line thickness. Points can be 
selected and deleted. Each point has two Bezier handles for correcting the curves between two points. You can 
modify shapes by pulling and pushing directly on the segment between the points. You can use it to perfect a 
central shape pencil line, a contour shape brush line, or even create an elaborate shape from a basic ellipse or 
square.

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com
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Reshaping a Drawing with the Contour Editor Tool
T-HFND-004-008A

You can use the Contour Editor tool to reshape vector drawings by editing the points. 

NOTE: To learn more about the Contour Editor tool options, see the Reference guide .

How to reshape drawings with the Contour Editor Tool

 1. In the Timeline or Xsheet view, select the cell in which you want to draw.

 2. In the Tools toolbar, select the Line , Ellipse , or Rectangle  tool. The following example uses the 
Ellipse tool.

 3. In the Tool Properties view, click the Ellipse  button, click the Auto Fill  button and set the pencil size 
to 0.

 4. In the Drawing or Camera view, draw a circle.

 5. In the Tools toolbar, select the Contour Editor  tool.

 6. In the Drawing or Camera view, click the line to reshape it.

 7. Select one or several points by clicking on them or circling around.
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 8. Press Delete to delete a selected point.

Press Ctrl (Windows/Linux) or ⌘  (Mac OS X)and click on the contour to add a new point to adjust the 
contour.

 9. To modify the shape, you can:

 l Pull on the Bezier handle. Both point’s handles will move as one.

 l Hold down Alt and pull on one of the Bezier handles. The point’s handle will move inde-
pendently from the other one.

 l Move the selected points to a new area.

 l Pull directly on the line between two points. No selection is necessary. Holding down Shift 
will limit the contour modification to the curve between the two first points.

 l If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

 l To add control points, press Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click the line.

 l To remove control points, select the control point and press Delete.
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About the Smooth Editor Tool 
When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines you draw may 
look as if they were drawn with an unsteady hand. When this occurs, you may need to correct the look of your lines.

Harmony has a very powerful tool you can use to optimize contours and reduce the number of points on the lines, the 
Smooth Editor  tool. 

NOTE: To learn more about the Smooth Editor tool options, see the Reference guide .
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Smoothing Lines
You can use the Smooth Editor to smooth out specific areas of your drawing strokes.

How to optimize lines with the Smooth Editor tool

 1. In the Tools toolbar, select the Smooth Editor  tool or select Drawing > Tools > Smooth Editor.

 2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass over 
the same line several times to remove more points and make the line smoother. Note that by default, the 
Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see the Reference 
guide  to learn about the various settings available.

144



Harmony 14 Essentials - User Guide

About the Perspective Tool
The Perspective tool lets you deform a drawing selection and alter its perspective. You can use the corner and edge 
anchor points to warp the shape.

To have even more control points to fully warp a vector image, see About the Envelope Tool. 

NOTE: To learn more about the Perspective tool options, see the Reference guide .
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Deforming a Drawing with the Perspective Tool
Use the Perspective tool to distort a drawing's bounding box.  

NOTE: To learn more about the Perspective tool options, see the Reference guide .

How to deform a drawing with the Perspective tool

 1. In the Tools toolbar, select the Perspective  tool from the Contour Editor drop-down menu or press Alt + 
0.

 2. In the Camera or Drawing view, select a drawing to deform.

 3. Click and drag the different anchor points to deform the shape.
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About the Envelope Tool
The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier handles. You can 
warp images to make them look like they are reflected in water or in a deformable mirror.

NOTE: To learn more about the Envelope tool options, see the Reference guide .
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Warping a Drawing with the Envelope Tool
You can warp your drawings using the Envelope tool.  

NOTE: To learn more about the Envelope tool options, see the Reference guide .

How to warp a drawing with the Envelope tool

 1. In the Tools toolbar, select the Envelope   tool from the Contour Editor drop-down menu.

 2. In the Timeline view, select a drawing to deform.

 3. In the Camera or Drawing view, select the region you want to deform

 4. Click and drag the different anchor points and handles to deform the image.
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 5. To display more controls, in the Tool Properties view, click the Show Advanced Controls  button.

 6. Increase the height and width of the grid to get more control points to deform your image.
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About the Text Tool
With the Text tool, you can type text in your project using various fonts and texts attributes. Text objects are part 
of a drawing, so you can manipulate them in the same way. OTF fonts are also supported.

Once your text is writing, you can break the strings apart to convert the letters into drawing objects that can than 
be individually modified with tools such as Select, Perspective, Contour Editor, Smooth Editor. 

NOTE: To learn more about the Text tool options, see the Reference guide .
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Adding Text
You can use the Text tool to add text to your drawings.  

NOTE: To learn more about the Text tool options, see the Reference guide .

How to add text to drawings 

 1. Do one of the following: 

 l In the Tools toolbar, select the Text  tool. 

 l From the top menu, select Drawing > Tools > Text.

 l Press Alt + 9.

 2. In the Timeline view, select the cell containing the drawing on which you want to add text.

 3. In the Drawing or Camera view, click on the location you want the text to begin.

 4. You can use the Tool Properties view to select the font, font size and format of the text you will type—see the 
Reference guide . 

 5. Type in the desired text.

 6. Click outside the text box to exit the typing mode.

If you want to create another text object, click outside the currently active text box. You can always return to 
edit the text by selecting the Text  tool and clicking in the text.

 7. You can resize the text box by selecting your text box with the Text   tool and moving the anchor point right 
or left. Using the Select tool will distort and scale your text itself rather than changing the width and height of 
your text box.
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Breaking Text Apart
Text contained in a text field is treated as a single drawing object. You can easily separate the text so each 
character becomes an individual drawing object that you can select and modify independently.

How to break a text object

 1. In the Tools toolbar, click the Select  tool or press Alt + S.

 2. In the Drawing or Camera view, select the text object you want to break.

 3. From the top menu, select Drawing > Convert > Break ApartText Layers.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText Lay-
ers.

Each character is surrounded by a bounding box that you can modify; they remain text objects that you can 
edit.

 4. If you want to convert your independent letter to a complete vector object that you can deform, use the Select 
tool to select the letters to convert.

 5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the selection into a reg-
ular drawing object, with no more text attributes.

 l From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text Lay-
ers to break the selection into a regular drawing object, with no more text attributes.
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About the Rotate View Tool
The Rotate View  tool lets you rotate the Drawing or Camera view, the same way as you would do with a real 
animation disc  for increased flexibility. This tool can also be used in the Perspective view.

The rotation angles for the Camera and Drawing views are independent; if you rotate the Drawing view 25 
degrees, if you switch to the Camera view, you can use the rotary table in that view and rotate it to a different 
angle without affecting the settings in the other view.

When using the Rotate View tool, you are only rotating your workspace. You can not changing the actual rotation 
angle of your drawings. Exporting your project will completely ignore the Rotate View angle.

The Rotate View tool has no options in the Tool Properties view.
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Rotating the Workspace
You can use the Rotate View tool to rotate your drawing workspace. 

How to use the Rotate View tool

 1. Do one of the following:

 l From the top menu, select Drawing > Tools > Rotate View.

 l In the Tools toolbar, select the Rotate View  tool.

 l In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

 l Hold down Ctrl + Alt (Windows/Linux) or ⌘  + Alt (Mac OS X).

The rotary table appears.

 2. In the Drawing or Camera view, click and drag to rotate the space. 

 3. Release the keyboard shortcut or switch to a new drawing tool.

 4. Reset the view rotation using View > Reset Rotation or press Shift + X to reset the rotation.
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About the Hand Tool
You can use the Hand tool to pan through the Drawing or Camera view. When you are zoomed in your 
workspace, you may need to pan to a different area of your image. You can do so with the Hand tool or the 
Spacebar keyboard shortcut. 

The Hand tool has no options in the Tool Properties view.

How to use the Hand tool 

 1. Do one of the following:

 l In the Tools toolbar, select the Hand  tool, click in the Drawing or Camera view and drag. 

 l You can also Hold down the Spacebar, click in the Drawing or Camera view and move your 
mouse in the direction you want to pan the view.
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About the Zoom Tool
The Zoom   tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

NOTE: To learn more about the Zoom tool options, see the Reference guide .

How to use the Zoom tool 

 1. In the Tools toolbar, select the Zoom  tool available in the Hand tool drop-down menu. 

 2. Click in the  Camera or Drawing view. 

 3. In the Tools Properties view, do the following:  

 l Enable the Zoom In  mode to zoom in mode when you click in the  Camera or Drawing view.
 When you're in Zoom In mode, hold  as you click to zoom out.

 l Enable the Zoom Out mode to zoom out when you click in the  Camera or Drawing view. 

 l Click on the Zoom In  button to immediately zoom in. You can also press 2.

 l Click on the Zoom Out   button to immediately zoom out. You can also press 1.
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About the Grid 
Harmony is equipped with a traditional animation grid. You can use it as a reference while drawing to fit a given 
layout field chart, align elements, or simply see the center of your drawing. You can draw beyond the grid 
boundaries as it is only a visual reference.  

In the Camera view, the Grid is visible when you select a drawing tool.
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Displaying the Grid
You can display the grid and it will be visible in the Drawing view. It will be visible in the Camera view when you 
select a drawing tool. 

Use the Show Grid option to display a grid in the Drawing or Camera views. 

How to display the grid 

 1. Do one of the following: 

 l In the Drawing View toolbar, press the Show Grid  button. 

 l In the Camera View toolbar, press the Show Grid  button.  

 l Select View > Grid > Show Grid. 

 l Press Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).
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Modifying the Grid
You can modify the look of the grid to be either square, 12-field, 16-field, outline, and so on. 

How to modify the grid display  

 1. Select View > Grid > Show Grid to display the grid. 

 2. To modify the grid, select one of the following: 

 l View > Grid > Grid Outline Only—Displays the outline of the grid only.

 l View > Grid > Square—Displays a standard square grid. 

 l View > Grid > 12 Field Grid—Displays a 12-field size grid. 

 l View > Grid > 16 Field Grid—Displays a 16-field size grid.

 l View > Grid > Underlay—Displays the grid under the drawing elements. 

 l View > Grid > Overlay—Displays the grid over the drawing elements.

 3. In the Drawing View and Camera View toolbars, you can also add the following buttons—see Customizing 
View Toolbars on page 63.

 l Grid Outline Only  button 

 l Square  button 

 l 12 Field Grid  button 

 l 16 Field Grid  button 

 l Underlay  button 

 l Overlay  button
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Grouping Drawing Strokes
Use the grouping options to group and ungroup selected drawing objects and strokes. This can help in the selection, 
repositioning, re-scaling and other transformations to be applied to multiple objects of a drawing. Grouping does not 
flatten your objects. You can ungroup your selection at any time. You can also group groups. 

How to group strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be grouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Group.

 l From the Camera or Drawing view menu,  select Edit > Group > Group.

 l Press Ctrl + G (Windows/Linux) or ⌘  + G (Mac OS X). 

How to ungroup strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  groups to be ungrouped.

 3. Do one of the following:

 l From the top menu, select Edit > Group > Ungroup.

 l From the Camera or Drawing view menu,  select Edit > Group > Ungroup.

 l Press Ctrl + Shift + G (Windows/Linux) or ⌘  + Shift + G (Mac OS X). 
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Arranging Drawing Strokes
The different Arrange options let you reorder drawing objects and strokes inside a single layer in the Drawing or 
Camera view.  

How to arrange drawing strokes 

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the  strokes to be reordered.

 3. Do one of the following: 

 l From the top menu, select Drawing > Arrange > Bring to Front—Moves the selected art to 
the front (on top). Press Ctrl + Shift + PgUp (Windows/Linux) or ⌘  + Shift + PgUp (Mac OS 
X). 

 l From the top menu, select Drawing > Arrange > Bring Forward—Moves the selected art 
one level forward (closer to the front). Press Ctrl + PgUp (Windows/Linux) or ⌘  + PgUp 
(Mac OS X).

 l From the top menu, select Drawing > Arrange > Send Backward—Moves the selected art 
one level lower (behind). Press Ctrl + PgDown (Windows/Linux) or ⌘  + PgDown (Mac OS 
X).

 l From the top menu, select Drawing > Arrange > Send to Back—Moves the selected art 
behind everything (bottom / back). Press Ctrl + Shift + PgDown (Windows/Linux) or ⌘  + 
Shift + PgDown (Mac OS X).

 4. In the Drawing View and Camera View toolbars, you can also add the following buttons—see Customizing 
View Toolbars on page 63.

 l Bring to Front  button

 l Bring Forward   button

 l Send Backward   button

 l Send to Back  button
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About Drawing Optimization 
As you work, you drawing can get complex and contain multiple strokes. You may want to optimize those drawings 
to reduce the number of brush strokes, pencil lines, and invisible strokes. You may also want to flatten your artwork 
or optimize your brush stroke textures.

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the selected drawing 
objects. Drawing objects will only be flattened and optimized if the selected objects do not change the appearance of 
the final image when they are merged. 

For example, if you have selected a number of partially transparent objects, which you layered to create an additive 
colour effect, the selected transparent drawing objects will not be merged. This is because merging the transparent 
drawing objects will cause them to lose the effect of the layered transparent colours. 

You could also want to add invisible contour strokes so that if you unpaint lines, the vector container remains to be 
repainted later.
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Flattening Drawings
The Flatten  operation is used to merge drawing objects and brush strokes into a single layer. If you draw new 
lines to fix a drawing or line with many brush strokes, it can be useful to flatten them all into a single shape. By 
default, lines are drawn one on top of each other. If you intend to repaint the lines or modify their shape, it will be 
easier if they are flattened.  

How to flatten drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to flatten. 

 3. Select Drawing > Optimize > Flatten or press Alt + Shift + F. You can also press the Flatten  button in 
the Tool Properties view.
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Smoothing Drawings
The Smooth operation is used to reduce the number of contour points on a brush stroke and center points on a pencil 
line. It also smooths out the shape.  

How to smooth drawings

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to smooth out. 

 3. Select Drawing > Optimize > Smooth or press Alt + Shift + S. You can also press the Smooth  button in 
the Tool Properties view.

165



Chapter 4: Drawing      About Drawing Optimization

Optimizing Drawings
You can use the Optimize feature to flatten your drawing strokes without changing the aspect of your drawings. 
This mainly means that transparencies will not be flattened. 

How to optimize a drawing

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, select the drawing strokes you want to optimize. 

 3. Do one of the following:

 l From the top menu, select Drawing > Optimize > Optimize.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Optimize. 
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Reducing the Drawing Texture Resolution

How to reduce the drawing texture resolution

 1. In the Tools toolbar, select the Select tool.

 2. In the Camera or Drawing view, use the Select tool to select the drawing objects whose texture resolution 
you wan to reduce.

 3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.

 l From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing Tex-
ture Resolution.

 4. In the dialog box, drag the slider toward the left to reduce the texture resolution.

 5. Enable the Apply to All Drawings option if you want the modification to be applied to all the drawings in your 
layer.

 6. Click OK.
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About Strokes Conversion 
You may have drawing stroke using the Pencil tool when you wanted to use the Brush tool. You may also have 
drawing your image using the Polyline tool and now you want to convert your strokes to brush strokes. For many 
reasons, you may want to switch your stroke types to another type to use the various advantage set they offer.  

There are three types of strokes: 

 l Brush strokes (contour vector) 

 l Pencil strokes (central vector) 

 l Invisible strokes (central vector with a thickness value of 0)

Harmony lets you convert pencil lines to brush strokes, brush strokes to pencil lines, and invisible strokes 
(strokes) to pencil lines. 

You can also break text objects apart—see Breaking Text Apart on page 153.
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Converting Brush Strokes to Pencil Lines 
The Brushes Strokes to Pencil Lines  operation converts selected contour strokes into centreline pencil strokes. The 
brush stroke thickness will be lost.

How to convert brush strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ̂ .

 l Right-click on the selection, select Convert >Brush Strokes to Pencil Lines or press ̂
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Converting Pencil Lines to Brush Strokes
The Pencil Lines to Brush Strokes  operation converts the selected centreline pencil strokes into contour strokes 
brush lines.

How to convert pencil lines to brush strokes

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press 
&.

 l Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &. 

 l In the Tool Properties view, press the Pencil Lines to Brush Strokes  button.
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Converting Strokes to Pencil Lines
The Strokes to Pencil Lines  operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines

 1. In the Tools toolbar, select the Select tool. 

 2. In the Camera or Drawing view, select the strokes you want to convert. 

 3. Do one of the following: 

 l Select Drawing > Convert > Strokes to Pencil Lines or press Shift + F12 (Windows/Linux 
only).

 l Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12 
(Windows/Linux only)
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About OpenGL Antialiasing
Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap. When you 
draw in the Drawing or Camera view, notice that your lines may appear jagged. This is caused by the fast real-
time display called OpenGL.  If you prefer to see smooth lines as you draw, you can enable the antialiasing 
preference.

Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only antialias your 
drawings, but all your different views in the interface. Full scene antialiasing is an option you can turn on or off; by 
default, it is disabled. 

There is no need to modify your graphic card settings.

NOTE: Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be 
rendered to 100% of its resolution regardless of your preference settings or graphic card panel.
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Setting the Full Scene Antialiasing Preference
You can enable  the Full Scene Antialiasing preference to smooth out the OpenGL artwork.

NOTE: You must restart Harmony after you change the parameters.

How to customize the full scene antialiasing parameters

 1. Do one of the following:

 l Select Edit > Preferences (Windows/Linux) or Harmony Essentials > Preferences (Mac 
OS X). 

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. In the OpenGL tab, select the Enable option in the Full Scene Antialiasing section.

 3. Number or samples: Enter the number of samples you want to be used for the antialiasing process. The 
number of samples is basically equivalent to the amount of times a pixel will be enlarged to calculate the anti-
aliasing. This technique is called supersampling. The higher the number of samples, the better the anti-
aliasing quality will be, but the longer it will take to calculate.

 4. Restart Harmony.
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Displaying the Current Drawing on Top
In the Camera view, when you draw on a layer, the artwork is displayed in the correct order. For example, if the 
layer on which you are drawing is located behind an object on another layer, the lines you draw will be hidden 
behind that object.

You can display a selected drawing on top of everything while you draw. Then, each time you  select a drawing 
tool, the drawing is displayed in front of everything in the Camera view. The Timeline view ordering remain 
unchanged. 

How to display the drawing on top

 1. Do one of the following:

 l From the top menu, select View > Show > Current Drawing on Top. 

 l In the Camera bottom toolbar, click the Current Drawing on Top button.

NOTE: The Current Drawing on Top status is retained when you exit Harmony. When you 
restart the application, the last status will be used.

 2. In the Tools toolbar, select a drawing tool. You only need to enable this option once, it is not necessary to 
do it each time you select a drawing tool.  

 3. In the Camera view, start drawing.
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Chapter 5: Paperless Animation
T-HFND-006-001

Toon Boom Harmony is a powerful paperless animation software that incorporates animation and drawing tools to 
make your work easier and more efficient.

Although it is a digital process, paperless animation is still hand-drawn and the fundamental principles of animation 
still apply. 

One of the advantages of working with paperless animation is that you do not lose time scanning elements in and 
testing them because everything is already digital. You can simply draw your animation and play back your line test 
right away. This also saves the substantial amount of paper required by traditional animation. Another practical 
advantage is the ability to undo and redo some actions that are often difficult on paper, such as erasing brush 
strokes.
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Creating a Rough Animation
The first step to complete a traditional paperless animation is the rough construction, which is the skeleton of your 
animation. You would usually start with the main action. For example, to animate a walk cycle, you will start with 
the torso motion and the legs. Head, arms and clothes will be added later during the secondary animation.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the details 
when you're satisfied with the movement. If you start animating all the details right away, you will lose a lot of 
time if you have to make corrections, and your animation is likely to look rigid. 

How to create a rough animation

 1. In the Tools toolbar, select the Brush  tool or press Alt + B.

 2. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your rough 
animation. This will make the clean up process easier as your clean dark lines will contrast with your light 
sketch lines. 

 3. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.

 4. In the Camera or Drawing view, draw the first key drawing.

176



Harmony 14 Essentials - User Guide

 5. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

 6. In the Tools toolbar, click the Onion Skin  button. This will display the previous and next drawings in a light 
colour in the Camera or Drawing view, behind your current drawing, so that you can use them as references 
to draw new drawings with accuracy. This can be useful to draw breakdown poses between two key poses, 
or to add an in-between drawing between two other drawings.

 7. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing on it. To 
do this, do one of the following:

 l In the Timeline view, drag the blue onion skin markers to extend the number of past and future 
drawings to display as onion skin, if needed. 

 l In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing 
, Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing 
 and Onion Skin Add One Next Drawing  buttons to adjust the span of the onion skin 

frame by frame.

 8. In the Camera or Drawing view, draw your second key drawing.

 9. In the Timeline or Xsheet view, select a cell between the two key drawings.
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 10. In the Camera or Drawing view, draw your new pose.

 11. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new drawing.

NOTE: When working with overlay layers in the Camera view, you can enable the Current Drawing on Top 
 option to make the layer you're working on appear over other layers. 

How to review your animation

 1. In the Timeline view, use the Enable/Disable All  and Solo  buttons to turn off any layers you don't  
want to see during playback.

 2. In the Timeline view, move the red playhead to the first frame of your animation and click the Start button 
on the Timeline toolbar. Then, move the playhead to the last frame of your animation and click the Stop but-
ton.

 3. In the Playback toolbar, click the Loop  button to enable looping during playback.

 4. In the Playback toolbar, click the Play  button to being playback.
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Creating the Tie Down Animation
Once your rough animation  is correct, you can start adding extra details, such as arms, clothes or hair. You can add 
the extra details on the same layer with the same colour or you can also create a new colour so that you can always 
see your original sketch.

If your primary and secondary animation were done as a rough drawing, it is now time to put your drawing on model, 
also known as tie down. This means that you have to review your animation and ensure that every single detail is on 
model and there is no volume distortion. You can do this directly on the original sketch layer or on a new layer.

If you want to keep your rough animation as it is to avoid any mistakes, you can add an extra drawing element and 
use the Light Table feature to draw over the first drawing element. This technique can also be used if you want to 
reuse your rough animation for other characters. For example, if you have a rough walk-cycle, you can reuse it for 
another character and add its personal features in a new layer. This way, you only need to animate the secondary 
animation instead of the whole body again. 

How to create secondary animation on the same layer

 1. In the Xsheet or Timeline view, select the cell in which you want to add new details.

 2. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for example) or 
select the same rough colour as before.
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 3. In the Drawing Tools toolbar, select your drawing tool.

 4. In the Camera or Drawing view, draw the secondary animation.

 5. Do one of the following:

 l In the Xsheet or Timeline view, select the next cell in which you want to draw.

 l Press F and G to navigate between your drawings.

 6. Do one of the following:

 l Select View > Onion Skin > Show Onion Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 7. Extend the onion skin.

 8. In the Camera or Drawing view, draw the secondary animation.
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 9. You can also use the Playback toolbar to play the animation in real time.

How to create your secondary animation on an extra layer

 1. Add a new drawing layer and name it secondary_animation.

 2. In the Timeline or Xsheet view, select the rough layer's timing.

 3. Copy the timing and in the top menu, select Edit > Paste Special or Ctrl + B (Windows/Linux) or ⌘  + B (Mac 
OS X).

 4. Choose Never create drawing files from the options to paste the timing but not the drawing files.

 5. If you are working in the Drawing view, in the Drawing View toolbar, enable the Light Table.

 6. In the Xsheet or Timeline view, select the cell where you want to add the new details.

 7. In the Colour view, create a new colour  (give it the same name and add the prefix _2 or _sec, for example) or 
select the same rough colour as before.
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 8. In the Tools toolbar, select your drawing tool.

 9. In the Drawing or Camera view, draw the secondary animation on top of your rough drawing.

 10. Do one of the following:

‣ In the Xsheet View, select the next cell in which you want to draw.

‣ In the Camera, Drawing or Xsheet view, press F and G to navigate between your drawings.

 11. Do one of the following:

 l In the top, Drawing View or Camera View menu, select View > Onion Skin > Show Onion 
Skin.

 l In the Timeline view menu, select Onion Skin > Show Onion Skin.

 l Press Alt + O.

 12. Extend the onion skin.

 13. In the Camera or Drawing view, draw the next secondary animation.

 14. You can also use the Playback toolbar to play the animation in real time.
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Cleaning Animation
T-HFND-006-010

When your rough animation is ready, it is time to clean it up and ink it. The clean-up is also called tracing. It consists 
of tracing solid and clean lines over the rough animation to get closed zones. This is the final paperless animation 
step before the ink and paint step.

You will need to add a new drawing layer to create your clean drawing. This is the equivalent of adding a sheet of 
paper and tracing the rough using the animation disk. This allows you to keep the roughs and the cleans intact. You 
only need to lock the rough layer to prevent it from appearing in the scene. 

If you plan on tracing your animation in the Drawing view, use the light table to display all the layers in your project.

How to trace animation in a new layer

 1. In the Layer toolbar, click the Add Drawing Layer  button and add a new layer.

 2. In the Timeline view, click the Lock button of the layer containing your rough animation to avoid selecting 
the layer in the Camera view.

 3. In the Timeline or Xsheet view, in the new layer, select the cell corresponding to the first key drawing of your 
rough animation.

 4. In the Tools toolbar, select the drawing tool of your choice. The Pencil  tool is recommended.

 5. In the Colour view, select a colour for tracing your animation. A dark bold colour, such as black, would ensure 
that it contrasts well with the light colour of your rough animation.

 6. In the Camera or Drawing view, start tracing the first key drawing.
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 7. If you have some other layers in the way, you can disable them temporarily from the Timeline view so that 
only the rough animation and clean-up layer are displayed in the Camera view. 

 8. In the Tools toolbar, click the Onion Skin  button and pull on the blue onion skin handles in the Timeline 
view to extend the number of frames you can see.

 9. In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing , 
Onion Skin Reduce One Previous Drawing , Onion Skin Reduce One Next Drawing  and 
Onion Skin Add One Next Drawing  buttons to adjust the span of the onion skin frame by frame.

 10. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

 11. In the Drawing or Camera view, trace your next drawing.

 12. Repeat the previous steps for each drawing.
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Paperless Animation Tools
To understand paperless animation, you must first discover the tools available. There are, of course, drawing tools, 
but also practical features such as setting a drawing as a key, breakdown or in-between.

When you create hand-drawn animation digitally, there are certain tools you require in order to work efficiently, as 
you would with an animation table, paper and pencils. 

The onion skin and light table are used to preview previous and next drawings, cells, elements and frames. When 
designing or animating, it is very useful to see your previous drawings. Just as if you were building a cut-out puppet, 
you want to view other drawing elements to know where to draw the new element. 

Harmony has many useful advanced features such as the Flipping toolbar, enhanced onion skin, extra drawing 
layers, and automated matte generation.
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Creating Empty Drawings
The Create Empty Drawing  command automatically creates Creates a drawing in the selected cell, replacing any 
drawing that may already be exposed in that cell and the following ones until it meets another drawing, key 
exposure or a blank cell. 

How to create an empty drawing

 1. In the Timeline or Xsheet view, select the cell in which you want to create an empty drawing.

 2. Do one of the following:

 l In the top menu, select Drawing > Create Empty Drawing.

 l In the  Timeline view toolbar, click the Create Empty Drawing  button. 

 l Press Alt + Shift + R.

The new drawing is created in the Xsheet and Timeline view.
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About the Onion Skin
The Onion Skin   tool lets Lets you preview the previous and next drawings. By default, the previous drawings appear 
in a shade of red and the next drawings are displayed with a shade of green. You can change these colours in the 
Preferences dialog box. 
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Enabling the Onion Skin
You can enable the onion skin to see your previous and next drawings as reference,  

NOTE: You can modify the onion skin display in the Preferences panel.

How to enable the onion skin

 1. Do one of the following:

 l From the top menu, select View > Onion Skin > Show Onion Skin.

 l In the Timeline view, click the Onion Skin  button on a layer.

 l In the Tools toolbar, click the Onion Skin  button.

 l Press Alt + O.

Blue arrows appear on both sides of the play head.  

 2. Drag the blue arrows to add more frames to the onion skin display.  
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Generating a Matte
You can quickly generate a matte to be displayed behind your rough animation so you don't see the background 
through the drawings. It can be generated in any art layer.

How to generate a matte

 1. Do one of the following:

 l In the Tools toolbar, select the Select  tool.

 l Press Alt + S.

 2. In the Camera or Drawing view, select the drawing you want to create a matte for. 

NOTE: You can also apply the operation to all the drawings in the layer at the same time.

 3. Do one of the following:

 l In the Camera or Drawing menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

 4. If you want to create a matte for all the drawings included in your layer, select the Apply to All Drawings 
option.

 5. Depending on how precise or rough your line is, increase or decrease the radius value. Use a lower value, the 
closer to your lines’ contours the matte will be shaped. The higher the value, the looser the matte will be 
shaped.
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 6. In the Source Art menu, select the layer from which you want the matte created: Line ArtColour Art.

 7. In the Destination Art menu, select the layer on which you want the matte to be created: Line ArtColour 
Art.

 8. If you already have artwork on the destination layer and you want the content to be deleted before the 
matte is added into it, select the Clear Destination Art First option.

 9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case you ever 
need to keep them for later), select the Copy Stroke in Destination option.

 10. Click OK.
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Chapter 6: Timing
When you create hand-drawn animation traditionally or in a paperless environment, it's important to know how to set 
and modify the timing of your drawings. 

In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper exposure sheet 
created by the animator. In a paperless workflow, the animator creates and manages their own exposure sheet 
directly in Harmony without the need for reproduction.

If you're more of a traditional animator, you will probably work with an exposure sheet. If you're a digital animator, 
you may prefer to work with a timeline to visualize your timing. Harmony offers both.

The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in hand-drawn 
animation. You can set the animation sequence's exposure and name the drawings.

The Timeline view is also used to visualize timing, and represents elements and groups of elements as layers.

You can adjust timing in both views; your choice depends on which technique you're accustomed to using. 
Depending on your working style, some actions may seem preferable to do in one view instead of another. Many of 
the actions you perform in the Xsheet can also be accomplished in the Timeline. This chapter will often show both 
techniques. You can choose which one you prefer.

In this chapter, you will learn how to work on your drawing’s exposure and length. The exposure and animation paths 
for symbols are covered in separate chapters.

NOTE: The exposure sheet is not mandatory for cut-out animation. It can be useful for creating characters and 
parts, but is not really needed for animation and timing. If you plan to work with cut-out animation, you can still 
learn useful tips by reviewing the section on exposure sheets.
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About Scene Length
The length of your scene is dependent on how many drawings you need to expose and for how long. A drawing 
can be a held for several frames to make the action appear slower or for just a few frames to make the action 
appear faster. When setting the timing for an animation, a lot of adding and removing of frames occur to get the 
timing just right. This invariably changes the scene length.

Adding and removing frames can be done in the Timeline, Xsheet or though the Scene menu.
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Setting Scene Lengths
T-HFND-007-007

You can set the scene length by adding the right number of frames to your scene. You can set the global scene 
length from the top menu.

In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length

 1. Select Scene > Scene Length.

The Set Scene Length dialog box opens.

 2. In the Number of Frames field, enter the number of frames needed.
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Modifying the Visible Scene Length
In the Timeline view, you can choose to extend or reduce the limit for visible frames.

When you reduce the scene length, the hidden drawings and symbols are not deleted. They're still available if you 
extend the scene again.

How to modify the scene length in the Timeline view

 1. In the Timeline view, drag the scene length bracket:

 l Right: To add more frames to your scene.

 l Left: To reduce the number of frames in your scene.
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Adding Frames to the Middle of a Scene
As you're setting the timing for drawings, you may realize that you need to add extra frames. It is possible to add 
new frames either before or after any frame in your scene.

How to add frames to the middle of a scene

You can add frames anywhere in the middle of the scene—before or after a selection. If you select a frame row in the 
Xsheet view, Harmony will add the new frames before or after the selection, depending on your choice.

 1. Do one of the following: 

 l In the Timeline view, select the frame to which you want to add frames before or after.

 l In the Xsheet view, select a frame row. 

 l In the Timeline view, select the frame to which you want to add frames before or after.

 2. Do one of the following:

 l From the top menu, select Scene > Frame > Add Frames Before Selection or Add Frames 
After Selection. 

 l In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add 
Frames After Selection.

 l In the Xsheet toolbar, click the Add Frames  button to add frame after your selection.

 l Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘  + G and  Ctrl + H (Mac OS X).

The Add Frames dialog box opens.

 3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 4. Click OK.
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Adding Frames to the Start or End of a Scene
As you're setting the timing for drawings, it is possible to add new frames either the start or end of the scene.

How to add frames at the start or end of a scene

 1. In the top menu, select Scene > Frames > Add Frames at Start or Add Frames at End.

The Add Frames dialog box opens.

 2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

 3. Click OK.
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Removing Frames
As you're setting the timing for drawings, it is possible to remove a frame or range of frames.

How to remove a frame or a range of frames  in the Xsheet view

In the Xsheet view, you can remove any selected frame range, such as the last frame.

 1. In the Xsheet view, do one of the following:

 l Select a frame in a given column.

 l Select a frame range by clicking the first frame’s number and then dragging the selection 
highlight down to the last frame to delete.

 

 2. To delete the selected frames, do one of the following: 

 l From the top menu, select Scene > Frame > Remove Selected Frames. 

 l Press Delete to delete the selection. 

 l Click the Remove Frames  button. To remove several frame selections, click the button 
repeatedly.

If you selected a range of frames, the Warning dialog box may open.

 3. To complete the operation:
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 l Click Yes to delete the selection.

 l Click No to delete only the exposure in the cell and not the frames.

 l Select the Don’t Show This Message Again option to prevent the warning message from 
being displayed each time you delete a frame range.
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About Layers and Columns
T-RIG-009-003

Before filling in any values or setting any timing or exposure, you need to create drawing elements. Each drawing 
element is represented as a vertical column in the Xsheet view and a horizontal layer in the Timeline view.

In Harmony, whether you work in the Timeline or Xsheet view,  any modification you do to one view will be applied 
to both.

When you add a drawing element to your scene, a folder is added to the scene directory. This folder is named the 
same way as the drawing element and is in fact, linked to the drawing element. Its purpose is to contain all the 
drawings related to this element (layer, column). For example, in cut-out animation, a character can have many 
heads available. All of the head drawings will be contained in this folder, even if they are not exposed in the 
Timeline or the Xsheet view.

Drawings are exposed in cells/frames and linked to the drawings saved in the layer's directory. When you remove 
a drawing from a cell/frame, it is not displayed, but still exists in the directory.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that 
when you modify, repaint, or correct a drawing named “1,” all exposures of drawing “1” are updated 
simultaneously. In order to modify a drawing independently from its other exposures, you must duplicate the 
drawing.

NOTE: There are different element types available, such as sound and expression. A sound element con-
tains sound files. Expressions, Beziers, 3D path, Quadmaps and Pegs are for motion purposes during the 
compositing step. It's not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu. 

NOTE: To learn more about the layer parameters, see the Reference guide .
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Layer and Column Types
A column is also known as a layer. There are several types of layers you can add in the Timeline and Xsheet view. 
Each layer is indicated by an icon to help you differentiate them. Some layers are represented differently in the 
Xsheet view. 

Drawing Layer

The most common layer type is the drawing layer. 

 

Any time you need to create a vector drawing or import a symbol or image, you can use a drawing layer. You can 
also create bitmap artwork on a drawing layer.

Bitmap Layer

If you import a bitmap images (as original bitmap) in your project, they are inserted in a Bitmap layer. If you choose to 
vectorize your image when you import, the vectorized object will be placed on a Drawing layer.

When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you place a bitmap 
into a symbol, you will be able to mix vector drawings with it on the same layer.

Camera Layer

You can only have one Camera layer at a time in the Timeline view. By default, there is no Camera layer when you 
create a scene. You need to add a Camera layer when you want to create a camera motion.

The Camera layer is not visible in the Xsheet view.

NOTE: If you want to have several cameras with different settings, you can keep adding Camera layers in your 
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time in 
your timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them.
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When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in the 
Functions section of the  Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene has no 
background colour and if you render it as a QuickTime movie or image sequence, it will have a black background.

This layer is not visible in the Xsheet view.

Group Layer

A Group layer can be used to organize the Timeline view. 

You can drag and drop other layers onto a Group layer and then collapse the Group layer to hide these other layers 
from view. 

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to any drawing 
layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in the Peg layer.

When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the  Functions 
section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain drawings. This 
can be attached to any drawing layer, cut-out puppet, or even other Peg layers. They will all follow the 
deformation you set in the Quadmap layer.

When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are displayed in the 
Functions section of the Xsheet view.

Sound Layer

You can import sound files to add dialog and sound effects to your project. The sound layer will be added to your 
Timeline and Xsheet view when you import a sound file in your scene.
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In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types

In the Xsheet view, you can add several advanced column types to create particular animation paths. When you 
create these columns, they are not linked automatically to any particular drawing layer. You can create a motion path 
using these columns and then link or unlink several drawing or peg layers to it. 

Advanced column types include:

• Timing

• 3D Path

• 3D Rotation

• Bezier Curve

• Ease Curve

• Expression 

• Annotation
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Adding Layers and Columns
T-HFND-005-002

There are different ways to add a drawing elements (layers and columns) to your project. By default, when you 
create a new scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the 
Timeline view.

When you add an element, it will appear as a column in the Xsheet view,  a layer in the Timeline view. 

NOTE: To learn more about the layer parameters, see the Reference guide .
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Adding Layers in the Timeline View
Drawing elements are more commonly known as layers in the Timeline view. Create them using the following 
procedure:

How to add a drawing element from the Timeline view

 1. In the Timeline view, click the Add Drawing Layer  button or press Ctrl + R (Windows/Linux) or ⌘  + R 
(Mac OS X).

The Add Drawing Layer window opens.

 2. In the Name field, name your new layer.

 3. Do one of the following: 

 l Click Add to add a first layer and keep the window open to add more layers. 

 l Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.
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Adding Layers from the Top Menu
Another way to add layers to the Timeline view is through the top menu.

How to add a drawing element from the top menu

 1. From the top menu, select Insert > Drawing.

The Add Drawing Layer dialog box opens.

 2. In the Name field, type a relevant element name and click  OK.

The new drawing element appears in your scene.
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Adding Columns from the Xsheet View
Drawing elements in the Xsheet view are more commonly known as columns. You can add columns using the 
following procedure:

How to add a drawing element from the Xsheet view

 1. Do one of the following:

 l In the Xsheet menu, select Columns > Add Columns. 

 l Click the Add Columns  button. 

 l Press Shift + C.

The Add Column dialog box opens.

 2. In the Name field, type a relevant element name.

 3. In the Type field, select Drawing. 

 4. To complete the operation:

 l Click Add and Close to add your new layers and close the dialog box.

 l Click Add to add your new layers and keep the dialog box open to add column.

 l Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Node views—see Layer and Column Types on 
page 201.
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Using the Advanced Add Column Dialog Box
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Deleting Layers and Columns
T-HFND-005-004

You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view

 1. In the Timeline view, select the layers to delete.

 2. Do one of the following:

 l In the Timeline’s Layer toolbar, click the Delete Layers  button. 

 l Right-click on the selection and select Delete.

How to delete columns in the Xsheet view

 1. In the Xsheet view, select the columns to be deleted by clicking on their header.

 2. Do one of the following

 l Right-click on the selection and select Delete Columns. 

 l In the Xsheet toolbar, click the Delete Columns  button.

 l Press Delete.

The Confirm Delete dialog box opens.

 3. To complete the operation:

 l Click OK to delete the selected layers.

 l Click Cancel to cancel the operation.
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Renaming Layers and Columns
Once you add layers and columns to your project, you can modify their names.

How to rename a layer in the Timeline view

 1. In the Timeline view, double-click on the name of the layer to rename.

 2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor

 1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.

The Layer Properties editor opens.

 2. In the Name field, rename the layer.

 3. Click Close.
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About Layer and Column Display
You can change the way a column in the Xsheet view displays. You can change the way a layer in the Timeline view 
or a column in the Xsheet view displays. You can stay organized without changing the content of elements or your 
animation output.
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Expanding and Collapsing Layers and Columns
To simplify the look of the Timeline or Xsheet view, you can expand and collapse some of the layers and 
columns. If layers are parented to other ones, you can collapse the parent layer to hide its children.   

How to collapse or expand selected layers in the Timeline view

 1. In the Timeline view, select the layer(s) to collapse or expand.

 2. Do one of the following:

 l Right-click on the selection and select Collapse/Expand > Collapse/Expand. 

 l Click the Expand Children Arrow  button on the parent layer.

 l Click the Collapse/Expand  button  (you may have to customize the toolbar to display it).

 l Press  Ctrl + I (Windows/Linux) or ⌘  + I (Mac OS X).

How to collapse or expand all layers in the Timeline view

 1. Do one of the following:

 l Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

 l In the Timeline toolbar, click the Collapse All  or Expand All  buttons (you may have 
to customize the toolbar to display them).

 l Press 0 and 9.

How to collapse and expand 3D path or rotation columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button to display the Functions list.

 2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or expand.

 3. Do one of the following:

 l Right-click on the column’s header and select Expand/Collapse > Collapse Selection or 
Expand Selection.

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view

Do one of the following:
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 l Right-click on any column’s header and select Expand/Collapse > Collapse All or Expand All.

 l Press 0 and 9.
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Showing and Hiding Layers and Columns
As you work in the Drawing, Camera or Xsheet view, some layers or columns may be in the way, such as those 
that were used as references. You can hide these layers to make your work area less cluttered and easier to 
navigate.
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Showing and Hiding Layers
T-HFND-005-010

You can show and hide layers in the Timeline view in several different ways.

When using the Solo mode to show or hide layers, here's how it works:

 l If you have anything selected, it is not affected.

 l When multiple layers are selected and you enable/disable the Solo mode on any of those layers, it is applied 
to all the selected layers. 

 l When multiple layers are selected and you enable/disable the Solo mode on layers that are not part of the 
selection, it is applied only to those particular layers. 

When exporting or rendering a scene, the Solo mode setting of layers is ignored. 

NOTE: When a layer is affected by an inverted cutter, enabling the Solo mode for this layer will not show it 
unless the mask is also enabled.

How to show or hide all layers

 1. Click one of the following in the Layers toolbar: 

 l Enable/Disable All  button to show or hide all layers. 

Any hidden layers are unhidden, so you can view all layers.

 l Solo Mode  button to view disable your current Solo mode selection. Any soloed drawing or 
sound layers are disabled, so you can view all layers. When you click again on the Solo Mode 
button, you last Solo selection is displayed.

How to show or hide individual layers

 1. Do one of the following:

 l In the Layer toolbar, click the Solo Mode  button.

 l Click the layer's Enable/Disable All  button to show or hide that layer. 

 

 l Press A to show a layer or D to hide selected layers.
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 l In the Timeline toolbar, click the Enable/Disable  button (you may have to customize the 
toolbar to display it).

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view.

How to enable the selected layer and disable all others

 1. Do one of the following:

 l Hold down Alt and click the Solo Mode  button of the layer you want to solo and hide all 
other layers.

 l In the Timeline toolbar, click the Disable All Others  button (you may have to customize 
the toolbar to display it).

In the Timeline view, you can hide or show certain types of layers such as Effect. 
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Showing and Hiding Columns
The Xsheet view has a Column List section that displays all the columns contained in the exposure sheet. It can be 
used to hide individual columns.

If you need to see a column after it has been hidden, you can display it directly from the Xsheet view without using 
the Column List section.

You can also hide a column type, such as Drawing or Sound. When you do this, its corresponding layer is disabled in 
the Timeline view.

How to show and hide columns in the Xsheet view

 1. In the Xsheet toolbar, click the Show Column List  button.

 2. On the right side of the Functions section, click the Expand  button to display the Column List section.

 3. Do one of the following:

 l In the Column List section, select the columns to display and deselect the columns to hide. 

 l In the Xsheet toolbar, click the Hide Selected Column  button (you may have to customize 
the toolbar to display it).
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Showing Hidden Columns
In order to save visual space in the Xsheet view, columns can be hidden from view. The hidden layer's presence 
is indicated by a thicker grey line between columns.

How to show hidden columns in the Xsheet view

 1. In the Xsheet view, do one of the following:

 l Click the thick grey line that represents a hidden column. 

 l Right-click on the column header and select Show Hidden Columns.

 l Press Alt + Shift + H.

The Show Hidden Columns dialog box opens.

 2. In the Show column, select the hidden columns you want to display in the Xsheet view.

 l Click Check to select all the selected columns.

 l Click Uncheck to deselect all selected columns.
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Showing and Hiding Column Types
You can hide specific column types from view, in order to work more easily with one aspect of your project. For 
example, you could hide all the Drawing columns in the Xsheet, so that you could work more easily with your 3D 
Path Columns. 

How to show and hide column types using the Column List

 1. In the Column List section, click the button corresponding to the column type you want to show or hide.

Column Type Action

Show/Hide All Columns

Show/Hide Drawing Columns

Show/Hide Function Columns

Show/Hide 3D Path Columns

Show/Hide 3D Rotation Columns

Show/Hide Sound Columns

Show/Hide Annotation Columns
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Displaying Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it's not easy to quickly identify a particular 
column. Displaying the column thumbnails makes this easier. This option displays a small thumbnail picture of 
the current frame below the column header.

How to display the thumbnails

 1. In the Xsheet toolbar, click the Show Thumbnails  button.

The thumbnails appear.
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Changing Layer and Column Colours
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and columns. 

How to change the layer’s colour in the Timeline view

 1. In the Timeline view, click the Change Track Colour  button of the layer you want to modify. 

 2. In the Select Colour dialog box, select a new colour for your layer.

 3. Click OK.

The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter, selected colour 
for easy identification. The corresponding column colour is also updated in the Xsheet.

How to reset a layer’s colour in the Timeline view

 1. In the Timeline view, select the layers to reset.

 2. In the Timeline toolbar, click the Default Track Colour  button (you may have to customize the toolbar to 
display it).

How to change a column’s colour in the Xsheet view

 1. In the Xsheet view, select one or more columns to modify.

 2. Right-click on the column’s header and select Colour > Change Columns Colour.

 3. In the Select Colour dialog box, select a new colour for your columns.
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 4. Click OK.

The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view

 1. In the Xsheet view, select the columns to reset.

 2. Right-click on the column’s header and select Colour > Default Columns Colour.
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Creating Scene Markers on Frame Ranges
Change the colour of the area above a frame range by setting a scene marker. This will allow you to find the range 
more rapidly when quickly scanning the Timeline.
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Editing Scene Markers
You can modify the colour of a scene marker or edit the note attached to it.

How to edit a scene marker

 1. In the frame counter area, select the entire scene marker.

NOTE: It's important to select the entire length of the scene marker, otherwise the Timeline Scene Marker 
dialog box will not open for editing.

 

 2. Right-click and select Scene Markers > Edit Scene Marker.

The Timeline Scene Marker dialog box opens.

 3. Make your changes.

 4. Click OK.
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Deleting Scene Markers
If you deem it no longer necessary to have a frame or a range of frames marked, you can delete the scene marker.

How to delete a scene marker

 1. In the frame counter area, select at least one frame in the scene marker you want to delete.

 2. Right-click and select Scene Markers > Delete Scene Marker.
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Reordering  Layers and Columns
You can change the order of your elements in the Timeline view and Xsheet view. When you change the order of 
your elements in one view, the other one is updated.

How to reorder layers in the Timeline view

 1. In the Timeline view, select the layers to move.

 2. Drag the selection to the new location.

 3. Do one of the following:

 l Drop the selection on an existing layer to make it a child of another element layer.

 l Drop it between the existing layers. Timeline layers that are located above the selection are 
displayed in front it. Layers located under it in the Timeline View are displayed behind it.

How to reorder columns in the Xsheet view

 1. In the Xsheet view, click on the column’s header with the middle mouse button.

 2. Drag the column to its new position.
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Navigating Layers and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames, and layers. 
Displays the previous drawing, next drawing, previous layer or next layer. using keyboard shortcuts that work in the 
Camera, Drawing, Xsheet and Timeline views.

You can navigate through:

• Drawings

• Frames

• Columns

How to navigate through drawings,and frames and columns

 1. In the Timeline or Xsheet view, select a cell.

 2. Once the cell is selected, you can navigate between:

 l Previous and next layers: From the top menu, select Drawing > Previous Layer and Next 
Layer or press H and J.

 l Previous and next drawings: From the top menu, select Drawing > Previous Drawing and 
Next Drawing or press F and G..

227



Chapter 6: Timing     Deleting Scene Markers

 l Previous and next frames: From the top menu, select Play > Previous Frame and Next 
Frame or press comma (,) and period (.).
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Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify anything you 
want in the duplicated element without affecting the original one.

How to duplicate an element

 1. In the Timeline or Xsheet view, click the layer or column to duplicate.

 2. Do one of the following: 

 l (Xsheet) Right-click on the column and select Duplicate Selected Columns.

 l (Timeline) Right-click on the layer and select Duplicate Selected Layers.

The new duplicated layer or column appears.
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Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same drawings as the 
original. For example, if you modify a drawing in the cloned or original column, it is updated in both columns. 

You can choose whether or not to copy the column timing to the cloned columns. 

 l You can modify the column timing independently from each other, but the drawings remain linked.

 l You can copy the columns timing, so drawings and timings remain linked.

You can clone selected nodes from the Node view in the same way.

This is useful when you want to reuse a hand-drawn animation but have different timings.

How to clone an element

 1. In the Timeline or Xsheet view, select the layer or column to clone.

 2. Do one of the following:

 l From the top menu, select Edit > Clone: Drawings Only to clone only the layer or column 
drawings.

The new cloned layer or column appears.
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Displaying Layer and Column Properties
Each element has its own set of properties that you can modify, including effect and peg layers.

If you want to modify an element’s properties, you can display the properties of a selected layer in the Timeline view. 
If you're working with the Xsheet, you can display its properties as well. You can display a layer's properties as a 
window or as a view of its own.

The Layer Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

 l Lock the layer

 l Change the track colour

The Column Properties editor allows you to:

 l Rename the layer

 l Enable or disable the layer

How to display a layer's properties

 1. Do one of the following:
 l In the Layer Properties view is not part of your workspace, from the top menu, select Windows > 

Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

The properties display—see Element/Drawing Node in the Reference guide .
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About Exposures
Harmony provides different ways to fill in exposures and values, create cycles, and set increments.

233



Chapter 6: Timing     About Exposures

Inserting and Overwriting Exposures

In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These modes 
control the filling behaviour. The Timeline view only uses the Overwrite mode.

By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence overwrites 
existing ones. The existing timing sequence remains in the same place and is not pushed down the column.

The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value sequence over 
existing ones, the new values are inserted between the old ones. The existing timing sequence is pushed down 
the column.

How to switch between the Overwrite and Insert modes

 1. Do one of the following:

‣ In the bottom-right corner of the Xsheet view, click Overwrite/Insert.

‣ Press I.
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Typing Exposures
T-HFND-006-007

To fill in your exposure, you can type the values directly in the Xsheet view.

If you want to type an exact drawing name or value in the Timeline view, you must use the Parameters section of the 
Timeline.

NOTE: You can only use alphanumeric values (0 to 9, a to z) and the underscore (_) and dash (-).

How to type a value in the Timeline view

 1. In the Drawing Substitution field, double-click to edit the field and type the name of the drawing you want to 
create.

 2. Press Enter/Return to validate the value.

How to type a value in the Xsheet view

 1. In an Xsheet column, double-click on a cell.

 2. Type a value or drawing name in the cell.
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 3. Press Enter/Return to move to the next cell.

 4. Press Esc to exit the typing mode.
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Holding Exposures
Drawings in an animation project are often exposed for more than one frame. The most common exposure of a 
drawing is two frames. In the industry, this type of exposure is known as animation in double frames or animation on 
twos. A drawing can also be exposed for three, four, or five cells and so on. To prevent mistakes and save time, you 
can hold cells automatically as you type in the Xsheet view.

How to hold an exposure

 1. Do one of the following:

‣ From the top menu, select Animation > Cell > Hold Exposure > the desired option.

 2. Type a value or drawing name in the cell.

‣ Press Enter/Return to move on to the next cell.

‣ Press Esc to quit the typing mode.
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Extending Single Exposures
T-HFND-007-008

Extending the exposure lets you select a cell and extend it to the desired frame. 

How to extend an exposure in the Timeline view

 1. In the Timeline view, select the cell you want to extend.

 2. Do one of the following:

 l Right-click and select Extend Exposure.

 l In the Timeline View menu, select Exposure > Extend Exposure.

 l Select Animation > Cell > Extend Exposure.

 l Press F5.

 3. In the Extend Exposure dialog box, enter the frame number to extend your cell to.

 4. Indicate if you want to insert the new frames before the following exposure or overwrite it. If you select 
insert, any following exposure will be moved down. if you select Overwrite, the following exposure will be 
erased and replaced by the drawing being extended.

NOTE: You can also select the last cell where you want to extend your drawing to (such as the 
last cell of the layer), right-click and select Extend Exposure. You will not be prompted the dia-
log box.

How to extend an exposure gesturally

 1. In the Xsheet view, select the red arrow  in the cell’s right side. Make sure you see the drag down  
cursor.

 2. Pull down the selected cell to the desired frame. 

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is 
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considered cancelled.

How to extend an exposure from the top menu

 1. Select a cell and do one of the following:
 l From the top menu, select Animation > Cell > Extend Exposure.

 l Press F5.

The Extend Exposure dialog box opens.

 2. Enter the frame number you want to extend the cell to.
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Extending Exposure Sequences
When working with a sequence that contains only numbers, you can extend an exposure sequence in a similar 
manner to extending a single exposure.

How to extend an exposure to create a sequence

 1. In the Xsheet view, select a cell containing a number.

 2. In the selected cell, click the red arrow  on the cell’s right side. Make sure to see the drag down  
cursor.

 3. Hold down the Shift key. Make sure a plus sign (+) appears.

 4. Pull down the selection box to the desired frame.

NOTE: The red selection box must be visible when releasing the cursor. If not, the action is 
considered cancelled.

 5. First release the Shift key, then release the mouse button.
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Extending Previous Drawing Exposures
T-HFND-006-005

When drawing on a blank frame, you can automatically create a new drawing and extend the timing from the 
previous exposed drawing. 

In the following example, a cell is selected in the Timeline view for creating a new drawing in image A. In image B, 
the previous exposure does not extend to the new drawing, while in image C, it does.

How to extend the exposure of previous drawings

 1. Open the Preferences dialog box by doing one of the following:

 l Select Edit > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

The Preferences dialog box opens.

 2. Select the General tab.
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 3. In the Timeline section, select the Extend Exposure of Previous Drawing option.

 4. On the left side of the Timeline view, select a cell and create a new drawing.

The previous exposure automatically extends to the beginning of the new drawing.
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Dragging Cells
To readjust your timing, you can drag one or more cells to a new location. You can drag a cell to any other frame in 
the same column or into another column.

You can turn off the Gestural Drag mode for the Xsheet view to prevent drawings from being dragged from one 
location to another. This feature does not apply to Annotation columns.

How to drag a cell to another location in the Timeline view

 1. In the Timeline view, select one or more cells to move.

 2. Drag the cells to the new location.

 3. Drop the selection by doing one of the following:

 l Drop by simply releasing the mouse or pen.

 l Hold Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the cells. The 
original cells will not be moved.

 l Press Shift while dropping the selection to insert them between existing frames.
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How to drag a cell to another location in the Xsheet view

 1. In the Xsheet view, select one or more cells.

 2. In the Xsheet view, position the pointer over the small dotted area  on the left side of the selected cells.

 3. Drag the selection to any other cell in the same column or in another column.

 4. Do one of the following:

‣ Drop the selection to overwrite the existing cells.
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 l Hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) while dropping the selection to copy the 
cells. The original selection will not be moved.

 l Press Shift while dropping the selection to insert it between existing frames.
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Increasing Exposures
Increasing the exposure Adds one more exposure to a selected cell; repeating this action adds an extra cell each 
time. This is an efficient way to extend a drawing's exposure and is always set in Insert mode. Increasing an 
exposure pushes the existing exposure forward. 

How to increase exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Increase Exposure. 

 l In the Xsheet  toolbar, click the Increase Exposure  button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

 l Right-click and select Exposure > Increase Exposure.

 l Press +.
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Decreasing Exposures
Decreasing the exposure removes one exposure from a selected cell and pulls any cells following it to the beginning 
of selection. You can do this for one cell or a range.

How to decrease a single exposure

 1. In the Timeline or Xsheet view, select a cell.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Decrease Exposure. 

 l In the Xsheet toolbar, click the Decrease Exposure  button.

‣ At the bottom-right corner of the Xsheet view, set the number of cells over which the drawing will be 
exposed. 

 l Right-click and select Exposure > Decrease Exposure. 

 l Press -.

How to decrease a range of exposures

 1. In the Timeline or Xsheet view,  select a range of cells.

247



Chapter 6: Timing     Increasing Exposures

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure and Pull. 

 l Right-click and select Exposure > Clear Exposure and Pull.

 l In the Xsheet toolbar, click the Clear Exposure and Pull  button.

The exposure is reduced by the selected number of cells.
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Deleting Exposures
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the Timeline or 
Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by typing its name again in a 
cell.

You can delete the exposure in a selected cell range  or delete the entire exposure of a drawing exposed over several 
cells. Note that you can also delete the exposure for drawings inside a collapsed group.

How to delete selected exposures

 1. In the Timeline or Xsheet view, select the exposure you want to delete.

 2. Do one of the following:

 l Right-click and select Delete.

 l Press Delete.

How to clear the entire exposure of a drawing

 1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.

 2. Do one of the following: 

 l From the top menu, select Animation > Cell > Clear Exposure.

 l In the Timeline view, right-click and select Exposure > Clear Exposure.
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Inserting Blank Cells
You can place an empty cell between other cells.  If you are set to Overwrite mode, the mode momentarily 
changes to Insert mode, in order to push down the existing exposures,

How to insert a blank cell

 1. In the Timeline or Xsheet view, select the cell in which you want to insert a blank cell.

 2. Do one of the following:

 l In the top menu, select Animation > Cell > Insert Blank Cell. 

 l Right-click and select Exposure > Insert Blank Cell.

 l In the Timeline or Xsheet toolbar, click the Insert Blank Cell  button (you may have to cus-
tomize the toolbar to display it).

 l Press Shift + J.

A blank cell is inserted.
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Setting the Exposure
T-HFND-006-009

You can easily increase or decrease the exposure for a selected cell range.

How to set the exposure

 1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.

 2. Do one of the following:

 l Select Animation > Cell > Set Exposure to > Set Exposure to 1, 2, 3, or Set Exposure.

 l In the Timeline toolbar, click one of the Set Exposure  buttons (you may have to 
customize the toolbar to display them).

 l In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 
2, or 3, or Set Exposure.

 3. If you chose the Set Exposure option, the Set Exposure dialog box opens. Enter the number of frames you 
want the drawings to display and click OK.

The new timing is displayed in the Xsheet view.
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Filling Selections with Single Exposures
You can Lets you fill the same value over an entire selection. The selection can be over one cell, a cell range in one 
column, a cell range over many columns, an entire column, or many columns. You can use numbers, words, letters, 
or any alphanumeric value.

How to fill a selection with a single exposure

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following: 

‣ From the top menu, select Animation > Cell > Fill Selection. 

‣ Press Ctrl + T (Windows/Linux) or ⌘  + T (Mac OS X)).

The Fill Selection dialog box opens.

 3. In the Value field, type the desired value.

 4. To insert a key exposure in the frame following the last cell in the selection, select the Add Key Exposure 
After option. Otherwise, leave it deselected.

 5. Click OK.
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Filling Selections with Sequences
You can Lets you create a numbered sequence over a selection. The sequence can be forward, backward, single, 
double or higher increment, as a cycle, and so on. The selection can be over one cell or a cell range in one column 
or more or an entire column or many entire columns.

How to fill a selection with a sequence

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l From the top menu, select Animation > Cell > Sequence Fill. 

 l In the Timeline view, right-click and select Exposure > Sequence Fill.

 l Press Ctrl + M (Windows/Linux) or ⌘  + M (Mac OS X)).

The Sequence Fill dialog box opens.

 3. In the Starting Value field, type the first number in the sequence.

 4. In the Increment field, type the number by which the drawing number will increase from frame to frame. For 
example, an increment of 1 gives you: 1-2-3-4; an increment of 2 gives you: 1-3-5-7; and -2 gives you 
this: 8-6-4-2.
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Filling Selections Randomly
You can Lets you fill in random values over a selection. You can give a maximum and a minimum value and create a 
range for Harmony to choose the random values from. The selection can be over one cell or a cell range in one 
column or more or an entire column or many entire columns.

How to fill cells randomly

 1. In the Timeline or Xsheet view, select a cell range.

 2. In the Xsheet view, click the Fill Cells Randomly  button  (you may have to customize the toolbar to dis-
play it).

The Fill Cells Randomly dialog box opens.

 3. In the Minimum Value field, enter the lowest acceptable value.

 4. In the Maximum Value field, enter the highest acceptable value.

 5. In the Hold field, choose an exposure holding value.

 6. If you are applying this option to a drawing column, select the Whole Numbers option to avoid decimal 
points.

 7. Click OK.
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Filling Empty Cells
You can Lets you fill empty cells to extend the exposure of single frame drawings to fill the range of empty cells after 
each one.When creating drawings on  cells that are not side-by-side, the exposure of the first drawing no longer fills 
automatically. You must select the frame range where you want your drawings to hold their exposure up to the next 
drawing and use the Fill Empty Cells command.

How to fill empty cells

 1. In the Timeline or Xsheet view, select a cell range.

 2. Do one of the following:

 l Right-click and select Exposure > Fill Empty Cells.

 l From the top menu, select Animation > Cell > Fill Empty Cells.

 l In the Timeline toolbar, click the Fill Empty Cells  button.

Each drawing in the selection is exposed in the range of empty cells that follow it.
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About Cycles
T-HFND-006-008

Once you have entered a series of drawings and exposures, you can create cycles out of them in several ways.

You can loop drawings using the following command:

• Create Cycle

When you create a drawing cycle, all the repeated drawings are linked to the same original files. When modify, 
repaint, or correct a drawing named “1” for example, all drawings named “1” are updated simultaneously. In order 
to modify a drawing independently from its other exposures, you must duplicate the drawing.
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Creating Cycles
You can create cycles for animated sequences that need repeating, such as a character walking.

How to  create a cycle

 1. In the Timeline or Xsheet view, select the cell range to loop.

 2. In the Timeline toolbar, click the Create Cycle  button (you may have to customize the toolbar to display 
it).

The Create Cycle dialog box opens.

 3. Enter the number of cycles you want, including the current selection.
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About Key Exposures
Before working with key exposures, it's important to understand how keyframes, exposure and key exposure 
work in Harmony:

 l Keyframe: A keyframe is a point in time where a change to the properties of the object or character 
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its con-
tents are moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

 l Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. 
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Key-
frames can be moved independently from the drawing exposure. 

 l Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed 
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for 
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony auto-
matically sets a key exposure when you perform a drawing swap.
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Adding Key Exposures
Key exposures are mainly used for swapping drawings in cut-out animation where you will have numerous drawings 
for the various positions of the mouth or eyes of a character for example. 

If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This prevents 
it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of an exposure 
that forces it to be exposed on a certain frame regardless of whether the previous exposure is the same drawing or 
not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be auto-
matically updated even if set as a key exposure.  This keeps your existing animation key poses intact. It is fre-
quently used on a mouth or eyes layer. 

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure. 

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is 
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key 
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for 
drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline toolbar, click the Add Key Exposure  button.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same 
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing 
is split in two and both parts contain the same drawing. 
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure is 
replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When the 
key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.
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Removing Duplicate Key Exposures
When working with drawings to adjust the timing of a mouth in a lipsync, for example, and forcing the use of 
specific key exposures, unnecessary key exposures will be created. You can delete these duplicates without 
affecting the rest of the drawing. The first drawing of the selection will be used for the range.

NOTE: Duplicate key exposures may occur when pasting with the Enforce Key Exposure option selected.

How to remove duplicate key exposures

 1. In the Timeline view, select the layer that contains duplicate key exposures. 

 2. In the Timeline toolbar, click the Remove Duplicate Key Exposure  button (you may have to customize 
the toolbar to display it).
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About Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files stored in the 
project’s folder. If you want to rename a drawing or delete a drawing from your project, you need to edit the file and 
not the cells.
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Renaming Drawings
T-HFND-005-003

To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

You can also rename a series of drawings relative to their frame position, which is useful in hand-drawn 
animation.

How to rename a drawing

 1. In the Timeline or Xsheet view, select the drawing to rename.

 2. Do one of the following:

 l Right-click and select Drawings > Rename Drawing.

 l In the Timeline toolbar, click the Rename Drawing  button (you may have to customize 
the toolbar to display it).

 l Press Ctrl + D (Windows/Linux) or ⌘  + D (Mac OS X).

The Rename Drawing dialog box opens.

 3. In the New Name field, type in the new drawing name.
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Deleting Drawings
You can permanently delete a drawing file from a project's folder.

NOTE: Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing

 1. In the Timeline or Xsheet view, select the drawings to delete.

 2. Do one of the following:

‣ From the top menu, select Drawing > Delete Selected Drawings.

‣ Right-click and select Drawings > Delete Selected Drawings.
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Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can duplicate the 
drawing and work on the copy. When duplicating a drawing, the selected cell is replaced with the new drawing. 
The exposure of the original drawing that was on the current cell is removed. The original drawing is not deleted 
from the project folder or other cells in which it is exposed.

With Toon Boom Harmony, you can create a keyframe at the same time as you duplicate your drawing. This way, 
you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing

 1. In the Timeline or Xsheet view, select the drawing to duplicate.

 2. Do one of the following:

‣ From the top menu, select Drawing > Duplicate Drawings.

‣ Right-click  and select Drawings > Duplicate Drawings.

‣ In the Xsheet toolbar, click the Duplicate Drawing  button.

‣ Press Alt + Shift + D.
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Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting the actual 
drawings, you are pasting the exposure. Exposure is a property; it is the length of time that a drawing is visible over a 
series of frames. In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. 
Keyframes can be moved independently from the drawing exposure. 

If you want to copy and paste selected drawings into a different layer or paste the selection in the same layer to 
duplicate the drawings, you must use the Paste Special feature.

There are four different ways to paste your selected drawings with the Paste Special dialog box:

When adding exposures to a drawing layer, drawing files will not be created.

Only create drawing files when they do not exist: When adding exposures to a drawing layer, new 
drawings will be created only when drawings with the same name do not already exist in the 
destination.

Replace existing drawings. Create drawing files when they do not exist: Replace drawings with 
the same names to update a scene with new modified drawings and preserve the animation.

Tip: If you don't want to lose the existing animation when pasting a template,  such as 
when placing new drawings after the animation, then delete the template's animation.  It 
will still have updated the drawings but not override the existing animation.

Always create drawing files: When adding exposures to a drawing layer, new drawings will always 
be created. If drawing files with the same name already exist, Harmony will create a new name for the 
drawing.

If you want to perform another Paste Special operation using the same settings you used previously, you can use 
the Paste Special Again command instead. You can paste your selection using the same settings as in the most 
recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command

 1. In the Timeline or Xsheet view, select the drawings to copy and press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X). 

 2. In the Timeline or Xsheet view, select the cell where you want your pasted selection to start.
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 3. Do one of the following:

 l Right-click and select Paste Special.

 l From the top menu, select Edit > Paste Special.

 l In the Xsheet  or Timeline toolbar, click the Paste Special  button (you may need to cus-
tomize the toolbar to display it).

 l Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X). 

The Paste Special dialog box opens.

 4. In the Drawings section, select the Always Create Drawings or Only Create Drawings When They Do 
Not Exist option.

How to paste new drawings with the previous Paste Special settings

 1. Do one of the following:

 l From the top menu, select Edit > Paste Special Again.

270



Harmony 14 Essentials - User Guide

 l Right-click and select Paste Special Again

 l In the Timeline or Xsheet  toolbar, click the Paste Special Again  button (you may have to 
customize the toolbar to display it).

 l Press Ctrl + Shift  + B (Windows/Linux) or ⌘  + Shift + B (Mac OS X).
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Chapter 7: Colours
Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some other 
software only allow users to work with on colour swatch at a time, painting in Harmony is done by using palettes 
containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can 
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones. 
This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using 
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and 
atmosphere of the scene without tediously repainting each element.
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About Colour Swatches
T-HFND-006-017

You can use several different types of colour swatches, including solid colour, gradient colour and bitmap texture 
swatches.

A colour palette is an actual file on the hard drive. 
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Adding a Colour Swatch 
T-HFND-006-017A

You can add as many colour swatches as you want in your palette. 

How to add a solid colour swatch

 1. In the Colour view, click the Add Colour  button.

 2. From the Colour view menu, select Colours > Edit or double-click on the colour swatch.

The Colour Picker window opens. 

 3. To set your colour, do one of the following:

 l In the colour wheel, select a colour.

 l Enter the HSV or RGB values in the corresponding fields.

 l Select the R,G,B,H,S or V options to change the look of the colour picking area.

 l Click the Dropper  button to select any colour on your screen. It can be from the Harmony 
interface, your operating system or any other open application. 
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 4. Click on the Shade Scale swatches to modify the shade of the selected colour. 

 5. Adjust the transparency with the Alpha slider or type the value directly in the Alpha field.

 6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can quickly 
access it later.

 7. Rename the colour swatch in the Colour Picker window or directly in the colour list by double-clicking on its 
name.
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Deleting a Colour Swatch
T-ANIMPA-003-007

You can delete unnecessary colour swatches from your palette. If painted zones are using this colour, they will be 
displayed in red and the system will try to recover them the next time you load the scene. 

How to delete a colour swatch

 1. In the Colour view, select the colour swatches to delete.

 2. Do one of the following:

 l From the Colour View menu, select Colours > Delete.

 l Click the Delete Colour  button. 

 l Right-click and select Delete.

 l Press Delete.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

 3. Click OK to delete the colours or click Cancel to abort the operation.

If you delete colour swatches already in use, the zones painted with them turn red so you can easily 
identify them.
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Adding a Gradient Colour Swatch 
T-HFND-006-017B

You can transform any colour swatch into a linear or radial gradient. 

How to create a gradient colour swatch

 1. In the Colour view, select a colour to modify .

 2. Do one of the following:

 l Click the new colour and from the Colour View  menu, select Colours > New. 

 l Double-click on the colour swatch.

The Colour Picker window opens.

 3. Select the Gradient option.

 4. Select the Linear or Radial option.

 5. Adjust the Gradient arrows to modify the colours.
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 l Add extra colours by clicking between the arrows below the gradient bar. Then click on the 
Colour Preview to select a colour.

 l Pull down the arrows to remove them.

 l Move the arrows left and right to modify the gradient distance.

NOTE: To learn how to reposition the gradient zones in your drawings, see About the Edit 
Gradient and Texture Tool on page 316.
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Adding a Texture Colour Swatch 
T-HFND-006-017C

You can add bitmap texture colour swatches to your palette. 

How to create a texture colour

 1. From the Colour  menu, select Colours > New Texture or click the New Texture  button.

The Browser window opens.

 2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.

The texture is added to the colour list.

NOTE: 
To learn how to reposition the textured zones in your drawings, see About the Edit Gradient and 
Texture Tool on page 316.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool instead of 
plaid, just update the texture file in the swatch and the entire project updates. Any transformation previously 
applied to the texture’s position in your drawings will be kept.
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Modifying a Texture Colour Swatch
You can replace a texture colour swatch and all zones already painted with it will update.

How to replace a texture swatch

 1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

 2. From the Colour View  menu, select Colours > Edit Texture or double-click on the swatch.

The Browser window opens.

 3. Browse for the new PSD or TGA bitmap file created in a third party software.

 4. Click Open to update the colour swatch.
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Mixing Colours
If you want to modify a series of colours to blend a tint in them or offset their RGBA values, you can use the Tint 
panel. You can also create palette styles, such as night and day styles.

How to mix colours

 1. In the Colour view, select the palette that contains the colours you want to offset or blend.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Tint Panel. 

 l Right-click and select Tint Panel.

The Tint Blend/Offset panel opens.

 3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 4. Select Preview option.
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 5. Select the Offset, Blend, or Mixer option.

Parameter Description

Offset

Offsets the selected colours by the adjustments made using the 
HSB and RGB sliders. Use the Amount slider to adjust the 
degree of offset. Use the Alpha slider to adjust the opacity of the 
selected colour. 

Blend

Blends the selected colours with the colour swatch in the top-
right corner. Use the Amount slider to adjust the degree of blend. 
A blend of 100% turns the selected colours into the same colour 
as the swatch. Adjusting the HSB and RGB sliders affect the 
swatch colour, which in turn affects the selected colours on the 
left. Use the Alpha slider to adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch. Use 
the slider just beneath to mix the Base and Tint colours by dif-
ferent amounts. This will affect the mixed swatch whether it is 
selected or not. Select either the Tint or Base swatch and use 
the HSB and RGB sliders to adjust its colour. This will affect the 
mixed swatch colour, which in turn affects the selected colours 
on the left.

 6. Click Apply.
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Copying and Pasting Colours 
When you're creating palettes, you may want to copy colour swatches or their values and paste them in other 
palettes to save time. You can also quickly copy a colour value from a palette in your scene to a selected colour 
swatch in a different palette.

You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch, it is 
impossible to use the Paste as Clone command in the same palette as you copied the original colour swatch from.

If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can copy the 
colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours

 1. In the Colour view, select one or more colours to copy.

 2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS X).

 3. In the Palette list, select the palette in which you want to paste the colours.

 4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V (Windows/Linux) or 
⌘  + V (Mac OS X).

 l To paste the colour values of the copied swatch over an existing colour swatch, select Col-
ours > Paste Colour Values.

How to clone a colour swatch

 1. In the Colour view, select the colour swatch you want to clone.

 2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘  + C (Mac OS 
X).

285



Chapter 7: Colours     About Colour Swatches

 3. In the Colour view, select the colour palette you want to paste the clone into or create a new palette.

 4. From the Colour View menu, select Colours > Paste as Clone.

The cloned colour swatch appears in the palette.

How to copy a colour ID

 1. In the Colour view, select the colour swatch you want toget the ID from.

 2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux) or ⌘  + 
C (Mac OS X).

 3. Paste the copied value as plain text in the desired document.
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Changing the Colour Display Mode 
The Colour view has two display modes:

 l List

 l Swatch

You can also display the RGB values and names of your solid colour swatches instead of only the name. This option 
is not available when displaying the colours in Swatch mode.

How to switch between the display modes

 1. From the Colour View menu, and do one of the following: 

 l Select Colours > Swatch Mode to display the swatches.

 l Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values

 l From the Colour View menu, select Palettes > Display Colour Values.   

The solid colour swatches’ RGB values are displayed between the colour swatch and its name. The gradient 
colour swatches will be identified as (gradient). 
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About Palettes
T-ANIMPA-003-001

In animation, specific colours are used to paint each part of each character. In order to maintain absolute 
consistency, a colour palette is created for each character, prop and effect throughout the production. This is 
referred to as a master palette.

Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of 
red, green, blue and opacity, the latter which is referred to as alpha.

Using a master colour palette has many benefits, including:

 l Each character consistently retains their dedicated colours.

 l You cannot accidentally use a colour which is not in the master palette.

 l Standardization and colour consistency throughout the production

 l Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and 
consistency in the painting process. 

A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette 
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue, 
shirt, pants, and so on.

In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a  *.plt file name 
extension. 

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch 
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted 
zones. This way, you can change the look of your character at any time without having to repaint it! 

Another advantage of this system is that you can create complete palettes for different lighting situations. For 
instance, in addition to the regular palette for a character, you could have one for that character in the rain using 
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. 
Using palettes linked to your character in this way allows you to instantly change its colouring to suit the mood 
and atmosphere of the scene without tediously repainting each element.
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In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is created 
from Harmony, it needs to be stored somewhere. By default, the palette file is stored in the scene directory in a 
palette-library folder unless you specify a different location.

There are four locations where you can find palette-library folders:

 l Element: The Palette Library folder is stored directly in the drawing Element folder.

 l Scene: The Palette Library folder is stored directly in the Scene folder.

 l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

 l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is recommended 
to keep it as is. If you work with a larger studio, it is recommended to verify with them on the file structure.
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This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure starting 
from the Environment down to the Element. Its client-server configuration allows all data, such as palettes and 
scenes, to be shared between a series of client machines.

Element Level 
Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes. 
When a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette file 
with the colour model, the colourist can load them both from the same location. This also creates a more 
organized structure.

Scene Level 
Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the palettes 
from the scene are stored together. The palette naming must be structured so the colourist or character builders 
can find the correct one. Saving the palettes at the scene level makes it very easy to back up the palettes and 
retrieve their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes 
all of the characters, props, effects, and location, the colour palette or model will often be directly imported to, or 
created in, the character building scene. Just as with a cut-out character building scene, each element uses the 
same palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene 
level. This prevents a palette overload because all of the models are in different scenes. It also allows each scene 
to have its own set of palettes corresponding to its model.

When working on a cut-out animation production, it is highly recommended that you work with the Scene level.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though the 
palettes are locked by default. That is why it is a good idea to copy and back up your palette libraries and master 
palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble replacing 
an altered file. Harmony automatically updates all of the files and drawings linked to it.
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About the Palette List
T-ANIMPA-003-006

The Colour view has two modes: basic and advanced.

 l Basic Mode

The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony, you only 
see the colours available in the Default palette which contains six basic colour swatches and is automatically 
named the same as your scene. For simple projects, you can manage with the default palette, but for movies, 
series, or shorts it is recommended that you create palettes for your characters. To create a palette, you have 
to switch to the Advanced mode of the Colour view and show the Palette list.

 l Advanced Mode

The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes for your 
characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a palette list. The 
scene also has a palette list.  For example, a drawing layer can use three different palettes stored in three different 
locations, while another drawing layer can use two of these palettes plus another one coming from another scene. 
The palette list keep track of the locations of the palettes.

There are two types of palette lists:

 l Scene Palette List 
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The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless and 
traditional animations. A cut-out character will often be divided into 20 to 30 different drawing elements that 
use the character’s master palette.

The palette list is stored at the scene level instead of the Element directory. This way, all palettes linked to 
this list will appear in every drawing element created in the scene. There is no need to manually load the 
palette in each element.

The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only 
Scene Palette lists.

 l Element Palette List
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In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your palette at 
an element’s level. The Element Palette list is mainly used with traditional and paperless animation. Unlike 
cut-out animation, all columns (drawing elements) contain different characters, props, backgrounds, and 
effects. The Element Palette list is used when you do not necessarily want all of the palettes for all of your 
elements linked in every column. 

The palette list is stored in the drawing element’s directory instead of directly in the Scene level. This ensures 
that the links to the palettes appear only in the appropriate element. If you prefer to access a global palette 
list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom Harmony uses 
the palette located highest in the list to determine the colour of the painted zones—see Cloning a Colour Palette  on 
page 302.

How to reorder palettes in the Palette list

Do one of the following:

‣ From the Colour View menu, select Palettes > Move Up or Move Down. 

‣ In the Palette list, click the Up  and Down  buttons.
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Showing and Hiding the Palette List
You can show or hide the palette list in the Colour view. 

How to show or hide the Palette list

 l In the Colour view, click the Show/Hide Palette List View  button to expand or collapse the Palette List 
area.

The Palette List window opens and displays all your palettes.
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Enabling the Advanced Palette Mode 
You can set up the Advanced Palette Lists option in the Preferences panel. This allows you to see the Element and 
Scene palette lists.

How to set the Advanced Palette Lists mode

 1. Do one of the following:

 l From the top menu, select Edit > Preferences (Windows/Linux) or Harmony Essentials > 
Preferences (Mac OS X).

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. Select the Advanced tab.

 3. In the  section, select  the Advanced Palette Lists option.

 4. Click OK.
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Creating a Colour Palette
T-ANIMPA-003-002 

You can create a palette in either Basic or Advanced mode.

By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended to use the 
Basic mode.  This setting stores the palettes automatically for you and saves them at the Scene level. When you 
use the Advanced Palette Lists mode, you can decide at which level you want to store your palettes: 
Environment, Job, Scene, or Element.

How to create a new palette (Basic Palette Lists mode)

 1. From the Colour view menu, select Palettes > New or click the New Palette button.

The Create Palette dialog box opens.

 2. Enter the palette name according to the model. 

 3. Click OK.

The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode

 1. In the Timeline or Xsheet view, select the drawing that requires a palette. 

 2. Make sure that you have the necessary rights to modify the palette list. If you do not, select  Edit > Edit 
Palette List Mode.

 3. In the Colour view, click the Show Palette List View  button to display the palette list. 

 4. Do one of the following:

 l From the Colour view menu, select Palettes > New. Before you can create a palette in the 
Advanced Palette Lists mode, you must first set your preferences to Advanced Palette Lists 
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mode in the Preferences dialog box—see Enabling the Advanced Palette Mode  on page 295.

 l Click the Create Palette  button. 

The Palette Browser: Create Palette dialog box opens. 

 5. Select the level to store the palette file. 

 l Environment: The palette-library folder is stored in the scene's parent environment folder.

 l Job: The  palette-library folder is stored in the scene's parent job folder. 

 l Scene: The  palette-library folder is stored directly in the scene folder. 

 l Element: The  palette-library folder is stored directly in the drawing element folder. 

When you select a level that has a palette stored in it, the palette names are displayed in the Palette field.

 6. Name the palette. There is no need to add the suffix "palette" to the as it is always recognized as a palette 
file.

 

 7. Select a Palette List option.

 

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often be divided 
in twenty to thirty different drawing elements that use the character's master palette. 

297



Chapter 7: Colours     About Palettes

The palette list is stored at the scene level instead of the Element directory. This way, all palettes 
linked to this list will appear in every drawing element created in the scene. There is no need to 
manually load the palette in each element. 

The Element Palette List is mainly used with traditional and paperless animation. Unlike cut-out 
animation, all columns (drawing elements) contain different characters, props, backgrounds and 
effects. The Element Palette List is used because you do not necessarily want all of the palettes for 
all of your elements linked in every column. 

The palette list is stored in the drawing element's directory instead of directly in the Scene level. 
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to 
access a global palette list, link your palettes to the Scene Palette List.

 8. Click OK. 

The new palette appears in the palette list.
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Renaming a Colour Palette
T-ANIMPA-003-003

You can rename a colour palette to keep your list organized. 

How to rename a palette

 1. In the Colour view, select the palette to rename.

 2. Do one of the following:

 l Right-click and select Rename.

 l From the Colour View menu, select Palettes > Rename.

 3. In the Rename dialog box, give the palette a new name and click OK.
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Removing a Colour Palette
You can remove palettes from your Palette list if they're not needed in your scene. The actual palette file will not 
be deleted and you can reimport it in your Palette list later on.

How to remove a palette

 1. In the Colour view, select the palette to remove.

 2. Do one of the following:

 l From the Colour View menu, select Palettes > Remove. 

 l Right-click on the selected palette and select Remove.

 l Click the Remove Palette button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette 
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but has a 
different ID and is independent from the original palette. This ensures that both palettes are completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all the colours. You 
can change the values and the names afterward without affecting the original palette. You can also keep some 
RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette 

 1. In the Colour view, select the palette to be duplicated.

 2. Do one of the following:

 l From the Colour menu, select Palettes > Duplicate. 

 l Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.

 3. If you are in Advanced Palette List mode, select the palette storage level—see About Palettes on page 288.

 4. In the New Palette Name field, name the palette.

 5. In the New Palette Name field, name the palette.

 6. Click OK.

The palette appears in the palette list.
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Cloning a Colour Palette 
A character usually has only one master palette, although there are times when the characters are placed in 
different lighting conditions and require a different colour shading. The night palette is a popular choice when a 
scene or sequence changes from day to night. It can be difficult and time-consuming to repaint everything and 
creating two independent palettes can be quite complex. As an alternative, Toon Boom Harmony provides clone 
palettes.

The clone palette is a copy of the master palette. The colours in each palette have the same properties. The 
colours have the same identification number pointing to the same colour zones, but they can have different 
names and RGBA values. Depending on the palette (night or day) you're currently using, the painted drawing will 
update. So there's no need to repaint the animation. All you have to do is create or import a clone palette (palette 
style).

How to clone a palette

 1. In the Colour view, select a palette to clone.

 2. From the Colour  menu, select Palettes > Clone or right-click and select Clone.

The Palette Browser: Clone Palette dialog box opens.

302



Harmony 14 Essentials - User Guide

 

 3. If you're in Advanced Palette List mode, select the palette storage level—see About Palettes on page 288.

 4. In the New Palette Name field, name the palette. We recommend keeping the "-clone" in the name.

 5. Click OK.

The cloned palette appears in the palette list.

 6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing Colours on page 
283.

 7. From the Colour View  menu, select Palettes > Tint Panel or right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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 8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A (Win-
dows/Linux) or ⌘  + A (Mac OS X).

 9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

 10. Select the Preview option to see a preview of the colours while you adjust them.

NOTE: You can also modify the colours individually with the Colour Picker window.
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Importing a Colour Palette
T-ANIMPA-003-005

You can import an existing colour palette in your project. 

How to import a palette into your project

 1. Do one of the following:

 l From the Colour menu, select Palettes > Import. 

 l Right-click and select Import.

The Browser window opens.

 2. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in your pro-
ject's palette-library directory.

 3. Click Open.

The Palette Browser opens. 

 4. If you're in Advanced Palette mode, select the level where the palette file is stored—see About Palettes on 
page 288.

 5. If you're in Advanced Palette mode, select the palette list linking level by enabling either Scene Palette List 
or Element Palette List—see About Palettes on page 288.

 6. In the New Palette Name, name the imported palette.

The palette appears in the Colour view and the file is copied in your project.
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About Painting
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vector-based, the 
colour zones are completely filled and there are no scattered spots left blank. Also, there are some actions that 
can be applied on an entire animation sequence at once, like dirt removal, some colour filling, line repainting, and 
so on.

When traditional animation is traced, cleaned up, scanned in and properly exposed, it's time for the ink and paint 
process. This consists of cleaning all dirt and hair (for example, dust that was in the scanner, dots that do not 
belong in the drawing, extra floating artwork around the drawing that must be removed), painting the lines and 
filling the colours in the empty zones on an entire animation sequence.

For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt to clean, 
only painting and inking. 

Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by assigning a 
set of colours to each character, prop or effect. The colour styling artist will create a new palette and add a new 
colour for each zone of the character, such as the skin, hair, tongue, shirt, pants, and so on. Each colour is known 
as a colour swatch—see About Palettes on page 288. 
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Copying Colour Models
You can copy pieces or the entire colour model to paste in your scene, 

How to copy the entire model from the Model view

 1. In the Model View toolbar, select the Select  tool.

 2. In the Model view, select your model.

 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Select the Drawing or Camera view, then go to the top menu and select Edit > Paste Drawing Object, or 
select the Timeline view and from the top menu, select Edit > Paste cells in the Timeline or pressCtrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.

How to copy part of the model from the Model view

 1. In the Model View toolbar, select the Cutter  tool or press Alt + T.

 2. In the Model view, use the Cutter tool to create a selection around the part of your model that you want to 
copy.
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 3. From the top menu, select Edit > Copy Drawing Object or pressCtrl + C (Windows/Linux) or ⌘  + C (Mac 
OS X).

 4. In the Timeline view, make sure you have the correct layer and frame selected.

 5. Do one of the following:

 l Select the Drawing or Camera view and select Edit > Paste Drawing Object. 

 l Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V 
(Windows/Linux) or ⌘  + V (Mac OS X). 

The model appears in the selected view.
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Painting Drawings
T-HFND-004-011

The main tool you will use to paint your drawings with is the Paint  tool. The Paint tool can be used in several different 
modes, which can be customized in the Tool Properties view.

The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the lines defining a 
zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic Close Gap option.

NOTE: To learn more about the Paint tool options, see the Reference guide .

How to paint drawings

 1. In the Timeline or Xsheet view, select the cell on which you want to paint.

 2. Do one of the following:

 l In the Tools toolbar, click the Paint  tool.

 l Press Alt + I. 

In the Tool Properties view or Tools toolbar, you can select additional painting modes. 

 l The Paint   mode paints everything it touches, including empty and filled zones.

 

 l The Paint Unpainted  mode paints only empty zones. Any line or filled zone will remain 
unchanged.
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 l The Unpaint   mode unpaints everything it touches, including empty and filled zones.

 3. In the Colour view, select a colour.

 4. In the  Drawing or Camera view, start painting. Click on a zone or pencil line to paint it, or trace a lasso or 
marquee selection to paint several zones or pencil lines at the same time.

NOTE: The last colour you select while using the Paint tool will be used the next time you 
select the Paint tool if you're using the unlocked painting tools in the Colour view.

Authors
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Repainting
You can use the Paint tool to click on the zones to repaint. If you click in an empty zone, it will fill the area.  

The Brush tool can be used to repaint specific segments. The Brush tool's Repaint Brush mode is used to paint a 
section by manually painting over the lines. This is useful when the vectorization triangles are not placed as you 
would like or you simply need to repaint a section of a segment. It is also useful for paperless animation, where 
there are no triangles. So, the Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only 
show on painted areas that are already painted. 

Unlike the Brush tool's regular mode, the Repaint Brush mode flattens automatically. The brush strokes are not 
added one on top of each other. 

How to enable the Repaint Brush mode

 1. In the Tools toolbar, select the Brush  tool.

 2. In the Tool Properties view, click the Repaint Brush  button. 

 3. In the Camera or Drawing view, draw on the zones to repaint.

312



Harmony 14 Essentials - User Guide

Selecting Strokes with the Current Colour
You can select zones painted with a specific colour swatch.

How to select the zones painted with the current colour

 1. In the Colour view, select the colour from which you want to select the corresponding zones.

 2. Do one of the following:

 l Select Drawing > Select Strokes With Current Colour. 

 l Press Ctrl + Shift + A (Windows/Linux) or ⌘  + Shift + A (Mac OS X).
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Closing Gaps
T-HFND-004-014

When painting, you may notice that some drawing areas are not closed. To close the zone, you can draw the 
missing line with the Brush or Pencil tool, or close the gap with an invisible line using the Close Gap tool.

The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between the two 
closest points to close the colour zone. You do not need to trace directly over the gap. You can draw it a few 
millimeters away. The two closest points automatically close the gap.

How to close gaps

 1. Select View > Show > Show Strokes or press K to see a preview of the result.

 2. In the Tools toolbar, select the Close Gaps  tool.

 3. In the Camera or Drawing view, trace a line near the gap to be closed. Your strokes will be invisible. 

 4. Enable the Auto-Flatten  option in the Tool Properties view if you want your strokes to be flattened with 
your artwork. They will cut overlapping drawing strokes in two pieces.

The gap automatically closes.

Authors

Marie-Eve Chartrand

Christopher Diaz

chrisdiazart.com

314

http://www.chrisdiazart.com/


Harmony 14 Essentials - User Guide

Picking a Colour with the Dropper Tool
While working in the Camera or Drawing view, you can use the Dropper  tool to pick a colour from your drawing 
without going to the Colour view. 

How to use the Dropper tool

 1. Do one of the following:

 l In the Tools toolbar, select the Dropper  tool.

 l From the top menu, select Drawing > Drawing Tools > Dropper.

 l Press Alt + D. 

 2. In the Camera or Drawing view, click on the desired colour.

 l If you're using another drawing tool such as the Paint tool, you can temporarily hold down the D 
key and click in your drawing before releasing the key to pick your colour. When you release 
the key,  you will return to your previous tool. You may also want to select the zones painted 
with the colour currently selected in the Colour view. This can be useful for removing rough 
lines from a clean drawing.
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About the Edit Gradient and Texture Tool
T-HFND-006-019

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to modify its 
position in the zone. You can move, scale, rotate and skew. If you want to match the colour to the animation, set 
the first texture position and copy the Edit Gradient/Texture position. When moving to the next drawing, you can 
select the next texture and paste the previous position to continue the modifications.

If you are painting a hand-drawn animation or if you want the Brush and Paint tool to use your gradient’s position, 
angle and scale settings instead of the default ones, you can store your own settings and reuse them afterward.

This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn with textured 
“brushes”. If you then paint your textured pencil line with a gradient, you can do so and then edit both elements 
independently at the same time.
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Using the Edit Gradient and Texture Tool 
T-HFND-006-019A

You can use the Edit Gradient/Texture tool to reposition a texture or gradient within a painted zone. 

How to use Edit Gradient/Texture tool

 1. Do one of the following: 

 l In the Tools toolbar, click the Edit Texture  tool.

 l Press Shift + F3.

 2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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 3. Edit the gradient or texture by adjusting the control handles around the selection frame.
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Chapter 8: Rigging
Harmony is a great tool for building characters. You can use different techniques and features to break down your 
puppets.

This chapter will guide you through all the steps to create a complete simple rig. Harmony allows you to create very 
advanced puppets using deformations, hierarchies and z ordering. As you practice and get familiar with those 
concepts, you will be able to develop more complex rigs and combine various advanced features.

For more great options and features to create powerful rigs, refer to Deformation on page 371.
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Chapter 8: About Rig Types
T-RIG-001-001

A rig is the process in which you will take apart the multiple pieces of your character and then reattach them 
together to get them to move individually. Harmony provides you with a multitude of tools to help you build 
characters. From the simplest of rigs, to a fully rotating character. There are about as many ways to rig a 
character as there are individuals who make them. The complexity of the rig is often determined by the level of 
animation to be achieved.
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About Simple Rigs
T-RIG-001-002

Simple rigging is very fast and easy to do. It is built as follows:

 l All the body parts are independent

 l All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being influenced by a 
parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B along a straight 
trajectory. The hand will not follow the arm's rotation. You will have to set more keyframes for the hand to move 
along a curved path.

321



Chapter 8: About Rig Types     

About Drawing Hierarchy Rigs
T-RIG-001-003

When you want one part to follow another part, such as the forearm following the arm, you can attach the layers 
one to the other. For example, you can attach the forearm layer to the arm layer without having to encapsulate the 
forearm into the arm layer. They will still be parented, but you can access the forearm directly without having to 
enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without having to select 
them or create a series of keyframes.

The disadvantage of parenting layers is that you are not able to move the parent independently of its children, 
since the child layers receive all the transformation information from their parent.
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Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from them is often a 
good solution.

NOTE: 
To attach one layer to another, you must drag the desired layer onto the other one in the Timeline view.

Harmony offers powerful techniques to create hierarchies between your layers without having to encapsulate 
layers into each other. These techniques are a great improvement over the less efficient and time consuming 
method of creating parenting between your layers by inserting symbols into other symbols. Therefore, rigging 
with symbols inside symbols is NOT recommended.
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About Peg Hierarchy Rigs
T-RIG-001-004

Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory layers that do 
not contain drawings. They are motion paths that you can use to control your entire puppet or advanced 
hierarchies.

Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You can scale a 
body part up the chain of pegs directly on the drawing layer. This way, you do not affect any child layers that could 
be attached to that part. 

Then, you can perform your translation and rotation on the peg layer so all the parts attached to that peg layer 
follow the same trajectory.
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About Scene Setup for Rigging
Planning your rig is an essential step in avoiding missteps at later stages. Once a rig has moved on to the animation 
level, it becomes more difficult to fix potential blunders, since updating the rig scene doesn't have repercussions on 
rigs outside of that scene.  These different topics will help you avoid such mistakes.
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About Models
To begin breaking down your puppet, you must first import your character into a new project. You can also draw 
your character directly in the scene.

You can import your character in several different formats: 

 l Library template—see Library

 l External vector format

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera view and 
scale it to fit inside the safe area frame.

If you have several views of your character, place each view in a separate cell and center them one on top of 
another. This will facilitate the break down process and ensure that all of your puppets are aligned and the same 
size.
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Photo Puppets

If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing software. Then, 
import your parts and vectorize them as textured images.

A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all the 
elements you want to import as a single layer in Harmony are grouped together in their own folder. Any layer that is 
not in a folder group, by itself or otherwise, will not be imported.
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About Size Relation
Understanding the relative size of every character and prop is important for maintaining consistency and structure 
throughout your project.

A production may contain many characters and props. It is not unusual for these to have been created by different 
people. If there is no size control implemented, the characters and elements created by different artists can vary 
greatly in size. When this occurs, the characters that are put together in a scene will be out of proportion. The 
animator or person doing the scene setup will then have to scale them to the correct size.

When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the element is 
scaled to its proper size, the outline may be so thin that the difference between one character's outline and 
another's will not look very good.

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then scaling 
them so they are in proportion with each other. This line up is very important and should be handed to any 
animator, layout and posing artist, or scene setup person working on the project.

For the prop design, it is recommended that you paste one of the main character's hands or even the full body 
beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is usually 
done during the character design step. When the character builder imports the model to the break down scene, 
the size relation should be correct.

Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props. You can 
display the field chart using the Show Grid option in the Camera and Drawing views.
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How to display the field chart

 1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.

‣ Press Ctrl + ' (Windows/Linux) or ⌘  + ' (Mac OS X).

‣ Click the Show Grid  button in the Camera View and Drawing View toolbars.

Brush Size

There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a good idea to 
create and save pens with precise sizes and parameters to trace and design your models and break downs—see 
About the Brush Tool on page 86.
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Setting Preferences for Rigging
 

Before you start adding layers to your puppets, make sure the Default Separate Position  is enabled.

With the Default Separate Position preference selected, when you create new peg layers, their X, Y and Z axes 
are independent from each other.

For cut-out animation, you want to have three independent axes so you can control them individually.

When you lock the three positions together, each time you add a keyframe, it is added on all three positions at the 
same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other two. This 
gives you more freedom when animating with motion keyframes and nudging parts forward and backward over 
time.

How to set the Default Separate Position option

 1. Do one of the following:

 l Windows/Linux: Select Edit > Preferences.

 l Mac OS X: Select Harmony Essentials > Preferences.

 l Press Ctrl + U (Windows/Linux) or ⌘  + U (Mac OS X).

 2. In the Preferences dialog box, select the General tab.

 3. In the Settings section, select the  Default Separate Position for Pegs option.

 4. Click OK.

330



Harmony 14 Essentials - User Guide

About Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention chart before 
starting the project. When dealing with thousands of characters, pieces and puppets, it is easy to get lost. Proper 
naming of both drawing layers and drawing substitutions is essential to keeping your workflow consistent throughout 
your project.
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Naming Drawing Layers
It is highly recommended that you incorporate a naming convention for the layers. This will be very convenient in 
later steps. 

One common practice is to add one or two letters for the character/prop name, so that we don't make it too long. 
You can then add the name of the part that you've separated. It is recommended to add an indicator of the position 
of your character's symetrical pieces to keep track of which part you are selecting. Common practice is to add 
either "F" or "B" (for front and back view) or "R" or "L" (for right or left). Avoid using spaces in between the words 
and opt for an underscore instead.

 l Character Orcus's right arm = 

 OR_arm_F 

 or 

 OR_arm_R.

Pink: Front or Right 

Blue: Back or Left
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About Character Breakdown
T-RIG-001-006

Now that you have imported or designed your model, the next step is to analyze it. This is to determine what parts 
will be broken apart and how they will be divided. Will the hair be separated into one, two or three sections? Will the 
hand be separated from the sleeve? To determine what is best for your character, observe the model in the Camera 
or Drawing view.

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the pupil and the 
eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to the side of the eyeball. For a 
more advanced break down, the two eyes are separated on their own individual three-layer sets.

Separating the Mouth Elements and Jaw

To get a greater level of flexibility, you can separate the jaw from the head. You can also separate the mouth shape, 
teeth, tongue and interior one from another.
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Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand. The full 
hand is a single layer with a bank of different hands stored inside. This technique is easy to work with and 
produces a less mechanical effect.

Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and reuse a 
character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly overlapping and 
complete. A common mistake is to trace the part just as it appears on the model.
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Tracing the Model
The main breakdown technique shown here is to trace your model.

How to break down a character by tracing

 1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Win-
dows/Linux) or ⌘  + R (Mac OS X)—see .

 2. In the  Timeline view, select the layer's first cell in which you want to draw the part.

 3. In the Tools toolbar, select a drawing tool.

 4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see  .

 5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are 
easy to manipulation, modify or redraw. There exists two easy ways to do this:

 l By using the Polyline tool

 l By drawing with the Pencil tool, then smoothing your lines with the Smooth Editor tool

If you are working in the Drawing view, click the Light Table  button  in the Drawing View toolbar to 
display the other layers in washed out colours. You can also press Shift + L.

 6. If you want to close a shape without drawing an actual stroke, you can use the Stroke tool in the Tools tool-
bar to create an invisible hairline .
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 l Select View > Show > Show Strokes or press K to display the invisible lines.

 7. In the Tools toolbar, select the Paint or Paint Unpainted  tool to colour your drawing.

 8. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.

 9. In the Camera or Drawing view, paint your drawing.

 10. In the Tools toolbar, select the Select  tool. Select your drawing and flatten the lines by clicking the Flatten 
 button in the Tool Properties view.

 11. Repeat the entire process for every body part that you wish to make animatable. 
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Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature. 

Breaks a character into its main body parts. There is no need to create any layers prior to this process. Make sure 
your model is well centered and sized in the Camera view.

You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes all the artwork 
of the part you want to break down. You will clean the extra bits and pieces later.

Using the Cutter tool, you can roughly cut the main sections, and then use the Select tool to select precise lines and 
colour zones.

How to break down the main parts

 1. In the Timeline view, select the cell of the model that corresponds to the first view to break down.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press 
Alt + S.

 l In the Tool Properties view, you can switch to the Lasso  selection mode.

 3. In the Camera view, create a selection around the first part to break down. If you click on a zone, the Cutter 
tool will select the zone. It will end the selection at the first point of intersection that it meets.

‣ Hold down Shift to create a new lasso selection around another zone and add it to your previous selection.
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 4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

 5. In the Layer Name field, type the name of the layer you want to create following the naming convention you 
established previously.

 6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You 
do not want to cut the artwork from the colour model.

 7. Click OK.

The new layer is created and your selection is copied in it. The drawing is created in the same frame 
number as the cell it was taken from.

 8. Repeat the previous steps for each main body part.
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Breaking Down Secondary Parts
You should now have a layer for each main part of the character for the first view to break down. You are now ready 
to break down those main pieces into smaller ones.

Breaking down the secondary parts is similar to the main part break down process except that this time you will cut 
away the artwork from the layer it has been selected from.

How to break down the secondary parts

 1. In the Timeline view, lock your model layer by clicking its Lock  button.

 2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

 3. In the Tools toolbar, select the Cutter  tool.

‣ If you prefer to use the Select  tool, choose the Select  tool from the Tools toolbar or press Alt + S.

 4. In the Camera view, create a selection around the part to break down.
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‣ If you click on a zone, the Cutter  tool will select the zone and end the selection at the first point of 
intersection that it meets. Click on the line with the Cutter tool to select it up to the next intersection.

 5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.

 6. In the Layer Name field, type the name of the layer you want to create following the naming convention you 
established previously.

 7. Select the Cut Artwork From Source option to remove the selected artwork from your original drawing. In 
this case, you want to cut the artwork from the colour model.

 8. Click OK.
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The new layer is created and your selection is copied in it. The drawing is created in the same frame number 
as the cell it was taken from.

 9. Repeat the previous steps for each body part.

NOTE: 
If you forgot to add some artwork to a layer you previously created, you can always add it later. 

In the Camera view, select the artwork to send to the existing layer. Open the Create Drawing from Drawing 
Selection dialog box by pressing F9 (Windows/Linux) or ⌘  + F9 (Mac OS X). In the dialog box, select an 
existing layer from the list instead of typing a new name. Click OK to add the artwork to the existing drawing in 
the layer you selected.
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Breaking Down Other Views
If your character model has more than one view, now is the time to break them down.

The process is very similar to breaking down the first view. You have two choices:

 l Breaking down the new view in a new set of layers

 l Breaking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you are break-
ing down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down later on.

Repeat the following steps for each extra view you need to break down.

How to break down the other views

 1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't forget to 
unlock the layer.

 2. In the Tools toolbar, select the Cutter  tool.

 l If you prefer to use the Select  tool, in the Tools toolbar select the Select  tool or press Alt + S.

 2. In the Camera view, create a selection around the first part to break down. 

 3. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9 (Win-
dows/Linux) or ⌘  + F9 (Mac OS X).

The Create Drawing From Drawing Selection dialog box opens.
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 4. In the Layer Name field, select the corresponding layer from the list if you want to use the same layers or type 
a new name if you want to create a new layer.

 5. Deselect the Cut Artwork From Source option to keep the selected artwork on your original drawing. You do 
not want to cut the artwork from the colour model.

 6. Click OK.

The artwork is inserted into the existing layer. The drawing is created in the same frame number as the cell it 
was taken from. It is not incorporated in the other view's drawings.

 7. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views, follow the exact same process as you did for the first view 
you broke down, but you will incorporate the new parts in the existing layers—see Breaking Down Other Views on 
page 344.

Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily need to 
have the same layer structure.

Here is an example of how your timeline should look at this stage:
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Completing Parts and Articulations
Now that all the layers are created and the parts are basically broken down, it is time to clean up the parts and 
complete the articulation.

Cleaning the Parts

You will need to use a series of drawing tools to clean the parts:

 l  Brush tool

 l  Eraser tool

 l  Select tool

 l  Cutter tool

 l  Contour Editor tool

 l  Paint tool

 l  Close Gap tool

How to clean your drawings

 1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

 2. In the Timeline view, select the cell containing the drawing to fix.

 3. In the Camera view, delete the extra bits using the Select  or Cutter  tool. You can also use the 
Eraser  tool.

 4. Draw the missing lines using the Brush  tool. If you use the Brush tool, it is recommended that you 
enable the Auto-Flatten  option in the Tool Properties view.
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 5. Using the Paint  tool, paint the gaps. You can close some gaps with invisible lines using the Close Gap 
 tool or press Alt + C.

 6. Reshape your lines using the Contour Editor  tool or press Alt + Q.

 7. Using the Select  tool, select the entire drawing and click the Flatten  button in the Tool Properties 
view to flatten your drawings.

 8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could be present 
in your drawing or press K.

 9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary invis-
ible lines in the drawing.

 10. Repeat this entire process for each drawing to fix.
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About Articulations
Once your pieces are traced, you can go ahead and complete the articulations.

Articulations are an important aspect of any cut-out break down because without them, a puppet cannot move 
properly and will not look good.

If you are using deformations to animate the limbs, your articulations don't need to overlap. The deformer effect 
will create the joint for you.
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Creating Classical Articulations
Classical articulation is the most popular technique for basic characters. It is quite simple and produces excellent 
results, but it's not the most efficient method. In many instances, it causes limitations and extra drawing 
corrections. For example, there may be a gap in the articulation if the part is bent too far. Joint design is usually a 
circle; the overlapping part cannot be sent behind without showing the joint.

Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour overlapping the 
bottom layer. You can use this technique for all the articulations on your puppet.

How to create a classical articulation

 1. In the Timeline view, select the cell containing the part to modify (piece located behind), such as the upper 
arm.

 2. In the Tools toolbar, select the Pencil , Polyline , Ellipse , Cutter , or Contour Editor  tool.

 3. In the Colour view, select an outline colour.

 4. In the Drawing or Camera view, use your drawing tool to make sure the joint overlaps the other part in a half-
circle shape.

If you are working in the Drawing view, click the Light Table  button in the Drawing toolbar or press Shift + 
L.

 5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines that may 
be present in your drawing.

 6. In the Drawing or Camera view, select all the strokes in your drawing.

 7. In the Tools Properties view, click the Flatten  button.

 8. In the Drawing or Camera view, select all the strokes in your drawing.

 9. Repeat the previous steps for the other articulations.

 10. In the Timeline  view, select the cell of the part that will be on top of the joint.
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NOTE: When placing rotation pivots later on, make sure they are positioned at the centre of 
the articulation.
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About Ordering Layers
T-HFND-005-005

At this point, it is possible that your character's pieces may show up in the wrong order.

There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or lower level in the 
Timeline view. The top layer is displayed in front of the others and the bottom one is displayed behind. Second, you 
can use the Z-axis nudging (forward and backward) if you have extra views included in the same layers (front, three-
quarter, back, etc.).
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Ordering Layers in the Timeline View
T-HFND-005-006

In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will be displayed 
behind. If you have multiple views, you should order your layers based on the most common view, which is 
generally the three-quarter front.

How to order layers

 1. In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.
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About Z Nudging
T-HFND-005-008

If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a part, such as the 
hand, to appear in front of its parent. Yet, if you move the hand layer above the arm layer, you will break the 
hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or forwards on the z-axis.

NOTE: You will do the same for the layers that are not in the right order on the extra views. Do not place the 
drawing on another layer. You want to keep all your drawings of the body parts in the same layers like a box con-
taining all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:

 l Up and down (Y-axis)

 l Left and right (X-axis)

 l Backwards and forwards (Z-axis)
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Nudging Layers
T-HFND-005-009

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the part to be 
reordered and see it in front of the other elements, even if its layer is actually behind the other ones in the Timeline 
view. The forward-backward position can also be animated over time.

How to nudge layers backwards and forwards

 1. In the Tools toolbar, select the Transform  tool. Make sure to enable the Animate  mode.

 2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is around the 
Camera view before selecting the element.

 3. To move the element forward,  press Alt + Up Arrow and to move the element backward,  press Alt + Down 
Arrow.
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About Pivots
T-RIG-006-001

Even with a complex hierarchy, a rig is useless without positioning the proper pivot points. This will allow the 
puppet's pieces to rotate correctly. The arm needs to rotate from the shoulder and stay attached to the torso, so its 
pivot point needs to be positioned accordingly. A good way to achieve this is to position the pivot point exactly in the 
center of the articulation.

The initial position of the pivot point is always at the center of the scene. Sometimes there will not be an obvious 
place of rotation to place the pivot point, but it's a good idea to reposition the pivot to the best transformation point. 
For instance, the master peg, which generally controls the entire rig, is often best positioned between the character's 
feet.
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About Permanent Pivots
T-RIG-006-002

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the Rotate  
tool.

356



Harmony 14 Essentials - User Guide

Setting Permanent Pivots
T-RIG-006-004

In this section, we'll take a look at one of the options we have for setting pivots. The permanent pivot allows you to 
push your rigs to great lengths without having to worry about repositioning your pivot once it is set.

How to set the pivots with the Rotate tool

 1. In the Advanced Animation toolbar, select the Rotate  tool.

 2. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view, you can 
also hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on the piece whose pivot you want to set.

 3. In the Camera view, drag the blue pivot to reposition it.

 4. Repeat the previous steps for all the pieces, including the eyes, nose and mouth. If you are unsure as where 
to place the pivot, put it in the center of the selected piece or group of pieces.

NOTE: If you added other pegs to your rig, you must set their pivot using the same method.
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Setting Multiple Permanent Pivots
You can simultaneously set the position of pivots for several drawing layers or pegs  that you would like to rotate 
and scale from the same point of origin, 

How to set pivots on multiple pegs

 1. Select the multiple pegs or drawing layers from either the node view or timeline view.

 2. Select any Advanced Animation tool, such as the  Rotate tool. 

 3. Reposition your pivot using the Advanced Animation tool

NOTE: Never use the Transform tool to permanently position pivots. The Transform tool only temporarily 
repositions it to accommodate your transformation, usually during the animation process.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform 
drawings that are under their hierarchy, without transforming the actual drawing. 

When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This 
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the position 
and exposure of your drawing layers independently in the Timeline view. It also makes it easier to create a hierarchy 
of which body parts can be animated together and independently. 

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool 
Properties view. You can also disable animating drawing layers, so that only pegs can be animated. 

NOTE: It is also possible to make drawing layers the children of other drawing layers. Just like the way anim-
ating a peg animates its children layers, animating a drawing layer with children will also animate its children lay-
ers. 

How to create parent pegs for your layers in the timeline

 1. In the Timeline view, select all the layers.

 2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected layers.

s
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Creating Hierarchies
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should 
influence other limbs, and how they can move independently. For example, when rigging a simple character's 
arm, you can make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. This 
way, if the character moves their forearm, the hand will follow, and if they move their arm, the forearm and hand 
will follow. 

When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can 
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig the 
legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view

 1. In the left area of the Timeline view, select the layer which you want tomake a child layer
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 2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you are not drop-
ping the child layer between two layers. 

 3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at the root. 
While rigging, if you want several layers to have a common parent, but no existing part of your rig can serve 
as that parent, create a new peg and nest those layers under that peg.

NOTE: In the Timeline view, you can unparent layers by holding down Shift and dragging the selected parents 
away from the child layer. Drop your selected between other layers.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they're 
rendered. Layers on top of the list will be rendered over layers at the bottom of the list.  Should you need to change a 
layer's order while animating, you can nudge this layer's position on the Z-axis to override the layer order and force it 
to appear beneath or over other layers. 

How to nudge a layer on the Z-axis

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Timeline, Node or Camera view, select the layer you want to nudge.

 3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the focus on the 
Camera view.

 4. Do one of the following:

 l To nudge the layer forward, press Alt + Down Arrow.

 l To nudge the layer backward, press Alt + Up Arrow.
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Adding the Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows you 
to manipulate the entire rig from a single layer, without having to manipulate each individual part. This is useful for 
positioning and scaling your character relative to the scene, as well as to animate your character's trajectory 
when it has to move between areas of the scene.

How to add a master peg in the Timeline view

 1. In the Timeline view, select the top layer.

 2. In the Timeline view, click on the Add Peg  button.

A new peg is added to the timeline as a parent of the selected layer.

 3. Name the new peg Master plus the character's name.

 4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is 
already parented to that peg.

 5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers are 
added above the already parented layers, move that parented layer back on top of the layer stack.
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Invert-Cutting
When rigging a character, there may be instances when you want to have the ability to move a particular piece to 
give the illusion of a rotation or move the pupil within the white of an eye without having the extra bit of the drawing 
sticking out of the character or eyeball. To do so, you can use masks to cut anything you don't want to be visible.

How to mask an object in the Timeline view

 1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece to cut.

 2. Select the layer that will act as the mask.

 3. In the Timeline view, right-click on the layer and select Clone Selected Layers: Drawings and Timing.

 4. Select the layer to be masked.

 5. In the Layer toolbar, click the Add Layer button and select Effects > Cutter.

 6. Click the Expand Parameters  button to display the Cutter properties.
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 7. Drag the cloned layer ONTO the Matte parameter connection area.

The masking layer name appears in the Matte parameter area and the masking layer is repositionned above 
the effect.

The masking layer is no longer visible in the Camera view. You can see that the masking layer is connected 
to the Cutter effect by clicking the Show/Hide Additional Links  button to display the Additional Links 
section.

 8. Your masking effect is most likely inverted and what you want to cut is probably showing. Double-click on the 
Mask layer to open the Layer Properties window. In the Layer Properties window, enable the Inverted option.

 9. In the Tools toolbar, select the Transform  tool and move the cut object within the masking zone.
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Grouping Rigs
Once your rigging is completed, you must group the puppet's skeleton to help organize the often large and complex 
networks. This way, once you have imported two or three characters into the scene, three Group nodes will be 
displayed instead of all the rigging connections of three puppets.

How to group nodes

 1. In the Node view, select all your nodes.

 2. In the top menu, select Edit > Group > Group Selected Layers  or press Ctrl + G (Windows/Linux) or ⌘  + 
G (Mac OS X).

Your nodes are grouped.

 3. Click on the Group node's right arrow to enter the group.

 4. If you do not have a Multi-Port Out node inside your group, in the Node Library view, select the Group cat-
egory and select a Multi-Port Out node.
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 5. Drag the Multi-Port-Out node to the Node view.

 6. Connect the Composite node's output port into the Multi-Port Out node. 

An output port is created on your Group node.

 7. In the bottom-left corner of the Node view, click Top to return to the network's root. You should now see an 
output port on your Group node.

 8. Click on the Group's Properties button to open the Layer Properties window.

 9. In the Layer Properties window, rename the Group node with your character's name.

 10. Click Close.

368



Harmony 14 Essentials - User Guide

Creating Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on each cell to 
create all of the function curves and block your pose in place.

How to create the keyframes

 1. In the Timeline view, collapse the master peg by clicking the Expand  arrow.

 2. In the Timeline view, select the first cell.

 3. Do one of the following:

 l From the top menu, select Insert > Keyframe. 

 l In the Timeline View toolbar, click the Add Keyframe  button.

 l Press F6.

NOTE: If you use the F6 shortcut when working Flash keyboard shortcuts flavour, this not only creates a key-
frame but also duplicates a drawing.
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About Timeline Marking
As you animate, the Timeline view will accumulate many layers and keyframes. You might want to identify them 
using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can 
use it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in 
action, an impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is 
displayed when you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and 
mark the whole section.

To see how to mark the Timeline, see , , Marking Layers with Colour
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Chapter 9: Deformation
T-RIG-007-001

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations  act 
as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made out 
of one, or many, drawing or image layers and make it move as if it were a cut-out puppet.   

A deformation skeleton is composed of deformation nodes, which are the various pieces (here represented as layers 
or nodes) required to articulate or deform your drawings, such as a series of bones or game bones.
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About Deformer Types
The 4 types of deformers are: Bone, Game Bone, Curve and Envelope. Each type has its own advantages and 
limitations and need to be rigged and handled in different ways.
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About Bone Deformation
T-RIG-007-002

The Bone deformation allows you to create a bone-like structure in which each part is solid, but with articulations 
that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or other parts that 
can be articulated such as torsos or fingers. For example, a Bone deformation can be used to articulate an arm that 
is made of a single drawing, so that the upper arm and forearm can be moved independently, without having to draw 
the upper arm and the forearm on different layers. Harmony will deform the drawing to make it look articulated. The 
different parts of a Bone deformation can be rotated around their joint, extended and shortened, giving you the same 
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot 
points, or clipping outlines.
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About Game Bone Deformation
T-RIG-007-003

The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like structure 
in which each part is solid, but with articulations that are flexible. This is mostly useful for animating a character's 
limbs, such as the arms or legs, or other parts that can be articulated such as torsos or fingers. For example, a 
Game Bone deformation can be used to articulate an arm that is made of a single drawing, so that the upper arm 
and forearm can be moved independently, without having to draw the upper arm and the forearm on different 
layers. Harmony will deform the drawing to make it look articulated. The different parts of a Game Bone 
deformation can be rotated around their joint, extended and shortened, giving you the same capabilities as 
animating articulations on different layers, without having to worry about parts detaching, pivot points, or clipping 
outlines.

The Game Bone deformation is different from the Bone deformation in which it is optimized for game engines 
such as Unity. Hence, it is usually only used for game development and not in animated productions. The 
difference between the Bone and Game Bone deformations is that  Game Bone deformations do not have a Bias 
property. The articulation folds also look slightly more rounded.
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About Basic Deformation Chain Creation
Using the Rigging tool, you can quickly create a basic deformation rig.

As you create your chains, the controls will be showing.  However, whenever you close your project, the deformation 
controls display is turned off. When you reopen the project, you can display all controls or only some of them—see 
Displaying the Deformation Controls on page 1.
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Setting Rest Positions for Bone and Game Bones
Every deformation rig needs to have a set resting position. The resting position is important as it acts as a 0 point 
for all the transformations that will be made to the drawing when animating. The resting position is also where we 
can see what parts of the drawing are assigned to which bone or articulation.

How to set up Bone and Game Bone deformation chains

 1. In the Timeline view, select the deformation nodes  you want to set.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. In the Deformation toolbar, click the Rigging  tool.

The chain turns from green to red. A green chain indicates the puppet is in animation mode. A red chain 
indicates the puppet is in a resting position. Make sure your chain is red.

 4. In the Camera view, set up the deformation chain.

 l Rotate the first bone to change the angle of the chain.

376



Harmony 14 Essentials - User Guide

 l Use the root control to reposition (offset) the entire chain.

 l Use the control points to reposition the articulations. This will elongate, shorten or change the 
direction of the bone and offset the subsequent children.

 l Use the articulation's control (square) to change the size of the articulation. For quality pur-
poses, it is recommended to have an articulation which fits the diameter of the part it controls.
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 5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is 
linked. You can also set additional parameters in the Layer Properties window—see the Reference guide .

 6. With the deformation nodes still selected, in the Deformation toolbar, click the Reset Current Keyframe 
 button. This will set the current resting position as the current frame one.

 7. Use the Transform  tool. For optimal results, make sure the size of the articulation is approximately the 
same size as the drawing.

How to add an articulation to an existing Bone or Game Bone deformation

 1. Select the drawing layer or the deformation chain to which you want to add an articulation.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

 3. Select the Rigging  tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the 
deformation. A red chain indicates that you're modifying the rig.

 4. Move your cursor over the bone segment, where you want to add an articulation.

 5. Hold Alt and click.
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Selecting Region of Influence Types
There are four types of region of influence:

 l Zero: This creates no influence around the deformer.

 l Infinite: This is the default option. The influence goes all the way to the image boundaries or until it intersects 
with another zone of influence. When working on a cut-out puppet built on several element layers, the best 
choice is to keep the default Infinite option as the zone of influence type. In the following examples, the zones 
of influence are explained through deformation chains on a single bitmap image. It's also recommended to 
keep the regions of influence to Infinite when using Envelope deformers.

 l Elliptic: This creates a region of influence following the deformer. Its size is based on a radius value. When 
you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and make sure 
that only the element you want to follow the deformation is included inside the zone.

 l Shaped: This creates a custom region of influence around the deformer that can be adjusted using control 
points and Bezier handles. When you set up the boundaries of your Shaped zone of influence, you should be 
as accurate as possible and make sure that only the elements that you want to follow the deformation are 
included inside the zone.

 When you have an Elliptic zone of influence selected in the Node view, you can convert it to a Shaped zone 
using the Convert Elliptic Zone of Influence to Shape option.

How to select a region of influence type

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see Displaying 
the Deformation Controls on page 1.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence Type:

 l Zero

 l Infinite

 l Elliptic

 l Shaped
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Setting Up Elliptic Regions of Influence
An elliptical region of influence is suited for regular shapes. Modify its parameters to refine the region boundaries.

How to set up the Elliptic region of influence

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see Dis-
playing Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display 
the deformer of the selected piece.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Elliptic.

 4. Set up the ellipse shape by adding values to the various fields:

Influence Fade Radius
This defines the size of the fade area around the actual region of 
influence's boundaries.

Transversal Influence Radius 
Left

When the Symmetric Ellipse of Influence option is enabled, this 
field controls the Left and Right transversal radius values. When 
disabled, it controls the size of the left transversal radius. By 
default, this value is set to 2.

Transversal Influence Radius 
Right

When the Symmetric Ellipse of Influence option is enabled, this 
field becomes inactive. The Left Transversal radius value is 
automatically applied to the Right Transversal. When the 
Symmetric Ellipse of Influence option is disabled, it controls the 
size of the Right Transversal radius. By default, this value is set 
to 2.

Longitudinal Influence Radius 
Begin

When the Symmetric Ellipse of Influence option is enabled, this 
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field becomes inactive. The End Longitudinal value is 
automatically applied to the Begin Longitudinal value. When the 
Symmetric Ellipse of Influence option is disabled, it controls the 
size of the Begin Longitudinal radius. By default, this value is set 
to 0.25.

Longitudinal Influence Radius 
End

When the Symmetric Ellipse of Influence option is enabled, this 
field controls both the Begin and End Longitudinal radius values. 
When this option is disabled, it controls the size of the End 
Longitudinal radius. By default, this value is set to 0.25.

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be symmetrical 
on both the transversal and longitudinal radii. In this case, use 
the Transversal Influence Radius Left field to set the transversal 
radius value and use the Longitudinal Influence Radius End field 
to set the longitudinal radius value. The two other fields will 
remain unused unless you disable the Symmetric Ellipse 
Influence option. In that case, you can set up different radius 
sizes for the four radii directions.

 5. You can also modify the elliptic shape in the Camera view using the  Rigging  tool.

 l If the Symmetric Ellipse of Influence option is enabled, one control point will be available in the Camera view. 
Drag this point in any direction to increase or decrease the size of the Zone. Dragging it left/right will modify 
both longitudinal radius sizes. Dragging it up/down will modify both transversal radius sizes.

 l If the Symmetric Ellipse of Influence is disabled, two control points will be available in the Camera view. Drag 
the top-corner point left/right to modify the end longitudinal radius size and up/down to modify the left trans-
versal radius size. Drag the bottom-corner control point left/right to modify the beginning longitudinal radius 
size and up/down to modify the right transversal radius size.
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Setting Up Shaped Regions of Influence
A Shaped region of influence is suited for irregular forms. Modify the region parameters to refine the shape's 
boundaries.

How to set up the Shaped zone of influence

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see Displaying 
Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer of the selected piece.

If you selected the Shaped option in the Layer Properties window or in the Rigging tool properties, the zone of 
influence will be square. This square has control points on all four corners and each control point as two 
control levers. If you converted an Elliptic zone to a shape, the zone will have more control points and 
handles.

 3. In the Layer Properties window, in the Region of Influence tab, set the Influence type to Shaped.

All radius options are disabled except the Influence Fade Radius option—see Setting Up Shaped Regions of 
Influence on page 383.

 l In the Camera view, use the Rigging tool and drag a control point to redefine its position and 
shape.
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 l Click and drag the control lever handle to modify the corners and redefine the shape.

 l Hold Alt down while dragging the control lever handle to move one handle at a time.
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Converting Elliptic Regions of Influence into Shapes
After you have tried tweaking an elliptical region of influence, you may find that you need to convert the ellipse into a 
shape, in order to create a more precise region. Instead of losing all the tweaks you have made, you can use the 
elliptical region you have created as a base for a Shaped region of influence.

How to convert an Elliptic zone of influence to a shape

 1. In the Timeline view, select the deformation nodes  you want to set the region of influence for—see Displaying 
Deformation Controls.

 2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others  button to display the 
deformer of the selected piece.

 3. In the Tools toolbar, click the  Rigging  button.

 4. In the Tool Properties view, in the Operations section, click the Convert Elliptic Zone of Influence to Shape 
 button.

The zone of influence is automatically converted to a shape. The shape is retained and control points appear 
around the zone, so you can customize the shape. 
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About Assembly
After you have created all the deformation chains for your character, you will need to assemble these separate 
body parts into a puppet. Your pieces should be properly overlapping and not set apart.

To avoid problems such as having the head stretched by the neck deformers or a hand modified by the body 
deformers, you can use the Kinematic Output node to assemble your pieces without propagating the 
deformations down the hierarchy chains.

The Kinematic Output node lets you hook a separate element that you want to be linked to the deformation chain 
but not be part of the deformation, such as a hand to an arm or an arm to the body. These elements will follow the 
movement of the chain just like a regular cut-out character hierarchy piece without being influenced by the 
deformation of the arm. If you don't use the Kinematic Output, the piece's pivot will not follow the deformation.

When building a cut-out puppet with deformations, each part controlled by a deformation chain will automatically 
rotate from the chain root point, which acts like a pivot. Because it is unlikely that every piece of your character 
will be rigged with a deformation chain, you must set pivot points for the pieces that are not using deformations—
see Setting Permanent Pivots on page 357.

Assembling Guidelines

When assembling a puppet with deformers, there are some guidelines to keep in mind:

 l You cannot parent deformers directly because deformers are not designed to be used on other deformers. 
To assemble deformers, you must insert a Kinematic Output node.
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 l Your peg must be placed above the deformer.
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Assembling in the Timeline View
In order to assemble the rigged parts of your character in the Timeline view, you need to use a Kinematic Output 
layer.

How to assemble a puppet using the Kinematic Output node in the Timeline view

 1. Select the element to attach to the Kinematic Output node, such as the hand or head peg.

 2. From the top menu, select Insert > Kinematic Output.

The node appears in the Timeline view as a parent of your selection.

 3. In the Timeline view, drag and drop the Kinematic Output layer ONTO the deformation layer you want your 
limb or piece to follow. For example, onto the neck deformer if you want your head to follow it without being 
deformed or onto the arm deformer if you want your hand to follow.

 l If your pieces are no longer ordered properly, use the Z-nudging feature to reorder them—see 
About Ordering Layers on page 351.
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 l It's good practice to rename the Kinematic Output layer to reflect which deformer it is assigned 
to as the Timeline view can become very large and layers can be positioned far apart. Select 
the Kinematic Output node and in the Layer Properties window, rename the node. You can also 
double-click on the layer's name.
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Displaying Selected Deformation Controls
Harmony lets you control which deformers are displayed in the Camera view independently from the current 
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view. 
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation 
controls won't display right away. Likewise, deselecting a deformation chain will not hide its deformation controls. 
Before you can animate or modify an existing deformation chain, you must manually display it.

How to display the selected deformation chains

 1. Do one of the following:

  l In the Timeline view, select any part of the deformation chain you want to display.

 l In the Camera, Timeline view, select one of the drawing elements linked to the deformation 
chain you want to display.

 2. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.

NOTE: The Show Selected Deformation Chain and Hide All Others button will display all deformation chains 
that are in the hierarchy of the selection. For example, if the master peg of a character model is selected, all 
of its deformation chains will be displayed. Likewise, if multiple layers linked with different deformation 
chains are selected, all of their deformation chains will be displayed.
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Hiding Deformation Controls
You can hide all the deformation controls for your rig all at once.

How to hide the deformation controls

 1. Do one of the following:

 l Click in the negative space of the Camera view, Timeline view or Node view to discard the cur-
rent selection, then click on  the Show Selected Deformation Chain and Hide All Others  but-
ton in the Deformation toolbar.

 l Select a layer that is not linked to any deformer, then click the Show the Selected 
Deformation Chain and Hide All Others button in the deformation toolbar.

 l In the Camera toolbar, click the Hide All Controls  button. 

 l From the top menu, select View > Hide All Controls. 

 l Press Shift + C.
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About Deformation Animation
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on their 
corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a deformer, 
except it requires using Transform tool instead of the Rigging tool. When the Transform tool is selected, 
deformation controls in the Camera view display in green, which means they are in animation mode, whereas 
when the Rigging tool is selected, they display in red, meaning they are in rigging mode.
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Animating Bone and Game Bone Deformers
You can add keyframes to deformers reposition their deformation controls to create animated sequences.

How to animate Bone and Game Bone deformations

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position and 
size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and size 
throughout the whole scene. 

 3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

 4. Select the first frame of the scene.

 5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first frame 
in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type in the 
amount of frames in your scene and confirm. This will make your model exposed (visible) throughout your 
whole scene,

 6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of every 
layer of the model. This ensures that when you make the second pose later, your first pose will not be 
affected. To do this do one of the following: 

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe is added on the current frame.

 7. Do one of the following:

  l In the Timeline view, select any part of the deformation chain you want to display.

 l In the Camera, Timeline view, select one of the drawing elements linked to the deformation 
chain you want to display.

 8. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others  button.

The selected deformation controls appear in the Camera view and all the others are hidden.
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 9. In the Camera view, do the following:

 l Rotate the first bone to rotate the limb.

 l Rotate the subsequent bones to bend the limb.

 l Use the root control to reposition (offset) the entire chain.

 l Use the control points to reposition the articulations. This will elongate, shorten, or change 
the direction of the bone and offset the subsequent children.
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 10. In the Timeline view, go the frame on which you want to set the next key pose. 

 11. Add a keyframe on the current frame by doing one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

 12. Repeat the previous steps to animate your character.

NOTE: When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt key to lock 
the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl (Windows/Linux) or ⌘  (Mac 
OS X) key to break the articulation off its chain and make it into a new, separate deformer chain.

NOTE: You can also manipulate the deformer by typing values directly in the Layer Properties of the deform-
ation effect nodes.                     
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Resetting a Deformer to its Resting Position
If you need to reset the current pose of the entire chain for the entire scene, you have the possibility to reset the 
deformation chain to the resting position on the current or all frames.

How to reset the position of deformers from the Camera view

 1. In the Timeline view, move the playhead to the frame where you want to reset the puppet to the resting pos-
ition.

 2. Do one of the following:

 l In the Camera or Timeline view, select one of the drawing layers linked to the deformation chain 
you want to [[[Undefined variable Variables.SnippetVariable1]]].

 l In the Timeline view, select any part of the deformation chain you want to [[[Undefined variable Vari-
ables.SnippetVariable1]]].

 3. In the Deformation toolbar, either:
 l Click the  Show the Selected Deformation Chain and Hide All Others  button to show the selec-

ted element's deformation chain and hide any other deformation chain that is currently displayed.

 l Click the  Show Selected Deformers button to show the selected element's deformation chain 
along with any other deformation chain that is currently displayed.

The selected deformation controls appear in the Camera view.

 4. In the Camera view, select the deformation point you want to reset. To select several deformation point, 
hold Ctrl and click on each point you want to reset to add them to the selection.

 5. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of the 
selected chain on the current frame.

How to reset the position of deformers from the Timeline                                 view

 1. In the Timeline view, move the playhead to the frame where you want to reset the deformer to its resting 
position.

 2. In the Timeline view, select the deformationlayer(s) you want to reset.

 3. In the Deformation toolbar, click on the Reset Current Keyframe  button to reset the position of the 
selected chain on the current frame.

NOTE: To completely reset the position and remove all keyframes on all frames, click on the Reset All Key-
frames  button.
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Disabling Deformation Preview
When adding new drawings while animating, you may need to see the reference drawings as their original resting 
position as it may be quite difficult to draw on a deformed canvas. You have the possibility to disable deformations in 
Harmony so that all drawings appear in their resting position.

NOTE: Disabling deformations is only a display mode. Although drawings will not appear deformed in the Cam-
era view, even in Render View mode, they will still be deformed in the rendered images.

How to disable the deformations to create new drawings

 1. In the Deformation toolbar, click on the Enable Deformations  button to toggle deformation preview.
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Transferring Curve Positions of Legacy Deformations
You can Lets you transfer all of the information from first curve deformer to its parent Offset node. This is useful 
for a legacy scene created using Curve deformations where the Offset's position has been placed far away from 
the drawing to make sure it doesn't affect  the drawing's deformation. You can bring back the offset and give it the 
first curve's position. The Envelope deformation lets you animate the offset of each curve separately. The offset 
no longer needs to be placed far away.

How to transfer a curve's position to its parent offset

 1. In the Node view, select the root Offset and the first curve.

 2. From the top menu, select Animation > Deformation > Set Curves and Offsets Independent from Par-
ent.

 3. In the Node view, select only the first curve node.

 4. From the top menu, select Animation > Deformation > Transfer Curve Values to Offset.

In the Node view, the first Curve node is disabled and the values are transferred to the parent Offset node.
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Converting Legacy Deformation Chains
You can also convert a legacy deformation rig to the new format using a script. You can select which chain you 
want to transform. Certain legacy nodes will remain in the structure to make sure the integrity of your original 
puppet is maintained.

How to convert legacy deformation chains to the new structure

 1. In the Node or Timeline view, select the deformation group containing the chain you want to convert to the 
new structure.

 2. In the Scripting toolbar, click on TB_ConvertLegacyDeformation. If the script is not available in the tool-
bar, you can load it.

 l In the Scripting toolbar, click on Manage Scripts

 l In the Script Manager dialog, in the File column, select the TB_Cover-
tLegacyDeformation.js script. If you cannot find the script in the list (most likely due to a 
software upgrade installation), you can load the script through the Script Editor view from the 
default resources folder—see Importing Scripts in the Scripting guide.

 l In the Functions column, select TB_ConvertLegacyDeformation.

 l Click the Right Arrow button to move the function to the Scripting toolbar.
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 l Click OK.

The legacy chain is converted.
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Chapter 10: Gaming in Harmony
There are two main pipelines for exporting data from Harmony to your game engine: 

 l Raw Game Data Export  on page 404

 l Frame-by-Frame Export  on page 405

Creating Animation in Harmony

When creating character rigs and animation for games, there are a few things to think about before starting.  Artists 
and programmers should work together to make sure their needs are met. 

 l What platforms will your game be create for?  Windows, Mac, Mobile, iOS, PS, XBOX, etc. 

 l What game engine will you be using?

 l What  will be animation style used to create the look of the game?  Hand drawn, cut-out, with textures, etc. 

These are just a few of the questions to consider before getting started.  They all have an impact on how you design, 
build, and animate characters. 

For example, if you’re planning a mobile game for smart phones, then you will most likely want to keep your game 
under 50 MB, so it can be downloaded without having to be on Wi-Fi.  In that case, your most important consideration 
is to create efficient characters with very tight sprite sheets and reuse a lot of the animation to keep the file sizes 
small.    During the process, you will need to: 

 l Rig and animate characters in Harmony.

 l Extract the Harmony data. 

 l Import the Harmony data into the game engine.  

Keep in mind, if you’re working with a custom engine, you can also process the Harmony data that’s exported and 
use it in a custom game engine.  If you need assistance with adapting data for your engine, contact 
store.toonboom.com/contact/support. 

If you’re making a game for consoles, like the PS or Xbox, then you have the freedom to create larger textures.  You 
may want to animate frame-by-frame, or you may want to animate with a cut-out character.     

If you're simply going to export on a frame-by-frame sequence, then you can use all the tools in Harmony without 
limitations.  You can then process an exported image sequence into a sprite sheet.  
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Raw Game Data Export 

Raw game data export is appropriate when you want the file sizes to be as small as possible.  Toon Boom lets you 
extract all the data from Harmony to incorporate into a game engine.  You can extract the skeleton information, 
drawing information, and keyframe animation data, as well as deformations (bones and articulations only), cutter, 
transparency nodes, and timing columns. 

 l Advantage: This is the lightest export, and will keep file sizes small which is ideal for mobile applications.
  

 l Disadvantage: You are somewhat limited in the tools you can use in Harmony.  You can use tools like 
Morphing as well as Curve and Envelope deformers, but you’ll need to bake it out to drawings so they're 
interpreted properly in the game engine.  You can use Cutter effects (masking), but you cannot cascade 
them, meaning you cannot have more than one in a hierarchy chain.  The Game Bone deformers can be 
used on your rig with having to bake it to drawings.

However, even with these limitations, you can create really great cut-out character animation in Harmony and 
extract all the data.  By moving, rotating, scaling, and skewing the different drawing layers, you can create 
advanced looking animation.  

When you extract the data, you'll have sprite sheets that contain only the drawings of the body parts used in your 
Harmony scene file.    You can also support multiple animations, such as idle, run, and jump, and reuse the same 
skeleton and drawings when possible by simply exporting new animation data. 

Toon Boom has fully integrated this solution with the Unity game development rendering engine. If you are 
creating your game in Unity, you have a seamless pipeline without the need to re-treat the data in your game 
engine. 
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Frame-by-Frame Export 

You can export from Harmony using an image sequence, which can be recompiled into a sprite sheet.

Advantage: You can use any of the tools in Harmony when you animate!

Disadvantage: These sprite sheets can become quite heavy and end up as large textures to process in the game. 
This may be fine for many games, like console games, but when you’re doing game development for mobile devices, 
such as iOS or Android, you need to be very light on your texture space. Also, file sizes should be kept under 50 MB 
to facilitate downloading without needing to be connected to Wi-Fi.

There is a script available in Harmony that allows you to export your animation in frame-by-frame to the EaselJS 
game engine   EaselJS is a javascript web compatible game engine.  It uses a json data structure to map each frame 
to an entry in the sprite sheet.  The data structure is easy to understand and can be adapted or converted to a 
different game engine if you need to.

To export to EaselJS, you need to add the script in the Scripting toolbar (TB_ExportToEaselJS).  This script is 
included in Harmony.  See the Scripting guide for more information on how to add the script to your Scripting toolbar 
and the interface parameters.
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About Game Asset Creation
In this section, you'll find guidelines for rigging, deformation, cutter and many useful animation tips.
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Game Rigging Guidelines
For complete procedures on how to rig a character, see—Rigging.

The following is a list of general guidelines to keep in mind when rigging your character. As you're planning the 
character rig for your game, keep in mind the style of the character, and create your custom colour palette.  
However, there are some limitations to consider if you plan to extract the game data:

 l Set your Harmony scene to be a square resolution (e.g. 1024 x 1024). You can do this in the Scene Setting 
dialog box—see the Reference guide .

 l Nudge layers in Z space if you need to reorder layers.  However, significant Z offsets are not supported 
within a character rig. 

 l Make every layer in your game engine  a separate scene in Harmony.  If you have two characters at dif-
ferent depths, put them in separate scene files. 

 l Character rigs in groups at the root level of your Harmony scene will render to a single plane in Unity, but 
use separate sprite sheet and animation data sets.  Keep this in mind for scenes in which you may have 
more than one character interacting with each other. 

 l Don’t use any effects.  Effects are not interpreted by game engines.  Use only direct hierarchy, drawing 
swaps, and keyframe animation. 

 l Set your pivot points on Peg layers using the Rotate tool to set the pivot on the entire layer.  Peg pivots are 
recommended over drawing pivots.  You should also set the pivot points on your drawing layers, even if 
you don’t animate on them, as this will allow you to retrieve the information later on in the game engine if 
you need to put a locator on a drawing layer.

 l Deform can be used and then baked out to individual drawings.  These drawings will then show up as new 
drawings in your sprite sheet.  Be wary of doing this too often as it will increase your texture space! 

 l For your pegs, when you animate, use Bezier curves and set them to Separate.  If you use 3D Path, it’s 
heavier than Separate. 

 l Be mindful of where you put your character before exporting. The master pivot of your exported game 
object will be the center of your Harmony scene (0,0).

 l Be sure to have a Display at the end of your hierarchy.

Keeping these tips in mind will allow you to create a tight, efficient 2D game character in Harmony while taking 
advantage of all the great tools. 

Here are some things you should do: 

 l Create a simple parent-child relationship hierarchy in the Timeline view.

 l Use peg layers to contain keyframe animation data, set to Separate Position.

 l Use drawing layers to draw on, creating new drawings when needed.

 l Use the Rotate tool to set the pivot points on the peg layers.

 l Name your layers properly so if you need to fetch a specific layer’s pivot point later on in the game engine, 
you can easily recognize the layer you need.  If you have a top-level Group A, which has a child group 
inside it (Group B), and the drawing layer is a child of Group B, then the drawing layer is exported as A_B_
DrawingLayer.

 l Set your anchors and props, see—Setting Anchors and Props
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You can use any of the drawing tools you want: Pencil and Brush tools, textured lines, solid areas, and gradients.  
Each individual drawing will be rendered out and assembled into a sprite sheet later.

NOTE: Because the Unity game engine does not support Unicode characters, it is recommended to avoid using 
it in scenes intended for games.
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Game Deformation Guidelines
Harmony can export deformations to the game engine XML format. Only hierarchies made of Game Bones can be 
successfully exported. In addition, Kinematic Outputs were implemented to complement your game bones—see 
About Game Bone Deformation on page 374. 

The deformation in the game engine SDK does not behave exactly as the deformation in Harmony.

To comply with most game engines and maintain fast calculations, the SDK implements a linear base skinning 
algorithm to linearly blend the bones at articulations. You may notice some differences depending on the 
curvature of the articulations used.

NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Game Cutter Guidelines
The cutter, or mask, operation in Harmony is used for cutting off drawings with custom shapes. The game engine 
SDK implements both cutters and inverted cutters with the following limitations:

 l For a sprite, only a single cutter drawing can be applied when it is rendered. This also applies to a composite 
of multiple matte drawings. The game engine SDK will only use the first matte drawing during rendering and 
discard the others.

 l A deformed drawing cannot be cut, but a cut drawing can be deformed.    

NOTE: * Not currently available in the Cocos2d-x implementation of the game engine SDK.
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Creating Metadata Notes
As you create assets for your game in Harmony, you may want to make notes about the scene or specific parts of 
the character or props for the programmer. These embedded notes that will be exported with your assets to Unity 
are known as metadata.

How to access the Metadata Editor view

 l In the top-right corner of a view, click the Add View  button and select Metadata Editor.

 l In the top menu, select Windows > Metadata Editor.

How to create scene metadata

 1. In the Metadata Editor view, in the Scene Metadata section, click on the plus button to create a new 
metadata entry.

The Add Metadata dialog box appears.

 2. In the Add Metadata dialog box, enter the name of your new scene entry.

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention 
must always use the prefix "game.". The term "game." is recognized automatically by Unity as a 
metadata information. For example: game.Armor001.

 3. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple 
entries. Continue adding multiple entries, clicking Add after each one. Click Close when you are through.

 4. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 5. Enter the value information for this entry. 

 6. Continue adding value information for all your entries.

This information will be exported with your Harmony assets. Once in Unity, scene Metadata will appear in 
Inspector view > Metadata when the asset is selected in the Hierarchy view.

How to create node metadata

 1. In the Timeline view, click on the layer to which you would like to attach metadata.

The name of the layer appears near the top of the Node Metadata section.
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 2. In the Node Metadata section, click on the plus button to create a new metadata entry.

The Add Metadata dialog box appears.

 3. In the Add Metadata dialog box, enter the name of your new node entry.

NOTE: For any anchor or prop information created within the Metadata Editor, the naming convention 
must always use the prefix "game.". The term "game." is recognized automatically by Unity as a 
metadata information. For example: game.Armor001.

 4. Click Add and Close if you only intend to add a single entry. Click Add if you intend to add multiple entries. 
Continue adding multiple entries, clicking Add after each one. Click Close when you are through.

 5. In the Metadata Editor view, double-click on the value field for the first entry to make it editable.

 6. Enter the value information for this entry. 

 7. Continue adding value information for all your entries.

This information will be exported with your Harmony assets, more specifically, this information will be linked 
to the selected layer. Once in Unity, scene Metadata will appear in Inspector view > Metadata when the 
asset is selected in the Hierarchy view.
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Game Animation Tips
When animating for games, depending on the type of game you’re creating, you may need to limit your animation.  
For example, if you’re creating mobile games and you want to keep the file sizes small and playback fast on all 
devices, then limit yourself to simple keyframe animation with as few drawing swaps as possible.  If you’re 
creating console games, you have the freedom to create more drawings and have a higher complexity.  You can 
explore with your programmer the limitations of the platforms you’re exporting to, and what your game engine 
supports.

Here are some tips for efficient, lightweight animation: 

 l Use mainly transformations, such as move, rotate, scale, and skew. 

 l Create additional drawing swaps when needed.

 l If you use Curve and Envelope deformers or Morphing, you’ll need to bake out the drawings for export.  Be 
careful when doing this, as you may want to keep the number of drawings small.  Don’t bake out an entire 
sequence, just selected drawings. You don't need to bake the Game Bone deformers.

 l The bigger the drawings are in the Drawing view, the more pixels they will occupy in the texture size on the 
sprite sheet.  When setting up your rig, make sure to not scale individual layers by using a keyframe with 
the Transform tool.  If you want to scale things up or down, use the Select tool.  This will keep things the 
same relative size on the sprite sheet.  When you export the sprite sheets, in the script you can also set the 
resolution of the sprite sheet so the drawings can be scaled down for smaller devices.

 l Only drawings which are exposed in the scene will be exported to the sprite sheet.  For example, if you 
have 10 drawings in your Library view, but only two of them are showing in your scene, only those two will 
be exported.  This keeps the sprite sheet as tight as possible. 

Animating Multiple Sequences
You will always have multiple animations for your characters.  For example, an idle sequence, a run sequence, an 
action sequence, and so on.  You need to work in a specific structure so you can export all of these animations to 
a single sprite sheet. 

There are two different work flows that you can use:

 l Workflow 1: Separate Scenes 

 l Workflow 2: Separating Using Scene Markers

Workflow 1: Separate Scenes  

First, create a scene file with the name of the character, such as Space Duck.  This is the file where you can 
create or import your game rig. In the top menu, select File > Save As New Version, and give this new version 
the name of the animation.  For example, Idle. 

Every time you need to do a new animation using the same character, perform a Save As New Version.  In the 
end, you may have something like this: 

Scene: Space Duck 

Versions: 
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 l Idle 

 l Run 

 l Jump 

 l Shoot 

When you run the export script, it will export the drawings from the current scene into the export folder.  It will also let 
you know if there are any other scene versions that were already exported to that folder.  If so, then it will recompile 
the sprite sheet to include all the drawings from all the animations. This allows the maximum possible reuse of 
drawings. 

Workflow 2: Separating Using Scene Markers

You can also create all of your character animations in a single scene, one after the other, such as idle, run, jump 
and shoot. Then use scene markers to mark and separate the individual animations, see—Creating Scene Markers 
on Frame Ranges on page 223

When you are marking individual animation frame ranges, be sure that they start and end with a keyframe. Do not 
create scene markers for a range of frames that starts or ends in the middle of an interpolated movement.

When exporting your sprite sheet, in the Export To Sprite Sheet dialog box, be sure to check the Use Scene 
Markers to Export Clips option.

The animated clips are divided and listed in the stage.xml in the same way that they would appear if you had 
exported each animated sequence from separate scenes to the same file location.
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Using the Harmony Game Previewer
If you are not a developer and would like to see if your animations and rigs will work once imported in Unity, you 
can use the Harmony Previewer application. You can visualize your characters in the Unity game engine with no 
programming required.

How to use the previewer on Windows

 1. Download the Harmony Game Previewer for Windows:

 l https://docs.toonboom.com/go/download/GamePreviewer-12-2-windows

 2. Extract the following to your hard drive:

 l GamePreviewer-[version].exe 

 l GamePreviewer-[version]_Data folder

 3. Copy your export from Harmony to this folder:

 l GamePreviewer-[version]_Data\StreamingAssets\HarmonyResources\

 4. Start the Game Previewer application.

 5. Select the export you want to preview.

How to use the previewer on Mac OS X

 1. Download the Harmony Game Previewer for Mac OS X:

 l https://docs.toonboom.com/go/download/GamePreviewer-12-2-mac

 2. Extract the GamePreviewer-[version].app.

 3. Right-click on the GamePreviewer-[version].app and select Show Package Contents.

 4. Copy your export from Harmony to this folder: Contents/Data/StreamingAssets/HarmonyResources/

 5. Start the Game Previewer application.

 6. Choose the export you want to preview
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About Export to Unity
If you have a custom game engine, you can take the exported Harmony data and proceed with your usual process.  
Or you can modify the export script to fit your convention.  

Before exporting a scene:

 l Be sure to set your Display as Display and not Display All.

 l Be certain to save your scene. Harmony makes the export based on the tvg files, any unsaved updates you 
have added will not be exported.

 l Set your Harmony scene to be a square resolution (ex. 1024 x 1024). Select Scene > Scene Settings.

The Transparency parameter attached to the element node is exported along with the animation. You can set the 
transparency through the Layer Properties window (Advanced tab).
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Clearing Scripts
If you were using Harmony 12.1 or earlier, it is strongly suggested that you clear your scripts before exporting 
animation for the first time. This will ensure there's no conflict with previous versions of the scripts and you have 
the most up-to-date script.

How to clear your scripts

 1. Close Harmony if it is open.

 2. Browse to the script folder location:

 l Windows:

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\Ap-
pData\Roaming\Toon Boom Animation\Toon BoomHarmony Essen-
tialsEssentials\1200-scripts

 l Mac OS X: 

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told 
down the Alt key.

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Prefer-
ences/Toon Boom Animation/Toon Boom Stage Essentials/1200-scripts

 3. Delete the 1200-scripts folder.

 4. Restart Harmony and test the export.
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Setting Anchors and Props
Before exporting to Unity, you need to set your anchors and props.

An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined by 
the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a helmet 
attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily 
swappable from within Harmony or Unity.

How to set an anchor

 1. Create a new Drawing layer and rename it according to the anchor you are creating.

 2. Inside the Layer Properties of your drawing layer, make sure that pivot option is set to  Don’t Use Embedded 
Pivot or Apply Embedded Pivot on Drawing Layer. The Apply Embedded Pivot on Parent Peg does not 
transition well to Unity and you will lose your pivot information.

 3. Once this is done, you can use any of the animation tools to reposition the pivot point of your layer, such as 
the Rotate tool in the Advanced Animation toolbar. You should be able to see the pivot coordinates from the 
Layer Properties of your Drawing layer. If the pivot is not repositioned, its default place will be at the centre of 
your Harmony scene (0,0).

 4. Once this is set up, select the Drawing layer and click the Toggle Anchor  button in the Game toolbar. You 
can also make a multi-selection to set an anchor on multiple Drawing layers simultaneously.

The Drawing layer is highlighted in red in the Timeline. Your anchor can now be used to attach a prop.

How to set a prop

 1. Create a new Drawing layer or take an existing prop on which you want to attach an anchor.

 2. Position the Drawing Pivot of the prop layer using a tool on the Advanced Animation toolbar, such as the 
Rotate tool. The position of the prop’s pivot will align with that of the anchor. Make sure it is positioned accord-
ingly.

 3. With the prop Drawing layer selected, click the Toggle Prop  button in the Game toolbar. You can also 
make a multi-selection to set a prop on multiple Drawing layers simultaneously.

The prop Drawing layer is highlighted in green in the Timeline.

 4. Do one of the following:

 l Connect the anchor and prop to the parent peg.
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 l Connect the prop under the anchor to create a parent/child hierarchy.
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Exporting Sprite Sheets
The Export to Sprite Sheets window export to multiple resolutions, generating multiple .xml files and one or multiple 
sprites sheets depending how many sprite resolutions you defined.

This saves different animations of the same character into the same name. For example, if there's an idle, run, and 
jump animation, these should all share the same Save Name. You can think of it as the overall collection of 
animations. Inside are the different saved scene versions whose drawings you can reuse for all the animations in 
that character set. Each scene version will be displayed as an item in the list.

When you export an animation, only the drawings used in that scene are exported. All the drawings are exported 
individually first and then atlased together into a sprite sheet.

If you saved multiple animations to the same Save Name (i.e. SpaceDuck: run, idle), then it will reatlas the sprite 
sheet to include all the drawings from all the animations in that folder, creating a new animation file, but reusing the 
same skeleton.

NOTE: 
Programmers may be interested to note that the XML data exported by Harmony can be converted afterwards to 
a more optimized binary data structure.  To convert XML to Binary format, use the Xml2Bin utility. This utility 
converts the XML data structure generated through the Toon Boom Harmony software to a compressed binary 
data structure. This utility is available in the gaming SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx:- Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you want to 
integrate with other game engines.

How to export sprite sheets

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Sprite Sheets  button in the Game toolbar.

The Export to Sprite Sheets window opens.

421



Chapter 10: Gaming in Harmony     About Export to Unity

 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If not, 
you can save anywhere, then transfer the animation into your Unity project, or any other game engine you 
want to use.

 4. Set your sprite sheet preferences, see—the Reference guide .

 5. Click Export.
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Exporting to Easel JS
The Export to Easel JS window lets you flatten an image sequence of your animation. Even if you have a fully rigged 
puppet or a single drawing layer with your animation sequence, the outcome will still be a flattened output of each 
frame, grouped together in your sprite sheet. This allows for more flexibility and freedom of work as you have access 
to any tools or effect modules you want to use. However, this can result in heavier files depending on the length, 
complexity and export size of your animation.

NOTE: 
Programmers may be interested to note that the XML data exported by Harmony can be converted afterwards to 
a more optimized binary data structure.  To convert XML to Binary format, use the Xml2Bin utility. This utility 
converts the XML data structure generated through the Toon Boom Harmony software to a compressed binary 
data structure. This utility is available in the gaming SDK under /HarmonySDK/Source/Utils/.

 l Utills/macosx:- Precompiled binary for Mac OSX.

 l Utils/win32:   Precompiled binary for Windows.

 l Utils/Xml2Bin:  Xml2Bin sources.

 l Utils/Xml2Bin/proj.mac/Xml2Bin.xcodeproj:  XCode project for Mac OSX.

 l Utils/Xml2Bin/proj.win32/Xml2Bin.sln: Visual Studio 2010 solution for Windows.

The C++ code that handles the data structure can be reused and parsed in your own code if you want to 
integrate with other game engines.

How to export to Easel JS

 1. Add the Game toolbar, by selectings Windows > Toolbars > Game.

 2. Run the script by clicking the  Export to Easel JS  button in the Game toolbar.

The Export to Easel JS window opens.
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 3. Set the Save Path to the correct folder in your Unity project if you want it to update automatically.  If not, 
you can save anywhere, then transfer the animation into your Unity project, or any other game engine you 
want to use.

 4. Set your sprite sheet preferences, see the Reference guide .

 5. Click Export.
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About Working in Unity
The Harmony Gaming Animation Guide is a basic guide on how to import Harmony projects and configure them, 
design and animate characters, and includes some tips. It is not meant as a guide on how to program games.
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About the Sample Unity Project
Toon Boom includes a sample Unity project that contains all the scripts necessary to import the data exported 
from Harmony.  Inside this project is an Assets folder which contains the following folders: 

 l Plugins 

 l Scenes (demo scenes and a previewer) 

 l Scripts (all Harmony scripts) 

 l StreamingAssets (this is where all the Harmony scene files should be exported to)

By configuring the Harmony script, you can automatically export animations into the StreamingAssets folder. 
This way, Unity will dynamically load the most up-to-date assets as soon as they appear in the folder.  You can 
also manually place exported Harmony data into this location.
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About the Unity Interface
Here are the main components of the Unity interface and their equivalents in Harmony:

Unity Harmony Description

Scene view Perspective view
This is where you set the scene, selecting and positioning 
environments, the player, the camera, enemies, and all other 
GameObjects. 

Game view Camera view
The rendered view from the camera(s) in your game. It is rep-
resentative of the final, published game. 

Inspector Layer Properties
Displays detailed information about the selected GameOb-
ject, including all attached Components and their properties.

Hierarchy Layers in Timeline view
Displays the hierarchy of elements in the scene, and lets you 
set up parent-child relationships for different game objects.

Project Browser --- Lets you access and manage a project's assets.

The main camera displays the scene and is located in the Hierarchy.  To show a Harmony object, you must add a 
special component.  With the main camera selected, in the Inspector, select Add Component > Scripts > 
Harmony Camera.
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Importing Harmony Files into Unity
Once you've finished creating your artwork and cyclable animated character movements in Harmony, it's time to 
import them into Unity for game integration.

How to import Harmony files directly into Unity

 1. Create a Unity 2D project.

 2. The SDK Harmony project needs to be imported to your project in order for the assets to be brought in. Do 
one of the following:

 l Go to the Unity Asset Store (assetstore.unity3d.com/en/#!/content/31211) and save the Harmony 
Game SDK file on your computer. Then import it in your project from the following: Top Menu > 
Asset > Import Package > Custom Package.

 l Search for the Harmony Game SDK in the Unity Asset Store, then download and import the pack-
age. You can access the Asset Store from the following: Top Menu > Window > Asset Store.

NOTE: For each new Unity project, you must repeat step 2 as it contains the necessary files and 
folders to make the Harmony import process work.

 3. Add the exported game object to the scene by going to Top Menu > GameObject > Harmony >

 l Harmony Object:  Lets you browse for the exported Harmony project folder.  If you’ve 
already saved this to your StreamingAssets folder, you can browse to it through 
there.  Then it adds the Harmony scene to your Unity file, and sets up the rendering, 
audio, and animation scripts you need to get going.

 l Harmony Texture Object: Lets you browse for the exported Harmony project folder 
similarly to Harmony Object, but creates a Unity plane to render your animation on it.
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About Game Objects
GameObjects are the fundamental objects in Unity that represent characters, props and scenery. Basically 
everything you create in Unity will be a GameObject.  There are two main types of GameObject you can use to 
import Harmony data: 

 l Create Empty

 l Create Other > Plane 

To understand the process fully, there are two examples using an empty GameObject and a plane GameObject with 
the SpaceCat demo file. Everything you do will be based on the GameObject you create to load your Harmony data.
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Using Empty Game Objects
An Empty Game object is a regular GameObject in which you can load the exported Harmony data.  All the 
individual body parts on the sprite sheet come in as separate elements, but are treated as one whole object with a 
dynamically created bounding box.  If you put a transparency on this object, you would see the overlapping 
transparencies of all the individual objects.  This creates a higher-quality render and should be the default if you’re 
not animating the transparency of an object.  With this option, direct rendering will read the depth information in the 
scene but not write it.  Note that with this option, the rendering cannot be customized. 

How to use an empty GameObject

 1. Select GameObject > Create Empty.  

 2. Rename the empty GameObject so it's clear in the Hierarchy. Since we're using the SpaceCat demo file, 
rename the GameObject to SpaceCat by doing one of the following:

 l Double-click on the name and rename it in the Hierarchy.

 l Select the GameObject and rename it in the Inspector. 

 3. At this point, it’s an empty object.  Accessing Harmony data is done through scripts.

 l Select the SpaceCat GameObject. 

 l In the Inspector, go to Add Component > Scripts > Harmony Renderer.

A new section appears in the Inspector called Harmony Renderer (Script).
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This will let you load an animation file.  You must put the path of the asset relative to the HarmonyResources 
folder.  Before this, you must export from Harmony directly to this folder, or manually copy and paste the data 
here.

 4. You exported a scene called SpaceCat.  In the Project Folder, place HarmonyResources/SpaceCat under 
the Transform information at the top, under Scale. Set the values to 0.01 for X, Y, and Z because the default 
Harmony project is for an HD screen.

 5. You won’t see anything until you define a few parameters:

 l Set the Clip Name Size to 1. A second field will appear, Element 0. 

 l Enter the clip name for the animation you want to load.

 6. Double-check on the right Clip Name to put in Element 0; you can check the output you exported from Har-
mony.  

 7. Double-check the stage.xml file, which was exported to the folder you specified when exporting from Har-
mony.  Our default export path is to StreamingAssets, so it will automatically load in the game engine.

 8. Look in the Project tab, under Assets > StreamingAssets > HarmonyResources > [ExportName]. 

You’ll find the data that was exported.  In this case, we’re looking for SpaceCat. Select the file marked stage 
to load the data you want to double-check. 

The text data appears in the Inspector.
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The name to use for loading the object is the stage name.  In this case, SpaceDuck_SpaceCatIdle.

 9. If your GameObject has animation in it, and you want it to load the animation data from the Harmony 
export, add one more component by doing the following:

 l Select the GameObject.

 l In the Inspector, select Add Component and select Scripts > Harmony Animation. 

 10. To loop the animation, you must set a GameObject to define it:

 l Select  GameObject > Create Empty and rename it: LoopAll.  

 l Click the LoopAll GameObject to display its properties in the Inspector. 

 l Click Add Component > Scripts > Loop All.   

When you play the animation, it will loop as it plays back. The Loop All command simply iterates on all 
GameObjects on runtime and asks them to loop, which is useful when testing the animation.  When 
programming the actual game, you should write additional scripts to control the different elements 
separately.
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Using Plane Game Objects
Renders the entire character to a plane. This renders your character to texture data.  If you animate the transparency 
of the plane, then the transparency of the rendered output is animated; you won't see the transparencies of the 
overlapping elements.  However, you will have one static bounding box the size of the plane that you render to. 

Use this option when you want to animate the transparency of a character in a scene.  Also, you can write your own 
custom shaders.  Simply set the Render Target to eRenderTarget.   You can see an example of this in the sample 
project DemoRenderTarget.  

 How to use a plane GameObject

 1. Select GameObject > Create Other > Plane.  

 2. Select Add Component > Scripts > Harmony Renderer. 

 3. Set Size to 1 and Element to 0 on the clip name as per previous instructions. 

 4. Set Render Target to eRender Texture.  

 5. Render Texture Viewport:  

 l X: To reposition the animation correctly; it should be -½ the width of your Harmony project.

 l Y: To reposition the animation correctly; it should be -½ the height of your Harmony project. 

 l W: Width of your Harmony project 

 l H: Height of your Harmony project.  

 6. Use the custom Shader created by Toon Boom to have a transparent background with premultiplied alpha 
channel.  This is what produces nice, antialiased drawings in your output.  

 7. With the Plane selected in the Inspector, go to Mesh Renderer > Materials. Under Element 0, select 
UnlitTransparentPremultiplied. 

 8. If you're starting with the Toon Boom demo project, this renderer should already be loaded in your list. 

You can also write your own custom shaders and use them here. 

 9. You must also add the animation component.  Select the Plane. In the inspector, click Add Component > 
Scripts > Harmony Animation.

Once your Harmony GameObject is imported, you should be able to see your character both in the Scene and the 
Hierarchy views. From here you can attach one or several props to an anchor.

433



Chapter 10: Gaming in Harmony     About Working in Unity

Attaching Props to Anchors in Unity
An anchor is an attachment point you can use to bind one or several props to a specific location that is predefined 
by the anchor.

A prop is a game item that will be attached to an anchor. It could be a stick held within the character’s hand, a 
helmet attached to the character’s head...the possibilities are endless. Props are easy to turn on or off, and easily 
swappable from within Harmony or Unity.

How to attach the prop to an anchor

 1. Open up your character in the Hierarchy view to have access to both the props and the anchors. 

 2. Click on the prop you wish to attach, and drag it onto the appropriate anchor. 

 3. Repeat these steps for each prop and anchor in your project.

 4. In the Inspector view, under Frame, you can select which frame you wish to show. If you only had one 
drawing in your prop, then you will not have multiple options.
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 5. If part of your character is cut off by the plane of the character, now that the props are showing, you will need 
to regenerate the mesh. To do so, select your GameObject. After this is done, go to Inspector View 
> Render > Generate Mesh.
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Placing Locators in Unity
In Unity, it's possible to assign a target to some part an imported Harmony animation.  For example, in the Space 
Duck scene, the character has a gun. You may want to attach some other action to this animated gun, such as 
shooting spheres and cubes out of its end. For this, you need to place a locator at the end of the gun. 

You can see some examples of this in the provided Unity project.  The first example is in the demo scene 
DemoLocator,  which shows a simple cylinder attached to the end of the gun. 

The second example DemoCallback shows the gun shooting spheres and cubes.

You can access any drawing layer created in Harmony later in Unity and use its pivot point to attach objects and 
animated sequences. In Harmony, you should set the pivot points on your drawing layers with the Rotate tool.

You can also create an empty drawing layer in Harmony, when setting up your character, to be used later in Unity. 
Use Create Empty Drawing to create a blank drawing, then use the Rotate tool to set the pivot point on this 
drawing layer.  In the Space Duck example, an empty drawing layer called hook_gun was created on which you 
can attach the locator in Unity. 

When you access the imported Harmony character in Unity, you can access the data with a script.  

How to set a locator to a part of a character

 1. Select Game Object > Create Empty to add a new GameObject to extract the target's position, rotation, 
and scale. 

 2. Drag and drop the new object so that it's a child of the character. 

It becomes indented.  

 3. Rename the GameObject to: Hook Gun.

 4. In the Inspector of the target object, select Add Component > Scripts > Harmony Locator.

 5. Enter the name of the drawing layer to which you want to attach.

 6. To find the exact name for the Locator Name, look at the skeleton.xml file in the Streaming Assets 
folder.  You can find it in Streaming Assets > Harmony Resources > Name of Harmony File > skel-
eton.
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All the drawing and peg layers are listed. In this example, look for  space_duck_hook_gun. Having drawing 
layers with distinctive names makes them easy to recognize when you need to retrieve them.

You can copy the name of the layer into the Locator Name to see the Transform information updating 
dynamically as you run the simulation.

 7. Now you can attach anything as a child of this Locator Object.  For testing purposes, you could attach a cyl-
inder for example.  In a real example, you’d want something to shoot out of the end of the gun, so you can see 
the Callback example to verify how that works.
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Setting Up Collisions in Unity
Extracting the bounding box information is useful when you want to make something collide with your character.  
When you put a 2D character into a 3D scene, you may want to use Physics to make the 2D character collide 
with the 3D plane.  To use the following scripts, you will need Unity 4.3 or higher. 

In the Demo scene, open the DemoPhysics example to see collisions and bounding boxes.  In this example, 
there’s a 3D plane and some 2D characters.  The 2D characters have a collision defined with their bounding box, 
and they're also reacting to the physics of the scene to fall with gravity. 

Colliders were improved to provide several different types of colliders for use in Unity. You can select polygon 
colliders and box colliders for a more accurate bounding box.

How to set up collisions

 1. Select your imported character.  

 2. In the inspector, select Add Component > Physics 2D > Box Collider 2D.  

 3. To enable the Physics on the character, go to Add Component > Physics 2D > Rigid Body 2D.  

NOTE: You can also use 3D physics on the imported files. 

You can now adjust the variables and see the results.
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About Working with Audio in Unity
When you create scene files in Harmony with audio, the audio is exported into the project folder.  However it’s 
important to understand how the game is built to determine the best way to handle audio.  

When a game is built from Unity, it creates its own database for holding the assets.  Within the export, the Streaming 
Assets folder is preserved intact.  This is what enables the Toon Boom plugin to access those assets on the fly, and 
render them in the camera to create the final animation you see on the screen. 

However when it comes to audio, the game first looks for the audio in the Unity database. So this is the most 
efficient place to store the audio for the real game.

If audio can't be found in the Unity database, then the game looks in the Streaming Assets folder to find the audio.  
When it does, it copies the audio on-the-fly back into the Unity database.  Since this action is quite costly, don’t 
leave the audio in the Streaming Assets folder for the final game.  It’s fine to leave it there while you’re testing, but not 
for the final game.  

The audio should be copied back into the Unity database, either manually or by automating this process with a 
script.
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Chapter 10: Troubleshooting
Unity Questions

Q. My Harmony asset does not appear in the Unity Editor.

A. There are several possible reasons for this. Check the following:

 l Has the HarmonyRenderer plugin been copied to the Assets/Plugins directory?  The plugin is 
named HarmonyRenderer.bundle on Mac OS X and HarmonyRenderer.dll on Win-
dows.

 l Is the clip name valid ? Make sure the clip name exists in the stage.xml file.

 l Are the binary files up to date? If you updated the Toon Boom Game Engine SDK to a newer 
version, make sure to regenerate the binary files if you use them so they’re compatible with 
the SDK.

Q. My Harmony asset does not appear in iOS or Android when exported from Unity.

A. There are several possible reasons for this. Check the following:

 l Make sure the Harmony assets are copied in the StreamingAssets directory. Since the 
HarmonyRenderer plugin cannot use Unity’s asset database, the Harmony assets were 
packaged as plain files so they are accessible to the plugin.

 l Is the plugin for iOS the same version as the one used for the editor? The plugin for iOS is in 
the Assets/Plugins/iOS directory.

 l Is the clip name spelled correctly? Windows and Mac OS X aren’t usually case sensitive file 
systems, but iOS and Android are. This implies that an asset that is visible on the editor will 
not appear on the mobile platform because it cannot be found.

 l Make sure the size of your sprite sheets does not exceed the hardware limit of the device 
you're working on. Otherwise, the texture might not appear at all.

 l Is the path to the project folder an absolute path? If it is, it might not work on the mobile 
device as that path will not exist on the platform. Make sure to use relative paths to the 
StreamingAssets directory.

Q. My Harmony asset does not composite properly with other 2D sprites in Unity. The 2D sprites always appear 
behind the Harmony assets even if I change the order index in the GameObjects.

A. The 2D sprites from Unity and the Harmony assets cannot currently composite together. There are, however, 
several solutions for working around this problem:

Use 2D textures instead of 2D sprites. The 2D textures, when attached to a geometry in Unity, will composite 
like the other 3D elements in the scene and you can change the compositing order by incrementing or 
decrementing the Z value of the transform.

Use multiple cameras to render your scene in parts. Here’s how:

Harmony Camera

 1. Create a new camera.

 2. Make sure you set the Harmony GameObjects to a specific layer (top-right of the game object inspector).
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 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in the background).

 4. Add the HarmonyCamera component to this camera so the Harmony GameObjects render properly.

Sprite Camera

 1. Create a new camera.

 2. Make sure to set the 2D sprite objects to a specific layer.

 3. In the camera, set the culling mask to this layer (and the other layers you want rendered in front of the 2D 
sprites).

 4. Make sure to set the clear flags to Depth Only or Don't Clear.

 5. Set the depth to be higher than the Harmony camera.

 6. Afterwards, if you move the camera, make sure to move both cameras simultaneously if you want to keep 
Game Ojects in sync.

Q. How can you specify the frame rate of the animation?  My animation does not play at the same frame rate in 
Harmony and in the Game Previewer in the Unity Editor.

A. The Game Previewer previews the animation at a default of 24 frames per second. In your game, using the 
HarmonyAnimation component, you can schedule animations at the speed you want.

Example

HarmonyAnimation animation = GetComponent<HarmonyAnimation>();

if (animation != null)

{

animation.PlayAnimation( frameRate, clipName );

}

Q. I cannot see my character in the Scene view in Unity. Is there any way to preview the Harmony asset?

A. Since the rendering of Harmony assets is implemented in a plugin, it does not update any Renderer component in 
the GameObject, and so cannot be shown directly in the Scene view.

However, you should still be able to preview your assets in the Game view (even when not playing).   To help find and 
position assets, we also added bounding box shapes rendered in the editor and the Game view.

Q. How is memory management handled in Unity for Harmony assets?

A. Most of the memory extensive algorithms are executed in the C++ plugin.  The data structure is maintained alive 
as long as a GameObject refers to it.  This means you can instantiate as many clones of a character without 
reloading the data. Upon destruction, the GameObject will issue a clean-up call to the plugin and delete its 
associated rendering object. The sprite sheet and animation data are kept alive as long as a single GameObject 
uses them and a cleanup call is issued once they are destroyed.

Q. The Harmony assets memory does not appear in the Unity profiler.  Can we profile the assets memory?

A. The Unity profiler does not pick up Harmony assets in its traces. Since the Harmony GameObject refers to a C++ 
plugin for its asset management and rendering, its memory cannot be recorded in the profiler. Profilers such as the 
one provided with XCode or Visual Studio should allow you to track your application’s memory including the 
Harmony assets and should also provide a more accurate result.
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General Questions

Q. How can you specify the resolution used for the drawings in the sprite sheet?

A. The drawing resolution is not fixed in Harmony.  Since you're exporting the scene to multiple sprite sheets in 
multiple resolutions, every drawing will have a different resolution in the end. You can use the Drawing view to 
see the resolution of a drawing compared to the rest of the scene.  By enabling the light table in the Drawing view, 
you will see all of the scene’s drawings untransformed in the same proportion as they will appear in the sprite 
sheet. More specifically, the resolution used in the sprite sheet for a drawing is the size it appears untransformed 
in the Camera view, scaled to the sprite sheet resolution ("Sprite Resolutions" in the Export Sprite Sheet dialog 
box).

Once you know that, you can easily adjust the size of a single drawing. Use the Select tool to scale down a 
drawing and use the Transform tool to scale it back up so it does not change visually in the Camera view. This 
should allow you to alter the size of drawings in the sprite sheet.

Q. The assets take time to load on mobile devices. Is there any way to speed up the process?

A. Harmony exports an interchange XML format that is intended to be compatible with multiple game engines. 
However, reading data from the XML files is slow and this is mostly intended to test the assets in your project. At 
some point, they should be converted to a binary compact data structure that can be read into memory a lot faster 
than the XML.

You can use the Xml2Bin tool provided with the game engine SDK to convert your XML files to binary. This tool is 
in the Utils/Xml2Bin folder and a precompiled version for Mac OS X is available in the Utils/macosx folder.

Q. There are problems with the character I exported in the game engine. Pieces are not exported or are not 
showing in the proper order. What can I do ?

A.  To integrate with the game engine SDK, all animations in Harmony must follow certain guidelines. Here are 
some of the key points for building a character that is compatible with the rendering in the game engine SDK:

 l Build your rig in the Timeline view. The game engine SDK data structure is similar to what is 
displayed in the Timeline view and an advanced node system might not always export prop-
erly.

 l Because every top level node in your scene will render separately in the game engine SDK, 
they may not intersect. A top level node is also isolated in its separate sprite sheet to allow 
the artist better memory segmentation of the character. If you created a character with top 
level nodes and this was not the intended result, create a top level group or peg to group 
them all together.

 l Use micro-Z ordering if necessary. With no Z ordering, a child layer will appear behind its par-
ent (as it does in Harmony).  To change the ordering, add some Z offset to the child layer.

 l The export script does not handle plain bitmap images.  Toon Boom vector drawings and 
Toon Boom bitmap drawings are supported though.

 l The export script does not handle symbols.
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Chapter 11: Library
T-RIG-009-001

Using templates and symbols, you can share and reuse any elements you create in Harmony. The Harmony library 
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact, 
anything you create in Harmony can be stored in the library.

The Library view is where you can store and reuse your artwork and animation in other scenes or build props and 
puppets.

The library is a storage centre for all production assets; the elements stored in the library are called templates. 
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation 
processes. The library can contain any asset used in a Toon Boom Harmony production. 

Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to the 
Timeline or Camera view when you want to reuse it.

Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's 
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's 
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from. 
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About Structure
As you will probably create a large number of symbols and templates, you will soon realize they need to be 
organized. You can create different libraries and subfolders to easily access your assets. For example, you can 
create a different library for each project and divide it into several categories, such as:

 l Characters

 l Props

 l Backgrounds
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Creating Libraries
There are two ways to create libraries. 

 l Directly through your operating system

 l Using Harmony's interface

Although you can only have one symbol library folder, you can organize it by creating subfolders.

How to create a library folder through your operating system

 1. On your computer, create a new folder with a relevant name in the location where you want the library to be 
stored.

How to create a library folder in Harmony

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse for the location where you want to store your new library folder.

 3. Click the New Folder button.

A new folder appears.

 4. Name the new library folder with a relevant name and click OK.

The new library appears in the Library List section.

445



Chapter 11: Library     Opening Libraries

Opening Libraries
Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as 
a library. Opening a library means linking the folder to your Library view. You only need to open the library once. 
The library folder is available every time you open the application until you decide to close the library and unlink it.

How to open a library

 1. In the Library View menu, select Folders > Open Library.

The Browser window opens.

 2. Browse to the location of the library folder.

 3. Select the folder and click OK.

The new library appears in the Library Folders section.
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Closing Libraries
You may not always require all the library folders in the Library List. If so, you can close the ones you do not need. 
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your 
hard drive or network and open it in the Library view.

How to close a library

 1. On the right side of the Library view, select the library folder to close.

 2. In the Library View menu, select Folders > Close Library.

The library closes.
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Creating Folders
T-ANIMPA-003-009

Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in 
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library 
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right 
to modify it before being able to add a new folder to it.

How to create a folder

 1. On the left side of the Library view, select the library folder to which you want to add a subfolder.

 2. In the Library View menu, select Edit > Right to Modify.

 3. In the Library View menu, select Folders > New Folder.

The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] 
sign to expand it.
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Deleting Folders
You can delete a folder from the library if its contents are no longer needed.

NOTE: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the data can-
not be retrieved.

How to delete a folder

 1. In the Library view's left side, select the folder to delete.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select Right 
to Modify.

 3. In the Library View menu, select Folders > Delete Folder or press Delete.
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Renaming Folders
Once you add a folder, you can rename it. This also renames the folder on your hard drive.

How to rename a folder

 1. In the Library view's left side, select the folder to rename.

 2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select 
Right to Modify.

 3. In the Library View menu, select Folders > Rename Folder.

 4. Rename the selected folder.

 5. Press Enter/Return to validate the operation.
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Refreshing Libraries
If you update the content of your libraries through your operating system, you will need to refresh your library folders 
in the Library view.

How to refresh a library

 1. In the Library view's left side, select the folder to refresh.

 2. In the Library View menu, select Folders > Refresh or press F5.

The library displays the new content.

451



Chapter 11: Library     Generating Thumbnails

Generating Thumbnails
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for 
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.

How to generate thumbnails

 1. In the Library view's right side, select the template in which you want to generate thumbnails.

 2. In the Library View menu, select View > Generate Thumbnails.

The progress bar appears.
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Deleting Thumbnails
You can also delete thumbnails if you want to send a template to another user or studio and keep your packages 
small.

How to delete thumbnails

 1. In the Library View menu, select Edit > Delete Thumbnails.

All the thumbnails contained in the library are removed.
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Searching in Libraries
When working on a movie or series, you will probably end up with many templates and symbols in your library. 
Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool

 1. From the left side of the Library view, select the library in which you want to search.

 2. In the Search field, type the name or partial name of the symbol or template you are looking for.

 3. Click the left  and right  arrows to see the previous and next results. The Search engine will look for 
results within the library master folder and its subfolders. It will not look in other libraries.
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About Templates
When you want to reuse artwork and animation from your project in other scenes, you must create a template. A 
template can be seen as a portable scene or package that you can drag inside your project. A template is an 
individual copy of the artwork stored in the library which you can reuse in different scenes. Once a template is stored 
in the library, you can access it from any project.
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Creating Templates
T-ANIMPA-003-010

You can create a template using the Timeline view.

NOTE: If you are creating a template from a character rig master template, you should collapse everything 
inside a master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Timeline view

 1. In the Timeline view, select some cells or layers. 

You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting the 
root layer. This can be useful for creating templates based on character rigs or scene backgrounds.

 2. In the Library view, select a folder to store the template. By default, a local scene will have a Harmony 
Essentials Library folder, which is stored in your Documents folder. 

 3. If the library folder is locked , right-click and select Right to Modify.

 4. Drag the selection to the  chosen library folder. 
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 5. In the Rename dialog box, give the new template a name.

 6. Click OK.

NOTE: To rename a template once it is created, right-click on the symbol and select Rename, or double-click 
on the template's name.
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Deleting Templates
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary. 

How to delete a template

 1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Delete or press Delete.
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Editing Templates
You can open a template and edit it just like any other project. If you want modify your templates, you can edit them 
using the Edit Template command.

How to edit a template

 1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

 2. Right-click on the selection and select Edit Template.

A new Harmony application opens.

 3. Edit the template.

 4. From the top menu, select File > Save.

 5. In the top menu, select File > Quit (Windows/Linux) or Harmony Essentials > Quit (Mac OS X).
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Importing Templates
There are several ways you can import templates in your scene.

For greater control over how the action template behaves when brought into the Timeline view, you can use the 
Paste Special feature—see Using Paste Special on page 476.

NOTE: Dragging a template into your scene copies the content in your Timeline and does not link it to the ori-
ginal. You can modify this individual copy at any time.

How to import a template into the Timeline or Camera view

 1. In the Library view, select the template you want to import.

 2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If you 
drop a template in the layers list in the Timeline view, it will be inserted between the layers where you 
dropped it. 

If your template has the same layer structure as a part of your scene, you can drop the template directly 
onto the frames on the right side of the Timeline view. Instead of inserting new layers into your scene, this 
will replace the drawings and keyframes in your scene with the ones from the template. This is useful for 
importing pose or animation templates for characters that are already in your scene. 
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How to import a template with symbols

 1. From the right side of the Library view, select the action template that contains symbols.

 2. Hold down Alt as you drag it from the Library view to the right side of the Timeline view and drop it next to a 
template with the exact same rig.

The Paste Special window opens.

 3. Select the Advanced tab.

 4. Select one of the following options from the Symbols menu:

‣ Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols 
in an action template from being copied.

‣ Duplicate symbols: Makes copies of the symbols in your template.
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Opening Templates as Folders
Since a template is like a scene, you can open the template's folder and select elements inside it such as 
drawings. 

Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In 
this case, use the Open As Folder command to import the items you want. 

If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.

How to open a template as a folder

 1. In the Library view, select the folder that contains the template to open. If the library folder is locked, right-
click on the folder and select Right to Modify.

 2. Right-click on the selection and select Open As Folder.

 3. In the library list section, click on the template's folder to display its content.

 4. Drag the content to the Timeline or Colour view.
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About Symbols
A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain artwork 
and animation and manipulate them as a single object. You can also use symbols as a placeholder in which you 
place a series of different drawings for each body part of your puppets or when you have a repeating cycle. However, 
symbols are not necessary for creating characters. 

When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest many 
symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the Editing stack 
at the top of the Camera view which displays the path to your symbol's location. You can click on the symbol's 
name to move up the chain.
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Creating Symbols
A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can 
also create symbols out of each body part in your cut-out puppets.

To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into 
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the 
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.

How to create a symbol from the Timeline view

 1. In the Timeline view, select the layer or cells from which your want to create a symbol.

 2. Do one of the following:

‣ From the top menu, select Edit > Create Symbol. 

‣ In the Edit toolbar, click the Create Symbol  button.

‣ Press F8.

‣ Drag your selection to the Symbol folder in the Library view.

The Create Symbol dialog box opens

 3. In the Enter Symbol's Name field, type the new symbol's name.

To rename a symbol once it is created, right-click on the symbol and select Rename.

 4. Click OK.
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The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the new 
symbol. The new symbol only appears in the library. You must drag it into your scene to use it.
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Creating a Symbol from a Drawing
You can create a symbol from a drawing selection.

How to create a symbol from a drawing selection

 1. In the Tools toolbar, select the Select  or Cutter  tool.

 2. In the Camera view, select the drawing elements to create a symbol.

 3. From the top menu, select Edit > Create Symbol or press F8.

‣ Clicking the Create Symbol  button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.

 4. In the Symbol Name field, type the name of the symbol.

‣ You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol 
on the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new 
layer.

 5. You can choose to place the current selected artwork in the drawing or remove it:

‣ To remove currently selected artwork from the drawing and place it in the new symbol, select the Cut 
Artwork From Source Drawing option. 

‣ To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut 
Artwork From Source Drawing option.

 6. Click OK.

The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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Creating Empty Symbols
You can create a symbol without any artwork in it.

How to create an empty symbol

 1. In the Library view, select the Symbol folder.

 2. Do one of the following:

 l In the Library view's right side, right-click and select New Symbol. 

 l From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.

The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top  
button in the Camera view.

To rename a symbol once it is created, right-click on the symbol and select Rename.
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Deleting Symbols
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the data. 
The symbol cannot be retrieved once you close the application.

How to delete a symbol

 1. In the Library view, select the symbol to delete.

 2. Right-click and select Delete or press Delete.

‣ If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol 
from the library and scene.
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Editing Symbols
You can either edit a symbol from the Timeline view or from the Library view.

When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in 
the position where they were created. The pivot is translated at the centre of the symbol.

How to edit a symbol from the Timeline view

 1. Do one of the following:

‣ In the Timeline view, double-click on the symbol's cell to edit the symbol. 

‣ In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘  + E (Mac OS 
X)). 

‣ Click the Edit Selected Symbol  button in the Camera View toolbar's extra buttons.

You are now inside the symbol and you are able to edit it.

 2. Do one of the following:

To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift 
+ E (Windows/Linux) or ⌘  + Shift + E (Mac OS X). 

‣ In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view

 1. In the Library view, select the symbol to edit.

 2. Right-click and select Edit > Edit Symbol or double-click on the symbol.

You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top  button in the Camera view's top-left corner, press  Ctrl + Shift + E 
(Windows/Linux) or ⌘  + Shift + E (Mac OS X). 
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Importing Symbols
There are several ways you can import symbols in your scene. 

When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If 
you import a symbol into your scene several times in the Timeline view, they will all be linked to the original 
symbol. If you modify one, they will all be modified. 

How to import a symbol in the Timeline view

 1. In the Library view, select the symbol you want to import.

 2. Drag the selected symbol to one of the following:

‣ The Timeline view's left side to import it into the centre of the camera frame.

‣ The Camera view to place it at the location where you release your cursor.

NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them 
into the Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would 
be more efficient to arrange them into their correct places as you bring them into the scene.

Expanding Symbols
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The 
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline. 
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer 
that contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may 
have created.

You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you 
expand the symbols, the layers will be contained in a group node that you can expand to see the content.

How to expand a symbol

 1. In the Timeline view, select the symbol to expand.

 2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

472



Harmony 14 Essentials - User Guide

How to expand a symbol in a group

 1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

 2. From the top menu, select Edit > Expand Selected Symbol in a Group.

 3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand 
Arrow to enter the group.
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Converting Symbols to Templates
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content 
in another scene, you must create a template. This conversion breaks the drawing's link with both the original 
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to convert a symbol into a template

 1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline 
view.  If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the 
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.

 2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other 
library folder. Make sure you have the right to modify the library folder.
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 3. In the Rename dialog box, rename the new template.

 4. Click OK.

Importing Files in the Library
Harmony lets you import sound files and images directly through the Library view. Simply open the folder containing 
your files in the Library view and drag them directly from there.

How to open a file through the Library

 1. In the Library view menu, select Folders > Open Library.

 2. Browse for the folder containing the files you want to import.

 3. Click Open.

 4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You 
can choose to import only the keyframes without the drawings or import only the drawings that are not already in 
your layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your 
scene, its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames 
will be exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to 
adjust the import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each 
time you import a symbol in the Timeline view’s right side until you set new parameters.

How to open the Paste Special dialog box

 1. In the Library view, select the symbol or template to import.

 2. Press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X) and drag the selection to the Timeline view.

NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.

 3. Set the parameters—see the Reference guide .

 4. Click OK. 
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Chapter 12: Cut-out Animation
Harmony provides some great tools for rigging and animating cut-out character models. You can make simple  rigs or 
give your characters flexible capabilities using peg hierarchies, groups, cutters, and deformers, among other things. 
You can create basic animations with the Transform tool, or more advanced animation with Deformers. Harmony 
also supports onion skin and image swapping features to help you animate efficiently and quickly. 
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About Animating with the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool has many 
useful functions: 

 

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each piece from 
their own pivot point. They are compositing tools. The Transform tool creates a global selection, so when many 
parts are selected, you can move them as one unit. The Transform tool is highly recommended for cut-out 
animation.

When animating with the Transform tool, make sure to select the right selection mode. In this example, make 
sure that the Peg Selection  Mode  is disabled in the  Tool Properties view or it will limit the selection in the 
Camera view to pegs only.
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If there are hierarchy connections in the cut-out character, the Transform tool will also be used as the Forward 
Kinematics equivalent. 
The Transform tool can be used on any kind of rigging.

When many parts are selected with the Transform tool, the first selected part's pivot will be used as the global 
selection's pivot. This pivot can be moved temporarily for the animation. When you offset the pivot, the permanent 
pivot is displayed as a ghost. 

NOTE: The interpolation of the animation poses is always calculated from each individual part's permanent 
pivot. If there's a parent peg on a limb, make sure to select it instead of making a selection of each part to avoid 
setting individual keyframes.
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Animating with the Transform Tool
The Transform tool allows you to move, rotate, scale and skew a selection or multi-selection. 

How to animate using the Transform tool

 1. In the Tools toolbar, click the Transform  tool or press Shift + T.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Timeline view, go to the frame on which you want to set the first position.

 4. In the Timeline toolbar, click the Add Keyframe  button or press F6. It is recommended to add a key-
frame before moving the character. Moving a character's part without setting a keyframe will create key-
frames only on certain parameters of the animation. You could run into issues later on when setting poses 
between existing ones. Creating a keyframe on all layers and parameters will ensure your pose is set and 
will not be modified by other poses later on.

 5. In the Camera view, select the element to animate and move it.

 6. In the Timeline view, go to the frame where you want to set the next position.

 7. In the Timeline toolbar, click the Add Keyframe  button or press F6.

 8. In the Camera view, animate the character.
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Resetting Transformations
With the Reset command, you can return a selected element to its initial position and scale values, depending on 
which tool is active. For example, if the Rotate  tool is active, the transformation angle will be reset to 0 and if the 
Transform  tool is active, then all transformation  values will be reset.

The Reset All option Resets all transformations on the current frame in a selected layer. Your keyframe will remain, 
but all the values will return to the starting value. All transformations are reset regardless of the tool you're using.

The Reset All Except Z option resets Resets all transformations on the current frame except the Z position. This is 
useful when doing cut-out animation. Cut-out puppets often have a particular Z ordering for the different views of a 
character. You might want to reset the transformation, but not necessarily the Z position. 

NOTE: When using the Transform  tool to select elements in the Camera view, always make sure the Peg 
Selection Mode  option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were 
created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all keyframes and 
reset all values for the entire layer.
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 l In the Timeline View menu, select Layers > Clear All Values. This will remove all key-
frames and reset all values for the entire layer.

The selected layers return to their original position.
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About Hierarchy Navigation
If there is a layer hierarchy in the puppet you built, use the keyboard shortcuts to travel up and down the parent-child 
chain. You can navigate between the children of the same parent. You can also easily center on your selection in the 
Timeline view.
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Navigating Layers
Navigate between the layers in the Timeline view, using keyboard shortcuts or the Animation menu. This way of 
navigating only works for unparented layers or the children of a parent layer. If you are navigating between 
unparented layers, parent layers can be selected, but their children will be skipped. If you start on a parented layer 
(child), only the other children of the same parent will be available for selection.

How move up and down the layer stack

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Camera or Timeline view, select an unparented layer or child layer of a parent with several children.

 3. From the top menu, select:

 l Animation > Select Previous Sibling or press / to select the previous child layer.

 l Animation Select Next Sibling or press ? to select the next child layer. 
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Selecting Parent and Children
When animating, large movements that are made at the root (parent) of a chain cause secondary movements 
throughout the rest (children) of the chain. For example, when you rotate the arm of a character from the shoulder, 
the forearm and hand will follow. However, in order to make the movement appear natural and graceful, the forearm 
and hand should not move at the same speed or angle. As a result, animators often need to move up and down a 
chain, intermittently selecting parent and children, in order to make both large and fine movements.

How to select the parent or child of the selected layer

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  mode  is deselected.

 3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

 4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select Anim-
ation > Select Child or press Shift + B to select the child layer or Animation > Select Children to select all 
child layers at the same time.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. In the Timeline view toolbar, click the Centre on Selection  button  or press O.
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About Keyframes
Keyframes are the building blocks of Cut-out animation. Unlike Traditional animation, where every pose is drawn, 
Cut-out animation uses keyframes to mark major poses (key poses) and lets the software create all the poses in 
between.

In Harmony, you can create two kinds of keyframes: Motion and Stop-Motion. Motion keyframes behave like the 
description above; they allow for the automatic creation of drawings between two keyframed poses. Stop-Motion 
keyframes do not allow for interpolation between keyframes. They are often used to block poses, somewhat similar 
to what you would see in Traditional Animation.
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Creating Motion Keyframes
After you have created the key poses, you can animate the in-between poses yourself or let Harmony do it using 
motion keyframes. When you use motion keyframes, the drawings gradually move to the next position instead of 
staying on the spot until the next keyframe.

How to  create motion keyframes

 1. In the top menu, make sure the Animation > Stop-Motion Keyframe option is disabled.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click on the selection and select Insert Keyframe. 

 l Click the Add Keyframe  button in the Timeline toolbar.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected ele-
ment, a keyframe will be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe

 1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.

488



Harmony 14 Essentials - User Guide

 2. Do one of the following:

 l Right-click on the selection and select Set Motion Keyframe. 

 l Click the Motion Keyframe  button in the Timeline View toolbar.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X).  

 

489



Chapter 12: Cut-out Animation     About Keyframes

Creating Stop-motion Keyframes
To start animating your character, start by doing your key poses. In fact, most of your time will be spent doing key 
poses. It is better to work with stop-motion keyframes so Harmony does not automatically create the interpolation 
between your keyframes.

When using stop-motion keyframes, also known as step keyframes, the segment between two keyframes is 
constant. There is no animation generated by the computer between the poses. The drawing remains in position 
until the next keyframe, then moves to its new position.

How to create stop-motion keyframes

 1. In the top menu, make sure the Animation > Stop-motion Keyframe option is selected.

 2. In the Timeline view, select the cell on which you want to add a keyframe.

 3. Do one of the following:

 l Right-click and select Insert Keyframe. 

 l In the Timeline toolbar, click the Add Keyframe  button.

 l Press F6. 

 l In the Camera view, if the Animate mode is enabled, as soon as you move the selected ele-
ment, a keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe

 1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes or press S.

 2. Do one of the following:

 l Right-click and select Set Stop-Motion Keyframes. 

 l In the Timeline toolbar, click the Stop-Motion Keyframe  button.

 l Press Ctrl + L (Windows/Linux) or ⌘  + L (Mac OS X). 
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About Swapping Drawings
T-RIG-004-001

Cut-out animation is not only about moving parts around. It's also about swapping drawings to give the animation 
a more traditional animation look. You can add as many new drawings as you want in your scene and use them in 
your current animation. You can also add new drawings to the library and  use them in other scenes. But before 
starting to swap drawings, it's important to understand how keyframes, exposure and key exposure work in 
Harmony:

 l Keyframe: A keyframe is a point in time where a change to the properties of the object or character 
occurs. In Harmony, keyframes consist of the coordinates that determine how an entire layer and its con-
tents are moved. Keyframes include these parameters: XYZ position, skew, scale, angle and pivot.

 l Exposure: Exposure is a property; it is the length of time that a drawing is visible over a series of frames. 
In Harmony, exposure is independent of keyframes. That is, keyframes are not linked to drawings. Key-
frames can be moved independently from the drawing exposure. 

 l Key Exposure: A key exposure in Harmony is a type of exposure that forces a drawing to remain exposed 
on a specific frame. If a drawing is exposed before a key exposure and you swap out that drawing for 
another one, then the original drawing is retained. This preserves the key drawing. Note that Harmony auto-
matically sets a key exposure when you perform a drawing swap.

When you want to swap drawings, you can do so in the Timeline or Library view. In the Timeline view, the 
Parameters area is where you can select a drawing to swap. In the Library view, the Drawing Substitution window 
lets you see the drawings before selecting one for swapping. In this view, you are actually selecting drawings in 
your scene layers, not drawings in the Library.

NOTE: Keep in mind that when you swap a drawing, its entire exposure is replaced up to the next drawing 
exposure.
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Swapping Drawings in the Timeline View
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different. If 
you are using the Parameters area of the Timeline view to select a drawing to replace a selected frame range, the 
new drawing will replace the frame range and continue until the next key exposure. In the following example, drawing 
2 (DR2) is replaced by a new drawing, starting at the beginning of the selected frame range and ending at the next 
key exposure.

How to swap a drawing in the Timeline view

 1. In the Timeline view’s right side, select the cell containing the drawing or symbol cell to swap.

 2. In the Drawing Substitution field, position the pointer over the value and drag left or right to change the cell or 
drawing exposed for another one. You can also type in the drawing name or symbol’s cell number if you know 
it.
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Swapping Drawings in the Library View
When selecting a certain frame range to be swapped, the behaviour of the Timeline and Library views is different. 
If you use the Drawing Substitution window in the Library view to select a drawing, the drawing is split in two and 
the exposure before and after the frame range remain the same. In the following example, drawing 2 (DR 2) is split 
in two and the selected frame range is filled with a new drawing.

How to swap images in the Library view

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Transform Tool Properties view, make sure the Peg Selection  button is deselected.

 3. In the Camera view, use the Transform  tool to select a part of the drawing to swap.

NOTE: You can swap the frames in symbols or the drawings in a layer. However, you cannot swap one sym-
bol for another.

 4. In the Timeline view, select the cell range in which you want to swap the drawing.

 5. In the Library view, go to the Drawing Substitution window.
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 6. Scroll through the symbol's frames or drawings by doing one of the following:

‣ From the top menu, select Animation > Substitute Drawing Previous or Substitute Drawing Next.

‣ Drag the slider left or right. 

‣ Press +.  

The drawing or symbol’s cell on the current frame is replaced.
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Adding Key Exposures
If there is a particular drawing you want to keep on a specific frame, you can set it as a key exposure. This 
prevents it from be overwritten by a drawing swap on a preceding frame. A key exposure is simply a property of 
an exposure that forces it to be exposed on a certain frame regardless of whether the previous exposure is the 
same drawing or not.

NOTE: Keep in mind that if you modify the artwork in a drawing, all instances of that drawing will be auto-
matically updated even if set as a key exposure.  This keeps your existing animation key poses intact. It is fre-
quently used on a mouth or eyes layer. 

Example: Swapping a drawing with no key exposure

In the following example, drawing 3 (DR 3) is selected on the timeline and it contains no key exposure. 

When it is swapped for drawing 4 (DR 4), the entire duration of drawing 3 substituted for drawing 4.

Example: Swapping a drawing with a key exposure

Here's what happens when swapping a drawing with a key exposure. In the following example, the playhead is 
positioned in the middle of drawing 5 (DR 5) to set the position for the new key exposure. When the new key 
exposure is added, drawing 5 is split in two; both halves contain drawing 5. Now if you swap the first drawing 5 for 
drawing 1, the second drawing 5 retains its exposure.
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How to add a key exposure

 1. In the Timeline view, select the drawing cell to set as the key exposure.

 2. Do one of the following:In the Timeline toolbar, click the Add Key Exposure  button.

‣ In the Timeline toolbar, click the Add Key Exposure  button.

‣ Right-click and select Exposure > Add Key Exposure.

A new key exposure is added. 

If you added a key exposure at the beginning of the drawing, the entire exposure is filled with that same 
drawing. If you added a key exposure anywhere other than the beginning of the drawing, then the drawing is 
split in two and both parts contain the same drawing. 
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Removing Key Exposures
When you no know longer need a key exposure, you can remove it. When you do this, the existing key exposure 
is replaced by the preceding exposure. In the following example, a key exposure is set to drawing 1 (DR 1). When 
the key exposure is removed, the exposure is replaced by the preceding exposure, drawing 4 (DR 4).

How to remove a key exposure

 1. In the Timeline view, select a key exposure to remove.

 2. Do one of the following:

 l In the Timeline toolbar, click the Remove Key Exposure button.

 l Right-click and select Exposure > Remove Key Exposure.

The key exposure is removed and replaced by the preceding exposure.

498



Harmony 14 Essentials - User Guide

About Eases
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply an ease to multiple functions and keyframes, use the Set Ease for Multiple Parameters feature and 
set the amount desired.

The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the function curve in 
the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and left 
handle fields, as well as the Bezier handle or Ease wheel controls on each selected keyframe. You can pull on them 
to adjust the ease in and ease out, or type values in the fields. 

If there are several functions whose velocity you want to adjust at the same time, such as the hand, forearm and arm 
of a cut-out character, you can apply the same velocity parameters to all the selected keyframes in one frame.
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Setting Eases for Multiple Parameters
You can adjust eases for multiple parameters at once.

How to set ease on multiple parametersHow to adjust the ease of the animation

 1. In the Timeline view, collapse your character model's hierarchy.

 2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the key-
frame on every layer simultaneously.

 3. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, you can click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.
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 5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Filters 
section, deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 
3D Path functions

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note 
that it is applied to the Morphing Velocity function in the Layer Properties window, not to the 
basic Morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other selected functions, such as all functions 
created to animate effect parameters.

 6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are cal-
culated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to 
the length of time you want the easing to last. The value must be between 0% and 100%.

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out. The value must be between 0% and 100%.

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 7. Click one of the following buttons:

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

 l Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.
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NOTE: If a range containing multiple keyframes is selected, only the first selected keyframe will be affected 
by the Seat Ease for Multiple Parameters functionality.
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Using the Onion Skin in Cut-out Animation
When animating cut-out characters, it is useful to see the previous and next frames on the animation. However, it 
can sometimes be confusing to see the onion skin for every part of the character. You will often only want to see the 
onion skin on a single part or a few parts, such as the arm that is currently being animated.

While animating in the Camera view, there is a series of different onion skin options. You can enable these options in 
the menu or manually in the Timeline view using the layer's Show Onion Skin  button. Only selected layers will 
be displayed in the onion skin preview; you can change the display options when you use the onion skin.

How to use the onion skin

 1. In the Tools toolbar, click the Onion Skin  button or press Alt + O.

 2. In the Tools toolbar, click the Transform  tool or press Shift + T.

 3. In the Camera view, select one or more elements.

 4. Select View > Onion Skin and one of the following commands: 

 l Add to Onion Skin: Adds a series of selected elements to the onion skin preview.

 l Remove From Onion Skin: Removes a series of selected elements from the onion skin 
preview.

 l Remove Unselected from Onion Skin: Removes all elements except the ones selected 
from the onion skin preview.

 l Add All to Onion Skin: Adds all of the scene's elements to the onion skin preview.

 l Remove All from Onion Skin: Removes all of the scene's elements from the onion skin 
preview. 

Add to Onion Skin
The Add to Onion Skin command adds a series of selected elements to the onion skin preview. The keyboard 
shortcut is Shift + S.
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Remove from Onion Skin
The Remove From Onion Skin command removes a series of selected elements from the onion skin preview.

Remove Unselected from Onion Skin
The Remove Unselected from Onion Skin command removes all elements except the ones selected from the 
onion skin preview.

Add All to Onion Skin
The Add All to Onion Skin command adds all scene elements to the onion skin preview. The keyboard shortcut is 
Alt + Shift + O.

Remove All from Onion Skin
The Remove All Onion Skin command removes all scene elements from the onion skin preview. The keyboard 
shortcut is Ctrl + Shift + O (Windows/Linux) or ⌘  + Shift + O (Mac OS X).
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Using the Outline Mode
Use the Outline mode to temporarily convert all the drawings on a layer to outlines. You can still select and 
manipulate the drawings in this mode. Select a drawing by selecting its outline. The fill is not taken into account 
when making selections in this mode.

Toggling drawings to outlines

 1. In the Timeline view, click once on the Change Track Colour button of a layer to toggle all drawings of that 
layer to outlines, in the Camera view.
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Changing the outline colour

 1. In the Timeline view, double-click on the Change Track Colour button of a layer to open the Select Colour 
dialog box.

 2. In the Select Colour window, select a new colour for your outlines.

506



Harmony 14 Essentials - User Guide

 3. Click Ok.

The colour swatch and frames of the selected layer take on the new colour.

 4. In the Timeline view, click once on the change track colour of a layer to toggle all drawings of that layer to out-
lines, in the Camera view.

The outlines of the layer's drawings appear in the selected colour.
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Flipping Through Poses
When animating, it is useful to flip through poses to see the flow of your animation without going through each 
frame in the Timeline view. Harmony lets you flip between the selected element’s keyframes.

How to flip through poses

 1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

 2. Do one of the following:

 l From the top menu, select Animation > Go to Previous Keyframe or Go to Next Key-
frame  

 l Press semicolon (;) and single quote ('). 

508



Harmony 14 Essentials - User Guide

Flipping Parts
If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and Flip Vertical 
options. If the Scaling parameter is not set to Separate Scale, the flip is not applied to the selection.

How to flip a selection

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select the parts to be flipped.

 4. In the  Tool Properties view, click the Flip Horizontal  or Flip Vertical  option or press 4 or 5 respectively.
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Animating Lip-Sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE: The letters assigned to these mouth shapes are standard identifiers, they NOT correspond to the 
sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated with 
the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, your 
character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and these 
drawings should be named by their corresponding letter. 
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How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice 
track. 
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 5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

 7. Click OK.

 8. In the Playback toolbar, enable the Enable Sound  option.

 9. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view

You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, allowing 
you to identify which phonemes you should match your character's mouth to. You will also be using drawing 
substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing 
name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing 
automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The cur-
rent drawing is swapped for the one in the preview window.
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Ordering  in Z-Depth
The layer ordering system in Harmony saves time and simplifies your work. There is no need to create a new 
layer or copy and paste artwork into other layers to change the order. The Z-axis (forward/backward) allows you to 
create a multiplane and move elements closer or farther from the camera. This allows you to move the puppet’s 
pieces in front of or behind other ones without physically changing the layer position. 

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe is created 
where different Z values can be entered. This allows the piece to move forward and backwards in space without 
requiring you to change the drawing’s original position or break the layer hierarchy. This also means that the layer 
ordering is maintained throughout the scene. You can combine animation assets so Harmony can interpolate 
them. 

How to nudge elements on the Z-axis

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tools toolbar, click the Animate  button.

 3. In the Camera view, select the part to be repositioned and hold down the Alt key. 

 4. Using the Up Arrow or Down Arrow arrow keys, nudge the part until it moves to the desired position.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your animation.

How to create an animation cycle 

 1. In the Xsheet or  Timeline view, select the cell range and keyframes to loop.

 2. From the top menu, select Edit > Copy Cells From the Timeline.

 3. In the Xsheet or  Timeline view, select the cell where you want your cycles to start.

 4. From the top menu, select one of the following:

 l Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘  + / (Mac OS X).

The Paste Special dialog box opens.

 l Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘  + B (Mac OS X).

The Paste Special dialog box opens.
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 2. In the Number of Cycles field, enter the number of cycles to paste.

 3. In the Cycle Type menu, select a type of cycle to paste.

 l Normal (forward): Pastes the selection as is, starting with the first cell and ending with the last.

 l Reverse: Pastes the selection reversed, beginning with the last cell and ending with the first.

 l Forward -> Reverse: Pastes the selection as a yo-yo, starting with the first cell, going to the last cell and 
ending with the first cell.

 l Reverse -> Forward: Pastes the selection as a reversed yo-yo, starting with the last cell, going to the first 
one and ending with the last cell.

 5. Click OK.

How to create a reverse animation cycle

 1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.
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 2. From the top menu, select Edit > Copy.

 3. In the  Timeline view, select the cell where you want the cycles to start.

 4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘  + . (Mac OS X).
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About Timeline Marking
As you animate, the Timeline view will accumulate many layers and keyframes. You might want to identify them 
using coloured layers and scene markers.

Scene markers are visual indicators displayed at the top of the Timeline view in the frame counter area. You can use 
it to denote anything relevant to your work. You can indicate the frames you want to clean up, a change in action, an 
impact, or where you intend to apply an effect. You can also add a note to a scene marker, which is displayed when 
you hover over the scene marker.

There are two ways to add a scene marker. You can mark the current frame or make a frame range selection and 
mark the whole section.

To see how to mark the Timeline, see , , Marking Layers with Colour
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Marking Layers with Colour
As you animate, you may want to differentiate between different types of layers, such as pegs and drawing 
layers, or simply highlight a layer you are currently working on. You can organize layers or make them stand out 
by changing the layer colour.

How to mark a layer with colour

 1. Click the Change Track Colour  button of a layer.

The Select Colour dialog box opens.

 2. Select a colour for the layer. You can modify the colour for any type of layer, such as group, peg, drawing 
and effects.
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Chapter 13: Import
Toon Boom Harmony allows you to import external content as well as being able to draw directly in the software. 
This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs 
can be brought in and animated. You can import QuickTime videos, pictures, multilayered .psd files, as well as .ai, 
.swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize them.

NOTE: For sound import, refer to Importing Sound on page 688.
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About Bitmap Images
T-HFND-007-001

Images can come in many different file formats and are usually saved in a format that retains the original 
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, while 
others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the following bitmap 
image formats: JPEG, BMP, PNG (16 bits per channel RGB and RGBA), TGA, PSD (16 bits per channel), TIFF, 
SGI, TVG, OMF, PAL, SCAN.

When importing a bitmap image, you must decide how Harmony must process it. You can choose between the 
following options:

 l Import as Bitmap: This imports the image exactly as is and ensures that it can not be modified when work-
ing on the scene. This is useful for using backgrounds that were created in different software in your pro-
ject.

 l Vectorize: Converts a bitmap  into Toon Boom vector art, which can easily be painted and edited using 
Harmony's vector drawing tools. This can be useful for importing line art scanned or created using a dif-
ferent software.

When importing images, the settings used to import are saved in your user settings.
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Importing Bitmap Images As Original Bitmap
T-HFND-007-002

Importing a bitmap image in its original format ensures it is preserved exactly as is in Harmony. When importing a 
bitmap image, you have several options available such as where you want to import the file and how to name it. 

How to import a bitmap image in its original format

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

 2. In the Files section of the Import Images dialog box, click Browse to find and select one or more images on 
your computer.

 3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following 
options:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create two lay-
ers, one named "a" and one named "b". Layer "a" will contain the two first images and "b" will 
contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're importing 
images as vector drawings, you can only import them into vector drawing layers. 
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Parameter Description

Fit

Adjusts the image's size to fit completely within the scene's 
field, both vertically and horizontally, making sure the entire 
image is visible. 

If the image's orientation is portrait, then it will adjust the image's 
height to fit the field's height, without affecting the image's 
aspect ratio:

If the image orientation is landscape, then it will adjust the 
image's width to fit the field's width, without affecting the 
image's aspect ratio:

Pan

This has the opposite effect to the fit parameter. The image's 
smallest dimension will be made to fit the scene frame's 
matching dimension, and the image's largest dimension will be 
adjusted proportionally, making the image fill the entire scene 
field, and bleed past its boundaries it if its aspect ratio does not 
match the field's aspect ratio. This option can be used to import 
a panning background image, also referred to as a pan.

If the image's orientation is portrait, it will adjust the image's 
width to fit the field's width, without affecting its aspect ratio:
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If the image's orientation is landscape, it will adjust the image's 
height to fit the field's height, without affecting its aspect ratio:

Project Resolution

Scales the image to fit the scene's resolution, making each pixel 
in the image take one pixel in the scene's field. For example, if 
the image's dimensions in pixels are half of the scene's 
resolution in pixels, then the image's dimensions will appear to 
be half of the scene field's dimensions. 

 4. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the way the 
pixels along the edge are blended with the other colours. You can choose between the following options:

Parameter Description

Premultiplied with White Individual pixels at the edge of an image are blended with white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight 
Pixels at the edge of an image are blended with black, white and 
greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour 
is clamped to the alpha, the colour value cannot be higher than the 
alpha value. It calculates the real colour value faster. When the 
RGB values are multiplied with the alpha value, that is to say, if you 
have a pixel of value R=247, G=188, B=29 and the alpha is 50% or 
the image has a 50% transparency, then the actual RGB values 
that are output would be half of the amounts listed above.
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 5. Click OK.

NOTE: By default, bitmap images will display in low resolution in the Camera view so as to avoid affecting 
playback performance. You can also adjust the display quality of a bitmap image by selecting it with the 
Transform tool, then opening the Bitmap Image Quality dialog via View > Bitmap File Quality. You can also 
preview your bitmap image in your scene's resolution by activating the Render Preview mode in the Cam-
era view. 
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Adjusting the Bitmap Image Display Quality 
T-HFND-007-004

You original bitmap are imported as is in your project. In the Camera view, they may appear low quality as a proxy 
image is displayed in its place to insure fast playback.

If the bitmap images that you imported look blurry or slightly pixelated, you can increase the image proxy display by 
changing the quality of the preview in the Camera view. It will not affect the final render.

How to change the bitmap image quality

 1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or 
simply select the bitmap image layer in the Timeline view if it's not.

 2. Do one of the following:

 l From the top menu, select View > Bitmap File Quality.

 l Press Ctrl + Q (Windows/Linux) or ⌘  + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

 3. Drag the slider to the right to improve the quality.

 4. Click OK.

 5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and return to 
your scene.
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Vectorizing Images on Import
You can import bitmap images as vector drawings, which allows you to edit them using Harmony's vector 
drawing tools. This is especially useful to convert bitmap line art scanned or created in a different software into 
vector line art so it can be painted in Harmony. 

How to import and vectorize a bitmap image

 1. Do one of the following:

 l From the top menu, select File > Import > Images. 

 l In the File toolbar, click the Import Images  button.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

 1. In the Files section of the Import Images dialog box, click Browse to select one or more images from your 
computer.

 2. Select the destination for your images:

 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
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images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. 
For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create two lay-
ers, one named "a" and one named "b". Layer "a" will contain the two first images and "b" will 
contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're importing 
images as vector drawings, you can only import them into vector drawing layers. 

 3. In the Vectorization section, select the Vectorize Image  option. 

 4. Select one of the following options: 

‣ Colour: Imports bitmaps as vector objects with their image as a texture. 

‣ Black and White: Vectorizes drawings with a solid black line. This creates a 100% vector-based drawing 
and paints it with the Vectorized Line colour swatch from your scene's palette.

 5. If you selected the Black and White option, set the following parameters:

Parameter Description

Threshold

Determines what values in the scanned image will be considered 
as part of the drawing, and what will be ignored and eliminated in 
the vectorized drawing. The lower the value, the darker the image 
and vice versa.

Smooth
Determines how smooth the lines will be. The lower the value, the 
more detail will be retained. The higher the value, the more polished 
and easy to edit the lines will be.

 6. Click OK.

Your vectorized images will appear in their selected destination.
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About Vector File Import
T-HFND-007-005

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon 
Boom format (TVG) and create a colour palette based on the colour settings of the original file. 

When importing AI and PDF files:

 l RGB is supported, CMYK is not.

 l Gradients and textures are not supported.

 l Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and 
Actionscript 3, cannot be imported.

 l When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be imported as sep-
arate layers. The import will use the Illustrator file's top level groups as separate layer names. However, 
you can change this behaviour by deselecting the PDF/Illustrator Import as Separate Layers option, to 
import your file as a single layer .

If a project was started in Adobe Flash and needs a more professional boost, such as camera movements or 
multiplaning, it can easily be imported into Harmony. 

The actual *.fla file is not supported in Harmony, so you must export your project from Adobe Flash.
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Importing AI and PDFs 
T-HFND-007-006

You can import vector Adobe Illustrator files as well as PDFs through the Library view and File menu. Make sure you 
have the rights to modify your Library folder and the your files are in RGB format.

How to import an AI or PDF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you will 
not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your AI or PDF file in the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type in a name for the new template or keep the name of the original AI or PDF file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.
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The message window opens.

 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking 
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option if you 
plan to import multiple .ai or .pdf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the 
imported file’s name.
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Importing SWF Files
You can import .swf files in Harmony that were published using any version of Flash Player, up to version 14. Note 
that some effects may not appear when imported in Harmony. 

How to import a SWF file

 1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library 
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you will 
not be able to import files.

 2. Do one of the following:

 l In the top menu, select File > Import > SWF, Illustrator Files to Library. 

 l Right-click on any unlocked folder and select Import Files.

The browser window opens.

 3. Find and select your.swf file from the Import Files dialog box and click Open.

The Rename dialog box opens.

 4. Type a name for the new template or keep the name of the original *.swf file. 

 5. Click OK.

A new template folder is created in the Library view.

 6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy 

cursor  appears before releasing the folder.
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 7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking 
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This 
might be useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the 
imported file’s name.

NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT 
DELETE THIS PEG. To maintain the look of your movie, it's important not to delete this peg or detach its 
child layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become 
regular drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or 
drawings within symbols collapse into their corresponding parent symbol.
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NOTE: Some layers in your .swf movie may be combined in a single layer as a result of optimization enhance-
ments in your movie file. You can easily move these elements back onto separate layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped 
together in one folder. In our example, this means that when you scroll through the Drawing Substitution 
preview in the Library view, the different hand, leg, tentacles, antennae, torso and facial positions are all 
organized together.
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Distributing SWFs to Layers
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might 
be combined as a single layer. If so, you can quickly redistribute these elements onto individual layers again. 

How to distribute to layers

 1. In the Tools toolbar, click the Select  tool.

 2. In the Camera view, select the drawing that contains elements you want to redistribute onto individual lay-
ers.  To select the all the elements of the selected drawing layer, press Ctrl + A (Windows/Linux) or ⌘  + A 
(Mac OS X).

 3. Do one of the following:
 l From the top menu, select Drawing > Distribute to Layers.

 l In the Tool Properties view of the Select tool, click the Distribute to Layers  button.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline 
view. The selected elements in the original drawing layer are removed. Each element is distributed onto a 
new drawing layer.

 4. Repeat the process for each drawing that contains elements to redistribute.
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Installing the Export to Harmony Option
The extension is required in order for Flash to export files to Harmony. The extension is called Export to 
Harmony.zxp and is located here: 

OS Edition Location

Windows

Premium
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Premium\resources\flash

Advanced
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Advanced\resources\flash

Essentials
C:\Program Files (x86)\Toon Boom Animation\Toon Boom Har-
mony [version] Essentials\resources\flash

Mac OS X

Premium
Applications > Toon Boom Harmony [version] Premium > tba > 
resources > flash

Advanced
Applications > Toon Boom Harmony [version] Advanced > tba > 
resources > flash

Essentials
Applications > Toon Boom Harmony [version]  Essentials > tba > 
resources > flash

NOTE: Before installing the extension, you must remove all Harmony offline and database preferences.

How to install the Export to Harmony extension

 1. Launch Adobe Extension Manager.

 2. In the top-right corner of the Adobe Extension Manager, click on Install.

An Open dialog appears.

 3. In the Open dialog, browse to and select the Export to Harmony.zxp file, then click on Open.

A message opens informing you that you're about to install the Export to Harmony extension.

 4. Click on Accept.

You may see the following message confirming that you want to install the extension. Click Install.
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 5. In order for the changes to take effect, you must close and restart Adobe Flash.

 6. Click OK.

How to remove a previously installed Export to Harmony.zxp extension (if applicable)

 1. If open, close Adobe Flash.

 2. Start Adobe Extension Manager.

 3. From the Products list, select Adobe Flash. 

If you have a previous version of the Export to Harmony.zxp extension installed, it will be listed in 
the right pane.

 4. Select the extension and click Remove.

A message opens asking you to confirm the removal of the extension.

 5. Click Yes.

Adobe has stopped  maintaining and updating their Extension Manager CC, therefore, it has become difficult to 
install extensions. In order to link an extension from Animate CC, follow the steps below. 

How to install an extension on Windows with Adobe Animate CC version 2015 and higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdWin

 3. Unzip the ExManCmd_win.zip package.

 4. Put the ExManCmd_win folder in a safe place.
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NOTE: The ExManCmd_win folder must not be deleted; this folder is necessary for installing or 
updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads folder:

C:\Program Files (x86)\Toon Boom Animation\Toon Boom Harmony 14.0 
Essentials\resources\flash\flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. In the ExManCmd_win folder, hold Shift and right-click to select Open command window here.

 10. Enter the following command: 

ExManCmd.exe /install <filename.zxp>.

 11. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by the 
Extension Manager CC.

 

 12. Open Animate CC.

 13. Access Top Menu > Commands.

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was successful.

 

539



Chapter 13: Import     About Vector File Import

NOTE: If you have a region language  other than English (US) installed on your computer, or if 
you have more than one language installed on your computer, Animate CC may not be able 
detect in which language folder the extension has been installed. If this occurs, you will not be 
able to see the Export to Harmony menu option in Top Menu > Commands list. To correct this, 
proceed to How to ensure Adobe detects extension files installed on your computer on page 
540.

How to ensure Adobe detects extension files installed on your computer

 1. Browse to:

C:\Users\<UserName>\AppData\Local\Adobe\Animate <VersionNumber>

 

If Adobe detects more than one language on your computer, you will see multiple language folders in the 
path.

 

For example:

 

 

 2. Look inside each folder to detect the main language used by Adobe on your computer. To do so, compare 
the contents of both folders.

For example, inside the en_Ca\Configuration:

 

 

For example, inside the en_US\Configuration:
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The main folder is the one with more files. In this case, Adobe is using English (US) as the main language. 
The folder en_CA only contains what was installed with the extension installation: commands, Javascript 
and WindowSWF.

 3. Copy and paste the contents of the commands folder within the sub-language folder, to the commands folder 
within the main language folder .
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 4. Copy and paste the contents of the Javascript folder within the sub-language folder, to the Javascript 
folder within the main language folder.

 5. Copy and paste the contents of the WindowSWF folder within the sub-language folder, to the Win-
dowSWF folder within the main language folder.
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How to install an extension on Mac OS X with Adobe Animate CC version 2015 and higher

 1. Ensure the following software is installed:

 l Adobe Creative Cloud

 l Animate CC and Mobile Device Packaging

 2. Download the ExManCmd from Adobe’s website. 

https://docs.toonboom.com/go/download/ExManCmdMac

 3. Unzip the ExManCmd_mac file.

 4. Put the ExManCmd_mac folder in a safe place.

NOTE: The ExManCmd_mac folder must not be deleted; this folder is necessary for installing or 
updating .zxp files.

 5. Copy the package containing the plug-in from the Harmony installation folder to your Downloads folder:

/Applications/Toon Boom Harmony 14.0 Essentials/tba/resources/flash/flashexport.zip

 6. Unzip the flashexport.zip package. 

 7. Open the folder containing the unzipped files. 

 8. Move or copy the Export to Harmony.zxp file directly into the ExManCmd_win folder.

 9. Drag and drop the .zxp file directly into the ExManCmd_mac folder.

 10. In Terminal, go to the folder where the ExManCmd_mac package was extracted.

For example, if you have put the ExManCmd_mac folder into the Downloads folder:
cd Dowonloads/ExManCmd_mac/

 11. Enter the following command:

Contents/MacOS/ExManCmd --install <filename.zxp>

 12. Press Enter.

If no error message displays, the extension has been installed on your computer and recognized by the 
Extension Manager CC.
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 13. Open Animate CC.

 14. Access Top Menu > Commands. 

If the Export to Harmony option appears in the Top Menu > Commands list, your installation was 
successful.
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Exporting FLA Files

How to export FLA files for Harmony from Adobe Flash

 1. Open your.fla file in Adobe Flash. 

NOTE: In case of a new file, it needs to be saved before continuing the exportation process. If not, the export 
won't be completed.

 2. Return to the scene level.

Before exporting to Harmony, it is assumed that you are at the scene level even if you're not.

 3. Do one of the following:

 l Older versions of Adobe Flash: Select Window > Other Panels > Export to Harmony. 

 l Adobe Flash CC: Window > Extensions > Export to Harmony.

NOTE: This window must be opened once after installing the extension in the extension manager because it cre-
ates a drect link to Harmony (even if the window is not used). Afterwards, you do not have to reopen it if there is 
no need to change the option.

The Export to Harmony window opens from which you can set the resolution of the files as it will appear in 
Harmony. The default resolution is set to 1920 x 1080, like the HD default resolution value of Harmony. If 
needed, you can change the compression: Photo (JPG) or Lossless (PNG).

 4. Do one of the following:

 l In the Export to Harmony window, click Export button. 

 l Select Commands > Export to Harmony.

The Output tab displays information about the conversions necessary for the export including:

Distributing to layers, breaking apart, the presence of shapes at the scene level, ungrouping all groups to 
verify if any symbols are hidden inside, breaking drawing objects to transfer them as shapes, drawing 
substitutions, and so on. Problematic situations will also be mentioned. If nothing appears in the Output tab, 
then your.fla file is clean and does not need any conversions.
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The .txt files contain the drawing substitution information and at which frame they are exposed. A .swf 
file is created for each symbol in Flash and a .tpl file is created of them. The corresponding export.json 
file is also created, which you will need when importing your Flash scene in Harmony. These files are in a 
folder located at the same location as the.fla file.  The folder name is the same as the .fla file.

NOTE: If  a folder with the same name as the .fla file already exists, you will be prompted to replace the 
folder. Be aware that saving Flash projects as .xfl files will automatically create a folder with the same 
name as the .fla file. In this case, the folder of the export will be created inside the folder of the xfl. If this 
not what you want, place a copy of the.fla in another path on your computer before the export.
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Displaying the Import Flash Scene Icon
When importing Flash files, the Scripting toolbar must be displayed, which should contain the Import Flash Scene 
icon. If the icon does not appear in the Scripting toolbar, add it to the toolbar. Note that you will only have to do this 
once. After that, you can import Flash files whenever needed.

How to display the Flash Import script icon

 1. From the top menu, select Windows > Toolbars > Scripting.

The Scripting toolbar bars appears below the File toolbar in the upper-left of the Harmony interface.

 2. Click the Manage Scripts  button.

The Scripts Manager opens.

 3. From the Files section, select TB_Import_Flash_Scene.js. 

On your computer, here is the location of the script file:

 l Windows:

 l Toon Boom Harmony Premium: C:\Users\[user_name]\AppData\Roaming\Toon Boom Anim-
ation\Toon Boom Harmony\1400-scripts

 l Toon Boom Harmony Advanced: C:\Users\[user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Advanced\1400-scripts
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 l Toon Boom Harmony Essentials: C:\Users[\user_name]\AppData\Roaming\Toon Boom 
Animation\Toon Boom Essentials\1400-scripts

 l Mac OS X: 

 l Toon Boom Harmony Premium: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Harmony/1400-scripts

 l Toon Boom Harmony Advanced: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Advanced/1400-scripts

 l Toon Boom Harmony Essentials: /Users/[user_name]/Library/Preferences/Toon Boom 
Animation/Toon Boom Essentials/1400-scripts

On Mac OS X, the Library folder is a hidden folder. To display the display the folder, told down the Alt key.

 l Global: [Server_Name] > USA_DB > scripts

 l Environment: [Server_Name] > USA_DB > environments > [environment_name]

 l Job: [Server_Name] > USA_DB > jobs > [job name]

 l User: [Server_Name] > USA_DB > users > [user_name] > stage > 1400-scripts

 5. From the Functions section, select TB_Import_Flash_Scene and click the arrow button to move it to the 
In Toolbar section.

 6. Click OK.

The Import Flash icon appears in the Scripting toolbar. Everything is now ready to import Flash scenes.
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Importing FLA Files
Once your extension is installed, your FLA file has been exported and your displayed the FLA import script in your 
toolbar, you are ready to import your FLA file in Harmony.

How to import FLA files

 1. In the Scripting toolbar, click the Import Flash  button.

 2. In the Import Files dialog box, locate the export.json file contained in the folder that was created when you 
exported your files from Flash.

 3. Click Open.

In a few moments, the colour recovery dialog box appears, requesting a colour recovery. 

 4. Before clicking Yes, you have the option of selecting the Do Not Ask Again For This Session option. 

In a few moments, the .fla files are imported in Harmony. 
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 5. In the Node view, press 1 to zoom out of the Node view and see the entire node system.
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Importing Multi-layer PSD Files
T-HFND-007-003

PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain multiple 
layers. This is advantageous as the image remains fully editable in terms of any colour correction, effects, masking, 
transparency, or compositing that were made to the .psd file in Adobe Photoshop. Harmony supports 8 and 16 bit 
files.

NOTE: Note that your .psd image file must be set to RGB mode within Adobe Photoshop prior to being impor-
ted into Harmony.

How to import a multi-layer PSD file

 1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all 
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any 
layer that is not in a folder group, by itself or otherwise, will not be imported.

 2. In Harmony, go to the top menu and select File > Import > Images or click the Import Images  button.

The Import Images dialog box opens.

 3. In the Files section, click Browse to find and select the .psd image on your computer.

 4. In the Layer section, select the Create Layer(s) option, then select one of the following options:
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 l Create Single Layer Named: Creates a new layer with the specified name and imports the 
images into it.

 l Create Layer(s) Based on Filenames: Creates a layer based on each unique filename pre-
fix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create 
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and 
"b" will contain the third one.

 l Add to Existing Layer: Imports the images into the specified layer. Note that you can only 
import into layers that are compatible with your import options. For example, if you're import-
ing images as vector drawings, you can only import them into vector drawing layers. 

 5. In the Import Options section, select the following option to import your image as its original format.

 l Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment sec-
tion, decide on the size and placement of your image within the camera frame. Depending on 
the Scene Settings (the height and width in pixels that you chose for your project), an image 
that you import may get scaled to the point where all its individual pixels become visible.

 6. Decide whether to select Vectorize Imported Items option.

 7. Click OK.

The Multilayer Image Import Settings dialog box opens.

 8. From the Create  menu, select one of the following:

 l Single Layer: To import the Camera and Layout layers merged together.

 l Separated Layers: To keep your Camera and Layout layers separated.

 9. From the Transparency menu, select one of Alpha option.

 10. Click OK.

Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group folders.

NOTE: The artwork displayed in every one of your layers as a result of a multilayer PSD file 
import is linked to the same source image. This means that if you use the Drawing > Delete 
Selected Drawings command to physically delete the drawing from the project folder, the 
exposed drawing will be deleted in all layers at once. Once deleted from the project folder, the 
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image cannot be retrieved unless you reimport your psd file.
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Importing QuickTime Movies
T-ANIMPA-004-002

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation. 
Toon Boom Harmony allows you to import QuickTime movies into your project. 

How to import a QuickTime movie

 1. From the top menu, select File > Import > Movie.

 2. Browse for the QuickTime movie to import and click Open.

The Import Images dialog box opens.

NOTE: Do not browse for the movie file again. Leave the automatically generated field text as “many files 
selected”.

 3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see the Refer-
ence guide .

 4. Click OK.

The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the film 
frame-by-frame just as you would scroll through your animation drawing-by-drawing.
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About Scanning
Harmony can receive images from any TWAIN device, such as  scanners or digital cameras. You can load these 
images as bitmaps into your scene or convert them into vector-based images that can be edited using Harmony.

You must install a TWAIN driver for your device in order to access its contents. Refer to the manufacturer of your 
device to get a TWAIN driver. Once all the animation layers are scanned in, you can set the timing in the digital 
exposure sheet.

Once your traditional animation sequences are completed and cleaned up, you're ready to scan and import them in 
Harmony. The scanning process is the point where the traditional production becomes digital. It's the moment where 
you use Harmony to control the project.
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Scanning Images 
Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These 
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be edited 
using Toon Boom Harmony.

If your operating system does not automatically recognize your device after it has been connected, you must 
install the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the 
device manufacturer’s website.

How to scan images

 1. From the top menu, select File > Acquire > From TWAIN.

The Acquire from scanner window opens. 

 2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the Scanner 
menu. If none are available, check your device to ensure that it's properly connected to your computer. If 
your device still does not appear in the menu, you may have to shut down and restart the software.

 3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing 
layer—see the Reference guide .

 4. In the Drawing Options section, set the following options if desired:
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 l Drawing Name: Name of the drawing to import.

 l Hold Value: Type the number of frames that the drawing will be exposed.

 l Scan and Advance: Lets you scan one drawing after another every time you click Scan.

 l Flip Drawing: Mirrors the drawings horizontally and scans it this way.

 5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

 6. Click Scan to scan your drawing.

 7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to cap-
ture your next frame.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.
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Vectorizing Scanned Drawings
You can turn scanned images into vector drawings, while maintaining the sketchiness of a pencil line or into 
vector images with a bitmap fill. Both options can add life to an animation, which straight vectorization with 
smoothing does not usually afford.

How to scan and vectorize drawings

 1. From the top menu, select File > Acquire from TWAIN or press Ctrl + Shift + S (Windows/Linux) or ⌘  + 
Shift + S (Mac OS X).

The Acquire from scanner window opens.

 2. Select your scanner from the Scanner list.

 3. Click Preview to get a test scan of your drawing.

 4. In the Layer section, select one of the following:
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 l Create Layer: Imports an image into a new layer. Type a name for the layer in the Name field. 

 l Add to Existing Layer: Imports the image into an existing layer. Select a layer from the Layer 
list.

 5. In the Vectorization section, select the Vectorize Image option and then set the following:

 l Colour: Creates a vector rectange with the bitmap as a texture inside.

 l Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based 
drawing. Set the Threshold and Smooth parameters.

Threshold: Determines which black, white or grey pixels become a black line. 0% means all the light 
pixels will be kept as black vector line. A value of 100% means only the very dark pixels become a black 
line.

Smooth: Determines the smoothness of lines. The higher the value, the less angular and bumpt the 
resulting lines will be.

Auto Apply: Automatically applies the colour or black and white settings to the scanned images.

 6. Adjust the Scale control and the sliders in the Preview Image window until you're satisfied with the view.

 7. Click Scan to import your drawing.

 8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have 
finished scanning all your drawings.
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About Custom Vectorization Parameters 
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be 
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center modules 
when scanning or vectorizing a series of drawings.

You can use an interface to select and test the different options, as well as type in some advanced settings.

The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green 
pencil marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, 
blue, green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your 
tones and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and 
watch the indicator colour zone lines disappear.
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Creating Vectorization Styles 
With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to set 
the Scan module vectorization style list.

You can vectorize drawings using one of the following methods:

 l Black and White: All the lines become vector based and 100% black. The white areas become completely 
transparent.

 l Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained inside 
a vector frame. The white areas become completely transparent.

 l Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and turn 
them into 100% vector lines, preserving their original colours—see the Reference guide .

How to create or modify the vectorization parameters

 1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization parameters 
(i.e. from the scanner).

 2. In the Scan Drawings window, do the following:

 l In the Layer section, decide on the layer options.

 l In the Import Options section, select the Convert to Toon Boom Vector Drawing option

 l Click Preview.

 3. In the Vectorization section, click the Vectorization Parameters button.

 4. The Vectorization Parameters dialog box opens.

 5. Set the different options available in the Vectorization Parameters dialog box—see the Reference guide .

 6. Click the Vectorize  button to update the Vectorized Image preview.

561



Chapter 13: Import     Creating Vectorization Styles

The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import 
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are 
applied during the vectorization process.

 7. To set advanced parameters, read the information on the Help tab, then type in the Advanced Options field 
at the bottom of the dialog box.

 8. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan mod-
ule vectorization style list, click  Save.

 9. In the Browser window, name and save the file.

 10. To save the current settings as your default settings, click Save As Default. To restore the default set-
tings, click Restore Defaults.

 11. To load a vectorization style, click Load and locate the existing *.vof file.

 12. Click OK.
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Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch 
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to create 
your own to fit your production style.

How to set the VectOptions.conf file on Windows or Mac OS X

 1. Open the vectOptions.conf file:

 l Windows: Select Programs / All Programs > Harmony 14 > Tools > Configuration Editor.

 l Mac OS X: Select Applications > Harmony 14 > Tools > Configuration Editor.

The Configuration Editor window opens.

 2. In the bottom section of the window, select the VectOptions.conf tab.

 3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vec-
torization style. These options are the same as in the Vectorization Parameters dialog box. It is recom-
mended that you create your vectorization style using Harmony and the Vectorization Parameters window 
and copy the result parameters in this file—see About Custom Vectorization Parameters  on page 560

 4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones to 
the list using the parameters you got using the Vectorization Parameters window. Notice that some of the 
lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the style list. 
The lines that have no sign at the beginning appear in the style list.

563



Chapter 13: Import     Setting the VectOptions.conf File

 5. To create a new style, type the following below the existing styles: 

style_name:

This should be followed by the name of your new style. For example: style_name: Black Lines.

 6. Under the style name line, type the following: 

options:

 7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Para-
meters window.

‣ To open the *.vof file, use any plain text editor application.

 8. In the Configuration Editor’s top menu, select File > Save.

 9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.  
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NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the vi text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_14/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5. 

$ sudo vi VectOptions.conf

 4. Enter the root password.

 5. Open the VectOptions.conf file:

$ vi VectOptions.conf

 6. To start editing, press I to enter Insert mode.

 7. When you're finished editing the file, press Esc to exit Insert mode.

 8. To save the changes made to the file, type the following and press Enter/Return:

$ :w!

 9. To exit the vi editor and return to the Terminal, type the following and press Enter/Return:

$ :q
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 10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the 
new style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and 
vectorize drawings, the selected style must be available on all the machines included in the batch processing 
list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the gedit text editor

 1. Open a Terminal window:
Menu: Applications > System Tools > Terminal

 2. Open the etc folder inside the installation directory:

$ cd /usr/local/ToonBoomAnimation/harmony_14/etc

 3. Change your user to "root":

$ su

‣ If your user is part of the sudoers list, enter the following command and go to step 5.

$ sudo gedit VectOptions.conf

 4. Enter the root password.

 5. Open the VectorOptions.conf file:

$ gedit VectOptions.conf

 6. Edit the parameters of the VectOptions.conf file as you would do in most text editor applications.

 7. Select File > Save.

 8. Select File > Quit.
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 9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new 
style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE: 
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize 
drawings, the selected style must be available on all the machines included in the batch processing list.

Refer to the Harmony Server Guide Guide to learn more about setting up and using batch processing.
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Chapter 14: Staging

Setting up your scene can be compared to building a set for a television show. This is the point when you position 
each scene element such as the camera frame, the background elements and the characters.

To learn how to position and animate your camera, see Cameras on page 673.
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About Layer Position

Setting up the scene also involves positioning the different scene elements within the camera frame.

At this time, the elements are set to a static position. See Motion Paths on page 615 to learn how to animate the 
elements and the camera.
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About the Animate Mode
T-HFND-008-001

The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view. 
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled, 
keyframes are not created when an object's parameters change.

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your drawing 
layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off

 1. In the Tools toolbar, click the Animate  button or select Animation > Animate.
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Selecting Layers
T-HFND-008-002

There are different ways to select the layers you want to reposition.

You can select your elements directly in the Camera view using the Transform  tool. When using this tool, its 
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection  Mode option 
in the Tool Properties view is disabled or it will limit the selection to pegs only.

How to select a layer in the Camera view

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Tool Properties view, make sure that the Peg Selection Mode  is deselected.

 3. In the Camera view, click on the element to be repositioned. You can select more than one element at a 
time. Hold down Shift while clicking on the elements to be selected.

The corresponding layers and columns are highlighted in the Timeline and Xsheet views.

How to select from the Timeline or Xsheet view

 l In the Timeline view, click the layer corresponding to the element you want to reposition. 

 l In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.

How to select non-adjacent elements in the Timeline or Xsheet view

 l In the Timeline view,  hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any layers that you 
would like to add to the selection.

 l In the Xsheet view,  hold down Ctrl (Windows/Linux) or ⌘  (Mac OS X) and click on any columns that you 
would like to add to the selection.

 The non-adjacent, selected layers and columns are highlighted in the Timeline and Xsheet views.

How to select all elements within a group in the Timeline view

 1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.
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Centering on Selections
When you have many layers in the Timeline view, you may find it hard to locate which one is selected. You can 
use the Centre on Selection feature to display the selected object's layer in the Timeline view.

How to center on the selected layer in the Timeline view

 1. In the Camera view, select a layer.

 2. In the Timeline view toolbar, click the Centre on Selection  button  or press O.
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About the Transform Tool 
T-HFND-008-003

Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera view. 

When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode  is 
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

There are two different options you can use when you want to flip your element.

The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and 
vertical axis.

Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip Scale 
Y will perform a flip on your drawing layer following its original axis.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.
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Repositioning Temporary Pivots with the Transform Tool
T-HFND-008-004

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can 
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is only 
moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot position—
see About Advanced Animation Tools on page 583.

How to temporarily reposition the pivot point

 1. In the Tools toolbar, select the Transform  tool.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is disabled.

 3. In the Camera view, select your element.

The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously repositioned.

 4. Click on the pivot point and drag it to a new position.

This will be the new position of the pivot point for the current transformation. It will remain in this position as 
long as you do not deselect the drawing. Using the Transform tool to reposition your pivot will temporarily 
override the existing pivot point position until you complete the current transformation. Then it returns 
automatically to its original position.

When you translate the pivot point using the Transform tool, the permanent pivot will appear as a ghost so 
you know where it is and also from where the animation will be interpolated when you create motion paths. 
The animation is always interpolated from the original pivot and not the temporary pivot.
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Panning with the Transform Tool
T-HFND-008-005

You can pan (translate) a layer using the Transform tool.

How to pan a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple 
layers to reposition them at the same time. Hold down Shift and select the different layers.
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Rotating with the Transform Tool
T-HFND-008-006

You can rotate a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to rotate from 
a different point.

How to rotate a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer outside of a corner of the bounding box and drag to rotate.
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Scaling with the Transform Tool
T-HFND-008-007

You can scale a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to scale 
from a different point.

How to scale a layer using the Transform tool

 1. In the Tools toolbar, enable or disable the Animate  mode if you want to animate or not.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold 
down Shift to lock the selection's aspect ratio. 

NOTE: When scaling your selection, you can hold down Shift to preserve its aspect ratio.
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Skewing with the Transform Tool
T-HFND-008-008

You can skew a layer from its pivot using the Transform tool. You can temporarily reposition the pivot to skew from a 
different point.

How to skew a layer using the Transform tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, select a drawing layer.

 5. Place  the pointer between two controls points and drag sideways or up and down. 
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Flipping with the Transform Tool
T-HFND-008-009

You can flip a layer using the Transform tool. There are two ways to flip.

 l The Flip Horizontal command flips the layer following the Camera view X-axis.

 l The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

How to flip a layer

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 4. In the Camera view, use the Transform  tool to select a drawing layer to flip.

 5. Do one of the following:

 l From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical. 

 l In the Tool Properties view, click the Flip Horizontal  and the Flip Vertical  buttons.

 l Press 4 or 5. 

How to flip an element following its original axis

 1. In the Tools toolbar, disable the Animate  mode.

 2. In the Tool Properties view, make sure the Peg Selection Mode  is deselected.

 3. In the Camera view, use the Transform  tool to select an element that has already been transformed.

 4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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About Advanced Animation Tools
T-HFND-008-010

You can also use the advanced animation tools to position your layers. The difference between these tools and the 
Transform tool is that they modify only one parameter of the position such as the rotation or the scale as the 
Transform tool adjusts all parameters together.

You can find the advanced animation tools in the Advanced Animation Tools toolbar.
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Repositioning Permanent Pivots
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the position 
of the drawing's pivot point. While making transformations using the Transform tool, you can drag and drop your 
selection's pivot. However, this has no permanent effect. It will only temporarily change the pivot's position to 
help you make transformations at the selected frame, but the actual pivot point of your drawing layer will remain 
the same. You can reposition a layer's pivot point permanently using the advanced animation tools.

How to permanently reposition the pivot point

 1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew  tool.

 2. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

The pivot point appears in the Camera view.

 3. Drag the pivot point to a new position.

NOTE: When you permanently move the pivot point, of a layer that is already animated, all the trans-
formations done on the layer on other keyframes will be recalculated according to the new pivot point's pos-
ition. Therefore, your existing animation will look completely different, except at the current frame. It is 
recommended to always make sure your pivot point is at its ideal position before you start animating.
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Using the Translate Tool
You can use the Translate tool to pan your elements on the X, Y and Z axes.

How to use the Translate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Translate. 

 l In the Advanced Animation toolbar, click the Translate  tool.

 l Press Alt + 2.

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 4. Drag the selection to a new area. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 
⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Rotate Tool
You can use the Rotate tool to rotate your objects on the x,y and z axis.

How to use the Rotate tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Rotate. 

 l In the Advanced Animation toolbar, click the Rotate  tool.

 l Press the Alt + 3. 

 3. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 4. Rotate the layer. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) 
or ⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Scale Tool
You scan use the Scale tool to squash, stretch, and resize your elements.

How to use the Scale tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Scale. 

 l In the Advanced Animation toolbar, click the Scale  tool.

 l Press Alt + 4. 

1. In the Camera view,  Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) to select your element. 

 3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s ratio when 
using the corner control points. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or 
⌘  + Shift + click (Mac OS X) on each element to select them. 
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Using the Skew Tool
You can use the Skew tool to distort your elements on the x and y axis.

How to use the Skew tool

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l Select Animation > Tools > Skew. 

 l In the Advanced Animation toolbar, click the Skew  tool.

 l Press Alt + 5.

 3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘  + click (Mac OS X) on the element to select it and 
drag a side of the bounding box up, down or sideways. 

 l You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) 
or ⌘  + Shift + click (Mac OS X) on each element to select them. 
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About the Layer Properties View
T-HFND-008-011

Each layer has a series of parameters that you can modify to adjust an element's position. You can access these 
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in the 
Camera view. These values can also be animated over time.

NOTE: To learn more about the layer parameters, see the Reference guide .

You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters  button. 

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and measures 
0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. Harmony 
uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has been 
drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have drawn on the 
page. This allows scanned drawings, imported images and paperless drawings to be properly registered together.

If you want to move your drawing in the upper-left region of the camera frame, you would type in something like the 
following:
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 l X Axis: -4 or 4W (4 West)

 l Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something like 
the following:

 l X Axis: 3 or 3E (3 East)

 l Y Axis: -2 or 2S (2 South)
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Displaying the Layer Properties View
You can display the Layer Properties view in several ways.

How to display layer parameters

 1. Do one of the following:
 l In the Layer Properties view is not part of your workspace, from the top menu, select Windows > 

Layer Properties. In the Timeline view, select a layer

 l In the Timeline view, double-click on a layer.

 l Press Shift + E.

The properties display—see Element/Drawing Node in the Reference guide .
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Positioning Elements with the Layer Properties View
T-HFND-008-012

You can type values to position your elements using exact coordinates. 

NOTE: To learn more about the layer parameters, see the Reference guide .

How to position an element with coordinates

 1. In the Timeline view, select a layer.

 2. In the Position section, select one of the following options:

 l Separate to independently edit the different coordinate fields. Continue to step 3.

 l 3D Path to use a 3D path function when animating your element. Continue to step 4.

 

 3. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—see 
About Multiplane on page 600.

As you type in values, the element’s position is updated in the Camera view. 

 4. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 5. In the Scale section, select one of the following options:

 l Locked to resizes the element uniformly in three directions.

 l Separate to resize the element in any direction without affecting the others.

 6. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position
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 7. Use the Function  buttons to create function curves and add keyframes to animate the parameter.

 8. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can enter val-
ues greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

 9. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

 10. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will 
change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see the Reference guide .
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About Selection Locking
You can prevent correctly positioned layers from being selected in the Camera view by locking them in the 
Timeline view. This is useful for making a multiple selection inside the Camera view while avoiding to select 
them. Once a layer has been locked, its locked state will be remembered the next time you open a saved project.

You can perform five types of locking actions on your layers:

 l The Lock  option lets you lock Locks one or a multiple selection of layers. 

 l The Unlock  button lets you unlock Unlocks one or a multiple selection of locked layers.

 l The Lock All  option lets you lock Locks all the layers in the Timeline view. 

 l The Unlock All  button lets you unlock Unlocks all the layers in the Timeline view. 

 l The Lock All Others  button lets you lock Locks every layer except the selected ones.
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Locking Layers
You can perform five types of locking actions on your layers. You will still be able to modify locked layers in the 
Timeline and Layer Properties views, but you will not be able to select them through the Camera view.

How to lock a layer or a selection of layers

 1. In the Timeline view, select one or more layers.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock. 

 l Click one of the selected layer’s Lock  icon. 

 l Press Ctrl + Alt + L (Windows/Linux) or ⌘  + Alt + L (Mac OS X).

All selected layers are locked. 

How to unlock a locked layer or a selection of locked layers

 1. In the Timeline view, select one or more locked layers.

 2. Do one of the following: 
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 l From the top menu, select Animation > Lock > Unlock. 

 l Click a selected layer’s Lock  icon. 

 l Press Ctrl + Shift + K (Windows/Linux) or ⌘  + Shift + K (Mac OS X). 

All selected layers are unlocked.

How to lock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Lock All. 

 l In the Timeline view, select all layers and click Lock  icon of a selected layer. 

 l Press Ctrl + Shift + L (Windows/Linux) or ⌘  + Shift + L (Mac OS X).

All layers are locked.

How to unlock all layers

 1. Do one of the following:

 l From the top menu, select Animation > Lock > Unlock All. 

 l In the Timeline view, select all layers (locked) and click Lock icon of a selected layer. 

 l Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘  + Alt + Shift + L (Mac OS X). 

All layers are unlocked.
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How to lock all other layers

 1. In the Timeline view, select the layers you do not want to lock.

 2. Do one of the following: 

 l From the top menu, select Animation > Lock > Lock All Others. 

 l Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘  + Alt + Shift + O (Mac OS X). 

All layers are locked except the selected ones.

How to display locked drawings as outline

 1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings  option.

 2. You can also set this option as a permanent preference. From the top menu, select Edit > Preferences (Win-
dows/Linux) or Harmony Essentials > Preferences (Mac OS X).

 3. In the Preferences dialog box, select the Camera tab.

 4. In the Tools section, select the Show Locked Drawings As Outlines option.
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Setting the Auto-Apply Option
If you want to always work in Auto-Apply mode, you can deselect the Auto-Apply option in the Preferences dialog 
box (General tab). Then, each time you start Harmony, the Auto-Apply  mode will be off. You must click the Apply 
button to see any modifications.

How to enable or disable the Auto Apply option

 l From the top menu, select Edit > Auto-Apply.

How to enable or disable the Auto-Apply preference

 1. In the top menu, select Edit > Preferences (Windows/Linux) or
Harmony Essentials > Preferences (Mac OS X).

The Preferences dialog box opens.

 2. In the Preferences dialog box, select the General tab.

 3. In the Options section, select or deselect the Auto Apply option.
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Resetting Transformations 
You can easily reset layers to their original position. With the Reset command, you can return the value of a selected 
element to the initial value of the active tool. For example, if the Rotate  tool is active, the transformation angle 
will be reset to 0 and if the Transform  tool is active, the all transformation parameters values will be reset.

When selecting elements in the Camera view using the Transform tool, always make sure that the Peg Selection 
Mode  is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.

How to reset the transformation on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were 
created.

The selected layer(s) return to their original position.

How to reset all transformations on the current frame

 1. In the Tools toolbar, select the Transform  tool or any Advanced Animation  tool.

 2. In the Timeline view or directly in the Camera view, select the drawing layer(s) to reset.

 3. From the top menu, select Animation > Reset All or press Shift + R.

The selected layer(s) return to their original position.

How to completely reset the layers' parameters

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. In the Timeline or Camera view, select one or more drawing layers to reset. 

 3. Do one of the following: 

 l Right-click the selected layers and select Clear All Values. This will remove all keyframes and 
reset all values for the entire layer.

 l In the Timeline View menu, select Layers > Clear All Values. This will remove all keyframes 
and reset all values for the entire layer.

The selected layers return to their original position.
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About Multiplane
T-HFND-008-013

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create 
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through this 
environment to create an impressive perspective illusion.

In live action, when the camera moves through the scene, objects near the camera will move by a greater 
distance than objects far from the camera. In 2D animation, multiplanes can be used to achieve a similar effect 
without resorting to 3D backgrounds. 

In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and 
positioning them at different depths relative to the camera.  

Before creating a multiplane, make sure you have a proper understanding of the environment in which your scene 
happens. Picture what your scene's background would be like in 3D, then image the camera moving through the 
space, and how the objects in the picture move at different speeds depending on where they are in relation to the 
camera lens.

In the following example, the background is made of 6 different layers, each picturing an object that is at a 
different distance from the camera. On the left, you can see how each object is positioned relative to the camera, 
as if you were looking at them from the side. On the right, you can see how layers are positioned relative to each 
other as if you were looking at the scene from a corner. Below, you can see the scene from the camera's point of 
view.
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NOTE: When creating a multiplane background, it is important to draw each layer fully. Even if some parts of a 
background layer is hidden behind a foreground layer in the camera's initial position, panning or zooming the 
camera may expose parts of background layers that are not initially visible.

In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You can do 
this by moving a layer using the Transform Tool  in the Side or Top views. You can also move a layer on Z-axis 
directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your element closer to 
the camera makes them appear bigger, and moving them further makes them appear smaller. It is also possible to 
move elements on the Z-axis without affecting their apparent size by using the Maintain Size tool in the 
Advanced Animation toolbar.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the Top 
and Side views.
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NOTE: Just like with other transformations, transformations on the Z-axis on a parent layer will also affect 
the apparent position on the Z-axis of its child layers. Therefore, a child layer's apparent position on the Z-
axis can be affected by any of its parents.
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Setting Up Multiplanes
T-HFND-008-017

You can setup your elements as a multiplane to create a parallax effect when moving your camera. You simply need 
to spread and scale the objects on the Z-axis.

How to rotate a scene in the Perspective view

 1. In the Tools toolbar, select the Rotate View   tool.

 2. Click in the view, and drag the cursor around to rotate the view or press and hold Ctrl + Alt (Windows/Linux) 
or ⌘  + Alt (Mac OS X) and click and drag to rotate the view one axis at a time. 

How to set up a multiplane

 1. To maintain the visual scale in the Camera view as you move your element, do one of the following:

 l In the Advanced Animation toolbar, select the Maintain Size  tool.

 l From the top menu, select Animation > Tools > Maintain Size.

 l Press Alt + 6.

 2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from 
the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.

 3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the same in 
the Camera view.

603



Chapter 14: Staging     About Multiplane

 4. For your element to scale up or down in relation to their distance to the camera, do one of the following:

 l In the Tools toolbar, select the Transform  tool. Make sure the Peg Selection Mode  
option is disabled in the Tool Properties view.

 l In the Advanced Animation toolbar, select the Translate  tool and select a layer from the 
thumbnails section of the Top or Side view.

 l Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

 5. In the Top  view, drag the element sideways to position it horizontally. Hold Shift while dragging the ele-
ment to make sure it only moves along the X-axis.

 6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging 
the element to make sure it only moves along the Y-axis.
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About Clone and Duplicate Layers 
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You can 
do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone uses the 
same drawings for all layers. A duplicated layer is simply an independent copy.

If you want to maintain the ability to modify drawings and propagate the changes through all layers, you should clone 
your layer. If you simply want to copy your layers and be able to modify your drawings without affecting the original 
layer, use the duplicate option.
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About Clone Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer, 
both will be updated. However, cloned layers can have different timings.

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or only 
the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element folder, 
as well as the same drawing and function columns. Therefore, if you change the drawing exposure or keyframe on 
one layer, all cloned layers will be updated.

You may want to create a large group of characters reusing the same animation, but want to slightly offset the 
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a 
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing exposures 
to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will create a 
heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same timing 
(function and exposure columns). 
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Cloning Layers
You can clone layers in several ways. Cloned layers use the same drawings.

How to clone a layer

 1. In the Timeline view, select a layer to clone. You can select multiple layers.

 2. Do one of the following:

 l From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and Tim-
ing.

 l In the Timeline view, right-click on the layers and select Clone Selected Layers: Drawings 
Only or Clone Selected Layers: Drawings and Timing.

The cloned layer appears. 
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About Duplicate Layers
T-HFND-006-013

You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as an 
independent timing (exposure). When you need the drawings to be modified independently, you will want to 
duplicate the layer instead of cloning it.
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Duplicating Layers
T-HFND-006-014

You can easily duplicate layers. Once duplicated, the layers are completely independent. Drawings are also 
duplicated.

How to duplicate a layer

 1. In the Timeline view, select one or more layers.

 2. Do one of the following:

 l In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

 l From the top menu, select Edit > Duplicate.

The duplicated layer appears.
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Displaying Port Tooltips
You can display any port tooltips by clicking on a port or connecting a cable.

How to display a port's tooltip

 1. In the Node view, hover the pointer over a port.

The port's tooltip displays source and destination information. 

 2. Click on any port to display the port type label. The label will also display as you connect cables into ports.

610



Harmony 14 Essentials - User Guide

About Peg Nodes
The Peg nodes control the transformation of elements (position, scale, skewing and rotation) over time. The green 
ports at the top and bottom of the node indicate that it accepts transformation information which can be passed on 
(inputs and outputs transformation information).

One peg can be used to control many different nodes or one node can accept more than one peg. In a situation like 
the latter, one peg might be used to modify the rotation, while the other is used to modify the position of the effect 
and then animated differently over time. 
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Connecting and Disconnecting Nodes
You can connect nodes by dragging cables from output ports to input ports. You can disconnect nodes by pulling 
on the cable connections.

How to connect nodes

 1. In the Node view, do one of the following: 

 l Extend a cable from the first node’s output port (bottom port) and connect it to the second 
node’s input port (top port). 

 l Select the node to connect, hold down the Alt key and drag the node on an existing cable.

It is possible to create links between nodes in the Node view by clicking on one node and Ctrl-clicking 
(Windows) or ⌘-clicking (Mac OS X) on a second port.

Select a node and Ctrl-click (Windows) or ⌘-click (Mac OS X) a port:

 l Click a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input port of a different 
node. The nodes are linked.

 l Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a dif-
ferent node. The nodes are linked.

 l Click the output port of a node, and then Ctrl-click (Windows) or ⌘-click (Mac OS X) a Com-
posite node. The node is linked to a new input port of the Composite.

 l Click a port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) port of a 
Composite node. The selected port replaces the link in the Composite's input port.

 l Click an output port of a node and then Ctrl-click (Windows) or ⌘-click (Mac OS X) the input 
port of a Group node. The selected output port replaces the link to the group.

 l Click an output port of a node and then Ctrl+ Alt-click (Windows) or ⌘+ Alt-click (Mac OS X) 
the input port of a Group node. The selected output port links to a new in-port of the group.

NOTE: You can reconnect a node's output port without disconnecting its destination port by dragging the con-
nect from the output port to another output port while holding Ctrl (Windows/Linux) or ⌘  (Mac OS X).
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How to disconnect nodes

 1. In the Node view, select the node to disconnect, hold down the Alt key and drag the node away. You can also 
pull on the connection cable.
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Grouping Layers
You can group your elements to keep your work organized.

How to group elements in the Timeline view

 1. In the Timeline view, select the elements you want to group. 

Any layers between the selected layers will be automatically grouped as well, so if the stacking order does 
not matter, move extra layers above or below the layers want to group. 

 2. Do one of the followings: 

 l Right-click on the highlighted layers and select Group Selection.

The layers appear indented under a new Group layer in the Timeline view. 
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Chapter 15: Motion Paths

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera moves and 
camera shakes, adjust the easing, shape your paths with control points and much more.

Before animating the position of your layers, you need to create motion paths which are trajectories on which you 
can attach drawing objects. Using keyframes, you can then record key positions along the trajectory. 

Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a 
simple motion, you will learn the basics of animating a layer.

There are two ways to create motion paths: animated drawing layers and pegs. They each have different purposes. 
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About Pegs
T-HFND-009-004

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.

Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg 
holes at the bottom or top of the animation paper are used to keep all the sheets even and at the same 
registration.

There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones are 
oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg hole.

To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the 
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and 
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create 
animation and camera motion. 

A peg is composed of many customizable parameters. These parameters are:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

You can control a peg’s trajectory the same way as the animated drawing layer.

A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds. 
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory 
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modifications much easier and faster. When building a puppet, most of the time you will add a master peg to control 
your puppet as one object.
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Adding Pegs
T-ANIMCO-001-001

You can add peg to your Timeline view and parent the layers to animate to it. 

How to add a peg in the Timeline view

 1. In the Timeline view, select the layer on which you want to attach a peg.

 2. Do one of the following: 

 l From the Timeline View layers toolbar, click the Add Peg  button.

 l From the Timeline view menu, select Insert > Peg.

 l From the top menu, select Insert > Peg.

 l Press Ctrl + P (Windows/Linux) or ⌘  + P (Mac OS X).

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer 
automatically takes the name of its child layer, with the addition of the suffix -P.

The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to the Peg 
layer. This relationship is called a parent-child relationship.

 3. If you intend to add multiple pegs or if the layer name that was added to the peg does not accurately rep-
resent the content of the Peg layer, you can rename it. Click the layer name and type in a new name. Or 
double-click the layer and type a new name into the dialog box.

 4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the 
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer 
below the Peg layer indicates whether it was correctly attached or not.

 l You can unparent layers by holding down Shift and dragging the selected parents away from 
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the child layer. Drop your selected between other layers.
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Enabling Peg Selection Mode
In the Tool Properties view, the Peg Selection Mode  lets you automatically select the peg layers in the 
Camera view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers 
directly, enable the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent 
Skipping Effects command.

How to enable the Peg Selection Mode

1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 1. In the Tool Properties view, click the Peg Selection Mode  button.

 2. In the Camera view, select an element parented to a peg.
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About Drawing Layers
T-ANIMCO-001-002

You can create a motion path directly on layers (animated layers). 

You can control and define a trajectory using several different parameters, including:

 l X, Y and Z positions (3D Path or Separate Positions)

 l Angle (rotation)

 l Skew

 l X and Y Scales

Harmony keeps track of each parameter of each layer by storing them in their own function curve. When you add a 
keyframe to a layer, a keyframe is created on each of these functions, and transformations done on a layer via the 
Camera view are translated into coordinates which are then stored in those functions. It is possible to edit these 
functions individually using the Function view, but that is rarely necessary, as Harmony provides easy-to-use tools 
for visually controlling trajectories and timing in the Camera and Timeline views.

If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select the 
layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls tab. If 
your layer was already animated, then your keyframes will appear dimmed so you can easily  identify them as ones 
that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.
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About Layer Parameters
T-HFND-009-008

A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew and 
scales. Each parameter has its own function which is a mathematical formula expressing the relationship between 
position values. You can view each function on a graph as a simple curve, such as the one below.

There are several options available for setting up function parameters:

 l Locked Positions (3D Path)

 l Separate Positions

 l Locked Scales

 l Separate Scales

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. When 
you lock or unlock parameters, this does not convert the functions from one to the other, but creates new ones.

In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you add a 
keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth 
trajectories.
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When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the 
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its 
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth 
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one another. 
This is why in cut-out animation it is recommended to use separate position settings. But if you work with 3D 
path, you can use the Constant Z feature to avoid this from happening.

The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes 
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works 
with 3D paths.

When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls 
directly on their function curve. This is useful when you want to set keyframes on one of the curves without 
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal 
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal) 
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions, 
you can squash, stretch and skew your elements.
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Displaying Layer Parameters
T-ANIMCO-001-004

You can easily display the parameters for each layer in the Timeline view.

How to display the layer parameters in the Timeline view

 1. Do one of the following:

 l In the Timeline’s left side, click a layer's Expand  button. 

 l In the Timeline view menu, select View > Show Functions.

 l Press Alt + F. 
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Setting Layer Parameters
T-ANIMCO-001-003

You can modify the layer parameters to different types of function and linking some of them together.

How to set the layer parameters

 1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also see 
the parameters in the Layer Properties window when you select the layer in the Timeline view.

The Layer Properties window opens.

 2. Select the Transformation tab.

 3. In the Position section, select the 3D Path or Separate option.

 4. In the Scale section, select the Locked or Separate option.

 5. Click Close.
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Enabling Constant Z
T-HFND-009-008A

You can also enable the Constant Z option directly in the Function view for specific functions.

How to enable the Constant Z option

 1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that you must 
select the 3D Path option for the layer.

 2. Double-click on one of the position functions to open the Function editor.

 3. In the Function editor, select the Constant Z  button.
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About Keyframes
T-HFND-009-005

Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like to 
create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no 
interpolation) and motion keyframes (computer-generated interpolation).

In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is 
constant or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to 
its new location.

In motion keyframes, there is no automatic interpolation created between the selected point and the next one. The 
layer will maintain its position until the animation reaches the frame of the next point and will then jump to the new 
position. Deselect this option to generate interpolation and get the layer to progressively move to the next 
position.
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Enabling the Animate Mode
T-ANIMCO-001-007

The Animate mode records the position, rotation, scale, skew, etc. of objects as keyframes in the Timeline view. 
Turn off the Animate mode to reposition objects for the entire scene. When the Animate mode is disabled, 
keyframes are not created when an object's parameters change.

When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your drawing 
layer. The animate mode is used to animate layers over time.

How to turn the Animate mode on or off

 1. In the Tools toolbar, click the Animate  button or select Animation > Animate.
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About Keyframe Creation
There are several different ways you can create keyframes. You can add a coordinate keyframe, position 
keyframe or a keyframe along with your drawing duplication.

You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays 
the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do not want 
to modify the original.

You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be 
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and 
Skew parameters.
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Creating Keyframes in the Timeline View
T-HFND-009-006

You can add keyframes in the Timeline view to multiple layers, a single layer or a specific parameter.

How to create keyframes in the Timeline view

 1. In the Timeline view, select the cell on which you want to add a keyframe.

 2. Add a keyframe  by doing one of the following:

 l From the top menu, select Insert > Keyframe.

 l Right-click  on the selection and select Insert Keyframe.

 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

If the Animate mode is enabled in the Camera view,  a keyframe is automatically created on the current frame.

 How to add a keyframe for a specific parameter

 1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

 2. Do one of the following:

 l Right-click the selected cell and select Insert Keyframe.

 l Press F6.

 l In the Timeline View toolbar, click the Add Keyframe  button.

How to create a keyframe and duplicate the drawing at the same time

 1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a keyframe.
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 2. Do one of the following:

 l From the top menu, select Insert > Keyframe and Duplicate Drawing.

 l Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

 l Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the original 
drawing.

632



Harmony 14 Essentials - User Guide

Creating Keyframes in the Function View
You can add keyframe directly on the graph using the Function view.

How to add or delete keyframes in the Function editor

1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt + F. 

 1. Double-click on the parameter layer name to open the Function editor window or click once on the parameter 
layer to display it in the Function view's left sidebar. If you are using the Function view, you must click on the 
function name from the sidebar list to view it in the graph display region.

 2. In the Function editor, do one of the following:

 l In the graph section, click on the frame  where you want to make changes.

 l In the Frame field, enter the frame number.

In the graph display area, the red playhead moves to that frame number.

 3. In the Function editor, click the Add Keyframe   button.
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 4. Click on the newly created keyframe and drag it up to increase the value of the function or down to 
decrease the value. Depending on the selected function, this could increase or decrease the width of the 
object (scale_x) or change the object's vertical position (position_y). Pull on the handles to create non-lin-
ear transition speeds between keyframes.

 5. If you do not like the changes you just made, select and delete the new keyframe by pressing  Delete or 
clicking the and Delete keyframe  button.

You can delete an existing keyframe by using the same process.
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Creating Keyframes in the Xsheet View
If you prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet view.

To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and 
then select the layer you want to modify. If you double-click on a function column's header, you will display the 
corresponding function curve in the Function editor.

How to add a keyframe in the Xsheet view

 1. In the Xsheet view, click the Expand button located on the right side of the main section to show the Func-
tions section. 

 1. In the Timeline view, select the layer that contains the parameters to modify.

The columns appear in the Xsheet view if function curves were previously created by adding keyframes in the 
Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

 2. In the Xsheet view, go to the function column on which you want to add a keyframe.

 3. Double-click on the cell on which you want to add a keyframe and type a numeric value.

 4. Press Enter/Return to continue to the next cell.

 5. Press Esc to exit the typing mode.
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How to convert a cell into a keyframe

 1. In the Xsheet view, go to the function column on which you want to add a keyframe.

 2. Select the cell to convert.

 3. Right-click on the cell and select Set Selection As Keyframe or press F6.

 4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in Selec-
tion or press F7.
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Deleting Keyframes
T-HFND-009-007

You can delete keyframes independently from drawing exposure.

NOTE: If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing 
exposure. To only delete the keyframe, you must use the Delete Keyframe command.

How to delete a keyframe

 1. In the Timeline view, select a keyframe and do one of the following:

 l Right-click and select Delete Keyframes. 

 l From the top menu, select Animation > Delete Keyframe.

 l Press F7.

 l In the Timeline View toolbar, click on the Delete Keyframes  button.

 l Use the Transform  tool to select a keyframe to delete from the trajectory in the Camera 
view and press Delete.
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Animating with Keyframes
T-ANIMCO-001-005

You can animate a layer or a peg by creating keyframes and moving your drawings in the Camera view.

How to animate a layer or a peg

 1. In the Tools toolbar, select the Transform  tool or press Shift + T.

 2. If you have parent pegs and are animating a drawing layer, in the Tool Properties view, make sure the Peg 
Selection Mode  is deselected.

 3. In the Tools toolbar, enable the Animate  mode. This allows the Transform tool to affect the position 
and size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and 
size throughout the whole scene. 

 4. In the Timeline view, go to the first frame.

 5. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert 
Keyframe.

A keyframe is created on the first frame of the Timeline view.

 6. In the Camera view, select the element to animate and move it to its first position.

 7. In the Timeline view, go to the frame on which you want to set the second position.
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 8. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert 
Keyframe.

A second keyframe is created on the Timeline view.

 9. In the Camera view, move the element to its second position.

 10. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 11. In the Playback toolbar, click on the Play  button to preview your animation.

NOTE: If  you animate layers on the Z axis, you may want to preview your animations from the Top or Side 
views while during playback. By default, playback is disabled in those view. To enable them, from the top 
menu, select Play > Enable Playback > Top View or Side View.
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Changing Keyframe Values
Once a keyframe is added, beside moving the image in the Camera view, you can change its value by typing it in 
the Timeline and Function views.

How to change the keyframe values in the Timeline view

 1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand  button or press Alt 
+ F. 

 2. Select the parameter for which you want to create a function curve.

 3. Place the cursor over the blue number value of the parameter and do one of the following:

 l Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand 
left to decrease the value or right to increase the value.

 l Double-click on the blue number and enter a value in the field.

How to change a keyframe value in the Function editor

 1. In the Timeline view, open the peg element's parameters by clicking the Plus  sign next the peg layer's 
name.

640



Harmony 14 Essentials - User Guide

 2. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer to 
display it in the Function view.

 3. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.

 4. Press Enter/Return or click the Play  button to view the changes made in the Camera view.

 5. Keep adjusting the values until you are satisfied with the results.

 6. Click Close.
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Switching Keyframe Types
T-ANIMCO-001-006

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.

How to switch between motion and stop-motion in the Timeline view

 1. On the right side of the Timeline view, select one or more keyframes to modify.

 2. Switch between motion and stop-motion by doing one of the following:

 l Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-
Motion Keyframes.

 l Press Ctrl + K (Windows/Linux) or ⌘  + K (Mac OS X) for motion keyframes and Ctrl + L 
(Windows/Linux) or ⌘  + L (Mac OS X) for stop-motion keyframes.

 l In the Timeline View toolbar, click the Motion Keyframe  or Stop-Motion Keyframe  
button.

How to switch between motion and stop-motion keyframes in the Function view

 1. Open the Function view.

 2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.

The Layer Properties window opens.

 3. Do one of the following:

 l In the Transformation tab, click the Function Editor  button.

 l In the Timeline view, click the Expand Function  button or press Alt + F and double-click 
on the function to edit.
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 4. On the function curve, select one or more keyframes to modify.

 5. Select or deselect the Stop-motion Keyframe  button to set a stop-motion or motion keyframe.
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Jumping to Keyframes
You can jump between the selected layer's keyframes in the Timeline view.

How to jump to keyframes

 1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip through.

 2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press semi-
colon (;) and single quote (').
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About Controls
T-HFND-009-010

Camera moves and motion paths can become quite advanced, especially with moves through 3D space. 
Harmony provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D 
perspective.

You can display the trajectory of a motion path when you select an object from any view it can be selected in.

A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both 
keyframes and control points. Both can be used to shape a path; each have their own behaviour, however only 
keyframes appear in the Timeline view. 

 l Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in 
time.

 l Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. There 
are no velocity handles available on a control point. The velocity segments are set between keyframes 
only, making curves and trajectories much smoother. Control points can only be added on a 3D path.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.

Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.
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Displaying Controls
T-HFND-009-011

You can display a layer's controls to adjust a trajectory or other parameters such as a gradient's position or 
deformation settings.

How to display the layer’s controls

 1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to dis-
play is selected in the Timeline view.

 2. From the top menu, select View > Show > Control or press Shift + F11 or in the Camera view toolbar, 
click on the Show Control  button.

NOTE: If nothing appears in the Camera view, you may not have animated or selected the 
layer.
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Adding Control Points
T-HFND-009-012

You can add control points on 3D Path trajectories. You need to display the layer's controls in the Camera view.

How to add a control point on a trajectory

 1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.

 2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top menu or 
press Shift + F11.

The trajectory appears in the Camera, Top, Side and Perspective views.

 3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and press P 
once. If you hold the key down, control points will be added continuously until you release the key.

A control point is added to the trajectory.
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Toggling Point Types
You can convert a control point into a keyframe and a keyframe into a control point. The position and other values 
will remain in both cases, only the frame will change. A control point is not locked in time.

How to switch between keyframe and control point

 1. In the Camera view, use the Transform  tool select a point to convert.

 2. To convert the point:

 l From the top menu, select Animation > Lock in Time.

 l In the Function view or Function Editor, select the keyframe to convert and click the Lock in 
Time  button.
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Adjusting Tension, Bias, and Continuity
You can adjust the shape of the curve passing through a point by modifying the bias, tension, and continuity 
settings. You can also set preferred settings as default.

How to adjust the control point preferences

 1. From the top menu, select Edit > Preferences (Windows) or Harmony Essentials > Preferences (Mac OS 
X).

The Preferences dialog box opens.

 2. Select the Camera tab and adjust the parameters in the Control Points section.
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Offsetting Trajectories
By offsetting a trajectory, you Lets you reposition the visual trajectory without offsetting or modifying your 
animation. By default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location 
than the centre of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you have 
several elements attached to one trajectory, you might want your trajectory to be at a different location to 
represent the group's motion better.

How to offset a trajectory

 1. In the Animation Tools toolbar, select the Spline Offset  tool or press Alt + 8.

 2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.

 3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the tra-
jectory, any transformation done using the Spline Offset tool will be ignored.

 4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, but 
also on the Z-axis using the Top and Side views.
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About Functions
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally 
create the ones you need to avoid being overloaded with too many functions you might not use.
When you select an element in the Camera view and move it around, it will automatically create the 
corresponding function curves. If you need to create certain functions manually, you can always do it through the 
Layer Properties view or editor.  You can then share it with other layer parameters or set keyframes directly on the 
function curve instead of doing it in the Timeline or Camera view.
You can also link a layer's parameter to an existing function curve or attach several parameters to the same 
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera 
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but 
this may produce undesirable results and even induce a feeling of motion sickness as you watch the final 
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore 
the angle, scale and skew. 

By default, all function curves can only be used and modified using their original parameter. If you want another 
layer or parameter to use the same function curve, you must share it.

There are two ways to share a function:

 l Share Functions command

 l Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:

Parameter Description

Create 3D Path Creates a new 3D Path Column set

Create Bezier Creates a new Bezier curve

Local Disconnects the parameter from any function and changes it to shared.

3D Path Displays the list of every shared 3D Path function available

Bezier Displays the list of every shared Bezier curve available

Velobased Displays the list of every shared velocity based curve available

3D Rotation Displays the list of every shared 3D Rotation function available

Connected Displays the list of every shared connected function curve

Unconnected Displays the list of every shared unconnected function curve

All Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have 
two or more parameters following the same function.

Depending on your favourite working method, you can create different types of function curves to suit your needs, 
including: 

 l Bezier function

 l Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you can use a Bezier 
function.
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These function editors present different ways of editing the values over time. The shape of the created graph 
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is largely 
based on your working preference. 
You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you do 
this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a Velobased 
function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it 
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an element.

You can convert a Bezier functions so you can edit it using the controls offered by that type of function. 

655



Chapter 15: Motion Paths     About Functions

Creating Functions
You can create function curves in several different ways. You cannot create function curves directly in the Xsheet 
view. You must do this in the Layer Properties window or the Timeline view.

 How to create the function curve in the Timeline view

 1. In the Timeline view, expand the layer's parameters.

 2. Click the Function button and, in the drop-down menu, select Create Bezier.

How to create function curves using the Layer Properties view

 1. In the Timeline view, double-click on the layer you want to create function curves for.

The Layer Properties Editor opens.

 2. In the Transformation tab, click the Function Arrow button beside the local function information.
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 3. Create a 3D Path, Bezier, or Velobased curve.

You can click the Function  button to open the Function editor.
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About Copying Motions
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and 
even copy them.

When you have position keyframes set in your drawing layer and you want to move them around when moving 
your drawing's timing, you can use the Paste Special feature to only move selected keyframes.

You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and 
drawings.

If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the 
Paste Reverse command to completely reverse the flow of your animation.
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Using Timeline Paste Modes
Use can copy and paste or drag and drop keyframes and drawings in the Timeline view using various modes.

How to paste a selection using different modes

 1. In the Timeline view, select the cells you want to copy and paste.

 2. In the Timeline toolbar, click the desired Paste  mode button.

 3. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

 4. In the Timeline view's right side, select the cell on which you want to paste your selection.

 5. Select Edit > Paste Cells in the Timeline  or press Ctrl + V (Windows/Linux) or ⌘  + V (Mac OS X).

Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

Paste Mode: Exposures Only
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Using Paste Special
You can copy drawing exposures and keyframes and paste only a portion of your selection using Paste Special.

How to copy and paste a motion using Paste Special

 1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go to step 
3.

 2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘  + C 
(Mac OS X).

 3. Edit your selection by doing the following:

 l To paste the selection, in the Timeline view, select the first cell on which you want to paste 
your keyframes and from the top menu, select Edit > Paste Special or press Ctrl + B (Win-
dows/Linux) or ⌘  + B (Mac OS X).

 l To move the selection, in the Timeline view, drag the selection and hold down Alt. Drop the 
selection where you need it and release the hot key.

The Paste Special window opens.

 4. Set the Drawing, Pegs and Functions, and Cycles parameters. 

 5. Click OK.
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About Velocity
T-ANIMCO-001-009

To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease 
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters 
script and set the amount.

The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve 
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and 
left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to 
adjust the ease in and ease out, or type values in the fields.

You can reshape the velocity function using Bezier controls.

If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for 
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes 
in the same frame.
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Displaying Velocity Curves
You can display a parameter's function curve and adjust the easing with the relevant controls.

How to display the velocity curve

 1. In the Timeline view, click the Expand  button on a layer or press Alt + F.

The layer’s functions are displayed.

 2. Double-click the desired function. Note that 3D Paths have a specific velocity curve controlling the X, Y, and 
Z axis together. You need to click on the Position:Velocity layer.

The Function Editor opens as the Bezier Editor.
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The editor will not be displayed if the function does not already exist.
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Adjusting Bezier Curve Velocity
You can reshape a Bezier curve velocity using the Function view controls.

How to adjust a Bezier curve velocity

 1. In the Function view, select a keyframe.

 2. Drag the controls to modify the shape of the curve.

You can reshape the function using the Bézier controls.

 3. The Continuity options influence how you can move the handles:

 l Straight: Lets you move the handles together, maintaining the same angle to the point.

 l Corner: Lets you move the handles independently.

 l Smooth: Lets you move the handles together, maintaining the same distance and angle to the 
point.
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Creating Stepped Velocity
You can create a stepped curve to hold the same value over a selected number of frames. This works well when 
you are animating drawings on 2s, for example, and you want to hold the same value for a function over those two 
frames.

How to create a step velocity

 1. Click the Hold Value Editor  button.

The Hold Value editor opens.

 2. In the Hold Value Editor, enter the following values:

 l Start: The starting frame for the effect.

 l Stop: The last frame for the effect.

 l Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) consistently 
between keyframes. That is, there is no acceleration in the effect.

How to create a step velocity for multiple parameters

 1. Add the Scripting toolbar to your interface:

 l Go to the top menu and select Windows > Toolbars > Scripting.

 l Right-click on the empty space near the top of the interface  and from the quick-access menu select-
ing Scripting.

 l Right-click on the empty space near the top of a view and from the quick-access menu selecting 
Scripting.

 2. In the Scripting toolbar, click on the Manage Scripts  button to open the Scripts Manager window.

 3. In the Scripts Manager, in the Files section, select the file TB_CreateStepsOn.js.

The functions associated with that file appear in the Functions section.
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 4. In the Functions section, select TB_CreateStepsOn.

The Add script to toolbar button becomes active.

 5. Click on the Add script to toolbar button.

The TB_CreateStepsOn script  button is added to the Scripting toolbar.

 6. Click Apply.

 7. Click OK.

 8. In the Timeline view, select the layer whose parameter values you would like to hold. 

 9. In the Scripting toolbar, click on the TB_CreateStepsOn script  button.

The Create Function Step On dialog box appears.

 10. In the Settings section, enter the hold value by changing the number in the Every Number of Frames field.

 11. In the Selection section, enter the first and last frame numbers to define the selection range.

667



Chapter 15: Motion Paths     About Velocity

NOTE: The playhead location determines the lowest value you can enter for the first frame, when 
defining the selection range. You need to move the playhead to frame one if you would like to set 
frame one as the lowest possible starting value. 

 12. Click OK.

 13. In the Timeline view, expand the layer properties of the selected layer by clicking on its plus  button.

 14. Double-click on a parameter layer to open its Bezier Editor. If that parameter was animated, the 3 frame 
hold from frame 20 to 60 was applied.
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 15. In the Bezier Editor, click on any of the keyframes to bring up the bezier point handles and use them to 
reshape the velocity curve for that parameter.

This means that multiple parameters can have the same stepped velocity, but have different ease-in ease-out 
curves defining that velocity.
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Adjusting Velocity in the Timeline View
If you would rather avoid playing with graphs and function curves, you can adjust the velocity in the Timeline 
view.

How to set the ease in the Timeline view

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter 
function. If many keyframes are selected on the same layer, the ease values will be applied only on the first 
keyframe and the rest will be ignored.

 2. In the Timeline toolbar, select an option from the Set Ease Type menu.

NOTE: TIP: Optimize your workflow by adding the Apply Ease to Selection  button to the Timeline tool-
bar. This lets you quickly reapply the ease type without going through the Set Ease Type menu each time. To 
add the button to the toolbar, right-click on the toolbar area of the Timeline view and select Customize. 
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Setting Ease on Multiple Parameters
T-HFND-009-013

You can adjust the velocity on multiple parameters at a same frame for consistency.

How to set the ease on multiple parameters

 1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple 
Parameter function. If many keyframes are selected on the same layer, the ease values will be 
applied only on the first keyframe and the rest will be ignored.

 2. Do one of the following:

 l In the Timeline view, right-click and select Set Ease For Multiple Parameters. 

 l In the Timeline toolbar, click the Set Ease For Multiple Parameters  button.

The Set Ease For Multiple Parameters dialog box opens.

 3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.
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 4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as 
Rotation or Scale. Deselect the function types you do not want to affect.

 l Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z 
and 3D Path functions.

 l Rotation: Applies the easing parameters to the selected Angle functions.

 l Scale: Applies the easing parameters to the selected Scale functions.

 l Skew: Applies the easing parameters to the selected Skew functions.

 l Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note 
that it applies to the Morphing velocity function found in the Layer Properties window, not the 
basic morphing ease in the Tool Properties view.

 l Other: Applies the easing parameters to all the other the selected functions, such as all func-
tions created to animate effect parameters.

 5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are cal-
culated in percentage.

 l In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding 
to the length of time you want the easing to last. Stay between 0% and 100%. If you go bey-
ond 100%, your motion will overshoot. 

 l In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong 
you want the easing out to be. Stay between 0% and 100%. If you go beyond 100%, your 
motion will overshoot. 

 l If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

 6. Once done, click one of the following:

 l Apply/Previous: Applies the easing parameters to the selected keyframes and then selects 
the previous keyframe in the timeline.

 l Apply: Applies the easing parameters to the selected keyframes.

 l Apply/Next: Applies the easing parameters to the selected keyframes and then selects the 
next keyframe in the timeline.

 l Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.
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Chapter 16: Cameras
T-HFND-009-001

Harmony contains a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis 
offers the possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera 
position is centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony, which is based on the origins of animation. In 
traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and measures 
0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart. Harmony 
uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the north-
south (up-down) direction and the Z axis is the forward-backward direction.

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the 
camera resolution and other parameters in the Scene Settings window. 

By default, a scene does not have a camera layer. In order to be able to tweak the camera's angle and position, you 
must add one to your scene. Although it is possible to have several cameras in the same scene, you can only view 
your scene using one camera at a time. This can be useful if you are still working on your scene composition and 
have different camera framing to try out.

The Camera layer is static which means that if you need to animate it, you must put it under a parent peg.

You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another 
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this positions 
the camera precisely where you want it to be rather than gauging it visually.
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You can change the near and far clipping planes of the camera. The near plane is the point on the camera cone 
where the camera is located. The far clipping plane is the far end of the camera cone. Nothing outside that range 
is visible. This is useful when dealing with 3D elements and 3D sets.  For example, the camera can be looking 
inside a 3D box or room and you might want the foreground wall to not obstruct the view of the interior. By default, 
the near clipping plane is set to 1 field and the far clipping plane is set to 1000 fields.
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Adding a Camera
T-HFND-009-002

By default, there is no camera in the scene. The frame visible in the Camera view is only a reference based on your 
project's resolution. In order to position your camera, you must add one to your scene.

How to add a camera in the Timeline view or Top menu

 1. Do one of the following:

 l In the Timeline view, click the Add Layer  button and select Camera.

 l From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.
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Selecting the Active Camera
T-HFND-009-003

You can add multiple cameras to your scene, but only one can be active at a time. You can select your active 
camera from the Camera list.

How to select the active camera from the Camera list

 1. From the top menu, select Scene > Camera > camera.
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Positioning the Camera Frame
You can grab the camera frame and move it around in the Camera view. You can also setup the camera position by 
entering coordinates and values in the Layer Properties view.

How to reposition the camera frame in the Camera view

 1. In the Tools toolbar, disable the Animate  mode.

 2. Do one of the following: 

 l From the top menu, select Animation > Tools > Translate. 

 l In the Advanced Animation toolbar, click the Translate  tool.

 l Press Alt + 2.

 3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera 
layer from the Timeline view.

The selected camera frame is highlighted.

 4. Drag the camera frame to a new position. 
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 5. To tilt the camera frame, do one of the following to select the Rotate tool:

 l From the top menu, select Animation > Tools > Rotate.

 l In the Advanced Animation toolbar, select the Rotate  tool.

 l Press Alt + 3.

 6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.

 7. To move camera frame closer to or further away from the scene, do one of the following to select the Scale 
tool:

 l From the top menu, select Animation > Tools > Scale.

 l In the Advanced Animation toolbar, select the Rotate  tool.
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 l Press Alt + 4.

NOTE: The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to set up the camera frame using the Layer Properties view

 1. In the Timeline view, select the camera layer.

 2. In the Layer Properties view, adjust the camera's properties.

 3. Type or use the numeric stepper to adjust the coordinate and angle values—see the Reference guide .
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Resetting the Camera Position
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the 
selected element to the initial value of the active tool. For example, if the Rotate tool is active, the transformation 
angle will be reset to 0 and if the Transform tool is active, then all parameters values will be reset.

How to reset the camera position

 1. In the Tools toolbar, select the Transform  tool or press Shift + T. If you want to reset a single para-
meter, select the corresponding Advanced Animation tool, such as the  Rotate  tool.

 2. In the Timeline or Camera view, select the camera layer.

 3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.
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Animating the Camera
T-HFND-009-009

A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and you 
can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, which 
means it keeps the same position and angle throughout the whole scene. In order to be able to animate the camera, 
you need to connect it to a peg layer, which can be animated, and which will directly affect the position and angle of 
the camera. 

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or Top 
views, which can be especially useful when animating a camera in a multiplane scene.

How to animate the camera

 1. In the Tools toolbar, enable the Animate  mode.

 2. In the Tools toolbar, select the Transform  tool or press Shift + T.

 3. In the Timeline view, select the Camera layer.

 4. From the Layers toolbar, click the Add Peg  button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it. 

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a Peg 
layer, for example Camera-P.

 5. On the right side of the Timeline view, on the Camera Peg layer, select  the frame at which you want the cam-
era movement to start.

 6. Do one of the following to add a keyframe:
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 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera 
position as this keyframe.

 7. Do one of the following to move the camera:

 8. In the Camera view, select the Camera, which should now be represented by a thin yellow rectangle with a 
red highlight, and move it to the desired position.Do one of the following to select In the Top, Side or Cam-
era view, select the camera (the large V-shaped cone) and move it to the desired position. In the Camera 
view, the camera is represented by a thin frame. You need to click directly on one of the edges.

 l In the Camera view, select the Camera, which is now be represented by a thin yellow rect-
angle with a red highlight, and move it to the desired position.

 l In the Top or Side view, select the camera, which is now represented by a large, yellow V-
shaped cone, and move it to the desired position.
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 9. On the Timeline view, click on the cell where the camera move will end.

 10. Do one of the following:

 l In the Timeline toolbar, click the Add Keyframe  button. 

 l Right-click and select Add Keyframe.

 l Press F6.

A keyframe appears in that cell.

 11. Select the camera in the Camera, Top or Side view and move it to the desired position. 

 12. In the Timeline view, select the first frame to rewind to the beginning of your animation.

 13. In the Playback toolbar, click on the Play  button to preview your animation.
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Chapter 17: Sound
With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing 
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to trim 
unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to continue 
throughout your animation.

Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection. 
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best 
apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for your 
character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your animation 
based on the mouth chart.
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About the Sound  Editor
When you double-click on a sound layer in the Timeline view, the Sound Element Editor appears.

 l Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

 l Layer Name: This field displays the layer's name.

 l Sound Editor: This button opens the Sound editor.

 l Start Frame/End Frame: These fields determine the start and end frame of the sound file.

 l Detect: This button launches the automated lip-sync detection.

 l Map: This button opens the Map Lip-sync dialog box.

 l Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the 
thumbnail image of each mouth to change the phoneme assigned to the current frame.
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Sound Layer Properties
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer Properties 
view.
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Importing Sound
T-HFND-007-009

If you wish to add sound to your animation, you should first edit and mix your sound files in a sound editing 
software. It is recommended to mix down your sound into full length sound tracks so that you can work with the 
exact same sound track in the different applications used for your production. 

Sound can be clipped in Harmony if needed. Importing a soundtrack longer than your scene will not extend your 
scene's length. Sound playback will stop at the end of your scene's length.

If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate 
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the 
exported scenes, allowing you to save time on splitting and importing your sound track.

Harmony can import .wav, .aiff and .mp3 audio files. It is recommended to work with .wav and .aiff files if 
possible. 

How to import a sound file

 1. Do one of the following:

 l From the top menu, select File > Import > Sound.

 l In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

The Select Sound File dialog box opens.

 2. From the Select Sound File dialog box, find and select a sound file.

The sound file  appears as a layer in the Timeline view. Its waveform is displayed in the track to help you 
visualize at which frames the sound effects in your soundtrack occur. 

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by default. 
If you wish, you can display a sound column's waveform by right-clicking on it, then selecting Sound 
Display > Waveform.
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Playing Sound
T-HFND-007-010

Before playing back any sound, click the Enable Sound  button in the Playback toolbar or enable it through the 
Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the ones 
included within symbols.

If there are two or more sound layers and you want to listen to them independently, you can disable the unwanted 
sound by clicking the Disable Layer  button on the sound name layer in the Timeline view.

If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you can do 
one of the following to troubleshoot the issue:

 l Shrink down the Camera view size to reduce the cached image size.

 l Playback your scene without sound first, then add the sound. If you do not cache the imahes first without 
sound, the playback will try to follow the sound by skipping images that will never get cached.

How to play back sound

 1. To select a starting point:

 l In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to 
the correct cell.

 2. In the Playback toolbar, activate the Enable Sound  button.

 3. Do one of the following:

 l Click the Play  button in the Playback toolbar.

 l From the top menu, select Play > Play or click on the Enter/Return key.

 4. To hear the sound played back again and again, do one of the following:

 l Click the Loop  button in the Playback toolbar 

 l From the top menu, select Play > Loop.

 5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer  button.
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Changing the Sound Display
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing needs.

You can show or hide the waveform in the Timeline view by selecting the Waveform  button in the Timeline 
View toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by 
default.

How to change the sound display in the Timeline view

 1. In the Timeline view's right area, right-click in the frame section and select Show Sound Waveforms.

 l You can change the waveform scale using the Zoom Waveform  icon on individual sound layers in the 
Timeline view's left side.

How to change the sound display in the Xsheet view

 1. Right-click in the sound column or on the sound column header, and select Sound Display and one of the 
following:

 l Sound Name: Shows the name of the sound file, as well as the file format. The line running 
vertically through the column frames between the same file name indicates a continuity of 
the same sound file in these frames.

 l Mouth Shapes: Shows the letter (or name depending on the way you named your char-
acter's different mouth positions) in the column's frames. There is only one mouth position 
allotted per frame and this position should correspond to the sound file after performing a lip-
sync.

 l Waveform: Shows a vertical display of the sound file's actual waveform. In the column 
header, in the field under the column name, you can type in a percentage to zoom in or zoom 
out on the waveform, or pass the scroll cursor  over the Zoom Waveform  icon.
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Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the 
playback pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds 
from the Timeline view. 

How to scrub a sound from the Timeline view

 1. Do one of the following:

‣ From the top menu, select Play > Enable Sound Scrubbing. 

‣ Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣ In the Playback toolbar, enable the Sound Scrubbing  button. 

 2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

 3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent sound 
frames. This allows you to do a more fluid scrubbing.
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Editing Sound
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the sound 
editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of Harmony 
and imported into your scene.

How to open the Sound Element editor

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

The Sound Element Editor dialog box opens.

The Sound Element editor consists of three main parts.

 l Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard when the 
final movie is rendered. It may be shorter than the original sound sample due to the length of the scene. If any 
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edits are made to the sound sample, they can be heard here. In the Sound Element panel, notice the col-
oured tabs that indicate the start and end frames of a sound segment. The frame number is displayed in 
the tab.

 l Current Sound: Displays the original sound file in its entirety and is where you can edit its properties. 
This window remains empty until you click inside the Sound Element Editor.

 l Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth pos-
itions to correspond with the sound sample. 
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Cropping Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make 
sure the sound ends by a certain frame, you must set an end frame.

In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame number is 
shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.

How to change start or end frame of a sound

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking 
the start and stop lines of each waveform section.

Click the Play  button in the Current Sound section (only the selected sound plays).

 3. Within the Sound Element panel, drag the selected clip to the frame number where you want it to start play-
ing. 
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You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in 
the same element.

 4. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.

 5. To hear how all the clips fit together in the element, click the Play  button  in the Sound Element section.

If you only want to hear the selected clip, click the Play  button  in the Current Sound section.

 6. Click Apply/Next.

The Xsheet and Timeline views display the sound clip at the start frame you selected.
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Trimming Sound
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For 
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise. 

The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest. This 
means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit sound 
files completely in a sound editor before bringing them into Harmony.

How to trim the start and end of a sound file

1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one 
sound section from another on the same sound layer, check the frame numbers that appear on tabs flanking 
the start and stop lines of each waveform section. Or select a soundwave and click the Play  button in the 
Current Sound panel (only the selected sound plays).

 3. Using the Current Sound section, decide on the part of the file you want to play by dragging the left and right 
boundaries of the selection area.

 4. Click the Play  button in the Current Sound section to check that you have trimmed the desired sections. 
Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim it more accur-
ately.

 5. Click Apply/Next. 

The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end positions you 
selected.
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Looping Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.

How to loop a sound sample

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. From the Sound Element section, select the sound section you want to loop.

 3. In the Current Sound section, type the number of times you want the sound to play in the Number of Loops 
field.

 4. Press the Enter/Return key. 

The looped sound appears after the current sound. They are indicated by their grey waveforms, as 
opposed to black.

When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the 
next sound sample starts or until the scene ends. This means that the looping could be cut if the next 
sound sample starts too soon or if the scene ends too quickly.
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Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and 
fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original sound file 
is not affected.

How to adjust the overall volume of the entire sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. In the Sound Element section, select the sound you want to work on. 

A more detailed version of the selected sound appears in the Current Sound section.

 3. In the Current Sound section, use the Volume slider to adjust the volume.

 4. Click the Play  button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip

 1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.

 2. In the Sound Element section, select the sound you want to work on.

 3. In the Current Sound section, click on the thin blue line above the waveform to add an envelope marker.

 4. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The line 
from the edge of the clip to the envelope marker identifies how the volume increases (fades-in) or decreases 
(fades-out) over time.

Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards increases the 
volume. 
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NOTE: To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right 
(bottom and top) channels.

 5. Click the Play  button in the Current Sound panel to check the fade envelopes.
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Setting the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start or 
stop at specific frames. This customized playback range does not affect the actual sound in the Sound element. 

How to change the playback range in the Sound Element editor 

 1. Drag the start or end range markers in the Sound Element section to the boundary frames you want.

 2. When you click the Play  button to play back your sound in the Sound Element editor, it only plays the 
sound which exists between the two markers.
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Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For 
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist 
on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-quarter view 
and have mouth position changes to fit with the sound sample from these two different views, you would need to 
cut up the sound samples needed for the profile view mouth positions on one layer and the sound samples needed 
for the three-quarter view on another.

For this task, you will need an empty sound layer. 

How to add an empty sound layer

 1. In the Timeline Layer toolbar, click the Add Layer button.

 2. From the drop-down menu, select Sound.

An empty (silent) sound layer appears in both the Timeline and Xsheet views.

 3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound Element 
editor. Click Apply/Next to accept the change.

1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut and Shift 
+ click on the final cell of the cut. The sample to be cut becomes highlighted.
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2. Drag the selection into the empty sound layer below.

 4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the lip-
synching process for each layer and its corresponding facial view.

NOTE: If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate Selec-
ted Layers button in the Timeline View toolbar. You must customize the toolbar to display this button because it 
is not included in this toolbar by default.
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About Lip-sync
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a 
particularly tedious part of the animation process. 

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the 
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in 
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE: The letters assigned to these mouth shapes are standard identifiers, they NOT correspond to the 
sound they are meant to produce. 

This is an approximation of the English phonemes each mouth shape can be used to represent:

 l A: m, b, p, h

 l B: s, d, j, i, k, t

 l C: e, a

 l D: A, E

 l E: o

 l F: u, oo

 l G: f, ph

 l X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the 
drawing column of your character's mouth layer with the generated lip-sync, by inserting the letter associated with 
the right mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, your 
character's mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and these 
drawings should be named by their corresponding letter. 
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, Xsheet 
view and Sound Element editor.

How to generate a sound detection for lip-sync using the Layer Properties view

 1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

 2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.

 3. Click the Map button to open the Lip-Sync Mapping dialog box.

 4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice 
track. 
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 5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

 7. Click OK.

 8. In the Playback toolbar, enable the Enable Sound  option.

 9. Press the Play  button in the Playback toolbar to see and hear the results in the Camera view

How to generate a  sound detection for lip-sync in the Xsheet or Timeline view

 1. Do one of the following: 

 l In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-Sync > 
Auto Lip-Sync Detection. 

 l From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame. 

How to generate a sound detection for lip-sync using the Sound Element editor

 1. Do one of the following:

 l In the Timeline view, double-click on the sound layer.

 l In  the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.

 2. In Sound Element section, select the waveform for which you want to generate a mouth chart.

 3. Right-click on the sound file and select Auto Lip-Sync Detection.
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A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to 
each sound cell.
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Mapping the Lip-Sync Detection
Harmony can automatically map Automatically maps drawings in an element to the mouth chart you have 
generated for a sound. This can save time when you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically labels 
all of the cells in the character's element with the appropriate name.

How to automatically map lip-sync drawings to a mouth layer

 1. To open the Lip-Sync Mapping dialog box, do one of the following:

‣ In the Layer Properties view, click on the Map button.

‣ In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map Lip-
Sync. 

‣ From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

 2. From the Destination Layer menu, select the layer that contains the mouth positions for the character's 
voice track. 

 3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the 
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to 
use the drawings or select the desired symbol from the drop-down menu.

 4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it 
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
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Modifying the Lip-sync Detection
You can change the mouth position assigned to a frame if you think another position is more appropriate. 

For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would 
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in 
astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an F.

If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the Lip-Sync 
Detection on page 708.

How to change the mouth position assignment of a sound from the Sound Element editor and Layer Prop-
erties view

 1. Double-click the sound layer name in the Timeline view to open the Sound Element editor.

 2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth position 
assignment on.

In the Lip-sync image area, the image on top represents the lip position assigned to the current frame. 

1. To change the image assigned to the frame, click on the image of the mouth position you want from below the 
preview image. The preview image changes to the mouth position image you select. You can perform the 
same operation in the Layer Properties view.

The position is updated in the Timeline view.

NOTE: Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.
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Manual Lip-syncing
You can manually create the lip-syncing for your scene  by selecting which mouth drawing should be exposed at 
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality, 
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, allowing 
you to identify which phonemes you should match your character's mouth to. You will also be using drawing 
substitution to change which mouth drawing is exposed at every frame.

How to animate lip-sync using the Timeline view

 1. In the Playback toolbar, enable the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the sound layer waveform.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing 
name (often a letter) until it changes to the swapping  pointer.

 5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing 
automatically changes to the new selection.

How to animate lip-sync using the Library view

 1. In the Playback toolbar, click the Sound Scrubbing  button.

 2. In the Timeline view, drag the red playhead along the waveform of your sound layer.

 3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips 
for an "oh" sound, click on that frame on your mouth shapes layer.

 4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The cur-
rent drawing is swapped for the one in the preview window.
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Chapter 18: Effects
T-HFND-010-001

When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs, 
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the way 
layers or groups of layers are rendered in your scene. 

Effects are special types of layers that you can add to your scene's structure. For an effect layer to work, it must be 
connected to a drawing or a group. Effects only alter the drawing or group they are connected to, which gives you 
flexibility in deciding precisely which parts of your scene is affected.

Some effects need to be linked to another layer referred to as the matte layer, which is used to define the area they 
should affect. The most basic example of this is the Cutter effect. Alone, a cutter effect does not have any effect on 
your drawing. Once combined with a matte layer, the Cutter effect cuts the shape of the matte out of the drawing. 

A matte layer is simply a drawing layer that is connected to an effect as its matte. The effect takes the shape of the 
drawing in the matte layer, ignoring its colours and details. 
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In the Timeline view, an effect must be rigged as the child of the drawing layer or group it is meant to affect. If the 
effect requires a matte, it will have a Matte parameter, on which you can drag and drop the layer you wish to use 
as the effect's matte layer.

Once your effect is connected, you can adjust its parameters using the Layer Properties view. If desired, you can 
even animate the parameters of your effect by converting their values to functions. 
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Adding Effect 
T-HFND-010-004

In Harmony, you can add effects through the Timeline view, connecting them to your drawing layers and then 
adjusting the parameters until you achieve the look you want.

How to add effects in the Timeline view

 1. In the Timeline view, select the layer on which you want to add an effect.

 2. Do one of the following:

 l From the top menu, select Insert > Effects > effect. 

 l In the Layers toolbar, click the Add Layers  button and select Effects > effect. 

 l From the Timeline menu, select Insert > Effects > effect. 

The effect appears in the Timeline view.

 

 3. In the Camera view, click the Render View  button to see  the scene's rendered current frame and effect. 
Note that most effects cannot be played back in real time. You need to use the Render and Play option in 
the Playback toolbar.

NOTE: By default, your background will appear pitch black. To remedy this, you can add a Colour 
Card layer at the bottom of your layers list, and tweak its colour in the Layer Properties view. 

 4. In the Timeline view, double-click on the effect layer to open the Layer Properties window. You can also 
select the effect layer and see its properties in the Layer Properties view.

The Layer Properties view opens, displaying the parameters available for the selected effect.
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 5. In the Layer Properties view, adjust the effect’s parameters as needed. Each time you make a change, the 
Camera view will need to refresh the render, which may cause a little delay before you can observe its 
effect.

 6. To play back your scene with the final effects, in the Playback toolbar, click the Render and Play  but-
ton.

NOTE: Once you have set the parameters for the effect, you can store it in the Library view as 
a template, so you can quickly reuse it without resetting the parameters again—see Templates 
in Chapter 7: Library of the Cut-out Animation Guide.
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Connecting Effects
T-HFND-010-006

You can connect layers to effects that have a single input or multiple input, such as effects using masks.

How to connect an effect in the Timeline view

 1. In the Timeline view, select the effect you want to connect to the drawing layer.

 2. Drag the effect and drop it onto the drawing layer.

How to connect effects with more than one port

 1. Select a drawing layer.

 2. Click the Add Layers  button and select Effects > Highlight.

The Highlight effect is parented to the selected layer.

 3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 4. In the Timeline view, click the Collapse/Expand  button on the effect layer.

 5. Drag and drop the matte layer beside the Matte field.
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 l Connect the Matte drawing to the Matte port of the Highlight node.

 6. Display the effect properties and adjust them until you achieve the desired effect.
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About Effects Preview
T-HFND-010-010

Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL 
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.

Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter, Harmony 
will recalculate the preview image. If your scene is heavy and you do not want the preview rendered automatically, 
deselect the Auto-Render option and do the preview update manually.

You cannot play back your animation in Render mode. You must perform a render or a preview render to see your 
animation with the final effects.  Effects must be calculated before they can be viewed in real time.

To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the 
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a 
check preview.
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Previewing Effects in Render Mode
T-HFND-010-011

You can preview a single final frames with all effects calculated in the Camera view when you enable the Render 
mode. You cannot playback your animation in Render mode. You can also disable the auto-render option when 
adjusting several effect parameters to avoid slowing down your computer.

How to preview effects in Render mode

 1. In the Camera view status bar, click the Render Mode  button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render. 
Depending on the size of the frame to render, it may take several seconds.

How to disable the Auto-Render option

 1. In the Camera view status bar, click the Auto-Render  button. In the top menu, you can enable and dis-
able Scene > Render > Auto-Render.

Once the Auto-Render option is disabled, you must request the preview update by clicking the Auto-
Render  button.

How to manually update the rendering preview

 1. In the Camera view status bar, click the Render button.
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Playing Back Effects
T-HFND-010-012

To playback your effects, you need to do a temporary render.

How to play back effects

 1. In the Playback toolbar, click the Render and Play  button.

The Play node opens and loads the frames.

 2. Once the frames are loaded, click the Play  button in the Play window.

 3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE: While previewing effects, you can press the Spacebar to stop and start playback.
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Changing the Preview Resolution
The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or one-
quarter of the scene resolution. You can even customize the preview resolution size.

How to use the Preview Resolution command

 1. From the top menu, select View > Preview Resolution and one of the following: 

‣ Same as Scene Resolution

‣ 3/4 of Scene Resolution

‣ 1/2 of Scene Resolution

‣ 1/3 of Scene Resolution

‣ 1/4 of Scene Resolution 

‣ Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.

 2. In the dialog box, select a resolution from the presets or type a new X-Y value.

 3. Click OK.

 4. Preview your effects animation.
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Animating an Effect
In some cases, you may want to have the intensity,  color, or another parameter of an effect animated.  For example, 
you may want an object to fade in or out, which would require making its transparency level animated so that it 
increases or decreases as your scene goes. You can animate an effect's parameters by creating a function curve for 
its parameter. You can then add keyframes to the function and set them to different values, hence making your 
effect's parameter change value as your scene plays out. To do this, you will need to use the Layer Properties view.

How to animate an effect

 1. In the Timeline view, select a layer and add an effect to it by doing one of the following:

 l Click the Add Layer  button and select Effects > desired effect.

 l Right-click and select Insert > Effects > desired effect.

 l From the top menu, select Insert > Effects > desired effect.

 2. Create the function curve by doing one of the following:

 l Double-click on the effect layer to display the effect properties. Click the Function  button of 
the parameter you want to animate and create a function curve.

 l In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand  
button. Then click the Function  button of the parameter you want to animate and create a 
function curve.
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 3. In the Timeline view, go to the frame on which you want to start animating the effect.

 4. In the Timeline toolbar, click the Add Keyframe  button.

 5. In the Value field of the parameter you want to animate, enter the keyframe value. If your keyframes are 
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set 
Motion Keyframe.

 6. Repeat these steps until your effect's animation is complete.

NOTE: Refer to About Effects Preview on page 717 to learn how to preview animated effects.
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About Advanced Node Usage
Some nodes only require to be connected to a drawing node, others require additional operations and connections. In 
this section you can see how to use some of the most common effects. You can also refer to the Nodes section in 
the Reference guide to learn more about each node—see the Reference guide .

Using the Shadow Node 724

Using the Cutter Node 726
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Using the Shadow Node 
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and 
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of 
the shadow. 

To add a shadow stretched out on the ground, simply add a Quadmap node to flip, stretch and skew the matte. 
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your 
character—see the Reference guide . 

How to use the Shadow effect

 1. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.

 2. In the Timeline view, click the Collapse/Expand  button on the effect layer.

 3. Display the Shadow properties and adjust the properties to control the type and amount of blur and the col-
our of the tone effect.
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Using the Cutter Node 
You can use the Cutter node to cut out parts of a layer. You can also use it to only show certain parts of a layer by 
enabling its Inverted parameter.

How to use the Cutter effect

 1. Select a drawing layer.

 2. Click the Add Layers  button and select Effects > Cutter.

The Cutter effect is created as a child of the selected layer. 

 3. In the Timeline view, create a new layer, which will be used as your Cutter effect's Matte layer.

 4. In your new Matte layer, draw the shape that you want to cut out from your drawing layer. 

 5. In the Timeline view, click the Collapse/Expand  button on the effect layer to display its Matte para-
meter.

 6. Drag and drop your matte layer next to your Cutter layer's Matte field, under the Parameters column.

 7. If you want to invert the Cutter's effect, double-click on your Cutter layer to open its Layer Properties dia-
log, then enable the Inverted option. 
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Chapter 19: Export
Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to further 
edit your movie using a third party software, composite the movie in a larger body of work or put it up directly on the 
web, Harmony supports several formats for all your rendering needs.

The render resolution for the various editions of Harmony are:

 l Harmony Essentials: 2K (2048x1556)

 l Harmony Advanced: 4K (4096x3112)

 l Harmony Premium: Unlimited
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Exporting QuickTime Movies
T-HFND-010-013

If you need to create a video file, you can export your scene as a QuickTime movie. 

By default, Harmony will export your entire scene in your scene's actual resolution. You can also choose to 
export only a specific frame range in your scene, or to export in a smaller resolution, which can be useful if you 
need to save on time or disk space. If you have specific requirements for the quality of your exported video files, 
you also have access to the codecs and compression settings made available by QuiickTime's interface. 

How to export a QuickTime Movie

 1. From the top menu, select File > Export > Movie.

The Export to QuickTime Movie dialog box opens.

 2. Click Browse and select a folder in which to save your movie and give it a file name for the export.

 3. Click OK.

 4. From the Export Range section, decide whether you want to export the entire scene (All) or a specific 
frame range. If you decide on the latter, enter the frame range.

 5. In the Resolution section, select one of the following from the menu:

 l A preferred resolution ratio.

 l Custom:  Enables the Width and Height fields so you can enter a specific size.

728



Harmony 14 Essentials - User Guide

 6. In the Options section, click Movie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and size.

Settings: Opens the Standard Video Compression Settings dialog 
box.

Filter: Opens the Choose Video Filter dialog box, where you can 
select from a range of filters to apply to your video export.

Size: Opens the Export Size Settings dialog box. The size settings 
are overridden by the Harmony's scene settings.

Sound
Enables the customization of the sound settings.

Settings: Opens the Sound Settings dialog box (see below).

Prepare for Internet Streaming Enables the customization of the Internet streaming options.

 7. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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 8. From the Compression Type menu, select a codec. The availability of certain compression settings 
depends on the Compression Type selected. For example, Animation is the default compression type and 
as a result the Data Rate option is greyed out. 

NOTE: If you want to render a QuickTime movie with lossless compression and transparency, you 
can use the Animation video codec with the colour depth set to Millions of Colours +. 

 9. In the Motion section, choose a Frame Rate from the list. 

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower 
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher 
frame rate. 

 10. If you want keyframes inserted, select the Every option and set the number per frame. 

This is the option is recommended by QuickTime. For further details, refer to the QuickTime 
documentation.

 11. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of 
the export, the larger the file.

 12. From the Data Rate section, either choose to allow the program to automatically select the most optimal 
bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of 
the export. 
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 13. In the same section, from the Optimized For menu, select the intended viewing method for the export.

 14. Click OK.

 15. From the Movie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

 16. From the Compressor menu, select a compression type. The default setting is None. This exports your 
audio as is without performing any lossy compression or conversion, preserving its fidelity. Other com-
pressors can be used if you need your movie's audio track to be exported in a specific format, or if disk space 
or download speed is critical, but they may impact the quality of your movie's soundtrack negatively. 

 17. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of your ori-
ginal sound files. For example, if your file has an audio sample rate of 48 kHz and you choose a conversion 
rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be missing, making it 
sound muffled. For reference, the standard sound quality is 44.1 kHz for films, and 48 kHz for DVD. Lower 
rates are liable to impact the quality of your movie's soundtrack negatively, but they can be useful if disk 
space or download speed is critical.

 18. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of precision 
used to record each wavelength in the soundtrack. The standard size is 16-bit. If you choose 8-bit, the 
amount of disk space your sound track requires is halved, but the audio will sound muffled.

 19. Select whether to Use the Mono or Stereo channel mode.  Stereo sound has a separate sound track for the 
left and the right speakers, allowing to make the origin of each sound realistically match the origin of their cor-
responding action. If you choose Mono, your sound track may use less disk space, but both the left and right 
channels will be merged into a single track. 

 20. Click OK.

 21. In the Export to QuickTime Movie dialog box, click OK.

A progress bar appears.

 22. Browse to the location on your computer where you saved your QuickTime video and double-click on it to 
view the export.

How to set the depth to Millions of Colours + to export a QuickTime movie with transparency

 l In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu.
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Exporting SWF Movies
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Exporting Image Sequences
In Harmony, you can export Exports a scene as a bitmap image sequence. If there is sound in your scene, it will 
not be exported with the images.

If you want to export images with transparency, you need to select the file type that supports this option, such as 
.tga, .psd or .png. Harmony supports 16 bits per channel RGB and RGBA .png files.  The Colour Mode menu 
changes according to the File Type selected. For example, selecting .tif will result in only having "Colour" as a 
Colour Mode option, whereas .png will have "Colour" and "Colour with Transparency".

How to render an image sequence

 1. From the top menu, select File > Export > Images or press Ctrl + Shift + Y (Windows/Linux) or ⌘  + Shift 
+ Y (Mac OS X).
The Export Images dialog box opens.

 2. In the Output section, choose a prefix. The prefix is the file name. Each image in the sequence will have 
this name, plus a sequence number and file format extension. For example: final-0001.jpg.

 3. Click Browse and specify the location in which your movie will be saved. The default location is the file dir-
ectory’s frames folder.

 4. In the Format section, choose the File Type, Colour Mode and Colour Depth from their respective menus.

 5. In the Range section, select the Frame Range to render.

 l All Frames: Exports export the entire scene.

 l Selected Frames: Lets you specify the first and last frame of the frame range to export.

 6. Select the Preview option to see the images being rendered.

 7. Click OK.

If you selected the Preview option, a generic player opens so you can watch the image sequence strung 
together as a video. The image sequence is now available in the scene’s frames directory. You should be 
able to preview each frame as an individual image.
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How to render an image sequence with transparency

 1. Open the Export Images dialog box.

 2. In the Format section, select Colour with Transparency from the Colour Mode menu.
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Batch Rendering
Harmony Server has the possibility to render your scene locally or send it to a render farm so other computers can 
render your scenes while you continue working on your station. This option is not available with Harmony Stand 
Alone. 

There are two approaches to rendering a scene in Harmony Server:

 l Local Rendering is done directly by your machine in your Harmony session. Hence, it uses your 
machine's resources and will prevent you from working on the scene until the render is done. You will see 
the render progress in real time and will be able to preview the results right after it's finished. 

 l Batch Rendering is done by sending a scene to the server's render queue so it can be processed by the 
render farm. This allows you to keep working on your scene while the render is being done. The rendering 
progress can be monitored in Control Center and, when finished, the results can be previewed in  Play. 

Batch rendering is a background process divided over several machines or a render farm. Sending your scene to 
batch render will share the rendering load with other machines in the render farm and lessen the amount of work 
required by your computer. 

NOTE: Refer to the Harmony Server Guide and Installation Guide to learn how to send scenes to batch 
render and check the status of the Render queue. 

How to send a scene to the batch rendering queue

 1. Save all the contents of your scene, all drawings, colour palettes and the palette list. 

 2. Select File > Save or press Ctrl + S (Windows/Linux) or ⌘  + S (Mac OS X).

 3. From the top menu, select  or press Ctrl + Shift + Y (Windows/Linux) or ⌘  + Shift + Y (Mac OS X).

If the system administrator did not complete the resolution configuration tasks, a warning message will 
open. This message notifies you that the resolution.conf file was not properly inserted in the configuration 
folder. 

 4. Click OK to continue. You will still be able to render your scene. 

 5. In the Range section, select the frames you want to render: 

 l All Frames: Sends all the frames in the scene to be rendered.

 l Selected Frames: Sends the specified range of frames to be rendered. 

 6. Select the Batch Composite option. 
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 l Select the Chunk option if you want to split the render jobs into several smaller render jobs. 
This can be useful for example if you want your scene to be rendered by several machines in 
the render farm at the same time. Note that this only affects Frame renders. If the render 
includes a movie file, the movie will still be exported as a single file once all the frames have 
been rendered.

 l Enter the number of frames for each chunk in the Size (Frames) field. For example, if your 
scene is 100 frames long and you enter a value of 20, there would be five entries in the queue of 
20 frames each. 

 l Select from which camera the scene should be rendered. By default, scenes only have one 
Camera, but more can be added in the Node View, and each of them can be positioned and 
animated independently. 

 7. Click OK to start the rendering process. 

A confirmation dialog box opens to inform you that the frames have been sent to the Render queue. 

If the selected frames were already sent to the Render queue, but were not yet rendered, dialog box opens to 
inform you that these frames were already in the queue, but that they have been updated with the latest 
rendering request.                 

You can also send scenes to batch rendering and check the status of the rendering queue from Control Center. 
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