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Chapter 1: Getting Started
Harmony is a complete animation software allowing you to create all kinds of creative animation projects. It comes
with a very wide variety of tools and features.
In this Getting Started Guide, you will learn about the main features and basic concepts of Toon Boom Harmony,
which will quickly bring you up to speed. Refer to the complete Toon Boom Harmony documentation available online
at docs.toonboom.com to learn about all the tools and options, as well as advanced techniques.
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Chapter 2: About the Welcome Screen
When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display the
Welcome screen by selecting Help > Show Welcome Screen.

NOTE: If you are using Harmony Server in Database mode, the Welcome screen will not open. Instead, the
database selector will open and allow you to open a scene from the database.

The Welcome screen allows you to:
1. Create scenes
2. Choose your scene resolution
3. Quickly open recently edited scenes
4. Manage your scene resolution presets
5. Watch Harmony video tutorials
6. Open the online support page
7. Browse for and open a scene from your documents
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Chapter 3: How to Create a Scene
All scenes created via Harmony Stand Alone are independent and local to the computer. You can create or open a
scene using the Welcome screen.
In Harmony Server, you cannot create scenes directly in Harmony. You must use the Control Center application.
How to create a scene from the Welcome screen
1. In the Name field, type the scene’s name.

NOTE: The scene name should not exceed 23 characters and cannot contain special characters,
such as *&^%!.

2. To decide in which directory the scene will be created, click the Browse button next to the Location field.

3. From the Camera Size menu, select a scene resolution.

4. Click on Create Scene.
A new scene is created.
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Chapter 4: About the Interface
It’s important that you become familiar with the following elements of the user interface as this will help you to start
using Toon Boom Harmony. You can learn more about the highlights described here, and how to use them in a
production context, throughout this guide.
When you start Toon Boom Harmony for the first time, the default workspace is displayed. It contains all the main
elements you need to use.

How to add a view to your workspace as a tab
1. In the top-right corner of an existing view, click the Add View

button

2. Select a view from the list. Some views, such as the Camera, Perspective, Library and Model views, can be
opened in multiple instances. For example, this can be useful if you want to have two Camera views open,
each focused on different areas of your scene, to quickly switch between working on these two areas.
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The view will appear as a new tab in the same section of your workspace:

How to add a view to your workspace as a window
1. Open the Windows menu.
2. Select the view you wish to add.
The view will appear as a new window over Harmony's main application window.
How to dock a view window to your workspace
1. Drag a window by its tab and do one of the following:
l

l

Drop the window onto other existing tabs to add it to that set of tabs.
Drop the window above, below or beside an existing view. When you get close to the edge
of a view, a black rectangle with a blue background appears, indicating where the view will
be inserted.
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Views
Below are a short introduction to the most commonly used views in Harmony.
Camera view
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate, create
animation paths and see your results. You can also move through your symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the display mode, or
go back up your symbols hierarchy.
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Drawing view
In Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when it comes to
drawing, there are some differences.
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion
Skin to display the previous and next drawings of the currently selected drawing layer.
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Tool Properties view
The Tool Properties view contains the most common options and operations related to the currently selected tool.
When you select a tool from the Tools toolbar, the Tool Properties view updates.
For example, if you choose the Select tool, the Tool Properties view will display the options and operations related to
it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.
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Colour view
The Colour view is where you create colours and palettes and import existing palettes into your project. The
Colour view is also necessary for drawing, painting and creating colour styling.

Timeline view
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to
become familiar with the Timeline view, how it works, and its interface.
The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and ordering
layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer names,
drawings, keyframes, timing, and frames.
The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing
name is displayed when you place your pointer over the drawing’s exposure.
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Xsheet view
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows the
drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s function
columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black squares in the
Timeline view. The Xsheet view contains more detail than the Timeline view, and is faster and easier to read.
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Library view
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse in
different projects. You can also use the Library view to create and store symbols.
To reuse an element from another project, you must create a template from your drawings. A template is a mini
scene that you import in other projects. A template has no link to the original scene. When you create a template,
the full content of your selection is copied in the template.
Additionally, the Library view's Drawing Substitution panel allows you to quickly change the current frame's
exposure to one of the existing drawings in a layer. This is especially useful for animating a cut-out character's
mouths, hands, eyelids and other such body parts which typically contain several drawings to choose from.
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Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.
The navigation commands in the table below can be used in the following views, with some exceptions:
l

Camera

l

Drawing

l

Perspective

l

Timeline

l

Xsheet

l

Function

l

Side and Top

l

Model

Command

Action

Access Methods
View > Zoom In

Zoom In

Press 2

Zooms in the view.

Roll the mouse wheel up (except in the
Timeline and Xsheet views)
View > Zoom Out
Zoom Out

Press 1

Zooms out the view.

Roll the mouse wheel down(except in the
Timeline and Xsheet views)
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Roll the middle mouse button up or down.
Zoom In or Out

Zooms in or out of the view.

Pan

Moves the view horizontally or vertically.

Reset Pan

Resets the view’s pan to its default
position.

Hold down the Spacebar and the middle
mouse button while dragging the mouse up
or down.
Hold down the Spacebar and drag in the
direction you want to pan the view.
View > Reset Pan
Press Shift + N
View > Reset View

Reset View

Resets the view to its default position.

Press Shift + M

Resets the view’s rotation to its default
position.

View > Reset Rotation

Reset Rotation

Press Shift + X

Reset Zoom

Resets the view’s zoom to its default
position.

View > Reset Zoom

Rotate View

Rotates the view.

Press Ctrl+Alt (Windows/Linux) or Ctrl+⌘
(Mac OS X) and drag in the direction you
want to rotate the view.

Rotate 30 CW

Rotates the Camera view 30 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW

Rotates the Camera view 30 degrees
View > Rotate View CCW
counter-clockwise, like an animation table.

Toggle Quick Close-up

Instantly multiplies the view's Zoom
Factor by 4. For example, if the Camera
View's Zoom Factor is at 100%, this will
make it toggle between 400% and 100%.

Shift+Z

Cycles through the following display
modes:
l

Toggle Full Screen
l

l

Normal Full-Screen: The main
application window becomes full
screen.
View Full-Screen: The selected
view becomes full screen and all
other views are collapsed.

View > Toggle Full Screen
Press Ctrl + F (Windows/Linux) or ⌘ + F
(Mac OS X)

Normal: The main application window is restored to its original size
and collapsed views are expanded.

Touch Interface
If you are working with a touch screen, or are using a tablet or trackpad that supports touch input, you can also
use standard two-finger gestures to zoom, rotate and pan the Camera and Drawing Views. To be able to do this,
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you must first enable the Support Gestures preference.
How to enable Suppert Gestures
1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS X).
2. Open the General tab.
3. In the Touch Interface section, check the Support Gestures check box.
4. Click on OK.
5. Restart Harmony.
You can now manipulate the Camera and Drawing views by dragging two fingers on your touch interface.
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Chapter 5: How to Draw
As soon as Toon Boom Harmony is started, you can start to draw straight away using the default drawing layer.
How to draw
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

3. In the Drawing or Camera view, start drawing.

4. To use a different colour, select a colour swatch from the Colour view. If you need to create a new colour,
click on the Add Colour
button, then double-click on the new colour swatch to open the Colour Picker window and change its colour. You can also double-click on an existing colour swatch to edit it. Remember that
when you edit an existing colour, anything already painted with that colour will update to the new colour.
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Chapter 6: How to Paint
Toon Boom Harmony has some very powerful painting features to add colour to your drawings. Whereas some other
software only allow users to work with on colour swatch at a time, painting in Harmony is done by using palettes
containing multiple colour swatches that can be saved and reused as needed.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You can
add as many swatches as you want. You can also rename them and modify existing ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted zones.
This way, you can change the look of your character at any time without having to repaint it!
Another advantage of this system is that you can create complete palettes for different lighting situations. For
instance, in addition to the regular palette for a character, you could have one for that character in the rain using
colours that are duller and less vibrant than the dry daytime colours, or yet another for using in a night scene. Using
palettes linked to your character in this way allows you to instantly change its colouring to suit the mood and
atmosphere of the scene without tediously repainting each element.
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In animation, specific colours are used to paint each part of each character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. This is
referred to as a master palette.
Master palettes contain a colour swatch for each area to colour. Each swatch stores a colour in precise levels of
red, green, blue and opacity, the latter which is referred to as alpha.
Using a master colour palette has many benefits, including:
l

Each character consistently retains their dedicated colours.

l

You cannot accidentally use a colour which is not in the master palette.

l

Standardization and colour consistency throughout the production

l

Multiple artists can use the same colour palette and produce the same results.

Harmony uses palettes to hold all the colours needed to paint your elements, allowing complete control and
consistency in the painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a new palette
and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair, tongue,
shirt, pants, and so on.
How to paint drawings
1. In the Timeline or Xsheet view, select the drawing you want to paint.
2. In the Tools toolbar, select the Paint

tool or press Alt + I.

3. In the Colour view, select a palette.
4. Select a colour from the palette.
l

If you are working with vector layers, you can double-click on a colour swatch to open the
Colour Picker window and modify the colour if desired.
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l

If you are working with bitmap layers, you can use the RGB / HSV sliders to select a colour.

NOTE: When opening a scene, the scene's palettes will not be immediately loaded into the Colour view. You
must select a drawing first.

5. In the Drawing or Camera view, start painting the colours on your drawing.
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Closing Gaps

When painting, you may find that some areas of your drawings were not completely closed due to small gaps in
their outlines, which prevents the Paint tool from filling the area as it only fills closed shapes. To close the zone,
you can draw a line over the gap with the Brush or Pencil tool. However, it's also possible toclose the gap by
adding an invisible line over it, which the Paint tool will treat like a any ordinary line. In Harmony, invisible lines
used to define areas to colour are called strokes.
The Close Gap tool lets you close small gaps in a drawing's outline by instantly drawing a stroke to fill the gap.
Contrary to the Stroke tool, you do not need to draw with precision when using the Close Gap tool. Simply
drawing a crude stroke near the gap will automatically create a straight stroke that connects directly from one end
of the gap to the other.
How to use the Close Gap tool
1. Before working with strokes, it's recommended to enable the Show Strokes option so that you can see
them in the Drawing or Camera view. You can enable the Show Strokes option by doing one of the following:
l

From the top menu, select View > Show > Show Strokes

l

Press K.

2. Do one of the following:
l

In the Tools …toolbar, select the Close Gap

tool.

l

From the top menu, select Drawing > Drawing Tools > Close Gap.

l

Press Alt + C.

3. In the Camera or Drawing view, trace an invisible line near to the gap to be closed.
The gap automatically closes.
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NOTE: The Paint tool also has a Close Gap option which can be enabled from the Tool Properties view. When
enabled, Harmony will attempt to automatically find and close small gaps when you attempt to fill a shape that
is not closed.
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Chapter 7: How to Create a Traditional Animation
The first step to complete a traditional paperless animation is the rough construction, which is the skeleton of your
animation. You would usually start with the main action. For example, to animate a walk cycle, you will start with the
torso motion and the legs. Head, arms and clothes will be added later during the secondary animation.

For a satisfactory animation, start by animating the main action with quick, rough sketches, then add the details
when you're satisfied with the movement. If you start animating all the details right away, you will lose a lot of time if
you have to make corrections, and your animation is likely to look rigid.
How to create a rough animation
1. Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X) to open the Preferences dialog box.
2. Select the Exposure Sheet tab.
3. Select the Use Current Frame as Drawing Name option. When this preference is enabled, drawings will be
named like the frame they are created on (frame number).
4. In the Tools toolbar, select the Brush

tool or press Alt + B.

5. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your rough animation. This will make the clean up process easier as your clean dark lines will contrast with your light sketch
lines.

6. In the Timeline or Xsheet view, select the cell where you want your first drawing to appear.
7. In the Camera or Drawing view, draw the first key drawing.
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8. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This will
help you stay organized.
l

In the Mark Drawing toolbar, click the Mark Selected Drawings as Key

button.

l

In the Xsheet view, select Drawings > Mark Drawing As > Key Drawing.

l

In the Timeline view, select Drawings > Mark Drawing As > Key Drawing.

9. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.
10. In the Tools toolbar, click the Onion Skin
button. This will display the previous and next drawings in a
light colour in the Camera or Drawing view, behind your current drawing, so that you can use them as references to draw new drawings with accuracy. This can be useful to draw breakdown poses between two
key poses, or to add an in-between drawing between two other drawings.
11. Ensure the onion skin displays your first key drawing, so that you can base your second key drawing on it.
To do this, do one of the following:
l

l

In the Timeline view, drag the blue onion skin markers to extend the number of past and
future drawings to display as onion skin, if needed.

In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing
, Onion Skin Reduce One Previous Drawing
, Onion Skin Reduce One Next Drawing
and Onion Skin Add One Next Drawing
buttons to adjust the span of the onion
skin frame by frame.
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NOTE: When in the Drawing view, you can use the Onion Skin toolbar to make onion skin display
only specific types of drawings, such as key drawings or breakdowns. Keep in mind that this
does not work in the Camera view.

12. In the Camera or Drawing view, draw your second key drawing.

13. In the Xsheet or Timeline view, identify the drawing as a key drawing.

14. In the Timeline or Xsheet view, select a cell between the two key drawings.

15. In the Camera or Drawing view, draw your new pose.

16. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new drawing.
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NOTE: When working with overlay layers in the Camera view, you can enable the Current Drawing on Top
option to make the layer you're working on appear over other layers.

How to review your animation
1. In the Timeline view, use the Enable/Disable All
want to see during playback.

and Solo

buttons to turn off any layers you don't

2. In the Timeline view, move the red playhead to the first frame of your animation and click the Start button
on the Timeline toolbar. Then, move the playhead to the last frame of your animation and click the Stop button.

3. In the Playback toolbar, click the Loop

button to enable looping during playback.

4. In the Playback toolbar, click the Play

button to being playback.

Cleaning Up

When your rough animation is completed, it is time to clean it up and ink it. This step is also called tracing. It
consists of tracing solid and clean lines over the rough animation to close any open zones. This is the final
paperless animation step before the ink and paint step.
In traditional animation, cleaned up drawings are usually traced on a new sheet of paper with the rough
underneath, made visible using the animation disk's light table. Likewise, in Harmony, you will need to add a new
drawing layer on which to draw cleaned up drawings. When you're done cleaning up, you can simply disable the
layer containing the rough animation so that it does not appear in the render. This approach also allows you to
keep the roughs and the cleaned up drawings intact and to manage them independently.
In the Camera view, you will see your rough animation while working on your clean up layer. If you plan on tracing
your animation in the Drawing view, you can enable the light table to display the rough animation while tracing on
your clean up layer.
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How to trace your animation in a new layer
1. In the Timeline view, click the Add Drawing Layer
(Mac OS X).

button or press Ctrl + R (Windows/Linux) or ⌘ + R

The Add Drawing Layer window opens.

2. In the Name field, name your new layer.
2. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap layer.
3. Do one of the following:
l

Click Add to add a first layer and keep the window open to add more layers.

l

Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.
4. In the Timeline view, click the Lock
icon of the layer containing your rough animation to prevent the layer
from being selected in the Camera view.

5. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your rough
animation.
6. In the Tools toolbar, select a drawing tool such as the Pencil

tool.

7. In the Colour view, select a colour for tracing your animation. Pick a dark bold colour, such as black, to make
sure it contrasts well with the light colour of your rough animation.
8. In the Camera or Drawing view, start tracing the first key drawing.
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NOTE: If you have other layers in the way, you can disable them temporarily in the Timeline
view, so that only your rough animation and your clean up layer are displayed in the Camera
view.

9. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.
10. In the Tools toolbar, click the Enable Onion Skin

button.

11. Ensure onion skin displays your previous cleaned up drawing, by doing one of the following:
l

l

In the Timeline view, drag the blue onion skin markers to extend the number of past and
future drawings to display as onion skin, if needed.

In the Camera View or Drawing View toolbar, use the Onion Skin Add One Previous Drawing
, Onion Skin Reduce One Previous Drawing
, Onion Skin Reduce One Next Drawing
and Onion Skin Add One Next Drawing
buttons to adjust the span of the onion
skin frame by frame.

12. In the Camera view, trace your next drawing.

13. Repeat the previous steps for each drawing.
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Chapter 8: How to Morph Drawings

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony's morphing feature
can help speed up the process. This powerful feature automatically creates computer-generated drawings between
your vector drawings to save time and increase productivity. You can easily modify the timing and velocity (ease in
and ease out) of a morphing animation.
One of the main uses of the morphing feature is effects animation. For example, animating smoke or water can be
time-consuming because these types of effects are usually slow moving requiring a large number of closely placed
inbetweens.
The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you by saving
time when you are working on tedious inbetweening and tracing tasks This, in turn, provides you with more time to
spend on complex animation tasks such as walk cycles or acrobatic sequences.
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles. Once you are
more familiar with the tool, you can increase your knowledge and expertise. In a very short time you will be
producing some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do and which
drawing lines may be more useful or problematic will enable you to design your key drawings so they morph
efficiently.

NOTE: The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing
than to hand-draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when
you can morph your drawings, do it! It allows you to fix your timing and velocity in no time without having to create any extra drawings!

How to create a basic morph
1. In the Timeline toolbar, click the Add Drawing Layer

button to add a new layer to your project.

2. Rename the new layer ( for example, Morphing).
3. In the Timeline or Xsheet view, select the first cell in the layer.
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4. Do one of the following:
l

In the Tools toolbar, select the Rectangle

l

Press Alt + 7.

tool.

5. In the Camera or Drawing view, draw a rectangle.

NOTE: When drawing a rectangle or an ellipsis, you can hold down the Shift key to draw your
shape with equal dimensions, so as to make a square or a circle instead. You can also hold
down the Alt key to draw the shape from its center rather than from its corner.

6. Paint your rectangle using the Paint tool.

7. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

8. Do one of the following:
l

In the Tools toolbar, select the Ellipse

l

Press Alt + =.

tool.

9. Draw and paint the ellipse with the same outline and fill colours as the rectangle.
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10. In the Xsheet or Timeline view, select the range of frame going from your first drawing to your second drawing, including the frames containing the drawings.

11. Do one of the following:
l

From the top menu, select Animation > Morphing > Create Morphing.

l

In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing

l

Press Alt + M.

Arrows appear between the two key drawings to show that computer generated inbetweens have been
created.

Adjusting the Morphing Velocity
When you look at your animation you will notice that the morphing motion is constant. To produce a less mechanical
motion, you will probably want to create some ease in or ease out.
How to add ease in and ease out to a morph
1. In the Tools toolbar, select the Morphing

tool or press F3.

2. In the Timeline view, click on a frame in the morphing sequence you want to adjust.
3. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the sequence's
velocity.

Adding Morph Hints
Harmony's Morphing tool allows you to control your morphing sequence in many ways. One of those ways is to
place hints to ensure Harmony morphs your drawings the way you intended.
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Hints are points that are placed in both the source and destination drawings to associate zones and lines between
the two drawings. They are used to fix errors in the way Harmony morphs drawings, such as a line that is not
following the colour fill zone, or when a part of your source drawing doesn't morph into its corresponding part of
the destination drawing. By default, Harmony will associate a corner or a point in the source drawing with the
nearest corner or point in the destination drawing. Hence, hints quickly become necessary if the shape being
morphed or its movement is complex.
How to add and hints
1. In the Timeline or Xsheet view, select the source drawing of your morphing sequence.
2. In the Tools toolbar, select the Morphing

tool or press F3.

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a reference.

3. In the Tool Properties view, select the type of hint you want to use.
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l

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note
that you obtain better results using the Pencil Hint point on pencil line rather than Contour Hint
points.

l

Select Pencil Hint to correct a pencil line (Central vector).

l

Select Zone Hint to correct a colour zone morphing match.

l

Select Vanishing Point Hint to correct a vanishing shape's trajectory.

l

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the problematic area.

5. Select the hint's point and move it to its correct position.

6. In the Timeline or Xsheet view, select your destination drawing.
7. Find and move the corresponding hint's point to the matching part of your destination drawing.

8. In the Playback toolbar, press the Play

button to see the result.
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Chapter 9: How to Import Bitmap Images
By default, Harmony works with vector images created within its own interface. Vector images are primarily
composed of information about the different shapes composing the images, as well as their line and fill colours. This
makes them easy to edit and colour, and allows us to resize them without affecting the image quality. In contrast,
bitmap images are composed of colour information about each individual pixel composing the image. Hence, they
are more fit for very detailed or realistic pictures, but they can not be scaled without losing image quality, and can not
be edited as easily as vector images.
Typically, you would need to work with bitmap images if you must create some of your scene assets, such as
backgrounds or props, in a different software. To do this, you can import bitmap image files into your Harmony
scene.
When importing a bitmap image, you must decide how Harmony must process it. You can choose between the
following options:
l

l

l

Keep as Original Bitmap: This imports the image exactly as is and ensures that it can not be modified when
working on the scene. This is useful for using backgrounds that were created in different software in your project.
Import as Toon Boom Bitmap Drawing: This imports the image as is, but allows you to edit it using Harmony's bitmap drawing tools.
Import as Toon Boom Vector Drawing: Converts a bitmap into Toon Boom vector art, which can easily be
painted and edited using Harmony's vector drawing tools. This can be useful for importing line art scanned or
created using a different software.

NOTE: You can drag and drop a bitmap image directly from the Library into the scene (Camera) as a quick way
of importing a bitmap image. However, you will not have access to all the import options.

How to import a bitmap image in its original format
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.
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2. In the Files section of the Import Images dialog box, click Browse to find and select one or more images
on your computer.
3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following
options:
l

l

l

Create Single Layer Named: Creates a new layer with the specified name and imports the
images into it.
Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and
"b" will contain the third one.
Add to Existing Layer: Imports the images into the specified layer. Note that you can only
import into layers that are compatible with your import options. For example, if you're importing images as vector drawings, you can only import them into vector drawing layers.

4. In the Import Options section, select the Keep As Original Bitmap option.
5. In the Alignment section, decide on the size and placement of your image within the camera frame. You
can choose between the following options:
Parameter

Description
Adjusts the image's size to fit completely within the scene's
field, both vertically and horizontally, making sure the entire
image is visible.

Fit
If the image's orientation is portrait, then it will adjust the image's
height to fit the field's height, without affecting the image's
aspect ratio:
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If the image orientation is landscape, then it will adjust the
image's width to fit the field's width, without affecting the
image's aspect ratio:

Pan

This has the opposite effect to the fit parameter. The image's
smallest dimension will be made to fit the scene frame's
matching dimension, and the image's largest dimension will be
adjusted proportionally, making the image fill the entire scene
field, and bleed past its boundaries it if its aspect ratio does not
match the field's aspect ratio. This option can be used to import
a panning background image, also referred to as a pan.
If the image's orientation is portrait, it will adjust the image's
width to fit the field's width, without affecting its aspect ratio:
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If the image's orientation is landscape, it will adjust the image's
height to fit the field's height, without affecting its aspect ratio:

Project Resolution

Scales the image to fit the scene's resolution, making each pixel
in the image take one pixel in the scene's field. For example, if
the image's dimensions in pixels are half of the scene's
resolution in pixels, then the image's dimensions will appear to
be half of the scene field's dimensions.

6. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the way
the pixels along the edge are blended with the other colours. You can choose between the following
options:
Parameter

Description

Premultiplied with White

Individual pixels at the edge of an image are blended with white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white and
greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is clamped to the alpha, the colour value cannot be higher
than the alpha value. It calculates the real colour value faster.
When the RGB values are multiplied with the alpha value, that is
to say, if you have a pixel of value R=247, G=188, B=29 and the
alpha is 50% or the image has a 50% transparency, then the
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actual RGB values that are output would be half of the amounts
listed above.
7. Click OK.

NOTE: By default, bitmap images will display in low resolution in the Camera view so as to avoid affecting playback performance. You can also adjust the display quality of a bitmap image by selecting it with the Transform
tool, then opening the Bitmap Image Quality dialog via View > Bitmap File Quality. You can also preview your
bitmap image in your scene's resolution by activating the Render Preview mode in the Camera view.

How to import a bitmap image as a Toon Boom bitmap drawing
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

button.

The Import Images dialog box opens.

1. In the Files section of the Import Images dialog box, click Browse to select one or more images from your
computer.
2. Select the destination for your images:
l

Create Single Layer Named: Creates a new layer with the specified name and imports the
images into it.
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l

l

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename
prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will
create two layers, one named "a" and one named "b". Layer "a" will contain the two first
images and "b" will contain the third one.
Add to Existing Layer: Imports the images into the specified layer. Note that you can only
import into layers that are compatible with your import options. For example, if you're
importing images as vector drawings, you can only import them into vector drawing layers.

2. In the Alignment section, decide on the size and placement of your image within the camera frame. You
can choose between the following options:
Parameter

Description
Adjusts the image's size so that its height matches the scene's
height, without affecting its aspect ratio.

Vertical Fit

Adjusts the image's size so that its width matches the scene's width,
without affecting its aspect ratio.

Horizontal Fit

Actual Size

Imports the image in its actual size, without adjusting its size relative
to the scene's resolution. For example, if the image's dimensions in
pixels are half of the scene's resolution in pixels, then the image's
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dimensions will appear to be half of the scene field's dimensions.
3. In the Transparency section, decide how the bitmap image will be antialiased, more specifically, the way the
pixels along the edge are blended with the other colours. You can choose between the following options:
Parameter

Description

Premultiplied with White

Individual pixels at the edge of an image are blended with white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white and
greys.

4. Click OK.
How to import and vectorize a bitmap image
1. Do one of the following:
l

From the top menu, select File > Import > Images.

l

In the File toolbar, click the Import Images

l

In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

button.

The Import Images dialog box opens.

1. In the Files section of the Import Images dialog box, click Browse to select one or more images from your
computer.
2. Select the destination for your images:
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l

l

l

Create Single Layer Named: Creates a new layer with the specified name and imports the
images into it.
Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For example, if you import three files named a-1.tga, a-2.tga and b-1.tga, this will create
two layers, one named "a" and one named "b". Layer "a" will contain the two first images and
"b" will contain the third one.
Add to Existing Layer: Imports the images into the specified layer. Note that you can only
import into layers that are compatible with your import options. For example, if you're importing images as vector drawings, you can only import them into vector drawing layers.

3. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.
4. In the Vectorization section, decide whether you want to import your image in black and white or in greyscale. You can also click the New Preset
button to create a custom vectorization parameter preset.
‣

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.
The outlines of your drawings will be painted with the Vectorized Line colour swatch of your scene's
colour palette.

‣

Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep the
texture from the scan, and the white of the paper becomes transparent.

NOTE: You can double-click on any of the presets at any time to open the Vectorization Parameters dialog
box to customize your option.

5. Click OK.
Your vectorized images will appear in their selected destination.
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Chapter 10: How to Rig
In Harmony, a character rig is basically a template based on your character's model, but in which all movable parts
are broken down into different layers, and arranged in a hierarchy that facilitates digital animation, also known as
cutout animation.
To make a puppet, we must first make sure you have a character model to build on. If you have any drawing of a
character available on your computer, import it into a new scene, then scale and position it to your liking. Once you
have a model ready, we can start breaking it down into parts to build your rig with.
There are many techniques you can use to break down a puppet. In this section, you will learn about one of the most
common and simplest methods. For your first character breakdown, follow these instructions to get an idea of the
way Harmony works. Once you understand Harmony's basic functions and commands, you will be able to create
your own techniques to satisfy the needs of your production.

Drawing the Pieces
The main breakdown technique shown here is to trace your model.
How to break down a character by tracing
1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Windows/Linux) or ⌘ + R (Mac OS X).
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2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select a drawing tool.
4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see How
to Paint on page 25.
5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces are
easy to manipulation, modify or redraw. There exists two easy ways to do this:
l

By using the Polyline

tool

l

By drawing with the Pencil

tool, then smoothing your lines with the Smooth Editor

tool

If you are working in the Drawing view, click the Light Table
button in the Drawing View toolbar to
display the other layers in washed out colours. You can also press Shift + L.
6. If you want to close a shape without drawing an actual stroke, you can use the Stroke tool in the Tools toolbar to create an invisible hairline .
l

Select View > Show > Show Strokes or press K to display the invisible lines.
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7. In the Tools toolbar, select the Paint

or Paint Unpainted

tool to colour your drawing.

8. In the Colour view, create the desired fill colour if it's not already in your palette, then select it.
9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select
button in the Tool Properties view.

tool. Select your drawing and flatten the lines by clicking the Flatten

11. If your lines are composed of several pencil strokes, you might want to combine them into one single smooth
pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool Properties view, click
the Merge Pencil Lines
button.

12. Repeat the entire process for every body part that you wish to make animatable.
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Adding Pegs
Pegs are a special type of layer that do not contain any drawing. They are used strictly to offset and transform
drawings that are under their hierarchy, without transforming the actual drawing.
When rigging or setting up a scene, it is recommended to add parent pegs for each of your drawing layers. This
allows you to keep animation keyframes and drawings on separate layers, making it easier to work on the position
and exposure of your drawing layers independently in the Timeline view. It also makes it easier to create a
hierarchy of which body parts can be animated together and independently.

If you want to animate only on pegs, you can activate the Peg selection mode of the Transform tool in the Tool
Properties view. You can also disable animating drawing layers, so that only pegs can be animated.

NOTE: It is also possible to make drawing layers the children of other drawing layers. Just like the way animating a peg animates its children layers, animating a drawing layer with children will also animate its children
layers.
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How to create parent pegs for your layers in the timeline
1. In the Timeline view, select all the layers.

2. In the Timeline Layer toolbar, click the Add Parent Peg

button to add a parent peg to all selected layers.

s

Parenting Layers
Harmony lets you build your rig in an elaborate hierarchy, allowing you to set which parts of your rig should influence
other limbs, and how they can move independently. For example, when rigging a simple character's arm, you can
make the forearm layer a child of the arm layer, and the hand layer a child of the forearm layer. This way, if the
character moves their forearm, the hand will follow, and if they move their arm, the forearm and hand will follow.
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When building a basic character rig, you should at least have a hierarchy for each arm and each leg. You can
make a hierarchy going from the torso, the neck and the head, and rig the arms to the torso, and you can rig the
legs to the hips. This would make a hierarchy like this:

How to create a hierarchy in the Timeline view
1. In the left area of the Timeline view, select the layer which you want tomake a child layer
2. Drag the child and drop it over the layer which you want to make the parent layer. Make sure you are not
dropping the child layer between two layers.
3. Repeat until you've created a hierarchy that rigs all of your character's parts, with a master peg at the root.
While rigging, if you want several layers to have a common parent, but no existing part of your rig can
serve as that parent, create a new peg and nest those layers under that peg.
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NOTE: In the Timeline view, you can unparent layers by holding down Shift and dragging the selected parents
away from the child layer. Drop your selected between other layers.

When rigging, keep in mind that the order of the layers in the Timeline view affects the order in which they're
rendered. Layers on top of the list will be rendered over layers at the bottom of the list. Should you need to change a
layer's order while animating, you can nudge this layer's position on the Z-axis to override the layer order and force it
to appear beneath or over other layers.
How to nudge a layer on the Z-axis
1. In the Tools toolbar, select the Transform

tool.

2. In the Timeline, Node or Camera view, select the layer you want to nudge.
3. If you selected the layer from the Timeline or Node view, click on the Camera view tab to set the focus on the
Camera view.
4. Do one of the following:
l

To nudge the layer forward, press Alt + Down Arrow.

l

To nudge the layer backward, press Alt + Up Arrow.

Master Peg
Your character rig should always have a master peg which connects to all of its parts. The master peg allows you to
manipulate the entire rig from a single layer, without having to manipulate each individual part. This is useful for
positioning and scaling your character relative to the scene, as well as to animate your character's trajectory when it
has to move between areas of the scene.
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How to add a master peg in the Timeline view
1. In the Timeline view, select the top layer.
2. In the Timeline view, click on the Add Peg

button.

A new peg is added to the timeline as a parent of the selected layer.
3. Name the new peg Master plus the character's name.
4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is
already parented to that peg.
5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your layers are
added above the already parented layers, move that parented layer back on top of the layer stack.
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Chapter 11: How to Use Deformers
Deformers give the ability to animate objects and parts of a character model using computer generated
deformations. This allows you to bend or distort drawings without having to redraw them. When used in cut-out
animation, they can extend considerably the range of movements and poses a character model can pull without
having any of its parts drawn in different poses, which can save a lot of time and make your cut-out animation look
much more natural with little effort.
Deformers can be used to deform a single drawing layer or a hierarchy of layers, so a single deformer can be used to
deform anything ranging from a simple prop to a whole character rig. They can be used on both vector and bitmap
drawings.
Deformers work by rigging them as a parent drawing(s) you wish to deform, building the deformer structure, then
animating it. This can be easily done using the Rigging
tool.
There are two types of deformers available in Harmony Advanced:
l

Bone

l

Game Bone

NOTE: Harmony Premium also supports Curve and Envelope deformers, which offer extended deformation capabilities that are not supported in Harmony Advanced.

Bone Deformer
The Bone deformation allows you to create a bone-like structure in which each part is solid, but with articulations
that are flexible. This is mostly useful for animating a character's limbs, such as the arms or legs, or other parts that
can be articulated such as torsos or fingers. For example, a Bone deformation can be used to articulate an arm that
is made of a single drawing, so that the upper arm and forearm can be moved independently, without having to draw
the upper arm and the forearm on different layers. Harmony will deform the drawing to make it look articulated. The
different parts of a Bone deformation can be rotated around their joint, extended and shortened, giving you the same
capabilities as animating articulations on different layers, without having to worry about parts detaching, pivot
points, or clipping outlines.
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Game Bone Deformer
The Game Bone deformation is very similar to the Bone deformation. It allows you to create a bone-like structure
in which each part is solid, but with articulations that are flexible. However, it is optimized for game engines such
as Unity. Hence, it is usually only used for game development and not in animated productions. Contrary to the
Bone deformations, Game Bone deformations do not have a Bias property. The articulation folds also look slightly
more rounded.

Creating Deformers
The most simple way of creating deformers is to use the Rigging
tool, available in the Deformation toolbar.
With this tool, all you need to do to create a deformer is to select the layer you wish to deform, then place each
point of your deformer in the Camera view.
A deformer is a hierarchy of its own. When you create a new deformer, the first point you set is the deformer's
root, and each new point you create is a child of the previous point. Deformers are hence created in a chain, and
should be created with your character's hierarchy in mind. For example, when you create a deformer for an arm,
the root should be the shoulder joint, the second point should be the elbow and the third should be the wrist.
When you create a new point using the Rigging tool, it is created as a child of the selected point. This is
essentially how the Rigging tool knows if it's creating a new deformer, or building an existing deformer, as the last
point you created will be selected by default. But you can also use this mechanism to create deformers that split
into multiple chains, by selecting the point in the middle of an existing deformer, and building a new chain from
there.

NOTE: You can also use the Timeline's Insert menu to manually add the nodes necessary to create your
deformation structures.

How to select the element on which to create a deformer
A deformer affects all the layers under its hierarchy. When you create a new deformer using the rigging tool, it is
automatically created as a parent of the selected layer, and will affect the selected layer and all its children.
Hence, it's important to select the right layer before attempting to create a deformer.
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For example, if you wish to create a deformer for an arm, and the arm is broken into several layers, you could rig the
arm in a hierarchy where the upper arm is the root, the forearm is the upper arm's child and the hand is the forearm's
child. Then, if you create your deformer on the forearm, it will be created as a parent of the forearm, and will hence
affect the whole arm, as its other parts are children of the forearm.

You can also group several layers under a peg, and create your deformer with this peg selected. When you create a
deformer on a peg, the deformer is created as a child of the peg, but as a parent of all of this peg's children. This is
because a peg is likely to be more useful over a deformer than under. If you move layers that are under a deformer,
they will exit the intended deformation zone, and may appear severely warped and distorted. Hence, it's better to
create deformations under pegs as much as possible, and pegs under deformers should only be animated if the
deformer is left untouched. Since the deformer will be created as a parent of all the peg's children, it will affect all the
layers under the peg.

How to create a Bone or Game Bone deformer
1. Once your element is selected, select the Rigging

tool in the Deformation toolbar.

2. In the Tool Properties view, enable the Bone
mode or the Game Bone
you're rigging for an animation project or a game.

mode, depending on whether

3. Place the cursor at the root of your drawing or drawing hierarchy, click once and release. For example, if
you're creating a deformer for a whole arm, click on the shoulder joint.

4. Move your cursor at the location where you want your first bone to finish and your second bone to start, and
click again. An articulation control point will automatically be inserted between each bone you create.
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5. Move your cursor where you want the next articulation to be and click to create the next point.
6. Observe that, as you create a new point, the previous point how has a circle around it. This indicates the
radius of the articulation. Every point in a bone deformer except for the first and the last point in the chain
have a radius setting. This allows you to determine how much of the drawing should be considered part of
the articulation. The smaller the

7. Click and hold the previous articulation's radius manipulator and adjust the articulation's radius so that it
covers the limb.

8. Repeat this until you are finished creating the Bone chain. Make sure you build each articulation in the right
order going from the root to the extremity.

Displaying Existing Deformation Chains
Harmony lets you control which deformers are displayed in the Camera view independently from the current
selection. When you create a deformation chain, its deformation controls are displayed in the Camera view.
However, if you select an existing deformer or a layer that's connected to existing deformers, its deformation
controls won't display right away. Likewise, deselecting a deformation chain will not hide its deformation controls.
Before you can animate or modify an existing deformation chain, you must manually display it.
How to display the selected deformation chains
1. Do one of the following:
l

l

In the Timeline view, select any part of the deformation chain you want to display.
In the Camera, Timeline view, select one of the drawing elements linked to the deformation
chain you want to display.

2. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others
The selected deformation controls appear in the Camera view and all the others are hidden.
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NOTE: The Show Selected Deformation Chain and Hide All Others button will display all deformation chains
that are in the hierarchy of the selection. For example, if the master peg of a character model is selected, all of
its deformation chains will be displayed. Likewise, if multiple layers linked with different deformation chains are
selected, all of their deformation chains will be displayed.

How to hide the deformation controls
1. Do one of the following:
l

l

Click in the negative space of the Camera view, Timeline view or Node view to discard the current selection, then click on the Show Selected Deformation Chain and Hide All Others
button in the Deformation toolbar.
Select a layer that is not linked to any deformer, then click the Show the Selected
Deformation Chain and Hide All Others
button in the deformation toolbar.

l

In the Camera toolbar, click the Hide All Controls

l

From the top menu, select View > Hide All Controls.

l

Press Shift + C.

button.

Modifying Existing Deformation Chains
As you attempt to animate a deformation, or if you need to make changes to the drawings under a deformation, you
may need to make adjustments to the deformation chain to better fit your needs.
How to add an articulation to an existing Bone or Game Bone deformation
1. Select the drawing layer or the deformation chain to which you want to add an articulation.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
button to display the
deformer controls in the Camera view. This also hides all the deformer controls that were displayed.
3. Select the Rigging

tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the deformation.
A red chain indicates that you're modifying the rig.
4. Move your cursor over the bone segment, where you want to add an articulation.
5. Hold Alt and click.
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How to make adjustments to existing deformers
1. Select the drawing layer or the deformation chain for which you need to make adjustments.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.
3. In the Deformation toolbar, click the Rigging

tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the
deformation. A red chain indicates that you're modifying the rig.

4. In the Camera view, set up the deformation chain.
l

Rotate the first bone to change the angle of the chain.

l

Use the root control to reposition (offset) the entire chain.
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l

l

Use the control points to reposition the articulations. This will elongate, shorten or change the
direction of the bone. This will also offset the subsequent points in the deformation chain.

Use the articulation's control (square) to change the size of the articulation. For quality purposes, it is recommended to have an articulation which fits the diameter of the part it controls.

5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is
linked.
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NOTE: When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt key to
lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl (Windows/Linux) or
⌘ (Mac OS X) key to break the articulation off its chain and make it into a new, separate deformer chain.

How to create a split deformation chain
It's possible to create a deformation chain that splits into multiple branches, allowing to rig complex drawings with
multiple extremities using a single deformer. Note that it might be difficult to ensure that the parts of the drawing
being deformed mesh properly in the area where the deformation branches meet.
1. Select the drawing layer or the deformation chain to which you want to add a branch
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.
3. Select the Rigging

tool.

The deformation chain turns from green to red. A green chain indicates that you're animating the
deformation. A red chain indicates that you're modifying the rig.
4. In the deformation chain, select the point from which you want the new deformation branch to start.
5. Place the cursor where you want your new branch's first point to be and click. A new chain is created.
6. Create the remainder of your chain's points as you would create a regular deformation.

When you have several chains controlling the same drawing or group of drawings, a Deformation Composite node
is automatically be created and appears in the Timeline view. In the Additional Links section of the Timeline view,
you can see which nodes are connected to the Deformation Composite.
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NOTE: When using the Rigging tool, you can select which existing deformation point you want the next deformation point you create to branch from at any time by selecting a point in the Camera view. When you create a
deformation point with the Rigging tool, it is always linked to the currently selected deformation point. By
default, creating a deformation point makes it selected, which is why you don't need to select it to create a
simple deformation chain. If no deformation point is selected, the Rigging tool creates a new deformation chain

Animating With Deformers
Just like with animating pegs and drawing layers, you can animate your deformers by creating keyframes on their
corresponding layers in the Timeline. Animating deformers works exactly like making modifications to a deformer,
except it requires using Transform
tool instead of the Rigging tool. When the Transform tool is selected,
deformation controls in the Camera view display in green, which means they are in animation mode, whereas when
the Rigging tool is selected, they display in red, meaning they are in rigging mode.

How to animate Bone and Game Bone deformations
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tools toolbar, enable the Animate
mode. This allows the Transform tool to affect the position and
size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and size
throughout the whole scene.
3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

4. Select the first frame of the scene.

5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first frame
in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type in the
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amount of frames in your scene and confirm. This will make your model exposed (visible) throughout your
whole scene,
6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of
every layer of the model. This ensures that when you make the second pose later, your first pose will not
be affected. To do this do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is added on the current frame.
7. Do one of the following:
l

l

In the Timeline view, select any part of the deformation chain you want to display.
In the Camera, Timeline view, select one of the drawing elements linked to the deformation
chain you want to display.

8. In the Deformation toolbar, click the Show Selected Deformation Chain and Hide All Others
The selected deformation controls appear in the Camera view and all the others are hidden.
9. In the Camera view, do the following:
l

Rotate the first bone to rotate the limb.

l

Rotate the subsequent bones to bend the limb.
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l

l

Use the root control to reposition (offset) the entire chain.

Use the control points to reposition the articulations. This will elongate, shorten, or change the
direction of the bone and offset the subsequent children.

10. In the Timeline view, go the frame on which you want to set the next key pose.
11. Add a keyframe on the current frame by doing one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

12. Repeat the previous steps to animate your character.
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NOTE: When manipulating the articulation of a Bone or Game Bone deformer, you can hold the Alt key to
lock the bone's angle and only shorten or elongate the bone. You can also hold the Ctrl (Windows/Linux) or
⌘ (Mac OS X) key to break the articulation off its chain and make it into a new, separate deformer chain.
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Chapter 12: How to Animate a Cut-out Character

Harmony provides some great tools for animating cut-out character models. You can simply animate a character by
using the Transform tool to move the drawings and pegs that constitute its cut-out model. With animated keyframes,
basic interpolations are automatically done by Harmony. The timing of the movement can be adjusted to make lifelike motion, and drawings can be swapped at any point during interpolations, allowing to combine movement and
drawing changes to create frame-perfect cut-out animations.
How to create a simple cut-out animation
We will create a simple cut-out animation by making your character's first pose on the first frame, its second pose on
a later frame, and letting Harmony interpolate them.
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tools toolbar, enable the Animate
mode. This allows the Transform tool to affect the position and
size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and size
throughout the whole scene.
3. In the Timeline view, collapse your character using the Expand/Collapse arrow.

4. Select the first frame of the scene.

5. To ensure your model doesn't disappear after 1 frame, extend its exposure by right-clicking on the first frame
in the Timeline and selecting Extend Exposure or by pressing F5. In the Set Exposure dialog, type in the
amount of frames in your scene and confirm. This will make your model exposed (visible) throughout your
whole scene,
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6. Now, we will make your character's first pose. First, make sure there is a keyframe on the first frame of
every layer of the model. This ensures that when you make the second pose later, your first pose will not
be affected. To do this do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe is added on the current frame.
7. In the Camera view, select the parts to animate. The Transform tool's control box will appear around the
selected layer. Each part of the Transform tool control can be used to make different kinds of transformations:

8. Use the Transform

tool to rotate, skew, scale or translate the selection to its new position.

9. Repeat for other parts of your character model until you have your first pose.
10. In the Tools toolbar, enable the Onion Skin

feature.

11. In the Timeline view, select the frame where you want to have your second pose.
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12. Create keyframe for your second pose by doing one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

13. In the Camera view, change your character's pose again.

14. Repeat this process for all the poses you wish to add to your animation.
How to adjust the ease of the animation
1. In the Timeline view, collapse your character model's hierarchy.
2. Select one of your animation keyframes. Since your model's hierarchy is collapsed, this selects the keyframe
on every layer simultaneously.

3. Do one of the following:
l

In the Timeline view, right-click and select Set Ease For Multiple Parameters.

l

In the Timeline toolbar, you can click the Set Ease For Multiple Parameters

The Set Ease For Multiple Parameters dialog box opens.
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4. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

5. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Filters section, deselect the function types you do not want to affect.
l

Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z
and 3D Path functions

l

Rotation: Applies the easing parameters to the selected Angle functions.

l

Scale: Applies the easing parameters to the selected Scale functions.

l

Skew: Applies the easing parameters to the selected Skew functions.

l

l

Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note
that it is applied to the Morphing Velocity function in the Layer Properties window, not to the
basic Morphing ease in the Tool Properties view.
Other: Applies the easing parameters to all the other selected functions, such as all functions created to animate effect parameters.

6. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are
calculated in percentage.
l

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding
to the length of time you want the easing to last. The value must be between 0% and 100%.
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l

l

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong
you want the easing out. The value must be between 0% and 100%.
If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

7. Click one of the following buttons:
l

l

l

l

Apply: Applies the easing parameters to the selected keyframes.
Apply/Previous: Applies the easing parameters to the selected keyframes and then selects
the previous keyframe in the timeline.
Apply/Next: Applies the easing parameters to the selected keyframes and then selects the
next keyframe in the timeline.
Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.

NOTE: If a range containing multiple keyframes is selected, only the first selected keyframe will be affected by
the Seat Ease for Multiple Parameters functionality.

Navigating Layers
Since cut-out animation often involves complex models with hierarchies, learning shortcuts to easily navigate
between layers can save a lot of time.
One very useful trick to learn is the Center on Selection keyboard shortcut. This shortcut allows you to navigate
directly to the selected layer in the Timeline view. Hence, you can use the Camera view to visually select the layer
you wish to animate, then use the Center on Selection shortcut to find the layer in the Timeline view, instead of going
through your layer's list to locate it.
How to Center on Selection
1. In the Timeline view, collapse all your layers.
2. In the Tools toolbar, select the Transform

tool.

3. In the Camera view, select any layer, preferably one that is deep in your character model's hierarchy.
4. Click on the Timeline view's tab, or anywhere in the Timeline view that will not change your selection. This is
because the shortcut works if the Timeline view is focused on.
5. Press O.
The Timeline view is now focused on the selected layer, and all its parents have been automatically
expanded.
This shortcut can also be used in the Node view. If your selection is inside a group, it will navigate to the inside of
this group and the center the Node view on the selected node.
If you want to use this shortcut frequently, you might find that having to click on the Timeline or Node view every
time is tedious. To remedy this, you can enable the Focus On Mouse Enter preference. This will set the focus on a
view as soon as your mouse cursor enters it, instantly making all of this view's keyboard shortcuts functional.
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How to enable Focus On Mouse Enter
1. From the top menu, go to Edit > Preferences (Windows/Linux) or Harmony > Preferences (Mac OS X).
2. Open the General tab.
3. In the Options section, check the Focus On Mouse Enter check box.
4. Click on OK.
Keyboard shortcuts for specific views will now work as soon as your mouse cursor enters the intended
view.
Otherwise, Harmony also features keyboard shortcuts to quickly change your selection from the currently
selected layer to its parent, child, or to one of its siblings, allowing you to quickly navigate your character's
hierarchy from one layer to one of its related layers.
How to select the parent or child of the selected layer
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Camera or Timeline view, select a layer or object attached to a hierarchy.

4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select Animation > Select Child or press Shift + B to select the child layer or Animation > Select Children to select
all child layers at the same time.
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How to select the siblings of the selected layer
1. In the Timeline view, select a layer that has at least one sibling and do the following:
l

To select the previous sibling in the family, press /.

l

To select the next sibling in the family, press the question mark (?) key.
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Chapter 13: How to Create Templates
You can create a template from a layer or from cells. You can store anything available in the Timeline view as a
template.
Creating a template by selecting a layer in the layers list on the left of the Timeline view will incorporate the layer and
all the drawings that were created in it, even if they're not exposed in the scene's timeline, whereas creating a
template by selecting specific cells in the timeline will only save the selected drawings in the template.
How to create a template from the Timeline view
1. In the Timeline view, select some cells or layers.
You can create a template from a whole hierarchy of layers by collapsing the hierarchy and selecting the root
layer. This can be useful for creating templates based on character rigs or scene backgrounds.
2. In the Library view, select a folder to store the template. By default, a local scene will have a Harmony
Advanced Library folder, which is stored in your Documents folder.
3. If the library folder is locked

, right-click and select Right to Modify.

4. Drag the selection to the chosen library folder.

5. In the Rename dialog box, give the new template a name.
6. Click OK.
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NOTE: To rename a template once it is created, right-click on the symbol and select Rename, or doubleclick on the template's name.

How to import a template into the Timeline or Camera view
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or to the left side of the Timeline view.

If you drop the template in the Camera view, its layers will be added at the top of your layers list. If you
drop a template in the layers list in the Timeline view, it will be inserted between the layers where you
dropped it.
If your template has the same layer structure as a part of your scene, you can drop the template directly
onto the frames on the right side of the Timeline view. Instead of inserting new layers into your scene, this
will replace the drawings and keyframes in your scene with the ones from the template. This is useful for
importing pose or animation templates for characters that are already in your scene.
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Chapter 14: Staging a Scene
Setting up your scene can be compared to building a set for a television show. This is the point when you position
each scene element such as the camera frame, the background elements and the characters.

Adding a Camera
By default, a scene does not have a camera layer. In order to be able to tweak the scene's camera angle and
position, you must add one to your scene. Although it is possible to have several cameras in the same scene, you
can only view your scene using one camera at a time. This can be useful if you are still working on your scene
composition and have different camera framing to try out.
How to add a camera in the Timeline view or Top menu
1. Do one of the following:
l

In the Timeline view, click the Add Layer

button and select Camera.

l

From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

How to switch between cameras
1. From the top menu, select Scene > Camera.
2. Among the listed cameras, select the one you want to work with.

Positioning the Camera
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution as well as other related parameters in the Scene Settings window, accessible from the Scene top
menu.
Note that the Camera layer is static. If you need to animate it, you must put it under a peg, which you can animate—
see Animating the Camera.
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You can reposition your camera frame directly in the Camera view by using the Translate
, Rotate
and
Scale
tools of the Advanced Animation toolbar. Alternatively, you can set up your camera by typing its
coordinates directly in the camera's properties. This can be useful if you've done your scene planning on paper,
as the coordinates match the ones on a traditional animation camera grid. Hence, using this approach allows you
to position the camera exactly where you want it to be.

How to reposition the camera frame in the Camera view
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
l

From the top menu, select Animation > Tools > Translate.

l

In the Advanced Animation toolbar, click the Translate

l

Press Alt + 2.

tool.

3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera
layer from the Timeline view.
The selected camera frame is highlighted.
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4. Drag the camera frame to a new position.

5. To tilt the camera frame, do one of the following to select the Rotate tool:
l

From the top menu, select Animation > Tools > Rotate.

l

In the Advanced Animation toolbar, select the Rotate

l

Press Alt + 3.

tool.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.
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7. To move camera frame closer to or further away from the scene, do one of the following to select the Scale
tool:
l

From the top menu, select Animation > Tools > Scale.

l

In the Advanced Animation toolbar, select the Rotate

l

Press Alt + 4.

tool.

NOTE: The Transform tool can also be used to move the camera, but not to rotate or scale it.

How to reset the camera position
1. In the Tools toolbar, select the Transform

tool or press Shift + T.
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2. In the Timeline or Camera view, select the camera layer.
3. From the top menu, select Animation > Reset or press Shift + R.
The camera automatically returns to its original position.

Positioning Objects
Setting up the scene also involves positioning the different scene elements within the camera frame.

How to pan a layer using the Transform tool
1. In the Tools toolbar, disable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple layers to reposition them at the same time. Hold down Shift and select the different layers.

How to rotate a layer using the Transform tool
1. In the Tools toolbar, disable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer.
5. Place the pointer outside of a corner of the bounding box and drag to rotate.

NOTE: You can display a rotation handle on the bounding box when transforming a layer. In the
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Preferences dialog box, select the Camera tab and then select the Use Rotation Lever with
Transformation Tools option. This preference is off by default.

How to scale a layer using the Transform tool
1. In the Tools toolbar, enable or disable the Animate
2. In the Tools toolbar, select the Transform

mode if you want to animate or not.

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold
down Shift to lock the selection's aspect ratio.

NOTE: When scaling your selection, you can hold down Shift to preserve its aspect ratio.

How to skew a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer.
5. Place the pointer between two controls points and drag sideways or up and down.

86

Toon Boom Harmony 14 Advanced Getting Started Guide

Repositioning the Pivot
Transformations made on a drawing layer, such as rotation, scale, skew and flip, are made relative to the position of
the drawing's pivot point. While making transformations using the Transform tool, you can drag and drop your
selection's pivot. However, this has no permanent effect. It will only temporarily change the pivot's position to help
you make transformations at the selected frame, but the actual pivot point of your drawing layer will remain the
same. You can reposition a layer's pivot point permanently using the advanced animation tools.
How to permanently reposition the pivot point
1. In the Advanced Animation toolbar, select the Translate

, Rotate

, Scale

, or Skew

tool.

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select your element.
The pivot point appears in the Camera view.

3. Drag the pivot point to a new position.

NOTE: When you permanently move the pivot point, of a layer that is already animated, all the transformations
done on the layer on other keyframes will be recalculated according to the new pivot point's position. Therefore,
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your existing animation will look completely different, except at the current frame. It is recommended to
always make sure your pivot point is at its ideal position before you start animating.
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Chapter 15: How to Animate Objects and the Camera
In Harmony, you can animate objects by drawing them on their individual layer, then positioning them at different
locations on different keyframes across the timeline, creating a motion path. The same principle can be applied to
the scene's camera, since it is a layer itself.

Animating a Layer
You can create a motion path directly on layers (animated layers).

You can control and define a trajectory using several different parameters, including:
l

X, Y and Z positions

l

Angle (rotation)

l

Skew

l

X and Y Scales

Harmony keeps track of each parameter of each layer by storing them in their own function curve. When you add a
keyframe to a layer, a keyframe is created on each of these functions, and transformations done on a layer via the
Camera view are translated into coordinates which are then stored in those functions. It is possible to edit these
functions individually using the Function view, but that is rarely necessary, as Harmony provides easy-to-use tools
for visually controlling trajectories and timing in the Camera and Timeline views.
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How to animate a layer or a peg
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. If you have parent pegs and are animating a drawing layer, in the Tool Properties view, make sure the Peg
Selection Mode
is deselected.
3. In the Tools toolbar, enable the Animate
mode. This allows the Transform tool to affect the position
and size of a layer at the current keyframe only, whereas it would otherwise affect the layer's position and
size throughout the whole scene.
4. In the Timeline view, go to the first frame.

5. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert
Keyframe.
A keyframe is created on the first frame of the Timeline view.

6. In the Camera view, select the element to animate and move it to its first position.

7. In the Timeline view, go to the frame on which you want to set the second position.

8. Select the cell where you want to create your first keyframe. Right-click on the selection and select Insert
Keyframe.
A second keyframe is created on the Timeline view.
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9. In the Camera view, move the element to its second position.

10. In the Timeline view, select the first frame to rewind to the beginning of your animation.
11. In the Playback toolbar, click on the Play

button to preview your animation.

NOTE: If you animate layers on the Z axis, you may want to preview your animations from the Top, Side or Perspective views while during playback. By default, playback is disabled in those view. To enable them, from the
top menu, select Play > Enable Playback > Top View, Side View or Perspective View.

Animating the Camera
A scene's camera can be manipulated and animated just like any other layer. It is listed in the Timeline view and you
can use the same tools and selection modes to offset or animate it. However, the camera layer itself is static, which
means it keeps the same position and angle throughout the whole scene. In order to be able to animate the camera,
you need to connect it to a peg layer, which can be animated, and which will directly affect the position and angle of
the camera.

You can animate your camera movements directly in the Camera view. Alternatively, you can use the Side or Top
views, which can be especially useful when animating a camera in a multiplane scene.
How to open the Top and Side views
1. Do one of the following:
l

From the top menu, select Windows > Top or Side.
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l

From any view already open, click the Add View
Top or Side.

button at the top-right corner and select

How to add a camera and its parent peg
1. By default, new scenes do not have a camera layer. To add a camera layer, do one of the following:
l

From the top menu, select Insert > Camera.

l

From the Layers toolbar, click the Add Layers

button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.
2. In the Timeline view, select the Camera layer.

3. From the Layers toolbar, click the Add Peg

button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it.
The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a
Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the
scene, which deactivated the layer on which you want to add the Peg layer. To fix this:
l

Select the Camera layer and drag and drop it under the new Peg layer. Or delete the misplaced Peg layer, select the Camera layer and click the Add Peg
button again.

You can also press Ctrl + P (Windows/Linux) or ⌘ + P (Mac OS X) to create a peg and connect it to
the camera.
How to animate the camera
1. In the Tools toolbar, enable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. On the right side of the Timeline view, on the Camera Peg layer, select the frame at which you want the
camera movement to start.
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4. Do one of the following to add a keyframe:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera position
as this keyframe.

5. Do one of the following to move the camera:
6. In the Camera view, select the Camera, which should now be represented by a thin yellow rectangle with a
red highlight, and move it to the desired position.Do one of the following to select In the Top, Side or Camera
view, select the camera (the large V-shaped cone) and move it to the desired position. In the Camera view,
the camera is represented by a thin frame. You need to click directly on one of the edges.
l

l

In the Camera view, select the Camera, which is now be represented by a thin yellow rectangle
with a red highlight, and move it to the desired position.

In the Top or Side view, select the camera, which is now represented by a large, yellow Vshaped cone, and move it to the desired position.
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7. On the Timeline view, click on the cell where the camera move will end.
8. Do one of the following:
l

In the Timeline toolbar, click the Add Keyframe

l

Right-click and select Add Keyframe.

l

Press F6.

button.

A keyframe appears in that cell.

9. Select the camera in the Camera, Top or Side view and move it to the desired position.
10. In the Timeline view, select the first frame to rewind to the beginning of your animation.
11. In the Playback toolbar, click on the Play

button to preview your animation.
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Chapter 16: How to Create a Multiplane

In live action, when the camera moves through the scene, objects near the camera will move by a greater distance
than objects far from the camera. In 2D animation, multiplanes can be used to achieve a similar effect without
resorting to 3D backgrounds.
In Harmony, a multiplane can be easily achieved by creating a scene's background over several layers, and
positioning them at different depths relative to the camera.
Before creating a multiplane, make sure you have a proper understanding of the environment in which your scene
happens. Picture what your scene's background would be like in 3D, then image the camera moving through the
space, and how the objects in the picture move at different speeds depending on where they are in relation to the
camera lens.
In the following example, the background is made of 6 different layers, each picturing an object that is at a different
distance from the camera. On the left, you can see how each object is positioned relative to the camera, as if you
were looking at them from the side. On the right, you can see how layers are positioned relative to each other as if
you were looking at the scene from a corner. Below, you can see the scene from the camera's point of view.
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NOTE: When creating a multiplane background, it is important to draw each layer fully. Even if some parts of
a background layer is hidden behind a foreground layer in the camera's initial position, panning or zooming the
camera may expose parts of background layers that are not initially visible.

In order to move a layer further from or closer to the Camera, you must change its position on the Z-axis. You can
do this by moving a layer using the Transform Tool
in the Side or Top views. You can also move a layer on Zaxis directly from the Camera View by holding Alt and dragging the layer up or down. Positioning your element
closer to the camera makes them appear bigger, and moving them further makes them appear smaller. It is also
possible to move elements on the Z-axis without affecting their apparent size by using the Maintain Size
tool
in the Advanced Animation toolbar.
It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the
Top and Side views.
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NOTE: Just like with other transformations, transformations on the Z-axis on a parent layer will also affect the
apparent position on the Z-axis of its child layers. Therefore, a child layer's apparent position on the Z-axis can
be affected by any of its parents.
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Chapter 17: How to Import Sound and Add Lip-Sync

Importing Sound
If you wish to add sound to your animation, you should first edit and mix your sound files in a sound editing software.
It is recommended to mix down your sound into full length sound tracks so that you can work with the exact same
sound track in the different applications used for your production.
Sound can be clipped in Harmony if needed. Importing a soundtrack longer than your scene will not extend your
scene's length. Sound playback will stop at the end of your scene's length.
If you create your project in Toon Boom Storyboard Pro, you can export all of your project's scenes as separate
Harmony scenes. The storyboard's sound track will be cut up by scene and each piece will be inserted into the
exported scenes, allowing you to save time on splitting and importing your sound track.
Harmony can import .wav, .aiff and .mp3 audio files. It is recommended to work with .wav and .aiff files if possible.
How to import a sound file
1. Do one of the following:
l

From the top menu, select File > Import > Sound.

l

In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

l

From the Xsheet menu, select File > Import > Sounds.

l

From the Timeline menu, select Import > Sounds.

The Select Sound File dialog box opens.
2. From the Select Sound File dialog box, find and select a sound file.
The sound file appears as a layer in the Timeline view. Its waveform is displayed in the track to help you
visualize at which frames the sound effects in your soundtrack occur.

Your soundtrack also appears as a column in the Xsheet view, but will not display a waveform by default. If
you wish, you can display a sound column's waveform by right-clicking on it, then selecting Sound Display
> Waveform.
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Automatic Lip-Sync Detection
Adding a lip-sync to your animation is essential to making your characters seem alive. However, it is also a
particularly tedious part of the animation process.

To solve this problem, Harmony provides an automatic lip-sync detection feature. This feature analyzes the
content of a sound track in your scene and associates each phoneme it detects with one of the mouth shapes in
the following mouth chart, which is a standard mouth chart in the animation industry.

NOTE: The letters assigned to these mouth shapes are standard identifiers, they NOT correspond to the
sound they are meant to produce.

This is an approximation of the English phonemes each mouth shape can be used to represent:
l

A: m, b, p, h

l

B: s, d, j, i, k, t

l

C: e, a

l

D: A, E

l

E: o
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l

F: u, oo

l

G: f, ph

l

X: Silence, undetermined sound

When performing automatic lip-sync detection, Harmony does not create mouth drawings. It simply fills the drawing
column of your character's mouth layer with the generated lip-sync, by inserting the letter associated with the right
mouth shape into each cell of the column. Therefore, for the automatic lip-sync detection to work, your character's
mouth layer should already contain a mouth drawing for each drawing in the mouth chart, and these drawings should
be named by their corresponding letter.
How to generate a sound detection for lip-sync using the Layer Properties view
1. In the Timeline or Xsheet view, select the sound layer.
The options for that layer will appear in the Layer Properties view.
2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.
3. Click the Map button to open the Lip-Sync Mapping dialog box.
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4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's
voice track.

5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-down menu.
6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
7. Click OK.
8. In the Playback toolbar, enable the Enable Sound
9. Press the Play

option.

button in the Playback toolbar to see and hear the results in the Camera view

If you need to make adjustments to the automatically-generated lipsync, see Animating Lip-Sync Manually
on page 102

Animating Lip-Sync Manually
You can manually create the lip-syncing for your scene by selecting which mouth drawing should be exposed at
each frame of your character's dialogue. For this process, you will be using the Sound Scrubbing functionality,
which plays the part of your sound track at the current frame whenever you move your Timeline cursor, allowing
you to identify which phonemes you should match your character's mouth to. You will also be using drawing
substitution to change which mouth drawing is exposed at every frame.
How to animate lip-sync using the Timeline view
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips
for an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing
name (often a letter) until it changes to the swapping
pointer.
5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing
automatically changes to the new selection.
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How to animate lip-sync using the Library view
1. In the Playback toolbar, click the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The current
drawing is swapped for the one in the preview window.
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Chapter 18: How to Add Effects to a Scene
When creating a scene, rigging a character or once your animation is finished, you can add effects such as blurs,
glows, shadows, colour filters and transparency filters and to enhance your project's quality. Effects change the way
layers or groups of layers are rendered in your scene.

About Effects
Effects are special types of layers that you can add to your scene's structure. For an effect layer to work, it must be
connected to a drawing or a group. Effects only alter the drawing or group they are connected to, which gives you
flexibility in deciding precisely which parts of your scene is affected.
Some effects need to be linked to another layer referred to as the matte layer, which is used to define the area they
should affect. The most basic example of this is the Cutter effect. Alone, a cutter effect does not have any effect on
your drawing. Once combined with a matte layer, the Cutter effect cuts the shape of the matte out of the drawing.

A matte layer is simply a drawing layer that is connected to an effect as its matte. The effect takes the shape of the
drawing in the matte layer, ignoring its colours and details.
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In the Timeline view, an effect must be rigged as the child of the drawing layer or group it is meant to affect. If the
effect requires a matte, it will have a Matte parameter, on which you can drag and drop the layer you wish to use
as the effect's matte layer.

Once your effect is connected, you can adjust its parameters using the Layer Properties view. If desired, you can
even animate the parameters of your effect by converting their values to functions.

Adding Effects
In Harmony, you can add effects by selecting the layer or group you wish to add an effect to, then adding the
effect through the Timeline view's Add Layers menu. Then, you can achieve the intended effect by adjusting its
parameters in the Layers Properties view, and connecting it to a matte layer if applicable.
How to add effects in the Timeline view
1. In the Timeline view, select the layer on which you want to add an effect.
2. Do one of the following:
l

From the top menu, select Insert > Effects > effect.

l

In the Layers toolbar, click the Add Layers

l

From the Timeline menu, select Insert > Effects > effect.

button and select Effects > effect.

The effect appears in the Timeline view.

3. In the Camera view, click the Render View
button to see the scene's rendered current frame and
effect. Note that most effects cannot be played back in real time. You need to use the Render and Play
option in the Playback toolbar.

NOTE: By default, your background will appear pitch black. To remedy this, you can add a Colour Card layer at the bottom of your layers list, and tweak its colour in the Layer Properties
view.

4. In the Timeline view, double-click on the effect layer to open the Layer Properties window. You can also
select the effect layer and see its properties in the Layer Properties view.
The Layer Properties view opens, displaying the parameters available for the selected effect.
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5. In the Layer Properties view, adjust the effect’s parameters as needed. Each time you make a change, the
Camera view will need to refresh the render, which may cause a little delay before you can observe its effect.
6. To play back your scene with the final effects, in the Playback toolbar, click the Render and Play

button.

NOTE: Once you have set the parameters for the effect, you can store it in the Library view as a
template, so you can quickly reuse it without resetting the parameters again—see Templates in
Chapter 7: Library of the Cut-out Animation Guide.

Cutter Effect

The Cutter effect cuts out a portion of an image. To accomplish this, it needs to be connected to the drawing it is
intended to cut as well as to a matte layer. The cutter will take the shape of the drawing in its matte layer and cut this
shape out of the drawing layer. This is especially useful if you want to make a character disappear between a
background element, or if you want to cut out a hole in the middle of a character.
The Cutter effect has an Inverted parameter, which is disabled by default. When enabled, the Cutter will have the
revert effect: Instead of cutting the matte's shape out of the drawing, it will cut everything outside of the matte's
shape out of the drawing, leaving only the parts of the drawing that are covered by the matte.
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How to use the Cutter effect
1. Select a drawing layer.
2. Click the Add Layers

button and select Effects > Cutter.

The Cutter effect is created as a child of the selected layer.

3. In the Timeline view, create a new layer, which will be used as your Cutter effect's Matte layer.
4. In your new Matte layer, draw the shape that you want to cut out from your drawing layer.
5. In the Timeline view, click the Collapse/Expand
meter.

button on the effect layer to display its Matte para-

6. Drag and drop your matte layer next to your Cutter layer's Matte field, under the Parameters column.

7. If you want to invert the Cutter's effect, double-click on your Cutter layer to open its Layer Properties dialog, then enable the Inverted option.

Animating an Effect
In some cases, you may want to have the intensity, color, or another parameter of an effect animated. For
example, you may want an object to fade in or out, which would require making its transparency level animated so
that it increases or decreases as your scene goes. You can animate an effect's parameters by creating a function
curve for its parameter. You can then add keyframes to the function and set them to different values, hence
making your effect's parameter change value as your scene plays out. To do this, you will need to use the Layer
Properties view.
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How to animate an effect
1. In the Timeline view, select a layer and add an effect to it by doing one of the following:
button and select Effects > desired effect.

l

Click the Add Layer

l

Right-click and select Insert > Effects > desired effect.

l

From the top menu, select Insert > Effects > desired effect.

2. Create the function curve by doing one of the following:
l

l

Double-click on the effect layer to display the effect properties. Click the Function
the parameter you want to animate and create a function curve.

button of

In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand
button. Then click the Function
button of the parameter you want to animate and create a
function curve.
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3. In the Timeline view, go to the frame on which you want to start animating the effect.
4. In the Timeline toolbar, click the Add Keyframe

button.

5. In the Value field of the parameter you want to animate, enter the keyframe value. If your keyframes are
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set
Motion Keyframe.

6. Repeat these steps until your effect's animation is complete.
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Chapter 19: How to Export a Movie
If you need to create a video file, you can export your scene as a QuickTime movie.
By default, Harmony will export your entire scene in your scene's actual resolution. You can also choose to export
only a specific frame range in your scene, or to export in a smaller resolution, which can be useful if you need to save
on time or disk space. If you have specific requirements for the quality of your exported video files, you also have
access to the codecs and compression settings made available by QuiickTime's interface.
How to export a QuickTime Movie
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it a file name for the export.
3. Click OK.
4. From the Export Range section, decide whether you want to export the entire scene (All) or a specific frame
range. If you decide on the latter, enter the frame range.

5. In the Resolution section, select one of the following from the menu:
l

A preferred resolution ratio.

l

Custom: Enables the Width and Height fields so you can enter a specific size.
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6. In the Options section, click Movie Options.

Parameter

Description
Enables the customization of the video settings, filters and size.
Settings: Opens the Standard Video Compression Settings
dialog box.

Video

Filter: Opens the Choose Video Filter dialog box, where you can
select from a range of filters to apply to your video export.
Size: Opens the Export Size Settings dialog box. The size
settings are overridden by the Harmony's scene settings.

Sound
Prepare for Internet Streaming

Enables the customization of the sound settings.
Settings: Opens the Sound Settings dialog box (see below).
Enables the customization of the Internet streaming options.

7. In the Video section, click Settings.
The Standard Video Compression Settings dialog box opens.
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8. From the Compression Type menu, select a codec. The availability of certain compression settings depends
on the Compression Type selected. For example, Animation is the default compression type and as a result
the Data Rate option is greyed out.

NOTE: If you want to render a QuickTime movie with lossless compression and transparency, you can
use the Animation video codec with the colour depth set to Millions of Colours +.

9. In the Motion section, choose a Frame Rate from the list.
By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher
frame rate.
10. If you want keyframes inserted, select the Every option and set the number per frame.
This is the option is recommended by QuickTime. For further details, refer to the QuickTime documentation.
11. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of the
export, the larger the file.

12. From the Data Rate section, either choose to allow the program to automatically select the most optimal bit
rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of the
export.
13. In the same section, from the Optimized For menu, select the intended viewing method for the export.
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14. Click OK.
15. From the Movie Settings dialog box, click Sound Settings.
The Sound Settings dialog box opens.

16. From the Compressor menu, select a compression type. The default setting is None. This exports your
audio as is without performing any lossy compression or conversion, preserving its fidelity. Other compressors can be used if you need your movie's audio track to be exported in a specific format, or if disk
space or download speed is critical, but they may impact the quality of your movie's soundtrack negatively.
17. From the Rate menu, select a rate. It is best to export your audio at a rate that matches the rate of your original sound files. For example, if your file has an audio sample rate of 48 kHz and you choose a conversion
rate of 22.05 kHz, the sound will play at the same speed, but higher frequencies will be missing, making it
sound muffled. For reference, the standard sound quality is 44.1 kHz for films, and 48 kHz for DVD.
Lower rates are liable to impact the quality of your movie's soundtrack negatively, but they can be useful if
disk space or download speed is critical.
18. Select the Size of your audio's encoding. Also known as Bit Depth, this determines the amount of precision used to record each wavelength in the soundtrack. The standard size is 16-bit. If you choose 8-bit,
the amount of disk space your sound track requires is halved, but the audio will sound muffled.
19. Select whether to Use the Mono or Stereo channel mode. Stereo sound has a separate sound track for
the left and the right speakers, allowing to make the origin of each sound realistically match the origin of
their corresponding action. If you choose Mono, your sound track may use less disk space, but both the
left and right channels will be merged into a single track.
20. Click OK.
21. In the Export to QuickTime Movie dialog box, click OK.
A progress bar appears.

22. Browse to the location on your computer where you saved your QuickTime video and double-click on it to
view the export.
How to set the depth to Millions of Colours + to export a QuickTime movie with transparency
l

In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu.
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Glossary
3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a threedimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without an
alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to
indicate motion. The camera moves are also animated. The animatic is used to determine
the rhythm of a project and provides a good overview of the project before beginning
production.

animation

A simulation of movement created by displaying a series of pictures or frames.

anime

An animation style known for its sinister and dark feel; popular in Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).
In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier
curve is a mathematical or parametric curve. Bézier curves use at least three points to
define a curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.
Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.

117

Glossary

breakdown

In cut-out animation, breakdown is the action of breaking a character into pieces to create a
puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next, the
joints are fixed and the pivots set.
In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help describe the motion and the rotation curve (usually referred
to as an arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the
road.

caption

A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the
animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of
distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up

After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK

Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a
process called offset printing.

colour card

A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model

The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to create the final result
prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
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computer generated or done traditionally using paper.
cycle

A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an
exposure sheet.

doping

To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI

Dots per inch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease

In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Also known as slow-in.

ease-out

Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.
The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

A measurement unit used to calculate motion, registration and camera positioning. A
standard animation scene will vary between 6 to 12 fields.
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field chart

A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.

film-1.33

A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66

A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of an animation
sequence very quickly in order to see the animation in motion. Flipping can also be the
action of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a cloak
is running. The main action is the body running. This will cause the cloak to follow the
motion, although it will not move at the same time, but react a few frames later and follow
the main motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.
frame

An animation frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.
This is the measurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer graphics,
video cameras, film cameras, and motion capture systems.
Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality and make full use of your resolution setting, the output device must be
compatible with HDTV technology.

hold

A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.

ink and paint

The ink and paint process is the action of painting the empty zones and colouring the lines
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on the final animation drawings, while following a colour model.
interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics
(IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, and make the
rest of the body follow naturally.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similar image. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose

Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are the main drawings in an animation sequence describing
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wave motion and the other extremity. By flipping those drawings, the animator can see
the skeleton of the motion without having all the drawings.

keyboard
shortcuts

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe

Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer

In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is the action of
putting the storyboard on model. That is, drawing the character by following the design in the
model pack, so the animator can start working.
The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start
working.

layout artist

The artist who draws the background, and creates the camera and field guide to match the
scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process

The communication step between the storyboard and the animation.

library

A storage area containing templates and assets that can be reused in any project or scene.

light table

A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action

The direction that the action will follow. Also known as path of action.

lip-sync

The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
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video file take precedence over quality. A low-resolution image is one that lacks fine detail.
manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the entire
production to maintain consistency in the look and to ensure that the same colours are used
throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in different
projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence) used for lip-sync.

multiplane

The effect of passing through multiple levels of drawings to create a sense of depth in a
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the camera moves, a depth illusion occurs. With a multiplane, all the
perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge

A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used to move a selection very slightly and precisely.

onion skin

A feature that lets you see the previous and next drawings of a sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is placed in front of the main
animation.

PAL

A resolution that works best with the European format for television and computer screens,
as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as a master palette.

palette style

A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be
called a clone palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.

paperless
The paperless animation process is the action of animating digitally. The main paperless
animation/tradigital animation process is to draw, frame by frame, the animation directly in the software.
passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.
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path of action

Direction that the action will follow. Also known as line of action.

peg

In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are
motion paths that you can use to add path articulations. For the latter, you can also use an
inverse kinematics tool.

phoneme

A unit of sound in a language.

pivot

The point around which a peg or drawing rotates.

pixel

The smallest element of an image displayed on a monitor or TV screen.
Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small section made out of smooth filtering. If you zoom
in close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdown. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as adding motion
blur before it produces a final image. The process of calculating the final images after the
compositing process.

resolution

The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720
x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.

rigging

The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs

Rough is a common name in an animation movie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.
The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped by the TV frame.
As a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that
the scene's main action will remain clearly visible once the film is screened on television.

scene

A shot in a movie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.
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script

The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.

sequence

A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.

shot

A scene in a movie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.

slow-in

The gradual acceleration in the action. Also known as ease-in.

slow-out

The gradual deceleration in the action. Also known as ease-out.

slugging

To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion
keyframe

A keyframe with no computer-generated interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The storyboard indicates what will
happen, when it will happen and how the objects in a scene are laid out.

straight-ahead
animation

A technique in which an entire sequence is drawn from the first position to the last, in order.
There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
spontaneous and creative, it can create inaccurate results.

strokes

Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol

A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.

tablet/pen

A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

template

An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.

thumbnail

A very small image used as a reference or indicator.

timecode

The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.

timeline

A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional

A type of animation process whereby all the animation sequences are drawn by hand on
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paper before scanning or inking them on cels.
trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoid making innumerable
drawings, animators routinely make a walk cycle for a character.

zone

An area which can be painted with colour.
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