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Chapter 1: Toon Boom Harmony - About this Help
System
Toon Boom Harmony is an animation and digital content creation tool that offers you a wide array of features and
options. Harmony is packaged in several different modules and allows you to create animation using the technique
of your choice—see About Toon Boom Harmony on page 9.
This help system is built to guide you through the different workflows possible and explains which tool and module to
use in a production context.
Help Structure

5

Tutorials and Other Help Tools
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System Requirements
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Chapter 1: Toon Boom Harmony - About this Help System

The fundamental concepts of animation and Harmony are explained in this guide. It covers the essentials of
various animation workflows, basic animation principles, as well as Harmony's interface. Depending on what you
want to do, you can either start with this Fundamentals Guide to get immersed into the world of Harmony and
animation or go right to the Getting Started Guide , which covers the main functions and tasks. All conceptual and
reference topics are omitted to get you up and running in a very short amount of time.
The core of this help system revolves around the main features and techniques you can use in Harmony to create
animation:
l

Traditional Animation

l

Paperless Animation

l

Cut-out Animation

l

Gaming Animation

All workflows join in the compositing step of the process. All the information on compositing in Harmony can be
found in the Compositing Guide. Finally, you can watch the rendered animations in the Play module. To learn how
to use the Play module, refer to the Play guide.
If you are focusing on a single part of the workflow such as ink and paint or scanning, you can simply read the
Fundamentals Guide and one of the corresponding module guides:
l

Paint Guide

l

Scan Guide

Other satellite guides are also available to learn about additional information such as the preferences and
keyboard shortcuts.
l

Keyboard Shortcuts Guide

l

Preferences Guide

l

Scripting Guide

l

Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to this latest
version, refer to:
l

What's New (Release Notes)

Tutorials and Other Help Tools
Aside from the main product documentation, you can find supplementary material to learn more about Harmony.
The Toon Boom website's online resources section offers a variety of videos and samples that can further your
knowledge of Harmony.
l

Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

l

Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network

l

Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

l

White Papers: toonboom.com/solutions/white-papers
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System Requirements
Here are the technical specifications for Harmony 12.2.

Harmony
Here are the specifications to install Harmony. Note that this does not encompass the network and server
specifications for Harmony Server.
Requirements

Windows

Mac OS X

Operating System

Windows 7 64-bit
Windows 8 64-bit

Processor

Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor

Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800

Memory

16 GB
8 GB
4 GB

Mac OS X 10.9.5
Mac OS X 10.10.2 or later

Fast
Fast
•

NVIDIA GeForce GTX 780

Medium
•
Video Card

NVIDIA GeForce GTX 560, 650

Slow
•

Intel HD Graphics 4000, 5000

•

Intel Iris Graphics

•

NVIDIA GeForce GT 520, 620,
720

‣ Wacom Intuos Pro
‣ Wacom Cintiq
Basic

‣ Wacom Intuos
Media Player

AMD FirePro D500

•

NVIDIA GeForce GTX 775M

Medium

Best

Drawing Tablet

•

Apple QuickTime Player (free)

7

•

AMD Radeon HD 6770

•

NVIDIA GeForce 750M

Slow
•

Intel HD Graphics 4000, 5000

•

Intel Iris Graphics

•

NVIDIA GeForce 320M

•

Radeon HD 6630
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Chapter 2: About Toon Boom Harmony
Toon Boom Harmony is the most advanced professional animation software on the market. Bringing together an
impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D models,

Top Features
l

Advanced Drawing Tools: Texture brushes, and thick and thin pencil lines

l

Smart Colour Palettes: Colour you can adjust on the fly

l

Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

l

Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full particle effects
engine

l

Real 3D Camera: A camera you can reposition in a full 3D space

l

3D Integration: Allowing you to import 3D models, position and animate them in 3D space

l

Production Pipeline Integration: Seamlessly integrate content from pre-production via Toon Boom Storyboard Pro

Toon Boom Pipeline
Toon Boom Harmony has been recognized for its excellence by winning many awards, including a Primetime
Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated pipeline with Toon Boom
Storyboard Pro.
Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore, animatics
created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for animation and scene setup
guidance.

Render Resolution
The render resolution for the various editions of Harmony are:
•

Harmony Essentials: 2K (2048x1556)

•

Harmony Advanced: 4K (4096x3112)

•

Harmony Premium: Unlimited

Modules

Harmony Stand Alone is composed of the following modules:
l

Harmony on page 10

l

Play on page 10

l

Web Control Center on page 11
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These modules are all accessible from:
l

Windows: Start > Programs > Harmony 12.2 Essentials

l

Mac OS X: Applications > Toon Boom Harmony 12.2.1 Essentials

Harmony

Harmony Premium, Harmony Advanced, and Harmony Essentials are the core of Harmony. It comprises all the
major drawing, animation and compositing features. It is used to work in the scene: design, character breakdown,
cut-out animation, traditional animation, ink and paint, exposure sheet, timeline, effects, compositing, camera
moves, colour styling, and so on.

NOTE: To create scenes, you must use Harmony Premium, Harmony Advanced or Harmony Essentials. You
cannot create scenes in Stage with Harmony Server; you require the Control Center module.

To learn more about Harmony Premium, Harmony Advanced and Harmony Essentials, refer to the following
guides:
l

Fundamentals Guide

l

Getting Started Guide

l

Traditional Animation Guide

l

Paperless Animation Guide

l

Cut-out Animation Guide

l

Gaming Guide

l

Compositing and Effects Guide

l

Play Guide

l

Preferences Guide

l

Keyboard Shortcuts Guide

l

Scripting Guide

l

Utilities Guide

Play

The Play module is used to play back the rendered image sequences enabling the user to view the final scenes
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and compositing results.
To learn more about the Play module, refer to the following guides:
l

Fundamentals Guide

l

Play Guide

Web Control Center

You can access your database via the Web Control Center. When you're running a studio, you will most likely have
a database set up. This enables all the artists working on your production to share the same scenes and assets.
The Web Control Center lets you host this database on the Internet. This way, freelancers can log in from anywhere
with an Internet connection. Then they can download a scene from the database, work on it, and upload it again.
You no longer need to spend time copying files to an FTPor require an administrator to export and import files from
the database. You can do it all directly through the Web Control Center.
To learn more about the Web Control Center, refer to the following guides:
l

Installation Guide

l

Control Center Guide
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Chapter 3: Animation Workflow
In this chapter, you will become familiar with the different animation workflows and how they end up merging
together. There is also an overview of how they work with Harmony.
To begin with, let's determine what an animation workflow is. No matter which method you choose to create your
project, it will always be divided in three segments. Then you will have to choose your animation method.

Harmony is designed to handle part of the pre-production and all of the production. Post-production is managed in an
external application. The three workflow segments are each broken down in different steps.

Pre-production
The first segment is the pre-production.
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Pre-production almost always follows these steps:
Script
Every project starts with a script or a synopsis. You will also see the term screenplay. A script is the written
version of a project done by a screenwriter. You will encounter a script in many different types of projects such as
movies, television series, video games and advertisements. It is the source for all the upcoming steps. A script
usually contains the storyline, location descriptions, actions, dialogue, sound effects, etc. It contains all the
information necessary for the artists to illustrate and animate the movie or series.
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The script is needed in order to transform the project into a storyboard. This same script is used as a dialogue for the
audio recording. Finally, characters, props and locations will be designed from all of the descriptions contained in the
script.
Storyboard
The storyboard, which is created by the storyboard artist from the script, is also common to all types of projects. A
storyboard is a visual representation of all the scenes and actions contained in the script. The dialogue,
backgrounds, action notes, and characters are included.

The storyboard is often created at the same time as the characters, props, location design and audio recording. The
first storyboard is not always exact, as the designs are subject to many changes during the beginning of a
production.
The storyboard is essential to the layout and posing, and the animatic.
This step is not done with Harmony. Traditionally, the storyboard is created on paper. This step can also be
achieved with Toon Boom Storyboard Pro, software developed specifically for this use. Toon Boom Storyboard Pro
projects can be imported into Harmony.
Character, Prop and Location Design
Once the script is completed, the designer can start work. Before any animation, background or colouration can be
15
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done, the overall design needs to be addressed. The artist has to decide on the production style, the character's
look, the location's complexity, and so on. Once these designs are done and approved, the model pack is
produced, containing all of the models for all these aspects.

The designs and models will be used by the colour stylist and layout artist, and finally by the animator.
Audio Recording
The audio recording is also called voice recording. The script is needed for dialogue and extra sound effects. The
actors will read the lines from the script and record their dialogue. These voices will be used later on for the
animatic, the animation and the final production compositing.
Animatic
The animatic, also known as leica, comes directly from the storyboard. The animatic is the first movie of a project
and is used to help the animators and compositors. The storyboard is scanned in and mounted with the sounds
and dialogue. There is no animation yet. It is simply the storyboard frames changing over time to help evaluate the
rhythm and the look of the show. This will help avoid mistakes that would have been found only at the end of a
show.
This step is unnecessary if you are absolutely sure of your storyboard and timing, but an animatic is always
recommended.
This step is not done with Harmony. Generally, an external software is used to do the storyboard editing to create
the animatic. This step can be achieved with Toon Boom Storyboard Pro software which was developed
specifically for this purpose.
Character, Prop and Background Colour Styling
Once the black and white designs are done, they are sent to colour styling. The colour stylist chooses the colours
and ambiance for the production and balances the characters, props and effects with the location palettes. This
contributes to a consistency or an emotional contrast, where needed, in the show. When the colours are
approved, colour models are produced and backgrounds are painted. Colour models will often be added to the
model pack.
The colour models will be used by the colourists and the coloured background will be sent for compositing.
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Sound Breakdown
For the dialogue, a sound breakdown can be done. This means that the sound will be broken down in small pieces
and written on the traditional exposure sheet for the animator to use. Each frame will have its own bit of sound
information which tells the animator what mouth phoneme to place on the character on a particular image.
For digital cut-out and paperless animation, the traditional sound breakdown is not necessary as there are different
tools inside Harmony to help the animator achieve the same result.

Production
The production segment can vary greatly depending on the user and the technique. There are three main techniques
or animation types that you will discover on the following pages: traditional, paperless and cut-out. For more
information about production steps, see About the Animation Types on page 19

Post-production
Post-production is the final step in which video and audio editing and calibrations are done. Some effects and colour
grading can also be performed at this stage.
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Final Editing
The final editing comes after the rendering of the production scene. Harmony does not handle the editing, so the
renders are exported to an external application. There, the different scenes are assembled and adjusted. If need
be, users can add extra filters and effects, such as transitions between the scenes, during this step.
Once the editing is completed, the audio will be added.
Audio Editing
The audio editing is also done in an external application. It can be done directly in the editing software or in an
audio application and then transferred to the editing software. The dialogue, sound effects and soundtracks will be
adjusted and placed with the project's final editing. The tracks will be matched to the images and volumes and
effects will be added.
Dubbing
Once the final images and sounds are assembled, the project is ready for dubbing. Actors will come in and record
voices over the movie. This process is called post-synchro. At this point in the process, multiple languages can
be added to the soundtrack.
The project is complete, and is ready to be output to the final master copy.
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Master Distribution
All of the data is transferred to the master copy and the user or studio is ready to distribute the project to the clients,
festivals, television, cinema, and other venues.

About the Animation Types
Harmony is an animation and digital content creation software. Animation can be divided into three main categories:
traditional, paperless, and cut-out animation.
These techniques can be used independently or together. Harmony is optimized to handle all three animation types,
one of the software's great benefits.
Each animation technique has its own advantages and disadvantages. Combining different techniques allows you to
incorporate the best elements while eliminating the weakness of an individual technique that may not be exactly
what you need.
Before going any further, review each animation type:

Traditional Animation

Traditional animation is the original method of animation, as well as the most popular. It is also called cel or classical
animation. It consists of drawing every image of an animation on paper, normally 12 to 30 drawings per second per
character or layer. The number of drawings per second is determined by the format (NTSC or PAL) or purpose. The
human brain is able to process an animation with a minimum of 12 drawings per second. The number of drawings per
second will be between 12 and 30. The standard is 24 or 25 frames per second.
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From the end of the 19th century to the late 1980s, the workflow was entirely done manually. Only with the
introduction of computers to the general public did some of the steps become automated. Now, with all the
technology available, the colouring and compositing are achieved digitally. However, the drawing part is still done
by hand on paper.

Paperless Animation
Paperless animation is the most recent 2D animation process. It consists of digitally drawing all of the images of
an animation. It is similar to the traditional animation technique.

This method is entirely digital; it does not involve any materials other than virtual tools. However, the animator
still must draw each frame individually.
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Paperless animation requires the user to be familiar with digital graphic applications and be able to convert this
traditional knowledge to a digital medium. This method of animation allows significant control over the drawings, a
possibility for greater quality and an infinite number of complex poses and rotations for the animated characters and
objects. It also eliminates the paper used in traditional animation and gives you the opportunity to instantly see a line
test. Paperless animation allows you to easily cut and paste parts of a drawing, undo actions in case of mistakes,
and zoom in and out of drawings.

Cut-out Animation

Cut-out animation consists of breaking down a puppet into pieces that are moved frame by frame to animate the
character. It can be divided into two categories: classical and digital. When working in the classical cut-out style, the
animator manually moves the parts under a camera and shoots each frame before moving on to the next pose. When
working in the digital style, the parts are moved in a similar way as the classical cut-out style and then keyframed in
the computer software, which means that it is fixed and recorded digitally. Since the characters and objects are
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composed of many parts, the animator does not need to redraw them on each frame, but can just move or distort
the parts to create the animation.

Harmony allows you to do digital cut-out animation, which has become increasingly popular in recent years.
Cut-out animation requires you to be familiar with digital graphics applications. Cut-out animation is very useful in
cutting down the time it takes to complete a project. There is no need to redraw characters and the computer can
handle a large part of the in-betweening. It also eliminates the paper used in traditional animation and allows you
to instantly see a line test. The team for a cut-out project is much smaller than that of a traditional production,
allowing the whole production to be kept within the same studio. This also means that you have a great deal of
control over quality.
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Production Steps

Now that you know the differences between the traditional, paperless and cut-out animation types, you can move on
to the basic organization of their workflow. The following illustrations show the animation pipelines that represent the
most popular workflows. The tasks can be divided or the order can be rearranged to suit the specific needs of the
studio or user.
After familiarizing yourself with the basic workflow pipelines, you should read about the various examples of the
workflows and how the individual and the studio are organized according to their size.

Traditional Animation Workflow
In a traditional workflow, many steps are done manually. Harmony is used for the digital portion. We will focus
mainly on these steps.
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The following is a list of the steps done using Harmony in a traditional animation workflow. This will help you
understand how the work is divided and give you a base to start building your own traditional pipeline.
Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses the storyboard
and prepares an organized folder for the animator. This folder contains a field guide that shows the proper camera
move and the right size of the scene. It also includes the character's main poses from the storyboard following the
official design, and the effects, backgrounds and all the other information necessary to the animator.
The backgrounds are done directly out of the storyboard and location design. A background is a section or an
angle of a location. The background artist refers to the storyboard and draws the background for each scene.
Once the background is completed, it is added to the layout folder.
In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on the
user's preferences.This step is mainly applied to larger productions. An individual user can move directly from the
storyboard to the animation.
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This step can be done with Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.
Animation
Traditional animation is done on paper. The animator receives the layout folder and uses the references to animate
the scene. The animator will draw each frame of the animation or each pose of the character. If there is dialogue in
the scene, the animator will follow the breakdown and animate the mouths and expressions.
Depending on the studio size, the animation can be divided in different ways. Sometimes the animator will do all of
the work, from the key poses to the in-betweens and then the clean up. Bigger studios will have the animator doing
only the key poses and then send the scene to the in-between department and finally to the clean up department.
Once the animation is completed, it is sent to the digital part of the process. This applies only to modern processes.
In the traditional, old-fashioned pipeline, the animation was sent for hand-inking and painting. The animation was
traced with ink on transparent cels and the colours are painted with brushes on the other side of the cel to fill the
zones. Today, using Harmony, you can still use this technique by utilizing the digital Line Art and Colour Art feature.
Digital Exposure Sheet
The digital exposure sheet is the first step done in Harmony. This controls the timing of the animation. The traditional
animator creates a paper exposure sheet in order to create the timing. The person in charge of the digital exposure
sheet reads the paper version and recreates it in Harmony. Once the drawings are all in place on the exposure sheet,
the scene is ready for the scan.
Note that a single user will scan the drawings first and then set the timing in the exposure sheet. The digital
exposure sheet is only created first in a larger animation studio using the advanced scan features available in
Harmony.
Scanning
Scanning is the second step in Harmony. The cleaned-up drawings are scanned and imported in the software in a
simple step that incorporates all of the drawings in the scene. When all the drawings are scanned, they are ready to
be inked and painted (coloured in).
Inking and Painting
At this point in the process, the colour models are ready and the drawings are scanned in and properly exposed.
Using Harmony's optimized tools, the colourist can clean the scanned artwork and start applying colour to the
different drawings. When the drawings are cleaned, as well as inked and painted, they are ready for compositing.
Compositing
The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
moves and other necessary motions. Finally, the compositor adds any digital effects required by the scene. These
can include tones, highlights and shadows. When the compositing is completed, the final step is the rendering.
Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
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Generally, the compositor will be the same person doing the render.

Paperless Animation Workflow

The following is a list of the steps done using Harmony in a paperless animation workflow. This will help you
understand how the work is divided and give you a base to start building your own paperless pipeline.
Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses the storyboard
and prepares an organized folder for the animator. This folder contains a field guide that shows the proper camera
move and the right size of the scene. It also includes the character's main poses from the storyboard following the
official design, and the effects, backgrounds and all the other information necessary to the animator.
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The backgrounds are done directly out of the storyboard and location design. A background is a section or an angle
of a location. The background artist refers to the storyboard and draws the background for each scene. Once the
background is completed, it is added to the layout folder.
In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on the
user's preferences.This step is mainly applied to larger productions. An individual user can move directly from the
storyboard to the animation.
This step can be done with Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.
Animation
Paperless animation is usually one of the first steps done in Harmony. All of the drawings are created digitally, using
a pen tablet to optimize work and drawing ability. Other than the digital aspect, the animation principles are not very
different from classical animation. The animator will use the same animation styles and methods as would be used
on paper–only the medium is changed.
When all of the animation is done and the drawing timing is completed through the exposure sheet or the Timeline
view, the scene can proceed to the animation clean-up process.
Animation Clean-Up
The animation clean-up consists of transforming the rough paperless animation into cleaned, tied down and inked
drawings. On a new layer, the clean-up artist will trace the animation following the official model pack (document
containing all the official character, location/props design and colours). This step must be done very accurately.
When the clean-up is over, the scene is passed along to the colourist for the ink and paint step.
Inking and Painting
At this point in the process, the colour models are ready and the drawings are properly exposed. Using Harmony's
optimized tools, the colourist can start applying colour to the different drawings. When the drawings are inked and
painted, they are ready for compositing.
Compositing
The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
moves and other necessary motions. Finally, the compositor adds any digital effects required by the scene. These
can include tones, highlights and shadows. When the compositing is completed, the final step is the rendering.
Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
Generally, the compositor will be the same person doing the render.
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Cut-out Animation Workflow

The following is a list of the steps done using Harmony in a cut-out animation workflow. This will help you
understand how the work is divided and give you a base to start building your own cut-out pipeline.
Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses the storyboard
and prepares an organized folder for the animator. This folder contains a field guide that shows the proper camera
move and the right size of the scene. It also includes the character's main poses from the storyboard following the
official design, and the effects, backgrounds and all the other information necessary to the animator.
The backgrounds are done directly out of the storyboard and location design. A background is a section or an
angle of a location. The background artist refers to the storyboard and draws the background for each scene.
Once the background is completed, it is added to the layout folder.
In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on the
user's preferences.This step is mainly applied to larger productions. An individual user can move directly from the
storyboard to the animation.
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This step can be done with Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.
Character and Prop breakdown
The breakdown step is really important in the cut-out workflow. The person doing the breakdown has to take the final
character or prop model and start building the puppet. This means deciding which parts will be separated and
preparing all of the joints and views for the animators.
Once the parts are broken down, the character or prop must be rigged. This means attaching the parts (hierarchy)
and assigning the appropriate pivot points. This step must be done with care because these puppets will be
distributed among all the animators later and you do not want to duplicate mistakes throughout the project.
When the character and prop rigs are ready, the breakdown artist stores them in the library as templates to be shared
with the rest of the team.
Library
The library is a central element of a digital cut-out production. It contains all the assets for the animation and scene
set up.
The library is a central location where all these templates are stored, organized and made available to the animators
and scene setup team. The library should be structured so that everyone using it can easily find the assets they
require. Someone should be assigned to manage the library so that it remains well organized. This person is often
the breakdown artist, but it depends on each studio's structure.
When the library is built, the scene setup person and the animators will start using the assets.
Scene Setup
The scene setup consists of preparing the scenes for the animators and is similar to the traditional layout and
posing. Following the storyboard and the animatic, the person working on the scene setup will import the assets
needed for the scene animation, as well as import the animatic reference and often position the camera.
When the scene setup is completed, the scene can be passed on to the animator who can start animating without
having to mount the scene.
Animation
Cut-out animation is a vast subject. There are many techniques employed by different studios and animators.
Basically, the animator moves the parts frame by frame to animate the puppet. The animator may even start their
own pre-compositing, camera moves, and trajectories. This depends on the user's workflow. Once the animation is
completed and approved, the scene goes to the final compositing and effects.
Compositing
The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
moves and other necessary motions. Finally, the compositor adds any digital effects required by the scene. These
can include tones, highlights and shadows. When the compositing is completed, the final step is the rendering.
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Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
Generally, the compositor will be the same person doing the render.
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Chapter 4: Animation Principles
Animation can be used for several different purposes such as movies, advertisements, video games, corporate
presentations, medical concept demonstrations and much more. Not all of these require the same animation quality
level. To illustrate a concept, simple and linear animation is often more than sufficient to convey the message. For a
feature length animation movie, the animation needs to be convincing and carry some weight and elasticity.
You will notice when you watch different movies that the animation style will differ quite a bit from film to film. Some
have a very fluid and smooth flow in their animation while others have a very bouncy, cartoony feel. People without
animation experience may watch a movie and find the animation very bad, unconvincing or too slow. They might not
know why exactly, but they know that something isn't right. Most of the time, it happens because the animators
missed a few of the fundamental animation principles.
If you already are an experienced animator, you can skip this topic and continue along.
Here are the main principles that create the backbone of a good animation. You will no doubt encounter variations of
these principles when reading articles online or reading different books.
Squash and Stretch

Squash and stretch is at the core of the animation principles. It is what gives some elasticity and flexibility to your
animation. When an object hits the ground, the impact drawing will be really squashed. As it bounces off the ground,
it will stretch in the opposite direction. The stronger the squash and stretch is, the smoother and bouncier the
animation will look. Also, hard objects such as a bowling ball require less squashing or stretching so that the heavy
and solid illusion remains. As you squash and stretch an object, it is really important to maintain the volume of the
object. When you squash something down, you need to proportionally stretch it sideways, otherwise, the object will
look like it is getting smaller.
Timing
Animation is all about the timing. The timing comprises many things in animation. It is the duration of an action. It is
the speed and velocity of an action. It is the way actions overlap and secondary objects follow the main action. If the
timing is off, too slow, too long, too fast, or too linear, the animation will not look realistic. It will be stiff, even boring.
The nature of the character, personality or weight of an object will influence the timing of the animation.
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Anticipation

Anticipation is the preparation for an action such as a jump or a punch. For example, a character will squat down
before pushing his body and legs up into a jump. The stronger the anticipation motion, the more cartoony and fluid
the animation will be. The smaller the anticipation, the more stiff the animation will be.
Straight-ahead and Pose-to-pose

These are two different ways to animate an action. The straight-ahead technique means to animate your action
from drawing 1 to the end in sequence order. The pose-to-pose technique is a bit more intricate as it means to
draw the key poses first (often the beginning and end drawing of the action and some other key moment between.
Once the key poses are done, the breakdown and inbetween drawings are added to fill the rest of the animation.
Smoke, water and other fluid elements are often animated using the straight-ahead technique. Actions that
require tight timing and structure are often animated with the pose-to-pose technique. This method helps maintain
a solid structure and preserve the volume. Sometimes, when using the straight-ahead technique, it may be
difficult to calculate where the action will end up and the final drawing may be out of proportion and not where it
should be.
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Follow-Through

The Follow-Through principle is very important for increasing the quality of your animation. All the secondary parts of
your character such as hair, clothes or a cloak will continue moving after the character stopped moving. Also if you
observe closely, when a character walks, its body moves and down, and its long hair or cloak follow behind on the
same path but with a slight delay. Therefore, your character might be at the lowest point in a crouching action but his
cloak will be all the way up in the air. Also, notice that when the cloak floats behind the character, it will move along
an "S" curve. The part of the cloak that is attached to the body will not always curve in the same direction as the tip
of the cloak.
Arcs of Rotation

The human body moves from its articulations such as the shoulders, knees, hips and elbows. Therefore, all limbs
move by rotating on their pivot (articulation). When animating an arm going up or down, the hand will not reach its
end point on a straight trajectory. It will follow an arc until it reaches its end point.
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Slow-in and Slow-out

Most characters and objects accelerate and decelerate when moving. Most movements are not linear, therefore
to reproduce the slow-in and slow-out effects, we add more drawings closer together at the beginning of the action
and same at the end of the movement. The closer the drawings are, the slower the animation will be. The farther
apart they are, the faster the animation will be.
Secondary Actions

Secondary actions add another layer of realism and quality to an animation. The secondary actions are the other
limbs or objects moving along with the main action. They are not the follow-through actions, which are inanimate
objects reacting to the main actions. They are the limbs that move, such as the character's arms swinging
rhythmically back and forth when walking. He could nod in time to music while taking a stroll or blink or chew
gum.
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Exaggeration

The principle of exaggeration is another important way of adding life in animation. Sticking exactly to reality will
make for a very stiff animation. Changing the direction of the main body curve from backward to forward in a
dramatic way, using squash and stretch, snappy timing and good slow-in and slow out help exaggerate the
movements and add life to your animation.
Solidity

In animation it is paramount for drawings to have a strong underlying structure. The animator must understand the
anatomy and skeleton of the characters and props to be animated. Without a good structure, the drawings will
deform, bend in the wrong places, and progressively become off model.
The animator should always know what is under the skin of his character.
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Chapter 5: Concepts

Harmony was designed using traditional animation concepts. This lets you use familiar tools and work practices.
Whether you are new to animation or an experienced animator who wants to understand Harmony, the concepts
covered in this section will be interesting and useful.
Bitmap and Vector Graphics
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Bitmap and Vector Graphics
There are two types of digital images: bitmap and vector. Discover their main differences so you can make the
optimal choice for your project.

Bitmap Image Types
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A bitmap image consists of pixels and has a fixed size. A pixel, short for picture element, a single point in a
graphic image. It is a small sample of an image, a dot, a square or a very small section made out of smooth
filtering. If you zoom in close enough on a digital image, you will see the pixels. They look like small squares of
different colours and intensity. Since a bitmap image is composed of pixels and has a single resolution (size), if it
is enlarged too much, it will start losing definition and pixels will start to appear. This is known as pixelation.

Vector Image Types

A vector-based image is composed of points and Bezier curves. The computer reads the points and traces the
segments linking them to reproduce the image shape. There is no fixed size or resolution in a vector image. You
can enlarge the graphic and distort it as much as you want, and the system will simply recalculate the segments
and rebuild the shapes. The segment's shape can be controlled with Bezier handles to curve and smooth it.
Vector images are translated and displayed in pixels once the calculation is done.

Advantages and Disadvantages of Bitmap and Vector Images
Bitmap images allow a more organic style. Since everything has a fixed size and is already made out of pixels,
more effects are possible, such as blur, texturing, shading, a painted look and so on. The bitmap format is
excellent for creating backgrounds and overlay elements. However, because of the precise resolution, in order to
zoom in on or to work in high resolution such as HDTV, the created file must be a large size.
Vector-based graphics can be very useful when creating large illustrations, as these graphics are resolution
independent. The images can be significantly enlarged without losing definition. A vector-based image is
generally a smaller file size than a bitmap, as it is a set of mathematical points. However, if there are many
vectors composing the graphic, the result can be larger than a bitmap file. A vector shape can always be
modified. It also creates very crisp images.

Colour Palettes

In animation, precise colours are used to paint each particular character and prop. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to as master palettes.
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Before computers, painters used real colour pots (often big glass jars) mixed by a colour palette artist. The colour
palette artists had to make sure to use the exact same amount of paint from each tint every time they would mix a
new batch to make sure the colours would remain consistent throughout the entire movie. Now, using a computer
process, a digital colour palette is created. This allows absolute colour accuracy by always having the same group
of colours associated with each character.
Master palettes contain a colour pot for each zone to colour with a precise RGBA colour value.
l

Red

l

Blue

l

Green

l

Alpha (contains transparency information)

Painting animation using a master palette is very similar to the paint-by-number concept.
Using a master colour palette has many benefits, including:
l

Each character consistently retains their dedicated colours.

l

You cannot accidentally use a colour which is not in the master palette.

l

Standardization and colour consistency throughout the production.

l

Multiple artists can use the same colour palette and produce the same results.

Exposure Sheet, Timeline and Timing
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Animation is about movement and in order to have the illusion of movement, you need different drawings to
progressively change over time. For your eyes to perceive a smooth motion and not just a series of drawings
changing, you need several drawings per second. To be more precise, you need a minimum of 12 drawings per
second. If you have less than 12 drawings per second, the motion will be jerky and you will not see a smooth
motion.
It is important to know that the number of drawings per second will be based on the final output: television,
cinema, web, DVD, etc., as those outputs have different frame per second rates. This parameter will influence
the number of drawings per second as well as their exposure.
The exposure of a drawing is the length of time that it stays on the screen. A second can be divided as follows:
24, 25 or 30 images depending on the format. They are also called frames, so there are 24, 25 or 30 frames per
second.

Broadcast Standards
There are two main broadcast standards used; the one selected will determine the frame rate.
In North America, Japan and other parts of Asia, the NTSC (National Television System Committee) format is
used. This format is 30 images (frames) per second.
In most of Europe, PAL (Phase Alternating Line) format is the broadcast standard. This format is 25 frames per
second.
Film format is 24 images per second.
The human brain is able to process an animation as slow as 12 drawings per second. Therefore, the number of
frames per second should be between 12 and 30. The general standard is 24 or 25 frames per second, so these 12
drawings are set on double exposure. This means that each drawing stays on the screen for two frames. If a
drawing is exposed for 24 frames, it means that it will appear to the eye for one second.
The timing is a drawing's exposure.

Exposure Sheet

The exposure sheet, also known as the Xsheet or dope sheet, is used when an animator is planning a scene. The
animator enters data in the different columns (layers), the name of the drawings and their exposure into the
Xsheet.The Xsheet allows you to see the animation timing in detail.
The Xsheet is composed of columns corresponding to the different layers. Each column is split into rows
representing the frames (images) in the scene. A paper Xsheet usually has 80 rows and ten columns. This
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enables the animator to associate a layer with a certain element (character, prop, mouth, etc.) and make a record of
the frame at which each drawing appears.
The traditional paper Xsheet was mainly created for the animator to communicate with the cameraman regarding the
scene's timing, the camera moves and element trajectories. It is still used today to express the same information to
the compositors and the person working on the digital Xsheet.

Timeline
A traditional timeline is a horizontal and chronological representation of key events occurring within a particular
historical period.

In the digital process, the timeline is quite similar. The timeline is read from left to right to help you understand the
scene and its timing. The frames or timecodes are placed at the top and the elements or layers on the left. There is
no drawing name or value information. The timeline displays the timing and elements in a simplified and systematic
manner, making it easy to read globally. The timeline can be considered to be a quick overview of the whole scene.

Xsheet and Timeline Usage
Xsheets and timelines are used for different tasks. When a scene is done in a traditional animation workflow, the
Xsheet is useful in keeping track of the drawings' ordering, names and timing. The Xsheet is used to reproduce the
animator's work in the digital software or the camera. The colourists can then follow the Xsheet to paint the drawing
sequences. Finally, the compositors can read the information that is necessary to their work from the Xsheet.
For digital animation, computer generated trajectories, hierarchies and distortions, there is a lot of extra information
involved, including keyframes, velocities, function curves, and more. A keyframe is a computer-generated key
position that contains values and coordinates for the element's onscreen positioning; keyframes can be displayed in
the exposure sheet as values. If there are too many keyframes, modifying one can be difficult due to all of the values
present. This is why there are digital timelines. Their simplified version of the timing is quite useful in these
situations. The Timeline view does not display drawing names or keyframe values, but instead represents them as
symbols, making it much easier for the eye to detect the desired element for modification. Although the name and
value information is not directly displayed, the Xsheet is still very valuable when retrieving this type of information.
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Pegs

Pegs have been used for a long time in the animation process, mainly for registration purposes. Peg holes at the
bottom (or top) of animation paper are used to keep all of the sheets even and at the same registration.
There are three peg holes in regular animation paper. The centre one is circular and the left and right ones are
rectangular and situated at 4 inches from the centre one.

To keep the drawings together, traditional animations use a peg bar. This bar has three pins shaped exactly like
the peg holes. Peg bars are normally found at the bottom and top of animation discs.
Before digital compositing, the peg bars were also used to move layers under the camera stand. All layer
translations were calculated based on the distance the pegs were moved frame by frame. They were the
equivalent of the digital trajectories. Harmony makes use of these concepts to create animation and camera
moves.
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Multiplane

In the animation context, multiplaning is used to create a scene with many planes placed at different distances from
the camera to recreate a perspective illusion. A plane is a layer or an element. In regular flat 2D scenes, all the
elements are at the same distance superposed one on top of another. So, when the camera moves, all the elements
are moving at the same speed. In real life, all objects and elements are placed at different distances from our eyes
so when we walk or drive past, the closest objects appear to be moving away faster. The farthest ones, like
mountains, are barely moving. In animation, that perspective effect has to be reproduced manually.
In 1933, the Walt Disney Company invented the multiplane camera. They got the idea from looking at methods used
in the theatre to introduce perspective into a space with limited depth. In the theatre, cut-outs and flat pieces were
placed in a variety of layers in front of a backdrop which allowed actors to move through the various sets while giving
the illusion of depth. Walt Disney's final design for the multiplane camera used this same concept. The multiplane
camera which was set up vertically, much like a photographic enlarger, would shoot down through as many as five
planes attached to vertical posts that allowed four of the planes to move independently of one another. The first two
planes were used for animation, the next two were for backgrounds, and the fifth was fixed and used for sky
backgrounds. The finished result produced a depth of perspective which had not previously been seen in animated
film.
Multiplane camera effects can be created digitally. There is no longer a need to use the big multiplane camera.
Multiplane shots are normally used to add depth to a scene to reproduce perspective effect more easily. They can
also be used on a smaller scale to make elements pass in front of and behind certain objects like trees or chairs.

Network
A network can be described as an interconnected group or system of elements leading to a central point. It is widely
known as a node system.
A network can be useful in animation because many components enter the process. A visual network can help
represent many things like scenes, effects, composition and textures.
the Xsheet and timeline enhance the element display, but they may not be the most efficient for some production
aspects. The Xsheet provides traditional animation details, displaying drawing names, values, exposures and
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timing. The timeline displays all of the timing, drawing exposures, keyframes and trajectories in a schematic view
to provide a quick overview of the whole scene, enabling you to easily detect different elements. When it is time
for advanced hierarchy, compositing, effects filters, grouping, and cutters, a timeline can get overloaded and may
not have the capacity to represent the reality of things.
For greater efficiency, a network is brought in to visually represent all of the parenting, hierarchy, effects and
element compositing. There is no timing representation or drawing name, but a visual set of links or cables
between the elements that are represented as boxes or nodes. It helps the eye follow very quickly to what is
happening in the scene. Also, because of the linking power available, a network allows more advanced
connections and parenting than a timeline.

Elements can be combined using effect nodes or composite nodes and turned into something new. Elements can
cut others or control other ones. In the end, all elements are brought into a composite node to turn all drawings,
layers, parameters and effects into the final animation output.

Frame Rate and Format

When you create an animation, the images you animate must move fluidly to produce the correct effect. If they
don't, you will have a jumpy animation which won't look good. To get a fluid movement between the drawings,
you need several images per second. You need a minimum of 12 images per second, any slower than that and the

44

Harmony 12.2 Essentials - Fundamentals Guide

animation becomes jumpy. An image can also be called a frame, therefore the frame rate is the number of frames
you play per second in your animation.
The format of your project is the size of your camera frame in pixels. You may not be familiar with the term pixel, but
you have probably seen it when you magnify a digital photograph. A pixel is the smallest element of an image
displayed on a monitor or TV screen. Pixel, which is short for picture element, is a single point in a graphic image. It
is a small sample of an image, a dot, a square or a very small section made out of smooth filtering. If you zoom in
close enough on a digital image, you will see the pixels; they look like small squares of different colours and
intensity.
Depending on the type of project you want to create, you will need a different image size. For example, if you want to
put your project on the web, you will probably export your movie as a small size so that it is light to play back once it
is on the web. The larger the images are, the heavier the project is, but also, the better the quality. If you want to
export your project for the theatre, you will ned to create your project in a large format so the image is of a high quality
and looks good on the big screen.
Also, some display media such as iPad, TV or theatre have an exact format requirement. For example, one TV
format that has been a standard for decades is the 4:3 size ratio, meaning that the width of your scene has the
equivalent of 4 units compared to 3 units for the height.
In recent years, a new TV standard has been defined with the advent of Blu-ray and high-definition technologies. It is
the 16:9 format, which is often referred to as HDTV (High Definition Television). The most common 16:9 format in
pixel is 1920 x 1080.
You can find most of the formats in the presets list provided in the Harmony Welcome screen.
To recap, the format is the size of your camera frame in pixels, and it matches the width and height required for the
medium in which you want to show your final movie.

Scenes

Planning is an important step in creating an animation project. This involves listing the scenes that need to be
animated, the characters to design and the different backgrounds to incorporate.
In animation, a scene is the action happening in front of the camera while the camera does not change angle. As long
as the camera does not stop "filming", you are in the same scene. A good example would be two characters talking.
When the camera is facing the first character, this is one scene. When the camera cuts and films the second
character, you have a second scene. When the camera returns to the first character, you have a third scene, and so
on.
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A group of scenes occurring in the same location about the same action or event is called a sequence. When
there is a change of location or subject, it becomes a second sequence.
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Chapter 6: Project Organization
When working in production, it is important to keep your work organized. It is important to create a naming
convention chart and establish a file storage structure before starting the project. It is not only extremely important
that everyone follows the criteria laid out in the naming convention chart and the file storage structure, but also that
they understand the organization and where to find the files.
A well thought-out and logical naming convention will help keep your production structured and allow it to run
smoothly by preventing the loss of files due to chaotic organization.
In this chapter, you will learn how to organize and name the different components in your animation project.
File Structure

47

Root Directory and Content Building Scenes

48

Drawings and Layers

50

Libraries and Templates

52

Naming Convention
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File Structure
A Harmony project is composed of several files. The drawings and colour palettes are not embedded in the project.
They are separate linked files. Therefore, if you want to archive or share a project, you require all the files contained
in the folder structure.

Scene File Structure
Here is an example of the file structure contained in a scene. As you work and use more features, different folders
may appear in your structure.

The Harmony scene folder contains the following folders: frames, audio, elements, etc.
Folder

Contents

annotation

Contains the images and thumbnails created while drawing in an Annotation
column in the Xsheet view.
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audio

Contains all imported audio files.

elements

Contains all the drawing files. The drawings are organized by folders named like
the layers they are associated with.

environments

Contains the exported palette files that were originally stored at the environment
level in the Harmony Server database structure or the palettes in a Harmony
Stand Alone scene that will be imported later at the environment level in Harmony
Server.

frames

Contains the final frames after a render if you are using the default settings of the
Write node in the Node view.

jobs

Contains the exported palette files that were originally stored at the environment
level in the Harmony Server database structure or the palettes in a Harmony
Stand Alone scene that will be imported later at the environment level in Harmony
Server.

palette-library

Contains scene palettes and scene palette list files.

timings

This folder is used when a user links external images to a scene and wants to
store a backup copy in case the link breaks.

Root Directory and Content Building Scenes
A production is not only composed of the series or movie’s scenes, there are also animatics, backgrounds,
character builds, colour models, references, storyboards, and so on. These elements must be stored somewhere.
Even if you have a structure integrated in Harmony, it is recommended that a root directory be created for your
external elements such as audio clips, bitmap backgrounds, references, and so on. This directory should be
stored on the server or be regularily backed up if you are a single user working on a standalone machine.
The Root directory contains subdirectories which hold such elements as animatics, backgrounds and audio files.
You must create these subdirectories and name them accordingly. For example, store the backgrounds used in
your production in a subdirectory called backgrounds or adventure_backgrounds.
Keeping an organized work structure will give you greater control and ease. You can further improve the
organization by grouping similar elements into categories.

Here is a list of typical subdirectories:
Animatic
Animatic project and movie files can be stored and organized in this folder.
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Backgrounds
Backgrounds can be stored by sequence or episode in the same way that animation scenes are. Create a
subdirectory named Backgrounds and then place a sequence or episode subdirectory inside it. Categorize each
background by episode or sequence.
Designs
Create a Designs subdirectory and split the designs into three categories:
l

Characters

l

Props

l

Effects

Categories for locations and backgrounds can also be added if you are creating the designs using Harmony.
Final Editing
Final Editing projects and renders can be stored and organized in this folder.
Library
The items contained in the library require a high level of organizational structure. The more structured the library, the
faster you will be able to retrieve the items. Categorize the elements using subdirectories, which can be further
subdivided. Categories could include:
l

Characters

l

Props

l

Effects

l

Audio

l

Models

The Library folder should always be stored on the server, even if it is not included in the root directory. A library is
generally shared between all the users working on the production as they will link this library to their Template Library
and reuse its contents.
Models
Create a Models subdirectory and divide it into three categories:
l

Characters

l

Props

l

Effects

You may also need to add categories for the backgrounds and model pack. Note that you only need to create a
Models subdirectory if you are not designing the models in Harmony.
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References
Create a References subdirectory and then categorize according to type:
l

l

Images: These may be any subject from which you can gain ideas and inspiration to help develop your project, For example, if you are producing an 18th-century adventure series, you may have images of period
costumes, buildings, and sailing ships.
Pictures: You can also use photographs of items which may help you produce an accurate account of the
time period in which your production is set.

Render
Create a Render subdirectory and categorize the exported image sequences or clips by scene. For example, you
would have a subdirectory named Render and categories named Scene_001, Scene_002 and so on.
It is also possible to do the following:
l

Create a subdirectory called Render and store your scene’s render in a subdirectory named sequence.

l

Create a subdirectory called Render and store your scene’s render in a subdirectory named episode.

Storyboard
Toon Boom Storyboard Pro projects or storyboard scans can be stored and organized in this folder.
Textures
You can create a bitmap texture bank for pen styles and colour palettes and store all of the files in this folder.

Drawings and Layers
A very important concept to understand in Harmony are drawings, drawing elements, and layers. Layers are also
referred to as columns in traditional animation, but in Harmony, there is a difference between a column and a
layer. A drawing element is a directory containing multiple drawings and is linked to a column in the Xsheet view
and the column is linked to a layer in the Timeline view. The layer and column are generally named the same way
as the drawing element (folder). A layer may also be an effect layer, a peg (motion) layer, etc. It is not always a
drawing layer. A drawing element is the directory containing the drawings that the corresponding layer is linking
to. Many layers can be linked to the same drawing element (folder) so that the same drawings are reused.
In traditional and paperless animation, a drawing element or layer can be a character, for example, level B. In cutout animation, a drawing element can be the hand layer.
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When you add a column or layer to your scene, a node and a folder (element folder) are also added. By default, the
element folder and layer are named the same way as the column. As explained above, the element folder's purpose
is to contain all the drawings related to this column. For example, in cut-out animation, a character can have many
mouths available. All these mouth drawings will be contained in this folder, even if they are not currently exposed in
the scene. In other words, there is always a drawing container hooked to a layer or column, unless that layer is
linked to another drawing element (clone).
You can find the drawing element folders in your scene's subdirectory called elements.

You can add drawing layers from the Timeline view, Xsheet view and the top menu .
In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete a
drawing, it is important to know how a layer works.
Each layer is linked to a column or layer and that column or layer is linked to a directory in which all of its drawings
are saved. This directory has the same name as the layer and column. When a value or drawing name is typed in a
layer’s cell, Harmony looks in the layer’s directory for the corresponding drawing to display. If there is no
corresponding drawing, a new one is created.
New vector drawings are created as *.tvg (Toon Boom Vector Graphic) files.

51

Chapter 6: Project Organization

The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted; it is simply not displayed.

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when you modify, repaint or correct a drawing named “1”, all drawings named “1” are updated simultaneously.
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Libraries and Templates
Harmony allows you to use a library to store and reuse elements such as animation cycles, network effects and
filters, trajectories, cut-out puppets, etc. We call these elements assets or templates. These libraries can be
placed and used on different levels.
Harmony provides some library folders, to which you can add your own libraries. Harmony’s library can be
accessed from any scene opened on the machine.
To store your assets somewhere other than the default location, you can create your own folder on your hard
drive. If you are connected to a network, you can create a folder on the server to be shared with other network
users.
We recommend that you name your library with a relevant project name, such as adventure_library.
The library folders and their templates are completely external to Harmony and can be archived and moved
independently from the production. They can also be sent to other Harmony users.
It is always a good idea to be descriptive when naming your templates (assets). Although not mandatory, it is
highly recommended to use alphanumeric characters:
l

a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues when working on different platforms such as Mac OS X or Linux.
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Library Structure Tips

The following recommendations may be useful as you structure your work. The main library can be divided into
categories to match different template types:
l

Character

l

Background

l

Audio

l

Prop

l

Effect

The character section is often altered the most. It is recommended that you divide this folder between:
l

Main Characters

l

Episode Characters

Within the Main Characters folder, you can create a folder for each individual character. Episode characters are
generally less numerous and can be stored in folders corresponding to their episode. Each character’s folder can be
further divided into subfolders, such as:
l

Model

l

Animation

l

Keyposes

l

Reuse Parts

The Animation section can be organized by actions, such as:
l

Run Cycle

l

Walk Cycle

l

Jumps

l

Miscellaneous

Some users may divide their animation folder by angle or view:
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l

Front

l

Three-quarter

l

Side

l

Three-quarter back

l

Back

Personal Libraries
During the animation process, an animator will often reuse certain templates. Some animators have their own
personal libraries to store their favourite templates. If a template has been updated in the master library, the
Library manager should send a note to the animators and the scene setup team to ensure that they update their
personal libraries.

Naming Convention
When working on large or even small projects, it is best practice to create a naming convention for everyone to
follow. This will help keep the work organized and consistent.

Scene Naming Convention
For improved consistency and ease of use, incorporate naming conventions for your scenes and other project
elements.
l

l

l

We recommend that you name your scene using alphanumeric characters: a to z, 0 to 9 and underscore ( _
).
Avoid capital letters or spaces in the file names.
Try to provide the maximum amount of information for future identification, which helps ensure that you do
not mix up elements and lose information.

For example, you could name a scene adventure_sc001, adventure_scene_01, adventure_
character_models or adventure_seq01_sc002.

Layer Naming Convention
When you create drawing layers, it is recommended to name them instead of keeping the default name. This way,
your work will be organized and it will be easier for another person to work with your data later on.
It is always a good idea to be descriptive when naming a layer. Although not mandatory, it is highly recommended
to use alphanumeric characters:
l

a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues when working on different platforms such as Mac OS X or Linux.
It is highly recommended that you incorporate a naming convention for the layers when building cut-out puppets.
This will be very useful later on.
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We suggest that you:
l

Add one or two letters for the character/prop name before the part name and an “r” for right or an “l” for left to
identify the corresponding character/prop:
l

l

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can add one
or two letters to identify the angle:
l

l

Character Abby’s right arm = ab_r_arm

Character Abby’s right arm, front view = ab_r_arm_f

Instead of using the “r” and “l” markers for the different right and left body pieces, you can use “1” to indicate if
a limb is closer to or farther away from the character. For example instead of r_arm and l_arm, you could have
arm and arm1. The reasoning is that when the character is flipped, it is less confusing to have “1’ as an indicator for a close limb instead of right or left:
l

Character Abby’s closer arm = ab_arm

l

Character Abby’s farthest arm = ab_arm_1

Renaming a Series of Nodes
When you use a blank rigging template, all of the nodes’ names are generic. You will need to add naming
information, such as the character’s name and the angle.
Harmony provides you with a script called Add Prefix or Suffix that allows you to add a prefix or a suffix to a series of
selected nodes at the same time.
How to add a prefix to a series of nodes
1. In the Network or Timeline view, select all of the nodes or press Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS
X).
2. In the Scripting toolbar, click the Add Prefix or Suffix script button.
The Add Prefix or Suffix dialog box opens.
3. Select the Prefix or Suffix option, depending on what you want to add to the element’s name.
4. Type the prefix or suffix information to be added to the node name.
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Puppet Drawing Naming Convention
We recommend that you use a naming convention for your drawings. If you combine all of the angles of a
character in the same breakdown scene, it is a good idea to identify each angle used.
Before drawing the parts in the drawing elements (layers), we recommend that you create a drawing name that
represents the angle used. This will be quite useful during animation and drawing substitution. For example, use
“f” for front, “s” for side, “q” for three-quarter so that the drawing name looks like this:
l

f1, f2, f3, s1, s2, etc.

In the facial feature drawings’ name, you can also add “h” for happy, “s” for sad or any other letter symbolizing an
expression to help regroup the same theme of drawings. For example:
l

l

Happy Mouths:
l

f_h_a,

l

f_h_b,

l

f_h_c,

l

f_h_d,

l

f_h_e,

l

f_h_f,

l

f_h_g,

l

f_h_x

Sad Mouths:
l

f_s_a,

l

f_s_b,

l

f_s_c,

l

f_s_d,

l

f_s_e,

l

f_s_f,

l

f_s_g,

l

f_s_x
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Chapter 7: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will learn about
starting the application, creating scenes, setting the resolution and opening the scenes.

Starting Harmony
You can run Harmony on Mac OS X or Windows operating systems.

NOTE: On Mac OS X 10.10.5 and more recent versions, Harmony and its modules will not start for the first time if your
security is set to Mac App Store and Identified Developers. Change your security to Anywhere or right-click on
Harmony or its modules to open it for the first time only.

How to start
1. Do one of the following:
l

Windows: Start > Programs > Harmony 12.2 Essentials > Harmony Essentials

l

Mac OS X: Applications > Toon Boom Harmony 12.2.1 Essentials > Harmony Essentials

Toon Boom Harmony opens.

Welcome Screen
When you start Toon Boom Harmony, the Welcome screen appears. If a scene is already open, you can display the
Welcome screen by selecting Help > Show Welcome Screen.

The Welcome screen allows you to:
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1. Create scenes
2. Choose the scene resolution
3. Open recent scenes from a list
4. Add or delete a custom scene resolution
5. Open Harmony directly without opening the Welcome screen first.
To display the Welcome screen later on, go to the top menu and select Help > Show Welcome Screen.
6. Open Harmony video tutorials
7. Open the online support page
8. Open scenes by browsing

Accessing the Documentation
How to access the Harmony documentation
1. In the Support section, click on the Get Help

button.

Your default web browser opens to the Toon Boom Support page.
2. From the Support page, under the Learn Toon Boom Software section, click on the Documentation button.
The Toon Boom Help page opens.
3. From the Toon Boom Help page, click on the Harmony Icon.
The Harmony 12.2 Help page opens.
All the Harmony guides can also be opened directly in the software. From the top menu, select Help >
Online Help or press F1.

Creating and Opening Scenes
All scenes created via Harmony Stand Alone are independent and local to the computer. You can create or open a
scene using the Welcome screen or the File menu.
How to create a scene from the Welcome screen
1. In the Name field, type the scene’s name.
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2. To select the scene’s location, in the Location section, click Browse.

NOTE: In general, the scene name should not exceed 23 characters and cannot contain special characters, such as
*&^%!.

3. From the Camera Size menu, select a scene resolution and click Create Scene.

A new scene is created.
How to create a new scene from the File menu
1. Do one of the following:
‣

From the top menu, select File > New.

‣

In the File toolbar, click the New

‣

Press Ctrl + N (Windows/Linux) or ⌘ + N (Mac OS X).

button.

The New Scene dialog box opens.
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2. In the Project Name field, type the scene's name.

3. Select a scene directory by clicking the Browse button.

NOTE: The scene name cannot exceed 23 characters and cannot contain special characters, such as *&^%!.

4. In the Resolution window, select the scene’s resolution and click Create.
A new scene is created.
How to create a scene with a custom resolution
1. Create a new scene from the Welcome screen or from the File menu in Harmony.
2. Set the scene resolution by doing one of the following:
‣

Select a scene resolution from the Camera sizes drop-down menu.

‣

Set a custom resolution by changing the values in the Width and Height fields. This preset will not be
saved.

‣

Add a new resolution to the list by clicking the Add
button. You can delete a custom resolution
from the Resolution list by selecting it, and clicking the Delete
button.

3. In the New Resolution dialog box, fill in the following fields and click Create.

‣

Resolution Name: Name your new resolution.

‣

Resolution: Set the width, height and aspect ratio of the resolution.

‣

Field of View: Set the horizontal fit and vertical fit.

‣

Frame Rate: Type the scene's frame rate per second.
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How to open a scene from the File menu
1. Do one of the following:
‣

From the top menu, select File > Open.

‣

In the File toolbar, click the Browse

‣

Press Ctrl + O (Windows/Linux) or ⌘ + O (Mac OS X).

button.

The Open Scene browser opens.
2. Browse and select the desired *.xstage file.
3. Click Open.
How to open a scene from the Welcome screen
1. In the Recent Scenes section, click Open.
The Open Scene browser opens.
2. Browse and select the desired *.xstage file.
3. Click Open.
How to open a recent scene from the Welcome screen
1. In the Open a Scene section, select a scene from the list.

How to open a recent scene from the File menu
1. From the top menu, select File > Open Recent.
2. Select a scene from the displayed list.

Saving Scenes
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in the title bar
beside the scene name to indicate that the scene contains unsaved changes.
To save the current state of a scene as another scene, you can use the Save As command. The Save As window
prompts you to give a new name and choose a different location to this scene before saving it. This will create a
complete scene directory for the new scene.
It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or parameters to
see which one will work best. Harmony allows you to save a new version of your scene. It is really important to note
that the drawings and palettes are the same between ALL the scene versions. You can modify the timing, effects,
parameters and camera motion, but if you modify the drawings, they will be changed everywhere.
You can also automatically save your work. Refer to the Preferences Guide to learn more about this function.
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How to save a scene
‣

From the top menu, select File > Save.

‣

Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

How to save a scene as a new copy
1. From the top menu, select File > Save As.
2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene a new
name. The name cannot exceed 23 characters.
3. Click Save.
How to save a new version of a scene
1. From the top menu, select File > Save As New Version.
The Save Version dialog box opens.
2. In the Save Version dialog box, type the new version name.
3. Click OK.
How to auto-save a scene
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage Essentials > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the General tab.
3. In the Save section, set the Auto-Save parameters:
‣

Interval (minutes): This is the frequency at which the auto-save takes place.

‣

Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are drawing or
doing anything in the application. If so, Auto-save waits this number of seconds before attempting
another save.

‣

Ask Before Saving: Before performing an auto-save, you are prompted with a message to confirm if
you want to save or not. You can choose to turn off this option.

‣

Enabled: This enables the Auto-save feature. If you do not want the system to automatically save
your work, deselect this option. The auto-save is off by default.

Setting the Scene Length
Once you have opened your scene, you can set its length.
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How to set the scene length
1. From the top menu, select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script automatically sets the scene length to 60 frames and
adds one of each of the following nodes: drawing element, composite, display and write.
You can find the script in the Script Editor window.

You can customize this script to fit your current project needs. This way, you can set the default scene length to any
number of frames you want, or even decide which types of elements and nodes you want to be in your scene when
you create it.
Refer to the Toon Boom Harmony Scripting Guide to learn more about using, creating and customizing scripts.

Adding a Drawing Layer
Now that your scene is set up, you can start adding drawing layers.
How to add a drawing layer from the Timeline view
1. In the Timeline view, click the Add Drawing Layer
(Mac OS X).
The Add Drawing Layer window opens.

2. In the Name field, name your new layer.
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3. Do one of the following:
‣

Click Add to add a first layer and keep the window open to add more layers.

‣

Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

Scene Settings
When you created your new scene, you set up the resolution and the alignment. However, if you want to change
these initial settings later, you can do it using the Scene Settings dialog box. The different Scene Settings options
are separated into four tabs.

How to access the Scene Settings dialog box
1. From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
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Resolution Tab

Parameter

Description
You can select your project’s resolution (camera frame size) from this preset list.

‣ HDTV: High definition television delivers a higher quality image than
standard television (4:3) does, because it has a greater number of lines of
resolution. To take advantage of the superior quality your output device
must be compatible with HDTV technology to make this resolution setting
useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to how
the images will be aligned in relation to the actual scene frame (default 4:3
grid). Note that the camera resolution and the scene frame are not the
same. When working with 12 or 16 field drawing grids, the grid is a different
aspect ratio from the camera frame. When you fit vertically, you fit the
images with the top and bottom of the scene grid.
Resolution Presets

‣ film-1.33: Use this resolution setting for the academy film format that
conforms to the standard 4:3 aspect ratio.

‣ film-1.66: Use this resolution setting for the widescreen film format that
conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to
how the drawing is fit into the scene frame. When working with 12 or 16
field drawing grids, the grid is a different aspect ratio from the camera
frame. When you fit vertically, you fit the images with the top and bottom
of the scene frame.

‣ NTSC: This is the standard analogue television broadcasting system used
in North America and conforms to the North American standards on how
rectangular pixels are displayed for computer and television screens.
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‣ PAL: This resolution works best with the European format for television
and computer screens, as the rectangular pixels are displayed at a
different orientation.

‣ Low: This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality.

‣ Cloud Preview: This is the resolution used by Web Control Center to
create its preview.
Selected Resolution Preset

Displays the selected resolution preset.

Save Resolution Setting

Click the Save Resolution button after you define your new resolution to save it
as a preset.
Displays the pixel dimensions for your project resolution.

Pixel Dimensions

If you decide to type in the pixel dimensions, or use the up and down arrows to
change the pixel increments, you will have to save your custom selection in order
to save it as a new preset. It will then appear in the resolution selection list. It
doesn't modify the current resolution preset.

Aspect Ratio

Displays the ratio between the horizontal and vertical dimensions of the camera
framing. Each resolution setting has a preset aspect ratio that cannot be changed.

Frame per second

Sets the frame rate for your project. The higher the frame rate, for example 30 fps,
the faster the animation will pla. The lower the frame rate, for example 12 fps, the
slower your animation will play. Avoid going under 12 frames per second as your
animation will have a choppy playback. The human eye requires a minimum of 12
frames per second to perceive a fluid animation.
Use these options to define the FOV (field of view) of the camera (angle of the
camera cone) and how the drawing elements (and drawing grid) align to the scene
grid. The drawing grid is always scaled proportionally to a 4:3 ratio (unless you
change the scene alignment), therefore changing the Field of View setting may
not show a visible difference if your project resolution is also 4:3, such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right edges of
the scene grid.

Field of View

‣ Vertical Fit: The camera resolution is set to fit the top and bottom edges of
the scene grid.
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Basic Commands
This table lists the most common commands used in Harmony.
Command

Action

Access Methods

New

Creates a new scene while
closing any scene already open. File > New
The New Scene dialog box
Press Ctrl + N (Windows/Linux)
opens, asking for directory,
or ⌘ + N (Mac OS X).
name, and resolution
information.
Displays the Open Scene dialog
box. Browse your file system for
a scene file.

Open

The Open command is not
disabled when a scene is
opened. You can open a new
scene from the current one and
the previous scene will be
closed.

File > Open
Press Ctrl + O (Windows/Linux)
or ⌘ + O (Mac OS X).

Open Recent

Displays a quick access list to
view and open recently used
Harmony files.

File > Open Recent

Open Recent > Clear

Clears the recently opened
Harmony files list.

File > Open Recent > Clear

Close

Closes the currently opened
scene, but does not close the
Harmony application.

File > Close

Save

Saves all changes made to the
opened scene, drawings,
palettes, and palette lists.

Save As

Saves the current state of a
scene as another scene. The
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Command

Action

Access Methods

Save As window prompts you to
give a new name and choose a
different location to this scene
before saving it. This will create
a complete scene directory for
the new scene.
The scene name cannot exceed
23 characters.
Windows/Linux: File > Quit
Quit

Closes the application.

Mac OS X: Stage Essentials>
Quit

Show Scan Information

Displays a status bar showing
the scanning information at the
bottom of the Drawing and
Camera view.

Drawing View Menu > View >
Show > Show Scan
Information

Cut

Removes selected objects. You Edit > Cut
can then paste the object or its
Press Ctrl + X (Windows/Linux)
properties to another object.
or ⌘ + X (Mac OS X).

Copy

Copies selected objects and
properties.

Paste

Places an object you cut or
copied into the location you
select in the Camera, Drawing
and Timeline views.

Delete

Removes selected objects.

Select All

Selects all drawing objects in the
current drawing window in the
Edit > Select All
Drawing, Timeline and Camera
Press Ctrl + A (Windows/Linux)
views. This helps you manage
or ⌘ + A (Mac OS X).
multiple objects as one when
moving them.

Deselect All

Deselects all selected objects in Edit > Deselect All
the Drawing and Camera views. Esc

Undo

Removes the last change made
to your project. Harmony
supports multiple undo, so you
can undo changes you made in
the order you made them.

Redo

Redoes an operation you have

Edit > Copy
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Harmony 12.2 Essentials - Fundamentals Guide

Command

Action

Access Methods

undone. This command is active
only after you use the Undo
Press Ctrl + Shift + Z.
command.

Help

Launches the Toon Boom
Harmony Online Help system,
complete with instructions on
how to use the system. This
requires an internet connection.

Help > Help

Toon Boom Harmony on the
Web

Launches the Toon Boom
Harmony website, which
features a Support and
Community > Forum section.

Help > Toon Boom Harmony
on the Web

About

Use the About command to
access general information
about the software.

Show Welcome Screen

Brings back the Welcome
screen

Customer Experience Improvement Program

Windows/Linux: Help > About
Mac OS X: Stage Essentials >
About
Help > Show Welcome Screen

Harmony includes an optional
customer experience feature
whereby usage information is
collected and sent to Toon
Boom. The data does not contain any personally identifiable
information and cannot be used
to identify you. The data will consist of a basic hardware description, a project summary and
usage information. This information will only be used for softHelp > Customer Experience
ware improvement purposes, as Improvement Program
well as sharing the information
with third parties for the same
reason.
The customer experience
feature is enabled by default but
is voluntary. If you prefer not to
participate, you can opt out
when you first launch the
software, by using a global
preference, or by a command
line argument.

Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can customize your
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the Preferences dialog
box to set parameters and options.
To learn about the different preferences available, refer to the Preferences Guide.
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How to open the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage Essentials > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
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Chapter 8: Interface Overview
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize your
workspace conveniently. There are a series of views and toolbars you can use as you perform different operations.
Usually, each person has a specific way of working in the interface and prefer particular views and toolbars. In this
chapter, you will learn about the main elements of the interface and how to manage them.

The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.
How to change the interface theme
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences (Mac
OS X) .
The Preferences dialog box opens.
2. Select the General tab.
3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.
4. Restart Harmony.
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This chapter is divided as follows:

Menus
Harmony contains three types of menus from which you can access many commands and options:
Top Menu
The top menu contains most of the commands. Depending on the view you're working in and the element, some
commands are available and others are not. The top menu is always located at the very top of the interface.

The top menu contains the following categories:
•

File

•

Edit

•

View

•

Play

•

Insert

•

Scene

•

Drawing

•

Animation

•

Windows

•

Help

On Mac OS X, there is also a Stage Essentials category that contains the following commands:
•

Preferences

•

About
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•

Quit

View Menu
A view menu contains commands specifically related to that view.
To access a view menu, click the Menu

button in the top-left corner of a view.

A view menu is available in the following views:
•

Colour

•

Function

•

Library

•

Script Editor

Quick Access Menu
A quick access menu lets you open a list of the commands you will use most often.
To access this menu, right-click anywhere in a view.
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Working with Views
The Harmony interface is composed of different views, each one designed for a specific purpose. You can modify
the location of the views by adding a new view as a tab or as a window. You can also swap the location of a view.
When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing or
other type of selection or the option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application unless you deselected the
Automatically Save Workspace option in the Preferences dialog box.
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How to add a view
1. Do one of the following:
‣

Select the view you want to add from Windows > desired view.

‣

In the top-right corner of a view, click the Add View

‣

a view from the list. You can open several instances of the same view except for the Timeline, Tool
Properties, Colour, and Drawing views.

button and select

By default, the view appears as a tab.

How to dock a window
1. Drag a window by its tab and do one of the following:
‣

Drop the window onto other existing tabs to add it to the others.

‣

Drop the window above, below or beside an existing view. When you get close to the edge of a view, a
black rectangle with a blue background appears, indicating where the view will be inserted.
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How to close a view
1. Click the Close View
‣

button.

If there are several tabs in the same view, press Shift and click the Close View
tabs at the same time.

button to close all

How to swap views
1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s tab.
2. When a blue rectangle outline appears showing an available location for the view, release the tab to drop
the view into position. One of three things will happen:
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•

The view becomes a tabbed view.

•

The view becomes a floating window.

•

The view becomes a new docked view.

How to resize a view
1. Place the pointer on the edge of the view to resize.
2. When you see the Resizing

icon, drag the side of the view to the desired size.
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How to temporarily hide a view
1. On the edge of the window you want to hide, click the Collapse/Expand button.
The view is compressed and only the Collapse/Expand button is visible.
2. Click the Collapse/Expand button again to redisplay the view.

Managing the Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also have
their own toolbars which you can move around. You can reposition the toolbars to suit your work style or hide
unused ones.

NOTE: Throughout this section, there may be slight differences between your interface and the illustrations in this
guide. This is because the images are taken from Harmony Premium.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars of the views
that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu updates.
The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If a
toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will move
from the top area to the view.
The toolbars in any of the views can be customized with your favourite tools. Using the Toolbar Manager dialog
box, you can organize different toolbars to suit your working style.
If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to expand
the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to close
Harmony and restart it for the new interface to be displayed. A default set of tools will appear in the toolbar.
However, you can customize the toolbar with the tools that more closely fit your work pattern.

If the default toolbar does not contain the tools you require, you can customize the toolbar.
Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means
that you can change the default set of tools and replace the tools you use less frequently with ones use more
often. This customizing is done through the Toolbar Manager.
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How to show and hide a toolbar
1. From the top menu, select Windows > Toolbars > the desired toolbar.
‣

You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, however, are
not available by right-clicking the toolbar area. You can access the toolbar of any open and active view by
right-clicking in the view's top area or the Windows menu.

How to resize a toolbar
1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.
2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.

79

Chapter 8: Interface Overview

How to move a toolbar
1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar area or
another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse button
and drop the toolbar into position.
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How to customize a view toolbar
1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a new button.
You can also reorder the buttons. Make sure the button you right-click on is active.
2. From the menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click the Right
Arrow
button to switch it to the Toolbar list.
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4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left Arrow
button to switch to the Available Tools list.

5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and click the Up
or Down
buttons to move it to the correct location.

6. Click OK when you are finished.
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How to use enable the Flat Tool Toolbar preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences (Mac
OS X).
2. In the Preferences dialog box, select the General tab.
3. Select the Flat Tool Toolbar option.
4. Click OK.
5. Save your work and close Harmony.
6. Restart Harmony.
The Tools toolbar no longer contains nested tools.

Customizing the Workspace
The Harmony interface is composed of several views. You can customize your workspace to suit your working
style, save it as a new workspace, and load it from the Workspace toolbar.
The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can access
these workspaces, and any others you create, from the Windows menu and the Workspace toolbar.
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep your
workspaces as they are and only save the modifications when you really want to, you must disable the
Automatically Save Workspace option.
The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces. You can save
your workspace as a new version to avoid over-writing the current one. If you do not want to modify the current
workspace, use the Workspace Manager to create another one and then modify that one.
You can also restore modified workspaces to their original default layout if you do not like the current modifications
or inadvertently closed some windows.
How to load a workspace
1. Do one of the following:
‣

From the top menu, select Windows > Workspace > Workspace.

‣

Select a workspace from the Workspace toolbar.
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How to open the Workspace Manager

1. Do one of the following:
‣

In the Workspace toolbar, click the

button.

‣

From the top menu, select Windows > Workspace > Workspace Manager.

How to create a new workspace
1. Open the Workspace Manager.
2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click the Add
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4. Select the new workspace that was created. Click Rename and give it a new name.

5. Select the new workspace and click the Right Arrow

6. Click OK.

85

button to move it to the Workspace toolbar.

Chapter 8: Interface Overview

How to rename a workspace
1. Open the Workspace Manager.
2. Choose the workspace to be renamed from the list.
3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit the
name.

4. Type in the new name of the workspace.
5. Press the Enter/Return key to validate the name.
6. Click OK.
How to disable the Automatically Save Workspace preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage Essentials > Preferences
(Mac OS X) to open the Preferences dialog box.
2. Select the General tab.
3. In the Options section, deselect the Automatically Save Workspace option.
4. Click OK.
The Save Workspace

button appears in the Workspace toolbar.

How to save a workspace manually
1. Do one of the following:
‣

In the Workspace toolbar, click the Save Workspace

‣

You can also select Windows > Workspace > Save Workspace.
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How to save your workspace as a new version
1. From the top menu, select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.
2. Type in a workspace name and click OK.
How to delete a workspace
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow
to the Available Workspaces list.

3. Select the workspace from the Available Workspaces list, then click the Delete
space.

button to move it

button to delete the work-

4. Click OK.
How to show a workspace
1. Open the Workspace Manager.
2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow
to move it to the Workspace toolbar.

button

3. Click OK.
How to hide a workspace
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow
to the Available Workspaces list.
3. Click OK.
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How to reorder workspaces
1. Open the Workspace Manager.
2. In the Workspace toolbar, select the workspace to be reordered and on the Up
move it up or down.

or Down

buttons to

3. Click OK.
How to restore the default workspaces

‣ From the top menu select Windows > Restore Default Workspace.

View References
Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views
available:
•

Camera view

•

Colour view

•

Drawing view

•

Function view

•

Layer Properties view

•

Library view

•

Message Log view

•

Script Editor views

•

Side view

•

Timeline view

•

Tool Properties view

•

Top view

•

Xsheet view
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Camera View
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate, create
animation paths and see your results. You can also move through your symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the display mode, or
go back up your symbols hierarchy.

Light Table

When you have a drawing layer or drawing selected, the Light Table button
button allows you to fade the colours
of the other layers so you can see the current artwork better as you edit with a drawing tool. Note that the light table
does not work when using a layer editing tool, such as the Transform
tool.
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Current Drawing on Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is temporarily displayed
in front of all the other elements. The actual scene is not modified.
Camera Mask

The Camera Mask
button shows or hides a black mask around the scene’s frame to avoid seeing the
unnecessary artwork. This option is handy when you're animating and setting up the scene. It allows you to see
your scene’s composition better.
You can also access this from the top menu by selecting View > Show > Camera Mask.
Safe Area

The Safe Area
button shows or hides the TV safety zone and the centre of the camera frame. The safe area
adapts to the scene resolution, as well as the safety zone and frame’s centre.
You can also access this feature from the top menu by selecting View > Show > Safe Area.
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Outline Locked Drawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) are displayed as wireframes.
Reset View
The Reset View
button resets any panning, zooming or rotation done in the Camera view and returns the display
to the initial settings. You can also press Shift + M.
Zoom Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.
To make the camera frame size always match the size of your view, select the Fit to View option. Click the dropdown arrow and select a zoom level or press 1 and 2.
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OpenGL View Mode

The OpenGL View Mode
button switches the Camera view to fast display, letting you see your animation
play in real time. The OpenGL display requires less memory. The final look of your effects is not shown in the
OpenGL View Mode. You must switch to the Render View Mode to see your effects.
Render View Mode

The Render View Mode
button swithes the Camera view to a fully rendered display showing the final image
of the current frame. If a modification is done to your current frame or if you move to a different frame, click the
Update Preview button to update the display if your preview does not update automatically.The Render View
Mode display lets you see the final look of your frames including effects and antialiasing. You cannot play back
your scene in Render View Mode. To see your scene fully rendered and to play it back, you must press the
Render and Play
button in the Playback toolbar.
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Matte View Mode

The Matte View Mode
button switches the Camera view to a matte display showing the alpha channel of the
elements in your scene. The transparency level ranges from 0 to 100 percent. Zero percent is completely transparent
and represented by black and 100 percent is completely opaque and represented by white. Everything in between
these extremes has a transparency level somewhere between 1 and 99 percent and is represented in various
shades of grey.
‣

To access the Matte View mode, click on the Render View
the drop-down menu.

button and select Matte View

from

Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell does
not contain any drawing, an Empty Cell text is shown in the field.
Tool Name
The Tool Name field displays the name of the selected tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily override a tool by holding its
keyboard shortcut without the [Alt] key. For example, the Select tool shortcut is Alt + S. If you hold down the S key,
you will switch to the Select tool. When you release the key, you will return to the tool you were using.
Frame Number
The Frame Number field displays the number of the current frame.
Selected Colour
The colour swatch displays the currently selected colour in the Colour view.
Camera Toolbar
The Camera View toolbar contains all the tools and options you can use in the Camera view to draw, animate or set
up the scene. The toolbar can be displayed or hidden by right-clicking on it and selecting or deselecting the Camera
View toolbar.
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View Menu
The View menu contains all the tools and options that you can use in the Camera view to draw, animate or set up
the scene.
Editing Stack Menu
The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a symbol.
You can click on the different names to go back up to the different parent symbols or the top/current project.

Colour View
The Colour view is where you create colours and palettes and import existing palettes into your project. The
Colour view is also necessary for drawing, painting and creating colour styling.

The Colour view has two display modes:
•

List mode

•

Swatch mode

How to switch between the display modes
1. From the Colour menu, select Colours > Swatch Mode and do one of the following:
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‣

Select the option to display the swatches.

‣

Deselect the option to display the colour list.

Add Colour
The Add Colour

button lets you add a new colour swatch to the bottom of your colour list.

Remove Colour
The Remove Colour
button lets you delete the currently selected colour swatches. If the colour swatch is used
in your project, the Delete Colour dialog box will appear asking you to confirm the operation.

‣ Click OK to confirm the operation or Cancel to cancel it.
Zones painted with colour swatches which have been deleted will turn red, easily identifying them so you can repaint
them with another colour swatch.

Add Texture
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The Add Texture
button lets you add a bitmap colour swatch to your palette. You can load photos and
textures and paint your drawings with it. The bitmap image must be a .tga or .psd file format.
Set Current Brush Colour
The Set Current Brush Colour
button let you set the currently selected colour swatch as the colour used by
the Brush
tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current Brush
Colour swatch will be updated.
Set Current Pencil Colour
The Set Current Pencil Colour
button lets you set the currently selected colour swatch as the colour used by
the Pencil
, Polyline
, Ellipse
, Rectangle
and Line
tools. If you select a new colour in the
Colour view while using any of these tools, the Set Current Pencil Colour swatch will be updated.
Set Current Paint Colour
The Set Current Paint Colour
button lets you set the currently selected colour swatch as the colour used by
the Brush
tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint
Colour swatch will be updated.
Show/Hide Palette List View

The Show/Hide Palette List View button lets you display the Palette List view in the Colour view. This option is
for the advanced user who wants to create colour palettes for their props and characters.
Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify which colour is
used to paint what part of your character or background.
Two colours can have the same name.
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Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour palettes are
composed of colour swatches. They can also be called colour pots. When you paint a zone with a colour swatch, the
zone is linked to the swatch. So if you update the swatch’s tint, the zone will be updated along with it. This allows
you to modify your animation colours even after it is completely painted.
Colour Menu
The Colour menu lets you access commands related to the Colour view such as creating new palettes, adding new
colour swatches, and displaying the Tint panel.
Add Palette
The Add Palette

button lets you add a new palette to the bottom of your palette list.

Remove Palette
The Remove Palette
button lets you delete the currently selected palette. If the colour swatch is used in your
project, zones painted with colour swatches which have been deleted will turn red, easily identifying them so you
can repaint them with another colour swatch.

Link Palette
The Link Palette

button lets you access other palettes created in the project and link them to your scene.

Order Palette List
The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour styles), the highest
palette is the list will override its clone located lower in the list.
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Drawing View
In Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when it comes to
drawing, there are some differences.
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or the Onion
Skin to display the previous and next drawings of the currently selected drawing layer.

Drawing Area
This is the main space in the Drawing view. It is where you draw and where the drawings are displayed.
Zoom Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.
To make the camera frame size always match the size of your view, select the Fit to View option. Click the dropdown arrow and select a zoom level or press 1 and 2.
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Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell does
not contain any drawing, an Empty Cell text is shown in the field.
Tool Name
The Tool Name field displays the name of the selected tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily override a tool by holding its
keyboard shortcut without the [Alt] key. For example, the Select tool shortcut is Alt + S. If you hold down the S key,
you will switch to the Select tool. When you release the key, you will return to the tool you were using.
Frame Number
This field displays the current frame of the animation you are working on.
Cursor Coordinates
This indicates the position of the your pointer in the drawing area.
Colour Picker
The Colour Picker allows you to select a colour for drawing.

Function View
The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and editing
keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in the
background as a reference.
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How to display functions in the Function view
1. Open the Function view.
The Function view is blank until you select the layer containing the functions you want to display.
2. To display a function in the Function view, click on the layer containing the functions to adjust in the
Timeline view.
3. To select the functions you want to edit, select them in the Function list.

Parameter

Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed.
You can hide the grid, disable the synchronization with the current frame, reset
the zoom level and normalize the function display by stacking them one over
the other to compare them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Interpolation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve,
adjust the segments to motion or stop-motion keyframes and set the velocity
to create steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe.
The more the handle is pulled out horizontally, the slower the animation will be.
The more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section
of a curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can
be referenced to know the current frame of a keyframe.

Layer Properties
Each layer has its own set of properties that can be modified, including effect and peg layers. Display the Layer
Properties editor or view if you want to modify some of the layer’s properties, such as the name or the antialiasing
quality.
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Library View
The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse in
different projects. You can also use the Library view to create and store symbols.
To reuse an element from another project, you must create a template from your drawings. A template is a mini
scene that you import in other projects. A template has no link to the original scene. When you create a template,
the full content of your selection is copied in the template.
You also have the possibility to create symbols. These can be used as drawing containers when you are creating
puppets so you can store different mouth shapes or hands to use while animating. Note that drawing layers
already have this capability without being a symbol. You can also use symbols when you are building props, such
as a skateboard that has a wheel you want to reuse for the four skateboard wheels.
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Library Menu
The Library menu lets you access commands related to the Library view, importing .swf movies and Illustrator files,
add a new folder, and refresh the library’s content.
Preview Window
The Preview window lets you see the content of the currently selected template or symbol in the Template/Symbol
list.
Preview Playback
The Preview Playback button lets you play back the content of the selected template or symbol if it contains more
than one frame. Press the Play
button to play back the preview.
Library Folder List
The Library Folder List displays all the folders linked to the Library view. There are two default folders:
•

Symbols: This folder is the only folder containing symbols. You can organize it by adding subfolders inside.

•

Stage Essentials Library: This is a default folder found on the hard drive in your user documents. This folder
can contain templates, but no symbols.

You can link new library folders to the Library view and organize them with subfolders.
Template/Symbol List
The Template/Symbol list displays the templates or symbols contained in the selected library folder. You can
103

Chapter 8: Interface Overview

display the templates by right-clicking the symbols’ thumbnails and selecting View > Thumbnails.

Message Log View
The Message log view displays information gathered during a render task, such as which frames and at what time
they were each rendered. The view also contains a list of the colour recovery operations.

Script Editor View
Qt Script provides access to many of the functions supported in the interface. With Qt Script, you can automate a
number of Harmony functions to speed the completion of various repetitive tasks. The Script Editor view allows
you to edit existing scripts and create new ones. Refer to the Scripting guide to learn more about scripting with
Harmony.
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Script List
On the left side of the Script Editor view, all existing script files are listed and can be modified in this view. The script
format is JavaScript. Click on a file to display its content in the Script Content window of the view.
Script Content
On the right side of the Script Editor view, the contents of the selected script are displayed and can be edited.
Search Toolbar
The Search toolbar allows you to search a string within the selected script content. You can use the Previous and
Next buttons to navigate through the results.
Verify
This function verifies the syntax of the currently displayed script and lists any error found.
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Save
Once you are satisfied with the modifications made to the script, click Save Changes to save the modifications.

Side View
The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a
scene’s stage from the side. This lets the camera cone and spacing between the elements to be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each element’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.
2. The camera cone represents the camera’s position and field-of-view (FOV).
3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
4. There are two view option buttons displayed in the lower-left corner of the view.
‣

Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣

Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that
lets you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.
7. Displays the currently selected tool.
8. Displays the currently selected frame of your animation.
9. Displays the currently selected colour in the palette.

Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to
become familiar with the Timeline view, how it works, and its interface.
The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and ordering
layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer names, drawings,
keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing name is
displayed when you place your pointer over the drawing’s exposure.

107

Chapter 8: Interface Overview

Enable/Disable All
The Enable/Disable All

button lets you show or hide layers.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view. When a
column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.
To disable a layer, click the layer's Enable/Disable All

button or press D.

To enable a layer, click the layer's Enable/Disable All

button or press A.

Solo
The Solo
button lets you view drawing or sound layers in the Camera view. You can enable this mode on
multiple layers. When the Sole mode button is deselected, everything is visible in the Camera view. When one or
more layers are soloed, only those layers appear in the Camera view.
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Onion Skin

The Onion Skin
button enables the Onion Skin option on a particular layer. If you want to see the previous and
next frames of a specific layer, go to the Timeline view and click the Onion Skin button for that particular layer. Blue
arrows appear on both sides of the play head. Drag the blue arrows to add more frames to the onion skin display.
To activate the general Onion Skin preview, in the Tools toolbar, click the Onion Skin

button.

Lock/Unlock Layer
The Lock/Unlock Layer
button lets you prevent the selection or editing of a layer in the Camera view. To
select some of the layers without selecting others, in the Timeline view, lock the layers you do not want to select.
When a layer is locked, its name is displayed in red.

In the top menu, there is a series of locking options. Select Animation > Lock > select one of the following:
•

Lock: Locks the currently selected element.

•

Unlock: Unlocks the currently selected element.

•

Lock All: Locks all the elements in the Camera view.

•

Unlock All: Unlocks all the elements in the Camera view.

•

Lock All Others: Locks all the elements in the Camera view except the currently selected one.

You can display the locked drawings as outlines in the Camera view to quickly find out which drawings are locked.
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How to display locked drawings as outline
1. In the Camera View bottom toolbar, enabled the Outline Locked Drawings

option.

2. You can also set this option as a permanent preference. From the top menu, select Edit > Preferences
(Windows/Linux) or Stage Essentials > Preferences (Mac OS X).
3. In the Preferences dialog box, select the Camera tab.
4. In the Tools section, select the Show Locked Drawings As Outlines option.
Change Track Colour
The Change Track Colour
button lets you change the colour of the exposed frames; this helps you to quickly
locate a layer in the Timeline view. Click the Change Track Colour
button to open the Select Colour window
and choose a new colour. You can modify the colour for any type of layer, such as group, peg, drawing, and
effects.
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Add Layers
The Add Layers
button lets you add new layers to the Timeline view. When you click the Add Layers button, a
menu appears displaying the layer types available. You can add several different types of layers:
•

Camera

•

Deformation

•

Drawing

•

Generator

•

Group

•

Transformation

•

Effects

•

Sound

Delete Layers
The Delete Layers

button lets you delete the currently selected layers in the Timeline view.

Add Drawing Layer
The Add Drawing Layer
button lets you automatically add a new drawing layer to the Timeline view. By default,
the layer is named Drawing.
Add Peg
The Add Peg
button lets you add a peg layer to the timeline. If several layers are selected, a peg is added and
parented to each layer.

Expand/Collapse
The Expand/Collapse
button is used to display the children layers of a parent layer. Once a layer is parented to
another layer, it is indented to the right and the Collapse/Expand Children button appears on the parent layer allowing
you to show or hide the child layer.
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Parameters
The Parameters section lets you add, remove or modify a keyframe at the current frame. You can show or hide
the Parameters section by clicking the Show/Hide Parameters
button.

Icon

Tool Name

Tool

Add Keyframe

Adds a keyframe at the current frame.

Delete Keyframe

Removes an existing keyframe at the current
frame.

Hand Cursor

Lets you change the current keyframe or drawing exposure. When you hover the cursor over
the value, the hand cursor appears. Drag left
or right to change the value. Or double-click
on the keyframe value and enter a new value.

Previous Keyframe
Next Keyframe
Show Function Menu

Lets you navigate through existing keyframes.
Displays the Function menu where you can
link a layer to an existing function or create a
new function—see Function Curves on page 1.

Current Drawing and Frame
The highlighted drawing represents the drawing currently displayed. The red play head represents the current
frame displayed and marked in the Playback toolbar. You can move the play head to the left or right to scrub
through frames and update the Camera view.
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Keyframe
A black or red square is displayed in the Timeline view when a keyframe exists. You can select these keyframes
and drag them wherever you want on the timeline. You can also copy, cut, and delete them.

NOTE: To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select the keyframe
to be deleted and then select Animation > Delete Keyframe from the top menu or press F7.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be displayed.
Split
The Split
button lets you split the Timeline view in two sections, allowing you to see two different portions of the
Timeline view. This way, if your scene length is very long, you can see the beginning and the end at the same time.

Drawing Exposure
In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is exposed for
several frames, the block is extended. When a second drawing is exposed, a new grey block is displayed.

The exposure’s colour can be changed. To pick a new colour, click the Change Track Colour
corresponding layer.

button in the

View Modes
The View Modes
button lets you streamline the process of working with elements in the Timeline view. There
are three different view modes you can choose to work in. With each mode you select, certain elements may or may
not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding elements when
you want to focus on specific ones. To select a view mode, use the drop-down menu in the bottom-left corner of the
Timeline view.
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Show/Hide Additional Links
The Show/Hide Additional Links
button lets you display links associated with a layer. For example, if you
connect a mask to more than one effect such as a Tone and a Highlight, you can see these connections in the
Additional Links section.

Zoom
The Zoom tool increases or reduces the width of the frames in the Timeline view. Move the slider right to increase
the width or left to reduce it. You can also press 1 and 2. Reset the zoom by click the Reset Zoom button.

Show/Hide Functions
The Show/Hide Functions
button lets you display the functions embedded in each layer. The functions are
the different coordinates and values used to record a layer’s parameters at each frame. This information is stored
on the function curves using keyframes.

Tool Properties View
The Tool Properties view contains the most common options and operations related to the currently selected tool.
When you select a tool from the Tools toolbar, the Tool Properties view updates.
For example, if you choose the Select tool, the Tool Properties view will display the options and operations
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.
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Top View
The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the
scene’s stage from above. This lets the camera cone and the spacing between the elements be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each element’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.
2. The camera cone represents the camera’s position and field-of-view (FOV).
3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
4. There are two view option buttons displayed in the lower-left corner of the view.
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‣

Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣

Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that
lets you see all of the scene layers and information in the Perspective view at once.

6. Displays the currently selected layer and drawing name.
7. Displays the currently selected tool.
8. Displays the currently selected frame of your animation.
9. Displays the currently selected colour in the palette.

Xsheet View
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows the
drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s function
columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black squares in the
Timeline view. The Xsheet view contains more detail than the Timeline view, and is faster and easier to read.
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1. Xsheet Main Section
The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing layers, also
known as drawing columns.
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When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear
in the main section. Unconnected functions mean that some motion paths are not attached to any particular layer.
When you reconnect functions to a layer, they are still visible in the main section.

2. Functions Section
The Functions section is used for more advanced techniques. This section displays the functions (paths) related
to the selected layer in the Timeline view. By default, the Functions section is hidden.

How to display the Functions section
1. In the Xsheet view, click the Expand button located on the right side of the main section. Click on the
same button to collapse it. You can also use the Show Column List
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button in the Xsheet View toolbar. If you select a drawing column in the main section of the Xsheet view,
the function columns will not be displayed. You must select the layer from the Timeline view.

3. Column List Section

The Column List section allows you to show and hide columns in the Xsheet view. When you hide a layer in the
Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type (drawing or function) from the
Xsheet view. By default, the Functions section is hidden.
How to display the Column List section
1. In the Xsheet view, click the Expand button on the right side of the main section to show the Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the
Xsheet toolbar.
‣

In Harmony, you can also go to the Xsheet view menu and select View > Show Column List.
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2. Click the Expand button on the right side of the Functions section to display the Column List section.

Xsheet Toolbar
The Xsheet view has its own toolbar where you can find the most common features. This toolbar is displayed by
default. If you do not see it, select Windows > Toolbars > Xsheet View.
The Xsheet view must be part of your workspace in order to display its toolbar.
Column Header
Each column available in the Xsheet view has a header displaying the column’s name. The column’s name is the
same as the corresponding timeline layer. If you rename one or the other, they will both be renamed.
A quick access menu is available when you right-click. This menu contains the command affecting an entire
column such as renaming, changing the default colour, or deleting a column.
The tooltip that appears when you hover at the top of each Xsheet column shows the folder path to the source
drawings for that column.
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In Harmony, the column header shows the layer’s name and the name of the drawing folder to which it is linked. If
the name of the layer is the same as the drawing folder, the drawing folder’s name will not be displayed. To modify
the name of the element folder independently from the column and layer name, you must select the Advanced
Element Mode option preference in the Advanced tab of the Preferences dialog box.

Current Drawing
A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing and Camera views.
The current drawing selection is not linked to the drawing displayed in the Camera view since drawings from each
visible layer are displayed at once.

Current Frame
The darker frame appearing in the Xsheet view represents the current frame.

Drawing Exposure
In the drawing columns, you can see the drawing names and their exposure. You can use any alphanumeric symbol
to name your drawing. When a drawing is exposed over more than one cell, a vertical black line is displayed to
indicate the continuity of the exposure. When there is no drawing in a cell, the cell will be blank.
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Frame Numbers

On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These read vertically
instead of being displayed horizontally as they are in the Timeline view.
•

To go to a particular frame, click the frame number.

•

To select an entire range of frames, click and drag a selection downwards.

Current Frame Display
At the bottom-right of the Xsheet view, you can see the current frame number, as well as the column containing
the drawing currently displayed in the Drawing view.
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Functions Column
The functions columns are displayed in the Functions section of the Xsheet view. They represent the motion and
rotation you applied to a drawing layer.
A function column can also be related to an effect. Selecting the effect layer shows you the corresponding function
column in the Xsheet view.
The function columns display the position value or effect value on each cell. If there is a keyframe on a cell, a black
square is displayed. Holding the same value for several frames displays a vertical black line.

Increase/Decrease Exposure
You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down arrows in the
Increase/Decrease Exposure field.

Overwrite/Insert Modes
The Overwrite/Insert button allows you to decide the way the values are inserted into the Xsheet.

Toolbar References
Harmony has several toolbars. There are two types of toolbars: the top toolbars available at the top of the interface
and the view toolbars in individual windows. View toolbars are only shown if the particular view is displayed in the
workspace. This is a complete list of the toolbars available in Harmony.

Top Toolbars
Advanced Animation Toolbar
The Advanced Animation toolbar contains tools to position and animate layers. The Scale, Translate and Rotate
tools can be used to reposition the permanent pivot position of a layer. Unlike the Transform tool, each tool in the
Advanced Animation toolbar performs a single operation, either rotate, scale, translate or scale in relation to the
camera distance.
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Deformation Toolbar
The Deformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is
displayed in the default interface.
By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and select
Customize, you can add additional buttons.

Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These options can also
be found in the Edit menu.

File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options can also be
found in the File menu.

Playback Toolbar

The Playback toolbar lets you play back animation and sound. Use it to scrub the sound to create your lip-sync,
loop the playback, navigate through frames, and change the playback range and speed.
Name

Button

Description
Plays and stops the animation.

Play

You can also select Play > Play Scene
Forward or Stop.
Creates a render of your scene to play back
the final result including the effects.

Render and Play

Repeatedly plays back your animation
indefinitely.

Loop

You can also select Play > Loop.
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Enables sound in the playback.
Sound
You can also select Play > Enable Sound.
Enables sound scrubbing in the playback.
Sound Scrubbing

You can also select Play > Enable Sound
Scrubbing.

Jog Frames

Lets you scroll through the playback’s frames.
Lets you change the playback frame range by
entering new values in the Start and Stop
fields. You can also click on the Start and
Stop words to set the start or end frame at the
current frame.
Lets you enter a new value to change the
speed of the playback.

FPS

Scripting Toolbar
The Scripting toolbar lets you import and access the scripts created to automate actions and operations.

Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Harmony. In the default workspace, you
will find this toolbar on the left-most side of the interface.
Workspace Toolbar
The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the
Hand-Drawn Animation and Compositing workspaces; these display different views and toolbars. You can access
these workspaces and any you create, from the Windows menu and the Workspace toolbar.

View Toolbars
Here is a list of the toolbars available in the Harmony views:
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•

Camera Toolbar

•

Drawing Toolbar

•

Layer Toolbar

•

Library Toolbar

•

Script Editor Toolbar

•

Timeline Toolbar

Interface Navigation
Toon Boom Harmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.
Command

Action

Access Methods
View > Zoom In

Zoom In

Zooms in the view.

Press 2 or roll the mouse
wheel up.
In the Timeline view, roll the
mouse wheel up.
View > Zoom Out

Zoom Out

Zooms out the view.

Press 1 or roll the mouse
wheel down.
In the Timeline view, roll the
mouse wheel down

Zooms in or out of the view.

Roll the middle mouse button
up or down.

Pan

Moves parallel to the view.

Hold down the Spacebar and
drag n in the direction in
which you want to pan the
view.

Recenter view

Recenters the view on the pointer.

Press N

Resets the view’s pan to its default
position.

View > Reset Pan

Reset Pan

Zoom In or Out

Press Shift + N
View > Reset View

Reset View

Resets the view to its default position. Press Shift + M

Reset Rotation

Resets the view’s rotation to its
default position.

Reset Zoom

Resets the view’s zoom to its default
position.
Enlarges the selected view to full
screen which is done in three stages.

Toggle Full Screen

View > Reset Rotation
Press Shift + X
View > Reset Zoom
View > Toggle Full Screen

Press Ctrl + F
First, the selected view enlarges to the (Windows/Linux) or ⌘ + F
maximum width or height, but keeps
(Mac OS X)
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the tool views such as Colour or Tool
Properties view.
Second, the view enlarges to full
screen.
Third, the view returns to its original
size.
Rotate 30 CW

Rotates the Camera view 30 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW

Rotates the Camera view 30 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

Use the Magnifier tool to quickly
center on the mouse position and
zoom in to a pre-defined value such as
4X. Then you can zoom out again.
Hold the Shift key and press Z to zoom
in and back out again. Replace the
Reset Zoom by pressing Shift +.
Toggle Quick Close-up
The area where you zoom in or out is
dependent on the pointer location in
the Camera view. If you zoom in and
then move the pointer to a different
location when you zoom out the
mouse will be centered on that
location.

Using the Play Menu to Navigate
From the top menu, you can select any of the following commands from the Play menu to navigate around the
interface.
Command

Description

Start Frame

Lets you set the frame on which playback will start.

End Frame

Lets you set the frame on which playback will end.

First Frame

Jump to the first frame. You can also press <.

Previous Frame

Jumps to the frame before the frame currently selected in the Timeline view. You
can also press the comma (,) key.

Next Frame

Jumps to the frame after the currently selected frame in the Timeline view. You
can also press the period (.) key.

Last Frame

Jumps to the last frame. You can also press >.
Opens the Go to Frame window in which you can enter the number of the frame
you want to display.

Go to Frame
You can also use the Go button, which you can add to the Timeline toolbar
through the Toolbar Manager. Open the Go to Frame dialog box and enter the
127

Chapter 8: Interface Overview

frame number to jump to.
Enable Playback

Plays back your animation from the Top or Side views.

Zoom Tool
The Zoom

tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

•

The keyboard shortcuts are 1 and 2.

•

When you're in Zoom In mode, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Parameter

Button

Description

Zoom In

Zooms in

Zoom Out

Zooms out

Zoom Tool Options
Zoom in the Camera or Drawing view.
Perform Zoom In
The keyboard shortcut is 2.
Zoom out the Camera or Drawing view.
Operations

Perform Zoom Out
The keyboard shortcut is 1.
Reset Zoom

Restores the current zoom level to 100%.

Reset View

Restores the original display by resetting any
pan, rotation or zoom actions.
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Glossary
3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a threedimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without an
alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The storyboard panel is exposed
for the duration of the scene and at times, the characters are placed on a trajectory to
indicate motion. The camera moves are also animated. The animatic is used to determine
the rhythm of a project and provides a good overview of the project before beginning
production.

animation

A simulation of movement created by displaying a series of pictures or frames.

anime

An animation style known for its sinister and dark feel; popular in Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or situation
from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).
In animations that constantly rotate, the axis element specifies what axis the object rotates
around. A negative number causes an animation to rotate counter clockwise whereas a
positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A Bézier
curve is a mathematical or parametric curve. Bézier curves use at least three points to
define a curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it will
lose definition and individual pixels will begin to appear. This is known as pixelation.
Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.
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breakdown

In cut-out animation, breakdown is the action of breaking a character into pieces to create a
puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next, the
joints are fixed and the pivots set.
In traditional animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help describe the motion and the rotation curve (usually referred
to as an arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on the
road.

caption

A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet on which the
animation is inked and painted before being sent to the camera. The picture's outline is
drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of
distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up

After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and shot.
The clean up process refers to either tracing a clean line over a rough drawing to achieve the
final version or removing dirt and extra lines left by the scanning process.

CMYK

Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used in a
process called offset printing.

colour card

A colour card is a card containing one solid colour that is the same size as the camera. The
colour card fills the background with a solid colour when there is no background image
included.

colour model

The official colour design that must be used to paint the animation. A model is the definitive
character, prop or location design that each artist must follow for the production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to create the final result
prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them correctly.
The artist will then set the camera frame and animate it, if needed. Finally, the animator will
create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there are no transition effects
inserted to pass from one scene to the next. The first scene ends and the second one starts
immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out of
several pieces by moving them around frame by frame. Cut-out animation can either be
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computer generated or done traditionally using paper.
cycle

A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to track the sequence and timing
of images, dialogue, sound effects, sound tracks and camera moves. Also known as an
exposure sheet.

doping

To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above this
line giving the appearance of a bounce.

DPI

Dots per inch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease

In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Also known as slow-in.

ease-out

Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening. For
example, if a child is playing on the ground in front of his house, the establishing shot would
be a scene where the viewer can see the house, the ground, a part of the street and the
buildings around the central point of action. This helps the viewer understand the story
location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.
The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in occurs
when the first scene appears progressively, from complete transparency to its complete
opacity. A fade out occurs when the last scene progressively disappears, going from
complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

A measurement unit used to calculate motion, registration and camera positioning. A
standard animation scene will vary between 6 to 12 fields.
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field chart

A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.

film-1.33

A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66

A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of an animation
sequence very quickly in order to see the animation in motion. Flipping can also be the
action of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a cloak
is running. The main action is the body running. This will cause the cloak to follow the
motion, although it will not move at the same time, but react a few frames later and follow
the main motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.
frame

An animation frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe the
standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.
This is the measurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer graphics,
video cameras, film cameras, and motion capture systems.
Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories and
effects parameters can be attached. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

Acronym for High Definition Television which delivers a higher quality image than standard
television because it has a greater number of lines of resolution. To take advantage of the
superior quality and make full use of your resolution setting, the output device must be
compatible with HDTV technology.

hold

A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn to create fluid transitions
between poses.

ink and paint

The ink and paint process is the action of painting the empty zones and colouring the lines
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on the final animation drawings, while following a colour model.
interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics
(IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy. Inverse
kinematics will animate a puppet from one of the extremities, such as a hand, and make the
rest of the body follow naturally.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is generally
caused by one scene ending, and a second one starting, with a similar image. The lack of
difference causes the eye to see a little jump between the two scenes.

key pose

Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are the main drawings in an animation sequence describing
the motion. For example, if an arm is waving, the keys will be of the arm at one extremity of
the wave motion and the other extremity. By flipping those drawings, the animator can see
the skeleton of the motion without having all the drawings.

keyboard
shortcuts

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe

Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer

In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is the action of
putting the storyboard on model. That is, drawing the character by following the design in the
model pack, so the animator can start working.
The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start
working.

layout artist

The artist who draws the background, and creates the camera and field guide to match the
scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the animation
and executing the initial stages of it.

layout process

The communication step between the storyboard and the animation.

library

A storage area containing templates and assets that can be reused in any project or scene.

light table

A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action

The direction that the action will follow. Also known as path of action.

lip-sync

The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.

low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
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video file take precedence over quality. A low-resolution image is one that lacks fine detail.
manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this process,
both sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing
substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the entire
production to maintain consistency in the look and to ensure that the same colours are used
throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production. A
colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in different
projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is used
to represent silence) used for lip-sync.

multiplane

The effect of passing through multiple levels of drawings to create a sense of depth in a
shot. A multiplane is a scene in which the layers are placed at different distances from the
camera so that when the camera moves, a depth illusion occurs. With a multiplane, all the
perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge

A small push (left, right, up, down, forward or backward) done with the keyboard arrow keys
on a selected element. Nudging is used to move a selection very slightly and precisely.

onion skin

A feature that lets you see the previous and next drawings of a sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is placed in front of the main
animation.

PAL

A resolution that works best with the European format for television and computer screens,
as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and avoid
the colour changing during the animation. Also referred to as a master palette.

palette style

A palette style is a second version of an existing palette with a slight change in the tint and
value. A palette style can be used to create the night version of a palette. It may also be
called a clone palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
panels.

paperless
The paperless animation process is the action of animating digitally. The main paperless
animation/tradigital animation process is to draw, frame by frame, the animation directly in the software.
passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.

134

Harmony 12.2 Essentials - Fundamentals Guide

path of action

Direction that the action will follow. Also known as line of action.

peg

In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you can
use peg layers. Peg layers are trajectory layers that do not contain drawings. They are
motion paths that you can use to add path articulations. For the latter, you can also use an
inverse kinematics tool.

phoneme

A unit of sound in a language.

pivot

The point around which a peg or drawing rotates.

pixel

The smallest element of an image displayed on a monitor or TV screen.
Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small section made out of smooth filtering. If you zoom
in close enough on a digital image, you will see the pixels, which look like small squares of
different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The secondary
poses are called breakdown. Finally, the animator fills the gaps with the in-between
drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as adding motion
blur before it produces a final image. The process of calculating the final images after the
compositing process.

resolution

The size of a scene, generally calculated in pixels. For example, the NTSC resolution is 720
x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue. A method of defining colour by specifying amounts of these three colour
components.

rigging

The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace for
greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame by
frame, for use in animated films. The act of sketching over live-action footage to create an
animated sequence.

roughs

Rough is a common name in an animation movie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.
The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines and
shapes, but can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped by the TV frame.
As a TV frame cuts a margin off the original frame size, maintaining a safe area ensures that
the scene's main action will remain clearly visible once the film is screened on television.

scene

A shot in a movie or show. A sequence is composed of several scenes. A scene changes to
another scene by a simple cut or transition.
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script

The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.

sequence

A series of scenes or shots forming a distinct part of the story or movie, usually connected
by unity of location or time.

shot

A scene in a movie or show. A sequence is composed of several shots. A shot changes to
another shot by a simple cut or transition.

slow-in

The gradual acceleration in the action. Also known as ease-in.

slow-out

The gradual deceleration in the action. Also known as ease-out.

slugging

To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion
keyframe

A keyframe with no computer-generated interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The storyboard indicates what will
happen, when it will happen and how the objects in a scene are laid out.

straight-ahead
animation

A technique in which an entire sequence is drawn from the first position to the last, in order.
There is very little planning in this methodology. Where the character ends up and how it
gets there can be a surprise for both the audience and the animator. While this approach is
spontaneous and creative, it can create inaccurate results.

strokes

Invisible vector lines forming the drawing zones. They can be adjusted with Bézier handles.

symbol

A symbol combines animation, artwork or layers into a single object that you can control in
one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet or
create reusable animations such as blinking.

tablet/pen

A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

template

An asset stored in the library that can be reused in any project. A template can be a drawing,
a series of keyframes, a sound file, a panel, a cut-out character, an effect, a trajectory, an
animation, or anything else used in the animation.

thumbnail

A very small image used as a reference or indicator.

timecode

The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.

timeline

A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional

A type of animation process whereby all the animation sequences are drawn by hand on
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paper before scanning or inking them on cels.
trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoid making innumerable
drawings, animators routinely make a walk cycle for a character.

zone

An area which can be painted with colour.
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arc 129

View menu 94

arcs of rotation 33

Zoom menu 91

area, safe 90

caption 130

Cloud module 11

aspect ratio 66, 129

cel 130

Harmony 9

audio

celluloid

about

Play module 10

dubbing 18

Stage 10

editing 18

adding
views 75
Advanced Animation toolbar 123
alpha channel 129

recording 16
auto-feed 129
auto-save
disabling on workspaces 86
axis 129

animation 129

background 129

animation principles 31
anticipation 32

character
design 15
styling 16
character design 130

animatic 16, 129

principles 31

See cel. 130

clean up 130
clockwise

background styling 16
Bezier 129

rotating 127
closing
views 76

bitmap graphics 37

CMYK 130

arcs of rotation 33

advantages, disadvantages 38

colour card 130

concepts, traditional 37

image types 37

colour model 130, 134

exaggeration 35

bitmap images 129

follow-through 33

breakdown 130

pose-to-pose 32

sound 17

colour palettes 38
switching display modes 94
Colour view 94

secondary actions 34

broadcast standards 40

slow-in, slow-out 34

camera mask 90

colour wheel 130

solidity 35

camera shake 130

commands

squash and stretch 31

Camera toolbar 93

straight-ahead 32

Camera view 89

timing 31

camera mask 90

switching palette display modes 94

basic 67
compositing 130
conventions, naming 54

Camera View toolbar 93

layer 54

cut-out 21

current drawing on top 90

puppet drawings 56

paperless 20

Editing Stack menu 94

renaming modules 55

traditional 19

light table 89

scene 54

animation types 19

animation workflows 13

Matte View mode 93

counterclockwise

post-production 17

OpenGL view mode 92

pre-production 13

outline locked drawings 91

production 17

Render View mode 92

scenes 58

anime 129

resetting view 91

scenes from File menu 59

anticipation 32

safe area 90

scenes from Welcome scene 58
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scenes with custom resolution 60
workspace, new 84
cross dissolve 130
current drawing on top, Camera view 90
custom resolution
creating scenes 60
customizing
toolbars 81
cut 130
cut-out animation 21, 130
workflow 28

final 18

Function view 99

Editing Stack menu 94
editors

displaying functions 100
functions 132

Layer Properties 101

displaying 100

establishing shot 131

gamut 132

exaggeration 35

graphics, bitmap and vector 37

exposure 131

advantages, disadvantages 38

exposure sheet 131

bitmap image types 37

traditional 40

vector image types 38

fade-in 131
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fade-out 131

dark style 71

cycle 131

field chart 132

file structure 47

dark style interface 71

field of view 66

interface 71

Deformation toolbar 124

custom 66

modules 9

deleting

horizontal fit 66

starting 57

workspace 87
dialogue 131
display

vertical fit 66
file structure 47
drawings and layers 50

Harmony Server
dark style 71
interface 71

workspace 87

File toolbar 124

distribution, master 19

film-1.33 65, 132

HDTV 65, 132

documentation

film-1.66 65, 132

HDTV_Vertical 65

film-1.66_Vertical 65

Help

accessing 58

starting 57

dope sheet 131

final editing 18

Harmony 5

doping 131

flat toolbars 78, 83

structure 5

DPI 131

flipping 132

drawing layers

follow-through 33, 132

views temporarily 78

format 44

workspace 87

adding 63

hiding

Drawing view 98

forward kinematics 132

Hold 132

drawings

FOV (field of view) 66

HSV 132

current drawing on top 90

custom 66

in-between 132

outline locked drawings 91

horizontal fit 66

ink and paint 132

vertical fit 66

interface 71

dubbing 18
ease 131

fps 66

ease-in 131

frame 132

interpolation 133

ease-out 131

frame rate 44, 132

jump cut 133

editing

frames per second 66

key pose 133

full screen 126

keyboard shortcuts 133

audio 18

dark style 71
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keyframes 133
Layer Properties editor 101
layers 133
adding drawing layer 63
naming convention 54
layout 133

mouth

onion skinning 134

chart 134

OpenGL

moving

view mode 92

toolbars 80
multiplane 134
traditional animation 43

opening
scenes 58
scenes from File menu 61

layout and posing 133

multiplane camera 43

scenes from Windows screen 61

library 52, 133

naming convention 54

Workspace Manager 84

personal 54

layer naming 54

organizing

Library view 102

puppet drawings 56

drawings and layers 50

light table 133

renaming modules 55

files 47

scene naming 54

projects 47-48

Camera view 89
line of action 133
lip-sync 133
auto detection 129
lip-sync detection
manual 134
loading
workspace 83

navigating

outline locked drawings 91

centering screen on mouse 127

overlay 134

full screen 126

PAL 66, 134

panning 126

palettes 134

Play menu 127

colour 38

recentering view 126

style 134

resetting pan 126

switching display modes 94

location design 15

resetting rotation 126

panel 134

looping

resetting views 126

panning 126, 134

playback 124

resetting zoom 126

resetting 126

low resolution 66, 133

rotating clockwise 127

manual lip-sync detection 134

rotating counterclockwise 127

mask

zooming in 126

passing position 134

zooming in or out 126

path of action 135

zooming out 126

pegs 135

camera 90
master distribution 19

paperless animation 20, 134
workflow 26

master palette 134

network 43

traditional animation 42

Matte View mode 93

node system 43

pen 136

menus 72

nodes

phoneme 135

Editing Stack 94

Cloud 11

picture element 45

View 94

Harmony 9

pipeline

Zoom 91

Play 10

Toon Boom 9

Message Log view 104

renaming 55

pivot 135

model 134

Stage 10

pixel 45, 135

model sheet See character design

NTSC 65, 134

motion keyframe 134

nudge 134

dimensions 66
pixelation See bitmap image
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Play menu 127
Play module
about 10
Playback toolbar 124
FPS button 125
Jog Frames button 125
Loop button 124
Play button 124
Render and Play button 124
Sound button 125
Sound Scrubbing button 125
playing back 124
fps 125
jogging frames 125
looping 124
rendering and playing 124
sound 125
sound scrubbing 125
pose-to-pose 135
post-production workflow 17
pre-production
workflow 13
preferences 69
disabling auto-save workspace 86
flat toolbars 83
Preferences dialog box 69
principles, animation 31
anticipation 32
arcs of rotation 33
exaggeration 35
follow-through 33
pose-to-pose 32
secondary actions 34
slow-in, slow-out 34
solidity 35
squash and stretch 31
straight-ahead 32

timing 31

film-1.66_Vertical 65

product requirements
Harmony 7

HDTV 65
HDTV_Vertical 65

production steps 23

Low 66

projects

NTSC 65

content building scenes,
organizing 48
drawings and layers, organizing 50
organizing 47
resolution 65
root directory, organizing 48
prop

PAL 66
presets 65
restoring
workspace, default 88
RGB 135
rigging 135
root directory 48

design 15
styling 16

rotary table 135
rotating

puppets

resetting rotation 126

naming convention 56
recentering

rotating clockwise 127
rotating counterclockwise 127

view 126

rotoscoping 135

renaming

roughs 135

nodes 55

safe area 90, 135

workspace 86
Render View mode 92
rendering 135
reordering

saving
auto-saving scenes 62
scenes 61
workspace manually 86

workspace 88
resetting

Scene Settings dialog box 64
scenes 45, 135

Camera view 91
pan 126

auto-saving 62
creating 58

rotation 126
views 126
zoom 126
resizing

creating from File menu 59
creating from Welcome scene 58
creating with custom resolution 60
file structure 47

toolbars 79
views 77

naming convention 54
new scene startup script 63

resolution 135
film-1.33 65
film-1.66 65
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opening from File menu 61
opening from Welcome screen 61

Index •

saving 61
scene length, setting 62
setting length 63
settings 64
script 136
Script Editor view 104
scripting
toolbar 125
Scripting toolbar 125
scripts 14

swapping

Workspace 125

views 76

tools

switching

Zoom 128

workspace 83
system requirements
Harmony 7

Tools toolbar 125
Top view 115
trace and paint 136

tablet 136

track breakdown 136

technical specifications

tradigital 134

Harmony 7

traditional animation 19, 136

templates 52, 136

colour palettes 38

thumbnails 136

concepts 37

scrubbing 136

timecode 136

exposure sheet 39-40

secondary actions 34

timeline 136

file structure 47

new scene startup 63

sequences 136

traditional 41

frame rate and format 44

settings

usage 41

multiplane 43

scene 64
shot 136
Side view 106

Timeline view 107

network 43

timing 31

pegs 42

scene length 63

slow-in 34, 136

Tool Properties view 114

slow-out 34, 136

toolbars 123

scenes 45

slugging 136

Advanced Animation 123

solidity 35

Camera View 93

sound

customizing 81

breakdown 17

Deformation 124

scrubbing 136

Edit 124

squash and stretch 31

File 124

Stage 10

flat 78

about 10
standards
broadcast 40
starting

project organization and file
structure 47

timeline 39
timeline usage 41
timeline, traditional 41
timing 39
workflow 23
Xsheet usage 41
trajectory 137
transition 137

hiding 79
managing 78
moving 80
Playback 124

Harmony 57

resizing 79

ToonBoomProductName 57

Scripting 125

stop-motion keyframe 136

showing and hiding 79

storyboard 15, 136

Tools 125

straight-ahead 32, 136

top 123

strokes 136

view 125

underlay 137
vector 137
vector graphics 37
advantages, disadvantages 38
images types 38
velocity 131, 137
View menu 94
view modes
Matte 93
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OpenGL 92

deleting 87

Render view 92

disabling auto-save 86

views 74

displaying 87

adding 74-75

hiding 87

Camera 89

loading 83

closing 76

managing 83

Colour 94

renaming 86

Drawing 98

reordering 88

Function 99

restoring default 88

hiding temporarily 78

saving as new version 87

Library 102

saving manually 86

managing 74

showing 87

Message Log 104

toolbar 125

recentering 126
resetting 126

Workspace Manager
opening 84

resizing 77

Workspace toolbar 125

Script Editor 104

Xsheet view 116

Side 106

usage 41

swapping 76

zone 137

Timeline 107

Zoom menu 91

Tool Properties 114

Zoom tool 128

Top 115

zooming

Xsheet 116

in 126

walk cycle 137

in or out 126

Web Control Center

out 126

about 11
Welcome screen 57

resetting zoom 126
Zoom tool 128

workflows
animation 13
cut-out animation 28
paperless animation 26
post-production 17
pre-production 13
production 17
traditional animation 23
workspace
creating new 84
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