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Chapter 1: Compositing - An Introduction
Once the ink and paint is done, the animation completed and the timing locked, you are ready to move on to
compositing. This includes different components, such as the elements' positioning, scene resolution, trajectories,
camera moves, effects and filters, and so on. During compositing, you are working with computer-generated effects
done with Harmony's many effect nodes. You can create many types of interesting effects and then customize it to
suit your animation style.
It is during the compositing phase that the three animation workflows merge together. Whatever your chosen path,
they all end up in the same animation, together in the same scene. However, the cut-out compositing can be a bit
more complex due to the advanced networking of the different puppets.

Topics in this section:
•

Import on page 7

•

Library on page 49

•

Scene Setup on page 73

•

Path Animation on page 107

•

Sound on page 151

•

Effects on page 173

•

Export on page 193
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Chapter 2: Import

Toon Boom Harmony allows you to import external content as well as being able to draw directly in the software.
This means that characters, backgrounds and videos created in other drawing, painting and multimedia programs
can be brought in and animated. You can import QuickTime videos, pictures, multilayered .psd files, as well as .ai,
.swf, .pdf, and .fla files. You can also scan images and import them as bitmap or vectorize them.
This chapter contains the following topics:
•

Importing Bitmap Images on page 7

•

Importing PSD Files as Separate Layers on page 11

•

Importing QuickTime Movies on page 34

•

Creating Custom Vectorization Parameters on page 35

NOTE: For sound import, refer to Importing a Sound File on page 151.

Importing Bitmap Images
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Images can come in many different file formats and are usually saved in a format that retains the original
specifications set by the image creator. Some formats can preserve the transparency or transparent layers, while
others are not resolution dependent due to their vector nature. Toon Boom Harmony supports the following
formats: JPEG, BMP, PNG, TGA, PSD, TIFF, SGI, TVG, OMF, PAL, SCAN.
When importing images and 3D models and linking images, the settings are saved in your user settings.
In this section, you will cover the following topics:
•

Importing a Bitmap Image Without Vectorization on page 8

•

Importing and Vectorizing Bitmap Images on page 9

Importing a Bitmap Image Without Vectorization
How to open the Import Images dialog box
1. Do one of the following:
‣

From the top menu, select File > Import > Images.

‣

In the File toolbar, click the Import Images

‣

In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

button.

The Import Images dialog box opens.

How to import a bitmap image in its original format
1. In the Files section of the Import Images dialog box, click Browse to find and select one or more images
on your computer.
2. Decide if the bitmap image will go on a new layer or an existing layer. To add the bitmap image to a new
layer, go to step 3. To add the bitmap image to an existing layer, go to step 4.
3. Add the bitmap image to a new layer by selecting the Create Layer(s) option and one of the following
options and then proceed to step 5:
‣

Create Single Layer Named: Creates a layer you can name.
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‣

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has two
drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

4. Select the Add to Existing Layer option to place the bitmap image on a layer you select from the list. If only
vector layers are available in your scene, they will not be displayed in the list.
5. Click OK.

Bitmap Image Quality
If the bitmap images that you imported look blurry or slightly pixelated, you can clean up the image by changing the
quality of the preview in the Camera view. It will not affect the final render.
How to change the bitmap image quality
1. In the Camera view, double-click on the bitmap image to enter its symbol if the image is encapsulated or
simply select the bitmap image layer in the Timeline view if it's not.
2. Do one of the following:
‣

From the top menu, select View > Bitmap File Quality.

‣

Press Ctrl + Q (Windows/Linux) or ⌘ + Q (Mac OS X).

The Bitmap Image Quality dialog box opens.

3. Drag the slider to the right to improve the quality.
4. Click OK.
5. If you are inside a symbol, go to the top of the Camera view and click Top to exit the symbol and return to
your scene.

Importing and Vectorizing Bitmap Images

You can turn bitmap images into vector drawings, while maintaining the sketchiness of a pencil line or into vector
images with a bitmap fill. Both options can add life to an animation, which straight vectorization with smoothing does
not usually afford.
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How to import and vectorize a bitmap image
1. Do one of the following:
‣

From the top menu, select File > Import > Images.

‣

In the File toolbar, click the Import Images

button.

The Import Images dialog box opens.

2. Click Browse to locate images.
3. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing
layer.
‣

Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter

Description

Create Single Layer Named

Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example,
the filenames a-1.tga, a-2.tga and b-1.tga will create layers named
"a" and "b", where "a" has two drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

‣

Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.
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‣

Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap images
with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol and vice
versa. Symbols will also be automatically added to the Symbol folder in the Library view.

4. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.
5. In the Vectorization section, decide whether you want to import your image in colour, black and white, grey,
or if you want to add a new preset.
‣

Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

‣

Grey: Vectorizes your image as a mix of vector contour and greyscale bitmap filling. Lines keep the
texture from the scan, and the white of the paper becomes transparent.

‣

New Preset: The New Preset
button lets you create custom vectorization parameters via the
Vectorization Parameters interface.

NOTE: The vectorized images are painted with the Vectorize Line colour swatch from the colour palette.

6. Click OK.

A symbol or new layer contains the vector drawing. For images contained in a symbol, double-click on the
image’s first cell in the Timeline view to enter the symbol so you can edit the image.

Importing PSD Files as Separate Layers
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PSD files (a format exportable exclusively from Adobe Photoshop) are unique in that they are able to retain
multiple layers. This is advantageous as the image remains fully editable in terms of any colour correction,
effects, masking, transparency, or compositing that were made to the .psd file in Adobe Photoshop.

NOTE: Note that your .psd image file must be set to RGB mode within Adobe Photoshop prior to being imported
into Harmony.

How to import the separated layers of a .psd file
1. In Adobe Photoshop, organize your file so that all your layers are “grouped” into individual folders, or that all
the elements you want to import as a single layer in Harmony are grouped together in their own folder. Any
layer that is not in a folder group, by itself or otherwise, will not be imported.

1. In Harmony, go to the top menu and select File > Import > Images or click the Import Images
The Import Images dialog box opens.

2. In the Files section, click Browse to find and select the .psd image on your computer.

12

button.

Harmony 12.2 Essentials - Compositing and Effects Guide

3. In the Layer section, select the Create Layer(s) option, then select one of the following options:
‣

Create Single Layer Named: Creates a layer you can name.

‣

Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has two
drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

4. In the Import Options section, select one of the following:
‣

Keep As Original Bitmap: Retains an imported image as a bitmap. In the Alignment section, decide on
the size and placement of your image within the camera frame. Depending on the Scene Settings (the
height and width in pixels that you chose for your project), an image that you import may get scaled to the
point where all its individual pixels become visible. There are three options available in the Alignment
section:

Parameter

Description
Enlarges or shrinks (but not distorts) the image height to match the full height of
the scene grid.

Fit

If the image orientation is landscape, this will enlarge or shrink (but not distort) the
image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.
Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
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image’s height will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer
properties.
Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.
Project Resolution
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Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.
‣

Import As Bitmap Drawing: Imports a drawing into a vector layer where you can edit the image using the
drawing tools. In the Alignment section, select one of the following:

Parameter

Description
Enlarges or shrinks (but not distort) to your image height to match the full height of
the scene frame (alignment grid).

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full width of
the scene frame (alignment grid).

Horizontal Fit

Actual Size

‣

Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

Convert to Toon Boom Vector Drawing: Imports a drawing and converts it to a Toon Boom vector
drawing. In the Vectorization section, select one of the following:
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Black and White: Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.
Grey: Vectorizes the image as a mix of vector contour and greyscale bitmap filling. Lines keep the texture
from the scan, and the white of the paper becomes transparent.
New Preset: Lets you create a new preset.
Delete Preset: Lets you delete any preset in the list.
Custom vectorization: Lets you set custom vectorization parameters—see Creating a Vectorization Style
on page 43.
5. Decide whether to select Vectorize Imported Items option.

NOTE: If you decide to use the Vectorize Imported Items option, see Importing and Vectorizing Bitmap Images on
page 9 to learn more about vectorization settings.

NOTE: If you disable the Vectorize Imported Items options, the Transparency and Alignment settings will appear in
place of the Vectorization settings—see Importing a Bitmap Image Without Vectorization on page 8.

6. Click OK.
The Multilayer Image Import Settings dialog box opens.

7. From the Create menu, select one of the following:
‣

Single Layer: To import the Camera and Layout layers merged together.

‣

Separated Layers: To keep your Camera and Layout layers separated.

8. From the Transparency menu, select one of the following if applicable:
Parameter

Description
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Premultiplied with White

Individual pixels at the edge of an image are blended with white.

Premultiplied with Black

Pixels at the edge of an image are blended with black.

Straight

Pixels at the edge of an image are blended with black, white and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the colour is
clamped to the alpha, the colour value cannot be higher than the alpha value. It
calculates the real colour value faster. When the RGB values are multiplied
with the alpha value, that is to say, if you have a pixel of value R=247, G=188,
B=29 and the alpha is 50% or the image has a 50% transparency, then the
actual RGB values that are output would be half of the amounts listed above.

9. Click OK.
Your image appears as separate layers in the Timeline view, corresponding to the PSD layer group folders.

NOTE: The artwork displayed in every one of your layers as a result of a multilayer PSD file import is linked to the
same source image. This means that if you use the Drawing > Delete Selected Drawings command to physically
delete the drawing from the project folder, the exposed drawing will be deleted in all layers at once. Once deleted
from the project folder, the image cannot be retrieved unless you reimport your psd file.

Exporting a Layout
Before exporting a layout, all the elements must be well positioned. For example, if you plan to include a camera
movement in this scene, you should also set this up, as you can export the camera keyframes to generate a clear
and complete layout.
You can also create all the layouts for your production in the same Harmony project which can be imported later on
when you start each scene’s project. This will help set up the scene and begin its creation. You can use the layout
.psd files to create the background art of each scene and make sure everything is correctly framed and at the right
size. Finally, you can also have a layer with a drawing of the rough poses of the character or action and generate
your layout posing from there.

NOTE: Because the layout image is one static .psd file, only the first frame of your drawing layers will be exported—
see Scene Setup on page 73 and Path Animation on page 107.

How to export your scene as a layout
Before exporting your scene as a layout, position your background elements, and everything you need as a
reference in your scene, including a camera movement.
1. From the top menu, select one of the following:
‣

File > Export > Layout Image to export all the elements in your scene to the layout .psd file.

‣

File > Export > Layout Image from Selection to export only the selected elements.

The Export Layout Image dialog box opens.
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2. In the Export Layout Image dialog box, set the export parameters:
Parameter

Description

Destination Path

Use the Browse button to select a location to save your layout and name the
resulting .psd file.
File Pattern: Automatically puts the name of the scene and/or the frame number in the name of the file you create.

Image Size

The size of the .psd image file that will be exported. The resulting image will be
72 dpi as the standard television resolution and its size in pixel will fit your
scene resolution settings. i.e HDTV, NTSC, PAL, etc. Note that if you have a
camera movement going over the normal camera frame limit, for example a
pan, the image will be bigger.
File Format: Lets you select the format to export your layout.
Export Camera Frame: This option is disabled by default. You can enable it
to export an additional layer to your .psd file displaying the camera frame on it.

Options

Add a Camera Frame for Each Keyframe: This option is disabled by default,
meaning that if you have a camera movement with more than a starting and an
ending point, only these positions of the camera frame will appear on the
camera layer of the exported layout .psd file. You must enable this option if you
need to the in-between keyframes to also be displayed.
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Label Camera Frame: Adds the camera position label in the top corner of the
camera frames. The camera label is a single alphabet letter determining the
order of the camera frame position.

Expand Render Area: This option is disabled by default, meaning the layout
image will take the complete PSD area, cropped at the very edge of the
canvas. You can enable this option to add a transparent area all around the
layout. You must setup the size of this area by using the Scale field lower. The
resulting image will be larger.

Scale Image: Sets the size of the transparent border around the layout image.
By default the value is set to 100% to export the image as is with no
transparent area around it. Increase the percentage value to add the extra
around the image to create the border.
Maximum Size: This option is enabled by default, meaning that when you
have a camera zoom movement, the size of the layout image will be adjusted
accordingly. The resulting percentage will be calculated following the maximal
camera zoom value appearing in the layout. This allows the image to be
exported at an appropriate resolution, preventing the layout image from
appearing pixelated or blurry when the camera zoom occurs. You can disable
this option to export the image layout at the normal size.
Vector Options
If you export one or more vector-based drawing layers in your layout image,
you have the option to export only the drawing layers you want. Enable or
disable the following options to export or prevent the export of the
corresponding art layers.
Overlay: Exports the art in the Overlay layer of the drawings to be exported to
the layout image.
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Line Art: Exports the art in the Line layer of the drawings to be exported to the
layout image.
Colour Art: Exports the art in the Colour layer of the drawings to be exported to
the layout image.
Underlay: Exports the art in the Underlay layer of the drawings to be exported
to the layout image.
3. Click OK to validate the settings and export a .psd file of your layout.
The resulting image is a .psd file with one or two layers, each of which is contained in a corresponding
group. These groups make the layout .psd file ready for a multilayer .psd import.

The Camera_Set group contains the camera drawing layer. If you selected the Export Camera option, this
group and layer appear in your layout image.

The Layout_Set group contains a merged drawing layer of all the content of your scene’s first frame when
you exported the layout image.

NOTE: An .xli file is exported along with your .psd file. This file contains all the necessary information for correctly
importing and automatically positioning your layout image in a Harmony project. Do not delete the .xli file or
rename it. Also, always keep it at the same location as the layout .psd file.

20

Harmony 12.2 Essentials - Compositing and Effects Guide

Scanning Images

Toon Boom Harmony can receive images from any TWAIN device such as scanners and digital cameras. These
images can either be loaded into your scene as bitmaps or converted into vector- based images that can be edited
using Toon Boom Harmony.
If your operating system does not automatically recognize your device after it has been connected, you must install
the correct TWAIN drivers in order to access its contents. You can usually download the drivers from the device
manufacturer’s website.
How to open the Scan Drawings window and set your scanner
1. From the top menu, select File > Import > From Scanner.
The Scan Drawings window opens.
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2. In the Scan Drawings window, select your scanner or other supported TWAIN device from the Scanner
menu. If none are available, check your device to ensure that it's properly connected to your computer. If
your device still does not appear in the menu, you may have to shut down and restart the software.
How to scan an image in its original format
1. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing
layer.
‣

Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter

Description

Create Single Layer Named

Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example,
the filenames a-1.tga, a-2.tga and b-1.tga will create layers named
"a" and "b", where "a" has two drawings and "b" has one. When creating a single layer from these three filenames, all three drawings will
be inserted in the new layers.

‣

Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.

‣

Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.
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2. In the Import Options section, select the Keep As Original Bitmap option.
3. In the Alignment section, decide on the size and placement of your scanned image within the camera frame.
Depending on the scene settings (the height and width, in pixels, that you chose for your project), an image
that you scan may be scaled to the point where all its individual pixels become visible.
Parameter

Description
Enlarges or shrinks (but not distorts) the image height to match the full height of
the scene grid.

Fit

If the image orientation is landscape, this will enlarge or shrink (but not distort) the
image width to match that of the scene grid.

Note that the Fit alignment rule equals the Center Fit rule in the layer properties.

Pan

This is the opposite of the Fit parameter. If the image orientation is portrait, its
width will be made to match the width of the scene grid. As a result, part of the
image’s height will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or from left to right to
make it appear as if the camera is panning or to actually perform a camera pan.
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The opposite will apply to a landscape image. Its height will be fit to the scene
grid, therefore it is possible that the image will extend beyond the scene grid's
boundaries.

Note that the Pan alignment rule equals the Center First Page rule in the layer
properties.
Scales the image in proportion to the scene's resolution. The system looks at the
resolution of the bitmap image, for example 4000 x 2000, then compares it to the
scene's resolution, for example 1920 x 1080, and adjusts the scale factor in
proportion. So, in this example, the bitmap would appear at 208% (4000/1920). If
you import a bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

Project Resolution

Note that the Project Resolution alignment rule is equal to the As Is rule in the
layer properties.
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4. In the Drawing Options section, set the following options if desired:

‣

Drawing Name: Name of the drawing to import.

‣

Hold Value: Type the number of frames that the drawing will be exposed.

‣

Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣

Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

6. Click Scan to scan your drawing.
7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.
How to scan an image as a Toon Boom bitmap drawing
1. In the Import Options section, select the Import as Toon Boom Bitmap Drawing option.
2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer.
‣

Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter

Description

Create Single Layer Named

Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, the
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and
"b", where "a" has two drawings and "b" has one. When creating a
single layer from these three filenames, all three drawings will be inserted in the new layers.

‣

Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.
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‣

Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

3. In the Alignment section, decide on the size and placement of your scanned image within the camera
frame. Depending on the scene settings (the height and width, in pixels, that you chose for your project),
an image that you scan may be scaled to the point where all its individual pixels become visible.

NOTE: Make sure you're in the Camera view’s Render mode when judging an imported image, otherwise it may
appear blurry.

The following three Alignment Rules options are available:
Parameter

Description
Enlarges or shrinks (but not distort) to your image height to match the full
height of the scene frame (alignment grid).

Vertical Fit

Enlarges or shrinks (but not distort) to your image height to match the full width
of the scene frame (alignment grid).

Horizontal Fit

Actual Size

Scales the image in proportion to the scene's resolution. The system looks at
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the resolution of the bitmap image, for example 4000 x 2000, then compares it
to the scene's resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would appear at 208%
(4000/1920). If you import a bitmap that is 960 x 540, it will be displayed at 50%
(960/1920) of the size of the project resolution.
4. In the Drawing Options section, set the following options if desired:

‣

Drawing Name: Name of the drawing to import.

‣

Hold Value: Type the number of frames that the drawing will be exposed.

‣

Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣

Flip Drawing: Mirrors the drawings horizontally and scans it this way.

5. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

6. Click Scan to scan your drawing.
7. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to capture your next frame.

8. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.
How to scan an image and convert it to a Toon Boom vector drawing
1. In the Import Options section, select the Convert to Toon Boom Vector Drawing option.
2. In the Layer section, decide if the scanned or imported image will be placed on a new layer or existing layer.
‣

Create Layer: Scans or imports the image into a new layer. Select one of the following options:

Parameter

Description

Create Single Layer Named

Creates a layer you can name.

Create Layer(s) Based on Filenames

Creates a layer based on each unique filename prefix. For example, the
filenames a-1.tga, a-2.tga and b-1.tga will create layers named "a" and
"b", where "a" has two drawings and "b" has one. When creating a
single layer from these three filenames, all three drawings will be inser-
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ted in the new layers.
‣

Add to Existing Layer: Scans or imports the image into an existing layer. Select a layer from the Layer
list. You must scan into the same layer type if you're using an existing layer.

‣

Create Symbol for Acquired Items: Encapsulates the bitmap image in a symbol. To mix bitmap
images with vector drawings on the same layer, the bitmap image must be encapsulated in a symbol
and vice versa. Symbols will also be automatically added to the Symbol folder in the Library view.

3. In the Vectorization section, decide whether you want to import your image in black and white or grey.

Parameter

Description

Black and White

Vectorizes drawings as a solid black line; creates a 100% vector-based drawing.

Grey

Vectorizes your image as a mix of vector contour and greyscale bitmap filling.
Lines keep the texture from the scan, and the white of the paper becomes transparent.

1. In the Drawing Options section, set the following options if desired:

‣

Drawing Name: Name of the drawing to import.

‣

Hold Value: Type the number of frames that the drawing will be exposed.

‣

Scan and Advance: Lets you scan one drawing after another every time you click Scan.

‣

Flip Drawing: Mirrors the drawings horizontally and scans it this way.

2. Adjust the Scale control and sliders in the Preview Image window until you are satisfied with the view.

3. Click Scan to scan your drawing.
4. If you are scanning panoramic drawings, in the Page Panning section, move the slider to the next letter to
capture your next frame.
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5. If you have more than one drawing, set the next drawing in place and click Scan again. Repeat until you have
finished scanning all your drawings.

Importing AI and PDF Files

You can import AI (Adobe Illustrator) and PDF files into Toon Boom Harmony to convert your files to the Toon Boom
format (TVG) and create a colour palette based on the colour settings of the original file.
When importing AI and PDF files:
•

RGB is supported, CMYK is not.

•

Gradients and textures are not supported.

•

Only legacy versions of Adobe Illustrator are supported. Exported SWFs, including Actionscript 2 and
Actionscript 3, cannot be imported.

•

When importing an Illustrator or PDF file in Toon Boom Harmony, by default the file will be imported as
separate layers. The import will use the Illustrator file's top level groups as separate layer names. However,
you can change this behaviour by deselecting the PDF/Illustrator Import as Separate Layers option, to import
your file as a single layer .

How to import an AI or PDF file
1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you will
not be able to import files.

NOTE: For more information, refer to the Library chapter in the Cut-out Animation Guide.
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2. Do one of the following:
‣

In the top menu, select File > Import > SWF, Illustrator Files to Library.

‣

Right-click on any unlocked folder and select Import Fi les.

The browser window opens.
3. Find and select your AI or PDF file in the Import Files dialog box and click Open.
The Rename dialog box opens.

4. Type in a name for the new template or keep the name of the original AI or PDF file.
5. Click OK.
A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy
cursor

appears before releasing the folder.

The message window opens.
7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option if you
plan to import multiple .ai or .pdf files.
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The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the imported
file’s name.

NOTE:
To learn about the Support CMYK in PDF/Illustrator Import option, refer to the Preferences Guide.

Importing SWF Files
You can import .swf files in Harmony that were published using any version of Flash Player, up to version 14. Note
that some effects may not appear when imported in Harmony.
How to import a SWF file
1. In the Library view, right-click on the Stage Library folder and select Right to Modify to unlock the library
folder. Make sure the Lock icon disappears from the folder. If not, your library will remain locked and you will
not be able to import files.

NOTE: For more information, refer to the Library chapter in the Cut-out Animation Guide.

2. Do one of the following:
‣

In the top menu, select File > Import > SWF, Illustrator Files to Library.

‣

Right-click on any unlocked folder and select Import Fi les.

The browser window opens.
3. Find and select your.swf file from the Import Files dialog box and click Open.
The Rename dialog box opens.
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4. Type a name for the new template or keep the name of the original *.swf file.
5. Click OK.
A new template folder is created in the Library view.
6. Drag the new template folder from the Library view to the left side of the Timeline view. Wait until the copy
cursor

appears before releasing the folder.

7. The colour recovery dialog box appears, requesting that a colour recovery should occur. Before clicking
the Yes button, you have the option of selecting the Do Not Ask Again For This Session option. This
might be useful if you plan to import multiple *.swf files.

The colour palette used to create the .ai or .pdf file is imported and a new palette is created under the
imported file’s name.
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NOTE: All the Flash layers are automatically attached to a parent peg called GlobalFlashPeg. DO NOT DELETE
THIS PEG. To maintain the look of your movie, it's important not to delete this peg or detach its child layers.

The Adobe Flash file layers appear in the Timeline view. Symbols that were created in Flash become regular
drawing layers, but can be reconverted into symbols in Harmony. Symbols within symbols or drawings within
symbols collapse into their corresponding parent symbol.

NOTE: Some layers in your .swf movie may be combined in a single layer as a result of optimization enhancements
in your movie file. You can easily move these elements back onto separate layers.

In addition, all drawing elements that are dynamically linked to the Toon Boom Harmony file are grouped
together in one folder. In our example, this means that when you scroll through the Drawing Substitution
preview in the Library view, the different hand, leg, tentacles, antennae, torso and facial positions are all
organized together.

Redistributing Elements
In some instances, due to an optimization enhancement in the exported SWF file (CS4), some of the layers might be
combined as a single layer. If so, you can quickly redistribute these elements onto individual layers again.
How to distribute to layers
1. In the Tools toolbar, click the Select

tool.

2. In the Camera view, select the drawing that contains elements you want to redistribute onto individual layers.
To select the all the elements of the selected drawing layer, press Ctrl + A (Windows/Linux) or ⌘ + A (Mac
OS X).
3. Do one of the following:
‣

From the top menu, select Drawing > Distribute to Layers.

‣

In the Tool Properties view of the Select tool, click the Distribute to Layers

button.

The number of drawing layers corresponding to the different grouped elements are created in the Timeline
view. The selected elements in the original drawing layer are removed. Each element is distributed onto a
new drawing layer.
4. Repeat the process for each drawing that contains elements to redistribute.
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Importing QuickTime Movies

When creating an animation, it is not unusual to embed moving elements saved as videos within the animation.
Toon Boom Harmony allows you to import QuickTime movies into your project.
How to import a QuickTime movie
1. From the top menu, select File > Import > Movie.
2. Browse for the QuickTime movie to import and click Open.
The Import Images dialog box opens.

NOTE: Do not browse for the movie file again. Leave the automatically generated field text as “many files
selected”.
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3. Make your decisions for the Layer, Alignment and Transparency sections of this dialog box—see Importing a
Bitmap Image Without Vectorization on page 8.
4. Click OK.
The QuickTime video appears in the Timeline view as an image sequence. You can scroll through the film
frame-by-frame just as you would scroll through your animation drawing-by-drawing.

Creating Custom Vectorization Parameters
You can create your own vectorization settings with Harmony. The vectorization parameters you create can be
saved, shared and also inserted into the VectOptions.conf file used by the Scan and Control Center modules
when scanning or vectorizing a series of drawings.
You can use an interface to select and test the different options, as well as type in some advanced settings.
The Vectorization Parameters dialog box lets you vectorize pencil drawings, along with any red, blue or green pencil
marks you may have used to indicate highlights and shadows. The drawing will be vectorized into pure red, blue,
green and black (RGB values), while creating colour art zones wherever lines connect. After painting in your tones
and highlights, change your pure RGB colours to transparent (0 Alpha) in the Colour Picker window and watch the
indicator colour zone lines disappear.
How to open the Vectorization Parameters dialog box
1. From the top menu, select File > Import > From Scanner.
You can also open it from any other import option that allows you to customize the vectorization parameters
(i.e. from the scanner).
2. In the Scan Drawings window, do the following:
‣

In the Layer section, decide on the layer options.

‣

In the Import Options section, select the Convert to Toon Boom Vector Drawing option

‣

Click Preview.
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3. In the Vectorization section, click the Vectorization Parameters

button.

The Vectorization Parameters dialog box opens.

•

Options Tab on page 36

•

Help Tab on page 38

Options Tab
The Options tab contains the main vectorization settings. More settings are available in the Help tab.

Parameter

Description
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The input filters are applied to the bitmap image before it is vectorized.
One Pass: One threshold value is applied to both the Line and Colour Art. For
drawings with distinct vector-style lines of mattes, you only need one pass.
Two Passes: Applies a different threshold value to each layer. For greyscale
drawings, you may want to perform the vectorization process twice to apply different threshold values to the Line and Colour Art layers.
Input

Threshold: Determines which values in the scanned image are considered
part of the Line or Colour Art layer and what will be eliminated from the
vectorized drawing; 0% is white and 100% is black. The threshold is between
these two values.
Expand Bitmap: Lets you enter a value to scale the bitmap to detect small
variations in the line. Use this option if you scanned a greyscale image and
want to preserve small variations in the texture to apply to the line art.
Jag Filter: Lets you enter a value to scale back the bitmap to remove some of
the line’s roughness. This is useless when you have a drawing that appears
quite rough; the Jag filter will eliminate excess strokes in the final drawing.
The output filters are applied during the vectorization process.
No Colour Art: Does not generate filling zones in the Colour Art layer.

Output

No Texture: Does not generate texture in the Line Art layer in the final images.
Select this option to create solid lines in the final line art.
Generate Matte in Underlay Layer: Creates an opaque zone behind your
drawing’s lines to avoid seeing through the layers.
Colour as Texture: Converts colour values into a texture layer.
The optical registration options are used to automatically align drawings based
on the position of the peg holes on the animation paper. The peg holes must
appear in the scanned drawings for the optical registration to work.
DPI: Lets you enter the dots-per-inch value of your image. You must enter the
same value as the DPI used to scan the image.

Optical Registration

Peg Side: Lets you select the position of the peg holes on your drawings.
Identify whether they are on the top, bottom, left or right.
Strictness: Determines how exact the location of the peg holes must be for the
software to recognize them. There are two values to choose from:
•

Strict: The peg holes must be in a tightly defined area to be recognized.

•

Loose: The peg holes can be recognized somewhere in a larger area.
This is the recommended setting.

Field Chart: Lets you indicate the size of the animation paper, 12 or 16.
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The Post Processing filters are applied to the final vector images.
Remove Holes: Removes holes of a specified value that might make painting
difficult.
Post Processing

Remove Dirt: Removes stray marks and dirt of a specified value. Try a value
around 500.
Remove Hair Size: Removes small strokes that have no line art.
Remove Hair: Number of Passes: The number of times the drawing will be
analyzed to identify hair marks.
Close Gaps: Closes gaps in the Colour Art so you can paint it.

Miscellaneous

Smooth Passes for Line Art Before Breaking Triangles: The number of
times the smoothing operation runs before creating the triangles that break
lines in the drawing. If unnecessary triangles are appearing in the drawing,
increase this value.
Smooth Passes for Line Art: The number of times the smoothing operation is
performed after the triangles have been created. This further smooths the line
art.

Preview

Show Strokes: Shows the strokes in the Vectorized Image panel.
Stroke Thickness: Shows the size of the strokes.

Help Tab
The Help tab contains the most advanced vectorization settings which you type in the Advanced Option fields at
the bottom of the Vectorization Parameters dialog box.

File IO Options
-file <filename (including extension)> [ options ]
-infile <filename (including extension)>; same as -file
-outfile <filename>; alternate output file
-informat <format>; the input format. Used if reading from stdin
-debug; turn on debug mode
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-noforce; don't force output if image is inconsistent
-version; print version information and quit
-output_version <version>; output files of this version. Valid versions can be: 0 or 604
-force_unamed_palette_for_texture; will generate a texture in TVG's internal palette

Registration Options
-register <dpi side strictness>; perform optical registration.
•

Side can be one of left, right, top, bottom or l, r, t, b.

•

Strictness can be either loose, strict or l, s.

-register_center_peg_holes; will use only round holes in 16 fields page
-rcph; short form of register_center_peg_holes
-registration_looseness_factor <factor>; registration looseness factor (default 2.000000)
-rlf; short form of registration_looseness_factor
-rdebug; output registration debug messages
-pegpitch <inch (default 8.000000)>; distance between peg bars
-threshr < (default 0.500000)>; threshold for optical registration; range 0.0 to 1.0
-rmargin <inch (default 1)>; region size where to look for peg bars
-peg_distance_from_center <inch (default 5.25)>; peg distance from centre of the image
-pdfc; short form of -peg_distance_from_center
-out_peg_position <side (default same)>; wanted position of the peg on the drawing.
•

Can be one of right, left, top, bottom (or r, l, t, b) or same.

•

A rotation will be performed if it is different from the side passed to -register.

-output_peg_matrix; output the peg transformation matrix on standard output.
-scanner_calibrate; < (default 1.0000 1.0000) > x and y scale factors to be applied to scanner image.

Filtering Options
-pixel <pixel_shape (default '4x3')>; Valid values: 4x3
-gap <worldUnits (default 10)>; close gaps up to this big
-pencil; generate line art only
-keep_dirt; don't filter out dirt
-thresh <threshold (default 0.2)>; range 0.0 to 1.0
-rmv_hairs <worldUnits (default 1)> <passes (default 1)>
•

remove hairs of size smaller than "size" in "passes" passes

-rmv_holes <area (default 7)>; remove holes smaller than "area"
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-rmv_dirt <area (default 1)>; remove dirt smaller than "area"
•

try values between 100 and 500 for rmv_holes and rmv_dirt. The area is in world units squared

-rmv_triangles <worldUnits (default 30.000000)>; remove triangles at "pixels"
•

distance from each other. Use -no_break to remove all triangles

-no_texture; don't generate textured strokes
-color_as_texture; will vectorize the alpha channel and put the RGB colour in a textured colour
-noclosegap; disable all gap closing algorithms
-no_break; disable the breaking of line art
-jag_filter <pixels (default 0>; expand the pixels in the vectorization bitmap
-expand_bitmap <pixels (default 0>; expand the pixels in the vectorization bitmap
-fit_errorc <error (default 1.000000>; fitting error for the colour art
-fit_errorl <error (default 1.000000>; fitting error for the line art
-smoothl <passes (default 1>; number of smooth passes for line art
-smoothc <passes (default 1>; number of smooth passes for colour art
-first_smooth <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothl <passes (default 0>; number of smooth passes for line art before breaking triangles
-first_smoothc <passes (default 0>; number of smooth passes for line art in colour art pass (needs -2pass)
-2pass; specify two sets of parameters; one for line art "l", one for colour art "c"
(-thresh, -rmv_holes and -rmv_dirt will be overridden by -threshl, threshc, -rmv_holesl,
-rmv_holesc, -rmv_dirtl and -rmv_dirtc)
-threshl <threshold for line art (default 0.5)>; range 0.0 to 1.0
-threshc <threshold for color art (default 0.5)>; range 0.0 to 1.0
-jag_filterl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-jag_filterc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-expand_bitmapl <pixels (default 0>; expand the pixels in the vectorization bitmap for line art
-expand_bitmapc <pixels (default 0>; expand the pixels in the vectorization bitmap for colour art
-rmv_holesl <area (default 7)>; remove line art holes smaller than "area"
-rmv_holesc <area (default 7)>; remove colour art holes smaller than "area"
-rmv_dirtl <area (default 1)>; remove line art dirt smaller than "area"
-rmv_dirtc <area (default 1)>; remove colour art dirt smaller than "area"
try values between 100 and 500 for rmv_holesl, rmv_holesc, rmv_dirtl and rmv_dirtc. The values are in
world units squared
-margins <inch (default 0.25)>; remove margin around bitmap
-top_margin <inch (default 0.25)>; remove margin at top of bitmap
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-bottom_margin <inch (default 0.25)>; remove margin at bottom of bitmap
-left_margin <inch (default 0.25)>; remove margin at left of bitmap
-right_margin <inch (default 0.25)>; remove margin at right of bitmap
-remove_peg_bars; remove the peg bar holes
-field_size <fields (default 12 or use value in scan file)>; set the drawing to this field size
-fs; short hand for -field_size
-peg_bar_size <inch (default 1)>; the size of the peg bar region
-noframe; do not put a frame around the colour art
-frame_fields <default -1.000000>; put a frame of the specified dimension around the colour art
-downscale_input <default 1>; downscale the raw input by this integer factor
-downscale_texture <default 1>; downscale the output texture by this integer factor
-buildmatte; generate a matte on underlay for line test
-buildmatte_colourart; generate a matte on colour art for line test
Note: -buildmatte and -buildmatte_colourart are mutually exclusive
-copystrokes; copy original strokes when building matte.

Options for bitmap that has no registration information
-pixel_margins <inch (default 0)>; remove margin around bitmap
-top_pixel_margin <inch (default 0)>; remove margin at top of bitmap
-bottom_pixel_margin <inch (default 0)>; remove margin at bottom of bitmap
-left_pixel_margin <inch (default 0)>; remove margin at left of bitmap
-right_pixel_margin <inch (default 0)>; remove margin at right of bitmap
-dpi <(default -1)>; dpi information of input bitmap

RGB Keying Options
-rgb; generate separate zones for red, green and blue lines
-rgb_alpha <value (default 255)>; generate red, green and blue colour with alpha of this value
-no_red; ignore red colour in vectorization
-no_green; ignore green colour in vectorization
-no_blue; ignore blue colour in vectorization
-flatten; flatten the drawing after generating colours
-rmv_rgb_dirt <threshold area default 0.0>; remove red, green and blue regions smaller than area
-expand_bitmap_rgb <pixels (default 0>; expand the pixels in the vectorization bitmap for rgb
-threshrgb <value> <threshold for rgb vectorization default 0.200000>;
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-threshsv <saturation threshold default 0.500000> <value threshold default 0.500000>; thresholds on saturation
and value to consider a pixel to be grey

Colour Vectorization Options
-color_vectorize; perform a colour vectorization
-file2 <colour art filename>; specify the colour art bitmap
-penstyle <center alpha (0.0-20.0)> <edge alpha (0.0-20.0)> <gamma (0-10)><centre pressure effect (0.0-1.0)>
<edge pressure effect (0.0-1.0)><texture bitmap downscaling (0.2-20)> <texture bitmap file (valid filename or "" if
no file)>; generate brush texture for the line art
-pressure_variation <strategy (0, 1 or 2)> <min pressure (0.0-1.0)> <max pressure (0.0-1.0)> <max variation
(0.0-1.0)>; specify a pressure strategy for the centre line.
-blur_radius <pixels (default 0)>; blur the penstyle texture generated
-color_contour_smooth_passes <times (default 3)>; perform number of smooth passes on contour before
computing texture
-ccsp <times (default 3)>; short for -color_contour_smooth_passes
-color_rmv_holesl <world units (default 0.000000)>; remove holes of this size when computing texture
-color_fill_holesl <world units (default 0.000000)>; fill holes of this size for colour line art

Bubble Usage (implemented only for colour vectorization's line art)
-create_bubbles; add bubbles into the LineArt. Implemented for colour vectorization only
-bubble_gap <value (default 3)>; max number of colour art points between 2 bubbles
-bubble_length <value (default 10)>; max number of circles in a bubble
-min_radius <value (default 1.5000)>; min radius of a circle in a bubble relative to the line thickness (must be >=
1.0)
-max_radius <value (default 3.5000)>; max radius of a circle in a bubble relative to the line thickness (must be
>= 1.0)
-uniform_gap; the space between bubbles is constant

4 Colour Vectorization
-4colours [key:value] ... [key:value] ; The key value list can be empty. The list of keys is:
rgbdiff:value ; between [0.0-1.0] or [0-255]
dark:value ; between [0.0-1.0] or [0-255]
grey:value ; between [0.0-1.0] or [0-255]
white:value ; between [0.0-1.0] or [0-255]
dirt:value ; dirt area. 200 is a good value
rt:value ; between [0.0-1.0] or [0-255]
gt:value ; between [0.0-1.0] or [0-255]
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bt:value ; between [0.0-1.0] or [0-255]

NOTE:
There must be no space between the colon and the key/value. For example: -4colours rgbdiff:20 dark:20 grey:120
white:250 dirt:200 rt:240 gt:240 bt:240

Creating a Vectorization Style
With Harmony, you can create custom vectorization parameters that can be saved, reused, shared, or used to set
the Scan module vectorization style list.
You can vectorize drawings using one of the following methods:
•

Black and White: All the lines become vector based and 100% black. The white areas become completely
transparent.

•

Greyscale: All the lines preserve their initial textured look in grey shades as a bitmap image contained inside
a vector frame. The white areas become completely transparent.

•

Four Colours: With the advanced parameters, you can isolate the red, green, blue, and black lines and turn
them into 100% vector lines, preserving their original colours—see Creating Custom Vectorization
Parameters on page 35.

How to create or modify the vectorization parameters
1. Set the different options available in the Vectorization Parameters dialog box.
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2. Click the Vectorize button to update the Vectorized Image preview.
The vectorized image is just a preview. The actual vectorization happens when you click OK in the Import
Images dialog box. There are many options to try in the Vectorization Parameters dialog box. These are
applied during the vectorization process.
3. To set advanced parameters, read the information on the Help tab, then type in the Advanced Options field
at the bottom of the dialog box.
4. To save your vectorization parameters to reuse them later, share them, or use them to set the Scan module vectorization style list, click Save.
5. In the Browser window, name and save the file.

6. To save the current settings as your default settings, click Save As Default. To restore the default settings, click Restore Defaults.
7. To load a vectorization style, click Load and locate the existing *.vof file.
8. Click OK.

Setting the VectOptions.conf File
Toon Boom Harmony Server uses a file called VectOptions.conf to get the vectorization style when batch
vectorizing a series of drawings. A series of default styles is available in this file, but you will certainly want to
create your own to fit your production style.
How to set the VectOptions.conf file on Windows or Mac OS X
1. Open the vectOptions.conf file:
‣

Windows: Select Programs / All Programs > Harmony 12.2 > Tools > Configuration Editor.

‣

Mac OS X: Select Applications > Harmony 12.2 > Tools > Configuration Editor.

The Configuration Editor window opens.
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2. In the bottom section of the window, select the VectOptions.conf tab.
3. Scroll down the VectOptions.conf file to see all the different options available for creating your custom vectorization style. These options are the same as in the Vectorization Parameters dialog box. It is recommended that you create your vectorization style using Harmony and the Vectorization Parameters window
and copy the result parameters in this file—see Creating a Vectorization Style on page 1.
4. Scroll down toward the bottom of the file to see the default styles. You can modify them or add new ones to
the list using the parameters you got using the Vectorization Parameters window. Notice that some of the
lines have a “#” sign at the beginning to indicate that the line is a comment and will not appear in the style list.
The lines that have no sign at the beginning appear in the style list.

5. To create a new style, type the following below the existing styles:
style_name:
This should be followed by the name of your new style. For example: style_name: Black Lines.
6. Under the style name line, type the following:
options:
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7. Copy and paste the information in your *.vof style when saving your settings in the Vectorization Parameters window.
‣

To open the *.vof file, use any plain text editor application.

8. In the Configuration Editor’s top menu, select File > Save.
9. If you have Toon Boom Harmony Scan on your computer, you can start the application and verify that the
new style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE:
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.
Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the vi text editor
1. Open a Terminal window:
Menu: Applications > System Tools > Terminal
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2. Open the etc folder inside the installation directory:
$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc
3. Change your user to "root":
$ su
‣

If your user is part of the sudoers list, enter the following command and go to step 5.
$ sudo vi VectOptions.conf

4. Enter the root password.
5. Open the VectOptions.conf file:
$ vi VectOptions.conf
6. To start editing, press I to enter Insert mode.
7. When you're finished editing the file, press Esc to exit Insert mode.
8. To save the changes made to the file, type the following and press Enter/Return:
$ :w!
9. To exit the vi editor and return to the Terminal, type the following and press Enter/Return:
$ :q
10. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the new
style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE:
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.
Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.

How to set the VectOptions.conf file on Linux using the gedit text editor
1. Open a Terminal window:
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Menu: Applications > System Tools > Terminal
2. Open the etc folder inside the installation directory:
$ cd /usr/local/ToonBoomAnimation/harmony_12.2/etc
3. Change your user to "root":
$ su
‣

If your user is part of the sudoers list, enter the following command and go to step 5.
$ sudo gedit VectOptions.conf

4. Enter the root password.
5. Open the VectorOptions.conf file:
$ gedit VectOptions.conf
6. Edit the parameters of the VectOptions.conf file as you would do in most text editor applications.
7. Select File > Save.
8. Select File > Quit.
9. If you have Toon Boom Harmony Scan module on your computer, start the application and verify that the
new style appears in the Vectorization Style list under Edit > Vectorization Style.

NOTE:
If you are using the batch processing method available with Toon Boom Harmony Server to scan and vectorize
drawings, the selected style must be available on all the machines included in the batch processing list.
Refer to the Control Center Guide Guide to learn more about setting up and using batch processing.
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Chapter 3: Library

Using templates and symbols , you can share and reuse any elements you create in Harmony. The Harmony library
lets you store several different elements such as puppets, backgrounds, animations and key poses. In fact,
anything you create in Harmony can be stored in the library.
This chapter contains the following topics:
•

Understanding the Library Concept on page 49

•

Library View on page 51

•

Organizing the Library on page 53

•

Templates on page 57

•

Symbols on page 59

•

Importing Symbols and Templates on page 67

•

Importing Files Through the Library on page 71

•

Using Paste Special on page 71

Understanding the Library Concept
The Library view is where you can store and reuse your artwork and animation in other scenes or build props and
puppets.
•

What is a Library? on page 50

•

Understanding the Library Concept on page 49

•

What is a Symbol? on page 50

•

Understanding the Library Concept on page 49

49

Chapter 3: Library

What is a Library?
The library is a storage centre for all production assets; the elements stored in the library are called templates.
Although it is mainly used for cut-out animation, the library is also useful for paperless and traditional animation
processes. The library can contain any asset used in a Toon Boom Harmony production.
Using the library is as simple as dragging the content into the library to store your artwork and then dragging it to
the Timeline or Camera view when you want to reuse it.
You can organize your library using several different subfolders and store them on your hard drive or network.

What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different scenes. Once
a template is stored in the library, you can access it from any project.
Dragging a template into your scene copies the content in your Timeline and does not link it to the original. You
can modify this individual copy at any time.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to contain
artwork and animation and manipulate them as a single object. You can also use symbols as a placeholder in
which you place a series of different drawings for each body part of your puppets or when you have a repeating
cycle. However, symbols are not necessary for creating characters.
To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the Symbol library into
your scene, it will be linked to the original symbol. If you drag a symbol into your scene several times in the
Timeline view, they will all be linked to the original symbol. If you modify one, they will all be modified.
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A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a symbol's content in
another scene, you must create a template out of it.
When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.

Library View

You use the Library view to create and manage your symbols and templates, display the folders and manage and all
of the content.
Library View Menu
The Library menu lets you access commands specific to the Library view, such as opening a Library or getting the
rights to modify a library folder.
Preview Window
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The Preview window lets you preview the content of a symbol or template, and swap between drawings and
symbol cells in the Timeline view. This window is also used as the Drawing Substitution window.
How to preview a template or symbol's content
1. In the Library view's right side, click or double-click on the symbol or template to preview.
2. In the Preview window, click the Play

button or drag the slider to scrub through the frames.

Library Search Tool
When working on a movie or series, you will probably end up with many templates and symbols in your library.
Using the Search tool, you can quickly find the templates and symbols in your folders.
How to use the Library Search tool
1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left

and right

arrows to see the previous and next results. The Search engine will look for

results within the library master folder and its subfolders. It will not look in other libraries.

Library List
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The Library list lets you navigate through the different libraries and subfolders. You can also open, close and create
new libraries from here.
The Library folders have these default libraries:
•

Symbols: The only library folder containing symbols for your project. You can organize the symbols library
folder using subfolders, but you cannot create a second library for your symbols. This library is local to your
project.

•

Harmony Library: This folder contains templates and is stored on your hard drive. You can organize the
Harmony library folder using subfolders. This folder does not contain symbols.

Templates and Symbols List

s
The symbols and templates contained in the selected Library list can be displayed on the right side of the Library
view as thumbnails, in a list or as details.
How to access the templates and symbols list display options

‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.
‣ In the Library View toolbar, you can click the following buttons:
Thumbnails
List
Details

Organizing the Library
As you will probably create a large number of symbols and templates, you will soon realize they need to be
organized. You can create different libraries and subfolders to easily access your assets. For example, you can
create a different library for each project and divide it into several categories, such as:
•

Characters

•

Props

•

Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.
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There are two ways to create library folders.
•

Directly through your operating system

•

Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or network as
a library. Opening a library means linking the folder to your Library view. You only need to open the library once.
The library folder is available every time you open the application until you decide to close the library and unlink it.
You may not always require all the library folders in the Library List. If so, you can close the ones you do not need.
Closing a folder does not delete it; it only unlinks it from the Library view. If you want to reopen it, locate it on your
hard drive or network and open it in the Library view.
Symbol and template libraries need to be organized. You can create different subfolders on your hard drive or in
the Harmony Library view, so you can easily access assets. By default, any new library you link to your Library
view is locked to prevent accidental deletion or modification of symbols and templates. You must obtain the right
to modify it before being able to add a new folder to it.
You can delete a folder from the library if its contents are no longer needed.

NOTE: Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.
If you update the content of your libraries through your operating system, you will need to refresh your library
folders in the Library view.
When you display thumbnails in the Library view, the system generates a series of small images (thumbnails) for
you. You can generate template thumbnails yourself, if they do not display or if the process has been stopped.
You can also delete thumbnails if you want to send a template to another user or studio and keep your packages
small.
How to create a library folder through your operating system
1. On your computer, create a new folder with a relevant name in the location where you want the library to be
stored.
How to create a library folder in Harmony
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse for the location where you want to store your new library folder.
3. Click the New Folder button.
A new folder appears.
4. Name the new library folder with a relevant name and click OK.
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The new library appears in the Library List section.

How to open a library
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder and click OK.
The new library appears in the Library Folders section.

How to close a library
1. On the right side of the Library view, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.
How to create a folder
1. On the left side of the Library view, select the library folder to which you want to add a subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > New Folder.
The new folder appears in the Library. Click on the library containing the new folder and click the plus [+] sign
to expand it.

How to delete a folder
1. In the Library view's left side, select the folder to delete.
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2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press Delete.
How to rename a folder
1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and select
Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press Enter/Return to validate the operation.
How to refresh a library
1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press F5.
The library displays the new content.
How to generate thumbnails
1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.
How to delete thumbnails
1. In the Library View menu, select Edit > Delete Thumbnails.
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All the thumbnails contained in the library are removed.

Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a template from
it. A template can be seen as a portable scene or package that you can drag inside your project. You can open a
template and edit it just like any other project. If you want modify your templates, you can edit them using the Edit
Template command.
You can create a template using the Timeline view.
To delete templates from your library, use the Library view. Harmony lets you undo the action if necessary.
How to create a template from the Timeline view
1. In the Timeline view, select some cells or layers.
2. In the Library view, select a folder to store the template.
3. If a library folder is locked, right-click and select Right to Modify.
4. Drag the selection to the Stage Essentials Library folder or any other library folder.
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5. In the Rename dialog box, give the new template a name.
To rename a template once it is created, right-click on the symbol and select Rename.
6. Click OK.
How to delete a template
1. In the Library view, select the folder containing the template to delete.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.
How to edit a template
1. In the Library view, select the folder containing the template to edit.

NOTE: If the library folder is locked, right-click on the folder and select Right to Modify.
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2. Right-click on the selection and select Edit Template.
A new Harmony application opens.
3. Edit the template.
4. From the top menu, select File > Save.
5. In the top menu, select File > Quit (Windows/Linux) or Stage Essentials > Quit (Mac OS X).

Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer. You can also
create symbols out of each body part in your cut-out puppets.
You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to retrieve the data.
The symbol cannot be retrieved once you close the application.
When you import a symbol from the library to the Timeline view it is linked to the original symbol in the library. If you
import a symbol into your scene several times in the Timeline view, they will all be linked to the original symbol. If
you modify one, they will all be modified.
If you want to edit a symbol without modifying the other instances, you must duplicate the symbol first. If other
symbols are nested inside the new symbol, they are not duplicated. If you modify them, the original and other
instances will also be modified.
You can either edit a symbol from the Timeline view or from the Library view.
When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are located in the
position where they were created. The pivot is translated at the centre of the symbol.
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When you enter a symbol to edit it, you are entering another scene with an independent timeline. You can nest
many symbols one inside the other. To help you follow the hierarchy of your nested symbol, take note of the
Editing stack at the top of the Camera view which displays the path to your symbol's location. You can click on
the symbol's name to move up the chain.
You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first convert
your symbol into a template. This conversion breaks the drawing's link with both the original scene and symbol. It
then becomes a separate entity that you can import into other projects.
How to create a symbol from a drawing selection
1. In the Tools toolbar, select the Select

or Cutter

tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.
‣

Clicking the Create Symbol

button in the Edit toolbar will create a symbol from the entire layer.

The Create Symbol from Drawing Selection dialog box opens.
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4. In the Symbol Name field, type the name of the symbol.
‣

You can also select an existing layer from the Symbol Name drop-down menu. It will add your symbol on
the layer's current cell. If there is already an exposure on that cell, the symbol will be added to a new
layer.

5. You can choose to place the current selected artwork in the drawing or remove it:
‣

To remove currently selected artwork from the drawing and place it in the new symbol, select the Cut
Artwork From Source Drawing option.

‣

To keep currently selected artwork in both the drawing and in the new symbol, deselect the Cut Artwork
From Source Drawing option.

6. Click OK.
The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.

How to create a symbol from the Timeline view
1. In the Timeline view, select the layer or cells from which your want to create a symbol.
2. Do one of the following:
‣

From the top menu, select Edit > Create Symbol.

‣

In the Edit toolbar, click the Create Symbol

‣

Press F8.

‣

Drag your selection to the Symbol folder in the Library view.

button.
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The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.
The new symbol appears in the Library view's Symbol folder. The current selection is not replaced by the
new symbol. The new symbol only appears in the library. You must drag it into your scene to use it.
How to create an empty symbol
1. In the Library view, select the Symbol folder.
2. Do one of the following:
‣

In the Library view's right side, right-click and select New Symbol.

‣

From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.
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The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top
in the Camera view.

button

To rename a symbol once it is created, right-click on the symbol and select Rename.
How to delete a symbol
1. In the Library view, select the symbol to delete.
2. Right-click and select Delete or press Delete.
‣

If the symbol is currently in use in the scene, a warning message displays. Click OK to delete the symbol
from the library and scene.

How to edit a symbol from the Timeline view
1. Do one of the following:
‣

In the Timeline view, double-click on the symbol's cell to edit the symbol.

‣

In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘ + E (Mac OS X)).

‣

Click the Edit Selected Symbol

button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

2. Do one of the following:
To return to the project's timeline, click the Top
button in the Camera view's top-left corner, press Ctrl + Shift
+ E (Windows/Linux) or ⌘ + Shift + E (Mac OS X).
‣

In the Timeline view's right side, right-click and select Symbols > Leave Current Symbol.

How to edit a symbol from the Library view
1. In the Library view, select the symbol to edit.
2. Right-click and select Edit > Edit Symbol or double-click on the symbol.
You are now inside the symbol and you are able to edit it.
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To return to the project's timeline, click the Top
E (Windows/Linux) or ⌘ + Shift + E (Mac OS X).

button in the Camera view's top-left corner, press Ctrl + Shift +

How to duplicate a symbol
1. In the Timeline view, go to the frame where you want to duplicate the symbol.
2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held exposure is
replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template
1. From the Library view, select the symbol to convert into a template and drag it to the Camera or Timeline
view. If you drop your symbol into the Camera view instead of the Timeline view, it will not be placed in the
centre of your camera frame, but rather wherever your cursor drops it within the camera frame.
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2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to any other
library folder. Make sure you have the right to modify the library folder.

3. In the Rename dialog box, rename the new template.
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4. Click OK.

Importing Symbols and Templates
There are several ways you can import symbols and templates in your scene.
Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates, can contain
symbols such as a leg that was made with a patch. However, a symbol does not work in the same way as an action
template. In the Timeline view, you can add an action template into another template of the same structure. When
working on a layer on the right side of the Timeline view and you place a symbol into a symbol of the same structure,
instead of being added to the previous symbol, the new symbol becomes a copy.
For greater control over how the action template behaves when brought into the Timeline view, you can use the
Paste Special feature—see Using Paste Special on page 71.
Since a template is like a scene, you can open the template's folder and select elements inside it such as drawings.
Instead of importing the entire contents of a template, you may only want to import a few drawings or a palette. In
this case, use the Open As Folder command to import the items you want.
If you want to import a palette, simply drag the palette file into the Palette list section of the Colour view.
You can use the Expand Symbol command to extract a symbol's contents and place it on the root timeline. The
symbol will not be removed from the Timeline view. Its contents will be copied and inserted into the root timeline.
The symbol's layers will be parented to it in case you created motions and transformations on the drawing layer that
contains the symbol. Breaking the hierarchy could result in the loss of any scaling and animation you may have
created.
You can also expand a symbol within a group to avoid crowding the timeline with a series of layers. When you
expand the symbols, the layers will be contained in a group node that you can expand to see the content.
How to import a template into the Timeline or Camera view
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer structure is the same as the existing one.

How to import a symbol in the Timeline view
1. In the Library view, select the symbol you want to import.
2. Drag the selected symbol to one of the following:
‣

The Timeline view's left side to import it into the centre of the camera frame.

‣

The Camera view to place it at the location where you release your cursor.
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NOTE: This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be more
efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols
1. From the right side of the Library view, select the action template that contains symbols.
2. Hold down Alt (Windows/Linux) or ⌘ (Mac OS X) as you drag it from the Library view to the right side of the
Timeline view and drop it next to a template with the exact same rig.
The Paste Special window opens.

3. Select the Advanced tab.
4. Select one of the following options from the Symbols menu:

‣

Copy symbols if they do not exist: This is the default setting for this operation and will prevent symbols
in an action template from being copied.

‣

Duplicate symbols: Makes copies of the symbols in your template.

How to open a template as a folder
1. In the Library view, select the folder that contains the template to open. If the library folder is locked, rightclick on the folder and select Right to Modify.
2. Right-click on the selection and select Open As Folder.
3. In the library list section, click on the template's folder to display its content.

69

Chapter 3: Library

4. Drag the content to the Timeline or Colour view.
How to expand a symbol
1. In the Timeline view, select the symbol to expand.

2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group
1. In the Timeline or Node view, select the symbol cell or symbol node you want to expand.

2. From the top menu, select Edit > Expand Selected Symbol in a Group.
3. In the Timeline view, click the plus sign (+) to see the group content. In the Node view, click the Expand
Arrow to enter the group.
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Importing Files Through the Library
Harmony lets you import sound files and images directly through the library. Simply open the folder containing your
files in the Library view and drag them directly from there.
How to open a file through the Library
1. In the Library View menu, select Folders > Open Library.
2. Browse for the folder containing the files you want to import.
3. Click Open.
4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.

Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and keyframes. You can
choose to import only the keyframes without the drawings or import only the drawings that are not already in your
layers. You can adjust the behaviour using the Paste Special dialog box.When you import a symbol in your scene,
its full length is exposed by default. If you import a symbol in the Timeline view’s left side, all the frames will be
exposed. However, if you import it into an existing layer, you can use the Paste Special dialog box to adjust the
import behaviour to fit your requirements.Once you set the parameters, Harmony will reuse them each time you
import a symbol in the Timeline view’s right side until you set new parameters.
How to open the Paste Special dialog box
1. In the Library view, select the symbol or template to import.
2. Press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X) and drag the selection to the Timeline view.
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NOTE: Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.
3. Set the parameters and click OK.
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Chapter 4: Scene Setup

Setting up your scene can be compared to building a set for a television show. This is the point when you position
each scene element such as the camera frame, the background elements and the characters.
This chapter contains the following topics:
•

Importing the Scene Elements on page 73

•

Setting the Camera Frame on page 73

•

Positioning the Scene Elements on page 77

•

Cloning and Duplicating Layers on page 97

•

Working with Groups on page 99

•

Creating a Multiplane on page 100

Importing the Scene Elements
The first step in the scene setup task is gathering the scene’s different components and then importing them into
your project. You might need to import some backgrounds, sound files or movie clips to complete your scene. You
can refer to the following topics to learn how to bring those elements in.
•

Importing Bitmap Images on page 7

•

Importing QuickTime Movies on page 34

•

Importing a Sound File on page 151

Setting the Camera Frame
The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution and other parameters in the Scene Settings window. Refer to the Fundamentals Guide, Starting
Harmony chapter to learn more.
The Camera layer is static which means that if you need to animate it, you must add a peg.
You need to add a camera layer to your scene, so you can edit the camera frame. You can only see one camera at a
time. If you add several cameras to your scene, you can use the Camera list to select the active one. You could use
this feature if you are still working on your scene composition and have different camera framing to try out.
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You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this
positions the camera precisely where you want it to be rather than gauging it visually.
You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the
selected element to the initial value of the active tool. For example, if the Rotate
tool is active, the
transformation angle will be reset to 0 and if the Transform
tool is active, then all parameters values will be
reset.
How to add a camera in the Timeline view
1. Do one of the following:
‣

In the Timeline view, click the Add Layer

button and select Camera.

‣

From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

NOTE: You cannot add a camera inside a symbol.

How to select a camera from the Camera list (set the active camera)
1. From the top menu, select Scene > Camera > the desired camera .
If you only add one camera to your scene, you will only see Default Camera in your list.
How to reposition the camera frame directly in the Camera view
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
‣

From the top menu, select Animation > Tools > Translate.

‣

In the Advanced Animation toolbar, click the Translate

‣

Press Alt + 2.

tool.

3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the camera
layer from the Timeline view.
The selected camera frame is highlighted.
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4. Drag the camera frame to a new position.

5. To tilt the camera frame, do one of the following to select the Rotate tool:
‣

From the top menu, select Animation > Tools > Rotate.

‣

In the Advanced Animation toolbar, select the Rotate

‣

Pres Alt + 3.

tool.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.
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How to set up the camera frame using the Layer Properties view
1. In the Timeline view, select the camera layer.
2. In the Layer Properties view, adjust the camera's properties.

Parameter

Description

Enable/Disable

Turns the camera layer on or off.

Change Track Colour

The Change Track Colour
button lets you change the colour of the
exposed frames; this helps you to quickly locate a layer in the Timeline view.
Click the Change Track Colour
button to open the Select Colour window
and choose a new colour. You can modify the colour for any type of layer, such
as group, peg, drawing, and effects.

Name

Displays the current layer name. You can rename the layer by typing in a new
layer name.

Position

Displays the current position of the camera layer using X-axis (East/West), Yaxis (North/South) and Z-axis (Forward/Backward) coordinates. To reposition
your camera frame, type in the new values corresponding to the desired position coordinates. You can also use the up and down arrows to set the value of
each field—see Positioning an Element Using the Layer Properties View on
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page 92.
Angle

Displays the current rotation value. To set a new rotation position, type in a
new angle value. You can also use the up and down arrows to set the new
angle value.

Pivot

Displays the current position of the rotation pivot of the camera layer. The camera will perform a rotation taking the position of the pivot as its angle centre. By
default, the pivot is set at the centre of the camera frame. To reposition the
pivot point, type in new X and Y coordinates values in the appropriate field. You
can also use the up and down arrows to set the position values.
In order to see the pivot's position you will need to have the Rotate tool selected.

How to reset the camera position
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Timeline or Camera view, select the camera layer.
3. From the top menu, select Animation > Reset or press Shift + R.
The camera automatically returns to its original position.

Positioning the Scene Elements

Setting up the scene also involves positioning the different scene elements within the camera frame.
Here are the main features and topics you need to know about to position your elements:
•

Animate Mode on page 78

•

Selecting a Layer on page 78

•

Positioning an Element Using the Transform Tool on page 82

•

Positioning an Element Using the Advanced Animation Tools on page 89

•

Positioning an Element Using the Layer Properties View on page 92

•

Drawing Layer Properties Reference on page 95
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•

Resetting a Transformation on page 97

Animate Mode
When positioning elements, make sure the Animate Mode is turned off, or it will create a keyframe on your
drawing layer. The animate mode is used to animate layers over time.

How to turn off the Animate mode
‣

In the Tools toolbar, click the Animate Mode

‣

In the top menu, disable Animation > Animate.

button. Make sure the button is depressed.

Selecting a Layer
There are different ways to select the layers you want to reposition.
You can select your elements directly in the Camera view using the Transform tool. When using this tool, its
properties and options appear in the Tool Properties view. Always make sure that the Peg Selection Mode option
in the Tool Properties view is disabled or it will limit the selection to pegs only.
When you have several layers in the Timeline view, you may find it hard to locate which one is selected. You can
use the Centre on Selection feature to display the selected layer in the Timeline view.
How to select a layer in the Camera view
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

1. In the Tool Properties view, make sure that the Peg Selection Mode

is deselected.

2. In the Camera view, click on the element to be repositioned. You can select more than one element at a
time. Hold down Shift while clicking on the elements to be selected.
The corresponding layers and columns are highlighted in the Timeline and Xsheet views.
How to center on the selected layer in the Timeline view
1. In the Camera view, select a layer.
2. In the Timeline view toolbar, click the Centre on Selection

button or press O.

How to select from the Timeline or Xsheet view
‣

In the Timeline view, click the layer corresponding to the element you want to reposition.

‣

In the Xsheet view, click the column header corresponding to the element you want to reposition.

The selected element is highlighted in the Camera view.
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How to select all elements within a group in the Timeline view
1. With a group collapsed or expanded, hold down Alt and click on the group in the Timeline view.

All elements contained within the group are selected.

Locking Layers in the Timeline View
You can prevent correctly positioned layers from being selected in the Camera view by locking them in the Timeline
view. This is useful for making a multiple selection inside the Camera view while avoiding to select them. Once a
layer has been locked, its locked state will be remembered the next time you open a saved project.
You can perform five types of locking actions on your layers:
•

The Lock

option lets you lock one or a multiple selection of layers.

•

The Unlock

•

The Lock All

•

The Unlock All

•

The Lock All Others

button lets you unlock one or a multiple selection of locked layers.
option lets you lock all the layers in the Timeline view.
button lets you unlock all the layers in the Timeline view.
button lets you lock every layer except the selected ones.

How to lock a layer or a selection of layers
1. In the Timeline view, select one or more layers.
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2. Do one of the following:
‣

From the top menu, select Animation > Lock > Lock.

‣

Click one of the selected layer’s Lock

‣

Press Ctrl + Alt + L (Windows/Linux) or ⌘ + Alt + L (Mac OS X).

icon.

All selected layers are locked.

How to unlock a locked layer or a selection of locked layers
1. In the Timeline view, select one or more locked layers.

2. Do one of the following:
‣

From the top menu, select Animation > Lock > Unlock.

‣

Click a selected layer’s Lock

‣

Press Ctrl + Shift + K (Windows/Linux) or ⌘ + Shift + K (Mac OS X).

icon.

All selected layers are unlocked.
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How to lock all layers
1. Do one of the following:
‣

From the top menu, select Animation > Lock > Lock All.

‣

In the Timeline view, select all layers and click Lock

‣

Press Ctrl + Shift + L (Windows/Linux) or ⌘ + Shift + L (Mac OS X).

icon of a selected layer.

All layers are locked.

How to unlock all layers
1. Do one of the following:
‣

From the top menu, select Animation > Lock > Unlock All.

‣

In the Timeline view, select all layers (locked) and click Lock

‣

Press Ctrl + Alt + Shift + L (Windows/Linux) or ⌘ + Alt + Shift + L (Mac OS X).

All layers are unlocked.

How to lock all other layers
1. In the Timeline view, select the layers you do not want to lock.
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2. Do one of the following:
‣

From the top menu, select Animation > Lock > Lock All Others.

‣

Press Ctrl + Alt + Shift + O (Windows/Linux) or ⌘ + Alt + Shift + O (Mac OS X).

All layers are locked except the selected ones.

Positioning an Element Using the Transform Tool
Using the Transform tool, you can easily reposition, scale, rotate and even skew layers directly in the Camera
view.
When positioning a drawing layer using the Transform tool, always make sure the Peg Selection Mode
deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs in the Camera view.

82

is

Harmony 12.2 Essentials - Compositing and Effects Guide

There are two different options you can use when you want to flip your element.
The Flip Horizontal and Flip Vertical options let you flip a drawing layer along the Camera view’s horizontal and
vertical axis.
Once your drawing layer is rotated, the original horizontal and vertical axes change. The Flip Scale X and Flip Scale
Y will perform a flip on your drawing layer following its original axis.
•

The Flip Horizontal command flips the layer following the Camera view X-axis.

•

The Flip Scale X command uses the original X-axis of the layer and flips the element following it.

Transformations, such as rotation, scale, skew and flip are made relative to the pivot point position. You can
temporarily reposition the pivot point for each transformation using the Transform tool. Note that the pivot is only
moved temporarily. When animating the position, the interpolation is calculated from the permanent pivot position—
see Positioning an Element Using the Advanced Animation Tools on page 89.
How to temporarily reposition the pivot point
1. In the Tools toolbar, select the Transform

tool.

2. In the Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select your element.
The pivot point appears at the center of the scene space (coordinates 0, 0, 0), unless previously repositioned.
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4. Click on the pivot point and drag it to a new position.
This will be the new position of the pivot point for the current transformation. It will remain in this position
as long as you do not deselect the drawing. Using the Transform tool to reposition your pivot will
temporarily override the existing pivot point position until you complete the current transformation. Then it
returns automatically to its original position.
When you translate the pivot point using the Transform tool, the permanent pivot will appear as a ghost so
you know where it is and also from where the animation will be interpolated when you create motion paths.
The animation is always interpolated from the original pivot and not the temporary pivot.

How to pan a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple
layers to reposition them at the same time. Hold down Shift and select the different layers.

How to rotate a layer using the Transform tool
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer.
5. Place the pointer outside of a corner of the bounding box and drag to rotate.
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How to scale a layer using the Transform tool
1. In the Tools toolbar, disable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point. Hold
down Shift to lock the selection's aspect ratio.

How to skew a layer using the Transform tool
1. In the Tools toolbar, disable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode

is deselected.

4. In the Camera view, select a drawing layer.
5. Place the pointer between two controls points and drag sideways or up and down.
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How to flip a layer
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tools toolbar, select the Transform

tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg Selection Mode
4. In the Camera view, use the Transform

is deselected.

tool to select a drawing layer to flip.

5. Do one of the following:
‣

From the top menu, select Animation > Flip > Flip Horizontal or Flip Vertical.

‣

In the Tool Properties view, click the Flip Horizontal

‣

Press 4 or 5.

and the Flip Vertical

buttons.

How to flip an element following its original axis
1. In the Tools toolbar, disable the Animate

mode.

2. In the Tool Properties view, make sure the Peg Selection Mode
3. In the Camera view, use the Transform

is deselected.

tool to select an element that has already been transformed.

4. From the top menu, select Animation > Flip > Flip Scale X or Flip Scale Y.
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Transform Tool Properties

Icon

Tool Name

Lasso and Marquee on page 87
Peg Selection Mode on page 88
Snap Options on page 88
Hide Manipulator Controls on page 88
Flip Horizontal and Flip Vertical on page 88

Rotate 90 Degrees CW and CCW on page 88

Width and Height on page 88

Offset X and Y on page 89
Angle on page 89

Lasso and Marquee
The Lasso and Marquee options let you choose the type of selection the current tool will perform. The default
selection mode is Marquee.
•

Lasso

•

Marquee

lets you draw a custom selection box around zones.
makes a rectangle selection box.

NOTE:
Hold down the Alt key to switch to toggle between the selection modes.
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Peg Selection Mode
In the Camera view, the Peg Selection Mode
limits the selection to peg layers instead of drawing layers. This
mode is useful when you have created a character rig using peg layers for each drawing. That way, you do not
accidentally select the drawing layer when you want to animate on the peg.
When disabled, the Transform tool selects the drawing layers.
Snap Options
When transforming or repositioning a layer using the Transform tool, you can enable different snap options to help
you.
•

Snap and Align: Snaps the selected layer to any existing object, while automatically displaying
temporary rulers that guide you and that you can also snap your object to.

•

Snap to Grid: Snaps your selection according to the currently enabled grid.

Hide Manipulator Controls
The Hide Manipulator Controls
button lets you hide the bounding box and manipulator controls from the
Camera view when an element is selected.
Flip Horizontal and Flip Vertical
The Flip Horizontal
and Flip Vertical
buttons let you flip the selected element horizontally or vertically.
You can also select Animation > Flip > Flip Horizontal and Flip Vertical from the top menu or press 4 or 5.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
degrees clockwise or counter-clockwise.

operations rotate the current selection 90

Width and Height
The Width

•

and Height

fields allow you to enter specific values for accurately resizing a selected layer.

Width: Enter a width value in this field to resize the width of your selection.
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•

Height: Enter a height value in this field to resize the height of your selection.

•

Lock: Click the Lock icon to lock or unlock the ratio between the width and height values.

Offset X and Y
Use the Offset X

and Offset Y

fields to enter specific values to reposition the selected layer accurately.

•

X: Enter an offset value in this field to reposition the selected layer along the X-axis.

•

Y: Enter an offset value in this field to reposition the selected layer along the Y-axis.

Angle
The Angle
field lets you enter specific values to rotate the selected layer accurately. A positive value rotates the
layer counterclockwise and a negative value rotates the layer clockwise.

•

Angle: Enter a degree value in this field to rotate the selected layer.

Positioning an Element Using the Advanced Animation Tools
You can also use the advanced animation tools to position your layers. The difference between these tools and the
Transform tool is that they modify only one parameter of the position such as the rotation or the scale as the
Transform tool adjusts all parameters together.
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Transformations, such as rotation, scale, skew and flip, are made relative to the pivot point position. You can
reposition this pivot point anywhere using the advanced animation tools.
How to permanently reposition the pivot point
1. In the Advanced Animation toolbar, select the Translate

, Rotate

, Scale

, or Skew

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select your element.
The pivot point appears in the Camera view.

3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.
How to pan a layer using the Translate tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
‣

From the top menu, select Animation > Tools > Translate.

‣

In the Advanced Animation toolbar, click the Translate

‣

Press Alt + 2.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select your element.
4. Drag the selection to a new area.
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‣

You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘ + Shift +
click (Mac OS X) on each element to select them.

How to rotate a layer using the Rotate tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
‣

From the top menu, select Animation > Tools > Rotate.

‣

In the Advanced Animation toolbar, click the Rotate

‣

Press the Alt + 3.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select your element.
4. Rotate the layer.

‣

You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘ + Shift +
click (Mac OS X) on each element to select them.

How to scale a layer using the Scale tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
‣

From the top menu, select Animation > Tools > Scale.

‣

In the Advanced Animation toolbar, click the Scale

‣

Press Alt + 4.

tool.

1. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select your element.
3. Pull or push either on the side, top or corner control point. Hold down Shift to lock the selection’s ratio when
using the corner control points.
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‣

You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘ +
Shift + click (Mac OS X) on each element to select them.

How to scale a layer using the Skew tool
1. In the Tools toolbar, disable the Animate

mode.

2. Do one of the following:
‣

Select Animation > Tools > Skew.

‣

In the Advanced Animation toolbar, click the Skew

‣

Press Alt + 5.

tool.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on the element to select it and
drag a side of the bounding box up, down or sideways.

‣

You can select multiple layers at the same time. Press Ctrl + Shift + click (Windows/Linux) or ⌘ +
Shift + click (Mac OS X) on each element to select them.

Positioning an Element Using the Layer Properties View
Each layer has a series of parameters that you can modify to adjust an element's position. You can access these
parameters in the Layer Properties view. In this view, you can type in a value instead of moving the object in the
Camera view. These values can also be animated over time. See Drawing Layer Properties Reference on page
95 for additional details.
You can also access a layer's parameters in the Timeline view. Click on the Expand Parameters
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It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of animation.
In traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart.
Harmony uses this unit of measurement as its coordinate system.

A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the northsouth (up-down) direction and the Z axis is the forward-backward direction.
In Harmony, a drawing's pivot is located at the centre of the field chart, regardless where your drawing has been
drawn on the page. Your drawing is the entire sheet of paper, not only the drawing strokes you have drawn on the
page. This allows scanned drawings, imported images and paperless drawings to be properly registered together.
If you want to move your drawing in the upper-left region of the camera frame, you would type in something like the
following:
•

X Axis: -4 or 4W (4 West)

•

Y Axis: 5 or 5N (5 North)

If you want to move your drawing in the lower-right region of the camera frame, you would type in something like the
following:
•

X Axis: 3 or 3E (3 East)

•

Y Axis: -2 or 2S (2 South)

How to display layer parameters
1. Do one of the following:
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‣

In the Layer Properties view is not part of your workspace, from the top menu, select Windows >
Layer Properties. In the Timeline view, select a layer

‣

In the Timeline view, double-click on a layer.

‣

Press Shift + E.

The properties display.

How to position an element
1. In the Timeline view, select a layer.
2. In the Position section, select one of the following options:
‣

Separate to independently edit the different coordinate fields. Continue to step 3.

‣

3D Path to use a 3D path function when animating your element. Continue to step 4.

3. In the (x), (y) and (z) Axis fields, type in a new coordinates corresponding to the desired position—see
Creating a Multiplane on page 100.
As you type in values, the element’s position is updated in the Camera view.
1. Use the Function

buttons to create function curves and add keyframes to animate the parameter.
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4. In the Scale section, select one of the following options:
‣

Locked to resizes the element uniformly in three directions.

‣

Separate to resize the element in any direction without affecting the others.

5. In the (x) and (y) Axis fields, type in a new coordinates corresponding to the desired position
2. Use the Function

buttons to create function curves and add keyframes to animate the parameter.

6. In the Rotation section, Angle z field, type in a degree value for the rotation angle. Note that you can enter values greater than 360 and -360 degrees. If you enter 720, the object will rotate twice.

7. In the Skew field, type in a degree value between -90 to 90 for the skew angle.

8. In the Pivot section, type in the desired coordinate value to reposition the transformation pivot. This will
change the permanent position of the pivot.

For detailed information on the Layer Properties parameters, see Drawing Layer Properties Reference on page 95.

Drawing Layer Properties Reference
The drawing layer's properties is composed of the following tabs:
•

Transformation Tab on page 95

Transformation Tab
The Transformation tab contains parameters for adjusting the position, scale, rotation, skew and pivots of an
element.
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Parameter

Description
3D Path: Lets you use a 3D path function to animate an element.
Separate: Lets you independently edit the different coordinate fields.
Path (x) Axis: Lets you type in a new East/West coordinate corresponding to
the desired position.

Position

Path (y) Axis: Lets you type in a new North/South coordinate corresponding to
the desired position.
Path (z) Axis: Lets you ype in a new Forward/Backward coordinate
corresponding to the desired position.
Velocity: When the 3D Path option is selected, lets you set the speed at which
Locked: Resizes the element while keeping its ratio. The X and Y axes scale
proportionally

Scale

Separate: Resizes the element allowing to modify the ratio (squash and
stretch).
(x) Axis: Lets you type in the horizontal scale value.
(y) Axis: Lets you type in the vertical scale value.

Rotation

Angle z: Lets you type in a degree value for the rotation angle. Note that you
can enter values greater than 360 and -360 degrees. If you enter 720, the object
will rotate twice.

Skew

Skew: Lets you type in a degree value between -90 to 90 for the skew angle.

Pivot

(x) Axis: Lets you type in a new East/West coordinate corresponding to the
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desired position.
(y) Axis: Lets you ype in a new North/South coordinate corresponding to the
desired position.

Resetting a Transformation
You can easily reset layers to their original position. With the Reset command, you can return the value of a selected
element to the initial value of the active tool. For example, if the Rotate
tool is active, the transformation angle
will be reset to 0 and if the Transform
tool is active, the all transformation parameters values will be reset.
When selecting elements in the Camera view using the Transform tool, always make sure that the Peg Selection
Mode
is deselected in the Tool Properties view. Otherwise, it will limit the selection to pegs only.
How to completely reset the layers' parameters
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Timeline or Camera view, select one or more drawing layers to reset.
3. Do one of the following:
‣

From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes
were created.

‣

Right-click the selected layers and select Clear All Values. This will remove all keyframes and reset all
values for the entire layer.

‣

In the Timeline view menu, select Layers > Clear All Values. This will remove all keyframes and reset
all values for the entire layer.

The selected layers return to their original position.
How to reset an individual parameter
1. In the Advanced Tools toolbar, select the Translate
the parameter to reset.

, Rotate

, Scale

, or Skew

tool based on

2. In the Timeline or Camera view, select the layer to reset.
3. From the top menu, select Animation > Reset or press R. This will reset the current frame if keyframes were
created.
The selected parameter returns to its original position.

Cloning and Duplicating Layers
At times, you will need to create a large group of characters such as a crowd, school of fish or flock of birds. You can
do this by cloning or duplicating a layer. The difference between cloning and duplicating is that a clone uses the
same drawings for all layers. A duplicated layer is simply an independent copy.
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If you want to maintain the ability to modify drawings and propagate the changes through all layers, you should
clone your layer. If you simply want to copy your layers and be able to modify your drawings without affecting the
original layer, use the duplicate option.

Cloning Layers
A cloned layer is linked to the original element directory. If a drawing is modified in the original or cloned layer,
both will be updated. However, cloned layers can have different timings.

When cloning layers, you have the ability to clone the drawings and the corresponding columns (timing) or only
the drawings. If you choose to clone the drawings and timing, your node will be linked to the same element folder,
as well as the same drawing and function columns. Therefore, if you change the drawing exposure or keyframe on
one layer, all cloned layers will be updated.
You may want to create a large group of characters reusing the same animation, but want to slightly offset the
timing so they're not dancing or walking quite on the same beat. For example, if you create a walk-cycle for a
soldier and want to use it for an entire army, you may want to have 50 layers with 50 different drawing exposures
to produce a slight difference in the timing. If you copy your layers and drawings 50 times over, it will create a
heavier scene. It is better to clone the 50 layers with only their drawings without linking to the same timing
(function and exposure columns).
How to clone a layer
1. In the Timeline view, select a layer to clone. You can select multiple layers.
2. Do one of the following:
‣

From the top menu, select Edit > Clone Drawings Only or Edit > Clone Drawings and Timing.

‣

In the Timeline view, right-click on the layers and select Clone Selected Layers: Drawings Only or
Clone Selected Layers: Drawings and Timing.
The cloned layer appears.

Duplicating Layers
You can duplicate a layer to have a copy of the drawings that are independent from the original ones, as well as an
independent timing (exposure). When you need the drawings to be modified independently, you will want to
duplicate the layer instead of cloning it.
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How to duplicate a layer
1. In the Timeline view, select a layer to clone. You can select multiple layers.
2. Do one of the following:
‣

In the Timeline view, right-click on the layers and select Duplicate Selected Layers.

‣

From the top menu, select Edit > Duplicate.
The duplicated layer appears.

Working with Groups
With so many connections and nodes possible, the Timeline view can quickly become crowded. Keep things
organized by grouping your nodes.

How to group elements in the Timeline view
1. In the Timeline view, select the elements you want to group.
Any layers between the selected layers will be automatically grouped as well, so if the stacking order does
not matter, move extra layers above or below the layers want to group.
2. Do one of the followings:

99

Chapter 4: Scene Setup

‣

Right-click on the highlighted layers and select Group Selection.

The layers appear indented under a new Group layer in the Timeline view.

Creating a Multiplane

One of the most exciting features in Harmony is the multiplane or Z-depth. In the multiplane, you can create
backgrounds in several layers, spread them on the Z-axis to add depth, and then move the camera through this
environment to create an impressive perspective illusion.
To construct a multiplane, you must imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving through the space. Notice that objects in the picture move at different
speeds depending on where they are in relation to the camera lens.
Building a multiplane requires an understanding of the scene's background, as well as the positioning of the
elements on different layers.
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For example, in the background illustrated above, the main objects to be separated are:
1. Fern
2. Front tower
3. Second tower
4. Moon
5. Stars
6. Sky
Although the bottom of the tower is hidden behind the plant and the ladder, each of the multiplane layers should be a
complete drawing. This is because hidden portions may show up during a camera move later on in the scene.
You can position layers on the Z-axis using the Side and Top view.
Positioning your element closer to the camera makes them appear bigger. You can also move elements towards the
camera or away from the camera while keeping the same size aspect ratio in the Camera view.
It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in the Top
and Side views—see Top View on page 103, Side View on page 105.
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How to position an element in the Top and Side views
1. To maintain the visual scale in the Camera view as you move your element, do one of the following:
‣

In the Advanced Animation toolbar, select the Maintain Size

‣

From the top menu, select Animation > Tools > Maintain Size.

‣

Press Alt + 6.

tool.

2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from
the Timeline view.
The selected layer is highlighted in the Top, Side and Camera views.

3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the same
in the Camera view.
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4. For your element to scale up or down in relation to their distance to the camera, do one of the following:
‣

In the Tools toolbar, select the Transform
disabled in the Tool Properties view.

tool. Make sure the Peg Selection Mode

‣

In the Advanced Animation toolbar, select the Translate
section of the Top or Side view.

‣

Select a layer from the Timeline view.

option is

tool and select a layer from the thumbnails

The selected layer is highlighted in the camera cone.

5. In the Top view, drag the element sideways to position it horizontally. Hold Shift while dragging the element
to make sure it only moves along the X-axis.
6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging the
element to make sure it only moves along the Y-axis.

Top View
The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see the
scene’s stage from above. This lets the camera cone and the spacing between the elements be seen.
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1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each element’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.
2. The camera cone represents the camera’s position and field-of-view (FOV).
3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
4. There are two view option buttons displayed in the lower-left corner of the view.
‣

Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣

Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that
lets you see all of the scene layers and information in the Perspective view at once.

6. Displays the currently selected layer and drawing name.
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7. Displays the currently selected tool.
8. Displays the currently selected frame of your animation.
9. Displays the currently selected colour in the palette.

Side View
The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a
scene’s stage from the side. This lets the camera cone and spacing between the elements to be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each element’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.
2. The camera cone represents the camera’s position and field-of-view (FOV).
3. The axis reference arrows let you maintain your orientation when navigating in the Perspective view.
4. There are two view option buttons displayed in the lower-left corner of the view.
‣

Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣

Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoom menu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that lets
you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.
7. Displays the currently selected tool.
8. Displays the currently selected frame of your animation.
9. Displays the currently selected colour in the palette.
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Chapter 5: Path Animation

With Harmony, you can animate layers using computer-generated trajectories, create multiplane camera moves and
camera shakes, adjust the easing, shape your paths with control points and much more.
This chapter contains the following topics:
•

Animating a Layer on page 107

•

Differences between Animated Layers and Pegs on page 109

•

Layer Parameters on page 112

•

Adding and Deleting Keyframes on page 115

•

Motion and Stop-motion Keyframes on page 117

•

Animating the Camera on page 121

•

Modifying a Path in the Camera, Top and Side Views on page 124

•

Modifying a Path in the Timeline View on page 129

•

Modifying a Path in the Function View on page 131

•

Modifying a Path in the Xsheet View on page 138

•

Function Curves on page 140

•

Copying and Pasting a Motion on page 143

•

Adjusting the Velocity on page 144

Animating a Layer
Before animating the position of drawing layers, you need to create motion paths which are trajectories on which you
can attach drawing objects. Using keyframes, you can then record key positions along the trajectory.
Harmony’s wide range of features let you produce simple and advanced motions and trajectories. By creating a
simple motion, you will learn the basics of animating a layer.
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The Animate mode lets you keyframe drawing layers to create computer-generated animation. When working in
the Animate mode, you can animate a layer's position and then turn off the mode to reposition a layer for the entire
scene. When the Animate mode is disabled, keyframes are created on selected layers at the current frame.
Depending on what transformations were performed (rotation, translation, skew), the new keyframes are added
on the corresponding parameters (function curves).
How to turn the Animate mode on or off
1. In the Tools toolbar, click the Animate

button or select Animation > Animate.

How to animate a layer
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg Selection Mode
3. In the Tools toolbar, enable the Animate
moving objects.

is deselected.

mode. This will create keyframes at the current frame when

4. In the Timeline view, go to the first frame.

5. In the Camera view, select the element to animate and move it to its first position.

A keyframe is created on the first frame of the Timeline view.

6. In the Timeline view, go to the frame on which you want to set the second position.
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7. In the Camera view, move the element to its second position.

A second keyframe is created on the Timeline view.

8. Play back

your animation.

To see your motion animations in the Top or Side views while you play back, you must turn on the Playback
option. From the top menu, select Play > Enable Playback > Top View or Side View.

Differences between Animated Layers and Pegs
There are two ways to create motion paths: animated drawing layers and pegs. They each have different purposes.
You can create a motion path directly on layers (animated layers).

You can control and define a trajectory using several different parameters, including:
•

X, Y and Z positions (3D Path or Separate Positions)

•

Angle (rotation)

•

Skew

•

X and Y Scales

109

Chapter 5: Path Animation

Each parameter has its own function curve where you can add keyframes and control the easing. If you're not
familiar with graphs and function curves, these are easy-to-use tools for visually controlling trajectories in the
Camera and Timeline views.

By default, you can animate a drawing layer using the same parameters as a peg, but you can choose not to do so
by turning off this feature. This allows you to switch your drawing layers so they can no longer be animated
without a peg, which has certain advantages. In cut-out animation, it's easier to separate drawing exposure and
keyframes to change the timing and rearrange keyframe position in the Timeline view. This also works for
backward compatibility when bringing in templates created in older versions of Harmony so as not to lose their
offset keyframes or drawing substitution keyframes.
If you do not want to animate a drawing layer, you can turn off its animation parameter. To do so, simply select
the layer and in the Layer Properties view, deselect the Animate Using Animation Tools option on the Controls
tab. If your layer was already animated, then your keyframes will appear dimmed so you can easily identify them
as ones that cannot be modified. To modify keyframes, select the Animate Using Animation Tools options.

A Peg layer is a trajectory that contains no drawings on which you can hook your drawings.
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Pegs have been used for a long time in the traditional animation process, mainly for registration purposes. Peg holes
at the bottom or top of the animation paper are used to keep all the sheets even and at the same registration.
There are three peg holes in regular animation paper. The centre peg hole is round while the left and right ones are
oval shaped. The oval peg holes are located on each side of the page, four inches away from the centre peg hole.
To keep the drawings together, the animator uses a peg bar. This peg bar has three pins that correspond to the
shape and location of the peg holes. Peg bars are normally found at the bottom and top of animation discs.
Before digital compositing, the peg bars were also used to move layers on the camera stand to create pans and
camera moves. They were the equivalent of digital trajectories. Harmony makes use of these concepts to create
animation and camera motion.
A peg is composed of many customizable parameters. These parameters are:
•

X, Y and Z positions (3D Path or Separate Positions)

•

Angle (rotation)

•

Skew

•

X and Y Scales

You can control a peg’s trajectory the same way as the animated drawing layer.
A peg layer is mainly used to control a series of drawing layers, such as clouds, a school of fish or a flock of birds.
You can attach them to a peg layer and make them follow a trajectory as a single unit. This makes trajectory
modifications much easier and faster. When building a puppet, most of the time you will add a master peg to control
your puppet as one object.
In the Tool Properties view, the Peg Selection Mode
lets you automatically select the peg layers in the Camera
view instead of the drawing layers. If you animate with pegs instead of animating the drawing layers directly, enable
the Peg Selection Mode to avoid having to select in the Timeline view or use the Select Parent Skipping Effects
command.
How to add a peg in the Timeline view
1. In the Timeline view, select the layer on which you want to attach a peg.

2. Do one of the following:
‣

From the Timeline View layers toolbar, click the Add Peg

‣

From the Timeline view menu, select Insert > Peg.

111

button.

Chapter 5: Path Animation

‣

From the top menu, select Insert > Peg.

The layer that was originally selected becomes a child of the new parent Peg layer. The new Peg layer
automatically takes the name of its child layer, with the addition of the suffix -P.
The indentation of the layer, along with the "L" indicates hierarchy and that the layer is attached to the Peg
layer. This relationship is called a parent-child relationship.

3. If you intend to add multiple pegs or if the layer name that was added to the peg does not accurately represent the content of the Peg layer, you can rename it. Click the layer name and type in a new name. Or
double-click the layer and type a new name into the dialog box.

4. If you did not create your peg layer directly above the layer you intended on parenting it to, then drag the
layer you want to attach to the peg and drop it directly below the Peg layer. The indentation of the layer
below the Peg layer indicates whether it was correctly attached or not.

‣

You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.

How to enable the Peg Selection Mode
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

1. In the Tool Properties view, click the Peg Selection Mode

button.

2. In the Camera view, select an element parented to a peg.

Layer Parameters
A layer is composed of many customizable parameters, such as the X, Y and Z positions, angle (rotation), skew
and scales. Each parameter has its own function which is a mathematical formula expressing the relationship
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between position values. You can view each function on a graph as a simple curve, such as the one below.

There are six options available for setting up function parameters:
‣

Locked Positions (3D Path)

‣

Separate Positions

‣

Locked Scales

‣

Separate Scales

You must select 3D Path, Separate Positions, Separate Scale, or Locked Scale before starting the animation. When
you lock or unlock parameters, this does not convert the functions from one to the other, but creates new ones.
In a 3D Path, the X, Y and Z curves are locked together and controlled by a single velocity function. When you add a
keyframe, it is added on all three trajectories at once, as is the velocity. This is very useful for long, smooth
trajectories.
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When the Separate Positions option is used, the X, Y and Z curves are independent and have velocity controls
directly on their function curve. This is useful when you want to set keyframes on one of the curves without
affecting the others.

When using the Scale parameter, you can use a single function curve to control both the vertical and horizontal
scale, or two separate scales. When using a single function curve, the values are the same for the X (horizontal)
and Y (vertical) axes for uniform size changes without distortion. However, if you separate the scale functions,
you can squash, stretch and skew your elements.
How to display the layer parameters in the Timeline view
1. Do one of the following:
‣

In the Timeline’s left side, click a layer's Expand

‣

In the Timeline view menu, select View > Show Functions.

‣

Press Alt + F.
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How to set the layer parameters
1. In the Timeline view, double-click on the layer on which you want to set the parameter. You can also see the
parameters in the Layer Properties window when you select the layer in the Timeline view.
The Layer Properties window opens.

2. Select the Transformation tab.
3. In the Position section, select the 3D Path or Separate option.
4. In the Scale section, select the Locked or Separate option.
5. Click Close.

Adding and Deleting Keyframes
There are several different ways you can create keyframes. You can add a coordinate keyframe, position keyframe
or a keyframe along with your drawing duplication.
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You can create a keyframe without a drawing. This adds new coordinate points but the drawing in the layer stays
the same. At the same time, you may also want to duplicate your drawing if you need to modify it and do not want
to modify the original.
You can also add a position keyframe instead of a regular keyframe. When you do this, keyframes will only be
added on the X, Y and Z parameters of the selected layer. Keyframes are not added on the Angle, Scale and
Skew parameters.

NOTE: If you select a keyframe in the Timeline view and press the Delete key, you will also delete the drawing
exposure. To only delete the keyframe, you must use the Delete Keyframe command—see Adding and Deleting
Keyframes on page 115.

How to create keyframes
1. In the Timeline view, select the cell on which you want to add a keyframe.

2. Add a keyframe by doing one of the following:
‣

From the top menu, select Insert > Keyframe.

‣

Right-click on the selection and select Insert Keyframe.

‣

Press F6.

‣

In the Timeline View toolbar, click the Add Keyframe

button.

If the Animate mode is enabled in the Camera view, a keyframe is automatically created on the current
frame.

How to create a keyframe and duplicate the drawing at the same time
1. In the Timeline view, select the cell containing the drawing you want to duplicate and add a keyframe.

2. Do one of the following:
‣

From the top menu, select Insert > Keyframe and Duplicate Drawing.

‣

Right-click on the selection and select Insert Keyframe and Duplicate Drawing.

‣

Press F6.

A keyframe and a duplicate of the drawing is created. The duplicated drawing sits on top of the original
drawing.
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How to delete a keyframe
‣

In the Timeline view, select a keyframe and do one of the following:
Right-click and select Delete Keyframes.
In the Timeline view menu, select Motion > Delete Keyframes.
From the top menu, select Animation > Delete Keyframe.
Press F7.

‣

Use the Transform
press Delete.

tool to select a keyframe to delete from the trajectory in the Camera view and

Motion and Stop-motion Keyframes
Interpolation is the computer-generated motion between two keyframes. Some animators and compositors like to
create their own in-betweens, while others like to have the computer do it. Harmony has stop-motion (no
interpolation) and motion keyframes (computer-generated interpolation).
In stop-motion keyframes, there is no computer-generated motion between two keyframes. The segment is constant
or flat. The drawing remains still until the playback reaches the next keyframe, then the drawing pops to its new
location.
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In motion keyframes, there is no automatic interpolation created between the selected point and the next one. The
layer will maintain its position until the animation reaches the frame of the next point and will then jump to the new
position. Deselect this option to generate interpolation and get the layer to progressively move to the next
position.

You can switch a keyframe from stop-motion to motion at any time in the Timeline view and Function Editor.
How to switch between motion and stop-motion in the Timeline view
1. On the right side of the Timeline view, select one or more keyframes to modify.

2. Switch between motion and stop-motion by doing one of the following:
‣

Right-click on the selected keyframes and select Set Motion Keyframes or Set Stop-Motion
Keyframes.

‣

Press Ctrl + K (Windows/Linux) or ⌘ + K (Mac OS X) for motion keyframes and Ctrl + L
(Windows/Linux) or ⌘ + L (Mac OS X) for stop-motion keyframes.

‣

In the Timeline View toolbar, click the Motion Keyframe

or Stop-Motion Keyframe

button.

How to switch between motion and stop-motion keyframes in the Function view
1. Open the Function view.
2. In the Timeline view, double-click on the layer that contains the keyframes you want to convert.
The Layer Properties window opens.
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3. Do one of the following:
‣

In the Transformation tab, click the Function Editor

‣

In the Timeline view, click the Expand Function
function to edit.

button.
button or press Alt + F and double-click on the

4. On the function curve, select one or more keyframes to modify.

5. Select or deselect the Stop-motion Keyframe

button to set a stop-motion or motion keyframe.
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Constant Z
When using a 3D path, the X, Y and Z functions work together using the same keyframes. This allows for the
velocity to control the curve and create a smooth trajectory. Even if a function does not have any variation on its
curve (for example, all keyframes are at zero), the velocity might add a slight motion to ensure a smooth
trajectory. This can cause elements that are very close to each other on the Z-axis to pop in front of one another.
This is why in cut-out animation it is recommended to use separate position settings. But if you work with 3D
path, you can use the Constant Z feature to avoid this from happening.
The Constant Z feature is used when creating motion keyframes. The Z function will use stop-motion keyframes
and will not be interpolated, which can be very useful for cut-out animation. The Constant Z feature only works
with 3D paths.
You can also enable the Constant Z option directly in the Function view for specific functions.
How to enable the Constant Z option
1. In the Timeline view, expand the layer on which you want to set the Constant Z feature. Note that you
must select the 3D Path option for the layer.
2. Double-click on one of the position functions to open the Function editor.
3. In the Function editor, select the Constant Z
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Animating the Camera
In Harmony is a camera that can move along the X, Y, and Z axes. Having the camera move on the Z-axis offers the
possibility to create truck in and truck outs, as well as multiplane camera moves. The default camera position is
centred and backed up to 12 fields.

It is important to understand the coordinate values in Harmony. Harmony's core is based on the origins of animation.
In traditional animation, a scene's size and camera motion are calculated in fields. A field has a 4:3 ratio and
measures 0.5 inches (12.7 mm) in width. A specific grid has been created for this purpose known as a field chart.
Harmony uses this unit of measurement as its coordinate system.
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A field chart uses the cardinal directions. The X axis is the east-west (left-right) direction, the Y axis is the northsouth (up-down) direction and the Z axis is the forward-backward direction.
The camera is treated the same way as any other element. You can use the same tools and selection modes to
offset or animate it, but the camera is a static object. To animate the camera, you need to connect it to a peg
layer. A peg is a trajectory layer.

While making camera moves, you can use the Top, Side, and Camera views.
How to open the Top and Side views
1. Do one of the following:
‣

From the top menu, select Windows > Top or Side.

‣

From any view already open, click the Add View
Side.

button at the top-right corner and select Top or

How to add a camera and parent it to a peg
1. If you don't already have a camera layer, do one of the following:
‣

From the top menu, select Insert > Camera.

‣

From the Layers toolbar, click the Add Layers

button and select Camera.

A new camera layer is added to the scene and appears in the Timeline view.
2. In the Timeline view, select the Camera layer.

3. From the Layers toolbar, click the Add Peg

button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it.
The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a
Peg layer, for example Camera-P.
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If the new Peg layer did not appear directly above the camera, you may have clicked elsewhere in the scene,
which deactivated the layer on which you want to add the Peg layer. To fix this:
‣

Select the Camera layer and drag and drop it under the new Peg layer. Or delete the misplaced Peg layer,
select the Camera layer and click the Add Peg
button again.

‣

You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.

How to animate the camera
1. In the Tools toolbar, enable the Animate
2. In the Tools toolbar, select the Transform

mode.
tool or press Shift + T.

3. On the right side of the Timeline view, on the Camera Peg layer, select the frame at which you want the camera move to start.
4. Do one of the following:
‣

In the Timeline toolbar, click the Add Keyframe

‣

Right-click and select Insert Keyframe.

‣

Press F6.

button.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as this keyframe.
5. In the Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the desired position. In the Camera view, the camera is represented by a thin frame. You need to click directly on one of the
edges.
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6. On the Timeline view, click on another cell a bit further down in time to indicate where the camera move
will end.
7. Select the camera in the Camera, Top or Side view and move it to the desired position.

A second keyframe appears and a line is created between the two frames to indicate that the subsequent
motion between the frames will be calculated and rendered by the program.
8. Play back

your animation.

Modifying a Path in the Camera, Top and Side Views
Camera moves and motion paths can become quite advanced, especially with moves through 3D space.
Harmony provides tools to view your camera’s path and make adjustments to it from both a 2D and 3D
perspective.
You can display the trajectory of a motion path when you select an object in the Timeline or Camera view.
A motion path is easy to manipulate. One important concept to understand is that a trajectory contains both
keyframes and control points. Both can be used to shape a path; each have their own significance and behaviour,
however only keyframes appear in the Timeline view.
•

Keyframes have a transformation value and a position in space at a given frame. Keyframes are locked in
time.

•

Control points have a position but no fixed frame or timing. It is mainly used to deform a trajectory. There
are no velocity handles available on a control point. The velocity segments are set between keyframes
only, making curves and trajectories much smoother. Control points can only be added on a 3D path.

You can set the default Continuity, Bias and Tension parameters in the Preferences panel.
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Continuity: Controls the smoothness of a transition between the segments joined by a point.

Tension: Controls how sharply the path bends as it passes through a control point or keyframe.

Bias: Controls the slope of the path so it flows towards one side of the motion point or the other.

When you select a control point on a path, you can switch between a rounded or square corner by using the
Linear/Curve command.
How to view the layer’s trajectory using the Control command
1. Verify that the Camera view (click its tab) is selected and that the layer whose trajectory you want to display
is selected in the Timeline view.
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2. From the top menu, select View > Show > Control or press Shift + F11.

NOTE: If nothing appears in the Camera view, you may not have animated or selected the layer.

How to add a control point on a trajectory
1. In the Timeline or Camera view, select the peg or layer on which you want to add a control point.
2. If the selected element’s trajectory is not displayed, select View > Show > Control from the top menu or
press Shift + F11.
The trajectory appears in the Camera, Top, Side and Perspective views.
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3. Add control points on a 3D path trajectory by placing the cursor where you want to add the point and press P
once. If you hold the key down, control points will be added continuously until you release the key.

How to switch between keyframe and control point
1. In the Camera view, use the Transform

tool select a point to convert.

2. To convert the point:
‣

From the top menu, select Animation > Lock in Time.

‣

In the Function view or Function Editor, select the keyframe to convert and click the Lock in Time
button.
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How to adjust the control point preferences
1. From the top menu, select Edit > Preferences (Windows) or Stage Essentials > Preferences (Mac OS
X).
The Preferences dialog box opens.
2. Select the Camera tab and adjust the parameters in the Control Points section.

Offsetting a Trajectory
By offsetting a trajectory, you reposition the visual trajectory without offsetting or modifying your animation. By
default, the trajectory is located at 0,0,0 fields. If your elements were drawn in a different location than the centre
of the drawing area, it will look like the trajectory is not aligned with your drawing. Also, if you have several
elements attached to one trajectory, you might want your trajectory to be at a different location to represent the
group's motion better.
How to offset a trajectory
1. In the Animation Tools toolbar, select the Spline Offset

tool or press Alt + 8.

2. In the Camera, Top, Side or Timeline view, select the layer whose trajectory you want to offset.
3. From the top menu, select View > Show > Control to display the trajectory. If you do not display the trajectory, any transformation done using the Spline Offset tool will be ignored.
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4. In the Camera view, drag the trajectory to the proper position. You can move it on the X and Y axes, but also
on the Z-axis using the Top and Side views.

Modifying a Path in the Timeline View
When you select a peg or drawing layer in the Camera view and move it around, Harmony will automatically create
keyframes on the corresponding function curves. If you want to modify these curves, you can do it through the peg
or drawing layer parameters in the Timeline view.
Harmony lets you also flip between the selected layer's keyframes in the Timeline view.
How to create the function curve in the Timeline view
1. In the Timeline view, expand the layer's parameters.
2. Click the Function button and, in the drop-down menu, select Create Bezier.
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How to add a keyframe in the Timeline view
1. On the right side of the Timeline view, select a cell on the layer’s function that you want to animate.

2. Do one of the following:
‣

Right-click the selected cell and select Insert Keyframe.

‣

Press F6.

‣

In the Timeline View toolbar, click the Add Keyframe

button.

How to delete a keyframe in the Timeline view
1. On the right side of the Timeline, select a keyframe to delete. You can [Shift]+click several keyframes to
select a group before deleting the keyframes.
2. Do one of the following:
‣

Right-click on the selected keyframe and select Delete Keyframes.

‣

Press F7.

‣

In the Timeline View toolbar, click on the Delete Keyframes

button.

NOTE: If you select a keyframe or group of keyframes and press Delete, the corresponding drawings on that cell
are also deleted.

How to change the keyframe values in the Timeline view
1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand
+ F.
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2. Select the parameter for which you want to create a function curve.
1. Place the cursor over the blue number value of the parameter and do one of the following:
‣

Wait until the cursor changes to a white hand with a two-way arrow and then drag the hand left to
decrease the value or right to increase the value.

‣

Double-click on the blue number and enter a value in the field.

How to flip through keyframes
1. In the Camera or Timeline view, select the layer that contains the keyframes you want to flip through.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or press semicolon (;) and single quote (').

Modifying a Path in the Function View
If you are accustomed to using graphs and function curves, you can use the Function view to define trajectories.
The graph in the Function view displays the motion over the first and last keyframes set in the scene, as well as any
keyframes created between. If the scene is 60 frames, but the character's motion ends at frame 40, then the editor
will only display up to frame 40.
The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and editing
keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in the
background as a reference.
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How to display functions in the Function view
1. Open the Function view.
The Function view is blank until you select the layer containing the functions you want to display.
2. To display a function in the Function view, click on the layer containing the functions to adjust in the
Timeline view.
3. To select the functions you want to edit, select them in the Function list.

Parameter

Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed.
You can hide the grid, disable the synchronization with the current frame, reset
the zoom level and normalize the function display by stacking them one over
the other to compare them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Interpolation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve,
adjust the segments to motion or stop-motion keyframes and set the velocity
to create steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe values are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe.
The more the handle is pulled out horizontally, the slower the animation will be.
The more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section
of a curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can
be referenced to know the current frame of a keyframe.

How to edit a function in the Function view
1. In the graph of the Function editor, select a white keyframe.
The keyframe turns red and displays a pointed yellow handle.
2. Drag the point up or down, or click and pull one of the handles to adjust the curve of the graph.
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In the example above, changing the velocity from a straight line (constant velocity) to a curved one
changes the ease-in (where the curve shoots up and then flattens out) and ease-out (where the curve
flattens out and then shoots up) values.
The centre keyframe cannot be dragged up or down because the velocity is set. Theoretically, dragging it
downwards towards zero would put it back to a place of nonmovement.
3. Press the Enter/Return key with the editor still open to watch the result of your curve adjustment in the
Camera view.
How to add or delete keyframes in the Function editor
1. In the Timeline view, open the drawing or layer’s parameters by clicking the Expand
+ F.

button or press Alt

1. Double-click on the parameter layer name to open the Function editor window or click once on the parameter layer to display it in the Function view.
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2. Do one of the following:
‣

In the graph section, click on the frame number where you want to make changes.

‣

In the Frame field, enter the frame number.

In the graph, the vertical red line moves to the frame number.
3. Do one of the following:
‣

In the Function editor, click the Add/Remove Keyframes

‣

In the Function view, click the Add Keyframe

button.

and Delete keyframe

buttons.

4. Click on the newly created keyframe and drag it up (to decrease the width of the object) or down (to increase
the width of the object) or pull on the handles to create a smooth fluctuation of the drawing object's width.
5. If you do not like the changes you just made, select and delete the new keyframe by pressing Delete or clicking the Add/Remove Keyframes
button.
You can delete an existing keyframe by using the same process.
How to change a keyframe value in the Function view
1. In the Timeline view, open the peg element's parameters by clicking the Plus
name.
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2. Double-click on the parameter layer name to open the Editor window or click once on the parameter layer
to display it in the Function view.

3. In the Value field, enter a value. You can also drag the keyframe up or down in the graph.
4. Press Enter/Return or click the Play

button to view the changes made in the Camera view.

5. Keep adjusting the values until you're satisfied with the results.
6. Click Close.

Function View
The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and
editing keyframes, as well as adjusting the velocity. The Function view allows you to display multiple functions in
the background as a reference.
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How to display functions in the Function view
1. Open the Function view.
The Function view is blank until you select the layer containing the functions you want to display.
2. To display a function in the Function view, click on the layer containing the functions to adjust in the Timeline
view.
3. To select the functions you want to edit, select them in the Function list.

Parameter

Description

Function List

When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
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don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed. You
can hide the grid, disable the synchronization with the current frame, reset the
zoom level and normalize the function display by stacking them one over the
other to compare them regardless of their value range.

Current Frame

Displays the current scene frame.

Selected Keyframe Value

Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Interpolation Options

This toolbar lets you add and delete keyframes, adjust the velocity curve, adjust
the segments to motion or stop-motion keyframes and set the velocity to create
steps instead of a constant progression.

Function Types

This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale

Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe

The selected keyframe is displayed in red. When selected, the keyframe values
are displayed in the corresponding fields.

Bezier Handles

The Bezier handles let you adjust the ease in and ease out of each keyframe. The
more the handle is pulled out horizontally, the slower the animation will be. The
more the handle is pulled out vertically, the faster the animation will be.

Function Curve

The thin line going from keyframe to keyframe is the actual curve. The section of
a curve located between two keyframes is called a segment.

Frame Scale

The Frame Scale displays the frame range for the displayed editing area. It can be
referenced to know the current frame of a keyframe.

Modifying a Path in the Xsheet View
If you are prefer working with the Xsheet view, you can also create keyframes and type values in the Xsheet
view.
You cannot create function curves directly in the Xsheet view. You must do this in the Layer Properties window or
the Timeline view.
To edit a function column in the Xsheet view, you must first display the Functions section of the Xsheet view and
then select the layer you want to modify. If you double-click on a function column's header, you will display the
corresponding function curve in the Function editor.
How to display the function columns in the Xsheet view
1. In the Xsheet view, click the Expand button located on the right side of the main section to show the Functions section.
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2. In the Timeline view, select the layer that contains the parameters to modify.
The columns appear in the Xsheet view if function curves were previously created by adding keyframes in the
Xsheet view or Layer Properties window. Otherwise, the columns do not appear.

How to add a keyframe in the Xsheet view
1. In the Xsheet view, go to the function column on which you want to add a keyframe.
2. Double-click on the cell on which you want to add a keyframe and type a numeric value.

3. Press Enter/Return to continue to the next cell.
4. Press Esc to exit the typing mode.
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How to convert a cell into a keyframe
1. In the Xsheet view, go to the function column on which you want to add a keyframe.
2. Select the cell to convert.

3. Right-click on the cell and select Set Selection As Keyframe or press F6.

4. To remove a keyframe, select the keyframe, right-click on the cell and select Clear Keyframe in Selection or press F7.

Function Curves
By default, when a drawing layer or peg is added to a scene, no function curves are created. You will generally
create the ones you need to avoid being overloaded with too many functions you might not use.
When you select an element in the Camera view and move it around, it will automatically create the
corresponding function curves. If you need to create certain functions manually, you can always do it through the
Layer Properties view or editor. You can then share it with other layer parameters or set keyframes directly on the
function curve instead of doing it in the Timeline or Camera view.
You can also link a layer's parameter to an existing function curve or attach several parameters to the same
function curve. For example, if you have an aircraft performing loops between clouds, you may want the camera
to follow the aircraft's motion path. If you attach the camera to the aircraft's layer, the camera will also loop, but
this may produce undesirable results and even induce a feeling of motion sickness as you watch the final
animation. Instead, you can share the X, Y and Z positions of the aircraft with the camera's peg layer, but ignore
the angle, scale and skew.
By default, all function curves can only be used and modified using their original parameter. If you want another
layer or parameter to use the same function curve, you must share it.
There are two ways to share a function:
•

Share Functions command

•

Layer Properties editor

When you create a function curve in the Layer Properties view or editor, there are several choices available:
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Parameter

Description

Create 3D Path

Creates a new 3D Path Column set

Create Bezier

Creates a new Bezier curve

Local

Disconnects the parameter from any function and changes it to shared.

3D Path

Displays the list of every shared 3D Path function available

Bezier

Displays the list of every shared Bezier curve available

Velobased

Displays the list of every shared velocity based curve available

3D Rotation

Displays the list of every shared 3D Rotation function available

Connected

Displays the list of every shared connected function curve

Unconnected

Displays the list of every shared unconnected function curve

All

Displays the list of every shared function curve

You have the choice of creating a new function curve or linking it to a shared function. This way, you can have two or
more parameters following the same function.
Depending on your favourite working method, you can create different types of function curves to suit your needs,
including:
•

Bezier function

•

Velobased function

When you create a function to control a parameter over time (Scale, X, Y, Z, Rotate), you can use a Bezier function.

These function editors present different ways of editing the values over time. The shape of the created graph
indicates the velocity of the function, regardless of the chosen editor. The type of function that you choose is largely
based on your working preference.
You can also create Velobased functions for certain effects, like changes in rotation or size over time. When you do
this, the Velobased functions are linked to the velocity of a 3D path. You cannot change the shape of a Velobased
function to control its velocity.
With Velobased functions, you can link changes in rotation or scaling to the velocity of a 3D path. This makes it
possible for changes in rotation or scaling to progress at the same speed as changes to the position of an element.
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You can convert a Bezier functions so you can edit it using the controls offered by that type of function.
How to create function curves
1. In the Timeline view, double-click on a layer.

The Layer Properties Editor opens.

2. In the Transformation tab, click the Function Arrow button beside the local function information.
3. Create a 3D Path, Bezier, or Velobased curve.
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You can click the Function

button to open the Function editor.

Copying and Pasting a Motion
In the Timeline view, you can easily drag keyframes to change the animation timing, delete them, cycle them and
even copy them.
When you have position keyframes set in your drawing layer and you want to move them around when moving your
drawing's timing, you can use the Paste Special feature to only move selected keyframes.
You can also use the Paste Cycle and Paste Reverse feature to cycle your selection including keyframes and
drawings.
If you want to cycle a portion of your animation, you can use the Paste Cycle command. You can also use the Paste
Reverse command to completely reverse the flow of your animation.
How to copy and paste a motion using Paste Special
1. In the Timeline view, select the keyframes to copy and paste. If you want to move the keyframes, go to step
3.

2. From the top menu, select Edit > Copy Cells from the Timeline or press Ctrl + C (Windows/Linux) or ⌘ + C
(Mac OS X).
3. Edit your selection by doing the following:
‣

To paste the selection, in the Timeline view, select the first cell on which you want to paste your
keyframes and from the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ +
B (Mac OS X).

‣

To move the selection, in the Timeline view, drag the selection and hold down Alt (Windows/Linux) or ⌘
(Mac OS X). Drop the selection where you need it and release the hot key.

The Paste Special window opens.
4. Set the Drawing, Pegs and Functions, and Cycles parameters.
5. Click OK.
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How to open the Paste Special dialog box
1. In the Library view, select the symbol or template to import.
2. While dragging the selection to the Timeline view, hold down the Alt (Windows/Linux) or ⌘ (Mac OS X).
Drop the selection in the Timeline view before releasing the hot key.
The Paste Special window opens.
3. Set the parameters.

Paste Special Options

Adjusting the Velocity
To add ease in and ease out on motion paths, you can display the function curve and modify the Bezier or Ease
curve. To apply ease to multiple functions and keyframes, you can use the Set Ease For Multiple Parameters
script and set the amount.
The Velocity, or ease, is used on motion keyframes. The Velocity must be adjusted directly on the function curve
in the Function view or Function editor. When a keyframe is selected, easing values appear in the right handle and
left handle fields, as well as Bezier handle or Ease wheel controls on each selected keyframe. Pull on them to
adjust the ease in and ease out, or type values in the fields.
You can reshape the velocity function using Bezier controls.
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You can create a stepped curve to hold the same value over a selected number of frames. This works well when you
are animating drawings on 2s, for example, and you want to hold the same value for a function over those two
frames.
If you have several functions whose velocity you want to adjust at the same time, you can use the Set Ease for
Multiple Parameters dialog box. It allows you to apply the same velocity parameters to all the selected keyframes in
the same frame.
How to display the velocity curve
1. In the Timeline view, click the Expand

button on a layer or press Alt + F.

The layer’s functions are displayed.

2. Double-click the desired function.

The Function Editor opens as the Bezier Editor.
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The editor will not be displayed if the function does not already exist. You can reshape the function using
the Bézier controls.

How to reshape a function using Bézier controls
1. Select a keyframe.
2. Drag the handles to modify the shape of the curve.
3. The Continuity options influence how you can move the handles:
‣

Straight: Lets you move the handles together, maintaining the same angle to the point.

‣

Corner: Lets you move the handles independently.

‣

Smooth: Lets you move the handles together, maintaining the same distance and angle to the point.

How to reshape the function using Ease controls
1. Select a keyframe.
2. To set the number of frames in the ease-in, press Alt, click to the right of the keyframe and drag the green
line. The ease in slope is indicated in blue.
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As you change the values visually, the value in the Ease In field is updated. This value represents the number
of frames in the ease-in.
3. To set the number of frames in the ease-out, press Alt, click to the left of the keyframe and drag the green
line. The ease-out slope is indicated in red.
As you change the values visually, the value in the Ease Out field is updated. This value represents the
number of frames in the ease-out.
4. To adjust the ease-in or ease-out, drag the handles around the keyframe.
The Continuity options, Corner and Straight, influence how you can move the handles:
‣

Straight: Lets you move the handles together, maintaining the same angle to the point.

‣

Corner: Lets you move the handles independently.

How to hold the same value over several frames
1. Click the Hold Value Editor

button.

The Hold Value editor opens.

2. In the Hold Value Editor, enter the following values:
‣

Start: The starting frame for the effect.

‣

Stop: The last frame for the effect.

‣

Step: The number of frames to hold the value.

The function curve is updated based on the values you entered.

You can reshape the curve to create a linear velocity, so the values are interpolated (tweened) consistently
between keyframes. That is, there is no acceleration in the effect.
How to set the ease on multiple parameters
1. In the Timeline view, select a keyframe on one or more layers.
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NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter
function. If many keyframes are selected on the same layer, the ease values will be applied only on the first
keyframe and the rest will be ignored.

2. Do one of the following:
‣

In the Timeline view, right-click and select Set Ease For Multiple Parameters.

‣

In the Timeline toolbar, click the Set Ease For Multiple Parameters

button.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph, adjust the Bezier handles to change the velocity for all the selected functions.

4. In the Filters section, you can apply the easing parameters to a specific type of function only, such as
Rotation or Scale. Deselect the function types you do not want to affect.
‣

Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions.

‣

Rotation: Applies the easing parameters to the selected Angle functions.

‣

Scale: Applies the easing parameters to the selected Scale functions.

‣

Skew: Applies the easing parameters to the selected Skew functions.
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‣

Morphing: Applies the easing parameters to the selected Morphing Velocity functions. Note that it
applies to the Morphing velocity function found in the Layer Properties window, not the basic morphing
ease in the Tool Properties view.

‣

Other: Applies the easing parameters to all the other the selected functions, such as all functions created
to animate effect parameters.

5. You can also adjust the easing by typing values in the Time and Value Ratio fields. The values are calculated
in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the length
of time you want the easing to last. Stay between 0% and 100%. If you go beyond 100%, your motion will
overshoot.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you want the
easing out to be. Stay between 0% and 100%. If you go beyond 100%, your motion will overshoot.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following:
‣

Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the previous
keyframe in the timeline.

‣

Apply: Applies the easing parameters to the selected keyframes.

‣

Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣

Close: Close the dialog box. If you did not apply the modifications, they will be cancelled.

How to set the ease in the Timeline view
1. In the Timeline view, select a keyframe on one or more layers.

NOTE: Only the first selected keyframe will be considered when using the Set Ease For Multiple Parameter function.
If many keyframes are selected on the same layer, the ease values will be applied only on the first keyframe and the
rest will be ignored.

2. In the Timeline toolbar, select an option from the Set Ease Type menu.
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NOTE: TIP: Optimize your workflow by adding the Apply Ease to Selection
button to the Timeline toolbar. This
lets you quickly reapply the ease type without going through the Set Ease Type menu each time. To add the button
to the toolbar, right-click on the toolbar area of the Timeline view and select Customize.
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Chapter 6: Sound

With Harmony, you can import soundtracks and dialogue into your animation.There are several sound editing
features you can use to synchronize sounds to individual frames or moments in time. You can also edit them to trim
unwanted seconds from the beginning and end of your sound files, as well as loop sounds that you want to continue
throughout your animation.
Your ability to add dialogue to animation is greatly enhanced with the Harmony automatic lip-sync detection.
Harmony can analyze voice tracks to determine which of the eight animation phonemes (lip positions) would best
apply to each frame of sound. With the mouth chart that is generated, you can easily draw lip positions for your
character. Furthermore, Harmony can automatically apply drawings of lip positions to each frame of your animation
based on the mouth chart.
This chapter contains the following topics:
•

Importing a Sound File on page 151

•

Sound Layer Properties and Sound Element Editor on page 152

•

Sound Displays on page 153

•

Sound Playback on page 154

•

Sound Scrubbing on page 155

•

Editing a Sound File on page 156

•

Adding an Empty Sound Layer on page 164

Importing a Sound File
If you decide to add sound to your animation, you must first prepare the sound outside of Harmony. Once this is
done, you must add a sound element in Harmony to the organize the sound files in your animation. Sound will play in
the movie until it reaches the end of the file or a stop frame that you created in the Sound Element Editor.
If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the different scenes for you
automatically.
You can import .wav, .aiff or .mp3 sound files.
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How to import a sound file
1. Do one of the following:
‣

From the top menu, select File > Import > Sound.

‣

In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

The Select Sound File dialog box opens.
2. From the Select Sound File dialog box, find and select a sound file.
The sound file appears as a layer in the Timeline and Xsheet views.

Sound Layer Properties and Sound Element Editor
When you select a sound layer in the Timeline view, the options related to that layer appear in the Layer
Properties view and in the Sound Element editor when you double click on the layer.
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•

Mute/Unmute: This button mutes and unmutes the sound layer during the scene play back.

•

Layer Name: This field displays the layer's name.

•

Sound Editor: This button opens the Sound editor.

•

Start Frame/End Frame: These fields determine the start and end frame of the sound file.

•

Detect: This button launches the automated lip-sync detection.

•

Map: This button opens the Map Lip-sync dialog box.

•

Mouth Shapes: This section shows the automated lip-sync detection during the scene play back. Click on the
thumbnail image of each mouth to change the phoneme assigned to the current frame.

Sound Displays
Within the Xsheet view, you can display the sound file in different ways, depending on your sound editing needs.
You can show or hide the waveform in the Timeline view by selecting the Waveform
button in the Timeline View
toolbar. You must customize the toolbar to display this button because it is not included in this toolbar by default.
How to change the sound display in the Timeline view
1. In the Timeline view's right area, right-click in the frame section and select Show Sound Waveforms.
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‣

You can change the waveform scale using the Zoom Waveform
the Timeline view's left side.

icon on individual sound layers in

How to change the sound display in the Xsheet view
1. Right-click in the sound column or on the sound column header, and select Sound Display and one of the
following:
‣

Sound Name: Shows the name of the sound file, as well as the file format. The line running vertically
through the column frames between the same file name indicates a continuity of the same sound file in
these frames.

‣

Mouth Shapes: Shows the letter (or name depending on the way you named your character's different
mouth positions) in the column's frames. There is only one mouth position allotted per frame and this
position should correspond to the sound file after performing a lip-sync.

‣

Waveform: Shows a vertical display of the sound file's actual waveform. In the column header, in the
field under the column name, you can type in a percentage to zoom in or zoom out on the waveform, or
pass the scroll cursor
over the Zoom Waveform
icon.

Sound Playback
Before playing back any sound, click the Enable Sound
button in the Playback toolbar or enable it through the
Play menu (in the top menu). This will ensure that you can hear the sound layers in your scene, even the ones
included within symbols.
If there are two or more sound layers and you want to listen to them independently, you can disable the unwanted
sound by clicking the Disable Layer
button on the sound name layer in the Timeline view.
If you are trying to do a playback with sound and the frame rate doesn't reach 24 fps (frame per second), you can
do one of the following to troubleshoot the issue:

154

Harmony 12.2 Essentials - Compositing and Effects Guide

l

l

Shrink down the Camera view size to reduce the cached image size.
Playback your scene without sound first, then add the sound. If you do not cache the imahes first without
sound, the playback will try to follow the sound by skipping images that will never get cached.

How to play back sound
1. To select a starting point:
‣

In the Timeline view, click on a cell in the sound layer. You can also slide the red playhead to the correct
cell.

2. In the Playback toolbar, activate the Enable Sound

button.

3. Do one of the following:
‣

Click the Play

button in the Playback toolbar.

‣

From the top menu, select Play > Play or click on the Enter/Return key.

4. To hear the sound played back again and again, do one of the following:
‣

Click the Loop

button in the Playback toolbar

‣

From the top menu, select Play > Loop.

5. To mute soundtrack, on the left side of the sound layer, click the Disable Layer

button.

Sound Scrubbing
Harmony uses a process known as Sound Scrubbing to let you hear sound in real-time while you move the playback
pointer forward or backward. This is very useful for finely-tuned lip-synching. You can scrub sounds from the
Timeline view.
How to scrub a sound from the Timeline view
1. Do one of the following:
‣

From the top menu, select Play > Enable Sound Scrubbing.

‣

Right-click in the frame bar of the Timeline view and select Play > Enable Sound Scrubbing.

‣

In the Playback toolbar, enable the Sound Scrubbing
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2. At the top of the Timeline view, drag the red playhead to hear the sound at each frame.

3. In the Playback toolbar, you can use the jog slidder to playback forward and backward subsequent sound
frames. This allows you to do a more fluid scrubbing.

Editing a Sound File
Now that you have successfully imported a sound file into Harmony, it is time to familiarize yourself with the
sound editing interface. The Sound Element editor makes it possible to edit sounds that were created outside of
Harmony and imported into your scene.
How to open the Sound Element editor
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
The Sound Element Editor dialog box opens.
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The Sound Element editor consists of three main parts.

‣

Sound Element: The waveform in the Sound Element Editor is the actual sample that will be heard when
the final movie is rendered. It may be shorter than the original sound sample due to the length of the
scene. If any edits are made to the sound sample, they can be heard here. In the Sound Element panel,
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notice the coloured tabs that indicate the start and end frames of a sound segment. The frame number
is displayed in the tab.
‣

Current Sound: Displays the original sound file in its entirety and is where you can edit its properties.
This window remains empty until you click inside the Sound Element Editor.

‣

Lip-sync Preview: Lets you preview the automated detection and to manually insert different mouth
positions to correspond with the sound sample.

You can accomplish the following tasks in the Sound Element Editor:
•

Changing the Start or End Frame of a Sound on page 158

•

Trimming the Start and End of a Sound File on page 160

•

Looping a Sound on page 161

•

Mixing the Sound Volume on page 162

•

Customizing the Playback Range on page 163

Changing the Start or End Frame of a Sound
To synchronize the sound with specific images in your scene, you must set a start frame for your sound. To make
sure the sound ends by a certain frame, you must set an end frame.
In the Sound Element panel you will see some coloured tabs, these tabs represent the frames. The frame number
is shown inside the tab flag marker. These tabs indicate the start and end frames of a sound segment.
How to change start or end frame of a sound
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one
sound section from another on the same sound layer, check the frame numbers that appear on tabs
flanking the start and stop lines of each waveform section.
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Click the Play

button in the Current Sound section (only the selected sound plays).

1. Within the Sound Element panel, drag the selected clip to the frame number where you want it to start playing.

You can only move the clip to a section that does not already contain a clip; you cannot overlap two clips in
the same element.
2. To change the end frame, drag the yellow marker at the end of the waveform to the frame position.
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3. To hear how all the clips fit together in the element, click the Play
tion.

If you only want to hear the selected clip, click the Play

button in the Sound Element sec-

button in the Current Sound section.

4. Click Apply/Next.
The Xsheet and Timeline views display the sound clip at the start frame you selected.

Trimming the Start and End of a Sound File
To play only a section of a sound file, use the Sound Element editor to select the exact part you want to use. For
example, if there is a bit of noise at the start of the sound, use the Sound Element editor to cut the noise.
The Sound Element Editor does not change the original sound file; it only plays a section of it, ignoring the rest.
This means that the entire sound file is included on export. If you need to be mindful of file size, it is better to edit
sound files completely in a sound editor before bringing them into Harmony.
How to trim the start and end of a sound file
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
2. In the Sound Element editor, select a sound sample from the Sound Element section. To distinguish one
sound section from another on the same sound layer, check the frame numbers that appear on tabs
flanking the start and stop lines of each waveform section. Or select a soundwave and click the Play
button in the Current Sound panel (only the selected sound plays).
1. Using the Current Sound section, decide on the part of the file you want to play by dragging the left and
right boundaries of the selection area.
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2. Click the Play
button in the Current Sound section to check that you have trimmed the desired sections.
Use the Zoom slider at the bottom of the panel to zoom in on the waveform so you can trim it more accurately.

3. Click Apply/Next.
The trimmed sound sample appears in both the Timeline and Xsheet views at the start and end positions you
selected.

Looping a Sound
To repeat a sound, specify the number of times that you want it to loop in the Sound Element editor.
How to loop a sound sample
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
1. From the Sound Element section, select the sound section you want to loop.
2. In the Current Sound section, type the number of times you want the sound to play in the Number of Loops
field.
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3. Press the Enter/Return key.
The looped sound appears after the current sound. They are indicated by their grey waveforms, as
opposed to black.
When you loop a sound, the looped sections fill the cells in the sound element (column or layer) until the
next sound sample starts or until the scene ends. This means that the looping could be cut if the next
sound sample starts too soon or if the scene ends too quickly.

Mixing the Sound Volume
You can adjust the volume of an entire sound clip or modify the volume in increments by adjusting the fade-in and
fade-out times, otherwise known as sound envelopes. The fade edit only affects the playback; the original sound
file is not affected.
How to adjust the overall volume of the entire sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
1. In the Sound Element section, select the sound you want to work on.
A more detailed version of the selected sound appears in the Current Sound section.
2. In the Current Sound section, use the Volume slider to adjust the volume.

3. Click the Play

button in the Current Sound panel to verify the volume.

How to create the fade in/out effect on a sound clip
1. Double-click on the sound layer name in the Timeline view or the sound column header in the Xsheet view.
1. In the Sound Element section, select the sound you want to work on.
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2. In the Current Sound section, click on the thin blue line above the waveform to add an envelope marker.

3. Drag the envelope markers to adjust the volume at that frame and to create the time of the transition. The line
from the edge of the clip to the envelope marker identifies how the volume increases (fades-in) or decreases
(fades-out) over time.
Dragging the marker to the bottom of the channel mutes the volume, while dragging it upwards increases the
volume.

NOTE: To create an even effect, be sure to adjust the envelope markers uniformly in both the left and right (bottom
and top) channels.

4. Click the Play

button in the Current Sound panel to check the fade envelopes.

Customizing the Playback Range
To hear a specific section of the sound element, adjust the playback range in the Sound Element editor to start or
stop at specific frames. This customized playback range does not affect the actual sound in the Sound element.
How to change the playback range in the Sound Element editor
1. Drag the start or end range markers in the Sound Element section to the boundary frames you want.
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2. When you click the Play
button to play back your sound in the Sound Element editor, it only plays the
sound which exists between the two markers.

Adding an Empty Sound Layer
When performing sound editing tasks, it can be useful to chop up a sound sample into different layers. For
example, when performing a lip-sync, only a single view of the various mouth positions for a character can exist
on one layer. Therefore, if you want to have a character turn its head from a profile view to a three-quarter view
and have mouth position changes to fit with the sound sample from these two different views, you would need to
cut up the sound samples needed for the profile view mouth positions on one layer and the sound samples needed
for the three-quarter view on another.
For this task, you will need an empty sound layer.
How to add an empty sound layer
1. In the Timeline Layer toolbar, click the Add Layer button.
2. From the drop-down menu, select Sound.
An empty (silent) sound layer appears in both the Timeline and Xsheet views.

3. Rename the layers accordingly by double-clicking on the layer name and renaming it in the Sound Element
editor. Click Apply/Next to accept the change.
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1. In the sound file you want to grab sounf frames from, click the cell where you want to start the cut and Shift +
click on the final cell of the cut. The sample to be cut becomes highlighted.

2. Drag the selection into the empty sound layer below.

4. You can now continue to cut-up and distribute the sound sample between the two layers or carry on to the lipsynching process for each layer and its corresponding facial view.

NOTE: If you need to duplicate your sound layer to keep an unedited copy for safety, select the Duplicate Selected
Layers button in the Timeline View toolbar. You must customize the toolbar to display this button because it is not
included in this toolbar by default.

Lip-sync
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Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for
silence).
The mouth shapes used by Harmony are based on the conventional mouth chart used in the animation industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

NOTE: If you are doing cut-out animation, refer to the Cut-out Animation Guide, Character Building chapter,
"Adding Extra Drawings" topic to learn how to add extra drawings to your character.

Here is an approximation of the sound each mouth shape can produce:
•

A: m, b, p, h

•

B: s, d, j, i, k, t

•

C: e, a

•

D: A, E

•

E: o

•

F: u, oo

•

G: f, ph

•

X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.
You can refer to the mouth chart positions as you draw the shape of the character's mouth.
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Generating a Lip-sync Detection
There are several places where you can perform a lip-sync detection: Layer Properties view, Timeline view, Xsheet
view and Sound Element editor.
How to generate a sound detection for lip-sync using the Layer Properties view
1. In the Timeline or Xsheet view, select the sound layer.
The options for that layer will appear in the Layer Properties view.
2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.
3. Click the Map button to open the Lip-Sync Mapping dialog box.
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4. From the Destination Layer menu, select the layer that contains the mouth positions for the character's
voice track.

5. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-down menu.
6. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.
7. Click OK.
8. Press the Play
button in the Playback toolbar to see and hear the results in the Camera view. To play
back your scene with sound, enable the Sound
button in the Playback toolbar.
How to generate a sound detection for lip-sync in the Xsheet or Timeline view
1. Do one of the following:
‣

In the Xsheet or Timeline view, right-click on the sound layer's cells and select Lip-Sync > Auto LipSync Detection.

‣

From the top menu, select Animation > Lip-Sync > Auto Lip-Sync Detection.

Harmony analyzes the selected sound clips and assigns a lip-sync letter to each frame.
How to generate a sound detection for lip-sync using the Sound Element editor
1. Do one of the following:
‣

In the Timeline view, double-click on the sound layer.

‣

In the Xsheet view, double-click on the sound column header.

The Sound Element editor opens.
2. In Sound Element section, select the waveform for which you want to generate a mouth chart.
3. Right-click on the sound file and select Auto Lip-Sync Detection.
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A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

Mapping the Lip-Sync Detection
Harmony can automatically map drawings in an element to the mouth chart you have generated for a sound. This
can save time when you are lip-synching a voice track.
In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically labels all
of the cells in the character's element with the appropriate name.
How to automatically map lip-sync drawings to a mouth layer
1. To open the Lip-Sync Mapping dialog box, do one of the following:
‣

In the Layer Properties view, click on the Map button.

‣

In the Timeline view, right-click on any cell in the sound sample layer and select Lip-Sync > Map LipSync.

‣

From the top menu, select Animation > Lip-Sync > Map Lip-Sync.

The Lip-Sync Mapping dialog box opens.

2. From the Destination Layer menu, select the layer that contains the mouth positions for the character's voice
track.

3. If the selected layer contains symbols, you can map the lip-sync using drawings located directly on the layer
or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to use the
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drawings or select the desired symbol from the drop-down menu.
4. In the Mapping section, type the drawing name or Symbol frames in the field to the right of the phoneme it
represents. If your drawings are already named with the phoneme letters, you do not have to do anything.

Modifying the Lip-sync
You can change the mouth position assigned to a frame if you think another position is more appropriate.
For example, you may have a character who says nothing for 10 frames between two speeches. Harmony would
normally assign an X image for the silent period. However, if you want your character's mouth to hang open in
astonishment for these 10 frames, you can change the lip assignment for these frames from an X to an F.
If you modify the sound detection, you will need to remap the lip-sync to your animation—see Mapping the LipSync Detection on page 169.
How to change the mouth position assignment of a sound from the Sound Element editor and Layer
Properties view
1. Double-click the sound layer name in the Timeline view to open the Sound Element editor.
2. In the Sound Element section, drag the frame slider to the frame you want to change the mouth position
assignment on.
In the Lip-sync image area, the image on top represents the lip position assigned to the current frame.

1. To change the image assigned to the frame, click on the image of the mouth position you want from below
the preview image. The preview image changes to the mouth position image you select. You can perform
the same operation in the Layer Properties view.

The position is updated in the Timeline view.
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NOTE: Note that if you modify the lip-sync detection you must remap the detection to your mouth layer.

Manual Lip-sync
Harmony allows for the manual swapping of mouth position drawings to match a voice track. For this process, both
sound scrubbing (listening to a sound wave broken up frame-by-frame) and drawing substitutions are used.
How to animate lip-sync using the Timeline view
1. In the Playback toolbar, enable the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the sound layer waveform.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Parameters section, staying on your mouth shapes layer, place your cursor on top of the drawing name
(often a letter) until it changes to the swapping
pointer.
5. Pull the cursor to see the list of mouth shape names and choose the one you want. The current drawing automatically changes to the new selection.

How to animate lip-sync using the Library view
1. In the Playback toolbar, click the Sound Scrubbing

button.

2. In the Timeline view, drag the red playhead along the waveform of your sound layer.
3. When you reach a frame where a mouth position should go, for example, an open mouth with rounded lips for
an "oh" sound, click on that frame on your mouth shapes layer.
4. In the Drawing Substitution window of the Library view, drag the slider to choose a mouth shape. The current
drawing is swapped for the one in the preview window.
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Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Harmony provides you with a series of essential effects that you can add to your layers.
This chapter contains the following topics:
•

Adding Effects on page 173

•

Animating an Effect over Time on page 178

•

How Does an Effect Work? on page 180

•

Effects in Harmony on page 180

Adding Effects

In Harmony, you can add effects through the Timeline view, connecting them to your drawing layers and then
adjusting the parameters until you achieve the look you want.
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How to add effects in the Timeline view
1. In the Timeline view, select the layer on which you want to add an effect.
2. Do one of the following:
‣

From the top menu, select Insert > Effects > desired effect.

‣

In the Layers toolbar, click the Add Layers

‣

From the Timeline menu, select Insert > Effects > desired effect.

button and select Effects > desired effect.

The effect appears in the Timeline view.

3. In the Camera view, click the Render View
button to see the scene's rendered current frame and
effect. Note that most effects cannot be played back in real time. You need to use the Render and Play
option in the Playback toolbar.

NOTE: If your background appears all in black, it's because you need to add a Colour Card. To do this, follow step
2.

4. In the Timeline view, double-click on the effect layer to open the Layer Properties window. You can also
select the effect layer and see its properties in the Layer Properties view.
The Layer Properties view opens, displaying the parameters available for the selected effect.

5. In the Layer Properties view, adjust the effect’s parameters—see Effects in Harmony on page 180.
6. To play back your scene with the final effects, in the Playback toolbar, click the Render and Play
ton.

NOTE:
Once you have set the parameters for the effect, you can store it in the Library view as a template, so you can
quickly reuse it without resetting the parameters again—see Templates in Chapter 7: Library of the Cut-out
Animation Guide.
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How to use effects with more than one port
1. Select a drawing layer.
2. Click the Add Layers

button and select Effects > Highlight.

The Highlight effect is parented to the selected layer.

3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.
4. In the Timeline view, click the Collapse/Expand

button on the effect layer.

5. Drag and drop the matte layer beside the Matte field.

6. Display the effect properties and adjust them until you achieve the desired effect.
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Previewing Effects
Most effects must be rendered so you can preview them properly. Some effects can be displayed in the OpenGL
view, but most of them must be rendered and previewed in the Render Mode of the Camera view.
Once you preview your effect, you may want to adjust it. By default, as soon as you modify a parameter,
Harmony will recalculate the preview image. If your scene is heavy and you do not want the preview rendered
automatically, deselect the Auto-Render option and do the preview update manually.
You cannot play back your animation in Render mode. You must perform a render or a preview render to see your
animation with the final effects. Effects must be calculated before they can be viewed in real time.
To make your previews calculate faster, you may want to render them at a smaller resolution. You can use the
Preview Resolution command so you will not have to modify the resolution of your scene every time you make a
check preview.
The Preview Resolution command allows you to quickly get a preview at three-quarter, half, one-third, or onequarter of the scene resolution. You can even customize the preview resolution size.
How to preview effects
1. In the Camera view status bar, click the Render Mode

button.

In the bottom-right corner of the Camera view, the progress bar indicates the status of the render.
Depending on the size of the frame to render, it may take several seconds.
How to disable the Auto-Render option
1. In the Camera view status bar, click the Auto-Render
able Scene > Render > Auto-Render.

button. In the top menu, you can enable and dis-

Once the Auto-Render option is disabled, you must request the preview update by clicking the AutoRender
button.
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How to manually update the rendering preview
1. In the Camera view status bar, click the Render

button.

How to play back effects
1. In the Playback toolbar, click the Render and Play

button.

The Play node opens and loads the frames.

2. Once the frames are loaded, click the Play

button in the Play window.

3. Select Scene > Render > Cancel Preview Render to cancel the rendering.

NOTE: While previewing effects, you can press the Spacebar to stop and start playback.

How to use the Preview Resolution command
1. From the top menu, select View > Preview Resolution and one of the following:
‣

Same as Scene Resolution

‣

3/4 of Scene Resolution

‣

1/2 of Scene Resolution

‣

1/3 of Scene Resolution

‣

1/4 of Scene Resolution

‣

Custom

If you selected the Custom option, the Custom Preview Resolution dialog box opens.
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2. In the dialog box, select a resolution from the presets or type a new X-Y value.
3. Click OK.
4. Preview your effects animation.

Animating an Effect over Time
When compositing your scene, you will often want to animate the parameters of an effect over time. For example,
you may want an object to fade in or out by changing the transparency level over time or by increasing the colour
contrast on one of your drawings over a certain frame range.
To animate an effect over time, create a function curve by adding keyframes to the parameters you want to
animate. To do this, you will use these views: Layer Properties and Timeline. You can fine tune your animation
using the Function view.
How to animate an effect over time
1. In the Timeline view, select a layer and add an effect to it by doing one of the following:
button and select Effects > desired effect.

‣

Click the Add Layer

‣

Right-click and select Insert > Effects > desired effect.

‣

From the top menu, select Insert > Effects > desired effect.

2. Create the function curve by doing one of the following:
‣

Double-click on the effect layer to display the effect properties. Click the Function
parameter you want to animate and create a function curve.
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‣

In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand
button.
Then click the Function
button of the parameter you want to animate and create a function curve.

3. In the Timeline view, go to the frame on which you want to start animating the effect.
4. In the Timeline toolbar, click the Add Keyframe

button.

5. In the Value field of the parameter you want to animation, enter the keyframe value. If your keyframes are
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set Motion
Keyframe.

6. Repeat this process for each keyframe to be added.

NOTE: Refer to Previewing Effects on page 176 to learn how to preview animated effects.
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How Does an Effect Work?
An effect always needs a drawing connection and sometimes a matte or shape connection. A matte provides
drawing information that determines the area on which the effect will be applied on the drawing. The details and
colours within the matte drawing don't matter, as only the shape and transparencies are used. A matte is also
known as mask.
The matte principle can be demonstrated with the Cutter effect.

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter
requires a matte input.
Adjust the Cutter properties to invert the effect of the matte on an image. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.
You can adjust the effect parameters in the Layer Properties view and link any of them to a function column to be
animated over time. This means that all of the effects can be customized.

Effects in Harmony
Here is the list of the main effects available in Harmony. Each effect and how to use it is described in the
corresponding section.
•

Blur on page 181 Blur on page 181

•

Brightness and Contrast on page 182

•

Colour-Scale on page 184

•
•
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•

Shadow on page 190

•

Transparency on page 192
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Blur

The Blur-Radial effect creates an effect that softens, fogs or obscures the image evenly in all directions. This effect
is useful when you want to make cloudy images not realistically seen in detail, such as a drawing object that is
farther back or in the background of your scene, usually blurry due to the laws of atmospheric perspective. Other
uses include the general softening of objects such as snow, stars and shadows that do not naturally have a hard
outline.

Use the Blur-Radial editor to change the values of the Blur effect.

Blur-Radial Properties
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When this option is deselected, the effect's values
remain unchanged regardless of any depth or scale changes. This option should
be deselected when multiple drawings are composited and attached to this effect.

Radius

Size of the blur. The larger the value, the greater the strength or reach of the blur.
The blur radius is affected by the drawing scale and camera position. Click the
Edit Curve button to change these values over time by adjusting the function
curve.

Quality

Select High for a slow and accurate operation or Low for a faster operation with a
more raw look.
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Brightness and Contrast

The Brightness and Contrast effect lets you modify the brilliance or dullness of an image or to create a greater
difference between the lights and darks of an image by increasing their respective intensities. This effect can be
used when an image appears too flat. Increasing the brightness or contrast can give a drawing a more attractive
and 3D quality. This can be useful if you want to push your background to the rear by making it look dull and flat
and pulling your foreground elements to the front by giving them a higher contrast.

Brightness and Contrast Properties
Parameter

Description

Brightness

A value less than 0 will darken the image; a value greater than 0 will brighten it.
Attach a Bezier or Ease function to change the brightness over time.

Contrast

A value less than 0 will reduce contrast; a value greater than 0 will increase
contrast. Attach a Bezier or Ease function to change the contrast over time.

Legacy Brightness/Contrast

If you are using an older version of this effect, the Legacy Brightness and
Legacy Contrast options are automatically selected. This ensures that the resulting effect looks the same as in older versions.
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Colour-Card

The Colour Card is a solid background the same size as the camera. The Colour Card lets you fill the scene's
background with a solid colour when there is no background image. If no background or colour card is added to the
scene, the resulting export will appear with a black background.
By default, the Colour Card has a Z ordering value of 12 Backward. This puts the Colour card behind all elements
that have a value lower than 12 Backward. Most of the time, the Colour card will appear automatically behind all
the scenes elements as they are all set to 0 Backward, unless you have changed the Z ordering of the scene
components. If so, the Colour Card will be in front of the elements that are pushed back to more than 12 fields
backward.

Colour Card Properties
Parameter

Description

Depth

The value used to determine composition order when the Z value of two elements
is the same.

Offset Z

The front-back position of the Colour Card layer in 3D space. This value can be
verified in the Top view.

Red/Green/Blue/Alpha

The colour and transparency of the Colour Card. You can also attach these
parameters to function columns to change their values over time.
Click the colour swatch to open the Colour Picker window and select a colour.

Colour Swatch

Opens the Colour Picker window in which you can specify the colour.
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Colour-Scale

The Colour-Scale effect offsets an image's colours. This effect is useful in creating ambient transitions, such as
from daytime to nighttime.

Colour-Scale Properties
Parameter

Description

Red, Green, Blue, Alpha

The red, green, blue and alpha used to offset the image.

Hue

The colour or hue to offset the image.

Saturation

The amount of colour to offset the image.
Enter the value for the colour to offset the image. The actual colour values of
the image are not changed; instead, the channels are multiplied by a selected
amount. For example:

Value

•

A value of 1 does not change the colour values.

•

A value greater than 1 brings the colour channel value closer to 255 (or
white).
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•

A value less than 1 brings the colour channel value closer to zero (0 or
black).

Cutter

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter requires a
matte input.
Adjust the Cutter properties to invert the effect of the matte on an image. Instead of the object being hidden by the
mask, it will only be visible where it intersects with the matte shape area.

How to use the Cutter effect
1. Select a drawing layer.
2. Click the Add Layers

button and select Effects > Cutter.

The Highlight effect is parented to the selected layer.

3. In the Drawing or Camera view, create a drawing on a new layer that will act as the matte.
4. In the Timeline view, click the Collapse/Expand

button on the effect layer.

1. Drag and drop the matte layer beside the Matte field.
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5. Display the Cutter properties and adjust the properties to control the type and amount of blur and the colour
of the Cutter effect.

Cutter Properties
Parameter

Description

Name

Allows you to change the node's name.

Inverted

When this option is enabled, the Cutter node will invert the matte shape to cut
the drawing. Instead of cutting the image intersecting with the matte, it will cut
any artwork outside of the matte shape.

Glow

The Glow effect adds a bright soft-edged light or diffuse light region around an image. The Glow effect is useful for
creating a shining rim around objects, such as the sun or stars.

Use the Glow editor to control the direction of the blur that creates the glow, as well as its colour.
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Glow Properties

Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo a
change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up the
edge of the matte.
Directional: The matte is blurred in the direction you select.

Radius

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.
If you selected the Directional Blur type, you can set the direction of the blur by
entering a value from 0 to 360 in this field.
0: Blurs the image to the west.

Directional Angle

90: Blurs the image to the south.
180: Blurs the image to the east.
270: Blurs the image to the north.
The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.

Directional Falloff Rate

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of the
character to the farthest edge of the blur.
1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of the
image.

Invert Matte

Inverts the matte used to create the tone, shadow, or highlight.
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Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you are
in render mode
to see this effect and that your background is NOT white and
that you do NOT have a white colour card node attached to the composite. As the
matte only gives colour information, but no alpha, the matte is automatically multiplied with the background colours. If there is no colour card attached and the
background appears black, you will see the matte colour at full opacity. If it is multiplied with a white background, the colours disappear into the full 255.

Multiplicative

Multiplies the tone or shadow colours with the background.

Colour
RGBA

Enter a value to add or subtract from the colour channels in the drawings or attach
these values to function curves.

Colour Swatch

Opens the Colour Picker where you can specify the colour.

Intensity

Lets you set a value to determine the strength of the effect or attach a function to
animate the effect.

Quadmap

The Quadmap transformation layer lets you deform the shape of an element. For example, you can use it to
create a drop-shadow effect on an element.
You can edit the Quadmap visually in the Camera view.
How to edit the Quadmap in the Camera view
1. In the Timeline view, click the Add Layer

button and select Quadmap.

2. Connect the drawing you want to deformto the Quadmap.

3. In the Tools toolbar, disable the Animate mode to change the value for the Quadmap over the entire duration of the element.
4. In the Timeline view, click on the Quadmap layer to select it.
5. From the top menu, select View > Show > Control or press Shift + F11.
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The quadmap handles appear around the element in the window. There is also a pivot point at the centre of
the quadmap frame that you can reposition.
6. In the Camera view window, use the Transform tool to move the points on the quadmap. Shift + click to
select multiple points.

The value of each point on the quadmap can be changed gradually. To do this, use the Quadmap node Layer
Properties to attach the points to function curves.
Only the X and Y values of each point in the quadmap can be changed.

Quadmap Properties

Parameter

Description

Name

Lets you rename the node.

2D Path

Changes the X and Y values simultaneously and control the velocity of the
change.

Separate

Changes the X and Y values separately. Each one can be attached to separate
function curves.
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Shadow

With the Shadow effect, you can turn a drawing into a shadow. It doesn't matter if the drawing layer is a fully
coloured character. The Shadow effect will render it into a grey, semitransparent, slightly blurry silhouette.

To add a shadow stretched out on the ground, simply add a Quadmap node to flip, stretch and skew the matte.
Attach the entire effect to the same trajectory as your drawing layer and watch the shadow move along with your
character.
Use the Shadow editor to modify the way the Shadow effect is created.
The Shadow effect uses the shape of the drawing connected to create the shadow behind another element and
can blur the edges to create a softer effect. You can control the type and amount of blur, as well as the colour of
the shadow.
For more information on the Apply-Peg-Transformation node, see Apply Peg Transformation on page 1.

Shadow Properties
Parameter

Description

Truck Factor

Activated by default, this option readjusts the blur when the elements undergo
a change of depth or scale. When disabled, the effect's values will remain
unchanged regardless of depth or scale changes. It is recommended that this
option be disabled when multiple drawings are composited and attached this
effect.

Blur Type

Radial: The edges of the matte are blurred evenly around points that make up
the edge of the matte.
Directional: The matte is blurred in the direction you select.

Radius

Enter a value for the size of the blur. The larger the value, the greater the blur
effect. The blur radius is affected by the drawing scale and camera position.
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If you selected the Directional Blur type, you can set the direction of the blur by
entering a value from 0 to 360 in this field.
0: Blurs the image to the west.
Directional Angle

90: Blurs the image to the south.
180: Blurs the image to the east.
270: Blurs the image to the north.
The distance where the blur fades from the edge of the image. Select a value
between 0 and 1.

Directional Falloff Rate

0: Makes the blur fade out slowly, distributing the blur evenly from the edge of
the character to the farthest edge of the blur.
1: Makes the blur fade out quickly. The blur is heaviest closer to the edge of
the image.

Invert Matte

Inverts the matte used to create the tone, shadow, or highlight.

Use Matte/Source Colour

Creates the shadow or tone using the matte shape's colour. Be sure that you
are in render mode
to see this effect and that your background is NOT
white and that you do NOT have a white colour card node attached to the composite. As the matte only gives colour information, but no alpha, the matte is
automatically multiplied with the background colours. If there is no colour card
attached and the background appears black, you will see the matte colour at
full opacity. If it is multiplied with a white background, the colours disappear
into the full 255.

Multiplicative

Multiplies the tone or shadow colours with the background.

Colour
RGBA

Enter a value to add or subtract from the colour channels in the drawings or
attach these values to function curves.

Colour Swatch

Opens the Colour Picker where you can specify the colour.

Intensity

Lets you set a value to determine the strength of the effect or attach a function
to animate the effect.
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Transparency

The Transparency effect is used to make an image partially transparent. The Transparency effect is useful when
fading images in and out, such as a phantom or to make something partially see-through, such as a window.

You can enter a value in the Transparency field or change the transparency value over time by linking it to a
function curve. Entering a value of 100 in the Transparency field will make the element 100% transparent, in other
words, invisible. Entering a value of 0 will render the element completely opaque.
Use the Transparency editor to control how translucent the element should be.

Transparency Properties
Parameter

Description

Name

Allows you to change the node's name.

Transparency

Lets you set the opacity of an element. Values range from 0 to 100. A value of
100 will make the element 100% transparent and a value of 0 will render the element completely opaque.
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Now that you've finished your animation, it's time to render your movie. Depending on whether you plan to further
edit your movie using a third party software, composite the movie in a larger body of work or put it up directly on the
web, Harmony supports several formats for all your rendering needs.
The render resolution for the various editions of Harmony are:
•

Harmony Essentials: 2K (2048x1556)

•

Harmony Advanced: 4K (4096x3112)

•

Harmony Premium: Unlimited

This chapter contains the following topics:
•

Exporting a QuickTime Movie on page 193

•

Exporting an SWF Movie on page 198

•

Exporting Image Sequences on page 198

Exporting a QuickTime Movie
If you require a video file, you can export your animation as a QuickTime movie. To render a QuickTime movie with
transparency, you need to set the Depth to Millions of Colours +. You can set this this when exporting a QuickTime
movie.
If your exported video is too small or too large, you can change the project size from the top menu in Scene > Scene
Settings. This will change the size of the video output.
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How to export a QuickTime Movie
1. From the top menu, select File > Export > Movie.
The Export to QuickTime Movie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it a file name for the export.
3. Click OK.
1. In the Display Source section, select the Display node to use for rendering your project.
2. From the Export Range section, decide whether you want to export the entire scene (All) or a specific
frame range. If you decide on the latter, enter the frame range.

3. In the Resolution section, select one of the following from the menu:
‣

A preferred resolution ratio.

‣

Custom: Enables the Width and Height fields so you can enter a specific size.

4. In the Options section, click Movie Options.
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Parameter

Description
Enables the customization of the video settings, filters and size.
Settings: Opens the Standard Video Compression Settings dialog
box.

Video

Filter: Opens the Choose Video Filter dialog box, where you can
select from a range of filters to apply to your video export.
Size: Opens the Export Size Settings dialog box. The size settings
are overridden by the Harmony's scene settings.

Sound
Prepare for Internet Streaming

Enables the customization of the sound settings.
Settings: Opens the Sound Settings dialog box (see below).
Enables the customization of the Internet streaming options.

5. In the Video section, click Settings.
The Standard Video Compression Settings dialog box opens.
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6. From the Compression Type menu, select a codec. The availability of certain compression settings
depends on the Compression Type selected. For example, Animation is the default compression type and
as a result the Data Rate option is greyed out.
7. In the Motion section, choose a Frame Rate from the list.
By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower
frame rate, your export playback will be faster than your actual project. The reverse is also true for a higher
frame rate.
8. If you want keyframes inserted, select the Every option and set the number per frame.
This is the option is recommended by QuickTime. For further details, refer to the QuickTime
documentation.
9. In the Quality section, use the slider to choose a quality setting. Remember that the better the quality of
the export, the larger the file.

10. From the Data Rate section, either choose to allow the program to automatically select the most optimal
bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality of
the export.
11. In the same section, from the Optimized For menu, select the intended viewing method for the export.
12. Click OK.
13. From the Movie Settings dialog box, click Sound Settings.
The Sound Settings dialog box opens.
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14. From the Compressor menu, select a compression type. The default setting is None. This will preserve your
original sound file without the loss of information. However, an uncompressed sound file will inevitably add
“weight” to the overall size of your video export.
15. From the Rate menu, select a rate. It is best to check and match the original properties of your sound file. For
example, if your file has an audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the
sound will play at the same speed, but with higher frequencies missing. For a standard film sound quality,
choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make the sound “dull” or less bright. For
things like recorded voice, this doesn't matter so much, but for music it can make an audible difference. If file
size is a consideration, such as with videos for the Internet, then a lower rate might be more practical.
16. Select the Size and Use, which are related. It is advisable to check your original sound file properties. If the
file was recorded in one channel (mono), there is no point in choosing the two channel (stereo) option.
Although Mono can support a 16-bit channel, the extra information is unnecessary. Mono is generally paired
with 8-bit and Stereo with 16-bit.
17. Click OK.
18. In the Export to QuickTime Movie dialog box, click OK.
A progress bar appears.

19. Browse to the location on your computer where you saved your QuickTime video and double-click on it to
view the export.
How to set the depth to Millions of Colours + to export a QuickTime movie with transparency

‣ In the Standard Video Compression Settings dialog box, select Millions of Colors+ from the Depth menu—
see Exporting a QuickTime Movie on page 193.

197

Chapter 8: Export

Exporting an SWF Movie
Exporting Image Sequences
In Harmony, you can export a scene as a bitmap image sequence. If there is sound in your scene, it will not be
exported with the images.
If you want to export images with transparency, you need to select the file type that supports this option, such as
.tga, .psd or .png. The Colour Mode menu changes according to the File Type selected. For example, selecting
.tif will result in only having "Colour" as a Colour Mode option, whereas .png will have "Colour" and "Colour with
Transparency".
How to render an image sequence
1. From the top menu, select File > Export > Images or press Ctrl + Shift + Y (Windows/Linux) or ⌘ + Shift
+ Y (Mac OS X).
The Export Images dialog box opens.
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2. In the Output section, choose a prefix. The prefix is the file name. Each image in the sequence will have this
name, plus a sequence number and file format extension. For example: final-0001.jpg.
3. Click Browse and specify the location in which your movie will be saved. The default location is the file directory’s frames folder.
4. In the Format section, choose the File Type, Colour Mode and Colour Depth from their respective menus.
5. In the Range section, select the Frame Range to render.
‣

All Frames: Exports export the entire scene.

‣

Selected Frames: Lets you specify the first and last frame of the frame range to export.

6. Select the Preview option to see the images being rendered.
7. Click OK.
If you selected the Preview option, a generic player opens so you can watch the image sequence strung
together as a video. The image sequence is now available in the scene’s frames directory. You should be
able to preview each frame as an individual image.
How to render an image sequence with transparency
1. Open the Export Images dialog box.
2. In the Format section, select Colour with Transparency from the Colour Mode menu.
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3D stereoscopic

The ability to create stereo images which, when animated and viewed through 3D active
shutter glasses or using glasses with one red and one blue lens, will appear as a threedimensional movie.

alpha channel

An image channel that carries transparency information. An image already has three
channels: red, green and blue (RGB). The alpha channel is the fourth channel (A). The
matte, or the transparency information, is stored in this fourth channel. An image without
an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The storyboard panel is
exposed for the duration of the scene and at times, the characters are placed on a
trajectory to indicate motion. The camera moves are also animated. The animatic is used
to determine the rhythm of a project and provides a good overview of the project before
beginning production.

animation

A simulation of movement created by displaying a series of pictures or frames.

anime

An animation style known for its sinister and dark feel; popular in Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or
situation from one state or scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any scene, frame or film
format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which multiple drawings are
stacked into a sheet feeder. When the scanner is activated, the drawings are scanned
consecutively, without further user intervention.

automatic lip-sync
detection

Automatically mapping drawings in an element to the mouth chart generated for a sound.
This can save time when lip-syncing a voice track.

axis

An imaginary line around which an object rotates.
For 2D graphics, there are two axes: X (horizontal and Y (vertical).
For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).
In animations that constantly rotate, the axis element specifies what axis the object
rotates around. A negative number causes an animation to rotate counter clockwise
whereas a positive number causes an animation to rotate clockwise.

background

The part of a scene that is farthest to the rear. The background is the artwork, or decor,
against which the animation takes place.

Bézier

A method of defining curved lines invented by French mathematician Pierre Bézier. A
Bézier curve is a mathematical or parametric curve. Bézier curves use at least three
points to define a curve.

bitmap

An image composed of pixels with a single resolution (size). If it is enlarged too much, it
will lose definition and individual pixels will begin to appear. This is known as pixelation.
Bitmap image files are defined as a standard rectangular mesh of individual pixels. Each
individual pixel contains a value that represents a specific colour.
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breakdown

In cut-out animation, breakdown is the action of breaking a character into pieces to create
a puppet with articulations. To break down a character, the artist cuts parts, such as the
hands and arms, from the character's model and pastes them in separate layers. Next,
the joints are fixed and the pivots set.
In traditional animation, a breakdown is an animation pose generally found between two
key poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help describe the motion and the rotation curve (usually
referred to as an arc).

camera shake

Camera shake occurs in a scene when the camera moves slightly and quickly in several
directions. This gives the impression of an impact, vibration or, for example, bumps on
the road.

caption

A text field containing dialogue, effects, sound or slugging information in a storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet on which
the animation is inked and painted before being sent to the camera. The picture's outline
is drawn on the front of the cel and then coloured along the back.

character design

Each character in an animated film is drawn from multiple angles in poster-style format,
called a model sheet, which serves as a reference for the animators.

chromatic
aberration

In optics, chromatic aberration (CA), achromatism or chromatic distortion, is a type of
distortion in which there is a failure of a lens to focus all colours to the same convergence
point.

clean up

After rough drawings have been tested and approved, all the noise in the image (excess
lines, notes, etc.) is removed to create final drawings which can be inked, painted and
shot. The clean up process refers to either tracing a clean line over a rough drawing to
achieve the final version or removing dirt and extra lines left by the scanning process.

CMYK

Acronym for Cyan, Magenta, Yellow, Black. These colours are the standard model used
in a process called offset printing.

colour card

A colour card is a card containing one solid colour that is the same size as the camera.
The colour card fills the background with a solid colour when there is no background
image included.

colour model

The official colour design that must be used to paint the animation. A model is the
definitive character, prop or location design that each artist must follow for the
production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to create the final
result prior to rendering. For example, the compositing artist will import all the animation
sequences, background, overlays and underlays in the scene and position them
correctly. The artist will then set the camera frame and animate it, if needed. Finally, the
animator will create all the computer-generated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there are no transition
effects inserted to pass from one scene to the next. The first scene ends and the second
one starts immediately.

cut-out animation

The process known as cut-out animation is the action of animating characters made out
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of several pieces by moving them around frame by frame. Cut-out animation can either
be computer generated or done traditionally using paper.
cycle

A group of images that together make up an action, such as walking. A cycle is an action
repeated as a loop over a period of time. It can be a series of animated drawings or
keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to track the sequence and
timing of images, dialogue, sound effects, sound tracks and camera moves. Also known
as an exposure sheet.

doping

To assign a particular drawing to a range of frames.

double bounce
walk

In the key frames and passing positions in a double bounce walk, the body is lower than a
reference line drawn in the upright position. During the in-betweens, the body is above
this line giving the appearance of a bounce.

DPI

Dots per inch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred to as
pixels per inch. Either way, the dot is the smallest discrete element making up the image.

ease

In animation, the ease, also known as velocity, is the acceleration and deceleration of a
motion. It can be a motion created by a function curve, or a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Also known as slow-in.

ease-out

Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is happening.
For example, if a child is playing on the ground in front of his house, the establishing shot
would be a scene where the viewer can see the house, the ground, a part of the street
and the buildings around the central point of action. This helps the viewer understand the
story location and scene orientation.

exposure

In animation, an exposure is the number of cels on which a drawing appears in the scene.
For a drawing to appear longer, the exposure must be extended over a greater number of
cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a scene's
timing. Each column represents a scene layer. The drawing numbers in each column are
indicated and repeated over the particular amount of frames they need to appear.
The exposure sheet is used by animators, directors and other members of a crew to track
the sequence and timing of images, dialogue, sound effects, sound tracks and camera
moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A fade in
occurs when the first scene appears progressively, from complete transparency to its
complete opacity. A fade out occurs when the last scene progressively disappears, going
from complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

A measurement unit used to calculate motion, registration and camera positioning. A
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standard animation scene will vary between 6 to 12 fields.
field chart

A guide containing all the field units that animation and layout artists use to determine a
scene size or camera motion.

film-1.33

A resolution that is ideal for the widescreen film format that conforms to the standard 4:3
pixel aspect ratio.

film-1.66

A resolution that is ideal for the widescreen film format that conforms to the 16:9 pixel
aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of an
animation sequence very quickly in order to see the animation in motion. Flipping can
also be the action of creating a mirror transformation of an object.

follow-through

The secondary motion caused by the main action. For example, a character wearing a
cloak is running. The main action is the body running. This will cause the cloak to follow
the motion, although it will not move at the same time, but react a few frames later and
follow the main motion curve.

forward kinematics Forward kinematics is a feature used to animate principally 3D characters and cut-out
puppets with hierarchy. It is used to animate a puppet from one of parent parts, such as a
shoulder, and make the rest of the arm move with it as a single piece.
frame

An animation frame is a single photographic image in a movie. In traditional animation,
the North American standard generally contains 24 frames per second, while in Europe
the standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally calculated
by frame per second. For example, a scene could be played back at 12, 24, 25, 30 or 60
frames per second or any other number.
This is the measurement of the frequency (rate) at which an imaging device produces
unique consecutive images, called frames. The term applies equally to computer
graphics, video cameras, film cameras, and motion capture systems.
Frame rate is most often expressed in frames per second (fps) and in progressive-scan
monitors as hertz (Hz).

function

A computer-generated motion, trajectory or path on which elements, other trajectories
and effects parameters can be attached. The function can be controlled by adding
keyframes and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

Acronym for High Definition Television which delivers a higher quality image than
standard television because it has a greater number of lines of resolution. To take
advantage of the superior quality and make full use of your resolution setting, the output
device must be compatible with HDTV technology.

hold

A frame in the animation in which the character maintains its position without moving. A
hold can be created between any two keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of hue (tint), saturation
(shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn to create fluid
transitions between poses.
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ink and paint

The ink and paint process is the action of painting the empty zones and colouring the
lines on the final animation drawings, while following a colour model.

interpolation

The computer-generated motion created between two keyframes. You have the choice to
create interpolation, or not, between your keyframes.

inverse kinematics
(IK)

A feature used mainly to animate 3D characters and cut-out puppets with hierarchy.
Inverse kinematics will animate a puppet from one of the extremities, such as a hand,
and make the rest of the body follow naturally.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It is
generally caused by one scene ending, and a second one starting, with a similar image.
The lack of difference causes the eye to see a little jump between the two scenes.

key pose

Important positions in the action defining the starting and ending points of any smooth
transition. Keys, or key poses, are the main drawings in an animation sequence
describing the motion. For example, if an arm is waving, the keys will be of the arm at one
extremity of the wave motion and the other extremity. By flipping those drawings, the
animator can see the skeleton of the motion without having all the drawings.

keyboard
shortcuts

One or more keyboard keys which, when used, cause an operation to be performed.

keyframe

Important positions in the action defining the starting and ending points of any action. A
keyframe is a computer-generated position at a specific moment (frame) on a given
trajectory.

layer

In animation, a layer is an individual column, level or character. A scene's layers are
superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is the action of
putting the storyboard on model. That is, drawing the character by following the design in
the model pack, so the animator can start working.
The layout artist draws the background, creates the camera and field guide matching the
scene and camera motion. Lastly, the animator draws on model the main action poses.

layout and posing

The action of putting on model (at the right scale) the storyboard for the animator to start
working.

layout artist

The artist who draws the background, and creates the camera and field guide to match
the scene and camera motion. They will draw on model the main action poses.

layout planning

Drawing of the main features of the scene used as reference when planning the
animation and executing the initial stages of it.

layout process

The communication step between the storyboard and the animation.

library

A storage area containing templates and assets that can be reused in any project or
scene.

light table

A device that allows you to see other layers in transparency while you are working on a
particular layer.

line of action

The direction that the action will follow. Also known as path of action.

lip-sync

The process of synchronizing a character's mouth to sounds in the dialogue soundtrack.
The mouth is adjusted frame-by-frame to match the sound of the dialogue and provide the
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illusion that the character is speaking. Lip-sync can be used for any sound sequence, not
only speech, you could for instance have a bird chirping or a wolf howling at the moon.
low resolution

A format that is ideal for videos destined for the web, where size and fast download of a
video file take precedence over quality. A low-resolution image is one that lacks fine
detail.

manual lip-sync
detection

The manual swapping of mouth position drawings to match a voice track. For this
process, both sound scrubbing (listening to a sound wave broken up frame-by-frame) and
drawing substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used throughout the
entire production to maintain consistency in the look and to ensure that the same colours
are used throughout the production. Also known as palette.

model/colour
model

The definitive character, prop or location design each artist must follow for a production.
A colour model is the official colour design that must be used to paint the animation.

morphing

A feature for creating computer-generated drawings between a source drawing and a
destination drawing. Animation created with the morphing feature can be reused in
different projects.

motion keyframe

A keyframe with computer-generated interpolation.

mouth chart

A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence) used for lip-sync.

multiplane

The effect of passing through multiple levels of drawings to create a sense of depth in a
shot. A multiplane is a scene in which the layers are placed at different distances from
the camera so that when the camera moves, a depth illusion occurs. With a multiplane,
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in North America. NTSC
conforms to North American standards on how rectangular pixels are displayed for
computer and television screens.

nudge

A small push (left, right, up, down, forward or backward) done with the keyboard arrow
keys on a selected element. Nudging is used to move a selection very slightly and
precisely.

onion skin

A feature that lets you see the previous and next drawings of a sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is placed in front of the
main animation.

PAL

A resolution that works best with the European format for television and computer
screens, as the rectangular pixels are displayed at a different orientation.

palette/master
palette

A palette or master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire project to maintain a consistency in the look and
avoid the colour changing during the animation. Also referred to as a master palette.

palette style

A palette style is a second version of an existing palette with a slight change in the tint
and value. A palette style can be used to create the night version of a palette. It may also
be called a clone palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be composed of one or several
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panels.
paperless
The paperless animation process is the action of animating digitally. The main paperless
animation/tradigital animation process is to draw, frame by frame, the animation directly in the software.
passing position

When drawing a walk sequence for a character, the passing position is the point at which
one leg passes the other.

path of action

Direction that the action will follow. Also known as line of action.

peg

In traditional animation, a tool used to ensure accurate registration of action as cel layers
move. In digital animation, in which you are doing a more advanced puppet rigging, you
can use peg layers. Peg layers are trajectory layers that do not contain drawings. They
are motion paths that you can use to add path articulations. For the latter, you can also
use an inverse kinematics tool.

phoneme

A unit of sound in a language.

pivot

The point around which a peg or drawing rotates.

pixel

The smallest element of an image displayed on a monitor or TV screen.
Pixel, short for picture element, is a single point in a graphic image. It is a small sample of
an image, a dot, a square, or a very small section made out of smooth filtering. If you
zoom in close enough on a digital image, you will see the pixels, which look like small
squares of different colours and intensity.

pose-to-pose
animation

The pose-to-pose animation process is the action of creating all the main action poses,
called key poses, and then placing the secondary poses between the keys. The
secondary poses are called breakdown. Finally, the animator fills the gaps with the inbetween drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer takes each
pixel that appears on screen and processes all of the components, as well as adding
motion blur before it produces a final image. The process of calculating the final images
after the compositing process.

resolution

The size of a scene, generally calculated in pixels. For example, the NTSC resolution is
720 x 480. The resolution should match the final output: HDTV, film-1.33, film-1.66,
NTSC, PAL, low.

RGB

Red, Green, Blue. A method of defining colour by specifying amounts of these three
colour components.

rigging

The process of attaching the various parts of a cut-out puppet.

rotary table

Equivalent to the animation disk/table, a device that allows you to rotate the workspace
for greater comfort while drawing.

rotoscoping

An animation technique in which animators trace over live-action film movement, frame
by frame, for use in animated films. The act of sketching over live-action footage to
create an animated sequence.

roughs

Rough is a common name in an animation movie for a drawing that is used as a reference
but which does not form part of the final image. A layout is a rough.
The skeleton sketch of an animation or design. Roughs mainly consist of sketch lines
and shapes, but can also contain design details.
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safe area

The zone at the center of a scene's frame that is safe from being cropped by the TV
frame. As a TV frame cuts a margin off the original frame size, maintaining a safe area
ensures that the scene's main action will remain clearly visible once the film is screened
on television.

scene

A shot in a movie or show. A sequence is composed of several scenes. A scene
changes to another scene by a simple cut or transition.

script

The original text containing all the movie or show information. In animation, the script
contains all of the location descriptions, dialogue, time and more. A project starts with a
script.

sequence

A series of scenes or shots forming a distinct part of the story or movie, usually
connected by unity of location or time.

shot

A scene in a movie or show. A sequence is composed of several shots. A shot changes
to another shot by a simple cut or transition.

slow-in

The gradual acceleration in the action. Also known as ease-in.

slow-out

The gradual deceleration in the action. Also known as ease-out.

slugging

To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the playhead forward or
backward. This is very useful for finely-tuning a lip-sync.

stop-motion
keyframe

A keyframe with no computer-generated interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The storyboard indicates what
will happen, when it will happen and how the objects in a scene are laid out.

straight-ahead
animation

A technique in which an entire sequence is drawn from the first position to the last, in
order. There is very little planning in this methodology. Where the character ends up and
how it gets there can be a surprise for both the audience and the animator. While this
approach is spontaneous and creative, it can create inaccurate results.

strokes

Invisible vector lines forming the drawing zones. They can be adjusted with Bézier
handles.

symbol

A symbol combines animation, artwork or layers into a single object that you can control
in one layer. You can also create symbols out of each body part in your cut-out puppets.
You can place whatever you want in a symbol. You can use symbols to animate a puppet
or create reusable animations such as blinking.

tablet/pen

A device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

template

An asset stored in the library that can be reused in any project. A template can be a
drawing, a series of keyframes, a sound file, a panel, a cut-out character, an effect, a
trajectory, an animation, or anything else used in the animation.

thumbnail

A very small image used as a reference or indicator.

timecode

The timing information printed on a movie clip to indicate the scene, hour, minute and
second that is currently displayed on the screen.
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timeline

A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil test, each
drawing is traced and painted for the final animation. In today's digital world, this may be
done in a variety ways other than the traditional celluloid or acetate methods.

track breakdown

The break down of an animated film's soundtrack into individual sounds to produce the
precise frame-by-frame position of each sound.

traditional
animation

A type of animation process whereby all the animation sequences are drawn by hand on
paper before scanning or inking them on cels.

trajectory

A computer-generated path or trajectory that elements can follow. The trajectory can be
controlled by control points, keyframes and velocity.

transition

An effect placed between two scenes as they pass from one to the other. Common
transition effects are cross-dissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed behind the main animation.

vector

A vector-based image is composed of points and Bézier curves. The computer reads the
points and traces the segments, linking them to reproduce the image shape. There is no
fixed size or resolution in a vector image. The graphic can be enlarged and distorted as
much as desired and the system will simply recalculate the segments and rebuild the
shapes. Vector images are translated and displayed in pixels once the calculation is
done.

velocity

In animation, the velocity, also known as ease, is the acceleration or deceleration of a
motion. This can be achieved by a function curve, or via a series of animated drawings.
Other common terms for ease-in and ease-out are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The illusion of
movement is created by the use of background pans. To avoid making innumerable
drawings, animators routinely make a walk cycle for a character.

zone

An area which can be painted with colour.
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paperless animation 206

Side view 105
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path of action 206

positioning elements 102

Windows 44
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vector 208

layer with Transform tool 85
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phoneme 206

slow-in 207

creating a style 43

pivot 206

slow-out 207

parameters, creating 43
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parameters, custom 35

sound

parameters, modifying 43

repositioning permanently 90
pixel 206
pixelation See bitmap image
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