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Chapter 1: Introduction
Harmony is a complete animation software allowing you to create all kinds of creative animation projects. It
comes with a very wide variety of tools and features.

In the Getting Started Guide, you will learn about themain features covering the basic concepts of Toon Boom
Harmony, which will quickly bring you up to speed. Refer to the complete Toon BoomHarmony documentation
available online at docs.toonboom.com to learn about all the tools and options, as well as advanced techniques.

This guide is divided as follows:

• About the Interface on page 7

• How to Draw on page 13

• How to Paint on page 15

• How to Create a Traditional Animation on page 19

• How to MorphDrawings on page 27

• How to Import Bitmap Images on page 31

• How to Build a Cut-out Character on page 39

• How to Use Deformers on page 49

• How to Animate a Cut-out Character on page 67

• How to Create Templates on page 73

• How to Set Up a Scene on page 77

• How to Create a Multiplane on page 91

• How to Set Up Objects in 3D Space on page 97

• How to AnimateObjects and the Camera on page 85

• How to Import Sound and Add Lip-Sync on page 101

• How to Add Effects to a Scene on page 105

• How to Export a Movie on page 115
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Chapter 2: About the Interface
It’s important that you become familiar with the following elements of the user interface as this will help you to
start using Toon BoomHarmony. You can learnmore about the highlights described here, and how to use them
in a production context, throughout this guide.

When you start Toon BoomHarmony for the first time, the default workspace is displayed. It contains all of the
main elements you need to use.

1. Menus

2. Tools toolbar

3. Camera view

4. Timeline view

5. Tool Properties view

6. Colour view

7. Playback toolbar

How to add a view

1. Do one of the following:

‣ Select the view youwant to add fromWindows > desired view.

‣ In the top-right corner of a view, click the Add View button and select a view from the list. You can
open several instances of the same view except for the Timeline, Tool Properties, Colour, and Drawing
views.
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By default, the view appears as a tab.

How to dock a window

1. Drag a window by its tab and do one of the following:

‣ Drop the window onto other existing tabs to add it to the others.

‣ Drop the window above, below or beside an existing view. When you get close to the edge of a
view, a black rectangle with a blue background appears, indicating where the view will be inserted.
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Tool Properties View

The contextual Tool Properties view contains themost common options and operations related to the currently
selected tool. When you select a tool from the Tools toolbar, the Tool Properties view is updated.

For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view displays the options
and operations related to the Select tool, such as Snap to Contour, Snap and Align, Flip Horizontal and Flatten.

Interface Navigation

Toon BoomHarmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.

Command Action Access Methods

Zoom In Zooms in the view.

View > Zoom In

Press 2 or roll themouse
wheel up.
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In the Timeline view, roll the
mouse wheel up.

ZoomOut Zooms out the view.

View > Zoom Out

Press 1 or roll themouse
wheel down.

In the Timeline view, roll the
mouse wheel down

Zoom In or Out Zooms in or out of the view.
Roll themiddlemouse button
up or down.

Pan Moves parallel to the view.

Hold down the Spacebar and
drag n in the direction in
which you want to pan the
view.

Recenter view Recenters the view on the pointer. Press N

Reset Pan
Resets the view’s pan to its default
position.

View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position.

View > Reset View

Press Shift + M

Reset Rotation
Resets the view’s rotation to its default
position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default
position.

View > Reset Zoom

Toggle Full Screen

Enlarges the selected view to full
screen which is done in three stages.

First, the selected view enlarges to the
maximumwidth or height, but keeps
the tool views such as Colour or Tool
Properties view.

Second, the view enlarges to full
screen.

Third, the view returns to its original
size.

View > Toggle Full Screen

Press Ctrl + F
(Windows/Linux) or⌘ + F
(MacOS X)

Rotate 30 CW Rotates the Camera view 30 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW
Rotates the Camera view 30 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

ToggleQuick Close-up Use theMagnifier tool to quickly
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center on themouse position and
zoom in to a pre-defined value such as
4X. Then you can zoom out again. Hold
the Shift key and press Z to zoom in
and back out again. Replace the Reset
Zoom by pressing Shift +.

The area where you zoom in or out is
dependent on the pointer location in
the Camera view. If you zoom in and
thenmove the pointer to a different
location when you zoom out themouse
will be centered on that location.

NOTE: If you're using a tablet or track pad that supports touch, then you can also use the standard two-finger gestures
to zoom, rotate, and pan the Camera and Drawing views.
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Chapter 3: How to Draw
As soon as Toon BoomHarmony is started, you can start to draw straight away using the default drawing layer.

How to draw

1. In the Tools toolbar, select the Brush tool or press Alt + B.

2. In the Timeline or Xsheet view, click in the first cell of the drawing layer.

3. In the Drawing or Camera view, start drawing.

4. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the colour
swatch to open the Colour Picker window and change the colour. Remember that anything already painted
with that colour will update to the new colour.
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Chapter 4: How to Paint

Toon BoomHarmony has some very powerful colouring features when it comes to painting. To paint your
drawings, you will use different colour swatches, unlike some other painting programs where youmodify themain
swatch each time youwant to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your drawing. You
can add as many swatches as you want. You can also rename them andmodify existing ones.

When youmodify the colour of an existing swatch, it automatically updates all the zones painted with this swatch
throughout the entire project. The colour swatch has a unique ID number that associates it with the painted
zones. This way, you can change the look of your character at any timewithout having to repaint it!

15



Chapter 4: How to Paint

In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. This is
referred to as amaster palette1.

Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.

Using a master colour palette has many benefits, including:

• Each character consistently retains their dedicated colours.

• You cannot accidentally use a colour which is not in themaster palette.

• Standardization and colour consistency throughout the production

• Multiple artists can use the same colour palette and produce the same results.

Toon BoomHarmony uses palettes to hold all the colours needed to paint your elements, allowing complete
control and consistency in your painting process.

A palette2 is created by assigning a set of colours to each character, prop or effect. You will create a new
palette and add a new colour, known as a colour swatch, for each zone of the character, such as the skin, hair,
tongue, shirt, pants, and so on.

How to paint drawings

1. In the Timeline or Xsheet view, select the drawing youwant to paint.

2. In the Tools toolbar, select the Paint tool or press Alt + I.

3. In the Colour view, select a palette.

4. Select a colour from the palette.

‣ If you are working with vector layers, double-click on a colour swatch to open the Colour Picker
window andmodify the colour.

‣ If you are working with bitmap layers, use the RGB/HSV controls to select a colour.

1Amaster palette is a group of colours attributed to a character or a prop. The palette is used throughout the
entire production to maintain consistency in the look and to ensure that the same colours are used throughout
the production. Also known as palette.
2Apalette or master palette is a group of colours attributed to a character or a prop. The palette is used
throughout the entire Toon Boom Studio project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master palette.
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NOTE: The colour palette only appears in the Colour view when you select a drawing element.

5. In the Drawing or Camera view, start painting the colours on your drawing.

Closing Gaps

17
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When painting, notice that some of your drawing areas are not closed. To close the zone, you can draw the
missing line with the Brush or Pencil tool or close the gap with an invisible line. To do so, you will use the Close
Gap tool.

The Close Gap tool lets you close small gaps in a drawing. The Paint tool only paints closed areas. The Close
Gap tool creates small, invisible strokes between the two closest points to close the colour zone. You do not
need to trace directly over the gap. You can draw it a few millimetres away and the Close Gap tool will
automatically choose the two closest points and close the gap.

How to use the Close Gap tool

1. Do one of the following:

‣ In the Tools toolbar, select the Close Gap   tool.

‣ From the top menu, select Drawing > Drawing Tools > Close Gap.

‣ Press Alt + C.

2. In the Tool Properties view, select the Auto-Flatten button if you want the stroke you draw to be
flattened in your drawing instead being on top.

3. You can display invisible lines by selecting View > Show > Show Strokes or press K. If you do not dis-
play the strokes, a message box will appear.

Select theDon’t Show This Message Again option to prevent this message box from appearing again.

4. In the Camera or Drawing view, trace an invisible line near to the gap to be closed.

The gap automatically closes.
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Chapter 5: How to Create a Traditional Animation

The first step to complete a traditional paperless animation is the rough construction, which is the skeleton of
your animation. You would usually start with themain action. For example, to animate a walk cycle, you will start
with the torso motion and the legs. Head, arms and clothes will be added later during the secondary animation.

For a satisfactory animation, complete themain action before adding all the details. If you start animating all the
details right away, you will lose a lot of time if you have to make corrections. Your animation will often look too
rigid.

How to animate

1. Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X) to open the Preferences dialog box.

2. Select the Exposure Sheet tab.

3. Select theUse Current Frame as DrawingName option. When this preference is enabled, drawings will
be named like the frame they are created on (frame number).

4. In the Tools toolbar, select the Brush tool or press Alt + B.

5. In the Colour view, select a colour for the brush. It is a good idea to choose a light colour for your rough
animation. This will help you in the task that follows, the clean up process.
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6. In the Timeline or Xsheet view, select the cell where the first drawing will appear.

7. In the Camera or Drawing view, draw the first key drawing.

8. With your first cell still selected, do one of the following to mark your drawing as a key drawing. This will
help you stay organized.

‣ In theMark Drawing toolbar, click theMark Selected Drawings as Key button.

‣ In the Xsheet view, select Drawings > Mark Drawing As > Key Drawing.

‣ In the Timeline view, select Drawings > Mark Drawing As > Key Drawing.

9. In the Tools toolbar, click theOnion Skin button. TheOnion Skin feature displays your previous and
next drawings as visual references to help you draw your new pose.

10. In the Timeline view, click and drag the blue onion skinmarkers to extend the number of previous and
next visible drawings.

11. In the Camera View or Drawing View toolbar, press either theOnion Skin ReduceOneNext/Previous
Drawing or Onion Skin AddOneNext/Previous Drawing to reduce or increase the number of previous
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and next visible drawings. The red icons are for the previous drawings and the green icons
are for the next drawings.

12. In the Timeline or Xsheet view, select the cell where your next key drawing will appear.

13. In the Camera or Drawing view, draw your second key drawing.

14. In the Xsheet or Timeline view, identify the drawing as a key drawing.

15. In the Timeline or Xsheet view, select a cell between the two key drawings.

16. From the Timeline toolbar, click Create Empty Drawing to create an empty drawing or press Alt +
Shift + R.

‣ In the Xsheet view, right-click and select Drawings > Create Empty Drawing or press Alt + Shift + R.
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Chapter 5: How to Create a Traditional Animation

NOTE: Instead of creating an empty drawing, you can simply start drawing.

17. In the Camera or Drawing view, draw your new pose.

18. If necessary, in the Xsheet or Timeline view, identify the new drawing as a key, breakdown or in-between
drawing using theMark Drawing toolbar.

19. Use the Flip and Easy Flipping toolbars to review your animation.

20. In the Timeline or Xsheet view, select a new cell and repeat the previous steps for each new drawing.

21. In the Timeline view, use the Enable/Disable All and Solo buttons to turn off any layers you
don't want to see during playback.
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22. To loop playback, move the red playhead to the desired start frame and click the Start button on the
Timeline toolbar. Move the playhead to the last frame of the playback and click the Stop button.

23. in the Playback toolbar, click the Loop button to start the playback.

24. In the Playback toolbar, click the Play button to start the animation.

Cleaning Up

When your rough animation is completed, it is time to clean it up and ink it. This step is also called tracing. It
consists of tracing solid and clean lines over the rough animation to close any open zones. This is the final
paperless animation step before the ink and paint step.

You will need to add a new drawing layer to draw your clean. This is the equivalent of adding a sheet of paper and
tracing the rough using the animation disk. This method allows you to keep the roughs and the cleans intact. You
only need to disable the rough layer to prevent it from appearing in the scene.

If you plan on tracing your animation in the Drawing view, you can turn on the light table to display all the layers in
your project.

How to trace your animation in a new layer

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ + R
(MacOS X).

The Add Drawing Layer window opens.
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Chapter 5: How to Create a Traditional Animation

2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap
layer.

4. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.

5. In the Timeline view, click the Lock icon of the layer containing your rough animation to prevent the
layer from being selected in the Camera view.

6. In the Timeline or Xsheet view, select the new layer’s cell corresponding to the first key drawing of your
rough animation.

7. In the Tools toolbar, select a drawing tool such as the Pencil tool.

8. In the Colour view, select a colour for tracing your animation. Pick a dark bold colour, such as black, to
make sure it contrasts well with the light colour of your rough animation.

9. In the Camera or Drawing view, start tracing the first key drawing.
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10. If you have other layers in the way, you can disable them temporarily in the Timeline view, so that only your
rough animation and your clean up layer are displayed in the Camera view.

11. In the Tools toolbar, click the EnableOnion Skin button.

12. If you are not using theOnion Skinning by Drawing option, extend theOnion Skin range in the Timeline
view, otherwise use theOnion Skin AddOne Previous Drawing and Onion Skin AddOneNext Drawing but-
tons in the Camera or Drawing View toolbar to add drawings to your onion skin display.

13. In the Timeline or Xsheet view, select the next cell corresponding to a rough drawing.

14. In the Camera view, trace your next drawing.

15. Repeat the previous steps for each drawing.
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Chapter 6: How to Morph Drawings

When it comes to morphing, you will need to practice and become at ease with it. Once you are familiar with the
basic rules, you can start creating morphing sequences. To begin, start with simple elements. When you are
confident with themorphing process, you can start to use complex and advanced morphing techniques, such as
head rotations or full characters.

Youmay want to delete an entiremorphing sequence in order to redo a sequence from scratch.

How to create a basicmorph

1. In the Timeline toolbar, click the Add Drawing Layer button to add a new layer to your project.

2. Rename the new layer ( for example, Morphing).

3. In the Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:

‣ In the Tools toolbar, select the Rectangle tool.

‣ Press Alt + 7.

5. In the Camera or Drawing view, draw a rectangle.

6. Do one or both of the following:

‣ Hold down the Shift key to draw a square.

‣ Hold down the Alt key to draw the rectangle from its centre.

7. Paint your rectangle using the Paint tool.
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Chapter 6: How to Morph Drawings

8. In the Xsheet or Timeline view, select the cell on which you want your morphing sequence to end.

9. Do one of the following:

‣ In the Tools toolbar, select the Ellipse tool.

‣ Press Alt + =.

10. Draw and paint the ellipse using the same outline colour as the rectangle.

11. In the Xsheet or Timeline view, select the first frame and all the frames up to and including the last
frame, which is the rectangle drawing.

12. Do one of the following:

‣ From the top menu, select Animation > Morphing > Create Morphing.

‣ In the Xsheet or Timeline view, right-click and selectMorphing > Create Morphing

‣ Press Alt + M.

Arrows appear between the two key drawings to show that computer generated inbetweens have been
created.
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NOTE: Use the Playback toolbar to play the morphing sequence. To flip through the inbetweens, toggle between
comma ( , ) and period ( . ). Press F4 to toggle between the two key drawings.

How to delete an entire morphing sequence

1. In the Xsheet or Timeline view, select a cell in themorphing sequence.

2. Do one of the following:

‣ From the top menu, select Animation > Morphing > Delete Morphing.

‣ In the Xsheet or Timeline view, selectMorphing > Delete Morphing.

‣ Right-click on your sequence and selectMorphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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Chapter 7: How to Import Bitmap Images
A bitmap image1 is an image composed of pixels that are both size and resolution dependent. In Harmony, you
can import bitmap images and vectorize them, making the images editable. Then you can use a variety of drawing
tools to edit the image. Or you can always keep the original bitmap image as is.

Also, you can choose to import bitmap images on bitmap or vector layers depending on your project.

NOTE: You can drag and drop a bitmap image directly from the Library into the scene (Camera) as a quick way of
importing a bitmap image. However, you will not have access to all the import options.

How to open the Import Images dialog box

1. Do one of the following:

‣ From the top menu, select File > Import > Images.

‣ In the File toolbar, click the Import Images button.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Images.

The Import Images dialog box opens.

How to import a bitmap image in its original format

1. In the Files section of the Import Images dialog box, click Browse to find and select one or more images on

1An image composed of pixels with a single resolution (size). If it is enlarged too much, it will lose definition and
pixels will begin to appear. This is known as pixelation.
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Chapter 7: How to Import Bitmap Images

your computer.

2. Decide if the bitmap imagewill go on a new layer or an existing layer. To add the bitmap image to a
new layer, go to step 3. To add the bitmap image to an existing layer, go to step 4.

3. Add the bitmap image to a new layer by selecting theCreate Layer(s) option and one of the following
options and then proceed to step 5:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a"
has two drawings and "b" has one. When creating a single layer from these three filenames, all three
drawings will be inserted in the new layers.

4. Select theAdd to Existing Layer option to place the bitmap image on a layer you select from the list. If
only vector layers are available in your scene, they will not be displayed in the list. You can choose to
encapsulate the bitmap in a symbol by selecting theCreate Symbols for Imported Items option.

5. In the Import Options section, select theKeepAs Original Bitmap option. In the Alignment section,
decide on the size and placement of your imagewithin the camera frame. Depending on the Scene Set-
tings (the height and width in pixels that you chose for your project), an image that you import may be
scaled to the point where all its individual pixels become visible. There are three options available in the
Alignment section:

Parameter Description

Fit

Enlarges or shrinks (but not distorts) the image height to
match the full height of the scene grid.

If the image orientation is landscape, this will enlarge or shrink
(but not distort) the imagewidth to match that of the scene
grid.
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Note that the Fit alignment rule equals the Center Fit rule in the
layer properties.

Pan

This is the opposite of the Fit parameter. If the image
orientation is portrait, its width will bemade to match the
width of the scene grid. As a result, part of the image’s height
will extend beyond the height of the frame. This can be useful if
you want to make your background move up and down, or
from left to right to make it appear as if the camera is panning
or to actually perform a camera pan.

The opposite will apply to a landscape image. Its height will be
fit to the scene grid, therefore it is possible that the imagewill
extend beyond the scene grid's boundaries.
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Note that the Pan alignment rule equals the Center First Page
rule in the layer properties.

Project Resolution

Scales the image in proportion to the scene's resolution. The
system looks at the resolution of the bitmap image, for
example 4000 x 2000, then compares it to the scene's
resolution, for example 1920 x 1080, and adjusts the scale
factor in proportion. So, in this example, the bitmap would
appear at 208% (4000/1920). If you import a bitmap that is 960
x 540, it will be displayed at 50% (960/1920) of the size of the
project resolution.

Note that the Project Resolution alignment rule is equal to the
As Is rule in the layer properties.

6. In the Transparency section, select one of the following from the Alpha menu:

Parameter Description

Premultiplied withWhite
Individual pixels at the edge of an image are blended with
white.

Premultiplied with Black
Semitransparent pixels in the original image are blended with
black.

Straight
Pixels at the edge of an image are blended with black, white
and greys.

Clamp Colour to Alpha

Premultiplies the colour value with the alpha value. When the
colour is clamped to the alpha, the colour value cannot be
higher than the alpha value. It calculates the real colour value
faster. When the RGB values aremultiplied with the alpha
value, that is, if you have a pixel of value R=247, G=188, B=29
and the alpha is 50% or the image has a 50% transparency,
then the actual RGB values that are output would be half of the
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amounts listed above.

1. Click OK.

How to import a bitmap image as a Toon Boom bitmap drawing

1. In the Files section of the Import Images dialog box, click Browse to find and select one or more images on
your computer.

2. In the Import Options section, select the Import asToon Boom BitmapDrawing option.

3. Decide if the bitmap imagewill go on a new layer or an existing layer. To add the bitmap image to a new
layer, go to step 4. To add the bitmap image to an existing layer, go to step 5.

4. In the Layer section, select theCreate Layer option, and one of the following options to add the bitmap
image to a new layer:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has
two drawings and "b" has one. When creating a single layer from these three filenames, all three
drawings will be inserted in the new layers.

5. Select theAdd to Existing Layer option to place the bitmap image on a layer you select from the list. If
only vector layers are available in your scene, they will not be displayed in the list. You can choose to
encapsulate the bitmap in a symbol by selecting theCreate Symbols for Imported Items option.

6. In the Alignment section, decide on the size and placement of your imagewithin the camera frame. Depend-
ing on the scene settings (the height and width, in pixels, that you chose for your project), an image that
you import may be scaled to the point where all its individual pixels become visible.

NOTE: Make sure you are in the Camera view’s Render Mode when judging an imported image,
otherwise it may appear blurry. You can also adjust the quality of a bitmap image displayed in the
OpenGL mode by using View > Bitmap File Quality. You must select your bitmap image using the
Transform tool.

The following three Alignment Rules options are available:

Parameter Description

Vertical Fit
Enlarges or shrinks (but not distort) to your image height to match
the full height of the scene frame (alignment grid).
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Horizontal Fit

Enlarges or shrinks (but not distort) to your image height to match
the full width of the scene frame (alignment grid).

Actual Size

Scales the image in proportion to the scene's resolution. The system
looks at the resolution of the bitmap image, for example 4000 x
2000, then compares it to the scene's resolution, for example 1920 x
1080, and adjusts the scale factor in proportion. So, in this example,
the bitmap would appear at 208% (4000/1920). If you import a
bitmap that is 960 x 540, it will be displayed at 50% (960/1920) of the
size of the project resolution.

7. In the Transparency section, decide how the bitmap imagewill be antialiased, more specifically, the way
the pixels along the edge are blended in the RGBA (red, green, blue, alpha (transparent)) channels. Your
bitmap imagewill exist in the bitmap layer of the newly created drawing element.

Parameter Description
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Premultiplied withWhite
Individual pixels at the edge of an image are blended with
white.

Premultiplied with Black Pixels at the edge of an image are blended with black.

Straight
Pixels at the edge of an image are blended with black, white
and greys.

8. Click OK.

How to import a bitmap image and convert it to a Toon Boom vector drawing

1. In the Files section of the Import Images dialog box, click Browse to select one or more images on your
computer.

2. In the Import Options section, select theConvert to Toon Boom Vector Drawing option.

3. Decide if the bitmap imagewill go on a new layer or an existing layer. To add the bitmap image to a new
layer, go to step 4. To add the bitmap image to an existing layer, go to step 5.

4. In the Layer section, select theCreate Layer option, and one of the following options to add the bitmap
image to a new layer:

‣ Create Single Layer Named: Creates a layer you can name.

‣ Create Layer(s) Based on Filenames: Creates a layer based on each unique filename prefix. For
example, the filenames a-1.tga, a-2.tga and b-1.tga will create layers name "a" and "b", where "a" has
two drawings and "b" has one. When creating a single layer from these three filenames, all three
drawings will be inserted in the new layers.

5. Select theAdd Existing Layer option to place the bitmap image on a layer you select from the list. If only
vector layers are available in your scene, they will not be displayed in the list. You can choose to encap-
sulate the bitmap in a symbol by selecting theCreate Symbols for Imported Items option.

6. In the Vectorization section, decide whether you want to import your image in black and white or grey.

Parameter Description

Black andWhite
Vectorizes drawings as a solid black line; creates a 100% vector-
based drawing.

Grey
Vectorizes your image as a mix of vector contour and greyscale
bitmap filling. Lines keep the texture from the scan, and the white
of the paper becomes transparent.

37



Harmony 12.1 Premium - Getting Started Guide (Server)

38



Harmony 12.1 Premium - Getting Started Guide (Server)

Chapter 8: How to Build a Cut-out Character

There aremany techniques you can use to break down a puppet. In this section, you will learn about one of the
most common and simplest methods. For your first character breakdown1, follow these instructions to get an
idea of the way Harmony works. Once you understand Harmony's basic functions and commands, you will be able
to create your own techniques to satisfy the needs of your production.

Drawing the Pieces

Themain breakdown technique shown here is to trace your model.

How to break down a character

1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl + R (Win-
dows/Linux) or⌘ + R (MacOS X).

1In cut-out animation, the breakdown is the action of breaking a character into pieces to create a puppet with
articulations. To breakdown a character, the artist will cut parts, such as hands and arms, from the character's
model and paste them in separate layers. Next, the joints will be fixed and the pivots set. In additional animation,
a breakdown is an animation pose generally found between two key poses. The key poses are themain poses in
an animation and the breakdowns are secondary poses, ones that help to describe themotion and the rotation
curve.
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2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select a drawing tool.

4. In the Colour view, select a colour swatch. If you haven't created a palette for your character yet, see
How to Paint on page 15.

5. In the Camera or Drawing view, draw the new part with as with as few points as possible so the pieces
are easy to manipulation, modify or redraw. Using the Polyline tool would make it easy to do this.

If you are working in the Drawing view, click the Light Table button in the Drawing View toolbar to
display the other layers as washed out colours. You can also press Shift + L.

6. You can use the Stroke tool in the Tools toolbar to create an invisible hairline if you want to close a
shapewithout drawing an actual stroke.

‣ Select View > Show > Show Strokes or press K to display the invisible lines.

7. In the Tools toolbar, select the Paint or Paint Unpainted tool to colour your drawing.

8. In the Colour view, select the corresponding colour.
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9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select tool. Select your drawing and flatten the lines by clicking the Flat-
ten button in the Tool Properties view.

11. If your lines are composed of several pencil strokes, youmight want to combine them into one single
smooth pencil line. Using the Select tool, select the pencil lines to bemerged and in the Tool Properties
view, click theMerge Pencil Lines button.

12. Repeat the entire process until the break down is completed.
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Adding Pegs

It is recommended to add parent pegs to your drawing layers which are path layers that let you add keyframes
to modify the positions of pieces over time. It is not mandatory, but it is helpful to have your drawings and
keyframes separated.

How to parent drawing layers to pegs

1. In the Timeline view, select all the layers.
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2. In the Timeline Layer toolbar, click the Add Parent Peg button to add a parent peg to all selected lay-
ers.

s

At this point, in the Node view, the layers look tangled.

3. In the Node view, select all the nodes and, in the Network View toolbar, click theOrder Network Down
button.
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Parenting Layers

Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards. You can
create hierarchies without encapsulating pieces inside each other by creating a linked structure between layers.

You should create a hierarchy on the arms and legs, and keep them separated from the body. This gives you
more animation freedom, and when you need to scale or skew the torso, it will not affect the entire body.

How to create a hierarchy in the Timeline view

1. Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the parent
(forearm) piece onto another parent piece (upper arm).
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‣ You can unparent layers by holding down Shift and dragging the selected parents away from the child
layer. Drop your selected between other layers.

How to create a hierarchy in the Node view

‣ Without Pegs: From the parent part, drag a new cable connection out of the node's output port
(bottom) and connect it to the child part node's input port (top).

‣ With Pegs: From the parent part's peg, drag a new cable connection out of the node's output port
(bottom) and connect it to the child part's peg input port (top).
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Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene. When
you need to scale down or move your character, it is a good idea to hook (attach) the whole puppet to a
trajectory.

Attaching your puppet to a peg1 will allow you to scale it and reposition it without having to do this to the
different parts and pieces. Only one layer will contain the position information, whichmakes your animation
easier to modify and control.

How to add amaster peg

1. In the Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able to
add a peg to your scene. Unless you use the Display All mode from the Display toolbar, you will get an
error message if you try to add a peg without any selection.

2. In the Timeline view, click on the Add Peg button.

A new peg is added to the timeline as a parent of the selected layer.

1. Name the new peg Master plus the character's name.

3. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one item is
already parented to that peg.

1In traditional animation, a tool used to ensure accurate registration of action as cel layers move. In digital
animation, in which you are doing a more advanced puppet rigging, you can use peg layers. Peg layers are
trajectory layers that do not contain drawings. They aremotion paths that you can use to add path
articulations. For the latter, you can also use the Inverse Kinematics tool.
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2. Drag your selectionON to the peg layer to parent all your character's pieces to the peg. If your layers are
added above the already parented layers, move that parented layer back on top of the layer stack.
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Chapter 9: How to Use Deformers
Deformation technology allows you to deform bitmap and vector drawings over a period of time. You can link
deformers to create a hierarchy of deformation. You can deform a character made out of one, or many, drawing
or image layers and make it move as if it were a cut-out puppet. This also allows you to take an area in a single
bitmap image and create animation by distortion.

About the Deformation Effects

Deformations let you animate bitmap or vector-based graphics, including gradients and textures. Deformations
act as a skeleton with limbs and articulations you can bend, reshape, and curve. You can deform a character made
out of one, or many, drawing or image layers and make it move as if it were a cut-out puppet. This also allows you
to take an area in a single bitmap image and create animation by distortion. A deformation skeleton is composed
of deformation nodes, which are the various pieces (here represented as layers or nodes) required to articulate or
deform your drawings, such as a series of bones, curves or game bones—seeDeformation Nodes on page 1.

Bone Deformer

The Bone deformation allows you to create a skeleton structure in which the parent bonemoves the child bone.
The Bone deformation is useful when animating the extremities of a character, such as the arms or legs, adding
fluidity and a natural feel to the animation. It can bemanipulated to rotate a limb at an articulation joint and to
shorten or elongate the extremities of a limb. It's also quite handy for bending the torso.

NOTE: If you are creating a rig to be used in a game, use the Game Bone deformation.
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Game Bone Deformer

TheGame Bone deformation is very similar to the Bone deformation and allows you to create a skeleton
structure in which the parent bonemoves the child bone. The difference is that the Game Bone deformation is
optimized to export to game engines, mainly Unity.

TheGame Bone deformation is mostly used when animating the extremities of a character, such as the arms or
legs, adding fluidity and a natural feel to the animation. TheGame Bone deformation can bemanipulated to
rotate a limb at an articulation joint and to shorten or elongate the extremities of a limb. It's also quite useful
for bending the torso.

Themain differences between the Bone and Game Bone deformations are that the Game Bone deformation
doesn't have the Bias parameter and no regions of influence settings. The rendered result is also different for
the articulation folds. They are slightly rounded.

Curve Deformer

The Curve deformation allows you to deform an image using Bezier handles. For example, when editing curves,
you can deform a straight line into an arc or a zigzag. Curve deformations aremostly used to animate elements
that don't have joints, such as hair or facial features. However, in some cases they can be used to animate
limbs to create a specific animation style, similar to the early rubber hose style of animation with typically
simple, flowing curves without articulation (no hinged wrists or elbows).
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Envelope Deformer

The Envelope deformation allows you to deform an image using Bezier handles located all around the contour of
the shape. Envelope deformation chains are composed of Curve deformation nodes. It is regularly used to
deform shapes, such as hair, cloak, shoulder shape, head shape and so on. You can use the Envelope deformation
to deform a drawing so it looks like it changes from a profile view to a front view to create head and character
rotations using only one set of drawings.

Themain differences between the Curve and Envelope deformers is that the Envelope chain can be closed by
connecting the last Curve deformation node to the initial Offset point. Once connected, theOffset point no
longer repositions the entire chain, only its own control point.

NOTE: It's not recommended to use the Envelope deformations on bitmap images and textures.

Rigging

Using the Rigging tool, you can quickly create a basic deformation rig. As you create chains, you can automatically
group the deformation nodes to keep your structure clean and organized.

As you create your chains, the controls will be showing. However, whenever you close your project, the
deformation controls display is turned off. When you reopen the project, you can display all controls or only some
of them—seeDisplay the Deformer Controls on page 62.

Before adding deformations, youmight want to use a default type of region of influence. You can set these
parameters in the Rigging tool's properties.

TheNode Library view allows you to manually add the nodes necessary to create the deformation skeleton.
Additional nodes such as the Kinematic Output are available to create advanced rigs.

How to automatically group deformation nodes

1. From the Deformation toolbar, click the Rigging tool.

2. In the Tool Properties view, in the Rig Tool Options section, enable the Automatically Create Group when
Creating a New Deformation Rig option.
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This option automatically creates a deformation group connected to the input port of the selected
element. This group includes all the necessary deformation nodes you created.

How to select an element to add deformation to

1. From the Deformation toolbar, click the Rigging tool.

2. In the Node, Camera or Timeline view, select the element on which you want to add a deformation.
When selecting a drawing node, the deformation components will be automatically added on top of the
drawing node. When selecting a peg node, the deformation components will be added below the peg.

NOTE: Never place a deformation node above a peg node. Having a peg below a deformation node (Bone, Game
Bone, Curve, etc.) will cause unexpected result. The animation on the peg will move the image out of the defined
deformation zone. The same applies to animations created on the drawing layer itself. A drawing layer has an
embedded peg.

3. In the Camera view, create your rig. See the following procedures to learn how to add a specific deform-
ation type.

How to add a Bone or Game Bone deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Bone
mode or theGame Bonemode depending on your purpose—seeMain Types of Deformations.

2. Place the cursor at the root of your drawing or group of drawings, click once and release. For example,
on the shoulder.
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3. Click again at the location where you want your first bone to finish and your second bone to start. An artic-
ulation control point will automatically be inserted between each bone you create. Note that the artic-
ulation parameters are part of the Bone and Game Bone nodes since Harmony 12.

4. Repeat this until you are finished creating the Bone chain.

5. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.

l Note that you can click on any Bone articulation point to start a new bone chain from that
point. Once the articulation point is selected (white), click on the location where you want to
add a bone and a new bone chain will be created, parented to the previous one.
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l When you have several chains controlling the same drawing or group of drawings, a
Deformation Composite node is automatically be created and appears in the Timeline
view. In the Additional Links section of the Timeline view, you can see which nodes are con-
nected to the Deformation Composite.

6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

How to add a Curve deformation chain

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Curve
mode.

2. Click at the root of your drawing, for example, the shoulder and drag to extend the control handle and
release just as you would when using the Polyline tool.
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3. Click again at the location where you want the curve to end and drag backwards to extend the second con-
trol handle.

4. Repeat this process until you have finished building the Curve chain.

NOTE: Note that you can click on any curve point (not the Bezier handle) to start a new curve chain from that point.
Once the control point is selected (white), click on the next location where you want to add a curve and a new chain
will be created, parented to the previous one.

l When you have several chains controlling the same drawing or group of drawings, a Deform-
ation Composite node is automatically be created and appears in the Timeline view. In the
Additional Links section of the Timeline view, you can see which nodes are connected to the
Deformation Composite.
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NOTE: The Deformation nodes are stacked on top of each other. You can organize the node system by selecting
all the nodes, clicking the Order Node View Up or Node View Down button.

NOTE: You can click on any curve point (not the Bezier handle) to start a new curve chain from that point. Once
the control point is selected (white), click on the next location where you want to add a curve and a new chain will
be created, parented to the previous one.

5. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

How to create an Envelope deformation rig

1. Once your element and the Rigging tool selected, in the Tool Properties view, enable the Envelope
mode.

2. Click at the starting point of your drawing shape, for example, the cheekbone and drag the cursor to
extend the control handle and release just as you would when using the Polyline tool.

3. Working as you would with the Curve deformer, continue adding control points around your shape. An
Envelope chain is composed of Curve deformers. You can place your control points slightly outside of
your contour line. As you go, place your cursor over the Bezier handle controls to reposition them. Hold
down the Alt key to move only one of the two Bezier control handles.
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4. To close Envelope deformer, hold downAlt and click on theOffset starting point.

NOTE: You can click on any control point (not the Bezier handle) to start a new envelope chain from that point. Once
the control point is selected (white), click on the next location where you want to add a curve and a new chain will be
created, parented to the previous one.
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l When you have several chains controlling the same drawing or group of drawings, a
Deformation Composite node is automatically be created and appears in the Timeline
view. In the Additional Links section of the Timeline view, you can see which nodes are con-
nected to the Deformation Composite.

5. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

NOTE: It's not recommended to use the Envelope deformers on bitmap images and textures.

How to add a deformation node

1. In the Node Library view, select theDeformation category.

2. From theNode Library view, select a deformation node and drag it to theNode view. Note that the
Glue, MeshWarp, Refract, and Turbulence nodes are not directly related to deformation rigging. You
can read more about these effect in the Compositing and Effects Guide.

Adjusting the Deformation Chain

Once you have a deformation chain created, you can optimize its positioning to fit the element it will deform.
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How to set up Bone andGame Bone deformation chains

1. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to set.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer controls in the Camera view. This also hides all the deformer controls that were displayed.

3. In the Deformation toolbar, click the Rigging tool.

The chain turns from green to red. A green chain indicates the puppet is in animationmode. A red chain
indicates the puppet is in a resting position. Make sure your chain is red.

4. In the Camera view, set up the deformation chain.

‣ Rotate the first bone to change the angle of the chain.
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‣ Use the root control to reposition (offset) the entire chain.

‣ Use the control points to reposition the articulations. This will elongate, shorten or change the
direction of the bone and offset the subsequent children.
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‣ Use the articulation's control (square) to change the size of the articulation. For quality purposes, it is
recommended to have an articulation which fits the diameter of the part it controls.

5. Repeat until all the articulations and bones of the chain are correctly aligned to the element to which it is
linked. You can also set additional parameters in the Layer Properties window.

6. With the deformation nodes or group still selected, in the Deformation toolbar, click the Reset Current
Keyframe button. This will set the current resting position as the current frame one.

7. Use the Transform tool. For optimal results, make sure the size of the articulation is approximately the
same size as the drawing.

8. If you need to insert a bone between existing ones, hold down the Alt key. When the Insert Bone cursor is
displayed, click on the existing bone segment at the location where you want to add an additional bone.
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Display the Deformer Controls

Before you canmanipulate the deformer outside of the Rigging mode, youmust display the deformation
controls.

If you just created the deformation rig, the controls will still be showing. However, when you close your
project, the deformers are turned off. When reopening a project, youmust display the controls so you can you
see the ones you need while animating.

How to display the selected deformation controls

1. In the Camera, Node or Timeline view, select the drawing layer or deformation group or nodes con-
taining the deformation chain you want to display.

2. Do one of the following:

‣ In the Camera toolbar, click the Show Control button.

‣ From the top menu, select View > Show > Control.

‣ Press Shift + F11.

How to display the selected deformation controls and hide all the others

1. In the Camera, Node or Timeline view, select the drawing layer or deformation group or nodes con-
taining the deformation chain you want to display.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button.

The selected deformation controls appear in the Camera view and all the others are hidden.

How to display all the deformer controls at the same time

1. In the Top level of the Node view or in the Timeline view, select Edit > Select All from the top menu to
select all the nodes or press Ctrl + A (Windows/Linux) or⌘ + A (MacOS X).

2. In the Camera toolbar, click the Show Control button or press Shift + F11.

All deformation controls in scene are displayed.

How to hide the deformer controls

1. Do one of the following:

62



Harmony 12.1 Premium - Getting Started Guide (Server)

‣ In the Camera toolbar, click the Hide All Controls button.

‣ From the top menu, select View > Hide All Controls.

‣ Press Shift + C.

Animation

The controls to animate deformations work the same as those for setting up the chains. You simply need to
create keyframes and position the control points.

As Envelope deformations are composed of Curve deformations, there aremany similarities in the way they are
animated.

How to animate Bone andGame Bone deformations

1. In the Timeline view, go the frame onwhich you want to create the first animation pose.

2. In the Tools toolbar, select the Transform tool.

3. If you want to create animation keyframes, enable the Animate mode in the Tools toolbar.

4. Do one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

A keyframe is added on the current frame.

5. In the Node or Timeline view, select the deformation group or nodes containing the deformation chain you
want to animate—seeDisplay the Deformer Controls on page 62.

6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others button to display
the deformer of the selected piece.

7. In the Camera view, do the following:

l Rotate the first bone to rotate the limb.
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l Rotate the subsequent bones to bend the limb.

l Use the root control to reposition (offset) the entire chain.

l Use the control points to reposition the articulations. This will elongate, shorten, or
change the direction of the bone and offset the subsequent children.

l Use the articulation's control (square) to change the size of the articulation. For quality
purposes, it is recommended to have an articulation which fits the diameter of the part it
controls.
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8. In the Timeline view, go the frame onwhich you want to set the next key pose. You will need to expend the
exposure to see your drawings further down the Timeline view.

9. Add a keyframe on the current frame by doing one of the following:

l In the Timeline toolbar, click the Add Keyframe button.

l Right-click and select AddKeyframe.

l Press F6.

10. Repeat the previous steps to animate your character.

You can also manipulate the deformer by typing values directly in the Layer Properties of the deformation
effect nodes.
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Chapter 10: How to Animate a Cut-out Character

Harmony provides some great tools for animating puppets. You can create simple animation using the Transform
tool, as well as create advanced animation using both forward and inverse kinematics. Harmony has advanced
onion skinning and image swapping features to help you animate efficiently and quickly. For animation freedom,
you have the ability to mix several different techniques of animation, such as simple rigging, hierarchy and symbol
animation.

How to create a simple cut-out animation

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Tools toolbar, enable the Animate mode so everything youmovewill be keyframed auto-
matically.

3. From the top menu, select Animation > Stop-Motion Keyframe so the interpolation is not created auto-
matically between keyframes.

4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the framewhere you want to set the first pose.

6. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to the
pose, right-click and select AddKeyframe or press F6.

7. In the Camera view, select the parts to animate.
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8. Use the Transform tool to rotate, skew, scale or translate the selection to its new position. To
rotate the piece, place your cursor slightly outside of a corner until you see the rotation cursor.

A new keyframe appears in the Timeline view if you did not create one previously. Always create your
keyframe first.

9. In the Tools toolbar, enable theOnion Skin feature.

10. In the Timeline view, go to the framewhere you want to set the second keyframe. Youwill need to
expend the exposure to see your drawings further down the Timeline view.

11. To ensure that nothing moves on the new pose, in the Timeline view, select the frame corresponding to
the pose, right-click and select AddKeyframe or press F6.

12. In the Camera view, animate your character.
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13. Repeat this process for all the poses.

How to select the parent or child layer

1. In the Tools toolbar, select the Transform tool.

2. In the Transform Tool Properties view, make sure the Peg Selection mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Select Anim-
ation > Select Child or press Shift + B to select the child layer.

NOTE: These keyboard shortcuts ignore any effect node encountered in the Node or Timeline view. Only drawing
and peg nodes are considered. If you want to navigate the hierarchy including the effect nodes, you can create a
custom keyboard shortcut in the Preferences dialog box for the Select Parent Skipping Effects and Select Child
Skipping Effects commands on the General tab. Refer to the Harmony Preferences Guide to learn how to create
custom keyboard shortcuts.
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How to navigate among the siblings of the same parent

1. In the Node view, select a child of a parent and do the following:

‣ To select the previous sibling in the family, press /.

‣ To select the next sibling in the family, press the questionmark (?) key.

How to set ease on multiple parameters

1. In the Timeline view, select a keyframe from one or more layers.

NOTE: Only the first keyframe selected on each layer is considered when using the Set Ease for Multiple
Parameter function. If many keyframes are selected on the same layer, the ease values will be applied only to the
first one and the rest will be ignored.

2. Do one of the following:

‣ In the Timeline view, right-click and select Set Ease ForMultiple Parameters.

70



Harmony 12.1 Premium - Getting Started Guide (Server)

‣ In the Timeline toolbar, you can click the Set Ease For Multiple Parameters   button. If the button is
not in the toolbar, you can add it through the Toolbar Manager. Right-click on the toolbar and select
Customize.

The Set Ease For Multiple Parameters dialog box opens.

3. In the graph, pull on the Bezier handle to adjust the velocity for all the selected functions.

4. To apply these easing parameters to a certain type of function only, such as Rotation or Scale, in the Filters
section, deselect the function types you do not want to affect.

‣ Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z and 3D Path
functions

‣ Rotation: Applies the easing parameters to the selected Angle functions.

‣ Scale: Applies the easing parameters to the selected Scale functions.

‣ Skew: Applies the easing parameters to the selected Skew functions.

‣ Morphing: Applies the easing parameters to the selectedMorphing Velocity functions. Note that it is
applied to theMorphing Velocity function in the Layer Properties window, not to the basicMorphing
ease in the Tool Properties view.

‣ Other: Applies the easing parameters to all the other selected functions, such as all functions created
to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values are cal-
culated in percentage.
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‣ In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding to the
length of time youwant the easing to last. The valuemust be between 0% and 100%.

‣ In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong you
want the easing out. The valuemust be between 0% and 100%.

‣ If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Click one of the following buttons:

‣ Apply: Applies the easing parameters to the selected keyframes.

‣ Apply/Previous: Applies the easing parameters to the selected keyframes and then selects the
previous keyframe in the timeline.

‣ Apply/Next: Applies the easing parameters to the selected keyframes and then selects the next
keyframe in the timeline.

‣ Close: Closes the dialog box. If you did not apply themodifications, they will be cancelled.
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Chapter 11: How to Create Templates
You can create a template from a layer or from cells. You can store anything available in the Timeline view as a
template.

When creating a template from the Timeline view, it will lose the extra connections, effects and groupings from
theNode view.

Creating a template by selecting a layer will incorporate the layer and all the drawings that were created in it,
even if they're not exposed in the Timeline view. Selecting cells will only save those specific drawings in the
template.

How to create a template from the Timeline view

1. In the Timeline view, select some cells or layers.

2. In the Library view, select a folder to store the template.

3. If a library folder is locked, right-click and select Right toModify.

4. Drag the selection to the Stage Library folder or any other library folder.

5. In the Rename dialog box, give the new template a name.

To rename a template once it is created, right-click on the symbol and select Rename.

73



Chapter 11: How to Create Templates

6. Click OK.

How to import a template into the Timeline or Camera view

1. In the Library view, select the template you want to import.

2. Drag the selected template to the Camera view or to the left side of the Timeline view.

3. You can also drag a template to the right side of the Timeline view and into existing layers if the layer
structure is the same as the existing one.

Creating a Template from the Node View

The Timeline and Node views display different information about a scene.

Amain character's template, also known as amaster template, is created from theNode view. This template
contains all the connections, effects, composites, nodes, pegs, advanced groupings, function columns, scene
lengths, drawings, timings, and so on. The template is saved in the Library view andmust be imported back
into the scene for use, either into theNode view or the left side of the Timeline view.
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NOTE: If you are creating a template from a character rig master template, you should collapse everything inside a
master peg and put a keyframe on the first frame before creating the template.

How to create a template from the Node view

1. In the Library view, select the folder in which you want to store the template.

2. If the library folder is locked, right-click and select Right toModify.

3. In the Node view, select the nodes for creating the template and group them. It is very important to group
your cut-out character rig before storing it in the Library, so your files are organized.

4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G (Windows/Linux) or
⌘ + G (MacOS X). Make sure you have a composite under the connections before grouping, otherwise
there will be numerous connections going outside the group.

5. In the Node view, click on the group node's yellow button to open the Layer Properties window.

6. In the Node view, select the group node and copy and paste it inside the template folder in the Library
view or press Ctrl + C and Ctrl + V (Windows/Linux) or⌘ + C and⌘ + V (MacOS X).
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7. In the Rename dialog box, give the new template a name and click OK.
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Chapter 12: How to Set Up a Scene
Setting up your scene can be compared to building a set for a television show. This is the point when you position
each scene element such as the camera frame, the background elements and the characters.

Positioning the Camera

The scene action occurs inside the camera frame, so it’s really important to set it up correctly. You can adjust the
camera resolution and other parameters in the Scene Settings window. Refer to the Fundamentals Guide,
Starting Harmony chapter to learnmore. If you're working in a gaming animation pipeline, you also have to
possibility to set an orthographic camera.

The Camera layer is static whichmeans that if you need to animate it, youmust add a peg.

You need to add a camera layer to your scene, so you can edit the camera frame. You can only see one camera at
a time. If you add several cameras to your scene, you can use the Camera list to select the active one. You could
use this feature if you are still working on your scene composition and have different camera framing to try out.

You can reposition your camera frame directly in the Camera view, using the advanced animation tools. Another
way to set up your camera frame is to type the coordinates directly in the camera's properties. Doing this
positions the camera precisely where you want it to be rather than gauging it visually.

You can easily reset the camera to its original position. Using the Reset command, you can reset the value of the
selected element to the initial value of the active tool. For example, if the Rotate tool is active, the
transformation angle will be reset to 0 and if the Transform tool is active, then all parameters values will be
reset.

How to add a camera in the Timeline view

1. Do one of the following:

‣ In the Timeline view, click the Add Layer button and select Camera.

‣ From the top menu, select Insert > Camera.

A new camera layer is added to the scene and appears in the Timeline view.

NOTE: You cannot add a camera inside a symbol.

How to add a camera in the Node view

1. In the Node Library view, select theCamera node from the Favourites or Move category.
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2. Drag the Camera node to theNode view.

How to reposition the camera frame directly in the Camera view

1. In the Tools toolbar, disable the Animate mode.

2. Do one of the following:

‣ From the top menu, select Animation > Tools > Translate.

‣ In the Advanced Animation toolbar, click the Translate tool.

‣ Press Alt + 2.

3. In the Camera view, click on the camera frame (thin rectangle) to select it. You can also select the cam-
era layer from the Timeline or Node view.

The selected camera frame is highlighted.
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4. Drag the camera frame to a new position.

5. To tilt the camera frame, do one of the following to select the Rotate tool:

‣ From the top menu, select Animation > Tools > Rotate.

‣ In the Advanced Animation toolbar, select the Rotate tool.

‣ Pres Alt + 3.

6. In the Camera view, drag to rotate the camera frame until it reaches the desired rotation angle.
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How to reset the camera position

1. In the Tools toolbar, select the Transform tool or press Shift + T.

2. In the Timeline, Node, or Camera view, select the camera layer.

3. From the top menu, select Animation > Reset or press Shift + R.

The camera automatically returns to its original position.

Positioning Objects

Setting up the scene also involves positioning the different scene elements within the camera frame.

How to pan a layer using the Transform tool

1. In the Tools toolbar, disable the Animate mode.

2. In the Tools toolbar, select the Transform tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg SelectionMode is deselected.

4. In the Camera view, select a drawing layer and drag the selection to a new area. You can select multiple
layers to reposition them at the same time. Hold down Shift and select the different layers.
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How to rotate a layer using the Transform tool

1. In the Tools toolbar, disable the Animate mode.

2. In the Tools toolbar, select the Transform tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg SelectionMode is deselected.

4. In the Camera view, select a drawing layer.

5. Place the pointer outside of a corner of the bounding box and drag to rotate.

NOTE:
You can display a rotation handle on the bounding box when transforming a layer. In the Preferences dialog box,
select the Camera tab and then select the Use Rotation Lever with Transformation Tools option. This preference is
off by default.

How to scale a layer using the Transform tool

1. In the Tools toolbar, disable the Animate mode.

2. In the Tools toolbar, select the Transform tool or press Shift + T.
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3. In the Tool Properties view, make sure the Peg SelectionMode is deselected.

4. In the Camera view, select a drawing layer and push or pull on the size, top, or corner control point.
Hold down Shift to lock the selection's aspect ratio.

How to skew a layer using the Transform tool

1. In the Tools toolbar, disable the Animate mode.

2. In the Tools toolbar, select the Transform tool or press Shift + T.

3. In the Tool Properties view, make sure the Peg SelectionMode is deselected.

4. In the Camera view, select a drawing layer.

5. Place the pointer between two controls points and drag sideways or up and down.

Repositioning the Pivot

Transformations, such as rotation, scale, skew and flip, aremade relative to the pivot point position. You can
reposition this pivot point anywhere using the advanced animation tools.

How to permanently reposition the pivot point

1. In the Advanced Animation toolbar, select the Translate , Rotate , Scale , or Skew tool.

2. In the Camera view, Ctrl + click (Windows/Linux) or⌘ + click (MacOS X) to select your element.

The pivot point appears in the Camera view.
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3. Drag the pivot point to a new position.

All transformations, including existing ones will be recalculated from this new pivot postion.
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Chapter 13: How to Animate Objects and the Camera
When it comes to animating objects, you will do this on layers by creating motion paths. You can also animate the
camera which is just like any other object you can animate.

Animating a Layer

You can create a motion path directly on layers (animated layers).

You can control and define a trajectory using several different parameters, including:

• X, Y and Z positions (3D Path or Separate Positions)

• Angle (rotation)

• Skew

• X and Y Scales

• Euler Angle or Quaternion Angle (when 3D option is enabled)

• Z Scale (when 3D option is enabled)

Each parameter has its own function curve where you can add keyframes and control the easing. If you're not
familiar with graphs and function curves, these are easy-to-use tools for visually controlling trajectories in the
Camera and Timeline views.

How to animate a layer

1. In the Tools toolbar, select the Transform
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tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg SelectionMode is deselected.

3. In the Tools toolbar, enable the Animate mode. This will create keyframes at the current frame
whenmoving objects.

1. In the Timeline view, go to the first frame.

2. In the Camera view, select the element to animate and move it to its first position.

A keyframe is created on the first frame of the Timeline view.

3. In the Timeline view, go to the frame onwhich you want to set the second position.

4. In the Camera view, move the element to its second position.
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A second keyframe is created on the Timeline view.

5. Play back your animation.

To see your motion animations in the Top, Side or Perspective views while you play back, youmust turn on
the Playback option. From the top menu, select Play > Enable Playback > Top View or Side View or
Perspective View.

Animating the Camera

The camera is treated the sameway as any other element. You can use the same tools and selectionmodes to
offset or animate it, but the camera is a static object. To animate the camera, you need to connect it to a peg
layer. A peg is a trajectory layer.

While making camera moves, you can use the Top, Side, and Camera views.

How to open the Top and Side views

1. Do one of the following:

‣ From the top menu, selectWindows > Top or Side.

‣ From any view already open, click the Add View button at the top-right corner and select Top or
Side.

How to add a camera and parent it to a peg

1. If you don't already have a camera layer, do one of the following:

‣ From the top menu, select Insert > Camera.

‣ From the Layers toolbar, click the Add Layers button and select Camera.
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‣ From theNode Library view, select a Camera node and drag it to theNode view.

A new camera layer is added to the scene and appears in the Timeline view.

2. In the Timeline view, select the Camera layer.

3. From the Layers toolbar, click the Add Peg button.

A Peg layer appears directly above the Camera layer, which is automatically attached to it.

The Peg layer automatically takes the name of the camera and adds the suffix -P to indicate that it is a
Peg layer, for example Camera-P.

If the new Peg layer did not appear directly above the camera, youmay have clicked elsewhere in the
scene, which deactivated the layer on which you want to add the Peg layer. To fix this:

‣ Select the Camera layer and drag and drop it under the new Peg layer. Or delete themisplaced Peg
layer, select the Camera layer and click the Add Peg button again.

‣ From theNode Library view, select a Peg node and drag it to theNode view. Then connect the
peg’s output port to the camera’s input port.

You can also press Ctrl + P (Windows/Linux) or⌘ + P (MacOS X) to create a peg and connect it to
the camera, or select the Camera node and press Ctrl + P (Windows/Linux) or⌘ + P (MacOS X) to
create a peg.

‣ You can unparent layers by holding down Shift and dragging the selected parents away from the
child layer. Drop your selected between other layers.
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How to animate the camera

1. In the Tools toolbar, enable the Animate mode.

4. In the Tools toolbar, select the Transform tool or press Shift + T.

2. On the right side of the Timeline view, on the Camera Peg layer, select the frame at which you want the
camera move to start.

3. Do one of the following:

‣ In the Timeline toolbar, click the Add Keyframe button.

‣ Right-click and select Insert Keyframe.

‣ Press F6.

A keyframe appears in that cell. Any frames preceding this keyframe cell will hold the same camera
position as this keyframe.

4. In the Top, Side or Camera view, select the camera (the large V-shaped cone) and move it to the desired
position. In the Camera view, the camera is represented by a thin frame. You need to click directly on one
of the edges.

5. On the Timeline view, click on another cell a bit further down in time to indicate where the camera move
will end.

6. Select the camera in the Camera, Top or Side view andmove it to the desired position.
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A second keyframe appears and a line is created between the two frames to indicate that the
subsequent motion between the frames will be calculated and rendered by the program.

7. Play back your animation.
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Chapter 14: How to Create a Multiplane

To construct a multiplane, youmust imagine what a real environment is like. Take a look at your background
picture and imagine a camera moving through the space. Notice that objects in the picturemove at different
speeds depending onwhere they are in relation to the camera lens.

Building a multiplane requires an understanding of the scene's background, as well as the positioning of the
elements on different layers.

For example, in the background illustrated above, themain objects to be separated are:
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1. Fern

2. Front tower

3. Second tower

4. Moon

5. Stars

6. Sky

Although the bottom of the tower is hidden behind the plant and the ladder, each of themultiplane layers
should be a complete drawing. This is because hidden portions may show up during a camera move later on in
the scene.

You can position layers on the Z-axis using the Side and Top view.

Positioning your element closer to the camera makes them appear bigger. You can also move elements
towards the camera or away from the camera while keeping the same size aspect ratio in the Camera view.

It is a good idea to keep a Camera view open to see what your scene looks like while positioning elements in
the Top and Side views.

You can see the cumulative Z value information in the Coordinates and Control Points view. When you select a
drawing cell that includes a keyframe, it will display the cumulative Z value.

When a layer is parented to other layers that aremoved forward or backward on the Z-axis, the currently
selected layer's position Z valuemay not be accurate since its parent will also have an offset on the Z-axis. The
Cumulative Z value is a compilation of all the Z-axis offsets to give the real Z-axis offset value related to the
(0,0) centre.
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How to position an element in the Top and Side views

NOTE: Before distributing layers along the Z-axis using the Top and Side views, deselect the No Z Dragging option by
selecting Animation > No Z Dragging. This option is disabled by default.

1. To maintain the visual scale in the Camera view as youmove your element, do one of the following:

‣ In the Advanced Animation toolbar, select theMaintain Size tool.

‣ From the top menu, select Animation > Tools > Maintain Size.

‣ Press Alt + 6.

2. In the Side or Top view, select one of the layers in the thumbnails section. You can also select a layer from
the Timeline view.

The selected layer is highlighted in the Top, Side and Camera views.
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3. Drag the layer to the correct depth position in the camera cone. Your element aspect will remain the
same in the Camera view.

4. For your element to scale up or down in relation to their distance to the camera, do one of the fol-
lowing:

‣ In the Tools toolbar, select the Transform tool. Make sure the Peg SelectionMode option is
disabled in the Tool Properties view.

‣ In the Advanced Animation toolbar, select the Translate tool and select a layer from the
thumbnails section of the Top or Side view.

‣ Select a layer from the Timeline view.

The selected layer is highlighted in the camera cone.

5. In the Top view, drag the element sideways to position it horizontally. Hold Shift while dragging the ele-
ment to make sure it only moves along the X-axis.
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6. In the Side view, drag the selected element up or down to position it vertically. Hold Shift while dragging
the element to make sure it only moves along the Y-axis.
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Chapter 15: How to Set Up Objects in 3D Space
Once your drawings and symbols are assembled, it is time to position them. This section explains how this is
done using the example of a simple room.

How to position layers in 3D space

1. In the Timeline view, double-click on the new layer to open the Layer Properties dialog box.

2. In the Transformation tab, select the Enable 3D option.

3. In the Rotation section, select the Euler Angles option.

4. In the (x) Axis field, type 90 to flip the floor so it is flat on the ground.

NOTE: Use the Perspective view to see this. Press Ctrl + Alt (Windows/Linux) or⌘ + Alt (Mac OS X) to change the
angle of the view.

5. To position the height of the floor, type values in the Position section of the Layer Properties, use the
Translate tool or Transform tool.
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6. Repeat the process for the other pieces to position.

7. If you have parallel walls, once you have positioned one, select theWall layer in the Timeline view.

8. Do one of the following to duplicated the layer.

‣ From the top menu, select Edit > Duplicate.

‣ Right-click and select Edit > Duplicate.

NOTE: If the drawing is contained within a symbol, the symbol will not be duplicated, only the layer containing the
symbol. This way, you are still using the same drawing.

9. Once the layer is duplicated, use the Layer Properties window to enter the positioning values or use the
transformation tools.

10. When using the transformation tools, use the Camera, Top, or Side view to position the elements
instead of the Perspective view to position your layers precisely.
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11. If your walls are touching each other, you should make them intersect by extending one end of the wall
through the other wall. This prevents seeing a small gap between them.

Now have a complete 3D room.
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Chapter 16: How to Import Sound and Add Lip-Sync

If you decide to add sound to your animation, youmust first prepare the sound outside of Harmony. Once this is
done, youmust add a sound element in Harmony to the organize the sound files in your animation. Sound will play
in themovie until it reaches the end of the file or a stop frame that you created in the Sound Element Editor.

If you first create your project in Toon Boom Storyboard Pro, the sound will be cut up into the different scenes for
you automatically.

You can import .wav, .aiff or .mp3 sound files.

How to import a sound file

1. Do one of the following:

‣ From the top menu, select File > Import > Sound.

‣ In the Xsheet view, right-click anywhere in the frame area and select Import > Sounds.

‣ From the Xsheet menu, select File > Import > Sounds.

‣ From the Timelinemenu, select Import > Sounds.

The Select Sound File dialog box opens.

1. From the Select Sound File dialog box, find and select a sound file.

The sound file appears as a layer in the Timeline and Xsheet views.

Lip-Sync

Adding a lip-sync to a project can really enhance its quality and storytelling. However, it can be difficult to shape a
character's mouth to match the sound at a precise frame.

To solve this problem, Harmony provides a lip-sync feature which analyzes the contents of a sound element and
generates a mouth chart (see below) based on the eight animation phonemes (A, B, C, D, E, F, G, and X for
silence).
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Themouth shapes used by Harmony are based on the conventional mouth chart used in the animation
industry.

NOTE: The letters used to represent the shapes do NOT correspond to an actual sound.

Here is an approximation of the sound eachmouth shape can produce:

• A: m, b, p, h

• B: s, d, j, i, k, t

• C: e, a

• D: A, E

• E: o

• F: u, oo

• G: f, ph

• X: Silence, undetermined sound

You can lip-sync the traditional way or let the system automatically create the basic detection.

You can refer to themouth chart positions as you draw the shape of the character's mouth.

Automatic Lip-Sync Detection

Harmony can automatically map drawings in an element to themouth chart you have generated for a sound.
This can save timewhen you are lip-synching a voice track.

In the Layer Properties view, you can identify each lip drawing of a character. Harmony then automatically
labels all of the cells in the character's element with the appropriate name.
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How to generate a sound detection for lip-sync using the Layer Properties view

1. In the Timeline or Xsheet view, select the sound layer.

The options for that layer will appear in the Layer Properties view.

2. In the Layer Properties, click Detect.

A progress bar appears while Harmony analyzes the selected sound clips and assigns a lip-sync letter to
each sound cell.

3. Click theMap button to open the Lip-SyncMapping dialog box.

4. From the Destination Layer menu, select the layer that contains themouth positions for the character's
voice track.
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5. If the selected layer contains symbols, you canmap the lip-sync using drawings located directly on the
layer or use the symbol's frames. In the Symbol Layer field select Don't Use Any Symbol if you want to
use the drawings or select the desired symbol from the drop-downmenu.

6. In theMapping section, type the drawing name or Symbol frames in the field to the right of the phon-
eme it represents. If your drawings are already named with the phoneme letters, you do not have to do
anything.

7. Click OK.

8. Press the Play button in the Playback toolbar to see and hear the results in the Camera view. To
play back your scene with sound, enable the Sound button in the Playback toolbar.
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Chapter 17: How to Add Effects to a Scene

Once your animation is completed, you can add effects such as blurs and glows to make your project look even
better! Harmony provides you with a series of essential effects that you can add to your layers.

About Effects

An effect always needs a drawing connection and sometimes a matte or shape connection. Amatte provides
drawing information that determines the area on which the effect will be applied on the drawing. The details and
colours within thematte drawing don't matter, as only the shape and transparencies are used. Amatte is also
known asmask.

Thematte principle can be demonstrated with the Cutter effect.

In general, a drawing layer is connected to the right port of the effect and thematte (mask) to the left.

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter
requires a matte input.
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Adjust the Cutter properties to invert the effect of thematte on an image. Instead of the object being hidden
by themask, it will only be visible where it intersects with thematte shape area.

You can adjust the effect parameters in the Layer Properties view and link any of them to a function column to
be animated over time. This means that all of the effects can be customized.

If, in addition to having one layer cut by another layer, you still want to see the cut layer, drag another
connection from that drawing node's port and connect it to the composite.

Adding Effects

In Harmony, you can add effects through theNode view. You can select an effect from theNode Library view,
drag it to theNode view and connect it to drawing layers to form a network of nodes. Then, by adjusting each
node's parameters, you can achieve exactly the look you have inmind.

Although all effects should be added through theNode view, there are some effects that you can also quickly
add through the Timeline view.

Working with the Node View and Node View Library

If you need to add new effects and other nodes to theNode view, you will need to get them from theNode
Library view.
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When you create a new project in Harmony, the default node system that appears in the Node view looks similar
to the one below.

How to add effects in the Node view

1. In the Node Library view, select a node and drag it to theNode view.
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2. In the Node view, click on the input or output port of a node and drag out a cable.

3. Connect the cable to the output port or input port of another node.

4. To connect a node between two connected nodes, use the Alt key as you drag the new node over the
existing cable connection. Use the sameAlt key to disconnect a node.

5. To remove a node, select and press Delete to remove it from theNode view.
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Cutter Effect

The Cutter effect cuts out a portion of an image using a matte drawing. You can use the Cutter effect to allow a
character to disappear behind a background element or to cut a virtual hole into the layer itself. The Cutter
requires a matte input.

Adjust the Cutter properties to invert the effect of thematte on an image. Instead of the object being hidden by
themask, it will only be visible where it intersects with thematte shape area.

How to use the Cutter effect

1. Select a drawing layer and do one of the following:

‣ From theNode Library view, select theCutter effect and drag it to theNode view.

‣ In the Node view, right-click and select Insert > Combine > Cutter.

2. Connect theCutter node between the drawing and Composite node.
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3. In the Drawing or Camera view, create a drawing on a new layer that will act as thematte.

4. In the Timeline view, click the Collapse/Expand button on the effect layer.

1. Do one of the following:

‣ Drag and drop thematte layer beside theMatte field.

‣ Connect theMatte drawing to theMatte port of the Cutter node.

5. Display the Cutter properties and adjust the properties to control the type and amount of blur and the
colour of the Cutter effect.

110



Harmony 12.1 Premium - Getting Started Guide (Server)

Cutter Properties

Parameter Description

Name Allows you to change the node's name.

Inverted
When this option is enabled, the Cutter nodewill invert thematte shape to cut
the drawing. Instead of cutting the image intersecting with thematte, it will cut
any artwork outside of thematte shape.

Animating an Effect Over Time

When compositing your scene, you will often want to animate the parameters of an effect over time. For example,
youmay want an object to fade in or out by changing the transparency level over time or by increasing the colour
contrast on one of your drawings over a certain frame range.

To animate an effect over time, create a function curve by adding keyframes to the parameters you want to
animate. To do this, you will use these views: Layer Properties, Node and Timeline. You can fine tune your
animation using the Function view.

How to animate an effect over time

1. Add an effect node to theNode view by doing one of the following:

‣ Right-click in the Node view and select Insert > desired effect.

‣ Drag a node from theNode Library view to theNode view.

111



Chapter 17: How to Add Effects to a Scene

2. Connect the effect between the drawing element on which you want to apply the effect and a composite
node. You can do this bymanually unplugging and plugging, or by holding Alt as you drag it through a
connection.

The effect also appears in the Timeline view.

3. Create the function curve by doing one of the following:

‣ Double-click on the effect layer to display the effect properties. Click the Function button of the
parameter you want to animate and create a function curve.

‣ In the Timeline view, expand the effect layer's parameters by clicking the Collapse/Expand
button. Then click the Function button of the parameter you want to animate and create a
function curve.
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4. In the Timeline view, go to the frame onwhich you want to start animating the effect.

5. In the Timeline toolbar, click the Add Keyframe button.

6. In the Value field of the parameter you want to animation, enter the keyframe value. If your keyframes are
stop-motion keyframes, in the Timeline view, select the new keyframes. Right-click and select Set Motion
Keyframe.

7. Repeat this process for each keyframe to be added.
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Chapter 18: How to Export a Movie
If you require a video file, you can export your animation as a QuickTimemovie. To render a QuickTimemovie
with transparency, you need to set the Depth to Millions of Colours +. You can set this this when exporting a
QuickTimemovie.

If your exported video is too small or too large, you can change the project size from the top menu in Scene >
Scene Settings. This will change the size of the video output.

How to export a QuickTime Movie

1. From the top menu, select File > Export > Movie.

The Export to QuickTimeMovie dialog box opens.

2. Click Browse and select a folder in which to save your movie and give it a file name for the export.

3. Click OK.

1. In the Display Source section, select the Display node to use for rendering your project.

If there is no Display node in the scene, the drop-down list will indicate Display All and render the scene in
the same order as the Timeline view, including nodes floating in theNode view. It is always recommended
to render from the Display node, located under the final Composite node, unless you want to render a
specific section isolated by a particular Display node.

2. From the Export Range section, decide whether you want to export the entire scene (All) or a specific
frame range. If you decide on the latter, enter the frame range.

3. In the Resolution section, select one of the following from themenu:

‣ Apreferred resolution ratio.
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‣ Custom: Enables theWidth and Height fields so you can enter a specific size.

4. In theOptions section, clickMovie Options.

Parameter Description

Video

Enables the customization of the video settings, filters and
size.

Settings: Opens the Standard Video Compression Settings dia-
log box (see below).

Filter: Opens the Choose Video Filter dialog box, where you
can select from a range of filters to apply to your video export.

Size: Opens the Export Size Settings dialog box. The size set-
tings are overridden by the Harmony's scene settings.

Sound
Enables the customization of the sound settings.

Settings: Opens the Sound Settings dialog box (see below).

Prepare for Internet Stream-
ing

Enables the customization of the Internet streaming options.

5. In the Video section, click Settings.

The Standard Video Compression Settings dialog box opens.
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6. From the Compression Typemenu, select a codec. The availability of certain compression settings
depends on the Compression Type selected. For example, Animation is the default compression type and
as a result the Data Rate option is greyed out.

7. In theMotion section, choose a Frame Rate from the list.

By default, it is set to match the frames-per-second (fps) of your Harmony project. If you choose a lower
frame rate, your export playback will be faster than your actual project. The reverse is also true for a
higher frame rate.

8. If you want keyframes inserted, select the Every option and set the number per frame.

This is the option is recommended byQuickTime. For further details, refer to theQuickTime
documentation.

9. In the Compressor section, select a Depth based on your movie’s needs. For example, Millions of Col-
ours+ houses an alpha channel.

10. In theQuality section, use the slider to choose a quality setting. Remember that the better the quality of
the export, the larger the file.

11. From the Data Rate section, either choose to allow the program to automatically select themost optimal
bit rate, or enter a Restricted rate to save space and allow for faster downloading at a cost to the quality
of the export.

12. In the same section, from theOptimized For menu, select the intended viewing method for the export.

13. Click OK.
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14. From theMovie Settings dialog box, click Sound Settings.

The Sound Settings dialog box opens.

15. From the Compressor menu, select a compression type.

The default setting is None. This will preserve your original sound file without the loss of information.
However, an uncompressed sound file will inevitably add “weight” to the overall size of your video
export.

16. From the Ratemenu, select a rate.

It is best to check and match the original properties of your sound file. For example, if your file has an
audio sample rate of 48 kHz and you choose a conversion rate of 22.05 kHz, the sound will play at the
same speed, but with higher frequencies missing.

For a standard film sound quality, choose 44.1 kHz, or 48 kHz for DVD quality. Anything less will make
the sound “dull” or less bright. For things like recorded voice, this doesn't matter so much, but for
music it canmake an audible difference.

If file size is a consideration, such as with videos for the Internet, then a lower ratemight bemore
practical.

17. Select the Size andUse, which are related. Once again, it is advisable to check your original sound file
properties. If the file was recorded in one channel (mono), there is no point in choosing the two channel
(stereo) option. AlthoughMono can support a 16-bit channel, the extra information is unnecessary.
Mono is generally paired with 8-bit and Stereo with 16-bit.

18. Click OK.

19. In the Export to QuickTimeMovie dialog box, click OK.

A progress bar appears.

20. Browse to the location on your computer where you saved your QuickTime video and double-click on it
to view the export.

How to set the depth toMillions of Colours + to export a QuickTime movie with transparency

‣ In the Standard Video Compression Settings dialog box, selectMillions of Colors+ from the Depth
menu.

118



Harmony 12.1 Premium - Getting Started Guide (Server)

119



Harmony 12.1 Premium - Getting Started Guide (Server)

120



Harmony 12.1 Premium - Getting Started Guide (Server)

Glossary

alpha channel

An image channel that carries transparency information. An image already has
three channels: red, green and blue (RGB). The alpha channel is the fourth
channel (RGBA). Thematte, or the transparency information, is stored in this
fourth channel. An imagewithout an alpha channel is always opaque.

animatic

Amovie with sound that is developed from the storyboard. The storyboard
panel is exposed for the duration of the scene and at times, the characters are
placed on a trajectory to indicatemotion. The camera moves are also
animated. The animatic is used to determine the rhythm of a project and
provides a good overview of the project before beginning production.

animation A simulation of movement created by displaying a series of pictures or frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc
Action rarely occurs in a straight-forward manner; rather it typically unfolds in
what storytellers refer to as an arc. The purpose of a story arc is to move a
character or situation from one state or scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any scene,
frame or film format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed
An automated method of feeding drawings into a scanner in whichmultiple
drawings are stacked into a sheet feeder. When the scanner is activated, the
drawings are scanned consecutively, without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to themouth chart generated
for a sound. This can save timewhen lip-syncing a voice track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z (depth).

background
The part of a scene that is farthest to the rear. The background is the artwork,
or decor, against which the animation takes place.

Bézier
Amethod of defining curved lines invented by Frenchmathematician Pierre
Bézier. A Bézier curve is a mathematical or parametric curve. Bézier curves use
at least three points to define a curve.

bitmap
An image composed of pixels with a single resolution (size). If it is enlarged
too much, it will lose definition and pixels will begin to appear. This is known
as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a character into
pieces to create a puppet with articulations. To break down a character, the
artist cuts parts, such as the hands and arms, from the character's model and
pastes them in separate layers. Next, the joints are fixed and the pivots set.

In traditional animation, a breakdown is an animation pose generally found
between two key poses. The key poses are themain poses in an animation
and the breakdowns are secondary poses, ones that help describe themotion
and the rotation curve (usually referred to as an arc).
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camera shake
Camera shake occurs in a scene when the camera moves slightly and quickly in
several directions. This gives the impression of an impact, vibration or, for
example, bumps on the road.

caption
A text field containing dialogue, effects, sound, or slugging information in a
storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent sheet
on which the animation is inked and painted before being sent to the camera.
The picture's outline is drawn on the front of the cel and then coloured along
the back.

In Harmony, a cel is an individual space in an Xsheet column fromwhich you can
expose a drawing or a function's coordinate.

character design
Each character in an animated film is drawn frommultiple angles in poster-
style format, called amodel sheet, which serves as a reference for the
animators.

clean up

After rough drawings have been tested and approved, all the noise in the
image (excess lines, notes, etc) is removed to create final drawings which can
be inked, painted and shot. The cleanup process refers to either tracing a
clean line over a rough drawing to achieve the final version, or removing dirt
and extra lines left by the scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by printers to define
colour on the printed page.

colour card
A colour card is a solid colour card that is the same size as the camera. The
colour card can be used to fill the background with a solid colour when there is
no background image included.

colour model
The official colour design that must be used to paint the animation. Amodel is
the definitive character, prop, or location design that each artist must follow
for the production.

colour wheel Adisplay of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to create
the final result prior to rendering. For example, the compositing artist will
import all the animation sequences, background, overlays and underlays in the
scene and position them correctly. The artist will then set the camera frame
and animate it, if needed. Finally, the animator will create all the computer-
generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
Adirect transition between two scenes. When a cut is used, there are no
transition effects inserted to pass from one scene to the next. The first scene
ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces bymoving them
around frame by frame. Cut-out animation can either be computer generated
or done traditionally using paper.

cycle
Agroup of images that together make up an action, such as walking. A cycle is
an action repeated as a loop over a period of time. It can be a series of
animated drawings or keyframes.
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dialogue The text spoken by a character in a movie or animation.

dope sheet
Used by animators, directors and other members of a crew to track the
sequence and timing of images, dialogue, sound effects, sound tracks and
camera moves. Also known as an exposure sheet or Xsheet.

doping To assign a particular drawing to a range of frames.

DPI

Dots per inch is the standard measure of resolution for computerized printers.
It is sometimes applied to screens, in which case it should more accurately be
referred to as pixels per inch. Either way, the dot is the smallest discrete
element making up the image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration and
deceleration of a motion. It can be a motion created by a function curve, or a
series of animated drawings. Other common terms for ease-in and ease-out
are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is
happening. For example, if a child is playing on the ground in front of his
house, the establishing shot would be a scene where the viewer can see the
house, the ground, a part of the street and the buildings around the central
point of action. This helps the viewer understand the story location and scene
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing appears in
the scene. For a drawing to appear longer, the exposuremust be extended
over a greater number of cels.

exposure sheet

A sheet with several vertical columns and horizontal frames used to indicate a
scene's timing. Each column represents a scene layer. The drawing numbers in
each column are indicated and repeated over the particular amount of frames
they need to appear.

The exposure sheet is used by animators, directors and other members of a
crew to track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A
fade in occurs when the first scene appears progressively, from complete
transparency to its complete opacity. A fade out occurs when the last scene
progressively disappears, going from complete opacity to complete
transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculatemotion,
registration and camera positioning. A standard animation scene will vary
between 6 to 12 fields.

field chart
Aguide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.
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film-1.33
A resolution that is ideal for the widescreen film format that conforms to the
standard 4:3 pixel aspect ratio.

film-1.66
A resolution that is ideal for the widescreen film format that conforms to the
16:9 pixel aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings of
an animation sequence very quickly in order to see the animation inmotion.
Flipping can also be the action of creating a mirror transformation of an
object.

follow-through

The secondarymotion caused by themain action. For example, a character
wearing a cloak is running. Themain action is the body running. This will cause
the cloak to follow themotion, although it will not move at the same time, but
react a few frames later and follow themainmotion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters and
cut-out puppets with hierarchy. It is used to animate a puppet from one of
parent parts, such as a shoulder, and make the rest of the armmovewith it as
a single piece.

frame
A single photographic image in a movie. In traditional animation, the North
American standard generally contains 24 frames per second, while in Europe
the standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are generally
calculated by frame per second. For example, a scene could be played back at
12, 24, 25, 30 or 60 frames per second or any other number.

This is themeasurement of the frequency (rate) at which an imaging device
produces unique consecutive images, called frames. The term applies equally
to computer graphics, video cameras, film cameras, and motion capture
systems.

Frame rate is most often expressed in frames per second (fps) and in
progressive-scanmonitors as hertz (Hz).

functions
A computer-generated motion, trajectory or path on which elements, other
trajectories and effects parameters can be attached. The function can be
controlled by adding keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than standard
television does because it has a greater number of lines of resolution. To take
advantage of the superior quality and make full use of your resolution setting,
the output devicemust be compatible with HDTV technology.

hold
A frame in the animation in which the character maintains its position without
moving. A hold can be created between any two keyframes.

HSV
Hue, Saturation, Value. Amethod of defining colours in terms of hue (tint),
saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn to create
fluid transitions between poses.

ink and paint The ink and paint process is the action of painting the empty zones and
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colouring the lines on the final animation drawings, while following a colour
model.

interpolation
The computer-generated motion created between two keyframes. You have
the choice to create interpolation, or not, between your keyframes.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually pleasing. It
is generally caused by one scene ending, and a second one starting, with a
similar image. The lack of difference causes the eye to see a little jump
between the two scenes.

key pose

Important positions in the action defining the starting and ending points of
any smooth transition. Keys, or key poses, are themain drawings in an
animation sequence describing themotion. For example, if an arm is waving,
the keys will be of the arm at one extremity of the wavemotion and the other
extremity. By flipping those drawings, the animator can see the skeleton of
themotion without having all the drawings.

keyboard shortcuts
One or more keyboard keys which, when used, cause an operation to be
performed.

keyframe
Important positions in the action defining the starting and ending points of
any action. A keyframe is a computer-generated position at a specific moment
(frame) on a given trajectory.

layers
In animation, a layer is an individual column, level or character. A scene's layers
are superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is the
action of putting the storyboard onmodel. That is, drawing the character by
following the design in themodel pack, so the animator can start working.

The layout artist draws the background, creates the camera and field guide
matching the scene and camera motion. Lastly, the animator draws onmodel
themain action poses.

layout and posing
The action of putting onmodel. That is, at the right scale, the storyboard for
the animator to start working.

library
A storage area containing templates and assets that can be reused in any
project or scene.

light table
Adevice that allows you to see other layers in transparency while you are
working on a particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync
The character's mouth synchronization with the dialogue sound track. Frame
by frame, themouth will be adjusted to fit the sound to give the illusion of the
character is speaking.

low resolution
A format that is ideal for videos destined for the web, where size and fast
download of a video file take precedence over quality. A low-resolution image
is one that lacks fine detail.

manual lip-sync detection
Themanual swapping of mouth position drawings to match a voice track. For
this process, both sound scrubbing (listening to a sound wave broken up
frame-by-frame) and drawing substitutions are used.
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master palette

A group of colours attributed to a character or prop. The palette is used
throughout the entire production to maintain consistency in the look and to
ensure that the same colours are used throughout the production. Also known
as palette.

model/colour model
The definitive character, prop or location design each artist must follow for a
production. A colour model is the official colour design that must be used to
paint the animation.

motion keyframe A keyframewith computer-generated interpolation.

mouth chart
A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X,
which is used to represent silence) used for lip-sync.

multiplane

The effect of passing throughmultiple levels of drawings to create a sense of
depth in a shot. Amultiplane is a scene in which the layers are placed at
different distances from the camera so that when the camera moves, a depth
illusion occurs. With a multiplane, all the perspective and scale is calculated
automatically.

NTSC
The standard analogue television broadcasting system used in North America.
NTSC conforms to North American standards on how rectangular pixels are
displayed for computer and television screens.

nudge
A small push (left, right, up, down, forward or backward) done with the
keyboard arrow keys on a selected element. Nudging is used to move a
selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay
Apart of the scene environment, such as a chair or a bush, that is placed in
front of themain animation.

PAL
A resolution that works best with the European format for television and
computer screens, as the rectangular pixels are displayed at a different
orientation.

palette/master palette

Apalette or master palette is a group of colours attributed to a character or a
prop. The palette is used throughout the entire project to maintain a
consistency in the look and avoid the colour changing during the animation.
Also referred to as a master palette.

palette style
Apalette style is a second version of an existing palette with a slight change in
the tint and value. A palette style can be used to create the night version of a
palette. It may also be called a clone palette.

pan To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be composed of one or
several panels.

paperless animation/tradigital
The paperless animation process is the action of animating digitally. Themain
paperless animation process is to draw, frame by frame, the animation directly
in the software.

passing position
When drawing a walk sequence for a character, the passing position is the
point at which one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.
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peg

In traditional animation, a tool used to ensure accurate registration of action
as cel layers move. In digital animation, in which you are doing a more
advanced puppet rigging, you can use peg layers. Peg layers are trajectory
layers that do not contain drawings. They aremotion paths that you can use
to add path articulations. For the latter, you can also use the Inverse
Kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel

The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a small
sample of an image, a dot, a square, or a very small sectionmade out of
smooth filtering. If you zoom in close enough on a digital image, you will see
the pixels, which look like small squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all themain
action poses, called key poses, and then placing the secondary poses between
the keys. The secondary poses are called breakdown. Finally, the animator fills
the gaps with the in-between drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the computer
takes each pixel that appears on screen and processes all of the components,
as well as adding motion blur before it produces a final image. The process of
calculating the final images after the compositing process.

resolution
The size of a scene, generally calculated in pixels. For example, the NTSC
resolution is 720 x 480. The resolution should match the final output: HDTV,
film-1.33, film-1.66, NTSC, PAL, low.

RGB
Red, Green, Blue. Amethod of defining colour by specifying amounts of these
three colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table
Equivalent to the animation disk/table, a device that allows you to rotate the
workspace for greater comfort while drawing.

rotoscoping
An animation technique in which animators trace over live-action film
movement, frame by frame, for use in animated films. The act of sketching
over live-action footage to create an animated sequence.

roughs
The skeleton sketch of an animation or design. Roughs mainly consist of
sketch lines and shapes, though they can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped by
the TV frame. As a TV frame cuts a margin off the original frame size,
maintaining a safe area ensures that the scene's main action will remain clearly
visible once the film is screened on television.

scene
A shot in a movie or show. A sequence is composed of several scenes. A scene
changes to another scene by a simple cut or transition.

script
The original text containing all themovie or show information. In animation,
the script contains all of the location descriptions, dialogue, time andmore. A
project starts with a script.
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sequence
A series of scenes or shots forming a distinct part of the story or movie,
usually connected by unity of location or time.

shot
A scene in a movie or show. A sequence is composed of several shots. A shot
changes to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing
Aprocess that lets you hear sound in real timewhile youmove the playhead
forward or backward. This is very useful for finely-tuning a lip-sync.

stop-motion keyframe A keyframewith no computer-generated interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The storyboard
indicates what will happen, when it will happen and how the objects in a scene
are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first position to the
last, in order. There is very little planning in this methodology. Where the
character ends up and how it gets there can be a surprise for both the
audience and the animator. While this approach is spontaneous and creative,
it can create inaccurate results.

strokes
Invisible vector lines forming the drawing zones. They can be adjusted with
Bézier handles.

tablet/pen
Adevice used in conjunction with, or instead of, a mouse to move a mouse
pointer (sometimes referred to as the cursor) around the computer screen.

template
An asset stored in the library that can be reused in any project. A template can
be a drawing, a series of keyframes, a sound file, a panel, a cut-out character,
an effect, a trajectory, an animation, or anything else used in the animation.

thumbnails A very small image used as a reference or indicator.

timecode
The timing information printed on a movie clip to indicate the scene, hour,
minute and second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or pencil
test, each drawing is traced and painted for the final animation. In today's
digital world, this may be done in a variety ways other than the traditional
celluloid or acetatemethods.

track breakdown
The break down of an animated film's soundtrack into individual sounds to
produce the precise frame-by-frame position of each sound.

traditional animation
A type of animation process whereby all the animation sequences are drawn
by hand on paper before scanning or inking them on cels.

trajectory
A computer-generated path or trajectory that elements can follow. The
trajectory can be controlled by control points, keyframes and velocity.

transition
An effect placed between two scenes as they pass from one to the other.
Common transition effects are cross-dissolve and wipe.
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underlay
In animation, an underlay is a specific part of the decor placed behind themain
animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid unit would
have a 1:1 ratio , whereas a grid unit of aspect ratio 4:3 is a unit with one side
1.33 times as big as the other side.

vector

A vector-based image is composed of points and Bézier curves. The computer
reads the points and traces the segments, linking them to reproduce the
image shape. There is no fixed size or resolution in a vector image. The
graphic can be enlarged and distorted as much as desired and the systemwill
simply recalculate the segments and rebuild the shapes. Vector images are
translated and displayed in pixels once the calculation is done.

velocity

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve, or via a
series of animated drawings. Other common terms for ease-in and ease-out
are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character. The
illusion of movement is created by the use of background pans. To avoid
making innumerable drawings, animators routinely make a walk cycle for a
character.

Xsheet (exposure sheet)

The Xsheet or exposure sheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the drawing numbers
are indicated and spread over the specific number of frames in which they
appear.

The exposure sheet is used by animators, directors and other members of the
crew to track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as dope sheet.

zone An area which can be painted with colour.
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3D

positioning layers 97

setting up objects 97

adding

views 7

alpha channel 121

animatic 121

animating

camera 85, 87, 89

effects over time 111

layers 85

objects 85

animation 121

anime 121

arc 121

aspect ratio 121, 129

auto-feed 121

axis 121

background 121

Bezier 121

bitmap images 121

converting to vector drawing 37

importing 31

importing as bitmap drawing 35

importing in original format 31

Bone deformer 49

animating bone and articulation
deformer 63

basic rig 52

Bone rig 52

Curve rig 54, 56

rigging 51

Bone rig

creating 52

breakdown 121

character 39

drawing pieces 39

parenting layers 44

camera

adding and parenting to peg 87

animating 85, 87, 89

positioning, scene setup 77

camera shake 122

caption 122

cel 122

celluloid

See cel. 122

character building

breaking down 39

cut-out 39

drawing pieces 39

parenting layers 44

character design 122

clean up 122

tracing 23

cleaning up 23

clockwise

rotating 10

Close Gap tool 18

closing

gaps 17

CMYK 122

colour card 122

colour model 122, 126

colour wheel 122

compositing 122

counterclockwise

rotating 10

cross dissolve 122

Curve rig

creating 54, 56

cut 122

cut-out animation 122

animating cut-out character 67

character building 39

creating 67

drawing pieces 39

navigating among brothers 70

selecting layers 69

cycle 122

deformation

adjusting deformation chain 58

basic rig 52

bone deform 49

Bone rig 52

chain, setting up bone and
articulation 59

Curve rig 54, 56

displaying deformer controls 62

rigging 51

dialogue 123

dope sheet 123

doping 123

DPI 123

drawing 13

pieces, character building 39

drawings

morphing 27

painting 16

ease 123

setting on multiple parameters 70

ease-in 123

ease-out 123

effects

about 105
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adding 105

animating over time 111

Tone 111

establishing shot 123

exporting

movie 119

QuickTime 119

exposure 123

exposure sheet 123, 129

fade-in 123

fade-out 123

field 123

field chart 123

film-1.33 124

film-1.66 124

flipping 124

follow-through 124

forward kinematics 124

frame 124

frame rate 124

full screen 10

functions 124

gamut 124

gaps

closing 17

HDTV 124

Hold 124

how to

paint 15

HSV 124

importing

bitmap image as bitmap drawing 35

bitmap image in original format 31

bitmap images 31

converting to vector drawing 37

sound file 101

templates 74

importing sound 101

in-between 124

ink and paint 124

interface 7

navigating 9

interpolation 125

jump cut 125

key pose 125

keyboard shortcuts 125

keyframes 125

layers 125

animating 85

panning with Transform tool 80

parenting 44

positioning in 3D space 97

rotating with Transform tool 81

selecting parent or child layer 69

skewing with Transform tool 82

layout 125

layout and posing 125

library 125

creating templates 73-74

Library view

importing templates 74

light table 125

line of action 125

lip-sync 101, 125

adding 101

auto detection 103, 121

lip-sync detection

manual 125

low resolution 125

manual lip-sync detection 125

master palette 126

master peg 46

adding 46

model 126

model sheet See character design

morphing

deleting 29

drawings 27

motion keyframe 126

mouth

chart 126

multiplane 126

creating 91

navigating

centering screen on mouse 10

full screen 10

interface 9

panning 10

recentering view 10

resetting pan 10

resetting rotation 10

resetting views 10

resetting zoom 10

rotating clockwise 10

rotating counterclockwise 10

zooming in 9

zooming in or out 10

zooming out 10

Node view

navigating siblings 70

NTSC 126

nudge 126

objects

animating 85

positioning 80
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setting up in 3D space 97

onion skinning 126

overlay 126

painting 15

drawings 16

PAL 126

palettes 126

style 126

panel 126

panning 10, 126

layer using Transform tool 80

resetting 10

paperless animation 126

parenting

layers 44

passing position 126

path of action 126

pegs 127

adding master 46

master 46

pen 128

phoneme 127

pivot 127

repositioning 82

repositioning permanently 82

pixel 127

pixelation See bitmap image

pose-to-pose 127

QuickTime

exporting 119

recentering

view 10

rendering 127

resetting

pan 10

rotation 10

views 10

zoom 10

resolution 127

RGB 127

rigging 51, 127

adding master peg 46

basic deformation rig 52

Bone rig 52

chain, setting up bone and
articulation 59

Curve rig 54, 56

displaying deformer controls 62

parenting layers 44

rotary table 127

rotating

layer with Transform tool 81

resetting rotation 10

rotating clockwise 10

rotating counterclockwise 10

rotoscoping 127

roughs 127

safe area 127

scaling

layer with Transform tool 81

scene setup 77

panning layer using Transform
tool 80

positioning camera 77

positioning objects 80

repositioning pivot 82

repositioning pivot permanently 82

rotating layer with Transform tool 81

scaling layer with Transform tool 81

skewing layer with Transform tool 82

scenes 127

script 127

scrubbing 128

sequences 128

shot 128

Side view

opening 87

positioning elements 93

skewing

layer with Transform tool 82

slow-in 128

slow-out 128

slugging 128

sound

importing 101

importing sound file 101

lip-sync 101

scrubbing 128

stop-motion keyframe 128

storyboard 128

straight-ahead 128

strokes 128

tablet 128

templates 128

creating 73

creating from Node view 74

importing 74

thumbnails 128

timecode 128

timeline 128

Tone effect 111

Tool Properties view 9

tools

Close Gap 18

Top view

opening 87
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positioning elements 93

trace and paint 128

tracing 23

track breakdown 128

tradigital 126

traditional animation 19, 128

painting 15-16

tracing animation 23

trajectory 128

Transform tool

panning layer 80

rotating layer 81

scaling layer 81

skewing layer 82

transition 128

underlay 129

vector 129

velocity 123, 129

views

adding 7

recentering 10

resetting 10

Tool Properties 9

walk cycle 129

Xsheet view 129

zone 129

zooming

in 9

in or out 10

out 10

resetting zoom 10
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