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Chapter 2: Toon Boom Harmony - About this Help
System
Toon BoomHarmony is an animation and digital content creation tool that offers you a wide array of features and
options. Harmony is packaged in several different modules and allows you to create animation using the
technique of your choice—seeAbout Toon BoomHarmony on page 11.

This help system is built to guide you through the different workflows possible and explains which tool and
module to use in a production context.

Help Structure 7

Tutorials and Other Help Tools 8

System Requirements 9

Help Structure
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Chapter 2: Toon Boom Harmony - About this Help System

The fundamental concepts of animation and Harmony are explained in this guide. It covers the essentials of
various animation workflows, basic animation principles, as well as Harmony's interface. Depending onwhat
you want to do, you can either start with this Fundamentals Guide to get immersed into the world of Harmony
and animation or go right to theGetting Started Guide , which covers themain functions and tasks. All
conceptual and reference topics are omitted to get you up and running in a very short amount of time.

If your work revolves more around system administration or coordination tasks, you will probably want to
move over to the Installation Guide followed by the Control Center Guide to learn how to install and configure
Harmony.

The core of this help system revolves around themain features and techniques you can use in Harmony to
create animation:

l Traditional Animation

l Paperless Animation

l Cut-out Animation

l Gaming Animation

All workflows join in the compositing step of the process. All the information on compositing in Harmony can
be found in the Compositing Guide. Finally, you can watch the rendered animations in the Playmodule. To
learn how to use the Playmodule, refer to the Play guide.

If you are focusing on a single part of the workflow such as ink and paint or scanning, you can simply read the
Fundamentals Guide and one of the corresponding module guides:

l Paint Guide

l ScanGuide

Other satellite guides are also available to learn about additional information such as the preferences and
keyboard shortcuts.

l Keyboard Shortcuts Guide

l Preferences Guide

l Scripting Guide

l Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to this
latest version, refer to:

l What's New (Release Notes)

Tutorials and Other Help Tools
Aside from themain product documentation, you can find supplementarymaterial to learnmore about
Harmony. The Toon Boomwebsite's online resources section offers a variety of videos and samples that can
further your knowledge of Harmony.

l Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

l Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network
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l Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

l White Papers: toonboom.com/solutions/white-papers

System Requirements
Here are the technical specifications for Harmony 12.1.

Harmony Server

Toon BoomHarmonyNetwork is a server-client configuration. The server stores all the assets, and holds the
database. The client machines simply run the software and allow themembers of your team to work on Harmony
and access the assets directly from the database.

NOTE: Note that an Internet connection is required to activate the animation software.

Before installing Harmony, refer to theHarmony and Your IT Department white paper to learn about the network
prerequisites for a Toon BoomHarmony installation. This document should be taken as a guide to help you
understand the preliminary steps before performing a typical Harmony installation.

There aremultiple ways of installing Harmony, as well as numerous types of hardware that can work with
Harmony. To perform a custom installation which fits the studio’s requirements, a proper analysis of the studio is
required, such as: the type of project, the productivity expected, and the delivery date, etc. If you are not yet
familiar with Harmony, you should get in touch with your sales contact at Toon Boom to organize a needs analysis
of your studio and production in order to make the best of Harmony and optimize your production pipeline.

The person who performs the installation should have the knowledge and expertise required for setting up and
configuring networks, computers, and operating systems. If you do not have an IT department or someonewho
knows the network technology thoroughly, contact your sales representative at Toon Boom to organize an
installation with our consulting department.

• White Paper: Harmony and Your IT Department

Harmony

Here are the specifications to install Harmony on client machines. Note that this does not encompass the network
and server specifications for Harmony Server.

Requirements Windows MacOS X

Operating System
Windows 7 64-bit
Windows 8 64-bit

MacOS X 10.9.5
MacOS X 10.10.2 or later

Processor
Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor
Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800

Memory 16GB
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8GB
4GB

Video Card

Fast

• NVIDIAGeForce GTX 780

Medium

• NVIDIAGeForce GTX 560, 650

Slow

• Intel HD Graphics 4000, 5000

• Intel Iris Graphics

• NVIDIAGeForce GT 520, 620,
720

Fast

• AMD FirePro D500

• NVIDIAGeForce GTX 775M

Medium

• AMD Radeon HD 6770

• NVIDIAGeForce 750M

Slow

• Intel HD Graphics 4000, 5000

• Intel Iris Graphics

• NVIDIAGeForce 320M

• Radeon HD 6630

Drawing Tablet

Best

‣ Wacom Intuos Pro

‣ WacomCintiq

Basic

‣ Wacom Intuos

Media Player AppleQuickTime Player (free)
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Chapter 3: About Toon Boom Harmony
Toon BoomHarmony is themost advanced professional animation software on themarket. Bringing together an
impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D models,

Harmony Server combines the animation toolset of Harmony with an impressive database for collaborative
workflow. Share assets, batch vectorize and render, and increase production efficiency.

Top Features

l AdvancedDrawing Tools: Texture brushes, and thick and thin pencil lines

l Smart Colour Palettes: Colour you can adjust on the fly

l Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

l Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full particle
effects engine

l Real 3D Camera: A camera you can reposition in a full 3D space

l 3D Integration: Allowing you to import 3D models, position and animate them in 3D space

l Batch Vectorizing and Rendering: Quickly process images for import and export through a single work-
station or a render farm

l Database File Sharing: Share libraries, colour palettes, animation, and more across the whole team

l Production Pipeline Integration: Seamlessly integrate content from pre-production via Toon Boom Story-
board Pro

Toon Boom Pipeline

Toon BoomHarmony has been recognized for its excellence by winning many awards, including a Primetime
Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated pipeline with Toon
Boom Storyboard Pro.

Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore, animatics
created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for animation and scene setup
guidance.

Render Resolution

The render resolution for the various editions of Harmony are:

• Harmony Essentials: 2K (2048x1556)

• Harmony Advanced: 4K (4096x3112)

• Harmony Premium: Unlimited

Modules

Harmony Server is composed of the following modules:
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l Control Center on page 12

l Stage on page 13

l Scan on page 13

l Paint on page 14

l Play on page 14

l Web Control Center on page 14

Thesemodules are all accessible from:

l Windows: Start > Programs > Harmony 12.1 Premium

l MacOS X: Applications > Toon Boom Harmony 12.1 Premium

l Linux: /usr/local/ToonBoomAnimation/harmony_12.1/lnx86_64/bin/

l Stage

l Stage -paint

l Controlcenter

l Scan

l Play

l ServerActivation

l ClientActivation

l LicenseWizard

Control Center

The Control Center module controls the database and organizes the production. The Control Center module
is used to create the environments, jobs and scenes, as well as importing and exporting scene packages. The
technical director or system administrator also uses the Control Center to create the login information for
users to access the database.

Control Center is also available in a web formwhere users can access scenes via the Internet—seeWeb Control
Center on page 14.

To learnmore about Control Center, refer to the following guides:

l Fundamentals Guide

l Installation Guide

l Control Center Guide
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Stage

The Stagemodule is the core of Harmony. It comprises all themajor drawing, animation and compositing
features. It is used to work in the scene: design, character breakdown, cut-out animation, traditional animation,
ink and paint, exposure sheet, timeline, effects, compositing, camera moves, colour styling, and so on.

NOTE: You cannot create scenes in Stage with Harmony Server, you require the Control Center module. You create
them directly in Stage with Harmony Stand Alone.

To learnmore about Stage, refer to the following guides:

l Fundamentals Guide

l Getting Started Guide

l Traditional Animation Guide

l Paperless Animation Guide

l Cut-out Animation Guide

l Gaming Guide

l Compositing and Effects Guide

l Play Guide

l Preferences Guide

l Keyboard Shortcuts Guide

l Scripting Guide

l Utilities Guide

Scan

The Scanmodule is used to scan drawings in batch. It creates a drawing list from the timing and exposure
previously created in the exposure sheet via the Stagemodule.

NOTE: It is possible to scan the drawings from a TWAIN device directly in the Stage module.

To learnmore about the Scanmodule, refer to the following guides:
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l Fundamentals Guide

l ScanGuide

Paint

Paint module is a component of the Stagemodule. It contains the drawing, painting and colour styling tools. It
is mainly used in large traditional animation studios to maintain a structure and avoid users having to learn the
full product application. This way, the colour styling or ink and paint team can concentrate on their task
without having to deal with the compositing and timing tools.

To learnmore about the Paint module, refer to the following guides:

• Fundamentals Guide

• Paint Guide

• Preferences Guide

Play

The Playmodule is used to play back the rendered image sequences enabling the user to view the final scenes
and compositing results.

To learnmore about the Playmodule, refer to the following guides:

l Fundamentals Guide

l Play Guide

WebControl Center

You can access your database via Web Control Center. When you're running a studio, you will most likely have
a database set up. This enables all the artists working on your production to share the same scenes and
assets.

Web Control Center lets you host this database on the Internet. This way, freelancers can log in from anywhere
with an Internet connection. Then they can download a scene from the database, work on it, and upload it
again.
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You no longer to spend time copying files to an FTPor have an admin exporting and importing files from the
database. You can do it all directly throughWeb Control Center.

To learnmore about Web Control Center, refer to the following guides:

l Installation Guide

l Control Center Guide
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Chapter 4: Animation Workflow
In this chapter, you will become familiar with the different animation workflows and how they end upmerging
together. There is also an overview of how they work with Harmony.

To begin with, let's determine what an animation workflow is. No matter whichmethod you choose to create
your project, it will always be divided in three segments. Then you will have to choose your animationmethod.

Harmony is designed to handle part of the pre-production and all of the production. Post-production is managed
in an external application. The three workflow segments are each broken down in different steps.

Pre-production
The first segment is the pre-production.
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Chapter 4: Animation Workflow

Pre-production almost always follows these steps:

Script

Every project starts with a script or a synopsis. You will also see the term screenplay. A script is the written
version of a project done by a screenwriter. You will encounter a script in many different types of projects such
as movies, television series, video games and advertisements. It is the source for all the upcoming steps. A
script usually contains the storyline, location descriptions, actions, dialogue, sound effects, etc. It contains all
the information necessary for the artists to illustrate and animate themovie or series.

18
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The script is needed in order to transform the project into a storyboard. This same script is used as a dialogue for
the audio recording. Finally, characters, props and locations will be designed from all of the descriptions
contained in the script.

Storyboard

The storyboard, which is created by the storyboard artist from the script, is also common to all types of projects.
A storyboard is a visual representation of all the scenes and actions contained in the script. The dialogue,
backgrounds, action notes, and characters are included.

The storyboard is often created at the same time as the characters, props, location design and audio recording.
The first storyboard is not always exact, as the designs are subject to many changes during the beginning of a
production.

The storyboard is essential to the layout and posing, and the animatic.

This step is not donewith Harmony. Traditionally, the storyboard is created on paper. This step can also be
achieved with Toon Boom Storyboard Pro, software developed specifically for this use. Toon Boom Storyboard
Pro projects can be imported into Harmony.

Character, Prop and Location Design

Once the script is completed, the designer can start work. Before any animation, background or colouration can
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Chapter 4: Animation Workflow

be done, the design needs to be addressed. The artist has to decide on the production style, the character's
look, the location's complexity, and so on. Once these designs are done and approved, themodel pack is
produced, containing all of themodels for all these aspects.

The designs and models will be used by the colour stylist and layout artist, and finally by the animator.

Audio Recording

The audio recording is also called voice recording. The script is needed for dialogue and extra sound effects.
The actors will read the lines from the script and record their dialogue. These voices will be used later on for
the animatic, the animation and the final production compositing.

Animatic

The animatic, also known as leica, comes directly from the storyboard. The animatic is the first movie of a
project and is used to help the animators and compositors. The storyboard is scanned in and mounted with
the sounds and dialogue. There is no animation yet. It is simply the storyboard frames changing over time to
help evaluate the rhythm and the look of the show. This will help avoid mistakes that would have been found
only at the end of a show.

This step is unnecessary if you are absolutely sure of your storyboard and timing, but an animatic is always
recommended.

This step is not donewith Harmony. Generally, an external software is used to do the storyboard editing to
create the animatic. This step can be achieved with Toon Boom Storyboard Pro software which was developed
specifically for this purpose.

Character, Prop and Background Colour Styling

Once the black and white designs are done, they are sent to colour styling. The colour stylist chooses the
colours and ambiance for the production and balances the characters, props and effects with the location
palettes. This contributes to an even feeling or an emotional contrast where needed in the show. When the
colours are approved, colour models are produced and backgrounds are painted. Colour models will often be
added to themodel pack.

The colour models will be used by the colourists and the coloured background will be sent for compositing.
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Sound Breakdown

For the dialogue, a sound breakdown can be done. This means that the sound will be broken down in small pieces
and written on the traditional exposure sheet for the animator to use. Each framewill have its own bit of sound
information which tells the animator what mouth phoneme to place on the character on a particular image.

For digital cut-out and paperless animation, the traditional sound breakdown is not necessary as there are
different tools inside Harmony to help the animator achieve the same result.

Production
The production segment can vary greatly depending on the user and the technique. There are threemain
techniques or animation types that you will discover on the following pages: traditional, paperless and cut-out.
For more information about production steps, seeAbout the Animation Types on page 23

Post-production
Post-production is the final step in which video and audio editing and calibrations are done. Some effects and
colour grading can also be performed at this stage.
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Final Editing

The final editing comes after the rendering of the production scene. Harmony does not handle the editing, so
the renders are exported to an external application. There, the different scenes are assembled and adjusted. If
need be, users can add extra filters and effects, such as transitions between the scenes, during this step.

Once the editing is completed, the audio will be added.

Audio Editing

The audio editing is also done in an external application. It can be done directly in the editing software or in an
audio application and then transferred to the editing software. The dialogue, sound effects and soundtracks
will be adjusted and placed with the project's final editing. The tracks will bematched to the images and
volumes and effects will be added.

Dubbing

Once the final images and sounds are assembled, the project is ready for dubbing. Actors will come in and
record voices over themovie. This process is called post-synchro. At this point in the process, multiple
languages can be added to the soundtrack.

The project is complete, and is ready to be output to the final master copy.
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Master Distribution

All of the data is transferred to themaster copy and the user or studio is ready to distribute the project to the
clients, festivals, television, cinema, and other venues.

About the Animation Types
Harmony is an animation and digital content creation software. Animation can be divided into threemain
categories: traditional, paperless, and cut-out animation.

These techniques can be used independently or together. Harmony is optimized to handle all three animation
types, one of the software's great benefits.

Each animation technique has its own advantages and disadvantages. Combining different techniques allows you
to incorporate the best elements while eliminating the weakness of an individual technique that may not be
exactly what you need.

Before going any further, review each animation type:

Traditional Animation

Traditional animation is the original method of animation, as well as themost popular. It is also called cel or
classical animation. It consists of drawing every image of an animation on paper, normally 12 to 30 drawings per
second per character or layer. The number of drawings per second is determined by the format (NTSC or PAL) or
purpose. The human brain is able to process an animation with a minimum of 12 drawings per second. The
number of drawings per second will be between 12 and 30. The standard is 24 or 25 frames per second.
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Chapter 4: Animation Workflow

From the end of the 19th century to the late 1980s, the workflow was entirely donemanually. Only with the
introduction of computers to the general public did some of the steps become automated. Now, with all the
technology available, the colouring and compositing are achieved digitally. However, the drawing part is still
done by hand on paper.

Paperless Animation

Paperless animation is themost recent 2D animation process. It consists of digitally drawing all of the images
of an animation. It is similar to the traditional animation technique.

This method is entirely digital; it does not involve anymaterials other than virtual tools. However, the animator
still must draw each frame individually.
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Paperless animation requires the user to be familiar with digital graphic applications and be able to convert this
traditional knowledge to a digital medium. This method of animation allows significant control over the drawings,
a possibility for greater quality and an infinite number of complex poses and rotations for the animated
characters and objects. It also eliminates the paper used in traditional animation and gives you the opportunity to
instantly see a line test. Paperless animation allows you to easily cut and paste parts of a drawing, undo actions in
case of mistakes, and zoom in and out of drawings.

Cut-out Animation

Cut-out animation consists of breaking down a puppet into pieces that aremoved frame by frame to animate the
character. It can be divided into two categories: classical and digital. Whenworking in the classical cut-out style,
the animator manually moves the parts under a camera and shoots each frame beforemoving on to the next
pose. Whenworking in the digital style, the parts aremoved in a similar way as the classical cut-out style and then
keyframed in the computer software, whichmeans that it is fixed and recorded digitally. Since the characters and
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Chapter 4: Animation Workflow

objects are composed of many parts, the animator does not need to redraw them on each frame, but can just
move or distort the parts to create the animation.

Harmony allows you to do digital cut-out animation, which has become increasingly popular in recent years.

Cut-out animation requires you to be familiar with digital graphics applications. Cut-out animation is very
useful in cutting down the time it takes to complete a project. There is no need to redraw characters and the
computer can handle a large part of the in-betweening. It also eliminates the paper used in traditional
animation and allows you to instantly see a line test. The team for a cut-out project is much smaller than that of
a traditional production, allowing the whole production to be kept within the same studio. This also means
that you have a great deal of control over quality.
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Production Steps

Now that you know the differences between the traditional, paperless and cut-out animation types, you canmove
on to the basic organization of their workflow. The following illustrations show the animation pipelines that
represent themost popular workflows. The tasks can be divided or the order can be rearranged to suit the
specific needs of the studio or user.

After familiarizing yourself with the basic workflow pipelines, you should read about the various examples of the
workflows and how the individual and the studio are organized according to their size.

Traditional Animation Workflow

In a traditional workflow, many steps are donemanually. Harmony is used for the digital portion. Wewill focus
mainly on these steps.
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Chapter 4: Animation Workflow

The following is a list of the steps done using Harmony in a traditional animation workflow. This will help you
understand how the work is divided and give you a base to start building your own traditional pipeline.

Layout and Posing

The layout and posing process links the storyboard artist and the animator. The layout artist uses the
storyboard and prepares an organized folder for the animator. This folder contains a field guide that shows
the proper camera move and the right size of the scene. It also includes the character's main poses from the
storyboard following the official design, and the effects, backgrounds and all the other information necessary
to the animator.

The backgrounds are done directly out of the storyboard and location design. A background is a section or an
angle of a location. The background artist refers to the storyboard and draws the background for each scene.
Once the background is completed, it is added to the layout folder.
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In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on
the user's preferences.This step is mainly applied to larger productions. An individual user canmove directly from
the storyboard to the animation.

This step can be donewith Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.

Animation

Traditional animation is done on paper. The animator receives the layout folder and uses the references to
animate the scene. The animator will draw each frame of the animation or each pose of the character. If there is
dialogue in the scene, the animator will follow the breakdown and animate themouths and expressions.

Depending on the studio size, the animation can be divided in different ways. Sometimes the animator will do all
of the work, from the key poses to the in-betweens and then the clean up. Bigger studios will have the animator
doing only the key poses and then send the scene to the in-between department and finally to the clean up
department.

Once the animation is completed, it is sent to the digital part of the process. This applies only to modern
processes. In the traditional, old-fashioned pipeline, the animation was sent for hand-inking and painting. The
animation was traced with ink on transparent cels and the colours are painted with brushes on the other side of
the cel to fill the zones. Today, using Harmony, you can still use this technique by utilizing the digital Line Art and
Colour Art feature.

Digital Exposure Sheet

The digital exposure sheet is the first step done in Harmony. This controls the timing of the animation. The
traditional animator creates a paper exposure sheet in order to create the timing. The person in charge of the
digital exposure sheet reads the paper version and recreates it in Harmony. Once the drawings are all in place on
the exposure sheet, the scene is ready for the scan.

Note that a single user will scan the drawings first and then set the timing in the exposure sheet. The digital
exposure sheet is only created first in a larger animation studio using the advanced scan features available in
Harmony.

Scanning

Scanning is the second step in Harmony. The cleaned-up drawings are scanned and imported in the software in a
simple step that incorporates all of the drawings in the scene. When all the drawings are scanned, they are ready
to be inked and painted (coloured in).

Inking and Painting

At this point in the process, the colour models are ready and the drawings are scanned in and properly exposed.
Using Harmony's optimized tools, the colourist can clean the scanned artwork and start applying colour to the
different drawings. When the drawings are cleaned, as well as inked and painted, they are ready for compositing.

Compositing

The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
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moves and other necessarymotions. Finally, the compositor adds any digital effects required by the scene.
These can include tones, highlights and shadows. When the compositing is completed, the final step is the
rendering.

Export - Render

Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
Generally, the compositor will be the same person doing the render.

Paperless Animation Workflow

The following is a list of the steps done using Harmony in a paperless animation workflow. This will help you
understand how the work is divided and give you a base to start building your own paperless pipeline.
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Layout and Posing

The layout and posing process links the storyboard artist and the animator. The layout artist uses the storyboard
and prepares an organized folder for the animator. This folder contains a field guide that shows the proper
camera move and the right size of the scene. It also includes the character's main poses from the storyboard
following the official design, and the effects, backgrounds and all the other information necessary to the
animator.

The backgrounds are done directly out of the storyboard and location design. A background is a section or an
angle of a location. The background artist refers to the storyboard and draws the background for each scene.
Once the background is completed, it is added to the layout folder.

In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on
the user's preferences.This step is mainly applied to larger productions. An individual user canmove directly from
the storyboard to the animation.

This step can be donewith Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.

Animation

Paperless animation is usually one of the first steps done in Harmony. All of the drawings are created digitally,
using a pen tablet to optimize work and drawing ability. Other than the digital aspect, the animation principles
are not very different from classical animation. The animator will use the same animation styles and methods as
would be used on paper–only themedium is changed.

When all of the animation is done and the drawing timing is completed through the exposure sheet or the
Timeline view, the scene can proceed to the animation clean-up process.

Animation Clean-Up

The animation clean-up consists of transforming the rough paperless animation into cleaned, tied down and inked
drawings. On a new layer, the clean-up artist will trace the animation following the official model pack (document
containing all the official character, location/props design and colours). This step must be done very accurately.

When the clean-up is over, the scene is passed along to the colourist for the ink and paint step.

Inking and Painting

At this point in the process, the colour models are ready and the drawings are properly exposed. Using
Harmony's optimized tools, the colourist can start applying colour to the different drawings. When the drawings
are inked and painted, they are ready for compositing.

Compositing

The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
moves and other necessarymotions. Finally, the compositor adds any digital effects required by the scene. These
can include tones, highlights and shadows. When the compositing is completed, the final step is the rendering.
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Export - Render

Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
Generally, the compositor will be the same person doing the render.

Cut-out Animation Workflow

The following is a list of the steps done using Harmony in a cut-out animation workflow. This will help you
understand how the work is divided and give you a base to start building your own cut-out pipeline.

Layout and Posing

The layout and posing process links the storyboard artist and the animator. The layout artist uses the
storyboard and prepares an organized folder for the animator. This folder contains a field guide that shows
the proper camera move and the right size of the scene. It also includes the character's main poses from the
storyboard following the official design, and the effects, backgrounds and all the other information necessary
to the animator.
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The backgrounds are done directly out of the storyboard and location design. A background is a section or an
angle of a location. The background artist refers to the storyboard and draws the background for each scene.
Once the background is completed, it is added to the layout folder.

In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will depend on
the user's preferences.This step is mainly applied to larger productions. An individual user canmove directly from
the storyboard to the animation.

This step can be donewith Harmony, but Toon Boom also has another software developed for this. Toon Boom
Storyboard Pro has optimized tools to create the layout and posing.

Character and Prop breakdown

The breakdown step is really important in the cut-out workflow. The person doing the breakdown has to take the
final character or prop model and start building the puppet. This means deciding which parts will be separated
and preparing all of the joints and views for the animators.

Once the parts are broken down, the character or prop must be rigged. This means attaching the parts
(hierarchy) and assigning the appropriate pivot points. This step must be donewith care because these puppets
will be distributed among all the animators later and you do not want to duplicatemistakes throughout the
project.

When the character and prop rigs are ready, the breakdown artist stores them in the library as templates to be
shared with the rest of the team.

Library

The library is a central element of a digital cut-out production. It contains all the assets for the animation and
scene set up.

The library is a central location where all these templates are stored, organized andmade available to the
animators and scene setup team. The library should be structured so that everyone using it can easily find the
assets they require. Someone should be assigned to manage the library so that it remains well organized. This
person is often the breakdown artist, but it depends on each studio's structure.

When the library is built, the scene setup person and the animators will start using the assets.

Scene Setup

The scene setup consists of preparing the scenes for the animators and is similar to the traditional layout and
posing. Following the storyboard and the animatic, the person working on the scene setup will import the assets
needed for the scene animation, as well as import the animatic reference and often position the camera.

When the scene setup is completed, the scene can be passed on to the animator who can start animating without
having to mount the scene.

Animation

Cut-out animation is a vast subject. There aremany techniques employed by different studios and animators.
Basically, the animator moves the parts frame by frame to animate the puppet. The animator may even start their
own pre-compositing, camera moves, and trajectories. This depends on the user's workflow. Once the animation
is completed and approved, the scene goes to the final compositing and effects.
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Compositing

The compositor imports the coloured background, animatic reference and sound as required. Referring to the
exposure sheet, animatic and animation, the compositor assembles all these elements and creates the camera
moves and other necessarymotions. Finally, the compositor adds any digital effects required by the scene.
These can include tones, highlights and shadows. When the compositing is completed, the final step is the
rendering.

Export - Render

Once the compositing is completed, the last step is to render the scene as a movie or an image sequence.
Generally, the compositor will be the same person doing the render.
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Chapter 5: Animation Principles
Animation can be used for several different purposes such as movies, advertisements, video games, corporate
presentations, medical concept demonstrations and muchmore. Not all of these require the same animation
quality level. To illustrate a concept, simple and linear animation is oftenmore than sufficient to convey the
message. For a feature length animationmovie, the animation needs to be convincing and carry someweight and
elasticity.

You will notice when youwatch different movies that the animation style will differ quite a bit from film to film.
Some have a very fluid and smooth flow in their animation while others have a very bouncy, cartoony feel. People
without animation experiencemay watch a movie and find the animation very bad, unconvincing or too slow. They
might not know why exactly, but they know that something isn't right. Most of the time, it happens because the
animators missed a few of the fundamental animation principles.

If you already are an experienced animator, you can skip this topic and continue along.

Here are themain principles that create the backbone of a good animation. You will no doubt encounter
variations of these principles when reading articles online or reading different books.

Squash and Stretch

Squash and stretch is at the core of the animation principles. It is what gives some elasticity and flexibility to your
animation. When an object hits the ground, the impact drawing will be really squashed. As it bounces off the
ground, it will stretch in the opposite direction. The stronger the squash and stretch is, the smoother and
bouncier the animation will look. Also, hard objects such as a bowling ball require less squashing or stretching so
that the heavy and solid illusion remains. As you squash and stretch an object, it is really important to maintain the
volume of the object. When you squash something down, you need to proportionally stretch it sideways,
otherwise, the object will look like it is getting smaller.

Timing

Animation is all about the timing. The timing comprises many things in animation. It is the duration of an action. It
is the speed and velocity of an action. It is the way actions overlap and secondary objects follow themain action. If
the timing is off, too slow, too long, too fast, or too linear, the animation will not look realistic. It will be stiff, even
boring. The nature of the character, personality or weight of an object will influence the timing of the animation.
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Anticipation

Anticipation is the preparation for an action such as a jump or a punch. For example, a character will squat
down before pushing his body and legs up into a jump. The stronger the anticipationmotion, themore
cartoony and fluid the animation will be. The smaller the anticipation, themore stiff the animation will be.

Straight-ahead and Pose-to-pose

These are two different ways to animate an action. The straight-ahead techniquemeans to animate your action
from drawing 1 to the end in sequence order. The pose-to-pose technique is a bit more intricate as it means to
draw the key poses first (often the beginning and end drawing of the action and some other keymoment
between. Once the key poses are done, the breakdown and inbetween drawings are added to fill the rest of
the animation. Smoke, water and other fluid elements are often animated using the straight-ahead technique.
Actions that require tight timing and structure are often animated with the pose-to-pose technique. This
method helps maintain a solid structure and preserve the volume. Sometimes, when using the straight-ahead
technique, it may be difficult to calculate where the action will end up and the final drawing may be out of
proportion and not where it should be.
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Follow-Through

The Follow-Through principle is very important for increasing the quality of your animation. All the secondary
parts of your character such as hair, clothes or a cloak will continuemoving after the character stoppedmoving.
Also if you observe closely, when a character walks, its bodymoves and down, and its long hair or cloak follow
behind on the same path but with a slight delay. Therefore, your character might be at the lowest point in a
crouching action but his cloak will be all the way up in the air. Also, notice that when the cloak floats behind the
character, it will move along an "S" curve. The part of the cloak that is attached to the body will not always curve
in the same direction as the tip of the cloak.

Arcs of Rotation

The human bodymoves from its articulations such as the shoulders, knees, hips and elbows. Therefore, all limbs
move by rotating on their pivot (articulation). When animating an arm going up or down, the hand will not reach
its end point on a straight trajectory. It will follow an arc until it reaches its end point.
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Slow-in and Slow-out

Most characters and objects accelerate and decelerate whenmoving. Most movements are not linear,
therefore to reproduce the slow-in and slow-out effects, we addmore drawings closer together at the
beginning of the action and same at the end of themovement. The closer the drawings are, the slower the
animation will be. The farther apart they are, the faster the animation will be.

Secondary Actions

Secondary actions add another layer of realism and quality to an animation. The secondary actions are the
other limbs or objects moving along with themain action. They are not the follow-through actions, which are
inanimate objects reacting to themain actions. They are the limbs that move, such as the character's arms
swinging rhythmically back and forth whenwalking. He could nod in time to music while taking a stroll or blink
or chew gum.
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Exaggeration

The principle of exaggeration is another important way of adding life in animation. Sticking exactly to reality will
make for a very stiff animation. Changing the direction of themain body curve from backward to forward in a
dramatic way, using squash and stretch, snappy timing and good slow-in and slow out help exaggerate the
movements and add life to your animation.

Solidity

In animation it is paramount for drawings to have a strong underlying structure. The animator must understand
the anatomy and skeleton of the characters and props to be animated. Without a good structure, the drawings
will deform, bend in the wrong places, and progressively become off model.

The animator should always know what is under the skin of his character.

39



Harmony 12.1 Premium - Fundamentals Guide (Server)

40



Harmony 12.1 Premium - Fundamentals Guide (Server)

Chapter 6: Concepts

Harmony was designed using traditional animation concepts. This lets you use familiar tools and work practices.
Whether you are new to animation or an experienced animator who wants to understand Harmony, the concepts
covered in this section will be interesting and useful.

Bitmap and Vector Graphics 41

Line and Colour Layers 42

Colour Palettes 43

Exposure Sheet, Timeline and Timing 44

Pegs 47

Multiplane 48

Network 48

Frame Rate and Format 49

Scenes 50

Bitmap and Vector Graphics
There are two types of digital images: bitmap and vector. Discover their main differences so you canmake the
optimal choice for your project.

Bitmap Image Types

Abitmap image consists of pixels and has a fixed size. A pixel, short for picture element, a single point in a
graphic image. It is a small sample of an image, a dot, a square or a very small sectionmade out of smooth
filtering. If you zoom in close enough on a digital image, you will see the pixels. They look like small squares of
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different colours and intensity. Since a bitmap image is composed of pixels and has a single resolution (size), if
it is enlarged too much, it will start losing definition and pixels will start to appear. This is known as pixelation.

Vector Image Types

A vector-based image is composed of points and Bezier curves. The computer reads the points and traces the
segments linking them to reproduce the image shape. There is no fixed size or resolution in a vector image.
You can enlarge the graphic and distort it as much as you want, and the systemwill simply recalculate the
segments and rebuild the shapes. The segment's shape can be controlled with Bezier handles to curve and
smooth it. Vector images are translated and displayed in pixels once the calculation is done.

Advantages and Disadvantages of Bitmap and Vector Images

Bitmap images allow a more organic style. Since everything has a fixed size and is alreadymade out of pixels,
more effects are possible, such as blur, texturing, shading, a painted look and so on. The bitmap format is
excellent for creating backgrounds and overlay elements. However, because of the precise resolution, in order
to zoom in on or to work in high resolution such as HDTV, the created file must be a large size.

Vector-based graphics can be very useful when creating large illustrations, as these graphics are resolution
independent. The images can be significantly enlarged without losing definition. A vector-based image is
generally a smaller file size than a bitmap, as it is a set of mathematical points. However, if there aremany
vectors composing the graphic, the result can be larger than a bitmap file. A vector shape can always be
modified. It also creates very crisp images.

Line and Colour Layers
Before the advent of computers, animation was donemanually. There was no process of scanning and painting
digitally. Once the animation was completed and cleaned on paper, the drawings were traced with a brush or a
quill onto cels. The cel transparency permitted many layers to be superimposed, composing the scene
elements together.
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The first step in the cel process is to ink the lines on the front side of the cel, either in black or with different
colours. In the late 1950s, this step was changed to photocopying the drawings on the cels, called the Xerox
process. Once the lines are inked, it is time to fill in the colours, usually painted with a brush. Painting on the same
level as the lines makes it all too easy to accidentally go over the line or not apply the colour densely enough, so
light is passed through the drawing. To remedy this, colours are painted on a second level onto the back of the
cel. This protects the lines from any colour stains and the colour filling can go under the lines covering the entire
zone.

Working digitally produces a similar process. Once you have scanned drawings into the system, you can colour
the lines without ruining the colour filling, or you can paint complete zones without staining the lines. If there is
some transparency (alpha) or texture in the line, the colour filling is allowed to go under the lines to create the
correct look.

Colour Palettes

In animation, precise colours are used to paint each particular character and prop. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production. These are
referred to asmaster palettes.

Before computers, painters used real colour pots (often big glass jars) mixed by a colour palette artist. The
colour palette artists had to make sure to use the exact same amount of paint from each tint every time they
would mix a new batch to make sure the colours would remain consistent throughout the entiremovie. Now,
using a computer process, a digital colour palette is created. This allows absolute colour accuracy by always
having the same group of colours associated with each character.

Master palettes contain a colour pot for each zone to colour with a precise RGBA colour value.
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l Red

l Blue

l Green

l Alpha (contains transparency information)

Painting animation using a master palette is very similar to the paint-by-number concept.

Using a master colour palette has many benefits, including:

l Each character consistently retains their dedicated colours.

l You cannot accidentally use a colour which is not in themaster palette.

l Standardization and colour consistency throughout the production.

l Multiple artists can use the same colour palette and produce the same results.

Exposure Sheet, Timeline and Timing

Animation is about movement and in order to have the illusion of movement, you need different drawings to
progressively change over time. For your eyes to perceive a smoothmotion and not just a series of drawings
changing, you need several drawings per second. To bemore precise, you need a minimum of 12 drawings per
second. If you have less than 12 drawings per second, themotion will be jerky and youwill not see a smooth
motion.

It is important to know that the number of drawings per second will be based on the final output: television,
cinema, web, DVD, etc., as those outputs have different frame per second rates. This parameter will influence
the number of drawings per second as well as their exposure.
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The exposure of a drawing is the length of time that it stays on the screen. A second can be divided as follows: 24,
25 or 30 images depending on the format. They are also called frames, so there are 24, 25 or 30 frames per
second.

Broadcast Standards

There are two main broadcast standards used; the one selected will determine the frame rate.

In North America, Japan and other parts of Asia, the NTSC (National Television SystemCommittee) format is
used. This format is 30 images (frames) per second.

Inmost of Europe, PAL (Phase Alternating Line) format is the broadcast standard. This format is 25 frames per
second.

Film format is 24 images per second.

The human brain is able to process an animation as slow as 12 drawings per second. Therefore, the number of
frames per second should be between 12 and 30. The general standard is 24 or 25 frames per second, so these 12
drawings are set on double exposure. This means that each drawing stays on the screen for two frames. If a
drawing is exposed for 24 frames, it means that it will appear to the eye for one second.

The timing is a drawing's exposure.

Exposure Sheet

The exposure sheet, also known as the Xsheet or dope sheet, is used when an animator is planning a scene. The
animator enters data in the different columns (layers), the name of the drawings and their exposure into the
Xsheet.The Xsheet allows you to see the animation timing in detail.

The Xsheet is composed of columns corresponding to the different layers. Each column is split into rows
representing the frames (images) in the scene. A paper Xsheet usually has 80 rows and ten columns. This enables
the animator to associate a layer with a certain element (character, prop, mouth, etc.) and make a record of the
frame at which each drawing appears.

The traditional paper Xsheet was mainly created for the animator to communicate with the cameraman regarding
the scene's timing, the camera moves and element trajectories. It is still used today to express the same
information to the compositors and the person working on the digital Xsheet.
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Timeline

A traditional timeline is a horizontal and chronological representation of key events occurring within a
particular historical period.

In the digital process, the timeline is quite similar. The timeline is read from left to right to help you understand
the scene and its timing. The frames or timecodes are placed at the top and the elements or layers on the left.
There is no drawing name or value information. The timeline displays the timing and elements in a simplified
and systematic manner, making it easy to read globally. The timeline can be considered to be a quick overview
of the whole scene.

Xsheet and Timeline Usage

Xsheets and timelines are used for different tasks. When a scene is done in a traditional animation workflow,
the Xsheet is useful in keeping track of the drawings' ordering, names and timing. The Xsheet is used to
reproduce the animator's work in the digital software or the camera. The colourists can then follow the Xsheet
to paint the drawing sequences. Finally, the compositors can read the information that is necessary to their
work from the Xsheet.

For digital animation, computer generated trajectories, hierarchies and distortions, there is a lot of extra
information involved, including keyframes, velocities, function curves, and more. A keyframe is a computer-
generated key position that contains values and coordinates for the element's onscreen positioning;
keyframes can be displayed in the exposure sheet as values. If there are too many keyframes, modifying one
can be difficult due to all of the values present. This is why there are digital timelines. Their simplified version of
the timing is quite useful in these situations. The Timeline view does not display drawing names or keyframe
values, but instead represents them as symbols, making it much easier for the eye to detect the desired
element for modification. Although the name and value information is not directly displayed, the Xsheet is still
very valuable when retrieving this type of information.
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Pegs

Pegs have been used for a long time in the animation process, mainly for registration purposes. Peg holes at the
bottom (or top) of animation paper are used to keep all of the sheets even and at the same registration.

There are three peg holes in regular animation paper. The centre one is circular and the left and right ones are
rectangular and situated at 4 inches from the centre one.

To keep the drawings together, traditional animations use a peg bar. This bar has three pins shaped exactly like
the peg holes. Peg bars are normally found at the bottom and top of animation discs.

Before digital compositing, the peg bars were also used to move layers under the camera stand. All layer
translations were calculated based on the distance the pegs weremoved frame by frame. They were the
equivalent of the digital trajectories. Harmonymakes use of these concepts to create animation and camera
moves.
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Multiplane

In the animation context, multiplaning is used to create a scene withmany planes placed at different distances
from the camera to recreate a perspective illusion. A plane is a layer or an element. In regular flat 2D scenes, all
the elements are at the same distance superposed one on top of another. So, when the camera moves, all the
elements aremoving at the same speed. In real life, all objects and elements are placed at different distances
from our eyes so whenwewalk or drive past, the closest objects appear to bemoving away faster. The
farthest ones, likemountains, are barely moving. In animation, that perspective effect has to be reproduced
manually.

In 1933, theWalt Disney Company invented themultiplane camera. They got the idea from looking at methods
used in the theatre to introduce perspective into a space with limited depth. In the theatre, cut-outs and flat
pieces were placed in a variety of layers in front of a backdrop which allowed actors to move through the
various sets while giving the illusion of depth. Walt Disney's final design for themultiplane camera used this
same concept. Themultiplane camera which was set up vertically, much like a photographic enlarger, would
shoot down through as many as five planes attached to vertical posts that allowed four of the planes to move
independently of one another. The first two planes were used for animation, the next two were for
backgrounds, and the fifth was fixed and used for sky backgrounds. The finished result produced a depth of
perspective which had not previously been seen in animated film.

Multiplane camera effects can be created digitally. There is no longer a need to use the big multiplane camera.
Multiplane shots are normally used to add depth to a scene to reproduce perspective effect more easily. They
can also be used on a smaller scale to make elements pass in front of and behind certain objects like trees or
chairs.

Network
A network can be described as an interconnected group or system of elements leading to a central point. It is
widely known as a node system.

A network can be useful in animation becausemany components enter the process. A visual network can help
represent many things like scenes, effects, composition and textures.
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the Xsheet and timeline enhance the element display, but theymay not be themost efficient for some production
aspects. The Xsheet provides traditional animation details, displaying drawing names, values, exposures and
timing. The timeline displays all of the timing, drawing exposures, keyframes and trajectories in a schematic view
to provide a quick overview of the whole scene, enabling you to easily detect different elements. When it is time
for advanced hierarchy, compositing, effects filters, grouping, and cutters, a timeline can get overloaded andmay
not have the capacity to represent the reality of things.

For greater efficiency, a network is brought in to visually represent all of the parenting, hierarchy, effects and
element compositing. There is no timing representation or drawing name, but a visual set of links or cables
between the elements that are represented as boxes or nodes. It helps the eye follow very quickly to what is
happening in the scene. Also, because of the linking power available, a network allows more advanced
connections and parenting than a timeline.

Elements can be combined using effect nodes or composite nodes and turned into something new. Elements can
cut others or control other ones. In the end, all elements are brought into a composite node to turn all drawings,
layers, parameters and effects into the final animation output.

Frame Rate and Format

When you create an animation, the images you animatemust move fluidly to produce the correct effect. If they
don't, you will have a jumpy animation which won't look good. To get a fluid movement between the drawings,
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you need several images per second. You need a minimum of 12 images per second, any slower than that and
the animation becomes jumpy. An image can also be called a frame, therefore the frame rate is the number of
frames you play per second in your animation.

The format of your project is the size of your camera frame in pixels. Youmay not be familiar with the term
pixel, but you have probably seen it when youmagnify a digital photograph. A pixel is the smallest element of
an image displayed on a monitor or TV screen. Pixel, which is short for picture element, is a single point in a
graphic image. It is a small sample of an image, a dot, a square or a very small sectionmade out of smooth
filtering. If you zoom in close enough on a digital image, you will see the pixels; they look like small squares of
different colours and intensity.

Depending on the type of project you want to create, you will need a different image size. For example, if you
want to put your project on the web, you will probably export your movie as a small size so that it is light to
play back once it is on the web. The larger the images are, the heavier the project is, but also, the better the
quality. If you want to export your project for the theatre, you will ned to create your project in a large format
so the image is of a high quality and looks good on the big screen.

Also, some displaymedia such as iPad, TV or theatre have an exact format requirement. For example, one TV
format that has been a standard for decades is the 4:3 size ratio, meaning that the width of your scene has the
equivalent of 4 units compared to 3 units for the height.

In recent years, a new TV standard has been defined with the advent of Blu-ray and high-definition
technologies. It is the 16:9 format, which is often referred to as HDTV (High Definition Television). Themost
common 16:9 format in pixel is 1920 x 1080.

You can find most of the formats in the presets list provided in the HarmonyWelcome screen.

To recap, the format is the size of your camera frame in pixels, and it matches the width and height required
for themedium in which you want to show your final movie.

Scenes

Planning is an important step in creating an animation project. This involves listing the scenes that need to be
animated, the characters to design and the different backgrounds to incorporate.

In animation, a scene is the action happening in front of the camera while the camera does not change angle.
As long as the camera does not stop "filming", you are in the same scene. A good example would be two
characters talking. When the camera is facing the first character, this is one scene. When the camera cuts and
films the second character, you have a second scene. When the camera returns to the first character, you have
a third scene, and so on.
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Agroup of scenes occurring in the same location about the same action or event is called a sequence. When there
is a change of location or subject, it becomes a second sequence.
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Chapter 7: Project Organization and File Structure
Whenworking in production, it is important to keep your work organized. It is important to create a naming
convention chart and establish a file storage structure before starting the project. It is not only extremely
important that everyone follows the criteria laid out in the naming convention chart and the file storage structure,
but also that they understand the organization and where to find the files.

A well thought-out and logical naming convention will help keep your production structured and allow it to run
smoothly by preventing the loss of files due to chaotic organization.

In this chapter, you will learn how to organize and name the different components in your animation project.

Database Structure 53

File Structure 55

Root Directory and Content Building Scenes 57

Drawings and Layers 60

Palettes 62

Libraries and Templates 64

Naming Convention 66

Database Structure
Harmony Server has a client-server configuration linked through a network. Although the user is working on a
client machine, all of the data is saved on the server.

You can compare the Harmony Server structure to a filing cabinet. Every element is structured and follows a
strictly organized hierarchy.

The following production structure hierarchy is used:

l Environment: Production, project, feature film, series—see Environments and Their Structure on page 54

l Job: Episode and sequence from each environment

l Scene: Scene from each job

l Element: Layers and columns from each scene

l Drawing: Drawings from each element
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If you imagine the environment as a filing cabinet containing all the folders and information, then the following
structure is used:

l The job is a drawer in the filing cabinet containing all the folders related to the drawer’s topic.

l The scenes are the folders contained in that drawer

l The elements are the papers contained in the folder

l The drawings are the information contained on the paper

A Harmony Server scene can only be saved inside the structure. This maintains structural organization so
nothing is lost. By adhering to this structure, every user working in the database always knows where to find
the scenes to work on.

Environments and Their Structure

Before you create or save any elements in your production, you should decide upon a project name. This
should reflect the content or title. Use the name to create the project’s environment, where you will store all of
your production elements.

For example, the environment could be called adventure_movie. An environment can be used for movies,
series, commercials, student work database, etc.

For a series, you can create an environment with the same name as the series, such as smith_family. Then
you can create a job per episode: smep_001, smep_002, and so on. Here is what the letters and numbers
represent:
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l sm: The first two letters of the name smith

l ep: Episode

l 001: The number of the episode

For commercials, which are rather short, you can create an environment, such as commercials. Then you can
create one job per commercial: toothpaste, soap, car, and so on. As commercials are short and do not require
splitting into episodes or sequences, you can group them all in the same environment.

For a database of student’s work, you can create an environment and name it with the class or group name, such
as gr402a. Then you can create one job per student: smith_john, robertson_jane. And then store the
different student exercises in separate scenes under their job name.

File Structure
AHarmony project is composed of several files. The drawings and colour palettes are not embedded in the
project. They are separate linked files. Therefore, if you want to archive or share a project, you require all the files
contained in the folder structure.

For Harmony Server, the scene files as well as user and configuration files are contained within the database
structure. If you want to share or archive a project, you will need to use Control Center to export your data from
the database. If you receive a package from another user or studio, you will also need to use Control Center to
import it in your database. Refer to the Control Center Guide to learn how.

Harmony Server Database Files

All Harmony Server directories are located by default onWindows in C: or onMacOS X at the root of themain
drive where the operating system is installed.

/usa /usa/nt/bin/ • Program directory (.exe)

/usa/etc/ • Configuration files directory

/usa/etc/flexlm/ • License directory

/usa_db

• Centralized database containing the structure of all the data that
Harmony uses, except for the drawings and final images

• Link to the databases (file systems)

• User profiles

/usadata

• All the data is stored here

• All the files including drawings, final frames, and sounds are placed
in the different usadata folders

• There can bemore than one usadata000 file system created, such
as usadata001, depending on the disks and the computer’s
organization
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usa_db Structure

The usa_db folder contains the configuration files, database and project structure, as well as shortcuts to
scene data. If you browse through usa_db to get to a scene, you will navigate directly to the jobs folder. Even
though the root of the project structure is the environment, you will go to jobs. The environment folder
contains only the environment list, global environment libraries and configuration files. This means that for
different projects, even though jobs are contained in different environments in Control Center, jobs must have
unique names as they are physically contained in the same jobs folder.

Within the jobs folder, you will find a directory for each individual job. Within each job folder, you will find the
folder for the global job library, job palettes, as well as a shortcut for each scene contained in the job. These
shortcuts go to the scene data location. Depending on the parameters set upon creating the scene in the
Control Center, different scenes may be located on different file systemss on different servers, based on
storage space and other structure organization.

Scene File Structure

Here is an example of the file structure contained in a scene. As you work and usemore features, different
folders may appear in your structure.

The Harmony scene folder contains the following folders: frames, audio, elements, etc.

Folder Contents

annotation
Contains the images and thumbnails created while drawing in an Annotation
column in the Xsheet view.

audio Contains all imported audio files.

database
This is no longer used for new projects; it remains for projects created with
older versions of the software.

elements
Contains all the drawing files. The drawings are organized by folders named
like the layers they are associated with.

frames
Contains the final frames after a render if you are using the default settings of
theWrite node in theNode view.

palette-library Contains scene palettes and scene palette list files.

stage
Contains multiple versions of a scene. This is useful if you are experimenting
with different ways to do a scene. Note that all versions of a scene use the
same drawing and palette files.

timings
This folder is used when a user links external images to a scene and wants to
store a backup copy in case the link breaks.
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Root Directory and Content Building Scenes
Aproduction is not only composed of the series or movie’s scenes, there are also animatics, backgrounds,
character builds, colour models, references, storyboards, and so on. These elements must be stored somewhere.

Most of these elements can be stored in the Harmony Server database.

There are two main elements that is recommended to store in the production’s environment:

l Colour models

l Character builds

Generally, a studio will create a special Job for themodels. In the Environment, you will find Jobs for the
episodes: ep001, ep002, ep003, and so on.

You will also find a special Job model where you will find three colour model scenes:

l Characters

l Props

l Effects

Each of these scenes contain the colour models related to them. For example, the character scene will have one
layer per character containing all of the colour model drawings belonging to it. If a movie has 50 characters, the
character colour model scenes will contain 50 layers, each with a different character. If the character has five
different models such as raincoat, regular clothes or pyjamas, the character’s layer will have five drawings.

In the samemodel job, you will find the cut-out character builds scene. Unlike the colour model scenes, the build
scenes only contain one character. As a character build is composed of many layers and functions, it is not
recommended that you build more than one character per scene. So, if a movie has 50 cut-out characters, the Job
model will contain 50 character builds scenes.

Even if you have a structure integrated in Harmony, it is recommended that a root directory be created for your
external elements such as audio clips, bitmap backgrounds, references, and so on. This directory should be
stored on the server or be regularily backed up if you are a single user working on a standalonemachine.

The Root directory contains subdirectories which hold such elements as animatics, backgrounds and audio files.
Youmust create these subdirectories and name them accordingly. For example, store the backgrounds used in
your production in a subdirectory called backgrounds or adventure_backgrounds.

Keeping an organized work structure will give you greater control and ease. You can further improve the
organization by grouping similar elements into categories.
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Here is a list of typical subdirectories:

Animatic

Animatic project and movie files can be stored and organized in this folder.

Backgrounds

Backgrounds can be stored by sequence or episode in the sameway that animation scenes are. Create a
subdirectory named Backgrounds and then place a sequence or episode subdirectory inside it. Categorize
each background by episode or sequence.

Designs

Create a Designs subdirectory and split the designs into three categories:

l Characters

l Props

l Effects

Categories for locations and backgrounds can also be added if you are creating the designs using Harmony.

Final Editing

Final Editing projects and renders can be stored and organized in this folder.

Library

The items contained in the library require a high level of organizational structure. Themore structured the
library, the faster you will be able to retrieve the items. Categorize the elements using subdirectories, which
can be further subdivided. Categories could include:

l Characters

l Props

58



Harmony 12.1 Premium - Fundamentals Guide (Server)

l Effects

l Audio

l Models

The Library folder should always be stored on the server, even if it is not included in the root directory. A library is
generally shared between all the users working on the production as they will link this library to their Template
Library and reuse its contents.

Models

Create a Models subdirectory and divide it into three categories:

l Characters

l Props

l Effects

Youmay also need to add categories for the backgrounds and model pack. Note that you only need to create a
Models subdirectory if you are not designing themodels in Harmony.

References

Create a References subdirectory and then categorize according to type:

l Images: Thesemay be any subject fromwhich you can gain ideas and inspiration to help develop your pro-
ject, For example, if you are producing an 18th-century adventure series, youmay have images of period
costumes, buildings, and sailing ships.

l Pictures: You can also use photographs of items whichmay help you produce an accurate account of the
time period in which your production is set.

Render

Create a Render subdirectory and categorize the exported image sequences or clips by scene. For example, you
would have a subdirectory named Render and categories named Scene_001, Scene_002 and so on.

It is also possible to do the following:

l Create a subdirectory called Render and store your scene’s render in a subdirectory named sequence.

l Create a subdirectory called Render and store your scene’s render in a subdirectory named episode.

Storyboard

Toon Boom Storyboard Pro projects or storyboard scans can be stored and organized in this folder.

Textures

You can create a bitmap texture bank for pen styles and colour palettes and store all of the files in this folder.
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Drawings and Layers
A very important concept to understand in Harmony are drawings, drawing elements, and layers. Layers are
also referred to as columns in traditional animation, but in Harmony, there is a difference between a column
and a layer. A drawing element is a directory containing multiple drawings and is linked to a column in the
Xsheet view and the column is linked to a layer in the Timeline view. The layer and column are generally named
the sameway as the drawing element (folder). A layer may also be an effect layer, a peg (motion) layer, etc. It is
not always a drawing layer. A drawing element is the directory containing the drawings that the corresponding
layer is linking to. Many layers can be linked to the same drawing element (folder) so that the same drawings
are reused. A layer will also be represented as a node (node) in the Node view.

In traditional and paperless animation, a drawing element or layer can be a character, for example, level B. In
cut-out animation, a drawing element can be the hand layer.

When you add a column or layer to your scene, a node and a folder (element folder) are also added. By default,
the element folder and layer (node) are named the sameway as the column. As explained above, the element
folder's purpose is to contain all the drawings related to this column. For example, in cut-out animation, a
character can havemanymouths available. All thesemouth drawings will be contained in this folder, even if
they are not currently exposed in the scene. In other words, there is always a drawing container hooked to a
layer or column, unless that layer is linked to another drawing element (clone).

You can find the drawing element folders in your scene's subdirectory called elements.
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You can add drawing layers from the Timeline view, Xsheet view and the top menu .

In order to understand what happens when you duplicate a drawing, extend an exposure, create cycles or delete
a drawing, it is important to know how a layer works.

Each layer is linked to a column and that column is linked to a directory in which all of its drawings are saved. This
directory has the same name as the layer and column. When a value or drawing name is typed in a layer’s cell,
Harmony looks in the layer’s directory for the corresponding drawing to display. If there is no corresponding
drawing, a new one is created.

New vector drawings are created as *.tvg (Toon Boom Vector Graphic) files.

The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s directory. If you
remove a drawing from the layer exposure, it is not deleted; it is simply not displayed.

When you create a drawing cycle, all of the repeated drawings are linked to the same original files. This means
that when youmodify, repaint or correct a drawing named “1”, all drawings named “1” are updated
simultaneously. In order to modify a drawing independently from its other exposures, youmust duplicate the
drawing.
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Palettes

In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a palette is
created fromHarmony, it needs to be stored somewhere. By default, the palette file is stored in the scene
directory in a palette-library folder unless you specify a different location. There are four locations where you
can find palette-library folders:

l Element: The Palette Library folder is stored directly in the drawing Element folder.

l Scene: The Palette Library folder is stored directly in the Scene folder.

l Job: The Palette Library folder is stored in a Job folder contained in the Scene folder.

l Environment: The Palette Library folder is stored in an Environment folder contained in the Scene
folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them on the
file structure.

This existing structure is compatible with Harmony Server. Harmony’s database has a leveled structure
starting from the Environment down to the Element. Its client-server configuration allows all data, such as
palettes and scenes, to be shared between a series of client machines.

Element Level

Working with Harmony Stand Alone, the Element level is very useful when there are a lot of different palettes.
When a colour model drawing is created, it is stored in its element folder. By storing the corresponding palette
file with the colour model, the colourist can load them both from the same location. This also creates a more
organized structure.

Scene Level

Working with Harmony Stand Alone, a palette file can also be saved at the scene level, so that all of the
palettes from the scene are stored together. The palette naming must be structured so the colourist or
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character builders can find the correct one. Saving the palettes at the scene level makes it very easy to back up the
palettes and retrieve their location.

The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that includes all
of the characters, props, effects, and location, the colour palette or model will often be directly imported to, or
created in, the character building scene. Just as with a cut-out character building scene, each element uses the
same palette so it would not be efficient to save the palette inside one element. Instead, it is saved at the scene
level. This prevents a palette overload because all of themodels are in different scenes. It also allows each scene
to have its own set of palettes corresponding to its model.

Whenworking on a cut-out animation production, it is highly recommended that you work with the Scene level.

Where to Save the Palette File

The palette storage location depends on the type of production and the backup plan being used. Some studios
like to store their palettes at the Element level and others at the Environment level as this will not create a
problem so long as the scene is in the Harmony structure. In fact, as long as the Harmony structure is maintained
it can be stored at any level. However, difficulties may occur when the scene is backed up or transferred to
another studio or database and removed from the structure.

What happens when you export a palette file?

It is important to understand what is happening to a palette file when the scene is exported.

Because of the Harmony client-server configuration, all of the data can be shared through all of the scenes in the
database. This also includes the palette files, even if they are stored at the Element, Scene, Job, Drawing or
Environment level. The palette files can be accessed from any scene of any project.

When you export scenes fromHarmony to either archive or send them to other users or studios, the palettes
stored in external scenes, jobs or environment will NOT be exported.

An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette library, the Job
and the Environment where it is stored. Any other palette from other Environments, Jobs, Elements or Scenes
(even from the same job) willNOT follow. Instead a recovery palette will be created when the scene is reopened
in another Harmony system. A recovery palette is a local palette created by the systemwhen palettes and colours
aremissing. This palette is no longer shared with the rest of the project.

For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the palettes from
Scene 2, Job 1 and Environment. ItWILL NOT carry the palettes from Element 3 in Scene 1, Scene 1 and Job 2. If
Scene 2 was linked to any of these, the systemwill create a recovery palette the next time Scene 2 is opened in
another Harmony system.
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The best place to store your palette is:

• Environment level for a movie or series

• Job level for a publicity or small project

• Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will requiremore
structure when exporting the scenes. The scene will have to be exported along with its colour model scene.
The other studio you are working withmust recreate an identical structure to yours, then import the received
scenes into the same location as you have them in order to maintain the links.

Palette Backup

When sharing palettes between scenes, some users may accidentally modify the colours, even though the
palettes are locked by default. That is why it is a good idea to copy and back up your palette libraries and
master palette directories.

When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Libraries and Templates
Harmony allows you to use a library to store and reuse elements such as animation cycles, network effects and
filters, trajectories, cut-out puppets, etc. We call these elements assets or templates. These libraries can be
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placed and used on different levels.

Harmony provides some library folders, to which you can add your own libraries. Harmony’s library can be
accessed from any scene opened on themachine.

To store your assets somewhere other than the default location, you can create your own folder on your hard
drive. If you are connected to a network, you can create a folder on the server to be shared with other network
users.

We recommend that you name your library with a relevant project name, such as adventure_library.

The library folders and their templates are completely external to Harmony and can be archived andmoved
independently from the production. They can also be sent to other Harmony users.

It is always a good idea to be descriptive when naming your templates (assets). Although not mandatory, it is
highly recommended to use alphanumeric characters:

l a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues whenworking on different platforms such as MacOS X or Linux.

Library Structure Tips

The following recommendations may be useful as you structure your work. Themain library can be divided into
categories to match different template types:

l Character

l Background

l Audio

l Prop

l Effect

The character section is often altered themost. It is recommended that you divide this folder between:

l Main Characters

l Episode Characters
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Within theMain Characters folder, you can create a folder for each individual character. Episode characters are
generally less numerous and can be stored in folders corresponding to their episode. Each character’s folder
can be further divided into subfolders, such as:

l Model

l Animation

l Keyposes

l Reuse Parts

The Animation section can be organized by actions, such as:

l Run Cycle

l Walk Cycle

l Jumps

l Miscellaneous

Some users may divide their animation folder by angle or view:

l Front

l Three-quarter

l Side

l Three-quarter back

l Back

Personal Libraries

During the animation process, an animator will often reuse certain templates. Some animators have their own
personal libraries to store their favourite templates. If a template has been updated in themaster library, the
Librarymanager should send a note to the animators and the scene setup team to ensure that they update
their personal libraries.

Naming Convention
Whenworking on large or even small projects, it is best practice to create a naming convention for everyone to
follow. This will help keep the work organized and consistent.

Scene Naming Convention

For improved consistency and ease of use, incorporate naming conventions for your scenes and other project
elements.

l We recommend that you name your scene using alphanumeric characters: a to z, 0 to 9 and underscore ( 
_ ).

l Avoid capital letters or spaces in the file names.
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l Try to provide themaximum amount of information for future identification, which helps ensure that you
do not mix up elements and lose information.

For example, you could name a scene adventure_sc001, adventure_scene_01, adventure_character_
models or adventure_seq01_sc002.

If your scene is contained within a Job in the Harmony Server centralized database (accessible via Control Center),
you can name your scene as follows: sc001, sc_001, 001, seq001_sc001, etc.

If you are working with the Harmony Server centralized database, you can give an indication of the environment
(project) and job in the scene name like:

l Environment = Lippyland

l Job = li_02

The jobs usually are not just named 01, 02, 03, etc., because they all reside in the same folder ( USA_DB/jobs/ and
USADATA000/ ), therefore some prefixes such as “li_” must be added.

In this case the scenes would be named:

l LIP_li_02_sc001

l LIP_li_02_sc002

l LIP_li_02_sc003

l LIP_li_02_sc004

Layer Naming Convention

When you create drawing layers, it is recommended to name them instead of keeping the default name. This way,
your work will be organized and it will be easier for another person to work with your data later on.

It is always a good idea to be descriptive when naming a layer. Although not mandatory, it is highly recommended
to use alphanumeric characters:

l a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues whenworking on different platforms such as MacOS X or Linux.

It is highly recommended that you incorporate a naming convention for the layers when building cut-out puppets.
This will be very useful later on.

We suggest that you:
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l Add one or two letters for the character/prop name before the part name and an “r” for right or an “l”
for left to identify the corresponding character/prop:

l Character Abby’s right arm = ab_r_arm

l If you plan to work with different angles for your characters (front, side, three-quarter, back), you can
add one or two letters to identify the angle:

l Character Abby’s right arm, front view = ab_r_arm_f

l Instead of using the “r” and “l” markers for the different right and left body pieces, you can use “1” to
indicate if a limb is closer to or farther away from the character. For example instead of r_arm and l_
arm, you could have arm and arm1. The reasoning is that when the character is flipped, it is less con-
fusing to have “1’ as an indicator for a close limb instead of right or left:

l Character Abby’s closer arm = ab_arm

l Character Abby’s farthest arm = ab_arm_1

Renaming a Series of Nodes

When you use a blank rigging template, all of the nodes’ names are generic. You will need to add naming
information, such as the character’s name and the angle.

Harmony provides you with a script called Add Prefix or Suffix that allows you to add a prefix or a suffix to a
series of selected nodes at the same time.

How to add a prefix to a series of nodes

1. In the Network or Timeline view, select all of the nodes or press Ctrl + A (Windows/Linux) or⌘ + A
(MacOS X).

2. In the Scripting toolbar, click the Add Prefix or Suffix script button.

The Add Prefix or Suffix dialog box opens.

3. Select the Prefix or Suffix option, depending onwhat you want to add to the element’s name.

4. Type the prefix or suffix information to be added to the node name.

Puppet Drawing Naming Convention

We recommend that you use a naming convention for your drawings. If you combine all of the angles of a
character in the same breakdown scene, it is a good idea to identify each angle used.

Before drawing the parts in the drawing elements (layers), we recommend that you create a drawing name that
represents the angle used. This will be quite useful during animation and drawing substitution. For example,
use “f” for front, “s” for side, “q” for three-quarter so that the drawing name looks like this:

l f1, f2, f3, s1, s2, etc.

In the facial feature drawings’ name, you can also add “h” for happy, “s” for sad or any other letter
symbolizing an expression to help regroup the same theme of drawings. For example:
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l HappyMouths:

l f_h_a,

l f_h_b,

l f_h_c,

l f_h_d,

l f_h_e,

l f_h_f,

l f_h_g,

l f_h_x

l SadMouths:

l f_s_a,

l f_s_b,

l f_s_c,

l f_s_d,

l f_s_e,

l f_s_f,

l f_s_g,

l f_s_x
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Chapter 8: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will learn about
starting the application, setting the resolution and opening the scenes.

Server and Centralized Database

The Harmony solution is a revolutionary team-based infrastructure for animation production and 2D games. Its
array of features increases productivity and encourages creativity. Developed in conjunction with leading studios
worldwide, Harmony is specifically designed for long-term episodic and feature length projects, providing a true
animation pipeline. Several animators can work simultaneously on the same project while the asset library
provides users with easy access to up-to-datemedia assets. Harmony is truly scalable; more than 100 staging
clients can share animation just as easily as a few can.

Note that Harmony can be used in Databasemode via the server connection (Harmony Server) or as a standalone
application.

What is Harmony Server?

Harmony Server is the link between the client machines and the server. It lets you work on the different projects
stored in the central Harmony database.

At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository.
Loaded with production proven tools to manage administration tasks, the server is completely flexible and will fit
in your existing infrastructure, whether you are onWindows, Linux or MacOS X. To learnmore, refer to the
Control Center Guide.

Working with Stage Via Harmony Server

When you start Stage, you can opt to either work offline in the application as a standalone software, or connect
to the database to work on projects via Harmony Server.

Whenworking with Harmony Server, the scenes and their data are stored directly on the server. No data is saved
or stored on the client machine. The client machines access the database and load the scenes and drawings
directly from the server. Each time the user saves his scene, the data is updated directly on the server. There are
no upload or download operations (check-in, check-out) done between the server and the clients.
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NOTE: If you have a standalone license, you will not have access to the database. You will automatically start the
application in standalone mode.

Starting Stage
You can run Harmony on Linux, MacOS X or Windows operating systems.

How to start Harmony Stage

1. Do one of the following:

l Windows: Start > Programs > Harmony 12.1 Premium> Stage Premium

l MacOS X: Applications > Toon BoomHarmony 12.1 Premium> Stage Premium

l Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_64/bin/Stage

NOTE: If you have a standalone license, Toon Boom Harmony will open directly with the Welcome screen.

2. In the User Name field, enter your username. It is generally provided by the supervisor, system admin-
istrator or team lead.

3. Select theConnect to Database orWork Offline option.

l Connect to Database: (Your databasemust first be set up.) Lets you work on Harmony con-
nected to the database so you can access scenes stored in the central database of the Toon
Boom Server; certain options become available in the different menus. However, you will not be
able to create new scenes directly from Stage and the available scenes will be the ones that were
previously created using the Control Center.

l Work Offline: Enabled by default when you start Harmony for the first time. Using this mode lets
you create new scenes and work locally on your machine on independent projects as you would
with any local software. However, the following limitations apply:

l Options exclusive to Harmony Server will not be available in the different menus.

l Youwill not have access to any projects stored in the central database of the Toon
Boom Server.

4. Click OK.

In Offlinemode, theWelcome Screen opens—seeWelcome Screen on page 77.

In Databasemode, the Database Selector opens—seeConnecting to the Database on page 73.
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l Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_64/bin/Stage

Toon BoomHarmony opens.

NOTE: If you have a standalone license, Toon Boom Harmony will open directly with the Welcome screen.

5. In the User Name field, enter your username. It is generally provided by the supervisor, system admin-
istrator or team lead.

6. Select theConnect to Database orWork Offline option.

l Connect to Database: (Your databasemust first be set up.) Lets you work on Harmony connected
to the database so you can access scenes stored in the central database of the Toon Boom Server;
certain options become available in the different menus. However, you will not be able to create
new scenes directly from Stage and the available scenes will be the ones that were previously cre-
ated using the Control Center.

l Work Offline: Enabled by default when you start Harmony for the first time. Using this mode lets
you create new scenes and work locally on your machine on independent projects as you would with
any local software. However, the following limitations apply:

l Options exclusive to Harmony Server will not be available in the different
menus.

l Youwill not have access to any projects stored in the central database of the
Toon Boom Server.

7. Click OK.

In Offlinemode, theWelcome Screen opens—seeWelcome Screen on page 77.

In Databasemode, the Database Selector opens—seeConnecting to the Database on page 73.

Connecting to the Database

Before you can work in Stage via Harmony Server, youmust be connected to the Harmony Database. When you
connect to the database, you cannot create new scenes directly from Stage. The available scenes will be the ones
that were previously created using the Control Center.
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How to connect to the Harmony database

1. Start Stage—see Starting Stage on page 72.

2. In the Toon Boom Stagewindow, select theConnect to Database option.

3. In the User Name field, type in your Harmony usernamewhich is provided by your project lead or system
administrator.

4. Click OK.

The Database Selector dialog box opens, displaying the environments available in Harmony database.

5. In the Environments column, select the scene's environment (project, movie).
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6. In the Jobs column, select the scene's job (episode, sequence).

7. In the Scenes column, select the scene.

8. Get the permissions needed for this session by selecting one of the following options:

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked.
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked items. If
someone tries to open a locked scene, it will be displayed as read-only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, nodes but not the drawing, palettes,
palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

1. Choose the version you want to open from the Versionmenu—see How to save the current version of a
scene in Harmony Server.

‣ The Saved By and Saved Date fields display the user who last saved the selected scene and the date of
the last save.

2. Click Open.

75



Chapter 8: Starting Toon Boom Harmony

Global Lock

Harmony Server has a lock system, referred to as Global Lock, for the different scenes and scene assets. As all
the data on the server can be accessed directly and modified from any client machine by default, the scenes are
locked. Users must obtain the rights to modify scenes in order to save their work on the server.

Only one user at a time canmodify a scene. Once a scene is opened on a client machine, other users can only
open the scene in read-only mode; they will not be able to save anymodifications.

If you work in standalonemode, you automatically have the rights to modify all drawings and palettes.

TheGlobal Lock has three levels:

A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked.
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked
items. If someone tries to open a locked scene, it will be displayed as read-only.

Here are the different lock possibilities:

Lock Description

Scene or Version Lock
Controls the Xsheet timing, layers, nodes but not the drawing, palettes,
palette-lists or templates.

Drawing Lock Only one user can edit and save a locked drawing.

Palette Lock Only one user can edit and save a locked palette.

Palette-list Lock Only one user can edit and save a locked palette-list.

Library Folder lock Only one user can edit and save into that folder in the Library.

These three levels of locking are available from the Database Selector when the user logs into Harmony. From
there you can select a scene and obtain the rights to modify it by selecting the desired lock option.
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There are several different ways to obtain the rights to modify the scenes. It can be donewhen the user loads a
scene fromHarmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Center node.

Acquiring Rights to a Scene Once it is Loaded

If you opened a scene in read-only mode, but realize that you need to modify it, you can easily acquire the
necessary rights without closing and reloading the scene.

Note that it is not possible to acquire the rights to modify the scene assets once the scene is loaded. This process
is done during the initial loading of the scene. To learnmore about enabling the rights to modify while creating
environments, jobs and scenes, refer to the Control Center module.

How to set the scene's rights after the scene is loaded

‣ In the top menu, select File > Rights toModify Scene or Rights toModify Scene Version.

Welcome Screen
When you start Toon BoomHarmony, theWelcome Screen appears. If a scene is already open, you can display
theWelcome screen by selectingHelp > Show Welcome Screen.

NOTE: Note that Harmony Server does not display a Welcome Screen. It displays the Database Selector window.

TheWelcome Screen allows you to:

1. Create scenes
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2. Choose the scene resolution

3. Add or delete a custom scene resolution

4. Open recent scenes from a list

5. Open scenes by browsing

6. Open the online support page

7. Open Harmony video tutorials

8. Open Harmony directly without opening theWelcome screen first.

To display theWelcome screen later on, go to the top menu and select Help > Show Welcome Screen.

Accessing the Documentation

How to access the Harmony documentation

1. In the Support section, click on theGet Help button.

Your default web browser opens to the Toon Boom Support page.

2. From the Support page, under the Learn Toon Boom Software section, click on the Documentation but-
ton.

The Toon BoomHelp page opens.

3. From the Toon BoomHelp page, click on the Harmony Icon.

The Harmony 12.1 Help page opens.

All the Harmony guides can also be opened directly in the software. From the top menu, select Help >
Online Help or press F1.

Saving a Scene
It is important to regularly save your scene. As youmake changes to a scene, an asterisk (*) appears in the title
bar beside the scene name to indicate that the scene contains unsaved changes.

It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or
parameters to see which one will work best. Harmony allows you to save a new version of your scene. It is
really important to note that the drawings and palettes are the same between ALL the scene versions. You can
modify the timing, effects, parameters and camera motion, but if youmodify the drawings, they will be
changed everywhere.

You can also automatically save your work. Refer to the Preferences guide to learnmore about this function.

When you use Harmony Server and work in a scene on the database, there aremany choices and options
available when you save your work.

l Save the scene as the current version.

l Save different versions representing different stages of the production of your scene.
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l Save different versions representing different scene setups.

l Choose specific assets that you want to save, such as drawings or palettes.

When you open the scene from the database and select the version you want to edit, you can save the changes
youmade in the current version or create a new version. The simplest way to save your work is to update the
current version.

You can delete any unnecessary versions using the VersionManager.

Whenworking withmultiple versions, youmay want to merge some of the changes from one version into
another. Youmay have created a version with some suggestions that you submitted to the director while
continuing to work on the official version. If the director has approved some of the changes, you can go ahead
and import them into the official version.

Youmight want to save some specific aspects of your scene or save a new version. The Advance Save feature
allows you to do this. Once you have chosen the components to save, you will conclude the procedure by
following the instructions in the section. All the specific components that are selected throughout the different
tabs of the Advanced Save dialog box will be saved.

How to save a scene

‣ From the top menu, select File > Save.

‣ Press Ctrl + S (Windows/Linux) or⌘ + S (MacOS X).

Auto-Save

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).

1. Select theGeneral tab.

2. In the Save section, select theAuto-save option.

• Interval (minutes): This is the frequency at which the auto-save takes place.

• Inactivity Interval (seconds):WhenAuto-save is about to take place, it verifies if you are drawing or doing
anything in the application. If so, Auto-save waits this number of seconds before attempting another save.

• Ask Before Saving: Before performing an auto-save, you are prompted with a message to confirm if you
want to save or not. You can choose to turn off this option.

• Enabled: This enables the Auto-save feature. If you do not want the system to automatically save your
work, deselect this option. The auto-save is off by default.
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How to save the current version of a scene in Harmony Server

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can
acquire the rights by selecting File > Rights toModify Scene Version or Rights toModify Scene.

2. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or⌘ + S (MacOS X).

When saving the scene for the first time, the Save dialog box opens, prompting you to name the
version.

3. Edit the information in the current version:

‣ In the This Version field, enter a relevant name for the current version.

‣ In the Description field, enter a short description of the current version.

4. Click Save.

How to delete versions

1. Make sure you have the necessary rights. If you do not, select File > Rights toModify Scene.

2. From the top menu, select File > Manage Versions.
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The Versions dialog box opens.

3. In the Existing Versions list, select the scene version you want to delete. When a version is selected, inform-
ation about it appears in the Description list.

4. Click Delete.

The ConfirmDelete Versions dialog box opens, warning you that the operation cannot be undone.

5. Click one of the following:

‣ Yes: ONLY if you are absolutely certain that the version can be deleted.

‣ No: To cancel the operation and keep the version.

About the Advanced Save dialog box

1. Make sure that you have the necessary rights to save the current scene version. If you do not, you can
acquire the rights by selecting File > Rights toModify Scene Version or Rights toModify Scene.

2. From the top menu, select File > Advanced Save.

The Advanced Save dialog box opens.
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File

In the File tab of the Save dialog box, you can do the following:

• Save the scene as a new version

• Overwrite an existing version

• Set a new current version.
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Parameter Description

Save

‣ Enable this option if you want to save themodifications made to the
current scene.

‣ Deselect the Save option if you only want to save specific components of
your scene listed in the Drawings, Palettes or Palette Lists tabs. This will
disable all option in the File tab.

This Version (number)
Saves the current version of the scene. You can rename the current version by
typing a new name into the field.

New Version (number)
Saves the current scene as a new version. You can name this new version by typ-
ing a name into the field.

Overwrite Existing Version Lets you select an existing version of your scene from the list to overwrite it.

Description
Use this field to add or edit an existing description for the scene version you
want to save.

Mark as Current
Lets you set this scene version as the current one. This version will be auto-
matically selected as the default current version when the scene is selected in
theDatabase Selector dialog box

Drawings

TheDrawings tab lists themodified drawings.

Parameter Description

Drawing list
Lets you select themodified drawings to save, and deselect the ones you do
not want to save.
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Select All Selects all modified drawings in list.

Deselect All Deselects all modified drawings in the list.

Palettes

The Palette tab lists themodified colour palettes.

Parameter Description

Colour Palette list
Lets you select the colour palette to save, and deselect the ones you do not
want to save.

Show Recovered Displays the recovered palettes in the list of modified palettes.

Select All Selects all modified colour palettes in the palette list.

Deselect All Deselects all modified colour palettes in the palette list.

Palette Lists

The Palette Lists tab lists all themodified colour palette lists.
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Parameter Description

Palette Lists
Lets you select themodified palette list to save, and deselect the ones you do
not want to save.

Show Recovered Displays the recovered palettes in the list of modified palettes.

Select All Selects all modified palette lists in the list.

Deselect All Deselects all modified palette lists in the list.

How to save with advanced settings

1. After selecting the components to save, click Save.
All the specific components that were selected throughout the different tabs of theAdvanced Save dialog
box are saved.

How tomerge scene versions

1. From the top menu, select Edit > Open Merge Editor.

The Choose Scene Versions for Merge window opens.
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2. In the Select Version to Merge Changes From list, select the scene version fromwhich you want to
merge the changes from in your current open version.

‣ In the Use Another Version for Reference section, you can select a different scene version to merge
the changes into, rather than your current version.

3. Click Load.

TheMerge Editor opens.
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4. From the right column, select the layers you want to merge the changes from into the reference version.

5. In the Select Element Range section, set the Start Frame and End Frame fields to indicate fromwhat frame
to what frame youwant to take the changes from.

6. ClickMerge Selected to complete the operation.

Setting the Scene Length
Once you have opened your scene, you can set its length.

How to set the scene length

1. From the top menu, select Scene > Scene Length.

The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

New Scene Startup Script

When you create a new scene, the TB_sceneCreated script automatically sets the scene length to 60 frames
and adds one of each of the following nodes: drawing element, composite, display and write.

You can find the script in the Script Editor window.
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You can customize this script to fit your current project needs. This way, you can set the default scene length to
any number of frames you want, or even decide which types of elements and nodes you want to be in your
scene when you create it.

Refer to the Toon BoomHarmony Scripting Guide to learnmore about using, creating and customizing scripts.

Adding a Drawing Layer
Now that your scene is set up, you can start adding drawing layers.

How to add a drawing layer from the Timeline view

1. In the Timeline view, click the Add Drawing Layer button or press Ctrl + R (Windows/Linux) or⌘ +
R (MacOS X).

The Add Drawing Layer window opens.

2. In the Name field, name your new layer.

3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a bitmap
layer.

4. Do one of the following:

‣ Click Add to add a first layer and keep the window open to addmore layers.

‣ Click Add and Close to add a new layer and close the window.

A new drawing layer is added to the Timeline view.
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Locking Drawings

The drawings are stored on the server database providing access to them from every client machine. They are
locked to avoid different users frommodifying the same drawings simultaneously. Only one person at a time can
get the rights to modify them. The drawing rights are independent from the scene rights because in a production
rush, two users may need to work on the same scene to finish painting the drawings faster. One user will get the
rights for one set of drawings, and the second user the rights to another set of drawings. This prevents work
from being duplicated.

When enabled, the Edit Drawings mode gives you the right to modify drawings, as well as create new drawings
by drawing directly on an empty cell. This mode is enabled by default when you open a scene version with the
rights enabled.

NOTE: If you open the scene with full rights from the Welcome screen or Control Center, the Edit Drawing mode is
not available.

When you disable the Edit DrawingMode, you can use theGet Rights to Modify Drawings option on a selection
of specific drawings. This is useful when, for example, many users are working on the same scene during the ink
and paint process and they want to split the drawings to paint between them.

Also, once you got the rights to modify drawings, you can release these rights if necessary.

If your system crashes and the drawings remain locked, you can force the release of the rights. Youmust use this
option carefully as data loss may occur if the scene is currently open and being edited by another person. Verify
that no one else is using the scene prior to forcing the release of the drawing rights.

Since the drawings are stored on the server, youmight at times need to refresh the drawings that are displayed in
your scene.

How to enable the Edit DrawingMode

1. From the top menu, select Edit > Edit DrawingMode.

How to get the rights on a selection of drawings

1. Make sure that the Edit DrawingMode is disabled.

2. In the Xsheet view, select the drawings you want to edit.
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3. From the top menu, select Edit > Get Rights toModify Drawings or press Alt + L.

How to release the rights on a selection of drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Release Rights toModify Drawings or press Alt + Shift + L.

How to force the release of the rights of locked drawings

1. In the Xsheet view, select the drawings you want to release.

2. From the top menu, select Edit > Force Release Rights toModify Drawings.

AWarning dialog box opens.

3. Do one of the following:

‣ Click Yes to force the release.

‣ Click No to cancel the force release.

How to read changed drawings

‣ From the top menu, select File > Read ChangedDrawings.

Scene Settings
When you created your new scene, you set up the resolution and the alignment. However, if you want to
change these initial settings later, you can do it using the Scene Settings dialog box. The different Scene
Settings options are separated into four tabs.
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How to open the Scene Settings dialog box

1. From the top menu, select Scene > Scene Settings.

The Scene Settings dialog box opens.

Resolution Tab

Parameter Description

Resolution Presets You can select your project’s resolution (camera frame size) from this preset
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list.

‣ HDTV: High definition television delivers a higher quality image than
standard television (4:3) does, because it has a greater number of lines
of resolution. To take advantage of the superior quality your output
devicemust be compatible with HDTV technology to make this
resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to
how the images will be aligned in relation to the actual scene frame
(default 4:3 grid). Note that the camera resolution and the scene frame
are not the same. Whenworking with 12 or 16 field drawing grids, the
grid is a different aspect ratio from the camera frame. When you fit
vertically, you fit the images with the top and bottom of the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format that
conforms to the standard 4:3 aspect ratio.

‣ film-1.66: Use this resolution setting for the widescreen film format that
conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to
how the drawing is fit into the scene frame. Whenworking with 12 or 16
field drawing grids, the grid is a different aspect ratio from the camera
frame. When you fit vertically, you fit the images with the top and
bottom of the scene frame.

‣ NTSC: This is the standard analogue television broadcasting system
used in North America and conforms to theNorth American standards
on how rectangular pixels are displayed for computer and television
screens.

‣ PAL: This resolution works best with the European format for television
and computer screens, as the rectangular pixels are displayed at a
different orientation.

‣ Low: This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality.

‣ Cloud Preview: This is the resolution used byWeb Control Center to
create its preview.

Selected Resolution Preset Displays the selected resolution preset.

Save Resolution Setting

Click the Save Resolution button after you define your new resolution to save it
as a preset.

If you are working in Harmony Server, you will be prompter a dialog box asking
you to name the new resolution as well as the level at which you want to save
the resolution,conf file.
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Pixel Dimensions

Displays the pixel dimensions for your project resolution.

If you decide to type in the pixel dimensions, or use the up and down arrows to
change the pixel increments, you will have to save your custom selection in
order to save it as a new preset. It will then appear in the resolution selection
list. It doesn't modify the current resolution preset.

Aspect Ratio
Displays the ratio between the horizontal and vertical dimensions of the camera
framing. Each resolution setting has a preset aspect ratio that cannot be
changed.

Frame per second

Sets the frame rate for your project. The higher the frame rate, for example 30
fps, the faster the animation will pla. The lower the frame rate, for example 12
fps, the slower your animation will play. Avoid going under 12 frames per
second as your animation will have a choppy playback. The human eye requires
a minimum of 12 frames per second to perceive a fluid animation.

Field of View

Use these options to define the FOV (field of view) of the camera (angle of the
camera cone) and how the drawing elements (and drawing grid) align to the
scene grid. The drawing grid is always scaled proportionally to a 4:3 ratio
(unless you change the scene alignment), therefore changing the Field of View
setting may not show a visible difference if your project resolution is also 4:3,
such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right edges
of the scene grid.

‣ Vertical Fit: The camera resolution is set to fit the top and bottom edges
of the scene grid.
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‣ Custom Fov: After selecting this option, use the now-active field to the
right to enter in a value, in degrees, of the angle that you want the
camera cone to be. Increasing this value will make the camera cone wider
(the angle is more obtuse), widening the FOV andmaking the grid and all
elements appear farther away. Decreasing the default value will create
the opposite effect.

Projection

The Projection settings allows you to modify the type of camera your scene is
using. You can either use a perspective camera (regular camera) or
orthographic camera (no perspective).

‣ Perspective: The Perspective option is the default and most common
option. Objects placed closer to the camera will be displayed bigger and
objects placed further away will be displayed smaller.

‣ Orthographic: TheOrthographic option is specific to the gaming
pipeline. It changes the camera from Perspective to Orthographic,
meaning that there is no more perspective in the Camera view. Objects,
whenmoved in depth will not change size. There is more information
available about this option in theGaming user guide. In order to create
scenes with theOrthographic camera by default, you need to create a
new custom scene resolution.
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Alignment Tab

Parameter Description

Alignment

The Alignment presets give you two preset options:

‣ 4:3 12 Fields: Defines the units of your project to have a 4:3 ratio and
sets up 12 of these units to run both vertically and horizontally in four
cardinal quarters (NW, NE, SW, SE). This Alignment preset is visible in
the FOV and drawing grids.

‣ Square 12 Fields: Defines the units of your project to have a 1:1 or
square ratio and sets up 12 units to run both vertically and horizontally in
four cardinal quarters (NW, NE, SW, SE). This Alignment preset is NOT
visible in the FOV and drawing grids.

Units Aspect Ratio

In the Units Aspect Ratio fields, enter the aspect ratio of the grid you will use.
The aspect ratio describes the shape of the grid unit. A square grid unit would
have the ratio 1:1, whereas a grid unit of aspect ratio 4:3 is a unit with one side
1.33 times as big as the other side.
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If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field (X-axis)
and 1 in the Up/Down field (Y-axis). The default Aspect Ratio is set to 4:3 as it is
the one used by traditional animators, who are accustomed to working with the
grid system described above.

Number of Units

In the Number of Units fields, enter the number of horizontal, vertical and depth
units for your scene’s grid.

Animators who prefer to work traditionally will understand the default setting
of 24 units horizontal by 24 units vertical as it, once again, corresponds to the
grid above. Twelve is a common setting for the field depth.

Those who prefer to work in pixels should enter the pixel dimensions (3) of their
project. This way if you want to move something over 600 pixels you just need
to type in 600 units.

Coordinates at Centre

In the Coordinates at Centre, you can enter a new coordinate for the centre of
your scene.

By default, the (0,0) centre is set in themiddle of the grid as shown in the grid
above. If you want to change the centre of your grid, for example to the upper
left corner, you would enter (-12, 12), -12 units across and 12 units up. That is of
course unless you changed the number of units to match the pixel dimensions of
your scene. Then you would enter negative half the width and positive half the
height.

Save
Saves your current Alignment settings and be able to select them later from the
list.
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NOTE: If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your project, you
may find that the animation grid becomes offset. To correct this, choose the following setting from the Layer
Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.

Bitmap Resolution Tab

The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter Description

Scene Resolution This is the scene resolution preset name and size in pixels.

Width

This is the width of the resolution for the bitmap that will be created. This is not
the actual size of the bitmap. TVG drawings (Toon Boomdrawing native
format) have an infinite size. Bitmap TVGs are composed of small tiles. There-
fore it does not mean that because you have artwork at the four corners of your
camera frame or even quite far outside of your drawing that your bitmap image
will be very large and heavy. By default, it is set to the samewidth as the scene
resolution.

Height
This is the height of the resolution for the bitmap that will be created. By
default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you
increase the percentage, the width and height fields will increase accordingly. If
you plan to animate the camera and zoom into your background, you will need
to set a higher resolution so that the smaller area in which you will zoomwill be
100% of the scene resolution.
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Advanced Tab

The Advanced tab contains an option for Toon BoomDigital Pro release 7.3 and Harmony release 7.3.

Since version 7.8, themethod in which Z-Ordering is calculated has been optimized. Enable this option if you
want to use the version 7.3 system.

Toon BoomDigital Pro and Toon BoomHarmony 7.3 allowed smaller values on the Z-axis such as 0.0001.
Since version 7.8, the Z-ordering calculation is now optimized and allows only larger values such as 0.001.

Verifying the Project Integrity
The Check Files command verifies the integrity of the drawing and palette files in your project.

How to open the Check Files dialog box

‣ From the top menu, select Scene > Check Files.

Check Files

Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

• Click Check Colours to open the Check Colours dialog box.

Check Colours

The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Basic Commands
This table lists themost common commands used in Harmony.

Command Action Access Methods

Open

Displays theOpen Scene dialog
box. Browse your file system for
a scene file.

TheOpen command is not
disabled when a scene is
opened. You can open a new
scene from the current one and
the previous scene will be
closed.

File > Open

Press Ctrl + O (Windows/Linux)
or⌘ + O (MacOS X).

Close
Closes the currently opened
scene, but does not close the
Harmony application.

File > Close

Save
Saves all changes made to the
opened scene, drawings,
palettes, and palette lists.

File > Save

Press Ctrl + S (Windows/Linux)
or⌘ + S (MacOS X).

Removed Unused Files
This command removes the
unused palettes from the scene
list.

File > Remove Unused Files

Save As New Version

Saves the current scene as
another version. The Save Ver-
sion dialog box prompts you to
give a name for this new ver-
sion. This will create a new
.xstage file in your current pro-
ject directory.

File > Save As New Version

Quit Closes the application.
Windows/Linux: File > Quit

MacOS X: Stage> Quit
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Command Action Access Methods

Show Scan Information

Displays a status bar showing
the scanning information at the
bottom of the Drawing and
Camera view.

Drawing View Menu > View >
Show > Show Scan
Information

Cut
Removes selected objects. You
can then paste the object or its
properties to another object.

Edit > Cut

Press Ctrl + X (Windows/Linux)
or⌘ + X (MacOS X).

Copy
Copies selected objects and
properties.

Edit > Copy

Press Ctrl + C (Windows/Linux)
or⌘ + C (MacOS X).

Paste

Places an object you cut or
copied into the location you
select in the Camera, Drawing
and Timeline views.

Edit > Paste

Press Ctrl + V (Windows/Linux)
or⌘ + V (MacOS X).

Delete Removes selected objects.
Edit > Delete

Delete

Select All

Selects all drawing objects in
the current drawing window in
the Drawing, Timeline and
Camera views. This helps you
managemultiple objects as one
whenmoving them.

Edit > Select All

Press Ctrl + A (Windows/Linux)
or⌘ + A (MacOS X).

Deselect All
Deselects all selected objects in
the Drawing and Camera views.

Edit > Deselect All

Esc

Undo

Removes the last changemade
to your project. Harmony
supports multiple undo, so you
can undo changes youmade in
the order youmade them.

Edit > Undo

Press Ctrl + Z (Windows/Linux)
or⌘ + Z (MacOS X).

Redo

Redoes an operation you have
undone. This command is active
only after you use the Undo
command.

Edit > Redo

Press Ctrl + Shift + Z.

Select Child Skipping Effects

Lets you select the first element
parented to the selected peg
element in the Timeline view
skipping effects in the hierarchy.

Animation > Select Child
Skipping Effects

Press Shift + B.

Select Children
Lets you select all elements
parented to the selected peg
element in the Timeline view.

Animation > Select Children
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Command Action Access Methods

Select Child
Lets you select the first element
parented to the selected peg
element in the Timeline view..

Animation > Select Child

Press Shift + B.

Select Parent Skipping Effects

Lets you select the parent of the
selected element in the Timeline
view skipping effects in the
hierarchy.

Animation > Select Parent
Skipping Effects

Press B.

Select Parent
Lets you select the parent of the
selected element in the Timeline
view.

Animation > Select Parent

Press B.

Select Previous Sibling
Lets you select the previous
element (above current
element) in the Timeline view.

Animation > Select Previous
Sibling

Press /.

Select Next Sibling
Lets you select the next element
(below current element) in the
Timeline view.

Animation > Select Next
Sibling

Press ?.

Auto Render Write

Use the Auto Render Write
command to render a frame
each time the current frame is
changed.

Youmust have a Write node in
your network to use this
command.

Scene > Render >Auto Render
Write

DebugMode

Enables the Debugmode for
gathering and displaying
precise information about each
rendering frame, such as the
nodes encountered and action
taken.

Help > DebugMode

Help

Launches the Toon Boom
HarmonyOnline Help system,
complete with instructions on
how to use the system. This
requires an internet connection.

Help > Help

Toon BoomHarmony on the
Web

Launches the Toon Boom
Harmony website, which
features a Support and
Community > Forum section.

Help > Toon Boom Harmony
on the Web

About
Use the About command to
access general information
about the software.

Windows/Linux: Help > About

MacOS X: Stage > About
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Command Action Access Methods

Customer Experience Improve-
ment Program

Harmony includes an optional
customer experience feature
whereby usage information is
collected and sent to Toon
Boom. The data does not con-
tain any personally identifiable
information and cannot be used
to identify you. The data will
consist of a basic hardware
description, a project summary
and usage information. This
information will only be used for
software improvement pur-
poses, as well as sharing the
information with third parties
for the same reason.

The customer experience
feature is enabled by default
but is voluntary. If you prefer
not to participate, you can opt
out when you first launch the
software, by using a global
preference, or by a command
line argument.

Help > Customer Experience
Improvement Program

Preferences
An important feature of Toon BoomHarmony is the Preferences dialog box. From here you can customize your
interface, tool behaviour and shortcuts. Throughout this guide, you are often required to go to the
Preferences dialog box to set parameters and options.

To learn about the different preferences available, refer to the Preferences Guide.

How to open the Preferences dialog box

1. Do one of the following:

‣ Windows/Linux: From the top menu, select Edit > Preferences.

‣ MacOS X: Select Stage > Preferences.

‣ Press Ctrl + U (Windows/Linux) or⌘ + U (MacOS X).
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Chapter 9: Interface
Knowing how to manage the Toon BoomHarmony interface helps you to work efficiently and organize your
workspace conveniently. There are a series of views and toolbars you can use as you perform different
operations. Usually, each person has a specific way of working in the interface and prefer particular views and
toolbars. In this chapter, you will learn about themain elements of the interface and how to manage them.

The Harmony interface is set to a dark theme by default. You have the option of switching to a light theme.

How to change the interface theme

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X) .

The Preferences dialog box opens.

2. Select theGeneral tab.

3. In theOptions section, deselect theUse Dark StyleSheet option to use the light theme.

4. Restart Harmony.
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This chapter is divided as follows:

Menus
Harmony contains three types of menus fromwhich you can access many commands and options:

TopMenu

The top menu contains most of the commands. Depending on the view you're working in and the element,
some commands are available and others are not. The top menu is always located at the very top of the
interface.

The top menu contains the following categories:

• File

• Edit

• View

• Play

• Insert

• Scene

• Drawing

• Animation

• Windows

• Help
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OnMacOS X, there is also a Stage category that contains the following commands:

• Preferences

• About

• Quit

View Menu

A view menu contains commands specifically related to that view.

To access a view menu, click theMenu button in the top-left corner of a view.

A view menu is available in the following views:

• Camera

• Colour

• Drawing

• Function

• Library

• Model

• Node Library

• Node

• Perspective

• Script Editor

• Side

• Timeline

• Top

• Xsheet

Quick Access Menu

Aquick access menu lets you open a list of the commands you will usemost often.

To access this menu, right-click anywhere in a view.
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Managing the Views
The Harmony interface is composed of different views, each one designed for a specific purpose. You can
modify the location of the views by adding a new view as a tab or as a window. You can also swap the location
of a view.

When a view is active, a red rectangle appears around the view. Keyboard shortcuts and top menu options are
associated with the active view. If a menu option is greyed out, it means it does not apply to the layer, drawing
or other type of selection or the option does not apply to the active view.

Workspacemodifications are automatically saved when you exit the application unless you deselected the
Automatically SaveWorkspace option in the Preferences dialog box.
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How to add a view

1. Do one of the following:

‣ Select the view youwant to add fromWindows > desired view.

‣ In the top-right corner of a view, click the Add View button and select a view from the list. You can
open several instances of the same view except for the Timeline, Tool Properties, Colour, and Drawing
views.

By default, the view appears as a tab.

How to dock a window

1. Drag a window by its tab and do one of the following:

‣ Drop the window onto other existing tabs to add it to the others.

‣ Drop the window above, below or beside an existing view. When you get close to the edge of a view, a
black rectangle with a blue background appears, indicating where the view will be inserted.
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How to close a view

1. Click the Close View button.

‣ If there are several tabs in the same view, press Shift and click the Close View button to close all
tabs at the same time.

How to swap views

1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another view’s tab.

2. When a blue rectangle outline appears showing an available location for the view, release the tab to
drop the view into position. One of three things will happen:
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• The view becomes a tabbed view.

• The view becomes a floating window.

• The view becomes a new docked view.

How to resize a view

1. Place the pointer on the edge of the view to resize.

2. When you see the Resizing icon, drag the side of the view to the desired size.
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How to temporarily hide a view

1. On the edge of the window youwant to hide, click theCollapse/Expand button.

The view is compressed and only the Collapse/Expand button is visible.

2. Click theCollapse/Expand button again to redisplay the view.

Managing the Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some of the views also
have their own toolbars which you canmove around. You can reposition the toolbars to suit your work style or
hide unused ones.

You can display or hide toolbars using themenus. The Toolbar menu only contains the View toolbars of the
views that are displayed in the workspace. As you show or hide views in your workspace, the Toolbar menu
updates.

The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be displayed. If
a toolbar is already displayed in the top area and you decide to display it in a view, the selected toolbar will
move from the top area to the view.

The View toolbars can be customized to contain your favourite tools and options. Using the Toolbar Manager
window, you can organize different toolbars to suit your working style.

If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you to
expand the toolbar so there are no nested toolsets in the toolbar. When you set this option, you will need to
close Harmony and restart it for the new interface to be displayed. A default set of tools will appear in the
toolbar. However, you can customize which tool icons appear in the toolbar to fit your work pattern.

If the default toolbar does not contain the tools you require, you can customize the toolbar.

Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar. This means
that you can change the default set of tools and replace the tools you use less frequently with ones usemore
often. This customizing is done through the Toolbar Manager.

How to show and hide a toolbar

1. From the top menu, selectWindows > Toolbars > the desired toolbar.
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‣ You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars, however,
are not available by right-clicking the toolbar area. You can access the toolbar of any open and active
view by right-clicking in the view's top area or theWindows menu.

How to resize a toolbar

1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.

2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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How tomove a toolbar

1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar area
or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release themouse but-
ton and drop the toolbar into position.

How to customize a view toolbar

1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a new but-
ton. You can also reorder the buttons. Make sure the button you right-click on is active.

2. From themenu, select Customize.
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The Toolbar Manager window opens.

3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and click the
Right Arrow  button to switch it to the Toolbar list.

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the Left
Arrow button to switch to the Available Tools list.
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5. To reorder the icons in your toolbar, select the command to bemoved from the Toolbar list and click
the Up or Down buttons to move it to the correct location.

6. Click OKwhen you are finished.

How to use enable the Flat Tool Toolbar preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X).

2. In the Preferences dialog box, select theGeneral tab.

3. Select the Flat Tool Toolbar option.

4. Click OK.

5. Save your work and close Harmony.

6. Restart Harmony.

The Tools toolbar no longer contains nested tools.

Managing the Workspace
The Harmony interface is composed of several views. You can customize your workspace to suit your working
style, save it as a new workspace, and load it from theWorkspace toolbar.

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the
Hand-Drawn Animation and Compositing workspaces. These display different views and toolbars. You can
access these workspaces, and any others you create, from theWindows menu and theWorkspace toolbar.
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By default, when youmodify the look of a workspace, it is automatically saved. If you prefer to keep your
workspaces as they are and only save themodifications when you really want to, youmust disable the
Automatically SaveWorkspace option.

TheWorkspaceManager allows you to modify, create, delete, rename and reorder you workspaces. You can
save your workspace as a new version to avoid over-writing the current one. If you do not want to modify the
current workspace, use theWorkspaceManager to create another one and thenmodify that one.

You can also restoremodified workspaces to their original default layout if you do not like the current
modifications or inadvertently closed somewindows.

How to load a workspace

1. Do one of the following:

‣ From the top menu, selectWindows >Workspace >Workspace.

‣ Select a workspace from theWorkspace toolbar.

How to open the Workspace Manager

1. Do one of the following:

‣ In theWorkspace toolbar, click the button.

‣ From the top menu, selectWindows >Workspace >Workspace Manager.

How to create a new workspace

1. Open theWorkspaceManager.
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2. In the AvailableWorkspaces list, select an existing workspace.

3. At the bottom of the AvailableWorkspaces list, click the Add button to add a workspace.

4. Select the new workspace that was created. Click Rename and give it a new name.

5. Select the new workspace and click the Right Arrow button to move it to theWorkspace toolbar.
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6. Click OK.

How to rename a workspace

1. Open theWorkspaceManager.

2. Choose the workspace to be renamed from the list.

3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit the
name.

4. Type in the new name of the workspace.

5. Press the Enter/Return key to validate the name.

6. Click OK.

How to disable the Automatically Save Workspace preference

1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (MacOS X) to
open the Preferences dialog box.

2. Select theGeneral tab.
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3. In theOptions section, deselect theAutomatically Save Workspace option.

4. Click OK.

The SaveWorkspace button appears in theWorkspace toolbar.

How to save a workspace manually

1. Do one of the following:

‣ In theWorkspace toolbar, click the SaveWorkspace button.

‣ You can also selectWindows >Workspace > Save Workspace.

How to save your workspace as a new version

1. From the top menu, selectWindows >Workspace > Save Workspace As.

The SaveWorkspace As dialog box opens.

2. Type in a workspace name and click OK.

How to delete a workspace

1. Open theWorkspaceManager.

2. In theWorkspaceManager, select the workspace to be deleted and click the Left Arrow button to
move it to the AvailableWorkspaces list.

3. Select the workspace from the AvailableWorkspaces list, then click the Delete button to delete the
workspace.

4. Click OK.

How to show a workspace

1. Open theWorkspaceManager.
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2. In the AvailableWorkspaces list, select the workspace to be displayed and click the Right Arrow but-
ton to move it to theWorkspace toolbar.

3. Click OK.

How to hide a workspace

1. Open theWorkspaceManager.

2. In theWorkspaceManager, select the workspace to be hidden and click the Left Arrow button to
move it to the AvailableWorkspaces list.

3. Click OK.

How to reorder workspaces

1. Open theWorkspaceManager.

2. In theWorkspace toolbar, select the workspace to be reordered and on the Up or Down buttons
to move it up or down.

3. Click OK.

How to restore the default workspaces

‣ From the top menu selectWindows > Restore Default Workspace.

View References
Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views available:

• Camera view

• Colour view

• Coordinates and Control Points view

• Drawing view

• Function view

• Layer Properties view

• Library view
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• Message Log view

• Model view

• Node Library view

• Node view

• Perspective view

• Script Editor views

• Side view

• Timeline view

• Tool Properties view

• Top view

• Xsheet view

Camera View

The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate, create
animation paths and see your results. You can also move through your symbol’s hierarchy.

The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the display
mode, or go back up your symbols hierarchy.
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Light Table

When you have a drawing layer or drawing selected, the Light Table button button allows you to fade the
colours of the other layers so you can see the current artwork better as you edit with a drawing tool. Note that
the light table does not work when using a layer editing tool, such as the Transform tool.

Current Drawing on Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is temporarily
displayed in front of all the other elements. The actual scene is not modified.

CameraMask

The Camera Mask button shows or hides a black mask around the scene’s frame to avoid seeing the
unnecessary artwork. This option is handy when you're animating and setting up the scene. It allows you to see
your scene’s composition better.

You can also access this from the top menu by selecting View > Show > CameraMask.
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Safe Area

The Safe Area button shows or hides the TV safety zone and the centre of the camera frame. The safe area
adapts to the scene resolution, as well as the safety zone and frame’s centre.

You can also access this feature from the top menu by selecting View > Show > Safe Area.

BBox Selection Style

When you select an object in the Camera view with the Transform tool, a bounding box always appears around
the object and the artwork is tinted in fuchsia, red or yellow. Enabling this option will only keep the bounding
box and remove the colour tint.

Outline LockedDrawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) are displayed as
wireframes.

Reset View

The Reset View
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button resets any panning, zooming or rotation done in the Camera view and returns the display to the initial
settings. You can also press Shift + M.

Zoom Menu

The Zoommenu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option. Click the drop-
down arrow and select a zoom level or press 1 and 2.

OpenGL View Mode

TheOpenGL View Mode button switches the Camera view to fast display, letting you see your animation play
in real time. TheOpenGL display requires less memory. The final look of your effects is not shown in theOpenGL
View Mode. Youmust switch to the Render View Mode to see your effects.
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Render View Mode

The Render View Mode button swithes the Camera view to a fully rendered display showing the final image
of the current frame. If a modification is done to your current frame or if youmove to a different frame, click the
Update Preview button to update the display if your preview does not update automatically.The Render View
Mode display lets you see the final look of your frames including effects and antialiasing. You cannot play back
your scene in Render View Mode. To see your scene fully rendered and to play it back, youmust press the
Render and Play button in the Playback toolbar.

Matte View Mode

TheMatte View Mode button switches the Camera view to a matte display showing the alpha channel of
the elements in your scene. The transparency level ranges from 0 to 100 percent. Zero percent is completely
transparent and represented by black and 100 percent is completely opaque and represented by white.
Everything in between these extremes has a transparency level somewhere between 1 and 99 percent and is
represented in various shades of grey.

‣ To access theMatte View mode, click on the Render View button and select Matte View
from the drop-downmenu.

DrawingName

TheDrawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.
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Tool Name

The Tool Name field displays the name of the selected tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s namewill be highlighted in red. You can temporarily override a tool by holding its
keyboard shortcut without the [Alt] key. For example, the Select tool shortcut is Alt + S. If you hold down the S
key, you will switch to the Select tool. When you release the key, you will return to the tool you were using.

Frame Number

The FrameNumber field displays the number of the current frame.

Selected Colour

The colour swatch displays the currently selected colour in the Colour view.

Camera Toolbar

The Camera View toolbar contains all the tools and options you can use in the Camera view to draw, animate or
set up the scene. The toolbar can be displayed or hidden by right-clicking on it and selecting or deselecting the
Camera View toolbar.

View Menu

The View menu contains all the tools and options that you can use in the Camera view to draw, animate or set up
the scene.

Editing StackMenu

The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a symbol. You
can click on the different names to go back up to the different parent symbols or the top/current project.

Colour View

The Colour view is where you create colours and palettes and import existing palettes into your project. The
Colour view is also necessary for drawing, painting and creating colour styling.
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The Colour view has two displaymodes:

• List mode

• Swatchmode

How to switch between the display modes

1. From the Colour menu, select Colours > Swatch Mode and do one of the following:

‣ Select the option to display the swatches.

‣ Deselect the option to display the colour list.

When you are painting on bitmap layers, the Colour view will look like the following. It contains a subset
of the tools available whenworking with vector layers.
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AddColour

The Add Colour button lets you add a new colour swatch to the bottom of your colour list.

Remove Colour

The Remove Colour button lets you delete the currently selected colour swatches. If the colour swatch is used
in your project, the Delete Colour dialog box will appear asking you to confirm the operation.

‣ Click OK to confirm the operation or Cancel to cancel it.

Zones painted with colour swatches which have been deleted will turn red, easily identifying them so you can
repaint themwith another colour swatch.
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Add Texture

The Add Texture button lets you add a bitmap colour swatch to your palette. You can load photos and
textures and paint your drawings with it. The bitmap imagemust be a .tga or .psd file format.

Set Current Brush Colour

The Set Current Brush Colour button let you set the currently selected colour swatch as the colour used by
the Brush tool. If you select a new colour in the Colour view while using the Brush tool, the Set Current
Brush Colour swatch will be updated.

Set Current Pencil Colour

The Set Current Pencil Colour button lets you set the currently selected colour swatch as the colour used
by the Pencil , Polyline , Ellipse , Rectangle and Line tools. If you select a new colour in the
Colour view while using any of these tools, the Set Current Pencil Colour swatch will be updated.

Set Current Paint Colour

The Set Current Paint Colour button lets you set the currently selected colour swatch as the colour used by
the Brush tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint
Colour swatch will be updated.
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Link/Unlink Three Colours

The Link/Unlink Three Colours button lets you link the Set Current Brush Colour, Set Current Pencil
Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the Colour view.

Show/Hide Palette List View

The Show/Hide Palette List View button lets you display the Palette List view in the Colour view. This option is for
the advanced user who wants to create colour palettes for their props and characters.

Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify which colour is
used to paint what part of your character or background.

Two colours can have the same name.

131



Chapter 9: Interface

Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour palettes
are composed of colour swatches. They can also be called colour pots. When you paint a zone with a colour
swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the zone will be updated along with
it. This allows you to modify your animation colours even after it is completely painted.

Colour Menu

The Colour menu lets you access commands related to the Colour view such as creating new palettes, adding
new colour swatches, and displaying the Tint panel.

Add Palette

The Add Palette button lets you add a new palette to the bottom of your palette list.

Remove Palette

The Remove Palette button lets you delete the currently selected palette. If the colour swatch is used in
your project, zones painted with colour swatches which have been deleted will turn red, easily identifying them
so you can repaint themwith another colour swatch.

Link Palette

The Link Palette button lets you access other palettes created in the project and link them to your scene.

Order Palette List

The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour styles), the
highest palette is the list will override its clone located lower in the list.
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Edit Palette Mode

In Server mode, the Edit PaletteMode button lets you get the rights to modify the palette. The palette files
can be locked to avoid accidentally modifying the palette.

Coordinates and Control Points View

Each time a keyframe or a control point is selected in the Camera, Timeline or Xsheet view, its parameters appear
in the Coordinates and Control Points view. You can also see the same information in the Coordinate and Control
Point toolbars.

You can edit keyframes and control point parameters, such as the position, continuity, bias, tension and lock-in-
time using the Coordinates and Control Point view.

Parameter Description

Name The name of the function curve to which the select point is linked.

Position

The coordinates in X, Y and Z of the selected point.

Separate: Modifies modify the X, Y and Z coordinates independently. When
this option is deselected, all three parameters are linked. If one is deleted, all
others will also be deleted.

Cumulative Z: When a layer is parented to other layers that aremoved forward
or backward on the Z-axis, the currently selected layer's Z position valuemay
not be accurate since its parent will also have an offset on the Z-axis. The Cumu-
lative Z value is a compilation of all the Z-axis offsets to give the real Z-axis off-
set value related to the (0,0) centre.
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Scale The width and height scale values of the selected point.

Separate Scale: Modifies the width and height values independently. When this
option is selected, the width and height are locked to the same value, forcing
the scale to be on a 1:1 ratio. If the option is deselected, you have the ability to
squash and stretch your layer at will.

Rotation Angle: The rotation angle value from the permanent pivot of the element.

Skew This is the skewing value.

Control Point and Keyframe

Frame: The frame at which the select point is set.

Locked in Time: This option indicates if the point is locked to a specific frame
(keyframe) or only locked to a specific position and the curve can flow through it
freely as other points are being added, moved, or adjusted (control point).

Stop-Motion Keyframe: When this option is selected, the keyframe is set as a
stop-motion point. This means that there is no automatic interpolation created
between the selected point and the next one. The layer will maintain its position
until the animation reaches the frame of the next point and will then jump to the
new position. Deselect this option to generate interpolation and get the layer
to progressively move to the next position.

• Continuity controls the smoothness of a transition between the segments joined by a point.

• Tension controls how sharply the path bends as it passes through a control point or keyframe.

• Bias controls the slope of the path so it flows towards one side of themotion point or the other.
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Drawing View

In Harmony, you can draw in the Drawing or Camera view. Although the two views are similar, when it comes to
drawing, there are some differences.

Only the selected drawing is displayed by default in the Drawing view. You can use features, such as the light
table to display the current drawing of all the enabled layers of your scene in washed-out colours, or theOnion
Skin to display the previous and next drawings of the currently selected drawing layer.
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Drawing Area

This is themain space in the Drawing view. It is where you draw and where the drawings are displayed.

Zoom Menu

The Zoommenu lets you enlarge or reduce the Camera or Drawing view display.

To make the camera frame size always match the size of your view, select the Fit to View option. Click the
drop-down arrow and select a zoom level or press 1 and 2.

DrawingName

TheDrawing Name field displays the name of the selected drawing, as well as the layer containing it. If the cell
does not contain any drawing, an Empty Cell text is shown in the field.

Tool Name

The Tool Name field displays the name of the selected tool. If you temporarily override a drawing tool using a
keyboard shortcut, the tool’s namewill be highlighted in red. You can temporarily override a tool by holding
its keyboard shortcut without the [Alt] key. For example, the Select tool shortcut is Alt + S. If you hold down
the S key, you will switch to the Select tool. When you release the key, you will return to the tool you were
using.

Frame Number

This field displays the current frame of the animation you are working on.

Cursor Coordinates

This indicates the position of the your pointer in the drawing area.

Colour Picker

The Colour Picker allows you to select a colour for drawing.
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Function View

The Function view lets you edit function curves and parameters. It is a visual graph for adding, removing, and
editing keyframes, as well as adjusting the velocity. The Function view allows you to displaymultiple functions in
the background as a reference.

How to display functions in the Function view

1. Open the Function view.

The Function view is blank until you select the layer containing the functions you want to display.

2. To display a function in the Function view, click on the layer containing the functions to adjust in the
Timeline view.

3. To select the functions you want to edit, select them in the Function list.

Parameter Description

Function List
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When selecting a layer in the Timeline view, all the corresponding functions are
displayed. Select all the functions you want to see and edit; hide the ones you
don't.

Display Toolbar

The Display toolbar allows you to modify how the editing area is displayed. You
can hide the grid, disable the synchronization with the current frame, reset the
zoom level and normalize the function display by stacking them one over the
other to compare them regardless of their value range.

Current Frame Displays the current scene frame.

Selected Keyframe Value Displays the value of the selected keyframe.

Display Advanced Parameter
Values

Displays the Projection, Bias, Tension and Continuity parameters to adjust the
curve around the selected keyframe.

Keyframe, Velocity and Inter-
polationOptions

This toolbar lets you add and delete keyframes, adjust the velocity curve, adjust
the segments to motion or stop-motion keyframes and set the velocity to cre-
ate steps instead of a constant progression.

Function Types
This toolbar lets you click on the different function types to enable or disable all
the listed functions of that type.

Value Scale
Displays the value range for the displayed editing area. It can be referenced to
know the value of a keyframe.

Selected Keyframe
The selected keyframe is displayed in red. When selected, the keyframe values
are displayed in the corresponding fields.

Bezier Handles
The Bezier handles let you adjust the ease in and ease out of each keyframe. The
more the handle is pulled out horizontally, the slower the animation will be. The
more the handle is pulled out vertically, the faster the animation will be.

Function Curve
The thin line going from keyframe to keyframe is the actual curve. The section of
a curve located between two keyframes is called a segment.

Frame Scale
The Frame Scale displays the frame range for the displayed editing area. It can
be referenced to know the current frame of a keyframe.

Layer Properties Editor

Each layer has its own set of properties that can bemodified, including effect and peg layers. Display the Layer
Properties editor if you want to modify some of the layer’s properties such as the name or the antialiasing
quality. You can display the editor by double-clicking a layer in the Timeline view or a node in theNode view.
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Library View

The Library view is used to store elements such as animation, drawings, backgrounds and puppets to reuse in
different projects. You can also use the Library view to create and store symbols.

To reuse an element from another project, youmust create a template from your drawings. A template is a mini
scene that you import in other projects. A template has no link to the original scene. When you create a template,
the full content of your selection is copied in the template.

You also have the possibility to create symbols. These can be used as drawing containers when you are creating
puppets so you can store different mouth shapes or hands to use while animating. Note that drawing layers
already have this capability without being a symbol. You can also use symbols when you are building props, such
as a skateboard that has a wheel you want to reuse for the four skateboard wheels.
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Library Menu

The Librarymenu lets you access commands related to the Library view, importing .swf movies and Illustrator
files, add a new folder, and refresh the library’s content.

Preview Window

The Preview window lets you see the content of the currently selected template or symbol in the
Template/Symbol list.

Preview Playback

The Preview Playback button lets you play back the content of the selected template or symbol if it contains
more than one frame. Press the Play button to play back the preview.

Library Folder List

The Library Folder List displays all the folders linked to the Library view. There are two default folders:

• Symbols: This folder is the only folder containing symbols. You can organize it by adding subfolders
inside.

• Stage Library: This is a default folder found on the hard drive in your user documents. This folder can
contain templates, but no symbols.

You can link new library folders to the Library view and organize themwith subfolders.
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Template/Symbol List

The Template/Symbol list displays the templates or symbols contained in the selected library folder. You can
display the templates by right-clicking the symbols’ thumbnails and selecting View > Thumbnails.

Message Log View

TheMessage log view displays information gathered during a render task, such as which frames and at what time
they were each rendered. The view also contains a list of the colour recovery operations.

Model View

Once you have a fully painted drawing, you can use it as a colour model and load it in theModel view. This
drawing can be used and loaded in any of your Harmony scenes.

Once a drawing is loaded in theModel view, you can use the Dropper  tool to select a colour from themodel
and use it to paint in the Camera or Drawing view without having to pick the colour from the colour palette.
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Node Library View

If you need to add new effects and other nodes to theNode view, you will need to get them from theNode
Library view.

When you create a new project in Harmony, the default node system that appears in the Node view looks
similar to the one below.
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Node Library View Toolbar

In the Node Library View toolbar, you can change how the nodes are displayed. You can display nodes as icons,
as a textual list or as icons with their names and a description.
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Node Categories

TheNode Library view is conveniently divided into several categories:

Category Description

3D Nodes related to working with 3D models within Harmony.

Combine Nodes for combining images.

Deformation
Nodes needed for building a deformation chain, as well as advanced effects
such as Fold and Auto Muscle. The Deformation category is divided into the
Bone and Distort categories.

Favorites
Nodes most commonly used. To add nodes to the Favorites category, select
any node from any other section and drag it onto the Favorites category.

Filter
Effect nodes, such as blurs. This category is subdivided into the following cat-
egories: Adjust, Blur, Colour Correct, Isolate and Stylize.

Generator Nodes that create an image, such as a gradient or colour.

Group Nodes for grouping, like Group nodes andMulti-Port-In nodes.

Misc Various nodes including External, Note, Script and Visibility.

Move
Nodes for changing elements over time, like Peg nodes, as well as certain
transformations.

Output
Output (Export) nodes such as Crop, Display, Scale-Output andWrite
nodes.

Particle
Nodes needed to construct complex particle systems. This category includes
a series of examples of particle effects and is subdivided into the following
categories: Basic, Examples andModifier.

Plugins Plugin nodes.

Shading Nodes for light shading.
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How to display all the nodes

1. If a category is selected and youwant to see all the nodes available in the library, in the Node Library view,
place your cursor in the Node Search field.

TheNode Library view displays all the nodes.

Adding, Removing and Renaming Categories

Customizing the categories is a great way to organize the nodes according to how you like to work and the
nodes you usemost often. You can easily add categories and subcategories, remove categories you don't use,
and rename categories.

How to add a category

1. Do one of the following:

‣ To create a new main category, click in the Node Search field.

‣ To create a subcategory, select a category.

2. Do one of the following:

‣ From theNode Librarymenu, select New Category.

‣ Right-click in the category area and select New Category.

TheNew Category window displays.

3. In the New Category window, type in the name of a new category and click OK.

145



Chapter 9: Interface

The new category appears in the Category list. Now you can add nodes to your new category—see
Adding and Removing Nodes on page 147.

How to remove categories

1. From the Category list, select a category to remove.

2. Do one of the following:

‣ From theNode Librarymenu, select Remove Category.

‣ Right-click in the category area and select Remove Category.

The Confirm Remove Category window displays.

3. Click Yes.

How to rename categories

1. From the Category list, select a category to rename.

2. Do one of the following:

‣ From theNode Librarymenu, select Rename Category.

‣ Right-click in the category area and select Rename Category.

The Confirm RenameCategory window displays.

3. Type in a new name for the category and click OK.
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Adding and Removing Nodes

Once you've created a category, you can add nodes to it for easy access. Later on, you can go back and remove
any nodes you no longer use. You can only add and remove nodes from a category you created.

When you add a node to a new category, it is essentially a copy of the node. The node in its default location
remains there. You cannot delete nodes from their default categories or move them.

How to add nodes

1. Select a node from any category and drag it to a category you created.

A copy of the selected node is added to your new category.

How to remove nodes

1. Select a node from a category you created.

NOTE: Nodes from the default categories cannot be removed.

2. Do one of the following:

‣ From theNode Librarymenu, select Remove Node.

‣ Right-click in the category area and select Remove Node.

‣ Press Delete.

The node is removed from the category.

Searching for Nodes, Categories and Descriptions

Sometimes it's faster to type in the name of a node instead of looking through all the categories. You can also
search for category names or descriptions as well. Once you type in the name of a node, description or category
in the Node Search tool, it is displayed in the library. Sometimes the result of a node search is in one or more
categories for convenience.
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How to search for nodes

1. In the Node Library, place your cursor in the Node Search field.

TheNode Library view displays all the nodes.

2. Type in the name of a node, category or description.

Depending on how you are viewing the nodes, the Node Library view displays the node, categories
and/or description you typed in.

3. To return to displaying all the nodes, place your cursor in the Node Search field again and delete the
node name in the Search field.

Node View

In the Node view, you can connect effects and compositing nodes to form a network, also known as a node
system. This view is very useful for rigging puppets, creating advanced effects and having a clear view of
complex scenes. The organization and order of the nodes determines the flow of data during the compositing
process and how your animation elements will be composited.
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Symbol Stack

When entering symbols, the Symbol Stack lets you navigate back to the top and see the hierarchy of the symbol in
which you are working.

Node System

Themain area of the Node view is where you can add and organize different nodes to represent a scene.

Navigator

TheNavigator view lets you pan the visible area to move quickly through extensive node sets.

Search Toolbar

The Search toolbar lets you find and match a node in the project. The search is not case-sensitive. Once you have
entered characters in the search field, press Enter/Return to validate and find the pattern in the node names. If
successful, the node is selected and centred in the view. If many instances are found, use the Previous and Next
buttons to cycle through each node.
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GroupNavigation

When entering a group, the Group Navigation allows you to navigate back to the top and see the hierarchy of
the group in which you are.

Perspective View

The Perspective view is used during scene setup. It allows you to see a multiplane scene’s orientation. The
Perspective view is similar to a 3D display, as it lets you rotate the scene through all possible angles to
understand the spacing between the elements. You can also position and rotate your layers and the camera
inside the 3D display to achieve some 3D setup and camera moves.

1. The red circle rotates the view on its X axis.
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2. The green circle rotates the view on its Y axis.

3. The blue circle rotates the view on its Z axis.

4. This is a perspective grid reference.

5. The axis reference arrows let youmaintain your orientation when navigating in the Perspective view.

6. There are three view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides camera frame in the Perspective view.

‣ Reset View: Resets the pan, rotation, and zoom of the Perspective view.

‣ Reset Rotation: Resets the rotation of the Perspective view.

7. This field displays the current zoom level in the Perspective view. You can use the Zoom level drop-down
menu to select a specific zoom level from the list. Zoom levels from 2.5% to 6400% are available; you can
also select Fit To View to automatically use a zoom level that lets you see all your scene layers and inform-
ation in the Perspective view at once.

8. This field displays the currently selected layer and drawing name.

9. This field displays the currently selected tool.

10. This field displays the currently selected frame of your animation.

11. This field displays the currently selected colour in the palette.

How to rotate a scene in the Perspective view

1. In the Tools toolbar, select the Rotate View tool.

‣ Click in the view, and drag the cursor around to rotate the view.

‣ Press and hold Ctrl + Alt (Windows/Linux) or⌘ + Alt (MacOS X) and click and drag to rotate the view
one axis at a time.

Script Editor View

Qt Script provides access to many of the functions supported in the interface. WithQt Script, you can automate a
number of Harmony functions to speed the completion of various repetitive tasks. The Script Editor view allows
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you to edit existing scripts and create new ones. Refer to the Scripting guide to learnmore about scripting
with Harmony.

Script List

On the left side of the Script Editor view, all existing script files are listed and can bemodified in this view. The
script format is JavaScript. Click on a file to display its content in the Script Content window of the view.

Script Content

On the right side of the Script Editor view, the contents of the selected script are displayed and can be edited.

Search Toolbar

The Search toolbar allows you to search a string within the selected script content. You can use the Previous
and Next buttons to navigate through the results.

Verify

This function verifies the syntax of the currently displayed script and lists any error found.
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Save

Once you are satisfied with themodifications made to the script, click Save Changes to save themodifications.

Side View

The Side view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see a
scene’s stage from the side. This lets the camera cone and spacing between the elements to be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in the
camera cone.

2. The camera cone represents the camera’s position and field-of-view (FOV).

3. The axis reference arrows let youmaintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoommenu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that lets
you see all of the scene layers and information in the Perspective view at once.
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6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Timeline View

To set your animation timing, you will mostly work with the Timeline and Xsheet views. It's extremely useful to
become familiar with the Timeline view, how it works, and its interface.

The Timeline view is themain view used when adjusting the timing of drawings, adding keyframes and ordering
layers. The Timeline view displays layers, sounds, keyframe values, scene length, layer names, drawings,
keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements in their
simplest form. You can also see the layers and their names, as well as the drawing’s exposure. The drawing
name is displayed when you place your pointer over the drawing’s exposure.
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Enable/Disable All

The Enable/Disable All button lets you show or hide layers.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet view. When a
column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

To disable a layer, click the layer's Enable/Disable All button or press D.

To enable a layer, click the layer's Enable/Disable All button or press A.

Solo

The Solo button lets you view drawing or sound layers in the Camera view. You can enable this mode on
multiple layers. When the Solemode button is deselected, everything is visible in the Camera view. When one or
more layers are soloed, only those layers appear in the Camera view.
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Onion Skin

TheOnion Skin button enables theOnion Skin option on a particular layer. If you want to see the previous
and next frames of a specific layer, go to the Timeline view and click theOnion Skin button for that particular
layer. Blue arrows appear on both sides of the play head. Drag the blue arrows to addmore frames to the
onion skin display.

To activate the general Onion Skin preview, in the Tools toolbar, click theOnion Skin button.

Lock/Unlock Layer

The Lock/Unlock Layer button lets you prevent the selection or editing of a layer in the Camera view.
To select some of the layers without selecting others, in the Timeline view, lock the layers you do not want to
select. When a layer is locked, its name is displayed in red.

In the top menu, there is a series of locking options. Select Animation > Lock > select one of the following:

• Lock: Locks the currently selected element.

• Unlock: Unlocks the currently selected element.

• Lock All: Locks all the elements in the Camera view.

• Unlock All: Unlocks all the elements in the Camera view.

• Lock All Others: Locks all the elements in the Camera view except the currently selected one.

You can display the locked drawings as outlines in the Camera view to quickly find out which drawings are
locked.
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How to display locked drawings as outline

1. In the Camera View bottom toolbar, enabled theOutline Locked Drawings option.

2. You can also set this option as a permanent preference. From the top menu, select Edit > Preferences
(Windows/Linux) or Stage > Preferences (MacOS X).

3. In the Preferences dialog box, select theCamera tab.

4. In the Tools section, select the Show LockedDrawings As Outlines option.

Change Track Colour

The Change Track Colour button lets you change the colour of the exposed frames; this helps you to quickly
locate a layer in the Timeline view. Click the Change Track Colour button to open the Select Colour window
and choose a new colour. You canmodify the colour for any type of layer, such as group, peg, drawing, and
effects.
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Add Layers

The Add Layers button lets you add new layers to the Timeline view. When you click the Add Layers
button, a menu appears displaying the layer types available. You can add several different types of layers:

• Camera

• Deformation

• Drawing

• Generator

• Group

• Transformation

• Effects

• Sound

Delete Layers

TheDelete Layers button lets you delete the currently selected layers in the Timeline view.

AddDrawing Layer

The Add Drawing Layer button lets you automatically add a new drawing layer to the Timeline view. By
default, the layer is named Drawing.

Add Peg

The Add Peg button lets you add a peg layer to the timeline. If several layers are selected, a peg is added
and parented to each layer.

Expand/Collapse

The Expand/Collapse button is used to display the children layers of a parent layer. Once a layer is
parented to another layer, it is indented to the right and the Collapse/Expand Children button appears on the
parent layer allowing you to show or hide the child layer.
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Parameters

The Parameters section lets you add, remove or modify a keyframe at the current frame. You can show or hide
the Parameters section by clicking the Show/Hide Parameters button.

Icon Tool Name Tool

Add Keyframe Adds a keyframe at the current frame.

Delete Keyframe
Removes an existing keyframe at the current
frame.

Hand Cursor

Lets you change the current keyframe or draw-
ing exposure. When you hover the cursor over
the value, the hand cursor appears. Drag left or
right to change the value. Or double-click on
the keyframe value and enter a new value.

Previous Keyframe
Lets you navigate through existing keyframes.

Next Keyframe

Show FunctionMenu
Displays the Functionmenuwhere you can link a
layer to an existing function or create a new
function—see Function Curves on page 1.

Current Drawing and Frame

The highlighted drawing represents the drawing currently displayed. The red play head represents the current
frame displayed andmarked in the Playback toolbar. You canmove the play head to the left or right to scrub
through frames and update the Camera view.
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Keyframe

Ablack or red square is displayed in the Timeline view when a keyframe exists. You can select these keyframes
and drag themwherever you want on the timeline. You can also copy, cut, and delete them.

NOTE: To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select the
keyframe to be deleted and then select Animation > Delete Keyframe from the top menu or press F7.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be displayed.

Split

The Split button lets you split the Timeline view in two sections, allowing you to see two different portions
of the Timeline view. This way, if your scene length is very long, you can see the beginning and the end at the
same time.

Drawing Exposure

In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is exposed for
several frames, the block is extended. When a second drawing is exposed, a new grey block is displayed.

The exposure’s colour can be changed. To pick a new colour, click the Change Track Colour button in the
corresponding layer.

View Modes

The View Modes button lets you streamline the process of working with elements in the Timeline view.
There are three different view modes you can choose to work in. With eachmode you select, certain elements
may or may not be visible in the Timeline view. Depending on your workflow, this can be useful for quickly
hiding elements when youwant to focus on specific ones. To select a view mode, use the drop-downmenu in
the bottom-left corner of the Timeline view.
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Show/Hide Additional Links

The Show/Hide Additional Links button lets you display links associated with a layer. For example, if you
connect a mask to more than one effect such as a Tone and a Highlight, you can see these connections in the
Additional Links section, as well as links to composite nodes.

Zoom

The Zoom tool increases or reduces the width of the frames in the Timeline view. Move the slider right to increase
the width or left to reduce it. You can also press 1 and 2. Reset the zoom by click the Reset Zoom button.

Show/Hide Functions

The Show/Hide Functions button lets you display the functions embedded in each layer. The functions are the
different coordinates and values used to record a layer’s parameters at each frame. This information is stored on
the function curves using keyframes.

161



Chapter 9: Interface

Tool Properties View

The Tool Properties view contains themost common options and operations related to the currently selected
tool. When you select a tool from the Tools toolbar, the Tool Properties view updates.

For example, if you choose the Select tool, the Tool Properties view will display the options and operations
related to it, such as Snap to Contour, Apply to All Drawings, Flip Horizontal, and Flatten.

Top View

The Top view is used mainly for multiplane scenes and to position elements in 3D space. It allows you to see
the scene’s stage from above. This lets the camera cone and the spacing between the elements be seen.

1. A thumbnail of each drawing layer in the scene. The order of the thumbnail images is based on each ele-
ment’s FB position in the scene space. You can see a representation of the FB position of each layer in
the camera cone.
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2. The camera cone represents the camera’s position and field-of-view (FOV).

3. The axis reference arrows let youmaintain your orientation when navigating in the Perspective view.

4. There are two view option buttons displayed in the lower-left corner of the view.

‣ Show/Hide Camera: Shows or hides the camera frame in the Perspective view.

‣ Reset View: Resets the pan, rotation and zoom of the Perspective view.

5. This field displays the current zoom level in the Perspective view. You can use the Zoommenu to select a
zoom level from 2.5% to 6400%. You can also select Fit To View to automatically use a zoom level that lets
you see all of the scene layers and information in the Perspective view at once.

6. Displays the currently selected layer and drawing name.

7. Displays the currently selected tool.

8. Displays the currently selected frame of your animation.

9. Displays the currently selected colour in the palette.

Xsheet View

The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows the
drawing’s name. You can also see the functions and keyframes of themotion paths in the Xsheet’s function
columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black squares in the
Timeline view. The Xsheet view contains more detail than the Timeline view, and is faster and easier to read.
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1. Xsheet Main Section

The Xsheet view has three sections. By default, only themain section is visible. It displays the drawing layers,
also known as drawing columns.
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When using advanced compositing and animation techniques, unconnected functions (motion paths) also appear
in themain section. Unconnected functions mean that somemotion paths are not attached to any particular layer.

When you reconnect functions to a layer, they are still visible in themain section.

2. Functions Section

The Functions section is used for more advanced techniques. This section displays the functions (paths) related to
the selected layer in the Timeline view. By default, the Functions section is hidden.

How to display the Functions section

1. In the Xsheet view, click the Expand button located on the right side of themain section. Click on the same
button to collapse it. You can also use the Show Column List
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button in the Xsheet View toolbar. If you select a drawing column in themain section of the Xsheet
view, the function columns will not be displayed. Youmust select the layer from the Timeline view.

. Column List Section

The Column List section allows you to show and hide columns in the Xsheet view. When you hide a layer in the
Xsheet view, it is also disabled in the Timeline view.

You can use the Column List to hide individual columns or hide an entire column type (drawing or function) from
the Xsheet view. By default, the Functions section is hidden.

How to display the Column List section

1. In the Xsheet view, click the Expand button on the right side of themain section to show the Functions
section. Click on the same button to collapse it. You can also use the Show Column List button in
the Xsheet toolbar.

‣ In Harmony, you can also go to the Xsheet view menu and select View > Show Column List.

166



Harmony 12.1 Premium - Fundamentals Guide (Server)

2. Click the Expand button on the right side of the Functions section to display the Column List section.

Xsheet Toolbar

The Xsheet view has its own toolbar where you can find themost common features. This toolbar is displayed by
default. If you do not see it, selectWindows > Toolbars > Xsheet View.

The Xsheet view must be part of your workspace in order to display its toolbar.

Column Header

Each column available in the Xsheet view has a header displaying the column’s name. The column’s name is the
same as the corresponding timeline layer. If you rename one or the other, they will both be renamed.

A quick access menu is available when you right-click. This menu contains the command affecting an entire column
such as renaming, changing the default colour, or deleting a column.

The tooltip that appears when you hover at the top of each Xsheet column shows the folder path to the source
drawings for that column.
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In Harmony, the column header shows the layer’s name and the name of the drawing folder to which it is
linked. If the name of the layer is the same as the drawing folder, the drawing folder’s namewill not be
displayed. For example; when you link a Timing column to a certain element (and thereby the Element’s folder).
To modify the name of the element folder independently from the column and layer name, youmust select the
Advanced Element Mode option preference in the Advanced tab of the Preferences dialog box.

Current Drawing

Adrawing selected in dark red indicates that the drawing is currently displayed in the Drawing and Camera
views. The current drawing selection is not linked to the drawing displayed in the Camera view since drawings
from each visible layer are displayed at once.

Current Frame

The darker frame appearing in the Xsheet view represents the current frame.

Drawing Exposure

In the drawing columns, you can see the drawing names and their exposure. You can use any alphanumeric
symbol to name your drawing. When a drawing is exposed over more than one cell, a vertical black line is
displayed to indicate the continuity of the exposure. When there is no drawing in a cell, the cell will be blank.
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Frame Numbers

On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These read vertically
instead of being displayed horizontally as they are in the Timeline view.

• To go to a particular frame, click the frame number.

• To select an entire range of frames, click and drag a selection downwards.

Current Frame Display

At the bottom-right of the Xsheet view, you can see the current frame number, as well as the column containing
the drawing currently displayed in the Drawing view.
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Functions Column

The functions columns are displayed in the Functions section of the Xsheet view. They represent themotion
and rotation you applied to a drawing layer. Only the function columns related to the selected layer are
displayed.

A function column can also be related to an effect. Selecting the effect layer shows you the corresponding
function column in the Xsheet view.

The function columns display the position value or effect value on each cell. If there is a keyframe on a cell, a
black square is displayed. Holding the same value for several frames displays a vertical black line.

Increase/Decrease Exposure

You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down arrows in
the Increase/Decrease Exposure field.

Overwrite/Insert Modes

TheOverwrite/Insert button allows you to decide the way the values are inserted into the Xsheet.

Toolbar References
Harmony has several toolbars. There are two types of toolbars: the top toolbars available at the top of the
interface and the view toolbars in individual windows. View toolbars are only shown if the particular view is
displayed in the workspace. This is a complete list of the toolbars available in Harmony.

Top Toolbars

AdvancedAnimation Toolbar

The Advanced Animation toolbar contains tools to position and animate layers. The Scale, Translate and
Rotate tools can be used to reposition the permanent pivot position of a layer. Unlike the Transform tool, each
tool in the Advanced Animation toolbar performs a single operation, either rotate, scale, translate or scale in
relation to the camera distance.
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Art Layer

Adrawing is composed of two layers, a line layer and a colour layer. The colour layer is always placed under the
line layer. These layers are accessible in the Drawing or Camera view (using drawing tools). When you view the
final drawing, you will see the final composition of the lines and colours, not two separate layers.

You can draw and paint in all layers. If you prefer to work in a single layer, everything can be done in the Line Art
layer.

You can change your preferences to enable the advanced use of layers and have access to four layers instead of
two:

• Overlay

• Line Art

• Colour Art

• Underlay

How to enable the Support Overlay andUnderlay Arts option

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( MacOS X ).

2. In the Preferences panel, select theAdvanced tab.

3. In the Advanced Options section, select the Support Overlay andUnderlay Arts option.

4. Click OK.

Art Layer

Adrawing is composed of two layers, a line layer and a colour layer. The colour layer is always placed under the
line layer. These layers are accessible in the Drawing or Camera view (using drawing tools). When you view the
final drawing, you will see the final composition of the lines and colours, not two separate layers.

You can draw and paint in all layers. If you prefer to work in a single layer, everything can be done in the Line Art
layer.

You can change your preferences to enable the advanced use of layers and have access to four layers instead of
two:

• Overlay

• Line Art

• Colour Art

• Underlay

How to enable the Support Overlay andUnderlay Arts option

1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( MacOS X ).

2. In the Preferences panel, select theAdvanced tab.

3. In the Advanced Options section, select the Support Overlay andUnderlay Arts option.

4. Click OK.

Coordinate Toolbar

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear in
the Coordinate toolbar. You can edit keyframes and control point parameters, such as the position, scale and
rotation coordinates.

Control Point Toolbar

Each time you select a keyframe or control point in the Camera, Timeline or Xsheet view, its parameters appear in
the Control Points toolbar. You can edit keyframes and control point parameters, such as the continuity, bias,
tension and lock-in-time.

Deformation Toolbar

TheDeformation toolbar contains the various tools and options used to create a deformation rig. This toolbar is
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displayed in the default interface.

By default, the Deformation toolbar only contains the essential options. If you right-click on the toolbar and
select Customize, you can add additional buttons.

Display Toolbar

TheDisplay toolbar lets you select the different Display nodes available in the node system.

When your scene does not have a Display node, it is automatically set to Display All which uses the Timeline
view ordering and shows floating nodes from theNode view. You can also set your scene to use Display All
using the Display toolbar.

NOTE: If you try to add a peg or other transformation layer in the Timeline view without having a layer selected, an
error message will display. Make sure to change to Display All. The peg layer will be floating in the Node view and
will not be visible in the Timeline view. The Timeline view shows only layers that are connected to the Composite
node.

If you switch to Display All, you run the risk of not realizing when you have floating nodes that are not connected to
your composite. For this reason, it is not recommended to work in Display All mode.

Easy Flipping Toolbar

The Easy Flipping toolbar lets you rapidly flip through drawings in the Drawing view as is done with paper
drawings.
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Edit Toolbar

The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These options can also
be found in the Edit menu.

File Toolbar

The File toolbar contains the common file operations such as New, Save and Open. These options can also be
found in the File menu.

Xsheet Toolbar

The Xsheet toolbar contains the common timing operations such as Add Column, Delete Column, Clone Column,
and so on. These options can also be found in the top menu.

Flip Toolbar

The Flip toolbar lets you determine the type of drawing to include in your flipping selection. You can flip through
the key, breakdown or in-between drawings individually, or view a combination.

Mark Drawing Toolbar

TheMark Drawing toolbar lets you identify drawings such as Key, Breakdown and In-between. The drawing
Identification feature can help the animator stay well organized and save timewhen identifying key, breakdown or
in-between drawings in the Xsheet and Timeline views.

Onion Skin Toolbar

When designing or animating, it is useful to be able to see your previous drawings. TheOnion Skin tool is used to
preview the previous and subsequent drawings. By default, the previous drawings will appear with a shade of red
and the next drawings will be displayed with a shade of green, but you can change the display options in the
Preferences dialog box. In theOnion Skin toolbar, you can select what type of drawing youwant to display in your
onion skin display.

173



Chapter 9: Interface

Playback Toolbar

The Playback toolbar lets you play back animation and sound. Use it to scrub the sound to create your lip-sync,
loop the playback, navigate through frames, and change the playback range and speed.

Name Button Description

Play

Plays and stops the animation.

You can also select Play > Play Scene
Forward or Stop.

Render and Play
Creates a render of your scene to play back
the final result including the effects.

Loop

Repeatedly plays back your animation
indefinitely.

You can also select Play > Loop.

Sound
Enables sound in the playback.

You can also select Play > Enable Sound.

Sound Scrubbing

Enables sound scrubbing in the playback.

You can also select Play > Enable Sound
Scrubbing.

Jog Frames
Lets you scroll through the playback’s
frames.

Lets you change the playback frame range by
entering new values in the Start and Stop
fields. You can also click on the Start and
Stop words to set the start or end frame at
the current frame.

FPS
Lets you enter a new value to change the
speed of the playback.

Scripting Toolbar

The Scripting toolbar lets you import and access the scripts created to automate actions and operations.

Tools Toolbar
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The Tools toolbar contains all of themain tools you will use while working in Harmony. In the default workspace,
you will find this toolbar on the left-most side of the interface.

Tool Presets Toolbar

The Tool Presets toolbar lets you create new tool presets and manage them.

Workspace Toolbar

The first time you open Harmony, the default workspace is loaded. Other workspaces are available such as the
Hand-Drawn Animation and Compositing workspaces; these display different views and toolbars. You can access
these workspaces and any you create, from theWindows menu and theWorkspace toolbar.

View Toolbars

Here is a list of the toolbars available in the Harmony views:

• Camera Toolbar

• Drawing Toolbar

• Layer Toolbar

• Library Toolbar

• Model Toolbar

• Node Toolbar

• Script Editor Toolbar

• Timeline Toolbar

• Xsheet Toolbar

Interface Navigation
Toon BoomHarmony lets you zoom in, zoom out, rotate, pan and reset views for easy navigation of the interface.

Command Action Access Methods

Zoom In Zooms in the view.

View > Zoom In

Press 2 or roll themouse
wheel up.

In the Timeline view, roll the
mouse wheel up.

ZoomOut Zooms out the view.
View > Zoom Out

Press 1 or roll themouse

175



Chapter 9: Interface

wheel down.

In the Timeline view, roll the
mouse wheel down

Zoom In or Out Zooms in or out of the view.
Roll themiddlemouse button
up or down.

Pan Moves parallel to the view.

Hold down the Spacebar and
drag n in the direction in
which you want to pan the
view.

Recenter view Recenters the view on the pointer. Press N

Reset Pan
Resets the view’s pan to its default
position.

View > Reset Pan

Press Shift + N

Reset View Resets the view to its default position.

View > Reset View

Press Shift + M

Reset Rotation
Resets the view’s rotation to its default
position.

View > Reset Rotation

Press Shift + X

Reset Zoom
Resets the view’s zoom to its default
position.

View > Reset Zoom

Toggle Full Screen

Enlarges the selected view to full
screen which is done in three stages.

First, the selected view enlarges to the
maximumwidth or height, but keeps
the tool views such as Colour or Tool
Properties view.

Second, the view enlarges to full
screen.

Third, the view returns to its original
size.

View > Toggle Full Screen

Press Ctrl + F
(Windows/Linux) or⌘ + F
(MacOS X)

Rotate 30 CW Rotates the Camera view 30 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 30 CCW
Rotates the Camera view 30 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

ToggleQuick Close-up

Use theMagnifier tool to quickly
center on themouse position and
zoom in to a pre-defined value such as
4X. Then you can zoom out again. Hold
the Shift key and press Z to zoom in
and back out again. Replace the Reset
Zoom by pressing Shift +.
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The area where you zoom in or out is
dependent on the pointer location in
the Camera view. If you zoom in and
thenmove the pointer to a different
location when you zoom out themouse
will be centered on that location.

Using the Play Menu to Navigate

From the top menu, you can select any of the following commands from the Playmenu to navigate around the
interface.

Command Description

Start Frame Lets you set the frame onwhich playback will start.

End Frame Lets you set the frame onwhich playback will end.

First Frame Jump to the first frame. You can also press <.

Previous Frame
Jumps to the frame before the frame currently selected in the Timeline view.
You can also press the comma (,) key.

Next Frame
Jumps to the frame after the currently selected frame in the Timeline view. You
can also press the period (.) key.

Last Frame Jumps to the last frame. You can also press >.

Go to Frame

Opens theGo to Framewindow in which you can enter the number of the frame
youwant to display.

You can also use theGo button, which you can add to the Timeline toolbar
through the Toolbar Manager. Open theGo to Frame dialog box and enter the
frame number to jump to.

Enable Playback Plays back your animation from the Top, Side, or Perspective views.

Zoom Tool

The Zoom tool in the Tools toolbar lets you zoom in and zoom out of the Camera or Drawing view.

• The keyboard shortcuts are 1 and 2.

• When you're in Zoom Inmode, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.
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Parameter Button Description

Zoom Tool Options
Zoom In Zooms in

ZoomOut Zooms out

Operations

Perform Zoom In
Zoom in the Camera or Drawing view.

The keyboard shortcut is 2.

Perform ZoomOut
Zoom out the Camera or Drawing view.

The keyboard shortcut is 1.

Reset Zoom Restores the current zoom level to 100%.

Reset View
Restores the original display by resetting
any pan, rotation or zoom actions.

Glossary

alpha channel

An image channel that carries transparency information. An image already
has three channels: red, green and blue (RGB). The alpha channel is the
fourth channel (RGBA). Thematte, or the transparency information, is
stored in this fourth channel. An imagewithout an alpha channel is always
opaque.

animatic

Amovie with sound that is developed from the storyboard. The storyboard
panel is exposed for the duration of the scene and at times, the characters
are placed on a trajectory to indicatemotion. The camera moves are also
animated. The animatic is used to determine the rhythm of a project and
provides a good overview of the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures or
frames.

anime An animation style known for its sinister and dark feel; popular in Japan.

arc
Action rarely occurs in a straight-forward manner; rather it typically unfolds
in what storytellers refer to as an arc. The purpose of a story arc is to move
a character or situation from one state or scenario to the next.

aspect ratio
The relationship between the width and height dimensions for any scene,
frame or film format. Television ratio is 4:3 and widescreen ratio is 16:9.

auto-feed
An automated method of feeding drawings into a scanner in whichmultiple
drawings are stacked into a sheet feeder. When the scanner is activated,
the drawings are scanned consecutively, without further user intervention.

automatic lip-sync detection
Automatically mapping drawings in an element to themouth chart
generated for a sound. This can save timewhen lip-syncing a voice track.

axis

An imaginary line around which an object rotates.

For 2D graphics, there are two axes: X (horizontal and Y (vertical).

For 3D graphics, there are three axes: X (horizontal, Y (vertical) and Z
(depth).
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background
The part of a scene that is farthest to the rear. The background is the
artwork, or decor, against which the animation takes place.

Bézier
Amethod of defining curved lines invented by Frenchmathematician Pierre
Bézier. A Bézier curve is a mathematical or parametric curve. Bézier curves
use at least three points to define a curve.

bitmap
An image composed of pixels with a single resolution (size). If it is enlarged
too much, it will lose definition and pixels will begin to appear. This is
known as pixelation.

breakdown

In cut-out animation, breakdown is the action of breaking a character into
pieces to create a puppet with articulations. To break down a character,
the artist cuts parts, such as the hands and arms, from the character's
model and pastes them in separate layers. Next, the joints are fixed and the
pivots set.

In traditional animation, a breakdown is an animation pose generally found
between two key poses. The key poses are themain poses in an animation
and the breakdowns are secondary poses, ones that help describe the
motion and the rotation curve (usually referred to as an arc).

camera shake
Camera shake occurs in a scene when the camera moves slightly and quickly
in several directions. This gives the impression of an impact, vibration or,
for example, bumps on the road.

caption
A text field containing dialogue, effects, sound, or slugging information in a
storyboard.

cel

In traditional animation, a cel (also known as celluloid) is a transparent
sheet on which the animation is inked and painted before being sent to the
camera. The picture's outline is drawn on the front of the cel and then
coloured along the back.

In Harmony, a cel is an individual space in an Xsheet column fromwhich you
can expose a drawing or a function's coordinate.

character design
Each character in an animated film is drawn frommultiple angles in poster-
style format, called amodel sheet, which serves as a reference for the
animators.

clean up

After rough drawings have been tested and approved, all the noise in the
image (excess lines, notes, etc) is removed to create final drawings which
can be inked, painted and shot. The cleanup process refers to either tracing
a clean line over a rough drawing to achieve the final version, or removing
dirt and extra lines left by the scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by printers to
define colour on the printed page.

colour card
A colour card is a solid colour card that is the same size as the camera. The
colour card can be used to fill the background with a solid colour when
there is no background image included.

colour model
The official colour design that must be used to paint the animation. A
model is the definitive character, prop, or location design that each artist
must follow for the production.
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colour wheel Adisplay of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements to
create the final result prior to rendering. For example, the compositing
artist will import all the animation sequences, background, overlays and
underlays in the scene and position them correctly. The artist will then set
the camera frame and animate it, if needed. Finally, the animator will create
all the computer-generated effects for the project.

cross dissolve An effect used to fade two scenes, one into the other.

cut
Adirect transition between two scenes. When a cut is used, there are no
transition effects inserted to pass from one scene to the next. The first
scene ends and the second one starts immediately.

cut-out animation
The action of animating characters made of several pieces bymoving them
around frame by frame. Cut-out animation can either be computer
generated or done traditionally using paper.

cycle
Agroup of images that together make up an action, such as walking. A
cycle is an action repeated as a loop over a period of time. It can be a series
of animated drawings or keyframes.

dialogue The text spoken by a character in a movie or animation.

dope sheet
Used by animators, directors and other members of a crew to track the
sequence and timing of images, dialogue, sound effects, sound tracks and
camera moves. Also known as an exposure sheet or Xsheet.

doping To assign a particular drawing to a range of frames.

DPI

Dots per inch is the standard measure of resolution for computerized
printers. It is sometimes applied to screens, in which case it should more
accurately be referred to as pixels per inch. Either way, the dot is the
smallest discrete element making up the image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration and
deceleration of a motion. It can be a motion created by a function curve, or
a series of animated drawings. Other common terms for ease-in and ease-
out are slow-in and slow-out.

ease-in Gradual acceleration in the action. Also known as slow-in.

ease-out Gradual deceleration in the action. Also known as slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a sequence is
happening. For example, if a child is playing on the ground in front of his
house, the establishing shot would be a scene where the viewer can see the
house, the ground, a part of the street and the buildings around the central
point of action. This helps the viewer understand the story location and
scene orientation.

exposure
In animation, an exposure is the number of cels on which a drawing appears
in the scene. For a drawing to appear longer, the exposuremust be
extended over a greater number of cels.

exposure sheet
A sheet with several vertical columns and horizontal frames used to indicate
a scene's timing. Each column represents a scene layer. The drawing
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numbers in each column are indicated and repeated over the particular
amount of frames they need to appear.

The exposure sheet is used by animators, directors and other members of a
crew to track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a sequence. A
fade in occurs when the first scene appears progressively, from complete
transparency to its complete opacity. A fade out occurs when the last scene
progressively disappears, going from complete opacity to complete
transparency.

fast-in Dramatic acceleration at the start of the action.

fast-out Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculatemotion,
registration and camera positioning. A standard animation scene will vary
between 6 to 12 fields.

field chart
Aguide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33
A resolution that is ideal for the widescreen film format that conforms to
the standard 4:3 pixel aspect ratio.

film-1.66
A resolution that is ideal for the widescreen film format that conforms to
the 16:9 pixel aspect ratio. (The pixels are wider than they are high).

flipping

In traditional animation, flipping is the action of going through the drawings
of an animation sequence very quickly in order to see the animation in
motion. Flipping can also be the action of creating a mirror transformation
of an object.

follow-through

The secondarymotion caused by themain action. For example, a character
wearing a cloak is running. Themain action is the body running. This will
cause the cloak to follow themotion, although it will not move at the same
time, but react a few frames later and follow themainmotion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D characters
and cut-out puppets with hierarchy. It is used to animate a puppet from one
of parent parts, such as a shoulder, and make the rest of the armmovewith
it as a single piece.

frame
A single photographic image in a movie. In traditional animation, the North
American standard generally contains 24 frames per second, while in
Europe the standard is 25 frames per second.

frame rate

The frame rate is the speed at which the frames are played. They are
generally calculated by frame per second. For example, a scene could be
played back at 12, 24, 25, 30 or 60 frames per second or any other number.

This is themeasurement of the frequency (rate) at which an imaging device
produces unique consecutive images, called frames. The term applies
equally to computer graphics, video cameras, film cameras, and motion
capture systems.
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Frame rate is most often expressed in frames per second (fps) and in
progressive-scanmonitors as hertz (Hz).

functions
A computer-generated motion, trajectory or path on which elements, other
trajectories and effects parameters can be attached. The function can be
controlled by adding keyframes and control points on the function curve.

gamut The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than standard
television does because it has a greater number of lines of resolution. To
take advantage of the superior quality and make full use of your resolution
setting, the output devicemust be compatible with HDTV technology.

hold
A frame in the animation in which the character maintains its position
without moving. A hold can be created between any two keyframes.

HSV
Hue, Saturation, Value. Amethod of defining colours in terms of hue (tint),
saturation (shade) and value (tone or luminance).

in-between
The drawings that exist between the key poses. These are drawn to create
fluid transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones and
colouring the lines on the final animation drawings, while following a colour
model.

interpolation
The computer-generated motion created between two keyframes. You
have the choice to create interpolation, or not, between your keyframes.

jump cut

A jerky cut between two scenes. Typically, a jump cut is not visually
pleasing. It is generally caused by one scene ending, and a second one
starting, with a similar image. The lack of difference causes the eye to see a
little jump between the two scenes.

key pose

Important positions in the action defining the starting and ending points of
any smooth transition. Keys, or key poses, are themain drawings in an
animation sequence describing themotion. For example, if an arm is
waving, the keys will be of the arm at one extremity of the wavemotion and
the other extremity. By flipping those drawings, the animator can see the
skeleton of themotion without having all the drawings.

keyboard shortcuts
One or more keyboard keys which, when used, cause an operation to be
performed.

keyframe
Important positions in the action defining the starting and ending points of
any action. A keyframe is a computer-generated position at a specific
moment (frame) on a given trajectory.

layers
In animation, a layer is an individual column, level or character. A scene's
layers are superimposed to form the final image.

layout

The communication step between the storyboard and the animation. It is
the action of putting the storyboard onmodel. That is, drawing the
character by following the design in themodel pack, so the animator can
start working.

The layout artist draws the background, creates the camera and field guide
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matching the scene and camera motion. Lastly, the animator draws on
model themain action poses.

layout and posing
The action of putting onmodel. That is, at the right scale, the storyboard
for the animator to start working.

library
A storage area containing templates and assets that can be reused in any
project or scene.

light table
Adevice that allows you to see other layers in transparency while you are
working on a particular layer.

line of action The direction that the action will follow. Also known as path of action.

lip-sync
The character's mouth synchronization with the dialogue sound track.
Frame by frame, themouth will be adjusted to fit the sound to give the
illusion of the character is speaking.

low resolution
A format that is ideal for videos destined for the web, where size and fast
download of a video file take precedence over quality. A low-resolution
image is one that lacks fine detail.

manual lip-sync detection
Themanual swapping of mouth position drawings to match a voice track.
For this process, both sound scrubbing (listening to a sound wave broken
up frame-by-frame) and drawing substitutions are used.

master palette

A group of colours attributed to a character or prop. The palette is used
throughout the entire production to maintain consistency in the look and to
ensure that the same colours are used throughout the production. Also
known as palette.

model/colour model
The definitive character, prop or location design each artist must follow for
a production. A colour model is the official colour design that must be used
to paint the animation.

motion keyframe A keyframewith computer-generated interpolation.

mouth chart
A chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X,
which is used to represent silence) used for lip-sync.

multiplane

The effect of passing throughmultiple levels of drawings to create a sense
of depth in a shot. Amultiplane is a scene in which the layers are placed at
different distances from the camera so that when the camera moves, a
depth illusion occurs. With a multiplane, all the perspective and scale is
calculated automatically.

NTSC
The standard analogue television broadcasting system used in North
America. NTSC conforms to North American standards on how rectangular
pixels are displayed for computer and television screens.

nudge
A small push (left, right, up, down, forward or backward) done with the
keyboard arrow keys on a selected element. Nudging is used to move a
selection very slightly and precisely.

onion skin A feature that lets you see the previous and next drawings of a sequence.

overlay
Apart of the scene environment, such as a chair or a bush, that is placed in
front of themain animation.
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PAL
A resolution that works best with the European format for television and
computer screens, as the rectangular pixels are displayed at a different
orientation.

palette/master palette

Apalette or master palette is a group of colours attributed to a character
or a prop. The palette is used throughout the entire project to maintain a
consistency in the look and avoid the colour changing during the animation.
Also referred to as a master palette.

palette style
Apalette style is a second version of an existing palette with a slight change
in the tint and value. A palette style can be used to create the night version
of a palette. It may also be called a clone palette.

pan To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be composed of one
or several panels.

paperless animation/tradigital
The paperless animation process is the action of animating digitally. The
main paperless animation process is to draw, frame by frame, the
animation directly in the software.

passing position
When drawing a walk sequence for a character, the passing position is the
point at which one leg passes the other.

path of action Direction that the action will follow. Also known as line of action.

peg

In traditional animation, a tool used to ensure accurate registration of
action as cel layers move. In digital animation, in which you are doing a
more advanced puppet rigging, you can use peg layers. Peg layers are
trajectory layers that do not contain drawings. They aremotion paths that
you can use to add path articulations. For the latter, you can also use the
Inverse Kinematics tool.

phoneme A unit of sound in a language.

pivot The point around which a peg or drawing rotates.

pixel

The smallest element of an image displayed on a monitor or TV screen.

Pixel, short for picture element, is a single point in a graphic image. It is a
small sample of an image, a dot, a square, or a very small sectionmade out
of smooth filtering. If you zoom in close enough on a digital image, you will
see the pixels, which look like small squares of different colours and
intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all themain
action poses, called key poses, and then placing the secondary poses
between the keys. The secondary poses are called breakdown. Finally, the
animator fills the gaps with the in-between drawings to achieve a smooth
animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes all of the
components, as well as adding motion blur before it produces a final
image. The process of calculating the final images after the compositing
process.
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resolution
The size of a scene, generally calculated in pixels. For example, the NTSC
resolution is 720 x 480. The resolution should match the final output: HDTV,
film-1.33, film-1.66, NTSC, PAL, low.

RGB
Red, Green, Blue. Amethod of defining colour by specifying amounts of
these three colour components.

rigging The process of attaching the various parts of a cut-out puppet.

rotary table
Equivalent to the animation disk/table, a device that allows you to rotate
the workspace for greater comfort while drawing.

rotoscoping
An animation technique in which animators trace over live-action film
movement, frame by frame, for use in animated films. The act of sketching
over live-action footage to create an animated sequence.

roughs
The skeleton sketch of an animation or design. Roughs mainly consist of
sketch lines and shapes, though they can also contain design details.

safe area

The zone at the center of a scene's frame that is safe from being cropped
by the TV frame. As a TV frame cuts a margin off the original frame size,
maintaining a safe area ensures that the scene's main action will remain
clearly visible once the film is screened on television.

scene
A shot in a movie or show. A sequence is composed of several scenes. A
scene changes to another scene by a simple cut or transition.

script
The original text containing all themovie or show information. In animation,
the script contains all of the location descriptions, dialogue, time andmore.
A project starts with a script.

sequence
A series of scenes or shots forming a distinct part of the story or movie,
usually connected by unity of location or time.

shot
A scene in a movie or show. A sequence is composed of several shots. A
shot changes to another shot by a simple cut or transition.

slow-in The gradual acceleration in the action. Also known as ease-in.

slow-out The gradual deceleration in the action. Also known as ease-out.

slugging To indicate the start and stop times of dialogue and relevant actions.

sound scrubbing
Aprocess that lets you hear sound in real timewhile youmove the playhead
forward or backward. This is very useful for finely-tuning a lip-sync.

stop-motion keyframe A keyframewith no computer-generated interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The storyboard
indicates what will happen, when it will happen and how the objects in a
scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first position to
the last, in order. There is very little planning in this methodology. Where
the character ends up and how it gets there can be a surprise for both the
audience and the animator. While this approach is spontaneous and
creative, it can create inaccurate results.

strokes
Invisible vector lines forming the drawing zones. They can be adjusted with
Bézier handles.
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tablet/pen
Adevice used in conjunction with, or instead of, a mouse to move a mouse
pointer (sometimes referred to as the cursor) around the computer screen.

template

An asset stored in the library that can be reused in any project. A template
can be a drawing, a series of keyframes, a sound file, a panel, a cut-out
character, an effect, a trajectory, an animation, or anything else used in the
animation.

thumbnails A very small image used as a reference or indicator.

timecode
The timing information printed on a movie clip to indicate the scene, hour,
minute and second that is currently displayed on the screen.

timeline A horizontal representation of a scene's elements, timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final line or
pencil test, each drawing is traced and painted for the final animation. In
today's digital world, this may be done in a variety ways other than the
traditional celluloid or acetatemethods.

track breakdown
The break down of an animated film's soundtrack into individual sounds to
produce the precise frame-by-frame position of each sound.

traditional animation
A type of animation process whereby all the animation sequences are
drawn by hand on paper before scanning or inking them on cels.

trajectory
A computer-generated path or trajectory that elements can follow. The
trajectory can be controlled by control points, keyframes and velocity.

transition
An effect placed between two scenes as they pass from one to the other.
Common transition effects are cross-dissolve and wipe.

underlay
In animation, an underlay is a specific part of the decor placed behind the
main animation.

aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid unit
would have a 1:1 ratio , whereas a grid unit of aspect ratio 4:3 is a unit with
one side 1.33 times as big as the other side.

vector

A vector-based image is composed of points and Bézier curves. The
computer reads the points and traces the segments, linking them to
reproduce the image shape. There is no fixed size or resolution in a vector
image. The graphic can be enlarged and distorted as much as desired and
the systemwill simply recalculate the segments and rebuild the shapes.
Vector images are translated and displayed in pixels once the calculation is
done.

velocity

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve, or via a
series of animated drawings. Other common terms for ease-in and ease-out
are slow-in and slow-out.

walk cycle

A series of drawings "on the spot" that describe the walk for a character.
The illusion of movement is created by the use of background pans. To
avoid making innumerable drawings, animators routinely make a walk cycle
for a character.

Xsheet (exposure sheet) The Xsheet or exposure sheet, is a sheet with several vertical columns and
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horizontal frames used to indicate a scene's timing.

Each column represents a scene's layer. In each column, the drawing
numbers are indicated and spread over the specific number of frames in
which they appear.

The exposure sheet is used by animators, directors and other members of
the crew to track the sequence and timing of images, dialogue, sound
effects, sound tracks and camera moves. Also known as dope sheet.

zone An area which can be painted with colour.
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auto-feed 178
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Camera view 122

bounding box selection style 124
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Camera View toolbar 127
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Editing Stack menu 127

light table 123

Matte View mode 126

OpenGL view mode 125

outline locked drawings 124

Render View mode 126
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safe area 124
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Zoommenu 125
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See cel. 179
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character

design 19

styling 20

character design 179

checking

colours 98

files, project 98

project files 98

clean up 179

clockwise

rotating 176

closing

views 110

CMYK 179

colour card 179

colour layers 42

colour model 179, 183

colour palettes 43

back up 64

locking 75-76

storage location 63

switching display modes 128

Colour view 127

switching palette display modes 128

colour wheel 180

colours

checking 98

commands

basic 99

compositing 180

Control Center

about 12

Control Point toolbar 171

controls points 171

conventions, naming 66

layer 67

puppet drawings 68

renaming modules 68

scene 66

Coordinate toolbar 171

coordinates

keyframes and control point
parameters 171

Coordinates and Control Points
view 133

counterclockwise

rotating 176

creating

workspace, new 117

cross dissolve 180

current drawing on top, Camera
view 123

customizing

toolbars 114

cut 180

cut-out animation 25, 180

workflow 32

cycle 180

dark style interface 105

database

connecting 73

files 55

structure, Harmony Network 53

Deformation toolbar 171

deleting

workspace 120

dialogue 180

display

workspace 120

Display toolbar 172

distribution, master 23

documentation

accessing 78

dope sheet 180

doping 180

DPI 180

drawing layers

adding 88

locking 89

Drawing view 135

drawings

current drawing on top 123

flipping through 172

locking 75-76, 89

outline locked drawings 124

dubbing 22

ease 180

ease-in 180

ease-out 180

Easy Flipping toolbar 172

editing

audio 22

final 22

Editing Stack menu 127

editors

Layer Properties 138

environments

Harmony Network 54

establishing shot 180

exaggeration 39

exporting

palettes 63

exposure 180

exposure sheet 180, 186

traditional 45

fade-in 181
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field chart 181
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drawings and layers 60

Harmony Network 55

File toolbar 173

files

checking project files 98

film-1.33 92, 181

film-1.66 92, 181

film-1.66_Vertical 92

final editing 22

flat toolbars 112, 116

Flip toolbar 173
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follow-through 37, 181
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forward kinematics 181

FOV (field of view) 93

custom 93

horizontal fit 93

vertical fit 93

fps 93

frame 181

frame rate 49, 181

frames per second 93

full screen 176

Function view 137

displaying functions 137

functions 182

displaying 137

gamut 182

get rights to modify 77

global lock 76

graphics, bitmap and vector 41

advantages, disadvantages 42

bitmap image types 41

vector image types 42

grid

aspect ratio, setting 95

centre coordinates, setting 96

number of units, setting 96

group navigation 150

Harmony

dark style 105

file structure 55

interface 105

modules 11

starting 71-72

Harmony Server

centralized database 71

connecting to database 73

dark style 105

database files 55

database structure 53

environments 54

file structure 55

interface 105

network connections 71

starting 71-72

usa_db structure 56

HDTV 92, 182

HDTV_Vertical 92

Help

Harmony 7

structure 7

hiding

views temporarily 112

workspace 121

Hold 182

HSV 182

in-between 182

ink and paint 182

integrity

project, checking 98

interface 105

dark style 105

interpolation 182

jump cut 182

key pose 182

keyboard shortcuts 182

keyframes 182

Layer Properties editor 138

layers 182

adding drawing layer 88

line and colour layers 42

naming convention 67

layout 182

layout and posing 183

Libary folder

locking 75-76

library 64, 183

personal 66

Library view 139

light table 183

Camera view 123

line layers 42

line of action 183
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lip-sync 183

auto detection 178

lip-sync detection

manual 183

loading

workspace 117

location design 19

locking 75-76

drawing 75-76

drawings 89

global lock 76

Library folder 75-76

palette list 75-76

palettes 75-76

scenes 75-76

version 75-76

looping

playback 174

low resolution 92, 183

manual lip-sync detection 183

Mark Drawing toolbar 173

mask

camera 123

master distribution 23

master palette 183-184

exporting 63

Matte View mode 126

menus 106

Editing Stack 127

View 127

Zoom 125

Message Log view 141

model 183

model sheet See character design

Model view 141

motion keyframe 183

mouth

chart 183

moving

toolbars 114

multiplane 183

traditional animation 48

multiplane camera 48

naming convention 66

layer naming 67

puppet drawings 68

renaming modules 68

scene naming 66

navigating

centering screen on mouse 176

full screen 176

panning 176

Play menu 177

recentering view 176

resetting pan 176

resetting rotation 176

resetting views 176

resetting zoom 176

rotating clockwise 176

rotating counterclockwise 176

zooming in 175

zooming in or out 176

zooming out 175

Navigator view 149

network 48

network connection 71

Node Library toolbar 143

Node Library view 142

toolbar 143

node system 48, 149

Node view 148

group navigation 150

Navigator view 149

Search toolbar 149

Symbol Stack 149

nodes

Cloud 14

Control Center 12

Harmony 11

Paint 14

Play 14

renaming 68

Scan 13

selecting 172

Stage 13

NTSC 92, 183

nudge 183

Onion Skin toolbar 173

onion skinning 183

toolbar 173

OpenGL

view mode 125

opening

Workspace Manager 117

organizing

drawings and layers 60

files 53

projects 53, 57

orthographic projection 94

outline locked drawings 124

overlay 183

Paint module

about 14

PAL 92, 184
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palette list

locking 75-76

palettes 62, 184

backup 64

colour 43

exporting 63

locking 75-76

storage location 63

style 184

switching display modes 128

panel 184

panning 176, 184

resetting 176

paperless animation 24, 184

workflow 30

passing position 184

path of action 184

pegs 184

traditional animation 47

pen 186

perspective projection 94

Perspective view 150

rotating a scene 151

phoneme 184

picture element 50

pipeline

Toon Boom 11

pivot 184

pixel 50, 184

dimensions 93

pixelation See bitmap image

Play menu 177

Play module
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Playback toolbar 174

FPS button 174

Jog Frames button 174

Loop button 174

Play button 174

Render and Play button 174

Sound button 174

Sound Scrubbing button 174

playing back 174

fps 174

jogging frames 174

looping 174

rendering and playing 174

sound 174

sound scrubbing 174

pose-to-pose 184

post-production workflow 21

pre-production

workflow 17
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disabling auto-save workspace 119

flat toolbars 116

Preferences dialog box 102

principles, animation 35

anticipation 36
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squash and stretch 35

straight-ahead 36

timing 35
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Harmony Server 9

production steps 27

projection settings 94
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checking files 98
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content building scenes,
organizing 57

drawings and layers, organizing 60
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locking 75-76
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resolution 91

root directory, organizing 57

verifying integrity 98
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design 19

styling 20
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naming convention 68
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Render View mode 126

rendering 184

reordering

workspace 121

resetting
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rotation 176

views 176
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resizing
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views 111
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film-1.66 92

film-1.66_Vertical 92

HDTV 92
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height, bitmap 97
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NTSC 92
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restoring

workspace, default 121

RGB 185
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rights to modify 77

root directory 57

rotary table 185
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rotoscoping 185

roughs 185

safe area 124, 185

saving

auto-saving scenes 79

scenes 78

workspace manually 120

Scan module
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scene resolution 97

Scene Settings dialog box 91

scenes 50, 185

auto-saving 79

file structure 56

locking 75-76

naming convention 66

new scene startup script 87

rotating in Perspective view 151

saving 78

scene length, setting 87
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settings 90

script 185

Script Editor view 151

scripting

toolbar 174

Scripting toolbar 174

scripts 18

new scene startup 87

scrubbing 185

secondary actions 38

selection style

bounding box 124
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settings

projection 94

scene 90

shot 185

Side view 153

slow-in 38, 185

slow-out 38, 185

slugging 185

solidity 39

sound

breakdown 21
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squash and stretch 35

Stage 13
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storyboard 19, 185

straight-ahead 36, 185
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swapping

views 110
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Symbol Stack 149

system requirements

Harmony 9

Harmony Server 9
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templates 64, 186
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timecode 186

timeline 186

traditional 46

usage 46

Timeline view 154

timing 35
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Tool Presets toolbar 175

Tool Properties view 162
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Camera View 127

Control Point 171
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customizing 114
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Display 172

Easy Flipping 172

Edit 173

File 173

flat 112

Flip 173
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managing 112

Mark Drawing 173

Module Library view 143

moving 114

Onion Skin 173

Playback 174

resizing 113

Scripting 174

Search, Network view 149

showing and hiding 112

Tool Presets 175

Tools 174

top 170

view 175

Workspace 175

Xsheet View 173

tools

Zoom 177

Tools toolbar 174

Top view 162

trace and paint 186

track breakdown 186

tradigital 184

traditional animation 23, 186

colour layers 42

colour palettes 43

concepts 41
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file structure 53

frame rate and format 49

line and colour layers 42
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multiplane 48

network 48

pegs 47

project organization and file
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scenes 50

timeline 44

timeline usage 46
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workflow 27

Xsheet usage 46
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transition 186

underlay 186

usa_db
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vector 186

vector graphics 41
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version

locking 75-76

View menu 127
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Matte 126

OpenGL 125

Render view 126

views 108
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Drawing 135

Function 137

hiding temporarily 112
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Message Log 141

Model 141
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Script Editor 151

Side 153

swapping 110

Timeline 154

Tool Properties 162
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Xsheet 163

walk cycle 186

Web Control Center
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Welcome screen 77

workflows

animation 17

cut-out animation 32

paperless animation 30

post-production 21

pre-production 17

production 21
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creating new 117

deleting 120

disabling auto-save 119
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loading 117

managing 116
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restoring default 121

saving as new version 120

saving manually 120

showing 120

toolbar 175

Workspace Manager

opening 117

Workspace toolbar 175

Xerox process 43

Xsheet toolbar 173
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zone 187
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