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Chapter 1: Introduction

What is Harmony?
Harmony is a team-based infrastructure for animation production. Its array of cutting-edge features increases
productivity and encourages creativity. Developed in conjunction with leading studios worldwide, Harmony is
specifically designed for long-term episodic and feature length projects, providing a true animation pipeline.
Several animators can work simultaneously on the same scene while the asset library provides users with easy
access to up-to-date media assets.
Harmony is truly scalable; more than 100 staging clients can share animation just as easily as a few can. Whether
you are a start-up studio or a large established animation facility, Harmony serves as the animation backbone
ensuring sustainability and growth.
Harmony is a powerful solution that brings together multiple teams working on the same project, whether inhouse or remotely. The Harmony solution offers a robust asset management system that enables users to quickly
locate assets, share tasks on complex scenes and centralize all assets in a common repository. Tremendous gains
in efficiency and quality are made by the teams, who enjoy a smooth flow between each task, and more time
dedicated to their creative assignments.

What is Harmony Server ?
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At the heart of the Harmony solution is the server, which centralizes all the production assets in a repository.
Loaded with production proven tools to manage administration tasks, the server is completely flexible and will
fit in your existing infrastructure, whether you are on Windows, Mac or Linux.
In addition, the server is critical at the end of a production for rendering projects efficiently. The Rendering
process, controlled directly by the server, not only renders production scenes but also executes the batch
vectorization of the scanned drawings. You can send an unlimited number of scenes to render and change their
priorities depending on your deadline! You can also render final frames locally or batch process over a network
in the background or at scheduled times.
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Chapter 2: Control Center

Using Harmony Server has the advantage that it centralizes your entire production on your server and organizes it
into structured database. The key piece of Harmony Server is the Control Center module. From Control Center,
you can manage your production database, users, visualize your rendering queue and more.
This chapter explains the general administrative tasks which must be performed to successfully run the Harmony
solution.
This chapter is divided as follows:
•

Starting Control Center on page 7

•

Centralized Data, Checking Out and Global Locking on page 10

•

Managing Harmony Users on page 11

•

Managing Environments, Jobs and Scenes on page 17

•

Exporting and Importing Data on page 38

•

Control Center Commands on page 46

Starting Control Center
To manage a production, you will need the Control Center module. Control Center is used to create new
environments, jobs, scenes and users, as well as to import and export scene packages. Control Center directly
manages your server database.
You can start Control Center from the server or any client machine.
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Before accessing the main Control Center interface, the Database Login dialog box opens, requesting a user
name. By default, there is a user name created called usabatch. Type this user name to log in the first time.
Once logged into Harmony, you can create your own set of users.

IMPORTANT: IMPORTANT: Do not delete the usabatch user name as it is used by Toon Boom Harmony Server
for batch processing.

How to open Control Center
1. Do one of the following:
‣

Windows: Start > Programs > Harmony 12.1 [edition] > Control Center

‣

Mac OS X: Applications > Toon Boom Harmony 12.1 [edition] > Control Center

‣

Linux: /usr/local/ToonBoomAnimation/harmony_12/lnx86_64/bin/Controlcenter

The Database Login dialog box opens.

2. In the User Name field, type usabatch. This is the default Harmony user.
The Control Center application opens.
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User Interface

The Control Center interface is divided into six areas:
Parameter

Description

Top menu

Contains the commands available in Control Center. You can also find the commands in the contextual menus available in each area by right-clicking.

Environments

Displays one of your projects, such as a feature film, a TV series or a group of
TV spots.

Jobs

Shows the sequences or episodes in your project (Environment). Select a
project from the Environments list to see your jobs.

Scenes

Shows the scenes in an episode or sequence (Job). Select a job from the Jobs
list to see your scenes.

Elements

Shows the layers or columns in a scene. Select a scene from the Scenes list to
see your elements.

Drawings

Shows the drawings in your layer or column (Element). Select an element from
the Elements list to see your drawings.

Here is a typical example of the database structure:
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Centralized Data, Checking Out and Global Locking
When working with Harmony Server, all scenes and their data are stored directly on the database; no data is
saved or stored on the client machine. The client machines access the database and load the scenes and
drawings directly from the server. Each time the user saves a scene, the data is updated directly on the server.
There are no upload or download operations done between the server and the clients. However, when
working with the Web Control Center, users must download and upload scenes to the Harmony database.
Harmony has a lock system, referred to as global lock, for the different scenes and scene assets. Since all data
on the server can be accessed directly and modified from any client machine, by default, scenes are locked and
users must get the rights to modify them in order to save their work onto the server. Only one user at a time
can modify a scene. Once a scene is opened on a client machine, other users can open the scene in read-only
mode if they need to consult it, but they will not be able to save any modifications.
In the Web Control Center, when a scene is downloaded locally by a user, global locking does not apply as it
will be modified in Harmony Stand Alone. To ensure that scenes are not simultaneously modified and causing
conflicts, scenes downloaded through the Web Control Center can be checked out by a user. When scenes are
checked out, they can be opened in read-only mode in Harmony Server.
Global lock has several levels:
A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked.
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked
items. If someone tries to open a locked scene, it will be displayed as read-only.
Here are the different lock possibilities:
Lock

Description

Scene or Version Lock

Controls the Xsheet timing, layers, nodes but not the drawing, palettes,
palette-lists or templates.

Drawing Lock

Only one user can edit and save a locked drawing.
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Palette Lock

Only one user can edit and save a locked palette.

Palette-list Lock

Only one user can edit and save a locked palette-list.

Library Folder lock

Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Center module.

Managing Harmony Users
In an animation studio, there are usually several people using Harmony who will probably be assigned different
tasks, such as ink and paint or compositing. Normally, you should create a different user for each one. This way,
the person assigned to ink and paint will only have access to the Paint module and not to other features that are
not relevant to their work.
Anyone who uses Harmony must have a login name in order to run any of the modules. When using Harmony in
standalone mode, there are no username or password required. The Harmony login is independent from the
computer session login.
Users connecting to the database through Web Control Center should have a password as it's safer for accessing
via the Internet. For Web Control Center users, it is recommended to create the users through Web Control
Center so you can set the password.
On Windows, by default, only the usabatch and BATCH users are created. However, you should not use them
for your staff. These should be kept for Harmony Server when performing background operations, such as batch
processing—see Creating a Default User for Batch Processing on page 17.

IMPORTANT: Before making the Web Control Center public, set passwords for all users so no one can delete
everything.

The User List dialog box lists all the users and their details, including: username, first and last names, and user
type. The buttons at the bottom of the dialog box let you add, delete or modify the list of users.
All Harmony users must have their name on the user list to log in to any application. The system uses the login to
track activities; it is not a security lockout.
Each login also has a user "type" assigned to it which allows access to only some of the Harmony modules.
As your studio network grows and evolves, you may need to delete old or obsolete user profiles from your
system. After you delete a user profile, the person who used that profile will no longer be able to access
Harmony. You cannot delete yourself from the user list. If you accidentally delete a name, you must follow the
procedures for adding a user to get the name back into the system.
You can modify the user profiles at any time to update the user information.

NOTE: NOTE: To change your own user profile, login as usabatch (the default user).
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How to view the user list
1. From the top menu, select Admin > Users.
The User List dialog box opens and displays your login name and a list of the other users in the system.

How to add a user to Harmony
1. To view the list of Harmony users, select Admin > Users.
The User List dialog box opens.

2. Click Add.
The Add User dialog box opens.

3. In the User Name field, type the person's user name.
4. Type the person's first name and last name in the corresponding First Name and Last Name fields. You
can enter a space if you want leave the field blank.
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5. In the Type menu, select the user type. This defines the type of work the user typically performs. It will
allow or block the person from accessing certain Harmony applications and perform operations in Control
Center—see User Types and Restrictions on page 15.

6. Click OK.
The name appears in alphabetical order in the user list.

How to delete a user
1. To view the list of users, select Admin > Users.
The User List dialog box opens.

2. In the user list, select the name you want to delete.
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3. Click Delete.
The Confirm dialog box opens.

4. Confirm if you want to delete the user from Harmony.
‣

Click OK to delete the selected user.

‣

Click Cancel to abort the delete command.

How to modify user information
1. To view the list of users, select Admin > Users.
The User List dialog box displays.

2. Select the profile to modify.
3. Click Modify.
The Modify User dialog box appears.

4. Type or select the new information in any or all of the following:
‣

User Name: The user's login name

‣

First Name: The user's given name

‣

Last Name: The user's family name

‣

Type: The type of access the user has in the system

5. Click OK.
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User Types and Restrictions
Here are the different user types available and their restrictions:

Feature

Web
Control
Control
Center
Center

RND,
Coordinator,
Supervisor,
TD,
Executive

Animator

Xsheet,
Archive

Scan

Ink &
Paint

Create Environment

•

•

•

Change Asset Lock on Environment

•

•

•

Delete Environment

•

•

•

View Vectorize Queue

•

•

•

•

•

•

View Render Queue

•

•

•

•

•

•

Create Job

•

•

•

•

Change Job Priority

•

•

•

•

•

•

•

Change Job Status

•

•

•

Delete Job

•

•

•

Create Scene

•

•

•

•

•

Delete Scene

•

•

•

Unlock scenes locked by
another user

•

•

•

Unlock scene version locked by
another user

•

•

•

Unlock scenes locked by me

•

•

•

•

•

Unlock scene version locked by
me

•

•

•

•

•

Move Scene

•

Rename Scene

•

•

•

Clear Scene

•

•

•

•
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Change Scene Priority

•

•

•

•

•

•

Change Scene Status

•

•

•

Reorder Scenes

•

•

•

Copy Scenes

•

•

•

•

Send to Vectorize

•

•

•

•

•

•

•

Send to Unvectorize

•

•

•

•

•

•

•

Send to Rendering

•

•

•

•

•

•

•

Add/Modify/Delete Users

•

•

•

Change Approval Policy

•

•

•

Change Vectorize Style

•

•

•

•

•

•

Change Asset Lock

•

•

Database Lock Manager

•

•

Export Scenes

•

•

•

•

•

Import Scenes

•

•

•

•

•

View Error Log

•

•

•

•

•

•

•

View Elements

•

•

•

•

•

•

View Drawings

•

•

•

•

•

•

Open in Control Center

•

•

•

•

Open in Paint

•

•

•

•

•

Open in Scan

•

•

•

•

•

•
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Creating a Default User for Batch Processing
If you intend to use the batch processing feature in Harmony or if you are installing the application on the server
machine, you must create:
•

An operating system user called usabatch

•

A Harmony user name called usabatch through the Control Center module.

Harmony uses this user profile during batch rendering.

IMPORTANT: It is important to verify that these users exist before starting a project and setting the batch processing.

•

Operating System Users
Windows: The usabatch operating system user profile was automatically created by the installation
wizard.
Mac OS X: The usabatch operating system user profile must be created manually or using the
configuration assistant.
Linux: You must manually create the usabatch operating system user.
Regardless of the operating you are using, a usabatch user account must exist on your operating system.
If you need to create this account, see your system administrator.

•

Harmony User Names
The usabatch Harmony user is created during the installation process on Windows, Mac OS X and Linux.
There is no need to create it manually unless it was deleted. To manually create the usabatch Harmony
user, refer to the Toon Boom Harmony Installation Guide.

Managing Environments, Jobs and Scenes
Every project you create with the Harmony solution starts with an environment; it is the highest level in Control
Center. You can build a complete environment by adding jobs, scenes, elements and drawings.
Control Center divides your animation project into the following categories which organize the components of
your animated projects:
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•

Environment: This is the name of your animation project.
Example: adventure_movie

•

Jobs: These are the major sections of an environment, such as sequences or episodes.
Example: adv_seq_001, adv_seq_002

IMPORTANT: All jobs are stored in the same location in the Harmony database. Be sure to prefix all job names
appropriately, so you can identify the project it belongs to. Each job must have a different name. You cannot give
two jobs the same name.

•

Scene: These are the different shots in a job.
Scenes are contained in their respective job folder in the Harmony database. Prefix all scenes names
appropriately, so you can identify which environment and job they belong to.
Example: sc_001, sc_002

•

Elements: These are the different layers and columns in your scenes.
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If you have not created an exposure sheet yet, the Frames column in the Scenes list displays 0 and no
elements appear in the Elements or Drawings list.
For example, scene 002 of show_episode_6 could have the following elements:
•

A background called bg.

•

A character called tony.

•

A highlight effect called hl.

You would then find these elements under job 002 and the show_episode_6 scene. The Elements list
would display the element names, types of elements in a scene, the type of scans, and the size of the field
chart.
•

Drawings: These are actual drawings of the elements (layers) in your scene.
For example, the tony element in 002 of show_episode_6 could consist of 35 drawings. To find these
drawings, you would look under Drawings to see the keyframes, state, and stage of each drawing.

As your projects come and go, you will probably want to start cleaning up your database, as well as your server's
hard disk, by removing old and obsolete environments and their associated animation data.

IMPORTANT: After you delete a scene, job, or environment, the associated data is permanently removed from your
storage disks. Make sure you really want to erase these items before you delete them as there is no way to retrieve
the data after it has been erased.

You might want to export old environments and archive them somewhere else before you delete them from your
system.

If you are working in a mixed Windows/Mac OS X/Linux environment or share files with other studios
that do, you should use lowercase letters to name the various items in your animation projects and not
include any spaces in component name. For example, write the_show instead of The Show. This
recommendation is due to the fact that Linux is case-sensitive while Windows is not.

Managing Environments
Harmony uses environments to manage and organize related projects. Using environments allows you to
organize your production projects by their nature or type.
If your projects center around episodic and commercial types of work, you can create two environments. For
example, one environment called commercials and the other called the_show. Then you can insert the jobs
that relate to each type of project. When you want to work on a commercial project, open the commercials
environment and select the commercial job you need. Similarly, if you want to work on an episodic project, open
the environment called the_show.
Environment

Job
sc_001

commercials

dentist
sc_002
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soda

sc_001

cereal

sc_001
sc_001

sho_001
sc_002
the_show

sho_002

sc_001
sc_001

dentist
sc_002
When you are ready to remove old environments, you can delete them from the database. However, in order
to prevent accidental loss of data, you can only delete an empty environment (an environment that contains no
jobs, images, or palette information).
How to create an environment
1. Do one of the following:
‣

From the top menu, select Environment > Create.

‣

Right-click in the Environments section and select Create.

In mixed platform Environments (Windows/Mac OS X and Windows/Linux) it is best to name everything
in lowercase so data can be interpreted the same way on each operating system. The same is true if
working between studios using Windows, Mac OS X, and Linux.
The Create Environment dialog box appears.

2. In the Environment Name field, type the new project's name.

The environment name is alphanumeric and can include underscores (_), but no spaces or other
special characters. The environment name is case sensitive.

3. If you want the user to automatically get the rights to modify all the scene assets (drawing, scene setup,
palette lists, etc.), select the Get Rights to Modify All Scene Assets option.
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4. Click OK.
The new environment appears in alphabetical order in the Environments list.
After you create an environment, you must add it to the Batch Processing queue so it can vectorize and render the
drawings and scenes automatically. You only have to add the environment to the Batch Processing queue once.
How to delete an environment
1. In the environment section, select the environment to delete from the Environments list.
2. Do one of the following:
‣

From the top menu, select Environment > Delete.

‣

Right-click in the Environments section and select Delete.

The Delete command is only available for an empty environment. You must delete the scenes and
jobs before you can successfully delete the environment.

The Confirm dialog box appears.

3. Click Yes to delete the selected Environment.
The environment no longer appears in the Environments list.

Setting the Resolution File
When you create a new environment or job, you can create a project resolution list that will appear in Stage. If you
work with a particular resolution, you can insert it in your list so it's available when doing the compositing in
Stage.
You need to copy the resolution.conf file at the server, environment or job level. If you insert the file at the
environment level, it is not necessary to add one at the job level. All jobs in the environment will use the
resolution.conf file at the environment level. If you want all environments to use the same resolution.conf file,
place the copy at the server level in the USA_DB folder.
Starting with Harmony Server 11.1, the resolution list is stored in an XML file. The resolution.conf file is still used
and it is still the file that you will copy from the samples folder. If you modify the resolution list in the Scene
Settings dialog box, Harmony will convert the file to an XML file.
The resolution.conf file is located here:
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•

Windows: Program Files > Toon Boom Animation > Harmony 12.1 [Edition] > resources > samples

•

Mac OS X: Applications > Harmony 12.1 [Edition] > tba > resources > samples

•

Linux: /usr/local/ToonBoomAnimation/harmony_12/resources/samples

NOTE: For Web Control Center, there is a WebCC preview resolution for previewing movies and thumbnails. It
should be in the samples folder. If it is not, be sure to place a copy in the resolution presets.

Insert the Resolution.conf file in the following directory:
Resolutions common to all jobs in
the environment.

/USA_DB/environments/environment_
name/resolution.conf

Resolutions common to all scenes in
/USA_DB/db_jobs/job_name/resolution.conf
the job.
Resolutions common to all scenes
and environments.

/USA_DB/resolution/resolution.conf

All scenes found under the environment or job have access to the resolutions stored in that file.
You can simply type new resolutions, modify or delete existing ones from the list. This file can also be sent to
other studios with whom you are working.

Below is the resolution.xml file created by Harmony.
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Managing Jobs
Within each environment is a list of jobs. These jobs contain all the segments for your animated sequence. If you
are creating a weekly television series called The Show, you could name your job show_ep_06 (the_show
would be the name of your environment).
If each episode was composed of 100 animated shots, each job would contain 100 scenes.
Each job must have a unique name. You cannot have two jobs with the same name, even if they appear in two
different environments. On the server, all the jobs are contained in the same folder.
As you continue working on your animation project, you may want to update the status of the jobs in your
environment. This status can display one of three things:
•

The stage the job has reached

•

When the job will be vectorized

•

When the job will be rendered

As you complete your animation project, you can update a job's status to reflect where it is in the overall
production process. You can classify jobs as being "In Production" or "Completed".
•

In Production: The job is still a work in progress. The other nodes can still access this job.

•

Completed: The job is finished. The Harmony database still has all the job's components (scenes,
elements, drawings), but the job neither appears nor is accessible from the Harmony applications.
In most cases, you would mark a job as "Completed" after it has been finalized (inked, painted, rendered)
and transferred to a medium, such as Blu-ray, or sent to post-production.
You can change a job's status from "Completed" to "In Production" at any time to continue working on it.

If you want to remove a job and its data from the Harmony database and archive it, you can export the job from
Control Center.
Before you send a job's scenes to be vectorized or rendered, you can change the job's priority level in the
processing queue. Increasing a job's priority lets the system process it before other jobs in the processing queue.
Use the Choose New Priority dialog box to change a job's rendering and vectorization queue priority. The
priority is set using a sliding scale where 0 is the highest priority and 10 is the lowest.
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For example, if job B is before job A in the queue, you can change the priority, so job A is processed first.
Changing a job's priority does not affect vectorizing or rendering jobs that are already sent in the queue. It will
only affect jobs that are sent after making the change. If you want to change a job's priority after it has been
sent to the queue, use the Change Priority button in the Queue window.
You should only delete jobs that you no longer need or that have already been exported to an archive (using
the Export command available in the Admin menu).
When you delete a job, the following components are permanently removed:
•

Scenes

•

Elements

•

Drawings

•

Database information associated with the selected job

•

Palettes stored under the selected job

Before you delete a job:
•

Make sure no one else is currently using the job. Failure to do this may result in file corruption and loss
of your work.

•

Wait until everyone is offline. This ensures no one can open the data files while you delete them.

IMPORTANT: You cannot archive a job by deleting the job. If you want to archive a job, you should export it to a
new location where it can be stored permanently.

Changing the job's stage from In Production to Completed only hides the job in the Control Center window; all
the associated files with the job are still on your system.

NOTE: You cannot delete a job if it still contains scenes.

How to create a job
1. In the Environments section, select the project in which you want to create a job.
2. Do one of the following:
‣

From the top menu, select Job > Create.

‣

Right-click in the Jobs section and select Create.

The Create Job dialog box appears.
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3. In the Name field, type the name of the job you want to create.

The job name is alphanumeric and can include underscores (_), but no spaces or other special
characters. The job name is case-sensitive.

4. In the TD menu, select a technical director (TD). You must select a technical director to create the job.
A TD is usually the person who oversees the animation project and makes sure the work is done properly.
Select the person who most closely resembles this definition. If you do not have a particular user for the
task, you can simply assign usabatch.
When you create your Harmony users, you can label a user as a technical director (TD).
5. In the ATD menu, select an assistant technical director (ATD). You must select an assistant technical director to create the job. If you do not have an ATD, select the same person for the TD and ATD jobs.
In some studios, the responsibilities of the technical director can be shared by more than one person. This
second person is the ATD.
The technical director and assistant technical director you select appear in the Scenes list for each scene of
the job.
6. In the Approval menu, select how Harmony will mark the various stages the scenes will pass in your production schedule.
‣

Automatic: When you work on your scenes, Harmony automatically approves their status at each
stage

‣

Manual: When you work on the scenes, the technical director or the assistant technical director must
approve their status at each stage using the Change Stage command (available in the Scene menu).

7. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or
Render queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of
other projects with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
If you do not know what priority to assign to your project, you can leave it at 5. You can always change it
later.
8. Click OK.
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Control Center adds your new job to the selected environment and it appears in alphabetical order in
the Jobs list.
How to change the stage of a job and view the list of completed jobs
1. In the Environments section, select an environment.
2. Do one of the following:
‣

From the top menu, select Job > Change Stage.

‣

Right-click in the Jobs section and select Change Stage.

The Change Stage of Jobs window appears.

3. Select the jobs you want to change the stage.
‣

If you want to change a job from In Production to Completed, select the jobs in the In Production
list.

‣

If you want to change a job from Completed to In Production, select the jobs in the Completed list.

4. Click one of the Change buttons to change the job's status.
‣

Click the Change to Completed

‣

Click the Change to In Production

button to change a job that is in production.
button to change a job that is completed.

5. Click OK.
How to change a job's priority
1. In the Environments section, select the environment containing the job you want to change the priority
for.
2. In the Jobs section, select the job whose priority you want to change.
3. Do one of the following:
‣

From the top menu, select Job > Change Priority.

‣

Right-click in the Jobs section and select Change Priority.

The Choose New Priority dialog box appears.
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4. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or
Render queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of
other projects with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
5. Click OK. When you send this job to be vectorized or rendered, it will have this new priority in the processing queue.
How to delete a job
1. In the Environments section, select the environment containing the job you want to delete.
2. In the Jobs section, select the job you want to delete.
3. Do one of the following:
‣

From the top menu, select Job > Delete.

‣

Right-click in the Jobs section and select Delete.

The Confirm dialog box appears.

4. Click OK.

Managing Scenes
After you create a scene, you can view the corresponding elements and drawings in the Control Center window.
When you select the environment and the job, the corresponding scenes for the selected job appears in the
Scenes list in the Control Center window.
For each scene in your job, you must create a unique exposure sheet to lay out the drawings, camera effects,
audio tracks, and other special effects for that scene.
When creating your scene, you must select the path where you want to store the scene data and where you want
the new scene to appear in the Scenes list. You can create a single scene or create multiple scenes all at once.
You do not have to enter the word "scene" when entering scene names. The system automatically adds scenein front of the name. For example, when you type"3" in the Scene Name field, the scene name automatically
displays as "scene-3" throughout the file system. The scene name will have "scene-" as a prefix, but that will only
be visible when looking at the scene on the file system. The scene will appear without this prefix in all the
Harmony applications.
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When you delete a scene, you not only remove the scene from the Control Center window, but you also
permanently remove all the information associated with the scene including:
•

Exposure sheet (and all associated versions)

•

Elements

•

Drawings

•

Database information

•

Any palettes stored in that scene's palette library

Before you delete a scene:
•

Make sure that you really want to remove all this information from the system

•

Are you going to use the scene in the future?

•

Do you need to archive the scene for future use?

•

Make sure no one else is currently using the scene.
failure to do this may result in file corruption and loss of your work.

•

Wait until everyone is offline. This ensures no one can open the scene while you delete it.

How to create a scene
1. In the Environments section, select the environment containing the job you want to add scenes in.
2. In the Jobs section, select the job you want to add scenes in.
3. Do one of the following:
‣

In the Scene section, select Scene> Create.

‣

Right-click in the Scenes section and select Create.

The Create Scene dialog box appears.

4. Click in the Scene Name(s) field and enter the name for the first scene you want to create.
5. Press the Enter/Return keyboard shortcut to move onto the next scene.
6. Enter the name of the next scene you want to create.
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NOTE:
When creating a new scene or renaming a scene, the scene's name cannot exceed 23 characters.
When creating scenes in Control Center, you should enter the scene names exactly as they appear on the actual
animation. This ensures that the information in your environment is consistent with the actual animation.
The job and scene names are alphanumeric and can include underscores (_), but no spaces, or other special
characters. The environment name is case-sensitive.

7. Repeat the previous steps until you have named all the scenes you want to create.

8. In the File System list, click the path where you want to store the files.
If you do not see the desired path in the list, specify a different path in the Other File System field.
If you are unsure which disk drive to select, consult your technical director or system administrator.
The information in the File System list displays:
‣

Available drives on which you can store new scenes

‣

Space that is currently available (in megabytes)

‣

The percentage of space the drives are currently using

NOTE: Although you can add as many scenes as you wish, you can only select one path at a time. Therefore, Control
Center stores all scenes you create in one session at the same place (same path).

9. Select where you want to place the scene in the Scenes list from the Add Scenes menu. These are the
options:
‣

At Bottom: Places the new scenes at the bottom of the list

‣

At Top: Places the new scenes at the top of the list

‣

Before Selected: Places the new scenes before the selected scene

‣

After Selected: Places the new scenes after the selected scene

‣

Name Sort: Arranges the new scenes alphabetically.
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NOTE: To use the After Selected and Before Selected options, you must select another scene from the Scene list
in the Control Center window.

10. Click OK.
The new scene is created and displayed in the Scenes list. If you do not want to create the scene, click
Cancel.
How to delete a scene
1. In the Scenes list, select the scene name you want to delete.
2. Select Scene > Delete or right-click anywhere in the Scenes list and select Delete.
The Confirm dialog box appears.

3. Click Yes to delete the scene and all its related information.
The scene name and all its associated files are deleted.

Updating Scenes
Your scenes contain the animation sequences you are working with, which allows you to manipulate them and
their associated files to achieve the desired effect.
You can:
•

Move a scene

•

Rename a scene

•

Change a scene's priority

•

Change a scene's stage

•

Change the sequence of a scene

•

Clear scenes from Control Center

•

Copy an exposure sheet to another scene

•

Send scenes to the render queue

When you create a scene, it and its associated files are stored on one drive. If you find you are running out of
space, you can move a scene to another drive. However, you can consolidate all the scenes for a particular job
in a single directory allowing you to find related information quickly. You may also want to file your scenes in
specific directories, creating a customized directory system. The Move command lets you move scene data
from one file system to another.
Before you move a scene's data:
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•

Make sure no one else is currently using the scene's data. Failure to do this may result in file corruption and
loss of your work.

•

Wait until everyone is offline. This ensures no one can open the data files while you move them.

As you work on your scenes, their nature and contents may change and the name you gave the scene when you
began the project may no longer reflect its contents. In this case, you can rename the scene to more accurately
reflect its contents.
Before you rename a scene:
•

Make sure no one else is currently using the scene.
Failure to do this may result in file corruption and loss of your work.

•

Wait until everyone is offline. This ensures no one can open the scene while you rename it.

You can change the scene's priority level in the processing queue. Increasing a scene's priority lets the system
process it before other scenes in the processing queue.
Use the Choose New Priority dialog box to change a scene's rendering and vectorization queue priority. The
priority is set using a sliding scale where 0 is the highest priority and 10 is the lowest. If a scene has already been
sent to the queue changing the priority at this point will not affect its priority in the queue. Changes will only be
applied next time it is sent to the queue. To change a scene's priority after it's been sent to the queue, use the
Change Priority button in the Queue window.
For example, If scene B comes before scene A in the queue, you can change the scene's priority so that scene A
will be processed first.
The Change Stage command allows you to change the approval stage name of a selected scene that is in Manual
approval mode. You can also create customized approval stages that reflect the approval process in your
production environment.
A scene's stage is a method of tracking its progress in your production; the scene's current stage does not stop
you from advancing the scene to other stages.
Changing a scene's stage and making manual approvals allows you to assign and change a scene's approval
stages to keep track of its current status. For example, if you have a scene whose drawings are being scanned,
you will mark it as the Scan stage. After you begin adding colour to these line drawings, you can change the
scene's stage to Paint. If the selected scene has an automatic approval policy, the Change Stage command will be
inactive in the Scene menu. To change a scene's stage, you must ensure that the approval policy is set to Manual.
You can change the sequence of scenes in your job, which affects the order in which the scenes appear in the job
throughout the system. You can place a scene anywhere in the Scenes list or you can sort them alphanumerically.
If you must restart a scene from scratch, you can completely erase a scene's exposure sheet. When you clear a
scene, you delete all exposure sheet database information and reset the scene as if it were completely new. You
are only deleting the files from the database; Control Center does not actually delete any image files (drawings,
scan, final frames). If you have questions concerning the contents of a scene, you should contact the technical
director responsible for the scene in question.
If you must clear a scene from Control Center, make sure no one else is currently using the scene's data. If you
clear a scene that someone else is working on at that moment, you run the risk of corrupting the files and losing
work.
If you must clear a scene, you should wait until everyone is offline to ensure that no one can open the data files
while you clear them from Control Center.
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When you have two scenes with similar exposure sheet information, instead of entering the information twice,
you can:
1. Enter the information for one exposure sheet.
2. Copy it to the other scene.
3. Modify the second exposure sheet as needed.
The Copy command lets you copy an existing exposure sheet from one scene into another scene. You can then
modify the copied exposure sheet using Stage.
When you are ready to send a set of scenes for rendering, you can use the Send to Rendering command. This
command allows you to send one or more scenes for rendering to the Batch Processing machine.
You can also use Stageto render scenes, but since you must open each scene individually in Stage, you can only
send one scene to render at a time.
How to move a scene from one directory to another directory
1. In the Scenes section, select the scenes you want to move.
2. Do one of the following:
‣

From the top menu, select Scene > Move.

‣

Right-click anywhere in the Scenes list and select Move.

The Move Scene dialog box appears.

3. In the Select Scene(s) to Move field, select the scenes you want to move from their current directory.
4. Click Calculate to know how much hard disk space your selection requires.
5. In the Move Scenes To list, select the directory where you want to move the scene. If it does not appear
in the list, enter the directory path in the Other field.
The Control Center node automatically checks the amount of free space for each directory and
compares it to the size of the scene you want to move.

32

Harmony 12.1 Control Center Guide

If there is not enough disk space on a particular drive/mount point to store the scene, the directory
displays a not "enough space message". Choose another disk from the list.
6. Click OK.
How to rename a scene
1. In the Scenes section, select the scene to rename.
2. Do one of the following:
‣

From the top menu, select Scene > Rename.

‣

Right-click anywhere in the Scenes list and select Rename.

The Rename Scene dialog box appears.

3. In the Enter New Scene Name field, type the new name for the scene and click OK. Try to keep scene
names brief. It is recommended that you use no more than 23 characters.

NOTE: Use lower case letters if these scenes may be used with a Windows workstation.

NOTE: When creating a new scene or renaming a scene, the scene's name cannot exceed 23 characters.

How to change a scene's priority
1. Select the environment, the job and the scene you want to prioritize.
2. Do one of the following:
‣

From the top menu, select Scene > Change Priority.

‣

Right-click anywhere in the Scenes list and select Change Priority.

The Choose New Priority dialog box appears.
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3. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or
Render queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of
other projects with lower priorities in the Vectorize and Render queues even if there is already a queue
processing.
4. Click OK.
The new scene priority appears in the Scenes list in the Priority column.
How to change a scene's stage status
1. In the Scenes section, select a scene.
2. Do one of the following:
‣

From the top menu, select Scene > Change Stage.

‣

Right-click anywhere in the Scenes list and select Change Stage.

The Change Scene Stage dialog box appears.

The current stage of the selected scene appears in the From Stage field.
3. Select the stage you want to apply to the current scene from the To Stage menu.
4. Click OK.
How to resequence a scene
1. Select the job whose scenes you want to re-sequence from the Jobs panel.
2. Do one of the following:
‣

From the top menu, select Scene > Reorder.

‣

Right-click anywhere in the Scenes list and select Reorder.

The Reorder Scenes dialog box appears.
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3. Select the reordering method by clicking on the column headers or dragging the scenes up or down.
4. Once the scenes are ordered, click OK.
How to clear a scene
1. Select the environment, job or scene you want to clear.
2. Do one of the following:
‣

From the top menu, select Scene > Clear.

‣

Right-click anywhere in the Scenes list and select Clear.

The Confirm dialog box appears.

3. Click OK.
The Scene list refreshes itself and displays blank elements and drawings lists, showing that the Control
Center node has deleted the exposure sheet for the scene you cleared.
How to copy an exposure sheet to another scene
1. Select the environment and the job from the Control Center window.
2. Do one of the following:
‣

From the top menu, select Scene > Copy.

‣

Right-click anywhere in the Scenes list and select Copy.

The Copy Scene dialog box appears.
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3. Select the environment, job, and scene to copy from the exposure sheet from the From panel.
The lower half of the dialog box displays the environments, jobs, and scenes to which you can copy the
exposure sheet.
4. Select the environment, job, and scene where you want to copy the selected exposure sheet to the To
panel.
5. If you want to copy the associated animation data files with the scene's exposure sheet, select the Copy
All Data Files option. Harmony will place a copy of the animation data in the target scene's storage directory.
6. Click OK.
7. If the scene you are copying to already has an exposure sheet, a Confirm dialog box appears to make
sure you want to replace the existing exposure sheet.
‣

Click Yes if you want to copy over the existing exposure sheet.

‣

Click No to cancel the copy or to select a different scene.

The Copy Xsheet dialog box disappears. You can view and modify the copied exposure sheet using Stage.
How to send a group of scenes to the render queues
1. In the Control Center window, select the environment, job and scenes that you want to send to the
Render queue for rendering.
2. Do one of the following:
‣

From the top menu, select Scene > Send to Rendering.

‣

Right-click anywhere in the Scenes list and select Send to Rendering.

The Render Network dialog box appears.
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3. Select the frames you want to render:
‣

All Frames: Sends all the frames in the scene to be rendered.

‣

Selected Frames: Sends a range of frames to be rendered. You can only send a range of frames if you
selected one scene.

4. Select the Chunk option if you want to split the frames into sets of frames. Enter the number of frames you
want in each chunk in the Size field.
5. Select the Version of the Scene you want to render.
6. Select the camera you want to use to render the scene's images from the Camera menu. These are the cameras you created in your exposure sheet in Stage.
7. If you want to create a Field Composite, select the checkbox to refine your selection.
‣

Add Pulldown: Uses the 3:2 pulldown technique.

‣

Automatic Combine: Combines even and odd fields on a scene's image.

•

Second Field First: Always start with the second field before combining with the first field.

8. If you did not select the Batch Composite Options option, select the Preview option to see the render
once it is completed.
9. Click OK.
To verify that the scenes have been sent for rendering, display the Render queue.

Viewing Elements and Drawings
You must use Stage, instead of Control Center, to add elements or drawings to your environment. After you add
them in the exposure sheet and save the source, Control Center displays them in the Elements and Drawings
panels.
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When you select a scene in the Scenes list, all of the elements associated with the scene (background,
characters, etc.) appear in the Elements and Drawings lists. Control Center retrieves these components from
information you previously entered in the exposure sheet.
You can click the Expand/Collapse

buttons to show or hide the Elements and Drawings sections.

Exporting and Importing Data
With Harmony, you can import and export data.
You can use Control Center's export utility to migrate scenes from your system for archival purposes or third
parties, and you can use the import utility to integrate scenes into a Harmony environment.
You can use Control Center's export utility to copy scene data. After Harmony copies the exported data to a
temporary directory, you can move the archived data to your storage device (for example, a CD or tape drive).
Harmony creates two files during export:
•

README.txt: Includes export statistics, such as creation date and user ID

•

IEContents.dat: Includes export parameters

In Linux, exporting your scenes using the Export command makes Harmony copy scene information and link
information to the temporary export directory you selected. Therefore, you must retrieve the animation data
from your server and copy it, along with the database information, to your storage device.
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NOTE: You can compress the export package to make it transportable. However, it will resolve hard links and symbolic
links, which might be contrary to your export options.

Copying the exported data to a storage device is a two-fold process. Copy the exported animation files to a file
on the storage device. Then remove the temporary export data from your system.
If the imported files are compressed, you must decompress them to a temporary directory before you can import
them into Harmony. If you don't know how to decompress these files, see your system administrator.
If you have any problems importing or exporting in Harmony, review the instructions to make sure you have
followed them completely. If you continue to have problems, consult the following list to troubleshoot common
import and export problems.
Problem: Import or Export Not Successful
If the transfer is not successful, an error dialog box appears to describe the problem. The most common
reason for a failed transfer is due to your current network permissions. See your system administrator for
help.
If the transfer fails in the middle of the process, the files that were imported or exported may be corrupt or
incomplete.
•

For a failed import, use Control Center to delete the scene.

•

For a failed export, manually delete the incomplete export folder.

If you click the Message Log tab, you can see more detailed descriptions, including error messages.
How to export data
1. Launch Control Center. To learn more about the different launch methods, see Starting Control Center on
page 7.
2. From the top menu, select Admin > Export.
The Export Scene(s) dialog box appears.
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3. Enter the path where you want to export the files. You can also use the Browse button to select the
path and create a folder. The destination must be an existing empty folder or a new folder that will be
created during the export process.
4. Click Add to select the scenes that you want to export from the Harmony database. You can select a
job to select all the scenes in the job. The scenes you select will appear in the list.
5. Select one or more scenes and click Remove to remove scenes from the export list.
6. In the Data Options tab, select what you want to export:
Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements in the scene.

Databases

If you select this option and deselect the Elements option, you can
access the elements from the Element Manager in the Control
Center, but their drawing and bitmap files will not be included.
The list of available versions in the scene is also exported. It is not
possible to open a scene if this is not selected for export.
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Final Frames

Exports the directory that contains the final, rendered frames.

Element

Selected by default, this option exports the contents (drawing and
bitmap files) of the Element directories.

Timing Drawing

Selected by default, this option exports the contents of the Timing
directories.

Other Directories

Exports all other directories and files in the scene's data structure.

Annotation

Lets you export the different drawings created while drawing in
the Annotation columns and imported images.
Selected by default, this option exports the Control Center
directory, which contains the Control Center files for each scene
you export. These files are necessary if you want to reuse the
exposure sheet (timing) and the node structure from the original
scene.

Stage

If this option is selected, you can select the Get Outside Drawings
option to copy drawings into the scene folder that is referred to
by the Timing columns and their Element (Drawing) nodes.
Exports the palette-library directories. Decide if you want to
export the palette-library from the environment, job or scene
level. When you select a level, the palette-library in lower-level
directories will also be exported.

Palette

This also exports the palette-list file which is necessary for the
scene to know which palettes to use. In most cases, you should
select this option as well as the Scene option.
Macros

Exports the macros (customized effect and node connections) that
were created and stored in the environment, jobs or scenes to be
exported. This is necessary if you have legacy scenes with macros.

Library

Exports templates created at the selected levels.

7. In the Advanced Options tab:
‣

Windows: Due to constraints in the operating system, you do not have any choices on the Advanced
Options tab. In Linux, you can make the following selections.

‣

(Mac OS X and Linux): Select how you want to package the exported scene. The choices you make
here are related to the size of the export package as well as the speed of the export process. In Linux,
you can make the following selections.
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‣

Select one of the following options in the Exporting Files section:

Parameter

Description
Speeds up the export process by making hard links to the original
files on the file system. Hard links keep disk space usage to a
minimum and ensure a quick export process.

As hard links if possible, otherwise copy

If it is not possible to create hard links (because the links cross file
systems, for example), the entire contents will be copied to the
destination directory, which will be a slower process that will take
up more space on your file system.

As hard links when possible, otherwise

Ensures a quicker export process. However, if symbolic links are
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symbolic links

used and the original file is deleted, the symbolic link will be
broken.

As symbolic links

Exports the scene using symbolic links to the original scene files
(when importing, imports the scene using symbolic links to the
export directory). While this process will reduce the size of the
export directory, if the original file is deleted, the symbolic link
will be broken.

Copy

Copies all scene data to the export location. This produces the
largest export package and therefore takes the longest to complete. However, it is the simplest method.

8. In the Valid Links Options section, select one of the following options:
Parameter

Description

Keep them

Maintains symbolic links.

Resolve them

Removes symbolic links, replacing them with the actual files. When
you use this option, the export package will contain real files, rather
than symbolic links.

Ignore them

Does not include valid symbolic links in the export package.

9. In the Broken Links Options section, select of the following options:
Parameter

Description

Keep them

Keeps symbolic links to missing files. When the missing files are
placed in the path searched by the symbolic link, broken links will be
valid again.

Ignore them

Does not include broken symbolic links in the export package.

10. Click Calculate to get a preview of the size of your export package.
11. Click Export.
The selected files and components are exported. Use the Message Log tab to view messages generated
during the export process.
Unlike Windows, where the database information and scene data have been copied to a different
directory, Linux creates a set of links to the data. You must use additional Linux commands to retrieve the
animation data pointed to by the links.
How to export your files to a storage device on Linux
1. Open a Linux shell and log in to the machine that connects to the storage device.
2. Copy the exported files using links from the source directory to the selected destination file. To export to
a file on a storage device, type the following command in a shell:
tb_backup_export_data -from [source_directory] -to [destination_file] writetarfile
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‣

Where [source_directory] is the folder where the scene was exported to.

‣

Where [destination_file] is the file that will be created by the tb_ backup_export_data script.

3. After a successful copy of the exported data, remove the temporary export directory using the following command:
tb_remove_export_data [export_directory]
‣

Where [export_directory] is the folder where the scene was temporarily exported to before it was
copied to the file or storage device.

How to import files into Control Center
1. Select Admin > Import.
The Import Scene(s) dialog box appears.

2. Any supported Stage file can be imported, including IEContents.dat files. The IEContents.dat
file includes database and scene file information. Specify the path of IEContents.dat for the scene(s)
you want to import.
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3. Click Browse to select the environment, job and file system where you want to place the imported scene.
4. If you want to import only some of the scenes in the Scenes to Import list box, select the scenes. If no
scenes are selected, all scenes will be imported.
5. In the Data Options tab, select what you want to import.
Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements in the scene.

Databases

If you select this option and deselect the Elements option, you can
access the elements from the Element Manager in the Control
Center, but their drawing and bitmap files will not be included. The
list of available versions in the scene is also exported. It is not
possible to open a scene if this is not selected for export.

Final Frames

Exports the directory that contains the final, rendered frames.

Element

Selected by default, this option exports the contents (drawing and
bitmap files) of the Element directories.

Timing Drawing

Selected by default, this option exports the contents of the Timing
directories.

Other Directories

Exports all other directories and files in the scene's data structure.

Annotation

Lets you export the different drawings created while drawing in the
Annotation columns and imported images.

Stage

Selected by default, this option exports the Control Center directory,
which contains the Control Center files for each scene you export.
These files are necessary if you want to reuse the exposure sheet
(timing) and the node structure from the original scene.
If this option is selected, you can select the Get Outside Drawings
option to copy drawings into the scene folder that is referred to by
the Timing columns and their Element (Drawing) nodes.

Palette

Exports the palette-library directories. Decide if you want to export
the palette-library from the environment, job or scene level. When
you select a level, the palette-library in lower-level directories will also
be exported.
This also exports the palette-list file which is necessary for the scene
to know which palettes to use. In most cases, you should select this
option as well as the Scene option.

Macros

Exports the macros (customized effect and node connections) that
were created and stored in the environment, jobs or scenes to be
exported. This is necessary if you have legacy scenes with macros.

Library

Exports templates created at the selected levels.
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6. In the Advanced Options tab, select how you want to import the scene. Select one option in the Valid
Links Options and the Broken Links Options section.
7. Click Import.
If the scene already exists, the Scene Exists dialog appears.
8. Click Import Scene for each scene or Import All Scenes to confirm your selection.
9. Use the Message Log tab to view messages generated during the import process.
If the name of the scene you are importing in Control Center is too long, you will be prompted with an
error message stating that it will be truncated. A scene's name cannot exceed 23 characters.
If you are importing scenes that were exported from the Harmony Network, or worked on in Harmony
Stand Alone, the system will try to retrieve the version name.

Control Center Commands
This section describes all the commands in the Control Center window.

Control Center Commands
The Control Center menu commands let you access the information about the application and quitting on Mac
OS X.
Command

Action

Access Methods

About Toon Boom Mac OS X: Displays product, version,
Harmony
licensing and copyright information.
Quit

Mac OS X: Closes the Control Center
window and ends the current session.

⌘ + Q.

File Commands
The File menu commands let you access the Log file and exit the application on Windows/Linux.
Command

Action

Access Methods

Exit

Windows/Linux: Closes the Control Center
window and ends the current session.

Ctrl + Q

View Log

Lets you view errors and warning messages
related to your actions during the current
Control Center session.

Environment Commands
The Environment menu commands let you manage the environments and queues.
Command

Action

Access Methods

Change Asset
Lock

Enables or disables the automatic Global
Lock on the scenes under the selected
Environment.

Right-click on the selected environment in
the Environments list and select Change
Asset Lock.
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Create

Opens a Create Environment dialog box,
where you can enter a name for a new
environment.

Right-click on the Environments list and
select Create.

Delete

Lets you delete an environment from the
database. You cannot delete an
environment unless it is empty; delete all of
the environment's scenes and jobs before
activating this command.

Right-click on the Environments list and
select Delete.

Render Queue

Opens the Render Queue dialog box where
you can monitor and prioritize the progress Right-click on the Environments list and
of the drawings that the system is
select Render Queue.
rendering.

Vectorize Queue

Opens the Vectorize Queue dialog box
where you can display the progress and
prioritize the drawings that the system is
converting to the TVG vector file format.

Right-click on the Environments list and
select Vectorize Queue.

Job Commands
The Job menu commands let you manage the jobs and their state.
Command

Action

Access Methods

Change Priority

Opens the Choose New Priority dialog box
where you can set the priority of the
rendering and vectorizing tasks for one or
Right-click on the Jobs list and select Change
more jobs. The priority is set using a sliding Priority.
scale where 0 is the highest priority and 10
is the lowest.

Change Stage

Opens the Change Stage of Jobs dialog
box where you can record the current stage
of the environment's jobs in the production
Right-click on the Jobs list and select Change
process. You can change the job from In
Stage.
Production to Completed, or from
Completed back to In Production if you
need to perform further work.
Opens the Create Job dialog box where
you can add a new job to the selected
environment.

Create

Delete

Your job must have a name that is unique to Right-click on the Environments list and select
Create.
the animation database (for example, you
cannot have two jobs with the same name
even if they exist in different environments;
they are all in the same database).
Removes a job from the selected
environment. When a job is deleted, its
Right-click on the Jobs list and select Delete.
scenes, elements, drawings, palette library,
and database information are permanently
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removed. If you want to archive a job, you
should only delete the job after you have
used the command to create the archive.
Before you activate this command, verify
that the selected jobs are not currently in
use.

Scene Commands
The Scene menu commands let you manage the scenes.
Command

Action

Access Methods

Change Priority

Opens the Choose New Priority dialog box
where you can set the priority of the
rendering and vectorizing tasks for one or
more scenes. The priority is set using a
sliding scale where 0 is the highest priority
and 10 is the lowest.

Right-click on the Scenes list and select
Change Priority.

Activating this command affects all
subsequent scenes you create. You can
change the priority of a scene already sent
to the batch processing queue by using the
Change Priority button in the queue.

Change Stage

Opens the Change Scene Stage dialog box
where you can record the current stage of
progress in a scene in an environment or a
production.

Right-click on the Scenes list and select
Change Stage.

This command is inactive if the scene's
approval policy has been set to Manual in
the Change Approval Policy dialog box.
Deletes a scene's exposure sheet. Only
exposure sheet files are deleted from the
database, not image files.

Clear

A delete confirmation message appears,
detailing the consequences of using this
option and requests that you contact your
Technical Director if you are unclear about
this procedure.

Right-click on the Scenes list and select
Clear.

Before you activate this command, make
sure that all users are logged out of Toon
Boom Harmony and that no files are
currently in use.

Copy Scene

Opens the Copy Scene dialog box where
you can copy a scene's exposure sheet into
another scene. You can select a source and
destination scene in which to copy the
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Xsheet data.
Opens the Create Scene dialog box where
you can add one or more scenes to the
selected job. You can also choose to:
Create

•
•

Right-click on the Scenes list and select
Add a scene from another file system
Create.
and add it to your job.
Choose the position the scene will
take within the job.

Removes a scene from the database. Before
you activate this command, make sure all
users are logged out of Toon Boom
Harmony and that no files are currently in
use.

Delete

When a scene is deleted, its exposure
sheet, elements, drawings, palette library
Right-click on the Scenes list and select
and database information are permanently Delete.
removed. If you want to archive a scene, you
should only delete the scene after you have
used the command to create the archive.
Before you activate this command, verify
that the selected scenes are not currently in
use.
Unlocks a scene was locked in Stage.
Generally, a scene unlocks when it is closed
by a user. However, if a computer crashes
while a scene is locked and in use, a scene
may remained locked even if it is not open.

Force Unlock

An unlock confirmation message appears
detailing the consequences of using this
option.

Right-click on the Scenes list and select
Force Unlock.

If you activated this command for more than
one scene, you will be prompted for
confirmation to unlock each scene
separately.

Force Unlock
Version

Unlocks a version of a scene that has been
locked by Stage. Generally, a scene unlocks
when it is closed by a user, however if a
computer crashes while a scene is locked
and in use, a scene may remained locked
even if it is not open.
An unlock confirmation message appears
detailing the consequences of using this
option.
If you activated this command for more than
one scene, you will be prompted for
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confirmation to unlock each scene
separately.

Move

Opens the Move Scene dialog box where
you can move one or more scenes and their
associated files to a file location of your
choice. The Move Scene command allows
you to select one or more scenes and
calculate the amount of space you will need
at the new location to accommodate the
moved scene.

Right-click on the Scenes list and select
Move.

Before you activate this command, make
sure all users are logged out of Toon Boom
Harmony and that no files are currently in
use.

Rename

Opens the Rename Scene dialog box where
you can enter a new name for the selected
scene. Before you activate this command,
Right-click on the Scenes list and select
verify that no users are using the scene, all
Rename.
users are logged out of Toon Boom
Harmony and that no files are currently in
use.

Reorder

Opens the Reorder Scenes dialog box
where you can change the sequence of the
scenes in a job.

Opens the Composite dialog box where
Send to Rendering you can add one or more scenes to the
rendering queue.

Right-click on the Scenes list and select
Reorder.
Right-click on the Scenes list and select
Send to Rendering.

Send to
Unvectorize

Opens the Send Scenes to Unvectorize
dialog box where you can convert a scene's
vector drawings into bitmap drawings.

Right-click on the Scenes list and select
Send to Unvectorize.

Send to Vectorize

Converts the Send to Vectorize command
to convert the selected drawings to the
TVG vector file format.

Right-click on the Scenes list and select
Send to Vectorize.

Element Commands
The Element menu commands let you vectorize and unvectorize the elements.
Command

Action

Access Methods

Send to
Unvectorize

Opens the Send Elements to Unvectorize
dialog box and converts an element's
vector drawings into bitmap drawings.

Right-click on the Elements list and select
Send to Unvectorize.

Send to Vectorize

Converts the drawings for the selected
elements to the TVG vector file format.

Right-click on the Elements list and select
Send to Vectorize.
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Drawing Commands
The Drawing menu commands let you vectorize and unvectorize the drawings.
Command

Action

Access Methods

Send to
Unvectorize

Opens the Send Drawings to Unvectorize
dialog box and converts selected vector
drawings into bitmap drawings.

Right-click on the Drawings list and select
Send to Unvectorize.

Send to Vectorize

Vectorizes the selected drawings.

Right-click on the Drawings list and select
Send to Vectorize.

Admin Commands
The Admin menu commands let you import and export scenes, and manage the users and approval policy.
Command

Action

Change Approval
Policy

Opens the Change Approval Policy dialog
box where you can select a manual or
automatic approval of the production status
at each stage of each scene.

Export

Access Methods

Opens the Export Scenes dialog box where
you can transfer copied data from the
database to a different directory.
You can also export scenes to Stage (offline
version) by selecting Export Offline.

Import

Opens the Import Scenes dialog box where
you can transfer copied data from another
directory into the database.

Users

Opens the User List dialog box where you
can display all valid Toon Boom Harmony
users in the network. You can add, delete,
or modify users in this list.

Vectorize Style

Opens the Vectorization Styles dialog where
you can select the vectorization style you
want to apply to drawings before sending
them to the vectorization queue.

Help Commands
The Help menu commands let you access the Help files and Control Center About information when using
Windows/Linux.
Command

Action

Access Methods

Help

Lets you view the Control Center integrated
help system.

F1

About

Windows/Linux: Displays product, version,
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Command

Action

Access Methods

licensing and copyright information.
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Chapter 3: Web Control Center

Web Control Center is a web version of the Control Center for freelancers to connect to a studio's Harmony
database and download scenes to work on them remotely. Scenes can be uploaded when ready and merged
back on the server.
The Web Control Center can also be used inside a studio instead of the Control Center to make use of the movie
previews and thumbnails for each scene in the database.
This chapter is divided as follows:
•

Connecting to Web Control Center on page 53

•

Centralized Data, Checking Out and Global Locking on page 10

•

Managing Harmony Users on page 11

•

Managing Environments, Jobs and Scenes on page 17

•

Exporting and Importing Data on page 38

•

Control Center Commands on page 46

Connecting to Web Control Center
To access Web Control Center to exchange scenes as a freelancer or manage the database structure as an
administrator, you need to open a web browser and enter the given Web Control Center URL. The URL must be
set by the studio's IT department. Refer to the Harmony Server Installation Guide for details on how to install and
set up the Web Control Center.
Note that if the Web Control Center application is not running, you will not be able to connect to it.
When installing Harmony Server, a default user is created called usabatch. The password is also usabatch.
When you log in for the first time, use this username and password. Once logged in, you can create a set of users.

NOTE:
• Do not delete the usabatch username as it is used by Harmony Server for batch processing.
•

It is highly recommended to change the password.

How to connect to Web Control Center
1. Open a web browser.
2. In the Address bar, type the Web Control Center URL provided by the studio you are working with.
‣

If you are an administrator viewing the Web Control Center instance installed on your machine, enter
localhost:8080. 8080 is the default port. If you modified it, enter your custom port number in place
of 8080.

53

Chapter 3: Web Control Center

‣

If you are testing the connection from a different machine connected to the same local network,
enter [name of machine]:8080 or the custom port number you previously set.

The Web Control Center page opens.

3. In the Username field, type the username assigned to you by the studio. If you are an administrator,
enter the administrator username.
4. In the Password field, type the password assigned to you by the studio. You can change your password
later. If you are an administrator, enter the administrator password.
5. Click Login.
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User Interface

The Web Control Center interface is divided into several areas:
Parameter

Description

Top menu

Contains all the commands available in Web Control Center. You can also find
the commands in the contextual menus available in each area by right-clicking.

Environments

Displays one of your projects, such as a feature film, a TV series or a group of
TV spots.

Jobs

Displays the sequences or episodes in your project (Environment). You can only
see your jobs when you select a project from the Environments list.

Scenes

Displays the scenes in an episode or sequence (Job). You can only see your
scenes when you select a job from the Jobs list. You can also see who checked
out the scene, as well as the number of versions and frames.
Click the Add Column button to add information columns to the scene list such
as Current Version, Frames, Checkout User and Priority.
Displays information of a selected scene, such as the name, priority, technical
director and user who checked the scene out.

Scene Information

You can also preview the scene's thumbnail and rendered clip of selected
scenes. When you select a scene that has no thumbnail available, the request is
sent to the Harmony database to create it. But first, batch processing must be
enabled on the Web Control Center server. If not, nothing will happen. For
more information, see Batch Processing in the Harmony Server Installation
Guide to learn how to set it up.
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NOTE: When navigating, click the Return to Scene list button in the top bar to return to the main page.

Centralized Data, Checking Out and Global Locking
When working with Harmony Server, all scenes and their data are stored directly on the database; no data is
saved or stored on the client machine. The client machines access the database and load the scenes and
drawings directly from the server. Each time the user saves a scene, the data is updated directly on the server.
There are no upload or download operations done between the server and the clients. However, when
working with the Web Control Center, users must download and upload scenes to the Harmony database.
Harmony has a lock system, referred to as global lock, for the different scenes and scene assets. Since all data
on the server can be accessed directly and modified from any client machine, by default, scenes are locked and
users must get the rights to modify them in order to save their work onto the server. Only one user at a time
can modify a scene. Once a scene is opened on a client machine, other users can open the scene in read-only
mode if they need to consult it, but they will not be able to save any modifications.
In the Web Control Center, when a scene is downloaded locally by a user, global locking does not apply as it
will be modified in Harmony Stand Alone. To ensure that scenes are not simultaneously modified and causing
conflicts, scenes downloaded through the Web Control Center can be checked out by a user. When scenes are
checked out, they can be opened in read-only mode in Harmony Server.
Global lock has several levels:
A Harmony project can be locked at various levels. Its timing, drawings, version and palettes can be locked.
Locking means that you have the rights to modify a scene or its assets. Other users cannot modify locked
items. If someone tries to open a locked scene, it will be displayed as read-only.
Here are the different lock possibilities:
Lock

Description

Scene or Version Lock

Controls the Xsheet timing, layers, nodes but not the drawing, palettes,
palette-lists or templates.

Drawing Lock

Only one user can edit and save a locked drawing.

Palette Lock

Only one user can edit and save a locked palette.

Palette-list Lock

Only one user can edit and save a locked palette-list.

Library Folder lock

Only one user can edit and save into that folder in the Library.

There are several different ways to obtain the rights to modify the scenes. It can be done when the user loads a
scene from Harmony, inside the application once the scene is loaded, or when an environment, job or scene is
created using the Control Center module.

Managing Users
In an animation studio, there are usually several people using Harmony who will probably be assigned different
tasks, such as ink and paint or compositing. Normally, you should create a different user for each one. This
way, the person assigned to ink and paint will only have access to the Paint module and not to other features
that are not relevant to their work.

56

Harmony 12.1 Control Center Guide

Anyone who uses Harmony must have a login name in order to run any of the modules. When using Harmony in
standalone mode, there are no username or password required. The Harmony login is independent from the
computer session login.
Users connecting to the database through Web Control Center should have a password as it's safer for accessing
via the Internet. For Web Control Center users, it is recommended to create the users through Web Control
Center so you can set the password.
On Windows, by default, only the usabatch and BATCH users are created. However, you should not use them
for your staff. These should be kept for Harmony Server when performing background operations, such as batch
processing—see Creating a Default User for Batch Processing on page 17.

IMPORTANT: Before making the Web Control Center public, set passwords for all users so no one can delete
everything.

All Harmony users must have their name on the user list to log in to any application. The system uses the login to
track activities; it is not a security lockout.
Each login also has a user "type" assigned to it which allows access to only some of the Harmony modules.
As your studio network grows and evolves, you may need to delete old or obsolete user profiles from your
system. After you delete a user profile, the person who used that profile will no longer be able to access
Harmony. You cannot delete yourself from the user list. If you accidentally delete a name, you must follow the
procedures for adding a user to get the name back into the system.
You can modify the user profiles at any time to update the user information.

NOTE: To change your own user profile, log in as usabatch (the default user).

If new users were created through the Control Center module while working in Web Control Center, you can
refresh the list to get the most up to date information.
How to view the user list
1. Select Admin > Manage Users.
The Manage Users screen displays a list of users in the system.

2. Select a user from the list.
The user information is displayed on the right.
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3. When you are finished, click Return to Scene List at the top-left of the screen.
How to add a user to Harmony
1. Select Admin > Manage Users.
2. In the upper-right corner of the Manage Users screen, click Add User.
The Create New User section displays.

3. In the New username field, enter the person's user name.
4. Type the person's first name and last name in the corresponding First Name and Last Name fields. If you
want leave the field blank, enter a space.
5. In the Type list, select the user type to define the type of work the user typically performs. This will
restrict access to certain Harmony modules and operations in the Control Center—see User Types and
Restrictions on page 60.
General users should be set to Animator, Xsheet, Scan or Ink & Paint so they can't delete environments,
jobs or scenes.
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6. For the password, do one of the following:
‣

To set a password (recommended), select the Set Password option and enter a secure password in
the New Password field. The user has the ability to modify the password later on.

‣

If you do not want the user to have a password, deselect the Set Password option and go to step 8.

7. In the Confirm New Password field, retype the password to confirm it.
8. Click Create.
The name appears in alphabetical order in the user list.
How to delete a user
1. Select Admin > Manage Users.
2. In the Manage Users screen, right-click on a user to delete and select Delete User.
The Confirm dialog box opens.
3. Click OK.
How to modify user information
1. Select Admin > Manage Users.
2. In the Manage Users screen, select the user to modify.
The Editing [username] section appears.
3. Modify the information as required.
4. Click Apply.
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How to refresh the user list
1. Select Admin > Manage Users.
2. In the Manage Users screen, right-click on the user list and select Refresh List.

User Types and Restrictions
Here are the different user types available and their restrictions:

Feature

Web
Control
Control
Center
Center

RND,
Coordinator,
Supervisor,
TD,
Executive

Animator

Xsheet,
Archive

Scan

Ink &
Paint

Create Environment

•

•

•

Change Asset Lock on Environment

•

•

•

Delete Environment

•

•

•

View Vectorize Queue

•

•

•

•

•

•

View Render Queue

•

•

•

•

•

•

Create Job

•

•

•

•

Change Job Priority

•

•

•

•

•

•

•

Change Job Status

•

•

•

Delete Job

•

•

•

Create Scene

•

•

•

•

•

Delete Scene

•

•

•

Unlock scenes locked by
another user

•

•

•

Unlock scene version locked
by another user

•

•

•

Unlock scenes locked by me

•

•

•

•

•

Unlock scene version locked
by me

•

•

•

•

•
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•

Move Scene

•

Rename Scene

•

•

•

Clear Scene

•

•

•

Change Scene Priority

•

•

•

Change Scene Status

•

•

•

Reorder Scenes

•

•

•

Copy Scenes

•

•

•

•

Send to Vectorize

•

•

•

Send to Unvectorize

•

•

Send to Rendering

•

Add/Modify/Delete Users

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

•

Change Approval Policy

•

•

•

Change Vectorize Style

•

•

•

•

•

•

Change Asset Lock

•

•

Database Lock Manager

•

•

Export Scenes

•

•

•

•

•

Import Scenes

•

•

•

•

•

View Error Log

•

•

•

•

•

•

•

View Elements

•

•

•

•

•

•

View Drawings

•

•

•

•

•

•

Open in Control Center

•

•

•

•

Open in Paint

•

•

•

•

•
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Open in Scan

•

•

•

•

•

•

Managing Environments, Jobs and Scenes
Every project you create with the Harmony solution starts with an environment, the highest level in the Web
Control Center. After that, you can add jobs and scenes. Elements (layers and columns) and drawings can only
be created directly in Stage when working with the Web Control Center.
The Web Control Center divides your animation project into the following categories which organize the
components of your animated projects:

•

Environment: This is the name of your animation project.
Example: adventure_movie

•

Jobs: These are the major sections of an environment, such as sequences or episodes.
Example: adv_seq_001, adv_seq_002

IMPORTANT: All jobs are stored in the same location in the Harmony database. Be sure to prefix all job names
appropriately, so you can identify the project in which it belongs. Each job must have a different name. You cannot
give two jobs the same name.

•

Scenes: These are the different shots in a job.
Scenes are contained in their respective job folder in the Harmony database. If desired, prefix all scenes
names appropriately, so you can identify the environment and job to which they belong.
Example: adv_sc_001, adv_sc_002, adv_sc_003 and so on.

As your projects come and go, you will probably want to start cleaning up your database, as well as your
server's hard drive, by removing old and obsolete environments and their associated animation data.
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IMPORTANT: After you delete a scene, job, or environment, the associated data is permanently removed from your
storage disks. Make sure you really want to erase these items before you delete them as there is no way to retrieve
the data after it has been erased.

You might want to export old environments and archive them somewhere else before you delete them from your
system.

NOTE: If you are working in a mixed Windows/Mac OS X/Linux environment or share files with other studios that do,
you should use lowercase letters to name the various items in your animation projects and not include any spaces. For
example, write the_show instead of The Show. This is useful for Linux because it is case-sensitive whereas Windows
is not.

Managing Environments
Harmony uses environments to manage and organize related projects. Using environments allows you to
organize your production projects by their nature or type.
If your projects center around episodic and commercial types of work, you can create two environments. For
example, one environment called commercials and the other called the_show. Then you can insert the jobs
that relate to each type of project. When you want to work on a commercial project, open the commercials
environment and select the commercial job you need. Similarly, if you want to work on an episodic project, open
the environment called the_show.
Environment

Job
sc_001
dentist
sc_002

commercials
soda

sc_001

cereal

sc_001
sc_001

sho_001
sc_002
the_show

sho_002

sc_001
sc_001

dentist
sc_002
When you are ready to remove old environments, you can delete them from the database. However, in order to
prevent accidental loss of data, you can only delete an empty environment (one that contains no jobs, images, or
palette information).
How to create an environment
1. From the top menu, select Environment > Create.
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In mixed platform Environments (Windows/Mac OS X and Windows/Linux) it is best to name everything
in lowercase so data can be interpreted the same way on each operating system. The same is true if
working between studios using Windows, Mac OS X, and Linux.
The Create Environment dialog box appears.

2. In the Create Environment field, enter a name for the new project.

NOTE: The environment name is alphanumeric and can include underscores (_), but no spaces or other special
characters. The environment name is case sensitive.

3. To grant the user with the rights to modify all the scene assets (drawing, scene setup, palette lists, etc.),
select the Change Asset Lock option.
4. Click Create.
The new environment appears in alphabetical order in the Environments list.

NOTE: After you create an environment, you must add it to the Batch Processing queue so it can vectorize and
render the drawings and scenes automatically. You only need to do this once. You can only do this in a shell with
the Setdef command.

How to delete an environment
1. In the environment section, select the environment to delete from the Environment list.
2. Select Environment > Delete.
The Confirm dialog box appears.
3. Click OK.

Managing Jobs
Within each environment is a list of jobs that contains all the segments for your animated sequence. If you are
creating a weekly television series called The Show, you could name your job show_ep_06 (the_show
would be the name of your environment).
If each episode is composed of 100 animated shots, each job would contain 100 scenes.
Each job must have a unique name. Two jobs cannot have the same name, even if they appear in two different
environments, because all the jobs are in the same folder on the server.
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As you complete your animation project, you can update a job's status to reflect its progress in the overall
production. You can indicate a job as being in production or not. If a job is in production, other modules can still
access this job. If a job is no longer in production, it means the job is completed. The Harmony database still has
all the job's components (scenes, elements, drawings), but the job neither appears nor is accessible from the
Harmony applications.
In most cases, a job is no longer in production after it has been finalized (inked, painted, rendered) and
transferred to a medium, such as Blu-ray, or sent to post-production. However, if you need to continue working
on a job, you can revert its status at any time.
Before sending a job's scenes to be vectorized or rendered, you can set their priority level for the processing
queue. Increasing the priority of a job makes the system process it before other jobs in the queue. For example, if
job B is before job A in the queue, you can change the priority, so job A is processed first.
Changing a job's priority does not affect the vectorizing or rendering of jobs already sent to the queue. It will only
affect jobs that are sent after the priorities were changed.
When you no longer need a job, you can delete it. Doing so will permanently remove the following:
•

Scenes

•

Elements

•

Drawings

•

Database information associated with the selected job

•

Palettes stored under the selected job

Before you delete a job:
•

Make sure no one else is currently using the job. Failure to do this may result in file corruption and loss of
your work.

•

Wait until everyone is offline. This ensures no one can open the data files while you delete them.

IMPORTANT: You cannot archive a job by deleting it. To archive a job, export first and save it to a secure location to
be stored permanently.

NOTE: You cannot delete a job if it still contains scenes.

How to create a job
1. From the Environment list, select the project in which you want to create a job.
2. Select Job > Create.
The Create Job window opens.
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3. In the New Job Name field, enter the name of the job to create.

NOTE: The job name is alphanumeric and can include underscores (_), but no spaces or other special characters.
The job name is case-sensitive.

4. From the Technical Director list, select a technical director (TD). The names available are generated
from a list of all possible users by their login username. You must select a TD to create the job.
A TD is usually the person who oversees the animation project and makes sure the work is done
properly. Select the person who most closely resembles this definition. If you do not have a particular
user for the task, you can simply assign this field to: BATCH.
When creating Harmony users, you can label a user as a TD.
5. From the Assistant Technical Director list, select an assistant technical director (ATD). The names available are generated from a list of all possible users by their login username. You must select an ATD to
create the job. If you do not have an ATD, select the same person for the TD and ATD jobs. In some studios, the responsibilities of the TD can be shared by more than one person. This second person is the
ATD.
6. From the Approval list, select how Harmony will mark the various stages that the scenes will pass
through in your production schedule.
‣

Automatic: When you work on scenes, Harmony automatically approves their status at each stage.

‣

Manual: When you work on scenes, the TD or ATD must approve their status at each stage using
the Change Status command in the Scene menu.

7. Adjust the Priority slider to increase or decrease the job's priority (0 means the job has the highest priority for processing through the Vectorize or Render queue, and a job with a priority of 10 is the least
important). Jobs with higher priorities pass in front of other projects with lower priorities in the rendering and vectorizing queues.
If you do not know what priority to assign to your project, leave it at 5. You can always change it later.
8. Click OK.
Web Control Center adds the new job to the selected environment; it appears in alphabetical order in
the Jobs list.
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How to change the status of a job
1. From the Environment list, select an environment.
2. Select Job > Change Status.
The Change Status window opens.

3. Deselect any completed jobs and close the window.
The deselected jobs no longer appear in the Jobs list.
How to change a job's priority
1. From the Environment list, select the environment with the job whose priority you want to change.
2. From the Job list, select a job.
3. Select Job > Change Priority.
The Change Priority window opens.

4. Adjust the slider to increase or decrease the priority (0 means the job has the highest priority for processing through the Vectorize or Render queue. A job with a priority of 10 is the least important). Jobs
with higher priorities will pass in front of other projects with lower priorities in the queues.
5. Click OK.
When you send this job to be vectorized or rendered, it will have this new priority in the processing queue.
How to delete a job
1. From the Environment list, select the environment with the job you want to delete.
2. From the Job list, select a job to delete.
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3. Select Job > Delete.
4. Click OK.

Managing Scenes
After you create a scene, you can view some of the scene information in the Scenes list, such as the version,
number of frames and status.

NOTE: It is useful to have at least one Display node in your scene as it dictates what is displayed in the movie and
thumbnail of the selected scene.

NOTE: Add more categories to the Scenes list by clicking the plus (+) icon at the top-right corner and selecting
items to view—see Scenes List on page 82.

When creating scenes, you must indicate where you want to store the scene data and where you want the new
scene to appear in the Scenes list. You can create a single scene or multiple scenes at the same time.
When deleting a scene, you remove the scene from the Web Control Center window, as well as permanently
removing all the information associated with the scene including:
•

Exposure sheet (and all associated versions)

•

Elements

•

Drawings

•

Database information

•

Any palettes stored in that scene's palette library

Before you delete a scene:
•

Be sure you really want to remove all this information from the system.

•

Are you going to use the scene in the future?

•

Do you need to archive the scene for future use?

•

Make sure no one else is currently using the scene. Failure to do this may result in file corruption and
loss of work.

•

Wait until everyone is offline. This ensures no one will open the scene as you are trying to delete it.
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NOTE: When selecting scenes from the Scenes list, there is a delay for the first preview/thumbnail update because it
is done in batch render.

How to create a scene
1. From the Environment list, select the environment with the job in which you want to add scenes.
2. From the Job list, select the job in which you want to add scenes.
3. Select Scene > Create.
The Create Scene window opens.

4. In the first field, enter the name of the scene to create.
5. To create additional scenes, do one of the following:
‣

Click the plus (+) sign and enter a name.

‣

Press Enter/Return.

Repeat until you have the required number of scenes.

NOTE: When creating a new scene or renaming a scene, the scene's name cannot exceed 23 characters. Job and
scene names are alphanumeric and can include underscores (_), but no spaces, or other special characters. All names
are case-sensitive.

6. From the File System list, select the path where you want to store the files.
If you are unsure which hard drive to select, consult your technical director or system administrator.

NOTE: Although you can add as many scenes as you want, you can only select one path at a time. Therefore, the Web
Control Center stores all scenes you create in one session at the same place (same path).
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7. Select where you want to place the scene(s) in the Scenes list from the Add Scene(s) list:
‣

At Bottom: Places the new scenes at the bottom of the list.

‣

At Top: Places the new scenes at the top of the list.

8. Click Create.
The new scene(s) are created and displayed in the Scene list. If you do not want to create the scene(s),
click the close button (x) at the top-right corner of the Create Scene window.
How to delete a scene
1. From the Scenes list, select a scene name to delete.
2. Do one of the following:
‣

Select Scene > Delete.

‣

Right-click and select Delete.

The Confirm dialog box appears.
3. Click OK.
The scene name all its associated files are deleted.

Renaming Scenes
As you work on scenes, their nature and content may change and the name of the scene may no longer be
relevant. When this happens, you can rename the scene.
Before renaming a scene:
•

Make sure no one else is currently using the scene. Failure to do this may result in file corruption and
loss of your work.

•

Wait until everyone is offline. This ensures no one can open the scene while you rename it.

How to rename a scene
1. From the Scenes list, select a scene to rename.
2. Do one of the following:
‣

Select Scene > Rename.

‣

Right-click and select Rename.

The Rename Scene window opens.

70

Harmony 12.1 Control Center Guide

3. Enter the new scene name and click Rename.

NOTE:
• Use lower case letters if the scenes may be used with a Windows workstation.
•

When creating a new scene or renaming a scene, the scene name cannot exceed 23 characters.

Reordering Scenes
You can change the sequence of scenes in your job, which affects the order in which the scenes appear in the job
throughout the system. You can place a scene anywhere in the Scenes list or sort them alphanumerically.
How to reorder a scene
1. Select a scene from the Scenes list.
2. Select Scene > Reorder.
The Reorder Scenes window opens.

3. Drag a scene up or down to reorder it.
4. Click OK.

Clearing Scenes
If you must clear a scene from Web Control Center, wait until everyone is offline to ensure no one can open the
data files while you clear them. Otherwise, there is a risk of corrupting the files and losing work.

71

Chapter 3: Web Control Center

How to clear a scene
1. From the Scenes list, select a scene to clear.
2. Do one of the following:
‣

Select Scene > Clear.

‣

Right-click and select Clear.

The Confirm dialog box appears.
3. Click OK.
The Scene list refreshes and displays blank elements and drawings lists, showing that the Web Control
Center module has deleted the exposure sheet for the scene you cleared.

Changing the Status of Scenes
Changing a scene's status and making manual approvals is a way to track its progress in your production. For
example, in a scene whose drawings are being scanned, you can set the scene status to Scan. After you begin
adding colour to these line drawings, you can change the scene status to Paint.
To change a scene's status, the approval policy must be set to Manual. You can also create customized
approval stages that reflect the approval process in your production environment—see Managing Jobs on
page 64.
How to change a scene's status
1. Select a scene from the Scenes list.
2. Do one of the following:
‣

Select Scene > Change Status.

‣

Right-click and select Change Status.

The Change Status window opens.

3. Select a status for the scene.
4. Click Apply.

Setting the Scene Priority
You can change a scene's rendering and vectorization queue priority to place it ahead of or behind other
scenes. For example, if scene B comes before scene A in the queue, change the scene's priority so scene A is

72

Harmony 12.1 Control Center Guide

processed first.
If a scene was already sent to the queue, changing the priority will not affect its priority in the queue. Changes will
only be applied the next time it is sent to the queue.

NOTE: If you want to change a scene's priority after it has been sent to the queue, you can do so using the Change
Priority button in the Queue window in the Control Center module—see Viewing the Render Queue in the Harmony
Server Installation Guide.

How to change the scene priority
1. Select a scene from the Scenes list.
2. Do one of the following:
‣

Select Scene > Change Priority.

‣

Right-click and select Change Priority.

The Change Priority window opens.

3. Drag the slider to adjust the priority. 0 = the highest priority for processing through the Vectorize or
Render queue and 10 = a priority of 10 is the least important. Items with higher priorities pass in front of
other projects with lower priorities in the Vectorize and Render queues even if there is already a queue processing.
4. Close the window.
The new scene priority appears in the Priority column of the Scenes list.

Vectorizing Scenes
When your scene is completed, you can revectorize scanned drawings with a different vectorization style,
including TVG, greyscale, greyscale rougher lines or soft edge, and tones/highlights. You can also choose to
convert vector drawings into bitmap drawings.
If you didn't scan drawings and just did them paperless or imported them, you cannot revectorize them because
the original bitmaps are required in the scene.
How to vectorize scenes
1. Select a scene from the Scenes list.
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2. Do one of the following:
‣

Select Scene > Vectorize.

‣

Right-click and select Send to Vectorize.

The Send to Vectorize window opens.

3. Select a vectorization style for the scene.
4. Click Send to Vectorize.
How to unvectorize scenes
1. Select a scene from the Scenes list.
2. Do one of the following:
‣

Select Scene > Unvectorize.

‣

Right-click and select Send to Unvectorize.

The Send to Unvectorize window opens.

3. From the Antialiasing Quality list, select a quality level.
4. In the Antialiasing Exponent field, set the .
5. In the Resolution section, select one of the following:
‣

As Scanned to use the resolution at which the drawing was scanned.
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‣

Use Custom Resolution, then enter the desired X and Y resolution.

6. From the Output File Format list, select a format for the unvectorized scene.
7. In the Command Line field, you can enter a command from the utransform utility. For example, you can set
the background colour: -bgcolor 1.0 1.0 1.1.
8. Click Send to Unvectorize.

Rendering Scenes
When one or more scenes are complete, you can send them to the batch processing machine for rendering. You
can also use Stage to render scenes, but since you must open each scene individually in Stage, you can only send
one scene to render at a time.
How to send a group of scenes to the Render queue
1. Select the environment, job and scenes to send to the Render queue.
2. Do one of the following:
‣

Select Scene > Send to Rendering.

‣

Right-click and select Send to Rendering.

The Send to Rendering window opens.

3. In the Range section, select the frames to render:
‣

All Frames: Sends all the frames in the scene to be rendered.

‣

Selected Frames: Sends a range of frames to be rendered. You can only do this if you selected one
scene. Enter the frame range.
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4. Select the Chunk Size (Frames) option if you want to split the frames into chunks. This lets you process
frames among many stations instead of just one. Enter the number of frames in each chunk.
5. From the Version list, select the version of the scene to render.
6. From the Camera list, select the camera to render the scene's images. These are the cameras you created in Stage.
7. If you want to create a sequence of images in fields, such as in NTSC or PAL, select Enable Field Composite option and any of the following:
‣

Add Pulldown: Uses the 3:2 pulldown technique.

‣

Automatic Combine: Combines even and odd fields on a scene's image.

‣

Second Field First: Always starts with the second field before combining with the first field.

8. Click Send to Rendering.

Downloading and Uploading Scenes
Web Control Center allows you to download (export offline) scenes from a studio's Harmony database and
work on them locally from a remote location. When downloading the scene, you have the option to check it out
so it's locked; this prevents other users from modifying your scene while you are working on it. When you are
done with the scene, you can upload (import) it, merging it back in the central Harmony database.
When downloading a scene, the data is first placed in the user's exchange folder where it can then be
downloaded on the user's remote computer. The exchange folder is located in the USA_DB directory of the
Harmony database. This folder contains individual folders for each user; this is where uploaded and
downloaded scenes are stored.
You can download scenes individually or in bulk.

NOTE: When working on local scenes, do not change the folder names or structures as it will cause problems when
reimporting scenes.

When you no longer need the stored packages in the exchange folder, delete them to keep your storage space
organized.
You can view all operations and error messages related to these processes in the Log view.
If you want to upload environments, jobs and scenes for archiving, you must use the Control Center. Web
Control Center only allows you to upload and download scenes for exchange between studios and freelancers.

NOTE: Scenes cannot be uploaded or downloaded using a tablet.

How to download an individual scene
1. From the Scenes list, select a scene to export.
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2. In the Selected Scene Information section, click Export Offline.
The Export Offline window opens.

3. Select the Checkout option to lock the scene, preventing anyone from modifying the scene.
4. Click Export.
The selected scene is zipped and exported to your user exchange folder. Wait for the Export process to
complete.
5. Close the Successful Export dialog box.
6. Select File > Manage Uploaded/Exported Files.
The Exchange Manager window opens.

7. In the Files Present in your User Exchange list, click a web link to download.
How to download multiple scenes
1. From the Scenes list, select the scenes to export.
2. Select Admin > Export.
The Export screen opens. The selected scenes are listed in the List of Scenes to Export section.
‣

To add more scenes, select the environment, job and scenes to add and click Add Selected Scenes.

‣

To remove unwanted scenes, select the scene and click Remove Selected Scene.

3. To export:
‣

Click Export Offline to export your selection to your user exchange folder using the preset options.
Select the Checkout option to lock the scene, preventing anyone from modifying the scene. Click
Export.
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‣

To export your selection with custom options, click Export to Another Database. The Export with
Options window opens—see Import or Export to Another Database Options on page 82. Select the
appropriate options and click Export.

4. Close the Successful Export dialog box.
5. In the top-left corner, click Return to Scene List to return to the main page.
6. Select File > Manage Uploaded/Exported Files.
7. In the Files Present in your User Exchange list, select the Zip file to download.
How to upload scenes back to the database
1. Zip (compress) your package. It should have the exact same structure and internal naming as the package you downloaded.
2. In Web Control Center, select Admin > Import.
The Import page opens.
3. Click Add Another File to your Exchange to upload your zip file.

NOTE: You can also import your zipped packaged through the Exchange Manager by selecting File > Manage
Uploaded/Exported Files. In the Exchange Manager, click Select Zip File to Upload. Once the package is
imported, go to the Import page to push it back to the Harmony database. Select Admin > Import. Click Import to
import your package.
You can export offline many scenes in one package but when you reimport them, each scene must be in its own
individual zip package. However, if you export/import to database, you can do multiple scenes at the import.

Once the package is imported, the package details disappear.
4. Select the Checkin option to check your scene back into the Harmony database and allow other users
to modify it.
5. To import:
‣

Click Quick Import to import your scenes using the preset options.

‣

Click Import with Options to import your scenes with custom options—see Import or Export to
Another Database Options on page 82.

NOTE: If you are trying to import a scene that was checked out by another user, you will not be able to complete
the operation. A warning message will be prompted.
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How to open the Log view
1. Select Help > View Log.
The Log view opens. Green messages indicate successful operations, orange indicates warnings,
and red messages are errors or failed operations.

2. To clear all messages from the Log view, click Clear Log.

Web Control Center Reference
File Menu
Command

Description

Manage Uploaded/Exported Files

Opens the Exchange Manager, where you can upload zip files from
your computer or download zip files exported from Web Control
Center.
NOTE: This command is not available on tablets.

Environment Menu
Command

Description

Create

Lets you create an environment and set the rights for modifying scene
assets.

Delete

Lets you delete an environment from the database. This command is
only available if the environment does not contain any jobs or scenes. If
it does, they must be deleted before the environment can be deleted.

Change Asset Lock

Lets you set the rights for modifying the scene assets of a selected
environment.
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Job Menu
Command

Description
Lets you a new job to the selected environment.

Create

Your job must have a unique name in the animation database. You
cannot have two jobs with the same name, even if they exist in
different environments, as they are all stored in the same folder on
the database.
Removes a job from the selected environment.

Delete

When a job is deleted, its scenes, elements, drawings, palette library,
and database information are permanently deleted. If you want to
archive a job, you should delete the job only after you have exported
it and saved it in a secure location.
Before deleting a job, verify that it is not currently in use.

Change Approval Policy

Let you select or deselect scenes for manual approval from the TD or
ATD.

Change Status

Lets you indicate whether jobs are in production or completed. You
can always put a completed job back in production.

Change Priority

Lets you set the priority of the selected job for the rendering and
vectorization queues. 0 = highest priority, 10 - lowest priority.

Scene Menu
Command

Description

Reset List Sorting

Resets the order of the scenes in the Scenes list. Click on the Current
Version heading to order to the scenes numerically by version number.
Click again to reverse the order.

Open

Launches Harmony Stage and opens the scene in it. If it was not
previously specified, you will be asked to specify the path to the
software's executable file. If you need to change the path, you can do
so by selecting Admin > Locate Stage.
NOTE: This command is not available on tablets.
Opens the Create Scene window where you can add one or more
scenes to the selected job. You can also choose to:

Create

•

Select the file system where the created scenes will be stored.

•

Choose the position the scene will take within the job.

Removes a scene from the database. Before you use this command,
make sure the selected scenes is not currently in use.
Delete

When a scene is deleted, its exposure sheet, elements, drawings,
palette library and database information are permanently removed. If
you want to archive a scene, you should delete the scene only after
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you have exported it and saved it in a secure location.
Rename

Opens the Rename Scene window where you can enter a new name
for the selected scene. Before doing this, verify that the scene is not in
use.
Unlocks a scene or version of a scene locked in Stage.

Force Unlock

Force Unlock Version

Usually, a scene unlocks when it is closed by a user. However, if a
computer crashes while a scene is locked (in use), a scene may remain
locked even if it is not open.
If you used this command on more than one scene, you are prompted
for confirmation to unlock each scene separately.

Checks in a scene that was checked out, but not checked back in.
Force Checkin

Use this command only in extreme cases. Otherwise, two versions of
the same scene will be in use, which will cause conflicts.
Lets you set the priority of the selected scene for the rendering and
vectorization queues. 0 = highest priority, 10 = lowest priority.

Change Priority

To change the priority of a scene already sent to the batch processing
queue, use the Change Priority button in the queue through the
Control Center module.

Change Status

Lets you change the status of a scene to indicate where it is in the
animation production process.

Reorder

Lets you change the order of scenes in a job.
Lets you delete a scene's exposure sheet, network, elements and
database information. Image files will need to be deleted manually.

Clear
Before using this command, make sure that none of the files in
question are currently in use.
Send to Vectorize

Lets you revectorize scanned drawings in the selected scene to the
vector style you set.

Send to Unvectorize

Lets you convert a scene's vector drawings into bitmap drawings.

Send to Rendering

Lets you add one or more scenes to the rendering queue.

Admin Menu
Command

Description

Change Password

Lets you change your password or set an empty password (no password needed for login).

Locate Control Center

Lets you set the path for the location of the Harmony Stage executable
file on your computer.
NOTE: This command is not available on tablets.

Manage Users

Displays a list of all system users. You can add, delete or modify user
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Command

Description
information in this list.

Export

Lets you select scenes to export from the selected environment and
job.

Import

Lets you upload single or multiple project zip files to your exchange
folder and then import them.

Help Menu
Command

Description

Help on WCC

Opens the Web Control Center integrated help system.

About

Opens the About Web Control Center page which displays copyright
information.

View Log

Opens the WebCC log window which details the activity in the Web
Control Center.

Scenes List
Parameter

Description

Current Version

Displays the version number of the scene. For example, there can
be many versions of the same scene saved in the root project
folder.

Frames

Displays the number of frames in the scene. This indicates the
length of the scene. If artwork has not been created in the scene
yet, the number of frames in the Frames column displays 0.

Checkout User

Indicates the name of the individual who checked out the scene by
their login username.

Status

Indicates the status of the scene in the animation production process. The default status is left blank to indicate that the scene has
not been assigned a status. The assignable statuses are: Scan, Vectorize, Pencil Test, Paint, Sceneplanning, Camera and Completed.

TD

Displays the name of the technical director of the scene by their
login username.

ATD

Displays the name of the assistant technical director of the scene
by their login username.

Priority

Displays the priority of the scene on a scale of 0–10 (0 = highest priority, 10 = lowest priority).

Import or Export to Another Database Options
Exporting to another database makes a package with many scenes that have to be imported into another
database. You cannot open them offline as individual scenes. This is most useful when exchanging large
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quantities of scenes from one studio to another. However, a freelancer working on a limited number of scenes
may not want to create a personal database at home.

Parameter

Description

Audio

Exports the Audio directory.
Selected by default, this option exports the elements in
the scene.

Databases

If you select this option and deselect
the Elements option, you can access the elements from
the Element Manager in the Control Center, but their
drawing and bitmap files will not be included. The list of
available versions in the scene is also exported. It is not
possible to open a scene if this is not selected for
export.

Final Frames

Exports the directory that contains the final, rendered
frames.

Element

Selected by default, this option exports the contents
(drawing and bitmap files) of the Element directories.

Timing Drawing

Selected by default, this option exports the contents of
the Timing directories.

Other Directories

Exports all other directories and files in the scene's
data structure.

Annotation

Lets you export the different drawings created while
drawing in the Annotation columns and imported
images.

Stage

Selected by default, this option exports the Control
Center directory, which contains the Control Center
files for each scene you export. These files are
necessary if you want to reuse the exposure sheet
(timing) and the node structure from the original scene.
If this option is selected, you can select the Get
Outside Drawings option to copy drawings into the
scene folder that is referred to by the Timing columns
and their Element (Drawing) nodes.

Palette

Exports the palette-library directories. Decide if you
want to export the palette-library from the
environment, job or scene level. When you select a
level, the palette-library in lower-level directories will
also be exported.
This also exports the palette-list file which is necessary
for the scene to know which palettes to use. In most
cases, you should select this option as well as the Scene
option.

83

Chapter 3: Web Control Center

Macros

Exports the macros (customized effect and node
connections) that were created and stored in the
environment, jobs or scenes to be exported. This is
necessary if you have legacy scenes with macros.

Library

Exports templates created at the selected levels.
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