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Chapter 2: Toon Boom Harmony - About this Help System
Toon Boom Harmony is an animation and digital content creation tool that offers you a wide array of
features and options. Harmony is packaged in several different modules and allows you to create
animation using the technique of your choice—see About Toon Boom Harmony on page 7.
This help system is built to guide you through the different workflows possible and explains which tool
and module to use in a production context.
•

Help Structure on the next page

•

Tutorials and Other Help Tools on page 4

1
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Help Structure

The fundamental concepts of animation and Harmony are explained in this guide. It covers the
essentials of various animation workflows, basic animation principles, as well as Harmony's interface.
Depending on what you want to do, you can either start with this Fundamentals Guide to get
immersed into the world of Harmony and animation or go right to the Getting Started Guide, which
covers the main functions and tasks. All conceptual and reference topics are omitted to get you up and
running in a very short amount of time.
The core of this help system revolves around the main animation techniques you can use in Harmony to
create animation:
•

Traditional Animation

•

Paperless Animation

•

Cut-out Animation

If you use one of the animation technique listed above to produce games, you can complete your
learning process using the Gaming Guide.
All workflows join in the compositing step of the process. All the information on compositing in
Harmony can be found in the Compositing Guide. Finally, you can watch the rendered animations in
the Play module. To learn how to use the Play module, refer to the Play guide.

2
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If you are focusing on a single part of the workflow such as ink and paint or digital Xsheet creation, you
can simply read the Fundamentals Guide and one of the corresponding module guides:
•

Paint Guide

•

Xsheet Guide

•

Scan Guide

•

Draw Guide

•

Sketch Guide

Other satellite guides are also available to learn about additional information such as the preferences
and keyboard shortcuts.
•

Keyboard Shortcuts Guide

•

Preferences Guide

•

Scripting Guide

•

Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to
this latest version, refer to:
•

Release Notes

3
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Tutorials and Other Help Tools
Aside from the main product documentation, you can find supplementary material to learn more
about Harmony. The Toon Boom website's online resources section offers a variety of videos and
samples that can further your knowledge of Harmony.
•

Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

•

Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network

•

Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

•

White Papers: toonboom.com/solutions/white-papers

4
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System Requirements
Here are the technical specifications for Toon Boom Harmony 11.1.

Harmony
Here are the specifications to install Harmony. Note that this does not encompass the network and
server specifications for Harmony Network.
Requirements

Windows

Mac OS X
Mac OS X 10.7.5
Mac OS X 10.8.5
Mac OS X 10.9.3 or later

Operating System

Windows 7 64-bit
Windows 8 64-bit

Processor

Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor

Memory

Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800
16 GB
8 GB
4 GB
Fast

‣ NVIDIA GeForce GTX

Fast

‣ NVIDIA Geforce GTX 780

Medium

Medium

‣ NVIDIA Geforce GTX 560
Video Card

775M

‣ NVIDIA GeForce GTX 650

‣ AMD Radeon HD 6770
‣ NVIDIA GeForce 750M
Slow

Slow

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris GraphicsNVIDIA
GeForce GT 520, 620, 720

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris Graphics
‣ NVIDIA GeForce 320M
‣ Radeon HD 4670

Best

‣ Wacom Intuos Pro
Drawing Tablet

‣ Wacom Cintiq
Basic

‣ Wacom Bamboo
‣ Wacom Intuos
5
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Media Player

Apple QuickTime Player (free)
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Chapter 3: About Toon Boom Harmony
Toon Boom Harmony is the most advanced professional animation software on the market. Bringing
together an impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D
models,

Top Features
•

Advanced Drawing Tools: Texture brushes, and thick and thin pencil lines

•

Smart Colour Palettes: Colour you can adjust on the fly

•

Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

•

Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full
particle effects engine

•

Real 3D Camera: A camera you can reposition in a full 3D space

•

3D Integration: Allowing you to import 3D models, position and animate them in 3D space

•

Production Pipeline Integration: Seamlessly integrate content from pre-production via
Toon Boom Storyboard Pro

Toon Boom Pipeline
Toon Boom Harmony has been recognized for its excellence by winning many awards, including a
Primetime Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated
pipeline with Toon Boom Storyboard Pro.
Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore,
animatics created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for
animation and scene setup guidance.

Modules

Harmony Stand Alone is composed of the following modules:
•

Stage on the next page

•

Draw on the next page

•

Sketch on page 9

•

Play on page 9

•

Cloud on page 9

These modules are all accessible from:
7
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•

Windows: Start > Programs > Toon Boom Harmony 11.1

•

Mac OS X: Applications > Toon Boom Harmony 11.1

Stage

The Stage module is the core of Harmony. It comprises all the major drawing, animation and
compositing features. It is used to work in the scene: design, character breakdown, cut-out
animation, traditional animation, ink and paint, exposure sheet, timeline, effects, compositing,
camera moves, colour styling, and so on.

You cannot create scenes in Stage Harmony Network, you require Control Center. You create them
directly in Stage with Harmony Stand Alone.

To learn more about Stage, refer to the following guides:
•

Fundamentals Guide

•

Getting Started Guide

•

Traditional Animation Guide

•

Paperless Animation Guide

•

Cut-out Animation Guide

•

Gaming Guide

•

Compositing Guide

•

Play Guide

•

Preferences Guide

•

Keyboard Shortcuts Guide

•

Scripting Guide

•

Utilities Guide

Draw

The Draw module is a component of the Stage module. It contains all the tools necessary to create a
paperless frame-by-frame animation project. There is no node system in this module, only the basic
essential effects. Contrary to the Stage module, instead of creating effects in the Network view, you
8
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simply create them in the Timeline view. The Draw module also includes all the scene setup and
camera features for you to do the compositing for your project.
•

Fundamentals Guide

•

Draw Guide

•

Preferences Guide

Sketch

The Sketch module is a component of the Stage module. It contains the essential tools to animate
frame-by-frame drawings and paint them. It allows you to add layers and animation, and paint and
adjust the timing. There are no effects, camera or other compositing tools included in this module.
The Sketch module allows you to focus on the paperless animation tasks at hand without being
distracted by other features that are not necessary to your work.
To learn more about the Sketch module, refer to the following guides:
•

Fundamentals Guide

•

Sketch Guide

•

Preferences Guide

Play

The Play module is used to play back the rendered image sequences enabling the user to view the
final scenes and compositing results.
To learn more about the Play module, refer to the following guides:
•

Fundamentals Guide

•

Play Guide

Cloud

Access your Database via the Cloud. When you're running a studio, you will most likely have a
database set up. This enables all the artists working on your production to share the same scenes
and assets.
9
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What the Toon Boom Cloud enables you to do is to host this database on the Internet. When you do
so, you can have freelancers log in from anywhere with an internet connection. Then they can
download a scene from the database, work on it, and upload it again.
No more need to spend time copying files to an FTP. No need to have an admin exporting and
importing files from the database. Do it all directly through the Cloud.
To learn more about the Cloud module, refer to the following guides:
•

Installation Guide

•

Control Center and Server Guide

16
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Chapter 4: Animation Workflow
In this chapter, you will become familiar with the different animation workflows and how they end up
merging together. There is also an overview of how they work with Harmony.
To begin with, let's determine what an animation workflow is. No matter which method you choose to
create your project, it will always be divided in three segments:
•

Pre-production on the next page

•

Production on page 16

•

Post-production on page 17

Harmony is designed to handle part of the pre-production and all of the production. Post-production
is managed in an external application. The three workflow segments are each broken down in
different steps.

17
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Pre-production

Pre-production
The first segment is the pre-production.

Pre-production almost always follows these steps:

Script
Every project starts with a script or a synopsis. You will also see the term screenplay. A script is the
written version of a project done by a screenwriter. You will encounter a script in many different
types of projects such as movies, television series, video games and advertisements. It is the source
for all the upcoming steps. A script usually contains the storyline, location descriptions, actions,
dialogue, sound effects, etc. It contains all the information necessary for the artists to illustrate and
animate the movie or series.

18
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The script is needed in order to transform the project into a storyboard. This same script is used as a
dialogue for the audio recording. Finally, characters, props and locations will be designed from all of
the descriptions contained in the script.

Storyboard
The storyboard, which is created by the storyboard artist from the script, is also common to all
types of projects. A storyboard is a visual representation of all the scenes and actions contained in
the script. The dialogue, backgrounds, action notes, and characters are included.

The storyboard is often created at the same time as the characters, props, location design and
audio recording. The first storyboard is not always exact, as the designs are subject to many
changes during the beginning of a production.
The storyboard is essential to the layout and posing, and the animatic.
This step is not done with Harmony. Traditionally, the storyboard is created on paper. This step can
also be achieved with Toon Boom Storyboard Pro, software developed specifically for this use.
Toon Boom Storyboard Pro projects can be imported into Harmony.

Character, Prop and Location Design
Once the script is completed, the designer can start work. Before any animation, background or

19
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Pre-production

colouration can be done, the design needs to be addressed. The artist has to decide on the
production style, the character's look, the location's complexity, and so on. Once these designs are
done and approved, the model pack is produced, containing all of the models for all these aspects.

The designs and models will be used by the colour stylist and layout artist, and finally by the
animator.

Audio Recording
The audio recording is also called voice recording. The script is needed for dialogue and extra sound
effects. The actors will read the lines from the script and record their dialogue. These voices will be
used later on for the animatic, the animation and the final production compositing.

Animatic
The animatic, also known as leica, comes directly from the storyboard. The animatic is the first movie
of a project and is used to help the animators and compositors. The storyboard is scanned in and
mounted with the sounds and dialogue. There is no animation yet. It is simply the storyboard frames
changing over time to help evaluate the rhythm and the look of the show. This will help avoid
mistakes that would have been found only at the end of a show.
This step is unnecessary if you are absolutely sure of your storyboard and timing, but an animatic is
always recommended.
This step is not done with Harmony. Generally, an external software is used to do the storyboard
editing to create the animatic. This step can be achieved with Toon Boom Storyboard Pro software
which was developed specifically for this purpose.

Character, Prop and Background Colour Styling
Once the black and white designs are done, they are sent to colour styling. The colour stylist
chooses the colours and ambiance for the production and balances the characters, props and effects
with the location palettes. This contributes to an even feeling or an emotional contrast where
needed in the show. When the colours are approved, colour models are produced and backgrounds
are painted. Colour models will often be added to the model pack.
The colour models will be used by the colourists and the coloured background will be sent for
compositing.

20
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Sound Breakdown
For the dialogue, a sound breakdown can be done. This means that the sound will be broken down
in small pieces and written on the traditional exposure sheet for the animator to use. Each frame will
have its own bit of sound information which tells the animator what mouth phoneme to place on the
character on a particular image.
For digital cut-out and paperless animation, the traditional sound breakdown is not necessary as
there are different tools inside Harmony to help the animator achieve the same result.

21
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Production

Production
The production segment can vary greatly depending on the user and the technique. There are three
main techniques or animation types that you will discover on the following pages: traditional,
paperless and cut-out. For more information about production steps, see About the Animation Types
on page 19
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Post-production
Post-production is the final step in which video and audio editing and calibrations are done. Some
effects and colour grading can also be performed at this stage.

Final Editing
The final editing comes after the rendering of the production scene. Harmony does not handle the
editing, so the renders are exported to an external application. There, the different scenes are
assembled and adjusted. If need be, users can add extra filters and effects, such as transitions
between the scenes, during this step.
Once the editing is completed, the audio will be added.

Audio Editing
The audio editing is also done in an external application. It can be done directly in the editing
software or in an audio application and then transferred to the editing software. The dialogue,
sound effects and soundtracks will be adjusted and placed with the project's final editing. The tracks
will be matched to the images and volumes and effects will be added.

Dubbing
Once the final images and sounds are assembled, the project is ready for dubbing. Actors will come
in and record voices over the movie. This process is called post-synchro. At this point in the process,

23

Chapter 4: Animation Workflow

Post-production

multiple languages can be added to the soundtrack.
The project is complete, and is ready to be output to the final master copy.

Master Distribution
All of the data is transferred to the master copy and the user or studio is ready to distribute the
project to the clients, festivals, television, cinema, and other venues.

24
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About the Animation Types
Harmony is an animation and digital content creation software. Animation can be divided into three
main categories: traditional, paperless, and cut-out animation.
These techniques can be used independently or together. Harmony is optimized to handle all three
animation types, one of the software's great benefits.
Each animation technique has its own advantages and disadvantages. Combining different techniques
allows you to incorporate the best elements while eliminating the weakness of an individual technique
that may not be exactly what you need.
Before going any further, review each animation type:
•

Traditional Animation below

•

Paperless Animation on the next page

•

Cut-out Animation on page 21

Traditional Animation

Traditional animation is the original method of animation, as well as the most popular. It is also called
cel or classical animation. It consists of drawing every image of an animation on paper, normally 12 to
30 drawings per second per character or layer. The number of drawings per second is determined by
the format (NTSC or PAL) or purpose. The human brain is able to process an animation with a
minimum of 12 drawings per second. The number of drawings per second will be between 12 and 30.
The standard is 24 or 25 frames per second.
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About the Animation Types

From the end of the 19th century to the late 1980s, the workflow was entirely done manually. Only with
the introduction of computers to the general public did some of the steps become automated. Now,
with all the technology available, the colouring and compositing are achieved digitally. However, the
drawing part is still done by hand on paper.

Paperless Animation
Paperless animation is the most recent 2D animation process. It consists of digitally drawing all of the
images of an animation. It is similar to the traditional animation technique.

This method is entirely digital; it does not involve any materials other than virtual tools. However, the
animator still must draw each frame individually.
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Paperless animation requires the user to be familiar with digital graphic applications and be able to
convert this traditional knowledge to a digital medium. This method of animation allows significant
control over the drawings, a possibility for greater quality and an infinite number of complex poses
and rotations for the animated characters and objects. It also eliminates the paper used in traditional
animation and gives you the opportunity to instantly see a line test. Paperless animation allows you to
easily cut and paste parts of a drawing, undo actions in case of mistakes, and zoom in and out of
drawings.

Cut-out Animation

Cut-out animation consists of breaking down a puppet into pieces that are moved frame by frame to
animate the character. It can be divided into two categories: classical and digital. When working in the
classical cut-out style, the animator manually moves the parts under a camera and shoots each frame
before moving on to the next pose. When working in the digital style, the parts are moved in a similar
way as the classical cut-out style and then keyframed in the computer software, which means that it is
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About the Animation Types

fixed and recorded digitally. Since the characters and objects are composed of many parts, the
animator does not need to redraw them on each frame, but can just move or distort the parts to
create the animation.

Harmony allows you to do digital cut-out animation, which has become increasingly popular in recent
years.
Cut-out animation requires you to be familiar with digital graphics applications. Cut-out animation is
very useful in cutting down the time it takes to complete a project. There is no need to redraw
characters and the computer can handle a large part of the in-betweening. It also eliminates the paper
used in traditional animation and allows you to instantly see a line test. The team for a cut-out project
is much smaller than that of a traditional production, allowing the whole production to be kept within
the same studio. This also means that you have a great deal of control over quality.

28
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Production Steps

Now that you know the differences between the traditional, paperless and cut-out animation types,
you can move on to the basic organization of their workflow. The following illustrations show the
animation pipelines that represent the most popular workflows. The tasks can be divided or the order
can be rearranged to suit the specific needs of the studio or user.
After familiarizing yourself with the basic workflow pipelines, you should read about the various
examples of the workflows and how the individual and the studio are organized according to their
size.
•

Traditional Animation Workflow below

•

Paperless Animation Workflow on page 26

•

Cut-out Animation Workflow on page 28

Traditional Animation Workflow
In a traditional workflow, many steps are done manually. Harmony is used for the digital portion. We
will focus mainly on these steps.

29
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Production Steps

The following is a list of the steps done using Harmony in a traditional animation workflow. This will
help you understand how the work is divided and give you a base to start building your own traditional
pipeline.

Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses
the storyboard and prepares an organized folder for the animator. This folder contains a field guide
that shows the proper camera move and the right size of the scene. It also includes the character's
main poses from the storyboard following the official design, and the effects, backgrounds and all
the other information necessary to the animator.
The backgrounds are done directly out of the storyboard and location design. A background is a
section or an angle of a location. The background artist refers to the storyboard and draws the
background for each scene. Once the background is completed, it is added to the layout folder.
In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will
depend on the user's preferences.This step is mainly applied to larger productions. An individual
user can move directly from the storyboard to the animation.
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This step can be done with Harmony, but Toon Boom also has another software developed for this.
Toon Boom Storyboard Pro has optimized tools to create the layout and posing.

Animation
Traditional animation is done on paper. The animator receives the layout folder and uses the
references to animate the scene. The animator will draw each frame of the animation or each pose of
the character. If there is dialogue in the scene, the animator will follow the breakdown and animate
the mouths and expressions.
Depending on the studio size, the animation can be divided in different ways. Sometimes the
animator will do all of the work, from the key poses to the in-betweens and then the clean up. Bigger
studios will have the animator doing only the key poses and then send the scene to the in-between
department and finally to the clean up department.
Once the animation is completed, it is sent to the digital part of the process. This applies only to
modern processes. In the traditional, old-fashioned pipeline, the animation was sent for hand-inking
and painting. The animation was traced with ink on transparent cels and the colours are painted with
brushes on the other side of the cel to fill the zones. Today, using Harmony, you can still use this
technique by utilizing the digital Line Art and Colour Art feature.

Digital Exposure Sheet
The digital exposure sheet is the first step done in Harmony. This controls the timing of the
animation. The traditional animator creates a paper exposure sheet in order to create the timing.
The person in charge of the digital exposure sheet reads the paper version and recreates it in
Harmony. Once the drawings are all in place on the exposure sheet, the scene is ready for the scan.
Note that a single user will scan the drawings first and then set the timing in the exposure sheet. The
digital exposure sheet is only created first in a larger animation studio using the advanced scan
features available in Harmony.

Scanning
Scanning is the second step in Harmony. The cleaned-up drawings are scanned and imported in the
software in a simple step that incorporates all of the drawings in the scene. When all the drawings
are scanned, they are ready to be inked and painted (coloured in).

Inking and Painting
At this point in the process, the colour models are ready and the drawings are scanned in and
properly exposed. Using Harmony's optimized tools, the colourist can clean the scanned artwork
and start applying colour to the different drawings. When the drawings are cleaned, as well as inked
and painted, they are ready for compositing.

Compositing
The compositor imports the coloured background, animatic reference and sound as required.
Referring to the exposure sheet, animatic and animation, the compositor assembles all these
elements and creates the camera moves and other necessary motions. Finally, the compositor adds
any digital effects required by the scene. These can include tones, highlights and shadows. When the
compositing is completed, the final step is the rendering.
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Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image
sequence. Generally, the compositor will be the same person doing the render.

Paperless Animation Workflow

The following is a list of the steps done using Harmony in a paperless animation workflow. This will
help you understand how the work is divided and give you a base to start building your own paperless
pipeline.

Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses
the storyboard and prepares an organized folder for the animator. This folder contains a field guide
that shows the proper camera move and the right size of the scene. It also includes the character's
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main poses from the storyboard following the official design, and the effects, backgrounds and all
the other information necessary to the animator.
The backgrounds are done directly out of the storyboard and location design. A background is a
section or an angle of a location. The background artist refers to the storyboard and draws the
background for each scene. Once the background is completed, it is added to the layout folder.
In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will
depend on the user's preferences.This step is mainly applied to larger productions. An individual
user can move directly from the storyboard to the animation.
This step can be done with Harmony, but Toon Boom also has another software developed for this.
Toon Boom Storyboard Pro has optimized tools to create the layout and posing.

Animation
Paperless animation is usually one of the first steps done in Harmony. All of the drawings are created
digitally, using a pen tablet to optimize work and drawing ability. Other than the digital aspect, the
animation principles are not very different from classical animation. The animator will use the same
animation styles and methods as would be used on paper–only the medium is changed.
When all of the animation is done and the drawing timing is completed through the exposure sheet
or the Timeline view, the scene can proceed to the animation clean-up process.

Animation Clean-Up
The animation clean-up consists of transforming the rough paperless animation into cleaned, tied
down and inked drawings. On a new layer, the clean-up artist will trace the animation following the
official model pack (document containing all the official character, location/props design and
colours). This step must be done very accurately.
When the clean-up is over, the scene is passed along to the colourist for the ink and paint step.

Inking and Painting
At this point in the process, the colour models are ready and the drawings are properly exposed.
Using Harmony's optimized tools, the colourist can start applying colour to the different drawings.
When the drawings are inked and painted, they are ready for compositing.

Compositing
The compositor imports the coloured background, animatic reference and sound as required.
Referring to the exposure sheet, animatic and animation, the compositor assembles all these
elements and creates the camera moves and other necessary motions. Finally, the compositor adds
any digital effects required by the scene. These can include tones, highlights and shadows. When the
compositing is completed, the final step is the rendering.

Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image
sequence. Generally, the compositor will be the same person doing the render.
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Production Steps

Cut-out Animation Workflow

The following is a list of the steps done using Harmony in a cut-out animation workflow. This will help
you understand how the work is divided and give you a base to start building your own cut-out
pipeline.

Layout and Posing
The layout and posing process links the storyboard artist and the animator. The layout artist uses
the storyboard and prepares an organized folder for the animator. This folder contains a field guide
that shows the proper camera move and the right size of the scene. It also includes the character's
main poses from the storyboard following the official design, and the effects, backgrounds and all
the other information necessary to the animator.
The backgrounds are done directly out of the storyboard and location design. A background is a
section or an angle of a location. The background artist refers to the storyboard and draws the
background for each scene. Once the background is completed, it is added to the layout folder.
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In a cut-out or paperless animation process, this step can be done digitally or traditionally. This will
depend on the user's preferences.This step is mainly applied to larger productions. An individual
user can move directly from the storyboard to the animation.
This step can be done with Harmony, but Toon Boom also has another software developed for this.
Toon Boom Storyboard Pro has optimized tools to create the layout and posing.

Character and Prop breakdown
The breakdown step is really important in the cut-out workflow. The person doing the breakdown
has to take the final character or prop model and start building the puppet. This means deciding
which parts will be separated and preparing all of the joints and views for the animators.
Once the parts are broken down, the character or prop must be rigged. This means attaching the
parts (hierarchy) and assigning the appropriate pivot points. This step must be done with care
because these puppets will be distributed among all the animators later and you do not want to
duplicate mistakes throughout the project.
When the character and prop rigs are ready, the breakdown artist stores them in the library as
templates to be shared with the rest of the team.

Library
The library is a central element of a digital cut-out production. It contains all the assets for the
animation and scene set up.
The library is a central location where all these templates are stored, organized and made available
to the animators and scene setup team. The library should be structured so that everyone using it
can easily find the assets they require. Someone should be assigned to manage the library so that it
remains well organized. This person is often the breakdown artist, but it depends on each studio's
structure.
When the library is built, the scene setup person and the animators will start using the assets.

Scene Setup
The scene setup consists of preparing the scenes for the animators and is similar to the traditional
layout and posing. Following the storyboard and the animatic, the person working on the scene
setup will import the assets needed for the scene animation, as well as import the animatic reference
and often position the camera.
When the scene setup is completed, the scene can be passed on to the animator who can start
animating without having to mount the scene.

Animation
Cut-out animation is a vast subject. There are many techniques employed by different studios and
animators. Basically, the animator moves the parts frame by frame to animate the puppet. The
animator may even start their own pre-compositing, camera moves, and trajectories. This depends
on the user's workflow. Once the animation is completed and approved, the scene goes to the final
compositing and effects.

Compositing
The compositor imports the coloured background, animatic reference and sound as required.
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Production Steps

Referring to the exposure sheet, animatic and animation, the compositor assembles all these
elements and creates the camera moves and other necessary motions. Finally, the compositor adds
any digital effects required by the scene. These can include tones, highlights and shadows. When the
compositing is completed, the final step is the rendering.

Export - Render
Once the compositing is completed, the last step is to render the scene as a movie or an image
sequence. Generally, the compositor will be the same person doing the render.
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Chapter 5: Animation Principles
Animation can be used for several different purposes such as movies, advertisements, video games,
corporate presentations, medical concept demonstrations and much more. Not all of these require
the same animation quality level. To illustrate a concept, simple and linear animation is often more
than sufficient to convey the message. For a feature length animation movie, the animation needs to
be convincing and carry some weight and elasticity.
You will notice when you watch different movies that the animation style will differ quite a bit from film
to film. Some have a very fluid and smooth flow in their animation while others have a very bouncy,
cartoony feel. People without animation experience may watch a movie and find the animation very
bad, unconvincing or too slow. They might not know why exactly, but they know that something isn't
right. Most of the time, it happens because the animators missed a few of the fundamental animation
principles.
If you already are an experienced animator, you can skip this topic and continue along.
Here are the main principles that create the backbone of a good animation. You will no doubt
encounter variations of these principles when reading articles online or reading different books.

Squash and Stretch

Squash and stretch is at the core of the animation principles. It is what gives some elasticity and
flexibility to your animation. When an object hits the ground, the impact drawing will be really
squashed. As it bounces off the ground, it will stretch in the opposite direction. The stronger the
squash and stretch is, the smoother and bouncier the animation will look. Also, hard objects such as
a bowling ball require less squashing or stretching so that the heavy and solid illusion remains. As
you squash and stretch an object, it is really important to maintain the volume of the object. When
you squash something down, you need to proportionally stretch it sideways, otherwise, the object
will look like it is getting smaller.

Timing
Animation is all about the timing. The timing comprises many things in animation. It is the duration of
an action. It is the speed and velocity of an action. It is the way actions overlap and secondary objects
follow the main action. If the timing is off, too slow, too long, too fast, or too linear, the animation
will not look realistic. It will be stiff, even boring. The nature of the character, personality or weight
of an object will influence the timing of the animation.
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Anticipation

Anticipation is the preparation for an action such as a jump or a punch. For example, a character will
squat down before pushing his body and legs up into a jump. The stronger the anticipation motion,
the more cartoony and fluid the animation will be. The smaller the anticipation, the more stiff the
animation will be.

Straight-ahead and Pose-to-pose
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These are two different ways to animate an action. The straight-ahead technique means to animate
your action from drawing 1 to the end in sequence order. The pose-to-pose technique is a bit more
intricate as it means to draw the key poses first (often the beginning and end drawing of the action
and some other key moment between. Once the key poses are done, the breakdown and inbetween
drawings are added to fill the rest of the animation. Smoke, water and other fluid elements are often
animated using the straight-ahead technique. Actions that require tight timing and structure are
often animated with the pose-to-pose technique. This method helps maintain a solid structure and
preserve the volume. Sometimes, when using the straight-ahead technique, it may be difficult to
calculate where the action will end up and the final drawing may be out of proportion and not where
it should be.

Follow-Through

The Follow-Through principle is very important for increasing the quality of your animation. All the
secondary parts of your character such as hair, clothes or a cloak will continue moving after the
character stopped moving. Also if you observe closely, when a character walks, its body moves and
down, and its long hair or cloak follow behind on the same path but with a slight delay. Therefore,
your character might be at the lowest point in a crouching action but his cloak will be all the way up in
the air. Also, notice that when the cloak floats behind the character, it will move along an "S" curve.
The part of the cloak that is attached to the body will not always curve in the same direction as the
tip of the cloak.

Arcs of Rotation
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The human body moves from its articulations such as the shoulders, knees, hips and elbows.
Therefore, all limbs move by rotating on their pivot (articulation). When animating an arm going up
or down, the hand will not reach its end point on a straight trajectory. It will follow an arc until it
reaches its end point.

Slow-in and Slow-out

Most characters and objects accelerate and decelerate when moving. Most movements are not
linear, therefore to reproduce the slow-in and slow-out effects, we add more drawings closer
together at the beginning of the action and same at the end of the movement. The closer the
drawings are, the slower the animation will be. The farther apart they are, the faster the animation
will be.

Secondary Actions
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Secondary actions add another layer of realism and quality to an animation. The secondary actions
are the other limbs or objects moving along with the main action. They are not the follow-through
actions, which are inanimate objects reacting to the main actions. They are the limbs that move, such
as the character's arms swinging rhythmically back and forth when walking. He could nod in time to
music while taking a stroll or blink or chew gum.

Exaggeration

The principle of exaggeration is another important way of adding life in animation. Sticking exactly
to reality will make for a very stiff animation. Changing the direction of the main body curve from
backward to forward in a dramatic way, using squash and stretch, snappy timing and good slow-in
and slow out help exaggerate the movements and add life to your animation.

Solidity

In animation it is paramount for drawings to have a strong underlying structure. The animator must
understand the anatomy and skeleton of the characters and props to be animated. Without a good
structure, the drawings will deform, bend in the wrong places, and progressively become off model.
The animator should always know what is under the skin of his character.
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Chapter 6: Concepts

Harmony was designed using traditional animation concepts. This lets you use familiar tools and work
practices. Whether you are new to animation or an experienced animator who wants to understand
Harmony, the concepts covered in this chapter will be interesting and useful.
•

Bitmap and Vector Graphics on the next page

•

Line and Colour Layers on page 40

•

Colour Palettes on page 41

•

Exposure Sheet, Timeline and Timing on page 43

•

Pegs on page 46

•

Multiplane on page 47

•

Network on page 48

•

Frame Rate and Format on page 49

•

Scenes on page 50
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Bitmap and Vector Graphics
There are two types of digital images: bitmap and vector. Find out about their main differences so you
can make the optimal choice for your project.
•

Bitmap Image Types below

•

Vector Image Types below

•

Advantages and Disadvantages of Bitmap and Vector Images below

Bitmap Image Types

A bitmap image consists of pixels and has a fixed size. A pixel, short for picture element, a single point
in a graphic image. It is a small sample of an image, a dot, a square or a very small section made out of
smooth filtering. If you zoom in close enough on a digital image, you will see the pixels. They look like
small squares of different colours and intensity. Since a bitmap image is composed of pixels and has a
single resolution (size), if it is enlarged too much, it will start losing definition and pixels will start to
appear. This is known as pixelation.

Vector Image Types

A vector-based image is composed of points and Bezier curves. The computer reads the points and
traces the segments linking them to reproduce the image shape. There is no fixed size or resolution in
a vector image. You can enlarge the graphic and distort it as much as you want, and the system will
simply recalculate the segments and rebuild the shapes. The segment's shape can be controlled with
Bezier handles to curve and smooth it. Vector images are translated and displayed in pixels once the
calculation is done.

Advantages and Disadvantages of Bitmap and Vector Images
Bitmap images allow a more organic style. Since everything has a fixed size and is already made out of
pixels, more effects are possible, such as blur, texturing, shading, a painted look and so on. The
bitmap format is excellent for creating backgrounds and overlay elements. However, because of the
precise resolution, in order to zoom in on or to work in high resolution such as HDTV, the created file
must be a large size.
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Vector-based graphics can be very useful when creating large illustrations, as these graphics are
resolution independent. The images can be significantly enlarged without losing definition. A vectorbased image is generally a smaller file size than a bitmap, as it is a set of mathematical points.
However, if there are many vectors composing the graphic, the result can be larger than a bitmap file.
A vector shape can always be modified. It also creates very crisp images.
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Line and Colour Layers
Before the advent of computers, animation was done manually. There was no process of scanning and
painting digitally. Once the animation was completed and cleaned on paper, the drawings were traced
with a brush or a quill onto cels. The cel transparency permitted many layers to be superimposed,
composing the scene elements together.

The first step in the cel process is to ink the lines on the front side of the cel, either in black or with
different colours. In the late 1950s, this step was changed to photocopying the drawings on the cels,
called the Xerox process. Once the lines are inked, it is time to fill in the colours, usually painted with a
brush. Painting on the same level as the lines makes it all too easy to accidentally go over the line or
not apply the colour densely enough, so light is passed through the drawing. To remedy this, colours
are painted on a second level onto the back of the cel. This protects the lines from any colour stains
and the colour filling can go under the lines covering the entire zone.
Working digitally produces a similar process. Once you have scanned drawings into the system, you
can colour the lines without ruining the colour filling, or you can paint complete zones without staining
the lines. If there is some transparency (alpha) or texture in the line, the colour filling is allowed to go
under the lines to create the correct look.
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Colour Palettes

In animation, precise colours are used to paint each particular character and prop. In order to maintain
absolute consistency, a colour palette is created for each character, prop and effect throughout the
production. These are referred to as master palettes.
Before computers, painters used real colour pots (often big glass jars) mixed by a colour palette
artist. The colour palette artists had to make sure to use the exact same amount of paint from each
tint every time they would mix a new batch to make sure the colours would remain consistent
throughout the entire movie. Now, using a computer process, a digital colour palette is created. This
allows absolute colour accuracy by always having the same group of colours associated with each
character.
Master palettes contain a colour pot for each zone to colour with a precise RGBA colour value.
•

Red

•

Blue

•

Green

•

Alpha (contains transparency information)

Painting animation using a master palette is very similar to the paint-by-number concept.

Advantages of Using a Master Palette
Using a master colour palette has many benefits, including:
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•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production.

•

Multiple artists can use the same colour palette and produce the same results.
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Exposure Sheet, Timeline and Timing

Animation is about movement and in order to have the illusion of movement, you need different
drawings to progressively change over time. For your eyes to perceive a smooth motion and not just a
series of drawings changing, you need several drawings per second. To be more precise, you need a
minimum of 12 drawings per second. If you have less than 12 drawings per second, the motion will be
jerky and you will not see a smooth motion.
It is important to know that the number of drawings per second will be based on the final output:
television, cinema, web, DVD, etc., as those outputs have different frame per second rates. This
parameter will influence the number of drawings per second as well as their exposure.
The exposure of a drawing is the length of time that it stays on the screen. A second can be divided as
follows: 24, 25 or 30 images depending on the format. They are also called frames, so there are 24, 25
or 30 frames per second.

Broadcast Standards
There are two main broadcast standards used; the one selected will determine the frame rate.
In North America, Japan and other parts of Asia, the NTSC (National Television System Committee)
format is used. This format is 30 images (frames) per second.
In most of Europe, PAL (Phase Alternating Line) format is the broadcast standard. This format is 25
frames per second.
Film format is 24 images per second.
The human brain is able to process an animation as slow as 12 drawings per second. Therefore, the
number of frames per second should be between 12 and 30. The general standard is 24 or 25 frames
per second, so these 12 drawings are set on double exposure. This means that each drawing stays on
the screen for two frames. If a drawing is exposed for 24 frames, it means that it will appear to the eye
for one second.
The timing is a drawing's exposure.
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Exposure Sheet

The exposure sheet, also known as the Xsheet or dope sheet, is used when an animator is planning a
scene. The animator enters data in the different columns (layers), the name of the drawings and their
exposure into the Xsheet.The Xsheet allows you to see the animation timing in detail.
The Xsheet is composed of columns corresponding to the different layers. Each column is split into
rows representing the frames (images) in the scene. A paper Xsheet usually has 80 rows and ten
columns. This enables the animator to associate a layer with a certain element (character, prop,
mouth, etc.) and make a record of the frame at which each drawing appears.
The traditional paper Xsheet was mainly created for the animator to communicate with the
cameraman regarding the scene's timing, the camera moves and element trajectories. It is still used
today to express the same information to the compositors and the person working on the digital
Xsheet.

Timeline
A traditional timeline is a horizontal and chronological representation of key events occurring within a
particular historical period.

In the digital process, the timeline is quite similar. The timeline is read from left to right to help you
understand the scene and its timing. The frames or timecodes are placed at the top and the elements
or layers on the left. There is no drawing name or value information. The timeline displays the timing
and elements in a simplified and systematic manner, making it easy to read globally. The timeline can
be considered to be a quick overview of the whole scene.

50

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

Xsheet and Timeline Usage
Xsheets and timelines are used for different tasks. When a scene is done in a traditional animation
workflow, the Xsheet is useful in keeping track of the drawings' ordering, names and timing. The
Xsheet is used to reproduce the animator's work in the digital software or the camera. The colourists
can then follow the Xsheet to paint the drawing sequences. Finally, the compositors can read the
information that is necessary to their work from the Xsheet.
For digital animation, computer generated trajectories, hierarchies and distortions, there is a lot of
extra information involved, including keyframes, velocities, function curves, and more. A keyframe is a
computer-generated key position that contains values and coordinates for the element's onscreen
positioning; keyframes can be displayed in the exposure sheet as values. If there are too many
keyframes, modifying one can be difficult due to all of the values present. This is why there are digital
timelines. Their simplified version of the timing is quite useful in these situations. The Timeline view
does not display drawing names or keyframe values, but instead represents them as symbols, making
it much easier for the eye to detect the desired element for modification. Although the name and value
information is not directly displayed, the Xsheet is still very valuable when retrieving this type of
information.
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Pegs

Pegs have been used for a long time in the animation process, mainly for registration purposes. Peg
holes at the bottom (or top) of animation paper are used to keep all of the sheets even and at the
same registration.
There are three peg holes in regular animation paper. The centre one is circular and the left and right
ones are rectangular and situated at 4 inches from the centre one.

To keep the drawings together, traditional animations use a peg bar. This bar has three pins shaped
exactly like the peg holes. Peg bars are normally found at the bottom and top of animation discs.
Before digital compositing, the peg bars were also used to move layers under the camera stand. All
layer translations were calculated based on the distance the pegs were moved frame by frame. They
were the equivalent of the digital trajectories. Harmony makes use of these concepts to create
animation and camera moves.
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Multiplane

In the animation context, multiplaning is used to create a scene with many planes placed at different
distances from the camera to recreate a perspective illusion. A plane is a layer or an element. In regular
flat 2D scenes, all the elements are at the same distance superposed one on top of another. So, when
the camera moves, all the elements are moving at the same speed. In real life, all objects and elements
are placed at different distances from our eyes so when we walk or drive past, the closest objects
appear to be moving away faster. The farthest ones, like mountains, are barely moving. In animation,
that perspective effect has to be reproduced manually.
In 1933, the Walt Disney Company invented the multiplane camera. They got the idea from looking at
methods used in the theatre to introduce perspective into a space with limited depth. In the theatre,
cut-outs and flat pieces were placed in a variety of layers in front of a backdrop which allowed actors
to move through the various sets while giving the illusion of depth. Walt Disney's final design for the
multiplane camera used this same concept. The multiplane camera which was set up vertically, much
like a photographic enlarger, would shoot down through as many as five planes attached to vertical
posts that allowed four of the planes to move independently of one another. The first two planes were
used for animation, the next two were for backgrounds, and the fifth was fixed and used for sky
backgrounds. The finished result produced a depth of perspective which had not previously been seen
in animated film.
Multiplane camera effects can be created digitally. There is no longer a need to use the big multiplane
camera. Multiplane shots are normally used to add depth to a scene to reproduce perspective effect
more easily. They can also be used on a smaller scale to make elements pass in front of and behind
certain objects like trees or chairs.
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Network
A network can be described as an interconnected group or system of elements leading to a central
point. It is widely known as a node system.
A network can be useful in animation because many components enter the process. A visual network
can help represent many things like scenes, effects, composition and textures.
the Xsheet and timeline enhance the element display, but they may not be the most efficient for some
production aspects. The Xsheet provides traditional animation details, displaying drawing names,
values, exposures and timing. The timeline displays all of the timing, drawing exposures, keyframes
and trajectories in a schematic view to provide a quick overview of the whole scene, enabling you to
easily detect different elements. When it is time for advanced hierarchy, compositing, effects filters,
grouping, and cutters, a timeline can get overloaded and may not have the capacity to represent the
reality of things.
For greater efficiency, a network is brought in to visually represent all of the parenting, hierarchy,
effects and element compositing. There is no timing representation or drawing name, but a visual set
of links or cables between the elements that are represented as boxes or modules. It helps the eye
follow very quickly to what is happening in the scene. Also, because of the linking power available, a
network allows more advanced connections and parenting than a timeline.

Elements can be combined using effect modules or composite modules and turned into something
new. Elements can cut others or control other ones. In the end, all elements are brought into a
composite module to turn all drawings, layers, parameters and effects into the final animation output.
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Frame Rate and Format

When you create an animation, the images you animate must move fluidly to produce the correct
effect. If they don't, you will have a jumpy animation which won't look good. To get a fluid movement
between the drawings, you need several images per second. You need a minimum of 12 images per
second, any slower than that and the animation becomes jumpy. An image can also be called a frame,
therefore the frame rate is the number of frames you play per second in your animation.
The format of your project is the size of your camera frame in pixels. You may not be familiar with the
term pixel, but you have probably seen it when you magnify a digital photograph. A pixel is the
smallest element of an image displayed on a monitor or TV screen. Pixel, which is short for picture
element, is a single point in a graphic image. It is a small sample of an image, a dot, a square or a very
small section made out of smooth filtering. If you zoom in close enough on a digital image, you will see
the pixels; they look like small squares of different colours and intensity.
Depending on the type of project you want to create, you will need a different image size. For
example, if you want to put your project on the web, you will probably export your movie as a small
size so that it is light to play back once it is on the web. The larger the images are, the heavier the
project is, but also, the better the quality. If you want to export your project for the theatre, you will
ned to create your project in a large format so the image is of a high quality and looks good on the big
screen.
Also, some display media such as iPad, TV or theatre have an exact format requirement. For example,
one TV format that has been a standard for decades is the 4:3 size ratio, meaning that the width of
your scene has the equivalent of 4 units compared to 3 units for the height.
In recent years, a new TV standard has been defined with the advent of Blu-ray and high-definition
technologies. It is the 16:9 format, which is often referred to as HDTV (High Definition Television). The
most common 16:9 format in pixel is 1920 x 1080.
You can find most of the formats in the presets list provided in the Harmony Welcome screen.
To recap, the format is the size of your camera frame in pixels, and it matches the width and height
required for the medium in which you want to show your final movie.
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Scenes

Planning is an important step in creating an animation project. This involves listing the scenes that
need to be animated, the characters to design and the different backgrounds to incorporate.
In animation, a scene is the action happening in front of the camera while the camera does not change
angle. As long as the camera does not stop "filming", you are in the same scene. A good example
would be two characters talking. When the camera is facing the first character, this is one scene. When
the camera cuts and films the second character, you have a second scene. When the camera returns to
the first character, you have a third scene, and so on.

A group of scenes occurring in the same location about the same action or event is called a sequence.
When there is a change of location or subject, it becomes a second sequence.
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Chapter 7: Project Organization and File Structure
When working in production, it is important to keep your work organized. It is important to create a
naming convention chart and establish a file storage structure before starting the project. It is not only
extremely important that everyone follows the criteria laid out in the naming convention chart and the
file storage structure, but also that they understand the organization and where to find the files.
A well thought-out and logical naming convention will help keep your production structured and allow
it to run smoothly by preventing the loss of files due to chaotic organization.
In this chapter, you will learn how to organize and name the different components in your animation
project.
•

File Structure on the next page

•

Root Directory and Content Building Scenes on page 54

•

Drawings and Layers on page 57

•

Libraries and Templates on page 59

•

Naming Convention on page 61
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File Structure

File Structure
A Harmony project is composed of several files. The drawings and colour palettes are not embedded
in the project. They are separate linked files. Therefore, if you want to archive or share a project, you
require all the files contained in the folder structure.

Scene File Structure
Here is an example of the file structure contained in a scene. As you work and use more features,
different folders may appear in your structure.

The Harmony scene folder contains the following folders: frames, audio, elements, etc.
Folder

Contents

annotation

Contains the images and thumbnails created while drawing in an Annotation column in the Xsheet view.

audio

Contains all imported audio files.

elements

Contains all the drawing files. The drawings are organized by
folders named like the layers they are associated with.

environments

Contains the exported palette files that were originally stored
at the environment level in the Harmony Network database
structure or the palettes in a Harmony Stand Alone scene that
will be imported later at the environment level in Harmony
Network.

frames

Contains the final frames after a render if you are using the
default settings of the Write module in the Network view.

jobs

Contains the exported palette files that were originally stored
at the environment level in the Harmony Network database
structure or the palettes in a Harmony Stand Alone scene that
will be imported later at the environment level in Harmony
Network.
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palette-library

Contains scene palettes and scene palette list files.

timings

This folder is used when a user links external images to a scene
and wants to store a backup copy in case the link breaks.
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Root Directory and Content Building Scenes
A production is not only composed of the series or movie’s scenes, there are also animatics,
backgrounds, character builds, colour models, references, storyboards, and so on. These elements
must be stored somewhere.
Even if you have a structure integrated in Harmony, it is recommended that a root directory be
created for your external elements such as audio clips, bitmap backgrounds, references, and so on.
This directory should be stored on the server or be regularily backed up if you are a single user
working on a standalone machine.
The Root directory contains subdirectories which hold such elements as animatics, backgrounds and
audio files. You must create these subdirectories and name them accordingly. For example, store the
backgrounds used in your production in a subdirectory called backgrounds or adventure_
backgrounds.
Keeping an organized work structure will give you greater control and ease. You can further improve
the organization by grouping similar elements into categories.

Here is a list of typical subdirectories:

Animatic
Animatic project and movie files can be stored and organized in this folder.

Backgrounds
Backgrounds can be stored by sequence or episode in the same way that animation scenes are.
Create a subdirectory named Backgrounds and then place a sequence or episode subdirectory
inside it. Categorize each background by episode or sequence.

Designs
Create a Designs subdirectory and split the designs into three categories:
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•

Characters

•

Props

•

Effects

Categories for locations and backgrounds can also be added if you are creating the designs using
Harmony.

Final Editing
Final Editing projects and renders can be stored and organized in this folder.

Library
The items contained in the library require a high level of organizational structure. The more
structured the library, the faster you will be able to retrieve the items. Categorize the elements using
subdirectories, which can be further subdivided. Categories could include:
•

Characters

•

Props

•

Effects

•

Audio

•

Models

The Library folder should always be stored on the server, even if it is not included in the root
directory. A library is generally shared between all the users working on the production as they will
link this library to their Template Library and reuse its contents.

Models
Create a Models subdirectory and divide it into three categories:
•

Characters

•

Props

•

Effects

You may also need to add categories for the backgrounds and model pack. Note that you only need
to create a Models subdirectory if you are not designing the models in Harmony.

References
Create a References subdirectory and then categorize according to type:
•

Images: These may be any subject from which you can gain ideas and inspiration to help develop
your project, For example, if you are producing an 18th-century adventure series, you may have
images of period costumes, buildings, and sailing ships.

•

Pictures: You can also use photographs of items which may help you produce an accurate
account of the time period in which your production is set.
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Render
Create a Render subdirectory and categorize the exported image sequences or clips by scene. For
example, you would have a subdirectory named Render and categories named Scene_001,
Scene_002 and so on.
It is also possible to do the following:
•

Create a subdirectory called Render and store your scene’s render in a subdirectory named
sequence.

•

Create a subdirectory called Render and store your scene’s render in a subdirectory named
episode.

Storyboard
Toon Boom Storyboard Pro projects or storyboard scans can be stored and organized in this folder.

Textures
You can create a bitmap texture bank for pen styles and colour palettes and store all of the files in
this folder.
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Drawings and Layers
A very important concept to understand in Harmony are drawings, drawing elements, and layers.
Layers are also referred to as columns in traditional animation. A drawing element is a directory
containing multiple drawings and is linked to a column in the Xsheet view and a layer in the Timeline
view. The layer and column are generally named the same way as the drawing element (folder). Note
that there is a slight variation between a drawing element and a layer. A layer may also be an effect
layer, a peg (motion) layer, etc. It is not always a drawing layer. A drawing element is the directory
containing the drawings that the corresponding layer is linking to. Many layers can be linked to the
same drawing element (folder) so that the same drawings are reused. A layer will be represented as a
module (node) in the Network view.
In traditional and paperless animation, a drawing element or layer can be a character, for example,
level B. In cut-out animation, a drawing element can be the hand layer.

When you add a column to your scene, a module and a folder (element folder) are also added. By
default, the element folder and layer (module) are named the same way as the column. As explained
above, the element folder's purpose is to contain all the drawings related to this column. For example,
in cut-out animation, a character can have many mouths available. All these mouth drawings will be
contained in this folder, even if they are not currently exposed in the scene. In other words, there is
always a drawing container hooked to a layer or column, unless that layer is linked to another drawing
element (clone).
You can find the drawing element folders in your scene's subdirectory called elements.
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You can add drawing elements from the Timeline view, Xsheet view and the top menu .
In order to understand what happens when you duplicate a drawing, extend an exposure, create
cycles or delete a drawing, it is important to know how a layer works.
Each layer is linked to a column and that column is linked to a directory in which all of its drawings are
saved. This directory has the same name as the layer and column. When a value or drawing name is
typed in a layer’s cell, Harmony looks in the layer’s directory for the corresponding drawing to display.
If there is no corresponding drawing, a new one is created.
New vector drawings are created as *.tvg (Toon Boom Vector Graphic) files.
The layer’s cells are not used for storage, but are linked to the drawings contained in the layer’s
directory. If you remove a drawing from the layer exposure, it is not deleted; it is simply not displayed.

When you create a drawing cycle, all of the repeated drawings are linked to the same original files.
This means that when you modify, repaint or correct a drawing named “1”, all drawings named “1”
are updated simultaneously. In order to modify a drawing independently from its other exposures, you
must duplicate the drawing.
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Libraries and Templates
Harmony allows you to use a library to store and reuse elements such as animation cycles, network
effects and filters, trajectories, cut-out puppets, etc. We call these elements assets or templates.
These libraries can be placed and used on different levels.
Harmony provides some library folders, to which you can add your own libraries. Harmony’s library
can be accessed from any scene opened on the machine.
To store your assets somewhere other than the default location, you can create your own folder on
your hard drive. If you are connected to a network, you can create a folder on the server to be shared
with other network users.
We recommend that you name your library with a relevant project name, such as adventure_
library.
The library folders and their templates are completely external to Harmony and can be archived and
moved independently from the production. They can also be sent to other Harmony users.
It is always a good idea to be descriptive when naming your templates (assets). Although not
mandatory, it is highly recommended to use alphanumeric characters:
•

a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues when working on different platforms such as Mac OS X or Linux.

Library Structure Tips

The following recommendations may be useful as you structure your work. The main library can be
divided into categories to match different template types:
•

Character

•

Background

•

Audio

•

Prop

•

Effect

The character section is often altered the most. It is recommended that you divide this folder between:
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•

Main Characters

•

Episode Characters

Libraries and Templates

Within the Main Characters folder, you can create a folder for each individual character. Episode
characters are generally less numerous and can be stored in folders corresponding to their episode.
Each character’s folder can be further divided into subfolders, such as:
•

Model

•

Animation

•

Keyposes

•

Reuse Parts

The Animation section can be organized by actions, such as:
•

Run Cycle

•

Walk Cycle

•

Jumps

•

Miscellaneous

Some users may divide their animation folder by angle or view:
•

Front

•

Three-quarter

•

Side

•

Three-quarter back

•

Back

Personal Libraries
During the animation process, an animator will often reuse certain templates. Some animators have
their own personal libraries to store their favourite templates. If a template has been updated in the
master library, the Library manager should send a note to the animators and the scene setup team to
ensure that they update their personal libraries.
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Naming Convention
When working on large or even small projects, it is best practice to create a naming convention for
everyone to follow. This will help keep the work organized and consistent.

Scene Naming Convention
For improved consistency and ease of use, incorporate naming conventions for your scenes and other
project elements.
•

We recommend that you name your scene using alphanumeric characters: a to z, 0 to 9 and
underscore ( _ ).

•

Avoid capital letters or spaces in the file names.

•

Try to provide the maximum amount of information for future identification, which helps ensure
that you do not mix up elements and lose information.

For example, you could name a scene adventure_sc001, adventure_scene_01, adventure_
character_models or adventure_seq01_sc002.

Layer Naming Convention
When you create drawing layers, it is recommended to name them instead of keeping the default
name. This way, your work will be organized and it will be easier for another person to work with your
data later on.
It is always a good idea to be descriptive when naming a layer. Although not mandatory, it is highly
recommended to use alphanumeric characters:
•

a to z, 0 to 9 and underscore ( _ )

This will avoid technical issues when working on different platforms such as Mac OS Xor Linux.
It is highly recommended that you incorporate a naming convention for the layers when building cutout puppets. This will be very useful later on.

We suggest that you:
•

Add one or two letters for the character/prop name before the part name and an “r” for right or
an “l” for left to identify the corresponding character/prop:
Character Abby’s right arm = ab_r_arm

•

If you plan to work with different angles for your characters (front, side, three-quarter, back), you
can add one or two letters to identify the angle:
Character Abby’s right arm, front view = ab_r_arm_f

•

Instead of using the “r” and “l” markers for the different right and left body pieces, you can use
“1” to indicate if a limb is closer to or farther away from the character. For example instead of r_
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arm and l_arm, you could have arm and arm1. The reasoning is that when the character is flipped, it
is less confusing to have “1’ as an indicator for a close limb instead of right or left:
Character Abby’s closer arm = ab_arm
Character Abby’s farthest arm = ab_arm_1

Renaming a Series of Modules
When you use a blank rigging template, all of the modules’ names are generic. You will need to add
naming information, such as the character’s name and the angle.
Harmony provides you with a script called Add Prefix or Suffix that allows you to add a prefix or a
suffix to a series of selected modules at the same time.

How to add a prefix to a series of modules
1. In the Network or Timeline view, select all of the modules or press Ctrl + A (Windows/Linux) or ⌘
+ A (Mac OS X).
2. In the Scripting toolbar, click the Add Prefix or Suffix script button.
The Add Prefix or Suffix dialog box opens.
3. Select the Prefix or Suffix option, depending on what you want to add to the element’s name.
4. Type the prefix or suffix information to be added to the module name.

Puppet Drawing Naming Convention
We recommend that you use a naming convention for your drawings. If you combine all of the angles
of a character in the same breakdown scene, it is a good idea to identify each angle used.
Before drawing the parts in the drawing elements (layers), we recommend that you create a drawing
name that represents the angle used. This will be quite useful during animation and drawing
substitution. For example, use “f” for front, “s” for side, “q” for three-quarter so that the drawing
name looks like this:
•

f1, f2, f3, s1, s2, etc.

In the facial feature drawings’ name, you can also add “h” for happy, “s” for sad or any other letter
symbolizing an expression to help regroup the same theme of drawings. For example:
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•

Happy Mouths:
•

f_h_a,

•

f_h_b,

•

f_h_c,

•

f_h_d,

•

f_h_e,

•

f_h_f,

•

f_h_g,

•

f_h_x

•

Sad Mouths:
•

f_s_a,

•

f_s_b,

•

f_s_c,

•

f_s_d,

•

f_s_e,

•

f_s_f,

•

f_s_g,

•

f_s_x
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Chapter 8: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will
learn about starting the application, creating scenes, setting the resolution and opening the scenes.
•

Starting on the next page

•

Welcome Screen on page 67

•

Creating and Opening Scenes on page 69

•

Saving a Scene on page 73

•

Setting the Scene Length on page 75

•

Adding a Drawing Layer on page 76

•

Scene Settings on page 77

•

Verifying the Project Integrity on page 85

•

Basic Commands on page 87

•

Preferences on page 90
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Starting

Starting
You can run the Harmony on the Mac OS X or Windows operating systems.

How to start Harmony
1. Do one of the following:
‣

Mac OS X: Double-click on the Harmony icon or select Applications > Toon Boom
Harmony 11.1 > .

‣

Windows: Double-click on the Harmony icon or select Start > Programs/All Programs >
Toon Boom Harmony 11.1 >

Toon Boom Harmony opens.
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Welcome Screen
When you start Toon Boom Harmony, the Welcome Screen appears. If a scene is already open, you
can display the Welcome screen by selecting Help > Show Welcome Screen.

The Welcome Screen allows you to:
1. Create scenes
2. Choose the scene resolution
3. Add or delete a custom scene resolution
4. Open recent scenes from a list
5. Open scenes by browsing
6. Open the Help documentation
7. Open Harmony directly without opening the Welcome screen first.
To display the Welcome screen later on, go to the top menu and select Help > Show Welcome
Screen.
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Accessing the Documentation

Accessing the Documentation
How to access the Harmony documentation
‣ In the Documentation section, click on the listed links to access the online documentation.

All the Harmony guides can also be opened directly in the software. From the top menu, select
Help > Help or press F1.
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Creating and Opening Scenes
All scenes created via Harmony Stand Aloneare independent and local to the computer. You can
create or open a scene using the Welcome screen or the File menu.

How to create a scene from the Welcome screen
1. To select the scene’s location, in the Project Directory section, browse the files by clicking Browse
button.

2. In the Project Name field, type the scene’s name.

The scene name cannot exceed 23 characters and cannot contain special characters, such as *&^%!.

3. In the Resolution window, select the scene’s resolution and click Create.
A new scene is created.

How to create a new scene from the File menu
1. Do one of the following:
‣

From the top menu, select File > New.

‣

In the File toolbar, click the New

‣

Press Ctrl + N (Windows/Linux) or ⌘ + N (Mac OS X).

button.

The New Scene dialog box opens.
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2. Select a scene directory by clicking the Browse

button.

3. In the Project Name field, type the scene's name.

The scene name cannot exceed 23 characters and cannot contain special characters, such as *&^%!.

4. In the Resolution window, select the scene’s resolution and click Create.
A new scene is created.

How to create a scene with a custom resolution
1. Create a new scene from the Welcome screen or from the File menu in Harmony.
2. Set the scene resolution by doing one of the following:
‣

Select the scene resolution and click Create.

A new scene is created.
‣

Add a new resolution to the list by clicking the Add
button. You can delete a custom
button.
resolution from the Resolution list by selecting it, and clicking the Delete
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3. In the New Resolution dialog box, fill in the following fields and click Create.

‣

Resolution Name: Name your new resolution.

‣

Resolution: Set the width, height and aspect ratio of the resolution.

‣

Field of View: Set the horizontal fit, vertical fit, or Custom Fov.

‣

Frame Rate: Type the scene's frame rate per second.

How to open a scene from the File menu
1. Do one of the following:
‣

From the top menu, select File > Open.

‣

In the File toolbar, click the Browse

‣

Press Ctrl + O (Windows/Linux) or ⌘ + O (Mac OS X).

button.

The Open Scene browser opens.
2. Browse and select the desired *.xstage file.
3. Click Open.

How to open a scene from the Welcome screen
1. In the Recent Scenes section, click Open Scene.
The Open Scene browser opens.
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2. Browse and select the desired *.xstage file.
3. Click Open.

How to open a recent scene from the Welcome screen
1. In the Recent Scenes section, select a scene from the list.

How to open a recent scene from the File menu
1. From the top menu, select File > Open Recent.
2. Select a scene from the displayed list.
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Saving a Scene
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in
the title bar beside the scene name to indicate that the scene contains unsaved changes.
To save the current state of a scene as another scene, you can use the Save As command. The Save As
window prompts you to give a new name and choose a different location to this scene before saving it.
This will create a complete scene directory for the new scene.
It is quite frequent, when working on a scene, to try out different timings, effects, camera motions or
parameters to see which one will work best. Harmony allows you to save a new version of your scene.
It is really important to note that the drawings and palettes are the same between ALL the scene
versions. You can modify the timing, effects, parameters and camera motion, but if you modify the
drawings, they will be changed everywhere.
You can also automatically save your work. Refer to the Preferences guide to learn more about this
function.

How to save a scene
‣

From the top menu, select File > Save.

‣

Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

How to save a scene as a new copy
1. From the top menu, select File > Save As.
2. In the Save As dialog box, browse to the location of the new archive and give the copy of the scene
a new name. The name cannot exceed 23 characters.
3. Click Save.

How to save a new version of a scene
1. From the top menu, select File > Save As New Version.
The Save Version dialog box opens.
2. In the Save Version dialog box, type the new version name.
3. Click OK.

Auto-Save
How to open the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the General tab.
3. In the Save section, select the Auto-save option.
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•

Interval (minutes): This is the frequency at which the auto-save takes place.

•

Inactivity Interval (seconds): When Auto-save is about to take place, it verifies if you are drawing
or doing anything in the application. If so, Auto-save waits this number of seconds before
attempting another save.

•

Ask Before Saving: Before performing an auto-save, you are prompted with a message to
confirm if you want to save or not. You can choose to turn off this option.

•

Enabled: This enables the Auto-save feature. If you do not want the system to automatically save
your work, deselect this option. The auto-save is off by default.

How to enable and disable the Open in Read Only mode if plugin syntax errors are
detected preference
How to open the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the General tab.
3. In the Save section, enable or disable the Open in Read Only mode if plugin syntax errors are
detected option.
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Setting the Scene Length
Once you have opened your scene, you can set its length.

How to set the scene length
1. From the top menu, select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

New Scene Startup Script
When you create a new scene, the TB_sceneCreated script automatically sets the scene length to 60
frames and adds one of each of the following modules: drawing element, composite, display and
write.
You can find the script in the Script Editor window.

You can customize this script to fit your current project needs. This way, you can set the default scene
length to any number of frames you want, or even decide which types of elements and modules you
want to be in your scene when you create it.
Refer to the Toon Boom Harmony Scripting Guide to learn more about using, creating and
customizing scripts.
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Adding a Drawing Layer
Now that your scene is set up, you can start adding drawing layers.

How to add a drawing layer from the Timeline view
1. In the Timeline view, click the Add Drawing Layer

button the .

The Add Drawing Layer window opens.

2. In the Name field, name your new layer.
3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a
bitmap layer.
4. Click OK.
A new drawing layer is added to the Timeline view.
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Scene Settings
When you created your new scene, you set up the resolution and the alignment. However, if you want
to change these initial settings later, you can do it using the Scene Settings dialog box. The different
Scene Settings options are separated into four tabs.

How to open the Scene Settings dialog box
1. From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
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Scene Settings

Resolution Tab

Parameter

Description
You can select your project’s resolution (camera frame size) from this
preset list.

‣ HDTV: High definition television delivers a higher quality image than
standard television (4:3) does, because it has a greater number of
lines of resolution. To take advantage of the superior quality your
output device must be compatible with HDTV technology to make
this resolution setting useful.

‣ HDTV_Vertical: The "vertical resolution" of HDTV_Vertical refers to

Resolution Presets

how the images will be aligned in relation to the actual scene frame
(default 4:3 grid). Note that the camera resolution and the scene
frame are not the same. When working with 12 or 16 field drawing
grids, the grid is a different aspect ratio from the camera frame.
When you fit vertically, you fit the images with the top and bottom of
the scene grid.

‣ film-1.33: Use this resolution setting for the academy film format
that conforms to the standard 4:3 aspect ratio.

‣ film-1.66: Use this resolution setting for the widescreen film format
that conforms to the 16:9 aspect ratio.

‣ film-1.66_Vertical: This is essentially the same as film-1.66. Refers to
how the drawing is fit into the scene frame. When working with 12 or
16 field drawing grids, the grid is a different aspect ratio from the
camera frame. When you fit vertically, you fit the images with the top
and bottom of the scene frame.
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‣ NTSC: This is the standard analogue television broadcasting system
used in North America and conforms to the North American
standards on how rectangular pixels are displayed for computer and
television screens.

‣ PAL: This resolution works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

‣ Low: This format is ideal for videos destined for the web, where size
and fast download of a video file might take precedence over
quality.
Selected Resolution
Preset

Displays the selected resolution preset.

Save Resolution Setting

Click the Save Resolution button after you define your new resolution
to save it as a preset.
Displays the pixel dimensions for your project resolution.

Pixel Dimensions

Aspect Ratio

Frame per second

Field of View

If you decide to type in the pixel dimensions, or use the up and down
arrows to change the pixel increments, you will have to save your
custom selection in order to save it as a new preset. It will then appear
in the resolution selection list. It doesn't modify the current resolution
preset.
Displays the ratio between the horizontal and vertical dimensions of the camera
framing. Each resolution setting has a preset aspect ratio that cannot be
changed.
Sets the frame rate for your project. The higher the frame rate, for
example 30 fps, the faster the animation will pla. The lower the frame
rate, for example 12 fps, the slower your animation will play. Avoid
going under 12 frames per second as your animation will have a
choppy playback. The human eye requires a minimum of 12 frames per
second to perceive a fluid animation.
Use these options to define the FOV (field of view) of the camera
(angle of the camera cone) and how the drawing elements (and
drawing grid) align to the scene grid. The drawing grid is always
scaled proportionally to a 4:3 ratio (unless you change the scene
alignment), therefore changing the Field of View setting may not show
a visible difference if your project resolution is also 4:3, such as NTSC.

‣ Horizontal Fit: The camera resolution is set to fit the left and right
edges of the scene grid.
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‣ Vertical Fit: The camera resolution is set to fit the top and bottom
edges of the scene grid.

‣ Custom Fov: After selecting this option, use the now-active field to
the right to enter in a value, in degrees, of the angle that you want
the camera cone to be. Increasing this value will make the camera
cone wider (the angle is more obtuse), widening the FOV and
making the grid and all elements appear farther away. Decreasing
the default value will create the opposite effect.
The Projection settings allows you to modify the type of camera your
scene is using. You can either use a perspective camera (regular
camera) or orthographic camera (no perspective).

‣ Perspective: The Perspective option is the default and most
Projection

common option. Objects placed closer to the camera will be
displayed bigger and objects placed further away will be displayed
smaller.

‣ Orthographic: The Orthographic option is very specific to the
gaming pipeline. It changes the camera from Perspective to
Orthographic, meaning that there is no more perspective in the
Camera view. Objects, when moved in depth will not change size.
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There is more information available about this option in the Gaming
user guide. In order to create scenes with the Orthographic camera
by default, you need to create a new custom scene resolution.

Alignment Tab

Parameter

Description
The Alignment presets give you two preset options:

‣ 4:3 12 Fields: Defines the units of your project to have a 4:3 ratio
Alignment

and sets up 12 of these units to run both vertically and horizontally in
four cardinal quarters (NW, NE, SW, SE). This Alignment preset is
visible in the FOV and drawing grids.

‣ Square 12 Fields: Defines the units of your project to have a 1:1 or
square ratio and sets up 12 units to run both vertically and
horizontally in four cardinal quarters (NW, NE, SW, SE). This
Alignment preset is NOT visible in the FOV and drawing grids.

Units Aspect Ratio

In the Units Aspect Ratio fields, enter the aspect ratio of the grid you
will use. The aspect ratio describes the shape of the grid unit. A
square grid unit would have the ratio 1:1, whereas a grid unit of aspect
ratio 4:3 is a unit with one side 1.33 times as big as the other side.
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If the aspect ratio you want to use is 1:1, enter 1 in the Left/Right field
(X-axis) and 1 in the Up/Down field (Y-axis). The default Aspect Ratio is
set to 4:3 as it is the one used by traditional animators, who are
accustomed to working with the grid system described above.
In the Number of Units fields, enter the number of horizontal, vertical
and depth units for your scene’s grid.

Number of Units

Animators who prefer to work traditionally will understand the default
setting of 24 units horizontal by 24 units vertical as it, once again,
corresponds to the grid above. Twelve is a common setting for the
field depth.
Those who prefer to work in pixels should enter the pixel dimensions
(3) of their project. This way if you want to move something over 600
pixels you just need to type in 600 units.
In the Coordinates at Centre, you can enter a new coordinate for the
centre of your scene.

Coordinat
es at
Centre

Save

By default, the (0,0) centre is set in the middle of the grid as shown in
the grid above. If you want to change the centre of your grid, for
example to the upper left corner, you would enter (-12, 12), -12 units
across and 12 units up. That is of course unless you changed the
number of units to match the pixel dimensions of your scene. Then you
would enter negative half the width and positive half the height.
Saves your current Alignment settings and be able to select them later from the
list.
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If you change your scene‘s alignment from 4:3 12 Fields to Square 12 Fields part way though your project,
you may find that the animation grid becomes offset. To correct this, choose the following setting from the
Layer Properties panel‘s Advanced tab: Alignment > Alignment Rule > Centre First Page.

Bitmap Resolution Tab
The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter

Description

Scene Resolution

This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have artwork at the four corners of your camera frame or even quite far outside
of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.

Height

This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.
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Scene Settings

Advanced Tab

The Advanced tab contains an option for Toon Boom Digital Pro release 7.3 and Harmony release
7.3.
Since version 7.8, the method in which Z-Ordering is calculated has been optimized. Enable this
option if you want to use the version 7.3 system.
Toon Boom Digital Pro and Toon Boom Harmony 7.3 allowed smaller values on the Z-axis such as
0.0001. Since version 7.8, the Z-ordering calculation is now optimized and allows only larger values
such as 0.001.
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Verifying the Project Integrity
The Check Files command verifies the integrity of the drawing and palette files in your project.

How to open the Check Files dialog box
‣ From the top menu, select > Check Files.

Check Files
Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

•

Click Check Colours to open the Check Colours dialog box.

Check Colours
The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Verifying the Project Integrity

Related Information
Scenes
Frame Rate and Format

50
49

Related Tasks
Creating and Opening Scenes
Saving a Scene
Setting the Scene Length
Adding a Drawing Layer

69
73
75
76

Reference Materials
Scene Settings

77

92

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

Basic Commands
This table lists the most common commands used in Harmony.
Command
New

Open

Action

Access Methods

Starts a new scene
while closing any scene
already open. The New
Scene dialog box
opens, asking for
directory, name, and
resolution information.

File > New

Displays the Open
Scene dialog box.
Browse your file system
for a scene file.

File > Open

Press Ctrl + N
(Windows/Linux) or ⌘
+ N (Mac OS X).

Press Ctrl + O
(Windows/Linux) or ⌘
+ O (Mac OS X).

The Open command is
not disabled when a
scene is opened. You
can open a new scene
from the current one
and the previous scene
will be closed.
Open Recent

Displays a quick access
list to view and open
recently used Harmony
files.

File > Open Recent

Open Recent > Clear

Clears the recently
opened Harmony files
list.

File > Open Recent >
Clear

Close

Closes the currently
opened scene, but does
not close the Harmony
application.

File > Close

Save

Saves all changes made
to the opened scene,
drawings, palettes, and
palette lists.

File > Save

Saves the current state
of a scene as another
scene. The Save As
window prompts you to
give a new name and
choose a different
location to this scene

File > Save As

Save As
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Command

Basic Commands

Action

Access Methods

before saving it. This
will create a complete
scene directory for the
new scene.
The scene name
cannot exceed 23
characters.
Save As New Version

Saves the current scene
as another version. The
Save Version dialog box
prompts you to give a
name for this new
version. This will create
a new .xstage file in
your current project
directory.

File > Save As New
Version

Quit

Closes
HarmonyHarmony
Stage.

Windows/Linux: File >
Quit

Removes selected
objects. You can then
paste the object or its
properties to another
object.

Edit > Cut

Copies selected objects
and properties.

Edit > Copy

Places an object you cut
or copied into the
location you select in
the Camera, Drawing
and Timeline views.

Edit > Paste

Removes selected
objects.

Edit > Delete

Selects all drawing
objects in the current
drawing window in the
Drawing, Timeline and
Camera views. This

Edit > Select All

Cut

Copy

Paste

Delete

Select All

Mac OS X: Stage>
Quit

Press Ctrl + X
(Windows/Linux) or ⌘
+ X (Mac OS X).

Press Ctrl + C
(Windows/Linux) or ⌘
+ C (Mac OS X).

Press Ctrl + V
(Windows/Linux) or ⌘
+ V (Mac OS X).

Delete
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Command

Action

Access Methods

helps you manage
multiple objects as one
when moving them.
Deselect All

Deselects all selected
objects in the Drawing
and Camera views.

Edit > Deselect All

Removes remove the
last change made to
your project. Harmony
supports multiple undo,
so you can undo
changes you made in
the order you made
them.

Edit > Undo

Redoes and operation
you have undone that
you later decide to
keep. This command is
active only after you use
the Undo command.

Edit > Redo

Help

Launches the Toon
Boom Harmony Online
Help system, complete
with instructions on
how to use the system.
This requires an
internet connection.

Help > Help

Toon Boom Harmony
on the Web

Launches the Toon
Boom Harmony
website, which features
a Support and
Community > Forum
section.

Help > Toon Boom
Harmony on the Web

About

Use the About
command to access
general information
about the software.

Windows/Linux: Help
> About

Brings back the
Welcome screen

Help > Show
Welcome Screen

Undo

Redo

Show Welcome
Screen

Esc

Press Ctrl + Z
(Windows/Linux) or ⌘
+ Z (Mac OS X).

Press Ctrl + Shift + Z
(Windows/Linux) or ⌘
+ Shift + Z (Mac OS X).

Mac OS X: Stage >
About
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Preferences

Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can
customize your interface, tool behaviour and shortcuts. Throughout this guide, you are often required
to go to the Preferences dialog box to set parameters and options.
To learn about the different preferences available, refer to the Preferences Guide.
How to open the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
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Chapter 9: Interface
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize
your workspace conveniently. There are a series of views and toolbars you can use as you perform
different operations. Usually, each person has a specific way of working in the interface and prefer
particular views and toolbars. In this chapter, you will learn about the main elements of the interface
and how to manage them.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. is a subset of
Harmony Stage.

The Harmony interface is set to a dark theme by default. You have the option of switching to a light
theme.

How to change the interface theme
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X) .
The Preferences dialog box opens.
2. Select the General tab.
3. In the Options section, deselect the Use Dark StyleSheet option to use the light theme.
4. Restart Harmony.

This chapter is divided as follows:
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•

Menus on the facing page

•

Managing the Views on page 95

•

Managing the Toolbars on page 99

•

Managing the Workspace on page 104

•

View References on page 109

•

Toolbar References on page 136

•

Interface Navigation on page 139
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Menus
Harmony has a large number of functions and options that you can access from the following menus:

Top Menu
The top menu contains most of the commands. Depending on the view you are working in and the
element, some commands are available and others not. The top menu is always located at the very
top of the interface.
The top menu contains the following categories:
•

File

•

Edit

•

View

•

Scene

•

Drawing

•

Windows

•

Help

On Mac OS X, there is a Stage category containing the following commands:
•

Preferences

•

About

•

Quit

View Menu

Some views have their own menu. These menus contain commands specifically related to that view.

How to access the view menu
1. In the view's top-left corner, click the Menu

button.

A list of commands is displayed.
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Quick Access Menu

Each view has a quick access menu containing commands you will use most often. This menu is
accessed by right-clicking anywhere in the view.
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Managing the Views
The Harmony user interface is composed of different views, each one designed for a specific purpose.
You can modify the location and accessibility of the views by adding a new view as a tab or as a
window. You can also swap the view locations around.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. is a subset of
Harmony Stage.

It is important to know about the active view. When a view is active, a red rectangle appears around
the view. Keyboard shortcuts and top menu options are linked to the active view. If a menu option is
greyed out, it either means it does not apply to your layer, drawing or other type of selection or the
option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application unless you deselected
the Automatically Save Workspace option in the Preferences dialog box.

How to add a view
1. Select the view you want to add from Windows > the desired view.
‣

You can also use the Window drop-down menu button in each view. Click the Add View
button and select a view from the list.You can open several instances of the same view
except for the Timeline, Tool Properties, Colour and Drawing views.
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By default, the view appears tabbed.

How to dock a floating window in the workspace
1. Drag the window’s tab onto one of the workspace’s views. You can drop the view onto the other
existing tabs to tab the view with the other ones. You can also drop the view onto either side of an
existing view to insert the floating one beside it. When you get close to one of the edges, a black
rectangle will appear, indicating where the view will be inserted.

How to close a view
1. Click the Close View
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button.
‣

If there are several tabs in the same window, hold Shift down and click the Close View
button to close all tabs together.

How to swap views around
1. Select the view's tab and drag it onto one of the view’s separators, top area or onto another
view’s tab.
2. When a blue rectangle outline appears showing an available location for the view, release the
mouse button and drop the view tab into position. One of three things will happen:

•

The view becomes a tabbed window.

•

The view becomes a floating window.

•

The view becomes a new docked window.

How to resize a view
1. Position your cursor on the edge of the view you want to resize.
2. When you see the Resizing
or height.

cursor, click and drag the side of the window to the desired width
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You can also temporarily hide a view to get more working space.

How to temporarily hide a view
1. On the edge of the window you want to hide, click the Collapse/Expand button.
The view is compressed and only the Collapse/Expand button is visible.
2. Click the Collapse/Expand button again to redisplay the view.
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Managing the Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some of the
workspace’s views also have their own toolbars which you can move around. You can reposition the
toolbars to suit your work style or hide unused ones.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. is a subset of
Harmony Stage.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars
of the views that are displayed in the workspace. As you show or hide views in your workspace, the
Toolbar menu updates.
The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be
displayed. If a toolbar is already displayed in the top area and you decide to display it in a view, the
selected toolbar will move from the top area to the view.
The View toolbars can be customized to contain your favourite tools and options. Using the Toolbar
Manager window, you can organize different toolbars to suit your working style.
If you prefer to have all your tools visible in the Tools toolbar, the Flat Tool Toolbar option allows you
to expand the toolbar so there are no nested toolsets in the toolbar. When you set this option, you
will need to close Harmony and restart it for the new interface to be displayed. A default set of tools
will appear in the toolbar. However, you can customize which tool icons appear in the toolbar to fit
your work pattern.

If the default toolbar does not contain the tools you require, you can customize the toolbar.
Once you are displaying the flat toolbars, you can customize the tools which appear in the toolbar.
This means that you can change the default set of tools and replace the tools you use less frequently
with ones use more often. This customizing is done through the Toolbar Manager.

How to show and hide a toolbar
1. From the top menu, select Windows > Toolbars > the desired toolbar.
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‣

Managing the Toolbars

You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars,
however, are not available by right-clicking the toolbar area. You can access the toolbar of
any open and active view by right-clicking in the view's top area or the Windows menu.

How to resize a toolbar
1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.
2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.
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How to move a toolbar
1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar
area or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse
button and drop the toolbar into position.

‣

1. Dock to the top toolbar area.
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‣

2. Move a toolbar down a row.

‣

3. Dock to the left toolbar area.

How to customize a view toolbar
1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a
new button. You can also reorder the buttons. Make sure the button you right-click on is active.
2. From the menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and
click the Right Arrow
button to switch it to the Toolbar list.

4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the
Left Arrow
button to switch to the Available Tools list.
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5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and
click the Up
or Down
buttons to move it to the correct location.

6. Click OK when you are finished.

How to use enable the Flat Tool Toolbar preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).
2. In the Preferences dialog box, select the General tab.
3. Select the Flat Tool Toolbar option.
4. Click OK.
5. Save your work and close Harmony.
6. Restart Harmony.
The Tools toolbar no longer contains nested tools.
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Managing the Workspace
The Harmony interface is composed of several views. You can customize your workspace to suit your
working style, save it as a new workspace, and load it from the Workspace toolbar.
The first time you open Harmony, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and Compositing workspaces. These display different views and
toolbars. You can access these workspaces, and any others you create, from the Windows menu and
the Workspace toolbar.
By default, when you modify the look of a workspace, it is automatically saved. If you prefer to keep
your workspaces as they are and only save the modifications when you really want to, you must disable
the Automatically Save Workspace option.
The Workspace Manager allows you to modify, create, delete, rename and reorder you workspaces.
You can save your workspace as a new version to avoid over-writing the current one. If you do not
want to modify the current workspace, use the Workspace Manager to create another one and then
modify that one.
You can also restore modified workspaces to their original default layout if you do not like the current
modifications or inadvertently closed some windows.

How to load a workspace
1. Do one of the following:
‣

From the top menu, select Windows > Workspace > Workspace.

‣

Select a workspace from the Workspace toolbar.

How to open the Workspace Manager
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1. Do one of the following:
‣

In the Workspace toolbar, click the

‣

From the top menu, select Windows > Workspace > Workspace Manager.

button.

How to create a new workspace
1. Open the Workspace Manager.
2. In the Available Workspaces list, select an existing workspace.

3. At the bottom of the Available Workspaces list, click the Add

button to add a workspace.

4. Select the new workspace that was created. Click Rename and give it a new name.
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5. Select the new workspace and click the Right Arrow
toolbar.

button to move it to the Workspace

6. Click OK.

How to rename a workspace
1. Open the Workspace Manager.
2. Choose the workspace to be renamed from the list.
3. Double-click on the workspace to be renamed or click the Rename button. This allows you to edit
the name.

4. Type in the new name of the workspace.
5. Press the Enter/Return key to validate the name.
6. Click OK.

How to disable the Automatically Save Workspace preference
1. From the top menu, select Edit > Preferences (Windows/Linux) orStage > Preferences (Mac OS
X) to open the Preferences dialog box.
2. Select the General tab.
3. In the Options section, deselect the Automatically Save Workspace option.
4. Click OK.
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The Save Workspace

button appears in the Workspace toolbar.

How to save a workspace manually
1. Do one of the following:
‣

In the Workspace toolbar, click the Save Workspace

‣

You can also select Windows > Workspace > Save Workspace.

button.

How to save your workspace as a new version
1. From the top menu, select Windows > Workspace > Save Workspace As.
The Save Workspace As dialog box opens.
2. Type in a workspace name and click OK.

How to delete a workspace
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be deleted and click the Left Arrow
button to move it to the Available Workspaces list.

3. Select the workspace from the Available Workspaces list, then click the Delete
delete the workspace.

button to

4. Click OK.

How to show a workspace
1. Open the Workspace Manager.
2. In the Available Workspaces list, select the workspace to be displayed and click the Right Arrow
button to move it to the Workspace toolbar.
3. Click OK.

How to hide a workspace
1. Open the Workspace Manager.
2. In the Workspace Manager, select the workspace to be hidden and click the Left Arrow
to move it to the Available Workspaces list.
3. Click OK.
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How to reorder workspaces
1. Open the Workspace Manager.
2. In the Workspace toolbar, select the workspace to be reordered and on the Up
buttons to move it up or down.

3. Click OK.

How to restore the default workspaces
‣ From the top menu select Windows > Restore Default Workspace.
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View References
Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views
available:
•

Camera view

•

Colour view

•

Message Log view

•

Model view

•

Script Editor view

•

Timeline view

•

Tool Properties view

•

Xsheet view

Camera View
The Camera view is the centre of operations in Harmony. In this view, you will draw, paint, animate,
create animation paths and see your results. You can also move through your symbol’s hierarchy.
The Camera view has a top and bottom toolbar that you can use to navigate in the view, change the
display mode, or go back up your symbols hierarchy.
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1. Light Table

When you have a drawing layer or drawing selected, the Light Table button
button allows you to
fade the colours of the other layers so you can see the current artwork better as you edit with a
drawing tool. Note that the light table does not work when using a layer editing tool such as the
Transform
tool.

2. Current Drawing On Top

When this button is enabled, the drawing that you are currently editing with a drawing tool is
temporarily displayed in front of all the other elements. The actual scene is not modified.

3. Camera Mask

The Camera Mask
button shows or hides a black mask around the scene’s frame to avoid seeing
the unnecessary artwork. This option is handy when you are animating and setting up the scene. It
allows you to see your scene’s composition better.
You can also access this feature from the top menu by selecting View > Show > Camera Mask.

116

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

4. Safe Area

The Safe Area
button shows or hides the TV safety zone and the centre of the camera frame. The
Safe Area will adapt to the scene resolution as well as the safety zone and frame’s centre.
You can also access this feature from the top menu by selecting View > Show > Safe Area.

6. Outline Locked Drawings

Drawings that are locked in the Timeline view (cannot be selected in the Camera view) will be
displayed as wireframes.

7. Reset View
The Reset View
button will reset any panning, zooming or rotation done in the Camera view and
return the display to the initial settings. You can also press Shift + M.

8. Zoom Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.
To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press 1 and 2.
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9. OpenGL View Mode

The OpenGL View Mode
button switches the Camera view to fast display, letting you see your
animation play in real time. The OpenGL display requires less memory. The final look of your effects
is not shown in the OpenGL View Mode. You must switch to the Render View Mode to see your
effects.

9a. Render View Mode
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The Render View Mode
button switches the Camera view to a fully rendered display showing the
final image of the current frame. If a modification is done to your current frame or if you move to a
different frame, click the Update Preview button to update the display if your preview does not
update automatically.
The Render View Mode display lets you see the final look of your frames including effects and
antialiasing. You cannot play back your scene in Render View Mode. To see your scene fully rendered
and to play it back, you must press the Render and Play
button in the Playback toolbar.

9b. Matte View Mode

The Matte View Mode
button switches the Camera view to a matte display showing the alpha
channel of the elements in your scene. The transparency level ranges from 0 to 100 percent. Zero
percent is completely transparent and represented by black and 100 percent is completely opaque
and represented by white. Everything in between these extremes has a transparency level
somewhere between 1 and 99 percent and is represented in various shades of grey.
‣

To access the Matte View mode, click on the Render View Mode
Matte View from the drop-down menu.

button and select

10. Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it.
If the cell does not contain any drawing, an Empty Cell text is shown in the field.

11. Tool Name
The Tool Name field displays the name of the selected tool. If you temporarily override a drawing
tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily
override a tool by holding its keyboard shortcut without the [Alt] key. For example, the Select tool
shortcut is Alt + S. If you hold down [S], you will switch to the Select tool. As soon as you release the
key, you will return to the tool you were using.

12. Frame Number
The Frame Number field displays the number of the current frame.

13. Selected Colour
The colour swatch displays the currently selected colour in the Colour view.

119

Chapter 9: Interface

View References

14. Camera View Toolbar
The Camera View toolbar contains all the tools and options you can use in the Camera view to draw,
animate or set up the scene. The toolbar can be displayed or hidden by right-clicking on it and
selecting or deselecting the Camera View toolbar.

15. View Menu
The View menu contains all the tools and options that you can use in the Camera view to draw,
animate or set up the scene.

16. Editing Stack Menu
The Editing Stack menu displays the names of the symbols and their hierarchy when you are editing a
symbol. You can click on the different names to go back up to the different parent symbols or the
top/current project.

Colour View
The Colour view is where you create colours and palettes and import existing palettes into your
project. The Colour view is also necessary for drawing, painting and creating colour styling.

The Colour view has two display modes:
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•

List mode

•

Swatch mode

How to switch between the display modes
1. From the Colour View menu, select Colours > Swatch Mode and do one of the following:
‣

Select the option to display the swatches.

‣

Deselect the option to display the colour list.

When you are painting on bitmap layers, the Colour view will look like the following. It contains a
subset of the tools available when working with vector layers.

1. Add Colour
The Add Colour

button lets you add a new colour swatch to the bottom of your colour list.

2. Remove Colour
The Remove Colour
button lets you delete the currently selected colour swatches. If the colour
swatch is used in your project, the Delete Colour dialog box will appear asking you to confirm the
operation.
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‣ Click OK to confirm the operation or Cancel to cancel it.
Zones painted with colour swatches which have been deleted will turn red, easily identifying them so
you can repaint them with another colour swatch.

3. Add Texture

The Add Texture
button lets you add a bitmap colour swatch to your palette. You can load
photos and textures and paint your drawings with it. The bitmap image must be a TGA or PSD file
format.

4. Set Current Brush Colour
The Set Current Brush Colour
button let you set the currently selected colour swatch as the
colour used by the Brush
tool. If you select a new colour in the Colour view while using the Brush
tool, the Set Current Brush Colour swatch will be updated.

5. Set Current Pencil Colour
The Set Current Pencil Colour
button lets you set the currently selected colour swatch as the
colour used by the Pencil
, Polyline
, Ellipse
, Rectangle
and Line
tools. If you
select a new colour in the Colour view while using any of these tools, the Set Current Pencil Colour
swatch will be updated.

6. Set Current Paint Colour
The Set Current Paint Colour
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button lets you set the currently selected colour swatch as the colour used by the Brush
tool. If you select a new colour in the Colour view while using the Paint tool, the Set Current Paint
Colour swatch will be updated.

7. Link/Unlink Three Colours

The Link/Unlink Three Colours
button lets you link the Set Current Brush Colour, Set Current
Pencil Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the
Colour view.

8. Show/Hide Palette List View

The Show/Hide Palette List View button lets you display the Palette List view in the Colour view. This
option is for the advanced user who wants to create colour palettes for their props and characters.

9. Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify
which colour is used to paint what part of your character or background.
Two colours can have the same name.
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10. Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour
palettes are composed of colour swatches. They can also be called colour pots. When you paint a
zone with a colour swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the
zone will be updated along with it. This allows you to modify your animation colours even after it is
completely painted.

11. Colour View Menu
The Colour view
menu lets you access commands related to the Colour view such as creating
new palettes, adding new colour swatches, and displaying the Tint panel.

12. Add Palette
The Add Palette

button lets you add a new palette to the bottom of your palette list.

13. Remove Palette
The Remove Palette
button lets you delete the currently selected palette. If the colour swatch is
used in your project, zones painted with colour swatches which have been deleted will turn red,
easily identifying them so you can repaint them with another colour swatch.

14. Link Palette
The Link Palette button lets you access other palettes created in the project and link them to your
scene.

15. Order Palette List
The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour
styles), the highest palette is the list will override its clone located lower in the list.
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Message Log View
The Message log view displays information gathered during a render task, such as which frames and
at what time they were each rendered. The view also contains a list of the colour recovery operations.

Model View
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view.
This drawing can be used and loaded in any of your Harmony scenes.
Once a drawing is loaded in the Model view, you can use the Dropper
tool to select a colour from
the model and use it to paint in the Camera or Drawing view without having to pick the colour from
the colour palette.
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Script Editor View
Qt Script provides access to many of the functions supported in the interface. With Qt Script, you can
automate a number of Harmony functions to speed the completion of various repetitive tasks. The
Script Editor view allows you to edit existing scripts and create new ones. Refer to the Scripting guide
to learn more about scripting with Harmony.
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Script List
On the left side of the Script Editor view, all existing script files are listed and can be modified in this
view. The script format is JavaScript. Click on a file to display its content in the Script Content
window of the view.

Script Content
On the right side of the Script Editor view, the contents of the selected script are displayed and can
be edited.

Search Toolbar
The Search toolbar allows you to search a string within the selected script content. You can use the
Previous and Next buttons to navigate through the results.

Syntax Check
This function verifies the syntax of the currently displayed script and lists any error found.

Save Changes
Once you are satisfied with the modifications made to the script, click Save Changes to save the
modifications.

Timeline View
To set your animation timing, you will mostly work with the Timeline and Xsheet views. It is extremely
useful to become familiar with the Timeline view, how it works, and its interface.
The Timeline view is the main view used when adjusting the timing of drawings, adding keyframes and
ordering layers. The Timeline view displays layers, effects, sounds, keyframe values, scene length, layer
names, drawings, keyframes, timing, and frames.

The Timeline view allows you to read your timing from left to right. It represents the scene’s elements
in their simplest form. You can also see the layers and their names, as well as the drawing’s exposure.
The drawing name is displayed when you place the cursor above the drawing’s exposure.
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You can see the drawing name when you display the Data view. The name of the drawing folder to
which the layer is linked is displayed in the Data view.

1. Enable/Disable All
The Enable/Disable All

button is used to show or hide all layers simultaneously.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view. When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline
view.
To disable a particular layer, deselect the layer’s checkbox or press D.

To enable a particular layer, select the layer’s checkbox or press A.
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2. Show Selection and Hide All Others

The Show Selection and Hide All Others
button is used to show only the currently selected layer
in the Timeline view and disable all the other layers.

3. Add Layers
The Add Layers
button lets you add new layers to the Timeline view. When you click the Add
Layers button, a drop-down menu will appear displaying the layer types available. You can add
several different types of layers:
•

Camera

•

Colour-Card

•

Drawing

•

Peg

•

Quadmap

•

Effect

•

Sound

•

An effect layer made in Harmony Draw will appear with this symbol
Boom Harmony.

when opened in Toon

4. Delete Layers
The Delete Layers

button lets you delete the currently selected layers in the Timeline view.

5. Add Drawing Layer
The Add Drawing Layer
button lets you automatically add a new drawing layer to the Timeline
view. By default, the layer is named Drawing.

6. Add Peg
The Add Peg
button lets you add a peg layer to your timeline. If one or several layers are
selected a peg will be added and parented to each individual layer.

7. Show/Hide Data View
The Show/Hide Data View
button lets you display the current frame’s drawing exposure and
keyframe values corresponding to each individual layer.
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•

Hidden Data View

•

Visible Data View

8. Current Drawing Displayed
The highlighted drawing represents the drawing currently displayed and is linked to play head
position.

9. Current Frame
The red play head represents the current frame displayed and marked in the Playback toolbar. If you
slide the play head to the left or right, it will scrub through your frames and update the Camera view.

10. Split
The Split
button lets you split the Timeline view in two sections, allowing you to see two
different portions of the Timeline view. This way, if your scene length is very long, you can see the
beginning and the end at the same time.
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11. Collapse/Expand Children
The Collapse/Expand Children button is used to display the children layers of a parent layer. Once a
layer is parented to another layer, it is indented to the right and the Collapse / Expand Children
button appears on the parent layer allowing you to show or hide the child layer.

12. Show/Hide Functions
The Show/Hide Functions
button lets you display the functions embedded in each layer. The
functions are the different coordinates and value used to record a layer’s parameters at each frame.
This information is stored on the function curves using keyframes.

13. Change Track Colour
The Change Track Colour
button lets you change the colour of the exposed frames; this helps
you to quickly locate a layer in the Timeline view. Double-click on the colour swatch to open the
Select Colour window and choose a new colour. You can modify the layer for any type of layer, such
as group, peg, drawing, and effects.
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14. Lock/Unlock Layer
The Lock/Unlock Layer
button lets you prevent the selection or editing of a layer in the
Camera view. To select some of the layers without selecting others, in the Timeline view, lock the
layers you do not want to select.

In the top menu, there are a series of locking options. Select Animation > Lock > select one of the
following actions:
•

Lock: Locks the currently selected element.

•

Unlock: Unlocks the currently selected element.

•

Lock All: Locks all the elements in the Camera view.

•

Unlock All: Unlocks all the elements in the Camera view.

•

Lock All Others: Locks all the elements in the Camera view except the currently selected one.

You can display the locked drawings as outlines in the Camera view to quickly find out which
drawings are locked.
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How to display locked drawings as outline
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac
OS X).
2. In the Preferences dialog box, select the Camera tab.
3. In the Tools section, select the Show Locked Drawings As Outlines option.

15. Onion Skin

The Onion Skin
button enables the Onion Skin option on a particular layer. If you want to see the
previous and next frames of a specific layer, go to the Timeline view and click the Onion Skin button
for that particular layer. Blue arrows appear on both sides of the play head. Pull on the blue arrows
to add more frames to the onion skin display.
To activate the general Onion Skin preview, in the Tools toolbar, click the Onion Skin

button.

16. Drawing Substitution
The Drawing Substitution field is used to change the drawing exposed at the current frame. To
access the Drawing Substitution field, you must first expand the Data view by clicking the Show/Hide
Data View
button.

To change the current drawing, click the drawing value in blue and slide your cursor left or right when
you see the hand
cursor, or double-click on the drawing name and type in a new value.
The drawing exposure will be changed for the entire block it is exposed, not just the current frame.

17. Keyframe Value
The Keyframe Value field is used to add, remove or modify a keyframe at the current frame. To
access the Keyframe Value field, you must first expand the Data view by clicking the Show/Hide Data
View
button.
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•

To add a keyframe at the current frame, click the Add Keyframe

button.

•

To remove an existing keyframe at the current frame, click the Delete Keyframe

•

To change the current keyframe, either click and slide your cursor left or right when you see the
hand
cursor, or double-click on the keyframe value and directly type a new value.

•

To navigate through the existing keyframes, click the Previous Keyframe
Keyframe
buttons.

•

To link your layer to an existing function or to create a new function, click the Show Function
Menu
button to display the drop-down Function menu.

button.

and the Next

18. Zoom
The Zoom tool is used to increase or reduce the width of the frames in the Timeline view. Drag the
cursor to the right to increase the width or to the left to reduce it. You can also press 1 and 2.

19. Keyframe
A black or red square is displayed in the Timeline view when a keyframe exists. You can select these
keyframes and drag them wherever you want on the timeline. You can also copy, cut and delete
them.
•

To delete a keyframe without deleting the drawing exposure, go to the Timeline view and select
the keyframe to be deleted and then select Animation > Delete Keyframes from the top menu.

When a parent layer is collapsed and a child layer contains a keyframe, a white square will be
displayed.

20. Drawing Exposure
In the Timeline view, when a drawing is exposed, it is represented as a grey block. If the drawing is
exposed for several frames, the block is extended. When a second drawing is exposed, a new grey
block is displayed.

•

The exposure’s colour can be changed. To pick a new colour, double-click on the Change Track
Colour
button in the corresponding layer.

21. Dragging and Pasting Modes
As you animate, you will find that you reuse many positions, drawings, and keys. However, you may
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only want to paste the drawings or just the keys or maybe everything. There are different paste
options available in the Timeline view which give you maximum flexibility when reusing and pasting.
Note that these modes also apply when you use drag instead of copy and paste.
There are three different modes for pasting your selection:
•

Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

•

Paste Mode: Keyframes Only: Pastes only the keyframes.

•

Paste Mode: Exposures Only: Pastes only the drawing exposure.

22. Timeline View Modes
To streamline the process of working with elements in the Timeline view, there are three different
view modes you can choose to work in. With each mode you select, certain elements may or may not
be visible in the Timeline view. Depending on your workflow, this can be useful for quickly hiding
elements when you want to focus on specific ones. To select a view mode, use the drop-down menu
in the Timeline view.

Tool Properties View
The contextual Tool Properties view contains the most common options and operations related to the
currently selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view
updates.
For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view will display
the options and operations related to the Select tool, such as Snap to Contour, Apply to All Drawings,
Flip Horizontal, and Flatten.
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Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the
current task’s needs.

Operations
Operations are actions you can perform while using the selected tool.

Xsheet View
The Xsheet view lets you read the timing vertically, displays the drawing layers as columns, and shows
the drawing’s name. You can also see the functions and keyframes of the motion paths in the Xsheet’s
function columns. The value of each keyframe is shown in the Xsheet view; these are displayed as black
squares in the Timeline view. The Xsheet view contains more details than the Timeline view, and is
faster and easier to read.

1. Xsheet Main Section
The Xsheet view has three sections. By default, only the main section is visible. It displays the drawing
layers, also known as drawing columns.

136

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

. Column List Section

The Column List section allows you to show and hide columns in the Xsheet view. When you hide a
layer in the Xsheet view, it is also disabled in the Timeline view.
You can use the Column List to hide individual columns or hide an entire column type (drawing or
function) from the Xsheet view. By default, the Functions section is hidden.

How to display the Column List section
1. In the Xsheet view, click the Expand button on the right side of the main section to show the
Functions section. Click on the same button to collapse it. You can also use the Show Column List
button in the Xsheet View toolbar.
‣

In Harmony, you can also go to the Xsheet view menu and select View > Show Column
List.

2. Click the Expand button on the right side of the Functions section to display the Column List
section.
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. Xsheet View Toolbar
The Xsheet view has its own toolbar where you can find the most common features. This toolbar is
displayed by default. If you do not see it, select Windows > Toolbars > Xsheet View.
The Xsheet view must be part of your workspace in order to display its toolbar.

. Column Header
Each column available in the Xsheet view has a header displaying the column’s name. The column’s
name is the same as the corresponding timeline layer. If you rename one or the other, they will both
be renamed.
A quick access menu is available when you right-click. This menu contains the command affecting an
entire column such as renaming, changing the default colour, or deleting a column.
The tooltip that appears when you hover at the top of each Xsheet column shows the folder path to
the source drawings for that column.
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. Current Drawing
A drawing selected in dark red indicates that the drawing is currently displayed in the Drawing and
Camera views. The current drawing selection is not linked to the drawing displayed in the Camera
view since drawings from each visible layer are displayed at once.

. Current Frame
The darker frame appearing in the Xsheet view represents the current frame.

. Drawing Exposure
In the drawing columns, you can see the drawing names and their exposure. You can use any
alphanumeric symbol to name your drawing. When a drawing is exposed over more than one cell, a
vertical black line is displayed to indicate the continuity of the exposure. When there is no drawing in
a cell, the cell will be blank.

. Frame Numbers
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On the left side of the Xsheet view, the frame numbers are shown indicating where you are. These
read vertically instead of being displayed horizontally as they are in the Timeline view.
•

To go to a particular frame, click the frame number.

•

To select an entire range of frames, click and drag a selection downwards.

. Current Frame Display
At the bottom-right of the Xsheet view, you can see the current frame number, as well as the column
containing the drawing currently displayed in the Drawing view.

10. Function Column
The function columns are displayed in the Functions section of the Xsheet view. They represent the
motion and rotation you applied to a drawing layer.
A function column can also be related to an effect. Selecting the effect layer shows you the
corresponding function column in the Xsheet view.
The function columns display the position value or effect value on each cell. If there is a keyframe on a
cell, a black square is displayed. Holding the same value for several frames displays a vertical black
line.

. Increase/Decrease Exposure
You can quickly increase or decrease the exposure of the selected cell by clicking on the up and down
arrows in the Increase/Decrease Exposure field.

140

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

Overwrite/Insert Modes
The Overwrite/Insert button allows you to decide the way the values are inserted into the Xsheet.
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Toolbar References
Harmony has several toolbars. The Top toolbars are available at the top of the interface and the View
toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in
the workspace. This is a complete list of the toolbars available in Toon Boom Harmony.

Top Toolbars
Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These
options can also be found in the Edit menu.

File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options
can also be found in the File menu.

Flip Toolbar
This toolbar lets you enable what type of drawing to include in your flipping selection. You can flip
through the key, breakdown or in-between drawings individually, or view a combination.

Mark Drawing Toolbar
The Mark Drawing toolbar lets you identify drawings such as Key, Breakdown and In-between. The
drawing Identification feature can help the animator stay well organized and save time when
identifying key, breakdown or in-between drawings in the Xsheet and Timeline views.

Onion Skin Toolbar
When designing or animating, it is useful to be able to see your previous drawings. The Onion Skin
tool is used to preview the previous and subsequent drawings. By default, the previous drawings will
appear with a shade of red and the next drawings will be displayed with a shade of green, but you
can change the display options in the Preferences dialog box. In the Onion Skin toolbar, you can
select what type of drawing you want to display in your onion skin display.
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Playback Toolbar

The Playback toolbar lets you play back your animation and sound. Use it to scrub the sound to
create your lip-sync, loop the playback, navigate through frames, and change the playback range
and speed.
Name

Button

Description
Plays and stops the
animation.

Play

You can also select Play >
Play Scene Forward or
Stop.
Creates a render of your scene to
play back the final result including the
effects.

Render and Play

Repeatedly plays back your
animation indefinitely.

Loop

You can also select Play >
Loop.
Enables sound in the
playback.

Sound

You can also select Play >
Enable Sound.
Enables sound scrubbing in
the playback.

Sound Scrubbing

You can also select Play >
Enable Sound Scrubbing.
Lets you scroll through the playback’s frames.

Jog Frames

Lets you change the playback frame
range by entering new values in the
Start and Stop fields. You can also
click on the Start and Stop words to
set the start or end frame at the current frame.
Lets you enter a new value to change
the speed of the playback.

FPS

Scripting Toolbar
The Scripting toolbar lets you import and access the scripts created to automate actions and
operations.
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Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Harmony. In the default
workspace, you will find this toolbar on the left-most side of the interface.

Workspace Toolbar
The first time you open Harmony, the default workspace is loaded. Other workspaces are available
such as the Hand-Drawn Animation and Compositing workspaces; these display different views and
toolbars. You can access these workspaces and any you create, from the Windows menu and the
Workspace toolbar.

View Toolbars
Here is a list of the view toolbars available in Harmony:
•

Camera View Toolbar

•

Drawing View Toolbar

•

Model View Toolbar

•

Script Editor View Toolbar

•

Timeline View Toolbar

•

Xsheet View Toolbar
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Interface Navigation
Toon Boom Harmony supports zoom in, zoom out, rotate, pan and reset view for easy interface
navigation for the views.
Command

Action

Access Methods
View > Zoom In
Press 2 or roll the mouse
wheel up.

Zoom In

Zooms into the view.

In the Timeline view, press
Ctrl (Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel up.
View > Zoom Out
Press 1 or roll the mouse
wheel down.

Zoom Out

Zooms out of the view.

Zoom In or Out

Zooms in or out of the view.

Roll the middle mouse
button up or down.

Pan

Moving parallel to the view.

Hold down the Spacebar and
drag the mouse in the direction
in which you want to pan the
view.

Recenter view

Recenters the view on your mouse
cursor.

Press N

Reset Pan

Resets the view’s pan to its default
position.

Reset View

Resets the view to its default position.

Reset Rotation

Resets the view’s rotation to its
default position.

In the Timeline view, press
Ctrl (Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel down.

View > Reset Pan
Press Shift + N
View > Reset View

Reset Zoom

Resets the view’s zoom to its default
position.

Toggle Full Screen

Enlarges the selected view to full
screen. The full screen process is
done in three stages.
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View > Reset
Rotation
Press Shift + X
View > Reset Zoom
View > Toggle Full
Screen
Press Ctrl + F
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First, the selected view
enlarges to the maximum
width or height, but keeps
the tool views such as
Colour or Tool Properties
view.

(Windows/Linux) or
⌘ + F (Mac OS X)

Second, the view enlarges
to full screen.
Third, the view returns to
its original size.
Rotate 90 CW

Rotates the Camera view 90 degrees
clockwise, like an animation table.

View > Rotate View CW

Rotate 90 CCW

Rotates the Camera view 90 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

Toggle Quick Close-up

Use the Magnifier tool to
quickly center on the
mouse position and zoom
in to a pre-defined value
such as 4X. Then you can
zoom out again. Hold the
shift key and press Z to
zoom in and back out
again. Replacing the Reset
Zoom by pressing Shift +.
The area where you zoom
in or out is dependent on
the cursor location in the
Camera view. If you zoom
in and them move the
cursor to a different
location when you zoom
out the mouse will be
centered on that location.

Using the Play Menu to Navigate
From the top menu, you can select any of the following commands from the Play menu to navigate
around the interface.
Command

Description

First Frame

Jump to the first frame. You can also press <.

Next Frame

Jumps to the frame after the currently selected frame in the Timeline view.
You can also press the period (.) key.

Last Frame

Jumps to the last frame. You can also press >.

Previous Frame

Jumps to the frame before the frame currently selected in the Timeline
view. You can also press the comma (,) key.
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Opens the Go to Frame window in which you can enter the
number of the frame you want to display.
Go to Frame

Enable Playback

You can also use the Go button, which you can add to the
Timeline View toolbar through the Toolbar Manager. Open the
Go to Frame dialog box and enter the frame number to jump
to.
Plays back your animation from the Top, Side, or Perspective view.

Zoom Tool
From the Tools toolbar, use the Zoom
view.

tool to zoom in and zoom out in the Camera or Drawing

•

The keyboard shortcuts are 1 and 2.

•

When the Zoom In mode is selected, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom Tool Options

Button

Description

Zoom In

Zooms in

Zoom Out

Zooms out

Operations

Button

Description

Perform Zoom In

Zoom in the Camera or Drawing view.
The keyboard shortcut is 2.

Perform Zoom Out

Zoom out the Camera or Drawing view.
The keyboard shortcut is 1.

Reset Zoom

Restores the current zoom level to 100%.

Reset View

Restores the original display by resetting
any pan, rotation or zoom actions.

Navigating between Frames and Columns
Once a cell is selected in the Timeline or Xsheet view, you can navigate between the drawings, frames,
and layers using keyboard shortcuts that work in the Camera, Drawing, Timeline, and Xsheet views.
You can navigate through:
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•

Drawings

•

Frames

•

Columns

Interface Navigation

How to navigate through drawings, frames and columns
1. In the Timeline or Xsheet view, select a cell.

2. Once the cell is selected, you can navigate between:
‣

Previous and next layers: From the top menu, select Drawing > Previous Layer and Next
Layer or press H and J.

‣

Previous and next drawings: From the top menu, select Drawing > Previous Drawing and
Next Drawing or press F and G.

‣

Previous and next frames: From the top menu, select Play > Previous Frame and Next
Frame or press comma (,) and period (.).

148

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

149

Glossary

Interface Navigation

Glossary

alpha channel

The image's channel carrying the transparency information. An
image already has three channels: red, green and blue (RGB). The
alpha channel is the fourth channel (RGBA). The matte, or the
transparency information, is stored in this fourth channel. An image
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at
times, the characters are placed on a trajectory to indicate motion.
The camera moves are also animated. The animatic is used to
determine the rhythm of a project and provides a good overview of
the project before beginning production.

animation

A simulation of movement created by displaying a series of pictures
or frames.

anime

An animation style known for its sinister and dark feel; popular in
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically
unfolds in what storytellers refer to as an arc. The purpose of a
story arc is to move a character or a situation from one state or
scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any
scene, frame or film format. Television ratio is 4:3 and widescreen
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which
multiple drawings are stacked into a sheet feeder. When the
scanner is activated, the drawings are scanned consecutively,
without further user intervention.

automatic lip-sync detection

Automatically mapping drawings in an element to the mouth chart
generated for a sound. This can save time when lip-syncing a voice
track.
An imaginary line around which an object rotates.
For 2D graphics, there are two axes:

axis

•

X: Horizontal

•

Y: Vertical

For 3D graphics, there are three axes:
•

X: Horizontal

•

Y: Vertical

•

Z: Depth

background

The part of a scene that is farthest to the rear. The background is
the artwork, or decor, against which the animation takes place.

Bézier

A method of defining curved lines invented by French
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mathematician Pierre Bézier. A Bézier curve is a mathematical or
parametric curve. Bézier curves use at least three points to define a
curve.
In Toon Boom, a function can be hooked to a Bézier curve and vary
along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves
and can be scaled indefinitely.
bitmap

An image composed of pixels with a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to
appear. This is known as pixelation.
In cut-out animation, breakdown is the action of breaking a
character into pieces to create a puppet with articulations. To
break down a character, the artist cuts part, such as hands and
arms, from the character's model and pastes them in separate
layers. Next, the joints are fixed and the pivots set.

breakdown

In traditional animation, a breakdown is an animation pose
generally found between two key poses. The key poses are the
main poses in an animation and the breakdowns are secondary
poses, ones that help to describe the motion and the rotation
curve.

camera shake

Camera shake occurs in a scene when the camera moves slightly
and quickly in several directions. This gives the impression of an
impact, vibration or, for example, bumps on the road.

caption

In a storyboard, a caption is a text field containing dialogue,
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a
transparent sheet on which the animation is inked and painted
before being sent to the camera.The picture's outline is drawn on
the front of the cel and then coloured along the back.
In Toon Boom, a cel is an individual space encountered in an
Xsheet's column, from which you can expose a drawing or a
function`s coordinate.

character design

Each character in an animated film is drawn from multiple angles in
poster-style format, called a model sheet, which serves as a
reference for the animators.

clean up

After rough drawings have been tested and approved, all the noise
in the image (excess lines, notes, etc) is removed to create final
drawings which can be inked, painted and shot. The cleanup
process refers to either tracing a clean line over a rough drawing to
achieve the final version, or removing dirt and extra lines left by the
scanning process.

CMYK

Cyan, Magenta, Yellow, Black. Refers to the process used by
printers to define colour on the printed page.

colour card

A Colour Card is a solid colour card that is the same size as the
camera. The Colour Card can be used to fill the background with a
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must
be used to paint the animation. A model is the definitive character,
prop, or location design that each artist must follow for the
production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements
to create the final result prior to rendering. For example, the
compositing artist will import all the animation sequences,
background, overlays and underlays in the scene and position them
correctly. The artist will then set the camera frame and animate it, if
needed. Finally, the animator will create all the computergenerated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there
are no transition effects inserted to pass from one scene to the
next. The first scene ends and the second one starts immediately.

cut-out animation

The action of animating characters made of several pieces by
moving them around frame by frame. Cut-out animation can either
be computer generated or done traditionally using paper.

cycle

A group of images that together make up an action, such as
walking. A cycle is an action repeated as a loop over a period of
time. It can be a series of animated drawings or keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to
track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as an exposure sheet
or Xsheet.

doping

To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for
computerized printers. It is sometimes applied to screens, in which
case it should more accurately be referred to as pixels per inch.
Either way, the dot is the smallest discrete element making up the
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration
and deceleration of a motion. It can be a motion created by a
function curve, or a series of animated drawings. Other common
terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Another common term for easein is slow-in.

ease-out

Gradual deceleration in the action. Another common term for easeout is slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a
sequence is happening. For example, if a child is playing on the
ground in front of his house, the establishing shot would be a scene
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where the viewer can see the house, the ground, a part of the
street and the buildings around the central point of action. This
helps the viewer understand the story location and scene
orientation.
exposure

In animation, an exposure is the number of cels on which a drawing
appears in the scene. For a drawing to appear longer, the
exposure must be extended over a greater number of cels.
The exposure sheet or Xsheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

exposure sheet (Xsheet)

Each column represents a scene's layer. In each column, the
drawing's numbers are indicated and repeated over the particular
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a
sequence. A fade in occurs when the first scene appears
progressively, from complete transparency to its complete opacity.
A fade out occurs when the last scene progressively disappears,
going from complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

In animation, a field is a measurement unit used to calculate
motion, registration and camera positioning. A standard animation
scene will vary between 6 to 12 fields.

field chart

A guide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33

Use this resolution setting for the widescreen film format that
conforms to the standard 4:3 pixel aspect ratio.

film-1.66

Use this resolution setting for the widescreen film format that
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than
they are high).

flipping

In traditional animation, flipping is the action of going through the
drawings of an animation sequence very quickly in order to see the
animation in motion. Flipping can also be the action of creating a
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main
action. For example, a character wearing a cloak is running. The
main action is the body running. This will cause the cloak to follow
the motion, although it will not move at the same time, but react a
few frames later and follow the main motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D
characters and cut-out puppets with hierarchy. It is used to animate
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a puppet from one of parent parts, such as a shoulder, and make
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional
animation, the North American standard generally contains 24
frames per second, while in Europe the standard is 25 frames per
second.
This is the measurement of the frequency (rate) at which an imaging
device produces unique consecutive images, called frames. The
term applies equally to computer graphics, video cameras, film
cameras, and motion capture systems.

frame rate

Frame rate is most often expressed in frames per second (FPS) and
in progressive-scan monitors as hertz (Hz).
The frame rate is the speed at which the frames are played. They
are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or
any other number

functions

A function is a computer generated motion, trajectory or path that
elements, other trajectories and effects parameters can be
attached to. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than
standard television does because it has a greater number of lines
of resolution. To take advantage of the superior quality and make
full use of your resolution setting, your output device must be
compatible with HDTV technology.

hold

This is a frame in the animation in which the character maintains its
position without moving. A hold can be created between any two
keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of
hue (tint), saturation (shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn
to create fluid transitions between poses.

ink and paint

The ink and paint process is the action of painting the empty zones
and colouring the lines on the final animation drawings, while
following a colour model.

interpolation

In animation, the interpolation is the computer generated motion
created between two keyframes. You have the choice to create
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut
is not visually pleasing. It is generally caused by one scene ending,
and a second one starting, with similar a image. The lack of
difference causes the eye to see a little jump between the two
scenes.
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key pose

Important positions in the action defining the starting and ending
points of any smooth transition. Keys, or key poses, are the main
drawings in an animation sequence describing the motion. For
example, if an arm is waving, the keys will be of the arm at one
extremity of the wave motion and the other extremity. By flipping
those drawings, the animator can see the skeleton of the motion
without having all of the drawings.
One or more keyboard keys which, when used, cause an operation
to be performed. Keyboard shortcuts are used throughout the
Toon Boom software and form an integral part of the workflow. It
is, in most cases, possible to customize the shortcuts in the
Preferences dialog of the software.

keyboard shortcuts

The shortcuts are written as follows in the Toon Boom user
documentation: Each key in a sequence is shown inside square
brackets as in: [Ctrl]+[A]. The brackets "[ ]" separate the key from
the plus sign (+). Neither the brackets, nor the plus sign are part of
the sequence. To use a shortcut, press the key and the character
simultaneously.

keyframe

Important positions in the action defining the starting and ending
points of any action. A keyframe is a computer generated position
at a specific moment (frame) on a given trajectory.

layer

In animation, a layer is an individual column, level or character. A
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the
storyboard and the animation. The layout and posing process is
the action of putting the storyboard on model, that is drawing the
character following the design in the model pack, so that the
animator can start his work. The layout artist will draw the
background, create the camera and field guide matching the scene
and the camera motion. Lastly, he will draw on model the main
action poses.

layout and posing

The action of putting on model, that is, at the right scale, the
storyboard for the animator to start his work.

library

A library is a storage area containing templates and assets that can
be reused in any project or scenes.

light table

The Light Table feature allows you to see the other layers in
transparency while you are working on a particular one in the
Drawing view.

line of action

Direction that the action will follow. Also known as the Path of
Action

lip-sync

The lip-sync is the character`s mouth synchronization with the
dialogue sound track. Frame by frame, the mouth will be adjusted
to fit the sound to give the illusion of the character is speaking.

low resolution

This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality. A
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice
track. For this process, both sound scrubbing (listening to a sound
wave broken up frame-by-frame) and drawing substitutions from
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or
a prop. The palette is used throughout the entire production to
maintain consistency in the look and to ensure that the same
colours are used throughout the production. Also known as
palette.

model/colour model

In animation, a model is the definitive character, prop or location
design that each artist must follow for the production. A colour
model is the official colour design that must be used to paint the
animation.

motion keyframe

In Toon Boom, the motion keyframe is a keyframe with computergenerated interpolation.

mouth chart

Adding a lip-sync to a project can really enhance its quality and
storytelling. However, it can be difficult to shape a character's
mouth so that it matches the sound at the precise frame. To solve
this problem, Toon Boom provides a lip-sync feature which
analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G,
and X, which is used to represent silence).

multiplane

The effect of passing through multiple levels of drawings to create
a sense of depth in a shot. A multiplane is a scene in which the
layers are placed at different distances from the camera so that
when the camera moves, a depth illusion occurs. With a multiplane,
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in
North America. NTSC conforms to North American standards on
how rectangular pixels are displayed for computer and television
screens.

nudge

A small push (left, right, up, down, forward or backward) done
with the keyboard arrow keys on a selected element. Nudging is
used to move a selection very slightly and precisely.

onion skin

A feature that lets you see the previous and next drawings of a
sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.

PAL

A resolution that works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a
character or a prop. The palette is used throughout the entire
project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master
palette.
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palette style

A palette style is a second version of an existing palette with a
slight change in the tint and value. A palette style can be used to
create the night version of a palette. It may also be called a clone
palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be
composed of one or several panels.

paperless animation/tradigital

The paperless animation process is the action of animating
digitally. The main paperless animation process is to draw, frame
by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing
position is the point at which one leg passes the other.

path of action

Direction that the action will follow. Also known as the Line of
Action.

peg

In traditional animation, a tool used to ensure accurate registration
of action as cel layers move. In digital animation, in which you are
doing a more advanced puppet rigging, you can use peg layers.
Peg layers are trajectory layers that do not contain drawings. They
are motion paths that you can use to add path articulations. For
the latter, you can also use the Inverse Kinematics tool.

phoneme

Unit of sound in a language.

pivot

A pivot is the point around which a peg or a drawing rotates.
Smallest element of an image displayed on a monitor or TV screen.

pixel

Pixel, short for Picture Element, is a single point in a graphic image.
It is a small sample of an image, a dot, a square, or a very small
section made out of smooth filtering. If you zoom in close enough
on a digital image, you will see the pixels, which look like small
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the
main action poses, called key poses, and then placing the
secondary poses between the keys. The secondary poses are
called breakdown. Finally, the animator fills the gaps with the inbetween drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes
all of the components as well as adding motion blur before it
produces a final image. In animation, the rendering process is the
action of calculating the final images after the compositing
process.

resolution

The resolution is the size of a scene, generally calculated in pixel.
For example, the NTSC resolution is 720 x 480. Resolution type
should match your final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue: method of defining colour by specifying amounts
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of these three colour components.
rigging

The rigging process is the action of attaching the cut-out puppet
parts one to the other.

rotary table

The Rotary Table is equivalent to the animation disk/table and
allows one to rotate the workspace to be more comfortable while
drawing.

rotoscoping

Is an animation technique in which animators trace over live-action
film movement, frame by frame, for use in animated films. The act
of sketching over live-action footage to create an animated
sequence.

roughs

The roughs are the skeleton sketch of an animation or a design.
Roughs mainly consist of sketch lines and shapes, though they can
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the
centre of the scene's frame, one safe from being cropped by the TV
frame. As a TV frame cuts a margin off the original frame size,
maintaining a safey area ensures that the scene's main action will
remain clearly visible once the film is screened on television.

scene

A scene is a shot in a movie or show. A sequence is composed of
several scenes. A scene changes to another scene by a simple cut,
or a transition.

script

The script is the original text containing all the movie or show
information. In animation, the script contains all of the location
descriptions, dialogues, time and more. A project starts with a
script.

sequence

In animation, a sequence is a series of scenes or shots forming a
distinct part of the story or movie, usually connected by unity of
location or time.

shot

A shot is a scene in a movie or show. A sequence is composed of
several shots. A shot changes to another shot by a simple cut, or a
transition.

slow-in

Gradual acceleration in the action. Another common term for slowin is ease-in.

slow-out

Gradual deceleration in the action. Another common term for slowout is ease-out.

slugging

In Storyboard Pro, slugging refers to indicating the start and stop
times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the
playhead forward or backward. This is very useful for finely-tuned
lip-syncing.

stop-motion keyframe

A stop-motion keyframe is a keyframe with no computer generated
interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The
storyboard indicates what will happen, when it will happen and
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how the objects in a scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first
position to the last, in order. There is very little planning in this
methodology, and where the character ends up and how it gets
there can be a surprise for both the audience and the animator.
While this approach is a lot more spontaneous and creative, it can
create inaccurate results.

strokes

Strokes are invisible vector lines forming the drawing zones. They
can be adjusted with Bézier handles.

tablet/pen

Device used in conjunction with, or instead of, a mouse to move a
mouse pointer (sometimes referred to as the cursor) around the
computer screen.

template

In Toon Boom, a template is an asset stored in the library, one that
can be reused in any project. A template can be a drawing, a series
of keyframes, a sound file, a panel, a cut-out character, an effect, a
trajectory, an animation, or anything else used in the software.

thumbnails

A thumbnail is a very small image used as a reference or indicator.

timecode

Timecode is timing information printed on a movie clip to indicate
what scene, hour, minute and second is currently displayed on the
screen.

timeline

The timeline is a horizontal representation of the scene`s elements,
timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final
line or pencil test, each drawing is traced and painted for the final
animation. In today's digital world, this may be done in a variety
ways other than via the traditional celluloid or acetate methods.

track breakdown

The soundtrack for animated film is broken down into individual
sounds documenting the precise frame-by-frame position of each
sound.

traditional animation

The traditional animation process is the action of drawing on paper
all of the animation sequences, before either scanning them or
inking them on cels.

trajectory

A computer generated path or trajectory that elements can follow.
The trajectory can be controlled by control points, keyframes and
velocity.

transition

A transition is an effect placed between two scenes as they pass
from one to the other. Common transition effects are crossdissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed
behind the main animation.

aspect ratio

The aspect ratio describes the shape of the grid unit. A square grid
unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves.
The computer reads the points and traces the segments, linking
them to reproduce the image shape. There is no fixed size or
resolution in a vector image. The graphic can be enlarged and
distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve,
or via a series of animated drawings. Other common terms for
ease-in and ease-out are slow-in and slow-out.

walk cycle

To avoid making innumerable drawings, animators routinely make
a walk cycle for their character. This comprises a series of drawings
``on the spot`` that describe the walk for that character. The illusion
of movement is created via the use of background pans.

workspace

In Toon Boom, the workspace is made up of the views, toolbars,
and menus.
The Xsheet or exposure sheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

Xsheet (exposure sheet)

Each column represents a scene's layer. In each column, the
drawing numbers are indicated and spread over the specific
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.

zone

An area which can be painted with colour.
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about
Cloud module 9
Draw module 8
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Play module 9
Sketch module 9
Stage 8
adding
views 95
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alpha channel
_defined 144
animatic 14
_defined 144
animation
_defined 144
principles 31
animation principles 31
anticipation 32
arcs of rotation 33
concepts, traditional 37
exaggeration 35
follow-through 33
pose-to-pose 32
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slow-in, slow-out 34
solidity 35
squash and stretch 31
straight-ahead 32
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timing 31
animation types 19
cut-out 21
paperless 20
traditional 19
animation workflows 11
post-production 17
pre-production 12
production 16
anime
_defined 144
anticipation 32
arc
_defined 144
arcs of rotation 33
area, safe 111
aspect ratio 79
_defined 144
defined 153
grid 81
audio
dubbing 17
editing 17
recording 14
auto-feed
_defined 144
auto-save
disabling on workspaces 106
axis
_defined 144
background
_defined 144
background styling 14
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Bezier
_defined 144
bitmap graphics 38
advantages, disadvantages 38
image types 38
bitmap images
_defined 145
bitmap resolution
height 83
resolution factor 83
settings 83
width 83
breakdown
_defined 145
sound 15
broadcast standards 43
camera mask 110
camera shake
_defined 145
Camera view 109
camera mask 110
Camera View toolbar 114
current drawing on top 110
Editing Stack menu 114
light table 110
Matte View mode 113
OpenGL view mode 112
outline locked drawings 111
Render View mode 112
resetting view 111
safe area 111
View menu 114
Zoom menu 111
Camera View toolbar 114
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caption
_defined 145
cel
_defined 145
celluloid
See cel. 145
centre coordinates, setting 82
character
design 13
styling 14
character design
_defined 145
checking
colours 85
files, project 85
project files 85
clean up
_defined 145
clockwise
rotating 140
closing
views 96
Cloud module
about 9
CMYK
_defined 145
colour card
_defined 145
colour layers 40
colour model
_defined 150
defined 146
colour palettes 41
master palette 41

164

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

switching display modes 115
Colour view 114
switching palette display modes 115
colour wheel
defined 146
colours
checking 85
columns
navigating 141
commands
basic 87
compositing
defined 146
conventions, naming 61
layer 61
puppet drawings 62
renaming modules 62
scene 61
counterclockwise
rotating 140
creating
scenes 69
scenes from File menu 69
scenes from Welcome scene 69
scenes with custom resolution 70
workspace, new 105
cross dissolve
defined 146
current drawing on top, Camera view 110
custom resolution
creating scenes 70
customizing
toolbars 102
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cut
defined 146
cut-out animation 21
defined 146
workflow 28
cycle
defined 146
dark style interface 91
deleting
workspace 107
dialogue
defined 146
display
workspace 107
distribution, master 18
docking
floating window 96
documentation
accessing 68
dope sheet
defined 146
doping
defined 146
DPI
defined 146
Draw module
about 8
drawing layers
adding 76
drawings
current drawing on top 110
navigating 141
outline locked drawings 111
dubbing 17
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ease
defined 146
ease-in
defined 146
ease-out
defined 146
editing
audio 17
final 17
Editing Stack menu 114
establishing shot
defined 146
exaggeration 35
exposure
_defined 147
exposure sheet
_defined 147, 154
traditional 44
fade-in
_defined 147
fade-out
_defined 147
field
_defined 147
field chart
_defined 147
field of view 79
custom 79
horizontal fit 79
vertical fit 79
file structure 51-52
drawings and layers 57
File toolbar 136
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files
checking project files 85
film-1.33 78
_defined 147
film-1.66 78
_defined 147
film-1.66_Vertical 78
final editing 17
flat toolbars 99, 103
Flip toolbar 136
flipping
_defined 147
follow-through 33
_defined 147
format 49
forward kinematics
_defined 147
FOV (field of view) 79
custom 79
horizontal fit 79
vertical fit 79
fps 79
frame
_defined 148
frame rate 49
_defined 148
frames
navigating 141
frames per second 79
full screen 139
functions
_defined 148
gamut
_defined 148
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graphics, bitmap and vector 38
advantages, disadvantages 38
bitmap image types 38
vector image types 38
grid
aspect ratio, setting 81
centre coordinates, setting 82
number of units, setting 82
Harmony
dark style 91
file structure 52
interface 91
modules 7
starting 65-66
Harmony Network
dark style 91
interface 91
starting 65-66
HDTV 78
_defined 148
HDTV_Vertical 78
Help
Harmony 1
structure 2
hiding
views temporarily 98
workspace 107
Hold
_defined 148
HSV
_defined 148
in-between
_defined 148
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ink and paint
_defined 148
integrity
project, checking 85
interface 91
dark style 91
docking a floating window 96
interpolation
_defined 148
jump cut
_defined 148
key pose
_defined 149
keyboard shortcuts
_defined 149
keyframes
_defined 149
layers
_defined 149
adding drawing layer 76
line and colour layers 40
naming convention 61
layout
_defined 149
layout and posing
_defined 149
library 59
_defined 149
personal 60
light table
_defined 149
Camera view 110
line layers 40
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line of action
_defined 149
lip-sync
_defined 149
auto detection, defined 144
lip-sync detection
manual, defined 150
loading
workspace 104
location design 13
looping
playback 137
low resolution 79
_defined 149
manual lip-sync detection
_defined 150
Mark Drawing toolbar 136
mask
camera 110
master distribution 18
master palette 41
_defined 150
Matte View mode 113
menus 93
Editing Stack 114
View 114
Zoom 111
Message Log view 119
model
_defined 150
model sheet See character design
Model view 119
modules
Cloud 9
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Draw 8
Harmony 7
Play 9
renaming 62
Sketch 9
Stage 8
motion keyframe
_defined 150
mouth
chart 150
moving
toolbars 101
multiplane
_defined 150
traditional animation 47
multiplane camera 47
naming convention 61
layer naming 61
puppet drawings 62
renaming modules 62
scene naming 61
navigating 139
centering screen on mouse 140
columns 141
drawings 141
frames 141
full screen 139
panning 139
Play menu 140
recentering view 139
resetting pan 139
resetting rotation 139
resetting views 139
resetting zoom 139
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rotating clockwise 140
rotating counterclockwise 140
zooming in 139
zooming in or out 139
zooming out 139
network 48
node system 48
NTSC 79
_defined 150
nudge
_defined 150
Onion Skin toolbar 136
onion skinng
_defined 150
onion skinning
toolbar 136
OpenGL
view mode 112
opening
scenes 69
scenes from File menu 71
scenes from Windows screen 71
Workspace Manager 104
organizing
drawings and layers 57
files 51
projects 51, 54
orthographic projection 80
outline locked drawings 111
overlay
_defined 150
PAL 79
_defined 150
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Interface Navigation

palettes
_defined 150
colour 41
master 41
style, defined 151
switching display modes 115
panel
_defined 151
panning 139
_defined 151
resetting 139
paperless animation 20
_defined 151
workflow 26
passing position
_defined 151
path of action
_defined 151
pegs
_defined 151
traditional animation 46
pen
_defined 153
perspective projection 80
phoneme
_defined 151
picture element 49
pipeline
Toon Boom 7
pivot
_defined 151
pixel 49
_defined 151
dimensions 79
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pixelation See bitmap image
Play menu 140
Play module
about 9
playback toolbar
Sound button 137
Playback toolbar 137
FPS button 137
Jog Frames button 137
Loop button 137
Play button 137
Render and Play button 137
Sound Scrubbing button 137
playing back 137
fps 137
jogging frames 137
looping 137
rendering and playing 137
sound 137
sound scrubbing 137
pose-to-pose
_defined 151
post-production workflow 17
pre-production
workflow 12
preferences 90
disabling auto-save workspace 106
flat toolbars 103
Preferences dialog box 90
principles, animation 31
anticipation 32
arcs of rotation 33
exaggeration 35
follow-through 33
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Interface Navigation

pose-to-pose 32
secondary actions 34
slow-in, slow-out 34
solidity 35
squash and stretch 31
straight-ahead 32
timing 31
product requirements
Harmony 5
Harmony Stand Alone 5
production steps 23
projection settings 80
orthographic 80
perspective 80
projects
checking colours 85
checking files 85
colours, checking 85
content building scenes, organizing 54
drawings and layers, organizing 57
files, checking 85
organizing 51
resolution 78
root directory, organizing 54
verifying integrity 85
prop
design 13
styling 14
puppets
naming convention 62
recentering
view 139
renaming
modules 62
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workspace 106
Render View mode 112
rendering
_defined 151
reordering
workspace 108
resetting
Camera view 111
pan 139
rotation 139
views 139
zoom 139
resizing
toolbars 100
views 97
resolution
_defined 151
bitmap 83
factor, bitmap 83
film-1.33 78
film-1.66 78
film-1.66_Vertical 78
HDTV 78
HDTV_Vertical 78
height, bitmap 83
Low 79
NTSC 79
PAL 79
presets 78
scene 83
width, bitmap 83
restoring
workspace, default 108
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Index

Interface Navigation

RGB
_defined 151
rigging
_defined 152
root directory 54
rotary table
_defined 152
rotating
resetting rotation 139
rotating clockwise 140
rotating counterclockwise 140
rotoscoping
_defined 152
roughs
_defined 152
safe area 111
_defined 152
saving
auto-saving scenes 73
scenes 73
workspace manually 107
scene resolution 83
Scene Settings dialog box 77
scenes 50
_defined 152
auto-saving 73
creating 69
creating from File menu 69
creating from Welcome scene 69
creating with custom resolution 70
file structure 52
naming convention 61
new scene startup script 75
opening 69

178

Toon Boom Harmony 11.1 Fundamentals Guide (Standalone)

opening from File menu 71
opening from Welcome screen 71
saving 73
scene length, setting 75
setting length 75
settings 77
script
_defined 152
Script Editor view 120
scripting
toolbar 137
Scripting toolbar 137
scripts 12
new scene startup 75
scrubbing
_defined 152
secondary actions 34
sequences
_defined 152
settings
projection 80
scene 77
shot
_defined 152
Sketch 9
about 9
slow-in 34
_defined 152
slow-out 34
slow_out
_defined 152
slugging
_defined 152
solidity 35
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Index

Interface Navigation

sound
breakdown 15
scrubbing
_defined 152
squash and stretch 31
Stage 8
about 8
standards
broadcast 43
starting
Harmony 65-66
ToonBoomProductName 66
stop-motion keyframe
_defined 152
storyboard 13
_defined 152
straight-ahead 32
_defined 153
strokes
_defined 153
swapping
views 97
switching
workspace 104
system requirements
Harmony 5
Harmony Stand Alone 5
tablet
_defined 153
technical specifications
Harmony 5
Harmony Stand Alone 5
templates 59
_defined 153
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thumbnails
_defined 153
timecode
_defined 153
timeline
_defined 153
traditional 44
usage 45
Timeline view 121
timing 31
scene length 75
Tool Properties view 129
toolbars 136
Camera View 114
customizing 102
Edit 136
File 136
flat 99
Flip 136
hiding 99
managing 99
Mark Drawing 136
moving 101
Onion Skin 136
Playback 137
resizing 100
Scripting 137
showing and hiding 99
Tools 138
top 136
view 138
Workspace 138
tools
Zoom 141
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Interface Navigation

Tools toolbar 138
trace and paint
_defined 153
track breakdown
_defined 153
tradigital
_defined 151
traditional animation 19
_defined 153
colour layers 40
colour palettes 41
concepts 37
exposure sheet 43-44
file structure 51
frame rate and format 49
line and colour layers 40
line layers 40
master palette 41
multiplane 47
network 48
pegs 46
project organization and file structure 51
scenes 50
timeline 43
timeline usage 45
timeline, traditional 44
timing 43
workflow 23
Xsheet usage 45
trajectory
_defined 153
transition
_defined 153
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underlay
_defined 153
vector
_defined 154
vector graphics 38
advantages, disadvantages 38
images types 38
velocity
defined 146, 154
View menu 114
view modes
Matte 113
OpenGL 112
Render View 112
views 95
adding 95
Camera 109
closing 96
Colour 114
docking a floating window 96
hiding temporarily 98
managing 95
Message Log 119
Model 119
recentering 139
resetting 139
resizing 97
Script Editor 120
swapping 97
Timeline 121
Tooll Properties 129
Xsheet 130
walk cycle
_defined 154
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Index

Interface Navigation

Welcome screen 67
workflows
animation 11
cut-out animation 28
paperless animation 26
post-production 17
pre-production 12
production 16
traditional animation 23
workspace
_defined 154
creating new 105
deleting 107
disabling auto-save 106
displaying 107
hiding 107
loading 104
managing 104
renaming 106
reordering 108
restoring default 108
saving as new version 107
saving manually 107
showing 107
toolbar 138
Workspace Manager
opening 104
Workspace toolbar 138
Xerox process 40
Xsheet view 130
_defined 154
usage 45
zone
_defined 154
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Zoom menu 111
Zoom tool 141
zooming
in 139
in or out 139
out 139
resetting zoom 139
Zoom tool 141
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Glossary
A

alpha channel
The image's channel carrying the transparency information. An image already has
three channels: red, green, blue (RGB). The alpha channel is the fourth channel
(RGBA). The matte, or the transparency information, is stored in this fourth channel.
An image without an alpha channel is always opaque.

animatic
An animatic is a movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at times, the
characters are placed on a trajectory to indicate motion. The camera moves are
also animated. The animatic is used to determine the rhythm of a project and
provides a good overview of the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures or frames.

arc
Action rarely occurs in a straight-forward manner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or a
situation from one state or scenario to the next.

aspect ratio
The aspect ratio is the relationship between the width and height dimensions for
any scene, frame or film format. The television ratio is 4:3 and the widescreen ratio
is 16:9.

auto-feed
Automated method of feeding drawings to a scanner in which multiple drawings
are stacked into a sheet feeder. When the user activates the scanner, the drawings
are scanned consecutively, without further user intervention.

axis
An axis is an imaginary line around which an object rotates. For 2D graphics, there
are two axes: • X which is horizontal • Y which is vertical For 3D graphics there are
three axes: • X which is horizontal • Y which is vertical • Z which is for the depth
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B

background
A background is the part of the scene that is the farthest to the rear. The
background is the artwork, or decor, against which the animation takes place.

backlight
The Backlight tool (in digital process) temporarily transforms the painted zones
into a darker colour, allowing you to easily locate any empty zones or bubbles left
behind during the Ink and Paint process.

Bézier
A method of defining curved lines invented by French mathematician Pierre Bézier.
A Bézier curve is a mathematical, or parametric curve. Bézier curves use at least
three points to define a curve. In Toon Boom, a function can be hooked to a Bézier
curve and vary along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves and can be scaled
indefinitely.

bitmap
A bitmap image is composed of pixels and has a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to appear. This is
known as pixelation.

bitmap image
An image composed of pixels with a single resolution (size). If it is enlarged too
much, it will lose definition and pixels will begin to appear. This is known as
pixelation.

breakdown
In cut-out animation, the breakdown is the action of breaking a character into
pieces to create a puppet with articulations. To breakdown a character, the artist
will cut parts, such as hands and arms, from the character's model and paste them
in separate layers. Next, the joints will be fixed and the pivots set. In additional
animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help to describe the motion and the rotation curve.
C

camera shake
Camera shake occurs in a scene when the camera moves slightly and quickly in
several directions. This gives the impression of an impact, vibration or, for
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example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue, effects, sound, or
slugging information.

cel
In traditional animation, a cel, also known as a celluloid, is a transparent sheet on
which the animation was inked and painted before being sent to the camera.The
picture's outline is drawn on the front of the cel and then coloured along the back.
In Toon Boom, a cel is an individual space encountered in an Xsheet's column, from
which you can expose a drawing or a function's coordinate.

character design
Each character in an animated film is drawn from multiple angles in poster-style
format, called a model sheet, which serves as a reference for the animators.

clean up
After the rough drawings have been tested and approved, all the noise in the
image (the excess lines, the notes, etc) is removed to create final drawings which
can be inked, painted, and shot. The clean up process refers to either tracing a
clean line over a rough drawing to achieve the final version, or removing dirt and
extra lines left by the scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by printers to define
colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the camera. The Colour
Card can be used to fill the background with a solid colour when there is no
background image included.

colour model
In animation, a colour model is the official colour design that must be used to paint
the animation. A model is the definitive character, prop, or location design that
each artist must follow for the production.

colour wheel
A display of the colour spectrum in the form of a circle.

compositing
The compositing process is the action of incorporating all of a scene's elements to
create the final result prior to rendering. For example, the compositing artist will
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import all the animation sequences, background, overlays and underlays in the
scene and position them correctly. The artist will then set the camera frame and
animate it, if need be. Finally, the animator will create all the computer-generated
effects necessary for the project.

cross dissolve
An effect, also known as transition, used to fade two scenes, one into the other.

cut
A cut is a direct transition between two scenes. When a cut is used, there are no
transition effects inserted to pass from one scene to the next. The first scene ends
and the second one starts immediately.

cut-out animation
The process known as cut-out animation is the action of animating characters made
out of several pieces by moving them around frame by frame. Cut-out animation
can either be computer generated, or done traditionally using paper.

cycle
A group of images that together make up an action, such as walking. A cycle is an
action repeated as a loop over a period of time. It can either be a series of
animated drawings, or a series of keyframes.
D

dialogue
The dialogue is the text spoken by a character in a movie or animation.

dope sheet
Used by animators, directors and other members of a crew to track the sequence
and timing of images, dialogue, sound effects, sound tracks and camera moves.
Also known as an Exposure Sheet or Xsheet

doping
Assigning a particular drawing to a range of frames.

dpi
Dots Per Inch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred
to as pixels per inch. In either case, the dot is the smallest discrete element making
up the image.
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drag
Mouse (or pen) operation that usually results in an object on the screen being
moved. Dragging with a mouse is done by holding down the left mouse button
when the cursor is over the object to be moved, and moving the mouse in any
direction.
E

ease
In animation, the ease, also known as velocity, is the acceleration and deceleration
of a motion. It can be a motion created by a function curve, or a series of animated
drawings. Other common terms for ease-in and ease-out are slow-in and slowout.

ease-in
Gradual acceleration in the action. Another common terms for ease-in is slow-in.

ease-out
Gradual deceleration in the action. Another common term for ease-out is slow-out.

establishing Shot
An establishing shot is a scene in which the viewer can see the whole area in which
a sequence is happening. For example, if a child is playing on the ground in front of
his house, the establishing shot would be a scene where the viewer can see the
house, the ground, a part of the street and the buildings around the central point
of action. This helps the viewer understand the story location and scene
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing appears in the
scene. For a drawing to appear longer, the exposure must be extended over a
greater number of cels.

exposure sheet
The exposure sheet or Xsheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing. Each column represents a
scene's layer. In each column, the drawing's numbers are indicated and repeated
over the particular amount of frames they need to appear. The exposure sheet is
used by animators, directors and other members of a crew to track the sequence
and timing of images, dialogue, sound effects, sound tracks and camera moves.
Also known as a Dope Sheet.
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F

fade in/fade out
Fade In or Fade Out is a transition effect used to open or close a sequence. A Fade
In occurs when the first scene appears progressively, from complete transparency
to its complete opacity. A Fade Out occurs when the last scene progressively
disappears, going from complete opacity to complete transparency.

fast-in
Dramatic acceleration at the start of the action.

fast-out
Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate motion, registration
and camera positioning. A standard animation scene will vary between 6 to 12
fields.

field chart
A field chart is a guide containing all the field units that animator and layout artists
use to determine a scene size or a camera motion.

film-1.33
Use this resolution setting for the widescreen film format that conforms to the
standard 4:3 pixel aspect ratio.

film-1.66
Use this resolution setting for the widescreen film format that conforms to the 16:9
pixel aspect ratio. (The pixels are wider than they are high).

flipping
In traditional animation, flipping is the action of going through the drawings of an
animation sequence very quickly in order to see the animation in motion. Flipping
can also be the action of creating a mirror transformation of an object.

follow-through
Follow-through is the secondary motion caused by the main action. For example, a
character wearing a cloak is running. The main action is the body running. This will
cause the cloak to follow the motion, although it will not move at the same time,
but react a few frames later and follow the main motion curve.
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forward kinematics
Forward kinematics is a feature used to animate principally 3D characters and cutout puppets with hierarchy. It is used to animate a puppet from one of parent
parts, such as a shoulder, and make the rest of the arm move with it as a single
piece.

frame
A frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe
the standard is 25 frames per second.

frame rate
This is the measurement of the frequency (rate) at which an imaging device
produces unique consecutive images, called frames. The term applies equally to
computer graphics, video cameras, film cameras, and motion capture systems.
Frame rate is most often expressed in frames per second (FPS) and in progressivescan monitors as hertz (Hz). The frame rate is the speed at which the frames are
played. They are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or any other
number.

function
In Toon Boom Studio, a function is a computer generated motion, trajectory or
path that elements, other trajectories and effects parameters can be attached to.
The function can be controlled by adding keyframes and control points on the
function curve.
G

gamut
The range of colours that a particular device can represent.
H

HDTV
High definition television delivers a higher quality image than standard television
does, because it has a greater number of lines of resolution. To take advantage of
the superior quality and make full use of your resolution setting, your output
device must be compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its position
without moving. A hold can be created between any two keyframes.
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HSV
Hue, Saturation, Value. A method of defining colours in terms of hue (tint),
saturation (shade) and value (tone or luminance).
I

in-between
The drawings that exist between the key poses. These are drawn to create fluid
transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones and colouring
the lines on the final animation drawings, while following a colour model.

interpolation
In animation, the interpolation is the computer generated motion created
between two keyframes. You have the choice to create interpolation, or not,
between your keyframes.
J

jump cut
A jump cut is a jerky cut between two scenes. Typically, a jump cut is not visually
pleasing. It is generally caused by one scene ending, and a second one starting,
with similar a image. The lack of difference causes the eye to see a little jump
between the two scenes.
K

key pose
Important positions in the action defining the starting and ending points of any
smooth transition. Keys, or key poses, are the main drawings in an animation
sequence describing the motion. For example, if an arm is waving, the keys will be
of the arm at one extremity of the wave motion and the other extremity. By
flipping those drawings, the animator can see the skeleton of the motion without
having all of the drawings.

keyboard shortcuts
One or more keyboard keys which, when used, cause an operation to be
performed. Keyboard shortcuts are used throughout the Toon Boom software and
form an integral part of the workflow. It is, in most cases, possible to customize the
shortcuts in the Preferences dialog of the software. The shortcuts are written as
follows in the Toon Boom user documentation: Each key in a sequence is shown
inside square brackets as in: [Ctrl]+[A]. The brackets "[ ]" separate the key from the
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plus sign (+). Neither the brackets, nor the plus sign are part of the sequence. To
use a shortcut, press the key and the character simultaneously.

keyframe
Important positions in the action defining the starting and ending points of any
action. In Toon Boom Studio, a keyframe is a computer generated position at a
specific moment (frame) on a given trajectory.
L

layer
In animation, a layer is an individual column, level or character. A scene's layers are
superposed to form the final image.

layout
The layout process is the communication step between the storyboard and the
animation. The layout and posing process is the action of putting the storyboard
on model, that is drawing the character following the design in the model pack, so
that the animator can start his work. The layout artist will draw the background,
create the camera and field guide matching the scene and the camera motion.
Lastly, he will draw on model the main action poses.

layout and posing
The layout and posing process is the action of putting on model, that is at the right
scale, the storyboard for the animatorto start his work.

library
A library is a storage area containing templates and assets that can be reused in
any project or scenes.

light table
The light table allows you to see the other layers in transparency while you are
working on a particular one.

line of action
Direction that the action will follow, also known as the path of action.

lip-sync
The lip-sync is the character`s mouth synchronization with the dialogue sound
track. Frame by frame, the mouth will be adjusted to fit the sound to give the
illusion of the character is speaking.
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low resolution
This format is ideal for videos destined for the web, where size and fast download
of a video file might take precedence over quality. A low-resolution image is one
that lacks fine detail.
M

master palette
A master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire production to maintain consistency in the
look and to ensure that the same colours are used throughout the production.
Also known as palette.

model
In animation, a model is the definitive character, prop or location design that each
artist must follow for the production. A colour model is the official colour design
that must be used to paint the animation.

mouth chart
Adding a lip-sync to a project can really enhance its quality and storytelling.
However, it can be difficult to shape a character's mouth so that it matches the
sound at the precise frame. To solve this problem, Toon Boom provides a lip-sync
feature which analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).

multiplane
The effect of passing through multiple levels of drawings to create a sense of
depth in a shot. A multiplane is a scene in which the layers are placed at different
distances from the camera so that when the camera moves, a depth illusion occurs.
With a multiplane, all the perspective and scale is calculated automatically.
N

NTSC
This is the standard analogue television broadcasting system used in North
America. It conforms to North American standards on how rectangular pixels are
displayed for computer and television screens.

nudge
A nudge is a small push (left, right, up, down, forward or backward) done with the
keyboard arrows on a selected element. Nudging is used to move a selection very
slightly and precisely.
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O

onion skin
The onion skin is a feature that lets you see the previous and next drawings of a
sequence.

overlay
An overlay is a part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.
P

PAL
This resolution works best with the European format for television and computer
screens, as the rectangular pixels are displayed at a different orientation.

palette
A palette or master palette is a group of colours attributed to a character or a
prop. The palette is used throughout the entire Toon Boom Studio project to
maintain a consistency in the look and avoid the colour changing during the
animation. Also referred to as a master palette.

palette style
A palette style is a second version of an existing palette with a slight change in the
tint and value. A palette style can be used to create the night version of a palette.
It may also be called a clone palette.

pan
To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be composed of one or
several panels.

paperless animation
The paperless animation process is the action of animating digitally. The main
paperless animation process is to draw, frame by frame, the animation directly in
the software.

passing position
When drawing a walk sequence for a character, the passing position is the point at
which one leg passes the other.
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path of action
Direction that the action will follow. Also known as the Line of Action.

peg
In traditional animation, a tool used to ensure accurate registration of action as cel
layers move. In digital animation, in which you are doing a more advanced puppet
rigging, you can use peg layers. Peg layers are trajectory layers that do not contain
drawings. They are motion paths that you can use to add path articulations. For the
latter, you can also use the Inverse Kinematics tool.

pen tablet
Device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

phoneme
Unit of sound in a language.

pivot
A pivot is the point around which a peg or a drawing rotates.

pixel
Smallest element of an image displayed on a monitor or TV screen. Pixel, short for
Picture Element, is a single point in a graphic image. It is a small sample of an
image, a dot, a square, or a very small section made out of smooth filtering. If you
zoom in close enough on a digital image, you will see the pixels, which look like
small squares of different colours and intensity.

pose-to-pose animation
The pose-to-pose animation process is the action of creating all the main action
poses, called key poses, and then placing the secondary poses between the keys.
The secondary poses are called breakdown. Finally, the animator fills the gaps with
the in-between drawings to achieve a smooth animation.
R

rendering
The final step when animating by computer. During rendering, the computer takes
each pixel that appears on screen and processes all of the components as well as
adding motion blur before it produces a final image. In animation, the rendering
process is the action of calculating the final images after the compositing process.

resolution
The resolution is the size of a scene, generally calculated in pixel. For example, the
NTSC resolution is 720 x 480. Resolution type should match your final output:
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HDTV, film-1.33, film-1.66, NTSC, PAL, low.

RGB
Red, Green, Blue: method of defining colour by specifying amounts of these three
colour components.

rigging
The rigging process is the action of attaching the cut-out puppet parts one to the
other.

rotary table
The Rotary Table is equivalent to the animation disk/table and allows one to rotate
the workspace to be more comfortable while drawing.

rotoscoping
Is an animation technique in which animators trace over live-action film movement,
frame by frame, for use in animated films. The act of sketching over live-action
footage to create an animated sequence.

rough
The roughs are the skeleton sketch of an animation or a design. Roughs mainly
consist of sketch lines and shapes, though they can also contain design details.
S

safety area
In animation and movie parlance, the safety area is the zone at the centre of the
scene's frame, one safe from being cropped by the TV frame. As a TV frame cuts a
margin off the original frame size, maintaining a safety area ensures that the
scene's main action will remain clearly visible once the film is screened on
television.

scene
A scene is a shot in a movie or show. A sequence is composed of several scenes. A
scene changes to another scene by a simple cut, or a transition.

script
The script is the original text containing all the movie or show information. In
animation, the script contains all of the location descriptions, dialogues, time and
more. A project starts with a script.

sequence
In animation, a sequence is a series of scenes or shots forming a distinct part of the
story or movie, usually connected by unity of location or time.

199

Glossary

shot
A shot is a scene in a movie or show. A sequence is composed of several shots. A
shot changes to another shot by a simple cut, or a transition.

slow-in
Gradual acceleration in the action. Another common term for slow-in is ease-in.

slow-out
Gradual deceleration in the action. Another common term for slow-out is ease-out.

slugging
Slugging refers to indicating the start and stop times of dialogue and relevant
actions.

sound scrubbing
The process known as Sound Scrubbing lets you hear sound in real-time while you
move the playback pointer forward or backward. This is very useful for finely-tuned
lip-synching.

stop-motion keyframe
A stop-motion keyframe is a keyframe with no computer generated interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The storyboard indicates
what will happen, when it will happen and how the objects in a scene are laid out.

straight-ahead animation
A technique in which an entire sequence is drawn from the first position to the last,
in order. There is very little planning in this methodology, and where the character
ends up and how it gets there can be a surprise for both the audience and the
animator. While this approach is a lot more spontaneous and creative, it can create
inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They can be adjusted
with Bézier handles.
T

tablet
Device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.
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template
In Toon Boom software, a template is an asset stored in the library, one that can be
reused in any project. A template can be a drawing, a series of keyframes, a sound
file, a panel, a cut-out character, an effect, a trajectory, an animation, or anything
else used in the software.

thumbnail
A thumbnail is a very small image used as a reference or indicator.

timecode
Timecode is timing information printed on a movie clip to indicate the scene, hour,
minute and second is currently displayed on the screen.

timeline
The timeline is a horizontal representation of the scene's elements, timing and
keyframes.

trace and paint
After the rough animations have gone through cleanup and a final line or pencil
test, each drawing is traced and painted for the final animation. In today's digital
world, this may be done in a variety ways other than via the traditional celluloid or
acetate methods.

track breakdown
The soundtrack for animated film is broken down into individual sounds
documenting the precise frame-by-frame position of each sound.

traditional animation
The traditional animation process is the action of drawing on paper all of the
animation sequences, before either scanning them or inking them on cels.

trajectory
A computer generated path or trajectory that elements can follow. The trajectory
can be controlled by control points, keyframes and velocity.

transition
A transition is an effect placed between two scenes as they pass from one to the
other. Common transition effects are cross-dissolve and wipe.
U

underlay
In animation, an underlay is a specific part of the decor placed behind the main
animation.

201

Glossary

units aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid unit would
have the ratio 1:1, whereas a grid unit of aspect ratio 4:3 is a unit with one side 1.33
times as big as the other side.
V

vector
A vector-based image is composed of points and Bézier curves. The computer
reads the points and traces the segments, linking them to reproduce the image
shape. There is no fixed size or resolution in a vector image. The graphic can be
enlarged and distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated and displayed
in pixels once the calculation is done.

velocity
In animation, the ease, also known as velocity, is the acceleration and deceleration
of a motion. It can be a motion created by a function curve, or a series of animated
drawings. Other common terms for ease-in and ease-out are slow-in and slowout.
W

walk cycle
To avoid making innumerable drawings, animators routinely make a walk cycle for
their character. This comprises a series of drawings "on the spot" that describe the
walk for that character. The illusion of movement is created via the use of
background pans.

workspace
The workspace is the organization of the software interface and is made up of the
views, toolbars, and menus.
X

Xsheet
The Xsheet or exposure sheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing. Each column represents a
scene's layer. In each column, the drawing numbers are indicated and spread over
the specific amount of frames they need to appear. The exposure sheet is used by
animators, directors and other members of a crew to track the sequence and
timing of images, dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.
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Z

zone
An area which can be painted with colour.
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