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Chapter 1: Cut-out Animation - An Introduction
Harmony is a high-performance animation software which not only offers a wide range of features, but
also handles more than one animation type and workflow. In this guide, you will learn how to perform
tasks related to the cut-out animation workflow from start to finish using Harmony.
Before reading this guide, be sure to take some time to familiarize yourself with the basic concepts in
the Fundamentals Guide. Each chapter is self-contained. so you can concentrate only on the chapter
pertaining to your task. You do not need to read the entire guide, but you should read the whole
chapter before starting to work.

Topics in this section:
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•

Character, Prop and Location Design on page 1

•

Colour Styling and Colour Models on page 1

•

Painting the Background on page 1

•

Timing on page 1

•

Character Building on page 283

•

Library on page 381

•

Cut-out Animation on page 415

•

Deformation on page 487

•

Morphing on page 567
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Chapter 2: Character, Prop and Location Design

Another important step in the project creation is the character, prop and location design. This
determines the style and models to follow for the entire project.
The design can be created on paper and scanned in or it can be created digitally. You can draw and
even create the colours entirely on paper, while others like to design on paper and scan the drawings
to create the colour model in a software program. The most popular method is to design directly in
Harmony.
To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to
design all elements directly in the application. This keeps all your work within the same software,
avoids using a lot of paper and losing time scanning in elements and importing them.
The character and prop design process is divided in three steps:
•

Preparation on the next page

•

Sketching the Model on page 20

•

Cleaning and Inking the Model on page 33

Harmony has an extensive set of drawing tools that can be used to design your characters. You can
learn more about this in the following topic:
•

Drawing Tasks on page 35

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learn
more about them in the following section:
•

Drawing Tool References on page 101

17

Chapter 2: Character, Prop and Location Design

Preparation

Preparation
To prepare for the design task, you will need to go through a few steps:
•

Getting References below

•

Using the Workspace below

Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have
the script in hand, you can learn about the characters and their personalities, the props, the
ambiances, and so on. This will be your main reference, so it is very important to read it carefully.
The storyboard is the second reference source and it can be quite useful as well. Although it will not
yet be the final version of the storyboard, it will show you what the character is doing and what props
need to be designed.

Using the Workspace
Once your scene is created, you can open it and set your workspace.
To sketch the characters, props or locations directly in Harmony, you will mostly use the Camera or
Drawing views along with the Colour, Timeline and Tool Properties views.

18
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Sketching the Model

Sketching the Model

Now that your references and scene are created, you can start designing. To draw your characters,
props and key locations, you will need to learn the following:
•

Drawing with the Brush or Pencil Tool below

•

Override Tool on the facing page

•

Relative Size on page 22

•

Palettes and Colours on page 26

•

Sketching the Character on page 30

Drawing with the Brush or Pencil Tool

The Brush
and Pencil
tools are used for drawing and sketching. Both tools support pressure
sensitivity, allowing you to create lines with variable thickness. The Brush tool produces contour vector
lines. The Pencil and shape tools produce central vector lines. This means that a pencil line’s control
points (used to deform its shape) are located along the length of the central spine, while the Brush
line’s control points are located along the contour.

20

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

•

If you draw with the Brush tool and want to modify the thickness, use the Contour Editor

tool.

•

If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor
tool.

•

You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line

option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the
Brush tool as it produces a more realistic and natural feel. The pencil line is very useful for tracing clean
or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppet articulations which use
patches.

Override Tool
The Override tool lets you increase productivity by rapidly switching between tools used for short
tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by
another key, such as the Eraser tool which is accessed by pressing Alt + E.
If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold
down the E key while you are erasing. Once you are done, release the E key to return to the previous
tool; in this case, the Brush tool. You can do the same for most drawing tools that have a shortcut
composed of Alt followed by another key.
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Relative Size

Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining
consistency and structure throughout the project.
A production can contain many characters and props. It is not unusual for these to be created by
different people. If there is no size control implemented, the characters and elements created by
different artists can vary greatly. When this occurs, the characters that are placed together in a scene
will be out of proportion. The animator or person doing the scene setup will then have to scale them
to the correct size.
When a character or prop is scaled down, the outline will become increasingly thinner. By the time the
element is scaled to its proper size, the outline may be so thin that a difference between one
character's outline and the one beside it will not look very good.
Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then
scaling them to the correct proportion in relation to the other characters. This line up is very
important and should be handed to any animator, layout and posing artist or scene setup person
working on the project.
For the prop design, it is recommended that you paste one of the main character's hands or even the
full body beside the prop. This enables the animator to know what size to draw the prop.
In your character design scene, it is a good idea to create a column for the character line up.The line
up is usually done during the character design step. When the character builder imports the model
to the breakdown scene, the size relation should be correct.

Field Chart

Harmony includes a field chart in its Camera and Drawing views. This tool is very useful in setting the
characters' and props' heights.
It is recommended that you keep the character design and breakdown inside the 12 field size. This
ensures that it fits the default camera size and the template thumbnails. If some parts were drawn
too big or too far apart, you can use the Reposition All Drawings tool and reposition, scale or rotate
multiple drawings from different layers all at once.
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Relative Size

Use the Show Grid option to display a grid in the Drawing or Camera view.
Name

Show
Grid

Button

Description

Displays the grid

Keyboard Shortcut
From the top menu,
select View > Grid >
Show Grid
Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square

Displays a standard square grid

From the top menu,
select View > Grid >
Square.

12 Field Grid

Displays a 12-field size grid

From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid

Displays a 16-field size grid

From the top menu,
select View > Grid >
16 Field Grid.

Underlay

Displays the grid under the drawing
elements

From the top menu, select
View > Grid > Underlay

Overlay

Displays the grid over the drawing
elements

From the top menu, select
View > Grid > Overlay

How to use the Reposition All Drawings
1. In the Tools toolbar from the Select drop-down menu, select the Reposition All Drawings
tool. This also automatically selects every stroke in your drawing in the Drawing and Camera
views.
2. To deform or reposition a selection:
‣

To reposition, click and drag your selection to a new area.

‣

To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift
to lock the selection’s ratio.

24

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

3. When you release your cursor, every drawing contained in the drawing layer you repositioned,
scaled, rotated or skewed will follow the same transformation.

Brush Size
Harmony provides a variety of pens and brushes and also allows you to create and save your own
through creating a tool preset.
It is a good idea to create and save pens with precise sizes and parameters to trace and design your
models and breakdowns.

How to create a tool preset
1. In the Tools toolbar, select a tool, for example the Brush tool.
2. Use the Tool Properties view to customize the tool.
3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the
tool. Note that when using this preset in another scene not using that colour palette, upon
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to
your scene.
4. In the Tool Presets toolbar, click the New Tool Preset

button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the
File
button.
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Relative Size

7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.
8. When you select any of the following options, they will take effect when you use the tool preset. If
an option is deselected, then using a tool preset will not override your current settings.
‣

Colour: Saves the current colour into the tool preset.

‣

Tool: Only the colour will be associated. You could, for example, set three different
colours with shortcuts. It would use the current tool with the chosen preset colour.

9. Click OK.

Palettes and Colours
Harmony has an integrated palette system. Each character, prop or background can have its own set
of colours and each colour in the palette can be associated to colour fill zones on a drawing. You can
create as many palettes and colours as you need.

Each scene created in Harmony includes a default colour palette which contains a standard set of
colours for sketching and painting.
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You can sketch and design using the default palette without any problem. However, it is not
recommended that you use the default palette for the colour models. A different colour palette should
be created for each colour model.
To sketch and design with a different colour swatch or create a palette for each character, prop or key
location, you will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)
1. From the Colour View menu, select Palettes > New or click the New Palette

button.

The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click OK.
The palette appears in the drawing element’s palette list.

How to add or modify a solid colour swatch
1. In the Colour view, click the New Colour

button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.
The Colour Picker window opens.
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Relative Size

3. To set your colour, do one of the following:
‣

In the colour wheel, select a colour.

‣

Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣

Click the Dropper
button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.
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Sketching the Character

Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your
characters:
•

Add a drawing layer

•

Sketch the model

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing
with bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your
layer as vector. If you use vector, you will be able to enlarge your drawing and zoom into it without
losing quality or resolution. You can also use the Contour Editor and Select tools to resize and modify
lines. If you draw with bitmap, you will not be able to scale the drawing beyond 100% of its resolution
without encountering pixelization issues.
If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 310

How to add a drawing layer
1. In the Timeline view, click the Add Drawing Layer
The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.
3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a
bitmap layer.
4. Click OK.
A new drawing layer is added to the Timeline view.

How to sketch a model
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.

3. In the Timeline or Xsheet view, click in the first cell of the drawing layer.
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4. In the Drawing or Camera view, enable the Grid (Field Chart). You can press Ctrl + '
(Windows/Linux) or ⌘ + ' (Mac OS X).
‣

Make sure the Drawing or Camera view is the active view while using the keyboard shortcut.

5. In the Drawing or Camera view, start drawing.

6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything
already painted with that colour swatch will update to the new colour.

7. In the Camera or Drawing view, use the Rotary Table
Ctrl+Alt (Windows/Linux) or Ctrl+⌘ (Mac OS X).
‣

to rotate your workspace.You can press

The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin
by pressing Alt + O.
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Cleaning and Inking the Model

When your rough models are ready, it is time to clean and ink them. You can still use the default
palette and colours to do so, especially if you are not the one doing the colour styling. If you have
already created a palette for your model, you can add new colours for tracing.
If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light
Table. This is the equivalent of adding a sheet of paper and tracing over the rough using the animation
disk light table. You only need to disable the rough layer to prevent it from appearing in the final scene
render.
If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 310

How to trace your character in a new layer
1. In the Timeline view, add a new drawing layer and name it: clean.
2. If you work in the Drawing view, enable the Light Table

or press Shift + L.

3. Do one of the following:
‣

In the Tools toolbar, select a drawing tool.

‣

From the top menu, select Drawing > Drawing Tools > desired tool.

4. In the Timeline or Xsheet view, select the cell in which you want to draw.
5. Trace the model.

6. To make perfect points and corners, you can intersect the two strokes to create a point. Using the
Cutter
tool, you can automatically trim the excess portion. In the Tool Properties view, enable
the Lasso
selection type. Make sure the Use Mouse Gesture
button is enabled. In this
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mode, you can automatically delete any extra sections of line in your artwork by simply clicking,
holding and dragging your mouse over it.

7. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines
together after cropping the points.
‣

In the Tools toolbar, select the Select

‣

In the Camera or Drawing view, select the two strokes to be merged.

‣

In the Tool Properties view, click the Merge Pencil Lines

‣

You can also set the Join option to Mitre.

tool.
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Drawing Tasks
Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to
use these tools. For the complete details on their options in the Tool Properties view, see Drawing
Tool References on page 101.
In this topic, you will learn about:
•

Current Drawing on Top below

•

Drawing with the Pencil Tool on the next page

•

Drawing with the Brush Tool on page 46

•

Drawing with Textured Brushes on page 53

•

Viewing the Final Lines as You Draw on page 67

•

Selecting the Current Colour of a Tool on page 68See "Selecting the Current Colour of a Tool " on
page 68

•

Selecting Drawing Objects on page 71

•

Erasing Parts of a Drawing on page 74

•

Reshaping a Drawing Using the Contour Editor Tool on page 76

•

Reshaping Pencil Lines with the Pencil Editor Tool on page 78

•

Drawing with Shapes on page 80

•

Drawing with the Polyline Tool on page 82

•

Drawing with Invisible Lines on page 83

•

Deforming a Drawing with the Perspective Tool on page 85

•

Warping a Drawing with the Envelope Tool on page 86

•

Cutting Drawing Parts on page 88

•

Smoothing Lines on page 89

•

Working With Text on page 89

•

Working with Tool Presets on page 90

•

More Drawing Tools on page 93

Current Drawing on Top
In Harmony, when you draw on a layer, the artwork is displayed in the correct order. For example, if
the layer on which you are drawing is located behind an object on another layer, the lines you are
drawing will be hidden behind that object.
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This lets you display the selected drawing on top of everything while you draw. By enabling this
option, each time you select a drawing tool, the selected drawing is displayed in front of everything in
the Camera view. The Timeline and Network view ordering remain unchanged.
The Show Current Drawing on Top status (enabled or disabled) is remembered when you exit
Harmony. When you restart the application, the last status will be used.
You only need to enable this option once, it is not necessary to do it each time you select a drawing
tool.

How to display your drawing on top
1. Do one of the following:
‣

From the top menu, select View > Show > Current Drawing on Top.

‣

In the Camera bottom toolbar, click the Current Drawing on Top

button.

2. In the Tools toolbar, select a drawing tool.
3. In the Camera view, start drawing.

Drawing with the Pencil Tool

The Pencil tool is for drawing the final images, such as character modules, cut-out puppet and clean
animation. The pencil creates a central vector shape. Pencil lines support pressure sensitivity and
texture.
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How to draw with the Pencil tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.

2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing or Camera view, start drawing.
‣

When you get close to an existing pencil line, hold Alt to draw and connect your stroke to
the existing one. Pencil lines are central vector lines and you might think your line is
connected, but in fact, only the contour is touching the other one. Also, make sure the
central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣

To draw a straight line, press Shift + Alt as you draw.

How to modify the pencil settings
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

37

Chapter 2: Character, Prop and Location Design

Drawing Tasks

The Pencil Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.
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You can adjust the start, end, and joint style of a selected
pencil line.
Shape

Texture

•

Start: Lets you select the style of the start tip, which is the
first tip you drew. You can choose between Round or Flat
style.

•

End: Lets you select the style of the end tip, which is the
last tip you drew. You can choose between Round or Flat
style.

•

Join: Lets you select the joint style. The joints are where
the line curves abruptly. You could also define the Join
style as the corner style. You can choose between Round,
Mitre and Bevel style.

See Pencil Line Texture on page 42.

Working with Pencil Presets

A preset is a pencil with specific properties. You can work with regular pencil presets and thickness
stencils.
Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the
thickness of the line varies according the amount of pressure you apply with a pen and tablet.
Thickness stencils that are indicated with this
icon are also set with specific properties, but
disregards the pressure you use with your pen and tablet. The line thickness varies. You can access
thickness stencils from the list of presets on the Tool Properties view or create your own.

How to select a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

2. In the Tool Properties view, use the Presets menu to select a pencil preset.
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3. In the Drawing or Camera view, draw your pencil line or shape.

How to select a pencil thickness stencil
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, use the Presets menu to select a thickness stencil. They are marked
with this

icon.

3. In the Drawing or Camera view, draw your pencil line or shape.

How to create a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, adjust your pencil settings—see How to modify the pencil settings on
page 37.
3. In the Tool Properties view, click the New Brush
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The New Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and click OK.
5. Start drawing in the Drawing or Camera view.

How to create a pencil thickness stencil
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the pencil line or shape from which you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil

button.

A new thickness stencil is added to the end of the list in the Presets menu.
4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing or
Camera view to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape
1. In the Tools toolbar, select the Select

tool.

2. In the Drawing or Camera view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.
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The style you selected is applied to your selection.

How to rename a thickness stencil or pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Presets menu, select the thickness stencil or preset you want to rename.
3. From the Brush menu, select Rename Brush.
The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

How to delete a thickness stencil or pencil preset
1. In the Tools toolbar, select the Pencil

tool.

2. In the Presets menu, select the thickness stencil or preset to delete.
3. Click the Delete Preset

button.

Pencil Line Texture
You can apply a texture to a pencil line.
Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your
lines. You can also change it afterwards using the Select tool. Textures are independent from pencil
templates.
When you import a texture in your pencil styles, it is saved in your scene. If you want to add that
texture to a bank that you will reuse in different scenes, you can add that texture to your preferences.
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There is a pencil texture palette created in each scene. In order for this palette to be created, you need
to draw a pencil stroke using texture. To see it, you need to enable the Advance Palette Lists option.
Once enabled, you will see a palette named pencilstyle_opacity in your palette list.
For advanced usage, you can assign a custom palette as your pencil texture palette. All textures used
to draw in your scene will be added to this custom palette. This gives you the ability to save your
custom palette at the Environment or Job level if you want to reuse that palette in more than one
scene—see .

How to apply a preset texture to a pencil line
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties display.

3. In the Texture section, select a texture for the pencil.
4. In the Camera or Drawing view, draw a pencil line.

How to create a pencil texture template with the Pencil tool
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, click the New Texture
Texture menu.
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To delete a preset style, click the Delete Texture

button.

4. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.

5. Click Open.
The imported texture is saved in your scene texture list.

6. In the Pencil Properties editor, select your new texture.

7. In the Tool Properties view, click the Texture menu and select Rename Texture.
The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.
9. In the Camera or Drawing view, draw your pencil lines.
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How to add a texture to your preferences
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your
preferences.
4. Click the Copy to Preference

button.

How to apply a preset texture to a pencil line
1. In the Tools toolbar, select the Select

tool.

2. In the Drawing or Camera view, select a pencil line.

3. In the Tool Properties view, select a texture from the Textures area to apply to the selected
stroke.

How to assign a custom palette as the Pencil Texture Palette
1. In the Colour view, create your custom palette and save it at the level of your choice—see .
2. Select the palette you want to assign as your pencil texture palette.
3. From the Colour view menu, select Palette > Pencil Texture Palette.
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How to enable the Advanced Palette Lists preference
1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac
OS X ).
2. In the Preferences dialog box, select the Advanced tab,
3. In the Advanced Options section, select the Advanced Palette Lists option.
4. Click OK.

Drawing with the Brush Tool

The Brush tool is pressure sensitive and can create a contour shape which gives a thick and thin line
effect, as if the drawing was made with a paint brush.
With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add
your drawing layer, you can simply select the vector or bitmap option. If you use vector, you will be
able to enlarge your drawing and zoom into it without losing quality or resolution. You can also use
the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you will not be
able to scale your drawing beyond 100% of its resolution without encountering pixelization issues.
You can create your own brush styles. A variety of brush styles are provided allowing you to create and
save your own.This way you can create brushes with precise sizes and parameters and save them so
you can draw and design. Renaming a brush can make it easier to identify and access the brushes you
use most frequently.
A dynamic brush can be created for drawing using patterns created from your artwork. Create a new
dynamic brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic
brushes using a single or multiple patterns that will automatically switch through the patterns as you
draw.

To draw with the Brush tool
1. In the Timeline view, click the Add Drawing Layer
The Add Drawing Layer window opens.
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2. In the Name field, name your new layer.
3. Set the Line Art and Colour Art options to Vector to get a vector layer or to Bitmap to have a
bitmap layer.
4. Click OK.
A new drawing layer is added to the Timeline view.
5. In the Timeline or Xsheet view, select the cell on which you want to draw.

6. In the Tools toolbar, select the Brush

tool or press Alt + B.

7. In the Colour view, click a colour swatch to select a colour.

8. In the Drawing or Camera view, start drawing.
‣

Hold Ctrl (Windows/Linux) or ⌘ (Mac OS X) to force a line to join the start and end of the
shape while drawing.
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The last colour you select while using the Brush tool is recalled the next time you select the Brush tool.

How to select a brush style
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties, select a brush style from the Brush Presets section.

How to modify the brush settings
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.

48

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Tip Shape

Texture

Lets you select a tip shape from round and square ones to
star shaped.

See How to draw with textured lines on page 54
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How to create a brush preset
1. Make sure your current brush has the settings you want in the preset you are will create.
2. Do one of the following:
‣

In the Brush view, click the New Brush

‣

From the Brush

‣

In the Properties window of the tool you are using, click the
corner.

button.

menu, select New Brush Preset.
button in the upper-left

3. In the New Preset window, type a name for your new brush preset.
The new brush is added to the end of the list of brush preset.

Brush presets cannot be updated. However you can select a preset, which applies those properties to the
current brush. Then you can modify the properties, and create a new preset with the new properties. If
desired, you can delete the old preset.

How to rename a brush
1. In the Tool Properties view, select a brush to rename.
2. From the Brush

menu, select Rename Brush.

3. Type in a new name for the brush.

How to delete a brush preset
1. Select the brush preset you want to delete.
2. Do one of the following:
‣

In the Brush Preset view, click the Delete Brush

‣

From the Brush Preset

button.

menu , select Delete Brush.

How to create a new dynamic brush
1. In the Tools toolbar, select a drawing tool.
2. In the Camera view, draw the pattern you want to use as your dynamic brush stamp.

3. In the Tools toolbar, click the Select
repeat.

tool and select the parts of the drawing you want to
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4. In the Tools toolbar, select the Brush

tool or press Alt + B.

5. In the Tool Properties view, click the Add Dynamic Brush
dynamic brush preset.
6. From the Brush

button to add your selection as a new

menu, select Rename Brush.

The Rename Preset dialog box opens.
7. Type in a name for the new dynamic brush and click OK.
8. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the
Maximum Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings
sbutton to create the layers you want to use
1. In the Timeline view, click the Add Drawing Layers
as patterns in your dynamic brush. Make sure to rename your layers.

2. In the Camera view, draw your individual pattern on a separated layer.
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3. In the Tools toolbar, select the Select

Drawing Tasks

tool.

4. In the Tool Properties view, disable the Works on Single Drawing
tool to grab artwork on multiple layers.

option to allow the Select

5. In the Camera view, select all the drawings you want to add to your new dynamic brush.

6. In the Tools toolbar, select the Brush
7. Click the Add Dynamic Brush

tool or press Alt + B.

button to add your selection as a new Dynamic Brush preset.

8. From the Brush menu, select Rename Brush.
The Rename Preset dialog box opens.
9. Type in a name for the new dynamic brush and click OK.
10. In the Camera or Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.
When you use this brush, you will cycle through the drawings.
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Drawing with Textured Brushes

In Harmony, you can use the Brush

tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes, but you can also
create your own collection by importing PSD or TGA files in the Preset list.
To create your own texture brush, you must prepare your texture file in a third-party software, such as
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be
either a PSD or TGA file. It is recommended that you maintain your texture resolution between 100 x
100 pixels and 400 x 400 pixels.
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and
you lose the feather created while drawing with the Brush tool. In Harmony, a special option in the
Eraser tool lets you create a soft edge on your textured lines. You can also cut or keep the vector
frame as is.
Sometimes you need to hide the line texture to see the complete vector frame around your lines. This
is useful to help you see any dirt floating around your drawing.
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At some point, you may want to modify the look of a textured drawing. Maybe you find that your line
is too smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity
command.
To hide the line texture in the Camera view, you must enable the Show Drawing on Top option. From
the top menu, select View > Show > Current Drawing on Top—see Current Drawing on Top on
page 35.
To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with
pencil line texture—see Pencil Line Texture on page 42

How to draw with textured lines
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties
view.

3. In the Texture section, select the Select Texture option.

4. Set the following parameters:
‣

Hardness: The hardness value corresponds to the smoothness of the line edge. The lower
the value, the more blurry and smooth the line edge will be. The higher the value, the
sharper the line edge will be.

‣

Minimum Opacity: This value corresponds to the transparency of the brush when the
pressure is very light. Values closer to 0 produce a more transparent line.
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‣

Maximum Opacity: This value corresponds to the transparency of the brush when the
pressure is heavy. Values closer to 1 produce a more opaque line.

‣

Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the
current texture. You can also browse for a texture file to import. Browsing for a texture file
in a brush already using texture will replace the file currently in use, although it will not
replace the texture in the lines already drawn. If your image has transparency in it, it will be
supported. The texture file must be either a PSD or TGA file. It is recommended that you
maintain your texture resolution between 100 x 100 pixels and 400 x 400 pixels.

‣

Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid
texture, the squares will be larger if you increase the value and smaller if you decrease it.

5. In the Camera or Drawing view, start drawing.
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How to erase textured lines
1. In the Tools toolbar, select the Eraser

tool, press Alt + E.

2. In the Tool Properties view, click the arrow button.

The Brush Properties window opens.

3. Adjust the following:
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‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour
boundaries (around the line). Lower values mean that the line will appear as you draw it
(with more control points added along the centre line). Higher values mean that the line will
be smoothed out (removing control points from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to
choose from: round, square, oval, star-shaped, and more. This option is only available when
the textured tip is not in use.

‣

Soft Tip: Gives the tip of your stroke a soft edge.

‣

Keep Vectors: Keeps your vector frames and does not cut them.

‣

Hardness: The smoothness of the line edge. The lower the value, the more blurry and
smooth the line edge will be. The higher the value, the sharper the line edge will be.

‣

Saturation: The intensity of line colour.

‣

Maximum Opacity: The transparency of the brush when the pressure is heavy. Values closer
to 1 produce a more opaque line.

‣

Minimum Opacity: The transparency of the brush when the pressure is very light. Values
closer to 0 produce a more transparent line.

4. In the Camera or Drawing view, erase your textures lines.

How to adjust the line texture opacity
1. If you are in Camera view, select the Current Drawing on Top option—see Current Drawing on
Top on page 35.
2. In the Timeline or Xsheet view, select the drawing that contains the opacity you want to adjust.
3. In the Camera or Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.
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4. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.
5. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All
Drawings option and click OK.

Drawing with Bitmap Brushes

With Harmony, you have the choice to draw with vector or bitmap brushes. When adding a new
drawing layer in , you can set your art layers (Line, Art, Colour Art) to vector or bitmap. This way, you
can draw in bitmap and paint in vector, draw everything in bitmap, or whatever other combination
suits you.
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Not all drawing tools are available when working on a bitmap layer. You can use the following tools:
•

Brush

•

Cutter

•

Dropper

•

Ellipse

•

Eraser

•

Line

•

Paint

•

Paint Unpainted

•

Pivot

•

Rectangle

•

Repaint

•

Reposition All Drawings

•

Select

•

Text

•

Unpaint

In , when adding a new drawing layer to the Timeline view, you can select the art mode for each art
layer. You can set the Line Art layer to vector while setting the Colour Art as bitmap. You also have the
opportunity to adjust them later by converting them from one to the other. If you are using the
Overlay and Underlay layers, you can also set them to either bitmap or vector.
If you selected the incorrect art mode for your layers, you can open the Layer Properties view and
modify them there directly. If you switch the art mode for a layer that already has strokes on it, the
artwork will NOT be converted. You will be able to add new strokes. A drawing with bitmap strokes
will be converted to a vector layer but the bitmap artwork will remain as bitmap. You will be able to
use vector drawing tools to continue drawing on it. A drawing with vector lines switched to a bitmap
layer will allow you to draw new bitmap strokes and move the vector strokes with the Select tool, but
you will not be able to edit the vector art further. You need to convert the drawings in order to pass
the artwork from one mode to the other.
To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.
Before you start drawing in bitmap, it is important to understand that your artwork will now be
resolution dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan
ahead and decide how high of a resolution you need your artwork to be. If you plan to zoom in your
scene, the smallest section of the image that the camera will frame must be 100% the size of your
scene resolution. For example, if your scene resolution is set to 1920 x 1080 and you zoom in at 300%,
then the resolution of the bitmap also has to be set to 300%. It is important to change the bitmap
layer resolution before you start drawing.
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level
affects newly created bitmap art layers.
Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be
very heavy. It depends on the amount of artwork your draw in it.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution
on an existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass
(resampling) and create additional pixels to avoid losing too much quality, but only to a certain extent.
For example, you used the default scene’s resolution for bitmap art but then discover you are zooming
quite close into the lines. If you do not want to see the pixels appear too much when you are zoomed
in, you can set the bitmap resolution to 200% and the bitmap art will have a higher resolution with
smaller pixels, but will NOT retain 100% of its quality. You can use this function on multiple drawings
using the Apply to All Drawings option. Changing this option will affect existing and selected bitmap
art layers.
If you drew an outline drawing on a bitmap layer, you can vectorize your artwork. Using a vector
drawing layer, you can simply select your bitmap drawing and the vector cell on which you want your
new vector layer to be, and use the Vectorize Line Art in Selected Drawing function.
You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that
when you continue drawing, your image will be resampled and your new strokes will be at the original
resolution and not the scaled up size.
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Your drawing should be scaled up using the Transform
very large bitmap layers.

tool instead of the Select tool to avoid creating

How to add a bitmap layer
1. In the Timeline view, click the Add Drawing Layer

button,

The Add Drawing Layer dialog box opens.

If you are using the Overlay and Underlay layers, those art layers are also displayed.

2. For each art layer, select the Vector or Bitmap option.
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3. Click OK.

How to change the art mode
1. Open the Layer Properties view.
2. In the Timeline view, select the layer you want to edit.
3. In the Layer Properties view, select the Drawing tab.

4. In the Art Layers section, select the art mode for each art layer.

How to adjust the art mode settings in the Preference Panel
1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac
OS X ).
2. Select the Network tab.

3. In the Layer Drawing Options section, set the art layers to the desired art mode. Once this option
is enabled, all new layers will follow these settings. It will not affect any existing layers.
4. Click OK.

62

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

How to convert drawings to match the art mode
1. In the Timeline view, select the layer that contains the drawings you want to convert.
2. From the Timeline view menu, select Layers > Convert Drawings to Match Art Layer Type.
You can also right-click on the selected layer and select Convert Drawings to Match Art Layer
Type.
All drawings in the layer are converted to the selected art mode. Note that bitmap strokes are not
vectorized when converted to a vector art layer. They are simply inserted in a square vector frame
containing a bitmap texture.

How to change the bitmap layer resolution at the scene level
1. From the top menu, select Scene > Scene Settings.
The Scene Settings dialog box opens.
2. Select the Bitmap Resolution tab.
3. Change the bitmap resolution settings and click OK.
The bitmap resolution settings at the scene level affects newly created bitmap art layers.

Parameter

Description

Scene Resolution

This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have artwork at the four corners of your camera frame or even quite far outside
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of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.
Height

This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.

How to change the bitmap resolution at the drawing level
1. In the Timeline view, select the drawing whose resolution you want to change.

Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if you
enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution
before drawing. If you need to change the resolution of a drawing to be larger than the one set in the
Scene Settings dialog box, create an empty drawing first and then follow this procedure.

2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.
The Change Bitmap Drawing Resolution window opens.

Parameter

Description

Scene Resolution

This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have artwork at the four corners of your camera frame or even quite far outside
of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.
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Height

This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.

Resample Bitmap

When this option is selected, the existing bitmap image is
modified to match the new resolution. If the width and height
are increased, more pixels will be created to enlarge the
image. Visually, the existing artwork will look the same,
maybe a little bit smoothed out, but the size will look the
same. When this option is deselected, the artwork is not
modified. Only the reference grid is resized. If the scene
resolution is 1920 x 1080 and you reduce the bitmap
resolution to 960 x 540, the image will be scaled up to twice
the size of the scene.

Apply to All Drawings

The modified settings are applied to all drawings in the drawing layer
for a given art layer. If the Apply to Line Art and Colour Art option is
enabled, it will then be applied to all bitmap art layers.

3. Change the bitmap resolution.
4. Click OK.

How to draw with bitmap brushes
1. In the Timeline view, add a bitmap drawing layer—see How to add a bitmap layer on page 61.
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. In the Colour view, select a colour.

‣

To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select
Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on
the colour sliders and select RGB Sliders or HSV Sliders.
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When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.
4. In the Camera or Drawing view, start drawing.

How to vectorize a bitmap drawing
1. In the Timeline view, add a vector drawing layer BELOW the bitmap drawing layer containing the
drawing to vectorize. In your bitmap drawing, the artwork to vectorize must be placed on the Line
Art layer (default drawing layer).

If you place the vector drawing on top of the bitmap layer, you will not be able to
perform the operation. A warning dialog box will display.

2. On the right side of the Timeline view, select the bitmap drawing and corresponding cell in the
vector drawing layer.
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3. Right-click and select Drawing > Vectorize Line Art in Selected Drawing.
The Convert to Vector Drawing dialog box opens.

4. In the Vectorization section, select a vectorization preset. You can customize your own preset
using the Add or Edit buttons—see Custom Vectorization Parameters.
5. Click OK.
Your vectorized drawing is created in the vector drawing layer. Your bitmap drawing remains
intact.

Viewing the Final Lines as You Draw

Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap.
Although, when you draw in the Drawing or Camera view, notice that your lines may appear jagged.
This is caused by the fast real-time display called OpenGL. If you prefer to see smooth lines as you
draw, you can enable the antialiasing preference.

Full Scene Antialiasing
Full scene antialiasing is generated by your computer’s graphics card. This antialiasing will not only
antialias your drawings, but all your different views in the interface. Full scene antialiasing is an option
you can turn on and off; by default, it is disabled.
There is no need to modify your graphic card settings.

Full Scene Antialiasing parameters are only valid while you work in your scene. The scene will be rendered
to 100% of its resolution regardless of your preference settings or graphic card panel.
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How to customize the full scene antialiasing parameters

For Mac OS X, you must restart Harmony after you change the parameters.

1. In the Harmony, do one of the following:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

The Preferences dialog box opens.
2. In the OpenGL tab, go to the Full Scene Antialiasing section.

‣

Enable: Select this option to enable/disable the Full Scene Antialiasing.

Number or samples (For Mac OS): If you are using a Mac OS X computer, enter the number of samples
you want to be used for the antialiasing process. The number of samples is basically equivalent to the
amount of times a pixel will be enlarged to calculate the antialiasing. This technique is called
supersampling. The higher the number of samples, the better the antialiasing quality will be, but the
longer it will take to calculate.
3. Restart Harmony.

Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of
the following tools:
•

Brush

•

Paint

•

Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint, and Pencil tools.
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How to unlink the storage swatches
1. In the Colour view, if the storage swatches are linked, click the Link

2. Click on the Brush

storage swatch.

3. In the Colour list, select the desired colour.
4. Click the Pencil

storage swatch.

5. In the Colour list, select a colour.
6. Click the Paint

storage swatch.

7. In the Colour list, select a colour.
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If you prefer to have Toon Boom Harmony use the same colour swatches regardless of the selected tool,
you can link the three swatches together.

How to link the storage swatches
1. In the Tools toolbar, select one of the following tools:
‣

Brush

‣

Paint

‣

Pencil

‣

Polyline

‣

Line

‣

Ellipse

‣

Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers
When working in the Colour view, by default the current colour is active for both vector and bitmap
layers. You can however, use different reference colours for each layer.
When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.

How to use independent colours
‣

From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.
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Selecting Drawing Objects

The Select tool is used to select strokes in both the Drawing and Camera views, and apply basic
transformations, such as repositioning, rotating, scaling or skewing using the different handles of the
bounding box.
Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to
select only the stroke or line that you do not want included in your selection. Then, you can invert the
selection so that everything else becomes selected. This can be quite a time saver.
By default, when you draw a selection box, the Select tool will select only the drawing strokes of the
current drawing. If you prefer the Select tool to select all the strokes on all layers, you can disable the
Works on Single Drawing option in the Tool Properties view or the Select Tool Works on Single
Drawing option in the Preferences dialog box.
Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of
the pivot point. You can temporarily reposition this pivot point for a transformation using the Select
tool.

How to select with the Select tool
1. In the Timeline view, select the cell on which you want to select drawing objects.
2. In the Tools toolbar, select the Select

tool or press Alt + S.

3. In the Camera or Drawing view, select the drawing objects.
‣

You can select all the drawing objects in a drawing by using Edit > Select All or by pressing
Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X).

4. To deform or reposition a selection:
‣

To reposition, click the selected drawing object and drag the selection to a new area.
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‣

To rotate, grab the selection box handle and rotate it.

‣

To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to
lock the selection’s ratio.

‣

To skew, drag sideways or up and down the sides or top and bottom segments, between
the control points.
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How to invert a selection
1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or ⌘ +
Shift + I (Mac OS X).
‣

You can also find the Invert Selection option in the Camera or Drawing View menu by
selecting Edit > Invert Selection.

How to enable and disable the Select Tool Works on Single Drawing preference
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).
The Preferences dialog box opens.
2. In the Camera tab, go to the Tools section and select or deselect the Select Tool Works on Single
Drawing option and click OK.
3. In the Tools toolbar, select the Select

tool or press Alt + S.

4. In the Camera view, make your selection. It is possible that you will have to restart Harmony
depending on your system.

How to temporarily reposition the pivot point
1. In the Camera or Drawing view, select the drawing object you want to transform.
The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.
This becomes the new position of the pivot point for the current transformation and will remain
there until you make a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts
of a drawing. You can also use the Select tool to select drawing objects and delete them instead of
erasing.

How to erase with the Eraser tool
1. In the Timeline or Xsheet view, select the cell that contains objects you want to erase.

2. In the Tools toolbar, select the Eraser

tool or press Alt + E.

3. In the Camera or Drawing view, start erasing.

How to modify the eraser settings
1. In the Tools toolbar, select the Eraser

tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.
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The Brush Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.
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Lets you select a tip shape from round and square ones to
star shaped.

See How to draw with textured lines on page 54

Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a
vector line and control them with Bezier handles. It is used to correct line shapes and modify a single
part of a colour zone. If a line is too thin or has a gap in it, you can modify and correct it with the
Contour Editor tool. You can also use this tool to create elaborate shapes.
The Contour Editor displays vector points around a shape and the central vector points in a pencil line.
Pulling or pushing on these points adjusts the brush’s line thickness. Points can be selected and
deleted. Each point has two Bezier handles for correcting the curves between two points. Shapes can
be modified by pulling and pushing directly on the segment between the points. You can use it to
perfect a central shape pencil line, a contour shape brush line, or even create an elaborate shape from
a basic ellipse or square.

How to reshape with the Contour Editor tool
1. In the Timeline or Xsheet view, select the cell in which you want to draw.
.

2. In the Tools toolbar, select a shape tool:
3. In the Tool Properties view, click the Ellipse
pencil size to 0.

button, click the Auto Fill

4. In the Drawing or Camera view, draw a circle.
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5. In the Tools toolbar, select the Contour Editor

tool.

6. In the Drawing or Camera view, click the line to reshape it.

7. Select one or several points by clicking on them or circling around.

8. Press Delete to delete a selected point.
Press Ctrl (Windows/Linux) or ⌘ (Mac OS X)and click on the contour to add a new point to adjust
the contour.
9. To modify the shape, you can:
‣

Pull on the Bezier handle. Both point’s handles will move as one.

‣

Hold down Alt and pull on one of the Bezier handles. The point’s handle will move
independently from the other one.

‣

Move the selected points to a new area.
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‣

Pull directly on the line between two points. No selection is necessary. Holding down Shift
will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣

To add control points, press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the line.

‣

To remove control points, select the control point and press Delete.

Reshaping Pencil Lines with the Pencil Editor Tool

The Pencil Editor tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vector
shape. The shape control points are located all along the central spine allowing you to adjust the stroke curve
and position. When using the Contour Editor tool, you can reposition the spine of the stroke. When using the
Pencil Editor tool, you can adjust the thick and thin areas of lines.

How to use the Pencil Editor tool
1. In the Tools toolbar, select the Pencil Editor

tool or press Alt + W.
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2. In the Camera or Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.

4. Press Delete to delete a selected point.
5. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the central spine to add a set of points to
adjust the contour.
6. To modify the shape, you can:
‣

Move the selected points to a new area. If you select matching points on each side of the
line, holding the Shift key will move them both. This way you can thicken or thin a line from
both sides at the same time.

‣

Pull on the Bezier handle to move both points’ handles as one.
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‣

Hold down Alt and pull on one of the Bezier handles. It moves the handle independently
from the other one.

‣

Pull directly on the line between two points. No selection is necessary. Holding down the
Shift key will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier handle, hold down Alt to display them.

Drawing with Shapes
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In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape
a square or circle into a much more complex drawing such as these butterfly wings—see Reshaping a
Drawing Using the Contour Editor Tool on page 76 and Reshaping Pencil Lines with the Pencil Editor
Tool on page 78.

How to draw with a Shape tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select a shape tool:

.

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill
4. In the Camera view, click and drag to draw the shape.

‣

Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣

Hold down Alt to draw the rectangle or ellipse from its centre.

‣

Hold down Shift to snap the line every 15 degrees.

‣

Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor

tool to deform the shape and create your drawing.
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Drawing with the Polyline Tool

The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to
add a point and then, without releasing the mouse, pull the handle in the desired direction before
adding the next point and repeat the operation. To edit the shape, you can use the Contour Editor
tool.

How to draw with the Polyline tool
1. In the Timeline view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Polyline

tool or press Alt + _.

3. In the Camera view, click and drag to create a point and a Bezier handle to shape your line.
‣

Press Alt to pull only one handle, instead of two.

‣

Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.
6. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click to release the Polyline tool from the current
path or shape that it is creating. Continue to use the tool to make multiple, independent paths or
shapes.
7. If necessary, reshape the lines using the Contour Editor
the Contour Editor Tool on page 76.
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Drawing with Invisible Lines

There are two different ways to draw invisible lines.
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be
useful for drawing tones and highlights directly on the character.
The Stroke tool draws invisible lines only. You cannot add thickness to the line, unlike the Close Gap
tool that creates a short, straight line between two points. The stroke line will stay exactly where you
draw it. This tool can be useful for closing a zone in a particular way or creating some hard shadows or
highlight areas.

Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue
stroke colour. In Harmony, you can display the strokes and washed-out the colours of your drawings
so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. From the top menu, select View > Drawing > Show Strokes

or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.
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Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to draw invisible lines with the Stroke tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
2. In the Tools toolbar from the Paint drop-down menu, select the Stroke
3. From the top menu, select View > Show Drawing > Show Strokes

tool or press Alt + V.
or press K.

4. In the Tool Properties view, you can adjust the smoothness.
5. In the Camera or Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to show the strokes with washed-out colours
‣ From the top menu, select View > Show > Show Stroke With Colour Wash.
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Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

How to deform a drawing with the Perspective tool
1. In the Tools toolbar, select the Perspective
press Alt + 0.

tool from the Contour Editor drop-down menu or

2. In the Camera or Drawing view, select a drawing to deform.
3. Click and drag the different anchor points to deform the shape.
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Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier
handles.

How to warp a drawing with the Envelope tool
1. In the Tools toolbar, select the Envelope

tool from the Contour Editor drop-down menu.

2. In the Timeline view, select a drawing to deform.
3. In the Camera or Drawing view, select the region you want to deform

4. Click and drag the different anchor points and handles to deform the image.
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5. To display more controls, in the Tool Properties view, click the Show Advanced Controls
button.

6. Increase the height and width of the grid to get more control points to deform your image.
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Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool
1. In the Tools toolbar, select the Cutter

tool or press Alt + T.

2. In the Camera view, make a selection around an area to cut away.

‣

To delete the selected zone, press Delete.

‣

To move the selection, click the selection and drag it to a new area.

‣

Use the bounding box controls to scale, skew, or rotate the cut piece.
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Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines
you draw may look as if they were drawn with an unsteady hand. When this occurs, you may need to
correct the look of your lines.
Harmony has a very powerful tool you can use to optimize contours and reduce the number of points
on the lines, the Smooth Editor tool.

How to optimize lines with the Smooth Editor tool
1. In the Tools toolbar, select the Smooth Editor
Editor.

tool or select Drawing > Tools > Smooth

2. In the Camera or Drawing view, place your pointer over the lines to smooth. You may need to pass
over the same line several times to remove more points and make the line smoother. Note that by
default, the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—
see Smooth Editor Tool Options on page 138 to learn about the various settings available.

Working With Text

With the Text tool, you can type text in your project using various fonts and texts attributes. Text
objects are part of a drawing, so you can manipulate them in the same way. OTF fonts are also
supported.
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How to add text to drawings
1. Do one of the following:
‣

In the Tools toolbar, select the Text

‣

From the top menu, select Drawing > Tools > Text.

‣

Press Alt + 9.

tool.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.
3. In the Drawing or Camera view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will
type—see Text Tool Options on page 140.
5. Type in the desired text.

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always
return to edit the text by selecting the Text
tool and clicking in the text.

Working with Tool Presets
Tool presets let you save a variety of settings and are very handy and efficient for accessing the tools
you use most often. That way, the tool is already set with the desired properties, such as colour, line
thickness, whether to enable Draw Behind or Auto Flatten mode, and so on. You can create presets
for these tools and many more: Brush, Pencil, Eraser, Rectangle, Ellipse, and Line. First, select a tool,
adjust the properties, and then create a tool preset for it. Once you have created a tool preset, you
can always make adjustments to fine-tune it, as well as create a keyboard shortcut for it.

The Tool Presets Toolbar
The Tool Presets toolbar lets you create new tool presets and manage them. There are four default
brush presets to get you started—Rough Brush, Clean Pencil, Fill Paint, and Inking Brush. By default,
this toolbar is not displayed.

How to display the Tool Presets toolbar
‣

Select Windows > Toolbars > Tool Presets.

‣

Right-click an empty area below the top menu and select Tool Presets.
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How to create a tool preset
1. In the Tools toolbar, select a tool, for example the Brush tool.
2. Use the Tool Properties view to customize the tool.
3. To set a specific colour for your preset, in the Colour view, select the colour swatch to link to the
tool. Note that when using this preset in another scene not using that colour palette, upon
selecting this new preset, a colour recovery dialog box will appear asking to add this colour to
your scene.
4. In the Tool Presets toolbar, click the New Tool Preset

button.

5. In the New Tool Preset dialog box, in the Name field, type a name for your new preset.

6. From the icon list, select an icon to quickly identify your preset or upload your own by clicking the
File
button.

7. (Optional) From the Shortcut menu, set a keyboard shortcut to quickly access your preset.
8. When you select any of the following options, they will take effect when you use the tool preset. If
an option is deselected, then using a tool preset will not override your current settings.
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‣

Colour: Saves the current colour into the tool preset.

‣

Tool: Only the colour will be associated. You could, for example, set three different colours
with shortcuts. It would use the current tool with the chosen preset colour.

9. Click OK.

How to select a tool preset
‣

In the Tool Presets toolbar, click the tool preset
icon you assigned when creating the
preset. Note that when using this preset in a new scene not using the assigned colour
swatch, a colour recovery dialog box appears asking to add this colour to your scene.

How to delete a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

2. From the list of tool presets on the left, select a preset to delete and click the Trash icon.

How to import a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets

button.

The Manage Tool Presets dialog box opens.
2. Click Import.
3. In the Select Folder window that opens, locate and select the preset(s) to import and click Select
Folder.

How to export a tool preset
1. In the Tool Presets toolbar, click the Manage Tool Presets
The Manage Tool Presets dialog box opens.
2. Click Export.
3. In the Export Brush Presets window that opens, click Export.
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4. Select a folder and click Select Folder.

How to update a tool preset
1. To update the colour of your preset, you must first select it in the Colour view.
2. In the Tool Presets toolbar, click the Manage Tool Presets

button.

3. In the Manage Tool Presets dialog box that opens, select the tool preset from the left side of the
dialog box.
4. Make any changes you would like to the preset.
5. Click Update.

More Drawing Tools
Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently;
tools such as Group, Arrange, and the animation disk to rotate your workspace.
•

Arrange below

•

Convert Brush Strokes to Pencil Lines on the next page

•

Pencil Lines to Brush Strokes on page 95

•

Strokes to Pencil Lines on page 95

•

Optimize on page 95

•

Remove Extra Strokes on page 96

•

Reduce Drawing Texture Resolution on page 96

•

Crop Brush Textures on page 97

•

Create Contour Stroke on page 98

•

Remove Contour Stroke on page 98

•

Grid on page 99

•

Group/Ungroup on page 99

•

Hand on page 100

•

Rotate View on page 100

Arrange
The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or
Camera view.
Name

Bring to Front

Button

Description

Access Method

Moves the selected art to the front
(on top)
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select Drawing >
Arrange > Bring to
Front.
Press Ctrl + Shift +
PgUp
(Windows/Linux) or
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⌘ + Shift + PgUp
(Mac OS X).

Bring Forward

Send Backward

Send to Back

Moves the selected art one level forward (closer to the front)

Moves the selected art one level
lower (behind)

Moves the selected art
behind everything (bottom
/ back)

From the top menu,
select Drawing >
Arrange > Bring
Forward.
Press Ctrl + PgUp
(Windows/Linux) or
⌘ + PgUp (Mac OS
X).
From the top menu,
select Drawing >
Arrange > Send
Backward.
Press Ctrl + PgDown
(Windows/Linux) or
⌘ + PgDown (Mac
OS X).
From the top menu,
select Drawing >
Arrange > Send to
Back.
Press Ctrl + Shift +
PgDown
(Windows/Linux) or
⌘ + Shift + PgDown
(Mac OS X).

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil
strokes. This command is only available from the top menu.

How to convert brush strokes to pencil lines
‣

From the top menu, select Drawing > Convert > Brush Strokes to Pencil Lines or press ^.

‣

Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ^
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Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into
contour strokes brush lines.

How to convert pencil lines to brush strokes
‣

From the top menu, select Drawing > Convert > Pencil Lines to Brush Strokes or press &.

‣

Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines
‣

From the top menu, select Drawing > Convert > Strokes to Pencil Lines or press Shift +
F12 (Windows/Linux only).

‣

Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize
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The Optimize command reduces the number of layers, such as overlapping brush strokes, in the
selected drawing objects. Drawing objects will only be flattened and optimized if the selected objects
do not change the appearance of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to
create an additive colour effect, the selected transparent drawing objects will not be merged. This is
because merging the transparent drawing objects will cause them to lose the effect of the layered
transparent colours.

How to optimize
‣

Use the Select tool to select the drawing objects you want to optimize.

‣

From the top menu, select Drawing > Optimize > Optimize.

‣

From the Camera or Drawing view menu, select Drawing > Optimize > Optimize.

Remove Extra Strokes
The Remove Extra Strokes option let you remove the invisible lines in your selection.

How to remove extra strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to
remove invisible lines from.
3. From the top menu, select Drawing > Optimize > Remove Extra Strokes.
‣

From the Camera or Drawing view menu, select Drawing > Optimize > Remove Extra
Strokes.

Reduce Drawing Texture Resolution
If you import and vectorize as texture (colour) a high resolution image, the size of your drawing can be
heavy. This option is used to reduce the size and resolution of the textures in your drawing. When you
import and vectorize drawings using the grey or colour preset styles, you don't have control on the
size of the bitmap texture. This tool allows you to reduce that bitmap texture.

How to reduce the drawing texture resolution
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to
reduce the texture resolution for.
3. From the top menu, select Drawing > Optimize > Reduce Drawing Texture Resolution.
‣

From the Camera or Drawing view menu, select Drawing > Optimize > Reduce Drawing
Texture Resolution.

4. In the dialog box, drag the slider toward the left to reduce the texture resolution.
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5. Enable the Apply to All Drawings option if you want the modification to be applied to all the
drawings in your layer.
6. Click OK.

Crop Brush Textures

The Crop Brush Textures option is used to crop an unnecessarily large texture bitmap that lies unseen
beneath the vector contour of a textured line. This often occurs when you cut and paste textured lines
from one drawing into another. If you cut a portion from a textured line and paste it into a different
drawing, Harmony pastes the entire unseen texture bitmap from the source drawing into the new one,
even if you only took a small portion of the source drawing. Using the Crop Brush Texture command
will crop away extraneous texture that does not touch the vector area. If there are many textured lines
in your scene, this will greatly reduce the file size.
In the example shown above, a textured line is cut from a drawing and pasted into a new drawing. At
first, it appears as if only a cropped section of the underlying texture bitmap was cut and pasted as
well. However, using the Contour Editor tool to expand the vector envelope of the textured line, it is
revealed that more texture bitmap exists beyond the cropped boundary. If you use the Crop Brush
Texture command, the bitmap texture is cropped to the boundaries of the textured line’s vector
contour (as seen in the fourth image where the vector envelope has been pulled out to reveal empty
space).

How to crop the brush texture
1. In the Timeline or Xsheet view, select the drawing whose texture you want to crop.
2. From the top menu, select Drawing > Optimize > Crop Brush Textures.
3. From the Camera or Drawing view menu, select Drawing > Optimize > Crop Brush Textures.
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Create Contour Stroke

The Create Contour Stroke
option is used to add a permanent invisible line around a shape that
was drawn directly in Harmony. This allows you to unpaint your lines with the Paint
tool but
maintain the shape of the lines, should you need to repaint later.
This command is useful when inking and painting and using the Apply to All Drawings in Layer
option.

How to create contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to
create contour strokes for.
3. From the top menu, select Drawing > Optimize > Create Contour Strokes.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were
created while scanning and vectorizing drawings or manually adding contour strokes. This is useful if
you want to remove the intersection triangles created during vectorization.

How to remove contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Camera or Drawing view, use the Select tool to select the drawing objects you want to
remove contour strokes for.
3. From the top menu, select Drawing > Optimize > Remove Contour Strokes.

98

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Grid

Use the Show Grid option to display a grid in the Drawing or Camera view.
Name

Show
Grid

Button

Description

Keyboard Shortcut
From the top menu,
select View > Grid >
Show Grid

Displays the grid

Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square

Displays a standard square grid

From the top menu,
select View > Grid >
Square.

12 Field Grid

Displays a 12-field size grid

From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid

Displays a 16-field size grid

From the top menu,
select View > Grid >
16 Field Grid.

Underlay

Displays the grid under the drawing
elements

From the top menu, select View
> Grid > Underlay

Overlay

Displays the grid over the drawing
elements

From the top menu, select View
> Grid > Overlay

Group/Ungroup
Use the Group option to group selected drawing objects. This can help in the selection, repositioning,
re-scaling and other transformations to be applied to multiple objects of a drawing.
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•

From the top menu, select Edit > Group > Group or Edit > Group > Ungroup.

•

From the Camera or Drawing view menu, select Edit > Group > Group or Edit > Group >
Ungroup.

•

Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or ⌘ + G and ⌘ + Shift + G (Mac OS X).

Hand
Use the Hand tool to pan through the Drawing or Camera view.
•

In the Tools toolbar, select the Hand

tool, click in the Drawing or Camera view and drag.

•

You can also Hold down the Spacebar, click in the Drawing or Camera view and move your mouse
in the direction you want to pan the view.

Rotate View
The Rotate View
tool lets you rotate the Drawing or Camera view, the same way as you would do
with a real animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool
1. Do one of the following:
‣

From the top menu, select Drawing > Tools > Rotate View.

‣

Press Ctrl + Alt (Windows/Linux) or ⌘ + Alt (Mac OS X).

‣

In the Tools toolbar, select the Rotate View

‣

In the Drawing or Camera view, right-click and select Drawing Tools > Rotate View.

tool.

2. In the Drawing or Camera view, click and drag to rotate the space.
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Drawing Tool References
Harmony has a wide variety of drawing tools and each one of them has a series of options and modes
available. This section covers these options. For details on how to use these tools, see Drawing Tasks
on page 35.
•

Pencil Tool Options below

•

Brush Tool Options on page 106

•

Select Tool Options on page 108

•

Eraser Tool Options on page 118

•

Contour Editor Options on page 119

•

Pencil Editor Options on page 122

•

Shape Tool Options on page 125

•

Polyline Tool Options on page 130

•

Stroke Tool Options on page 131

•

Perspective Tool Options on page 132

•

Envelope Tool Options on page 133

•

Cutter Tool Options on page 136

•

Smooth Editor Tool Options on page 138

•

Text Tool Options on page 140

•

Drawing Pivot Tool on page 144

Pencil Tool Options
When you select the Pencil

tool, its properties and options appears in the Tool Properties view.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Thickness Stencils
Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 39 and Pencil Line Texture on
page 42.

Pencil Line Texture
You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture
on page 42

Draw Behind

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.
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Auto-Flatten Mode
When drawing on vector layers, lines do not usually become one object. The Auto-Flatten
mode
automatically merges lines created with the existing ones into one single object as you draw.
When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened.
You can no longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a
flattened pencil line to create a nice finish on the lines and corners of your artwork.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.
It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building
mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tips are merge into one single stroke.
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This mode only works with pencil lines.

Auto Adjust Thickness

The Auto Adjust Thickness
tool is useful when you want to render a portion of a line thicker.
When tracing a drawing on paper, you will often go back to a section of a curve to make it thicker to
add dynamism to the line. Using the Auto Adjust Thickness tool, you can draw highlight strokes over
the section to make thicker. Once you release the pen or mouse, the line becomes thicker following
the shape and curve of the original stroke. This way is much faster and smoother than using the
Pencil Editor tool. You do not have to add extra points and adjust the position and Bezier handles.
The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the Auto Adjust Thickness

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Line Pushing Mode
The Line Pushing Mode
option lets you draw highlight strokes over existing pencil lines. You can
reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted
section will be reshaped in one direction or the other.
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The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

To change the Line Pushing Mode colour
1. In the Tools toolbar, select the Pencil

tool.
2. In the Tool Properties view, select the Line Pushing Mode

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Brush Tool Options
When you select the Brush

tool, its properties and options appear in the Tool Properties view.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you
can reuse for repeated tasks. You can create as many brush presets as you need—see Drawing with
the Brush Tool on page 46.

Draw Behind

When the Draw Behind
already exists.

mode is enabled, the lines you draw will appear behind the art that

Repaint Brush Mode

The Repaint Brush
is used to repaint zones that have already been painted, it will not affect
empty zones or pencil lines. It also automatically flattens each of its brush lines so it does not add
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new brush lines on top of existing ones. You can use this mode to paint tones or highlights onto your
character.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes
and pencil lines will flatten with pencil lines.

Respect Protected Colour
The Respect Protected Colour
option prevent the colours you marked as protected in the
Colour view to be repainted using the Repaint Brush mode or any of the painting tools.

Use Stored Colour Gradient
The Use Stored Colour Gradient
option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Select Tool Options
When you choose the Select

tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso

and Marquee
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•

Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
You can enable different snapping modes to help you when repositioning drawings using the Select
tool.
•

Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you
move it close enough to another line, your point or selection will snap to it.

•

Snap and Align: Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.
Snap to Grid: Snaps your selection following the currently enabled grid.

•

How to snap to grid
1. Do one of the following:
•

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press
Ctrl + ' (Windows/Linux) or ⌘ + ' (Mac OS X).

•

Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.
tool or press Alt + Q.

2. In the Tools toolbar, select the Contour Editor

3. In the Contour Editor Tool Properties view, click the Snap to Grid

button.

4. In the Camera or Drawing view, click on the anchor point you want to snap following the grid,
drag it to the desired position and release.
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Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same
colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour

button.

3. In the Camera view, click on any zone in your drawing.
All zones of the same colour are selected.
4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection
option lets you maintain a selection over multiple drawings. Once this
option is enabled, the selection zone made using the Select tool will remain as you navigate through
drawings from a layer and drawings from other drawing layers. This option can be used to
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simultaneously delete artwork inside or outside of the selection on several drawings when combined
with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer

The Apply to All Drawings in Layer
option is used to perform an action on all the drawings
contained in a layer. For example, you could enable the option to paint a section on all the drawings
simultaneously. The Apply Tool to All Drawings option must be activated before performing the
action and will stay enabled only for the next action.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Works on Single Drawing

By default, when you draw a selection box in the Camera view, the Select tool will select only the
drawing strokes of the current drawing. If you prefer the Select tool to select all the strokes on all
layers, you can disable the Works on Single Drawing option in the Tool Properties view or the Select
Tool Works on Single Drawing preference.
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Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.
Flatten
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The Flatten
operation is used to merge drawing objects and brush strokes into a single layer. If
you draw new lines to fix a drawing or line with many brush strokes, it can be useful to flatten them
all into a single shape. By default, lines are drawn one on top of each other. If you intend to repaint
the lines or modify their shape, it will be easier if they are flattened.

‣ From the top menu, select Drawing > Optimize > Flatten or pres Alt + Shift + F.
Create Colour Art from Line Art
You can use the outline you traced on one of the four embedded layers and create invisible strokes
to paint your drawings on separate layers. This provides more inking and painting flexibility.
You can also configure the option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones out of the Line Art content
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Camera or Drawing view, select the artwork to transfer to the Colour Art.
3. In the Drawing View toolbar, click the Create Colour Art from Line Art button or press *.

How to configure the Create Colour Art from Line Art option
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, Shift + click the Create Colour Art from Line Art

button.

The Configure Line Art to Colour Art dialog box opens.

Parameter

Description

Use rendered version of the
drawing

Renders the drawing and vectorize it to calculate the position of the
centreline that will produce the colour art stroke.

Maximum Resolution for
rendered image

The size of the rendered image.

Threshold for rendered image The value of grey processed to create the rendered vectorized arts.
Fitting error for rendered Bez- This value represents how precise the fitting of the colour art zone in
iers
relation to the line art will be.
Source layer

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay)
you want the colour art to be created from.
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Lets you select the layer (Line Art, Colour Art, Underlay or Overlay)
you want the colour art to be created on.

Destination layer
Clear Destination Art Layer
First

Deletes the content before the colour art is added. This is
useful when you already have artwork on the destination
layer.

Perform Line Art to Colour
Art Operation Immediately

Performs the Create Colour Art from Line Art command when you
click OK.

Distribute to Layers
option is used to separate the selected art strokes and send them to
The Distribute to Layers
new drawing layers. In the Camera view, once you have drawn your artwork, you can select the
strokes you want to distribute using the Select
tool and click on the Distribute to Layers
button; you can also select Drawing > Distribute to Layers. It will automatically take every stroke
from the drawing selection made in the Camera view and separate them into a different layer for
each. If an artwork is composed of several strokes, you must group them using Edit > Group >
Group before using the Distribute to Layers option. This option cannot be done from the Drawing
view.

Store Colour Gradient
Use the Store Colour Gradient
operation to record the selected gradient’s position. This reuses
the stored position of the gradient when drawing new brush lines or painting colour zones. Enable
the Use Stored Colour Gradient
option in the Paint or Brush Tool Properties view to do this.

Pencil to Brush

The Pencil to Brush
strokes brush lines.

operation converts the selected centre line pencil strokes into contour

From the top menu, select Drawing > Convert > Pencil Lines to Brush or press &.
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Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines
option. The ends of your lines
are adjusted to form one single line.

Points must be close enough to be merged. If there is a large gap between the lines, they will not be
merged.

Reverse Pencil Thickness

The Reverse Pencil Thickness
option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.
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Width and Height
Use the Width and Height operation fields to enter specific values to resize the selected shape with
precision.

1. Width: Type a value in this field to resize the width of your selection.
2. Height: Type a value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or Height fields.
4. Lock icon: Click the lock icon to lock or unlock the ratio between the Width and Height values.

Offset X and Y
Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the
selected shape.

1. X: Type a value in this field to reposition your selection along the X-axis.
2. Y: Type a value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.

Angle
The Angle operation lets you to enter specific values and accurately rotate the selected shape.

1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

Adjusting the Pencil Line Thickness
Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes.
This operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline
stroke.
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2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline
stroke.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness
value field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils

Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines
even after they are drawn. You can apply preset pencil stencils or create your own—see Working
with Pencil Presets on page 39.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your
own. Textures are independent from pencil stencils—see Pencil Line Texture on page 42.

Adjusting the Text Selection
When you select text with the Select tool, the tool properties will display the Text tool options on
the bottom of the view. You can also press Alt + 9 to display only the Text properties in the Tool
Properties view—see Text Tool Options on page 140.
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Eraser Tool Options
When you select the Eraser

tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.
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Eraser Presets
Eraser presets are created by saving the properties of the current eraser to a new preset, which you
can reuse for repeated tasks. You can create as many eraser presets as you need—see Erasing Parts
of a Drawing on page 74.
The Eraser tool uses its own preset list, separated from the Brush tool. Toon Boom Harmony
provides a variety of eraser styles and allows you to create and save your own. It is a good idea to
create and save eraser with precise sizes and parameters to draw and design.

Eraser Blur Parameters
Since Harmony lets you draw with textured lines and create feathered edges on them, you may also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur
Parameters allow you to adjust the smoothness of your eraser for the textured lines—see How to
erase textured lines on page 56

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Contour Editor Options
When you select the Contour Editor
view.

tool, its properties and options appear in the Tool Properties

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.
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Snap to Contour

The Snap to Contour

option will snap the selected anchor point to any line you position it on.

How to snap two shapes together
1. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap to the other shape,
drag it on top of the contour line area and release it.

Snap and Align

The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align
1. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align

button.

3. In the Camera or Drawing view, click on an anchor point you want to snap, drag it until a ruler is
displayed, position it on the ruler or on the contour line and release.
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Show Contour Editor Controls

Use the Show Contour Editor Controls
option to show the contour editor controls. You can use
these controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Smooth Selection
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.
Split Pencil Line and Join Pencil Lines
When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil
Editor to adjust the thickness point by point, but if you want to adjust it quicker, you can use the
Split Pencil Line and Point Pencil Lines options to create segments and apply a pencil stencil to your
drawing. Note that if you did not join the pencil lines on your polyline stroke, the segments between
the points will act as separated segments.
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How to split and join pencil lines
1. In the Tools toolbar, select the Contour Editor tool.
2. In the Drawing or Camera view, select the contour points you want to split or join.
3. In the Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
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Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
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•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Preset
To work with Pencil line presets, see Working with Pencil Presets on page 39.

Textures
To work with Pencil Line Texture, see Pencil Line Texture on page 42

Smooth
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Drawing> Optimize > Smooth or press Alt + Shift + S.
Pump Pencil Pressure

The Pump Pencil Pressure
pencil line.

option is used to increase the line thickness of a selected area on a

Deflate Pencil Pressure
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The Deflate Pencil Pressure
pencil line.

option is used to decrease the line thickness of a selected area on a

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines
option. The ends of your lines
are adjusted to form one single line.

Reverse Pencil Thickness

The Reverse Pencil Thickness
option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.

Shape Tool Options
When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool
Properties view.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Size
Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
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•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Thickness Stencils
Toon Boom Harmony provides a variety of thickness stencils and also lets you create and save your
own. It is a good idea to create and save pencils with precise sizes and parameters when you draw
and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 39

Draw Behind

When the Draw Behind
already exists.

mode is enabled, the lines you draw will appear behind the art that

Snap Options
When drawing a shape, you can enable different snap modes to help you create your shape.
•

The Snap to Contour

option snaps your shape to any line you position it on.

•

The Snap and Align
option snaps the selected anchor point to any existing line, while
displaying temporary rulers as a guide that you can also snap your anchor point to.

•

The Snap to Grid

snaps your shape to the currently enabled grid.
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Automatic Filling

Use the Automatic Filling
option to automatically fill your shape with the selected colour as you
draw. By default, the Shape tool creates the contour of an empty shape that you can later fill using
the Paint tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes
and pencil lines will flatten with pencil lines.
Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil
line. This creates a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When enabled, the Auto-Close Gap
mode automatically connects, with an invisible stroke, the
pencil lines you draw close to each other in the Camera or Drawing view.

It is recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient
The Use Stored Colour Gradient
option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Line Building Mode

The Line Building
mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

This mode only works with pencil lines.
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Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw
Square option appears. When selecting these options, the shape produced will be a circle or square.
Holding down the Shift key as you create your shape will maintain proportion.

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Size
The Size parameter lets you set the size of the polyline that you will draw.
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Thickness Stencils
Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 39

Snap to Contour
The Snap to Contour

option will snap your selection to any line you position it on.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes
and pencil lines will flatten with pencil lines.

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines
Enable the Draw Stroke as Straight Lines

option if you want the new strokes you draw to be a
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perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends
Enable the Connect Line Ends
option if you want the start or end point of your new stroke to
connect to your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawing or Camera view. Brush strokes will flatten with brush strokes
and pencil lines will flatten with pencil lines.

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother line with fewer control
points. Use the left and right arrows to increment the value by one full unit. Use the Up - Down slider
to quickly increment the value.

Perspective Tool Options
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
•

The Snap to Contour
option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 119.

•

The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—see Contour
Editor Options on page 119.

•

The Snap to Grid

option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.
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Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Envelope Tool Options
Selecting the Envelope tool displays its properties and options in the Tool Properties view.
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Width and Height
Increase the width and height values to add more columns and rows to the deformation grids.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
•

The Snap to Contour
option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 119.

•

The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—see Contour
Editor Options on page 119.

•

The Snap to Grid

option snaps your selection according to the currently enabled grid.

Show Advanced Controls
To display more controls,you can click on the Show Advanced Controls
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Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW
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The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smooths
the deformed lines. Increasing the value will result in a smoother line with fewer control points. The
more you increase the value, the less details and curves you will get. Use the left and right arrows to
increment the value by one full unit. Use the Up - Down slider to quickly increment the value.

Cutter Tool Options
When you select the Cutter

tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Use Mouse Gesture
When using the Lasso
selection type, the Use Mouse Gesture
option lets you automatically
delete any extra sections of line in your artwork by simply dragging your mouse over it.

For this operation to work, you lines CANNOT be flattened.
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Use Mouse Gesture Breaker Mode
When using the Lasso
selection type, the Use Mouse Gesture Breaker Mode
option lets you
draw an invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with
this option, you will be able to select the two portions independently with either the Cutter tool,
Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be
smooth, a slight amount of antialiasing is used. When using the Cutter tool, you can cut a portion of
your drawing with or without antialiasing. By default, the option is enabled. If you want to cut your
drawing using a hard edge, you can select the Antialiasing Off option.
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Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Drawing > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Drawing > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties
view.

Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing
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stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or Lasso.
Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen
grab clarity.

Show Control Points
The Show Control Points
option allows you to show or hide the Bezier points around lines.
When the Bezier points are displayed, you can see the result of your smoothing and the number of
points left on the curve. When it is turned off, only the original artwork is displayed.

Minimum Size and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
This options is available while using the Brush Smoothing

style.

‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

•

Up/Down arrows: Use the up and down arrows to set the minimum and maximum size value.

Smoothness
The Smoothness
impacts the strength of the smoothing result. The higher the value, the more
points are removed and the smoother the curve. The Smoothness range is from 0 to 100; the default
value is 20.
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Drawing Tool References

Colour
You can modify the colour of the control points displayed on the artwork while working with the
Smooth Editor tool by double-clicking on the colour swatch.

Text Tool Options
Use the Text tool's properties to select the font type and other formatting options you want to apply
to the text.
If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type
Use the Font drop-down menu to select a font. OTF fonts are supported.
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Font Style
Use these buttons to select a style for your text:
•

Bold

•

Italic

Alignment
Use these buttons to align the paragraph.
Left

Centered

Right

Justified

Font Size
Enter a size for the text.
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Drawing Tool References

Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto
Kern option to set the kerning automatically based on the font’s predefined standard. A negative
value decreases spacing between each character, creating a letter overlap and a positive value
increases it.

Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A
positive value sets the first line of your paragraph farther to the right and a negative value sets it
farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text
tool and moving the anchor
point right or left. Using the Select tool will distort and scale your text itself rather than changing the
width and height of your text box.
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Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text
so each character becomes an individual drawing object that you can select and modify
independently.

How to break a text object
1. In the Tools toolbar, click the Select

tool or press Alt + S.

2. In the Drawing or Camera view, select the text object you want to break.

3. From the top menu, select Drawing > Convert > Break ApartText Layers.
‣

From the Drawing or Camera view menu, select Drawing > Convert > Break ApartText
Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects
that you can edit.
4. If you want to convert your independent letter to a complete vector object that you can deform,
use the Select tool to select the letters to convert.
5. From the top menu, select Drawing > Convert > Break Apart Text Layers to break the
selection into a regular drawing object, with no more text attributes.
‣

From the Drawing or Camera view menu, select Drawing > Convert > Break Apart Text
Layers to break the selection into a regular drawing object, with no more text attributes.
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Drawing Tool References

Drawing Pivot Tool
tool lets you set the pivots on your character. You can set the drawing pivots
The Drawing Pivot
on drawings and symbols.

Setting the Drawing Pivot for Symbos on All Frames
The Set the Pivot for Symbol on All Frames
option is enabled by default. When you set a drawing
pivot on a symbol, all of its cells use the same drawing pivot. This means you do not have to set a
drawing pivot on all frames. Once you set it, it is done.
If you prefer to set a different drawing pivot for a series of cells, you can deselect the option and set
your pivots on each cell or cell range.

If you have already set several different pivots on your symbol's cells and selected the Set the Pivot for
Symbol on All Frames option, once you set a new pivot on the same symbol, all of its pivots will be reset
and will use your new pivot.

Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing
pivot is released, it either snaps to the reference grid, drawing's contour, or aligns with an existing
drawing stroke.

Reset Pivot
When you click the Reset Pivot
option, the drawing pivot of the selected drawing or symbol is
reset to the centre of the Camera view.

Copying Pivot on Parent Symbol
When you import new extra drawings, such as hands and mouths, you can use the drawing pivot that
was set on your drawings and report them to the symbol's cells. Use the Copy Pivot to Parent
Symbol
command for this.

When you copy drawing pivots to the parent symbol, there is no link between the drawings' pivots and the
symbol's pivots. If you modify the drawing pivot later, it will not link to the symbol. You would need to
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perform the operation again. If you need to modify the symbol's pivots, you can do it directly on the
symbol's cells.
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Chapter 3: Colour Styling and Colour Models

Once the characters, props and locations are designed, it is time for the colour styling and colour
models creation. This is when the colours and moods are determined. The line models created during
the design step are painted and organized as colour models for the colourists.
Harmony has a great concept of colour palettes. Each character can have its own set of colours that is
carried through the entire project called the master palette. If the master is modified, the colours in
the entire project are updated simultanously.
By doing the colour styling in Harmony, your master palette will be created at the same time, so you
do not need to use third party software. Also you will not have to recreate the colour palette again in
Harmony. It is possible to create this step in an external software, but it is a great time saver to do it
directly in Harmony.
To create the colour style and colour models, follow these steps:
•

Preparation on the next page

•

Working with Palettes on page 153

•

Colours on page 170

•

Painting the Model on page 182

•

Sharing the Colour Model on page 184
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Preparation
Before painting, you need to organize the colour model scenes and bring in your references. The
colour styling preparation is done in five steps:
•

Colour Model Storage below

•

Scene Creation below

•

Setting Up the Workspace on the facing page

•

Naming on page 150

Colour Model Storage
First, you will need to create a storage location for all your models and palettes. The best way to do
this is to create a colour model scene. There are different possibilities available to structure your
designs and colour model scenes. We strongly recommend that you put all of your colour models in
the same scenes. It is important to maintain a structure for your models so they do not end up
scattered throughout the project.
There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the
characters, props, effects, and locations in the same scene. For large projects such as feature-length
productions or series, you should create four separate model scenes following these categories.

Scene Creation
In order to create colour models, you need to create your scenes.
When working on a paperless or cut-out animation project, if you have designed your characters,
props, effects and locations directly in Harmony, you can paint your models directly in your design
scene. You can also create a new colour model scene and import your designs in that one. Refer to the
Fundamentals Guide to learn more about creating a scene.
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If you have not already done so, refer to the Fundamentals Guide to learn about production structure,
file organization, and how to create a Project root directory. We recommend storing your colour
model scenes in the root directory or in a colour models subdirectory for even better organization.
A useful way to name your colour model scene is to include the project name, then the colour model
type such as characters, props, effects, or locations, and finally colourmodel. For example, a
character colour model scene for the Adventure project would be named adventure_characters_
colourmodel. This ensures that you always know what scene corresponds to what.

Colour Model Scene Structure
To store your colour models in a scene, it is recommended that you create one drawing layer for each
character, prop, effect, or location. You should name these according to the model.
You can also load other colour references in the scene to balance your overall colours. For example, if
you work in a character colour model scene, it is a good idea to import some of the key locations to
compare and adjust the colours so they match well.

Setting Up the Workspace
Now that your scenes are created and structured, you can open the corresponding colour model
scene. For the optimal workspace for inking and painting, set up your workspace with these views:
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•

Xsheet

•

Camera

•

Drawing

•

Colour

•

Model

Naming
Now that your models are imported, you can rename them appropriately. You should rename
elements (layers) and drawings corresponding to the model. This will help keep the work organized
and make it easy for others to follow.
For example, if there is a black and white character model called Erik in one drawing element and its
colour models in another one, rename your elements to include the character's name. For example,
the colour model for Erik's armour could be named: erik_armour_colour.
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How to rename a drawing element
1. Do one of the following:
‣

In the Xsheet view, double-click on the column header of the drawing element.

‣

In the Timeline view, double-click on the drawing element's layer.

The Layer Properties window opens.

2. Type in a new name.
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How to rename a drawing
1. In the Xsheet view, click on a drawing name.

2. Do one of the following:
‣

From the Xsheet menu, select Drawings > Rename Drawing.

‣

Right-click on the drawing name and select Drawings >Rename Drawing.

‣

Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X).

The Rename Drawing dialog box opens.

3. Type in a new name and click OK.
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Working with Palettes
In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production.
These are referred to as master palettes.
Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production

•

Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing
complete control and consistency in your painting process.
A palette is created by assigning a set of colours to each character, prop or effect. You will create a
new palette and add a new colour, known as a colour swatch, for each zone of the character, such as
the skin, hair, tongue, shirt, pants, and so on.
In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a *.plt
file name extension—see Palette File Storage on page 157.
When a zone on the character is painted with the colour contained in a colour swatch, a link is
automatically created between that colour swatch and the zone. This means that if the tint of the
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way
that colour palettes can save time and money in your production.
Another advantage of this system is that you can create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you could have one for that
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet
another for using in a night scene. Using palettes linked to your character in this way allows you to
instantly change its colouring to suit the mood and atmosphere of the scene without tediously
repainting each element.
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This section is divided as follows:
•

Palette Lists below

•

Palette File Storage on page 157

•

Creating a Colour Palette on page 158

•

Duplicating a Colour Palette on page 162

•

Cloning a Colour Palette on page 163

•

Importing and Linking Palettes on page 165

Palette Lists
The Colour view has two modes: basic and advanced.
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•

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony,
you only see the colours available in the Default palette which contains six basic colour swatches
and is automatically named the same as your scene. For simple projects, you can manage with the
default palette, but for movies, series, or shorts it is recommended that you create palettes for
your characters. To create a palette, you have to switch to the Advanced mode of the Colour view
and show the Palette list.

•

Advanced Mode
The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes
for your characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a
palette list. The scene also has a palette list. For example, a drawing layer can use three different
palettes stored in three different locations, while another drawing layer can use two of these palettes
plus another one coming from another scene. The palette list keep track of the locations of the
palettes.
There are two types of palette lists:
•

Scene Palette List
The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless
and traditional animations. A cut-out character will often be divided into 20 to 30 different drawing
elements that use the character’s master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes
linked to this list will appear in every drawing element created in the scene. There is no need to
manually load the palette in each element.
The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only
Scene Palette lists.

•

Element Palette List
In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your
palette at an element’s level. The Element Palette list is mainly used with traditional and paperless
animation. Unlike cut-out animation, all columns (drawing elements) contain different characters,
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props, backgrounds, and effects. The Element Palette list is used when you do not necessarily
want all of the palettes for all of your elements linked in every column.
The palette list is stored in the drawing element’s directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to
access a global palette list, link your palettes to the Scene Palette list.

When you are using several cloned palettes that are related to the same original palette, Toon Boom
Harmony uses the highest palette in the list to determine the colour of the painted zones—see Cloning
a Colour Palette on page 163.

How to show or hide the Palette list
‣

In the Colour view, click the Show/Hide Palette List View
the Palette List area.

The Palette List window opens and displays all your palettes.

How to set the Advanced Palette Lists mode
1. Do one of the following:
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‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the Advanced tab.
3. Select the Advanced Palette Lists option.

4. Click OK.

How to reorder palettes in the Palette list
Do one of the following:
‣

From the Colour View menu, select Palettes > Move Up or Move Down.

‣

In the Palette list, click the Up

and Down

buttons.

Palette File Storage
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a
palette is created from Harmony, it needs to be stored somewhere. By default, the palette file is
stored in the scene directory in a palette-library folder unless you specify a different location. There are
four locations where you can find palette-library folders:

•

Element
The Palette Library folder is stored directly in the drawing Element folder.
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•

Scene
The Palette Library folder is stored directly in the Scene folder.

•

Job
The Palette Library folder is stored in a Job folder contained in the Scene folder.

•

Environment
The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them
on the file structure.
This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s
database has a leveled structure starting from the Environment down to the Element. Its client-server
configuration allows all data, such as palettes and scenes, to be shared between a series of client
machines.

Element Level
Working with Harmony as a stand alone, the Element level is very useful when there are a lot of
different palettes. When a colour model drawing is created, it is stored in its element folder. By
storing the corresponding palette file with the colour model, the colourist can load them both from
the same location. This also creates a more organized structure.

Scene Level
Working with Toon Boom Harmony as a stand alone, a palette file can also be saved at the scene level,
so that all of the palettes from the scene are stored together. The palette naming must be structured
so the colourist or character builders can find the correct one. Saving the palettes at the scene level
makes it very easy to back up the palettes and retrieve their location.
The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that
includes all of the characters, props, effects, and location, the colour palette or model will often be
directly imported to, or created in, the character building scene. Just as with a cut-out character
building scene, each element uses the same palette so it would not be efficient to save the palette
inside one element. Instead, it is saved at the scene level. This prevents a palette overload because all
of the models are in different scenes. It also allows each scene to have its own set of palettes
corresponding to its model.
When working on a cut-out animation production, it is highly recommended that you work with the
Scene level.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though
the palettes are locked by default. That is why it is a good idea to copy and back up your palette
libraries and master palette directories.
When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette
You can create a palette in either Basic or Advanced mode.
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By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended
to use the Basic mode. This setting stores the palettes automatically for you and saves them at the
Scene level. When you use the Advanced Palette Lists mode, you can decide at which level you want to
store your palettes: Environment, Job, Scene, or Element.
Before you can create a palette in the Advanced Palette Lists mode, you must first set your
preferences to Advanced Palette Lists mode in the Preferences dialog box.
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette
file will not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode
1. Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the Advanced tab.
3. Select the Advanced Palette Lists option.

4. Click OK.

How to create a new palette (Basic Palette Lists mode)
1. From the Colour View menu, select Palettes > New or click the New Palette

button.

The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click OK.
The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode
1. In the Timeline or Xsheet view, select the drawing that requires a palette.
2. In the Colour view, click the Show Palette List View button to display the palette list.
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3. Do one of the following:
‣

From the Colour view menu, select Palettes > New.

‣

Click the Create Palette

button.

The Palette Browser: Create Palette dialog box opens.

4. Select the level to store the palette file.
‣

Environment: The palette-library folder is stored in the scene's parent environment folder.

‣

Job: The palette-library folder is stored in the scene's parent job folder.

‣

Scene: The palette-library folder is stored directly in the scene folder.

‣

Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the
Palette field.
5. Name the palette. There is no need to add the suffix "palette" to the name as it is always
recognized as a palette file.

6. Select a Palette List option.

‣

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often
be divided in twenty to thirty different drawing elements that use the character's master
palette.
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The palette list is stored at the scene level instead of the Element directory. This way, all
palettes linked to this list will appear in every drawing element created in the scene. There is no
need to manually load the palette in each element.
‣

The Element Palette List is mainly used with traditional and paperless animation. Unlike cutout animation, all columns (drawing elements) contain different characters, props,
backgrounds and effects. The Element Palette List is used because you do not necessarily
want all of the palettes for all of your elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer
to access a global palette list, link your palettes to the Scene Palette List.

7. Click OK.
The new palette appears in the palette list.

How to rename a palette
1. In the Colour view, select the palette to rename.

2. Do one of the following:
‣

Right-click and select Rename.

‣

From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette
1. In the Colour view, select the palette to remove.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Remove.

‣

Right-click on the selected palette and select Remove.

‣

Click the Remove Palette

button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.
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Duplicating a Colour Palette
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but
has a different ID and is independent from the original palette. This ensures that both palettes are
completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all of
the colours. You can change the values and the names afterward without affecting the original palette.
You can also keep some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.

How to duplicate a palette
1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Duplicate.

‣

Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.
3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 157.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.
6. Click OK.
The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are
placed in different lighting conditions and require a different colour shading. The night palette is a
popular choice when a scene or sequence changes from day to night. It can be difficult and timeconsuming to repaint everything and creating two independent palettes can be quite complex. As an
alternative, Toon Boom Harmony provides clone palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same
properties. The colours have the same identification number pointing to the same colour zones, but
they can have different names and RGBA values. Depending on the activated palette (night or day), the
painted drawing will update. So there is no need to repaint the animation, but to create or import a
clone palette (palette style).

How to clone a palette
1. In the Colour view, select a palette to clone.

2. From the Colour View menu, select Palettes > Clone or right-click and select Clone.
The Palette Browser: Clone Palette dialog box opens.
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3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 157.

4. In the New Palette Name field, name the palette. It is recommended that you keep the "-clone" in
the name.
5. Click OK.
The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing
Colours on page 179.
7. From the Colour View menu, select Palettes> Tint Panel or right-click and select Tint Panel.
The Blend/Offset Tint panel opens.

164

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).
9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

You can also modify the colours individually with the Colour Picker window.

Importing and Linking Palettes
Before starting colouring work such as Ink and Paint or even creating new colour models, you may
want to load existing colour palettes to your scene. You can do so by linking colour palettes to your
palette lists.
You may encounter a case where only a colour palette is visible when a layer is selected. If you need
that palette in a second layer, you can link the palette to the second layer's palette list, A good
example would be a scene where there is a character on one layer and its arm is on another. In order
for both layers to access the palette, you must link both Element Palette lists to that palette. If you
palette is linked to the Scene Palette list, it will be accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can
browse for the palette file on your computer and add it to your scene. When the palette is imported in
your scene, the file is copied in the project’s directory. It is not linked to the original file.
With Toon Boom Harmony as a stand-alone application, every scene is local to the machine. This
means that all of the scene’s data is only accessible from that particular scene. Palettes are also local
to the scene; they can be shared between all drawing layers, but not between scenes.
However, you may want to share palettes across a whole project. Harmony offers that possibility. By
default, a palette is an independent file stored in your scene. This file can be copied, moved, or
deleted.
To link a palette throughout an entire project, you need to create a central directory where you can
copy all the palettes you created. Every time you link a palette in an element, it is linked to this folder.
If you modify the palette, it will be updated throughout the whole project.
You will notice that when you create or link a palette, a small icon appears on its left. These icons
represent the palette linkage status.
Icon

Description
Indicates that the palette is safe.
There won’t be any trouble once the scene will be exported. For example,
the palette file is stored in the scene folder and is linked to the Scene Palette
List.
Indicates that the palette file is stored in a directory external to the scene’s
structure.
The palette file is probably stored in a Master Palette directory on a hard
drive external to the palette-libraries planned for the palette storage. The
warning in this case is that if you move your Master Palette directory to
another location, you may loose the palette in your scene.
Indicates that a palette file stored in a level such as Element, Scene, Job or
Environment is linked to a Palette list that is not on the same level.
For example, a palette file is stored into the Environment folder and is linked
to the Element Palette list. The palette is shared.

How to link a colour palette
1. Do one of the following:
‣

From the Colour View menu, select Palettes > Link.

‣

Right-click and select Link.

‣

Click the Import

button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 157.
3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—
see Palette Lists on page 154.
The palette appears in the Colour view.

How to import a palette into your project
4. Do one of the following:
‣

From the Colour View menu, select Palettes > Import.

‣

Right-click and select Import.

The Browser window opens.
5. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in
your project's palette-library directory.
6. Click Open.
The Palette Browser opens.
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7. If you are in Advanced Palette mode, select the level where the palette file is stored—see Palette
File Storage on page 157.
8. If you are in Advanced Palette mode, select the palette list linking level by enabling either Scene
Palette List or Element Palette List—see Palette Lists on page 154.
9. In the New Palette Name, name the imported palette.
The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette
1. In the Colour view, click on the Create Palette
external.

button to create your palette to be used as

2. Save your scene by selecting File > Save from the top menu or by clicking the Save
press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

button or

3. On your computer or server, create a master directory. Ideally, this should be created in your Root
folder to keep it within the project directory. You could also place it inside your Colour Model’s
subdirectory. Refer to the Fundamentals Guide to learn more about project organization.

4. Name the folder appropriately, for example: Joe_master_palette.
5. From your operating system, browse to your Toon Boom Harmony scene and open the palettelibrary folder.

6. Select and copy your palette *.plt file to copy it to the master palette directory.

168

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.
8. In the Timeline or Xsheet view, select the element to link the palette to.

9. From the Colour View menu, select Palettes > Link to External.
The Link to External Palette dialog box opens.

10. Click Browse to search for your master palettes folder and select the palette *.plt file you want
to link.
11. In the Palette list section, select how you want to load the palette; at the scene or element level.
12. Click OK.
The linked palette appears in the Colour view.
If a palette is outside the scene, the External

icon appears beside the palette name.

To link an element (such as a colour model) to the palette that is stored in the external palette directory,
you must remove the original palette from the element’s palette list. You will then load the duplicated
palette into the palette list using the Link to External command, like you did for the other elements.
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Colours
Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint
your drawings, you will use different colour swatches, unlike some other painting programs where you
modify the main swatch each time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your
drawing. You can add as many swatches as you want. You can also rename them and modify existing
ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with
this swatch throughout the entire project. The colour swatch has a unique ID number that associates it
with the painted zones. This way, you can change the look of your character at any time without having
to repaint it!
This section is divided as follows:
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•

Adding a Colour Swatch below

•

Colour Display Modes on page 177

•

Copying and Pasting Colours on page 178

•

Mixing Colours on page 179

Adding a Colour Swatch
You can use several different types of colour swatches.

In Toon Boom Harmony, when you click on the Add Colour
button, a new colour swatch is created
using the colour of the currently selected swatch from your palette. However, you can set a default
colour to be used every time you create a new colour in your colour palette. This might be useful if you
want to create different shades of the same basic colour.
The default colour is also the colour used when you choose to vectorize images that you are scanning
into your scene, however you add the Default colour swatch to your palette in a different way, so that
it is unique. It has a unique ID number that makes it recognizable from all the other colours in your
colour palettes. Being able to change this colour allows you to change the basic colour of all scanned
drawings. This can be useful on more than just an aesthetic level as sometimes when you go to NTSC
or PAL, pure colours, such as pure black, can create problems.

How to add or modify a solid colour swatch
1. In the Colour view, click the New Colour

button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.
The Colour Picker window opens.

171

Chapter 3: Colour Styling and Colour Models Colours

3. To set your colour, do one of the following:
‣

In the colour wheel, select a colour.

‣

Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣

Click the Dropper
button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.

How to change the default swatch colour for all your colour palettes
1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X).
2. In the Preferences dialog box, select the Drawing tab.
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3. In the New Colour Pots section, select the Create New Colour Pot Using the Default Colour
option. You can also click on the colour swatch beside the option to change the Default colour.

How to add a new colour swatch using the default colour
‣

From the Colour View menu, select Colours > New.

A new swatch is added to your palette using the default colour swatch colour. The new swatch
created with the New command will be named New 0.

How to create a gradient colour swatch
1. In the Colour view, select a colour to modify .
2. Do one of the following:
‣

Click the new colour and from the Colour View menu, select Colours > New.

‣

Double-click on the colour swatch.

The Colour Picker window opens.

3. Select the Gradient option.
4. Select the Linear or Radial option.
5. Adjust the Gradient arrows to modify the colours.

‣

Add extra colours by clicking between the arrows below the gradient bar. Then click on the
Colour Preview to select a colour.

‣

Pull down the arrows to remove them.
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‣

Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 1 topic to learn how to reposition the gradient zones
in your drawings.

How to create a texture colour
1. From the Colour View menu, select Colours > New Texture or click the New Texture

button.

The Browser window opens.
2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.
The texture is added to the colour list.

Refer to the Editing Gradients and Textures on page 1 topic to learn how to reposition your textured
zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool
instead of plaid, just update the texture file in the swatch and the entire project updates. Any
transformation previously applied to the texture’s position in your drawings will be kept.
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How to replace a texture swatch
1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.

4. Click Open to update the colour swatch.

How to delete a colour swatch
1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:
‣

From the Colour View menu, select Colours > Delete.

‣

Click the Delete Colour

‣

Right-click and select Delete.

‣

Press Delete.

button.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.
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3. Click OK to delete the colours or click Cancel to abort the operation.
‣

If you delete colour swatches already in use, the zones painted with them turn red so you
can easily identify them.

Colour Display Modes
The Colour view has two display modes:
•

List

•

Swatch

You can alsodisplay the RGB values and names of your solid colour swatches instead of only the name.
This option is not available when displaying the colours in Swatch mode.

How to switch between the display modes
1. From the Colour View menu, and do one of the following:
‣

Select Colours > Swatch Mode to display the swatches.

‣

Deselect Colours > Swatch Mode to display the colour list.
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How to display the swatch colour values
‣ From the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values will be displayed between the colour swatch and its name.
The gradient colour swatches will be identified as (gradient).

Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them
in other palettes to save time. You can also quickly copy a colour value from a palette in your scene to
a selected colour swatch in a different palette.
You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch,
it is impossible to use the Paste as Clone command in the same palette as you copied the original
colour swatch from.
If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can
copy the colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours
1. In the Colour view, select one or more colours to copy.

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C (Mac
OS X).
3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V
(Windows/Linux) or ⌘ + V (Mac OS X).
‣

To paste the colour values of the copied swatch over an existing colour swatch, select
Colours > Paste Colour Values.
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How to clone a colour swatch
1. In the Colour view, select the colour swatch you want to clone.
2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C
(Mac OS X).
3. In the Colour view, select the colour palette you want to paste the clone into or create a new
palette.
4. From the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.

How to copy a colour ID
1. In the Colour view, select the colour swatch you want toget the ID from.
2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux)
or ⌘ + C (Mac OS X).
3. Paste the copied value as plain text in the desired document.

Mixing Colours
If you want to modify a series of colours at once to blend a tint in them or offset their RGBA values, you
can use the Tint panel. This panel is quite useful when creating palette styles such as night and day
styles.

How to mix colours
1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Tint Panel.

‣

Right-click and select Tint Panel.

The Blend/Offset Tint panel opens.
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3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).

4. Select Preview option.
5. Select the Offset, Blend, or Mix option.

Parameter
Offset

Description
Offsets the selected colours by the adjustments made using
the HSB and RGB sliders. Use the Amount slider to adjust the
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degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right
corner. Use the Amount slider to adjust the degree of blend. A blend of
100% turns the selected colours into the same colour as the swatch.
Adjusting the HSB and RGB sliders affect the swatch colour, which in
turn affects the selected colours on the left. Use the Alpha slider to
adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch.
Use the slider just beneath to mix the Base and Tint colours
by different amounts. This will affect the mixed swatch
whether it is selected or not. Select either the Tint or Base
swatch and use the HSB and RGB sliders to adjust its colour.
This will affect the mixed swatch colour, which in turn affects
the selected colours on the left.

6. Click Apply.
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Painting the Model
Now that you have created the colours and the palette, you are ready to paint your model.
The colour model needs to be painted in order to adjust the colours with the other elements in the
production. You can paint your model regardless of the colour RGBA and adjust them later when all
the elements are together.
Once your palette is created and your model is painted, you can import a key background and other
characters using the Import Drawings option or the Library to compare and adjust the palettes—see
Importing Models to learn how to import your background file.

For paperless and cut-out animation, it is a good idea to provide a line-up template with the colour
model to show the scale ratio between the characters, props and backgrounds.

Once your colour model is completed, create a line-up template by pasting one of the production's
main characters, or even just a hand, beside the colour model to show the relative size. This allows the
animator, layout artist, or scene setup artist to retain the correct scaling throughout the entire project
when setting the elements in the scene. You can store your template in the Library.

How to paint a colour model
1. From the Drawing or Camera View menu, select View > Switch to Colour Art/Switch to Line Art
or press L.
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2. Create your master colour palette—see Creating a Colour Palette on page 158
3. Add new colours to the palette—see Adding a Colour Swatch on page 171.
4. Select your Paint Bucket

tool. We recommend the Paint Unpainted

tool.

5. In the Colour view, select the colour you need to paint your drawing.

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that
only closed zones will be painted. If there is a gap in your artwork, you will need to close it in order
to paint it.

7. If you would like to separate your lines and fill zones on separated art layers, see Art Layers on
page 310.
8. Adjust the colours—see Mixing Colours on page 179.
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Sharing the Colour Model
When your colour models are prepared and have been organized in a colour model scene, it is time to
share them. However, since the Harmony scenes are local, the palettes cannot be shared with other
scenes. You must prepare templates from the models and store them in the Library.
The Library is a central repository for all the data which will be reused throughout the production. It
can be accessed from any Harmony scene; if multiple users are connected to the same network, all
machines can access a central library. These models can be shared among all the users to ensure that
everybody has the same set of colours and references.
A template is a set of elements created from a Harmony scene that can be imported into other scenes.
It can contain drawings, palettes, and any other elements available in Harmony.
A colour model template is very simple to make. When a drawing is stored in the Library, the
corresponding palette is attached to it. This means that whenever the colour model is imported from
the Library into the scene, the palette is also imported. To learn more about libraries and templates—
see the Harmony Cut-Out Animation Guide.

It is recommended that you add a colour model subfolder to your library.

There are two ways to create In the Timeline view, you can create a template by selecting the drawing
element's module. This contains all drawings from the drawing element, palettes, and exposure. A
template that has been created by selecting the drawing exposure contains the selected drawings,
their exposures, and the palettes.

How to create a template from the Timeline view
1. In the Library, select a folder to store the template. Right-click and select Right to Modify.
2. From the Timeline view, select the drawings, pegs, effects, keyframes, sounds, exposures, and
modules, and drag them to the Library's folder. Anything that is available in the Timeline view can
be stored as a template.

The Rename window opens.

3. Type in a name for the template and click OK.
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There is no need to save the library. Everything is automatically stored and saved as soon as it is
pasted in the library.
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Chapter 4: Painting the Background

Not only does Toon Boom Harmony give you the ability to animate and composite, you can also use it
to paint your backgrounds. You can use solid, gradient or textured colours to create vector-based
and bitmap colouring.
If you create multiplane moves, a vector background will generally be lighter and will allow extreme
truck-ins.
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The background painting process consists of painting the black and white production backgrounds,
also known as background layouts. For traditional animation, the background layouts are usually
drawn on paper and then scanned in. For paperless and cut-out animation, the background layouts
can either be drawn on paper or designed directly in Harmony.
This chapter is divided as follows:
•

Preparation on the facing page

•

Importing the Background Layout on page 191

•

Importing Palettes and Models on page 193

•

Painting the Background on page 197
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Preparation
Before you begin painting, prepare by organizing your work and bringing in your references.

Setting the Scene
Once you chose your technique, it is time to open or create your scene and get ready to import your
background layouts.

Working Directly in the Production Scenes
You can decide to import the background layout directly in the corresponding production scene
and paint it there. This way, the background exists only in the production scene and not in a central
storage scene, saving space on the hard disc drive and avoiding duplicate files.

Working in a Special Background Scene
You can decide to create a new scene, import all your background layouts and paint them in that
scene. This scene will become the colour background storage scene.
It is useful to keep all the backgrounds in the same scene to compare the style and colours, use the
same master palette, and keep track of the work and all existing backgrounds.
We recommend that you store this scene in the project root folder.

Using the Workspace
While inking and painting, you can use the Workspace Manager to save a frequently used layout and
name it Ink and Paint, for example.
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Importing the Background Layout

When the background painting or production scene is ready, import your background layout in it.
Designing your backgrounds and locations directly in Harmony can be a time saver and allows you to
keep all your project materials in the same software.

Refer to Chapter 2: Import in the Compositing Guide to learn how to import bitmap images and the Scan
Guide to learn how to scan the layout.

Importing a Bitmap Layout
If your background layout was drawn on paper and scanned in a third-party software or simply
drawn in a bitmap third-party software, you can import them using the Import Drawings command.

Scanning the Layout from a TWAIN Device
If your models were drawn on paper, you can also scan and import them using a TWAIN Device.

Importing a Toon Boom Harmony Vector-Based Layout
If the background layout was designed in Harmony, it can be imported into the scene through the
Library view. To do so, create a template out of the main background layout and then import it in
the scene.

Importing the Template in the Background Painting Scene
Once the template is created, you are ready to import it into your background painting scene. Drag
the template to import it.
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There is no need to obtain the right to modify the library to import a template.
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Importing Palettes and Models

In order to paint your background, you have to load the location colour model and its corresponding
palettes. Prior to the painting process, the colour stylist creates the palettes and models and stores
them in colour model templates and colour model scenes—see Colour Styling and Colour Models on
page 147.
Once your background layout is imported, you can start painting it. If you already created the location
colour model in Harmony, you can load the required palette. If not, see Working with Palettes on
page 153 to learn how to create a colour palette.

Importing a Colour Model Template
A good method of importing a palette is to import a template from the template library that contains
the location colour model and master palette. This template should be created when you are creating
your colour styling and colour model for your project. If you did not create any colour models, you can
create your colour palette directly in the scene.
Once the templates are created, you are ready to import them in your scene. Import the templates
from the template library to make the models and their palettes available in your scene. Then you will
be able to load the palettes in the corresponding drawing element and the colour models to the
Model View.

There is no need to obtain the right to modify the library to import a template.
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How to import a template
1. Open the scene to ink and paint.

2. In the Library view, browse to the colour model storage folder.

3. Select the corresponding colour model template.

4. Drag the selection to the Network or Timeline view.
‣

If you drop the selection in the Timeline's left side, new elements and modules are created.

‣

If you drop the selection in the Timeline's right side, the information is inserted into existing
elements. In order for the template to combine with existing elements, the structure needs
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to be consistent. If it is not possible to merge the elements together, move on to the
Timeline's left side to create new elements.

When you import a template in a scene, there is no link between the library and the scene. Instead,
a copy of all drawings, effects, trajectories, and so on is created. This means that you are free to
modify anything copied to your scene without affecting the original.

Loading Palettes and Models
Importing the colour model template in your scene creates a new drawing element. Importing also
updates the master palettes; these palettes are now local to the scene.
If you are painting a drawing sequence, you can refer to the visual model to know where colours go,
especially if the palette uses many colour swatches. Use the Model view to load the colour model so
you can see it at the same time as you paint.

How to load your current drawing in the Model view
1. In the Timeline or Xsheet View, select the desired colour model drawing.

2. From the Model View menu, select Model > Use Current Drawing As Model.
The colour model is loaded in the Model View.
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Once your model is loaded, you can import palettes in your drawing element.

How to add a palette to your element
1. In the Xsheet or Timeline view, select the drawing element in which you want to load the palette.

2. Do one of the following:
‣

In the Colour view menu, select Palettes >Link.

‣

In the Colour view toolbar, click the Link Palette

button.

The Palette Browser window opens.
3. Select the location where the palette file is stored; it is usually at the Scene or Element level.
4. If you are working in Advanced Palette List mode, decide how you want the palette loaded: as a
Scene or Element palette list.

5. Click OK.
In the Colour view of the drawing element, the palette appears in the palette list.
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Painting the Background

Now that your background layout, master palette and location colour model are imported in your
scene, you are ready to paint your background.
A Harmonydrawing is composed of several art layers. Lines and colours can be separated or joined,
depending on the animation process. When a traditional drawing is scanned in, strokes are
automatically created in the Colour Art from the Line Art. For paperless drawings, once the drawing
sequence is completed, create your Colour Art strokes if you plan to paint your animation in the
Colour Art layer. Use the Create Colour Art from Line Art option to create strokes from your lines—
see Art Layers on page 310.

How to create strokes once the drawing is completed
You may prefer to create strokes once the drawing is cleaned up. In this case, select the full drawing
and create the strokes in Colour Art.
1. Skip this step if you are creating strokes for a single drawing. Do one of the following:
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‣

In the Select Tool Properties view, click the Permanent Selection

‣

PressCtrl + Shift + P (Windows/Linux) or ⌘ + Shift + P (Mac OS X).

tool.

2. Do one of the following:
‣

In the Drawing Tools toolbar, click the Select

‣

Press Alt + S.

tool.

3. Select the entire animation sequence.
4. Do one of the following:
‣

In the Drawing or Camera view, select Drawing > Create Colour Art from Line Art.

‣

Press *

5. Repeat steps 1 to 4 for each drawing in the animation sequence.

How to create strokes while drawing in Line Art mode
If you have some traditional drawings that need to be fixed, for example, need extra lines to patch
gaps, the strokes can be created in the Colour Art layer at the same time as the lines are drawn using
the Auto-Create Colour Art from Brush feature. This feature creates strokes from the lines and brush
strokes created in the Line Art layer as you draw.
You can use it to fix drawings, but if you draw a sketch from scratch it is better to create the strokes
afterward using the Create Colour Art from Line Art option.
1. Do one of the following:
‣

In the Drawing or Camera View toolbar, click the Automatically Create Colour Art from
Brush
button. You may have to customize the toolbar to display it.

‣

When the Brush, Pencil or any shape tool is enabled, in the Tool Properties editor, click the
Automatically Create Colour Art from Brush
button.

2. Draw the extra lines required.
3. Once you are done, deselect the Automatically Create Colour Art option.
You are now ready to paint your background.

How to paint your background
1. Do one of the following:
‣

In the Camera or Drawing view, switch to the Line Art or Colour Art to paint your model.

‣

Press L.
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2. Select one of the Paint Bucket

tools. The Paint Unpainted

tool is recommended.

3. Paint the background by selecting the colours from the colour model or the palette, and clicking on
the different drawing zones.

How to use the Stroke tool to create tone and highlight zones
You can use the Stroke
tool to draw invisible vector strokes and separate some of the drawing
sections to create tone and highlight zones.
1. Do one of the following:
‣

In the Camera view or Drawing view menu, select Drawing Tools > Stroke.

‣

Press Alt + V.

2. Do one of the following:
‣

In the Camera view or Drawing view menu, select View > Show Strokes.

‣

Press K.

The strokes appear.
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3. Draw the stroke on the background drawing.

4. In your colour palette, select the colour needed to paint the new zone.

5. In the Tools toolbar, click the Repaint

button.

6. Do one of the following:
‣

In the Drawing or Camera View toolbar, select View > > Show Strokes to hide the strokes.

‣

Press K.
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How to use gradient colour
Using a gradient colour adds more depth and variation to your drawings.

1. In the Colour view, select the colour to be modified.

2. Do one of the following:
‣

In the Colour view menu, select Colour > Edit Colour.

‣

Double-click on the colour swatch.

The Colour Picker window opens.

3. Select the Gradient option.

4. Select the Linear or Radial option.
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5. Select the Gradient arrows to modify the colours.

‣

Click between the arrows to add extra colours.

‣

Pull down the arrows to remove them.

‣

Move the arrows left and right to modify the gradient distance.

6. Use the Edit Gradient/Texture tool to set your gradient's position.

How to use the Edit Gradient and Texture tool
1. Do one of the following:
‣

In the Camera view or Drawing view menu, select Drawing Tools > Edit
Gradient/Texture.

‣

Press Shift + F3.

2. Click on the gradient or texture colour to be modified.
The Edit Gradient/Texture selection frame appears.

3. Move the edit texture's parameters to the desired result.
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4. If the same modification needs to be applied to another gradient or texture zone, do one of the
following:
‣

Select the modified zone and select Edit > Copy.

‣

Press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).

5. Select the zone you want to modify.
6. Do one of the following:
‣

From the top menu, select Edit > Paste.

‣

Press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).
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Chapter 8: Timing

When you create hand-drawn animation traditionally or in a paperless environment, it is important to
know how to set and modify the timing of your drawings.
In a traditional workflow, the person in charge of the digital exposure sheet reproduces the paper
exposure sheet created by the animator. In a paperless workflow, the animator creates and manages
his own exposure sheet directly in Harmony without the need for reproduction.
If you are more of a traditional animator, you are more likely to work with an exposure sheet. If you are
a digital animator, you may prefer to work with a timeline to visualize your timing. Harmony offers
both.
The Xsheet view displays the digital reproduction of a traditional paper exposure sheet used in handdrawn animation. You can set the animation sequence's exposure and name the drawings.
The Timeline view is also used to visualize timing, and represents elements and groups of elements as
layers.
You can adjust timing in both views; your choice depends on which technique you are used to working
with. Depending on your working style, some actions may seem preferable to do in one view instead
of another. Many of the actions you perform in the Xsheet can also be accomplished in the Timeline.
This chapter will often show both techniques. You will be able to choose which one you prefer.
In this topic, you will learn how to work on your drawing’s exposure and length. The exposure and
animation paths for symbols are covered in separate chapters.

The exposure sheet is not mandatory for Cut-out animation. It can be useful for creating characters and
parts, but is not really needed for animation and timing. If you plan to work with Cut-out animation, you can
still gain useful tips by reviewing the section on exposure sheets.

The basic digital exposure sheet process is divided into the following steps:
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•

Preparation on the facing page

•

Frames on page 209

•

Filling Exposure on page 235

•

Managing Drawings on page 257

•

Modifying the Layer and Column Display on page 264

•

Printing the Xsheet on page 280
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Preparation
The digital exposure task is quite simple. There are very few things to prepare in order to get ready.

Opening the Scene
The scene is generally created during a previous step such as scanning (in a traditional animation
workflow), scene setup, digital layout, or production organization.

Using the Workspace
The person creating the exposure sheet will need only the Xsheet view to create the digital exposure
sheet, although the Timeline view may also be helpful. If you are doing paperless animation, use the
Camera or Drawing view if you want to sketch at the same time.
If you work with this layout often, you can use the Workspace Manager to save it as a
workspace,and name it Xsheet, for example.

While drawing and animating paperless animation, you can use the Workspace Manager to save a
frequently used layout and name it Paperless Animation, for example.
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Preparing References

To start an exposure sheet, you need to prepare your references. For traditional animation, you will
need to reproduce the animator's paper exposure sheet. If you are working remotely, the studio can
scan the paper exposure sheet using third-party software and send the digital files to be opened and
viewed digitally.
In paperless animation, you will usually create an exposure sheet from the Xsheet view.The
information from your layout and posing or storyboard will help you approximate how many
elements are required in the scene.
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Frames
Once the references are ready, you need to set the scene length by adding the right number of frames
to your scene. You can set the global scene length from the top menu.
In the Xsheet and Timeline view, you can add and remove frames from a scene to edit its length.

How to set the scene length
1. From the top menu, select Scene > Scene Length.
The Set Scene Length dialog box opens.

2. In the Number of Frames field, enter the number of frames needed.

How to extend a scene in the Timeline view
1. In the Timeline view, drag the scene length bracket to the right to add more frames to your scene.

How to add frames before or after a selection to the extend scene length in the
Xsheet view
You can add frames anywhere in the middle of the scene. If you select a frame row in the Xsheet view,
Harmony will add the new frames before or after the selection, depending on your choice.
1. In the Xsheet view, select a frame row.

2. Do one of the following:
‣

From the top menu, select Scene >Frame > Add Frames Before Selection or Add
Frames After Selection.

‣

In the Xsheet view, right-click and select Frames > Add Frames Before Selection or Add
Frames After Selection.
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‣

In the Xsheet view toolbar, click the Add Frames
selection.

‣

Press Ctrl + G and Ctrl + H (Windows/Linux) or ⌘ + G and Ctrl + H (Mac OS X).

button to add frame after your

The Add Frames dialog box opens.

3. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to add frames at the start or end to extend the scene length from the top menu
1. From the top menu, select Scene > Frame > Add Frames At Start or Add Frames At End.
‣

In the Xsheet view toolbar, press the Add Frames
selection.

button to add frame after your

The Add Frames dialog box opens.

2. In the Number of Frames to Add field, enter the number of frames needed in the scene.

How to reduce the scene length in the Timeline view
When you remove frames at the end of a scene to reduce the scene length in the Timeline view, the
exposed drawings and symbols are not deleted. They are still available if you extend the scene
afterwards.
1. In the Timeline view, drag the scene length bracket to the left to remove frames from the scene.

How to remove a frame or a range of frames to reduce the scene length in the
Xsheet view
In the Xsheet view, you can remove any selected frame range, such as the last frame.
1. In the Xsheet view, do one of the following:
‣

Select a frame in a given column.

‣

Select a frame range by clicking the first frame’s number and then dragging the selection
highlight down to the last frame to delete.
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2. To delete the selected frames, do one of the following:
‣

From the top menu, select Scene > Frame > Remove Selected Frames.

‣

Press Delete to delete the selection.

‣

Click Remove Frames
repeatedly.

button. To remove several frame selections, click the button

If you selected a range of frames, the Warning dialog box may open.

3. To complete the operation:
‣

Click Yes to delete the selection.

‣

Click No to delete only the exposure in the cell and not the frames.

‣

Select the Don’t Show This Message Again option to prevent the warning message from
being displayed each time you delete a frame range.
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Creating Drawing Elements
Before filling any value or setting any timing or exposure, you need to add different drawing elements.
Each drawing element is represented as a vertical element column in the Xsheet view and a horizontal
element layer in the Timeline view.
In Harmony, whether you work in the Timeline or Xsheet view, any modification you do to one view will
be applied to both. You can also see your layers displayed in the Network view as modules.
To start an exposure sheet, you will use drawing elements. Drawing elements are drawing containers.
Any image file, either bitmap or vector, will use a drawing element.
When you add a drawing element to your scene, a folder is added to the scene directory. This folder is
named the same way as the drawing element. Its purpose is to contain all the drawings related to this
element. For example, in cut-out animation, a character can have many heads available. All of the head
drawings will be contained in this folder, even if they are not exposed in the Timeline or the Xsheet
view. There is always a drawing container connected to a drawing element (layer, column).

There are different element types available such as Sound and Expression. A sound element will contain
sound files. Expressions, Beziers, Eases, 3D Path, Quadmaps and Pegs are for motion purposes during the
compositing step. It is not necessary to create these types to create your exposure sheet.

You can add drawing elements from the Timeline view, Xsheet view, and the Scene menu.
This section is divided as follows:
•

Layer and Column Concepts below

•

Layer and Column Types on the facing page

•

Adding New Drawing Elements on page 216

•

Deleting Layers and Columns on page 220

•

Layer and Column Properties on page 222

•

Modifying Layers and Columns on page 223

•

Duplicating Layers and Columns on page 226

•

Cloning Layers and Columns on page 226

•

Adding an Annotation Column on page 227

Layer and Column Concepts
A layer is linked to a directory, the location where all its drawings are saved. This directory has the
same name as the layer. When a name is typed in a cell,Harmony searches the layer's directory for the
corresponding drawing to display. If there is no corresponding drawing, a new one is created.
Drawings are exposed in cells, and linked to the drawings saved in the layer's directory. Removing a
drawing from a cell means it is not displayed. It will not be deleted from the directory.
A drawing that is exposed multiple times (for example, in a walk cycle) would be linked to the same
original drawing in the layer's directory. If you modify, repaint, or correct the drawing, all exposed
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drawings with the same name are updated simultaneously. You must duplicate or create a new
drawing to modify a single exposure and retain the others.

When you create a drawing cycle, all of the repeated drawings are linked to the original files. This means that
when you modify, repaint, or correct a drawing named “1,” all drawings named “1” are updated simultaneously.
In order to modify a drawing independently from its other exposures, you must duplicate the drawing.

Layer and Column Types
A column is also known as a layer. There are several types of layers that you can add in the Xsheet and
Timeline view. Each layer is tagged with an icon to help differentiate them. Some layers are
represented differently in the Xsheet view.

Drawing Layer

The most common layer type is the drawing layer. Any time you need to create a vector drawing or
import a symbol or image, you can use a drawing layer. You can also create bitmap artwork on a
drawing layer.

Bitmap images are contained in Bitmap layers.

Bitmap Layer
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If you import a picture or bitmap images in your project, they are inserted in a Bitmap layer. If you
choose to vectorize your image when you import, the bitmap object will be placed on a Drawing
layer. This way, you can have bitmap images mixed with vector drawings on a Drawing layer.
When importing a bitmap image, you have the option of encapsulating the image in a symbol. If you
place a non-vectorized bitmap into a symbol, you will still not be able to mix vector drawings with it
on the same layer. If you place a vectorized bitmap in a symbol, you must enter the symbol to be able
to mix it with vector artwork.

Camera Layer

You can only have one Camera layer at a time in your timeline. By default, there is no Camera layer
when you create a scene. You need to add a Camera layer when you want to create a camera
motion.
The Camera layer is not visible in the Xsheet view.

If you want to have several cameras with different settings, you can keep adding Camera layers in your
Timeline view (however, only one will ever be visible at a time as you can only have one camera at a time
in your timeline). To switch to a different camera, select Scene > Camera and select another camera layer.

Effect Layer

To enhance the look of your scene, you can add effect layers and attach your drawings to them. In
Harmony, there is a series of effect modules in the Module Library view.
When you select the Effect layer in the Timeline view, the effect’s parameter columns are displayed in
the Functions section of the Xsheet view.

Colour-Card Layer

The Colour-Card layer is used to add a plain colour background to a scene. By default, your scene
has no background colour and if you render it as a QuickTime movie or image sequence, it will have a
black background.
This layer is not visible in the Xsheet view.

Group Layer
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A Group layer can be used to organize both the Timeline and Network views. You can drag and drop
other layers onto a Group layer and then collapse the Group layer to hide these other layers from
view.
If you create the Group layer in the Timeline view, a corresponding module will appear in the
Network view. Any layers that you connect to the Group layer will appear in the Group module
connected to an Input and Output port.

Peg Layer

A Peg layer is a trajectory or motion path layer that does not contain drawings. It can be attached to
any drawing layer, cut-out puppet, or other peg layers; they will all follow the trajectory you set in
the Peg layer.
When you select the Peg layer in the Timeline view, the peg’s function columns are displayed in the
Functions section of the Xsheet view.

Quadmap Layer

A Quadmap layer can be described as a deformation transformation layer that does not contain
drawings. This can be attached to any drawing layer, cut-out puppet, or even other peg layers. They
will all follow the deformation you set in the Quadmap layer.
When you select the Quadmap layer in the Timeline view, the Quadmap’s function columns are
displayed in the Functions section of the Xsheet view.

Sound Layer
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You can import sound files to add dialog and sound effects to your project. The sound layer will be
added to your Timeline and Xsheet view when you import a sound file in your scene.
In the Xsheet view, the Sound layer is a dark grey colour.

Advanced Column Types
In the Xsheet view, you can add several advanced column types to create particular animation paths.
When you create these columns, they are not linked automatically to any particular drawing layer. You
can create a motion path using these columns and then link or unlink several drawing or peg layers to
it.
Advanced column types include:
•

Timing

•

3D Path

•

3D Rotation

•

Bezier Curve

•

Ease Curve

•

Expression

•

Annotation

Adding New Drawing Elements
There are different ways to add a drawing layer to your project. By default, when you create a new
scene there is one Drawing column in the Xsheet view and one corresponding Drawing layer in the
Timeline view.
You can add an element for each drawing and it will appear as a column in the Xsheet view, a layer in
the Timeline view, and a module in the Network view.

How to add a drawing element from the Timeline view
1. Do one of the following:
‣

In the Timeline View menu, select Insert > Drawing.

‣

In the Timeline view toolbar, click the Add Layers

‣
‣

Press Ctrl + R (Windows/Linux) or ⌘ + R (Mac OS X).

The Add Drawing Layer dialog box opens.
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2. In the Name field, enter a relevant element name.

3. Do one of the following:
‣

Click OK to add the layer and close the dialog box.

‣

Click Apply to add the layer and keep the dialog box open to add another layer.

‣

Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Network Views.

How to add multiple drawing elements from the Timeline view
1. In the Timeline View menu, select Insert > Add Layer(s).
The Add Layers dialog box opens.

2. In the Type menu, select the Drawing option.
3. In the Number field, enter the number of layers you want to add.
4. In the Name field, type the name of the layer you want to add. If you are adding more than one
layer, a numerical suffix will be added to subsequent layers.
5. Do one of the following:
‣

Click OK to add the layers and close the dialog box.

‣

Click Apply to add the layers and keep the dialog box open to add another layer.

‣

Click Close to cancel the operation.

The new drawing elements appear in the Timeline, Xsheet and Network views.

How to add a drawing element from the top menu
1. From the top menu, select Insert > Drawing.
The Add Drawing Layer dialog box opens.

2. In the Name field, type a relevant element name.
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3. Click OK.
The new drawing element appears in the Timeline, Xsheet and Network views.

How to add a drawing element from the Xsheet view
1. Do one of the following:
‣

In the Xsheet view menu, select Columns > Add Columns.

‣

Click the Add Columns

‣

Press Shift + C.

button.

The Add Column dialog box opens.

2. In the Name field, type a relevant element name.

3. In the Type field, select Drawing.

4. To complete the operation:
‣

Click OK to add your new layers and close the dialog box.

‣

Click Apply to add your new layers and keep the dialog box open to add column.

‣

Click Close to cancel the operation.

The new drawing element appears in the Timeline, Xsheet and Network Views—see Layer and
Column Types on page 213.

How to create a column in Harmony using the advanced Add Column dialog box
You can use the advanced Add Column dialog box to make more file format and field size options
available when you insert the column.
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1. From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS
X) and select the Advanced tab.
2. In the Advanced Options section, select the Advanced Element Mode option to access the
advanced Add Column dialog box.

3. Click OK.
4. In the Xsheet View menu, select Columns > Add Column or press Shift + C.
The Add Column dialog box opens.

5. In the Name field, type the new column’s name.
6. In the Type drop-down menu, select the Drawing type.
7. In the Element section, select one of the following:
‣

Create New Element: Create an independent column with its own drawing folder.

‣

Reuse Existing Folder: Link your column to an existing folder within the Element folder of
your scene. If you select this option, in the Folder drop-down field, select the folder to which
you want to link your new column.

‣

Use Existing Element:Use drawings from an existing column in the new column. Both
columns will be attached to the same set of drawings, but their timing will remain
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independent from one another. If you modify one of the drawings, it will be modified in both
columns. This is the same principle as the Clone column.
If you selected the Use Existing Element option, in the Name drop-down field, select the
column to which you want to link your new column.

8. If you selected the Create New Element option:
‣

Deselect the Vector option if you want your layer to contain bitmap images or enable it if
you want the layer to contain vector drawings. Most of the time, the Vector option will be
enabled.

‣

If you deselected the Vector option, from the Bitmap Format list, select which type of
bitmap image you want to insert in the column. Select the SCAN type if you are planning to
scan drawings using the Toon Boom Harmony Scan module.

‣

If you deselected the Vector option and you chose the SCAN type, from the Scan Type
menu, select what kind of scanning you want to achieve.

‣

In the Field Chart field, when importing traditional animation, indicate the size of paper on
which the animation or background was drawn. If you are not using perforated animation
paper, leave the 12 field default value as is.

9. Do one of the following:
‣

Click OK button to create the new column and close the dialog box.

‣

Click Apply to create the new column but keep the dialog box opened to create other new
columns.

Deleting Layers and Columns
You can delete an element in the Timeline view or Xsheet view.

How to delete layers in the Timeline view
1. In the Timeline view, select the layers to be deleted.

2. Do one of the following:
‣

In the Timeline’s Layer toolbar, click the Delete Layers

‣

Right-click on the selection and select Delete.

The Confirm Delete dialog box opens.
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‣

Select the Delete Drawing Files and Element Folders option to delete all drawings and
folder linked to this layer.

3. Select the Delete Xsheet Columns option if you also want to delete the existing column in the
Xsheet view.

How to delete columns in the Xsheet view
1. In the Xsheet view, select the columns to be deleted by clicking on their header.

2. Do one of the following
‣

Right-click on the selection and select Delete Columns.

‣

In the Xsheet View toolbar, click the Delete Columns

‣

Press Delete.

button.

The Confirm Delete dialog box opens.

‣

Select the Delete Drawing Files and Element Folder option if you want to delete the
drawings and folders linked to the selected column.

3. To complete the operation:
‣

Click OK to delete the selected layers.

‣

Click Cancel to cancel the operation.

The Warning dialog box may open.

4. Do one of the following:
‣

Click Yes to delete all the frames from your scene.

‣

Click No to keep the frames in your scene.

‣

Select the Don’t Show This Message Again option if you do not want the dialog box to
display again in the future.

221

Chapter 8: Timing Creating Drawing Elements

Layer and Column Properties
Each element has its own set of properties that can be modified, including effect and peg layers.
If you want to modify some of the element’s properties, display the Layer Properties or Column
Properties editor. You can display the Layer Properties editor from the Timeline or Network view as a
dialog box or open the Layer Properties as a view of its own.
The Layer Properties editor allows you to:
•

Rename the layer

•

Enable or disable the layer

•

Lock the layer

•

Change the track colour

•

Activate the onion skin preview

•

Adjust the positioning and animation parameters

•

Adjust many other advanced parameters

The Column Properties editor allows you to:

222

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

•

Rename the layer

•

Enable or disable the layer

•

Adjust parameters for bitmap format, scan type and field chart

How to display the Column Properties editor from the Xsheet view
1. Do one of the following:
‣

In the Xsheet view, double-click on a column’s header.

‣

In the Xsheet view, right-click on a column's header and select Column Editor.

‣

Press Shift + E.

How to display the Layer Properties editor
1. Do one of the following:
‣

In the top menu, select Windows > Layer Properties.

‣

In the Timeline view, double-click on a layer.

‣

Press Shift + E.

‣

In the Network view, click on the module’s yellow properties button.

2. In the Timeline or Xsheet view, select the layer whose properties you want to view.
The Xsheet column will not open the Layer Properties editor, but it will show the column properties
allowing you to modify settings related to the Xsheet column.

Modifying Layers and Columns
Once you add layers and columns to your project, you can modify their properties, names, or
ordering.
You can change the order of your elements in the Timeline view and Xsheet view. When you change the
order of your elements in one view, the other one is updated.
The Element Manager lets you add, delete or modify elements (drawing folders) in your scene. If you
have drawing folders that are not linked to a column in your scene, use the Element Manager to delete
them if needed.
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How to rename a layer in the Timeline view
1. In the Timeline view, double-click on the name of the layer to rename.
2. In the Name field, rename the layer and press Enter/Return.

How to rename a layer in the Layer Properties editor
1. In the Timeline view, double-click anywhere on the layer except the layer name to rename.
The Layer Properties editor opens.
2. In the Name field, rename the layer.

3. Click Close.

How to rename a column
1. In the Xsheet view, double-click on a column name. Do not click on the drawing folder name that
the column is linked to (this also appears in the column header just below the column name).
The Drawing dialog box opens.

2. In the Name field, rename the column.
3. Click OK.

How to reorder layers in the Timeline view
1. In the Timeline view, select the layers to move.
2. Drag the selection to the new location.
3. Do one of the following:
‣

Drop the selection on an existing layer to make it a child of another element layer.

‣

Drop it between the existing layers. Timeline layers that are located above the selection are
displayed in front it. Layers located under it in the Timeline View are displayed behind it.
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How to reorder columns in the Xsheet view
1. In the Xsheet view, click on the column’s header with the middle mouse button.
2. Drag the column to its new position.

How to use the Element Manager dialog box
‣ From the top menu, select Scene > Element Manager.

Interface Element

Action

Elements

Displays a list of the elements
contained in your scene.

Delete Elements

Deletes the selected elements.

Delete Elements and Directories

Deletes the selected layer, as well as
its directories (drawing folder).

Add/Modify Element

Use this area to add or modify an element.

Name

Type a new name in this field to create
an element or to rename the selected
element.

Vector

Check this box if the new element is a vector
drawing or if you want to enable the parameters on the selected element in the Elements list.
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Interface Element

Action

Bitmap Format

Select the file format of the bitmap layer
from the drop-down list

Scan Type

If you are planning to scan elements with the
Toon Boom Harmony Scan module, select
the scan type from the drop-down list.

Field Chart

If you are importing traditional animation,
select the size of the paper on which the
animation was drawn.

Add

Creates a new element with the current parameters entered in the Add/Modify Element
section.

Modify

Applies the parameter changes made to the
selected element.

Duplicating Layers and Columns
Duplicating an element provides you with a copy of the drawings and their exposure. You can modify
anything you want in the duplicated element without affecting the original one. In the Network view,
you can duplicate the selected modules in the same way.

How to duplicate an element
1. In the Timeline or Xsheet view, click the layer you want to duplicate.

2. From the top menu, select Edit > Duplicate.
3. In the Xsheet view or Timeline view toolbar, click the Duplicate Drawing

button.

The new duplicated layer or column appears.

Cloning Layers and Columns
Cloning a layer or column provides you with a copy of the selected element that uses the same
drawings as the original. For example, if you modify a drawing in the cloned or original column, it is
updated in both columns.
You can choose whether or not to copy the column timing to the cloned columns.
•

You can modify the column timing independently from each other, but the drawings remain linked.

•

You can copy the columns timing, so drawings and timings remain linked.

You can clone selected modules from the Network view in the same way.
This feature is useful when you want to reuse a hand-drawn animation but have different timings.

226

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

How to clone an element
1. In the Timeline or Xsheet view, select the layer or column you want to clone.

2. Do one of the following:
‣

From the top menu, select Edit > Clone.

‣

In the Xsheet View toolbar, click the Clone Selected Columns: Drawings Only

‣

From the top menu, select Edit > Clone to clone the columns' drawings only.

‣

From the Timeline View menu, select Layers > Clone Selected Layers: Drawings Only or
Layers > Clone Selected Layers: Drawings Only.

‣

In the Xsheet View or Timeline View toolbar, click the Clone Selected Layers/Columns:
button.
Drawings Only

button.

The new cloned layer or column appears.

Adding an Annotation Column
The Annotation columns are useful for marking actions, corrections or other information related to
your animation that you want to draw or write. This way, you can print your Xsheet, take it back to
your animation table and work with the annotations.

How to add an annotation column
1. Do one of the following:
‣

In the Xsheet View menu, select Columns > Add Columns.

‣

In the Xsheet View toolbar, click the Add Columns

‣

Press Shift + C.

The Add Column dialog box opens.

2. In the Name field, type in an appropriate name.
3. From the Type list, select Annotation and click OK.
The new column appears.
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Drawing and Typing in the Annotation Column

In the annotation column, you can type in your notes and relevant information, as well as draw
sketches and ideas that will be useful in producing your animation.

How to draw in the Annotation column
Before you can draw in the Annotation column, you must first activate the Enable Drawing option to
activate the Drawing mode.

Pen tablet pressure sensitivity is not supported in the Annotation column.

1. Do one of the following:
‣

In the Xsheet View menu, select Annotation > Enable Drawing.

‣

In the Annotation column header, click to cycle through the icons, until the Brush
displayed.

icon is

The Drawing mode is enabled.
2. To draw in an Annotation column, simply use your mouse or pen tablet.

How to type in an Annotation column
Typing in an Annotation column is independent from the Drawing mode. You can be in either mode
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and the typing will work.
1. Do one of the following:
‣

In the selected cell, press Ctrl (Windows/Linux) or ⌘ (Mac OS X).

‣

In the selected cell, hold down Ctrl + Shift + click (Windows/Linux) or ⌘ + Shift + click (Mac
OS X)..

2. In the selected cell, type the desired text.

To learn about typing values in the Xsheet view, refer to Typing Exposure on page 236.

How to erase part of a drawn annotation using Erasing mode
You can erase part or all of the Annotation column’s text and drawn annotations.

Annotations that you type in cannot be erased using this method.

1. In the Annotation column header, click to cycle through the icons until the Eraser
displayed.

icon is

2. In the column, click and drag the cursor on top of the drawn annotation to erase parts of it.
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When using a pen on a tablet, you MUST flip your pen to the eraser side for the eraser to work.

How to erase an Annotation column selection
1. In the Annotation column header, click to cycle through the icons until the Select
displayed.

icon is

2. In the Xsheet view, select the cell range you want to clear of text or drawn annotations. A selection
is indicated by four pairs of dots on the left side of a cell. Do not select any cells if you plan to clear
everything.

3. In the Xsheet view, right-click in the Annotation column.
4. Do one of the following:
‣

Select Annotation > Erase All to erase the entire content of the column.

‣

Select Annotation > Erase Selected Images to erase the images contained in the selected
cell range.

‣

Select Annotation > Erase Selected Texts to erase the text contained in the selected cell
range.

Changing the Drawing Settings
You can change the pen size and colour when you draw in the Annotation column.

How to change the pen width
1. Right click on a frame within an annotation column or in the Xsheet View menu, select Annotation
> Pen Width.
2. Do one of the following:
‣

Select a pen width preset.

‣

Select Change Current.

If you selected the Change Current option, the Pen Width dialog box opens.
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3. In the Pen Width field, type the number of pixels you want the pen size to be.
4. Click OK.

How to change the pen colour
1. In the Xsheet View menu, select Annotation > Change Pen Colour.
The Select Colour dialog box opens.

2. Choose the new colour.
3. Click OK.

Displaying Tick Marks
When working with the Annotation columns, it is useful to display tick marks on odd-numbered
frames.

To display the tick marks, you must run a short script.

How to display tick marks
1. From the top menu, select Windows > Script Editor.
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2. From the Script Editor menu, select File > New Script.
3. Type in a name for your script and click OK.
4. In the File list, select the script you created.
5. On the right side of the view, type the following script:
function display_tick_marks()
{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", true);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER",
false));
}
6. Click Verify.
The script is verified.
7. From the File menu, select Play/Debug > Run.
A dialog box opens with your script selected in the Files column.
8. In the Functions column, select display_tick_marks and click OK.
Tick marks appear on odd frames in the Annotation column.

If you do not see tick marks, close and restart Harmony.

How to turn off the display of tick marks
1. Follow steps 1 to 5 of How to display tick marks and use the following script:
{
preferences.setBool("XSHEET_ANNOTATION_FRAME_MARKER", false);
MessageLog.trace( preferences.getBool("XSHEET_ANNOTATION_FRAME_MARKER",
false));
}
2. Follow steps 6 to 8.
All tick marks are removed from the Annotation column.

Importing an Annotation File
If you scanned your paper exposure sheet’s annotations or if you need to place some pictures or
drawings in the annotation columns, you can easily import them.

How to import annotation files
1. In the Xsheet view, select the first cell in the annotation column where you want the imported
image to start.
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2. Right click on the frame or from the Xsheet view menu, select Annotation > Import File.
3. Browse for the bitmap image to import.
4. Click Open.
The image appears in the annotation column.

Linking External Files with Timing Columns
Timing columns are unique in that they can reference a source folder outside of the project folder to
bring images into the project. For example, you may have background scenes created in a third party
software that you might need to update in the future; by using Timing columns, you can dynamically
link your backgrounds, expose different backgrounds at different times, and have live, automatic
updating capabilities.

If the project file is moved, or the folder that the column is linked to is moved, then dynamic linking is
broken and the images that were in that folder will disappear in Toon Boom Harmony.

How to use a Timing column
1. In the Xsheet view, click on the Add Columns

button.

2. In the Add Column dialog box, type in the name of the new column, then from the Type menu,
select Timing.
3. Do one of the following:
‣

Click OK if you are finished.

‣

Click Apply if you want to continue adding more columns and column types.

A peach coloured column appears in the Xsheet with the name you typed in, and for the header,
<unused>.
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4. In the Network view, add a new element module—See Adding Modules on page 1.
5. Open the Layer Properties editor by clicking on the yellow square of the module.
6. In the Drawing tab, select the Timing Columns option.
7. In the Name field, enter the path of the folder you want to access. If you use the Browse button to
locate a folder, you must select a file in the folder you want and then delete the dash and the suffix
(for example, background-01 should be renamed to background) from the file name in the
field. If you leave the full file name selected, Harmony will display that file for the entire duration of
the scene, regardless of the contents of the Timing Column field.

This means that all the images in the folder that you are linking to are named using the naming convention
described above. If for some reason you are unable to access a certain directory, type the directory
extension directly in the path extension field at the top of the browser window.

8. In the Timing Column field, click the Arrow button to create a new timing column, or select the
name of the column from the list. If you have an element directory selected in the Name field, the
Timing Column will indicate which files are called from that element directory. Remember that the
file displayed at each frame is based on the element name, cell label, and extension. If the element
is toto, the timing column is labeled 1, 2, and 3, and the extension is TVG, Harmony will display
drawings totobody-1.tvg, totobody-2.tvg, and totobody-3.tvg at the selected frames.

In the Xsheet, the <unused> header changes to the name of the module in the Network view.
9. From the Extension list, select the file format of the files you want to display.
10. Click OK.
11. In the Xsheet view, in the Timing column, type the number that corresponds to the suffix of the
drawing file that you want to expose to make it appear in the Camera view.
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Filling Exposure
Harmony provides different tools to fill in exposures and values, create cycles, and set increments.
This section is divided as follows:
•

Filling Exposure Mode below

•

Typing Exposure on the next page

•

Holding Exposure on page 238

•

Extending a Single Exposure on page 239

•

Extending an Exposure Sequence on page 240

•

Dragging Cells on page 240

•

Increasing and Decreasing Exposure on page 243

•

Inserting Blank Cells on page 246

•

Deleting Exposure on page 245

•

Setting the Exposure on page 247

•

Filling a Selection with a Single Exposure on page 248

•

Filling a Selection with a Sequence on page 249

•

Filling a Selection Randomly on page 251

•

Filling Empty Cells on page 252

•

Creating Cycles on page 253

•

Managing Drawings on page 257

•

Renaming a Drawing on page 257

•

Deleting a Drawing on page 258

•

Duplicating a Drawing on page 259

•

Copying and Pasting Drawings on page 259

•

Merging Drawings on page 262

Filling Exposure Mode
In the Xsheet view, you can fill columns using two different filling modes: Overwrite or Insert. These
modes control the filling behaviour. The Timeline view only uses the Overwrite mode.

How to toggle between Overwrite and Insert modes
1. Do one of the following:
‣

In the bottom-right corner of the Xsheet view, click the Overwrite/Insert button.

‣

Press I.
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Overwrite Mode
By default, the Xsheet view is set to Overwrite mode. Adding a new value or a new value sequence
overwrites existing ones. The existing timing sequence remains in the same place and is not pushed
down the column.

Insert Mode
The Insert mode is the opposite of the Overwrite mode. When you add a new value or a new value
sequence over existing ones, the new values are inserted between the old ones. The existing timing
sequence is pushed down the column.

Typing Exposure
To fill in your exposure, you can directly type the values in the Xsheet view and Timeline view.

How type a value in the Timeline view
If you want to type an exact drawing name or value into the Timeline view, you must use the Data
view section of the Timeline.

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).
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1. In the Timeline view, click the Show Data View

button.

2. In the Drawing Substitution field, type the name of the drawing you want to create, and press
Enter/Return.

How to type values in the Xsheet view

You can only use alphanumeric values. (0-9, a-z, underscore (_) and dash (-)).

1. In an Xsheet column, double-click on one cell.

2. Type a value or drawing name in the cell.

3. Press Enter/Return to move to the next cell.

4. Press Esc to exit the typing mode and return to normal mode.
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Holding Exposure
Drawings in an animation project are not always exposed on a single frame; they are often exposed
for more than one frame. The most common exposure of a drawing is two frames. In the industry, this
type of exposure is known as animation in double frames or animation on twos. A drawing can also be
exposed for three, four, five cells and so on. To prevent mistakes and save time, the Xsheet lets you
hold your cells automatically as you type.
The Set Exposure option allows you to choose how many frames you want to hold for your exposure.

•

This option is only available in the Xsheet view.

•

The selected Set Exposure settings will be kept from session to session. You will not
have to set them every time you use Toon Boom Harmony.

How to hold exposure
1. In the Xsheet View menu, select Exposure > Hold Exposure > Hold 2 Cells.
2. In the Xsheet view, right-click and select Exposure > Set Exposure To > Set Exposure to 1, 2,3,
or Set Exposure.
3. Type a value or drawing name in the cell.
‣

Press Enter/Return to move on to the next cell.

‣

Press Esc to quit the typing mode.

‣

If you selected Set Exposure, the Set Exposure dialog box opens. You can hold as many
cells as needed.
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Extending a Single Exposure
Extending the exposure lets you select an Xsheet cell that contains a value and pull it down to the
desired frame.

How to extend a cell exposure gesturally
1. In the Xsheet view, select the red arrow in the cell’s right side. Make sure you see the drag down
cursor.

2. Pull down the selected cell to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered
cancelled.

How to extend a sequence from the top menu
1. Do one of the following:
‣

In the top menu, select Animation > Cell > Extend Exposure.

‣

Press F5.

The Extend Exposure dialog box opens.
2. Enter the frame number you want to extend the cell to.
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Extending an Exposure Sequence
When working with a sequence that contains only numbers, you can extend an exposure sequence in a
similar manner to extending a single exposure.

How to extend an exposure to create a sequence
1. In the Xsheet view, select a cell containing a number.
2. In the selected cell, click the red arrow on the cell’s right side. Make sure to see the drag down
cursor.

3. Hold down the Shift key. Make sure a plus (+) sign appears.
4. Pull down the selection box to the desired frame.

The red selection box must be visible when releasing the mouse button. If not, the action is considered
cancelled.

5. First release the Shift key, then release the mouse button.

Dragging Cells
To readjust your timing, you can drag one or several cells to a new location. You can drag a cell to any
other frame in the same column or into another column.

How to drag a cell to another location in the Timeline view
1. In the Timeline view, select one or several cells to move.
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2. Click on the cells selection and drag it to the new location.

3. Drop the selection. Do one of the following:
‣

Drop by simply releasing the mouse or pen to overwrite the existing cells.

‣

Hold Ctrl (Windows/Linux) or ⌘ (Mac OS X) while dropping the selection to copy the cells.
The original cells will not be moved.

‣

Press Shift while dropping to insert the selection between the existing frames.

How to drag a cell to another location in the Xsheet view
1. In the Xsheet view, select one or more cells.

2. In the Xsheet view, select the small dotted area

on the left side of the selected cells.
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3. Drag the selection to any other cell in the same column or in another column.

4. Do one of the following:
‣

Drop the selection to overwrite the existing cells.

‣

Hold down Ctrl (Windows/Linux) or ⌘ (Mac OS X) while dropping the selection to copy the
cells. The original selection will not be moved.

‣

Press Shift while dropping the selection to insert it between the existing frames.
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You can turn off the Gestural Drag Mode for the Xsheet view to prevent drawings from being
dragged from one location to another.

How to turn off the Gestural Drag mode
1. Do one of the following:

‣ In the Xsheet view, right-click and deselect the Gestural Drag Mode option.
‣ Click the Toggle Gestural Drag Mode button (you may have to customize the toolbar to display
it).

The dragging pad disappears when the Gestural Drag mode is off.

This feature does not apply to Annotation columns.

Increasing and Decreasing Exposure
Once a value is entered in the Timeline or Xsheet view, you can increase and decrease its exposure.

How to increase exposure
Increasing the exposure adds one more exposure to a selected cell; repeating this action adds an
extra cell each time. This is an efficient way of extending a drawing exposure and is always set in
Insert mode. Increasing an exposure pushes the existing exposure ahead.
1. In the Timeline or Xsheet view, select a cell.
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2. Do one of the following:
‣

In the top menu, select Animation > Cell > Increase Exposure.

‣

Right-click on the selected cell and select Exposure > Increase Exposure.

‣

Press +.

‣

In the Xsheet or Timeline View toolbar, click the Increase Exposure

button.

How to decrease exposure
1. In the Timeline or Xsheet view, select a cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Decrease Exposure.

‣

Right-click on the selected cell and select Exposure > Decrease Exposure.

‣

In the Xsheet or Timeline View toolbar, click the Increase Exposure

‣

Press -.

button.

How to increase and decrease exposure using the Increase/Decrease Exposure field
You can use this option in the Xsheet view to increase or decrease the exposure of a selected drawing.
1. In the Xsheet view, select the cell to modify.
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2. Do one of the following:
‣

In the Xsheet's bottom right-corner, enter the number of cells over which the drawing will be
exposed.

‣

In the Xsheet’s bottom-right corner, increase or decrease the drawing’s exposure by
clicking the up or down arrows.

‣

Press + to increase exposure.

‣

Press - to decrease exposure.

How to use the Clear Exposure and Pull feature
You can use this option to reduce a drawing’s exposure.
1. In the Timeline or Xsheet view, select or range of cells.

2. Do one of the following:
‣

From the top menu, select Animation > Cell > Clear Exposure and Pull.

‣

Right-click on the selected cell and select Exposure > Clear Exposure and Pull.

‣

In the Xsheet or Timeline View toolbar, click the Clear Exposure and Pull

button.

3. The exposure is reduced by the selected number of cells.

Deleting Exposure
You can delete a drawing’s exposure in several ways. When you delete a drawing’s exposure from the
Timeline or Xsheet view, you are not deleting the actual drawing file. You can always retrieve it by
typing its name again in a cell.
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You can delete the exposure contained in a selected cell range or delete the entire exposure of a
drawing exposed over several cells . Note that you can also delete the exposure for drawings
contained inside a collapsed group.

How to delete selected exposures
1. In the Timeline or Xsheet view, select the exposure you want to delete.
2. Do one of the following:
‣

Right-click and select Delete.

‣

Press Delete.

How to clear the entire exposure of a drawing
1. In the Timeline or Xsheet view, select a cell of a drawing exposed over several cells.
2. Do one of the following:
‣

In the top menu, select Animation > Cell > Clear Exposure.

‣

In the Timeline view, right-click on the selection and select Exposure > Clear Exposure.

‣

In the Xsheet View toolbar, click the Clear Exposure
the toolbar to display it).

button (you may have to customize

Inserting Blank Cells
You can place an empty cell between other cells. This is always done in Insert mode and pushes down
existing exposure, even if you are set to Overwrite mode.

How to insert blank cells
1. In the Xsheet or Timeline view, select the cell in which you want to insert a blank cell.

2. Do one of the following:
‣

In the top menu, select Animation > Cell > Insert Blank Cell.

‣

Right-click on the selected cell and select Exposure > Insert Blank Cell.

‣

In the Xsheet or Timeline view toolbar, click the Insert Blank Cell
to customize the toolbar to display it).

‣

Press Shift + J.

The blank cell is inserted.
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How to clear a selected cell range without changing the exposure and timing
1. In the Xsheet view, select the frame range to clear.

2. Right-click on the selected cells and select Clear.

Setting the Exposure
You can easily increase or decrease the exposure for a selected cell range by using the Set Exposure
options.

How to set the exposure
1. In the Timeline or Xsheet view, select the cell range on which you want to set the exposure.
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2. Do one of the following:
‣

From the top menu, Animation > Cell > Set Exposure to > Set Exposure to 1, 2, or 3, or
Set Exposure.

‣

In the Xsheet view, right click and select Exposure > Set Exposure to > Set Exposure to 1,
2, or 3, or Set Exposure.

‣

In the Timeline View toolbar, click one of the Set Exposure
have to customize the toolbar to display them).

buttons (you may

3. In the Xsheet view, right-click and select Exposure > Set Exposure to > Set Exposure to 1, 2, or
3, or Set Exposure.
If you chose the Set Exposure option, the Set Exposure dialog box opens.

4. Type the number of frames you want the drawings to display and click OK.
The new timing is displayed in the Xsheet view.

Filling a Selection with a Single Exposure
The Fill Selection option lets you fill the same value over an entire selection. The selection can be over
one cell, a cell range in one column, a cell range over many columns, an entire column, or many
columns. You can use numbers, words, letters, or any alphanumeric value.
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How to fill a selection with a single exposure
1. In the Xsheet or Timeline view, select a cell range.

2. Do one of the following:
‣

In the top menu, select Animation > Cell >Fill Selection.

‣

Click the Fill Selection
button in the Xsheet or Timeline view toolbar (you may have to
customize the toolbar to display it).

‣

Press Ctrl + T (Windows/Linux) or ⌘ + T (Mac OS X)).

The Fill Selection dialog box opens.

3. In the Value field, type the desired value.
4. To insert a keyframe in the frame following the last cell in the selection, select the Add Key
Exposure After option. Otherwise, leave it deselected.
5. Click OK.

Filling a Selection with a Sequence
You can create a numbered sequence over a selection. The sequence can be forward, backward,
single, double or higher increment, as a cycle, and so on. The sequence can be over one cell, a cell
range in one or more columns, or one or more columns.

How to fill a selection with a sequence
1. In the Xsheet or the Timeline view, select a cell range.
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2. Do one of the following:
‣

From the top menu, select Animation > Cell >Sequence Fill.

‣

In the Timeline view, right-click and select Exposure > Sequence Fill.

‣

In the Xsheet View toolbar, click the Sequence Fill
the toolbar to display it).

‣

Press Ctrl + M (Windows/Linux) or ⌘ + M (Mac OS X).

button (you may have to customize

The Sequence Fill dialog box opens.

3. In the Starting Value field, type the first number in the sequence.
4. In the Increment field, type the number by which the drawing number will increase from frame to
frame. For example, an increment of 1 is used in this sequence:1-2-3-4; this sequence increments
by 2: 1-3-5-7; and this one, by -2: 8-6-4-2.
5. In the Hold field, select an exposure holding value.
6. Select the Cycle option if you want a cycle; enter the number of cells for this cycle’s duration.

If you choose a two-cell hold, a cycle of three drawings will last for six cells.

7. If you selected a larger range than the amount of frames needed, select the End Frame option and
type the last frame needed.
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8. If you want to have more than one digit in your numbers such as “001” instead of “1”, select the
Padding option and add as many pound signs (#) as digits needed. In the field, you can type a
letter or word to add before the drawing number.

9. To insert a keyframe in the frame following the last cell in the selection, select the Add Key
Exposure After option. Otherwise, leave it deselected.
10. Click OK.

Filling a Selection Randomly
You can fill in random values over a selection. You can give a maximum and a minimum value and
create a range for the system to choose the random values from. The selection can be over one cell,
a cell range in one column or more, or an entire column or many entire columns.

How to fill cells randomly
1. In the Xsheet view, select a cell range.

2. Do one of the following:
‣

Select Animation > Cell > Fill Cells Randomly.

‣

In the Xsheet view, click the Fill Cells Randomly
toolbar to display it).

The Fill Cells Randomly dialog box opens.
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3. In the Minimum Value field, enter the lowest acceptable value.
4. In the Maximum Value field, enter the highest acceptable value.
5. In the Hold field, choose an exposure holding value.
6. If you are applying this option to a drawing column, enable the Whole Numbers option to avoid
decimal points.
7. Click OK.

Filling Empty Cells
The Filling Empty Cells feature is used to extend the exposure of single frame drawings to fill the
range of empty cells after each one.
When creating drawings on cells that are not side-by-side, the exposure of the first drawing no longer
fills automatically. You need to select the frame range where you want your drawings to hold their
exposure up to the next drawing and use the Fill Empty Cells command.

How to fill empty cells
1. In the Xsheet view or Timeline view, select a cell range.
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2. Do one of the following:
‣

From the top menu, select Animation > Cell > Fill Empty Cells.

‣

In the Timeline View toolbar, click on the Fill Empty Cells

button.

Each drawing in the selection is exposed in the range of empty cells that follow it.

Creating Cycles
Once you have entered a series of drawings and exposures, you can create cycles out of them in
several ways.
You can loop your drawings using the following commands:
•

Paste Cycle

•

Paste Reverse

•

Create Cycle
When you create a drawing cycle, all of the repeated drawings are linked to the same original files.
This means that when you modify, repaint, or correct a drawing named “1,” all drawings named “1”
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are updated simultaneously. In order to modify a drawing independently from its other exposures,
you must duplicate the drawing.

How to create a cycle
1. In the Timeline view, select the cell range to loop.

2. In the Timeline View toolbar, click the Create Cycle
toolbar to display it).

button (you may have to customize the

The Create Cycle dialog box opens.

3. Enter the number of cycles you want, including the current selection.

How to paste a cycle
1. In the Xsheet or Timeline view, select the cell range to loop.

2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:
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‣

From the top menu, select Edit > Paste Cycle.

‣

Right-click and select Paste Cycle.

‣

Press Ctrl + / (Windows/Linux) or ⌘ + / (Mac OS X).

The Paste Cycle dialog box opens.

5. Do one of the following:
‣

In the Number of Cycles field, enter the number of cycles you want to paste.

‣

Increase or decrease the number of cycles you want to paste.

6. In the Cycle Type menu, select the type of cycle you want to paste.

‣

Normal (forward): Pastes cycles as for all cycles, starting with the first cell of your selection
and ending with the last.

‣

Reverse: Pastes cycles in the reverse order of the original selection, starting with the last
cell of your selection and ending with the first one.

‣

Forward > Reverse: Pastes the first cycle in your selection as is, then the following one in
reverse order. This repeated until all cycles are pasted.

‣

Reverse > Forward: Pastes the first cycle in your selectionin reverse order, then the
following one as is. This repeated until all cycles are pasted.

7. Click OK.

You can perform the same operation using the Paste Special dialog box. To open the Paste Special dialog
box, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).

How to paste a reversed cycle
1. In the Xsheet or Timeline view, select the cell range to paste in reverse order.
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2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. Do one of the following:
‣

From the top menu, select Edit > Paste Reverse.

‣

Right-click and select Paste Reverse.

‣

Press Ctrl + . (Windows/Linux) or ⌘ + . (Mac OS X).
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Managing Drawings
Drawings that are created in Toon Boom Harmony are not stored in their cells. They are actual files
stored in the project’s folder. If you want to rename a drawing or delete a drawing from your project,
you need to edit the file and not the cells.
This section is divided as follows:
•

Renaming a Drawing below

•

Deleting a Drawing on the next page

•

Duplicating a Drawing on page 259

•

Copying and Pasting Drawings on page 259

•

Merging Drawings on page 262

Renaming a Drawing
To rename a drawing, you need to select the drawing cell and use the Rename Drawing command.

How to rename a drawing
1. In the Xsheet or Timeline view, select the drawing to rename.

2. Do one of the following:
In the Xsheet or Timeline View toolbar, click the Rename Drawing
customize the toolbar to display it).
‣

button (you may have to

Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X).

The Rename Drawing dialog box opens.

3. In the New Name field, type in the new drawing name.

How to rename a drawing sequence with a prefix
You can rename a drawing sequence with a prefix, which can be quite useful for cut-out puppet
breakdown and deformation animation.
1. In the Xsheet or Timeline view, select your drawing sequence. Note that you can only select a
drawing range in one column or layer at the time.
2. Right-click and select Drawings > Rename Drawing with Prefix.
The Rename Drawing with Prefix dialog box opens.
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3. In the Prefix to Add field, type the prefix to add before the drawing name.

How to rename drawings by their frame position
You can rename a series of drawings relative to their frame position. This is useful in hand-drawn
animation.
1. In the Xsheet or Timeline view, select the drawing sequence to be renamed.

2. From the top menu, select Drawing > Rename by Frame.

Deleting a Drawing
You can permanently delete a drawing file from a project's folder.

Deleting a drawing file is an operation that cannot be undone.

How to delete a drawing
1. In the Xsheet or Timeline view, select the drawings to delete.
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2. Do one of the following:
‣

From the top menu, select Drawing > Delete Selected Drawings.

‣

Right-click and select Drawings > Delete Selected Drawings.

Duplicating a Drawing
If you want to modify a drawing that already exists, but keep the original drawing intact, you can
duplicate the drawing and work on the copy. When duplicating a drawing, the selected cell is replaced
with the new drawing. The exposure of the original drawing that was on the current cell is removed.
The original drawing is not deleted from the project folder or other cells in which it is exposed.
With Toon Boom Harmony you can create a keyframe at the same time as you duplicate your drawing.
This way you can modify and reposition drawings without affecting the original drawing.

How to duplicate a drawing
1. In the Xsheet or Timeline view, select the drawing to duplicate.

2. Do one of the following:
‣

From the top menu, select Drawing > Duplicate Drawing.

‣

Right-click and select Drawings > Duplicate Drawings.

‣

In the Xsheet view toolbar, click the Drawing > Duplicate Drawing

‣

Press Alt + Shift + D.

button.

Copying and Pasting Drawings
When you copy and paste a selection in the Timeline or Xsheet view, you are not copying and pasting
the actual drawings, you are pasting the exposure.
If you want to copy and paste the selected drawings into a different layer or paste the selection in the
same layer to duplicate the drawings, you must use the Paste Special feature.
There are three methods of pasting your selected drawings with the Paste Special dialog box:
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•

Never Create Drawing Files: Pastes all of your drawings as is. If there is a drawing in a cell, it is
overwritten by the pasted selection.

•

Always Create Drawings: Pastes all of your drawings as is, unless a pasted drawing has the same
name as an existing one. In this case, the pasted drawing is duplicated and renamed.

•

Only Create Drawings When They Do Not Exist: Pastes only the drawings that are named
differently from existing drawings. If a drawing has the same name as an existing one, it is ignored
and not pasted. This avoids the duplication of drawings in your layers.
This option is useful when you are pasting cut-out character templates containing drawings you
may already have in your scene and some new ones. Using this option, you only paste the new
drawings and are not duplicating all of the other parts you already have.

If you want to perform another Paste Special operation using the same settings you used previously,
you can use the Paste Special Again command instead. You can paste your selection using the same
settings as in the most recent Paste Special operation, without opening the Paste Special dialog box.

How to paste drawings with the Paste Special command
1. In the Xsheet or Timeline view, select the drawings to copy and press Ctrl + C (Windows/Linux) or
⌘ + C (Mac OS X).

2. In the Xsheet or Timeline view, select the cell where you want your pasted selection to start.

3. Do one of the following:
‣

Right-click and select Paste Special.

‣

From the top menu, select Edit > Paste Special.

‣

In the Xsheet or Timeline View toolbar, click the Paste Special
customize the toolbar to display it).

‣

Press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).

The Paste Special dialog box opens.
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4. Select the Basic tab.
5. In the Drawings section, select an option: Always Create Drawings or Only Create Drawings
When They Do Not Exist.

How to paste new drawings with the previous Paste Special settings
1. Do one of the following:
‣

From the top menu, select Edit > Paste Special Again.

‣

Right-click and select Paste Special Again

‣

In the Xsheet or Timeline view toolbar, click the Paste Special Again
have to customize the toolbar to display it).

‣

Press Ctrl + Shift + B (Windows/Linux) or ⌘ + Shift + B (Mac OS X).
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Merging Drawings
There are two methods of merging drawings.
•

You can merge selected drawings in adjacent elements. The columns and layers will be left intact,
and each new merged drawing will reside in the frames of the left-most column or lower layer.

•

You can merge elements. All drawings will be merged. Unused columns and layers will be deleted,
but the original drawing files are still accessible.

How to merge selected drawings
1. In the Xsheet view, select the drawings you want to merge.

2. Do one of the following:
‣

In the Xsheet View menu, select Columns> Merge Selected Drawings.

‣

In the Timeline View menu, select Layers > Merge Selected Drawings.
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3. Do one of the following:
‣

In the Xsheet View menu, select Columns > Merge Selected Columns.

‣

In the Timeline View menu, select Layers > Merge Selected Layers.

In the Xsheet view, the right-most column will contain the merged drawings and the remaining
columns will be left blank at the corresponding frames. In the Timeline view, the bottom timeline
layer will contain the merged drawings from all layers and the other layers will be left blank at the
corresponding frames. Drawings are not deleted and are still accessible.

How to merge drawings in entire layers or columns
1. Do one of the following:
‣

In the Timeline view,select the layers you want to merge.

‣

In the Xsheet view, Shift-click the headers of the columns you want to merge.

2. Do one of the following:
‣

In the Xsheet View menu, select Columns > Merge Selected Columns.

‣

In the Timeline View menu, select Layers > Merge Selected Layers.
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In the Xsheet view, the right-most column will contain the merged drawings and the other columns
will be deleted. In the Timeline view, the bottom timeline layer will contain the merged drawings
from all layers and the other layers will be deleted. Drawings are not deleted and are still accessible.

Modifying the Layer and Column Display
You can change the way a layer in the Timeline view or a column in the Xsheet view display. You can
stay organized without changing the content of elements or your animation output.
This section is divided as follows:
•

Expanding and Collapsing Layers and Columns below

•

Showing and Hiding Layers on the facing page

•

Showing and Hiding Columns on page 267

•

Modifying the Look of the Column on page 269

•

Xsheet Thumbnails on page 274

•

Changing the Colour of a Layer or Column on page 274

•

Setting Scene Markers on page 276

•

Setting Tempo Markers on page 279

Expanding and Collapsing Layers and Columns
To simplify the look of the Xsheet or Timeline view, you can expand and collapse your timeline layers
and 3D columns. If some timeline layers are parented to other ones, you can collapse the parent layer
to hide its children.

How to collapse or expand a layer selection in the Timeline view
1. In the Timeline view, select the layer(s) to collapse or expand.
2. Do one of the following:
‣

Right-click on the selection and select Collapse/Expand > Collapse/Expand.

‣

Click the Expand Children Arrow

‣

Press Ctrl + I (Windows/Linux) or ⌘ + I (Mac OS X).

‣

Click the Collapse/Expand

button on the parent layer.

button (you may have to customize the toolbar to display it).
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‣

How to collapse or expand all layers in the Timeline view
1. Do one of the following:
‣

Right-click on the layers and select Collapse/Expand > Expand All or Collapse All.

‣

In the Timeline View toolbar, click the Collapse All
have to customize the toolbar to display them).

‣

Press 0 and 9.

or Expand All

buttons (you may

How to collapse and expand 3D path or rotation columns in the Xsheet view
1. In the Xsheet View toolbar, click the Show Column List

button to display the Functions list.

2. In the Xsheet view, select the column header of the 3D path or 3D rotation column to collapse or
expand.
3. Do one of the following:
‣

Right-click on the column’s header and select Expand/Collapse > Collapse Selection or
Expand Selection.

‣

or Expand Selection
In the Xsheet View toolbar, click the Collapse Selection
buttons (you may have to customize the toolbar to display it).

How to collapse or expand all 3D path and 3D rotation columns in the Xsheet view
Do one of the following:
‣

Right-click on any column’s header and select Expand/Collapse > Expand All or Collapse
All.

‣

Press 0 and 9.

‣

In the Xsheet View toolbar, click the Collapse All
have to customize the toolbar to display it).

or Expand All

buttons (you may

Showing and Hiding Layers
As you work in the Drawing or Camera view, some layers may be in the way or are used as references.
You can hide these layers to make your work area less cluttered and easier to navigate. You can show
and hide layers in the Timeline view in several different ways.

How to show or hide all layers
1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable All

button (you may have to customize the

toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Enable/Disable All
layers.
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How to show or hide individual layers
1. Do one of the following:

‣ In the Timeline View toolbar, click the Enable/Disable

button (you may have to customize the

toolbar to display it).

‣ On the right side of the Timeline view, select or deselect the layer’s checkbox.

When you deselect a layer in the Timeline view, the corresponding column is hidden in the Xsheet
view.

How to enable the selected layer and disable all others
1. Do one of the following:

‣ In the Timeline View toolbar, click the Disable All Others

button (you may have to customize

the toolbar to display it).

‣ In the Timeline view’s Layer toolbar, click the Show Selection and Hide All Others

button.

In the Timeline view, you can hide or show certain types of layers such as Group and Effect.

How to show and hide layer types in the Timeline view
1. Do one of the following:
‣

From the Timeline View menu, select View > Show > Show Manager.

‣

You can also select View > Show > Show Sounds, Show Effects or Show Groups to
immediately show or hide the selected type. This option will remain only for the current
session. When you close and reopen Harmony, the default settings will return.

The Show Manager dialog box opens.

2. Select the types of layers you want to display and deselect the ones you want to turn off.
3. Click Set As Default to make these new settings the default ones that will be used each time to
start the application. Click Restore Default to restore the settings used when installing the
application.
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In the Xsheet view, you have the choice of hiding or showing certain types of columns such as
Annotation and Functions.

Showing and Hiding Columns
The Xsheet view has a Column List section that can display all the columns contained in the exposure
sheet. It can be used to hide individual columns.
If you need to see a column after it has been hidden, you can display it directly from the Xsheet view
without using the Column List section.
You can also hide an entire column type, such as Drawing or Sound.
When a column is hidden in the Xsheet view, the corresponding layer is disabled in the Timeline view.

How to show or hide columns in the Xsheet view
1. In the Xsheet View toolbar, click the Show Column List

button.

2. On the right side of the Functions section, click the Expand button to display the Column List
section.
3. Do one of the following:
‣

In the Column List section, select the columns to display and deselect the columns to hide.

‣

In the Xsheet view toolbar, click the Hide Selected Column
customize the toolbar to display it).

button (you may have to

How to show a hidden column in the Xsheet view
1. In the Xsheet view menu, click on the thick grey line that represents a hidden column. You can also
right-click on the column header and select Show Hidden Columns.

The Show Hidden Columns dialog box opens.
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2. In the Show column, select the hidden columns you want to display in the Xsheet view.
‣

Click Check to select all the selected columns.

‣

Click Uncheck to deselcted all selected columns.

How to show all columns
‣

In the Xsheet view menu, select View > Unhide All Columns.

How to show and hide column types
1. In the Xsheet view, select View > Column Types Manager.
The Column Types dialog box opens.

2. Select the types of columns you want to display and disable the ones you want to hide.
3. Click Set As Default if you want to make these new settings the default ones that will be used each
time to start the application.
4. Click Restore Default if you want to restore the settings used when installing the application.

How to show or hide Xsheet columns using the Column List
1. In the Xsheet view toolbar, click the Show Column List

button.

2. On the right side of the Functions section, click the Expand button to display the Column List
section.
3. In the Column List section, select the columns to display and deselect the columns to hide.
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How to show or hide an Xsheet column type using the Column List
1. In the Column List section, click the button corresponding to the type you want to show or hide.

Column Type butAction
ton
Show/Hide All Columns
Show/Hide Drawing Columns
Show/Hide Function Columns
Show/Hide 3D Path Columns
Show/Hide Sound Columns
Show/Hide 3D Rotation Columns
Show/Hide Annotation Columns

How to show or hide function columns on the left side of the Xsheet view
1. Right-click on a column and select Tag > Function Columns Visible or Function Columns
Invisible.

Modifying the Look of the Column
In Harmony, you can modify the way the column displays drawings, empty cells and the column width.
You can modify the following elements:
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•

Empty cells

•

Row units

•

Held exposure

•

Column width

How to modify the look of empty cell
1. From the Xsheet View menu, select View > Empty Cells > With an “X” or Blank.

How to modify row units
1. From the Xsheet View menu, select View > Row Units > Frames or Feet.

How to modify the look of a held exposure

‣

In the Xsheet View menu, select View > Held Exposures > Line or Value.

How to modify column width
1. In the Xsheet view, select any column to modify the width.
2. From the Xsheet view menu, select View > Set Columns Width.
The Xsheet Column Width dialog box opens.

270

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

3. In the Column Width field, enter the desired width in pixels.
4. To end the operation:
‣

Click OK to validate and close the dialog box.

‣

Click Apply to validate the operation and keep the dialog box opened to adjust the next
column’s width.

‣

Click Set As Default to create all the new columns to this width.

‣

Click Close to cancel the operation.

5. To restore all columns to the default value, in the Xsheet View menu, select All Columns to
Default Width.

Drawing Identification
In the Xsheet view, you can identify drawings as Key, Breakdown or In-between. This helps to keep the
Xsheet well organized while animating.
When working with several animators, directors, or even other studios, the necessity for retakes will
often arise. Harmony also gives you the possibility to mark new drawings as either Retake Key, Retake
Breakdown, or Retake Inbetweens.
If your production requires you to mark drawings with a custom marker, you also have the option to
create your own.
Make custom marks for the Xsheet by creating your own icons, then cutting, pasting and changing a
bit of code. Not only is it possible to have your custom mark appear in the Xsheet and Mark Drawing
toolbars, but also in the Onion Skin and Flip toolbars.
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You can create custom shortcuts for the Drawing Identification options in the Preferences dialog box.

How to mark a drawing as Key, Breakdown or In-between
1. From the top menu, select Windows > Toolbars > Mark Drawing.
The Mark Drawing toolbar displays.

2. In the Xsheet view, select the cell you want to identify. This option is not available in the Timeline
view.
3. In the Mark Drawing toolbar, click one of these buttons: Mark as Key Drawing
, Mark as
Breakdown Drawing
or Mark as In-between Drawing
. In the Xsheet View menu, you can
also select Drawing > Mark Drawing As > Key Drawing, Breakdown Drawing, In-between
Drawing, Retake Key, Retake BD and Retake IB.
‣

If you selected Mark as Key Drawing, a

‣

If you selected Mark as Breakdown Drawing, a

‣

If you selected Mark as In-Between Drawing, there is no icon displayed in the cell since it is
used to remove a Key or Breakdown marker.

icon appears in the cell.

272

icon appears in the cell.

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

How to create custom markers
1. With a bitmap editing software, create the following icons in PNG format:
‣

Mark Drawing Toolbar icon (24 x 24 pixel)

‣

Onion Skin Toolbar icon (24 x 24 pixel)

‣

Flip Toolbar icon (24 x 24 pixel)

‣

Xsheet Column icon (16 x 16 pixel)

2. Close Harmony.
3. When your icons are ready, open the Toon Boom Harmony drawingTypes.d folder.

If the drawingTypes.d folder does not exist, you must create it. To do so, copy the
resources folder from the following location.
•

Windows: C:/Program Files (x86)/Toon Boom Animation/Harmony
11.1/resources/drawingTypes.d

•

Mac OS X: /Applications/Harmony 11.1/resources/drawingTypes.d

•

Linux:
/usr/local/ToonBoomAnimation/ProductNameVersion/resources/drawingTypes.d

Stand-alone
‣

Windows: C:\Users\USERNAME\AppData\Roaming\Toon Boom Animation\Toon
Boom Harmony\full-1100-pref\drawingTypes.d

‣

Mac OS X: /Users/USERNAME/Library/Preferences/Toon Boom
Animation/Toon Boom Harmony/full-1100-pref/drawingTypes.d

The Library folder is usually hidden in the Finder. To see all the hidden folders and files,
type the following in a terminal window:
defaults write com.apple.Finder AppleShowAllFiles YES

‣

Linux: /home/USERNAME/Toon Boom Animation/Toon Boom Harmony/full1100-pref/drawingTypes.d/

Network
In Harmony Network, the path is global for all users so you must create the folder and place in
/USA_DB.
‣

/USA_DB/drawingTypes.d

4. Paste your icons in the drawingTypes.d directory.
5. In the same directory, open the drawingTypes.xml file in a text editor.
6. For each custom icon you want to create, add the following line. Make sure to place it before this
closing tag: </DrawingTypes>.

273

Chapter 8: Timing Merging Drawings

‣

<DrawingType text="NewButtonName" pixmapFile="XsheetIcon.png"
commandIcon="MarkDrawingIcon.png" flipIcon="FlipIcon.png"
onionIcon="OnionIcon.png" />

7. In that line, replace the following information with your new icon information:
‣

NewButtonName: Write the name of your new marker. This name will appear in the button
tooltip.

‣

XsheetIcon.png: Write the name of the icon that you created to appear in the Xsheet
column. Include the file extension.

‣

MarkDrawingIcon.png: Write the name of the icon that you created to appear in the Mark
Drawing toolbar. Include the file extension.

‣

FlipIcon.png: Write the name of the icon that you created to appear in the Flip toolbar.
Include the file extension.

‣

OnionIcon.png: Write the name of the icon that you created to appear in the Onion Skin
toolbar. Include the file extension.

8. Save the file and close it.
9. Start Harmony.

Xsheet Thumbnails
When there are a large number of columns in the exposure sheet, it is not always easy to quickly
identify a particular column. Displaying the column thumbnails makes this easier. This option displays a
small thumbnail picture of the current frame below the column header.

How to display the thumbnails
1. In the Xsheet view, select View > Show Thumbnails.
The thumbnails appear.

Changing the Colour of a Layer or Column
To easily identify elements in the Timeline or Xsheet view, you can change the colour of layers and
columns. The colours you choose will be reflected in the Network view.

How to change the layer’s colour in the Timeline view
1. Do one of the following:
‣

In the Timeline view, click the colour swatch of the layer you want to modify.

2. In the Select Colour dialog box, select a new colour for your layer.
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3. Click OK.
The layer’s background colour is updated. In a Drawing layer, exposed cells are the brighter,
selected colour for easy identification. The corresponding column colour is also updated.

How to reset a layer’s colour in the Timeline view
1. In the Timeline view, select the layers to reset.
2. In the Timeline View toolbar, click the Default Track Colour
the toolbar to display it).

button (you may have to customize

How to change a column’s colour in the Xsheet view
1. In the Xsheet view, select one or more columns to modify.
2. Right-click on the column’s header and select Colour > Change Columns Colour.
3. In the Select Colour dialog box, select a new colour for your columns.

4. Click OK.
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The column’s colour is updated. The corresponding column colour is also updated.

How to reset the column’s colour in the Xsheet view
1. In the Xsheet view, select the columns to reset.
2. Right-click on the column’s header and select Colour > Default Columns Colour.

Setting Scene Markers
Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a
scene marker, which is displayed when you hover over the scene marker.
There are two ways to add a scene marker. You can make a frame range selection and mark that
whole section or simply mark the current frame.

How to mark the current frame
1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you
right-click on a different frame, the scene marker will be created on the current frame, which means
where the red playhead is.
2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.
4. In the Note field, enter text to display a tooltip.
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5. Click OK.
6. In the Timeline view, the scene marker is displayed at the current frame. Hover over the scene
marker to display its note as a tooltip.

How to create a scene marker on a frame range
1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.
The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.

3. Click the colour swatch and select a colour for the scene marker.
4. In the Note field, enter text to display as a tooltip.

5. Click OK.
6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over
the scene marker to display its note as a tooltip.
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How to edit a scene marker

If you select only a part of a scene marker, you will not open the scene marker for editing. You will only be
able to create a new scene marker to overwrite it.

1. In the Timeline view frame counter, select the entire scene marker.

2. Right-click the selection and select Edit Scene Marker.
The Timeline Scene Marker dialog box opens.

3. Make your changes.
4. Click OK.

How to delete a scene marker
1. In the Timeline view frame counter, at least one frame counter in the scene marker you want to
delete.

2. Right-click the selection and select Delete Scene Marker.
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Setting Tempo Markers
Tempo markers are used to synchronize your animation with a musical score. This lets you reproduce
the FPB (Frames Per Beat) and use the tempo signature as tempo markers. The Xsheet view allows
you to pace your animation according to the tempo or beat of the soundtrack music or to any rhythmic
sound, such as the ticking of a clock or water leaking from a spout.

How to set the tempo markers
1. In the Xsheet View menu, select View > Set Tempo Marker or in the sound column, right-click and
select View > Set Tempo Marker.
The Tempo Marker dialog box opens.

2. Reproduce the tempo and beat value of your music or sound for the Xsheet view marker display.
‣

Starting Frame: Enter the number of the frame where you want the tempo markers to
begin.

‣

Frames/Beat: Set the frames per beat value. This will determine the frequency (in frames) in
which a beat marker will appear. Keep in mind that, by default, 24 frames represent 1
second.

‣

Beat/Bar: Set the tempo of your music or sound. This will determine the frequency (in beats)
in which a tempo marker will appear in the Xsheet view.

3. Click OK.
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Printing the Xsheet
Once you have marked all the information, corrections, and timing you want in the Xsheet view, you
can print your exposure sheet. Printing the Xsheet allows you to take it with you to your animation
table or give a copy to the animator. You can also use it to create your Xsheet skeleton directly in
Harmony.

How to print your exposure sheet
1. Select File > Print > Xsheet.
The Print dialog box opens.
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2. To set up your print:
‣

Windows: In the Select Printer section, select your printer and adjust the rest of the printing
settings.

‣

Linux: In the Print Destination section, select your printer and adjust the rest of the printing
settings.

‣

Mac OS X: In the Printer section, select your printer and adjust the rest of the settings by
clicking on the Parameters
button. You can also click PDF and select an option from the
menu if you want to save a PDF version of your exposure sheet.

Refer to your printer user guide to learn more about its options.

3. Do one of the following:
‣

Windows and Mac OS X: Click Print.

‣

Linux: Click OK.
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Chapter 9: Character Building

Harmony is a great tool for building characters. You can use different techniques and features to
break down your puppets.
This chapter contains the following topics:
•

About the Model on the next page

•

Relative Sizes on page 286

•

Studying the Model on page 288

•

Setting the Default Separate Position Preference on page 292

•

Naming Conventions on page 294

•

Disabling the Animation on Drawing Layers on page 297

•

Breaking Down the Character on page 299

•

Ordering the Layers on page 316

•

Rigging on page 320

•

Adding Extra Drawings on page 338

•

Setting the Pivots on page 340

•

Skeleton Optimization on page 344

•

Storing the Character in the Library on page 349

•

Appendix on page 352

For more great options and features to create powerful and efficient puppets, refer to Deformation
on page 487. You will find a series of features for bending, curving and deforming drawings for more
realistic, cartoony and fluid animation.
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About the Model

To begin breaking down your puppet, you must first import your character into a new project. You can
also draw your character directly in the scene.
You can import your character in several different formats:
•

Library template

•

Bitmap image or picture

•

External vector format

Model Alignment

When setting the character model in your scene, we recommend that you to center it in the Camera
view and scale it to fit inside the safe area frame.
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If you have several views of your character, place each view in a separate cell and center them one on
top of another. This will facilitate the break down process and ensure that all of your puppets are
aligned and the same size.

Photo Puppets
If you are creating a cut-out puppet out of photos, break down the different parts in a bitmap editing
software. Then, import your parts and vectorize them as textured images.
A good way to set and import your bitmap parts is to organize them in a multilayered PSD file.

285

Chapter 9: Character Building Relative Sizes

Relative Sizes
Understanding the relative size of every character and prop is important for maintaining consistency
and structure throughout your project.
A production may contain many characters and props. It is not unusual for these to have been created
by different people. If there is no size control implemented, the characters and elements created by
different artists can vary greatly in size. When this occurs, the characters that are put together in a
scene will be out of proportion. The animator or person doing the scene setup will then have to scale
them to the correct size.
When a character or a prop is scaled down, the outline will get increasingly thinner. By the time the
element is scaled to its proper size, the outline may be so thin that the difference between one
character's outline and another's will not look very good.
These tips will help you to create and determine the correct relative sizes for each puppet:
•

Line Up below

•

Field Chart on the facing page

•

Brush Size on the facing page

Line Up

A line up consists of copying and pasting all of your character designs into the same drawing and then
scaling them so they are in proportion with each other. This line up is very important and should be
handed to any animator, layout and posing artist, or scene setup person working on the project.
For the prop design, it is recommended that you paste one of the main character's hands or even the
full body beside the prop. This enables the animator to know what size to draw or set the prop.

In your character design scene, it is a good idea to create a layer for the character line up. The line up is
usually done during the character design step. When the character builder imports the model to the break
down scene, the size relation should be correct.
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Field Chart

The field chart in Harmony is a tool that is very useful when setting the height of characters and props.
You can display the field chart using the Show Grid option in the Camera and Drawing views.
How to display the field chart
1. Do one of the following:

‣ From the top menu, select View > Grid > Show Grid.
‣ Press Ctrl + ' (Windows/Linux) or ⌘ + ' (Mac OS X).
‣ Click the Show Grid

button in the Camera View and Drawing View toolbars.

Brush Size
There are a variety of pens and brushes in Harmony and you can also create and save your own. It is a
good idea to create and save pens with precise sizes and parameters to trace and design your models
and break downs—see Drawing with the Brush Tool on page 46.
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Studying the Model

Now that you have imported or designed your model, the next step is to analyze it. This is to
determine what parts will be broken apart and how they will be divided. Will the hair be separated
into one, two or three sections? Will the hand be separated from the sleeve? To determine what is
best for your character, observe the model in the Camera or Drawing view.
To help you improve the quality of your break down, here are some tips and tricks. The following
examples are from "Grossology" a production by Nelvana Limited:
•

Eyelids and Pupils below

•

Creating Mouth Shapes Directly on the Head on the facing page

•

Keeping Fingers Attached to the Hand on the facing page

•

Mixing Hand-Drawn Animation on page 290

•

Flipping Logos on page 291

•

Complete and Overlapping Pieces on page 291

Eyelids and Pupils

For increased flexibility when animating the eyes, you can split them into three layers: the eyeball, the
pupil and the eyelid. The eyelid layer is used for the blink and to cut the pupil when it gets too close to
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the side of the eyeball. For a more advanced break down, the two eyes are separated on their own
individual three-layer sets.

Creating Mouth Shapes Directly on the Head

To animate more realistic lip syncing and facial expressions, you can create the mouth shapes on the
head layer. Just deform the jaw to match the mouth opening.

Keeping Fingers Attached to the Hand

To avoid needlessly complicating the break down, the fingers are not usually separated from the hand.
The full hand is a single layer with a bank of different hands stored inside. This technique is easy to
work with and produces a less mechanical effect.
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Mixing Hand-Drawn Animation

For more advanced cut-out animation and a more traditional animation look, you could keep full arms
and full legs. This means that only the hands and feet are separated from the limbs. The animator will
create extra drawing shapes and substitute them during the animation.

The animator may temporarily combine some parts to facilitate the work and produce a higher quality
animation. One example is to combine both full legs and hips into a single drawing to create poses
that would be difficult using cut-out pieces. Both full legs could be drawn on the hip level with the legs
and feet exposure removed. This technique is a mix of cut-out and hand-drawn animation.
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Flipping Logos

You can separate logos and letters that appear on a character or a prop. This allows you to flip and
reuse a character's puppet.

Complete and Overlapping Pieces

For a better result with animated parts, it is important to understand that they must be properly
overlapping and complete. A common mistake is to trace the part just as it appears on the model.
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Setting the Default Separate Position Preference
Before you start adding layers to your puppets, you should enable the Default Separate Positions for
Elements preference if it is not already done.

With the Default Separate Positions for Elements option selected, when you create new layers, their X,
Y and Z axes are independent from each other.
By default, this preference is enabled. For cut-out animation, you want to have three independent axes
so you can control them individually. When you lock the three positions together, each time you add a
keyframe, it is added on all three positions at the same time.

When you separate the three positions and add a keyframe on one axis, it is not added on the other
two. This gives you more freedom when animating with motion keyframes and nudging parts forward
and backward over time.

How to enable the Default Separate Positions preference
1. Do one of the following:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. In the Preferences dialog box, select the General tab.
3. In the Settings section, select the Default Separate Positions for Elements option.
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4. Click OK.
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Naming Conventions
When working on a production, it is critical to keep work well organized with a naming convention
chart before starting the project. It is crucial that everyone follows the criteria laid out in the naming
convention chart. When dealing with thousands of characters, pieces and puppets, it is easy to get
lost.

Adding a Prefix or Suffix to a Layer
It is highly recommended that you incorporate a naming convention for the layers. This will be very
convenient in later steps. We suggest that you add one or two letters for the character/prop name
before the part name and an "R" or "L" for right and left to identify the corresponding
character/prop:
•

Character Abby's right arm = ab_r_arm.

If you plan to work with different angles for your characters (front, side, three-quarter, back), you can
add one or two letters to identify the angle:
•

Character Abby's right arm, front view = ab_r_arm_f.

How to add a prefix to a series of layers
1. In the Network or Timeline view, select all the modules or layers to rename or press Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).
button. If the Scripting toolbar is
2. In the Scripting toolbar, click the Add Prefix or Suffix Script
not visible, you can display it by selecting Windows > Toolbars from the top menu.
The Add Prefix or Suffix dialog box opens.

3. Select the Prefix or Suffix option depending on what you want to add to the layer's name.
4. Type the prefix or suffix information to be added to the layer's name.
5. Click OK.

Naming the Drawings
We recommend that you use a naming convention for your drawings. If you combine all the angles of a
character in the same breakdown scene, it is a good idea to identify each angle used.

294

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Before breaking down the characters for your production, we recommend that you create a drawing
name convention that represents the angle used. For example, use "f" for front, "s" for side, "q" for
three-quarter so that the drawing name looks like this: f1, f2, f3, s1, s2, etc. This will be quite useful
during animation and drawing substitution. Since drawings are displayed in alphabetical and numerical
order, all the drawings for the front view will be together, then all the drawings for the three quarter
view, and so on.

How to add a prefix to one or more drawings
1. In the Timeline view, select the drawing range to rename.

2. Do one of the following:
‣

Right-click on the selection and select Drawings > Rename Drawing with Prefix.

‣

From the top menu, select Drawing > Rename Drawing with Prefix.

The Rename Drawing with Prefix dialog box opens.

3. Type the characters you want to add before the current drawing name.
4. Click OK.
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To rename a drawing, select the drawing and use the Rename Drawing option. Do not double-click on the
frame and write a new name, as this will create a new drawing and hide your actual one. Note that the
hidden drawing has not been deleted and is still located within the element folder. Simply retype the
name and it will reappear.
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Disabling the Animation on Drawing Layers
By default, a drawing layer can be animated, but Harmony lets you disable this feature. Being able to
switch your drawings so they can no longer be animated without a peg has certain advantages. It
means that you can access the drawing substitution feature for this drawing layer, while being able to
create keyframes on its parent peg. This feature is also available for backward compatibility when
bringing in templates created in older versions of Harmony, so as not to lose their offset keyframes or
drawing substitution keyframes.
When selecting the element in the Camera view, the actual drawing layer is selected, but the motion
you will create will automatically be transposed to the peg layer. You cannot animate (add keyframes)
directly onto the drawing layer if the option is disabled. You will still be able to perform certain offset
movements in the Transformation tab of the Layer Properties, but not using any of the animation tools
in the Tools toolbar.
There are two ways to disable animation on drawing layers, via the Layer Properties window and the
Preferences dialog box. When you disable animation in the Layer Properties window, it affects only
the selected layer and not any others.
If you prefer this style of animation and want every drawing element that you create to not be
animated, you can disable the Element Module “Animate Using Animation Tools” Default Value
preference. This will disable the Animate Using Animation Tools option on all the new layers you will
create from that point on so you don't have to do this through the Layers Properties window for every
layer. It is recommended to disable this preference before starting a new character rig.

How to disable animation in the Layer Properties view
1. In the Timeline view, double-click on a layer.
The Layer Properties window opens.
2. In the Controls tab, deselect the Animate Using Animation Tools option.

Notice that the layer functions are no longer available in the Timeline view.
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3. Click Close.

How to disable the option in the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: Select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

The keyboard shortcut is Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the Advanced tab.
3. In the Advanced Options section, deselect the Element Module "Animate Using Animation
Tools" Default Value option.
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Breaking Down the Character

There are many techniques you can use to break down a puppet. In this section, you will learn about
one of the most common and simplest methods. For your first character breakdown, follow these
instructions to get an idea of the way Harmony works. Once you understand Harmony's basic
functions and commands, you will be able to create your own techniques to satisfy the needs of your
production.
Refer to the Appendix on page 352 at the end of the chapter for alternate tips.

Tracing the Model
The main breakdown technique shown here is to trace your model, completing the hidden lines and
filling the gaps—see the Appendix on page 352 to learn about more techniques.

How to break down a character
1. In the Timeline view, add a new drawing layer for each body part to separate. You can press Ctrl +
R (Windows/Linux) or ⌘ + R (Mac OS X).

2. In the Timeline view, select the layer's first cell in which you want to draw the part.

3. In the Tools toolbar, select a drawing tool.
4. In the Colour view, select a colour swatch.
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5. In the Camera or Drawing view, draw the new part.

If you are working in the Drawing view, click the Light Table
button in the Drawing View toolbar
to display the other layers as washed out colours. You can also press Shift + L.
6. In the Tool Properties view, you can set the Pencil tool width to 0 to create an invisible hairline if
you want to close a shape without drawing an actual stroke.

‣

Select View > Show > Show Strokes or press K to display the invisible lines.
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7. In the Tools toolbar, select the Paint

or Paint Unpainted

tool to colour your drawing.

8. In the Colour view, select the corresponding colour.
9. In the Camera or Drawing view, paint your drawing.

10. In the Tools toolbar, select the Select
tool. Select your drawing and flatten the lines by clicking
the Flatten
button in the Tool Properties view.
11. If your lines are composed of several pencil strokes, you might want to combine them into one
single smooth pencil line. Using the Select tool, select the pencil lines to be merged and in the Tool
Properties view, click the Merge Pencil Lines
button.
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12.Repeat the entire process until the break down is completed.

Articulations

Once your pieces are traced, you can proceed to the completion of the articulations.
Articulations are an important aspect of any cut-out break down because without them, a puppet
cannot move properly and will not look good.
This topic is divided as follows:
•

Classical Articulation below

•

Auto-patch Articulations on page 305

Classical Articulation
Classical articulation is the most popular technique for basic characters. It is quite simple and
produces excellent results, but it is not the most efficient method. In many instances, it causes
limitations and extra drawing corrections. For example, there may be a gap in the articulation if the
part is bent too far. Joint design is usually a circle; the overlapping part cannot be sent behind without
showing the joint.
For a more advanced articulation, see Patch Articulation on page 371 in the Appendix section.
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Classical articulation is done by erasing a part of the line from the overlay layer, leaving the colour
overlapping the bottom one. You can use this technique for all the articulations on your puppet.

How to create a classical articulation
1. In the Timeline view, select the cell containing the first part to modify, such as the upper arm.

2. In the Tools toolbar, select the Pencil

, Polyline

, Ellipse

, or Contour Editor

tool.

3. In the Colour view, select an outline colour.

4. In the Drawing or Camera view, use your drawing tool to make sure that the joint overlaps the
other part in a half-circle shape.
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‣

If you are working in the Drawing view, click the Light Table
toolbar or press Shift + L.

button in the Drawing View

5. From the top menu, select View > Show > Show Strokes or press K to display the invisible lines
that may be present in your drawing.
6. In the Drawing or Camera view, select all the strokes in your drawing.
7. In the Tools Properties view, click the Flatten

button.

8. In the Drawing or Camera view, select all the strokes in your drawing.
9. In the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any unnecessary
invisible lines in your drawing.
10. Repeat steps 1 to 9 for the other part of the joint.
11. In the Timeline view, select the cell of the part that will be on top of the joint.

12. In the Tools toolbar, select the Select

, Cutter

or Eraser

tool.

13. In the Drawing or Camera view, remove a part of the overlapping outline in order to have only the
filling colour overlapping the joint.

14. In the Tools toolbar, select the Contour Editor

tool.

15. In the Drawing or Camera view, adjust the colour fill so that the pencil outline does not overlap it.
Be careful not to leave a gap between the line and the fill.
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When placing rotation pivots later on, make sure they are positioned at the centre of the articulation.

Auto-patch Articulations
Harmony has a very efficient module to automatically patch an articulation without you having to do
any line adjustment or colour overlapping. You can draw your two pieces with their complete lines
overlapping each other in semicircles and the Auto-patch module will create a perfect articulation from
it.
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In order for the Auto-patch to work on your puppet, you must draw the outline with the Pencil tool
(pencil lines) on the Line Art layer or y our drawing, and then paint the colour on the Colour Art layer of
your drawing.

How to create Colour Art zones out of the Line Art content
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, enable the Permanent Selection
operation on all drawings in the layer.

option if you want to apply the

3. In the Camera or Drawing view, select the artwork to transfer to the Colour Art. Create a selection
around the entire animation sequence if you want to apply the operation to all your drawings.

4. In the Drawing View toolbar, click the Create Colour Art from Line Art
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You can use this technique in an even more efficient way by adding extra lines in the Overlay layer of
your drawing to create a fold illusion for a bent elbow.

307

Chapter 9: Character Building Breaking Down the Character

About the Auto Patch Module

The Auto Patch module is used mainly when creating joint patches for cut-out puppets drawn with
pencil lines and painted in the Colour Art layer. Instead of removing a portion of the outline to attempt
to create a seamless joint, you can draw complete pieces, and with the Auto Patch module,
automatically create a perfect articulation.
The requirements for this effect to work are:
•

Drawing outlines must be drawn in pencil lines

•

Drawing outlines must be drawn in the Line Art layer

•

Drawing fill colours must be painted in the Colour Art layer

Pencil lines are central vector lines. The vector is located along the centre of the line. This means that
when you paint a zone delimited by a pencil line, the colour fill will expand to the centre of the pencil
line.

When using the regular patch technique, recommended for the brush line, the result with pencil lines is
very odd looking because the colour fill zone is bigger than the pencil line inner contour.
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Instead of using the regular patch method, you can use the Auto Patch module. It will automatically
extract the Colour Art and clip it to the right size. Then, you can connect it in front of the piece to be
covered.
The network connection for the Auto Patch is quite simple. Once your basic character rigging is done,
you can add the Auto Patch module to the joints you want to cover. There is no need to set any
parameters.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell
animation. These art layers are contained within a single drawing as opposed to the timeline layers or
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes .
Toon Boom Harmony drawings include four art layers.
•

Overlay on the facing page

•

Line Art on page 312

•

Colour Art on page 312

•

Underlay on page 313

You can access the art layers through the Art Layer toolbar. By default, only the Line Art and Colour
Art are displayed. You need to enable the Support Overlay and Underlay Arts option in the
Preferences dialog box.

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and
facilitate creation and revision.
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Overlay

The Overlay layer can serve multiple purposes:
•

Highlights and tones

•

Annotations and corrections

•

Sketching
You can also draw in the Overlay layer as it is a regular layer.
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Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.

Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or
approval before carrying on with your work. If you have several characters in your project that are
overlapping, it may be difficult to understand what is going on as you can see through the
characters. Toon Boom Harmony can generate a matte automatically in the Underlay, or even in the
Colour Art layer, and fill all the zones inside your characters making them opaque. This process is
fast and easy and allows you to send easy-to-understand movies.
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Underlay

The Underlay layer can serve multiple purposes. It is frequently used by animators to sketch rough
animation or generate a matte colour when doing line testing.

How to enable the Support Overlay and Underlay Arts option
1. From the top menu, select Edit > Preferences ( Windows/Linux ) or Stage > Preferences ( Mac
OS X ).
2. In the Preferences dialog box, select the Advanced tab.
3. In the Advanced Options section, select the Support Overlay and Underlay Arts option.
4. Click OK.

How to switch between drawing layers
or Colour Art
buttons. When switching art layer,
1. In the Art Layer toolbar, click the Line Art
it will allow you to edit the select layer without affecting the other one.

2. Click the Preview All Enabled Art Layers
button to display both layers together. Even when the
Preview mode is enabled, you will only be able to edit the select art layer. The other ones are only
displayed as a reference. By default, the Preview mode is always enabled in the Camera view. You
will only be able to see the select art layer by itself if you enable the Current Drawing on Top
option located in the Camera bottom toolbar.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to
Line Art and Colour Art button in the Tool Properties of the tools supporting the
operation.

How to switch between the drawing layers in Advanced Art mode
1. In the Art Layer toolbar, click the Overlay Art
, Line Art
, Colour Art
or Underlay Art
buttons to display the appropriate layer—see How to enable the Support Overlay and Underlay
Arts option above. When switching art layer, it will allow you to edit the select layer without
affecting the other one.
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2. Click the Preview All Enabled Art Layers
button to display all the layers together. The other
ones are only displayed as a reference. By default, the Preview mode is always enabled in the
Camera view. You will only be able to see the select art layer by itself if you enable the Current
option located in the Camera bottom toolbar.
Drawing on Top

How to generate a matte
1. Do one of the following:
‣

In the Tools toolbar, select the Select

‣

Press Alt + S.

tool.

2. In the Camera or Drawing view, select the drawing you want to create a matte for.

You can also apply the operation to all the drawings in the layer at the same time.

3. Do one of the following:
‣

From the top menu, select Drawing > Generate Auto-Matte.

‣

In the Camera or Drawing view menu, select Drawing > Generate Auto-Matte.

The Auto-Matte dialog box opens.

4. If you want to create a matte for all the drawings included in your layer, select the Apply to
Multiple Drawings option.
5. Depending on how precise or rough your line is, increase or decrease the radius value. The lower
the value is, the closer to your lines’ contours the matte will be shaped. The higher the value is, the
looser the matte will be shaped.
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6. In the Source Art menu, select the layer from which you want the matte created: Line Art, Colour
Art, Underlay or Overlay.
7. In the Destination Art menu, select the layer you want the matte to be created on: Line Art, Colour
Art, Underlay or Overlay.
8. If you already have artwork on the destination layer and you want the content to be deleted before
the matte is added into it, select the Clear Destination Art First option.
9. If you want the contour of your lines to be copied as invisible lines in your matte drawing (in case
you ever need to keep them for later), select the Copy Stroke in Destination option.
10. Click OK.
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Ordering the Layers

At this point, it is possible that your character's pieces may show up in the wrong order.
There are several ways to fix this. First, you can reorder your layers by dragging them to a higher or
lower level in the Timeline view. The top layer is displayed in front of the others and the bottom one is
displayed behind. Second, you can use the Z-axis nudging (forward and backward) if you have extra
views included in the same layers (front, three-quarter, back, etc.).
This topic is divided as follows:
•

Ordering the Timeline Layers below

•

Ordering Layers in the Network View on the facing page

•

Nudging Parts Backwards and Forwards on page 318

Ordering the Timeline Layers
In the Timeline view, the layer positioned at the top will be displayed in front and the ones below will
be displayed behind. If you have multiple views, you should order your layers based on the most
common view, which is generally the three-quarter front.
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How to order the layers
‣

In the Timeline view, drag a layer to reorder it and drop it between other layers.

If you drop it on a layer, it will create a parent hierarchy, so make sure to drop it between layers.

Ordering Layers in the Network View

The Network view allows you to reorder layers without breaking any hierarchy. For example, if you
want the Head layer to appear behind all the facial features, in the Timeline view, you cannot simply
move the layer down because you will break the parenting between the head layers. In the Network
view, since you have a set of flexible connections, you can change the Composite module ordering
without breaking the parenting between the modules.
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The Composite module ordering corresponds to your timeline ordering unless the Network's
organization is too complex for the Timeline view to display. The element connected in the left-most
port of the Composite module is displayed in front in the Camera view and the one connected in the
right-most port is displayed behind.

How to order your layers in the Network view
‣

In the Network view, select the module's output cable connected to the Composite module and
drag it to its new position.

Nudging Parts Backwards and Forwards
If you created a hierarchy on your arms, legs or other body parts, it is possible that you will want a
part, such as the hand, to appear in front of its parent. Yet, if you move the hand layer above the arm
layer, you will break the hierarchy. To reorder a layer rigged in a hierarchy, nudge it backwards or
forwards on the z-axis.
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You will do the same for the layers that are not in the right order on the extra views. Do not place the
drawing on another layer. You want to keep all your drawings of the body parts in the same layers like a box
containing all of the hands or all of the shoes.

Harmony allows you to move your elements in three dimensions:
•

Up and down (Y-axis)

•

Left and right (X-axis)

•

Backwards and forwards (Z-axis)

In the same way you create multiplane backgrounds (depth), you can perform a micro nudge of the
part to be reordered and see it in front of the other elements, even if its layer is actually behind the
other ones in the Timeline view. The forward-backward position can also be animated over time.
Repeat the following instructions for all the views.

How to nudge your parts backward and forward
1. In the Tools toolbar, select the Transform

tool. Make sure to enable the Animate

mode.

2. In the Camera view, select the element you want to reorder. Make sure the focus (red outline) is
around the Camera view before selecting the element.
3. To move the element forward, press Alt + Down Arrow and to move the element backward, press
Alt + Up Arrow.

319

Chapter 9: Character Building Rigging

Rigging

s
The rigging process is where building a puppet can take several different directions.
In this section, you will learn how to create a simple rig. Afterwards, you will learn how to add pegs
and create a hierarchy. You can also see more advanced tricks in the Appendix on page 352. For a very
flexible and advanced rig, see Deformation on page 487.
•

About Rigging below

•

Adding Pegs on page 324

•

Rigging the Head on page 325

•

Rigging the Body on page 327

•

Creating a Hierarchy on page 328

•

Ordering the Layers on page 316

•

Adding the Master Peg on page 331

•

Creating the Keyframes on page 332

•

Setting Properties for Many Layers on page 333

•

Masking on page 335

About Rigging
There are some basic concepts to know when rigging and layer parenting:
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•

Simple Rigging below

•

Parenting Layers on the next page

•

Rigging Using Pegs on page 323

Simple Rigging
Simple rigging is very fast and easy to do. It is built as follows:
•

All the body parts are independent

•

All the timeline layers are attached to a master peg layer (trajectory layer)

The advantage of using this technique is that you are free to move any part around without being
influenced by a parent layer.

However, since the parts are not parented to each other, the parts will move from point A to point B
along a straight trajectory. The hand will not follow the arm's rotation. You will have to set more
keyframes for the hand to move along a curved path.
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Parenting Layers

When you want one part to follow another part, such as the forearm following the arm, you can attach
the layers one to the other. For example, you can attach the forearm layer to the arm layer without
having to encapsulate the forearm into the arm layer. They will still be parented, but you can access
the forearm directly without having to enter the arm layer.

The advantage of parenting layers is that the child layers will follow the parent smoothly without
having to select them or create a series of keyframes.
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The disadvantage of parenting layers is that you are not able to move the parent independently of its
children, since the child layers receive all the transformation information from their parent.

Parenting layers, such as the arms and legs, and allowing the torso and hips to be independent from
them is often a good solution.

To attach one layer to another, you must drag the desired layer onto the other one in the
Timeline view.
Harmony offers powerful techniques to create hierarchies between your layers without
having to encapsulate layers into each other. These techniques are a great improvement
over the less efficient and time consuming method of creating parenting between your
layers by inserting symbols into other symbols. Therefore, rigging with symbols inside
symbols is NOT recommended.

Rigging Using Pegs
Peg layer are useful when you are doing more advanced puppet rigging. Peg layers are trajectory
layers that do not contain drawings. They are motion paths that you can use to control your entire
puppet or advanced hierarchies.
Parenting a drawing layer to a peg layer allows you to divide your motions on two separate levels. You
can scale a body part up the chain of pegs directly on the drawing layer. This way, you do not affect
any child layers that could be attached to that part.
Then, you can perform your translation and rotation on the peg layer so all the parts attached to that
peg layer follow the same trajectory.
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Adding Pegs
When it is time to animate your pieces, you must parent them to pegs which are path layers that let
you add keyframes to modify the positions of pieces over time. It is not mandatory, but it is helpful to
have your drawings and keyframes separated—see Disabling the Animation on Drawing Layers on
page 297.

How to parent drawing layers to pegs
1. In the Timeline view, select all the layers.

2. In the Timeline Layer toolbar, click the Add Parent Peg
selected layers.
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s
At this point, in the Network view, the layers look tangled.
3. In the Network View toolbar, select all the modules and click the Order Network Down
in the Network View toolbar.

Rigging the Head
You will start by attaching the facial features to the head.
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The advantage of parenting the head and the facial features to the same peg is that you can easily
animate each facial feature, and they will all follow the head motion.

How to parent the facial features to the head
1. In the Timeline view, deselect any selected layers.
2. Select the head peg layer.

3. In the Timeline View Layer toolbar, click the Add Parent Peg
button to add a new peg layer to
your timeline. You can rename the peg to keep your work organized.

A new peg is added and parented to the head peg layer.
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4. Select all the remaining head and facial feature layers and drag them ONTO the peg layer or
BETWEEN the head peg layer and the new head peg to parent them.

Rigging the Body
Now that the character's head is ready, you can move on to the body. You can do a simple rigging
where all the body parts are independent of each other, or create some parenting between some of
the layers. Refer to Creating a Hierarchy on the next page to learn how to parent your layers.
Simple rigging consists of leaving the layers in the Timeline view without doing any kind of parenting.
Later on, you will attach those layers to a master peg and organize them in the correct order.
Your drawings must be connected to a Composite module. A Composite module takes all the drawing
layers connected in it and flattens them into a single image which allows you to organize your network
and manipulate your puppet easily. It also allows you to apply effects on your complete character. The
Composite module is useful when you are working with many modules in the Network view.
If you create your layers in the Timeline view, they will automatically be connected to the Composite
module in the Network view, as long as you are not using the Display All mode in the Display toolbar.
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Connecting Modules to a Composite Module
In Harmony, if your modules are not connected to a Composite module in the Network view, you can
connect them all at once following the Timeline order.

How to connect your modules to a Composite module
1. If you do not have a Composite module, open a Module Library view. From the top menu, select
Window > Module Library.
2. Select the Filters tab and select the Composite module.
3. Drag the Composite module to the Network view or press Ctrl + H.

4. In the Timeline view, select all the modules you can to connect to your Composite module.

5. Right-click on the selection and select Connect To Composite > select the desired Composite
module.
Your modules are now connected to the Composite module in the same order as the Timeline
view.

Creating a Hierarchy
Harmony lets you extend your rigging techniques beyond normal boundaries and sets new standards.
You can create hierarchies without encapsulating pieces inside each other by creating a linked
structure between layers.
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You should create a hierarchy on the arms and legs, and keep them separated from the body. This
gives you more animation freedom, and when you need to scale or skew the torso, it will not affect the
entire body.

How to create a hierarchy in the Timeline view
‣ Drag the child piece (hand) and drop it ON the parent piece (forearm). Then, you can drag the
parent (forearm) piece onto another parent piece (upper arm).

‣ See See "Nudging Parts Backwards and Forwards" on page 318 to reorder parts that should be in
front of their parents.

How to create a hierarchy in the Network view
‣

Without Pegs: From the parent part, drag a new cable connection out of the module's output
port (bottom) and connect it to the child part module's input port (top).
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‣

With Pegs: From the parent part's peg, drag a new cable connection out of the module's
output port (bottom) and connect it to the child part's peg input port (top).

Here is a basic rig with pegs example:
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Adding the Master Peg

When you animate your character, you will probably need to resize and reposition it to fit your scene.
When you need to scale down or move your character, it is a good idea to hook (attach) the whole
puppet to a trajectory.
Attaching your puppet to a peg will allow you to scale it and reposition it without having to do this to
the different parts and pieces. Only one layer will contain the position information, which makes your
animation easier to modify and control.

How to add a master peg
1. In the Timeline view, select the top layer to parent a peg to it. You need to select a layer to be able
to add a peg to your scene. Unless you use the Display All mode from the Display toolbar, you will
get an error message if you try to add a peg without any selection.
2. In the Timeline view, click on the Add Peg

button.

A new peg is added to the timeline as a parent of the selected layer.
3. Name the new peg Master plus the character's name.
4. In the Timeline view, select all the layers you want to attach to your new peg. Remember that one
item is already parented to that peg.
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5. Drag your selection ON to the peg layer to parent all your character's pieces to the peg. If your
layers are added above the already parented layers, move that parented layer back on top of the
layer stack.

Creating the Keyframes
Once all your drawings are ordered and your master peg is added, you need to insert keyframes on
each cell to create all of the function curves and block your pose in place.

How to create the keyframes
1. In the Timeline view, collapse the master peg by clicking the Expand

arrow.

2. In the Timeline view, select the first cell.

3. Do one of the following:
‣

From the top menu, select Insert > Keyframe.

‣

In the Timeline View toolbar, click the Add Keyframe

‣

Press F6.s

button.

If you use the F6 shortcut when working Flash keyboard shortcuts, this not only creates a keyframe but
also duplicates a drawing.
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Setting Properties for Many Layers
When working with several modules, you may frequently want to modify a series of settings. Instead of
opening the properties for each individual layer, you can set the properties for many layers so you can
change a common setting in a single click.
This allows you to modify the following settings:
•

3D Path or Separate mode

•

Use Embedded Pivot

•

Overlay

•

Line Art

•

Colour Art

•

Underlay

•

Animate Using Animation Tools

You can access this function in the Network View toolbar. You can also add the button to the Timeline View
toolbar through the Toolbar Manager. In the Toolbar Manager, you will find the feature in the script section
under the name Script: TB_Set_Properties_on_manu_layers in TB_Set_Properties_on_many_layers.js.

How to properties for many layers
1. In the Network or Timeline view, select all the layers you want to modify at the same time.

333

Chapter 9: Character Building Rigging

2. In the Network or Timeline View toolbar, click the Set Properties for Many Layers

button.

The Set Properties for Many Layers dialog box opens.

3. Modify the properties. If your modules have different parameters enabled for a certain setting,
leave the As Is option selected to avoid modifying it. Each module will keep its original setting.
Select any other options for all modules to change to this parameter regardless of their original
setting.
4. Click OK.
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Masking

When rigging a character, there will be cases where you want to have the ability to move some pieces
to give the illusion of a rotation or move the pupil within the white of the eye without having the extra
bit of the drawing sticking out of the character or eyeball. To do so, you can use masks to cut anything
you do not want to be visible.

How to mask an object
1. In the Timeline view, make sure the keyframe is added on the object that will be masking the piece
to cut.

2. From the Module Library view, select the Cutter module and drag it to the Network view.
3. Connect the object you want to cut in the Cutter module's right port and connect the Cutter to the
Composite module.
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4. Pull out a second cable from the masking object and connect it in the Cutter module's left port.

5. Your masking effect is most likely inverted and what you want to cut is probably showing. Click on
the Mask module's yellow button to open the Layer Properties window. In the Layer Properties
window, enable the Inverted option.

6. From the Tools toolbar, select the Transform
zone.
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Adding Extra Drawings

Your break down is now complete. You can move on to adding extra drawings your character needs,
such as principal hand positions and mouth shapes. If you ever forget to add extra drawings in your
main character's template, you can easily add them later.

Add your extra drawings in the layer corresponding to the part you are drawing. You should see the layers as
containers for the different pieces. Each body part has its own container in which you can add more
drawings of the same part.

How to add extra drawings
1. In the Timeline view, expand the master peg by clicking the Expand
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2. In the Timeline view, select the cell where you want to add a new drawing. If you want to duplicate
the current drawing and work from it, you can select Drawing > Duplicate Drawings or press Alt +
Shift + D.
A new drawing is created in the selected cell and automatically extended to the next one. The new
drawing is a duplicate of the one that was selected so it contains a duplicate of the art. You can
modify it to create your new drawing or delete its contents in the Camera or Drawing view and
start from scratch.
3. In the Tools toolbar, select a drawing tool for drawing your extra part.
4. In the Camera or Drawing view, draw your new drawing.

5. Using the Select
tool, select your drawing and flatten the lines by clicking the Flatten
button in the Tool Properties view.
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Setting the Pivots

The last step before storing the character in the library is to set the pivots for the different parts.
Harmony has three types of pivots:
•

Peg Pivot
The Peg pivot is a permanent pivot that is applied to the entire drawing layer. If you modify its
position, it will be changed for the entire layer, modifying the animation, scale and rotation
interpolation. The Peg pivot is set using the Rotate, Translate or Scale tool. The Transform tool
will only move that pivot temporarily for positioning purposes, but the animation interpolation will
be done from the original Peg pivot's position. The Transform tool is designed to move the pivot
temporarily during the animation process. It also permits you to select multiple pegs and apply a
common temporary pivot.
To permanently move a peg pivot, use the Rotate
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•

Drawing Pivot
The Drawing pivot is contained within each drawing. In one layer, each drawing can have its own
pivot. If you have many different views of a character within one layer, the pivot can be different and
the animation will adjust to the pivot. The Drawing pivot can also be referred to as embedded
pivot. If you are not mixing different views within the same layers or are using pegs to animate your
layers, it is recommended to use the Peg pivot.

You can set a different pivot for each one of your drawings. For example, if you have a series of
drawings from different views, they are not likely to rotate from the same location. In that case, you
can set a different pivot for these drawings by using the Drawing Pivot
tool—see Drawing Pivot
Tool on page 144.
•

Symbol Pivot
The Symbol pivot is similar to the Drawing pivot. Each symbol cell can have its own pivot and act
the same as the Drawing pivot. The Symbol pivot can also be referred to as embedded pivot.
Inside a symbol, each drawing can have its own pivot. If you are not mixing different views within
the same layers or are using pegs to animate your layers, it is recommended to use the Peg pivot—
see Setting Different Pivots for a Puppet Using Symbols on page 376.

For a simple character rig, it is recommended to set the Peg pivot (even on drawing layers) using the
Rotate
tool.
If you want the puppet's pieces to rotate correctly, you must set the pivot points right in the middle of
an articulation, such as an elbow or a knee.
By default, your master peg pivot is placed at the centre of the Camera view, which generally equates
to your character's hips. A good way to set your peg's pivot is to move it between the character's
feet.
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How to set the pivots with the Rotate tool
1. In the top menu, select Windows > Toolbars > Advanced Animation.
2. In the Advanced Animation toolbar, select the Rotate

tool.

3. In the Camera or Timeline view, select the layer whose pivot you want to set. In the Camera view,
you can also hold down Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click on the piece whose pivot
you want to set.
4. In the Camera view, drag the blue pivot to reposition it. You can also drag the pivot marker to the
desired location.
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5. Repeat the previous steps for all the pieces, including the eyes, nose and mouth.

How to set the master peg pivot with the Rotate tool
1. In the Advanced Animation toolbar, select the Rotate

or Scale

tool.

2. In the Timeline view, select the master peg layer.

3. In the Camera view, click the peg pivot and move it to its new location.

If you added other pegs to your rig, you must set their pivot using the same method.
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Skeleton Optimization
In the Network view, you can add extra modules, such as a Display, and group all the modules to keep
your work organized.
There are four steps to make sure your puppet can be reused efficiently:
•

Deleting the Write Module below

•

Renaming the Display Module below

•

Changing the Composite Type on page 346

•

Grouping Modules on page 346

Deleting the Write Module
The first step in optimizing your network is to delete the Write module, which used for rendering
certain portions of the Network view.
When you render a scene that contains three or four characters and they each have a Write module in
their skeleton, a render is created for each one and they overwrite each other.

How to delete the Write module
1. In the Network view, select the Write module.

2. From the top menu, select Edit > Delete or press Delete.

Renaming the Display Module

The Display module lets you see a section of the network in the Camera view. By renaming the Display
module with your character's name, you can quickly identify it in the Global Display toolbar and isolate
your character to see it better while working on it.
If you do not have a Display module in your network, you can add one by selecting one from the
Module Library view and dragging it into the Network view.
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How to rename your Display module
1. In the Network view, click on the Display module's Properties button to open the editor.

2. In the Layer Properties window, rename the Display module with your character's name.

3. Click Close.

How to add a Display module
1. In the Module Library view, select the IO tab and select the Display module.
2. Drag the module to the Network view.

3. Connect the Composite module's output port into the Display module's input port.
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Changing the Composite Type
When you create a character with Harmony, you have to connect all your modules in the Composite
module. The Composite module takes all the different images coming out of your drawing modules
and flattens them into one single image.
This is useful when it is time to apply an effect to your entire character or group your layers for a more
organized network.
The regular Composite module will flatten all the pieces into one image preventing interaction with
props or characters connected to a different Composite module. That is why you have to change the
Composite module's type to a special one that will still output one single image but will not flatten the
drawings together. This will allow you to nudge your drawings on the Z-axis so that parts of you
characters can pass in front and behind other characters and objects. This Composite type is called
Pass Through.

How to change your Composite module to a Pass Through type
1. In the Network view, click on the Composite module's Properties button.

The Layer Properties dialog box opens.
2. From the Mode menu, select Pass Through.

3. Click Close.

Grouping Modules
Once your rigging is completed, you must group the puppet's skeleton to help organize the often
large and complex networks. This way, once you have imported two or three characters into the
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scene, three Group modules will be displayed instead of all the rigging connections of three puppets.

How to group modules
1. In the Network view, select all your modules.
2. In the top menu, select Edit > Group > Group or press Ctrl + G (Windows/Linux) or ⌘ + G (Mac
OS X).
Your modules are grouped.
3. Click on the Group module's right arrow to enter the group.
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4. If you do not have a Multi-Port Out module inside your group, in the Module Library view, go to the
Group tab and select a Multi-Port Out module.

5. Drag the Multi-Port-Out module to the Network view.
6. Connect the Composite module's output port into the Multi-Port Out module.
An output port is created on your Group module.
7. In the bottom-left corner of the Network view, click Top to return to the network's root. You
should now see an output port on your Group module.

8. Click on the Group's Properties button to open the Layer Properties window.

s
9. In the Layer Properties window, rename the Group module with your character's name.
10. Click Close.
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Storing the Character in the Library
For maximum efficiency and reuse of your character in different scenes, you must store a template in
the Library view. You can create different kinds of templates, such as templates that include all the
layers, a template for a body, key pose or even some containing only the head.
Harmony has a Timeline and a Network view. The Timeline view represents the layers in a linear and
simple way. The Network view lets you create all sorts of complex connections that the Timeline view
cannot display. This means that:
•

Any template created from the Timeline view must be imported in the Timeline view.

•

Any template created from the Network view must be imported in the Network view. These
templates are also referred to as master templates.

It is highly recommended that you create a cut-out puppet's main template (master template) from the
Network view since it contains advanced connections, Display modules and Composite modules.

How to create a template from the Network view
1. In the Library view, right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.

3. If your scene has a series of blank cells, they must also be included in the template if you drag the
layer to the Library view. Reduce the scene length so there are no empty cells before creating your
template.
4. Add a keyframe on the collapsed character.
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5. In the Network view, select your character's group and in the top menu, select Edit > Copy. In the
Library view, select the folder in which you want to store the template and in the top menu, select
Edit > Paste.

The Rename dialog box opens.

6. In the Name field, type in a name for the template.
7. Click OK.

How to create a key pose template
1. In the Library view, right-click on the desired library folder and select Right To Modify.
2. In the Timeline view, collapse the master peg layer.
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3. Select the cell containing the desired view and drag it into the desired library folder.

The Rename dialog box opens.

4. In the Name field, type in a name for the template.
5. Click OK.

When you create a template from the Timeline view, you must first import your master
template in order for everything to work properly when you reimport it into a scene.
Once the master template is imported, you can import the key pose template's content
into the right side of the Timeline view.

When you create a template from a keyframe in the Timeline view's right side, it only copies the
drawings and keyframes. It does not copy all of the network's advanced connections and
composites. If you import a Timeline template in the Network view or in the Timeline view's left side,
your layers will be in the wrong order and will not be connected to a composite.
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Appendix

The many options and animation techniques available for building a puppet make it impossible to
determine only one method to break down a character. Here are some advanced tips on breaking
down puppets. As you become more familiar with the software, you will find more ways to improve
the construction of your puppet.
This section is divided as follows:
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•

Break Down: Cutting the Character in Pieces below

•

Break Down: Distribute to Layers on page 364

•

Break Down: Creating Ghost Drawings on page 365

•

Converting the Layers into Symbols on page 368

•

Patch Articulation on page 371

•

Setting Different Pivots for a Puppet Using Symbols on page 376

•

Setting Pivots on a Frame Range on page 378

•

See "Adding New Drawings to an Existing Template" on page 379

Break Down: Cutting the Character in Pieces

If you do not want to redraw all the artwork for your character, you can use the cut away technique
where, with the Cutter tool, you select and send pieces of the model on a new layer.
The first step in breaking down your character is to do a rough cut down of the main parts, such as the
body, arms, legs and head. Using the Create Drawing from Drawing Selection feature lets you
automatically create layers and copy your selection in it.
This section is divided as follows:
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•

Breaking Down the Main Parts below

•

Breaking Down the Secondary Parts on page 356

•

See "Selecting and Incorporating to an Existing Layer" on page 359

•

Breaking Down the Extra View Main Parts on page 360

•

Breaking Down Secondary Parts in the Extra Views on page 361

Breaking Down the Main Parts
To break down the main body parts, you will use the Create Drawing From Drawing Selection feature.
There is no need to create any layers prior to this process, you need to have your model well centered
and sized in the Camera view.
You do not need to make clean cuts around your parts; a rough one is sufficient as long as it includes
all the artwork of the part you want to break down. You will clean the extra bits and pieces later.
Using the Cutter tool, you will roughly cut the main sections, and then use the Select tool to select
precise lines and colour zones.

How to break down the main parts
1. In the Timeline view, select the model's cell that corresponds to the first view to break down.

2. In the Tools toolbar, select the Cutter

tool.

‣

If you prefer to use the Select tool, choose the Select
press Alt + S.

‣

In the Tool Properties view, you can switch to the Lasso

tool from the Tools toolbar or
selection mode.

3. In the Camera view, create a selection around the first part to break down. If you click on a zone,
the Cutter tool will select the zone. It will end the selection at the first point of intersection that it
meets.

354

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

‣

Hold down Shift to create a new lasso selection around another zone and add it to your
previous selection.

4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (Mac OS X).
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, type the name of the layer you want to create following the naming
convention you established previously.
6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original
drawing. You do not want to cut the artwork from the colour model.
7. Click OK.
The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.
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8. Repeat step 1 to 7 for each main body part.

Breaking Down the Secondary Parts

You should now have a layer for each main part of the character for the first view to break down. You
are now ready to break down those main pieces into smaller ones.
Breaking down the secondary parts is similar to the main part break down process except that this
time you will cut away the artwork from the layer it has been selected from.

How to break down the secondary parts
1. In the Timeline view, lock your model layer by clicking its Lock
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2. In the Timeline view, select the cell that corresponds to the main part you want to break down.

3. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, choose the Select
press Alt + S.

tool from the Tools toolbar or

4. In the Camera view, create a selection around the part to break down.

‣

If you click on a zone, the Cutter
tool will select the zone and end the selection at the first
point of intersection that it meets. Click on the line with the Cutter tool to select it up to the
next intersection.

5. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (Mac OS X).
The Create Drawing From Drawing Selection dialog box opens.
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6. In the Layer Name field, type the name of the layer you want to create following the naming
convention you established previously.
7. Select the Cut Artwork From Source option to remove the selected artwork from your original
drawing. In this case, you want to cut the artwork from the colour model.
8. Click OK.
The new layer is created and your selection is copied in it. The drawing is created in the same frame
number as the cell it was taken from.
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9. Repeat steps 2 to 8 for each body part.

If you forgot to add some artwork to a layer you previously created, you can always add it
later.
In the Camera view, select the artwork to send to the existing layer. Open the Create
Drawing from Drawing Selection dialog box by pressing F9 (Windows/Linux) or ⌘ + F9
(Mac OS X). In the dialog box, select an existing layer from the list instead of typing a new
name. Click OK to add the artwork to the existing drawing in the layer you selected.

Selecting and Incorporating to an Existing Layer
Your first view should now be completely broken down. If your articulations are still rough and bits and
pieces are missing you will fix those in the next step.
If your character model has more than one view, now is the time to break them down.
The process is very similar to breaking down the first view. You have two choices:
•

Breaking down the new view in a net set of layers

•

Braking down the new views in the same existing layers
If your layers are not in the correct order, you can reorder them later. Simply add the part that you
are breaking down to the layer you previously created for the same body part.

Start by breaking down the main pieces, as you did before. The secondary parts will be broken down
later on.
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Breaking Down the Extra View Main Parts
Repeat the following steps for each extra view you need to break down.

How to break down the other views
1. In the Timeline view, selected the model's cell corresponding to the view to break down. Don't
forget to unlock the layer.

2. In the Tools toolbar, select the Cutter
‣

tool.

If you prefer to use the Select tool, in the Tools toolbar select the Select
Alt + S.

tool or press

3. In the Camera view, create a selection around the first part to break down.

4. From the top menu, select Edit > Create Drawing From Drawing Selection or press F9
(Windows/Linux) or ⌘ + F9 (Mac OS X).
The Create Drawing From Drawing Selection dialog box opens.

5. In the Layer Name field, select the corresponding layer from the list if you want to use the same
layers or type a new name if you want to create a new layer.
6. Deselect the Cut Artwork From Source option to keep the selected artwork on your original
drawing. You do not want to cut the artwork from the colour model.
7. Click OK.
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The artwork is inserted into the existing layer. The drawing is created in the same frame number as
the cell it was taken from. It is not incorporated in the other view's drawings.

8. Repeat step 1 to 7 for each main body part.

Breaking Down Secondary Parts in the Extra Views
To break down the secondary parts for your extra views, follow the exact same process as you did for
the first view you broke down, but you will incorporate the new parts in the existing layers—see
Breaking Down the Secondary Parts on page 356.
Each view can have its own set of layers in the Timeline view, therefore each view does not necessarily
need to have the same layer structure.
Here is an example of how your timeline should look at this stage:

Completing the Parts and Articulation
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Now that all the layers are created and the parts are basically broken down, it is time to clean up the
parts and complete the articulation.

Cleaning the Parts
You will need to use a series of drawing tools to clean the parts:
•

Brush tool

•

Eraser tool

•

Select tool

•

Cutter tool

•

Contour Editor tool

•

Paint tool

•

Close Gap tool

How to clean your drawings
1. In the Tools toolbar, select the drawing tool you need to fix your drawings.

2. In the Timeline view, select the cell containing the drawing to fix.
3. In the Camera view, delete the extra bits using the Select
the Eraser
tool.
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4. Draw the missing lines using the Brush
tool. If you use the Brush tool, it is recommended that
you enable the Auto-Flatten
option in the Tool Properties view.

5. Using the Paint
tool, paint the gaps. You can close some gaps with invisible lines using the
Close Gap
tool or press Alt + C.

6. Reshape your lines using the Contour Editor

tool or press Alt + Q.

7. Using the Select
tool, select the entire drawing and click the Flatten
Properties view to flatten your drawings.

button in the Tool

8. From the top menu, select View > Show > Show Strokes to display the invisible lines that could
be present in your drawing or press K.
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9. From the top menu, select Drawing > Optimize > Remove Extra Strokes to remove any
unnecessary invisible lines in the drawing.
10. Repeat this entire process for each drawing to fix.

Break Down: Distribute to Layers
When breaking down a character, you can distribute each selected art stroke to a new layer.
Each stroke you select in the Camera view is automatically placed on a new layer. One layer per stroke.
If one part of your puppet is composed of several strokes, you must group them before distributing
them onto new layers.

You cannot distribute layers in the Drawing view; it must be done in the Camera view.

How to distribute to layers
1. In the Tools toolbar, click the Select

tool.

2. In the Camera view, select the art strokes you want to distribute to different layers.

3. From the top menu, select Drawing > Distribute to Layers or click the Distribute to Layers
button in the Tool Properties view.
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Drawing layers are created in the Timeline view, each corresponding to the different strokes or
groups of strokes selected. Each stroke or group of strokes is distributed into each new Drawing
layer. The selected strokes in the original drawing layer are removed.

Break Down: Creating Ghost Drawings

At this point, your basic breakdown should be almost complete. There is one optional step you can do
before moving on, and that is to add extra drawings and expressions to your character called adding
ghost drawings.
Right now, the Timeline view looks something like this:
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Some parts have no drawings in certain views. For example, the left eye has no drawing available for
the Side view. To make your puppet more efficient when you animate, a good trick is to add invisible
drawings that you can select even when no image is necessary.

Creating ghost or invisible drawings can be very useful if you need to select a part of your character for
use with Drawing Substitution feature or Inverse Kinematics tool, or to avoid having the system
automatically fill in the exposure gaps when swapping images.
To create ghost drawings, copy one of the existing drawings, paste it in the empty cell and repaint it
with a fully transparent colour.

How to create ghost drawings
1. In the Colour view, add a fully transparent colour to your character's palette.

2. In the Timeline view, select the cell containing the drawing to copy and use to create the invisible
drawing.
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3. In the Tools toolbar, select the Select

tool or press Alt + S.

4. In the Camera or Drawing view, select the drawing to copy.

5. From the top menu, select Edit > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).
6. In the Timeline view, select the empty cell where you want to create your ghost.

7. Go to the Camera or Drawing view.
8. From the top menu, select Edit > Paste or press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).
9. In the Tools toolbar, select the Select
body's area.
10. In the Tools toolbar, select the Paint

tool or press Alt + S, and offset the drawing outside the
tool or press Alt + I.

11.In the Colour view, select the transparent colour.

12.In the Camera or Drawing view, repaint the drawing to make it invisible.

The Timeline view should look like this:
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At this point, you can convert the layers to symbols—see Converting the Layers into Symbols below.

Converting the Layers into Symbols

Converting your layers into symbols is optional. When animating, you will need to enter the symbol to create
a new drawing. IF YOU WANT TO USE MORPHING WHEN ANIMATING, KEEP YOUR LAYERS AS
DRAWINGS. DO NOT USE SYMBOLS.

Once the breakdown is completed, you can create symbols out of each drawing. The symbol will
encapsulate each drawing of the layer. Later on, even if you only expose the first frame, such as the
front head, you will still have access to all of the head drawings you placed in the symbol. This will also
allow you to add more drawings, as your characters' master templates will evolve throughout the
production of your movie or series.
All your layers should be stored in the library as symbols. Before building your puppet, remove all the
current layers in your scene. All of your work is saved in the library.
If you are not sure that you put everything in your library, you can always perform a Save As on your
scene and work on a new version.
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How to create a symbol
1. Create a symbol by doing one of the following:
‣

From the Timeline view, drag the layer to the Symbols library folder.

‣

In the Timeline view, select the layer to convert to a symbol. From the top menu, select Edit
> Create Symbol or press F8. You can also click on the Create Symbol
button available
in the Edit toolbar.

The Create Symbol dialog box opens.

2. In the Enter Symbol's Name field, type the new symbol's name. It is recommended that you keep
your original layer's name.
3. Click OK.
4. Repeat this process for each layer in the Timeline view.

Make sure all your layers are stored in the symbol library.

How to save your scene as a new version
‣ From the top menu, select File > Save As. You can also click the Save As
the File toolbar.
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How to clean the Timeline view
1. In the Timeline view, select all of your layers.

2. In the Timeline's Layer toolbar, click the Delete Layers

button.

3. In the Confirm Delete dialog box, click OK.
Your timeline is now ready to receive the body part symbols for the rigging process.

Your Network view should look like this:
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Patch Articulation

The Harmony advanced rigging can use an articulation fixing technique called Patch Articulation. This
technique is a colour fill patch that is drawn on a third layer and is used to cover the joint lines. It is a
simple, yet powerful method.

With this technique, you avoid having to create a correction layer at the end of the animation to fill the
gaps in the joints. You do not need to worry about the articulations at all. Once a patch is set, the
articulation is fixed for the entire length of the animation.
To make this technique even more efficient, Harmony lets you draw the patch inside the same
drawing, but on a separate contained layer. The Line Art and Colour Art layers are not only useful in
traditional ink and paint, but also in advanced cut-out breakdown. You can draw the patch in the
Colour Art layer and extract it in the Network view. The advantage of doing it this way is that when
animating and using the drawing substitution, the patch drawing will change at the same time as the
main drawing.

How to create a patch articulation
1. In the Tools toolbar, select the Transform

tool or press Shift + T.

2. If you plan to create your patch on an independent layer, do the following. If not, go the next step.
‣

In the Timeline view, add a new drawing layer by clicking the Add Drawing Layer
or press Ctrl + R (Windows/Linux) or ⌘ + R (Mac OS X).
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3. In the Camera view, select the part for which you want to create a patch. For example, if you are
fixing the elbow articulation, select the arm or forearm drawing to edit it.

4. In the Tools toolbar, select the Select

tool or press Alt + S.

5. If you drew your lines with pencil lines, it is recommended to convert them to brush lines (fill
shapes):
‣

In the Camera view, select the pencil lines.

‣

In the Tools Properties view, click the Convert Brush Strokes to Pencil Lines
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‣

In the Camera view, select the piece's outline and fill.

‣

In the Tool Properties view, click the Flatten
under the contour stroke.

button to remove the excess colour fill located

If you want to keep your lines as pencil and create a patch joint, you will need to use the Auto-patch
Articulations on page 305 module.

6. In the Camera view, select the fill zone of the part's drawing.
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7. In the Camera view, right-click and select Copy.
8. To paste the selection:
‣

If you are using the recommended method, which is to paste your selection in the Colour
Art, in the Art Layer toolbar, click the Colour Art
button.
OR

‣

If you are using an independent layer, in the Timeline view, select the cell in which you want to
create the patch.

9. In the Camera view, right-click and select Paste.
10. In the Tools toolbar, select the Cutter

tool.

11.In the Camera view, make a selection around the pasted zone to cut everything out but a small
overlapping zone to cover the articulation.

12. To extract the patch from the Colour Art layer:
‣

In the Network view, select the module containing the drawing with the patch.

‣

Copy and paste the selected module. Note that when you copy and paste from the Network
view, by default it creates a clone, so any changes that are made to one affect the other.

‣

Click on the module's yellow button to open the Layer Properties window.

‣

In the Name field, add the word patch to the module's name.

‣

Close the Layer Properties window.
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13.In the Module Library, select the All Module tab. Drag a Colour Art module and connect it below
the Patch module.

14.In the Network view, connect the main part you create the patch from and parent it to the patch
module.

15. Select the patch module's connection to the Composite module and drag it in front of the piece to
be covered. In this case, the elbow patch is parented to the arm and connected in front of the
forearm.
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16.Repeat the process for each articulation which requires fixing.

Setting Different Pivots for a Puppet Using Symbols
If you want the puppet's pieces to rotate correctly, you must set the pivot points onto the
articulations. You can set the pivots using the Rotate tool which sets it for the entire layer or you can
set the pivots directly on your symbol and have a different pivot for each symbol cell. By default, when
you create symbols, the symbol pivot is located at the centre of your drawing. You will need to move it
onto the shoulder or elbow.
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You will set the pivot on the symbol's cells, not directly on the drawings. To set your pivots, you must
be at the top level of your character building scene and not inside the symbols.
By default, when you set the pivot onto a symbol, all the cells use the same pivot. If you need different
pivots for different cells, refer to the following procedure.
Do the following steps for each layer in the Timeline view.

How to set the pivots for the body parts
1. In the Tools toolbar, select the Drawing Pivot
Pivot.

tool or select Drawing > Tools > Drawing

2. In the Camera or Timeline view, select the symbol on which you want to set a pivot.

3. If you only want to set one pivot for your symbol, in the Tool Properties view, select theSet the
Pivot for Symbol on All Frames
button.

‣

Deselect this button if you want to set a series of different pivots for your symbol's cells.

4. In the Camera view, click where you want the pivot to be. You can also drag the pivot marker to the
desired location.
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5. If you want to set a different pivot for another drawing or symbol cell, select the drawing or cell
and in the Camera view, set the new pivot.
Make sure the Set the Pivot for Symbol on All Frames button is deselected.

Setting Pivots on a Frame Range
If you are using the drawing pivots rather than the Rotate tool pivot and if some elements need the
same drawing pivot, such as all of the three-quarter hands, you can select all of these hands cells and
set the pivot all at once. If your pivot is already correctly set on your first drawing, copy and paste that
pivot onto the other drawings in the Timeline or Xsheet view.

You must have the same drawing pivots on the extra parts from the same angle. If you substitute a
drawing while the part is rotating, the animation risks popping out of place if the pivot is uneven.

How set the drawing pivot of a frame range
1. In the Drawing or Camera view, set the first drawing pivot of the series. For example, set it on
hand-1.

2. In the Timeline view, select the cell that contains the correct pivot.
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3. From the top menu, select Edit > Copy.
4. In the Timeline view, select the cell range that requires the same pivot.

5. From the top menu, select Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac
OS X).
The Paste Special dialog box opens.

6. In the Paste Special dialog box, select the Advanced tab.
7. In the Drawings section, select the Update Drawing Pivot option.
8. Click OK.

You can also copy and paste the pivot from one drawing to another using the keyboard shortcuts Ctrl + C
and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (Mac OS X) when the drawing pivot tool is active and
the focus is around the Camera view.

Adding New Drawings to an Existing Template
How to add new drawings to an existing drawing template
1. In the Library view, right-click on the library folder containing the template to modify and select
Right To Modify.
2. In the Library view's right side, right-click on the extra drawings template to modify and select Edit
Template.
A new instance of Harmony opens.
3. In the Tools toolbar, select a drawing tool.
4. In the Colour view, select a colour.
5. In the template's timeline, select the blank cell where you want to draw your new piece.
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6. In the Camera or Drawing view, draw the new pieces.

7. If you are using drawing pivots, in the Tools toolbar, select the Drawing Pivot
tool and in the
Camera view, set the pivot directly on the new drawing's cell. If you are using symbols and symbol
pivots, you do not set the pivot on the symbol's cell.
8. From the top menu, select File > Save or press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).
9. From the top menu, select File > Quit (Windows/Linux) or Stage > Quit Toon Boom Stage (Mac
OS X).
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Chapter 10: Library

Using symbols and templates, you can share and reuse any elements you create in Harmony. The
Harmony library lets you store several different elements such as puppets, backgrounds, animations
and key poses. In fact, anything you create in Harmony can be stored in the library.
This chapter contains the following topics:
•

Understanding the Library Concept on the next page

•

Library View on page 384

•

Structuring the Library on page 387

•

Templates on page 399

•

Symbols on page 391

•

Importing Symbols and Templates on page 403

•

Importing Files Through the Library on page 409

•

Using Paste Special on page 410
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Understanding the Library Concept

Understanding the Library Concept
The Library view is where you can store and reuse your artwork and animation in other scenes or build
props and puppets.
•

What is a Library? below

•

What is a Symbol? below

•

What is a Template? on the facing page

•

Understanding the Library Concept above

What is a Library?
A library is a folder where you store symbols and templates. You can access these folders from
different projects. Using the library is as simple as dragging the content into the library to store your
artwork and then dragging it to the Timeline or Camera view when you want to reuse it.
You can organize your library using several different subfolders and store them on your hard drive or
network.

What is a Symbol?

A symbol is a container used to build your props, puppets and looping clips. You can use symbols to
contain artwork and animation and manipulate them as a single object. You can also use symbols as a
placeholder in which you place a series of different drawings for each body part of your puppets or
when you have a repeating cycle. However, symbols are not necessary for creating characters.
To create a symbol, drag your artwork to the Symbol library. When you drag a symbol from the
Symbol library into your scene, it will be linked to the original symbol. If you drag a symbol into your
scene several times in the Timeline view, they will all be linked to the original symbol. If you modify one,
they will all be modified.
A symbol is local to the project and cannot be accessed directly from other scenes. To reuse a
symbol's content in another scene, you must create a template out of it.
When a symbol is exposed in the Timeline view, the symbol's cells are represented as a movie strip.
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What is a Template?

A template is an individual copy of the artwork stored in the library which you can reuse in different
scenes. Once a template is stored in the library, you can access it from any project.
Dragging a template into your scene copies the content in your Timeline and does not link it to the
original. Yo can modify this individual copy at any time.
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Library View

Library View

You use the Library view to create and manage your symbols and templates, display the folders and
manage and all of the content.

Library View Menu
The Library View menu lets you access commands specific to the Library view, such as opening a
Library or getting the rights to modify a library folder.

Preview Window

The Preview window lets you preview the content of a symbol or template, and swap between
drawings and symbol cells in the Timeline view. This window is also used as the Drawing Substitution
window.

How to preview a template or symbol's content
1. In the Library view's right side, click or double-click on the symbol or template to preview.
2. In the Preview window, click the Play

button or drag the slider to scrub through the frames.
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Library Search Tool
When working on a movie or series, you will probably end up with many templates and symbols in
your library. Using the Search tool, you can quickly find the templates and symbols in your folders.

How to use the Library Search tool
1. From the left side of the Library view, select the library in which you want to search.

2. In the Search field, type the name or partial name of the symbol or template you are looking for.

3. Click the left
and right
arrows to see the previous and next results. The Search engine
will look for results within the library master folder and its subfolders. It will not look in other
libraries.

Library List

The Library list lets you navigate through the different libraries and subfolders. You can also open,
close and create new libraries from here.
The Library folders have these default libraries:
•

Symbols: The only library folder containing symbols for your project. You can organize the
symbols library folder using subfolders, but you cannot create a second library for your symbols.
This library is local to your project.

•

Harmony Library: This folder contains templates and is stored on your hard drive. You can
organize the Harmony library folder using subfolders. This folder does not contain symbols.
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Library View

Templates and Symbols List

s
The symbols and templates contained in the selected Library list can be displayed on the right side of
the Library view as thumbnails, in a list or as details.

How to access the templates and symbols list display options
‣ In the Library view's right side, right-click and select View > List, Thumbnails or Details.
‣ In the Library View toolbar, you can click the following buttons:
Thumbnails
List
Details
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Structuring the Library
As you will probably create a large number of symbols and templates, you will soon realize they need
to be organized. You can create different libraries and subfolders to easily access your assets. For
example, you can create a different library for each project and divide it into several categories, such
as:
•

Characters

•

Props

•

Backgrounds

Although you can only have one symbol library folder, you can organize it by creating subfolders.
There are two ways to create library folders.
•

Directly through your operating system

•

Using Harmony's interface

Folders can be opened in Harmony when you require it. You can open any folder on your hard drive or
network as a library. Opening a library means linking the folder to your Library view. You only need to
open the library once. The library folder is available every time you open the application until you
decide to close the library and unlink it.
You may not always require all the library folders in the Library List. If so, you can close the ones you
do not need. Closing a folder does not delete it; it only unlinks it from the Library view. If you want to
reopen it, locate it on your hard drive or network and open it in the Library view.
Symbol and template libraries need to be organized. You can create different subfolders on your hard
drive or in the Harmony Library view, so you can easily access assets. By default, any new library you
link to your Library view is locked to prevent accidental deletion or modification of symbols and
templates. You must obtain the right to modify it before being able to add a new folder to it.
You can delete a folder from the library if its contents are no longer needed.

Warning: All templates and symbols in the folder will be deleted from your hard drive. Once deleted, the
data cannot be retrieved.

Once you add a folder, you can rename it. This also renames the folder on your hard drive.
If you update the content of your libraries through your operating system, you will need to refresh your
library folders in the Library view.
When you display thumbnails in the Library view, the system generates a series of small images
(thumbnails) for you. You can generate template thumbnails yourself, if they do not display or if the
process has been stopped.
You can also delete thumbnails if you want to send a template to another user or studio and keep your
packages small.

How to create a library folder through your operating system
1. On your computer, create a new folder with a relevant name in the location where you want the
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Structuring the Library

library to be stored.

How to create a library folder in Harmony
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse for the location where you want to store your new library folder.
3. Click the New Folder button.
A new folder appears.
4. Name the new library folder with a relevant name and click OK.
The new library appears in the Library List section.

How to open a library
1. In the Library View menu, select Folders > Open Library.
The Browser window opens.
2. Browse to the location of the library folder.
3. Select the folder and click OK.
The new library appears in the Library Folders section.

How to close a library
1. On the right side of the Library view, select the library folder to close.
2. In the Library View menu, select Folders > Close Library.
The library closes.

How to create a folder
1. On the left side of the Library view, select the library folder to which you want to add a subfolder.
2. In the Library View menu, select Edit > Right to Modify.
3. In the Library View menu, select Folders > Nesw Folder.
The new folder appears in the Library. Click on the library containing the new folder and click the
plus [+] sign to expand it.
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How to delete a folder
1. In the Library view's left side, select the folder to delete.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and
select Right to Modify.
3. In the Library View menu, select Folders > Delete Folder or press Delete.

How to rename a folder
1. In the Library view's left side, select the folder to rename.
2. In the Library View menu, select Edit > Right to Modify or right-click on the selected library and
select Right to Modify.
3. In the Library View menu, select Folders > Rename Folder.
4. Rename the selected folder.

5. Press Enter/Return to validate the operation.

How to refresh a library
1. In the Library view's left side, select the folder to refresh.
2. In the Library View menu, select Folders > Refresh or press F5.
The library displays the new content.

How to generate thumbnails
1. In the Library view's right side, select the template in which you want to generate thumbnails.

2. In the Library View menu, select View > Generate Thumbnails.
The progress bar appears.
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How to delete thumbnails
1. In the Library View menu, select Edit > Delete Thumbnails.
All the thumbnails contained in the library are removed.
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Symbols

A symbol combines animation, artwork or layers into a single object that you can control in one layer.
You can also create symbols out of each body part in your cut-out puppets.
You do not need to create symbols in order to create drawings or characters in Toon Boom Harmony.
When you delete a symbol, it will be deleted from your hard drive. You can use the Undo function to
retrieve the data. The symbol cannot be retrieved once you close the application.
When you import a symbol from the library to the Timeline view it is linked to the original symbol in the
library. If you import a symbol into your scene several times in the Timeline view, they will all be linked
to the original symbol. If you modify one, they will all be modified.
If you want to edit a symbol without modifying the other instances, you must duplicate the symbol
first. If other symbols are nested inside the new symbol, they are not duplicated. If you modify them,
the original and other instances will also be modified.
You can either edit a symbol from the Timeline view or from the Library view.
When you edit a symbol, the drawings contained in it are not placed at the centre of the stage, but are
located in the position where they were created. The pivot is translated at the centre of the symbol.

When you enter a symbol to edit it, you are entering another scene with an independent timeline. You
can nest many symbols one inside the other. To help you follow the hierarchy of your nested symbol,
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take note of the Editing stack at the top of the Camera view which displays the path to your symbol's
location. You can click on the symbol's name to move up the chain.
You can share a symbol and use its contents (the drawings) in another scene. To do this, you must first
convert your symbol into a template. This conversion breaks the drawing's link with both the original
scene and symbol. It then becomes a separate entity that you can import into other projects.

How to create a symbol from a drawing selection
1. In the Tools toolbar, select the Select

or Cutter

tool.

2. In the Camera view, select the drawing elements to create a symbol.

3. From the top menu, select Edit > Create Symbol or press F8.
‣

Clicking the Create Symbol
entire layer.

button in the Edit toolbar will create a symbol from the

The Create Symbol from Drawing Selection dialog box opens.

4. In the Symbol Name field, type the name of the symbol.
‣

You can also select an existing layer from the Symbol Name drop-down menu. It will add
your symbol on the layer's current cell. If there is already an exposure on that cell, the
symbol will be added to a new layer.

5. You can choose to place the current selected artwork in the drawing or remove it:
‣

To remove currently selected artwork from the drawing and place it in the new symbol,
select the Cut Artwork From Source Drawing option.

‣

To keep currently selected artwork in both the drawing and in the new symbol, deselect the
Cut Artwork From Source Drawing option.

6. Click OK.
The new symbol appears in the Library view's symbol folder and in the Timeline view as a new layer.
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How to create a symbol from the Timeline view
1. In the Timeline view, select the layer or cells from which your want to create a symbol.
2. Do one of the following:
‣

From the top menu, select Edit > Create Symbol.

‣

In the Edit toolbar, click the Create Symbol

‣

Press F8.

‣

Drag your selection to the Symbol folder in the Library view.

button.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.
The new symbol appears in the Library view's Symbol folder. The current selection is not replaced
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to
use it.

How to create a symbol from the Network view
1. In the Network view, select the modules from which you want to create a symbol.
2. Do one of the following:
‣

From the top menu, select Edit > Create Symbol.
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‣

In the Edit toolbar, click the Create Symbol

‣

Press F8.

‣

Copy and paste Ctrl + C and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (Mac OS X)
your selection to the Symbol folder in the Library view.s

button.

The Create Symbol dialog box opens

3. In the Enter Symbol's Name field, type the new symbol's name.
To rename a symbol once it is created, right-click on the symbol and select Rename.
4. Click OK.
The new symbol appears in the Library view's Symbol folder. The current selection is not replaced
by the new symbol. The new symbol only appears in the library. You must drag it into your scene to
use it.

How to create an empty symbol
1. In the Library view, select the Symbol folder.
2. Do one of the following:
‣

In the Library view's right side, right-click and select New Symbol.

‣

From the top menu, select Insert > Create Empty Symbol in Library.

The new empty symbol appears in the Library view.
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The symbol is ready for you to edit (add content to). To go back to the root timeline, click the Top
button in the Camera view.
To rename a symbol once it is created, right-click on the symbol and select Rename.

How to delete a symbol
1. In the Library view, select the symbol to delete.
2. Right-click and select Delete or press Delete.
‣

If the symbol is currently in use in the scene, a warning message displays. Click OK to delete
the symbol from the library and scene.

How to edit a symbol from the Timeline view
1. Do one of the following:
‣

In the Timeline view, double-click on the symbol's cell to edit the symbol.

‣

In the Camera view, double-click on the symbol or press Ctrl + E (Windows/Linux) or ⌘ + E
(Mac OS X)).

‣

Click the Edit Selected Symbol

button in the Camera View toolbar's extra buttons.
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You are now inside the symbol and you are able to edit it.

2. Do one of the following:
‣

Click the Top
button in the Camera view's top-left corner to return to the project's
timeline or press Ctrl + Shift + E (Windows/Linux) or ⌘ + Shift + E (Mac OS X).

‣

In the Timeline view's right side, right-click and select Symbols >Leave Current Symbol.

How to edit a symbol from the Library view
1. In the Library view, select the symbol to edit.
2. Right-click and select Edit > Edit Symbol or double-click on the symbol.
You are now inside the symbol and you are able to edit it.
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‣

Click the Top
button in the Camera view's top-left corner to return to the project's
timeline or press Ctrl + Shift + E (Windows/Linux) or ⌘ + Shift + E (Mac OS X).

How to duplicate a symbol
1. In the Timeline view, go to the frame where you want to duplicate the symbol.
2. Select the symbol's cell.

3. From the top menu, select Edit > Duplicate Selected Symbol.
In the Library view, the symbol is duplicated and in the Timeline view, the current cell and its held
exposure is replaced with the new symbol. You can now modify the symbol's content.

How to convert a symbol into a template
1. From the Library view, select the symbol to convert into a template and drag it to the Camera or
Timeline view. If you drop your symbol into the Camera view instead of the Timeline view, it will not
be placed in the centre of your camera frame, but rather wherever your cursor drops it within the
camera frame.

2. In the Timeline view, select the symbol's cells or layer and drag it to the Stage Library folder or to
any other library folder. Make sure you have the right to modify the library folder.
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3. In the Rename dialog box, rename the new template.

4. Click OK.
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Templates

When you want to reuse artwork and animation from your project in other scenes, you must create a
template from it. A template can be seen as a portable scene or package that you can drag inside your
project. You can open a template and edit it just like any other project. If you want modify your
templates, you can edit them using the Edit Template command.
You can create a template from both the Timeline and Network views:
•

Master Template below

•

See "Creating a Template from the Network View " on page 399

•

See "Action Templates" on page 401

•

Creating a Template from the Timeline View on page 401

To delete templates from your library, use the Library view. Harmony lets you undo the action if
necessary.

Master Template
You can create a master template out of a cut-out puppet you created so you can reuse it throughout
a single project or a full production. A cut-out character's master template stores the entire rig,
structure, drawings, and keyframes of the different poses of your puppet into a single asset.
Master templates are created from the Network view.

Creating a Template from the Network View
The Timeline and Network views display different information about a scene.
A main character's template, also known as a master template, is created from the Network view. This
template contains all the connections, effects, composites, modules, pegs, advanced groupings,
function columns, scene lengths, drawings, timings, and so on. The template is saved in the Library
view and must be imported back into the scene for use, either into the Network view or the left side of
the Timeline view.

If you are creating a template from a character rig master template, you should collapse everything inside a
master peg and put a keyframe on the first frame before creating the template.
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How to create a template from the Network view
1. In the Library view, select the folder in which you want to store the template.
2. If the library folder is locked, right-click and select Right to Modify.
3. In the Network view, select the modules for creating the template and group them. It is very
important to group your cut-out character rig before storing it in the Library.
4. From the top menu, select Edit > Group > Group Selected Layers or press Ctrl + G
(Windows/Linux) or ⌘ + G (Mac OS X).

5. In the Network view, click on the group module's yellow button to rename it.
The Layer Properties window opens.

6. In the Network view, select the group module and copy and paste it inside the template folder in
the Library view or press Ctrl + C and Ctrl + V (Windows/Linux) or ⌘ + C and ⌘ + V (Mac OS X).
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7. In the Rename dialog box, rename the new template.

To rename a template, right-click on it and select Rename.
8. Click OK.

Action Templates
An action template, also known as animation template, is created from the Timeline view. This
template allow you to reuse animations, key poses and part of an animation and contains mainly
keyframes and drawing exposures. For example, you can reuse head positions or a leg animation from
a walk-cycle and place them inside other animations. When it is extracted from the Timeline view, it
loses the extra connections, effects, and groupings from the Network view.
An action template is used with a master template. It cannot be used on its own since it does not
contain all the information required to rebuild the puppet skeleton and advanced connections. The
standard process is to first import the master template to the Network view or Timeline’s left side,
and then slide the action template into the Timeline’s right side. This allows you to first build the
skeleton and then give it the right pose.
The combination of master and action templates will function as long as the layer order and
connections are the same.
When you create an action template, be sure to name it so you can easily identify it as an animation.

Creating a Template from the Timeline View
How to create a template from the Timeline view
1. In the Timeline view, select some cells or layers.
2. In the Library view, select a folder to store the template.
3. If a library folder is locked, right-click and select Right to Modify.
4. Drag the selection to the Stage Library folder or any other library folder.
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5. In the Rename dialog box, give the new template a name.
To rename a template once it is created, right-click on the symbol and select Rename.
6. Click OK.

How to delete a template
1. In the Library view, select the folder containing the template to delete.

If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Delete or press Delete.

How to edit a template
1. In the Library view, select the folder containing the template to edit.

If the library folder is locked, right-click on the folder and select Right to Modify.

2. Right-click on the selection and select Edit Template.
A new Harmony application opens.
3. Edit the template.
4. From the top menu, select File > Save.
5. In the top menu, select File > Quit (Windows/Linux) or Stage > Quit (Mac OS X).
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Importing Symbols and Templates
There are several ways you can import symbols and templates in your scene.
Sometimes a character rig is not a straightforward matter. Rigs, which are usually saved as templates,
can contain symbols such as a leg that was made with a patch. However, a symbol does not work in
the same way as an action template. In the Timeline view, you can add an action template into another
template of the same structure. When working on a layer on the right side of the Timeline view and
you place a symbol into a symbol of the same structure, instead of being added to the previous
symbol, the new symbol becomes a copy.
For greater control over how the action template behaves when brought into the Timeline view, you
can use the Paste Special feature—see Using Paste Special on page 410.
In Harmony, when you import a symbol in your scene, you can navigate through it in the Network view.
Since a template is like a scene, you can open the template's folder and select elements inside it such
as drawings.
Instead of importing the entire contents of a template, you may only want to import a few drawings or
a palette. In this case, use the Open As Folder command to import the items you want.
If you want to import a palette, simply drag the palette file into the Palette list section of the Colour
view.
You can use the Expand Symbol command to extract a symbol's contents and place it on the root
timeline. The symbol will not be removed from the Timeline view. Its contents will be copied and
inserted into the root timeline. The symbol's layers will be parented to it in case you created motions
and transformations on the drawing layer that contains the symbol. Breaking the hierarchy could result
in the loss of any scaling and animation you may have created.
You can also expand a symbol within a group to avoid crowding the timeline with a series of layers.
When you expand the symbols, the layers will be contained in a group module that you can expand to
see the content.

How to import a template into the Timeline or Camera view
1. In the Library view, select the template you want to import.
2. Drag the selected template to the Camera view or to the left side of the Timeline view.
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3. You can also drag a template to the right side of the Timeline view and into existing layers if the
layer structure is the same as the existing one.

How to import a network template
1. In the Library view, select the template or symbol you want to import.
2. Drag the selected template to the Network or Camera view or the left side of the Timeline view.

3. If necessary, in the Network view, connect your template to the Composite module. To do this,
click its out-port and drag the connection to the Composite module until an in-port appears.
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If the template you are importing was created in the Network view, make sure to drop it in the Network
view or on the left side of the Timeline view. Otherwise, some network connections could be broken. If
you are importing a template containing the exact same connections as a template you imported
previously, you can drop it on the Timeline view's right side over the existing layer. This will combine both
templates and keep the same existing layers.

How to import a symbol in the Timeline view
1. In the Library view, select the symbol you want to import.
2. Drag the selected symbol to one of the following:
‣

The Timeline view's left side to import it into the centre of the camera frame.

‣

The Camera view to place it at the location where you release your cursor.

This may be useful if you saved a character's body parts as separate symbols. If you dropped them into the
Timeline view, then they would all appear in the centre, haphazardly one on top of the other. It would be
more efficient to arrange them into their correct places as you bring them into the scene.

How to import a template with symbols
1. From the right side of the Library view, select the action template that contains symbols.
2. Hold down Alt (Windows/Linux) or ⌘ (Mac OS X) as you drag it from the Library view to the right
side of the Timeline view and drop it next to a template with the exact same rig.
The Paste Special window opens.

3. Select the Advanced tab.
4. Select one of the following options from the Symbols menu:

‣

Copy symbols if they do not exist: This is the default setting for this operation and will
prevent symbols in an action template from being copied.

‣

Duplicate symbols: Makes copies of the symbols in your template.
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How to navigate your symbol in the Network view
1. In the Network view, select the symbol you want to open and press Ctrl + E (Windows/Linux) or ⌘
+ E (Mac OS X) to use the Edit Selected Symbol command.

2. In the Network view, inside the Symbol’s top module is the composition of your symbol. In this
example, a group module was turned into a symbol.

3. In the Network view’s top-left corner, click the Top
button to return to the top module. Or
press Ctrl + Shift + E (Windows/Linux) or ⌘ + Shift + E (Mac OS X) to use the Leave Current
Symbol command.

How to open a template as a folder
1. In the Library view, select the folder that contains the template to open. If the library folder is
locked, right-click on the folder and select Right to Modify.
2. Right-click on the selection and select Open As Folder.
3. In the library list section, click on the template's folder to display its content.
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4. Drag the content to the Timeline or Colour view.

How to expand a symbol
1. In the Timeline view, select the symbol to expand.

2. From the top menu, select Edit > Expand Symbol or press Shift + F8.

How to expand a symbol in a group
1. In the Timeline or Network view, select the symbol cell or symbol module you want to expand.

2. From the top menu, select Edit > Expand Selected Symbol in a Group.
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3. In the Timeline view, click the plus sign (+) to see the group content. In the Network view, click the
Expand Arrow to enter the group.
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Importing Files Through the Library
Harmony lets you import sound files and images directly through the library. Simply open the folder
containing your files in the Library view and drag them directly from there.

How to open a file through the Library
1. In the Library View menu, select Folders > Open Library.
2. Browse for the folder containing the files you want to import.
3. Click Open.
4. From the Library's template list, drag the file you want to import in the Timeline or Camera view.
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Using Paste Special
When you import a template in the Timeline view, all layers are created as well as drawings and
keyframes. You can choose to import only the keyframes without the drawings or import only the
drawings that are not already in your layers. You can adjust the behaviour using the Paste Special
dialog box.
When you import a symbol in your scene, its full length is exposed by default. If you import your
symbol in the Timeline view’s left side, all the frames will be exposed. However, if you import it into an
existing layer, you can use the Paste Special dialog box to adjust the import behaviour to fit your
requirements.
Once you set the parameters, Harmony will reuse them each time you import a symbol in the Timeline
view’s right side until you set new parameters.

How to open the Paste Special dialog box
1. In the Library view, select the Symbol or template to import.
2. While dragging the selection to the Timeline view, hold down Alt (Windows/Linux) or ⌘ (Mac OS
X).

Drop the selection in the Timeline view before releasing the keyboard shortcut key.

The Paste Special dialog box opens.
3. Set the parameters and click OK.

Paste Special - Basic Tab

Drawings
Parameter

Description

Only create drawing files
when they do not exist

When adding exposures to a drawing layer, new drawings will be created
only when drawings with the same name do not already exist in the destination.

Always create drawings

When adding exposures to a drawing layer, new drawings will always be
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created. If drawing files with the same name already exist, Harmony will
create a new name for the drawing.
Paste all Frames of the Symbols (full movie)

When enabled, the Paste Special command exposes all the Symbol's
frames instead of only the first one.

Cycle
Parameter

Description

Number of Cycles

The number of cycles your selection is repeated.
Normal (forward): Pastes your selection as is, starting with the
first cell and ending with the last.
Reverse: Pastes your selection in reverse, starting with the last
cell and ending with the first.

Cycle Type

Forward > Reverse: Pastes your selection as a yo-yo, starting
with the first cell, going to the last one and ending with the first
cell.
Reverse > Forward: Pastes your selection as a reverse yo-yo,
starting with the last cell, going to the first one and ending with
the last cell.
Number of Cycles: Lets you set the number of cycles.

Paste Special - Advanced Tab
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Drawings
Parameter

Description
Do Nothing: Does not create or overwrite drawings.
Update Drawing Pivot: Revises the drawing pivot in the
destination to use the same drawing pivot as the first drawing
in the template. If you have a range of drawings selected in the
destination, the pivot points of all selected drawings will be
updated.
Add/Remove Exposure: Creates/deletes exposure values in
the selected layer. You have the following choices as to how to
treat drawings be created when adding an exposure:

Drawings

•

Never create drawing files: When adding exposures to a
drawing layer, drawing files will not be created.

•

Only create drawing files when they do not exist: When
adding exposures to a drawing layer, new drawings will be
created only when drawings with the same name do not
already exist in the destination.

•

Always create drawing files: When adding exposures to a
drawing layer, new drawings will always be created. If
drawing files with the same name already exist, Harmony
will create a new name for the drawing.

•

Key Drawing Mode (Substitution): Pasting an exposure
value replaces the cell value in the current frame and in all
frames following in sequence with the original cell value.

•

Paste all Frames of the Symbols (full movie): When
enabled, the Paste Special command exposes all the
symbol's frames instead of only the first one.

Motion: Copies the properties of the selected motion
keyframe to the new frame.
Velocity: Copies the properties of the selected velocity
keyframe to the new frame.
Rotation: Copies the properties of the selected rotation
keyframe to the new frame.

Add/Remove Keyframes

Skew: Copies the properties of the selected skew keyframe to
the new frame.
Scale: Copies the properties of the selected scale keyframe to
the new frame.
Force Keyframes at Function's Beginning and End: Adds a
keyframe to the beginning and end of the pasted function,
reproducing the source function.
Offset Keyframes: When pasting functions, offsets the
keyframes from the function's last value by the values in the
pasted function. This will continue the progression of a function
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rather than repeat the values.
Do nothing: Does not create, overwrite, merge or link
palettes.
Reuse palettes. Copy palettes if they do not exist: Palettes in
the destination drawings are left as they are.
Copy and overwrite existing palettes: Overwrites destination
palettes with the palettes from the source drawings.
Copy and create new palette files: Creates new palette files,
placing them at the same relative environment and scene level
as the source. If the palettes in the templates were stored at
the environment level of the source scene, the paste operation
will place the palettes in the environment level of the
destination scene.
Copy and create new palette files in element folder: Creates
new palette files in the element folders of the destination
scene, rather than in the same relative job or environment.
Palettes

Copy palette and merge colours. Add new colours only:
Adds new colours to the destination palettes and ignores
colours that are the same in the two palettes.
Copy palette and update existing colours only: Adds new
colours to the destination palette and updates duplicate
colours in the destination with colour values from the source.
Link to original palettes (colour model): Links the colour
palettes in the destination scene to the palettes in the source.
Use this to link drawings to the palettes in a colour model.
Copy scene palettes and merge colours. Add new colours
only: Adds new colours to the destination scene palettes and
ignores colours that are the same in the two palettes.
Copy scene palettes and update existing colours: Adds new
colours to the destination scene palette and updates duplicate
colours in the destination with the colour values from the
source.

Symbols

Copy symbols if they do not exist: This is the default setting
for this operation and will prevent symbols in a Action template
from being copied.
Duplicate symbols: Creates a duplicate of the symbol instead
of linking the symbol instance to the original one. The new
symbol is created in the Library.
Normal (forward): Pastes your selection as is, starting with the
first cell and ending with the last.

Cycles

Reverse: Pastes your selection in reverse, starting with the last
cell and ending with the first.
Forward > Reverse: Pastes your selection as a yo-yo, starting
with the first cell, going to the last one and ending with the first
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cell.
Reverse > Forward: Pastes your selection as a reverse yo-yo,
starting with the last cell, going to the first one and ending with
the last cell.
Number of Cycles: Lets you set the number of cycles.

Modules

Create New Columns: A new column is created when you copy
and paste modules from the Network view or Layer in the
Timeline view. If the layers are linked to function curves, the
function curves, drawings and timing will be duplicated.

Elements

Reuse Existing Elements: Lets you paste existing elements
without creating new ones. This should be used only when
pasting within versions of the same scene.
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Harmony provides you with some great tools to animate your puppets. You can create simple
animation using the Transform tool and you can create advanced animation using both forward and
inverse kinematics. Harmony has advanced onion skinning and image swapping features to help you
animate efficiently and quickly. For animation freedom, you have the ability to mix several different
techniques of animation, such as simple rigging, hierarchy and symbol animation.
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•

Getting the Character on the facing page

•

Keyframes and Drawing Blocks on page 421

•

Creating a Simple Cut-out Animation on page 423

•

Selecting Layers to Animate or Position on page 426

•

Navigating the Hierarchy on page 429

•

Animating Using the Transform Tool on page 431

•

Animating Using Inverse Kinematics on page 433

•

Animating in Stop-motion on page 449

•

Animating Using Computer-generated Interpolation on page 451

•

Marking the Timeline on page 456

•

Flipping Through Poses on page 459

•

Using the Onion Skin in Cut-out Animation on page 460

•

Flipping Parts on page 463

•

Reusing Extra Drawings, Poses and Facial Expressions on page 464

•

Swapping Images on page 466

•

Adding a New Drawing on page 470

•

Ordering Layers Over Time on page 474

•

Resetting a Transformation on page 476

•

Creating Cycles on page 477

•

Copying and Pasting Animation on page 480

•

Adding Pegs on page 482

•

Offsetting a Portion of an Animation on page 484
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Getting the Character
The first step in animating your character is to import a master template from the library.
In Harmony, you can create your character template from the Network view.

If the template you are importing was created in the Network view, make sure to import it first and drop it
into the Network view or the left side of the Timeline view. Otherwise, some network connections may be
broken.

How to import a character from the library
1. Create a new Harmony project.
2. In the Library view, select a character master template to animate.

3. Drag the selected template to the Camera or Timeline view’s left side. You can also import a
template directly in the Network view.

4. In the Timeline view, drag the red scene length bracket to extend or shorten the scene length.
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How to import a Network template (Master Template)
1. Create a new Harmony project.
2. In the Library view, select the character's master template you want to animate.

3. Drag the selected template in the Network view.

4. In the Network view, connect the template's group module to the Composite module by clicking
its out-port and dragging the connection to the Composite module until an in-port appears.

5. In the Timeline view, extend or shorten the scene length by dragging the scene length bracket.
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Selecting the Pose

If the template you imported contains several poses, you must choose which pose you will use to start
your animation and remove the other ones.
If you created your different views in separate templates, you can import them on separate layers, and
turn them on or off in the Timeline view depending on which one you need.

How to select the character's pose
1. In the Timeline view, collapse your character's layers.

2. In the Timeline view's right side, select the keyframe corresponding to the pose you want to keep.

3. Drag the selected keyframe to the first frame.

4. Select all the extra drawings and keyframes that you do not need and press Delete.

Extending the Exposure
Once you have chosen a pose, all that is left to do is extend the exposure of your character to the end
of the scene.

How to extend the exposure of the character
1. In the Timeline view, collapse the character.
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2. In the Timeline view’s right side, select the last cell of the character.

3. Right-click and select Extend Exposure or press F5. You can also copy the first pose and paste it in
the last cell.
The drawing exposure is extended to the end. You will not see any changes in the Timeline view
when the master peg is collapsed.
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Keyframes and Drawing Blocks
When you extend the exposure of a drawing, it is represented by a grey block in the Timeline view.
When you expose a second drawing, a second grey block is displayed.
You can consider these blocks as drawing blocks.

To animate the position of a block over time, you do not need to create a second block, you simply
need to add a position keyframe. The position keyframes are coordinates indicating the position of
your drawing on a particular frame. These appear as black squares in the Timeline view.
In the example below, notice that the keyframes are positioned on frames independently from the
beginning and end of each drawing block.

You can keyframe three different positions for your drawing in the same drawing block and create a
motion path between them.

Creating Keyframes and Drawings in the Timeline View
You can see how the Timeline view behaves differently depending on whether you create a new
drawing, a new keyframe, or both at the same time.

How to create a drawing in the Timeline view
1. Do one of the following:
‣

From the top menu, select Drawing > Create Empty Drawing.

‣

In the Timeline View toolbar, click the Create Empty Drawing

‣

Press Alt + Shift + R.

A new drawing block is inserted.
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How to create a keyframe in the Timeline view
1. Do one of the following:
‣

From the top menu, select Insert > Keyframe

‣

In the Timeline View toolbar, click the Add Keyframe

‣

Press F6.

button.

A keyframe is created in the layer.

How to create a drawing and a keyframe simultaneously in the Timeline view
1. Do one of the following:
‣

From the top menu, select Insert > Keyframe and Duplicate Drawing.

A drawing block is created which contains copies of the selected drawing and a keyframe.
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Creating a Simple Cut-out Animation

Here is how you can create a simple cut-out animation. Follow these steps so you can try out the
animation tools you will learn in the next topics.

How to create a simple cut-out animation
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, enable the Animate
automatically.

tool or press Shift + T.
mode so that everything you move will be keyframed

3. From the top menu, select Animation > Stop-Motion Keyframe so that the interpolation is not
created automatically between keyframes.
4. In the Timeline view, collapse your character.

5. In the Timeline view, go to the frame where you want to set the first pose.
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6. In the Camera view, select the parts to animate.

7. Use the Transform
tool to rotate, skew, scale or translate the selection to its new position. To
rotate the piece, place your cursor slightly outside of a corner until you see the rotation cursor.

A new keyframe appears in the Timeline view.
8. To ensure that nothing will move on your new pose, in the Timeline view, select the frame
corresponding to the pose, right-click and select Add Keyframe or press F6.
feature.

9. In the Tools toolbar, enable the Onion Skin

10.In the Timeline view, go to the frame where you want to set your second keyframe.

11. If you want to make sure that nothing will move on your new pose, in the Timeline view, select the
frame corresponding to the pose, right-click and select Add Keyframe or press F6.
12. In the Camera view, animate your character.
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13. Repeat this process until all the poses are done.
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Selecting Layers to Animate or Position

When you are animating characters, it is important to understand how the Animate mode allows you
to create keyframes on the current frame or to reposition the entire layer.

Animate Mode
The Animate
button, in the Tools toolbar, turns keyframing on or off. When you enable the
Animate mode, as soon as your move an element in the Camera view, a keyframe is positioned on the
current frame in the Timeline view to indicate the new position.

When you turn off the Animate mode, and you select and move an element, the entire animation in the
layer will be offset at once.

This means that when you are animating a character, you must enable the Animate mode. If you are
scaling down your puppet to fit the scene composition and want to resize the entire animation, you
must disable the Animate mode.

How to turn the Animate mode on or off
1. In the Tools toolbar, click the Animate

button or select Animation > Animate.
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Selecting Drawing Layers using the Transform Tool
To manipulate your drawing layers in order to animate them, you must use the Transform
The Select tool is used to modify the drawing strokes and not the actual drawing layer.

tool.

When selecting your drawing layers with the Transform tool, make sure that the Peg Selection Mode
option is turned off in the Transform Tool Properties view. If this option is enabled, it will limit the
selection in the Camera view to pegs only.

How to select using the Transform tool
1. Do one of the following:
‣

In the Tools toolbar, click the Transform

‣

From the top menu, select Animation > Tools > Transform.

‣

Press Shift + T.

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Camera view, select the element to animate.

Selecting an Element in the Camera View Using the Transform Tool
When you select an element in the Camera view using the Transform tool, make sure that the Peg
Selection
mode is disabled in the Transform Tool Properties view, the element selected is the
actual drawing layer corresponding to the selected element. If you have a layer parented toa peg, you
must either use the keyboard shortcuts to go up the hierarchy chain, select it in the Timeline view, or
enable the Peg Selection
mode option in the Transform Tool Properties view, this will limit the
selection in the Camera view to pegs only.

If the layer has child layers, they will also be highlighted. Depending if you are using pegs or only
drawing layers in your rig, the selection can be magenta, yellow or both.
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Selecting a Layer in the Timeline View
When you select a layer in the Timeline view, the corresponding element is highlighted in the Camera
view. If the selected layer has child layers, they are also highlighted.

Selecting in the Network View
As with the Timeline view, when you select a module in the Network view, the corresponding element
will be highlighted in the Camera view. If the selected module has child layers, they will also be
highlighted.
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Navigating the Hierarchy
If you created a layer hierarchy when you built your puppet, you can use the keyboard shortcuts to
travel up and down the parent-child chain. You can also navigate between the children of the same
parent.

How to select the parent or child layer
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Camera or Timeline view, select a layer attached to a hierarchy.

4. From the top menu, select Animation > Select Parent or press B to select the parent layer. Now
select Animation > Select Child or press Shift + B to select the child layer.

These keyboard shortcuts ignore any effect module encountered in the Network or Timeline view. Only
drawing and peg modules are considered. If you want to navigate the hierarchy including the effect
modules, you can create a custom keyboard shortcut in the Preferences dialog box for the Select Parent
Skipping Effects and Select Child Skipping Effects commands on the General tab. Refer to the Harmony
Preferences Guide to learn how to create custom keyboard shortcuts.

How to select the children layers
1. In the Tools toolbar, select the Transform

tool.

2. In the Camera or Timeline view, select a layer attached to a parent layer with several children or not
parented at all.
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3. From the top menu,
‣

Select Animation > Select Previous Brother or press / to select the previous child layer.

‣

Select Animation Select Next Brother or press ? to select the next child layer.

‣

Select Animation > Select Children to select all child layers at the same time.
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Animating Using the Transform Tool
The Transform tool is the main tool to use when working with a cut-out character. The Transform tool
has many useful functions:

Using the individual Rotate, Translate, Scale and Skew tools is not recommended, as they move each
piece from their own pivot point. They are compositing tools. The Transform tool creates a global
selection, so that when many parts are selected, you can move them as one unit. The Transform tool is
highly recommended for cut-out animation.
When animating with the Transform tool, make sure to select the right selection mode. In this
example, make sure that the Peg Selection
Mode is disabled in the Tool Properties view or it will
limit the selection in the Camera view to pegs only.
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If you have hierarchy connections in your cut-out character, the Transform tool will also be used as the
Forward Kinematics equivalent.
The Transform tool can be used on any kind of rigging.
When many parts are selected with the Transform tool, the first selected part's pivot will be used as
the global selection's pivot. This pivot can be moved temporarily for the animation. When you offset
the pivot, the permanent pivot is displayed as a ghost.

The interpolation of your animation poses is always calculated from each individual part's permanent pivot. If
you have a parent peg on a limb, make sure to select that parent peg rather than making a selection of each
parts to avoid setting individual keyframes.

How to use the Transform tool
1. In the Tools toolbar, click the Transform

tool or press Shift + T.

2. In the Transform Tool Properties view, make sure the Peg Selection

mode is deselected.

3. In the Timeline view, go to the frame you want to set the first position.
4. In the Timeline View toolbar, click the Add Keyframe
button or press F6. It is recommended to
add a keyframe before moving your character. Moving a character's part without setting a
keyframe will create keyframes only on certain parameters of your animation. You could run into
issues later on when setting poses between existing ones. Creating a keyframe on all layers and
parameters will ensure your pose is set and will not be modified by other poses later on.
5. In the Camera view, select the element to animate and move it.

6. In the Timeline view, go to the frame where you want to set the next position.

7. In the Timeline View toolbar, click the Add Keyframe
8. In the Camera view, animate the character.
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Animating Using Inverse Kinematics

The Inverse Kinematics (IK) tool allows you to pull on your character's extremities, such as the hands
and feet, and have the rest of the body follow. It can be used on any piece connected in a hierarchy.
However, you do not have to use IK every time you have a hierarchy rig. This tool is useful when you
want to bend a character's knees, make it sit and move the rest of the body, and so on. It will also
assist you with the posing of difficult moves.
In most 3D animation software, Inverse Kinematics is implemented as a skeleton system. Harmony
uses the rigging hierarchy already created in the Timeline view, so there is no need to place bones in
the character. Inverse Kinematics in Harmony uses the connection between each of the parts' pivots.
Inverse Kinematics will not work on basic rigs without hierarchy because there is no hierarchy chain
present. IK only works on a hierarchy where the pivots are properly set.
When animating a hierarchy puppet, you will use both the Transform and Inverse Kinematics tools.
•

About IK Hierarchy Chains below

•

Where to Start with Inverse Kinematics? on page 435

•

Inverse Kinematics Tool Properties on page 436

•

Setting Up the Character to Use IK on page 439

•

Nails on page 442

•

Minimum and Maximum Angle on page 443

•

IK Keyframes on page 444

•

When to Use the Inverse Kinematics (IK) Tool on page 446

About IK Hierarchy Chains
Before we go any further, a word about IK chains. There are three types of chains:
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•

Single Chains below

•

Direct Chains below

•

See "All Chains" on page 435

Single Chains

The single chains are the most basic of chains. A single chain is a straight line with no secondary chain
attached. It goes up to the first intersection.

Direct Chains

A direct chain is a single chain which goes directly to the core (root).
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All Chains

All chains are attached and move together when one part is moved.

Where to Start with Inverse Kinematics?
IK works best when you lock a part of the character on the spot, such as a foot on the floor, then select
the entire body or another extremity and move it. It also works well in single chain mode when you
need to simply position a limb.

Tip: To lock a part in place, use the IK Nail option—see Nails on page 442.

How to use the Inverse Kinematics tool
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on a part of the body.
The entire IK skeleton appears.
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3. Click on a part of the body and pull on it to move the character.

4. Hold down the Shift key and click on the pivot belonging to the part you want to lock in place.You
can Shift + click on a bone to lock the orientation of the bone.

5. Click on another part of the character and pull on it.

Inverse Kinematics Tool Properties

Mode
The IK tool has a series of different modes available in the Tool Properties view.
Mode
Bone Selection

Button

Description
Enabled by default, this mode lets you click on any bone
in a character and move it without having to select the
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actual layer.
When you disable this mode, you can not move any
bone except the selected one. This allows you to grab
and rotate the selected part from many angles and
location. You can click completely outside the character
and move the pieces.
•

Simple Chain Mode: this is the default mode and
will only allow for the movement of parts attached to
a single chain up to the point of intersection. A single
chain is a straight line with no secondary chain
attached

•

Direct Chain Mode: this mode will allow the
movement of parts up a simple secondary chain to a
principle chain as long as translation movement is
possible (the principle chain is attached to its own
peg), but will ignore all secondary chains. A direct
chain is a single chain which goes directly to the core.

•

All Chain Mode: this mode allows for the movement
of all parts attached to all chains in the IK skeleton.
All chains are attached and move simultaneously
when one part is moved.

Chain

The main working mode for the Inverse Kinematics tool.
Enable this mode when you want to animate and
position your puppet.

IK Manipulation

Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on
a body part to select it. You do not need to select a part
to be able to move it.

Apply IK Constraints

Lets you correct a part's position on a series of frames. For
example, if the character's foot is sinking into the floor, you can
correct its position and angle over a series of frames.

Edit Min/Max Angle

Lets you set a rotation restriction on some of your parts, such as
elbows, knees and ankles.

Bone Editing

Lets you fix the bone orientation on extremities such as hands and
feet.

IK Options
Parameter
IK Keyframe

Description
Used in combination with the IK Constraints mode, this option
determines the starting frame of the constraint you will apply.
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While you animate with the IK tool, prior to doing a movement
you can set an easing preset so that your motion is not so
mechanical.
Before moving your part, select a preset from the Ease Shape
menu:

Ease Shape

If you select a new preset in the list and move the part again on
the same keyframe, the easing will be automatically updated.

Selection
Mode

Enable Translation If Top of
Hierarchy

Button

Description
Used only on master pegs. This option is useful when you
have a situation such as this: you want the character to do a
perfect split (sitting down with the legs at right angles to the
body or at the sides with the torso facing forwards), then the
hip will need to translate and not just rotate on the spot. And
since IK is all about rotation, you would select the hip layer
and enable the translation option.
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Enable Rotation
This option is enabled by default. The pivot disappear but
you can still see the bone.
If you disable this option, the selected part cannot be rotated
and will remain in the same position. You can use this option
to simulate an arm in a plaster cast.
This option lets you exclude certain parts of your puppet
from the IK influence, such as the eyes and mouth.

Exclude from IK

IK Nails

These options let you temporarily fix a part of a character to a spot
either in translation or rotation, or enable maximum and minimum angle
usage.

Stiffness

When a certain part is selected, you can apply a stiffness value to it. A
different stiffness value can be set to each body part individually. The
greater the Stiffness value applied, the more difficult it is to make that
part rotate, thereby rendering it stiff while the other parts continue to
move freely on their joints.

---

Setting Up the Character to Use IK
The first time you display the character's skeleton, you will notice a series of bones on the extremities
which are out of place, and there may also be some elements that you would like to exclude from the
Inverse Kinematics chain.
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It is highly recommended to set up the skeleton before starting your animation.
Before fixing any bones, or excluding layers from the IK, it is important that you make sure all the
elements you want to be parented in a chain are set up.
You do not need to have hierarchy chains all over the body. They could exist only on the legs and arms.
If the body is not completely rigged in hierarchy, the skeleton will look a bit more messy, but the IK
tool will still work properly.
When working with the IK tool, you will probably want to move the main parts around, but not
necessarily the small ones such as the nose or ears. To do this, you can select some elements on your
character and exclude them from the skeleton.
Once you remove the extra elements from your skeleton, you will want to set the bone orientation for
the extremity parts. By default, they are oriented horizontally towards the right. This orientation often
works for the feet but not necessarily for the hair or hands.

How to exclude elements from the skeleton
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on the part to exclude
from the IK.
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4. In the Tool Properties view, click the Exclude from IK

button.

5. Repeat the process for every part to be excluded from the IK.

How to set the bone orientation
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, enable the Bone Editing

mode.

3. In the Camera view, click on the pivot belonging to the part whose bone you want to reposition,
then pull the pivot in the direction you want the bone to be.

4. Repeat this process for each bone you want to position.

This command only works on the extremities.
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Nails
Often, you will want to animate only part of a character, such as the arm and not the entire body. You
can do this using IK nails, which are IK constraints that temporarily cut or constrain the chain. With the
IK nails, you can cut an IK chain or block a part on the spot. For example, you can fix a character's feet
to the ground when he walks.
There are different types of constraints you can place on the chain:
•

IK Nail: Blocks the X, Y and Z positions.

•

Hold Orientation: Blocks the angle.

•

Hold X: Blocks only the X position.

•

Hold Y: Blocks only the Y position.

•

Enable Maximum and Minimum Angles: Sets limitations on the angle parameter to prevent
the puppet from bending too far.

How to set an IK nail
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Tool Properties view, make sure the IK Manipulation Mode

is enabled.

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on the part to set a nail
on.
4. In the Tool Properties view, select a type of nail:
‣

You can also hold down the Shift key and click on any part's pivot to set a regular nail on it
without having to select it.

‣

You can hold down the Shift key and click on the bone to set a Hold Orientation nail.
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‣

You can select the nail type in the top menu by selecting Animation > IK Constraints > the
desired nail.

‣

You can remove the nail at anytime using the same technique you did to place the nail. It will
not affect the animation.

5. To remove every nail except the Enable Min/Max Angle ones, from the top menu, select
Animation > IK Constraints > Remove All Constraints.

Minimum and Maximum Angle

Harmony allows you to set a minimum and maximum angle constraint on certain joints, such as the
knees or elbows. When using the Inverse Kinematics tool or even the Forward Kinematics (Transform
tool), it is possible that some joints will bend in the wrong direction.
If you plan to animate a lot with the Inverse Kinematics tool, it is a good idea to try the angle
constraints. It depends on your taste. The angle constraints can be set by the character builder or by
the animator in some particular scenes where it is needed.

It is recommended to use the minimum and maximum angles only if the character does
not change view within the same layers. For example, if a character is facing the camera
and has some angle limitations enabled, it could be problematic if the character switches
to side or quarter view since the joints won't bend the same way.
You can use the minimum and maximum angle constraints if your character's views are in
different templates or layers. If the character's views are in the same layers, you are better
off not using the angle constraints.

How to set the minimum and maximum angles
1. In the Tools toolbar, select the Inverse Kinematics

443

tool or press Shift + I.

Chapter 11: Cut-out Animation

Animating Using Inverse Kinematics

2. In the Tool Properties view, in the Mode section, make sure the Edit Min/Max Angle Mode
enabled.

is

3. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) on the piece to set the
minimum and maximum angle.

4. In the Tool Properties view, in the Selection section, click the Enable Min/Max Angle

option.

5. In the Camera view, rotate the Minimum and Maximum handles to set the angle.

6. Test the angles using the IK Manipulation

mode.

7. For additional control over the Min/Max Angle, go to Edit > Preferences (Windows/Linux) or
Stage > Preferences (Mac OS X). Select the Camera tab. In the Inverse Kinematics section, look at
the Min/Max Angle Constraint Wight. Although the maximum value goes up to 1.0, in a production
setting, the most practical value would be closer to 0.1. This value acts similar to the Stiffness
setting in the Tool Properties view. The higher the value, the more difficult it becomes to approach
the minimum and maximum values.

IK Keyframes

When you animate a walking character and lock the feet down, the locked position will be perfect on
the key poses. However, when you use the motion keyframes to auto in-between the animation, you
will notice a movement of feet. This motion is caused by the in-betweening of the rotations.
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The nail holds in place the body part on the keyframe, but it will not hold it for the entire duration
between keyframes.
If you place a nail on the shoulder to move just the arm, you do not necessarily want to keep the
shoulder in the same place until the next key pose. You will probably want the shoulder, or any other
part that is nailed, to have a slight, natural motion following the main body action. Of course, this is
not the case when you fix a hand or a foot on the spot. If you have a fixed hand or foot, you will
probably want it to stay exactly where you placed it. That is why you can apply an IK constraint on a
frame range and on selected body parts.
To fix the part on the same spot requires an angle (rotation) correction on the parts that are moving
too much. For example, to fix a foot that is moving too much, you will correct the angles on the foot,
leg and thigh. To fix a hand, you will correct the angles on the hand, forearm and upper arm.

How to apply IK constraints on a frame range
1. In the Tools toolbar, select the Inverse Kinematics

tool or press Shift + I.

2. In the Camera view, click on the part you want to apply the constraint to.
3. In the Timeline view, set the cursor to the first frame where you want to start applying the
constraint.

4. In the Tool Properties view, enable the Apply IK Constraints
5. In the Tool Properties view, click on the IK Keyframe

mode.

button to enter the first frame number.

6. In the Timeline view, move the playhead to the last frame on which you want to apply the
constraint.

The IK Keyframe field should now look like this:

7. In the Camera view, set a nail at the top of the limb you are correcting. For a foot, set the nail on
the thigh by holding down the Shift key and clicking its pivot.
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8. In the Tool Properties view, select the type of constraint you want to apply to your piece.The most
and Hold Orientation
options.
common case is a combination of the regular Nail
9. In the Camera view, click on the bone of the part you want to apply a constraint to.
A warning message appears asking you to confirm that you want to add your constraint on that
particular piece and for that frame duration.

10. Click OK.
Your constraint are now be applied.

When to Use the Inverse Kinematics (IK) Tool
Harmony provides different tools for animating cut-out characters and trajectories. The two main
tools used to animate characters are the Transform and Inverse Kinematics tools.
Here, we will compare the usage of these tools and explain the Inverse Kinematics philosophy.
•

Transform Tool

Also known as forward kinematics, the Transform tool is the main tool to use for cut-out
animation. This tool rotates, scales, moves and skews selected elements as one global element.
Forward kinematics means that the limb is animated from the parent down to the last child as a
single piece. In other words, if the shoulder is animated, then the arm, forearm and hand follow as
a complete arm drawing.
•

Inverse Kinematics Tool (IK)

This assistance tool helps you achieve complex motions, such as sitting down or knee bending. The
Inverse Kinematics tool moves and rotates every selected element as a chain.
Inverse kinematics means that the element is animated from the child up to the parent. In other
words, if the hand is animated, then the forearm, arm and shoulder follow the hand in a fairly
natural way in terms of the movement, rotation and bending.
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IK Tool and Rigging
The IK tool cannot be used on every type of cut-out character. It depends on the way the pieces and
parts are attached to one another. In other words, it depends on the rigging type.
There are several ways to rig a puppet. These are the three main rigging techniques:

The Basic Rig Technique
•

This is the simplest rig technique.

•

There are no connections between the parts.

•

They are free to move, rotate and scale independently one from the other.

•

The Inverse Kinematics tool CANNOT be used on this type of rigging.

The Hierarchy Rig Technique
•

This is the complex rig technique.

•

All the parts are connected one to the other.

•

As they move, rotate and scale, they will influence all the other parts.

•

The Inverse Kinematics tool can be used on this type of rigging.

The Mixed Rig Technique
•

This is the best of the basic and hierarchy rig.

•

Some parts are independent such as the torso.

•

Some parts are set up into a hierarchy such as the arms and legs.

•

Independent parts are rigged in hierarchy using parent pegs.

•

The Inverse Kinematics tool can be used on this type of rigging.

Animating with the Tools
Puppets are animated by using a combination of the Transform and Inverse Kinematics tools.
You will mainly use the Transform tool (forward kinematics) as it has all the main motions: rotate,
scale, skew, move and select. You can also control the exact position of the parts while using the
Transform tool. As well, the Transform tool creates a temporary global pivot on the selection that can
be moved around for the animation purpose.
To complete complex motions, such as bending the knees while keeping the feet on the ground, you
can use the Inverse Kinematics tool as an assistance tool. By adding IK constraints (nails), it is possible
to lock the feet or any other part to a particular spot and move the rest of the body, which will react to
the constraints.

Inverse Kinematics Philosophy
It is important to keep in mind that the Inverse Kinematics tool is an assistance tool. You will not be
using it to animate all the time.
Also, the Inverse Kinematics tool can be used to do the character's posing faster. Posing is a crucial
part in the animation process. The IK tool can be used to pose the character more naturally,
depending on your own preferences.
An IK nail can be added anywhere on the character to animate only a small part of the hierarchy chain,
such as an arm or a portion of the arm.
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Tips and Tricks for Inverse Kinematics
Here are some tips and tricks to help you to use the Inverse Kinematics tool.
•

IK on Mixed Rigs
The Inverse Kinematics tool can be used on a full puppet's body even if it is connected as a mixed
rig, meaning some parts are rigged in a hierarchy and others not. For example, you can add IK nails
on the puppet's feet, select the full body master peg and move the character as if it was connected
in a full hierarchy rig. This technique works on most mix rigs.

•

IK Constraints
It is important to remember that you can add and remove IK constraints (nails, hold orientation,
etc.) at any time during the animation. They hold a certain part on the spot while you animate the
rest of the body. Because they are not constricting one part to another object, you can add or
remove them without affecting any of the animation you have already done.

•

Useful Shortcuts
•

While using the IK tool, you can Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select
any part.

•

Hold down Altto rotate the selected part without affecting the IK chain.

•

Press Shiftand click in a part's pivot to add or remove an IK Nail.

•

Press Shiftand click on a bone to add or remove and Hold Orientation constraint.
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Animating in Stop-motion
To start animating your character, start by doing your key poses. In fact, most of your time will be
spent doing key poses. It is better to work with stop-motion keyframes so Harmony does not
automatically create the interpolation between your keyframes.
When using stop-motion keyframes, also known as stepkeyframes, the segment between two
keyframes is constant. There is no animation generated by the computer between the poses. The
drawing remains in position until the next keyframe, then moves to its new position.

Creating a Stop-motion Keyframe
You can create a stop-motion keyframe in several different ways. You can have Harmony create it
automatically, transform a motion keyframe into a stop-motion keyframe, or even switch your
preferences to get Harmony to always create stop-motion keyframes by default.

How to automatically create stop-motion keyframes
1. In the top menu, make sure the Animation > Stop-motion Keyframe option is deselected.
2. In the Timeline view, select the cell on which you want to add a keyframe.

3. Do one of the following:
‣

Right-click on the selection and select Add Keyframe.

‣

In the Timeline View toolbar, click the Add Keyframe

‣

Press F6.

button.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe is automatically created on the current frame.
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How to convert a motion keyframe into a stop-motion keyframe
1. In the Timeline view, select the motion keyframes to convert into stop-motion keyframes. The default
keyboard shortcut is S.

2. Do one of the following:
‣

Right-click on the selection and select Set Stop-Motion Keyframes.

‣

In the Timeline View toolbar, click the Stop-Motion Keyframe

‣

Press Ctrl + L (Windows/Linux) or ⌘ + L (Mac OS X).
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Animating Using Computer-generated Interpolation
After you have created the key poses, you can animate the in-between poses yourself or let Harmony
do it using motion keyframes. When you use motion keyframes, your drawings gradually move to the
next position instead of staying on the spot until the next keyframe.

Creating a Motion Keyframe
You can create a motion keyframe in several different ways. You can have Harmony create it
automatically, transform a stop-motion keyframe into a motion keyframe and even switch your
preferences to get Harmony to always create motion keyframes by default.

How to automatically create stop-motion keyframes
1. In the top menu, make sure that the Animation > Stop-Motion Keyframe option is disabled.
2. In the Timeline view, select the cell where you want to add a keyframe.

3. Do one of the following:
‣

Right-click on the selection and select Add Keyframe.

‣

Click the Add Keyframe

‣

Press F6.

button in the Timeline View toolbar.

In the Camera view, if the Animate mode is enabled, as soon as you move the selected element, a
keyframe will be automatically created on the current frame.

How to convert a stop-motion keyframe into a motion keyframe
1. In the Timeline view, select the stop-motion keyframes to convert into motion keyframes.
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2. Do one of the following:
‣

Right-click on the selection and select Set Motion Keyframes.

‣

Click the Motion Keyframe

‣

Press Ctrl + K (Windows/Linux) or ⌘ + K (Mac OS X).

button in the Timeline View toolbar.

Adjusting the Ease

To add ease in and ease out on your motion paths, you can display the function curve and modify the
Bézier or Ease curve. To apply an ease to multiple functions and keyframes, you can use the Set Ease
for Multiple Parameters feature and set the amount desired.
The velocity, or ease, is used on motion keyframes. The velocity must be adjusted directly on the
function curve in the Function view or Function editor. When a keyframe is selected, easing values
appear in the right handle and left handle fields, as well as the Bézier handle or Ease wheel controls on
each selected keyframe. You can pull on them to adjust the ease in and ease out, or type values in the
fields.
If there are several functions whose velocity you want to adjust at the same time, such as the hand,
forearm and arm of a cut-out character, you can apply the same velocity parameters to all the selected
keyframes in one frame.

How to adjust the velocity in the Function view
1. In the Timeline view, click the Expand Function
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2. Double-click on the desired function.

The Function Editor opens.

The Function editor will not display if the function does not already exist. Add a keyframe to create the
function.

3. Select a keyframe and pull on its Bézier handles or Ease wheel to adjust the velocity. Refer to the
Compositing Guide to learn how to create Ease curves instead of Bezier curves.
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How to set ease on multiple parameters
1. In the Timeline view, select a keyframe from one or more layers.

Only the first keyframe selected on a given layer will be considered when using the Set Ease for Multiple
Parameter function. If many keyframes are selected on the same layer, the ease values will be applied only
to the first one and the rest will be ignored.

2. In the Timeline view, right-click and select Set Ease For Multiple Parameters. In the Timeline View
toolbar, you can click the Set Ease For Multiple Parameters
button. If the button is not in the
Timeline View menu, you can add it through the Toolbar Manager. Right-click on the toolbar and
select Customize.
The Set Ease For Multiple Parameters dialog box opens.

3. In the graph interface, pull on the Bézier handle to adjust the velocity for all the selected functions.

454

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

4. If you want to apply these easing parameters to a certain type of function only, such as Rotation or
Scale, in the Filters section, deselect the function types you do not want to affect.
‣

Motion: Applies the easing parameters to the selected Position X, Position Y, Position Z
and 3D Path functions

‣

Rotation: Applies the easing parameters to the selected Angle functions.

‣

Scale: Applies the easing parameters to the selected Scale functions.

‣

Skew: Applies the easing parameters to the selected Skew functions.

‣

Morphing: Applies the easing parameters to the selected Morphing Velocity functions.
Note that it applied to the Morphing velocity function in the Layer Properties dialog, not to
the basic Morphing ease in the Tool Properties view.

‣

Other: Applies the easing parameters to all the other selected functions, such as all
functions created to animate effect parameters.

5. You can also adjust the easing by typing values in the Time Ratio and Value Ratio fields. The values
are calculated in percentage.
‣

In the Left Time Ratio and Right Time Ratio fields, type the percentage value corresponding
to the length of time you want the easing to last. The value must be between 0% and 100%.

‣

In the Left Value Ratio and Right Value Ratio fields, type the percentage value of how strong
you want the easing out. The value must be between 0% and 100%.

‣

If your Time Ratio and Value Ratio values are equal, you will have a linear motion.

6. Once done, click one of the following buttons:
‣

Apply: Applies the easing parameters to the selected keyframes.

‣

Apply/Previous: Applies the easing parameters to the selected keyframes and then selects
the previous keyframe in the timeline.

‣

Apply/Next: Applies the easing parameters to the selected keyframes and then selects the
next keyframe in the timeline.

‣

Close: Closes the dialog box. If you did not apply the modifications, they will be cancelled.
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Marking the Timeline
As you animate, the Timeline view will contain many layers and keyframes. You might want to identify
them using coloured layers and scene markers.
Scene markers are visual indicators displayed at the top of the timeline in the frame counter area. You
can use it to denote anything relevant to your work. You can indicate at the frames you want to clean
up, a change in action, an impact, or where you intend to apply an effect. You can also add a note to a
scene marker, which is displayed when you hover over the scene marker.
There are two ways to add a scene marker. You can make a frame range selection and mark that
whole section or simply mark the current frame.

How to mark the current frame
1. In the Timeline view, make sure the playhead is set on the frame you want to mark. Even if you
right-click on a different frame, the scene marker will be created on the current frame, which means
where the red playhead is.
2. Right-click in the frame counter area and select Scene Markers > Mark Current Frame.

The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.

3. Double-click the Colour box to select a colour for your scene marker.
4. In the Note field, enter text to display a tooltip.

5. Click OK.
6. In the Timeline view, the scene marker is displayed at the current frame. Hover over the scene
marker to display its note as a tooltip.
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How to create a scene marker on a frame range
1. In the Timeline view frame counter, select the frame range on which you want to mark your scene.

2. Right-click and select Scene Markers.
The Timeline Scene Marker dialog box opens. The Colour box displays a black colour swatch, or
the colour of the last scene marker you created.

3. Click the colour swatch and select a colour for the scene marker.
4. In the Note field, enter text to display as a tooltip.

5. Click OK.
6. In the Timeline view, the scene marker is displayed over the selected frame counters. Hover over
the scene marker to display its note as a tooltip.

How to modify a layer's colour
The Change Track Colour
button is used to change the colour of the exposed frames so you can
quickly locate a layer in the Timeline view.
1. Click the swatch to open the Select Colour dialog box and choose a new colour. You can modify
the layer for any type of layer, such as group, peg, drawing and effects.
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Flipping Through Poses

When animating, it is useful to flip through poses to see the flow of your animation without going
through each frame in the Timeline view. Harmony lets you flip between the selected element’s
keyframes.

How to flip through poses
1. In the Camera or Timeline view, select a layer that contains the poses you want to view.

2. From the top menu, select Animation > Go to Previous Keyframe or Go to Next Keyframe or
press semicolon (;) and single quote (').
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Using the Onion Skin in Cut-out Animation

When animating cut-out characters, it is useful to see the previous and next frames on the animation.
However, it can sometimes be confusing to see the onion skin for every part of the character. You will
often only want to see the onion skin on a single part or a few parts, such as the arm, that are currently
being animated. Harmony offers that possibility.
While animating in the Camera view, there is a series of different onion skin options. You can enable
these options in the menu or manually in the Timeline view using the layer's Show Onion Skin
button. Unless you change the onion skin options when you display the onion skin, only the selected
layers will be displayed in the onion skin preview.

How to use the onion skin
1. In the Tools toolbar, click the Onion Skin

button or press Alt + O.

2. In the Tools toolbar, click the Transform

tool or press Shift + T.

3. In the Camera view, select one or more elements.
4. From the top menu, select View > Onion Skin > Add to Onion Skin, Remove From Onion Skin,
Remove Unselected from Onion Skin, Add All to Onion Skin or Remove All from Onion Skin.

Add to Onion Skin

The Add to Onion Skin command is used to add a series of selected elements to the onion skin
preview. The keyboard shortcut is Shift + S.
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Remove from Onion Skin

The Remove From Onion Skin command is used to remove a series of selected elements from the
onion skin preview.

Remove Unselected from Onion Skin

The Remove Unselected from Onion Skin command is used to remove all elements except the ones
selected from the onion skin preview.

Add All to Onion Skin

The Add All to Onion Skin command is used to add all of the scene's elements to the onion skin
preview. The keyboard shortcut is Alt + Shift + O.
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Remove All from Onion Skin

The Remove All Onion Skin command is used to remove all of the scene's elements from the onion
skin preview. The keyboard shortcut is Ctrl + Shift + O (Windows/Linux) or ⌘ + Shift + O (Mac OS
X).
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Flipping Parts

If you want to flip a part, a limb or a whole puppet, use the Transform tool and the Flip Horizontal and
Flip Vertical options. If the scaling parameter is not set to Separate Scale, the flip is not applied to the
selection.

How to flip a selection
1. In the Animation Tools toolbar, select the Transform

tool or press Shift + T.

2. In the Tool Properties view, make sure the Peg Selection Mode

is disabled.

3. In the Camera view, select the parts to be flipped.

4. In the Tool Properties view, click the Flip Horizontal
respectively.
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Reusing Extra Drawings, Poses and Facial Expressions

Reusing animation and assets is an important aspect of cut-out animation. This is why Harmony
includes a library for storing all of the reusable information. To save time, you can take an action which
you have already animated such as a walk-cycle or jump and use it again. You can store the initial
animation in the Library view, then select and drag it into a new scene as often as you need it.
You can import a master template into the Timeline view and start animating with it, then later on
decide to import an action template. You can import the template into the window on the right side of
the Timeline view. This is where all the keyframes are located. An action template is a template that
allows you to store drawings (like a blink) or keyframes (like a walk cycle) that you want to reuse in an
animation sequence.
To insert a template into another one, the layer ordering has to be exactly the same. If it is
inconsistent, the system will indicate that the templates cannot be combined. In that case, you could
bring the action to the Timeline's left window to create a new set of layers or convert it into a symbol
and drop it into any layer.

You can create a single keyframe action template of the different viewpoints (front, three-quarter or
side view). Then import and insert those action templates into the animation to turn the character. The
same pattern can be created for a head, arm, full upper body, etc.
If the master template you are importing was created in the Network view, make sure to import it first
and to drop it into either the Network view or the left side of the Timeline view. Failure to do this may
break some network connections.
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If you created templates for different body parts you can reuse them in your scene by dragging them in
your layers. You can also open a template as a folder and select a particular drawing from it and drag
it into your drawing layer.
If your layers are symbols, you will need to drag the templates inside the symbols. When you import
extra drawings, such as different hand and mouth positions, use the pivot that was set on your
drawings and copy them to the symbol's cells. You can do this by using the Copy Pivot to Parent
Symbol command.
When you copy your pivots to the parent symbol, there is no link between the drawing's pivots and
the symbol's. It is simply a copying operation. If you modify the drawing pivot later, it will not be
copied to the symbol and you would need to perform the operation again. If you need to modify the
symbol's pivots, do it directly on the symbol's cells.
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Swapping Images

Cut-out animation is not only about moving parts around. It is also about swapping drawings to give
the animation a more traditional animation look. You can add as many new drawings as you want in
your scene and use them in your current animation. You can also add new drawings to your library and
import them in other scenes.
It is not necessary to remember the frame on which you drew or imported the drawings as you can see
them in the Drawing Substitution window.
You cannot swap one symbol for another—only the symbol’s frames or layer’s drawings.
You can swap images in the Timeline or Library view. When you use the Drawing Substitution window
in the Library view, you are not selecting drawings from the Library but drawings contained in your
scene’s layers. The Drawing Substitution and Preview area are simply sharing the same interface
space.
It is important to understand that when you swap a drawing, its entire exposure is replaced up to the
next drawing block.

Although, if you select a frame range to be swapped, the following exposure will remain the same
even if it was part of the same drawing block.
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If you want to make sure that a certain drawing remains exposed on a particular frame and is not
overridden by a drawing swap on an earlier frame, you can use the key exposure function. They key
exposure feature breaks a drawing block into two pieces. The same drawing is used in both blocks. If
you modify the artwork in one, the artwork be modified in the second one, but if you swap the
exposure of the first one for another drawing, the second block will remain with the first drawing. This
feature is used to avoid messing up your animation key poses. One of the most frequent layers it is
used on is the mouth layer.

How to set a key exposure
1. In the Timeline view, select the drawing cell to set as your key exposure.
2. In the Timeline View menu, select Exposure > Add Key Exposure. In the Timeline View toolbar,
you can click the Add Key Exposure
button.
‣

To delete a key exposure, click the Remove Key Exposure
menu, select Exposure > Remove Key Exposure.

button. In the Timeline View

How to swap images in the Library view
1. In the Tools toolbar, select the Transform

tool.

2. In the Transform Tool Properties view, make sure the Peg Selection
3. In the Camera view, use the Transform

button is deselected.

tool to select the part you want to swap.
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4. In the Timeline view, select the cell range where you want to swap the drawing.

5. In the Library view, go to the Drawing Substitution window.

6. Scroll through the Symbol's frames or drawings by doing one of the following:
‣

From the top menu, select Animation > Substitute Drawing Previous or Substitute
Drawing Next.

‣

Drag the slider left or right.

‣

Press +.

The drawing or symbol’s cell on the current frame is replaced by the selected one.
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How to swap a drawing in the Timeline view
1. In the Timeline view, click the Show Data View

button to expand the Data view.

2. In the Timeline view’s right side, select the cell containing the drawing or symbol’s cell to swap.

3. In the Data view, drag the pointer left or right to change the cell or drawing exposed for another
one. You can also directly type the drawing name or Symbol’s cell number if you know it.
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Adding a New Drawing
If you need to add a new drawing in your scene, you can do so by duplicating the existing drawing on
the current frame. If you are using symbols, you can also add a new drawing inside the body part’s
symbol.

Duplicating a Drawing
If your character does not use symbols, you must duplicate the drawing on the cell where you need to
use a new drawing. You could also create a new blank drawing, but duplicating the existing drawing
allows you to keep the pivot you previously set (if you are using drawing pivots) and you can also reuse
a portion of the existing artwork. When you create a new drawing, you get a blank cell with a pivot set
at the centre of the Camera view.

How to duplicate a drawing
1. In the Timeline or Camera view, select the drawing to duplicate.

2. From the top menu, select Drawing > Duplicate Drawing or press Alt + Shift + D.
The new drawing appears in the currently selected cell.

3. In the Camera view, draw the new piece.

Reposition Drawing Tool
When creating additional drawings for a cut-out puppet, you should generally try to create them in the
same location as the original drawings (resting position) so you can scale and rotate them the same
pivot.

Although, when adding drawings that are specific to an animation, it may be easier to draw it in
relation to the character's position and scene's composition. If you draw a series of drawings that are

470

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

not in the same location, you can use the Reposition Drawing
tool to reposition the drawing
strokes while simultaneously creating keyframes in the Timeline view to compensate for the
repositioning. In the Camera view, the drawings will retain the location and position in which you drew
them while in the Drawing view, all your drawings will be aligned.

How to reposition and align drawings
1. In the Advanced Animation toolbar, select the Reposition Drawing

tool.

2. In the Camera view, Ctrl + click (Windows/Linux) or ⌘ + click (Mac OS X) to select the drawing to
reposition. You can also select the drawing layer or the parented peg in the Timeline view.
The Reposition Drawing controls appear in the Camera view. They are positioned on top of each
other. The source controls are represented by black lines. The destination controls are
represented by dotted blue lines.
3. On your first drawing (reference drawing), position the black source controls to indicate the
position at which all other drawings will be aligned.

4. In the Timeline view, scroll to your next drawing.
5. In the Camera view, move the blue destination controls to match the reference position you set on
the original drawing. You can use the long handle to rotate the position. If you rotate the control
multiple times, the drawing will rotate multiple times.
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6. Select the blue checkbox once the position is correct.
7. Repeat the previous two steps for all drawings in your animation.

8. Once all your drawings are completed, in the Drawing view, verify that your drawing strokes are
correctly aligned.
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9. If necessary, delete the last keyframe if your last drawing moves back to the reference drawing's
position.

10. If your animation does not require interpolation, in the Timeline view, select the newly created
keyframes. In the Timeline view toolbar, click the Set Stop-Motion Keyframe
button to remove
any computer-generated interpolation.
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Ordering Layers Over Time

The layer ordering system in Harmony saves time and simplifies your work. There is no need to create
a new layer or copy and paste artwork into other layers to change the order. The Z-axis
(forward/backward) allows you to create a multiplane and move elements closer or farther from the
camera. This allows you to move the puppet’s pieces in front of or behind other ones without
physically changing the layer position.

Harmony provides you with a shortcut to move the piece with a micro nudge on the Z-axis. A keyframe
is created where different Z values can be entered. This allows for the piece to move forward and
backwards in space without requiring you to change the drawing’s original position or break the layer
hierarchy. This also means that the layer ordering is maintained throughout the scene. You can
combine animation assets so Harmony can interpolate them.

How to nudge elements on the Z-axis
1. In the Tools toolbar, select the Transform
2. In the Tools toolbar, click the Animate

tool or press Shift + T.
button.

3. In the Camera view, click on the part to be repositioned and hold down the Alt key. Using the Up or
Down arrow keys, nudge the part until it moves to the desired position.
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Resetting a Transformation
If you made too many transformations and it is not going where you want it to go, or simply because
you want to reset a pose you are reusing from another animation, you can reset your character's
position. Once the layers are positioned in the Camera view, you can easily return them to their
original position. There are three different ways to reset a transformation.
Using the Reset command, you can reset the value of the selected element to the initial value of the
active tool. For example, if the Rotate
tool is active, the transformation angle will be reset to 0
and if the Transform
tool is active, all the transformation values will be reset.
The Reset All option resets all transformations on the current frame in a selected layer. Your keyframe
will remain, but all the values will return to the default position. All transformation are reset regardless
of the tool you are using.
The Reset All Except Z option resets all the transformations on the current frame except the Z
position. This is useful when doing cut-out animation. Cut-out puppets often have a particular Z
ordering for the different views of a character. You might want to reset the transformation, but not
necessarily the Z position.
In the Timeline view, you can also use the Clear All Values command to reset all transformation values
on the selected layers. Right-click on the selected layers and select Layers > Clear All Values.

When using the Transform tool to select elements in the Camera view, always make sure that the Peg
Selection Mode option in the Tool Properties view is disabled or it will limit the selection to peg only.

How to reset the transformation on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset or press Shift + R.
The selected layer(s) return to their original position.

How to reset all transformations on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

tool.

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset All.
The selected layer(s) return to their original position.

How to reset all transformations except the Z position on the current frame
1. In the Tools toolbar, select the Transform

tool or any Advanced Animation

2. In the Timeline or directly in the Camera view, select the drawing layer(s) to reset.
3. From the top menu, select Animation > Reset All Except Z.
The selected layer(s) return to their original position, except for the Z values.
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Creating Cycles
You can create cycles from a portion of your animation or completely reverse the flow of your
animation.

How to create an animation cycle
1. In the Xsheet or Timeline view, select the cell range and keyframes to loop.

2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want your cycles to start.

4. From the top menu, select one of the following:
‣

Edit > Paste Cycle or press Ctrl + / (Windows/Linux) or ⌘ + / (Mac OS X).
The Paste Cycle dialog box opens.

‣

Edit > Paste Special or press Ctrl + B (Windows/Linux) or ⌘ + B (Mac OS X).
The Paste Special dialog box opens.
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5. In the Number of Cycles field, enter the number of cycles to paste.
6. In the Cycle Type menu, select a type of cycle to paste.

‣

Normal (forward): Pastes your selection as is, starting with the first cell and ending with the
last.

‣

Reverse: Pastes your selection reversed, beginning with the last cell and ending with the
first.

‣

Forward -> Reverse: Pastes your selection as a yo-yo, starting with the first cell, going to
the last cell and ending with the first cell.

‣

Reverse -> Forward: Pastes your selection as a reversed yo-yo, starting with the last cell,
going to the first one and ending with the last cell.

7. Click OK.

How to create a reverse animation cycle
1. In the Xsheet or Timeline view, select the cell range and keyframes to paste inverted.
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2. From the top menu, select Edit > Copy.
3. In the Xsheet or Timeline view, select the cell where you want the cycles to start.

4. From the top menu, select Edit > Paste Reverse or press Ctrl + . (Windows/Linux) or ⌘ + . (Mac
OS X).
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Copying and Pasting Animation
As you animate, you will find that you reuse many positions, drawings, and keys. However, you may
only want to paste the drawings or just the keys or maybe everything. There are different paste
options available in the Timeline view which give you maximum flexibility when reusing and pasting.
Note that these modes also apply when you use drag instead of copy and paste.
There are three different modes for pasting your selection:
•

Paste Mode: All Drawing Attributes: Pastes the drawing exposure and keyframes.

•

Paste Mode: Keyframes Only: Pastes only the keyframes.

•

Paste Mode: Exposures Only: Pastes only the drawing exposure.

How to paste a selection using different modes
1. In the Timeline view, select the cells you want to copy and paste.

2. In the Timeline view's left side, enable the desired Paste

mode.

3. From the top menu, select Edit > Copy cells from the Timeline or press Ctrl + C (Windows/Linux)
or ⌘ + C (Mac OS X).
4. In the Timeline view's right side, select the cell where you want to paste your selection.

5. Select Edit > Paste Cells in the Timeline or press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).
Paste Mode: All Drawing Attributes

Paste Mode: Keyframes Only

480

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Paste Mode: Exposures Only
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Adding Pegs
Now that you have your puppet on stage, you probably need to resize and reposition it to fit your
scene. When you need to scale down or move your character, it is a good idea to hook (attach) the
whole puppet to a trajectory.
In Harmony, there is a type of layer you can add to your timeline, allowing you to create a motion path
or reposition drawings. This trajectory layer is called a peg. Any drawing or layer you hook to a peg
will follow the defined motion path, rotation, scaling and skewing information.
Attaching your puppet to a peg allows you to scale and reposition it without having to do the same on
all the different parts and pieces. Only one layer will contain the position information, making your
animation easier to modify and control.
Next, position your character on the stage by moving it and scaling it to the correct size. You will not
scale each layer individually. You either want to do it on the top symbol or top peg layer.

How to add a repositioning peg
1. In the Timeline view, select the top layer on which you want to parent a peg.

You must select a layer to be able to add a peg to your scene. Unless you use the Display All mode from
the Display toolbar, an error message will display if you try to add a peg without any selection.

2. In the Timeline view, click the Add Peg

button.

A new peg is added to the timeline as a parent of the selected layer.

3. Double-click on the name of new peg layer and rename it Master_Peg.

4. In the Timeline view, select all of the layers you want to attach to the new peg. Remember that one
item is already parented to that peg.
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5. Drag your selection and drop it on the peg layer to parent all your character's pieces to the peg. If
your layers are added above the already-parented layers, move that parented layer back on top of
the layer stack.

How to reposition a character
1. In the Timeline view, select the top peg layer (master peg).
2. In the Tools toolbar, select the Transform

tool and disable the Animate

3. In the Camera view, position the character.
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Offsetting a Portion of an Animation
If there is a section of your animation that you want to reposition such as the head's height or the
puppet's position, you can do it using the function curve.

How to reposition a portion of an animation
1. In the Timeline view, click the Expand Function
button of the body part layer to reposition. If
you want to reposition the entire body, expand the master peg's parameters.

2. Double-click on the layer's parameter controlling the keyframes you want to reposition.

The Function Editor opens.
3. In the Function editor, select the keyframes you want to reposition by tracing a selection box.

4. Enable the Show Current Frame option view the transformation results in the Camera view as you
do them.

5. Drag the keyframe selection up or down to reposition your sequence.
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6. Close the Function editor.
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Chapter 12: Deformation

Harmony provides you with the deformation technology to deform bitmap and vector drawings over a
period of time. These deformers can be linked to create a hierarchy of deformation. You can deform a
character made out of one, or many, drawing or image layers and make it move as if it were a cut-out
puppet. It also allows you to take an area in a single bitmap image and create animation by distortion.
This chapter is divided as follows:
•

About the Deformation Effect on the next page

•

Deformation Basics on page 491

•

Creating a Basic Deformation Rig on page 494

•

Setting Up the Resting Position on page 500

•

Manipulating a Deformer to Create Animation on page 506

•

Zones of Influence on page 512

•

Creating a Full Character Turnaround Deformation Rig on page 522

•

Deformation Toolbar on page 536

•

Deformer Effects on page 542
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About the Deformation Effect
The Deformation effect can be used to animate bitmap or vector-based graphics – it even works on
gradients and textures. The Deformation effect acts as a skeleton in which you can maneuver different
articulations or bend it into a fluid curve. It can be useful in many situations including cut-out animation.
When paired with your creativity, the Deformation effect can produce some stunning results.
The Deform group will be created automatically when using the Rigging tool. However if you want to
create a Deform manually, all the modules can be accessed from the Deformation tab in the Module
Library—see Deformer Effects on page 542.

Main Types of Deformer
There are two main types of deformer:
•

Bone Deformer below

•

Curve Deformer on the facing page

Bone Deformer
The Bone Deformer allows you to create a basic or advanced skeleton structure in which the parent
deformer will move the child deformers. The Bone Deformer is mostly used when animating the
extremities of a character, such as the arms or legs, adding fluidity and a natural feel to the animation.
The Bone effect can be manipulated to rotate a limb at an articulation joint and to shorten or elongate
the extremities of a limb. Every Bone module within a skeleton chain is linked by an Articulation
module. It is also quite useful to bend the torso.
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Curve Deformer
The Curve Deformer has a hierarchy similar to that of the Bone Deformer and provides you with
complete flexibility. For example, when editing curves, you can deform a straight line into an arc or a
zigzag with only a few clicks. Curve Deformers are mostly used to animate elements that do not have
joints, such as hair or facial features. However, in some cases they can be used to animate limbs to
create a specific animation genre, similar to the early rubber hose style of animation with typically
simple, flowing curves without articulation (no hinged wrists or elbows).
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Deformation Basics
Before starting to work with Deformation effects, you should :
•

Setting the Performance Preferences below

•

Displaying the Deformation Controls below

•

Deformation in the Network and Timeline Views on the next page

Setting the Performance Preferences
There are some preferences that you must set in order to work efficiently with the Deformation
effects.
You can customize the display of deformation, its functionality, and the performance of the system by
altering the preferences—see the Preferences Guide to learn more.
When using deformation, set the Use Hardware Vertex Texture Fetching if Available option for
optimal performance—see the Preferences Guide to learn more.

How to access the Preferences dialog box
1. Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the OpenGL tab.
3. In the Settings section, select the Use Hardware Vertex Texture Fetching if Available option.
This option is deselected by default, however it is strongly recommended that you enable it before
using the deformers. If your CPU and graphics card allow it, the system will use vertex shaders to
considerably help the process of deformation.

Displaying the Deformation Controls
Before you can manipulate the deformer outside of the Setup mode, you must enable the Deformation
Controls.
If you have just created the bone rig, the controls will still be showing. However, when you close your
project, the deformers are turned off. By enabling the Deformation Controls, the controls will display
when you reopen a project so can you see the ones you need while you are animating.
You can also select all the modules from Network view and select View > Show > Controls from the
top menu.

How to display the selected deformation controls
1. In the Network view, select the Deformation Group containing the deformation chain you want to
display.
2. Do one of the following:
‣

In the Camera View toolbar, click the Show Control

‣

From the top menu, select View > Show > Control.

‣

Press Shift + F11.
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How to display the selected deformation controls and hide all the others
1. In the Network view, select the Deformation Group containing the deformation chain you want to
display.
2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others

button.

The selected deformation controls appear in the Camera view and all the others are hidden.

How to display all the deformer controls at the same time
1. In the Top level of the Network view, select Edit > Select All from the top menu to select all the
modules or press Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X).
2. In the Camera View toolbar, click the Show Control

button or press Shift + F11.

All deformation controls in your scene are displayed.

How to hide the deformer controls
1. Do one of the following:
‣

In the Camera View toolbar, click the Hide All Controls

‣

From the top menu, select View > Hide All Controls.

‣

Press Shift + C.

button.

Deformation in the Network and Timeline Views
The Deformation effect layers and modules are visible in the Network and Timeline views. You can
modify their values and set up function curves using both views.

Refer to the Compositing Guide to learn how to work with functions.
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Creating a Basic Deformation Rig
Using the Rigging tool, you can quickly create a basic Bone and Articulation or Curve rig. Before you
can create a Basic Deformation rig, you must set up the performance preferences which are necessary
to allow the system to process the deformation effect efficiently—seeSetting the Performance
Preferences on page 491. Refer to the Creating a Full Character Turnaround Deformation Rig on
page 522 to learn how to rig a complete character.

How to create a basic deformation rig
1. In the Preferences dialog box, under the Deformation tab, deselect the Automatically
Create New Deformer Structure for each Pose/Drawing option—see Setting the Performance
Preferences on page 491. This will result in a simpler Network rigging structure. But remember
that this option must be re-enabled before rigging a multipose (front, quarter, side and back)
character.
2. From the Deformation toolbar, select the Rigging
3. In the Rigging Tool Properties, enable the Automatic

tool.
Mode.

4. In the Network, Camera or Timeline view, select the element on which you want to add a
deformation.

5. In the Camera view, create a Bone or Curve rig.

How to create a Bone rig
1. Place the cursor at the far end of your element, click once and release. For example, on the
shoulder.

2. Click again at the location where you want your first bone to finish and your second bone to start.
An articulation will automatically be inserted between each bone you create.
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3. Repeat this until you are finished creating the Bone chain.

How to create a Curve rig
1. Click at the far end of your element, for example, the shoulder and drag the cursor to extend the
control handle and release just as you would do when using the Polyline tool—see Drawing with
the Polyline Tool on page 82.

2. Click again at the location where you want the curve to end and drag the cursor to extend the
second control handle.

3. Repeat this process until you have finished building the Curve chain.
This will automatically create a Deformation group connected to the top node of the selected
element. This group includes all the necessary deformation modules as well as the Bones, Curves and
Articulations you created. Note that this Network structure is the result of a simple rigging which
was created without the Automatically Create New Deformer Structure for each Pose/Drawing
preference.
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If you have just created the bone rig, the controls will still be showing. However, whenever you close your
project the deformers are turned off, so when you reopen the project you can show the ones you need
while you're animating.

Modifying a Deform Rig
How to set up a bone and articulation deformation chain
1. In the Network view, select the Deformation group you want to set up.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
button to
display the deformer controls in the Camera view. This also hides all the deformer controls that
were displayed.
3. In the Deformation toolbar, click the Setup Mode

button.

The chain turns from green to red. A green chain indicates the Setup mode is disabled. If so, click
the button again to enable it.
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4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, set up the deformation chain.
‣

Use the Pivot rotation handle to change the angle of the chain.

‣

Use the Pivot centre control point to reposition the entire chain.
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‣

Use the Articulation control point, the square at the bottom, to reposition the articulation.
This will elongate, shorten or change the direction of the first bone.

‣

Use the Articulation, top diamond-shaped, control point to change the size of the
articulation. For quality purposes, it is recommended to have an articulation which fits the
diameter of the part it controls.

‣

(Optional) In the Deformation toolbar, deselect the Show Simplified Manipulators
button to display all the manipulators. You can choose to work with the simplified
deformers, but if you need more control, you can also access the full deformers. You will
notice two extra square control points appearing in the middle of the articulation circle.
Drag these up and down to modify the steepness (bias) of the articulation.
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6. Repeat until all the articulations and bones of the chain are correctly aligned to the element it is
linked to.
7. With the Deformation group still selected, click the Copy Resting Position to Current
This will make sure to set the current resting position as the current frame one.

button.

8. In the Deformation toolbar, click the Setup Mode
button to turn off the mode. Then test your
modifications using the Transform
tool. For optimal results, make sure the size of the
articulation is about the same size as the drawing.
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Setting Up the Resting Position
Once you have a deformation chain created, you can optimize its positioning to fit the element it will
deform. This task is done in the Setup
mode.
A deformation rig has a resting position and an animated position. The resting position is the original
pose the character is in when not animated with keyframes. You can always revert your animated
character to its resting position to recover the initial scale, angle, and shape. You can revert the entire
character or only certain deformation chains, such as the arm or leg. You must make sure your resting
position is fully set before deploying the character in production.
The Bone, Curve and Articulation deformers have different sets of controllers.

How to set up a bone and articulation deformation chain
1. In the Network view, select the Deformation group you want to set up.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
button to
display the deformer controls in the Camera view. This also hides all the deformer controls that
were displayed.
3. In the Deformation toolbar, click the Setup Mode

button.

The chain turns from green to red. A green chain indicates the Setup mode is disabled. If so, click
the button again to enable it.

4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, set up the deformation chain.
‣

Use the Pivot rotation handle to change the angle of the chain.
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‣

Use the Pivot centre control point to reposition the entire chain.

‣

Use the Articulation control point, the square at the bottom, to reposition the articulation.
This will elongate, shorten or change the direction of the first bone.

‣

Use the Articulation, top diamond-shaped, control point to change the size of the
articulation. For quality purposes, it is recommended to have an articulation which fits the
diameter of the part it controls.
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(Optional) In the Deformation toolbar, deselect the Show Simplified Manipulators
button to display all the manipulators. You can choose to work with the simplified
deformers, but if you need more control, you can also access the full deformers. You will
notice two extra square control points appearing in the middle of the articulation circle.
Drag these up and down to modify the steepness (bias) of the articulation.

6. Repeat until all the articulations and bones of the chain are correctly aligned to the element it is
linked to.
7. With the Deformation group still selected, click the Copy Resting Position to Current
This will make sure to set the current resting position as the current frame one.

button.

8. In the Deformation toolbar, click the Setup Mode
button to turn off the mode. Then test your
modifications using the Transform
tool. For optimal results, make sure the size of the
articulation is about the same size as the drawing.

How to set up a curve deformation chain
1. In the Network view, select the Deformation group you want to set up.

2. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
display the deformer’s controls in the Camera view.
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3. In the Deformation toolbar, enable the Setup Mode

button.

The chain turns from green to red. A green chain indicates the Setup mode is disabled. If so, click
the button again to enable it.

4. In the Tools toolbar, select the Transform

tool.

5. In the Camera view, setup the deformation chain.
‣

Use the Pivot rotation handle to change the angle of the chain.

‣

Use the Pivot centre control point to reposition the entire chain.

‣

Use the curve handles to modify the shape of the curve.
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Use the curve’s square control points to resize and reposition each segment of the curve
chain.

6. Repeat until all the curves of the chain are correctly aligned to the element to which it is linked.
7. With the Deformation group still selected, click the Copy Resting Position to Current
This will make sure to set the current resting position as the current frame one.
8. In the Deformation toolbar, deselect the Setup Mode
the Transform
tool.
‣

button.

button and test your modifications using

You can also set up the resting position of the deformers by typing values directly into the
Layer Properties of the deformation effect modules.
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Manipulating a Deformer to Create Animation
The Bone, Articulation and Curve deformers have very different ways of being manipulated. When you
are choosing the type of deformation chain to use on each part, keep in mind the kind of animation
movement they can create.
•

Manipulating a Bone and Articulation Deformer below

•

Manipulating a Curve Deformer on page 508

Manipulating a Bone and Articulation Deformer
The Bone deformer operates in the same way as a human limb and is composed of a pivot as the
starting point, and bones and articulations.

How to animate a Bone and Articulation deformer
1. In the Timeline view, go the frame on which you want to create your first animation pose.
2. In the Deformation toolbar, deselect the Setup
Mode . If you leave Setup Mode on, you will
modify the resting position of the deformer chain instead of animating it. When Setup Mode is
disabled, the default colour of the deformation control is light green. If you made changes to your
rig in Setup mode, you can select the deform group and click Copy Resting Position to Current
button, located in the Deformation toolbar. This resets the rig outside the Setup mode to match
what the rig looks like in Setup mode.
3. If you want to create animation keyframes, enable the Animate
4. In the Tools toolbar, select the Transform

mode in the Tools toolbar.

tool.

5. From the Camera view, select the piece to animate.
6. In the Deformation toolbar, click the Show Selected Deformers and Hide All Others
display the deformer of the selected piece.

button to

7. In the Camera view, do the following:
‣

Click on the centre of the Deformation-Root pivot and drag it around to reposition the
entire limb.

‣

Use the first bone or the square pivot handle to rotate the entire limb.
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‣

Use the square control point located at the extremity of a bone to stretch or shorten its
length.

‣

Use a bone next to an articulation to rotate it. You can also hold down the Alt key to lock all
the controls and movement, and only allow the rotation of the articulation.

‣

Click and drag the articulation’s diamond-shaped control point to modify its radius.

8. In the Timeline view, go the frame on which you want to set your next key pose.
9. Repeat the previous steps to animate your character.
10. If needed, in the Deformation toolbar, deselect the Show Simplified Manipulators button
display the advanced controls.
11. In the Camera view, do the following:
‣

Click and drag the round articulation control points to adjust the steepness (bias) of the
articulation.
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Use the square articulation control point to rotate it.

You can also manipulate the deformer by typing values directly in the Layer Properties of the
deformation effect modules.

Manipulating a Curve Deformer
The Curve Deformer distorts the element to follow an organic and fluid curve line.

How to manipulate a Curve Deformer
1. In the Deformation toolbar, deselect the Setup
Mode . If you leave Setup Mode on, you will
modify the resting position of the deformer chain instead of animating it. When Setup Mode is
disabled, the default colour of the deformation control is light green.
2. If you want to create animation keyframes, enable the Animate
3. In the Tools toolbar, select the Transform

tool.
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4. In the top level of the Network view, press Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X) to select
all the modules or select Edit > Select All from the top menu.
5. In the Camera View toolbar, click the Show Control

button or press Shift + F11.

All the deformation controls in your scene are displayed—see Displaying the Deformation Controls
on page 491.
6. In the Camera view, do the following:

‣

Click on the centre of the Deformation-Root pivot and drag it around to reposition the
entire limb.

‣

Use the pivot’s square handle to rotate the entire chain.
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‣

Use the square control point located at the extremity of a bone to stretch or shorten its
length.

‣

Use the curve handles to modify the shape of the curve.

7. If you have a chain of several curves, you can get all the children of a curve to follow the movement
of one handle. This can be useful when, for example, animating an arm and you do not want the
fingers sticking to their original place while moving the wrist.

‣

Select the handle you want to move.

The handle’s colour turns white.

‣

Press and hold the Ctrl (Windows/Linux) or ⌘ (Mac OS X) and move the handle.

All the children follow the movement.
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8. If you have a double-sided handle, you can lock it, so only one side will move at a time.
‣

Select the handle you want to move independently from the other.

The handle’s colour turns white.

‣

Press and hold the Alt key and move the handle.

You can also manipulate the deformers by typing values directly in the Layer Properties of the
Deformation effect modules.
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Zones of Influence

To increase the quality of your animation and the accuracy of the Deformation effect, you can modify
the zones of influence around the deformation chains. A zone of influence is the area around the
deformer within which art will be influenced by the deformation. The deformer has the power to shape
all art contained within the influence area on its own element or on its children elements.
Zones of influence are different depending on the deformer type and zone type you selected.
You can find the settings for the zones of influence in the layer properties of the Curve, Bone and
Articulation modules as well as in the Rigging tool properties.
When working on a cut-out puppet built on several element layers, the best choice is to keep the
default Infinite option as the zone of influence type. In the following examples, the zones of influence
are explained through deformation chains on a single bitmap image. The image was previously
imported and vectorized with colour.
When you set up the shape of your Elliptic zone of influence, you should be as accurate as possible and
make sure that only the element that you want to follow the deformation is included inside the zone.
When you have an Elliptic zone of influence selected in the Network view, you can convert it to a
Shaped zone using the Convert Elliptic Zone of Influence to Shape option.
When you set up the boundaries of your Shaped zone of influence, you should be as accurate as
possible and make sure that only the elements that you want to follow the deformation are included
inside the zone.
To better illustrate the zone of influence Fade Radius and its effect, the bitmap picture will be
swapped with a grid pattern.
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There is an area called the deformer Fade which surrounds the zone of influence; this is the link
between the strict boundaries of the zone of influence and the surrounding region. This area gradually
stretches or squashes following the deformation. You can edit the Fade Radius value to modify the
size of this area and the exponent of the deformation fade effect.

You can change the default behaviour so the fading effect is inside the zone of influenceinstead of
outside. This is explained in this example.

You can also prevent a child’s element from undergoing its parent deformation by connecting it through a
kinematic output—see Assembling the Parts on page 529.

How to select a zone type
1. In the Deformation toolbar, enable the Setup Mode

.

2. Once you have created a Bone and Articulation or Curve deformation chain, in the Network view,
navigate to your deformer module, inside the element’s Deformation Group and inside the pose
subgroup if applicable.

3. Click on the deformer module’s square yellow button to open the Layer Properties dialog box.
4. In the deformer Layer Properties, select the type of Zone of Influence you want from the Influence
Type menu.
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Parameter

Zones of Influence

Description

Zero InfluThe Zone of Influence does not exist. No deformation will happen.
ence

Infinite
Influence

The default and most commonly used zone of influence. The Zone of Influence has no boundary and covers the whole element to which the deformer is linked to and its children, excluding areas that are already part of another elliptic or shaped zone of influence. The Infinite
influence zone will from the centre of your skeleton, going towards infinity, working in perpendicular with the skeleton. This is the recommended Zone type for a cut-out puppet
assembled from several element layers.
The zone of influence boundary is defined by an elliptical shape whose size can be
customized using the Bone, Articulation or Curve module properties or by using
the Transform
tool. The Elliptic Influence is most likely to be used on a bitmap
picture you want to deform.

Elliptic
Influence

The zone of influence boundary is defined by a shape which you can customize
using the Transform
tool. The Elliptic Influence is most likely to be used on a
bitmap picture you want to deform.

Shaped
Influence
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5. When you select the Elliptic or Shaped type, the zone of influence appears in the Camera view
where you can customize the shape using the Transform tool and Layer Properties options.

This example illustrates the Zones of Influence of a Curve deformer. This example also applies to the Bone
and Articulation deformers.

You can also use the Convert Elliptic Deformation ROI to Shape function to convert your Elliptic zone of
influence to a shape. From the top menu, select Animation > Deformation > Convert Elliptic
Deformation ROI to Shape. This function will create a much smaller initial zone of influence than if you
were to convert it directly to a shape.

How to set up the Elliptic zone of influence
1. In the Deformation toolbar, enable the Setup Mode
2. In the Tools toolbar, select the Transform

.

tool.

3. In the Network view, select the deformer’s module to which you want to customize the Elliptic
Zone of Influence.
4. Click on the deformer module’s square yellow button to open the Layer Properties dialog box.

5. In the deformer Layer Properties, setup the ellipse shape by adding values to the various fields:
Parameter

Description

Symmetric Ellipse Influence

Enabled by default. The shape of the ellipse will be symmetrical on both
the transversal and longitudinal radii. In this case, use the Transversal
Influence Radius Left field to set the transversal radius value and use the
Longitudinal Influence Radius End field to set the longitudinal radius
value. The two other fields will remain unused, unless you disable the
Symmetric Ellipse Influence option. In that case, you can set up different
radii sizes for the four radii directions.

Transversal Influence Radius
Left

When the Symmetric Ellipse of Influence option is enabled,
this field controls both Left and Right transversal radius
values. When disabled, it controls the size of the left
transversal radius. By default this value is set to 2.
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Transversal Influence Radius
Right

Longitudinal Influence Radius
Begin

When the Symmetric Ellipse of Influence option is enabled,
this field loses its influence. The Left Transversal radius value
is automatically applied to the Right Transversal. When this
option is disabled, it controls the size of the Right Transversal
radius. By default this value is set to 2.

When the Symmetric Ellipse of Influence option is enabled,
this field loses its influence. The End Longitudinal value is
automatically applied to the Begin Longitudinal. When this
option is disabled, it controls the size of the Begin
Longitudinal radius. By default this value is set to 0.25.

When the Symmetric Ellipse of Influence option is enabled,
this field controls both the Begin and End Longitudinal radius
values. When this option is disabled, it controls the size of the
End Longitudinal radius. By default this value is set to 0.25.
Longitudinal Influence Radius
End

6. You can also modify the elliptic shape in the Camera view, using the Transform
‣

tool.

If the Symmetric Ellipse of Influence option is enabled, one control point will be available in
the Camera view. Drag this point in any direction to increase or decrease the size of the
Zone. Dragging it left/right will modify both longitudinal radius sizes. Dragging it up/down
will modify both transversal radius sizes.
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‣

If the Symmetric Ellipse of Influence is disabled, two control points will be available in the
Camera view. Drag the top-corner point left/right to modify the end longitudinal radius size
and up/down to modify the left transversal radius size. Drag the bottom-corner control
point left/right to modify the beginning longitudinal radius size and up/down to modify the
right transversal radius size.

You can also select the Zone of Influence type in the Rigging Tool Properties to change the default setting
before creating a deformation chain—see Rigging Tool Properties on page 536.

How to convert an Elliptic zone of influence to a shape
1. In the Deformation toolbar, enable the Setup Mode

.

2. In the Network view, select the deformer module that has an elliptic zone of influence type.

3. In the Deformation toolbar or Rigging Tool Properties, click the Convert Elliptic Zone of Influence
to Shape
button.
The zone of influence will automatically be converted to a shape. It will keep the shape it was when
the button was pressed except, control points will appear all around the zone to allow the shape
to be customized.
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Refer to the section below to learn how to customize a shaped zone of influence .

How to set up the Shaped zone of influence
1. In the Deformation toolbar, enable the Setup Mode
2. In the Tools toolbar, select the Transform

.

tool.

3. In the Network view, select the deformer module in which you want to customize the Shaped zone
of influence .
If you selected the Shaped option in the Layer Properties dialog box or in the Rigging tool
properties, the zone of influence will be square. This square has control points on all four corners
and each control point as two control levers. If you converted an Elliptic zone to a shape, the zone
will have more control points and handles.

‣

Click and drag a control point to redefine its position and shape.

‣

Click and drag the control lever handle to modify the corners and redefine the shape.
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‣

Hold Alt down while dragging the control lever handle to move one handle at a time.

Refer to the section to learn how to convert an elliptic zone to a shape.

How to modify the Fade Radius and Exponent
1. In the Network view, select the deformer module you want to modify. Note that this deformer
needs to have an Elliptic or Shaped zone of influence type.
2. Click on the yellow square button of the module to open the Layer Properties dialog box.

3. Adjust the Influence Fade Radius field to modify size of the fading area. The default value is 0.5.
4. Click Close.
5. In the Network view, locate the Deformation-Switch module under the Deformation-Composite
module in your deformation chain.
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6. Click on the yellow square button on the Deformation-Switch module to open the Layer Properties
dialog box.

7. In the Layer Properties dialog box:
Parameter

Description
Use the up and down arrow to modify the exponent value or type the
exact value in the field.

Influence Fade Exponent

Fade Inside Region

•

A value of 1 is similar to a linear curve.

•

A higher value will result in an ease-in type of curve.

•

A lower value will result in an ease-out type of curve.

By default this option is disabled, meaning that the Fade effect will
occur outside of the Zone of Influence. You can enable this option so
that the fade effect is inside the Zone of Influence.

520

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Converting Your Deformation Animation to Drawings
You may at times want to adjust your deformation animation using the drawing tools in order to
perfect something, or add detail. You might also want to change the timing and set it on double
frame, rather than single frame. Harmony offers you the option to convert your deformation animation
to an image sequence.

How to convert deformation animation to drawings
1. In the Timeline view, select the deformation frame range for which you wish to convert to drawings.

2. From the top menu, select Animation > Deformation > Convert Deformed Drawing to
Drawings.
The Baking Drawing process window opens. Wait for the baking to complete.
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Creating a Full Character Turnaround Deformation Rig

Creating and rigging a full character turnaround is a complex process, but it can easily be achieved by
following the step-by-step process explained in this chapter.
For a more simplified process, you can keep each view of your character separate on the Timeline or in
the Network view. If you create separate rigs for each view, then you can simply turn on or off the
exposure of each view in the Timeline when needed. In this case, you can simplify the process by not
having to create posed deformers or use drawing pivots.
However if you want to keep the entire character, with all views, in one group/rig on your Timeline,
then you can follow the process described here.
This section is divided as follows:
•

Preparing the Character below

•

Enabling the Posed Deformer Preference on the facing page

•

Renaming the Drawings on page 524

•

Rigging the Parts on page 526

•

Assembling the Parts on page 529

Preparing the Character
Before building a puppet’s deformation skeleton, you must prepare your character. The best way to
proceed is to have the limbs on separate drawing layers. This is similar to a standard cut-out puppet
preparation, but uses fewer pieces. Since this is a more advanced type of puppet, you should keep the
character’s head, hands, feet, and facial features on a separate layer from the body, arms, and legs.
This will avoid the extremities from being distorted if the limbs are stretched during an action. It will
also let you use drawing substitution to swap hands, feet, eyes and mouth poses during animation—
see Swapping Images.
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There are many ways to break down a cut-out puppet. The example described in this chapter uses
these pieces:
•

Body

•

Left Ear

•

Right Ear

•

Head

•

Left Eye

•

Right Eye

•

Mouth

•

Left
Eyebrow

•

Right
Eyebrow

•

Nose

•

Left Arm

•

Right
Arm

•

Left
Hand

•

Right
Hand

•

Left Leg

•

Right Leg

•

Left Foot

•

Right
Foot

Refer to the following topics to learn how to break down a character:
•

About the Model on page 284

•

Relative Sizes on page 286

•

Studying the Model on page 288

•

Breaking Down the Character on page 299

•

Adding Extra Drawings on page 338

Enabling the Posed Deformer Preference

The first thing you should do when rigging your character turnaround is to make sure to select the
Automatically Create New Deformer Structure for Each Pose/Drawing preference. This preference is on the
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Deformation tab of the Preferences dialog box; by default this option is selected.

When rigging with this preference enabled, notice that the structure of the deformation inside the
Deformation group is slightly different than when executing a basic rig with the preference disabled.
Each pose you rig within the same element is part of a separate subgroup all of which are gathered
together by a Deformation-Composite module; each subgroup is called by its drawing number or
name. These subgroups cannot be renamed once the rig is complete, as the name of the group and
drawing is the link between them. If you kept the default drawing numbering of 1, 2, 3, and so on, your
groups will be called 1, 2, 3, and so on. For this reason, you might want to rename your drawing
before you start rigging so the names correspond to the poses. For example: front, side, quarter, etc.

Renaming the Drawings
Although renaming your drawings is not mandatory, it can prove useful in maintaining a clear Network
structure for your project. If you leave your drawing as is and do not rename it, your deformation
subgroups will be automatically named according to the drawing numbering. If you plan to have
several drawings using the same rig within an element, for instance, drawing substitution, then you
should rename these extra drawings before starting your rig, or you will find that extra unused
subgroups will be created automatically.
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How to rename drawings to link them to the same chain
1. In the Xsheet view, locate the column that corresponds to the element which includes several
drawings that will use the same chain, such as a character that has several costumes which you plan
to swap by using drawing substitution. In our example, we will use the rabbit’s feet, which will all
use the same deformation curve.

2. In the Xsheet view, select the first drawing of the column. This is the one that will be rigged.
3. From the Xsheet view menu, select Drawings > Rename Drawing or press Ctrl + D
(Windows/Linux) or ⌘ + D (Mac OS X).
4. In the Rename Drawing dialog box, type a relevant new name for the drawing and click OK.
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5. In the Xsheet view, select the next drawing in the column and select Drawings > Rename Drawing
from the Xsheet view menu.
6. In the Rename Drawing dialog box, type the same name that you gave the first drawing of the
column, exactly as it is written and add a plus sign (+) and any number. For example, if the first
drawing is named front, the subsequent drawings are named: front+1, front+2, front+3,
etc.

You must strictly adhere to this rule if you want the extra drawings to be linked to the deformation chain of
the main drawing.

7. Repeat steps 5 and step 6 for each subsequent drawing that needs to be linked to the same
deformation chain.

Rigging the Parts
You can start your deformation rig by creating the Bones or Curves on the character’s arms and legs.
The style of animation you plan on producing will influence the style of rig you will use (Bones and
Articulations or Curves).

How to rig the arms and legs of the character turnaround
1. In the Timeline view, make sure the time marker is set to the frame displaying your first drawing.
2. In the Network view, select your character’s arm or leg.

3. In the Deformation toolbar, select the Rigging

tool.

4. In the Rigging Tool Properties, set the mode to Automatic

.

5. To create a Bones and Articulations structure:
‣

Click on the extremity corresponding to the shoulder or hip of the limb and release to
create the first rotation point.

‣

Click again in the middle of the limb where the elbow or knee is located to create the first
articulation.

526

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

‣

Click one last time at the end of the limb, where the wrist or ankle rests to create the second
bone.

6. To create a Curve structure:
‣

Click on the extremity corresponding to the shoulder or hip of the limb and drag the cursor
to extend the first control handle.

‣

Click at the end of the limb, where the wrist or ankle rests and drag the cursor to extend the
second control handle.

7. In the Timeline view, move the time marker to display the frame with the next pose of that drawing
element.
8. Repeat the previous steps until all of the element‘s different poses are rigged, then begin the
whole process again for each limb. Although it is recommended to keep consistency in your rigging
of different poses in the same element, you can choose a different type of rig for each pose if
necessary.

You can also set the Rigging Tool Properties mode to Curve
or Bone
mistakes leading to the creation of the wrong type of deformer.

. This will prevent gesture

Once you create a chain, you can modify its position and orientation using the Setup
Transform
tool—see Skeleton Optimization on page 344.

Mode and

Linking Extra Drawings to a Single Rig
When you have several drawings that will use exactly the same rig, there is a special naming rule to
follow so that the same rig is linked to these different drawings. This can happen when you have
drawing substitution in this layer.
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You should rename your extra drawings BEFORE rigging the main drawing of your element. Otherwise, an
unnecessary subgroup will be created for each extra drawing—see Renaming the Drawings on page 524.

Once your drawings are correctly named, you can start the rigging process.

How to link extra drawings to a single rig
1. In the Timeline view, make sure that the time marker is on the first frame or the frame displaying
the main drawing.
2. In the Network view, select your element’s module.

3. In the Deformation toolbar, select the Rigging

tool.

4. In the Rigging tool Tool Properties, set the mode to either Automatic

, Curve

or Bone

5. In the Camera view, build your Curve or Bone deformation chain—see Rigging the Parts on
page 526.

6. Switch to the next drawing or press G. Notice that the subsequent drawings that are part of the
link already have a deformation chain. This is the same as you just created for the main drawing.

7. If you look in the Deformation group of your element in the Network view, notice there are no
subgroups created for the extra drawings. They are all automatically linked to the main drawing’s
deformation chain.

528

.

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Assembling the Parts
After you have created all the deformation chains for your character, you will need to assemble these
separate body parts into a puppet.
To avoid problems such as having the head stretched by the neck deformers or a hand modified by the
neck and body deformers, it is recommended to put them on a separate layer. When they are on a
separate layer, rig them using a Kinematic output coming directly from your Deformation group,
instead of the normal hierarchy connection between modules. This will let you connect a part directly
to it, so it will only be influenced by the position of its parent and not undergo any deformation. This is
recommended as a method of optimizing the functionality of the puppet and also as a way of avoiding
any unwanted distortion effects for any assembled parts.

How to assemble the puppet’s parts
1. In the Network view, locate the puppet’s head. You can also select the head in the Camera view
using the Transform tool and then press O in the Network view to center your selection.

2. If you did not add a Deformation effect to this module, you can connect all the facial feature
modules as its children, just as you would normally do with a typical cut-out character rig.
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1. In the Network view, locate the body of the puppet. Select the Deformation group linked to the
character’s body module.

2. In the Deformation toolbar, click the Create Kinematic Output

button.

A Deformation-Composite module is added inside your Deformation group. This is set up to
create a special output which you can use to connect your modules and create the puppet’s
hierarchy. It also automatically creates the necessary connections, so that every pose is part of the
setup. The deformation will not influence the modules that are connected to this output.

By default, the last deformer module of each deformation chain is connected to this new
Deformation-Composite. The extremity of this deformer is where the child element will be
attached. In this case, the last bone is the neck.

If your network becomes tangled, select the lower module of the tree and click the Order Network Up
button. Leave the settings to default and click OK.
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3. As there will be several parts connected to this body Deformation group, you should rename the
new Composite module with a relevant name. Click on the module’s yellow square button to
display the Deformation-Composite module’s properties.

4. In the Name field, type a new name for the module and click Close.
5. In the Network view, exit the Deformation group and go back to Top level.
6. Connect the new bottom port of the body Deformation group module into the top port of the
head module.

7. In the Network view, select the body Deformation group module again and click the Create
Kinematic Output
button to create another kinematic output.
8. Enter the Deformation group and rename the newly created Deformation-Composite module. In
this example: body-shoulder.

By default, the last deformer of each subgroup is linked to this new Deformation-Composite
module. In this case, this Composite will act as the shoulder attachment for the two arms. If the
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connections are left as is, the arms will follow the movements of the neck and head. For this
reason, it is important to select the correct Bone or Articulation.
9. In the Network view, enter the first deformation subgroup.

10. Inside the first subgroup, locate the connection to break.

If you hover the cursor over the top of a node on the Multi-Port-Out module, a tooltip window will display
information about the module and port number it is connected to.

In this example, we need to break the connection to the Body-shoulder module. Click on the node
and pull out the cable to disconnect it.

Notice that the disconnected node will still be visible on the Multi-Port-Out module. This is because
a cable is still connected to the output port outside of the subgroup. This will be removed at a later
step.
11. Locate the Bone,Articulation or Curve which you want to connect the arms to and find its module in
the deformation chain. In this example, the arms should be connected to the previous bone in the
chain. They should not be connected to the articulation in between, because the arms would follow
the rotation of the articulation instead of following the steady position of the shoulders.

12. Click on the desired deformer module bottom node and drag the cable to the Multi-Port-Out
module to create a connection.
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13. Exit the subgroup and go back to the body Deformation group.
14. Disconnect the current unused connection between your first subgroup and the shoulder
Deformation-Composite module. This will also remove the empty node on the Multi-Port-Out
module inside your subgroup.

15. Connect the remaining bottom node of your subgroup to the shoulder Deformation-Composite
module.

16. Repeat steps 9 to 15 for each subgroup contained in your body Deformation Group.
17. In the Network view, go back to the Top level.
18. Connect the two arms to the available bottom node of the body Deformation group.
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19. Repeat steps 7 to 18 for the legs and any other parts that need to be assembled. Remember to link
the deformer modules used for the hips to the Kinematic Output.

When you have completed this process the body Deformation group should look similar to this.

And the final network should look similar to this.
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Setting Up the Pivots
When building a cut-out puppet with deformation effects, each part controlled by a deformation chain
will automatically rotate from the Deformation-Root point, which acts like a pivot. Because it is unlikely
that every piece of your character will be rigged with a deformation chain, you must set pivot points—
see Setting the Pivots on page 340.
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Deformation Toolbar
The Deformation toolbar contains the various tools and options used to create the Deformation
effect. This toolbar is displayed in the default interface.

Rigging Tool

The Rigging Tool is used to create either a Bone or Curve deformation chain and automatically create
a Deformation group on a selected element. Using this tool considerably speeds up the rigging
process by automatically creating all the necessary links and modules for your deformation chain.

Rigging Tool Properties

In the Rigging Tool Properties dialog box, you can customize not only the behaviour of the tool but
also the settings of the deformers that you will create:
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•

Mode below

•

Rig Tool Options below

•

Operations on the next page

Mode
Name

Button

Description

Automatic Mode

Sets the Rigging tool to automatically create a Bone
or Curve deformer, corresponding to the movement
of the cursor in the Camera view.

Bone Mode

Sets the Rigging tool to create Bone deformers.

Curve Mode

Sets the Rigging tool to create Curve deformers.
Lets you immediately see the resting position in red
(Setup) and the animated position in green—see
Show All Manipulators on the next page.

Show All
Manipulators

Lets you visualize the area within which the art will be
influenced by the deformation effect—see Show All
Zones of Influence on the next page.

Show All Zones of Influence

Rig Tool Options
Parameter

Description
The Zone of Influence setting used as the default when creating an articulation, bone deformer or curve deformer using the Rigging tool.
Zero Influence: The Zone of Influence does not exist. No deformation
will happen.

Articulation, Bone, Curve

Infinite Influence: This is the default option and is the most commonly
used. The Zone of Influence has no boundary and covers the whole element to which the deformer is linked and its children, excluding areas that
are already part of another elliptic or shaped Zone of Influence. The Infinite Influence zone will extend from the centre of your skeleton to infinity,
working perpendicular to the skeleton.
Elliptic Influence: The Zone of Influence boundary is defined by an elliptical shape; its size can be customized using the Bone, Articulation or
Curve module properties or by using the Transform
tool. The Elliptic
Influence will most likely be used on a bitmap picture you want to deform.
Shaped Influence: The Zone of Influence boundary is defined by a shape
which you can customize using the Transform
tool. The Shaped Influence will most likely be used on a bitmap picture you want to deform.

Influence Radius

This value is the size of the influence zone. The default value is 2.

Bone Ratio

This value sets the size of the articulation that will be created relative to
the size of the bone that precedes it.
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Operations
Name

Button

Description
After you have created a deformation chain using
Elliptic as the Zone of Influence type, you can select
your deformer and click on this button to convert it to
a Shape type. Control points will appear around the
shape making it easy to customize.

Convert Elliptic
Zone of Influence to
Shape
Copy Resting Position to Current

Copies the resting position of the deformation skeleton to the current frame.

Setup Mode
, you can use the Transform
tool to adjust the position, resize and
When you are in Setup mode
tweak the Bone, Articulation and Curve deformers which you created using the Rigging tool. When in
Setup mode, the manipulators appear in red in the Camera view—see Deformation Basics on
page 491and Setting Up the Resting Position on page 500.

Show All Manipulators

The Show All Manipulators
button lets you visualize the resting position in red (Setup mode) and
the active position in green at the same time—see Deformation Basics on page 491 to learn how to
make the manipulators visible in the Camera view.

Show All Zones of Influence

The Zones of Influence
button displays all zones of influence in the deformers in your project. Note
that the deformer’s controls must be visible in order for its Zone of Influence to show. Zones will not
be displayed when a deformer’s Zone of Influence is set to Infinite or Zero—see Deformation Basics on
page 491and Zones of Influence on page 512.
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Show Simplified Manipulators
button hides some of the more advanced control handles that
The Show Simplified Manipulators
are visible in the Camera view. This can prove useful when animating, as it prevents you from
inadvertently moving the handles—see Deformation Basics on page 491 to learn how to make the
manipulators visible in the Camera view.

Show Selected Manipulators and Hide All Others
The Show Selected Manipulators and Hide All Others
button hides all manipulators displayed in
the Camera view. Only the manipulators of the selected deformation module are displayed—see
Deformation Basics on page 491 to learn how to make the manipulators visible in the Camera view.

Insert Deformation Above
The Insert Deformation Above
button adds a Deformation group above the selected element.
This contains all the basic Deformation modules you need to begin the manual construction of a
deformation chain, namely the Deformation-Root, Deformation-Composite and Deformation-Switch
modules. If your preferences are set to create pose deformation, the subgroups linking to each of the
drawings of the selected elements will also be created. After which you can use the various
Deformation Effect modules from the Module Library and start rigging.

If you are planning to rig your element using the Rigging
the Rigging tool will do it automatically.

tool, you will not need to use this option, as

Insert Deformation Under
The Insert Deformation Under
button adds a Deformation group under the selected element. This
contains all the basic Deformation modules you need to begin the manual construction of a
deformation chain, namely the Deformation-Root, Deformation-Composite and Deformation-Switch
modules. If your preferences are set to create pose deformation, the subgroups linking to each of the
drawings of the selected elements will also be created. After which you can use the various
Deformation Effect modules from the Module Library and start rigging.
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If you are planning to rig your element using the Rigging
the Rigging tool will do it automatically.

tool, you will not need to use this option, as

Create Kinematic Output
The Create Kinetic Output
button adds an output to your deformation which lets you hook a
separate element that you want to be linked to the deformation chain but not be part of the
deformation. For example, a hand connected to a wrist or when assembling different parts of a
character without having the different deformation chains influencing one another. These elements will
follow movement of the chain just like a regular cut-out character hierarchy piece without being
influenced by the deformation of the arm—see Assembling the Parts on page 529 to learn more about
the use of Kinematic Output.

Copy Resting Position to Current
button displays the resting position, the original setup of
The Copy Resting Position to Current
your skeleton before undergoing any deformation. Once you have created a deformation chain, you
can use the Setup Mode button to adjust the position and appearance of the rig to fit the element.
When the skeleton is in place, you can use the Copy Resting Position to Current button to reset the
current frame position to the resting position which you just modified leaving everything in place when
you exit the Setup mode. If you do not use this option, the rig will undergo a deformation and revert
to the position it was before you set up your skeleton, in relation to the new resting position.

Convert Ellipse
Once you have created a deformation chain using Elliptic as the Zone of Influence type, you can select
type. Control points
your deformer and click the Convert Ellipse button to convert it to a Shape
will appear around the shape making it easy to customize. This option is also available in the tool
properties of the Rigging tool—see Zones of Influence on page 512 topic to learn more about using
the zones of influence.

You can also use the Convert Elliptic Deformation ROI to Shape function to convert your Elliptic zone of
influence to a shape. From the top menu, select Animation > Deformation > Convert Elliptic Deformation
ROI to Shape. This function will create a much smaller initial zone of influence than if you were to convert it
directly to a shape.

Convert to New Drawing and Add Pose
After creating your deformation rig, you may want to convert a pose and the deformer in the current
frame to a drawing with a duplicate deformer that you can animate. This can be useful when you want
to add a pose to a turnaround deformation rig you have already spent time creating and manipulating.
The Convert to New Drawing and Add Pose
option will take the pose/drawing and the deformer
of the selected frame and convert it to a new pose/drawing with the corresponding deformer. This
option works with the default deformation preference settings. Go to Edit > Preferences (Windows)
or Stage > Preferences (Mac OS X) and select the Deformation tab. Make sure that Automatically
Create New Deformer Structure for Each Pose/Drawing is selected.
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Keep the naming convention of the drawing consistent between all views or the drawing link will be broken.
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Deformer Effects
There are 13 deformer effects modules. These effects enhance the existing deformation by applying
specific types of effects to the Bone Deformer or the Curve Deformer. Secondary deformers must be
used in conjunction with either the Bone Deformer or the Curve Deformer to work.
To understand the various parameters better, you should know the following terms:
•

Radius: The radius determines the size of a zone. The radius value is the length from the central
point of the zone to its edge. By increasing the radius value, you increase the size of the area.

•

Transversal: The transversal parameter is related to the width of the zone in relation to the bone.
The transversal value cuts across the bone.
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•

Longitudinal: The longitudinal parameter is related to the length of the zone in relation to the
bone. The longitudinal value is parallel to the bone's length.

Articulation
The Articulation module is used between two bones to create a joint where the limb or element will
rotate.
When you create a bone structure using the Rigging
tool, an Articulation module is automatically
added between every two bones you create. You can also add an Articulation module to your Bone
deformation effect in the network to add a supplementary articulation to any existing limb previously
built. This module can also be used to manually build a bone structure. The Articulation module
works best when inserted between two Bone modules—see Bone Deformer on page 488.
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If you adjust your rig in Setup mode with the Transform tool, it will adjust these parameters for you—
see Setting Up the Resting Position on page 500. However, you can manually set the Articulation
effect module parameters in the Layer Properties dialog:
Parameter

Description

Name

Use this field to rename the module.

Influence Type

Lets you choose a zone of influence type. This is the area of the
drawing surrounding the deformer which will be influenced
(deformed) by the deformation.

Influence Fade Radius

Enter the your Fade Radius value for the Zone of Influence. You
can also use the up and down arrow buttons to select a value.
This option is enabled by default. The shape of the
ellipse will be symmetrical on both transversal and
longitudinal radius. The following will happen:

Symmetric Ellipse of Influence

•

The value for Transversal Influence Radius Left will
define the value for the Transversal Influence
Radius Right.

•

The Transversal Influence Radius End value will
define the value for the Transversal Influence
Radius Begin.

Note: If you want to define individual values for
these, then deselect the Symmetric Ellipse of
Influence option and enter the values required for
each.

Transversal Influence Radius Left

When the Symmetric Ellipse of Influence option is enabled, this
field controls both the Left and Right Transversal Radius values.
When the option is disabled, enter the value in this field to control the size of the Left Transversal Radius.

Transversal Influence Radius Right

When the Symmetric Ellipse of Influence option is enabled, the
value in this field will be unused. When the option is disabled,
enter the value in this field to control the size of the Right Transversal Radius.

Longitudinal Influence Radius Begin

When the Symmetric Ellipse of Influence option is enabled, the
value in this field will be unused.When the option is disabled,
enter the value in this field to control the size of the radius at
the beginning of the deformer.

Longitudinal Influence Radius End

When the Symmetric Ellipse of Influence option is enabled, this
field controls both the End and Begin longitudinal radius values.
When the option is disabled, enter the value in this field to control the size of the radius at the end of the deformer.

Rest Radius

Lets you set the resting radius of the articulation (size of the
circle).

Resting Orientation

Lets you set the resting rotation angle value of the articulation.
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Rest Bias

Lets you set the resting bias value of the articulation, which can
also be seen as the steepness of the articulation. The smaller
the bias value the smoother the articulation angle and the larger the bias value the more angular the articulation is.

Radius

Lets you set the radius of the articulation (size of the circle).
When animated, this value will be connected to a function.

Orientation

Lets you set the rotation angle value of the articulation. When
animated, this value will be connected to a function.

Bias

Lets you set the bias value, which can also be seen as the steepness of the articulation. When animated, this value will be connected to a function.

AutoFold

The AutoFold module is used to automatically fix the folding area of a deformer so no line overlap
occurs. The AutoFold module is similar to the Fold module, but since it is automated it is optimized
to fit the most standard folding point with fewer controls to set up.
This effect module is best used with Curve Deformers.

How to use the AutoFold module
1. In the Camera view, enable Render

mode to preview what the fold will look like.

2. In the Network view, navigate to the Deformation effect module which is causing the unwanted
overlap.
3. In the Module Library, select an AutoFold module and drag it to the Network view.
4. Connect the AutoFold module directly under the Deformation effect module which is causing the
unwanted line effect.
5. Click the square yellow button to open the AutoFold Layers Properties dialog box. This is where
you can customize the AutoFold settings.
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6. In the Enable AutoFold field, type 1 to enable it or 0 to disable the effect.

If you connect this option to a function, then you can enable or disable the effect at a specific point in
your animation.

7. In the Length field, set the length of the fold axis line.
8. Click Close.

Auto-Muscle
The Auto-Muscle module is used to simulate muscle movement. This will allow your characters to flex
their muscles when they lift something or to create muscle-tone when they move. When the AutoMuscle module is connected to a Bone Deformer that is rotated, the drawing is automatically
inflated to simulate muscle movement in the limb.
How to use the Auto-Muscle module
1. In the Network view, navigate inside the Deformation Group you want to add an Auto-Muscle
effect to.
2. In the Module Library, select an Auto-Muscle module and drag it to the Network view.
3. Connect the Auto-Muscle module directly under the Articulation and after the Bone you want the
effect to be applied to.
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4. In the Network view, click on the Auto-Muscle module’s square yellow button to open the Layer
Properties dialog box.

5. You can set the following parameters in the Auto-Muscle Layer Properties dialog box:
Parameter

Description

Name

Use this field to rename the module.
This option is enabled by default. When enabled, the left side of the Bone
Deformer will inflate as the articulation is rotated toward the direction of the Bone
Deformer. Disable this option if you do not want the left side of the bone to
inflate.

Muscle
Left

The default value of the starting position of the left-side muscle is set to -2. This
means it will start at the deformer situated two steps before the position where
the Auto-Muscle is connected. You can change the starting point by typing the
number corresponding to the deformer module.

Left Start

This parameter controls the length (muscle length) over which the effect module will be
Left Span applied to the left side of the deformer. By default the setting is 1, representing the length of
the deformer to which it is applied.

547

Chapter 12: Deformation

Deformer Effects

This parameter controls the physical size of the left muscle. Increase the value to
make the muscle bigger, decrease the value to make it smaller.
Left
Amplitude

This option is enabled by default. When enabled, the right side of the Bone
Deformer will inflate as the articulation is rotated toward the direction of the Bone
Deformer. Disable this option if you do not want the right side of the bone to
inflate.
Muscle
Right

This option is enabled by default, allowing each side of the Bone Deformer to
inflate to follow the rotation of the articulation. Enable this option to synchronize
the right muscle with the left so both muscles will inflate when the articulation is
rotated to the left.

Same as
Left

Right
Start

The default value of the starting position of the right-side muscle is set to -2. This
means it will start at the deformer situated two steps before where the AutoMuscle is connected, in this case, Bone. You can change the starting point by
typing the number corresponding to the deformer module.
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Right
Span

This parameter controls the length (muscle length) over which the effect module will be
applied to the right side of the deformer. By default the setting is 1, representing the length
of the deformer to which it is applied.

Right
This parameter controls the physical size of the right muscle. Increase the value to make the
Amplitudmuscle bigger, decrease the value to make it smaller.
e

Deformation-Composite
Just like a standard Composite module, the Deformation-Composite module is used to bring
together all the elements that are connected to it, allowing you to customize parameters that will
influence the result of the output.
The Deformation-Composite links the deformation chain to the graphic element to which it is
related. This is automatically added to your Deformation Group when creating a deformer chain with
the Rigging
tool.

You can set up the following parameters in the Deformation-Composite Layer Properties window:
Parameter

Description

Name

Use this field to rename the module.

Output Kinematic Only

This option is disabled by default, allowing the deformation
chain to be output correctly. This option should be enabled in
order to output the chain information position only. This will
allow you to connect a part to the hierarchy without it undergoing the deformation applied to the rest of the chain—see
Assembling the Parts on page 529

Output Selected Port Only

This option is important if you have several
deformation chains for one element, as in the case of
a character with multiple poses.
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•

When this option is enabled, it will only use the
selected chain, which you will be able to define in
the Output Kinematic Chain options of the
Deformation-Composite. In some situations, this
option is enabled and setup automatically (For
example, when you are working with the Create
Posed Deformer in Create Deformation
Above/Under enabled)—see Creating a Full
Character Turnaround Deformation Rig on
page 522

•

When this option is disabled, all the different
chains for this element will be used at once.

Lets you select a deformation chain option to use.
This parameter is used when the Output Selected
Port Only option is enabled.

Output Kinematic Chain

Rightmost: Only the first chain connected to the right of the
composite module will be used.
Leftmost: Only the first chain connected to the left of the composite module will be used.
Select: If you select this option, you can define which chain to
output according to the order they are connected from left to
right.
Use First Connected Element’s Exposure as Key: Allows the
deformation effect to automatically detect which deformation
chain to use (subgroup) by detecting the exposure of the first
element connected to the deformation. This option is used in
the case of a multiple pose rig—see Creating a Full Character
Turnaround Deformation Rig on page 522
Use Parent Composite’s Connected Element Exposure:
When the Output Kinematic Only option enabled, the information from the parent element’s exposure is used to attach the
child to the correct chain, following which pose is exposed—
see Assembling the Parts on page 529
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When the Output Selected Port Only option is
selected AND the Select option is used as the
Output Kinematic Chain setting, this field defines
which deformation chain you want to use on your
element. Select the number which corresponds to
the left to right order that the chains are connected
to the Deformation-Composite module.

Output Kinematic Chain Selection
You can attach this value to a function and enable
different chains over a period of time on specific
frames. This value can be modified in the Timeline
view by using the Deformation-Switch layer. Since
the Deformation-Composite module is only visible in
the Network view, the layer has a reference to this
parameter enabling you to easily edit the value when
working in the Timeline view.
Note: If you are working with Create Posed
Deformer in Create Deformation Above/Under
enabled, you will not need to set up this option. The
settings in the Deformation-Composite module will
automatically be set up and the system will
recognize which chain to use following the element’s
exposure—see Creating a Full Character
Turnaround Deformation Rig on page 522

Deformation-Root
The Deformation-Root is the starting point and pivot for the deformer chain. When you use the
Rigging
tool, this module is automatically added to the top of your deformation chain in the
Deformation group.
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You can modify the quality level of the Deformation effect in the Deformation-Root Layer Properties
window:
Parameter

Description

Name

Use this field to rename the module.
Defines the number of slices the graphic is split into and used
when undergoing a deformation. The higher the quality level,
the more slices are created and the smoother the
deformation applied to the graphic. There are five levels of
quality:

Quality

•

Low

•

Medium

•

High

•

Very High (default value)

•

Extreme

Deformation-Scale
The deformers can only be scaled along the centre axis to adjust the length of the limb. The
Deformation-Scale can be used in combination with a Bone or Curve deformer to scale a drawing so
it follows the opposite direction of the deformer axis (the width). For example, when combined with
function curves this can be used to create advanced muscle effects. All these settings can be
animated over time.
How to set up the Deformation-Scale effect module
1. In the Network view, navigate inside the Deformation Group to which you want to add a
Deformation-Scale effect.
2. In the Module Library, select a Deformation-Scale module and drag it to the Network view.
3. Connect the Deformation-Scale module directly under the lower deformer module of your chain.
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4. In the Network view, select the Deformation-Scale module and select View > Show > Control to
display its controls in the Camera view. Refer to for more information about display options.

5. Click on the square yellow button of the Deformation-Scale module to open the Layer Properties
window.

Parameter

Description

Name

Use this field to rename the module.

This series of options controls the left side scaling deformation.

Scale Left

This option is enabled by default. It allows the left side of the deformer to
be scaled. In the Camera view, the dark blue controls are used for the left
side. If you disable this option, the controls will be hidden and no scaling
deformation will occur for this side.
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Left Fade In

The value is set to 0 no fade, by default. Increase the value to add a fade
effect to smooth the transition between the starting point of the scale and
the area before it.

Left Fade Out

The value is set to 0 no fade, by default. Increase the value to add a fade
effect to smooth the transition between the Left Span point of the scale
and the area after it.

Left Start

This parameter defines the starting point of the left scale deformation.
The default value is 0 and represents the Deformation-Root. Each main
control point count for +1.

Left Span

This parameter defines the length of the left scale effect.

Left Start Scale

This parameter definers the start of the left scale effect.

Left End Scale

This parameter definers the end of the left scale effect.

Left Start Handle Position

This parameter definers the starting position of the left handle.

Left End Handle Position

This parameter definers the ending position of the left handle.

Left Start Handle Scale

This parameter definers the starting position of the left scale handle.

Left End Handle Scale

This parameter definers the ending position of the left scale handle.

Scale Right

This option is enabled by default. It allows the right side of the deformer
to be scaled. In the Camera view, the light blue controls are used for the
right side. If you disable this option, the controls will be hidden and no scaling deformation will occur for this side.

Same as Left

This option is disabled by default. It means that the left and
right sides will use different scaling parameters. If you enable
this option, the right side controls will be hidden in the Camera
view and the left parameters will be used for both side for a
symmetrical scaling effect.

The right side parameters are a mirror of the left side parameters
6. In the Layer Properties dialog box, you can set up all the parameters.
7. In the Tools toolbar, select the Transform

tool.

8. In the Camera view, set up the Deformation-Scale module (you can also set these parameters
directly in the Layer Properties window):
‣

To modify the scaling value of the curve, drag the two control handles away and forward
from the deformation axis.
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‣

Move the first blue arrow along the deformer’s central axis to set the starting point of the
Deformation-Scale and the last arrow to set the length (span) of the transformation.

‣

Drag the square scaling curve control points away and forward from the deformer axis to
set the scaling value at the starting and ending point.

‣

Drag the two middle blue arrows along the deformer’s centre axis to set the position of the
curve handles.

9. You can animate the different parameters of the Deformation-Scale module by enabling the
Animate
mode in the Tools toolbar and adding keyframes. In this case, different values will be
connected to functions.

If you feel the controls are too far away from the deformer, you can change the default display of the
Deformation-Scale and Deformation-Uniform-Scale controls in the Preferences dialog box to bring them
closer.
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Deformation-Switch
The Deformation-Switch module acts as a On and Off switch for the deformation chain. It is also the
module which controls the Zone of Influence Fade area. The Deformation-Switch also displays a
Kinematic Chain Selection Reference option, this allows you to modify the chain selection directly in
the Timeline view.

Parameter

Description

Name

Use this field to rename the module.
Defines the quality of the deformation effect when your
drawings are stretched and deformed. There are five levels of
quality:

Vector Quality

Influence Fade Exponent

•

Low

•

Medium

•

High

•

Very High (default value)

•

Extreme

A value of 1 is similar to a linear curve. A higher value will
result in an ease-in type of curve. A lower value will result in an
ease-out type of curve.

Fade Inside Region

This option is disabled by default. The fade effect will occur outside the
zone of influence. Enable this option to have the fade effect inside the
Zone of Influence—see Zones of Influence on page 512.

Enable Deformation

Acts as an on/off switch for the deformation. The value of this field is set
to 1 by default, this means the deformation is enabled. Enter a value of
0 to disable it.

Kinematic Chain Selection
Reference

Determines which chain is selected and used at a specific frame. It is a
reference to the option in the Deformation-Composite module. Having
this reference in the Deformation-Switch module allows you to use and
modify the chain selection value directly in the Timeline view since the
Deformation-Composite module is only visible in the Network view.

Deformation-Uniform-Scale
The Deformation-Uniform-Scale effect module is used to create the squash and stretch effect on your
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animated deformation rig. It will let you scale the rigged element on the opposite axis of the
deformer (width).
How to use the Deformation-Uniform-Scale module
1. In the Network view, navigate inside the Deformation group to which you want to add a
Deformation-Uniform-Scale module.
2. In the Module Library, select the Deformation-Uniform-Scale module and drag it to the Network
view. Note that the Deformation-Uniform-Scale module name changes to Deformation-UniformScale as it enters the Network view.
3. Connect the Deformation-Uniform-Scale module directly below the lowest deformation module in
your chain.

4. In the Network view, select the Deformation-Uniform-Scale module.
5. Display the Uniform Scale controls in the Camera view by pressing Shift + F11—see Displaying the
Deformation Controls on page 491.
6. In the Camera view, drag the handle to resize the width of the limb. You can also use the Scale field
to enter a specific value. These parameters can be animated over time.

If you feel the controls are too far away from the deformer, you can change the default display of the
Deformation-Scale and Deformation-Uniform-Scale controls in the Preferences dialog box to bring them
closer.

Deformation-Wave
The Deformation-Wave effect deforms the chain by adjusting the scaling in a waveform style. It can
be used to animate a wave deformation effect on your deformation chain over a period of time.
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How to use the Deformation-Wave effect
1. In the Network view, navigate inside the Deformation group to which you want to add a
Deformation-Wave effect to.
2. In the Module Library, select an Deformation-Wave module and drag it to the Network view. Note
that the Deformation-Wave module name changes to Deformation-Wave as it enters the Network
view.
3. Connect the Deformation-Wave module to your deformation chain.
A wave deformation is applied to the limb or art connected to the deformation chain.

4. In the Network view, click on the Deformation-Wave module’s square yellow button to open the
Layer Properties window.

5. You can set the following parameters in the Deformation-Wave Layer Properties window:
Parameter

Description

Name

Use this field to rename the module.

Wave Left

This option is enabled by default, allowing the Deformation-Wave effect
to be applied on the left side of the deformer chain. Disable this option
to prevent the effect from being applied.
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Left Start

Defines the length of the left wave effect.
Defines the starting point of the left wave deformation. The
default value is 0 and represents the Deformation-Root. Each
main control point count for +1.

Left Span

This is the parameter you may want to connect to a function.
It controls the offset of the deformation on the left side and
allows you to create a fluid wave animation along the
deformer axis.
Left Offset Deformer

Controls the height of the left wave effect.

Left Amplitude

Used to apply an offset value to the amplitude of the left
wave. The wave will be lifted and become higher, or dropped
and become lower, depending whether the value is increased
or decreased.
Left Offset Scaling

Left Period

Controls the interval of occurrence of the left waves. By
default the value is 1, meaning that a wave will occur for every
deformer. If you decrease the value to 0.5, it will result in a
wave occurring every half deformer.

Wave Right

By default this option is enabled, allowing the DeformationWave effect to be applied on the right side of the deformer
chain. Disable this option to prevent the effect from being
applied.

Same as Left

This option is disabled by default. It allows the left and right
size of the Deformation-Wave to be controlled separately.
Select this option if you want the effect to be symmetrical and
controlled by the left side parameters.
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Defines the starting point of the right wave deformation. The
default value is 0 and represents the Deformation-Root. Each
main control point count for +1.
Right Start

Right Span

Defines the length of the right wave effect.
This is the parameter you might want to connect to a
function. It controls the offset of the deformation on the right
side, allowing you to create a fluid wave animation along the
deformer axis.

Right Offset Deformer

Controls the height of the right wave effect.

Right Amplitude

Used to apply an offset value to the amplitude of the right
wave. The wave will be lifted and become higher, or dropped
and become lower, depending whether the value is increased
or decreased.
Right Offset Scaling

Right Period

Controls the interval of occurrence of the right side waves. By
default the value is 1, meaning that a wave will occur for every
deformer. If you decrease the value at 0.5 it will result in a
wave occurring every half deformer.
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Fold

The Fold effect is used when bending a deformation further than the drawing is able to take it. This
may result in an unwanted overlap of the line art at the junction of the articulation or deformation.
The Fold effect lets you control certain parameters that will help eliminate the unwanted line effect.

How to set up the Deformation-Fold effect module
mode to preview the fold. This will help you set up the
1. In the Camera view, enable the Render
Deformation-Fold effect as accurately as possible.
2. In the Network view, navigate to the Deformation effect module causing the unwanted overlap
(in this case, an articulation).
3. In the Module Library, select the Fold module and drag it to the Network view.
4. Connect the Deformation-Fold module directly under the deformation effect module which is
causing the unwanted line effect.

5. In the Network view, select the Deformation-Fold module and select View > Show > Control to
display its controls in the Camera view.
6. In the Tools toolbar, select the Transform

tool.

7. In the Camera view, set up the Deformation-Fold. You can also set these parameters directly in
the Deformation-Fold Layer Properties:
‣

Click on the fold axis and rotate it to match the angle of the bend articulation.
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‣

Use the middle arrow to position the axis along the deformer’s central line. It should be in
the corner of the bending area.

‣

Use the right and left arrows to control the appearance of the two overlapping lines.

‣

Use the axis’s square handle to lengthen or shorten the axis.
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8. If your character moves a lot and you need to adjust the fold at different positions to follow the
limb animation, you can set up the Deformation-Fold effect in a different position over time. To
do this, enable the Animation
mode in the Tools toolbar and add keyframes. In this case, the
different values will be connected to functions.
9. You can also enable and disable the Deformation-Fold effect over time by connecting a function
to the Enable Fold parameter in the Layer Properties. A value of 1 enables the effect, a value of 0
disables the effect.

Offset
The Offset effect lets you position the root of your deformation chain. It is automatically added to
your Deformation group when you create a deformation rig using the Rigging
tool.
When you move your chain using Setup mode
, the values at the top section of Layer Properties
update to follow the new resting position. If you move the chain without being in the Setup mode,
you will be able to animate the active position of the chain over time. In that case, the bottom values
will be connected to functions.
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Parameter

Description

Name

Use this field to rename the module.

(x) Axis

Sets the resting position of the Deformation-Root on the X
(east/west) axis.

(y)Axis

Sets the resting position of the Deformation-Root on the Y
(north/south) axis.

RestingOrientation

Sets the rotation angle of the resting position of the
Deformation-Root.
Lets you choose the type of coordinates to use:
•

Separate: The two coordinates are set separately. If they
are connected to a function, each one will have its own
function curve. This is the default setting.

•

2DPath: The two coordinates are set together within a
single 2D path function.

Type

This option is only available when the Type is set to Separate.
It is used to set the active position value of the DeformationRoot on the X (east/west) and Y (north/south) axis.
(x) Axis
(y) Axis

You can enter the value, use the up and down arrow buttons
to choose a value, or use the Transform
tool, when Setup
mode is NOT enabled, to move the deformation chain.
Remember, that if you want to add a keyframe, you need to
enable Animation
mode from the Tools toolbar.

Path

This option is only available when the Type is set to 2D Path. It is used
to set the active position value of both Y and X axis. Use the Transform
tool when Setup mode is NOT enabled to move the deformation
chain along the 2D path. Remember, that if you want to add a keyframe,
you need to enable the Animation
mode from the Tools toolbar.

Orientation

Sets the rotation angle of the active position of the Deformation-Root.
You can enter the angle, use the up and down arrow buttons to choose
the desired value, or use the Transform
tool when Setup mode is
NOT enabled to rotate the deformation chain. Remember, that if you
want to add a keyframe, you need to enable Animation
mode from
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the Tools toolbar.
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Chapter 13: Morphing

Hand-drawn animation requires you to spend a lot of time tracing in-between drawings. Harmony
speeds up the process using its helpful morphing feature. This powerful and useful feature creates
computer-generated drawings and places them between vector drawings to save time and increase
productivity. Animation created with the morphing feature can be reused in different projects. You can
easily modify the timing and velocity (ease in and ease out).
One of the main uses of the morphing feature is effects animation. For example, animating smoke or
water can be time-consuming because these types of effects are usually slow moving requiring a large
number of closely placed inbetweens.
This chapter is divided as follows:
•

Understanding Morphing on the next page

•

Source and Destination Drawings on page 569

•

Morphing Rules on page 570

•

Creating a Basic Morphing Sequence on page 574

•

Tool Properties View on page 577

•

Adjusting the Velocity and Timing on page 580

•

Morphing Tool and Hints on page 584

•

Morphing Layers on page 592

•

Morphing Two Sequences in a Row on page 599

•

Inserting a Morphing Key Drawing on page 600

•

Converting Morphing Inbetweens to Drawings on page 601

•

Morphing Holes and Transparencies on page 602

•

Adjusting the Morphing Quality on page 605

•

Tips and Tricks on page 606
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Understanding Morphing
The morphing feature is used to animate similar and simple shapes such as hair or smoke. It helps you
by saving time when you are working on tedious inbetweening and tracing tasks This, in turn, provides
you with more time to spend on complex animation tasks such as walk cycles or acrobatic sequences.

Ideas Behind Morphing
To learn how to morph drawings, it is better to start with basic shapes such as circles and rectangles.
Once you are more familiar with the tool, you can increase your knowledge and expertise. In a very
short time you will be producing some remarkable effects.
It is helpful to know the pros and cons of morphing before you start. Understanding what you can do
and which drawing lines may be more useful or problematic will enable you to design your key
drawings so they morph efficiently.

The more complex the shape is, the longer it takes to morph. If it takes more time to morph a drawing than
to hand-draw it, then it is better to animate it instead of morphing. However, if you spot an occasion when
you can morph your drawings, do it! It allows you to fix your timing and velocity in no time without having to
create any extra drawings!
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Source and Destination Drawings

The morphing feature matches similar shapes in a source and a destination drawing. Harmony
evaluates the source's shape properties and matches them to the most similar ones in the destination
drawing.
Morphing works between similar shapes, which are drawings that have the same palette, colours and
number of shapes. You can even change any shape into another one, as long as the source and
destination keep the same colours, number of lines and number of shapes.
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Morphing Rules
Harmony follows a set of rules as it evaluates the shapes. Familiarize yourself with these basic
morphing rules before you start morphing.

Note that a morphing sequence can only be done on vector drawings. You cannot morph bitmap layers or
Toon Boom bitmap drawings.

Closest Similar Shape
A colour, line shape or zone will morph with the closest similar one in the destination drawing. This
means it will morph with the zone nearest to it, as long as that zone uses the same palette's colour
swatch (colour ID) and has the same vector properties (Central or Contour).

In the example above, the red heart shape (1) will morph with the closest shape using the same
colour swatch. It will morph with the red diamond shape (1) in the next drawing. The red diamond
shape (2) in the source drawing will morph with the red heart shape (2) located in the same area in
the destination drawing. The black spade shape (3) in the source drawing will morph with the black
club shape (3) located in the same area in the destination drawing. Finally, the black club shape (4) in
the source drawing will morph into the black spade shape (4) located above in the destination
drawing.

Pencil Line to Pencil Line
If you trace a shape using a pencil line such as the Ellipse
, Rectangle
, Polyline
, Line
or Pencil
tool, you have to morph it with another pencil line. Make sure that both drawings are
pencil shapes (central vector).
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A pencil line will never morph with a brush stroke.

Pencil lines with thickness are supported in morphing sequences. The thickness will morph according
to the thickest and thinnest areas in the source and destination drawings.

Pencil lines with textures are not supported in a morphing sequence. During the morphing, the
texture will disappear and show without pencil line opacity texture.
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If you have pencil lines in your source drawing, the same number of pencil lines must be present in the
destination drawings. A pencil line will appear if it is not found in the destination drawing. It will pop
out on the first or last frame depending on which one it is drawn.
When two pencil lines cross one another, they are considered to be two lines and not four lines
anymore (as it was in version 7.8 and below of the application). In this case, you must have two pencil
lines in your destination drawing for your morphing to work correctly.

Fill Shape to Fill Shape
If you have a brush stroke or a colour fill ( contour vectors), make sure that you morph it with another
brush stroke or fill zone. It is important to undersand that strokes drawn with the Brush tool are the
same thing as zones painted with the Paint tool. Vector points are located along the contour. They
are simply not the same size. Contour vectors will not morph with pencil lines (central vectors). A
brush stroke can morph into a colour fill zone and vice versa as they are the exact same thing.
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Colour Swatch to Same Colour Swatch
Harmony does not morph between colours. If you want to perform a colour transition, you have to
create the effect during the compositing step of your production. A colour palette is composed of
colour swatches. Each colour swatch has its own unique identification number, even if two swatches
are the same colour value, they are identified independently. A colour zone or shape will morph with
another one painted with the same colour swatch.

Vanishing and Appearing
If a colour zone does not find a match in the first or the second drawing, it will progressively appear
or disappear.

Colour Art to Colour Art and Line Art to Line Art
In Harmony, there is an advanced concept for painting your drawings called Line Art and Colour Art.
Basically, an extra layer is added in your drawings so that you can fill the colour zones on a separate
layer. The regular layer on which you are drawing is called Line Art and the extra layer under the Line
Art is the Colour Art.
•

A shape drawn in Colour Art can only be morphed with another shape existing in the Colour Art.

•

A shape drawn in Line Art can only be morphed with another shape existing in the Line Art.

•

A shape created in Colour Art can never morph with a shape created in Line Art.
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Creating a Basic Morphing Sequence

When it comes to morphing, you will need to practice and become at ease it. Once you are familiar
with the basic rules, you can start creating morphing sequences. To begin, start with simple elements.
When you are confident with the morphing process, you can start to use complex and advanced
morphing techniques, such as head rotations or full characters.
You may want to delete an entire morphing sequence in order to redo a sequence from scratch.

How to create a basic morph
1. In the Timeline View toolbar, click the Add Drawing Layer
project.

button to add a new layer to your

2. Rename the new layer ( for example, Morphing).
3. In the Timeline or Xsheet view, select the first cell in the layer.

4. Do one of the following:
‣

In the Tools toolbar, select the Rectangle

‣

Press Alt + 7.

tool.

5. In the Camera or Drawing view, draw a rectangle.
6. Do one or both of the following:
‣

Hold down the Shift key to draw a square.

‣

Hold down the Alt key to draw the rectangle from its centre.

7. Paint your rectangle using the Paint tool.
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8. In the Xsheet or Timeline view, select the last cell.

9. Do one of the following:
‣

In the Tools toolbar, select the Ellipse

‣

Press Alt + =.

tool.

10. Draw and paint the ellipse using the same outline colour as the rectangle.

11. In the Xsheet or Timeline view, select the first frame and all the frames up to and including the last
frame, which is the rectangle drawing.

12. Do one of the following:
‣

From the top menu, select Animation > Morphing > Create Morphing.

‣

In the Xsheet or Timeline view, right-click and select Morphing > Create Morphing

‣

Press Alt + M.

Arrows appear between the two key drawings to show that computer generated in-betweens have
been created.
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Use the Playback toolbar to play the morphing sequence. To flip through the inbetweens toggle between
comma ( , ) and period ( . ). Press F4 to toggle between the two key drawings.

How to delete an entire morphing sequence
1. In the Xsheet or Timeline view, right-click on a cell between two keyframes.
2. Do one of the following:
‣

From the top menu, select Animation > Morphing > Delete Morphing.

‣

In the Xsheet or Timeline view, select Morphing > Delete Morphing.

The entire sequence between the two keyframes is removed.
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Tool Properties View

As you create and adjust your morphing sequences, you will often use the Tool Properties view. Using
this view allows you to do things such as toggle between your key drawings, adjust the easing or
select a hint type.

How to access the content of the Tool Properties view
1. Do one of the following:

‣ In the Tools toolbar, select the Morphing

tool.

‣ Press F3.
Hint Type

The Hint Type drop-down menu allows you to select the correct hint to remedy any problem areas in
your drawing—see Contour Hint on page 587 and Morphing Tool and Hints on page 584.
You can have more than one hint type in your drawings. You can mix all of the hint types in your
morphing sequence.
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Hide Hints

The Hide Hints
button temporarily hides the hint points from the key drawings. Use this option
when you have a series of hint points hiding some lines you would like to see.

Show Morphing in Place
The Show Morphing In Place
option is used with morphing layers. Enabling this option prevents
the currently selected morphing layer from being shown on top of the others and maintains the
correct layer ordering—see Morphing Layers on page 592.

Suggest Hints
The Suggest Hints
option is used to automatically set hint points on your key drawings as a help
tool. If you are not sure where to set your hints, you can use this option. It will set the main hints
which you can then fine tune.

Switch Between Drawings
The Switch Between Drawings
button is used to toggle between the two key drawings in your
morphing sequence. This option is useful while setting hints. You can use the default keyboard
shortcut F4 to toggle between your drawings.

Flatten
The Flatten
option is used when you have to morph a sequence with a semi-transparent or
transparent colour in it—see Morphing Holes and Transparencies on page 602.

Quality

The Quality setting is used to make the lines of the morphed drawings smoother. Adjust this
parameter when you are doing an extreme close up of your animation—see Adjusting the Morphing
Quality on page 605.
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Morphing Layers

The Morphing Layers option is used when working with morphing layers. You can add, remove and
manage your different morphing layers in this space—see Morphing Layers on page 592

Easing

The Easing option is used to adjust the starting and ending velocity of your morphing sequence so
that the motion is smooth and not mechanical.
You can adjust the Ease In and Ease Out value by dragging your cursor up and down or typing a new
value. The values go from -1.0 to 1.0—see Adjusting the Velocity and Timing on the next page

Convert Hints

The Convert Hints
option is used to switch the type of the selected hint points. This option is
useful when you position hints and then realize they are not the right type. You can select them and
convert them to the correct type instead of deleting them and setting new ones.
Use the Morphing tool to select the hints and then convert them by going to the Tool Properties
view and selecting the new hint type from the Convert Hints drop-down menu.

Time

The Time field is used to set the timing on Appearing Point and Vanishing Point hints. These hints are
used to set the trajectory of appearing and vanishing objects, With the Time field, select your
Appearing Point or Vanishing Point hint and type the frame number on which the object will start its
appearing or vanishing animation.
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Adjusting the Velocity and Timing

Once you have set up a morphing sequence, you can control its timing and velocity. When you look at
your animation you will notice that the morphing motion is constant. To produce a less mechanical
motion, you will probably want to create some ease in or ease out.
If you did not place your source and destination drawings on the correct frames you may need to
extend or shrink the sequence length.
If you have several morphing sequences on a single layer, you may find it easier to adjust their
velocities on one function curve rather than several separate ones. Having all of your velocity
parameters in one place is more efficient and easier to modify.
Adjusting the velocity in the Layer Properties editor also allows you to reverse a section of the
morphing sequence. The sequence will always start with the source drawing and end at the
destination. You can play the morphing sequence backwards or forwards during the animation.
You can have two levels of easing:
•

In the Tool Properties View, you can adjust the velocity of each sequence in your layer
independently

•

In the Layer Properties editor, you can adjust the morphing velocity function to control the entire
layer's easing

How to extend or shrink a morphing sequence length
1. In the Timeline view, select the source or destination drawing.
2. Click on your selection and drag the drawing to its new frame.
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How to adjust the velocity in the Tool Properties view
1. In the Timeline view, click on a frame in the morphing sequence you want to adjust.
2. In the Tool Properties view, increase and decrease the Ease In and Ease Out value to adjust the
sequence's velocity.

How to adjust the velocity in the Layer Properties editor
1. In the Timeline view, double-click on the drawing layer to open the Layer Properties editor.

2. In the Layer Properties editor, go to the Advanced tab and click on the Function
create a function curve.

3. In the Layer Properties editor, click the Function

button to

button again to open the velocity curve.
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4. Add a keyframe at the first frame of the morphing (source) and one at the end (destination) by
clicking on the Add/Remove Keyframe
button.

5. Move the destination keyframe upward.

It is important that the last keyframe remains above the first one.
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6. Make sure that the first keyframe is not a stop-motion keyframe. To do this, disable the Stopmotion Keyframe
button. To use the Toggle Stop-Motion Segment feature, press S.
7. Click on the keyframes and pull the Bezier handles to create ease in and ease out. If you make the
curve go downward instead of upward, the animation will play backward until the curve starts to
go upward again.

If you have more than one morphing sequence in the same layer, you need to add a keyframe on the
velocity curve for each source and destination drawing.

8. If you want your morphing to play back on a double frame exposure rather than single frame, you
can use the Hold Value editor and set the velocity to change every second frame, instead of every
frame.
9. In the Morphing Function editor, click on the Hold Value Editor
to hold the value for two frames.
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Morphing Tool and Hints

Harmony's Morphing
tool controls your morphing sequence, this works by placing different types
of hints to help the system morph the animation the way that you want it.
Hints are points that are placed in both the source and destination drawings. They associate zones
and lines between the two drawings. Hints are used to fix problem zones, such as a line that is not
following the colour fill zone.

Corners and points are more challenging, in general. Animation curves are complex and may be unable
to match corners. It will generally associate a corner with its nearest neighbour; this is not always
correct and it is why we use hint points to determine what goes with what.

Using the Morphing Tool
Hints are identification points existing in both the source and destination drawings to create
associations between the two of them.
To correct morphing distortions, Harmony has different types of hints available for controlling
different types of problems:
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•

Contour Hint on page 587

•

Zone Hint on page 588

•

Pencil Hint on page 588

•

Vanishing Point Hint on page 589

•

Appearing Point Hint on page 589

Each type of hint has a different purpose and they can all be used in the same drawing. Use the
Morphing tool to add hints to your morphing sequences.
A hint will automatically appear in both the source and destination drawings when it is added. A hint
cannot exist in a single drawing. If you delete a hint from one drawing, it will be also deleted from the
other.
The key to placing your hints is to put them where the biggest problem is. Fix the largest distortions
first, this may also fix the smaller ones at the same time.

Do not add too many hints, this is a common mistake when morphing, it takes some practice to learn
how to correctly use and place hints.
To add and remove hints:
1. In the Timeline or Xsheet view, select the source or destination drawing of your morphing sequence.

2. In the Tools toolbar, select the Morphing

tool or press F3.

585

Chapter 13: Morphing Morphing Tool and Hints

Use your other morphing key drawing, shown in the Drawing view's bottom right corner, as a
reference.

3. In the Tool Properties view, select the type of hint you want to use.

‣

Select Contour Hint to correct a brush line or colour zone's contour (Contour vector).
Contour Hint points will behave similar to Pencil Hint points when used on a pencil line. Note
that you obtain better results using the Pencil Hint point on pencil line rather than Contour
Hint points.

‣

Select Pencil Hint to correct a pencil line (Central vector).

‣

Select Zone Hint to correct a colour zone morphing match.

‣

Select Vanishing Point Hint to correct a vanishing shape's trajectory.

‣

Select Appearing Point Hint to correct an appearing shape's trajectory.

4. In the Camera or Drawing view, click on the drawing near the problematic area.
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5. Select the hint's point and move it to its correct position.

6. Select one or many hints and press Delete to remove extra or unused hints.
‣

To delete all of the hint points at once, press Shift + Delete.

7. In the Playback toolbar, press the Play

button to see the result.

Hints

Hint points in the source drawing are green and red in the destination drawing.

Contour Hint
The Contour Hint
point is used on the colour fill zone and brush lines; in other words, on
Contour vectors. It allows the control of line thickness and contour position. Also, if a contour is not
animated the way that it should be you can use hints to correct the animation. For example, if a flag
is not waving properly.
When adding a Contour Hint point, make sure that you place it far enough away from the contour so
that you can see it snap to the contour.
The Contour Hint points are yellow.
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Do not place the Contour Hint directly on the line as it may look like it has snapped to the contour, when
in fact, it has not and the morphing will remain unchanged.

To correct a brush stroke, place a hint on both sides of the line to indicate its thickness variations over
time.

Zone Hint
point is used on a colour zone to control the proximity rule. The Zone Hint is
The Zone Hint
placed in the centre of the colour zone. Sometimes a colour zone is not associated with the
corresponding one by default. For example, in a splash animation there are many water droplets
that are the same colour. The system automatically morphs the droplet to the nearest one. This is
not always the one you may have predicted. A Zone Hint will force a colour zone to morph with
another one.

Zone Hint points are cyan in colour so you can easily see them.

Pencil Hint
A Pencil Hint
point is used to control a pencil line, also known as central vector. It can be used on
drawings that were done using the Pencil, Polyline, Ellipse, Line and Rectangle tools. Like the
Contour Hint, the Pencil Hint snaps to the central vector. Make sure to place it far enough away from
the line so you will see it snap when you move it.

588

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

Pencil Hint points are magenta in colour so you can easily see them.

Vanishing Point Hint
A Vanishing Point Hint
is used to control the trajectory of a vanishing shape. A shape will vanish
from the source drawing when there is no corresponding shape in the destination drawing. If you do
not place a Vanishing Hint to control the point of disappearance, the shape will vanish into its centre.

Vanishing Point Hint points are green in colour so you can easily see them.

Appearing Point Hint
An Appearing Point Hint
is used to control the trajectory of an appearing shape. A shape will
appear in the destination drawing when there is no corresponding shape in the source drawing. If
you do not place an Appearing Point Hint to control the point of appearance, the shape will appear
from its centre and expand outwards.
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Appearing Point Hint points are violet in colour so you can easily see them.

Copying Hint Points from One Drawing to Another

If you have two morphing sequences that use the same drawing and you would like to copy it and its
hint points, you can do so in the Drawing view.

How to copy a drawing and its hints
1. Do one of the following:
‣

In the Tools toolbar, click the Select

‣

Press Alt + S.

tool.

2. In the Drawing view, select the drawing to reuse in your second morphing sequence.
3. Do one of the following:
‣

In the top menu, select Edit > Copy.

‣

Press Ctrl + C (Windows/Linux) or ⌘ + C (Mac OS X).

4. In the Timeline view, select the cell where the new drawing will be.
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5. In the Drawing view, paste your selection.
6. Do one of the following:
‣

In the top menu, select Edit > Paste .

‣

Press Ctrl + V (Windows/Linux) or ⌘ + V (Mac OS X).

7. In the Timeline view, select the cell where the second drawing will be.

8. In the Drawing or Camera view, draw your second drawing.

9. Do one of the following:
‣

In the Timeline view, create the morphing sequence for the new drawings.

‣

Press Alt + M.

10. Do one of the following:
‣

In the Tools toolbar, select the Morphing

‣

Press F3.

tool.

11. In the Drawing or Camera view, position your hint points.
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Morphing Layers
Morphing layers simplify the morphing animation. Complex shapes are often too difficult to control
and may not work properly, by dividing the drawings into morphing layers, the task becomes much
easier.
The major points used in controlling a morphing sequence are the intersections. If there are many lines
intersecting within a drawing, the system will require more control—see Hints on page 587
An important aspect of morphing is to identify possible problem zones in order to fix them and avoid
potentially frustrating situations.

Identifying Problem Zones
Simple details that look easy to morph can sometimes be more challenging than they may initially
appear to be. For example, you may find that the nose becomes an issue when performing a head
rotation. As explained earlier, the drawings need to be similar in their number of shapes. Generally,
on a head rotation, the source nose is in the centre of the face, but on the destination, the nose line
is part of the face outline. This means that on the source drawing, the nose and the face outline are
two separate shapes, whereas they are combined into one shape on the destination drawing.
Morphing a full face as demonstrated on the figure below will cause the source nose to slowly vanish
as the destination nose grows from the character's cheek.
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Any shape that is contained inside another one and has to morph out of that shape will be
problematic for the same reasons as the nose is. At some point during the morphing sequence, the
shape contained inside the face will merge with the face outline, and then become a separate shape
again.

Morphing Layer Properties
It is because of these reasons, explained in the section, Identifying Problem Zones on the previous
page, that morphing layers exist. Morphing layers are all contained in the same drawing layer. It is
like having a mini Timeline within a Timeline layer, or a mini Xsheet within an Xsheet column.
Each morphing layer can have its own duration and velocity. Also, because you only have a single
element to handle in your Timeline or Xsheet view, it will be treated as one element for the
Compositing process, making the compositor's work easier.
You can separate all of your elements into different drawing elements and have many layers, but you
would have to create a large number of morphing sequences and make sure that you modify all of
their timings properly.

Both solutions are correct, but morphing layers makes it easier to handle and does not change the scene
structure by adding more elements, which can be very important for Cut-out animation puppets. For
example, if you morph a front head to a three-quarter head where the ear needs to be separate, you do
not want to add a new ear layer at the same time and have to worry about connecting it inside the
puppet's construction. Instead, simply create an ear morphing layer within the head layer.
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How to create a morph with morphing Layers
When you click on a morphing layer drawing, it automatically appears on top of the others. If you
want it to stay in place, for example the wing behind the body, enable the Show Morphing in Place
option in the Morphing Tool Properties view.

Use a naming convention for each morphing layer such as ear_1, ear_2 or head_1, head_2. You can also
use the numbers 1 to 9 for the first layer, 10 to 19 for the second one, 20 to 29 for the third one and so
one. This technique is useful if you plan to do more than one morphing sequence in the same column. For
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example, front head to three-quarter head to side head. The three-quarter drawings will be used in both
morphing sequences.

How to create a morph with morphing layers
1. In the Timeline view, add a new drawing element and name it properly.
2. In the first cell, draw the main source shape such as the head shape or body shape. Do not add
details like eyes.

3. In the Timeline View, select the destination cell.
4. Enable and extend the Onion Skin.

5. In the destination cell, draw the second drawing.

6. In the Timeline view, select the in-between cells.
7. Do one of the following:
‣

Right-click and select Morphing > Create Morphing.

‣

Press Alt + M.
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8. In the Tools toolbar, select the Morphing

tool.

9. In the Morphing Tools Properties view, click on the Add Layer
layer.

button to add a new morphing

10.Double-click on the new layer's name and name it appropriately.
11.Press Enter/Return.

12. Use the Up
layer.
‣

and Down

arrow buttons to move the new layer above or below the Main

If placed above the Main layer, it will be displayed in front. If it is placed below, it will be
displayed behind.
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13. To create new drawings, double-click on the blank area under the From section to create the
source drawing and the To section for the destination drawing and type a different value than the
ones used for the main layer.
14. Press Enter/Return.
You do not need to type any value for the Main layer as it uses the one from the Xsheet column.

15.Click on the new source drawing to start drawing the new part. (Make sure that you are working
on the proper drawing by verifying the name in the Camera or Drawing view's bottom left
corner.)

16.In the Camera or Drawing view, draw the source drawing.

17. Once the source drawing is done, use the Morphing Tool Properties view and click on the
destination drawing's name and draw it in the Camera or Drawing View.
18. Repeat steps Step 9 to Step 15 for each layer needed. You can add as many layers as you want.
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19.Enable or disable the layers that you want to display or hide while drawing.

20.If you want to change the layer duration, click on the layer and change the start and stop
numbers.

The length indicator changes according to the new values.
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Morphing Two Sequences in a Row
If you are morphing two sequences in a row, you will have to create a different set of hint points for
each sequence.

Morphing two sequences in a row requires three drawings: 1, 2 and 3. Using these three drawings you
create two morphing sequences; one sequence between drawings 1 and 2, and a second sequence
between drawings 2 and 3.

Each morphing sequence has its own set of parameters and hints. This means that Drawing 2 will have a set
of hints for the first sequence and another set for the second sequence. The two sets of hints will not show
at the same time. Each set of hints that appears always corresponds to the morphing sequence you are
working on.
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Inserting a Morphing Key Drawing

Once you have a morphing sequence, you can add a morphing key drawing.
A morphing key drawing allows you to insert extra details into a morphing sequence. For example,
during a morphing sequence you may need to insert a detail such as teeth or a mouth, this is easy to
do when you use a morphing key drawing. Instead of creating an entirely new drawing, convert a
computer generated in-between to a morphing key drawing and add your extra details to it and the
next key drawing.
A morphing key drawing converts a computer generated morphing frame into a real drawing that you
can edit. It splits the morphing sequence into two sequences, retaining any previous modifications.

How to insert a morphing key drawing
1. In the Timeline or Xsheet view, select the morphing frame you want to transform into a morphing
keyframe.

2. Do one of the following:
‣

In the top menu, select Animation > Morphing > Insert Morphing Key Drawing.

‣

Right-click and select Morphing > Insert Morphing Key Drawing.

The new morphing key drawing appears.

3. In the Drawing or Camera view, draw your new details on the morphing key drawing.
4. In the Playback toolbar, press the Play

button to see the result.
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Converting Morphing Inbetweens to Drawings
Harmony lets you convert your morphing inbetweens to real drawings that you can edit.
This is useful when you manually edit your morphing sequence or if you prefer to have your animation
timing in double frame (on twos) instead of single frame (on ones).

How to convert morphing inbetweens to drawings
1. In the Timeline or Xsheet view, select a morphed drawing in the morphing sequence you want to
convert to real drawings.

2. Do one of the following:
‣

In the top menu, select Animation > Morphing > Convert Morphing to Drawings.

‣

Right-click and select Morphing > Convert Morphing to Drawings.

The Converting Morph dialog box opens.

3. Type the drawing basename you want to give to your new drawings. In this case, you could type
circle.
4. Click OK.
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Morphing Holes and Transparencies
To be able to morph shapes with holes or transparent colours, it is important to understand the
process of analyzing and morphing a shape. Harmony begins the process by reading the exterior
outline of the entire shape. So if you are morphing a doughnut, it will first read the entire circular shape
and ignore the central hole.

Once the general morphing shape is analyzed, the system will carry on analyzing the interior details
such as colour zones and holes.

As you can see, because the hole was placed on top after the main shape was morphed, the centre is
filled with an opaque brown colour. In order to avoid opaque holes, you have to paint the zone with a
transparent colour so that you can control it and flatten the transparency to cut a hole through the
main shape.
The same thing happens when you have holes painted with semi-transparent colours. To see through
your shapes, you have to follow the same process as morphing shapes with holes.
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How to morph a shape with a hole
1. In your Colour view, select an unused colour swatch and set its alpha (transparency) to 0.

2. Paint both holes on the source and destination drawings.

3. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

4. Do one of the following:
‣

In the Tools toolbar, select the Morphing

‣

Press F3.

5. In the Tool Properties view, enable the Flatten

tool.
button.

A hole appears in the shape.
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Adjusting the Morphing Quality
Increasing the morphing quality settings improves the line shape between vector points. It also creates
a larger file, so only increase quality when you are zooming in closely. You can adjust the quality in the
Tool Properties view and in the Preferences panel.

When morphing in Toon Boom Harmony, there is a preference you can set to help you set the default
quality of morphing sequences. Refer to the following parameter in the Preferences Guide for
complete descriptions.
•

Drawing tab: Settings, Morphing Quality

How to set a morphing sequence's quality level
1. In the Timeline or Xsheet view, click on a cell in your morphing sequence.

2. Do one of the following:
‣

In the Tools toolbar, select the Morphing

‣

Press F3.

tool.

3. In the Tool Properties view, adjust the Quality level.
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Tips and Tricks
This section provides a list of easy tips and tricks to help you morph your drawings more efficiently.

Using the Brush Tool as a Beginner
When learning about morphing, it is recommended that you use the Brush tool. You can use the
Pencil line for simple closed shapes.

Flattening Drawings
Flatten your drawing before starting a morphing sequence.

Cleaning-up your Drawings
If you leave a dot, even the smallest one, it is possible that your morphing will create odd shapes. If
the source line is closer to the dot than the destination line, the source line will morph into the dot
and the destination line will disappear.

Using the Same Colour Swatch
Use the same colour swatch between two drawings. You cannot morph between two different
colour swatches even if they have the same RGB values. This can be turned to your advantage for
complex morphing.

Morphing Similar Shapes
Similar shapes should have the same number of colour zones. This only applies to the number of
zones and lines and not the number of points on a curve.

Avoiding Crossing Zones During Morphing
If a zone inside a larger zone on the source drawing ends up outside on the destination drawing, the
morphing will fail.
A line cannot cross another line during a morphing sequence.
For example, if you are morphing a face so it turns from the front to the side, the nose is located in
the middle of the face on the source drawing. However if after morphing, the nose ends up outside
or merged with the face profile line on the destination drawing, this will give undesirable results. You
can avoid this by using morphing layers and splitting the nose on a separate layer.
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alpha channel

The image's channel carrying the transparency information. An
image already has three channels: red, green and blue (RGB). The
alpha channel is the fourth channel (RGBA). The matte, or the
transparency information, is stored in this fourth channel. An image
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at
times, the characters are placed on a trajectory to indicate motion.
The camera moves are also animated. The animatic is used to
determine the rhythm of a project and provides a good overview of
the project before beginning production.

animation

A simulation of movement created by displaying a series of pictures
or frames.

anime

An animation style known for its sinister and dark feel; popular in
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically
unfolds in what storytellers refer to as an arc. The purpose of a
story arc is to move a character or a situation from one state or
scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any
scene, frame or film format. Television ratio is 4:3 and widescreen
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which
multiple drawings are stacked into a sheet feeder. When the
scanner is activated, the drawings are scanned consecutively,
without further user intervention.

automatic lip-sync detection

Automatically mapping drawings in an element to the mouth chart
generated for a sound. This can save time when lip-syncing a voice
track.
An imaginary line around which an object rotates.
For 2D graphics, there are two axes:

axis

•

X: Horizontal

•

Y: Vertical

For 3D graphics, there are three axes:
•

X: Horizontal

•

Y: Vertical

•

Z: Depth

background

The part of a scene that is farthest to the rear. The background is
the artwork, or decor, against which the animation takes place.

Bézier

A method of defining curved lines invented by French
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mathematician Pierre Bézier. A Bézier curve is a mathematical or
parametric curve. Bézier curves use at least three points to define a
curve.
In Toon Boom, a function can be hooked to a Bézier curve and vary
along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves
and can be scaled indefinitely.
bitmap

An image composed of pixels with a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to
appear. This is known as pixelation.
In cut-out animation, breakdown is the action of breaking a
character into pieces to create a puppet with articulations. To
break down a character, the artist cuts part, such as hands and
arms, from the character's model and pastes them in separate
layers. Next, the joints are fixed and the pivots set.

breakdown

In traditional animation, a breakdown is an animation pose
generally found between two key poses. The key poses are the
main poses in an animation and the breakdowns are secondary
poses, ones that help to describe the motion and the rotation
curve.

camera shake

Camera shake occurs in a scene when the camera moves slightly
and quickly in several directions. This gives the impression of an
impact, vibration or, for example, bumps on the road.

caption

In a storyboard, a caption is a text field containing dialogue,
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a
transparent sheet on which the animation is inked and painted
before being sent to the camera.The picture's outline is drawn on
the front of the cel and then coloured along the back.
In Toon Boom, a cel is an individual space encountered in an
Xsheet's column, from which you can expose a drawing or a
function`s coordinate.

character design

Each character in an animated film is drawn from multiple angles in
poster-style format, called a model sheet, which serves as a
reference for the animators.

clean up

After rough drawings have been tested and approved, all the noise
in the image (excess lines, notes, etc) is removed to create final
drawings which can be inked, painted and shot. The cleanup
process refers to either tracing a clean line over a rough drawing to
achieve the final version, or removing dirt and extra lines left by the
scanning process.

CMYK

Cyan, Magenta, Yellow, Black. Refers to the process used by
printers to define colour on the printed page.

colour card

A Colour Card is a solid colour card that is the same size as the
camera. The Colour Card can be used to fill the background with a
solid colour when there is no background image included.

608

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

colour model

In animation, a colour model is the official colour design that must
be used to paint the animation. A model is the definitive character,
prop, or location design that each artist must follow for the
production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements
to create the final result prior to rendering. For example, the
compositing artist will import all the animation sequences,
background, overlays and underlays in the scene and position them
correctly. The artist will then set the camera frame and animate it, if
needed. Finally, the animator will create all the computergenerated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there
are no transition effects inserted to pass from one scene to the
next. The first scene ends and the second one starts immediately.

cut-out animation

The action of animating characters made of several pieces by
moving them around frame by frame. Cut-out animation can either
be computer generated or done traditionally using paper.

cycle

A group of images that together make up an action, such as
walking. A cycle is an action repeated as a loop over a period of
time. It can be a series of animated drawings or keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to
track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as an exposure sheet
or Xsheet.

doping

To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for
computerized printers. It is sometimes applied to screens, in which
case it should more accurately be referred to as pixels per inch.
Either way, the dot is the smallest discrete element making up the
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration
and deceleration of a motion. It can be a motion created by a
function curve, or a series of animated drawings. Other common
terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Another common term for easein is slow-in.

ease-out

Gradual deceleration in the action. Another common term for easeout is slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a
sequence is happening. For example, if a child is playing on the
ground in front of his house, the establishing shot would be a scene
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where the viewer can see the house, the ground, a part of the
street and the buildings around the central point of action. This
helps the viewer understand the story location and scene
orientation.
exposure

In animation, an exposure is the number of cels on which a drawing
appears in the scene. For a drawing to appear longer, the
exposure must be extended over a greater number of cels.
The exposure sheet or Xsheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

exposure sheet (Xsheet)

Each column represents a scene's layer. In each column, the
drawing's numbers are indicated and repeated over the particular
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a
sequence. A fade in occurs when the first scene appears
progressively, from complete transparency to its complete opacity.
A fade out occurs when the last scene progressively disappears,
going from complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

In animation, a field is a measurement unit used to calculate
motion, registration and camera positioning. A standard animation
scene will vary between 6 to 12 fields.

field chart

A guide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33

Use this resolution setting for the widescreen film format that
conforms to the standard 4:3 pixel aspect ratio.

film-1.66

Use this resolution setting for the widescreen film format that
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than
they are high).

flipping

In traditional animation, flipping is the action of going through the
drawings of an animation sequence very quickly in order to see the
animation in motion. Flipping can also be the action of creating a
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main
action. For example, a character wearing a cloak is running. The
main action is the body running. This will cause the cloak to follow
the motion, although it will not move at the same time, but react a
few frames later and follow the main motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D
characters and cut-out puppets with hierarchy. It is used to animate
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a puppet from one of parent parts, such as a shoulder, and make
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional
animation, the North American standard generally contains 24
frames per second, while in Europe the standard is 25 frames per
second.
This is the measurement of the frequency (rate) at which an imaging
device produces unique consecutive images, called frames. The
term applies equally to computer graphics, video cameras, film
cameras, and motion capture systems.

frame rate

Frame rate is most often expressed in frames per second (FPS) and
in progressive-scan monitors as hertz (Hz).
The frame rate is the speed at which the frames are played. They
are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or
any other number

functions

A function is a computer generated motion, trajectory or path that
elements, other trajectories and effects parameters can be
attached to. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than
standard television does because it has a greater number of lines
of resolution. To take advantage of the superior quality and make
full use of your resolution setting, your output device must be
compatible with HDTV technology.

hold

This is a frame in the animation in which the character maintains its
position without moving. A hold can be created between any two
keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of
hue (tint), saturation (shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn
to create fluid transitions between poses.

ink and paint

The ink and paint process is the action of painting the empty zones
and colouring the lines on the final animation drawings, while
following a colour model.

interpolation

In animation, the interpolation is the computer generated motion
created between two keyframes. You have the choice to create
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut
is not visually pleasing. It is generally caused by one scene ending,
and a second one starting, with similar a image. The lack of
difference causes the eye to see a little jump between the two
scenes.
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key pose

Important positions in the action defining the starting and ending
points of any smooth transition. Keys, or key poses, are the main
drawings in an animation sequence describing the motion. For
example, if an arm is waving, the keys will be of the arm at one
extremity of the wave motion and the other extremity. By flipping
those drawings, the animator can see the skeleton of the motion
without having all of the drawings.
One or more keyboard keys which, when used, cause an operation
to be performed. Keyboard shortcuts are used throughout the
Toon Boom software and form an integral part of the workflow. It
is, in most cases, possible to customize the shortcuts in the
Preferences dialog of the software.

keyboard shortcuts

The shortcuts are written as follows in the Toon Boom user
documentation: Each key in a sequence is shown inside square
brackets as in: [Ctrl]+[A]. The brackets "[ ]" separate the key from
the plus sign (+). Neither the brackets, nor the plus sign are part of
the sequence. To use a shortcut, press the key and the character
simultaneously.

keyframe

Important positions in the action defining the starting and ending
points of any action. A keyframe is a computer generated position
at a specific moment (frame) on a given trajectory.

layer

In animation, a layer is an individual column, level or character. A
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the
storyboard and the animation. The layout and posing process is
the action of putting the storyboard on model, that is drawing the
character following the design in the model pack, so that the
animator can start his work. The layout artist will draw the
background, create the camera and field guide matching the scene
and the camera motion. Lastly, he will draw on model the main
action poses.

layout and posing

The action of putting on model, that is, at the right scale, the
storyboard for the animator to start his work.

library

A library is a storage area containing templates and assets that can
be reused in any project or scenes.

light table

The Light Table feature allows you to see the other layers in
transparency while you are working on a particular one in the
Drawing view.

line of action

Direction that the action will follow. Also known as the Path of
Action

lip-sync

The lip-sync is the character`s mouth synchronization with the
dialogue sound track. Frame by frame, the mouth will be adjusted
to fit the sound to give the illusion of the character is speaking.

low resolution

This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality. A
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice
track. For this process, both sound scrubbing (listening to a sound
wave broken up frame-by-frame) and drawing substitutions from
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or
a prop. The palette is used throughout the entire production to
maintain consistency in the look and to ensure that the same
colours are used throughout the production. Also known as
palette.

model/colour model

In animation, a model is the definitive character, prop or location
design that each artist must follow for the production. A colour
model is the official colour design that must be used to paint the
animation.

motion keyframe

In Toon Boom, the motion keyframe is a keyframe with computergenerated interpolation.

mouth chart

Adding a lip-sync to a project can really enhance its quality and
storytelling. However, it can be difficult to shape a character's
mouth so that it matches the sound at the precise frame. To solve
this problem, Toon Boom provides a lip-sync feature which
analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G,
and X, which is used to represent silence).

multiplane

The effect of passing through multiple levels of drawings to create
a sense of depth in a shot. A multiplane is a scene in which the
layers are placed at different distances from the camera so that
when the camera moves, a depth illusion occurs. With a multiplane,
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in
North America. NTSC conforms to North American standards on
how rectangular pixels are displayed for computer and television
screens.

nudge

A small push (left, right, up, down, forward or backward) done
with the keyboard arrow keys on a selected element. Nudging is
used to move a selection very slightly and precisely.

onion skin

A feature that lets you see the previous and next drawings of a
sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.

PAL

A resolution that works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a
character or a prop. The palette is used throughout the entire
project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master
palette.
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palette style

A palette style is a second version of an existing palette with a
slight change in the tint and value. A palette style can be used to
create the night version of a palette. It may also be called a clone
palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be
composed of one or several panels.

paperless animation/tradigital

The paperless animation process is the action of animating
digitally. The main paperless animation process is to draw, frame
by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing
position is the point at which one leg passes the other.

path of action

Direction that the action will follow. Also known as the Line of
Action.

peg

In traditional animation, a tool used to ensure accurate registration
of action as cel layers move. In digital animation, in which you are
doing a more advanced puppet rigging, you can use peg layers.
Peg layers are trajectory layers that do not contain drawings. They
are motion paths that you can use to add path articulations. For
the latter, you can also use the Inverse Kinematics tool.

phoneme

Unit of sound in a language.

pivot

A pivot is the point around which a peg or a drawing rotates.
Smallest element of an image displayed on a monitor or TV screen.

pixel

Pixel, short for Picture Element, is a single point in a graphic image.
It is a small sample of an image, a dot, a square, or a very small
section made out of smooth filtering. If you zoom in close enough
on a digital image, you will see the pixels, which look like small
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the
main action poses, called key poses, and then placing the
secondary poses between the keys. The secondary poses are
called breakdown. Finally, the animator fills the gaps with the inbetween drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes
all of the components as well as adding motion blur before it
produces a final image. In animation, the rendering process is the
action of calculating the final images after the compositing
process.

resolution

The resolution is the size of a scene, generally calculated in pixel.
For example, the NTSC resolution is 720 x 480. Resolution type
should match your final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue: method of defining colour by specifying amounts
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of these three colour components.
rigging

The rigging process is the action of attaching the cut-out puppet
parts one to the other.

rotary table

The Rotary Table is equivalent to the animation disk/table and
allows one to rotate the workspace to be more comfortable while
drawing.

rotoscoping

Is an animation technique in which animators trace over live-action
film movement, frame by frame, for use in animated films. The act
of sketching over live-action footage to create an animated
sequence.

roughs

The roughs are the skeleton sketch of an animation or a design.
Roughs mainly consist of sketch lines and shapes, though they can
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the
centre of the scene's frame, one safe from being cropped by the TV
frame. As a TV frame cuts a margin off the original frame size,
maintaining a safey area ensures that the scene's main action will
remain clearly visible once the film is screened on television.

scene

A scene is a shot in a movie or show. A sequence is composed of
several scenes. A scene changes to another scene by a simple cut,
or a transition.

script

The script is the original text containing all the movie or show
information. In animation, the script contains all of the location
descriptions, dialogues, time and more. A project starts with a
script.

sequence

In animation, a sequence is a series of scenes or shots forming a
distinct part of the story or movie, usually connected by unity of
location or time.

shot

A shot is a scene in a movie or show. A sequence is composed of
several shots. A shot changes to another shot by a simple cut, or a
transition.

slow-in

Gradual acceleration in the action. Another common term for slowin is ease-in.

slow-out

Gradual deceleration in the action. Another common term for slowout is ease-out.

slugging

In Storyboard Pro, slugging refers to indicating the start and stop
times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the
playhead forward or backward. This is very useful for finely-tuned
lip-syncing.

stop-motion keyframe

A stop-motion keyframe is a keyframe with no computer generated
interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The
storyboard indicates what will happen, when it will happen and
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how the objects in a scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first
position to the last, in order. There is very little planning in this
methodology, and where the character ends up and how it gets
there can be a surprise for both the audience and the animator.
While this approach is a lot more spontaneous and creative, it can
create inaccurate results.

strokes

Strokes are invisible vector lines forming the drawing zones. They
can be adjusted with Bézier handles.

tablet/pen

Device used in conjunction with, or instead of, a mouse to move a
mouse pointer (sometimes referred to as the cursor) around the
computer screen.

template

In Toon Boom, a template is an asset stored in the library, one that
can be reused in any project. A template can be a drawing, a series
of keyframes, a sound file, a panel, a cut-out character, an effect, a
trajectory, an animation, or anything else used in the software.

thumbnails

A thumbnail is a very small image used as a reference or indicator.

timecode

Timecode is timing information printed on a movie clip to indicate
what scene, hour, minute and second is currently displayed on the
screen.

timeline

The timeline is a horizontal representation of the scene`s elements,
timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final
line or pencil test, each drawing is traced and painted for the final
animation. In today's digital world, this may be done in a variety
ways other than via the traditional celluloid or acetate methods.

track breakdown

The soundtrack for animated film is broken down into individual
sounds documenting the precise frame-by-frame position of each
sound.

traditional animation

The traditional animation process is the action of drawing on paper
all of the animation sequences, before either scanning them or
inking them on cels.

trajectory

A computer generated path or trajectory that elements can follow.
The trajectory can be controlled by control points, keyframes and
velocity.

transition

A transition is an effect placed between two scenes as they pass
from one to the other. Common transition effects are crossdissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed
behind the main animation.

aspect ratio

The aspect ratio describes the shape of the grid unit. A square grid
unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves.
The computer reads the points and traces the segments, linking
them to reproduce the image shape. There is no fixed size or
resolution in a vector image. The graphic can be enlarged and
distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve,
or via a series of animated drawings. Other common terms for
ease-in and ease-out are slow-in and slow-out.

walk cycle

To avoid making innumerable drawings, animators routinely make
a walk cycle for their character. This comprises a series of drawings
``on the spot`` that describe the walk for that character. The illusion
of movement is created via the use of background pans.

workspace

In Toon Boom, the workspace is made up of the views, toolbars,
and menus.
The Xsheet or exposure sheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

Xsheet (exposure sheet)

Each column represents a scene's layer. In each column, the
drawing numbers are indicated and spread over the specific
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.

zone

An area which can be painted with colour.
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Tips and Tricks

Index
alpha channel
_defined 607
animatic
_defined 607
animation
_defined 607
anime
_defined 607
Annotation column 227
changing drawing settings 230
drawing 228
erasing annotations 229-230
importing Annotation file 232
pen colour 231
pen width 230
tick marks, displaying 231
typing 228
annotations
changing drawing settings 230
changing pen colour 231
changing pen width 230
drawing 228
erasing 229-230
typing 228
arc
_defined 607
aspect ratio
_defined 607
defined 616
auto-feed
_defined 607
axis
_defined 607
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background
_defined 607
backing up
palettes 158
Bezier
_defined 607
bitmap images
_defined 608
Bitmap layer 213
bitmap resolution
height 64-65
resolution factor 64-65
width 63-64
bone deform
basic rig 494
Bone rig 494
Curve rig 495
Bone rig
creating 494
breakdown
_defined 608
character 299
Camera layer 214
camera shake
_defined 608
caption
_defined 608
cel
_defined 608
celluloid
See cel. 608
character building
breaking down 299
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Tips and Tricks

character design
_defined 608
clean up
_defined 608
cloning
layers and columns 226
CMYK
_defined 608
Colour-Card
layer 214
colour card
_defined 608
colour model
_defined 613
defined 609
colour palettes
back up 158
location 157
colour wheel
defined 609
Column Properties editor
displaying in Xsheet 223
columns
advanced types 216
cloning 226
deleting 220
duplicating 226
modifying 223
properties 222
renaming 224
reordering 225
Timing 233
types 213
Xsheet 212
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compositing
defined 609
cross dissolve
defined 609
Curve rig
creating 495
cut
defined 609
cut-out animation
creating 423
defined 609
selecting layers 429
cycle
defined 609
deformation
basic rig 494
Bone rig 494
chain, setting up bone and articulation 496, 500
Curve rig 495
dialogue
defined 609
dope sheet
defined 609
doping
defined 609
DPI
defined 609
drawing elements
adding 216
creating 212
duplicating 226
Drawing layer 213
ease
defined 609
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Index

Tips and Tricks

setting on multiple parameters 454
ease-in
defined 609
ease-out
defined 609
editors
Column Properties 223
Effect layer 214
Element Manager dialog box
parameters 225
establishing shot
defined 609
exposure
_defined 610
exposure sheet
_defined 610, 617
timing 205
fade-in
_defined 610
fade-out
_defined 610
field
_defined 610
field chart
_defined 610
film-1.33
_defined 610
film-1.66
_defined 610
flipping
_defined 610
follow-through
_defined 610
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forward kinematics
_defined 610
frame
_defined 611
frame rate
_defined 611
frames 209
adding 210
adding before/after selection 209
functions
_defined 611
gamut
_defined 611
HDTV
_defined 611
Hold
_defined 611
how to
create a template 401
HSV
_defined 611
importing
Annotation file 232
templates 403
in-between
_defined 611
ink and paint
_defined 611
interpolation
_defined 611
jump cut
_defined 611
key pose
_defined 612
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Index

Tips and Tricks

keyboard shortcuts
_defined 612
keyframes
_defined 612
Layer Properties editor
displaying 223
renaming layers 224
layers 212
_defined 612
bitmap 213
camera 214
cloning 226
Colour-Card 214
deleting 220
drawing 213
duplicating 226
effect 214
Group 214
modifying 223
Peg 215
properties 222
Quadmap 215
renaming 224
reordering 224
selecting parent or child layer 429
Sound 215
types 213
layout
_defined 612
layout and posing
_defined 612
library
_defined 612
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light table
_defined 612
line of action
_defined 612
linking
external files 233
lip-sync
_defined 612
auto detection, defined 607
lip-sync detection
manual, defined 613
Llibrary view
importing templates 403
low resolution
_defined 612
manual lip-sync detection
_defined 613
master palette
_defined 613
master peg
adding 331
model
_defined 613
model sheet See character design
morphing
deleting 576
motion keyframe
_defined 613
mouth
chart 613
multiplane
_defined 613
NTSC
_defined 613
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Tips and Tricks

nudge
_defined 613
onion skinng
_defined 613
overlay
_defined 613
PAL
_defined 613
palettes
_defined 613
backup 158
location 157
style, defined 614
panel
_defined 614
panning
_defined 614
paperless animation
_defined 614
passing position
_defined 614
path of action
_defined 614
Peg layer 215
pegs
_defined 614
adding master 331
pen
_defined 616
phoneme
_defined 614
pivot
_defined 614
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pixel
_defined 614
pixelation See bitmap image
pose-to-pose
_defined 614
Quadmap layer 215
rendering
_defined 614
resolution
_defined 614
factor, bitmap 64-65
height, bitmap 64-65
scene 63-64
width, bitmap 63-64
RGB
_defined 614
rigging
_defined 615
adding master peg 331
basic deformation rig 494
Bone rig 494
chain, setting up bone and articulation 496, 500
Curve rig 495
rotary table
_defined 615
rotoscoping
_defined 615
roughs
_defined 615
safe area
_defined 615
scene resolution 63-64
scenes
_defined 615

627

Index

Tips and Tricks

adding frames before/after selection 209
extending 209-210
reducing length 210
removing frames 210
setting length 209
script
_defined 615
scrubbing
_defined 615
sequences
_defined 615
shot
_defined 615
slow-in
_defined 615
slow_out
_defined 615
slugging
_defined 615
sound
scrubbing
_defined 615
Sound layer 215
stop-motion keyframe
_defined 615
storyboard
_defined 615
straight-ahead
_defined 616
strokes
_defined 616
tablet
_defined 616

628

Toon Boom Harmony 11.1 Network - Cut-out Animation Guide (Standalone)

templates
_defined 616
importing 403
thumbnails
_defined 616
tick marks, Xsheet
displaying 231
turning off 232
timecode
_defined 616
timeline
_defined 616
Timeline view
cloning layers and columns 226
modifying layers and columns 223
reducing scene length 210
renaming layers 224
reordering layers 224
timing 205
adding frames before/after selection 209
Annotation column, adding 227
changing drawing settings 230
drawing in Annotation column 228
erasing annotation 229-230
extending scenes 209-210
frames 209
importing Annotation file 232
linking external files 233
preparing 207
reducing scene length 210
references 208
removing frames 210
scene length 209
Timing column 233
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Index

Tips and Tricks

typing in Annotation column 228
Timing column 233
linking external files 233
using 233
trace and paint
_defined 616
track breakdown
_defined 616
tradigital
_defined 614
traditional animation
_defined 616
trajectory
_defined 616
transition
_defined 616
underlay
_defined 616
vector
_defined 617
velocity
defined 609, 617
walk cycle
_defined 617
workspace
_defined 617
Xsheet
typing in Annotation column 228
Xsheet view
_defined 223, 617
adding frames before/after selection 209
advanced column types 216
Annotation column, adding 227
changing drawing settingss 230
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cloning layers and columns 226
columns 212
erasing annotations 229-230
importing Annotation file 232
layers 212
modifying layers and columns 223
removing frames 210
renaming columns 224
reordering columns 225
tick marks, displays 231
Timing column 233
zone
_defined 617
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Glossary
A

alpha channel
The image's channel carrying the transparency information. An image already has
three channels: red, green, blue (RGB). The alpha channel is the fourth channel
(RGBA). The matte, or the transparency information, is stored in this fourth channel.
An image without an alpha channel is always opaque.

animatic
An animatic is a movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at times, the
characters are placed on a trajectory to indicate motion. The camera moves are
also animated. The animatic is used to determine the rhythm of a project and
provides a good overview of the project before beginning production.

animation
A simulation of movement created by displaying a series of pictures or frames.

arc
Action rarely occurs in a straight-forward manner; rather it typically unfolds in what
storytellers refer to as an arc. The purpose of a story arc is to move a character or a
situation from one state or scenario to the next.

aspect ratio
The aspect ratio is the relationship between the width and height dimensions for
any scene, frame or film format. The television ratio is 4:3 and the widescreen ratio
is 16:9.

auto-feed
Automated method of feeding drawings to a scanner in which multiple drawings
are stacked into a sheet feeder. When the user activates the scanner, the drawings
are scanned consecutively, without further user intervention.

axis
An axis is an imaginary line around which an object rotates. For 2D graphics, there
are two axes: • X which is horizontal • Y which is vertical For 3D graphics there are
three axes: • X which is horizontal • Y which is vertical • Z which is for the depth
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B

background
A background is the part of the scene that is the farthest to the rear. The
background is the artwork, or decor, against which the animation takes place.

backlight
The Backlight tool (in digital process) temporarily transforms the painted zones
into a darker colour, allowing you to easily locate any empty zones or bubbles left
behind during the Ink and Paint process.

Bézier
A method of defining curved lines invented by French mathematician Pierre Bézier.
A Bézier curve is a mathematical, or parametric curve. Bézier curves use at least
three points to define a curve. In Toon Boom, a function can be hooked to a Bézier
curve and vary along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves and can be scaled
indefinitely.

bitmap
A bitmap image is composed of pixels and has a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to appear. This is
known as pixelation.

bitmap image
An image composed of pixels with a single resolution (size). If it is enlarged too
much, it will lose definition and pixels will begin to appear. This is known as
pixelation.

breakdown
In cut-out animation, the breakdown is the action of breaking a character into
pieces to create a puppet with articulations. To breakdown a character, the artist
will cut parts, such as hands and arms, from the character's model and paste them
in separate layers. Next, the joints will be fixed and the pivots set. In additional
animation, a breakdown is an animation pose generally found between two key
poses. The key poses are the main poses in an animation and the breakdowns are
secondary poses, ones that help to describe the motion and the rotation curve.
C

camera shake
Camera shake occurs in a scene when the camera moves slightly and quickly in
several directions. This gives the impression of an impact, vibration or, for
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example, bumps on the road.

caption
In a storyboard, a caption is a text field containing dialogue, effects, sound, or
slugging information.

cel
In traditional animation, a cel, also known as a celluloid, is a transparent sheet on
which the animation was inked and painted before being sent to the camera.The
picture's outline is drawn on the front of the cel and then coloured along the back.
In Toon Boom, a cel is an individual space encountered in an Xsheet's column, from
which you can expose a drawing or a function's coordinate.

character design
Each character in an animated film is drawn from multiple angles in poster-style
format, called a model sheet, which serves as a reference for the animators.

clean up
After the rough drawings have been tested and approved, all the noise in the
image (the excess lines, the notes, etc) is removed to create final drawings which
can be inked, painted, and shot. The clean up process refers to either tracing a
clean line over a rough drawing to achieve the final version, or removing dirt and
extra lines left by the scanning process.

CMYK
Cyan, Magenta, Yellow, Black. Refers to the process used by printers to define
colour on the printed page.

colour card
A Colour Card is a solid colour card that is the same size as the camera. The Colour
Card can be used to fill the background with a solid colour when there is no
background image included.

colour model
In animation, a colour model is the official colour design that must be used to paint
the animation. A model is the definitive character, prop, or location design that
each artist must follow for the production.

colour wheel
A display of the colour spectrum in the form of a circle.

compositing
The compositing process is the action of incorporating all of a scene's elements to
create the final result prior to rendering. For example, the compositing artist will
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import all the animation sequences, background, overlays and underlays in the
scene and position them correctly. The artist will then set the camera frame and
animate it, if need be. Finally, the animator will create all the computer-generated
effects necessary for the project.

cross dissolve
An effect, also known as transition, used to fade two scenes, one into the other.

cut
A cut is a direct transition between two scenes. When a cut is used, there are no
transition effects inserted to pass from one scene to the next. The first scene ends
and the second one starts immediately.

cut-out animation
The process known as cut-out animation is the action of animating characters made
out of several pieces by moving them around frame by frame. Cut-out animation
can either be computer generated, or done traditionally using paper.

cycle
A group of images that together make up an action, such as walking. A cycle is an
action repeated as a loop over a period of time. It can either be a series of
animated drawings, or a series of keyframes.
D

dialogue
The dialogue is the text spoken by a character in a movie or animation.

dope sheet
Used by animators, directors and other members of a crew to track the sequence
and timing of images, dialogue, sound effects, sound tracks and camera moves.
Also known as an Exposure Sheet or Xsheet

doping
Assigning a particular drawing to a range of frames.

dpi
Dots Per Inch is the standard measure of resolution for computerized printers. It is
sometimes applied to screens, in which case it should more accurately be referred
to as pixels per inch. In either case, the dot is the smallest discrete element making
up the image.
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drag
Mouse (or pen) operation that usually results in an object on the screen being
moved. Dragging with a mouse is done by holding down the left mouse button
when the cursor is over the object to be moved, and moving the mouse in any
direction.
E

ease
In animation, the ease, also known as velocity, is the acceleration and deceleration
of a motion. It can be a motion created by a function curve, or a series of animated
drawings. Other common terms for ease-in and ease-out are slow-in and slowout.

ease-in
Gradual acceleration in the action. Another common terms for ease-in is slow-in.

ease-out
Gradual deceleration in the action. Another common term for ease-out is slow-out.

establishing Shot
An establishing shot is a scene in which the viewer can see the whole area in which
a sequence is happening. For example, if a child is playing on the ground in front of
his house, the establishing shot would be a scene where the viewer can see the
house, the ground, a part of the street and the buildings around the central point
of action. This helps the viewer understand the story location and scene
orientation.

exposure
In animation, an exposure is the number of cels on which a drawing appears in the
scene. For a drawing to appear longer, the exposure must be extended over a
greater number of cels.

exposure sheet
The exposure sheet or Xsheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing. Each column represents a
scene's layer. In each column, the drawing's numbers are indicated and repeated
over the particular amount of frames they need to appear. The exposure sheet is
used by animators, directors and other members of a crew to track the sequence
and timing of images, dialogue, sound effects, sound tracks and camera moves.
Also known as a Dope Sheet.
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F

fade in/fade out
Fade In or Fade Out is a transition effect used to open or close a sequence. A Fade
In occurs when the first scene appears progressively, from complete transparency
to its complete opacity. A Fade Out occurs when the last scene progressively
disappears, going from complete opacity to complete transparency.

fast-in
Dramatic acceleration at the start of the action.

fast-out
Dramatic acceleration at the end of the action.

field
In animation, a field is a measurement unit used to calculate motion, registration
and camera positioning. A standard animation scene will vary between 6 to 12
fields.

field chart
A field chart is a guide containing all the field units that animator and layout artists
use to determine a scene size or a camera motion.

film-1.33
Use this resolution setting for the widescreen film format that conforms to the
standard 4:3 pixel aspect ratio.

film-1.66
Use this resolution setting for the widescreen film format that conforms to the 16:9
pixel aspect ratio. (The pixels are wider than they are high).

flipping
In traditional animation, flipping is the action of going through the drawings of an
animation sequence very quickly in order to see the animation in motion. Flipping
can also be the action of creating a mirror transformation of an object.

follow-through
Follow-through is the secondary motion caused by the main action. For example, a
character wearing a cloak is running. The main action is the body running. This will
cause the cloak to follow the motion, although it will not move at the same time,
but react a few frames later and follow the main motion curve.
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forward kinematics
Forward kinematics is a feature used to animate principally 3D characters and cutout puppets with hierarchy. It is used to animate a puppet from one of parent
parts, such as a shoulder, and make the rest of the arm move with it as a single
piece.

frame
A frame is a single photographic image in a movie. In traditional animation, the
North American standard generally contains 24 frames per second, while in Europe
the standard is 25 frames per second.

frame rate
This is the measurement of the frequency (rate) at which an imaging device
produces unique consecutive images, called frames. The term applies equally to
computer graphics, video cameras, film cameras, and motion capture systems.
Frame rate is most often expressed in frames per second (FPS) and in progressivescan monitors as hertz (Hz). The frame rate is the speed at which the frames are
played. They are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or any other
number.

function
In Toon Boom Studio, a function is a computer generated motion, trajectory or
path that elements, other trajectories and effects parameters can be attached to.
The function can be controlled by adding keyframes and control points on the
function curve.
G

gamut
The range of colours that a particular device can represent.
H

HDTV
High definition television delivers a higher quality image than standard television
does, because it has a greater number of lines of resolution. To take advantage of
the superior quality and make full use of your resolution setting, your output
device must be compatible with HDTV technology.

hold
This is a frame in the animation in which the character maintains its position
without moving. A hold can be created between any two keyframes.
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HSV
Hue, Saturation, Value. A method of defining colours in terms of hue (tint),
saturation (shade) and value (tone or luminance).
I

in-between
The drawings that exist between the key poses. These are drawn to create fluid
transitions between poses.

ink and paint
The ink and paint process is the action of painting the empty zones and colouring
the lines on the final animation drawings, while following a colour model.

interpolation
In animation, the interpolation is the computer generated motion created
between two keyframes. You have the choice to create interpolation, or not,
between your keyframes.
J

jump cut
A jump cut is a jerky cut between two scenes. Typically, a jump cut is not visually
pleasing. It is generally caused by one scene ending, and a second one starting,
with similar a image. The lack of difference causes the eye to see a little jump
between the two scenes.
K

key pose
Important positions in the action defining the starting and ending points of any
smooth transition. Keys, or key poses, are the main drawings in an animation
sequence describing the motion. For example, if an arm is waving, the keys will be
of the arm at one extremity of the wave motion and the other extremity. By
flipping those drawings, the animator can see the skeleton of the motion without
having all of the drawings.

keyboard shortcuts
One or more keyboard keys which, when used, cause an operation to be
performed. Keyboard shortcuts are used throughout the Toon Boom software and
form an integral part of the workflow. It is, in most cases, possible to customize the
shortcuts in the Preferences dialog of the software. The shortcuts are written as
follows in the Toon Boom user documentation: Each key in a sequence is shown
inside square brackets as in: [Ctrl]+[A]. The brackets "[ ]" separate the key from the
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plus sign (+). Neither the brackets, nor the plus sign are part of the sequence. To
use a shortcut, press the key and the character simultaneously.

keyframe
Important positions in the action defining the starting and ending points of any
action. In Toon Boom Studio, a keyframe is a computer generated position at a
specific moment (frame) on a given trajectory.
L

layer
In animation, a layer is an individual column, level or character. A scene's layers are
superposed to form the final image.

layout
The layout process is the communication step between the storyboard and the
animation. The layout and posing process is the action of putting the storyboard
on model, that is drawing the character following the design in the model pack, so
that the animator can start his work. The layout artist will draw the background,
create the camera and field guide matching the scene and the camera motion.
Lastly, he will draw on model the main action poses.

layout and posing
The layout and posing process is the action of putting on model, that is at the right
scale, the storyboard for the animatorto start his work.

library
A library is a storage area containing templates and assets that can be reused in
any project or scenes.

light table
The light table allows you to see the other layers in transparency while you are
working on a particular one.

line of action
Direction that the action will follow, also known as the path of action.

lip-sync
The lip-sync is the character`s mouth synchronization with the dialogue sound
track. Frame by frame, the mouth will be adjusted to fit the sound to give the
illusion of the character is speaking.
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low resolution
This format is ideal for videos destined for the web, where size and fast download
of a video file might take precedence over quality. A low-resolution image is one
that lacks fine detail.
M

master palette
A master palette is a group of colours attributed to a character or a prop. The
palette is used throughout the entire production to maintain consistency in the
look and to ensure that the same colours are used throughout the production.
Also known as palette.

model
In animation, a model is the definitive character, prop or location design that each
artist must follow for the production. A colour model is the official colour design
that must be used to paint the animation.

mouth chart
Adding a lip-sync to a project can really enhance its quality and storytelling.
However, it can be difficult to shape a character's mouth so that it matches the
sound at the precise frame. To solve this problem, Toon Boom provides a lip-sync
feature which analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G, and X, which is
used to represent silence).

multiplane
The effect of passing through multiple levels of drawings to create a sense of
depth in a shot. A multiplane is a scene in which the layers are placed at different
distances from the camera so that when the camera moves, a depth illusion occurs.
With a multiplane, all the perspective and scale is calculated automatically.
N

NTSC
This is the standard analogue television broadcasting system used in North
America. It conforms to North American standards on how rectangular pixels are
displayed for computer and television screens.

nudge
A nudge is a small push (left, right, up, down, forward or backward) done with the
keyboard arrows on a selected element. Nudging is used to move a selection very
slightly and precisely.
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O

onion skin
The onion skin is a feature that lets you see the previous and next drawings of a
sequence.

overlay
An overlay is a part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.
P

PAL
This resolution works best with the European format for television and computer
screens, as the rectangular pixels are displayed at a different orientation.

palette
A palette or master palette is a group of colours attributed to a character or a
prop. The palette is used throughout the entire Toon Boom Studio project to
maintain a consistency in the look and avoid the colour changing during the
animation. Also referred to as a master palette.

palette style
A palette style is a second version of an existing palette with a slight change in the
tint and value. A palette style can be used to create the night version of a palette.
It may also be called a clone palette.

pan
To move the camera across the scene in any direction.

panel
In a storyboard, a panel is a frame in a shot. A shot can be composed of one or
several panels.

paperless animation
The paperless animation process is the action of animating digitally. The main
paperless animation process is to draw, frame by frame, the animation directly in
the software.

passing position
When drawing a walk sequence for a character, the passing position is the point at
which one leg passes the other.
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path of action
Direction that the action will follow. Also known as the Line of Action.

peg
In traditional animation, a tool used to ensure accurate registration of action as cel
layers move. In digital animation, in which you are doing a more advanced puppet
rigging, you can use peg layers. Peg layers are trajectory layers that do not contain
drawings. They are motion paths that you can use to add path articulations. For the
latter, you can also use the Inverse Kinematics tool.

pen tablet
Device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.

phoneme
Unit of sound in a language.

pivot
A pivot is the point around which a peg or a drawing rotates.

pixel
Smallest element of an image displayed on a monitor or TV screen. Pixel, short for
Picture Element, is a single point in a graphic image. It is a small sample of an
image, a dot, a square, or a very small section made out of smooth filtering. If you
zoom in close enough on a digital image, you will see the pixels, which look like
small squares of different colours and intensity.

pose-to-pose animation
The pose-to-pose animation process is the action of creating all the main action
poses, called key poses, and then placing the secondary poses between the keys.
The secondary poses are called breakdown. Finally, the animator fills the gaps with
the in-between drawings to achieve a smooth animation.
R

rendering
The final step when animating by computer. During rendering, the computer takes
each pixel that appears on screen and processes all of the components as well as
adding motion blur before it produces a final image. In animation, the rendering
process is the action of calculating the final images after the compositing process.

resolution
The resolution is the size of a scene, generally calculated in pixel. For example, the
NTSC resolution is 720 x 480. Resolution type should match your final output:
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HDTV, film-1.33, film-1.66, NTSC, PAL, low.

RGB
Red, Green, Blue: method of defining colour by specifying amounts of these three
colour components.

rigging
The rigging process is the action of attaching the cut-out puppet parts one to the
other.

rotary table
The Rotary Table is equivalent to the animation disk/table and allows one to rotate
the workspace to be more comfortable while drawing.

rotoscoping
Is an animation technique in which animators trace over live-action film movement,
frame by frame, for use in animated films. The act of sketching over live-action
footage to create an animated sequence.

rough
The roughs are the skeleton sketch of an animation or a design. Roughs mainly
consist of sketch lines and shapes, though they can also contain design details.
S

safety area
In animation and movie parlance, the safety area is the zone at the centre of the
scene's frame, one safe from being cropped by the TV frame. As a TV frame cuts a
margin off the original frame size, maintaining a safety area ensures that the
scene's main action will remain clearly visible once the film is screened on
television.

scene
A scene is a shot in a movie or show. A sequence is composed of several scenes. A
scene changes to another scene by a simple cut, or a transition.

script
The script is the original text containing all the movie or show information. In
animation, the script contains all of the location descriptions, dialogues, time and
more. A project starts with a script.

sequence
In animation, a sequence is a series of scenes or shots forming a distinct part of the
story or movie, usually connected by unity of location or time.
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shot
A shot is a scene in a movie or show. A sequence is composed of several shots. A
shot changes to another shot by a simple cut, or a transition.

slow-in
Gradual acceleration in the action. Another common term for slow-in is ease-in.

slow-out
Gradual deceleration in the action. Another common term for slow-out is ease-out.

slugging
Slugging refers to indicating the start and stop times of dialogue and relevant
actions.

sound scrubbing
The process known as Sound Scrubbing lets you hear sound in real-time while you
move the playback pointer forward or backward. This is very useful for finely-tuned
lip-synching.

stop-motion keyframe
A stop-motion keyframe is a keyframe with no computer generated interpolation.

storyboard
A visual plan of all the scenes and shots in an animation. The storyboard indicates
what will happen, when it will happen and how the objects in a scene are laid out.

straight-ahead animation
A technique in which an entire sequence is drawn from the first position to the last,
in order. There is very little planning in this methodology, and where the character
ends up and how it gets there can be a surprise for both the audience and the
animator. While this approach is a lot more spontaneous and creative, it can create
inaccurate results.

strokes
Strokes are invisible vector lines forming the drawing zones. They can be adjusted
with Bézier handles.
T

tablet
Device used in conjunction with, or instead of, a mouse to move a mouse pointer
(sometimes referred to as the cursor) around the computer screen.
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template
In Toon Boom software, a template is an asset stored in the library, one that can be
reused in any project. A template can be a drawing, a series of keyframes, a sound
file, a panel, a cut-out character, an effect, a trajectory, an animation, or anything
else used in the software.

thumbnail
A thumbnail is a very small image used as a reference or indicator.

timecode
Timecode is timing information printed on a movie clip to indicate the scene, hour,
minute and second is currently displayed on the screen.

timeline
The timeline is a horizontal representation of the scene's elements, timing and
keyframes.

trace and paint
After the rough animations have gone through cleanup and a final line or pencil
test, each drawing is traced and painted for the final animation. In today's digital
world, this may be done in a variety ways other than via the traditional celluloid or
acetate methods.

track breakdown
The soundtrack for animated film is broken down into individual sounds
documenting the precise frame-by-frame position of each sound.

traditional animation
The traditional animation process is the action of drawing on paper all of the
animation sequences, before either scanning them or inking them on cels.

trajectory
A computer generated path or trajectory that elements can follow. The trajectory
can be controlled by control points, keyframes and velocity.

transition
A transition is an effect placed between two scenes as they pass from one to the
other. Common transition effects are cross-dissolve and wipe.
U

underlay
In animation, an underlay is a specific part of the decor placed behind the main
animation.
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units aspect ratio
The aspect ratio describes the shape of the grid unit. A square grid unit would
have the ratio 1:1, whereas a grid unit of aspect ratio 4:3 is a unit with one side 1.33
times as big as the other side.
V

vector
A vector-based image is composed of points and Bézier curves. The computer
reads the points and traces the segments, linking them to reproduce the image
shape. There is no fixed size or resolution in a vector image. The graphic can be
enlarged and distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated and displayed
in pixels once the calculation is done.

velocity
In animation, the ease, also known as velocity, is the acceleration and deceleration
of a motion. It can be a motion created by a function curve, or a series of animated
drawings. Other common terms for ease-in and ease-out are slow-in and slowout.
W

walk cycle
To avoid making innumerable drawings, animators routinely make a walk cycle for
their character. This comprises a series of drawings "on the spot" that describe the
walk for that character. The illusion of movement is created via the use of
background pans.

workspace
The workspace is the organization of the software interface and is made up of the
views, toolbars, and menus.
X

Xsheet
The Xsheet or exposure sheet, is a sheet with several vertical columns and
horizontal frames used to indicate a scene's timing. Each column represents a
scene's layer. In each column, the drawing numbers are indicated and spread over
the specific amount of frames they need to appear. The exposure sheet is used by
animators, directors and other members of a crew to track the sequence and
timing of images, dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.
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Z

zone
An area which can be painted with colour.
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