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Chapter 1: Introduction

Contents

Chapter 1: Introduction
The Harmony Paint module is mainly used in large productions where there is an Ink and Paint or
Colour Stylist team. The Harmony Paint module includes the Drawing and Colour views as well as
drawing tools. By using this module the Ink and Paint team does not need to learn the entire
application, but can focus on the Ink and Paint process.
The Harmony Paint module can only be used with a connection to the Harmony database, unlike other
Harmonymodules which can be used as a standalone application. To start the ink and paint process,
you need to first fill in your scene’s exposure sheets and import the drawings that need to be
coloured.
Refer to the Harmony Xsheet and Harmony Scan Guides to learn more about the previous steps of the
production.
This guide is divided as follows:
•

Toon Boom Harmony - About this Help System on page 9

•

About Toon Boom Harmony on page 15

•

Starting Toon Boom Harmony on page 21

•

Interface on page 39

•

Character, Prop and Location Design on page 63

•

Colour Styling and Colour Models on page 177

•

Ink and Paint on page 219
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Chapter 2: Toon Boom Harmony - About this Help System
Toon Boom Harmony is an animation and digital content creation tool that offers you a wide array of
features and options. Harmony is packaged in several different modules and allows you to create
animation using the technique of your choice—see About Toon Boom Harmony on page 15.
This help system is built to guide you through the different workflows possible and explains which tool
and module to use in a production context.
•

Help Structure on the next page

•

Tutorials and Other Help Tools on page 12

9
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Help Structure

The fundamental concepts of animation and Harmony are explained in this guide. It covers the
essentials of various animation workflows, basic animation principles, as well as Harmony's interface.
Depending on what you want to do, you can either start with this Fundamentals Guide to get
immersed into the world of Harmony and animation or go right to the Getting Started Guide, which
covers the main functions and tasks. All conceptual and reference topics are omitted to get you up and
running in a very short amount of time.
If your work revolves more around system administration or coordination tasks, you will probably
want to move over to the Installation Guide followed by the Control Center and Server Guide to learn
how to install and configure Harmony.
The core of this help system revolves around the main animation techniques you can use in Harmony to
create animation:
•

Traditional Animation

•

Paperless Animation

•

Cut-out Animation

If you use one of the animation technique listed above to produce games, you can complete your
learning process using the Gaming Guide.
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All workflows join in the compositing step of the process. All the information on compositing in
Harmony can be found in the Compositing Guide. Finally, you can watch the rendered animations in
the Play module. To learn how to use the Play module, refer to the Play guide.
If you are focusing on a single part of the workflow such as ink and paint or digital Xsheet creation, you
can simply read the Fundamentals Guide and one of the corresponding module guides:
•

Paint Guide

•

Xsheet Guide

•

Scan Guide

•

Draw Guide

•

Sketch Guide

Other satellite guides are also available to learn about additional information such as the preferences
and keyboard shortcuts.
•

Keyboard Shortcuts Guide

•

Preferences Guide

•

Scripting Guide

•

Utilities Guide

If you are already a Harmony user and want to know more about the new features that were added to
this latest version, refer to:
•

Release Notes
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Tutorials and Other Help Tools
Aside from the main product documentation, you can find supplementary material to learn more
about Harmony. The Toon Boom website's online resources section offers a variety of videos and
samples that can further your knowledge of Harmony.
•

Video Tutorials: toonboom.com/resources/video-tutorials/harmony-network

•

Templates and Sample Scenes: toonboom.com/resources/templates/harmony-network

•

Tips and Tricks: toonboom.com/resources/tips-and-tricks/harmony-network

•

White Papers: toonboom.com/solutions/white-papers
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System Requirements
Here are the technical specifications for Toon Boom Harmony 11.1.

Harmony Network
Toon Boom Harmony Network is a server-client configuration. The server stores all the assets, and
holds the database. The client machines simply run the software and allow the members of your team
to work on Harmony and access the assets directly from the database.

Note that an Internet connection is required to activate the animation software.

Before installing Harmony, refer to the Harmony and Your IT Department white paper to learn about
the network prerequisites for a Toon Boom Harmony installation. This document should be taken as a
guide to help you understand the preliminary steps before performing a typical Harmony installation.
There are multiple ways of installing Harmony, as well as numerous types of hardware that can work
with Harmony. To perform a custom installation which fits the studio’s requirements, a proper analysis
of the studio is required, such as: the type of project, the productivity expected, and the delivery date,
etc. If you are not yet familiar with Harmony, you should get in touch with your sales contact at Toon
Boom to organize a needs analysis of your studio and production in order to make the best of
Harmony and optimize your production pipeline.
The person who performs the installation should have the knowledge and expertise required for
setting up and configuring networks, computers, and operating systems. If you do not have an IT
department or someone who knows the network technology thoroughly, contact your sales
representative at Toon Boom to organize an installation with our consulting department.
•

White Paper: Harmony and Your IT Department

Harmony
Here are the specifications to install Harmony on client machines. Note that this does not encompass
the network and server specifications for Harmony Network.
Requirements

Windows

Mac OS X
Mac OS X 10.7.5
Mac OS X 10.8.5
Mac OS X 10.9.3 or later

Operating System

Windows 7 64-bit
Windows 8 64-bit

Processor

Intel Core i7, 3.4 GHz
Intel Core i5, 3 GHz
Intel Core 2 Duo

Monitor
Memory

Optimized for 1920 x 1080 or higher
Minimum requirement is 1280 x 800
16 GB
8 GB
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4 GB
Fast

‣ NVIDIA GeForce GTX

Fast

‣ NVIDIA Geforce GTX 780

Medium

Medium

‣ NVIDIA Geforce GTX 560
Video Card

775M

‣ NVIDIA GeForce GTX 650

‣ AMD Radeon HD 6770
‣ NVIDIA GeForce 750M
Slow

Slow

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris GraphicsNVIDIA
GeForce GT 520, 620, 720

‣ Intel HD Graphics 4000,
5000

‣ Intel Iris Graphics
‣ NVIDIA GeForce 320M
‣ Radeon HD 4670

Best

‣ Wacom Intuos Pro
Drawing Tablet

‣ Wacom Cintiq
Basic

‣ Wacom Bamboo
‣ Wacom Intuos
Media Player

Apple QuickTime Player (free)
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Chapter 3: About Toon Boom Harmony
Toon Boom Harmony is the most advanced professional animation software on the market. Bringing
together an impressive 2D drawing toolset with the ability to work in a real 3D space, and import 3D
models,
Harmony Network combines the animation toolset of Harmony with an impressive database for
collaborative workflow. Share assets, batch vectorize and render, and increase production efficiency.

Top Features
•

Advanced Drawing Tools: Texture brushes, and thick and thin pencil lines

•

Smart Colour Palettes: Colour you can adjust on the fly

•

Character Rigging: Hierarchy, deform, and effects for creating sophisticated rigs

•

Special Effects: An array of effects including highlights and shadows, glows, blurs, and a full
particle effects engine

•

Real 3D Camera: A camera you can reposition in a full 3D space

•

3D Integration: Allowing you to import 3D models, position and animate them in 3D space

•

Batch Vectorizing and Rendering: Quickly process images for import and export through a single
workstation or a render farm

•

Database File Sharing: Share libraries, colour palettes, animation, and more across the whole
team

•

Production Pipeline Integration: Seamlessly integrate content from pre-production via
Toon Boom Storyboard Pro

Toon Boom Pipeline
Toon Boom Harmony has been recognized for its excellence by winning many awards, including a
Primetime Emmy® Engineering Award and the prestigious Ub Iwerks Annie Award for the integrated
pipeline with Toon Boom Storyboard Pro.
Harmony works perfectly with Toon Boom Storyboard Pro for all pre-production phases. Therefore,
animatics created in Toon Boom Storyboard Pro can be imported seamlessly in Harmony for
animation and scene setup guidance.

Modules

Harmony Network is composed of the following modules:
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•

Control Center below

•

Stage on the facing page

•

Draw on the facing page

•

Sketch on page 18

•

Scan on page 18

•

Xsheet on page 19

•

Paint on page 19

•

Play on page 19

•

Cloud on page 20

These modules are all accessible from:
•

Windows: Start > Programs > Toon Boom Harmony 11.1

•

Mac OS X: Applications > Toon Boom Harmony 11.1

•

Linux: /usr/local/ToonBoomAnimation/harmony_11.1/lnx86_64/bin
•

Controlcenter

•

Stage

•

Draw

•

Sketch

•

Scan

•

Stage -xsheet

•

Stage -paint

•

Play

•

ServerActivation

•

ClientActivation

•

LicenseWizard

Control Center

The Control Center module controls the database and organizes the production. The Control
Center module is used to create the environments, jobs and scenes, as well as importing and
exporting scene packages. The technical director or system administrator also uses the Control
Center to create the login information for users to access the database.
Control Center is also available in a cloud form where users can access scenes via the Internet.
To learn more about Control Center, refer to the following guides:
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•

Fundamentals Guide

•

Installation Guide

•

Control Center and Server Guide

Stage

The Stage module is the core of Harmony. It comprises all the major drawing, animation and
compositing features. It is used to work in the scene: design, character breakdown, cut-out
animation, traditional animation, ink and paint, exposure sheet, timeline, effects, compositing,
camera moves, colour styling, and so on.

You cannot create scenes in Stage Harmony Network, you require Control Center. You create them
directly in Stage with Harmony Stand Alone.

To learn more about Stage, refer to the following guides:
•

Fundamentals Guide

•

Getting Started Guide

•

Traditional Animation Guide

•

Paperless Animation Guide

•

Cut-out Animation Guide

•

Gaming Guide

•

Compositing Guide

•

Play Guide

•

Preferences Guide

•

Keyboard Shortcuts Guide

•

Scripting Guide

•

Utilities Guide

Draw
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The Draw module is a component of the Stage module. It contains all the tools necessary to create a
paperless frame-by-frame animation project. There is no node system in this module, only the basic
essential effects. Contrary to the Stage module, instead of creating effects in the Network view, you
simply create them in the Timeline view. The Draw module also includes all the scene setup and
camera features for you to do the compositing for your project.
•

Fundamentals Guide

•

Draw Guide

•

Preferences Guide

Sketch

The Sketch module is a component of the Stage module. It contains the essential tools to animate
frame-by-frame drawings and paint them. It allows you to add layers and animation, and paint and
adjust the timing. There are no effects, camera or other compositing tools included in this module.
The Sketch module allows you to focus on the paperless animation tasks at hand without being
distracted by other features that are not necessary to your work.
To learn more about the Sketch module, refer to the following guides:
•

Fundamentals Guide

•

Sketch Guide

•

Preferences Guide

Scan

The Scan module is used to scan drawings in batch. It creates a drawing list from the timing and
exposure previously created in the exposure sheet (via Stage or Xsheet module).

It is possible to scan the drawings from a TWAIN device directly in the Stage module.

To learn more about the Scan module, refer to the following guides:
•

Fundamentals Guide

•

Scan Guide
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Xsheet

The Xsheet module is a component of the Stage module. It contains the tools used to create digital
exposure sheets, columns and timing. It is mainly used in large traditional animation studios to
maintain a structure and avoid users having to learn the full product application. This way, the Xsheet
team can concentrate on their task without having to deal with the compositing and drawing tools.
To learn more about the Xsheet module, refer to the following guides:
•

Fundamentals Guide

•

Xsheet Guide

•

Preferences Guide

Paint

Paint module is a component of the Stage module. It contains the drawing, painting and colour
styling tools. It is mainly used in large traditional animation studios to maintain a structure and avoid
users having to learn the full product application. This way, the colour styling or ink and paint team
can concentrate on their task without having to deal with the compositing and timing tools.
To learn more about the Paint module, refer to the following guides:
•

Fundamentals Guide

•

Paint Guide

•

Preferences Guide

Play

The Play module is used to play back the rendered image sequences enabling the user to view the
final scenes and compositing results.
To learn more about the Play module, refer to the following guides:
•

Fundamentals Guide

•

Play Guide
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Cloud

Access your Database via the Cloud. When you're running a studio, you will most likely have a
database set up. This enables all the artists working on your production to share the same scenes
and assets.
What the Toon Boom Cloud enables you to do is to host this database on the Internet. When you do
so, you can have freelancers log in from anywhere with an internet connection. Then they can
download a scene from the database, work on it, and upload it again.
No more need to spend time copying files to an FTP. No need to have an admin exporting and
importing files from the database. Do it all directly through the Cloud.
To learn more about the Cloud module, refer to the following guides:
•

Installation Guide

•

Control Center and Server Guide
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Chapter 4: Starting Toon Boom Harmony
Once Harmony is installed, you are ready to start the application and animate! In this chapter, you will
learn about starting the application, setting the resolution and opening the scenes.
•

Network Connection and Centralized Database on the next page

•

Starting Paint on page 23

•

Saving a Scene on page 29

•

Verifying the Project Integrity on page 32

•

Basic Commands on page 34

•

Preferences on page 38
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Network Connection and Centralized Database

Network Connection and Centralized Database

The Harmony solution is a revolutionary team-based infrastructure for animation production and 2D
games. Its array of features increases productivity and encourages creativity. Developed in conjunction
with leading studios worldwide, Harmony is specifically designed for long-term episodic and feature
length projects, providing a true animation pipeline. Several animators can work simultaneously on the
same project while the asset library provides users with easy access to up-to-date media assets.
Harmony is truly scalable; more than 100 staging clients can share animation just as easily as a few can.
Note that Harmony can be used in Database mode via the Network connection or as a standalone
application.

What is the Network Connection?
Harmony Network is the link between the client machines and the server. It lets you work on the
different projects stored in the central Harmony database.
At the heart of the Harmony solution is the server, which centralizes all the production assets in a
repository. Loaded with production proven tools to manage administration tasks, the server is
completely flexible and will fit in your existing infrastructure, whether you are on Windows, Linux or
Mac OS X. To learn more, refer to the Control Center Guide.

Working with Harmony Stage Via Harmony Network
When you start Harmony Stage, you can opt to either work offline in the application as a standalone
software, or connect to the database to work on projects via Harmony Network.
When working with Harmony Network, the scenes and their data are stored directly on the server. No
data is saved or stored on the client machine. The client machines access the database and load the
scenes and drawings directly from the server. Each time the user saves his scene, the data is updated
directly on the server. There are no upload or download operations (check-in, check-out) done
between the server and the clients.

If you have a standalone license, you will not have access to the database. You will automatically start the
application in standalone mode.
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Starting Paint
You can run the Harmony on the Linux, Mac OS X or Windows operating systems.

How to start Harmony Paint
1. Do one of the following:
‣

Mac OS X: Double-click on the Harmony Paint icon or select Applications > Toon Boom
Harmony 11.1 > Paint.

‣

Windows: Double-click on the Harmony Paint icon or select Start > Programs/All Programs
> Toon Boom Harmony 11.1 > Paint

‣

Linux: Select Applications > Toon Boom Harmony 11.1 > Paint

Toon Boom Harmony opens.
2. In the User Name field, enter your username. It is generally provided by the supervisor, system
administrator or team lead.
3. Click OK.
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Loading Drawings and Elements

Loading Drawings and Elements
Once you launch Harmony Paint, you need to load a scene’s drawings from the Database Selector, in
order to start the ink and paint process. The drawings must have previously gone through the Xsheet
and Scanning processes.
There are two ways of loading drawings:
•

Open Drawings
This option will let you load drawings from one element at a time, for quick ink and paint on a
single layer animation.

•

Open Elements
This option will let you load drawings from several elements at once. This can be useful when an
animation is separated in many layers, to insure that they are well aligned and that the painted
shapes and lines fit together. A good example of this would be a dialogue with the chin and mouth
separated from the rest of the head.

How to open drawings in Harmony Paint
1. Once Harmony Paint is launched and you are logged in, select File > Open Drawings. Press Ctrl +
O (Windows/Linux) or ⌘ + O (Mac OS X).
The Database Selector opens, displaying the Environments available from the Harmony database.

2. Select the Environment, Job, Scene and Element where the drawings you need to paint are
located.
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3. Choose the version you want to open from the Version drop-down menu.

‣

The Saved By and Saved Date fields display the user who was the last to save the selected
scene and the date of the last save.

4. Click on the Open button.
The Drawings Selector dialog box opens.

5. Select the desired drawings from the drawings list:
‣

Click on a single drawing to select it.

‣

You can create a continuous multiple selection by holding the Shift key.
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Loading Drawings and Elements

‣

You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘ (Mac OS X)
key.

‣

Click on the All button to select all the drawings that are listed in the Drawings Selector.

‣

Click on the Unpainted button to select all the drawings whose status appears as
UNPAINTED.

‣

Click on the Painted button to select all the drawings whose status appears as PAINTED.

6. Click OK.
The selected drawings appear in the Drawing Thumbnails view
7. Use the Control panel to navigate between the previous and next drawings. Press F and G.

You are now ready to ink and paint!

How to open elements in Paint
1. Once Harmony Paint is launched and you are logged in, select File > Open Elements. Press Ctrl +
E (Windows/Linux) or ⌘ + E (Mac OS X).
The Database Selector opens, displaying the Environments available from the Harmony database.

2. Select the Environment, Job and Scene where the elements containing the drawings you need to
paint are located.
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3. Choose the version you want to open from the Version drop-down menu.

‣

The Saved By and Saved Date fields display the user who was the last to save the selected
scene and the date of the last save.

4. Click on the Open button.
The Open Elements dialog box opens.

5. Select the elements you need to paint from the Elements list:
‣

You can create a continuous multiple selection by holding the Shift key.

‣

You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘ (Mac OS X)
key.
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Loading Drawings and Elements

6. Select the frames you wish to load from the Frames list:
‣

You can create a continuous multiple selection by holding the Shift key.

‣

You can create a multiple selection by holding the Ctrl (Windows/Linux) or ⌘ (Mac OS X)
key.

‣

Click on the All Frames button to load all the frames of the scene.

7. Click OK.
The Drawing Thumbnails view is hidden and your selected elements are loaded in Harmony Paint.
8. Enable the Light Table

option from the Drawing view toolbar to display all the drawing layers.

The selected layer are displayed in original colours and the other layers are displayed as washed
out colours.

9. Use the Control Panel to navigate between previous and next layers. Press H and J.

10. Use the Control panel to navigate between previous and next drawings. Press F and G.

You are now ready to ink and paint!
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Saving a Scene
It is important to regularly save your scene. As you make changes to a scene, an asterisk (*) appears in
the title bar beside the scene name to indicate that the scene contains unsaved changes.
When you use Harmony Network and work in a scene on the database, there are many choices and
options available when you save your work.
•

Save the scene as the current version.

•

Choose specific assets that you want to save, such as drawings or palettes.

You might want to save some specific aspects of your scene or save a new version. The Advance Save
feature allows you to do this. Once you have chosen the components to save, you will conclude the
procedure by following the instructions in the section. All the specific components that are selected
throughout the different tabs of the Advanced Save dialog box will be saved.

How to save a scene
‣

From the top menu, select File > Save.

‣

Press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

About the Advanced Save dialog box
1. Make sure that you have the necessary rights to save the current scene version.
2. From the top menu, select File > Save....
The Advanced Save dialog box opens.

Drawings
The Drawings tab lists the modified drawings.
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Parameter
Drawing list

Saving a Scene

Description
Lets you select the modified drawings to save, and deselect
the ones you do not want to save.

Select All

Selects all modified drawings in list.

Deselect All

Deselects all modified drawings in the list.

Palettes
The Palette tab lists the modified colour palettes.

Parameter

Description

Colour Palette list

Lets you select the colour palette to save, and deselect the
ones you do not want to save.

Show Recovered

Displays the recovered palettes in the list of modified
palettes.

Select All

Selects all modified colour palettes in the palette list.

Deselect All

Deselects all modified colour palettes in the palette list.

Palette Lists
The Palette Lists tab lists all the modified colour palette lists.
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Parameter

Description

Palette Lists

Lets you select the modified palette list to save, and deselect
the ones you do not want to save.

Show Recovered

Displays the recovered palettes in the list of modified
palettes.

Select All

Selects all modified palette lists in the list.

Deselect All

Deselects all modified palette lists in the list.

How to save with advanced settings
1. After selecting the components to save, click Save.
All the specific components that were selected throughout the different tabs of the Advanced
Save dialog box are saved.
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Verifying the Project Integrity

Verifying the Project Integrity
The Check Files command verifies the integrity of the drawing and palette files in your project.

How to open the Check Files dialog box
‣ From the top menu, select File > Check Files.

Check Files
Use the Check Files dialog box to verify that the data is consistent, correct, and accessible.

•

Click Check Colours to open the Check Colours dialog box.

Check Colours
The Check Colours dialog box checks the palette integrity and displays the colour recovery data.
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Related Tasks
Saving a Scene

29
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Basic Commands

Basic Commands
This table lists the most common commands used in Harmony.
Command

Action

Access Methods

Close

Closes the currently
opened scene, but does
not close the Harmony
application.

File > Close

Save

Saves all changes made
to the opened scene,
drawings, palettes, and
palette lists.

File > Save

Closes
HarmonyHarmony
Stage.

Windows/Linux: File >
Quit

Removes selected
objects. You can then
paste the object or its
properties to another
object.

Edit > Cut

Copies selected objects
and properties.

Edit > Copy

Places an object you cut
or copied into the
location you select in
the Camera, Drawing
and Timeline views.

Edit > Paste

Removes selected
objects.

Edit > Delete

Selects all drawing
objects in the current
drawing window in the
Drawing, Timeline and
Camera views. This
helps you manage
multiple objects as one
when moving them.

Edit > Select All

Quit

Cut

Copy

Paste

Delete

Select All

Press Ctrl + S
(Windows/Linux) or ⌘
+ S (Mac OS X).

Mac OS X: Stage>
Quit

Press Ctrl + X
(Windows/Linux) or ⌘
+ X (Mac OS X).

Press Ctrl + C
(Windows/Linux) or ⌘
+ C (Mac OS X).

Press Ctrl + V
(Windows/Linux) or ⌘
+ V (Mac OS X).

Delete
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Command
Deselect All

Action

Access Methods

Deselects all selected
objects in the Drawing
and Camera views.

Edit > Deselect All

Removes remove the
last change made to
your project. Harmony
supports multiple undo,
so you can undo
changes you made in
the order you made
them.

Edit > Undo

Redoes and operation
you have undone that
you later decide to
keep. This command is
active only after you use
the Undo command.

Edit > Redo

Help

Launches the Toon
Boom Harmony Online
Help system, complete
with instructions on
how to use the system.
This requires an
internet connection.

Help > Help

Toon Boom Harmony
on the Web

Launches the Toon
Boom Harmony
website, which features
a Support and
Community > Forum
section.

Help > Toon Boom
Harmony on the Web

About

Use the About
command to access
general information
about the software.

Windows/Linux: Help
> About

Undo

Redo

Esc

Press Ctrl + Z
(Windows/Linux) or ⌘
+ Z (Mac OS X).

Press Ctrl + Shift + Z
(Windows/Linux) or ⌘
+ Shift + Z (Mac OS X).

Mac OS X: Stage >
About

This table lists the most common commands used in Harmony Paint.
Command
File >
Add/Revert

Action

Shortcut

Use the Add/Revert
command to load new
drawings to the already
existing selection or to
reload drawings to revert
the modifications to the
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Command

Basic Commands

Action

Shortcut

last save.
This option does not
work when several
elements are loaded.
Windows >
Colour

Use the Colour command
to display the Colour
view.

Windows >
Colour Editor

Use the Colour Editor
command to display the
Colour Editor view.

Windows >
Model

Use the Model command
to display the Model
view.

Windows > Tool
Properties

Use the Tool Properties
command to display the
Tool Properties view.

File > Load
Background File

Use the Load
Background File
command to import a
background image in
Paint to compare your
drawing's colours with it.

File > Move
Background

Use the Move
Background command
to move the background
image in the stage.

File > Open
Drawings

Use the Open Drawings
command to open the
Database Selector dialog
box to select a set of
drawings.

The Ctrl + O
(Windows/Linux) or ⌘ +
O (Mac OS X).

File > Open
Elements

Use the Open Elements
command to open the
Open Elements window
and select a series of
drawing elements and a
frame range to work on.

The Ctrl + E
(Windows/Linux) or ⌘ + E
(Mac OS X).

Options > Play
by Frame

Use the Play by Frame
command to flip between
the frames instead of the
drawings. If a drawing is
exposed on two frames,
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Command

Action

Shortcut

you will have to flip twice
before moving on to the
next drawing.
File > Reset
Background
Position

Use the Reset
Background Position
command to restore the
background image
original size and position.

File > Scale
Background
Down

Use the Scale
Background Down
command to scale down
the size of the
background image.

File > Scale
Background Up

Use the Scale
Background Up
command to scale up the
size of the background
image.

File > Unload
Background

Use the Unload
Background File
command to remove the
background image from
Paint.
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Preferences

Preferences
An important feature of Toon Boom Harmony is the Preferences dialog box. From here you can
customize your interface, tool behaviour and shortcuts. Throughout this guide, you are often required
to go to the Preferences dialog box to set parameters and options.
To learn about the different preferences available, refer to the Preferences Guide.
How to open the Preferences dialog box
1. Do one of the following:
‣

Windows/Linux: From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
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Chapter 5: Interface
Knowing how to manage the Toon Boom Harmony interface helps you to work efficiently and organize
your workspace conveniently. There are a series of views and toolbars you can use as you perform
different operations. Usually, each person has a specific way of working in the interface and prefer
particular views and toolbars. In this chapter, you will learn about the main elements of the interface
and how to manage them.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Paint is a subset of
Harmony Stage.

This chapter is divided as follows:
•

Menus on the next page

•

Managing the Views on page 42

•

Managing the Toolbars on page 44

•

View References on page 48

•

Toolbar References on page 59

•

Interface Navigation on page 60
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Menus

Menus
Harmony has a large number of functions and options that you can access from the following menus:

Top Menu
The top menu contains most of the commands. Depending on the view you are working in and the
element, some commands are available and others not. The top menu is always located at the very
top of the interface.
The top menu contains the following categories:
•

File

•

Edit

•

View

•

Drawing

•

Selected

•

Tools

•

Options

•

Colours

•

Palettes

•

Windows

•

Help

On Mac OS X, there is a Stage category containing the following commands:
•

Preferences

•

About

•

Quit

View Menu

Some views have their own menu. These menus contain commands specifically related to that view.
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How to access the view menu
1. In the view's top-left corner, click the Menu

button.

A list of commands is displayed.

Quick Access Menu

Each view has a quick access menu containing commands you will use most often. This menu is
accessed by right-clicking anywhere in the view.
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Managing the Views

Managing the Views
The Harmony user interface is composed of different views, each one designed for a specific purpose.
You can modify the location and accessibility of the views by adding a new view as a tab or as a
window. You can also swap the view locations around.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Paint is a subset of
Harmony Stage.

It is important to know about the active view. When a view is active, a red rectangle appears around
the view. Keyboard shortcuts and top menu options are linked to the active view. If a menu option is
greyed out, it either means it does not apply to your layer, drawing or other type of selection or the
option does not apply to the active view.

Workspace modifications are automatically saved when you exit the application unless you deselected
the Automatically Save Workspace option in the Preferences dialog box.

How to add a view
1. Select the view you want to add from Windows > the desired view.

How to close a view
1. Click the Close View button.

How to resize a view
1. Position your cursor on the edge of the view you want to resize.
2. When you see the Resizing
or height.

cursor, click and drag the side of the window to the desired width
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You can also temporarily hide a view to get more working space.

How to temporarily hide a view
1. On the edge of the window you want to hide, click the Collapse/Expand button.
The view is compressed and only the Collapse/Expand button is visible.
2. Click the Collapse/Expand button again to redisplay the view.
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Managing the Toolbars

Managing the Toolbars
Harmony contains toolbars which, by default, are located at the top of the interface. Some of the
workspace’s views also have their own toolbars which you can move around. You can reposition the
toolbars to suit your work style or hide unused ones.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Paint is a subset of
Harmony Stage.

You can display or hide toolbars using the menus. The Toolbar menu only contains the View toolbars
of the views that are displayed in the workspace. As you show or hide views in your workspace, the
Toolbar menu updates.
The top toolbars can also be displayed directly in a view. Only one instance of each toolbar can be
displayed. If a toolbar is already displayed in the top area and you decide to display it in a view, the
selected toolbar will move from the top area to the view.
The View toolbars can be customized to contain your favourite tools and options. Using the Toolbar
Manager window, you can organize different toolbars to suit your working style.
If the default toolbar does not contain the tools you require, you can customize the toolbar.

How to show and hide a toolbar
1. From the top menu, select Windows > Toolbars > the desired toolbar.
‣

You can right-click anywhere in the toolbar area to access Harmony toolbars. View toolbars,
however, are not available by right-clicking the toolbar area. You can access the toolbar of
any open and active view by right-clicking in the view's top area or the Windows menu.
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How to resize a toolbar
1. Hide a portion of a toolbar by dragging another open toolbar over its tail-end.
2. Click on the arrows appearing at the end of the collapsed toolbar to expand it.

How to move a toolbar
1. Select the toolbar you want to move by clicking its anchor point and dragging it into a view toolbar
area or another position in the top or side interface toolbar area.

2. When a highlighted zone appears showing an available location for the toolbar, release the mouse
button and drop the toolbar into position.
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Managing the Toolbars

‣

1. Dock to the top toolbar area.

‣

2. Move a toolbar down a row.

‣

3. Dock to the left toolbar area.

How to customize a view toolbar
1. In the chosen view, right-click on any button in the toolbar where you want to add or subtract a
new button. You can also reorder the buttons. Make sure the button you right-click on is active.
2. From the menu, select Customize.

The Toolbar Manager window opens.
3. To add a new icon to your toolbar, select the tool or command from the Available Tools list and
click the Right Arrow
button to switch it to the Toolbar list.
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4. To remove an icon from your toolbar, select the tool or command in the Toolbar list and click the
button to switch to the Available Tools list.
Left Arrow

5. To reorder the icons in your toolbar, select the command to be moved from the Toolbar list and
click the Up
or Down
buttons to move it to the correct location.

6. Click OK when you are finished.
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View References

View References
Harmony contains a series of views that are each focused on a specific set of tasks. Here are the views
available:
•

Colour view

•

Colour Editor view

•

Drawing view

•

Message Log view

•

Model view

•

Tool Properties view

Colour View
The Colour view is where you create colours and palettes and import existing palettes into your
project. The Colour view is also necessary for drawing, painting and creating colour styling.
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The Colour view has two display modes:
•

List mode

•

Swatch mode

How to switch between the display modes
1. From the Colour View menu, select Colours > Swatch Mode and do one of the following:
‣

Select the option to display the swatches.

‣

Deselect the option to display the colour list.

When you are painting on bitmap layers, the Colour view will look like the following. It contains a
subset of the tools available when working with vector layers.
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View References

1. Add Colour
The Add Colour

button lets you add a new colour swatch to the bottom of your colour list.

2. Remove Colour
The Remove Colour
button lets you delete the currently selected colour swatches. If the colour
swatch is used in your project, the Delete Colour dialog box will appear asking you to confirm the
operation.

‣ Click OK to confirm the operation or Cancel to cancel it.
Zones painted with colour swatches which have been deleted will turn red, easily identifying them so
you can repaint them with another colour swatch.
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3. Add Texture

The Add Texture
button lets you add a bitmap colour swatch to your palette. You can load
photos and textures and paint your drawings with it. The bitmap image must be a TGA or PSD file
format.

4. Set Current Brush Colour
The Set Current Brush Colour
button let you set the currently selected colour swatch as the
colour used by the Brush
tool. If you select a new colour in the Colour view while using the Brush
tool, the Set Current Brush Colour swatch will be updated.

5. Set Current Pencil Colour
The Set Current Pencil Colour
button lets you set the currently selected colour swatch as the
colour used by the Pencil
, Polyline
, Ellipse
, Rectangle
and Line
tools. If you
select a new colour in the Colour view while using any of these tools, the Set Current Pencil Colour
swatch will be updated.

6. Set Current Paint Colour
The Set Current Paint Colour
button lets you set the currently selected colour swatch as the
colour used by the Brush
tool. If you select a new colour in the Colour view while using the Paint
tool, the Set Current Paint Colour swatch will be updated.
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View References

7. Link/Unlink Three Colours

The Link/Unlink Three Colours
button lets you link the Set Current Brush Colour, Set Current
Pencil Colour and Set Current Paint Colour swatches to the currently selected colour swatches in the
Colour view.

8. Show/Hide Palette List View

The Show/Hide Palette List View button lets you display the Palette List view in the Colour view. This
option is for the advanced user who wants to create colour palettes for their props and characters.

9. Colour Swatch Name

Each colour swatch available in the Colour view can have its own name, making it easy to identify
which colour is used to paint what part of your character or background.
Two colours can have the same name.
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10. Colour Swatch

A colour swatch is a specific colour used to paint a certain zone of a character or background. Colour
palettes are composed of colour swatches. They can also be called colour pots. When you paint a
zone with a colour swatch, the zone is linked to the swatch. So if you update the swatch’s tint, the
zone will be updated along with it. This allows you to modify your animation colours even after it is
completely painted.

11. Colour View Menu
The Colour view
menu lets you access commands related to the Colour view such as creating
new palettes, adding new colour swatches, and displaying the Tint panel.

12. Add Palette
The Add Palette

button lets you add a new palette to the bottom of your palette list.

13. Remove Palette
The Remove Palette
button lets you delete the currently selected palette. If the colour swatch is
used in your project, zones painted with colour swatches which have been deleted will turn red,
easily identifying them so you can repaint them with another colour swatch.

14. Link Palette
The Link Palette button lets you access other palettes created in the project and link them to your
scene.

15. Order Palette List
The Up and Down arrows let you reorder the selected palette. When using clone palettes (colour
styles), the highest palette is the list will override its clone located lower in the list.

53

Chapter 5: Interface

View References

16. Edit Palette Mode
In Network mode, the Edit Palette Mode
button lets you get the rights to modify the palette.
The palette files can be locked to avoid accidentally modifying the palette.

17. Colour Editor
The Colour Editor panel allows you to modify the HSV and RGBA values of the selected colour
without using the Colour Picker window.

18. Drawing Navigation and Art Layers
These controls are used to quickly have access to common commands.

•

Previous and Next Drawing
These buttons let you switch to the previous or next drawings. The shortcuts are F and G.

•

Previous and Next Layer
These buttons are used to switch to the previous or next layer when you have different layers
loaded. The shortcuts are H and J.

•

Line Art, Colour Art, Preview Mode
Use these buttons to toggle between the Line Art to Colour Art layers. The shortcut is L. You can
also enable or disable the Preview mode. The shortcuts are Shift + P.

Drawing View
Only the selected drawing is displayed by default in the Drawing view. You can use features, such as
the light table to display the current drawing of all the enabled layers of your scene in washed-out
colours, or the Onion Skin to display the previous and next drawings of the currently selected drawing
layer.
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1. Drawing Area
This is the main space in the Drawing view. It is where you draw and where the drawings are
displayed.

2. Zoom Menu
The Zoom menu lets you enlarge or reduce the Camera or Drawing view display.
To make the camera frame size always match the size of your view, select the Fit to View option.
Click the drop-down arrow and select a zoom level or press 1 and 2.
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View References

3. Drawing Name
The Drawing Name field displays the name of the selected drawing, as well as the layer containing it.
If the cell does not contain any drawing, an Empty Cell text is shown in the field.

4. Tool Name
The Tool Name field displays the name of the selected tool. If you temporarily override a drawing
tool using a keyboard shortcut, the tool’s name will be highlighted in red. You can temporarily
override a tool by holding its keyboard shortcut without the [Alt] key. For example, the Select tool
shortcut is Alt + S. If you hold down [S], you will switch to the Select tool. As soon as you release the
key, you will return to the tool you were using.

5. Current Frame
This field displays the current frame of the animation you are working on.

6.Cursor Coordinates
This indicates the position of the mouse cursor in the drawing area.

7. Colour Picker
The Colour Picker allows you to select a colour for drawing.

8. Drawing Thumbnails Panel
The Drawing Thumbnails panel displays a list with thumbnails of the loaded drawings. The
highlighted drawing is the one displayed in the drawing area. You can select the drawing you want to
paint directly from this list.

Message Log View
The Message log view displays information gathered during a render task, such as which frames and
at what time they were each rendered. The view also contains a list of the colour recovery operations.
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Model View
Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view.
This drawing can be used and loaded in any of your Harmony scenes.
Once a drawing is loaded in the Model view, you can use the Dropper
tool to select a colour from
the model and use it to paint in the Camera or Drawing view without having to pick the colour from
the colour palette.
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Tool Properties View
The contextual Tool Properties view contains the most common options and operations related to the
currently selected tool. As soon as you select a tool from the Tools toolbar, the Tool Properties view
updates.
For example, if you choose the Select tool in the Tools toolbar, the Tool Properties view will display
the options and operations related to the Select tool, such as Snap to Contour, Apply to All Drawings,
Flip Horizontal, and Flatten.

Options
Options are different modes you can apply to a selected tool to modify its behaviour to fit the
current task’s needs.

Operations
Operations are actions you can perform while using the selected tool.
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Toolbar References
Harmony has several toolbars. The Top toolbars are available at the top of the interface and the View
toolbars are in individual windows. View toolbars are only shown if the particular view is displayed in
the workspace. This is a complete list of the toolbars available in Toon Boom Harmony.

Top Toolbars
Edit Toolbar
The Edit toolbar contains common operations such as Copy, Paste, Cut, Undo and Redo. These
options can also be found in the Edit menu.

File Toolbar
The File toolbar contains the common file operations such as New, Save and Open. These options
can also be found in the File menu.

Tools Toolbar

The Tools toolbar contains all of the main tools you will use while working in Harmony. In the default
workspace, you will find this toolbar on the left-most side of the interface.

View Toolbars
Here is a list of the view toolbars available in Harmony:
•

Model View Toolbar
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Interface Navigation

Interface Navigation
Toon Boom Harmony supports zoom in, zoom out, rotate, pan and reset view for easy interface
navigation for the views.
Command

Action

Access Methods
View > Zoom In
Press 2 or roll the mouse
wheel up.

Zoom In

Zooms into the view.

In the Timeline view,
press Ctrl
(Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel up.
View > Zoom Out
Press 1 or roll the mouse
wheel down.

Zoom Out

Zooms out of the view.

Zoom In or Out

Zooms in or out of the view.

Roll the middle mouse
button up or down.

Pan

Moving parallel to the view.

Hold down the Spacebar and
drag the mouse in the direction in which you want to
pan the view.

Recenter view

Recenters the view on your mouse
cursor.

Press N

Reset Pan

Resets the view’s pan to its default
position.

In the Timeline view,
press Ctrl
(Windows/Linux) or ⌘
(Mac OS X) and roll the
mouse wheel down.

View > Reset Pan
Press Shift + N
View > Reset
View

Reset View

Resets the view to its default position.

Reset Rotation

Resets the view’s rotation to its
default position.

Press Shift + M

View > Reset
Rotation
Press Shift + X

Reset Zoom

Resets the view’s zoom to its default
position.

View > Reset Zoom

Rotate 90 CW

Rotates the Camera view 90 degrees

View > Rotate View CW
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clockwise, like an animation table.
Rotate 90 CCW

Rotates the Camera view 90 degrees
counter-clockwise, like an animation
table.

View > Rotate View CCW

Use the Magnifier tool to
quickly center on the mouse
position and zoom in to a
pre-defined value such as
4X. Then you can zoom out
again. Hold the shift key and
press Z to zoom in and back
out again. Replacing the
Reset Zoom by pressing
Shift +.

Toggle Quick Close-up

The area where you zoom in
or out is dependent on the
cursor location in the
Camera view. If you zoom in
and them move the cursor
to a different location when
you zoom out the mouse will
be centered on that
location.

Zoom Tool
From the Tools toolbar, use the Zoom
view.

tool to zoom in and zoom out in the Camera or Drawing

•

The keyboard shortcuts are 1 and 2.

•

When the Zoom In mode is selected, hold Alt as you click to zoom out.

When you select the Zoom tool, its properties are displayed in the Tool Properties view.

Zoom Tool Options

Button

Description

Zoom In

Zooms in

Zoom Out

Zooms out

Operations

Button

Description
Zoom in the Camera or Drawing view.
The keyboard shortcut is 2.

Perform Zoom In
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Perform Zoom Out

Zoom out the Camera or Drawing view.
The keyboard shortcut is 1.

Reset Zoom

Restores the current zoom level to 100%.

Reset View

Restores the original display by resetting
any pan, rotation or zoom actions.
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Chapter 6: Character, Prop and Location Design

Another important step in the project creation is the character, prop and location design. This
determines the style and models to follow for the entire project.
The design can be created on paper and scanned in or it can be created digitally. You can draw and
even create the colours entirely on paper, while others like to design on paper and scan the drawings
to create the colour model in a software program. The most popular method is to design directly in
Harmony.
To save paper and time and avoid having to recreate colour palettes, Harmony gives you the ability to
design all elements directly in the application. This keeps all your work within the same software,
avoids using a lot of paper and losing time scanning in elements and importing them.
The character and prop design process is divided in three steps:
•

Preparation on the next page

•

Sketching the Model on page 65

•

Cleaning and Inking the Model on page 77

Harmony has an extensive set of drawing tools that can be used to design your characters. You can
learn more about this in the following topic:
•

Drawing Tasks on page 79

Each drawing tool has a series of options to customize its behaviour and drawing style. You can learn
more about them in the following section:
•

Drawing Tool References on page 134
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Preparation

Preparation
To prepare for the design task, you will need to go through a few steps:
•

Getting References below

•

Using the Workspace below

Getting References

Creating models requires two main reference sources, the script and the storyboard. Once you have
the script in hand, you can learn about the characters and their personalities, the props, the
ambiances, and so on. This will be your main reference, so it is very important to read it carefully.
The storyboard is the second reference source and it can be quite useful as well. Although it will not
yet be the final version of the storyboard, it will show you what the character is doing and what props
need to be designed.

Using the Workspace
Once your scene is created, you can open it and set your workspace.
To sketch the characters, props or locations directly in Harmony, you will mostly use the Drawing view
along with the Colour, and Tool Properties views.
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Now that your references and scene are created, you can start designing. To draw your characters,
props and key locations, you will need to learn the following:
•

Drawing with the Brush or Pencil Tool below

•

Override Tool on the next page

•

Relative Size on page 67

•

Palettes and Colours on page 70

•

Sketching the Character on page 74

Drawing with the Brush or Pencil Tool

The Brush
and Pencil
tools are used for drawing and sketching. Both tools support pressure
sensitivity, allowing you to create lines with variable thickness. The Brush tool produces contour vector
lines. The Pencil and shape tools produce central vector lines. This means that a pencil line’s control
points (used to deform its shape) are located along the length of the central spine, while the Brush
line’s control points are located along the contour.
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•

If you draw with the Brush tool and want to modify the thickness, use the Contour Editor

tool.

•

If you draw with the Pencil tool and want to modify the thickness variation, use the Pencil Editor
tool.

•

You can also convert a brush zone into a pencil line with the Brush Stroke to Pencil Line

option.

If you sketch a drawing using a semitransparent colour to get a paper-like feel, you should use the
Brush tool as it produces a more realistic and natural feel. The pencil line is very useful for tracing clean
or final drawings.

Also, it is recommended to use brush lines when designing cut-out puppet articulations which use
patches.

Override Tool
The Override tool lets you increase productivity by rapidly switching between tools used for short
tasks and your previous tool. Most drawing tool shortcuts are accessed using the Alt key followed by
another key, such as the Eraser tool which is accessed by pressing Alt + E.
If you are drawing with the Brush tool and need to briefly switch to the Eraser before continuing, hold
down the E key while you are erasing. Once you are done, release the E key to return to the previous
tool; in this case, the Brush tool. You can do the same for most drawing tools that have a shortcut
composed of Alt followed by another key.
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Relative Size

The size relation between the props, characters and backgrounds is very important in maintaining
consistency and structure throughout the project.
A production can contain many characters and props. It is not unusual for these to be created by
different people. If there is no size control implemented, the characters and elements created by
different artists can vary greatly. When this occurs, the characters that are placed together in a scene
will be out of proportion. The animator or person doing the scene setup will then have to scale them
to the correct size.
When a character or prop is scaled down, the outline will become increasingly thinner. By the time the
element is scaled to its proper size, the outline may be so thin that a difference between one
character's outline and the one beside it will not look very good.
Here are a few tips you can use to create a suitable size relation.
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Line Up

A line up consists of copying and pasting all your character designs into the same drawing and then
scaling them to the correct proportion in relation to the other characters. This line up is very
important and should be handed to any animator, layout and posing artist or scene setup person
working on the project.
For the prop design, it is recommended that you paste one of the main character's hands or even the
full body beside the prop. This enables the animator to know what size to draw the prop.
In your character design scene, it is a good idea to create a column for the character line up.The line
up is usually done during the character design step. When the character builder imports the model
to the breakdown scene, the size relation should be correct.

Field Chart

Harmony includes a field chart in its Drawing view. This tool is very useful in setting the characters'
and props' heights.
It is recommended that you keep the character design and breakdown inside the 12 field size. This
ensures that it fits the default camera size and the template thumbnails. If some parts were drawn
too big or too far apart, you can use the Reposition All Drawings tool and reposition, scale or rotate
multiple drawings from different layers all at once.
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Use the Show Grid option to display a grid in the Drawing view.
Name

Show
Grid

Button

Description

Keyboard Shortcut

Displays the grid

From the top menu,
select View > Grid >
Show Grid
Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square

Displays a standard square grid

From the top menu,
select View > Grid >
Square.

12 Field Grid

Displays a 12-field size grid

From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid

Displays a 16-field size grid

From the top menu,
select View > Grid >
16 Field Grid.

Underlay

Displays the grid under the drawing
elements

From the top menu, select
View > Grid > Underlay

Overlay

Displays the grid over the drawing
elements

From the top menu, select
View > Grid > Overlay

How to use the Reposition All Drawings
1. In the Tools toolbar from the Select drop-down menu, select the Reposition All Drawings
tool. This also automatically selects every stroke in your drawing in the Drawing view.
2. To deform or reposition a selection:
‣

To reposition, click and drag your selection to a new area.

‣

To scale, pull or push on the top, side, bottom or corner control points. Hold down Shift
to lock the selection’s ratio.
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3. When you release your cursor, every drawing contained in the drawing layer you repositioned,
scaled, rotated or skewed will follow the same transformation.

Brush Size
Harmony provides a variety of pens and brushes and also allows you to create and save your own
through creating a tool preset.
It is a good idea to create and save pens with precise sizes and parameters to trace and design your
models and breakdowns.

Palettes and Colours
Harmony has an integrated palette system. Each character, prop or background can have its own set
of colours and each colour in the palette can be associated to colour fill zones on a drawing. You can
create as many palettes and colours as you need.

Each scene created in Harmony includes a default colour palette which contains a standard set of
colours for sketching and painting.
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You can sketch and design using the default palette without any problem. However, it is not
recommended that you use the default palette for the colour models. A different colour palette should
be created for each colour model.
To sketch and design with a different colour swatch or create a palette for each character, prop or key
location, you will need to learn how to manage the Harmony palettes.

How to create a new palette (Basic Palette Lists mode)
1. From the Colour View menu, select Palettes > New or click the New Palette
‣

button.

Make sure that you have the necessary rights to modify the palette list. If you do not, select
Edit > Edit Palette List Mode.

The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click OK.
The palette appears in the drawing element’s palette list.

How to lock or unlock the palette list
‣

In the Colour view, click the Edit Palette Mode

button.

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch
1. In the Colour view, click the New Colour

button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.
The Colour Picker window opens.
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3. To set your colour, do one of the following:
‣

In the colour wheel, select a colour.

‣

Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣

Click the Dropper
button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.
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Sketching the Character

You are now ready to sketch your models. There are two tasks to perform in order to draw your
characters:
•

Add a drawing layer

•

Sketch the model

You have the choice to sketch your model as a bitmap or vector drawing. If you like the feel of drawing
with bitmap lines, you can set your layer as bitmap. If you like drawing with vectors, you can set your
layer as vector. If you use vector, you will be able to enlarge your drawing and zoom into it without
losing quality or resolution. You can also use the Contour Editor and Select tools to resize and modify
lines. If you draw with bitmap, you will not be able to scale the drawing beyond 100% of its resolution
without encountering pixelization issues.
If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 226

How to sketch a model
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush preset and adjust its parameters.
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3. In the Drawing Thumbnails panel, select a drawing.
4. In the Drawing view, enable the Grid (Field Chart). You can press Ctrl + ' (Windows/Linux) or ⌘ + '
(Mac OS X).
‣

Make sure the Drawing view is the active view while using the keyboard shortcut.

5. In the Drawing view, start drawing.

6. To select a different colour, in the Colour view, select a different colour swatch. Double-click on the
colour swatch to open the Colour Picker window and modify the colour. Remember that anything
already painted with that colour swatch will update to the new colour.

7. In the Drawing view, use the Rotary Table
(Windows/Linux) or Ctrl+⌘ (Mac OS X).

to rotate your workspace.You can press Ctrl+Alt
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‣

Sketching the Character

The default keyboard shortcut to reset the workspace rotation is Shift + X.

8. If you decide to draw in the next cell and need to see your previous drawing, enable the Onion Skin
by pressing Alt + O.
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Cleaning and Inking the Model

When your rough models are ready, it is time to clean and ink them. You can still use the default
palette and colours to do so, especially if you are not the one doing the colour styling. If you have
already created a palette for your model, you can add new colours for tracing.
If you want to keep your roughs and sketches, add a new drawing layer and trace in it using the Light
Table. This is the equivalent of adding a sheet of paper and tracing over the rough using the animation
disk light table. You only need to disable the rough layer to prevent it from appearing in the final scene
render.
If you would like to separate your lines and colours on separated art layers, see Art Layers on
page 226

How to trace your character
1. In the Drawing Thumbnails panel, select the drawing to trace in.
2. If you work in the Drawing view, enable the Light Table

or press Shift + L.

3. Do one of the following:
‣

In the Tools toolbar, select a drawing tool.

‣

From the top menu, select Tools > desired tool.

4. Trace the model.

5. To make perfect points and corners, you can intersect the two strokes to create a point. Using the
Cutter
tool, you can automatically trim the excess portion. In the Tool Properties view, enable
the Lasso
selection type. Make sure the Use Mouse Gesture
button is enabled. In this
mode, you can automatically delete any extra sections of line in your artwork by simply clicking,
holding and dragging your mouse over it.
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6. If you are using the Pencil tool to clean your drawing, you will need to merge your pencil lines
together after cropping the points.
‣

In the Tools toolbar, select the Select

‣

In the Drawing view, select the two strokes to be merged.

‣

In the Tool Properties view, click the Merge Pencil Lines

‣

You can also set the Join option to Mitre.

tool.
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Drawing Tasks
Harmony has a wide variety of drawing tools for all kinds of drawing tasks. This section covers how to
use these tools. For the complete details on their options in the Tool Properties view, see Drawing
Tool References on page 134.
In this topic, you will learn about:
•

Drawing with the Pencil Tool below

•

Drawing with the Brush Tool on page 88

•

Drawing with Textured Brushes on page 94

•

Viewing the Final Lines as You Draw on page 105

•

Selecting the Current Colour of a Tool on page 107See "Selecting the Current Colour of a Tool "
on page 107

•

Selecting Drawing Objects on page 109

•

Erasing Parts of a Drawing on page 112

•

Reshaping a Drawing Using the Contour Editor Tool on page 114

•

Reshaping Pencil Lines with the Pencil Editor Tool on page 116

•

Drawing with Shapes on page 118

•

Drawing with the Polyline Tool on page 119

•

Drawing with Invisible Lines on page 120

•

Deforming a Drawing with the Perspective Tool on page 122

•

Warping a Drawing with the Envelope Tool on page 123

•

Cutting Drawing Parts on page 125

•

Smoothing Lines on page 126

•

Working With Text on page 127

•

More Drawing Tools on page 127

Drawing with the Pencil Tool
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The Pencil tool is for drawing the final images, such as character modules, cut-out puppet and clean
animation. The pencil creates a central vector shape. Pencil lines support pressure sensitivity and
texture.

How to draw with the Pencil tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing view, start drawing.
‣

When you get close to an existing pencil line, hold Alt to draw and connect your stroke to
the existing one. Pencil lines are central vector lines and you might think your line is
connected, but in fact, only the contour is touching the other one. Also, make sure the
central vector crosses the other one.
To connect the start or end of your stroke, hold Alt when you start or finish drawing a line.

‣

To draw a straight line, press Shift + Alt as you draw.

How to modify the pencil settings
1. In the Tools toolbar, select the Pencil

tool or press Alt + /.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.
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The Pencil Properties window opens.

This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Shape
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You can adjust the start, end, and joint style of a selected
pencil line.

Texture

•

Start: Lets you select the style of the start tip, which is the
first tip you drew. You can choose between Round or Flat
style.

•

End: Lets you select the style of the end tip, which is the
last tip you drew. You can choose between Round or Flat
style.

•

Join: Lets you select the joint style. The joints are where
the line curves abruptly. You could also define the Join
style as the corner style. You can choose between Round,
Mitre and Bevel style.

See Pencil Line Texture on page 85.

Working with Pencil Presets

A preset is a pencil with specific properties. You can work with regular pencil presets and thickness
stencils.
Regular pencil presets allow you to set the size and smoothing of the line or shape. As you draw, the
thickness of the line varies according the amount of pressure you apply with a pen and tablet.
icon are also set with specific properties, but
Thickness stencils that are indicated with this
disregards the pressure you use with your pen and tablet. The line thickness varies. You can access
thickness stencils from the list of presets on the Tool Properties view or create your own.

How to select a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

2. In the Tool Properties view, use the Presets menu to select a pencil preset.

3. In the Drawing view, draw your pencil line or shape.

82

tool.

Toon Boom Harmony 11.1 Paint Guide

How to select a pencil thickness stencil
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, use the Presets menu to select a thickness stencil. They are marked
with this

icon.

3. In the Drawing view, draw your pencil line or shape.

How to create a pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Tool Properties view, adjust your pencil settings—see How to modify the pencil settings on
page 80.
3. In the Tool Properties view, click the New Brush

button.

The New Preset dialog box opens.

4. Type in a name for your new pencil thickness stencil and click OK.
5. Start drawing in the Drawing view.
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How to create a pencil thickness stencil
1. In the Tools toolbar, select the Select

tool.

2. In the Camera view, select the pencil line or shape from which you want to take the style.

3. In the Tool Properties view, click the New Thickness Stencil

button.

A new thickness stencil is added to the end of the list in the Presets menu.
4. In the Presets menu, select a new thickness stencil and click on a line or shape in the Drawing view
to apply the thickness stencil you created.

How to apply a thickness stencil to a pencil line or shape
1. In the Tools toolbar, select the Select

tool.

2. In the Drawing view, select the pencil line or shape on which you want to apply a style.

3. In the Tool Properties view, select the style you want to apply from the Presets list.

The style you selected is applied to your selection.
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How to rename a thickness stencil or pencil preset
1. In the Tools toolbar, select the Pencil

, Line

, Ellipse

, or Rectangle

tool.

2. In the Presets menu, select the thickness stencil or preset you want to rename.
3. From the Brush menu, select Rename Brush.
The Rename Preset dialog box opens.

4. In the Name field, type in the new name.

How to delete a thickness stencil or pencil preset
1. In the Tools toolbar, select the Pencil

tool.

2. In the Presets menu, select the thickness stencil or preset to delete.
3. Click the Delete Preset

button.

Pencil Line Texture
You can apply a texture to a pencil line.
Pencil lines support texture. Before drawing, you can select or import a texture and apply it to your
lines. You can also change it afterwards using the Select tool. Textures are independent from pencil
templates.
When you import a texture in your pencil styles, it is saved in your scene. If you want to add that
texture to a bank that you will reuse in different scenes, you can add that texture to your preferences.

How to apply a preset texture to a pencil line
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

In the Pencil Properties display.
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3. In the Texture section, select a texture for the pencil.
4. In the Drawing view, draw a pencil line.

How to create a pencil texture template with the Pencil tool
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties editor, click the New Texture
Texture menu.
‣

To delete a preset style, click the Delete Texture

button or select New Texture from the
button.

4. Browse for your bitmap texture file.

The file must be a TGA or PSD. Your texture MUST HAVE an alpha channel.

5. Click Open.
The imported texture is saved in your scene texture list.

6. In the Pencil Properties editor, select your new texture.
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7. In the Tool Properties view, click the Texture menu and select Rename Texture.
The Rename Opacity Texture dialog box opens.

8. In the Name field, type the template name and click OK.
9. In the Drawing view, draw your pencil lines.

How to add a texture to your preferences
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the arrow button beside the stroke preview area.

3. In the Pencil Properties property editor, select a texture from the Textures area to add to your
preferences.
4. Click the Copy to Preference

button.

How to apply a preset texture to a pencil line
1. In the Tools toolbar, select the Select

tool.

2. In the Drawing view, select a pencil line.
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3. In the Tool Properties view, select a texture from the Textures area to apply to the selected
stroke.

Drawing with the Brush Tool

The Brush tool is pressure sensitive and can create a contour shape which gives a thick and thin line
effect, as if the drawing was made with a paint brush.
With the Brush tool, you can draw as vector or bitmap, depending on your preference. When you add
your drawing layer, you can simply select the vector or bitmap option. If you use vector, you will be
able to enlarge your drawing and zoom into it without losing quality or resolution. You can also use
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the Contour Editor and Select tools to resize and modify lines. If you draw with bitmap, you will not be
able to scale your drawing beyond 100% of its resolution without encountering pixelization issues.
You can create your own brush styles. A variety of brush styles are provided allowing you to create and
save your own.This way you can create brushes with precise sizes and parameters and save them so
you can draw and design. Renaming a brush can make it easier to identify and access the brushes you
use most frequently.
A dynamic brush can be created for drawing using patterns created from your artwork. Create a new
dynamic brush to copy a pattern you have drawn to reproduce it quickly. You can create dynamic
brushes using a single or multiple patterns that will automatically switch through the patterns as you
draw.

To draw with the Brush tool
1. In the Timeline or Xsheet view, select the cell on which you want to draw.
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. In the Colour view, click a colour swatch to select a colour.

4. In the Drawing view, start drawing.
‣

Hold Ctrl (Windows/Linux) or ⌘ (Mac OS X) to force a line to join the start and end of the
shape while drawing.

The last colour you select while using the Brush tool is recalled the next time you select the Brush tool.
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How to select a brush style
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties, select a brush style from the Brush Presets section.

How to modify the brush settings
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Tip Shape

Texture

Lets you select a tip shape from round and square ones to
star shaped.

See How to draw with textured lines on page 95
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How to create a brush preset
1. Make sure your current brush has the settings you want in the preset you are will create.
2. Do one of the following:
‣

In the Brush view, click the New Brush

‣

From the Brush

‣

In the Properties window of the tool you are using, click the
corner.

button.

menu, select New Brush Preset.
button in the upper-left

3. In the New Preset window, type a name for your new brush preset.
The new brush is added to the end of the list of brush preset.

Brush presets cannot be updated. However you can select a preset, which applies those properties to the
current brush. Then you can modify the properties, and create a new preset with the new properties. If
desired, you can delete the old preset.

How to rename a brush
1. In the Tool Properties view, select a brush to rename.
2. From the Brush

menu, select Rename Brush.

3. Type in a new name for the brush.

How to delete a brush preset
1. Select the brush preset you want to delete.
2. Do one of the following:
‣

In the Brush Preset view, click the Delete Brush

‣

From the Brush Preset

button.

menu , select Delete Brush.

How to create a new dynamic brush
1. In the Tools toolbar, select a drawing tool.
2. In the Camera view, draw the pattern you want to use as your dynamic brush stamp.

3. In the Tools toolbar, click the Select
repeat.

tool and select the parts of the drawing you want to
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4. In the Tools toolbar, select the Brush

tool or press Alt + B.

5. In the Tool Properties view, click the Add Dynamic Brush
dynamic brush preset.
6. From the Brush

button to add your selection as a new

menu, select Rename Brush.

The Rename Preset dialog box opens.
7. Type in a name for the new dynamic brush and click OK.
8. In the Drawing view, start drawing with your dynamic brush to quickly repeat a pattern.

9. To adjust the scale of your pattern to make it bigger or smaller as you stamp it, adjust the
Maximum Size value in the Tool Properties view.

How to create a dynamic brush with multiple drawings
10. In the Drawing view, draw your pattern.
11. In the Tools toolbar, select the Select

tool.

12. In the Camera view, select all the drawings you want to add to your new dynamic brush.
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13. In the Tools toolbar, select the Brush
14. Click the Add Dynamic Brush

Drawing Tasks

tool or press Alt + B.

button to add your selection as a new Dynamic Brush preset.

15. From the Brush menu, select Rename Brush.
The Rename Preset dialog box opens.
16. Type in a name for the new dynamic brush and click OK.
17. In the Drawing view, start drawing with your dynamic brush to quickly repeat a pattern. When you
use this brush, you will cycle through the drawings.

Drawing with Textured Brushes
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In Harmony, you can use the Brush

tool to draw with bitmap textured lines.

In the Brush Tool Properties view, you will find a series of default textured brushes, but you can also
create your own collection by importing PSD or TGA files in the Preset list.
To create your own texture brush, you must prepare your texture file in a third-party software, such as
Adobe Photoshop. If your image has transparency in it, it will be supported. The texture file must be
either a PSD or TGA file. It is recommended that you maintain your texture resolution between 100 x
100 pixels and 400 x 400 pixels.
When you use the Eraser tool to erase a portion of a textured line, the vector frame is cut straight and
you lose the feather created while drawing with the Brush tool. In Harmony, a special option in the
Eraser tool lets you create a soft edge on your textured lines. You can also cut or keep the vector
frame as is.
Sometimes you need to hide the line texture to see the complete vector frame around your lines. This
is useful to help you see any dirt floating around your drawing.
At some point, you may want to modify the look of a textured drawing. Maybe you find that your line
is too smooth or too faint. You can adjust those parameters by using the Adjust Line Texture Opacity
command.
To draw with textured lines, use the Brush tool and the correct pen in the list. You can also draw with
pencil line texture—see Pencil Line Texture on page 85

How to draw with textured lines
1. In the Tools toolbar, select the Brush

tool or press Alt + B.

2. In the Tool Properties view, select a brush and click the Arrow button to open the Brush Properties
view.

3. In the Texture section, select the Select Texture option.
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4. Set the following parameters:
‣

Hardness: The hardness value corresponds to the smoothness of the line edge. The lower
the value, the more blurry and smooth the line edge will be. The higher the value, the
sharper the line edge will be.

‣

Minimum Opacity: This value corresponds to the transparency of the brush when the
pressure is very light. Values closer to 0 produce a more transparent line.

‣

Maximum Opacity: This value corresponds to the transparency of the brush when the
pressure is heavy. Values closer to 1 produce a more opaque line.

‣

Select Texture: Lets you use and select a texture for your brush. The thumbnail displays the
current texture. You can also browse for a texture file to import. Browsing for a texture file
in a brush already using texture will replace the file currently in use, although it will not
replace the texture in the lines already drawn. If your image has transparency in it, it will be
supported. The texture file must be either a PSD or TGA file. It is recommended that you
maintain your texture resolution between 100 x 100 pixels and 400 x 400 pixels.
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‣

Texture Scale: Changes the size of the texture in the lines you draw. If you are using a plaid
texture, the squares will be larger if you increase the value and smaller if you decrease it.

5. In the Drawing view, start drawing.

How to erase textured lines
1. In the Tools toolbar, select the Eraser

tool, press Alt + E.

2. In the Tool Properties view, click the arrow button.

The Brush Properties window opens.
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3. Adjust the following:
‣

Maximum/Minimum Size: Defines the minimum and maximum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

‣

Contour Smoothing: Defines the number of control points added to the contour
boundaries (around the line). Lower values mean that the line will appear as you draw it
(with more control points added along the centre line). Higher values mean that the line will
be smoothed out (removing control points from the centre line).

‣

Tip Shape: Lets you select a shape for the tip of the eraser. There are a variety of tips to
choose from: round, square, oval, star-shaped, and more. This option is only available when
the textured tip is not in use.

‣

Soft Tip: Gives the tip of your stroke a soft edge.

‣

Keep Vectors: Keeps your vector frames and does not cut them.

‣

Hardness: The smoothness of the line edge. The lower the value, the more blurry and
smooth the line edge will be. The higher the value, the sharper the line edge will be.

‣

Saturation: The intensity of line colour.

‣

Maximum Opacity: The transparency of the brush when the pressure is heavy. Values closer
to 1 produce a more opaque line.

‣

Minimum Opacity: The transparency of the brush when the pressure is very light. Values
closer to 0 produce a more transparent line.
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4. In the Drawing view, erase your textures lines.

How to adjust the line texture opacity
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Drawing view menu, select Drawing > Adjust Line Texture Opacity.
The Adjust Line Texture Opacity dialog box opens.

3. Drag the sliders toward the middle to increase the contrast and opacity of the textured lines.
4. If you want to apply the changes to all drawings exposed on the layer, select the Apply to All
Drawings option and click OK.
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Drawing with Bitmap Brushes

With Harmony, you have the choice to draw with vector or bitmap brushes. When adding a new
drawing layer in Harmony Stage, Harmony Sketch or Harmony Draw, you can set your art layers (Line,
Art, Colour Art) to vector or bitmap. This way, you can draw in bitmap and paint in vector, draw
everything in bitmap, or whatever other combination suits you.
Not all drawing tools are available when working on a bitmap layer. You can use the following tools:
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•

Brush

•

Cutter

•

Dropper

•

Ellipse

•

Eraser

•

Line

•

Paint

•

Paint Unpainted

•

Pivot

•

Rectangle

•

Repaint

•

Reposition All Drawings

•

Select

•

Text

•

Unpaint

In Harmony Stage, Harmony Sketch or Harmony Draw, when adding a new drawing layer to the
Timeline view, you can select the art mode for each art layer. You can set the Line Art layer to vector
while setting the Colour Art as bitmap. You also have the opportunity to adjust them later by
converting them from one to the other. If you are using the Overlay and Underlay layers, you can also
set them to either bitmap or vector.
If you selected the incorrect art mode for your layers, you can open the Layer Properties view and
modify them there directly. If you switch the art mode for a layer that already has strokes on it, the
artwork will NOT be converted. You will be able to add new strokes. A drawing with bitmap strokes
will be converted to a vector layer but the bitmap artwork will remain as bitmap. You will be able to
use vector drawing tools to continue drawing on it. A drawing with vector lines switched to a bitmap
layer will allow you to draw new bitmap strokes and move the vector strokes with the Select tool, but
you will not be able to edit the vector art further. You need to convert the drawings in order to pass
the artwork from one mode to the other.
To always reuse the same art mode settings, you can adjust them in the Preferences dialog box.
Before you start drawing in bitmap, it is important to understand that your artwork will now be
resolution dependent. If you zoom in your scene, you artwork will be enlarged. It is important to plan
ahead and decide how high of a resolution you need your artwork to be. If you plan to zoom in your
scene, the smallest section of the image that the camera will frame must be 100% the size of your
scene resolution. For example, if your scene resolution is set to 1920 x 1080 and you zoom in at 300%,
then the resolution of the bitmap also has to be set to 300%. It is important to change the bitmap
layer resolution before you start drawing.
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The bitmap resolution can be set at the scene level or drawing level. The setting at the scene level
affects newly created bitmap art layers.
Note that even if your drawing resolution is set to be very large, it doesn't mean that your file will be
very heavy. It depends on the amount of artwork your draw in it.

There is a function to change the resolution of bitmap art for individual drawings. You can reduce the
resolution of your bitmap file as well as increase it. Be careful because enlarging the bitmap resolution
on an existing drawing will result in a loss of quality.Harmony will perform a pixel smoothing pass
(resampling) and create additional pixels to avoid losing too much quality, but only to a certain extent.
For example, you used the default scene’s resolution for bitmap art but then discover you are zooming
quite close into the lines. If you do not want to see the pixels appear too much when you are zoomed
in, you can set the bitmap resolution to 200% and the bitmap art will have a higher resolution with
smaller pixels, but will NOT retain 100% of its quality. You can use this function on multiple drawings
using the Apply to All Drawings option. Changing this option will affect existing and selected bitmap
art layers.
If you drew an outline drawing on a bitmap layer, you can vectorize your artwork. Using a vector
drawing layer, you can simply select your bitmap drawing and the vector cell on which you want your
new vector layer to be, and use the Vectorize Line Art in Selected Drawing function.
You should avoid scaling up your bitmap strokes using the Select tool. If you do, keep in mind that
when you continue drawing, your image will be resampled and your new strokes will be at the original
resolution and not the scaled up size.
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Your drawing should be scaled up using the Transform
very large bitmap layers.

tool instead of the Select tool to avoid creating

How to change the bitmap resolution at the drawing level
1. In the Drawing Thumbnails panel, select a bitmap drawing.

Note that the drawing can be enlarged slightly and retain its original look, but you may lose quality if you
enlarge it too much. Pixels are created and a smoothing pass is applied. You should set your resolution
before drawing. If you need to change the resolution of a drawing to be larger than the one set in the
Scene Settings dialog box, create an empty drawing first and then follow this procedure.

2. From the top menu, select Drawing > Change Bitmap Drawing Resolution.
The Change Bitmap Drawing Resolution window opens.

Parameter

Description
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Scene Resolution

This is the scene resolution preset name and size in pixel.

Width

This is the width of the resolution for the bitmap that will be created.
This is not the actual size of the bitmap. TVG drawings (Toon Boom
drawing native format) have an infinite size. Bitmap TVGs are composed
of small tiles. Therefore it does not mean that because you have artwork at the four corners of your camera frame or even quite far outside
of your drawing that your bitmap image will be very large and heavy. By
default, it is set to the same width as the scene resolution.

Height

This is the height of the resolution for the bitmap that will be created.
By default, it is set to the same height as the scene resolution.

Resolution Factor

This is the size of the bitmap resolution in relation to the scene resolution. If you increase the percentage, the width and height fields will
increase accordingly. If you plan to animate the camera and zoom into
your background, you will need to set a higher resolution so that the
smaller area in which you will zoom will be 100% of the scene resolution.

Resample Bitmap

When this option is selected, the existing bitmap image is
modified to match the new resolution. If the width and height
are increased, more pixels will be created to enlarge the
image. Visually, the existing artwork will look the same,
maybe a little bit smoothed out, but the size will look the
same. When this option is deselected, the artwork is not
modified. Only the reference grid is resized. If the scene
resolution is 1920 x 1080 and you reduce the bitmap
resolution to 960 x 540, the image will be scaled up to twice
the size of the scene.

Apply to All Drawings

The modified settings are applied to all drawings in the drawing layer
for a given art layer. If the Apply to Line Art and Colour Art option is
enabled, it will then be applied to all bitmap art layers.

3. Change the bitmap resolution.
4. Click OK.

How to draw with bitmap brushes
1. In the Drawing Thumbnails panel, select a bitmap drawing.
2. In the Tools toolbar, select the Brush

tool or press Alt + B.

3. In the Colour view, select a colour.
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‣

To switch the bitmap colour picker from HSV to RGB, in the Colour view menu, select
Colour > Bitmap Colour Sliders > HSV Sliders or RGB Sliders. You can also right-click on
the colour sliders and select RGB Sliders or HSV Sliders.

When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.
4. In the Drawing view, start drawing.

Viewing the Final Lines as You Draw
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Everything you draw in Harmony is vector-based, unless you purposely elected to draw as bitmap.
Although, when you draw in the Drawing or Camera view, notice that your lines may appear jagged.
This is caused by the fast real-time display called OpenGL. If you prefer to see smooth lines as you
draw, you can enable the antialiasing preference.

Real-time Antialiasing

It is highly recommended that you use Full Scene Antialiasing. The Real-time Antialiasing method is NOT
RECOMMENDED as it is heavier to run than the Full Scene Antialiasing.

Real-time Antialiasing is generated by . This means that when you draw your lines, the preview
becomes antialiased as you go. If you zoom in more than 100% in the Camera view, pixels will start to
appear. Your elements are still fully vector based. Only the preview becomes pixelated. Your drawings
are antialiased to the scene’s resolution.
Antialiasing is a preference you can turn on and off; by default, it is disabled.
This option lets you see the final result of your scene as you draw. You can change the value of the
antialiasing, through the Preferences dialog box, to fit to the current zoom level used in the Camera or
Drawing view or disable it.

Real-time Antialiasing parameters are only valid while you work in your scene. The scene will be rendered to
100% of its resolution regardless of your preference settings.

To customize the antialiasing parameters:
1. Select Edit > Preferences (Windows/Linux) or Stage > Preferences (Mac OS X).
The Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).
The Preferences dialog box opens.
2. In the OpenGL tab, go to the Real-Time Antialiasing section.

‣

Enable: Click on the Enable check box to enable or disable the Real-Time Antialiasing.
Press Ctrl + Alt + A (Windows/Linux) or ⌘ + Alt + A (Mac OS X).

‣

Render at this Factor Times the Scene Resolution: The default value is 1. This value
corresponds to how many times larger than the scene’s resolution you want your drawings
to be antialiased. If you zoom into your drawings to 200% you should set the value to 2.

‣

Tile Size: When the drawing is antialiased, the whole is broken into small tiles to make the
process faster. Only the tiles with artwork on are rendered out. When you modify a zone on
your drawing, only the modified tiles are updated.
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•

Making the tiles too small results in sending more tiles to be rendered out, which makes the
process longer.

•

Making the tiles too large results in sending bigger tiles out to be rendered out which is more of
a strain on the video card. Since the tiles are larger, they get updated more often because the
artwork you modify may be one of these tiles.

Selecting the Current Colour of a Tool

While drawing and painting, you can let Harmony retain the last colour you selected for each one of
the following tools:
•

Brush

•

Paint

•

Pencil, Ellipse, Line, Rectangle, Polyline

The Colour view has three swatches where you can set a colour for the Brush , Paint, and Pencil tools.

How to unlink the storage swatches
1. In the Colour view, if the storage swatches are linked, click the Link

2. Click on the Brush

storage swatch.
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3. In the Colour list, select the desired colour.
4. Click the Pencil

storage swatch.

5. In the Colour list, select a colour.
6. Click the Paint

storage swatch.

7. In the Colour list, select a colour.

If you prefer to have Toon Boom Harmony use the same colour swatches regardless of the selected tool,
you can link the three swatches together.

How to link the storage swatches
1. In the Tools toolbar, select one of the following tools:
‣

Brush

‣

Paint

‣

Pencil

‣

Polyline

‣

Line

‣

Ellipse
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‣

Rectangle

2. In the Colour view, if the storage swatches are unlinked, click the Link

button to link them.

Each time you select a new colour for your current tool, all the storage swatches are updated.

Using Independent Colours when Working with Bitmap Layers
When working in the Colour view, by default the current colour is active for both vector and bitmap
layers. You can however, use different reference colours for each layer.
When using bitmap colours, there is no longer a link between the painted zones and selected colour.
You can modify the colour picker as much as you want. Your drawing will not be affected. You can
still select colours from your vector colour palette to use the same tint, but you will not create links
between your drawing and the swatches.

How to use independent colours
‣

From the Colour view menu, select Colours > Independent Bitmap Colour.

Whichever colour you choose as the reference color is retained for that layer type.

Selecting Drawing Objects

The Select tool is used to select strokes in both the Drawing view, and apply basic transformations,
such as repositioning, rotating, scaling or skewing using the different handles of the bounding box.
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Sometimes, when you want to select multiple objects while leaving one unselected, it can be handy to
select only the stroke or line that you do not want included in your selection. Then, you can invert the
selection so that everything else becomes selected. This can be quite a time saver.
Some of the transformations, such as rotation, scale, skew, and flip are done relative to the position of
the pivot point. You can temporarily reposition this pivot point for a transformation using the Select
tool.

How to select with the Select tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Select

tool or press Alt + S.

3. In the Camera or Drawing view, select the drawing objects.
‣

You can select all the drawing objects in a drawing by using Edit > Select All or by pressing
Ctrl + A (Windows/Linux) or ⌘ + A (Mac OS X).

4. To deform or reposition a selection:
‣

To reposition, click the selected drawing object and drag the selection to a new area.

‣

To rotate, grab the selection box handle and rotate it.

‣

To scale, pull or push on the top, side, bottom or corner control point. Hold down Shift to
lock the selection’s ratio.
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‣

To skew, drag sideways or up and down the sides or top and bottom segments, between
the control points.

How to invert a selection
1. From the top menu, select Edit > Invert Selection or press Ctrl + Shift + I (Windows/Linux) or ⌘ +
Shift + I (Mac OS X).

How to temporarily reposition the pivot point
1. In the Drawing view, select the drawing object you want to transform.
The pivot point appears in the middle of your selection.

2. Click the pivot point and drag it to a new position.
This becomes the new position of the pivot point for the current transformation and will remain
there until you make a new selection.
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Erasing Parts of a Drawing

The Eraser tool is pressure sensitive, like the Brush tool, giving you more precision when erasing parts
of a drawing. You can also use the Select tool to select drawing objects and delete them instead of
erasing.

How to erase with the Eraser tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Eraser

tool or press Alt + E.

3. In the Drawing view, start erasing.

How to modify the eraser settings
1. In the Tools toolbar, select the Eraser

tool .

2. In the Tool Properties view, the preview area displays the stroke that will be produced after you
customize the different parameters in the Tool Properties view. Click the arrow button.

The Brush Properties window opens.
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This is where you set the minimum and maximum sizes of your drawing tool which will produce
the thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
Parameter

Description

Maximum Size

Sets the maximum width of the line.

Minimum Size

Sets the minimum width of the line in relation to the maximum size.

Smoothness

Lets you modify the central line smoothness of the line. This parameter
smooths the initial movement of your line. Increasing the value will result
in a smoother line with fewer control points.

Contour Smoothness

Optimizes the contour line smoothness of the line. This parameter will
smooth the contour of the line once it has been traced; the higher the
value, the fewer control points will compose your line.

Tip Shape

Texture

Lets you select a tip shape from round and square ones to
star shaped.

See How to draw with textured lines on page 95
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Reshaping a Drawing Using the Contour Editor Tool

The Contour Editor tool is a powerful tool that allows you to add, remove or modify points on a
vector line and control them with Bezier handles. It is used to correct line shapes and modify a single
part of a colour zone. If a line is too thin or has a gap in it, you can modify and correct it with the
Contour Editor tool. You can also use this tool to create elaborate shapes.
The Contour Editor displays vector points around a shape and the central vector points in a pencil line.
Pulling or pushing on these points adjusts the brush’s line thickness. Points can be selected and
deleted. Each point has two Bezier handles for correcting the curves between two points. Shapes can
be modified by pulling and pushing directly on the segment between the points. You can use it to
perfect a central shape pencil line, a contour shape brush line, or even create an elaborate shape from
a basic ellipse or square.

How to reshape with the Contour Editor tool
1. Select a drawing from the Drawing Thumbnails panel.
.

2. In the Tools toolbar, select a shape tool:
3. In the Tool Properties view, click the Ellipse
pencil size to 0.

button, click the Auto Fill

4. In the Drawing view, draw a circle.

5. In the Tools toolbar, select the Contour Editor
6. In the Drawing view, click the line to reshape it.
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7. Select one or several points by clicking on them or circling around.

8. Press Delete to delete a selected point.
Press Ctrl (Windows/Linux) or ⌘ (Mac OS X)and click on the contour to add a new point to adjust
the contour.
9. To modify the shape, you can:
‣

Pull on the Bezier handle. Both point’s handles will move as one.

‣

Hold down Alt and pull on one of the Bezier handles. The point’s handle will move
independently from the other one.

‣

Move the selected points to a new area.

‣

Pull directly on the line between two points. No selection is necessary. Holding down Shift
will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier handles, hold down the Alt key to display them.

‣

To add control points, press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the line.

115

Chapter 6: Character, Prop and Location Design

‣

Drawing Tasks

To remove control points, select the control point and press Delete.

Reshaping Pencil Lines with the Pencil Editor Tool

The Pencil Editor tool is used to modify the thick and thin contour of a pencil line. A pencil line is a central vector
shape. The shape control points are located all along the central spine allowing you to adjust the stroke curve
and position. When using the Contour Editor tool, you can reposition the spine of the stroke. When using the
Pencil Editor tool, you can adjust the thick and thin areas of lines.

How to use the Pencil Editor tool
1. In the Tools toolbar, select the Pencil Editor

tool or press Alt + W.

2. In the Drawing view, select a pencil line and click the line to reshape it.

3. Select one or several points by clicking them or circling around.
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4. Press Delete to delete a selected point.
5. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click the central spine to add a set of points to
adjust the contour.
6. To modify the shape, you can:
‣

Move the selected points to a new area. If you select matching points on each side of the
line, holding the Shift key will move them both. This way you can thicken or thin a line from
both sides at the same time.

‣

Pull on the Bezier handle to move both points’ handles as one.

‣

Hold down Alt and pull on one of the Bezier handles. It moves the handle independently
from the other one.
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‣

Pull directly on the line between two points. No selection is necessary. Holding down the
Shift key will limit the contour modification to the curve between the two first points.

‣

If an anchor point has no visible Bezier handle, hold down Alt to display them.

Drawing with Shapes

In Harmony, you can use the shape tools to draw circles, lines and squares. You can also easily reshape
a square or circle into a much more complex drawing such as these butterfly wings—see Reshaping a
Drawing Using the Contour Editor Tool on page 114 and Reshaping Pencil Lines with the Pencil Editor
Tool on page 116.

How to draw with a Shape tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select a shape tool:

.

3. To automatically fill the shape, in the Tool Properties view, select the Auto Fill
4. In the DrawingCamera view, click and drag to draw the shape.
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‣

Hold down Shift to lock the rectangle or the ellipse ratio to 1:1.

‣

Hold down Alt to draw the rectangle or ellipse from its centre.

‣

Hold down Shift to snap the line every 15 degrees.

‣

Hold down Alt to snap the start or end of the line to a nearby stroke.

5. Use the Contour Editor

tool to deform the shape and create your drawing.

Drawing with the Polyline Tool

The Polyline tool is used to draw shapes with a central vector type of line. To form a shape, you click to
add a point and then, without releasing the mouse, pull the handle in the desired direction before
adding the next point and repeat the operation. To edit the shape, you can use the Contour Editor
tool.

How to draw with the Polyline tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Polyline

tool or press Alt + _.
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3. In the Drawing view, click and drag to create a point and a Bezier handle to shape your line.
‣

Press Alt to pull only one handle, instead of two.

‣

Press Shift to snap the handles to 45, 90, or 180 degrees.

4. Click a new area and drag to create a second point and Bezier handle.

5. Repeat the previous step until your shape is completed.
6. Press Ctrl (Windows/Linux) or ⌘ (Mac OS X) and click to release the Polyline tool from the current
path or shape that it is creating. Continue to use the tool to make multiple, independent paths or
shapes.
7. If necessary, reshape the lines using the Contour Editor
the Contour Editor Tool on page 114.

tool—see Reshaping a Drawing Using

Drawing with Invisible Lines

There are two different ways to draw invisible lines.
Using the Pencil tool, you can draw as strokes only, meaning that the line will be invisible. This can be
useful for drawing tones and highlights directly on the character.
The Stroke tool draws invisible lines only. You cannot add thickness to the line, unlike the Close Gap
tool that creates a short, straight line between two points. The stroke line will stay exactly where you
draw it. This tool can be useful for closing a zone in a particular way or creating some hard shadows or
highlight areas.
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Sometimes, it may be difficult to see your strokes, especially if your colours are similar to the blue
stroke colour. In Harmony, you can display the strokes and washed-out the colours of your drawings
so that the invisible lines stand out.

How to draw invisible lines with the Pencil tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar, select the Pencil

tool or press Alt + /.

3. From the top menu, select View > Show Strokes

or press K.

4. In the Tool Properties view, set the Pen Style size to 0. You can also adjust the smoothness.
5. In the Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.

Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to draw invisible lines with the Stroke tool
1. Select a drawing from the Drawing Thumbnails panel.
2. In the Tools toolbar from the Paint drop-down menu, select the Stroke
3. From the top menu, select View > Show Strokes

tool or press Alt + V.

or press K.

4. In the Tool Properties view, you can adjust the smoothness.
5. In the Drawing view, start drawing.
If you forgot to enable the Show Strokes option before drawing, as soon as you draw a first
stroke, a Message dialog box opens.
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Select the Don’t Show This Message Again option if you do not want the dialog box to notify you
about the Show Strokes option.
6. Click OK.
7. You can modify the stroke shape with the Contour Editor

tool.

How to show the strokes with washed-out colours
‣ From the top menu, select View > Show Stroke With Colour Wash.

Deforming a Drawing with the Perspective Tool

The Perspective tool lets you deform a drawing selection and alter its perspective.

How to deform a drawing with the Perspective tool
1. In the Tools toolbar, select the Perspective
press Alt + 0.

tool from the Contour Editor drop-down menu or

2. In the Drawing view, select a drawing to deform.
3. Click and drag the different anchor points to deform the shape.
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Warping a Drawing with the Envelope Tool

The Envelope tool lets you deform and warp part of a drawing using a grid envelope and Bezier
handles.

How to warp a drawing with the Envelope tool
1. In the Tools toolbar, select the Envelope

tool from the Contour Editor drop-down menu.

2. Select a drawing from the Drawing Thumbnails panel.
3. In the Drawing view, select the region you want to deform
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4. Click and drag the different anchor points and handles to deform the image.

5. To display more controls, in the Tool Properties view, click the Show Advanced Controls
button.

6. Increase the height and width of the grid to get more control points to deform your image.
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Cutting Drawing Parts

The Cutter tool lets you cut a drawing area to move, copy, cut or delete it.

How to cut with the Cutter tool
1. In the Tools toolbar, select the Cutter

tool or press Alt + T.

2. In the Drawing view, make a selection around an area to cut away.
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‣

To delete the selected zone, press Delete.

‣

To move the selection, click the selection and drag it to a new area.

‣

Use the bounding box controls to scale, skew, or rotate the cut piece.

Smoothing Lines

When drawing in a digital application, it is not like drawing on a sheet of paper. Sometimes the lines
you draw may look as if they were drawn with an unsteady hand. When this occurs, you may need to
correct the look of your lines.
Harmony has a very powerful tool you can use to optimize contours and reduce the number of points
on the lines, the Smooth Editor tool.

How to optimize lines with the Smooth Editor tool
1. In the Tools toolbar, select the Smooth Editor

tool or select Tools > Smooth Editor.

2. In the Drawing view, place your pointer over the lines to smooth. You may need to pass over the
same line several times to remove more points and make the line smoother. Note that by default,
the Smooth Editor tool colour is yellow, it was changed to orange for screen grab clarity—see
Smooth Editor Tool Options on page 170 to learn about the various settings available.
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Working With Text

With the Text tool, you can type text in your project using various fonts and texts attributes. Text
objects are part of a drawing, so you can manipulate them in the same way. OTF fonts are also
supported.

How to add text to drawings
1. Do one of the following:
‣

In the Tools toolbar, select the Text

‣

From the top menu, select Tools > Text.

‣

Press Alt + 9.

tool.

2. In the Timeline view, select the cell containing the drawing on which you want to add text.
3. In the Drawing view, click on the location you want the text to begin.

4. You can use the Tool Properties view to select the font, font size and format of the text you will
type—see Text Tool Options on page 172.
5. Type in the desired text.

6. Click outside the text box to exit the typing mode.
If you want to create another text object, click outside the currently active text box. You can always
return to edit the text by selecting the Text
tool and clicking in the text.

More Drawing Tools
Harmony offers a wide variety of useful tools to optimize your drawings and work more efficiently;
tools such as Group, Arrange, and the animation disk to rotate your workspace.
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•

Arrange below

•

Convert Brush Strokes to Pencil Lines on the facing page

•

Pencil Lines to Brush Strokes on the facing page

•

Strokes to Pencil Lines on page 130

•

Optimize on page 130

•

Remove Extra Strokes on page 130

•

Create Contour Stroke on page 131

•

Remove Contour Stroke on page 131

•

Grid on page 132

•

Group/Ungroup on page 132

•

Hand on page 132

•

Rotate View on page 133

Arrange
The different Arrange options let you reorder drawing objects inside a single layer in the Drawing or
Camera view.
Name

Bring to Front

Bring Forward

Send Backward

Button

Description

Moves the selected art to the front
(on top)

Moves the selected art one level forward (closer to the front)

Moves the selected art one level
lower (behind)
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Access Method
From the top menu,
select Selected >
Arrange > Bring to
Front.
Press Ctrl + Shift +
PgUp
(Windows/Linux) or
⌘ + Shift + PgUp
(Mac OS X).
From the top menu,
select Selected >
Arrange > Bring
Forward.
Press Ctrl + PgUp
(Windows/Linux) or
⌘ + PgUp (Mac OS
X).
From the top menu,
select Selected >
Arrange > Send
Backward.
Press Ctrl + PgDown
(Windows/Linux) or
⌘ + PgDown (Mac
OS X).
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Send to Back

Moves the selected art
behind everything (bottom
/ back)

From the top menu,
select Selected >
Arrange > Send to
Back.
Press Ctrl + Shift +
PgDown
(Windows/Linux) or
⌘ + Shift + PgDown
(Mac OS X).

Convert Brush Strokes to Pencil Lines

The Brushes Strokes to Pencil Lines operation converts selected contour strokes into centreline pencil
strokes. This command is only available from the top menu.

How to convert brush strokes to pencil lines
‣

From the top menu, select Selected > Convert > Brush Strokes to Pencil Lines or press ^.

‣

Right-click on the selection, select Convert > Brush Strokes to Pencil Lines or press ^

Pencil Lines to Brush Strokes

The Pencil Lines to Brush Strokes operation converts the selected centreline pencil strokes into
contour strokes brush lines.

How to convert pencil lines to brush strokes
‣

From the top menu, select Selected > Convert > Pencil Lines to Brush Strokes or press &.

‣

Right-click on the selection, select Convert > Pencil Lines to Brush Strokes or press &

129

Chapter 6: Character, Prop and Location Design

Drawing Tasks

Strokes to Pencil Lines

The Strokes to Pencil Lines operation converts the selected invisible line to a pencil line.

How to convert strokes to pencil lines
‣

From the top menu, select Selected > Convert > Strokes to Pencil Lines or press Shift +
F12 (Windows/Linux only).

‣

Right-click on the selection, select Convert > Strokes to Pencil Lines or press Shift + F12
(Windows/Linux only)

Optimize

The Optimize command reduces the number of layers, such as overlapping brush strokes, in the
selected drawing objects. Drawing objects will only be flattened and optimized if the selected objects
do not change the appearance of the final image when they are merged.
For example, if you have selected a number of partially transparent objects, which you layered to
create an additive colour effect, the selected transparent drawing objects will not be merged. This is
because merging the transparent drawing objects will cause them to lose the effect of the layered
transparent colours.

How to optimize
‣

Use the Select tool to select the drawing objects you want to optimize.

‣

From the top menu, select Selected > Optimize.

Remove Extra Strokes
The Remove Extra Strokes option let you remove the invisible lines in your selection.
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How to remove extra strokes
1. In the Tools toolbar, select the Select tool.
2. In the Drawing view, use the Select tool to select the drawing objects you want to remove invisible
lines from.
3. From the top menu, select Selected > Flatten and Remove Extra Strokes.

Create Contour Stroke

The Create Contour Stroke
option is used to add a permanent invisible line around a shape that
was drawn directly in Harmony. This allows you to unpaint your lines with the Paint
tool but
maintain the shape of the lines, should you need to repaint later.
This command is useful when inking and painting and using the Apply to All Drawings in Layer
option.

How to create contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Drawing view, use the Select tool to select the drawing objects you want to create contour
strokes for.
3. From the top menu, select Selected > Create Contour Strokes.

Remove Contour Stroke
The Remove Contour Stroke option is used to remove any permanently invisible lines that were
created while scanning and vectorizing drawings or manually adding contour strokes. This is useful if
you want to remove the intersection triangles created during vectorization.

How to remove contour strokes
1. In the Tools toolbar, select the Select tool.
2. In the Drawing view, use the Select tool to select the drawing objects you want to remove contour
strokes for.
3. From the top menu, select Selected > Remove Contour Strokes.
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Grid

Use the Show Grid option to display a grid in the Drawing view.
Name

Show
Grid

Button

Description

Displays the grid

Keyboard Shortcut
From the top menu,
select View > Grid >
Show Grid
Press Ctrl + '
(Windows/Linux) or
⌘ + ' (Mac OS X).

Square

Displays a standard square grid

From the top menu,
select View > Grid >
Square.

12 Field Grid

Displays a 12-field size grid

From the top menu,
select View > Grid >
12 Field Grid.

16 Field Grid

Displays a 16-field size grid

From the top menu,
select View > Grid >
16 Field Grid.

Underlay

Displays the grid under the drawing
elements

From the top menu, select View
> Grid > Underlay

Overlay

Displays the grid over the drawing
elements

From the top menu, select View
> Grid > Overlay

Group/Ungroup
Use the Group option to group selected drawing objects. This can help in the selection, repositioning,
re-scaling and other transformations to be applied to multiple objects of a drawing.
•

From the top menu, select Selected> Group > Group or Selected > Group > Ungroup.

•

Press Ctrl + G and Ctrl + Shift + G (Windows/Linux) or ⌘ + G and ⌘ + Shift + G (Mac OS X).

Hand
Use the Hand tool to pan through the Drawing view.
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•

In the Tools toolbar, select the Hand

tool, click in the Drawing view and drag.

•

You can also Hold down the Spacebar, click in the Drawing view and move your mouse in the
direction you want to pan the view.

Rotate View
The Rotate View
tool lets you rotate the Drawing view, the same way as you would do with a real
animation disc. This tool can also be used in the Perspective view.

How to use the Rotate View tool
1. Do one of the following:
‣

From the top menu, select Tools > Rotate View.

‣

Press Ctrl + Alt (Windows/Linux) or ⌘ + Alt (Mac OS X).

‣

In the Tools toolbar, select the Rotate View

‣

In the Drawing view, right-click and select Drawing Tools > Rotate View.

tool.

2. In the Drawing view, click and drag to rotate the space.
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Drawing Tool References
Harmony has a wide variety of drawing tools and each one of them has a series of options and modes
available. This section covers these options. For details on how to use these tools, see Drawing Tasks
on page 79.
•

Pencil Tool Options below

•

Brush Tool Options on page 139

•

Select Tool Options on page 141

•

Eraser Tool Options on page 150

•

Contour Editor Options on page 151

•

Pencil Editor Options on page 154

•

Shape Tool Options on page 157

•

Polyline Tool Options on page 162

•

Stroke Tool Options on page 163

•

Perspective Tool Options on page 164

•

Envelope Tool Options on page 165

•

Cutter Tool Options on page 168

•

Smooth Editor Tool Options on page 170

•

Text Tool Options on page 172

•

Drawing Pivot Tool on page 175

Pencil Tool Options
When you select the Pencil

tool, its properties and options appears in the Tool Properties view.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style
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You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Thickness Stencils
Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 82 and Pencil Line Texture on
page 85.

Pencil Line Texture
You can apply a bitmap texture on your pencil line and adjust it as needed—see Pencil Line Texture
on page 85

Draw Behind

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.
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Auto-Flatten Mode
When drawing on vector layers, lines do not usually become one object. The Auto-Flatten
mode
automatically merges lines created with the existing ones into one single object as you draw.
When drawing on a bitmap layer, you are laying down the bare pixels, so they are always flattened.
You can no longer access the individual stroke after you draw it.

Using the Select tool, you can use the middle mouse button to select a segment of a
flattened pencil line to create a nice finish on the lines and corners of your artwork.

Auto-Close Gap

When using the pencil tool, you can automatically close strokes with an invisible stroke.
It is recommended to keep this option enabled when drawing with the Pencil tool.

Line Building Mode

The Line Building
mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tips are merge into one single stroke.
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This mode only works with pencil lines.

Auto Adjust Thickness

The Auto Adjust Thickness
tool is useful when you want to render a portion of a line thicker.
When tracing a drawing on paper, you will often go back to a section of a curve to make it thicker to
add dynamism to the line. Using the Auto Adjust Thickness tool, you can draw highlight strokes over
the section to make thicker. Once you release the pen or mouse, the line becomes thicker following
the shape and curve of the original stroke. This way is much faster and smoother than using the
Pencil Editor tool. You do not have to add extra points and adjust the position and Bezier handles.
The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

How to change the Auto Adjust Thickness Colour
1. In the Tools toolbar, select the Pencil

tool.

2. In the Tool Properties view, click the Auto Adjust Thickness

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Line Pushing Mode
The Line Pushing Mode
option lets you draw highlight strokes over existing pencil lines. You can
reshape the curves. Depending how you draw the pushing stroke over your line, the highlighted
section will be reshaped in one direction or the other.
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The default overlay colour is light yellow. If this colour is difficult to see because of the background or
drawing colour, you can adjust the colour.

To change the Line Pushing Mode colour
1. In the Tools toolbar, select the Pencil

tool.
2. In the Tool Properties view, select the Line Pushing Mode

button.

3. Click the colour swatch.

The Colour Picker window opens.
4. In the Colour Picker window, select a new colour.

Brush Tool Options
When you select the Brush

tool, its properties and options appear in the Tool Properties view.

139

Chapter 6: Character, Prop and Location Design

Drawing Tool References

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Brush Presets
Brush presets are created by saving the properties of the current brush to a new preset, which you
can reuse for repeated tasks. You can create as many brush presets as you need—see Drawing with
the Brush Tool on page 88.

Draw Behind

When the Draw Behind
already exists.

mode is enabled, the lines you draw will appear behind the art that

Repaint Brush Mode

The Repaint Brush
is used to repaint zones that have already been painted, it will not affect
empty zones or pencil lines. It also automatically flattens each of its brush lines so it does not add
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new brush lines on top of existing ones. You can use this mode to paint tones or highlights onto your
character.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawingview. Brush strokes will flatten with brush strokes and pencil
lines will flatten with pencil lines.

Respect Protected Colour
The Respect Protected Colour
option prevent the colours you marked as protected in the
Colour view to be repainted using the Repaint Brush mode or any of the painting tools.

Use Stored Colour Gradient
The Use Stored Colour Gradient
option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Select Tool Options
When you choose the Select

tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso

and Marquee

options to change the selection style of the tool.
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Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
You can enable different snapping modes to help you when repositioning drawings using the Select
tool.
•

Snap to Contour: Snaps your selection or point to any line you position it on. As soon as you
move it close enough to another line, your point or selection will snap to it.

•

Snap and Align: Snaps the selected anchor point to any existing line while displaying
temporary rulers as a guide that you can also snap your anchor point to.
Snap to Grid: Snaps your selection following the currently enabled grid.

•

How to snap to grid
1. Do one of the following:
•

Select View > Grid > Show Grid to display the grid in the Camera or Drawing view or press
Ctrl + ' (Windows/Linux) or ⌘ + ' (Mac OS X).

•

Select View > Grid > Square Grid, 12 Field Grid or 16 Field Grid for your current needs.

2. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

3. In the Contour Editor Tool Properties view, click the Snap to Grid

button.

4. In the Camera or Drawing view, click on the anchor point you want to snap following the grid,
drag it to the desired position and release.
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Select by Colour

The Select by Colour mode lets you select all the zones in your drawing painted with the same
colour.

Only the zones painted with the SAME colour swatch will be selected. If another zone is coloured with the
exact same RGB value (same colour), but not painted with the same colour swatch, it will not be selected.

How to select areas by colour
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, click the Select by Colour

button.

3. In the Drawing view, click on any zone in your drawing.
All zones of the same colour are selected.
4. Click the Select tool again to return to the regular Select mode.

Permanent Selection

The Permanent Selection
option lets you maintain a selection over multiple drawings. Once this
option is enabled, the selection zone made using the Select tool will remain as you navigate through
drawings from a layer and drawings from other drawing layers. This option can be used to
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simultaneously delete artwork inside or outside of the selection on several drawings when combined
with the Apply to Multiple Drawings option.

Apply to All Drawings in Layer

The Apply to All Drawings in Layer
option is used to perform an action on all the drawings
contained in a layer. For example, you could enable the option to paint a section on all the drawings
simultaneously. The Apply Tool to All Drawings option must be activated before performing the
action and will stay enabled only for the next action.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Selected > Transform > Flip Horizontal and Flip Vertical.
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Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Selected > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Selected > Smooth or press Alt + Shift + S.
Flatten

The Flatten
operation is used to merge drawing objects and brush strokes into a single layer. If
you draw new lines to fix a drawing or line with many brush strokes, it can be useful to flatten them
all into a single shape. By default, lines are drawn one on top of each other. If you intend to repaint
the lines or modify their shape, it will be easier if they are flattened.

‣ From the top menu, select Selected > Flatten or pres Alt + Shift + F.
Create Colour Art from Line Art
You can use the outline you traced on one of the four embedded layers and create invisible strokes
to paint your drawings on separate layers. This provides more inking and painting flexibility.
You can also configure the option to create the invisible strokes on any of the four embedded layers.

How to create Colour Art zones out of the Line Art content
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Drawing view, select the artwork to transfer to the Colour Art.
3. In the Drawing View toolbar, click the Create Colour Art from Line Art button or press *.

145

Chapter 6: Character, Prop and Location Design

Drawing Tool References

How to configure the Create Colour Art from Line Art option
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Tool Properties view, Shift + click the Create Colour Art from Line Art

button.

The Configure Line Art to Colour Art dialog box opens.

Parameter

Description

Use rendered version of the
drawing

Renders the drawing and vectorize it to calculate the position of the
centreline that will produce the colour art stroke.

Maximum Resolution for
rendered image

The size of the rendered image.

Threshold for rendered image The value of grey processed to create the rendered vectorized arts.
Fitting error for rendered Bez- This value represents how precise the fitting of the colour art zone in
iers
relation to the line art will be.
Source layer

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay)
you want the colour art to be created from.

Destination layer

Lets you select the layer (Line Art, Colour Art, Underlay or Overlay)
you want the colour art to be created on.

Clear Destination Art Layer
First

Deletes the content before the colour art is added. This is
useful when you already have artwork on the destination
layer.

Perform Line Art to Colour
Art Operation Immediately

Performs the Create Colour Art from Line Art command when you
click OK.

Store Colour Gradient
Use the Store Colour Gradient
operation to record the selected gradient’s position. This reuses
the stored position of the gradient when drawing new brush lines or painting colour zones. Enable
the Use Stored Colour Gradient
option in the Paint or Brush Tool Properties view to do this.
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Pencil to Brush

The Pencil to Brush
strokes brush lines.

operation converts the selected centre line pencil strokes into contour

From the top menu, select Selected > Convert > Pencil Lines to Brush or press &.

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines
option. The ends of your lines
are adjusted to form one single line.

Points must be close enough to be merged. If there is a large gap between the lines, they will not be
merged.
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Reverse Pencil Thickness

The Reverse Pencil Thickness
option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.

Width and Height
Use the Width and Height operation fields to enter specific values to resize the selected shape with
precision.

1. Width: Type a value in this field to resize the width of your selection.
2. Height: Type a value in this field to resize the height of your selection.
3. Up/Down arrows: Use the up and down arrows to modify the value in the Width or Height fields.
4. Lock icon: Click the lock icon to lock or unlock the ratio between the Width and Height values.

Offset X and Y
Use the Offset X and Offset Y operation fields to enter specific values and precisely reposition the
selected shape.

1. X: Type a value in this field to reposition your selection along the X-axis.
2. Y: Type a value in this field to reposition your selection along the Y-axis.
3. Up/Down arrows: Use the up and down arrows to modify the value in the X or Y value field.

Angle
The Angle operation lets you to enter specific values and accurately rotate the selected shape.
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1. Angle: Type a degree value in this field to rotate your selection.
2. Up/Down arrows: Use the up and down arrows to modify the value in the Angle value field.

Adjusting the Pencil Line Thickness
Use the Adjusting the Pencil Line Thickness operation field to resize the selected centreline strokes.
This operation is not permitted on contour line shapes, such as brush strokes or shape fills.

1. Minimum Size: Type a value in this field to set the minimum thickness of the selected centreline
stroke.
2. Maximum Size: Type a value in this field to set the maximum thickness of the selected centreline
stroke.
3. Up/Down arrows: Use the up and down arrows to modify the value contained in the Thickness
value field.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Pencil Stencils
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Toon Boom Harmony gives you the flexibility to change the style and thickness of your pencil lines
even after they are drawn. You can apply preset pencil stencils or create your own—see Working
with Pencil Presets on page 82.

Adding Texture to a Pencil Line
Pencil lines support texture. Once a pencil line is drawn, you can apply a preset texture or load your
own. Textures are independent from pencil stencils—see Pencil Line Texture on page 85.

Adjusting the Text Selection
When you select text with the Select tool, the tool properties will display the Text tool options on
the bottom of the view. You can also press Alt + 9 to display only the Text properties in the Tool
Properties view—see Text Tool Options on page 172.

Eraser Tool Options
When you select the Eraser

tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,
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Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Eraser Presets
Eraser presets are created by saving the properties of the current eraser to a new preset, which you
can reuse for repeated tasks. You can create as many eraser presets as you need—see Erasing Parts
of a Drawing on page 112.
The Eraser tool uses its own preset list, separated from the Brush tool. Toon Boom Harmony
provides a variety of eraser styles and allows you to create and save your own. It is a good idea to
create and save eraser with precise sizes and parameters to draw and design.

Eraser Blur Parameters
Since Harmony lets you draw with textured lines and create feathered edges on them, you may also
want to erase with smooth edges instead of the solid vector based eraser. The Eraser Blur
Parameters allow you to adjust the smoothness of your eraser for the textured lines—see How to
erase textured lines on page 97

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Contour Editor Options
When you select the Contour Editor
view.

tool, its properties and options appear in the Tool Properties
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Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Snap to Contour

The Snap to Contour

option will snap the selected anchor point to any line you position it on.

How to snap two shapes together
1. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

2. In the Tool Properties view, click the Snap to Contour

button.

3. In the Drawing view, click on an anchor point you want to snap to the other shape, drag it on top
of the contour line area and release it.

Snap and Align
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The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to.

How to snap and align
1. In the Tools toolbar, select the Contour Editor

tool or press Alt + Q.

2. In the Tool Properties view, click the Snap and Align

button.

3. In the Drawing view, click on an anchor point you want to snap, drag it until a ruler is displayed,
position it on the ruler or on the contour line and release.

Show Contour Editor Controls

Use the Show Contour Editor Controls
option to show the contour editor controls. You can use
these controls to scale, reposition and rotate the selected anchor points.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Smooth Selection
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Selected > Smooth or press Alt + Shift + S.
Split Pencil Line and Join Pencil Lines
When drawing with the Polyline tool, your drawing has an even line thickness. You can use the Pencil
Editor to adjust the thickness point by point, but if you want to adjust it quicker, you can use the
Split Pencil Line and Point Pencil Lines options to create segments and apply a pencil stencil to your
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drawing. Note that if you did not join the pencil lines on your polyline stroke, the segments between
the points will act as separated segments.

How to split and join pencil lines
1. In the Tools toolbar, select the Contour Editor tool.
2. In the Drawing, select the contour points you want to split or join.
3. In the Tool Properties view, click on the Join Pencil Lines or Separate Pencil Line buttons.

Pencil Editor Options
When you select the Pencil Editor tool, its properties and options appear in the Tool Properties view.
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Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Maximum Size and Smoothing
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

‣

Smoothing: Defines the number of control points added to the centre line.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
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•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Preset
To work with Pencil line presets, see Working with Pencil Presets on page 82.

Textures
To work with Pencil Line Texture, see Pencil Line Texture on page 85

Smooth
The Smooth

operation lets you smooth out selected drawing strokes and remove extra points.

‣ From the top menu, select Selected > Smooth or press Alt + Shift + S.
Pump Pencil Pressure

The Pump Pencil Pressure
pencil line.

option is used to increase the line thickness of a selected area on a

Deflate Pencil Pressure
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The Deflate Pencil Pressure
pencil line.

option is used to decrease the line thickness of a selected area on a

Merge Pencil Lines

Pencil lines are central vector lines and it might be difficult to match pencil line’s tips properly to align
them and make it look like it is one single line. With the Select tool, you can select several pencil lines
and merge them as one single object using the Merge Pencil Lines
option. The ends of your lines
are adjusted to form one single line.

Reverse Pencil Thickness

The Reverse Pencil Thickness
option inverts the thick and thin section on a selected pencil line.
This option will take the thickest size on the line and apply it to the thinnest, and it will apply the
thinnest to the thickest.

Shape Tool Options
When you select a shape tool (Rectangle, Ellipse, Line), its properties and options appear in the Tool
Properties view.
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Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Size
Move the Size slider left to reduce the line thickness and to the right to increase its width.

Adjusting the Pencil Line Style

You can adjust the start, end, and joint style of a selected pencil line.
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•

Start: Lets you select the style of the start tip, which is the first tip you drew. You can choose
between Round or Flat style.

•

End: Lets you select the style of the end tip, which is the last tip you drew. You can choose
between Round or Flat style.

•

Join: Lets you select the joint style. The joints are where the line curves abruptly. You could also
define the Join style as the corner style. You can choose between Round, Mitre and Bevel style.

Thickness Stencils
Toon Boom Harmony provides a variety of thickness stencils and also lets you create and save your
own. It is a good idea to create and save pencils with precise sizes and parameters when you draw
and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 82

Draw Behind

When the Draw Behind
already exists.

mode is enabled, the lines you draw will appear behind the art that

Snap Options
When drawing a shape, you can enable different snap modes to help you create your shape.
•

The Snap to Contour

option snaps your shape to any line you position it on.

•

The Snap and Align
option snaps the selected anchor point to any existing line, while
displaying temporary rulers as a guide that you can also snap your anchor point to.

•

The Snap to Grid

snaps your shape to the currently enabled grid.
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Automatic Filling

Use the Automatic Filling
option to automatically fill your shape with the selected colour as you
draw. By default, the Shape tool creates the contour of an empty shape that you can later fill using
the Paint tool.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawingview. Brush strokes will flatten with brush strokes and pencil
lines will flatten with pencil lines.
Using the Select tool, you can use the middle mouse button to select a segment of flattened pencil
line. This creates a nice finish on the lines and corners of your artwork.
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Auto-Close Gap

When enabled, the Auto-Close Gap
mode automatically connects, with an invisible stroke, the
pencil lines you draw close to each other in the Drawing view.

It is recommended to leave this option enabled when drawing with the Pencil tool.

Use Stored Colour Gradient
The Use Stored Colour Gradient
option makes your tool use the previously stored gradient
position. This way, every new brush line or colour fill will use the stored gradient position.

Line Building Mode

The Line Building
mode is very useful when drawing long lines and curves in small increments
with pencil lines. As the pencil lines are central vector lines and it may be difficult to align the line tips
perfectly to create a uniform stroke and close all gaps.
In this mode, you can draw lines in small increments and the tips are merge into one single stroke.

This mode only works with pencil lines.
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Keep Proportion

When the Ellipse or Rectangle mode is enabled in the Tool Properties view, the Draw Circle or Draw
Square option appears. When selecting these options, the shape produced will be a circle or square.
Holding down the Shift key as you create your shape will maintain proportion.

Polyline Tool Options
When you select the Polyline tool, its properties and options appear in the Tool Properties view.

Previewing the Stroke
The Preview area lets you see a preview of the stroke that will be produced after you customize the
different parameters in the Tool Properties view. Click on the Show Extended Properties arrow to
display advanced customization parameters,

Size
The Size parameter lets you set the size of the polyline that you will draw.
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Thickness Stencils
Harmony provides a variety of thickness stencils and also lets you create and save your own. It is a
good idea to create and save pencils with precise sizes and parameters when you draw and design.
A thickness stencil saves a preset of how the thickness information looks across the length of the
line. When drawing with a thickness stencil, the pressure sensitivity of the tablet is discarded in order
to apply the thickness stencil.
A thickness stencil can be used while drawing, or applied afterwards.
You also have the possibility to apply different textures to your lines by either using the preset ones
or importing your own—see Working with Pencil Presets on page 82

Snap to Contour
The Snap to Contour

option will snap your selection to any line you position it on.

Create Colour Art Automatically

As you draw in the Line Art layer, the Create Colour Art Automatically
option automatically
creates the corresponding strokes in the Colour Art layer. To access this option, you must be in the
Advanced Art mode.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawingview. Brush strokes will flatten with brush strokes and pencil
lines will flatten with pencil lines.

Stroke Tool Options
When you select the Stroke tool, its properties and options appears in the Tool Properties view.

Draw Stroke as Straight Lines
Enable the Draw Stroke as Straight Lines

option if you want the new strokes you draw to be a
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perfect straight line. Disable the option if you want the stroke to follow the mouse gesture.

Connect Line Ends
Enable the Connect Line Ends
option if you want the start or end point of your new stroke to
connect to your existing strokes to make sure no gaps are left in your drawing.

Auto-Flatten Mode
When enabled, the Auto-Flatten mode automatically flattens the new lines created with the existing
artwork as you draw in the Drawingview. Brush strokes will flatten with brush strokes and pencil
lines will flatten with pencil lines.

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smooths
the initial movement of your line. Increasing the value will result in a smoother line with fewer control
points. Use the left and right arrows to increment the value by one full unit. Use the Up - Down slider
to quickly increment the value.

Perspective Tool Options
Selecting the Perspective tool displays its properties and options in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
•

The Snap to Contour
option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 151.

•

The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—see Contour
Editor Options on page 151.

•

The Snap to Grid

option snaps your selection according to the currently enabled grid.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.
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Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Selected > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Selected > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Envelope Tool Options
Selecting the Envelope tool displays its properties and options in the Tool Properties view.
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Width and Height
Increase the width and height values to add more columns and rows to the deformation grids.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Snap Options
•

The Snap to Contour
option will snap the selected anchor point to any line you position it
on—see Contour Editor Options on page 151.

•

The Snap and Align
option lets you snap the selected anchor point to any existing line while
displaying temporary rulers as a guide that you can also snap your anchor point to—see Contour
Editor Options on page 151.

•

The Snap to Grid

option snaps your selection according to the currently enabled grid.

Show Advanced Controls
To display more controls,you can click on the Show Advanced Controls
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Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Selected > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW
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The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Selected > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smoothness
You can modify the central line smoothness of your line using this option. This parameter smooths
the deformed lines. Increasing the value will result in a smoother line with fewer control points. The
more you increase the value, the less details and curves you will get. Use the left and right arrows to
increment the value by one full unit. Use the Up - Down slider to quickly increment the value.

Cutter Tool Options
When you select the Cutter

tool, its properties and options appear in the Tool Properties view.

Lasso and Marquee
Choose between the Lasso
•

and Marquee

options to change the selection style of the tool.

Click and hold Alt to temporarily switch from the current mode to the other.

Apply to Line and Colour Art
The Apply to Line and Colour Art
option uses the concept of Line Art and Colour Art layers. Use
this option to apply an action such as selecting or resizing a drawing on both Line Art and Colour Art
layers, as well as the Overlay and Underlay layers.

Use Mouse Gesture
When using the Lasso
selection type, the Use Mouse Gesture
option lets you automatically
delete any extra sections of line in your artwork by simply dragging your mouse over it.

For this operation to work, you lines CANNOT be flattened.
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Use Mouse Gesture Breaker Mode
When using the Lasso
selection type, the Use Mouse Gesture Breaker Mode
option lets you
draw an invisible stroke on a pencil line to cut it in two individual objects. Once a pencil line is cut with
this option, you will be able to select the two portions independently with either the Cutter tool,
Pencil Editor tool or Select tool.

This option only works with pencil lines.

Tip Style

Use the Tip Style option to customize the tip of the pencil line you are cutting.

Antialiasing

When drawing on a bitmap layer, lines are no longer clean vector shapes. For the edges to be
smooth, a slight amount of antialiasing is used. When using the Cutter tool, you can cut a portion of
your drawing with or without antialiasing. By default, the option is enabled. If you want to cut your
drawing using a hard edge, you can select the Antialiasing Off option.
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Flip Horizontal and Vertical

The Flip Horizontal
vertically.

and Flip Vertical

operations flip the current selection horizontally or

‣ From the top menu, select Selected > Transform > Flip Horizontal and Flip Vertical.
Rotate 90 Degrees CW and CCW

The Rotate 90 Degrees CW
and Rotate 90 Degrees CCW
selection 90 degrees clockwise or counter-clockwise.

operations rotate the current

‣

From the top menu, select Selected > Transform > Rotate 90 Degrees CW and Rotate 90
Degrees CCW.

‣

Press Ctrl + 7 and Ctrl + 9 (Windows/Linux) or ⌘ + 7 and ⌘ + 9 (Mac OS X).

Smooth Editor Tool Options
When you select the Smooth Editor tool, its properties and options appear in the Tool Properties
view.

Brush, Marquee and Lasso Smoothing Style
The Smoothing Style options allow you to smooth a portion of your drawing by tracing a smoothing
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stroke over the zone to optimize or by selecting an area of the drawing with the Marquee or Lasso.
Note that by default, the Smooth Editor tool colour is yellow, it was changed to orange for screen
grab clarity.

Show Control Points
The Show Control Points
option allows you to show or hide the Bezier points around lines.
When the Bezier points are displayed, you can see the result of your smoothing and the number of
points left on the curve. When it is turned off, only the original artwork is displayed.

Minimum Size and Maximum Size
This is where you set the minimum and maximum sizes of your drawing tool which will produce the
thick and thin effect on your stroke. This works with the pressure sensitivity of a pen tablet.
This options is available while using the Brush Smoothing

style.

‣

Maximum and Minimum Size: Defines the maximum and minimum width of the stroke.

•

Up/Down arrows: Use the up and down arrows to set the minimum and maximum size value.

Smoothness
The Smoothness
impacts the strength of the smoothing result. The higher the value, the more
points are removed and the smoother the curve. The Smoothness range is from 0 to 100; the default
value is 20.
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Colour
You can modify the colour of the control points displayed on the artwork while working with the
Smooth Editor tool by double-clicking on the colour swatch.

Text Tool Options
Use the Text tool's properties to select the font type and other formatting options you want to apply
to the text.
If you already wrote your text, you must first use the Text tool and select the text portion you want to
format.

Font Type
Use the Font drop-down menu to select a font. OTF fonts are supported.
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Font Style
Use these buttons to select a style for your text:
•

Bold

•

Italic

Alignment
Use these buttons to align the paragraph.
Left

Centered

Right

Justified

Font Size
Enter a size for the text.
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Kerning
Use the kerning field to modify the spacing between letters and characters. You can select the Auto
Kern option to set the kerning automatically based on the font’s predefined standard. A negative
value decreases spacing between each character, creating a letter overlap and a positive value
increases it.

Indent
Enter a value in the Indent field to increase or decrease the indentation on the first line of your text. A
positive value sets the first line of your paragraph farther to the right and a negative value sets it
farther to the left.

Line Spacing
Enter a value in the Line Spacing field to decrease or increase the space between each line of text.

Resizing the Text Box
You can resize the text box by selecting your text box with the Text
tool and moving the anchor
point right or left. Using the Select tool will distort and scale your text itself rather than changing the
width and height of your text box.
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Converting Text into Separate Objects
Text contained in a text field is treated as a single drawing object. You can easily separate the text
so each character becomes an individual drawing object that you can select and modify
independently.

How to break a text object
1. In the Tools toolbar, click the Select

tool or press Alt + S.

2. In the Drawing view, select the text object you want to break.

3. From the top menu, select Drawing > Convert > Break ApartText Layers.

Each character is surrounded by a bounding box that you can modify; they remain text objects
that you can edit.
4. If you want to convert your independent letter to a complete vector object that you can deform,
use the Select tool to select the letters to convert.
5. From the top menu, select Selected > Convert > Break Apart Text Layers to break the
selection into a regular drawing object, with no more text attributes.

Drawing Pivot Tool
The Drawing Pivot
tool lets you set the pivots on your character. You can set the drawing pivots
on drawings and symbols.
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Snapping

When you drag the drawing pivot around, you can enable a snap option so that when the drawing
pivot is released, it either snaps to the reference grid, drawing's contour, or aligns with an existing
drawing stroke.

Reset Pivot
When you click the Reset Pivot
option, the drawing pivot of the selected drawing or symbol is
reset to the centre of the Camera view.
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Once the characters, props and locations are designed, it is time for the colour styling and colour
models creation. This is when the colours and moods are determined. The line models created during
the design step are painted and organized as colour models for the colourists.
Harmony has a great concept of colour palettes. Each character can have its own set of colours that is
carried through the entire project called the master palette. If the master is modified, the colours in
the entire project are updated simultanously.
By doing the colour styling in Harmony, your master palette will be created at the same time, so you
do not need to use third party software. Also you will not have to recreate the colour palette again in
Harmony. It is possible to create this step in an external software, but it is a great time saver to do it
directly in Harmony.

Throughout this chapter you might notice slight differences between your interface and the images used to
demonstrate the procedure. This is because the images are taken from Harmony Stage. Paint is a subset of
Harmony Stage.

To create the colour style and colour models, follow these steps:
•

Preparation on the next page

•

Working with Palettes on page 181

•

Colours on page 205

•

Painting the Model on page 216
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Preparation
Before painting, you need to organize the colour model scenes and bring in your references. The
colour styling preparation is done in five steps:
•

Colour Model Storage below

•

Scene Creation below

•

Setting Up the Workspace on the facing page

•

Preparation above

Colour Model Storage
First, you will need to create a storage location for all your models and palettes. The best way to do
this is to create a colour model scene. There are different possibilities available to structure your
designs and colour model scenes. We strongly recommend that you put all of your colour models in
the same scenes. It is important to maintain a structure for your models so they do not end up
scattered throughout the project.
There are four main model categories:

If you have a small project, such as a short or an advertising contract, you can always place all the
characters, props, effects, and locations in the same scene. For large projects such as feature-length
productions or series, you should create four separate model scenes following these categories.

Scene Creation
In order to create colour models, you need to create your scenes.
When working on a paperless or cut-out animation project, if you have designed your characters,
props, effects and locations directly in Harmony, you can paint your models directly in your design
scene. You can also create a new colour model scene and import your designs in that one. Refer to the
Fundamentals Guide to learn more about creating a scene.
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If you have not already done so, refer to the Fundamentals Guide to learn about production structure,
file organization, and how to create a Project root directory. We recommend storing your colour
model scenes in the root directory or in a colour models subdirectory for even better organization.
A useful way to name your colour model scene is to include the project name, then the colour model
type such as characters, props, effects, or locations, and finally colourmodel. For example, a
character colour model scene for the Adventure project would be named adventure_characters_
colourmodel. This ensures that you always know what scene corresponds to what.

To learn how to create environment, job, and scene for your colour models, refer to the Control
Center and Server Guide.

Colour Model Scene Structure
To store your colour models in a scene, it is recommended that you create one drawing layer for each
character, prop, effect, or location. You should name these according to the model.
You can also load other colour references in the scene to balance your overall colours. For example, if
you work in a character colour model scene, it is a good idea to import some of the key locations to
compare and adjust the colours so they match well.

Setting Up the Workspace
Now that your scenes are created and structured, you can open the corresponding colour model
scene. For the optimal workspace for inking and painting, set up your workspace with these views:
•

Drawing

•

Colour

•

Model

How to rename a drawing
1. Do one of the following:
‣

Press Ctrl + D (Windows/Linux) or ⌘ + D (Mac OS X).

The Rename Drawing dialog box opens.
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2. Type in a new name and click OK.
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Working with Palettes
In animation, specific colours are used to paint each particular character. In order to maintain absolute
consistency, a colour palette is created for each character, prop and effect throughout the production.
These are referred to as master palette1s.
Master palettes contain a colour swatch for each zone to colour with a precise RGBA colour value.
Using a master colour palette has many benefits, including:
•

Each character consistently retains their dedicated colours.

•

You cannot accidentally use a colour which is not in the master palette.

•

Standardization and colour consistency throughout the production

•

Multiple artists can use the same colour palette and produce the same results.

Toon Boom Harmony uses palettes to hold all the colours needed to paint your elements, allowing
complete control and consistency in your painting process.
A palette2 is created by assigning a set of colours to each character, prop or effect. You will create a
new palette and add a new colour, known as a colour swatch, for each zone of the character, such as
the skin, hair, tongue, shirt, pants, and so on.
In Harmony, palettes are individual files that you can copy, transfer, and store. Palettes have a *.plt
file name extension—see Palette File Storage on page 185.
When a zone on the character is painted with the colour contained in a colour swatch, a link is
automatically created between that colour swatch and the zone. This means that if the tint of the
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way
that colour palettes can save time and money in your production.
Another advantage of this system is that you can create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you could have one for that
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet
another for using in a night scene. Using palettes linked to your character in this way allows you to
instantly change its colouring to suit the mood and atmosphere of the scene without tediously
repainting each element.

1A master palette is a group of colours attributed to a character or a prop. The palette is used throughout the

entire production to maintain consistency in the look and to ensure that the same colours are used throughout
the production. Also known as palette.
2A palette or master palette is a group of colours attributed to a character or a prop. The palette is used
throughout the entire Toon Boom Studio project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master palette.
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This section is divided as follows:
•

Palette Lists below

•

Palette File Storage on page 185

•

Creating a Colour Palette on page 188

•

Duplicating a Colour Palette on page 192

•

Cloning a Colour Palette on page 194

•

Palette Operations on page 196

•

Importing and Linking Palettes on page 200

Palette Lists
The Colour view has two modes: basic and advanced.
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•

Basic Mode
The Colour view’s basic mode only shows the Colour list. When you open Toon Boom Harmony,
you only see the colours available in the Default palette which contains six basic colour swatches
and is automatically named the same as your scene. For simple projects, you can manage with the
default palette, but for movies, series, or shorts it is recommended that you create palettes for
your characters. To create a palette, you have to switch to the Advanced mode of the Colour view
and show the Palette list.

•

Advanced Mode
The Advanced mode displays the list of all palettes that are linked to the scene. To create palettes
for your characters, you must display the Palette list.

A palette list is a file containing all of the links to the original palette files. Every drawing layer has a
palette list. The scene also has a palette list. For example, a drawing layer can use three different
palettes stored in three different locations, while another drawing layer can use two of these palettes
plus another one coming from another scene. The palette list keep track of the locations of the
palettes.
There are two types of palette lists:
•

Scene Palette List
The Scene Palette list is mainly used with cut-out animation, but is also very useful for paperless
and traditional animations. A cut-out character will often be divided into 20 to 30 different drawing
elements that use the character’s master palette.
The palette list is stored at the scene level instead of the Element directory. This way, all palettes
linked to this list will appear in every drawing element created in the scene. There is no need to
manually load the palette in each element.
The Scene Palette list is the simplest one to use. By default, Toon Boom Harmony is set to use only
Scene Palette lists.

•

Element Palette List
In Toon Boom Harmony, you can switch to Advanced Palette List mode and choose to save your
palette at an element’s level. The Element Palette list is mainly used with traditional and paperless
animation. Unlike cut-out animation, all columns (drawing elements) contain different characters,
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props, backgrounds, and effects. The Element Palette list is used when you do not necessarily
want all of the palettes for all of your elements linked in every column.
The palette list is stored in the drawing element’s directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer to
access a global palette list, link your palettes to the Scene Palette list.

To prevent users from accidentally removing a link to a palette, the palette lists are locked. To link or
create a new palette, the palette list must first be unlocked.
When you are using several cloned palettes that are related to the same original palette, Toon Boom
Harmony uses the highest palette in the list to determine the colour of the painted zones—see Cloning
a Colour Palette on page 194.

How to show or hide the Palette list
‣

In the Colour view, click the Show/Hide Palette List View
the Palette List area.

The Palette List window opens and displays all your palettes.
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How to lock and unlock to the palette list
‣

From the top menu, select Edit > Edit Palette List Mode.

A grey pencil appears on the top-right corner of the Palette list to indicate that it can be modified.

How to set the Advanced Palette Lists mode
1. Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the General tab.
3. Select the Advanced Palette Lists option.
4. Click OK.

How to reorder palettes in the Palette list
Do one of the following:
‣

From the Colour View menu, select Palettes > Move Up or Move Down.

‣

In the Palette list, click the Up

and Down

buttons.

Palette File Storage
In Harmony, palettes are individual *.plt files that can be copied, transferred and stored. When a
palette is created from Harmony, it needs to be stored somewhere. By default, the palette file is
stored in the scene directory in a palette-library folder unless you specify a different location. There are
four locations where you can find palette-library folders:
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•

Element
The Palette Library folder is stored directly in the drawing Element folder.

•

Scene
The Palette Library folder is stored directly in the Scene folder.

•

Job
The Palette Library folder is stored in a Job folder contained in the Scene folder.

•

Environment
The Palette Library folder is stored in an Environment folder contained in the Scene folder.

By default, the palette is stored at the scene level. For simple projects and standalone projects, it is
recommended to keep it as is. If you work with a larger studio, it is recommended to verify with them
on the file structure.
This existing structure is compatible with Toon Boom Harmony Server. Toon Boom Harmony’s
database has a leveled structure starting from the Environment down to the Element. Its client-server
configuration allows all data, such as palettes and scenes, to be shared between a series of client
machines.

Element Level
Working with Harmony as a stand alone, the Element level is very useful when there are a lot of
different palettes. When a colour model drawing is created, it is stored in its element folder. By
storing the corresponding palette file with the colour model, the colourist can load them both from
the same location. This also creates a more organized structure.

Scene Level
Working with Toon Boom Harmony as a stand alone, a palette file can also be saved at the scene level,
so that all of the palettes from the scene are stored together. The palette naming must be structured
so the colourist or character builders can find the correct one. Saving the palettes at the scene level
makes it very easy to back up the palettes and retrieve their location.
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The scene level can also be useful for cut-out animation. Instead of creating a colour model scene that
includes all of the characters, props, effects, and location, the colour palette or model will often be
directly imported to, or created in, the character building scene. Just as with a cut-out character
building scene, each element uses the same palette so it would not be efficient to save the palette
inside one element. Instead, it is saved at the scene level. This prevents a palette overload because all
of the models are in different scenes. It also allows each scene to have its own set of palettes
corresponding to its model.
When working on a cut-out animation production, it is highly recommended that you work with the
Scene level.

Where to Save the Palette File
The palette storage location depends on the type of production and the backup plan being used.
Some studios like to store their palettes at the Element level and others at the Environment level as
this will not create a problem so long as the scene is in the Harmony structure. In fact, as long as the
Harmony structure is maintained it can be stored at any level. However, difficulties may occur when the
scene is backed up or transferred to another studio or database and removed from the structure.

What happens when you export a palette file?
It is important to understand what is happening to a palette file when the scene is exported.
Because of the Harmony client-server configuration, all of the data can be shared through all of the
scenes in the database. This also includes the palette files, even if they are stored at the Element,
Scene, Job, Drawing or Environment level. The palette files can be accessed from any scene of any
project.
When you export scenes from Harmony to either archive or send them to other users or studios, the
palettes stored in external scenes, jobs or environment will NOT be exported.
An exported scene will carry palettes stored in its own Element’s Palette Library, scene’s palette
library, the Job and the Environment where it is stored. Any other palette from other Environments,
Jobs, Elements or Scenes (even from the same job) will NOT follow. Instead a recovery palette will be
created when the scene is reopened in another Harmony system. A recovery palette is a local palette
created by the system when palettes and colours are missing. This palette is no longer shared with the
rest of the project.
For example, in the following chart, if you export Scene 2 from Job 1, the package will carry the
palettes from Scene 2, Job 1 and Environment. It WILL NOT carry the palettes from Element 3 in
Scene 1, Scene 1 and Job 2. If Scene 2 was linked to any of these, the system will create a recovery
palette the next time Scene 2 is opened in another Harmony system.
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The best place to store your palette is:
•

Environment level for a movie or series

•

Job level for a publicity or small project

•

Scene level for a student exercise

To store your palette with their colour models, you can use the Element level, however, it will require
more structure when exporting the scenes. The scene will have to be exported along with its colour
model scene. The other studio you are working with must recreate an identical structure to yours, then
import the received scenes into the same location as you have them in order to maintain the links.

Palette Backup
When sharing palettes between scenes, some users may accidentally modify the colours, even though
the palettes are locked by default. That is why it is a good idea to copy and back up your palette
libraries and master palette directories.
When a palette file is copied, it automatically becomes a clone palette, so there will not be any trouble
replacing an altered file. Harmony automatically updates all of the files and drawings linked to it.

Creating a Colour Palette
You can create a palette in either Basic or Advanced mode.
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By default, Toon Boom Harmony is set to the Basic mode. For simple productions, it is recommended
to use the Basic mode. This setting stores the palettes automatically for you and saves them at the
Scene level. When you use the Advanced Palette Lists mode, you can decide at which level you want to
store your palettes: Environment, Job, Scene, or Element.
If you are using Harmony Network, see Palette File Storage on page 185.
Before you can create a palette in the Advanced Palette Lists mode, you must first set your
preferences to Advanced Palette Lists mode in the Preferences dialog box. You also need to have the
rights to modify the palette list. If you do not, select Edit > Edit Palette List Mode from the top menu.
You can remove palettes from your Palette list if they are not needed in your scene. The actual palette
file will not be deleted and you can reimport it in your Palette list later on.

How to set the Advanced Palette Lists mode
1. Do one of the following:
‣

From the top menu, select Edit > Preferences (Windows/Linux) or Stage > Preferences
(Mac OS X).

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

2. Select the General tab.
3. Select the Advanced Palette Lists option.
4. Click OK.

How to create a new palette (Basic Palette Lists mode)
1. From the Colour View menu, select Palettes > New or click the New Palette
‣

button.

Make sure that you have the necessary rights to modify the palette list. If you do not, select
Edit > Edit Palette List Mode.

The Create Palette window opens.
2. Enter the palette name according to the model.

3. Click OK.
The palette appears in the drawing element’s palette list.

How to create a palette from the Advanced Palette Lists mode
1. In the Timeline or Xsheet view, select the drawing that requires a palette.
2. Make sure that you have the necessary rights to modify the palette list. If you do not, select Edit >
Edit Palette List Mode.
3. In the Colour view, click the Show Palette List View button to display the palette list.

189

Chapter 7: Colour Styling and Colour Models Working with Palettes

4. Do one of the following:
‣

From the Colour view menu, select Palettes > New.

‣

Click the Create Palette

button.

The Palette Browser: Create Palette dialog box opens.

5. Select the level to store the palette file.
‣

Environment: The palette-library folder is stored in the scene's parent environment folder.

‣

Job: The palette-library folder is stored in the scene's parent job folder.

‣

Scene: The palette-library folder is stored directly in the scene folder.

‣

Element: The palette-library folder is stored directly in the drawing element folder.

When you select a level that has a palette stored in it, the palette names are displayed in the
Palette field.
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6. Name the palette. There is no need to add the suffix "palette" to the name as it is always
recognized as a palette file.

7. Select a Palette List option.

‣

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often
be divided in twenty to thirty different drawing elements that use the character's master
palette.
The palette list is stored at the scene level instead of the Element directory. This way, all
palettes linked to this list will appear in every drawing element created in the scene. There is no
need to manually load the palette in each element.

‣

The Element Palette List is mainly used with traditional and paperless animation. Unlike cutout animation, all columns (drawing elements) contain different characters, props,
backgrounds and effects. The Element Palette List is used because you do not necessarily
want all of the palettes for all of your elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer
to access a global palette list, link your palettes to the Scene Palette List.

8. Click OK.
The new palette appears in the palette list.

How to rename a palette
1. In the Colour view, select the palette to rename.
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2. Do one of the following:
‣

Right-click and select Rename.

‣

From the Colour View menu, select Palettes > Rename.

3. In the Rename dialog box, give the palette a new name and click OK.

How to remove a palette
1. In the Colour view, select the palette to remove.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Remove.

‣

Right-click on the selected palette and select Remove.

‣

Click the Remove Palette

button located above the Palette list.

If the palette was used in your scene, the zones painted with its colours turn red.

Duplicating a Colour Palette
A duplicated palette is a simple copy of the original palette. It uses the same names, colour values, but
has a different ID and is independent from the original palette. This ensures that both palettes are
completely independent.
This option is used when there are similar models and you want to avoid recreating and naming all of
the colours. You can change the values and the names afterward without affecting the original palette.
You can also keep some RGBA values, such as the eyes, teeth, tongue, inside mouth, etc.
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How to duplicate a palette
1. In the Colour view, select the palette to be duplicated.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Duplicate.

‣

Right-click on the selected palette and select Duplicate.

The Palette Browser: Duplicate Palette window opens.
3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 185.

4. In the New Palette Name field, name the palette.

5. In the New Palette Name field, name the palette.
6. Click OK.
The palette appears in the palette list.
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Cloning a Colour Palette

A character usually has only one master palette, although there are times when the characters are
placed in different lighting conditions and require a different colour shading. The night palette is a
popular choice when a scene or sequence changes from day to night. It can be difficult and timeconsuming to repaint everything and creating two independent palettes can be quite complex. As an
alternative, Toon Boom Harmony provides clone palettes.
The clone palette is a copy of the master palette. The colours in each palette have the same
properties. The colours have the same identification number pointing to the same colour zones, but
they can have different names and RGBA values. Depending on the activated palette (night or day), the
painted drawing will update. So there is no need to repaint the animation, but to create or import a
clone palette (palette style).

How to clone a palette
1. In the Colour view, select a palette to clone.

2. From the Colour View menu, select Palettes > Clone or right-click and select Clone.
The Palette Browser: Clone Palette dialog box opens.
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3. If you are in Advanced Palette List mode, select the palette storage level—see Palette File Storage
on page 185.

4. In the New Palette Name field, name the palette. It is recommended that you keep the "-clone" in
the name.
5. Click OK.
The cloned palette appears in the palette list.

6. In the Palette list, select the clone palette you created to offset or blend colours—see Mixing
Colours on page 214.
7. From the Colour View menu, select Palettes> Tint Panel or right-click and select Tint Panel.
The Blend/Offset Tint panel opens.
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8. Select one or more colours to modify. You can select all your colours by pressing Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).
9. Offset, blend, or mix the colours using the sliders and increasing the Amount value.

10. Select the Preview option to see a preview of the colours while you adjust them.

You can also modify the colours individually with the Colour Picker window.

Palette Operations
When you start Toon Boom Harmony connected to the database, you can access the Palette
Operations dialog box which lets you clone, rename, or delete palettes.

How to open the Palette Operations dialog box
1. Start Harmony Paint and log in.
2. Close the Database Selector dialog box.
3. From the top menu, select Tools > Palette Operations.
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The Palette Operations dialog box opens.

How to clone a palette in the Palette Operations dialog box
1. Select the palette you want to clone at the location and level in which it was stored.

2. Click Clone.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every
time you perform this operation.
4. Click Yes.
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The Palette Browser dialog box opens.
5. Select the level to store the palette file.

6. Name the palette. There is no need to add the suffix "palette" to the name as it is always
recognized as a palette file.

7. Select a Palette List option.

‣

The Scene Palette List is mainly used with cut-out animation. A cut-out character will often
be divided in twenty to thirty different drawing elements that use the character's master
palette.
The palette list is stored at the scene level instead of the Element directory. This way, all
palettes linked to this list will appear in every drawing element created in the scene. There is no
need to manually load the palette in each element.

‣

The Element Palette List is mainly used with traditional and paperless animation. Unlike cutout animation, all columns (drawing elements) contain different characters, props,
backgrounds and effects. The Element Palette List is used because you do not necessarily
want all of the palettes for all of your elements linked in every column.
The palette list is stored in the drawing element's directory instead of directly in the Scene level.
This ensures that the links to the palettes appear only in the appropriate element. If you prefer
to access a global palette list, link your palettes to the Scene Palette List.

8. Click OK.

How to rename a palette in the Palette Operation dialog box
1. Select the palette you want to rename at the location and level in which it was stored.
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2. Click Rename.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every
time you perform this operation.
4. Click Yes.
The Rename Palette dialog box opens.

5. Type in a name for the palette.
6. Click OK.

How to delete a palette in the Palette Operation dialog box
1. Select the palette you want to delete at the location and level in which it was stored.
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2. Click Delete.
A Warning dialog box opens.

3. Select the Don't show this message again option if you do not want to see this message every
time you perform this operation.

It is not recommended to disable the warning message as deleting a palette cannot be undone.

4. Click Yes.

Importing and Linking Palettes
Before starting colouring work such as Ink and Paint or even creating new colour models, you may
want to load existing colour palettes to your scene. You can do so by linking colour palettes to your
palette lists.
You may encounter a case where only a colour palette is visible when a layer is selected. If you need
that palette in a second layer, you can link the palette to the second layer's palette list, A good
example would be a scene where there is a character on one layer and its arm is on another. In order
for both layers to access the palette, you must link both Element Palette lists to that palette. If you
palette is linked to the Scene Palette list, it will be accessible by all layers.
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If you created a palette in another project and you want to import it in your current project, you can
browse for the palette file on your computer and add it to your scene. When the palette is imported in
your scene, the file is copied in the project’s directory. It is not linked to the original file.
Harmony lets you link an external palette to your scene without copying it in your project. This method
is not recommended. It is always safer to have the palettes contained within the database to avoid
data loss if the source palette were to be deleted or the project exported without including the
external palettes.
You will notice that when you create or link a palette, a small icon appears on its left. These icons
represent the palette linkage status.
Icon

Description
Indicates that the palette is safe.
There won’t be any trouble once the scene will be exported. For example,
the palette file is stored in the scene folder and is linked to the Scene Palette
List.
Indicates that the palette file is stored in a directory external to the scene’s
structure.
The palette file is probably stored in a Master Palette directory on a hard
drive external to the palette-libraries planned for the palette storage. The
warning in this case is that if you move your Master Palette directory to
another location, you may loose the palette in your scene.
Indicates that a palette file stored in a level such as Element, Scene, Job or
Environment is linked to a Palette list that is not on the same level.
For example, a palette file is stored into the Environment folder and is linked
to the Element Palette list. The palette is shared.

How to link a colour palette
1. Do one of the following:
‣

From the Colour View menu, select Palettes > Link.

‣

Right-click and select Link.

‣

Click the Import

button.

The Palette Browser: Link Palette dialog box opens.
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2. Select the level where the palette file is stored—see Palette File Storage on page 185.
3. Select the palette list linking level by enabling either Scene Palette List or Element Palette List—
see Palette Lists on page 182.
The palette appears in the Colour view.

How to import a palette into your project
4. Do one of the following:
‣

From the Colour View menu, select Palettes > Import.

‣

Right-click and select Import.

The Browser window opens.
5. Browse for a palette file located (*.plt) on your hard drive. You will generally find the palettes in
your project's palette-library directory.
6. Click Open.
The Palette Browser opens.
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7. If you are in Advanced Palette mode, select the level where the palette file is stored—see Palette
File Storage on page 185.
8. If you are in Advanced Palette mode, select the palette list linking level by enabling either Scene
Palette List or Element Palette List—see Palette Lists on page 182.
9. In the New Palette Name, name the imported palette.
The palette appears in the Colour view and the file is copied in your project.

How to link to an external palette
1. In the Colour view, click on the Create Palette
external.

button to create your palette to be used as

2. Save your scene by selecting File > Save from the top menu or by clicking the Save
press Ctrl + S (Windows/Linux) or ⌘ + S (Mac OS X).

button or

3. On your computer or server, create a master directory. Ideally, this should be created in your Root
folder to keep it within the project directory. You could also place it inside your Colour Model’s
subdirectory. Refer to the Fundamentals Guide to learn more about project organization.

4. Name the folder appropriately, for example: Joe_master_palette.
5. From your operating system, browse to your Toon Boom Harmony scene and open the palettelibrary folder.
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6. Select and copy your palette *.plt file to copy it to the master palette directory.

7. Create a new Toon Boom Harmony scene or open the scene where you will link this palette.
8. From the Colour View menu, select Palettes > Link to External.
The Link to External Palette dialog box opens.

9. Click Browse to search for your master palettes folder and select the palette *.plt file you want
to link.
10. In the Palette list section, select how you want to load the palette; at the scene or element level.
11. Click OK.
The linked palette appears in the Colour view.
If a palette is outside the scene, the External

icon appears beside the palette name.

To link an element (such as a colour model) to the palette that is stored in the external palette directory,
you must remove the original palette from the element’s palette list. You will then load the duplicated
palette into the palette list using the Link to External command, like you did for the other elements.
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Colours
Toon Boom Harmony has some very powerful colouring features when it comes to painting. To paint
your drawings, you will use different colour swatches, unlike some other painting programs where you
modify the main swatch each time you want to paint with a different colour.

In the Colour view, you choose a different colour swatch for each colour you want to paint in your
drawing. You can add as many swatches as you want. You can also rename them and modify existing
ones.

When you modify the colour of an existing swatch, it automatically updates all the zones painted with
this swatch throughout the entire project. The colour swatch has a unique ID number that associates it
with the painted zones. This way, you can change the look of your character at any time without having
to repaint it!
This section is divided as follows:
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•

Adding a Colour Swatch below

•

Colour Display Modes on page 212

•

Copying and Pasting Colours on page 213

•

Mixing Colours on page 214

Adding a Colour Swatch
You can use several different types of colour swatches.

A colour palette is an actual file that is on the hard drive. These palette files can be stored in a different
location on the server. They can be stored in the Environment, Job, Scene, or Element folder and
linked to any palette list. This means that if the original palette file is modified, it will update in every
drawing element the palette is linked to.
To avoid accidentally modifying the palette, the palette files can be locked. If a palette must be
modified, you must get the rights to modify them before doing so.s

How to lock or unlock the palette list
‣

In the Colour view, click the Edit Palette Mode

button.

A grey pencil icon appears in the top-right corner of the Palette list.

How to add or modify a solid colour swatch
1. In the Colour view, click the New Colour

button.

2. From the Colour View menu, select Colours > Edit or double-click on the colour swatch.
The Colour Picker window opens.

206

Toon Boom Harmony 11.1 Paint Guide

3. To set your colour, do one of the following:
‣

In the colour wheel, select a colour.

‣

Enter the HSV or RGB values in the corresponding fields. Select the R,G,B,H,S or V options
to change the look of the colour picking area.

‣

Click the Dropper
button to select any colour on your screen. It can be from the Toon
Boom Harmony interface, your operating system or any other open application.

You can also click Multi Wheel Mode to open the Multiwheel Colour dialog box. This displays all
the picking area styles together and also contains a picking undo list. To return to the regular
Colour Picker window, click Single Wheel Mode.
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4. Click on the Shade Scale swatches to modify the shade of the selected colour.

5. Adjust the desired level of transparency with the Alpha slider, or type the value directly in the Alpha
field.

6. Click the Add button to add the current selected colour to the Colour Storage Library, so you can
quickly access it later.

7. You can rename the colour swatch in the Colour Picker window or directly in the colour list by
double-clicking on its name.

How to create a gradient colour swatch
1. In the Colour view, select a colour to modify .
2. Do one of the following:
‣

Click the new colour and from the Colour View menu, select Colours > New.
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‣

Double-click on the colour swatch.

The Colour Picker window opens.

3. Select the Gradient option.
4. Select the Linear or Radial option.
5. Adjust the Gradient arrows to modify the colours.

‣

Add extra colours by clicking between the arrows below the gradient bar. Then click on the
Colour Preview to select a colour.

‣

Pull down the arrows to remove them.

‣

Move the arrows left and right to modify the gradient distance.

Refer to the Editing Gradients and Textures on page 240 topic to learn how to reposition the gradient
zones in your drawings.
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How to create a texture colour
1. From the Colour View menu, select Colours > New Texture or click the New Texture

button.

The Browser window opens.
2. Browse for a PSD or TGA bitmap file created with a third party software and click Open.
The texture is added to the colour list.

Refer to the Editing Gradients and Textures on page 240 topic to learn how to reposition your textured
zones in your drawings.

You can also replace a texture once it is painted. If you decide to make the character’s shirt wool
instead of plaid, just update the texture file in the swatch and the entire project updates. Any
transformation previously applied to the texture’s position in your drawings will be kept.

How to replace a texture swatch
1. In the Colour view, select the texture swatch that contains the bitmap texture you want to replace.

2. From the Colour View menu, select Colours > Edit Texture or double-click on the swatch.
The Browser window opens.
3. Browse for the new PSD or TGA bitmap file created in a third party software.
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4. Click Open to update the colour swatch.

How to delete a colour swatch
1. In the Colour view, select the colour swatches to delete.

2. Do one of the following:
‣

From the Colour View menu, select Colours > Delete.

‣

Click the Delete Colour

‣

Right-click and select Delete.

‣

Press Delete.

button.

If the colour swatch is used in a drawing, the Delete Colour dialog box opens.

3. Click OK to delete the colours or click Cancel to abort the operation.
‣

If you delete colour swatches already in use, the zones painted with them turn red so you
can easily identify them.
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Colour Display Modes
The Colour view has two display modes:
•

List

•

Swatch

You can alsodisplay the RGB values and names of your solid colour swatches instead of only the name.
This option is not available when displaying the colours in Swatch mode.

How to switch between the display modes
1. From the Colour View menu, and do one of the following:
‣

Select Colours > Swatch Mode to display the swatches.

‣

Deselect Colours > Swatch Mode to display the colour list.

How to display the swatch colour values
‣ From the Colour View menu, select Palettes > Display Colour Values.
The solid colour swatches’ RGB values will be displayed between the colour swatch and its name.
The gradient colour swatches will be identified as (gradient).
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Copying and Pasting Colours
When you are creating palettes, you may want to copy colour swatches or their values and paste them
in other palettes to save time. You can also quickly copy a colour value from a palette in your scene to
a selected colour swatch in a different palette.
You can copy a selected colour swatch and paste it as a clone. Since it produces a clone colour swatch,
it is impossible to use the Paste as Clone command in the same palette as you copied the original
colour swatch from.
If you would like to keep a reference file of some colour IDs or use them with custom plug-ins, you can
copy the colour swatch IDs. Here is an example of colour ID: 075cf5b552401130.

How to copy and paste colours
1. In the Colour view, select one or more colours to copy.
‣

In the Colour view, click the Edit Palette Mode

button to be able to edit the colour list.

2. In the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C (Mac
OS X).
3. In the Palette list, select the palette in which you want to paste the colours.

4. From the Colour View menu, select Colours > Paste as New Colours or press Ctrl + V
(Windows/Linux) or ⌘ + V (Mac OS X).
‣

To paste the colour values of the copied swatch over an existing colour swatch, select
Colours > Paste Colour Values.

How to clone a colour swatch
1. In the Colour view, select the colour swatch you want to clone.
‣

In the Colour view, click the Edit Palette Mode

button to be able to edit the colour list.

2. From the Colour View menu, select Colours > Copy or press Ctrl + C (Windows/Linux) or ⌘ + C
(Mac OS X).
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3. In the Colour view, select the colour palette you want to paste the clone into or create a new
palette.
4. From the Colour View menu, select Colours > Paste as Clone.
The cloned colour swatch appears in the palette.

How to copy a colour ID
1. In the Colour view, select the colour swatch you want toget the ID from.
‣

In the Colour view, click the Edit Palette Mode

button to be able to edit the colour list.

2. From the Colour View menu, select Colours > Copy Colour ID or press Ctrl + C (Windows/Linux)
or ⌘ + C (Mac OS X).
3. Paste the copied value as plain text in the desired document.

Mixing Colours
If you want to modify a series of colours at once to blend a tint in them or offset their RGBA values, you
can use the Tint panel. This panel is quite useful when creating palette styles such as night and day
styles.

How to mix colours
1. In the Colour view, select the palette that contains the colours you want to offset or blend.

2. Do one of the following:
‣

From the Colour View menu, select Palettes > Tint Panel.

‣

Right-click and select Tint Panel.

The Blend/Offset Tint panel opens.

3. Select one or more colours to modify in the colour list. To select all the colours, press Ctrl + A
(Windows/Linux) or ⌘ + A (Mac OS X).
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4. Select Preview option.
5. Select the Offset, Blend, or Mix option.

Parameter

Description

Offset

Offsets the selected colours by the adjustments made using
the HSB and RGB sliders. Use the Amount slider to adjust the
degree of offset. Use the Alpha slider to adjust the opacity of
the selected colour.

Blend

Blends the selected colours with the colour swatch in the top-right
corner. Use the Amount slider to adjust the degree of blend. A blend of
100% turns the selected colours into the same colour as the swatch.
Adjusting the HSB and RGB sliders affect the swatch colour, which in
turn affects the selected colours on the left. Use the Alpha slider to
adjust the opacity of the swatch.

Mixer

Select a Base and Tint colour to form a third colour swatch.
Use the slider just beneath to mix the Base and Tint colours
by different amounts. This will affect the mixed swatch
whether it is selected or not. Select either the Tint or Base
swatch and use the HSB and RGB sliders to adjust its colour.
This will affect the mixed swatch colour, which in turn affects
the selected colours on the left.

6. Click Apply.
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Painting the Model
Now that you have created the colours and the palette, you are ready to paint your model.
The colour model needs to be painted in order to adjust the colours with the other elements in the
production. You can paint your model regardless of the colour RGBA and adjust them later when all
the elements are together.
Once your palette is created and your model is painted, you can import a key background and other
characters using the Import Drawings option or the Library to compare and adjust the palettes—see
Basic Commands on page 34 to learn how to import your background file.

For paperless and cut-out animation, it is a good idea to provide a line-up template with the colour
model to show the scale ratio between the characters, props and backgrounds.

Once your colour model is completed, create a line-up template by pasting one of the production's
main characters, or even just a hand, beside the colour model to show the relative size. This allows the
animator, layout artist, or scene setup artist to retain the correct scaling throughout the entire project
when setting the elements in the scene. You can store your template in the Library.

How to paint a colour model
1. From the Drawing View menu, select View > Switch to Colour Art/Switch to Line Art or press L.
2. Create your master colour palette—see Creating a Colour Palette on page 188
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3. Add new colours to the palette—see Adding a Colour Swatch on page 206.
4. Select your Paint Bucket

tool. We recommend the Paint Unpainted

tool.

5. In the Colour view, select the colour you need to paint your drawing.

6. Paint the model by selecting colour swatches in the palette and clicking on your drawing. Note that
only closed zones will be painted. If there is a gap in your artwork, you will need to close it in order
to paint it.

7. If you would like to separate your lines and fill zones on separated art layers, see Art Layers on
page 226.
8. Adjust the colours—see Mixing Colours on page 214.
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When traditional animation is traced, cleaned up, scanned in and properly exposed, it is time for the
ink and paint process. This consists of cleaning all dirt and hair (for example, dust that was in the
scanner, dots that do not belong in the drawing, extra floating artwork around the drawing that must
be removed), painting the lines and filling the colours in the empty zones on an entire animation
sequence.
For paperless animation, the drawings are cleaned up directly in Harmony, so there is generally no dirt
to clean, only painting and inking.
For cut-out animation, once the character builder paints the pieces, there is no more ink and paint
process because the same parts are always reused and moved around. The ink and paint process
applies only to traditional and paperless animation workflows.
Harmony is optimized to ink and paint drawings efficiently. Since most of the drawings are vectorbased, the colour zones are completely filled and there are no scattered spots left blank. Also, there
are some actions that can be applied on an entire animation sequence at once, like dirt removal, some
colour filling, line repainting, and so on.
Harmony uses palettes to hold all the colours you need to paint your elements. A palette is created by
assigning a set of colours to each character, prop or effect. The colour styling artist will create a new
palette and add a new colour for each zone of the character, such as the skin, hair, tongue, shirt,
pants, and so on. Each colour is known as a colour swatch—see Working with Palettes on page 181.

When a zone on the character is painted with the colour contained in a colour swatch, a link is
automatically created between that colour swatch and the zone. This means that if the tint of the
colour in the colour swatch is changed, any zone linked to it will update to the new tint. This is one way
that colour palettes can save time and money in your production.
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Another advantage of this system is that you can create complete palettes for different lighting
situations. For instance, in addition to the regular palette for a character, you could have one for that
character in the rain using colours that are duller and less vibrant than the dry daytime colours, or yet
another for using in a night scene. Using palettes linked to your character in this way allows you to
instantly change its colouring to suit the mood and atmosphere of the scene without tediously
repainting each element.
The ink and paint process is divided into the following steps:
•

Preparation on the facing page

•

Dirt Clean Up on page 223

•

Art Layers on page 226

•

Creating Strokes on page 229

•

Painting on page 231

•

Inking the Lines on page 249

•

Verifying the Zones are Painted on page 253

•

Ink and Paint Tool Properties on page 254
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Preparation
The optimal workspace for creating colour models and inking/painting in traditional animation
includes the following views:
•

Drawing

•

Colour

•

Model

As there is no default workspace for these tasks you will need to create a custom workspace for
yourself—refer to the Fundamentals Guide.
You may have a character or element palette that has colours that are very similar to the Drawing and
Camera view's background colour. For example, a white eyeball colour on a white background which
makes it difficult to know if the zone was painted. You can change the background colour of the
Camera or Drawing view in the Preferences dialog box.

How to change a view's background colour
1. Do one of the following:
‣

From the top menu, select Edit > Preferences.

‣

Mac OS X: Select Stage > Preferences.

‣

Press Ctrl + U (Windows/Linux) or ⌘ + U (Mac OS X).

The Preferences dialog box opens.
2. Select the General tab.
3. In the Colours section, click Edit Colours.
The Colours dialog box opens.
4. Change the background colour of:
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‣

Click the Background colour swatch.

The Select Colour dialog box opens.
5. Select a colour by clicking a colour swatch, clicking a colour in the colour gradient, or entering a
HSV/RGB Value.

6. Click OK in the three opened dialog boxes to apply your changes.

When you need to paint drawings with similar colours throughout the palette, you can
create a clone of that palette and change all the colours to very bright tints to facilitate
the paint process—see .

222

Toon Boom Harmony 11.1 Paint Guide

Dirt Clean Up
When paper drawings are passed through a scanner, there can be some hair and dirt scattered across
them. These lines and dots need to be cleaned. Harmony provides different tools to help get rid of
them quickly.

The Remove Dirt tool selects small dots and hairs on the drawing. Raising the Remove Dirt level will
select bigger dots. When selecting larger dots, be careful not to lose small details like pupils and
nostrils. Once you have chosen the level, you can apply it to the current drawing or the entire
animation sequence. This is a quick way to get rid of most dirt and dust.
During this process, the dirt that will be removed is highlighted in red.

The Remove Art Outside Selection option lets you remove any art existing outside a selection. It is
recommended that you clean your Colour Art level as well. If you have a stroke accumulation in your
Colour Art, it can result in large output files, especially if you work in high-definition resolutions.
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If there are some marks that cannot be removed with the automated tools, you can erase them with
the Eraser tool or select them with the Select tool and then delete them. It is always safer to select and
delete them than to erase them, so you do not overlook anything.

How to use the Remove Dirt tool
1. Do one of the following:
‣

From the top menu, select Selected > Clean Up > Remove Dirt.

‣

Press Shift + D.

2. Increase the Remove Dirt value by moving the slider to the right.
3. Enable the Apply to All Drawings if you want to operation to be apply to all drawings in the layer.

How to clean dirt with Remove Art Outside Selection
1. In the Tools toolbar, select the Select

tool.

2. In the Tool Properties view, enable the Permanent Selection option.
3. Draw a selection around the animation making sure to include the entire animation sequence.
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4. Select Selected > Clean Up and one of the following options:
‣

Remove Art Outside Selection to delete artwork outside your selection on a single
drawing.

‣

Remove Art Outside Selection on All Drawings to delete artwork outside your selection
on all the drawings.

The art outside the selection is removed.

How to access the Eraser tool
‣

From the Tools toolbar, click the Eraser

‣

From the top menu, select Tools > Eraser.

‣

Press Alt + E.

button.

How to access the Select tool
‣

From the Tools toolbar, click the Select

‣

From the top menu, select Tools > Select.

‣

Press Alt + S.

button.
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Art Layers

Art layers give you the possibility to divide the artwork in your drawing on different layers. For
example, you can separate the outline and colour fill on two art layers, similar to 1950s traditional cell
animation. These art layers are contained within a single drawing as opposed to the timeline layers or
Xsheet columns where individual drawings with individual timing are stacked one on top of the other—
see Creating Strokes on page 229.
Toon Boom Harmony drawings include two art layers.
•

Line Art below

•

Colour Art on the facing page

Each layer can be used for separate hand-drawn animation tasks, letting you organize your work and
facilitate creation and revision.

Line Art

In hand-drawn animation, the Line Art layer is mainly used to trace and clean up animation. The
outline is drawn in the Line Art layer and colour is painted in the Colour Art layer.
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Colour Art

In hand-drawn animation, you use the Colour Art layer to paint your animation. The outline is drawn
in the Line Art layer and colour is painted in the Colour Art layer. Strokes (invisible lines) are
generated from Line Art to contain the painted area.

When you are doing rough animation, you may want to send a clip to somebody for feedback or
approval before carrying on with your work. If you have several characters in your project that are
overlapping, it may be difficult to understand what is going on as you can see through the
characters. Toon Boom Harmony can generate a matte automatically in the Colour Art layer, and fill
all the zones inside your characters making them opaque. This process is fast and easy and allows
you to send easy-to-understand movies.

How to switch between Line Art and Colour Art layers and enable the Preview mode
1. Do one of the following:
‣

In the Drawing view, right-click and select Switch to Colour Art/Switch to Line Art or press
L.

‣

In the Colour view, click the Colour Art

‣

In the Colour view, click the Line Art

button.
button.

2. To preview the Line Art and Colour Art at the same time:
‣

In the Drawing view, right-click and select Preview Line Art and Colour Art or press Shift +
P. While using the Preview mode, you still edit one mode at a time.

‣

In the Colour view, click the Preview

button.

To edit both Line Art and Colour Art at the same time, you must enable the Apply to
Line Art and Colour Art button in the Tool Properties of the tools supporting the
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operation.

228

Toon Boom Harmony 11.1 Paint Guide

Creating Strokes
A drawing is composed of Line and Colour filling layers. Lines and colours can be separated or kept
together, depending on which animation process you use. The following diagram presents Line Art
and Colour Art recommendations based on the selected animation workflow.

When a traditional drawing is scanned, strokes are automatically created in the Colour Art from the
Line Art when drawings are vectorized unless you specified otherwise.
When working with Cut-out animation, we recommend that you do all of the work in the Line Art.
Once the drawing sequence is completed for paperless drawings, you can proceed with creating
Colour Art strokes if you plan to paint the animation in the Colour Art. Use the Create Colour Art from
Line Art option to create strokes from your lines.
You can create strokes in the Colour Art during the following stages:
•

After the full drawing is completed in Line Art

•

While drawing in Line Art

You may have some traditional drawings that need to be fixed; for example, needing extra lines to
patch gaps. Use the Auto-Create Colour Art from Brush option to create the strokes at the same time
as the lines are drawn. This creates strokes from the lines and brush strokes created in the Line Art
while you draw and is useful for fixing drawings. However, if you are drawing a new sketch, it is better
to create the strokes afterward using the Create Colour Art from Line Art option.

Make sure to select the Advanced Art Mode in the Preferences dialog box to use this feature.

How to create Colour Art zones out of the Line Art content
1. In the Tools toolbar, select the Select

tool or press Alt + S.
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2. In the Tool Properties view, enable the Permanent Selection
operation on all drawings in the layer.

option if you want to apply the

3. In the Drawing view, select the artwork to transfer to the Colour Art. Create a selection around the
entire animation sequence if you want to apply the operation to all your drawings.

4. In the Drawing View toolbar, click the Create Colour Art from Line Art

button or press *.

How to create strokes with the Auto-Create Colour Art From Brush option
5. Draw the required lines.
6. Once you are done, deselect the Auto-Create Colour Art from Brush option. You are now ready
to paint your model.
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Painting
You can choose to paint your animation in the Line Art or Colour Art level. You can paint in Line Art,
but for traditional and paperless animation, you should fill your colour zones in Colour Art. You can
access the art layers through the Art Layer toolbar—see Art Layers on page 226.
There are many advantages to separating the lines and colour zones, but the main one concerns the
painting process. To paint very quickly, it is useful to not worry about painting over the lines. If the
lines are separated, you can fill the zones very quickly and you will never accidentally paint the lines.
Conversely, if you are inking the lines, you will not repaint the colour zones either.
If you have transparent lines, bitmap lines or textured lines with transparency, it is better to have your
colour zones bleeding under your lines to avoid seeing the backgrounds and other elements through
the lines.

To avoid painting in Line Art by mistake, turn off the Preview mode and paint in the Drawing view rater
than the Camera view. Press P to turn the mode on or off.
This section is divided as follows:
•

Painting Using the Paint Tool on the next page

•

Advanced Painting Features on the next page

•

Selecting a Colour in a Drawing on page 236

•

Importing Models on page 238

•

Editing Gradients and Textures on page 240

•

Closing Gaps on page 245

•

Protecting Colours on page 247

•

Highlighting the Selected Colour on page 247

•

Inverting a Colour Selection on page 248
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Painting Using the Paint Tool

The main tool you will use to paint your drawings with is the Paint tool. The Paint tool can be used in
several different modes, which can be customized in the Tool Properties view.
The Paint tool paints closed zones, including brush strokes and pencil lines. If there are gaps in the
lines defining a zone, you must close them using the Brush, Pencil, or Close Gap tools or the Automatic
Close Gap option.

How to paint with the Paint tool
1. Do one of the following:
‣

In the Tools toolbar, click the Paint

‣

From the top menu, select Drawing > Drawing Tools > Paint.

‣

Press Alt + I.

tool.

2. In the Colour view, select a colour.

3. In the Drawing view, start painting. You can click on a zone or pencil line to paint it, or you can
trace a lasso or marquee selection to paint several zones or pencil lines at once.

The last colour you select while using the Paint tool will be remembered the next time you select the Paint
tool if you are using the unlocked painting tools in the Colour view.

Advanced Painting Features
The following advanced painting features are available in Toon Boom Harmony and are described in
this section:
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•

Repaint Selection

•

Repaint Selection On All Drawings

•

Repaint Outside Selection

•

Repaint Outside Selection On All Drawings

•

Unpaint Selection

•

Unpaint Selection On All Drawings

•

Unpaint Outside Selection

•

Unpaint Outside Selection On All Drawings

The Repaint Selection command is used to repaint any art inside a selection. You must first draw a
selection using the Select tool in order for this command to be available.

The Repaint Selection On All Drawings command is used to repaint any art inside a selection on all the
drawings contained within the same layer. You must enable the Permanent Selection
option in the
Select tool Tool Properties view and then select an area of your drawing using the Select tool in order
for this command to be available. The Permanent Selection option lets you maintain the same
selection throughout the drawings of a same layer.

The Repaint Outside Selection command is used to repaint any art outside a selection. If no selection
has been drawn using the Select tool, the entire drawing will be repainted.
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The Repaint Outside Selection On All Drawings command is used to repaint any art outside a selection
on all the drawings contained within the same layer. You must enable the Permanent Selection
option in the Select tool Tool Properties view and then select an area of your drawing using the Select
tool in order for this command to be available. The Permanent Selection option lets you maintain the
same selection throughout the drawings of a same layer.

The Unpaint Selection command is used to unpaint any art existing inside a selection. You must first
draw a selection using the Select tool in order for this command to be available.

The Unpaint Selection on All Drawings command is used to unpaint all art contained inside a selection
on all the drawings within the same layer.
You must enable the Permanent Selection
option in the Select tool Tool Properties view and then
select an area of your drawing using the Select tool in order for this command to be available. The
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Permanent Selection option lets you maintain the same selection throughout the drawings of a same
layer.

The Unpaint Outside Selection command is used to unpaint any art existing outside a selection. If no
selection have been drawn using the Select tool, the entire drawing will be unpainted.

The Unpaint Outside Selection on All Drawings command is used to unpaint all art outside a selection
on all the drawings within the same layer. You must enable the Permanent Selection
option in the
Select tool Tool Properties view and then select an area of your drawing using the Select tool in order
for this command to be available. The Permanent Selection option lets you maintain the same
selection throughout the drawings of a same layer.

How to access the Repaint Selection command
‣

From the top menu, select Drawing > Paint > Repaint Selection.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection.

How to access the Repaint Selection On All Drawings command
‣

From the top menu, select Drawing > Paint > Repaint Selection On All Drawings.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Repaint Selection On
All Drawings.
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How to access the Repaint Outside Selection command
‣

From the top menu, select Drawing > Paint > Repaint Outside Selection.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside
Selection.

How to access the Repaint Outside Selection on All Drawings command
‣

From the top menu, select Drawing > Paint > Repaint Outside Selection on All Drawings.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Repaint Outside
Selection on All Drawings.

How to access the Unpaint Selection command:
‣

From the top menu, select Drawing > Paint > Unpaint Selection.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection.

How to access the Unpaint Selection On All Drawings command:
‣

From the top menu, select Drawing > Paint > Unpaint Selection On All Drawings.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Selection On
All Drawings.

How to access the Unpaint Selection command
‣

From the top menu, select Drawing > Paint > Unpaint Outside Selection.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside
Selection.

How to use the Unpaint Outside Selection On All Drawings command
‣

From the top menu, select Drawing > Paint > Unpaint Outside Selection On All
Drawings.

‣

From the Camera or Drawing view menu, select Drawing > Paint > Unpaint Outside
Selection On All Drawings.

Selecting a Colour in a Drawing
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While working in your Drawing view, you can use the Dropper tool to pick a colour from your drawing
without going to the Colour view.

How to use the Dropper tool
1. Do one of the following:
‣

In the Tools toolbar, select the Dropper

‣

Press Alt + D.

tool.

2. In the Drawing view, click on the desired colour.
‣

If you are using another drawing tool such as the Paint tool, you can temporarily hold down
the D key and click in your drawing before releasing the key to pick your colour. When you
release the key, Toon Boom Harmony will return to your previous tool. You may also want
to select the zones painted with the colour currently selected in the Colour view. This can be
useful for removing rough lines from a clean drawing.

How to select the zones painted with the current colour
1. In the Colour view, select the colour you want to select the corresponding zones from.

2. Do one of the following:
‣

Press Ctrl + Shift + A (Windows/Linux) or ⌘ + Shift + A (Mac OS X).
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Importing Models

Once you have a fully painted drawing, you can use it as a colour model and load it in the Model view.
That drawing can be used and loaded in any of your Harmony scenes.
Once a drawing is loaded in the Model view, you can use the Dropper
to select a colour from the
model and use it to paint in your Camera or Drawing view without having to pick the colour from the
colour palette.
You can do more than just copy colours from a colour model. Harmony gives you the ability to copy
parts of the character directly from its colour model and paste these elements into the Drawing or
Camera views.

How to browse for a colour model drawing on your hard drive
1. Do one of the following:
‣

From the Model View menu, select Import Model.

‣

Click the Import Model

‣

Select File > Import > Colour Model.

button or from the Model View’s toolbar.

2. In the Browser window, browse for any *.tvg drawing file on your hard drive or in the database.
3. Click Open.
The model appears in the Model view.

How to load the default models
1. In your scene’s folder, create a new folder and name it models.
2. On your hard drive copy the *.tvg drawing file you want to use as colour models in your scene.
3. Do one of the following:
‣

From the Model View menu, select Load Default Model.

‣

In the Model View toolbar’s extra buttons, click the Load Default Model

How to clear a colour model
‣

In the Model View menu, select Clear Model or press Delete.
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How to copy the entire model from the Model view
1. In the Model view’s toolbar, select the Select

tool.

2. In the Model view, select your model.

3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘ +
C (Mac OS X).
4. Select either the Drawing view then go to the top menu and select Edit > Paste Drawing Objector
pressCtrl + V (Windows/Linux) or ⌘ + V (Mac OS X).
The model now appears in the selected view.

How to copy part of the model from the Model view
1. In the Model view’s toolbar, select the Cutter

tool or press Alt + T.

2. In the Model view, use the Cutter tool to create a selection around the part of your model that you
want to copy.

3. From the top menu, select Edit > Copy Drawing Object or press Ctrl + C (Windows/Linux) or ⌘ +
C (Mac OS X).
4. Do one of the following:
‣

Select the Drawing view and select Edit > Paste Drawing Object.

‣

Select the Timeline view and select Edit > Paste cells in the Timeline or press Ctrl + V
(Windows/Linux) or ⌘ + V (Mac OS X).
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The model appears in the selected view.

Editing Gradients and Textures

If you paint a zone with a gradient or texture colour, you can use the Edit Gradient/Texture tool to
modify its position in the zone. You can move, scale, rotate and skew. If you want to match the colour
to the animation, set the first texture position and copy the Edit Gradient/Texture position. When
moving to the next drawing, you can select the next texture and paste the previous position to
continue the modifications.
If you are painting a hand-drawn animation or if your want the Brush tool and Paint tool to use your
gradient’s position, angle and scale settings instead of the default ones, you can store your own
settings and reuse them afterward.
This way of editing a texture using the Edit Gradient/Texture tool also works with pencil lines drawn
with textured “brushes”. If you then paint your textured pencil line with a gradient, you can do so and
then edit both elements independently at the same time.

How to use Edit Gradient/Texture tool
1. Do one of the following:
‣

In the Tools toolbar, click the Edit Texture

‣

From the Drawing View menu, select Drawing Tools > Edit Gradient/Texture

‣

Press Shift + F3.

tool.

2. Click the gradient or texture colour to modify.

A blue selection frame surrounds the selected gradient or texture.
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3. Edit the gradient or texture by adjusting the control handles around the selection frame.

How to store your gradient and texture settings
1. In the Tools toolbar, select the Select

tool or press Alt + S.

2. In the Drawing view, select the gradient or texture zone to store.

3. In the Tool Properties view, click the Store Colour Gradient

button.

How to use the stored gradient and texture settings
1. In the Tools toolbar, select the Brush

or Paint

tool.

2. In the Tool Properties view, click the Use Stored Colour Gradient

button.

3. In the Drawing view, draw and paint.

How to use Pencil Editor tool to edit the texture or gradient on a pencil line
1. Do one of the following:
‣

In the Tools toolbar, select the Pencil Editor

‣

Press Alt + W.

tool.

2. Click on the pencil line to be modified to bring up its contour envelope.
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3. Select one of the contour points around the envelope and move its position to change the size of
the tiled texture or gradient. You can also pull directly on the lines of the contour envelope or play
with the Bezier handles of any given point in order to continue to modify the envelope form.

Expanding the width of the envelope parallel to the pencil line’s central vector will cause the tiled
texture to be stretched. Conversely, reducing the envelope’s width will cause the tiled texture to
look squashed.
Reducing the contour’s width perpendicular to the pencil line’s central vector will reduce the
number of tiles, while expanding it will increase the number of tiled images.

This editing technique does not just work on texture fills, but can also be applied to pencil lines
drawn with a textured “brush”.

How to use Edit Gradient/Texture tool to edit the texture or gradient on a pencil line
1. In the Tools toolbar, select the Edit Gradient/Texture

tool. You can also press Shift + F3.

2. Click on the pencil line to be modified to bring up the editor controls.

242

Toon Boom Harmony 11.1 Paint Guide

3. The editor controls delineate a single tile in the texture. For gradients, this is less applicable. Pull
on the top of the editor controls to stretch the tiled texture throughout the length of the stroke.
As gradients are parallel to the stroke’s central vector, this will stretch the way that the gradient is
distributed in the pencil line’s envelope. The envelope still acts as a boundary for the texture or
gradient.

4. Drag the editor control perpendicular to the stroke. You will feel it glide along the strokes central
vector line. This is another way to resize the texture tile. Instead of stretching or shrinking it
vertically, this motion stretches or shrinks it vertically. As gradients are parallel to the pencil line’s
central vector, stretching them vertically gives no visual result.

243

Chapter 8: Ink and Paint Importing Models

How to use Edit Gradient/Texture tool to edit both the texture and the gradient of a
pencil line
1. Do one of the following:
‣

In the Tools toolbar, select the Edit Gradient/Texture

‣

Press Shift + F3.

tool.

2. Click on the pencil line to be modified to bring up the editor controls.

3. Use the top editor controls edit the gradient.

4. Use the bottom controls edit the “brush” texture.
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Closing Gaps

When painting, you may notice that some drawing areas are not closed. To close the zone, you can
either draw the missing line with the Brush or Pencil tool, or close the gap with an invisible line using
the Close Gap tool.
The Close Gap tool lets you close small gaps in a drawing by creating small, invisible strokes between
the two closest points to close the colour zone. You do not need to trace directly over the gap. You
can draw it a few millimeters away. The two closest points automatically close the gap.

How to close gaps
1. From the top menu, select View >Show Strokes or press K to see a preview of the result.
option in the Tool Properties view if you want the strokes you draw to
2. Enable the Auto-Flatten
be flattened in your drawing instead of being on top.
The Close Gaps dialog box opens.
3. Adjust the slider to set the size of the gap you want to be closed.

4. To close all gaps in the drawings of the selected layer, select the Apply to all drawings option and
click OK.
5. In the Tools toolbar, select the Close Gaps

tool.

6. In the Drawing view, trace a line near the gap to be closed. Your strokes will be invisible
The gap automatically closes.
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Protecting Colours
When you are finished painting some zones, you can protect the colour swatch they are associated
with, so the work cannot be accidentally painted over.
When you are done inking one colour, you can lock it so that if you ever paint over it accidentally, the
work already done will not be affected. You can also use the Protect Colour feature to block the filling
colours if you painted all of the animation in Line Art and you plan to repaint the lines.

How to protect colours
1. In the Colour view, select the colour to be protected.

2. Do one of the following:
‣

Right-click and select Protect Colour.

‣

From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.

Respecting Protected Colours
When painting, the Respect Protected Colour
option is enabled by default. In the Colour view, you
can protect a colour swatch to avoid repainting or unpainting the zones linked to that swatch. If you
disable this option, the Paint tool will not follow the protect colour rule and you will repaint or unpaint
the protected colours on your drawings until you enable the option again.

How to toggle the Respect Protected Colours option
Do one of the following:
‣

Paint tool properties, click the Respect Protected Colour

‣

Press Shift + S.

button.

Highlighting the Selected Colour
The Highlight Selected Colour option is used to identify colour swatch used in a drawing. For example,
if you have unnamed colours in your palette and want to know if a particular colour was used on the
current model or drawing, you can select the colour and use the Highlight Selected Colour option.
Harmony will dim all the colours in the drawing except the selected one, so it stands out and can be
identified. You can rename it accordingly.
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How to use the Highlight Selected Colour option
1. In the Colour view, select the colour you want to highlight.
2. From the Drawing menu, select View > Show > Highlight Selected Colour.

Inverting a Colour Selection
When you need to select all colour swatches but one, or select only a few swatches here and there, it
might be faster to select the only colour you do not need, in order to select and invert the selection.

How to invert a colour swatch selection in the Colour view
1. In the Colour view, select the colour swatch you DO NOT want to have in your final selection.

2. Do one of the following:
‣

From the top menu, select Edit > Invert Selection.

‣

Press Ctrl + Shift + I (Windows/Linux) or ⌘ + Shift + I (Mac OS X).
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Inking the Lines
Some animation styles require you to paint the lines, a process also be called inking. To ink your lines,
you must be in Line Art mode. You can repaint any type of lines including the texture lines—see Art
Layers on page 226.
Unless you are repainting all of the lines on the whole animation sequence, do not use the Apply Tool
to All Drawings option. Since the line positions change a lot over time, you risk painting lines that are
not supposed to be painted.
These are the main tools used to ink the lines:
•

Repaint Tool

•

Repaint Brush Tool

•

Ink Tool

•

Protecting Colours

The main tool used to ink the lines is the Repaint tool. As the colour filling is probably done in the
Colour Art, you will not have to worry about not touching it. The Repaint tool will not paint empty
zones either.
During the vectorization process on traditional scanned drawings, triangles are added on the lines'
intersections to break the artwork in segments. This way, when you paint a line, it will not repaint the
whole drawing, only the relevant segment.

The Repaint Brush tool is used to paint a section by manually painting over the lines. This is useful
when the vectorization triangles are not placed as you would like or you simply need to repaint a
section of a segment. It is also useful for paperless animation, where there are no triangles. So, the
Repaint Brush is used to paint a certain area. It acts like the Brush tool, but will only show on painted
areas that are already painted.
Unlike the Brush tool, the Repaint Brush flattens automatically. The brush strokes are not added one
on top of each other.

When you are done inking one colour, you can lock it so if you ever paint over it accidentally, the work
already done will not be affected. You can also use the Protect Colour feature to block the filling
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colours if you painted all of the animation in Line Art and you plan to repaint the lines—see Protecting
Colours on page 247.
The Brush tool is often the most intuitive and rapid tool for creating rough sketches and clean lines. A
single colour, such as black, is often used when tracing a clean version of a rough sketch. However,
when it comes time to soft trace the lines in different colours, the flattened or unflattened clean brush
strokes can suddenly become time consuming to ink.
Toon Boom Harmony lets you create triangular breaks at natural line intersections. These
intersections are the probable locations where colour line breaks may occur, such as where a sleeve
meets a hand.
Although pencil lines can be painted in much the same way as closed zones, you can use the Paint,
Repaint, Repaint Brush, and Ink tools to make painting segmented lines easier. Normally when you
have a drawing, such as the one below, and you use the Paint tool to paint one of the lines, the entire
line is painted.

However, if you select the Ink
tool instead and click on the same pencil line, only the segment that
you clicked on between two intersections will be painted.

The newly inked segment will always be moved to the front of all other pencil strokes, even if it was
behind all other pencil strokes before it was inked.

That is, unless you hold down Alt while clicking a segment. Then the opposite becomes true. The inked
segment will be sent to the back, even if it was in front of all other segments to begin with.
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Painting and Inking can be used in combination depending on what it is that you need to paint. If you
need to ink a character’s outline in black, it might be easier to use the Paint tool. If you need to paint
the outline of a character’s neck with a tan colour and its shirt outline blue and both the neck and shirt
belong to the same continuous outline, then the Ink tool might prove more useful.

How to select the Repaint Tool
1. In the Tools toolbar, select the Repaint

tool located in the Paint tool drop-down menu.

How to select the Repaint Brush
1. In the Tools toolbar, select the Brush

tool.

2. In the Tool Properties view, enable the Repaint Brush

mode.

How to select the Ink Tool
1. In the Tools toolbar, select the Ink

tool located in the Paint tool drop-down menu.

How to protect colours
1. In the Colour view, select a colour to lock.

2. Do one of the following:
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‣

Right-click and select Protect Colour.

‣

From the Colour view menu, select Colours > Protect Colour.

A red bar appears beside the colour to indicate that it is locked.
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Verifying the Zones are Painted
When the ink and paint process is completed, it is always a good idea to verify that every zone was
painted properly.
The backlight produces a silhouette effect by changing the drawing’s coloured areas into a single
dark, solid colour use this to verify the completeness of the ink and paint process. Any unpainted
zones can be seen as the light shows through the unpainted areas of the silhouetted drawing.

How to use the backlight

This feature is only available in the Drawing view.

1. Do one of the following:
‣

From the top menu, select View > Backlight.

‣

In the Drawing View toolbar, click the Backlight

‣

Press Alt + Shift + B.

button.

2. Verify the drawings in the Colour Art to make sure that all the areas are painted. In the Colour
View, click on the Colour Art button.
3. In the Colour View, click on the Preview button to see the colour zones with lines to ensure that you
did not forget any spots between the colour filling and lines.
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Ink and Paint Tool Properties
The Ink and Paint tool properties contain many options that will help you along with your task.
•

Ink Tool Properties below

•

Paint Tool Properties on the facing page

Ink Tool Properties
When you select the Ink tool, its properties and options appear in the Tool Properties view.

Icon

Tool Name

Tool
The Lasso and Marquee options let you
choose the type of selection the current tool
will perform. The default selection mode is
Marquee.
•

Lasso
lets you draw a custom
selection box around zones.

•

Marquee
makes a rectangle
selection box.

Hold down the Alt key to switch
to the opposite mode of your
selection.

Lasso and Marquee

How to invert a selection
1. Do one of the following:
‣

From the top menu, select Edit >
Invert Selection.

‣

From the Drawing menu, select
Edit > Invert Selection.

‣

Press Ctrl + Shift + I
(Windows/Linux) or ⌘ + Shift + I
(Mac OS X).

Highlights all pencil lines (no brush strokes)
on the selected layer. Pencil line segments
that are already inked with the selected
swatch colour from the colour palette are
also not highlighted.

Show Inkable Lines
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As you hover and move the cursor across
intersecting pencil lines, the path that you
create will be highlighted. When you click on
your mouse or stylus the highlighted
segments are inked.
Be Smart on Connecting Lines

With this option disabled, all the intersecting
segments that your cursor comes near will
be highlighted and become part of the
selection, even if they were not situated in
the direction of the chosen path.
Note: This option only works if the Ink tool
is in Hover mode.

Select Mode

Use this
mode instead of the Hover
Mode. In the Hover Mode, any potentially
inkable pencil line will have its central vector
line highlighted as the Ink tool’s cursor
hovers over it. Use Ctrl (Windows/Linux) or
⌘ (Mac OS X) to toggle between the two
modes.

Select Newly Painted,
Repainted, Unpainted
Contours and Lines

Keeps a selection highlighted around the
latest painted zone after using the Paint,
Repaint, Unpaint, or Paint Unpainted tool.

Arrange Ink Lines

Brings all newly-inked lines to the front. Disable this
option if you want all newly-inked lines to be sent to
the back. Press Alt to toggle between the two options.
As you hover over two perpendicular or
nearly perpendicular segments, a
highlighted path with a corner is created.
Clicking on these highlighted segments inks
both segments and makes them appear as a
single stroke with a corner or bend.

Mitre

Click the Mitre
button to choose from
As is, Round, Mitre, and Bevel.

Lets you customize the edge of the Ink tool.
Options include: Round, Flat, and Bevel.
Tip Style

Paint Tool Properties
When you select the Paint tool, its properties and options appears in the Tools Properties view.
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Icon

Tool
Lasso and Marquee below
Painting Modes below
Paint and Remove Texture on page 258
Apply to Multiple Drawings on page 258
Apply to All Visible Drawings on page 259Apply to All Visible
Drawings on page 259
Respect Protected Colour on page 259
Use Stored Colour Gradient on page 260
Select Newly Painted/Repainted/Unpainted Contours/Lines on
page 260
Automatic Close Gap on page 260

Lasso and Marquee
The Lasso and Marquee options let you choose the type of selection the current tool will perform. The
default selection mode is Marquee.
•

Lasso

lets you draw a custom selection box around zones.

•

Marquee

makes a rectangle selection box.

Hold down the Alt key to switch to the opposite mode of your selection.

How to invert a selection
1. Do one of the following:
‣

From the top menu, select Edit > Invert Selection.

‣

From the Drawing menu, select Edit > Invert Selection.

‣

Press Ctrl + Shift + I (Windows/Linux) or ⌘ + Shift + I (Mac OS X).

Painting Modes
The Paint tool has four different modes available:
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You can also find these tools directly in the Tools toolbar and in the Drawing Tools menu.

Paint Mode

The Paint

mode paints everything it touches, including empty and filled zones.

Paint Unpainted Mode

The Paint Unpainted

mode paints only empty zones. Any line or filled zone will remain unchanged.

Repaint Mode

The Repaint
mode paints everything it touches except empty zones. Any zone that is not painted
will remain intact.
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Unpaint Mode

The Unpaint

mode unpaints everything it touches, including empty and filled zones.

Paint and Remove Texture

The Paint and Remove Texture
option is used when you vectorized images as greyscale texture
style. An image vectorized as texture is a mix of bitmap filling encapsulated in a vector-based frame.
Painting a textured zones with the Paint tool will change the tint of the textured lines. Painting the
textured zones using the Paint and Remove Texture option transforms the bitmap filling into a 100%
vector based zone and fills it with a solid colour.

Apply to Multiple Drawings
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The Apply to Multiple Drawings
option is used for fast painting in hand-drawn animation. When
you want to paint several drawings in a same layer at once, such as a walk cycle, you can enable this
option and make a selection in your Camera or Drawing view. All the closed zones located within your
Paint tool selection are painted with the selected colour swatch.
You do not need to enable the Onion Skin preview to use this option. The option will stay enabled only
for the next action. If you want to use it again, you must click on the Apply to Multiple Drawings
button again, or press Alt + A.

Apply to All Visible Drawings

The Apply to All Visible Drawings
option is used to paint several drawings on separated layers on
the current frames. If you have a character broken in several layers, you can enable this option to paint
all your layers at once. The operation is only applied on the current frame. This option will stay enabled
only for the next action. If you want to use it again, you must click on the Apply to All Visible Drawings
button again.

This option is only available in the Camera view and does not affect symbols.

Respect Protected Colour
The Respect Protected Colour
option is enabled by default. In your Colour view, you can protect
some colour swatches to avoid repainting or unpainting the zones linked to that swatch.
If you disable this option the Paint tool will not follow the protect colour rule and will repaint or
unpaint the protected colours on your drawings until you enable the option again—see Protecting
Colours on page 247.
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Use Stored Colour Gradient

When you paint a zone with a gradient or textured colour swatch, the gradient or texture’s position is
set relative to the size of the zone your are painting. If you want the Paint tool to use a particular size
and position, you must first store your desired position and size using the Select
tool and then
enable the Use Stored Colour Gradient
option in the Paint tool Tool Properties view—see Editing
Gradients and Textures on page 240.

Select Newly Painted/Repainted/Unpainted Contours/Lines

In the Paint tool Tool Properties view, enabling this option
will keep a selection highlighted
around the latest painted zone after using the Paint, Repaint, Unpaint, or Paint Unpainted tool.

Automatic Close Gap
The Automatic Close Gap option has four modes available:
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The Automatic Close Gap
options are used while painting drawings with small gaps.
Instead of having to close them manually with the Brush tool or Close Gap tool, Toon Boom Harmony
will analyze the drawing and close the gaps while you paint according to the selected mode. The
automated gap closing should be done using the zoom function setting of your Camera or Drawing
view. If your eye does not see the gap, Toon Boom Harmony won’t either—see Closing Gaps on
page 245.
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Glossary

alpha channel

The image's channel carrying the transparency information. An
image already has three channels: red, green and blue (RGB). The
alpha channel is the fourth channel (RGBA). The matte, or the
transparency information, is stored in this fourth channel. An image
without an alpha channel is always opaque.

animatic

A movie with sound that is developed from the storyboard. The
storyboard panel is exposed for the duration of the scene and at
times, the characters are placed on a trajectory to indicate motion.
The camera moves are also animated. The animatic is used to
determine the rhythm of a project and provides a good overview of
the project before beginning production.

animation

A simulation of movement created by displaying a series of pictures
or frames.

anime

An animation style known for its sinister and dark feel; popular in
Japan.

arc

Action rarely occurs in a straight-forward manner; rather it typically
unfolds in what storytellers refer to as an arc. The purpose of a
story arc is to move a character or a situation from one state or
scenario to the next.

aspect ratio

The relationship between the width and height dimensions for any
scene, frame or film format. Television ratio is 4:3 and widescreen
ratio is 16:9.

auto-feed

An automated method of feeding drawings into a scanner in which
multiple drawings are stacked into a sheet feeder. When the
scanner is activated, the drawings are scanned consecutively,
without further user intervention.

automatic lip-sync detection

Automatically mapping drawings in an element to the mouth chart
generated for a sound. This can save time when lip-syncing a voice
track.
An imaginary line around which an object rotates.
For 2D graphics, there are two axes:

axis

•

X: Horizontal

•

Y: Vertical

For 3D graphics, there are three axes:
•

X: Horizontal

•

Y: Vertical

•

Z: Depth

background

The part of a scene that is farthest to the rear. The background is
the artwork, or decor, against which the animation takes place.

Bézier

A method of defining curved lines invented by French
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mathematician Pierre Bézier. A Bézier curve is a mathematical or
parametric curve. Bézier curves use at least three points to define a
curve.
In Toon Boom, a function can be hooked to a Bézier curve and vary
along with the curve value information. Bézier curves are also very
useful in vector graphics. They are used to model smooth curves
and can be scaled indefinitely.
bitmap

An image composed of pixels with a single resolution (size). If it is
enlarged too much, it will lose definition and pixels will begin to
appear. This is known as pixelation.
In cut-out animation, breakdown is the action of breaking a
character into pieces to create a puppet with articulations. To
break down a character, the artist cuts part, such as hands and
arms, from the character's model and pastes them in separate
layers. Next, the joints are fixed and the pivots set.

breakdown

In traditional animation, a breakdown is an animation pose
generally found between two key poses. The key poses are the
main poses in an animation and the breakdowns are secondary
poses, ones that help to describe the motion and the rotation
curve.

camera shake

Camera shake occurs in a scene when the camera moves slightly
and quickly in several directions. This gives the impression of an
impact, vibration or, for example, bumps on the road.

caption

In a storyboard, a caption is a text field containing dialogue,
effects, sound, or slugging information.

cel

In traditional animation, a cel, also known as a celluloid, is a
transparent sheet on which the animation is inked and painted
before being sent to the camera.The picture's outline is drawn on
the front of the cel and then coloured along the back.
In Toon Boom, a cel is an individual space encountered in an
Xsheet's column, from which you can expose a drawing or a
function`s coordinate.

character design

Each character in an animated film is drawn from multiple angles in
poster-style format, called a model sheet, which serves as a
reference for the animators.

clean up

After rough drawings have been tested and approved, all the noise
in the image (excess lines, notes, etc) is removed to create final
drawings which can be inked, painted and shot. The cleanup
process refers to either tracing a clean line over a rough drawing to
achieve the final version, or removing dirt and extra lines left by the
scanning process.

CMYK

Cyan, Magenta, Yellow, Black. Refers to the process used by
printers to define colour on the printed page.

colour card

A Colour Card is a solid colour card that is the same size as the
camera. The Colour Card can be used to fill the background with a
solid colour when there is no background image included.
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colour model

In animation, a colour model is the official colour design that must
be used to paint the animation. A model is the definitive character,
prop, or location design that each artist must follow for the
production.

colour wheel

A display of the colour spectrum in the form of a circle.

compositing

Compositing is the action of incorporating all of a scene's elements
to create the final result prior to rendering. For example, the
compositing artist will import all the animation sequences,
background, overlays and underlays in the scene and position them
correctly. The artist will then set the camera frame and animate it, if
needed. Finally, the animator will create all the computergenerated effects for the project.

cross dissolve

An effect used to fade two scenes, one into the other.

cut

A direct transition between two scenes. When a cut is used, there
are no transition effects inserted to pass from one scene to the
next. The first scene ends and the second one starts immediately.

cut-out animation

The action of animating characters made of several pieces by
moving them around frame by frame. Cut-out animation can either
be computer generated or done traditionally using paper.

cycle

A group of images that together make up an action, such as
walking. A cycle is an action repeated as a loop over a period of
time. It can be a series of animated drawings or keyframes.

dialogue

The text spoken by a character in a movie or animation.

dope sheet

Used by animators, directors and other members of a crew to
track the sequence and timing of images, dialogue, sound effects,
sound tracks and camera moves. Also known as an exposure sheet
or Xsheet.

doping

To assig a particular drawing to a range of frames.

DPI

Dots Per Inch is the standard measure of resolution for
computerized printers. It is sometimes applied to screens, in which
case it should more accurately be referred to as pixels per inch.
Either way, the dot is the smallest discrete element making up the
image.

ease/velocity

In animation, the ease, also known as velocity, is the acceleration
and deceleration of a motion. It can be a motion created by a
function curve, or a series of animated drawings. Other common
terms for ease-in and ease-out are slow-in and slow-out.

ease-in

Gradual acceleration in the action. Another common term for easein is slow-in.

ease-out

Gradual deceleration in the action. Another common term for easeout is slow-out.

establishing shot

A scene in which the viewer can see the whole area in which a
sequence is happening. For example, if a child is playing on the
ground in front of his house, the establishing shot would be a scene
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where the viewer can see the house, the ground, a part of the
street and the buildings around the central point of action. This
helps the viewer understand the story location and scene
orientation.
exposure

In animation, an exposure is the number of cels on which a drawing
appears in the scene. For a drawing to appear longer, the
exposure must be extended over a greater number of cels.
The exposure sheet or Xsheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

exposure sheet (Xsheet)

Each column represents a scene's layer. In each column, the
drawing's numbers are indicated and repeated over the particular
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a dope sheet.

fade in/fade out

Fade in or fade out is a transition effect used to open or close a
sequence. A fade in occurs when the first scene appears
progressively, from complete transparency to its complete opacity.
A fade out occurs when the last scene progressively disappears,
going from complete opacity to complete transparency.

fast-in

Dramatic acceleration at the start of the action.

fast-out

Dramatic acceleration at the end of the action.

field

In animation, a field is a measurement unit used to calculate
motion, registration and camera positioning. A standard animation
scene will vary between 6 to 12 fields.

field chart

A guide containing all the field units that animation and layout artists use to
determine a scene size or camera motion.

film-1.33

Use this resolution setting for the widescreen film format that
conforms to the standard 4:3 pixel aspect ratio.

film-1.66

Use this resolution setting for the widescreen film format that
conforms to the 16:9 pixel aspect ratio. (The pixels are wider than
they are high).

flipping

In traditional animation, flipping is the action of going through the
drawings of an animation sequence very quickly in order to see the
animation in motion. Flipping can also be the action of creating a
mirror transformation of an object.

follow-through

The follow-through is the secondary motion caused by the main
action. For example, a character wearing a cloak is running. The
main action is the body running. This will cause the cloak to follow
the motion, although it will not move at the same time, but react a
few frames later and follow the main motion curve.

forward kinematics

Forward kinematics is a feature used to animate principally 3D
characters and cut-out puppets with hierarchy. It is used to animate
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a puppet from one of parent parts, such as a shoulder, and make
the rest of the arm move with it as a single piece.

frame

A frame is a single photographic image in a movie. In traditional
animation, the North American standard generally contains 24
frames per second, while in Europe the standard is 25 frames per
second.
This is the measurement of the frequency (rate) at which an imaging
device produces unique consecutive images, called frames. The
term applies equally to computer graphics, video cameras, film
cameras, and motion capture systems.

frame rate

Frame rate is most often expressed in frames per second (FPS) and
in progressive-scan monitors as hertz (Hz).
The frame rate is the speed at which the frames are played. They
are generally calculated by frame per second. For example, a scene
could be played back at 12, 24, 25, 30 or 60 frames per second or
any other number

functions

A function is a computer generated motion, trajectory or path that
elements, other trajectories and effects parameters can be
attached to. The function can be controlled by adding keyframes
and control points on the function curve.

gamut

The range of colours that a particular device can represent.

HDTV

High Definition Television delivers a higher quality image than
standard television does because it has a greater number of lines
of resolution. To take advantage of the superior quality and make
full use of your resolution setting, your output device must be
compatible with HDTV technology.

hold

This is a frame in the animation in which the character maintains its
position without moving. A hold can be created between any two
keyframes.

HSV

Hue, Saturation, Value. A method of defining colours in terms of
hue (tint), saturation (shade) and value (tone or luminance).

in-between

The drawings that exist between the key poses. These are drawn
to create fluid transitions between poses.

ink and paint

The ink and paint process is the action of painting the empty zones
and colouring the lines on the final animation drawings, while
following a colour model.

interpolation

In animation, the interpolation is the computer generated motion
created between two keyframes. You have the choice to create
interpolation, or not, between your keyframes.

jump cut

A jump cut is a jerky cut between two scenes. Typically, a jump cut
is not visually pleasing. It is generally caused by one scene ending,
and a second one starting, with similar a image. The lack of
difference causes the eye to see a little jump between the two
scenes.
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key pose

Important positions in the action defining the starting and ending
points of any smooth transition. Keys, or key poses, are the main
drawings in an animation sequence describing the motion. For
example, if an arm is waving, the keys will be of the arm at one
extremity of the wave motion and the other extremity. By flipping
those drawings, the animator can see the skeleton of the motion
without having all of the drawings.
One or more keyboard keys which, when used, cause an operation
to be performed. Keyboard shortcuts are used throughout the
Toon Boom software and form an integral part of the workflow. It
is, in most cases, possible to customize the shortcuts in the
Preferences dialog of the software.

keyboard shortcuts

The shortcuts are written as follows in the Toon Boom user
documentation: Each key in a sequence is shown inside square
brackets as in: [Ctrl]+[A]. The brackets "[ ]" separate the key from
the plus sign (+). Neither the brackets, nor the plus sign are part of
the sequence. To use a shortcut, press the key and the character
simultaneously.

keyframe

Important positions in the action defining the starting and ending
points of any action. A keyframe is a computer generated position
at a specific moment (frame) on a given trajectory.

layer

In animation, a layer is an individual column, level or character. A
scene's layers are superposed to form the final image.

layout

The layout process is the communication step between the
storyboard and the animation. The layout and posing process is
the action of putting the storyboard on model, that is drawing the
character following the design in the model pack, so that the
animator can start his work. The layout artist will draw the
background, create the camera and field guide matching the scene
and the camera motion. Lastly, he will draw on model the main
action poses.

layout and posing

The action of putting on model, that is, at the right scale, the
storyboard for the animator to start his work.

library

A library is a storage area containing templates and assets that can
be reused in any project or scenes.

light table

The Light Table feature allows you to see the other layers in
transparency while you are working on a particular one in the
Drawing view.

line of action

Direction that the action will follow. Also known as the Path of
Action

lip-sync

The lip-sync is the character`s mouth synchronization with the
dialogue sound track. Frame by frame, the mouth will be adjusted
to fit the sound to give the illusion of the character is speaking.

low resolution

This format is ideal for videos destined for the web, where size and
fast download of a video file might take precedence over quality. A
low-resolution image is one that lacks fine detail.
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manual lip-sync detection

The manual swapping of mouth position drawings to match a voice
track. For this process, both sound scrubbing (listening to a sound
wave broken up frame-by-frame) and drawing substitutions from
the Library view are used.

master palette

A master palette is a group of colours attributed to a character or
a prop. The palette is used throughout the entire production to
maintain consistency in the look and to ensure that the same
colours are used throughout the production. Also known as
palette.

model/colour model

In animation, a model is the definitive character, prop or location
design that each artist must follow for the production. A colour
model is the official colour design that must be used to paint the
animation.

motion keyframe

In Toon Boom, the motion keyframe is a keyframe with computergenerated interpolation.

mouth chart

Adding a lip-sync to a project can really enhance its quality and
storytelling. However, it can be difficult to shape a character's
mouth so that it matches the sound at the precise frame. To solve
this problem, Toon Boom provides a lip-sync feature which
analyses the contents of a sound element and generates a mouth
chart based on the eight animation phonemes (A, B, C, D, E, F, G,
and X, which is used to represent silence).

multiplane

The effect of passing through multiple levels of drawings to create
a sense of depth in a shot. A multiplane is a scene in which the
layers are placed at different distances from the camera so that
when the camera moves, a depth illusion occurs. With a multiplane,
all the perspective and scale is calculated automatically.

NTSC

The standard analogue television broadcasting system used in
North America. NTSC conforms to North American standards on
how rectangular pixels are displayed for computer and television
screens.

nudge

A small push (left, right, up, down, forward or backward) done
with the keyboard arrow keys on a selected element. Nudging is
used to move a selection very slightly and precisely.

onion skin

A feature that lets you see the previous and next drawings of a
sequence.

overlay

A part of the scene environment, such as a chair or a bush, that is
placed in front of the main animation.

PAL

A resolution that works best with the European format for
television and computer screens, as the rectangular pixels are
displayed at a different orientation.

palette/master palette

A palette or master palette is a group of colours attributed to a
character or a prop. The palette is used throughout the entire
project to maintain a consistency in the look and avoid the colour
changing during the animation. Also referred to as a master
palette.
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palette style

A palette style is a second version of an existing palette with a
slight change in the tint and value. A palette style can be used to
create the night version of a palette. It may also be called a clone
palette.

pan

To move the camera across the scene in any direction.

panel

In a storyboard, a panel is a frame in a shot. A shot can be
composed of one or several panels.

paperless animation/tradigital

The paperless animation process is the action of animating
digitally. The main paperless animation process is to draw, frame
by frame, the animation directly in the software.

passing position

When drawing a walk sequence for a character, the passing
position is the point at which one leg passes the other.

path of action

Direction that the action will follow. Also known as the Line of
Action.

peg

In traditional animation, a tool used to ensure accurate registration
of action as cel layers move. In digital animation, in which you are
doing a more advanced puppet rigging, you can use peg layers.
Peg layers are trajectory layers that do not contain drawings. They
are motion paths that you can use to add path articulations. For
the latter, you can also use the Inverse Kinematics tool.

phoneme

Unit of sound in a language.

pivot

A pivot is the point around which a peg or a drawing rotates.
Smallest element of an image displayed on a monitor or TV screen.

pixel

Pixel, short for Picture Element, is a single point in a graphic image.
It is a small sample of an image, a dot, a square, or a very small
section made out of smooth filtering. If you zoom in close enough
on a digital image, you will see the pixels, which look like small
squares of different colours and intensity.

pose-to-pose animation

The pose-to-pose animation process is the action of creating all the
main action poses, called key poses, and then placing the
secondary poses between the keys. The secondary poses are
called breakdown. Finally, the animator fills the gaps with the inbetween drawings to achieve a smooth animation.

rendering

The final step when animating by computer. During rendering, the
computer takes each pixel that appears on screen and processes
all of the components as well as adding motion blur before it
produces a final image. In animation, the rendering process is the
action of calculating the final images after the compositing
process.

resolution

The resolution is the size of a scene, generally calculated in pixel.
For example, the NTSC resolution is 720 x 480. Resolution type
should match your final output: HDTV, film-1.33, film-1.66, NTSC,
PAL, low.

RGB

Red, Green, Blue: method of defining colour by specifying amounts
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of these three colour components.
rigging

The rigging process is the action of attaching the cut-out puppet
parts one to the other.

rotary table

The Rotary Table is equivalent to the animation disk/table and
allows one to rotate the workspace to be more comfortable while
drawing.

rotoscoping

Is an animation technique in which animators trace over live-action
film movement, frame by frame, for use in animated films. The act
of sketching over live-action footage to create an animated
sequence.

roughs

The roughs are the skeleton sketch of an animation or a design.
Roughs mainly consist of sketch lines and shapes, though they can
also contain design details.

safey area

In animation and movie parlance, the safey area is the zone at the
centre of the scene's frame, one safe from being cropped by the TV
frame. As a TV frame cuts a margin off the original frame size,
maintaining a safey area ensures that the scene's main action will
remain clearly visible once the film is screened on television.

scene

A scene is a shot in a movie or show. A sequence is composed of
several scenes. A scene changes to another scene by a simple cut,
or a transition.

script

The script is the original text containing all the movie or show
information. In animation, the script contains all of the location
descriptions, dialogues, time and more. A project starts with a
script.

sequence

In animation, a sequence is a series of scenes or shots forming a
distinct part of the story or movie, usually connected by unity of
location or time.

shot

A shot is a scene in a movie or show. A sequence is composed of
several shots. A shot changes to another shot by a simple cut, or a
transition.

slow-in

Gradual acceleration in the action. Another common term for slowin is ease-in.

slow-out

Gradual deceleration in the action. Another common term for slowout is ease-out.

slugging

In Storyboard Pro, slugging refers to indicating the start and stop
times of dialogue and relevant actions.

sound scrubbing

A process that lets you hear sound in real time while you move the
playhead forward or backward. This is very useful for finely-tuned
lip-syncing.

stop-motion keyframe

A stop-motion keyframe is a keyframe with no computer generated
interpolation.

storyboard

A visual plan of all the scenes and shots in an animation. The
storyboard indicates what will happen, when it will happen and
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how the objects in a scene are laid out.

straight-ahead

A technique in which an entire sequence is drawn from the first
position to the last, in order. There is very little planning in this
methodology, and where the character ends up and how it gets
there can be a surprise for both the audience and the animator.
While this approach is a lot more spontaneous and creative, it can
create inaccurate results.

strokes

Strokes are invisible vector lines forming the drawing zones. They
can be adjusted with Bézier handles.

tablet/pen

Device used in conjunction with, or instead of, a mouse to move a
mouse pointer (sometimes referred to as the cursor) around the
computer screen.

template

In Toon Boom, a template is an asset stored in the library, one that
can be reused in any project. A template can be a drawing, a series
of keyframes, a sound file, a panel, a cut-out character, an effect, a
trajectory, an animation, or anything else used in the software.

thumbnails

A thumbnail is a very small image used as a reference or indicator.

timecode

Timecode is timing information printed on a movie clip to indicate
what scene, hour, minute and second is currently displayed on the
screen.

timeline

The timeline is a horizontal representation of the scene`s elements,
timing and keyframes.

trace and paint

After the rough animations have gone through cleanup and a final
line or pencil test, each drawing is traced and painted for the final
animation. In today's digital world, this may be done in a variety
ways other than via the traditional celluloid or acetate methods.

track breakdown

The soundtrack for animated film is broken down into individual
sounds documenting the precise frame-by-frame position of each
sound.

traditional animation

The traditional animation process is the action of drawing on paper
all of the animation sequences, before either scanning them or
inking them on cels.

trajectory

A computer generated path or trajectory that elements can follow.
The trajectory can be controlled by control points, keyframes and
velocity.

transition

A transition is an effect placed between two scenes as they pass
from one to the other. Common transition effects are crossdissolve and wipe.

underlay

In animation, an underlay is a specific part of the decor placed
behind the main animation.

aspect ratio

The aspect ratio describes the shape of the grid unit. A square grid
unit would have the ratio 1:1, whereas a grid unit of aspect ratio
4:3 is a unit with one side 1.33 times as big as the other side.
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vector

A vector-based image is composed of points and Bézier curves.
The computer reads the points and traces the segments, linking
them to reproduce the image shape. There is no fixed size or
resolution in a vector image. The graphic can be enlarged and
distorted as much as desired and the system will simply recalculate
the segments and rebuild the shapes. Vector images are translated
and displayed in pixels once the calculation is done.

velocity/ease

In animation, the velocity, also known as ease, is the acceleration or
deceleration of a motion. This can be achieved by a function curve,
or via a series of animated drawings. Other common terms for
ease-in and ease-out are slow-in and slow-out.

walk cycle

To avoid making innumerable drawings, animators routinely make
a walk cycle for their character. This comprises a series of drawings
``on the spot`` that describe the walk for that character. The illusion
of movement is created via the use of background pans.

workspace

In Toon Boom, the workspace is made up of the views, toolbars,
and menus.
The Xsheet or exposure sheet, is a sheet with several vertical
columns and horizontal frames used to indicate a scene's timing.

Xsheet (exposure sheet)

Each column represents a scene's layer. In each column, the
drawing numbers are indicated and spread over the specific
amount of frames they need to appear.
The exposure sheet is used by animators, directors and other
members of a crew to track the sequence and timing of images,
dialogue, sound effects, sound tracks and camera moves. Also
known as a Dope Sheet.

zone

An area which can be painted with colour.
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Index
about
Cloud module 20
Draw module 17
Harmony 15
Harmony Control Center 16
Paint module 19
Play module 19
Scan 18
Sketch module 18
Stage 17
Xsheet module 19
adding
views 42
alpha channel
_defined 262
animatic
_defined 262
animation
_defined 262
anime
_defined 262
arc
_defined 262
aspect ratio
_defined 262
defined 271
auto-feed
_defined 262
axis
_defined 262
background
_defined 262
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backing up
palettes 188
Bezier
_defined 262
bitmap images
_defined 263
bitmap resolution
height 104
resolution factor 104
width 104
breakdown
_defined 263
camera shake
_defined 263
caption
_defined 263
cel
_defined 263
celluloid
See cel. 263
character design
_defined 263
checking
colours 32
files, project 32
project files 32
clean up
_defined 263
clockwise
rotating 60
closing
views 42
Cloud module
about 20
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CMYK
_defined 263
colour card
_defined 263
colour model
_defined 268
defined 264
colour palettes
back up 188
location 185
storage location 187
switching display modes 49
Colour view 48
switching palette display modes 49
colour wheel
defined 264
colours
checking 32
commands
basic 34
compositing
defined 264
Control Center
about 16
counterclockwise
rotating 61
cross dissolve
defined 264
customizing
toolbars 46
cut
defined 264
cut-out animation
defined 264

275

Index

Ink and Paint Tool Properties

cycle
defined 264
dialogue
defined 264
dope sheet
defined 264
doping
defined 264
DPI
defined 264
Draw module
about 17
Drawing view 54
ease
defined 264
ease-in
defined 264
ease-out
defined 264
establishing shot
defined 264
exporting
palettes 187
exposure
_defined 265
exposure sheet
_defined 272, 265
fade-in
_defined 265
fade-out
_defined 265
field
_defined 265
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field chart
_defined 265
File toolbar 59
files
checking project files 32
film-1.33
_defined 265
film-1.66
_defined 265
flipping
_defined 265
follow-through
_defined 265
forward kinematics
_defined 265
frame
_defined 266
frame rate
_defined 266
functions
_defined 266
gamut
_defined 266
Harmony
interface 39
modules 15
starting 21, 23
Harmony Network
centralized database 22
interface 39
network connections 22
starting 21, 23
HDTV
_defined 266

277

Index

Ink and Paint Tool Properties

Help
Harmony 9
structure 10
hiding
views temporarily 43
Hold
_defined 266
HSV
_defined 266
in-between
_defined 266
ink and paint
_defined 266
integrity
project, checking 32
interface 39
interpolation
_defined 266
jump cut
_defined 266
key pose
_defined 267
keyboard shortcuts
_defined 267
keyframes
_defined 267
layers
_defined 267
layout
_defined 267
layout and posing
_defined 267
library
_defined 267
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light table
_defined 267
line of action
_defined 267
lip-sync
_defined 267
auto detection, defined 262
lip-sync detection
manual, defined 268
low resolution
_defined 267
manual lip-sync detection
_defined 268
master palette
_defined 268
exporting 187
menus 40
Message Log view 56
model
_defined 268
model sheet See character design
Model view 57
modules
Cloud 20
Control Center 16
Draw 17
Harmony 15
Paint 19
Play 19
Scan 18
Sketch 18
Stage 17
Xsheet 19
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motion keyframe
_defined 268
mouth
chart 268
moving
toolbars 45
multiplane
_defined 268
navigating 60
centering screen on mouse 61
panning 60
recentering view 60
resetting pan 60
resetting rotation 60
resetting views 60
resetting zoom 60
rotating clockwise 60
rotating counterclockwise 61
zooming in 60
zooming in or out 60
zooming out 60
network connection 22
NTSC
_defined 268
nudge
_defined 268
onion skinng
_defined 268
overlay
_defined 268
Paint module
about 19
PAL
_defined 268
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palettes
_defined 268
backup 188
exporting 187
location 185
storage location 187
style, defined 269
switching display modes 49
panel
_defined 269
panning 60
_defined 269
resetting 60
paperless animation
_defined 269
passing position
_defined 269
path of action
_defined 269
pegs
_defined 269
pen
_defined 271
phoneme
_defined 269
pipeline
Toon Boom 15
pivot
_defined 269
pixel
_defined 269
pixelation See bitmap image
Play module
about 19
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pose-to-pose
_defined 269
preferences 38
Preferences dialog box 38
product requirements
Harmony 13
Harmony Network 13
Harmony Stand Alone 13
projects
checking colours 32
checking files 32
colours, checking 32
files, checking 32
verifying integrity 32
recentering
view 60
rendering
_defined 269
resetting
pan 60
rotation 60
views 60
zoom 60
resizing
toolbars 45
views 42
resolution
_defined 269
factor, bitmap 104
height, bitmap 104
scene 104
width, bitmap 104
RGB
_defined 269
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rigging
_defined 270
rotary table
_defined 270
rotating
resetting rotation 60
rotating clockwise 60
rotating counterclockwise 61
rotoscoping
_defined 270
roughs
_defined 270
safe area
_defined 270
saving
scenes 29
Scan module
about 18
scene resolution 104
scenes
_defined 270
saving 29
script
_defined 270
scrubbing
_defined 270
sequences
_defined 270
shot
_defined 270
Sketch 18
about 18
slow-in
_defined 270
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slow_out
_defined 270
slugging
_defined 270
sound
scrubbing
_defined 270
Stage 17
about 17
starting
Harmony 21, 23
ToonBoomProductName 23
stop-motion keyframe
_defined 270
storyboard
_defined 270
straight-ahead
_defined 271
strokes
_defined 271
system requirements
Harmony 13
Harmony Network 13
Harmony Stand Alone 13
tablet
_defined 271
technical specifications
Harmony 13
Harmony Network 13
Harmony Stand Alone 13
templates
_defined 271
thumbnails
_defined 271
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timecode
_defined 271
timeline
_defined 271
Tool Properties view 58
toolbars 59
customizing 46
Edit 59
File 59
hiding 44
managing 44
moving 45
resizing 45
showing and hiding 44
Tools 59
top 59
view 59
tools
Zoom 61
Tools toolbar 59
trace and paint
_defined 271
track breakdown
_defined 271
tradigital
_defined 269
traditional animation
_defined 271
trajectory
_defined 271
transition
_defined 271
underlay
_defined 271
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vector
_defined 272
velocity
defined 264, 272
views 42
adding 42
closing 42
Colour 48
Drawing 54
hiding temporarily 43
managing 42
Message Log 56
Model 57
recentering 60
resetting 60
resizing 42
Tooll Properties 58
walk cycle
_defined 272
workspace
_defined 272
Xsheet view 19
_defined 272
zone
_defined 272
Zoom tool 61
zooming
in 60
in or out 60
out 60
resetting zoom 60
Zoom tool 61
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